DirectX 9.0 for Managed Code

Purpose

Microsoft DirectX 9.0 is your backstage pass to multimedia applications that sizzle.

Where Applicable

DirectX is a set of low-level application programming interfaces (APIs) for creating games and other high-performance multimedia applications. It includes support for high-performance 2-D and 3-D graphics, sound, and input.

Developer Audience

This documentation set is for developers using the Microsoft .NET Framework. Separate documentation is available for developers using the C/C++ programming language.

Run-Time Requirements

DirectX 9.0 can be used in the Microsoft Windows 98, Windows Millennium Edition (Windows Me), Windows 2000, and Windows XP environments.

See Also

GDI+ Leave Site

OpenGL Leave Site

Windows Image Acquisition Leave Site

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.


Legal Information

DirectX 9.0 Programmer's Reference

Portions of this document are preliminary and may be changed substantially prior to final commercial release. This document is provided for informational purposes only and Microsoft makes no warranties, either express or implied, in this document. Information in this document, including URL and other Internet Web site references, is subject to change without notice. The entire risk of the use or the results of the use of this document remains with the user. Unless otherwise noted, the example companies, organizations, products, domain names, e-mail addresses, logos, people, places and events depicted herein are fictitious, and no association with any real company, organization, product, domain name, e-mail address, logo, person, place or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 1995-2005 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows NT, Direct3D, DirectAnimation, DirectDraw, DirectInput, DirectMusic, DirectPlay, DirectShow, DirectSound, DirectX, Visual C++, Visual Studio, Win32, and XNA are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

BLUETOOTH is a trademark owned by Bluetooth SIG, Inc. and licensed to Microsoft Corporation.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.

Sample Code Usage Guidelines

To learn about the rights conferred to you for using, modifying, and redistributing the samples provided in the Microsoft DirectX software development kit (SDK), refer to the DirectX end-user license agreement (EULA), which is installed in the following folder:

(SDK root)\Documentation\License Agreements\

Note: Manufacturers of telecommunications devices implementing this application programming interface (API) must ensure compliance with section 255 of the telecommunications act of 1996.


Introducing DirectX 9.0 for Managed Code

Microsoft DirectX is a set of low-level application programming interfaces (APIs) for creating games and other high-performance multimedia applications. It includes support for high-performance 2-D and 3-D graphics, sound, and input.

DirectX 9.0 for Managed Code

With DirectX 9.0, developers can take advantage of DirectX multimedia functionality and hardware acceleration while using managed code. DirectX 9.0 for Managed Code enables access to most of the original unmanaged DirectX functionality. The following are the managed code languages supported by DirectX 9.0 and documented in the software development kit (SDK).

  • Microsoft Visual C#
  • Microsoft Visual Basic .NET
  • Microsoft Visual C++
  • Microsoft JScript .NET

Components

DirectX 9.0 for Managed Code is made up of the following major components.

  • Direct3D Graphics provides a single API that you can use for 3-D graphics programming.
  • DirectDraw provides direct low-level access to video memory for high-speed rendering. Deprecated.
  • DirectInput provides support for a variety of input devices, including full support for force-feedback technology.
  • DirectPlay provides support for multiplayer networked games. Deprecated.
  • DirectSound provides support for playing and capturing prerecorded digital samples.
  • Audio Video Playback allows for playback and simple control of audio and video media.

Benefits of DirectX 9.0 for Managed Code

By eliminating the Component Object Model (COM) interoperability layer, DirectX 9.0 for Managed Code improves performance. Managed code can reduce the volume of code and increase productivity. The interface is more intuitive, inheriting from the powerful and easy-to-use Microsoft .NET Framework common types. Managed code also frees you from having to deal with most memory management tasks, such as releasing objects. In the SDK you will find managed Visual C# samples and tutorials that duplicate many of the unmanaged code samples.

Requirements

The minimum required operating system that will support the managed DirectX 9.0 runtime is Microsoft Windows 98. However, the minimum operating system that will run the samples and tools in the DirectX 9.0 SDK is Windows 2000.

Related Topics

  • What Is Managed Code?


Tips and Tricks Using Managed Code

This topic discusses the basics of how to install and use Microsoft DirectX 9.0 for Managed Code and documentation. The following sections are included.

  • Getting Started with DirectX 9.0 for Managed Code
  • Using Sample Applications
  • Class Inheritance
  • Debugging DirectX Applications
  • Using Managed DirectX Documentation in Visual Studio .NET 2003
  • Using DirectX Help Documentation
  • DirectX Redistribution

Getting Started with DirectX 9.0 for Managed Code

Install the latest Microsoft .NET Framework runtime from How to Get the .NET Framework Leave Site. This installs the Framework on your local computer, which includes the .NET runtime. The .NET runtime is a set of dynamic-link libraries (DLLs) that managed code applications require. You can install the full software development kit (SDK), but only the runtime is required.

Download the DirectX 9.0 SDK from the DirectX Leave Site Web site, or from MSDN DirectX Downloads Leave Site. The SDK includes the set of DirectX DLLs that are required to run DirectX applications.

Note: Uninstall previous versions of DirectX before installing this release. Use the Add or Remove Programs Control Panel to remove an earlier version. Before they run, applications developed for managed code should confirm that DirectX 9.0 has been installed.

Using Sample Applications

Pre-tested code for sample applications can be found at:
(SDK root)\Samples\Managed\

The sample applications should be built with Microsoft Visual Studio .NET 2003.

For each DirectX technology you will find the following folder structure.

  • Individual sample folders: Contain a variety of applications specifically designed for managed code. Within each subfolder you will find a complete Visual Studio .NET 2003 project and solution that will quickly get you started.
  • Bin subfolder: Contains compiled applications that you can run by double-clicking.
  • Tutorials subfolder (Microsoft Direct3D only): Contains sample applications that will take you step-by-step through the procedures of creating a complete working application. The Direct3D C# tutorials are described in detail in Direct3D Tutorials.

Class Inheritance

DirectX 9.0 for Managed Code does not support class inheritance in applications. Inheriting from DirectX 9.0 for Managed Code classes is not recommended and the resulting behavior is undefined.

Although you may discover that certain inherited classes work with this version of DirectX 9.0 for Managed Code, such inheritance may not work in future versions.

Debugging DirectX Applications

From the Visual Studio .NET 2003 Integrated Development Environment (IDE):

  • Within the Solution Explorer pane, right-click your project (not the solution) and select Properties.
  • Click the Configuration Properties folder at the left, then click the Debugging selection.
  • Within the Debuggers options, set Enable Unmanaged Debugging to True. It is set to False by default.

Using Managed DirectX Documentation in Visual Studio .NET 2003

When the SDK has been loaded using the above procedure, documentation will be readable from within Visual Studio .NET 2003. From the Visual Studio Help menu, select Contents to open a table of contents, Index to search by alphabetical words, or Search to do a text search in the documentation, as shown in the following.

Visual Studio screen shot with help menu

From within managed code, you can also view detailed documentation and syntax by clicking anywhere on the name of a class, structure, member, property, or field and then pressing F1.

Using DirectX Help Documentation

Installing DirectX documentation from both the DirectX SDK and MSDN Library can result in duplicate topics in Visual Studio .NET 2003. If this occurs, take the following steps to uninstall the DirectX documentation from the SDK.

  1. In Control Panel, click the Add/Remove Programs icon.
  2. Highlight Microsoft DirectX 9.0 SDK and then click Change.
  3. When the InstallShield Wizard opens, click Next.
  4. Select Modify. Click Next.
  5. In the DirectX Documentation list, click This feature will not be available.
  6. Click Next and the documentation will be removed.

DirectX Redistribution

Stand-alone developer runtime installers install only the DirectX developer and debug runtime for redistribution purposes. These installers are located at:
(SDK root)\Developer Runtime\Managed DirectX\

DirectX 9.0 for Managed Code includes a full set of DLLs for redistribution. To install the full set, perform the following steps.

  1. Verify that the Framework is installed.
  2. Navigate to:
    (SDK root)\Redist\DirectX9\
  3. Call DXSetup.exe with the /InstallManagedDX command line attribute, as follows.
DXSetup.exe /InstallManagedDX


What's New in DirectX 9.0 for Managed Code, August 2005

This page describes new features of Microsoft DirectX 9.0 for Managed Code in the DirectX 9.0 SDK Update (August 2005).

New and Changed Features

  • Effects System: Use Effect.SetRawValue to set a contiguous range of shader constants with a memory copy.
  • TextureGutterHelper.ResampleTexture - Resamples a texture from one parameterization into another. This can be used in conjunction with the UVAtlas class to create a new, optimal texture atlas for a mesh and then resample the original texture into the new parameterization.
  • Sprite depth and texture sort - When submitting sprites for rendering, you may sort sprite drawing order by depth (SpriteFlags.SortDepthFrontToBack or SpriteFlags.SortDepthBackToFront) and then by texture (SpriteFlags.SortTexture). This is useful for rendering UI components as sprites.
  • Skipping the highest mip levels during texture loading - You can now choose to skip the highest mip level(s) when loading a texture from file. This can be useful for adapting applications to low-memory situations, and can be specified in the following texture creation member methods of the TextureLoader class: FromFile, FromStream, FromCubeFile, FromCubeStream, FromVolumeFile, FromVolumeStream.


What Is Managed Code?

Managed code is code written in one of over twenty high-level programming languages that are available for use with the Microsoft .NET Framework, including C#, J#, Microsoft Visual Basic .NET, Microsoft JScript .NET, and C++. All of these languages share a unified set of class libraries and can be encoded into an Intermediate Language (IL). A runtime-aware compiler compiles the IL into native executable code within a managed execution environment that ensures type safety, array bound and index checking, exception handling, and garbage collection.

By using managed code and compiling in this managed execution environment, you can avoid many typical programming mistakes that lead to security holes and unstable applications. Also, many unproductive programming tasks are automatically taken care of, such as type safety checking, memory management, and destruction of unneeded objects. You can therefore focus on the business logic of your applications and write them using fewer lines of code. The result is shorter development time and more secure and stable applications.

Related Topics

  • .NET Framework Technology Overview Leave Site


Direct3D Graphics

Microsoft Direct3D is a low-level graphics application programming interface (API) that enables you to manipulate visual models of 3-dimensional objects and take advantage of hardware acceleration, such as video graphics cards.

Roadmap

  • Getting Started with Direct3D

    Contains architectural descriptions, drawings of 3-D conventions, discussion of Direct3D devices and resources, and step-by-step tutorials. Code snippets are used throughout to clarify the usage of Direct3D components.

  • Microsoft.DirectX.Direct3D

    Contains the reference pages for the Direct3D namespace. This includes the syntax for methods, properties, and data structures. It includes an explanation of how the Direct3D component works, and often includes code snippets.

  • Microsoft.DirectX

    Contains the reference pages for the Microsoft DirectX utility namespace. This namespace provides utility operations and data storage for DirectX application programming, including exception handling, simple helper methods, and structures used for matrix, clipping plane, quaternion, and vector manipulation.

  • How Do I ...?

    Explains typical tasks you may encounter in developing DirectX applications, with short snippets of C# code.


Getting Started with Direct3D

This section provides a brief introduction to the three-dimensional (3-D) graphics functionality in the Microsoft Direct3D application programming interface (API), plus tutorials to help you quickly get applications up and running.

  • 3-D Coordinate Systems and Geometry
  • Devices
  • Resources
  • Transforms
  • Direct3D Rendering
  • Direct3D Surfaces
  • Direct3D Textures
  • Direct3D Tutorials
  • Direct3D Samples for Managed Code


3-D Coordinate Systems and Geometry

Programming Microsoft Direct3D applications requires a working familiarity with 3-D geometric principles. This section introduces the most important geometric concepts for creating 3-D scenes. The following topics provide high-level descriptions of the basic concepts employed by a Direct3D application.

  • 3-D Coordinate Systems
  • Face and Vertex Normal Vectors
  • 3-D Primitives
  • Rasterization Rules
  • Rectangles
  • Triangle Interpolation
  • Vectors, Vertices, and Quaternions


3-D Coordinate Systems

Typically, 3-D graphics applications use two types of Cartesian coordinate systems: left-handed and right-handed. In both coordinate systems, the positive x-axis points to the right, and the positive y-axis points up. You can remember which direction the positive z-axis points by pointing the fingers of either your left or right hand in the positive x direction and curling them into the positive y direction. The direction your thumb points, either toward or away from you, is the direction that the positive z-axis points for that coordinate system. The following illustration shows these two coordinate systems.

Left- and right-handed Cartesian coordinates

Microsoft Direct3D uses a left-handed coordinate system. If you are porting an application that is based on a right-handed coordinate system, you must make two changes to the data passed to Direct3D.

  • Flip the order of triangle vertices so that the system traverses them clockwise from the front. In other words, if the vertices are v0, v1, v2, pass them to Direct3D as v0, v2, v1.
  • Use the view matrix to scale world space by -1 in the z direction. To do this, flip the sign of the M31, M32, M33, and M34 fields of the Matrix structure that you use for your view matrix.

To obtain what amounts to a right-handed world, use the PerspectiveRH and PerspectiveLH methods to define the projection transform. However, be careful to use the corresponding LookAtRH function, reverse the backface-culling order, and lay out the cube maps accordingly.

Although left-handed and right-handed coordinates are the most common systems, there is a variety of other coordinate systems used in 3-D software. For example, it is not unusual for 3-D modeling applications to use a coordinate system in which the y-axis points toward or away from the viewer, and the z-axis points up. In this case, right-handedness is defined as any positive axis (x, y, or z) pointing toward the viewer. Left-handedness is defined as any positive axis (x, y, or z) pointing away from the viewer. If you are porting a left-handed modeling application where the z-axis points up, you must do a rotation on all the vertex data in addition to the previous steps.

The essential operations performed on objects defined in a 3-D coordinate system are translation, rotation, and scaling. You can combine these basic transformations to create a transform matrix.

When you combine these operations, the results are not commutative: the order in which you multiply matrices is important.


Face and Vertex Normal Vectors

Each face in a mesh has a perpendicular normal vector. The vector's direction is determined by the order in which the vertices are defined and by whether the coordinate system is right- or left-handed. The face normal points away from the front side of the face. In Microsoft Direct3D, only the front of a face is visible. A front face is one in which vertices are defined in clockwise order.

Front face of polygon with normal vector

Any face that is not a front face is a back face. Direct3D does not always render back faces; therefore, back faces are said to be culled. You can change the culling mode to render back faces if you want.

Direct3D uses the vertex normals for Gouraud shading, lighting, and texturing effects.

Vertex normals on a pyramid

When applying Gouraud shading to a polygon, Direct3D uses the vertex normals to calculate the angle between the light source and the surface. It calculates the color and intensity values for the vertices and interpolates them for every point across all the primitive's surfaces. Direct3D calculates the light intensity value by using the angle. The greater the angle, the less light is shining on the surface.

If you are creating an object that is flat, set the vertex normals to point perpendicular to the surface, as shown in the following illustration. A flat surface composed of two triangles is defined.

Vertex normals on a flat object

It is more likely, however, that your object is made up of triangle strips and the triangles are not coplanar. One simple way to achieve smooth shading across all the triangles in the strip is to first calculate the surface normal vector for each polygonal face with which the vertex is associated. The vertex normal can be set to make an equal angle with each surface normal. However, this method might not be efficient enough for complex primitives.

This method is illustrated by the following figure, which shows two surfaces, S1 and S2, seen edge-on from above. The normal vectors for S1 and S2 are shown in blue. The vertex normal vector is shown in red. The angle that the vertex normal vector makes with the surface normal of S1 is the same as the angle between the vertex normal and the surface normal of S2. When these two surfaces are lit and shaded with Gouraud shading, the result is a smoothly shaded, smoothly rounded edge between them.

Vertex normal for the edge of two intersecting surfaces

If the vertex normal leans toward one of the faces with which it is associated, it causes the light intensity to increase or decrease for points on that surface, depending on the angle it makes with the light source. An example is shown in the following figure. Again, these surfaces are seen edge-on. The vertex normal leans toward S1, causing it to have a smaller angle with the light source than if the vertex normal had equal angles with the surface normals.

Light source illuminating the edge of two intersecting surfaces

You can use Gouraud shading to display some objects in a 3-D scene with sharp edges. To do so, duplicate the vertex normal vectors at any intersection of faces where a sharp edge is required, as shown in the following illustration.

Vertex normals used to generate Gouraud shading on a sharp edge

If you use the Device Draw...Primitives methods to render your scene, define the object with sharp edges as a triangle list, rather than a triangle strip. When you define an object as a triangle strip, Direct3D treats it as a single polygon composed of multiple triangular faces. Gouraud shading is applied both across each face of the polygon and between adjacent faces. The result is an object that is smoothly shaded from face to face. Because a triangle list is a polygon composed of a series of disjoint triangular faces, Direct3D applies Gouraud shading across each face of the polygon. However, it is not applied from face to face. If two or more triangles of a triangle list are adjacent, they appear to have a sharp edge between them.

Another alternative is to change to flat shading when rendering objects with sharp edges. This is computationally the most efficient method, but it may result in objects in the scene that are not rendered as realistically as the objects that are Gouraud-shaded.


3-D Primitives

A 3-D primitive is a collection of vertices that form a single 3-D entity. The simplest primitive is a collection of points in a 3-D coordinate system, which is called a point list.

Often, 3-D primitives are polygons. A polygon is a closed 3-D figure delineated by at least three vertices. The simplest polygon is a triangle. Microsoft Direct3D uses triangles to compose most of its polygons because all three vertices in a triangle are guaranteed to be coplanar. Rendering nonplanar vertices is inefficient. You can combine triangles to form large, complex polygons and meshes.

The following illustration shows a cube. Two triangles form each face of the cube. The entire set of triangles forms one cubic primitive. You can apply textures and materials to the surfaces of primitives to make them appear to be a single solid form. For details, see Direct3D Textures.

Cube created from triangles

You can also use triangles to create primitives whose surfaces appear to be smooth curves. The following illustration shows how a sphere can be simulated with triangles. After a material is applied, the sphere looks curved when it is rendered. This is especially true if you use Gouraud shading. For details, see Gouraud Shading.

Sphere approximated with triangular faces


Rasterization Rules

Often, the points specified for vertices do not precisely match the pixels on the screen. When this happens, Microsoft Direct3D applies triangle rasterization rules to decide which pixels apply to a given triangle.

  • Triangle Rasterization Rules
  • Point and Line Rules
  • Point Sprite Rules

Triangle Rasterization Rules

Direct3D uses a top-left filling convention for filling geometry. This is the same convention that is used for rectangles in Microsoft Windows Graphics Device Interface (GDI) and OpenGL. In Direct3D, the center of the pixel is the decisive point. If the center is inside a triangle, the pixel is part of the triangle. Pixel centers are at integer coordinates.

This description of triangle-rasterization rules used by Direct3D does not necessarily apply to all available hardware. Your testing may uncover minor variations in the implementation of these rules.

The following illustration shows a rectangle whose upper-left corner is at (0, 0) and whose lower-right corner is at (5, 5). This rectangle fills 25 pixels, just as you would expect. The width of the rectangle is defined as right minus left. The height is defined as bottom minus top.

Numbered square divided into 6 rows and columns

In the top-left filling convention, top refers to the vertical location of horizontal spans, and left refers to the horizontal location of pixels within a span. An edge cannot be a top edge unless it is horizontal. In general, most triangles have only left and right edges.

Numbered square containing two triangles

The top-left filling convention determines the action taken by Direct3D when a triangle passes through the center of a pixel. The following illustration shows two triangles, one at (0, 0), (5, 0), and (5, 5), and the other at (0, 5), (0, 0), and (5, 5). The first triangle in this case gets 15 pixels (shown in black), whereas the second gets only 10 pixels (shown in gray) because the shared edge is the left edge of the first triangle.

Numbered square containing diagonal line

If you define a rectangle with its upper-left corner at (0.5, 0.5) and its lower-right corner at (2.5, 4.5), the center point of this rectangle is at (1.5, 2.5). When the Direct3Drasterizertessellates this rectangle, the center of each pixel is unambiguously inside each of the four triangles, and the top-left filling convention is not needed. The following illustration shows this. The pixels in the rectangle are labeled according to the triangle in which Direct3D includes them.

Rectangle divided into four triangles

If you move the rectangle in the previous example so that its upper-left corner is at (1.0, 1.0), its lower-right corner at (3.0, 5.0), and its center point at (2.0, 3.0), Direct3D applies the top-left filling convention. Most pixels in this rectangle straddle the border between two or more triangles, as the next illustration shows.

Rectangle divided into four triangles shifted one-half pixel right and down

For both rectangles, the same pixels are affected.

Direct3D top-left filling of a rectangle divided into four triangles

Point and Line Rules

Points are rendered the same as point sprites, which are both rendered as screen-aligned quadrilaterals and thus adhere to the same rules as polygon rendering.

Non-antialiased line rendering rules are exactly the same as those for GDI.

For information about antialiased line rendering, see Line.

Point Sprite Rules

Point sprites and patch primitives are rasterized as if the primitives were first tessellated into triangles and the resulting triangles rasterized.


Rectangles

Throughout Microsoft Direct3D and Microsoft Windows programming, objects on the screen are referred to in terms of bounding rectangles. The sides of a bounding rectangle are always parallel to the sides of the screen. Managed code applications should use the Rectangle Leave Site structure, in the System.Drawing Leave Site namespace, for storing rectangle information and when blitting to the screen or performing collision detection.

Most unmanaged C++ applications use the RECT Leave Site structure, which requires the (x,y) coordinates of the rectangle's upper-left and lower-right corners. A managed code application typically supplies Rectangle Leave Site properties that indicate the (x,y) coordinates of the rectangle's upper-left corner, and its height and width, as shown in the following diagram.

Bounding rectangle within a display screen

In the interest of efficiency, consistency, and ease of use, all Direct3D presentation functions work with rectangles.


Triangle Interpolation

During rendering, the pipeline interpolates vertex data across each triangle. Several types of data can be interpolated.

  • Diffuse color
  • Specular color
  • Diffuse alpha (triangle opacity)
  • Specular alpha
  • Fog factor (taken from specular alpha for fixed function vertex pipeline and from fog register for programmable vertex pipeline)
  • Texture coordinates

The interpolation of the vertex data is dependent on the current shading mode, as shown in the following table.

Shading mode | Description
Flat | Only the fog factor is interpolated in flat shade mode. For all other interpolated values, the color of the first vertex in the triangle is applied across the entire face.
Gouraud | Linear interpolation is performed between all three vertices.

The color and specular interpolated values are treated differently, depending on the color model. In the RGB color model, the system uses the red, green, and blue color components in the interpolation.

The alpha component of a color is treated as a separate interpolated value because device drivers can implement transparency in two different ways: by using texture blending or by using stippling.

Use the ShadeCaps property of the Caps structure to determine what forms of interpolation the current device driver supports.


Vectors, Vertices, and Quaternions

Throughout Microsoft Direct3D, vertices describe position and orientation. Each vertex in a primitive is described by a vector that gives its position, color, texture coordinates, and a normal vector that gives its orientation.

Quaternions add a fourth element to the [x,y,z] values that define a three-component vector. Quaternions are an alternative to the matrix methods that are typically used for 3-D rotations. A quaternion represents an axis in 3-D space and a rotation around that axis. For example, a quaternion might represent a (1,1,2) axis and a rotation of 1 radian. Quaternions carry valuable information, but their true power comes from the two operations that you can perform on them: composition and interpolation.

Performing composition on quaternions is similar to combining them. The composition of two quaternions is notated as follows:

Quaternion composition equation

The composition of two quaternions applied to a geometry means "rotate the geometry around axis2 by rotation2, then rotate it around axis1 by rotation1." In this case, Q represents a rotation around a single axis that is the result of applying q2, then q1 to the geometry.

Using quaternion interpolation, an application can calculate a smooth and reasonable path from one axis and orientation to another. Therefore, interpolation between q1 and q2 provides a simple way to animate from one orientation to another.

When you use composition and interpolation together, they provide you with a simple way to manipulate a geometry in a manner that appears complex. For example, imagine that you have a geometry that you want to rotate to a given orientation. You know that you want to rotate it r2 degrees around axis2, then rotate it r1 degrees around axis1, but you don't know the final quaternion. By using composition, you could combine the two rotations on the geometry to get a single quaternion that is the result. Then, you could interpolate from the original to the composed quaternion to achieve a smooth transition from one to the other.

The Microsoft.DirectX namespace includes the Quaternion structure that helps you work with quaternions. For example, the RotateAxis method applies a rotation value to a vector that defines an axis of rotation, and updates the fields and properties of the original quaternion structure. Additionally, the Multiply method performs a composition of quaternions, and the Slerp method performs spherical linear interpolation between two quaternions.

Direct3D applications can also use the methods of the Microsoft.DirectX.Vector2, Vector3, and Vector4 structures to simplify the task of working with two-, three-, and four-component vectors, respectively.


Devices

A Microsoft Direct3D device is the rendering component of Direct3D. It encapsulates and stores the rendering state. In addition, a Direct3D device performs transformations and lighting operations and rasterizes an image to a surface. The following topics provide further details on using devices.

  • Device Types
  • Creating a Device
  • Selecting a Device
  • Lost Devices
  • Determining Hardware Support
  • Processing Vertex Data
  • Device-Supported Primitive Types

Architecturally, Direct3D devices contain a transformation module, a lighting module, and a rasterizing module, as the following illustration shows.

Direct3D device architecture

Microsoft DirectX currently supports two main types of Direct3D devices: a hardware device with hardware-accelerated rasterization and shading with both hardware and software vertex processing; and a reference device.

You can think of these devices as two separate drivers. Software and reference devices are represented by software drivers, and the hardware device is represented by a hardware driver. The most common way to take advantage of these devices is to use the hardware device for shipping applications, and the reference device for feature testing. These are provided by third parties to emulate particular devices, for example, developmental hardware that has not yet been released.

The Direct3D device that an application creates must correspond to the capabilities of the hardware on which the application is running. Direct3D provides rendering capabilities, either by accessing 3-D hardware that is installed in the computer or by emulating the capabilities of 3-D hardware in software. Therefore, Direct3D provides devices for both hardware access and software emulation.

Hardware-accelerated devices give much better performance than software devices. The hardware device type is available on all Direct3D supported graphic adapters. In most cases, applications target computers that have hardware acceleration and rely on software emulation to accommodate lower-end computers.

With the exception of the reference device, software devices do not always support the same features as a hardware device. Applications should always query for device capabilities to determine which features are supported.

Because the behavior of the software and reference devices provided with DirectX 9.0 is identical to that of the hardware device, application code authored to work with the hardware device will work with the software or reference devices without modifications. Note that while the provided software or reference device behavior is identical to that of the hardware device, the device capabilities do vary, and a particular software device may implement a much smaller set of capabilities.

Behaviors

Direct3D enables you to specify the behavior of a device, as well the device type. The Device(Int32,DeviceType,IntPtr,CreateFlags,PresentParameters[]) method enables a combination of one or more of the CreateFlags behavior flags to control the global behaviors of the Direct3D device. These behaviors specify what is and is not maintained in the run-time portion of Direct3D, and the device types specify which driver to use. Although some combinations of device behaviors are not valid, it is possible to use all device behaviors with all device types. For example, it is valid to specify DeviceType.Software, which indicates a pluggable software device, with the device creation flag CreateFlags.PureDevice, which specifies that the device does not support vertex processing.


Device Types

Hardware Device

The primary device type is the hardware device, which supports hardware-accelerated rasterization and both hardware and software vertex processing. If the computer on which your application is running is equipped with a display adapter that supports Microsoft Direct3D, your application should use it for 3-D operations. Direct3D hardware devices implement all or part of the transformation, lighting, and rasterizing modules in hardware.

Applications do not access 3-D cards directly. They call Direct3D functions and methods. Direct3D accesses the hardware through a hardware abstraction layer. If the computer running your application supports the abstraction layer, it will gain the best performance by using a hardware device.

To specify hardware rasterization and shading, create a Device object using the DeviceType.Hardware constant.

Note: Hardware devices cannot render to 8-bit render target surfaces.

Reference Device

Direct3D supports an additional device type called a reference device or reference rasterizer. Unlike a software device, the reference rasterizer supports every Direct3D feature. Because these features are implemented for accuracy, rather than speed, and are implemented in software, the results are not very fast. The reference rasterizer does make use of special CPU instructions whenever it can, but it is not intended for retail applications. Use the reference rasterizer only for feature testing or demonstration purposes.

To create a reference device, create a Device object using the DeviceType.Reference constant.


Creating a Device
Note: All rendering devices created by a given Microsoft Direct3D object share the same physical resources. Although your application can create multiple rendering devices from a single Direct3D object, because they share the same hardware, extreme performance penalties will be incurred.

To create a Direct3D device, your managed code application should first create a PresentParameters object that contains the presentation parameters for the device. The following C# code example contains a simple initialization using the Device(Int32,DeviceType,Control,CreateFlags,PresentParameters[]) constructor that receives a PresentParameters object.

          [C#]

using Microsoft.DirectX.Direct3D;
.
.
.
// Global variables for this project
Device device = null;              // Create rendering device
PresentParameters presentParams = new PresentParameters();

device = new Device(0, DeviceType.Hardware, this,
                    CreateFlags.SoftwareVertexProcessing, presentParams);

This call also specifies the default adapter, a hardware device, and software vertex processing.

Note that a call to create, dispose, or reset the device should happen only on the same thread as the window procedure of the focus window. After creating the device, set its state.

Related Topics

  • Tutorial 1: Creating a Device


Selecting a Device

Applications can query hardware to detect the supported Microsoft Direct3D device types. This section contains information on the primary tasks involved in enumerating display adapters and selecting Direct3D devices.

An application must perform a series of tasks to select an appropriate Direct3D device. Note that the following steps are intended for a full-screen application. In most cases, a windowed application can skip most of these steps.

  1. Initially, the application must enumerate the display adapters on the system. An adapter is a physical piece of hardware. Note that the graphics card might contain more than a single adapter, as is the case with a dual-head display. For a detailed example of enumerating adapters, see (SDK root)\Samples\Managed\Common\dxmutenum.cs. Applications that are not concerned with multiple-monitor support can disregard this step and use the default adapter enumeration.
  2. For each adapter, the application enumerates the supported display modes with the Adapters property of the Manager object. The collection of adapters can be queried with the AdapterListCollection object.
  3. If required, the application checks for the presence of hardware acceleration in each enumerated display mode by checking the return value of the checkType parameter of Manager.CheckDeviceType. Other parameters of CheckDeviceType can provide additional information on the current display and back buffer formats of the device.
  4. The application checks for the desired level of functionality for the device on this adapter using the Device.DeviceCaps property. This property returns a Caps structure that describes the capabilities of the device. Those devices that do not support the required functionality will not contain a valid structure. The device capability returned by DeviceCaps is guaranteed to be constant for a device across all display modes verified by CheckDeviceType.
  5. Devices can always render to surfaces of the format of an enumerated display mode that is supported by the device. If the application is required to render to a surface of a different format, it can call CheckDeviceType. If the device can render to the format, then it is guaranteed that all capabilities returned by DeviceCaps are applicable.
  6. Lastly, the application can determine if multisampling techniques, such as full-scene antialiasing, are supported for a render format by using the CheckDeviceMultiSampleType method.

After completing the above steps, the application should have a list of display modes in which it can operate. The final step is to verify that enough device-accessible memory is available to accommodate the required number of buffers and antialiasing. This test is necessary because the memory consumption for the mode and multisample combination is impossible to predict without verifying it. Moreover, some display adapter architectures might not have a constant amount of device-accessible memory. This means that an application should be able to report out-of-video-memory failures when going into full-screen mode. Typically, an application should remove full-screen mode from the list of modes it offers to a user, or it should attempt to consume less memory by reducing the number of back buffers or using a simpler multisampling technique.

A windowed application performs a similar set of tasks, as follows.

  1. It determines the desktop rectangle covered by the client area of the window.
  2. It enumerates adapters, looking for the adapter for which the monitor covers the client area. If the client area is owned by more than one adapter, then the application can choose to drive each adapter independently, or to drive a single adapter and have Direct3D transfer pixels from one device to another at presentation. The application can also disregard the above two steps and use the default adapter, although this might result in slower operation when the window is placed on a secondary monitor. The default adapter is the first ordinal identified by the DeviceCreationParameters.AdapterOrdinal. The adapter ordinal value can be queried with the GetDeviceCaps method or returned by the AdapterInformation.Adapter property.
  3. The application should call CheckDeviceType to determine if the device can support rendering to a back buffer of the specified format while in desktop mode. The AdapterInformation.CurrentDisplayMode property can be used to determine the desktop display format.


Lost Devices

A Microsoft Direct3D device can be in either an operational state or a lost state. The operational state is the normal state of the device, in which the device runs and presents all rendering as expected. The device makes a transition to the lost state when an event, such as the loss of keyboard focus in a full-screen application, causes rendering to become impossible. The lost state is characterized by the silent failure of all rendering operations, which means that the rendering methods can return success codes even though the rendering operations fail. In this situation, the Device.DeviceLost event is triggered.

By design, the full set of scenarios that can cause a device to become lost is not specified. A typical example is a loss of focus, such as when the user presses ALT+TAB or a system dialog is initialized. Devices can also be lost due to a power management event, or when another application assumes full-screen operation. In addition, any failure from Device.Reset puts the device into a lost state.

The following two exception objects may be handled:

  • DeviceLostException: This object indicates that the device has been lost but cannot be reset, so rendering is not possible.
  • DeviceNotResetException: This object indicates that the device has been lost but can be reset at this time.

Responding to a Lost Device

A lost device must re-create resources (including video memory resources) after it has been reset. If a device is lost, the application queries the device to see if it can be restored to the operational state. If not, the application waits until the device can be restored.

If the device can be restored, the application prepares the device by destroying all video-memory resources and any swap chains. Then, the application calls the Reset method. Reset is the only method that has an effect when a device is lost, and is the only method by which an application can change the device from a lost to an operational state. The method will fail unless the application releases all resources that are allocated in Default, including those created by the CreateRenderTarget and CreateDepthStencilSurface methods.

For the most part, the high-frequency calls of Direct3D do not return any information about whether the device has been lost. The application can continue to call rendering methods, such as Device.DrawPrimitives, without receiving notification of a lost device. Internally, these operations are discarded until the device is reset to the operational state.

The application can determine whether a device is lost by querying the return value of the CheckCooperativeLevel method.

Locking Operations

Internally, Direct3D does enough work to ensure that a lock operation will succeed after a device is lost. However, it is not guaranteed that the data of the video-memory resource will be accurate during the lock operation. It is guaranteed that no error code will be returned. This allows applications to be written without concern for device loss during a lock operation.

Resources

Resources can consume video memory. Because a lost device is disconnected from the video memory owned by the adapter, it is not possible to guarantee allocation of video memory when the device is lost. As a result, all resource creation methods allocate only dummy system memory. Because any video-memory resource must be destroyed before the device is resized, there is no issue of over-allocating video memory. These dummy surfaces allow lock and copy operations to appear to function normally until the application calls Device.Present and discovers that the device has been lost.

All video memory must be released before a device can be reset from a lost state to an operational state. This means that the application should release any swap chains created with SwapChain and any resources placed in Pool.Default memory. The application need not release resources in Managed or SystemMemory memory. Other state data is automatically destroyed by the transition to an operational state.

You are encouraged to develop applications with a single code path to respond to device loss. This code path is likely to be similar, if not identical, to the code path taken to initialize the device at startup.

Retrieved Data

Direct3D allows applications to validate texture and render states against single-pass rendering by the hardware using ValidateDevice. This method, which is typically invoked during initialization of the application, will return a DeviceLostException object if the device has been lost.

Direct3D also allows applications to copy generated or previously written images from video-memory resources to nonvolatile system-memory resources. Because the source images of such transfers might be lost at any time, Direct3D allows such copy operations to fail when the device is lost.

Copy operations, using UpdateSurface and GetFrontBufferData, can return a DeviceLostException object when the source object is in volatile memory (Pool.Default) and the destination object is in nonvolatile memory (SystemMemory or Managed). A GetFrontBufferData call can fail due to retrieving data from the primary surface. Note that these cases are the only instance of DeviceLostException that will be returned outside of the Present, TestCooperativeLevel, and Reset methods.

Programmable Shaders

In Microsoft DirectX 9.0, Vertex Shader 1_1 Leave Site and Pixel Shader 1_X Leave Site do not need to be re-created after Device.Reset is called. They will be remembered. In previous versions of DirectX, when a device was lost, shaders had to be re-created.


Determining Hardware Support

Microsoft Direct3D provides the following methods to determine hardware support.

  • CheckDeviceFormat

    Used to verify whether a surface format can be used as a texture, whether a surface format can be used as a texture and a render target, or whether a surface format can be used as a depth stencil buffer. In addition, this method is used to verify depth buffer format support and depth stencil buffer format support.

  • CheckDeviceType

    Used to verify a device's ability to perform hardware acceleration, a device's ability to build a swap chain for presentation, or a device's ability to render to the current display format.

  • CheckDepthStencilMatch

    Used to verify whether a depth stencil buffer format is compatible with a render-target format. Note that before calling this method, the application should call CheckDeviceFormat on both the depth stencil and render target formats.


Processing Vertex Data

The Device class supports vertex processing in both software and hardware. In general, the device capabilities for software and hardware vertex processing are not identical. Hardware capabilities are variable, depending on the display adapter and driver, while software capabilities are fixed.

The following constants of the CreateFlags enumeration control vertex processing behavior for the hardware and reference devices.

  • SoftwareVertexProcessing
  • HardwareVertexProcessing
  • MixedVertexProcessing

The BehaviorFlags structure can also be used to control behavior using properties that access these same constant values.

Specify one of these flags when calling the Device constructor. The MixedVertexProcessing mixed-mode flag enables the device to perform both software and hardware vertex processing. Only one of these three vertex processing flags may be set for a device at any one time; they are mutually exclusive. Note that the HardwareVertexProcessing flag is required to be set when creating a pure device (PureDevice).

To avoid dual vertex processing capabilities on a single device, only the hardware vertex processing capabilities can be queried at run time. Software vertex processing capabilities are fixed and cannot be queried at run time.

You can consult the properties of the VertexProcessingCaps structure to determine the hardware vertex processing capabilities of the device. For software vertex processing the following VertexProcessingCaps capabilities are supported (which are all but two of the available capabilities).

  • SupportsDirectionalLights
  • SupportsLocalViewer
  • SupportsMaterialSource
  • SupportsPositionalLights
  • SupportsTextureGeneration
  • SupportsTweening

In addition, the following table lists the values that are set for device capabilities (Caps) for the software vertex processing mode.

Member | Software vertex processing capabilities
MaxActiveLights | Unlimited
MaxUserClipPlanes | 6
MaxVertexBlendMatrices | 4
MaxStreams | 16
MaxVertexIndex | int(0xffffffff)

Software vertex processing provides a guaranteed set of vertex processing capabilities, including an unbounded number of lights and full support for programmable vertex shaders. You can toggle between software and hardware vertex processing at any time when using the hardware device, the only device type that supports both hardware and software vertex processing. The only requirement is that vertex buffers used for software vertex processing must be allocated in system memory, typically with the SystemMemory constant of the Pool enumeration.

Note: The performance of hardware vertex processing is comparable to that of software vertex processing. For this reason, it is a good idea to provide, within a single device type, both hardware- and software-emulation functionality for vertex processing. This is not the case for rasterization, for which host processors are much slower than specialized graphics hardware. Thus both hardware- and software-emulated rasterization are not provided within a single device type. Software vertex processing is the only instance of functionality duplicated between the run time and the hardware (driver) within a single device. All other device capabilities represent potentially variable functionality provided by the driver.


Device-Supported Primitive Types

Microsoft Direct3Ddevices can create and manipulate the following types of primitives.

  • Point Lists
  • Line Lists
  • Line Strips
  • Triangle Lists
  • Triangle Strips
  • Triangle Fans

You can render primitive types from a managed code application with any of the Device rendering methods.


Point Lists

A point list is a collection of vertices that are rendered as isolated points. Your application can use them in 3-D scenes for star fields, or dotted lines on the surface of a polygon.

The following illustration depicts a rendered point list.

Rendered point list

Your application can apply materials and textures to a point list. The colors in the material or texture appear only at the points drawn, and not anywhere between the points.


Line Lists

A line list is a list of isolated, straight line segments. Line lists are useful for such tasks as adding sleet or heavy rain to a 3-D scene. Applications create a line list by filling an array of vertices, and the number of vertices in a line list must be an even number greater than or equal to two.

The following illustration shows a rendered line list.

Rendered line list

You can apply materials and textures to a line list. The colors in the material or texture appear only along the lines drawn, not at any point in between the lines.


Line Strips

A line strip is a primitive that is composed of connected line segments. Your application can use line strips for creating polygons that are not closed. A closed polygon is a polygon whose last vertex is connected to its first vertex by a line segment. If your application makes polygons based on line strips, the vertices are not guaranteed to be coplanar.

The following illustration depicts a rendered line strip.

Rendered line strip


Triangle Lists

A triangle list is a list of isolated triangles. They might or might not be near each other. A triangle list must have at least three vertices. The total number of vertices must be divisible by three.

Use triangle lists to create an object that is composed of disjoint pieces. For instance, one way to create a force-field wall in a 3-D game is to specify a large list of small, unconnected triangles. Then apply a material and texture that appears to emit light to the triangle list. Each triangle in the wall appears to glow. The scene behind the wall becomes partially visible through the gaps between the triangles, as a player might expect when looking at a force field.

Triangle lists are also useful for creating primitives that have sharp edges and are shaded with Gouraud shading. See Face and Vertex Normal Vectors.

The following illustration depicts a rendered triangle list.

Rendered triangle list


Triangle Strips

A triangle strip is a series of connected triangles. Because the triangles are connected, the application does not need to repeatedly specify all three vertices for each triangle. For example, you need only seven vertices to define the following triangle strip.

The system uses vertices v1, v2, and v3 to draw the first triangle, v2, v4, and v3 to draw the second triangle, v3, v4, and v5 to draw the third, v4, v6, and v5 to draw the fourth, and so on. Notice that the vertices of the second and fourth triangles are out of order; this is required to make sure that all the triangles are drawn in a clockwise orientation.

Most objects in 3-D scenes are composed of triangle strips. This is because triangle strips can be used to specify complex objects in a way that makes efficient use of memory and processing time.

The following illustration depicts a rendered triangle strip.

Rendered triangle strip


Triangle Fans

A triangle fan is similar to a triangle strip, except that all the triangles share one vertex. This is shown in the following illustration.

The system uses vertices v2, v3, and v1 to draw the first triangle, v3, v4, and v1 to draw the second triangle, v4, v5, and v1 to draw the third triangle, and so on. When flat shading is enabled, the system shades the triangle with the color from its first vertex.

The following illustration depicts a rendered triangle fan.

Rendered triangle fan


Resources

Resources are the textures and buffers that are used to render a scene. Applications need to create, load, copy, and use resources. This section gives a brief introduction to resources and the steps and methods used by applications when working with resources.

All resources, including the geometry resources IndexBuffer and VertexBuffer, inherit from the Resource class. The texture resources, Texture, CubeTexture, and Volume, also inherit from the BaseTexture class.

Additional information is divided into the following topics.

  • Resource Properties
  • Manipulating Resources
  • Locking Resources
  • Managing Resources
  • Application-Managed Resources and Allocation Strategies


Resource Properties

All resources share the following properties, which are specified in enumerations by the same or similar name.

Property | Enumeration | Description
Usage | Usage | The way a resource is used, for example, as a texture or a render target.
Format | Format | The format of the data, for example, the pixel format of a 2-D surface.
Pool | Pool | The type of memory where the resource is allocated.
Type | ResourceType | The type of resource, for example, a vertex buffer or render target.

Resource uses are enforced. An application that will use a resource in a certain operation must specify that operation at resource-creation time.

The RTPatches, NPatches, and Points constants of the Usage enumeration indicate to the driver that the data in these buffers is likely to be used for triangular or grid patches, N-patches, or point sprites, respectively. These flags are provided in case the hardware cannot perform these operations without host processing. Therefore, the driver should typically allocate these surfaces in system memory so that the CPU can access them. If the driver can perform these operations entirely in hardware, it can allocate these surfaces in video or accelerated graphics port (AGP) memory to avoid a host copy and improve performance at least twofold. Note that the information provided by these flags is not absolutely required. A driver can detect that such operations are being performed on the data, and it will move the buffer back to system memory for subsequent frames.

A pool cannot be mixed for different objects contained in a single resource, that is, mip levels in a mipmap, and when a pool is chosen for a resource, the pool cannot be changed.

The resource types are set implicitly at run time when the application calls a resource constructor such as CubeTexture. Applications can query these types at run time; however, it is expected that most scenarios will not require run-time type checking.


Manipulating Resources

Your application manipulates resources in order to render a scene. First, the application creates texture resources by initializing CubeTexture, Texture, or VolumeTexture objects. Note that these texture classes all inherit from the BaseTexture base class.

The texture objects returned are containers for surfaces or volumes; these containers are generically known as buffers. The buffers owned by the resource inherit the usages, format, and pool of the resource but have their own type. For more information, see Resource Properties.

The application gains access to the contained surfaces, for the purpose of loading artwork, by calling the CubeTexture.LockRectangle, Texture.LockRectangle, or VolumeTexture.LockBox methods. For details, see Locking Resources. The lock methods take arguments denoting the contained surface and return pointers to the pixels. Examples of such arguments are the mipmap sub-level or cube face of the texture. The typical application never uses a surface object directly.

In addition, the application creates geometry-oriented resources when it initializes IndexBuffer or VertexBuffer objects. Your application locks and fills the buffer resources by calling the IndexBuffer.Lock or VertexBuffer.Lock methods.

If your application is allowing the Microsoft Direct3D run time to manage these resources, then the resource creation process ends here. Otherwise, the application manages the promotion of system memory resources to device-accessible resources, where the hardware accelerator can use them, by calling the UpdateTexture method.

To present images rendered from resources, the application also needs color and depth stencil buffers. For typical applications, the color buffer is owned by the device's swap chain, which is a collection of back buffer surfaces and is implicitly created with the device. Depth stencil surfaces can be implicitly created, or explicitly created by using the CreateDepthStencilSurface method. The application associates a device and its depth and color buffer with a call to SetRenderTarget.


Locking Resources

Locking a resource means granting CPU access to its storage. The locking procedure is defined by the constants of the LockFlags enumeration. However, these locking flags are only hints, and the run time does not check that applications are following the functionality specified by these flags.

An application that specifies LockFlags.ReadOnly but then writes to the resource should expect undefined results. In general, working against locking flags, including the locking usage flags, is not guaranteed to work in later releases and may incur a significant performance penalty.

A lock operation is followed by an unlock operation. For example, after locking a texture, the application subsequently relinquishes direct access to locked textures by unlocking them. In addition to granting processor access, any other operations involving that resource are serialized for the duration of a lock. Only a single lock for a resource is allowed, even for non-overlapping regions, and no accelerator operations on a surface can be ongoing while a lock operation is outstanding on that surface.

Each resource class has methods for locking the contained buffers. Each texture resource can also lock a sub-portion of that resource. Two-dimensional resources (surfaces) allow the locking of sub-rectangles, and volume resources allow the locking of sub-volumes or boxes. Each lock method returns a System.Array Leave Site that contains values representing the distances between rows or planes of data, depending on the resource type. The returned array always begins with the top-left byte in the locked sub-regions.

When working with index and vertex buffers, you can make multiple lock calls; however, you must ensure that the number of lock calls matches the number of unlock calls.

The Microsoft DirectX Transform set of compressed texture formats, which store pixels in encoded 4x4 blocks, can only be locked on 4x4 boundaries.


Managing Resources

Resource management is the process in which resources are promoted from system-memory storage to device-accessible storage and discarded from device-accessible storage. The Microsoft Direct3D run time has its own management algorithm based on a least-recently-used priority technique. Direct3D switches to a most-recently-used priority technique when it detects that more resources than can coexist in device-accessible memory are used in a single frame, between Device.BeginScene and EndScene calls.

Use the Managed constant of the Pool enumeration at creation time to specify a managed resource. Managed resources persist through transitions between the lost and operational states of the device. The device can be restored with a call to Reset, and such resources continue to function normally without being reloaded with artwork. However, if the device must be destroyed and re-created, all resources created using Managed must be re-created.

Use the Default flag at creation time to specify that a resource is to be placed in the default pool. Resources in the default pool do not persist through transitions between the lost and operational states of the device. These resources must be released before calling Reset and must then be re-created.

For more information on the lost state of a device, see Lost Devices.

Note that resource management is not supported for all types and usages. For example, objects created with the RenderTarget flag are not supported. In addition, resource management is not recommended for objects whose contents are changing with high frequency. For example, a managed vertex buffer that changes every frame can significantly degrade performance for some hardware. However, this is not a problem for texture resources.


Application-Managed Resources and Allocation Strategies

Dynamic vertex buffers are intended for rendering dynamic geometry and data pulled in from binary space partitioned (BSP) trees or other visibility data structures. This type of rendering can be accomplished by pre-allocating buffers of the desired format with the Dynamic constant of the Usage enumeration. These resources are then parceled out to support application needs by a resource manager within the application.

Because there are only a few different vertex strides that an application will use simultaneously, and a different vertex buffer is required only for each unique stride, the total number of dynamic vertex buffers is small. When managing dynamic resources in this way, it is important to ensure that high-frequency demands on the resources do not significantly decrease application performance.

Managed vertex-buffer or index-buffer resources cannot be declared dynamic by setting Dynamic at creation time. This would require an additional copy for every modification to the vertex buffer contents.

When using resources managed by both Microsoft Direct3D and applications, allocate application-managed resources in Pool.Default memory prior to creating Direct3D-managed resources. This enables the memory manager to maintain an accurate count of available memory.


Transforms

Transformations are used to convert object geometry from one coordinate space to another. The most common transformations are done using matrices. A matrix is an essential tool for holding the transformation values and applying them to the data. The topics below introduce matrices, and explain how to use them to generate the world, view, and projection transformations.

  • View Transformation
  • World Transformation
  • Matrices
  • Projection Transformation


View Transformation

This section introduces the basic concepts of the view transformation and provides details on how to set up a view transformation matrix in a Microsoft Direct3D application. The information is organized into the following sections.

  • What Is a View Transformation?
  • Setting Up a View Matrix

What Is a View Transformation?

The view transformation locates the viewer in world space, transforming vertices into camera space. In camera space, the camera, or viewer, is at the origin, looking in the positive z-direction. Recall that Direct3D uses a left-handed coordinate system, so z is positive into a scene. The view matrix relocates the objects in the world around a camera's position—the origin of camera space—and orientation.

There are many ways to create a view matrix. In all cases, the camera has some logical position and orientation in world space that is used as a starting point to create a view matrix that will be applied to the models in a scene. The view matrix translates and rotates objects to place them in camera space, where the camera is at the origin. One way to create a view matrix is to combine a translation matrix with rotation matrices for each axis. In this approach, the following general matrix formula applies.

In this formula, V is the view matrix being created, T is a translation matrix that repositions objects in the world, and Rx through Rz are rotation matrices that rotate objects along the x-, y-, and z-axis. The translation and rotation matrices are based on the camera's logical position and orientation in world space. So, if the camera's logical position in the world is <10,20,100>, the aim of the translation matrix is to move objects -10 units along the x-axis, -20 units along the y-axis, and -100 units along the z-axis. The rotation matrices in the formula are based on the camera's orientation, in terms of how much the axes of camera space are rotated out of alignment with world space. For example, if the camera mentioned earlier is pointing straight down, its z-axis is 90 degrees (pi/2 radians) out of alignment with the z-axis of world space, as shown in the following illustration.

The rotation matrices apply rotations of equal, but opposite, magnitude to the models in the scene. The view matrix for this camera includes a rotation of -90 degrees around the x-axis. The rotation matrix is combined with the translation matrix to create a view matrix that adjusts the position and orientation of the objects in the scene so that their top is facing the camera, giving the appearance that the camera is above the model.

Setting Up a View Matrix

The Matrix.LookAtLH and Matrix.LookAtRH helper functions create a view matrix based on the camera location and a look-at point.

The following C# code example creates a view matrix for left-handed coordinates.

          [C#]

Vector3 eye = new Vector3(0,3,-5);
Vector3 at = new Vector3(0,0,0);
Vector3 up = new Vector3(0,1,0);

Matrix viewMatrix = Matrix.LookAtLH(eye,at,up);

Direct3D uses the world and view matrices that you set to configure several internal data structures. Each time you set a new world or view matrix, the system recalculates the associated internal structures. Setting these matrices frequently is computationally time-consuming. You can minimize the number of required calculations by concatenating your world and view matrices into a world-view matrix that you set as the world matrix, and then setting the view matrix to the identity. Keep cached copies of individual world and view matrices so that you can modify, concatenate, and reset the world matrix as needed. For clarity, the samples rarely employ this optimization.


World Transformation

This discussion of the world transformation introduces basic concepts and provides details on how to set up a world transformation matrix in a Microsoft Direct3D application.

What Is a World Transformation?

A world transformation changes coordinates from model space, where vertices are defined relative to a model's local origin, to world space, where vertices are defined relative to an origin common to all of the objects in a scene. In essence, the world transformation places a model into the world; hence its name. The following diagram illustrates the relationship between the world coordinate system and a model's local coordinate system.

World Coordinate system

The world transformation can include any combination of translations, rotations, and scalings. For a discussion of the mathematics of transformations, see 3-D Transformations.

Setting Up a World Matrix

As with any other transformation, you create the world transformation by concatenating a series of transformation matrices into a single matrix that contains the sum total of their effects. In the simplest case, when a model is at the world origin and its local coordinate axes are oriented the same as world space, the world matrix is the identity matrix. More commonly, the world matrix is a combination of a translation into world space and possibly one or more rotations to turn the model as needed.

The following C# code example, from a fictitious 3-D model class written in C#, creates a world matrix that includes three rotations to orient a model and a translation to relocate it relative to its position in world space.

          [C#]

public class ModelClass
{
   private float xPos=0;
   private float yPos=0;
   private float zPos=0;

   private float Pitch=0;
   private float Yaw=0;
   private float Roll=0;

   //...Other model properties and methods

   public Matrix MakeWorldMatrix(Matrix worldMatrix)
   {
      worldMatrix.Translate(xPos,yPos,zPos);

      Matrix matRot = Matrix.Identity;

      matRot.RotateYawPitchRoll(Yaw,Pitch,Roll);

      worldMatrix = Matrix.Multiply(matRot, worldMatrix);

      return worldMatrix;

   }
}

After you prepare the world transformation matrix, call the SetTransform method to set it, specifying the TransformType.World value for the first parameter. Alternately, you can pass the world transformation matrix to the Device.Transform.World property.

Note: Direct3D uses the world and view matrices that you set to configure several internal data structures. Each time you set a new world or view matrix, the system recalculates the associated internal structures. Setting these matrices frequently—for example, thousands of times per frame—is computationally time-consuming. You can minimize the number of required calculations by concatenating your world and view matrices into a world-view matrix that you set as the world matrix, and then setting the view matrix to the identity. Keep cached copies of individual world and view matrices so that you can modify, concatenate, and reset the world matrix as needed. For clarity, Direct3D samples in this documentation rarely employ this optimization.


Matrices

Microsoft Direct3D uses matrices to perform 3-D transformations. This section explains how matrices create 3-D transformations, describes some common uses for transformations, and details how you can combine matrices to produce a single matrix that encompasses multiple transformations. Information is divided into the following topics.

  • 3-D Transformations
  • Translation and Scaling
  • Rotation
  • Matrix Concatenation


3-D Transformations

In applications that work with 3-D graphics, geometrical transformations can be used to do the following.

  • Express the location of an object relative to another object.
  • Rotate and size objects.
  • Change viewing positions, directions, and perspectives.

You can transform any point (x,y,z) into another point (x', y', z') using a 4 x 4 matrix.

Perform the following operations on (x, y, z) and the matrix to produce the point (x', y', z').

The most common transformations are translation, rotation, and scaling. You can combine the matrices that produce these effects into a single matrix to calculate several transformations at once. For example, you can build a single matrix to translate and rotate a series of points. For more information, see Matrix Concatenation.

Matrices are written in row-column order. A matrix that evenly scales vertices along each axis, a process known as uniform scaling, is represented by the following matrix using mathematical notation.

Microsoft Direct3D declares matrices as a two-dimensional array, using the Matrix structure. The following C# code example shows how to create a Matrix structure to act as a uniform scaling matrix.

          [C#]

// In this example, s is a variable of type float.
Matrix scale = new Matrix();

scale.M11=s;    scale.M12=0.0f; scale.M13=0.0f; scale.M14=0.0f;
scale.M21=0.0f; scale.M22=s;    scale.M23=0.0f; scale.M24=0.0f;
scale.M31=0.0f; scale.M32=0.0f; scale.M33=s;    scale.M34=0.0f;
scale.M41=0.0f; scale.M42=0.0f; scale.M43=0.0f; scale.M44=1.0f;


Translation and Scaling

Translation

The following transformation translates the point (x, y, z) to a new point (x', y', z').

You can manually create a translation matrix in managed code. The following C# code example shows the source code for a function that creates a matrix to translate vertices.

          [C#]

private Matrix TranslateMatrix(float dx, float dy, float dz)
{
   Matrix ret;

   ret = Matrix.Identity;

   ret.M41 = dx;
   ret.M42 = dy;
   ret.M43 = dz;

   return ret;
}

For convenience, managed the Microsoft Direct3D supplies the Translation method.

Scaling

The following transformation scales the point (x, y, z) by arbitrary values in the x-, y-, and z-directions to a new point (x', y', z').


Rotation

The transformations described here are for left-handed coordinate systems, and so might be different from transformation matrices that you have seen elsewhere. For more information, see 3-D Coordinate Systems.

The following transformation rotates the point (x, y, z) around the x-axis, producing a new point (x', y', z').

Matrix x rotation

The following transformation rotates the point around the y-axis.

Matrix y rotation

The following transformation rotates the point around the z-axis.

Matrix z rotation

In these example matrices, the Greek letter theta (?) stands for the angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

In a managed application, use the Matrix.RotationX, Matrix.RotationY, and Matrix.RotationZ methods to create rotation matrices. The following C# code example demonstrates how the Matrix.RotationX method performs a rotation.

          [C#]

private Matrix MatrixRotationX(float angle)
{
   double sin, cos;
   sin = Math.Sin(angle);
   cos = Math.Cos(angle);

   Matrix ret;
   ret.M11 = 1.0f; ret.M12 = 0.0f; ret.M13 = 0.0f; ret.M14 = 0.0f;
   ret.M21 = 0.0f; ret.M22 = (float)cos; ret.M23 = (float)sin; ret.M24 = 0.0f;
   ret.M31 = 0.0f; ret.M32 = (float)-sin; ret.M33 = (float)cos; ret.M34 = 0.0f;
   ret.M41 = 0.0f; ret.M42 = 0.0f; ret.M43 = 0.0f; ret.M44 = 1.0f;
   return ret;
}


Matrix Concatenation

One advantage of using matrices is that you can combine the effects of two or more matrices by multiplying them. This means that, to rotate a model and then translate it to some location, you do not need to apply two matrices. Instead, you multiply the rotation and translation matrices to produce a composite matrix that contains all of their effects. This process, called matrix concatenation, can be written with the following formula.

In this formula, C is the composite matrix being created, and M1 through Mn are the individual transformations that matrix C contains. In most cases, only two or three matrices are concatenated, but there is no limit.

Use the Matrix.Multiply method to perform matrix multiplication.

The order in which the matrix multiplication is performed is crucial. The preceding formula reflects the left-to-right rule of matrix concatenation. That is, the visible effects of the matrices that you use to create a composite matrix occur in left-to-right order. A typical world transformation matrix is shown in the following example. Imagine that you are creating the world transformation matrix for a stereotypical flying saucer. You would probably want to spin the flying saucer around its center - the y-axis of model space - and translate it to some other location in your scene. To accomplish this effect, you first create a rotation matrix, and then multiply it by a translation matrix, as shown in the following formula.

World Space explanation

In this formula, Ry is a matrix for rotation about the y-axis, and Tw is a translation to some position in world coordinates.

The order in which you multiply the matrices is important because, unlike multiplying two scalar values, matrix multiplication is not commutative. Multiplying the matrices in the opposite order has the visual effect of translating the flying saucer to its world space position, and then rotating it around the world origin.

No matter what type of matrix you are creating, remember the left-to-right rule to ensure that you achieve the expected effects.


Direct3D Rendering

Applications use the DrawPrimitive family of methods to render a 3-D scene.

  • Shading
  • Presenting a Scene
  • Rendering Primitives
  • Depth Buffers
  • Fog
  • Alpha Blending


Shading

This section describes techniques used in Microsoft Direct3D to control the shading of 3-D polygons.

  • Shading Modes
  • Comparing Shading Modes
  • Setting the Shading Mode


Shading Modes

The shading mode used to render a polygon has a profound effect on its appearance. Shading modes determine the intensity of color and lighting at any point on a polygon face. Microsoft Direct3D supports two shading modes: flat and Gouraud.

Flat Shading

In the flat shading mode, the Direct3D rendering pipeline renders a polygon, using the color of the polygon material at its first vertex as the color for the entire polygon. 3-D objects that are rendered with flat shading have visibly sharp edges between polygons if they are not coplanar.

The following figure shows a teapot rendered with flat shading. The outline of each polygon is clearly visible. Flat shading is the fastest form of shading.

Rough image of teapot

Gouraud Shading

When Direct3D renders a polygon using Gouraud shading, it computes a color for each vertex by using the vertex normal and lighting parameters. Then, it interpolates the color across the face of the polygons. The interpolation is done in a linear manner. For example, if the red component of the color of vertex 1 is 0.8 and the red component of vertex 2 is 0.4, using the Gouraud shading mode and the RGB color model, the Direct3D lighting module assigns a red component of 0.6 to the pixel at the midpoint of the line between these vertices.

The following figure demonstrates Gouraud shading. This teapot is composed of many flat, triangular polygons. However, Gouraud shading makes the surface of the object appear curved and smooth.

Smooth image of teapot

Gouraud shading also can be used to display objects with sharp edges.

For more information, see Face and Vertex Normal Vectors.


Comparing Shading Modes

In flat shading mode, the pyramid below is displayed with a sharp edge between adjoining faces. In Gouraud shading mode, however, shading values are interpolated across the edge, and the final appearance is of a curved surface.

Automatic face normals

Gouraud shading lights flat surfaces more realistically than flat shading. A face in flat shading mode is a uniform color, but Gouraud shading enables light to fall across a face more correctly. This effect is particularly obvious if there is a nearby point source.

Gouraud shading smooths the sharp edges between polygons that are visible with flat shading. However, it can result in Mach bands. An application can reduce the appearance of Mach bands by increasing the number of polygons in an object, increasing screen resolution, or increasing the color depth of the application.

Gouraud shading can miss some details. One example is shown in the following illustration, in which a spotlight is completely contained within a polygon face.

In this case, Gouraud shading, which interpolates between vertices, would miss the spotlight altogether, and the face would be rendered as though the spotlight did not exist.


Setting the Shading Mode

Microsoft Direct3D enables one shading mode to be selected at a time. Gouraud shading is selected by default. In Microsoft DirectX 9.0 for Managed Code, the shading mode can be changed by setting the ShadeMode property of the RenderStateManager object that is returned by the Device.RenderState property.

The following C# code example illustrates how the current shading mode of a Direct3D application can be set to either flat or Gouraud.

          [C#]

// This code example assumes that device is already initialized .
// Set to flat shading.

device.RenderState.ShadeMode = ShadeMode.Flat;

// Set to Gouraud shading. This is the default for Direct3D.
device.RenderState.ShadeMode = ShadeMode.Gouraud;


Presenting a Scene

This section introduces the presentation application programming interfaces (APIs) and discusses the issues involved in presenting a scene to the display.

Information is divided into the following topics.

  • Introduction to Presenting a Scene
  • Multiple Views in Windowed Mode
  • Multiple-Monitor Operations
  • Manipulating the Depth Buffer
  • Accessing the Color Front Buffer


Introduction to Presenting a Scene

The presentation application programming interfaces (APIs) are a set of methods that control the state of the device that affects what the user sees on the monitor. The set includes methods for setting display modes as well as once-per-frame methods that are used to present images to the user.

  • Device.Present
  • Device.Reset
  • Device.GetGammaRamp
  • Device.SetGammaRamp
  • Device.GetRasterStatus

Familiarity with the following terms is necessary to understand the presentation APIs.

  • front buffer. A rectangle of memory that is translated by the graphics adapter and displayed on the monitor or other output device.
  • back buffer. A surface whose contents can be promoted to the front buffer.
  • swap chain. A collection of back buffers that can be serially presented to the front buffer. Typically, a full-screen swap chain presents subsequent images with the flipping device driver interface (DDI), and a windowed swap chain presents images with the blitting DDI.

Because Microsoft Direct3D for Microsoft DirectX 9.0 has one swap chain as a property of the device, there is always at least one swap chain per device. The Device class includes a set of methods that manipulate the implicit swap chain and are a copy of the swap chain's own interface. Applications can create additional swap chains; however, this is not necessary for the typical single-window or full-screen application.

The front buffer is not directly exposed in the Direct3D API for DirectX 9.0. As a result, applications cannot lock or render to the front buffer. For more information, see Accessing the Color Front Buffer.

Note: DirectX 7.0 provides a number of presentation APIs that are called together. A good example of this is the IDirectDraw7::SetCooperativeLevel, IDirectDraw7::SetDisplayMode, and IDirectDraw7::CreateSurface sequence. Additionally, the IDirectDrawSurface7::Flip and IDirectDrawSurface7::Blt methods signal the transport of rendered frames to the monitor. DirectX 9.0 collapses these groups of APIs into two main methods, Reset and Present. Reset subsumes SetCooperativeLevel, SetDisplayMode, CreateSurface, and some of the parameters to flip. Present subsumes flip and the presentation uses of blit.

A call to Manager represents an implicit reset of the device. The DirectX 9.0 API has no notion of a primary surface; it is not possible to create an object that represents the primary surface because it is considered to be an internal property of the device.

Gamma ramps are associated with a swap chain and are manipulated with the GetGammaRamp and SetGammaRamp methods.


Multiple Views in Windowed Mode

In addition to the swap chain that is owned and manipulated through the Device object, an application can use the SwapChain.SwapChain method to create additional swap chains for presenting multiple views from the same device.

Typically, the application creates one swap chain per view, and it associates each swap chain with a particular view. The application renders images in the back buffers of each swap chain, and then uses the SwapChain.Present method to present them individually. Note that only one swap chain at a time can be full-screen on each adapter.


Multiple-Monitor Operations

When a device is successfully reset (with Device.Reset) or created (with Device.Device) in full-screen operations, the Microsoft Direct3D object that created the device is marked as owning all adapters on that system. This state is known as exclusive mode, and is owned by the Direct3D object. Exclusive mode means that devices created by any other Direct3D object can neither assume full-screen operations nor allocate video memory. In addition, when a Direct3D object assumes exclusive mode, all devices other than the one that went full-screen are placed in lost state. For more information, see Lost Devices.

Along with exclusive mode, the Direct3D object is informed of the focus window that the device will use. Exclusive mode is released when the final full-screen device owned by that Direct3D object is either reset to windowed mode or destroyed.

Devices can be divided into two categories when a Direct3D object owns exclusive mode. The first category of devices have the following characteristics.

  • They are created by the same Direct3D object that created the full-screen device.
  • They have the same focus window as the full-screen device.
  • They represent a different adapter from any full-screen device.

Devices in this category have no restrictions concerning their ability to be reset or created, and they are not placed in lost state. They can even be put into full-screen mode.

Devices that do not fall into the first category—those that are created by another Direct3D object, created with a different focus window, and created for an adapter with a device that is already full-screen—cannot be reset and remain in lost state until the exclusive mode is lost. As a result, a multiple-monitor application can place several devices in full-screen mode, but only if all of them are for different adapters, were created by the same Direct3D object, and share the same focus window.


Manipulating the Depth Buffer

Depth buffers are associated with the device. Applications are required to move the depth buffers when they set render targets. The Device.DepthStencilSurface property is used to manipulate depth buffers.


Accessing the Color Front Buffer

Accessing the front buffer is allowed through the Device.GetFrontBufferData method. This method is the only way to get a screen shot of an anti-aliased scene.


Rendering Primitives

The following topics provide information about drawing primitives in an application.

  • Vertex Data Streams
  • Setting the Stream Source
  • Rendering from Vertex and Index Buffers
  • Rendering from User Memory Pointers


Vertex Data Streams

The rendering interfaces for Microsoft Direct3D consist of methods that render primitives from vertex data stored in one or more data buffers. Vertex data consists of vertex elements that are combined to form vertex components. Vertex elements—the smallest unit of a vertex—represent entities such as position, normal, or color.

Vertex components are one or more vertex elements that are stored contiguously (interleaved per vertex) in a single memory buffer. A complete vertex consists of one or more components, where each component is in a separate memory buffer. To render a primitive, multiple vertex components are read and assembled so that complete vertices are available for vertex processing.

The illustration below shows the process of rendering primitives using vertex components.

Rendering primitives consists of two steps: setting up one or more vertex component streams, and then invoking a Device.DrawPrimitives method to render from those streams. Identification of vertex elements within these component streams is specified by the vertex shader.

The Device.DrawPrimitives methods specify an offset in the vertex data streams so that an arbitrary contiguous subset of the primitives within one set of vertex data can be rendered with each draw invocation. This enables changes to the device rendering state between groups of primitives that are rendered from the same vertex buffers.

Both indexed and nonindexed drawing methods are supported. For more information, see Rendering from Vertex and Index Buffers.


Setting the Stream Source

The Device.SetStreamSource method binds a vertex buffer to a device data stream, creating an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The actual references to the stream data do not occur until a drawing method, such as Device.DrawPrimitives, is called.

A stream is defined as a uniform array of component data, where each component consists of one or more elements that represent a single entity such as position, normal, or color. The Stride parameter of the Device.SetStreamSource method specifies the size of the component in bytes.


Rendering from Vertex and Index Buffers

Microsoft Direct3D supports both indexed and nonindexed drawing methods. The indexed methods use a single set of indices for all vertex components. Vertex data is stored in vertex buffers, and index data is stored in index buffers. Listed below are a few common scenarios for drawing primitives using vertex and index buffers. These examples compare the use of Device.DrawPrimitives and Device.DrawIndexedPrimitives.

Scenario 1: Drawing Two Triangles without Indexing

Suppose you want to draw the following quad.

Two triangles without indexing

If you use the Triangle List primitive type to render the two triangles, each triangle is stored as three individual vertices, resulting in a vertex buffer similar to this.

Vertex buffer of two triangles without indexing

To perform the drawing call, draw two triangles, starting at location 0 within the vertex buffer. If culling is enabled, the order of the vertices is important. This example assumes the default counterclockwise culling state, so visible triangles must be drawn in clockwise order. The Triangle List primitive type simply reads three vertices in linear order from the buffer for each triangle, so the following C# call draws triangles (0, 1, 2) and (3, 4, 5).

          [C#]

Device.DrawPrimitives(PrimitiveType.TriangleList,   // PrimitiveType
                      0,                            // StartVertex
                      2);                           // PrimitiveCount

Scenario 2: Drawing Two Triangles with Indexing

As you will notice, the vertex buffer contains duplicate data in locations 0 and 4, 2 and 5. This makes sense because the two triangles share two common vertices. This duplicate data is wasteful, and the vertex buffer can be compressed by using an index buffer. A smaller vertex buffer reduces the amount of vertex data that must be sent to the graphics adapter. Even more importantly, using an index buffer allows the adapter to store vertices in a vertex cache; if the primitive being drawn contains a recently used vertex, that vertex can be fetched from the cache instead of reading it from the vertex buffer, which results in a significant performance increase.

An index buffer 'indexes' into the vertex buffer so that each unique vertex needs to be stored only once in the vertex buffer. Here is an indexed approach to the drawing scenario above.

Index and vertex buffer of two triangles with indexing

The index buffer stores VB Index values, which reference a particular vertex within the vertex buffer. A vertex buffer can be thought of as an array of vertices, so the VB Index is simply the index into the vertex buffer for the target vertex. Similarly, an IB Index is an index into the index buffer. This can get very confusing very quickly if you are not careful, so be sure you are clear on the vocabulary being used: VB Index values index into the vertex buffer, IB Index values index into the index buffer, and the index buffer itself stores VB Index values.

The drawing call is shown below. The meanings of all of the arguments are discussed at length for the next drawing scenario; for now, just note that this call is again instructing Direct3D to render a triangle list that contains two triangles, starting at location 0 within the index buffer. The following C# call draws the same two triangles in the exact same order as before, ensuring a proper clockwise orientation.

          [C#]

Device.DrawIndexedPrimitives(PrimitiveType.TriangleList,  // PrimitiveType
                             0,                           // BaseVertexIndex
                             0,                           // MinIndex
                             4,                           // NumVertices
                             0,                           // StartIndex
                             2);                          // PrimitiveCount

Scenario 3: Drawing One Triangle with Indexing

Suppose now that you want to draw only the second triangle, but you want to use the same vertex buffer and index buffer you used when drawing the entire quad.

Index and vertex buffer for drawing one triangle with indexing

For this drawing call, the first IB Index used is 3; this value is called the StartIndex. The lowest VB Index used is 0; this value is called the MinIndex. Even though only three vertices are required to draw the triangle, those three vertices are spread across four adjacent locations in the vertex buffer; the number of locations within the contiguous block of vertex buffer memory required for the drawing call is called NumVertices, and is set to 4 in this call. The MinIndex and NumVertices values are really just hints to help Direct3D optimize memory access during software vertex processing, and could simply be set to include the entire vertex buffer at the price of performance.

Here is the drawing C# call for the single triangle case. The meaning of the BaseVertexIndex argument will be explained next.

          [C#]

Device.DrawIndexedPrimitives(PrimitiveType.TriangleList,  // PrimitiveType
                             0,                           // BaseVertexIndex
                             0,                           // MinIndex
                             4,                           // NumVertices
                             3,                           // StartIndex
                             1);                          // PrimitiveCount

Scenario 4: Drawing One Triangle with Offset Indexing

BaseVertexIndex is a value that is effectively added to every VB Index stored in the index buffer. For example, if a value of 50 had been passed in for BaseVertexIndex during the previous call, that would functionally be the same as using the following index buffer for the duration of the Device.DrawIndexedPrimitives call.

Index buffer of one triangle with offset indexing

This value is rarely set to anything other than 0, but it can be useful if you want to decouple the index buffer from the vertex buffer: If, when filling in the index buffer for a particular mesh, the location of the mesh within the vertex buffer is not yet known, you can simply pretend that the mesh vertices will be located at the start of the vertex buffer. When it is time to make the draw call, simply pass the actual starting location as the BaseVertexIndex.

This technique also can be used when drawing multiple instances of a mesh using a single index buffer; for example, if the vertex buffer contained two meshes with identical draw orders but slightly different vertices (perhaps different diffuse colors or texture coordinates), both meshes could be drawn by using different values for BaseVertexIndex. Taking this concept one step further, you could use one index buffer to draw multiple instances of a mesh, each contained in a different vertex buffer, simply by cycling which vertex buffer is active and adjusting the BaseVertexIndex as needed. Note that the BaseVertexIndex value also is automatically added to the MinIndex argument, which makes sense when you see how it is used.

Suppose now that you again want to draw only the second triangle of the quad using the same index buffer as before; however, a different vertex buffer is being used in which the quad is located at VB Index 50. The relative order of the quad vertices remains unchanged, and only the starting location within the vertex buffer is different. The index buffer and vertex buffer would look like this.

Index and vertex buffer of one triangle with offset indexing

Here is the appropriate draw C# call; note that BaseVertexIndex is the only value that has changed from the previous scenario:

          [C#]

Device.DrawIndexedPrimitives(PrimitiveType.TriangleList,  // PrimitiveType
                             50,                          // BaseVertexIndex
                             0,                           // MinIndex
                             4,                           // NumVertices
                             3,                           // StartIndex
                             1);                          // PrimitiveCount


Rendering from User Memory Pointers

A secondary set of rendering interfaces supports passing vertex and index data directly from user memory pointers. These interfaces support a single stream of vertex data only. For more information, see the following reference topics.

  • Device.DrawUserPrimitives
  • Device.DrawIndexedUserPrimitives

These methods render with data specified by user memory pointers rather than vertex and index buffers.


Depth Buffers

A depth buffer, often called a z-buffer or a w-buffer, is a property of a device that stores depth information to be used by Microsoft Direct3D. When Direct3D renders a 3-D scene to a target surface, it can use the memory in an associated depth-buffer surface as a workspace to determine how the pixels of rasterized polygons occlude one another. Direct3D uses an offscreen Direct3D surface as the target to which final color values are written. The depth-buffer surface that is associated with the render target surface is used to store depth information that tells Direct3D how deep each visible pixel is in the scene.

When a 3-D scene is rasterized with depth buffering enabled, each point on the rendering surface is tested. The values in the depth buffer can be a point's z-coordinate or its homogeneous w-coordinate—from the point's (x,y,z,w) location in projection space. A depth buffer that uses z values is often called a z-buffer, and one that uses w values is called a w-buffer. Each type of depth buffer has advantages and disadvantages, which are discussed later.

At the beginning of the test, the depth value in the depth buffer is set to the largest possible value for the scene. The color value on the rendering surface is set to either the background color value or the color value of the background texture at that point. Each polygon in the scene is tested to see if it intersects with the current coordinate (x,y) on the rendering surface. If it does, the depth value—which will be the z coordinate in a z-buffer, and the w coordinate in a w-buffer—at the current point is tested to see if it is smaller than the depth value stored in the depth buffer. If the depth of the polygon value is smaller, it is stored in the depth buffer, and the color value from the polygon is written to the current point on the rendering surface. If the depth value of the polygon at that point is larger, the next polygon in the list is tested. This process is shown in the following illustration.

Note: Although most applications do not use this feature, it is possible to change the comparison that Direct3D uses to determine which values are placed in the depth buffer and subsequently the render-target surface. To do so, change the value for the RenderStateManager.ZBufferFunction property.

Nearly all 3-D accelerators on the market support z-buffering, making z-buffers the most common type of depth buffer today. However ubiquitous, z-buffers have their drawbacks. Due to the mathematics involved, the generated z values in a z-buffer tend not to be distributed evenly across the z-buffer range (typically 0.0 to 1.0, inclusive). Specifically, the ratio between the far and near clipping planes strongly affects how unevenly z values are distributed. Using a far-plane distance to near-plane distance ratio of 100, 90 percent of the depth buffer range is spent on the first 10 percent of the scene depth range. Typical applications for entertainment or visual simulations with exterior scenes often require far-plane/near-plane ratios of anywhere between 1000 to 10000. At a ratio of 1000, 98 percent of the range is spent on the first 2 percent of the depth range, and the distribution becomes worse with higher ratios. This can cause hidden surface artifacts in distant objects, especially when using 16-bit depth buffers, the most commonly supported bit depth.

A w-based depth buffer, on the other hand, is often more evenly distributed between the near and far clip planes than a z-buffer. The key benefit is that the ratio of distances for the far and near clipping planes is no longer an issue. This allows applications to support large maximum ranges, while still getting relatively accurate depth buffering close to the eye point. A w-based depth buffer is not perfect, and can sometimes exhibit hidden surface artifacts for near objects. Another drawback to the w-buffered approach is related to hardware support: w-buffering is not supported as widely in hardware as z-buffering.

Z-buffering requires overhead during rendering. Various techniques can be used to optimize rendering when using z-buffers. Applications can increase performance when using z-buffering and texturing by ensuring that scenes are rendered from front to back. Textured z-buffered primitives are pre-tested against the z-buffer on a scan-line basis. If a scan line is hidden by a previously rendered polygon, the system rejects it quickly and efficiently. Z-buffering can improve performance, but the technique is most useful when a scene draws the same pixels more than once. Though this is difficult to calculate exactly, close approximations often can be made. If the same pixels are drawn less than twice, the best performance can be achieved by turning z-buffering off and rendering the scene from back to front.

Note: The actual interpretation of a depth value is specific to the 3-D renderer.

The following topics present information about using depth buffers for hidden line and hidden surface removal.

  • Querying for Depth Buffer Support
  • Creating a Depth Buffer
  • Enabling Depth Buffering
  • Retrieving a Depth Buffer
  • Clearing Depth Buffers
  • Changing Depth Buffer Write Access
  • Changing Depth Buffer Comparison Functions
  • Using Z-Bias


Querying for Depth Buffer Support

As with any feature, the driver that an application uses might not support all types of depth buffering. Always check the driver's capabilities. Although most drivers support z-based depth buffering, not all support w-based depth buffering (w-buffering). Drivers do not fail if you attempt to enable an unsupported scheme. Instead, they fall back on another depth buffering method, or sometimes disable depth buffering altogether, which can result in scenes rendered with extreme depth-sorting artifacts.

To check for general support for depth buffers, query Microsoft Direct3D for the display device that your application will use before you create a Direct3D device. If the Direct3D object reports that it supports depth buffering, any hardware devices created from it will support z-buffering.

To query for depth buffering support, use the Manager.CheckDeviceFormat method, as shown in the following C# code example.

          [C#]

AdapterInformation ai = Manager.Adapters.Default;

// Verify that the depth format exists.
if (Manager.CheckDeviceFormat(ai.Adapter,
                                DeviceType.Hardware,
                                adapterFmt,
                                Usage.DepthStencil,
                                ResourceType.Surface,
                                DepthFormat.D16,
                                out result))
{
    return true;
}

return false;   // If the call fails, the error code is passed back in the result.

The Manager.CheckDeviceFormat method allows you to choose a device to create based on the capabilities of that device. In this case, devices that do not support 16-bit depth buffers are rejected.

Using Manager.CheckDepthStencilMatch to determine depth-stencil compatibility with a render target is illustrated in the following C# code example.

          [C#]

// Reject devices that cannot create a render target of RTFormat while
// the back buffer is of RTFormat and the depth-stencil buffer is
// at least 8 bits of stencil.
AdapterInformation ai = Manager.Adapters.Default;

if (Manager.CheckDepthStencilMatch(ai.Adapter,
                                    DeviceType.Hardware,
                                    adapterFmt,
                                    RTFormat,
                                    DepthFormat.D24S8))
{
    return true;    // Device can create the render target.
}

return false;   // Reject the device; it cannot create the render target.

When you know that the driver supports depth buffers, you can verify w-buffer support. Although depth buffers are supported for all software rasterizers, w-buffers are supported only by the reference rasterizer, which is not suited for use by real-world applications. Regardless of the type of device an application uses, support for w-buffers should be verified before any attempt is made to enable w-based depth buffering.

The following procedure demonstrates how to verify support for w-buffers.

  1. After creating the device, retrieve its Caps structure from the Device.DeviceCaps property.
  2. The Caps.LineCaps property contains a reference to a LineCaps structure that contains information about the driver's support for rendering primitives.
  3. If the driver supports w-based depth buffering for that primitive type, check the RasterCaps.SupportsWBuffer property of the RasterCaps structure contained in the Caps.RasterCaps property.


Creating a Depth Buffer

A depth buffer is a property of a device. To create a depth buffer that is managed by Microsoft Direct3D, set the appropriate members of the PresentParameters class as shown in the following C# code example.

          [C#]

PresentParameters presentParams = new PresentParameters();

presentParams.Windowed = true;
presentParams.SwapEffect = SwapEffect.Copy;
presentParams.EnableAutoDepthStencil = true;
presentParams.AutoDepthStencilFormat = DepthFormat.D16;

Setting the PresentParameters.EnableAutoDepthStencil member to true instructs Direct3D to manage depth buffers for the application. Note that PresentParameters.AutoDepthStencilFormat must be set to a valid depth buffer format. The DepthFormat.D16 value specifies a 16-bit depth buffer, provided one is available.

The following C# call to the Device constructor creates a device that in turn creates a depth buffer.

          [C#]

Device device;

// Create a device using the PresentParameters previously set.
device = new Device(0,
                    DeviceType.Hardware,
                    this,
                    CreateFlags.SoftwareVertexProcessing,
                    presentParams);

The depth buffer is automatically set as the render target of the device. When the device is reset, the depth buffer is automatically destroyed and re-created in the new size. To create a new depth buffer surface, use the Device.CreateDepthStencilSurface method. To set a new depth-buffer surface for the device, use the Device.DepthStencilSurface method.

To use the depth buffer in an application, the depth buffer must be enabled. For more information, see Enabling Depth Buffering.


Enabling Depth Buffering

After creating a depth buffer (as described in Creating a Depth Buffer), you enable depth buffering by setting the RenderStateManager.ZBufferEnable property of the Device.RenderState property to true. To enable w-buffering, set the device's render state RenderStateManager.UseWBuffer property to true. These steps are illustrated in the following C# code example.

          [C#]

using System;
using Microsoft.DirectX.Direct3D;

    // Declare a rendering device.
    Device device = null;

    // Initialize the device.
    .
    .
    .

    // Get the device's render state object.
    RenderStates rs = device.RenderState;

    // Enable depth buffering.
    rs.ZBufferEnable = true;

    // Render the scene.
    .
    .
    .

    // Disable depth buffering
    // (note the different syntax; both forms are acceptable)
    device.RenderState.ZBufferEnable = false;

    // Use w-buffering.
    device.RenderState.UseWBuffer = true;
Note: To use w-buffering, an application must set a compliant projection matrix, even if it does not use the Microsoft Direct3D transformation pipeline. For information about providing an appropriate projection matrix, see A W-Friendly Projection Matrix. The projection matrix discussed in What Is the Projection Transformation? is compliant.


Retrieving a Depth Buffer

The following C# code example demonstrates how to use the Device.DepthStencilSurface property to retrieve a Surface object that describes the depth-buffer surface owned by the device.

          [C#]

Device device = null;
Surface surface = null;

// Create the device.
.
.
.

surface = device.DepthStencilSurface;


Clearing Depth Buffers

Many C# applications clear the depth buffer before rendering each new frame. Through Microsoft Direct3D, the depth buffer can be cleared explicitly by calling Device.Clear and specifying ClearFlags.ZBuffer for the flags parameter. The Device.Clear method allows specification of an arbitrary depth value in the zdepth parameter.

The following C# code example demonstrates how to clear the depth buffer.

          [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;

// Create a rendering device.
.
.
.

// Clear the depth buffer.
device.Clear(ClearFlags.ZBuffer, 0, 0.5f, 0);


Changing Depth Buffer Write Access

By default, the Microsoft Direct3D system is allowed to write to the depth buffer. Most applications leave writing to the depth buffer enabled, but some special effects can be achieved by disabling this functionality in the Direct3D system.

To disable depth buffer writes in C#, set the RenderStateManager.ZBufferWriteEnable property of the Device.RenderState property to false. This is illustrated in the following C# code example.

          [C#]

using System;
using Microsoft.DirectX.Direct3D;

    // Declare a rendering device.
    Device device = null;

    // Initialize the device.
    .
    .
    .

    // Get the device's render state object.
    RenderStates rs = device.RenderState;

    // Disable depth buffer writes.
    rs.ZBufferWriteEnable = false;

    // Render the scene.
    .
    .
    .

    // Enable depth buffer writes
    // (note the different syntax; both forms are acceptable)
    device.RenderState.ZBufferWriteEnable = true;


Changing Depth Buffer Comparison Functions

By default, when depth testing is performed on a rendering surface, the Microsoft Direct3D system updates the render target surface if the corresponding depth value (z or w) for each point is less than the value in the depth buffer. In a C# application, changes to how the system performs comparisons on depth values are made by setting the RenderStateManager.ZBufferFunction property of the Device.RenderState property to a value of the Compare enumerated type. This is illustrated in the following C# code example.

          [C#]

using System;
using Microsoft.DirectX.Direct3D;

    // Declare a rendering device.
    Device device = null;

    // Initialize the device.
    .
    .
    .

    // Get the device's render state object.
    RenderStates rs = device.RenderState;

    // Set the ZBuffer comparison function.
    rs.ZBufferFunction = Compare.Greater;

    // Render the scene.
    .
    .
    .

    // Change the comparison function to some other value
    // (note the different syntax; both forms are acceptable)
    device.RenderState.ZBufferFunction = Compare.LessEqual;


Using Z-Bias

Polygons that are coplanar in 3-D space can be made to appear as if they are not coplanar by adding a z-bias to each one. This is a technique commonly used to ensure that shadows in a scene are displayed properly. For instance, a shadow on a wall will likely have the same depth value as the wall does. If the wall is rendered before the shadow, the shadow might not be visible, or depth artifacts might be visible. The order in which the coplanar objects are rendered can be reversed in hopes of reversing the effect, but depth artifacts are still likely.

A C# application can help ensure that coplanar polygons are rendered properly by adding a bias to the z-values that the system uses when it renders the sets of coplanar polygons. To add a z-bias to a set of polygons, set the RenderStateManager.DepthBias property of the Device.RenderState property to a value between 0 and 16, inclusive. A higher z-bias value increases the likelihood that the rendered polygons will be visible when displayed with other coplanar polygons.

The following C# code example demonstrates how to set the z-bias value.

          [C#]

using System;
using Microsoft.DirectX.Direct3D;

    // Declare a rendering device.
    Device device = null;

    // Initialize the device.
    .
    .
    .

    // Get the device's render state object.
    RenderStates rs = device.RenderState;

    // Set the depth bias value.
    rs.DepthBias = 7.0f;

    // Render the scene.
    .
    .
    .

    // Change the depth bias value
    // (note the different syntax; both forms are acceptable)
    device.RenderState.DepthBias = 3.0f;


Fog

Adding fog to a 3-D scene can enhance realism, provide ambiance or set a mood, and obscure artifacts that are sometimes caused when distant geometry comes into view. Microsoft Direct3D supports two fog models, pixel fog and vertex fog, each with its own features and programming interface.

Essentially, fog is implemented by blending the color of objects in a scene with a chosen fog color, based on the depth of an object in a scene or its distance from the viewpoint. As objects grow more distant, their original color blends more and more with the chosen fog color, creating the illusion that the object is being increasingly obscured by tiny particles floating in the scene. The following illustration shows a scene rendered without fog, and a similar scene rendered with fog enabled.

Scene rendered without fog (left), and with fog (right)

In this illustration, the scene on the left has a clear horizon, beyond which no scenery is visible, even though it would be visible in the real world. The scene on the right obscures the horizon by using a fog color that is identical to the background color, making polygons appear to fade into the distance. By combining discrete fog effects with creative scene design, it is possible to add mood and soften the color of objects in a scene.

Direct3D provides two ways to add fog to a scene: pixel fog and vertex fog, named for the manner in which the fog effects are applied. For more information, see Pixel Fog and Vertex Fog. In short, pixel fog—also called table fog—is implemented in the device driver, and vertex fog is implemented in the Direct3D lighting engine. An application can implement both types of fog simultaneously if desired.

Note: Regardless of whether pixel or vertex fog is used, an application must provide a compliant projection matrix to ensure that fog effects are properly applied. This restriction applies even to applications that do not use the Direct3D transformation and lighting engine. For more information about how to provide an appropriate matrix, see A W-Friendly Projection Matrix.

The following topics introduce fog and present information about using various fog features in Direct3D applications.

  • Fog Formulas
  • Fog Parameters
  • Fog Blending
  • Fog Color
  • Vertex Fog
  • Pixel Fog

Fog blending is controlled by render states; it is not part of the programmable pixel pipeline.


Fog Formulas

C# applications can control how fog affects the color of objects in a scene by changing the way Microsoft Direct3D computes fog effects over distance. The FogMode enumerated type contains members that identify the three fog formulas (linear fog and two types of exponential fog). All formulas calculate a fog factor as a function of distance, given parameters that an application sets.

Linear Fog

This is set with Linear.

Linear fog equation

where

  • start is the distance at which fog effects begin.
  • end is the distance at which fog effects no longer increase.
  • d represents depth, or the distance from the viewpoint. For range-based fog, the value for d is the distance between the camera position and a vertex. For non-range-based fog, the value for d is the absolute value of the z-coordinate in camera space.

Exponential Fog

Linear and exponential formulas are supported for both pixel fog and vertex fog.

This is set with Exp.

Exponential fog equation

where

  • e is the base of natural logarithms (approximately 2.71828).
  • density is an arbitrary fog density that can range from 0.0 to 1.0.
  • d represents depth, or the distance from the viewpoint, as stated earlier.

This is set with Exp2.

Exponential square fog equation

where

  • e is the base of natural logarithms, as stated above.
  • density is an arbitrary fog density that can range from 0.0 to 1.0, as stated above.
  • d represents depth, or the distance from the viewpoint, as stated above.
Note: The system stores the fog factor in the alpha component of the specular color for a vertex. If an application performs its own transformation and lighting, fog factor values can be inserted manually, to be applied by the system during rendering.

The following illustration graphs these formulas, using common values as in the formula parameters.

Linear is 1.0 at start and 0.0 at end. It is not measured relative to the near or far planes.

When Direct3D calculates fog effects, it uses the fog factor from one of the preceding equations in a blending formula, shown here.

This formula effectively scales the color of the current polygon C by the fog factor f, and adds the product to the fog color C, scaled by the bitwise inverse of the fog factor. The resulting color value is a blend of the fog color and the original color, as a factor of distance. The formula applies to all devices supported in Microsoft DirectX 7.0 and later. For the legacy ramp device, the fog factor scales the diffuse and specular color components, clamped to the range of 0.0 and 1.0, inclusive. The fog factor typically starts at 1.0 for the near plane and decreases to 0.0 at the far plane.


Fog Parameters

Fog parameters are controlled through device render states. Both pixel and vertex fog types support all of the fog formulas introduced in Fog Formulas. The FogMode enumerated type defines constants that can be used to identify the fog formula you want Microsoft Direct3D to use. The RenderStateManager.FogTableMode property controls the fog mode that Direct3D uses for pixel fog, and the RenderStateManager.FogVertexMode property controls the mode for vertex fog.

When using the linear fog formula, set the starting and ending distances through the RenderStateManager.FogStart and RenderStateManager.FogEnd properties. How the system interprets these values depends on the type of fog—pixel or vertex—an application uses, and when using pixel fog, whether z-based or w-based depth is being used. The following table summarizes fog types and their start and end units.

Fog type | Fog start/end units
Pixel (Z) | Device space [0.0,1.0]
Pixel (W) | Camera space
Vertex | Camera space

The RenderStateManager.FogDensity property controls the fog density that is applied when an exponential fog formula is enabled. Fog density is essentially a weighting factor, ranging from 0.0 to 1.0 (inclusive), that scales the distance value in the exponent.

The color that the system uses for fog blending is controlled through the RenderStateManager.FogColor device property. For more information, see Fog Color and Fog Blending.


Fog Blending

Fog blending refers to the application of the fog factor to fog and object colors to produce the final color that appears in a scene (as discussed in Fog Formulas). The RenderStateManager.FogEnable property controls fog blending. The default value is false; set this render state to true to enable fog blending, as shown in the following C# code example.

          [C#]

// For this example, device is a valid Device object.

// Get the device's render states object.
RenderStates rs = device.RenderState;

rs.FogEnable = true;

Fog blending must be enabled for both pixel fog and vertex fog. For information about using these types of fog, see Pixel Fog and Vertex Fog.


Fog Color

Fog color for both pixel and vertex fog is set through the RenderStateManager.FogColor property. The render state values can be any RGB color, specified as an RGBA color. The alpha component is ignored.

The following C# code example sets the fog color to white.

          [C#]

// For this example, device is a valid Device object.

// Get the device's render states object.
RenderStates rs = device.RenderState;

rs.FogColor = System.Color.White;

Fog is applied differently by the fixed-function pipeline and the programmable pipeline.

  1. If the driver supports MiscCaps.SupportsFogAndSpecularAlpha:
    • If the fixed-function pipeline is used and RenderStateManager.FogColor is set, v1.w (in the pixel shader) equals the value set in the fog render state.
    • If the programmable pipeline is used, v1.w (in the pixel shader) equals 0, even if oD1.w is explicitly written in a vertex shader.
  2. If the driver does not support MiscCaps.SupportsFogAndSpecularAlpha:
    • If the fixed-function pipeline is used and RenderStateManager.FogColor is set, v1.w (in the pixel shader) equals the value set in the fog render state.
    • If oFog is explicitly written in a vertex shader, v1.w (in the pixel shader) equals oFog, clamped between 0 and 1.
    • If neither of the above two cases applies, v1.w (in the pixel shader) equals 0, even if oD1.w is explicitly written in a vertex shader.

For more information, see MiscCaps.


Vertex Fog

When the system performs vertex fogging, it applies fog calculations at each vertex in a polygon, and then interpolates the results across the face of the polygon during rasterization. Vertex fog effects are computed by the Microsoft Direct3D lighting and transformation engine. For more information, see Fog Parameters.

If an application does not use Direct3D for transformation and lighting, the application must perform fog calculations. In this case, place the fog factor that is computed in the alpha component of the specular color for each vertex. Any formula can be used—range-based, volumetric, or otherwise. Direct3D uses the supplied fog factor to interpolate across the face of each polygon. Applications that perform their own transformation and lighting also must perform their own vertex fog calculations. As a result, such an application need only enable fog blending and set the fog color through the associated render states, as described in Fog Blending and Fog Color.

Note: When using a vertex shader, vertex fog must be used. This is accomplished by using the vertex shader to write the per-vertex fog intensity to the oFog register. After the pixel shader completes, the oFog data is used to linearly interpolate with the fog color. This intensity is not available in a pixel shader.

Range-Based Fog

Note: Direct3D uses range-based fog calculations only when using vertex fog with the Direct3D transformation and lighting engine. This is because pixel fog is implemented in the device driver, and no hardware currently exists to support per-pixel range-based fog. If an application performs its own transformation and lighting, it must perform its own fog calculations, range-based or otherwise.

Sometimes, using fog can introduce graphic artifacts that cause objects to be blended with the fog color in nonintuitive ways. For example, imagine a scene in which there are two visible objects: one distant enough to be affected by fog, and the other near enough to be unaffected. If the viewing area rotates in place, the apparent fog effects can change, even if the objects are stationary. The following illustration shows a top-down view of such a situation.

Effects on fog of changing the viewport

Range-based fog is another, more accurate, way to determine the fog effects. In range-based fog, Direct3D uses the actual distance from the viewpoint to a vertex for its fog calculations. Direct3D increases the effect of fog as the distance between the two points increases, rather than the depth of the vertex in the scene, thereby avoiding rotational artifacts.

If the current device supports range-based fog, it sets the SupportsFogRange property in the RasterCaps member of the Caps structure that is returned by a call to the Manager.GetDeviceCaps method. To enable range-based fog, set the RenderStateManager.RangeFogEnable property to true.

Range-based fog is computed by Direct3D during transformation and lighting. Applications that do not use the Direct3D transformation and lighting engine also must perform their own vertex fog calculations. In this case, provide the range-based fog factor in the alpha component of the specular component for each vertex.

Using Vertex Fog

Use the following steps to enable vertex fog in an application.

  1. Enable fog blending by setting RenderStateManager.FogEnable to true.
  2. Set the fog color in the RenderStateManager.FogColor property.
  3. Choose the desired fog formula by setting the RenderStateManager.FogVertexMode property to a member of the FogMode enumerated type.
  4. Set the fog parameters as desired for the selected fog formula in the render states.

The following C# code example shows what these steps might look like in code.

          [C#]

// For the purposes of this example, device is a valid Device object.
//
void SetupVertexFog(Color color, FogMode mode, bool bUseRange, float fDensity)
{
    float Start = 0.5f;     // Linear fog distances.
    float End   = 0.8f;

    // Enable fog blending.
    device.RenderState.FogEnable = true;

    // Set the fog color.
    device.RenderState.FogColor = color;

    // Set fog parameters.
    if (mode == FogMode.Linear)
    {
        device.RenderState.FogVertexMode = mode;
        device.RenderState.FogStart = Start;
        device.RenderState.FogEnd = End;
    }
    else
    {
        device.RenderState.FogVertexMode = mode;
        device.RenderState.FogDensity = fDensity;
    }

    // Enable range-based fog if desired (only supported for
    // vertex fog). For this example, it is assumed that bUseRange
    // is set only if the driver exposes the
    // RasterCaps.SupportsFogRange capability.
    // Note: This is slightly more performance-intensive
    // than non-range-based fog.

    if (bUseRange)
        device.RenderState.RangeFogEnable = true;
}


Pixel Fog

Pixel fog gets its name from the fact that it is calculated on a per-pixel basis in the device driver. This is different from vertex fog, which is computed by the pipeline during transformation and lighting calculations. Pixel fog is sometimes called table fog because some drivers use a precalculated lookup table to determine the fog factor, using the depth of each pixel to apply in blending computations. It can be applied using any fog formula identified by members of the FogMode enumerated type. The implementations of these formulas are driver-specific. If a driver does not support a complex fog formula, it should degrade to a less complex formula.

Eye-Relative vs. Z-Based Depth

To alleviate fog-related graphic artifacts caused by uneven distribution of z-values in a depth buffer, most hardware devices use eye-relative depth instead of z-based depth values for pixel fog. Eye-relative depth is essentially the w element from a homogeneous coordinate set. Microsoft Direct3D takes the reciprocal of the RHW element from a device space coordinate set to reproduce true w. If a device supports eye-relative fog, it sets the SupportsWFog property in the RasterCaps member of the Caps structure that is returned by a call to Manager.GetDeviceCaps. With the exception of the reference rasterizer, software devices always use z to calculate pixel fog effects.

When eye-relative fog is supported, the system automatically uses eye-relative depth rather than z-based depth if the provided projection matrix produces z-values in world space that are equivalent to w-values in device space. Set the projection matrix by calling the Device.SetTransform method, using the TransformType.Projection value and passing a Matrix structure that represents the desired matrix. If the projection matrix is not compliant with this requirement, fog effects are not applied properly. For details about producing a compliant matrix, see A W-Friendly Projection Matrix. The perspective projection matrix provided in What Is the Projection Transformation? produces a compliant projection matrix.

Direct3D uses the currently set projection matrix in its w-based depth calculations. As a result, an application must set a compliant projection matrix to receive the desired w-based features, even if it does not use the Direct3D transformation pipeline.

Direct3D checks the fourth column of the projection matrix. If the coefficients are [0,0,0,1] (for an affine projection) the system uses z-based depth values for fog. In this case, the start and end distances for linear fog effects must be specified in device space, which ranges from 0.0 at the nearest point to the user, and 1.0 at the farthest point.

Using Pixel Fog

Use the following steps to enable pixel fog in an application.

  1. Enable fog blending by setting the RenderStateManager.FogEnable property to true.
  2. Set the desired fog color in the RenderStateManager.FogColor property.
  3. Choose the fog formula to use by setting the RenderStateManager.FogTableMode property to the corresponding member of the FogMode enumerated type.
  4. Set the fog parameters as desired for the selected fog mode in the associated render states. This includes the start and end distances for linear fog, and fog density for exponential fog mode.

The following C# code example shows what these steps might look like in code.

          [C#]

// For the purposes of this example, device is a valid Device object.
//
void SetupPixelFog(Color color, FogMode mode)
{
    float Start   = 0.5f;   // For linear mode.
    float End     = 0.8f;   //

    float Density = 0.66f;  // For exponential modes.

    // Enable fog blending.
    device.RenderState.FogEnable = true;

    // Set the fog color.
    device.RenderState.FogColor = color;

    // Set fog parameters.
    if (mode == FogMode.Linear)
    {
        device.RenderState.FogTableMode = mode;
        device.RenderState.FogStart = Start;
        device.RenderState.FogEnd = End;
    }
    else
    {
        device.RenderState.FogTableMode = mode;
        device.RenderState.FogDensity = Density;
    }
}


Alpha Blending

Alpha blending is used to display an image that has transparent or semi-transparent pixels. In addition to a red, green, and blue color channel, each pixel in an alpha bitmap has a transparency component known as its alpha channel. The alpha channel typically contains as many bits as a color channel. For example, an 8-bit alpha channel can represent 256 levels of transparency, from 0 (meaning the entire pixel is transparent) to 255 (meaning the entire pixel is opaque).

Color can be defined with or without alpha values. Color without alpha is RGB; color with alpha is stored as ARGB. Vertex data, material data, and texture data can be used to give objects transparency. The frame buffer also can be used to generate transparency effects.

The list below shows some special effects that can be created using alpha blending.

  • Vertex Alpha
  • Material Alpha
  • Texture Alpha
  • Frame Buffer Alpha
  • Render Target Alpha

The following samples demonstrate alpha blending.

  • Billboarding
  • Clouds, Smoke, and Vapor Trails
  • Fire, Flares, and Explosions


Vertex Alpha

Alpha data can be supplied in the vertex data. To enable vertex alpha, set the device's render state RenderStateManager.DiffuseMaterialSource to ColorSource.Color1 so that the Microsoft Direct3D runtime takes the diffuse value from the diffuse color rather than the material.

Alpha data can be added to a color component of a vertex. The following code creates two copies of a sphere mesh, adds a color component to the vertex definition, and specifies the color for each vertex. This code can be added to the GraphicsClass.InitializeDeviceObjects method generated by the DirectX 9.0 Visual C# Wizard to demonstrate the functionality.

          [C#]

// Create the sphere geometry.
rearSphere = Mesh.Sphere(device,1f,10,10);

// Copy the sphere, adding a diffuse color to the vertices.
sphere = rearSphere.Clone(MeshFlags.Managed,VertexFormats.PositionNormal | VertexFormats.Diffuse,device);

// Add the same color componant to the original sphere.
rearSphere = rearSphere.Clone(MeshFlags.Managed,VertexFormats.PositionNormal | VertexFormats.Diffuse,device);

// Lock the vertex buffer of the rearSphere to obtain the vertex information.
CustomVertex.PositionNormalColored[] Source =
               (CustomVertex.PositionNormalColored[])rearSphere.LockVertexBuffer(typeof(CustomVertex.PositionNormalColored),
                0,rearSphere.NumberVertices);

// Loop through the vertices, adding a red transparent color to each.
for(int x=0; x < (Source.GetLength(0)); x++)
{
   Source[x].Color = Color.FromArgb(0, 255, 0, 255).ToArgb();
}
rearSphere.UnlockVertexBuffer();

// Add a color component with alpha to the second sphere.
CustomVertex.PositionNormalColored[] Destination =
             (CustomVertex.PositionNormalColored[])sphere.LockVertexBuffer(typeof(CustomVertex.PositionNormalColored),
              0,rearSphere.NumberVertices);

// Instead of adding the same alpha value to each of the vertices,
// this code increments the value, creating a gradient effect across the sphere.
int num = 256/Destination.GetLength(0);
for(int x=0; x < (Destination.GetLength(0)); x++)
{
   Destination[x].Color = Color.FromArgb(150, 255, 255, num*x).ToArgb();
}
sphere.UnlockVertexBuffer();

The color alpha value that has been added into the vertices now can be used to draw the spheres with transparency. The following code sets up a rendering Device and draws sphere in front of rearSphere to demonstrate the transparency. This code can be added to the GraphicsClass.Render method generated by the DirectX 9.0 Visual C# Wizard to demonstrate the functionality. Place the code after the Device.Transform.Projection matrix is set.

          [C#]

// A StateBlock is used to reset the device to its former state after we draw transparency.
StateBlock sb = new StateBlock(device, StateBlockType.All);
sb.Capture();

// Use the diffuse vertex color as the DiffuseMaterialSource for color lighting calculations
// (as opposed to a material).
device.RenderState.DiffuseMaterialSource = ColorSource.Color1;

// Set up the device to render the alpha information.
device.RenderState.AlphaBlendEnable = true;
device.RenderState.SourceBlend = Blend.SourceColor;
device.RenderState.DestinationBlend = Blend.InvSourceAlpha;

// Translate the rearSphere so that it is drawn behind the sphere.
Matrix m2 = m;
m.Translate(0,0,2);
device.Transform.World = m;

rearSphere.DrawSubset(0);

// Rotate the sphere so we can see the gradient a little better.
device.Transform.World = m2;
Vector3 rot = new Vector3(90,0,0);
m2.RotateAxis(rot,-45);
device.Transform.World = m2;

sphere.DrawSubset(0);

// Restore the device to its original settings.
sb.Apply();

This code results in two transparent spheres, one slightly in front of the other.


Material Alpha

Alpha data also can be supplied in a material. To enable material alpha, set the diffuse material render state so that the runtime uses the material diffuse color components rather than the vertex diffuse color components, as shown in the following C# code.

          [C#]

// Enable material alpha.
device.RenderState.DiffuseMaterialSource = ColorSource.Material;

The following C# code initializes the material with an alpha value, and sets the material before drawing.

          [C#]

Material mtrl = new Material();
Color c = Color.FromArgb(127, 255, 0, 0);

mtrl.Diffuse = c;
mtrl.Ambient = c;
mtrl.Specular = c;
mtrl.Emissive = c;

device.Material = mtrl;


Texture Alpha

Alpha data also can be supplied by textures. The texture must first be created, and then the alpha values added to it. To render with the texture, set it to a texture stage and select the appropriate texture stage operation and operands. When draw is called, the primitive is rendered with transparency.

These steps are illustrated in the following C# code example.

          [C#]

// Declare a Device.
Device device = null

// Declare a global texture variable.
Texture texture = null;

// Initialize the device.
.
.
.

// Create an alpha texture.
texture = new Texture(device, 128, 128, 0, 0, Format.A8R8G8B8, Pool.Managed);

LoadGradient();

The Texture class sets up everything by creating an empty texture. After the texture resource is created, LoadGradient is called to load the alpha channel.

          [C#]

protected void LoadGradient()
{
    uint yGrad, xGrad;
    uint dx = 128;      // width
    uint dy = 128;      // height

    uint[] buffer = new uint[dy * dx];

    GraphicsStream gs = null;

    try
    {
        gs = texture.LockRectangle(0, LockFlags.Discard);

        for (uint y = 0; y < dy; y++)
        {
            uint offset = y * dx;
            yGrad = (uint)(((float)y / (float)dx) * 255.0f);

            for (uint x = 0; x < dx;)
            {
                xGrad = (uint)(((float)x / (float)dx) * 255.0f);

                uint b = (uint)(xGrad + (255 - yGrad)) / 2 & 0xFF;
                uint g = (uint)((255 - xGrad) + yGrad) / 2 & 0xFF;
                uint r = (uint)(xGrad + yGrad) / 2 & 0xFF;
                uint a = (uint)(xGrad + yGrad) / 2 & 0xFF;

                buffer[offset + x] = ((a << 24) + (r << 16) + (g << 8) + (b));
                x++;
            }
        }

        gs.Write(buffer);
        texture.UnlockRectangle(0);
    }
    catch(InvalidCallException)
    {
        return;
    }
}

The alpha value is calculated based on the current pixel's relative x/y position within the texture size.

Next, assign the texture to a texture stage and set up the texture stage.

          [C#]

 // Assign texture.
device.SetTexture(0, texture)

// Texture stage states.
device.TextureState[0].ColorOperation = TextureOperation.Modulate;
device.TextureState[0].ColorArgument1 = TextureArgument.TextureColor;
device.TextureState[0].ColorArgument2 = TextureArgument.Diffuse;

device.TextureState[0].AlphaOperation = TextureOperation.Modulate;
device.TextureState[0].AlphaArgument1 = TextureArgument.TextureColor;
device.TextureState[0].AlphaArgument2 = TextureArgument.Diffuse;

This code results in a primitive with a transparency gradient. The gradient is transparent where x = 0, and opaque where x is its maximum value.


Frame Buffer Alpha

Frame buffer alpha blending is a bit different than vertex alpha, material alpha, and texture alpha. Vertex, material, and texture alpha set transparency values that are used only for the current primitive, and by themselves have no effect on other primitives. Frame buffer alpha blending controls how the current primitive is combined with existing pixels in the frame buffer to yield a final pixel color.

When performing alpha blending, two colors are being combined: a source color and a destination color. The source color is from the transparent object, and the destination color is the color already at the pixel location. The destination color is the result of rendering some other object that is behind the transparent object; that is, the object that will be visible through the transparent object. Alpha blending uses the following formula to control the ratio between the source and destination objects.

Final Color = ObjectColor * SourceBlendFactor
                + PixelColor * DestinationBlendFactor

ObjectColor is the contribution from the primitive being rendered at the current pixel location. PixelColor is the contribution from the frame buffer at the current pixel location.

The following set of blend factors can be used.

Blend mode factor | Description
Zero | (0, 0, 0, 0)
One | (1, 1, 1, 1)
SourceColor | (Rs,Gs,Bs,As)
InvSourceColor | (1 - Rs, 1 - Gs, 1 - Bs, 1 - As)
SourceAlpha | (As, As, As, As)
InvSourceAlpha | (1 - As, 1 - As, 1 - As, 1 - As)
DestinationAlpha | (Ad, Ad, Ad, Ad)
InvDestinationAlpha | (1 - Ad, 1 - Ad, 1 - Ad, 1 - Ad)
DestinationColor | (Rd, Gd, Bd, Ad)
InvDestinationColor | (1 - Rd, 1 - Gd, 1 - Bd, 1 - Ad)
SourceAlphaSat | (f, f, f, 1); f = min(As, 1 - Ad)
BothSourceAlpha | Obsolete. To achieve the same effect, set the source and destination blend factors to SourceAlpha and InvSourceAlpha in separate calls.
BothInvSourceAlpha | Obsolete. To achieve the same effect, set the source and destination blend factors to SourceAlpha and InvSourceAlpha in separate calls. Source blend factor is (1 - As, 1 - As, 1 - As, 1 - As), and destination blend factor is (As, As, As, As); the destination blend selection is overridden. This blend mode is supported only if the RenderStateManager.SourceBlend property is set to true.
BlendFactor | Constant color blending factor used by the frame-buffer blender. Uses color.r, color.g, color.b, and color.a obtained from RenderStateManager.BlendFactor. This blend mode is supported only if the BlendCaps.SupportsBlendFactor property is set to true.
InvBlendFactor | Inverted constant color blending factor used by the frame-buffer blender. Uses 1-color.r, 1-color.g, 1-color.b, and 1-color.a obtained from RenderStateManager.BlendFactor. This blend mode is supported only if the BlendCaps.SupportsBlendFactor property is set to true.

Microsoft Direct3D uses RenderStateManager.AlphaBlendEnable to enable alpha transparency blending. The type of alpha blending that is done depends on the RenderStateManager.SourceBlend and RenderStateManager.DestBlend render states. Source and destination blend states are used in pairs. The following C# code fragment sets the source blend state to Blend.SourceColor and the destination blend state to Blend.InvSourceColor.

          [C#]

// This code fragment assumes that device is a
//   valid Device object.

// Enable alpha blending.
device.RenderState.AlphaBlendEnable = true;

// Set the source blend state.
device.RenderState.SourceBlend = Blend.SourceColor;

// Set the destination blend state.
device.RenderState.DestBlend = Blend.InvSourceColor;

This code performs a linear blend between the source color (the color of the primitive being rendered at the current location) and the destination color (the color at the current location in the frame buffer). The resulting appearance is similar to tinted glass in that some of the color of the destination object seems to be transmitted through the source object; the rest of it appears to be absorbed.

Many of these blend factors require alpha values in the texture to operate correctly. Thus, when using vertex or material alpha, the application is restricted as to which modes produce interesting results.


Render Target Alpha

The frame buffer blender can now blend alpha channels independently of color-channel blending on render targets. This control is enabled with a new render state, RenderStateManager.SeparateAlphaBlendEnabled.

When RenderStateManager.SeparateAlphaBlendEnabled is set to false (which is the default condition), the render-target blending factors and operations applied to alpha are the same as those defined for blending color channels. A driver needs to set the MiscCaps.SupportsSeparateAlphaBlend cap to indicate that it can support render-target alpha blending. Be sure to set RenderStateManager.AlphaBlendEnable to tell the pipeline that alpha blending is needed.

To control the factors in the alpha channel of the render-target blenders, the following new render states are defined.

  • RenderStateManager.AlphaDestinationBlend
  • RenderStateManager.AlphaSourceBlend

Like RenderStateManager.SourceBlend and RenderStateManager.DestinationBlend, these states can be set to one of the values in the Blend enumeration. The source and destination blend settings can be combined in several ways, depending on the settings of the BlendCaps object set in Caps.DestinationBlendCaps and Caps.SourceBlendCaps.

The alpha blending is done as follows:

renderTargetAlpha = (alphain* srcBlendOp) BlendOp (alphart* destBlendOp)

Where:

  • alphain is the input alpha value.
  • srcBlendOp is one of the blend factors in Blend.
  • BlendOp is one of the blend factors in Blend.
  • alphart is the render-target alpha value.
  • destBlendOp is one of the blend factors in Blend.
  • renderTargetAlpha is the final blended alpha value.


Alpha Examples

Alpha blending is used to display an image that has transparent or semi-transparent pixels. In addition to a red, green, and blue color channel, each pixel in an alpha bitmap has a transparency component known as its alpha channel. The alpha channel typically contains as many bits as a color channel. For example, an 8-bit alpha channel can represent 256 levels of transparency, from 0 (meaning the entire pixel is transparent) to 255 (meaning the entire pixel is opaque). The list below shows some special effects that can be created using alpha blending.

  • Billboarding
  • Clouds, Smoke, and Vapor Trails
  • Fire, Flares, and Explosions


Billboarding

When creating 3-D scenes, an application can sometimes gain performance advantages by rendering 2-D objects in a way that makes them appear to be 3-D. This is the basic idea behind the technique of billboarding.

A billboard in the normal sense of the word is a sign along a roadway. Microsoft Direct3D applications can create and render this type of billboard by defining a rectangular solid and applying a texture to it. Billboarding in the more specialized sense of 3-D graphics is an extension of this. The goal is to make 2-D objects appear to be 3-D, and the technique is to apply a texture that contains the object's image to a rectangular primitive. The primitive is rotated so that it always faces the user. It does not matter if the object's image is not rectangular. Portions of the billboard can be made transparent, so the parts of the billboard image that you do not want seen are not visible.

Many games employ billboarding for animated sprites. For instance, when the user is moving through a 3-D maze, he or she may see weapons or rewards that can be picked up. These are typically 2-D images textured on a rectangular primitive. Billboarding often is used in games to render images of trees, bushes, and clouds.

When an image is applied to a billboard, the rectangular primitive first must be rotated so that the resulting image faces the user. The application then must translate it into position, after which it can apply a texture to the primitive.

Billboarding works best for symmetrical objects, especially objects that are symmetrical along the vertical axis. It also requires that the altitude of the viewpoint does not increase too much. If the user is allowed to view the billboarded object from above, it becomes readily apparent that the object is 2-D rather than 3-D.


Clouds, Smoke, and Vapor Trails

Clouds, smoke, and vapor trails all can be created by an extension of the billboarding technique (see Billboarding). By rotating the billboard on two axes instead of one, an application can enable the user to view a billboard from any angle. Typically, an application rotates the billboard on the horizontal and vertical axes.

To make a simple cloud, an application can rotate a rectangular primitive on one or two axes so that the primitive faces the user. A cloud-like texture then can be applied to the primitive with transparency. The cloud can be animated by applying a series of textures over time.

An application can create more complex clouds by forming them from a group of primitives. Each part of the cloud is a rectangular primitive. The primitives can be moved independently over time to give the appearance of a dynamic mist. This concept is illustrated in the following figure.

Formation from a group of primitives

The appearance of smoke is displayed in a manner similar to clouds. It typically requires multiple billboards, like complex clouds. Smoke usually billows and rises over time, so the billboards that make up the smoke plume need to move accordingly. More billboards might need to be added as the plume rises and disperses.

A vapor trail is a smoke plume that does not rise. However, like a smoke plume, it disperses over time. The following figure illustrates the technique of using billboards to simulate a vapor trail.


Fire, Flares, and Explosions

Microsoft Direct3D can be used to simulate natural phenomena involving energy releases. For instance, an application can generate the appearance of fire by applying flame-like textures to a set of billboards. This is especially effective if the application uses a sequence of fire textures to animate the flames on each billboard in the fire. Varying the speed of the animation playback from billboard to billboard increases the appearance of real flames. The semblance of intermingled 3-D flames can be achieved by layering the billboards and the textures on the billboards.

Flares and flashes can be simulated by applying successively brighter light maps to all primitives in a scene. Although this technique is high in computational overhead, it allows an application to simulate a localized flare or flash. That is, the portion of the scene where the flare or flash originates can brighten first.

Another technique is to position a billboard in front of the scene so that the entire render target area is covered. The application applies successively whiter textures to the billboard and decreases the transparency over time. The entire scene fades to white as time passes. This is a low-overhead method of creating a flare. However, using this technique, it can be difficult to generate the appearance of a bright flash from a single point light source.

Explosions can be displayed in a 3-D scene procedure similar to those used for fire, flashes, and flares. For instance, an application might use a billboard to display a shock wave and rising plume of smoke when the explosion occurs. At the same time, the application can use a set of billboards to simulate flames. In addition, it can position a single billboard in front of the scene to add a flare of light to the entire scene.

Energy beams can be simulated using billboards. The application also can display them using primitives that are defined as line lists or line strips. For more information, see Line Lists and Line Strips.

An application can create force fields using billboards or primitives defined as triangle lists. To create a force field from triangle lists, define a set of disjoint triangles in a triangle list equally spaced over the region covered by the force field. The gaps between the triangles allow the user to see the scene behind the triangles, as might be expected when looking at a force field. Apply a texture to the triangle list that gives the triangles the appearance of glowing with energy. For more information, see Triangle Lists.


Direct3D Surfaces

A surface represents a linear area of display memory. Surfaces usually reside in the display memory of the display card, although they can exist in system memory. They are managed by the Surface class.

Familiarity with the following terms is necessary to understand surfaces.

  • front buffer. A rectangle of memory that is translated by the graphics adapter and displayed on the monitor. In Microsoft Direct3D, an application never writes directly to the front buffer.
  • back buffer. A rectangle of memory that an application can directly write to. The back buffer is never directly displayed on the monitor.
  • flipping surfaces. The process of moving the back buffer to the front buffer.
  • swap chain. A collection of one or more back buffers that can be serially presented to the front buffer.

Getting a Surface

To create a surface, call any of the following methods.

  • Device.CreateDepthStencilSurface
  • Device.CreateOffscreenPlainSurface
  • Device.CreateRenderTarget

Surface formats determine how data for each pixel in surface memory is interpreted. Direct3D uses the Format property of the SurfaceDescription structure to describe the surface format. The SurfaceDescription structure of an existing surface can be retrieved via its Surface.Description property.

Once a surface is created, a pointer to it can be obtained by calling any of the following methods.

  • CubeTexture.GetCubeMapSurface
  • Device.GetBackBuffer
  • Device.DepthStencilSurface
  • Device.GetFrontBufferData
  • Device.GetRenderTarget
  • SwapChain.GetBackBuffer
  • Texture.GetSurfaceLevel

The Surface class enables indirect access to memory through the UpdateSurface method. This method allows the copying of a rectangular region of pixels from one UpdateSurface class to another. The UpdateSurface class also has methods to directly access display memory. For example, the Surface.LockRectangle method can be used to lock a rectangular region of display memory. It is important to call Surface.UnlockRectangle after working with the locked rectangular region on the surface.

Additional Surface Topics

The following topics provide information about how to use surfaces.

  • Surface Formats
  • What is a Swap Chain?
  • Width vs. Pitch
  • Flipping Surfaces
  • Page Flipping and Back Buffering
  • Copying to Surfaces
  • Copying Surfaces
  • Accessing Surface Memory Directly
  • Private Surface Data
  • Gamma Controls


Surface Formats

In Microsoft Direct3D, all two-dimensional (2-D) images are represented by a linear range of memory called a surface. A surface can be thought of as a 2-D array in which each element holds a color value that represents a small section of the image, called a pixel. An image's detail level is defined both by the number of pixels needed to represent the image and the number of bits needed for the image's color spectrum. For example, an image that is 800 pixels wide by 600 pixels tall with 32 bits of color for each pixel (written as 800x600x32) is more detailed then an image that is 640 pixels wide by 480 pixels tall with 16 bits of color for each pixel (written as 640x480x16). Likewise, the more detailed image requires a larger surface to store the data. For an 800x600x32 image, the surface's array dimensions are 800x600, and each element holds a 32-bit value to represent its color.

All surfaces have a size and store a specific number of bits that represent color. These bits are separated into individual color elements: red, green, and blue. In Microsoft DirectX 9.0 for Managed Code, all color elements are defined by the Format enumeration. A color format is broken down into the number of byes reserved for each color. For example, a 16-bit color format is defined as Format.R5G6B5, where five bits are reserved for red (R), six bits for green (G), and five bits for blue (B).

All formats are listed from left to right, most significant bit (MSB) to least significant bit (LSB). For example, ARGB is ordered from the MSB channel A (alpha) to the LSB channel B (blue). During traversal of surface data, the data is stored in memory from LSB to MSB, which means that the channel order in memory is from LSB (blue) to MSB (alpha).

The default value for formats that contain undefined channels is 1. The only exception is the A8 format, which is initialized to 000 for the three color channels.

Unsigned Formats

Data in an unsigned format must be positive. Unsigned formats use combinations of (R)ed, (G)reen, (B)lue, (A)lpha, (L)uminance, and (P)alette data. Palette data is also referred to as color-indexed data because the data is used to index a color palette.

Unsigned format flags | Format
R8G8B8 | A 24-bit RGB pixel format that uses 8 bits per channel.
A8R8G8B8 | A 32-bit ARGB pixel format, with alpha, that uses 8 bits per channel.
X8R8G8B8 | A 32-bit RGB pixel format in which 8 bits are reserved for each color.
R5G6B5 | A 16-bit RGB pixel format that uses 5 bits for red, 6 bits for green, and 5 bits for blue.
X1R5G5B5 | A 16-bit pixel format in which 5 bits are reserved for each color.
A1R5G5B5 | A 16-bit pixel format in which 5 bits are reserved for each color and 1 bit is reserved for alpha.
A4R4G4B4 | A 16-bit ARGB pixel format that uses 4 bits for each channel.
R3G3B2 | An 8-bit RGB texture format that uses 3 bits for red, 3 bits for green, and 2 bits for blue.
ii | An 8-bit format that uses alpha only.
A8R3G3B2 | A 16-bit ARGB texture format that uses 8 bits for alpha, 3 bits each for red and green, and 2 bits for blue.
X4R4G4B4 | A 16-bit RGB pixel format that uses 4 bits for each color.
A2B10G10R10 | A 32-bit pixel format that uses 10 bits for each color and 2 bits for alpha.
A8B8G8R8 | A 32-bit ARGB pixel format, with alpha, that uses 8 bits per channel.
X8B8G8R8 | A 32-bit RGB pixel format in which 8 bits are reserved for each color.
G16R16 | A 32-bit pixel format that uses 16 bits each for green and red.
A2R10G10B10 | A 32-bit pixel format that uses 10 bits each for red, green, and blue, and 2 bits for alpha.
A16B16G16R16 | A 64-bit pixel format that uses 16 bits for each component.
A8P8 | An 8-bit color format indexed with 8 bits of alpha.
P8 | An 8-bit color indexed format.
L8 | An 8-bit luminance-only format.
L16 | A 16-bit luminance-only format.
A8L8 | A 16-bit format that uses 8 bits each for alpha and luminance.
A4L4 | An 8-bit format that uses 4 bits each for alpha and luminance.

Signed Formats

Data in a signed format can be both positive and negative. Signed formats use combinations of (U), (V), (W), and (Q) data.

Signed-format flags | Format
V8U8 | A 16-bit bump-map format that uses 8 bits each for U and V data.
Q8W8V8U8 | A 32-bit bump-map format that uses 8 bits for each channel.
V16U16 | A 32-bit bump-map format that uses 16 bits for each channel.
Q16W16V16U16 | A 64-bit bump-map format that uses 16 bits for each component.
CxV8U8 | A 16-bit normal compression format. The texture sampler computes the C channel from C = sqrt(1 - U2 - V2).

Mixed Formats

Data in mixed formats can contain a combination of signed and unsigned data.

Mixed-format flags | Format
L6V5U5 | A 16-bit bump-map format, with luminance, that uses 6 bits for luminance and 5 bits each for v and u data.
X8L8V8U8 | A 32-bit bump-map format, with luminance, that uses 8 bits for each channel.
A2W10V10U10 | A 32-bit bump-map format that uses 2 bits for alpha and 10 bits each for w, v, and u data.

FOURCC Formats

Data in a four-character code (FOURCC) format is compressed.

MAKEFOURCC

The enumerated value of the following formats is based on a number generated by combining several integer values. This allows hardware designers to use custom enumerated values that are not explicitly listed here to indicate a FOURCC format.

The following C# code fragment generates FOURCC codes.

          [C#]

static int MakeFourCC(int ch0, int ch1, int ch2, int ch3)
{
   return ((int)(byte)(ch0)|((int)(byte)(ch1) << 8)| ((int)(byte)(ch2) << 16) | ((int)(byte)(ch3) << 24));
}

The defined FOURCC formats are as follows.

FOURCC flags | Value | Format
Multi2Argb8 | MakeFourCC('M','E','T','1') | MultiElement texture (not compressed).
G8R8G8B8 | MakeFourCC('G', 'R', 'G', 'B') | A 16-bit packed RGB format that is analogous to YUY2 (Y0U0, Y1V0, Y2U2, etc.). It requires a pixel pair to properly represent the color value. The first pixel in the pair contains 8 bits of green (in the high 8 bits) and 8 bits of red (in the low 8 bits). The second pixel contains 8 bits of green (in the high 8 bits) and 8 bits of blue (in the low 8 bits). The two pixels share the red and blue components, while each has a unique green component (G0R0, G1B0, G2R2, etc.). When looking up into a pixel shader, the texture sampler does not normalize the colors; they remain in the range of 0.0f to 255.0f. This is true for all programmable pixel shader models. For the fixed-function pixel shader, the hardware should normalize to the 0.f to 1.f range and treat it as the YUY2 texture. Hardware that exposes this format must have the Caps.PixelShader1xMaxValue member set to a value capable of handling that range.
R8G8B8G8 | MakeFourCC('R', 'G', 'B', 'G') | A 16-bit packed RGB format that is analogous to UYVY (U0Y0, V0Y1, U2Y2, etc.). It requires a pixel pair ito properly represent the color value. The first pixel in the pair contains 8 bits of green (in the low 8 bits) and 8 bits of red (in the high 8 bits). The second pixel contains 8 bits of green (in the low 8 bits) and 8 bits of blue (in the high 8 bits). The two pixels share the red and blue components, while each has a unique green component (R0G0, B0G1, R2G2, etc.). When looking up into a pixel shader, the texture sampler does not normalize the colors; they remain in the range of 0.0f to 255.0f. This is true for all programmable pixel shader models. For the fixed-function pixel shader, the hardware should normalize to the 0.f to 1.f range and treat it as the YUY2 texture. Hardware that exposes this format must have the Caps.PixelShader1xMaxValue member set to a value capable of handling that range.
Dxt1 | MakeFourCC('D', 'X', 'T', '1') | DXT1 compression texture format.
Dxt2 | MakeFourCC('D', 'X', 'T', '2') | DXT2 compression texture format.
Dxt3 | MakeFourCC('D', 'X', 'T', '3') | DXT3 compression texture format.
DXT4 | MakeFourCC('D', 'X', 'T', '4') | DXT4 compression texture format.
Dxt5 | MakeFourCC('D', 'X', 'T', '5') | DXT5 compression texture format.
Uyvy | MakeFourCC('U', 'Y', 'V', 'Y') | UYVY format (PC98 compliance).
Yuy2 | MakeFourCC('Y', 'U', 'Y', '2') | YUY2 format (PC98 compliance).

Buffer Formats

Depth, stencil, vertex, and index buffers each have unique formats.

Buffer flags | Format
D16Lockable | A 16-bit z-buffer bit depth.
D32 | A 32-bit z-buffer bit depth.
D15S1 | A 16-bit z-buffer bit depth in which 15 bits are reserved for the depth channel and 1 bit is reserved for the stencil channel.
D24S8 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 8 bits for the stencil channel.
D24X8 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel.
D24X4S4 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 4 bits for the stencil channel.
D32SingleLockable | A lockable format in which the depth value is represented as a standard Institute of Electrical and Electronics Engineers (IEEE) floating-point number.
D24SingleS8 | A nonlockable format that contains 24 bits of depth (in a 24-bit floating-point format - 20e4) and 8 bits of stencil.
D16 | A 16-bit z-buffer bit depth.
VertexData | Describes a vertex buffer surface.

All depth stencil formats except D16Lockable indicate no particular bit ordering per pixel, and the driver is allowed to consume more than the indicated number of bits per depth channel (but not per stencil channel).

Floating-Point Formats

These flags are used for floating-point surface formats. They use 16 bits per channel and are also known as s10e5 formats.

Floating-point flags | Format
R16F | A 16-bit floating-point format that uses 16 bits for the red channel.
G16R16F | A 32-bit floating-point format that uses 16 bits each for the red and green channels.
A16B16G16R16F | A 64-bit floating-point format that uses 16 bits for each channel (alpha, blue, green, and red).

IEEE Formats

These flags are used for floating-point surface formats. They use 32 bits per channel and are also known as s23e8 formats.

Floating-point flags | Format
R32F | A 32-bit floating-point format that uses 32 bits for the red channel.
G32R32F | A 64-bit floating-point format that uses 32 bits each for the red and green channels.
A32B32G32R32F | A 128-bit floating-point format that uses 32 bits for each channel (alpha, blue, green, and red).

Other

This flag is used for undefined formats.

Other flags | Format
Unknown | Surface format is unknown.

BackBuffer or Display Formats

These formats are the only valid formats for a back buffer or a display.

Format | Back buffer | Display
A2R10G10B10 | x | x (full-screen mode only)
A8R8G8B8 | x |
X8R8G8B8 | x | x
A1R5G5B5 | x |
X1R5G5B5 | x | x
R5G6B5 | x | x

Remarks

The order of the bits starts with the most significant byte, so A8L8 indicates that the high byte of this 2-byte format is alpha. The D16 format indicates a 16-bit integer value and an application-lockable surface.

Pixel formats have been chosen to enable the expression of extension formats defined by hardware vendors, and to include the well-established FOURCC method. The set of formats understood by the Direct3D runtime is defined by the Caps structure.

Note that formats are supplied by independent hardware vendors (IHVs), and many FOURCC codes are not listed. The formats in this enumeration are unique in that they are sanctioned by the runtime, which means that the reference rasterizer operates on all of these types. Formats supplied by IHVs are supported by the individual vendors on a card-by-card basis.

Related Topics

  • Format Enumeration


What is a Swap Chain?

A graphics adapter holds a pointer to a surface that represents the image being displayed on the monitor, called a front buffer. As the monitor is refreshed, the graphics card sends the contents of the front buffer to the monitor to be displayed. However, this leads to a problem when rendering real-time graphics. The heart of the problem is that monitor refresh rates are very slow in comparison to the rest of the computer. Common refresh rates range from 60Hz (60 times per second) to 100Hz. If an application is updating the front buffer while the monitor is in the middle of a refresh, the image that is displayed is cut in half, with the upper half of the display containing the old image and the lower half containing the new image. This problem is referred to as tearing.

Microsoft Direct3D implements two ways to avoid tearing: An option that allows updates of the monitor only on the vertical retrace (or vertical sync) operation, or a technique called back buffering. A monitor refreshes its image by sweeping the electron beam of the cathode ray tube (CRT) in a zigzag pattern, starting at the top left of the monitor and ending at the bottom right. When the scanning beam reaches the bottom, the monitor recalibrates the electron beam by moving it back to the upper left so that the process can start again. This recalibration is called a vertical sync. During a vertical sync, the monitor is not drawing anything, so any update to the front buffer will not be seen until the monitor starts to draw again. The vertical sync is relatively slow, but not slow enough to render a complex scene while waiting. What is needed to avoid tearing and to be able to render complex scenes is the process of back buffering.

Back buffering is the process of drawing a scene to an off-screen surface, called a back buffer. Note that any surface other than the front buffer is called an off-screen surface because it is never directly viewed by the monitor. By using a back buffer, an application has the freedom to render a scene whenever the system is idle (that is, no windows messages are waiting) without having to consider the monitor's refresh rate. Back buffering brings an additional complication of how and when to move the back buffer to the front buffer.

The process of moving the back buffer to the front buffer is called surface flipping. Remember that the graphics card simply uses a pointer to a surface to represent the front buffer. Because of this, a simple pointer change is all that is needed to set the back buffer to the front buffer. When an application asks Direct3D to present the back buffer to the front buffer, Direct3D simply flips the two surface pointers. The result is that the back buffer is now the new front buffer, and the old front buffer is the new back buffer. A surface flip is invoked whenever an application asks the Direct3D device to present the back buffer; however, Direct3D can be set up to queue the requests until a vertical sync occurs. This option is referred to as the Direct3D device's presentation interval. Note that the data in the new back buffer might not be reusable, depending on how an application specifies how Direct3D should handle surface flipping. Surface flipping is key in multimedia, animation, and game software. It is equivalent to the way that animation can be done with a pad of paper. On each page, the artist changes the figures slightly, so that when you flip rapidly between sheets, the drawing appears animated.

Related Topics

  • Flipping Surfaces


Width vs. Pitch

Although the terms width and pitch are often used interchangeably, their meanings are distinctly different. It is important to understand these meanings, and how to interpret the values that Microsoft Direct3D uses to describe them.

Direct3D uses the SurfaceDescription structure to carry information that describes a surface. Among other things, this structure is defined to contain information about a surface's dimensions, as well as how those dimensions are represented in memory. The structure uses the Height and Width members to describe the logical dimensions of the surface. Both members are measured in pixels. Therefore, the Height and Width values for a 640x480 surface are the same whether it is an 8-bit surface or a 24-bit RGB surface.

When a surface is locked using the Surface.LockRectangle method, and depending on the method overload called, the method returns either a GraphicsStream object or an Array Leave Site filled with the surface data. The pitch of the surface is passed back in the pitch parameter. The value returned in the pitch parameter describes the surface's memory pitch, also called stride. Pitch is the distance, in bytes, between two memory addresses that represent the beginning of one bitmap line and the beginning of the next bitmap line. Because pitch is measured in bytes rather than pixels, a 640x480x8 surface has a very different pitch value than a surface with the same dimensions but a different pixel format. Additionally, the pitch value sometimes reflects bytes that Direct3D has reserved as a cache, so it is not safe to assume that pitch is simply the width multiplied by the number of bytes per pixel. Rather, visualize the difference between width and pitch as shown in the following illustration.

Pitch and width difference

In this figure, the front buffer and back buffer are both 640x480x8, and the cache is 384x480x8.

When accessing surfaces directly, take care to stay within the memory allocated for the dimensions of the surface and stay out of any memory reserved for cache. Also, when locking only a portion of a surface, you must stay within the rectangle you specify when locking the surface. Failure to follow these guidelines will lead to unpredictable results. When rendering directly into surface memory, always use the pitch returned by the Surface.LockRectangle method. Do not assume a pitch based solely on the display mode. If your application works on some display adapters but looks garbled on others, this may be the cause of the problem.

Related Topics

  • Accessing Surface Memory Directly


Flipping Surfaces

A Microsoft Direct3D application typically displays an animated sequence by generating the frames of the animation in back buffers and presenting them in sequence. Back buffers are organized into swap chains. A swap chain is a series of buffers that flip to the screen one after another. A swap chain can be used to render one scene in memory and then flip the scene to the screen when rendering is complete. This prevents the phenomenon known as tearing, and allows for smoother animation.

Each device created in Direct3D has at least one swap chain. When you initialize the first Direct3D device, you set the BackBufferCount member of the PresentParameters structure, which tells Direct3D the number of back buffers that will be in the swap chain. The Device constructor then creates the Direct3D device and corresponding swap chain.

When you use the Device.Present method to request a surface flip operation, the pointers to surface memory for the front buffer and back buffers are swapped. Flipping is performed by switching pointers that the display device uses for referencing memory, not by copying surface memory. When a flipping chain contains a front buffer and more than one back buffer, the pointers are switched in a circular pattern, as shown in the following illustration.

Additional swap chains for a device can be created by calling the SwapChain constructor. An application can create one swap chain per view and associate each swap chain with a particular window. The application renders images in the back buffers of each swap chain, and then presents them individually. The two parameters that SwapChain takes are a reference to a PresentParameters object and a valid Device object. The SwapChain.Present method can then be used to display the contents of the next back buffer to the front buffer. Note that a device can have only one full-screen swap chain.

To gain access to a specific back buffer, call the Device.GetBackBuffer or SwapChain.GetBackBuffer method, which returns a Surface object that represents the returned back buffer surface.

Remember that Direct3D flips surfaces by swapping surface memory pointers within the swap chain, not by swapping the surfaces themselves. This means that you will always render to the back buffer that will be displayed next.

It is important to note the distinction between a "flipping operation" as performed by a display adapter driver, and a "present" operation applied to a swap chain that was created with SwapEffect.Flip.

The term flip conventionally denotes an operation that alters the range of video memory addresses that a display adapter uses to generate its output signal, thus causing the contents of a previously hidden back buffer to be displayed. In Microsoft DirectX 9.0, the term is often used more generally to describe the presentation of a back buffer in any swap chain created with the SwapEffect.Flip swap effect.

While such "present" operations are almost invariably implemented by flip operations when the swap chain is a full-screen one, they are necessarily implemented by copy operations when the swap chain is windowed. Furthermore, a display adapter driver can use flipping to implement "present" operations against full-screen swap chains based on SwapEffect.Discard and SwapEffect.Copy.

For a more general discussion of the different swap effects for both windowed and full-screen swap chains, see SwapEffect.


Page Flipping and Back Buffering

Page flipping is key in multimedia, animation, and game software. It is similar to the way that animation is done with a pad of paper; that is, on each page, the artist changes the figure slightly, so that when you flip rapidly between sheets, the drawing appears to be animated.

Microsoft Direct3D implements page flipping functionality through a swap chain, which is a property of the device. Initially, you set up a series of Direct3D buffers that flip to the screen in the way that the artist's paper flips to the next page. The first buffer is referred to as the color front buffer. The buffers behind it are called back buffers. Your application writes to a back buffer and then flips the color front buffer so that the back buffer appears on screen. While the system displays the image, the software is again writing to a back buffer. The process continues as long as the animation, and enables you to animate images efficiently.

Direct3D makes it easy to set up page flipping schemes, from simple double-buffered schemes (that is, a color front buffer with one back buffer) to more sophisticated schemes with multiple back buffers.


Copying to Surfaces

Several restrictions apply when using Device.UpdateSurface to copy to a surface. You can pass a rectangle on the source surface, or use null to specify the entire surface. You can also pass a point on the destination surface to which the upper left position of the rectangle on the source image is copied.

The Device.UpdateSurface method does not support clipping. Unless the source rectangle and the corresponding destination rectangle are completely contained within the source and destination surfaces respectively, the operation will fail. Note that the destination and source surfaces must be distinct. The method also does not support alpha blending, color keys, or format conversion.

The following methods also are available for copying images to a Microsoft Direct3D surface.

  • SurfaceLoader.FromFile
  • SurfaceLoader.FromStream
  • SurfaceLoader.FromSurface

Related Topics

  • Device.StretchRectangle


Copying Surfaces

The term blit is shorthand for "bit block transfer," which is the process of transferring blocks of data from one place to another in memory. The blitting device driver interface (DDI) continues to be used in Microsoft DirectX 9.0 as the primary mechanism for moving large rectangles of pixels on a per-frame basis, the mechanism behind the copy-oriented Device.Present method. The transportation of artwork in the blit operation is performed by the Device.UpdateTexture method. Artwork also can be copied in DirectX 9.0 by using the Device.UpdateSurface method, which copies a rectangular subset of pixels.

Related Topics

  • Device.StretchRectangle


Accessing Surface Memory Directly

Surface memory can be accessed directly by using the Surface.LockRectangle method. When this method is called, the rect parameter is a reference to a Rectangle Leave Site structure that describes the rectangle on the surface to access directly. To request that the entire surface be locked, either call one of the Surface.LockRectangle overloads that do not take a Rectangle Leave Site structure, or set the rect parameter to the dimensions of the entire surface. It is also possible to specify a Rectangle Leave Site that covers only a portion of the surface. Providing that no two rectangles overlap, two threads or processes can simultaneously lock multiple rectangles in a surface. Note that a multisample back buffer cannot be locked.

Depending on which Surface.LockRectangle method overload is called, the method returns either a GraphicsStream object or an Array Leave Site that describes the locked region. The method call returns the pitch value in the pitch parameter. When access to the surface memory is finished, the Surface.UnlockRectangle method should be called to unlock it.

While a surface is locked, its contents can be manipulated directly. The following list provides some tips for avoiding common problems associated with directly rendering surface memory.

  • Never assume a constant display pitch. Always examine the pitch information returned by the Surface.LockRectangle method. This pitch can vary for a number of reasons, including the location of the surface memory, the display card type, or even the version of the Microsoft Direct3D driver. For more information, see Width vs. Pitch.
  • Be sure to copy to unlocked surfaces. Direct3D copy methods will fail if called on a locked surface.
  • Limit the application's activity while a surface is locked.
  • A surface cannot be locked if it belongs to a resource assigned to the Pool.Default memory pool, unless it is a dynamic texture or was created using Device.CreateOffscreenPlainSurface. Back buffer surfaces, which can be accessed using the Device.GetBackBuffer and SwapChain.GetBackBuffer methods, can be locked only if the swap chain was created with the PresentFlag property of the PresentParameters structure set to PresentFlag.LockableBackBuffer.


Private Surface Data

Any kind of application-specific data can be stored with a surface. For example, a surface that represents a map in a game might contain information about terrain.

A surface can have more than one private data buffer. Each buffer is identified by a globally unique identifier (GUID) that you supply when attaching the data to the surface.

To store private surface data, use Surface.SetPrivateData (inherited from the Resource class), passing an application-defined GUID for the data, and a Byte Leave Site array that contains the private data to associate with the surface. Data is passed by value, and multiple sets can be associated with a single resource.

The SetPrivateData method allocates an internal buffer for the data and copies it. Once this is done, it is safe to free the source buffer or object. The internal buffer is released when FreePrivateData is called. This occurs automatically when the surface is freed.

To retrieve private data for a surface, declare a Byte Leave Site array and then call the Surface.GetPrivateData method (also inherited from the Resource class), passing the GUID that was assigned to the data to populate the array.


Gamma Controls

Gamma controls allow you to change how the system displays the contents of the surface, without affecting those contents. Think of these controls as very simple filters that Microsoft Direct3D applies to data as it leaves a surface and before it is rendered on the screen.

Gamma controls are a property of a swap chain. They make it possible to dynamically change how a surface's red, green, and blue levels map to the actual levels that the system displays. By setting gamma levels, you can cause the user's screen to flash colors—red when the user's character is shot, green when the character picks up a new item, and so on—without copying new images to the frame buffer to achieve the effect. Or, you might adjust color levels to apply a color bias to the images in the back buffer.

There is always at least one swap chain (the implicit swap chain) for each device because Direct3D for Microsoft DirectX 9.0 has one swap chain as a property of the device. Because the gamma ramp is a property of the swap chain, the gamma ramp can be applied when the swap chain is windowed. The gamma ramp takes effect immediately; there is no waiting for a vertical sync operation.

The Device.SetGammaRamp and Device.GetGammaRamp methods allow manipulation of ramp levels that affect the red, green, and blue color components of pixels from the surface before they are sent to the digital-to-analog converter (DAC) for display.

Gamma Ramp Levels

In Direct3D, the term gamma ramp describes a set of values that map the level of a particular color component—red, green, blue—for all pixels in the frame buffer to new levels that are received by the DAC for display. The remapping is performed by way of three look-up tables, one for each color component.

Here's how it works: Direct3D takes a pixel from the frame buffer and evaluates its individual red, green, and blue color components. Each component is represented by a value from 0 to 65535. Direct3D takes the original value and uses it to index a 256-element array (the ramp), where each element contains a value that replaces the original one. Direct3D performs this look-up and replace process for each color component of each pixel in the frame buffer, thereby changing the final colors for all of the on-screen pixels.

It is handy to visualize the ramp values by graphing them. In the following illustration, the left graph shows a ramp that does not modify colors at all. The right graph shows a ramp that imposes a negative bias to the color component to which it is applied.

The array elements for the graph on the left contain values identical to their index—0 in the element at index 0, and 65535 at index 255. This type of ramp is the default, as it does not change the input values before they are displayed. The right graph provides more variation; its ramp contains values that range from 0 in the first element to 32768 in the last element, with values ranging uniformly in between. The effect is that the color component that uses this ramp appears muted on the display. You are not limited to using linear graphs; your application can assign arbitrary mapping if needed. You can even set the entries to all zeroes to completely remove a color component from the display.

Setting and Retrieving Gamma Ramp Levels

Gamma ramp levels are effectively look-up tables that Direct3D uses to map the frame buffer color components to new levels that will be displayed. You can set and retrieve ramp levels for the primary surface by calling the Device.SetGammaRamp and Device.GetGammaRamp methods.

The Device.SetGammaRamp method accepts three parameters and the Device.GetGammaRamp method accepts one parameter. For Device.SetGammaRamp, the first parameter is an integer that specifies the swap chain. The second parameter, calibrate, is a Boolean value that controls whether gamma correction should be applied. The third parameter, ramp, is a GammaRamp structure that contains three 256-element arrays of short integers, one array each to contain the red, green, and blue gamma ramps. The Device.GetGammaRamp method has one parameter that takes an integer representing the swap chain that contains the GammaRamp to retrieve.

You can set the calibrate parameter of the Device.SetGammaRamp method to true to invoke the calibrator when setting new gamma levels. Calibrating gamma ramps incurs some processing overhead, and should not be used frequently. Setting a calibrated gamma ramp provides a consistent and absolute gamma value for the user, regardless of the display adapter and monitor.

Not all systems support gamma calibration. To determine whether it is supported, call Manager.GetDeviceCaps and examine the DriverCaps member of the returned Caps structure. If the DriverCaps.CanCalibrateGamma property is set to true, gamma calibration is supported.

When setting new ramp levels, keep in mind that that the levels you set in the arrays are used only when your application is in full-screen exclusive mode. Whenever your application changes to normal mode, the ramp levels are set aside, taking effect again when the application reinstates full-screen mode.

If the device does not support gamma ramps in the swap chain's current presentation mode (full-screen or windowed), no error value is returned. Applications can check the DriverCaps.SupportsFullscreenGamma and DriverCaps.CanCalibrateGamma properties to determine the capabilities of the device and whether a calibrator is installed.


Direct3D Textures

Textures are a powerful tool for creating realism in computer-generated 3-D images. Microsoft DirectX 9.0 for Managed Code supports an extensive texturing feature set, giving developers access to advanced texturing techniques.

This section provides an introduction to textures.

  • Basic Texturing Concepts


Basic Texturing Concepts

Early computer-generated 3-D images, although generally advanced for their time, tended to have a shiny plastic look. They lacked the types of markings—such as scuffs, cracks, fingerprints, and smudges—that give 3-D objects realistic visual complexity. In recent years, textures have gained popularity among developers as a tool for enhancing the realism of computer-generated 3-D images.

In its everyday use, the word texture refers to an object's smoothness or roughness. In computer graphics, however, a texture is a bitmap of pixel colors that give an object the appearance of texture.

Because Microsoft Direct3D textures are bitmaps, any bitmap can be applied to a Direct3D primitive. For instance, applications can create and manipulate objects that appear to have a wood grain pattern in them. Grass, dirt, and rocks can be applied to a set of 3-D primitives that form a hill. The result is a realistic-looking hillside. Textures also can be used to create effects such as signs along a road, rock strata in a cliff, or the appearance of marble on a floor.

In addition, Direct3D supports more advanced texturing techniques such as texture blending—with or without transparency—and light mapping.

If an application creates a hardware abstraction layer (HAL) device or a software device, it can use 8, 16, 24, 32, 64, or 128-bit textures.

Additional information is contained in the following topics.

  • Texture Addressing Modes
  • Texture Dirty Regions
  • Texture Palettes
  • Loading a Texture


Texture Addressing Modes

Your Microsoft DirectX 9.0 for Managed Code application can assign texture coordinates to any vertex of any primitive. Typically, the u-texture and v-texture coordinates that you assign to a vertex are in the range of 0.0 to 1.0, inclusive. However, by assigning texture coordinates outside of that range, you can create certain special texturing effects.

You control what Microsoft Direct3D does with texture coordinates that are outside of the [0.0, 1.0] range by setting the texture addressing mode. For instance, you can have your application set the texture addressing mode so that a texture is tiled across a primitive.

Direct3D enables applications to perform texture wrapping. It is important to note that setting the texture addressing mode to TextureAddress.Wrap is not the same as performing texture wrapping. Setting the texture addressing mode to TextureAddress.Wrap results in multiple copies of the source texture being applied to the current primitive; enabling texture wrapping changes how the system rasterizes textured polygons.

Enabling texture wrapping effectively makes texture coordinates outside of the [0.0, 1.0] range invalid, and the behavior for rasterizing such delinquent texture coordinates is undefined in this case. When texture wrapping is enabled, texture addressing modes are not used. Ensure that your application does not specify texture coordinates lower than 0.0 or higher than 1.0 when texture wrapping is enabled.

Setting the Addressing Mode

You can set texture addressing modes for individual texture stages by setting the SamplerStateManager object, which is returned in the SamplerStateManagerCollection.SamplerState property that is retrieved from the Device.SamplerState property. The addressing mode can be set to any member of the TextureAddress enumeration. The following C# code example shows how to set and retrieve addressing modes.

          [C#]

// For this example, device is a valid Device object.
//
using System;
using Microsoft.DirectX.Direct3D;

// Load a texture.
Texture tx = new Texture(device, 4, 4, 0, 0, Format.X8R8G8B8, Pool.Managed);

// Set the texture in stage 0.
device.SetTexture(0, tx);

// Set some sampler states.
device.SamplerState[0].AddressU = TextureAddress.Clamp;
device.SamplerState[0].AddressV = TextureAddress.Border;

// Retrieve a sampler state.
TextureAddress ta = device.SamplerState[0].AddressU;

Device Limitations

Although the system generally allows texture coordinates outside of the range of 0.0 to 1.0, hardware limitations often affect how far outside of that range texture coordinates can be. A rendering device communicates this limit in the MaxTextureRepeat property of the Caps structure when you retrieve device capabilities. The value in this member describes the full range of texture coordinates the device allows. For instance, if this value is 128, the input texture coordinates must be kept in the range of -128.0 to +128.0. Passing vertices with texture coordinates outside of this range is invalid. The same restriction applies to the texture coordinates generated as a result of automatic texture coordinate generation and texture coordinate transformations.

The interpretation of Caps.MaxTextureRepeat also is affected by the TextureCaps.SupportsTextureRepeatNotScaledBySize property. When this property is set, the value in Caps.MaxTextureRepeat is used precisely as described. However, when TextureCaps.SupportsTextureRepeatNotScaledBySize is not set, texture-repeating limitations depend on the size of the texture indexed by the texture coordinates. In this case, Caps.MaxTextureRepeat must be scaled by the current texture size at the highest level of detail to compute the valid texture coordinate range. For example, given a texture dimension of 32 and a Caps.MaxTextureRepeat value of 512, the actual valid texture coordinate range is 512/32 = 16, so the texture coordinates for this device must be within the range of -16.0 to +16.0.

Additional information about the texture addressing modes is contained in the following topics.

  • Wrap Texture Address Mode
  • Mirror Texture Address Mode
  • Clamp Texture Address Mode
  • Border Color Texture Address Mode


Wrap Texture Address Mode

The wrap texture address mode, identified by the TextureAddress.Wrap enumerated value, makes Microsoft Direct3D repeat the texture on every integer junction. Suppose, for example, that an application creates a square primitive and specifies texture coordinates of (0.0,0.0), (0.0,3.0), (3.0,3.0), and (3.0,0.0). Setting the texture address mode to TextureAddress.Wrap results in the texture being applied three times in both the u-direction and the v-direction, as shown in the following illustration.

The effects of this texture address mode are similar to, but distinct from, those of the mirror mode. For more information, see Mirror Texture Address Mode.


Mirror Texture Address Mode

The mirror texture address mode, identified by the TextureAddress.Mirror enumerated value, causes Microsoft Direct3D to mirror the texture at every integer boundary. Suppose, for example, that an application creates a square primitive and specifies texture coordinates of (0.0,0.0), (0.0,3.0), (3.0,3.0), and (3.0,0.0). Setting the texture address mode to TextureAddress.Mirror results in the texture being applied three times in both the u-direction and the v-direction. Every other row and column to which it is applied is a mirror image of the preceding row or column, as shown in the following illustration.

The effects of this texture address mode are similar to, but distinct from, those of the wrap mode. For more information, see Wrap Texture Address Mode.


Clamp Texture Address Mode

The clamp texture address mode, identified by the TextureAddress.Clamp enumerated value, causes Microsoft Direct3D to clamp texture coordinates to the [0.0, 1.0] range. That is, it applies the texture once, and then smears the color of edge pixels.

For example, suppose that an application creates a square primitive and assigns texture coordinates of (0.0,0.0), (0.0,3.0), (3.0,3.0), and (3.0,0.0) to the primitive's vertices. Setting the texture address mode to TextureAddress.Clamp results in the texture being applied once. The pixel colors at the top of the columns and the end of the rows are extended to the top and right of the primitive respectively, as shown in the following illustration.


Border Color Texture Address Mode

The border color texture address mode is identified by the TextureAddress.Border enumerated value. It causes Microsoft Direct3D to use an arbitrary color, known as the border color, for any texture coordinates outside of the range of 0.0 through 1.0, inclusive.

In the following illustration, the application specifies that the texture be applied to the primitive using a red border.

Applications set the border color by setting the SamplerStateManager object returned in the SamplerStateManagerCollection.SamplerState property, which is retrieved from the Device.SamplerState property. In the following C# code example, the SamplerStateManagerCollection.SamplerState index parameter is set to the desired texture stage identifier, and the SamplerStateManager.BorderColor property is set to the new RGBA border color.

          [C#]

// For this example, device is a valid Device object.

using System;
using Microsoft.DirectX.Direct3D;

// Load a texture.
Texture tx = new Texture(device, 4, 4, 0, 0, Format.X8R8G8B8, Pool.Managed);

// Set the texture in stage 0.
device.SetTexture(0, tx);

// Set the address mode for the u-coord.
device.SamplerState[0].AddressU = TextureAddress.Border;

// Set the border color.
device.SamplerState[0].BorderColor = System.Drawing.Color.Blue.ToArgb();

// Get the border color.
int color = device.SamplerState[0].BorderColor;


Texture Dirty Regions

Applications can optimize which subset of a texture is copied by specifying dirty regions on textures. Only those regions marked as dirty are copied by a call to Device.UpdateTexture. However, the dirty regions can be expanded to optimize alignment. When a texture is created, the entire texture is considered dirty. Only the following operations affect this state.

  • Adding a dirty region to a texture.
  • Locking some buffer in the texture. This operation adds the locked region as a dirty region. The application can turn off this automatic dirty-region update if it has better knowledge of the actual dirty regions.
  • Using a surface level of the texture as a destination in Device.UpdateSurface marks the entire texture as dirty.
  • Using the texture as a source in Device.UpdateTexture clears all dirty regions on the source texture.
  • Using Surface.GetGraphics to return a device context.
  • Calling BaseTexture.GenerateMipSubLevels marks the entire texture as dirty.
  • Setting BaseTexture.AutoGenerateFilterType marks the entire texture as dirty.

Dirty regions are set on the top level of a mipmapped texture, and Device.UpdateTexture can expand the dirty region down the mip chain to minimize the number of bytes copied for each sublevel. Note that the sublevel dirty region coordinates are rounded outward; that is, their fractional parts are rounded toward the nearest edge of the texture.

Because each type of texture has different types of dirty regions, there are methods on each texture type, as shown in the following list. Two-dimensional (2-D) textures use dirty rectangles, and volume textures use boxes.

  • CubeTexture.AddDirtyRectangle
  • Texture.AddDirtyRectangle
  • VolumeTexture.AddDirtyBox

Omitting the rect or box parameters for the above methods expands the dirty region to cover the entire texture.

Each lock method can take LockFlags.NoDirtyUpdate, which prevents any changes to the dirty state of the texture. For more information, see Locking Resources.

When more information about the true set of regions that are changed during a lock operation is available, applications should use LockFlags.NoDirtyUpdate. Note that a lock or a copy to a texture sublevel only (that is, without locking or copying to the top level) does not update the dirty regions for that texture. Applications assume the same responsibility for updating dirty regions when they lock lower levels without locking the topmost level.


Texture Palettes

Microsoft DirectX 9.0 for Managed Code supports paletted textures through a set of 256 entry palettes associated with a Device object. A palette is made current by setting the Device.CurrentTexturePalette property. The current palette is used for translating all paletted textures for all active texture stages. The Device.SetPaletteEntries method updates all of a palette's 256 entries. Each entry is a PaletteEntry structure of type Format.A8R8G8B8. All entries default to 0xFFFFFFFF.

The Device palettes contain an alpha channel that can be used when the TextureCaps.SupportsAlphaPalette device capability flag is set, indicating that the device supports alpha from the palette. The palette alpha channel is used when the texture format does not have an alpha channel. If the device does not support alpha from the palette and the texture format does not have an alpha channel, a value of 0xFF is used for alpha.

There is a maximum of 65,536 (0x0000FFFF) palettes. Because memory resources associated with the set of palettes are proportional to the maximum palette number that an application references, contiguous palette numbers starting at zero should be used.


Loading a Texture

With Microsoft DirectX 9.0 for Managed Code, it is relatively simple to load a texture. The following C# code example does just that. To load a texture using DirectX 9.0 for Managed Code, it is first necessary to create a valid Device and a Texture object.

          [C#]

using Microsoft.DirectX.Direct3D;
.
.
.
// Global variables for this project.
Device device = null; // Rendering device.
Texture texture = null;

// Initialize the device.
.
.
.
// Device reset method.
public void OnResetDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;

    // Now create the texture.
    texture = TextureLoader.FromFile(dev, Application.StartupPath +
                                              @"\..\..\banana.bmp");
}

Related Topics

  • Tutorial 5: Using Texture Maps
  • TextureLoader


Direct3D Tutorials

The following C# tutorials use the base functionality of Microsoft Direct3D to help you begin to create stand-alone graphics applications.

Tutorial | Description
Tutorial 1: Creating a Device | Initializes Direct3D, renders a simple blue screen, and eventually shuts down.
Tutorial 2: Rendering Vertices | Initializes the procedures of Tutorial 1, creates the simplest shape (a triangle), and renders it to the display.
Tutorial 3: Using Matrices | Introduces the concept of matrices and shows how to use them to transform the coordinates of vertices and to set up cameras and viewports.
Tutorial 4: Using Materials and Lights | Adds lights and materials to create more realism in Direct3D objects.
Tutorial 5: Using Texture Maps | Adds texture to Direct3D objects.
Tutorial 6: Using Meshes | Introduces the topic of meshes and shows how to load, render, and unload a mesh.

These tutorials follow a progression, where each retains most of the code of the previous tutorial but adds more functionality. All tutorials are located at (SDK root)\Samples\Managed\Direct3D\Tutorials\.


Tutorial 1: Creating a Device

The CreateDevice tutorial project initializes Microsoft Direct3D, renders a simple blue screen, and eventually shuts down.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial1

Procedure

Creating an Application Window

The first thing any Microsoft Windows application must do when run is to create an application window. To do this, the first call in the Main() function of the following sample code is to the constructor of an application-defined CreateDevice class that sets the size of the display window, the caption of the window, and the window icon. CreateDevice is created from the System.Windows.Forms.Form Leave Site class used in the Microsoft .NET Framework to represent a window in an application.

          [C#]

using System;
using System.Drawing;
using System.Windows.Forms;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

namespace DeviceTutorial
{
    public class CreateDevice : Form
    {
        // Our global variables for this project
        Device device = null; // Our rendering device

        public CreateDevice()
        {
            // Set the initial size of our form
            this.ClientSize = new System.Drawing.Size(400,300);
            // And its caption
            this.Text = "D3D Tutorial 01: CreateDevice";
        }
        .
        .
        .
    }
    .
    .
    .
}

Initializing the Direct3D Object

After you create the application window, you are ready to initialize the Direct3D object that you will use to render the scene. This process includes creating the object, setting the presentation parameters, and finally creating the Direct3D device.

          [C#]

public bool InitializeGraphics()
{
    try
    {
        // Now  setup our D3D stuff
        PresentParameters presentParams = new PresentParameters();
        presentParams.Windowed=true;
        presentParams.SwapEffect = SwapEffect.Discard;
        device = new Device(0, DeviceType.Hardware, this,
                CreateFlags.SoftwareVertexProcessing, presentParams);
                return true;
    }
    catch (DirectXException)
    {
         return false;
    }
}

The preceding code sample relies upon a PresentParameters object that is used to set the windows display characteristics. For example, by setting the Windowed property to true, the size of the window displayed is less than full screen. This default small-window format has no menu or child windows, but it includes Minimize, Maximize, and Close buttons common to windowed applications. In this case, the ability to quickly swap back buffer memory into system memory is disabled with the SwapEffect.Discard flag. If the Windowed property is instead false, then the created window is placed above all non-topmost windows and should stay above them, even when the window is deactivated.

The final step in the initialization procedure is to create the Direct3D device. In this example the flags input to the Device(Int32,DeviceType,Control,CreateFlags,PresentParameters[]) specify that a hardware device is preferred, and that vertex processing is to be done in software. Note that if you tell the system to use hardware vertex processing by specifying CreateFlags.HardwareVertexProcessing, you will see a significant performance gain on video cards that support hardware vertex processing.

Rendering the Direct3D Object

The application is kept running in a loop using the Application Leave Site.DoEvents Leave Site method, which here takes as its argument a CreateDevice object called frm. DoEvents Leave Site runs a standard Windows application message loop on the current thread.

          [C#]

static void Main()
{

    using (CreateDevice frm = new CreateDevice())
    {
        if (!frm.InitializeGraphics()) // Initialize Direct3D
        {
            MessageBox.Show(
                "Could not initialize Direct3D.  This tutorial will exit.");
            return;
        }
        frm.Show();

        // While the form is still valid, render and process messages
        while(frm.Created)
        {
            frm.Render();
            Application.DoEvents();
        }
    }
}

While the created CreateDevice Form Leave Site object is valid, an application-defined Render method is called to render the Direct3D object. First the viewport (the open window) is set to be a uniform blue color with the Device.Clear method. Scene rendering is begun using the Device.BeginScene method. Rendering is completed and the scene is ended with successive calls to the EndScene and Present methods.

          [C#]

private void Render()
{
    if (device == null)
        return;

    //Clear the backbuffer to a blue color
    device.Clear(ClearFlags.Target, System.Drawing.Color.Blue, 1.0f, 0);
    //Begin the scene
    device.BeginScene();

    // Rendering of scene objects can happen here

    //End the scene
    device.EndScene();
    device.Present();
}


Tutorial 2: Rendering Vertices

Applications written in Microsoft Direct3D use vertices to draw geometric shapes. Each three-dimensional (3-D) scene includes one or more of these geometric shapes. The Vertices tutorial project begins with the initialization procedures of Tutorial 1: Creating a Device and then creates the simplest shape, a triangle, and renders it to the display.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial2

Procedure

This tutorial renders a 2-D triangle by using three vertices. This introduces the concept of the vertex buffer, usually a VertexBuffer object that is used to store and render vertices.

Vertices can be defined in many ways through available structures in the CustomVertex custom vertex class. In this case, the vertices are transformed, so the vertices are already in 2-D window coordinates. The point (0,0) is therefore at the upper left corner, the positive x-axis is right, and the positive y-axis is down. These vertices also do not use Direct3D lighting, but instead they supply their own diffuse color. This character is specified by initializing the vertex buffer with the CustomVertex.CustomVertex.TransformedColored structure, as in the following code fragment.

          [C#]

public class Vertices : Form
{
    // Global variables for this project
    Device device = null; // Rendering device
    VertexBuffer vb = null;
    .
    .
    .
    public void OnCreateDevice(object sender, EventArgs e)
    {
    Device dev = (Device)sender;

    // Now create the vertex buffer
    vertexBuffer = new VertexBuffer(
        typeof(CustomVertex.TransformedColored), 3, dev, 0,
        CustomVertex.TransformedColored.Format, Pool.Default);
    vertexBuffer.Created +=
        new System.EventHandler(this.OnCreateVertexBuffer);
    this.OnCreateVertexBuffer(vb, null);
    }

    public void OnCreateVertexBuffer(object sender, EventArgs e)
    {
    VertexBuffer vb = (VertexBuffer)sender;
    GraphicsStream stm = vb.Lock(0, 0, 0);
    CustomVertex.TransformedColored[] verts =
        new CustomVertex.TransformedColored[3];
    .
    .
    .
    vb.Unlock();
    }
}

In the above code, the VertexBuffer.Lock method is called to grant direct CPU access to the vertex buffer data. Each lock call must be followed by an unlock call. See Locking Resources for more information on locking and unlocking.

The verts object created in the above code is an array of three CustomVertex.TransformedColored structures, one structure for each of the triangle's three vertices. The (X,Y,X), Rhw, and Color fields of each vertex structure are initialized in the following code. The ToArgb Leave Site method is used to provide color data in the required ARGB 32-bit format.

          [C#]

verts[0].X=150; verts[0].Y=50; verts[0].Z=0.5f; verts[0].Rhw=1;
verts[0].Color = System.Drawing.Color.Aqua.ToArgb();

verts[1].X=250; verts[1].Y=250; verts[1].Z=0.5f; verts[1].Rhw=1;
verts[1].Color = System.Drawing.Color.Brown.ToArgb();

verts[2].X=50; verts[2].Y=250; verts[2].Z=0.5f; verts[2].Rhw=1;
verts[2].Color = System.Drawing.Color.LightPink.ToArgb();

stm.Write(verts);

The GraphicsStream class (stm object) was introduced in the above two code fragments. A graphics stream is used to bind data to input registers for use by shaders. This code provides the GraphicsStream object direct access to the vertex buffer, or, understood in another way, it places the vertex buffer contents into the graphics stream and advances the current position within the stream by the length of the vertex buffer.

The following code fragment shows how the private Render method is expanded from Tutorial 1 to initialize the stream source, vertex format, and primitives rendering of the Device object. As in Tutorial 1, Render renders to the display as long as the current Vertices object (frm) is valid, or if a system paint event is triggered.

          [C#]

private void Render()
{
    if (device == null)
    return;

    // Clear the back buffer to a blue color (ARGB = 000000ff)
    device.Clear(ClearFlags.Target, System.Drawing.Color.Blue, 1.0f, 0);
    // Begin the scene
    device.BeginScene();

    // New for Tutorial 2
    device.SetStreamSource(0, vertexBuffer, 0);
    device.VertexFormat = CustomVertex.TransformedColored.Format;
    device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

    // End the scene
    device.EndScene();
    device.Present();
}


Tutorial 3: Using Matrices

The Matrices tutorial project introduces the concept of matrices and shows how to use them. Matrices are used to transform the coordinates of vertices and to set up cameras and viewports.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial3

Procedure

Note: For information about initializing Microsoft Direct3D, handling Microsoft Windows messages, rendering, or shutting down, see Tutorial 1: Creating a Device.

Tutorial 2: Rendering Vertices rendered 2-D vertices to draw a triangle. This tutorial adds to the code of Tutorial 2 to rotate the triangle using 3-D vertex transformations.

Because this project will apply transformations to the triangle object, instead of using already-transformed 2-D window coordinates as in Tutorial 2, the vertex buffer is initialized with the CustomVertex.CustomVertex.PositionColored structure, as in the following code fragment.

          [C#]

Device dev = (Device)sender;
// Now create the vertex buffer.
vertexBuffer = new VertexBuffer(typeof(CustomVertex.PositionColored),
                                3,
                                dev,
                                0,
                                CustomVertex.PositionColored.Format,
                                Pool.Default);

In addition, within the private Render method, the device vertex format is initialized to be the CustomVertex.PositionColored format, as shown in the following code. Before geometry is rendered, the application-defined SetupMatrices method, which creates and sets the 3-D matrix transformations of the triangle object, is called from Render.

          [C#]

private void Render()
{
    .
    .
    .
    // Set up the world, view, and projection matrices.
    SetupMatrices();

    device.SetStreamSource(0, vertexBuffer, 0);
    device.VertexFormat = CustomVertex.PositionColored.Format;
    device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

    // End the scene.
    device.EndScene();
    device.Present();
}

Typically, three types of transformation are set for a 3-D scene. The transformations are all defined as properties of the Transforms object, accessed from the Device.Transform property. All use a left-handed coordinate system typical of Direct3D; see 3-D Coordinate Systems.

  1. World Transformation Matrix: In this case, the triangle is rotated around the y-axis by calling the Matrix.RotateY method, as shown in the following code sample. Note that Matrix is part of the general-purpose Microsoft.DirectX namespace. This call uses the system Environment Leave Site.TickCount Leave Site method, divided by a scaling value, to provide the RotateY argument in radians. This procedure yields a smoothly-varying rotation about the y-axis.
  2. View Transformation Matrix: The view transformation matrix yields the camera view of the scene, in this sample code by calling the Matrix.RotateY method. Three Vector3 vectors form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The three vectors represent respectively the eye location, the camera look-at target (in this case the origin), and the current world's up-direction.
  3. Projection Transformation Matrix: The projection transformation matrix defines how geometry is transformed from 3-D view space to 2-D viewport space. In this sample code it is formed from the matrix returned by the left-handed PerspectiveFovLH method. Arguments to the method are the field of view in radians, the aspect ratio (view space height divided by width), the near clipping plane distance, and the far clipping plane distance.

The order in which these transformation matrices are created does not affect the layout of the objects in a scene. However, Direct3D applies the matrices to the scene in the above order.

          [C#]

private void SetupMatrices()
{
    // For our world matrix, we will just rotate the object about the y-axis.

    // Set up the rotation matrix to generate 1 full rotation (2*PI radians)
    // every 1000 ms. To avoid the loss of precision inherent in very high
    // floating point numbers, the system time is modulated by the rotation
    // period before conversion to a radian angle.
    int  iTime  = Environment.TickCount % 1000;
    float fAngle = iTime * (2.0f * (float)Math.PI) / 1000.0f;
    device.Transform.World = Matrix.RotationY( fAngle );

    // Set up our view matrix. A view matrix can be defined given an eye
    // point, a point to lookat, and a direction for which way is up. Here,
    // we set the eye five units back along the z-axis and up three units,
    // look at the origin, and define "up" to be in the y-direction.

    device.Transform.View = Matrix.LookAtLH(
        new Vector3( 0.0f, 3.0f,-5.0f ),
        new Vector3( 0.0f, 0.0f, 0.0f ),
        new Vector3( 0.0f, 1.0f, 0.0f ) );

    // For the projection matrix, we set up a perspective transform (which
    // transforms geometry from 3D view space to 2D viewport space, with
    // a perspective divide making objects smaller in the distance). To build
    // a perpsective transform, we need the field of view (1/4 pi is common),
    // the aspect ratio, and the near and far clipping planes (which define
    // at what distances geometry should be no longer be rendered).
    device.Transform.Projection = Matrix.PerspectiveFovLH(
        (float)Math.PI / 4,
        1.0f,
        1.0f,
        100.0f );
}

The character of rendering is controlled by setting properties of the RenderStateManager class. This is done in the OnResetDevice application-defined method, as shown in the following code fragment.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;
    // Turn off culling, so the user sees the front and back of the triangle
    dev.RenderState.CullMode = Cull.None;
    // Turn off Direct3D lighting, since object provides its own vertex colors
    dev.RenderState.Lighting = false;
}

In this case, culling beyond a backplane and Direct3D lighting are both turned off. These settings allow the full depth of the 3-D object to be viewed and the object to provide its own colors.


Tutorial 4: Using Materials and Lights

The Lights tutorial project adds lights and materials to create more realism in Microsoft Direct3D objects. Each object in the scene will be lit based on the location and type of lights that are used. Materials describe how polygons reflect ambient and diffuse light, how their specular highlights appear, and whether the polygons appear to emit light.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial4

Procedure

Note: For information about initializing Direct3D, handling Microsoft Windows messages, rendering, or shutting down, see Tutorial 1: Creating a Device.

Tutorial 3: Using Matrices transformed object vertices in 3-D. This tutorial adds to the Tutorial 3 code to create a material and a light.

Initializing a Depth Stencil

This project also adds to the Tutorial 3 initialization an initialization procedure to allow use of a z-buffer (depth buffer) and a depth stencil, as shown in the following code fragment. Depth stencils enable applications to mask sections of the rendered image so that they are not displayed. Here the depth stencil is first enabled, and then the format is set to a 16-bit z-buffer depth.

          [C#]

public bool InitializeGraphics()
{
    .
    .
    .
    // Turn on a depth stencil
    presentParams.EnableAutoDepthStencil = true;

    // Set the stencil format
    presentParams.AutoDepthStencilFormat = DepthFormat.D16;
    .
    .
    .
}

Intializing the Vertex Buffer and Render States

One of the requirements of using lights is that each surface has a normal vector. This project therefore uses a different custom vertex type than the previous tutorials, the CustomVertex.PositionNormal structure, which includes a 3-D position and a surface normal that is used internally by Direct3D for lighting calculations.

          [C#]

public void OnCreateDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;

    // Now create the vertex buffer
    vertexBuffer = new VertexBuffer(typeof(CustomVertex.PositionNormal),
                                    100,
                                    dev,
                                    Usage.WriteOnly,
                                    CustomVertex.PositionNormal.Format,
                                    Pool.Default);
    vertexBuffer.Created +=
                    new System.EventHandler(this.OnCreateVertexBuffer);
    this.OnCreateVertexBuffer(vertexBuffer, null);
}

The sample code also enables use of a z-buffer (depth buffer), for efficiently storing scene geometry, and enables Direct3D lighting with RenderStateManager properties as follows.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;

    // Turn off culling, so the user sees the front and back of the triangle
    device.RenderState.CullMode = Cull.None;

    // Turn on the z-buffer
    device.RenderState.ZBufferEnable = true;
    device.RenderState.Lighting = true;    // Make sure lighting is enabled
}

Creating the Cylinder Object

At device initialization (OnCreateDevice shown above), the application-defined OnCreateVertexBuffer method is called to create a cylinder object. A vertex buffer is initialized that stores the points of the cylinder, and then the position and normal of each point on the cylinder are loaded into the vertex buffer, as shown in the following sample code.

          [C#]

public void OnCreateVertexBuffer(object sender, EventArgs e)
{
    VertexBuffer vb = (VertexBuffer)sender;
    // Create and lock a vertex buffer (which will return the structures)
    CustomVertex.PositionNormal[] verts =
                    (CustomVertex.PositionNormal[])vb.Lock(0,0);

    for (int i = 0; i < 50; i++)
    {
        // Fill up the structs
        float theta = (float)(2 * Math.PI * i) / 49;
        verts[2 * i].Position = new Vector3(
                (float)Math.Sin(theta), -1, (float)Math.Cos(theta));
        verts[2 * i].Normal = new Vector3(
                (float)Math.Sin(theta), 0, (float)Math.Cos(theta));
        verts[2 * i + 1].Position = new Vector3(
                (float)Math.Sin(theta), 1, (float)Math.Cos(theta));
        verts[2 * i + 1].Normal = new Vector3(
                (float)Math.Sin(theta), 0, (float)Math.Cos(theta));
    }
    // Unlock (and copy) the data
    vb.Unlock();
}

The cylinder is rotated using the world transformation matrix in the SetupMatrices private method, as in Tutorial 3.

Creating a Material

A material defines the color that is reflected off the surface of a geometric object when a light hits it. The following code fragment uses the Material structure to create a material that is white in color. The diffuse and ambient color properties for the material are set to white. After this call is made, every primitive will be rendered with this material until the color properties are set to another value.

          [C#]

private void SetupLights()
{
    System.Drawing.Color col = System.Drawing.Color.White;

    // Set up a material. The material here just has the diffuse and ambient
    // colors set to white. Note that only one material can be used at a time.
    Direct3D.Material mtrl = new Direct3D.Material();
    mtrl.Diffuse = col;
    mtrl.Ambient = col;
    device.Material = mtrl;
    .
    .
    .
}

Creating a Light

There are three types of lights available in Direct3D: point lights, directional lights, and spotlights. This tutorial project creates a directional light, which is a light that shines in one direction, and it oscillates the direction of the light. The following code fragment uses a Light object to create a directional light with a dark turquoise color. All objects in the scene are also illuminated with a low level of monochromatic (gray) ambient lighting.

          [C#]

private void SetupLights()
{
    .
    .
    .
    // Set up a colored directional light, with an oscillating direction.
    // Note that many lights may be active at a time (but each one slows down
    // the rendering of the scene). However, here just one is used.
    device.Lights[0].Type = LightType.Directional;
    device.Lights[0].Diffuse = System.Drawing.Color.DarkTurquoise;
    device.Lights[0].Direction = new Vector3(
                    (float)Math.Cos(Environment.TickCount / 250.0f),
                    1.0f,
                    (float)Math.Sin(Environment.TickCount / 250.0f));

    device.Lights[0].Enabled = true; // Turn it on

    // Finally, turn on some ambient light.
    // Ambient light is light that scatters and lights all objects evenly.
    device.RenderState.Ambient = System.Drawing.Color.FromArgb(0x202020);


Tutorial 5: Using Texture Maps

The Textures tutorial project adds texture to Microsoft Direct3D objects. While lights and materials add a great deal of realism to a scene, nothing adds more realism than adding textures to surfaces. Textures can be thought of as wallpaper that is shrink-wrapped onto a surface. You could place a wood texture on a cube to make it look like the cube is actually made of wood. This tutorial project adds a "banana peel" texture to the cylinder object created in Tutorial 4: Using Materials and Lights.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial5

Procedure

Note: For information about initializing Direct3D, handling Microsoft Windows messages, rendering, or shutting down, see Tutorial 1: Creating a Device.

Tutorial 4: Using Materials and Lights created materials and lighting on the Direct3D object. This tutorial adds to the Tutorial 4 code with procedures for loading textures, setting up vertices, and displaying objects with texture.

Creating the Texture

To be able to use textures, a vertex buffer must be created that has texture coordinates in its custom vertex format. Texture coordinates tell Direct3D where to place a texture for each vector in a primitive. Texture coordinates range from 0.0 to 1.0, where (0.0, 0.0) represents the upper left side of the texture and (1.0, 1.0) represents the lower-right side of the texture.

After initializing a new Texture object, the following sample code sets the format of the vertex buffer using the CustomVertex.PositionNormalTextured structure. This initialization prepares the vertex buffer to receive (x, y, z) position and (x, y, z) normal data, and one set of (tu, tv) texture coordinates.

          [C#]

public class Textures : Form
{
    // Our global variables for this project
    Device device = null; // Our rendering device
    VertexBuffer vertexBuffer = null;
    Texture texture = null;
    .
    .
    .

    public void OnCreateDevice(object sender, EventArgs e)
    {
        Device dev = (Device)sender;

        // Now create the vertex buffer
        vertexBuffer = new VertexBuffer(
                            typeof(CustomVertex.PositionNormalTextured),
                            100,
                            dev,
                            Usage.WriteOnly,
                            CustomVertex.PositionNormalTextured.Format,
                            Pool.Default);
        vertexBuffer.Created += new System.EventHandler(
                            this.OnCreateVertexBuffer);
        this.OnCreateVertexBuffer(vertexBuffer, null);
    }
}

Loading Texture Data

The render state settings (display parameters) are similar to those of Tutorial 4, except that Direct3D lighting is disabled to allow the colors of the cylinder object to be displayed, and a "banana peel" texture is loaded from a bitmap file using the TextureLoader.FromFile method.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    Device dev = (Device)sender;

    // Turn off culling, so the user sees the front and back of the triangle
    dev.RenderState.CullMode = Cull.None;

    // Turn off Direct3D lighting
    dev.RenderState.Lighting = false;

    // Turn on the z-buffer
    dev.RenderState.ZBufferEnable = true;

    // Now create the texture
    texture = TextureLoader.FromFile(dev,
                        Application.StartupPath + @"\..\..\banana.bmp");
}

The procedure for loading the vertex buffer with the cylinder object's properties is identical to the OnCreateVertexBuffer application-defined method in Tutorial 4, with the addition of texture coordinates (tu, tv) for each point, as shown in the following code sample. This procedure causes the texture to wrap smoothly around the cylinder when rendered, and the texture remains pinned to the original cylinder.

          [C#]

public void OnCreateVertexBuffer(object sender, EventArgs e)
{
    VertexBuffer vb = (VertexBuffer)sender;

    // Create a vertex buffer
    // Lock the buffer (which will return the structures)
    CustomVertex.PositionNormalTextured[] verts =
                (CustomVertex.PositionNormalTextured[])vb.Lock(0,0);
    for (int i = 0; i < 50; i++)
    {
        // Fill up the structures
        float theta = (float)(2 * Math.PI * i) / 49;
        verts[2 * i].Position = new Vector3(
                (float)Math.Sin(theta), -1, (float)Math.Cos(theta));
        verts[2 * i].Normal = new Vector3(\
                (float)Math.Sin(theta), 0, (float)Math.Cos(theta));
        verts[2 * i].Tu = ((float)i)/(50-1);
        verts[2 * i].Tv = 1.0f;
        verts[2 * i + 1].Position = new Vector3(
                (float)Math.Sin(theta), 1, (float)Math.Cos(theta));
        verts[2 * i + 1].Normal = new Vector3(
                (float)Math.Sin(theta), 0, (float)Math.Cos(theta));
        verts[2 * i + 1].Tu = ((float)i)/(50-1);
        verts[2 * i + 1].Tv = 0.0f;
    }
}

Rendering the Scene

Texture stages enable you to define the behavior of how a texture or textures are to be rendered. For example, you could blend multiple textures together. This tutorial project starts with the private Render method of Tutorial 4 and sets to 0 the texture stage that the Direct3D device will use to render. A device can have up to eight set textures, so the maximum stage value is 7, but this tutorial project has only one texture and places it at stage 0. Zero is used as both the stage parameter of the Device.SetTexture method and as the array value for the Device.TextureState property.

Constants of the TextureOperation and TextureArgument enumerations control how the texture renders. For example, the settings in this code cause the output color to be the texture color multiplied by the diffuse color. For more information on color blending in textures.

          [C#]

private void Render()
{
    .
    .
    .
    // Set up our texture. Using textures introduces the texture stage states,
    // which govern how textures get blended together (in the case of multiple
    // textures) and lighting information. In this case, modulate (blend)
    // the texture with the diffuse color of the vertices.
    device.SetTexture(0,texture);
    device.TextureState[0].ColorOperation = TextureOperation.Modulate;
    device.TextureState[0].ColorArgument1 = TextureArgument.TextureColor;
    device.TextureState[0].ColorArgument2 = TextureArgument.Diffuse;
    device.TextureState[0].AlphaOperation = TextureOperation.Disable;
    .
    .
    .


Tutorial 6: Using Meshes

Complicated geometry is usually modeled using 3-D modeling software and saved to a file. An example of this is the .x file format. Microsoft Direct3D uses meshes to load the objects from these files. The Meshes tutorial project introduces the topic of meshes and shows how to load, render, and unload a mesh.

A mesh contains the data for a complex model. It is an abstract data container that contains resources such as textures and materials, and attributes such as position data and adjacency data. Although meshes are somewhat complicated, Direct3D contains methods that make using meshes easier.

Path

Source location: (SDK root)\Samples\Managed\Direct3D\Tutorials\Tutorial6

Procedure

Note: For information about initializing Direct3D, handling Microsoft Windows messages, rendering, or shutting down, see Tutorial 1: Creating a Device.

Tutorial 5: Using Texture Maps created texture on the Direct3D object. This tutorial adds to the Tutorial 5 code with procedures for handling a mesh from a file, but it drops the OnCreateDevice application-defined method and related device creation calls that were used to create a vertex buffer. The procedure used here handles vertex buffers implicitly within mesh method calls.

Initializing a Mesh Object

This tutorial project initializes multidimensional material and texture arrays as follows. Note also the using declarations of System.ComponentModel Leave Site and System.IO Leave Site namespaces.

          [C#]

using System;
using System.Drawing;
using System.ComponentModel;
using System.Windows.Forms;
using System.IO;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;
using Direct3D = Microsoft.DirectX.Direct3D;
public class Meshes : Form
{
    Device device = null;              // Rendering device
    Mesh mesh = null;                  // Mesh object in system memory
    Direct3D.Material[] meshMaterials; // Materials for the mesh
    Texture[] meshTextures;            // Textures for the mesh
    PresentParameters presentParams = new PresentParameters();
    .
    .
    .
}

The application-defined OnResetDevice method initializes an ExtendedMaterial object that is used to capture the mesh file data to a Material structure. The method sets the directory path to the mesh file, initializes a device, and turns on the z-buffer and white ambient lighting.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    ExtendedMaterial[] materials = null;

    // Set the directory up to load the right data, because the
    // default build location is Bin\debug or Bin\release.
    Directory.SetCurrentDirectory(Application.StartupPath +  @"\..\..\");

    Device dev = (Device)sender;

    // Turn on the z-buffer.
    dev.RenderState.ZBufferEnable = true;

    // Turn on ambient lighting.
    dev.RenderState.Ambient = System.Drawing.Color.White;
    .
    .
    .
}

Loading a Mesh Object

As shown in the following code fragment, the OnResetDevice method next loads a mesh that represents a texture-mapped 3-D tiger from the tiger.x file. In this Mesh.FromFile method call, the SystemMemory constant of the MeshFlags enumeration indicates that the mesh is to be loaded into system RAM not typically accessible by the device. After the mesh is loaded, a meshMaterials Material object has its members filled with the Material structures of the materials ExtendedMaterial object that came from the mesh file. The material is also set to the ambient color. Finally, a meshTextures Texture object is loaded with the texture the file with a call to the TextureLoader.FromFile method. Both meshMaterials and meshTextures are initialized to the dimension (Length Leave Site) of the materials structure from the file.

          [C#]

public void OnResetDevice(object sender, EventArgs e)
{
    .
    .
    .
    // Load the mesh from the specified file.
    mesh = Mesh.FromFile("tiger.x",
                         MeshFlags.SystemMemory,
                         device,
                         out materials);
    if (meshTextures == null)
    {
        // Extract the material properties and texture names.
        meshTextures  = new Texture[materials.Length];
        meshMaterials = new Direct3D.Material[materials.Length];
        for( int i=0; i<materials.Length; i++ )
        {
            meshMaterials[i] = materials[i].Material3D;

            // Set the ambient color for the material. Direct3D
            // does not do this by default.
            meshMaterials[i].Ambient = meshMaterials[i].Diffuse;

            // Create the texture.
            meshTextures[i] = TextureLoader.FromFile(dev,
                                       materials[i].TextureFilename);
        }
    }
}

Rendering a Mesh Object

After the mesh has been loaded, the private Render method is called to render the mesh object. It first begins the scene and calls the SetupMatrices application-defined method, as was done in Tutorial 5. To render the mesh, it is divided into subsets, one for each material that was loaded. As shown in the following code fragment, a loop is run to render each material subset. The loop does the following for each material:

  • The Material property of the device is set to the meshMaterials Material structure.
  • The device texture stage 0 is set to the meshTextures Texture structure.
  • The material subset is drawn with the DrawSubset method, which inherits from the BaseMesh class.

          [C#]

private void Render()
{
    .
    .
    .
    for( int i=0; i<meshMaterials.Length; i++ )
    {
        // Set the material and texture for this subset.
        device.Material = meshMaterials[i];
        device.SetTexture(0, meshTextures[i]);

        // Draw the mesh subset.
        mesh.DrawSubset(i);
    }

    // End the scene.
    device.EndScene();
    device.Present();
}


Direct3D Samples for Managed Code

The samples in this section show how to use Microsoft Direct3D in a C# managed code application. When you have mastered the tutorials, you are ready to jump into the samples. Some of these samples demonstrate the latest features of Microsoft DirectX 9.0 for Managed Code. Other samples demonstrate existing functionality that is fundamental to using Direct3D. All of the samples are built on top of the sample framework. See The Sample Framework and Sample Framework Reference.

Samples

These samples demonstrate the newest techniques incorporated into DirectX. While DirectX 9.0 for Managed Code supports a variety of managed development languages including Microsoft Visual Basic .NET, the majority of samples are written in C#.

Note: Although DirectX samples include Microsoft Visual Studio .NET solution files, you might need to verify other settings in your development environment to ensure that the samples compile properly.

C# Samples

Sample | Description
BasicHLSL Direct3D Sample | Coded in both Microsoft Visual C# and Visual Basic .NET, this is a simple example of using high-level shader language (HLSL) with the Effect class.
CustomUI Direct3D Sample | A simple demonstration of the user interface (UI) subsystem implemented by the DirectX 9.0 for Managed Code sample framework.
EmptyProject Direct3D Sample | A starting point for new Direct3D applications.
EnhancedMesh Direct3D Sample | Demonstrates mesh tessellation in Direct3D.
FragmentLinker Direct3D Sample | Uses the FragmentLinker class to split shader source code into a series of shader fragments, which are compiled separately and linked together to form a complete shader.
HDRCubeMap Direct3D Sample | Demonstrates cubic environment-mapping with floating-point textures and high dynamic range (HDR) lighting.
HDRFormats Direct3D Sample | Shows how HDR data can be encoded into integer formats for compatibility across a wide range of devices.
HLSLwithoutEffects Direct3D Sample | Provides an example of how to use HLSL, without the use of the D3DX effect interfaces.
ProgressiveMesh Direct3D Sample | Shows how an application can use the D3DX progressive mesh functionality to simplify meshes for faster rendering.
PrtPerVertex Direct3D Sample | Demonstrates how to use PrtEngine, a precomputed radiance transfer (PRT) simulator that uses low-order spherical harmonics (SH).
C# Scripting Direct3D Sample | Demonstrates one possible technique for using C# code as a script in your unmanaged applications, and includes techniques to ensure that scripts not deemed to be safe cannot be executed.
SimpleAnimation Direct3D Sample | Shows how to animate a 3-D model that has a skeletal structure.
Text3D Direct3D Sample | Shows how to draw 2-D text in a 3-D scene.

Visual Basic .NET Samples

Sample | Description
BasicHLSL Direct3D Sample | Coded in both Visual C# and Visual Basic .NET, this is a simple example of using HLSL with the Effect class.


BasicHLSL Direct3D Sample

Coded in both Microsoft Visual C# and Microsoft Visual Basic .NET, this is a simple example of using high-level shader language (HLSL) with the Effect class.

Supported Languages

  • C#
  • Visual Basic .NET

Path

Source: | (SDK root)\Samples\Managed\Direct3D\BasicHLSL
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csBasicHLSL.exe

Sample Overview

This sample simply loads a Mesh, creates an Effect from a file, and then uses the Effect to render the Mesh. The Effect that is used is a simple vertex shader that animates the vertices based upon time, along with the possibility to have multiple directional lights.

How the Sample Works

First the sample loads the geometry with Mesh.FromFile and calls ComputeNormals to create mesh normals if there are not yet any. The sample then calls OptimizeInPlace to optimize the mesh for the vertex cache. It then loads the textures using its CreateTextureFromFile method. Finally, it calls its CreateEffectFromFile method to compile the effect text file into an Effect object called effect.

Note that the CreateEffectFromFile call takes flags which are needed to debug shaders with the Microsoft Visual Studio .NET shader debugger. Debugging vertex shaders requires either reference or software vertex processing, and debugging pixel shaders requires reference vertex processing. The ForcePixelShaderSoftwareNoOptimizations and ForceVertexShaderSoftwareNoOptimizations flags improve the debug experience in the shader debugger. They enable source level debugging, prevent instruction reordering, prevent dead code elimination, and force the compiler to compile against the next highest available software target, ensuring that the unoptimized shaders do not exceed the shader model limitations. Setting these flags causes slower rendering because the shaders will be unoptimized and forced to run in software. To turn these flags on with the C# sample code, simply remove the comment marks from either the #define DEBUG_VS or the #define DEBUG_PS line near the top of the file. Turning on one of these flags also forces the device into software processing by adding some code to the ModifyDeviceSettings callback method.

The OnFrameRender callback method sets the appropriate technique with the effect.Technique property, which passes an EffectHandle (in this case a string). It is possible to pass an EffectHandle instead of a string, thereby improving performance because this high frequency call does not have to spend time performing a string comparison.

The OnFrameRender method then sets variables used by the technique, such as the World*View*Projection matrix and the time variable, with various effect.SetArrayRange calls. To render the scene, OnFrameRender calls effect.Begin, which returns pass, the number of passes required by the technique, then it loops through each pass calling effect.BeginPass(pass) and rendering the mesh with mesh.DrawSubset. After each pass, OnFrameRender calls effect.EndPass. When all the passes are completed, OnFrameRender calls effect.End.


CompiledEffect Direct3D Sample

This sample shows how an Effect object can be compiled when the project is built and loaded directly as a binary file at run time.

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\CompiledEffect
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csCompiledEffect.exe

Sample Overview

Large-scale projects may contain dozens or even hundreds of shader and effect files. Compiling these files at run time can cause a noticeable delay during initialization, and this delay is incurred each and every time the project is run; instead, these files can be compiled as part of your project build process, eliminating the need for any further compilation during program execution. Since these files will only need to be compiled when changes are made, no additional build time is spent on effect files which have already been compiled. Note that when developing or debugging effect files it is still beneficial to compile at run time, which allows more debugging flexibility. Also note that the process illustrated in this sample is identical whether compiling a complete Effect object or individual shaders. The only change would be the target profile command line passed to the compiler.

How the Sample Works

The code is very similar to the BasicHLSL sample except for a couple important differences:

  • The call to the CreateEffectFromFile function is passed the filename of the compiled effect (CompiledEffect.fxo) instead of the filename of the effect source (CompiledEffect.fx).
  • No debugging flags are passed to the CreateEffectFromFile function. Instead, flags are passed to the effect compiler to enable shader debugging.

The program used to compile shaders at build time is fxc. This command-line utility ships with the software development kit (SDK), and wraps the EffectCompiler calls used to perform the compilation. It's interesting to note that you could create your own shader compiler fairly easily using the EffectCompiler class, but fxc should be flexible enough for most needs. The commands used to build release and debug versions of a hypothetical MyEffect.fx file are:

Release: | fxc /Tfx_2_0 /FoMyEffect.fxo MyEffect.fx
Debug: | fxc /Od /Zi /Tfx_2_0 /FoMyEffect.fxo MyEffect.fx

Run fxc without any arguments for usage information.

Build Environment Configuration

To configure the build environment using Microsoft Visual Studio .NET, complete the following steps.

  1. Open the CompiledEffect sample project inside Visual Studio .NET.
  2. From within the Solution Explorer window, right click CompiledEffect project and select Properties from the context menu.
  3. Select Common Properties, then Build Events to view the custom build step directives.


CustomUI Direct3D Sample

This sample is a simple demonstration of the user interface (UI) subsystem implemented by the Microsoft DirectX 9.0 for Managed Code sample framework. The sample framework provides code and infrastructure common to most DirectX 9.0 for Managed Code applications. One area of the framework is user interface support. The sample framework contains commonly used control objects, such as buttons and check boxes, that both windowed and full screen Microsoft Direct3D applications can use to implement their user interfaces.

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\CustomUI
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csCustomUI.exe

How the Sample Works

This sample demonstrates how an application that uses the DirectX 9.0 for Managed Code sample framework can take advantage of the framework's UI support. The sample framework supports the following control types:

Control type | Class that implements it
Statics | Microsoft.Samples.DirectX.UtilityToolkit.StaticText
Buttons | Microsoft.Samples.DirectX.UtilityToolkit.Button
Radio buttons | Microsoft.Samples.DirectX.UtilityToolkit.RadioButton
Check boxes | Microsoft.Samples.DirectX.UtilityToolkit.Checkbox
Combo boxes | Microsoft.Samples.DirectX.UtilityToolkit.ComboBox
List boxes | Microsoft.Samples.DirectX.UtilityToolkit.ListBox
Sliders | Microsoft.Samples.DirectX.UtilityToolkit.Slider
Scrollbars | Microsoft.Samples.DirectX.UtilityToolkit.Scrollbar
Edit boxes | Microsoft.Samples.DirectX.UtilityToolkit.EditBox

All of the sample framework controls work similarly to Microsoft Windows controls. They are implemented entirely from scratch and with the exception of the EditBox do not use any Windows control underneath. They are also rendered with Direct3D, and therefore can be used by both windowed and full screen Direct3D applications.

This sample starts by defining two Dialog objects: hud and sampleUi. A Dialog serves as a container that encapsulates one or more controls. It sits between the application and the controls, so that the application can pass messages and rendering calls to Dialog, and Dialog will ensure that all of its controls receive the messages and get rendered properly. The controls themselves are designed to be used with a Dialog, not stand-alone. Applications are not limited to one Dialog object. They can use more at once, as this sample does.

As the user interacts with the UI controls, the controls can notify the sample about important events, so that it can respond accordingly. At this time the sample also initializes additional fonts that it will need. This is done with the SetFont method.

The next step that the sample has to do is create the controls it needs. This is achieved by calling the Dialog's AddXXX methods, such as AddButton. In the sample, hud contains 3 buttons that provide standard functionalities that Direct3D samples have: toggle between Hardware and Reference devices, and changing 3D device settings. sampleUi contains the rest of the controls, which are sample-specific. After a control is added, its appearance can be modified. This is demonstrated in the sample as it modifies the appearance of the static controls as well as the combo box. At creation the appropriate events are hooked for each control and responded to in the event handler methods.

Next, in OnResetDevice, are a number of calls to the Dialog's and controls' SetSize and SetLocation methods. This is because when the user resizes the application window, some dialogs and controls need to be resized and repositioned as well. It is worth noting that the Dialog's location is relative to the application window, while a control's location is relative to the Dialog it belongs.

To render the user interface, the sample calls the OnRender method of the two Dialog objects in its OnFrameRender function. Dialog will render the controls it contains in the correct order.

The final step required to make the UI work is passing messages to the controls. This lets them receive keyboard and mouse events from the user. In MsgProc, the sample calls Dialog's MsgProc method to pass down the messages. It is very important that if Dialog's MsgProc returns true indicating that the message has been handled, the sample sets the noFurtherProcessing parameter to true and returns immediately. Failure to do so will cause a message to be processed more than once.

Events

Certain events happen as the user interacts with the UI controls, such as checking or unchecking a check box, selecting a new item in a combo box, selecting a new item in a radio button group, etc. The application may be interested in such events, and it can be notified with controls events. In the sample, a series of event handler functions are defined and hooked as the controls are created. As a result, these functions will get called whenever the user performs an interesting action with a UI control. The actions that can trigger a callback are:

  • Clicking a button (Button)
  • Selecting a new item in a combo box (ComboBox)
  • Selecting a new item in a radio button group (RadioButton)
  • Changing the check state of a check box (CheckBox)
  • Changing the value of a slider (Slider)
  • Pressing Enter in an edit box (EditBox and EditBox)

In the event handlers, the control that fired the event and any necessary extra data are available to the application. The sample responds to the events by retrieving content of the firing control and displaying it on screen.


EmptyProject Direct3D Sample

This sample is a starting point for new Microsoft Direct3D applications.

  • Supported Languages
  • Path
  • Sample Overview
  • How the Sample Works

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\EmptyProject
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csEmptyProject.exe

Sample Overview

This sample is a bare-bones Direct3D application provided as a convenient starting point for your own project.

How the Sample Works

This sample uses the sample framework to initialize and run a basic Direct3D application.


EnhancedMesh Direct3D Sample

This sample demonstrates mesh tessellation in Microsoft Direct3D. Mesh tessellation subdivides mesh triangles. This produces a mesh with finer geometry details which can produce better lighting results even with per-vertex lighting. Mesh tessellation is often used to implement a level of detail (LOD) technique where meshes closer to the viewer are rendered with more details, and meshes further away are rendered with less detail.

  • Supported Languages
  • Path
  • How the Sample Works

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\EnhancedMesh
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csEnhancedMesh.exe

How the Sample Works

The sample can run in one of two modes: hardware tessellation or software tessellation. The user can set the tessellation level to different values and see how the mesh changes in reaction to the level adjustment.

When running in hardware tessellation mode, the sample tessellates the mesh by setting the Device.NPatchMode property which sets the number of tessellation segments into which the device will tessellate each mesh segment. For instance, specifying 3.0 will cause each original segment in the input mesh to be tessellated into three segments. This tessellation happens in real-time, after the mesh draw calls in the render loop.

When running in software tessellation mode, the sample does not rely on the hardware to do on-the-fly tessellation. Therefore, the sample must process the mesh and obtain the desired detail level before rendering it. The code achieves this by calling Mesh.TessellateNPatches which takes an input mesh and a segment count, and then outputs another mesh that represents the tessellated version of the input mesh. The sample can then render this tessellated mesh using any standard mechanism.


FragmentLinker Direct3D Sample

This sample shows how to use the FragmentLinker class. Shader source code can be split into a series of shader fragments which are compiled separately and linked together to form a complete shader. This linking stage is very efficient, making it suitable for run-time use. In this way, a Microsoft Direct3D application can custom-build an appropriate shader for the current graphics card.

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\FragmentLinker
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csFragmentLinker.exe

Sample Overview

Large-scale Direct3D applications commonly employ a large set of redundant shaders covering every supported fallback case for a given technique (often generated by uniform parameters) from which the appropriate shader for the current graphics hardware is selected at run time. This approach can result in a large amount of compiled shaders being included with the application, only a small fraction of which are ever used on a given machine. Using shader fragments, the desired shader for the current graphics card can be built at run time.

How the Sample Works

This sample links together one of two vertex shader fragments that handles projection (vertex animated or static) and one of two vertex shader fragments that handles vertex lighting (diffuse enabled or ambient only). These fragments are compiled once during initialization and are then linked together at run time.

Only a few steps need to be followed when using shader fragments in your application:

  1. Create the FragmentLinker object with the FragmentLinker Constructor.
  2. Load and compile the shader fragments by calling one of the following FragmentLinker methods: GatherFragmentsFromFile, GatherFragmentsFromStream, or GatherFragmentsFromString.
  3. Add the compiled fragments to the linker's internal list with a call to FragmentLinker.AddFragments.
  4. Retrieve the handles of the fragments you want linked through calls to FragmentLinker.GetFragmentHandle.
  5. Link together a subset of the added fragments by passing fragment handles to one of the following FragmentLinker methods: LinkVertexShader, LinkPixelShader, or LinkShader. These methods return an object that contains a compiled shader that can be used for rendering.

The following sample application performs these steps upon device creation within the sample's OnCreateDevice function:

          [C#]

private void OnCreateDevice( object sender, DeviceEventArgs e )
.
.
.
// Create the fragment linker interface
fragmentLinker = new FragmentLinker( e.Device, 0 );

// Compile the fragments to a buffer. The fragments must be linked
// together to form a shader before they can be used for rendering.
path = Utility.FindMediaFile( "FragmentLinker.fx" );
compiledFragments =
    Microsoft.DirectX.Direct3D.FragmentLinker.GatherFragmentsFromFile(
        path, null, null, ShaderFlags.None );

// Build the list of compiled fragments
fragmentLinker.AddFragments( compiledFragments );

// Store the fragment handles
ComboBox cb1 = sampleUI.GetComboBox( Lighting );
cb1.Clear();
cb1.AddItem( "Ambient",
    fragmentLinker.GetFragmentHandle( "AmbientFragment" ) );
cb1.AddItem( "Ambient & Diffuse",
    fragmentLinker.GetFragmentHandle( "AmbientDiffuseFragment" ) );

ComboBox cb2 = sampleUI.GetComboBox( Animation );
cb2.Clear();
cb2.AddItem( "On" ,
    fragmentLinker.GetFragmentHandle( "ProjectionFragment_Animated" ) );
cb2.AddItem( "Off",
    fragmentLinker.GetFragmentHandle( "ProjectionFragment_Static" ) );

// Link the desired fragments to create the vertex shader
LinkVertexShader();

The final linking step is performed within the FragmentLinker.LinkVertexShader method. In addition to being called upon device creation, this method is also called whenever the user changes a fragment combobox selection. The currently selected fragments are retrieved from the user interface controls and the shader data is updated.

          [C#]

private void LinkVertexShader()
{
    const int NumberFragments = 2;
    Device device = sampleFramework.Device;
    EffectHandle[] aHandles = new EffectHandle[NumberFragments];

    aHandles[0] =
        sampleUI.GetComboBox( Animation ).GetSelectedData() as EffectHandle;
    aHandles[1] =
        sampleUI.GetComboBox( Lighting ).GetSelectedData() as EffectHandle;

    if ( vertexShader != null )
    {
        vertexShader.Dispose();
    }

    string errors;
    using (GraphicsStream code = fragmentLinker.LinkShader(
        "vs_1_1", ShaderFlags.None, aHandles, out errors ) )
    {
        vertexShader = new VertexShader( device, code );
        constTable = ConstantTable.FromShader( code );
    }
    // Set the global variables
    device.VertexShader = vertexShader;
    if ( constTable != null )
    {
        constTable.SetValue( device, "g_vMaterialAmbient", MaterialAmbient );
        constTable.SetValue( device, "g_vMaterialDiffuse", MaterialDiffuse );
        constTable.SetValue( device, "g_vLightColor", LightColor );
        constTable.SetValue( device, "g_vLightPosition",LightPosition );
    }
        }


HDRCubeMap Direct3D Sample

This sample demonstrates cubic environment-mapping with floating-point textures and high dynamic range (HDR) lighting. In Microsoft DirectX 9.0, floating-point formats have become available for textures. These formats can store color values higher than 1.0, which can make lighting effects more realistic on the environment-mapped mesh when the material absorbs part of the light.

Note that not all cards support all features for the environment-mapping and HDR lighting techniques.

  • Supported Languages
  • Path
  • User's Guide
  • Sample Overview
  • Implementation
  • The Rendering Code
  • The Shaders
  • High Dynamic Range Realism
  • Alternatives

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\HDRCubeMap
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csHDRCubeMap.exe

User's Guide

General controls defined in the sample:

Key | Action
E,D | Adjust material reflectivity
W,S | Adjust light intensity
F | Change cubic map format
R | Reset lighting parameters
N | Change to another mesh
F2 | Change device
Esc | Quit

Sample Overview

HDRCubeMap shows off two rendering techniques: cubic environment-mapping and HDR lighting. Cubic environment-mapping is a technique in which the environment surrounding a 3-D object is rendered into a cube texture map, so that the object can use the cube map to achieve complex lighting effects without expensive lighting calculations. HDR lighting is a technique to render highly-realistic lighting effects by using floating-point textures and high-intensity lights. The floating-point texture formats are introduced in DirectX 9.0. Unlike traditional textures in integer format, floating-point textures are capable of storing a wide range of color values. Because color values in floating-point textures do not get clamped to [0, 1], much like lights in the real world, these textures can be used to achieve greater realism.

The scene that HDRCubeMap renders is an environment-mapped mesh, along with several other objects making up the environment around the mesh. The mesh has a reflectivity setting adjustable from 0 to 1, where 0 means the mesh absorbs light completely, and 1 means it absorbs no light and reflects all. The lights used in the scene consist of four point lights, whose intensity is adjustable by the user.

Implementation

HDRCubeMap follows the DirectX sample framework architecture.

The scene that the sample renders consists of these objects:

  • A room Mesh object. This includes the walls, floor, and ceiling.
  • Four small sphere Mesh objects representing light sources.
  • A Mesh object in the center of the room with the environment map applied to it.
  • Two bi-plane Mesh objects. These orbit around the environment-mapped mesh and are reflected on the environment map. They give the visual cue that the environment map is dynamic, and changes as the surrounding environment changes.

When the sample loads, it creates two cubic textures, one in A8R8G8B8 format and the other in A16B16G16R16F format. When rendering, the sample uses one of these to construct an environment map based on the user's choice. This is done to show the visual difference between integer and floating-point textures when used with HDR lighting. A stencil surface with a size equal to the size of a cube texture face is also created at this time. This stencil surface will be used as the stencil buffer when the sample renders the scene onto the cube texture. The sample also creates an effect object that contains all of the shaders and techniques needed for rendering the scene.

The camera used in the sample is a ModelViewerCamera. This camera always looks at the origin, where the environment-mapped mesh is. The user can move the camera position around the mesh and rotate the mesh with mouse control. The camera object computes the view and projection matrices for rendering, as well as the world matrix for the environment-mapped mesh.

The Rendering Code

The rendering of the sample happens in three functions: RenderSceneIntoCubeMap(), OnFrameRender(), and RenderScene(), using vertex and pixel shaders.

RenderScene() is the function that does the actual work of rendering the scene onto the current render target. This is called both to render the scene onto the cube texture and onto the device backbuffer. It takes six parameters: the device used for rendering, a view matrix, a projection matrix, the technique group for the currently selected rendering mode, the application's current time, and a flag indicating whether it should render the environment-mapped mesh. The flag is needed because the environment-mapped mesh is not drawn when constructing the environment map. The rest of the function is straightforward. It first updates the effect object with the latest transformation matrices, as well as the light position in view space. Then, it renders every mesh object in the scene by using an appropriate technique for each one.

The job of RenderSceneIntoCubeMap() is to render the entire scene (minus the environment-mapped mesh) onto the cube texture. First, it saves the current render target and stencil buffer, and sets the stencil surface for the cube texture as the device stencil buffer. Next, the function iterates through the six faces of the cube texture. For each face, it sets the appropriate face surface as the render target. Then, it computes the view matrix to use for that particular face, with the camera at the origin looking out in the direction of the cube face. It then calls RenderScene() with bRenderEnvMappedMesh set to false, passing along the computed view matrix and a special projection matrix. This projection matrix has a 90 degree field of view and an aspect ratio of 1, owing to the fact that the render target is a square. After this process is complete for all six faces, the function restores the old render target and stencil buffer. The environment map is now fully constructed for the frame.

OnFrameRender() is the top level rendering function called once per frame by the sample framework. It calls RenderSceneIntoCubeMap() to construct the cube texture to reflect the environment for that frame. After that, it renders the scene by calling RenderScene() with the view and projection matrices from the camera, and renderEnvMappedMesh set to true.

The Shaders

All of the rendering in this sample is done by programmable shaders, divided into three effect techniques: RenderLight, RenderHDREnvMap, and RenderScene.

The RenderLight technique is used for rendering the spheres representing the light sources. The vertex shader does a usual world-view-projection transformation, then assigns the light intensity value to the output diffuse. The pixel shader propagates the diffuse to the pipeline.

The RenderHDREnvMap technique is used for rendering the environment-mapped mesh in the scene. Besides transforming the position from object space to screen space, the vertex shader computes the eye reflection vector (the reflection of the eye-to-vertex vector) in view space. This vector is passed to the pixel shader as a cubic texture coordinate. The pixel shader samples the cube texture, applies the reflectivity to the sampled value, and returns the result to the pipeline.

The RenderScene technique is used to render everything else. Objects rendered by this technique employ per-pixel diffuse lighting. The vertex shader transforms the position from object to screen space. Then, it computes the vertex position and normal in view space and passes them to the pixel shader as texture coordinates. The pixel shader uses this information to perform per-pixel lighting. A for-loop is used to compute the amount of light received from the four light sources. The diffuse term of the pixel is computed by taking the dot product of the normal and the unit vector from the pixel to the light. The attenuation term is computed as the reciprocal of the square of the distance between the pixel and the light. These two terms are then modulated to represent the amount of light the pixel receives from one of the light sources. Once this process is done for all lights in the scene, the values are summed and modulated with the light intensity and the texel to form the output.

High Dynamic Range Realism

Prior to DirectX 9.0, only integer texture formats are supported by Microsoft Direct3D. When a texture of this type is used, if a color value is higher than 1.0, it is clamped to 1.0 before being written so that the value can fit in an 8-bit integer. This means that when the cube texture is written, its texel color values will have a maximum of 1.0. When this texture is later used for environment-mapping on a material that is not 100 percent reflective (perhaps only 30 percent reflective), even the brightest texels in the texture will end up showing at 0.3 on the mesh, regardless of how high the original light intensity is. Consequently, realism is compromised. This is demonstrated in the figure below.

When DirectX 9.0's new floating-point cube texture is used with lights whose intensity is higher than 1, the texture is capable of storing color values higher than 1.0, thus preserving true luminance even after the reflectivity multiplication. The figure below shows this.

Alternatives

It is possible to achieve a high level of realism in an HDR lighting environment without using floating-point cube textures. An application can accomplish this by applying the material reflectivity multiplier when constructing the cubic environment map. Then, during rendering, the pixel shader will sample the cube texture and output the value straight back to the pipeline. This method works around color-clamping by scaling before the clamping instead of after. The drawback of this method is that if the scene has multiple environment-mapped objects with different reflectivity, a different environment map will generally need to be rendered for each of these objects.


HDRFormats Direct3D Sample

This sample shows how high dynamic range (HDR) data can be encoded into integer formats for compatibility across a wide range of devices.HDR lighting effects require the ability to work with color values beyond the 0 to 255 range, usually by storing high range color data in textures. Floating point texture formats are the natural choice for HDR applications, but they may not be available on all target systems.

  • Supported Languages
  • Path
  • Sample Overview
  • Implementation

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\HDRFormats
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csHDRFormats.exe

Sample Overview

HDR lighting techniques add realism to your application; furthermore, these techniques are fairly straightforward to implement, integrate well into an existing render pipeline, and require a modest amount of processing time; however, most HDR techniques rely in floating-point texture formats, which may not be available on the target system. One way to enable HDR techniques on devices without floating-point texture support is to encode high range floating-point data into an integer format, decoding on-the-fly as needed.

Be aware that integer textures are not perfect replacements for floating-point textures; the disadvantages of integer encoding are a loss of precision and/or a loss a range from the floating-point source, plus a performance hit resulting from the encoding/decoding process. This encoding/decoding happens seemlessly within the pixel shaders, so it is not prohibitively expensive, but it does use some of the available shader instruction count and can cause a slight frame-rate drop. For static elements, such as a skyboxes, the encoding can be done once during initialization, saving some cycles during run-time.

Implementation

The application uses two HDR techniques: tone mapping and blooming. If you are not familiar with how these techniques work or want more information about HDR images in general, view the HDRLighting and HDRCubeMap samples included with the software development kit (SDK), or consult the following references:

  • Kawase, Masaki. "Real-Time High Dynamic Range Image-Based Lighting" Leave Microsoft.
  • Reinhard, Erik, Mike Stark, Peter Shirley, and James Ferwerda. "Photographic Tone Reproduction for Digital Images" Leave Microsoft. ACM Transactions on Graphics (TOG), Proceedings of the 29th Annual Conference on Computer Graphics and Interactive Techniques (SIGGRAPH), pp. 267-276. New York, NY: ACM Press, 2002.

For the techniques used in this sample, the ability to store HDR data in textures is critical. The scene must be rendered to an HDR render target, the environment map texture needs to be HDR, and the temporary textures used to measure scene luminance all need to store HDR data. A device which supports floating-point textures will offer the best performance and simplest implementation, but with a little extra work, integer textures can be used to store HDR data. This sample implements two encoding schemes:

RGB16

Using a 16-bit per channel integer format, 65536 discrete values are available to store per-channel data. This encoding is a simple linear distribution of those 65536 values between 0.0f and an arbitrary maximum value (100.0f for this sample). The alpha channel is unused. Here is the formula for decoding the floating-point value from an encoded RGB16 color:

decoded.rgb = encoded.rgb dot max_value

RGBE8

This encoding is more sophisticated than RGB16 and allows for a far greater range of color data by using a logarithmic distribution. Each channel stores the mantissa of the color component, and the alpha channel stores a shared exponent. The added flexibility of this encoding comes at the cost of extra computation. Here is the formula for decoding the floating-point value from an encoded RGBE8 color:

decoded.rgb = encoded.rgb * 2encoded.a

The images below show the textures used to render the scene in top-down order according to when they are used. Images with a blue border contain high dynamic range data, shown here with RGBE8 encoding.

HDR rendering operations

The process of rendering the scene is nearly identical between the native floating-point texture mode and the encoded integer texture modes. Pixel shaders which read from high dynamic range textures simply require an extra decoding step when reading from encoded integer textures and require a similar encoding step when writing HDR data to integer textures. By using uniform arguments to the shader, the same shader can be compiled differently and used by every encoding scheme. For example, here is the pixel shader that lights the model:

//-----------------------------------------------------------------------------
// Name: ScenePS
// Type: Pixel Shader
// Desc: Environment mapping and simplified hemispheric lighting
//-----------------------------------------------------------------------------
float4 ScenePS( SceneVS_Output Input,
                uniform bool RGBE8,
                uniform bool RGB16 ) : COLOR
{
    // Sample the environment map
    float3 vReflect = reflect( Input.ViewVec_World, Input.Normal_World );
    float4 vEnvironment = texCUBE( CubeSampler, vReflect );

    if( RGBE8 )
        vEnvironment.rgb = DecodeRGBE8( vEnvironment );
    else if( RGB16 )
        vEnvironment.rgb = DecodeRGB16( vEnvironment );

    // Simple overhead lighting
    float3 vColor = saturate( MODEL_COLOR * Input.Normal_World.y );

    // Add in reflection
    vColor = lerp( vColor, vEnvironment.rgb, MODEL_REFLECTIVITY );

    if( RGBE8 )
        return EncodeRGBE8( vColor );
    else if( RGB16 )
        return EncodeRGB16( vColor );
    else
        return float4( vColor, 1.0f );
}


HLSLwithoutEffects Direct3D Sample

This sample shows an example of how to use Microsoft Direct3D's high-level shader language (HLSL), without the use of the D3DX effect interfaces. Not using the Effect interface is a more difficult method of using HLSL. See BasicHLSL Direct3D Sample for a simpler method of using HLSL.

  • Supported Languages
  • Path
  • Sample Overview
  • How the Sample Works

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\HLSLwithoutEffects
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csHLSLwithoutEffects.exe

Sample Overview

The sample demonstrates using HLSL to write vertex shaders without using the D3DX Effect Interfaces. HLSL is a language that closely resembles C syntax and constructs. By writing shaders in HLSL instead of assembly language, developers can take advantage of not only the features and elements of the language with which they are already familiar, but also the great optimization capabilities offered by the D3DX shader compiler.

How the Sample Works

The scene that this sample renders consists of a square grid of triangles lying on the XZ plane. In each frame, the vertices of this grid will move up or down along the Y direction based on a function of their distance to the origin and time. The vertices are also lit using another function of the distance and time. The time is incremented for each frame. Because the Y coordinate and color of the vertices are generated in each frame, they do not need to be stored. Therefore, the vertex declaration only contains a Vector2 member, for the X and Z coordinates.

During initialization, the sample calls CompileShaderFromFile to compile the sample's shader function stored in a file into binary shader code, that can be understood by the 3-D device. After this process, a GraphicsStream object containing the shader code and a ConstantTable object that allows the application to get and set the global variables of the shader are created. Then, the sample creates a new vertex shader using the shader code to obtain a VertexShader object that can be passed to the 3-D device for execution.

In OnFrameMove(), the sample uses the ConstantTable obtained from initialization to set the shader's global variables worldViewProj and appTime, in order to update the view + projection transformation and time parameter for the shader. At render time, the sample sets the VertexShader property to enable vertex shader rendering on the device. When DrawIndexedPrimitives is called after that, the vertex shader will be invoked once for every vertex processed.

In the sample, the vertex shader is written in a text file called HLSLwithoutEffects.fx. In this file, there are two global variables and a shader function called Ripple. Ripple takes a float2 as input (for X and Z of the vertex), and outputs two float4 representing the screen-space position and vertex color. The Y coordinate is generated using this formula:

Y = 0.1 * sin( 15 * L * sin(T) );

L is the distance between the vertex and the origin before the Y adjustment, so it has the value of sqrt( X^2 + Z^2 ), because the vertices are lying on the XZ plane. T is the appTime global variable.

The color of the vertex will be some shade of gray based on this formula:

C = 0.5 - 0.5 * cos( 15 * L * sin(T) );

C will be the value used for all red, green, blue, and alpha, and will range from 0 to 1, giving the vertex a color of black to white, respectively. The result looks like ripples with width changing back and forth between narrow and wide, and are properly shaded based on the slope.


ProgressiveMesh Direct3D Sample

This sample shows how an application can use the D3DX progressive mesh functionality to simplify meshes for faster rendering. A progressive mesh is a specialized mesh object that can increase or decrease its geometry complexity, thereby providing flexibility when drawing the mesh so that performance can be maintained at a steady level. This feature is useful when providing level of detail (LOD) support in an application.

  • Supported Languages
  • Path
  • How the Sample Works

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\ProgressiveMesh
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csProgressiveMesh.exe

How the Sample Works

The functionalities of progressive meshes are provided by the ProgressiveMesh object. This ProgressiveMesh object is similar to the Mesh object with additional methods for managing the mesh's complexity. The progressive mesh can be used just like a regular mesh. To render it, the sample loops through its materials and calls DrawSubset to send the geometry subset to the device. To adjust the progressive mesh's LOD, the sample sets the ProgressiveMesh.NumberVertices property to the desired number of vertices. A progressive mesh will simplify or enhance its geometry to match the number of vertices as closely as possible.

The sample also shows an optimization technique for progressive meshes by trimming multiple progressive meshes. Trimming limits the maximum and minimum number of vertices or faces a progressive mesh can have. The sample divides the range (maximum - minimum) of the progressive mesh vertices into ten sub-ranges. After the sub-ranges are computed, the sample creates ten progressive meshes by calling ProgressiveMesh.Clone on the original mesh. Then the sample calls ProgressiveMesh.TrimByVertices on each progressive mesh using a different sub-range. After setting the range of vertices, the sample calls ProgressiveMesh.OptimizeBaseLevelOfDetail to optimize the mesh's vertex and index buffers. Whenever the user changes the vertex count, the new vertex count is checked against the range of the optimized progressive mesh set, and the mesh whose range contains the desired vertex count is selected the ProgressiveMesh.NumberVertices property.

The advantage of using multiple meshes is that adjusting LOD is more efficient than using a single progressive mesh. The performance load of changing LOD is directly proportional to the difference in complexity (represented by vertex count in this sample). Simplifying a mesh by reducing the number of vertices by ten takes less time than reducing the vertex count by 100. That is why this sample achieves better performance by trimming several progressive meshes, each of which covers a smaller LOD range.


PrtPerVertex Direct3D Sample

This sample demonstrates how to use PrtEngine, a precomputed radiance transfer (PRT) simulator that uses low-order spherical harmonics (SH). The sample also demonstrates how to use these results to accomplish dynamic light transport using a dynamic lighting environment and a vs_1_1 vertex shader.

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\PrtPerVertex
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csPrtPerVertex.exe

Why is this sample interesting?

PRT using low-order SH basis functions has a number of advantages over typical diffuse (N * L) lighting. Area light sources and global effects such as interreflections, soft shadows, self shadowing, and subsurface scattering can be rendered in real time after a precomputed light transport simulation. Clustered principal component analysis (CPCA) allows the results of the simulator to be compressed so the shader does not need as many constants or per-vertex data.

Overview

The basic idea is first to run a PRT simulator offline as part of the art content creation process and to save the compressed results for later real-time use. The light transport simulator models global effects that would typically be very difficult to do in real time. The real-time engine evaluates the lights in terms of SH basis functions and sums them up into a single set of SH basis coefficients describing the entire lighting environment. It then uses a vertex shader to arrive at the vertex's diffuse color by combining the compressed simulator results and the lighting environment. Because the offline simulator did the work of computing the interreflections and soft shadows, this technique is visually impressive, efficient, and can be used for real-time lighting.

How the Sample Works

The sample performs both the offline and real time portions of PRT. The startup dialog box asks the user which step to perform. The user can run the offline simulator or view a mesh using previously saved results from the PRT simulator. The offline step would typically be done in a separate tool, but this sample does both in the same executable file.

Step 1: Offline Processing

The first step is to run the offline per vertex PRT simulator in the PRTSimulator.cs source file. This code accepts a number of parameters to control the operation of the simulator, an array of meshes, and an array of SphericalHarmonicMaterial structures. One material is allowed per mesh, so each mesh is assumed to be homogenous. The simulator's input parameters and the members of the SH material structure are explained extensively by the sample dialog's tooltips. If you want to pass in more than one mesh, before you do so the meshes need to be transformed into the same coordinate space.

Most of the simulator input parameters do not affect how the results are used. In particular sample's Order parameter does affect how to use the results, specifying the order of SH basis functions that are used to approximate transferred radiance.

In addition to the Order parameter, the spectral parameter (spectralCB) also affects the results. If spectral simulation is chosen, there will be three color channels - red, green, and blue. However, sometimes it is useful to work just with one channel (when modeling shadows, for example). If you choose non-spectral simulation, you simply use the red channel when calling the SH functions, because the other channels are optional.

The simulator will run for a period of time, typically minutes, that depends on the complexity of the meshes, the number of rays, and simulation settings. The output is a GraphicsStream object that contains an internal header and an array of float values for each vertex of the mesh.

The float values for each vertex, called radiance transfer vectors, can be used by a vertex shader to transform source radiance into exit radiance. However, since there are Order2 transfer coefficients per channel, then with spectral and Order = 6 there would be 3 x 36 or 108 scalars per vertex. Fortunately, you can compress this large number of scalars with the CPCA algorithm. The number of coefficients per vertex will be reduced to the number of principal component analysis (PCA) vectors, and this number does not need to be large for good results. For example, four or eight usually yields good results. For example, if there are eight PCA vectors and Order = 6, then you will only need eight coefficients per vertex instead of 108. The number of PCA vectors must be less than Order2.

Step 2: Rendering in Real Time

The equation to render compressed PRT data is:

PRT rendering equation

where:

Parameter | Description
Rp | A single channel of exit radiance at vertex p and is evaluated at every vertex on the mesh.
Mk | The mean for cluster k. This is an Order2 vector of coefficients.
k | The cluster identifier (ID) for vertex p.
L' | The approximation of the source radiance into the SH basis functions. This is an Order2 vector of coefficients.
j | An integer that sums over the number of PCA vectors.
N | The number of PCA vectors.
wpj | The jth PCA weight for point p. This is a single coefficient.
Bkj | The jth PCA basis vector for cluster k. This is an Order2 vector of coefficients.

The sample's PRTMesh.cs source file collects all of the data needed for this equation and passes the appropriate data to a vertex shader that implements the equation, as follows:

  1. The sample's prtMesh.LoadMesh method is used to load the mesh, but since CPCA needs (PrtCompressedBuffer.NumberPcaVectors + 1) scalars per vertex, the mesh is cloned with a VertexElement declaration that provides enough memory to store this data. The addition of one is required to provide the vertex shader an index into an array of cluster data. The sample uses the BlendWeight constant value to store the CPCA data, but this semantic is arbitrary and is chosen because skinning and PRT do not work together. In the initialization of the input vertex data with the VertexElement constructor, for usageIndex = 0, the sample defines DeclarationType as Float1 and uses it to store an index into a constant array. For usage indices 1 through 6, the declaration type is Float4. The sample can therefore store up to 24 PCA weights in the vertex buffer.
  2. The sample loads the simulator's SH PRT results from a file and places this data into a PrtCompressedBuffer object. The sample's prtMesh.CompressBuffer method then calls the PrtCompressedBuffer constructor to apply CPCA using some number of PCA vectors and some number of clusters. The output is a PrtCompressedBuffer object called prtCompBuffer that contains the data needed for the above equation. By means of the ReloadState method you can select the number of PCA vectors and clusters without running the simulator again.
  3. The sample extracts CPCA data from prtCompBuffer by first calling PrtCompressedBuffer.ExtractClusterIDs to get the cluster IDs for the vertices. This method writes to an array of Int32 Leave Site values, where the cluster ID for vertex N is at clusterIds[N]. An array offset is computed for each vertex and stored in the vertex buffer. The offset is used by the vertex shader to allow it to index directly to the data for the current vertex's cluster. This offset is simply the cluster ID times the stride of the constant array filled with CPCA data.
  4. The sample calls PrtCompressedBuffer.ExtractToMesh with usage = BlendWeight and usageIndexStart = 1 to instruct the method to store the per-vertex PCA weights in the mesh starting at the semantic BlendWeight[1], and continuing with BlendWeight[2] and so on until all the PCA weights have been written. Since the application has defined BlendWeight indices 1 through 6 to be type float4, then if there are 20 PCA vectors, this method will write to BlendWeight indices 1 through 5. Note that these vertex elements do not have to be of type float4; they only need to be signed.
  5. As the rendering equation shows, to calculate the exit radiance in the shader you need per-vertex compressed transfer vectors as well as the lighting environment (also called source radiance) approximated using SH basis functions. Several methods of the SphericalHarmonics class are available to help with this step:
    • EvaluateDirectionalLight
    • EvaluateSphericalLight
    • EvaluateConeLight
    • EvaluateHemisphereLight
    • ProjectCubeMap

    You can use one of these functions to get an array of Order2 float output values per channel for each light. Then add these arrays together using SphericalHarmonics.Add to arrive at a single set of Order2 SH coefficients per channel that describe the scene's source radiance, which is L' in the rendering equation. Note that these methods take the light direction in object space, so you will typically have to transform the light's direction by the inverse of the world matrix.
  6. The last piece of data the sample needs from the ExtractToMesh method is the cluster mean (M), and the PCA basis vectors (B). The sample stores this data in a large array of float values so that when the lights change it can reevaluate the lights and recompute M * L and B * L. To do this it calls PrtCompressedBuffer.ExtractBasis, which extracts the basis a cluster at a time. Each cluster's basis is comprised of a mean and PCA basis vectors. Therefore the size of the array needed to store all of the cluster bases is:
    int clusterBasisSize = (numberPcaVectors + 1)
                           * numberCoefficients * numberChannels;
     Note that one is added to the number of PCA vectors to store the cluster mean. Also note that since both (Mk * L') and (Bkj * L') are constant, the sample calculates these values on the CPU and passes them as constants to the vertex shader. The sample stores this per-vertex data in the vertex buffer.
  7. The sample's PrtMesh.ComputeShaderConstants method performs the M * L and B * L calculations in the rendering equation and stores the computed CPCA constant values in the prtConstants array, defined as:
    prtConstants = new float[ numberClusters
                   * (4 + numberChannels * numberPcaVectors) ];
     This array is passed directly to the vertex shader with the Effect.SetValue method. Note that the vertex shader uses float4 because each register can hold four float values, so on the vertex shader side the array is of size:
    int numberVConsts = numberClusters
                        * (1 + numberChannels * numberPcaVectors / 4) + 4;
     Evaluating the lights, and calculating and setting the constant table, are rapid procedures that can be done once or more per frame, but for optimization purposes the sample only evaluates lighting effects when the lights are moved.
  8. Now that the sample has extracted all the data it needs, it can render the scene using SH PRT with CPCA. The render loop uses the effects file PRTPerVertex.fx to render the scene. The sample's vertex shader technique PrtDiffuseVS implements the rendering equation to yield exit radiance.

Limitations

  • Because this technique uses low order spherical harmonics, the lighting environment is assumed to be of low frequency.
  • The transfer vectors are precomputed, so the relative spatial relationship of the precomputed scene cannot change. A mesh can therefore be rotated, translated, or scaled since those rigid operations do not change the transfer vectors. However, if the mesh is deformed or skinned, then the rendering will be inaccurate. The same logic also applies for scenes composed of several meshes. For example, if you pass a scene of three meshes to the simulator, the real-time engine could rotate, translate, and scale them all as one, but it could not rotate a single mesh independent of the others without producing inaccurate rendering.
  • For accurate rendering with this vertex-based technique, the mesh must be highly tessellated. However, the vertex-based technique can run on vs_1_1 hardware, while the texture-based technique requires ps_2_0 hardware.
  • If you mix meshes that have subsurface scattering with ones that do not, then you may need to scale the transfer coefficients for the subsurface scattered mesh because the scattered light is typically about three times darker. With a single mesh you can simply scale the projected light coefficients. You can scale the transfer coefficients by using PrtEngine.ScaleMeshChunk before compressing the data.

Image Resources

  • Images of the Uffizi, St. Peter's, Grace, Galileo's Tomb, and RNL Light Probe are Copyright ® 1999 Paul Debevec, and are used with permission. These images are located at:

    (SDK root)\Samples\Light Probes

  • The images are made available in Greg Ward's Radiance high dynamic range image format, Radiance Synthetic Imaging System Leave Microsoft.
  • The images were converted to the vertical cross format using HDR Shop: HDR Shop Leave Microsoft.
  • For additional images and resources, see Light Probe Image Gallery Leave Microsoft.

Further Information

For more detail about the math behind PRT, CPCA, and SH, see the following references:

  • Sloan, Peter-Pike, Jan Kautz, and John Snyder. "Precomputed Radiance Transfer for Real-Time Rendering in Dynamic, Low-Frequency Lighting Environments" Leave Microsoft. ACM Transactions on Graphics (TOG), Proceedings of the 29th Annual Conference on Computer Graphics and Interactive Techniques (SIGGRAPH), pp. 527-536. New York, NY: ACM Press, 2002.
  • Sloan, Peter-Pike, Jesse Hall, John Hart, and John Snyder. "Clustered Principal Components for Precomputed Radiance Transfer" Leave Microsoft. ACM Transactions on Graphics (TOG), Vol. 22, Issue 3 (SIGGRAPH), pp. 382-391. New York, NY: ACM Press, July 2003.
  • Green, Robin. "Spherical Harmonic Lighting: The Gritty Details" Leave Microsoft. Game Developers' Conference, San Jose, CA, March 2003.


C# Scripting Direct3D Sample

The sample demonstrates one possible technique for using C# code as a 'script' in your unmanaged applications, and includes techniques to ensure scripts that are not deemed to be 'safe' cannot be executed. The sample includes three scripts, one simple 'stateless' script, one more advanced script which maintains state and reacts to the environment, and a final script that is emulating a 'bad' script that attempts to delete files from your hard drive.

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\Scripting
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\Scripting.exe

Sample Overview

Having a robust scripting engine in your game titles can open up new avenues for development of your title. Many different aspects of the game could be controlled by these 'scripts' (although given these will actually be compiled and executed, 'script' is not entirely accurate). You could have your camera scripted for a 'cut scene' inside the game, game AI, or any other number of manipulations of your game environment. One of the more exciting prospects would be to have user added content (for example custom added units) that would use the scripts to have custom actions, and react to the environment appropriately.

This particular sample comes with three different types of scripts, each with a unique characteristic:

  • Script #1 - A simple state-less script that makes the character move slowly around the scene while rotating.
  • Script #2 - A more advanced script that maintains state, and uses this information to deteremine which action to perform. The character can bounce off walls, and the rotation will change when it does so.
  • Bad Guy Hacker Script - A script that is designed to emulate a "Bad Guy Hacker" trying to delete files from your computer. Due to the security settings set on the scripts that are allowed to run, this will not be allowed.

How the Sample Works

This sample uses the most direct technique possible to compile the C# code into scripts on the fly. It starts with the ShadowVolume C++ software development kit (SDK) Sample, and is modified to allow the character in the scene to be controllable by C# scripts. First, the sample was updated to be a mixed mode assembly by adding the /CLR compiler switch. This allows you to have your managed code that will control the scripting engine to be embedded directly into your application.

You'll notice that the unmanaged code file of the sample also includes a new #pragma unmanaged directive to let the compiler know that this code will only be unmanaged code. At startup the security policy is set and then while running, the user is allowed to pick one of the three scripts that ship with the SDK (or choose no scripts at all).

When one of the scripts is selected from the user interface, the work for compiling and loading the script's code happens. An instance of the CSharpCodeProvider Leave Site class is created, and the raw code of the script is fed into the class to be compiled. The assembly is compiled and stored in the temporary files where it is then loaded into the application. Once the assembly has been loaded, the main class of the script (which all scripts must implement) is loaded and stored; this will be used later to call the methods from the script.

Note: For this sample, any compile errors from one of the scripts will be ignored and the character will simply behave as if there are no scripts running.

Once a script has been compiled and loaded, a series of four potential methods will be called (depending on if the script implements them). The character's rotation (on each axis) can be modified, as well as the character's position.

Security Considerations

Allowing unknown code to run within your game engine can be a scary prospect to say the least. What would stop a script writer from deciding to write a script that emailed all of your important documents to everyone in your global address book, then formatted your hard drive? C# as a language is extremely powerful and could allow you to do either of these things in a fully trusted environment.

Luckily, managed code has something called Code Access Security, which was designed specifically for situations such as this. By default, any code running on the local machine (which most client applications will be) is granted Full Trust, which basically means it is allowed to do anything the language is capable of doing (like format the hard drive). To ensure these unsafe things aren't allowed the Application Domain's security policy is updated. During startup, the sample calls the Initialize() method on the script engine, which contains the following code snippet:

// Create a new, empty permission set so we don't mistakenly grant some permission we don't want
PermissionSet* pPermissions = new PermissionSet(PermissionState::None);

// Set the permissions that you will allow, in this case we only want to allow execution of code
pPermissions->AddPermission(new SecurityPermission(SecurityPermissionFlag::Execution));

// Make sure we have the permissions currently
pPermissions->Demand();

// Create the security policy level for this application domain
PolicyLevel* pSecurityLevel = PolicyLevel::CreateAppDomainLevel();

// Give the policy level's root code group a new policy statement based
// on the new permission set.
pSecurityLevel->RootCodeGroup->PolicyStatement = new PolicyStatement(pPermissions);

// Update the application domain's policy now
AppDomain::CurrentDomain->SetAppDomainPolicy(pSecurityLevel);

The code above first creates a PermissionSet, using the PermissionState::None permission state, which is essentially saying 'Do not allow this code to do anything'. Obviously, this is a little too restrictive, since at the very least, you will want the code that is running the scripts to be executed. Given that, you can add a new permission to this list that you will allow, and as you see in the code snippet, the SecurityPermissionFlag::Execution is added (there are quite a few different security permissions that can be set in this manner). After the PolicyLevel is created, and the RootCodeGroup is updated, the application domain's security policy is updated. Any assemblies loaded after this point (such as the scripts later) will have this security policy enforced. Notice when you're running the sample, the final script fails to run due to the security violations.

Performance Considerations

In this sample, you'll notice that the InvokeMember() method is called in order to execute the script methods. While this method is quick to implement and works well, this technique also relies on Reflection to make this call, which can be an order of magnitude slower than simply calling the method directly. In the scenario where you are making one (or more) calls per frame as this sample is doing, you will probably want to implement a more efficient way to call these methods.

One of the easier implementations that has much better performance than this technique is by defining an interface that the scripts must implement. You would put this interface into a managed assembly which you would then add a reference to in your application. When compiling the script, you would get the Interface type you declared in the managed assembly and call the methods on that directly. This would remove the cost of the InvokeMember() method, and instead allow you to call into the compiled scripts directly.

Implementation Considerations

It might not be possible (or practical) for your application to be compiled with the /CLR switch to be compiled as a mixed mode assembly (one that contains both managed and unmanaged code) like this sample does. There are numerous other ways you could implement techniques similar to what this sample does such as:

  • Separate mixed mode assembly that contains both the Script Engine code (like this example has) as well as an unmanaged interopability layer that your unmanaged code will call.
  • Separate purely managed assembly (for example a C# assembly) that contains the ScriptEngine code where the classes are marked as [ComImport]. This method requires much more setup time because the managed assembly will need to be registered for Component Object Model (COM) use via the RegAsm tool.
  • Require the script code themselves to implement the [ComImport] attribute. This is definitely the worst of the scenarios.


SimpleAnimation Direct3D Sample

This sample shows how to animate a 3-D model that has a skeletal structure.

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\SimpleAnimation
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csSimpleAnimation.exe

Sample Overview

This sample shows how to access bone and skinning information in a mesh hierarchy and render the animated mesh to the display.

How the Sample Works

The Sample Framework is used to initialize and run a simple Microsoft Direct3D animation application.


Text3D Direct3D Sample

This sample shows how to draw 2-D text in a 3-D scene. This is useful for displaying statistics or game menus, for example.

Supported Languages

  • C#

Path

Source: | (SDK root)\Samples\Managed\Direct3D\Text3D
Executable: | (SDK root)\Samples\Managed\Direct3D\Bin\x86\csText3D.exe

Programming Notes

This sample uses the Font class to display 2-D text in a 3-D scene. The class uses Microsoft Windows Graphics Device Interface (GDI) to load a font and output each letter to a bitmap. That bitmap, in turn, is used to create a texture.

When the DrawText function is called, a vertex buffer is filled with polygons that are textured using the font texture created as mentioned above. The polygons may be drawn as a 2-D overlay which may be useful for printing statistics.

The sample also creates a 3-D mesh of a text string and renders it.


Sample Framework for DirectX 9.0 for Managed Code

The sample framework is a layer used by most of the Microsoft Direct3D samples and is built on top of the Microsoft Windows application programming interface (API) and the Direct3D API. Its goal is to make Direct3D samples, prototypes, and tools as well as professional games more robust and easier to build. It simplifies the Windows and Direct3D APIs for typical usage and is designed to help make simple to moderately complex Direct3D applications.

Using the Sample Framework

The Microsoft DirectX 9.0 for Managed Code sample framework is included in the DirectX software development kit (SDK) as C# source files that you can include in your application. They are located in the following directory:

(SDK root)\Samples\Managed\Common

To include the functionality of the sample framework in an application you can either start your application with the EmptyProject Direct3D Sample or do the following:
  • Add the following classes to your project:
    • dxmut.cs
    • dxmutdata.cs
    • dxmutenum.cs
    • dxmutexception.cs
    • dxmutgui.cs
    • dxmutmesh.cs
    • dxmutmisc.cs
    • dxmutSettingsDlg.cs
  • Add references to the following dynamic-link libraries (DLLs) to your project:
    • Microsoft.DirectX.dll
    • Microsoft.DirectX.Direct3D.dll
    • Microsoft.DirectX.Direct3DX.dll
  • Set the "Allow Unsafe Code Blocks" build flag for your project to true.

For documentation on the API elements provided by the framework, see Sample Framework Reference.

Related Topics

  • Direct3D Samples for Managed Code


Framework Class (Framework)

Framework Class

Language:

Contains properties and methods that provide helper functionality for 3-D graphics in applications such as the Microsoft DirectX 9.0 for Managed Code sample applications included in the DirectX software development kit (SDK).

Definition

Visual Basic Public Class Framework
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Framework : MarshalByRefObject, IDisposable
C++ | public ref class Framework : MarshalByRefObject, IDisposable
JScript | public class Framework extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
DeviceCreated | Occurs when the Direct3D Device object is created.
DeviceLost | Occurs when the Direct3D Device object is lost.
DeviceReset | Occurs when the Direct3D Device object is reset.
Disposing | Occurs when the Framework object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
DefaultSizeHeight | Retrieves the default window height, in pixels, when the application starts.
DefaultSizeWidth | Retrieves the default window width, in pixels, when the application starts.
TrueIntPtr | Retrieves the Boolean value of true as a System.IntPtr Leave Site.

Methods

Method | Description
CloseWindow | Closes the current application window.
CreateDevice | Creates a Microsoft Direct3D device.
CreateDeviceFromSettings | Tells the framework to change to a device created from settings described in a DeviceSettings object.
CreateWindow | Creates a window for the application.
DisplayErrorMessage | Displays a custom error message box.
Dispose | Immediately releases the unmanaged resources used by the Framework object.
Finalize | Allows the Framework object to free resources before it is destroyed by the garbage collector.
Initialize | Initializes the sample framework.
KillTimer | Uninstalls an existing timer.
LoadFirstIconFromResource | Attempts to load the first icon from the application's resources.
MainLoop | Starts the main execution loop of the sample framework.
Pause | Sets the paused state of the sample framework internal timer and/or rendering process.
Render3DEnviroment | Renders the 3-D environment and updates application and device parameters.
Reset3DEnviroment | Resets the 3-D environment.
ResetState | Resets the sample framework state to its initial default state, and all previous framework state changes are lost.
SetCallbackInterface | Sets the interface that the sample framework will use to call into samples.
SetConstantFrameTime | Enables or disables a constant frame time.
SetCursorSettings | Sets options for cursor usage in full-screen mode.
SetDevice | Sets an existing Direct3D Device for use by the sample framework.
SetDeviceCreationInterface | Sets the interface that the framework will use to determine if a device is acceptable.
SetKeyboardCallback | Sets the keyboard event callback function.
SetMouseCallback | Sets the mouse event callback function.
SetTimer | Adds a timer to the list of timers for the application.
SetWindow | Sets a previously created window for the framework to use.
SetWndProcCallback | Sets the WndProcCallback delegate to use in the sample framework.
ShowSettingsDialog | Indicates whether the sample framework's device settings dialog box is currently showing.
ToggleFullscreen | Switches the application between windowed and full-screen modes.
ToggleReference | Switches the application between hardware abstraction layer (HAL) and reference devices.

Properties

Property | Description
BackBufferSurfaceDescription | Retrieves a SurfaceDescription structure that describes the back buffer on the current adapter.
CanAutomaticallyChangeMonitor | Sets or retrieves if the current adapter can automatically change monitors.
Device | Retrieves the Device object currently used by the framework.
DeviceCaps | Retrieves a Caps structure that describes the capabilities of the current device.
DeviceSettings | Retrieves the DeviceSettings object that contains the device settings for the current Device object used by the framework.
DeviceStats | Retrieves a string containing the current device type, vertex processing behavior, and device name.
ExitCode | Retrieves the sample framework exit code.
FPS | Retrieves the number of frames per second the application is currently running.
FrameStats | Retrieves a string containing the current number of frames per second, resolution, back buffer format, and depth stencil format.
IsD3DSettingsDialogShowing | Retrieves whether the settings dialog is displayed.
IsNotifiedOnMouseMove | Retrieves whether the framework should notify for mouse moves.
IsOverridingFullScreen | Retrieves whether the framework should override and start fullscreen.
IsWindowed | Retrieves whether the current device is windowed.
PresentParameters | Retrieves the PresentParameters object for the current Device object.
Window | Retrieves the handle of the window used for rendering.
WindowClientRectangle | Retrieves the size and location of the window that is rendering.
WindowDeviceFullscreen | Retrieves the handle of the window used for fullscreen rendering.
WindowDeviceWindowed | Retrieves the handle of the window used for windowed rendering.
WindowFocus | Retrieves the handle of the window that currently has focus.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Framework

Class Information

Namespace | Framework
Assembly ()
Strong Name | , Version=, Culture=, PublicKeyToken=


Framework.CloseWindow() Method (CloseWindow)

Framework.CloseWindow Method

Closes the current application window.

Definition

Visual Basic | Public Sub CloseWindow()
C# | public void CloseWindow();
C++ public:
void CloseWindow();
JScript | public function CloseWindow();


Framework.CreateDevice(UInt32,Boolean,Int32,Int32,CreateDevice) Method (CreateDevice)

Framework.CreateDevice Method

Creates a Microsoft Direct3D device.

Definition

Visual Basic Public Sub CreateDevice( _
ByVal adapterOridinal As UInt32, _
ByVal windowed As Boolean, _
ByVal suggestedWidth As Integer, _
ByVal suggestedHeight As Integer, _
ByVal callback As IDeviceCreation _
)
C# public void CreateDevice(
uint adapterOridinal,
bool windowed,
int suggestedWidth,
int suggestedHeight,
IDeviceCreation callback
);
C++ public:
void CreateDevice(
unsigned int adapterOridinal,
bool windowed,
int suggestedWidth,
int suggestedHeight,
IDeviceCreation^ callback
);
JScript public function CreateDevice(
adapterOridinal : uint,
windowed : boolean,
suggestedWidth : int,
suggestedHeight : int,
callback : IDeviceCreation
);

Parameters

adapterOridinal System.Int32
The index of the desired adapter.
windowed System.Boolean
Set to true to start the application windowed. Set to false to start the application full-screen.
suggestedWidth System.Int32
The requested initial width of the application's back buffer.
suggestedHeight System.Int32
The requested initial height of the application's back buffer.
callback Microsoft.Samples.DirectX.UtilityToolkit.IDeviceCreation
An interface that the framework will use to determine if a device is acceptable.

Remarks

If CreateWindow or SetWindow has not already been called, this method will call CreateWindow with default parameters. Instead of calling CreateDevice, you can call SetDevice or CreateDeviceFromSettings.

The actual height and width may be adjusted to fit device and operating system constraints. The default value is 640x480.


Framework.CreateDeviceFromSettings Method ()

Tells the framework to change to a device created from settings described in a DeviceSettings object.

Overload List

public void CreateDeviceFromSettings(DeviceSettings);
public void CreateDeviceFromSettings(DeviceSettings, bool);

Remarks

If CreateWindow or SetWindow has not already been called, this method will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDevice.


Framework.CreateDeviceFromSettings(CreateDeviceFromSettings) Method (CreateDeviceFromSettings)

Framework.CreateDeviceFromSettings Method

Tells the framework to change to a device created from settings described in a DeviceSettings object.

Definition

Visual Basic Public Sub CreateDeviceFromSettings( _
ByVal deviceSettings As DeviceSettings _
)
C# public void CreateDeviceFromSettings(
DeviceSettings deviceSettings
);
C++ public:
void CreateDeviceFromSettings(
DeviceSettings^ deviceSettings
);
JScript public function CreateDeviceFromSettings(
deviceSettings : DeviceSettings
);

Parameters

deviceSettings Microsoft.Samples.DirectX.UtilityToolkit.DeviceSettings
The DeviceSettings object contains the settings for the new device.

Remarks

If CreateWindow or SetWindow has not already been called, this method will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDevice.


Framework.CreateDeviceFromSettings(CreateDeviceFromSettings,Boolean) Method (CreateDeviceFromSettings)

Framework.CreateDeviceFromSettings Method

Tells the framework to change to a device created from settings described in a DeviceSettings object.

Definition

Visual Basic Public Sub CreateDeviceFromSettings( _
ByVal deviceSettings As DeviceSettings, _
ByVal preserveInput As Boolean _
)
C# public void CreateDeviceFromSettings(
DeviceSettings deviceSettings,
bool preserveInput
);
C++ public:
void CreateDeviceFromSettings(
DeviceSettings^ deviceSettings,
bool preserveInput
);
JScript public function CreateDeviceFromSettings(
deviceSettings : DeviceSettings,
preserveInput : boolean
);

Parameters

deviceSettings Microsoft.Samples.DirectX.UtilityToolkit.DeviceSettings
The DeviceSettings object contains the settings for the new device.
preserveInput System.Boolean
Set to true if the device settings in the DeviceSettings object will be used without change. Set to false if a valid device will be created with device settings that are as near as possible to the original device settings in the DeviceSettings object.

Remarks

If CreateWindow or SetWindow has not already been called, this method will call CreateWindow with default parameters. Instead of calling this, you can call SetDevice or CreateDevice.


Framework.CreateWindow Method ()

Creates a window for the application.

Overload List

public void CreateWindow(string);
public void CreateWindow(string, Icon, MainMenu, int, int);

Remarks

This method is called by the framework with default parameter if the application calls the CreateDevice, SetDevice, or CreateDeviceFromSettings methods before this method.

Instead of calling CreateWindow, you can call SetWindow to change the settings of the current window used by the application.


Framework.CreateWindow(String) Method (CreateWindow)

Framework.CreateWindow Method

Creates a window for the application.

Definition

Visual Basic Public Sub CreateWindow( _
ByVal windowTitle As String _
)
C# public void CreateWindow(
string windowTitle
);
C++ public:
void CreateWindow(
String^ windowTitle
);
JScript public function CreateWindow(
windowTitle : String
);

Parameters

windowTitle System.String
The title to use for the form that is created.

Remarks

This method is called by the framework with default parameter if the application calls the CreateDevice, SetDevice, or CreateDeviceFromSettings methods before this method.

Instead of calling CreateWindow, you can call SetWindow to change the settings of the current window used by the application.


Framework.CreateWindow(String,Icon,MainMenu,Int32,Int32) Method (CreateWindow)

Framework.CreateWindow Method

Creates a window for the application.

Definition

Visual Basic Public Sub CreateWindow( _
ByVal windowTitle As String, _
ByVal icon As Icon, _
ByVal menu As MainMenu, _
ByVal x As Integer, _
ByVal y As Integer _
)
C# public void CreateWindow(
string windowTitle,
Icon icon,
MainMenu menu,
int x,
int y
);
C++ public:
void CreateWindow(
String^ windowTitle,
Icon^ icon,
MainMenu^ menu,
int x,
int y
);
JScript public function CreateWindow(
windowTitle : String,
icon : Icon,
menu : MainMenu,
x : int,
y : int
);

Parameters

windowTitle System.String
The title to use for the form that is created.
icon System.Drawing.Icon
The icon to use for the form that is created.
menu System.Windows.Forms.MainMenu
The menu to use for the form that is created.
x System.Int32
The horizontal start position for the window that is created.
y System.Int32
The vertical start position for the window that is created.

Remarks

This method is called by the framework with default parameter if the application calls the CreateDevice, SetDevice, or CreateDeviceFromSettings methods before this method.

Instead of calling CreateWindow, you can call SetWindow to change the settings of the current window used by the application.


Framework.DisplayErrorMessage(Exception) Method (DisplayErrorMessage)

Framework.DisplayErrorMessage Method

Displays a custom error message box.

Definition

Visual Basic Public Sub DisplayErrorMessage( _
ByVal e As Exception _
)
C# public void DisplayErrorMessage(
Exception e
);
C++ public:
void DisplayErrorMessage(
Exception^ e
);
JScript public function DisplayErrorMessage(
e : Exception
);

Parameters

e System.Exception
The exception that the displayed message box will show.


Framework.Dispose() Method (Dispose)

Framework.Dispose Method

Immediately releases the unmanaged resources used by the Framework object.

Definition

Visual Basic | Public Sub Dispose()
C# | public void Dispose();
C++ | ~Framework();
JScript | public function Dispose();


Framework.Finalize() Method (Finalize)

Framework.Finalize Method

Allows the Framework object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Public Sub Finalize()
C# | public void Finalize();
C++ public:
void Finalize();
JScript | public function Finalize();


Framework.Initialize(Boolean,Boolean,Boolean) Method (Initialize)

Framework.Initialize Method

Initializes the sample framework.

Definition

Visual Basic Public Sub Initialize( _
ByVal isParsingCommandLine As Boolean, _
ByVal handleDefaultKeys As Boolean, _
ByVal showMessageBoxOnError As Boolean _
)
C# public void Initialize(
bool isParsingCommandLine,
bool handleDefaultKeys,
bool showMessageBoxOnError
);
C++ public:
void Initialize(
bool isParsingCommandLine,
bool handleDefaultKeys,
bool showMessageBoxOnError
);
JScript public function Initialize(
isParsingCommandLine : boolean,
handleDefaultKeys : boolean,
showMessageBoxOnError : boolean
);

Parameters

isParsingCommandLine System.Boolean
Set to true if the sample framework checks for command-line arguments; otherwise, false.
handleDefaultKeys System.Boolean
Set to true if the sample framework automatically responds to certain keyboard input; otherwise, false.
showMessageBoxOnError System.Boolean
Set to true if the sample framework displays a message box if there is an error condition; otherwise, false.

Remarks

Command-line arguments take precedence over options set by the application when a Microsoft Direct3D device is first created, but they are ignored afterward to allow the user to interactively change the settings.

The following table contains descriptions of possible command-line arguments when executing a sample framework application.
Command-line Argument | Description
-adapter:# | Forces the application to use this adapter ordinal. Fails if the adapter ordinal does not exist.
-fullscreen | Starts in full-screen mode.
-windowed | Starts in windowed mode.
-startx:# | For windowed mode, sets the x-coordinate of the window position to the value of #.
-starty:# | For windowed mode, sets the y-coordinate of the window position to the value of #.
-height:# | Sets the window height to the value of #. For full-screen mode, the sample framework picks the closest possible supported mode.
-width:# | Sets the window width to the value of #. For full-screen mode, the sample framework picks the closest possible supported mode.
-forcehal | Forces the application to use a hardware abstraction layer (HAL) device type. Fails if a HAL device does not exist.
-forcehwvp | Forces the application to use hardware vertex processing. Fails if the device does not support this mode.
-forcepurehwvp | Forces the application to use pure hardware vertex processing. Fails if the device does not support this mode.
-forceref | Forces the application to use a reference device type. Fails if a reference device does not exist.
-forceswvp | Forces the application to use software vertex processing.
-constantframetime | Uses a constant frame time.
-noerrormsgboxes | Prevents the display of message boxes generated by the framework, allowing the application to be run without user interaction.
-quitafterframe:# | Forces the application to quit after frame #.

The following table lists the keyboard input that is handled by default when the handleDefaultKeys property is set to true.
Keyboard Input | Description
ALT+ENTER | Toggles between full-screen and windowed modes.
ESC | Exits the application.
F2 | Prompts the user to select a new rendering device or display mode.
F3 | Toggles between HAL and reference devices.
F8 | Toggles between wireframe and rendered views.
PAUSE | Pauses the application.


Framework.KillTimer(Int32) Method (KillTimer)

Framework.KillTimer Method

Uninstalls an existing timer.

Definition

Visual Basic Public Sub KillTimer( _
ByVal id As Integer _
)
C# public void KillTimer(
int id
);
C++ public:
void KillTimer(
int id
);
JScript public function KillTimer(
id : int
);

Parameters

id System.Int32
The event identifier (ID) for the timer being destroyed.

Remarks

The ID used by the id parameter is provided to the application by the SetTimer method.

Timers created with the SetTimer method can be destoryed by this method.


Framework.LoadFirstIconFromResource() Method (LoadFirstIconFromResource)

Framework.LoadFirstIconFromResource Method

Attempts to load the first icon from the application's resources.

Definition

Visual Basic | Public Function LoadFirstIconFromResource() As Icon
C# | public Icon LoadFirstIconFromResource();
C++ public:
Icon^ LoadFirstIconFromResource();
JScript | public function LoadFirstIconFromResource() : Icon;

Return Value

System.Drawing.Icon
The first icon from the application's resources.

Remarks

If no icon is found in the application's resources, this method wil return a null.


Framework.MainLoop() Method (MainLoop)

Framework.MainLoop Method

Starts the main execution loop of the sample framework.

Definition

Visual Basic | Public Sub MainLoop()
C# | public void MainLoop();
C++ public:
void MainLoop();
JScript | public function MainLoop();

Remarks

This method starts the message loop that will run for the lifetime of the application. During execution, MainLoop calls the registered callback functions to inform the application of input events and to trigger resource management and render calls.


Framework.Pause(Boolean,Boolean) Method (Pause)

Framework.Pause Method

Sets the paused state of the sample framework internal timer and/or rendering process.

Definition

Visual Basic Public Sub Pause( _
ByVal pauseTime As Boolean, _
ByVal pauseRendering As Boolean _
)
C# public void Pause(
bool pauseTime,
bool pauseRendering
);
C++ public:
void Pause(
bool pauseTime,
bool pauseRendering
);
JScript public function Pause(
pauseTime : boolean,
pauseRendering : boolean
);

Parameters

pauseTime System.Boolean
Set to true to pause the sample framework internal timer. Set to false to resume the sample framework internal timer.
pauseRendering System.Boolean
Set to true to keep the application from rendering. Set to false to resume the sample framework rendering.


Framework.Render3DEnviroment() Method (Render3DEnviroment)

Framework.Render3DEnviroment Method

Renders the 3-D environment and updates application and device parameters.

Definition

Visual Basic | Public Sub Render3DEnviroment()
C# | public void Render3DEnviroment();
C++ public:
void Render3DEnviroment();
JScript | public function Render3DEnviroment();

Remarks

This method does not normally need to be called. It is useful only when the application does not use MainLoop but still wants the sample framework to assist with rendering.

This method checks whether the device is lost. If so, the method attempts to reset the device and then calls the neccessary FrameMove and Render methods.

If the application window is minimized or the application is paused, CPU time is yielded to other processes.


Framework.Reset3DEnviroment() Method (Reset3DEnviroment)

Framework.Reset3DEnviroment Method

Resets the 3-D environment.

Definition

Visual Basic | Public Sub Reset3DEnviroment()
C# | public void Reset3DEnviroment();
C++ public:
void Reset3DEnviroment();
JScript | public function Reset3DEnviroment();

Remarks

When this method is called, the sample framework calls the DeviceLost event then resets the device. After that, this method stores the back buffer description, sets up the full screen Microsoft Direct3D cursor if requested, and then calls the DeviceReset event.


Framework.ResetState() Method (ResetState)

Framework.ResetState Method

Resets the sample framework state to its initial default state, and all previous framework state changes are lost.

Definition

Visual Basic | Public Sub ResetState()
C# | public void ResetState();
C++ public:
void ResetState();
JScript | public function ResetState();

Remarks

This method is useful for testing purposes because the application process does not have to be restarted.


Framework.SetCallbackInterface(SetCallbackInterface) Method (SetCallbackInterface)

Framework.SetCallbackInterface Method

Sets the interface that the sample framework will use to call into samples.

Definition

Visual Basic Public Sub SetCallbackInterface( _
ByVal callback As IFrameworkCallback _
)
C# public void SetCallbackInterface(
IFrameworkCallback callback
);
C++ public:
void SetCallbackInterface(
IFrameworkCallback^ callback
);
JScript public function SetCallbackInterface(
callback : IFrameworkCallback
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.IFrameworkCallback
The interface that the sample framework will use to call into samples.


Framework.SetConstantFrameTime Method ()

Enables or disables a constant frame time.

Overload List

public void SetConstantFrameTime(bool);
public void SetConstantFrameTime(bool, float);

Remarks

The default rate is one second for every 30 frames, or 0.0333 seconds per frame.

This function is useful for saving the rendered output to a video format for playback, allowing animation at a rate independent of the actual rate at which frames were rendered.


Framework.SetConstantFrameTime(Boolean) Method (SetConstantFrameTime)

Framework.SetConstantFrameTime Method

Enables or disables a constant frame time.

Definition

Visual Basic Public Sub SetConstantFrameTime( _
ByVal constantFrameTime As Boolean _
)
C# public void SetConstantFrameTime(
bool constantFrameTime
);
C++ public:
void SetConstantFrameTime(
bool constantFrameTime
);
JScript public function SetConstantFrameTime(
constantFrameTime : boolean
);

Parameters

constantFrameTime System.Boolean
Set to true to enable a constant frame time; otherwise, false.

Remarks

The default rate is one second for every 30 frames, or 0.0333 seconds per frame.

This function is useful for saving the rendered output to a video format for playback, allowing animation at a rate independent of the actual rate at which frames were rendered.


Framework.SetConstantFrameTime(Boolean,Single) Method (SetConstantFrameTime)

Framework.SetConstantFrameTime Method

Enables or disables a constant frame time.

Definition

Visual Basic Public Sub SetConstantFrameTime( _
ByVal constantFrameTime As Boolean, _
ByVal timePerFrame As Single _
)
C# public void SetConstantFrameTime(
bool constantFrameTime,
float timePerFrame
);
C++ public:
void SetConstantFrameTime(
bool constantFrameTime,
float timePerFrame
);
JScript public function SetConstantFrameTime(
constantFrameTime : boolean,
timePerFrame : float
);

Parameters

constantFrameTime System.Boolean
Set to true to enable a constant frame time; otherwise, false.
timePerFrame System.Single
Time per frame, in seconds.

Remarks

The default rate is one second for every 30 frames, or 0.0333 seconds per frame.

This function is useful for saving the rendered output to a video format for playback, allowing animation at a rate independent of the actual rate at which frames were rendered.


Framework.SetCursorSettings(Boolean,Boolean) Method (SetCursorSettings)

Framework.SetCursorSettings Method

Sets options for cursor usage in full-screen mode.

Definition

Visual Basic Public Sub SetCursorSettings( _
ByVal showCursorWhenFullscreen As Boolean, _
ByVal clipCursorWhenFullscreen As Boolean _
)
C# public void SetCursorSettings(
bool showCursorWhenFullscreen,
bool clipCursorWhenFullscreen
);
C++ public:
void SetCursorSettings(
bool showCursorWhenFullscreen,
bool clipCursorWhenFullscreen
);
JScript public function SetCursorSettings(
showCursorWhenFullscreen : boolean,
clipCursorWhenFullscreen : boolean
);

Parameters

showCursorWhenFullscreen System.Boolean
Set to true if the cursor will be visible when the application is running in full-screen mode; otherwise, false.
clipCursorWhenFullscreen System.Boolean
Set to true if the cursor will be restricted from exiting the screen boundaries when the application is running in full-screen mode; otherwise, false.


Framework.SetDevice(Device) Method (SetDevice)

Framework.SetDevice Method

Sets an existing Microsoft Direct3D Device for use by the sample framework.

Definition

Visual Basic Public Sub SetDevice( _
ByVal device As Device _
)
C# public void SetDevice(
Device device
);
C++ public:
void SetDevice(
Device^ device
);
JScript public function SetDevice(
device : Device
);

Parameters

device Microsoft.DirectX.Direct3D.Device
The Direct3D Device the sample framework is to use.

Remarks

If the CreateWindow method has not already been called, it will call it with the default parameters. Instead of calling SetDevice, you can call CreateDevice method or CreateDeviceFromSettings method.

The application can call this method after a device has already been created to change the current device.


Framework.SetDeviceCreationInterface(SetDeviceCreationInterface) Method (SetDeviceCreationInterface)

Framework.SetDeviceCreationInterface Method

Sets the interface that the framework will use to determine if a device is acceptable.

Definition

Visual Basic Public Sub SetDeviceCreationInterface( _
ByVal callback As IDeviceCreation _
)
C# public void SetDeviceCreationInterface(
IDeviceCreation callback
);
C++ public:
void SetDeviceCreationInterface(
IDeviceCreation^ callback
);
JScript public function SetDeviceCreationInterface(
callback : IDeviceCreation
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.IDeviceCreation
The interface that the framework will use to determine if a device is acceptable.


Framework.SetKeyboardCallback(SetKeyboardCallback) Method (SetKeyboardCallback)

Framework.SetKeyboardCallback Method

Sets the keyboard event callback function.

Definition

Visual Basic Public Sub SetKeyboardCallback( _
ByVal callback As KeyboardCallback _
)
C# public void SetKeyboardCallback(
KeyboardCallback callback
);
C++ public:
void SetKeyboardCallback(
KeyboardCallback^ callback
);
JScript public function SetKeyboardCallback(
callback : KeyboardCallback
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.KeyboardCallback
The KeyboardCallback delegate the sample framework will use.

Remarks

If the callback parameter is set to null, the sample framework will not notify the application about keyboard events.


Framework.SetMouseCallback(SetMouseCallback) Method (SetMouseCallback)

Framework.SetMouseCallback Method

Sets the mouse event callback function.

Definition

Visual Basic Public Sub SetMouseCallback( _
ByVal callback As MouseCallback _
)
C# public void SetMouseCallback(
MouseCallback callback
);
C++ public:
void SetMouseCallback(
MouseCallback^ callback
);
JScript public function SetMouseCallback(
callback : MouseCallback
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.MouseCallback
The MouseCallback delegate the sample framework will use.

Remarks

If the callback parameter is set to null, the sample framework will not notify the application about mouse events.


Framework.SetTimer(SetTimer,Single) Method (SetTimer)

Framework.SetTimer Method

Adds a timer to the list of timers for the application.

Definition

Visual Basic Public Function SetTimer( _
ByVal callbackTimer As TimerCallback, _
ByVal timeoutInSeconds As Single _
) As Integer
C# public int SetTimer(
TimerCallback callbackTimer,
float timeoutInSeconds
);
C++ public:
int SetTimer(
TimerCallback^ callbackTimer,
float timeoutInSeconds
);
JScript public function SetTimer(
callbackTimer : TimerCallback,
timeoutInSeconds : float
) : int;

Parameters

callbackTimer Microsoft.Samples.DirectX.UtilityToolkit.TimerCallback
The TimerCallback delegate that handles the timer events.
timeoutInSeconds System.Single
Interval, in seconds, between successive calls to the TimerCallback delegate.

Return Value

System.Int32
The unique identifier (ID) of the timer.

Remarks

Timers that are created with this method can be destroyed by the KillTimer method.


Framework.SetWindow(IntPtr,IntPtr,IntPtr,Boolean) Method (SetWindow)

Framework.SetWindow Method

Sets a previously created window for the framework to use.

Definition

Visual Basic Public Sub SetWindow( _
ByVal windowFocus As IntPtr, _
ByVal windowDeviceFullscreen As IntPtr, _
ByVal windowDeviceWindowed As IntPtr, _
ByVal handleMessages As Boolean _
)
C# public void SetWindow(
IntPtr windowFocus,
IntPtr windowDeviceFullscreen,
IntPtr windowDeviceWindowed,
bool handleMessages
);
C++ public:
void SetWindow(
IntPtr windowFocus,
IntPtr windowDeviceFullscreen,
IntPtr windowDeviceWindowed,
bool handleMessages
);
JScript public function SetWindow(
windowFocus : IntPtr,
windowDeviceFullscreen : IntPtr,
windowDeviceWindowed : IntPtr,
handleMessages : boolean
);

Parameters

windowFocus System.IntPtr
Handle of the Microsoft Direct3D focus window.
windowDeviceFullscreen System.IntPtr
Handle of the Direct3D window used in full-screen mode.
windowDeviceWindowed System.IntPtr
Handle of the Direct3D window used in windowed mode.
handleMessages System.Boolean
Set to true if the framework will handle and respond to messages for the window. Set to false the framework will not handle messages for the window, giving the application full responsibility for responding to messages.

Remarks

If the SetWindow method has not already been called, it will call it with default parameters. Instead of calling SetWindow you can call the CreateWindow method to create a new window.

No input parameter may be null. However, the same handle may be used for more than one parameter.


Framework.SetWndProcCallback(SetWndProcCallback) Method (SetWndProcCallback)

Framework.SetWndProcCallback Method

Sets the WndProcCallback delegate to use in the sample framework.

Definition

Visual Basic Public Sub SetWndProcCallback( _
ByVal callback As WndProcCallback _
)
C# public void SetWndProcCallback(
WndProcCallback callback
);
C++ public:
void SetWndProcCallback(
WndProcCallback^ callback
);
JScript public function SetWndProcCallback(
callback : WndProcCallback
);

Parameters

callback Microsoft.Samples.DirectX.UtilityToolkit.WndProcCallback
The WndProcCallback delegate to use in the sample framework.


Framework.ShowSettingsDialog(Boolean) Method (ShowSettingsDialog)

Framework.ShowSettingsDialog Method

Indicates whether the sample framework's device settings dialog box is currently showing.

Definition

Visual Basic Public Sub ShowSettingsDialog( _
ByVal show As Boolean _
)
C# public void ShowSettingsDialog(
bool show
);
C++ public:
void ShowSettingsDialog(
bool show
);
JScript public function ShowSettingsDialog(
show : boolean
);

Parameters

show System.Boolean
Set to true if the sample framework's device settings dialog box is currently showing; otherwise, false.


Framework.ToggleFullscreen() Method (ToggleFullscreen)

Framework.ToggleFullscreen Method

Switches the application between windowed and full-screen modes.

Definition

Visual Basic | Public Sub ToggleFullscreen()
C# | public void ToggleFullscreen();
C++ public:
void ToggleFullscreen();
JScript | public function ToggleFullscreen();

Remarks

Toggling between windowed and full-screen modes will result in the Microsoft Direct3D device being reset or recreated.


Framework.ToggleReference() Method (ToggleReference)

Framework.ToggleReference Method

Switches the application between hardware abstraction layer (HAL) and reference devices.

Definition

Visual Basic | Public Sub ToggleReference()
C# | public void ToggleReference();
C++ public:
void ToggleReference();
JScript | public function ToggleReference();

Remarks

Toggling between HAL and reference devices will result in the Microsoft Direct3D device being recreated.


Framework.BackBufferSurfaceDescription Property (BackBufferSurfaceDescription)

Framework.BackBufferSurfaceDescription Property

Retrieves a SurfaceDescription structure that describes the back buffer on the current adapter.

Definition

Visual Basic | Public ReadOnly Property BackBufferSurfaceDescription As SurfaceDescription
C# | public SurfaceDescription BackBufferSurfaceDescription { get; }
C++ public:
property SurfaceDescription BackBufferSurfaceDescription {
SurfaceDescription get();
}
JScript | public function get BackBufferSurfaceDescription() : SurfaceDescription

Property Value

Microsoft.DirectX.Direct3D.SurfaceDescription
A SurfaceDescription structure that describes the back buffer on the current adapter.

This property is read-only.


Framework.CanAutomaticallyChangeMonitor Property (CanAutomaticallyChangeMonitor)

Framework.CanAutomaticallyChangeMonitor Property

Sets or retrieves if the current adapter can automatically change monitors.

Definition

Visual Basic | Public Property CanAutomaticallyChangeMonitor As Boolean
C# | public bool CanAutomaticallyChangeMonitor { get; set; }
C++ public:
property bool CanAutomaticallyChangeMonitor {
bool get();
void set(bool value);
}
JScript public function get CanAutomaticallyChangeMonitor() : boolean
public function set CanAutomaticallyChangeMonitor(boolean);

Property Value

System.Boolean
A value that is set to true if the current adapter can automatically change monitors; otherwise, false.

This property is read/write.


Framework.Device Property (Device)

Framework.Device Property

Retrieves the Device object currently used by the framework.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device object currently used by the framework.

This property is read-only.

Remarks

This property will return a null if no device has been created by the framework.


Framework.DeviceCaps Property (DeviceCaps)

Framework.DeviceCaps Property

Retrieves a Caps structure that describes the capabilities of the current device.

Definition

Visual Basic | Public ReadOnly Property DeviceCaps As Caps
C# | public Caps DeviceCaps { get; }
C++ public:
property Caps DeviceCaps {
Caps get();
}
JScript | public function get DeviceCaps() : Caps

Property Value

Microsoft.DirectX.Direct3D.Caps
A Caps structure that describes the capabilities of the current device.

This property is read-only.


Framework.DeviceSettings Property (DeviceSettings)

Framework.DeviceSettings Property

Retrieves the DeviceSettings object that contains the device settings for the current Device object used by the framework.

Definition

Visual Basic | Public ReadOnly Property DeviceSettings As DeviceSettings
C# | public DeviceSettings DeviceSettings { get; }
C++ public:
property DeviceSettings^ DeviceSettings {
DeviceSettings^ get();
}
JScript | public function get DeviceSettings() : DeviceSettings

Property Value

Microsoft.Samples.DirectX.UtilityToolkit.DeviceSettings
The DeviceSettings object that contains the device settings for the current Device object used by the framework.

This property is read-only.

Remarks

If there is no current Device object used by the framework, the DeviceSettings object will contain blank settings.


Framework.DeviceStats Property (DeviceStats)

Framework.DeviceStats Property

Retrieves a string containing the current device type, vertex processing behavior, and device name.

Definition

Visual Basic | Public ReadOnly Property DeviceStats As String
C# | public string DeviceStats { get; }
C++ public:
property String^ DeviceStats {
String^ get();
}
JScript | public function get DeviceStats() : String

Property Value

System.String
A string containing the current device type, vertex processing behavior, and device name.

This property is read-only.


Framework.ExitCode Property (ExitCode)

Framework.ExitCode Property

Retrieves the sample framework exit code.

Definition

Visual Basic | Public ReadOnly Property ExitCode As Integer
C# | public int ExitCode { get; }
C++ public:
property int ExitCode {
int get();
}
JScript | public function get ExitCode() : int

Property Value

System.Int32
The sample framework exit code.

This property is read-only.

Remarks

This table contains descriptions of possible ExitCode property values.
Value | Description
0 | Successful execution.
1 | An undetermined error occurred.
2 | No compatible Microsoft Direct3D device could be found.
3 | No Device object could be found with the specified device settings.
4 | The Microsoft DirectX software development kit (SDK) media file could not be found.
5 | The Device object has a nonzero reference count, meaning that some objects were not released.
6 | An error occurred when attempting to create the Device object.
7 | An error occurred when attempting to reset the Device object.
8 | An error occurred in the device creation callback function.
9 | An error occurred in the device creation callback function.
10 | The incorrect version of DirectX or D3DX is installed.
11 | The device used upon exit was a Reference device type.


Framework.FPS Property (FPS)

Framework.FPS Property

Retrieves the number of frames per second the application is currently running.

Definition

Visual Basic | Public ReadOnly Property FPS As Single
C# | public float FPS { get; }
C++ public:
property float FPS {
float get();
}
JScript | public function get FPS() : float

Property Value

System.Single
The number of frames per second the application is currently running.

This property is read-only.


Framework.FrameStats Property (FrameStats)

Framework.FrameStats Property

Retrieves a string containing the current number of frames per second, resolution, back buffer format, and depth stencil format.

Definition

Visual Basic | Public ReadOnly Property FrameStats As String
C# | public string FrameStats { get; }
C++ public:
property String^ FrameStats {
String^ get();
}
JScript | public function get FrameStats() : String

Property Value

System.String
A string containing the current number of frames per second, resolution, back buffer format, and depth stencil format.

This property is read-only.


Framework.IsD3DSettingsDialogShowing Property (IsD3DSettingsDialogShowing)

Framework.IsD3DSettingsDialogShowing Property

Retrieves whether the settings dialog is displayed.

Definition

Visual Basic | Public ReadOnly Property IsD3DSettingsDialogShowing As Boolean
C# | public bool IsD3DSettingsDialogShowing { get; }
C++ public:
property bool IsD3DSettingsDialogShowing {
bool get();
}
JScript | public function get IsD3DSettingsDialogShowing() : boolean

Property Value

System.Boolean
Set to true if the settings dialog is displayed; otherwise, false.

This property is read-only.


Framework.IsNotifiedOnMouseMove Property (IsNotifiedOnMouseMove)

Framework.IsNotifiedOnMouseMove Property

Retrieves whether the framework should notify for mouse moves.

Definition

Visual Basic | Public Property IsNotifiedOnMouseMove As Boolean
C# | public bool IsNotifiedOnMouseMove { get; set; }
C++ public:
property bool IsNotifiedOnMouseMove {
bool get();
void set(bool value);
}
JScript public function get IsNotifiedOnMouseMove() : boolean
public function set IsNotifiedOnMouseMove(boolean);

Property Value

System.Boolean
Set to true if the framework should notify for mouse moves; otherwise, false.

This property is read/write.


Framework.IsOverridingFullScreen Property (IsOverridingFullScreen)

Framework.IsOverridingFullScreen Property

Retrieves whether the framework should override and start fullscreen.

Definition

Visual Basic | Public Property IsOverridingFullScreen As Boolean
C# | public bool IsOverridingFullScreen { get; set; }
C++ public:
property bool IsOverridingFullScreen {
bool get();
void set(bool value);
}
JScript public function get IsOverridingFullScreen() : boolean
public function set IsOverridingFullScreen(boolean);

Property Value

System.Boolean
Set to true if the framework should override and start full-screen; otherwise, false.

This property is read/write.


Framework.IsWindowed Property (IsWindowed)

Framework.IsWindowed Property

Retrieves whether the current device is windowed.

Definition

Visual Basic | Public ReadOnly Property IsWindowed As Boolean
C# | public bool IsWindowed { get; }
C++ public:
property bool IsWindowed {
bool get();
}
JScript | public function get IsWindowed() : boolean

Property Value

System.Boolean
Set to true if the current device is windowed; otherwise, false.

This property is read-only.

Remarks

If no device exists yet, return false.


Framework.PresentParameters Property (PresentParameters)

Framework.PresentParameters Property

Retrieves the PresentParameters object for the current Device object.

Definition

Visual Basic | Public ReadOnly Property PresentParameters As PresentParameters
C# | public PresentParameters PresentParameters { get; }
C++ public:
property PresentParameters^ PresentParameters {
PresentParameters^ get();
}
JScript | public function get PresentParameters() : PresentParameters

Property Value

Microsoft.DirectX.Direct3D.PresentParameters
The PresentParameters object for the current Device.

This property is read-only.

Remarks

If no Device object exists yet, then PresentParameters returns a PresentParameters object with blank parameters.


Framework.Window Property (Window)

Framework.Window Property

Retrieves the handle of the window used for rendering.

Definition

Visual Basic | Public ReadOnly Property Window As IntPtr
C# | public IntPtr Window { get; }
C++ public:
property IntPtr Window {
IntPtr get();
}
JScript | public function get Window() : IntPtr

Property Value

System.IntPtr
The handle of the window used for rendering.

This property is read-only.


Framework.WindowClientRectangle Property (WindowClientRectangle)

Framework.WindowClientRectangle Property

Retrieves the size and location of the window that is rendering.

Definition

Visual Basic | Public ReadOnly Property WindowClientRectangle As Rectangle
C# | public Rectangle WindowClientRectangle { get; }
C++ public:
property Rectangle WindowClientRectangle {
Rectangle get();
}
JScript | public function get WindowClientRectangle() : Rectangle

Property Value

System.Drawing.Rectangle
Retrieves the size and location of the window that is rendering.

This property is read-only.


Framework.WindowDeviceFullscreen Property (WindowDeviceFullscreen)

Framework.WindowDeviceFullscreen Property

Retrieves the handle of the window used for fullscreen rendering.

Definition

Visual Basic | Public ReadOnly Property WindowDeviceFullscreen As IntPtr
C# | public IntPtr WindowDeviceFullscreen { get; }
C++ public:
property IntPtr WindowDeviceFullscreen {
IntPtr get();
}
JScript | public function get WindowDeviceFullscreen() : IntPtr

Property Value

System.IntPtr
The handle of the window used for fullscreen rendering.

This property is read-only.


Framework.WindowDeviceWindowed Property (WindowDeviceWindowed)

Framework.WindowDeviceWindowed Property

Retrieves the handle of the window used for windowed rendering.

Definition

Visual Basic | Public ReadOnly Property WindowDeviceWindowed As IntPtr
C# | public IntPtr WindowDeviceWindowed { get; }
C++ public:
property IntPtr WindowDeviceWindowed {
IntPtr get();
}
JScript | public function get WindowDeviceWindowed() : IntPtr

Property Value

System.IntPtr
The handle of the window used for windowed rendering.

This property is read-only.


Framework.WindowFocus Property (WindowFocus)

Framework.WindowFocus Property

Retrieves the handle of the window that currently has focus.

Definition

Visual Basic | Public ReadOnly Property WindowFocus As IntPtr
C# | public IntPtr WindowFocus { get; }
C++ public:
property IntPtr WindowFocus {
IntPtr get();
}
JScript | public function get WindowFocus() : IntPtr

Property Value

System.IntPtr
The handle of the window that currently has focus.

This property is read-only.


Framework.DefaultSizeHeight Field (DefaultSizeHeight)

Framework.DefaultSizeHeight Field

Retrieves the default window height, in pixels, when the application starts.

Definition

Visual Basic | Public DefaultSizeHeight As Int32
C# | public Int32 DefaultSizeHeight;
C++ | public: Int32 DefaultSizeHeight;
JScript | public var DefaultSizeHeight : Int32

Field Value

System.Int32
The default window height, in pixels, when the application starts.

This field is read-only.


Framework.DefaultSizeWidth Field (DefaultSizeWidth)

Framework.DefaultSizeWidth Field

Retrieves the default window width, in pixels, when the application starts.

Definition

Visual Basic | Public DefaultSizeWidth As Int32
C# | public Int32 DefaultSizeWidth;
C++ | public: Int32 DefaultSizeWidth;
JScript | public var DefaultSizeWidth : Int32

Field Value

System.Int32
The default window width, in pixels, when the application starts.

This field is read-only.


Framework.TrueIntPtr Field (TrueIntPtr)

Framework.TrueIntPtr Field

Retrieves the Boolean value of true as a System.IntPtr Leave Site.

Definition

Visual Basic | Public TrueIntPtr As IntPtr
C# | public IntPtr TrueIntPtr;
C++ | public: IntPtr TrueIntPtr;
JScript | public var TrueIntPtr : IntPtr

Field Value

System.IntPtr
The Boolean value of true as a System.IntPtr Leave Site.

This field is read-only.

Remarks

This value is used as a return value for certain message handling events, which return the type System.IntPtr Leave Site.


Framework.DeviceCreated Event (DeviceCreated)

Framework.DeviceCreated Event

Occurs when the Microsoft Direct3D Device object is created.

Definition

Visual Basic | Event DeviceCreated As Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler
C# | event Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler DeviceCreated;
C++ :
event Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler^ DeviceCreated;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

When this event is triggered, it will return a Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventArgs object that contains the Direct3D Device object created and a description of the back buffer as a SurfaceDescription object.


Framework.DeviceLost Event (DeviceLost)

Framework.DeviceLost Event

Occurs when the Microsoft Direct3D Device object is lost.

Definition

Visual Basic | Event DeviceLost As EventHandler
C# | event EventHandler DeviceLost;
C++ :
event EventHandler^ DeviceLost;
JScript | In JScript, you can use events, but you cannot define your own.


Framework.DeviceReset Event (DeviceReset)

Framework.DeviceReset Event

Occurs when the Microsoft Direct3D Device object is reset.

Definition

Visual Basic | Event DeviceReset As Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler
C# | event Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler DeviceReset;
C++ :
event Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventHandler^ DeviceReset;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

When this event is triggered, it will return a Microsoft.Samples.DirectX.UtilityToolkit.DeviceEventArgs object that contains the Direct3D Device object that was reset and a description of the back buffer as a SurfaceDescription object.


Framework.Disposing Event (Disposing)

Framework.Disposing Event

Occurs when the Framework object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Event Disposing As EventHandler
C# | event EventHandler Disposing;
C++ :
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.


DirectDraw
Warning: Microsoft DirectDraw has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

The DirectDraw application programming interface (API) is the component of DirectX that enables you to directly manipulate display memory, the hardware blitter, hardware overlay support, and flipping surface support. For more information, see the Microsoft.DirectX.DirectDraw managed code reference documentation.


DirectInput

This section provides information about the Microsoft DirectInput component of the Microsoft DirectX application programming interface (API). The DirectInput API is used to process data from a keyboard, mouse, joystick, or other game controller. For more information, see the Microsoft.DirectX.DirectInput managed code reference documentation.


Enumerating Microsoft DirectInput Devices

In order to capture device input using Microsoft DirectInput, you have to know from which device you want to capture, and if it is currently attached to the user's computer. You can do this by enumerating DeviceInstance objects using several different static methods of the Manager class.

  • Enumerating All Available DirectInput Devices
  • Enumerating a Particular Type of Device
  • Enumerating a Certain Class of Device
  • Enumerating All Force Feedback Devices

Enumerating All Available DirectInput Devices

You should enumerate when you are looking for a particular kind of device, want to offer the user a choice of devices, or need to work with two or more devices.

Enumeration serves three purposes:

  • Reports what DirectInput devices are available.
  • Supplies a globally unique identifier (GUID) for each DirectInput device.
  • Enables you to create a DeviceInstance object for each DirectInput device as it is enumerated so that you can check the type of device it is and its capabilities.
You can enumerate all the available DirectInput devices on the user's computer by using the Devices property of the Manager class. The following C# sample code is used to populate a TreeView control with all available DirectInput devices.
[C#]
private void PopulateAllDevices(TreeView tvDevices)
{
    //Add "All Devices" node to TreeView
    TreeNode allNode = new TreeNode("All Devices");
    tvDevices.Nodes.Add(allNode);

    //Populate All devices
    foreach(DeviceInstance di in Manager.Devices)
    {

        //Get Device name
        TreeNode nameNode = new TreeNode(di.InstanceName);

        //Is device attached?
        TreeNode attachedNode = new TreeNode(
            "Attached = " +
            Manager.GetDeviceAttached(di.ProductGuid));

        //Get device Guid
        TreeNode guidNode = new TreeNode(
            "Guid = " + di.InstanceGuid);

        //Add nodes
        nameNode.Nodes.Add(attachedNode);
        nameNode.Nodes.Add(guidNode);
        allNode.Nodes.Add(nameNode);
    }

}

Enumerating a Particular Type of Device

To enumerate a particular type of device, such as keyboards, you can use the GetDevices method of the Manager class. GetDevices is a static method allows you to retrieve a collection of DeviceInstance objects of a certain type, like keyboards. It has a parameter that gives you the ability to pass it a flag or a combination of flags in order to filter the collection. In this way, you can retrieve a list containing only attached keyboards.

The following C# sample code is used to populate a TreeView control with all attached keyboards.
[C#]
private void PopulateKeyboards(TreeView tvDevices)
{
    //Add "Keyboard Devices" node to TreeView
    TreeNode keyboardNode = new TreeNode("Keyboard Devices");
    tvInputDevices.Nodes.Add(keyboardNode);

    //Populate Attached Keyboards
    foreach(DeviceInstance di in
        Manager.GetDevices(DeviceType.Keyboard,EnumDevicesFlags.AttachedOnly))
    {

        //Get device name
        TreeNode nameNode = new TreeNode(di.InstanceName);
        TreeNode guidNode = new TreeNode(
            "Guid = " + di.InstanceGuid);

        //Add nodes
        nameNode.Nodes.Add(guidNode);
        keyboardNode.Nodes.Add(nameNode);
    }

}

Enumerating a Certain Class of Device

When enumerating pointing devices on the user's computer, you likely will not want to limit yourself to just a mouse pointer. Some laptops use track-pads or other types of pointing devices.

The C# sample below illustrates how to use the DeviceClass enumeration with the GetDevices method to populate a TreeView control with all attached devices that fall into the screen pointer class, such as mice or track-pads.
[C#]
private void PopulatePointers(TreeView tvDevices)
{
    //Add "Pointer Devices" node to TreeView
    TreeNode pointerNode = new TreeNode("Pointer Devices");
    tvInputDevices.Nodes.Add(pointerNode);

    //Populate Attached Mouse/Pointing Devices
    foreach(DeviceInstance di in
        Manager.GetDevices(DeviceClass.Pointer,EnumDevicesFlags.AttachedOnly))
    {

        //Get device name
        TreeNode nameNode = new TreeNode(di.InstanceName);
        nameNode.Tag = di;
        TreeNode guidNode = new TreeNode(
            "Guid = " + di.InstanceGuid);

        //Add nodes
        nameNode.Nodes.Add(guidNode);
        pointerNode.Nodes.Add(nameNode);
    }

}
Note: This code can also be used to enumerate all types of joysticks by using the DeviceClass.GameControl value in the GetDevices method.

Enumerating All Force Feedback Devices

Sometimes you may want to just enumerate devices that have force feedback capabilities. Because many different types of devices use force feedback, you may need to look for any type of device that supports it.

The following C# sample code illustrates how to enumerate all devices that support force feedback, and populate a TreeView control with those devices.
[C#]
private void PopulateForceFeedback(TreeView tvDevices)
{
    //Add "ForceFeedback Devices" node to TreeView
    TreeNode forcefeedbackNode = new TreeNode("ForceFeedback Devices");
    tvInputDevices.Nodes.Add(forcefeedbackNode);

    //Populate ForceFeedback Devices
    foreach(DeviceInstance di in
        Manager.GetDevices( DeviceClass.All,EnumDevicesFlags.ForceFeedback))
    {
        //Get device name
        TreeNode nameNode = new TreeNode(di.InstanceName);
        nameNode.Tag = di;
        TreeNode guidNode = new TreeNode("Guid = " + di.InstanceGuid);

        //Add nodes
        nameNode.Nodes.Add(guidNode);
        forcefeedbackNode.Nodes.Add(nameNode);
    }
}


Capturing from Microsoft DirectInput Devices

Capturing device input using Microsoft DirectInput can be done in three simple steps. First you create a Device object that represents the input device you wish to capture. After you create the device object, you do any necessary configuration, such as calling the SetCooperativeLevel method. Once you have configured the device you can start checking the state of the device in your application.

  • Creating DirectInput Device Objects
  • Configuring DirectInput Device Objects
  • Capturing from DirectInput Device Objects

Creating DirectInput Device Objects

As discussed in Enumerating DirectInput Devices, there are many ways to find out what input devices are currently attached to the user's computer. More often than not, you will have to capture input from more than one device.

The following C# example code illustrates how to create three different Device objects: one for the default keyboard on the user's computer, one for the default mouse, and one for a joystick.
[C#]
private void InitDevices()
{
    //create keyboard device.
    keyboard = new Device(SystemGuid.Keyboard);
    if(keyboard == null) throw new Exception("No keyboard found.");

    //create mouse device.
    mouse = new Device(SystemGuid.Mouse);
    if(mouse == null)
    {
        throw new Exception("No mouse found.");
    }

    //create joystick device.
    foreach(
        DeviceInstance di in
        Manager.GetDevices(
            DeviceClass.GameControl,
            EnumDevicesFlags.AttachedOnly))
    {
        joystick = new Device(di.InstanceGuid);
        break;
    }

    if(joystick == null)
    {
        //Throw exception if joystick not found.
        throw new Exception("No joystick found.");
    }
}

Configuring DirectInput Device Objects

Because the input devices you capture from are a shared system resource, you have to configure them to cooperate with other system resources. You do this by calling the SetCooperativeLevel method of the Device objects you created with a combination of flags from the CooperativeLevelFlags enumeration.

The following table describes CooperativeLevelFlags that can be used when setting the cooperative level.
Flag | Description
CooperativeLevelFlags.Background | This device can be used in the background and can be acquired at any time, even if the application window is not active.
CooperativeLevelFlags.Foreground | This device can only be used when the application window is in the foreground. When the application window loses focus, the device will no linger be acquired.
CooperativeLevelFlags.Exclusive | This device requires exclusive access. No other application can acquire this device. For security reasons, this flag cannot be used in conjunction with the background flag on certain devices such as a keyboard and mouse.
CooperativeLevelFlags.NonExclusive | This device can be shared with any other application that does not require exclusive access.
CooperativeLevelFlags.NoWindowsKey | This flag disables the window's key.

Another configuration task is setting the range of a joystick axis. This allows you to set a numeric range to the complete distance traveled on a joystick axis. Even if the joystick you are using does not support the resolution of the range you assign, DirectInput will translate the joystick's resolution into the range you assign.

The following C# example code demonstrates how to configure the devices created in the previous sample.
[C#]
//Set mouse axis mode absolute.
mouse.Properties.AxisModeAbsolute = true;

//Set joystick axis ranges.
foreach(DeviceObjectInstance doi in joystick.Objects)
{
    if((doi.ObjectId & (int)DeviceObjectTypeFlags.Axis) != 0)
    {
        joystick.Properties.SetRange(
            ParameterHow.ById,
            doi.ObjectId,
            new InputRange(-5000,5000));
    }
}

//Set joystick axis mode absolute.
joystick.Properties.AxisModeAbsolute = true;

//set cooperative level.
keyboard.SetCooperativeLevel(
    this,
    CooperativeLevelFlags.NonExclusive |
    CooperativeLevelFlags.Background);

mouse.SetCooperativeLevel(
    this,
    CooperativeLevelFlags.NonExclusive |
    CooperativeLevelFlags.Background);

joystick.SetCooperativeLevel(
    this,
    CooperativeLevelFlags.NonExclusive |
    CooperativeLevelFlags.Background);

//Acquire devices for capturing.
keyboard.Acquire();
mouse.Acquire();
joystick.Acquire();

Capturing from DirectInput Device Objects

Normally you would want to capture the device object's state at a certain point of your application.

The C# example code below contains methods for capturing device input from the devices created in the previous examples, and updating a label control. They can be called by an application whenever you need to capture DirectInput device input.
[C#]
private void UpdateKeyboard()
{
    string info = "Keyboard: ";

    //Capture pressed keys.
    foreach(Key k in keyboard.GetPressedKeys())
    {
        info += k.ToString() + " ";
    }
    lbKeyboard.Text = info;
}

private void UpdateMouse()
{
    string info = "Mouse: ";

    //Get Mouse State.
    MouseState state = mouse.CurrentMouseState;

    //Capture Position.
    info += "X:" + state.X + " ";
    info += "Y:" + state.Y + " ";
    info += "Z:" + state.Z + " ";

    //Capture Buttons.
    byte[] buttons = state.GetMouseButtons();
    for(int i = 0; i < buttons.Length; i++)
    {
        if(buttons[i] != 0)
        {
            info += "Button:" + i + " ";
        }
    }

    lbMouse.Text = info;
}

private void UpdateJoystick()
{
    string info = "Joystick: ";

    //Get Mouse State.
    JoystickState state = joystick.CurrentJoystickState;

    //Capture Position.
    info += "X:" + state.X + " ";
    info += "Y:" + state.Y + " ";
    info += "Z:" + state.Z + " ";

    //Capture Buttons.
    byte[] buttons = state.GetButtons();
    for(int i = 0; i < buttons.Length; i++)
    {
        if(buttons[i] != 0)
        {
            info += "Button:" + i + " ";
        }
    }

    lbJoystick.Text = info;
}


Using Force Feedback

Force Feedback allows you to send messages and properties to a user's Microsoft DirectInput device to relay feedback in the form of physical force. This is only applicable to DirectInput devices that support force feedback.

  • Types of Force Feedback
  • Creating and Configuring a Device for Force Feedback
  • Loading a Force Feedback Effect File
  • Assigning a Predefined Effect to a Device

Types of Force Feedback

There are two methods to relay physical force to an input device. One method is to download a force feedback effect file into the device. A force feedback effect file contains a collection of effects that can be played at any time once they are downloaded into the device.

The other method is to assign a particular effect that is supported by the device. These effects have parameters that can be configured and assigned to axes on the device. The following is a list of effects that are included in Microsoft DirectX 9.0 for Managed Code.

  • ForceFeedbackGuid.ConstantForce
  • ForceFeedbackGuid.CustomForce
  • ForceFeedbackGuid.Damper
  • ForceFeedbackGuid.Friction
  • ForceFeedbackGuid.Inertia
  • ForceFeedbackGuid.RampForce
  • ForceFeedbackGuid.SawtoothDown
  • ForceFeedbackGuid.SawtoothUp
  • ForceFeedbackGuid.Sine
  • ForceFeedbackGuid.Spring
  • ForceFeedbackGuid.Square
  • ForceFeedbackGuid.Triangle

Creating and Configuring a Device for Force Feedback

In order to use force feedback, you must first create a Device object for the force feedback compatible device. The following C# sample code creates a Device object from the first available force feedback-capable game control.
[C#]
//create force feedback capable joystick device.
foreach(DeviceInstance di in Manager.GetDevices(
    DeviceClass.GameControl,
    EnumDevicesFlags.AttachedOnly | EnumDevicesFlags.ForceFeedback))
{
    joystick = new Device(di.InstanceGuid);
    break;
}
if (joystick == null)
{
    //Throw exception if joystick not found.
    throw new Exception("No joystick that supports forced feedback found.");
}

Once the Device object is created, it needs to be configured properly to work with force feedback. In order for force feedback to work properly, you must set the cooperative level to exclusive. You also need to create an array of axes to use with the force feedback.

The following C# sample code illustrates how to configure the Device object created in the previous code.
[C#]
//set cooperative level.
joystick.SetCooperativeLevel(
    this,
    CooperativeLevelFlags.Exclusive | CooperativeLevelFlags.Background);

//Set axis mode absolute.
joystick.Properties.AxisModeAbsolute = true;

//Acquire joystick for capturing.
joystick.Acquire();

//Configure axes
int[] axis = null;
foreach(DeviceObjectInstance doi in joystick.Objects)
{

    //Set axes ranges.
    if((doi.ObjectId & (int)DeviceObjectTypeFlags.Axis) != 0)
    {
        joystick.Properties.SetRange(
        ParameterHow.ById,
        doi.ObjectId,
        new InputRange(-5000,5000));
    }

    int[] temp;

    // Get info about first two FF axii on the device
    if ((doi.Flags & (int)ObjectInstanceFlags.Actuator) != 0)
    {
        if (axis != null)
        {
            temp = new int[axis.Length + 1];
            axis.CopyTo(temp,0);
            axis = temp;
        }
        else
        {
            axis = new int[1];
        }

        // Store the offset of each axis.
        axis[axis.Length - 1] = doi.Offset;
        if (axis.Length == 2)
        {
            break;
        }
    }
}

Loading a Force Feedback Effect File

The following C# sample code shows you how to download a force feedback effect file into the Device object created and configured in previous samples.
[C#]
//Load force feedback effect file
string path =
    @"C:\Program Files\Microsoft DirectX 9.0 SDK (December 2004)\Samples\Managed\DirectInput\ReadFFE\guna.ffe";

EffectList el = null;
el = joystick.GetEffects(path,FileEffectsFlags.ModifyIfNeeded);
foreach(FileEffect fe in el)
{
    EffectObject feo = new EffectObject(
        fe.EffectGuid,
        fe.EffectStruct,
        joystick);
    try
    {
        feo.Download();
    }
    catch(Exception ex)
    {
        throw new Exception("Could not download force feedback effect file.", ex);
    }
    fxList.Add(feo);

}
 Once the above force feedback effect file is downloaded into the Device object, it can be played by using the following C# sample code.
[C#]
//Play gun force feedback file effect
foreach(EffectObject eo in fxList)
{
    eo.Start(1,EffectStartFlags.NoDownload);
}
button0pressed = true;

Assigning a Predefined Effect to a Device

If you want to relay a physical force such as a constant force to the axes of a Device object, you can do this by assigning a predefined effect to its axes. The following C# sample code first checks to see if the Device object supports the effect. It then creates the effects, sets some parameters for the effects, then applies them to the axes of the Device object.
[C#]
//See if joystick supports ConstantForce and set it.
EffectObject eo = null;
Effect e;

foreach (EffectInformation ei in joystick.GetEffects(EffectType.All))
{
    //If the joystick supports ConstantForce, then apply it.

    if (DInputHelper.GetTypeCode(ei.EffectType)
        == (int)EffectType.ConstantForce)
    {
        // Fill in some generic values for the effect.
        e = new Effect();
        e.SetDirection(new int[axis.Length]);
        e.SetAxes(new int[axis.Length]);
        e.ConditionStruct =  new Condition[axis.Length];

        e.EffectType = EffectType.ConstantForce;
        e.Duration = (int)DI.Infinite;
        e.Gain = 10000;
        e.SamplePeriod = 0;
        e.TriggerButton = (int)Microsoft.DirectX.DirectInput.Button.NoTrigger;
        e.TriggerRepeatInterval = (int)DI.Infinite;
        e.Flags = EffectFlags.ObjectOffsets | EffectFlags.Cartesian;
        e.SetAxes(axis);

        // Create the effect, using the passed in guid.
        eo = new EffectObject(ei.EffectGuid, e, joystick);

    }
}

if (eo == null)
{
    throw new Exception("ConstantForce is not supported.");
}


DirectPlay
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

The DirectPlay application programming interface (API) provides developers with the tools to develop multiplayer applications such as games or chat clients. For simplicity, this documentation will refer to all such applications as "games." A multiplayer application has two basic characteristics:

  • Two or more individual users, each with a game client on their computer.
  • Network links that enable the users' computers to communicate with each other, perhaps through a centralized server.

DirectPlay provides a layer that largely isolates your application from the underlying network. For most purposes, your application can just use the DirectPlay API, and enable DirectPlay to handle the details of network communication. DirectPlay provides many features that simplify the process of implementing many aspects of a multiplayer application, including:

  • Creating and managing both peer-to-peer and client/server sessions
  • Managing users and groups within a session
  • Managing messaging between the members of a session over different network links and varying network conditions
  • Enabling applications to interact with lobbies
  • Enabling users to communicate with each other by voice

This documentation provides a high-level overview of the capabilities of DirectPlay. Subsequent sections will take you into the details of how to use DirectPlay in your multiplayer game.

For more information, see the Microsoft.DirectX.DirectPlay managed code reference documentation.


Client/Server Topology
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

A client/server game consists of the individual players' computers (the "game clients") connected to a central server computer. The topology of a four-player client/server game is depicted in the following illustration.

Game play is handled by having each user's game client communicate with the server. The server is responsible for passing information on to the other users. For instance, when one user moves, the user's computer sends a message to the server. The server then sends messages to the other players to inform them of a change in game state. The server can have a number of responsibilities; it can:

  • Act as the session's messaging hub. Each computer needs to send messages only to the server. The server handles the logistics of synchronizing all the other users. This arrangement can substantially reduce message traffic, especially for large games.
  • Host the game. The server typically takes care of the tasks that must be handled by the session host in a peer-to-peer game.
  • Support many aspects of the game. The server often does much more than support game logistics. With many games, especially large ones, much of the processing that maintains the "game universe" takes place on the server. The game clients are primarily responsible for handling the user interface (UI).

A client/server game is typically arranged and launched through a lobby client application that resides on the user's computer. The lobby client acts as a link to a lobby server application, which usually runs on the same remote computer that is hosting the game. When the game has been launched, the game server application becomes the host and handles tasks such as admitting new users to the game.

There are a number of advantages to client/server games.

  • They are more efficient, especially for large-scale games. In particular, they scale much better than peer-to-peer games because additional players cause only a linear increase in the messaging traffic. The client/server topology is necessary for massively multiplayer games.
  • You are not limited by the processing power of your users' computers. You can locate much of the processing required to maintain a large complex "game universe" on a single powerful computer, and let the users' computers handle the UI.
  • You can control key aspects of your game at a central site. For instance, you can often update the game or fix bugs by modifying the server application, thereby avoiding the need to update large numbers of game clients.

Once you have developed and shipped a peer-to-peer game, you are essentially finished. The game clients are largely self-sufficient. However, with a client/server game, you have an ongoing responsibility to your users that goes beyond providing support services. You must also provide and maintain a game server computer and the associated software, along with the network links to handle all the messaging, for the lifetime of the application. In the case of massively multiplayer games, you may need to operate your servers for extended periods with few or no breaks in service, or risk angering users by disrupting their game play.


Communicating with DirectPlay Objects
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

DirectPlay essentially consists of a collection of Component Object Model (COM) objects. Each object exposes one or more interfaces that enable you to control various aspects of DirectPlay. For instance, the DirectPlay Peer object is used to manage peer-to-peer games.

You communicate with a DirectPlay object by calling the methods exposed by its interfaces. For instance, to send some data to another user in a peer-to-peer game, you would send a message by calling the SendTo method. DirectPlay then takes care of getting the message to its target.

DirectPlay communicates with your application through one or more callback functions. Your application implements the callback function and passes a pointer to the function to DirectPlay during initialization. When DirectPlay needs to communicate with your application, it calls the callback function and passes in two key items of information:

  • A message identifier (ID) that identifies the message type
  • A pointer to a block of data, typically a structure, that provides any needed details.

Because much of DirectPlay messaging is multithreaded, it is critical that callback functions be properly implemented.


Creating and Managing Sessions
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

A game session is an instance of a particular multiplayer game. A session has two or more users playing simultaneously, each with the same game client on his or her computer. A player is an entity in the game itself, and is defined by the particular game. Each user may have more than one player in a game. However, the game application must manage these players itself, using separate DirectPlay interfaces or objects for each player.

The first step in creating a session is to collect a group of users. There are two basic approaches:

  • Many game sessions are arranged by a lobby application running on a remote computer. This approach is used by most Internet-based games.
  • It is also possible to arrange games by having the individual users' computers communicate with each other. This approach is typically limited such situations as a group of potential users that are all on the same local area network (LAN).

Once the session has been arranged, the game is launched and gameplay begins. As the session proceeds, players may be eliminated from the session or new players added. The details are up to the individual game.

With a multiplayer game, each user's user interface (UI) can be synchronized with that of all other users in the session. Managing a multiplayer session thus requires a continual stream of messages to and from each user. For example, every time a player moves, a message must be sent to update that player's position on all the other game clients in the session. The core of DirectPlay is that part of the application programming interface (API) that supports efficient and flexible messaging between all the computers in a session.

There are two basic ways to structure the messaging topology of a session: peer-to-peer and client/server. Both topologies have their advantages and limitations, so you will need to evaluate which is most appropriate for your game.

This section includes the following topics.

  • Peer-to-Peer Topology
  • Client/Server Topology


DirectPlay Lobby Support
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

A lobby is an application whose primary purpose is to enable players to meet and arrange games. It is typically located on a remote computer, and accessed over the Internet. Lobby servers often also perform a variety of other functions, such as hosting chat rooms, posting news and information, and selling merchandise. While lobby servers are convenient and commonly used to arrange multiplayer games, they aren't required. Multiplayer games can also be arranged by direct communication between lobby clients.

There are normally three components that are needed to enable a game to interact with a lobby:

  • A lobby server
  • A lobby client
  • A lobbyable game.

DirectPlay does not specify how you should implement a lobby server application. Instead, DirectPlay provides support for a lobby client. A lobby client is an application that is implemented by a lobby server vendor, and installed on each user's system. It serves as a link between the user and the lobby. While you could handle such communication directly, you would have to know the specific implementation details of every lobby that might launch your game.

The lobby client application handles the details of communicating with its associated lobby server, using whatever protocols are appropriate. The lobby client communicates with the user and their game applications through a DirectPlay interface. DirectPlay then passes messages to the application. The application can also use a DirectPlay interface to pass messages to the lobby client.

A lobby can launch virtually any application. However, the application must have some specific lobby-aware components to take full advantage of lobby-launching. In particular, a lobbyable application can communicate with the lobby client throughout the course of the session. If an application is registered as lobbyable, the lobby client also automatically receives updates for various changes in game status, such as host migration.


DirectPlay Network Communication
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

The primary function of DirectPlay is to provide you with efficient and flexible messaging support that largely isolates your application from the underlying network hardware and software. If you need to send a status update, you can call the relevant DirectPlay application programming interface (API), regardless of what kind of network link is involved. DirectPlay network service providers support communication over Transmission Control Protocol/Internet Protocol (TCP/IP), Internetwork Packet Exchange (IPX), modem, and serial links.

Note: DirectPlay does not support secure communications.

To use modems on Microsoft Windows 95 systems, you must install version 2.0 of the Telephony API (TAPI). You can download TAPI 2.0 from http://www.microsoft.com.

  • DirectPlay Transport Protocol
  • DirectPlay Addresses

DirectPlay Transport Protocol

The core of the DirectPlay networking capabilities is the DirectPlay protocol. This transport-layer protocol has been completely overhauled for DirectPlay 8, and is now used for all messaging. The DirectPlay protocol is focused on making it simple for you to send data from the sending application to the target application, without needing to worry about what happens in between. The protocol offers a number of features that are tailored to the needs of multiplayer games, including:

  • Reliable and unreliable delivery of messages. Reliable messages will be resent until the target application receives them. You can assign the delivery type on a message-by-message basis.
  • Sequential and non-sequential delivery of messages. Sequential messages will be passed to the target application in the order they were sent.
  • Message fragmentation and reassembly. If message size exceeds the capacity of a particular network, DirectPlay automatically fragments and reassembles the message.
  • Congestion control. DirectPlay automatically throttles your outgoing messages to a level that can be handled by the target. This feature prevents you from flooding the target with more messages than it can process.
  • Send prioritization. To ensure that the most important messages get sent first, DirectPlay enables you to designate messages as low, medium, or high priority. The high priority messages are sent to the front of the output queue, followed by medium and low priority messages.
  • Message timeouts. To prevent the outgoing message queue from being clogged with messages that have been superseded by more recent messages, DirectPlay enables you to assign a timeout value to all messages. When a message times out, it is removed from the outgoing message queue, regardless of whether it has been sent or not.

DirectPlay Addresses

In order to deliver messages, each participant in a multiplayer game must have a unique address. Addresses can refer either to the computer that your application is running on (device address), or a computer that your application needs to communicate with (host address).

DirectPlay addresses are in the form of URL strings. These strings consist of a scheme, scheme separator, and data string in the following general format:

x-directplay:/[data string]

The data string contains several elements that specify everything that is needed to enable communication to take place between sender and target, over a variety of different types of network link.

In use, the URL strings are embedded in a DirectPlay address object which is passed to or from DirectPlay API methods. You have the option of either manipulating the URL string directly, or using the methods exposed by the address object to handle each element of the data string separately.


DirectPlay Voice Communication
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

The current trend toward team-based multiplayer games makes player-to-player communication an essential part of gameplay. Historically, this has been confined to text-based communication, where players type out the messages to their teammates. Although suitable for slower, turn-based games, text-based communication is at best an inconvenience for real-time games. Not only does it put slow typists at a disadvantage during gameplay, but it is also a significant break in the reality that games attempt to create for the player. An obvious solution to the problem is the use of speech as a means for communication. It requires no training and increases the immersion of the game itself.

The windows platform provides all the tools required to provide real-time voice conferencing to video game developers, but it requires a significant amount of effort on the part of the game developer. This, combined with the cost and difficulty of obtaining the rights to compression technology capable of handling extremely low-bandwidth situations, has prevented the wide-spread use of voice in games.

DirectPlay 9.0 provides the game developer with a robust real-time voice conferencing system that requires a minimal amount of effort to use.


Peer-to-Peer Topology
Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.

A peer-to-peer game consists of the individual players' computers, connected by network links. Schematically, the topology of a four-player peer-to-peer game looks like:

Gameplay is handled by having each user's game client communicate directly with the other users' clients. For instance, when one user moves, the game client must send three update messages, one to each of the other users' computers.

A peer-to-peer game is normally arranged and launched through a lobby client application that resides on the user's computer. There are two basic ways the lobby client can arrange a session:

  • The lobby client communicates directly with other potential users' lobby clients. This approach can be used, for instance, to arrange a game among users on the same local area network (LAN) subnet.
  • The lobby client acts as a link to lobby server application running on a remote computer. This is the way Internet-based games are normally arranged.

Once a session has been arranged and launched, most or all of the messaging will be user to user. If a lobby server is involved, it will only be handling such tasks as updating its list of session members when a player leaves the game, or enabling a new user to request entry to the session. Otherwise, the server stays in the background, and is typically not even aware of most of the messages that are being sent.

Because the server is either non-existent or at least not directly involved with the game play, one user is designated as the game host. They are responsible for handling logistical details such as bringing new players into an ongoing session.

Peer-to-peer games have the advantage of simplicity. All that is needed is a collection of players with game clients, and a way to organize a session. The primary drawback of the peer-to-peer topology is scalability. As the number of users increase, the number of messages needed to facilitate game play increases geometrically. The maximum number of users that can be accommodated depends on the game and the network bandwidth, but is typically no more than thirty.


DirectSound

Microsoft DirectSound provides a system to capture sounds from input devices and play sounds through various playback devices using advanced 3-dimensional positioning effects, and filters for echo, distortion, reverberation, and other effects.

Information is presented in the following topics.

Playing Sounds | This section is a guide to playing WAV sounds through DirectSound buffers.
3-D Sound | Using DirectSound, you can locate sounds in space and apply Doppler shift to moving sounds. 3-D effects are applied to individual DirectSound buffers. Global parameters are set on an object called the listener.
Using Effects | DirectSound provides support for effects processing of sounds by Microsoft DirectX Media Objects (DMOs).
Capturing Waveforms | DirectSound enables you to capture sounds from a microphone or other input to the sound card, for immediate playback or storage in a file. Data can be captured in Pulse Code Modulation (PCM) or compressed formats.
Optimizing Performance | This section offers some miscellaneous tips for improving the performance of applications that play their audio data directly into DirectSound buffers.

For more information, see the Microsoft.DirectX.DirectSound managed code reference documentation.


Playing Sounds

This section is a guide to playing WAV sounds through Microsoft DirectSound buffers.

Information in this section is contained in the following topics.

  • Playback Overview
  • Devices
  • Buffers
  • Using WAV Data

Related Topics

  • Using Effects


Playback Overview

The Microsoft DirectSound Device object represents a sound playback device and is used to manage that device and create sound buffers.

Multiple applications can create Device objects for the same sound device. When the input focus changes between applications, the audio output automatically switches from one application's streams to the other's. As a result, applications do not have to repeatedly play and stop their buffers when the input focus changes.

The primary buffer holds the audio that the listener will hear. Secondary sound buffers each contain a single sound or stream of audio. DirectSound automatically creates a primary buffer, but it is the application's responsibility to create secondary buffers. When sounds in secondary buffers are played, DirectSound mixes them in the primary buffer and sends them to the output device. Only the available processing time limits the number of buffers that DirectSound can mix.

Buffers are represented by either the Buffer class or the SecondaryBuffer class. Most applications use only the SecondaryBuffer class, which inherits from Buffer. However, an object representing the primary buffer must be a Buffer object.

A short sound can be loaded into a buffer in its entirety and played at any time by a simple method call. Longer sounds have to be streamed. An application can ascertain when it is time to stream more data into the buffer either by polling the position of the play cursor or by requesting notification when the play cursor reaches certain points.

Managed Microsoft DirectX provides a method for loading nonstreaming (static) buffers from a WAV file directly into a secondary buffer but, for streaming buffers, you are responsible for parsing the file and copying the data into the buffer.


Devices

The first step in implementing Microsoft DirectSound in an application is to create a Device object, which represents a sound device.

This section describes how your application can enumerate available sound devices, create the Device object, and use the methods of the object to set the cooperative level, retrieve the capabilities of the device, create sound buffers, set the configuration of the system's speakers, and compact hardware memory.

  • Enumeration of Sound Devices
  • Creating the Device Object
  • Cooperative Levels
  • Device Capabilities
  • Speaker Configuration
  • Compacting Hardware Memory

Enumeration of Sound Devices

For an application that is simply going to play sounds through the user's preferred playback device, you do not need to enumerate the available devices. For more information, see Creating the Device Object.

If you are looking for a particular kind of device, want to offer the user a choice of devices, or need to work with two or more devices, you must enumerate the devices available on the system.

Enumeration serves three purposes.

  • Reports what hardware is available.
  • Supplies a globally unique identifier (GUID) for each device.
  • Enables you to create a temporary Device object for each device as it is enumerated, so that you can check the capabilities of the device.

To enumerate devices, instantiate a DevicesCollection object, and use its methods and properties to query for the available devices. The description, driver GUID, and module name of each device can be obtained from the properties of the DeviceInformation structure.

The following C# sample code retrieves the available devices. The same procedure can be used to identify available capture devices by substituting CaptureDevicesCollection for DevicesCollection.
[C#]
using Microsoft.DirectX.DirectSound;
public class wfEnum : System.Windows.Forms.Form
private DevicesCollection myDevices = null;
private struct myDeviceDescription
{
    public DeviceInformation info;
    public override string ToString()
    {
        return info.Description;
    }
        public myDeviceDescription(DeviceInformation di)
        {
            info = di;
        }
}
public wfEnum()
{
    // Retrieve the available DirectSound devices
    myDevices = new DevicesCollection();

    foreach (DeviceInformation dev in myDevices)
    {
        myDeviceDescription dd = new myDeviceDescription(dev);

        // Use DevicesCollection and DeviceInformation to query for devices.
    }
Note: The first device enumerated is always called the Primary Sound Driver. This device represents the preferred playback device set by the user in Control Panel. It is enumerated separately to make it easy for the application to add "Primary Sound Driver" to a list when presenting the user with a choice of devices. The primary device is also enumerated with its proper name and GUID.

Creating the Device Object

The following C# example show how to create a Device object for the default device.
[C#]
private Device dsDevice = null;
dsDevice = new Device();
The following C# example creates a device from a GUID, represented by the deviceGuid variable. This GUID can be obtained by enumeration of devices.
[C#]
dsDevice = new Device(deviceGuid);

You can also use one of the following values to specify a default device.

Value | Description
DSoundHelper.DefaultPlaybackDevice | The default system audio device. This is the same as the device created when no parameter is passed to the Device constructor.
DSoundHelper.DefaultVoicePlaybackDevice | The default voice communications device. Typically this is a secondary device such as a USB headset with microphone.

The object cannot be created if there is no sound device or, under VxD virtual device drivers, if the sound device is under the control of an application using the standard Microsoft Win32 waveform-audio functions.

See also Capturing Waveforms.

Cooperative Levels

Because Windows is a multitasking environment, more than one application can be working with a device driver at any one time. Through the use of cooperative levels, Microsoft DirectX makes sure that each application does not gain access to the device in the wrong way or at the wrong time. Each DirectSound application has a cooperative level that determines the extent to which it is allowed to access the device.

After creating a Device object, you must set the cooperative level for the device by using the Device.SetCooperativeLevel method before you can play sounds.

DirectSound defines three cooperative levels for sound devices, represented by the values of the CooperativeLevel enumeration.

Normal Cooperative Level

At the normal cooperative level, the application cannot set the format of the primary buffer, write to the primary buffer, or compact the on-board memory of the device. All applications at this cooperative level use a primary buffer format of 22 kHz, stereo sound, and 8-bit samples, so that the device can switch between applications as smoothly as possible.

Priority Cooperative Level

When using a DirectSound device with the priority cooperative level, the application has first rights to hardware resources, such as hardware mixing, and can set the format of the primary sound buffer and compact the on-board memory of the device.

Game applications should use the priority cooperative level in almost all circumstances. This level gives the most robust behavior while allowing the application control over sampling rate and bit depth. The priority cooperative level also allows audio from other applications, such as IP telephony, to be heard along with the audio from the game.

Write-primary Cooperative Level

The highest cooperative level is write-primary. When using a DirectSound device with this cooperative level, your application has direct access to the primary sound buffer. In this mode, the application must write directly to the primary buffer. Secondary buffers cannot be played while this is happening.

An application must be set to the write-primary level in order to obtain direct write access to the audio samples in the primary buffer. If the application is not set to this level, then all calls to the Buffer.Write or the Buffer.Read method will fail.

When your application is set to the write-primary cooperative level and gains the foreground, all secondary buffers for other applications are stopped and marked as lost. When your application in turn moves to the background, its primary buffer is marked as lost and must be restored when the application again moves to the foreground.

You cannot set the write-primary cooperative level if a DirectSound driver is not present on the user's system. To determine whether this is the case, check the Caps.EmulateDriver property of Device.Caps. If EmulateDriver is true, the DirectSound driver is being emulated for the device, and the write-primary level cannot be set.

Device Capabilities

DirectSound enables your application to retrieve the hardware capabilities of the sound device. Most applications will not need to do this, because DirectSound automatically takes advantage of any available hardware acceleration. However, high-performance applications can use the information to scale their sound requirements to the available hardware. For example, an application might choose to play more sounds if hardware mixing is available than if it is not.

After creating a Device object, your application can retrieve the capabilities of the sound device from the Device.Caps property. The Caps structure contains information about the performance and resources of the sound device, including the maximum resources of each type and the resources that are currently available.

If your application scales to hardware capabilities, you should check the Caps property after every buffer allocation to determine if there are enough resources to create the next buffer.

Speaker Configuration

DirectSound uses the speaker configuration-that is, the position of the speakers relative to the listener-to optimize 3-D effects for the user's sound system.

In Microsoft Windows 98, Windows 2000, and later operating systems, the speaker configuration can be set by the user in Control Panel. An application can retrieve this value from the Device.SpeakerConfig property. Although this property can be set, applications should not do so, as this is a global setting that affects other users and applications.

Compacting Hardware Memory

As long as it has at least the priority cooperative level, your application can use the Device.Compact method to move any on-board sound memory into a contiguous block to make the largest portion of free memory available. This method is not useful on most modern sound cards, which use system memory.


Buffers

Microsoft DirectSound buffer objects control the delivery of waveform data from a source to a destination. For most buffers, the destination is a mixing engine called the primary buffer. From the primary buffer, the data goes to the hardware that converts digital samples to sound waves.

Information about using DirectSound buffers is contained in the following topics.

For information about capture buffers, see Capturing Waveforms.

  • Buffer Basics
  • Creating Secondary Buffers
  • Buffer Control Options
  • 3-D Algorithms for Buffers
  • Filling and Playing Static Buffers
  • Using Streaming Buffers
  • Playback Controls
  • Play and Write Cursors
  • Play Buffer Notification
  • Mixing Sounds
  • Losing and Restoring Buffers

Buffer Basics

When DirectSound is initialized, it automatically creates and manages a primary buffer for mixing sounds and sending them to the output device.

Your application must create at least one secondary sound buffer for storing and playing individual sounds. For more information on how to do this, see Creating Secondary Buffers.

A secondary buffer has a waveform format that must match the format of the data. This format is described in a WaveFormat structure. The format of a secondary buffer cannot be changed. Sounds of different formats can be played in different secondary buffers, and are automatically mixed to a common format in the primary buffer.

A secondary buffer can exist throughout the life of an application or it can be destroyed when no longer needed. It can contain a single sound that is to be played repeatedly, such as a sound effect in a game, or it can be filled with new data from time to time. The application can play a sound stored in a secondary buffer as a single event or as a looping sound that plays continuously. Secondary buffers can also be used to stream data, in cases where a sound file contains more data than can conveniently be stored in memory.

Buffers can be located either in hardware or in software. Hardware buffers are mixed by the sound card processor, and software buffers are mixed by the CPU. Software buffer data is always in system memory; hardware buffer data can be in system memory or, if the application requests it and resources are available, in on-board memory. For more information, see Dynamic Voice Management and Hardware Acceleration on ISA and PCI Cards.

You mix sounds from different secondary buffers simply by playing them at the same time. Any number of secondary buffers can be played at one time, up to the limits of available processing power.

Normally, you do not have to concern yourself at all with the primary buffer; DirectSound manages it behind the scenes. However, if your application is to perform its own mixing, DirectSound will let you write directly to the primary buffer. If you do this, you cannot also use secondary buffers.

Creating Secondary Buffers

To create a secondary sound buffer, use one of the five overloaded constructors of SecondaryBuffer, with an instantiated Device object passed to the constructor. As appropriate, also pass to the constructor a Stream Leave Site source data stream object, or a String Leave Site file name object.

Buffer objects are owned by the Device object that created them. When the Device object is released, all buffers created by that object also will be released and should not be referenced.

DirectSound allocates hardware resources to the first buffer that can take advantage of them. Because hardware buffers are mixed by the sound card processor, they have much less impact on application performance. To specify the buffer location, pass a BufferDescription object to the constructor as follows.

BufferDescription Options

An instantiated BufferDescription object may be passed to the SecondaryBuffer constructor in order to describe the characteristics and location of the buffer.

If you want to specify the location of a buffer instead of letting DirectSound decide where it belongs, set either the BufferDescription.LocateInHardware property or BufferDescription.LocateInSoftware property. If LocateInHardware is set and there are insufficient hardware resources, the buffer creation request fails.

To take advantage of the voice management features of DirectSound, set the BufferDescription.DeferLocation property when creating the buffer. This property defers the allocation of resources for the buffer until it is played. For more information, see Dynamic Voice Management.

You can ascertain the location of an existing buffer by getting the Buffer.Caps property (inherited by SecondaryBuffer). Check the BufferCaps structure for either LocateInHardware or LocateInSoftware properties. One or the other is always specified.

Setting BufferDescription.StaticBuffer lets DirectSound know that the buffer should be created in on-board hardware memory if possible. Buffer creation does not fail if a hardware buffer is not available. Hardware static buffers should be used only for short sounds that are to be played repeatedly. This property has no effect on most modern sound cards, which use system memory for their buffers.

See Also

Hardware Acceleration on ISA and PCI Cards.

Buffer Control Options

When creating a sound buffer, your application must specify the control options needed for that buffer. This is done with the BufferDescription class, which can contain one or more of the following control properties from the BufferCaps structure. This is not a complete list of all available properties.

Property | Description
Control3D | Buffer supports 3-D control. Cannot be combined with ControlPan.
ControlFrequency | Buffer supports frequency control.
ControlEffects | Buffer supports effects processing.
ControlPan | Buffer supports pan control. Cannot be combined with Control3D.
ControlPositionNotify | Buffer supports notifications of cursor position.
ControlVolume | Buffer supports volume control.

To obtain the best performance on all sound cards, your application should specify only control options it will use.

DirectSound uses the control options in determining whether hardware resources can be allocated to sound buffers. For example, a device might support hardware buffers but provide no pan control on those buffers. In this case, DirectSound would use hardware acceleration only if the ControlPan property was not specified.

If your application attempts to use a control that a buffer lacks, the method call fails. For example, if you attempt to set the Buffer.Volume property, an exception occurs unless the ControlVolume property was specified when the buffer was created.

See Also

Playback Controls

3-D Algorithms for Buffers

When you create a secondary buffer with the BufferCaps.Control3D property and the buffer is in software, you can specify an algorithm to simulate 3-D spatial location of a sound. By default, no head-related transfer function (HRTF) processing is performed, and the location of the sound relative to the listener is indicated by panning and volume only. You can request two levels of HRTF for the buffer.

See Also

BufferDescription.Guid3DAlgorithm.

Filling and Playing Static Buffers

A secondary buffer that contains an entire self-contained sound is called a static buffer. Although it is possible to reuse the same buffer for different sounds, typically data is written to a static buffer only once.

Static buffers are created and managed just like streaming buffers. The only difference is in the way they are used: static buffers are filled once and then played, but streaming buffers are constantly refreshed with data as they are playing.

Note: A static buffer is not necessarily one created by setting the BufferCaps.StaticBuffer property in the buffer description. This property requests allocation of memory on the sound card, which is not available on most modern hardware. A static buffer can exist in system memory and can be created with either the LocateInHardware or LocateInHardware properties. For more information, see Hardware Acceleration on ISA and PCI Cards.

When you create a secondary buffer using the SecondaryBuffer(String,BufferDescription,Device) or SecondaryBuffer(Stream,BufferDescription,Device) constructors, the buffer is automatically given the correct format and size, and is filled with the data. If you use the SecondaryBuffer(String,Device) or SecondaryBuffer(Stream,Device) constructors, you are responsible for setting the format and size of the buffer, and you must write the data to the buffer by using the Buffer.Write method (inherited by SecondaryBuffer).

To play the buffer, call Buffer.Play.

The following C# example creates a buffer from a file and plays it. The buffer supports volume control, panning, and frequency control. Assume that FileName is a valid path to a WAV file, and device is a Device object.
[C#]
SecondaryBuffer secBuff = null;
BufferDescription desc = new BufferDescription();
desc.Flags = BufferCaps.ControlPan | BufferCaps.ControlVolume | BufferCaps.ControlFrequency;
secBuff = new SecondaryBuffer(FileName, desc, device);
secBuff.Play(0, 0);

Because the BufferPlayFlags.Looping flag is not set in the example, the buffer automatically stops when it reaches the end. You can also stop it prematurely, or stop a looping buffer, by using Buffer.Stop.

Using Streaming Buffers

A streaming buffer plays a long sound that cannot all fit into the buffer at once. As the buffer plays, old data is periodically replaced with new data. Play a streaming sound with the following procedure.

  1. Call SecondaryBuffer(Stream,BufferDescription,Device) to create a buffer with the correct waveform format, and of a convenient size. A buffer large enough to hold one or two seconds of data is typical; smaller buffers can be used, but they have to be refreshed more frequently, which can be inefficient.
  2. Set notification positions so that your application knows when to refresh a portion of the buffer. For example, you can set notifications halfway through the buffer and at the end. When the play cursor reaches the halfway point, the first part of the buffer is refreshed; when it reaches the end, the second part is refreshed. Alternatively, you can poll the play cursor as the buffer plays, but this is less efficient than notification. For more information, see Play and Write Cursors.
  3. Load the entire buffer with data by using Buffer.Write.
  4. Call Buffer.Play (inherited by SecondaryBuffer), specifying the BufferStatus.Looping property.
  5. When the play cursor reaches the first point at which you want to refresh data, call Write again, writing new data from the start of the buffer up to the play cursor. Save the position of the last byte written.
  6. Call Write each time the cursor reaches a refresh point, writing data to the part of the buffer that lies between the saved position and the play cursor. Note that wraparound is handled automatically: if the buffer is 10,000 bytes long, and you write 2000 bytes to offset 9000, the last 1000 bytes are written to the front of the buffer.
  7. When all data has been written to the buffer, set a notification position at the last valid byte, or poll for this position. When the cursor reaches the end of the data, call Buffer.Stop.

Never write to the entire buffer while it is playing. Refresh only a portion of the buffer each time. Do not write to the part of the buffer that lies between the play cursor and the write cursor.

Playback Controls

To retrieve and set the volume at which a buffer is played, your application can use the Buffer.Volume property. (All properties are inherited by SecondaryBuffer.) Setting the volume on the primary buffer changes the waveform-audio volume of the sound card. Volume is measured in hundredths of a decibel and is a negative value. Because the decibel scale is not linear, effective silence may occur long before the minimum volume of -10,000 is reached.

The Buffer.Frequency property controls the frequency at which audio samples play, in samples per second. Set this property to 0 to reset the frequency to the original value, as specified in the WaveFormat structure that describes the format of the buffer. You cannot change the frequency of the primary buffer.

The Buffer.Pan property controls the right-left position of the sound. The pan effect is achieved by attenuating one channel. When the sound is at the center (a Pan value of 0), both channels are at full volume.

In order to use any of these controls, you must set the appropriate flags when creating the buffer. See Buffer Control Options.

Play and Write Cursors

DirectSound maintains two pointers into the buffer: the play cursor and the write cursor. These positions are byte offsets into the buffer.

The Buffer.Play method always starts playing at the buffer's play cursor. When a buffer is created, the cursor position is set to 0. As a sound is played, the cursor moves and always points to the next byte of data to be output. When the buffer is stopped, the cursor remains at the next byte of data.

The write cursor is the point after which it is safe to write data into the buffer. The block between the current play position and the current write position is already committed to be played, and it cannot be changed safely.

You might visualize the buffer as a clock face, with data written to it in a clockwise direction. The play position and the write position are like two hands sweeping around the face at the same speed, the write position always keeping a little ahead of the play position. If the play position points to the 1 and the write position points to the 2, it is only safe to write data after the 2. Data between the 1 and the 2 may already have been queued for playback by DirectSound and should not be touched.

The write position moves with the play position, not with data written to the buffer. If you are streaming data, you are responsible for maintaining your own pointer into the buffer to indicate where the next block of data should be written.

An application can retrieve the play and write cursors from the PlayPosition and WritePosition properties. You can also set the PlayPosition property, which indirectly changes WritePosition.

To ensure that the play cursor is reported as accurately as possible, always specify the BufferCaps.CanGetCurrentPosition property when creating a secondary buffer.

Play Buffer Notification

When streaming audio, you may want your application to be notified when the play cursor reaches a certain point in the buffer, or when playback is stopped. By using the Notify.SetNotificationPositions method, you can set any number of points within the buffer where events are to be signaled. You cannot do this while the buffer is playing.

To set up notifications, do the following:

  1. Create an AutoResetEvent Leave Site for each notification position.
  2. Obtain the Notify object by passing the SecondaryBuffer object to the Notify constructor.
  3. Create an array of BufferPositionNotify structures, one for each notification position. Set the Offset property to the byte offset where you want to be notified. Set the EventNotifyHandle property to the AutoResetEvent Leave Site.Handle Leave Site of one of the events you created in step 1.
  4. Call Notify.SetNotificationPositions, passing in the array of BufferPositionNotify structures.

You can now play the buffer in a separate thread and use WaitHandle Leave Site.WaitAny Leave Site to wait for notifications.

Mixing Sounds

Mixing is done automatically when you play multiple secondary buffers at the same time.

Under earlier driver models, the DirectSound mixer produces the best sound quality if all your application's sounds use the same WAV format and the hardware output format is matched to the format of the sounds. If this is done, the mixer does not need to perform any format conversion.

Your application can change the hardware output format by creating a primary sound buffer object and setting the Buffer.Format property. This primary buffer object is for control purposes only; creating it is not the same as obtaining write access to the primary buffer, and you do not need the CooperativeLevel.WritePrimary cooperative level. However, you do need a cooperative level of CooperativeLevel.Priority. DirectSound will restore the hardware format to the format specified in the last call every time the application gains the input focus.

You must set the format of the primary buffer before creating any secondary buffers.

Note: With Microsoft Windows Driver Model (WDM) drivers, setting the primary buffer format has no effect. The format is determined by the kernel mixer. For more information, see DirectSound Driver Models.

Losing and Restoring Buffers

Memory for a sound buffer can be lost in certain situations: for example, when buffers are located in sound card memory and another application gains control of the hardware resources. Loss can also occur when an application with the write-primary cooperative level moves to the foreground; in this case, DirectSound makes all other sound buffers lost so that the foreground application can write directly to the primary buffer.

An exception is raised when the application attempts to play or write data to a lost buffer. When the application that caused the loss either lowers its cooperative level from write-primary or moves to the background, other applications can attempt to reallocate the buffer memory by calling the Buffer.Restore method. If successful, this method restores the buffer memory and all other settings for the buffer, such as volume and pan settings. However, a restored buffer may not contain valid sound data, so the owning application should rewrite the data to the buffer.


Using WAV Data

Microsoft DirectSound buffers play only waveform audio data consisting of digital samples of the sound at a fixed sampling rate. The representation of an analog signal by a sequence of numbers is known as Pulse Code Modulation (PCM).

WAV data is usually stored in files or resources in Resource Interchange File Format (RIFF). The data includes a description of the WAV format, including parameters such as the sampling rate and number of output channels. The format of a sound is described by a WaveFormat structure. Managed DirectSound does not support audio formats with more than two channels, as described in a C++ WAVEFORMATEXTENSIBLE structure.

DirectSound does not support compressed WAV formats. Applications should use the Audio Compression Manager (ACM) functions, provided with the Microsoft Win32 application programming interfaces (APIs) in the Microsoft Platform Software Development Kit (SDK), to convert compressed audio to PCM format before writing the data to a sound buffer.

For short sounds, you can create a SecondaryBuffer from a WAV file by using SecondaryBuffer(String,Device) or SecondaryBuffer(String,BufferDescription,Device). To access streaming buffers, you can use the SecondaryBuffer(Stream,Device) or SecondaryBuffer(Stream,BufferDescription,Device) constructors.


3-D Sound

Using Microsoft DirectSound, you can locate sounds in space and apply Doppler shift to moving sounds. 3-D effects are applied to individual DirectSound buffers. Global parameters are set on an object called the listener.

The following topics cover some general aspects of 3-D sound.

  • Coordinates of 3-D Space
  • Perception of Sound Positions

Information about how to use 3-D sound in an application is found in the following sections.

  • 3-D Buffers
  • 3-D Listeners


Coordinates of 3-D Space

The position, velocity, and orientation of sound sources and listeners in 3-D space are represented by Cartesian coordinates, which are values on three axes: the x-axis, the y-axis, and the z-axis. The axes are relative to a viewpoint established by the application. Values on the x-axis increase from left to right, on the y-axis from down to up, and on the z-axis from near to far.

Left-handed Cartesian coordinates

Microsoft DirectSound uses the left-handed coordinate system shown. If you point the fingers of your left hand in the positive x direction and curl them into the positive y direction, your thumb will point in the positive z direction.

Conventionally, vectors are expressed as three values enclosed in parentheses and separated by commas, in the order (x, y, z). In DirectSound, coordinates of position, velocity, or orientation on the three axes are described in a Vector3 structure.

For position, the values are in meters by default. If your application does not use the meter as its unit of measure for 3-D graphics, you can set a distance factor, which is a floating-point value representing meters per application-specified distance unit. For example, if your application uses the foot as the distance unit, it could specify a distance factor of 0.3048, which is the number of meters in a foot. For more information, see Distance Factor.

For velocity, the vector describes the rate of movement along each axis in units per second. Again, the default unit is meters, but this can be changed by the application.

For orientation, the values are in arbitrary units and are relative to one another. If the base view of the 3-D world is facing north, level to the ground, and the orientation of the listener is (1, 0, 0)-that is, positive on the x-axis and neutral on the other two axes-then the listener is facing due east. If the vector is (1, 0, 1), the listener's orientation is to the northeast. If it is (-1, 0, 1), the listener is facing northwest. Because the values within a vector are not in absolute units, the last example could equally well be expressed in many other ways, such as (-5, 0, 5) or (-0.25, 0, 0.25).

You can see how vectors in 2-D space work by drawing them on a sheet of graph paper. Let the values increase from the bottom of the paper to the top and from left to right. A line drawn from (0, 0) to (1, 1) has the same orientation, or direction, as one drawn from (0, 0), to (5, 5). However, the second line indicates a greater distance, or velocity. 3-D vectors work in just the same way, with an additional axis.


Perception of Sound Positions

In the real world, the perception of a sound's position in space is influenced by several factors. Not all of these factors are acoustical; one of the most important is sight. Clues from the sounds themselves include the following:

  • Overall loudness. As a sound source moves away from the listener, its perceived volume decreases at a fixed rate. This phenomenon is known as rolloff.
  • Interaural intensity difference. For example, a sound coming from the listener's right sounds louder in the right ear than in the left.
  • Interaural time difference. For example, a sound coming from the listener's right arrives at the right ear slightly before it arrives at the left ear. The difference is approximately a millisecond.
  • Muffling. The shape and orientation of the ears ensures that sounds coming from behind the listener are slightly muffled compared with sounds coming from the front. In addition, if a sound is coming from the right, the sound reaching the left ear will be muffled by the mass of the listener's head as well as by the orientation of the left ear.
  • Effect of the pinnae. The ridges of the earlobes alter the pitch and timing of sounds arriving from different directions, giving subtle clues to the brain about the location of the sound source. The mathematics behind this effect are known as the head-related transfer function (HRTF).

Microsoft DirectSound creates virtual 3-D effects on two speakers or headphones, or on multichannel systems with Microsoft Windows Driver Model (WDM) drivers if the user has chosen a surround sound speaker configuration in Control Panel. For more information, see BufferDescription.


3-D Buffers

Each sound source in a 3-D environment is represented by an object of the Buffer3D class. This class is supported only by sound buffers created with the BufferCaps.Control3D property.

Applications must supply monaural sound sources when using the 3-D capabilities of Microsoft DirectSound. If you attempt to create a buffer with the Control3D property set and a WAV format with more than one channel, an exception is raised.

This section describes how your applications can obtain and manage Buffer3D objects. The following topics are discussed.

  • Obtaining the Buffer3D Object
  • Batch Parameters for 3-D Buffers
  • Minimum and Maximum Distances
  • Processing Mode
  • Buffer Position and Velocity
  • Sound Cones

Obtaining the Buffer3D Object

Create a Buffer3D object by passing a SecondaryBuffer object to the Buffer3D constructor. The BufferDescription.Control3D property must have been set to true.

See Also

Buffer3D(SecondaryBuffer)

Batch Parameters for 3-D Buffers

Applications can retrieve or set a 3-D sound buffer's parameters individually or in batches. To set individual values, your application can use the applicable Buffer3D property. However, applications often must set or retrieve several values at once as the sound source moves about, changes velocity, and so on. You can do this by using the Buffer3D.AllParameters property.

Parameter changes can also be made more efficiently by flagging them as deferred and then running them all at once. For more information, see Deferred Settings.

Minimum and Maximum Distances

As a listener approaches a sound source, the sound gets louder; the volume doubles when the distance is halved. Past a certain point, however, it is not practical for the volume to continue to increase. This is the minimum distance for the sound source.

The minimum distance is especially useful when an application must compensate for the difference in absolute volume levels of different sounds. Although a jet engine is much louder than a bee, for practical reasons these sounds must be recorded at similar absolute volumes. An application might use a minimum distance of 100 meters for the jet engine and 2 centimeters for the bee. With these settings, the jet engine would be at half volume when the listener was 200 meters away, but the bee would be at half volume when the listener was 4 centimeters away.

The default minimum distance for a sound buffer is defined as 1 unit, or 1 meter at the default distance factor. Unless you change this value, the sound is at full volume when it is 1 meter away from the listener, at half volume 2 meters away, at quarter volume 4 meters away, and so on. For most sounds you will probably want to set a larger minimum distance so that the sound does not fade so rapidly as it moves away.

The maximum distance for a sound source is the distance beyond which the volume does not get any lower. The default maximum distance for a DirectSound 3-D buffer is 1 billion, meaning that in most cases the attenuation will continue to be calculated long after the sound has moved out of hearing range. To avoid unnecessary processing on software buffers under VxD virtual device drivers, applications should set a reasonable maximum distance and include the Mute3DAtMaximumDistance property when creating the buffer.

The maximum distance can also be used to prevent a sound from becoming inaudible. For example, if you have set the minimum distance for a sound at 100 meters, that sound might become effectively inaudible at 1,000 meters or less. By setting the maximum distance at 800 meters, you ensure that the sound always has at least one-eighth of its maximum volume regardless of the distance. In this case, of course, you should not set the Mute3DAtMaximumDistance property.

The following illustration shows how minimum and maximum distance affect the sound volume of a jet and a bee at increasing distances.

Graph of effects of minimum and maximum distances on sound volume

By default, distance values are expressed in meters. See Distance Factor.

To adjust the effect of distance on volume for all sound buffers, you can change the Rolloff Factor.

See Also

Buffer3D.AllParameters property

Buffer3D.MaxDistance property

Buffer3D.MinDistance property

Processing Mode

Sound buffers have three processing modes: normal, head-relative, and disabled.

In normal mode, the sound source is positioned and oriented absolutely in world space. This is the default mode, and is used for sound sources that do not move and turn with the listener.

In head-relative mode, the 3-D properties of the sound source are all relative to the current position, velocity, and orientation of the listener. As the listener moves and turns, the buffer is automatically repositioned in world space. Head-relative mode can be used for sounds such as the listener's own footsteps. However, most head-relative sounds do not have to be 3-D sounds at all.

In disabled mode, 3-D sound processing is disabled and the sound seems to originate from the center of the listener's head.

See Also

Buffer3D.AllParameters property

Buffer3D.Mode property

Buffer Position and Velocity

As a sound source moves, it is up to the application to specify values for its position and velocity.

Position is measured in distance units along each of the three axes, relative to either world space or the listener, depending on the processing mode.

Velocity is measured in distance units per second along each of the three axes of a vector. By default, distance units are meters. Velocity is used by DirectSound only to calculate the effects of Doppler shift.

See Also

Buffer3D.AllParameters property

Buffer3D.Position property

Buffer3D.Velocity property

Distance Factor

Doppler Factor

Processing Mode

Sound Cones

A sound with no orientation has the same amplitude at a given distance in all directions. A sound with an orientation is loudest in the direction of orientation. The model that describes the loudness of the oriented sound is called a sound cone, which has its apex located at the source of the sound. Sound cones are made up of an inside (or inner) cone and an outside (or outer) cone. The outside cone angle must always be equal to or greater than the inside cone angle.

At any angle within the inner cone, the volume of the sound is just what it would be if there were no cone, after taking into account the basic volume of the buffer, the distance from the listener, the listener's orientation, and so on.

At any angle outside the outer cone, the normal volume is attenuated by a factor set by the application. The outside cone volume is expressed in hundredths of decibels and is a negative value, because it represents attenuation from the default volume of 0.

Between the inner and outer cones is a zone of transition from the inside volume to the outside volume. The volume decreases as the angle increases.

The following illustration shows the concept of sound cones.

Diagram of listener within inside and outside sound cones

Every 3-D sound buffer has a sound cone, but by default a buffer behaves like an omnidirectional sound source, because the outside volume is not attenuated, and the inside and outside cone angles are 360 degrees. Unless the application changes these values, the sound does not have any apparent orientation.

Designing sound cones properly can add dramatic effects to your application. For example, you could position a sound source in the center of a room, setting its orientation toward an open door in a hallway. Then set the angle of the inside cone so that it extends to the width of the doorway, make the outside cone a bit wider, and set the outside cone volume to inaudible. A listener moving along the hallway will begin to hear the sound only when near the doorway, and the sound will be loudest as the listener passes in front of the open door.

See Also

Buffer3D.ConeAngles property

Buffer3D.ConeOrientation property

Buffer3D.ConeOutsideVolume property


3-D Listeners

In a virtual 3-D environment as in the real world, sounds exist in relation to a point of reception. The 3-D sound effects in a Microsoft DirectSound application are affected not only by the position, orientation, and velocity values of the sound sources, but also by the position, orientation, and velocity of the virtual listener.

By default, the listener is stationary at the zero point of all vectors, oriented with the nose toward the positive z-axis and the top of the head toward the positive y-axis. By obtaining an object to represent the listener, the application can change all these values to reflect the movement and "facing" of the user within virtual space. The listener object also controls the general parameters of the acoustic environment, such as the amount of Doppler shift and the rate of volume attenuation over distance.

This section describes how your application can obtain a listener and manage global 3-D sound parameters. The following topics are discussed.

  • Obtaining the 3-D Listener
  • Batch Parameters for 3-D Listeners
  • Deferred Settings
  • Distance Factor
  • Listener Orientation
  • Listener Position and Velocity
  • Doppler Factor
  • Rolloff Factor

Obtaining the 3-D Listener

Global sound parameters are set and retrieved by using the Listener3D object, which is obtained from the primary buffer. Only one listener exists in an application.

The following Microsoft Visual Basic function creates a Buffer object representing the primary buffer, which is created with the Control3D property. The function then creates and returns a Listener3D object.
[Visual Basic]
Private Function getListener(ByVal dev As Device) As Listener3D
    Dim primaryBuffer As Buffer
    Dim desc As New BufferDescription()
    Dim caps As New BufferCaps()
    desc.PrimaryBuffer = True
    desc.Flags = caps.PrimaryBuffer OR caps.Control3D
    primaryBuffer = New Buffer(desc, dev)
    Dim listener = New Listener3D(primaryBuffer)
    Return listener
End Function

Batch Parameters for 3-D Listeners

Applications can retrieve or set a listener's parameters individually or in batches. To set individual values, your application can use the applicable Listener3D property. However, applications often must set or retrieve several values at once as the sound source moves about, changes velocity, and so on. You can do this by using the Listener3D.AllParameters property.

Parameter changes can also be made more efficiently by flagging them as deferred and then executing them all at once. For more information, see Deferred Settings.

Deferred Settings

Every change to 3-D sound buffer and listener settings causes remixing, at the expense of CPU cycles. To minimize the performance impact of changing 3-D settings, set the Deferred property on the Listener3D object and all Buffer3D objects. When this property is true, no other properties are changed until you call Listener3D.CommitDeferredSettings.

Note: CommitDeferredSettings settings are replaced by immediate settings. For example, if you set Listener3D.Deferred to true and set the listener velocity to (1.0, 0.0, 0.0), and then you set Deferred to false and set the velocity to (2.0, 0.0, 0.0), the velocity immediately becomes (2.0, 0.0, 0.0) and does not change when CommitDeferredSettings is called.

Distance Factor

The distance factor is the number of meters in a vector unit. By default, the distance factor is 1.0. If the velocity of a buffer is (2.0, 0.0, 0.0), the sound source is considered to be moving along the positive x-axis at 2 meters per second. Applications that are using a different unit of measurement for 3-D graphics vectors might want to change the distance factor accordingly.

Suppose, for example, that the basic unit of measurement in your application is the foot, or 0.3048 meters. You set the Listener3D.DistanceFactor property to 0.3048. From then on, properties such as position and velocity are measured in feet.

The distance factor mainly affects Doppler shift, by changing the actual velocity represented by n units per second. It does not directly affect rolloff, because the rate of attenuation over distance is based on the minimum distance in unspecified units. If you set the minimum distance for a given sound at 2 units, the volume will be halved at a distance of 4 units, whether those units are in feet, meters, or any other measure.

See Also

Minimum and Maximum Distances

Listener Orientation

Listener orientation is defined by the relationship between two vectors that share an origin at the center of the listener's head: the top and front vectors. The top vector points straight up through the top of the head, and the front vector points forward through the listener's face at right angles to the top vector, as in the following illustration.

Diagram of listener top and front vectors

By default, the front vector is (0.0, 0.0, 1.0), and the top vector is (0.0, 1.0, 0.0). The two vectors must always be at right angles to one another. If necessary, DirectSound will adjust the front vector so that it is at right angles to the top vector.

See Also

Listener3D.Orientation property

Listener Position and Velocity

As the listener moves, it is up to the application to specify values for its position and velocity.

Position is measured in distance units along each of the three axes, relative to either world space or the listener, depending on the processing mode.

Velocity is measured in distance units per second along each of the three axes of a vector. By default, distance units are meters. To calculate Doppler shift, DirectSound combines the velocity of the sound source with the velocity of the listener.

See Also

Listener3D.AllParameters property

Listener3D.Position property

Listener3D.Velocity property

Distance Factor

Doppler Factor

Doppler Factor

DirectSound automatically creates Doppler shift effects for 3-D sound buffers based on their velocity relative to the listener.

In order to have realistic Doppler shift effects in your application, you must calculate the speed of any object that is moving, whether a sound source or a listener, and set the appropriate velocity. You are free to exaggerate or lessen this value in a particular case in order to create special effects. You can also globally increase or decrease Doppler shift by changing the Listener3D.DopplerFactor property.

The Doppler factor can range from 0.0 (DSoundHelper.MinDopplerFactor) to 10.0 (DSoundHelper.MaxDopplerFactor). A value of 0 means no Doppler shift is applied to a sound. Every other value represents a multiple of the real-world Doppler shift. In other words, a value of 1 (DSoundHelper.DefaultDopplerFactor) means the Doppler shift that would be experienced in the real world is applied to the sound, a value of 2 means twice the real-world Doppler shift, and so on.

See Also

Buffer3D.Velocity property

Listener3D.Velocity property

Rolloff Factor

Rolloff is the amount of attenuation that is applied to sounds, based on the listener's distance from the sound source. DirectSound can ignore rolloff, exaggerate it, or give it the same effect as in the real world, depending on the value of the Listener3D.RolloffFactor property.

The rolloff factor can range from 0.0 (DSoundHelper.MinRolloffFactor) to 10.0 (DSoundHelper.MaxRolloffFactor). A value of 0 means no rolloff is applied to a sound. Every other value represents a multiple of the real-world rolloff. In other words, a value of 1 (DSoundHelper.DefaultRolloffFactor) means the rolloff that would be experienced in the real world is applied to the sound, a value of 2 means twice the real-world rolloff, and so on.

To change the effect of distance for an individual sound buffer, you can set the minimum distance for the buffer. For more information, see Minimum and Maximum Distances.


Using Effects

Microsoft DirectSound provides support for effects processing of sounds by Microsoft DirectX Media Objects (DMOs).

All the standard DMOs except Waves reverberation can process 8-bit or 16-bit Pulse Code Modulation (PCM) data with one or two channels at any sample rate supported by DirectSound. Waves reverberation does not support 8-bit samples.

The following topics contain information on setting up and using effects.

  • Setting Effects on Buffers
  • Effect Parameters
  • Standard Effects


Setting Effects on Buffers

Any number of effects can be set on a secondary buffer that was created with the BufferCaps.ControlEffects property. Effects might not work smoothly on very small buffers, and Microsoft DirectSound does not permit the creation of effects-capable buffers that hold less than 150 (BufferSize.FxMin) milliseconds of data.

To implement an effect on a buffer, use the SecondaryBuffer.SetEffects method. This method takes an array of EffectDescription structures that describe the effects. You can also use SetEffects to remove effects, by passing a null reference instead of an array. In either case, the buffer must not be playing.

Effects can be instantiated in hardware (that is, implemented by the sound card driver) or in software. For more information, see EffectDescription.

The following Microsoft Visual Basic sample function sets the standard echo effect on a buffer.
[Visual Basic]
Private Sub SetEcho(ByVal b As SecondaryBuffer)
    Dim fx As EffectDescription()
    ReDim fx(0)
    fx(0).GuidEffectClass = DSoundHelper.StandardEchoGuid
    Try
        b.SetEffects(fx)
    Catch e As ControlUnavailableException
        Debug.WriteLine("BufferDescription does not have ControlEffects set.")
    End Try
End Sub


Effect Parameters

To set or retrieve parameters of sound effects, you must first obtain the appropriate effect object from the buffer that contains the effect.

Objects of the following classes give you access to parameters of the Microsoft DirectX Media Objects (DMOs) supplied with DirectX.

  • ChorusEffect class
  • CompressorEffect class
  • DistortionEffect class
  • EchoEffect class
  • FlangerEffect class
  • GargleEffect class
  • Interactive3DLevel2ReverbEffect class
  • ParamEqEffect class
  • WavesReverbEffect class

To retrieve an effect object, use the SecondaryBuffer.GetEffects method. This method can retrieve a single object or an array of objects.

The following Microsoft Visual Basic sample code retrieves an EchoEffect object representing the first effect set on a buffer, and sets two parameters on the effect. Assume that fxBuffer is a SecondaryBuffer object.
[Visual Basic]
Dim echoFx As EchoEffect
Dim echoParams As EffectsEcho
echoFx = fxBuffer.GetEffects(0)
echoParams = echoFx.AllParameters
echoParams.LeftDelay = 500
echoParams.RightDelay = 500
echoFx.AllParameters = echoParams

Effect parameters can be changed while the buffer is playing.

For efficiency, Microsoft DirectSound preprocesses 100 milliseconds of sound data in a buffer, starting at the play cursor, before SecondaryBuffer.Play is called. This can happen after any of the following calls.

  • SecondaryBuffer.SetCurrentPosition
  • SecondaryBuffer.SetEffects
  • SecondaryBuffer.Stop
  • SecondaryBuffer.Write

If you call any of these methods and then change effect parameters, the new parameters will not be heard until the preprocessed data has been played. To avoid this situation, do one of the following:

  • Write data to the buffer after effect parameters have been changed, not before.
  • Call Stop or SetCurrentPosition on the buffer to force preprocessing after you have set the parameters.


Standard Effects

This topic is an introduction to the sound effects provided with Microsoft DirectSound.

The following effects are covered.

  • Chorus
  • Compression
  • Distortion
  • Echo
  • Environmental Reverberation
  • Flange
  • Gargle
  • Parametric Equalizer
  • Waves Reverberation

Chorus

Chorus is a voice-doubling effect created by echoing the original sound with a slight delay and slightly modulating the delay of the echo.

This effect is represented by the ChorusEffect class. Its parameters are contained in the EffectsChorus structure.

Compression

Compression is a reduction in the fluctuation of a signal above a certain amplitude.

This effect is represented by the CompressorEffect class. Its parameters are contained in the EffectsCompressor structure.

Distortion

Distortion is achieved by adding harmonics to the signal in such a way that, as the level increases, the top of the waveform becomes squared off or clipped.

This effect is represented by the DistortionEffect class. Its parameters are contained in the EffectsDistortion structure.

Echo

An echo effect causes sounds to be repeated after a fixed delay, usually at a diminished volume. As the repeated sounds are fed back into the mix, they are repeated again.

This effect is represented by the EchoEffect class. Its parameters are contained in the EffectsEcho structure.

Environmental Reverberation

DirectX supports environmental reverberation in accordance with the Interactive 3-D Audio, Level 2 (I3DL2) specification, published by the Interactive Audio Special Interest Group.

The Microsoft DirectX environmental reverb effect is an implementation of the listener properties in the I3DL2 specification. Source properties are not supported.

Sounds reaching the listener have three temporal components.

  • The direct path is the audio signal that goes straight from the sound source to the listener, without bouncing off any surface. There is therefore only one direct path signal.
  • Early reflections are the audio signals that reach the listener after one or two reflections off surfaces such as the walls, floor, and ceiling. If a signal is the result of the sound hitting only one wall on its way to the listener, it is called a first-order reflection. If it bounces off two walls before reaching the listener, it is called a second-order reflection. Humans can typically perceive individual reflections only of the first or second order.
  • Late reverberation, or simply reverb, consists of the combined lower-order reflections, usually a dense succession of echoes of diminishing intensity.

The combination of early reflections and late reverberation is sometimes called the room effect.

Reverb properties include the following:

  • Attenuation of the early reflections and late reverberation.
  • Rolloff factor, or the rate at which reflected signals become attenuated with distance. The rolloff factor for the direct path is managed by the DirectSound listener.
  • Reflections delay, which is the interval between the arrival of the direct-path signals and the arrival of the first early reflections.
  • Reverb delay, which is the interval between the first of the early reflections and the onset of late reverberation.
  • Decay time, which is the interval between the onset of late reverberation and the time when its intensity has been reduced by 60 decibels (dB).
  • Diffusion, which is proportional to the number of echoes per second in the late reverberation. Depending on the implementation, the density can change as the reverberation decays. In DirectX, the application can control this property by setting a percentage of the range allowed by the implementation.
  • Density, which is is proportional to the number of resonances per hertz in the late reverberation. Lower densities produce hollower sounds like those found in small rooms. In DirectX, the application can control this property by setting a percentage of the range allowed by the implementation.

Reverb properties are represented by an Interactive3DLevel2ReverbEffect class, and the parameters of the environment are contained in an EffectsInteractive3DLevel2Reverb structure.

DirectSound supports many sets of default parameters, or presets, that describe the reverb properties of audio environments ranging from mountains to sewer pipes. Most applications can simply choose one of these environments by using the Interactive3DLevel2ReverbEffect.Preset property.

To set and retrieve custom properties, use the Interactive3DLevel2ReverbEffect.AllParameters property.

Flange

Flange, also called flanger, is an echo effect in which the delay between the original signal and its echo is very short and varies over time. The result is sometimes referred to as a sweeping sound. The term flange originated with the practice of grabbing the flanges of a tape reel to change the speed.

This effect is represented by the FlangerEffect class. Its parameters are contained in the EffectsFlanger structure.

Gargle

The gargle effect modulates the amplitude of the signal.

This effect is represented by the GargleEffect class. Its parameters are contained in the EffectsGargle structure.

Parametric Equalizer

A parametric equalizer amplifies or attenuates signals of a given frequency.

Parametric equalizer effects for different pitches can be applied in parallel by setting multiple instances of the effect on the same buffer. In this way, the application can have tone control similar to that provided by a hardware equalizer.

This effect is represented by the ParamEqEffect class. Its parameters are contained in the EffectsParamEq structure.

Waves Reverberation

The Waves reverberation effect is intended for use with music. The Waves reverberation DirectX Media Object (DMO) is based on the Waves MaxxVerb technology, which is licensed to Microsoft.

This effect is represented by the WavesReverbEffect class. Its parameters are contained in the EffectsWavesReverb structure.


Capturing Waveforms

Microsoft DirectSound enables you to capture sounds from a microphone or other input to the sound card, for immediate playback or storage in a file. Data can be captured in Pulse Code Modulation (PCM) or compressed formats.

The Capture object is used to query the capabilities of sound capture devices and to create buffers for capturing sound samples.

The CaptureBuffer object represents a buffer used for receiving data from the input device. This buffer is conceptually circular: When input reaches the end of the buffer, it automatically starts again at the beginning.

The methods of CaptureBuffer enable you to retrieve the properties of the buffer, start and stop audio capture, and retrieve data. On operating systems that support capture effects, it also provides methods for retrieving effect objects and ascertaining the status of effects.

More information about WAV capture is found in the following topics.

  • Enumeration of Capture Devices
  • Creating the Capture Object
  • Capture Device Capabilities
  • Creating a Capture Buffer
  • Capture Buffer Information
  • Capture Buffer Notification
  • Capture Buffer Effects
  • Using the Capture Buffer


Enumeration of Capture Devices

If you are looking for a particular kind of device, want to offer the user a choice of devices, or need to work with two or more devices, you must enumerate the devices available on the system. For an application that is just going to capture sounds through the user's preferred capture device, you don't need to enumerate the available devices. For more information, see Creating the Capture Object.

Enumeration serves three purposes.

  • Reports what hardware is available.
  • Supplies a globally unique identifier (GUID) for each device.
  • Enables you to create a temporary Capture object for each device as it is enumerated, so that you can check the capabilities of the device.

To enumerate devices, first create a capture device using CaptureDevicesCollection.


Creating the Capture Object

If your application will capture and record sounds, you will create and use a Capture object.

The following C# example shows how to initialize a Capture object for the default device.
[C#]
private Capture dsCapture = null;
dsCapture = new Capture();
The following C# example creates a device from a globally unique identifier (GUID), represented by the deviceGuid variable. This GUID can be obtained by enumeration of devices.
[C#]
dsCapture = new Capture(deviceGuid);

You can also use one of the following values to specify a default device.

Value | Description
DSoundHelper.DefaultCaptureDevice | The default system capture device. This is the same as the device created when no parameter is passed to the Capture constructor.
DSoundHelper.DefaultVoiceCaptureDevice | The default voice capture device. Typically this is a secondary device such as a USB headset with microphone.

The object cannot be created if there is no capture device or, under VxD virtual device drivers, if the sound device is under the control of an application using the standard Microsoft Win32 waveform-audio functions.

If your application will capture sounds as well as play them, you should create both Device and Capture objects.

If you want the playback and capture objects to coexist, you should create and initialize the Device object before creating and initializing the Capture object.

Some audio devices are not configured for full duplex audio by default. If your application has problems with creating and initializing both a Device object and a Capture object, you should advise the user to check the audio device properties to ensure that full duplex is enabled.


Capture Device Capabilities

The capabilities of a capture device are described in the CaptureCaps structure, which contains the number of channels the device supports, as well as a combination of standard audio formats that are supported, equivalent to the values in the WAVEINCAPS structure used in the Microsoft Win32 waveform audio functions.

On non-WDM (Microsoft Windows Driver Model) drivers, a capture device can be used by only one application at a time. Each application can set its own format for the capture buffer by setting the properties in CaptureCaps.


Creating a Capture Buffer

Create a capture buffer for storing sound data by creating a CaptureBuffer object.

The capture buffer can be specified directly using the CaptureBuffer(IntPtr,Capture) constructor, or a new capture buffer can be created with the CaptureBuffer(CaptureBufferDescription,Capture) constructor, which takes a CaptureBufferDescription structure that specifies the characteristics of the desired buffer. The Format member of this structure is a WaveFormat structure, which must be initialized with the details of the desired WAV format.

Note that if your application is using Microsoft DirectSound playback as well as DirectSound capture, capture buffer creation can fail when the format of the capture buffer is not the same as that of the primary buffer. The reason is that some cards have only a single clock and cannot support capture and playback at two different frequencies.


Capture Buffer Information

Properties of a capture buffer are obtained from the CaptureBuffer.Caps property.

The CaptureBufferCaps structure describes the size of the buffer, whether it supports effects, and whether it supports the format specified when it was created or must use the Microsoft Win32 wave mapper.

To retrieve information about the format of the data in the buffer, as set when the buffer was created, use the CaptureBuffer.Format property.

To find out what a capture buffer is currently doing, check the CaptureBuffer properties. The Capturing property is set if the buffer is capturing. Looping is set if Looping was set in the last call to the CaptureBuffer.Start method, as will usually be the case.

The CaptureBuffer.GetCurrentPosition method returns the offsets of the read and capture cursors within the buffer. The read cursor is at the end of the data that has been fully captured into the buffer at this point. The capture cursor is at the end of the block of data that is currently being copied into the buffer. You cannot safely retrieve data between the read cursor and the capture cursor.


Capture Buffer Notification

When capturing audio, you might want your application to be notified when the read cursor reaches a certain point in the buffer, or when the buffer is stopped. By using the Notify.SetNotificationPositions method, you can set any number of points within the buffer where events are to be signaled. You cannot do this while the buffer is capturing.

To set up notifications, do the following.

  1. Create an AutoResetEvent Leave Site for each notification position.
  2. Obtain the Notify object by passing the CaptureBuffer object to the Notify constructor.
  3. Create an array of BufferPositionNotify structures, one for each notification position. Set the Offset member to the byte offset where you want to be notified. Set the EventNotifyHandle member to the AutoResetEvent Leave Site.Handle Leave Site of one of the events you created in step 1.
  4. Call Notify.SetNotificationPositions, passing in the array of BufferPositionNotify structures.

You can now start the buffer in a separate thread and use WaitHandle Leave Site.WaitAny Leave Site to wait for notifications.


Capture Buffer Effects

Two capture buffer effects are available as kernel mode implementations on Microsoft Windows XP Home Edition and Windows XP Professional and later operating systems.

  • Acoustic echo cancellation (AEC)
  • Noise suppression
These effects can be used only in conjunction with a FullDuplex object.

The CaptureBuffer constructor takes either a predefined buffer location in memory or a CaptureBufferDescription structure that contains a CaptureEffectDescription structure that describes desired effects.

For each CaptureEffectDescription structure, you must specify either the LocateInHardware property or the LocateInSoftware property. In most cases, specify LocateInSoftware. Buffer creation fails if the effect is not available in the specified location.

The effect is identified in the CaptureEffectDescription.GuidEffectsClass property. To obtain the Microsoft software implementation, specify DSoundHelper.CaptureEffectsMsAcousticEchoCancellation or DSoundHelper.CaptureEffectsMsNoiseSuppression. To use another implementation available in hardware or software, obtain the class and instance globally unique identifier (GUID) from the manufacturer.

After the buffer has been created, you can retrieve information about the effects by using the CaptureBuffer.GetEffectsStatus method.

AEC is primarily of interest for applications that use voice communication from one site to another. Without echo cancellation, the signal from a microphone at site A is output from the speakers at site B, picked up by the microphone at site B, and rebroadcast at site A, possibly resulting in a feedback loop. AEC overcomes this problem by monitoring the incoming signal, adjusting it to take the room environment into account, and then removing it from the outgoing signal.

AEC has the following limitations.

  • If the acoustic environment changes, the adaptive filter can take two seconds or more to adjust.
  • Any late reverberations occurring more than 128 milliseconds after the original signal are not removed from the outgoing signal.
  • Only one capture buffer at a time can use AEC.
  • AEC cannot be created if another application is capturing.

The effect objects are obtained from the capture buffer object by using CaptureBuffer.GetObjectInPath.

Use the CaptureAcousticEchoCancellationEffect object to set and retrieve AEC parameters on a capture buffer that contains the AEC effect. You can also enable noise fill, which is a means of preventing complete silence when there is no new data in the outgoing signal.

Noise suppression can be applied only if AEC is also enabled. The noise suppression capture effect removes constant background noise, such as fan noise. Use the CaptureNoiseSuppressEffect object to set and retrieve parameters.


Using the Capture Buffer

Once you have created a CaptureBuffer object, you will need to control the process of reading and recording sound data. Capturing a sound consists of these steps.

  1. Start the buffer by calling CaptureBuffer.Start(true), which sets the capture buffer to a looping mode.
  2. Wait until the desired amount of data is available. For one method of determining when the capture cursor reaches a certain point, see Capture Buffer Notification. Alternatively, you can poll the read cursor by using CaptureBuffer.GetCurrentPosition.
  3. When sufficient data is available, read data from the buffer by calling CaptureBuffer.Read.
  4. Repeat steps 2 and 3 until you are ready to stop capturing data. Then call CaptureBuffer.Stop.


Optimizing Performance

This section offers some miscellaneous tips for improving the performance of applications that play their audio data directly into Microsoft DirectSound buffers.

The following topics are covered.

  • Matching Buffer Formats
  • Using Hardware Mixing
  • Dynamic Voice Management
  • Hardware Acceleration on ISA and PCI Cards
  • Minimizing Control Changes
  • CPU Considerations for 3-D Buffers
  • DirectSound Driver Models


Matching Buffer Formats

The Microsoft DirectSound mixer converts the data from each secondary sound buffer into the format of the primary buffer. This conversion is done on the fly as data is mixed into the primary buffer, and costs CPU cycles. You can eliminate this overhead by ensuring that your secondary buffers and primary buffer have the same format. Normally, this means setting the primary buffer format to the format of the WAV files used for data.

Because of the way DirectSound does format conversion, you only need to match the sample rate and number of channels. It does not matter if there is a difference in sample size (8-bit or 16-bit).


Using Hardware Mixing

Most sound cards support some level of hardware mixing if there is a Microsoft DirectSound driver for the card.

The following tips will enable you to make the most of hardware mixing.

  • At run time, use the Device.Caps property to determine what formats are supported by the sound-accelerator hardware, and use only those formats if possible.
  • Create sound buffers first for the sounds you use the most. There is a limit to the number of buffers that can be mixed by hardware.
  • To force a buffer to be created in hardware, set the BufferDescription.LocateInHardware property. If you do this and resources for hardware mixing are not available, buffer creation will fail.
  • Use voice management to enable DirectSound to assign buffers to hardware resources when they are available, and to force termination of less important buffers in order to free hardware resources. See Dynamic Voice Management.


Dynamic Voice Management

A number of options are available for handling multiple voices in hardware or software devices. Many sound cards maintain their own secondary buffers and handle 3-D effects and mixing for them. These hardware buffers, as they are called, usually reside in system memory rather than on the card itself, but because they are mixed by the device, they make far smaller demands on the system processor than do software buffers. It is therefore most efficient to have as many buffers as possible allocated to hardware, especially 3-D buffers.

By default, Microsoft DirectSound allocates buffers to hardware whenever it can. However, it can create only as many hardware buffers as the device can play at one time. The number of hardware buffers is therefore limited by the hardware voices available. DirectSound allocates a hardware voice when a buffer is created and releases it only when the buffer is destroyed; the voice is not free even when the buffer is not playing. If an application creates many buffers, chances are that some of them will end up being in software that is, they will be managed and mixed by the CPU rather than the sound card.

To defer the allocation of resources for hardware mixing and 3-D effects to the moment when the buffer is played, set the DeferLocation property in the BufferDescription object passed to the Buffer(BufferDescription,Device) buffer creation method. When you call SecondaryBuffer.Play or SecondaryBuffer.AcquireResources on the buffer, DirectSound places the buffer in hardware if possible, and in software otherwise.

When calling Play, you can attempt to free a hardware voice for the buffer by passing one of the following BufferPlayFlags, or one of the first two flags in combination with the third. DirectSound then searches for a playing buffer that is suitable for termination as specified by the flags.

Flag | Action
TerminateByTime | Select the buffer that has been playing longer than any other candidate buffers.
TerminateByDistance | Select the 3-D candidate buffer farthest from the listener.
TerminateByPriority | Select the buffer that has the lowest priority of candidate buffers, as set in the call to Play. If this is combined with one of the other two flags, the other flag is used only to resolve ties.

If it finds a suitable buffer, DirectSound stops it and allocates the voice it was using to the newly played buffer. If no buffer is suitable for termination, the newly played buffer is played in software, unless the LocateInHardware flag was specified, in which case the call to Play fails.

For more information on how deferred buffers are dealt with when played, see Buffer.Play.

Note: Do not use the StaticBuffer property in combination with DeferLocation when creating buffers. When StaticBuffer is specified, buffers are placed in on-card memory when this is available, as is the case for some Peripheral Component Interconnect (PCI) cards. If you create such a buffer with the DeferLocation property, the buffer memory is not copied to the sound card until the buffer is played for the first time, which can result in unacceptable delays. For more information, see Hardware Acceleration on ISA and PCI Cards.


Hardware Acceleration on ISA and PCI Cards

In the past few years, sound cards have moved from the Industry Standard Architecture (ISA) bus to the Peripheral Component Interconnect (PCI) bus. This design change has fundamentally altered the way Microsoft DirectSound-accelerated cards handle audio data. In addition, DirectSound has introduced voice management, which enables applications to make more efficient use of limited hardware acceleration resources.

This section discusses some considerations in allocating buffers and using voice management on the two kinds of sound cards. The following topics are discussed.

  • DirectSound Buffers on ISA Cards
  • DirectSound Buffers on PCI Cards
  • Voice Management on ISA and PCI Cards

DirectSound Buffers on ISA Cards

When DirectSound was first introduced, all audio devices operated on the ISA bus. The ISA bus was sufficient to stream 16-bit, 22-kHz stereo data from the CPU to the sound card without unduly affecting overall system performance, but attempting to send more data often placed an undue burden on the bus. This limitation had a strong influence on audio hardware design.

To mix DirectSound buffers, a chip on the sound card has two choices: it can reach across the ISA bus into system memory, or it can have dedicated memory on the card itself. Owing to the ISA bus's limited bandwidth, reading audio data from system memory is not practical. Therefore, ISA-based sound cards that do DirectSound acceleration almost always have dedicated on-card RAM.

When such a sound card is used to accelerate DirectSound, the sound data must first be copied from system memory, across the ISA bus, and into the dedicated memory on the card. This copying can take some time. However, once the data is on the card, there is almost no cost to the system for starting, stopping, and mixing sounds; all that work is handled by the audio processor chip accessing its own dedicated memory.

ISA-based DirectSound accelerators support static buffers on the card, but not streaming buffers, because it is impractical to stream data across the slow ISA bus. DirectSound buffers created with the BufferDescription.StaticBuffer property are located in card memory if it is available. Others are created in system memory.

DirectSound Buffers on PCI Cards

Modern audio cards are designed to connect to the PCI bus. With the movement to this bus comes a large increase in the available bandwidth between the system and the audio card. It is now practical to have the audio chip reach directly into system memory to retrieve audio data for hardware mixing. As a result, it is no longer worthwhile to have on-board memory for buffers.

On PCI cards, static buffers and streaming buffers are effectively the same. The BufferDescription.StaticBuffer property does not affect the location of the buffer, because all buffers are located in system memory.

Note: Most sound cards report in the Device.Caps property that they have static buffers, even though they have no on-card RAM. The streaming and static buffers reported by these cards are often the same buffers.

Voice Management on ISA and PCI Cards

By using the BufferDescription.DeferLocation when creating a buffer, you can defer the allocation of buffers to hardware-mixed or software-mixed memory until the moment when they are played. For information, see Dynamic Voice Management.

The effect of deferred allocation on application performance depends on the type of DirectSound accelerator in the user's system.

Consider the case of a PCI accelerator. When a deferred buffer is played, DirectSound first determines if there is hardware available to play the sound. Assuming that there is, DirectSound then ensures that the hardware has access to the sound data, which remains where it is. Finally, DirectSound tells the hardware to start playing. This process is both efficient and fast.

Note: The DirectSound voice manager allocates hardware mixing resources, not memory. On a PCI card, the buffer occupies the same memory before and after it is allocated, regardless of whether it is allocated to the hardware mixer or the software mixer.

If the user has an ISA-based accelerator, the situation is quite different. In this case, the act of getting audio data to a hardware-mixed buffer is very slow, because the data needs to cross the ISA bus and be loaded into memory on the sound card before it can be mixed. For deferred buffers, this can introduce an unacceptable delay between when the play call is made and when the sound starts. For this reason, using voice management is not recommended on ISA-based DirectSound accelerator cards.

It is easy to prevent your application from using voice management on ISA devices. A buffer will not be assigned to on-card memory unless the BufferDescription.StaticBuffer property is set. Therefore, as long as you do not combine StaticBuffer and DeferLocation, there is no danger that buffers will be assigned to on-card memory at play time.

Using StaticBuffer by itself ensures that the buffer will take advantage of any existing memory on an ISA card, but it has no effect on a PCI card. In the absence of other properties, DirectSound will attempt to place the buffer under hardware control but still in system memory. Using DeferLocation by itself has no effect on an ISA card, since the buffer is always placed in system memory and is not managed by the hardware.

The following table summarizes the effects of the StaticBuffer and DeferLocation properties on buffers created for ISA and PCI devices.

Card | BufferDescription property | Memory | Hardware acceleration
ISA | StaticBuffer | Hardware if available. | Yes, if in hardware memory.
PCI | StaticBuffer | System. | Yes, if hardware voice available; property setting has no effect.
ISA | DeferLocation | Hardware if available, if BufferCaps.StaticBuffer set. | Yes, if in hardware memory, but latency on first play.
PCI | DeferLocation | System. | Yes, if hardware voice available.

To take advantage of acceleration on ISA cards without running into the dangers presented by deferred allocation, first check the capabilities of the device. If the card reports more than zero static buffers and no streaming buffers, it is probably an older ISA card with on-card memory. You can then use the StaticBuffer property, but do not use DeferLocation. If the card reports more than zero streaming buffers, it is probably a newer PCI-based accelerator card. In this case, you'll want to use DeferLocation, and not StaticBuffer, to make maximum use of the hardware voices.


Minimizing Control Changes

Performance is affected when you change the pan, volume, or frequency on a secondary buffer. To prevent interruptions in sound output, the Microsoft DirectSound mixer must mix ahead from 20 to 100 or more milliseconds. Whenever you make a control change, the mixer has to flush its mix-ahead buffer and remix with the changed sound.

It is a good idea to minimize the number of control changes you send. Try reducing the frequency of calls to routines that use SecondaryBuffer.Volume, .Pan, and .Frequency. For example, if you have a routine that moves a sound from the left to the right speaker in synchronization with animation frames, try setting Pan only every second or third frame.

Note: 3-D control changes (orientation, position, velocity, Doppler factor, and so on) also cause DirectSound to remix its mix-ahead buffer. However, you can group a number of 3-D control changes together and cause only a single remix. See 3-D Listeners.


CPU Considerations for 3-D Buffers

Software-emulated 3-D buffers are computationally time consuming. You should take this into consideration when deciding when and how to use 3-D buffers in your applications.

Use as few 3-D sounds as you can, and do not use 3-D on sounds that will not really benefit from the effect. Design your application so that it is easy to enable and disable 3-D effects on each sound. You can set the Buffer3D.Mode property to Mode3D.Disable to disable 3-D processing on any 3-D sound buffer.

You can also ensure that 3-D processing is suspended on buffers that are too far away from the listener to be heard. See Minimum and Maximum Distances.


DirectSound Driver Models

Under the virtual device driver (VxD) model, all Microsoft DirectSound mixing is done in Dsound.vxd, a virtual device driver. Dsound.vxd also provides close access to the actual direct memory access (DMA) buffer that the sound card uses to receive data from the host CPU. This is the same as the DirectSound primary buffer. A DirectSound application can set specific properties of the primary buffer, such as sampling rate and bit depth, thus changing the properties of the hardware itself.

Under the Microsoft Windows Driver Model (WDM), DirectSound does not have direct access to the sound hardware, except in the case of hardware-accelerated buffers. Instead, DirectSound works with the kernel mixer, or Kmixer. The job of Kmixer is to convert the format of multiple audio streams to a common format, mix them together and send the result to the hardware. In a sense, it does what Dsound.vxd does. One major difference is that Dsound.vxd only mixes DirectSound buffer data, but Kmixer mixes all Windows audio data, including data from applications that use the Microsoft Win32waveOut functions. The rule that DirectSound and the waveform-audio output device cannot both be open at the same time is not true on systems with WDM drivers.

Of particular importance is Kmixer's relationship with the audio hardware. Kmixer is the only software on the system that can specify the format of the hardware's DMA buffer. It selects the format on the basis of sounds it is asked to mix. It sets the output format to the highest-quality format of sounds that it is asked to mix, or to the closest format to this that the hardware supports.

This has one very important implication: DirectSound cannot set the format of the hardware's DMA buffer. For your application, this means that the hardware format is based on the data you actually play. If you play a 44-kHz file, Kmixer will mix all data up to 44 kHz and ensure that the hardware is running at 44 kHz.

As an application developer, you do not choose the driver model used. That is completely determined by the type of sound card, the version of Windows, and the particular driver the user has installed. For that reason, it is very important that you cover all possibilities when you test your application. DirectSound might be using Dsound.vxd or it might be using Kmixer, and you should ensure that your application's behavior and performance are acceptable on both.


Audio Video Playback

The AudioVideoPlayback application programming interface (API) provides for basic playback and simple control of audio and video files. For more information, see the Microsoft.DirectX.AudioVideoPlayback managed code reference documentation.

Use the Video class to play video files, including those that contain audio. Use the Audio class to play audio-only files. You can also use the Audio class to control the audio properties when you play a video file. The SeekPositionFlags enumeration controls seek operations, and the StateFlags enumeration has flags to denote whether the media file is running, paused, or stopped.

Note: The Audio class is primarily designed for very simple playback scenarios, or for use with the Video class. You can also use Microsoft DirectSound to play audio files, which gives you much greater control over the audio playback.

  • Playing a Video File
  • Playing an Audio File

Playing a Video File

To play a video file, start by creating an instance of the Video class. You can specify the file name in the Video constructor as in the following C# code example, or else call the Open method with the file name.

[C#]
using Microsoft.DirectX.AudioVideoPlayback;
public class MyVideoPlayer : System.Windows.Forms.Form
{
    /* ... */
    private void OpenFile()
    {
        try
        {
            Video ourVideo = new Video("C:\\Example.avi");
            /* ... */
        }
    }
    /* ... */
}

The Video object throws an exception if you try to open a file that contains no video. Next, specify a parent window in your application to hold the Video object's video window, as follows:

[C#]
ourVideo.Owner = this;  // 'this' refers to the application's Form object.

Control playback by calling the Play, Pause, and Stop methods. For example, the following event handler stops playback.

[C#]
private void mnuStop_Click(object sender, System.EventArgs e)
{
    if (ourVideo != null)
    {
        ourVideo.Stop();
        }
}

To set the size of the playback window, set the Size property, which takes a System.Drawing.Size Leave Site object, as follows:

[C#]
ourVideo.Size = new Size(480, 320);

You can get the native video size by examining the DefaultSize property. If the video file contains audio, the Video.Audio property returns an Audio object. You can use this object to set the volume or the stereo balance for the audio. If the file does not contain audio, setting these properties causes an exception. Use a try block around the code, as follows:

[C#]
try
{
    Video.Audio.Volume = 100;
}

Playing an Audio File

The Audio object is similar to the Video object, but it supports properties that relate to audio, such as Volume and Balance. To play an audio file, specify the file name in the Audio constructor, as in the following C# code example, or call the Open method with the file name.

[C#]
Audio ourAudio = new Audio("C:\MyAudioFile.wav");


Audio and Video Playback Error Codes

Below is a list of possible error codes that can occur in Microsoft.DirectX.AudioVideoPlayback.

Audio Video Playback Error Code Table

ErrorCode | ErrorString | Description
-2147220992 | VFW_E_INVALIDMEDIATYPE | The specified media type is invalid.
-2147220991 | VFW_E_INVALIDSUBTYPE | The specified media subtype is invalid.
-2147220990 | VFW_E_NEED_OWNER | This object can only be created as an aggregated object.
-2147220989 | VFW_E_ENUM_OUT_OF_SYNC | The state of the enumerated object has changed and is now inconsistent with the state of the enumerator. Discard any data obtained from previous calls to the enumerator and then update the enumerator by calling the enumerator's Reset method.
-2147220988 | VFW_E_ALREADY_CONNECTED | At least one of the pins involved in the operation is already connected.
-2147220987 | VFW_E_FILTER_ACTIVE | This operation cannot be performed because the filter is active.
-2147220986 | VFW_E_NO_TYPES | One of the specified pins supports no media types.
-2147220985 | VFW_E_NO_ACCEPTABLE_TYPES | There is no common media type between these pins.
-2147220984 | VFW_E_INVALID_DIRECTION | Two pins of the same direction cannot be connected.
-2147220983 | VFW_E_NOT_CONNECTED | The operation cannot be performed because the pins are not connected.
-2147220982 | VFW_E_NO_ALLOCATOR | No sample buffer allocator is available.
-2147220981 | VFW_E_RUNTIME_ERROR | A run-time error occurred.
-2147220980 | VFW_E_BUFFER_NOTSET | No buffer space has been set.
-2147220979 | VFW_E_BUFFER_OVERFLOW | The buffer is not sufficiently large.
-2147220978 | VFW_E_BADALIGN | An invalid alignment was specified.
-2147220977 | VFW_E_ALREADY_COMMITTED | The allocator was not committed.
-2147220976 | VFW_E_BUFFERS_OUTSTANDING | One or more buffers are still active.
-2147220975 | VFW_E_NOT_COMMITTED | Cannot allocate a sample when the allocator is not active.
-2147220974 | VFW_E_SIZENOTSET | Cannot allocate memory because no size has been set.
-2147220973 | VFW_E_NO_CLOCK | Cannot lock for synchronization because no clock has been defined.
-2147220972 | VFW_E_NO_SINK | Quality messages could not be sent because no quality sink has been defined.
-2147220971 | VFW_E_NO_INTERFACE | A required interface has not been implemented.
-2147220970 | VFW_E_NOT_FOUND | An object or name was not found.
-2147220969 | VFW_E_CANNOT_CONNECT | No combination of intermediate filters could be found to make the connection.
-2147220968 | VFW_E_CANNOT_RENDER | No combination of filters could be found to render the stream.
-2147220967 | VFW_E_CHANGING_FORMAT | Could not change formats dynamically.
-2147220966 | VFW_E_NO_COLOR_KEY_SET | No color key has been set.
-2147220965 | VFW_E_NOT_OVERLAY_CONNECTION | Transport.
-2147220964 | VFW_E_NOT_SAMPLE_CONNECTION | Current pin connection is not using the correct transport.
-2147220963 | VFW_E_PALETTE_SET | Setting a color key would conflict with the palette already set.
-2147220962 | VFW_E_COLOR_KEY_SET | Setting a palette would conflict with the color key already set.
-2147220961 | VFW_E_NO_COLOR_KEY_FOUND | No matching color key is available.
-2147220960 | VFW_E_NO_PALETTE_AVAILABLE | No palette is available.
-2147220959 | VFW_E_NO_DISPLAY_PALETTE | Display does not use a palette.
-2147220958 | VFW_E_TOO_MANY_COLORS | Too many colors for the current display settings.
-2147220957 | VFW_E_STATE_CHANGED | The state changed while waiting to process the sample.
-2147220956 | VFW_E_NOT_STOPPED | The operation could not be performed because the filter is not stopped.
-2147220955 | VFW_E_NOT_PAUSED | The operation could not be performed because the filter is not paused.
-2147220954 | VFW_E_NOT_RUNNING | The operation could not be performed because the filter is not running.
-2147220953 | VFW_E_WRONG_STATE | The operation could not be performed because the filter is in the wrong state.
-2147220952 | VFW_E_START_TIME_AFTER_END | The sample start time is after the sample end time.
-2147220951 | VFW_E_INVALID_RECT | The supplied rectangle is invalid.
-2147220950 | VFW_E_TYPE_NOT_ACCEPTED | This pin cannot use the supplied media type.
-2147220949 | VFW_E_SAMPLE_REJECTED | This sample cannot be rendered.
-2147220948 | VFW_E_SAMPLE_REJECTED_EOS | This sample cannot be rendered because the end of the stream has been reached.
-2147220947 | VFW_E_DUPLICATE_NAME | An attempt to add a filter with a duplicate name failed.
-2147220946 | VFW_E_TIMEOUT | A time-out has expired.
-2147220945 | VFW_E_INVALID_FILE_FORMAT | The file format is invalid.
-2147220944 | VFW_E_ENUM_OUT_OF_RANGE | The list has already been exhausted.
-2147220943 | VFW_E_CIRCULAR_GRAPH | The filter graph is circular.
-2147220942 | VFW_E_NOT_ALLOWED_TO_SAVE | Updates are not allowed in this state.
-2147220941 | VFW_E_TIME_ALREADY_PASSED | An attempt was made to queue a command for a time in the past.
-2147220940 | VFW_E_ALREADY_CANCELLED | The queued command was already canceled.
-2147220939 | VFW_E_CORRUPT_GRAPH_FILE | Cannot render the file because it is corrupt.
-2147220938 | VFW_E_ADVISE_ALREADY_SET | Advise link already exists.
-2147220936 | VFW_E_NO_MODEX_AVAILABLE | No full-screen modes are available.
-2147220935 | VFW_E_NO_ADVISE_SET | This Advise cannot be canceled because it was not successfully set.
-2147220934 | VFW_E_NO_FULLSCREEN | Full-screen mode is not available.
-2147220933 | VFW_E_IN_FULLSCREEN_MODE | Window methods while in full-screen mode.
-2147220928 | VFW_E_UNKNOWN_FILE_TYPE | The media type of this file is not recognized.
-2147220927 | VFW_E_CANNOT_LOAD_SOURCE_FILTER | The source filter for this file could not be loaded.
-2147220925 | VFW_E_FILE_TOO_SHORT | A file appeared to be incomplete.
-2147220924 | VFW_E_INVALID_FILE_VERSION | The file's version number is invalid.
-2147220921 | VFW_E_INVALID_CLSID | This file is corrupt: it contains an invalid class identifier.
-2147220920 | VFW_E_INVALID_MEDIA_TYPE | This file is corrupt: it contains an invalid media type.
-2147220919 | VFW_E_SAMPLE_TIME_NOT_SET | No time stamp has been set for this sample.
-2147220911 | VFW_E_MEDIA_TIME_NOT_SET | No media time was set for this sample.
-2147220910 | VFW_E_NO_TIME_FORMAT_SET | No media time format was selected.
-2147220909 | VFW_E_MONO_AUDIO_HW | Cannot change balance because audio device is monaural only.
-2147220907 | VFW_E_NO_DECOMPRESSOR | Cannot play back the video stream: could not find a suitable decompressor.
-2147220906 | VFW_E_NO_AUDIO_HARDWARE | Cannot play back the audio stream: no audio hardware is available, or the hardware is not supported.
-2147220903 | VFW_E_RPZA | Cannot play back the video stream: format 'RPZA' is not supported.
-2147220901 | VFW_E_PROCESSOR_NOT_SUITABLE | Microsoft DirectShow cannot play MPEG movies on this processor.
-2147220900 | VFW_E_UNSUPPORTED_AUDIO | Cannot play back the audio stream: the audio format is not supported.
-2147220899 | VFW_E_UNSUPPORTED_VIDEO | Cannot play back the video stream: the video format is not supported.
-2147220898 | VFW_E_MPEG_NOT_CONSTRAINED | DirectShow cannot play this video stream because it falls outside the constrained standard.
-2147220897 | VFW_E_NOT_IN_GRAPH | Cannot perform the requested function on an object that is not in the filter graph.
-2147220895 | VFW_E_NO_TIME_FORMAT | Cannot access the time format on an object.
-2147220894 | VFW_E_READ_ONLY | Could not make the connection because the stream is read-only and the filter alters the data.
-2147220892 | VFW_E_BUFFER_UNDERFLOW | The buffer is not full enough.
-2147220891 | VFW_E_UNSUPPORTED_STREAM | Cannot play back the file: the format is not supported.
-2147220890 | VFW_E_NO_TRANSPORT | Pins cannot connect because they don't support the same transport.
-2147220887 | VFW_E_BAD_VIDEOCD | The Video CD can't be read correctly by the device or the data is corrupt.
-2147220880 | VFW_S_NO_STOP_TIME | The sample had a start time but not a stop time. In this case, the stop time that is returned is set to the start time plus one.
-2147220879 | VFW_E_OUT_OF_VIDEO_MEMORY | There is not enough video memory at this display resolution and number of colors. Reducing resolution might help.
-2147220878 | VFW_E_VP_NEGOTIATION_FAILED | The video port connection negotiation process has failed.
-2147220877 | VFW_E_DDRAW_CAPS_NOT_SUITABLE | Either Microsoft DirectDraw has not been installed or the video card capabilities are not suitable. Make sure the display is not in 16-color mode.
-2147220876 | VFW_E_NO_VP_HARDWARE | No video port hardware is available, or the hardware is not responding.
-2147220875 | VFW_E_NO_CAPTURE_HARDWARE | No capture hardware is available, or the hardware is not responding.
-2147220874 | VFW_E_DVD_OPERATION_INHIBITED | This user operation is inhibited by digital video disc (DVD) content at this time.
-2147220873 | VFW_E_DVD_INVALIDDOMAIN | This operation is not permitted in the current domain.
-2147220872 | VFW_E_DVD_NO_BUTTON | Requested button is not available.
-2147220871 | VFW_E_DVD_GRAPHNOTREADY | DVD-Video playback graph has not been built yet.
-2147220870 | VFW_E_DVD_RENDERFAIL | DVD-Video playback graph building failed.
-2147220869 | VFW_E_DVD_DECNOTENOUGH | DVD-Video playback graph could not be built due to insufficient decoders.
-2147220853 | VFW_E_DVD_NOT_IN_KARAOKE_MODE | The DVD Navigator is not in karaoke mode.
-2147220850 | VFW_E_FRAME_STEP_UNSUPPORTED | Frame stepping is not supported.
-2147220845 | VFW_E_PIN_ALREADY_BLOCKED_ON_THIS_THREAD | Pin is already blocked on the calling thread.
-2147220844 | VFW_E_PIN_ALREADY_BLOCKED | Pin is already blocked on another thread.
-2147220843 | VFW_E_CERTIFICATION_FAILURE | Use of this filter is restricted by a software key. The application must unlock the filter.
-2147220842 | VFW_E_VMR_NOT_IN_MIXER_MODE | The Video Mixing Renderer (VMR) is not in mixing mode.
-2147220841 | VFW_E_VMR_NO_AP_SUPPLIED | The application has not yet provided the VMR filter with a valid allocator-presenter object.
-2147220840 | VFW_E_VMR_NO_DEINTERLACE_HW | The VMR could not find any deinterlacing hardware on the current display device.
-2147220839 | VFW_E_VMR_NO_PROCAMP_HW | The VMR could not find any hardware that supports ProcAmp controls on the current display device.
-2147220838 | VFW_E_DVD_VMR9_INCOMPATIBLEDEC | The hardware decoder uses video port extensions (VPE), which are not compatible with the VMR-9 filter.
-2147220494 | VFW_E_BAD_KEY | A registry entry is corrupt.


How Do I ...?

The documents in this section show you how to accomplish commonly encountered development tasks in Microsoft DirectX.

The following tables list tasks available for DirectX feature areas using C# code examples.

Handle a Device (Direct3D)

Check for Shader Support | This example shows how to check the hardware device for shader support.
Create an Additional Swap Chain | This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.
Maintain Floating Point Precision after Device Creation | When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.
Record and Apply StateBlocks | This example demonstrates how to use state blocks to set and retrieve a device's state.

Render a 3-D Scene (Direct3D)

Draw A Sprite | This example demonstrates how to draw a sprite.
Generate a Scene | This example shows how to begin scene generation and draw primitives.
Render Mesh with Texture using HLSL | This example demonstrates how to render a mesh texture using the high-level shader language (HLSL).
Set Up a Projection Matrix | This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.
Set Up a View Matrix | This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.
Using an Effect | This example demonstrates how to use an effect technique that was loaded from a file.

Use Meshes, Textures, and Effects (Direct3D)

Check For HDR Texture Support | This example demonstrates how to check a device to determine whether a specific texture format is supported.
Clean a Mesh | This example shows how to clean a mesh in preparation for simplification.
Clone a Mesh | This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.
Compute a Bounding Sphere from a Mesh | This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method.
Copy a Texture | This example demonstrates how to copy a texture.
Create a Cube Texture | This example demonstrates how to create a cube texture.
Create a Mesh Object | This example shows how to create a Mesh object.
Save a Screenshot | This example demonstrates how to save a screen shot to a file.
Simplify a Mesh | This example demonstrates how to simplify a mesh.

Use Vertex and Index Buffers (Direct3D)

Create a Vertex Declaration | This example demonstrates how to create a vertex declaration.
Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams | This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.
Read and Write VertexBuffer Data With Arrays | This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

Use Effects on Sound (DirectSound)

Add Effects to a SecondaryBuffer Object | This C# example demonstrates how to add effect objects to a SecondaryBuffer object.
Use Effect Parameters | This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.


Check for Shader Support

This example shows how to check the hardware device for shader support.

To determine whether the hardware device supports shaders, Microsoft Direct3D allows the application to check the shader version.

To check for shader support:

  1. Obtain the device's capabilities by using the Manager.GetDeviceCaps method.
  2. Using the capabilities object obtained with the previous call, check the shader version by calling Caps.VertexShaderVersion.

          [C#]

public bool CheckShaderSupport()
{
    Version v1_1 = new Version(1,1); // check version is at least shader 1.1

    // retrieve the device caps
    Caps caps = Manager.GetDeviceCaps(0, DeviceType.Hardware);

    // check the supported shader version
    if ((caps.VertexShaderVersion >= v1_1) && (caps.PixelShaderVersion >= v1_1))
    {
        return true;
    }

    return false;
}


Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

          [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);


Record and Apply StateBlocks

This example demonstrates how to use state blocks to set and retrieve a device's state.

A StateBlock instance can be used to return a device to a default state. It also can be stored as a member of a class to quickly restore a desired rendering state for that class. A StateBlock is most useful when used to save default device state once a device is created. This allows for rapid restoration of default state when needed during rendering.

To record and apply a state block:

  1. Call Device.BeginStateBlock to begin recording device state.
  2. Tell the device the states and values to record.
  3. Call Device.EndStateBlock to stop recording device state and return a StateBlock instance containing the recorded states.
  4. Capture the device's current state by calling StateBlock.Capture using the previously obtained StateBlock instance.
  5. Do some processing that changes device state.
  6. Restore the device's saved states by calling StateBlock.Apply.

In the following C# code example, device is assumed to be the rendering Device.

          [C#]

// begin recording device state
device.BeginStateBlock();

// tell device the states and values to record
device.RenderState.FogStart = 0.3f;
device.RenderState.FogEnd = 100.0f;
device.RenderState.FogColor = Color.Gray;

// stop recording device state
StateBlock sb = device.EndStateBlock();

// save device states recorded above
sb.Capture;

// change device states
device.RenderState.FogStart = 2000.0f;
device.RenderState.FogEnd = 35000.0f;
device.RenderState.FogColor = Color.Yellow;

// render scene w/changed states
device.DrawPrimitives();

// restore device's saved states
sb.Apply();

// render scene w/saved states
device.DrawPrimitives();


Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

          [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();


Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

          [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();


Render Mesh with Texture using HLSL

This example demonstrates how to render a mesh texture using the high-level shader language (HLSL).

In the following C# code example, the following assumptions are made:

  1. effect is a valid HLSL Effect with its technique set.
  2. The code occurs between calls to Effect.BeginPass and Effect.EndPass.
  3. mesh is a valid Mesh.
  4. meshTextures is a valid array of textures for the mesh.

          [C#]

effect.SetValue("WorldViewProjection", worldMatrix);

// Iterate through each subset and render with its texture
for (int m = 0; m < meshTextures.Length; ++m)
{
    effect.SetValue("SceneTexture", meshTextures[m]));
    effect.CommitChanges();
    mesh.DrawSubset(m);
}


Set Up a Projection Matrix

This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.

See the following C# code example, the Projection transformation matrix is set to be equal to the left-handed (LH) PerspectiveFovLH matrix. Input arguments to PerspectiveFovLH are as follows.

  1. Field of view in radians: pi/4.
  2. Aspect ratio, or view-space height divided by width: 1, for a square window.
  3. Near clipping plane distance: 1 unit.
  4. Far clipping plane distance: 100 units.

          [C#]

using Microsoft.DirectX;

Direct3D.Device device = null;  // Create rendering device.

// For the projection matrix, you set up a perspective transform (which
//   transforms geometry from 3-D view space to 2-D viewport space, with
//   a perspective divide making objects smaller in the distance). To build
//   a perspective transform, you need the field of view (1/4 pi is common),
//   the aspect ratio, and the near and far clipping planes (which define
//   the distances at which geometry should no longer be rendered).

device.Transform.Projection = Matrix.PerspectiveFovLH(
                              (float)Math.PI / 4, 1.0f, 1.0f, 100.0f );


Set Up a View Matrix

This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.

In the following C# code example, the vector components of the Vector3 structure form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The View transformation matrix is set to be equal to this look-at matrix.

The three input vectors represent the following, respectively:

  1. The eye point: [0, 3, -5].
  2. The camera look-at target: the origin [0, 0, 0].
  3. The current world's up-direction: usually [0, 1, 0].

          [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;  // Create rendering device.

// Set up the view matrix. A view matrix can be defined given an eye point,
//   a point to view, and a direction for which way is up. Here, you set
//   the eye five units back along the z-axis and up three units, view the
//   origin, and define "up" to be in the y-direction.

device.Transform.View = Microsoft.DirectX.Matrix.LookAtLH(
                            new Vector3(0.0f, 3.0f, -5.0f),
                            new Vector3(0.0f, 0.0f, 0.0f),
                            new Vector3(0.0f, 1.0f, 0.0f));


Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

          [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}


Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

          [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Clean a Mesh

This example shows how to clean a mesh in preparation for simplification.

In the following C# procedure, the Mesh.Clean method cleans the mesh by adding another vertex where two fans of triangles originally shared the same vertex. This vertex splitting results in two new triangles being added to the polygon on either side of the line segment connecting the two new vertices.

          [C#]

GraphicsStream adj = null;

// Load the mesh from the specified file
Mesh pMesh = Mesh.FromFile("tiger.x", MeshFlags.Managed, device, out adj);

// perform simple cleaning operation on the mesh
Mesh pTempMesh = Mesh.Clean(CleanType.Optimization, pMesh, adj, adj);
pMesh.Dispose();
pMesh = pTempMesh;


Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

          [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}


Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

          [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

          [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

          [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

          [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

          [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

          [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

Related Topics

  • Clean a Mesh


Create a Vertex Declaration

This example demonstrates how to create a vertex declaration.

[C#]

As shown in the following C# code example, first declare a VertexElement array to hold the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).

Create a VertexDeclaration instance using the Device and VertexElement array previously created.

Note: The offset parameter of each element is the cumulative offset of the elements from the start of the declaration. For example, the second element is offset 12 bytes, since it is three floats of four bytes each, or (3 * sizeof(float) = 12).

// Create the vertex element array.
VertexElement[] elements = new VertexElement[]
{
    new VertexElement(0, 0, DeclarationType.Float3,
                            DeclarationMethod.Default,
                            DeclarationUsage.Position, 0),

    new VertexElement(0, 12, DeclarationType.Float3,
                             DeclarationMethod.Default,
                             DeclarationUsage.Normal, 0),

    new VertexElement(0, 24, DeclarationType.Float2,
                             DeclarationMethod.Default,
                             DeclarationUsage.TextureCoordinate, 0),

    VertexElement.VertexDeclarationEnd
};

// Use the vertex element array to create a vertex declaration.
VertexDeclaration decl = new VertexDeclaration(device, elements);


Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams

This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The vertex buffer data is then locked using its offset and size in bytes. A GraphicsStream object is returned which is derived from Stream Leave Site and can be used in a similar fashon. In the code example, the Write method is used to copy data into the stream from an array of vertex data.

The second part of the method shows use of GraphicsStream using unsafe data access. The InternalDataPointerGraphicsStream.InternalData property returns a void pointer to the vertex buffer data. In this code example, the data is cast to an array of PositionNormalTexVertex structures which makes data manipulation more readable.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public  float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}
public class Example
{
    public unsafe void  GraphicsStreamReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTexVertex.FVF, Pool.Managed);

        //First, fill an array of PositionNormalTexVertex elements with data.
        PositionNormalTexVertex[] vertices = new PositionNormalTexVertex[50];
        for(int i=0; i<50; i++)
        {
            //fill the vertices with some data...
            vertices[i].Position = new Vector3(3f,4f,5f);
        }

        //The size of the verticies are 32-bytes each (float3 (12) + float3 (12) + float(4) + float(4))
        //To lock 50 verticies, the size of the lock would be 1600 (32 * 50)
        GraphicsStream vbData =  vb.Lock(0,1600, LockFlags.None);

        //copy the vertex data into the vertex buffer
        vbData.Write(vertices);

        //Unlock the VB
        vb.Unlock();

        //This time, lock the entire VertexBuffer
        vbData =  vb.Lock(0, 3200, LockFlags.None);

        //Cast the InternalDataPointer (a void pointer) to an array of verticies
        PositionNormalTexVertex* vbArray = (PositionNormalTexVertex*) vbData.InternalDataPointer;

        for(int i=0; i<100; i++)
        {
            //perform some operations on the data
            vbArray[i].Tu0 = i;
            vbArray[i].Tv0 = vbArray[i].Tu0 * 2;

            Console.WriteLine(vbArray[i].Tv0.ToString());
        }

        //Unlock the buffer
        vb.Unlock();
        vb.Dispose();
    }
}

Related Topics

  • Read and Write VertexBuffer Data With Arrays


Read and Write VertexBuffer Data With Arrays

This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The first part of the code sample shows the use of Lock to lock an arbitrary number of vertices and fill them with data. The second part shows how to lock an entire VertexBuffer for reading and retrieving data from the array. A similar procedure can be used to write to and read from nearly all Microsoft Direct3D resource types.

Using Arrays Leave Site is not the most efficient method for filling and reading from Direct3D resources; it requires extra memory and cycles to copy the unmanaged resources into managed arrays. However, it makes for very readable code with no unsafe access.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}

public class Example
{
    public void ArrayBasedReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTex1Vertex.FVF, Pool.Managed);

        //Fill an array of the appropriate type with the VB data using Lock()
        PositionNormalTexVertex[] vbData = (PositionNormalTexVertex[]) vb.Lock(0, typeof(PositionNormalTexVertex), LockFlags.None, 50);
        for(int i=0; i<50; i++)
        {
            //set your vertices to something...
            vbData[i].Position = new Vector3(2f,2f,2f);
            vbData[i].Normal = new Vector3(1f,0f,0f);
            vbData[i].Tu0 = i;
            vbData[i].Tv0 = i;
        }
        //Unlock the vb before you can use it elsewhere
        vb.Unlock();

        //This lock overload simply locks the entire VB -- setting ReadOnly can improve perf when reading a vertexbuffer
        vbData = (PositionNormalTexVertex[]) vb.Lock(0, LockFlags.ReadOnly);
        for(int i=0; i<100; i++)
        {
            //read some vertex data
            Console.WriteLine("Vertex " + i + "Tu: " +  vbData[i].Tu0 + " , Tv: " + vbData[i].Tv0);
        }

        //Unlock the buffer
        vb.Unlock();

        vb.Dispose();
    }
}

Related Topics

  • Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams


Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

          [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Related Topics

  • Use Effect Parameters


Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

          [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Related Topics

  • Add Effects to a SecondaryBuffer Object


References

The following table lists the namespaces available in Microsoft DirectX.

Microsoft.DirectX | This namespace provides utility operations and data storage for DirectX application programming, including exception handling, simple helper methods, and structures used for matrix, clipping plane, quaternion, and vector manipulation.
Microsoft.DirectX.AudioVideoPlayback | The AudioVideoPlayback application programming interface (API) provides for basic playback and simple control of audio and video files.
Microsoft.DirectX.Diagnostics | The DirectX Diagnostics application programming interface (API) enables you to programmatically query the information gathered by the DirectX Diagnostics Tool (DxDiag).
Microsoft.DirectX.Direct3D | Microsoft Direct3D is a low-level graphics API that enables you to manipulate visual models of 3-D objects and take advantage of hardware acceleration.
Microsoft.DirectX.DirectDraw
Warning: Microsoft DirectDraw has been deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw enables you to directly manipulate display memory, the hardware blitter, hardware overlay support, and flipping surface support.
Microsoft.DirectX.DirectInput | Microsoft DirectInput is used to process data from a keyboard, mouse, joystick, or other game controller.
Microsoft.DirectX.DirectPlay
Warning: DirectPlay has been deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay enables you to write network applications such as multiplayer games.
Microsoft.DirectX.DirectPlay.Lobby
Warning: Microsoft DirectPlay Lobby has been deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay Lobby enables a DirectX application to interact with an application hosted on a remote server.
Microsoft.DirectX.DirectPlay.Voice
Warning: DirectPlay Voice has been deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay Voice provides media-independent network transport and client management, but it does not duplicate DirectPlay session control features.
Microsoft.DirectX.DirectSound | Microsoft DirectSound provides a system to capture sounds from input devices and play sounds through various playback devices using advanced 3-D positioning effects, and filters for echo, distortion, reverberation, and other effects.
Microsoft.DirectX.PrivateImplementationDetails | The PrivateImplementationDetails namespace contains structures and interfaces that allow the managed API to have access to the unmanaged portions of the DirectX API. These structures and interfaces are not intended to be used directly from your code.
Microsoft.DirectX.Security | Controls permissions related to Direct3D, DirectInput, DirectPlay, and DirectSound.
Microsoft.DirectX.Security.Permissions | Allows security actions to be applied to code using declarative security.


Microsoft.DirectX.AudioVideoPlayback

The AudioVideoPlayback application programming interface (API) provides for basic playback and simple control of audio and video files. The following tables list the members exposed by the Microsoft.DirectX.AudioVideoPlayback namespace.

Classes

Audio | The Audio class is primarily designed for very simple playback scenarios, or for use with the Video class.
TextureRenderEventArgs | Contains properties for retrieving arguments from a called Video.TextureReadyToRender event.
Video | Contains the properties and methods to play video files, including those that contain audio.

Enumerations

SeekPositionFlags | Contains constants for specifiying the type of seek for the Audio or Video objects.
StateFlags | Contains constants for specifiying the state of the Audio or Video objects.

Structures

SeekingCaps Collection of properties that describe the capabilities of a media stream.

Delegates

TextureRenderEventHandler Represents the method that handles the Video.TextureReadyToRender event.


Audio Class (Microsoft.DirectX.AudioVideoPlayback)

Audio Class

The Audio class is primarily designed for very simple playback scenarios, or for use with the Video class.

Definition

Visual Basic NotInheritable Public Class Audio
Inherits Object
Implements IDisposable
C# | public sealed class Audio : Object, IDisposable
C++ | public ref class Audio sealed : Object, IDisposable
JScript | public final class Audio extends Object implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.
Ending | Occurs when the playback is ending.
Pausing | Occurs when the playback is pausing.
Starting | Occurs when the playback is starting.
Stopping | Occurs when the playback is stopping.

Methods

Method | Description
Audio | Initializes a new instance of the object and opens an audio file for playback.
Dispose | Immediately releases the unmanaged resources used by an object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FromFile | Creates an Audio object from a file.
static (Shared in Visual Basic) FromUrl | Creates an Audio object from a Uri Leave Site object.
Open | Loads a new file into the Audio object.
Pause | Pauses playback.
Play | Starts playback.
raise_Disposing | Raises the Audio.Disposing event when called from within a derived class.
raise_Ending | Raises the Audio.Ending event when called from within a derived class.
raise_Pausing | Raises the Audio.Pausing event when called from within a derived class.
raise_Starting | Raises the Audio.Starting event when called from within a derived class.
raise_Stopping | Raises the Audio.Stopping event when called from within a derived class.
SeekCurrentPosition | Seeks to a specific playback position.
SeekStopPosition | Sets a new stop position in playback.
Stop | Stops playback.
StopWhenReady | Stops playback when the Audio object is ready.

Properties

Property | Description
Balance | Retrieves and sets the playback position in the stereo field.
CurrentPosition | Retrieves and sets the current position of playback.
Disposed | Retrieves a value that is true if the object is disposed; otherwise the value is false.
Duration | Retrieves the length, in seconds, of the audio file.
Paused | Retrieves the current playback state, whether playback is currently paused.
Playing | Retrieves the current playback state, whether playback is currently playing.
SeekingCaps | Retrieves the seeking capabilities of playback.
State | Retrieves the current state of playback.
Stopped | Retrieves the current playback state, whether playback is currently stopped.
StopPosition | Retrieves the position where playback stopped.
Volume | Retrieves and sets the amount to attenuate the volume of audio playback.

Inheritance Hierarchy

Object Leave Site
Audio

Class Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Audio.Audio Constructor ()

Initializes a new instance of the object and opens an audio file for playback.

Overload List

public Audio(string);
public Audio(string, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Audio(String) Constructor (Microsoft.DirectX.AudioVideoPlayback)

Audio.Audio Constructor

Initializes a new instance of the object and opens an audio file for playback, but does not start playback.

Definition

Visual Basic Public Sub New( _
ByVal fileName As String _
)
C# public Audio(
string fileName
);
C++ public:
Audio(
String^ fileName
);
JScript public function Audio(
fileName : String
);

Parameters

fileName System.String
Specifies the name of the file.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Audio(String,Boolean) Constructor (Microsoft.DirectX.AudioVideoPlayback)

Audio.Audio Constructor

Initializes a new instance of the object and opens an audio file for playback, and optionally starts playback.

Definition

Visual Basic Public Sub New( _
ByVal fileName As String, _
ByVal autoRun As Boolean _
)
C# public Audio(
string fileName,
bool autoRun
);
C++ public:
Audio(
String^ fileName,
bool autoRun
);
JScript public function Audio(
fileName : String,
autoRun : boolean
);

Parameters

fileName System.String
Specifies the name of the file.
autoRun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Dispose() Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Dispose Method

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Audio();
JScript | public override function Dispose();

See Also

  • Audio.Disposed
  • Audio.Disposing


Audio.Finalize() Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Audio();
C++ | !Audio();
JScript | protected override function Finalize();


Audio.FromFile Method ()

Creates an Audio object from a file.

Overload List

public static Audio FromFile(string);
public static Audio FromFile(string, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromFile(String) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.FromFile Method

Creates an Audio object from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String _
) As Audio
C# public static Audio FromFile(
string filename
);
C++ public:
static Audio^ FromFile(
String^ filename
);
JScript public static function FromFile(
filename : String
) : Audio;

Parameters

filename System.String
The path to the audio file.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Audio
Returns the Audio object from filename.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromFile(String,Boolean) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.FromFile Method

Creates an Audio object from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal autorun As Boolean _
) As Audio
C# public static Audio FromFile(
string filename,
bool autorun
);
C++ public:
static Audio^ FromFile(
String^ filename,
bool autorun
);
JScript public static function FromFile(
filename : String,
autorun : boolean
) : Audio;

Parameters

filename System.String
The path to the audio file.
autorun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Audio
Returns the Audio object from filename.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromUrl Method ()

Creates an Audio object from a Uri Leave Site object.

Overload List

public static Audio FromUrl(Uri);
public static Audio FromUrl(Uri, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromUrl(Uri) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.FromUrl Method

Creates an Audio object from a Uri Leave Site object.

Definition

Visual Basic Public Shared Function FromUrl( _
ByVal address As Uri _
) As Audio
C# public static Audio FromUrl(
Uri address
);
C++ public:
static Audio^ FromUrl(
Uri^ address
);
JScript public static function FromUrl(
address : Uri
) : Audio;

Parameters

address System.Uri
A Uri Leave Site that points to an audio file to create the Audio object.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Audio
Returns the Audio object from address.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.FromUrl(Uri,Boolean) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.FromUrl Method

Creates an Audio object from a Uri Leave Site object.

Definition

Visual Basic Public Shared Function FromUrl( _
ByVal address As Uri, _
ByVal autorun As Boolean _
) As Audio
C# public static Audio FromUrl(
Uri address,
bool autorun
);
C++ public:
static Audio^ FromUrl(
Uri^ address,
bool autorun
);
JScript public static function FromUrl(
address : Uri,
autorun : boolean
) : Audio;

Parameters

address System.Uri
A Uri Leave Site that points to an audio file to create the Audio object.
autorun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Audio
Returns the Audio object from address.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open Method ()

Loads a new file into the Audio object.

Overload List

public void Open(string);
public void Open(string, bool);
public void Open(Uri);
public void Open(Uri, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open(Uri) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Open Method

Loads a new file into the Audio object.

Definition

Visual Basic Public Sub Open( _
ByVal address As Uri _
)
C# public void Open(
Uri address
);
C++ public:
void Open(
Uri^ address
);
JScript public function Open(
address : Uri
);

Parameters

address System.Uri
The Uri Leave Site to open a file from.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open(Uri,Boolean) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Open Method

Loads a new file into the Audio object.

Definition

Visual Basic Public Sub Open( _
ByVal address As Uri, _
ByVal autoRun As Boolean _
)
C# public void Open(
Uri address,
bool autoRun
);
C++ public:
void Open(
Uri^ address,
bool autoRun
);
JScript public function Open(
address : Uri,
autoRun : boolean
);

Parameters

address System.Uri
The Uri Leave Site to open a file from.
autoRun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open(String) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Open Method

Loads a new file into the Audio object.

Definition

Visual Basic Public Sub Open( _
ByVal fileName As String _
)
C# public void Open(
string fileName
);
C++ public:
void Open(
String^ fileName
);
JScript public function Open(
fileName : String
);

Parameters

fileName System.String
The path to the audio file.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Open(String,Boolean) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Open Method

Loads a new file into the Audio object.

Definition

Visual Basic Public Sub Open( _
ByVal fileName As String, _
ByVal autoRun As Boolean _
)
C# public void Open(
string fileName,
bool autoRun
);
C++ public:
void Open(
String^ fileName,
bool autoRun
);
JScript public function Open(
fileName : String,
autoRun : boolean
);

Parameters

fileName System.String
The path to the audio file.
autoRun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Pause() Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Pause Method

Pauses playback.

Definition

Visual Basic | Public Sub Pause()
C# | public void Pause();
C++ public:
void Pause();
JScript | public function Pause();

Remarks

When playback is paused, playback will be stopped. When playback resumes, it will continue from the same position where playback was paused.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Play() Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Play Method

Starts playback.

Definition

Visual Basic | Public Sub Play()
C# | public void Play();
C++ public:
void Play();
JScript | public function Play();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.raise_Disposing Method

Raises the Audio.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Audio.raise_Ending(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.raise_Ending Method

Raises the Audio.Ending event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Ending( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Ending(
object i1,
EventArgs i2
);
C++ protected:
void raise_Ending(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Ending(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Audio.raise_Pausing(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.raise_Pausing Method

Raises the Audio.Pausing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Pausing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Pausing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Pausing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Pausing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Audio.raise_Starting(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.raise_Starting Method

Raises the Audio.Starting event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Starting( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Starting(
object i1,
EventArgs i2
);
C++ protected:
void raise_Starting(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Starting(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Audio.raise_Stopping(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.raise_Stopping Method

Raises the Audio.Stopping event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Stopping( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Stopping(
object i1,
EventArgs i2
);
C++ protected:
void raise_Stopping(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Stopping(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Audio.SeekCurrentPosition(Double,SeekPositionFlags) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.SeekCurrentPosition Method

Seeks to a specific playback position.

Definition

Visual Basic Public Function SeekCurrentPosition( _
ByVal time As Double, _
ByVal flags As SeekPositionFlags _
) As Double
C# public double SeekCurrentPosition(
double time,
SeekPositionFlags flags
);
C++ public:
double SeekCurrentPosition(
double time,
SeekPositionFlags flags
);
JScript public function SeekCurrentPosition(
time : double,
flags : SeekPositionFlags
) : double;

Parameters

time System.Double
Position to seek.
flags Microsoft.DirectX.AudioVideoPlayback.SeekPositionFlags
The position seek type to use.

Return Value

System.Double
Returns the position after the seek.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.SeekStopPosition(Double,SeekPositionFlags) Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.SeekStopPosition Method

Sets a new stop position in playback.

Definition

Visual Basic Public Function SeekStopPosition( _
ByVal time As Double, _
ByVal flags As SeekPositionFlags _
) As Double
C# public double SeekStopPosition(
double time,
SeekPositionFlags flags
);
C++ public:
double SeekStopPosition(
double time,
SeekPositionFlags flags
);
JScript public function SeekStopPosition(
time : double,
flags : SeekPositionFlags
) : double;

Parameters

time System.Double
Position that is the new stop time for playback.
flags Microsoft.DirectX.AudioVideoPlayback.SeekPositionFlags
The position seek type to use to set the new stop position.

Return Value

System.Double
Returns the new stop position.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Stop() Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.Stop Method

Stops playback.

Definition

Visual Basic | Public Sub Stop()
C# | public void Stop();
C++ public:
void Stop();
JScript | public function Stop();

Remarks

Stopping playback will cause the position to be reset to the beginning.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.StopWhenReady() Method (Microsoft.DirectX.AudioVideoPlayback)

Audio.StopWhenReady Method

Stops playback when the Audio object is ready.

Definition

Visual Basic | Public Sub StopWhenReady()
C# | public void StopWhenReady();
C++ public:
void StopWhenReady();
JScript | public function StopWhenReady();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Balance Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.Balance Property

Retrieves and sets the playback position in the stereo field.

Definition

Visual Basic | Public Property Balance As Integer
C# | public int Balance { get; set; }
C++ public:
property int Balance {
int get();
void set(int value);
}
JScript public function get Balance() : int
public function set Balance(int);

Property Value

System.Int32
The playback position in the stereo field.

This property is read/write.

Remarks

When this property is set to -10000, playback in the left channel is at normal volume and the right channel is effectively silent.

When this property is set to 10000, playback in the right channel is at normal volume and the left channel is effectively silent.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.CurrentPosition Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.CurrentPosition Property

Retrieves and sets the current position of playback.

Definition

Visual Basic | Public Property CurrentPosition As Double
C# | public double CurrentPosition { get; set; }
C++ public:
property double CurrentPosition {
double get();
void set(double value);
}
JScript public function get CurrentPosition() : double
public function set CurrentPosition(double);

Property Value

System.Double
The current position of playback.

This property is read/write.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Disposed Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.Disposed Property

Retrieves a value that is true if the object is disposed; otherwise the value is false.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Audio.Duration Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.Duration Property

Retrieves the length, in seconds, of the audio file.

Definition

Visual Basic | Public ReadOnly Property Duration As Double
C# | public double Duration { get; }
C++ public:
property double Duration {
double get();
}
JScript | public function get Duration() : double

Property Value

System.Double
The length, in seconds, of the audio file.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Paused Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.Paused Property

Retrieves the current playback state, whether playback is currently paused.

Definition

Visual Basic | Public ReadOnly Property Paused As Boolean
C# | public bool Paused { get; }
C++ public:
property bool Paused {
bool get();
}
JScript | public function get Paused() : boolean

Property Value

System.Boolean
A value that is set to true, if the playback is currently paused; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Playing Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.Playing Property

Retrieves the current playback state, whether playback is currently playing.

Definition

Visual Basic | Public ReadOnly Property Playing As Boolean
C# | public bool Playing { get; }
C++ public:
property bool Playing {
bool get();
}
JScript | public function get Playing() : boolean

Property Value

System.Boolean
A value that is set to true, if the playback is currently playing; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.SeekingCaps Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.SeekingCaps Property

Retrieves the seeking capabilities of playback.

Definition

Visual Basic | Public ReadOnly Property SeekingCaps As SeekingCaps
C# | public SeekingCaps SeekingCaps { get; }
C++ public:
property SeekingCaps SeekingCaps {
SeekingCaps get();
}
JScript | public function get SeekingCaps() : SeekingCaps

Property Value

Microsoft.DirectX.AudioVideoPlayback.SeekingCaps
The seeking capabilities of playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.State Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.State Property

Retrieves the current state of playback.

Definition

Visual Basic | Public ReadOnly Property State As StateFlags
C# | public StateFlags State { get; }
C++ public:
property StateFlags State {
StateFlags get();
}
JScript | public function get State() : StateFlags

Property Value

Microsoft.DirectX.AudioVideoPlayback.StateFlags
The current state of playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Stopped Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.Stopped Property

Retrieves the current playback state, whether playback is currently stopped.

Definition

Visual Basic | Public ReadOnly Property Stopped As Boolean
C# | public bool Stopped { get; }
C++ public:
property bool Stopped {
bool get();
}
JScript | public function get Stopped() : boolean

Property Value

System.Boolean
A value that is set to true, if the playback is stopped; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.StopPosition Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.StopPosition Property

Retrieves the position where playback stopped.

Definition

Visual Basic | Public ReadOnly Property StopPosition As Double
C# | public double StopPosition { get; }
C++ public:
property double StopPosition {
double get();
}
JScript | public function get StopPosition() : double

Property Value

System.Double
The position where playback stopped.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Volume Property (Microsoft.DirectX.AudioVideoPlayback)

Audio.Volume Property

Retrieves and sets the amount to attenuate the volume of audio playback.

Definition

Visual Basic | Public Property Volume As Integer
C# | public int Volume { get; set; }
C++ public:
property int Volume {
int get();
void set(int value);
}
JScript public function get Volume() : int
public function set Volume(int);

Property Value

System.Int32
The amount to attenuate the audio playback volume.

This property is read/write.

Remarks

When this property is set to 0, playback will be at maximum volume.

When this property is set to -10000, playback will be effectively silent.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Audio.Disposing Event (Microsoft.DirectX.AudioVideoPlayback)

Audio.Disposing Event

Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Audio.Disposing event, use the following code.

audio.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Audio.Ending Event (Microsoft.DirectX.AudioVideoPlayback)

Audio.Ending Event

Occurs when the playback is ending.

Definition

Visual Basic | Public Event Ending As EventHandler
C# | public event EventHandler Ending;
C++ public:
event EventHandler^ Ending;
JScript | In JScript, you can use events, but you cannot define your own.


Audio.Pausing Event (Microsoft.DirectX.AudioVideoPlayback)

Audio.Pausing Event

Occurs when the playback is pausing.

Definition

Visual Basic | Public Event Pausing As EventHandler
C# | public event EventHandler Pausing;
C++ public:
event EventHandler^ Pausing;
JScript | In JScript, you can use events, but you cannot define your own.


Audio.Starting Event (Microsoft.DirectX.AudioVideoPlayback)

Audio.Starting Event

Occurs when the playback is starting.

Definition

Visual Basic | Public Event Starting As EventHandler
C# | public event EventHandler Starting;
C++ public:
event EventHandler^ Starting;
JScript | In JScript, you can use events, but you cannot define your own.


Audio.Stopping Event (Microsoft.DirectX.AudioVideoPlayback)

Audio.Stopping Event

Occurs when the playback is stopping.

Definition

Visual Basic | Public Event Stopping As EventHandler
C# | public event EventHandler Stopping;
C++ public:
event EventHandler^ Stopping;
JScript | In JScript, you can use events, but you cannot define your own.


TextureRenderEventArgs Class (Microsoft.DirectX.AudioVideoPlayback)

TextureRenderEventArgs Class

Contains properties for retrieving arguments from a called Video.TextureReadyToRender event.

Definition

Visual Basic NotInheritable Public Class TextureRenderEventArgs
Inherits EventArgs
C# | public sealed class TextureRenderEventArgs : EventArgs
C++ | public ref class TextureRenderEventArgs sealed : EventArgs
JScript | public final class TextureRenderEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property | Description
Texture | Retrieves a Direct3D.Texture from the Video object when the Video.TextureReadyToRender event is triggered.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
TextureRenderEventArgs

Class Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureRenderEventArgs.Texture Property (Microsoft.DirectX.AudioVideoPlayback)

TextureRenderEventArgs.Texture Property

Retrieves a Direct3D.Texture from the Video object when the Video.TextureReadyToRender event is triggered.

Definition

Visual Basic | Public ReadOnly Property Texture As Texture
C# | public Texture Texture { get; }
C++ public:
property Texture^ Texture {
Texture^ get();
}
JScript | public function get Texture() : Texture

Property Value

Microsoft.DirectX.Direct3D.Texture
A Direct3D.Texture from the Video object when the Video.TextureReadyToRender event is triggered.

This property is read-only.

Remarks

The Direct3D.Texture object is the current frame of video that can be used as a texture in Microsoft Direct3D.


Video Class (Microsoft.DirectX.AudioVideoPlayback)

Video Class

Contains the properties and methods to play video files, including those that contain audio.

Definition

Visual Basic NotInheritable Public Class Video
Inherits Object
Implements IDisposable
C# | public sealed class Video : Object, IDisposable
C++ | public ref class Video sealed : Object, IDisposable
JScript | public final class Video extends Object implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.
Ending | Occurs when the playback is ending.
Pausing | Occurs when the playback is pausing.
Starting | Occurs when the playback is starting.
Stopping | Occurs when the playback is stopping.
TextureReadyToRender | Occurs when target texture is ready to render video playback.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by an object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FromFile | Creates a Video object from a file.
static (Shared in Visual Basic) FromUrl | Creates a Video object from a Uri Leave Site object.
HideCursor | Hides the cursor while playing video.
Open | Loads a new file into the Video object.
Pause | Pauses playback.
Play | Starts playback.
raise_Disposing | Raises the Video.Disposing event when called from within a derived class.
raise_Ending | Raises the Video.Ending event when called from within a derived class.
raise_Pausing | Raises the Video.Pausing event when called from within a derived class.
raise_Starting | Raises the Video.Starting event when called from within a derived class.
raise_Stopping | Raises the Video.Stopping event when called from within a derived class.
raise_TextureReadyToRender | Raises the Video.TextureReadyToRender event when called from within a derived class.
RenderToTexture | Enables the Video to trigger the TextureReadyToRender event to generate Texture objects for rendering video in Microsoft Direct3D.
SeekCurrentPosition | Seeks to a specific playback postion.
SeekStopPosition | Sets a new stop postion in playback.
ShowCursor | Shows the cursor while playing video.
Stop | Stops playback.
StopWhenReady | Stops playback when the Video object is ready.
Video | Initializes a new instance of the object.

Properties

Property | Description
Audio | Retrieves the Audio object the video is using for audio playback.
AverageTimePerFrame | Retrieves the average time per frame during playback.
Caption | Retrieves and sets the caption of the Form Leave Site playing the video.
CurrentPosition | Retrieves and sets the current position of playback.
DefaultSize | Retrieves the default size of the video for playback.
Disposed | Retrieves a value that is true if the object is disposed; otherwise the value is false.
Duration | Retrieves the length, in seconds, of the video file.
Fullscreen | Retrieves and sets whether the video plays back in fullscreen mode.
IsCursorHidden | Retrieves whether the cursor is hidden for the video.
MaximumIdealSize | Retrieves the maximum ideal size of the video for playback.
MinimumIdealSize | Retrieves the minimum ideal size of the video for playback.
Owner | Retrieves or sets the Control Leave Site where the video will be played.
Paused | Retrieves whether playback is currently paused.
Playing | Retrieves whether playback is currently playing.
SeekingCaps | Retrieves the seeking capabilities of playback.
Size | Retrieves and sets the size of the video for playback.
State | Retrieves the current state of playback.
Stopped | Retrieves whether playback is currently stopped.
StopPosition | Retrieves the position where playback stopped.

Inheritance Hierarchy

Object Leave Site
Video

Class Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Video.Dispose() Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Dispose Method

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Video();
JScript | public override function Dispose();

See Also

  • Video.Disposed
  • Video.Disposing


Video.Finalize() Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Video();
C++ | !Video();
JScript | protected override function Finalize();


Video.FromFile Method ()

Creates a Video object from a file.

Overload List

public static Video FromFile(string);
public static Video FromFile(string, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromFile(String) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.FromFile Method

Creates a Video object from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String _
) As Video
C# public static Video FromFile(
string filename
);
C++ public:
static Video^ FromFile(
String^ filename
);
JScript public static function FromFile(
filename : String
) : Video;

Parameters

filename System.String
The path to the video file.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Video
The Video object created from the file indicated by the filename parameter.

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromFile(String,Boolean) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.FromFile Method

Creates a Video object from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal autorun As Boolean _
) As Video
C# public static Video FromFile(
string filename,
bool autorun
);
C++ public:
static Video^ FromFile(
String^ filename,
bool autorun
);
JScript public static function FromFile(
filename : String,
autorun : boolean
) : Video;

Parameters

filename System.String
The path to the video file.
autorun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Video
The Video object created from the file indicated by the filename parameter.

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromUrl Method ()

Creates a Video object from a Uri Leave Site object.

Overload List

public static Video FromUrl(Uri);
public static Video FromUrl(Uri, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromUrl(Uri) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.FromUrl Method

Creates a Video object from a Uri Leave Site object.

Definition

Visual Basic Public Shared Function FromUrl( _
ByVal address As Uri _
) As Video
C# public static Video FromUrl(
Uri address
);
C++ public:
static Video^ FromUrl(
Uri^ address
);
JScript public static function FromUrl(
address : Uri
) : Video;

Parameters

address System.Uri
A Uri Leave Site that points to a video file to create the Audio object.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Video
The Video object created from the Uri Leave Site indicated by the address parameter.

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.FromUrl(Uri,Boolean) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.FromUrl Method

Creates a Video object from a Uri Leave Site object.

Definition

Visual Basic Public Shared Function FromUrl( _
ByVal address As Uri, _
ByVal autorun As Boolean _
) As Video
C# public static Video FromUrl(
Uri address,
bool autorun
);
C++ public:
static Video^ FromUrl(
Uri^ address,
bool autorun
);
JScript public static function FromUrl(
address : Uri,
autorun : boolean
) : Video;

Parameters

address System.Uri
A Uri Leave Site that points to a video file to create the Audio object.
autorun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Return Value

Microsoft.DirectX.AudioVideoPlayback.Video
The Video object created from the Uri Leave Site indicated by the address parameter.

Remarks

Exceptions
DirectXException For more information on the cause of this exception reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.HideCursor() Method (Microsoft.DirectX.AudioVideoPlayback)

Video.HideCursor Method

Hides the cursor while playing video.

Definition

Visual Basic | Public Sub HideCursor()
C# | public void HideCursor();
C++ public:
void HideCursor();
JScript | public function HideCursor();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open Method ()

Loads a new file into the Video object.

Overload List

public void Open(string);
public void Open(string, bool);
public void Open(Uri);
public void Open(Uri, bool);

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open(Uri) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Open Method

Loads a new file into the Video object.

Definition

Visual Basic Public Sub Open( _
ByVal address As Uri _
)
C# public void Open(
Uri address
);
C++ public:
void Open(
Uri^ address
);
JScript public function Open(
address : Uri
);

Parameters

address System.Uri
The Uri Leave Site to open a file from.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open(Uri,Boolean) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Open Method

Loads a new file into the Video object.

Definition

Visual Basic Public Sub Open( _
ByVal address As Uri, _
ByVal autoRun As Boolean _
)
C# public void Open(
Uri address,
bool autoRun
);
C++ public:
void Open(
Uri^ address,
bool autoRun
);
JScript public function Open(
address : Uri,
autoRun : boolean
);

Parameters

address System.Uri
The Uri Leave Site to open a file from.
autoRun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open(String) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Open Method

Loads a new file into the Video object.

Definition

Visual Basic Public Sub Open( _
ByVal fileName As String _
)
C# public void Open(
string fileName
);
C++ public:
void Open(
String^ fileName
);
JScript public function Open(
fileName : String
);

Parameters

fileName System.String
The path to the video file.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Open(String,Boolean) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Open Method

Loads a new file into the Video object.

Definition

Visual Basic Public Sub Open( _
ByVal fileName As String, _
ByVal autoRun As Boolean _
)
C# public void Open(
string fileName,
bool autoRun
);
C++ public:
void Open(
String^ fileName,
bool autoRun
);
JScript public function Open(
fileName : String,
autoRun : boolean
);

Parameters

fileName System.String
The path to the video file.
autoRun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Pause() Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Pause Method

Pauses playback.

Definition

Visual Basic | Public Sub Pause()
C# | public void Pause();
C++ public:
void Pause();
JScript | public function Pause();

Remarks

Pausing playback will maintain the playback position when playback is resumed.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Play() Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Play Method

Starts playback.

Definition

Visual Basic | Public Sub Play()
C# | public void Play();
C++ public:
void Play();
JScript | public function Play();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.raise_Disposing Method

Raises the Video.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Video.raise_Ending(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.raise_Ending Method

Raises the Video.Ending event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Ending( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Ending(
object i1,
EventArgs i2
);
C++ protected:
void raise_Ending(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Ending(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Video.raise_Pausing(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.raise_Pausing Method

Raises the Video.Pausing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Pausing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Pausing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Pausing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Pausing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Video.raise_Starting(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.raise_Starting Method

Raises the Video.Starting event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Starting( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Starting(
object i1,
EventArgs i2
);
C++ protected:
void raise_Starting(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Starting(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Video.raise_Stopping(Object,EventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.raise_Stopping Method

Raises the Video.Stopping event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Stopping( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Stopping(
object i1,
EventArgs i2
);
C++ protected:
void raise_Stopping(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Stopping(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Video.raise_TextureReadyToRender(Object,TextureRenderEventArgs) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.raise_TextureReadyToRender Method

Raises the Video.TextureReadyToRender event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_TextureReadyToRender( _
ByVal i1 As Object, _
ByVal i2 As TextureRenderEventArgs _
)
C# protected void raise_TextureReadyToRender(
object i1,
TextureRenderEventArgs i2
);
C++ protected:
void raise_TextureReadyToRender(
Object^ i1,
TextureRenderEventArgs^ i2
);
JScript protected function raise_TextureReadyToRender(
i1 : Object,
i2 : TextureRenderEventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 Microsoft.DirectX.AudioVideoPlayback.TextureRenderEventArgs
Arguments to pass to the event handler.


Video.RenderToTexture(Device) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.RenderToTexture Method

Enables the Video to trigger the TextureReadyToRender event to generate Texture objects for rendering video in Microsoft Direct3D.

Definition

Visual Basic Public Sub RenderToTexture( _
ByVal graphicsDevice As Device _
)
C# public void RenderToTexture(
Device graphicsDevice
);
C++ public:
void RenderToTexture(
Device^ graphicsDevice
);
JScript public function RenderToTexture(
graphicsDevice : Device
);

Parameters

graphicsDevice Microsoft.DirectX.Direct3D.Device
The parent Direct3D.Device that renders the video textures.

Remarks

When rendering a video in Direct3D using this method, be sure to hook the TextureReadyToRender event to retrieve the Texture objects.


Video.SeekCurrentPosition(Double,SeekPositionFlags) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.SeekCurrentPosition Method

Seeks to a specific playback postion.

Definition

Visual Basic Public Function SeekCurrentPosition( _
ByVal time As Double, _
ByVal flags As SeekPositionFlags _
) As Double
C# public double SeekCurrentPosition(
double time,
SeekPositionFlags flags
);
C++ public:
double SeekCurrentPosition(
double time,
SeekPositionFlags flags
);
JScript public function SeekCurrentPosition(
time : double,
flags : SeekPositionFlags
) : double;

Parameters

time System.Double
Position to seek.
flags Microsoft.DirectX.AudioVideoPlayback.SeekPositionFlags
The position seek type to use.

Return Value

System.Double
Returns the position after the seek.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.SeekStopPosition(Double,SeekPositionFlags) Method (Microsoft.DirectX.AudioVideoPlayback)

Video.SeekStopPosition Method

Sets a new stop postion in playback.

Definition

Visual Basic Public Function SeekStopPosition( _
ByVal time As Double, _
ByVal flags As SeekPositionFlags _
) As Double
C# public double SeekStopPosition(
double time,
SeekPositionFlags flags
);
C++ public:
double SeekStopPosition(
double time,
SeekPositionFlags flags
);
JScript public function SeekStopPosition(
time : double,
flags : SeekPositionFlags
) : double;

Parameters

time System.Double
Position that is the new stop time for playback.
flags Microsoft.DirectX.AudioVideoPlayback.SeekPositionFlags
The position seek type to use to set the new stop position.

Return Value

System.Double
Returns the new stop position.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.ShowCursor() Method (Microsoft.DirectX.AudioVideoPlayback)

Video.ShowCursor Method

Shows the cursor while playing video.

Definition

Visual Basic | Public Sub ShowCursor()
C# | public void ShowCursor();
C++ public:
void ShowCursor();
JScript | public function ShowCursor();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Stop() Method (Microsoft.DirectX.AudioVideoPlayback)

Video.Stop Method

Stops playback.

Definition

Visual Basic | Public Sub Stop()
C# | public void Stop();
C++ public:
void Stop();
JScript | public function Stop();

Remarks

Stopping playback will cause the position to be reset to the beginning.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.StopWhenReady() Method (Microsoft.DirectX.AudioVideoPlayback)

Video.StopWhenReady Method

Stops playback when the Video object is ready.

Definition

Visual Basic | Public Sub StopWhenReady()
C# | public void StopWhenReady();
C++ public:
void StopWhenReady();
JScript | public function StopWhenReady();

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Video Constructor ()

Initializes a new instance of the object.

Overload List

public Video(string);
public Video(string, bool);


Video.Video(String) Constructor (Microsoft.DirectX.AudioVideoPlayback)

Video.Video Constructor

Initializes a new instance of the Video class.

Definition

Visual Basic Public Sub New( _
ByVal fileName As String _
)
C# public Video(
string fileName
);
C++ public:
Video(
String^ fileName
);
JScript public function Video(
fileName : String
);

Parameters

fileName System.String
Path to the video file this object will play.


Video.Video(String,Boolean) Constructor (Microsoft.DirectX.AudioVideoPlayback)

Video.Video Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal fileName As String, _
ByVal autoRun As Boolean _
)
C# public Video(
string fileName,
bool autoRun
);
C++ public:
Video(
String^ fileName,
bool autoRun
);
JScript public function Video(
fileName : String,
autoRun : boolean
);

Parameters

fileName System.String
Path to the video file this object will play.
autoRun System.Boolean
Set to true to automatically start playback. Set to false to open the file but not play it.


Video.Audio Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Audio Property

Retrieves the Audio object the video is using for audio playback.

Definition

Visual Basic | Public ReadOnly Property Audio As Audio
C# | public Audio Audio { get; }
C++ public:
property Audio^ Audio {
Audio^ get();
}
JScript | public function get Audio() : Audio

Property Value

Microsoft.DirectX.AudioVideoPlayback.Audio
The Audio object the video is using for audio playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.AverageTimePerFrame Property (Microsoft.DirectX.AudioVideoPlayback)

Video.AverageTimePerFrame Property

Retrieves the average time per frame during playback.

Definition

Visual Basic | Public ReadOnly Property AverageTimePerFrame As Double
C# | public double AverageTimePerFrame { get; }
C++ public:
property double AverageTimePerFrame {
double get();
}
JScript | public function get AverageTimePerFrame() : double

Property Value

System.Double
The average time per frame during playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Caption Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Caption Property

Retrieves and sets the caption of the Form Leave Site playing the video.

Definition

Visual Basic | Public Property Caption As String
C# | public string Caption { get; set; }
C++ public:
property String^ Caption {
String^ get();
void set(String^ value);
}
JScript public function get Caption() : String
public function set Caption(String);

Property Value

System.String
The caption of the Form Leave Site playing the video.

This property is read/write.

Remarks

This property only applies to videos that are played in their own Form Leave Site when the Owner property is not set.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.CurrentPosition Property (Microsoft.DirectX.AudioVideoPlayback)

Video.CurrentPosition Property

Retrieves and sets the current position of playback.

Definition

Visual Basic | Public Property CurrentPosition As Double
C# | public double CurrentPosition { get; set; }
C++ public:
property double CurrentPosition {
double get();
void set(double value);
}
JScript public function get CurrentPosition() : double
public function set CurrentPosition(double);

Property Value

System.Double
The current position of playback.

This property is read/write.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.DefaultSize Property (Microsoft.DirectX.AudioVideoPlayback)

Video.DefaultSize Property

Retrieves the default size of the video for playback.

Definition

Visual Basic | Public ReadOnly Property DefaultSize As System.Drawing.Size
C# | public System.Drawing.Size DefaultSize { get; }
C++ public:
property System.Drawing.Size^ DefaultSize {
System.Drawing.Size^ get();
}
JScript | public function get DefaultSize() : System.Drawing.Size

Property Value

System.Drawing.Size
The default size of the video for playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Disposed Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Disposed Property

Retrieves a value that is true if the object is disposed; otherwise the value is false.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Video.Duration Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Duration Property

Retrieves the length, in seconds, of the video file.

Definition

Visual Basic | Public ReadOnly Property Duration As Double
C# | public double Duration { get; }
C++ public:
property double Duration {
double get();
}
JScript | public function get Duration() : double

Property Value

System.Double
The length, in seconds, of the video file.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Fullscreen Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Fullscreen Property

Retrieves and sets whether the video plays back in fullscreen mode.

Definition

Visual Basic | Public Property Fullscreen As Boolean
C# | public bool Fullscreen { get; set; }
C++ public:
property bool Fullscreen {
bool get();
void set(bool value);
}
JScript public function get Fullscreen() : boolean
public function set Fullscreen(boolean);

Property Value

System.Boolean
When set to true, the video plays back in fullscreen mode.

This property is read/write.

Remarks

When playing a video in fullscreen mode, the Owner property can not be set. If you attempt to set the Owner property after setting the Fullscreen property to true, a DirectXException will be thrown. If you try to set the Fullscreen property to true after you set the Owner property, the video will play back in the control and not in fullscreen mode.

If focus is taken away from the application playing the video, the video will no longer play in fullscreen mode and will return to windowed mode.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.IsCursorHidden Property (Microsoft.DirectX.AudioVideoPlayback)

Video.IsCursorHidden Property

Retrieves whether the cursor is hidden for the video.

Definition

Visual Basic | Public ReadOnly Property IsCursorHidden As Boolean
C# | public bool IsCursorHidden { get; }
C++ public:
property bool IsCursorHidden {
bool get();
}
JScript | public function get IsCursorHidden() : boolean

Property Value

System.Boolean
A value that is set to true if the cursor is hidden for the video; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.MaximumIdealSize Property (Microsoft.DirectX.AudioVideoPlayback)

Video.MaximumIdealSize Property

Retrieves the maximum ideal size of the video for playback.

Definition

Visual Basic | Public ReadOnly Property MaximumIdealSize As System.Drawing.Size
C# | public System.Drawing.Size MaximumIdealSize { get; }
C++ public:
property System.Drawing.Size^ MaximumIdealSize {
System.Drawing.Size^ get();
}
JScript | public function get MaximumIdealSize() : System.Drawing.Size

Property Value

System.Drawing.Size
The maximum ideal size of the video for playback.

This property is read-only.

Remarks

The maximum ideal size may differ from the native video size, because the video hardware might have specific stretching requirements.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.MinimumIdealSize Property (Microsoft.DirectX.AudioVideoPlayback)

Video.MinimumIdealSize Property

Retrieves the minimum ideal size of the video for playback.

Definition

Visual Basic | Public ReadOnly Property MinimumIdealSize As System.Drawing.Size
C# | public System.Drawing.Size MinimumIdealSize { get; }
C++ public:
property System.Drawing.Size^ MinimumIdealSize {
System.Drawing.Size^ get();
}
JScript | public function get MinimumIdealSize() : System.Drawing.Size

Property Value

System.Drawing.Size
The minimum ideal size of the video for playback.

This property is read-only.

Remarks

The minimum ideal size may differ from the native video size, because the video hardware might have specific stretching requirements.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Owner Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Owner Property

Retrieves or sets the Control Leave Site where the video will be played.

Definition

Visual Basic | Public Property Owner As Control
C# | public Control Owner { get; set; }
C++ public:
property Control^ Owner {
Control^ get();
void set(Control^ value);
}
JScript public function get Owner() : Control
public function set Owner(Control);

Property Value

System.Windows.Forms.Control
The Control Leave Site where the video will be played.

This property is read/write.

Remarks

If this property is not set before playback, a new Form Leave Site will be created for playback.

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Paused Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Paused Property

Retrieves whether playback is currently paused.

Definition

Visual Basic | Public ReadOnly Property Paused As Boolean
C# | public bool Paused { get; }
C++ public:
property bool Paused {
bool get();
}
JScript | public function get Paused() : boolean

Property Value

System.Boolean
A value that is set to true if the playback is currently paused; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Playing Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Playing Property

Retrieves whether playback is currently playing.

Definition

Visual Basic | Public ReadOnly Property Playing As Boolean
C# | public bool Playing { get; }
C++ public:
property bool Playing {
bool get();
}
JScript | public function get Playing() : boolean

Property Value

System.Boolean
A value that is set to true if the playback is currently playing; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.SeekingCaps Property (Microsoft.DirectX.AudioVideoPlayback)

Video.SeekingCaps Property

Retrieves the seeking capabilities of playback.

Definition

Visual Basic | Public ReadOnly Property SeekingCaps As SeekingCaps
C# | public SeekingCaps SeekingCaps { get; }
C++ public:
property SeekingCaps SeekingCaps {
SeekingCaps get();
}
JScript | public function get SeekingCaps() : SeekingCaps

Property Value

Microsoft.DirectX.AudioVideoPlayback.SeekingCaps
The seeking capabilities of playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Size Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Size Property

Retrieves and sets the size of the video for playback.

Definition

Visual Basic | Public Property Size As System.Drawing.Size
C# | public System.Drawing.Size Size { get; set; }
C++ public:
property System.Drawing.Size^ Size {
System.Drawing.Size^ get();
void set(System.Drawing.Size^ value);
}
JScript public function get Size() : System.Drawing.Size
public function set Size(System.Drawing.Size);

Property Value

System.Drawing.Size
The size of the video for playback.

This property is read/write.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.State Property (Microsoft.DirectX.AudioVideoPlayback)

Video.State Property

Retrieves the current state of playback.

Definition

Visual Basic | Public ReadOnly Property State As StateFlags
C# | public StateFlags State { get; }
C++ public:
property StateFlags State {
StateFlags get();
}
JScript | public function get State() : StateFlags

Property Value

Microsoft.DirectX.AudioVideoPlayback.StateFlags
The current state of playback.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Stopped Property (Microsoft.DirectX.AudioVideoPlayback)

Video.Stopped Property

Retrieves whether playback is currently stopped.

Definition

Visual Basic | Public ReadOnly Property Stopped As Boolean
C# | public bool Stopped { get; }
C++ public:
property bool Stopped {
bool get();
}
JScript | public function get Stopped() : boolean

Property Value

System.Boolean
A value that is set to true if the playback is stopped; otherwise, false.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.StopPosition Property (Microsoft.DirectX.AudioVideoPlayback)

Video.StopPosition Property

Retrieves the position where playback stopped.

Definition

Visual Basic | Public ReadOnly Property StopPosition As Double
C# | public double StopPosition { get; }
C++ public:
property double StopPosition {
double get();
}
JScript | public function get StopPosition() : double

Property Value

System.Double
The position where playback stopped.

This property is read-only.

Remarks

Exceptions
DirectXException For more information on the cause of this exception, reference the DirectXException.ErrorCode and DirectXException.ErrorString properties to the AudioVideoPlayback error code table.


Video.Disposing Event (Microsoft.DirectX.AudioVideoPlayback)

Video.Disposing Event

Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Video.Disposing event, use the following code.

video.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Video.Ending Event (Microsoft.DirectX.AudioVideoPlayback)

Video.Ending Event

Occurs when the playback is ending.

Definition

Visual Basic | Public Event Ending As EventHandler
C# | public event EventHandler Ending;
C++ public:
event EventHandler^ Ending;
JScript | In JScript, you can use events, but you cannot define your own.


Video.Pausing Event (Microsoft.DirectX.AudioVideoPlayback)

Video.Pausing Event

Occurs when the playback is pausing.

Definition

Visual Basic | Public Event Pausing As EventHandler
C# | public event EventHandler Pausing;
C++ public:
event EventHandler^ Pausing;
JScript | In JScript, you can use events, but you cannot define your own.


Video.Starting Event (Microsoft.DirectX.AudioVideoPlayback)

Video.Starting Event

Occurs when the playback is starting.

Definition

Visual Basic | Public Event Starting As EventHandler
C# | public event EventHandler Starting;
C++ public:
event EventHandler^ Starting;
JScript | In JScript, you can use events, but you cannot define your own.


Video.Stopping Event (Microsoft.DirectX.AudioVideoPlayback)

Video.Stopping Event

Occurs when the playback is stopping.

Definition

Visual Basic | Public Event Stopping As EventHandler
C# | public event EventHandler Stopping;
C++ public:
event EventHandler^ Stopping;
JScript | In JScript, you can use events, but you cannot define your own.


Video.TextureReadyToRender Event (Microsoft.DirectX.AudioVideoPlayback)

Video.TextureReadyToRender Event

Occurs when target texture is ready to render video playback.

Definition

Visual Basic | Public Event TextureReadyToRender As TextureRenderEventHandler
C# | public event TextureRenderEventHandler TextureReadyToRender;
C++ public:
event TextureRenderEventHandler^ TextureReadyToRender;
JScript | In JScript, you can use events, but you cannot define your own.


SeekPositionFlags Enumeration (Microsoft.DirectX.AudioVideoPlayback)

SeekPositionFlags Enumeration

Contains constants for specifiying the type of seek for the Audio or Video objects.

Definition

Visual Basic | Public Enum SeekPositionFlags
C# | public enum SeekPositionFlags
C++ | public enum class SeekPositionFlags
JScript | public enum SeekPositionFlags

Members

Member | Value | Description
NoFlush | 32 | Do not flush
SeekToKeyFrame | 4 | Seek to the nearest key frame. This might be faster, but less accurate.
IncrementalPositioning | 3 | The stop position is relative to the current position.
RelativePositioning | 2 | The specified position is relative to the previous value.
AbsolutePositioning | 1 | The specified position is absolute.

Enumeration Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Audio.SeekCurrentPosition
  • Audio.SeekStopPosition
  • Video.SeekCurrentPosition
  • Video.SeekStopPosition


StateFlags Enumeration (Microsoft.DirectX.AudioVideoPlayback)

StateFlags Enumeration

Contains constants for specifiying the state of the Audio or Video objects.

Definition

Visual Basic | Public Enum StateFlags
C# | public enum StateFlags
C++ | public enum class StateFlags
JScript | public enum StateFlags

Members

Member | Value | Description
Running | 2 | The Audio or Video object is running.
Paused | 1 | The Audio or Video object is paused.
Stopped | 0 | The Audio or Video object is stopped.

Enumeration Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Audio.State
  • Video.State


SeekingCaps Structure (Microsoft.DirectX.AudioVideoPlayback)

SeekingCaps Structure

Collection of properties that describe the capabilities of a media stream.

Definition

Visual Basic | Public Structure SeekingCaps
C# | public struct SeekingCaps
C++ | public value class SeekingCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property | Description
CanGetCurrentPosition | Retrieves whether the stream can report its current position.
CanGetDuration | Retrieves whether the stream can report its duration.
CanGetStopPosition | Retrieves whether the stream can report its stop position.
CanSeekAbsolute | Retrieves whether the stream can seek to an absolute position.
CanSeekBackwards | Retrieves whether the stream can seek backward
CanSeekForwards | Retrieves whether the stream can seek forward.

Structure Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Auido.SeekingCaps
  • Video.SeekingCaps


SeekingCaps.CanGetCurrentPosition Property (Microsoft.DirectX.AudioVideoPlayback)

SeekingCaps.CanGetCurrentPosition Property

Retrieves whether the stream can report its current position.

Definition

Visual Basic | Public ReadOnly Property CanGetCurrentPosition As Boolean
C# | public bool CanGetCurrentPosition { get; }
C++ public:
property bool CanGetCurrentPosition {
bool get();
}
JScript | public function get CanGetCurrentPosition() : boolean

Property Value

System.Boolean
A value that is set to true if the stream can report its current position; otherwise, false.

This property is read-only.


SeekingCaps.CanGetDuration Property (Microsoft.DirectX.AudioVideoPlayback)

SeekingCaps.CanGetDuration Property

Retrieves whether the stream can report its duration.

Definition

Visual Basic | Public ReadOnly Property CanGetDuration As Boolean
C# | public bool CanGetDuration { get; }
C++ public:
property bool CanGetDuration {
bool get();
}
JScript | public function get CanGetDuration() : boolean

Property Value

System.Boolean
A value that is set to true if the stream can report its duration; otherwise, false.

This property is read-only.


SeekingCaps.CanGetStopPosition Property (Microsoft.DirectX.AudioVideoPlayback)

SeekingCaps.CanGetStopPosition Property

Retrieves whether the stream can report its stop position.

Definition

Visual Basic | Public ReadOnly Property CanGetStopPosition As Boolean
C# | public bool CanGetStopPosition { get; }
C++ public:
property bool CanGetStopPosition {
bool get();
}
JScript | public function get CanGetStopPosition() : boolean

Property Value

System.Boolean
A value that is set to true if the stream can report its stop position; otherwise, false.

This property is read-only.


SeekingCaps.CanSeekAbsolute Property (Microsoft.DirectX.AudioVideoPlayback)

SeekingCaps.CanSeekAbsolute Property

Retrieves whether the stream can seek to an absolute position.

Definition

Visual Basic | Public ReadOnly Property CanSeekAbsolute As Boolean
C# | public bool CanSeekAbsolute { get; }
C++ public:
property bool CanSeekAbsolute {
bool get();
}
JScript | public function get CanSeekAbsolute() : boolean

Property Value

System.Boolean
A value that is set to true if the stream can seek to an absolute position; otherwise, false.

This property is read-only.


SeekingCaps.CanSeekBackwards Property (Microsoft.DirectX.AudioVideoPlayback)

SeekingCaps.CanSeekBackwards Property

Retrieves whether the stream can seek backward

Definition

Visual Basic | Public ReadOnly Property CanSeekBackwards As Boolean
C# | public bool CanSeekBackwards { get; }
C++ public:
property bool CanSeekBackwards {
bool get();
}
JScript | public function get CanSeekBackwards() : boolean

Property Value

System.Boolean
A value that is set to true if the stream can seek backward; otherwise, false.

This property is read-only.


SeekingCaps.CanSeekForwards Property (Microsoft.DirectX.AudioVideoPlayback)

SeekingCaps.CanSeekForwards Property

Retrieves whether the stream can seek forward.

Definition

Visual Basic | Public ReadOnly Property CanSeekForwards As Boolean
C# | public bool CanSeekForwards { get; }
C++ public:
property bool CanSeekForwards {
bool get();
}
JScript | public function get CanSeekForwards() : boolean

Property Value

System.Boolean
A value that is set to true if the stream can seek forward; otherwise, false.

This property is read-only.


TextureRenderEventHandler(Object,TextureRenderEventArgs) Delegate (Microsoft.DirectX.AudioVideoPlayback)

TextureRenderEventHandler Delegate

Represents the method that handles the Video.TextureReadyToRender event.

Definition

Visual Basic Public Delegate Sub TextureRenderEventHandler( _
ByVal sender As Object, _
ByVal e As TextureRenderEventArgs _
)
C# public delegate void TextureRenderEventHandler(
object sender,
TextureRenderEventArgs e
);
C++ public delegate void TextureRenderEventHandler(
Object^ sender,
TextureRenderEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
The System.Object Leave Site that is calling the event.
e Microsoft.DirectX.AudioVideoPlayback.TextureRenderEventArgs
A TextureRenderEventArgs object that allows you to pass an argument to the Video.TextureReadyToRender event.

Delegate Information

Namespace | Microsoft.DirectX.AudioVideoPlayback
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Microsoft.DirectX.Diagnostics

The Microsoft DirectX Diagnostics application programming interface (API) enables you to programmatically query the information gathered by the DirectX Diagnostics Tool (DxDiag). DxDiag gathers information about the system and the DirectX components installed on it, as well as providing a number of tests to ensure that components are working properly.

A sample application is provided at (SDK root)\Samples\Managed\Misc\DxDiagOutput. The executable is at %windir%\system32\dxdiag.exe.

The following tables list the members exposed by the Microsoft.DirectX.Diagnostics namespace.

Classes

Container | A diagnostics container. Contains properties and other containers.
ContainerList | Maintains a list of containers.
PropertyList | Maintains a list of properties.

Structures

ContainerData | Holds the Container and its name.
PropertyData | Contains the property name and value.


Container Class (Microsoft.DirectX.Diagnostics)

Container Class

A diagnostics container. Contains properties and other containers.

Definition

Visual Basic Public Class Container
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Container : MarshalByRefObject, IDisposable
C++ | public ref class Container : MarshalByRefObject, IDisposable
JScript | public class Container extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Container | Initializes a new instance of the Container class.
Dispose | Immediately releases the unmanaged resources used by an object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
GetContainer | Retrieves a container with a specified name or index.
GetProperty | Retrieves a property with a specified name or index.

Properties

Property | Description
Containers | Retrieves a ContainerList object that holds the containers for the current container object.
NumberContainers | Retrieves the number of containers stored in the ContainerList.
NumberProperties | Retrieves the number of properties stored in the PropertyList.
Properties | Retrieves a PropertyList object that holds the properties for the current container object.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Container

Class Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Container.Container(Boolean) Constructor (Microsoft.DirectX.Diagnostics)

Container.Container Constructor

Initializes a new instance of the Container class.

Definition

Visual Basic Public Sub New( _
ByVal allowWhqlChecks As Boolean _
)
C# public Container(
bool allowWhqlChecks
);
C++ public:
Container(
bool allowWhqlChecks
);
JScript public function Container(
allowWhqlChecks : boolean
);

Parameters

allowWhqlChecks System.Boolean
Set to true if Windows Hardware Quality Labs (WHQL) checks are allowed; otherwise, false.


Container.Dispose() Method (Microsoft.DirectX.Diagnostics)

Container.Dispose Method

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Container();
JScript | public override function Dispose();


Container.Finalize() Method (Microsoft.DirectX.Diagnostics)

Container.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Container();
C++ | !Container();
JScript | protected override function Finalize();


Container.GetContainer Method ()

Retrieves a container with a specified name or index.

Overload List

public ContainerData GetContainer(int);
public ContainerData GetContainer(string);


Container.GetContainer(String) Method (Microsoft.DirectX.Diagnostics)

Container.GetContainer Method

Container with the specified name.

Definition

Visual Basic Public Function GetContainer( _
ByVal name As String _
) As ContainerData
C# public ContainerData GetContainer(
string name
);
C++ public:
ContainerData GetContainer(
String^ name
);
JScript public function GetContainer(
name : String
) : ContainerData;

Parameters

name System.String
String that represents the name of the container to retrieve.

Return Value

Microsoft.DirectX.Diagnostics.ContainerData
Requested ContainerData object.


Container.GetContainer(Int32) Method (Microsoft.DirectX.Diagnostics)

Container.GetContainer Method

Container with the specified index.

Definition

Visual Basic Public Function GetContainer( _
ByVal index As Integer _
) As ContainerData
C# public ContainerData GetContainer(
int index
);
C++ public:
ContainerData GetContainer(
int index
);
JScript public function GetContainer(
index : int
) : ContainerData;

Parameters

index System.Int32
Integer that represents the index of the container to retrieve.

Return Value

Microsoft.DirectX.Diagnostics.ContainerData
Requested ContainerData object.


Container.GetProperty Method ()

Retrieves a property with a specified name or index.

Overload List

public PropertyData GetProperty(int);
public PropertyData GetProperty(string);


Container.GetProperty(String) Method (Microsoft.DirectX.Diagnostics)

Container.GetProperty Method

Property with the specified name.

Definition

Visual Basic Public Function GetProperty( _
ByVal name As String _
) As PropertyData
C# public PropertyData GetProperty(
string name
);
C++ public:
PropertyData GetProperty(
String^ name
);
JScript public function GetProperty(
name : String
) : PropertyData;

Parameters

name System.String
String that represents the name of the property to retrieve.

Return Value

Microsoft.DirectX.Diagnostics.PropertyData
Requested PropertyData object.


Container.GetProperty(Int32) Method (Microsoft.DirectX.Diagnostics)

Container.GetProperty Method

Property with the specified index.

Definition

Visual Basic Public Function GetProperty( _
ByVal index As Integer _
) As PropertyData
C# public PropertyData GetProperty(
int index
);
C++ public:
PropertyData GetProperty(
int index
);
JScript public function GetProperty(
index : int
) : PropertyData;

Parameters

index System.Int32
Integer that represents the index of the property to retrieve.

Return Value

Microsoft.DirectX.Diagnostics.PropertyData
Requested PropertyData object.


Container.Containers Property (Microsoft.DirectX.Diagnostics)

Container.Containers Property

Retrieves a ContainerList object that holds the containers for the current container object.

Definition

Visual Basic | Public ReadOnly Property Containers As ContainerList
C# | public ContainerList Containers { get; }
C++ public:
property ContainerList^ Containers {
ContainerList^ get();
}
JScript | public function get Containers() : ContainerList

Property Value

Microsoft.DirectX.Diagnostics.ContainerList
A ContainerList object to retrieve.

This property is read-only.


Container.NumberContainers Property (Microsoft.DirectX.Diagnostics)

Container.NumberContainers Property

Retrieves the number of containers stored in the ContainerList.

Definition

Visual Basic | Public ReadOnly Property NumberContainers As Integer
C# | public int NumberContainers { get; }
C++ public:
property int NumberContainers {
int get();
}
JScript | public function get NumberContainers() : int

Property Value

System.Int32
Integer value that represents the number of containers stored in the ContainerList.

This property is read-only.


Container.NumberProperties Property (Microsoft.DirectX.Diagnostics)

Container.NumberProperties Property

Retrieves the number of properties stored in the PropertyList.

Definition

Visual Basic | Public ReadOnly Property NumberProperties As Integer
C# | public int NumberProperties { get; }
C++ public:
property int NumberProperties {
int get();
}
JScript | public function get NumberProperties() : int

Property Value

System.Int32
Integer value that represents the number of properties stored in the PropertyList.

This property is read-only.


Container.Properties Property (Microsoft.DirectX.Diagnostics)

Container.Properties Property

Retrieves a PropertyList object that holds the properties for the current container object.

Definition

Visual Basic | Public ReadOnly Property Properties As PropertyList
C# | public PropertyList Properties { get; }
C++ public:
property PropertyList^ Properties {
PropertyList^ get();
}
JScript | public function get Properties() : PropertyList

Property Value

Microsoft.DirectX.Diagnostics.PropertyList
A PropertyList object to retrieve.

This property is read-only.


ContainerList Class (Microsoft.DirectX.Diagnostics)

ContainerList Class

Maintains a list of containers.

Definition

Visual Basic Public Class ContainerList
Inherits Object
Implements IEnumerable, IEnumerator
C# | public class ContainerList : Object, IEnumerable, IEnumerator
C++ | public ref class ContainerList : Object, IEnumerable, IEnumerator
JScript | public class ContainerList extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can iterate through the ContainerList.
MoveNext | Advances the enumerator to the next item in the list.
Reset | Resets the current enumerator to point to the beginning of the list.

Properties

Property | Description
Count | Retrieves the number of Objects Leave Site in the ContainerList.
Current | Retrieves the current Object Leave Site in the list.

Inheritance Hierarchy

Object Leave Site
ContainerList

Class Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ContainerList.GetEnumerator() Method (Microsoft.DirectX.Diagnostics)

ContainerList.GetEnumerator Method

Returns an enumerator that can iterate through the ContainerList.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator
Enumerator that can iterate through the ContainerList.


ContainerList.MoveNext() Method (Microsoft.DirectX.Diagnostics)

ContainerList.MoveNext Method

Advances the enumerator to the next item in the list.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean
Value that is true if the move to the next item was successful, or false if it was not.


ContainerList.Reset() Method (Microsoft.DirectX.Diagnostics)

ContainerList.Reset Method

Resets the current enumerator to point to the beginning of the list.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the list.

After Reset is called, the cursor is undefined. Call MoveNext initially to point to the first item in the list.


ContainerList.Count Property (Microsoft.DirectX.Diagnostics)

ContainerList.Count Property

Retrieves the number of Objects Leave Site in the ContainerList.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32
Number of Objects Leave Site in the ContainerList.

This property is read-only.


ContainerList.Current Property (Microsoft.DirectX.Diagnostics)

ContainerList.Current Property

Retrieves the current Object Leave Site in the list.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object
Current Object Leave Site in the list.

This property is read-only.


PropertyList Class (Microsoft.DirectX.Diagnostics)

PropertyList Class

Maintains a list of properties.

Definition

Visual Basic Public Class PropertyList
Inherits Object
Implements IEnumerable, IEnumerator
C# | public class PropertyList : Object, IEnumerable, IEnumerator
C++ | public ref class PropertyList : Object, IEnumerable, IEnumerator
JScript | public class PropertyList extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can iterate through the PropertyList.
MoveNext | Advances the enumerator to the next item in the list.
Reset | Resets the current enumerator to point to the beginning of the list.

Properties

Property | Description
Count | Retrieves the number of Objects Leave Site in the PropertyList.
Current | Retrieves the current Object Leave Site in the list.

Inheritance Hierarchy

Object Leave Site
PropertyList

Class Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PropertyList.GetEnumerator() Method (Microsoft.DirectX.Diagnostics)

PropertyList.GetEnumerator Method

Returns an enumerator that can iterate through the PropertyList.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator
Enumerator that can iterate through the PropertyList.


PropertyList.MoveNext() Method (Microsoft.DirectX.Diagnostics)

PropertyList.MoveNext Method

Advances the enumerator to the next item in the list.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean
Value that is true if the move to the next item was successful, or false if it was not.


PropertyList.Reset() Method (Microsoft.DirectX.Diagnostics)

PropertyList.Reset Method

Resets the current enumerator to point to the beginning of the list.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the list.

After Reset is called, the cursor is undefined. Call MoveNext initially to point to the first item in the list.


PropertyList.Count Property (Microsoft.DirectX.Diagnostics)

PropertyList.Count Property

Retrieves the number of Objects Leave Site in the PropertyList.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32
Number of Objects Leave Site in the PropertyList.

This property is read-only.


PropertyList.Current Property (Microsoft.DirectX.Diagnostics)

PropertyList.Current Property

Retrieves the current Object Leave Site in the list.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object
Current Object Leave Site in the list.

This property is read-only.


ContainerData Structure (Microsoft.DirectX.Diagnostics)

ContainerData Structure

Holds the Container and its name.

Definition

Visual Basic | Public Structure ContainerData
C# | public struct ContainerData
C++ | public value class ContainerData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ContainerData | Initializes a new instance of the ContainerData class.

Properties

Property | Description
Container | Retrieves the Container associated with the current object.
Name | Retrieves the name of the Container associated with the current object.

Structure Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ContainerData.ContainerData() Constructor (Microsoft.DirectX.Diagnostics)

ContainerData.ContainerData Constructor

Initializes a new instance of the ContainerData class.

Definition

Visual Basic | Public Sub New()
C# | public ContainerData();
C++ public:
ContainerData();
JScript | public function ContainerData();


ContainerData.Container Property (Microsoft.DirectX.Diagnostics)

ContainerData.Container Property

Retrieves the Container associated with the current object.

Definition

Visual Basic | Public ReadOnly Property Container As Container
C# | public Container Container { get; }
C++ public:
property Container^ Container {
Container^ get();
}
JScript | public function get Container() : Container

Property Value

Microsoft.DirectX.Diagnostics.Container
A Container to retrieve.

This property is read-only.


ContainerData.Name Property (Microsoft.DirectX.Diagnostics)

ContainerData.Name Property

Retrieves the name of the Container associated with the current object.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
String that contains the name of the Container.

This property is read-only.


PropertyData Structure (Microsoft.DirectX.Diagnostics)

PropertyData Structure

Contains the property name and value.

Definition

Visual Basic | Public Structure PropertyData
C# | public struct PropertyData
C++ | public value class PropertyData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PropertyData | Initializes a new instance of the PropertyData class.

Properties

Property | Description
Data | Retrieves the property's value in the form of an Object Leave Site.
Name | Retrieves the name of the Data associated with the current object.

Structure Information

Namespace | Microsoft.DirectX.Diagnostics
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PropertyData.PropertyData() Constructor (Microsoft.DirectX.Diagnostics)

PropertyData.PropertyData Constructor

Initializes a new instance of the PropertyData class.

Definition

Visual Basic | Public Sub New()
C# | public PropertyData();
C++ public:
PropertyData();
JScript | public function PropertyData();


PropertyData.Data Property (Microsoft.DirectX.Diagnostics)

PropertyData.Data Property

Retrieves the property's value in the form of an Object Leave Site.

Definition

Visual Basic | Public ReadOnly Property Data As Object
C# | public object Data { get; }
C++ public:
property Object^ Data {
Object^ get();
}
JScript | public function get Data() : Object

Property Value

System.Object
An Object Leave Site that represents the property value.

This property is read-only.


PropertyData.Name Property (Microsoft.DirectX.Diagnostics)

PropertyData.Name Property

Retrieves the name of the Data associated with the current object.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
String that contains the name of the Data.

This property is read-only.


Microsoft.DirectX.Direct3D

Microsoft Direct3D is a low-level graphics application programming interface (API) that enables you to manipulate visual models of 3-D objects and take advantage of hardware acceleration. The following tables list the members exposed by the Microsoft.DirectX.Direct3D namespace.

See also the Microsoft.DirectX namespace, which provides utility and data storage operations.

Classes

AdapterInformation | Manipulates adapter information.
AdapterListCollection | Manipulates a collection of adapters.
AllocateHierarchy | Derived by the application to allocate/free frame and mesh container objects. Methods of this class are called during loading and destruction of frame hierarchies.
AnimationController | Controls animation functionality, connecting animation sets to the transformation frames being animated.
AnimationOutput | Encapsulates matrix, scale, rotate, and translate (SRT) transformation objects.
AnimationSet Encapsulates the minimum functionality required of an animation set by an animation controller.

Advanced users might want to implement this class themselves to suit their specialized needs. For most users, however, the derived CompressedAnimationSet and KeyframedAnimationSet classes should suffice.
BaseEffect | Provides methods for retrieving and setting effect parameters such as constants, functions, shaders, and techniques.
BaseMesh | Manipulates and queries mesh objects and derived mesh objects.
BaseTexture | Manipulates texture resources, including cube and volume textures.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique. For more information, see MeshFlags.OptimizeAttrSort.
CannotModifyIndexBufferException | The index buffer cannot be modified.
ClipPlane | Defines the clipping plane for a device.
ClipPlanes | Contains the clipping planes on the device.
ColorOperator | Contains methods for manipulating colors.
CompressedAnimationSet | Implements a keyframe animation set that is stored in a compressed data format.
ConflictingRenderStateException | The currently set render states cannot be used together.
ConflictingTextureFilterException | The current texture filters cannot be used together.
ConflictingTexturePaletteException | The current textures cannot be used simultaneously.
ConstantTable | Provides access to the constant table, which contains the variables that are used by high-level language shaders and effects.
CubeTexture | Manipulates a cube texture resource.
CustomVertex | Defines various custom fixed-format vertex types. This class is a container of structures. See the individual structures for more information.
D3DX | Contains default constant values for Direct3D extensions.
Device | Performs primitive-based rendering, creates resources, handles system-level variables, adjusts gamma ramp levels, gets and sets palettes, and creates shaders.
DeviceInformation | Contains functionality for retrieving the driver level for a device.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
DeviceNotResetException | The device has been lost but can be reset at this time.
Direct3DXException | Base exception class for D3DX. Derives from DirectXException.
DisplayModeCollection | Manipulates a collection of DisplayMode structures.
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DriverInvalidCallException | The driver reports that the current method call is invalid.
DuplicateNamedFragmentException | There is a duplicate named fragment.
Effect | Used to set and query effects and choose techniques.
EffectCompiler | Compiles an effect from a function or vertex shader.
EffectHandle | Represents a handle to specific effects.
EffectPool | Allows applications to share resources between effects.
EffectStateManager EffectStateManager is a user-implemented class that allows an application to set the device state from an effect. Each of the methods in this class must be implemented by the user and will then be used as a callback to the application when either of the following occur:
  • Effect.BeginPass is called.
  • Effect state is dynamically updated by calling the appropriate state change API. See individual method pages for details.
Font | Encapsulates the textures and resources needed to render a specific font on a specific device.
FragmentLinker | Links shader fragments at runtime.
Frame | Encapsulates a transform frame in a transformation frame hierarchy.
Geometry | Contains miscellaneous math-related functions.
GraphicsException | Base exception type for graphics. Derives from DirectXException.
Include | Provides access to include-file directives.
IndexBuffer | Manipulates an index buffer resource.
IntegratedMetricTensor | Contains methods to calculate integrated metric tensor (IMT) values for use in UVAtlas operations.
InterfaceGuid | Encapsulates various object globally unique identifiers (GUIDs) for use with the Surface.GetContainer and Volume.GetContainer methods.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
InvalidDataException | The data is invalid.
InvalidDeviceException | The requested device type is not valid.
InvalidMeshException | The mesh is invalid.
KeyframedAnimationSet | Implements a keyframe animation set.
Light | Defines a set of lighting properties.
LightsCollection | Defines a collection of lights.
Line | Implements line drawing using textured triangles.
LoadedMeshHasNoDataException | The mesh has no data.
LoadUserData | Derived by the application to allocate or free frame and mesh container objects. Methods of this class are called during loading and destruction of frame hierarchies.
Manager | Provides information about the environment, and enumerates and retrieves device capabilities.
Mesh | Manipulates mesh objects.
MeshContainer | Encapsulates a mesh object in a transformation frame hierarchy.
MoreDataException | More data is available than the specified buffer size can hold.
NotAvailableException | This device does not support the queried technique.
NotFoundException | The requested item was not found.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
PatchMesh | Provides patch mesh functionality.
PixelShader | Encapsulates the functionality of a pixel shader.
PresentParameters | Describes the presentation parameters.
ProgressiveMesh | Manipulates progressive mesh objects.
PrtBuffer | Used as a data buffer to store vertex and pixel data for use with precomputed radiance transfer (PRT) methods and functions.
PrtCompressedBuffer | Stores a compressed version of a PrtBuffer object for use with principal component analysis (PCA).
PrtEngine | The PrtEngine class is used to compute a PRT simulation. Its methods are typically used offline to compute per-vertex or per-texel transfer vectors in advance of real-time 3-D modeling.
Query | Performs asynchronous queries on a driver.
RenderStateManager | Defines device render states.
RenderToEnvironmentMap | Generalizes the process of rendering to environment maps. An environment map is used to texture-map scene geometry to provide a more sophisticated scene without using complex geometry. This class supports the creation of surfaces for the following kinds of geometry: cube, half sphere or hemispheric, parabolic, and sphere.
RenderToSurface | Generalizes the process of rendering to surfaces. Surfaces can be used in a variety of ways; for example, as render targets, or for off-screen rendering and rendering to textures.
Resource | Queries and prepares resources.
SamplerStateManager | Contains sampler states for the device.
SamplerStateManagerCollection | Collection of SamplerStateManager objects.
SaveUserData | Implemented by the application to save frame and mesh container objects.
ShaderLoader | Encapsulates the functionality for loading shader objects.
SimplificationMesh | Manipulates simplification mesh objects.
SkinInformation | Manipulates bone matrices, which are used to skin vertex data for animation.
SkinningNotSupportedException | Skinning is not supported.
SphericalHarmonics | Encapsulates spherical harmonic (SH) mathematical functions.
Sprite | Provides methods and properties that simplify the process of drawing sprites using Direct3D.
StateBlock | Encapsulates render states.
Surface | Queries and prepares surfaces.
SurfaceLoader | Loads and saves surfaces.
SwapChain | Manipulates a swap chain.
Texture | Manipulates a texture resource.
TextureGutterHelper | Used to build and manage gutter regions in a texture. Gutter regions separate textures and allow for bilinear interpolation to avoid rendering artifacts at texture boundaries.
TextureLoader | Contains functions to load and save textures.
TextureShader | Encapsulates the functionality of a texture shader.
TextureStateManager | Contains texture states for the device.
TextureStateManagerCollection | Collection of TextureStateManager objects.
TooManyInfluencesException | Too many influences specified.
TooManyOperationsException | The application is requesting more texture-filtering operations than the device supports.
Transforms | Allows applications to specify and obtain matrix transformations; for example, the world, view, and transformation matrices used for Direct3D object rendering.
UnsupportedAlphaArgumentException | The device does not support a specified texture-blending argument for the alpha channel.
UnsupportedAlphaOperationException | The device does not support a specified texture-blending operation for the alpha channel.
UnsupportedColorArgumentException | The device does not support a specified texture-blending argument for color values.
UnsupportedColorOperationException | The device does not support a specified texture-blending operation for color values.
UnsupportedFactorValueException | The device does not support the specified texture factor value. Not used; provided only to support older drivers.
UnsupportedTextureFilterException | The device does not support the specified texture filter.
UVAtlas | Contains methods for creating UV texture atlases.
VertexBuffer | Manipulates vertex buffer resources.
VertexDeclaration | Encapsulates the vertex shader declaration.
VertexInformation | Retrieves vertex information.
VertexShader | Encapsulates the functionality of a vertex shader.
VertexTextureCoordinate | Constructs bit patterns that are used to identify texture coordinate formats in a flexible vertex format description.
Volume | Manipulates volume resources.
VolumeLoader | Contains functions for loading and saving volumes.
VolumeTexture | Manipulates a volume texture resource.
WasStillDrawingException | The device was still drawing.
WrongTextureFormatException | The pixel format of the texture surface is not valid.
XFile | Retrieves information about XFile file objects.
XFileData | Builds or accesses the immediate hierarchy of a data object.
XFileGuid | Provides various GUID values for use with XFiles (.x files).
XFileManager | Manages XFile (.x) objects.
XFileSaveData | Applications use the methods of the XFileSaveData class to add data objects as children of a .x file data node.
XFileSaveObject | Creates and saves data objects and templates.

Enumerations

AnimationOutputFlags | Defines the flags used to create an AnimationOutput object.
BackBufferType | Defines constants that identify the type of back buffers in a swap chain.
BasisType | Defines the basis type of a high-order patch surface.
Blend | Defines the supported . (The RGBA values of the source and destination are indicated by the subscripts s and d.)
BlendOperation | Defines the supported blend operations.
CallbackSearchFlags | Defines the flags used to obtain callback information.
Channel | Defines flags that specify which channels in a texture to operate on.
CharacterSet | Defines a character set.
CleanType | Defines vertex operations to perform in preparation for mesh cleaning.
ClearFlags | Specifies the buffer to use when calling the Device.Clear method.
ClipStatusFlags | Defines the current clip status.
ColorSource | Defines the location at which a color or color component must be accessed for lighting calculations.
ColorWriteEnable | Defines values that are used to specify a channel in the RenderStateManager class type.
Compare | Defines the supported compare functions in the RenderStateManager class type.
CompressionFlags | Defines the compression mode to use for storing compressed animation set data.
CompressionQuality | Defines SH compression settings.
CreateFlags | Defines the flags to use when creating a device.
CubeMapFace | Defines the faces of a cube map in the CubeTexture class type.
Cull | Defines the supported culling modes, which specify how back faces are culled during geometry rendering.
DeclarationMethod | Defines the declaration methods for a vertex declaration.
DeclarationType | Defines declaration types for a vertex declaration.
DeclarationUsage | Defines declaration usage for a vertex declaration.
DegreeType | Defines the degree of the variables in an equation that describes a curve.
DepthFormat | Defines depth buffer formats.
DeviceType | Specifies a device type.
DisplacementMap | Identifies a texture sampler stage.
DrawTextFormat | Specifies the method of formatting text.
EffectDefaultType | Defines effect data types.
EventType | Defines the types of events that can be keyed by the animation controller.
FillMode | Defines constants that describe the fill mode.
Filter | Defines texture filtering modes for a texture stage.
FogMode | Defines constants that describe the fog mode.
FontQuality | Specifies the level of font quality.
FontWeight | Specifies font weights.
Format | Defines various types of surface formats. For a more complete discussion, see Surface Formats.
FX | Defines flags for saving shader state.
GpuSimulatorOption | Describes the resolution of the shadow z-buffer that will be used in PRT direct lighting simulation on the graphics processing unit (GPU). A higher quality z-buffer can also be specified to reduce noise in the results of the direct lighting simulation, although the simulation will be slower.
ImageFileFormat | Defines the supported image file formats.
ImtWrap | Flags used by IntegratedMetricTensor methods.
IncludeType | Defines an include file.
IssueFlags | Defines issue flags.
LightType | Defines the light type.
LockFlags | Defines the type of lock to perform.
MeshFlags | Defines flags used to specify creation options for a mesh.
MultiSampleType | Defines the levels of full-scene multisampling that the device can apply.
NormalMap | Defines the flags used to convert a height map into a normal map.
ParameterClass | Defines the class of the object.
ParameterFlags | Defines shader and effect constants.
ParameterType | Defines the data contained by the enumeration.
PatchEdge | Defines whether the current tessellation mode is discrete or continuous.
PatchType | Defines mesh patch types.
PitchAndFamily | Defines font families.
PlaybackType | Defines the type of looping mode to use for playback of an animation set.
Pool | Defines the memory class that holds buffers for a resource.
Precision | Specifies the desired output precision.
Present | Defines flags that allow the application to request that the SwapChain.Present return immediately when the driver reports that it cannot schedule a presentation.
PresentFlag | Defines flags that control a Device.Present operation.
PresentInterval | Defines flags that describe the relationship between the adapter refresh rate and the rate at which Device.Present operations are completed.
PrimitiveType | Defines the primitives supported by Direct3D.
PriorityType | Defines the priority type an animation track is assigned to.
QueryType | Defines the query type.
RegisterSet | Defines the data type of the register.
RenderStates | Defines device render states.
RenderTargetsMax | Defines the maximum number of simultaneous render targets supported.
ResourceType | Defines resource types.
ResultCode | Defines result codes.
SamplerStageStates | Defines the sampler state types.
ShadeMode | Defines constants that describe the supported shading modes.
ShaderFlags | Defines the compiler options to use during a shader compilation.
SpriteFlags | Defines flags used to specify sprite rendering options.
StateBlockType | Defines logical groups of device states.
StencilOperation | Defines the supported stencil operations.
SwapEffect | Defines swap effects.
TangentOptions | Defines settings used for mesh tangent frame computations.
TextureAddress | Defines constants that describe the supported texture-addressing modes.
TextureArgument | Defines the supported texture arguments.
TextureCoordinateIndex | Defines the supported texture coordinate index values.
TextureFilter | Defines texture filtering modes for a texture stage.
TextureOperation | Defines per-stage texture-blending operations.
TextureStageStates | Defines texture stage states.
TextureTransform | Defines texture-stage state values.
TransformType | Defines constants that describe transformation state values.
TransitionType | Defines the transition style between values of a mesh animation.
Usage | Defines supported usage types for the current resource.
VertexBlend | Defines enumerated values used to control the number of matrices that the system applies when performing multimatrix vertex blending.
VertexFormats | Describes values that define a vertex format used to describe the contents of vertices that are stored interleaved in a single data stream.
WeldEpsilonsFlags | Defines the options for welding vertices together.
Wrap | Defines texture wrapping.
WrapCoordinates | Defines supported wrap coordinates.
XFileErrorCodes | Defines XFile error codes. The methods used to work with Microsoft DirectX XFiles can return the following return values. Exceptions thrown from methods that use XFiles can also contain these values.
XFileFormat | Defines file formats for XFiles.

Structures

AdapterDetails | Contains information that identifies the adapter.
AddressCaps | Contains the texture addressing capabilities for Texture objects.
AnimationRootFrame | Contains the root frame and animation controller in a frame hierarchy.
AttributeRange | Stores an attribute table entry.
AttributeWeights | Specifies mesh weight attributes.
BandwidthTimings | Provides throughput measurement comparisons for help in understanding the performance of an application.
BehaviorFlags | Contains a set of properties that indicate the global behavior of a device.
BlendCaps | Indicates the supported capabilities.
BoneCombination | Describes a subset of the mesh that has the same attribute and bone combination.
BoneInfluences | Describes the vertices and weights that a bone influences.
Box | Defines a volume.
CacheUtilization | Measures the cache hit rate performance for textures and indexed vertices.
CallbackData | Retrieves information about animation callbacks.
Caps | Represents the capabilities of the hardware exposed through the Direct3D object.
ClipStatus | Describes the current clip status.
ColorValue | Stores the red, green, blue, and alpha channel values that together define a specific color.
ComparisonCaps | Retrieves comparison capabilities.
ConstantDescription | Describes a constant in a constant table.
ConstantTableDescription | Describes the constant table.
CubeTextureRequirements | Contains cube texture creation parameters.
CursorCaps | Indicates the hardware support that is available for cursors.
CustomVertex.PositionColored | Describes a custom vertex format structure that contains position and color information.
CustomVertex.PositionColoredTextured | Describes a custom vertex format structure that contains position, color, and one set of texture coordinates.
CustomVertex.PositionNormal | Describes a custom vertex format structure that contains position and normal data.
CustomVertex.PositionNormalColored | Describes a custom vertex format structure that contains position, color, and normal data.
CustomVertex.PositionNormalTextured | Describes a custom vertex format structure that contains position, normal data, and one set of texture coordinates.
CustomVertex.PositionOnly | Describes a custom vertex format structure that contains only position data.
CustomVertex.PositionTextured | Describes a custom vertex format structure that contains position and one set of texture coordinates.
CustomVertex.Transformed | Describes a custom vertex format structure that contains transformed vertices.
CustomVertex.TransformedColored | Describes a custom vertex format structure that contains transformed vertices and color information.
CustomVertex.TransformedColoredTextured | Describes a custom vertex format structure that contains transformed vertices, color, and one set of texture coordinates.
CustomVertex.TransformedTextured | Describes a custom vertex format structure that contains transformed vertices and one set of texture coordinates.
DeclarationTypeCaps | Indicates the type of data formats that are supported in a vertex declaration.
DegenerateItems | Indicates the index of patches and vertices that cause the PatchMesh.Validate method to fail.
DeviceCaps | Retrieves device-specific information about a device.
DeviceCreationParameters | Describes the creation parameters for a device.
DisplacementParameter | Contains mesh geometry displacement parameters.
DisplayMode | Describes the display mode.
DriverCaps | Indicates driver-specific capabilities.
EffectDefault | Manages a default effect parameter.
EffectDescription | Describes an effect object.
EffectInstance | Manages a set of default effect parameters.
EventDescription | Describes an animation event.
ExtendedMaterial | Returns material information that is saved in DirectX (.x) files.
FilterCaps | Indicates texture filter capabilities.
FontDescription | Defines the attributes of a font.
FormatList | Contains a list of formats supported by the device.
FragmentDescription | Describes an annotation used by an effect object.
FunctionDescription | Describes a function used by an effect.
GammaRamp | Contains red, green, and blue ramp data.
GlyphMetricsFloat | Contains information about the position and orientation of the corresponding glyph in the string.
ImageInformation | Contains a description of the original contents of an image file.
IndexBufferDescription | Describes an index buffer.
InterfaceTimings | Provides percentage of time processing data in the driver. These statistics may help identify cases when the driver is waiting for other resources.
IntersectInformation | Describes the intersection of a ray and a triangle.
KeyCallback | Describes a callback key for use in keyframe animation.
KeyQuaternion | Describes a quaternion key for use in keyframe animation, and specifies a quaternion value at a given time.
KeyVector3 | Describes a vector key for use in keyframe animation, and specifies a vector at a given time.
LineCaps | Defines the capabilities for line-drawing primitives.
LinePattern | Describes a line pattern.
LockedBox | Describes a locked box (volume).
Macro | Describes preprocessor definitions used by an effect object.
Material | Specifies material properties.
MeshData | Contains mesh data.
MeshOptions | Specifies the type of mesh optimization to perform.
MiscCaps | Contains miscellaneous driver primitive capabilities.
MyD3DXAllocateHierarchy | Not supported.
MyD3DXAnimationCallback | Not supported.
MyD3DXFrame | Not supported.
MyD3DXIncludeClass | Not supported.
MyD3DXLoadUserData | Not supported.
MyD3DXMeshContainer | Not supported.
MyD3DXSaveUserData | Not supported.
PaletteEntry | Specifies the color and usage of an entry in a logical palette.
ParameterDescription | Describes a parameter that is used for an effect object.
PassDescription | Describes a pass for an effect object.
PatchInformation | Contains the attributes of a patch mesh.
PipelineTimings | Provides percentage of time spent processing data in the pipeline.
PixelShaderCaps | Contains pixel shader capabilities.
PropertyDescription | Describes a property used for an effect object.
PrtSplitMeshClusterData | Contains PRT split mesh cluster data.
PrtSplitMeshVertexData | Contains PRT split mesh vertex data.
RasterCaps | Contains information about raster drawing capabilities.
RasterStatus | Describes the raster status.
RectanglePatchInformation | Describes a rectangular high-order patch.
RenderToEnvironmentDescription | Describes an off-screen render target.
RenderToSurfaceDescription | Describes a render surface.
ResourceManager | Contains resource manager usage statistics.
ResourceStats | Contains information about the resource manager.
ScaleRotateTranslate | Encapsulates scale, rotate and translate structures.
Semantic | Maps a parameter to vertex or pixel shader registers.
ShadeCaps | Defines shading operation capabilities.
ShaderConstantInformation | Contains shader constant information.
ShaderConstantTable | Contains the shader constant table that is embedded inside the shader.
ShaderDebugInformation | Contains shader debug information.
ShaderFileInformation | Contains information about the shader file.
ShaderInstructionInformation | Contains data for retrieving shader instruction information.
ShaderStructMemberInformation | Contains the shader structure member information.
ShaderTypeInformation | Contains shader type information.
ShaderVariableInformation | Contains shader variable information.
ShaderWriteInformation | Contains the shader write information.
SkinMesh | Contains skin information and mesh data.
SphericalHarmonicMaterial | Contains SH PRT material characteristics.
StageTimings | Provides percentage of time spent processing shader data.
StencilCaps | Contains flags that specify supported stencil-buffer operations.
SurfaceDescription | Describes a surface.
TechniqueDescription | Describes a technique used by an effect.
TextureCaps | Contains miscellaneous texture-mapping capabilities.
TextureOperationCaps | Contains values that describe the texture operations that the current device supports.
TextureRequirements | Contains texture creation parameters.
TrackDescription | Describes an animation track and specifies its weight and speed at a given time.
TrianglePatchInformation | Describes a triangular high-order patch.
UVAtlasOutput | Contains texture atlas data returned from UVAtlas member methods.
ValidateDeviceParams | Describes the number of passes and the result code returned from a ValidateDevice call.
VertexBufferDescription | Describes a vertex buffer.
VertexCache | Defines vertex cache optimization hints.
VertexElement | Defines input vertex data to the pipeline.
VertexFormatCaps | Specifies the flexible vertex format (FVF) capabilities supported by a device.
VertexProcessingCaps | Describes vertex processing capabilities.
VertexShaderCaps | Describes vertex shader capabilities.
VertexStats | Reports the number of triangles that have been processed and clipped by the runtime's software vertex processing.
Viewport | Defines the window dimensions of a render target surface onto which a 3-D volume projects.
VolumeDescription | Describes a volume.
VolumeTextureRequirements | Contains volume texture creation parameters.
WeldEpsilons | Specifies a per-vertex value that is used to weld similar vertices together.

Delegates

Fill2DTextureCallback | Represents the method that handles the FillTexture(Texture,Fill2DTextureCallback) call.
Fill3DTextureCallback | Represents the method that handles the FillTexture(VolumeTexture,Fill3DTextureCallback) or FillTexture(CubeTexture,Fill3DTextureCallback) call.
HandleAnimationCallback | This delegate is used to handle callbacks triggered by KeyCallbacks in an animation track.
ImtSignalCallback | Callback method for IntegratedMetricTensor.ComputeFromSignal.
PercentageCompleteCallback | Callback for methods associated with UVAtlas and PRT operations.

Related Topics

  • Microsoft.DirectX


AdapterInformation Class (Microsoft.DirectX.Direct3D)

AdapterInformation Class

Manipulates adapter information.

Definition

Visual Basic NotInheritable Public Class AdapterInformation
Inherits Object
C# | public sealed class AdapterInformation : Object
C++ | public ref class AdapterInformation sealed : Object
JScript | public final class AdapterInformation extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
GetWhqlInformation | Retrieves adapter information that includes Windows Hardware Quality Labs (WHQL) information.

Properties

Property | Description
Adapter | Retrieves the adapter ordinal number.
CurrentDisplayMode | Retrieves the current display mode.
Information | Retrieves information about the current adapter.
SupportedDisplayModes | Returns a collection of supported display modes for the current adapter.

Inheritance Hierarchy

Object Leave Site
AdapterInformation

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AdapterInformation.Equals(Object) Method (Microsoft.DirectX.Direct3D)

AdapterInformation.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


AdapterInformation.GetHashCode() Method (Microsoft.DirectX.Direct3D)

AdapterInformation.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


AdapterInformation.GetWhqlInformation() Method (Microsoft.DirectX.Direct3D)

AdapterInformation.GetWhqlInformation Method

Retrieves adapter information that includes Windows Hardware Quality Labs (WHQL) information.

Definition

Visual Basic | Public Function GetWhqlInformation() As AdapterDetails
C# | public AdapterDetails GetWhqlInformation();
C++ public:
AdapterDetails GetWhqlInformation();
JScript | public function GetWhqlInformation() : AdapterDetails;

Return Value

Microsoft.DirectX.Direct3D.AdapterDetails
An AdapterDetails structure that contains the adapter information.

Remarks

This method returns information about a specific hardware device and its drivers.


AdapterInformation.Adapter Property (Microsoft.DirectX.Direct3D)

AdapterInformation.Adapter Property

Retrieves the adapter ordinal number.

Definition

Visual Basic | Public ReadOnly Property Adapter As Integer
C# | public int Adapter { get; }
C++ public:
property int Adapter {
int get();
}
JScript | public function get Adapter() : int

Property Value

System.Int32
Integer that specifies the adapter to retrieve.

This property is read-only.


AdapterInformation.CurrentDisplayMode Property (Microsoft.DirectX.Direct3D)

AdapterInformation.CurrentDisplayMode Property

Retrieves the current display mode.

Definition

Visual Basic | Public ReadOnly Property CurrentDisplayMode As DisplayMode
C# | public DisplayMode CurrentDisplayMode { get; }
C++ public:
property DisplayMode CurrentDisplayMode {
DisplayMode get();
}
JScript | public function get CurrentDisplayMode() : DisplayMode

Property Value

Microsoft.DirectX.Direct3D.DisplayMode
A DisplayMode structure that represents the current display mode.

This property is read-only.


AdapterInformation.Information Property (Microsoft.DirectX.Direct3D)

AdapterInformation.Information Property

Retrieves information about the current adapter.

Definition

Visual Basic | Public ReadOnly Property Information As AdapterDetails
C# | public AdapterDetails Information { get; }
C++ public:
property AdapterDetails Information {
AdapterDetails get();
}
JScript | public function get Information() : AdapterDetails

Property Value

Microsoft.DirectX.Direct3D.AdapterDetails
An AdapterDetails structure that represents the current adapter information.

This property is read-only.


AdapterInformation.SupportedDisplayModes Property (Microsoft.DirectX.Direct3D)

AdapterInformation.SupportedDisplayModes Property

Returns a collection of supported display modes for the current adapter.

Definition

Visual Basic | Public ReadOnly Property SupportedDisplayModes As DisplayModeCollection
C# | public DisplayModeCollection SupportedDisplayModes { get; }
C++ public:
property DisplayModeCollection^ SupportedDisplayModes {
DisplayModeCollection^ get();
}
JScript | public function get SupportedDisplayModes() : DisplayModeCollection

Property Value

Microsoft.DirectX.Direct3D.DisplayModeCollection
A DisplayModeCollection class containing DisplayMode structures that represent the supported display modes for the adapter.

This property is read-only.


AdapterListCollection Class (Microsoft.DirectX.Direct3D)

AdapterListCollection Class

Manipulates a collection of adapters.

Definition

Visual Basic NotInheritable Public Class AdapterListCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class AdapterListCollection : Object, IEnumerable, IEnumerator
C++ | public ref class AdapterListCollection sealed : Object, IEnumerable, IEnumerator
JScript | public final class AdapterListCollection extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetEnumerator | Returns an enumerator that can iterate through the AdapterListCollection.
GetHashCode | Returns the hash code for the current instance.
MoveNext | Advances the enumerator to the next light.
Reset | Resets the current enumerator to point to the head of the queue.

Properties

Property | Description
Count | Retrieves the number of AdapterInformation objects in AdapterListCollection.
Current | Retrieves the current AdapterInformation object in the queue.
Default | Retrieves the default adapter.
Item | Retrieves a specific AdapterInformation object using an index value.

Inheritance Hierarchy

Object Leave Site
AdapterListCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AdapterListCollection.Equals(Object) Method (Microsoft.DirectX.Direct3D)

AdapterListCollection.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


AdapterListCollection.GetEnumerator() Method (Microsoft.DirectX.Direct3D)

AdapterListCollection.GetEnumerator Method

Returns an enumerator that can iterate through the AdapterListCollection.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator
Enumerator that can iterate through the AdapterListCollection.


AdapterListCollection.GetHashCode() Method (Microsoft.DirectX.Direct3D)

AdapterListCollection.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


AdapterListCollection.MoveNext() Method (Microsoft.DirectX.Direct3D)

AdapterListCollection.MoveNext Method

Advances the enumerator to the next light.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean
Value that is true if the move to the next item was successful, or false if it was not.


AdapterListCollection.Reset() Method (Microsoft.DirectX.Direct3D)

AdapterListCollection.Reset Method

Resets the current enumerator to point to the head of the queue.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the queue.

After Reset Leave Site is called, the cursor is undefined. Call MoveNext Leave Site initially to point to the first item in the list.


AdapterListCollection.Count Property (Microsoft.DirectX.Direct3D)

AdapterListCollection.Count Property

Retrieves the number of AdapterInformation objects in AdapterListCollection.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32
Number of AdapterInformation objects in AdapterListCollection.

This property is read-only.


AdapterListCollection.Current Property (Microsoft.DirectX.Direct3D)

AdapterListCollection.Current Property

Retrieves the current AdapterInformation object in the queue.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object
Current AdapterInformation object in the queue.

This property is read-only.


AdapterListCollection.Default Property (Microsoft.DirectX.Direct3D)

AdapterListCollection.Default Property

Retrieves the default adapter.

Definition

Visual Basic | Public ReadOnly Property Default As AdapterInformation
C# | public AdapterInformation Default { get; }
C++ public:
property AdapterInformation^ Default {
AdapterInformation^ get();
}
JScript | public function get Default() : AdapterInformation

Property Value

Microsoft.DirectX.Direct3D.AdapterInformation
An AdapterInformation object that represents the default adapter.

This property is read-only.


AdapterListCollection.Item Property (Microsoft.DirectX.Direct3D)

AdapterListCollection.Item Property

Retrieves a specific AdapterInformation object using an index value.

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal adapter As Integer _
) As AdapterInformation
C# public AdapterInformation this[
int adapter
] { get; }
C++ public:
property AdapterInformation^ default [int] {
AdapterInformation^ get(int adapter);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

adapter System.Int32
Index value of the adapter to retrieve.

Property Value

Microsoft.DirectX.Direct3D.AdapterInformation
An AdapterInformation object at the param_Int32_index.

This property is read-only.


AllocateHierarchy Class (Microsoft.DirectX.Direct3D)

AllocateHierarchy Class

Derived by the application to allocate/free frame and mesh container objects. Methods of this class are called during loading and destruction of frame hierarchies.

Definition

Visual Basic MustInherit Public Class AllocateHierarchy
Inherits Object
C# | public abstract class AllocateHierarchy : Object
C++ | public ref class AllocateHierarchy abstract : Object
JScript | public abstract class AllocateHierarchy extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AllocateHierarchy | Initializes a new instance of the AllocateHierarchy class.
CreateFrame | Requests allocation of a frame object.
CreateMeshContainer | Requests allocation of a MeshContainer object.
Finalize | Allows the AllocateHierarchy object to free resources before it is destroyed by the garbage collector.

Inheritance Hierarchy

Object Leave Site
AllocateHierarchy

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AllocateHierarchy.AllocateHierarchy() Constructor (Microsoft.DirectX.Direct3D)

AllocateHierarchy.AllocateHierarchy Constructor

Initializes a new instance of the AllocateHierarchy class.

Definition

Visual Basic | Public Sub New()
C# | public AllocateHierarchy();
C++ public:
AllocateHierarchy();
JScript | public function AllocateHierarchy();


AllocateHierarchy.CreateFrame(String) Method (Microsoft.DirectX.Direct3D)

AllocateHierarchy.CreateFrame Method

Requests allocation of a frame object.

Definition

Visual Basic MustOverride Public Function CreateFrame( _
ByVal name As String _
) As Frame
C# public abstract Frame CreateFrame(
string name
);
C++ public:
virtual Frame^ CreateFrame(
String^ name
) abstract;
JScript public abstract function CreateFrame(
name : String
) : Frame;

Parameters

name System.String
Name of the frame to create.

Return Value

Microsoft.DirectX.Direct3D.Frame
Created frame object.


AllocateHierarchy.CreateMeshContainer(String,MeshData,ExtendedMaterial[],EffectInstance[],GraphicsStream,SkinInformation) Method (Microsoft.DirectX.Direct3D)

AllocateHierarchy.CreateMeshContainer Method

Requests allocation of a MeshContainer object.

Definition

Visual Basic MustOverride Public Function CreateMeshContainer( _
ByVal name As String, _
ByVal meshData As MeshData, _
ByVal materials() As ExtendedMaterial, _
ByVal effectInstances() As EffectInstance, _
ByVal adjacency As GraphicsStream, _
ByVal skinInfo As SkinInformation _
) As MeshContainer
C# public abstract MeshContainer CreateMeshContainer(
string name,
MeshData meshData,
ExtendedMaterial[] materials,
EffectInstance[] effectInstances,
GraphicsStream adjacency,
SkinInformation skinInfo
);
C++ public:
virtual MeshContainer^ CreateMeshContainer(
String^ name,
MeshData meshData,
array<ExtendedMaterial>^ materials,
array<EffectInstance>^ effectInstances,
GraphicsStream^ adjacency,
SkinInformation^ skinInfo
) abstract;
JScript public abstract function CreateMeshContainer(
name : String,
meshData : MeshData,
materials : ExtendedMaterial[],
effectInstances : EffectInstance[],
adjacency : GraphicsStream,
skinInfo : SkinInformation
) : MeshContainer;

Parameters

name System.String
String that represents the name of the mesh.
meshData Microsoft.DirectX.Direct3D.MeshData
Reference to a MeshData structure.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures used in the mesh.
effectInstances Microsoft.DirectX.Direct3D.EffectInstance[]
Array of EffectInstance structures used in the mesh.
adjacency Microsoft.DirectX.GraphicsStream
Array of GraphicsStream objects that represent an adjacency array for the mesh.
skinInfo Microsoft.DirectX.Direct3D.SkinInformation
Reference to the SkinInformation object, if skin data is found.

Return Value

Microsoft.DirectX.Direct3D.MeshContainer
Created MeshContainer.


AllocateHierarchy.Finalize() Method (Microsoft.DirectX.Direct3D)

AllocateHierarchy.Finalize Method

Allows the AllocateHierarchy object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~AllocateHierarchy();
C++ | !AllocateHierarchy();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


AnimationController Class (Microsoft.DirectX.Direct3D)

AnimationController Class

Controls animation functionality, connecting animation sets to the transformation frames being animated.

Definition

Visual Basic NotInheritable Public Class AnimationController
Inherits Object
Implements ICloneable, IDisposable
C# | public sealed class AnimationController : Object, ICloneable, IDisposable
C++ | public ref class AnimationController sealed : Object, ICloneable, IDisposable
JScript | public final class AnimationController extends Object implements ICloneable, IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the AnimationController object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AdvanceTime | Animates the mesh and advances the global animation time by a specified amount.
AnimationController | Initializes a new instance of the AnimationController class.
Clone | Clones, or copies, an animation controller.
Dispose | Immediately releases the unmanaged resources used by the AnimationController object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the AnimationController object to free resources before it is destroyed by the garbage collector.
GetAnimationSet | Retrieves the animation set.
GetCurrentPriorityBlend | Returns an event handle to a priority blend event that is currently running.
GetCurrentTrackEvent | Returns an event handle to the event that is currently running on the specified animation track.
GetEventDescription | Retrieves a description of a specified animation event.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetTrackAnimationSet | Retrieves the animation set for a given track.
GetTrackDescription | Retrieves the description for a track.
GetUpcomingPriorityBlend | Returns an event handle to the next priority blend event scheduled to occur after a specified event.
GetUpcomingTrackEvent | Returns an event handle to the next event scheduled to occur after a specified event on an animation track.
IsEventValid | Determines whether a specified event handle is valid and an animation event has completed.
KeyPriorityBlend | Sets blending event keys for the specified animation track.
KeyTrackEnable | Sets an event key that enables or disables an animation track.
KeyTrackPosition | Sets an event key that changes the local time of an animation track.
KeyTrackSpeed | Sets an event key that changes the local time of an animation track.
KeyTrackWeight | Sets an event key that changes the weight of an animation track.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.AnimationController.Disposing event when called from within a derived class.
RegisterAnimationOutput | Adds an animation output to the animation controller and registers objects for scale, rotate, and translate (SRT) transformations.
RegisterAnimationSet | Adds an animation set to the animation controller.
ResetTime | Resets the global animation time to zero. Any pending events retain their original schedules, but in the new time frame.
SetTrackAnimationSet | Applies the animation set to the specified track.
SetTrackDescription | Sets the track description.
SetTrackEnable | Enables or disables a track in the animation controller.
SetTrackPosition | Sets the track to the specified local animation time.
SetTrackPriority | Sets the priority blending weight for the specified animation track.
SetTrackSpeed | Sets the priority blending weight for the specified animation track.
SetTrackWeight | Sets the track weight, which is used to determine how to blend multiple tracks together.
UnkeyAllPriorityBlends | Removes all scheduled priority blend events from the animation controller.
UnkeyAllTrackEvents | Removes all events from a specified animation track.
UnkeyEvent | Removes a specified event from an animation track, preventing the event from being run.
UnregisterAnimationOutput | Removes an animation output from the animation controller.
UnregisterAnimationSet | Removes an animation set from the animation controller.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this AnimationController object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
ValidateEvent | Determines whether a specified event handle is valid and the animation event has completed.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
MaxNumberAnimationOutputs | Retrieves the maximum number of animation outputs the controller can support.
MaxNumberAnimationSets | Retrieves the maximum number of animation sets the controller can support.
MaxNumberEvents | Retrieves the maximum number of events the controller can support.
MaxNumberTracks | Retrieves the maximum number of tracks in the mixer.
NumberAnimationSets | Returns the number of animation sets currently registered in the animation controller.
PriorityBlend | Retrieves or sets the track blending weight.
Time | Retrieves the local animation time.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXAnimationController interface pointer.

Inheritance Hierarchy

Object Leave Site
AnimationController

Remarks

The methods of this class mix multiple animations and modify blending parameters over time to enable smooth transitions and other effects.

An AnimationController is typically obtained from a valid DirectX (.x) file loaded into an AnimationRootFrame. This structure has an AnimationController property that exposes the AnimationController. The following C# code example demonstrates how to create an AnimationController from a file. The allocH variable is an instance of a class derived from AllocateHierarchy. The device variable is the current rendering Device.

[C#]
  ...
    AnimationRootFrame animRoot = new AnimationRootFrame();

    animRoot = Mesh.LoadHierarchyFromFile("tiny.x", MeshFlags.Managed, device, allocH, null);

    AnimationController animController = animRoot.AnimationController;
  ...
The AnimationController can then be used to play and manipulate the animations loaded from the file.

An AnimationController class loaded from a file typically has a number of animation tracks, each of which is identified by an index value. Using SetTrackAnimationSet, an AnimationSet (or a class derived from one) can be assigned to a track. The AnimationController class can then blend the animations in different tracks to create one smooth animation.

The AnimationController class also provides methods that allow changes to be made to each track over time. Key values that enable or disable a track (KeyTrackEnable) or change a track's speed (KeyTrackSpeed), its position in time (KeyTrackPosition), its weight (KeyTrackWeight), and its blend values (KeyPriorityBlend) can be set for specific times.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.AdvanceTime Method ()

Animates the mesh and advances the global animation time by a specified amount.

Overload List

public void AdvanceTime(double);
public void AdvanceTime(double, HandleAnimationCallback);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.AdvanceTime(Double) Method (Microsoft.DirectX.Direct3D)

AnimationController.AdvanceTime Method

Animates the mesh and advances the global animation time by a specified amount.

Definition

Visual Basic Public Sub AdvanceTime( _
ByVal timeDelta As Double _
)
C# public void AdvanceTime(
double timeDelta
);
C++ public:
void AdvanceTime(
double timeDelta
);
JScript public function AdvanceTime(
timeDelta : double
);

Parameters

timeDelta System.Double
Amount, in seconds, by which to advance the global animation time. This value must be non-negative or 0.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.AdvanceTime(Double,HandleAnimationCallback) Method (Microsoft.DirectX.Direct3D)

AnimationController.AdvanceTime Method

Animates the mesh and advances the global animation time by a specified amount.

Definition

Visual Basic Public Sub AdvanceTime( _
ByVal timeDelta As Double, _
ByVal callbackHandler As HandleAnimationCallback _
)
C# public void AdvanceTime(
double timeDelta,
HandleAnimationCallback callbackHandler
);
C++ public:
void AdvanceTime(
double timeDelta,
HandleAnimationCallback^ callbackHandler
);
JScript public function AdvanceTime(
timeDelta : double,
callbackHandler : HandleAnimationCallback
);

Parameters

timeDelta System.Double
Amount, in seconds, by which to advance the global animation time. This value must be non-negative or 0.
callbackHandler Microsoft.DirectX.Direct3D.HandleAnimationCallback
A HandleAnimationCallback user-defined animation callback handler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.AnimationController Constructor ()

Initializes a new instance of the AnimationController class.

Overload List

public AnimationController(ID3DXAnimationController);
public AnimationController(int, int, int, int);
public AnimationController(IntPtr);

Remarks

An animation controller contains methods and properties for manipulating animations.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.AnimationController(ID3DXAnimationController) Constructor (Microsoft.DirectX.Direct3D)

AnimationController.AnimationController Constructor

Initializes a new instance of the AnimationController class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXAnimationController _
)
C# public AnimationController(
ID3DXAnimationController pUnk
);
C++ public:
AnimationController(
ID3DXAnimationController pUnk
);
JScript public function AnimationController(
pUnk : ID3DXAnimationController
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationController
Unmanaged Component Object Model (COM) ID3DXAnimationController interface pointer.

Remarks

An animation controller contains methods and properties for manipulating animations.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.AnimationController(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

AnimationController.AnimationController Constructor

Initializes a new instance of the AnimationController class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public AnimationController(
IntPtr unmanagedObject
);
C++ public:
AnimationController(
IntPtr unmanagedObject
);
JScript public function AnimationController(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXAnimationController interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

An animation controller contains methods and properties for manipulating animations.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.AnimationController(Int32,Int32,Int32,Int32) Constructor (Microsoft.DirectX.Direct3D)

AnimationController.AnimationController Constructor

Initializes a new instance of the AnimationController class.

Definition

Visual Basic Public Sub New( _
ByVal maxNumberMatrices As Integer, _
ByVal maxNumberAnimationSets As Integer, _
ByVal maxNumberTracks As Integer, _
ByVal maxNumberEvents As Integer _
)
C# public AnimationController(
int maxNumberMatrices,
int maxNumberAnimationSets,
int maxNumberTracks,
int maxNumberEvents
);
C++ public:
AnimationController(
int maxNumberMatrices,
int maxNumberAnimationSets,
int maxNumberTracks,
int maxNumberEvents
);
JScript public function AnimationController(
maxNumberMatrices : int,
maxNumberAnimationSets : int,
maxNumberTracks : int,
maxNumberEvents : int
);

Parameters

maxNumberMatrices System.Int32
Maximum number of matrices that can be animated.
maxNumberAnimationSets System.Int32
Maximum number of animation sets that can be mixed.
maxNumberTracks System.Int32
Maximum number of animation sets that can be mixed simultaneously.
maxNumberEvents System.Int32
Maximum number of outstanding events that the controller will support.

Remarks

An animation controller contains methods and properties for manipulating animations.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.Clone(Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.Clone Method

Clones, or copies, an animation controller.

Definition

Visual Basic Public Function Clone( _
ByVal maxNumberAnimationOutputs As Integer, _
ByVal maxNumberAnimationSets As Integer, _
ByVal maxNumberTracks As Integer, _
ByVal maxNumberEvents As Integer _
) As AnimationController
C# public AnimationController Clone(
int maxNumberAnimationOutputs,
int maxNumberAnimationSets,
int maxNumberTracks,
int maxNumberEvents
);
C++ public:
AnimationController^ Clone(
int maxNumberAnimationOutputs,
int maxNumberAnimationSets,
int maxNumberTracks,
int maxNumberEvents
);
JScript public function Clone(
maxNumberAnimationOutputs : int,
maxNumberAnimationSets : int,
maxNumberTracks : int,
maxNumberEvents : int
) : AnimationController;

Parameters

maxNumberAnimationOutputs System.Int32
Maximum number of animation outputs the controller can support.
maxNumberAnimationSets System.Int32
Maximum number of animation sets the controller can support.
maxNumberTracks System.Int32
Maximum number of tracks the controller can support.
maxNumberEvents System.Int32
Maximum number of events the controller can support.

Return Value

Microsoft.DirectX.Direct3D.AnimationController
A cloned AnimationController object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.Dispose() Method (Microsoft.DirectX.Direct3D)

AnimationController.Dispose Method

Immediately releases the unmanaged resources used by the AnimationController object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~AnimationController();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.AnimationController.Disposed
  • Microsoft.DirectX.Direct3D.AnimationController.Disposing


AnimationController.Equals(Object) Method (Microsoft.DirectX.Direct3D)

AnimationController.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


AnimationController.Finalize() Method (Microsoft.DirectX.Direct3D)

AnimationController.Finalize Method

Allows the AnimationController object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~AnimationController();
C++ | !AnimationController();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


AnimationController.GetAnimationSet Method ()

Retrieves the animation set.

Overload List

public AnimationSet GetAnimationSet(int);
public AnimationSet GetAnimationSet(string);

Remarks

The animation controller contains an array of animation sets. This method returns one of them at the given index or animationName.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.GetAnimationSet(String) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetAnimationSet Method

Retrieves the animation set.

Definition

Visual Basic Public Function GetAnimationSet( _
ByVal animationName As String _
) As AnimationSet
C# public AnimationSet GetAnimationSet(
string animationName
);
C++ public:
AnimationSet^ GetAnimationSet(
String^ animationName
);
JScript public function GetAnimationSet(
animationName : String
) : AnimationSet;

Parameters

animationName System.String
A string that contains the name of the animation set to retrieve.

Return Value

Microsoft.DirectX.Direct3D.AnimationSet
An AnimationSet object at the given animationName.

Remarks

The animation controller contains an array of animation sets. This method returns one of them at the given index or animationName.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.GetAnimationSet(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetAnimationSet Method

Retrieves the animation set.

Definition

Visual Basic Public Function GetAnimationSet( _
ByVal index As Integer _
) As AnimationSet
C# public AnimationSet GetAnimationSet(
int index
);
C++ public:
AnimationSet^ GetAnimationSet(
int index
);
JScript public function GetAnimationSet(
index : int
) : AnimationSet;

Parameters

index System.Int32
An integer that represent the index of the animation set to retrieve.

Return Value

Microsoft.DirectX.Direct3D.AnimationSet
An AnimationSet object at the given index.

Remarks

The animation controller contains an array of animation sets. This method returns one of them at the given index or animationName.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.GetCurrentPriorityBlend() Method (Microsoft.DirectX.Direct3D)

AnimationController.GetCurrentPriorityBlend Method

Returns an event handle to a priority blend event that is currently running.

Definition

Visual Basic | Public Function GetCurrentPriorityBlend() As Integer
C# | public int GetCurrentPriorityBlend();
C++ public:
int GetCurrentPriorityBlend();
JScript | public function GetCurrentPriorityBlend() : int;

Return Value

System.Int32
Priority event. If no priority blend event is currently running, a value of 0 is returned.


AnimationController.GetCurrentTrackEvent(Int32,EventType) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetCurrentTrackEvent Method

Returns an event handle to the event that is currently running on the specified animation track.

Definition

Visual Basic Public Function GetCurrentTrackEvent( _
ByVal track As Integer, _
ByVal eventType As EventType _
) As Integer
C# public int GetCurrentTrackEvent(
int track,
EventType eventType
);
C++ public:
int GetCurrentTrackEvent(
int track,
EventType eventType
);
JScript public function GetCurrentTrackEvent(
track : int,
eventType : EventType
) : int;

Parameters

track System.Int32
Track identifier.
eventType Microsoft.DirectX.Direct3D.EventType
Type of event to query.

Return Value

System.Int32
Event currently running on the specified track. If no event is running on the specified track, a value of 0 is returned.


AnimationController.GetEventDescription(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetEventDescription Method

Retrieves a description of a specified animation event.

Definition

Visual Basic Public Function GetEventDescription( _
ByVal eventHandle As Integer _
) As EventDescription
C# public EventDescription GetEventDescription(
int eventHandle
);
C++ public:
EventDescription GetEventDescription(
int eventHandle
);
JScript public function GetEventDescription(
eventHandle : int
) : EventDescription;

Parameters

eventHandle System.Int32
Event handle to the animation event to describe.

Return Value

Microsoft.DirectX.Direct3D.EventDescription
An EventDescription structure that contains a description of the animation event.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.GetHashCode() Method (Microsoft.DirectX.Direct3D)

AnimationController.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


AnimationController.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXAnimationController, which allows unmanaged COM clients to create an instance of the managed AnimationController class. Not supported.


AnimationController.GetTrackAnimationSet(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetTrackAnimationSet Method

Retrieves the animation set for a given track.

Definition

Visual Basic Public Function GetTrackAnimationSet( _
ByVal track As Integer _
) As AnimationSet
C# public AnimationSet GetTrackAnimationSet(
int track
);
C++ public:
AnimationSet^ GetTrackAnimationSet(
int track
);
JScript public function GetTrackAnimationSet(
track : int
) : AnimationSet;

Parameters

track System.Int32
Track identifier.

Return Value

Microsoft.DirectX.Direct3D.AnimationSet
An AnimationSet class for the given track.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.GetTrackDescription(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetTrackDescription Method

Retrieves the description for a track.

Definition

Visual Basic Public Function GetTrackDescription( _
ByVal trackNumber As Integer _
) As TrackDescription
C# public TrackDescription GetTrackDescription(
int trackNumber
);
C++ public:
TrackDescription GetTrackDescription(
int trackNumber
);
JScript public function GetTrackDescription(
trackNumber : int
) : TrackDescription;

Parameters

trackNumber System.Int32
Track identifier.

Return Value

Microsoft.DirectX.Direct3D.TrackDescription
A TrackDescription structure.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.GetUpcomingPriorityBlend(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetUpcomingPriorityBlend Method

Returns an event handle to the next priority blend event scheduled to occur after a specified event.

Definition

Visual Basic Public Function GetUpcomingPriorityBlend( _
ByVal eventHandle As Integer _
) As Integer
C# public int GetUpcomingPriorityBlend(
int eventHandle
);
C++ public:
int GetUpcomingPriorityBlend(
int eventHandle
);
JScript public function GetUpcomingPriorityBlend(
eventHandle : int
) : int;

Parameters

eventHandle System.Int32
Event handle to the specified event. If set to 0, the method returns the next scheduled priority blend event.

Return Value

System.Int32
Event handle to the next scheduled priority blend event. If no new priority blend event is scheduled, a value of 0 is returned.

Remarks

This method can be used iteratively to locate a desired priority blend event by repeatedly passing in 0 for param_Int32_eventHandle.

Note: Do not iterate further after the method returns 0.


AnimationController.GetUpcomingTrackEvent(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.GetUpcomingTrackEvent Method

Returns an event handle to the next event scheduled to occur after a specified event on an animation track.

Definition

Visual Basic Public Function GetUpcomingTrackEvent( _
ByVal track As Integer, _
ByVal eventHandle As Integer _
) As Integer
C# public int GetUpcomingTrackEvent(
int track,
int eventHandle
);
C++ public:
int GetUpcomingTrackEvent(
int track,
int eventHandle
);
JScript public function GetUpcomingTrackEvent(
track : int,
eventHandle : int
) : int;

Parameters

track System.Int32
Track identifier.
eventHandle System.Int32
Event handle to the specified event. If set to 0, the method returns the next scheduled event.

Return Value

System.Int32
Event handle to the next event scheduled to run on the specified track. If no new event is scheduled, a value of 0 is returned.

Remarks

This method can be used iteratively to locate a desired priority blend event by repeatedly passing in 0 for param_Int32_eventHandle.

Note: Do not iterate further after the method returns 0.


AnimationController.IsEventValid Method ()

Determines whether a specified event handle is valid and an animation event has completed.

Overload List

public bool IsEventValid(int);
public bool IsEventValid(int, out int);

Remarks

This method indicates whether an event handle is valid even if the event is still running.


AnimationController.IsEventValid(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.IsEventValid Method

Determines whether a specified event handle is valid and an animation event has completed.

Definition

Visual Basic Public Function IsEventValid( _
ByVal eventHandle As Integer _
) As Boolean
C# public bool IsEventValid(
int eventHandle
);
C++ public:
bool IsEventValid(
int eventHandle
);
JScript public function IsEventValid(
eventHandle : int
) : boolean;

Parameters

eventHandle System.Int32
Event handle to the animation event.

Return Value

System.Boolean
Returns true if the method succeeds; false if it fails.

Remarks

This method indicates whether an event handle is valid even if the event is still running.


AnimationController.IsEventValid(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.IsEventValid Method

Determines whether a specified event handle is valid and an animation event has completed.

Definition

Visual Basic Public Function IsEventValid( _
ByVal eventHandle As Integer, _
ByRef result As Integer _
) As Boolean
C# public bool IsEventValid(
int eventHandle,
out int result
);
C++ public:
bool IsEventValid(
int eventHandle,
[Out] int% result
);
JScript public function IsEventValid(
eventHandle : int,
result : int
) : boolean;

Parameters

eventHandle System.Int32
Event handle to the animation event.
result System.Int32
HRESULT code passed back from the method.

Return Value

System.Boolean
Returns true if the method succeeds; false if it fails.

Remarks

This method indicates whether an event handle is valid even if the event is still running.


AnimationController.KeyPriorityBlend(Single,Double,Double,TransitionType) Method (Microsoft.DirectX.Direct3D)

AnimationController.KeyPriorityBlend Method

Sets blending event keys for the specified animation track.

Definition

Visual Basic Public Function KeyPriorityBlend( _
ByVal newBlendWeight As Single, _
ByVal startTime As Double, _
ByVal duration As Double, _
ByVal method As TransitionType _
) As Integer
C# public int KeyPriorityBlend(
float newBlendWeight,
double startTime,
double duration,
TransitionType method
);
C++ public:
int KeyPriorityBlend(
float newBlendWeight,
double startTime,
double duration,
TransitionType method
);
JScript public function KeyPriorityBlend(
newBlendWeight : float,
startTime : double,
duration : double,
method : TransitionType
) : int;

Parameters

newBlendWeight System.Single
Number between 0 and 1 that is used to blend tracks.
startTime System.Double
Global time at which to start the blend.
duration System.Double
Global time duration of the blend.
method Microsoft.DirectX.Direct3D.TransitionType
Transition type used for the duration of the blend. For more information, see TransitionType.

Return Value

System.Int32
Handle to the priority blend event. If one or more of the input parameters is invalid, or if no free event is available, a value of 0 is returned.

Remarks

The animation controller blends in three phases: low-priority tracks are blended first, high-priority tracks are blended second, and then the results of both are blended.

See Also

  • PriorityBlend


AnimationController.KeyTrackEnable(Int32,Boolean,Double) Method (Microsoft.DirectX.Direct3D)

AnimationController.KeyTrackEnable Method

Sets an event key that enables or disables an animation track.

Definition

Visual Basic Public Function KeyTrackEnable( _
ByVal track As Integer, _
ByVal newEnable As Boolean, _
ByVal startTime As Double _
) As Integer
C# public int KeyTrackEnable(
int track,
bool newEnable,
double startTime
);
C++ public:
int KeyTrackEnable(
int track,
bool newEnable,
double startTime
);
JScript public function KeyTrackEnable(
track : int,
newEnable : boolean,
startTime : double
) : int;

Parameters

track System.Int32
Identifier of the animation track to modify.
newEnable System.Boolean
Set to true to enable the animation track. Set to false to disable the animation track.
startTime System.Double
Global time key that specifies the global time at which the change will occur.

Return Value

System.Int32
Priority blend event. If the track is invalid, a value of 0 is returned.


AnimationController.KeyTrackPosition(Int32,Double,Double) Method (Microsoft.DirectX.Direct3D)

AnimationController.KeyTrackPosition Method

Sets an event key that changes the local time of an animation track.

Definition

Visual Basic Public Function KeyTrackPosition( _
ByVal track As Integer, _
ByVal newPosition As Double, _
ByVal startTime As Double _
) As Integer
C# public int KeyTrackPosition(
int track,
double newPosition,
double startTime
);
C++ public:
int KeyTrackPosition(
int track,
double newPosition,
double startTime
);
JScript public function KeyTrackPosition(
track : int,
newPosition : double,
startTime : double
) : int;

Parameters

track System.Int32
Identifier of the track to modify.
newPosition System.Double
New local time of the animation track.
startTime System.Double
Global time key that specifies the global time at which the change will occur.

Return Value

System.Int32
Priority blend event. If track is invalid, or if no free event is available, a value of 0 is returned.


AnimationController.KeyTrackSpeed(Int32,Single,Double,Double,TransitionType) Method (Microsoft.DirectX.Direct3D)

AnimationController.KeyTrackSpeed Method

Sets an event key that changes the local time of an animation track.

Definition

Visual Basic Public Function KeyTrackSpeed( _
ByVal track As Integer, _
ByVal newSpeed As Single, _
ByVal startTime As Double, _
ByVal duration As Double, _
ByVal method As TransitionType _
) As Integer
C# public int KeyTrackSpeed(
int track,
float newSpeed,
double startTime,
double duration,
TransitionType method
);
C++ public:
int KeyTrackSpeed(
int track,
float newSpeed,
double startTime,
double duration,
TransitionType method
);
JScript public function KeyTrackSpeed(
track : int,
newSpeed : float,
startTime : double,
duration : double,
method : TransitionType
) : int;

Parameters

track System.Int32
Identifier of the track to modify.
newSpeed System.Single
New speed of the animation track.
startTime System.Double
Global time key that specifies the global time at which the change will occur.
duration System.Double
Transition time, which specifies how long the smooth transition will take to complete.
method Microsoft.DirectX.Direct3D.TransitionType
Transition type used for transitioning between speeds. For more information, see TransitionType.

Return Value

System.Int32
Event handle to the priority blend event. If one or more of the input parameters is invalid, or if no free event is available, a value of 0 is returned.


AnimationController.KeyTrackWeight(Int32,Single,Double,Double,TransitionType) Method (Microsoft.DirectX.Direct3D)

AnimationController.KeyTrackWeight Method

Sets an event key that changes the weight of an animation track.

Definition

Visual Basic Public Function KeyTrackWeight( _
ByVal track As Integer, _
ByVal newWeight As Single, _
ByVal startTime As Double, _
ByVal duration As Double, _
ByVal method As TransitionType _
) As Integer
C# public int KeyTrackWeight(
int track,
float newWeight,
double startTime,
double duration,
TransitionType method
);
C++ public:
int KeyTrackWeight(
int track,
float newWeight,
double startTime,
double duration,
TransitionType method
);
JScript public function KeyTrackWeight(
track : int,
newWeight : float,
startTime : double,
duration : double,
method : TransitionType
) : int;

Parameters

track System.Int32
Identifier of the track to modify.
newWeight System.Single
New weight of the track.
startTime System.Double
Global time key that specifies the global time at which the change will occur.
duration System.Double
Transition time, which specifies how long the smooth transition will take to complete.
method Microsoft.DirectX.Direct3D.TransitionType
Transition type used for transitioning between weights. For more information, see TransitionType.

Return Value

System.Int32
Event handle to the priority blend event. If one or more of the input parameters is invalid, or if no free event is available, a value of 0 is returned.

Remarks

The weight of an animation track is used as a multiplier to determine how much of the current track to blend with other tracks.


AnimationController.op_Equality(AnimationController,AnimationController) Method (Microsoft.DirectX.Direct3D)

AnimationController.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As AnimationController, _
ByVal right As AnimationController _
) As Boolean
C# public static bool op_Equality(
AnimationController left,
AnimationController right
);
C++ public:
static bool operator==(
AnimationController^ left,
AnimationController^ right
);
JScript public static function op_Equality(
left : AnimationController,
right : AnimationController
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.AnimationController
The AnimationController object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.AnimationController
The AnimationController object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


AnimationController.op_Inequality(AnimationController,AnimationController) Method (Microsoft.DirectX.Direct3D)

AnimationController.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As AnimationController, _
ByVal right As AnimationController _
) As Boolean
C# public static bool op_Inequality(
AnimationController left,
AnimationController right
);
C++ public:
static bool operator!=(
AnimationController^ left,
AnimationController^ right
);
JScript public static function op_Inequality(
left : AnimationController,
right : AnimationController
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.AnimationController
The AnimationController object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.AnimationController
The AnimationController object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


AnimationController.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

AnimationController.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.AnimationController.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


AnimationController.RegisterAnimationOutput Method ()

Adds an animation output to the animation controller and registers objects for scale, rotate, and translate (SRT) transformations.

Overload List

public void RegisterAnimationOutput(AnimationOutput);
public void RegisterAnimationOutput(Frame);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.RegisterAnimationOutput(Frame) Method (Microsoft.DirectX.Direct3D)

AnimationController.RegisterAnimationOutput Method

Adds an animation output to the animation controller and registers objects for scale, rotate, and translate (SRT) transformations.

Definition

Visual Basic Public Sub RegisterAnimationOutput( _
ByVal animationFrame As Frame _
)
C# public void RegisterAnimationOutput(
Frame animationFrame
);
C++ public:
void RegisterAnimationOutput(
Frame^ animationFrame
);
JScript public function RegisterAnimationOutput(
animationFrame : Frame
);

Parameters

animationFrame Microsoft.DirectX.Direct3D.Frame
A Frame object that encapsulates a transform frame in a transformation frame hierarchy. Uses the Frame.TransformationMatrix property.

Remarks

If the animation output is already registered, animationFrame. TransformationMatrix is filled with the input transformation data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.RegisterAnimationOutput(AnimationOutput) Method (Microsoft.DirectX.Direct3D)

AnimationController.RegisterAnimationOutput Method

Adds an animation output to the animation controller and registers objects for scale, rotate, and translate (SRT) transformations.

Definition

Visual Basic Public Sub RegisterAnimationOutput( _
ByVal output As AnimationOutput _
)
C# public void RegisterAnimationOutput(
AnimationOutput output
);
C++ public:
void RegisterAnimationOutput(
AnimationOutput^ output
);
JScript public function RegisterAnimationOutput(
output : AnimationOutput
);

Parameters

output Microsoft.DirectX.Direct3D.AnimationOutput
An AnimationOutput object that encapsulates the scale, rotate, and translate (SRT) transformations objects.

Remarks

If the animation output is already registered, output. Matrix is filled with the input transformation data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.RegisterAnimationSet(AnimationSet) Method (Microsoft.DirectX.Direct3D)

AnimationController.RegisterAnimationSet Method

Adds an animation set to the animation controller.

Definition

Visual Basic Public Sub RegisterAnimationSet( _
ByVal animationSet As AnimationSet _
)
C# public void RegisterAnimationSet(
AnimationSet animationSet
);
C++ public:
void RegisterAnimationSet(
AnimationSet^ animationSet
);
JScript public function RegisterAnimationSet(
animationSet : AnimationSet
);

Parameters

animationSet Microsoft.DirectX.Direct3D.AnimationSet
The AnimationSet to add.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.ResetTime() Method (Microsoft.DirectX.Direct3D)

AnimationController.ResetTime Method

Resets the global animation time to zero. Any pending events retain their original schedules, but in the new time frame.

Definition

Visual Basic | Public Sub ResetTime()
C# | public void ResetTime();
C++ public:
void ResetTime();
JScript | public function ResetTime();

Remarks

This method is typically used when the global animation time value nears the maximum precision of DOUBLE storage, or 264 - 1.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.SetTrackAnimationSet(Int32,AnimationSet) Method (Microsoft.DirectX.Direct3D)

AnimationController.SetTrackAnimationSet Method

Applies the animation set to the specified track.

Definition

Visual Basic Public Sub SetTrackAnimationSet( _
ByVal track As Integer, _
ByVal animationSet As AnimationSet _
)
C# public void SetTrackAnimationSet(
int track,
AnimationSet animationSet
);
C++ public:
void SetTrackAnimationSet(
int track,
AnimationSet^ animationSet
);
JScript public function SetTrackAnimationSet(
track : int,
animationSet : AnimationSet
);

Parameters

track System.Int32
Identifier of the track to which the animation set is applied.
animationSet Microsoft.DirectX.Direct3D.AnimationSet
The AnimationSet to add to the track.

Remarks

This method sets the animation set to the specified track for mixing. The animation set for each track is blended according to the track weight and speed when AnimationController.AdvanceTime is called.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.SetTrackDescription(Int32,TrackDescription) Method (Microsoft.DirectX.Direct3D)

AnimationController.SetTrackDescription Method

Sets the track description.

Definition

Visual Basic Public Sub SetTrackDescription( _
ByVal trackNumber As Integer, _
ByVal value As TrackDescription _
)
C# public void SetTrackDescription(
int trackNumber,
TrackDescription value
);
C++ public:
void SetTrackDescription(
int trackNumber,
TrackDescription value
);
JScript public function SetTrackDescription(
trackNumber : int,
value : TrackDescription
);

Parameters

trackNumber System.Int32
Identifier of the track to modify.
value Microsoft.DirectX.Direct3D.TrackDescription
Description of the track.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.SetTrackEnable(Int32,Boolean) Method (Microsoft.DirectX.Direct3D)

AnimationController.SetTrackEnable Method

Enables or disables a track in the animation controller.

Definition

Visual Basic Public Sub SetTrackEnable( _
ByVal track As Integer, _
ByVal enable As Boolean _
)
C# public void SetTrackEnable(
int track,
bool enable
);
C++ public:
void SetTrackEnable(
int track,
bool enable
);
JScript public function SetTrackEnable(
track : int,
enable : boolean
);

Parameters

track System.Int32
Track identifier.
enable System.Boolean
Set to true if the track is enabled in the controller. Set to false if the track should not be mixed.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.SetTrackPosition(Int32,Double) Method (Microsoft.DirectX.Direct3D)

AnimationController.SetTrackPosition Method

Sets the track to the specified local animation time.

Definition

Visual Basic Public Sub SetTrackPosition( _
ByVal track As Integer, _
ByVal position As Double _
)
C# public void SetTrackPosition(
int track,
double position
);
C++ public:
void SetTrackPosition(
int track,
double position
);
JScript public function SetTrackPosition(
track : int,
position : double
);

Parameters

track System.Int32
Track identifier.
position System.Double
Local animation time value to assign to the track.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.SetTrackPriority(Int32,PriorityType) Method (Microsoft.DirectX.Direct3D)

AnimationController.SetTrackPriority Method

Sets the priority blending weight for the specified animation track.

Definition

Visual Basic Public Sub SetTrackPriority( _
ByVal track As Integer, _
ByVal priority As PriorityType _
)
C# public void SetTrackPriority(
int track,
PriorityType priority
);
C++ public:
void SetTrackPriority(
int track,
PriorityType priority
);
JScript public function SetTrackPriority(
track : int,
priority : PriorityType
);

Parameters

track System.Int32
Track identifier.
priority Microsoft.DirectX.Direct3D.PriorityType
Track priority; should be set to one of the PriorityType constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.SetTrackSpeed(Int32,Single) Method (Microsoft.DirectX.Direct3D)

AnimationController.SetTrackSpeed Method

Sets the priority blending weight for the specified animation track.

Definition

Visual Basic Public Sub SetTrackSpeed( _
ByVal track As Integer, _
ByVal speed As Single _
)
C# public void SetTrackSpeed(
int track,
float speed
);
C++ public:
void SetTrackSpeed(
int track,
float speed
);
JScript public function SetTrackSpeed(
track : int,
speed : float
);

Parameters

track System.Int32
Track identifier.
speed System.Single
Track priority; should be set to one of the constants from PriorityType.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.SetTrackWeight(Int32,Single) Method (Microsoft.DirectX.Direct3D)

AnimationController.SetTrackWeight Method

Sets the track weight, which is used to determine how to blend multiple tracks together.

Definition

Visual Basic Public Sub SetTrackWeight( _
ByVal track As Integer, _
ByVal weight As Single _
)
C# public void SetTrackWeight(
int track,
float weight
);
C++ public:
void SetTrackWeight(
int track,
float weight
);
JScript public function SetTrackWeight(
track : int,
weight : float
);

Parameters

track System.Int32
Identifier of the track for which to set the weight.
weight System.Single
Weight value.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


AnimationController.UnkeyAllPriorityBlends() Method (Microsoft.DirectX.Direct3D)

AnimationController.UnkeyAllPriorityBlends Method

Removes all scheduled priority blend events from the animation controller.

Definition

Visual Basic | Public Sub UnkeyAllPriorityBlends()
C# | public void UnkeyAllPriorityBlends();
C++ public:
void UnkeyAllPriorityBlends();
JScript | public function UnkeyAllPriorityBlends();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.UnkeyAllTrackEvents(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.UnkeyAllTrackEvents Method

Removes all events from a specified animation track.

Definition

Visual Basic Public Sub UnkeyAllTrackEvents( _
ByVal track As Integer _
)
C# public void UnkeyAllTrackEvents(
int track
);
C++ public:
void UnkeyAllTrackEvents(
int track
);
JScript public function UnkeyAllTrackEvents(
track : int
);

Parameters

track System.Int32
Identifier of the track from which to remove events.

Remarks

This method prevents the execution of all events previously scheduled on the track, and discards all data associated with those events.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.UnkeyEvent(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.UnkeyEvent Method

Removes a specified event from an animation track, preventing the event from being run.

Definition

Visual Basic Public Sub UnkeyEvent( _
ByVal eventHandle As Integer _
)
C# public void UnkeyEvent(
int eventHandle
);
C++ public:
void UnkeyEvent(
int eventHandle
);
JScript public function UnkeyEvent(
eventHandle : int
);

Parameters

eventHandle System.Int32
Event handle to the event to remove.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


AnimationController.UnregisterAnimationOutput Method ()

Removes an animation output from the animation controller.

Overload List

public void UnregisterAnimationOutput(AnimationOutput);
public void UnregisterAnimationOutput(Frame);
public void UnregisterAnimationOutput(string);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.UnregisterAnimationOutput(Frame) Method (Microsoft.DirectX.Direct3D)

AnimationController.UnregisterAnimationOutput Method

Removes an animation output from the animation controller.

Definition

Visual Basic Public Sub UnregisterAnimationOutput( _
ByVal animationFrame As Frame _
)
C# public void UnregisterAnimationOutput(
Frame animationFrame
);
C++ public:
void UnregisterAnimationOutput(
Frame^ animationFrame
);
JScript public function UnregisterAnimationOutput(
animationFrame : Frame
);

Parameters

animationFrame Microsoft.DirectX.Direct3D.Frame
A Frame object to remove.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.UnregisterAnimationOutput(AnimationOutput) Method (Microsoft.DirectX.Direct3D)

AnimationController.UnregisterAnimationOutput Method

Removes an animation output from the animation controller.

Definition

Visual Basic Public Sub UnregisterAnimationOutput( _
ByVal output As AnimationOutput _
)
C# public void UnregisterAnimationOutput(
AnimationOutput output
);
C++ public:
void UnregisterAnimationOutput(
AnimationOutput^ output
);
JScript public function UnregisterAnimationOutput(
output : AnimationOutput
);

Parameters

output Microsoft.DirectX.Direct3D.AnimationOutput
An AnimationOutput object to remove.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.UnregisterAnimationOutput(String) Method (Microsoft.DirectX.Direct3D)

AnimationController.UnregisterAnimationOutput Method

Removes an animation output from the animation controller.

Definition

Visual Basic Public Sub UnregisterAnimationOutput( _
ByVal name As String _
)
C# public void UnregisterAnimationOutput(
string name
);
C++ public:
void UnregisterAnimationOutput(
String^ name
);
JScript public function UnregisterAnimationOutput(
name : String
);

Parameters

name System.String
A string that represents the name of the animation output to remove.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.UnregisterAnimationSet(AnimationSet) Method (Microsoft.DirectX.Direct3D)

AnimationController.UnregisterAnimationSet Method

Removes an animation set from the animation controller.

Definition

Visual Basic Public Sub UnregisterAnimationSet( _
ByVal animationSet As AnimationSet _
)
C# public void UnregisterAnimationSet(
AnimationSet animationSet
);
C++ public:
void UnregisterAnimationSet(
AnimationSet^ animationSet
);
JScript public function UnregisterAnimationSet(
animationSet : AnimationSet
);

Parameters

animationSet Microsoft.DirectX.Direct3D.AnimationSet
The AnimationSet to remove.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested item was not found.


AnimationController.UpdateUnmanagedPointer(ID3DXAnimationController) Method (Microsoft.DirectX.Direct3D)

AnimationController.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this AnimationController object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXAnimationController _
)
C# public void UpdateUnmanagedPointer(
ID3DXAnimationController pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXAnimationController pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXAnimationController
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationController
Pointer to the ID3DXAnimationController structure used to update the unmanaged pointer for this AnimationController object.


AnimationController.ValidateEvent(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationController.ValidateEvent Method

Determines whether a specified event handle is valid and the animation event has completed.

Definition

Visual Basic Public Sub ValidateEvent( _
ByVal eventHandle As Integer _
)
C# public void ValidateEvent(
int eventHandle
);
C++ public:
void ValidateEvent(
int eventHandle
);
JScript public function ValidateEvent(
eventHandle : int
);

Parameters

eventHandle System.Int32
Event handle to the animation event.

Remarks

This method indicates whether an event handle is valid even if the event is still running.

Exceptions
Direct3DXException The event handle is invalid and/or the event has completed.


AnimationController.Disposed Property (Microsoft.DirectX.Direct3D)

AnimationController.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


AnimationController.MaxNumberAnimationOutputs Property (Microsoft.DirectX.Direct3D)

AnimationController.MaxNumberAnimationOutputs Property

Retrieves the maximum number of animation outputs the controller can support.

Definition

Visual Basic | Public ReadOnly Property MaxNumberAnimationOutputs As Integer
C# | public int MaxNumberAnimationOutputs { get; }
C++ public:
property int MaxNumberAnimationOutputs {
int get();
}
JScript | public function get MaxNumberAnimationOutputs() : int

Property Value

System.Int32
Maximum number of animation outputs.

This property is read-only.

See Also

  • MaxNumberAnimationSets
  • MaxNumberEvents
  • MaxNumberTracks


AnimationController.MaxNumberAnimationSets Property (Microsoft.DirectX.Direct3D)

AnimationController.MaxNumberAnimationSets Property

Retrieves the maximum number of animation sets the controller can support.

Definition

Visual Basic | Public ReadOnly Property MaxNumberAnimationSets As Integer
C# | public int MaxNumberAnimationSets { get; }
C++ public:
property int MaxNumberAnimationSets {
int get();
}
JScript | public function get MaxNumberAnimationSets() : int

Property Value

System.Int32
Maximum number of animation sets.

This property is read-only.


AnimationController.MaxNumberEvents Property (Microsoft.DirectX.Direct3D)

AnimationController.MaxNumberEvents Property

Retrieves the maximum number of events the controller can support.

Definition

Visual Basic | Public ReadOnly Property MaxNumberEvents As Integer
C# | public int MaxNumberEvents { get; }
C++ public:
property int MaxNumberEvents {
int get();
}
JScript | public function get MaxNumberEvents() : int

Property Value

System.Int32
Maximum number of events.

This property is read-only.


AnimationController.MaxNumberTracks Property (Microsoft.DirectX.Direct3D)

AnimationController.MaxNumberTracks Property

Retrieves the maximum number of tracks in the mixer.

Definition

Visual Basic | Public ReadOnly Property MaxNumberTracks As Integer
C# | public int MaxNumberTracks { get; }
C++ public:
property int MaxNumberTracks {
int get();
}
JScript | public function get MaxNumberTracks() : int

Property Value

System.Int32
Maximum number of tracks.

This property is read-only.


AnimationController.NumberAnimationSets Property (Microsoft.DirectX.Direct3D)

AnimationController.NumberAnimationSets Property

Returns the number of animation sets currently registered in the animation controller.

Definition

Visual Basic | Public ReadOnly Property NumberAnimationSets As Integer
C# | public int NumberAnimationSets { get; }
C++ public:
property int NumberAnimationSets {
int get();
}
JScript | public function get NumberAnimationSets() : int

Property Value

System.Int32
An integer that represents the number of animation sets in the animation controller.

This property is read-only.

Remarks

The AnimationController contains any number of animations sets and tracks. Animation sets can be registered with RegisterAnimationSet. An AnimationController created by a call to Mesh.LoadHierarchyFromFile will automatically register loaded animation sets.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationController.PriorityBlend Property (Microsoft.DirectX.Direct3D)

AnimationController.PriorityBlend Property

Retrieves or sets the track blending weight.

Definition

Visual Basic | Public Property PriorityBlend As Single
C# | public float PriorityBlend { get; set; }
C++ public:
property float PriorityBlend {
float get();
void set(float value);
}
JScript public function get PriorityBlend() : float
public function set PriorityBlend(float);

Property Value

System.Single
Track blending weight.

This property is read/write.


AnimationController.Time Property (Microsoft.DirectX.Direct3D)

AnimationController.Time Property

Retrieves the local animation time.

Definition

Visual Basic | Public ReadOnly Property Time As Double
C# | public double Time { get; }
C++ public:
property double Time {
double get();
}
JScript | public function get Time() : double

Property Value

System.Double
Local animation time.

This property is read-only.


AnimationController.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

AnimationController.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXAnimationController interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXAnimationController
C# | public ID3DXAnimationController UnmanagedComPointer { get; }
C++ public:
property ID3DXAnimationController UnmanagedComPointer {
ID3DXAnimationController get();
}
JScript | public function get UnmanagedComPointer() : ID3DXAnimationController

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationController
Unmanaged ID3DXAnimationController interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


AnimationController.Disposing Event (Microsoft.DirectX.Direct3D)

AnimationController.Disposing Event

Occurs when the Dispose method is called or when the AnimationController object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.AnimationController.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the AnimationController object indicates whether that object has been disposed.


AnimationOutput Class (Microsoft.DirectX.Direct3D)

AnimationOutput Class

Encapsulates matrix, scale, rotate, and translate (SRT) transformation objects.

Definition

Visual Basic Public Class AnimationOutput
Inherits Object
Implements IDisposable
C# | public class AnimationOutput : Object, IDisposable
C++ | public ref class AnimationOutput : Object, IDisposable
JScript | public class AnimationOutput extends Object implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AnimationOutput | Initializes a new instance of the AnimationOutput class.
Dispose | Immediately releases the unmanaged resources used by the AnimationOutput object.
Finalize | Allows the AnimationOutput object to free resources before it is destroyed by the garbage collector.

Properties

Property | Description
Matrix | Retrieves the matrix output for the animation.
Name | Retrieves the name of the animation output.
Rotation | Retrieves the rotation output for the animation.
Scale | Retrieves the scale output for the animation.
Translation | Retrieves the translation output for the animation.

Inheritance Hierarchy

Object Leave Site
AnimationOutput

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • AnimationController

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.AnimationOutput(String,AnimationOutputFlags) Constructor (Microsoft.DirectX.Direct3D)

AnimationOutput.AnimationOutput Constructor

Initializes a new instance of the AnimationOutput class.

Definition

Visual Basic Public Sub New( _
ByVal name As String, _
ByVal flags As AnimationOutputFlags _
)
C# public AnimationOutput(
string name,
AnimationOutputFlags flags
);
C++ public:
AnimationOutput(
String^ name,
AnimationOutputFlags flags
);
JScript public function AnimationOutput(
name : String,
flags : AnimationOutputFlags
);

Parameters

name System.String
Name of the animation output.
flags Microsoft.DirectX.Direct3D.AnimationOutputFlags
One or more values of the AnimationOutputFlags enumeration that specify which outputs to receive.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Dispose() Method (Microsoft.DirectX.Direct3D)

AnimationOutput.Dispose Method

Immediately releases the unmanaged resources used by the AnimationOutput object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~AnimationOutput();
JScript | public override function Dispose();


AnimationOutput.Finalize() Method (Microsoft.DirectX.Direct3D)

AnimationOutput.Finalize Method

Allows the AnimationOutput object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~AnimationOutput();
C++ | !AnimationOutput();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


AnimationOutput.Matrix Property (Microsoft.DirectX.Direct3D)

AnimationOutput.Matrix Property

Retrieves the matrix output for the animation.

Definition

Visual Basic | Public ReadOnly Property Matrix As Matrix
C# | public Matrix Matrix { get; }
C++ public:
property Matrix Matrix {
Matrix get();
}
JScript | public function get Matrix() : Matrix

Property Value

Microsoft.DirectX.Matrix
A Matrix object that contains the animation's matrix transformation data.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Name Property (Microsoft.DirectX.Direct3D)

AnimationOutput.Name Property

Retrieves the name of the animation output.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
A string that represents the name of the animation output.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Rotation Property (Microsoft.DirectX.Direct3D)

AnimationOutput.Rotation Property

Retrieves the rotation output for the animation.

Definition

Visual Basic | Public ReadOnly Property Rotation As Quaternion
C# | public Quaternion Rotation { get; }
C++ public:
property Quaternion Rotation {
Quaternion get();
}
JScript | public function get Rotation() : Quaternion

Property Value

Microsoft.DirectX.Quaternion
A Quaternion object that contains the animation's rotation data.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Scale Property (Microsoft.DirectX.Direct3D)

AnimationOutput.Scale Property

Retrieves the scale output for the animation.

Definition

Visual Basic | Public ReadOnly Property Scale As Vector3
C# | public Vector3 Scale { get; }
C++ public:
property Vector3 Scale {
Vector3 get();
}
JScript | public function get Scale() : Vector3

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the animation's scale data.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationOutput.Translation Property (Microsoft.DirectX.Direct3D)

AnimationOutput.Translation Property

Retrieves the translation output for the animation.

Definition

Visual Basic | Public ReadOnly Property Translation As Vector3
C# | public Vector3 Translation { get; }
C++ public:
property Vector3 Translation {
Vector3 get();
}
JScript | public function get Translation() : Vector3

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the animation's translation data.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationSet Class (Microsoft.DirectX.Direct3D)

AnimationSet Class

Encapsulates the minimum functionality required of an animation set by an animation controller.

Advanced users might want to implement this class themselves to suit their specialized needs. For most users, however, the derived CompressedAnimationSet and KeyframedAnimationSet classes should suffice.

Definition

Visual Basic Public Class AnimationSet
Inherits Object
Implements IDisposable
C# | public class AnimationSet : Object, IDisposable
C++ | public ref class AnimationSet : Object, IDisposable
JScript | public class AnimationSet extends Object implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the AnimationSet object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
AnimationSet | Initializes a new instance of the AnimationSet class.
Dispose | Immediately releases the unmanaged resources used by the AnimationSet object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the AnimationSet object to free resources before it is destroyed by the garbage collector.
GetAnimationIndex | Retrieves the index of an animation, given its name.
GetAnimationName | Retrieves the name of an animation, given its index.
GetCallback | Retrieves information about a specific callback in an animation set.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPeriodicPosition | Returns the time position in the local timeframe of an animation set.
GetScaleRotateTranslate | Retrieves the scale, rotate, and translate (SRT) values of an animation set.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.AnimationSet.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this AnimationSet object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Name | Retrieves the name of an animation set.
NumberAnimations | Retrieves a value that indicates the number of animations in the animation set.
Period | Retrieves the period of an animation set.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXAnimationSet interface pointer.

Inheritance Hierarchy

Object Leave Site
AnimationSet
CompressedAnimationSet
KeyframedAnimationSet

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AnimationSet.AnimationSet Constructor ()

Initializes a new instance of the AnimationSet class.

Overload List

public AnimationSet(ID3DXAnimationSet);
public AnimationSet(IntPtr);


AnimationSet.AnimationSet(ID3DXAnimationSet) Constructor (Microsoft.DirectX.Direct3D)

AnimationSet.AnimationSet Constructor

Initializes a new instance of the AnimationSet class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXAnimationSet _
)
C# public AnimationSet(
ID3DXAnimationSet pUnk
);
C++ public:
AnimationSet(
ID3DXAnimationSet pUnk
);
JScript public function AnimationSet(
pUnk : ID3DXAnimationSet
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationSet
Unmanaged Component Object Model (COM) ID3DXAnimationSet interface pointer.


AnimationSet.AnimationSet(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

AnimationSet.AnimationSet Constructor

Initializes a new instance of the AnimationSet class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public AnimationSet(
IntPtr unmanagedObject
);
C++ public:
AnimationSet(
IntPtr unmanagedObject
);
JScript public function AnimationSet(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXAnimationSet interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


AnimationSet.Dispose() Method (Microsoft.DirectX.Direct3D)

AnimationSet.Dispose Method

Immediately releases the unmanaged resources used by the AnimationSet object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~AnimationSet();
JScript | public override function Dispose();

Applies To

CompressedAnimationSet, KeyframedAnimationSet

See Also

  • Microsoft.DirectX.Direct3D.AnimationSet.Disposed
  • Microsoft.DirectX.Direct3D.AnimationSet.Disposing


AnimationSet.Equals(Object) Method (Microsoft.DirectX.Direct3D)

AnimationSet.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Finalize() Method (Microsoft.DirectX.Direct3D)

AnimationSet.Finalize Method

Allows the AnimationSet object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~AnimationSet();
C++ | !AnimationSet();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetAnimationIndex(String) Method (Microsoft.DirectX.Direct3D)

AnimationSet.GetAnimationIndex Method

Retrieves the index of an animation, given its name.

Definition

Visual Basic Public Function GetAnimationIndex( _
ByVal name As String _
) As Integer
C# public int GetAnimationIndex(
string name
);
C++ public:
int GetAnimationIndex(
String^ name
);
JScript public function GetAnimationIndex(
name : String
) : int;

Parameters

name System.String
Animation name.

Return Value

System.Int32
Returns the index of the named animation; otherwise, throws a Direct3DXException.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetAnimationName(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationSet.GetAnimationName Method

Retrieves the name of an animation, given its index.

Definition

Visual Basic Public Function GetAnimationName( _
ByVal index As Integer _
) As String
C# public string GetAnimationName(
int index
);
C++ public:
String^ GetAnimationName(
int index
);
JScript public function GetAnimationName(
index : int
) : String;

Parameters

index System.Int32
Animation index.

Return Value

System.String
Returns a string that contains the animation name; otherwise, throws a Direct3DXException.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetCallback(Double,CallbackSearchFlags) Method (Microsoft.DirectX.Direct3D)

AnimationSet.GetCallback Method

Retrieves information about a specific callback in an animation set.

Definition

Visual Basic Public Function GetCallback( _
ByVal position As Double, _
ByVal flags As CallbackSearchFlags _
) As CallbackData
C# public CallbackData GetCallback(
double position,
CallbackSearchFlags flags
);
C++ public:
CallbackData GetCallback(
double position,
CallbackSearchFlags flags
);
JScript public function GetCallback(
position : double,
flags : CallbackSearchFlags
) : CallbackData;

Parameters

position System.Double
Position from which to find callbacks.
flags Microsoft.DirectX.Direct3D.CallbackSearchFlags
Callback search flags. This parameter can be set to one or more CallbackSearchFlags constants.

Return Value

Microsoft.DirectX.Direct3D.CallbackData
This method's return values are implemented by an application programmer. In general, if no error occurs, the method should return an empty structure; otherwise, it should throw an exception. For more information, see DirectXException.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetHashCode() Method (Microsoft.DirectX.Direct3D)

AnimationSet.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

AnimationSet.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXAnimationSet, which allows unmanaged COM clients to create an instance of the managed AnimationSet class. Not supported.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetPeriodicPosition(Double) Method (Microsoft.DirectX.Direct3D)

AnimationSet.GetPeriodicPosition Method

Returns the time position in the local timeframe of an animation set.

Definition

Visual Basic Public Function GetPeriodicPosition( _
ByVal position As Double _
) As Double
C# public double GetPeriodicPosition(
double position
);
C++ public:
double GetPeriodicPosition(
double position
);
JScript public function GetPeriodicPosition(
position : double
) : double;

Parameters

position System.Double
Local time of the animation set.

Return Value

System.Double
Time position as measured in the timeframe of the animation set. This value is bounded by the period of the animation set.

Remarks

The time position this method returns can be used as the periodicPosition parameter of GetScaleRotateTranslate.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.GetScaleRotateTranslate(Double,Int32) Method (Microsoft.DirectX.Direct3D)

AnimationSet.GetScaleRotateTranslate Method

Retrieves the scale, rotate, and translate (SRT) values of an animation set.

Definition

Visual Basic Public Function GetScaleRotateTranslate( _
ByVal periodicPosition As Double, _
ByVal animation As Integer _
) As ScaleRotateTranslate
C# public ScaleRotateTranslate GetScaleRotateTranslate(
double periodicPosition,
int animation
);
C++ public:
ScaleRotateTranslate GetScaleRotateTranslate(
double periodicPosition,
int animation
);
JScript public function GetScaleRotateTranslate(
periodicPosition : double,
animation : int
) : ScaleRotateTranslate;

Parameters

periodicPosition System.Double
Position of the animation set; can be obtained by calling GetPeriodicPosition.
animation System.Int32
Animation index.

Return Value

Microsoft.DirectX.Direct3D.ScaleRotateTranslate
Returns a ScaleRotateTranslate structure.

Applies To

CompressedAnimationSet, KeyframedAnimationSet

See Also

  • GetPeriodicPosition


AnimationSet.op_Equality(AnimationSet,AnimationSet) Method (Microsoft.DirectX.Direct3D)

AnimationSet.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As AnimationSet, _
ByVal right As AnimationSet _
) As Boolean
C# public static bool op_Equality(
AnimationSet left,
AnimationSet right
);
C++ public:
static bool operator==(
AnimationSet^ left,
AnimationSet^ right
);
JScript public static function op_Equality(
left : AnimationSet,
right : AnimationSet
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.AnimationSet
The AnimationSet object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.AnimationSet
The AnimationSet object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.op_Inequality(AnimationSet,AnimationSet) Method (Microsoft.DirectX.Direct3D)

AnimationSet.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As AnimationSet, _
ByVal right As AnimationSet _
) As Boolean
C# public static bool op_Inequality(
AnimationSet left,
AnimationSet right
);
C++ public:
static bool operator!=(
AnimationSet^ left,
AnimationSet^ right
);
JScript public static function op_Inequality(
left : AnimationSet,
right : AnimationSet
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.AnimationSet
The AnimationSet object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.AnimationSet
The AnimationSet object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

AnimationSet.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.AnimationSet.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.UpdateUnmanagedPointer(ID3DXAnimationSet) Method (Microsoft.DirectX.Direct3D)

AnimationSet.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this AnimationSet object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXAnimationSet _
)
C# public void UpdateUnmanagedPointer(
ID3DXAnimationSet pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXAnimationSet pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXAnimationSet
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationSet
Pointer to the ID3DXAnimationSet structure used to update the unmanaged pointer for this AnimationSet object.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Disposed Property (Microsoft.DirectX.Direct3D)

AnimationSet.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Name Property (Microsoft.DirectX.Direct3D)

AnimationSet.Name Property

Retrieves the name of an animation set.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
Animation set name.

This property is read-only.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.NumberAnimations Property (Microsoft.DirectX.Direct3D)

AnimationSet.NumberAnimations Property

Retrieves a value that indicates the number of animations in the animation set.

Definition

Visual Basic | Public ReadOnly Property NumberAnimations As Integer
C# | public int NumberAnimations { get; }
C++ public:
property int NumberAnimations {
int get();
}
JScript | public function get NumberAnimations() : int

Property Value

System.Int32
Number of animations in the set.

This property is read-only.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Period Property (Microsoft.DirectX.Direct3D)

AnimationSet.Period Property

Retrieves the period of an animation set.

Definition

Visual Basic | Public ReadOnly Property Period As Double
C# | public double Period { get; }
C++ public:
property double Period {
double get();
}
JScript | public function get Period() : double

Property Value

System.Double
Animation set period.

This property is read-only.

Remarks

The period is the range of time in which the animation key frames are valid. For looping animations, this is the period of the loop. The application determines the time units (for example, seconds) in which the key frames are specified.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

AnimationSet.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXAnimationSet interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXAnimationSet
C# | public ID3DXAnimationSet UnmanagedComPointer { get; }
C++ public:
property ID3DXAnimationSet UnmanagedComPointer {
ID3DXAnimationSet get();
}
JScript | public function get UnmanagedComPointer() : ID3DXAnimationSet

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXAnimationSet
Unmanaged ID3DXAnimationSet interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


AnimationSet.Disposing Event (Microsoft.DirectX.Direct3D)

AnimationSet.Disposing Event

Occurs when the Dispose method is called or when the AnimationSet object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.AnimationSet.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the AnimationSet object indicates whether that object has been disposed.

Applies To

CompressedAnimationSet, KeyframedAnimationSet


BaseEffect Class (Microsoft.DirectX.Direct3D)

BaseEffect Class

Provides methods for retrieving and setting effect parameters such as constants, functions, shaders, and techniques.

Definition

Visual Basic Public Class BaseEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class BaseEffect : MarshalByRefObject, IDisposable
C++ | public ref class BaseEffect : MarshalByRefObject, IDisposable
JScript | public class BaseEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the BaseEffect object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
BaseEffect | Initializes a new instance of the BaseEffect class.
Dispose | Immediately releases the unmanaged resources used by the BaseEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the BaseEffect object to free resources before it is destroyed by the garbage collector.
GetAnnotation | Retrieves an annotation.
GetFunction | Retrieves a function.
GetFunctionDescription | Retrieves a function description.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetParameter | Retrieves a top-level parameter or a structure member parameter.
GetParameterBySemantic | Retrieves the handle of a top-level parameter or structure member parameter by looking up its semantic.
GetParameterDescription | Retrieves a parameter or annotation description.
GetParameterElement | Retrieves the EffectHandle of an array element parameter.
GetPass | Retrieves the EffectHandle of a pass.
GetPassDescription | Retrieves a pass description.
GetTechnique | Retrieves the EffectHandle of a technique.
GetTechniqueDescription | Retrieves a technique description.
GetValue | Retrieves the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.
GetValueBoolean | Retrieves a Boolean value.
GetValueBooleanArray | Retrieves an array of Boolean values.
GetValueColor | Retrieves a ColorValue structure.
GetValueColorArray | Retrieves an array of ColorValue structures.
GetValueFloat | Retrieves a floating-point value.
GetValueFloatArray | Retrieves an array of floating-point values.
GetValueInteger | Retrieves an integer.
GetValueIntegerArray | Retrieves an array of integers.
GetValueMatrix | Retrieves a nontransposed matrix.
GetValueMatrixArray | Retrieves an array of nontransposed matrices.
GetValueMatrixTranspose | Retrieves a transposed matrix.
GetValueMatrixTransposeArray | Retrieves an array of transposed matrices.
GetValuePixelShader | Retrieves a pixel shader.
GetValueString | Retrieves a string.
GetValueTexture | Retrieves a texture.
GetValueVector | Retrieves a vector.
GetValueVectorArray | Retrieves an array of vectors.
GetValueVertexShader | Retrieves a vertex shader.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.BaseEffect.Disposing event when called from within a derived class.
SetValue | Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.
SetValueTranspose | Sets a transposed matrix.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseEffect object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves an effect description.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseEffect
Effect
EffectCompiler

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BaseEffect.BaseEffect Constructor ()

Initializes a new instance of the BaseEffect class.

Overload List

public BaseEffect(ID3DXBaseEffect);
public BaseEffect(IntPtr);


BaseEffect.BaseEffect(ID3DXBaseEffect) Constructor (Microsoft.DirectX.Direct3D)

BaseEffect.BaseEffect Constructor

Initializes a new instance of the BaseEffect class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXBaseEffect _
)
C# public BaseEffect(
ID3DXBaseEffect pUnk
);
C++ public:
BaseEffect(
ID3DXBaseEffect pUnk
);
JScript public function BaseEffect(
pUnk : ID3DXBaseEffect
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseEffect
Unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer.


BaseEffect.BaseEffect(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

BaseEffect.BaseEffect Constructor

Initializes a new instance of the BaseEffect class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public BaseEffect(
IntPtr unmanagedObject
);
C++ public:
BaseEffect(
IntPtr unmanagedObject
);
JScript public function BaseEffect(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXBaseEffect interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


BaseEffect.Dispose() Method (Microsoft.DirectX.Direct3D)

BaseEffect.Dispose Method

Immediately releases the unmanaged resources used by the BaseEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~BaseEffect();
JScript | public override function Dispose();

Applies To

Effect, EffectCompiler

See Also

  • Microsoft.DirectX.Direct3D.BaseEffect.Disposed
  • Microsoft.DirectX.Direct3D.BaseEffect.Disposing


BaseEffect.Equals(Object) Method (Microsoft.DirectX.Direct3D)

BaseEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

Effect, EffectCompiler


BaseEffect.Finalize() Method (Microsoft.DirectX.Direct3D)

BaseEffect.Finalize Method

Allows the BaseEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~BaseEffect();
C++ | !BaseEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.

Applies To

Effect, EffectCompiler


BaseEffect.GetAnnotation Method ()

Retrieves an annotation.

Overload List

public EffectHandle GetAnnotation(EffectHandle, int);
public EffectHandle GetAnnotation(EffectHandle, string);

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.


BaseEffect.GetAnnotation(EffectHandle,String) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetAnnotation Method

Retrieves an annotation.

Definition

Visual Basic Public Function GetAnnotation( _
ByVal technique As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetAnnotation(
EffectHandle technique,
string name
);
C++ public:
EffectHandle^ GetAnnotation(
EffectHandle^ technique,
String^ name
);
JScript public function GetAnnotation(
technique : EffectHandle,
name : String
) : EffectHandle;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents a technique, pass, or top-level parameter.
name System.String
Annotation name.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
A EffectHandle object that specifies the annotation, or null if the annotation is not found.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.

Applies To

Effect, EffectCompiler


BaseEffect.GetAnnotation(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetAnnotation Method

Retrieves an annotation.

Definition

Visual Basic Public Function GetAnnotation( _
ByVal technique As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetAnnotation(
EffectHandle technique,
int index
);
C++ public:
EffectHandle^ GetAnnotation(
EffectHandle^ technique,
int index
);
JScript public function GetAnnotation(
technique : EffectHandle,
index : int
) : EffectHandle;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents a technique, pass, or top-level parameter.
index System.Int32
Annotation index.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
A EffectHandle object that specifies the annotation, or null if the annotation is not found.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.

Applies To

Effect, EffectCompiler


BaseEffect.GetFunction Method ()

Retrieves a function.

Overload List

public EffectHandle GetFunction(int);
public EffectHandle GetFunction(string);


BaseEffect.GetFunction(String) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetFunction Method

Retrieves a function.

Definition

Visual Basic Public Function GetFunction( _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetFunction(
string name
);
C++ public:
EffectHandle^ GetFunction(
String^ name
);
JScript public function GetFunction(
name : String
) : EffectHandle;

Parameters

name System.String
String that contains the name of the function.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
Specified EffectHandle associated with the function, or null if it is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetFunction(Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetFunction Method

Retrieves a function.

Definition

Visual Basic Public Function GetFunction( _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetFunction(
int index
);
C++ public:
EffectHandle^ GetFunction(
int index
);
JScript public function GetFunction(
index : int
) : EffectHandle;

Parameters

index System.Int32
Index of the function.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
Specified EffectHandle associated with the function, or null if it is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetFunctionDescription(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetFunctionDescription Method

Retrieves a function description.

Definition

Visual Basic Public Function GetFunctionDescription( _
ByVal shader As EffectHandle _
) As FunctionDescription
C# public FunctionDescription GetFunctionDescription(
EffectHandle shader
);
C++ public:
FunctionDescription GetFunctionDescription(
EffectHandle^ shader
);
JScript public function GetFunctionDescription(
shader : EffectHandle
) : FunctionDescription;

Parameters

shader Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that indicates the function form from which to retrieve the description.

Return Value

Microsoft.DirectX.Direct3D.FunctionDescription
A FunctionDescription structure that describes the function.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetHashCode() Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Applies To

Effect, EffectCompiler


BaseEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXBaseEffect, which allows unmanaged COM clients to create an instance of the managed BaseEffect class. Not supported.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameter Method ()

Retrieves a top-level parameter or a structure member parameter.

Overload List

public EffectHandle GetParameter(EffectHandle, int);
public EffectHandle GetParameter(EffectHandle, string);


BaseEffect.GetParameter(EffectHandle,String) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetParameter Method

Retrieves a top-level parameter or a structure member parameter.

Definition

Visual Basic Public Function GetParameter( _
ByVal constant As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetParameter(
EffectHandle constant,
string name
);
C++ public:
EffectHandle^ GetParameter(
EffectHandle^ constant,
String^ name
);
JScript public function GetParameter(
constant : EffectHandle,
name : String
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that indicates the parameter, or null for top-level parameters.
name System.String
String that contains the parameter name.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle of the specified parameter, or null if the parameter is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameter(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetParameter Method

Retrieves a top-level parameter or a structure member parameter.

Definition

Visual Basic Public Function GetParameter( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetParameter(
EffectHandle constant,
int index
);
C++ public:
EffectHandle^ GetParameter(
EffectHandle^ constant,
int index
);
JScript public function GetParameter(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that indicates the parameter, or null for top-level parameters.
index System.Int32
Parameter index.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle of the specified parameter, or null if the parameter is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameterBySemantic(EffectHandle,String) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetParameterBySemantic Method

Retrieves the handle of a top-level parameter or structure member parameter by looking up its semantic.

Definition

Visual Basic Public Function GetParameterBySemantic( _
ByVal constant As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetParameterBySemantic(
EffectHandle constant,
string name
);
C++ public:
EffectHandle^ GetParameterBySemantic(
EffectHandle^ constant,
String^ name
);
JScript public function GetParameterBySemantic(
constant : EffectHandle,
name : String
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of the parameter, or null for top-level parameters.
name System.String
String that contains the semantic name.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of the first parameter that matches the specified semantic, or null if the semantic is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameterDescription(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetParameterDescription Method

Retrieves a parameter or annotation description.

Definition

Visual Basic Public Function GetParameterDescription( _
ByVal parameter As EffectHandle _
) As ParameterDescription
C# public ParameterDescription GetParameterDescription(
EffectHandle parameter
);
C++ public:
ParameterDescription GetParameterDescription(
EffectHandle^ parameter
);
JScript public function GetParameterDescription(
parameter : EffectHandle
) : ParameterDescription;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that indicates the parameter or annotation handle.

Return Value

Microsoft.DirectX.Direct3D.ParameterDescription
Description of the specified parameter or annotation. For more information, see ParameterDescription.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetParameterElement(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetParameterElement Method

Retrieves the EffectHandle of an array element parameter.

Definition

Visual Basic Public Function GetParameterElement( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetParameterElement(
EffectHandle constant,
int index
);
C++ public:
EffectHandle^ GetParameterElement(
EffectHandle^ constant,
int index
);
JScript public function GetParameterElement(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle associated with the array.
index System.Int32
Array element index.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
Handle of the specified parameter, or null if either param_EffectHandle_constant or param_Int32_index is invalid.

Remarks

This method is used to get an element of a parameter that is an array.

Applies To

Effect, EffectCompiler


BaseEffect.GetPass Method ()

Retrieves the EffectHandle of a pass.

Overload List

public EffectHandle GetPass(EffectHandle, int);
public EffectHandle GetPass(EffectHandle, string);


BaseEffect.GetPass(EffectHandle,String) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetPass Method

Retrieves the EffectHandle of a pass.

Definition

Visual Basic Public Function GetPass( _
ByVal technique As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetPass(
EffectHandle technique,
string name
);
C++ public:
EffectHandle^ GetPass(
EffectHandle^ technique,
String^ name
);
JScript public function GetPass(
technique : EffectHandle,
name : String
) : EffectHandle;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of the parent technique.
name System.String
String that contains the name of the pass.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of the specified pass inside the specified technique, or null if the index is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetPass(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetPass Method

Retrieves the EffectHandle of a pass.

Definition

Visual Basic Public Function GetPass( _
ByVal technique As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetPass(
EffectHandle technique,
int index
);
C++ public:
EffectHandle^ GetPass(
EffectHandle^ technique,
int index
);
JScript public function GetPass(
technique : EffectHandle,
index : int
) : EffectHandle;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of the parent technique.
index System.Int32
Index for the pass.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of the specified pass inside the specified technique, or null if the index is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetPassDescription(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetPassDescription Method

Retrieves a pass description.

Definition

Visual Basic Public Function GetPassDescription( _
ByVal pass As EffectHandle _
) As PassDescription
C# public PassDescription GetPassDescription(
EffectHandle pass
);
C++ public:
PassDescription GetPassDescription(
EffectHandle^ pass
);
JScript public function GetPassDescription(
pass : EffectHandle
) : PassDescription;

Parameters

pass Microsoft.DirectX.Direct3D.EffectHandle
Pass EffectHandle.

Return Value

Microsoft.DirectX.Direct3D.PassDescription
A PassDescription of the specified pass.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetTechnique Method ()

Retrieves the EffectHandle of a technique.

Overload List

public EffectHandle GetTechnique(int);
public EffectHandle GetTechnique(string);


BaseEffect.GetTechnique(String) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetTechnique Method

Retrieves the EffectHandle of a technique.

Definition

Visual Basic Public Function GetTechnique( _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetTechnique(
string name
);
C++ public:
EffectHandle^ GetTechnique(
String^ name
);
JScript public function GetTechnique(
name : String
) : EffectHandle;

Parameters

name System.String
String that contains the technique name.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of the first technique that has the specified name, or null if the name is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetTechnique(Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetTechnique Method

Retrieves the EffectHandle of a technique.

Definition

Visual Basic Public Function GetTechnique( _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetTechnique(
int index
);
C++ public:
EffectHandle^ GetTechnique(
int index
);
JScript public function GetTechnique(
index : int
) : EffectHandle;

Parameters

index System.Int32
Technique index.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of the first technique that has the specified name, or null if the name is not found.

Applies To

Effect, EffectCompiler


BaseEffect.GetTechniqueDescription(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetTechniqueDescription Method

Retrieves a technique description.

Definition

Visual Basic Public Function GetTechniqueDescription( _
ByVal technique As EffectHandle _
) As TechniqueDescription
C# public TechniqueDescription GetTechniqueDescription(
EffectHandle technique
);
C++ public:
TechniqueDescription GetTechniqueDescription(
EffectHandle^ technique
);
JScript public function GetTechniqueDescription(
technique : EffectHandle
) : TechniqueDescription;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
Technique EffectHandle.

Return Value

Microsoft.DirectX.Direct3D.TechniqueDescription
A TechniqueDescription of the specified technique.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValue(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValue Method

Retrieves the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Function GetValue( _
ByVal parameter As EffectHandle, _
ByVal numberBytes As Integer _
) As GraphicsStream
C# public GraphicsStream GetValue(
EffectHandle parameter,
int numberBytes
);
C++ public:
GraphicsStream^ GetValue(
EffectHandle^ parameter,
int numberBytes
);
JScript public function GetValue(
parameter : EffectHandle,
numberBytes : int
) : GraphicsStream;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
numberBytes System.Int32
Number of bytes in the GraphicsStream. To skip size validation, pass in 0, provided the GraphicsStream is large enough to contain the entire parameter.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the value.

Remarks

Exceptions
InvalidCallException | The call is invalid.
BaseEffect | This method can be used in place of nearly all of the Get* calls in BaseEffect.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueBoolean(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueBoolean Method

Retrieves a Boolean value.

Definition

Visual Basic Public Function GetValueBoolean( _
ByVal parameter As EffectHandle _
) As Boolean
C# public bool GetValueBoolean(
EffectHandle parameter
);
C++ public:
bool GetValueBoolean(
EffectHandle^ parameter
);
JScript public function GetValueBoolean(
parameter : EffectHandle
) : boolean;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

System.Boolean
Boolean value.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueBooleanArray(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueBooleanArray Method

Retrieves an array of Boolean values.

Definition

Visual Basic Public Function GetValueBooleanArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Boolean()
C# public bool[] GetValueBooleanArray(
EffectHandle parameter,
int count
);
C++ public:
array<bool>^ GetValueBooleanArray(
EffectHandle^ parameter,
int count
);
JScript public function GetValueBooleanArray(
parameter : EffectHandle,
count : int
) : boolean[];

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
count System.Int32
Number of Boolean values in the returned array.

Return Value

System.Boolean[]
Array of Boolean values.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueColor(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueColor Method

Retrieves a ColorValue structure.

Definition

Visual Basic Public Function GetValueColor( _
ByVal parameter As EffectHandle _
) As ColorValue
C# public ColorValue GetValueColor(
EffectHandle parameter
);
C++ public:
ColorValue GetValueColor(
EffectHandle^ parameter
);
JScript public function GetValueColor(
parameter : EffectHandle
) : ColorValue;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle associated with the color value.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueColorArray(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueColorArray Method

Retrieves an array of ColorValue structures.

Definition

Visual Basic Public Function GetValueColorArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As ColorValue()
C# public ColorValue[] GetValueColorArray(
EffectHandle parameter,
int count
);
C++ public:
array<ColorValue>^ GetValueColorArray(
EffectHandle^ parameter,
int count
);
JScript public function GetValueColorArray(
parameter : EffectHandle,
count : int
) : ColorValue[];

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle associated with the color value array.
count System.Int32
Number of values in the returned array.

Return Value

Microsoft.DirectX.Direct3D.ColorValue[]
Array of ColorValue structures.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueFloat(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueFloat Method

Retrieves a floating-point value.

Definition

Visual Basic Public Function GetValueFloat( _
ByVal parameter As EffectHandle _
) As Single
C# public float GetValueFloat(
EffectHandle parameter
);
C++ public:
float GetValueFloat(
EffectHandle^ parameter
);
JScript public function GetValueFloat(
parameter : EffectHandle
) : float;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

System.Single
A Single Leave Site value.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueFloatArray(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueFloatArray Method

Retrieves an array of floating-point values.

Definition

Visual Basic Public Function GetValueFloatArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Single()
C# public float[] GetValueFloatArray(
EffectHandle parameter,
int count
);
C++ public:
array<float>^ GetValueFloatArray(
EffectHandle^ parameter,
int count
);
JScript public function GetValueFloatArray(
parameter : EffectHandle,
count : int
) : float[];

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
count System.Int32
Number of floating-point values in the returned array.

Return Value

System.Single[]
Array of Single Leave Site values.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueInteger(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueInteger Method

Retrieves an integer.

Definition

Visual Basic Public Function GetValueInteger( _
ByVal parameter As EffectHandle _
) As Integer
C# public int GetValueInteger(
EffectHandle parameter
);
C++ public:
int GetValueInteger(
EffectHandle^ parameter
);
JScript public function GetValueInteger(
parameter : EffectHandle
) : int;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

System.Int32
Integer.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueIntegerArray(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueIntegerArray Method

Retrieves an array of integers.

Definition

Visual Basic Public Function GetValueIntegerArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Integer()
C# public int[] GetValueIntegerArray(
EffectHandle parameter,
int count
);
C++ public:
array<int>^ GetValueIntegerArray(
EffectHandle^ parameter,
int count
);
JScript public function GetValueIntegerArray(
parameter : EffectHandle,
count : int
) : int[];

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
count System.Int32
Number of integers in the returned array.

Return Value

System.Int32[]
Array of integers.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueMatrix(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueMatrix Method

Retrieves a nontransposed matrix.

Definition

Visual Basic Public Function GetValueMatrix( _
ByVal parameter As EffectHandle _
) As Matrix
C# public Matrix GetValueMatrix(
EffectHandle parameter
);
C++ public:
Matrix GetValueMatrix(
EffectHandle^ parameter
);
JScript public function GetValueMatrix(
parameter : EffectHandle
) : Matrix;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Matrix
Nontransposed Matrix.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueMatrixArray(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueMatrixArray Method

Retrieves an array of nontransposed matrices.

Definition

Visual Basic Public Function GetValueMatrixArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Matrix()
C# public Matrix[] GetValueMatrixArray(
EffectHandle parameter,
int count
);
C++ public:
array<Matrix>^ GetValueMatrixArray(
EffectHandle^ parameter,
int count
);
JScript public function GetValueMatrixArray(
parameter : EffectHandle,
count : int
) : Matrix[];

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
count System.Int32
Number of matrices in the returned array.

Return Value

Microsoft.DirectX.Matrix[]
Nontransposed matrices.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueMatrixTranspose(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueMatrixTranspose Method

Retrieves a transposed matrix.

Definition

Visual Basic Public Function GetValueMatrixTranspose( _
ByVal parameter As EffectHandle _
) As Matrix
C# public Matrix GetValueMatrixTranspose(
EffectHandle parameter
);
C++ public:
Matrix GetValueMatrixTranspose(
EffectHandle^ parameter
);
JScript public function GetValueMatrixTranspose(
parameter : EffectHandle
) : Matrix;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Matrix
Transposed Matrix.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueMatrixTransposeArray(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueMatrixTransposeArray Method

Retrieves an array of transposed matrices.

Definition

Visual Basic Public Function GetValueMatrixTransposeArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Matrix()
C# public Matrix[] GetValueMatrixTransposeArray(
EffectHandle parameter,
int count
);
C++ public:
array<Matrix>^ GetValueMatrixTransposeArray(
EffectHandle^ parameter,
int count
);
JScript public function GetValueMatrixTransposeArray(
parameter : EffectHandle,
count : int
) : Matrix[];

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
count System.Int32
Number of matrices in the returned array.

Return Value

Microsoft.DirectX.Matrix[]
Array of transposed matrices.

Remarks

A transposed matrix contains column-major data; that is, each vector is contained in a column.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValuePixelShader(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValuePixelShader Method

Retrieves a pixel shader.

Definition

Visual Basic Public Function GetValuePixelShader( _
ByVal parameter As EffectHandle _
) As PixelShader
C# public PixelShader GetValuePixelShader(
EffectHandle parameter
);
C++ public:
PixelShader^ GetValuePixelShader(
EffectHandle^ parameter
);
JScript public function GetValuePixelShader(
parameter : EffectHandle
) : PixelShader;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Direct3D.PixelShader
A PixelShader object.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueString(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueString Method

Retrieves a string.

Definition

Visual Basic Public Function GetValueString( _
ByVal parameter As EffectHandle _
) As String
C# public string GetValueString(
EffectHandle parameter
);
C++ public:
String^ GetValueString(
EffectHandle^ parameter
);
JScript public function GetValueString(
parameter : EffectHandle
) : String;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

System.String
String identified by the effect handle param_EffectHandle_parameter.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueTexture(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueTexture Method

Retrieves a texture.

Definition

Visual Basic Public Function GetValueTexture( _
ByVal parameter As EffectHandle _
) As Texture
C# public Texture GetValueTexture(
EffectHandle parameter
);
C++ public:
Texture^ GetValueTexture(
EffectHandle^ parameter
);
JScript public function GetValueTexture(
parameter : EffectHandle
) : Texture;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueVector(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueVector Method

Retrieves a vector.

Definition

Visual Basic Public Function GetValueVector( _
ByVal parameter As EffectHandle _
) As Vector4
C# public Vector4 GetValueVector(
EffectHandle parameter
);
C++ public:
Vector4 GetValueVector(
EffectHandle^ parameter
);
JScript public function GetValueVector(
parameter : EffectHandle
) : Vector4;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Vector4
A Vector4 object.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueVectorArray(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueVectorArray Method

Retrieves an array of vectors.

Definition

Visual Basic Public Function GetValueVectorArray( _
ByVal parameter As EffectHandle, _
ByVal count As Integer _
) As Vector4()
C# public Vector4[] GetValueVectorArray(
EffectHandle parameter,
int count
);
C++ public:
array<Vector4>^ GetValueVectorArray(
EffectHandle^ parameter,
int count
);
JScript public function GetValueVectorArray(
parameter : EffectHandle,
count : int
) : Vector4[];

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
count System.Int32
Number of vectors in the returned array.

Return Value

Microsoft.DirectX.Vector4[]
Array of Vector4 objects.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.GetValueVertexShader(EffectHandle) Method (Microsoft.DirectX.Direct3D)

BaseEffect.GetValueVertexShader Method

Retrieves a vertex shader.

Definition

Visual Basic Public Function GetValueVertexShader( _
ByVal parameter As EffectHandle _
) As VertexShader
C# public VertexShader GetValueVertexShader(
EffectHandle parameter
);
C++ public:
VertexShader^ GetValueVertexShader(
EffectHandle^ parameter
);
JScript public function GetValueVertexShader(
parameter : EffectHandle
) : VertexShader;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.

Return Value

Microsoft.DirectX.Direct3D.VertexShader
A VertexShader object.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.op_Equality(BaseEffect,BaseEffect) Method (Microsoft.DirectX.Direct3D)

BaseEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As BaseEffect, _
ByVal right As BaseEffect _
) As Boolean
C# public static bool op_Equality(
BaseEffect left,
BaseEffect right
);
C++ public:
static bool operator==(
BaseEffect^ left,
BaseEffect^ right
);
JScript public static function op_Equality(
left : BaseEffect,
right : BaseEffect
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.BaseEffect
The BaseEffect object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.BaseEffect
The BaseEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

Effect, EffectCompiler


BaseEffect.op_Inequality(BaseEffect,BaseEffect) Method (Microsoft.DirectX.Direct3D)

BaseEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As BaseEffect, _
ByVal right As BaseEffect _
) As Boolean
C# public static bool op_Inequality(
BaseEffect left,
BaseEffect right
);
C++ public:
static bool operator!=(
BaseEffect^ left,
BaseEffect^ right
);
JScript public static function op_Inequality(
left : BaseEffect,
right : BaseEffect
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.BaseEffect
The BaseEffect object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.BaseEffect
The BaseEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Applies To

Effect, EffectCompiler


BaseEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

BaseEffect.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.BaseEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Applies To

Effect, EffectCompiler


BaseEffect.SetValue Method ()

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Overload List

public void SetValue(EffectHandle, BaseTexture);
public void SetValue(EffectHandle, bool);
public void SetValue(EffectHandle, bool[]);
public void SetValue(EffectHandle, ColorValue);
public void SetValue(EffectHandle, ColorValue[]);
public void SetValue(EffectHandle, GraphicsStream);
public void SetValue(EffectHandle, int);
public void SetValue(EffectHandle, int[]);
public void SetValue(EffectHandle, Matrix);
public void SetValue(EffectHandle, Matrix[]);
public void SetValue(EffectHandle, float);
public void SetValue(EffectHandle, float[]);
public void SetValue(EffectHandle, string);
public void SetValue(EffectHandle, Vector4);
public void SetValue(EffectHandle, Vector4[]);
public void SetValue(EffectHandle, void, int);

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,BaseTexture) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal texture As BaseTexture _
)
C# public void SetValue(
EffectHandle parameter,
BaseTexture texture
);
C++ public:
void SetValue(
EffectHandle^ parameter,
BaseTexture^ texture
);
JScript public function SetValue(
parameter : EffectHandle,
texture : BaseTexture
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
texture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,String) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal str As String _
)
C# public void SetValue(
EffectHandle parameter,
string str
);
C++ public:
void SetValue(
EffectHandle^ parameter,
String^ str
);
JScript public function SetValue(
parameter : EffectHandle,
str : String
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
str System.String
A String Leave Site to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Matrix[]) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValue(
EffectHandle parameter,
Matrix[] matrix
);
C++ public:
void SetValue(
EffectHandle^ parameter,
array<Matrix>^ matrix
);
JScript public function SetValue(
parameter : EffectHandle,
matrix : Matrix[]
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
matrix Microsoft.DirectX.Matrix[]
Array of Matrix structures to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Matrix) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValue(
EffectHandle parameter,
Matrix matrix
);
C++ public:
void SetValue(
EffectHandle^ parameter,
Matrix matrix
);
JScript public function SetValue(
parameter : EffectHandle,
matrix : Matrix
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
matrix Microsoft.DirectX.Matrix
A Matrix structure to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,ColorValue[]) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal color() As ColorValue _
)
C# public void SetValue(
EffectHandle parameter,
ColorValue[] color
);
C++ public:
void SetValue(
EffectHandle^ parameter,
array<ColorValue>^ color
);
JScript public function SetValue(
parameter : EffectHandle,
color : ColorValue[]
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
color Microsoft.DirectX.Direct3D.ColorValue[]
Array of ColorValue structures to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,ColorValue) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal color As ColorValue _
)
C# public void SetValue(
EffectHandle parameter,
ColorValue color
);
C++ public:
void SetValue(
EffectHandle^ parameter,
ColorValue color
);
JScript public function SetValue(
parameter : EffectHandle,
color : ColorValue
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
color Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Vector4[]) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal vector() As Vector4 _
)
C# public void SetValue(
EffectHandle parameter,
Vector4[] vector
);
C++ public:
void SetValue(
EffectHandle^ parameter,
array<Vector4>^ vector
);
JScript public function SetValue(
parameter : EffectHandle,
vector : Vector4[]
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
vector Microsoft.DirectX.Vector4[]
Array of Vector4 structures to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Vector4) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal vector As Vector4 _
)
C# public void SetValue(
EffectHandle parameter,
Vector4 vector
);
C++ public:
void SetValue(
EffectHandle^ parameter,
Vector4 vector
);
JScript public function SetValue(
parameter : EffectHandle,
vector : Vector4
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
vector Microsoft.DirectX.Vector4
A Vector4 structure to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Single[]) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal f() As Single _
)
C# public void SetValue(
EffectHandle parameter,
float[] f
);
C++ public:
void SetValue(
EffectHandle^ parameter,
array<float>^ f
);
JScript public function SetValue(
parameter : EffectHandle,
f : float[]
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
f System.Single[]
Array of Single Leave Site values to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Single) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal f As Single _
)
C# public void SetValue(
EffectHandle parameter,
float f
);
C++ public:
void SetValue(
EffectHandle^ parameter,
float f
);
JScript public function SetValue(
parameter : EffectHandle,
f : float
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
f System.Single
A Single Leave Site value to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Int32[]) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal n() As Integer _
)
C# public void SetValue(
EffectHandle parameter,
int[] n
);
C++ public:
void SetValue(
EffectHandle^ parameter,
array<int>^ n
);
JScript public function SetValue(
parameter : EffectHandle,
n : int[]
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
n System.Int32[]
Array of Int32 Leave Site values to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal n As Integer _
)
C# public void SetValue(
EffectHandle parameter,
int n
);
C++ public:
void SetValue(
EffectHandle^ parameter,
int n
);
JScript public function SetValue(
parameter : EffectHandle,
n : int
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
n System.Int32
An Int32 Leave Site value to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Boolean[]) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal b() As Boolean _
)
C# public void SetValue(
EffectHandle parameter,
bool[] b
);
C++ public:
void SetValue(
EffectHandle^ parameter,
array<bool>^ b
);
JScript public function SetValue(
parameter : EffectHandle,
b : boolean[]
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
b System.Boolean[]
Array of Boolean Leave Site values to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Boolean) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal b As Boolean _
)
C# public void SetValue(
EffectHandle parameter,
bool b
);
C++ public:
void SetValue(
EffectHandle^ parameter,
bool b
);
JScript public function SetValue(
parameter : EffectHandle,
b : boolean
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
b System.Boolean
A Boolean Leave Site value to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal data As GraphicsStream _
)
C# public void SetValue(
EffectHandle parameter,
GraphicsStream data
);
C++ public:
void SetValue(
EffectHandle^ parameter,
GraphicsStream^ data
);
JScript public function SetValue(
parameter : EffectHandle,
data : GraphicsStream
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
data Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the data to set.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValue(EffectHandle,Void,Int32) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValue Method

Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures.

Definition

Visual Basic Public Sub SetValue( _
ByVal parameter As EffectHandle, _
ByVal data As Void, _
ByVal dataSize As Integer _
)
C# public void SetValue(
EffectHandle parameter,
void data,
int dataSize
);
C++ public:
void SetValue(
EffectHandle^ parameter,
void data,
int dataSize
);
JScript public function SetValue(
parameter : EffectHandle,
data : void,
dataSize : int
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
data System.Void
A buffer containing the data to set.
dataSize System.Int32
Number of bytes in the data buffer.

Remarks

This method can be used in place of nearly all of the Set* methods in BaseEffect.

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseEffect.SetValueTranspose Method ()

Sets a transposed matrix.

Overload List

public void SetValueTranspose(EffectHandle, Matrix);
public void SetValueTranspose(EffectHandle, Matrix[]);

Remarks

Exceptions
InvalidCallException The call is invalid.


BaseEffect.SetValueTranspose(EffectHandle,Matrix[]) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValueTranspose Method

Sets a transposed matrix.

Definition

Visual Basic Public Sub SetValueTranspose( _
ByVal parameter As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValueTranspose(
EffectHandle parameter,
Matrix[] matrix
);
C++ public:
void SetValueTranspose(
EffectHandle^ parameter,
array<Matrix>^ matrix
);
JScript public function SetValueTranspose(
parameter : EffectHandle,
matrix : Matrix[]
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
matrix Microsoft.DirectX.Matrix[]
Array of Matrix structures to set.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.SetValueTranspose(EffectHandle,Matrix) Method (Microsoft.DirectX.Direct3D)

BaseEffect.SetValueTranspose Method

Sets a transposed matrix.

Definition

Visual Basic Public Sub SetValueTranspose( _
ByVal parameter As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValueTranspose(
EffectHandle parameter,
Matrix matrix
);
C++ public:
void SetValueTranspose(
EffectHandle^ parameter,
Matrix matrix
);
JScript public function SetValueTranspose(
parameter : EffectHandle,
matrix : Matrix
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
Unique EffectHandle identifier.
matrix Microsoft.DirectX.Matrix
A Matrix structure to set.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.UpdateUnmanagedPointer(ID3DXBaseEffect) Method (Microsoft.DirectX.Direct3D)

BaseEffect.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this BaseEffect object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXBaseEffect _
)
C# public void UpdateUnmanagedPointer(
ID3DXBaseEffect pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXBaseEffect pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXBaseEffect
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseEffect
Pointer to the ID3DXBaseEffect structure used to update the unmanaged pointer for this BaseEffect object.

Applies To

Effect, EffectCompiler


BaseEffect.Description Property (Microsoft.DirectX.Direct3D)

BaseEffect.Description Property

Retrieves an effect description.

Definition

Visual Basic | Public ReadOnly Property Description As EffectDescription
C# | public EffectDescription Description { get; }
C++ public:
property EffectDescription Description {
EffectDescription get();
}
JScript | public function get Description() : EffectDescription

Property Value

Microsoft.DirectX.Direct3D.EffectDescription
An EffectDescription object that contains the effect description.

This property is read-only.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Effect, EffectCompiler


BaseEffect.Disposed Property (Microsoft.DirectX.Direct3D)

BaseEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Applies To

Effect, EffectCompiler


BaseEffect.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

BaseEffect.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXBaseEffect
C# | public ID3DXBaseEffect UnmanagedComPointer { get; }
C++ public:
property ID3DXBaseEffect UnmanagedComPointer {
ID3DXBaseEffect get();
}
JScript | public function get UnmanagedComPointer() : ID3DXBaseEffect

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseEffect
Unmanaged ID3DXBaseEffect interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.

Applies To

Effect, EffectCompiler


BaseEffect.Disposing Event (Microsoft.DirectX.Direct3D)

BaseEffect.Disposing Event

Occurs when the Dispose method is called or when the BaseEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.BaseEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the BaseEffect object indicates whether that object has been disposed.

Applies To

Effect, EffectCompiler


BaseMesh Class (Microsoft.DirectX.Direct3D)

BaseMesh Class

Manipulates and queries mesh objects and derived mesh objects.

Definition

Visual Basic MustInherit Public Class BaseMesh
Inherits MarshalByRefObject
Implements IDisposable
C# | public abstract class BaseMesh : MarshalByRefObject, IDisposable
C++ | public ref class BaseMesh abstract : MarshalByRefObject, IDisposable
JScript | public abstract class BaseMesh extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the BaseMesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
BaseMesh | Initializes a new instance of the BaseMesh class.
Clone | Clones, or copies, a mesh object.
ComputeNormals | Computes normals for each vertex in a mesh.
ConvertAdjacencyToPointReps | Converts mesh adjacency information to an array of point representatives.
ConvertPointRepsToAdjacency | Converts point representative data to mesh adjacency information.
Dispose | Immediately releases the unmanaged resources used by the BaseMesh object.
DrawSubset | Draws a subset of a mesh.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the BaseMesh object to free resources before it is destroyed by the garbage collector.
GenerateAdjacency | Generates adjacency information based on mesh indices.
GetAttributeTable | Retrieves an attribute table for a mesh.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
LockIndexBuffer | Locks an index buffer and obtains the index buffer data.
LockVertexBuffer | Locks a vertex buffer and obtains a pointer to the vertex buffer memory.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.BaseMesh.Disposing event when called from within a derived class.
SetIndexBufferData | Sets index buffer data.
SetVertexBufferData | Sets vertex buffer data.
UnlockIndexBuffer | Unlocks an index buffer.
UnlockVertexBuffer | Unlocks a vertex buffer.
UpdateSemantics Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Declaration | Retrieves a declaration that describes the vertices in a mesh.
Device | Retrieves the device associated with a mesh.
Disposed | Gets a value that indicates whether the object is disposed.
IndexBuffer | Retrieves the data in an index buffer.
NumberAttributes | Retrieves the number of entries stored in an attribute table for a mesh.
NumberBytesPerVertex | Retrieves the number of bytes per vertex.
NumberFaces | Retrieves the number of faces in a mesh.
NumberVertices | Retrieves the number of vertices in a mesh.
Options | Retrieves the mesh options enabled for the current mesh at creation time.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseMesh interface pointer.
VertexBuffer | Retrieves the vertex buffer of a mesh.
VertexFormat | Retrieves the vertex format that describes the contents of vertices.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseMesh
Mesh
ProgressiveMesh

Remarks

A mesh is an object made up of a set of polygonal faces. It defines a set of vertices and a set of faces. The faces are defined in terms of the vertices and normals of the mesh.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Mesh
  • PatchMesh
  • ProgressiveMesh
  • SimplificationMesh


BaseMesh.BaseMesh Constructor ()

Initializes a new instance of the BaseMesh class.

Overload List

public BaseMesh(ID3DXBaseMesh);
public BaseMesh(IntPtr);


BaseMesh.BaseMesh(ID3DXBaseMesh) Constructor (Microsoft.DirectX.Direct3D)

BaseMesh.BaseMesh Constructor

Initializes a new instance of the BaseMesh class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXBaseMesh _
)
C# public BaseMesh(
ID3DXBaseMesh pUnk
);
C++ public:
BaseMesh(
ID3DXBaseMesh pUnk
);
JScript public function BaseMesh(
pUnk : ID3DXBaseMesh
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseMesh
Unmanaged Component Object Model (COM) ID3DXBaseMesh interface pointer.


BaseMesh.BaseMesh(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

BaseMesh.BaseMesh Constructor

Initializes a new instance of the BaseMesh class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public BaseMesh(
IntPtr unmanagedObject
);
C++ public:
BaseMesh(
IntPtr unmanagedObject
);
JScript public function BaseMesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXBaseMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


BaseMesh.Clone Method ()

How Do I...?
  • Clone a Mesh

Clones, or copies, a mesh object.

Overload List

public Mesh Clone(MeshFlags, GraphicsStream, Device);
public Mesh Clone(MeshFlags, VertexElement[], Device);
public Mesh Clone(MeshFlags, VertexFormats, Device);

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout, which it does by creating a new mesh object. For example, the method can be used to add space for normals, texture coordinates, colors, and weights.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. This method does not modify the contents of the vertex buffer. It can be used, for example, to relabel a 3-D texture coordinate as a binormal or tangent, or vice versa.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

See Also

  • BaseMesh.Declaration
  • DeclaratorFromFormat


BaseMesh.Clone(MeshFlags,GraphicsStream,Device) Method (Microsoft.DirectX.Direct3D)

BaseMesh.Clone Method

How Do I...?
  • Clone a Mesh

Clones, or copies, a mesh object.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration As GraphicsStream, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
GraphicsStream declaration,
Device device
);
C++ public:
Mesh^ Clone(
MeshFlags options,
GraphicsStream^ declaration,
Device^ device
);
JScript public function Clone(
options : MeshFlags,
declaration : GraphicsStream,
device : Device
) : Mesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, as specified with one or more MeshFlags flags (excepting the Simplify* and Optimize* flags, which should not be used for this purpose).
declaration Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the mesh data to duplicate.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Cloned mesh.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout, which it does by creating a new mesh object. For example, the method can be used to add space for normals, texture coordinates, colors, and weights.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. This method does not modify the contents of the vertex buffer. It can be used, for example, to relabel a 3-D texture coordinate as a binormal or tangent, or vice versa.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.Declaration
  • DeclaratorFromFormat


BaseMesh.Clone(MeshFlags,VertexElement[],Device) Method (Microsoft.DirectX.Direct3D)

BaseMesh.Clone Method

How Do I...?
  • Clone a Mesh

Clones, or copies, a mesh object.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexElement[] declaration,
Device device
);
C++ public:
Mesh^ Clone(
MeshFlags options,
array<VertexElement>^ declaration,
Device^ device
);
JScript public function Clone(
options : MeshFlags,
declaration : VertexElement[],
device : Device
) : Mesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, as specified with one or more MeshFlags flags (excepting the Simplify* and Optimize* flags, which should not be used for this purpose).
declaration Microsoft.DirectX.Direct3D.VertexElement[]
Vertex data, as defined with an array of VertexElement structures.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Cloned mesh.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout, which it does by creating a new mesh object. For example, the method can be used to add space for normals, texture coordinates, colors, and weights.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. This method does not modify the contents of the vertex buffer. It can be used, for example, to relabel a 3-D texture coordinate as a binormal or tangent, or vice versa.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.Declaration
  • DeclaratorFromFormat


BaseMesh.Clone(MeshFlags,VertexFormats,Device) Method (Microsoft.DirectX.Direct3D)

BaseMesh.Clone Method

How Do I...?
  • Clone a Mesh

Clones, or copies, a mesh object.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
C++ public:
Mesh^ Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device^ device
);
JScript public function Clone(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
) : Mesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, as specified with one or more MeshFlags flags (excepting the Simplify* and Optimize* flags, which should not be used for this purpose).
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Mesh vertex format, as specified with one or more VertexFormats flags.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Cloned mesh.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout, which it does by creating a new mesh object. For example, the method can be used to add space for normals, texture coordinates, colors, and weights.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. This method does not modify the contents of the vertex buffer. It can be used, for example, to relabel a 3-D texture coordinate as a binormal or tangent, or vice versa.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.Declaration
  • DeclaratorFromFormat


BaseMesh.ComputeNormals Method ()

How Do I...?
  • Clone a Mesh

Computes normals for each vertex in a mesh.

Overload List

public void ComputeNormals();
public void ComputeNormals(GraphicsStream);
public void ComputeNormals(int[]);

Remarks

The input mesh must have the VertexFormats.Normal flag specified.

A normal for a vertex is generated by averaging the normals of all faces that share that vertex.

If adjacency is provided, replicated vertices are ignored and smoothed over. If adjacency is not provided, the normals of replicated vertices are averaged only from the faces that explicitly reference them.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}


BaseMesh.ComputeNormals() Method (Microsoft.DirectX.Direct3D)

BaseMesh.ComputeNormals Method

How Do I...?
  • Clone a Mesh

Computes normals for each vertex in a mesh.

Definition

Visual Basic | Public Sub ComputeNormals()
C# | public void ComputeNormals();
C++ public:
void ComputeNormals();
JScript | public function ComputeNormals();

Remarks

The input mesh must have the VertexFormats.Normal flag specified.

A normal for a vertex is generated by averaging the normals of all faces that share that vertex.

If adjacency is provided, replicated vertices are ignored and smoothed over. If adjacency is not provided, the normals of replicated vertices are averaged only from the faces that explicitly reference them.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.ComputeNormals(Int32[]) Method (Microsoft.DirectX.Direct3D)

BaseMesh.ComputeNormals Method

How Do I...?
  • Clone a Mesh

Computes normals for each vertex in a mesh.

Definition

Visual Basic Public Sub ComputeNormals( _
ByVal adjacency() As Integer _
)
C# public void ComputeNormals(
int[] adjacency
);
C++ public:
void ComputeNormals(
array<int>^ adjacency
);
JScript public function ComputeNormals(
adjacency : int[]
);

Parameters

adjacency System.Int32[]
Array of three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Remarks

The input mesh must have the VertexFormats.Normal flag specified.

A normal for a vertex is generated by averaging the normals of all faces that share that vertex.

If adjacency is provided, replicated vertices are ignored and smoothed over. If adjacency is not provided, the normals of replicated vertices are averaged only from the faces that explicitly reference them.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.ComputeNormals(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

BaseMesh.ComputeNormals Method

How Do I...?
  • Clone a Mesh

Computes normals for each vertex in a mesh.

Definition

Visual Basic Public Sub ComputeNormals( _
ByVal adjacency As GraphicsStream _
)
C# public void ComputeNormals(
GraphicsStream adjacency
);
C++ public:
void ComputeNormals(
GraphicsStream^ adjacency
);
JScript public function ComputeNormals(
adjacency : GraphicsStream
);

Parameters

adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Remarks

The input mesh must have the VertexFormats.Normal flag specified.

A normal for a vertex is generated by averaging the normals of all faces that share that vertex.

If adjacency is provided, replicated vertices are ignored and smoothed over. If adjacency is not provided, the normals of replicated vertices are averaged only from the faces that explicitly reference them.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.ConvertAdjacencyToPointReps Method ()

Converts mesh adjacency information to an array of point representatives.

Overload List

public int[] ConvertAdjacencyToPointReps(GraphicsStream);
public int[] ConvertAdjacencyToPointReps(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • BaseMesh.ConvertPointRepsToAdjacency


BaseMesh.ConvertAdjacencyToPointReps(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

BaseMesh.ConvertAdjacencyToPointReps Method

Converts mesh adjacency information to an array of point representatives.

Definition

Visual Basic Public Function ConvertAdjacencyToPointReps( _
ByVal adjacency As GraphicsStream _
) As Integer()
C# public int[] ConvertAdjacencyToPointReps(
GraphicsStream adjacency
);
C++ public:
array<int>^ ConvertAdjacencyToPointReps(
GraphicsStream^ adjacency
);
JScript public function ConvertAdjacencyToPointReps(
adjacency : GraphicsStream
) : int[];

Parameters

adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Return Value

System.Int32[]
Array that contains one Int32 Leave Site per vertex of the mesh that is filled with point representative data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.ConvertPointRepsToAdjacency


BaseMesh.ConvertAdjacencyToPointReps(Int32[]) Method (Microsoft.DirectX.Direct3D)

BaseMesh.ConvertAdjacencyToPointReps Method

Converts mesh adjacency information to an array of point representatives.

Definition

Visual Basic Public Function ConvertAdjacencyToPointReps( _
ByVal adjaceny() As Integer _
) As Integer()
C# public int[] ConvertAdjacencyToPointReps(
int[] adjaceny
);
C++ public:
array<int>^ ConvertAdjacencyToPointReps(
array<int>^ adjaceny
);
JScript public function ConvertAdjacencyToPointReps(
adjaceny : int[]
) : int[];

Parameters

adjaceny System.Int32[]
Array of three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Return Value

System.Int32[]
Array that contains one Int32 Leave Site per vertex of the mesh that is filled with point representative data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.ConvertPointRepsToAdjacency


BaseMesh.ConvertPointRepsToAdjacency Method ()

Converts point representative data to mesh adjacency information.

Overload List

public int[] ConvertPointRepsToAdjacency(GraphicsStream);
public int[] ConvertPointRepsToAdjacency(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • ConvertAdjacencyToPointReps


BaseMesh.ConvertPointRepsToAdjacency(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

BaseMesh.ConvertPointRepsToAdjacency Method

Converts point representative data to mesh adjacency information.

Definition

Visual Basic Public Function ConvertPointRepsToAdjacency( _
ByVal pointReps As GraphicsStream _
) As Integer()
C# public int[] ConvertPointRepsToAdjacency(
GraphicsStream pointReps
);
C++ public:
array<int>^ ConvertPointRepsToAdjacency(
GraphicsStream^ pointReps
);
JScript public function ConvertPointRepsToAdjacency(
pointReps : GraphicsStream
) : int[];

Parameters

pointReps Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains one Int32 Leave Site per vertex of the mesh that represents point representative data. This parameter is optional; supplying a value of 0 causes it to be interpreted as an "identity" array.

Return Value

System.Int32[]
Array of three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh

See Also

  • ConvertAdjacencyToPointReps


BaseMesh.ConvertPointRepsToAdjacency(Int32[]) Method (Microsoft.DirectX.Direct3D)

BaseMesh.ConvertPointRepsToAdjacency Method

Converts point representative data to mesh adjacency information.

Definition

Visual Basic Public Function ConvertPointRepsToAdjacency( _
ByVal pointReps() As Integer _
) As Integer()
C# public int[] ConvertPointRepsToAdjacency(
int[] pointReps
);
C++ public:
array<int>^ ConvertPointRepsToAdjacency(
array<int>^ pointReps
);
JScript public function ConvertPointRepsToAdjacency(
pointReps : int[]
) : int[];

Parameters

pointReps System.Int32[]
Array that contains one Int32 Leave Site per vertex of the mesh that contains point representative data. This parameter is optional; supplying a value of 0 causes it to be interpreted as an "identity" array.

Return Value

System.Int32[]
Array of three Int32 Leave Site values per face, which specify the three neighbors for each face in the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh

See Also

  • ConvertAdjacencyToPointReps


BaseMesh.Dispose() Method (Microsoft.DirectX.Direct3D)

BaseMesh.Dispose Method

Immediately releases the unmanaged resources used by the BaseMesh object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~BaseMesh();
JScript | public override function Dispose();

Applies To

Mesh, ProgressiveMesh

See Also

  • Microsoft.DirectX.Direct3D.BaseMesh.Disposed
  • Microsoft.DirectX.Direct3D.BaseMesh.Disposing


BaseMesh.DrawSubset(Int32) Method (Microsoft.DirectX.Direct3D)

BaseMesh.DrawSubset Method

Draws a subset of a mesh.

Definition

Visual Basic Public Sub DrawSubset( _
ByVal attributeID As Integer _
)
C# public void DrawSubset(
int attributeID
);
C++ public:
void DrawSubset(
int attributeID
);
JScript public function DrawSubset(
attributeID : int
);

Parameters

attributeID System.Int32
An Int32 Leave Site value that specifies which subset of the mesh to draw. This value is used to differentiate faces in a mesh as belonging to one or more attribute groups.

Remarks

The subset that is specified by attributeID will be rendered by the DrawIndexedPrimitives method, using the TriangleList primitive type, so an index buffer must be properly initialized.

An attribute table is used to identify areas of the mesh that need to be drawn with different textures, render states, and materials. The application can use the attribute table to hide portions of a mesh by leaving out a given attribute identifier (attributeID) when drawing the frame. Attribute tables can also be used for application defined purposes.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • GetAttributeTable


BaseMesh.Equals(Object) Method (Microsoft.DirectX.Direct3D)

BaseMesh.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

Mesh, ProgressiveMesh


BaseMesh.Finalize() Method (Microsoft.DirectX.Direct3D)

BaseMesh.Finalize Method

Allows the BaseMesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~BaseMesh();
C++ | !BaseMesh();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.

Applies To

Mesh, ProgressiveMesh


BaseMesh.GenerateAdjacency(Single,Int32[]) Method (Microsoft.DirectX.Direct3D)

BaseMesh.GenerateAdjacency Method

Generates adjacency information based on mesh indices.

Definition

Visual Basic Public Sub GenerateAdjacency( _
ByVal epsilon As Single, _
ByVal adjacency() As Integer _
)
C# public void GenerateAdjacency(
float epsilon,
int[] adjacency
);
C++ public:
void GenerateAdjacency(
float epsilon,
array<int>^ adjacency
);
JScript public function GenerateAdjacency(
epsilon : float,
adjacency : int[]
);

Parameters

epsilon System.Single
Specifies that vertices that differ in position by less than epsilon should be treated as coincident.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face to be filled with adjacent face indices. The size of this array must be at least 3 * BaseMesh.NumberFaces.

Remarks

The GenerateAdjacency method determines which patches are adjacent (within the provided tolerance). This information is used internally to optimize tessellation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Applies To

Mesh, ProgressiveMesh


BaseMesh.GetAttributeTable() Method (Microsoft.DirectX.Direct3D)

BaseMesh.GetAttributeTable Method

Retrieves an attribute table for a mesh.

Definition

Visual Basic | Public Function GetAttributeTable() As AttributeRange()
C# | public AttributeRange[] GetAttributeTable();
C++ public:
array<AttributeRange>^ GetAttributeTable();
JScript | public function GetAttributeTable() : AttributeRange[];

Return Value

Microsoft.DirectX.Direct3D.AttributeRange[]
Array of AttributeRange structures, which represent each entry in the attribute table.

Remarks

An attribute table is created by calling Mesh.Optimize and passing OptimizeAttrSort for the param_MeshFlags_flags parameter.

An attribute table is used to identify areas of the mesh that need to be drawn with different textures, render states and materials. The application can use the attribute table to hide portions of a mesh by leaving out a given attribute identifier (attributeID) when drawing the frame. Attribute tables can also be used for application defined purposes.

Exceptions
ArgumentException Leave Site | There is no attribute table.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.GetHashCode() Method (Microsoft.DirectX.Direct3D)

BaseMesh.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Applies To

Mesh, ProgressiveMesh


BaseMesh.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

BaseMesh.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXBaseMesh, which allows unmanaged COM clients to create an instance of the managed BaseMesh class. Not supported.

Applies To

Mesh, ProgressiveMesh


BaseMesh.LockIndexBuffer Method ()

Locks an index buffer and obtains the index buffer data.

Overload List

public GraphicsStream LockIndexBuffer(LockFlags);
public Array LockIndexBuffer(Type, LockFlags, int[]);

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set index buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • IndexBuffer
  • SetIndexBufferData
  • UnlockIndexBuffer


BaseMesh.LockIndexBuffer(Type,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

BaseMesh.LockIndexBuffer Method

Locks an index buffer and obtains the index buffer data.

Definition

Visual Basic Public Function LockIndexBuffer( _
ByVal typeIndex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockIndexBuffer(
Type typeIndex,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockIndexBuffer(
Type^ typeIndex,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockIndexBuffer(
typeIndex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeIndex System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set index buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • IndexBuffer
  • SetIndexBufferData
  • UnlockIndexBuffer


BaseMesh.LockIndexBuffer(LockFlags) Method (Microsoft.DirectX.Direct3D)

BaseMesh.LockIndexBuffer Method

Locks an index buffer and obtains the index buffer data.

Definition

Visual Basic Public Function LockIndexBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockIndexBuffer(
LockFlags flags
);
C++ public:
GraphicsStream^ LockIndexBuffer(
LockFlags flags
);
JScript public function LockIndexBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set index buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • IndexBuffer
  • SetIndexBufferData
  • UnlockIndexBuffer


BaseMesh.LockVertexBuffer Method ()

Locks a vertex buffer and obtains a pointer to the vertex buffer memory.

Overload List

public GraphicsStream LockVertexBuffer(LockFlags);
public Array LockVertexBuffer(Type, LockFlags, int[]);

Remarks

When working with vertex buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set vertex buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • VertexBuffer
  • UnlockVertexBuffer
  • SetVertexBufferData


BaseMesh.LockVertexBuffer(LockFlags) Method (Microsoft.DirectX.Direct3D)

BaseMesh.LockVertexBuffer Method

Locks a vertex buffer and obtains a pointer to the vertex buffer memory.

Definition

Visual Basic Public Function LockVertexBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockVertexBuffer(
LockFlags flags
);
C++ public:
GraphicsStream^ LockVertexBuffer(
LockFlags flags
);
JScript public function LockVertexBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set vertex buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • VertexBuffer
  • UnlockVertexBuffer
  • SetVertexBufferData


BaseMesh.LockVertexBuffer(Type,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

BaseMesh.LockVertexBuffer Method

Locks a vertex buffer and obtains a pointer to the vertex buffer memory.

Definition

Visual Basic Public Function LockVertexBuffer( _
ByVal typeVertex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockVertexBuffer(
Type typeVertex,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockVertexBuffer(
Type^ typeVertex,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockVertexBuffer(
typeVertex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeVertex System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. Calls to Device.DrawPrimitives, for example, will not succeed with any outstanding lock count on any currently set vertex buffer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • VertexBuffer
  • UnlockVertexBuffer
  • SetVertexBufferData


BaseMesh.op_Equality(BaseMesh,BaseMesh) Method (Microsoft.DirectX.Direct3D)

BaseMesh.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As BaseMesh, _
ByVal right As BaseMesh _
) As Boolean
C# public static bool op_Equality(
BaseMesh left,
BaseMesh right
);
C++ public:
static bool operator==(
BaseMesh^ left,
BaseMesh^ right
);
JScript public static function op_Equality(
left : BaseMesh,
right : BaseMesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.BaseMesh
The BaseMesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.BaseMesh
The BaseMesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

Mesh, ProgressiveMesh


BaseMesh.op_Inequality(BaseMesh,BaseMesh) Method (Microsoft.DirectX.Direct3D)

BaseMesh.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As BaseMesh, _
ByVal right As BaseMesh _
) As Boolean
C# public static bool op_Inequality(
BaseMesh left,
BaseMesh right
);
C++ public:
static bool operator!=(
BaseMesh^ left,
BaseMesh^ right
);
JScript public static function op_Inequality(
left : BaseMesh,
right : BaseMesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.BaseMesh
The BaseMesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.BaseMesh
The BaseMesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Applies To

Mesh, ProgressiveMesh


BaseMesh.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

BaseMesh.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.BaseMesh.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Applies To

Mesh, ProgressiveMesh


BaseMesh.SetIndexBufferData(Object,LockFlags) Method (Microsoft.DirectX.Direct3D)

BaseMesh.SetIndexBufferData Method

Sets index buffer data.

Definition

Visual Basic Public Sub SetIndexBufferData( _
ByVal data As Object, _
ByVal flags As LockFlags _
)
C# public void SetIndexBufferData(
object data,
LockFlags flags
);
C++ public:
void SetIndexBufferData(
Object^ data,
LockFlags flags
);
JScript public function SetIndexBufferData(
data : Object,
flags : LockFlags
);

Parameters

data System.Object
An Object Leave Site that contains the data to copy into the index buffer. This can be any value type or array of value types. The Int32 Leave Site and Int16 Leave Site values are commonly used.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform when setting the data. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Remarks

The SetIndexBufferData method locks, sets, and then unlocks the index buffer. A call to UnlockIndexBuffer is not required.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.SetVertexBufferData(Object,LockFlags) Method (Microsoft.DirectX.Direct3D)

BaseMesh.SetVertexBufferData Method

Sets vertex buffer data.

Definition

Visual Basic Public Sub SetVertexBufferData( _
ByVal data As Object, _
ByVal flags As LockFlags _
)
C# public void SetVertexBufferData(
object data,
LockFlags flags
);
C++ public:
void SetVertexBufferData(
Object^ data,
LockFlags flags
);
JScript public function SetVertexBufferData(
data : Object,
flags : LockFlags
);

Parameters

data System.Object
An Object Leave Site that contains the data to copy into the vertex buffer. This can be any value type or array of value types. The Int32 Leave Site and Int16 Leave Site values are commonly used.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform when setting the data. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Remarks

The SetVertexBufferData method locks, sets, and then unlocks the vertex buffer. A call to UnlockVertexBuffer is not required.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.UnlockIndexBuffer() Method (Microsoft.DirectX.Direct3D)

BaseMesh.UnlockIndexBuffer Method

Unlocks an index buffer.

Definition

Visual Basic | Public Sub UnlockIndexBuffer()
C# | public void UnlockIndexBuffer();
C++ public:
void UnlockIndexBuffer();
JScript | public function UnlockIndexBuffer();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • LockIndexBuffer
  • SetIndexBufferData
  • IndexBuffer


BaseMesh.UnlockVertexBuffer() Method (Microsoft.DirectX.Direct3D)

BaseMesh.UnlockVertexBuffer Method

Unlocks a vertex buffer.

Definition

Visual Basic | Public Sub UnlockVertexBuffer()
C# | public void UnlockVertexBuffer();
C++ public:
void UnlockVertexBuffer();
JScript | public function UnlockVertexBuffer();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh

See Also

  • LockVertexBuffer
  • SetVertexBufferData
  • IndexBuffer


BaseMesh.UpdateSemantics Method ()

Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size.

Overload List

public void UpdateSemantics(GraphicsStream);
public void UpdateSemantics(VertexElement[]);

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout. For example, it can be used to add space for new normals, texture coordinates, colors, and weights that were not present before.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. For example, it can be used to re-label a 3-D texture coordinate as a binormal or a tangent, or vice versa.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


BaseMesh.UpdateSemantics(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

BaseMesh.UpdateSemantics Method

Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size.

Definition

Visual Basic Public Sub UpdateSemantics( _
ByVal declaration As GraphicsStream _
)
C# public void UpdateSemantics(
GraphicsStream declaration
);
C++ public:
void UpdateSemantics(
GraphicsStream^ declaration
);
JScript public function UpdateSemantics(
declaration : GraphicsStream
);

Parameters

declaration Microsoft.DirectX.GraphicsStream
A GraphicsStream containing VertexElement structures that describe the vertex format of the mesh vertices.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout. For example, it can be used to add space for new normals, texture coordinates, colors, and weights that were not present before.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. For example, it can be used to re-label a 3-D texture coordinate as a binormal or a tangent, or vice versa.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.UpdateSemantics(VertexElement[]) Method (Microsoft.DirectX.Direct3D)

BaseMesh.UpdateSemantics Method

Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size.

Definition

Visual Basic Public Sub UpdateSemantics( _
ByVal declaration() As VertexElement _
)
C# public void UpdateSemantics(
VertexElement[] declaration
);
C++ public:
void UpdateSemantics(
array<VertexElement>^ declaration
);
JScript public function UpdateSemantics(
declaration : VertexElement[]
);

Parameters

declaration Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that describe the vertex format of the mesh vertices.

Remarks

The BaseMesh.Clone method is used to reformat and change the vertex data layout. For example, it can be used to add space for new normals, texture coordinates, colors, and weights that were not present before.

The BaseMesh.UpdateSemantics method updates the vertex declaration with new semantic information without changing the layout of the vertex buffer. For example, it can be used to re-label a 3-D texture coordinate as a binormal or a tangent, or vice versa.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.UpdateUnmanagedPointer(ID3DXBaseMesh) Method (Microsoft.DirectX.Direct3D)

BaseMesh.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this BaseMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXBaseMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXBaseMesh pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXBaseMesh pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXBaseMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseMesh
Pointer to the ID3DXBaseMesh structure used to update the unmanaged pointer for this BaseMesh object.

Applies To

Mesh, ProgressiveMesh


BaseMesh.Declaration Property (Microsoft.DirectX.Direct3D)

BaseMesh.Declaration Property

Retrieves a declaration that describes the vertices in a mesh.

Definition

Visual Basic | Public ReadOnly Property Declaration As VertexElement()
C# | public VertexElement[] Declaration { get; }
C++ public:
property array<VertexElement>^ Declaration {
array<VertexElement>^ get();
}
JScript | public function get Declaration() : VertexElement[]

Property Value

Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that describe the vertex format of the mesh vertices. The vertex element array ends with the value specified in the VertexElement.VertexDeclarationEnd field.

This property is read-only.

Applies To

Mesh, ProgressiveMesh

See Also

  • BaseMesh.VertexFormatTopic


BaseMesh.Device Property (Microsoft.DirectX.Direct3D)

BaseMesh.Device Property

Retrieves the device associated with a mesh.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
A Device object that represents the Microsoft Direct3D device object associated with the mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Mesh, ProgressiveMesh


BaseMesh.Disposed Property (Microsoft.DirectX.Direct3D)

BaseMesh.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.IndexBuffer Property (Microsoft.DirectX.Direct3D)

BaseMesh.IndexBuffer Property

Retrieves the data in an index buffer.

Definition

Visual Basic | Public ReadOnly Property IndexBuffer As IndexBuffer
C# | public IndexBuffer IndexBuffer { get; }
C++ public:
property IndexBuffer^ IndexBuffer {
IndexBuffer^ get();
}
JScript | public function get IndexBuffer() : IndexBuffer

Property Value

Microsoft.DirectX.Direct3D.IndexBuffer
An IndexBuffer object that represents the index buffer object associated with the mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The call is invalid.

Applies To

Mesh, ProgressiveMesh


BaseMesh.NumberAttributes Property (Microsoft.DirectX.Direct3D)

BaseMesh.NumberAttributes Property

Retrieves the number of entries stored in an attribute table for a mesh.

Definition

Visual Basic | Public ReadOnly Property NumberAttributes As Integer
C# | public int NumberAttributes { get; }
C++ public:
property int NumberAttributes {
int get();
}
JScript | public function get NumberAttributes() : int

Property Value

System.Int32
An integer value that represents the number of entries stored in the attribute table for the mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

Mesh, ProgressiveMesh


BaseMesh.NumberBytesPerVertex Property (Microsoft.DirectX.Direct3D)

BaseMesh.NumberBytesPerVertex Property

Retrieves the number of bytes per vertex.

Definition

Visual Basic | Public ReadOnly Property NumberBytesPerVertex As Integer
C# | public int NumberBytesPerVertex { get; }
C++ public:
property int NumberBytesPerVertex {
int get();
}
JScript | public function get NumberBytesPerVertex() : int

Property Value

System.Int32
Number of bytes per vertex.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.NumberFaces Property (Microsoft.DirectX.Direct3D)

BaseMesh.NumberFaces Property

Retrieves the number of faces in a mesh.

Definition

Visual Basic | Public ReadOnly Property NumberFaces As Integer
C# | public int NumberFaces { get; }
C++ public:
property int NumberFaces {
int get();
}
JScript | public function get NumberFaces() : int

Property Value

System.Int32
Number of faces in the mesh.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.NumberVertices Property (Microsoft.DirectX.Direct3D)

BaseMesh.NumberVertices Property

Retrieves the number of vertices in a mesh.

Definition

Visual Basic | Public ReadOnly Property NumberVertices As Integer
C# | public int NumberVertices { get; }
C++ public:
property int NumberVertices {
int get();
}
JScript | public function get NumberVertices() : int

Property Value

System.Int32
Number of vertices in the mesh.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.Options Property (Microsoft.DirectX.Direct3D)

BaseMesh.Options Property

Retrieves the mesh options enabled for the current mesh at creation time.

Definition

Visual Basic | Public ReadOnly Property Options As MeshOptions
C# | public MeshOptions Options { get; }
C++ public:
property MeshOptions Options {
MeshOptions get();
}
JScript | public function get Options() : MeshOptions

Property Value

Microsoft.DirectX.Direct3D.MeshOptions
A MeshOptions structure that contains the options enabled for the mesh at creation time.

This property is read-only.

Applies To

Mesh, ProgressiveMesh


BaseMesh.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

BaseMesh.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXBaseMesh interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXBaseMesh
C# | public ID3DXBaseMesh UnmanagedComPointer { get; }
C++ public:
property ID3DXBaseMesh UnmanagedComPointer {
ID3DXBaseMesh get();
}
JScript | public function get UnmanagedComPointer() : ID3DXBaseMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXBaseMesh
Unmanaged ID3DXBaseMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.

Applies To

Mesh, ProgressiveMesh


BaseMesh.VertexBuffer Property (Microsoft.DirectX.Direct3D)

BaseMesh.VertexBuffer Property

How Do I...?
  • Compute a Bounding Sphere from a Mesh

Retrieves the vertex buffer of a mesh.

Definition

Visual Basic | Public ReadOnly Property VertexBuffer As VertexBuffer
C# | public VertexBuffer VertexBuffer { get; }
C++ public:
property VertexBuffer^ VertexBuffer {
VertexBuffer^ get();
}
JScript | public function get VertexBuffer() : VertexBuffer

Property Value

Microsoft.DirectX.Direct3D.VertexBuffer
A VertexBuffer object that contains the vertex data associated with the mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.VertexFormat Property (Microsoft.DirectX.Direct3D)

BaseMesh.VertexFormat Property

How Do I...?
  • Clone a Mesh

Retrieves the vertex format that describes the contents of vertices.

Definition

Visual Basic | Public ReadOnly Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; }
C++ public:
property VertexFormats VertexFormat {
VertexFormats get();
}
JScript | public function get VertexFormat() : VertexFormats

Property Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object that describes the content of the vertices associated with the mesh.

This property is read-only.

Remarks

If the vertex format cannot be mapped directly to a flexible vertex format (FVF) code, this method can return 0. This can occur when a mesh created from a vertex declaration does not have the same order and elements as those supported by the FVF codes.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Clone a Mesh

This example shows how to clone a mesh to add space for normals, texture coordinates, colors, weights, etc. that were not originally present.

In the following C# code example, after the mesh is loaded from a file, the Mesh.Clone method is called. The call to pMesh.Clone obtains mesh flags from pMesh, and adds flags for supported VertexFormats and vertex normals.

The original pMesh mesh object is overwritten to contain these additional values. Note that pMesh is disposed before setting to the updated temporary mesh object.

In this example, device is assumed to be the rendering Device.

              [C#]

using Microsoft.DirectX.Direct3D;

pMesh = Mesh.FromFile("a_mesh_file.x", MeshFlags.Managed, device);

if ((pMesh.VertexFormat & VertexFormats.Normal) == 0)
{
    Mesh pTempMesh = pMesh.Clone(pMesh.Options.Value,
                                 pMesh.VertexFormat |
                                 VertexFormats.Normal, device);
    pTempMesh.ComputeNormals();
    pMesh.Dispose();
    pMesh = pTempMesh;
}

Applies To

Mesh, ProgressiveMesh


BaseMesh.Disposing Event (Microsoft.DirectX.Direct3D)

BaseMesh.Disposing Event

Occurs when the Dispose method is called or when the BaseMesh object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.BaseMesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the BaseMesh object indicates whether that object has been disposed.

Applies To

Mesh, ProgressiveMesh


BaseTexture Class (Microsoft.DirectX.Direct3D)

BaseTexture Class

Manipulates texture resources, including cube and volume textures.

Definition

Visual Basic MustInherit Public Class BaseTexture
Inherits Resource
C# | public abstract class BaseTexture : Resource
C++ | public ref class BaseTexture abstract : Resource
JScript | public abstract class BaseTexture extends Resource

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BaseTexture | Initializes a new instance of the BaseTexture class.
Dispose | Immediately releases the unmanaged resources used by the Resource object. Inherited from Resource.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GenerateMipSubLevels | Generates mipmap sublevels.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
SetLevelOfDetail | Sets the most detailed level of detail (LOD) for a managed texture.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseTexture object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.

Properties

Property | Description
AutoGenerateFilterType | Retrieves or sets the filter type used for automatically generated sublevels.
Device | Retrieves the device associated with a resource. Inherited from Resource.
LevelCount | Retrieves the number of texture levels in a multilevel texture.
LevelOfDetail | Retrieves or sets the most detailed level of detail (LOD) for a managed texture.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DBaseTexture9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
CubeTexture
Texture
VolumeTexture

Remarks

The BaseTexture object assigned to a particular stage for a device is obtained by calling the Device.GetTexture method.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BaseTexture.BaseTexture Constructor ()

Initializes a new instance of the BaseTexture class.

Overload List

public BaseTexture(IDirect3DBaseTexture9);
public BaseTexture(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


BaseTexture.BaseTexture(IDirect3DBaseTexture9) Constructor (Microsoft.DirectX.Direct3D)

BaseTexture.BaseTexture Constructor

Initializes a new instance of the BaseTexture class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As IDirect3DBaseTexture9 _
)
C# public BaseTexture(
IDirect3DBaseTexture9 pInterop
);
C++ public:
BaseTexture(
IDirect3DBaseTexture9 pInterop
);
JScript public function BaseTexture(
pInterop : IDirect3DBaseTexture9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DBaseTexture9
Unmanaged Component Object Model (COM) IDirect3DBaseTexture9 interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


BaseTexture.BaseTexture(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

BaseTexture.BaseTexture Constructor

Initializes a new instance of the BaseTexture class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public BaseTexture(
IntPtr unmanagedObject
);
C++ public:
BaseTexture(
IntPtr unmanagedObject
);
JScript public function BaseTexture(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DBaseTexture9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


BaseTexture.Equals(Object) Method (Microsoft.DirectX.Direct3D)

BaseTexture.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.GenerateMipSubLevels() Method (Microsoft.DirectX.Direct3D)

BaseTexture.GenerateMipSubLevels Method

Generates mipmap sublevels.

Definition

Visual Basic | Public Sub GenerateMipSubLevels()
C# | public void GenerateMipSubLevels();
C++ public:
void GenerateMipSubLevels();
JScript | public function GenerateMipSubLevels();

Remarks

An application can generate mipmap sublevels at any time by calling BaseTexture.GenerateMipSubLevels. To have mipmap sublevels generated automatically at texture creation time, specify AutoGenerateMipMap when calling the Texture, CubeTexture, and VolumeTexture constructors. For more information about usage constants, see Usage.

Applies To

CubeTexture, Texture, VolumeTexture

See Also

  • BaseTexture.AutoGenerateFilterType


BaseTexture.GetHashCode() Method (Microsoft.DirectX.Direct3D)

BaseTexture.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

BaseTexture.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DBaseTexture9, which allows unmanaged COM clients to create an instance of the managed BaseTexture class. Not supported.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.op_Equality(BaseTexture,BaseTexture) Method (Microsoft.DirectX.Direct3D)

BaseTexture.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As BaseTexture, _
ByVal right As BaseTexture _
) As Boolean
C# public static bool op_Equality(
BaseTexture left,
BaseTexture right
);
C++ public:
static bool operator==(
BaseTexture^ left,
BaseTexture^ right
);
JScript public static function op_Equality(
left : BaseTexture,
right : BaseTexture
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.BaseTexture
The BaseTexture object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.BaseTexture
The BaseTexture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.op_Inequality(BaseTexture,BaseTexture) Method (Microsoft.DirectX.Direct3D)

BaseTexture.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As BaseTexture, _
ByVal right As BaseTexture _
) As Boolean
C# public static bool op_Inequality(
BaseTexture left,
BaseTexture right
);
C++ public:
static bool operator!=(
BaseTexture^ left,
BaseTexture^ right
);
JScript public static function op_Inequality(
left : BaseTexture,
right : BaseTexture
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.BaseTexture
The BaseTexture object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.BaseTexture
The BaseTexture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.SetLevelOfDetail(Int32) Method (Microsoft.DirectX.Direct3D)

BaseTexture.SetLevelOfDetail Method

Sets the most detailed level of detail (LOD) for a managed texture.

Definition

Visual Basic Public Function SetLevelOfDetail( _
ByVal lodNew As Integer _
) As Integer
C# public int SetLevelOfDetail(
int lodNew
);
C++ public:
int SetLevelOfDetail(
int lodNew
);
JScript public function SetLevelOfDetail(
lodNew : int
) : int;

Parameters

lodNew System.Int32
Most detailed LOD value to set for the chain.

Return Value

System.Int32
An Int32 Leave Site value, clamped to the maximum LOD value (one less than the total number of levels). Subsequent calls to this method return the maximum value, not the previously set LOD value.

Remarks

The BaseTexture.SetLevelOfDetail method is used for LOD control of managed textures. The method communicates to the Microsoft Direct3D texture manager the most detailed mipmap in the chain that should be loaded into local video memory. For example, in a five-level mipmap chain, setting param_Int32_lodNew to 2 indicates that the texture manager should load only mipmap levels 2 through 4 into local video memory at any given time.

More specifically, if the texture was created with the dimensions of 256x256, setting the most detailed level to 0 indicates that 256x256 is the largest mipmap available, setting the most detailed level to 1 indicates that 128x128 is the largest mipmap available, and so on, up to the most detailed mip level (the smallest texture size) for the chain.

Applies To

CubeTexture, Texture, VolumeTexture

See Also

  • BaseTexture.LevelOfDetail


BaseTexture.UpdateUnmanagedPointer(IDirect3DBaseTexture9) Method (Microsoft.DirectX.Direct3D)

BaseTexture.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this BaseTexture object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DBaseTexture9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DBaseTexture9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DBaseTexture9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DBaseTexture9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DBaseTexture9
Pointer to the IDirect3DBaseTexture9 structure used to update the unmanaged pointer for this BaseTexture object.

Applies To

CubeTexture, Texture, VolumeTexture

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BaseTexture.AutoGenerateFilterType Property (Microsoft.DirectX.Direct3D)

BaseTexture.AutoGenerateFilterType Property

Retrieves or sets the filter type used for automatically generated sublevels.

Definition

Visual Basic | Public Property AutoGenerateFilterType As TextureFilter
C# | public TextureFilter AutoGenerateFilterType { get; set; }
C++ public:
property TextureFilter AutoGenerateFilterType {
TextureFilter get();
void set(TextureFilter value);
}
JScript public function get AutoGenerateFilterType() : TextureFilter
public function set AutoGenerateFilterType(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter
A TextureFilter. A texture must be created with Usage.AutoGenerateMipMap to use this property. Any other usage value sets this property to TextureFilter.None.

This property is read/write.

Remarks

Changing the filter type "dirties" the mipmap sublevels and causes them to be regenerated.

The (default) filter type set at texture creation time is Linear. If the driver does not support a linear filter, the filter type is set to Point. All filter types supported by the driver for regular texture filtering are supported for autogeneration except None. Setting the AutoGenerateFilterType property fails unless the driver sets the appropriate SupportsMinify* caps. These values are specified in the Caps.FilterCaps and/or Caps.CubeTextureFilterCaps members. For more information about texture filter types, see TextureFilter.

If the texture is not created with AutoGenerateMipMap, this method has no effect. In this case, an exception is not thrown. For more information about usage constants, see Usage.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

Applies To

CubeTexture, Texture, VolumeTexture

See Also

  • GenerateMipSubLevels


BaseTexture.LevelCount Property (Microsoft.DirectX.Direct3D)

BaseTexture.LevelCount Property

Retrieves the number of texture levels in a multilevel texture.

Definition

Visual Basic | Public ReadOnly Property LevelCount As Integer
C# | public int LevelCount { get; }
C++ public:
property int LevelCount {
int get();
}
JScript | public function get LevelCount() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of texture levels in the multilevel texture.

This property is read-only.

Applies To

CubeTexture, Texture, VolumeTexture


BaseTexture.LevelOfDetail Property (Microsoft.DirectX.Direct3D)

BaseTexture.LevelOfDetail Property

Retrieves or sets the most detailed level of detail (LOD) for a managed texture.

Definition

Visual Basic | Public Property LevelOfDetail As Integer
C# | public int LevelOfDetail { get; set; }
C++ public:
property int LevelOfDetail {
int get();
void set(int value);
}
JScript public function get LevelOfDetail() : int
public function set LevelOfDetail(int);

Property Value

System.Int32
Most detailed LOD value to set in the chain.

This property is read/write.

Remarks

This property returns 0 on nonmanaged textures.

Setting LevelOfDetail communicates to the Microsoft Direct3D texture manager the most detailed mipmap in the chain that should be loaded into local video memory. For example, in a five-level mipmap chain, setting LevelOfDetail to 2 indicates that the texture manager should load only mipmap levels 2 through 4 into local video memory at any given time.

More specifically, if the texture was created with the dimensions of 256x256, setting the most detailed level to 0 indicates that 256x256 is the largest mipmap available, setting the most detailed level to 1 indicates that 128x128 is the largest mipmap available, and so on, up to the most detailed mip level (the smallest texture size) for the chain.

Applies To

CubeTexture, Texture, VolumeTexture

See Also

  • SetLevelOfDetail


BaseTexture.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

BaseTexture.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DBaseTexture9 interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As IDirect3DBaseTexture9
C# | public IDirect3DBaseTexture9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DBaseTexture9 UnmanagedComPointer {
IDirect3DBaseTexture9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DBaseTexture9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DBaseTexture9
Unmanaged IDirect3DBaseTexture9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.

Applies To

CubeTexture, Texture, VolumeTexture


CannotAttributeSortException Class (Microsoft.DirectX.Direct3D)

CannotAttributeSortException Class

Attribute sort is not supported as an optimization technique. For more information, see MeshFlags.OptimizeAttrSort.

Definition

Visual Basic Public Class CannotAttributeSortException
Inherits Direct3DXException
C# | public class CannotAttributeSortException : Direct3DXException
C++ | public ref class CannotAttributeSortException : Direct3DXException
JScript | public class CannotAttributeSortException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotAttributeSortException | Initializes a new instance of the CannotAttributeSortException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
CannotAttributeSortException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotAttributeSortException.CannotAttributeSortException Constructor ()

Initializes a new instance of the CannotAttributeSortException class.

Overload List

public CannotAttributeSortException();
protected CannotAttributeSortException(SerializationInfo, StreamingContext);
public CannotAttributeSortException(string);
public CannotAttributeSortException(string, Exception);


CannotAttributeSortException.CannotAttributeSortException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:

Initializes a new instance of the CannotAttributeSortException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotAttributeSortException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotAttributeSortException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotAttributeSortException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


CannotAttributeSortException.CannotAttributeSortException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:

Initializes a new instance of the CannotAttributeSortException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotAttributeSortException(
string message,
Exception inner
);
C++ public:
CannotAttributeSortException(
String^ message,
Exception^ inner
);
JScript public function CannotAttributeSortException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


CannotAttributeSortException.CannotAttributeSortException(String) Constructor (Microsoft.DirectX.Direct3D)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:

Initializes a new instance of the CannotAttributeSortException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotAttributeSortException(
string message
);
C++ public:
CannotAttributeSortException(
String^ message
);
JScript public function CannotAttributeSortException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


CannotAttributeSortException.CannotAttributeSortException() Constructor (Microsoft.DirectX.Direct3D)

CannotAttributeSortException.CannotAttributeSortException Constructor

 Language:

Initializes a new instance of the CannotAttributeSortException class.

Definition

Visual Basic | Public Sub New()
C# | public CannotAttributeSortException();
C++ public:
CannotAttributeSortException();
JScript | public function CannotAttributeSortException();


CannotModifyIndexBufferException Class (Microsoft.DirectX.Direct3D)

CannotModifyIndexBufferException Class

The index buffer cannot be modified.

Definition

Visual Basic Public Class CannotModifyIndexBufferException
Inherits Direct3DXException
C# | public class CannotModifyIndexBufferException : Direct3DXException
C++ | public ref class CannotModifyIndexBufferException : Direct3DXException
JScript | public class CannotModifyIndexBufferException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotModifyIndexBufferException | Initializes a new instance of the CannotModifyIndexBufferException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
CannotModifyIndexBufferException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor ()

Initializes a new instance of the CannotModifyIndexBufferException class.

Overload List

public CannotModifyIndexBufferException();
protected CannotModifyIndexBufferException(SerializationInfo, StreamingContext);
public CannotModifyIndexBufferException(string);
public CannotModifyIndexBufferException(string, Exception);


CannotModifyIndexBufferException.CannotModifyIndexBufferException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:

Initializes a new instance of the CannotModifyIndexBufferException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotModifyIndexBufferException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotModifyIndexBufferException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotModifyIndexBufferException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


CannotModifyIndexBufferException.CannotModifyIndexBufferException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:

Initializes a new instance of the CannotModifyIndexBufferException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotModifyIndexBufferException(
string message,
Exception inner
);
C++ public:
CannotModifyIndexBufferException(
String^ message,
Exception^ inner
);
JScript public function CannotModifyIndexBufferException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


CannotModifyIndexBufferException.CannotModifyIndexBufferException(String) Constructor (Microsoft.DirectX.Direct3D)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:

Initializes a new instance of the CannotModifyIndexBufferException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotModifyIndexBufferException(
string message
);
C++ public:
CannotModifyIndexBufferException(
String^ message
);
JScript public function CannotModifyIndexBufferException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


CannotModifyIndexBufferException.CannotModifyIndexBufferException() Constructor (Microsoft.DirectX.Direct3D)

CannotModifyIndexBufferException.CannotModifyIndexBufferException Constructor

 Language:

Initializes a new instance of the CannotModifyIndexBufferException class.

Definition

Visual Basic | Public Sub New()
C# | public CannotModifyIndexBufferException();
C++ public:
CannotModifyIndexBufferException();
JScript | public function CannotModifyIndexBufferException();


ClipPlane Class (Microsoft.DirectX.Direct3D)

ClipPlane Class

Defines the clipping plane for a device.

Definition

Visual Basic NotInheritable Public Class ClipPlane
Inherits Object
C# | public sealed class ClipPlane : Object
C++ | public ref class ClipPlane sealed : Object
JScript | public final class ClipPlane extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetSingleArray | Retrieves the coefficients of a user-defined clipping plane for the device.
SetSingleArray | Sets the coefficients of a user-defined clipping plane for the device.

Properties

Property | Description
Enabled | Enables or disables a clipping plane.
Plane | Retrieves or sets the coefficients of a user-defined clipping plane for the device.

Inheritance Hierarchy

Object Leave Site
ClipPlane

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • ClipPlanes
  • Device


ClipPlane.GetSingleArray() Method (Microsoft.DirectX.Direct3D)

ClipPlane.GetSingleArray Method

Retrieves the coefficients of a user-defined clipping plane for the device.

Definition

Visual Basic | Public Function GetSingleArray() As Single()
C# | public float[] GetSingleArray();
C++ public:
array<float>^ GetSingleArray();
JScript | public function GetSingleArray() : float[];

Return Value

System.Single[]
Returns a four-element array of values that represent the coefficients of the clipping plane, in the form of the general plane equation. See Remarks.

Remarks

The coefficients that this method reports take the form of the general plane equation. If the values in the array at pPlane are labeled A, B, C, and D in the order in which they appear in the array, they will fit into the general plane equation so that Ax + By + Cz + Dw = 0. A point with homogeneous coordinates (x, y, z, w) is visible in the half space of the plane if Ax + By + Cz + Dw > = 0. Points that exist on or behind the clipping plane are clipped from the scene.

The plane equation this method uses exists in world space and is set by a previous call to ClipPlane.SetSingleArray.


ClipPlane.SetSingleArray(Single[]) Method (Microsoft.DirectX.Direct3D)

ClipPlane.SetSingleArray Method

Sets the coefficients of a user-defined clipping plane for the device.

Definition

Visual Basic Public Sub SetSingleArray( _
ByVal value() As Single _
)
C# public void SetSingleArray(
float[] value
);
C++ public:
void SetSingleArray(
array<float>^ value
);
JScript public function SetSingleArray(
value : float[]
);

Parameters

value System.Single[]
A four-element array of values that represent the clipping plane coefficients to set, in the form of the general plane equation. See Remarks.

Remarks

The coefficients that this method sets take the form of the general plane equation. If the values in the array are labeled A, B, C, and D in the order in which they appear in the array, they will fit into the general plane equation so that Ax + By + Cz + Dw = 0. A point with homogeneous coordinates (x, y, z, w) is visible in the half space of the plane if Ax + By + Cz + Dw > = 0. Points that exist behind the clipping plane are clipped from the scene.

When the fixed function pipeline is used, the plane equations are assumed to be in world space. When the programmable pipeline is used, the plane equations are assumed to be in the clipping space (the same space as output vertices).

This method does not enable the clipping plane equation to be set. To enable a clipping plane, set ClipPlane.Enabled to true.

Exceptions
ArgumentException Leave Site | value cannot be null or 0.
IndexOutOfRangeException Leave Site | value must be a four-element array.

See Also

  • ClipPlane.GetSingleArray


ClipPlane.Enabled Property (Microsoft.DirectX.Direct3D)

ClipPlane.Enabled Property

Enables or disables a clipping plane.

Definition

Visual Basic | Public Property Enabled As Boolean
C# | public bool Enabled { get; set; }
C++ public:
property bool Enabled {
bool get();
void set(bool value);
}
JScript public function get Enabled() : boolean
public function set Enabled(boolean);

Property Value

System.Boolean
Set to true to enable a clipping plane, or false to disable it.

This property is read/write.


ClipPlane.Plane Property (Microsoft.DirectX.Direct3D)

ClipPlane.Plane Property

Retrieves or sets the coefficients of a user-defined clipping plane for the device.

Definition

Visual Basic | Public Property Plane As Plane
C# | public Plane Plane { get; set; }
C++ public:
property Plane Plane {
Plane get();
void set(Plane value);
}
JScript public function get Plane() : Plane
public function set Plane(Plane);

Property Value

Microsoft.DirectX.Plane
User-defined clipping Plane.

This property is read/write.


ClipPlanes Class (Microsoft.DirectX.Direct3D)

ClipPlanes Class

Contains the clipping planes on the device.

Definition

Visual Basic NotInheritable Public Class ClipPlanes
Inherits Object
C# | public sealed class ClipPlanes : Object
C++ | public ref class ClipPlanes sealed : Object
JScript | public final class ClipPlanes extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DisableAll | Disables all clipping planes on the device.
EnableAll | Enables all clipping planes that have been set.

Properties

Property | Description
Item | Retrieves the ClipPlane object referenced by index.

Inheritance Hierarchy

Object Leave Site
ClipPlanes

Remarks

This class is a collection of ClipPlane objects that are associated with a Device.

ClipPlanes supports a maximum of 32 ClipPlane objects.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClipPlanes.DisableAll() Method (Microsoft.DirectX.Direct3D)

ClipPlanes.DisableAll Method

Disables all clipping planes on the device.

Definition

Visual Basic | Public Sub DisableAll()
C# | public void DisableAll();
C++ public:
void DisableAll();
JScript | public function DisableAll();


ClipPlanes.EnableAll() Method (Microsoft.DirectX.Direct3D)

ClipPlanes.EnableAll Method

Enables all clipping planes that have been set.

Definition

Visual Basic | Public Sub EnableAll()
C# | public void EnableAll();
C++ public:
void EnableAll();
JScript | public function EnableAll();


ClipPlanes.Item Property (Microsoft.DirectX.Direct3D)

ClipPlanes.Item Property

Retrieves the ClipPlane object referenced by index.

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal index As Integer _
) As ClipPlane
C# public ClipPlane this[
int index
] { get; }
C++ public:
property ClipPlane^ default [int] {
ClipPlane^ get(int index);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32
Index of the ClipPlane to retrieve.

Property Value

Microsoft.DirectX.Direct3D.ClipPlane
The ClipPlane referenced by index.

This property is read-only.

Remarks

The maximum number of clipping planes is 32.

Exceptions
ArgumentOutOfRangeException Leave Site The index parameter is out of range. It must be a value between 0 and 31.


ColorOperator Class (Microsoft.DirectX.Direct3D)

ColorOperator Class

Contains methods for manipulating colors.

Definition

Visual Basic NotInheritable MustInherit Public Class ColorOperator
Inherits Object
C# | public abstract sealed class ColorOperator : Object
C++ | public ref class ColorOperator abstract sealed : Object
JScript | public final abstract class ColorOperator extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) Add | Adds two color values together to create a new color value.
static (Shared in Visual Basic) AdjustContrast | Adjusts the contrast value of a color.
static (Shared in Visual Basic) AdjustSaturation | Adjusts the saturation value of a color.
static (Shared in Visual Basic) Lerp | Creates a color value using linear interpolation.
static (Shared in Visual Basic) Modulate | Blends two colors.
static (Shared in Visual Basic) Negative | Creates a negative color value from a given color value.
static (Shared in Visual Basic) Scale | Scales a color value.
static (Shared in Visual Basic) Subtract | Subtracts two color values to create a new color value.

Inheritance Hierarchy

Object Leave Site
ColorOperator

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorOperator.Add Method ()

Adds two color values together to create a new color value.

Overload List

public static Color Add(Color, Color);
public static ColorValue Add(ColorValue, ColorValue);
public static int Add(int, int);

See Also

  • ColorOperator.Subtract


ColorOperator.Add(ColorValue,ColorValue) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Add Method

Adds two color values together to create a new color value.

Definition

Visual Basic Public Shared Function Add( _
ByVal c1 As ColorValue, _
ByVal c2 As ColorValue _
) As ColorValue
C# public static ColorValue Add(
ColorValue c1,
ColorValue c2
);
C++ public:
static ColorValue Add(
ColorValue c1,
ColorValue c2
);
JScript public static function Add(
c1 : ColorValue,
c2 : ColorValue
) : ColorValue;

Parameters

c1 Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the color to add.
c2 Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the color to add.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
Returns a ColorValue object that represents the sum of the two colors added together.

See Also

  • ColorOperator.Subtract


ColorOperator.Add(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Add Method

Adds two color values together to create a new color value.

Definition

Visual Basic Public Shared Function Add( _
ByVal c1 As Integer, _
ByVal c2 As Integer _
) As Integer
C# public static int Add(
int c1,
int c2
);
C++ public:
static int Add(
int c1,
int c2
);
JScript public static function Add(
c1 : int,
c2 : int
) : int;

Parameters

c1 System.Int32
c2 System.Int32

Return Value

System.Int32

See Also

  • ColorOperator.Subtract


ColorOperator.Add(Color,Color) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Add Method

Adds two color values together to create a new color value.

Definition

Visual Basic Public Shared Function Add( _
ByVal c1 As Color, _
ByVal c2 As Color _
) As Color
C# public static Color Add(
Color c1,
Color c2
);
C++ public:
static Color Add(
Color c1,
Color c2
);
JScript public static function Add(
c1 : Color,
c2 : Color
) : Color;

Parameters

c1 System.Drawing.Color
A Color Leave Site object that specifies the color to add.
c2 System.Drawing.Color
A Color Leave Site object that specifies the color to add.

Return Value

System.Drawing.Color
Returns a Color Leave Site object that represents the sum of the two colors added together.

See Also

  • ColorOperator.Subtract


ColorOperator.AdjustContrast Method ()

Adjusts the contrast value of a color.

Overload List

public static Color AdjustContrast(Color, float);
public static ColorValue AdjustContrast(ColorValue, float);
public static int AdjustContrast(int, float);

Remarks

The s parameter linearly interpolates between 50 percent gray and the color. There are no limits on the parameter's value. If the value is 0, the returned color is 50 percent gray. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the contrast is decreased; if it is greater than 1, the contrast is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustContrast(ColorValue,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.AdjustContrast Method

Adjusts the contrast value of a color.

Definition

Visual Basic Public Shared Function AdjustContrast( _
ByVal c As ColorValue, _
ByVal s As Single _
) As ColorValue
C# public static ColorValue AdjustContrast(
ColorValue c,
float s
);
C++ public:
static ColorValue AdjustContrast(
ColorValue c,
float s
);
JScript public static function AdjustContrast(
c : ColorValue,
s : float
) : ColorValue;

Parameters

c Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the color to adjust.
s System.Single
Floating-point value that represents the contrast value to apply to the given color. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the result of the contrast adjustment.

Remarks

The s parameter linearly interpolates between 50 percent gray and the color. There are no limits on the parameter's value. If the value is 0, the returned color is 50 percent gray. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the contrast is decreased; if it is greater than 1, the contrast is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustContrast(Int32,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.AdjustContrast Method

Adjusts the contrast value of a color.

Definition

Visual Basic Public Shared Function AdjustContrast( _
ByVal c As Integer, _
ByVal s As Single _
) As Integer
C# public static int AdjustContrast(
int c,
float s
);
C++ public:
static int AdjustContrast(
int c,
float s
);
JScript public static function AdjustContrast(
c : int,
s : float
) : int;

Parameters

c System.Int32
s System.Single
Floating-point value that represents the contrast value to apply to the given color. See Remarks.

Return Value

System.Int32

Remarks

The s parameter linearly interpolates between 50 percent gray and the color. There are no limits on the parameter's value. If the value is 0, the returned color is 50 percent gray. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the contrast is decreased; if it is greater than 1, the contrast is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustContrast(Color,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.AdjustContrast Method

Adjusts the contrast value of a color.

Definition

Visual Basic Public Shared Function AdjustContrast( _
ByVal c As Color, _
ByVal s As Single _
) As Color
C# public static Color AdjustContrast(
Color c,
float s
);
C++ public:
static Color AdjustContrast(
Color c,
float s
);
JScript public static function AdjustContrast(
c : Color,
s : float
) : Color;

Parameters

c System.Drawing.Color
A Color Leave Site object that specifies the color to adjust.
s System.Single
Floating-point value that represents the contrast value to apply to the given color. See Remarks.

Return Value

System.Drawing.Color
Returns a Color Leave Site object that represents the result of the contrast adjustment.

Remarks

The s parameter linearly interpolates between 50 percent gray and the color. There are no limits on the parameter's value. If the value is 0, the returned color is 50 percent gray. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the contrast is decreased; if it is greater than 1, the contrast is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustSaturation Method ()

Adjusts the saturation value of a color.

Overload List

public static Color AdjustSaturation(Color, float);
public static ColorValue AdjustSaturation(ColorValue, float);
public static int AdjustSaturation(int, float);

Remarks

The s parameter linearly interpolates between the color converted to grayscale and the original color. There are no limits on the parameter's value. If the value is 0, the returned color is the grayscale color. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the saturation is decreased; if it is greater than 1, the saturation is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustSaturation(ColorValue,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.AdjustSaturation Method

Adjusts the saturation value of a color.

Definition

Visual Basic Public Shared Function AdjustSaturation( _
ByVal c As ColorValue, _
ByVal s As Single _
) As ColorValue
C# public static ColorValue AdjustSaturation(
ColorValue c,
float s
);
C++ public:
static ColorValue AdjustSaturation(
ColorValue c,
float s
);
JScript public static function AdjustSaturation(
c : ColorValue,
s : float
) : ColorValue;

Parameters

c Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the color to adjust.
s System.Single
Floating-point value that represents the saturation value to apply to the given color. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the result of the saturation adjustment.

Remarks

The s parameter linearly interpolates between the color converted to grayscale and the original color. There are no limits on the parameter's value. If the value is 0, the returned color is the grayscale color. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the saturation is decreased; if it is greater than 1, the saturation is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustSaturation(Int32,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.AdjustSaturation Method

Adjusts the saturation value of a color.

Definition

Visual Basic Public Shared Function AdjustSaturation( _
ByVal c As Integer, _
ByVal s As Single _
) As Integer
C# public static int AdjustSaturation(
int c,
float s
);
C++ public:
static int AdjustSaturation(
int c,
float s
);
JScript public static function AdjustSaturation(
c : int,
s : float
) : int;

Parameters

c System.Int32
s System.Single
Floating-point value that represents the saturation value to apply to the given color. See Remarks.

Return Value

System.Int32

Remarks

The s parameter linearly interpolates between the color converted to grayscale and the original color. There are no limits on the parameter's value. If the value is 0, the returned color is the grayscale color. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the saturation is decreased; if it is greater than 1, the saturation is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.AdjustSaturation(Color,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.AdjustSaturation Method

Adjusts the saturation value of a color.

Definition

Visual Basic Public Shared Function AdjustSaturation( _
ByVal c As Color, _
ByVal s As Single _
) As Color
C# public static Color AdjustSaturation(
Color c,
float s
);
C++ public:
static Color AdjustSaturation(
Color c,
float s
);
JScript public static function AdjustSaturation(
c : Color,
s : float
) : Color;

Parameters

c System.Drawing.Color
A Color Leave Site object that specifies the color to adjust.
s System.Single
Floating-point value that represents the saturation value to apply to the given color. See Remarks.

Return Value

System.Drawing.Color
Returns a Color Leave Site object that represents the result of the saturation adjustment.

Remarks

The s parameter linearly interpolates between the color converted to grayscale and the original color. There are no limits on the parameter's value. If the value is 0, the returned color is the grayscale color. If the value is 1, the returned color is the original color. If s is greater than 0 and less than 1, the saturation is decreased; if it is greater than 1, the saturation is increased.

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Lerp Method ()

Creates a color value using linear interpolation.

Overload List

public static Color Lerp(Color, Color, float);
public static ColorValue Lerp(ColorValue, ColorValue, float);
public static int Lerp(int, int, float);

Remarks

If linear interpolation is performed between the colors A and B, and s is 0, the resulting color is A. If s is 1, the resulting color is B.


ColorOperator.Lerp(ColorValue,ColorValue,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Lerp Method

Creates a color value using linear interpolation.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal c1 As ColorValue, _
ByVal c2 As ColorValue, _
ByVal s As Single _
) As ColorValue
C# public static ColorValue Lerp(
ColorValue c1,
ColorValue c2,
float s
);
C++ public:
static ColorValue Lerp(
ColorValue c1,
ColorValue c2,
float s
);
JScript public static function Lerp(
c1 : ColorValue,
c2 : ColorValue,
s : float
) : ColorValue;

Parameters

c1 Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the first source color.
c2 Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the second source color.
s System.Single
Floating-point value that linearly interpolates between the colors c1 and c2, treating them both as 4-D vectors. There are no limits on this parameter's value.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the result of the linear interpolation.

Remarks

If linear interpolation is performed between the colors A and B, and s is 0, the resulting color is A. If s is 1, the resulting color is B.


ColorOperator.Lerp(Int32,Int32,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Lerp Method

Creates a color value using linear interpolation.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal c1 As Integer, _
ByVal c2 As Integer, _
ByVal s As Single _
) As Integer
C# public static int Lerp(
int c1,
int c2,
float s
);
C++ public:
static int Lerp(
int c1,
int c2,
float s
);
JScript public static function Lerp(
c1 : int,
c2 : int,
s : float
) : int;

Parameters

c1 System.Int32
c2 System.Int32
s System.Single
Floating-point value that linearly interpolates between the colors c1 and c2, treating them both as 4-D vectors. There are no limits on this parameter's value.

Return Value

System.Int32

Remarks

If linear interpolation is performed between the colors A and B, and s is 0, the resulting color is A. If s is 1, the resulting color is B.


ColorOperator.Lerp(Color,Color,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Lerp Method

Creates a color value using linear interpolation.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal c1 As Color, _
ByVal c2 As Color, _
ByVal s As Single _
) As Color
C# public static Color Lerp(
Color c1,
Color c2,
float s
);
C++ public:
static Color Lerp(
Color c1,
Color c2,
float s
);
JScript public static function Lerp(
c1 : Color,
c2 : Color,
s : float
) : Color;

Parameters

c1 System.Drawing.Color
A Color Leave Site object that specifies the first source color.
c2 System.Drawing.Color
A Color Leave Site object that specifies the second source color.
s System.Single
Floating-point value that linearly interpolates between the colors c1 and c2, treating them both as 4-D vectors. There are no limits on this parameter's value.

Return Value

System.Drawing.Color
A Color Leave Site object that represents the result of the linear interpolation.

Remarks

If linear interpolation is performed between the colors A and B, and s is 0, the resulting color is A. If s is 1, the resulting color is B.


ColorOperator.Modulate Method ()

Blends two colors.

Overload List

public static Color Modulate(Color, Color);
public static ColorValue Modulate(ColorValue, ColorValue);
public static int Modulate(int, int);

Remarks

This method blends two colors by multiplying matching color components.


ColorOperator.Modulate(ColorValue,ColorValue) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Modulate Method

Blends two colors.

Definition

Visual Basic Public Shared Function Modulate( _
ByVal c1 As ColorValue, _
ByVal c2 As ColorValue _
) As ColorValue
C# public static ColorValue Modulate(
ColorValue c1,
ColorValue c2
);
C++ public:
static ColorValue Modulate(
ColorValue c1,
ColorValue c2
);
JScript public static function Modulate(
c1 : ColorValue,
c2 : ColorValue
) : ColorValue;

Parameters

c1 Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the first source color to modulate.
c2 Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the second source color to modulate.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the result of the blending operation.

Remarks

This method blends two colors by multiplying matching color components.


ColorOperator.Modulate(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Modulate Method

Blends two colors.

Definition

Visual Basic Public Shared Function Modulate( _
ByVal c1 As Integer, _
ByVal c2 As Integer _
) As Integer
C# public static int Modulate(
int c1,
int c2
);
C++ public:
static int Modulate(
int c1,
int c2
);
JScript public static function Modulate(
c1 : int,
c2 : int
) : int;

Parameters

c1 System.Int32
c2 System.Int32

Return Value

System.Int32

Remarks

This method blends two colors by multiplying matching color components.


ColorOperator.Modulate(Color,Color) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Modulate Method

Blends two colors.

Definition

Visual Basic Public Shared Function Modulate( _
ByVal c1 As Color, _
ByVal c2 As Color _
) As Color
C# public static Color Modulate(
Color c1,
Color c2
);
C++ public:
static Color Modulate(
Color c1,
Color c2
);
JScript public static function Modulate(
c1 : Color,
c2 : Color
) : Color;

Parameters

c1 System.Drawing.Color
A Color Leave Site object that specifies the first source color to modulate.
c2 System.Drawing.Color
A Color Leave Site object that specifies the second source color to modulate.

Return Value

System.Drawing.Color
A Color Leave Site object that represents the result of the blending operation.

Remarks

This method blends two colors by multiplying matching color components.


ColorOperator.Negative Method ()

Creates a negative color value from a given color value.

Overload List

public static Color Negative(Color);
public static ColorValue Negative(ColorValue);
public static int Negative(int);

Remarks

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Negative(ColorValue) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Negative Method

Creates a negative color value from a given color value.

Definition

Visual Basic Public Shared Function Negative( _
ByVal c As ColorValue _
) As ColorValue
C# public static ColorValue Negative(
ColorValue c
);
C++ public:
static ColorValue Negative(
ColorValue c
);
JScript public static function Negative(
c : ColorValue
) : ColorValue;

Parameters

c Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the source color.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the negative color value of the source color.

Remarks

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Negative(Int32) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Negative Method

Creates a negative color value from a given color value.

Definition

Visual Basic Public Shared Function Negative( _
ByVal c As Integer _
) As Integer
C# public static int Negative(
int c
);
C++ public:
static int Negative(
int c
);
JScript public static function Negative(
c : int
) : int;

Parameters

c System.Int32

Return Value

System.Int32

Remarks

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Negative(Color) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Negative Method

Creates a negative color value from a given color value.

Definition

Visual Basic Public Shared Function Negative( _
ByVal c As Color _
) As Color
C# public static Color Negative(
Color c
);
C++ public:
static Color Negative(
Color c
);
JScript public static function Negative(
c : Color
) : Color;

Parameters

c System.Drawing.Color
A Color Leave Site object that specifies the source color.

Return Value

System.Drawing.Color
A Color Leave Site object that represents the negative color value of the source color.

Remarks

The input alpha channel is copied, unmodified, to the output alpha channel.


ColorOperator.Scale Method ()

Scales a color value.

Overload List

public static Color Scale(Color, float);
public static ColorValue Scale(ColorValue, float);
public static int Scale(int, float);


ColorOperator.Scale(ColorValue,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Scale Method

Scales a color value.

Definition

Visual Basic Public Shared Function Scale( _
ByVal c As ColorValue, _
ByVal s As Single _
) As ColorValue
C# public static ColorValue Scale(
ColorValue c,
float s
);
C++ public:
static ColorValue Scale(
ColorValue c,
float s
);
JScript public static function Scale(
c : ColorValue,
s : float
) : ColorValue;

Parameters

c Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the source color to scale.
s System.Single
Floating-point value that represents the scaling factor to apply. The scaling factor scales the color, treating it like a 4-D vector. There are no limits on this parameter's value. If s is 1, the resulting color is the original color.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that is the scaled color value.


ColorOperator.Scale(Int32,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Scale Method

Scales a color value.

Definition

Visual Basic Public Shared Function Scale( _
ByVal c As Integer, _
ByVal s As Single _
) As Integer
C# public static int Scale(
int c,
float s
);
C++ public:
static int Scale(
int c,
float s
);
JScript public static function Scale(
c : int,
s : float
) : int;

Parameters

c System.Int32
s System.Single
Floating-point value that represents the scaling factor to apply. The scaling factor scales the color, treating it like a 4-D vector. There are no limits on this parameter's value. If s is 1, the resulting color is the original color.

Return Value

System.Int32


ColorOperator.Scale(Color,Single) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Scale Method

Scales a color value.

Definition

Visual Basic Public Shared Function Scale( _
ByVal c As Color, _
ByVal s As Single _
) As Color
C# public static Color Scale(
Color c,
float s
);
C++ public:
static Color Scale(
Color c,
float s
);
JScript public static function Scale(
c : Color,
s : float
) : Color;

Parameters

c System.Drawing.Color
A Color Leave Site object that specifies the source color to scale.
s System.Single
Floating-point value that represents the scaling factor to apply. The scaling factor scales the color, treating it like a 4-D vector. There are no limits on this parameter's value. If s is 1, the resulting color is the original color.

Return Value

System.Drawing.Color
A Color Leave Site object that is the scaled color value.


ColorOperator.Subtract Method ()

Subtracts two color values to create a new color value.

Overload List

public static Color Subtract(Color, Color);
public static ColorValue Subtract(ColorValue, ColorValue);
public static int Subtract(int, int);

See Also

  • ColorOperator.Add


ColorOperator.Subtract(ColorValue,ColorValue) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Subtract Method

Subtracts two color values to create a new color value.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal c1 As ColorValue, _
ByVal c2 As ColorValue _
) As ColorValue
C# public static ColorValue Subtract(
ColorValue c1,
ColorValue c2
);
C++ public:
static ColorValue Subtract(
ColorValue c1,
ColorValue c2
);
JScript public static function Subtract(
c1 : ColorValue,
c2 : ColorValue
) : ColorValue;

Parameters

c1 Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the color to subtract.
c2 Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that specifies the color to subtract.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the difference between the two colors.

See Also

  • ColorOperator.Add


ColorOperator.Subtract(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Subtract Method

Subtracts two color values to create a new color value.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal c1 As Integer, _
ByVal c2 As Integer _
) As Integer
C# public static int Subtract(
int c1,
int c2
);
C++ public:
static int Subtract(
int c1,
int c2
);
JScript public static function Subtract(
c1 : int,
c2 : int
) : int;

Parameters

c1 System.Int32
c2 System.Int32

Return Value

System.Int32

See Also

  • ColorOperator.Add


ColorOperator.Subtract(Color,Color) Method (Microsoft.DirectX.Direct3D)

ColorOperator.Subtract Method

Subtracts two color values to create a new color value.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal c1 As Color, _
ByVal c2 As Color _
) As Color
C# public static Color Subtract(
Color c1,
Color c2
);
C++ public:
static Color Subtract(
Color c1,
Color c2
);
JScript public static function Subtract(
c1 : Color,
c2 : Color
) : Color;

Parameters

c1 System.Drawing.Color
A Color Leave Site object that specifies the color to subtract.
c2 System.Drawing.Color
A Color Leave Site object that specifies the color to subtract.

Return Value

System.Drawing.Color
A Color Leave Site object that represents the difference between the two colors.

See Also

  • ColorOperator.Add


CompressedAnimationSet Class (Microsoft.DirectX.Direct3D)

CompressedAnimationSet Class

Implements a keyframe animation set that is stored in a compressed data format.

Definition

Visual Basic NotInheritable Public Class CompressedAnimationSet
Inherits AnimationSet
C# | public sealed class CompressedAnimationSet : AnimationSet
C++ | public ref class CompressedAnimationSet sealed : AnimationSet
JScript | public final class CompressedAnimationSet extends AnimationSet

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CompressedAnimationSet object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
CompressedAnimationSet | Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.
Dispose | Immediately releases the unmanaged resources used by the CompressedAnimationSet object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CompressedAnimationSet object to free resources before it is destroyed by the garbage collector.
GetAnimationIndex | Retrieves the index of an animation, given its name. Inherited from AnimationSet.
GetAnimationName | Retrieves the name of an animation, given its index. Inherited from AnimationSet.
GetCallback | Retrieves information about a specific callback in an animation set. Inherited from AnimationSet.
GetCallbackKeys | Fills an array with callback key data that is used for keyframe animation.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPeriodicPosition | Returns the time position in the local timeframe of an animation set. Inherited from AnimationSet.
GetScaleRotateTranslate | Retrieves the scale, rotate, and translate (SRT) values of an animation set. Inherited from AnimationSet.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from AnimationSet.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from AnimationSet.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this CompressedAnimationSet object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this AnimationSet object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code. Inherited from AnimationSet.

Properties

Property | Description
CompressedData | Retrieves the data buffer that stores compressed keyframe animation data.
Disposed | Gets a value that indicates whether the object is disposed.
Name | Retrieves the name of an animation set. Inherited from AnimationSet.
NumberAnimations | Retrieves a value that indicates the number of animations in the animation set. Inherited from AnimationSet.
NumberCallbackKeys | Retrieves the number of callback keys in the animation set.
Period | Retrieves the period of an animation set. Inherited from AnimationSet.
PlaybackType | Retrieves the type of the animation set playback loop.
SourceTicksPerSecond | Retrieves the number of animation keyframe ticks that occur per second.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXAnimationSet interface pointer. Inherited from AnimationSet.
UnmanagedComPointer | Returns the unmanaged COM ID3DXCompressedAnimationSet interface pointer.

Inheritance Hierarchy

Object Leave Site
AnimationSet
CompressedAnimationSet

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CompressedAnimationSet.CompressedAnimationSet Constructor ()

Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.

Overload List

public CompressedAnimationSet(ID3DXCompressedAnimationSet);
public CompressedAnimationSet(IntPtr);
public CompressedAnimationSet(string, double, PlaybackType, GraphicsStream, KeyCallback[]);


CompressedAnimationSet.CompressedAnimationSet(ID3DXCompressedAnimationSet) Constructor (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.CompressedAnimationSet Constructor

Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As ID3DXCompressedAnimationSet _
)
C# public CompressedAnimationSet(
ID3DXCompressedAnimationSet pInterop
);
C++ public:
CompressedAnimationSet(
ID3DXCompressedAnimationSet pInterop
);
JScript public function CompressedAnimationSet(
pInterop : ID3DXCompressedAnimationSet
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXCompressedAnimationSet
Unmanaged Component Object Model (COM) ID3DXCompressedAnimationSet interface pointer.


CompressedAnimationSet.CompressedAnimationSet(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.CompressedAnimationSet Constructor

Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public CompressedAnimationSet(
IntPtr unmanagedObject
);
C++ public:
CompressedAnimationSet(
IntPtr unmanagedObject
);
JScript public function CompressedAnimationSet(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXCompressedAnimationSet interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


CompressedAnimationSet.CompressedAnimationSet(String,Double,PlaybackType,GraphicsStream,KeyCallback[]) Constructor (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.CompressedAnimationSet Constructor

Creates a CompressedAnimationSet object that stores key-frame data in a compressed format.

Definition

Visual Basic Public Sub New( _
ByVal name As String, _
ByVal ticksPerSecond As Double, _
ByVal playback As PlaybackType, _
ByVal compressedData As GraphicsStream, _
ByVal callbackKeys() As KeyCallback _
)
C# public CompressedAnimationSet(
string name,
double ticksPerSecond,
PlaybackType playback,
GraphicsStream compressedData,
KeyCallback[] callbackKeys
);
C++ public:
CompressedAnimationSet(
String^ name,
double ticksPerSecond,
PlaybackType playback,
GraphicsStream^ compressedData,
array<KeyCallback>^ callbackKeys
);
JScript public function CompressedAnimationSet(
name : String,
ticksPerSecond : double,
playback : PlaybackType,
compressedData : GraphicsStream,
callbackKeys : KeyCallback[]
);

Parameters

name System.String
Animation set name.
ticksPerSecond System.Double
Number of key-frame ticks that elapse per second.
playback Microsoft.DirectX.Direct3D.PlaybackType
Type of the animation set playback loop. See PlaybackType.
compressedData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the animation set graphics data.
callbackKeys Microsoft.DirectX.Direct3D.KeyCallback[]
Array of KeyCallback objects that store user callback data.


CompressedAnimationSet.Dispose() Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.Dispose Method

Immediately releases the unmanaged resources used by the CompressedAnimationSet object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~CompressedAnimationSet();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposed
  • Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposing


CompressedAnimationSet.Equals(Object) Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CompressedAnimationSet.Finalize() Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.Finalize Method

Allows the CompressedAnimationSet object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~CompressedAnimationSet();
C++ | !CompressedAnimationSet();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


CompressedAnimationSet.GetCallbackKeys() Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.GetCallbackKeys Method

Fills an array with callback key data that is used for keyframe animation.

Definition

Visual Basic | Public Function GetCallbackKeys() As KeyCallback()
C# | public KeyCallback[] GetCallbackKeys();
C++ public:
array<KeyCallback>^ GetCallbackKeys();
JScript | public function GetCallbackKeys() : KeyCallback[];

Return Value

Microsoft.DirectX.Direct3D.KeyCallback[]
Returns an array of KeyCallback objects filled with callback data.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


CompressedAnimationSet.GetHashCode() Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


CompressedAnimationSet.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXCompressedAnimationSet, which allows unmanaged COM clients to create an instance of the managed CompressedAnimationSet class. Not supported.


CompressedAnimationSet.op_Equality(CompressedAnimationSet,CompressedAnimationSet) Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As CompressedAnimationSet, _
ByVal right As CompressedAnimationSet _
) As Boolean
C# public static bool op_Equality(
CompressedAnimationSet left,
CompressedAnimationSet right
);
C++ public:
static bool operator==(
CompressedAnimationSet^ left,
CompressedAnimationSet^ right
);
JScript public static function op_Equality(
left : CompressedAnimationSet,
right : CompressedAnimationSet
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.CompressedAnimationSet
The CompressedAnimationSet object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.CompressedAnimationSet
The CompressedAnimationSet object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CompressedAnimationSet.op_Inequality(CompressedAnimationSet,CompressedAnimationSet) Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As CompressedAnimationSet, _
ByVal right As CompressedAnimationSet _
) As Boolean
C# public static bool op_Inequality(
CompressedAnimationSet left,
CompressedAnimationSet right
);
C++ public:
static bool operator!=(
CompressedAnimationSet^ left,
CompressedAnimationSet^ right
);
JScript public static function op_Inequality(
left : CompressedAnimationSet,
right : CompressedAnimationSet
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.CompressedAnimationSet
The CompressedAnimationSet object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.CompressedAnimationSet
The CompressedAnimationSet object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


CompressedAnimationSet.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


CompressedAnimationSet.UpdateUnmanagedPointer(ID3DXCompressedAnimationSet) Method (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this CompressedAnimationSet object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXCompressedAnimationSet _
)
C# public void UpdateUnmanagedPointer(
ID3DXCompressedAnimationSet pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXCompressedAnimationSet pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXCompressedAnimationSet
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXCompressedAnimationSet
Pointer to the ID3DXCompressedAnimationSet structure used to update the unmanaged pointer for this CompressedAnimationSet object.


CompressedAnimationSet.CompressedData Property (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.CompressedData Property

Retrieves the data buffer that stores compressed keyframe animation data.

Definition

Visual Basic | Public ReadOnly Property CompressedData As GraphicsStream
C# | public GraphicsStream CompressedData { get; }
C++ public:
property GraphicsStream^ CompressedData {
GraphicsStream^ get();
}
JScript | public function get CompressedData() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains compressed keyframe animation data.

This property is read-only.


CompressedAnimationSet.Disposed Property (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public Shadows ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


CompressedAnimationSet.NumberCallbackKeys Property (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.NumberCallbackKeys Property

Retrieves the number of callback keys in the animation set.

Definition

Visual Basic | Public ReadOnly Property NumberCallbackKeys As Integer
C# | public int NumberCallbackKeys { get; }
C++ public:
property int NumberCallbackKeys {
int get();
}
JScript | public function get NumberCallbackKeys() : int

Property Value

System.Int32
Number of callback keys in the animation set.

This property is read-only.


CompressedAnimationSet.PlaybackType Property (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.PlaybackType Property

Retrieves the type of the animation set playback loop.

Definition

Visual Basic | Public ReadOnly Property PlaybackType As PlaybackType
C# | public PlaybackType PlaybackType { get; }
C++ public:
property PlaybackType PlaybackType {
PlaybackType get();
}
JScript | public function get PlaybackType() : PlaybackType

Property Value

Microsoft.DirectX.Direct3D.PlaybackType
Type of the animation set playback loop.

This property is read-only.


CompressedAnimationSet.SourceTicksPerSecond Property (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.SourceTicksPerSecond Property

Retrieves the number of animation keyframe ticks that occur per second.

Definition

Visual Basic | Public ReadOnly Property SourceTicksPerSecond As Double
C# | public double SourceTicksPerSecond { get; }
C++ public:
property double SourceTicksPerSecond {
double get();
}
JScript | public function get SourceTicksPerSecond() : double

Property Value

System.Double
Number of animation keyframe ticks per second.

This property is read-only.


CompressedAnimationSet.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXCompressedAnimationSet interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As ID3DXCompressedAnimationSet
C# | public ID3DXCompressedAnimationSet UnmanagedComPointer { get; }
C++ public:
property ID3DXCompressedAnimationSet UnmanagedComPointer {
ID3DXCompressedAnimationSet get();
}
JScript | public function get UnmanagedComPointer() : ID3DXCompressedAnimationSet

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXCompressedAnimationSet
Unmanaged ID3DXCompressedAnimationSet interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


CompressedAnimationSet.Disposing Event (Microsoft.DirectX.Direct3D)

CompressedAnimationSet.Disposing Event

Occurs when the Dispose method is called or when the CompressedAnimationSet object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.CompressedAnimationSet.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CompressedAnimationSet object indicates whether that object has been disposed.


ConflictingRenderStateException Class (Microsoft.DirectX.Direct3D)

ConflictingRenderStateException Class

The currently set render states cannot be used together.

Definition

Visual Basic Public Class ConflictingRenderStateException
Inherits GraphicsException
C# | public class ConflictingRenderStateException : GraphicsException
C++ | public ref class ConflictingRenderStateException : GraphicsException
JScript | public class ConflictingRenderStateException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConflictingRenderStateException | Initializes a new instance of the ConflictingRenderStateException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ConflictingRenderStateException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConflictingRenderStateException.ConflictingRenderStateException Constructor ()

Initializes a new instance of the ConflictingRenderStateException class.

Overload List

public ConflictingRenderStateException();
protected ConflictingRenderStateException(SerializationInfo, StreamingContext);
public ConflictingRenderStateException(string);
public ConflictingRenderStateException(string, Exception);


ConflictingRenderStateException.ConflictingRenderStateException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:

Initializes a new instance of the ConflictingRenderStateException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConflictingRenderStateException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConflictingRenderStateException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConflictingRenderStateException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


ConflictingRenderStateException.ConflictingRenderStateException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:

Initializes a new instance of the ConflictingRenderStateException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConflictingRenderStateException(
string message,
Exception inner
);
C++ public:
ConflictingRenderStateException(
String^ message,
Exception^ inner
);
JScript public function ConflictingRenderStateException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


ConflictingRenderStateException.ConflictingRenderStateException(String) Constructor (Microsoft.DirectX.Direct3D)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:

Initializes a new instance of the ConflictingRenderStateException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConflictingRenderStateException(
string message
);
C++ public:
ConflictingRenderStateException(
String^ message
);
JScript public function ConflictingRenderStateException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


ConflictingRenderStateException.ConflictingRenderStateException() Constructor (Microsoft.DirectX.Direct3D)

ConflictingRenderStateException.ConflictingRenderStateException Constructor

 Language:

Initializes a new instance of the ConflictingRenderStateException class.

Definition

Visual Basic | Public Sub New()
C# | public ConflictingRenderStateException();
C++ public:
ConflictingRenderStateException();
JScript | public function ConflictingRenderStateException();


ConflictingTextureFilterException Class (Microsoft.DirectX.Direct3D)

ConflictingTextureFilterException Class

The current texture filters cannot be used together.

Definition

Visual Basic Public Class ConflictingTextureFilterException
Inherits GraphicsException
C# | public class ConflictingTextureFilterException : GraphicsException
C++ | public ref class ConflictingTextureFilterException : GraphicsException
JScript | public class ConflictingTextureFilterException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConflictingTextureFilterException | Initializes a new instance of the ConflictingTextureFilterException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ConflictingTextureFilterException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConflictingTextureFilterException.ConflictingTextureFilterException Constructor ()

Initializes a new instance of the ConflictingTextureFilterException class.

Overload List

public ConflictingTextureFilterException();
protected ConflictingTextureFilterException(SerializationInfo, StreamingContext);
public ConflictingTextureFilterException(string);
public ConflictingTextureFilterException(string, Exception);


ConflictingTextureFilterException.ConflictingTextureFilterException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:

Initializes a new instance of the ConflictingTextureFilterException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConflictingTextureFilterException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConflictingTextureFilterException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConflictingTextureFilterException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


ConflictingTextureFilterException.ConflictingTextureFilterException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:

Initializes a new instance of the ConflictingTextureFilterException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConflictingTextureFilterException(
string message,
Exception inner
);
C++ public:
ConflictingTextureFilterException(
String^ message,
Exception^ inner
);
JScript public function ConflictingTextureFilterException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


ConflictingTextureFilterException.ConflictingTextureFilterException(String) Constructor (Microsoft.DirectX.Direct3D)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:

Initializes a new instance of the ConflictingTextureFilterException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConflictingTextureFilterException(
string message
);
C++ public:
ConflictingTextureFilterException(
String^ message
);
JScript public function ConflictingTextureFilterException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


ConflictingTextureFilterException.ConflictingTextureFilterException() Constructor (Microsoft.DirectX.Direct3D)

ConflictingTextureFilterException.ConflictingTextureFilterException Constructor

 Language:

Initializes a new instance of the ConflictingTextureFilterException class.

Definition

Visual Basic | Public Sub New()
C# | public ConflictingTextureFilterException();
C++ public:
ConflictingTextureFilterException();
JScript | public function ConflictingTextureFilterException();


ConflictingTexturePaletteException Class (Microsoft.DirectX.Direct3D)

ConflictingTexturePaletteException Class

The current textures cannot be used simultaneously.

Definition

Visual Basic Public Class ConflictingTexturePaletteException
Inherits GraphicsException
C# | public class ConflictingTexturePaletteException : GraphicsException
C++ | public ref class ConflictingTexturePaletteException : GraphicsException
JScript | public class ConflictingTexturePaletteException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConflictingTexturePaletteException | Initializes a new instance of the ConflictingTexturePaletteException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ConflictingTexturePaletteException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor ()

Initializes a new instance of the ConflictingTexturePaletteException class.

Overload List

public ConflictingTexturePaletteException();
protected ConflictingTexturePaletteException(SerializationInfo, StreamingContext);
public ConflictingTexturePaletteException(string);
public ConflictingTexturePaletteException(string, Exception);


ConflictingTexturePaletteException.ConflictingTexturePaletteException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:

Initializes a new instance of the ConflictingTexturePaletteException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConflictingTexturePaletteException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConflictingTexturePaletteException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConflictingTexturePaletteException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


ConflictingTexturePaletteException.ConflictingTexturePaletteException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:

Initializes a new instance of the ConflictingTexturePaletteException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConflictingTexturePaletteException(
string message,
Exception inner
);
C++ public:
ConflictingTexturePaletteException(
String^ message,
Exception^ inner
);
JScript public function ConflictingTexturePaletteException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


ConflictingTexturePaletteException.ConflictingTexturePaletteException(String) Constructor (Microsoft.DirectX.Direct3D)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:

Initializes a new instance of the ConflictingTexturePaletteException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConflictingTexturePaletteException(
string message
);
C++ public:
ConflictingTexturePaletteException(
String^ message
);
JScript public function ConflictingTexturePaletteException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


ConflictingTexturePaletteException.ConflictingTexturePaletteException() Constructor (Microsoft.DirectX.Direct3D)

ConflictingTexturePaletteException.ConflictingTexturePaletteException Constructor

 Language:

Initializes a new instance of the ConflictingTexturePaletteException class.

Definition

Visual Basic | Public Sub New()
C# | public ConflictingTexturePaletteException();
C++ public:
ConflictingTexturePaletteException();
JScript | public function ConflictingTexturePaletteException();


ConstantTable Class (Microsoft.DirectX.Direct3D)

ConstantTable Class

Provides access to the constant table, which contains the variables that are used by high-level language shaders and effects.

Definition

Visual Basic NotInheritable Public Class ConstantTable
Inherits Object
Implements IDisposable
C# | public sealed class ConstantTable : Object, IDisposable
C++ | public ref class ConstantTable sealed : Object, IDisposable
JScript | public final class ConstantTable extends Object implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the ConstantTable object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
ConstantTable | Initializes a new instance of the ConstantTable class.
Dispose | Immediately releases the unmanaged resources used by the ConstantTable object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the ConstantTable object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FromShader | Returns a constant table from a GraphicsStream shader data object.
GetConstant | Retrieves a constant by looking up its index or by name.
GetConstantDescription | Retrieves an array of constant descriptions in the constant table.
GetConstantElement | Retrieves a constant from an array of constants.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetSamplerIndex | Retrieves the sampler index.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.ConstantTable.Disposing event when called from within a derived class.
SetDefaults | Sets constants to their default values, which are declared in the variable declarations in the shader.
SetValue | Sets the value to the constant table.
SetValueTranspose | Sets a Matrix or an array of matrices to the constant table.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this ConstantTable object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves a description of the constant table.
Disposed | Gets a value that indicates whether the object is disposed.
StreamData | Retrieves a GraphicsStream object that contains the constant table.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXConstantTable interface pointer.

Inheritance Hierarchy

Object Leave Site
ConstantTable

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConstantTable.ConstantTable Constructor ()

Initializes a new instance of the ConstantTable class.

Overload List

public ConstantTable(ID3DXConstantTable);
public ConstantTable(IntPtr);


ConstantTable.ConstantTable(ID3DXConstantTable) Constructor (Microsoft.DirectX.Direct3D)

ConstantTable.ConstantTable Constructor

Initializes a new instance of the ConstantTable class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXConstantTable _
)
C# public ConstantTable(
ID3DXConstantTable pUnk
);
C++ public:
ConstantTable(
ID3DXConstantTable pUnk
);
JScript public function ConstantTable(
pUnk : ID3DXConstantTable
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXConstantTable
Unmanaged Component Object Model (COM) ID3DXConstantTable interface pointer.


ConstantTable.ConstantTable(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

ConstantTable.ConstantTable Constructor

Initializes a new instance of the ConstantTable class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public ConstantTable(
IntPtr unmanagedObject
);
C++ public:
ConstantTable(
IntPtr unmanagedObject
);
JScript public function ConstantTable(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXConstantTable interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


ConstantTable.Dispose() Method (Microsoft.DirectX.Direct3D)

ConstantTable.Dispose Method

Immediately releases the unmanaged resources used by the ConstantTable object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~ConstantTable();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.ConstantTable.Disposed
  • Microsoft.DirectX.Direct3D.ConstantTable.Disposing


ConstantTable.Equals(Object) Method (Microsoft.DirectX.Direct3D)

ConstantTable.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


ConstantTable.Finalize() Method (Microsoft.DirectX.Direct3D)

ConstantTable.Finalize Method

Allows the ConstantTable object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~ConstantTable();
C++ | !ConstantTable();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


ConstantTable.FromShader(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

ConstantTable.FromShader Method

Returns a constant table from a GraphicsStream shader data object.

Definition

Visual Basic Public Shared Function FromShader( _
ByVal code As GraphicsStream _
) As ConstantTable
C# public static ConstantTable FromShader(
GraphicsStream code
);
C++ public:
static ConstantTable^ FromShader(
GraphicsStream^ code
);
JScript public static function FromShader(
code : GraphicsStream
) : ConstantTable;

Parameters

code Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains shader data.

Return Value

Microsoft.DirectX.Direct3D.ConstantTable
The constant table contained within the GraphicsStream object.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.GetConstant Method ()

Retrieves a constant by looking up its index or by name.

Overload List

public EffectHandle GetConstant(EffectHandle, int);
public EffectHandle GetConstant(EffectHandle, string);


ConstantTable.GetConstant(EffectHandle,String) Method (Microsoft.DirectX.Direct3D)

ConstantTable.GetConstant Method

Retrieves a constant by looking up its index or by name.

Definition

Visual Basic Public Function GetConstant( _
ByVal constant As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetConstant(
EffectHandle constant,
string name
);
C++ public:
EffectHandle^ GetConstant(
EffectHandle^ constant,
String^ name
);
JScript public function GetConstant(
constant : EffectHandle,
name : String
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that serves as a unique identifier to the parent data structure. If the constant is a top-level parameter (that is, if there is no parent data structure), use 0.
name System.String
Name of the constant.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle class that represents the constant.


ConstantTable.GetConstant(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

ConstantTable.GetConstant Method

Retrieves a constant by looking up its index or by name.

Definition

Visual Basic Public Function GetConstant( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetConstant(
EffectHandle constant,
int index
);
C++ public:
EffectHandle^ GetConstant(
EffectHandle^ constant,
int index
);
JScript public function GetConstant(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that serves as a unique identifier to the parent data structure. If the constant is a top-level parameter (that is, if there is no parent data structure), use 0.
index System.Int32
Zero-based index of the constant.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle class that represents the constant.


ConstantTable.GetConstantDescription(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

ConstantTable.GetConstantDescription Method

Retrieves an array of constant descriptions in the constant table.

Definition

Visual Basic Public Function GetConstantDescription( _
ByVal constant As EffectHandle, _
ByVal numberConstants As Integer _
) As ConstantDescription()
C# public ConstantDescription[] GetConstantDescription(
EffectHandle constant,
int numberConstants
);
C++ public:
array<ConstantDescription>^ GetConstantDescription(
EffectHandle^ constant,
int numberConstants
);
JScript public function GetConstantDescription(
constant : EffectHandle,
numberConstants : int
) : ConstantDescription[];

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle class that uniquely identifies a constant.
numberConstants System.Int32
[in, out] Input supplied must be the maximum size of the array. Output is the number of elements that are filled in the array when the function returns.

Return Value

Microsoft.DirectX.Direct3D.ConstantDescription[]
Array of descriptions. For more information, see ConstantDescription.

Remarks

Because samplers can appear more than once in a constant table, this method can return an array of descriptions, each with a different register index.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • ConstantTable.Description


ConstantTable.GetConstantElement(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

ConstantTable.GetConstantElement Method

Retrieves a constant from an array of constants.

Definition

Visual Basic Public Function GetConstantElement( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetConstantElement(
EffectHandle constant,
int index
);
C++ public:
EffectHandle^ GetConstantElement(
EffectHandle^ constant,
int index
);
JScript public function GetConstantElement(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle class that uniquely identifies the array of constants. This value cannot be 0.
index System.Int32
Zero-based index of the element in the array.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that uniquely identifies the constant.

Remarks

To get a constant that is not part of an array, use ConstantTable.GetConstant.


ConstantTable.GetHashCode() Method (Microsoft.DirectX.Direct3D)

ConstantTable.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


ConstantTable.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

ConstantTable.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXConstantTable, which allows unmanaged COM clients to create an instance of the managed ConstantTable class. Not supported.


ConstantTable.GetSamplerIndex(EffectHandle) Method (Microsoft.DirectX.Direct3D)

ConstantTable.GetSamplerIndex Method

Retrieves the sampler index.

Definition

Visual Basic Public Function GetSamplerIndex( _
ByVal constant As EffectHandle _
) As Integer
C# public int GetSamplerIndex(
EffectHandle constant
);
C++ public:
int GetSamplerIndex(
EffectHandle^ constant
);
JScript public function GetSamplerIndex(
constant : EffectHandle
) : int;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier for the sampler whose index is to be retrieved.

Return Value

System.Int32
The sampler index number from the constant table.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.op_Equality(ConstantTable,ConstantTable) Method (Microsoft.DirectX.Direct3D)

ConstantTable.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As ConstantTable, _
ByVal right As ConstantTable _
) As Boolean
C# public static bool op_Equality(
ConstantTable left,
ConstantTable right
);
C++ public:
static bool operator==(
ConstantTable^ left,
ConstantTable^ right
);
JScript public static function op_Equality(
left : ConstantTable,
right : ConstantTable
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.ConstantTable
The ConstantTable object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.ConstantTable
The ConstantTable object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


ConstantTable.op_Inequality(ConstantTable,ConstantTable) Method (Microsoft.DirectX.Direct3D)

ConstantTable.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As ConstantTable, _
ByVal right As ConstantTable _
) As Boolean
C# public static bool op_Inequality(
ConstantTable left,
ConstantTable right
);
C++ public:
static bool operator!=(
ConstantTable^ left,
ConstantTable^ right
);
JScript public static function op_Inequality(
left : ConstantTable,
right : ConstantTable
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.ConstantTable
The ConstantTable object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.ConstantTable
The ConstantTable object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


ConstantTable.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

ConstantTable.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.ConstantTable.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


ConstantTable.SetDefaults(Device) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetDefaults Method

Sets constants to their default values, which are declared in the variable declarations in the shader.

Definition

Visual Basic Public Sub SetDefaults( _
ByVal device As Device _
)
C# public void SetDefaults(
Device device
);
C++ public:
void SetDefaults(
Device^ device
);
JScript public function SetDefaults(
device : Device
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ConstantTable.SetValue Method ()

Sets the value to the constant table.

Overload List

public void SetValue(Device, EffectHandle, bool);
public void SetValue(Device, EffectHandle, bool[]);
public void SetValue(Device, EffectHandle, ColorValue);
public void SetValue(Device, EffectHandle, ColorValue[]);
public void SetValue(Device, EffectHandle, GraphicsStream);
public void SetValue(Device, EffectHandle, int);
public void SetValue(Device, EffectHandle, int[]);
public void SetValue(Device, EffectHandle, Matrix);
public void SetValue(Device, EffectHandle, Matrix[]);
public void SetValue(Device, EffectHandle, float);
public void SetValue(Device, EffectHandle, float[]);
public void SetValue(Device, EffectHandle, Vector4);
public void SetValue(Device, EffectHandle, Vector4[]);
public void SetValue(Device, EffectHandle, void, int);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Matrix[]) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValue(
Device device,
EffectHandle constant,
Matrix[] matrix
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
array<Matrix>^ matrix
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
matrix : Matrix[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
matrix Microsoft.DirectX.Matrix[]
Array of nontransposed matrices to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Matrix) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValue(
Device device,
EffectHandle constant,
Matrix matrix
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
Matrix matrix
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
matrix : Matrix
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
matrix Microsoft.DirectX.Matrix
Nontransposed Matrix to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,ColorValue[]) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal color() As ColorValue _
)
C# public void SetValue(
Device device,
EffectHandle constant,
ColorValue[] color
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
array<ColorValue>^ color
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
color : ColorValue[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
color Microsoft.DirectX.Direct3D.ColorValue[]
Array of ColorValue structures to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,ColorValue) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal color As ColorValue _
)
C# public void SetValue(
Device device,
EffectHandle constant,
ColorValue color
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
ColorValue color
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
color : ColorValue
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
color Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Vector4[]) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal vector() As Vector4 _
)
C# public void SetValue(
Device device,
EffectHandle constant,
Vector4[] vector
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
array<Vector4>^ vector
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
vector : Vector4[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
vector Microsoft.DirectX.Vector4[]
Array of Vector4 structures to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Vector4) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal vector As Vector4 _
)
C# public void SetValue(
Device device,
EffectHandle constant,
Vector4 vector
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
Vector4 vector
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
vector : Vector4
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
vector Microsoft.DirectX.Vector4
A Vector4 structure to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Single[]) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal f() As Single _
)
C# public void SetValue(
Device device,
EffectHandle constant,
float[] f
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
array<float>^ f
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
f : float[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
f System.Single[]
Array of Single Leave Site values to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Single) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal f As Single _
)
C# public void SetValue(
Device device,
EffectHandle constant,
float f
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
float f
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
f : float
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
f System.Single
A Single Leave Site value to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Int32[]) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal n() As Integer _
)
C# public void SetValue(
Device device,
EffectHandle constant,
int[] n
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
array<int>^ n
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
n : int[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
n System.Int32[]
Array of Int32 Leave Site values to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal n As Integer _
)
C# public void SetValue(
Device device,
EffectHandle constant,
int n
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
int n
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
n : int
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
n System.Int32
An Int32 Leave Site value to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Boolean[]) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal b() As Boolean _
)
C# public void SetValue(
Device device,
EffectHandle constant,
bool[] b
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
array<bool>^ b
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
b : boolean[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
b System.Boolean[]
Array of Boolean Leave Site values to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Boolean) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal b As Boolean _
)
C# public void SetValue(
Device device,
EffectHandle constant,
bool b
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
bool b
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
b : boolean
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
b System.Boolean
A Boolean Leave Site value to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal data As GraphicsStream _
)
C# public void SetValue(
Device device,
EffectHandle constant,
GraphicsStream data
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
GraphicsStream^ data
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
data : GraphicsStream
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
data Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains values to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValue(Device,EffectHandle,Void,Int32) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValue Method

Sets the value to the constant table.

Definition

Visual Basic Public Sub SetValue( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal data As Void, _
ByVal dataSize As Integer _
)
C# public void SetValue(
Device device,
EffectHandle constant,
void data,
int dataSize
);
C++ public:
void SetValue(
Device^ device,
EffectHandle^ constant,
void data,
int dataSize
);
JScript public function SetValue(
device : Device,
constant : EffectHandle,
data : void,
dataSize : int
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
data System.Void
A buffer containing the data to set.
dataSize System.Int32
Number of bytes in the data buffer.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ConstantTable.SetValueTranspose Method ()

Sets a Matrix or an array of matrices to the constant table.

Overload List

public void SetValueTranspose(Device, EffectHandle, Matrix);
public void SetValueTranspose(Device, EffectHandle, Matrix[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ConstantTable.SetValueTranspose(Device,EffectHandle,Matrix[]) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValueTranspose Method

Sets a Matrix or an array of matrices to the constant table.

Definition

Visual Basic Public Sub SetValueTranspose( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValueTranspose(
Device device,
EffectHandle constant,
Matrix[] matrix
);
C++ public:
void SetValueTranspose(
Device^ device,
EffectHandle^ constant,
array<Matrix>^ matrix
);
JScript public function SetValueTranspose(
device : Device,
constant : EffectHandle,
matrix : Matrix[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
matrix Microsoft.DirectX.Matrix[]
Array of transposed matrices to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ConstantTable.SetValueTranspose(Device,EffectHandle,Matrix) Method (Microsoft.DirectX.Direct3D)

ConstantTable.SetValueTranspose Method

Sets a Matrix or an array of matrices to the constant table.

Definition

Visual Basic Public Sub SetValueTranspose( _
ByVal device As Device, _
ByVal constant As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValueTranspose(
Device device,
EffectHandle constant,
Matrix matrix
);
C++ public:
void SetValueTranspose(
Device^ device,
EffectHandle^ constant,
Matrix matrix
);
JScript public function SetValueTranspose(
device : Device,
constant : EffectHandle,
matrix : Matrix
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the constant table.
constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents a unique identifier of a constant.
matrix Microsoft.DirectX.Matrix
Transposed matrix to set to the constant table.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ConstantTable.UpdateUnmanagedPointer(ID3DXConstantTable) Method (Microsoft.DirectX.Direct3D)

ConstantTable.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this ConstantTable object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXConstantTable _
)
C# public void UpdateUnmanagedPointer(
ID3DXConstantTable pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXConstantTable pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXConstantTable
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXConstantTable
Pointer to the ID3DXConstantTable structure used to update the unmanaged pointer for this ConstantTable object.


ConstantTable.Description Property (Microsoft.DirectX.Direct3D)

ConstantTable.Description Property

Retrieves a description of the constant table.

Definition

Visual Basic | Public ReadOnly Property Description As ConstantTableDescription
C# | public ConstantTableDescription Description { get; }
C++ public:
property ConstantTableDescription Description {
ConstantTableDescription get();
}
JScript | public function get Description() : ConstantTableDescription

Property Value

Microsoft.DirectX.Direct3D.ConstantTableDescription
A ConstantTableDescription structure.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • GetConstantDescription


ConstantTable.Disposed Property (Microsoft.DirectX.Direct3D)

ConstantTable.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


ConstantTable.StreamData Property (Microsoft.DirectX.Direct3D)

ConstantTable.StreamData Property

Retrieves a GraphicsStream object that contains the constant table.

Definition

Visual Basic | Public ReadOnly Property StreamData As GraphicsStream
C# | public GraphicsStream StreamData { get; }
C++ public:
property GraphicsStream^ StreamData {
GraphicsStream^ get();
}
JScript | public function get StreamData() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the constant table.

This property is read-only.


ConstantTable.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

ConstantTable.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXConstantTable interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXConstantTable
C# | public ID3DXConstantTable UnmanagedComPointer { get; }
C++ public:
property ID3DXConstantTable UnmanagedComPointer {
ID3DXConstantTable get();
}
JScript | public function get UnmanagedComPointer() : ID3DXConstantTable

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXConstantTable
Unmanaged ID3DXConstantTable interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


ConstantTable.Disposing Event (Microsoft.DirectX.Direct3D)

ConstantTable.Disposing Event

Occurs when the Dispose method is called or when the ConstantTable object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.ConstantTable.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the ConstantTable object indicates whether that object has been disposed.


CubeTexture Class (Microsoft.DirectX.Direct3D)

CubeTexture Class

Manipulates a cube texture resource.

Definition

Visual Basic NotInheritable Public Class CubeTexture
Inherits BaseTexture
Implements IDisposable
C# | public sealed class CubeTexture : BaseTexture, IDisposable
C++ | public ref class CubeTexture sealed : BaseTexture, IDisposable
JScript | public final class CubeTexture extends BaseTexture implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CubeTexture object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDirtyRectangle | Adds a dirty region to a cube texture resource.
CubeTexture | Initializes a new instance of the CubeTexture class.
Dispose | Immediately releases the unmanaged resources used by the CubeTexture object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CubeTexture object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GenerateMipSubLevels | Generates mipmap sublevels. Inherited from BaseTexture.
GetCubeMapSurface | Retrieves a cube texture map surface.
GetHashCode | Returns the hash code for the current instance.
GetLevelDescription | Retrieves a description of one face of a specified cube texture level.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
LockRectangle | Locks a rectangle on a cube texture resource.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseTexture.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseTexture.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.CubeTexture.Disposing event when called from within a derived class.
SetLevelOfDetail | Sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
UnlockRectangle | Unlocks a rectangle on a cube texture resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseTexture object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseTexture.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.

Properties

Property | Description
AutoGenerateFilterType | Retrieves or sets the filter type used for automatically generated sublevels. Inherited from BaseTexture.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
LevelCount | Retrieves the number of texture levels in a multilevel texture. Inherited from BaseTexture.
LevelOfDetail | Retrieves or sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface pointer.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DBaseTexture9 interface pointer. Inherited from BaseTexture.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
CubeTexture

Remarks

This class inherits additional functionality from the BaseTexture class.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CubeTexture.AddDirtyRectangle Method ()

Adds a dirty region to a cube texture resource.

Overload List

public void AddDirtyRectangle(CubeMapFace);
public void AddDirtyRectangle(CubeMapFace, Rectangle);

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CubeTexture.LockRectangle
  • CubeTexture.UnlockRectangle
  • CubeTexture.GetLevelDescription


CubeTexture.AddDirtyRectangle(CubeMapFace) Method (Microsoft.DirectX.Direct3D)

CubeTexture.AddDirtyRectangle Method

Adds a dirty region to a cube texture resource.

Definition

Visual Basic Public Sub AddDirtyRectangle( _
ByVal faceType As CubeMapFace _
)
C# public void AddDirtyRectangle(
CubeMapFace faceType
);
C++ public:
void AddDirtyRectangle(
CubeMapFace faceType
);
JScript public function AddDirtyRectangle(
faceType : CubeMapFace
);

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace
A CubeMapFace value that identifies the face where the dirty region will be added. Omitting the sig_CubeMapFace_Rectangle parameter indicates that the dirty region should expand to cover the full face.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CubeTexture.LockRectangle
  • CubeTexture.UnlockRectangle
  • CubeTexture.GetLevelDescription


CubeTexture.AddDirtyRectangle(CubeMapFace,Rectangle) Method (Microsoft.DirectX.Direct3D)

CubeTexture.AddDirtyRectangle Method

Adds a dirty region to a cube texture resource.

Definition

Visual Basic Public Sub AddDirtyRectangle( _
ByVal faceType As CubeMapFace, _
ByVal rect As Rectangle _
)
C# public void AddDirtyRectangle(
CubeMapFace faceType,
Rectangle rect
);
C++ public:
void AddDirtyRectangle(
CubeMapFace faceType,
Rectangle rect
);
JScript public function AddDirtyRectangle(
faceType : CubeMapFace,
rect : Rectangle
);

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace
A CubeMapFace value that identifies the face where the dirty region will be added. Omitting the sig_CubeMapFace_Rectangle parameter indicates that the dirty region should expand to cover the full face.
rect System.Drawing.Rectangle
A Rectangle Leave Site that specifies the dirty region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CubeTexture.LockRectangle
  • CubeTexture.UnlockRectangle
  • CubeTexture.GetLevelDescription


CubeTexture.CubeTexture Constructor ()

How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Overload List

public CubeTexture(Device, int, int, Usage, Format, Pool);
public CubeTexture(IDirect3DCubeTexture9);
public CubeTexture(IDirect3DCubeTexture9, Device, Pool);
public CubeTexture(IntPtr);

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.CubeTexture(IDirect3DCubeTexture9) Constructor (Microsoft.DirectX.Direct3D)

CubeTexture.CubeTexture Constructor

How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As IDirect3DCubeTexture9 _
)
C# public CubeTexture(
IDirect3DCubeTexture9 pInterop
);
C++ public:
CubeTexture(
IDirect3DCubeTexture9 pInterop
);
JScript public function CubeTexture(
pInterop : IDirect3DCubeTexture9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DCubeTexture9
Unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface pointer.

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.CubeTexture(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

CubeTexture.CubeTexture Constructor

How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public CubeTexture(
IntPtr unmanagedObject
);
C++ public:
CubeTexture(
IntPtr unmanagedObject
);
JScript public function CubeTexture(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.CubeTexture(IDirect3DCubeTexture9,Device,Pool) Constructor (Microsoft.DirectX.Direct3D)

CubeTexture.CubeTexture Constructor

How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DCubeTexture9, _
ByVal device As Device, _
ByVal pool As Pool _
)
C# public CubeTexture(
IDirect3DCubeTexture9 lp,
Device device,
Pool pool
);
C++ public:
CubeTexture(
IDirect3DCubeTexture9 lp,
Device^ device,
Pool pool
);
JScript public function CubeTexture(
lp : IDirect3DCubeTexture9,
device : Device,
pool : Pool
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DCubeTexture9
Unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
A Device object.
pool Microsoft.DirectX.Direct3D.Pool
A Pool value that describes the memory class into which the cube texture should be placed.

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.CubeTexture(Device,Int32,Int32,Usage,Format,Pool) Constructor (Microsoft.DirectX.Direct3D)

CubeTexture.CubeTexture Constructor

How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTexture class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal edgeLength As Integer, _
ByVal levels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool _
)
C# public CubeTexture(
Device device,
int edgeLength,
int levels,
Usage usage,
Format format,
Pool pool
);
C++ public:
CubeTexture(
Device^ device,
int edgeLength,
int levels,
Usage usage,
Format format,
Pool pool
);
JScript public function CubeTexture(
device : Device,
edgeLength : int,
levels : int,
usage : Usage,
format : Format,
pool : Pool
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object.
edgeLength System.Int32
Size of the edges of all top-level faces of the cube texture. The pixel dimensions of subsequent levels of each face are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0, 1 is taken instead.
levels System.Int32
Number of levels in each face of the cube texture. If this value is 0, Microsoft Direct3D generates all cube texture sublevels down to 1x1 pixels for each face, for hardware that supports cube textures. To see the number of levels generated, check the BaseTexture.LevelCount property.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage values. It is good practice to match the usage parameter in the CubeTexture constructor with the behavior flags in the Device constructor. See Remarks.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the format of all levels in all faces of the cube texture.
pool Microsoft.DirectX.Direct3D.Pool
A Pool value that describes the memory class into which the cube texture should be placed.

Remarks

A mipmap is a collection of successively downsampled (mipmapped) surfaces. A cube texture created by CubeTexture is a collection of six textures (each mipmapped), one for each face. All faces must be present in the cube texture. Also, a cube map surface must be the same pixel size in all three dimensions (x, y, and z).

An application can discover support for the automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, this constructor succeeds, but it creates a one-level texture.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTexture.Dispose() Method (Microsoft.DirectX.Direct3D)

CubeTexture.Dispose Method

Immediately releases the unmanaged resources used by the CubeTexture object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~CubeTexture();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.CubeTexture.Disposed
  • Microsoft.DirectX.Direct3D.CubeTexture.Disposing


CubeTexture.Equals(Object) Method (Microsoft.DirectX.Direct3D)

CubeTexture.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CubeTexture.Finalize() Method (Microsoft.DirectX.Direct3D)

CubeTexture.Finalize Method

Allows the CubeTexture object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~CubeTexture();
C++ | !CubeTexture();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


CubeTexture.GetCubeMapSurface(CubeMapFace,Int32) Method (Microsoft.DirectX.Direct3D)

CubeTexture.GetCubeMapSurface Method

Retrieves a cube texture map surface.

Definition

Visual Basic Public Function GetCubeMapSurface( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer _
) As Surface
C# public Surface GetCubeMapSurface(
CubeMapFace faceType,
int level
);
C++ public:
Surface^ GetCubeMapSurface(
CubeMapFace faceType,
int level
);
JScript public function GetCubeMapSurface(
faceType : CubeMapFace,
level : int
) : Surface;

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a mipmapped cube texture.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the returned cube texture map surface.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


CubeTexture.GetHashCode() Method (Microsoft.DirectX.Direct3D)

CubeTexture.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


CubeTexture.GetLevelDescription(Int32) Method (Microsoft.DirectX.Direct3D)

CubeTexture.GetLevelDescription Method

Retrieves a description of one face of a specified cube texture level.

Definition

Visual Basic Public Function GetLevelDescription( _
ByVal level As Integer _
) As SurfaceDescription
C# public SurfaceDescription GetLevelDescription(
int level
);
C++ public:
SurfaceDescription GetLevelDescription(
int level
);
JScript public function GetLevelDescription(
level : int
) : SurfaceDescription;

Parameters

level System.Int32
Level of a mipmapped cube texture.

Return Value

Microsoft.DirectX.Direct3D.SurfaceDescription
A SurfaceDescription structure that describes one face of the specified cube texture level.

Remarks

The SurfaceDescription structure contains Height and Width members, which indicate the size of one face of the cube. To get the size of the entire cube, multiply the data by 6.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • AddDirtyRectangle
  • LockRectangle
  • UnlockRectangle


CubeTexture.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

CubeTexture.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DCubeTexture9, which allows unmanaged COM clients to create an instance of the managed CubeTexture class. Not supported.


CubeTexture.LockRectangle Method ()

Locks a rectangle on a cube texture resource.

Overload List

public GraphicsStream LockRectangle(CubeMapFace, int, LockFlags);
public GraphicsStream LockRectangle(CubeMapFace, int, LockFlags, out int);
public GraphicsStream LockRectangle(CubeMapFace, int, Rectangle, LockFlags);
public GraphicsStream LockRectangle(CubeMapFace, int, Rectangle, LockFlags, out int);
public Array LockRectangle(Type, CubeMapFace, int, LockFlags, out int, int[]);
public Array LockRectangle(Type, CubeMapFace, int, LockFlags, int[]);
public Array LockRectangle(Type, CubeMapFace, int, Rectangle, LockFlags, out int, int[]);
public Array LockRectangle(Type, CubeMapFace, int, Rectangle, LockFlags, int[]);

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(CubeMapFace,Int32,Rectangle,LockFlags,Int32) Method (Microsoft.DirectX.Direct3D)

CubeTexture.LockRectangle Method

Locks a rectangle on a cube texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
out int pitch
);
C++ public:
GraphicsStream^ LockRectangle(
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
[Out] int% pitch
);
JScript public function LockRectangle(
faceType : CubeMapFace,
level : int,
rect : Rectangle,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a cube texture.
rect System.Drawing.Rectangle
A Rectangle Leave Site to lock. To expand the dirty region to cover the entire cube texture, omit this parameter.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags enumerated values that describe the type of lock to perform.
pitch System.Int32
Pitch of the returning data.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(CubeMapFace,Int32,LockFlags,Int32) Method (Microsoft.DirectX.Direct3D)

CubeTexture.LockRectangle Method

Locks a rectangle on a cube texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
CubeMapFace faceType,
int level,
LockFlags flags,
out int pitch
);
C++ public:
GraphicsStream^ LockRectangle(
CubeMapFace faceType,
int level,
LockFlags flags,
[Out] int% pitch
);
JScript public function LockRectangle(
faceType : CubeMapFace,
level : int,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a cube texture.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags enumerated values that describe the type of lock to perform.
pitch System.Int32
Pitch of the returning data.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(CubeMapFace,Int32,Rectangle,LockFlags) Method (Microsoft.DirectX.Direct3D)

CubeTexture.LockRectangle Method

Locks a rectangle on a cube texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags
);
C++ public:
GraphicsStream^ LockRectangle(
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags
);
JScript public function LockRectangle(
faceType : CubeMapFace,
level : int,
rect : Rectangle,
flags : LockFlags
) : GraphicsStream;

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a cube texture.
rect System.Drawing.Rectangle
A Rectangle Leave Site to lock. To expand the dirty region to cover the entire cube texture, omit this parameter.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags enumerated values that describe the type of lock to perform.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(CubeMapFace,Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

CubeTexture.LockRectangle Method

Locks a rectangle on a cube texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
CubeMapFace faceType,
int level,
LockFlags flags
);
C++ public:
GraphicsStream^ LockRectangle(
CubeMapFace faceType,
int level,
LockFlags flags
);
JScript public function LockRectangle(
faceType : CubeMapFace,
level : int,
flags : LockFlags
) : GraphicsStream;

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a cube texture.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags enumerated values that describe the type of lock to perform.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(Type,CubeMapFace,Int32,Rectangle,LockFlags,Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

CubeTexture.LockRectangle Method

Locks a rectangle on a cube texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
out int pitch,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
[Out] int% pitch,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
faceType : CubeMapFace,
level : int,
rect : Rectangle,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a cube texture.
rect System.Drawing.Rectangle
A Rectangle Leave Site to lock. To expand the dirty region to cover the entire cube texture, omit this parameter.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags enumerated values that describe the type of lock to perform.
pitch System.Int32
Pitch of the returning data.
ranks System.Int32[]
Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(Type,CubeMapFace,Int32,LockFlags,Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

CubeTexture.LockRectangle Method

Locks a rectangle on a cube texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
CubeMapFace faceType,
int level,
LockFlags flags,
out int pitch,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
CubeMapFace faceType,
int level,
LockFlags flags,
[Out] int% pitch,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
faceType : CubeMapFace,
level : int,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a cube texture.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags enumerated values that describe the type of lock to perform.
pitch System.Int32
Pitch of the returning data.
ranks System.Int32[]
Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(Type,CubeMapFace,Int32,Rectangle,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

CubeTexture.LockRectangle Method

Locks a rectangle on a cube texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
CubeMapFace faceType,
int level,
Rectangle rect,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
faceType : CubeMapFace,
level : int,
rect : Rectangle,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a cube texture.
rect System.Drawing.Rectangle
A Rectangle Leave Site to lock. To expand the dirty region to cover the entire cube texture, omit this parameter.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags enumerated values that describe the type of lock to perform.
ranks System.Int32[]
Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.LockRectangle(Type,CubeMapFace,Int32,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

CubeTexture.LockRectangle Method

Locks a rectangle on a cube texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal faceType As CubeMapFace, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
CubeMapFace faceType,
int level,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
CubeMapFace faceType,
int level,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
faceType : CubeMapFace,
level : int,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a cube texture.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags enumerated values that describe the type of lock to perform.
ranks System.Int32[]
Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked rectangle.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Cube textures created with Default are not lockable. Cube textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Dynamic.

The only lockable format for a depth stencil texture is Format.D16Lockable.

See Also

  • AddDirtyRectangle
  • GetLevelDescription
  • UnlockRectangle


CubeTexture.op_Equality(CubeTexture,CubeTexture) Method (Microsoft.DirectX.Direct3D)

CubeTexture.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As CubeTexture, _
ByVal right As CubeTexture _
) As Boolean
C# public static bool op_Equality(
CubeTexture left,
CubeTexture right
);
C++ public:
static bool operator==(
CubeTexture^ left,
CubeTexture^ right
);
JScript public static function op_Equality(
left : CubeTexture,
right : CubeTexture
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.CubeTexture
The CubeTexture object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.CubeTexture
The CubeTexture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CubeTexture.op_Inequality(CubeTexture,CubeTexture) Method (Microsoft.DirectX.Direct3D)

CubeTexture.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As CubeTexture, _
ByVal right As CubeTexture _
) As Boolean
C# public static bool op_Inequality(
CubeTexture left,
CubeTexture right
);
C++ public:
static bool operator!=(
CubeTexture^ left,
CubeTexture^ right
);
JScript public static function op_Inequality(
left : CubeTexture,
right : CubeTexture
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.CubeTexture
The CubeTexture object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.CubeTexture
The CubeTexture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


CubeTexture.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

CubeTexture.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.CubeTexture.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


CubeTexture.UnlockRectangle(CubeMapFace,Int32) Method (Microsoft.DirectX.Direct3D)

CubeTexture.UnlockRectangle Method

Unlocks a rectangle on a cube texture resource.

Definition

Visual Basic Public Sub UnlockRectangle( _
ByVal faceType As CubeMapFace, _
ByVal level As Integer _
)
C# public void UnlockRectangle(
CubeMapFace faceType,
int level
);
C++ public:
void UnlockRectangle(
CubeMapFace faceType,
int level
);
JScript public function UnlockRectangle(
faceType : CubeMapFace,
level : int
);

Parameters

faceType Microsoft.DirectX.Direct3D.CubeMapFace
Member of the CubeMapFace enumerated type that identifies a cube map face.
level System.Int32
Level of a mipmapped cube texture.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • LockRectangle
  • AddDirtyRectangle


CubeTexture.Disposed Property (Microsoft.DirectX.Direct3D)

CubeTexture.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


CubeTexture.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

CubeTexture.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DCubeTexture9 interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As IDirect3DCubeTexture9
C# | public IDirect3DCubeTexture9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DCubeTexture9 UnmanagedComPointer {
IDirect3DCubeTexture9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DCubeTexture9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DCubeTexture9
Unmanaged IDirect3DCubeTexture9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


CubeTexture.Disposing Event (Microsoft.DirectX.Direct3D)

CubeTexture.Disposing Event

Occurs when the Dispose method is called or when the CubeTexture object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.CubeTexture.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CubeTexture object indicates whether that object has been disposed.


CustomVertex Class (Microsoft.DirectX.Direct3D)

CustomVertex Class

How Do I...?
  • Create a Mesh Object
  • Generate a Scene

Defines various custom fixed-format vertex types. This class is a container of structures. See the individual structures for more information.

Definition

Visual Basic NotInheritable Public Class CustomVertex
Inherits Object
C# | public sealed class CustomVertex : Object
C++ | public ref class CustomVertex sealed : Object
JScript | public final class CustomVertex extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Structures

Structure | Description
CustomVertex.PositionColored | Describes a custom vertex format structure that contains position and color information.
CustomVertex.PositionColoredTextured | Describes a custom vertex format structure that contains position, color, and one set of texture coordinates.
CustomVertex.PositionNormal | Describes a custom vertex format structure that contains position and normal data.
CustomVertex.PositionNormalColored | Describes a custom vertex format structure that contains position, color, and normal data.
CustomVertex.PositionNormalTextured | Describes a custom vertex format structure that contains position, normal data, and one set of texture coordinates.
CustomVertex.PositionOnly | Describes a custom vertex format structure that contains only position data.
CustomVertex.PositionTextured | Describes a custom vertex format structure that contains position and one set of texture coordinates.
CustomVertex.Transformed | Describes a custom vertex format structure that contains transformed vertices.
CustomVertex.TransformedColored | Describes a custom vertex format structure that contains transformed vertices and color information.
CustomVertex.TransformedColoredTextured | Describes a custom vertex format structure that contains transformed vertices, color, and one set of texture coordinates.
CustomVertex.TransformedTextured | Describes a custom vertex format structure that contains transformed vertices and one set of texture coordinates.

Inheritance Hierarchy

Object Leave Site
CustomVertex

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DX Class (Microsoft.DirectX.Direct3D)

D3DX Class

Contains default constant values for Microsoft Direct3D extensions.

Definition

Visual Basic NotInheritable Public Class D3DX
Inherits Object
C# | public sealed class D3DX : Object
C++ | public ref class D3DX sealed : Object
JScript | public final class D3DX extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) Default | Retrieves the value of the Default constant for Direct3D extensions.
static (Shared in Visual Basic) DefaultFloat | Retrieves the value of the DefaultFloat constant for Direct3D extensions.
static (Shared in Visual Basic) DefaultNonPowerOf2 | Retrieves the value of the DefaultNonPowerOf2 constant for Direct3D extensions.
static (Shared in Visual Basic) FormatFromFile | Retrieves the value of the FormatFromFile constant for Direct3D extensions.
static (Shared in Visual Basic) FromFile | Retrieves the value of the FromFile constant for Direct3D extensions.

Methods

Method | Description
D3DX | Initializes a new instance of the D3DX class.

Inheritance Hierarchy

Object Leave Site
D3DX

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DX.D3DX() Constructor (Microsoft.DirectX.Direct3D)

D3DX.D3DX Constructor

Initializes a new instance of the D3DX class.

Definition

Visual Basic | Public Sub New()
C# | public D3DX();
C++ public:
D3DX();
JScript | public function D3DX();


D3DX.Default Field (Microsoft.DirectX.Direct3D)

D3DX.Default Field

Retrieves the value of the Default constant for Microsoft Direct3D extensions.

Definition

Visual Basic | Public Shared Default As Int32
C# | public static Int32 Default;
C++ | public: static Int32 Default;
JScript | public static var Default : Int32

Field Value

System.Int32
Returned value is -1.

This field is read-only.


D3DX.DefaultFloat Field (Microsoft.DirectX.Direct3D)

D3DX.DefaultFloat Field

Retrieves the value of the DefaultFloat constant for Microsoft Direct3D extensions.

Definition

Visual Basic | Public Shared DefaultFloat As Single
C# | public static Single DefaultFloat;
C++ | public: static Single DefaultFloat;
JScript | public static var DefaultFloat : Single

Field Value

System.Single
Returned value is 3.402823466e+38F.

This field is read-only.


D3DX.DefaultNonPowerOf2 Field (Microsoft.DirectX.Direct3D)

D3DX.DefaultNonPowerOf2 Field

Retrieves the value of the DefaultNonPowerOf2 constant for Microsoft Direct3D extensions.

Definition

Visual Basic | Public Shared DefaultNonPowerOf2 As Int32
C# | public static Int32 DefaultNonPowerOf2;
C++ | public: static Int32 DefaultNonPowerOf2;
JScript | public static var DefaultNonPowerOf2 : Int32

Field Value

System.Int32
Returned value is -2.

This field is read-only.


D3DX.FormatFromFile Field (Microsoft.DirectX.Direct3D)

D3DX.FormatFromFile Field

Retrieves the value of the FormatFromFile constant for Microsoft Direct3D extensions.

Definition

Visual Basic | Public Shared FormatFromFile As Int32
C# | public static Int32 FormatFromFile;
C++ | public: static Int32 FormatFromFile;
JScript | public static var FormatFromFile : Int32

Field Value

System.Int32
Returned value is -3.

This field is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


D3DX.FromFile Field (Microsoft.DirectX.Direct3D)

D3DX.FromFile Field

Retrieves the value of the FromFile constant for Microsoft Direct3D extensions.

Definition

Visual Basic | Public Shared FromFile As Int32
C# | public static Int32 FromFile;
C++ | public: static Int32 FromFile;
JScript | public static var FromFile : Int32

Field Value

System.Int32
Returned value is -3.

This field is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device Class (Microsoft.DirectX.Direct3D)

Device Class

How Do I...?
  • Generate a Scene

Performs primitive-based rendering, creates resources, handles system-level variables, adjusts gamma ramp levels, gets and sets palettes, and creates shaders.

Definition

Visual Basic NotInheritable Public Class Device
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class Device : MarshalByRefObject, IDisposable
C++ | public ref class Device sealed : MarshalByRefObject, IDisposable
JScript | public final class Device extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
DeviceLost | Occurs when a device is about to be lost (for example, immediately prior to a reset).
DeviceReset | Occurs after a device is reset, allowing an application to re-create all Pool.Default resources.
DeviceResizing | Occurs when a device is resizing, allowing the application to cancel the default handling of the resize.
Disposing | Occurs when the Dispose method is called or when the Device object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
BeginScene | Begins a scene.
BeginStateBlock | Signals Direct3D to begin recording a device state block.
CheckCooperativeLevel | Reports the current cooperative-level status of the Direct3D device for a windowed or full-screen application.
Clear | Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.
ColorFill | Allows an application to fill a rectangular area of a Default surface with a specified color.
CreateDepthStencilSurface | Creates a depth stencil resource.
CreateOffscreenPlainSurface | Creates an off-screen surface.
CreateRenderTarget | Creates a render target surface.
DeletePatch | Frees a cached high-order patch.
Device | Initializes a new instance of the current class.
Dispose | Immediately releases the unmanaged resources used by the Device object.
DrawIndexedPrimitives | Renders the specified geometric primitive, based on indexing into an array of vertices.
DrawIndexedUserPrimitives | Renders the specified geometric primitive with data specified by a user memory pointer.
DrawPrimitives | Renders a sequence of non-indexed geometric primitives of the specified type from the current set of data input streams.
DrawRectanglePatch | Draws a rectangular patch using the currently set streams.
DrawTrianglePatch | Draws a triangular patch using the currently set streams.
DrawUserPrimitives | Renders data specified by a user memory pointer as a sequence of geometric primitives of the specified type.
EndScene | Ends a scene that was started by calling the Device.BeginScene method.
EndStateBlock | Signals Microsoft Direct3D to stop recording a device state block and retrieve a pointer to the state block interface.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
EvictManagedResources | Evicts all managed resources, including Direct3D resources and those that are driver-managed.
Finalize | Allows the Device object to free resources before it is destroyed by the garbage collector.
GetBackBuffer | Retrieves a back buffer from a device's swap chain.
GetCubeTexture | Retrieves the cube texture assigned to a stage for a device.
GetFrontBufferData | Generates a copy of a device's front buffer and places it in a system memory buffer provided by the application.
GetGammaRamp | Retrieves the gamma correction ramp for the swap chain.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPaletteEntries | Retrieves palette entries.
GetPixelShaderBooleanConstant | Retrieves a Boolean shader constant.
GetPixelShaderInt32Constant | Retrieves an integer shader constant.
GetPixelShaderSingleConstant | Retrieves a floating-point shader constant.
GetRasterStatus | Returns information that describes the raster of the monitor on which the swap chain is presented.
GetRenderStateBoolean | Retrieves the Boolean value of a given render state.
GetRenderStateInt32 | Retrieves the integer value of a given render state.
GetRenderStateSingle | Retrieves the floating-point value of a given render state.
GetRenderTarget | Retrieves a render target surface.
GetRenderTargetData | Copies the render target data from device memory to system memory.
GetSamplerStageStateBoolean | Retrieves the Boolean value of a given sampler stage state.
GetSamplerStageStateInt32 | Retrieves the integer value of a given sampler stage state.
GetSamplerStageStateSingle | Retrieves the floating-point value of a given sampler stage state.
GetStreamSource | Retrieves a vertex buffer bound to the specified data stream.
GetStreamSourceFrequency | Retrieves the stream source frequency divider value.
GetSwapChain | Retrieves a reference to a swap chain.
GetTexture | Retrieves a texture assigned to a stage for a device.
GetTextureStageStateBoolean | Retrieves the Boolean value of a given texture stage state.
GetTextureStageStateInt32 | Retrieves the integer value of a given texture stage state.
GetTextureStageStateSingle | Retrieves the floating-point value of a given texture stage state.
GetTransform | Retrieves a matrix that describes a transformation state.
GetVertexShaderBooleanConstant | Retrieves a Boolean vertex shader constant.
GetVertexShaderInt32Constant | Retrieves an integer vertex shader constant.
GetVertexShaderSingleConstant | Retrieves a floating-point vertex shader constant.
GetVolumeTexture | Retrieves the volume texture assigned to a stage for a device.
MultiplyTransform | Multiplies a device's world, view, or projection matrices by a specified matrix.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Present | Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.
ProcessVertices | Applies the vertex processing defined by the vertex shader to the set of input data streams, generating a single stream of interleaved vertex data to the destination vertex buffer.
raise_DeviceLost | Raises a Device.DeviceLost event when called from within a derived class.
raise_DeviceReset | Raises a Device.DeviceReset event when called from within a derived class.
raise_DeviceResizing | Raises a Device.DeviceResizing event when called from within a derived class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Device.Disposing event when called from within a derived class.
Reset | Resets the presentation parameters for the current device.
SetCursor | Sets the current cursor.
SetCursorPosition | Sets the cursor position and update options.
SetCursorProperties | Sets properties for the cursor.
SetDialogBoxesEnabled | Enables the use of Microsoft Windows Graphics Device Interface (GDI) dialog boxes in full-screen applications.
SetGammaRamp | Sets the gamma correction ramp for the implicit swap chain.
SetPaletteEntries | Sets palette entries.
SetPixelShaderConstant | Sets a pixel shader constant.
SetPixelShaderConstantBoolean | Sets Boolean shader constants.
SetPixelShaderConstantInt32 | Sets integer shader constants.
SetPixelShaderConstantSingle | Sets floating-point shader constants.
SetRenderState | Sets a render state value.
SetRenderTarget | Sets a new color buffer for a device.
SetSamplerState | Sets a sampler stage state value.
SetStreamSource | Binds a vertex buffer to a device data stream.
SetStreamSourceFrequency | Sets the stream source frequency divider value.
SetTexture | Assigns a texture to a device stage.
SetTextureStageState | Sets a texture stage state value.
SetTransform | Sets a single device transform.
SetVertexShaderConstant | Sets a vertex shader constant.
SetVertexShaderConstantBoolean | Sets Boolean vertex shader constants.
SetVertexShaderConstantInt32 | Sets integer vertex shader constants.
SetVertexShaderConstantSingle | Sets floating-point vertex shader constants.
ShowCursor | Displays or hides the cursor.
StretchRectangle | Copies the contents of the source rectangle to the destination rectangle.
TestCooperativeLevel | Reports the current cooperative-level status of the Direct3D device for a windowed or full-screen application.
UpdateSurface | Copies rectangular subsets of pixels from one surface to another.
UpdateTexture | Updates the dirty portions of a texture.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Device object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
ValidateDevice | Reports the device's ability to render the current texture-blending operations and arguments in a single pass.

Properties

Property | Description
AvailableTextureMemory | Retrieves an estimate of the amount of available texture memory.
ClipPlanes | Retrieves the clipping planes on the current device.
ClipStatus | Retrieves or sets a ClipStatus object.
CreationParameters | Retrieves the creation parameters of the device.
CurrentTexturePalette | Retrieves or sets the current texture palette.
DepthStencilSurface | Retrieves or sets the depth stencil surface owned by the Device object.
DeviceCaps | Retrieves the capabilities of the rendering device.
DisplayMode | Retrieves the display mode's spatial resolution, color resolution, and refresh frequency.
Disposed | Gets a value that indicates whether the object is disposed.
Indices | Retrieves or sets index data.
static (Shared in Visual Basic) IsUsingEventHandlers | Retrieves or sets a value that indicates whether the device should use event handlers.
Lights | Retrieves the LightsCollection collection on the current device.
Material | Retrieves or sets the current material properties for the device.
NPatchMode | Retrieves or sets the N-patch mode segments.
NumberOfSwapChains | Retrieves the number of implicit swap chains.
PixelShader | Retrieves or sets the current pixel shader.
PresentationParameters | Retrieves presentation parameters for a device.
RasterStatus | Retrieves information that describes the raster of the monitor on which the swap chain is presented.
RenderState | Retrieves a render-state value for a device.
SamplerState | Retrieves a device's sampler states.
ScissorRectangle | Retrieves or sets the scissor rectangle.
SoftwareVertexProcessing | Retrieves or sets the vertex processing mode.
TextureState | Retrieves a state value for an assigned texture.
Transform | Retrieves a matrix that describes a transformation state.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DDevice9 interface pointer.
VertexDeclaration | Retrieves or sets a vertex shader declaration.
VertexFormat | Retrieves or sets the supported flexible vertex formats.
VertexShader | Retrieves or sets the current vertex shader.
Viewport | Retrieves or sets the viewport parameters for the current device.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Device

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Device.BeginScene() Method (Microsoft.DirectX.Direct3D)

Device.BeginScene Method

How Do I...?
  • Generate a Scene

Begins a scene.

Definition

Visual Basic | Public Sub BeginScene()
C# | public void BeginScene();
C++ public:
void BeginScene();
JScript | public function BeginScene();

Remarks

Every call to BeginScene should eventually be followed by a call to EndScene before the display is updated with Device.Present.

If the method fails, the device was unable to begin the scene, and there is no need to call EndScene. In fact, calls to EndScene fail if the previous call to BeginScene fails.

Exceptions
InvalidCallException The method call is invalid. This occurs when BeginScene is called while already in a BeginScene ... EndScene pair. Never call BeginScene twice without first calling EndScene.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();


Device.BeginStateBlock() Method (Microsoft.DirectX.Direct3D)

Device.BeginStateBlock Method

Signals Microsoft Direct3D to begin recording a device state block.

Definition

Visual Basic | Public Sub BeginStateBlock()
C# | public void BeginStateBlock();
C++ public:
void BeginStateBlock();
JScript | public function BeginStateBlock();

Remarks

To ensure that all recorded states are valid, an application can call the Device.ValidateDevice method prior to calling this method.

The following properties and methods can be recorded in a state block, after calling Device.BeginStateBlock and before calling Device.EndStateBlock.

  • ClipPlane.SetSingleArray
  • ClipPlane.Plane
  • Device.CurrentTexturePalette
  • Device.VertexFormat
  • Device.Indices
  • Device.Material
  • Device.NPatchMode
  • Device.PixelShader
  • Device.SetPixelShaderConstant
  • Device.RenderState
  • Device.SamplerState
  • Device.ScissorRectangle
  • Device.SetStreamSource
  • Device.SetStreamSourceFrequency
  • Device.SetTexture
  • Device.TextureState
  • Device.VertexDeclaration
  • Device.VertexShader
  • Device.SetVertexShaderConstant
  • All of the Light properties that are committed.
  • All of the parameters and methods in ClipPlane (except GetSingleArray).
  • All of the ClipPlanes methods.
  • All of the SamplerStateManager properties.
  • All of the TextureStateManager properties.
  • All of the Transforms properties.
  • All of the RenderStateManager properties.

The ordering of state changes in a state block is not guaranteed. If the same state is specified multiple times in a state block, only the last value is used.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • StateBlock


Device.CheckCooperativeLevel Method ()

Reports the current cooperative-level status of the Microsoft Direct3D device for a windowed or full-screen application.

Overload List

public bool CheckCooperativeLevel();
public bool CheckCooperativeLevel(out int);

Remarks

If the device is lost but cannot be restored at the current time, Device.CheckCooperativeLevel returns the DeviceLost result code in the param_Int32R_result parameter. This is the case, for example, when a full-screen device loses focus. If an application detects a lost device, it should pause and periodically call Device.CheckCooperativeLevel until it receives a return value of DeviceNotReset. The application can then attempt to reset the device by calling Device.Reset and, if this succeeds, restore the necessary resources and resume normal operation. Note that Device.Present throws a DeviceLostException if the device is lost or not reset.

A call to CheckCooperativeLevel fails if made on a different thread than the one used to create the device being reset.

See Also

  • DeviceNotResetException
  • Lost Devices


Device.CheckCooperativeLevel() Method (Microsoft.DirectX.Direct3D)

Device.CheckCooperativeLevel Method

Reports the current cooperative-level status of the Microsoft Direct3D device for a windowed or full-screen application.

Definition

Visual Basic | Public Function CheckCooperativeLevel() As Boolean
C# | public bool CheckCooperativeLevel();
C++ public:
bool CheckCooperativeLevel();
JScript | public function CheckCooperativeLevel() : boolean;

Return Value

System.Boolean
Current cooperative-level status of the device for a windowed or full-screen application. A return value of true indicates that the device is operational and that the calling application can continue; a value of false indicates that the device is lost or needs to be reset.

Remarks

If the device is lost but cannot be restored at the current time, Device.CheckCooperativeLevel returns the DeviceLost result code in the param_Int32R_result parameter. This is the case, for example, when a full-screen device loses focus. If an application detects a lost device, it should pause and periodically call Device.CheckCooperativeLevel until it receives a return value of DeviceNotReset. The application can then attempt to reset the device by calling Device.Reset and, if this succeeds, restore the necessary resources and resume normal operation. Note that Device.Present throws a DeviceLostException if the device is lost or not reset.

A call to CheckCooperativeLevel fails if made on a different thread than the one used to create the device being reset.

See Also

  • DeviceNotResetException
  • Lost Devices


Device.CheckCooperativeLevel(Int32) Method (Microsoft.DirectX.Direct3D)

Device.CheckCooperativeLevel Method

Reports the current cooperative-level status of the Microsoft Direct3D device for a windowed or full-screen application.

Definition

Visual Basic Public Function CheckCooperativeLevel( _
ByRef result As Integer _
) As Boolean
C# public bool CheckCooperativeLevel(
out int result
);
C++ public:
bool CheckCooperativeLevel(
[Out] int% result
);
JScript public function CheckCooperativeLevel(
result : int
) : boolean;

Parameters

result System.Int32
[in, out] Current cooperative-level status of the device for a windowed or full-screen application, reported using a ResultCode value. A Success result indicates that the device is operational and that the calling application can continue. A DeviceLost result indicates that the device is lost but cannot be reset at this time; therefore, rendering is not possible. A DeviceNotReset result indicates that the device is lost but can be reset at this time.

Return Value

System.Boolean
Current cooperative-level status of the device for a windowed or full-screen application. A return value of true indicates that the device is operational and that the calling application can continue; a value of false indicates that the device is lost or needs to be reset.

Remarks

If the device is lost but cannot be restored at the current time, Device.CheckCooperativeLevel returns the DeviceLost result code in the param_Int32R_result parameter. This is the case, for example, when a full-screen device loses focus. If an application detects a lost device, it should pause and periodically call Device.CheckCooperativeLevel until it receives a return value of DeviceNotReset. The application can then attempt to reset the device by calling Device.Reset and, if this succeeds, restore the necessary resources and resume normal operation. Note that Device.Present throws a DeviceLostException if the device is lost or not reset.

A call to CheckCooperativeLevel fails if made on a different thread than the one used to create the device being reset.

See Also

  • DeviceNotResetException
  • Lost Devices


Device.Clear Method ()

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Overload List

public void Clear(ClearFlags, Color, float, int);
public void Clear(ClearFlags, Color, float, int, Rectangle[]);
public void Clear(ClearFlags, int, float, int);
public void Clear(ClearFlags, int, float, int, Rectangle[]);

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Clear(ClearFlags,Color,Single,Int32) Method (Microsoft.DirectX.Direct3D)

Device.Clear Method

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Definition

Visual Basic Public Sub Clear( _
ByVal flags As ClearFlags, _
ByVal color As Color, _
ByVal zdepth As Single, _
ByVal stencil As Integer _
)
C# public void Clear(
ClearFlags flags,
Color color,
float zdepth,
int stencil
);
C++ public:
void Clear(
ClearFlags flags,
Color color,
float zdepth,
int stencil
);
JScript public function Clear(
flags : ClearFlags,
color : Color,
zdepth : float,
stencil : int
);

Parameters

flags Microsoft.DirectX.Direct3D.ClearFlags
Flags that indicate which surfaces to clear. This parameter can be any combination of the following flags, but at least one flag must be used.

ClearFlags.Stencil: Clears the stencil buffer to the value in the stencil parameter.

ClearFlags.Target: Clears the render target to the color in the color parameter.

ClearFlags.ZBuffer: Clears the depth buffer to the value in the Z parameter.
color System.Drawing.Color
A Color Leave Site object that represents the color to which the render target surface is cleared.
zdepth System.Single
New z value that this method stores in the depth buffer. This parameter can be in the range of 0.0 through 1.0 (for z-based or w-based depth buffers). A value of 0.0 represents the nearest distance to the viewer; a value of 1.0 represents the farthest distance.
stencil System.Int32
Integer value to store in each stencil-buffer entry. This parameter can be in the range of 0 through 2n-1, where n is the bit depth of the stencil buffer.

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Clear(ClearFlags,Color,Single,Int32,Rectangle[]) Method (Microsoft.DirectX.Direct3D)

Device.Clear Method

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Definition

Visual Basic Public Sub Clear( _
ByVal flags As ClearFlags, _
ByVal color As Color, _
ByVal zdepth As Single, _
ByVal stencil As Integer, _
ByVal rect() As Rectangle _
)
C# public void Clear(
ClearFlags flags,
Color color,
float zdepth,
int stencil,
Rectangle[] rect
);
C++ public:
void Clear(
ClearFlags flags,
Color color,
float zdepth,
int stencil,
array<Rectangle>^ rect
);
JScript public function Clear(
flags : ClearFlags,
color : Color,
zdepth : float,
stencil : int,
rect : Rectangle[]
);

Parameters

flags Microsoft.DirectX.Direct3D.ClearFlags
Flags that indicate which surfaces to clear. This parameter can be any combination of the following flags, but at least one flag must be used.

ClearFlags.Stencil: Clears the stencil buffer to the value in the stencil parameter.

ClearFlags.Target: Clears the render target to the color in the color parameter.

ClearFlags.ZBuffer: Clears the depth buffer to the value in the Z parameter.
color System.Drawing.Color
A Color Leave Site object that represents the color to which the render target surface is cleared.
zdepth System.Single
New z value that this method stores in the depth buffer. This parameter can be in the range of 0.0 through 1.0 (for z-based or w-based depth buffers). A value of 0.0 represents the nearest distance to the viewer; a value of 1.0 represents the farthest distance.
stencil System.Int32
Integer value to store in each stencil-buffer entry. This parameter can be in the range of 0 through 2n-1, where n is the bit depth of the stencil buffer.
rect System.Drawing.Rectangle[]
Array of Rectangle Leave Site structures that describe the rectangles to clear. To clear the entire surface, set a rectangle to the dimensions of the rendering target. Each rectangle uses screen coordinates that correspond to points on the render target surface. Coordinates are clipped to the bounds of the viewport rectangle.

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Clear(ClearFlags,Int32,Single,Int32) Method (Microsoft.DirectX.Direct3D)

Device.Clear Method

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Definition

Visual Basic Public Sub Clear( _
ByVal flags As ClearFlags, _
ByVal color As Integer, _
ByVal zdepth As Single, _
ByVal stencil As Integer _
)
C# public void Clear(
ClearFlags flags,
int color,
float zdepth,
int stencil
);
C++ public:
void Clear(
ClearFlags flags,
int color,
float zdepth,
int stencil
);
JScript public function Clear(
flags : ClearFlags,
color : int,
zdepth : float,
stencil : int
);

Parameters

flags Microsoft.DirectX.Direct3D.ClearFlags
Flags that indicate which surfaces to clear. This parameter can be any combination of the following flags, but at least one flag must be used.

ClearFlags.Stencil: Clears the stencil buffer to the value in the stencil parameter.

ClearFlags.Target: Clears the render target to the color in the color parameter.

ClearFlags.ZBuffer: Clears the depth buffer to the value in the Z parameter.
color System.Int32
A 32-bit ARGB color value to which the render target surface is cleared.
zdepth System.Single
New z value that this method stores in the depth buffer. This parameter can be in the range of 0.0 through 1.0 (for z-based or w-based depth buffers). A value of 0.0 represents the nearest distance to the viewer; a value of 1.0 represents the farthest distance.
stencil System.Int32
Integer value to store in each stencil-buffer entry. This parameter can be in the range of 0 through 2n-1, where n is the bit depth of the stencil buffer.

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Clear(ClearFlags,Int32,Single,Int32,Rectangle[]) Method (Microsoft.DirectX.Direct3D)

Device.Clear Method

Clears the viewport or a set of rectangles in the viewport to a specified RGBA color, clears the depth buffer, and erases the stencil buffer.

Definition

Visual Basic Public Sub Clear( _
ByVal flags As ClearFlags, _
ByVal color As Integer, _
ByVal zdepth As Single, _
ByVal stencil As Integer, _
ByVal regions() As Rectangle _
)
C# public void Clear(
ClearFlags flags,
int color,
float zdepth,
int stencil,
Rectangle[] regions
);
C++ public:
void Clear(
ClearFlags flags,
int color,
float zdepth,
int stencil,
array<Rectangle>^ regions
);
JScript public function Clear(
flags : ClearFlags,
color : int,
zdepth : float,
stencil : int,
regions : Rectangle[]
);

Parameters

flags Microsoft.DirectX.Direct3D.ClearFlags
Flags that indicate which surfaces to clear. This parameter can be any combination of the following flags, but at least one flag must be used.

ClearFlags.Stencil: Clears the stencil buffer to the value in the stencil parameter.

ClearFlags.Target: Clears the render target to the color in the color parameter.

ClearFlags.ZBuffer: Clears the depth buffer to the value in the Z parameter.
color System.Int32
A 32-bit ARGB color value to which the render target surface is cleared.
zdepth System.Single
New z value that this method stores in the depth buffer. This parameter can be in the range of 0.0 through 1.0 (for z-based or w-based depth buffers). A value of 0.0 represents the nearest distance to the viewer; a value of 1.0 represents the farthest distance.
stencil System.Int32
Integer value to store in each stencil-buffer entry. This parameter can be in the range of 0 through 2n-1, where n is the bit depth of the stencil buffer.
regions System.Drawing.Rectangle[]
Array of Rectangle Leave Site structures that describe the rectangles to clear. To clear the entire surface, set a rectangle to the dimensions of the rendering target. Each rectangle uses screen coordinates that correspond to points on the render target surface. Coordinates are clipped to the bounds of the viewport rectangle.

Remarks

This method fails if the ZBuffer or Stencil flags are specified when the render target does not have an attached depth buffer. Similarly, the method fails if the Stencil flag is specified when the depth-buffer format does not contain stencil buffer information.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.ColorFill Method ()

Allows an application to fill a rectangular area of a Default surface with a specified color.

Overload List

public void ColorFill(Surface, Rectangle, Color);
public void ColorFill(Surface, Rectangle, int);

Remarks

This method can be applied only to a render target, a render-target texture surface, or an off-screen plain surface with a pool type of Default.

Device.ColorFill works with all formats. However, when using a reference or a software device, the only formats supported are X1R5G5B5, A1R5G5B5, R5G6B5, X8R8G8B8, A8R8G8B8, YUY2, G8R8G8B8, UYVY, R8G8B8G8, R16F, G16R16F, A16B16G16R16F, R32F, G32R32F, and A32B32G32R32F.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Pool


Device.ColorFill(Surface,Rectangle,Color) Method (Microsoft.DirectX.Direct3D)

Device.ColorFill Method

Allows an application to fill a rectangular area of a Default surface with a specified color.

Definition

Visual Basic Public Sub ColorFill( _
ByVal surface As Surface, _
ByVal rect As Rectangle, _
ByVal color As Color _
)
C# public void ColorFill(
Surface surface,
Rectangle rect,
Color color
);
C++ public:
void ColorFill(
Surface^ surface,
Rectangle rect,
Color color
);
JScript public function ColorFill(
surface : Surface,
rect : Rectangle,
color : Color
);

Parameters

surface Microsoft.DirectX.Direct3D.Surface
Surface to be filled.
rect System.Drawing.Rectangle
Source rectangle. To fill the entire surface, specify null.
color System.Drawing.Color
Color used for filling.

Remarks

This method can be applied only to a render target, a render-target texture surface, or an off-screen plain surface with a pool type of Default.

Device.ColorFill works with all formats. However, when using a reference or a software device, the only formats supported are X1R5G5B5, A1R5G5B5, R5G6B5, X8R8G8B8, A8R8G8B8, YUY2, G8R8G8B8, UYVY, R8G8B8G8, R16F, G16R16F, A16B16G16R16F, R32F, G32R32F, and A32B32G32R32F.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Pool


Device.ColorFill(Surface,Rectangle,Int32) Method (Microsoft.DirectX.Direct3D)

Device.ColorFill Method

Allows an application to fill a rectangular area of a Default surface with a specified color.

Definition

Visual Basic Public Sub ColorFill( _
ByVal surface As Surface, _
ByVal rect As Rectangle, _
ByVal color As Integer _
)
C# public void ColorFill(
Surface surface,
Rectangle rect,
int color
);
C++ public:
void ColorFill(
Surface^ surface,
Rectangle rect,
int color
);
JScript public function ColorFill(
surface : Surface,
rect : Rectangle,
color : int
);

Parameters

surface Microsoft.DirectX.Direct3D.Surface
Surface to be filled.
rect System.Drawing.Rectangle
Source rectangle. To fill the entire surface, specify null.
color System.Int32
Color used for filling.

Remarks

This method can be applied only to a render target, a render-target texture surface, or an off-screen plain surface with a pool type of Default.

Device.ColorFill works with all formats. However, when using a reference or a software device, the only formats supported are X1R5G5B5, A1R5G5B5, R5G6B5, X8R8G8B8, A8R8G8B8, YUY2, G8R8G8B8, UYVY, R8G8B8G8, R16F, G16R16F, A16B16G16R16F, R32F, G32R32F, and A32B32G32R32F.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Pool


Device.CreateDepthStencilSurface(Int32,Int32,DepthFormat,MultiSampleType,Int32,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.CreateDepthStencilSurface Method

Creates a depth stencil resource.

Definition

Visual Basic Public Function CreateDepthStencilSurface( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal format As DepthFormat, _
ByVal multiSample As MultiSampleType, _
ByVal multiSampleQuality As Integer, _
ByVal discard As Boolean _
) As Surface
C# public Surface CreateDepthStencilSurface(
int width,
int height,
DepthFormat format,
MultiSampleType multiSample,
int multiSampleQuality,
bool discard
);
C++ public:
Surface^ CreateDepthStencilSurface(
int width,
int height,
DepthFormat format,
MultiSampleType multiSample,
int multiSampleQuality,
bool discard
);
JScript public function CreateDepthStencilSurface(
width : int,
height : int,
format : DepthFormat,
multiSample : MultiSampleType,
multiSampleQuality : int,
discard : boolean
) : Surface;

Parameters

width System.Int32
Width of the depth stencil surface in pixels.
height System.Int32
Height of the depth stencil surface in pixels.
format Microsoft.DirectX.Direct3D.DepthFormat
Member of the DepthFormat enumerated type that describes the format of the depth stencil surface. This value must be one of the enumerated depth stencil formats for the current device.
multiSample Microsoft.DirectX.Direct3D.MultiSampleType
Member of the MultiSampleType enumerated type that describes the multisampling buffer type. This value must be one of the supported multisample types. When this surface is passed to the Device.DepthStencilSurface property, its multisample type must be the same as that of the render target set by Device.SetRenderTarget.
multiSampleQuality System.Int32
Quality level. The valid range is between 0 and one less than the level returned by the param_MultiSampleType_multiSampleType parameter of the Manager.CheckDeviceMultiSampleType method. Passing a larger value results in a GraphicsException with an InvalidCall value. The param_Int32_multiSampleQuality values of paired render targets, depth stencil surfaces, and the param_MultiSampleType_multiSample type must all match.
discard System.Boolean
Set to true to enable z-buffer discarding; otherwise false.

If this flag is set, the contents of the depth stencil buffer are invalid after Device.Present is called or when Device.DepthStencilSurface is set with a different depth surface.

This flag's behavior is the same as passing the enumerated value PresentFlag.DiscardDepthStencil to the Device.Present method.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface that represents the created depth stencil surface resource.

Remarks

The memory class of the depth stencil buffer is always Default.

Exceptions
NotAvailableException | The current device does not support the queried multisample type.
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


Device.CreateOffscreenPlainSurface(Int32,Int32,Format,Pool) Method (Microsoft.DirectX.Direct3D)

Device.CreateOffscreenPlainSurface Method

How Do I...?
  • Copy a Texture

Creates an off-screen surface.

Definition

Visual Basic Public Function CreateOffscreenPlainSurface( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal format As Format, _
ByVal pool As Pool _
) As Surface
C# public Surface CreateOffscreenPlainSurface(
int width,
int height,
Format format,
Pool pool
);
C++ public:
Surface^ CreateOffscreenPlainSurface(
int width,
int height,
Format format,
Pool pool
);
JScript public function CreateOffscreenPlainSurface(
width : int,
height : int,
format : Format,
pool : Pool
) : Surface;

Parameters

width System.Int32
Width of the surface in pixels.
height System.Int32
Height of the surface in pixels.
format Microsoft.DirectX.Direct3D.Format
Format of the surface. For more information, see Format.
pool Microsoft.DirectX.Direct3D.Pool
Surface pool type. For more information, see Pool.

Return Value

Microsoft.DirectX.Direct3D.Surface
The Surface object that is created.

Remarks

The Default pool is appropriate for use with Device.StretchRectangle and Device.ColorFill.

The Managed pool is not allowed when creating an off-screen plain surface. For more information about memory pools, see Pool.

Off-screen plain surfaces are always lockable, regardless of their pool type.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


Device.CreateRenderTarget(Int32,Int32,Format,MultiSampleType,Int32,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.CreateRenderTarget Method

Creates a render target surface.

Definition

Visual Basic Public Function CreateRenderTarget( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal format As Format, _
ByVal multiSample As MultiSampleType, _
ByVal multiSampleQuality As Integer, _
ByVal lockable As Boolean _
) As Surface
C# public Surface CreateRenderTarget(
int width,
int height,
Format format,
MultiSampleType multiSample,
int multiSampleQuality,
bool lockable
);
C++ public:
Surface^ CreateRenderTarget(
int width,
int height,
Format format,
MultiSampleType multiSample,
int multiSampleQuality,
bool lockable
);
JScript public function CreateRenderTarget(
width : int,
height : int,
format : Format,
multiSample : MultiSampleType,
multiSampleQuality : int,
lockable : boolean
) : Surface;

Parameters

width System.Int32
Width of the render-target surface in pixels.
height System.Int32
Height of the render-target surface in pixels.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the format of the render target.
multiSample Microsoft.DirectX.Direct3D.MultiSampleType
Member of the MultiSampleType enumerated type that describes the multisampling buffer type. This parameter specifies the antialiasing type for the render target. When this surface is passed to Device.SetRenderTarget, its multisample type must be the same as that of the depth stencil property Device.DepthStencilSurface.
multiSampleQuality System.Int32
Quality level. The valid range is between 0 and one less than the level returned by the param_Int32R_qualityLevels parameter of the Manager.CheckDeviceMultiSampleType. Passing a larger value causes an InvalidCallException. The param_Int32_multiSampleQuality values of paired render targets, depth stencil surfaces, and the multisample type must all match.
lockable System.Boolean
Set to true if render targets are lockable; otherwise, false. Note that lockable render targets reduce performance on some graphics hardware.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface.

Remarks

Render-target surfaces are placed in the Pool memory class.

The creation of lockable, multisampled render targets is not supported.

Exceptions
NotAvailableException | The device does not support the queried multisample type.
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


Device.DeletePatch(Int32) Method (Microsoft.DirectX.Direct3D)

Device.DeletePatch Method

Frees a cached high-order patch.

Definition

Visual Basic Public Sub DeletePatch( _
ByVal handle As Integer _
)
C# public void DeletePatch(
int handle
);
C++ public:
void DeletePatch(
int handle
);
JScript public function DeletePatch(
handle : int
);

Parameters

handle System.Int32
Handle of the cached high-order patch to delete.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Device.Device Constructor ()

How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Overload List

public Device(IDirect3DDevice9);
public Device(int, DeviceType, Control, CreateFlags, PresentParameters[]);
public Device(int, DeviceType, IntPtr, CreateFlags, PresentParameters[]);
public Device(IntPtr);

Remarks

Exceptions
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter may have an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Device(IDirect3DDevice9) Constructor (Microsoft.DirectX.Direct3D)

Device.Device Constructor

How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DDevice9 _
)
C# public Device(
IDirect3DDevice9 pUnk
);
C++ public:
Device(
IDirect3DDevice9 pUnk
);
JScript public function Device(
pUnk : IDirect3DDevice9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DDevice9
Unmanaged Component Object Model (COM) IDirect3DDevice9 interface pointer.

Remarks

Exceptions
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter may have an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Device(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Device.Device Constructor

How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Device(
IntPtr unmanagedObject
);
C++ public:
Device(
IntPtr unmanagedObject
);
JScript public function Device(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DDevice9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter may have an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Device(Int32,DeviceType,IntPtr,CreateFlags,PresentParameters[]) Constructor (Microsoft.DirectX.Direct3D)

Device.Device Constructor

How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Definition

Visual Basic Public Sub New( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal renderWindowHandle As IntPtr, _
ByVal behaviorFlags As CreateFlags, _
ByVal presentationParameters() As PresentParameters _
)
C# public Device(
int adapter,
DeviceType deviceType,
IntPtr renderWindowHandle,
CreateFlags behaviorFlags,
PresentParameters[] presentationParameters
);
C++ public:
Device(
int adapter,
DeviceType deviceType,
IntPtr renderWindowHandle,
CreateFlags behaviorFlags,
array<PresentParameters^>^ presentationParameters
);
JScript public function Device(
adapter : int,
deviceType : DeviceType,
renderWindowHandle : IntPtr,
behaviorFlags : CreateFlags,
presentationParameters : PresentParameters[]
);

Parameters

adapter System.Int32
Ordinal number that identifies which physical device the object represents. Device 0 is the default device. The highest value that can be used in this parameter is one less than the total number of physical devices.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumerated type that denotes the desired device type. If the desired device type is not available, the method fails.
renderWindowHandle System.IntPtr
Handle to a Form Leave Site, Panel Leave Site, or any other Control Leave Site derived class. This parameter indicates the surface to bind to the device.

For full-screen mode, the window specified must be a top-level window.

For windowed mode, this parameter can be null. If null is specified, a non-null handle must be specified when calling Device.Present. This can be done either by setting the PresentParameters.DeviceWindow property, or by using the optional param_Control_overrideWindow parameter of the Device.Present method.
behaviorFlags Microsoft.DirectX.Direct3D.CreateFlags
Combination of one or more options that control device creation.
presentationParameters Microsoft.DirectX.Direct3D.PresentParameters[]
[in, out] Pointer to a PresentParameters object that describes the presentation parameters for the device to create. For Microsoft Windows 2000 and Windows XP, the full-screen device display refresh rate is set in the following order.
  1. User-specified nonzero ForcedRefreshRate registry key, if supported by the device.
  2. Application-specified nonzero refresh rate value in the presentation parameter.
  3. Refresh rate of the latest desktop mode, if supported by the device.
  4. 75 hertz if supported by the device.
  5. 60 hertz if supported by the device.
  6. Device default.
By default, if a refresh rate is unsupported, the closest supported refresh rate below it is used. For example, if the application specifies 63 hertz, 60 hertz is used. No refresh rates below 57 hertz are supported.

Calling this method changes the value of several members of PresentParameters.
  • BackBufferCount, BackBufferWidth, and BackBufferHeight = 0 for windowed or full-screen mode.
  • BackBufferFormat = Unknown for windowed mode only. Full-screen mode must specify a format.
If AdapterGroupDevice is set, param_PresentParametersA_presentationParameters is an array. Regardless of the number of heads that exist, only one depth stencil surface is automatically created.

Remarks

Exceptions
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter may have an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Device(Int32,DeviceType,Control,CreateFlags,PresentParameters[]) Constructor (Microsoft.DirectX.Direct3D)

Device.Device Constructor

How Do I...?
  • Maintain Floating Point Precision after Device Creation

Initializes a new instance of the current class.

Definition

Visual Basic Public Sub New( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal renderWindow As Control, _
ByVal behaviorFlags As CreateFlags, _
ByVal presentationParameters() As PresentParameters _
)
C# public Device(
int adapter,
DeviceType deviceType,
Control renderWindow,
CreateFlags behaviorFlags,
PresentParameters[] presentationParameters
);
C++ public:
Device(
int adapter,
DeviceType deviceType,
Control^ renderWindow,
CreateFlags behaviorFlags,
array<PresentParameters^>^ presentationParameters
);
JScript public function Device(
adapter : int,
deviceType : DeviceType,
renderWindow : Control,
behaviorFlags : CreateFlags,
presentationParameters : PresentParameters[]
);

Parameters

adapter System.Int32
Ordinal number that identifies which physical device the object represents. Device 0 is the default device. The highest value that can be used in this parameter is one less than the total number of physical devices.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumerated type that denotes the desired device type. If the desired device type is not available, the method fails.
renderWindow System.Windows.Forms.Control
Pointer to an unmanaged (or non-Windows form) window handle.
behaviorFlags Microsoft.DirectX.Direct3D.CreateFlags
Combination of one or more options that control device creation.
presentationParameters Microsoft.DirectX.Direct3D.PresentParameters[]
[in, out] Pointer to a PresentParameters object that describes the presentation parameters for the device to create. For Microsoft Windows 2000 and Windows XP, the full-screen device display refresh rate is set in the following order.
  1. User-specified nonzero ForcedRefreshRate registry key, if supported by the device.
  2. Application-specified nonzero refresh rate value in the presentation parameter.
  3. Refresh rate of the latest desktop mode, if supported by the device.
  4. 75 hertz if supported by the device.
  5. 60 hertz if supported by the device.
  6. Device default.
By default, if a refresh rate is unsupported, the closest supported refresh rate below it is used. For example, if the application specifies 63 hertz, 60 hertz is used. No refresh rates below 57 hertz are supported.

Calling this method changes the value of several members of PresentParameters.
  • BackBufferCount, BackBufferWidth, and BackBufferHeight = 0 for windowed or full-screen mode.
  • BackBufferFormat = Unknown for windowed mode only. Full-screen mode must specify a format.
If AdapterGroupDevice is set, param_PresentParametersA_presentationParameters is an array. Regardless of the number of heads that exist, only one depth stencil surface is automatically created.

Remarks

Exceptions
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter may have an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.

This constructor creates a fully functional device object that is set to the required display mode (or windowed mode) and allocated with the appropriate back buffers. To begin rendering, the application needs only to create and set a depth buffer (assuming EnableAutoDepthStencil is false in PresentParameters).

Note that the HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing vertex flags are mutually exclusive, and that at least one must be specified when calling this method.

Back buffers created as part of the device are lockable only if LockableBackBuffer is specified in PresentParameters. Multisampled back buffers and depth surfaces are never lockable.

The Device.Reset and Device.TestCooperativeLevel methods must be called from the same thread that used this method to create a device.

The Format.Unknown type can be specified for the windowed mode back-buffer format when calling Device, Device.Reset, and SwapChain.SwapChain(Device, PresentParameters) (the constructor override for creating a new swap chain). This means the application does not have to query the current desktop format before calling Device for windowed mode. For full-screen mode, the back-buffer format must be specified.

The Device method fails if an attempt is made to create a device on a 0x0-sized window.

How Do I...?

Maintain Floating Point Precision after Device Creation

When a Device object is created, the common language runtime will change the floating-point unit (FPU) to single precision to maintain better performance. To maintain the default double precision FPU, which is default for the common language runtime, use the CreateFlags.FpuPreserve flag when creating a Device object as in the sample code below.

[C#]
Device device = null;              // Create rendering device
    PresentParameters presentParams = new PresentParameters();

    device = new Device(0, DeviceType.Hardware, this,
            CreateFlags.SoftwareVertexProcessing |
            CreateFlags.FpuPreserve, presentParams);

See Also

  • CreateFlags


Device.Dispose() Method (Microsoft.DirectX.Direct3D)

Device.Dispose Method

Immediately releases the unmanaged resources used by the Device object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Device();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Device.Disposed
  • Microsoft.DirectX.Direct3D.Device.Disposing


Device.DrawIndexedPrimitives(PrimitiveType,Int32,Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.DrawIndexedPrimitives Method

Renders the specified geometric primitive, based on indexing into an array of vertices.

Definition

Visual Basic Public Sub DrawIndexedPrimitives( _
ByVal primitiveType As PrimitiveType, _
ByVal baseVertex As Integer, _
ByVal minVertexIndex As Integer, _
ByVal numVertices As Integer, _
ByVal startIndex As Integer, _
ByVal primCount As Integer _
)
C# public void DrawIndexedPrimitives(
PrimitiveType primitiveType,
int baseVertex,
int minVertexIndex,
int numVertices,
int startIndex,
int primCount
);
C++ public:
void DrawIndexedPrimitives(
PrimitiveType primitiveType,
int baseVertex,
int minVertexIndex,
int numVertices,
int startIndex,
int primCount
);
JScript public function DrawIndexedPrimitives(
primitiveType : PrimitiveType,
baseVertex : int,
minVertexIndex : int,
numVertices : int,
startIndex : int,
primCount : int
);

Parameters

primitiveType Microsoft.DirectX.Direct3D.PrimitiveType
Member of the PrimitiveType enumerated type that describes the type of primitive to render. The PointList constant is not supported with this method. See Remarks.
baseVertex System.Int32
Offset from the start of the index buffer to the first vertex index.
minVertexIndex System.Int32
Minimum vertex index for vertices used during the call.
numVertices System.Int32
Number of vertices used during the call, starting from param_Int32_baseVertex + param_Int32_minVertexIndex.
startIndex System.Int32
Location in the index array at which to start reading vertices.
primCount System.Int32
Number of primitives to render. The number of vertices used is a function of the param_Int32_primCount and param_PrimitiveType_primitiveType. To determine the maximum number of primitives allowed, check the MaxPrimitiveCount member of the Caps structure.

Remarks

This method draws indexed primitives from the current set of data input streams.

The param_Int32_minVertexIndex parameter and all of the indices in the index stream are relative to the param_Int32_baseVertex.

The param_Int32_minVertexIndex and param_Int32_numVertices parameters specify the range of vertex indices used for each Device.DrawIndexedPrimitives call. These vertex indices are used to optimize vertex processing of indexed primitives by processing a sequential range of vertices prior to indexing into them. Indices used during this call cannot reference any vertices outside of this range.

If no index array is set, Device.DrawIndexedPrimitives fails.

The PointList member of the PrimitiveType enumerated type is not supported and is not a valid type for this method.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Device.DrawPrimitives
  • Device.SetStreamSource


Device.DrawIndexedUserPrimitives(PrimitiveType,Int32,Int32,Int32,Object,Boolean,Object) Method (Microsoft.DirectX.Direct3D)

Device.DrawIndexedUserPrimitives Method

Renders the specified geometric primitive with data specified by a user memory pointer.

Definition

Visual Basic Public Sub DrawIndexedUserPrimitives( _
ByVal primitiveType As PrimitiveType, _
ByVal minVertexIndex As Integer, _
ByVal numVertexIndices As Integer, _
ByVal primitiveCount As Integer, _
ByVal indexData As Object, _
ByVal sixteenBitIndices As Boolean, _
ByVal vertexStreamZeroData As Object _
)
C# public void DrawIndexedUserPrimitives(
PrimitiveType primitiveType,
int minVertexIndex,
int numVertexIndices,
int primitiveCount,
object indexData,
bool sixteenBitIndices,
object vertexStreamZeroData
);
C++ public:
void DrawIndexedUserPrimitives(
PrimitiveType primitiveType,
int minVertexIndex,
int numVertexIndices,
int primitiveCount,
Object^ indexData,
bool sixteenBitIndices,
Object^ vertexStreamZeroData
);
JScript public function DrawIndexedUserPrimitives(
primitiveType : PrimitiveType,
minVertexIndex : int,
numVertexIndices : int,
primitiveCount : int,
indexData : Object,
sixteenBitIndices : boolean,
vertexStreamZeroData : Object
);

Parameters

primitiveType Microsoft.DirectX.Direct3D.PrimitiveType
Member of the PrimitiveType enumerated type that describes the type of primitive to render.
minVertexIndex System.Int32
Minimum vertex index, relative to 0 (the start of param_Object_vertexStreamZeroData), for vertices used during the call.
numVertexIndices System.Int32
Number of vertices used during the call, starting from param_Int32_minVertexIndex.
primitiveCount System.Int32
Number of primitives to render. The number of indices used is a function of the primitive count and primitive type. To determine the maximum number of primitives allowed, check the MaxPrimitiveCount member of the Caps structure.
indexData System.Object
User memory pointer to the index data.
sixteenBitIndices System.Boolean
Set to true to indicate 16-bit indices. Set to false if to indicate 32-bit indices.
vertexStreamZeroData System.Object
User memory pointer to the vertex data to use for vertex stream 0.

Remarks

This method is intended for use in applications that are unable to store their vertex data in vertex buffers.

It supports only a single vertex stream, which must be declared as stream 0.

Following any Device.DrawIndexedUserPrimitives call, the stream 0 settings referenced by Device.GetStreamSource are set to null. The index buffer setting for Indices also is set to null.

The vertex data passed to DrawIndexedUserPrimitives does not need to persist after the call. Microsoft Direct3D completes its access to that data prior to returning from the call.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Device.DrawIndexedPrimitives
  • Device.DrawPrimitives
  • Device.SetStreamSource


Device.DrawPrimitives(PrimitiveType,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.DrawPrimitives Method

How Do I...?
  • Generate a Scene

Renders a sequence of non-indexed geometric primitives of the specified type from the current set of data input streams.

Definition

Visual Basic Public Sub DrawPrimitives( _
ByVal primitiveType As PrimitiveType, _
ByVal startVertex As Integer, _
ByVal primitiveCount As Integer _
)
C# public void DrawPrimitives(
PrimitiveType primitiveType,
int startVertex,
int primitiveCount
);
C++ public:
void DrawPrimitives(
PrimitiveType primitiveType,
int startVertex,
int primitiveCount
);
JScript public function DrawPrimitives(
primitiveType : PrimitiveType,
startVertex : int,
primitiveCount : int
);

Parameters

primitiveType Microsoft.DirectX.Direct3D.PrimitiveType
Member of the PrimitiveType enumerated type that describes the type of primitive to render.
startVertex System.Int32
Index of the first vertex to load. Beginning at param_Int32_startVertex, the correct number of vertices is read out of the vertex buffer.
primitiveCount System.Int32
Number of primitives to render. To determine the maximum number of primitives allowed, check Caps.MaxPrimitiveCount. The param_Int32_primitiveCount is the number of primitives as determined by the primitive type. If it is a line list, each primitive has two vertices. If it is a triangle list, each primitive has three vertices.

Remarks

Device.DrawPrimitives should not be called with a single triangle at a time.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

See Also

  • Device.DrawIndexedPrimitives
  • Device.SetStreamSource


Device.DrawRectanglePatch Method ()

Draws a rectangular patch using the currently set streams.

Overload List

public void DrawRectanglePatch(int, Plane);
public void DrawRectanglePatch(int, Plane, RectanglePatchInformation);
public void DrawRectanglePatch(int, Plane, RectanglePatchInformation);
public void DrawRectanglePatch(int, float[]);
public void DrawRectanglePatch(int, float[], RectanglePatchInformation);
public void DrawRectanglePatch(int, float[], RectanglePatchInformation);

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Plane,RectanglePatchInformation) Method (Microsoft.DirectX.Direct3D)

Device.DrawRectanglePatch Method

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane, _
ByVal rectPatchInformation As RectanglePatchInformation _
)
C# public void DrawRectanglePatch(
int handle,
Plane numSegs,
RectanglePatchInformation rectPatchInformation
);
C++ public:
void DrawRectanglePatch(
int handle,
Plane numSegs,
RectanglePatchInformation rectPatchInformation
);
JScript public function DrawRectanglePatch(
handle : int,
numSegs : Plane,
rectPatchInformation : RectanglePatchInformation
);

Parameters

handle System.Int32
Handle to the rectangular patch to draw.
numSegs Microsoft.DirectX.Plane
A Plane structure. The A, B, C and D fields identify the number of segments each edge of the rectangle patch should be divided into when tessellated.
rectPatchInformation Microsoft.DirectX.Direct3D.RectanglePatchInformation

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Single[],RectanglePatchInformation) Method (Microsoft.DirectX.Direct3D)

Device.DrawRectanglePatch Method

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single, _
ByVal rectPatchInformation As RectanglePatchInformation _
)
C# public void DrawRectanglePatch(
int handle,
float[] numSegs,
RectanglePatchInformation rectPatchInformation
);
C++ public:
void DrawRectanglePatch(
int handle,
array<float>^ numSegs,
RectanglePatchInformation rectPatchInformation
);
JScript public function DrawRectanglePatch(
handle : int,
numSegs : float[],
rectPatchInformation : RectanglePatchInformation
);

Parameters

handle System.Int32
Handle to the rectangular patch to draw.
numSegs System.Single[]
Array of four floating-point values that identify the number of segments into which each edge of the rectangle patch should be divided when tessellated. For more information, see RectanglePatchInformation.
rectPatchInformation Microsoft.DirectX.Direct3D.RectanglePatchInformation

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Plane,RectanglePatchInformation) Method (Microsoft.DirectX.Direct3D)

Device.DrawRectanglePatch Method

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane, _
ByVal rectPatchInformation As RectanglePatchInformation _
)
C# public void DrawRectanglePatch(
int handle,
Plane numSegs,
RectanglePatchInformation rectPatchInformation
);
C++ public:
void DrawRectanglePatch(
int handle,
Plane numSegs,
RectanglePatchInformation rectPatchInformation
);
JScript public function DrawRectanglePatch(
handle : int,
numSegs : Plane,
rectPatchInformation : RectanglePatchInformation
);

Parameters

handle System.Int32
Handle to the rectangular patch to draw.
numSegs Microsoft.DirectX.Plane
A Plane structure. The A, B, C and D fields identify the number of segments each edge of the rectangle patch should be divided into when tessellated.
rectPatchInformation Microsoft.DirectX.Direct3D.RectanglePatchInformation
A pointer to a RectanglePatchInformation structure that describes the rectangular patch to draw. Use this if your code block is marked unsafe.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Single[],RectanglePatchInformation) Method (Microsoft.DirectX.Direct3D)

Device.DrawRectanglePatch Method

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single, _
ByVal rectPatchInformation As RectanglePatchInformation _
)
C# public void DrawRectanglePatch(
int handle,
float[] numSegs,
RectanglePatchInformation rectPatchInformation
);
C++ public:
void DrawRectanglePatch(
int handle,
array<float>^ numSegs,
RectanglePatchInformation rectPatchInformation
);
JScript public function DrawRectanglePatch(
handle : int,
numSegs : float[],
rectPatchInformation : RectanglePatchInformation
);

Parameters

handle System.Int32
Handle to the rectangular patch to draw.
numSegs System.Single[]
Array of four floating-point values that identify the number of segments into which each edge of the rectangle patch should be divided when tessellated. For more information, see RectanglePatchInformation.
rectPatchInformation Microsoft.DirectX.Direct3D.RectanglePatchInformation
A pointer to a RectanglePatchInformation structure that describes the rectangular patch to draw. Use this if your code block is marked unsafe.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Plane) Method (Microsoft.DirectX.Direct3D)

Device.DrawRectanglePatch Method

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane _
)
C# public void DrawRectanglePatch(
int handle,
Plane numSegs
);
C++ public:
void DrawRectanglePatch(
int handle,
Plane numSegs
);
JScript public function DrawRectanglePatch(
handle : int,
numSegs : Plane
);

Parameters

handle System.Int32
Handle to the rectangular patch to draw.
numSegs Microsoft.DirectX.Plane
A Plane structure. The A, B, C and D fields identify the number of segments each edge of the rectangle patch should be divided into when tessellated.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawRectanglePatch(Int32,Single[]) Method (Microsoft.DirectX.Direct3D)

Device.DrawRectanglePatch Method

Draws a rectangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawRectanglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single _
)
C# public void DrawRectanglePatch(
int handle,
float[] numSegs
);
C++ public:
void DrawRectanglePatch(
int handle,
array<float>^ numSegs
);
JScript public function DrawRectanglePatch(
handle : int,
numSegs : float[]
);

Parameters

handle System.Int32
Handle to the rectangular patch to draw.
numSegs System.Single[]
Array of four floating-point values that identify the number of segments into which each edge of the rectangle patch should be divided when tessellated. For more information, see RectanglePatchInformation.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_RectanglePatchInformationR_rectPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawRectanglePatch subsequently without the param_RectanglePatchInformationR_rectPatchInformation parameter. When drawing a cached patch, the currently set streams are ignored. Override the cached param_SingleA_numSegs by specifying a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawRectanglePatch with a handle invalidates the same handle cached by a previous Device.DrawTrianglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_RectanglePatchInformationR_rectPatchInformation to null.

Exceptions
ArgumentException Leave Site | The numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.DeletePatch

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch Method ()

Draws a triangular patch using the currently set streams.

Overload List

public void DrawTrianglePatch(int, Plane);
public void DrawTrianglePatch(int, Plane, TrianglePatchInformation);
public void DrawTrianglePatch(int, Plane, TrianglePatchInformation);
public void DrawTrianglePatch(int, float[]);
public void DrawTrianglePatch(int, float[], TrianglePatchInformation);
public void DrawTrianglePatch(int, float[], TrianglePatchInformation);

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Plane,TrianglePatchInformation) Method (Microsoft.DirectX.Direct3D)

Device.DrawTrianglePatch Method

Draws a triangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane, _
ByVal triPatchInformation As TrianglePatchInformation _
)
C# public void DrawTrianglePatch(
int handle,
Plane numSegs,
TrianglePatchInformation triPatchInformation
);
C++ public:
void DrawTrianglePatch(
int handle,
Plane numSegs,
TrianglePatchInformation triPatchInformation
);
JScript public function DrawTrianglePatch(
handle : int,
numSegs : Plane,
triPatchInformation : TrianglePatchInformation
);

Parameters

handle System.Int32
Handle to the triangular patch to draw.
numSegs Microsoft.DirectX.Plane
A Plane structure. The A, B, C, and D fields identify the number of segments into which each edge of the triangle patch should be divided when tessellated.
triPatchInformation Microsoft.DirectX.Direct3D.TrianglePatchInformation
A TrianglePatchInformation structure that describes the triangular high-order patch to draw.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Single[],TrianglePatchInformation) Method (Microsoft.DirectX.Direct3D)

Device.DrawTrianglePatch Method

Draws a triangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single, _
ByVal triPatchInformation As TrianglePatchInformation _
)
C# public void DrawTrianglePatch(
int handle,
float[] numSegs,
TrianglePatchInformation triPatchInformation
);
C++ public:
void DrawTrianglePatch(
int handle,
array<float>^ numSegs,
TrianglePatchInformation triPatchInformation
);
JScript public function DrawTrianglePatch(
handle : int,
numSegs : float[],
triPatchInformation : TrianglePatchInformation
);

Parameters

handle System.Int32
Handle to the triangular patch to draw.
numSegs System.Single[]
Pointer to an array of three floating-point values that identify the number of segments each edge of the triangle patch should be divided into when tessellated. For more information, see TrianglePatchInformation.
triPatchInformation Microsoft.DirectX.Direct3D.TrianglePatchInformation
A TrianglePatchInformation structure that describes the triangular high-order patch to draw.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Plane,TrianglePatchInformation) Method (Microsoft.DirectX.Direct3D)

Device.DrawTrianglePatch Method

Draws a triangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane, _
ByVal triPatchInformation As TrianglePatchInformation _
)
C# public void DrawTrianglePatch(
int handle,
Plane numSegs,
TrianglePatchInformation triPatchInformation
);
C++ public:
void DrawTrianglePatch(
int handle,
Plane numSegs,
TrianglePatchInformation triPatchInformation
);
JScript public function DrawTrianglePatch(
handle : int,
numSegs : Plane,
triPatchInformation : TrianglePatchInformation
);

Parameters

handle System.Int32
Handle to the triangular patch to draw.
numSegs Microsoft.DirectX.Plane
A Plane structure. The A, B, C, and D fields identify the number of segments into which each edge of the triangle patch should be divided when tessellated.
triPatchInformation Microsoft.DirectX.Direct3D.TrianglePatchInformation
A pointer to a TrianglePatchInformation structure that describes the triangular high-order patch to draw. Use this if your code block is marked unsafe.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Single[],TrianglePatchInformation) Method (Microsoft.DirectX.Direct3D)

Device.DrawTrianglePatch Method

Draws a triangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single, _
ByVal triPatchInformation As TrianglePatchInformation _
)
C# public void DrawTrianglePatch(
int handle,
float[] numSegs,
TrianglePatchInformation triPatchInformation
);
C++ public:
void DrawTrianglePatch(
int handle,
array<float>^ numSegs,
TrianglePatchInformation triPatchInformation
);
JScript public function DrawTrianglePatch(
handle : int,
numSegs : float[],
triPatchInformation : TrianglePatchInformation
);

Parameters

handle System.Int32
Handle to the triangular patch to draw.
numSegs System.Single[]
Pointer to an array of three floating-point values that identify the number of segments each edge of the triangle patch should be divided into when tessellated. For more information, see TrianglePatchInformation.
triPatchInformation Microsoft.DirectX.Direct3D.TrianglePatchInformation
A pointer to a TrianglePatchInformation structure that describes the triangular high-order patch to draw. Use this if your code block is marked unsafe.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Plane) Method (Microsoft.DirectX.Direct3D)

Device.DrawTrianglePatch Method

Draws a triangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs As Plane _
)
C# public void DrawTrianglePatch(
int handle,
Plane numSegs
);
C++ public:
void DrawTrianglePatch(
int handle,
Plane numSegs
);
JScript public function DrawTrianglePatch(
handle : int,
numSegs : Plane
);

Parameters

handle System.Int32
Handle to the triangular patch to draw.
numSegs Microsoft.DirectX.Plane
A Plane structure. The A, B, C, and D fields identify the number of segments into which each edge of the triangle patch should be divided when tessellated.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawTrianglePatch(Int32,Single[]) Method (Microsoft.DirectX.Direct3D)

Device.DrawTrianglePatch Method

Draws a triangular patch using the currently set streams.

Definition

Visual Basic Public Sub DrawTrianglePatch( _
ByVal handle As Integer, _
ByVal numSegs() As Single _
)
C# public void DrawTrianglePatch(
int handle,
float[] numSegs
);
C++ public:
void DrawTrianglePatch(
int handle,
array<float>^ numSegs
);
JScript public function DrawTrianglePatch(
handle : int,
numSegs : float[]
);

Parameters

handle System.Int32
Handle to the triangular patch to draw.
numSegs System.Single[]
Pointer to an array of three floating-point values that identify the number of segments each edge of the triangle patch should be divided into when tessellated. For more information, see TrianglePatchInformation.

Remarks

For static patches, set the vertex shader and the appropriate streams, supply patch information in the param_TrianglePatchInformationR_triPatchInformation parameter, and specify a handle so that Microsoft Direct3D can capture and cache information. To efficiently draw the patch, call Device.DrawTrianglePatch with param_TrianglePatchInformationR_triPatchInformation set to null. When drawing a cached patch, the currently set streams are ignored. To override the cached param_SingleA_numSegs, specify a new value for param_SingleA_numSegs. When rendering a cached patch, set the same vertex shader that was set when it was captured.

Calling Device.DrawTrianglePatch with a handle invalidates the same handle cached by a previous Device.DrawRectanglePatch call.

For dynamic patches, the patch data changes for every rendering of the patch, so it is not efficient to cache information. The application can convey this to Direct3D by setting param_Int32_handle to 0. In this case, Direct3D draws the patch using the currently set streams and the param_SingleA_numSegs values, and does not cache any information. It is not valid to simultaneously set param_Int32_handle to 0 and param_TrianglePatchInformationR_triPatchInformation to null.

Exceptions
ArgumentException Leave Site | The param_SingleA_numSegs parameter must be an array of four segments.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.DrawUserPrimitives(PrimitiveType,Int32,Object) Method (Microsoft.DirectX.Direct3D)

Device.DrawUserPrimitives Method

Renders data specified by a user memory pointer as a sequence of geometric primitives of the specified type.

Definition

Visual Basic Public Sub DrawUserPrimitives( _
ByVal primitiveType As PrimitiveType, _
ByVal primitiveCount As Integer, _
ByVal vertexStreamZeroData As Object _
)
C# public void DrawUserPrimitives(
PrimitiveType primitiveType,
int primitiveCount,
object vertexStreamZeroData
);
C++ public:
void DrawUserPrimitives(
PrimitiveType primitiveType,
int primitiveCount,
Object^ vertexStreamZeroData
);
JScript public function DrawUserPrimitives(
primitiveType : PrimitiveType,
primitiveCount : int,
vertexStreamZeroData : Object
);

Parameters

primitiveType Microsoft.DirectX.Direct3D.PrimitiveType
Member of the PrimitiveType enumerated type that describes the type of primitive to render.
primitiveCount System.Int32
Number of primitives to render. To determine the maximum number of primitives allowed, check the Caps.MaxPrimitiveCount member.
vertexStreamZeroData System.Object
User memory vertex data to use for vertex stream 0.

Remarks

This method is intended for use in applications that are unable to store their vertex data in vertex buffers. It supports only a single vertex stream, and uses the provided vertex data pointer and stride for vertex stream 0. It is invalid for the declaration of the current vertex shader to refer to vertex streams other than stream 0.

Following any Device.DrawUserPrimitives call, the stream 0 settings referenced by Device.GetStreamSource are set to null.

The vertex data passed to Device.DrawUserPrimitives does not need to persist after the call. Microsoft Direct3D completes its access to that data prior to returning from the call.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.EndScene() Method (Microsoft.DirectX.Direct3D)

Device.EndScene Method

Ends a scene that was started by calling the Device.BeginScene method.

Definition

Visual Basic | Public Sub EndScene()
C# | public void EndScene();
C++ public:
void EndScene();
JScript | public function EndScene();

Remarks

Every call to BeginScene should eventually be followed by a call to EndScene before the display is updated with Device.Present.

When EndScene succeeds, the scene is queued up for rendering by the driver. The method is not synchronous, so the scene is not guaranteed to have completed rendering when the method returns.

When scene rendering begins successfully, this method must be called before calling the Device.BeginScene method to start rendering another scene. If a prior call to Device.BeginScene fails, the scene did not begin and this method should not be called.

Exceptions
InvalidCallException The method failed because EndScene was called before BeginScene.


Device.EndStateBlock() Method (Microsoft.DirectX.Direct3D)

Device.EndStateBlock Method

Signals Microsoft Direct3D to stop recording a device state block and retrieve a pointer to the state block interface.

Definition

Visual Basic | Public Function EndStateBlock() As StateBlock
C# | public StateBlock EndStateBlock();
C++ public:
StateBlock^ EndStateBlock();
JScript | public function EndStateBlock() : StateBlock;

Return Value

Microsoft.DirectX.Direct3D.StateBlock
State block object. For more information, see StateBlock.

Remarks

Exceptions
InvalidCallException The method call is invalid. This can occur if EndStateBlock is called without a corresponding BeginStateBlock.


Device.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Device.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Device.EvictManagedResources() Method (Microsoft.DirectX.Direct3D)

Device.EvictManagedResources Method

Evicts all managed resources, including Microsoft Direct3D resources and those that are driver-managed.

Definition

Visual Basic | Public Sub EvictManagedResources()
C# | public void EvictManagedResources();
C++ public:
void EvictManagedResources();
JScript | public function EvictManagedResources();

Remarks

This method causes only the Default copy of resources to be evicted. The resource copy in system memory is retained. For more information, see Pool.

Exceptions
OutOfVideoMemoryException Direct3D does not have enough display memory to perform the operation.


Device.Finalize() Method (Microsoft.DirectX.Direct3D)

Device.Finalize Method

Allows the Device object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Device();
C++ | !Device();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Device.GetBackBuffer(Int32,Int32,BackBufferType) Method (Microsoft.DirectX.Direct3D)

Device.GetBackBuffer Method

How Do I...?
  • Save a Screenshot

Retrieves a back buffer from a device's swap chain.

Definition

Visual Basic Public Function GetBackBuffer( _
ByVal swapChain As Integer, _
ByVal backBuffer As Integer, _
ByVal backBufferType As BackBufferType _
) As Surface
C# public Surface GetBackBuffer(
int swapChain,
int backBuffer,
BackBufferType backBufferType
);
C++ public:
Surface^ GetBackBuffer(
int swapChain,
int backBuffer,
BackBufferType backBufferType
);
JScript public function GetBackBuffer(
swapChain : int,
backBuffer : int,
backBufferType : BackBufferType
) : Surface;

Parameters

swapChain System.Int32
Unsigned integer that specifies the swap chain.
backBuffer System.Int32
Index of the back buffer object to return.
backBufferType Microsoft.DirectX.Direct3D.BackBufferType
Stereo view is not supported in Microsoft DirectX 9.0, so the only valid value for this parameter is Mono.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface that represents the returned back buffer surface.

Remarks

Back buffers are numbered from 0 to the total number of back buffers - 1. A value of 0 returns the first back buffer, not the front buffer. The front buffer is not accessible through this method.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


Device.GetCubeTexture(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetCubeTexture Method

Retrieves the cube texture assigned to a stage for a device.

Definition

Visual Basic Public Function GetCubeTexture( _
ByVal stage As Integer _
) As CubeTexture
C# public CubeTexture GetCubeTexture(
int stage
);
C++ public:
CubeTexture^ GetCubeTexture(
int stage
);
JScript public function GetCubeTexture(
stage : int
) : CubeTexture;

Parameters

stage System.Int32
Stage identifier of the CubeTexture to retrieve. Stage identifiers are zero-based.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the returned CubeTexture.

Remarks

Exceptions
InvalidOperationException Leave Site The texture returned was not of type CubeTexture.


Device.GetFrontBufferData(Int32,Surface) Method (Microsoft.DirectX.Direct3D)

Device.GetFrontBufferData Method

Generates a copy of a device's front buffer and places it in a system memory buffer provided by the application.

Definition

Visual Basic Public Sub GetFrontBufferData( _
ByVal swapChain As Integer, _
ByVal buffer As Surface _
)
C# public void GetFrontBufferData(
int swapChain,
Surface buffer
);
C++ public:
void GetFrontBufferData(
int swapChain,
Surface^ buffer
);
JScript public function GetFrontBufferData(
swapChain : int,
buffer : Surface
);

Parameters

swapChain System.Int32
Unsigned integer that specifies the swap chain.
buffer Microsoft.DirectX.Direct3D.Surface
[in, out] A Surface class that receives a copy of the front buffer's contents. The data is returned in successive rows with no intervening space, proceeding from the highest vertical row on the device's output to the lowest.

For windowed mode, the size of the destination surface should be the desktop size. For full-screen mode, the size of the destination surface should be the screen size.

Remarks

The param_Surface_buffer parameter is filled with a representation of the front buffer, converted to the standard 32-bits-per-pixel format A8R8G8B8.

This method is the only way to capture an antialiased screen shot.

The method is slow by design, and therefore should not be used in a performance-critical path.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.


Device.GetGammaRamp(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetGammaRamp Method

Retrieves the gamma correction ramp for the swap chain.

Definition

Visual Basic Public Function GetGammaRamp( _
ByVal swapChain As Integer _
) As GammaRamp
C# public GammaRamp GetGammaRamp(
int swapChain
);
C++ public:
GammaRamp GetGammaRamp(
int swapChain
);
JScript public function GetGammaRamp(
swapChain : int
) : GammaRamp;

Parameters

swapChain System.Int32
Unsigned integer that specifies the swap chain.

Return Value

Microsoft.DirectX.Direct3D.GammaRamp
[in, out] Application-supplied GammaRamp structure to fill with the gamma correction ramp.

See Also

  • SwapChain
  • Device.SetGammaRamp


Device.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Device.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Device.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DDevice9, which allows unmanaged COM clients to create an instance of the managed Device class. Not supported.


Device.GetPaletteEntries(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetPaletteEntries Method

Retrieves palette entries.

Definition

Visual Basic Public Function GetPaletteEntries( _
ByVal paletteNumber As Integer _
) As PaletteEntry()
C# public PaletteEntry[] GetPaletteEntries(
int paletteNumber
);
C++ public:
array<PaletteEntry>^ GetPaletteEntries(
int paletteNumber
);
JScript public function GetPaletteEntries(
paletteNumber : int
) : PaletteEntry[];

Parameters

paletteNumber System.Int32
Ordinal value that identifies the palette to retrieve.

Return Value

Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry structure that represents the returned palette entries.

Remarks

For more information about PaletteEntry, see the Microsoft Platform Software Development Kit (SDK).

In Microsoft DirectX 9.0 and later, the Flags member of the PaletteEntry structure does not work as documented in the Platform SDK. The Flags member is now the alpha channel for 8-bit palletized formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.CurrentTexturePalette
  • Device.SetPaletteEntries


Device.GetPixelShaderBooleanConstant(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetPixelShaderBooleanConstant Method

Retrieves a Boolean shader constant.

Definition

Visual Basic Public Function GetPixelShaderBooleanConstant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Boolean()
C# public bool[] GetPixelShaderBooleanConstant(
int startRegister,
int constantCount
);
C++ public:
array<bool>^ GetPixelShaderBooleanConstant(
int startRegister,
int constantCount
);
JScript public function GetPixelShaderBooleanConstant(
startRegister : int,
constantCount : int
) : boolean[];

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantCount System.Int32
Number of Boolean values in the array of constants.

Return Value

System.Boolean[]
Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetPixelShaderConstant


Device.GetPixelShaderInt32Constant(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetPixelShaderInt32Constant Method

Retrieves an integer shader constant.

Definition

Visual Basic Public Function GetPixelShaderInt32Constant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Integer()
C# public int[] GetPixelShaderInt32Constant(
int startRegister,
int constantCount
);
C++ public:
array<int>^ GetPixelShaderInt32Constant(
int startRegister,
int constantCount
);
JScript public function GetPixelShaderInt32Constant(
startRegister : int,
constantCount : int
) : int[];

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantCount System.Int32
Number of four-integer vectors in the array of constants.

Return Value

System.Int32[]
Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetPixelShaderConstant


Device.GetPixelShaderSingleConstant(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetPixelShaderSingleConstant Method

Retrieves a floating-point shader constant.

Definition

Visual Basic Public Function GetPixelShaderSingleConstant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Single()
C# public float[] GetPixelShaderSingleConstant(
int startRegister,
int constantCount
);
C++ public:
array<float>^ GetPixelShaderSingleConstant(
int startRegister,
int constantCount
);
JScript public function GetPixelShaderSingleConstant(
startRegister : int,
constantCount : int
) : float[];

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantCount System.Int32
Number of four-float vectors in the array of constants.

Return Value

System.Single[]
Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetPixelShaderConstant


Device.GetRasterStatus(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetRasterStatus Method

Returns information that describes the raster of the monitor on which the swap chain is presented.

Definition

Visual Basic Public Function GetRasterStatus( _
ByVal swapChain As Integer _
) As RasterStatus
C# public RasterStatus GetRasterStatus(
int swapChain
);
C++ public:
RasterStatus GetRasterStatus(
int swapChain
);
JScript public function GetRasterStatus(
swapChain : int
) : RasterStatus;

Parameters

swapChain System.Int32
Unsigned integer that specifies the swap chain.

Return Value

Microsoft.DirectX.Direct3D.RasterStatus
A RasterStatus structure that contains information about the position or other status of the raster on the monitor driven by this adapter.

Remarks

This method does not return device state for a device created using PureDevice. To use this method, create a device with any of the other values in CreateFlags.

Exceptions
InvalidCallException The device does not support reading the current scan line. To determine whether a device supports reading the scan line, check for the DriverCaps.ReadScanLine property in Caps.DriverCaps.


Device.GetRenderStateBoolean(RenderStates) Method (Microsoft.DirectX.Direct3D)

Device.GetRenderStateBoolean Method

Retrieves the Boolean value of a given render state.

Definition

Visual Basic Public Function GetRenderStateBoolean( _
ByVal state As RenderStates _
) As Boolean
C# public bool GetRenderStateBoolean(
RenderStates state
);
C++ public:
bool GetRenderStateBoolean(
RenderStates state
);
JScript public function GetRenderStateBoolean(
state : RenderStates
) : boolean;

Parameters

state Microsoft.DirectX.Direct3D.RenderStates
A member from the RenderStates enumeration that represents the render state value to retreive.

Return Value

System.Boolean
The render state value retrieved.

Remarks

Use this method to retrieve render states with Boolean values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetRenderStateInt32(RenderStates) Method (Microsoft.DirectX.Direct3D)

Device.GetRenderStateInt32 Method

Retrieves the integer value of a given render state.

Definition

Visual Basic Public Function GetRenderStateInt32( _
ByVal state As RenderStates _
) As Integer
C# public int GetRenderStateInt32(
RenderStates state
);
C++ public:
int GetRenderStateInt32(
RenderStates state
);
JScript public function GetRenderStateInt32(
state : RenderStates
) : int;

Parameters

state Microsoft.DirectX.Direct3D.RenderStates
A member from the RenderStates enumeration that represents the render state value to retreive.

Return Value

System.Int32
The render state value retrieved.

Remarks

Use this method to retrieve render states with integer values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetRenderStateSingle(RenderStates) Method (Microsoft.DirectX.Direct3D)

Device.GetRenderStateSingle Method

Retrieves the floating-point value of a given render state.

Definition

Visual Basic Public Function GetRenderStateSingle( _
ByVal state As RenderStates _
) As Single
C# public float GetRenderStateSingle(
RenderStates state
);
C++ public:
float GetRenderStateSingle(
RenderStates state
);
JScript public function GetRenderStateSingle(
state : RenderStates
) : float;

Parameters

state Microsoft.DirectX.Direct3D.RenderStates
A member from the RenderStates enumeration that represents the render state value to retreive.

Return Value

System.Single
The render state value retrieved.

Remarks

Use this method to retrieve render states with floating-point values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetRenderTarget(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetRenderTarget Method

Retrieves a render target surface.

Definition

Visual Basic Public Function GetRenderTarget( _
ByVal renderTargetIndex As Integer _
) As Surface
C# public Surface GetRenderTarget(
int renderTargetIndex
);
C++ public:
Surface^ GetRenderTarget(
int renderTargetIndex
);
JScript public function GetRenderTarget(
renderTargetIndex : int
) : Surface;

Parameters

renderTargetIndex System.Int32
Index of the render target. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface that represents the returned render target surface for the current device.

Remarks

Typically, methods that return state do not work on devices created using PureDevice. This method, however, is an exception because it returns an interface.

The device can support multiple render targets. The number of render targets supported by a device is contained in the Caps.NumberSimultaneousRts member.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | No render target is available for the given index.

See Also

  • SetRenderTarget


Device.GetRenderTargetData(Surface,Surface) Method (Microsoft.DirectX.Direct3D)

Device.GetRenderTargetData Method

Copies the render target data from device memory to system memory.

Definition

Visual Basic Public Sub GetRenderTargetData( _
ByVal renderTarget As Surface, _
ByVal destSurface As Surface _
)
C# public void GetRenderTargetData(
Surface renderTarget,
Surface destSurface
);
C++ public:
void GetRenderTargetData(
Surface^ renderTarget,
Surface^ destSurface
);
JScript public function GetRenderTargetData(
renderTarget : Surface,
destSurface : Surface
);

Parameters

renderTarget Microsoft.DirectX.Direct3D.Surface
A Surface object that represents a render target.
destSurface Microsoft.DirectX.Direct3D.Surface
[in, out] A Surface object that represents a destination surface.

Remarks

The destination surface must be either an off-screen plain surface or a level of a texture (either mipmap or cube) created with SystemMemory.

The source surface must be a regular render target or a level of a render target texture (either mipmap or cube) created with Default.

This method will fail if:

  • The render target is multisampled.
  • The source render target is of a different size than the destination surface.
  • The source render target and destination surface formats do not match.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.GetSamplerStageStateBoolean(Int32,SamplerStageStates) Method (Microsoft.DirectX.Direct3D)

Device.GetSamplerStageStateBoolean Method

Retrieves the Boolean value of a given sampler stage state.

Definition

Visual Basic Public Function GetSamplerStageStateBoolean( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates _
) As Boolean
C# public bool GetSamplerStageStateBoolean(
int stage,
SamplerStageStates state
);
C++ public:
bool GetSamplerStageStateBoolean(
int stage,
SamplerStageStates state
);
JScript public function GetSamplerStageStateBoolean(
stage : int,
state : SamplerStageStates
) : boolean;

Parameters

stage System.Int32
Index value of the sampler stage to retrieve.
state Microsoft.DirectX.Direct3D.SamplerStageStates
A member from the SamplerStageStates enumeration that represents the sampler stage state value to retreive.

Return Value

System.Boolean
The sampler stage state value retrieved.

Remarks

Use this method to retrieve sampler stage states with Boolean values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetSamplerStageStateInt32(Int32,SamplerStageStates) Method (Microsoft.DirectX.Direct3D)

Device.GetSamplerStageStateInt32 Method

Retrieves the integer value of a given sampler stage state.

Definition

Visual Basic Public Function GetSamplerStageStateInt32( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates _
) As Integer
C# public int GetSamplerStageStateInt32(
int stage,
SamplerStageStates state
);
C++ public:
int GetSamplerStageStateInt32(
int stage,
SamplerStageStates state
);
JScript public function GetSamplerStageStateInt32(
stage : int,
state : SamplerStageStates
) : int;

Parameters

stage System.Int32
Index value of the sampler stage to retrieve.
state Microsoft.DirectX.Direct3D.SamplerStageStates
A member from the SamplerStageStates enumeration that represents the sampler stage state value to retreive.

Return Value

System.Int32
The sampler stage state value retrieved.

Remarks

Use this method to retrieve sampler stage states with integer values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetSamplerStageStateSingle(Int32,SamplerStageStates) Method (Microsoft.DirectX.Direct3D)

Device.GetSamplerStageStateSingle Method

Retrieves the floating-point value of a given sampler stage state.

Definition

Visual Basic Public Function GetSamplerStageStateSingle( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates _
) As Single
C# public float GetSamplerStageStateSingle(
int stage,
SamplerStageStates state
);
C++ public:
float GetSamplerStageStateSingle(
int stage,
SamplerStageStates state
);
JScript public function GetSamplerStageStateSingle(
stage : int,
state : SamplerStageStates
) : float;

Parameters

stage System.Int32
Index value of the sampler stage to retrieve.
state Microsoft.DirectX.Direct3D.SamplerStageStates
A member from the SamplerStageStates enumeration that represents the sampler stage state value to retreive.

Return Value

System.Single
The sampler stage state value retrieved.

Remarks

Use this method to retrieve sampler stage states with floating-point values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetStreamSource(Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetStreamSource Method

Retrieves a vertex buffer bound to the specified data stream.

Definition

Visual Basic Public Function GetStreamSource( _
ByVal streamNumber As Integer, _
ByRef offsetInBytes As Integer, _
ByRef stride As Integer _
) As VertexBuffer
C# public VertexBuffer GetStreamSource(
int streamNumber,
out int offsetInBytes,
out int stride
);
C++ public:
VertexBuffer^ GetStreamSource(
int streamNumber,
[Out] int% offsetInBytes,
[Out] int% stride
);
JScript public function GetStreamSource(
streamNumber : int,
offsetInBytes : int,
stride : int
) : VertexBuffer;

Parameters

streamNumber System.Int32
Number of the data stream, in the range of 0 to the maximum number of streams -1.
offsetInBytes System.Int32
Offset from the beginning of the stream to the beginning of the vertex data, in bytes. See Remarks.
stride System.Int32
Pointer to a returned stride of the component, in bytes. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.VertexBuffer
A VertexBuffer class that represents the returned vertex buffer bound to the specified data stream.

Remarks

A stream is a uniform array of component data in which each component consists of one or more elements that represent a single entity such as position, normal, or color.

When a flexible vertex format (FVF) vertex shader is used, the stride of the vertex stream must match the vertex size, computed from the FVF. When a declaration is used, the stride should be greater than or equal to the stream size computed from the declaration.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetStreamSource


Device.GetStreamSourceFrequency(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetStreamSourceFrequency Method

Retrieves the stream source frequency divider value.

Definition

Visual Basic Public Function GetStreamSourceFrequency( _
ByVal streamNumber As Integer _
) As Integer
C# public int GetStreamSourceFrequency(
int streamNumber
);
C++ public:
int GetStreamSourceFrequency(
int streamNumber
);
JScript public function GetStreamSourceFrequency(
streamNumber : int
) : int;

Parameters

streamNumber System.Int32
Stream source number.

Return Value

System.Int32
Frequency divider value.

Remarks

Vertex shaders can be invoked more than once per vertex.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetStreamSourceFrequency


Device.GetSwapChain(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetSwapChain Method

Retrieves a reference to a swap chain.

Definition

Visual Basic Public Function GetSwapChain( _
ByVal swapChain As Integer _
) As SwapChain
C# public SwapChain GetSwapChain(
int swapChain
);
C++ public:
SwapChain^ GetSwapChain(
int swapChain
);
JScript public function GetSwapChain(
swapChain : int
) : SwapChain;

Parameters

swapChain System.Int32
Swap chain ordinal value. For more information, see Caps.NumberOfAdaptersInGroup.

Return Value

Microsoft.DirectX.Direct3D.SwapChain
A SwapChain class that receives a copy of the swap chain.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.GetTexture(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetTexture Method

Retrieves a texture assigned to a stage for a device.

Definition

Visual Basic Public Function GetTexture( _
ByVal stage As Integer _
) As Texture
C# public Texture GetTexture(
int stage
);
C++ public:
Texture^ GetTexture(
int stage
);
JScript public function GetTexture(
stage : int
) : Texture;

Parameters

stage System.Int32
Stage identifier of the texture to retrieve. Stage identifiers are zero-based.

Return Value

Microsoft.DirectX.Direct3D.Texture
A BaseTexture object that represents the returned texture.

Remarks

Typically, methods that return state do not work on devices created using PureDevice. This method, however, is an exception.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetTexture
  • Device.TextureState


Device.GetTextureStageStateBoolean(Int32,TextureStageStates) Method (Microsoft.DirectX.Direct3D)

Device.GetTextureStageStateBoolean Method

Retrieves the Boolean value of a given texture stage state.

Definition

Visual Basic Public Function GetTextureStageStateBoolean( _
ByVal stage As Integer, _
ByVal state As TextureStageStates _
) As Boolean
C# public bool GetTextureStageStateBoolean(
int stage,
TextureStageStates state
);
C++ public:
bool GetTextureStageStateBoolean(
int stage,
TextureStageStates state
);
JScript public function GetTextureStageStateBoolean(
stage : int,
state : TextureStageStates
) : boolean;

Parameters

stage System.Int32
Index value of the texture stage to retrieve.
state Microsoft.DirectX.Direct3D.TextureStageStates
A member from the TextureStageStates enumeration that represents the texture stage state value to retreive.

Return Value

System.Boolean
The texture stage state value retrieved.

Remarks

Use this method to retrieve texture stage states with Boolean values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetTextureStageStateInt32(Int32,TextureStageStates) Method (Microsoft.DirectX.Direct3D)

Device.GetTextureStageStateInt32 Method

Retrieves the integer value of a given texture stage state.

Definition

Visual Basic Public Function GetTextureStageStateInt32( _
ByVal stage As Integer, _
ByVal state As TextureStageStates _
) As Integer
C# public int GetTextureStageStateInt32(
int stage,
TextureStageStates state
);
C++ public:
int GetTextureStageStateInt32(
int stage,
TextureStageStates state
);
JScript public function GetTextureStageStateInt32(
stage : int,
state : TextureStageStates
) : int;

Parameters

stage System.Int32
Index value of the texture stage to retrieve.
state Microsoft.DirectX.Direct3D.TextureStageStates
A member from the TextureStageStates enumeration that represents the texture stage state value to retreive.

Return Value

System.Int32
The texture stage state value retrieved.

Remarks

Use this method to retrieve texture stage states with integer values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetTextureStageStateSingle(Int32,TextureStageStates) Method (Microsoft.DirectX.Direct3D)

Device.GetTextureStageStateSingle Method

Retrieves the floating-point value of a given texture stage state.

Definition

Visual Basic Public Function GetTextureStageStateSingle( _
ByVal stage As Integer, _
ByVal state As TextureStageStates _
) As Single
C# public float GetTextureStageStateSingle(
int stage,
TextureStageStates state
);
C++ public:
float GetTextureStageStateSingle(
int stage,
TextureStageStates state
);
JScript public function GetTextureStageStateSingle(
stage : int,
state : TextureStageStates
) : float;

Parameters

stage System.Int32
Index value of the texture stage to retrieve.
state Microsoft.DirectX.Direct3D.TextureStageStates
A member from the TextureStageStates enumeration that represents the texture stage state value to retreive.

Return Value

System.Single
The texture stage state value retrieved.

Remarks

Use this method to retrieve texture stage states with floating-point values.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.GetTransform(TransformType) Method (Microsoft.DirectX.Direct3D)

Device.GetTransform Method

Retrieves a matrix that describes a transformation state.

Definition

Visual Basic Public Function GetTransform( _
ByVal state As TransformType _
) As Matrix
C# public Matrix GetTransform(
TransformType state
);
C++ public:
Matrix GetTransform(
TransformType state
);
JScript public function GetTransform(
state : TransformType
) : Matrix;

Parameters

state Microsoft.DirectX.Direct3D.TransformType
Transform that is being retrieved. This parameter can be any member of the TransformType enumerated type.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that describes the returned transformation state.

Remarks

This method does not return device state for devices created using PureDevice. To use this method, create a device with any of the other flag values in CreateFlags.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetTransform


Device.GetVertexShaderBooleanConstant(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetVertexShaderBooleanConstant Method

Retrieves a Boolean vertex shader constant.

Definition

Visual Basic Public Function GetVertexShaderBooleanConstant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Boolean()
C# public bool[] GetVertexShaderBooleanConstant(
int startRegister,
int constantCount
);
C++ public:
array<bool>^ GetVertexShaderBooleanConstant(
int startRegister,
int constantCount
);
JScript public function GetVertexShaderBooleanConstant(
startRegister : int,
constantCount : int
) : boolean[];

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantCount System.Int32
Number of Boolean values in the array of constants.

Return Value

System.Boolean[]
Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetVertexShaderConstantBoolean


Device.GetVertexShaderInt32Constant(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetVertexShaderInt32Constant Method

Retrieves an integer vertex shader constant.

Definition

Visual Basic Public Function GetVertexShaderInt32Constant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Integer()
C# public int[] GetVertexShaderInt32Constant(
int startRegister,
int constantCount
);
C++ public:
array<int>^ GetVertexShaderInt32Constant(
int startRegister,
int constantCount
);
JScript public function GetVertexShaderInt32Constant(
startRegister : int,
constantCount : int
) : int[];

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantCount System.Int32
Number of four-integer vectors in the array of constants.

Return Value

System.Int32[]
Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetVertexShaderConstantInt32


Device.GetVertexShaderSingleConstant(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetVertexShaderSingleConstant Method

Retrieves a floating-point vertex shader constant.

Definition

Visual Basic Public Function GetVertexShaderSingleConstant( _
ByVal startRegister As Integer, _
ByVal constantCount As Integer _
) As Single()
C# public float[] GetVertexShaderSingleConstant(
int startRegister,
int constantCount
);
C++ public:
array<float>^ GetVertexShaderSingleConstant(
int startRegister,
int constantCount
);
JScript public function GetVertexShaderSingleConstant(
startRegister : int,
constantCount : int
) : float[];

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantCount System.Int32
Number of four-float vectors in the array of constants.

Return Value

System.Single[]
Array of constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetVertexShaderConstantSingle


Device.GetVolumeTexture(Int32) Method (Microsoft.DirectX.Direct3D)

Device.GetVolumeTexture Method

Retrieves the volume texture assigned to a stage for a device.

Definition

Visual Basic Public Function GetVolumeTexture( _
ByVal stage As Integer _
) As VolumeTexture
C# public VolumeTexture GetVolumeTexture(
int stage
);
C++ public:
VolumeTexture^ GetVolumeTexture(
int stage
);
JScript public function GetVolumeTexture(
stage : int
) : VolumeTexture;

Parameters

stage System.Int32
Stage identifier of the VolumeTexture to retrieve. Stage identifiers are zero-based.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
A VolumeTexture object that represents the returned VolumeTexture.

Remarks

Exceptions
InvalidOperationException Leave Site The texture returned was not of type VolumeTexture.


Device.MultiplyTransform(TransformType,Matrix) Method (Microsoft.DirectX.Direct3D)

Device.MultiplyTransform Method

Multiplies a device's world, view, or projection matrices by a specified matrix.

Definition

Visual Basic Public Sub MultiplyTransform( _
ByVal state As TransformType, _
ByVal matrix As Matrix _
)
C# public void MultiplyTransform(
TransformType state,
Matrix matrix
);
C++ public:
void MultiplyTransform(
TransformType state,
Matrix matrix
);
JScript public function MultiplyTransform(
state : TransformType,
matrix : Matrix
);

Parameters

state Microsoft.DirectX.Direct3D.TransformType
Member of the TransformType enumerated type that identifies which device matrix to modify. The most common setting, World, modifies the world matrix, but the view or projection matrices also can be modified.
matrix Microsoft.DirectX.Matrix
A Matrix structure that modifies the current transformation.

Remarks

The multiplication order is param_Matrix_matrix x param_TransformType_state.

An application might use the Device.MultiplyTransform method to work with hierarchies of transformations. For example, the geometry and transformations describing an arm might be arranged in the following hierarchy.

shoulder_transformation
    upper_arm geometry
    elbow transformation
        lower_arm geometry
        wrist transformation
            hand geometry

An application might use the following series of calls to render this hierarchy. Not all the parameters are shown in this C# pseudocode.

[C#]
Device.SetTransform(TransformType.World, shoulder_transform);
Device.DrawPrimitive(upper_arm);
Device.MultiplyTransform(TransformType.World, elbow_transform);
Device.DrawPrimitive(lower_arm);
Device.MultiplyTransform(TransformType.World, wrist_transform);
Device.DrawPrimitive(hand);

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.op_Equality(Device,Device) Method (Microsoft.DirectX.Direct3D)

Device.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Equality(
Device left,
Device right
);
C++ public:
static bool operator==(
Device^ left,
Device^ right
);
JScript public static function op_Equality(
left : Device,
right : Device
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Device
The Device object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Device
The Device object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Device.op_Inequality(Device,Device) Method (Microsoft.DirectX.Direct3D)

Device.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Inequality(
Device left,
Device right
);
C++ public:
static bool operator!=(
Device^ left,
Device^ right
);
JScript public static function op_Inequality(
left : Device,
right : Device
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Device
The Device object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Device
The Device object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Device.Present Method ()

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Overload List

public void Present();
public void Present(Control);
public void Present(IntPtr);
public void Present(Rectangle, bool);
public void Present(Rectangle, Control, bool);
public void Present(Rectangle, IntPtr, bool);
public void Present(Rectangle, Rectangle, Control);
public void Present(Rectangle, Rectangle, IntPtr);

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,IntPtr,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.Present Method

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindowHandle As IntPtr, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
overrideWindowHandle : IntPtr,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
The Rectangle Leave Site to present.
overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for this presentation. If this parameter is not used, PresentParameters.DeviceWindow is taken.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(IntPtr) Method (Microsoft.DirectX.Direct3D)

Device.Present Method

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic Public Sub Present( _
ByVal overrideWindowHandle As IntPtr _
)
C# public void Present(
IntPtr overrideWindowHandle
);
C++ public:
void Present(
IntPtr overrideWindowHandle
);
JScript public function Present(
overrideWindowHandle : IntPtr
);

Parameters

overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for this presentation. If this parameter is not used, PresentParameters.DeviceWindow is taken.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,Rectangle,IntPtr) Method (Microsoft.DirectX.Direct3D)

Device.Present Method

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindowHandle As IntPtr _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle
);
C++ public:
void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle
);
JScript public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindowHandle : IntPtr
);

Parameters

sourceRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the source rectangle. If the rectangle exceeds the source surface, it is clipped to the source surface. This parameter can be used only if the swap chain was created with SwapEffect.Copy.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the destination rectangle. This parameter can be used only if the swap chain was created with SwapEffect.Copy.
overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for this presentation. If this parameter is not used, PresentParameters.DeviceWindow is taken.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.Present Method

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
The Rectangle Leave Site to present.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,Control,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.Present Method

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindow As Control, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
Control overrideWindow,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
Control^ overrideWindow,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
overrideWindow : Control,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
The Rectangle Leave Site to present.
overrideWindow System.Windows.Forms.Control
Pointer to a destination window whose client area is taken as the target for this presentation. If this parameter is omitted, PresentParameters.DeviceWindow is taken.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Control) Method (Microsoft.DirectX.Direct3D)

Device.Present Method

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic Public Sub Present( _
ByVal overrideWindow As Control _
)
C# public void Present(
Control overrideWindow
);
C++ public:
void Present(
Control^ overrideWindow
);
JScript public function Present(
overrideWindow : Control
);

Parameters

overrideWindow System.Windows.Forms.Control
Pointer to a destination window whose client area is taken as the target for this presentation. If this parameter is omitted, PresentParameters.DeviceWindow is taken.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present() Method (Microsoft.DirectX.Direct3D)

Device.Present Method

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic | Public Sub Present()
C# | public void Present();
C++ public:
void Present();
JScript | public function Present();

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.Present(Rectangle,Rectangle,Control) Method (Microsoft.DirectX.Direct3D)

Device.Present Method

Presents the display with the contents of the next buffer in the sequence of back buffers owned by the device.

Definition

Visual Basic Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindow As Control _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control overrideWindow
);
C++ public:
void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control^ overrideWindow
);
JScript public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindow : Control
);

Parameters

sourceRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the source rectangle. If the rectangle exceeds the source surface, it is clipped to the source surface. This parameter can be used only if the swap chain was created with SwapEffect.Copy.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the destination rectangle. This parameter can be used only if the swap chain was created with SwapEffect.Copy.
overrideWindow System.Windows.Forms.Control
Pointer to a destination window whose client area is taken as the target for this presentation. If this parameter is omitted, PresentParameters.DeviceWindow is taken.

Remarks

If necessary, a stretch operation is applied to transfer the pixels within the source rectangle to the destination rectangle in the client area of the target window.

This method fails, throwing an InvalidCallException exception, if it is called between BeginScene and EndScene pairs, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.Reset


Device.ProcessVertices Method ()

Applies the vertex processing defined by the vertex shader to the set of input data streams, generating a single stream of interleaved vertex data to the destination vertex buffer.

Overload List

public void ProcessVertices(int, int, int, VertexBuffer, VertexDeclaration);
public void ProcessVertices(int, int, int, VertexBuffer, VertexDeclaration, bool);

Remarks

The order of operations for this method is as follows.

  • Transform vertices to projection space using the world + view + projection matrix.
  • Compute screen coordinates using viewport settings.
  • If clipping is enabled, compute clipping codes and store them in an internal buffer that is associated with the destination vertex buffer. If a vertex is inside of the viewing frustum, its screen coordinates are computed. If the vertex is outside of the viewing frustum, it is stored in the destination vertex buffer in projection space coordinates.

Note that the user does not have access to the internal clip code buffer. No clipping is done on triangles or any other primitives.

The destination vertex buffer, param_VertexBuffer_destBuffer, must be created with a nonzero flexible vertex format parameter. The flexible vertex format (FVF) code specified during the call to the VertexBuffer constructor method specifies the vertex elements present in the destination vertex buffer.

When Microsoft Direct3D generates texture coordinates or copies or transforms input texture coordinates, and the output texture coordinate format defines more texture coordinate components than Direct3D generates, Direct3D does not change the extra components.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.ProcessVertices(Int32,Int32,Int32,VertexBuffer,VertexDeclaration) Method (Microsoft.DirectX.Direct3D)

Device.ProcessVertices Method

Applies the vertex processing defined by the vertex shader to the set of input data streams, generating a single stream of interleaved vertex data to the destination vertex buffer.

Definition

Visual Basic Public Sub ProcessVertices( _
ByVal srcStartIndex As Integer, _
ByVal destIndex As Integer, _
ByVal vertexCount As Integer, _
ByVal destBuffer As VertexBuffer, _
ByVal vertexDeclaration As VertexDeclaration _
)
C# public void ProcessVertices(
int srcStartIndex,
int destIndex,
int vertexCount,
VertexBuffer destBuffer,
VertexDeclaration vertexDeclaration
);
C++ public:
void ProcessVertices(
int srcStartIndex,
int destIndex,
int vertexCount,
VertexBuffer^ destBuffer,
VertexDeclaration^ vertexDeclaration
);
JScript public function ProcessVertices(
srcStartIndex : int,
destIndex : int,
vertexCount : int,
destBuffer : VertexBuffer,
vertexDeclaration : VertexDeclaration
);

Parameters

srcStartIndex System.Int32
Index of first vertex to load.
destIndex System.Int32
Index of first vertex in the destination vertex buffer into which the results are placed.
vertexCount System.Int32
Number of vertices to process.
destBuffer Microsoft.DirectX.Direct3D.VertexBuffer
A VertexBuffer class; the destination vertex buffer that represents the stream of interleaved vertex data.
vertexDeclaration Microsoft.DirectX.Direct3D.VertexDeclaration
A VertexDeclaration class that represents the output vertex data declaration. When vertex shader 3.0 or later is set as the current vertex shader, the output vertex declaration must be present.

Remarks

The order of operations for this method is as follows.

  • Transform vertices to projection space using the world + view + projection matrix.
  • Compute screen coordinates using viewport settings.
  • If clipping is enabled, compute clipping codes and store them in an internal buffer that is associated with the destination vertex buffer. If a vertex is inside of the viewing frustum, its screen coordinates are computed. If the vertex is outside of the viewing frustum, it is stored in the destination vertex buffer in projection space coordinates.

Note that the user does not have access to the internal clip code buffer. No clipping is done on triangles or any other primitives.

The destination vertex buffer, param_VertexBuffer_destBuffer, must be created with a nonzero flexible vertex format parameter. The flexible vertex format (FVF) code specified during the call to the VertexBuffer constructor method specifies the vertex elements present in the destination vertex buffer.

When Microsoft Direct3D generates texture coordinates or copies or transforms input texture coordinates, and the output texture coordinate format defines more texture coordinate components than Direct3D generates, Direct3D does not change the extra components.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.ProcessVertices(Int32,Int32,Int32,VertexBuffer,VertexDeclaration,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.ProcessVertices Method

Applies the vertex processing defined by the vertex shader to the set of input data streams, generating a single stream of interleaved vertex data to the destination vertex buffer.

Definition

Visual Basic Public Sub ProcessVertices( _
ByVal srcStartIndex As Integer, _
ByVal destIndex As Integer, _
ByVal vertexCount As Integer, _
ByVal destBuffer As VertexBuffer, _
ByVal vertexDeclaration As VertexDeclaration, _
ByVal copyData As Boolean _
)
C# public void ProcessVertices(
int srcStartIndex,
int destIndex,
int vertexCount,
VertexBuffer destBuffer,
VertexDeclaration vertexDeclaration,
bool copyData
);
C++ public:
void ProcessVertices(
int srcStartIndex,
int destIndex,
int vertexCount,
VertexBuffer^ destBuffer,
VertexDeclaration^ vertexDeclaration,
bool copyData
);
JScript public function ProcessVertices(
srcStartIndex : int,
destIndex : int,
vertexCount : int,
destBuffer : VertexBuffer,
vertexDeclaration : VertexDeclaration,
copyData : boolean
);

Parameters

srcStartIndex System.Int32
Index of first vertex to load.
destIndex System.Int32
Index of first vertex in the destination vertex buffer into which the results are placed.
vertexCount System.Int32
Number of vertices to process.
destBuffer Microsoft.DirectX.Direct3D.VertexBuffer
A VertexBuffer class; the destination vertex buffer that represents the stream of interleaved vertex data.
vertexDeclaration Microsoft.DirectX.Direct3D.VertexDeclaration
A VertexDeclaration class that represents the output vertex data declaration. When vertex shader 3.0 or later is set as the current vertex shader, the output vertex declaration must be present.
copyData System.Boolean
Set to true for default processing. Set to false to prevent the system from copying vertex data not affected by the vertex operation into the destination buffer.

Remarks

The order of operations for this method is as follows.

  • Transform vertices to projection space using the world + view + projection matrix.
  • Compute screen coordinates using viewport settings.
  • If clipping is enabled, compute clipping codes and store them in an internal buffer that is associated with the destination vertex buffer. If a vertex is inside of the viewing frustum, its screen coordinates are computed. If the vertex is outside of the viewing frustum, it is stored in the destination vertex buffer in projection space coordinates.

Note that the user does not have access to the internal clip code buffer. No clipping is done on triangles or any other primitives.

The destination vertex buffer, param_VertexBuffer_destBuffer, must be created with a nonzero flexible vertex format parameter. The flexible vertex format (FVF) code specified during the call to the VertexBuffer constructor method specifies the vertex elements present in the destination vertex buffer.

When Microsoft Direct3D generates texture coordinates or copies or transforms input texture coordinates, and the output texture coordinate format defines more texture coordinate components than Direct3D generates, Direct3D does not change the extra components.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.raise_DeviceLost(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Device.raise_DeviceLost Method

Raises a Device.DeviceLost event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_DeviceLost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_DeviceLost(
object i1,
EventArgs i2
);
C++ protected:
void raise_DeviceLost(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_DeviceLost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Device.raise_DeviceReset(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Device.raise_DeviceReset Method

Raises a Device.DeviceReset event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_DeviceReset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_DeviceReset(
object i1,
EventArgs i2
);
C++ protected:
void raise_DeviceReset(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_DeviceReset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Device.raise_DeviceResizing(Object,CancelEventArgs) Method (Microsoft.DirectX.Direct3D)

Device.raise_DeviceResizing Method

Raises a Device.DeviceResizing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_DeviceResizing( _
ByVal i1 As Object, _
ByVal i2 As CancelEventArgs _
)
C# protected void raise_DeviceResizing(
object i1,
CancelEventArgs i2
);
C++ protected:
void raise_DeviceResizing(
Object^ i1,
CancelEventArgs^ i2
);
JScript protected function raise_DeviceResizing(
i1 : Object,
i2 : CancelEventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.ComponentModel.CancelEventArgs


Device.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Device.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Device.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Device.Reset(PresentParameters[]) Method (Microsoft.DirectX.Direct3D)

Device.Reset Method

Resets the presentation parameters for the current device.

Definition

Visual Basic Public Sub Reset( _
ByVal presentationParameters() As PresentParameters _
)
C# public void Reset(
PresentParameters[] presentationParameters
);
C++ public:
void Reset(
array<PresentParameters^>^ presentationParameters
);
JScript public function Reset(
presentationParameters : PresentParameters[]
);

Parameters

presentationParameters Microsoft.DirectX.Direct3D.PresentParameters[]
[in, out] A PresentParameters structure that describes the new presentation parameters. This value cannot be null.

Remarks

When switching to full-screen mode, Microsoft Direct3D tries to find a desktop format that matches the back buffer format, so that back and front buffer formats are identical. This eliminates the need for color conversion.

If a call to Device.Reset fails, the device is placed in the "lost" state (as indicated by a return value of false from a call to CheckCooperativeLevel) unless it is already in the "not reset" state (as indicated by a ResultCode.DeviceNotReset returned from the param_Int32R_result parameter of the Device.CheckCooperativeLevel method). For more information about the use of Reset in the context of lost devices, see CheckCooperativeLevel.

Calling Device.Reset causes all texture memory surfaces and state information to be lost, and managed textures to be flushed from video memory. Before calling Device.Reset for a device, an application should release any explicit render targets, depth stencil surfaces, additional swap chains, state blocks, and Default resources associated with the device.

Swap chains are either full-screen or windowed. If the new swap chain is full-screen, the adapter is placed in the display mode that matches the new size.

Microsoft DirectX 9.0 applications can expect messages to be sent to them during this call (for example, before the call is returned); applications should take precautions not to call into Direct3D at this time. In addition, when Device.Reset fails, the only valid methods that can be called are Device.Reset, Device.CheckCooperativeLevel, Device.TestCooperativeLevel, and the various Release member functions. Calling any other method can result in an exception.

A call to Device.Reset fails if made on a different thread than the one used to create the device being reset.

Pixel shaders and vertex shaders survive Device.Reset calls for DirectX 9.0. They do not need to be re-created explicitly by the application.

Unknown can be specified for the windowed mode back buffer format when calling Device.Device, Device.Reset, and SwapChain. This means the application does not have to query the current desktop format before calling Device.Device for windowed mode. For full-screen mode, the back buffer format must be specified. Setting PresentParameters.BackBufferCount = 0 results in the creation of one back buffer.

When trying to reset more than one display adapter in a group, pass in an array of PresentParameters objects, one for each display in the adapter group.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Device.Present
  • SwapEffect


Device.SetCursor(Cursor,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.SetCursor Method

Sets the current cursor.

Definition

Visual Basic Public Sub SetCursor( _
ByVal cursor As Cursor, _
ByVal addWaterMark As Boolean _
)
C# public void SetCursor(
Cursor cursor,
bool addWaterMark
);
C++ public:
void SetCursor(
Cursor^ cursor,
bool addWaterMark
);
JScript public function SetCursor(
cursor : Cursor,
addWaterMark : boolean
);

Parameters

cursor System.Windows.Forms.Cursor
Handle to the cursor.
addWaterMark System.Boolean
Set to true to add small grey characters that read "D3D" to the upper-left corner of the cursor image.

See Also

  • Device.SetCursorPosition
  • Device.SetCursorProperties


Device.SetCursorPosition(Int32,Int32,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.SetCursorPosition Method

Sets the cursor position and update options.

Definition

Visual Basic Public Sub SetCursorPosition( _
ByVal positionX As Integer, _
ByVal positionY As Integer, _
ByVal updateImmediate As Boolean _
)
C# public void SetCursorPosition(
int positionX,
int positionY,
bool updateImmediate
);
C++ public:
void SetCursorPosition(
int positionX,
int positionY,
bool updateImmediate
);
JScript public function SetCursorPosition(
positionX : int,
positionY : int,
updateImmediate : boolean
);

Parameters

positionX System.Int32
New X-position of the cursor in virtual desktop coordinates. See Remarks.
positionY System.Int32
New Y-position of the cursor in virtual desktop coordinates. See Remarks.
updateImmediate System.Boolean
Set to true if the system guarantees that the cursor is updated at a minimum of half of the display refresh rate, but never more frequently than the display refresh rate. Set to false if the method delays cursor updates until the next Device.Present call.

Setting this parameter to false usually results in better performance. However, applications should use true if the rate of calls to Present is low enough that users would notice a significant delay in cursor motion. This flag has no effect in an application in windowed mode. Some video cards implement hardware color cursors; this flag does not affect these cards.

Remarks

When running in full-screen mode, screen space coordinates are the back buffer coordinates appropriately scaled to the current display mode. When running in windowed mode, screen space coordinates are the desktop coordinates. The cursor image is drawn at the specified position minus the hot spot offset specified by Device.SetCursorProperties.

If the cursor is hidden by Device.ShowCursor, it is not drawn.

See Also

  • Device.SetCursor


Device.SetCursorProperties(Int32,Int32,Surface) Method (Microsoft.DirectX.Direct3D)

Device.SetCursorProperties Method

Sets properties for the cursor.

Definition

Visual Basic Public Sub SetCursorProperties( _
ByVal hotSpotX As Integer, _
ByVal hotSpotY As Integer, _
ByVal cursorBitmap As Surface _
)
C# public void SetCursorProperties(
int hotSpotX,
int hotSpotY,
Surface cursorBitmap
);
C++ public:
void SetCursorProperties(
int hotSpotX,
int hotSpotY,
Surface^ cursorBitmap
);
JScript public function SetCursorProperties(
hotSpotX : int,
hotSpotY : int,
cursorBitmap : Surface
);

Parameters

hotSpotX System.Int32
X-coordinate offset (in pixels) that marks the center of the cursor. The offset is relative to the upper-left corner of the cursor. When the cursor is given a new position, the image is drawn at an offset from the new position. The offset is determined by subtracting the hot spot coordinates from the position.
hotSpotY System.Int32
Y-coordinate offset (in pixels) that marks the center of the cursor. The offset is relative to the upper-left corner of the cursor. When the cursor is given a new position, the image is drawn at an offset from the new position. The offset is determined by subtracting the hot spot coordinates from the position.
cursorBitmap Microsoft.DirectX.Direct3D.Surface
A Surface object. This parameter must be an 8888 ARGB surface (format A8R8G8B8). The contents of this surface are copied and potentially converted into an internal buffer from which the cursor is displayed. The dimensions of this surface must be less than the dimensions of the display mode, and must be a power of two in each direction, although not necessarily the same power of two. The alpha channel must be either 0.0 or 1.0.

Remarks

An operating system cursor is created and used under either of the following conditions.

  • The hardware set CursorCaps.SupportsColor to true and the cursor size is 32x32 (which is the cursor size in the operating system).
  • The application is running in windowed mode.

If neither condition is present, Microsoft DirectX uses an emulated cursor. An application uses Device.SetCursorPosition to move an emulated cursor in order to follow mouse movement.

To determine which hardware support is available for cursors, an application can examine appropriate members of the Caps structure. Typically, hardware supports only 32x32 cursors, and the system, when windowed, also might support only 32x32 cursors. In this case, Device.SetCursorProperties still succeeds, but the cursor might be reduced to that size. The hot spot is scaled appropriately.

The cursor does not survive when the device is lost. This method must be called after the device is reset.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.SetCursor
  • Device.ShowCursor


Device.SetDialogBoxesEnabled(Boolean) Method (Microsoft.DirectX.Direct3D)

Device.SetDialogBoxesEnabled Method

Enables the use of Microsoft Windows Graphics Device Interface (GDI) dialog boxes in full-screen applications.

Definition

Visual Basic Public Sub SetDialogBoxesEnabled( _
ByVal value As Boolean _
)
C# public void SetDialogBoxesEnabled(
bool value
);
C++ public:
void SetDialogBoxesEnabled(
bool value
);
JScript public function SetDialogBoxesEnabled(
value : boolean
);

Parameters

value System.Boolean
Set to true to enable GDI dialog boxes. Set to false to disable GDI dialog boxes.

Remarks

The GDI dialog boxes must be created as child elements to the device window. They should also be created within the same thread that created the device, because this enables the parent window to manage redrawing of the child window.

This method has no effect on applications in windowed mode, but its setting takes effect if the application resets the device into full-screen mode. If SetDialogBoxesEnabled succeeds in a windowed-mode application, any subsequent reset to full-screen mode is checked against the restrictions cited above. Also, because SetDialogBoxesEnabled causes all back buffers on the swap chain to be discarded, an application is expected to refresh its content for all back buffers after the call.

Exceptions

InvalidCallException: The method call is invalid. For example, a method's parameter might contain an invalid value.

This method also might fail if the all of the following are conditions are present.

  • The application specified a back buffer format compatible with GDI; that is, X1R5G5B5, R5G6B5, or X8R8G8B8.
  • The application specified no multisampling.
  • The application specified SwapEffect.Discard.
  • The application specified PresentFlag.LockableBackBuffer.
  • The application did not specify CreateFlags.AdapterGroupDevice.
  • The application is not in a BeginScene ... EndScene pair.


Device.SetGammaRamp(Int32,Boolean,GammaRamp) Method (Microsoft.DirectX.Direct3D)

Device.SetGammaRamp Method

Sets the gamma correction ramp for the implicit swap chain.

Definition

Visual Basic Public Sub SetGammaRamp( _
ByVal swapChain As Integer, _
ByVal calibrate As Boolean, _
ByVal ramp As GammaRamp _
)
C# public void SetGammaRamp(
int swapChain,
bool calibrate,
GammaRamp ramp
);
C++ public:
void SetGammaRamp(
int swapChain,
bool calibrate,
GammaRamp ramp
);
JScript public function SetGammaRamp(
swapChain : int,
calibrate : boolean,
ramp : GammaRamp
);

Parameters

swapChain System.Int32
Unsigned integer that specifies the swap chain.
calibrate System.Boolean
Set to true to indicate that correction should be applied. Set to false to indicate that no gamma correction should be applied. The supplied gamma table is transferred directly to the device.
ramp Microsoft.DirectX.Direct3D.GammaRamp
A GammaRamp structure that represents the gamma correction ramp to set for the implicit swap chain.

Remarks

Each device always has at least one swap chain (the implicit swap chain), because Microsoft DirectX 9.0 sets a swap chain as a device property.

Gamma correction results in a more consistent display, but can incur processing overhead and should not be used frequently. Short-duration effects, such as flashing the entire screen red, should not be calibrated, but long-duration gamma changes should be. If a gamma calibrator is installed, the ramp is modified before being sent to the device to account for the system and monitor response curves. If no calibrator is installed, the ramp is passed directly to the device.

For windowed gamma correction presentation, use SwapChain.Present if the hardware supports the feature.

The gamma ramp takes effect immediately. No wait for a vertical sync operation is performed.

If the device does not support gamma ramps in the swap chain's current presentation mode (full-screen or windowed), no error is returned. Applications can check DriverCaps.SupportsFullscreenGamma and DriverCaps.CanCalibrateGamma to determine the capabilities of the device and whether a calibrator is installed.

See Also

  • SwapChain
  • GetGammaRamp


Device.SetPaletteEntries(Int32,PaletteEntry[]) Method (Microsoft.DirectX.Direct3D)

Device.SetPaletteEntries Method

Sets palette entries.

Definition

Visual Basic Public Sub SetPaletteEntries( _
ByVal paletteNumber As Integer, _
ByVal entries() As PaletteEntry _
)
C# public void SetPaletteEntries(
int paletteNumber,
PaletteEntry[] entries
);
C++ public:
void SetPaletteEntries(
int paletteNumber,
array<PaletteEntry>^ entries
);
JScript public function SetPaletteEntries(
paletteNumber : int,
entries : PaletteEntry[]
);

Parameters

paletteNumber System.Int32
Ordinal value that identifies the palette on which the operation is performed.
entries Microsoft.DirectX.Direct3D.PaletteEntry[]
Pointer to a PaletteEntry structure that represents the palette entries to set. The number of PaletteEntry structures passed into param_PaletteEntryA_entries is assumed to be 256. See Remarks.

Remarks

For Microsoft DirectX 9.0 applications, any palette sent to this method must conform to the TextureCaps.SupportsAlphaPalette capability bit of Caps.TextureCaps. If TextureCaps.SupportsAlphaPalette is not set, every entry in the palette must have alpha set to 1.0, or this method will fail and throw an InvalidCallException. If TextureCaps.SupportsAlphaPalette is set, any set of alpha values is allowed. Note that the debug runtime prints a warning message if all palette entries have alpha set to 0.

A single logical palette is associated with the device, and is shared by all texture stages.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.CurrentTexturePalette
  • Device.GetPaletteEntries


Device.SetPixelShaderConstant Method ()

Sets a pixel shader constant.

Overload List

public void SetPixelShaderConstant(int, bool[]);
public void SetPixelShaderConstant(int, int[]);
public void SetPixelShaderConstant(int, Matrix);
public void SetPixelShaderConstant(int, Matrix);
public void SetPixelShaderConstant(int, Matrix[]);
public void SetPixelShaderConstant(int, float[]);
public void SetPixelShaderConstant(int, Vector4);
public void SetPixelShaderConstant(int, Vector4);
public void SetPixelShaderConstant(int, Vector4[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Vector4) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Vector4 _
)
C# public void SetPixelShaderConstant(
int startRegister,
Vector4 constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
Vector4 constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : Vector4
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Vector4
A pointer to a Vector4 object that represents the constant data to set. Use this if your code block is marked unsafe.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Matrix) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Matrix _
)
C# public void SetPixelShaderConstant(
int startRegister,
Matrix constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
Matrix constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : Matrix
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Matrix
A pointer to a Matrix object that represents the constant data to set. Use this if your code block is marked unsafe.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Vector4) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Vector4 _
)
C# public void SetPixelShaderConstant(
int startRegister,
Vector4 constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
Vector4 constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : Vector4
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Vector4
A Vector4 object representing the constant data to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Matrix) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Matrix _
)
C# public void SetPixelShaderConstant(
int startRegister,
Matrix constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
Matrix constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : Matrix
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Matrix
A Matrix object representing the constant data to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Boolean[]) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Boolean _
)
C# public void SetPixelShaderConstant(
int startRegister,
bool[] constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
array<bool>^ constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : boolean[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData System.Boolean[]
Array of Boolean Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Integer _
)
C# public void SetPixelShaderConstant(
int startRegister,
int[] constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
array<int>^ constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : int[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData System.Int32[]
Array of Int32 Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Vector4[]) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Vector4 _
)
C# public void SetPixelShaderConstant(
int startRegister,
Vector4[] constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
array<Vector4>^ constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : Vector4[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Vector4[]
Array of Vector4 constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Matrix[]) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Matrix _
)
C# public void SetPixelShaderConstant(
int startRegister,
Matrix[] constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
array<Matrix>^ constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : Matrix[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Matrix[]
Array of Matrix constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstant(Int32,Single[]) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstant Method

Sets a pixel shader constant.

Definition

Visual Basic Public Sub SetPixelShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Single _
)
C# public void SetPixelShaderConstant(
int startRegister,
float[] constantData
);
C++ public:
void SetPixelShaderConstant(
int startRegister,
array<float>^ constantData
);
JScript public function SetPixelShaderConstant(
startRegister : int,
constantData : float[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData System.Single[]
Array of Single Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetPixelShaderConstantBoolean(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstantBoolean Method

Sets Boolean shader constants.

Definition

Visual Basic Public Sub SetPixelShaderConstantBoolean( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetPixelShaderConstantBoolean(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
C++ public:
void SetPixelShaderConstantBoolean(
int startRegister,
GraphicsStream^ constantData,
int numberRegisters
);
JScript public function SetPixelShaderConstantBoolean(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister System.Int32
Register number that will contain the first constant value.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader constants to set.
numberRegisters System.Int32
Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetPixelShaderBooleanConstant

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetPixelShaderConstantInt32(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstantInt32 Method

Sets integer shader constants.

Definition

Visual Basic Public Sub SetPixelShaderConstantInt32( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetPixelShaderConstantInt32(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
C++ public:
void SetPixelShaderConstantInt32(
int startRegister,
GraphicsStream^ constantData,
int numberRegisters
);
JScript public function SetPixelShaderConstantInt32(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister System.Int32
Register number that will contain the first constant value.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader constants to set.
numberRegisters System.Int32
Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetPixelShaderInt32Constant

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetPixelShaderConstantSingle(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetPixelShaderConstantSingle Method

Sets floating-point shader constants.

Definition

Visual Basic Public Sub SetPixelShaderConstantSingle( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetPixelShaderConstantSingle(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
C++ public:
void SetPixelShaderConstantSingle(
int startRegister,
GraphicsStream^ constantData,
int numberRegisters
);
JScript public function SetPixelShaderConstantSingle(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister System.Int32
Register number that will contain the first constant value.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader constants to set.
numberRegisters System.Int32
Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetPixelShaderSingleConstant

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderState Method ()

Sets a render state value.

Overload List

public void SetRenderState(RenderStates, bool);
public void SetRenderState(RenderStates, int);
public void SetRenderState(RenderStates, float);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetRenderStateBoolean
  • Device.GetRenderStateInt32
  • Device.GetRenderStateSingle

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderState(RenderStates,Single) Method (Microsoft.DirectX.Direct3D)

Device.SetRenderState Method

Sets a render state value.

Definition

Visual Basic Public Sub SetRenderState( _
ByVal state As RenderStates, _
ByVal value As Single _
)
C# public void SetRenderState(
RenderStates state,
float value
);
C++ public:
void SetRenderState(
RenderStates state,
float value
);
JScript public function SetRenderState(
state : RenderStates,
value : float
);

Parameters

state Microsoft.DirectX.Direct3D.RenderStates
A member from the RenderStates enumeration that represents the render state value to set.
value System.Single
A floating-point render state value to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetRenderStateBoolean
  • Device.GetRenderStateInt32
  • Device.GetRenderStateSingle

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderState(RenderStates,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.SetRenderState Method

Sets a render state value.

Definition

Visual Basic Public Sub SetRenderState( _
ByVal state As RenderStates, _
ByVal value As Boolean _
)
C# public void SetRenderState(
RenderStates state,
bool value
);
C++ public:
void SetRenderState(
RenderStates state,
bool value
);
JScript public function SetRenderState(
state : RenderStates,
value : boolean
);

Parameters

state Microsoft.DirectX.Direct3D.RenderStates
A member from the RenderStates enumeration that represents the render state value to set.
value System.Boolean
A Boolean render state value to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetRenderStateBoolean
  • Device.GetRenderStateInt32
  • Device.GetRenderStateSingle

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderState(RenderStates,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetRenderState Method

Sets a render state value.

Definition

Visual Basic Public Sub SetRenderState( _
ByVal state As RenderStates, _
ByVal value As Integer _
)
C# public void SetRenderState(
RenderStates state,
int value
);
C++ public:
void SetRenderState(
RenderStates state,
int value
);
JScript public function SetRenderState(
state : RenderStates,
value : int
);

Parameters

state Microsoft.DirectX.Direct3D.RenderStates
A member from the RenderStates enumeration that represents the render state value to set.
value System.Int32
An integer render state value to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetRenderStateBoolean
  • Device.GetRenderStateInt32
  • Device.GetRenderStateSingle

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetRenderTarget(Int32,Surface) Method (Microsoft.DirectX.Direct3D)

Device.SetRenderTarget Method

Sets a new color buffer for a device.

Definition

Visual Basic Public Sub SetRenderTarget( _
ByVal renderTargetIndex As Integer, _
ByVal renderTarget As Surface _
)
C# public void SetRenderTarget(
int renderTargetIndex,
Surface renderTarget
);
C++ public:
void SetRenderTarget(
int renderTargetIndex,
Surface^ renderTarget
);
JScript public function SetRenderTarget(
renderTargetIndex : int,
renderTarget : Surface
);

Parameters

renderTargetIndex System.Int32
Index of the render target. See Remarks.
renderTarget Microsoft.DirectX.Direct3D.Surface
New color buffer. If set to null, the color buffer for the corresponding param_Int32_renderTargetIndex is disabled. Devices must always be associated with a color buffer.

The new render-target surface must have at least RenderTarget specified.

Remarks

The device can support multiple render targets. The number of render targets supported by a device is contained in Caps.NumberSimultaneousRts.

Some hardware tests the compatibility of the depth stencil buffer with the color buffer. If this is done, it is done only in a debug build.

The following restrictions apply when using this method.

  • The multisample type must be the same for the render target and the depth stencil surface.
  • The formats must be compatible for the render target and the depth stencil surface. For more information, see Manager.CheckDepthStencilMatch.
  • The size of the depth stencil surface must be greater than or equal to the size of the render target.

These restrictions are validated only when using the debug runtime when any of the Device Draw methods are called.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

Exceptions
InvalidCallException The method call is invalid. Either param_Surface_renderTarget = null and param_Int32_renderTargetIndex = 0, or param_Surface_renderTarget != null and the render target is invalid.


Device.SetSamplerState Method ()

Sets a sampler stage state value.

Overload List

public void SetSamplerState(int, SamplerStageStates, bool);
public void SetSamplerState(int, SamplerStageStates, int);
public void SetSamplerState(int, SamplerStageStates, float);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetSamplerState(Int32,SamplerStageStates,Single) Method (Microsoft.DirectX.Direct3D)

Device.SetSamplerState Method

Sets a sampler stage state value.

Definition

Visual Basic Public Sub SetSamplerState( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates, _
ByVal value As Single _
)
C# public void SetSamplerState(
int stage,
SamplerStageStates state,
float value
);
C++ public:
void SetSamplerState(
int stage,
SamplerStageStates state,
float value
);
JScript public function SetSamplerState(
stage : int,
state : SamplerStageStates,
value : float
);

Parameters

stage System.Int32
Index value of the sampler stage to set.
state Microsoft.DirectX.Direct3D.SamplerStageStates
A member from the SamplerStageStates enumeration that represents the sampler stage state value to set.
value System.Single
A floating-point value to set for the given sampler stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetSamplerState(Int32,SamplerStageStates,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.SetSamplerState Method

Sets a sampler stage state value.

Definition

Visual Basic Public Sub SetSamplerState( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates, _
ByVal value As Boolean _
)
C# public void SetSamplerState(
int stage,
SamplerStageStates state,
bool value
);
C++ public:
void SetSamplerState(
int stage,
SamplerStageStates state,
bool value
);
JScript public function SetSamplerState(
stage : int,
state : SamplerStageStates,
value : boolean
);

Parameters

stage System.Int32
Index value of the sampler stage to set.
state Microsoft.DirectX.Direct3D.SamplerStageStates
A member from the SamplerStageStates enumeration that represents the sampler stage state value to set.
value System.Boolean
A Boolean value to set for the given sampler stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetSamplerState(Int32,SamplerStageStates,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetSamplerState Method

Sets a sampler stage state value.

Definition

Visual Basic Public Sub SetSamplerState( _
ByVal stage As Integer, _
ByVal state As SamplerStageStates, _
ByVal value As Integer _
)
C# public void SetSamplerState(
int stage,
SamplerStageStates state,
int value
);
C++ public:
void SetSamplerState(
int stage,
SamplerStageStates state,
int value
);
JScript public function SetSamplerState(
stage : int,
state : SamplerStageStates,
value : int
);

Parameters

stage System.Int32
Index value of the sampler stage to set.
state Microsoft.DirectX.Direct3D.SamplerStageStates
A member from the SamplerStageStates enumeration that represents the sampler stage state value to set.
value System.Int32
An integer value to set for the given sampler stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetStreamSource Method ()

How Do I...?
  • Generate a Scene

Binds a vertex buffer to a device data stream.

Overload List

public void SetStreamSource(int, VertexBuffer, int);
public void SetStreamSource(int, VertexBuffer, int, int);

Remarks

When a flexible vertex format vertex shader is used, the stride of the vertex stream must match the vertex size, computed from the flexible vertex format (FVF). When a declaration is used, the stride should be greater than or equal to the stream size computed from the declaration.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

See Also

  • DrawUserPrimitives
  • DrawIndexedPrimitives
  • GetStreamSource
  • DrawIndexedUserPrimitives


Device.SetStreamSource(Int32,VertexBuffer,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetStreamSource Method

How Do I...?
  • Generate a Scene

Binds a vertex buffer to a device data stream.

Definition

Visual Basic Public Sub SetStreamSource( _
ByVal streamNumber As Integer, _
ByVal streamData As VertexBuffer, _
ByVal offsetInBytes As Integer _
)
C# public void SetStreamSource(
int streamNumber,
VertexBuffer streamData,
int offsetInBytes
);
C++ public:
void SetStreamSource(
int streamNumber,
VertexBuffer^ streamData,
int offsetInBytes
);
JScript public function SetStreamSource(
streamNumber : int,
streamData : VertexBuffer,
offsetInBytes : int
);

Parameters

streamNumber System.Int32
Data stream in the range of 0 to the maximum number of streams -1.
streamData Microsoft.DirectX.Direct3D.VertexBuffer
Pointer to a VertexBuffer class that represents the vertex buffer to bind to the specified data stream.
offsetInBytes System.Int32
Offset from the beginning of the stream to the beginning of the vertex data, in bytes. To determine whether the device supports stream offsets, see DeviceCaps.SupportsStreamOffset.

Remarks

When a flexible vertex format vertex shader is used, the stride of the vertex stream must match the vertex size, computed from the flexible vertex format (FVF). When a declaration is used, the stride should be greater than or equal to the stream size computed from the declaration.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

See Also

  • DrawUserPrimitives
  • DrawIndexedPrimitives
  • GetStreamSource
  • DrawIndexedUserPrimitives


Device.SetStreamSource(Int32,VertexBuffer,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetStreamSource Method

How Do I...?
  • Generate a Scene

Binds a vertex buffer to a device data stream.

Definition

Visual Basic Public Sub SetStreamSource( _
ByVal streamNumber As Integer, _
ByVal streamData As VertexBuffer, _
ByVal offsetInBytes As Integer, _
ByVal stride As Integer _
)
C# public void SetStreamSource(
int streamNumber,
VertexBuffer streamData,
int offsetInBytes,
int stride
);
C++ public:
void SetStreamSource(
int streamNumber,
VertexBuffer^ streamData,
int offsetInBytes,
int stride
);
JScript public function SetStreamSource(
streamNumber : int,
streamData : VertexBuffer,
offsetInBytes : int,
stride : int
);

Parameters

streamNumber System.Int32
Data stream in the range of 0 to the maximum number of streams -1.
streamData Microsoft.DirectX.Direct3D.VertexBuffer
Pointer to a VertexBuffer class that represents the vertex buffer to bind to the specified data stream.
offsetInBytes System.Int32
Offset from the beginning of the stream to the beginning of the vertex data, in bytes. To determine whether the device supports stream offsets, see DeviceCaps.SupportsStreamOffset.
stride System.Int32
Stride of the component, in bytes. See Remarks.

Remarks

When a flexible vertex format vertex shader is used, the stride of the vertex stream must match the vertex size, computed from the flexible vertex format (FVF). When a declaration is used, the stride should be greater than or equal to the stream size computed from the declaration.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

See Also

  • DrawUserPrimitives
  • DrawIndexedPrimitives
  • GetStreamSource
  • DrawIndexedUserPrimitives


Device.SetStreamSourceFrequency(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetStreamSourceFrequency Method

Sets the stream source frequency divider value.

Definition

Visual Basic Public Sub SetStreamSourceFrequency( _
ByVal streamNumber As Integer, _
ByVal divider As Integer _
)
C# public void SetStreamSourceFrequency(
int streamNumber,
int divider
);
C++ public:
void SetStreamSourceFrequency(
int streamNumber,
int divider
);
JScript public function SetStreamSourceFrequency(
streamNumber : int,
divider : int
);

Parameters

streamNumber System.Int32
Stream source number.
divider System.Int32
Frequency divider value.

Remarks

Vertex shaders can be invoked more than once per vertex.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetStreamSourceFrequency


Device.SetTexture(Int32,BaseTexture) Method (Microsoft.DirectX.Direct3D)

Device.SetTexture Method

How Do I...?
  • Render Mesh with Texture using HLSL

Assigns a texture to a device stage.

Definition

Visual Basic Public Sub SetTexture( _
ByVal stage As Integer, _
ByVal texture As BaseTexture _
)
C# public void SetTexture(
int stage,
BaseTexture texture
);
C++ public:
void SetTexture(
int stage,
BaseTexture^ texture
);
JScript public function SetTexture(
stage : int,
texture : BaseTexture
);

Parameters

stage System.Int32
Index value for the device stage.
texture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that represents the texture being set.

Remarks

This method is not allowed if the texture is created with a pool type of Scratch, nor is it allowed with a pool type of SystemMemory, unless DeviceCaps.SupportsTextureSystemMemory is set to true.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Render Mesh with Texture using HLSL

This example demonstrates how to render a mesh texture using the high-level shader language (HLSL).

In the following C# code example, the following assumptions are made:

  1. effect is a valid HLSL Effect with its technique set.
  2. The code occurs between calls to Effect.BeginPass and Effect.EndPass.
  3. mesh is a valid Mesh.
  4. meshTextures is a valid array of textures for the mesh.

              [C#]

effect.SetValue("WorldViewProjection", worldMatrix);

// Iterate through each subset and render with its texture
for (int m = 0; m < meshTextures.Length; ++m)
{
    effect.SetValue("SceneTexture", meshTextures[m]));
    effect.CommitChanges();
    mesh.DrawSubset(m);
}

See Also

  • GetTexture


Device.SetTextureStageState Method ()

Sets a texture stage state value.

Overload List

public void SetTextureStageState(int, TextureStageStates, bool);
public void SetTextureStageState(int, TextureStageStates, int);
public void SetTextureStageState(int, TextureStageStates, float);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetTextureStageState(Int32,TextureStageStates,Single) Method (Microsoft.DirectX.Direct3D)

Device.SetTextureStageState Method

Sets a texture stage state value.

Definition

Visual Basic Public Sub SetTextureStageState( _
ByVal stage As Integer, _
ByVal state As TextureStageStates, _
ByVal value As Single _
)
C# public void SetTextureStageState(
int stage,
TextureStageStates state,
float value
);
C++ public:
void SetTextureStageState(
int stage,
TextureStageStates state,
float value
);
JScript public function SetTextureStageState(
stage : int,
state : TextureStageStates,
value : float
);

Parameters

stage System.Int32
Index value of the texture stage to set.
state Microsoft.DirectX.Direct3D.TextureStageStates
A member from the TextureStageStates enumeration that represents the texture stage state value to set.
value System.Single
A floating-point value to set for the given texture stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetTextureStageState(Int32,TextureStageStates,Boolean) Method (Microsoft.DirectX.Direct3D)

Device.SetTextureStageState Method

Sets a texture stage state value.

Definition

Visual Basic Public Sub SetTextureStageState( _
ByVal stage As Integer, _
ByVal state As TextureStageStates, _
ByVal value As Boolean _
)
C# public void SetTextureStageState(
int stage,
TextureStageStates state,
bool value
);
C++ public:
void SetTextureStageState(
int stage,
TextureStageStates state,
bool value
);
JScript public function SetTextureStageState(
stage : int,
state : TextureStageStates,
value : boolean
);

Parameters

stage System.Int32
Index value of the texture stage to set.
state Microsoft.DirectX.Direct3D.TextureStageStates
A member from the TextureStageStates enumeration that represents the texture stage state value to set.
value System.Boolean
A Boolean value to set for the given texture stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetTextureStageState(Int32,TextureStageStates,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetTextureStageState Method

Sets a texture stage state value.

Definition

Visual Basic Public Sub SetTextureStageState( _
ByVal stage As Integer, _
ByVal state As TextureStageStates, _
ByVal value As Integer _
)
C# public void SetTextureStageState(
int stage,
TextureStageStates state,
int value
);
C++ public:
void SetTextureStageState(
int stage,
TextureStageStates state,
int value
);
JScript public function SetTextureStageState(
stage : int,
state : TextureStageStates,
value : int
);

Parameters

stage System.Int32
Index value of the texture stage to set.
state Microsoft.DirectX.Direct3D.TextureStageStates
A member from the TextureStageStates enumeration that represents the texture stage state value to set.
value System.Int32
An integer value to set for the given texture stage state.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetTransform(TransformType,Matrix) Method (Microsoft.DirectX.Direct3D)

Device.SetTransform Method

Sets a single device transform.

Definition

Visual Basic Public Sub SetTransform( _
ByVal state As TransformType, _
ByVal matrix As Matrix _
)
C# public void SetTransform(
TransformType state,
Matrix matrix
);
C++ public:
void SetTransform(
TransformType state,
Matrix matrix
);
JScript public function SetTransform(
state : TransformType,
matrix : Matrix
);

Parameters

state Microsoft.DirectX.Direct3D.TransformType
Type of transform that is being modified; can be any member of the TransformType enumerated type.
matrix Microsoft.DirectX.Matrix
A Matrix structure that modifies the current transform.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetTransform


Device.SetVertexShaderConstant Method ()

Sets a vertex shader constant.

Overload List

public void SetVertexShaderConstant(int, bool[]);
public void SetVertexShaderConstant(int, int[]);
public void SetVertexShaderConstant(int, Matrix);
public void SetVertexShaderConstant(int, Matrix);
public void SetVertexShaderConstant(int, Matrix[]);
public void SetVertexShaderConstant(int, float[]);
public void SetVertexShaderConstant(int, Vector4);
public void SetVertexShaderConstant(int, Vector4);
public void SetVertexShaderConstant(int, Vector4[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Vector4) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Vector4 _
)
C# public void SetVertexShaderConstant(
int startRegister,
Vector4 constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
Vector4 constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : Vector4
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Vector4
A pointer to a Vector4 object that represents the constant data to set. Use this if your code block is marked unsafe.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Matrix) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Matrix _
)
C# public void SetVertexShaderConstant(
int startRegister,
Matrix constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
Matrix constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : Matrix
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Matrix
A pointer to a Matrix object that represents the constant data to set. Use this if your code block is marked unsafe.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Vector4) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Vector4 _
)
C# public void SetVertexShaderConstant(
int startRegister,
Vector4 constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
Vector4 constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : Vector4
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Vector4
A Vector4 object representing the constant data to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Matrix) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData As Matrix _
)
C# public void SetVertexShaderConstant(
int startRegister,
Matrix constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
Matrix constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : Matrix
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Matrix
A Matrix object representing the constant data to set.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Boolean[]) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Boolean _
)
C# public void SetVertexShaderConstant(
int startRegister,
bool[] constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
array<bool>^ constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : boolean[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData System.Boolean[]
Array of Boolean Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Integer _
)
C# public void SetVertexShaderConstant(
int startRegister,
int[] constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
array<int>^ constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : int[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData System.Int32[]
Array of Int32 Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Vector4[]) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Vector4 _
)
C# public void SetVertexShaderConstant(
int startRegister,
Vector4[] constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
array<Vector4>^ constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : Vector4[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Vector4[]
Array of Vector4 constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Matrix[]) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Matrix _
)
C# public void SetVertexShaderConstant(
int startRegister,
Matrix[] constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
array<Matrix>^ constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : Matrix[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData Microsoft.DirectX.Matrix[]
Array of Matrix constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstant(Int32,Single[]) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstant Method

Sets a vertex shader constant.

Definition

Visual Basic Public Sub SetVertexShaderConstant( _
ByVal startRegister As Integer, _
ByVal constantData() As Single _
)
C# public void SetVertexShaderConstant(
int startRegister,
float[] constantData
);
C++ public:
void SetVertexShaderConstant(
int startRegister,
array<float>^ constantData
);
JScript public function SetVertexShaderConstant(
startRegister : int,
constantData : float[]
);

Parameters

startRegister System.Int32
Register number that contains the first constant value.
constantData System.Single[]
Array of Single Leave Site constants.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.SetVertexShaderConstantBoolean(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstantBoolean Method

Sets Boolean vertex shader constants.

Definition

Visual Basic Public Sub SetVertexShaderConstantBoolean( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetVertexShaderConstantBoolean(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
C++ public:
void SetVertexShaderConstantBoolean(
int startRegister,
GraphicsStream^ constantData,
int numberRegisters
);
JScript public function SetVertexShaderConstantBoolean(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister System.Int32
Register number that will contain the first constant value.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader constants to set.
numberRegisters System.Int32
Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetVertexShaderBooleanConstant

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetVertexShaderConstantInt32(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstantInt32 Method

Sets integer vertex shader constants.

Definition

Visual Basic Public Sub SetVertexShaderConstantInt32( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetVertexShaderConstantInt32(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
C++ public:
void SetVertexShaderConstantInt32(
int startRegister,
GraphicsStream^ constantData,
int numberRegisters
);
JScript public function SetVertexShaderConstantInt32(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister System.Int32
Register number that will contain the first constant value.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader constants to set.
numberRegisters System.Int32
Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetVertexShaderInt32Constant

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetVertexShaderConstantSingle(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

Device.SetVertexShaderConstantSingle Method

Sets floating-point vertex shader constants.

Definition

Visual Basic Public Sub SetVertexShaderConstantSingle( _
ByVal startRegister As Integer, _
ByVal constantData As GraphicsStream, _
ByVal numberRegisters As Integer _
)
C# public void SetVertexShaderConstantSingle(
int startRegister,
GraphicsStream constantData,
int numberRegisters
);
C++ public:
void SetVertexShaderConstantSingle(
int startRegister,
GraphicsStream^ constantData,
int numberRegisters
);
JScript public function SetVertexShaderConstantSingle(
startRegister : int,
constantData : GraphicsStream,
numberRegisters : int
);

Parameters

startRegister System.Int32
Register number that will contain the first constant value.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader constants to set.
numberRegisters System.Int32
Number of constants contained within constantData.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Device.GetVertexShaderSingleConstant

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.ShowCursor(Boolean) Method (Microsoft.DirectX.Direct3D)

Device.ShowCursor Method

Displays or hides the cursor.

Definition

Visual Basic Public Function ShowCursor( _
ByVal canShow As Boolean _
) As Boolean
C# public bool ShowCursor(
bool canShow
);
C++ public:
bool ShowCursor(
bool canShow
);
JScript public function ShowCursor(
canShow : boolean
) : boolean;

Parameters

canShow System.Boolean
Set to true if the cursor is shown. Set to false if the cursor is hidden.

Return Value

System.Boolean
Value that indicates whether the cursor was previously visible. If set to true, the cursor was visible; if set to false, it was not.

Remarks

Microsoft Direct3D cursor functions use either the Microsoft Windows Graphics Device Interface (GDI) cursor or software emulation, depending on the hardware.

See Also

  • SetCursor
  • SetCursorPosition
  • SetCursorProperties


Device.StretchRectangle(Surface,Rectangle,Surface,Rectangle,TextureFilter) Method (Microsoft.DirectX.Direct3D)

Device.StretchRectangle Method

Copies the contents of the source rectangle to the destination rectangle.

Definition

Visual Basic Public Sub StretchRectangle( _
ByVal sourceSurface As Surface, _
ByVal sourceRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal filter As TextureFilter _
)
C# public void StretchRectangle(
Surface sourceSurface,
Rectangle sourceRectangle,
Surface destSurface,
Rectangle destRectangle,
TextureFilter filter
);
C++ public:
void StretchRectangle(
Surface^ sourceSurface,
Rectangle sourceRectangle,
Surface^ destSurface,
Rectangle destRectangle,
TextureFilter filter
);
JScript public function StretchRectangle(
sourceSurface : Surface,
sourceRectangle : Rectangle,
destSurface : Surface,
destRectangle : Rectangle,
filter : TextureFilter
);

Parameters

sourceSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourceRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle. If set to null, the entire source surface is used.
destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle. If set to null, the entire destination surface is used.
filter Microsoft.DirectX.Direct3D.TextureFilter
Filter type. Allowable values are None, Point, or Linear. For more information, see TextureFilter.

Remarks

The source rectangle can be stretched and filtered by the copy. This method is often used to change the aspect ratio of a video stream.

General Restrictions

There are many restrictions on which surface combinations are valid for Device.StretchRectangle. Factors include whether the driver is part of Microsoft DirectX 9.0 or an earlier version, and whether the operation will result in stretching or shrinking. Since applications are not expected to recognize whether the driver is a DirectX 9.0 driver, Microsoft Direct3D automatically sets a new value in the DeviceCaps.CanStretchRectangleFromTextures property for drivers from DirectX 9.0 and later.

The following tables show the possible surface combinations.

DirectX 9.0 driver (no stretching)

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | No | Yes | Yes | No
RT texture | No | Yes | Yes | No
RT | No | Yes | Yes | No
Off-screen plain | No | Yes | Yes | Yes

DirectX 9.0 driver (stretching)

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | No | Yes | Yes | No
RT texture | No | Yes | Yes | No
RT | No | Yes | Yes | No
Off-screen plain | No | Yes | Yes | No

Device.StretchRectangle requires that both source and destination surfaces be Pool.Default surfaces.

If filtering is specified, Device.StretchRectangle fails unless the driver sets Caps.StretchRectangleFilterCaps. If TextureFilter.None is specified, the driver chooses a filtering algorithm.

The stretch operation supports color-space conversion from YUV to high-precision RGBA only. Stretching between rectangles on the same surface is not supported. To test the hardware for color conversion, use Manager.CheckDeviceFormatConversion, because software emulation for the conversion is not supported.

Texture Restrictions

Device.StretchRectangle works for a texture surface or cube texture surface only for DirectX 9.0 drivers (those that set DeviceCaps.CanStretchRectangleFromTextures).

Depth and Stencil Restrictions

Depth and stencil surfaces can be copied using Device.StretchRectangle with the following restrictions.

  • Because both source and destination surfaces must be plain depth stencil surfaces and not textures, they must be created with Device.CreateDepthStencilSurface.
  • Both surfaces must be of the same format; that is, no format conversion is allowed.
  • No stretching or shrinking is allowed.
  • Subrectangle copies are not allowed. The entire surface must be copied; that is, sourceRectangle and destRectangle must be null or must point to rectangles that cover the whole surface.
  • Device.StretchRectangle cannot be called inside of a Device.BeginScene ... Device.EndScene pair.
  • The source or destination surface cannot be a mip level of a texture or cube texture created with Usage.DepthStencil.
  • Neither of the surfaces can be created with their Discard values set to true.
  • Drivers must set DeviceCaps.CanStretchRectangleFromTextures.

Device.StretchRectangle will fail in any of the following situations.

  • The sourceSurface and destSurface parameters are the same.
  • Stretching or shrinking is involved and either surface has a DXTn compressed format.
  • The destination surface is an off-screen plain surface, but the source is not.
  • The destination surface is an off-screen plain surface, and stretching is involved.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.TestCooperativeLevel() Method (Microsoft.DirectX.Direct3D)

Device.TestCooperativeLevel Method

Reports the current cooperative-level status of the Microsoft Direct3D device for a windowed or full-screen application.

Definition

Visual Basic | Public Sub TestCooperativeLevel()
C# | public void TestCooperativeLevel();
C++ public:
void TestCooperativeLevel();
JScript | public function TestCooperativeLevel();

Remarks

If the device is lost and cannot be restored at the current time, Device.TestCooperativeLevel throws a DeviceLostException. This is the case, for example, when a full-screen device loses focus. If an application detects a lost device, it should pause and periodically call Device.TestCooperativeLevel until no exceptions are thrown. The application can then attempt to reset the device by calling Device.Reset and, if this succeeds, restore the necessary resources and resume normal operation. Note that Device.Present throws a DeviceLostException if the device is either "lost" or "not reset".

A call to Device.TestCooperativeLevel fails if made on a different thread than the one used to create the device being reset.

Exceptions
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
DeviceNotResetException | The device is lost but can be reset at this time.


Device.UpdateSurface Method ()

Copies rectangular subsets of pixels from one surface to another.

Overload List

public void UpdateSurface(Surface, Rectangle, Surface);
public void UpdateSurface(Surface, Rectangle, Surface, Point);
public void UpdateSurface(Surface, Surface);
public void UpdateSurface(Surface, Surface, Point);

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateSurface(Surface,Surface) Method (Microsoft.DirectX.Direct3D)

Device.UpdateSurface Method

Copies rectangular subsets of pixels from one surface to another.

Definition

Visual Basic Public Sub UpdateSurface( _
ByVal sourceSurface As Surface, _
ByVal destinationSurface As Surface _
)
C# public void UpdateSurface(
Surface sourceSurface,
Surface destinationSurface
);
C++ public:
void UpdateSurface(
Surface^ sourceSurface,
Surface^ destinationSurface
);
JScript public function UpdateSurface(
sourceSurface : Surface,
destinationSurface : Surface
);

Parameters

sourceSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface; must point to a surface other than destinationSurface.
destinationSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateSurface(Surface,Surface,Point) Method (Microsoft.DirectX.Direct3D)

Device.UpdateSurface Method

Copies rectangular subsets of pixels from one surface to another.

Definition

Visual Basic Public Sub UpdateSurface( _
ByVal sourceSurface As Surface, _
ByVal destinationSurface As Surface, _
ByVal destPoint As Point _
)
C# public void UpdateSurface(
Surface sourceSurface,
Surface destinationSurface,
Point destPoint
);
C++ public:
void UpdateSurface(
Surface^ sourceSurface,
Surface^ destinationSurface,
Point destPoint
);
JScript public function UpdateSurface(
sourceSurface : Surface,
destinationSurface : Surface,
destPoint : Point
);

Parameters

sourceSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface; must point to a surface other than destinationSurface.
destinationSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPoint System.Drawing.Point
A Point Leave Site object that represents the upper-left corner of the destination rectangle. Specifying null for this parameter causes the entire surface to be copied.

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateSurface(Surface,Rectangle,Surface) Method (Microsoft.DirectX.Direct3D)

Device.UpdateSurface Method

Copies rectangular subsets of pixels from one surface to another.

Definition

Visual Basic Public Sub UpdateSurface( _
ByVal sourceSurface As Surface, _
ByVal sourceRect As Rectangle, _
ByVal destinationSurface As Surface _
)
C# public void UpdateSurface(
Surface sourceSurface,
Rectangle sourceRect,
Surface destinationSurface
);
C++ public:
void UpdateSurface(
Surface^ sourceSurface,
Rectangle sourceRect,
Surface^ destinationSurface
);
JScript public function UpdateSurface(
sourceSurface : Surface,
sourceRect : Rectangle,
destinationSurface : Surface
);

Parameters

sourceSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface; must point to a surface other than destinationSurface.
sourceRect System.Drawing.Rectangle
A Rectangle Leave Site object that represents the rectangle on the source surface. Specifying null for this parameter causes the entire surface to be copied.
destinationSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateSurface(Surface,Rectangle,Surface,Point) Method (Microsoft.DirectX.Direct3D)

Device.UpdateSurface Method

Copies rectangular subsets of pixels from one surface to another.

Definition

Visual Basic Public Sub UpdateSurface( _
ByVal sourceSurface As Surface, _
ByVal sourceRect As Rectangle, _
ByVal destinationSurface As Surface, _
ByVal destPoint As Point _
)
C# public void UpdateSurface(
Surface sourceSurface,
Rectangle sourceRect,
Surface destinationSurface,
Point destPoint
);
C++ public:
void UpdateSurface(
Surface^ sourceSurface,
Rectangle sourceRect,
Surface^ destinationSurface,
Point destPoint
);
JScript public function UpdateSurface(
sourceSurface : Surface,
sourceRect : Rectangle,
destinationSurface : Surface,
destPoint : Point
);

Parameters

sourceSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface; must point to a surface other than destinationSurface.
sourceRect System.Drawing.Rectangle
A Rectangle Leave Site object that represents the rectangle on the source surface. Specifying null for this parameter causes the entire surface to be copied.
destinationSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPoint System.Drawing.Point
A Point Leave Site object that represents the upper-left corner of the destination rectangle. Specifying null for this parameter causes the entire surface to be copied.

Remarks

This method has the following restrictions.

  • The source surface must have been created with Pool.SystemMemory.
  • The destination surface must have been created with Pool.Default.
  • Neither surface can be locked or hold an outstanding device context.
  • Neither surface can be created with multisampling. The only valid flag for both surfaces is MultiSampleType.None.
  • The surface format cannot be a depth stencil format.
  • The source and destination rectangles must fit within the surface.
  • No stretching or shrinking is allowed; that is, the rectangles must be the same size.
  • The source format must match the destination format.

The following table shows the supported format combinations.

Destination format
Source format | Texture | RT texture | RT | Off-screen plain
Texture | Yes | Yes | Yes* | Yes
RT texture | No | No | No | No
RT | No | No | No | No
Off-screen plain | Yes | Yes | Yes | Yes

* If the driver does not support the requested copy, it is emulated using locking and copying.

If the application needs to copy data from a Pool.Default render target to a Pool.SystemMemory surface, it can use Device.GetRenderTargetData.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateTexture(BaseTexture,BaseTexture) Method (Microsoft.DirectX.Direct3D)

Device.UpdateTexture Method

Updates the dirty portions of a texture.

Definition

Visual Basic Public Sub UpdateTexture( _
ByVal sourceTexture As BaseTexture, _
ByVal destinationTexture As BaseTexture _
)
C# public void UpdateTexture(
BaseTexture sourceTexture,
BaseTexture destinationTexture
);
C++ public:
void UpdateTexture(
BaseTexture^ sourceTexture,
BaseTexture^ destinationTexture
);
JScript public function UpdateTexture(
sourceTexture : BaseTexture,
destinationTexture : BaseTexture
);

Parameters

sourceTexture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that represents the source texture, which must be in system memory (Pool.SystemMemory).
destinationTexture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that represents the destination texture, which must be in the default memory pool (Pool.Default).

Remarks

To dirty a portion of a texture, either lock it or call one of the following methods.

  • CubeTexture.AddDirtyRectangle
  • Texture.AddDirtyRectangle
  • VolumeTexture.AddDirtyBox
  • Device.UpdateSurface

Device.UpdateTexture retrieves the dirty portions of the texture by calculating what has been accumulated since the last update operation.

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when Texture.LockRectangle or VolumeTexture.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. Also, the destination surface of Device.UpdateSurface is marked dirty.

This method fails if the textures are of different types, if their bottom-level buffers are of different sizes, or if their matching levels do not match. For example, consider a six-level source texture with the following dimensions:

32x16, 16x8, 8x4, 4x2, 2x1, 1x1

This six-level source texture could be the source for the following one-level destination:

1x1

For the following two-level destination:

2x1, 1x1

Or for the following three-level destination:

4x2, 2x1, 1x1

In addition, this method fails if the textures are of different formats. If the destination texture has fewer levels than the source, only the matching levels are copied. If the source texture has fewer levels than the destination, the method fails.

If the source texture contains dirty regions, the copy operation can be optimized by restricting it to those regions only. It is not guaranteed that only those bytes marked dirty will be copied.

The following scenarios are supported for source and destination surface combinations.

  • If sourceTexture is a non-autogenerated mipmap and destinationTexture is an autogenerated mipmap, only the topmost matching level is updated, and the destination sublevels are regenerated. All other source sublevels are ignored.
  • If both sourceTexture and destinationTexture are autogenerated mipmaps, only the topmost matching level is updated. The sublevels from the source are ignored and the destination sublevels are regenerated.
  • If sourceTexture is an autogenerated mipmap and destinationTexture a non-autogenerated mipmap, this method fails.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Device.UpdateUnmanagedPointer(IDirect3DDevice9) Method (Microsoft.DirectX.Direct3D)

Device.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Device object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DDevice9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DDevice9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DDevice9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DDevice9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DDevice9
Pointer to the IDirect3DDevice9 structure used to update the unmanaged pointer for this Device object.


Device.ValidateDevice() Method (Microsoft.DirectX.Direct3D)

Device.ValidateDevice Method

Reports the device's ability to render the current texture-blending operations and arguments in a single pass.

Definition

Visual Basic | Public Function ValidateDevice() As ValidateDeviceParams
C# | public ValidateDeviceParams ValidateDevice();
C++ public:
ValidateDeviceParams ValidateDevice();
JScript | public function ValidateDevice() : ValidateDeviceParams;

Return Value

Microsoft.DirectX.Direct3D.ValidateDeviceParams
A ValidateDeviceParams object that provides the number of passes and the result code of the validation check.

Remarks

The Device.ValidateDevice method should be used to validate scenarios only when other capabilities are deficient. For example, in a multistage texturing scenario, the Caps.MaxTextureBlendStages and Caps.MaxSimultaneousTextures properties could be queried to determine whether multistage texturing is possible on the device.

Current hardware does not necessarily implement all possible combinations of operations and arguments. To determine whether a particular blending operation can be performed with given arguments, set the desired blending operation and then call the Device.ValidateDevice method.

The Device.ValidateDevice method uses the current render states, textures, and texture-stage states to perform validation at the time of the call. Changes to these factors after the call invalidate the previous result, and the method must be called again before rendering a scene.

For best performance, call Device.ValidateDevice at initialization time; do not use it within a render loop.

Using diffuse iterated values, either as an argument or as an operation (TextureArgument.Diffuse, TextureOperation.BlendDiffuseAlpha), is rarely supported on current hardware. Most hardware can introduce iterated color data only at the last texture operation stage.

In general, specify the texture TextureArgument.TextureColor for each stage as the first argument rather than the second argument.

Many video cards do not support the use of diffuse or scalar values at arbitrary texture stages. Often, these values are available only at the first or last texture-blending stage.

Many cards do not have a blending unit associated with the first texture that is capable of more than replicating alpha to color channels or inverting the input. Therefore, an application might need to use only the second texture stage, if possible. On such hardware, the first unit is presumed to be in its default state, in which the first color argument is set to TextureArgument.TextureColor with the TextureOperation.SelectArg1 operation.

Operations on the output alpha that are more intricate than or substantially different from the color operations are less likely to be supported.

Some hardware does not support simultaneous use of TextureArgument.TFactor and TextureArgument.Diffuse.

Many cards do not support simultaneous use of multiple textures and mipmapped trilinear filtering. If trilinear filtering is requested for a texture involved in multitexture blending operations and validation fails, turn off trilinear filtering and revalidate. In this case, performing multipass rendering might be a better alternative.

Exceptions
ConflictingRenderStateException | Currently set render states cannot be used together.
ConflictingTextureFilterException | Current texture filters cannot be used together.
DeviceLostException | Device has been lost and cannot be reset at this time; therefore, rendering is not possible.
DriverInternalErrorException | An internal driver error occurred. Generally, an application should shut down when it receives this error.
TooManyOperationsException | Application is requesting more texture-filtering operations than the device supports.
UnsupportedAlphaArgumentException | Device does not support a specified texture-blending argument for the alpha channel.
UnsupportedAlphaOperationException | Device does not support a specified texture-blending operation for the alpha channel.
UnsupportedColorArgumentException | Device does not support a specified texture-blending argument for color values.
UnsupportedColorOperationException | Device does not support a specified texture-blending operation for color values.
UnsupportedFactorValueException | Device does not support the specified texture factor value.
UnsupportedTextureFilterException | Device does not support the specified texture filter.
WrongTextureFormatException | Pixel format of the texture surface is not valid.

See Also

  • Tutorial 5: Using Texture Maps
  • Device.TextureState


Device.AvailableTextureMemory Property (Microsoft.DirectX.Direct3D)

Device.AvailableTextureMemory Property

Retrieves an estimate of the amount of available texture memory.

Definition

Visual Basic | Public ReadOnly Property AvailableTextureMemory As Integer
C# | public int AvailableTextureMemory { get; }
C++ public:
property int AvailableTextureMemory {
int get();
}
JScript | public function get AvailableTextureMemory() : int

Property Value

System.Int32
Returns an estimate of the available texture memory.

This property is read-only.

Remarks

The returned value is rounded to the nearest megabyte. This is done to reflect the fact that video memory estimates are never precise, due to alignment and other issues that affect consumption by certain resources. Applications can use the value to make gross estimates of memory availability for use in large-scale resource decisions (such as how many levels of a mipmap to attempt to allocate), but not to make small-scale decisions (such as whether enough memory is left to allocate another resource).


Device.ClipPlanes Property (Microsoft.DirectX.Direct3D)

Device.ClipPlanes Property

Retrieves the clipping planes on the current device.

Definition

Visual Basic | Public ReadOnly Property ClipPlanes As ClipPlanes
C# | public ClipPlanes ClipPlanes { get; }
C++ public:
property ClipPlanes^ ClipPlanes {
ClipPlanes^ get();
}
JScript | public function get ClipPlanes() : ClipPlanes

Property Value

Microsoft.DirectX.Direct3D.ClipPlanes
Clipping planes on the current device.

This property is read-only.

See Also

  • ClipPlane
  • ClipPlanes


Device.ClipStatus Property (Microsoft.DirectX.Direct3D)

Device.ClipStatus Property

Retrieves or sets a ClipStatus object.

Definition

Visual Basic | Public Property ClipStatus As ClipStatus
C# | public ClipStatus ClipStatus { get; set; }
C++ public:
property ClipStatus ClipStatus {
ClipStatus get();
void set(ClipStatus value);
}
JScript public function get ClipStatus() : ClipStatus
public function set ClipStatus(ClipStatus);

Property Value

Microsoft.DirectX.Direct3D.ClipStatus
A ClipStatus object that describes the current clip status.

This property is read/write.

Remarks

Clip status is used during software vertex processing; therefore, this method is not supported on hardware processing devices, whether or not they are pure. For more information about pure devices, see CreateFlags.

When clipping is enabled during vertex processing (by Device.ProcessVertices, Device.DrawPrimitives, or other drawing functions), Microsoft DirectX 9.0 computes a clip code for every vertex. The clip code is a combination of ClipStatusFlags values. When a vertex is outside of a particular clipping plane, the corresponding bit is set in the clip code. Microsoft Direct3D maintains the clip status using ClipStatus, which has ClipUnion and ClipIntersection members. ClipUnion is a bitwise OR of all vertex clip codes and has an initial value of 0; ClipIntersection is a bitwise AND of all vertex clip codes and has an initial value of 0xFFFFFFFF. When RenderStateManager.Clipping is set to false, ClipUnion and ClipIntersection are set to 0. Direct3D updates the clip status during drawing calls. To compute clip status for a particular object, set ClipUnion and ClipIntersection to their initial values and continue drawing.

Clip status is not updated by Device.DrawRectanglePatch and Device.DrawTrianglePatch because there is no software emulation for them.

Exceptions
InvalidCallException One of the arguments is invalid.


Device.CreationParameters Property (Microsoft.DirectX.Direct3D)

Device.CreationParameters Property

Retrieves the creation parameters of the device.

Definition

Visual Basic | Public ReadOnly Property CreationParameters As DeviceCreationParameters
C# | public DeviceCreationParameters CreationParameters { get; }
C++ public:
property DeviceCreationParameters CreationParameters {
DeviceCreationParameters get();
}
JScript | public function get CreationParameters() : DeviceCreationParameters

Property Value

Microsoft.DirectX.Direct3D.DeviceCreationParameters
Returns a DeviceCreationParameters object that describes the device's creation parameters.

This property is read-only.

Remarks

To retrieve the ordinal of the adapter represented by the device, query the DeviceCreationParameters.AdapterOrdinal member of the returned object.


Device.CurrentTexturePalette Property (Microsoft.DirectX.Direct3D)

Device.CurrentTexturePalette Property

Retrieves or sets the current texture palette.

Definition

Visual Basic | Public Property CurrentTexturePalette As Integer
C# | public int CurrentTexturePalette { get; set; }
C++ public:
property int CurrentTexturePalette {
int get();
void set(int value);
}
JScript public function get CurrentTexturePalette() : int
public function set CurrentTexturePalette(int);

Property Value

System.Int32
Current texture palette.

This property is read/write.

Remarks

Microsoft Direct3D for Microsoft DirectX 9.0 supports paletted textures through a set of 256 entry palettes associated with the Device object. A palette is made current by setting the Device.CurrentTexturePalette property. The current palette is used for translating all paletted textures for all active texture stages. Device.SetPaletteEntries updates all 256 of a palette's entries, each of which is a PaletteEntry object formatted with Format.A8R8G8B8. By default, all entries are set to 0xFFFFFFFF.

The Device palettes contain an alpha channel, which can be used when the TextureCaps.SupportsAlphaPalette device capability flag is set, indicating that the device supports alpha from the palette. The palette alpha channel is used when the texture format does not have an alpha channel. If the device does not support alpha from the palette and the texture format does not have an alpha channel, a value of 0xFF is used for alpha.

A maximum of 65,536 (0x0000FFFF) palettes is allowed. Because memory resources associated with the set of palettes are proportional to the maximum palette number that an application references, use contiguous palette numbers starting at zero.


Device.DepthStencilSurface Property (Microsoft.DirectX.Direct3D)

Device.DepthStencilSurface Property

Retrieves or sets the depth stencil surface owned by the Device object.

Definition

Visual Basic | Public Property DepthStencilSurface As Surface
C# | public Surface DepthStencilSurface { get; set; }
C++ public:
property Surface^ DepthStencilSurface {
Surface^ get();
void set(Surface^ value);
}
JScript public function get DepthStencilSurface() : Surface
public function set DepthStencilSurface(Surface);

Property Value

Microsoft.DirectX.Direct3D.Surface
Returns a Surface object that represents the depth stencil surface. If no depth stencil buffer is associated with the device, the return value is null.

Setting this value to null disables the depth stencil operation.

This property is read/write.

Remarks

The following restrictions apply when using this property.

  • The multisample type must be the same for the render target and the depth stencil surface.
  • The formats for the render target and depth stencil surface must be compatible. For more information, see Manager.CheckDepthStencilMatch.
  • The size of the depth stencil surface must be greater than or equal to the size of the render target.

These restrictions are validated only when using the debug runtime when any of the Device drawing methods are called.

Cube textures differ from other surfaces in that they are collections of surfaces. To set a new depth stencil surface with a cube texture, choose an individual face using CubeTexture.GetCubeMapSurface, and pass the resulting surface to this property.

Exceptions
NotFoundException | Occurs if the device does not have a depth stencil buffer associated with it.
InvalidCallException | Occurs if the method call is invalid. For example, a parameter may have an invalid value.


Device.DeviceCaps Property (Microsoft.DirectX.Direct3D)

Device.DeviceCaps Property

Retrieves the capabilities of the rendering device.

Definition

Visual Basic | Public ReadOnly Property DeviceCaps As Caps
C# | public Caps DeviceCaps { get; }
C++ public:
property Caps DeviceCaps {
Caps get();
}
JScript | public function get DeviceCaps() : Caps

Property Value

Microsoft.DirectX.Direct3D.Caps
A Caps object that describes the returned device.

This property is read-only.

Remarks

Device.DeviceCaps retrieves the software vertex pipeline capabilities when the device is used in software vertex processing mode.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.DisplayMode Property (Microsoft.DirectX.Direct3D)

Device.DisplayMode Property

Retrieves the display mode's spatial resolution, color resolution, and refresh frequency.

Definition

Visual Basic | Public ReadOnly Property DisplayMode As DisplayMode
C# | public DisplayMode DisplayMode { get; }
C++ public:
property DisplayMode DisplayMode {
DisplayMode get();
}
JScript | public function get DisplayMode() : DisplayMode

Property Value

Microsoft.DirectX.Direct3D.DisplayMode
A DisplayMode object that contains data about the display mode of the adapter (as opposed to the display mode of the device, which might not be active if the device does not own full-screen mode).

This property is read-only.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.Disposed Property (Microsoft.DirectX.Direct3D)

Device.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Device.Indices Property (Microsoft.DirectX.Direct3D)

Device.Indices Property

Retrieves or sets index data.

Definition

Visual Basic | Public Property Indices As IndexBuffer
C# | public IndexBuffer Indices { get; set; }
C++ public:
property IndexBuffer^ Indices {
IndexBuffer^ get();
void set(IndexBuffer^ value);
}
JScript public function get Indices() : IndexBuffer
public function set Indices(IndexBuffer);

Property Value

Microsoft.DirectX.Direct3D.IndexBuffer
An IndexBuffer object that represents the index data.

This property is read/write.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.IsUsingEventHandlers Property (Microsoft.DirectX.Direct3D)

Device.IsUsingEventHandlers Property

Retrieves or sets a value that indicates whether the device should use event handlers.

Definition

Visual Basic | Public Shared Property IsUsingEventHandlers As Boolean
C# | public static bool IsUsingEventHandlers { get; set; }
C++ public:
static property bool IsUsingEventHandlers {
bool get();
void set(bool value);
}
JScript public static function get IsUsingEventHandlers() : boolean
public function set IsUsingEventHandlers(boolean);

Property Value

System.Boolean
A value of true indicates that event handlers are enabled; false indicates that they are disabled.

This property is read/write.


Device.Lights Property (Microsoft.DirectX.Direct3D)

Device.Lights Property

Retrieves the LightsCollection collection on the current device.

Definition

Visual Basic | Public ReadOnly Property Lights As LightsCollection
C# | public LightsCollection Lights { get; }
C++ public:
property LightsCollection^ Lights {
LightsCollection^ get();
}
JScript | public function get Lights() : LightsCollection

Property Value

Microsoft.DirectX.Direct3D.LightsCollection
A LightsCollection collection object.

This property is read-only.


Device.Material Property (Microsoft.DirectX.Direct3D)

Device.Material Property

Retrieves or sets the current material properties for the device.

Definition

Visual Basic | Public Property Material As Material
C# | public Material Material { get; set; }
C++ public:
property Material Material {
Material get();
void set(Material value);
}
JScript public function get Material() : Material
public function set Material(Material);

Property Value

Microsoft.DirectX.Direct3D.Material
A Material object that represents the current material properties or the material properties to set.

This property is read/write.

Remarks

Exceptions
InvalidCallException Occurs if properties of the Material object are invalid.


Device.NPatchMode Property (Microsoft.DirectX.Direct3D)

Device.NPatchMode Property

Retrieves or sets the N-patch mode segments.

Definition

Visual Basic | Public Property NPatchMode As Single
C# | public float NPatchMode { get; set; }
C++ public:
property float NPatchMode {
float get();
void set(float value);
}
JScript public function get NPatchMode() : float
public function set NPatchMode(float);

Property Value

System.Single
Specifies the number of subdivision segments. If the number is less than 1.0, N-patches are disabled. The default value is 0.0.

This property is read/write.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.NumberOfSwapChains Property (Microsoft.DirectX.Direct3D)

Device.NumberOfSwapChains Property

Retrieves the number of implicit swap chains.

Definition

Visual Basic | Public ReadOnly Property NumberOfSwapChains As Integer
C# | public int NumberOfSwapChains { get; }
C++ public:
property int NumberOfSwapChains {
int get();
}
JScript | public function get NumberOfSwapChains() : int

Property Value

System.Int32
Number of implicit swap chains.

This property is read-only.

Remarks

Implicit swap chains are created by the device during a call to the Device constructor.

An application can create additional swap chains using the SwapChain class.


Device.PixelShader Property (Microsoft.DirectX.Direct3D)

Device.PixelShader Property

Retrieves or sets the current pixel shader.

Definition

Visual Basic | Public Property PixelShader As PixelShader
C# | public PixelShader PixelShader { get; set; }
C++ public:
property PixelShader^ PixelShader {
PixelShader^ get();
void set(PixelShader^ value);
}
JScript public function get PixelShader() : PixelShader
public function set PixelShader(PixelShader);

Property Value

Microsoft.DirectX.Direct3D.PixelShader
A PixelShader object that represents the current pixel shader or a pixel shader object to set.

This property is read/write.

Remarks

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.PresentationParameters Property (Microsoft.DirectX.Direct3D)

Device.PresentationParameters Property

Retrieves presentation parameters for a device.

Definition

Visual Basic | Public ReadOnly Property PresentationParameters As PresentParameters
C# | public PresentParameters PresentationParameters { get; }
C++ public:
property PresentParameters^ PresentationParameters {
PresentParameters^ get();
}
JScript | public function get PresentationParameters() : PresentParameters

Property Value

Microsoft.DirectX.Direct3D.PresentParameters
A PresentParameters object that describes the device's presentation parameters.

This property is read-only.


Device.RasterStatus Property (Microsoft.DirectX.Direct3D)

Device.RasterStatus Property

Retrieves information that describes the raster of the monitor on which the swap chain is presented.

Definition

Visual Basic | Public ReadOnly Property RasterStatus As RasterStatus
C# | public RasterStatus RasterStatus { get; }
C++ public:
property RasterStatus RasterStatus {
RasterStatus get();
}
JScript | public function get RasterStatus() : RasterStatus

Property Value

Microsoft.DirectX.Direct3D.RasterStatus
A RasterStatus object that contains information about the position or other status of the raster on the monitor driven by the current adapter.

This property is read-only.

Remarks

This method does not return device state for a device created using CreateFlags.PureDevice. To use this method, create a device with any of the other values in CreateFlags.

Exceptions
InvalidCallException Occurs if the device does not support reading the current scan line. To determine whether the device supports reading the scan line, check DriverCaps.ReadScanLine.


Device.RenderState Property (Microsoft.DirectX.Direct3D)

Device.RenderState Property

Retrieves a render-state value for a device.

Definition

Visual Basic | Public ReadOnly Property RenderState As RenderStateManager
C# | public RenderStateManager RenderState { get; }
C++ public:
property RenderStateManager^ RenderState {
RenderStateManager^ get();
}
JScript | public function get RenderState() : RenderStateManager

Property Value

Microsoft.DirectX.Direct3D.RenderStateManager
Returns the RenderStateManager object for the device.

This property is read-only.

Remarks

This method returns the last render state that was set for the device, or the default device render state, if not previously set, for a device created using CreateFlags.PureDevice.


Device.SamplerState Property (Microsoft.DirectX.Direct3D)

Device.SamplerState Property

Retrieves a device's sampler states.

Definition

Visual Basic | Public ReadOnly Property SamplerState As SamplerStateManagerCollection
C# | public SamplerStateManagerCollection SamplerState { get; }
C++ public:
property SamplerStateManagerCollection^ SamplerState {
SamplerStateManagerCollection^ get();
}
JScript | public function get SamplerState() : SamplerStateManagerCollection

Property Value

Microsoft.DirectX.Direct3D.SamplerStateManagerCollection
Returns the SamplerStateManagerCollection object for the device.

This property is read-only.

Remarks

This method returns the last sampler state that was set for the device, or the default device sampler state, if not previously set, for a device created using CreateFlags.PureDevice.


Device.ScissorRectangle Property (Microsoft.DirectX.Direct3D)

Device.ScissorRectangle Property

Retrieves or sets the scissor rectangle.

Definition

Visual Basic | Public Property ScissorRectangle As Rectangle
C# | public Rectangle ScissorRectangle { get; set; }
C++ public:
property Rectangle ScissorRectangle {
Rectangle get();
void set(Rectangle value);
}
JScript public function get ScissorRectangle() : Rectangle
public function set ScissorRectangle(Rectangle);

Property Value

System.Drawing.Rectangle
A Rectangle Leave Site object that defines the rendering area within the render target, if scissor testing is enabled.

This property is read/write.

Remarks

The scissor rectangle is used as a rectangular clipping region. For more information about the use of rectangles in Microsoft DirectX, see Rectangle Leave Site.

Exceptions
InvalidCallException Occurs if any properties of the Rectangle Leave Site object are invalid.


Device.SoftwareVertexProcessing Property (Microsoft.DirectX.Direct3D)

Device.SoftwareVertexProcessing Property

Retrieves or sets the vertex processing mode.

Definition

Visual Basic | Public Property SoftwareVertexProcessing As Boolean
C# | public bool SoftwareVertexProcessing { get; set; }
C++ public:
property bool SoftwareVertexProcessing {
bool get();
void set(bool value);
}
JScript public function get SoftwareVertexProcessing() : boolean
public function set SoftwareVertexProcessing(boolean);

Property Value

System.Boolean
Value that is true for software vertex processing; false for hardware vertex processing.

This property is read/write.

Remarks

The following restrictions apply when changing modes.

  • If a device is created with CreateFlags.SoftwareVertexProcessing, vertex processing is done in software and cannot be changed.
  • If a device is created with CreateFlags.HardwareVertexProcessing, vertex processing is done in hardware and cannot be changed.
  • If a device is created with CreateFlags.MixedVertexProcessing, vertex processing is done in hardware by default, and can be switched between software and hardware. An application can create a mixed-mode device to use both software and hardware vertex processing. Use this property to switch between the two vertex processing modes.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Processing Vertex Data


Device.TextureState Property (Microsoft.DirectX.Direct3D)

Device.TextureState Property

Retrieves a state value for an assigned texture.

Definition

Visual Basic | Public ReadOnly Property TextureState As TextureStateManagerCollection
C# | public TextureStateManagerCollection TextureState { get; }
C++ public:
property TextureStateManagerCollection^ TextureState {
TextureStateManagerCollection^ get();
}
JScript | public function get TextureState() : TextureStateManagerCollection

Property Value

Microsoft.DirectX.Direct3D.TextureStateManagerCollection
Returns a TextureStateManagerCollection object that contains the device's texture states. To retrieve the TextureStateManager object that contains the actual texture states for the device, use the TextureStateManagerCollection.TextureState property.

This property is read-only.

Remarks

This method returns the last texture state that was set for the device, or the default device texture state, if not previously set, for a device created using CreateFlags.PureDevice.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.Transform Property (Microsoft.DirectX.Direct3D)

Device.Transform Property

Retrieves a matrix that describes a transformation state.

Definition

Visual Basic | Public ReadOnly Property Transform As Transforms
C# | public Transforms Transform { get; }
C++ public:
property Transforms^ Transform {
Transforms^ get();
}
JScript | public function get Transform() : Transforms

Property Value

Microsoft.DirectX.Direct3D.Transforms
A Transforms object that describes the returned transformation state.

This property is read-only.

Remarks

This method does not return device state for a device created using CreateFlags.PureDevice. To use this method, create a device with any of the other values in CreateFlags.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Device.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DDevice9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DDevice9
C# | public IDirect3DDevice9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DDevice9 UnmanagedComPointer {
IDirect3DDevice9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DDevice9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DDevice9
Unmanaged IDirect3DDevice9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Device.VertexDeclaration Property (Microsoft.DirectX.Direct3D)

Device.VertexDeclaration Property

Retrieves or sets a vertex shader declaration.

Definition

Visual Basic | Public Property VertexDeclaration As VertexDeclaration
C# | public VertexDeclaration VertexDeclaration { get; set; }
C++ public:
property VertexDeclaration^ VertexDeclaration {
VertexDeclaration^ get();
void set(VertexDeclaration^ value);
}
JScript public function get VertexDeclaration() : VertexDeclaration
public function set VertexDeclaration(VertexDeclaration);

Property Value

Microsoft.DirectX.Direct3D.VertexDeclaration
A VertexDeclaration object that contains the vertex shader declaration.

This property is read/write.

Remarks

A vertex shader declaration is made up of an array of vertex elements.


Device.VertexFormat Property (Microsoft.DirectX.Direct3D)

Device.VertexFormat Property

Retrieves or sets the supported flexible vertex formats.

Definition

Visual Basic | Public Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; set; }
C++ public:
property VertexFormats VertexFormat {
VertexFormats get();
void set(VertexFormats value);
}
JScript public function get VertexFormat() : VertexFormats
public function set VertexFormat(VertexFormats);

Property Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object that represents the current flexible vertex format values or the flexible vertex format values to set.

This property is read/write.

Remarks

The fixed vertex function declaration is a set of flexible vertex format (FVF) flags that determine how vertices processed by the fixed function pipeline are used. For more information, see Processing Vertex Data.

Exceptions
InvalidCallException Occurs if the method call is invalid. For example, a parameter might contain an invalid value.


Device.VertexShader Property (Microsoft.DirectX.Direct3D)

Device.VertexShader Property

Retrieves or sets the current vertex shader.

Definition

Visual Basic | Public Property VertexShader As VertexShader
C# | public VertexShader VertexShader { get; set; }
C++ public:
property VertexShader^ VertexShader {
VertexShader^ get();
void set(VertexShader^ value);
}
JScript public function get VertexShader() : VertexShader
public function set VertexShader(VertexShader);

Property Value

Microsoft.DirectX.Direct3D.VertexShader
A VertexShader object that represents the device's current vertex shader or a vertex shader object to set.

This property is read/write.

Remarks

To set a fixed-function vertex shader (after having set a programmable vertex shader), set this property to null to release the programmable shader, and then set the Device.VertexFormat property with the fixed-function vertex format.

Exceptions
InvalidCallException Occurs if the method fails.


Device.Viewport Property (Microsoft.DirectX.Direct3D)

Device.Viewport Property

Retrieves or sets the viewport parameters for the current device.

Definition

Visual Basic | Public Property Viewport As Viewport
C# | public Viewport Viewport { get; set; }
C++ public:
property Viewport Viewport {
Viewport get();
void set(Viewport value);
}
JScript public function get Viewport() : Viewport
public function set Viewport(Viewport);

Property Value

Microsoft.DirectX.Direct3D.Viewport
A Viewport object that represents the returned viewport parameters or specifies the viewport parameters to set.

This property is read/write.

Remarks

Device.Viewport can be used to draw on part of the screen. It should be set before any geometry is drawn so the Viewport will take effect.

To draw multiple views within a scene, repeat setting Device.Viewport and draw a geometry sequence for each view.

Exceptions
InvalidCallException Occurs if Viewport is invalid, or if Viewport describes a region that cannot exist within the render target surface.


Device.DeviceLost Event (Microsoft.DirectX.Direct3D)

Device.DeviceLost Event

Occurs when a device is about to be lost (for example, immediately prior to a reset).

Definition

Visual Basic | Public Event DeviceLost As EventHandler
C# | public event EventHandler DeviceLost;
C++ public:
event EventHandler^ DeviceLost;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Device.DeviceLost event, use the following C# code.

[C#]
device.DeviceLost += new System.EventHandler(this.DeviceLostEventHandler);


Device.DeviceReset Event (Microsoft.DirectX.Direct3D)

Device.DeviceReset Event

Occurs after a device is reset, allowing an application to re-create all Pool.Default resources.

Definition

Visual Basic | Public Event DeviceReset As EventHandler
C# | public event EventHandler DeviceReset;
C++ public:
event EventHandler^ DeviceReset;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Device.DeviceReset event, use the following C# code.

[C#]
device.DeviceReset += new System.EventHandler(this.DeviceResetEventHandler);


Device.DeviceResizing Event (Microsoft.DirectX.Direct3D)

Device.DeviceResizing Event

Occurs when a device is resizing, allowing the application to cancel the default handling of the resize.

Definition

Visual Basic | Public Event DeviceResizing As CancelEventHandler
C# | public event CancelEventHandler DeviceResizing;
C++ public:
event CancelEventHandler^ DeviceResizing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Device.DeviceResizing event, use the following C# code.

[C#]
device.DeviceResizing += new System.CancelEventHandler(this.DeviceResizingEventHandler);

See Also

  • System.CancelEventHandler Leave Site


Device.Disposing Event (Microsoft.DirectX.Direct3D)

Device.Disposing Event

Occurs when the Dispose method is called or when the Device object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Device.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Device object indicates whether that object has been disposed.


DeviceInformation Class (Microsoft.DirectX.Direct3D)

DeviceInformation Class

Contains functionality for retrieving the driver level for a device.

Definition

Visual Basic NotInheritable MustInherit Public Class DeviceInformation
Inherits Object
C# | public abstract sealed class DeviceInformation : Object
C++ | public ref class DeviceInformation abstract sealed : Object
JScript | public final abstract class DeviceInformation extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) GetDriverLevel | Retrieves the driver level for a device.

Inheritance Hierarchy

Object Leave Site
DeviceInformation

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceInformation.GetDriverLevel(Device) Method (Microsoft.DirectX.Direct3D)

DeviceInformation.GetDriverLevel Method

Retrieves the driver level for a device.

Definition

Visual Basic Public Shared Function GetDriverLevel( _
ByVal device As Device _
) As Integer
C# public static int GetDriverLevel(
Device device
);
C++ public:
static int GetDriverLevel(
Device^ device
);
JScript public static function GetDriverLevel(
device : Device
) : int;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that is used to retrieve the driver level.

Return Value

System.Int32
An Int32 Leave Site value that indicates the driver level of the device.


DeviceLostException Class (Microsoft.DirectX.Direct3D)

DeviceLostException Class

The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.

Definition

Visual Basic Public Class DeviceLostException
Inherits GraphicsException
C# | public class DeviceLostException : GraphicsException
C++ | public ref class DeviceLostException : GraphicsException
JScript | public class DeviceLostException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceLostException | Initializes a new instance of the DeviceLostException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DeviceLostException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceLostException.DeviceLostException Constructor ()

Initializes a new instance of the DeviceLostException class.

Overload List

public DeviceLostException();
protected DeviceLostException(SerializationInfo, StreamingContext);
public DeviceLostException(string);
public DeviceLostException(string, Exception);


DeviceLostException.DeviceLostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

DeviceLostException.DeviceLostException Constructor

Initializes a new instance of the DeviceLostException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceLostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DeviceLostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DeviceLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


DeviceLostException.DeviceLostException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

DeviceLostException.DeviceLostException Constructor

Initializes a new instance of the DeviceLostException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceLostException(
string message,
Exception inner
);
C++ public:
DeviceLostException(
String^ message,
Exception^ inner
);
JScript public function DeviceLostException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


DeviceLostException.DeviceLostException(String) Constructor (Microsoft.DirectX.Direct3D)

DeviceLostException.DeviceLostException Constructor

Initializes a new instance of the DeviceLostException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DeviceLostException(
string message
);
C++ public:
DeviceLostException(
String^ message
);
JScript public function DeviceLostException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


DeviceLostException.DeviceLostException() Constructor (Microsoft.DirectX.Direct3D)

DeviceLostException.DeviceLostException Constructor

Initializes a new instance of the DeviceLostException class.

Definition

Visual Basic | Public Sub New()
C# | public DeviceLostException();
C++ public:
DeviceLostException();
JScript | public function DeviceLostException();


DeviceNotResetException Class (Microsoft.DirectX.Direct3D)

DeviceNotResetException Class

The device has been lost but can be reset at this time.

Definition

Visual Basic Public Class DeviceNotResetException
Inherits GraphicsException
C# | public class DeviceNotResetException : GraphicsException
C++ | public ref class DeviceNotResetException : GraphicsException
JScript | public class DeviceNotResetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceNotResetException | Initializes a new instance of the DeviceNotResetException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DeviceNotResetException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceNotResetException.DeviceNotResetException Constructor ()

Initializes a new instance of the DeviceNotResetException class.

Overload List

public DeviceNotResetException();
protected DeviceNotResetException(SerializationInfo, StreamingContext);
public DeviceNotResetException(string);
public DeviceNotResetException(string, Exception);


DeviceNotResetException.DeviceNotResetException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

DeviceNotResetException.DeviceNotResetException Constructor

Initializes a new instance of the DeviceNotResetException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceNotResetException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DeviceNotResetException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DeviceNotResetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


DeviceNotResetException.DeviceNotResetException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

DeviceNotResetException.DeviceNotResetException Constructor

Initializes a new instance of the DeviceNotResetException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceNotResetException(
string message,
Exception inner
);
C++ public:
DeviceNotResetException(
String^ message,
Exception^ inner
);
JScript public function DeviceNotResetException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


DeviceNotResetException.DeviceNotResetException(String) Constructor (Microsoft.DirectX.Direct3D)

DeviceNotResetException.DeviceNotResetException Constructor

Initializes a new instance of the DeviceNotResetException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DeviceNotResetException(
string message
);
C++ public:
DeviceNotResetException(
String^ message
);
JScript public function DeviceNotResetException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


DeviceNotResetException.DeviceNotResetException() Constructor (Microsoft.DirectX.Direct3D)

DeviceNotResetException.DeviceNotResetException Constructor

Initializes a new instance of the DeviceNotResetException class.

Definition

Visual Basic | Public Sub New()
C# | public DeviceNotResetException();
C++ public:
DeviceNotResetException();
JScript | public function DeviceNotResetException();


Direct3DXException Class (Microsoft.DirectX.Direct3D)

Direct3DXException Class

Base exception class for D3DX. Derives from DirectXException.

Definition

Visual Basic Public Class Direct3DXException
Inherits DirectXException
C# | public class Direct3DXException : DirectXException
C++ | public ref class Direct3DXException : DirectXException
JScript | public class Direct3DXException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
Direct3DXException | Initializes a new instance of the Direct3DXException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
CannotAttributeSortException
CannotModifyIndexBufferException
DuplicateNamedFragmentException
InvalidDataException
InvalidMeshException
LoadedMeshHasNoDataException
SkinningNotSupportedException
TooManyInfluencesException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Direct3DXException.Direct3DXException Constructor ()

Initializes a new instance of the Direct3DXException class.

Overload List

public Direct3DXException();
protected Direct3DXException(SerializationInfo, StreamingContext);
public Direct3DXException(string);
public Direct3DXException(string, Exception);


Direct3DXException.Direct3DXException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

Direct3DXException.Direct3DXException Constructor

Initializes a new instance of the Direct3DXException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected Direct3DXException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
Direct3DXException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function Direct3DXException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


Direct3DXException.Direct3DXException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

Direct3DXException.Direct3DXException Constructor

Initializes a new instance of the Direct3DXException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public Direct3DXException(
string message,
Exception inner
);
C++ public:
Direct3DXException(
String^ message,
Exception^ inner
);
JScript public function Direct3DXException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


Direct3DXException.Direct3DXException(String) Constructor (Microsoft.DirectX.Direct3D)

Direct3DXException.Direct3DXException Constructor

Initializes a new instance of the Direct3DXException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public Direct3DXException(
string message
);
C++ public:
Direct3DXException(
String^ message
);
JScript public function Direct3DXException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


Direct3DXException.Direct3DXException() Constructor (Microsoft.DirectX.Direct3D)

Direct3DXException.Direct3DXException Constructor

Initializes a new instance of the Direct3DXException class.

Definition

Visual Basic | Public Sub New()
C# | public Direct3DXException();
C++ public:
Direct3DXException();
JScript | public function Direct3DXException();


Direct3DXException.GetExceptionFromResultInternal(Int32) Method (Microsoft.DirectX.Direct3D)

Direct3DXException.GetExceptionFromResultInternal Method

Retrieves an Exception Leave Site object that represents the result code passed in.

Definition

Visual Basic Public Shadows Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public new static Exception GetExceptionFromResultInternal(
int resultCode
);
C++ public:
static Exception^ GetExceptionFromResultInternal(
int resultCode
);
JScript public hide static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32
Integer that represents the result code of the exception.

Return Value

System.Exception
An Exception Leave Site object that represents the error that occurred.

Applies To

CannotAttributeSortException, CannotModifyIndexBufferException, DuplicateNamedFragmentException, InvalidDataException, InvalidMeshException, LoadedMeshHasNoDataException, SkinningNotSupportedException, TooManyInfluencesException


DisplayModeCollection Class (Microsoft.DirectX.Direct3D)

DisplayModeCollection Class

Manipulates a collection of DisplayMode structures.

Definition

Visual Basic NotInheritable Public Class DisplayModeCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class DisplayModeCollection : Object, IEnumerable, IEnumerator
C++ | public ref class DisplayModeCollection sealed : Object, IEnumerable, IEnumerator
JScript | public final class DisplayModeCollection extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetEnumerator | Returns an enumerator that can iterate through the DisplayModeCollection.
GetHashCode | Returns the hash code for the current instance.
MoveNext | Advances the enumerator to the next DisplayMode.
Reset | Resets the current enumerator to point to the head of the queue.

Properties

Property | Description
Count | Retrieves the number of DisplayMode structures in DisplayModeCollection.
Current | Retrieves the current DisplayMode object in the queue.
Item | Retrieves the DisplayMode structure with the specified Format.

Inheritance Hierarchy

Object Leave Site
DisplayModeCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisplayModeCollection.Equals(Object) Method (Microsoft.DirectX.Direct3D)

DisplayModeCollection.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


DisplayModeCollection.GetEnumerator() Method (Microsoft.DirectX.Direct3D)

DisplayModeCollection.GetEnumerator Method

Returns an enumerator that can iterate through the DisplayModeCollection.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator
Enumerator that can iterate through the DisplayModeCollection.


DisplayModeCollection.GetHashCode() Method (Microsoft.DirectX.Direct3D)

DisplayModeCollection.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


DisplayModeCollection.MoveNext() Method (Microsoft.DirectX.Direct3D)

DisplayModeCollection.MoveNext Method

Advances the enumerator to the next DisplayMode.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean
Value that is true if the move to the next item was successful, or false if it was not.


DisplayModeCollection.Reset() Method (Microsoft.DirectX.Direct3D)

DisplayModeCollection.Reset Method

Resets the current enumerator to point to the head of the queue.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the queue.

After Reset Leave Site is called, the cursor is undefined. Call MoveNext Leave Site initially to point to the first item in the list.


DisplayModeCollection.Count Property (Microsoft.DirectX.Direct3D)

DisplayModeCollection.Count Property

Retrieves the number of DisplayMode structures in DisplayModeCollection.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32
Number of DisplayMode structures in DisplayModeCollection.

This property is read-only.


DisplayModeCollection.Current Property (Microsoft.DirectX.Direct3D)

DisplayModeCollection.Current Property

Retrieves the current DisplayMode object in the queue.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object
Current DisplayMode object in the queue as an Object Leave Site.

This property is read-only.


DisplayModeCollection.Item Property (Microsoft.DirectX.Direct3D)

DisplayModeCollection.Item Property

Retrieves the DisplayMode structure with the specified Format.

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal f As Format _
) As DisplayModeCollection
C# public DisplayModeCollection this[
Format f
] { get; }
C++ public:
property DisplayModeCollection^ default [Format] {
DisplayModeCollection^ get(Format f);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

f Microsoft.DirectX.Direct3D.Format
A Format flag that indicates the format of the DisplayMode to retrieve.

Property Value

Microsoft.DirectX.Direct3D.DisplayModeCollection

This property is read-only.


DriverInternalErrorException Class (Microsoft.DirectX.Direct3D)

DriverInternalErrorException Class

Internal driver error. Applications should generally shut down when receiving this error.

Definition

Visual Basic Public Class DriverInternalErrorException
Inherits GraphicsException
C# | public class DriverInternalErrorException : GraphicsException
C++ | public ref class DriverInternalErrorException : GraphicsException
JScript | public class DriverInternalErrorException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DriverInternalErrorException | Initializes a new instance of the DriverInternalErrorException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DriverInternalErrorException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DriverInternalErrorException.DriverInternalErrorException Constructor ()

Initializes a new instance of the DriverInternalErrorException class.

Overload List

public DriverInternalErrorException();
protected DriverInternalErrorException(SerializationInfo, StreamingContext);
public DriverInternalErrorException(string);
public DriverInternalErrorException(string, Exception);


DriverInternalErrorException.DriverInternalErrorException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:

Initializes a new instance of the DriverInternalErrorException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DriverInternalErrorException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DriverInternalErrorException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DriverInternalErrorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


DriverInternalErrorException.DriverInternalErrorException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:

Initializes a new instance of the DriverInternalErrorException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DriverInternalErrorException(
string message,
Exception inner
);
C++ public:
DriverInternalErrorException(
String^ message,
Exception^ inner
);
JScript public function DriverInternalErrorException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


DriverInternalErrorException.DriverInternalErrorException(String) Constructor (Microsoft.DirectX.Direct3D)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:

Initializes a new instance of the DriverInternalErrorException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DriverInternalErrorException(
string message
);
C++ public:
DriverInternalErrorException(
String^ message
);
JScript public function DriverInternalErrorException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


DriverInternalErrorException.DriverInternalErrorException() Constructor (Microsoft.DirectX.Direct3D)

DriverInternalErrorException.DriverInternalErrorException Constructor

 Language:

Initializes a new instance of the DriverInternalErrorException class.

Definition

Visual Basic | Public Sub New()
C# | public DriverInternalErrorException();
C++ public:
DriverInternalErrorException();
JScript | public function DriverInternalErrorException();


DriverInvalidCallException Class (Microsoft.DirectX.Direct3D)

DriverInvalidCallException Class

The driver reports that the current method call is invalid.

Definition

Visual Basic Public Class DriverInvalidCallException
Inherits GraphicsException
C# | public class DriverInvalidCallException : GraphicsException
C++ | public ref class DriverInvalidCallException : GraphicsException
JScript | public class DriverInvalidCallException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DriverInvalidCallException | Initializes a new instance of the DriverInvalidCallException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DriverInvalidCallException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DriverInvalidCallException.DriverInvalidCallException Constructor ()

Initializes a new instance of the DriverInvalidCallException class.

Overload List

public DriverInvalidCallException();
protected DriverInvalidCallException(SerializationInfo, StreamingContext);
public DriverInvalidCallException(string);
public DriverInvalidCallException(string, Exception);


DriverInvalidCallException.DriverInvalidCallException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:

Initializes a new instance of the DriverInvalidCallException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DriverInvalidCallException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DriverInvalidCallException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DriverInvalidCallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


DriverInvalidCallException.DriverInvalidCallException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:

Initializes a new instance of the DriverInvalidCallException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DriverInvalidCallException(
string message,
Exception inner
);
C++ public:
DriverInvalidCallException(
String^ message,
Exception^ inner
);
JScript public function DriverInvalidCallException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


DriverInvalidCallException.DriverInvalidCallException(String) Constructor (Microsoft.DirectX.Direct3D)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:

Initializes a new instance of the DriverInvalidCallException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DriverInvalidCallException(
string message
);
C++ public:
DriverInvalidCallException(
String^ message
);
JScript public function DriverInvalidCallException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


DriverInvalidCallException.DriverInvalidCallException() Constructor (Microsoft.DirectX.Direct3D)

DriverInvalidCallException.DriverInvalidCallException Constructor

 Language:

Initializes a new instance of the DriverInvalidCallException class.

Definition

Visual Basic | Public Sub New()
C# | public DriverInvalidCallException();
C++ public:
DriverInvalidCallException();
JScript | public function DriverInvalidCallException();


DuplicateNamedFragmentException Class (Microsoft.DirectX.Direct3D)

DuplicateNamedFragmentException Class

There is a duplicate named fragment.

Definition

Visual Basic Public Class DuplicateNamedFragmentException
Inherits Direct3DXException
C# | public class DuplicateNamedFragmentException : Direct3DXException
C++ | public ref class DuplicateNamedFragmentException : Direct3DXException
JScript | public class DuplicateNamedFragmentException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DuplicateNamedFragmentException | Initializes a new instance of the DuplicateNamedFragmentException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
DuplicateNamedFragmentException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor ()

Initializes a new instance of the DuplicateNamedFragmentException class.

Overload List

public DuplicateNamedFragmentException();
protected DuplicateNamedFragmentException(SerializationInfo, StreamingContext);
public DuplicateNamedFragmentException(string);
public DuplicateNamedFragmentException(string, Exception);


DuplicateNamedFragmentException.DuplicateNamedFragmentException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:

Initializes a new instance of the DuplicateNamedFragmentException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DuplicateNamedFragmentException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DuplicateNamedFragmentException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DuplicateNamedFragmentException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


DuplicateNamedFragmentException.DuplicateNamedFragmentException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:

Initializes a new instance of the DuplicateNamedFragmentException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DuplicateNamedFragmentException(
string message,
Exception inner
);
C++ public:
DuplicateNamedFragmentException(
String^ message,
Exception^ inner
);
JScript public function DuplicateNamedFragmentException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


DuplicateNamedFragmentException.DuplicateNamedFragmentException(String) Constructor (Microsoft.DirectX.Direct3D)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:

Initializes a new instance of the DuplicateNamedFragmentException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DuplicateNamedFragmentException(
string message
);
C++ public:
DuplicateNamedFragmentException(
String^ message
);
JScript public function DuplicateNamedFragmentException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


DuplicateNamedFragmentException.DuplicateNamedFragmentException() Constructor (Microsoft.DirectX.Direct3D)

DuplicateNamedFragmentException.DuplicateNamedFragmentException Constructor

 Language:

Initializes a new instance of the DuplicateNamedFragmentException class.

Definition

Visual Basic | Public Sub New()
C# | public DuplicateNamedFragmentException();
C++ public:
DuplicateNamedFragmentException();
JScript | public function DuplicateNamedFragmentException();


Effect Class (Microsoft.DirectX.Direct3D)

Effect Class

How Do I...?
  • Using an Effect

Used to set and query effects and choose techniques.

Definition

Visual Basic NotInheritable Public Class Effect
Inherits BaseEffect
C# | public sealed class Effect : BaseEffect
C++ | public ref class Effect sealed : BaseEffect
JScript | public final class Effect extends BaseEffect

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Effect object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally just before a device is reset.
Reset | Occurs after the Effect.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
ApplyParameterBlock | Assigns a state value to each effect parameter in a parameter block.
Begin | Begins the application of an effect technique.
BeginParameterBlock | Captures parameter effect state changes.
BeginPass | Applies the state settings for the specified pass of a technique.
Clone | Creates a clone of an effect.
CommitChanges | Propagates the state change that occurs inside of an active pass to the device before rendering.
DeleteParameterBlock | Deletes an effect parameter block.
Disassemble | Disassembles an effect.
Dispose | Immediately releases the unmanaged resources used by the Effect object.
Effect | Initializes a new instance of the Effect class.
End | Ends the application of the current effect technique.
EndParameterBlock | Stops the capturing of effect parameter state changes.
EndPass | Signals the end of an effect pass.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the BaseEffect object to free resources before it is destroyed by the garbage collector. Inherited from BaseEffect.
FindNextValidTechnique | Searches for the next valid technique, starting at the technique after the one specified.
static (Shared in Visual Basic) FromFile | Creates an effect from an ASCII or binary effect description.
static (Shared in Visual Basic) FromStream | Creates an effect from an ASCII or binary effect description.
static (Shared in Visual Basic) FromString | Creates an effect from an ASCII or binary effect description in a string.
GetAnnotation | Retrieves an annotation. Inherited from BaseEffect.
GetFunction | Retrieves a function. Inherited from BaseEffect.
GetFunctionDescription | Retrieves a function description. Inherited from BaseEffect.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetParameter | Retrieves a top-level parameter or a structure member parameter. Inherited from BaseEffect.
GetParameterBySemantic | Retrieves the handle of a top-level parameter or structure member parameter by looking up its semantic. Inherited from BaseEffect.
GetParameterDescription | Retrieves a parameter or annotation description. Inherited from BaseEffect.
GetParameterElement | Retrieves the EffectHandle of an array element parameter. Inherited from BaseEffect.
GetPass | Retrieves the EffectHandle of a pass. Inherited from BaseEffect.
GetPassDescription | Retrieves a pass description. Inherited from BaseEffect.
GetTechnique | Retrieves the EffectHandle of a technique. Inherited from BaseEffect.
GetTechniqueDescription | Retrieves a technique description. Inherited from BaseEffect.
GetValue | Retrieves the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures. Inherited from BaseEffect.
GetValueBoolean | Retrieves a Boolean value. Inherited from BaseEffect.
GetValueBooleanArray | Retrieves an array of Boolean values. Inherited from BaseEffect.
GetValueColor | Retrieves a ColorValue structure. Inherited from BaseEffect.
GetValueColorArray | Retrieves an array of ColorValue structures. Inherited from BaseEffect.
GetValueFloat | Retrieves a floating-point value. Inherited from BaseEffect.
GetValueFloatArray | Retrieves an array of floating-point values. Inherited from BaseEffect.
GetValueInteger | Retrieves an integer. Inherited from BaseEffect.
GetValueIntegerArray | Retrieves an array of integers. Inherited from BaseEffect.
GetValueMatrix | Retrieves a nontransposed matrix. Inherited from BaseEffect.
GetValueMatrixArray | Retrieves an array of nontransposed matrices. Inherited from BaseEffect.
GetValueMatrixTranspose | Retrieves a transposed matrix. Inherited from BaseEffect.
GetValueMatrixTransposeArray | Retrieves an array of transposed matrices. Inherited from BaseEffect.
GetValuePixelShader | Retrieves a pixel shader. Inherited from BaseEffect.
GetValueString | Retrieves a string. Inherited from BaseEffect.
GetValueTexture | Retrieves a texture. Inherited from BaseEffect.
GetValueVector | Retrieves a vector. Inherited from BaseEffect.
GetValueVectorArray | Retrieves an array of vectors. Inherited from BaseEffect.
GetValueVertexShader | Retrieves a vertex shader. Inherited from BaseEffect.
IsParameterUsed | Determines whether a parameter is used by a technique.
IsTechniqueValid | Validates a technique.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseEffect.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseEffect.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Effect.Disposing event when called from within a derived class.
raise_Lost | Raises an Effect.Lost event when called from within a derived class.
raise_Reset | Raises an Effect.Reset event when called from within a derived class.
SetArrayRange | Sets the range of an array to pass to the device.
SetRawValue | Sets a contiguous range of shader constants with a memory copy.
SetValue | Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures. Inherited from BaseEffect.
SetValueTranspose | Sets a transposed matrix. Inherited from BaseEffect.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseEffect object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseEffect.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Effect object. This method supports the Framework infrastructure and is not intended to be used directly in your code.
ValidateTechnique | Validates a technique.

Properties

Property | Description
Description | Retrieves an effect description. Inherited from BaseEffect.
Device | Retrieves the device associated with an effect.
Disposed | Gets a value that indicates whether the object is disposed.
Pool | Retrieves an effect pool object that represents the pool of shared parameters.
StateManager | Retrieves or sets the EffectStateManager object for this effect.
Technique | Retreives and sets the active technique.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer. Inherited from BaseEffect.
UnmanagedComPointer | Returns the unmanaged COM ID3DXEffect interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseEffect
Effect

Remarks

An effect object can contain multiple techniques to render the same effect.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Effect.ApplyParameterBlock(EffectHandle) Method (Microsoft.DirectX.Direct3D)

Effect.ApplyParameterBlock Method

Assigns a state value to each effect parameter in a parameter block.

Definition

Visual Basic Public Sub ApplyParameterBlock( _
ByVal parameterBlock As EffectHandle _
)
C# public void ApplyParameterBlock(
EffectHandle parameterBlock
);
C++ public:
void ApplyParameterBlock(
EffectHandle^ parameterBlock
);
JScript public function ApplyParameterBlock(
parameterBlock : EffectHandle
);

Parameters

parameterBlock Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that is returned by Effect.EndParameterBlock.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Effect.Begin(FX) Method (Microsoft.DirectX.Direct3D)

Effect.Begin Method

How Do I...?
  • Using an Effect

Begins the application of an effect technique.

Definition

Visual Basic Public Function Begin( _
ByVal flags As FX _
) As Integer
C# public int Begin(
FX flags
);
C++ public:
int Begin(
FX flags
);
JScript public function Begin(
flags : FX
) : int;

Parameters

flags Microsoft.DirectX.Direct3D.FX
One or more FX enumerated values that determine whether state modified by an effect will be saved and restored. The default value, 0, specifies that Effect.Begin and Effect.End will save and restore all state modified by the effect (including pixel and vertex shader constants). DoNotSaveShaderState indicates that shader device state will not be saved or restored; DoNotSaveState indicates that device state will not be saved or restored.

Return Value

System.Int32
An integer value that indicates the number of passes needed to render the current effect technique.

Remarks

This method returns the number of passes needed to render the current effect technique. The application must incrementally call Effect.BeginPass for each pass before drawing the geometry to which the effect needs to be applied, followed by a call to Effect.EndPass. After all passes are rendered, Effect.End must be called.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}


Effect.BeginParameterBlock() Method (Microsoft.DirectX.Direct3D)

Effect.BeginParameterBlock Method

Captures parameter effect state changes.

Definition

Visual Basic | Public Sub BeginParameterBlock()
C# | public void BeginParameterBlock();
C++ public:
void BeginParameterBlock();
JScript | public function BeginParameterBlock();

Remarks

This method captures effect parameter state changes until Effect.EndParameterBlock is called. Effect parameters include any state changes outside of a pass.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Effect.BeginPass(Int32) Method (Microsoft.DirectX.Direct3D)

Effect.BeginPass Method

How Do I...?
  • Using an Effect

Applies the state settings for the specified pass of a technique.

Definition

Visual Basic Public Sub BeginPass( _
ByVal passNumber As Integer _
)
C# public void BeginPass(
int passNumber
);
C++ public:
void BeginPass(
int passNumber
);
JScript public function BeginPass(
passNumber : int
);

Parameters

passNumber System.Int32
An integer that identifies the pass to apply. This value is returned by Effect.Begin, which must be called before rendering an effect.

Remarks

Before entering the rendering loop for the effect, Effect.Begin must be called to obtain the number of effect passes.

After calling Effect.BeginPass, the application must draw the geometry to the device to which the effect is set and then call Effect.EndPass.

After all passes are rendered, Effect.End must be called.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.End

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.Clone(Device) Method (Microsoft.DirectX.Direct3D)

Effect.Clone Method

Creates a clone of an effect.

Definition

Visual Basic Public Function Clone( _
ByVal dev As Device _
) As Effect
C# public Effect Clone(
Device dev
);
C++ public:
Effect^ Clone(
Device^ dev
);
JScript public function Clone(
dev : Device
) : Effect;

Parameters

dev Microsoft.DirectX.Direct3D.Device
The Device associated with the effect.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect object that contains the cloned effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Effect.CommitChanges() Method (Microsoft.DirectX.Direct3D)

Effect.CommitChanges Method

How Do I...?
  • Using an Effect

Propagates the state change that occurs inside of an active pass to the device before rendering.

Definition

Visual Basic | Public Sub CommitChanges()
C# | public void CommitChanges();
C++ public:
void CommitChanges();
JScript | public function CommitChanges();

Remarks

If the application changes any effect state using the Effect class members that modify state, such as Effect.StateManager, inside of an Effect.BeginPass/Effect.EndPass matching pair, the application must call Effect.CommitChanges before any of the various Device.DrawPrimitives methods are called to propagate state changes to the device before rendering. If no state changes occur within an Effect.BeginPass/Effect.EndPass matching pair, it is not necessary to call Effect.CommitChanges.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.DeleteParameterBlock(EffectHandle) Method (Microsoft.DirectX.Direct3D)

Effect.DeleteParameterBlock Method

Deletes an effect parameter block.

Definition

Visual Basic Public Sub DeleteParameterBlock( _
ByVal parameterBlock As EffectHandle _
)
C# public void DeleteParameterBlock(
EffectHandle parameterBlock
);
C++ public:
void DeleteParameterBlock(
EffectHandle^ parameterBlock
);
JScript public function DeleteParameterBlock(
parameterBlock : EffectHandle
);

Parameters

parameterBlock Microsoft.DirectX.Direct3D.EffectHandle
Handle to the parameter block to delete. This is the handle returned by Effect.EndParameterBlock.

Remarks

Parameter blocks are blocks of effect state changes. Use a parameter block to record state changes so that they can be applied later on with a single API call. When no longer needed, delete the parameter block to reduce memory usage.

See Also

  • EndParameterBlock

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.Disassemble Method ()

Disassembles an effect.

Overload List

public string Disassemble(bool);
public static string Disassemble(Effect, bool);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.Disassemble(Boolean) Method (Microsoft.DirectX.Direct3D)

Effect.Disassemble Method

Disassembles an effect.

Definition

Visual Basic Public Function Disassemble( _
ByVal enableColorCode As Boolean _
) As String
C# public string Disassemble(
bool enableColorCode
);
C++ public:
String^ Disassemble(
bool enableColorCode
);
JScript public function Disassemble(
enableColorCode : boolean
) : String;

Parameters

enableColorCode System.Boolean
Set to true to enable color coding to make the disassembly easier to read. Set to false for no color coding.

Return Value

System.String
A string that contains the disassembled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.Disassemble(Effect,Boolean) Method (Microsoft.DirectX.Direct3D)

Effect.Disassemble Method

Disassembles an effect.

Definition

Visual Basic Public Shared Function Disassemble( _
ByVal effect As Effect, _
ByVal enableColorCode As Boolean _
) As String
C# public static string Disassemble(
Effect effect,
bool enableColorCode
);
C++ public:
static String^ Disassemble(
Effect^ effect,
bool enableColorCode
);
JScript public static function Disassemble(
effect : Effect,
enableColorCode : boolean
) : String;

Parameters

effect Microsoft.DirectX.Direct3D.Effect
An Effect object that contains the effect to disassemble.
enableColorCode System.Boolean
Set to true to enable color coding to make the disassembly easier to read. Set to false for no color coding.

Return Value

System.String
A string that contains the disassembled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.Dispose() Method (Microsoft.DirectX.Direct3D)

Effect.Dispose Method

Immediately releases the unmanaged resources used by the Effect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Effect();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Effect.Disposed
  • Microsoft.DirectX.Direct3D.Effect.Disposing


Effect.Effect Constructor ()

Initializes a new instance of the Effect class.

Overload List

public Effect(ID3DXEffect);
public Effect(ID3DXEffect, Device);
public Effect(IntPtr);


Effect.Effect(ID3DXEffect) Constructor (Microsoft.DirectX.Direct3D)

Effect.Effect Constructor

Initializes a new instance of the Effect class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As ID3DXEffect _
)
C# public Effect(
ID3DXEffect pInterop
);
C++ public:
Effect(
ID3DXEffect pInterop
);
JScript public function Effect(
pInterop : ID3DXEffect
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffect
Unmanaged Component Object Model (COM) ID3DXEffect interface pointer.


Effect.Effect(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Effect.Effect Constructor

Initializes a new instance of the Effect class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Effect(
IntPtr unmanagedObject
);
C++ public:
Effect(
IntPtr unmanagedObject
);
JScript public function Effect(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXEffect interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Effect.Effect(ID3DXEffect,Device) Constructor (Microsoft.DirectX.Direct3D)

Effect.Effect Constructor

Initializes a new instance of the Effect class.

Definition

Visual Basic Public Sub New( _
ByVal pData As ID3DXEffect, _
ByVal device As Device _
)
C# public Effect(
ID3DXEffect pData,
Device device
);
C++ public:
Effect(
ID3DXEffect pData,
Device^ device
);
JScript public function Effect(
pData : ID3DXEffect,
device : Device
);

Parameters

pData Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffect
Unmanaged Component Object Model (COM) ID3DXEffect interface pointer.
device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the Effect object.


Effect.End() Method (Microsoft.DirectX.Direct3D)

Effect.End Method

How Do I...?
  • Using an Effect

Ends the application of the current effect technique.

Definition

Visual Basic | Public Sub End()
C# | public void End();
C++ public:
void End();
JScript | public function End();

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.Begin
  • Effect.BeginPass


Effect.EndParameterBlock() Method (Microsoft.DirectX.Direct3D)

Effect.EndParameterBlock Method

Stops the capturing of effect parameter state changes.

Definition

Visual Basic | Public Function EndParameterBlock() As EffectHandle
C# | public EffectHandle EndParameterBlock();
C++ public:
EffectHandle^ EndParameterBlock();
JScript | public function EndParameterBlock() : EffectHandle;

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle for the parameter state block.

Remarks

To start capturing effect parameter state changes, call Effect.BeginParameterBlock. All effect parameters that change state (before Effect.EndParameterBlock is called) are saved in an effect parameter state block, and then Effect.ApplyParameterBlock is used to apply this block of state changes to effect parameters. Effect parameters include any state changes outside of a pass.

See Also

  • DeleteParameterBlock


Effect.EndPass() Method (Microsoft.DirectX.Direct3D)

Effect.EndPass Method

How Do I...?
  • Using an Effect

Signals the end of an effect pass.

Definition

Visual Basic | Public Sub EndPass()
C# | public void EndPass();
C++ public:
void EndPass();
JScript | public function EndPass();

Remarks

After calling Effect.BeginPass, the application must draw the geometry to the device to which the effect is set and then call Effect.EndPass.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.BeginPass
  • Effect.Begin

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Effect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Effect.FindNextValidTechnique(EffectHandle) Method (Microsoft.DirectX.Direct3D)

Effect.FindNextValidTechnique Method

Searches for the next valid technique, starting at the technique after the one specified.

Definition

Visual Basic Public Function FindNextValidTechnique( _
ByVal technique As EffectHandle _
) As EffectHandle
C# public EffectHandle FindNextValidTechnique(
EffectHandle technique
);
C++ public:
EffectHandle^ FindNextValidTechnique(
EffectHandle^ technique
);
JScript public function FindNextValidTechnique(
technique : EffectHandle
) : EffectHandle;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
Unique identifier of a technique. For more information, see EffectHandle. Specify null for this parameter to find the first valid technique.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that identifies the next technique, or null if the current technique is the last.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Effect.ValidateTechnique
  • TechniqueDescription


Effect.FromFile Method ()

How Do I...?
  • Using an Effect

Creates an effect from an ASCII or binary effect description.

Overload List

public static Effect FromFile(Device, string, Include, string, ShaderFlags, EffectPool);
public static Effect FromFile(Device, string, Include, string, ShaderFlags, EffectPool, out string);
public static Effect FromFile(Device, string, Macro[], Include, string, ShaderFlags, EffectPool, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.FromStream
  • Effect.FromString


Effect.FromFile(Device,String,Include,String,ShaderFlags,EffectPool) Method (Microsoft.DirectX.Direct3D)

Effect.FromFile Method

How Do I...?
  • Using an Effect

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal device As Device, _
ByVal sourceDataFile As String, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool _
) As Effect
C# public static Effect FromFile(
Device device,
string sourceDataFile,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool
);
C++ public:
static Effect^ FromFile(
Device^ device,
String^ sourceDataFile,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool
);
JScript public static function FromFile(
device : Device,
sourceDataFile : String,
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that creates the effect.
sourceDataFile System.String
A String Leave Site object that indicates the file name.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.FromStream
  • Effect.FromString


Effect.FromFile(Device,String,Include,String,ShaderFlags,EffectPool,String) Method (Microsoft.DirectX.Direct3D)

Effect.FromFile Method

How Do I...?
  • Using an Effect

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal device As Device, _
ByVal sourceDataFile As String, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromFile(
Device device,
string sourceDataFile,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
C++ public:
static Effect^ FromFile(
Device^ device,
String^ sourceDataFile,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool,
[Out] String^% compilationErrors
);
JScript public static function FromFile(
device : Device,
sourceDataFile : String,
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that creates the effect.
sourceDataFile System.String
A String Leave Site object that indicates the file name.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.FromStream
  • Effect.FromString


Effect.FromFile(Device,String,Macro[],Include,String,ShaderFlags,EffectPool,String) Method (Microsoft.DirectX.Direct3D)

Effect.FromFile Method

How Do I...?
  • Using an Effect

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal device As Device, _
ByVal sourceDataFile As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromFile(
Device device,
string sourceDataFile,
Macro[] preprocessorDefines,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
C++ public:
static Effect^ FromFile(
Device^ device,
String^ sourceDataFile,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool,
[Out] String^% compilationErrors
);
JScript public static function FromFile(
device : Device,
sourceDataFile : String,
preprocessorDefines : Macro[],
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that creates the effect.
sourceDataFile System.String
A String Leave Site object that indicates the file name.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}

See Also

  • Effect.FromStream
  • Effect.FromString


Effect.FromStream Method ()

Creates an effect from an ASCII or binary effect description.

Overload List

public static Effect FromStream(Device, Stream, Include, string, ShaderFlags, EffectPool);
public static Effect FromStream(Device, Stream, Include, string, ShaderFlags, EffectPool, out string);
public static Effect FromStream(Device, Stream, Macro[], Include, string, ShaderFlags, EffectPool, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Effect.FromFile
  • Effect.FromString


Effect.FromStream(Device,Stream,Include,String,ShaderFlags,EffectPool) Method (Microsoft.DirectX.Direct3D)

Effect.FromStream Method

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool _
) As Effect
C# public static Effect FromStream(
Device device,
Stream data,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool
);
C++ public:
static Effect^ FromStream(
Device^ device,
Stream^ data,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool
);
JScript public static function FromStream(
device : Device,
data : Stream,
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that will create the effect.
data System.IO.Stream
A Stream Leave Site object that contains the data used to create the Effect.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Effect.FromFile
  • Effect.FromString


Effect.FromStream(Device,Stream,Include,String,ShaderFlags,EffectPool,String) Method (Microsoft.DirectX.Direct3D)

Effect.FromStream Method

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromStream(
Device device,
Stream data,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
C++ public:
static Effect^ FromStream(
Device^ device,
Stream^ data,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool,
[Out] String^% compilationErrors
);
JScript public static function FromStream(
device : Device,
data : Stream,
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that will create the effect.
data System.IO.Stream
A Stream Leave Site object that contains the data used to create the Effect.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Effect.FromFile
  • Effect.FromString


Effect.FromStream(Device,Stream,Macro[],Include,String,ShaderFlags,EffectPool,String) Method (Microsoft.DirectX.Direct3D)

Effect.FromStream Method

Creates an effect from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromStream(
Device device,
Stream data,
Macro[] preprocessorDefines,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
C++ public:
static Effect^ FromStream(
Device^ device,
Stream^ data,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool,
[Out] String^% compilationErrors
);
JScript public static function FromStream(
device : Device,
data : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that will create the effect.
data System.IO.Stream
A Stream Leave Site object that contains the data used to create the Effect.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Effect.FromFile
  • Effect.FromString


Effect.FromString Method ()

Creates an effect from an ASCII or binary effect description in a string.

Overload List

public static Effect FromString(Device, string, Include, string, ShaderFlags, EffectPool);
public static Effect FromString(Device, string, Include, string, ShaderFlags, EffectPool, out string);
public static Effect FromString(Device, string, Macro[], Include, string, ShaderFlags, EffectPool, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Effect.FromString(Device,String,Include,String,ShaderFlags,EffectPool) Method (Microsoft.DirectX.Direct3D)

Effect.FromString Method

Creates an effect from an ASCII or binary effect description in a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal device As Device, _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool _
) As Effect
C# public static Effect FromString(
Device device,
string sourceData,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool
);
C++ public:
static Effect^ FromString(
Device^ device,
String^ sourceData,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool
);
JScript public static function FromString(
device : Device,
sourceData : String,
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that will create the effect.
sourceData System.String
A String Leave Site that describes the Effect to create.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Effect.FromString(Device,String,Include,String,ShaderFlags,EffectPool,String) Method (Microsoft.DirectX.Direct3D)

Effect.FromString Method

Creates an effect from an ASCII or binary effect description in a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal device As Device, _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromString(
Device device,
string sourceData,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
C++ public:
static Effect^ FromString(
Device^ device,
String^ sourceData,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool,
[Out] String^% compilationErrors
);
JScript public static function FromString(
device : Device,
sourceData : String,
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that will create the effect.
sourceData System.String
A String Leave Site that describes the Effect to create.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Effect.FromString(Device,String,Macro[],Include,String,ShaderFlags,EffectPool,String) Method (Microsoft.DirectX.Direct3D)

Effect.FromString Method

Creates an effect from an ASCII or binary effect description in a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal device As Device, _
ByVal sourceData As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal skipConstants As String, _
ByVal flags As ShaderFlags, _
ByVal pool As EffectPool, _
ByRef compilationErrors As String _
) As Effect
C# public static Effect FromString(
Device device,
string sourceData,
Macro[] preprocessorDefines,
Include includeFile,
string skipConstants,
ShaderFlags flags,
EffectPool pool,
out string compilationErrors
);
C++ public:
static Effect^ FromString(
Device^ device,
String^ sourceData,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ skipConstants,
ShaderFlags flags,
EffectPool^ pool,
[Out] String^% compilationErrors
);
JScript public static function FromString(
device : Device,
sourceData : String,
preprocessorDefines : Macro[],
includeFile : Include,
skipConstants : String,
flags : ShaderFlags,
pool : EffectPool,
compilationErrors : String
) : Effect;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device that will create the effect.
sourceData System.String
A String Leave Site that describes the Effect to create.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Optional null-terminated array of preprocessor macro definitions. For more information, see Macro.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
skipConstants System.String
A string of effect parameters that will be ignored by the effect system. The string must be NULL terminated and needs to contain the name of each application-managed constant separated by a semicolon.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
pool Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object to use for shared parameters. If this value is null, no parameters are shared.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.Effect
An Effect that contains the compiled effect.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Effect.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Effect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Effect.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Effect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXEffect, which allows unmanaged COM clients to create an instance of the managed Effect class. Not supported.


Effect.IsParameterUsed(EffectHandle,EffectHandle) Method (Microsoft.DirectX.Direct3D)

Effect.IsParameterUsed Method

Determines whether a parameter is used by a technique.

Definition

Visual Basic Public Function IsParameterUsed( _
ByVal parameter As EffectHandle, _
ByVal technique As EffectHandle _
) As Boolean
C# public bool IsParameterUsed(
EffectHandle parameter,
EffectHandle technique
);
C++ public:
bool IsParameterUsed(
EffectHandle^ parameter,
EffectHandle^ technique
);
JScript public function IsParameterUsed(
parameter : EffectHandle,
technique : EffectHandle
) : boolean;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that acts as a unique identifier for the parameter.
technique Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that acts as a unique identifier for the technique.

Return Value

System.Boolean
Value that is true if the parameter is being used, or false if it is not being used.


Effect.IsTechniqueValid Method ()

Validates a technique.

Overload List

public bool IsTechniqueValid(EffectHandle);
public bool IsTechniqueValid(EffectHandle, out int);


Effect.IsTechniqueValid(EffectHandle) Method (Microsoft.DirectX.Direct3D)

Effect.IsTechniqueValid Method

Validates a technique.

Definition

Visual Basic Public Function IsTechniqueValid( _
ByVal technique As EffectHandle _
) As Boolean
C# public bool IsTechniqueValid(
EffectHandle technique
);
C++ public:
bool IsTechniqueValid(
EffectHandle^ technique
);
JScript public function IsTechniqueValid(
technique : EffectHandle
) : boolean;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of a technique.

Return Value

System.Boolean
A value that is set to true, if the technique is valid; otherwise, true.


Effect.IsTechniqueValid(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

Effect.IsTechniqueValid Method

Validates a technique.

Definition

Visual Basic Public Function IsTechniqueValid( _
ByVal technique As EffectHandle, _
ByRef returnValue As Integer _
) As Boolean
C# public bool IsTechniqueValid(
EffectHandle technique,
out int returnValue
);
C++ public:
bool IsTechniqueValid(
EffectHandle^ technique,
[Out] int% returnValue
);
JScript public function IsTechniqueValid(
technique : EffectHandle,
returnValue : int
) : boolean;

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle of a technique.
returnValue System.Int32
Return code for validation.

Return Value

System.Boolean
A value that is set to true, if the technique is valid; otherwise, true.


Effect.OnLostDevice() Method (Microsoft.DirectX.Direct3D)

Effect.OnLostDevice Method

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic | Public Sub OnLostDevice()
C# | public void OnLostDevice();
C++ public:
void OnLostDevice();
JScript | public function OnLostDevice();

Remarks

This method should be called whenever a device is lost. Before the object can be used again, the device must be reset and the Effect.OnResetDevice method called.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Effect.OnResetDevice() Method (Microsoft.DirectX.Direct3D)

Effect.OnResetDevice Method

Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic | Public Sub OnResetDevice()
C# | public void OnResetDevice();
C++ public:
void OnResetDevice();
JScript | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, it is unnecessary to call Effect.OnResetDevice under normal circumstances. However, if at any point Device.IsUsingEventHandlers is set to false, Effect.OnResetDevice should be called immediately after the device is reset.


Effect.op_Equality(Effect,Effect) Method (Microsoft.DirectX.Direct3D)

Effect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Effect, _
ByVal right As Effect _
) As Boolean
C# public static bool op_Equality(
Effect left,
Effect right
);
C++ public:
static bool operator==(
Effect^ left,
Effect^ right
);
JScript public static function op_Equality(
left : Effect,
right : Effect
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Effect
The Effect object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Effect
The Effect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Effect.op_Inequality(Effect,Effect) Method (Microsoft.DirectX.Direct3D)

Effect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Effect, _
ByVal right As Effect _
) As Boolean
C# public static bool op_Inequality(
Effect left,
Effect right
);
C++ public:
static bool operator!=(
Effect^ left,
Effect^ right
);
JScript public static function op_Inequality(
left : Effect,
right : Effect
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Effect
The Effect object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Effect
The Effect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Effect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Effect.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Effect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Effect.raise_Lost(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Effect.raise_Lost Method

Raises an Effect.Lost event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
C++ protected:
void raise_Lost(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Effect.raise_Reset(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Effect.raise_Reset Method

Raises an Effect.Reset event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
C++ protected:
void raise_Reset(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Effect.SetArrayRange(EffectHandle,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Effect.SetArrayRange Method

Sets the range of an array to pass to the device.

Definition

Visual Basic Public Sub SetArrayRange( _
ByVal parameter As EffectHandle, _
ByVal start As Integer, _
ByVal end As Integer _
)
C# public void SetArrayRange(
EffectHandle parameter,
int start,
int end
);
C++ public:
void SetArrayRange(
EffectHandle^ parameter,
int start,
int end
);
JScript public function SetArrayRange(
parameter : EffectHandle,
start : int,
end : int
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the effect.
start System.Int32
The array starting index.
end System.Int32
The array ending index.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.SetRawValue(EffectHandle, GraphicsStream, Int32) Method (Microsoft.DirectX.Direct3D)

Effect.SetRawValue Method

Set a contiguous range of shader constants with a memory copy.

Definition

Visual Basic Public Sub SetRawValue( _
ByVal parameter As EffectHandle _
ByVal data As GraphicsStream _
ByVal byteOffset As Integer _
)
C# public void SetRawValue(
EffectHandle parameter
GraphicsStream data
int byteOffset
);
C++ public:
void SetRawValue(
EffectHandle parameter
GraphicsStream data
int byteOffset
);
JScript public function SetRawValue(
parameter : EffectHandle
data : GraphicsStream
byteOffset : int
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that specifies the value to set, or the name of the value passed in as a string. Passing in a handle is more efficient.
data Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the data to be set. SetRawValue checks for valid memory, but does not do any checking for valid data.
byteOffset System.Int32
Number of bytes between the beginning of the effect data and the beginning of the effect constants you are going to set.

Remarks

SetRawValue is a very fast way to set effect constants since it performs a memory copy without performing validation or any data conversion (like converting a row-major matrix to a column-major matrix). Use SetRawValue to set a series of contiguous effect constants.

All values are expected to be either matrix4x4s or float4s and all matrices are expected to be in column-major order. Int or float values are cast into a float4; therefore, it is highly recommended that you use SetRawValue with only float4 or matrix4x4 data.


Effect.UpdateUnmanagedPointer(ID3DXEffect) Method (Microsoft.DirectX.Direct3D)

Effect.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Effect object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXEffect _
)
C# public void UpdateUnmanagedPointer(
ID3DXEffect pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXEffect pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXEffect
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffect
Pointer to the ID3DXEffect structure used to update the unmanaged pointer for this Effect object.


Effect.ValidateTechnique(EffectHandle) Method (Microsoft.DirectX.Direct3D)

Effect.ValidateTechnique Method

Validates a technique.

Definition

Visual Basic Public Sub ValidateTechnique( _
ByVal technique As EffectHandle _
)
C# public void ValidateTechnique(
EffectHandle technique
);
C++ public:
void ValidateTechnique(
EffectHandle^ technique
);
JScript public function ValidateTechnique(
technique : EffectHandle
);

Parameters

technique Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object used as a unique identifier for the effect.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Effect.Technique


Effect.Device Property (Microsoft.DirectX.Direct3D)

Effect.Device Property

Retrieves the device associated with an effect.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device object associated with the effect.

This property is read-only.


Effect.Disposed Property (Microsoft.DirectX.Direct3D)

Effect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public Shadows ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Effect.Pool Property (Microsoft.DirectX.Direct3D)

Effect.Pool Property

Retrieves an effect pool object that represents the pool of shared parameters.

Definition

Visual Basic | Public ReadOnly Property Pool As EffectPool
C# | public EffectPool Pool { get; }
C++ public:
property EffectPool^ Pool {
EffectPool^ get();
}
JScript | public function get Pool() : EffectPool

Property Value

Microsoft.DirectX.Direct3D.EffectPool
An EffectPool object that represents the pool of shared parameters.

This property is read-only.

Remarks

Pools contain parameters that are shared between effects.


Effect.StateManager Property (Microsoft.DirectX.Direct3D)

Effect.StateManager Property

Retrieves or sets the EffectStateManager object for this effect.

Definition

Visual Basic | Public Property StateManager As EffectStateManager
C# | public EffectStateManager StateManager { get; set; }
C++ public:
property EffectStateManager^ StateManager {
EffectStateManager^ get();
void set(EffectStateManager^ value);
}
JScript public function get StateManager() : EffectStateManager
public function set StateManager(EffectStateManager);

Property Value

Microsoft.DirectX.Direct3D.EffectStateManager
An EffectStateManager object to set or retrieve.

This property is read/write.

Remarks

EffectStateManager is a user-implemented class whose methods are used as callbacks to the application during effect rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Effect.Technique Property (Microsoft.DirectX.Direct3D)

Effect.Technique Property

How Do I...?
  • Using an Effect

Retreives and sets the active technique.

Definition

Visual Basic | Public Property Technique As EffectHandle
C# | public EffectHandle Technique { get; set; }
C++ public:
property EffectHandle^ Technique {
EffectHandle^ get();
void set(EffectHandle^ value);
}
JScript public function get Technique() : EffectHandle
public function set Technique(EffectHandle);

Property Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that is a unique identifier for the active technique.

This property is read/write.

How Do I...?

Using an Effect

This example demonstrates how to use an effect technique that was loaded from a file.

Add effects code to your rendering method, such as OnRender(), in-between calls to Device.BeginScene and Device.EndScene.

  1. Create or obtain access to a high-level shader language (HLSL) file (.fx).
  2. Load the HLSL file using Effect.FromFile.
  3. Set Effect.Technique with the effect's technique.
  4. Use Effect.Begin to obtain the number of passes for the effect.
  5. Create a loop to iterate through all of the effect's passes. Rendering an effect occurs within a loop between calls to Effect.BeginPass and Effect.EndPass. The loop itself is nested between calls to Effect.Begin and Effect.End.
  6. Render each pass within the loop with calls to Effect.BeginPass, Device.DrawPrimitives, and Effect.EndPass.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

public void OnRender ()
{
    .
    .
    .

    // Load the effect from file.
    Effect effect = Effect.FromFile(device, "shadercode.fx", null,
                                    ShaderFlags.None, null);
    // Set the technique.
    effect.Technique = "ShaderTechnique";

    // Note: Effect.Begin returns the number of
    // passes required to render the effect.
    int passes = effect.Begin(0);

    // Loop through all of the effect's passes.
    for (int i = 0; i < passes; i++)
    {
        // Set a shader constant
        effect.SetValue("WorldMatrix", worldMatrix);

        // Set state for the current effect pass.
        effect.BeginPass(i);

        // Render some primitives.
        device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

        // End the effect pass
        effect.EndPass();
    }

    // Must call Effect.End to signal the end of the technique.
    effect.End();

    .
    .
    .
}


Effect.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Effect.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXEffect interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As ID3DXEffect
C# | public ID3DXEffect UnmanagedComPointer { get; }
C++ public:
property ID3DXEffect UnmanagedComPointer {
ID3DXEffect get();
}
JScript | public function get UnmanagedComPointer() : ID3DXEffect

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffect
Unmanaged ID3DXEffect interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Effect.Disposing Event (Microsoft.DirectX.Direct3D)

Effect.Disposing Event

Occurs when the Dispose method is called or when the Effect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Effect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Effect object indicates whether that object has been disposed.


Effect.Lost Event (Microsoft.DirectX.Direct3D)

Effect.Lost Event

Occurs when an object is lost, normally just before a device is reset.

Definition

Visual Basic | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
C++ public:
event EventHandler^ Lost;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Effect.Lost event, use the following C# code.

[C#]
effect.Lost += new System.EventHandler(this.LostEventHandler);


Effect.Reset Event (Microsoft.DirectX.Direct3D)

Effect.Reset Event

Occurs after the Effect.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
C++ public:
event EventHandler^ Reset;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Effect.Reset event, use the following C# code.

[C#]
effect.Reset += new System.EventHandler(this.ResetEventHandler);


EffectCompiler Class (Microsoft.DirectX.Direct3D)

EffectCompiler Class

Compiles an effect from a function or vertex shader.

Definition

Visual Basic NotInheritable Public Class EffectCompiler
Inherits BaseEffect
C# | public sealed class EffectCompiler : BaseEffect
C++ | public ref class EffectCompiler sealed : BaseEffect
JScript | public final class EffectCompiler extends BaseEffect

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the EffectCompiler object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
CompileEffect | Compiles an effect.
CompileShader | Compiles a shader from an effect that contains one or more functions.
Dispose | Immediately releases the unmanaged resources used by the BaseEffect object. Inherited from BaseEffect.
EffectCompiler | Initializes a new instance of the EffectCompiler class.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the BaseEffect object to free resources before it is destroyed by the garbage collector. Inherited from BaseEffect.
static (Shared in Visual Basic) FromFile | Creates an effect compiler from an ASCII or binary effect description.
static (Shared in Visual Basic) FromStream | Creates an effect compiler from an ASCII or binary effect description in a stream.
static (Shared in Visual Basic) FromString | Creates an effect compiler from an ASCII or binary effect description in a string.
GetAnnotation | Retrieves an annotation. Inherited from BaseEffect.
GetFunction | Retrieves a function. Inherited from BaseEffect.
GetFunctionDescription | Retrieves a function description. Inherited from BaseEffect.
GetHashCode | Returns the hash code for the current instance.
GetLiteral | Retrieves a literal status of a parameter.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetParameter | Retrieves a top-level parameter or a structure member parameter. Inherited from BaseEffect.
GetParameterBySemantic | Retrieves the handle of a top-level parameter or structure member parameter by looking up its semantic. Inherited from BaseEffect.
GetParameterDescription | Retrieves a parameter or annotation description. Inherited from BaseEffect.
GetParameterElement | Retrieves the EffectHandle of an array element parameter. Inherited from BaseEffect.
GetPass | Retrieves the EffectHandle of a pass. Inherited from BaseEffect.
GetPassDescription | Retrieves a pass description. Inherited from BaseEffect.
GetTechnique | Retrieves the EffectHandle of a technique. Inherited from BaseEffect.
GetTechniqueDescription | Retrieves a technique description. Inherited from BaseEffect.
GetValue | Retrieves the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures. Inherited from BaseEffect.
GetValueBoolean | Retrieves a Boolean value. Inherited from BaseEffect.
GetValueBooleanArray | Retrieves an array of Boolean values. Inherited from BaseEffect.
GetValueColor | Retrieves a ColorValue structure. Inherited from BaseEffect.
GetValueColorArray | Retrieves an array of ColorValue structures. Inherited from BaseEffect.
GetValueFloat | Retrieves a floating-point value. Inherited from BaseEffect.
GetValueFloatArray | Retrieves an array of floating-point values. Inherited from BaseEffect.
GetValueInteger | Retrieves an integer. Inherited from BaseEffect.
GetValueIntegerArray | Retrieves an array of integers. Inherited from BaseEffect.
GetValueMatrix | Retrieves a nontransposed matrix. Inherited from BaseEffect.
GetValueMatrixArray | Retrieves an array of nontransposed matrices. Inherited from BaseEffect.
GetValueMatrixTranspose | Retrieves a transposed matrix. Inherited from BaseEffect.
GetValueMatrixTransposeArray | Retrieves an array of transposed matrices. Inherited from BaseEffect.
GetValuePixelShader | Retrieves a pixel shader. Inherited from BaseEffect.
GetValueString | Retrieves a string. Inherited from BaseEffect.
GetValueTexture | Retrieves a texture. Inherited from BaseEffect.
GetValueVector | Retrieves a vector. Inherited from BaseEffect.
GetValueVectorArray | Retrieves an array of vectors. Inherited from BaseEffect.
GetValueVertexShader | Retrieves a vertex shader. Inherited from BaseEffect.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseEffect.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseEffect.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.EffectCompiler.Disposing event when called from within a derived class.
SetArrayRange | Sets the range of an array to pass to the device.
SetLiteral | Toggles the literal status of a parameter.
SetValue | Sets the value of an arbitrary parameter or annotation, including simple types, structures, arrays, strings, shaders, and textures. Inherited from BaseEffect.
SetValueTranspose | Sets a transposed matrix. Inherited from BaseEffect.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseEffect object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseEffect.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this EffectCompiler object. This method supports the Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves an effect description. Inherited from BaseEffect.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseEffect interface pointer. Inherited from BaseEffect.
UnmanagedComPointer | Returns the unmanaged COM ID3DXEffectCompiler interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseEffect
EffectCompiler

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectCompiler.CompileEffect Method ()

Compiles an effect.

Overload List

public GraphicsStream CompileEffect();
public GraphicsStream CompileEffect(ShaderFlags);
public GraphicsStream CompileEffect(ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileEffect() Method (Microsoft.DirectX.Direct3D)

EffectCompiler.CompileEffect Method

Compiles an effect.

Definition

Visual Basic | Public Function CompileEffect() As GraphicsStream
C# | public GraphicsStream CompileEffect();
C++ public:
GraphicsStream^ CompileEffect();
JScript | public function CompileEffect() : GraphicsStream;

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled effect.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileEffect(ShaderFlags) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.CompileEffect Method

Compiles an effect.

Definition

Visual Basic Public Function CompileEffect( _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public GraphicsStream CompileEffect(
ShaderFlags flags
);
C++ public:
GraphicsStream^ CompileEffect(
ShaderFlags flags
);
JScript public function CompileEffect(
flags : ShaderFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more ShaderFlags that specify compile options, or 0.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled effect.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileEffect(ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.CompileEffect Method

Compiles an effect.

Definition

Visual Basic Public Function CompileEffect( _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String _
) As GraphicsStream
C# public GraphicsStream CompileEffect(
ShaderFlags flags,
out string errorMessages
);
C++ public:
GraphicsStream^ CompileEffect(
ShaderFlags flags,
[Out] String^% errorMessages
);
JScript public function CompileEffect(
flags : ShaderFlags,
errorMessages : String
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more ShaderFlags that specify compile options, or 0.
errorMessages System.String
String that contains at least the first compile error message that occurs, including effect compiler errors and high-level language compile errors.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled effect.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader Method ()

Compiles a shader from an effect that contains one or more functions.

Overload List

public GraphicsStream CompileShader(EffectHandle, string, ShaderFlags);
public GraphicsStream CompileShader(EffectHandle, string, ShaderFlags, out ConstantTable);
public GraphicsStream CompileShader(EffectHandle, string, ShaderFlags, out string);
public GraphicsStream CompileShader(EffectHandle, string, ShaderFlags, out string, out ConstantTable);

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader(EffectHandle,String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.CompileShader Method

Compiles a shader from an effect that contains one or more functions.

Definition

Visual Basic Public Function CompileShader( _
ByVal functionName As EffectHandle, _
ByVal target As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public GraphicsStream CompileShader(
EffectHandle functionName,
string target,
ShaderFlags flags
);
C++ public:
GraphicsStream^ CompileShader(
EffectHandle^ functionName,
String^ target,
ShaderFlags flags
);
JScript public function CompileShader(
functionName : EffectHandle,
target : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

functionName Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle used as a unique identifier for the function to be compiled. This value must not be null.
target System.String
String that identifies the shader version. See Remarks.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more ShaderFlags flags that specify compile options, or 0.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader. The compiler shader is an array of Int32 Leave Site values.

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader(EffectHandle,String,ShaderFlags,ConstantTable) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.CompileShader Method

Compiles a shader from an effect that contains one or more functions.

Definition

Visual Basic Public Function CompileShader( _
ByVal functionName As EffectHandle, _
ByVal target As String, _
ByVal flags As ShaderFlags, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public GraphicsStream CompileShader(
EffectHandle functionName,
string target,
ShaderFlags flags,
out ConstantTable table
);
C++ public:
GraphicsStream^ CompileShader(
EffectHandle^ functionName,
String^ target,
ShaderFlags flags,
[Out] ConstantTable^% table
);
JScript public function CompileShader(
functionName : EffectHandle,
target : String,
flags : ShaderFlags,
table : ConstantTable
) : GraphicsStream;

Parameters

functionName Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle used as a unique identifier for the function to be compiled. This value must not be null.
target System.String
String that identifies the shader version. See Remarks.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more ShaderFlags flags that specify compile options, or 0.
table Microsoft.DirectX.Direct3D.ConstantTable
A ConstantTable object that can be used to access shader constants. This value can be null.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader. The compiler shader is an array of Int32 Leave Site values.

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader(EffectHandle,String,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.CompileShader Method

Compiles a shader from an effect that contains one or more functions.

Definition

Visual Basic Public Function CompileShader( _
ByVal functionName As EffectHandle, _
ByVal target As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String _
) As GraphicsStream
C# public GraphicsStream CompileShader(
EffectHandle functionName,
string target,
ShaderFlags flags,
out string errorMessages
);
C++ public:
GraphicsStream^ CompileShader(
EffectHandle^ functionName,
String^ target,
ShaderFlags flags,
[Out] String^% errorMessages
);
JScript public function CompileShader(
functionName : EffectHandle,
target : String,
flags : ShaderFlags,
errorMessages : String
) : GraphicsStream;

Parameters

functionName Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle used as a unique identifier for the function to be compiled. This value must not be null.
target System.String
String that identifies the shader version. See Remarks.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more ShaderFlags flags that specify compile options, or 0.
errorMessages System.String
String that contains at least the first compile error message that occurred. This includes effect compiler errors and high-level language compile errors.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader. The compiler shader is an array of Int32 Leave Site values.

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.CompileShader(EffectHandle,String,ShaderFlags,String,ConstantTable) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.CompileShader Method

Compiles a shader from an effect that contains one or more functions.

Definition

Visual Basic Public Function CompileShader( _
ByVal functionName As EffectHandle, _
ByVal target As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public GraphicsStream CompileShader(
EffectHandle functionName,
string target,
ShaderFlags flags,
out string errorMessages,
out ConstantTable table
);
C++ public:
GraphicsStream^ CompileShader(
EffectHandle^ functionName,
String^ target,
ShaderFlags flags,
[Out] String^% errorMessages,
[Out] ConstantTable^% table
);
JScript public function CompileShader(
functionName : EffectHandle,
target : String,
flags : ShaderFlags,
errorMessages : String,
table : ConstantTable
) : GraphicsStream;

Parameters

functionName Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle used as a unique identifier for the function to be compiled. This value must not be null.
target System.String
String that identifies the shader version. See Remarks.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more ShaderFlags flags that specify compile options, or 0.
errorMessages System.String
String that contains at least the first compile error message that occurred. This includes effect compiler errors and high-level language compile errors.
table Microsoft.DirectX.Direct3D.ConstantTable
A ConstantTable object that can be used to access shader constants. This value can be null.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader. The compiler shader is an array of Int32 Leave Site values.

Remarks

Targets for vertex shaders, pixel shaders, and texture fill functions can be specified in the target parameter. The following table lists the shader versions for each type.

Target type | Shader version
Vertex shader | vs_1_1, vs_2_0, vs_2_sw, vs_3_0
Pixel shader | ps_1_1, ps_1_2, ps_1_3, ps_1_4, ps_2_0, ps_2_sw, ps_3_0
Texture fill | tx_0, tx_1

This method compiles a shader from a function that is written in a C-like language.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


EffectCompiler.EffectCompiler Constructor ()

Initializes a new instance of the EffectCompiler class.

Overload List

public EffectCompiler(ID3DXEffectCompiler);
public EffectCompiler(IntPtr);


EffectCompiler.EffectCompiler(ID3DXEffectCompiler) Constructor (Microsoft.DirectX.Direct3D)

EffectCompiler.EffectCompiler Constructor

Initializes a new instance of the EffectCompiler class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As ID3DXEffectCompiler _
)
C# public EffectCompiler(
ID3DXEffectCompiler pInterop
);
C++ public:
EffectCompiler(
ID3DXEffectCompiler pInterop
);
JScript public function EffectCompiler(
pInterop : ID3DXEffectCompiler
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectCompiler
Unmanaged Component Object Model (COM) ID3DXEffectCompiler interface pointer.


EffectCompiler.EffectCompiler(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

EffectCompiler.EffectCompiler Constructor

Initializes a new instance of the EffectCompiler class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public EffectCompiler(
IntPtr unmanagedObject
);
C++ public:
EffectCompiler(
IntPtr unmanagedObject
);
JScript public function EffectCompiler(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXEffectCompiler interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


EffectCompiler.Equals(Object) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


EffectCompiler.FromFile Method ()

Creates an effect compiler from an ASCII or binary effect description.

Overload List

public static EffectCompiler FromFile(string, Include, ShaderFlags);
public static EffectCompiler FromFile(string, Include, ShaderFlags, out string);
public static EffectCompiler FromFile(string, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromString


EffectCompiler.FromFile(String,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromFile Method

Creates an effect compiler from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As EffectCompiler
C# public static EffectCompiler FromFile(
string sourceFile,
Include includeFile,
ShaderFlags flags
);
C++ public:
static EffectCompiler^ FromFile(
String^ sourceFile,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function FromFile(
sourceFile : String,
includeFile : Include,
flags : ShaderFlags
) : EffectCompiler;

Parameters

sourceFile System.String
String that indicates the file name.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromString


EffectCompiler.FromFile(String,Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromFile Method

Creates an effect compiler from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromFile(
string sourceFile,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static EffectCompiler^ FromFile(
String^ sourceFile,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromFile(
sourceFile : String,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceFile System.String
String that indicates the file name.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromString


EffectCompiler.FromFile(String,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromFile Method

Creates an effect compiler from an ASCII or binary effect description.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromFile(
string sourceFile,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static EffectCompiler^ FromFile(
String^ sourceFile,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromFile(
sourceFile : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceFile System.String
String that indicates the file name.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromString


EffectCompiler.FromStream Method ()

Creates an effect compiler from an ASCII or binary effect description in a stream.

Overload List

public static EffectCompiler FromStream(Stream, Include, ShaderFlags);
public static EffectCompiler FromStream(Stream, Include, ShaderFlags, out string);
public static EffectCompiler FromStream(Stream, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromString


EffectCompiler.FromStream(Stream,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromStream Method

Creates an effect compiler from an ASCII or binary effect description in a stream.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As EffectCompiler
C# public static EffectCompiler FromStream(
Stream sourceData,
Include includeFile,
ShaderFlags flags
);
C++ public:
static EffectCompiler^ FromStream(
Stream^ sourceData,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function FromStream(
sourceData : Stream,
includeFile : Include,
flags : ShaderFlags
) : EffectCompiler;

Parameters

sourceData System.IO.Stream
A Stream Leave Site object that contains the data used to create the EffectCompiler.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromString


EffectCompiler.FromStream(Stream,Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromStream Method

Creates an effect compiler from an ASCII or binary effect description in a stream.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromStream(
Stream sourceData,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static EffectCompiler^ FromStream(
Stream^ sourceData,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromStream(
sourceData : Stream,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceData System.IO.Stream
A Stream Leave Site object that contains the data used to create the EffectCompiler.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromString


EffectCompiler.FromStream(Stream,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromStream Method

Creates an effect compiler from an ASCII or binary effect description in a stream.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromStream(
Stream sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static EffectCompiler^ FromStream(
Stream^ sourceData,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromStream(
sourceData : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceData System.IO.Stream
A Stream Leave Site object that contains the data used to create the EffectCompiler.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromString


EffectCompiler.FromString Method ()

Creates an effect compiler from an ASCII or binary effect description in a string.

Overload List

public static EffectCompiler FromString(string, Include, ShaderFlags);
public static EffectCompiler FromString(string, Include, ShaderFlags, out string);
public static EffectCompiler FromString(string, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromStream


EffectCompiler.FromString(String,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromString Method

Creates an effect compiler from an ASCII or binary effect description in a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As EffectCompiler
C# public static EffectCompiler FromString(
string sourceData,
Include includeFile,
ShaderFlags flags
);
C++ public:
static EffectCompiler^ FromString(
String^ sourceData,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function FromString(
sourceData : String,
includeFile : Include,
flags : ShaderFlags
) : EffectCompiler;

Parameters

sourceData System.String
A String Leave Site that describes the EffectCompiler to create.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromStream


EffectCompiler.FromString(String,Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromString Method

Creates an effect compiler from an ASCII or binary effect description in a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromString(
string sourceData,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static EffectCompiler^ FromString(
String^ sourceData,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromString(
sourceData : String,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceData System.String
A String Leave Site that describes the EffectCompiler to create.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromStream


EffectCompiler.FromString(String,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.FromString Method

Creates an effect compiler from an ASCII or binary effect description in a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As EffectCompiler
C# public static EffectCompiler FromString(
string sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static EffectCompiler^ FromString(
String^ sourceData,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromString(
sourceData : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : EffectCompiler;

Parameters

sourceData System.String
A String Leave Site that describes the EffectCompiler to create.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Optional array of preprocessor macro definitions. For more information, see Macro.
includeFile Microsoft.DirectX.Direct3D.Include
Optional Include object to use for handling #include directives. If this value is null, #include directives are either honored when compiling from a file, or cause an error when compiled from a resource or memory.
flags Microsoft.DirectX.Direct3D.ShaderFlags
One or more compile options identified by the ShaderFlags enumeration.
compilationErrors System.String
String that contains a listing of compilation errors.

Return Value

Microsoft.DirectX.Direct3D.EffectCompiler
An EffectCompiler that represents the effect compiler.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromStream


EffectCompiler.GetHashCode() Method (Microsoft.DirectX.Direct3D)

EffectCompiler.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


EffectCompiler.GetLiteral(EffectHandle) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.GetLiteral Method

Retrieves a literal status of a parameter.

Definition

Visual Basic Public Function GetLiteral( _
ByVal parameter As EffectHandle _
) As Boolean
C# public bool GetLiteral(
EffectHandle parameter
);
C++ public:
bool GetLiteral(
EffectHandle^ parameter
);
JScript public function GetLiteral(
parameter : EffectHandle
) : boolean;

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that is used as the unique identifier of the parameter.

Return Value

System.Boolean
Value that is true if the parameter is a literal, or false if it is not.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectCompiler.SetLiteral


EffectCompiler.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXEffectCompiler, which allows unmanaged COM clients to create an instance of the managed EffectCompiler class. Not supported.


EffectCompiler.op_Equality(EffectCompiler,EffectCompiler) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As EffectCompiler, _
ByVal right As EffectCompiler _
) As Boolean
C# public static bool op_Equality(
EffectCompiler left,
EffectCompiler right
);
C++ public:
static bool operator==(
EffectCompiler^ left,
EffectCompiler^ right
);
JScript public static function op_Equality(
left : EffectCompiler,
right : EffectCompiler
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.EffectCompiler
The EffectCompiler object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.EffectCompiler
The EffectCompiler object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


EffectCompiler.op_Inequality(EffectCompiler,EffectCompiler) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As EffectCompiler, _
ByVal right As EffectCompiler _
) As Boolean
C# public static bool op_Inequality(
EffectCompiler left,
EffectCompiler right
);
C++ public:
static bool operator!=(
EffectCompiler^ left,
EffectCompiler^ right
);
JScript public static function op_Inequality(
left : EffectCompiler,
right : EffectCompiler
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.EffectCompiler
The EffectCompiler object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.EffectCompiler
The EffectCompiler object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


EffectCompiler.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.EffectCompiler.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


EffectCompiler.SetArrayRange(EffectHandle,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.SetArrayRange Method

Sets the range of an array to pass to the device.

Definition

Visual Basic Public Sub SetArrayRange( _
ByVal parameter As EffectHandle, _
ByVal start As Integer, _
ByVal end As Integer _
)
C# public void SetArrayRange(
EffectHandle parameter,
int start,
int end
);
C++ public:
void SetArrayRange(
EffectHandle^ parameter,
int start,
int end
);
JScript public function SetArrayRange(
parameter : EffectHandle,
start : int,
end : int
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the effect.
start System.Int32
The array starting index.
end System.Int32
The array ending index.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectCompiler.SetLiteral(EffectHandle,Boolean) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.SetLiteral Method

Toggles the literal status of a parameter.

Definition

Visual Basic Public Sub SetLiteral( _
ByVal parameter As EffectHandle, _
ByVal value As Boolean _
)
C# public void SetLiteral(
EffectHandle parameter,
bool value
);
C++ public:
void SetLiteral(
EffectHandle^ parameter,
bool value
);
JScript public function SetLiteral(
parameter : EffectHandle,
value : boolean
);

Parameters

parameter Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that is used as a unique identifier for the parameter.
value System.Boolean
Set to true to make the parameter a literal. Set to false if the parameter can change value during the shader lifetime.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectCompiler.GetLiteral


EffectCompiler.UpdateUnmanagedPointer(ID3DXEffectCompiler) Method (Microsoft.DirectX.Direct3D)

EffectCompiler.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this EffectCompiler object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXEffectCompiler _
)
C# public void UpdateUnmanagedPointer(
ID3DXEffectCompiler pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXEffectCompiler pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXEffectCompiler
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectCompiler
Pointer to the ID3DXEffectCompiler structure used to update the unmanaged pointer for this EffectCompiler object.


EffectCompiler.Disposed Property (Microsoft.DirectX.Direct3D)

EffectCompiler.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public Shadows ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


EffectCompiler.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

EffectCompiler.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXEffectCompiler interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As ID3DXEffectCompiler
C# | public ID3DXEffectCompiler UnmanagedComPointer { get; }
C++ public:
property ID3DXEffectCompiler UnmanagedComPointer {
ID3DXEffectCompiler get();
}
JScript | public function get UnmanagedComPointer() : ID3DXEffectCompiler

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectCompiler
Unmanaged ID3DXEffectCompiler interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


EffectCompiler.Disposing Event (Microsoft.DirectX.Direct3D)

EffectCompiler.Disposing Event

Occurs when the Dispose method is called or when the EffectCompiler object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.EffectCompiler.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the EffectCompiler object indicates whether that object has been disposed.


EffectHandle Class (Microsoft.DirectX.Direct3D)

EffectHandle Class

Represents a handle to specific effects.

Definition

Visual Basic NotInheritable Public Class EffectHandle
Inherits Object
C# | public sealed class EffectHandle : Object
C++ | public ref class EffectHandle sealed : Object
JScript | public final class EffectHandle extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the EffectHandle object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FromString | Creates an effect handle object from a string.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Implicit | This method has the same functionality as FromString, but is not supported.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.

Inheritance Hierarchy

Object Leave Site
EffectHandle

Remarks

An EffectHandle object is used as a unique identifier for a specific effect. Methods that work with effects often require the effect handle object of the effect.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectHandle.Equals(Object) Method (Microsoft.DirectX.Direct3D)

EffectHandle.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


EffectHandle.Finalize() Method (Microsoft.DirectX.Direct3D)

EffectHandle.Finalize Method

Allows the EffectHandle object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~EffectHandle();
C++ | !EffectHandle();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


EffectHandle.FromString(String) Method (Microsoft.DirectX.Direct3D)

EffectHandle.FromString Method

Creates an effect handle object from a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal value As String _
) As EffectHandle
C# public static EffectHandle FromString(
string value
);
C++ public:
static EffectHandle^ FromString(
String^ value
);
JScript public static function FromString(
value : String
) : EffectHandle;

Parameters

value System.String
A String Leave Site that describes the EffectHandle to create.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents the created effect handle.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


EffectHandle.GetHashCode() Method (Microsoft.DirectX.Direct3D)

EffectHandle.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


EffectHandle.op_Equality(EffectHandle,EffectHandle) Method (Microsoft.DirectX.Direct3D)

EffectHandle.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As EffectHandle, _
ByVal right As EffectHandle _
) As Boolean
C# public static bool op_Equality(
EffectHandle left,
EffectHandle right
);
C++ public:
static bool operator==(
EffectHandle^ left,
EffectHandle^ right
);
JScript public static function op_Equality(
left : EffectHandle,
right : EffectHandle
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


EffectHandle.op_Implicit(String) Method (Microsoft.DirectX.Direct3D)

EffectHandle.op_Implicit Method

This method has the same functionality as FromString, but is not supported.

Definition

Visual Basic Public Shared Function op_Implicit( _
ByVal value As String _
) As EffectHandle
C# public static EffectHandle op_Implicit(
string value
);
C++ public:
static operator EffectHandle^ (
String^ value
);
JScript public static function op_Implicit(
value : String
) : EffectHandle;

Parameters

value System.String

Return Value

Microsoft.DirectX.Direct3D.EffectHandle


EffectHandle.op_Inequality(EffectHandle,EffectHandle) Method (Microsoft.DirectX.Direct3D)

EffectHandle.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As EffectHandle, _
ByVal right As EffectHandle _
) As Boolean
C# public static bool op_Inequality(
EffectHandle left,
EffectHandle right
);
C++ public:
static bool operator!=(
EffectHandle^ left,
EffectHandle^ right
);
JScript public static function op_Inequality(
left : EffectHandle,
right : EffectHandle
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.EffectHandle
The EffectHandle object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


EffectPool Class (Microsoft.DirectX.Direct3D)

EffectPool Class

Allows applications to share resources between effects.

Definition

Visual Basic NotInheritable Public Class EffectPool
Inherits Object
Implements IDisposable
C# | public sealed class EffectPool : Object, IDisposable
C++ | public ref class EffectPool sealed : Object, IDisposable
JScript | public final class EffectPool extends Object implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the EffectPool object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the EffectPool object.
EffectPool | Creates a new instance of an EffectPool object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the EffectPool object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.EffectPool.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this EffectPool object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXEffectPool interface pointer.

Inheritance Hierarchy

Object Leave Site
EffectPool

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectPool.Dispose() Method (Microsoft.DirectX.Direct3D)

EffectPool.Dispose Method

Immediately releases the unmanaged resources used by the EffectPool object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~EffectPool();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.EffectPool.Disposed
  • Microsoft.DirectX.Direct3D.EffectPool.Disposing


EffectPool.EffectPool Constructor ()

Creates a new instance of an EffectPool object.

Overload List

public EffectPool();
public EffectPool(ID3DXEffectPool);
public EffectPool(IntPtr);

Remarks

A pool is used to share parameters between effects. For effects within a pool, shared parameters with the same name share values.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectPool.EffectPool(ID3DXEffectPool) Constructor (Microsoft.DirectX.Direct3D)

EffectPool.EffectPool Constructor

Creates a new instance of an EffectPool object.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXEffectPool _
)
C# public EffectPool(
ID3DXEffectPool pUnk
);
C++ public:
EffectPool(
ID3DXEffectPool pUnk
);
JScript public function EffectPool(
pUnk : ID3DXEffectPool
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectPool
Unmanaged Component Object Model (COM) ID3DXEffectPool interface pointer.

Remarks

A pool is used to share parameters between effects. For effects within a pool, shared parameters with the same name share values.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectPool.EffectPool(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

EffectPool.EffectPool Constructor

Creates a new instance of an EffectPool object.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public EffectPool(
IntPtr unmanagedObject
);
C++ public:
EffectPool(
IntPtr unmanagedObject
);
JScript public function EffectPool(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXEffectPool interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

A pool is used to share parameters between effects. For effects within a pool, shared parameters with the same name share values.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectPool.EffectPool() Constructor (Microsoft.DirectX.Direct3D)

EffectPool.EffectPool Constructor

Creates a new instance of an EffectPool object.

Definition

Visual Basic | Public Sub New()
C# | public EffectPool();
C++ public:
EffectPool();
JScript | public function EffectPool();

Remarks

A pool is used to share parameters between effects. For effects within a pool, shared parameters with the same name share values.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectPool.Equals(Object) Method (Microsoft.DirectX.Direct3D)

EffectPool.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


EffectPool.Finalize() Method (Microsoft.DirectX.Direct3D)

EffectPool.Finalize Method

Allows the EffectPool object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~EffectPool();
C++ | !EffectPool();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


EffectPool.GetHashCode() Method (Microsoft.DirectX.Direct3D)

EffectPool.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


EffectPool.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

EffectPool.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXEffectPool, which allows unmanaged COM clients to create an instance of the managed EffectPool class. Not supported.


EffectPool.op_Equality(EffectPool,EffectPool) Method (Microsoft.DirectX.Direct3D)

EffectPool.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As EffectPool, _
ByVal right As EffectPool _
) As Boolean
C# public static bool op_Equality(
EffectPool left,
EffectPool right
);
C++ public:
static bool operator==(
EffectPool^ left,
EffectPool^ right
);
JScript public static function op_Equality(
left : EffectPool,
right : EffectPool
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.EffectPool
The EffectPool object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.EffectPool
The EffectPool object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


EffectPool.op_Inequality(EffectPool,EffectPool) Method (Microsoft.DirectX.Direct3D)

EffectPool.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As EffectPool, _
ByVal right As EffectPool _
) As Boolean
C# public static bool op_Inequality(
EffectPool left,
EffectPool right
);
C++ public:
static bool operator!=(
EffectPool^ left,
EffectPool^ right
);
JScript public static function op_Inequality(
left : EffectPool,
right : EffectPool
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.EffectPool
The EffectPool object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.EffectPool
The EffectPool object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


EffectPool.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

EffectPool.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.EffectPool.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


EffectPool.UpdateUnmanagedPointer(ID3DXEffectPool) Method (Microsoft.DirectX.Direct3D)

EffectPool.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this EffectPool object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXEffectPool _
)
C# public void UpdateUnmanagedPointer(
ID3DXEffectPool pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXEffectPool pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXEffectPool
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectPool
Pointer to the ID3DXEffectPool structure used to update the unmanaged pointer for this EffectPool object.


EffectPool.Disposed Property (Microsoft.DirectX.Direct3D)

EffectPool.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


EffectPool.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

EffectPool.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXEffectPool interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXEffectPool
C# | public ID3DXEffectPool UnmanagedComPointer { get; }
C++ public:
property ID3DXEffectPool UnmanagedComPointer {
ID3DXEffectPool get();
}
JScript | public function get UnmanagedComPointer() : ID3DXEffectPool

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXEffectPool
Unmanaged ID3DXEffectPool interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


EffectPool.Disposing Event (Microsoft.DirectX.Direct3D)

EffectPool.Disposing Event

Occurs when the Dispose method is called or when the EffectPool object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.EffectPool.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the EffectPool object indicates whether that object has been disposed.


EffectStateManager Class (Microsoft.DirectX.Direct3D)

EffectStateManager Class

EffectStateManager is a user-implemented class that allows an application to set the device state from an effect. Each of the methods in this class must be implemented by the user and will then be used as a callback to the application when either of the following occur:

  • Effect.BeginPass is called.
  • Effect state is dynamically updated by calling the appropriate state change application programming interface (API). See individual method pages for details.

Definition

Visual Basic MustInherit Public Class EffectStateManager
Inherits Object
C# | public abstract class EffectStateManager : Object
C++ | public ref class EffectStateManager abstract : Object
JScript | public abstract class EffectStateManager extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectStateManager | Initializes a new instance of the EffectStateManager class.
Finalize | Allows the EffectStateManager object to free resources before it is destroyed by the garbage collector.
LightEnable | Enables or disables a light.
SetLight | Sets a light.
SetMaterial | Sets a material.
SetNPatchMode | Sets the number of subdivision segments for N-patches.
SetPixelShader | Sets a pixel shader.
SetPixelShaderConstantBoolean | Sets an array of pixel shader Boolean constants.
SetPixelShaderConstantInt32 | Sets an array of pixel shader integer constants.
SetPixelShaderConstantSingle | Sets an array of pixel shader floating-point constants.
SetRenderState | Sets a render state.
SetSamplerState | Sets a sampler state.
SetTexture | Sets a texture.
SetTextureStageState | Sets a texture stage state.
SetTransform | Sets a transform.
SetVertexFormat | Sets a vertex format code.
SetVertexShader | Sets a vertex shader.
SetVertexShaderConstantBoolean | Sets an array of vertex shader Boolean constants.
SetVertexShaderConstantInt32 | Sets an array of vertex shader integer constants.
SetVertexShaderConstantSingle | Sets an array of vertex shader floating-point constants.

Inheritance Hierarchy

Object Leave Site
EffectStateManager

Remarks

A user creates a class that inherits from EffectStateManager and implements all the methods. Once the derived class is created, you can get or set the state manager within an effect using Effect.StateManager.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.EffectStateManager() Constructor (Microsoft.DirectX.Direct3D)

EffectStateManager.EffectStateManager Constructor

Initializes a new instance of the EffectStateManager class.

Definition

Visual Basic | Public Sub New()
C# | public EffectStateManager();
C++ public:
EffectStateManager();
JScript | public function EffectStateManager();

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.Finalize() Method (Microsoft.DirectX.Direct3D)

EffectStateManager.Finalize Method

Allows the EffectStateManager object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~EffectStateManager();
C++ | !EffectStateManager();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.LightEnable(Int32,Boolean) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.LightEnable Method

Enables or disables a light.

Definition

Visual Basic MustOverride Public Sub LightEnable( _
ByVal lightIndex As Integer, _
ByVal isEnabled As Boolean _
)
C# public abstract void LightEnable(
int lightIndex,
bool isEnabled
);
C++ public:
virtual void LightEnable(
int lightIndex,
bool isEnabled
) abstract;
JScript public abstract function LightEnable(
lightIndex : int,
isEnabled : boolean
);

Parameters

lightIndex System.Int32
An integer that represents the index of the light to enable or disable.
isEnabled System.Boolean
Set to true to enable the light. Set to false to disable the light.

Remarks

LightEnable is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetLight(Int32,Light) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetLight Method

Sets a light.

Definition

Visual Basic MustOverride Public Sub SetLight( _
ByVal lightIndex As Integer, _
ByVal light As Light _
)
C# public abstract void SetLight(
int lightIndex,
Light light
);
C++ public:
virtual void SetLight(
int lightIndex,
Light^ light
) abstract;
JScript public abstract function SetLight(
lightIndex : int,
light : Light
);

Parameters

lightIndex System.Int32
The zero-based index of the light.
light Microsoft.DirectX.Direct3D.Light
The Light object to set.

Remarks

SetLight is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetMaterial(Material) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetMaterial Method

Sets a material.

Definition

Visual Basic MustOverride Public Sub SetMaterial( _
ByRef material As Material _
)
C# public abstract void SetMaterial(
ref Material material
);
C++ public:
virtual void SetMaterial(
Material% material
) abstract;
JScript public abstract function SetMaterial(
material : Material
);

Parameters

material Microsoft.DirectX.Direct3D.Material
The Material object to set.

Remarks

SetMaterial is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetNPatchMode(Single) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetNPatchMode Method

Sets the number of subdivision segments for N-patches.

Definition

Visual Basic MustOverride Public Sub SetNPatchMode( _
ByVal numberSegments As Single _
)
C# public abstract void SetNPatchMode(
float numberSegments
);
C++ public:
virtual void SetNPatchMode(
float numberSegments
) abstract;
JScript public abstract function SetNPatchMode(
numberSegments : float
);

Parameters

numberSegments System.Single
A float value that represents the number of segments for N-patches.

Remarks

SetNPatchMode is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetPixelShader(PixelShader) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetPixelShader Method

Sets a pixel shader.

Definition

Visual Basic MustOverride Public Sub SetPixelShader( _
ByVal pixelShader As PixelShader _
)
C# public abstract void SetPixelShader(
PixelShader pixelShader
);
C++ public:
virtual void SetPixelShader(
PixelShader^ pixelShader
) abstract;
JScript public abstract function SetPixelShader(
pixelShader : PixelShader
);

Parameters

pixelShader Microsoft.DirectX.Direct3D.PixelShader
The PixelShader object to set.

Remarks

SetPixelShader is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetPixelShaderConstantBoolean(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetPixelShaderConstantBoolean Method

Sets an array of pixel shader Boolean constants.

Definition

Visual Basic MustOverride Public Sub SetPixelShaderConstantBoolean( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetPixelShaderConstantBoolean(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
C++ public:
virtual void SetPixelShaderConstantBoolean(
int registerIndex,
GraphicsStream^ constantData,
int registerCount
) abstract;
JScript public abstract function SetPixelShaderConstantBoolean(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex System.Int32
The zero-based index of the first constant register.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents an array of Boolean constants.
registerCount System.Int32
The number of registers in constantData

Remarks

SetPixelShaderConstantBoolean is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetPixelShaderConstantInt32(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetPixelShaderConstantInt32 Method

Sets an array of pixel shader integer constants.

Definition

Visual Basic MustOverride Public Sub SetPixelShaderConstantInt32( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetPixelShaderConstantInt32(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
C++ public:
virtual void SetPixelShaderConstantInt32(
int registerIndex,
GraphicsStream^ constantData,
int registerCount
) abstract;
JScript public abstract function SetPixelShaderConstantInt32(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex System.Int32
The zero-based index of the first constant register.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents an array of integer constants.
registerCount System.Int32
The number of registers in constantData.

Remarks

SetPixelShaderConstantInt32 is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetPixelShaderConstantSingle(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetPixelShaderConstantSingle Method

Sets an array of pixel shader floating-point constants.

Definition

Visual Basic MustOverride Public Sub SetPixelShaderConstantSingle( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetPixelShaderConstantSingle(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
C++ public:
virtual void SetPixelShaderConstantSingle(
int registerIndex,
GraphicsStream^ constantData,
int registerCount
) abstract;
JScript public abstract function SetPixelShaderConstantSingle(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex System.Int32
The zero-based index of the first constant register.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents an array of floating-point constants.
registerCount System.Int32
The number of registers in >constantData.

Remarks

SetPixelShaderConstantSingle is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetRenderState(RenderStates,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetRenderState Method

Sets a render state.

Definition

Visual Basic MustOverride Public Sub SetRenderState( _
ByVal renderState As RenderStates, _
ByVal stateValue As Integer _
)
C# public abstract void SetRenderState(
RenderStates renderState,
int stateValue
);
C++ public:
virtual void SetRenderState(
RenderStates renderState,
int stateValue
) abstract;
JScript public abstract function SetRenderState(
renderState : RenderStates,
stateValue : int
);

Parameters

renderState Microsoft.DirectX.Direct3D.RenderStates
A value from the RenderStates enumeration to set.
stateValue System.Int32
The render state value to set for the given render state.

Remarks

SetRenderState is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetSamplerState(Int32,SamplerStageStates,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetSamplerState Method

Sets a sampler state.

Definition

Visual Basic MustOverride Public Sub SetSamplerState( _
ByVal samplerStage As Integer, _
ByVal state As SamplerStageStates, _
ByVal value As Integer _
)
C# public abstract void SetSamplerState(
int samplerStage,
SamplerStageStates state,
int value
);
C++ public:
virtual void SetSamplerState(
int samplerStage,
SamplerStageStates state,
int value
) abstract;
JScript public abstract function SetSamplerState(
samplerStage : int,
state : SamplerStageStates,
value : int
);

Parameters

samplerStage System.Int32
The zero-based sampler stage index.
state Microsoft.DirectX.Direct3D.SamplerStageStates
A SamplerStageStates enumeration that identifies sampler state, which can specify the filtering, addressing, or the border color.
value System.Int32
The value to set for the sampler state type specified in state.

Remarks

SetSamplerState is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetTexture(Int32,BaseTexture) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetTexture Method

Sets a texture.

Definition

Visual Basic MustOverride Public Sub SetTexture( _
ByVal textureStage As Integer, _
ByVal texture As BaseTexture _
)
C# public abstract void SetTexture(
int textureStage,
BaseTexture texture
);
C++ public:
virtual void SetTexture(
int textureStage,
BaseTexture^ texture
) abstract;
JScript public abstract function SetTexture(
textureStage : int,
texture : BaseTexture
);

Parameters

textureStage System.Int32
The zero-based texture stage index.
texture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that represents the texture to set.

Remarks

SetTexture is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetTextureStageState(Int32,TextureStageStates,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetTextureStageState Method

Sets a texture stage state.

Definition

Visual Basic MustOverride Public Sub SetTextureStageState( _
ByVal textureStage As Integer, _
ByVal state As TextureStageStates, _
ByVal value As Integer _
)
C# public abstract void SetTextureStageState(
int textureStage,
TextureStageStates state,
int value
);
C++ public:
virtual void SetTextureStageState(
int textureStage,
TextureStageStates state,
int value
) abstract;
JScript public abstract function SetTextureStageState(
textureStage : int,
state : TextureStageStates,
value : int
);

Parameters

textureStage System.Int32
The zero-based texture stage index.
state Microsoft.DirectX.Direct3D.TextureStageStates
A TextureStageStates enumeration that identifies texture state to set.
value System.Int32
The value to set for the texture state type specified in state.

Remarks

SetTextureStageState is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetTransform(TransformType,Matrix) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetTransform Method

Sets a transform.

Definition

Visual Basic MustOverride Public Sub SetTransform( _
ByVal transformType As TransformType, _
ByRef transform As Matrix _
)
C# public abstract void SetTransform(
TransformType transformType,
ref Matrix transform
);
C++ public:
virtual void SetTransform(
TransformType transformType,
Matrix% transform
) abstract;
JScript public abstract function SetTransform(
transformType : TransformType,
transform : Matrix
);

Parameters

transformType Microsoft.DirectX.Direct3D.TransformType
A value from the TransformType enumeration to set.
transform Microsoft.DirectX.Matrix
A transformation Matrix to set.

Remarks

SetTransform is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexFormat(VertexFormats) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetVertexFormat Method

Sets a vertex format code.

Definition

Visual Basic MustOverride Public Sub SetVertexFormat( _
ByVal vertexFormat As VertexFormats _
)
C# public abstract void SetVertexFormat(
VertexFormats vertexFormat
);
C++ public:
virtual void SetVertexFormat(
VertexFormats vertexFormat
) abstract;
JScript public abstract function SetVertexFormat(
vertexFormat : VertexFormats
);

Parameters

vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
A value of the VertexFormats enumeration that detemines how to interpret vertex data.

Remarks

SetVertexFormat is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexShader(VertexShader) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetVertexShader Method

Sets a vertex shader.

Definition

Visual Basic MustOverride Public Sub SetVertexShader( _
ByVal vertexShader As VertexShader _
)
C# public abstract void SetVertexShader(
VertexShader vertexShader
);
C++ public:
virtual void SetVertexShader(
VertexShader^ vertexShader
) abstract;
JScript public abstract function SetVertexShader(
vertexShader : VertexShader
);

Parameters

vertexShader Microsoft.DirectX.Direct3D.VertexShader
The VertexShader object to set.

Remarks

SetVertexShader is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexShaderConstantBoolean(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetVertexShaderConstantBoolean Method

Sets an array of vertex shader Boolean constants.

Definition

Visual Basic MustOverride Public Sub SetVertexShaderConstantBoolean( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetVertexShaderConstantBoolean(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
C++ public:
virtual void SetVertexShaderConstantBoolean(
int registerIndex,
GraphicsStream^ constantData,
int registerCount
) abstract;
JScript public abstract function SetVertexShaderConstantBoolean(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex System.Int32
The zero-based index of the first constant register.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents an array of Boolean constants.
registerCount System.Int32
The number of registers in constantData.

Remarks

SetVertexShaderConstantBoolean is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexShaderConstantInt32(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetVertexShaderConstantInt32 Method

Sets an array of vertex shader integer constants.

Definition

Visual Basic MustOverride Public Sub SetVertexShaderConstantInt32( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetVertexShaderConstantInt32(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
C++ public:
virtual void SetVertexShaderConstantInt32(
int registerIndex,
GraphicsStream^ constantData,
int registerCount
) abstract;
JScript public abstract function SetVertexShaderConstantInt32(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex System.Int32
The zero-based index of the first constant register.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents an array of integer constants.
registerCount System.Int32
The number of registers in constantData.

Remarks

SetVertexShaderConstantInt32 is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectStateManager.SetVertexShaderConstantSingle(Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

EffectStateManager.SetVertexShaderConstantSingle Method

Sets an array of vertex shader floating-point constants.

Definition

Visual Basic MustOverride Public Sub SetVertexShaderConstantSingle( _
ByVal registerIndex As Integer, _
ByVal constantData As GraphicsStream, _
ByVal registerCount As Integer _
)
C# public abstract void SetVertexShaderConstantSingle(
int registerIndex,
GraphicsStream constantData,
int registerCount
);
C++ public:
virtual void SetVertexShaderConstantSingle(
int registerIndex,
GraphicsStream^ constantData,
int registerCount
) abstract;
JScript public abstract function SetVertexShaderConstantSingle(
registerIndex : int,
constantData : GraphicsStream,
registerCount : int
);

Parameters

registerIndex System.Int32
The zero-based index of the first constant register.
constantData Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents an array of floating-point constants.
registerCount System.Int32
The number of registers in constantData.

Remarks

SetVertexShaderConstantSingle is a user-implemented method that is called from an effect during rendering.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Font Class (Microsoft.DirectX.Direct3D)

Font Class

Encapsulates the textures and resources needed to render a specific font on a specific device.

Definition

Visual Basic NotInheritable Public Class Font
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class Font : MarshalByRefObject, IDisposable
C++ | public ref class Font sealed : MarshalByRefObject, IDisposable
JScript | public final class Font extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Font object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally just before a device is reset.
Reset | Occurs after the Font.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Font object.
DrawText | Draws formatted text.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Font object to free resources before it is destroyed by the garbage collector.
Font | Creates a new instance of a Font class.
GetGlyphData | Returns information about the placement and orientation of a glyph in a character cell.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
MeasureString | Measures the rectangular dimensions of the specified text string when drawn with the specified Sprite object and formatted with the specified DrawTextFormat method of formatting text.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PreloadCharacters | Loads a series of characters into video memory to improve the efficiency of rendering to a device.
PreloadGlyphs | Loads a series of glyphs into video memory to improve the efficiency of rendering to a device.
PreloadText | Loads formatted text into video memory to improve the efficiency of rendering to a device.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Font.Disposing event when called from within a derived class.
raise_Lost | Raises a Font.Lost event when called from within a derived class.
raise_Reset | Raises a Font.Reset event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Font object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves a description of the current font object.
Device | Retrieves the Microsoft Direct3D device associated with a font object.
DeviceContext | Returns a handle to a display device context (DC) that includes the font set.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFont interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Font

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Font.Dispose() Method (Microsoft.DirectX.Direct3D)

Font.Dispose Method

Immediately releases the unmanaged resources used by the Font object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Font();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Font.Disposed
  • Microsoft.DirectX.Direct3D.Font.Disposing


Font.DrawText Method ()

Draws formatted text.

Overload List

public int DrawText(Sprite, string, int, int, Color);
public int DrawText(Sprite, string, int, int, int);
public int DrawText(Sprite, string, Point, Color);
public int DrawText(Sprite, string, Point, int);
public int DrawText(Sprite, string, Rectangle, DrawTextFormat, Color);
public int DrawText(Sprite, string, Rectangle, DrawTextFormat, int);

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Int32,Int32,Color) Method (Microsoft.DirectX.Direct3D)

Font.DrawText Method

Draws formatted text.

Definition

Visual Basic Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal color As Color _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
int x,
int y,
Color color
);
C++ public:
int DrawText(
Sprite^ sprite,
String^ text,
int x,
int y,
Color color
);
JScript public function DrawText(
sprite : Sprite,
text : String,
x : int,
y : int,
color : Color
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite
A Sprite object that contains the string. Can be null, in which case Microsoft Direct3D renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text System.String
String to draw.
x System.Int32
The x-coordinate where to draw the font.
y System.Int32
The y-coordinate where to draw the font.
color System.Drawing.Color
Color of the text. For more information, see Color Leave Site.

Return Value

System.Int32
If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Font.DrawText Method

Draws formatted text.

Definition

Visual Basic Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal color As Integer _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
int x,
int y,
int color
);
C++ public:
int DrawText(
Sprite^ sprite,
String^ text,
int x,
int y,
int color
);
JScript public function DrawText(
sprite : Sprite,
text : String,
x : int,
y : int,
color : int
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite
A Sprite object that contains the string. Can be null, in which case Microsoft Direct3D renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text System.String
String to draw.
x System.Int32
The x-coordinate where to draw the font.
y System.Int32
The y-coordinate where to draw the font.
color System.Int32
Integer color value.

Return Value

System.Int32
If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Point,Color) Method (Microsoft.DirectX.Direct3D)

Font.DrawText Method

Draws formatted text.

Definition

Visual Basic Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal pos As Point, _
ByVal color As Color _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
Point pos,
Color color
);
C++ public:
int DrawText(
Sprite^ sprite,
String^ text,
Point pos,
Color color
);
JScript public function DrawText(
sprite : Sprite,
text : String,
pos : Point,
color : Color
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite
A Sprite object that contains the string. Can be null, in which case Microsoft Direct3D renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text System.String
String to draw.
pos System.Drawing.Point
A Point Leave Site structure that specifies the upper left-hand coordinates of where to draw the font.
color System.Drawing.Color
Color of the text. For more information, see Color Leave Site.

Return Value

System.Int32
If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Point,Int32) Method (Microsoft.DirectX.Direct3D)

Font.DrawText Method

Draws formatted text.

Definition

Visual Basic Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal pos As Point, _
ByVal color As Integer _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
Point pos,
int color
);
C++ public:
int DrawText(
Sprite^ sprite,
String^ text,
Point pos,
int color
);
JScript public function DrawText(
sprite : Sprite,
text : String,
pos : Point,
color : int
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite
A Sprite object that contains the string. Can be null, in which case Microsoft Direct3D renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text System.String
String to draw.
pos System.Drawing.Point
A Point Leave Site structure that specifies the upper left-hand coordinates of where to draw the font.
color System.Int32
Integer color value.

Return Value

System.Int32
If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Rectangle,DrawTextFormat,Color) Method (Microsoft.DirectX.Direct3D)

Font.DrawText Method

Draws formatted text.

Definition

Visual Basic Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal rect As Rectangle, _
ByVal format As DrawTextFormat, _
ByVal color As Color _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
Rectangle rect,
DrawTextFormat format,
Color color
);
C++ public:
int DrawText(
Sprite^ sprite,
String^ text,
Rectangle rect,
DrawTextFormat format,
Color color
);
JScript public function DrawText(
sprite : Sprite,
text : String,
rect : Rectangle,
format : DrawTextFormat,
color : Color
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite
A Sprite object that contains the string. Can be null, in which case Microsoft Direct3D renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text System.String
String to draw.
rect System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the rectangle, in logical coordinates, in which the text is being formatted.
format Microsoft.DirectX.Direct3D.DrawTextFormat
Method of formatting the text; can be any combination of values from the DrawTextFormat enumeration.
color System.Drawing.Color
Color of the text. For more information, see Color Leave Site.

Return Value

System.Int32
If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.DrawText(Sprite,String,Rectangle,DrawTextFormat,Int32) Method (Microsoft.DirectX.Direct3D)

Font.DrawText Method

Draws formatted text.

Definition

Visual Basic Public Function DrawText( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal rect As Rectangle, _
ByVal format As DrawTextFormat, _
ByVal color As Integer _
) As Integer
C# public int DrawText(
Sprite sprite,
string text,
Rectangle rect,
DrawTextFormat format,
int color
);
C++ public:
int DrawText(
Sprite^ sprite,
String^ text,
Rectangle rect,
DrawTextFormat format,
int color
);
JScript public function DrawText(
sprite : Sprite,
text : String,
rect : Rectangle,
format : DrawTextFormat,
color : int
) : int;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite
A Sprite object that contains the string. Can be null, in which case Microsoft Direct3D renders the string with its own sprite object.

If Font.DrawText will be called more than once in a row, a sprite object should be specified to improve efficiency.
text System.String
String to draw.
rect System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the rectangle, in logical coordinates, in which the text is being formatted.
format Microsoft.DirectX.Direct3D.DrawTextFormat
Method of formatting the text; can be any combination of values from the DrawTextFormat enumeration.
color System.Int32
Integer color value.

Return Value

System.Int32
If the function succeeds, the return value is the height of the text in logical units. If DrawTextFormat.Center or DrawTextFormat.Bottom is specified in the format parameter, the return value is the offset from rect.Top Leave Site to the bottom of the drawn text. If the function fails, the return value is 0.

Remarks

This method must be called from inside of a Device.BeginScene ... Device.EndScene block.

Unless the NoClip format is used, this method clips the text so that it does not appear outside of the specified rectangle. All formatting is assumed to have multiple lines unless the SingleLine format is specified.

If the selected font is too large for the rectangle, this method does not attempt to substitute a smaller font.

This method supports only fonts whose escapement and orientation are both zero.


Font.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Font.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Font.Finalize() Method (Microsoft.DirectX.Direct3D)

Font.Finalize Method

Allows the Font object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Font();
C++ | !Font();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Font.Font Constructor ()

Creates a new instance of a Font class.

Overload List

public Font(Device, Font);
public Font(Device, FontDescription);
public Font(Device, int, int, FontWeight, int, bool, CharacterSet, Precision, FontQuality, PitchAndFamily, string);
public Font(ID3DXFont);
public Font(IntPtr);


Font.Font(ID3DXFont) Constructor (Microsoft.DirectX.Direct3D)

Font.Font Constructor

Creates a new instance of a Font class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXFont _
)
C# public Font(
ID3DXFont pUnk
);
C++ public:
Font(
ID3DXFont pUnk
);
JScript public function Font(
pUnk : ID3DXFont
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFont
Unmanaged Component Object Model (COM) ID3DXFont interface pointer.


Font.Font(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Font.Font Constructor

Creates a new instance of a Font class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Font(
IntPtr unmanagedObject
);
C++ public:
Font(
IntPtr unmanagedObject
);
JScript public function Font(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXFont interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Font.Font(Device,Font) Constructor (Microsoft.DirectX.Direct3D)

Font.Font Constructor

Creates a new instance of a Font class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal font As Font _
)
C# public Font(
Device device,
Font font
);
C++ public:
Font(
Device^ device,
Font^ font
);
JScript public function Font(
device : Device,
font : Font
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the font object.
font System.Drawing.Font
The Font Leave Site object.


Font.Font(Device,FontDescription) Constructor (Microsoft.DirectX.Direct3D)

Font.Font Constructor

Creates a new instance of a Font class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal description As FontDescription _
)
C# public Font(
Device device,
FontDescription description
);
C++ public:
Font(
Device^ device,
FontDescription description
);
JScript public function Font(
device : Device,
description : FontDescription
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the font object.
description Microsoft.DirectX.Direct3D.FontDescription
A FontDescription structure.


Font.Font(Device,Int32,Int32,FontWeight,Int32,Boolean,CharacterSet,Precision,FontQuality,PitchAndFamily,String) Constructor (Microsoft.DirectX.Direct3D)

Font.Font Constructor

Creates a new instance of a Font class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal height As Integer, _
ByVal width As Integer, _
ByVal weight As FontWeight, _
ByVal miplevels As Integer, _
ByVal italic As Boolean, _
ByVal charset As CharacterSet, _
ByVal outputPrecision As Precision, _
ByVal quality As FontQuality, _
ByVal pitchFamily As PitchAndFamily, _
ByVal faceName As String _
)
C# public Font(
Device device,
int height,
int width,
FontWeight weight,
int miplevels,
bool italic,
CharacterSet charset,
Precision outputPrecision,
FontQuality quality,
PitchAndFamily pitchFamily,
string faceName
);
C++ public:
Font(
Device^ device,
int height,
int width,
FontWeight weight,
int miplevels,
bool italic,
CharacterSet charset,
Precision outputPrecision,
FontQuality quality,
PitchAndFamily pitchFamily,
String^ faceName
);
JScript public function Font(
device : Device,
height : int,
width : int,
weight : FontWeight,
miplevels : int,
italic : boolean,
charset : CharacterSet,
outputPrecision : Precision,
quality : FontQuality,
pitchFamily : PitchAndFamily,
faceName : String
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the font object.
height System.Int32
Height of the font.
width System.Int32
Width of the font.
weight Microsoft.DirectX.Direct3D.FontWeight
Weight of the font.
miplevels System.Int32
Number of mip levels.
italic System.Boolean
Set to true if the font is in italics; otherwise, false.
charset Microsoft.DirectX.Direct3D.CharacterSet
A CharacterSet enumerated value that indicates the type of characters to use.
outputPrecision Microsoft.DirectX.Direct3D.Precision
A Precision constant that indicates the font precision.
quality Microsoft.DirectX.Direct3D.FontQuality
A FontQuality value that indicates the quality of the font.
pitchFamily Microsoft.DirectX.Direct3D.PitchAndFamily
A PitchAndFamily value that indicates the font pitch and family.
faceName System.String
A string that indicates the name of the font.


Font.GetGlyphData Method ()

Returns information about the placement and orientation of a glyph in a character cell.

Overload List

public Texture GetGlyphData(int);
public Texture GetGlyphData(int, out Rectangle, out Point);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.GetGlyphData(Int32) Method (Microsoft.DirectX.Direct3D)

Font.GetGlyphData Method

Returns information about the placement and orientation of a glyph in a character cell.

Definition

Visual Basic Public Function GetGlyphData( _
ByVal glyph As Integer _
) As Texture
C# public Texture GetGlyphData(
int glyph
);
C++ public:
Texture^ GetGlyphData(
int glyph
);
JScript public function GetGlyphData(
glyph : int
) : Texture;

Parameters

glyph System.Int32
Glyph identifier.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that contains the glyph.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.GetGlyphData(Int32,Rectangle,Point) Method (Microsoft.DirectX.Direct3D)

Font.GetGlyphData Method

Returns information about the placement and orientation of a glyph in a character cell.

Definition

Visual Basic Public Function GetGlyphData( _
ByVal glyph As Integer, _
ByRef blackBox As Rectangle, _
ByRef cellInc As Point _
) As Texture
C# public Texture GetGlyphData(
int glyph,
out Rectangle blackBox,
out Point cellInc
);
C++ public:
Texture^ GetGlyphData(
int glyph,
[Out] Rectangle% blackBox,
[Out] Point% cellInc
);
JScript public function GetGlyphData(
glyph : int,
blackBox : Rectangle,
cellInc : Point
) : Texture;

Parameters

glyph System.Int32
Glyph identifier.
blackBox System.Drawing.Rectangle
Smallest Rectangle Leave Site object that completely encloses the glyph (its black box).
cellInc System.Drawing.Point
A Vector2 structure that connects the origin of the current character cell to the origin of the next character cell.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that contains the glyph.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Font.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Font.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Font.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFont, which allows unmanaged COM clients to create an instance of the managed Font class. Not supported.


Font.MeasureString Method ()

Measures the rectangular dimensions of the specified text string when drawn with the specified Sprite object and formatted with the specified DrawTextFormat method of formatting text.

Overload List

public Rectangle MeasureString(Sprite, string, DrawTextFormat, Color);
public Rectangle MeasureString(Sprite, string, DrawTextFormat, int);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Font.MeasureString(Sprite,String,DrawTextFormat,Color) Method (Microsoft.DirectX.Direct3D)

Font.MeasureString Method

Measures the rectangular dimensions of the specified text string when drawn with the specified Sprite object and formatted with the specified DrawTextFormat method of formatting text.

Definition

Visual Basic Public Function MeasureString( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal format As DrawTextFormat, _
ByVal color As Color _
) As Rectangle
C# public Rectangle MeasureString(
Sprite sprite,
string text,
DrawTextFormat format,
Color color
);
C++ public:
Rectangle MeasureString(
Sprite^ sprite,
String^ text,
DrawTextFormat format,
Color color
);
JScript public function MeasureString(
sprite : Sprite,
text : String,
format : DrawTextFormat,
color : Color
) : Rectangle;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite
A Sprite object that contains the string.
text System.String
String to measure.
format Microsoft.DirectX.Direct3D.DrawTextFormat
Method of formatting the text; can be any combination of values from the DrawTextFormat enumeration.
color System.Drawing.Color
Color of the text. For more information, see Color Leave Site.

Return Value

System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the rectangle, in logical coordinates, that encompasses the formatted text string.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Font.MeasureString(Sprite,String,DrawTextFormat,Int32) Method (Microsoft.DirectX.Direct3D)

Font.MeasureString Method

Measures the rectangular dimensions of the specified text string when drawn with the specified Sprite object and formatted with the specified DrawTextFormat method of formatting text.

Definition

Visual Basic Public Function MeasureString( _
ByVal sprite As Sprite, _
ByVal text As String, _
ByVal format As DrawTextFormat, _
ByVal color As Integer _
) As Rectangle
C# public Rectangle MeasureString(
Sprite sprite,
string text,
DrawTextFormat format,
int color
);
C++ public:
Rectangle MeasureString(
Sprite^ sprite,
String^ text,
DrawTextFormat format,
int color
);
JScript public function MeasureString(
sprite : Sprite,
text : String,
format : DrawTextFormat,
color : int
) : Rectangle;

Parameters

sprite Microsoft.DirectX.Direct3D.Sprite
A Sprite object that contains the string.
text System.String
String to measure.
format Microsoft.DirectX.Direct3D.DrawTextFormat
Method of formatting the text; can be any combination of values from the DrawTextFormat enumeration.
color System.Int32
Integer color value.

Return Value

System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the rectangle, in logical coordinates, that encompasses the formatted text string.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Font.OnLostDevice() Method (Microsoft.DirectX.Direct3D)

Font.OnLostDevice Method

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic | Public Sub OnLostDevice()
C# | public void OnLostDevice();
C++ public:
void OnLostDevice();
JScript | public function OnLostDevice();


Font.OnResetDevice() Method (Microsoft.DirectX.Direct3D)

Font.OnResetDevice Method

Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic | Public Sub OnResetDevice()
C# | public void OnResetDevice();
C++ public:
void OnResetDevice();
JScript | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, it is unnecessary to call Font.OnResetDevice under normal circumstances. However, if at any point Device.IsUsingEventHandlers is set to false, Font.OnResetDevice should be called immediately after the device is reset.


Font.op_Equality(Font,Font) Method (Microsoft.DirectX.Direct3D)

Font.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Font, _
ByVal right As Font _
) As Boolean
C# public static bool op_Equality(
Font left,
Font right
);
C++ public:
static bool operator==(
Font^ left,
Font^ right
);
JScript public static function op_Equality(
left : Font,
right : Font
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Font
The Font object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Font
The Font object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Font.op_Inequality(Font,Font) Method (Microsoft.DirectX.Direct3D)

Font.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Font, _
ByVal right As Font _
) As Boolean
C# public static bool op_Inequality(
Font left,
Font right
);
C++ public:
static bool operator!=(
Font^ left,
Font^ right
);
JScript public static function op_Inequality(
left : Font,
right : Font
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Font
The Font object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Font
The Font object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Font.PreloadCharacters(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Font.PreloadCharacters Method

Loads a series of characters into video memory to improve the efficiency of rendering to a device.

Definition

Visual Basic Public Sub PreloadCharacters( _
ByVal first As Integer, _
ByVal last As Integer _
)
C# public void PreloadCharacters(
int first,
int last
);
C++ public:
void PreloadCharacters(
int first,
int last
);
JScript public function PreloadCharacters(
first : int,
last : int
);

Parameters

first System.Int32
Identifier of the first character to load into video memory.
last System.Int32
Identifier of the last character to load into video memory.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.PreloadGlyphs(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Font.PreloadGlyphs Method

Loads a series of glyphs into video memory to improve the efficiency of rendering to a device.

Definition

Visual Basic Public Sub PreloadGlyphs( _
ByVal first As Integer, _
ByVal last As Integer _
)
C# public void PreloadGlyphs(
int first,
int last
);
C++ public:
void PreloadGlyphs(
int first,
int last
);
JScript public function PreloadGlyphs(
first : int,
last : int
);

Parameters

first System.Int32
Identifier of the first glyph to load into video memory.
last System.Int32
Identifier of the last glyph to load into video memory.

Remarks

This method does not render the glyphs to the device; Font.DrawText still must be called to render the glyphs. However, pre-loading glyphs into video memory causes Font.DrawText to use substantially fewer CPU resources.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.PreloadText(String) Method (Microsoft.DirectX.Direct3D)

Font.PreloadText Method

Loads formatted text into video memory to improve the efficiency of rendering to a device.

Definition

Visual Basic Public Sub PreloadText( _
ByVal text As String _
)
C# public void PreloadText(
string text
);
C++ public:
void PreloadText(
String^ text
);
JScript public function PreloadText(
text : String
);

Parameters

text System.String
String of characters to load into video memory.

Remarks

This method does not render text to the device; Font.DrawText must still be called to render the text. However, pre-loading text into video memory causes Font.DrawText to use substantially fewer CPU resources.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Font.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Font.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Font.raise_Lost(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Font.raise_Lost Method

Raises a Font.Lost event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
C++ protected:
void raise_Lost(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Font.raise_Reset(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Font.raise_Reset Method

Raises a Font.Reset event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
C++ protected:
void raise_Reset(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Font.UpdateUnmanagedPointer(ID3DXFont) Method (Microsoft.DirectX.Direct3D)

Font.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Font object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFont _
)
C# public void UpdateUnmanagedPointer(
ID3DXFont pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXFont pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXFont
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFont
Pointer to the ID3DXFont structure used to update the unmanaged pointer for this Font object.


Font.Description Property (Microsoft.DirectX.Direct3D)

Font.Description Property

Retrieves a description of the current font object.

Definition

Visual Basic | Public ReadOnly Property Description As FontDescription
C# | public FontDescription Description { get; }
C++ public:
property FontDescription Description {
FontDescription get();
}
JScript | public function get Description() : FontDescription

Property Value

Microsoft.DirectX.Direct3D.FontDescription
A FontDescription structure that describes the font object.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.Device Property (Microsoft.DirectX.Direct3D)

Font.Device Property

Retrieves the Microsoft Direct3D device associated with a font object.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
A Device class that represents the Direct3D device associated with the font object.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Font.DeviceContext Property (Microsoft.DirectX.Direct3D)

Font.DeviceContext Property

Returns a handle to a display device context (DC) that includes the font set.

Definition

Visual Basic | Public ReadOnly Property DeviceContext As IntPtr
C# | public IntPtr DeviceContext { get; }
C++ public:
property IntPtr DeviceContext {
IntPtr get();
}
JScript | public function get DeviceContext() : IntPtr

Property Value

System.IntPtr
Handle to a display DC.

This property is read-only.


Font.Disposed Property (Microsoft.DirectX.Direct3D)

Font.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Font.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Font.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXFont interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXFont
C# | public ID3DXFont UnmanagedComPointer { get; }
C++ public:
property ID3DXFont UnmanagedComPointer {
ID3DXFont get();
}
JScript | public function get UnmanagedComPointer() : ID3DXFont

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFont
Unmanaged ID3DXFont interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Font.Disposing Event (Microsoft.DirectX.Direct3D)

Font.Disposing Event

Occurs when the Dispose method is called or when the Font object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Font.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Font object indicates whether that object has been disposed.


Font.Lost Event (Microsoft.DirectX.Direct3D)

Font.Lost Event

Occurs when an object is lost, normally just before a device is reset.

Definition

Visual Basic | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
C++ public:
event EventHandler^ Lost;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Font.Lost event, use the following C# code.

[C#]
Font.Lost += new System.EventHandler(this.LostEventHandler);


Font.Reset Event (Microsoft.DirectX.Direct3D)

Font.Reset Event

Occurs after the Font.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
C++ public:
event EventHandler^ Reset;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Font.Reset event, use the following C# code.

[C#]
Font.Reset += new System.EventHandler(this.ResetEventHandler);


FragmentLinker Class (Microsoft.DirectX.Direct3D)

FragmentLinker Class

Links shader fragments at runtime.

Definition

Visual Basic NotInheritable Public Class FragmentLinker
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class FragmentLinker : MarshalByRefObject, IDisposable
C++ | public ref class FragmentLinker sealed : MarshalByRefObject, IDisposable
JScript | public final class FragmentLinker extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the FragmentLinker object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddFragments | Adds fragments to the existing fragment linker.
ClearCache | Clears the fragment linker cache.
Dispose | Immediately releases the unmanaged resources used by the FragmentLinker object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the FragmentLinker object to free resources before it is destroyed by the garbage collector.
FragmentLinker | Initializes a new instance of the FragmentLinker class.
static (Shared in Visual Basic) GatherFragmentsFromFile | Assembles shader fragments and creates a new fragment linker object.
static (Shared in Visual Basic) GatherFragmentsFromStream | Assembles shader fragments and creates a new fragment linker object.
static (Shared in Visual Basic) GatherFragmentsFromString | Assembles shader fragments and creates a new fragment linker object.
GetFragment | Retrieves a GraphicsStream object that contains the compiled shader fragment.
GetFragmentDescription | Retrieves a FragmentDescription object.
GetFragmentHandle | Retrieves an EffectHandle object by name or by index.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
LinkPixelShader | Links a compiled pixel shader at run time.
LinkShader | Links a compiled shader at run time.
LinkVertexShader | Links a compiled shader at run time.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.FragmentLinker.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this FragmentLinker object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
AllFragments | Retrieves a GraphicsStream object that contains the compiled linker fragments.
Device | Retrieves the Device for the current fragment linker.
Disposed | Gets a value that indicates whether the object is disposed.
NumberOfFragments | Retrieves the number of fragments in the linker.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFragmentLinker interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
FragmentLinker

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • FragmentLinker Direct3D Sample


FragmentLinker.AddFragments(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.AddFragments Method

Adds fragments to the existing fragment linker.

Definition

Visual Basic Public Sub AddFragments( _
ByVal fragments As GraphicsStream _
)
C# public void AddFragments(
GraphicsStream fragments
);
C++ public:
void AddFragments(
GraphicsStream^ fragments
);
JScript public function AddFragments(
fragments : GraphicsStream
);

Parameters

fragments Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains shader fragments to add.

Remarks

Exceptions
DuplicateNamedFragmentException Multiple fragments with the same name were found. No fragments were added.


FragmentLinker.ClearCache() Method (Microsoft.DirectX.Direct3D)

FragmentLinker.ClearCache Method

Clears the fragment linker cache.

Definition

Visual Basic | Public Sub ClearCache()
C# | public void ClearCache();
C++ public:
void ClearCache();
JScript | public function ClearCache();


FragmentLinker.Dispose() Method (Microsoft.DirectX.Direct3D)

FragmentLinker.Dispose Method

Immediately releases the unmanaged resources used by the FragmentLinker object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~FragmentLinker();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.FragmentLinker.Disposed
  • Microsoft.DirectX.Direct3D.FragmentLinker.Disposing


FragmentLinker.Equals(Object) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


FragmentLinker.Finalize() Method (Microsoft.DirectX.Direct3D)

FragmentLinker.Finalize Method

Allows the FragmentLinker object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~FragmentLinker();
C++ | !FragmentLinker();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


FragmentLinker.FragmentLinker Constructor ()

Initializes a new instance of the FragmentLinker class.

Overload List

public FragmentLinker(Device, int);
public FragmentLinker(ID3DXFragmentLinker);
public FragmentLinker(IntPtr);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


FragmentLinker.FragmentLinker(ID3DXFragmentLinker) Constructor (Microsoft.DirectX.Direct3D)

FragmentLinker.FragmentLinker Constructor

Initializes a new instance of the FragmentLinker class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXFragmentLinker _
)
C# public FragmentLinker(
ID3DXFragmentLinker pUnk
);
C++ public:
FragmentLinker(
ID3DXFragmentLinker pUnk
);
JScript public function FragmentLinker(
pUnk : ID3DXFragmentLinker
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFragmentLinker
Unmanaged Component Object Model (COM) ID3DXFragmentLinker interface pointer.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


FragmentLinker.FragmentLinker(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

FragmentLinker.FragmentLinker Constructor

Initializes a new instance of the FragmentLinker class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public FragmentLinker(
IntPtr unmanagedObject
);
C++ public:
FragmentLinker(
IntPtr unmanagedObject
);
JScript public function FragmentLinker(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXFragmentLinker interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


FragmentLinker.FragmentLinker(Device,Int32) Constructor (Microsoft.DirectX.Direct3D)

FragmentLinker.FragmentLinker Constructor

Initializes a new instance of the FragmentLinker class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal shaderCacheSize As Integer _
)
C# public FragmentLinker(
Device device,
int shaderCacheSize
);
C++ public:
FragmentLinker(
Device^ device,
int shaderCacheSize
);
JScript public function FragmentLinker(
device : Device,
shaderCacheSize : int
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device to associate with the FragmentLinker.
shaderCacheSize System.Int32
Integer that represents the shader cache size.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


FragmentLinker.GatherFragmentsFromFile Method ()

Assembles shader fragments and creates a new fragment linker object.

Overload List

public static GraphicsStream GatherFragmentsFromFile(string, Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromFile(string, Macro[], Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromFile(string, Macro[], Include, ShaderFlags, out string);
public static GraphicsStream GatherFragmentsFromFile(string, ShaderFlags);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromFile(String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromFile Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromFile( _
ByVal file As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromFile(
string file,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromFile(
String^ file,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromFile(
file : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file System.String
String that represents the name of the file that contains the shader fragments.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromFile(String,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromFile Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromFile( _
ByVal file As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromFile(
string file,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromFile(
String^ file,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromFile(
file : String,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file System.String
String that represents the name of the file that contains the shader fragments.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromFile(String,Macro[],Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromFile Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromFile( _
ByVal file As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromFile(
string file,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromFile(
String^ file,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromFile(
file : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file System.String
String that represents the name of the file that contains the shader fragments.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Array of Macro objects that specify the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromFile(String,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromFile Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromFile( _
ByVal file As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromFile(
string file,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ GatherFragmentsFromFile(
String^ file,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function GatherFragmentsFromFile(
file : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

file System.String
String that represents the name of the file that contains the shader fragments.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Array of Macro objects that specify the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.
compilationErrors System.String
A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream Method ()

Assembles shader fragments and creates a new fragment linker object.

Overload List

public static GraphicsStream GatherFragmentsFromStream(Stream, Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromStream(Stream, Macro[], Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromStream(Stream, Macro[], Include, ShaderFlags, out string);
public static GraphicsStream GatherFragmentsFromStream(Stream, ShaderFlags);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream(Stream,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromStream Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromStream( _
ByVal data As Stream, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromStream(
Stream data,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromStream(
Stream^ data,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromStream(
data : Stream,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.IO.Stream
A Stream Leave Site object that contains the shader fragments.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream(Stream,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromStream Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromStream( _
ByVal data As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromStream(
Stream data,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromStream(
Stream^ data,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromStream(
data : Stream,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.IO.Stream
A Stream Leave Site object that contains the shader fragments.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream(Stream,Macro[],Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromStream Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromStream( _
ByVal data As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromStream(
Stream data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromStream(
Stream^ data,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromStream(
data : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.IO.Stream
A Stream Leave Site object that contains the shader fragments.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Array of Macro objects that specify the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromStream(Stream,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromStream Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromStream( _
ByVal data As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromStream(
Stream data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ GatherFragmentsFromStream(
Stream^ data,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function GatherFragmentsFromStream(
data : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

data System.IO.Stream
A Stream Leave Site object that contains the shader fragments.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Array of Macro objects that specify the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.
compilationErrors System.String
A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString Method ()

Assembles shader fragments and creates a new fragment linker object.

Overload List

public static GraphicsStream GatherFragmentsFromString(string, Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromString(string, Macro[], Include, ShaderFlags);
public static GraphicsStream GatherFragmentsFromString(string, Macro[], Include, ShaderFlags, out string);
public static GraphicsStream GatherFragmentsFromString(string, ShaderFlags);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString(String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromString Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromString( _
ByVal data As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromString(
string data,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromString(
String^ data,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromString(
data : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.String
A String Leave Site that contains the shader fragments.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString(String,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromString Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromString( _
ByVal data As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromString(
string data,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromString(
String^ data,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromString(
data : String,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.String
A String Leave Site that contains the shader fragments.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString(String,Macro[],Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromString Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromString( _
ByVal data As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromString(
string data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ GatherFragmentsFromString(
String^ data,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function GatherFragmentsFromString(
data : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.String
A String Leave Site that contains the shader fragments.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Array of Macro objects that specify the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GatherFragmentsFromString(String,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GatherFragmentsFromString Method

Assembles shader fragments and creates a new fragment linker object.

Definition

Visual Basic Public Shared Function GatherFragmentsFromString( _
ByVal data As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream GatherFragmentsFromString(
string data,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ GatherFragmentsFromString(
String^ data,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function GatherFragmentsFromString(
data : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

data System.String
A String Leave Site that contains the shader fragments.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Array of Macro objects that specify the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
An Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the shader compiler options to use.
compilationErrors System.String
A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the created shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragment(String) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GetFragment Method

Retrieves a GraphicsStream object that contains the compiled shader fragment.

Definition

Visual Basic Public Function GetFragment( _
ByVal name As String _
) As GraphicsStream
C# public GraphicsStream GetFragment(
string name
);
C++ public:
GraphicsStream^ GetFragment(
String^ name
);
JScript public function GetFragment(
name : String
) : GraphicsStream;

Parameters

name System.String
String that represents the name of the shader fragment.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader fragment.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragmentDescription(EffectHandle) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GetFragmentDescription Method

Retrieves a FragmentDescription object.

Definition

Visual Basic Public Function GetFragmentDescription( _
ByVal name As EffectHandle _
) As FragmentDescription
C# public FragmentDescription GetFragmentDescription(
EffectHandle name
);
C++ public:
FragmentDescription GetFragmentDescription(
EffectHandle^ name
);
JScript public function GetFragmentDescription(
name : EffectHandle
) : FragmentDescription;

Parameters

name Microsoft.DirectX.Direct3D.EffectHandle
EffectHandle that represents the shader fragment.

Return Value

Microsoft.DirectX.Direct3D.FragmentDescription
A FragmentDescription object that contains the fragment description.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • GetFragmentHandle


FragmentLinker.GetFragmentHandle Method ()

Retrieves an EffectHandle object by name or by index.

Overload List

public EffectHandle GetFragmentHandle(int);
public EffectHandle GetFragmentHandle(string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragmentHandle(String) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GetFragmentHandle Method

Retrieves an EffectHandle object by name or by index.

Definition

Visual Basic Public Function GetFragmentHandle( _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetFragmentHandle(
string name
);
C++ public:
EffectHandle^ GetFragmentHandle(
String^ name
);
JScript public function GetFragmentHandle(
name : String
) : EffectHandle;

Parameters

name System.String
String that represents the name of the shader fragment.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that contains the fragment handle.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GetFragmentHandle(Int32) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GetFragmentHandle Method

Retrieves an EffectHandle object by name or by index.

Definition

Visual Basic Public Function GetFragmentHandle( _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetFragmentHandle(
int index
);
C++ public:
EffectHandle^ GetFragmentHandle(
int index
);
JScript public function GetFragmentHandle(
index : int
) : EffectHandle;

Parameters

index System.Int32
Integer that represents the zero-based index of the shader fragment.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that contains the fragment handle.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.GetHashCode() Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


FragmentLinker.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFragmentLinker, which allows unmanaged COM clients to create an instance of the managed FragmentLinker class. Not supported.


FragmentLinker.LinkPixelShader(String,ShaderFlags,EffectHandle[],String) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.LinkPixelShader Method

Links a compiled pixel shader at run time.

Definition

Visual Basic Public Function LinkPixelShader( _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByVal fragmentHandles() As EffectHandle, _
ByRef errors As String _
) As PixelShader
C# public PixelShader LinkPixelShader(
string profile,
ShaderFlags flags,
EffectHandle[] fragmentHandles,
out string errors
);
C++ public:
PixelShader^ LinkPixelShader(
String^ profile,
ShaderFlags flags,
array<EffectHandle^>^ fragmentHandles,
[Out] String^% errors
);
JScript public function LinkPixelShader(
profile : String,
flags : ShaderFlags,
fragmentHandles : EffectHandle[],
errors : String
) : PixelShader;

Parameters

profile System.String
A String Leave Site that contains the pixel shader profile that determines the shader instruction set.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the link options to use.
fragmentHandles Microsoft.DirectX.Direct3D.EffectHandle[]
Array of EffectHandle objects that represent the handles of the fragments to link.
errors System.String
A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.Direct3D.PixelShader
A PixelShader object that contains the linked pixel shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.LinkShader(String,ShaderFlags,EffectHandle[],String) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.LinkShader Method

Links a compiled shader at run time.

Definition

Visual Basic Public Function LinkShader( _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByVal fragmentHandles() As EffectHandle, _
ByRef errors As String _
) As GraphicsStream
C# public GraphicsStream LinkShader(
string profile,
ShaderFlags flags,
EffectHandle[] fragmentHandles,
out string errors
);
C++ public:
GraphicsStream^ LinkShader(
String^ profile,
ShaderFlags flags,
array<EffectHandle^>^ fragmentHandles,
[Out] String^% errors
);
JScript public function LinkShader(
profile : String,
flags : ShaderFlags,
fragmentHandles : EffectHandle[],
errors : String
) : GraphicsStream;

Parameters

profile System.String
A String Leave Site that contains the compiled shader profile that determines the shader instruction set.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the link options to use.
fragmentHandles Microsoft.DirectX.Direct3D.EffectHandle[]
Array of EffectHandle objects that represent the handles of the fragments to link.
errors System.String
A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the linked shader. This buffer contains the compiled shader code as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.LinkVertexShader(String,ShaderFlags,EffectHandle[],String) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.LinkVertexShader Method

Links a compiled shader at run time.

Definition

Visual Basic Public Function LinkVertexShader( _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByVal fragmentHandles() As EffectHandle, _
ByRef errors As String _
) As VertexShader
C# public VertexShader LinkVertexShader(
string profile,
ShaderFlags flags,
EffectHandle[] fragmentHandles,
out string errors
);
C++ public:
VertexShader^ LinkVertexShader(
String^ profile,
ShaderFlags flags,
array<EffectHandle^>^ fragmentHandles,
[Out] String^% errors
);
JScript public function LinkVertexShader(
profile : String,
flags : ShaderFlags,
fragmentHandles : EffectHandle[],
errors : String
) : VertexShader;

Parameters

profile System.String
A String Leave Site that contains the vertex shader profile that determines the shader instruction set.
flags Microsoft.DirectX.Direct3D.ShaderFlags
A ShaderFlags enumeration that specifies the link options to use.
fragmentHandles Microsoft.DirectX.Direct3D.EffectHandle[]
Array of EffectHandle objects that represent the handles of the fragments to link.
errors System.String
A String Leave Site that contains a listing of errors and warnings that were encountered during compilation.

Return Value

Microsoft.DirectX.Direct3D.VertexShader
A VertexShader object that contains the linked vertex shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.op_Equality(FragmentLinker,FragmentLinker) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As FragmentLinker, _
ByVal right As FragmentLinker _
) As Boolean
C# public static bool op_Equality(
FragmentLinker left,
FragmentLinker right
);
C++ public:
static bool operator==(
FragmentLinker^ left,
FragmentLinker^ right
);
JScript public static function op_Equality(
left : FragmentLinker,
right : FragmentLinker
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.FragmentLinker
The FragmentLinker object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.FragmentLinker
The FragmentLinker object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


FragmentLinker.op_Inequality(FragmentLinker,FragmentLinker) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As FragmentLinker, _
ByVal right As FragmentLinker _
) As Boolean
C# public static bool op_Inequality(
FragmentLinker left,
FragmentLinker right
);
C++ public:
static bool operator!=(
FragmentLinker^ left,
FragmentLinker^ right
);
JScript public static function op_Inequality(
left : FragmentLinker,
right : FragmentLinker
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.FragmentLinker
The FragmentLinker object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.FragmentLinker
The FragmentLinker object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


FragmentLinker.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.FragmentLinker.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


FragmentLinker.UpdateUnmanagedPointer(ID3DXFragmentLinker) Method (Microsoft.DirectX.Direct3D)

FragmentLinker.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this FragmentLinker object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFragmentLinker _
)
C# public void UpdateUnmanagedPointer(
ID3DXFragmentLinker pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXFragmentLinker pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXFragmentLinker
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFragmentLinker
Pointer to the ID3DXFragmentLinker structure used to update the unmanaged pointer for this FragmentLinker object.


FragmentLinker.AllFragments Property (Microsoft.DirectX.Direct3D)

FragmentLinker.AllFragments Property

Retrieves a GraphicsStream object that contains the compiled linker fragments.

Definition

Visual Basic | Public ReadOnly Property AllFragments As GraphicsStream
C# | public GraphicsStream AllFragments { get; }
C++ public:
property GraphicsStream^ AllFragments {
GraphicsStream^ get();
}
JScript | public function get AllFragments() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled linker fragments.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


FragmentLinker.Device Property (Microsoft.DirectX.Direct3D)

FragmentLinker.Device Property

Retrieves the Device for the current fragment linker.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device object associated with the current fragment linker.

This property is read-only.


FragmentLinker.Disposed Property (Microsoft.DirectX.Direct3D)

FragmentLinker.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


FragmentLinker.NumberOfFragments Property (Microsoft.DirectX.Direct3D)

FragmentLinker.NumberOfFragments Property

Retrieves the number of fragments in the linker.

Definition

Visual Basic | Public ReadOnly Property NumberOfFragments As Integer
C# | public int NumberOfFragments { get; }
C++ public:
property int NumberOfFragments {
int get();
}
JScript | public function get NumberOfFragments() : int

Property Value

System.Int32
Integer that represents the number of fragments in the linker.

This property is read-only.


FragmentLinker.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

FragmentLinker.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXFragmentLinker interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXFragmentLinker
C# | public ID3DXFragmentLinker UnmanagedComPointer { get; }
C++ public:
property ID3DXFragmentLinker UnmanagedComPointer {
ID3DXFragmentLinker get();
}
JScript | public function get UnmanagedComPointer() : ID3DXFragmentLinker

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFragmentLinker
Unmanaged ID3DXFragmentLinker interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


FragmentLinker.Disposing Event (Microsoft.DirectX.Direct3D)

FragmentLinker.Disposing Event

Occurs when the Dispose method is called or when the FragmentLinker object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.FragmentLinker.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the FragmentLinker object indicates whether that object has been disposed.


Frame Class (Microsoft.DirectX.Direct3D)

Frame Class

Encapsulates a transform frame in a transformation frame hierarchy.

Definition

Visual Basic MustInherit Public Class Frame
Inherits Object
C# | public abstract class Frame : Object
C++ | public ref class Frame abstract : Object
JScript | public abstract class Frame extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) AppendChild | Adds a child frame to a frame.
static (Shared in Visual Basic) CalculateBoundingSphere | Computes the bounding sphere of all meshes in the frame hierarchy.
static (Shared in Visual Basic) Destroy | Destroys the subtree of frames under the root, including the root.
Finalize | Allows the Frame object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) Find | Finds the child frame of a root frame.
Frame | Initializes a new instance of the Frame class.
static (Shared in Visual Basic) GetNumberNamedMatrices | Retrieves the number of frames in a subtree that have non-null names.
static (Shared in Visual Basic) RegisterNamedMatrices | Given a frame hierarchy, registers all named matrices in the animation mixer.

Properties

Property | Description
FrameFirstChild | Retrieves the first child of the frame.
FrameSibling | Retrieves the first sibling of the current frame in the hierarchy.
MeshContainer | Retrieves or sets a MeshContainer object in a transformation frame hierarchy.
Name | Retrieves or sets the name of a frame.
TransformationMatrix | Retrieves or sets the transformation Matrix of a frame.

Inheritance Hierarchy

Object Leave Site
Frame

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Frame.AppendChild(Frame,Frame) Method (Microsoft.DirectX.Direct3D)

Frame.AppendChild Method

Adds a child frame to a frame.

Definition

Visual Basic Public Shared Sub AppendChild( _
ByVal parent As Frame, _
ByVal child As Frame _
)
C# public static void AppendChild(
Frame parent,
Frame child
);
C++ public:
static void AppendChild(
Frame^ parent,
Frame^ child
);
JScript public static function AppendChild(
parent : Frame,
child : Frame
);

Parameters

parent Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the parent node in the frame hierarchy.
child Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the child node to add to the frame hierarchy.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Frame.CalculateBoundingSphere(Frame,Vector3) Method (Microsoft.DirectX.Direct3D)

Frame.CalculateBoundingSphere Method

Computes the bounding sphere of all meshes in the frame hierarchy.

Definition

Visual Basic Public Shared Function CalculateBoundingSphere( _
ByVal frameRoot As Frame, _
ByRef center As Vector3 _
) As Single
C# public static float CalculateBoundingSphere(
Frame frameRoot,
out Vector3 center
);
C++ public:
static float CalculateBoundingSphere(
Frame^ frameRoot,
[Out] Vector3% center
);
JScript public static function CalculateBoundingSphere(
frameRoot : Frame,
center : Vector3
) : float;

Parameters

frameRoot Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the root node in the frame hierarchy.
center Microsoft.DirectX.Vector3
A Vector3 object that contains the center coordinates of the bounding sphere.

Return Value

System.Single
Floating-point value that represents the radius of the bounding sphere.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Frame.Destroy(Frame,AllocateHierarchy) Method (Microsoft.DirectX.Direct3D)

Frame.Destroy Method

Destroys the subtree of frames under the root, including the root.

Definition

Visual Basic Public Shared Sub Destroy( _
ByVal frameRoot As Frame, _
ByVal allocHierarchy As AllocateHierarchy _
)
C# public static void Destroy(
Frame frameRoot,
AllocateHierarchy allocHierarchy
);
C++ public:
static void Destroy(
Frame^ frameRoot,
AllocateHierarchy^ allocHierarchy
);
JScript public static function Destroy(
frameRoot : Frame,
allocHierarchy : AllocateHierarchy
);

Parameters

frameRoot Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the root node in the frame hierarchy.
allocHierarchy Microsoft.DirectX.Direct3D.AllocateHierarchy
An AllocateHierarchy object used to deallocate nodes of the frame hierarchy.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Frame.Finalize() Method (Microsoft.DirectX.Direct3D)

Frame.Finalize Method

Allows the Frame object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Frame();
C++ | !Frame();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Frame.Find(Frame,String) Method (Microsoft.DirectX.Direct3D)

Frame.Find Method

Finds the child frame of a root frame.

Definition

Visual Basic Public Shared Function Find( _
ByVal frameRoot As Frame, _
ByVal name As String _
) As Frame
C# public static Frame Find(
Frame frameRoot,
string name
);
C++ public:
static Frame^ Find(
Frame^ frameRoot,
String^ name
);
JScript public static function Find(
frameRoot : Frame,
name : String
) : Frame;

Parameters

frameRoot Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the root node in the frame hierarchy.
name System.String
String that represents the name of the child frame to find.

Return Value

Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the located child frame.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Frame.Frame() Constructor (Microsoft.DirectX.Direct3D)

Frame.Frame Constructor

Initializes a new instance of the Frame class.

Definition

Visual Basic | Public Sub New()
C# | public Frame();
C++ public:
Frame();
JScript | public function Frame();


Frame.GetNumberNamedMatrices(Frame) Method (Microsoft.DirectX.Direct3D)

Frame.GetNumberNamedMatrices Method

Retrieves the number of frames in a subtree that have non-null names.

Definition

Visual Basic Public Shared Function GetNumberNamedMatrices( _
ByVal frameRoot As Frame _
) As Integer
C# public static int GetNumberNamedMatrices(
Frame frameRoot
);
C++ public:
static int GetNumberNamedMatrices(
Frame^ frameRoot
);
JScript public static function GetNumberNamedMatrices(
frameRoot : Frame
) : int;

Parameters

frameRoot Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the root node of the subtree.

Return Value

System.Int32
Integer that represents the number of frames that have non-null names.


Frame.RegisterNamedMatrices(Frame,AnimationController) Method (Microsoft.DirectX.Direct3D)

Frame.RegisterNamedMatrices Method

Given a frame hierarchy, registers all named matrices in the animation mixer.

Definition

Visual Basic Public Shared Sub RegisterNamedMatrices( _
ByVal frameRoot As Frame, _
ByVal animationMixer As AnimationController _
)
C# public static void RegisterNamedMatrices(
Frame frameRoot,
AnimationController animationMixer
);
C++ public:
static void RegisterNamedMatrices(
Frame^ frameRoot,
AnimationController^ animationMixer
);
JScript public static function RegisterNamedMatrices(
frameRoot : Frame,
animationMixer : AnimationController
);

Parameters

frameRoot Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the root node in the frame hierarchy.
animationMixer Microsoft.DirectX.Direct3D.AnimationController
An AnimationController object that represents the animation mixer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Frame.FrameFirstChild Property (Microsoft.DirectX.Direct3D)

Frame.FrameFirstChild Property

Retrieves the first child of the frame.

Definition

Visual Basic | Public ReadOnly Property FrameFirstChild As Frame
C# | public Frame FrameFirstChild { get; }
C++ public:
property Frame^ FrameFirstChild {
Frame^ get();
}
JScript | public function get FrameFirstChild() : Frame

Property Value

Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the first child of the frame.

This property is read-only.


Frame.FrameSibling Property (Microsoft.DirectX.Direct3D)

Frame.FrameSibling Property

Retrieves the first sibling of the current frame in the hierarchy.

Definition

Visual Basic | Public ReadOnly Property FrameSibling As Frame
C# | public Frame FrameSibling { get; }
C++ public:
property Frame^ FrameSibling {
Frame^ get();
}
JScript | public function get FrameSibling() : Frame

Property Value

Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the first sibling of the frame.

This property is read-only.


Frame.MeshContainer Property (Microsoft.DirectX.Direct3D)

Frame.MeshContainer Property

Retrieves or sets a MeshContainer object in a transformation frame hierarchy.

Definition

Visual Basic | Public Property MeshContainer As MeshContainer
C# | public MeshContainer MeshContainer { get; set; }
C++ public:
property MeshContainer^ MeshContainer {
MeshContainer^ get();
void set(MeshContainer^ value);
}
JScript public function get MeshContainer() : MeshContainer
public function set MeshContainer(MeshContainer);

Property Value

Microsoft.DirectX.Direct3D.MeshContainer
A MeshContainer object.

This property is read/write.


Frame.Name Property (Microsoft.DirectX.Direct3D)

Frame.Name Property

Retrieves or sets the name of a frame.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String
A String Leave Site that represents the name of the frame.

This property is read/write.


Frame.TransformationMatrix Property (Microsoft.DirectX.Direct3D)

Frame.TransformationMatrix Property

Retrieves or sets the transformation Matrix of a frame.

Definition

Visual Basic | Public Property TransformationMatrix As Matrix
C# | public Matrix TransformationMatrix { get; set; }
C++ public:
property Matrix TransformationMatrix {
Matrix get();
void set(Matrix value);
}
JScript public function get TransformationMatrix() : Matrix
public function set TransformationMatrix(Matrix);

Property Value

Microsoft.DirectX.Matrix
A Matrix object that represents the transformation matrix of the frame.

This property is read/write.


Geometry Class (Microsoft.DirectX.Direct3D)

Geometry Class

How Do I...?
  • Compute a Bounding Sphere from a Mesh

Contains miscellaneous math-related functions.

Definition

Visual Basic NotInheritable MustInherit Public Class Geometry
Inherits Object
C# | public abstract sealed class Geometry : Object
C++ | public ref class Geometry abstract sealed : Object
JScript | public final abstract class Geometry extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) BoxBoundProbe | Determines whether a ray intersects the volume of a bounding box.
static (Shared in Visual Basic) ComputeBoundingBox | Computes a coordinate axis-oriented bounding box.
static (Shared in Visual Basic) ComputeBoundingSphere | Computes a bounding sphere for a mesh.
static (Shared in Visual Basic) ComputeTangentFrame | Performs tangent frame computations on a mesh. Tangent, binormal, and optionally normal vectors are generated. Singularities are handled as required by grouping edges and splitting vertices.
static (Shared in Visual Basic) DegreeToRadian | Converts degrees to radians.
static (Shared in Visual Basic) FresnelTerm | Calculates the Fresnel term.
static (Shared in Visual Basic) IntersectTri | Computes the intersection of a ray and a triangle.
static (Shared in Visual Basic) OptimizeFaces | Optimizes a set of faces.
static (Shared in Visual Basic) OptimizeVertices | Optimizes a set of vertices.
static (Shared in Visual Basic) RadianToDegree | Converts radians to degrees.
static (Shared in Visual Basic) SphereBoundProbe | Determines whether a ray intersects the volume of a sphere's bounding box.

Inheritance Hierarchy

Object Leave Site
Geometry

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Geometry.BoxBoundProbe(Vector3,Vector3,Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.BoxBoundProbe Method

Determines whether a ray intersects the volume of a bounding box.

Definition

Visual Basic Public Shared Function BoxBoundProbe( _
ByVal min As Vector3, _
ByVal max As Vector3, _
ByVal rayPosition As Vector3, _
ByVal rayDirection As Vector3 _
) As Boolean
C# public static bool BoxBoundProbe(
Vector3 min,
Vector3 max,
Vector3 rayPosition,
Vector3 rayDirection
);
C++ public:
static bool BoxBoundProbe(
Vector3 min,
Vector3 max,
Vector3 rayPosition,
Vector3 rayDirection
);
JScript public static function BoxBoundProbe(
min : Vector3,
max : Vector3,
rayPosition : Vector3,
rayDirection : Vector3
) : boolean;

Parameters

min Microsoft.DirectX.Vector3
A Vector3 structure that describes the lower-left corner of the bounding box. See Remarks.
max Microsoft.DirectX.Vector3
A Vector3 structure that describes the upper-right corner of the bounding box. See Remarks.
rayPosition Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDirection Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray. This vector should not be (0,0,0), but does not need to be normalized.

Return Value

System.Boolean
Value that is true if the ray intersects the volume of the bounding box, or false if it does not.

Remarks

The Geometry.BoxBoundProbe method determines whether the ray intersects the volume of the bounding box, not just the surface of the box.

The values passed to Geometry.BoxBoundProbe are xmin, xmax, ymin, ymax, zmin, and zmax. Thus, the following defines the corners of the bounding box.

xmax, ymax, zmax
xmax, ymax, zmin
xmax, ymin, zmax
xmax, ymin, zmin
xmin, ymax, zmax
xmin, ymax, zmin
xmin, ymin, zmax
xmin, ymin, zmin

The depth of the bounding box is zmax - zmin in the z direction; ymax - ymin in the y direction, and xmax - xmin in the x direction. For example, with the following minimum and maximum vectors, min (-1, -1, -1) and max (1, 1, 1), the bounding box is defined as follows.

 1,  1,  1
 1,  1, -1
 1, -1,  1
 1, -1, -1
-1,  1,  1
-1,  1, -1
-1, -1,  1
-1, -1, -1

See Also

  • ComputeBoundingBox


Geometry.ComputeBoundingBox Method ()

Computes a coordinate axis-oriented bounding box.

Overload List

public static void ComputeBoundingBox(Array, int, out Vector3, out Vector3);
public static void ComputeBoundingBox(Array, VertexFormats, out Vector3, out Vector3);
public static void ComputeBoundingBox(GraphicsStream, int, int, out Vector3, out Vector3);
public static void ComputeBoundingBox(GraphicsStream, int, VertexFormats, out Vector3, out Vector3);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingBox(GraphicsStream,Int32,VertexFormats,Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeBoundingBox Method

Computes a coordinate axis-oriented bounding box.

Definition

Visual Basic Public Shared Sub ComputeBoundingBox( _
ByVal pointsFvf As GraphicsStream, _
ByVal numVertices As Integer, _
ByVal vertexFormat As VertexFormats, _
ByRef min As Vector3, _
ByRef max As Vector3 _
)
C# public static void ComputeBoundingBox(
GraphicsStream pointsFvf,
int numVertices,
VertexFormats vertexFormat,
out Vector3 min,
out Vector3 max
);
C++ public:
static void ComputeBoundingBox(
GraphicsStream^ pointsFvf,
int numVertices,
VertexFormats vertexFormat,
[Out] Vector3% min,
[Out] Vector3% max
);
JScript public static function ComputeBoundingBox(
pointsFvf : GraphicsStream,
numVertices : int,
vertexFormat : VertexFormats,
min : Vector3,
max : Vector3
);

Parameters

pointsFvf Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the points around which the bounding box is constructed.
numVertices System.Int32
Number of vertices.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object that specifies the format of the vertices that are passed in.
min Microsoft.DirectX.Vector3
A Vector3 structure that describes the returned lower-left corner of the bounding box.
max Microsoft.DirectX.Vector3
A Vector3 structure that describes the returned upper-right corner of the bounding box.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingBox(Array,VertexFormats,Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeBoundingBox Method

Computes a coordinate axis-oriented bounding box.

Definition

Visual Basic Public Shared Sub ComputeBoundingBox( _
ByVal pointsFvf As Array, _
ByVal vertexFormat As VertexFormats, _
ByRef min As Vector3, _
ByRef max As Vector3 _
)
C# public static void ComputeBoundingBox(
Array pointsFvf,
VertexFormats vertexFormat,
out Vector3 min,
out Vector3 max
);
C++ public:
static void ComputeBoundingBox(
Array^ pointsFvf,
VertexFormats vertexFormat,
[Out] Vector3% min,
[Out] Vector3% max
);
JScript public static function ComputeBoundingBox(
pointsFvf : Array,
vertexFormat : VertexFormats,
min : Vector3,
max : Vector3
);

Parameters

pointsFvf System.Array
Array that contains the points around which the bounding box is constructed.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object that specifies the format of the vertices that are passed in.
min Microsoft.DirectX.Vector3
A Vector3 structure that describes the returned lower-left corner of the bounding box.
max Microsoft.DirectX.Vector3
A Vector3 structure that describes the returned upper-right corner of the bounding box.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingBox(GraphicsStream,Int32,Int32,Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeBoundingBox Method

Computes a coordinate axis-oriented bounding box.

Definition

Visual Basic Public Shared Sub ComputeBoundingBox( _
ByVal pointsFvf As GraphicsStream, _
ByVal numVertices As Integer, _
ByVal strideSize As Integer, _
ByRef min As Vector3, _
ByRef max As Vector3 _
)
C# public static void ComputeBoundingBox(
GraphicsStream pointsFvf,
int numVertices,
int strideSize,
out Vector3 min,
out Vector3 max
);
C++ public:
static void ComputeBoundingBox(
GraphicsStream^ pointsFvf,
int numVertices,
int strideSize,
[Out] Vector3% min,
[Out] Vector3% max
);
JScript public static function ComputeBoundingBox(
pointsFvf : GraphicsStream,
numVertices : int,
strideSize : int,
min : Vector3,
max : Vector3
);

Parameters

pointsFvf Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the points around which the bounding box is constructed.
numVertices System.Int32
Number of vertices.
strideSize System.Int32
min Microsoft.DirectX.Vector3
A Vector3 structure that describes the returned lower-left corner of the bounding box.
max Microsoft.DirectX.Vector3
A Vector3 structure that describes the returned upper-right corner of the bounding box.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingBox(Array,Int32,Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeBoundingBox Method

Computes a coordinate axis-oriented bounding box.

Definition

Visual Basic Public Shared Sub ComputeBoundingBox( _
ByVal pointsFvf As Array, _
ByVal strideSize As Integer, _
ByRef min As Vector3, _
ByRef max As Vector3 _
)
C# public static void ComputeBoundingBox(
Array pointsFvf,
int strideSize,
out Vector3 min,
out Vector3 max
);
C++ public:
static void ComputeBoundingBox(
Array^ pointsFvf,
int strideSize,
[Out] Vector3% min,
[Out] Vector3% max
);
JScript public static function ComputeBoundingBox(
pointsFvf : Array,
strideSize : int,
min : Vector3,
max : Vector3
);

Parameters

pointsFvf System.Array
Array that contains the points around which the bounding box is constructed.
strideSize System.Int32
min Microsoft.DirectX.Vector3
A Vector3 structure that describes the returned lower-left corner of the bounding box.
max Microsoft.DirectX.Vector3
A Vector3 structure that describes the returned upper-right corner of the bounding box.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Geometry.ComputeBoundingSphere Method ()

How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Overload List

public static float ComputeBoundingSphere(Array, int, out Vector3);
public static float ComputeBoundingSphere(Array, VertexFormats, out Vector3);
public static float ComputeBoundingSphere(GraphicsStream, int, int, out Vector3);
public static float ComputeBoundingSphere(GraphicsStream, int, VertexFormats, out Vector3);

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeBoundingSphere(GraphicsStream,Int32,VertexFormats,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeBoundingSphere Method

How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Definition

Visual Basic Public Shared Function ComputeBoundingSphere( _
ByVal pointsFvf As GraphicsStream, _
ByVal numVertices As Integer, _
ByVal vertexFormat As VertexFormats, _
ByRef center As Vector3 _
) As Single
C# public static float ComputeBoundingSphere(
GraphicsStream pointsFvf,
int numVertices,
VertexFormats vertexFormat,
out Vector3 center
);
C++ public:
static float ComputeBoundingSphere(
GraphicsStream^ pointsFvf,
int numVertices,
VertexFormats vertexFormat,
[Out] Vector3% center
);
JScript public static function ComputeBoundingSphere(
pointsFvf : GraphicsStream,
numVertices : int,
vertexFormat : VertexFormats,
center : Vector3
) : float;

Parameters

pointsFvf Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the points around which the bounding sphere is constructed.
numVertices System.Int32
Number of vertices.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object that specifies the format of the vertices that are passed in.
center Microsoft.DirectX.Vector3
A Vector3 structure that defines the coordinate center of the returned bounding sphere.

Return Value

System.Single
Radius of the returned bounding sphere.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeBoundingSphere(Array,VertexFormats,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeBoundingSphere Method

How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Definition

Visual Basic Public Shared Function ComputeBoundingSphere( _
ByVal pointsFvf As Array, _
ByVal vertexFormat As VertexFormats, _
ByRef center As Vector3 _
) As Single
C# public static float ComputeBoundingSphere(
Array pointsFvf,
VertexFormats vertexFormat,
out Vector3 center
);
C++ public:
static float ComputeBoundingSphere(
Array^ pointsFvf,
VertexFormats vertexFormat,
[Out] Vector3% center
);
JScript public static function ComputeBoundingSphere(
pointsFvf : Array,
vertexFormat : VertexFormats,
center : Vector3
) : float;

Parameters

pointsFvf System.Array
Array that contains the points around which the bounding box is constructed.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object that specifies the format of the vertices that are passed in.
center Microsoft.DirectX.Vector3
A Vector3 structure that defines the coordinate center of the returned bounding sphere.

Return Value

System.Single
Radius of the returned bounding sphere.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeBoundingSphere(GraphicsStream,Int32,Int32,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeBoundingSphere Method

How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Definition

Visual Basic Public Shared Function ComputeBoundingSphere( _
ByVal pointsFvf As GraphicsStream, _
ByVal numVertices As Integer, _
ByVal strideSize As Integer, _
ByRef center As Vector3 _
) As Single
C# public static float ComputeBoundingSphere(
GraphicsStream pointsFvf,
int numVertices,
int strideSize,
out Vector3 center
);
C++ public:
static float ComputeBoundingSphere(
GraphicsStream^ pointsFvf,
int numVertices,
int strideSize,
[Out] Vector3% center
);
JScript public static function ComputeBoundingSphere(
pointsFvf : GraphicsStream,
numVertices : int,
strideSize : int,
center : Vector3
) : float;

Parameters

pointsFvf Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the points around which the bounding sphere is constructed.
numVertices System.Int32
Number of vertices.
strideSize System.Int32
center Microsoft.DirectX.Vector3
A Vector3 structure that defines the coordinate center of the returned bounding sphere.

Return Value

System.Single
Radius of the returned bounding sphere.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeBoundingSphere(Array,Int32,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeBoundingSphere Method

How Do I...?
  • Compute a Bounding Sphere from a Mesh

Computes a bounding sphere for a mesh.

Definition

Visual Basic Public Shared Function ComputeBoundingSphere( _
ByVal pointsFvf As Array, _
ByVal strideSize As Integer, _
ByRef center As Vector3 _
) As Single
C# public static float ComputeBoundingSphere(
Array pointsFvf,
int strideSize,
out Vector3 center
);
C++ public:
static float ComputeBoundingSphere(
Array^ pointsFvf,
int strideSize,
[Out] Vector3% center
);
JScript public static function ComputeBoundingSphere(
pointsFvf : Array,
strideSize : int,
center : Vector3
) : float;

Parameters

pointsFvf System.Array
Array that contains the points around which the bounding box is constructed.
strideSize System.Int32
center Microsoft.DirectX.Vector3
A Vector3 structure that defines the coordinate center of the returned bounding sphere.

Return Value

System.Single
Radius of the returned bounding sphere.

How Do I...?

Compute a Bounding Sphere from a Mesh

This example shows how to generate a simple bounding sphere around a 3-D object, using the Geometry.ComputeBoundingSphere method. A bounding sphere has many possible uses in 3-D graphics; for example, to help test whether one 3-D object intersects with another.

In the following C# code example, a vertex buffer is created from the vertex data of the mesh object. The new vertex buffer is then locked so that Geometry algorithms can be computed on it. The output of the ComputeBoundingSphere is the radius from the center to the farthest extremity of the mesh object. The mesh object is assumed to be a valid mesh loaded with Mesh.FromFile.

              [C#]

float objectRadius = 0.0f;
Vector3 objectCenter = new Vector3();

using (VertexBuffer vb = Mesh.VertexBuffer)
{
    GraphicsStream vertexData = vb.Lock(0, 0, LockFlags.None);
    objectRadius = Geometry.ComputeBoundingSphere(vertexData,
                                                  mesh.NumberVertices,
                                                  mesh.VertexFormat,
                                                  out objectCenter);
    vb.Unlock();
}


Geometry.ComputeTangentFrame(Mesh,Int32,Int32,Int32,Int32,Int32,Int32,Int32,Int32,TangentOptions,GraphicsStream,Single,Single,Single,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Geometry.ComputeTangentFrame Method

Performs tangent frame computations on a mesh. Tangent, binormal, and optionally normal vectors are generated. Singularities are handled as required by grouping edges and splitting vertices.

Definition

Visual Basic Public Shared Function ComputeTangentFrame( _
ByVal mesh As Mesh, _
ByVal textureInSemantic As Integer, _
ByVal textureInIndex As Integer, _
ByVal upartialOutSemantic As Integer, _
ByVal upartialOutIndex As Integer, _
ByVal vpartialOutSemantic As Integer, _
ByVal vpartialOutIndex As Integer, _
ByVal normalOutSemantic As Integer, _
ByVal normalOutIndex As Integer, _
ByVal options As TangentOptions, _
ByVal adjacency As GraphicsStream, _
ByVal partialEdgeTreshold As Single, _
ByVal singularPointThreshold As Single, _
ByVal normalEdgeThreshold As Single, _
ByRef vertexRemapping As GraphicsStream _
) As Mesh
C# public static Mesh ComputeTangentFrame(
Mesh mesh,
int textureInSemantic,
int textureInIndex,
int upartialOutSemantic,
int upartialOutIndex,
int vpartialOutSemantic,
int vpartialOutIndex,
int normalOutSemantic,
int normalOutIndex,
TangentOptions options,
GraphicsStream adjacency,
float partialEdgeTreshold,
float singularPointThreshold,
float normalEdgeThreshold,
out GraphicsStream vertexRemapping
);
C++ public:
static Mesh^ ComputeTangentFrame(
Mesh^ mesh,
int textureInSemantic,
int textureInIndex,
int upartialOutSemantic,
int upartialOutIndex,
int vpartialOutSemantic,
int vpartialOutIndex,
int normalOutSemantic,
int normalOutIndex,
TangentOptions options,
GraphicsStream^ adjacency,
float partialEdgeTreshold,
float singularPointThreshold,
float normalEdgeThreshold,
[Out] GraphicsStream^% vertexRemapping
);
JScript public static function ComputeTangentFrame(
mesh : Mesh,
textureInSemantic : int,
textureInIndex : int,
upartialOutSemantic : int,
upartialOutIndex : int,
vpartialOutSemantic : int,
vpartialOutIndex : int,
normalOutSemantic : int,
normalOutIndex : int,
options : TangentOptions,
adjacency : GraphicsStream,
partialEdgeTreshold : float,
singularPointThreshold : float,
normalEdgeThreshold : float,
vertexRemapping : GraphicsStream
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Input Mesh mesh object.
textureInSemantic System.Int32
Specifies the name of the semantic declaration to use for reading texture coordinates, typically TextureCoordinate.
textureInIndex System.Int32
If a mesh has multiple texture coordinates, specifies the texture coordinate to use for the tangent frame computations. If zero, the mesh has only a single texture coordinate.
upartialOutSemantic System.Int32
Specifies the DeclarationUsage type, typically BiNormal, that describes where the partial derivative with respect to the u texture coordinate will be stored.
upartialOutIndex System.Int32
Specifies the semantic index at which to store the partial derivative with respect to the u texture coordinate.
vpartialOutSemantic System.Int32
Specifies the DeclarationUsage type, typically BiNormal, that describes where the partial derivative with respect to the v texture coordinate will be stored.
vpartialOutIndex System.Int32
Specifies the semantic index at which to store the partial derivative with respect to the v texture coordinate.
normalOutSemantic System.Int32
Specifies the DeclarationUsage type, typically Normal, that describes where the normal vector at each vertex will be stored.
normalOutIndex System.Int32
Specifies the semantic index at which to store the normal vector at each vertex.
options Microsoft.DirectX.Direct3D.TangentOptions
Combination of one or more TangentOptions values that specify tangent frame computation options. If zero, the following options will be specified: & !( WeightByArea | WeightEqual | OrthogonalizeFromU | OrthogonalizeFromV | WrapUV | DontNormalizePartials | WindClockwise | CalculateNormals ).
adjacency Microsoft.DirectX.GraphicsStream
GraphicsStream object that represents an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
partialEdgeTreshold System.Single
Specifies the maximum cosine of the angle at which two partial derivatives are deemed to be incompatible with each other. If the dot product of the direction of the two partial derivatives in adjacent triangles is less than or equal to this threshold, then the vertices shared between these triangles will be split.
singularPointThreshold System.Single
Specifies the maximum magnitude of a partial derivative at which a vertex will be deemed singular. As multiple triangles are incident on a point that have nearby tangent frames, but altogether cancel each other out (such as at the top of a sphere), the magnitude of the partial derivative will decrease. If the magnitude is less than or equal to this threshold, then the vertex will be split for every triangle that contains it.
normalEdgeThreshold System.Single
Similar to partialEdgeTreshold, specifies the maximum cosine of the angle between two normals that is a threshold beyond which vertices shared between triangles will be split. If the dot product of the two normals is less than the threshold, the shared vertices will be split, forming a hard edge between neighboring triangles. If the dot product is more than the threshold, neighboring triangles will have their normals interpolated.
vertexRemapping Microsoft.DirectX.GraphicsStream
Output GraphicsStream object that receives a mapping of new vertices computed by this method to the original vertices.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Output Mesh mesh object that receives the computed tangent, binormal, and normal vector data.

Remarks

A simplified version of this function is available as Mesh.ComputeTangentFrame.

The computed normal vector at each vertex is always normalized to have unit length.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.ComputeTangentFrame

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Geometry.DegreeToRadian(Single) Method (Microsoft.DirectX.Direct3D)

Geometry.DegreeToRadian Method

Converts degrees to radians.

Definition

Visual Basic Public Shared Function DegreeToRadian( _
ByVal degree As Single _
) As Single
C# public static float DegreeToRadian(
float degree
);
C++ public:
static float DegreeToRadian(
float degree
);
JScript public static function DegreeToRadian(
degree : float
) : float;

Parameters

degree System.Single
Value, in degrees, to convert to radians.

Return Value

System.Single
Converted value in radians.

Remarks

This method uses the following formula to compute radians:

degree * (3.141592654f/180.0f)

See Also

  • Geometry.RadianToDegree


Geometry.FresnelTerm(Single,Single) Method (Microsoft.DirectX.Direct3D)

Geometry.FresnelTerm Method

Calculates the Fresnel term.

Definition

Visual Basic Public Shared Function FresnelTerm( _
ByVal cosTheta As Single, _
ByVal refractionIndex As Single _
) As Single
C# public static float FresnelTerm(
float cosTheta,
float refractionIndex
);
C++ public:
static float FresnelTerm(
float cosTheta,
float refractionIndex
);
JScript public static function FresnelTerm(
cosTheta : float,
refractionIndex : float
) : float;

Parameters

cosTheta System.Single
Cosine of the incident angle; must be between 0 and 1.
refractionIndex System.Single
Refraction index of a material; must be greater than 1.

Return Value

System.Single
Fresnel term for unpolarized light.

Remarks

To find the Fresnel term, use the following equation.

If F is the Fresnel term, A is the angle of incidence, and B is the angle of refraction, then

F = 0.5 * [tan2(A - B) / tan2(A + B) + sin2(A - B) / sin2(A + B)]
  = 0.5 * sin2(A - B) / sin2(A + B) * [cos2(A + B) / cos2(A - B) + 1]

Let r   = sina(A) / sin(B)      (the relative refractive index)
Let c   = cos(A)
Let g   = (r2 + c2 - 1)1/2

Then, expand using the trigonometric identities and simplifying to produce the following result.

F = 0.5 * (g + c)2 / (g - c)2 * ([c(g + c) - 1]2 / [c(g - c) + 1]2 + 1)


Geometry.IntersectTri(Vector3,Vector3,Vector3,Vector3,Vector3,IntersectInformation) Method (Microsoft.DirectX.Direct3D)

Geometry.IntersectTri Method

Computes the intersection of a ray and a triangle.

Definition

Visual Basic Public Shared Function IntersectTri( _
ByVal zero As Vector3, _
ByVal one As Vector3, _
ByVal two As Vector3, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef hitLocation As IntersectInformation _
) As Boolean
C# public static bool IntersectTri(
Vector3 zero,
Vector3 one,
Vector3 two,
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation hitLocation
);
C++ public:
static bool IntersectTri(
Vector3 zero,
Vector3 one,
Vector3 two,
Vector3 rayPos,
Vector3 rayDir,
[Out] IntersectInformation% hitLocation
);
JScript public static function IntersectTri(
zero : Vector3,
one : Vector3,
two : Vector3,
rayPos : Vector3,
rayDir : Vector3,
hitLocation : IntersectInformation
) : boolean;

Parameters

zero Microsoft.DirectX.Vector3
A Vector3 structure that describes the first triangle vertex position.
one Microsoft.DirectX.Vector3
A Vector3 structure that describes the second triangle vertex position.
two Microsoft.DirectX.Vector3
A Vector3 structure that describes the third triangle vertex position.
rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the position of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.
hitLocation Microsoft.DirectX.Direct3D.IntersectInformation
An IntersectInformation structure that indicates the coordinates at which the ray intersects with the triangle.

Return Value

System.Boolean
Value that is true if the ray intersects the area of the triangle, or false if it does not.

Remarks

The IntersectTri method provides a way to understand points in and around a triangle, regardless of its location. This function returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, while the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using barycentric coordinates represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.


Geometry.OptimizeFaces Method ()

Optimizes a set of faces.

Overload List

public static int[] OptimizeFaces(short[], int);
public static int[] OptimizeFaces(int[], int);


Geometry.OptimizeFaces(Int32[],Int32) Method (Microsoft.DirectX.Direct3D)

Geometry.OptimizeFaces Method

Optimizes a set of faces.

Definition

Visual Basic Public Shared Function OptimizeFaces( _
ByVal indices() As Integer, _
ByVal numberVertices As Integer _
) As Integer()
C# public static int[] OptimizeFaces(
int[] indices,
int numberVertices
);
C++ public:
static array<int>^ OptimizeFaces(
array<int>^ indices,
int numberVertices
);
JScript public static function OptimizeFaces(
indices : int[],
numberVertices : int
) : int[];

Parameters

indices System.Int32[]
Array of 32-bit indices that indicate the mesh faces to optimize.
numberVertices System.Int32
Number of vertices in the mesh to optimize.

Return Value

System.Int32[]
Array of Int32 Leave Site values that represent the optimized faces.


Geometry.OptimizeFaces(Int16[],Int32) Method (Microsoft.DirectX.Direct3D)

Geometry.OptimizeFaces Method

Optimizes a set of faces.

Definition

Visual Basic Public Shared Function OptimizeFaces( _
ByVal indices() As Short, _
ByVal numberVertices As Integer _
) As Integer()
C# public static int[] OptimizeFaces(
short[] indices,
int numberVertices
);
C++ public:
static array<int>^ OptimizeFaces(
array<short>^ indices,
int numberVertices
);
JScript public static function OptimizeFaces(
indices : short[],
numberVertices : int
) : int[];

Parameters

indices System.Int16[]
Array of 16-bit indices that indicate the mesh faces to optimize.
numberVertices System.Int32
Number of vertices in the mesh to optimize.

Return Value

System.Int32[]
Array of Int32 Leave Site values that represent the optimized faces.


Geometry.OptimizeVertices Method ()

Optimizes a set of vertices.

Overload List

public static int[] OptimizeVertices(short[], int);
public static int[] OptimizeVertices(int[], int);


Geometry.OptimizeVertices(Int32[],Int32) Method (Microsoft.DirectX.Direct3D)

Geometry.OptimizeVertices Method

Optimizes a set of vertices.

Definition

Visual Basic Public Shared Function OptimizeVertices( _
ByVal indices() As Integer, _
ByVal numberVertices As Integer _
) As Integer()
C# public static int[] OptimizeVertices(
int[] indices,
int numberVertices
);
C++ public:
static array<int>^ OptimizeVertices(
array<int>^ indices,
int numberVertices
);
JScript public static function OptimizeVertices(
indices : int[],
numberVertices : int
) : int[];

Parameters

indices System.Int32[]
Array of 32-bit indices that indicate the vertices to optimize.
numberVertices System.Int32
Number of vertices to optimize.

Return Value

System.Int32[]
Optimized vertices.


Geometry.OptimizeVertices(Int16[],Int32) Method (Microsoft.DirectX.Direct3D)

Geometry.OptimizeVertices Method

Optimizes a set of vertices.

Definition

Visual Basic Public Shared Function OptimizeVertices( _
ByVal indices() As Short, _
ByVal numberVertices As Integer _
) As Integer()
C# public static int[] OptimizeVertices(
short[] indices,
int numberVertices
);
C++ public:
static array<int>^ OptimizeVertices(
array<short>^ indices,
int numberVertices
);
JScript public static function OptimizeVertices(
indices : short[],
numberVertices : int
) : int[];

Parameters

indices System.Int16[]
Array of 16-bit indices that indicate the vertices to optimize.
numberVertices System.Int32
Number of vertices to optimize.

Return Value

System.Int32[]
Optimized vertices.


Geometry.RadianToDegree(Single) Method (Microsoft.DirectX.Direct3D)

Geometry.RadianToDegree Method

Converts radians to degrees.

Definition

Visual Basic Public Shared Function RadianToDegree( _
ByVal radian As Single _
) As Single
C# public static float RadianToDegree(
float radian
);
C++ public:
static float RadianToDegree(
float radian
);
JScript public static function RadianToDegree(
radian : float
) : float;

Parameters

radian System.Single
Value, in radians, to convert to degrees.

Return Value

System.Single
Converted value in degrees.

Remarks

This method uses the following value for pi to compute radians:

3.141592654f


Geometry.SphereBoundProbe(Vector3,Single,Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

Geometry.SphereBoundProbe Method

Determines whether a ray intersects the volume of a sphere's bounding box.

Definition

Visual Basic Public Shared Function SphereBoundProbe( _
ByVal center As Vector3, _
ByVal radius As Single, _
ByVal rayPosition As Vector3, _
ByVal rayDirection As Vector3 _
) As Boolean
C# public static bool SphereBoundProbe(
Vector3 center,
float radius,
Vector3 rayPosition,
Vector3 rayDirection
);
C++ public:
static bool SphereBoundProbe(
Vector3 center,
float radius,
Vector3 rayPosition,
Vector3 rayDirection
);
JScript public static function SphereBoundProbe(
center : Vector3,
radius : float,
rayPosition : Vector3,
rayDirection : Vector3
) : boolean;

Parameters

center Microsoft.DirectX.Vector3
A Vector3 structure that specifies the center coordinate of the sphere.
radius System.Single
Radius of the sphere.
rayPosition Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDirection Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray. This vector should not be (0,0,0), but does not need to be normalized.

Return Value

System.Boolean
Value that is true if the ray intersects the volume of the sphere's bounding box, or false if it does not.

Remarks

The SphereBoundProbe method determines whether the ray intersects the volume of the sphere, not just its surface.


GraphicsException Class (Microsoft.DirectX.Direct3D)

GraphicsException Class

Base exception type for graphics. Derives from DirectXException.

Definition

Visual Basic Public Class GraphicsException
Inherits DirectXException
C# | public class GraphicsException : DirectXException
C++ | public ref class GraphicsException : DirectXException
JScript | public class GraphicsException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in.
GraphicsException | Initializes a new instance of the GraphicsException class.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ConflictingRenderStateException
ConflictingTextureFilterException
ConflictingTexturePaletteException
DeviceLostException
DeviceNotResetException
DriverInternalErrorException
DriverInvalidCallException
InvalidCallException
InvalidDeviceException
MoreDataException
NotAvailableException
NotFoundException
OutOfVideoMemoryException
TooManyOperationsException
UnsupportedAlphaArgumentException
UnsupportedAlphaOperationException
UnsupportedColorArgumentException
UnsupportedColorOperationException
UnsupportedFactorValueException
UnsupportedTextureFilterException
WasStillDrawingException
WrongTextureFormatException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GraphicsException.GetExceptionFromResultInternal(Int32) Method (Microsoft.DirectX.Direct3D)

GraphicsException.GetExceptionFromResultInternal Method

Retrieves an Exception Leave Site object that represents the result code passed in.

Definition

Visual Basic Public Shadows Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public new static Exception GetExceptionFromResultInternal(
int resultCode
);
C++ public:
static Exception^ GetExceptionFromResultInternal(
int resultCode
);
JScript public hide static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32
Integer that represents the result code of the exception to retrieve.

Return Value

System.Exception
An Exception Leave Site object that represents the error that occurred.

Applies To

ConflictingRenderStateException, ConflictingTextureFilterException, ConflictingTexturePaletteException, DeviceLostException, DeviceNotResetException, DriverInternalErrorException, DriverInvalidCallException, InvalidCallException, InvalidDeviceException, MoreDataException, NotAvailableException, NotFoundException, OutOfVideoMemoryException, TooManyOperationsException, UnsupportedAlphaArgumentException, UnsupportedAlphaOperationException, UnsupportedColorArgumentException, UnsupportedColorOperationException, UnsupportedFactorValueException, UnsupportedTextureFilterException, WasStillDrawingException, WrongTextureFormatException


GraphicsException.GraphicsException Constructor ()

Initializes a new instance of the GraphicsException class.

Overload List

public GraphicsException();
protected GraphicsException(SerializationInfo, StreamingContext);
public GraphicsException(string);
public GraphicsException(string, Exception);


GraphicsException.GraphicsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

GraphicsException.GraphicsException Constructor

Initializes a new instance of the GraphicsException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected GraphicsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
GraphicsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function GraphicsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


GraphicsException.GraphicsException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

GraphicsException.GraphicsException Constructor

Initializes a new instance of the GraphicsException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public GraphicsException(
string message,
Exception inner
);
C++ public:
GraphicsException(
String^ message,
Exception^ inner
);
JScript public function GraphicsException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


GraphicsException.GraphicsException(String) Constructor (Microsoft.DirectX.Direct3D)

GraphicsException.GraphicsException Constructor

Initializes a new instance of the GraphicsException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public GraphicsException(
string message
);
C++ public:
GraphicsException(
String^ message
);
JScript public function GraphicsException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


GraphicsException.GraphicsException() Constructor (Microsoft.DirectX.Direct3D)

GraphicsException.GraphicsException Constructor

Initializes a new instance of the GraphicsException class.

Definition

Visual Basic | Public Sub New()
C# | public GraphicsException();
C++ public:
GraphicsException();
JScript | public function GraphicsException();


Include Class (Microsoft.DirectX.Direct3D)

Include Class

Provides access to include-file directives.

Definition

Visual Basic MustInherit Public Class Include
Inherits Object
C# | public abstract class Include : Object
C++ | public ref class Include abstract : Object
JScript | public abstract class Include extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Finalize | Allows the Include object to free resources before it is destroyed by the garbage collector.
Include | Initializes a new instance of the Include class.
Open | Opens and reads the contents of a shader #include file.

Inheritance Hierarchy

Object Leave Site
Include

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Include.Finalize() Method (Microsoft.DirectX.Direct3D)

Include.Finalize Method

Allows the Include object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Include();
C++ | !Include();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Include.Include() Constructor (Microsoft.DirectX.Direct3D)

Include.Include Constructor

Initializes a new instance of the Include class.

Definition

Visual Basic | Public Sub New()
C# | public Include();
C++ public:
Include();
JScript | public function Include();


Include.Open(IncludeType,String) Method (Microsoft.DirectX.Direct3D)

Include.Open Method

Opens and reads the contents of a shader #include file.

Definition

Visual Basic MustOverride Public Function Open( _
ByVal includeType As IncludeType, _
ByVal filename As String _
) As Stream
C# public abstract Stream Open(
IncludeType includeType,
string filename
);
C++ public:
virtual Stream^ Open(
IncludeType includeType,
String^ filename
) abstract;
JScript public abstract function Open(
includeType : IncludeType,
filename : String
) : Stream;

Parameters

includeType Microsoft.DirectX.Direct3D.IncludeType
An IncludeType object that represents the #include file to open.
filename System.String
A String Leave Site that contains the name of the #include file to open.

Return Value

System.IO.Stream
A Stream Leave Site object that contains the #include file data.


IndexBuffer Class (Microsoft.DirectX.Direct3D)

IndexBuffer Class

How Do I...?
  • Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams
  • Read and Write VertexBuffer Data With Arrays

Manipulates an index buffer resource.

Definition

Visual Basic NotInheritable Public Class IndexBuffer
Inherits Resource
Implements IDisposable
C# | public sealed class IndexBuffer : Resource, IDisposable
C++ | public ref class IndexBuffer sealed : Resource, IDisposable
JScript | public final class IndexBuffer extends Resource implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Created | Occurs after a device is reset and the IndexBuffer is re-created.
Disposing | Occurs when the Dispose method is called or when the IndexBuffer object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the IndexBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object. Inherited from Resource.
Finalize | Allows the IndexBuffer object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GetHashCode | Returns the hash code for the current instance. Inherited from Resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
IndexBuffer | Creates a new instance of the IndexBuffer class.
Lock | Locks a range of index data and obtains a pointer to the index buffer memory.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Created | Raises an IndexBuffer.Created event when called from within a derived class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.IndexBuffer.Disposing event when called from within a derived class.
SetData | Locks, sets, and unlocks a range of vertex data.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
Unlock | Unlocks index data.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this IndexBuffer object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.

Properties

Property | Description
Description | Retrieves a description of the index buffer resource.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
SizeInBytes | Retrieves the size of the IndexBuffer data, in bytes.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DIndexBuffer9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
IndexBuffer

Remarks

This object inherits additional functionality from the Resource object.

How Do I...?

Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams

This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The vertex buffer data is then locked using its offset and size in bytes. A GraphicsStream object is returned which is derived from Stream Leave Site and can be used in a similar fashon. In the code example, the Write method is used to copy data into the stream from an array of vertex data.

The second part of the method shows use of GraphicsStream using unsafe data access. The InternalDataPointerGraphicsStream.InternalData property returns a void pointer to the vertex buffer data. In this code example, the data is cast to an array of PositionNormalTexVertex structures which makes data manipulation more readable.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public  float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}
public class Example
{
    public unsafe void  GraphicsStreamReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTexVertex.FVF, Pool.Managed);

        //First, fill an array of PositionNormalTexVertex elements with data.
        PositionNormalTexVertex[] vertices = new PositionNormalTexVertex[50];
        for(int i=0; i<50; i++)
        {
            //fill the vertices with some data...
            vertices[i].Position = new Vector3(3f,4f,5f);
        }

        //The size of the verticies are 32-bytes each (float3 (12) + float3 (12) + float(4) + float(4))
        //To lock 50 verticies, the size of the lock would be 1600 (32 * 50)
        GraphicsStream vbData =  vb.Lock(0,1600, LockFlags.None);

        //copy the vertex data into the vertex buffer
        vbData.Write(vertices);

        //Unlock the VB
        vb.Unlock();

        //This time, lock the entire VertexBuffer
        vbData =  vb.Lock(0, 3200, LockFlags.None);

        //Cast the InternalDataPointer (a void pointer) to an array of verticies
        PositionNormalTexVertex* vbArray = (PositionNormalTexVertex*) vbData.InternalDataPointer;

        for(int i=0; i<100; i++)
        {
            //perform some operations on the data
            vbArray[i].Tu0 = i;
            vbArray[i].Tv0 = vbArray[i].Tu0 * 2;

            Console.WriteLine(vbArray[i].Tv0.ToString());
        }

        //Unlock the buffer
        vb.Unlock();
        vb.Dispose();
    }
}

Read and Write VertexBuffer Data With Arrays

This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a FVF type defined by the PositionNormalTexVertex structure. The first part of the code sample shows the use of Lock to lock an arbitrary number of vertices and fill them with data. The second part shows how to lock an entire VertexBuffer for reading and retrieving data from the array. A similar procedure can be used to write to and read from nearly all Microsoft Direct3D resource types.

Using Arrays Leave Site is not the most efficient method for filling and reading from Direct3D resources; it requires extra memory and cycles to copy the unmanaged resources into managed arrays. However, it makes for very readable code with no unsafe access.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}

public class Example
{
    public void ArrayBasedReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTex1Vertex.FVF, Pool.Managed);

        //Fill an array of the appropriate type with the VB data using Lock()
        PositionNormalTexVertex[] vbData = (PositionNormalTexVertex[]) vb.Lock(0, typeof(PositionNormalTexVertex), LockFlags.None, 50);
        for(int i=0; i<50; i++)
        {
            //set your vertices to something...
            vbData[i].Position = new Vector3(2f,2f,2f);
            vbData[i].Normal = new Vector3(1f,0f,0f);
            vbData[i].Tu0 = i;
            vbData[i].Tv0 = i;
        }
        //Unlock the vb before you can use it elsewhere
        vb.Unlock();

        //This lock overload simply locks the entire VB -- setting ReadOnly can improve perf when reading a vertexbuffer
        vbData = (PositionNormalTexVertex[]) vb.Lock(0, LockFlags.ReadOnly);
        for(int i=0; i<100; i++)
        {
            //read some vertex data
            Console.WriteLine("Vertex " + i + "Tu: " +  vbData[i].Tu0 + " , Tv: " + vbData[i].Tv0);
        }

        //Unlock the buffer
        vb.Unlock();

        vb.Dispose();
    }
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IndexBuffer.Dispose() Method (Microsoft.DirectX.Direct3D)

IndexBuffer.Dispose Method

Immediately releases the unmanaged resources used by the IndexBuffer object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~IndexBuffer();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.IndexBuffer.Disposed
  • Microsoft.DirectX.Direct3D.IndexBuffer.Disposing


IndexBuffer.Finalize() Method (Microsoft.DirectX.Direct3D)

IndexBuffer.Finalize Method

Allows the IndexBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~IndexBuffer();
C++ | !IndexBuffer();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


IndexBuffer.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

IndexBuffer.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DIndexBuffer9, which allows unmanaged COM clients to create an instance of the managed IndexBuffer class. Not supported.


IndexBuffer.IndexBuffer Constructor ()

Creates a new instance of the IndexBuffer class.

Overload List

public IndexBuffer(Device, int, Usage, Pool, bool);
public IndexBuffer(IDirect3DIndexBuffer9);
public IndexBuffer(IDirect3DIndexBuffer9, Device, Usage, Pool);
public IndexBuffer(IDirect3DIndexBuffer9, Type, int, Device, Usage, Pool);
public IndexBuffer(IntPtr);
public IndexBuffer(Type, int, Device, Usage, Pool);

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft Direct3D to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(IDirect3DIndexBuffer9) Constructor (Microsoft.DirectX.Direct3D)

IndexBuffer.IndexBuffer Constructor

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As IDirect3DIndexBuffer9 _
)
C# public IndexBuffer(
IDirect3DIndexBuffer9 pInterop
);
C++ public:
IndexBuffer(
IDirect3DIndexBuffer9 pInterop
);
JScript public function IndexBuffer(
pInterop : IDirect3DIndexBuffer9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9
Unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface pointer.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft Direct3D to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

IndexBuffer.IndexBuffer Constructor

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public IndexBuffer(
IntPtr unmanagedObject
);
C++ public:
IndexBuffer(
IntPtr unmanagedObject
);
JScript public function IndexBuffer(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft Direct3D to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(IDirect3DIndexBuffer9,Type,Int32,Device,Usage,Pool) Constructor (Microsoft.DirectX.Direct3D)

IndexBuffer.IndexBuffer Constructor

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DIndexBuffer9, _
ByVal typeIndexType As Type, _
ByVal numberIndices As Integer, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public IndexBuffer(
IDirect3DIndexBuffer9 lp,
Type typeIndexType,
int numberIndices,
Device device,
Usage usage,
Pool pool
);
C++ public:
IndexBuffer(
IDirect3DIndexBuffer9 lp,
Type^ typeIndexType,
int numberIndices,
Device^ device,
Usage usage,
Pool pool
);
JScript public function IndexBuffer(
lp : IDirect3DIndexBuffer9,
typeIndexType : Type,
numberIndices : int,
device : Device,
usage : Usage,
pool : Pool
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9
Unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface pointer.
typeIndexType System.Type
Member of the Type Leave Site that indicates the type of index data the buffer holds. This can be a value type or any type that contains only value types.
numberIndices System.Int32
Maximum number of indices the buffer can hold.
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the index buffer.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the param_Usage_usage parameter in the IndexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes a valid memory class into which to place the resource.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft Direct3D to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(IDirect3DIndexBuffer9,Device,Usage,Pool) Constructor (Microsoft.DirectX.Direct3D)

IndexBuffer.IndexBuffer Constructor

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DIndexBuffer9, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public IndexBuffer(
IDirect3DIndexBuffer9 lp,
Device device,
Usage usage,
Pool pool
);
C++ public:
IndexBuffer(
IDirect3DIndexBuffer9 lp,
Device^ device,
Usage usage,
Pool pool
);
JScript public function IndexBuffer(
lp : IDirect3DIndexBuffer9,
device : Device,
usage : Usage,
pool : Pool
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9
Unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the index buffer.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the param_Usage_usage parameter in the IndexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes a valid memory class into which to place the resource.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft Direct3D to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(Device,Int32,Usage,Pool,Boolean) Constructor (Microsoft.DirectX.Direct3D)

IndexBuffer.IndexBuffer Constructor

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal sizeOfBufferInBytes As Integer, _
ByVal usage As Usage, _
ByVal pool As Pool, _
ByVal sixteenBitIndices As Boolean _
)
C# public IndexBuffer(
Device device,
int sizeOfBufferInBytes,
Usage usage,
Pool pool,
bool sixteenBitIndices
);
C++ public:
IndexBuffer(
Device^ device,
int sizeOfBufferInBytes,
Usage usage,
Pool pool,
bool sixteenBitIndices
);
JScript public function IndexBuffer(
device : Device,
sizeOfBufferInBytes : int,
usage : Usage,
pool : Pool,
sixteenBitIndices : boolean
);

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the index buffer.
sizeOfBufferInBytes System.Int32
Size of the index buffer in bytes.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the param_Usage_usage parameter in the IndexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes a valid memory class into which to place the resource.
sixteenBitIndices System.Boolean
Set to true if the index buffer contains 16-bit indices. Set to false if the index buffer contains 32-bit indices.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft Direct3D to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.IndexBuffer(Type,Int32,Device,Usage,Pool) Constructor (Microsoft.DirectX.Direct3D)

IndexBuffer.IndexBuffer Constructor

Creates a new instance of the IndexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal typeIndexType As Type, _
ByVal numberIndices As Integer, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public IndexBuffer(
Type typeIndexType,
int numberIndices,
Device device,
Usage usage,
Pool pool
);
C++ public:
IndexBuffer(
Type^ typeIndexType,
int numberIndices,
Device^ device,
Usage usage,
Pool pool
);
JScript public function IndexBuffer(
typeIndexType : Type,
numberIndices : int,
device : Device,
usage : Usage,
pool : Pool
);

Parameters

typeIndexType System.Type
Member of the Type Leave Site that indicates the type of index data the buffer holds. This can be a value type or any type that contains only value types.
numberIndices System.Int32
Maximum number of indices the buffer can hold.
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the index buffer.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the param_Usage_usage parameter in the IndexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes a valid memory class into which to place the resource.

Remarks

Index buffers are memory resources used to hold indices. They are similar to surfaces and vertex buffers. The use of index buffers enables Microsoft Direct3D to avoid unnecessary data copying and to place the buffer in the optimal memory type for the expected usage.

To use index buffers, create an index buffer, lock it, fill it with indices, unlock it, pass it to Device.Indices, set up the vertices, set up the vertex shader, and call Device.DrawIndexedPrimitives for rendering.

The Caps.MaxVertexIndex member indicates the types of index buffers that are valid for rendering.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description


IndexBuffer.Lock Method ()

How Do I...?
  • Create a Mesh Object

Locks a range of index data and obtains a pointer to the index buffer memory.

Overload List

public GraphicsStream Lock(int, int, LockFlags);
public Array Lock(int, LockFlags);
public Array Lock(int, Type, LockFlags, int[]);

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. None of the DrawPrimitives calls will succeed with any outstanding lock count on any currently set index buffer.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • Unlock


IndexBuffer.Lock(Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

IndexBuffer.Lock Method

How Do I...?
  • Create a Mesh Object

Locks a range of index data and obtains a pointer to the index buffer memory.

Definition

Visual Basic Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal flags As LockFlags _
) As Array
C# public Array Lock(
int offsetToLock,
LockFlags flags
);
C++ public:
Array^ Lock(
int offsetToLock,
LockFlags flags
);
JScript public function Lock(
offsetToLock : int,
flags : LockFlags
) : Array;

Parameters

offsetToLock System.Int32
Offset into the index data to lock, in bytes. To lock the entire index buffer, specify 0 for the param_Int32_sizeToLock and param_Int32_offsetToLock parameters.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, NoOverwrite, and ReadOnly.

Return Value

System.Array
An Array Leave Site that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. None of the DrawPrimitives calls will succeed with any outstanding lock count on any currently set index buffer.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • Unlock


IndexBuffer.Lock(Int32,Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

IndexBuffer.Lock Method

How Do I...?
  • Create a Mesh Object

Locks a range of index data and obtains a pointer to the index buffer memory.

Definition

Visual Basic Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal sizeToLock As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream Lock(
int offsetToLock,
int sizeToLock,
LockFlags flags
);
C++ public:
GraphicsStream^ Lock(
int offsetToLock,
int sizeToLock,
LockFlags flags
);
JScript public function Lock(
offsetToLock : int,
sizeToLock : int,
flags : LockFlags
) : GraphicsStream;

Parameters

offsetToLock System.Int32
Offset into the index data to lock, in bytes. To lock the entire index buffer, specify 0 for the param_Int32_sizeToLock and param_Int32_offsetToLock parameters.
sizeToLock System.Int32
Size of the index data to lock, in bytes. To lock the entire index buffer, specify 0 for the param_Int32_sizeToLock and param_Int32_offsetToLock parameters.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, NoOverwrite, and ReadOnly.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. None of the DrawPrimitives calls will succeed with any outstanding lock count on any currently set index buffer.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • Unlock


IndexBuffer.Lock(Int32,Type,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

IndexBuffer.Lock Method

How Do I...?
  • Create a Mesh Object

Locks a range of index data and obtains a pointer to the index buffer memory.

Definition

Visual Basic Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal typeIndex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array Lock(
int offsetToLock,
Type typeIndex,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ Lock(
int offsetToLock,
Type^ typeIndex,
LockFlags flags,
array<int>^ ranks
);
JScript public function Lock(
offsetToLock : int,
typeIndex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

offsetToLock System.Int32
Offset into the index data to lock, in bytes. To lock the entire index buffer, specify 0 for the param_Int32_sizeToLock and param_Int32_offsetToLock parameters.
typeIndex System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, NoOverwrite, and ReadOnly.
ranks System.Int32[]
Array of 1 to 3 Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked index buffer.

Remarks

When working with index buffers, multiple lock calls are allowed. However, the number of lock calls must match the number of unlock calls. None of the DrawPrimitives calls will succeed with any outstanding lock count on any currently set index buffer.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • Unlock


IndexBuffer.raise_Created(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

IndexBuffer.raise_Created Method

Raises an IndexBuffer.Created event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Created( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Created(
object i1,
EventArgs i2
);
C++ protected:
void raise_Created(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Created(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


IndexBuffer.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

IndexBuffer.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.IndexBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


IndexBuffer.SetData(Object,Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

IndexBuffer.SetData Method

Locks, sets, and unlocks a range of vertex data.

Definition

Visual Basic Public Sub SetData( _
ByVal data As Object, _
ByVal lockAtOffset As Integer, _
ByVal flags As LockFlags _
)
C# public void SetData(
object data,
int lockAtOffset,
LockFlags flags
);
C++ public:
void SetData(
Object^ data,
int lockAtOffset,
LockFlags flags
);
JScript public function SetData(
data : Object,
lockAtOffset : int,
flags : LockFlags
);

Parameters

data System.Object
An Object Leave Site that contains the data to copy into the index buffer.
lockAtOffset System.Int32
Offset to set in the index buffer. To set the entire buffer, set this parameter to 0.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags locking flags that describe the type of lock to perform when setting the buffer. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Remarks

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


IndexBuffer.Unlock() Method (Microsoft.DirectX.Direct3D)

IndexBuffer.Unlock Method

How Do I...?
  • Create a Mesh Object

Unlocks index data.

Definition

Visual Basic | Public Sub Unlock()
C# | public void Unlock();
C++ public:
void Unlock();
JScript | public function Unlock();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


IndexBuffer.UpdateUnmanagedPointer(IDirect3DIndexBuffer9) Method (Microsoft.DirectX.Direct3D)

IndexBuffer.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this IndexBuffer object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DIndexBuffer9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DIndexBuffer9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DIndexBuffer9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DIndexBuffer9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9
Pointer to the IDirect3DIndexBuffer9 structure used to update the unmanaged pointer for this IndexBuffer object.


IndexBuffer.Description Property (Microsoft.DirectX.Direct3D)

IndexBuffer.Description Property

Retrieves a description of the index buffer resource.

Definition

Visual Basic | Public ReadOnly Property Description As IndexBufferDescription
C# | public IndexBufferDescription Description { get; }
C++ public:
property IndexBufferDescription Description {
IndexBufferDescription get();
}
JScript | public function get Description() : IndexBufferDescription

Property Value

Microsoft.DirectX.Direct3D.IndexBufferDescription
An IndexBufferDescription structure that describes the returned index buffer.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


IndexBuffer.Disposed Property (Microsoft.DirectX.Direct3D)

IndexBuffer.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


IndexBuffer.SizeInBytes Property (Microsoft.DirectX.Direct3D)

IndexBuffer.SizeInBytes Property

Retrieves the size of the IndexBuffer data, in bytes.

Definition

Visual Basic | Public ReadOnly Property SizeInBytes As Integer
C# | public int SizeInBytes { get; }
C++ public:
property int SizeInBytes {
int get();
}
JScript | public function get SizeInBytes() : int

Property Value

System.Int32
The size of the IndexBuffer data, in bytes.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IndexBuffer.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

IndexBuffer.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DIndexBuffer9 interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As IDirect3DIndexBuffer9
C# | public IDirect3DIndexBuffer9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DIndexBuffer9 UnmanagedComPointer {
IDirect3DIndexBuffer9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DIndexBuffer9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DIndexBuffer9
Unmanaged IDirect3DIndexBuffer9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


IndexBuffer.Created Event (Microsoft.DirectX.Direct3D)

IndexBuffer.Created Event

Occurs after a device is reset and the IndexBuffer is re-created.

Definition

Visual Basic | Public Event Created As EventHandler
C# | public event EventHandler Created;
C++ public:
event EventHandler^ Created;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

Note: This event occurs only on Pool.Default resources.

To add an event handler that listens for an IndexBuffer.Created event, use the following C# code.

[C#]
indexBuffer.Created += new System.EventHandler(this.CreatedEventHandler);


IndexBuffer.Disposing Event (Microsoft.DirectX.Direct3D)

IndexBuffer.Disposing Event

Occurs when the Dispose method is called or when the IndexBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.IndexBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the IndexBuffer object indicates whether that object has been disposed.


IntegratedMetricTensor Class (Microsoft.DirectX.Direct3D)

IntegratedMetricTensor Class

Contains methods to calculate integrated metric tensor (IMT) values for use in UVAtlas operations.

Definition

Visual Basic NotInheritable MustInherit Public Class IntegratedMetricTensor
Inherits Object
C# | public abstract sealed class IntegratedMetricTensor : Object
C++ | public ref class IntegratedMetricTensor abstract sealed : Object
JScript | public final abstract class IntegratedMetricTensor extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) ComputeFromPerTexelSignal | Calculates an IMT from per-texel data. This function is very similar to ComputeFromTexture, but it uses a float array to pass in the data, and it can calculate higher dimensional values than 4.
static (Shared in Visual Basic) ComputeFromPerVertexSignal | Calculates an IMT from from per-vertex data.
static (Shared in Visual Basic) ComputeFromSignal | Calculates an IMT from data that varies over the surface of the mesh (generally at a higher frequency than vertex data).
static (Shared in Visual Basic) ComputeFromTexture | Calculates an IMT from texture data.

Inheritance Hierarchy

Object Leave Site
IntegratedMetricTensor

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IntegratedMetricTensor.ComputeFromPerTexelSignal(Mesh,Int32,Single[],Int32,Int32,Int32,Int32,ImtWrap) Method (Microsoft.DirectX.Direct3D)

IntegratedMetricTensor.ComputeFromPerTexelSignal Method

Calculates an IMT from per-texel data. This function is very similar to ComputeFromTexture, but it uses a float array to pass in the data, and it can calculate higher dimensional values than 4.

Definition

Visual Basic Public Shared Function ComputeFromPerTexelSignal( _
ByVal mesh As Mesh, _
ByVal textureIndex As Integer, _
ByVal texelSignal() As Single, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal signalDimension As Integer, _
ByVal components As Integer, _
ByVal flags As ImtWrap _
) As GraphicsStream
C# public static GraphicsStream ComputeFromPerTexelSignal(
Mesh mesh,
int textureIndex,
float[] texelSignal,
int width,
int height,
int signalDimension,
int components,
ImtWrap flags
);
C++ public:
static GraphicsStream^ ComputeFromPerTexelSignal(
Mesh^ mesh,
int textureIndex,
array<float>^ texelSignal,
int width,
int height,
int signalDimension,
int components,
ImtWrap flags
);
JScript public static function ComputeFromPerTexelSignal(
mesh : Mesh,
textureIndex : int,
texelSignal : float[],
width : int,
height : int,
signalDimension : int,
components : int,
flags : ImtWrap
) : GraphicsStream;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
An input mesh (see Mesh) that contains the object geometry for calculating the IMT.
textureIndex System.Int32
Zero-based texture coordinate index that identifies which set of texture coordinates to use.
texelSignal System.Single[]
An array of floating-point values that represent the texel signals. The array size is equivalent to width*height*components.
width System.Int32
The width of the texture.
height System.Int32
The height of the texture.
signalDimension System.Int32
The number of floating-point values per component in each element of the texelSignal array.
components System.Int32
The number of components in each element of the texelSignal array.
flags Microsoft.DirectX.Direct3D.ImtWrap
Combination of one or more ImtWrap flags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that will return the calculated IMT data.

Remarks

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IntegratedMetricTensor.ComputeFromPerVertexSignal(Mesh,Single[],Int32,Int32) Method (Microsoft.DirectX.Direct3D)

IntegratedMetricTensor.ComputeFromPerVertexSignal Method

Calculates an IMT from from per-vertex data.

Definition

Visual Basic Public Shared Function ComputeFromPerVertexSignal( _
ByVal mesh As Mesh, _
ByVal vertexSignal() As Single, _
ByVal signalDimension As Integer, _
ByVal signalStride As Integer _
) As GraphicsStream
C# public static GraphicsStream ComputeFromPerVertexSignal(
Mesh mesh,
float[] vertexSignal,
int signalDimension,
int signalStride
);
C++ public:
static GraphicsStream^ ComputeFromPerVertexSignal(
Mesh^ mesh,
array<float>^ vertexSignal,
int signalDimension,
int signalStride
);
JScript public static function ComputeFromPerVertexSignal(
mesh : Mesh,
vertexSignal : float[],
signalDimension : int,
signalStride : int
) : GraphicsStream;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
An input mesh (see Mesh) that contains the object geometry for calculating the IMT.
vertexSignal System.Single[]
An array of floating-point values that represent per-vertex signal data. The array size is signalStride * v, where v is the number of vertices in the input mesh.
signalDimension System.Int32
The number of floating-point values per vertex.
signalStride System.Int32
The number of bytes per vertex in the array. This must be a multiple of sizeof(Single).

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream that will return the calculated IMT data.

Remarks

ComputeFromPerVertexSignal sets up a linear system over the triangle, solves for the jacobian J, then constructs the IMT from that (J^TJ). This function enables you to calculate the IMT based off of any value in a mesh (color, normal, and so on) by specifying the correct stride of the array. The IMT computed will cause areas of the mesh with similar values to occupy less space in the texture.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IntegratedMetricTensor.ComputeFromSignal(Mesh,Int32,Int32,Single,ImtSignalCallback) Method (Microsoft.DirectX.Direct3D)

IntegratedMetricTensor.ComputeFromSignal Method

Calculates an IMT from data that varies over the surface of the mesh (generally at a higher frequency than vertex data).

Definition

Visual Basic Public Shared Function ComputeFromSignal( _
ByVal mesh As Mesh, _
ByVal textureIndex As Integer, _
ByVal signalDimension As Integer, _
ByVal maxUVDistance As Single, _
ByVal callback As ImtSignalCallback _
) As GraphicsStream
C# public static GraphicsStream ComputeFromSignal(
Mesh mesh,
int textureIndex,
int signalDimension,
float maxUVDistance,
ImtSignalCallback callback
);
C++ public:
static GraphicsStream^ ComputeFromSignal(
Mesh^ mesh,
int textureIndex,
int signalDimension,
float maxUVDistance,
ImtSignalCallback^ callback
);
JScript public static function ComputeFromSignal(
mesh : Mesh,
textureIndex : int,
signalDimension : int,
maxUVDistance : float,
callback : ImtSignalCallback
) : GraphicsStream;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
An input mesh (see Mesh) that contains the object geometry for calculating the IMT.
textureIndex System.Int32
Zero-based texture coordinate index that identifies which set of texture coordinates to use.
signalDimension System.Int32
The number of components in each data point in the signal.
maxUVDistance System.Single
The maximum distance between vertices; the algorithm continues subdividing until the distance between all vertices is less than or equal to maxUVDistance.
callback Microsoft.DirectX.Direct3D.ImtSignalCallback
A callback that is useful for monitoring progress.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that returns the calculated IMT data.

Remarks

This function requires the mesh to already be parameterized (so that it already has texture coordinates). It allows the user to define a signal arbitrarily over the surface of the mesh.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IntegratedMetricTensor.ComputeFromTexture(Mesh,Texture,Int32,ImtWrap) Method (Microsoft.DirectX.Direct3D)

IntegratedMetricTensor.ComputeFromTexture Method

Calculates an IMT from texture data.

Definition

Visual Basic Public Shared Function ComputeFromTexture( _
ByVal mesh As Mesh, _
ByVal texture As Texture, _
ByVal textureIndex As Integer, _
ByVal flags As ImtWrap _
) As GraphicsStream
C# public static GraphicsStream ComputeFromTexture(
Mesh mesh,
Texture texture,
int textureIndex,
ImtWrap flags
);
C++ public:
static GraphicsStream^ ComputeFromTexture(
Mesh^ mesh,
Texture^ texture,
int textureIndex,
ImtWrap flags
);
JScript public static function ComputeFromTexture(
mesh : Mesh,
texture : Texture,
textureIndex : int,
flags : ImtWrap
) : GraphicsStream;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
An input mesh (see Mesh) that contains the object geometry for calculating the IMT.
texture Microsoft.DirectX.Direct3D.Texture
The texture (see Texture) that is mapped to the mesh.
textureIndex System.Int32
Zero-based texture coordinate index that identifies which set of texture coordinates to use.
flags Microsoft.DirectX.Direct3D.ImtWrap
Combination of one or more ImtWrap flags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that will return the calculated IMT data.

Remarks

Given a texture that maps over the surface of the mesh, the algorithm computes the IMT for each face. This will cause large areas that are very similar to occupy less room when parameterized with UVAtlas. The texture is assumed to be interpolated over the mesh bilinearly.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


InterfaceGuid Class (Microsoft.DirectX.Direct3D)

InterfaceGuid Class

Encapsulates various object globally unique identifiers (GUIDs) for use with the Surface.GetContainer and Volume.GetContainer methods.

Definition

Visual Basic NotInheritable MustInherit Public Class InterfaceGuid
Inherits Object
C# | public abstract sealed class InterfaceGuid : Object
C++ | public ref class InterfaceGuid abstract sealed : Object
JScript | public final abstract class InterfaceGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) BaseTexture | Specifies the BaseTexture GUID.
static (Shared in Visual Basic) CubeTexture | Specifies the CubeTexture GUID.
static (Shared in Visual Basic) Device | Specifies the Device GUID.
static (Shared in Visual Basic) IndexBuffer | Specifies the IndexBuffer GUID.
static (Shared in Visual Basic) PixelShader | Specifies the PixelShader GUID.
static (Shared in Visual Basic) Resource | Specifies the Resource GUID.
static (Shared in Visual Basic) StateBlock | Specifies the StateBlock GUID.
static (Shared in Visual Basic) Surface | Specifies the Surface GUID.
static (Shared in Visual Basic) SwapChain | Specifies the SwapChain GUID.
static (Shared in Visual Basic) VertexBuffer | Specifies the VertexBuffer GUID.
static (Shared in Visual Basic) VertexDeclaration | Specifies the VertexDeclaration GUID.
static (Shared in Visual Basic) VertexShader | Specifies the VertexShader GUID.
static (Shared in Visual Basic) Volume | Specifies the Volume GUID.
static (Shared in Visual Basic) VolumeTexture | Specifies the VolumeTexture GUID.

Inheritance Hierarchy

Object Leave Site
InterfaceGuid

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InterfaceGuid.BaseTexture Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.BaseTexture Field

Specifies the BaseTexture globally unique identifier (GUID).

Definition

Visual Basic | Public Shared BaseTexture As Guid
C# | public static Guid BaseTexture;
C++ | public: static Guid BaseTexture;
JScript | public static var BaseTexture : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the BaseTexture GUID.

This field is read-only.


InterfaceGuid.CubeTexture Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.CubeTexture Field

Specifies the CubeTexture globally unique identifier (GUID).

Definition

Visual Basic | Public Shared CubeTexture As Guid
C# | public static Guid CubeTexture;
C++ | public: static Guid CubeTexture;
JScript | public static var CubeTexture : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the CubeTexture GUID.

This field is read-only.


InterfaceGuid.Device Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.Device Field

Specifies the Device globally unique identifier (GUID).

Definition

Visual Basic | Public Shared Device As Guid
C# | public static Guid Device;
C++ | public: static Guid Device;
JScript | public static var Device : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the Device GUID.

This field is read-only.


InterfaceGuid.IndexBuffer Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.IndexBuffer Field

Specifies the IndexBuffer globally unique identifier (GUID).

Definition

Visual Basic | Public Shared IndexBuffer As Guid
C# | public static Guid IndexBuffer;
C++ | public: static Guid IndexBuffer;
JScript | public static var IndexBuffer : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the IndexBuffer GUID.

This field is read-only.


InterfaceGuid.PixelShader Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.PixelShader Field

Specifies the PixelShader globally unique identifier (GUID).

Definition

Visual Basic | Public Shared PixelShader As Guid
C# | public static Guid PixelShader;
C++ | public: static Guid PixelShader;
JScript | public static var PixelShader : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the PixelShader GUID.

This field is read-only.


InterfaceGuid.Resource Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.Resource Field

Specifies the Resource globally unique identifier (GUID).

Definition

Visual Basic | Public Shared Resource As Guid
C# | public static Guid Resource;
C++ | public: static Guid Resource;
JScript | public static var Resource : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the Resource GUID.

This field is read-only.


InterfaceGuid.StateBlock Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.StateBlock Field

Specifies the StateBlock globally unique identifier (GUID).

Definition

Visual Basic | Public Shared StateBlock As Guid
C# | public static Guid StateBlock;
C++ | public: static Guid StateBlock;
JScript | public static var StateBlock : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the StateBlock GUID.

This field is read-only.


InterfaceGuid.Surface Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.Surface Field

Specifies the Surface globally unique identifier (GUID).

Definition

Visual Basic | Public Shared Surface As Guid
C# | public static Guid Surface;
C++ | public: static Guid Surface;
JScript | public static var Surface : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the Surface GUID.

This field is read-only.


InterfaceGuid.SwapChain Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.SwapChain Field

Specifies the SwapChain globally unique identifier (GUID).

Definition

Visual Basic | Public Shared SwapChain As Guid
C# | public static Guid SwapChain;
C++ | public: static Guid SwapChain;
JScript | public static var SwapChain : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the SwapChain GUID.

This field is read-only.


InterfaceGuid.VertexBuffer Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.VertexBuffer Field

Specifies the VertexBuffer globally unique identifier (GUID).

Definition

Visual Basic | Public Shared VertexBuffer As Guid
C# | public static Guid VertexBuffer;
C++ | public: static Guid VertexBuffer;
JScript | public static var VertexBuffer : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the VertexBuffer GUID.

This field is read-only.


InterfaceGuid.VertexDeclaration Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.VertexDeclaration Field

Specifies the VertexDeclaration globally unique identifier (GUID).

Definition

Visual Basic | Public Shared VertexDeclaration As Guid
C# | public static Guid VertexDeclaration;
C++ | public: static Guid VertexDeclaration;
JScript | public static var VertexDeclaration : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the VertexDeclaration GUID.

This field is read-only.


InterfaceGuid.VertexShader Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.VertexShader Field

Specifies the VertexShader globally unique identifier (GUID).

Definition

Visual Basic | Public Shared VertexShader As Guid
C# | public static Guid VertexShader;
C++ | public: static Guid VertexShader;
JScript | public static var VertexShader : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the VertexShader GUID.

This field is read-only.


InterfaceGuid.Volume Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.Volume Field

Specifies the Volume globally unique identifier (GUID).

Definition

Visual Basic | Public Shared Volume As Guid
C# | public static Guid Volume;
C++ | public: static Guid Volume;
JScript | public static var Volume : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the Volume GUID.

This field is read-only.


InterfaceGuid.VolumeTexture Field (Microsoft.DirectX.Direct3D)

InterfaceGuid.VolumeTexture Field

Specifies the VolumeTexture globally unique identifier (GUID).

Definition

Visual Basic | Public Shared VolumeTexture As Guid
C# | public static Guid VolumeTexture;
C++ | public: static Guid VolumeTexture;
JScript | public static var VolumeTexture : Guid

Field Value

System.Guid
A Guid Leave Site object that represents the VolumeTexture GUID.

This field is read-only.


InvalidCallException Class (Microsoft.DirectX.Direct3D)

InvalidCallException Class

The method call is invalid. For example, a method's parameter might not be valid.

Definition

Visual Basic Public Class InvalidCallException
Inherits GraphicsException
C# | public class InvalidCallException : GraphicsException
C++ | public ref class InvalidCallException : GraphicsException
JScript | public class InvalidCallException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidCallException | Initializes a new instance of the InvalidCallException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidCallException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidCallException.InvalidCallException Constructor ()

Initializes a new instance of the InvalidCallException class.

Overload List

public InvalidCallException();
protected InvalidCallException(SerializationInfo, StreamingContext);
public InvalidCallException(string);
public InvalidCallException(string, Exception);


InvalidCallException.InvalidCallException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

InvalidCallException.InvalidCallException Constructor

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidCallException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidCallException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidCallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidCallException.InvalidCallException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

InvalidCallException.InvalidCallException Constructor

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidCallException(
string message,
Exception inner
);
C++ public:
InvalidCallException(
String^ message,
Exception^ inner
);
JScript public function InvalidCallException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


InvalidCallException.InvalidCallException(String) Constructor (Microsoft.DirectX.Direct3D)

InvalidCallException.InvalidCallException Constructor

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidCallException(
string message
);
C++ public:
InvalidCallException(
String^ message
);
JScript public function InvalidCallException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


InvalidCallException.InvalidCallException() Constructor (Microsoft.DirectX.Direct3D)

InvalidCallException.InvalidCallException Constructor

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic | Public Sub New()
C# | public InvalidCallException();
C++ public:
InvalidCallException();
JScript | public function InvalidCallException();


InvalidDataException Class (Microsoft.DirectX.Direct3D)

InvalidDataException Class

The data is invalid.

Definition

Visual Basic Public Class InvalidDataException
Inherits Direct3DXException
C# | public class InvalidDataException : Direct3DXException
C++ | public ref class InvalidDataException : Direct3DXException
JScript | public class InvalidDataException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDataException | Initializes a new instance of the InvalidDataException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
InvalidDataException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidDataException.InvalidDataException Constructor ()

Initializes a new instance of the InvalidDataException class.

Overload List

public InvalidDataException();
protected InvalidDataException(SerializationInfo, StreamingContext);
public InvalidDataException(string);
public InvalidDataException(string, Exception);


InvalidDataException.InvalidDataException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

InvalidDataException.InvalidDataException Constructor

Initializes a new instance of the InvalidDataException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDataException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidDataException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidDataException.InvalidDataException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

InvalidDataException.InvalidDataException Constructor

Initializes a new instance of the InvalidDataException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDataException(
string message,
Exception inner
);
C++ public:
InvalidDataException(
String^ message,
Exception^ inner
);
JScript public function InvalidDataException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


InvalidDataException.InvalidDataException(String) Constructor (Microsoft.DirectX.Direct3D)

InvalidDataException.InvalidDataException Constructor

Initializes a new instance of the InvalidDataException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidDataException(
string message
);
C++ public:
InvalidDataException(
String^ message
);
JScript public function InvalidDataException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


InvalidDataException.InvalidDataException() Constructor (Microsoft.DirectX.Direct3D)

InvalidDataException.InvalidDataException Constructor

Initializes a new instance of the InvalidDataException class.

Definition

Visual Basic | Public Sub New()
C# | public InvalidDataException();
C++ public:
InvalidDataException();
JScript | public function InvalidDataException();


InvalidDeviceException Class (Microsoft.DirectX.Direct3D)

InvalidDeviceException Class

The requested device type is not valid.

Definition

Visual Basic Public Class InvalidDeviceException
Inherits GraphicsException
C# | public class InvalidDeviceException : GraphicsException
C++ | public ref class InvalidDeviceException : GraphicsException
JScript | public class InvalidDeviceException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDeviceException | Initializes a new instance of the InvalidDeviceException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidDeviceException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidDeviceException.InvalidDeviceException Constructor ()

Initializes a new instance of the InvalidDeviceException class.

Overload List

public InvalidDeviceException();
protected InvalidDeviceException(SerializationInfo, StreamingContext);
public InvalidDeviceException(string);
public InvalidDeviceException(string, Exception);


InvalidDeviceException.InvalidDeviceException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

InvalidDeviceException.InvalidDeviceException Constructor

Initializes a new instance of the InvalidDeviceException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDeviceException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidDeviceException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidDeviceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidDeviceException.InvalidDeviceException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

InvalidDeviceException.InvalidDeviceException Constructor

Initializes a new instance of the InvalidDeviceException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDeviceException(
string message,
Exception inner
);
C++ public:
InvalidDeviceException(
String^ message,
Exception^ inner
);
JScript public function InvalidDeviceException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


InvalidDeviceException.InvalidDeviceException(String) Constructor (Microsoft.DirectX.Direct3D)

InvalidDeviceException.InvalidDeviceException Constructor

Initializes a new instance of the InvalidDeviceException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidDeviceException(
string message
);
C++ public:
InvalidDeviceException(
String^ message
);
JScript public function InvalidDeviceException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


InvalidDeviceException.InvalidDeviceException() Constructor (Microsoft.DirectX.Direct3D)

InvalidDeviceException.InvalidDeviceException Constructor

Initializes a new instance of the InvalidDeviceException class.

Definition

Visual Basic | Public Sub New()
C# | public InvalidDeviceException();
C++ public:
InvalidDeviceException();
JScript | public function InvalidDeviceException();


InvalidMeshException Class (Microsoft.DirectX.Direct3D)

InvalidMeshException Class

The mesh is invalid.

Definition

Visual Basic Public Class InvalidMeshException
Inherits Direct3DXException
C# | public class InvalidMeshException : Direct3DXException
C++ | public ref class InvalidMeshException : Direct3DXException
JScript | public class InvalidMeshException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidMeshException | Initializes a new instance of the InvalidMeshException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
InvalidMeshException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidMeshException.InvalidMeshException Constructor ()

Initializes a new instance of the InvalidMeshException class.

Overload List

public InvalidMeshException();
protected InvalidMeshException(SerializationInfo, StreamingContext);
public InvalidMeshException(string);
public InvalidMeshException(string, Exception);


InvalidMeshException.InvalidMeshException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

InvalidMeshException.InvalidMeshException Constructor

Initializes a new instance of the InvalidMeshException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidMeshException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidMeshException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidMeshException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidMeshException.InvalidMeshException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

InvalidMeshException.InvalidMeshException Constructor

Initializes a new instance of the InvalidMeshException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidMeshException(
string message,
Exception inner
);
C++ public:
InvalidMeshException(
String^ message,
Exception^ inner
);
JScript public function InvalidMeshException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


InvalidMeshException.InvalidMeshException(String) Constructor (Microsoft.DirectX.Direct3D)

InvalidMeshException.InvalidMeshException Constructor

Initializes a new instance of the InvalidMeshException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidMeshException(
string message
);
C++ public:
InvalidMeshException(
String^ message
);
JScript public function InvalidMeshException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


InvalidMeshException.InvalidMeshException() Constructor (Microsoft.DirectX.Direct3D)

InvalidMeshException.InvalidMeshException Constructor

Initializes a new instance of the InvalidMeshException class.

Definition

Visual Basic | Public Sub New()
C# | public InvalidMeshException();
C++ public:
InvalidMeshException();
JScript | public function InvalidMeshException();


KeyframedAnimationSet Class (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet Class

Implements a keyframe animation set.

Definition

Visual Basic NotInheritable Public Class KeyframedAnimationSet
Inherits AnimationSet
C# | public sealed class KeyframedAnimationSet : AnimationSet
C++ | public ref class KeyframedAnimationSet sealed : AnimationSet
JScript | public final class KeyframedAnimationSet extends AnimationSet

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the KeyframedAnimationSet object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Compress | Transforms animations in an animation set into a compressed format and returns the compressed data.
Dispose | Immediately releases the unmanaged resources used by the KeyframedAnimationSet object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the KeyframedAnimationSet object to free resources before it is destroyed by the garbage collector.
GetAnimationIndex | Retrieves the index of an animation, given its name. Inherited from AnimationSet.
GetAnimationName | Retrieves the name of an animation, given its index. Inherited from AnimationSet.
GetCallback | Retrieves information about a specific callback in an animation set. Inherited from AnimationSet.
GetCallbackKey | Retrieves information about a specific callback in the animation set.
GetCallbackKeys | Fills an array with callback key data used for keyframe animation.
GetHashCode | Returns the hash code for the current instance.
GetNumberRotationKeys | Retrieves the number of rotation keys in the specified keyframe animation.
GetNumberScaleKeys | Retrieves the number of scale keys in the specified keyframe animation.
GetNumberTranslationKeys | Retrieves the number of translation keys in the specified keyframe animation.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPeriodicPosition | Returns the time position in the local timeframe of an animation set. Inherited from AnimationSet.
GetRotationKey | Retrieves rotation information for a specific key frame in the animation set.
GetRotationKeys | Fills an array with rotational key data used for keyframe animation.
GetScaleKey | Retrieves scale information for a specific key frame in the animation set.
GetScaleKeys | Fills an array with scale key data used for keyframe animation.
GetScaleRotateTranslate | Retrieves the scale, rotate, and translate (SRT) values of an animation set. Inherited from AnimationSet.
GetTranslationKey | Retrieves translation information for a specific key frame in the animation set.
GetTranslationKeys | Fills an array with translational key data used for keyframe animation.
KeyframedAnimationSet | Creates a KeyframedAnimationSet.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from AnimationSet.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from AnimationSet.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposing event when called from within a derived class.
RegisterAnimationKeys | Registers all of the scale, rotate, and translate (SRT) keyframe data of an animation, and fills arrays with SRT key data used for keyframe animation.
SetCallbackKey | Sets information about a specific callback in the animation set.
SetRotationKey | Sets rotation information for a specific key frame in the animation set.
SetScaleKey | Sets scale information for a specific key frame in the animation set.
SetTranslationKey | Sets translation information for a specific key frame in the animation set.
UnregisterAnimation | Removes the animation data from the animation set.
UnregisterRotationKey | Removes the rotation data at the specified key frame.
UnregisterScaleKey | Removes the scale data at the specified key frame.
UnregisterTranslationKey | Removes the translation data at the specified key frame.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this AnimationSet object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code. Inherited from AnimationSet.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this KeyframedAnimationSet object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Name | Retrieves the name of an animation set. Inherited from AnimationSet.
NumberAnimations | Retrieves a value that indicates the number of animations in the animation set. Inherited from AnimationSet.
NumberCallbackKeys | Retrieves the number of callback keys in an animation set.
Period | Retrieves the period of an animation set. Inherited from AnimationSet.
PlaybackType | Retrieves the type of the animation set playback loop.
SourceTicksPerSecond | Retrieves the number of animation keyframe ticks that occur per second.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXKeyframedAnimationSet interface pointer.
UnmanagedComPointer | Returns the unmanaged COM ID3DXAnimationSet interface pointer. Inherited from AnimationSet.

Inheritance Hierarchy

Object Leave Site
AnimationSet
KeyframedAnimationSet

Remarks

A KeyframedAnimationSet is a class that encapsulates a set of rotation, translation, and scale data over time. Typically, this class is used to manipulate a set of animations that represent the actions of a character, such as walking, running, or sitting. Multiple KeyframedAnimationSet classes can run animations in different tracks of an AnimationController class, which can blend the animations together to create a single seamless animation.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CompressedAnimationSet


KeyframedAnimationSet.Compress(CompressionFlags,Single,Frame) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.Compress Method

Transforms animations in an animation set into a compressed format and returns the compressed data.

Definition

Visual Basic Public Function Compress( _
ByVal flags As CompressionFlags, _
ByVal lossiness As Single, _
ByVal hierarchy As Frame _
) As GraphicsStream
C# public GraphicsStream Compress(
CompressionFlags flags,
float lossiness,
Frame hierarchy
);
C++ public:
GraphicsStream^ Compress(
CompressionFlags flags,
float lossiness,
Frame^ hierarchy
);
JScript public function Compress(
flags : CompressionFlags,
lossiness : float,
hierarchy : Frame
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.CompressionFlags
One of the CompressionFlags values that define the compression mode used for storing compressed animation set data.
lossiness System.Single
Desired compression loss ratio, in the range of 0 to 1.
hierarchy Microsoft.DirectX.Direct3D.Frame
A Frame transformation frame hierarchy. Can be null.

Return Value

Microsoft.DirectX.GraphicsStream
A CompressedAnimationSet object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.Dispose() Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.Dispose Method

Immediately releases the unmanaged resources used by the KeyframedAnimationSet object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~KeyframedAnimationSet();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposed
  • Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposing


KeyframedAnimationSet.Equals(Object) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


KeyframedAnimationSet.Finalize() Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.Finalize Method

Allows the KeyframedAnimationSet object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~KeyframedAnimationSet();
C++ | !KeyframedAnimationSet();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


KeyframedAnimationSet.GetCallbackKey(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetCallbackKey Method

Retrieves information about a specific callback in the animation set.

Definition

Visual Basic Public Function GetCallbackKey( _
ByVal index As Integer _
) As KeyCallback
C# public KeyCallback GetCallbackKey(
int index
);
C++ public:
KeyCallback GetCallbackKey(
int index
);
JScript public function GetCallbackKey(
index : int
) : KeyCallback;

Parameters

index System.Int32
An integer that represents the animation index.

Return Value

Microsoft.DirectX.Direct3D.KeyCallback
A KeyCallback object that describes the animation's callback key.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.GetCallbackKeys() Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetCallbackKeys Method

Fills an array with callback key data used for keyframe animation.

Definition

Visual Basic | Public Function GetCallbackKeys() As KeyCallback()
C# | public KeyCallback[] GetCallbackKeys();
C++ public:
array<KeyCallback>^ GetCallbackKeys();
JScript | public function GetCallbackKeys() : KeyCallback[];

Return Value

Microsoft.DirectX.Direct3D.KeyCallback[]
Array of KeyCallback structures that contain callback data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • KeyframedAnimationSet.NumberCallbackKeys


KeyframedAnimationSet.GetHashCode() Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


KeyframedAnimationSet.GetNumberRotationKeys(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetNumberRotationKeys Method

Retrieves the number of rotation keys in the specified keyframe animation.

Definition

Visual Basic Public Function GetNumberRotationKeys( _
ByVal animation As Integer _
) As Integer
C# public int GetNumberRotationKeys(
int animation
);
C++ public:
int GetNumberRotationKeys(
int animation
);
JScript public function GetNumberRotationKeys(
animation : int
) : int;

Parameters

animation System.Int32
Animation index.

Return Value

System.Int32
Number of rotation keys in the specified keyframe animation.


KeyframedAnimationSet.GetNumberScaleKeys(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetNumberScaleKeys Method

Retrieves the number of scale keys in the specified keyframe animation.

Definition

Visual Basic Public Function GetNumberScaleKeys( _
ByVal animation As Integer _
) As Integer
C# public int GetNumberScaleKeys(
int animation
);
C++ public:
int GetNumberScaleKeys(
int animation
);
JScript public function GetNumberScaleKeys(
animation : int
) : int;

Parameters

animation System.Int32
Animation index.

Return Value

System.Int32
Number of scale keys in the specified keyframe animation.


KeyframedAnimationSet.GetNumberTranslationKeys(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetNumberTranslationKeys Method

Retrieves the number of translation keys in the specified keyframe animation.

Definition

Visual Basic Public Function GetNumberTranslationKeys( _
ByVal animation As Integer _
) As Integer
C# public int GetNumberTranslationKeys(
int animation
);
C++ public:
int GetNumberTranslationKeys(
int animation
);
JScript public function GetNumberTranslationKeys(
animation : int
) : int;

Parameters

animation System.Int32
Animation index.

Return Value

System.Int32
Number of translation keys in the specified keyframe animation.


KeyframedAnimationSet.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXKeyframedAnimationSet, which allows unmanaged COM clients to create an instance of the managed KeyframedAnimationSet class. Not supported.


KeyframedAnimationSet.GetRotationKey(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetRotationKey Method

Retrieves rotation information for a specific key frame in the animation set.

Definition

Visual Basic Public Function GetRotationKey( _
ByVal animation As Integer, _
ByVal key As Integer _
) As KeyQuaternion
C# public KeyQuaternion GetRotationKey(
int animation,
int key
);
C++ public:
KeyQuaternion GetRotationKey(
int animation,
int key
);
JScript public function GetRotationKey(
animation : int,
key : int
) : KeyQuaternion;

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.

Return Value

Microsoft.DirectX.Direct3D.KeyQuaternion
A KeyQuaternion object that contains the key frame's rotation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.GetRotationKeys(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetRotationKeys Method

Fills an array with rotational key data used for keyframe animation.

Definition

Visual Basic Public Function GetRotationKeys( _
ByVal animation As Integer _
) As KeyQuaternion()
C# public KeyQuaternion[] GetRotationKeys(
int animation
);
C++ public:
array<KeyQuaternion>^ GetRotationKeys(
int animation
);
JScript public function GetRotationKeys(
animation : int
) : KeyQuaternion[];

Parameters

animation System.Int32
Animation index.

Return Value

Microsoft.DirectX.Direct3D.KeyQuaternion[]
Array of KeyQuaternion structures that contain animation rotation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetNumberRotationKeys


KeyframedAnimationSet.GetScaleKey(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetScaleKey Method

Retrieves scale information for a specific key frame in the animation set.

Definition

Visual Basic Public Function GetScaleKey( _
ByVal animation As Integer, _
ByVal key As Integer _
) As KeyVector3
C# public KeyVector3 GetScaleKey(
int animation,
int key
);
C++ public:
KeyVector3 GetScaleKey(
int animation,
int key
);
JScript public function GetScaleKey(
animation : int,
key : int
) : KeyVector3;

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.

Return Value

Microsoft.DirectX.Direct3D.KeyVector3
A KeyVector3 object that contains the key frame's scale data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.GetScaleKeys(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetScaleKeys Method

Fills an array with scale key data used for keyframe animation.

Definition

Visual Basic Public Function GetScaleKeys( _
ByVal animation As Integer _
) As KeyVector3()
C# public KeyVector3[] GetScaleKeys(
int animation
);
C++ public:
array<KeyVector3>^ GetScaleKeys(
int animation
);
JScript public function GetScaleKeys(
animation : int
) : KeyVector3[];

Parameters

animation System.Int32
Animation index.

Return Value

Microsoft.DirectX.Direct3D.KeyVector3[]
Array of KeyVector3 structures that contain animation scale data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetNumberScaleKeys


KeyframedAnimationSet.GetTranslationKey(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetTranslationKey Method

Retrieves translation information for a specific key frame in the animation set.

Definition

Visual Basic Public Function GetTranslationKey( _
ByVal animation As Integer, _
ByVal key As Integer _
) As KeyVector3
C# public KeyVector3 GetTranslationKey(
int animation,
int key
);
C++ public:
KeyVector3 GetTranslationKey(
int animation,
int key
);
JScript public function GetTranslationKey(
animation : int,
key : int
) : KeyVector3;

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.

Return Value

Microsoft.DirectX.Direct3D.KeyVector3
A KeyVector3 object that contains the key frame's translation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.GetTranslationKeys(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.GetTranslationKeys Method

Fills an array with translational key data used for keyframe animation.

Definition

Visual Basic Public Function GetTranslationKeys( _
ByVal animation As Integer _
) As KeyVector3()
C# public KeyVector3[] GetTranslationKeys(
int animation
);
C++ public:
array<KeyVector3>^ GetTranslationKeys(
int animation
);
JScript public function GetTranslationKeys(
animation : int
) : KeyVector3[];

Parameters

animation System.Int32
Animation index.

Return Value

Microsoft.DirectX.Direct3D.KeyVector3[]
Array of KeyVector3 structures that contain animation translation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetNumberTranslationKeys


KeyframedAnimationSet.KeyframedAnimationSet Constructor ()

Creates a KeyframedAnimationSet.

Overload List

public KeyframedAnimationSet(ID3DXKeyframedAnimationSet);
public KeyframedAnimationSet(IntPtr);
public KeyframedAnimationSet(string, double, PlaybackType, int, KeyCallback[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.KeyframedAnimationSet(ID3DXKeyframedAnimationSet) Constructor (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.KeyframedAnimationSet Constructor

Creates a KeyframedAnimationSet.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As ID3DXKeyframedAnimationSet _
)
C# public KeyframedAnimationSet(
ID3DXKeyframedAnimationSet pInterop
);
C++ public:
KeyframedAnimationSet(
ID3DXKeyframedAnimationSet pInterop
);
JScript public function KeyframedAnimationSet(
pInterop : ID3DXKeyframedAnimationSet
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXKeyframedAnimationSet
Unmanaged Component Object Model (COM) ID3DXKeyframedAnimationSet interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.KeyframedAnimationSet(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.KeyframedAnimationSet Constructor

Creates a KeyframedAnimationSet.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public KeyframedAnimationSet(
IntPtr unmanagedObject
);
C++ public:
KeyframedAnimationSet(
IntPtr unmanagedObject
);
JScript public function KeyframedAnimationSet(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXKeyframedAnimationSet interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.KeyframedAnimationSet(String,Double,PlaybackType,Int32,KeyCallback[]) Constructor (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.KeyframedAnimationSet Constructor

Creates a KeyframedAnimationSet.

Definition

Visual Basic Public Sub New( _
ByVal name As String, _
ByVal ticksPerSecond As Double, _
ByVal playback As PlaybackType, _
ByVal numberAnimations As Integer, _
ByVal callbackKeys() As KeyCallback _
)
C# public KeyframedAnimationSet(
string name,
double ticksPerSecond,
PlaybackType playback,
int numberAnimations,
KeyCallback[] callbackKeys
);
C++ public:
KeyframedAnimationSet(
String^ name,
double ticksPerSecond,
PlaybackType playback,
int numberAnimations,
array<KeyCallback>^ callbackKeys
);
JScript public function KeyframedAnimationSet(
name : String,
ticksPerSecond : double,
playback : PlaybackType,
numberAnimations : int,
callbackKeys : KeyCallback[]
);

Parameters

name System.String
String that contains the name of the animation set.
ticksPerSecond System.Double
Number of key-frame ticks that elapse per second.
playback Microsoft.DirectX.Direct3D.PlaybackType
Type of the animation set playback loop. For more information, see PlaybackType.
numberAnimations System.Int32
Number of scale, rotate, and translate (SRT) animation sets.
callbackKeys Microsoft.DirectX.Direct3D.KeyCallback[]
Array that contains the callback keys.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


KeyframedAnimationSet.op_Equality(KeyframedAnimationSet,KeyframedAnimationSet) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As KeyframedAnimationSet, _
ByVal right As KeyframedAnimationSet _
) As Boolean
C# public static bool op_Equality(
KeyframedAnimationSet left,
KeyframedAnimationSet right
);
C++ public:
static bool operator==(
KeyframedAnimationSet^ left,
KeyframedAnimationSet^ right
);
JScript public static function op_Equality(
left : KeyframedAnimationSet,
right : KeyframedAnimationSet
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.KeyframedAnimationSet
The KeyframedAnimationSet object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.KeyframedAnimationSet
The KeyframedAnimationSet object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


KeyframedAnimationSet.op_Inequality(KeyframedAnimationSet,KeyframedAnimationSet) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As KeyframedAnimationSet, _
ByVal right As KeyframedAnimationSet _
) As Boolean
C# public static bool op_Inequality(
KeyframedAnimationSet left,
KeyframedAnimationSet right
);
C++ public:
static bool operator!=(
KeyframedAnimationSet^ left,
KeyframedAnimationSet^ right
);
JScript public static function op_Inequality(
left : KeyframedAnimationSet,
right : KeyframedAnimationSet
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.KeyframedAnimationSet
The KeyframedAnimationSet object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.KeyframedAnimationSet
The KeyframedAnimationSet object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


KeyframedAnimationSet.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


KeyframedAnimationSet.RegisterAnimationKeys(String,KeyVector3[],KeyQuaternion[],KeyVector3[]) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.RegisterAnimationKeys Method

Registers all of the scale, rotate, and translate (SRT) keyframe data of an animation, and fills arrays with SRT key data used for keyframe animation.

Definition

Visual Basic Public Function RegisterAnimationKeys( _
ByVal animationName As String, _
ByVal scaleKeys() As KeyVector3, _
ByVal rotationKeys() As KeyQuaternion, _
ByVal translationKeys() As KeyVector3 _
) As Integer
C# public int RegisterAnimationKeys(
string animationName,
KeyVector3[] scaleKeys,
KeyQuaternion[] rotationKeys,
KeyVector3[] translationKeys
);
C++ public:
int RegisterAnimationKeys(
String^ animationName,
array<KeyVector3>^ scaleKeys,
array<KeyQuaternion>^ rotationKeys,
array<KeyVector3>^ translationKeys
);
JScript public function RegisterAnimationKeys(
animationName : String,
scaleKeys : KeyVector3[],
rotationKeys : KeyQuaternion[],
translationKeys : KeyVector3[]
) : int;

Parameters

animationName System.String
String that contains the animation name.
scaleKeys Microsoft.DirectX.Direct3D.KeyVector3[]
Array of KeyVector3 structures that contain animation scale data.
rotationKeys Microsoft.DirectX.Direct3D.KeyQuaternion[]
Array of KeyQuaternion structures that contain animation rotation data.
translationKeys Microsoft.DirectX.Direct3D.KeyVector3[]
Array of KeyVector3 structures that contain animation translation data.

Return Value

System.Int32
The animation index.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • GetNumberRotationKeys
  • GetNumberScaleKeys
  • GetNumberTranslationKeys


KeyframedAnimationSet.SetCallbackKey(Int32,KeyCallback) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.SetCallbackKey Method

Sets information about a specific callback in the animation set.

Definition

Visual Basic Public Sub SetCallbackKey( _
ByVal index As Integer, _
ByVal value As KeyCallback _
)
C# public void SetCallbackKey(
int index,
KeyCallback value
);
C++ public:
void SetCallbackKey(
int index,
KeyCallback value
);
JScript public function SetCallbackKey(
index : int,
value : KeyCallback
);

Parameters

index System.Int32
An integer that represents the animation index.
value Microsoft.DirectX.Direct3D.KeyCallback
A KeyCallback object that describes the animation's callback key.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.SetRotationKey(Int32,Int32,KeyQuaternion) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.SetRotationKey Method

Sets rotation information for a specific key frame in the animation set.

Definition

Visual Basic Public Sub SetRotationKey( _
ByVal animation As Integer, _
ByVal key As Integer, _
ByVal value As KeyQuaternion _
)
C# public void SetRotationKey(
int animation,
int key,
KeyQuaternion value
);
C++ public:
void SetRotationKey(
int animation,
int key,
KeyQuaternion value
);
JScript public function SetRotationKey(
animation : int,
key : int,
value : KeyQuaternion
);

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.
value Microsoft.DirectX.Direct3D.KeyQuaternion
A KeyQuaternion object that contains the key frame's rotation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.SetScaleKey(Int32,Int32,KeyVector3) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.SetScaleKey Method

Sets scale information for a specific key frame in the animation set.

Definition

Visual Basic Public Sub SetScaleKey( _
ByVal animation As Integer, _
ByVal key As Integer, _
ByVal value As KeyVector3 _
)
C# public void SetScaleKey(
int animation,
int key,
KeyVector3 value
);
C++ public:
void SetScaleKey(
int animation,
int key,
KeyVector3 value
);
JScript public function SetScaleKey(
animation : int,
key : int,
value : KeyVector3
);

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.
value Microsoft.DirectX.Direct3D.KeyVector3
A KeyVector3 object that contains the key frame's scale data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.SetTranslationKey(Int32,Int32,KeyVector3) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.SetTranslationKey Method

Sets translation information for a specific key frame in the animation set.

Definition

Visual Basic Public Sub SetTranslationKey( _
ByVal animation As Integer, _
ByVal key As Integer, _
ByVal value As KeyVector3 _
)
C# public void SetTranslationKey(
int animation,
int key,
KeyVector3 value
);
C++ public:
void SetTranslationKey(
int animation,
int key,
KeyVector3 value
);
JScript public function SetTranslationKey(
animation : int,
key : int,
value : KeyVector3
);

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.
value Microsoft.DirectX.Direct3D.KeyVector3
A KeyVector3 object that contains the key frame's translation data.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UnregisterAnimation(Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.UnregisterAnimation Method

Removes the animation data from the animation set.

Definition

Visual Basic Public Sub UnregisterAnimation( _
ByVal index As Integer _
)
C# public void UnregisterAnimation(
int index
);
C++ public:
void UnregisterAnimation(
int index
);
JScript public function UnregisterAnimation(
index : int
);

Parameters

index System.Int32
An integer that represents the index of the animation data to be removed.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UnregisterRotationKey(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.UnregisterRotationKey Method

Removes the rotation data at the specified key frame.

Definition

Visual Basic Public Sub UnregisterRotationKey( _
ByVal animation As Integer, _
ByVal key As Integer _
)
C# public void UnregisterRotationKey(
int animation,
int key
);
C++ public:
void UnregisterRotationKey(
int animation,
int key
);
JScript public function UnregisterRotationKey(
animation : int,
key : int
);

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UnregisterScaleKey(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.UnregisterScaleKey Method

Removes the scale data at the specified key frame.

Definition

Visual Basic Public Sub UnregisterScaleKey( _
ByVal animation As Integer, _
ByVal key As Integer _
)
C# public void UnregisterScaleKey(
int animation,
int key
);
C++ public:
void UnregisterScaleKey(
int animation,
int key
);
JScript public function UnregisterScaleKey(
animation : int,
key : int
);

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UnregisterTranslationKey(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.UnregisterTranslationKey Method

Removes the translation data at the specified key frame.

Definition

Visual Basic Public Sub UnregisterTranslationKey( _
ByVal animation As Integer, _
ByVal key As Integer _
)
C# public void UnregisterTranslationKey(
int animation,
int key
);
C++ public:
void UnregisterTranslationKey(
int animation,
int key
);
JScript public function UnregisterTranslationKey(
animation : int,
key : int
);

Parameters

animation System.Int32
An integer that represents the animation index.
key System.Int32
An integer that represents the animation key frame.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


KeyframedAnimationSet.UpdateUnmanagedPointer(ID3DXKeyframedAnimationSet) Method (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this KeyframedAnimationSet object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXKeyframedAnimationSet _
)
C# public void UpdateUnmanagedPointer(
ID3DXKeyframedAnimationSet pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXKeyframedAnimationSet pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXKeyframedAnimationSet
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXKeyframedAnimationSet
Pointer to the ID3DXKeyframedAnimationSet structure used to update the unmanaged pointer for this KeyframedAnimationSet object.


KeyframedAnimationSet.Disposed Property (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public Shadows ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


KeyframedAnimationSet.NumberCallbackKeys Property (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.NumberCallbackKeys Property

Retrieves the number of callback keys in an animation set.

Definition

Visual Basic | Public ReadOnly Property NumberCallbackKeys As Integer
C# | public int NumberCallbackKeys { get; }
C++ public:
property int NumberCallbackKeys {
int get();
}
JScript | public function get NumberCallbackKeys() : int

Property Value

System.Int32
Number of callback keys in the animation set.

This property is read-only.


KeyframedAnimationSet.PlaybackType Property (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.PlaybackType Property

Retrieves the type of the animation set playback loop.

Definition

Visual Basic | Public ReadOnly Property PlaybackType As PlaybackType
C# | public PlaybackType PlaybackType { get; }
C++ public:
property PlaybackType PlaybackType {
PlaybackType get();
}
JScript | public function get PlaybackType() : PlaybackType

Property Value

Microsoft.DirectX.Direct3D.PlaybackType
Type of the animation set playback loop. For more information, see PlaybackType.

This property is read-only.


KeyframedAnimationSet.SourceTicksPerSecond Property (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.SourceTicksPerSecond Property

Retrieves the number of animation keyframe ticks that occur per second.

Definition

Visual Basic | Public ReadOnly Property SourceTicksPerSecond As Double
C# | public double SourceTicksPerSecond { get; }
C++ public:
property double SourceTicksPerSecond {
double get();
}
JScript | public function get SourceTicksPerSecond() : double

Property Value

System.Double
Number of animation keyframe ticks that occur per second.

This property is read-only.


KeyframedAnimationSet.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXKeyframedAnimationSet interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As ID3DXKeyframedAnimationSet
C# | public ID3DXKeyframedAnimationSet UnmanagedComPointer { get; }
C++ public:
property ID3DXKeyframedAnimationSet UnmanagedComPointer {
ID3DXKeyframedAnimationSet get();
}
JScript | public function get UnmanagedComPointer() : ID3DXKeyframedAnimationSet

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXKeyframedAnimationSet
Unmanaged ID3DXKeyframedAnimationSet interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


KeyframedAnimationSet.Disposing Event (Microsoft.DirectX.Direct3D)

KeyframedAnimationSet.Disposing Event

Occurs when the Dispose method is called or when the KeyframedAnimationSet object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.KeyframedAnimationSet.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the KeyframedAnimationSet object indicates whether that object has been disposed.


Light Class (Microsoft.DirectX.Direct3D)

Light Class

Defines a set of lighting properties.

Definition

Visual Basic NotInheritable Public Class Light
Inherits Object
C# | public sealed class Light : Object
C++ | public ref class Light sealed : Object
JScript | public final class Light extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FromLight | Creates a new light based on an existing light.
Light | Creates a new instance of the Light class.
ToString | Obtains a string representation of the current instance.
Update | Updates the settings for the current Light object.

Properties

Property | Description
Ambient Retrieves or sets the ambient color emitted by the light.

This member is a Color Leave Site structure.
AmbientColor Retrieves or sets the ambient color emitted by the light.

This member is a ColorValue structure.
Attenuation0 | Retrieves or sets a value that specifies how light intensity changes over distance.
Attenuation1 | Retrieves or sets a value that specifies how light intensity changes over distance.
Attenuation2 | Retrieves or sets a value that specifies how light intensity changes over distance.
Diffuse Retrieves or sets the diffuse color emitted by the light.

This member is a Color Leave Site structure.
DiffuseColor Retrieves or sets the diffuse color emitted by the light.

This member is a ColorValue structure.
Direction | Retrieves or sets the direction in which the light is pointing in world space, as specified by a Vector3 structure.
Enabled | Retrieves or sets a Boolean value that enables or disables a set of lighting parameters within a device.
Falloff | Retrieves or sets the decrease in illumination between a spotlight's inner cone (the angle specified by InnerConeAngle) and the outer edge of the outer cone (the angle specified by OuterConeAngle).
InnerConeAngle | Retrieves or sets the angle, in radians, of a spotlight's inner cone; that is, the fully illuminated spotlight cone.
OuterConeAngle | Retrieves or sets the angle, in radians, that defines the outer edge of a spotlight's outer cone.
Position | Retrieves or sets the position of the light in world space, as specified by a Vector3 structure.
Range | Retrieves or sets the distance beyond which the light has no effect.
Specular Retrieves or sets the specular color emitted by the light.

This member is a Color Leave Site structure.
SpecularColor Retrieves or sets the specular color emitted by the light.

This member is a ColorValue structure.
Type | Retrieves or sets the type of the light source.
XDirection | Retrieves or sets an X-axis value that indicates the direction in which the light points.
XPosition | Retrieves or sets an X-coordinate value that indicates the position of the light.
YDirection | Retrieves or sets a Y-axis value that indicates the direction of the light.
YPosition | Retrieves or sets a Y-coordinate value that indicates the position of the light.
ZDirection | Retrieves or sets a Z-axis value that indicates the direction of the light.
ZPosition | Retrieves or sets a Z-coordinate value that indicates the position of the light.

Inheritance Hierarchy

Object Leave Site
Light

Remarks

Light properties are not updated on the device until either Light.Update is called to commit the changes or Light.Enabled is set to true.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • LightsCollection


Light.FromLight(Light) Method (Microsoft.DirectX.Direct3D)

Light.FromLight Method

Creates a new light based on an existing light.

Definition

Visual Basic Public Sub FromLight( _
ByVal light As Light _
)
C# public void FromLight(
Light light
);
C++ public:
void FromLight(
Light^ light
);
JScript public function FromLight(
light : Light
);

Parameters

light Microsoft.DirectX.Direct3D.Light
Existing light that is used to create the new light.


Light.Light Constructor ()

Creates a new instance of the Light class.

Overload List

public Light();
public Light(_D3DLIGHT9);


Light.Light(_D3DLIGHT9) Constructor (Microsoft.DirectX.Direct3D)

Light.Light Constructor

Creates a new instance of the Light class.

Definition

Visual Basic Public Sub New( _
ByVal pLight As _D3DLIGHT9 _
)
C# public Light(
_D3DLIGHT9 pLight
);
C++ public:
Light(
_D3DLIGHT9 pLight
);
JScript public function Light(
pLight : _D3DLIGHT9
);

Parameters

pLight Microsoft.DirectX.PrivateImplementationDetails._D3DLIGHT9
Unmanaged _D3DLIGHT9 structure pointer.


Light.Light() Constructor (Microsoft.DirectX.Direct3D)

Light.Light Constructor

Creates a new instance of the Light class.

Definition

Visual Basic | Public Sub New()
C# | public Light();
C++ public:
Light();
JScript | public function Light();


Light.ToString() Method (Microsoft.DirectX.Direct3D)

Light.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Light.Update() Method (Microsoft.DirectX.Direct3D)

Light.Update Method

Updates the settings for the current Light object.

Definition

Visual Basic | Public Sub Update()
C# | public void Update();
C++ public:
void Update();
JScript | public function Update();

Remarks

Changes made to the Light object's properties do not take effect until this method is called, or Light.Enabled is set to true.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Light.Ambient Property (Microsoft.DirectX.Direct3D)

Light.Ambient Property

Retrieves or sets the ambient color emitted by the light.

This member is a Color Leave Site structure.

Definition

Visual Basic | Public Property Ambient As Color
C# | public Color Ambient { get; set; }
C++ public:
property Color Ambient {
Color get();
void set(Color value);
}
JScript public function get Ambient() : Color
public function set Ambient(Color);

Property Value

System.Drawing.Color
A Color Leave Site structure that represents the ambient color emitted by the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.AmbientColor Property (Microsoft.DirectX.Direct3D)

Light.AmbientColor Property

Retrieves or sets the ambient color emitted by the light.

This member is a ColorValue structure.

Definition

Visual Basic | Public Property AmbientColor As ColorValue
C# | public ColorValue AmbientColor { get; set; }
C++ public:
property ColorValue AmbientColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get AmbientColor() : ColorValue
public function set AmbientColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
ColorValue structure that represents the ambient color emitted by the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.Attenuation0 Property (Microsoft.DirectX.Direct3D)

Light.Attenuation0 Property

Retrieves or sets a value that specifies how light intensity changes over distance.

Definition

Visual Basic | Public Property Attenuation0 As Single
C# | public float Attenuation0 { get; set; }
C++ public:
property float Attenuation0 {
float get();
void set(float value);
}
JScript public function get Attenuation0() : float
public function set Attenuation0(float);

Property Value

System.Single
Value that specifies how light intensity changes over distance.

This property is read/write.

Remarks

Attenuation values are ignored for directional lights. This member represents an attenuation constant. Its valid values range from 0.0 to infinity. For non-directional lights, all three attenuation values should not be set to 0.0 simultaneously.

Exceptions
InvalidCallException The property value is invalid.


Light.Attenuation1 Property (Microsoft.DirectX.Direct3D)

Light.Attenuation1 Property

Retrieves or sets a value that specifies how light intensity changes over distance.

Definition

Visual Basic | Public Property Attenuation1 As Single
C# | public float Attenuation1 { get; set; }
C++ public:
property float Attenuation1 {
float get();
void set(float value);
}
JScript public function get Attenuation1() : float
public function set Attenuation1(float);

Property Value

System.Single
Value that specifies how light intensity changes over distance.

This property is read/write.

Remarks

Attenuation values are ignored for directional lights. This member represents an attenuation constant. Its valid values range from 0.0 to infinity. For non-directional lights, all three attenuation values should not be set to 0.0 simultaneously.

Exceptions
InvalidCallException The property value is invalid.


Light.Attenuation2 Property (Microsoft.DirectX.Direct3D)

Light.Attenuation2 Property

Retrieves or sets a value that specifies how light intensity changes over distance.

Definition

Visual Basic | Public Property Attenuation2 As Single
C# | public float Attenuation2 { get; set; }
C++ public:
property float Attenuation2 {
float get();
void set(float value);
}
JScript public function get Attenuation2() : float
public function set Attenuation2(float);

Property Value

System.Single
Value that specifies how light intensity changes over distance.

This property is read/write.

Remarks

Attenuation values are ignored for directional lights. This member represents an attenuation constant. Its valid values range from 0.0 to infinity. For non-directional lights, all three attenuation values should not be set to 0.0 simultaneously.

Exceptions
InvalidCallException The property value is invalid.


Light.Diffuse Property (Microsoft.DirectX.Direct3D)

Light.Diffuse Property

Retrieves or sets the diffuse color emitted by the light.

This member is a Color Leave Site structure.

Definition

Visual Basic | Public Property Diffuse As Color
C# | public Color Diffuse { get; set; }
C++ public:
property Color Diffuse {
Color get();
void set(Color value);
}
JScript public function get Diffuse() : Color
public function set Diffuse(Color);

Property Value

System.Drawing.Color
A Color Leave Site structure that represents the diffuse color.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.DiffuseColor Property (Microsoft.DirectX.Direct3D)

Light.DiffuseColor Property

Retrieves or sets the diffuse color emitted by the light.

This member is a ColorValue structure.

Definition

Visual Basic | Public Property DiffuseColor As ColorValue
C# | public ColorValue DiffuseColor { get; set; }
C++ public:
property ColorValue DiffuseColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get DiffuseColor() : ColorValue
public function set DiffuseColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure that represents the diffuse color.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.Direction Property (Microsoft.DirectX.Direct3D)

Light.Direction Property

Retrieves or sets the direction in which the light is pointing in world space, as specified by a Vector3 structure.

Definition

Visual Basic | Public Property Direction As Vector3
C# | public Vector3 Direction { get; set; }
C++ public:
property Vector3 Direction {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Direction() : Vector3
public function set Direction(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 structure that represents the direction in which the light is pointing.

This property is read/write.

Remarks

This member has meaning only for directional light and spotlights. The vector need not be normalized, but it should have a nonzero length.

Exceptions
InvalidCallException The property value is invalid.


Light.Enabled Property (Microsoft.DirectX.Direct3D)

Light.Enabled Property

Retrieves or sets a Boolean value that enables or disables a set of lighting parameters within a device.

Definition

Visual Basic | Public Property Enabled As Boolean
C# | public bool Enabled { get; set; }
C++ public:
property bool Enabled {
bool get();
void set(bool value);
}
JScript public function get Enabled() : boolean
public function set Enabled(boolean);

Property Value

System.Boolean
Value that enables or disables the lighting parameters.

This property is read/write.


Light.Falloff Property (Microsoft.DirectX.Direct3D)

Light.Falloff Property

Retrieves or sets the decrease in illumination between a spotlight's inner cone (the angle specified by InnerConeAngle) and the outer edge of the outer cone (the angle specified by OuterConeAngle).

Definition

Visual Basic | Public Property Falloff As Single
C# | public float Falloff { get; set; }
C++ public:
property float Falloff {
float get();
void set(float value);
}
JScript public function get Falloff() : float
public function set Falloff(float);

Property Value

System.Single
Value that indicates the decrease in illumination.

This property is read/write.

Remarks

The effect of falloff, the light attenuation between a spotlight's inner and outer cones, on the lighting is subtle. Furthermore, a small performance penalty is incurred by shaping the falloff curve. For these reasons, most developers set this value to 1.0.

Exceptions
InvalidCallException The property value is invalid.


Light.InnerConeAngle Property (Microsoft.DirectX.Direct3D)

Light.InnerConeAngle Property

Retrieves or sets the angle, in radians, of a spotlight's inner cone; that is, the fully illuminated spotlight cone.

Definition

Visual Basic | Public Property InnerConeAngle As Single
C# | public float InnerConeAngle { get; set; }
C++ public:
property float InnerConeAngle {
float get();
void set(float value);
}
JScript public function get InnerConeAngle() : float
public function set InnerConeAngle(float);

Property Value

System.Single
Value that indicates the angle of the spotlight's inner cone.

This property is read/write.

Remarks

This value must be in the range of 0 through the value specified by OuterConeAngle.

Exceptions
InvalidCallException The property value is invalid.


Light.OuterConeAngle Property (Microsoft.DirectX.Direct3D)

Light.OuterConeAngle Property

Retrieves or sets the angle, in radians, that defines the outer edge of a spotlight's outer cone.

Definition

Visual Basic | Public Property OuterConeAngle As Single
C# | public float OuterConeAngle { get; set; }
C++ public:
property float OuterConeAngle {
float get();
void set(float value);
}
JScript public function get OuterConeAngle() : float
public function set OuterConeAngle(float);

Property Value

System.Single
Value that indicates the angle of the outer edge of the spotlight's outer cone.

This property is read/write.

Remarks

Points outside of the cone are not lit by the spotlight.

This value must fall between 0 and pi.

Exceptions
InvalidCallException The property value is invalid.

See Also

  • InnerConeAngle


Light.Position Property (Microsoft.DirectX.Direct3D)

Light.Position Property

Retrieves or sets the position of the light in world space, as specified by a Vector3 structure.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 structure that represents the position of the light in world space.

This property is read/write.

Remarks

This member has no effect on directional lights.

Exceptions
InvalidCallException The property value is invalid.


Light.Range Property (Microsoft.DirectX.Direct3D)

Light.Range Property

Retrieves or sets the distance beyond which the light has no effect.

Definition

Visual Basic | Public Property Range As Single
C# | public float Range { get; set; }
C++ public:
property float Range {
float get();
void set(float value);
}
JScript public function get Range() : float
public function set Range(float);

Property Value

System.Single
Value that indicates the distance beyond which the light has no effect.

This property is read/write.

Remarks

The maximum allowable value for this member is the square root of MaxValue Leave Site.

This member does not affect directional lights.

Exceptions
InvalidCallException The property value is invalid.


Light.Specular Property (Microsoft.DirectX.Direct3D)

Light.Specular Property

Retrieves or sets the specular color emitted by the light.

This member is a Color Leave Site structure.

Definition

Visual Basic | Public Property Specular As Color
C# | public Color Specular { get; set; }
C++ public:
property Color Specular {
Color get();
void set(Color value);
}
JScript public function get Specular() : Color
public function set Specular(Color);

Property Value

System.Drawing.Color
A Color Leave Site structure that represents the specular color.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.SpecularColor Property (Microsoft.DirectX.Direct3D)

Light.SpecularColor Property

Retrieves or sets the specular color emitted by the light.

This member is a ColorValue structure.

Definition

Visual Basic | Public Property SpecularColor As ColorValue
C# | public ColorValue SpecularColor { get; set; }
C++ public:
property ColorValue SpecularColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get SpecularColor() : ColorValue
public function set SpecularColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure that represents the specular color.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.Type Property (Microsoft.DirectX.Direct3D)

Light.Type Property

Retrieves or sets the type of the light source.

Definition

Visual Basic | Public Property Type As LightType
C# | public LightType Type { get; set; }
C++ public:
property LightType Type {
LightType get();
void set(LightType value);
}
JScript public function get Type() : LightType
public function set Type(LightType);

Property Value

Microsoft.DirectX.Direct3D.LightType
A value that represents the light source's type.

This property is read/write.

Remarks

This value is a member of the LightType enumerated type.

Exceptions
InvalidCallException The property value is invalid.


Light.XDirection Property (Microsoft.DirectX.Direct3D)

Light.XDirection Property

Retrieves or sets an X-axis value that indicates the direction in which the light points.

Definition

Visual Basic | Public Property XDirection As Single
C# | public float XDirection { get; set; }
C++ public:
property float XDirection {
float get();
void set(float value);
}
JScript public function get XDirection() : float
public function set XDirection(float);

Property Value

System.Single
Value that indicates the direction in which the light points.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.XPosition Property (Microsoft.DirectX.Direct3D)

Light.XPosition Property

Retrieves or sets an X-coordinate value that indicates the position of the light.

Definition

Visual Basic | Public Property XPosition As Single
C# | public float XPosition { get; set; }
C++ public:
property float XPosition {
float get();
void set(float value);
}
JScript public function get XPosition() : float
public function set XPosition(float);

Property Value

System.Single
Value that indicates the position of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.YDirection Property (Microsoft.DirectX.Direct3D)

Light.YDirection Property

Retrieves or sets a Y-axis value that indicates the direction of the light.

Definition

Visual Basic | Public Property YDirection As Single
C# | public float YDirection { get; set; }
C++ public:
property float YDirection {
float get();
void set(float value);
}
JScript public function get YDirection() : float
public function set YDirection(float);

Property Value

System.Single
Value that indicates the direction of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.YPosition Property (Microsoft.DirectX.Direct3D)

Light.YPosition Property

Retrieves or sets a Y-coordinate value that indicates the position of the light.

Definition

Visual Basic | Public Property YPosition As Single
C# | public float YPosition { get; set; }
C++ public:
property float YPosition {
float get();
void set(float value);
}
JScript public function get YPosition() : float
public function set YPosition(float);

Property Value

System.Single
Value that indicates the position of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.ZDirection Property (Microsoft.DirectX.Direct3D)

Light.ZDirection Property

Retrieves or sets a Z-axis value that indicates the direction of the light.

Definition

Visual Basic | Public Property ZDirection As Single
C# | public float ZDirection { get; set; }
C++ public:
property float ZDirection {
float get();
void set(float value);
}
JScript public function get ZDirection() : float
public function set ZDirection(float);

Property Value

System.Single
Value that indicates the direction of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


Light.ZPosition Property (Microsoft.DirectX.Direct3D)

Light.ZPosition Property

Retrieves or sets a Z-coordinate value that indicates the position of the light.

Definition

Visual Basic | Public Property ZPosition As Single
C# | public float ZPosition { get; set; }
C++ public:
property float ZPosition {
float get();
void set(float value);
}
JScript public function get ZPosition() : float
public function set ZPosition(float);

Property Value

System.Single
Value that indicates the position of the light.

This property is read/write.

Remarks

Exceptions
InvalidCallException The property value is invalid.


LightsCollection Class (Microsoft.DirectX.Direct3D)

LightsCollection Class

Defines a collection of lights.

Definition

Visual Basic NotInheritable Public Class LightsCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class LightsCollection : Object, IEnumerable, IEnumerator
C++ | public ref class LightsCollection sealed : Object, IEnumerable, IEnumerator
JScript | public final class LightsCollection extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Returns an enumerator that can iterate through the LightsCollection.
MoveNext | Advances the enumerator to the next light.
Reset | Resets the current enumerator to point to the head of the queue.

Properties

Property | Description
Count | Retrieves the number of Light objects in the LightsCollection.
Current | Retrieves the current Light object in the LightsCollection.
Item | Retrieves a specific Light object within the LightsCollection.

Inheritance Hierarchy

Object Leave Site
LightsCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


LightsCollection.GetEnumerator() Method (Microsoft.DirectX.Direct3D)

LightsCollection.GetEnumerator Method

Returns an enumerator that can iterate through the LightsCollection.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator
An enumerator that can iterate through the LightsCollection.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


LightsCollection.MoveNext() Method (Microsoft.DirectX.Direct3D)

LightsCollection.MoveNext Method

Advances the enumerator to the next light.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean
Set to true if the move to the next item was sucessful; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


LightsCollection.Reset() Method (Microsoft.DirectX.Direct3D)

LightsCollection.Reset Method

Resets the current enumerator to point to the head of the queue.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();

Remarks

An enumerator can move only in a forward direction. This method restarts the enumerator at the beginning of the queue.

After Reset Leave Site is called, the cursor is undefined. Call MoveNext Leave Site initially to point to the first item in the list.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


LightsCollection.Count Property (Microsoft.DirectX.Direct3D)

LightsCollection.Count Property

Retrieves the number of Light objects in the LightsCollection.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32
Number of Light objects in the LightsCollection.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


LightsCollection.Current Property (Microsoft.DirectX.Direct3D)

LightsCollection.Current Property

Retrieves the current Light object in the LightsCollection.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object
Current Light object in the LightsCollection.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


LightsCollection.Item Property (Microsoft.DirectX.Direct3D)

LightsCollection.Item Property

Retrieves a specific Light object within the LightsCollection.

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal index As Integer _
) As Light
C# public Light this[
int index
] { get; }
C++ public:
property Light^ default [int] {
Light^ get(int index);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32
Index value of the light to retrieve.

Property Value

Microsoft.DirectX.Direct3D.Light
The Light object at the given index.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Line Class (Microsoft.DirectX.Direct3D)

Line Class

Implements line drawing using textured triangles.

Definition

Visual Basic NotInheritable Public Class Line
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class Line : MarshalByRefObject, IDisposable
C++ | public ref class Line sealed : MarshalByRefObject, IDisposable
JScript | public final class Line extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Line object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally just before a device is reset.
Reset | Occurs after the Line.OnResetDevice method is called or after the Line is reset.

Methods

Method | Description
Begin | Prepares a device to draw lines.
Dispose | Immediately releases the unmanaged resources used by the Line object.
Draw | Draws a line strip in screen space. Input is in the form of an array that defines points (of Vector2) on the line strip.
DrawTransform | Draws a line strip in screen space with a specified input transformation matrix.
End | Restores the device to the state it was in when Line.Begin was called.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Line object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
Line | Uses a left-handed coordinate system to create a line.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Line.Disposing event when called from within a derived class.
raise_Lost | Raises a Line.Lost event when called from within a derived class.
raise_Reset | Raises a Line.Reset event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Line object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Antialias | Retrieves or sets the antialiasing switch value for a line.
Device | Retrieves the Direct3D device associated with a line object.
Disposed | Gets a value that indicates whether the object is disposed.
GlLines | Retrieves or sets a value that switches between Microsoft Direct3D and OpenGL line-drawing modes.
Pattern | Retrieves or sets the line stipple pattern.
PatternScale | Retrieves or sets the stipple-pattern scale value.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXLine interface pointer.
Width | Retrieves or sets the thickness of a line.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Line

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Line.Begin() Method (Microsoft.DirectX.Direct3D)

Line.Begin Method

Prepares a device to draw lines.

Definition

Visual Basic | Public Sub Begin()
C# | public void Begin();
C++ public:
void Begin();
JScript | public function Begin();

Remarks

Calling Begin is optional. If called outside of a Begin ... Line.End sequence, the draw methods internally call Begin and End. If more than one draw method will be called successively, use this method to avoid extra overhead.

This method must be called from inside of a Device.BeginScene ... Device.EndScene sequence.

The Begin method cannot be used as a substitute for either Device.BeginScene or RenderToSurface.BeginScene.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.Dispose() Method (Microsoft.DirectX.Direct3D)

Line.Dispose Method

Immediately releases the unmanaged resources used by the Line object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Line();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Line.Disposed
  • Microsoft.DirectX.Direct3D.Line.Disposing


Line.Draw Method ()

Draws a line strip in screen space. Input is in the form of an array that defines points (of Vector2) on the line strip.

Overload List

public void Draw(Vector2[], Color);
public void Draw(Vector2[], int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • DrawTransform


Line.Draw(Vector2[],Color) Method (Microsoft.DirectX.Direct3D)

Line.Draw Method

Draws a line strip in screen space. Input is in the form of an array that defines points (of Vector2) on the line strip.

Definition

Visual Basic Public Sub Draw( _
ByVal vertexList() As Vector2, _
ByVal color As Color _
)
C# public void Draw(
Vector2[] vertexList,
Color color
);
C++ public:
void Draw(
array<Vector2>^ vertexList,
Color color
);
JScript public function Draw(
vertexList : Vector2[],
color : Color
);

Parameters

vertexList Microsoft.DirectX.Vector2[]
Array of vertices that make up the line. For more information, see Vector2.
color System.Drawing.Color
A Color Leave Site object that specifies the color of the line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • DrawTransform


Line.Draw(Vector2[],Int32) Method (Microsoft.DirectX.Direct3D)

Line.Draw Method

Draws a line strip in screen space. Input is in the form of an array that defines points (of Vector2) on the line strip.

Definition

Visual Basic Public Sub Draw( _
ByVal vertexList() As Vector2, _
ByVal color As Integer _
)
C# public void Draw(
Vector2[] vertexList,
int color
);
C++ public:
void Draw(
array<Vector2>^ vertexList,
int color
);
JScript public function Draw(
vertexList : Vector2[],
color : int
);

Parameters

vertexList Microsoft.DirectX.Vector2[]
Array of vertices that make up the line. For more information, see Vector2.
color System.Int32
An Int32 Leave Site color value that specifies the color of the line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • DrawTransform


Line.DrawTransform Method ()

Draws a line strip in screen space with a specified input transformation matrix.

Overload List

public void DrawTransform(Vector3[], Matrix, Color);
public void DrawTransform(Vector3[], Matrix, int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Draw


Line.DrawTransform(Vector3[],Matrix,Color) Method (Microsoft.DirectX.Direct3D)

Line.DrawTransform Method

Draws a line strip in screen space with a specified input transformation matrix.

Definition

Visual Basic Public Sub DrawTransform( _
ByVal vertexList() As Vector3, _
ByVal transform As Matrix, _
ByVal color As Color _
)
C# public void DrawTransform(
Vector3[] vertexList,
Matrix transform,
Color color
);
C++ public:
void DrawTransform(
array<Vector3>^ vertexList,
Matrix transform,
Color color
);
JScript public function DrawTransform(
vertexList : Vector3[],
transform : Matrix,
color : Color
);

Parameters

vertexList Microsoft.DirectX.Vector3[]
Array of vertices that make up the line. For more information, see Vector2.
transform Microsoft.DirectX.Matrix
Scale, rotate, and translate (SRT) matrix for transforming the points. For more information, see Matrix. If this matrix is a projection matrix, any stippled lines are drawn with a perspective-correct stippling pattern. Or, vertices can be transformed and Line.Draw used to draw the line with a stipple pattern and no perspective correction.
color System.Drawing.Color
A Color Leave Site object that specifies the color of the line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Draw


Line.DrawTransform(Vector3[],Matrix,Int32) Method (Microsoft.DirectX.Direct3D)

Line.DrawTransform Method

Draws a line strip in screen space with a specified input transformation matrix.

Definition

Visual Basic Public Sub DrawTransform( _
ByVal vertexList() As Vector3, _
ByVal transform As Matrix, _
ByVal color As Integer _
)
C# public void DrawTransform(
Vector3[] vertexList,
Matrix transform,
int color
);
C++ public:
void DrawTransform(
array<Vector3>^ vertexList,
Matrix transform,
int color
);
JScript public function DrawTransform(
vertexList : Vector3[],
transform : Matrix,
color : int
);

Parameters

vertexList Microsoft.DirectX.Vector3[]
Array of vertices that make up the line. For more information, see Vector2.
transform Microsoft.DirectX.Matrix
Scale, rotate, and translate (SRT) matrix for transforming the points. For more information, see Matrix. If this matrix is a projection matrix, any stippled lines are drawn with a perspective-correct stippling pattern. Or, vertices can be transformed and Line.Draw used to draw the line with a stipple pattern and no perspective correction.
color System.Int32
An Int32 Leave Site color value that specifies the color of the line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Draw


Line.End() Method (Microsoft.DirectX.Direct3D)

Line.End Method

Restores the device to the state it was in when Line.Begin was called.

Definition

Visual Basic | Public Sub End()
C# | public void End();
C++ public:
void End();
JScript | public function End();

Remarks

The End method cannot be used as a substitute for either Device.EndScene or RenderToSurface.EndScene.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Line.Begin


Line.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Line.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Line.Finalize() Method (Microsoft.DirectX.Direct3D)

Line.Finalize Method

Allows the Line object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Line();
C++ | !Line();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Line.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Line.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Line.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Line.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXLine, which allows unmanaged COM clients to create an instance of the managed Line class. Not supported.


Line.Line Constructor ()

Uses a left-handed coordinate system to create a line.

Overload List

public Line(Device);
public Line(ID3DXLine);
public Line(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Line.Line(ID3DXLine) Constructor (Microsoft.DirectX.Direct3D)

Line.Line Constructor

Uses a left-handed coordinate system to create a line.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXLine _
)
C# public Line(
ID3DXLine pUnk
);
C++ public:
Line(
ID3DXLine pUnk
);
JScript public function Line(
pUnk : ID3DXLine
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXLine
Unmanaged Component Object Model (COM) ID3DXLine interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Line.Line(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Line.Line Constructor

Uses a left-handed coordinate system to create a line.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Line(
IntPtr unmanagedObject
);
C++ public:
Line(
IntPtr unmanagedObject
);
JScript public function Line(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXLine interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Line.Line(Device) Constructor (Microsoft.DirectX.Direct3D)

Line.Line Constructor

Uses a left-handed coordinate system to create a line.

Definition

Visual Basic Public Sub New( _
ByVal device As Device _
)
C# public Line(
Device device
);
C++ public:
Line(
Device^ device
);
JScript public function Line(
device : Device
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created line.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Line.OnLostDevice() Method (Microsoft.DirectX.Direct3D)

Line.OnLostDevice Method

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic | Public Sub OnLostDevice()
C# | public void OnLostDevice();
C++ public:
void OnLostDevice();
JScript | public function OnLostDevice();


Line.OnResetDevice() Method (Microsoft.DirectX.Direct3D)

Line.OnResetDevice Method

Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic | Public Sub OnResetDevice()
C# | public void OnResetDevice();
C++ public:
void OnResetDevice();
JScript | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, it is unnecessary to call Line.OnResetDevice under normal circumstances. However, if at any point Device.IsUsingEventHandlers is set to false, Line.OnResetDevice should be called immediately after the device is reset.


Line.op_Equality(Line,Line) Method (Microsoft.DirectX.Direct3D)

Line.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Line, _
ByVal right As Line _
) As Boolean
C# public static bool op_Equality(
Line left,
Line right
);
C++ public:
static bool operator==(
Line^ left,
Line^ right
);
JScript public static function op_Equality(
left : Line,
right : Line
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Line
The Line object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Line
The Line object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Line.op_Inequality(Line,Line) Method (Microsoft.DirectX.Direct3D)

Line.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Line, _
ByVal right As Line _
) As Boolean
C# public static bool op_Inequality(
Line left,
Line right
);
C++ public:
static bool operator!=(
Line^ left,
Line^ right
);
JScript public static function op_Inequality(
left : Line,
right : Line
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Line
The Line object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Line
The Line object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Line.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Line.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Line.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Line.raise_Lost(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Line.raise_Lost Method

Raises a Line.Lost event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
C++ protected:
void raise_Lost(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Line.raise_Reset(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Line.raise_Reset Method

Raises a Line.Reset event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
C++ protected:
void raise_Reset(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Line.UpdateUnmanagedPointer(ID3DXLine) Method (Microsoft.DirectX.Direct3D)

Line.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Line object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXLine _
)
C# public void UpdateUnmanagedPointer(
ID3DXLine pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXLine pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXLine
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXLine
Pointer to the ID3DXLine structure used to update the unmanaged pointer for this Line object.


Line.Antialias Property (Microsoft.DirectX.Direct3D)

Line.Antialias Property

Retrieves or sets the antialiasing switch value for a line.

Definition

Visual Basic | Public Property Antialias As Boolean
C# | public bool Antialias { get; set; }
C++ public:
property bool Antialias {
bool get();
void set(bool value);
}
JScript public function get Antialias() : boolean
public function set Antialias(boolean);

Property Value

System.Boolean
Value that indicates antialiasing state. If true, antialiasing is on; if false, it is off.

This property is read/write.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.Device Property (Microsoft.DirectX.Direct3D)

Line.Device Property

Retrieves the Microsoft Direct3D device associated with a line object.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device that is associated with the line.

This property is read-only.

Remarks

The End method cannot be used as a substitute for either Device.EndScene or RenderToSurface.EndScene.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.Disposed Property (Microsoft.DirectX.Direct3D)

Line.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Line.GlLines Property (Microsoft.DirectX.Direct3D)

Line.GlLines Property

Retrieves or sets a value that switches between Microsoft Direct3D and OpenGL line-drawing modes.

Definition

Visual Basic | Public Property GlLines As Boolean
C# | public bool GlLines { get; set; }
C++ public:
property bool GlLines {
bool get();
void set(bool value);
}
JScript public function get GlLines() : boolean
public function set GlLines(boolean);

Property Value

System.Boolean
Value that is true if lines based on OpenGL are enabled; false if lines based on Direct3D are enabled.

This property is read/write.

Remarks

As a software interface for graphics hardware, OpenGL renders multidimensional objects into a frame buffer.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.Pattern Property (Microsoft.DirectX.Direct3D)

Line.Pattern Property

Retrieves or sets the line stipple pattern.

Definition

Visual Basic | Public Property Pattern As Integer
C# | public int Pattern { get; set; }
C++ public:
property int Pattern {
int get();
void set(int value);
}
JScript public function get Pattern() : int
public function set Pattern(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the line stipple pattern: either 1 (opaque) or 0 (transparent).

This property is read/write.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.PatternScale Property (Microsoft.DirectX.Direct3D)

Line.PatternScale Property

Retrieves or sets the stipple-pattern scale value.

Definition

Visual Basic | Public Property PatternScale As Single
C# | public float PatternScale { get; set; }
C++ public:
property float PatternScale {
float get();
void set(float value);
}
JScript public function get PatternScale() : float
public function set PatternScale(float);

Property Value

System.Single
Value that scales the stipple pattern; 1.0f is the default and represents no scaling. A value less than 1.0f shrinks the pattern, and a value greater than 1.0 stretches it.

This property is read/write.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


Line.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Line.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXLine interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXLine
C# | public ID3DXLine UnmanagedComPointer { get; }
C++ public:
property ID3DXLine UnmanagedComPointer {
ID3DXLine get();
}
JScript | public function get UnmanagedComPointer() : ID3DXLine

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXLine
Unmanaged ID3DXLine interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Line.Width Property (Microsoft.DirectX.Direct3D)

Line.Width Property

Retrieves or sets the thickness of a line.

Definition

Visual Basic | Public Property Width As Single
C# | public float Width { get; set; }
C++ public:
property float Width {
float get();
void set(float value);
}
JScript public function get Width() : float
public function set Width(float);

Property Value

System.Single
Line thickness.

This property is read/write.


Line.Disposing Event (Microsoft.DirectX.Direct3D)

Line.Disposing Event

Occurs when the Dispose method is called or when the Line object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Line.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Line object indicates whether that object has been disposed.


Line.Lost Event (Microsoft.DirectX.Direct3D)

Line.Lost Event

Occurs when an object is lost, normally just before a device is reset.

Definition

Visual Basic | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
C++ public:
event EventHandler^ Lost;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Line.Lost event, use the following C# code.

[C#]
line.Lost += new System.EventHandler(this.LostEventHandler);


Line.Reset Event (Microsoft.DirectX.Direct3D)

Line.Reset Event

Occurs after the Line.OnResetDevice method is called or after the Line is reset.

Definition

Visual Basic | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
C++ public:
event EventHandler^ Reset;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Line.Reset event, use the following C# code.

[C#]
line.Reset += new System.EventHandler(this.ResetEventHandler);


LoadedMeshHasNoDataException Class (Microsoft.DirectX.Direct3D)

LoadedMeshHasNoDataException Class

The mesh has no data.

Definition

Visual Basic Public Class LoadedMeshHasNoDataException
Inherits Direct3DXException
C# | public class LoadedMeshHasNoDataException : Direct3DXException
C++ | public ref class LoadedMeshHasNoDataException : Direct3DXException
JScript | public class LoadedMeshHasNoDataException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
LoadedMeshHasNoDataException | Initializes a new instance of the LoadedMeshHasNoDataException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
LoadedMeshHasNoDataException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor ()

Initializes a new instance of the LoadedMeshHasNoDataException class.

Overload List

public LoadedMeshHasNoDataException();
protected LoadedMeshHasNoDataException(SerializationInfo, StreamingContext);
public LoadedMeshHasNoDataException(string);
public LoadedMeshHasNoDataException(string, Exception);


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:

Initializes a new instance of the LoadedMeshHasNoDataException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected LoadedMeshHasNoDataException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
LoadedMeshHasNoDataException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function LoadedMeshHasNoDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:

Initializes a new instance of the LoadedMeshHasNoDataException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public LoadedMeshHasNoDataException(
string message,
Exception inner
);
C++ public:
LoadedMeshHasNoDataException(
String^ message,
Exception^ inner
);
JScript public function LoadedMeshHasNoDataException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException(String) Constructor (Microsoft.DirectX.Direct3D)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:

Initializes a new instance of the LoadedMeshHasNoDataException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public LoadedMeshHasNoDataException(
string message
);
C++ public:
LoadedMeshHasNoDataException(
String^ message
);
JScript public function LoadedMeshHasNoDataException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


LoadedMeshHasNoDataException.LoadedMeshHasNoDataException() Constructor (Microsoft.DirectX.Direct3D)

LoadedMeshHasNoDataException.LoadedMeshHasNoDataException Constructor

 Language:

Initializes a new instance of the LoadedMeshHasNoDataException class.

Definition

Visual Basic | Public Sub New()
C# | public LoadedMeshHasNoDataException();
C++ public:
LoadedMeshHasNoDataException();
JScript | public function LoadedMeshHasNoDataException();


LoadUserData Class (Microsoft.DirectX.Direct3D)

LoadUserData Class

Derived by the application to allocate or free frame and mesh container objects. Methods of this class are called during loading and destruction of frame hierarchies.

Definition

Visual Basic MustInherit Public Class LoadUserData
Inherits Object
C# | public abstract class LoadUserData : Object
C++ | public ref class LoadUserData abstract : Object
JScript | public abstract class LoadUserData extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Finalize | Allows the LoadUserData object to free resources before it is destroyed by the garbage collector.
LoadFrameChildData | Loads frame child data from a Microsoft DirectX (.x) file.
LoadMeshChildData | Loads mesh child data from a DirectX (.x) file.
LoadTopLevelData | Loads top-level data from a DirectX (.x) file.
LoadUserData | Initializes a new instance of the LoadUserData class.

Inheritance Hierarchy

Object Leave Site
LoadUserData

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LoadUserData.Finalize() Method (Microsoft.DirectX.Direct3D)

LoadUserData.Finalize Method

Allows the LoadUserData object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~LoadUserData();
C++ | !LoadUserData();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


LoadUserData.LoadFrameChildData(Frame,XFileData) Method (Microsoft.DirectX.Direct3D)

LoadUserData.LoadFrameChildData Method

Loads frame child data from a Microsoft DirectX (.x) file.

Definition

Visual Basic MustOverride Public Sub LoadFrameChildData( _
ByVal frame As Frame, _
ByVal xofChildData As XFileData _
)
C# public abstract void LoadFrameChildData(
Frame frame,
XFileData xofChildData
);
C++ public:
virtual void LoadFrameChildData(
Frame^ frame,
XFileData^ xofChildData
) abstract;
JScript public abstract function LoadFrameChildData(
frame : Frame,
xofChildData : XFileData
);

Parameters

frame Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the frame hierarchy.
xofChildData Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the .x file data to load.


LoadUserData.LoadMeshChildData(MeshContainer,XFileData) Method (Microsoft.DirectX.Direct3D)

LoadUserData.LoadMeshChildData Method

Loads mesh child data from a Microsoft DirectX (.x) file.

Definition

Visual Basic MustOverride Public Sub LoadMeshChildData( _
ByVal meshContainer As MeshContainer, _
ByVal xofChildData As XFileData _
)
C# public abstract void LoadMeshChildData(
MeshContainer meshContainer,
XFileData xofChildData
);
C++ public:
virtual void LoadMeshChildData(
MeshContainer^ meshContainer,
XFileData^ xofChildData
) abstract;
JScript public abstract function LoadMeshChildData(
meshContainer : MeshContainer,
xofChildData : XFileData
);

Parameters

meshContainer Microsoft.DirectX.Direct3D.MeshContainer
A MeshContainer object that represents the mesh container.
xofChildData Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the .x file data.


LoadUserData.LoadTopLevelData(XFileData) Method (Microsoft.DirectX.Direct3D)

LoadUserData.LoadTopLevelData Method

Loads top-level data from a Microsoft DirectX (.x) file.

Definition

Visual Basic MustOverride Public Sub LoadTopLevelData( _
ByVal xofChildData As XFileData _
)
C# public abstract void LoadTopLevelData(
XFileData xofChildData
);
C++ public:
virtual void LoadTopLevelData(
XFileData^ xofChildData
) abstract;
JScript public abstract function LoadTopLevelData(
xofChildData : XFileData
);

Parameters

xofChildData Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the .x file data.


LoadUserData.LoadUserData() Constructor (Microsoft.DirectX.Direct3D)

LoadUserData.LoadUserData Constructor

Initializes a new instance of the LoadUserData class.

Definition

Visual Basic | Public Sub New()
C# | public LoadUserData();
C++ public:
LoadUserData();
JScript | public function LoadUserData();


Manager Class (Microsoft.DirectX.Direct3D)

Manager Class

Provides information about the environment, and enumerates and retrieves device capabilities.

Definition

Visual Basic NotInheritable Public Class Manager
Inherits MarshalByRefObject
C# | public sealed class Manager : MarshalByRefObject
C++ | public ref class Manager sealed : MarshalByRefObject
JScript | public final class Manager extends MarshalByRefObject

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) CheckDepthStencilMatch | Determines whether a depth stencil format is compatible with a render target format in a particular display mode.
static (Shared in Visual Basic) CheckDeviceFormat | Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.
static (Shared in Visual Basic) CheckDeviceFormatConversion | Tests a device to determine whether it supports conversion from one display format to another.
static (Shared in Visual Basic) CheckDeviceMultiSampleType | Determines whether a multisampling technique is available on the current device.
static (Shared in Visual Basic) CheckDeviceType | Specifies whether a hardware-accelerated device type can be used on the current adapter.
static (Shared in Visual Basic) DisableD3DSpy | Blocks D3DSpy from monitoring an application.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Manager object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) GenerateD3DSpyBreak | Generates a breakpoint in D3DSpy when called within the application.
static (Shared in Visual Basic) GetAdapterMonitor | Returns the handle of the monitor associated with the Microsoft Direct3D object.
static (Shared in Visual Basic) GetDeviceCaps | Retrieves information specific to a device.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.

Properties

Property | Description
static (Shared in Visual Basic) Adapters | Collection of adapters on the system.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Manager

Remarks

In managed code, the Manager class replaces most of the functionality of the C++ IDirect3D9 interface, except that it does not create a device. For device creation and manipulation options, see Device. Also note that the Manager class cannot be inherited or directly instantiated.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Manager.CheckDepthStencilMatch Method ()

Determines whether a depth stencil format is compatible with a render target format in a particular display mode.

Overload List

public static bool CheckDepthStencilMatch(int, DeviceType, Format, Format, DepthFormat);
public static bool CheckDepthStencilMatch(int, DeviceType, Format, Format, DepthFormat, out int);

Remarks

The CheckDepthStencilMatch method enables applications to work with hardware that requires that certain depth formats work only with certain render-target formats.

The following C# code fragment demonstrates the use of CheckDeviceFormat to validate a depth stencil format.

              [C#]

public void TestFunc()
{
    int result;

    // Test some formats
    IsDepthFormatOK(DepthFormat.D16, Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result == (int)ResultCode.NotAvailable)
        System.Windows.Forms.MessageBox.Show(String.Format("The depth stencil format is invalid:  {0}", result));
}

private bool IsDepthFormatOK (DepthFormat depthFmt, Format adapterFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the depth format exists
    if (Manager.CheckDeviceFormat(ai.Adapter, DeviceType.Hardware, adapterFmt, Usage.DepthStencil, ResourceType.Surface, depthFmt, out result))
    {
        // Verify that the depth format is compatible
        if (Manager.CheckDepthStencilMatch(ai.Adapter, DeviceType.Hardware, adapterFmt, backbufferFmt, depthFmt, out result))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding call returns false if depthFmt cannot be used in conjunction with adapterFmt and backbufferFmt.


Manager.CheckDepthStencilMatch(Int32,DeviceType,Format,Format,DepthFormat,Int32) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDepthStencilMatch Method

Determines whether a depth stencil format is compatible with a render target format in a particular display mode.

Definition

Visual Basic Public Shared Function CheckDepthStencilMatch( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal renderTargetFormat As Format, _
ByVal depthStencilFormat As DepthFormat, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDepthStencilMatch(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Format renderTargetFormat,
DepthFormat depthStencilFormat,
out int result
);
C++ public:
static bool CheckDepthStencilMatch(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Format renderTargetFormat,
DepthFormat depthStencilFormat,
[Out] int% result
);
JScript public static function CheckDepthStencilMatch(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
renderTargetFormat : Format,
depthStencilFormat : DepthFormat,
result : int
) : boolean;

Parameters

adapter System.Int32
Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that identifies the device type.
adapterFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
renderTargetFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the render-target surface to be tested.
depthStencilFormat Microsoft.DirectX.Direct3D.DepthFormat
Member of the DepthFormat enumeration that identifies the format of the depth stencil surface to be tested.
result System.Int32
HRESULT code passed back from the method.

Return Value

System.Boolean
Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned. If a depth stencil format is not compatible with the render target in the display mode, result is set to ResultCode.NotAvailable.

Remarks

The CheckDepthStencilMatch method enables applications to work with hardware that requires that certain depth formats work only with certain render-target formats.

The following C# code fragment demonstrates the use of CheckDeviceFormat to validate a depth stencil format.

              [C#]

public void TestFunc()
{
    int result;

    // Test some formats
    IsDepthFormatOK(DepthFormat.D16, Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result == (int)ResultCode.NotAvailable)
        System.Windows.Forms.MessageBox.Show(String.Format("The depth stencil format is invalid:  {0}", result));
}

private bool IsDepthFormatOK (DepthFormat depthFmt, Format adapterFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the depth format exists
    if (Manager.CheckDeviceFormat(ai.Adapter, DeviceType.Hardware, adapterFmt, Usage.DepthStencil, ResourceType.Surface, depthFmt, out result))
    {
        // Verify that the depth format is compatible
        if (Manager.CheckDepthStencilMatch(ai.Adapter, DeviceType.Hardware, adapterFmt, backbufferFmt, depthFmt, out result))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding call returns false if depthFmt cannot be used in conjunction with adapterFmt and backbufferFmt.


Manager.CheckDepthStencilMatch(Int32,DeviceType,Format,Format,DepthFormat) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDepthStencilMatch Method

Determines whether a depth stencil format is compatible with a render target format in a particular display mode.

Definition

Visual Basic Public Shared Function CheckDepthStencilMatch( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal renderTargetFormat As Format, _
ByVal depthStencilFormat As DepthFormat _
) As Boolean
C# public static bool CheckDepthStencilMatch(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Format renderTargetFormat,
DepthFormat depthStencilFormat
);
C++ public:
static bool CheckDepthStencilMatch(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Format renderTargetFormat,
DepthFormat depthStencilFormat
);
JScript public static function CheckDepthStencilMatch(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
renderTargetFormat : Format,
depthStencilFormat : DepthFormat
) : boolean;

Parameters

adapter System.Int32
Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that identifies the device type.
adapterFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
renderTargetFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the render-target surface to be tested.
depthStencilFormat Microsoft.DirectX.Direct3D.DepthFormat
Member of the DepthFormat enumeration that identifies the format of the depth stencil surface to be tested.

Return Value

System.Boolean
Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned. If a depth stencil format is not compatible with the render target in the display mode, result is set to ResultCode.NotAvailable.

Remarks

The CheckDepthStencilMatch method enables applications to work with hardware that requires that certain depth formats work only with certain render-target formats.

The following C# code fragment demonstrates the use of CheckDeviceFormat to validate a depth stencil format.

              [C#]

public void TestFunc()
{
    int result;

    // Test some formats
    IsDepthFormatOK(DepthFormat.D16, Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result == (int)ResultCode.NotAvailable)
        System.Windows.Forms.MessageBox.Show(String.Format("The depth stencil format is invalid:  {0}", result));
}

private bool IsDepthFormatOK (DepthFormat depthFmt, Format adapterFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the depth format exists
    if (Manager.CheckDeviceFormat(ai.Adapter, DeviceType.Hardware, adapterFmt, Usage.DepthStencil, ResourceType.Surface, depthFmt, out result))
    {
        // Verify that the depth format is compatible
        if (Manager.CheckDepthStencilMatch(ai.Adapter, DeviceType.Hardware, adapterFmt, backbufferFmt, depthFmt, out result))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding call returns false if depthFmt cannot be used in conjunction with adapterFmt and backbufferFmt.


Manager.CheckDeviceFormat Method ()

How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Overload List

public static bool CheckDeviceFormat(int, DeviceType, Format, Usage, ResourceType, DepthFormat);
public static bool CheckDeviceFormat(int, DeviceType, Format, Usage, ResourceType, DepthFormat, out int);
public static bool CheckDeviceFormat(int, DeviceType, Format, Usage, ResourceType, Format);
public static bool CheckDeviceFormat(int, DeviceType, Format, Usage, ResourceType, Format, out int);

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormat(Int32,DeviceType,Format,Usage,ResourceType,DepthFormat) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceFormat Method

How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Definition

Visual Basic Public Shared Function CheckDeviceFormat( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal usage As Usage, _
ByVal resourceType As ResourceType, _
ByVal checkFormat As DepthFormat _
) As Boolean
C# public static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
DepthFormat checkFormat
);
C++ public:
static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
DepthFormat checkFormat
);
JScript public static function CheckDeviceFormat(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
usage : Usage,
resourceType : ResourceType,
checkFormat : DepthFormat
) : boolean;

Parameters

adapter System.Int32
Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall if this value equals or exceeds the number of display adapters in the system.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that identifies the device type.
adapterFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
usage Microsoft.DirectX.Direct3D.Usage
Requested usage options for the surface. Usage options are any combination of Usage enumeration values (only a subset of the Usage values are valid for CheckDeviceFormat). For more information, see Usage.
resourceType Microsoft.DirectX.Direct3D.ResourceType
A ResourceType requested for use with the queried format.
checkFormat Microsoft.DirectX.Direct3D.DepthFormat
Member of the Format enumeration that identifies the format of the surfaces that can be used, as defined by usage.

Return Value

System.Boolean
Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the format is not acceptable to the device for this usage, result is set to ResultCode.NotAvailable.

If adapter equals or exceeds the number of display adapters in the system, result is set to ResultCode.InvalidCall.

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormat(Int32,DeviceType,Format,Usage,ResourceType,DepthFormat,Int32) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceFormat Method

How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Definition

Visual Basic Public Shared Function CheckDeviceFormat( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal usage As Usage, _
ByVal resourceType As ResourceType, _
ByVal checkFormat As DepthFormat, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
DepthFormat checkFormat,
out int result
);
C++ public:
static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
DepthFormat checkFormat,
[Out] int% result
);
JScript public static function CheckDeviceFormat(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
usage : Usage,
resourceType : ResourceType,
checkFormat : DepthFormat,
result : int
) : boolean;

Parameters

adapter System.Int32
Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall if this value equals or exceeds the number of display adapters in the system.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that identifies the device type.
adapterFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
usage Microsoft.DirectX.Direct3D.Usage
Requested usage options for the surface. Usage options are any combination of Usage enumeration values (only a subset of the Usage values are valid for CheckDeviceFormat). For more information, see Usage.
resourceType Microsoft.DirectX.Direct3D.ResourceType
A ResourceType requested for use with the queried format.
checkFormat Microsoft.DirectX.Direct3D.DepthFormat
Member of the Format enumeration that identifies the format of the surfaces that can be used, as defined by usage.
result System.Int32
HRESULT code passed back from the method.

Return Value

System.Boolean
Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the format is not acceptable to the device for this usage, result is set to ResultCode.NotAvailable.

If adapter equals or exceeds the number of display adapters in the system, result is set to ResultCode.InvalidCall.

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormat(Int32,DeviceType,Format,Usage,ResourceType,Format) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceFormat Method

How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Definition

Visual Basic Public Shared Function CheckDeviceFormat( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal usage As Usage, _
ByVal resourceType As ResourceType, _
ByVal checkFormat As Format _
) As Boolean
C# public static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
Format checkFormat
);
C++ public:
static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
Format checkFormat
);
JScript public static function CheckDeviceFormat(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
usage : Usage,
resourceType : ResourceType,
checkFormat : Format
) : boolean;

Parameters

adapter System.Int32
Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall if this value equals or exceeds the number of display adapters in the system.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that identifies the device type.
adapterFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
usage Microsoft.DirectX.Direct3D.Usage
Requested usage options for the surface. Usage options are any combination of Usage enumeration values (only a subset of the Usage values are valid for CheckDeviceFormat). For more information, see Usage.
resourceType Microsoft.DirectX.Direct3D.ResourceType
A ResourceType requested for use with the queried format.
checkFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the surfaces that can be used, as defined by usage.

Return Value

System.Boolean
Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the format is not acceptable to the device for this usage, result is set to ResultCode.NotAvailable.

If adapter equals or exceeds the number of display adapters in the system, result is set to ResultCode.InvalidCall.

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormat(Int32,DeviceType,Format,Usage,ResourceType,Format,Int32) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceFormat Method

How Do I...?
  • Check For HDR Texture Support

Determines whether a surface format is available as a specified resource type and can be used as a texture, depth stencil buffer, render target, or any combination of the three, on a device representing the current adapter.

Definition

Visual Basic Public Shared Function CheckDeviceFormat( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal adapterFormat As Format, _
ByVal usage As Usage, _
ByVal resourceType As ResourceType, _
ByVal checkFormat As Format, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
Format checkFormat,
out int result
);
C++ public:
static bool CheckDeviceFormat(
int adapter,
DeviceType deviceType,
Format adapterFormat,
Usage usage,
ResourceType resourceType,
Format checkFormat,
[Out] int% result
);
JScript public static function CheckDeviceFormat(
adapter : int,
deviceType : DeviceType,
adapterFormat : Format,
usage : Usage,
resourceType : ResourceType,
checkFormat : Format,
result : int
) : boolean;

Parameters

adapter System.Int32
Ordinal number that denotes the display adapter to query. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall if this value equals or exceeds the number of display adapters in the system.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that identifies the device type.
adapterFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the display mode into which the adapter will be placed.
usage Microsoft.DirectX.Direct3D.Usage
Requested usage options for the surface. Usage options are any combination of Usage enumeration values (only a subset of the Usage values are valid for CheckDeviceFormat). For more information, see Usage.
resourceType Microsoft.DirectX.Direct3D.ResourceType
A ResourceType requested for use with the queried format.
checkFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that identifies the format of the surfaces that can be used, as defined by usage.
result System.Int32
HRESULT code passed back from the method.

Return Value

System.Boolean
Value that is true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the format is not acceptable to the device for this usage, result is set to ResultCode.NotAvailable.

If adapter equals or exceeds the number of display adapters in the system, result is set to ResultCode.InvalidCall.

How Do I...?

Check For HDR Texture Support

This example demonstrates how to check a device to determine whether a specific texture format is supported.

In the following C# code example, device is assumed to be the rendering Device, and the adapterFormat variable is assumed to be a valid member of the Format enum.

              [C#]

// check support for a Format.A16B16R16F render target
if (!Manager.CheckDeviceFormat(0, DeviceType.Hardware, adapterFormat,
                                  Usage.RenderTarget, ResourceType.CubeTexture,
                                  Format.A16B16G16R16F))
    return true;
else
    return false;


Manager.CheckDeviceFormatConversion Method ()

Tests a device to determine whether it supports conversion from one display format to another.

Overload List

public static bool CheckDeviceFormatConversion(int, DeviceType, Format, Format);
public static bool CheckDeviceFormatConversion(int, DeviceType, Format, Format, out int);

Remarks

Using Manager.CheckDeviceType to test for compatibility between a back buffer and the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back buffer format, the call still returns ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, the return value is also ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.

Manager.CheckDeviceFormatConversion also can be used to determine which combinations of source surface formats and destination surface formats are permissible in calls to Device.StretchRectangle.

Color conversion is restricted to the following source and target formats.

  • Source format must be a four-character code (FOURCC) format or a valid back buffer format. For a list of these, see FOURCC Formats and BackBuffer or Display Formats.
  • Target format must be one of the following unsigned formats. For more information, see Unsigned Formats.

    X1R5G5B5 | A1R5G5B5 | R5G6B5
    R8G8B8 | X8R8G8B8 | A8R8G8B8
    A2R10G10B10 | A16B16G16R16 | A2B10G10R10
    A8B8G8R8 | X8B8G8R8 | A16B16G16R16F
    A32B32G32R32F

See Also

  • Format
  • Surface Formats
  • Device.ColorFill


Manager.CheckDeviceFormatConversion(Int32,DeviceType,Format,Format,Int32) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceFormatConversion Method

Tests a device to determine whether it supports conversion from one display format to another.

Definition

Visual Basic Public Shared Function CheckDeviceFormatConversion( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal sourceFormat As Format, _
ByVal targetFormat As Format, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDeviceFormatConversion(
int adapter,
DeviceType deviceType,
Format sourceFormat,
Format targetFormat,
out int result
);
C++ public:
static bool CheckDeviceFormatConversion(
int adapter,
DeviceType deviceType,
Format sourceFormat,
Format targetFormat,
[Out] int% result
);
JScript public static function CheckDeviceFormatConversion(
adapter : int,
deviceType : DeviceType,
sourceFormat : Format,
targetFormat : Format,
result : int
) : boolean;

Parameters

adapter System.Int32
Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Device type. Member of the DeviceType enumeration.
sourceFormat Microsoft.DirectX.Direct3D.Format
Source adapter format. Member of the Format enumeration.
targetFormat Microsoft.DirectX.Direct3D.Format
Target adapter format. Member of the Format enumeration.
result System.Int32
HRESULT code passed back from the method.

Return Value

System.Boolean
Returns true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to ResultCode.InvalidCall.

If the hardware does not support conversion between the two formats, result is set to ResultCode.NotAvailable.

Remarks

Using Manager.CheckDeviceType to test for compatibility between a back buffer and the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back buffer format, the call still returns ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, the return value is also ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.

Manager.CheckDeviceFormatConversion also can be used to determine which combinations of source surface formats and destination surface formats are permissible in calls to Device.StretchRectangle.

Color conversion is restricted to the following source and target formats.

  • Source format must be a four-character code (FOURCC) format or a valid back buffer format. For a list of these, see FOURCC Formats and BackBuffer or Display Formats.
  • Target format must be one of the following unsigned formats. For more information, see Unsigned Formats.

    X1R5G5B5 | A1R5G5B5 | R5G6B5
    R8G8B8 | X8R8G8B8 | A8R8G8B8
    A2R10G10B10 | A16B16G16R16 | A2B10G10R10
    A8B8G8R8 | X8B8G8R8 | A16B16G16R16F
    A32B32G32R32F

See Also

  • Format
  • Surface Formats
  • Device.ColorFill


Manager.CheckDeviceFormatConversion(Int32,DeviceType,Format,Format) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceFormatConversion Method

Tests a device to determine whether it supports conversion from one display format to another.

Definition

Visual Basic Public Shared Function CheckDeviceFormatConversion( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal sourceFormat As Format, _
ByVal targetFormat As Format _
) As Boolean
C# public static bool CheckDeviceFormatConversion(
int adapter,
DeviceType deviceType,
Format sourceFormat,
Format targetFormat
);
C++ public:
static bool CheckDeviceFormatConversion(
int adapter,
DeviceType deviceType,
Format sourceFormat,
Format targetFormat
);
JScript public static function CheckDeviceFormatConversion(
adapter : int,
deviceType : DeviceType,
sourceFormat : Format,
targetFormat : Format
) : boolean;

Parameters

adapter System.Int32
Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Device type. Member of the DeviceType enumeration.
sourceFormat Microsoft.DirectX.Direct3D.Format
Source adapter format. Member of the Format enumeration.
targetFormat Microsoft.DirectX.Direct3D.Format
Target adapter format. Member of the Format enumeration.

Return Value

System.Boolean
Returns true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to ResultCode.InvalidCall.

If the hardware does not support conversion between the two formats, result is set to ResultCode.NotAvailable.

Remarks

Using Manager.CheckDeviceType to test for compatibility between a back buffer and the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back buffer format, the call still returns ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, the return value is also ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.

Manager.CheckDeviceFormatConversion also can be used to determine which combinations of source surface formats and destination surface formats are permissible in calls to Device.StretchRectangle.

Color conversion is restricted to the following source and target formats.

  • Source format must be a four-character code (FOURCC) format or a valid back buffer format. For a list of these, see FOURCC Formats and BackBuffer or Display Formats.
  • Target format must be one of the following unsigned formats. For more information, see Unsigned Formats.

    X1R5G5B5 | A1R5G5B5 | R5G6B5
    R8G8B8 | X8R8G8B8 | A8R8G8B8
    A2R10G10B10 | A16B16G16R16 | A2B10G10R10
    A8B8G8R8 | X8B8G8R8 | A16B16G16R16F
    A32B32G32R32F

See Also

  • Format
  • Surface Formats
  • Device.ColorFill


Manager.CheckDeviceMultiSampleType Method ()

Determines whether a multisampling technique is available on the current device.

Overload List

public static bool CheckDeviceMultiSampleType(int, DeviceType, Format, bool, MultiSampleType);
public static bool CheckDeviceMultiSampleType(int, DeviceType, Format, bool, MultiSampleType, out int, out int);

Remarks

This method is intended for use with both render-target and depth stencil surfaces because they must be created multisampled to be used together.

The following C# code fragment demonstrates the use of CheckDeviceMultiSampleType to test for devices that support a specific multisampling method.

              [C#]

public void Test_Manager_CheckDeviceMultiSampleType()
{
    int result;

    // Test some formats
    IsDeviceMultiSampleOK(DepthFormat.D16, Format.A8R8G8B8, MultiSampleType.TwoSamples, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The multisample options are invalid:  {0}", result));
}

public bool IsDeviceMultiSampleOK (DepthFormat depthFmt, Format backbufferFmt, MultiSampleType multisampleType, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;
    int qualityLevels = 0;

    // Verify that the render target surface supports the given multisample type
    if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, backbufferFmt, false, multisampleType, out result, ref qualityLevels))
    {
        // Verify that the depth stencil surface supports the given multisample type
        if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, (Format)depthFmt, false, multisampleType, out result, ref qualityLevels))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device supports the full-screen MultiSampleType.TwoSamples multisampling method with the surface format.


Manager.CheckDeviceMultiSampleType(Int32,DeviceType,Format,Boolean,MultiSampleType,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceMultiSampleType Method

Determines whether a multisampling technique is available on the current device.

Definition

Visual Basic Public Shared Function CheckDeviceMultiSampleType( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal surfaceFormat As Format, _
ByVal windowed As Boolean, _
ByVal multiSampleType As MultiSampleType, _
ByRef result As Integer, _
ByRef qualityLevels As Integer _
) As Boolean
C# public static bool CheckDeviceMultiSampleType(
int adapter,
DeviceType deviceType,
Format surfaceFormat,
bool windowed,
MultiSampleType multiSampleType,
out int result,
out int qualityLevels
);
C++ public:
static bool CheckDeviceMultiSampleType(
int adapter,
DeviceType deviceType,
Format surfaceFormat,
bool windowed,
MultiSampleType multiSampleType,
[Out] int% result,
[Out] int% qualityLevels
);
JScript public static function CheckDeviceMultiSampleType(
adapter : int,
deviceType : DeviceType,
surfaceFormat : Format,
windowed : boolean,
multiSampleType : MultiSampleType,
result : int,
qualityLevels : int
) : boolean;

Parameters

adapter System.Int32
Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration.
surfaceFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that specifies the format of the surface to be multisampled. See Remarks.
windowed System.Boolean
Set to true to inquire about windowed multisampling. Set to false to inquire about full-screen multisampling.
multiSampleType Microsoft.DirectX.Direct3D.MultiSampleType
Member of the MultiSampleType enumeration that identifies the multisampling technique to test.
result System.Int32
HRESULT code passed back from the method.
qualityLevels System.Int32
Number of quality stops available for a given multisample type; can be null if it is not necessary to return the values.

Return Value

System.Boolean
Returns true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to one of the following values: ResultCode.InvalidCall if the adapter or multiSampleType parameters are invalid, ResultCode.NotAvailable if the device does not support the queried multisampling technique, or ResultCode.InvalidDevice if deviceType does not apply to the adapter.

Remarks

This method is intended for use with both render-target and depth stencil surfaces because they must be created multisampled to be used together.

The following C# code fragment demonstrates the use of CheckDeviceMultiSampleType to test for devices that support a specific multisampling method.

              [C#]

public void Test_Manager_CheckDeviceMultiSampleType()
{
    int result;

    // Test some formats
    IsDeviceMultiSampleOK(DepthFormat.D16, Format.A8R8G8B8, MultiSampleType.TwoSamples, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The multisample options are invalid:  {0}", result));
}

public bool IsDeviceMultiSampleOK (DepthFormat depthFmt, Format backbufferFmt, MultiSampleType multisampleType, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;
    int qualityLevels = 0;

    // Verify that the render target surface supports the given multisample type
    if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, backbufferFmt, false, multisampleType, out result, ref qualityLevels))
    {
        // Verify that the depth stencil surface supports the given multisample type
        if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, (Format)depthFmt, false, multisampleType, out result, ref qualityLevels))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device supports the full-screen MultiSampleType.TwoSamples multisampling method with the surface format.


Manager.CheckDeviceMultiSampleType(Int32,DeviceType,Format,Boolean,MultiSampleType) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceMultiSampleType Method

Determines whether a multisampling technique is available on the current device.

Definition

Visual Basic Public Shared Function CheckDeviceMultiSampleType( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType, _
ByVal surfaceFormat As Format, _
ByVal windowed As Boolean, _
ByVal multiSampleType As MultiSampleType _
) As Boolean
C# public static bool CheckDeviceMultiSampleType(
int adapter,
DeviceType deviceType,
Format surfaceFormat,
bool windowed,
MultiSampleType multiSampleType
);
C++ public:
static bool CheckDeviceMultiSampleType(
int adapter,
DeviceType deviceType,
Format surfaceFormat,
bool windowed,
MultiSampleType multiSampleType
);
JScript public static function CheckDeviceMultiSampleType(
adapter : int,
deviceType : DeviceType,
surfaceFormat : Format,
windowed : boolean,
multiSampleType : MultiSampleType
) : boolean;

Parameters

adapter System.Int32
Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration.
surfaceFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that specifies the format of the surface to be multisampled. See Remarks.
windowed System.Boolean
Set to true to inquire about windowed multisampling. Set to false to inquire about full-screen multisampling.
multiSampleType Microsoft.DirectX.Direct3D.MultiSampleType
Member of the MultiSampleType enumeration that identifies the multisampling technique to test.

Return Value

System.Boolean
Returns true if the method succeeds; false if it fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to one of the following values: ResultCode.InvalidCall if the adapter or multiSampleType parameters are invalid, ResultCode.NotAvailable if the device does not support the queried multisampling technique, or ResultCode.InvalidDevice if deviceType does not apply to the adapter.

Remarks

This method is intended for use with both render-target and depth stencil surfaces because they must be created multisampled to be used together.

The following C# code fragment demonstrates the use of CheckDeviceMultiSampleType to test for devices that support a specific multisampling method.

              [C#]

public void Test_Manager_CheckDeviceMultiSampleType()
{
    int result;

    // Test some formats
    IsDeviceMultiSampleOK(DepthFormat.D16, Format.A8R8G8B8, MultiSampleType.TwoSamples, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The multisample options are invalid:  {0}", result));
}

public bool IsDeviceMultiSampleOK (DepthFormat depthFmt, Format backbufferFmt, MultiSampleType multisampleType, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;
    int qualityLevels = 0;

    // Verify that the render target surface supports the given multisample type
    if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, backbufferFmt, false, multisampleType, out result, ref qualityLevels))
    {
        // Verify that the depth stencil surface supports the given multisample type
        if (Manager.CheckDeviceMultiSampleType(ai.Adapter, DeviceType.Hardware, (Format)depthFmt, false, multisampleType, out result, ref qualityLevels))
        {
            return true;    // if both calls succeed
        }
    }

    return false;   // if either call fails.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device supports the full-screen MultiSampleType.TwoSamples multisampling method with the surface format.


Manager.CheckDeviceType Method ()

Specifies whether a hardware-accelerated device type can be used on the current adapter.

Overload List

public static bool CheckDeviceType(int, DeviceType, Format, Format, bool);
public static bool CheckDeviceType(int, DeviceType, Format, Format, bool, out int);

Remarks

A hardware abstraction layer (HAL) device type requires hardware acceleration. Applications can use Manager.CheckDeviceType to determine whether the hardware and drivers necessary to support a HAL device are present.

Full-screen applications should not specify a displayFormat that contains an alpha channel; doing so will result in a failed call. Note that an alpha channel can be present in the back buffer, but the two display formats must be identical in all other respects. For example, if displayFormat = Format.X1R5G5B5, valid values for backBufferFormat include Format.X1R5G5B5 and Format.A1R5G5B5 but exclude Format.R5G6B5.

The following C# code fragment demonstrates the use of CheckDeviceType to determine whether a certain device type can be used on the adapter.

              [C#]

public void Test_Manager_CheckDeviceType()
{
    int result;

    // Test some formats
    IsDeviceTypeOK(Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The device check failed:  {0}", result));
}

public bool IsDeviceTypeOK (Format displayFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the device can be used on the default adapter with the given surface format
    if (Manager.CheckDeviceType(ai.Adapter, DeviceType.Hardware, displayFmt, backbufferFmt, false, out result))
    {
        return true;    // if the call succeeds
    }

    return false;   // otherwise fail.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device can be used on the default adapter with the specified surface format.

Using Manager.CheckDeviceType to test for compatibility between a back buffer that differs from the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back-buffer format, result is still set to ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, result is also set to ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.


Manager.CheckDeviceType(Int32,DeviceType,Format,Format,Boolean) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceType Method

Specifies whether a hardware-accelerated device type can be used on the current adapter.

Definition

Visual Basic Public Shared Function CheckDeviceType( _
ByVal adapter As Integer, _
ByVal checkType As DeviceType, _
ByVal displayFormat As Format, _
ByVal backBufferFormat As Format, _
ByVal windowed As Boolean _
) As Boolean
C# public static bool CheckDeviceType(
int adapter,
DeviceType checkType,
Format displayFormat,
Format backBufferFormat,
bool windowed
);
C++ public:
static bool CheckDeviceType(
int adapter,
DeviceType checkType,
Format displayFormat,
Format backBufferFormat,
bool windowed
);
JScript public static function CheckDeviceType(
adapter : int,
checkType : DeviceType,
displayFormat : Format,
backBufferFormat : Format,
windowed : boolean
) : boolean;

Parameters

adapter System.Int32
Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
checkType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that indicates the device type to check.
displayFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that indicates the format of the adapter display mode for which the device type is being checked. For example, some devices operate only in modes of 16 bits per pixel.
backBufferFormat Microsoft.DirectX.Direct3D.Format
Back buffer format. For more information about formats, see Format. This value must be one of the render target formats. Device.DisplayMode can be used to obtain the current format.

For windowed applications, the back buffer format does not need to match the display mode format if the hardware supports color conversion. The set of possible back buffer formats is constrained, but the runtime allows any valid back buffer format to be presented to any desktop format. Additionally, the device must be operable in desktop mode because devices typically do not operate in modes of 8 bits per pixel.

Full-screen applications cannot perform color conversion.

Format.Unknown is allowed for windowed mode.
windowed System.Boolean
Set to true if the device type will be used in windowed mode. Set to false if the device type will be used in full-screen.

Return Value

System.Boolean
Returns true if the method succeeds and the device can be used on this adapter; false if the method fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to ResultCode.InvalidCall, provided adapter equals or exceeds the number of display adapters in the system. ResultCode.InvalidCall also is returned if CheckDeviceType specified a device that does not exist.

If the requested back buffer format is not supported, or if hardware acceleration is not available for the specified formats, result is set to ResultCode.NotAvailable.

Remarks

A hardware abstraction layer (HAL) device type requires hardware acceleration. Applications can use Manager.CheckDeviceType to determine whether the hardware and drivers necessary to support a HAL device are present.

Full-screen applications should not specify a displayFormat that contains an alpha channel; doing so will result in a failed call. Note that an alpha channel can be present in the back buffer, but the two display formats must be identical in all other respects. For example, if displayFormat = Format.X1R5G5B5, valid values for backBufferFormat include Format.X1R5G5B5 and Format.A1R5G5B5 but exclude Format.R5G6B5.

The following C# code fragment demonstrates the use of CheckDeviceType to determine whether a certain device type can be used on the adapter.

              [C#]

public void Test_Manager_CheckDeviceType()
{
    int result;

    // Test some formats
    IsDeviceTypeOK(Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The device check failed:  {0}", result));
}

public bool IsDeviceTypeOK (Format displayFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the device can be used on the default adapter with the given surface format
    if (Manager.CheckDeviceType(ai.Adapter, DeviceType.Hardware, displayFmt, backbufferFmt, false, out result))
    {
        return true;    // if the call succeeds
    }

    return false;   // otherwise fail.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device can be used on the default adapter with the specified surface format.

Using Manager.CheckDeviceType to test for compatibility between a back buffer that differs from the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back-buffer format, result is still set to ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, result is also set to ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.


Manager.CheckDeviceType(Int32,DeviceType,Format,Format,Boolean,Int32) Method (Microsoft.DirectX.Direct3D)

Manager.CheckDeviceType Method

Specifies whether a hardware-accelerated device type can be used on the current adapter.

Definition

Visual Basic Public Shared Function CheckDeviceType( _
ByVal adapter As Integer, _
ByVal checkType As DeviceType, _
ByVal displayFormat As Format, _
ByVal backBufferFormat As Format, _
ByVal windowed As Boolean, _
ByRef result As Integer _
) As Boolean
C# public static bool CheckDeviceType(
int adapter,
DeviceType checkType,
Format displayFormat,
Format backBufferFormat,
bool windowed,
out int result
);
C++ public:
static bool CheckDeviceType(
int adapter,
DeviceType checkType,
Format displayFormat,
Format backBufferFormat,
bool windowed,
[Out] int% result
);
JScript public static function CheckDeviceType(
adapter : int,
checkType : DeviceType,
displayFormat : Format,
backBufferFormat : Format,
windowed : boolean,
result : int
) : boolean;

Parameters

adapter System.Int32
Display adapter ordinal number. AdapterListCollection.Default is always the primary display adapter. This method returns ResultCode.InvalidCall when the value equals or exceeds the number of display adapters in the system.
checkType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that indicates the device type to check.
displayFormat Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that indicates the format of the adapter display mode for which the device type is being checked. For example, some devices operate only in modes of 16 bits per pixel.
backBufferFormat Microsoft.DirectX.Direct3D.Format
Back buffer format. For more information about formats, see Format. This value must be one of the render target formats. Device.DisplayMode can be used to obtain the current format.

For windowed applications, the back buffer format does not need to match the display mode format if the hardware supports color conversion. The set of possible back buffer formats is constrained, but the runtime allows any valid back buffer format to be presented to any desktop format. Additionally, the device must be operable in desktop mode because devices typically do not operate in modes of 8 bits per pixel.

Full-screen applications cannot perform color conversion.

Format.Unknown is allowed for windowed mode.
windowed System.Boolean
Set to true if the device type will be used in windowed mode. Set to false if the device type will be used in full-screen.
result System.Int32
HRESULT code passed back from the method.

Return Value

System.Boolean
Returns true if the method succeeds and the device can be used on this adapter; false if the method fails. Check the result parameter for the HRESULT code returned.

If the method fails, result is set to ResultCode.InvalidCall, provided adapter equals or exceeds the number of display adapters in the system. ResultCode.InvalidCall also is returned if CheckDeviceType specified a device that does not exist.

If the requested back buffer format is not supported, or if hardware acceleration is not available for the specified formats, result is set to ResultCode.NotAvailable.

Remarks

A hardware abstraction layer (HAL) device type requires hardware acceleration. Applications can use Manager.CheckDeviceType to determine whether the hardware and drivers necessary to support a HAL device are present.

Full-screen applications should not specify a displayFormat that contains an alpha channel; doing so will result in a failed call. Note that an alpha channel can be present in the back buffer, but the two display formats must be identical in all other respects. For example, if displayFormat = Format.X1R5G5B5, valid values for backBufferFormat include Format.X1R5G5B5 and Format.A1R5G5B5 but exclude Format.R5G6B5.

The following C# code fragment demonstrates the use of CheckDeviceType to determine whether a certain device type can be used on the adapter.

              [C#]

public void Test_Manager_CheckDeviceType()
{
    int result;

    // Test some formats
    IsDeviceTypeOK(Format.X8R8G8B8, Format.A8R8G8B8, out result);

    if (result != (int)ResultCode.Success)
        System.Windows.Forms.MessageBox.Show(String.Format("The device check failed:  {0}", result));
}

public bool IsDeviceTypeOK (Format displayFmt, Format backbufferFmt, out int result)
{
    AdapterInformation ai = Manager.Adapters.Default;

    // Verify that the device can be used on the default adapter with the given surface format
    if (Manager.CheckDeviceType(ai.Adapter, DeviceType.Hardware, displayFmt, backbufferFmt, false, out result))
    {
        return true;    // if the call succeeds
    }

    return false;   // otherwise fail.  NOTE: HRESULT passed back in result
}

The preceding code returns true if the device can be used on the default adapter with the specified surface format.

Using Manager.CheckDeviceType to test for compatibility between a back buffer that differs from the display format returns appropriate values. This means that the call reflects device capabilities. If the device cannot render to the requested back-buffer format, result is still set to ResultCode.NotAvailable. If the device can render to the format but cannot perform the color-converting presentation, result is also set to ResultCode.NotAvailable. Applications can discover hardware support for the presentation itself by calling Manager.CheckDeviceFormatConversion. No software emulation for the color-converting presentation itself is offered.


Manager.DisableD3DSpy() Method (Microsoft.DirectX.Direct3D)

Manager.DisableD3DSpy Method

Blocks D3DSpy from monitoring an application.

Definition

Visual Basic | Public Shared Function DisableD3DSpy() As Boolean
C# | public static bool DisableD3DSpy();
C++ public:
static bool DisableD3DSpy();
JScript | public static function DisableD3DSpy() : boolean;

Return Value

System.Boolean
Returns true if D3DSpy is monitoring this application; otherwise, false.

Remarks

D3DSpy is a utility that monitors function calls to the Microsoft Direct3D application programming interface (API), and shows a representation of Direct3D's internal state. This is valuable when writing a Direct3D program, or when trying to understand why a program is behaving as it is.


Manager.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Manager.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Manager.Finalize() Method (Microsoft.DirectX.Direct3D)

Manager.Finalize Method

Allows the Manager object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Manager();
C++ | !Manager();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Manager.GenerateD3DSpyBreak() Method (Microsoft.DirectX.Direct3D)

Manager.GenerateD3DSpyBreak Method

Generates a breakpoint in D3DSpy when called within the application.

Definition

Visual Basic | Public Shared Function GenerateD3DSpyBreak() As Boolean
C# | public static bool GenerateD3DSpyBreak();
C++ public:
static bool GenerateD3DSpyBreak();
JScript | public static function GenerateD3DSpyBreak() : boolean;

Return Value

System.Boolean
Returns true if D3DSpy is monitoring this application; otherwise, false.

Remarks

D3DSpy is a utility that monitors function calls to the Microsoft Direct3D application programming interface (API), and shows a representation of Direct3D's internal state. This is valuable when writing a Direct3D program, or when trying to understand why a program is behaving as it is.


Manager.GetAdapterMonitor(Int32) Method (Microsoft.DirectX.Direct3D)

Manager.GetAdapterMonitor Method

Returns the handle of the monitor associated with the Microsoft Direct3D object.

Definition

Visual Basic Public Shared Function GetAdapterMonitor( _
ByVal adapter As Integer _
) As IntPtr
C# public static IntPtr GetAdapterMonitor(
int adapter
);
C++ public:
static IntPtr GetAdapterMonitor(
int adapter
);
JScript public static function GetAdapterMonitor(
adapter : int
) : IntPtr;

Parameters

adapter System.Int32
Ordinal number that denotes the display adapter. AdapterListCollection.Default is always the primary display adapter.

Return Value

System.IntPtr
Handle of the monitor associated with the Direct3D object.

Remarks

The following C# code fragment illustrates how to obtain a handle to the monitor associated with a given device.

              [C#]

IntPtr hMonitor;
AdapterInformation ai = Manager.Adapters.Default;

hMonitor = Manager.GetAdapterMonitor(ai.Adapter);


Manager.GetDeviceCaps(Int32,DeviceType) Method (Microsoft.DirectX.Direct3D)

Manager.GetDeviceCaps Method

How Do I...?
  • Check for Shader Support

Retrieves information specific to a device.

Definition

Visual Basic Public Shared Function GetDeviceCaps( _
ByVal adapter As Integer, _
ByVal deviceType As DeviceType _
) As Caps
C# public static Caps GetDeviceCaps(
int adapter,
DeviceType deviceType
);
C++ public:
static Caps GetDeviceCaps(
int adapter,
DeviceType deviceType
);
JScript public static function GetDeviceCaps(
adapter : int,
deviceType : DeviceType
) : Caps;

Parameters

adapter System.Int32
Ordinal number that denotes the display adapter. AdapterListCollection.Default is always the primary display adapter.
deviceType Microsoft.DirectX.Direct3D.DeviceType
Member of the DeviceType enumeration that identifies the device type.

Return Value

Microsoft.DirectX.Direct3D.Caps
If the method succeeds, the return value is a Caps object that contains information that describes the device's capabilities.

Remarks

The application should not assume the persistence of vertex processing capabilities across Microsoft Direct3D device objects. The particular capabilities that a physical device exposes might depend on parameters supplied to Device.Device. For example, the capabilities might yield different vertex processing capabilities before and after creating a Direct3D Device object with hardware vertex processing enabled. For more information, see Caps.

Exceptions
InvalidCallException | Method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDeviceException | Requested device type is not valid.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.

How Do I...?

Check for Shader Support

This example shows how to check the hardware device for shader support.

To determine whether the hardware device supports shaders, Direct3D allows the application to check the shader version.

To check for shader support:

  1. Obtain the device's capabilities by using the Manager.GetDeviceCaps method.
  2. Using the capabilities object obtained with the previous call, check the shader version by calling Caps.VertexShaderVersion.

              [C#]

public bool CheckShaderSupport()
{
    Version v1_1 = new Version(1,1); // check version is at least shader 1.1

    // retrieve the device caps
    Caps caps = Manager.GetDeviceCaps(0, DeviceType.Hardware);

    // check the supported shader version
    if ((caps.VertexShaderVersion >= v1_1) && (caps.PixelShaderVersion >= v1_1))
    {
        return true;
    }

    return false;
}


Manager.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Manager.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Manager.op_Equality(Manager,Manager) Method (Microsoft.DirectX.Direct3D)

Manager.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Manager, _
ByVal right As Manager _
) As Boolean
C# public static bool op_Equality(
Manager left,
Manager right
);
C++ public:
static bool operator==(
Manager^ left,
Manager^ right
);
JScript public static function op_Equality(
left : Manager,
right : Manager
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Manager
The Manager object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Manager
The Manager object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Manager.op_Inequality(Manager,Manager) Method (Microsoft.DirectX.Direct3D)

Manager.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Manager, _
ByVal right As Manager _
) As Boolean
C# public static bool op_Inequality(
Manager left,
Manager right
);
C++ public:
static bool operator!=(
Manager^ left,
Manager^ right
);
JScript public static function op_Inequality(
left : Manager,
right : Manager
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Manager
The Manager object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Manager
The Manager object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Manager.Adapters Property (Microsoft.DirectX.Direct3D)

Manager.Adapters Property

Collection of adapters on the system.

Definition

Visual Basic | Public Shared ReadOnly Property Adapters As AdapterListCollection
C# | public static AdapterListCollection Adapters { get; }
C++ public:
static property AdapterListCollection^ Adapters {
AdapterListCollection^ get();
}
JScript | public static function get Adapters() : AdapterListCollection

Property Value

Microsoft.DirectX.Direct3D.AdapterListCollection

This property is read-only.


Mesh Class (Microsoft.DirectX.Direct3D)

Mesh Class

How Do I...?
  • Create a Mesh Object

Manipulates mesh objects.

Definition

Visual Basic NotInheritable Public Class Mesh
Inherits BaseMesh
C# | public sealed class Mesh : BaseMesh
C++ | public ref class Mesh sealed : BaseMesh
JScript | public final class Mesh extends BaseMesh

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Mesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
static (Shared in Visual Basic) Box | Uses a left-handed coordinate system to create a mesh that contains an axis-aligned box.
static (Shared in Visual Basic) Clean | Cleans a mesh, preparing it for simplification.
Clone | Clones, or copies, a mesh object. Inherited from BaseMesh.
ComputeNormals | Computes normals for each vertex in a mesh. Inherited from BaseMesh.
ComputeTangent | Computes the tangent vectors for the texture coordinates given in a texture stage.
ComputeTangentFrame | Performs tangent frame computations on a mesh. Tangent, binormal, and optionally normal vectors are generated. Singularities are handled as required by grouping edges and splitting vertices.
ConvertAdjacencyToPointReps | Converts mesh adjacency information to an array of point representatives. Inherited from BaseMesh.
static (Shared in Visual Basic) ConvertMeshSubsetToSingleStrip | Converts the specified mesh subset into a single triangle strip..
static (Shared in Visual Basic) ConvertMeshSubsetToStrips | Converts the specified mesh subset into a series of strips.
ConvertPointRepsToAdjacency | Converts point representative data to mesh adjacency information. Inherited from BaseMesh.
static (Shared in Visual Basic) Cylinder | Uses a left-handed coordinate system to create a mesh that contains a cylinder.
Dispose | Immediately releases the unmanaged resources used by the Mesh object.
DrawSubset | Draws a subset of a mesh. Inherited from BaseMesh.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Mesh object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FromFile | Loads a mesh from a .x file.
static (Shared in Visual Basic) FromStream | Loads a mesh from a Stream Leave Site.
static (Shared in Visual Basic) FromX | Loads a mesh from an XFileData object.
GenerateAdjacency | Generates adjacency information based on mesh indices. Inherited from BaseMesh.
GetAttributeTable | Retrieves an attribute table for a mesh. Inherited from BaseMesh.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
Intersect | Determines whether a ray intersects with a mesh.
IntersectSubset | Intersects the specified ray with a given mesh subset.
static (Shared in Visual Basic) LoadHierarchy | Loads the first frame hierarchy from a Stream Leave Site.
static (Shared in Visual Basic) LoadHierarchyFromFile | Loads the first frame hierarchy in a DirectX (.x) file.
LockAttributeBuffer | Locks an attribute buffer and obtains its memory.
LockAttributeBufferArray | Locks an attribute buffer and obtains its memory.
LockIndexBuffer | Locks an index buffer and obtains the index buffer data. Inherited from BaseMesh.
LockVertexBuffer | Locks a vertex buffer and obtains a pointer to the vertex buffer memory. Inherited from BaseMesh.
Mesh | Creates a new Mesh instance.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseMesh.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseMesh.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Optimize | Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.
OptimizeInPlace | Controls the reordering of mesh faces and vertices to optimize performance.
static (Shared in Visual Basic) Polygon | Uses a left-handed coordinate system to create a mesh that contains an n-sided polygon.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Mesh.Disposing event when called from within a derived class.
Save | Saves the mesh to the specified stream object.
static (Shared in Visual Basic) SaveHierarchyToFile | Creates a DirectX (.x) file and saves the mesh hierarchy and corresponding animations in it.
SetAttributeTable | Sets a mesh's attribute table and specifies the number of entries stored in it.
SetIndexBufferData | Sets index buffer data. Inherited from BaseMesh.
SetVertexBufferData | Sets vertex buffer data. Inherited from BaseMesh.
static (Shared in Visual Basic) Simplify | Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.
static (Shared in Visual Basic) Sphere | Uses a left-handed coordinate system to create a mesh that contains a sphere.
static (Shared in Visual Basic) Split | Splits a mesh into multiple meshes that are smaller than the specified size.
static (Shared in Visual Basic) Teapot | Uses a left-handed coordinate system to create a mesh that contains a teapot.
static (Shared in Visual Basic) TessellateNPatches | Tessellates the given mesh using the N-patch tessellation scheme.
static (Shared in Visual Basic) TextFromFont | Creates a mesh that contains the specified text, using a .NET font object.
static (Shared in Visual Basic) Torus | Uses a left-handed coordinate system to create a mesh that contains a torus.
UnlockAttributeBuffer | Unlocks an attribute buffer.
UnlockIndexBuffer | Unlocks an index buffer. Inherited from BaseMesh.
UnlockVertexBuffer | Unlocks a vertex buffer. Inherited from BaseMesh.
UpdateSemantics Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size. Inherited from BaseMesh.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseMesh.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Mesh object. This method supports the Framework infrastructure and is not intended to be used directly in your code.
Validate | Validates a mesh.
WeldVertices | Welds together replicated vertices that have equal attributes.

Properties

Property | Description
Declaration | Retrieves a declaration that describes the vertices in a mesh. Inherited from BaseMesh.
Device | Retrieves the device associated with a mesh. Inherited from BaseMesh.
Disposed | Gets a value that indicates whether the object is disposed.
IndexBuffer | Retrieves the data in an index buffer. Inherited from BaseMesh.
NumberAttributes | Retrieves the number of entries stored in an attribute table for a mesh. Inherited from BaseMesh.
NumberBytesPerVertex | Retrieves the number of bytes per vertex. Inherited from BaseMesh.
NumberFaces | Retrieves the number of faces in a mesh. Inherited from BaseMesh.
NumberVertices | Retrieves the number of vertices in a mesh. Inherited from BaseMesh.
Options | Retrieves the mesh options enabled for the current mesh at creation time. Inherited from BaseMesh.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXMesh interface pointer.
UnmanagedComPointer | Returns the unmanaged COM ID3DXBaseMesh interface pointer. Inherited from BaseMesh.
VertexBuffer | Retrieves the vertex buffer of a mesh. Inherited from BaseMesh.
VertexFormat | Retrieves the vertex format that describes the contents of vertices. Inherited from BaseMesh.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseMesh
Mesh

Remarks

This object inherits additional functionality from the BaseMesh object.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Mesh.Box Method ()

Uses a left-handed coordinate system to create a mesh that contains an axis-aligned box.

Overload List

public static Mesh Box(Device, float, float, float);
public static Mesh Box(Device, float, float, float, out GraphicsStream);

Remarks

The created box is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Box(Device,Single,Single,Single) Method (Microsoft.DirectX.Direct3D)

Mesh.Box Method

Uses a left-handed coordinate system to create a mesh that contains an axis-aligned box.

Definition

Visual Basic Public Shared Function Box( _
ByVal device As Device, _
ByVal width As Single, _
ByVal height As Single, _
ByVal depth As Single _
) As Mesh
C# public static Mesh Box(
Device device,
float width,
float height,
float depth
);
C++ public:
static Mesh^ Box(
Device^ device,
float width,
float height,
float depth
);
JScript public static function Box(
device : Device,
width : float,
height : float,
depth : float
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object.
width System.Single
Width of the box along the x-axis.
height System.Single
Height of the box along the y-axis.
depth System.Single
Depth of the box along the z-axis.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that contains the box.

Remarks

The created box is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Box(Device,Single,Single,Single,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Box Method

Uses a left-handed coordinate system to create a mesh that contains an axis-aligned box.

Definition

Visual Basic Public Shared Function Box( _
ByVal device As Device, _
ByVal width As Single, _
ByVal height As Single, _
ByVal depth As Single, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Box(
Device device,
float width,
float height,
float depth,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ Box(
Device^ device,
float width,
float height,
float depth,
[Out] GraphicsStream^% adjacency
);
JScript public static function Box(
device : Device,
width : float,
height : float,
depth : float,
adjacency : GraphicsStream
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object.
width System.Single
Width of the box along the x-axis.
height System.Single
Height of the box along the y-axis.
depth System.Single
Depth of the box along the z-axis.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object. When the method returns, this parameter is filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that contains the box.

Remarks

The created box is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Clean Method ()

Cleans a mesh, preparing it for simplification.

Overload List

public static Mesh Clean(CleanType, Mesh, GraphicsStream, GraphicsStream);
public static Mesh Clean(CleanType, Mesh, GraphicsStream, GraphicsStream, out string);
public static Mesh Clean(CleanType, Mesh, int[], out int);
public static Mesh Clean(CleanType, Mesh, int[], out int, out string);

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Clean(CleanType,Mesh,Int32[],Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.Clean Method

Cleans a mesh, preparing it for simplification.

Definition

Visual Basic Public Shared Function Clean( _
ByVal cleanType As CleanType, _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByRef adjacencyOut As Integer _
) As Mesh
C# public static Mesh Clean(
CleanType cleanType,
Mesh mesh,
int[] adjacency,
out int adjacencyOut
);
C++ public:
static Mesh^ Clean(
CleanType cleanType,
Mesh^ mesh,
array<int>^ adjacency,
[Out] int% adjacencyOut
);
JScript public static function Clean(
cleanType : CleanType,
mesh : Mesh,
adjacency : int[],
adjacencyOut : int
) : Mesh;

Parameters

cleanType Microsoft.DirectX.Direct3D.CleanType
A flag from the CleanType enumeration that specifies the type of mesh cleaning to perform.
mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to clean.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be cleaned.
adjacencyOut System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned cleaned mesh. If no cleaning is necessary, the returned mesh is the same as the one that was passed in.

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Clean(CleanType,Mesh,Int32[],Int32,String) Method (Microsoft.DirectX.Direct3D)

Mesh.Clean Method

Cleans a mesh, preparing it for simplification.

Definition

Visual Basic Public Shared Function Clean( _
ByVal cleanType As CleanType, _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByRef adjacencyOut As Integer, _
ByRef errorsAndWarnings As String _
) As Mesh
C# public static Mesh Clean(
CleanType cleanType,
Mesh mesh,
int[] adjacency,
out int adjacencyOut,
out string errorsAndWarnings
);
C++ public:
static Mesh^ Clean(
CleanType cleanType,
Mesh^ mesh,
array<int>^ adjacency,
[Out] int% adjacencyOut,
[Out] String^% errorsAndWarnings
);
JScript public static function Clean(
cleanType : CleanType,
mesh : Mesh,
adjacency : int[],
adjacencyOut : int,
errorsAndWarnings : String
) : Mesh;

Parameters

cleanType Microsoft.DirectX.Direct3D.CleanType
A flag from the CleanType enumeration that specifies the type of mesh cleaning to perform.
mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to clean.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be cleaned.
adjacencyOut System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.
errorsAndWarnings System.String
A String Leave Site that contains a list of errors and warnings that explain the problems found in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned cleaned mesh. If no cleaning is necessary, the returned mesh is the same as the one that was passed in.

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Clean(CleanType,Mesh,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Clean Method

Cleans a mesh, preparing it for simplification.

Definition

Visual Basic Public Shared Function Clean( _
ByVal cleanType As CleanType, _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal adjacencyOut As GraphicsStream _
) As Mesh
C# public static Mesh Clean(
CleanType cleanType,
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream adjacencyOut
);
C++ public:
static Mesh^ Clean(
CleanType cleanType,
Mesh^ mesh,
GraphicsStream^ adjacency,
GraphicsStream^ adjacencyOut
);
JScript public static function Clean(
cleanType : CleanType,
mesh : Mesh,
adjacency : GraphicsStream,
adjacencyOut : GraphicsStream
) : Mesh;

Parameters

cleanType Microsoft.DirectX.Direct3D.CleanType
A flag from the CleanType enumeration that specifies the type of mesh cleaning to perform.
mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to clean.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be cleaned.
adjacencyOut Microsoft.DirectX.GraphicsStream
A GraphicsStream object. When the method returns, this parameter is filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned cleaned mesh. If no cleaning is necessary, the returned mesh is the same as the one that was passed in.

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Clean(CleanType,Mesh,GraphicsStream,GraphicsStream,String) Method (Microsoft.DirectX.Direct3D)

Mesh.Clean Method

Cleans a mesh, preparing it for simplification.

Definition

Visual Basic Public Shared Function Clean( _
ByVal cleanType As CleanType, _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal adjacencyOut As GraphicsStream, _
ByRef errorsAndWarnings As String _
) As Mesh
C# public static Mesh Clean(
CleanType cleanType,
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream adjacencyOut,
out string errorsAndWarnings
);
C++ public:
static Mesh^ Clean(
CleanType cleanType,
Mesh^ mesh,
GraphicsStream^ adjacency,
GraphicsStream^ adjacencyOut,
[Out] String^% errorsAndWarnings
);
JScript public static function Clean(
cleanType : CleanType,
mesh : Mesh,
adjacency : GraphicsStream,
adjacencyOut : GraphicsStream,
errorsAndWarnings : String
) : Mesh;

Parameters

cleanType Microsoft.DirectX.Direct3D.CleanType
A flag from the CleanType enumeration that specifies the type of mesh cleaning to perform.
mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to clean.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be cleaned.
adjacencyOut Microsoft.DirectX.GraphicsStream
A GraphicsStream object. When the method returns, this parameter is filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.
errorsAndWarnings System.String
A String Leave Site that contains a list of errors and warnings that explain the problems found in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned cleaned mesh. If no cleaning is necessary, the returned mesh is the same as the one that was passed in.

Remarks

This method cleans the mesh by adding another vertex where two fans of triangles share the same vertex.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.ComputeTangent Method ()

Computes the tangent vectors for the texture coordinates given in a texture stage.

Overload List

public void ComputeTangent(int, int, int, int);
public void ComputeTangent(int, int, int, int, GraphicsStream);
public void ComputeTangent(int, int, int, int, int[]);

Remarks

If the mesh vertex declaration specifies tangent or binormal fields, ComputeTangent updates any user-supplied tangent or binormal data. Alternatively, set tangentIndex to D3DX.Default to prevent updates to the user-supplied tangent data, or binormIndex to D3DX.Default to prevent updates to the user-supplied binormal data.

The ComputeTangent method depends on the mesh vertex declaration containing either the tangent field (tangentIndex), the binormal field (binormIndex), or both. If both are set to D3DX.Default, the method fails.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.ComputeTangent(Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.ComputeTangent Method

Computes the tangent vectors for the texture coordinates given in a texture stage.

Definition

Visual Basic Public Sub ComputeTangent( _
ByVal texStage As Integer, _
ByVal tangentIndex As Integer, _
ByVal binormIndex As Integer, _
ByVal wrap As Integer _
)
C# public void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap
);
C++ public:
void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap
);
JScript public function ComputeTangent(
texStage : int,
tangentIndex : int,
binormIndex : int,
wrap : int
);

Parameters

texStage System.Int32
Index that represents the TextureStateManager in TextureStateManagerCollection.
tangentIndex System.Int32
Index that provides the usage index for the tangent data. The vertex declaration implies the usage; this index modifies it.
binormIndex System.Int32
Index that provides the usage index for the binormal data. The vertex declaration implies the usage; this index modifies it.
wrap System.Int32
Value that is set to 0 to specify no wrapping, or to 1 to specify wrapping in the u and v directions.

Remarks

If the mesh vertex declaration specifies tangent or binormal fields, ComputeTangent updates any user-supplied tangent or binormal data. Alternatively, set tangentIndex to D3DX.Default to prevent updates to the user-supplied tangent data, or binormIndex to D3DX.Default to prevent updates to the user-supplied binormal data.

The ComputeTangent method depends on the mesh vertex declaration containing either the tangent field (tangentIndex), the binormal field (binormIndex), or both. If both are set to D3DX.Default, the method fails.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.ComputeTangent(Int32,Int32,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.ComputeTangent Method

Computes the tangent vectors for the texture coordinates given in a texture stage.

Definition

Visual Basic Public Sub ComputeTangent( _
ByVal texStage As Integer, _
ByVal tangentIndex As Integer, _
ByVal binormIndex As Integer, _
ByVal wrap As Integer, _
ByVal adjacency As GraphicsStream _
)
C# public void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap,
GraphicsStream adjacency
);
C++ public:
void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap,
GraphicsStream^ adjacency
);
JScript public function ComputeTangent(
texStage : int,
tangentIndex : int,
binormIndex : int,
wrap : int,
adjacency : GraphicsStream
);

Parameters

texStage System.Int32
Index that represents the TextureStateManager in TextureStateManagerCollection.
tangentIndex System.Int32
Index that provides the usage index for the tangent data. The vertex declaration implies the usage; this index modifies it.
binormIndex System.Int32
Index that provides the usage index for the binormal data. The vertex declaration implies the usage; this index modifies it.
wrap System.Int32
Value that is set to 0 to specify no wrapping, or to 1 to specify wrapping in the u and v directions.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object filled with an array of three Int32 Leave Site values per face to be filled with adjacent face indices.

Remarks

If the mesh vertex declaration specifies tangent or binormal fields, ComputeTangent updates any user-supplied tangent or binormal data. Alternatively, set tangentIndex to D3DX.Default to prevent updates to the user-supplied tangent data, or binormIndex to D3DX.Default to prevent updates to the user-supplied binormal data.

The ComputeTangent method depends on the mesh vertex declaration containing either the tangent field (tangentIndex), the binormal field (binormIndex), or both. If both are set to D3DX.Default, the method fails.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.ComputeTangent(Int32,Int32,Int32,Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

Mesh.ComputeTangent Method

Computes the tangent vectors for the texture coordinates given in a texture stage.

Definition

Visual Basic Public Sub ComputeTangent( _
ByVal texStage As Integer, _
ByVal tangentIndex As Integer, _
ByVal binormIndex As Integer, _
ByVal wrap As Integer, _
ByVal adjacency() As Integer _
)
C# public void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap,
int[] adjacency
);
C++ public:
void ComputeTangent(
int texStage,
int tangentIndex,
int binormIndex,
int wrap,
array<int>^ adjacency
);
JScript public function ComputeTangent(
texStage : int,
tangentIndex : int,
binormIndex : int,
wrap : int,
adjacency : int[]
);

Parameters

texStage System.Int32
Index that represents the TextureStateManager in TextureStateManagerCollection.
tangentIndex System.Int32
Index that provides the usage index for the tangent data. The vertex declaration implies the usage; this index modifies it.
binormIndex System.Int32
Index that provides the usage index for the binormal data. The vertex declaration implies the usage; this index modifies it.
wrap System.Int32
Value that is set to 0 to specify no wrapping, or to 1 to specify wrapping in the u and v directions.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh. The size of this array must be at least 3 * BaseMesh.NumberFaces.

Remarks

If the mesh vertex declaration specifies tangent or binormal fields, ComputeTangent updates any user-supplied tangent or binormal data. Alternatively, set tangentIndex to D3DX.Default to prevent updates to the user-supplied tangent data, or binormIndex to D3DX.Default to prevent updates to the user-supplied binormal data.

The ComputeTangent method depends on the mesh vertex declaration containing either the tangent field (tangentIndex), the binormal field (binormIndex), or both. If both are set to D3DX.Default, the method fails.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.ComputeTangentFrame(TangentOptions) Method (Microsoft.DirectX.Direct3D)

Mesh.ComputeTangentFrame Method

Performs tangent frame computations on a mesh. Tangent, binormal, and optionally normal vectors are generated. Singularities are handled as required by grouping edges and splitting vertices.

Definition

Visual Basic Public Sub ComputeTangentFrame( _
ByVal options As TangentOptions _
)
C# public void ComputeTangentFrame(
TangentOptions options
);
C++ public:
void ComputeTangentFrame(
TangentOptions options
);
JScript public function ComputeTangentFrame(
options : TangentOptions
);

Parameters

options Microsoft.DirectX.Direct3D.TangentOptions
Combination of one or more TangentOptions values that specify tangent frame computation options. If zero, the following options will be specified: & ( GenerateInPlace | ( !( WeightByArea | WeightEqual | OrthogonalizeFromU | OrthogonalizeFromV | WrapUV | DontNormalizePartials | WindClockwise | CalculateNormals ) ).

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Geometry.ComputeTangentFrame

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Mesh.ConvertMeshSubsetToSingleStrip(Mesh,Int32,MeshFlags,Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.ConvertMeshSubsetToSingleStrip Method

Converts the specified mesh subset into a single triangle strip..

Definition

Visual Basic Public Shared Function ConvertMeshSubsetToSingleStrip( _
ByVal mesh As Mesh, _
ByVal attributeIdentifier As Integer, _
ByVal indexBufferOptions As MeshFlags, _
ByRef numIndices As Integer _
) As IndexBuffer
C# public static IndexBuffer ConvertMeshSubsetToSingleStrip(
Mesh mesh,
int attributeIdentifier,
MeshFlags indexBufferOptions,
out int numIndices
);
C++ public:
static IndexBuffer^ ConvertMeshSubsetToSingleStrip(
Mesh^ mesh,
int attributeIdentifier,
MeshFlags indexBufferOptions,
[Out] int% numIndices
);
JScript public static function ConvertMeshSubsetToSingleStrip(
mesh : Mesh,
attributeIdentifier : int,
indexBufferOptions : MeshFlags,
numIndices : int
) : IndexBuffer;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A BaseMesh object that represents the mesh to convert.
attributeIdentifier System.Int32
Attribute identifier of the mesh subset to convert.
indexBufferOptions Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify options for creating the single strip mesh (excepting the Simplify* and Optimize* flags).
numIndices System.Int32
Number of indices in the buffer returned in the ret_IndexBuffer.

Return Value

Microsoft.DirectX.Direct3D.IndexBuffer
An object that contains the strip.

Remarks

Before running this function, call Optimize or OptimizeFaces, with the MeshFlags.OptimizeAttributeSort flag set.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.ConvertMeshSubsetToStrips(BaseMesh,Int32,MeshFlags,Int32,GraphicsStream,Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.ConvertMeshSubsetToStrips Method

Converts the specified mesh subset into a series of strips.

Definition

Visual Basic Public Shared Function ConvertMeshSubsetToStrips( _
ByVal mesh As BaseMesh, _
ByVal attributeIdentifier As Integer, _
ByVal indexBufferOptions As MeshFlags, _
ByRef numIndices As Integer, _
ByRef stripLengths As GraphicsStream, _
ByRef numStrips As Integer _
) As IndexBuffer
C# public static IndexBuffer ConvertMeshSubsetToStrips(
BaseMesh mesh,
int attributeIdentifier,
MeshFlags indexBufferOptions,
out int numIndices,
out GraphicsStream stripLengths,
out int numStrips
);
C++ public:
static IndexBuffer^ ConvertMeshSubsetToStrips(
BaseMesh^ mesh,
int attributeIdentifier,
MeshFlags indexBufferOptions,
[Out] int% numIndices,
[Out] GraphicsStream^% stripLengths,
[Out] int% numStrips
);
JScript public static function ConvertMeshSubsetToStrips(
mesh : BaseMesh,
attributeIdentifier : int,
indexBufferOptions : MeshFlags,
numIndices : int,
stripLengths : GraphicsStream,
numStrips : int
) : IndexBuffer;

Parameters

mesh Microsoft.DirectX.Direct3D.BaseMesh
A BaseMesh class that represents the mesh to convert.
attributeIdentifier System.Int32
Attribute identifier of the mesh subset to convert.
indexBufferOptions Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify options for creating the new strip mesh (excepting the Simplify* and Optimize* flags).
numIndices System.Int32
Number of indices in the buffer returned in the ret_IndexBuffer.
stripLengths Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains one Int32 Leave Site value per strip, which specifies the number of triangles in that strip.
numStrips System.Int32
Number of individual strips in the index buffer and the corresponding strip length array.

Return Value

Microsoft.DirectX.Direct3D.IndexBuffer
A class that represents the index buffer containing the strip.

Remarks

Before running this function, call Optimize or OptimizeFaces, with the MeshFlags.OptimizeAttributeSort flag set.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Cylinder Method ()

Uses a left-handed coordinate system to create a mesh that contains a cylinder.

Overload List

public static Mesh Cylinder(Device, float, float, float, int, int);
public static Mesh Cylinder(Device, float, float, float, int, int, out GraphicsStream);

Remarks

The created cylinder is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Cylinder(Device,Single,Single,Single,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.Cylinder Method

Uses a left-handed coordinate system to create a mesh that contains a cylinder.

Definition

Visual Basic Public Shared Function Cylinder( _
ByVal device As Device, _
ByVal radius1 As Single, _
ByVal radius2 As Single, _
ByVal length As Single, _
ByVal slices As Integer, _
ByVal stacks As Integer _
) As Mesh
C# public static Mesh Cylinder(
Device device,
float radius1,
float radius2,
float length,
int slices,
int stacks
);
C++ public:
static Mesh^ Cylinder(
Device^ device,
float radius1,
float radius2,
float length,
int slices,
int stacks
);
JScript public static function Cylinder(
device : Device,
radius1 : float,
radius2 : float,
length : float,
slices : int,
stacks : int
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created cylinder mesh.
radius1 System.Single
Radius at the negative Z end. Value should be greater than or equal to 0.0f.
radius2 System.Single
Radius at the positive Z end. Value should be greater than or equal to 0.0f.
length System.Single
Length of the cylinder along the z-axis.
slices System.Int32
Number of slices around the main axis.
stacks System.Int32
Number of stacks along the main axis.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the cylinder mesh.

Remarks

The created cylinder is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Cylinder(Device,Single,Single,Single,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Cylinder Method

Uses a left-handed coordinate system to create a mesh that contains a cylinder.

Definition

Visual Basic Public Shared Function Cylinder( _
ByVal device As Device, _
ByVal radius1 As Single, _
ByVal radius2 As Single, _
ByVal length As Single, _
ByVal slices As Integer, _
ByVal stacks As Integer, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Cylinder(
Device device,
float radius1,
float radius2,
float length,
int slices,
int stacks,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ Cylinder(
Device^ device,
float radius1,
float radius2,
float length,
int slices,
int stacks,
[Out] GraphicsStream^% adjacency
);
JScript public static function Cylinder(
device : Device,
radius1 : float,
radius2 : float,
length : float,
slices : int,
stacks : int,
adjacency : GraphicsStream
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created cylinder mesh.
radius1 System.Single
Radius at the negative Z end. Value should be greater than or equal to 0.0f.
radius2 System.Single
Radius at the positive Z end. Value should be greater than or equal to 0.0f.
length System.Single
Length of the cylinder along the z-axis.
slices System.Int32
Number of slices around the main axis.
stacks System.Int32
Number of stacks along the main axis.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the cylinder mesh.

Remarks

The created cylinder is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Dispose() Method (Microsoft.DirectX.Direct3D)

Mesh.Dispose Method

Immediately releases the unmanaged resources used by the Mesh object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Mesh();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Mesh.Disposed
  • Microsoft.DirectX.Direct3D.Mesh.Disposing


Mesh.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Mesh.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Mesh.Finalize() Method (Microsoft.DirectX.Direct3D)

Mesh.Finalize Method

Allows the Mesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Mesh();
C++ | !Mesh();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Mesh.FromFile Method ()

Loads a mesh from a .x file.

Overload List

public static Mesh FromFile(string, MeshFlags, Device);
public static Mesh FromFile(string, MeshFlags, Device, out EffectInstance);
public static Mesh FromFile(string, MeshFlags, Device, out ExtendedMaterial);
public static Mesh FromFile(string, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static Mesh FromFile(string, MeshFlags, Device, out GraphicsStream);
public static Mesh FromFile(string, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static Mesh FromFile(string, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial);
public static Mesh FromFile(string, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial, out EffectInstance);

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromFile Method

Loads a mesh from a .x file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out EffectInstance effects
);
C++ public:
static Mesh^ FromFile(
String^ filename,
MeshFlags options,
Device^ device,
[Out] EffectInstance% effects
);
JScript public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : Mesh;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,GraphicsStream,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromFile Method

Loads a mesh from a .x file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
C++ public:
static Mesh^ FromFile(
String^ filename,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] EffectInstance% effects
);
JScript public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : Mesh;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromFile Method

Loads a mesh from a .x file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static Mesh^ FromFile(
String^ filename,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array that contains materials data. The array contains an array of Material structures, which in turn contain information from the .x file.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device) Method (Microsoft.DirectX.Direct3D)

Mesh.FromFile Method

Loads a mesh from a .x file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device
);
C++ public:
static Mesh^ FromFile(
String^ filename,
MeshFlags options,
Device^ device
);
JScript public static function FromFile(
filename : String,
options : MeshFlags,
device : Device
) : Mesh;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.FromFile Method

Loads a mesh from a .x file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ FromFile(
String^ filename,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency
);
JScript public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

Mesh.FromFile Method

Loads a mesh from a .x file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
C++ public:
static Mesh^ FromFile(
String^ filename,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials
);
JScript public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : Mesh;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array that contains materials data. The array contains an array of Material structures, which in turn contain information from the .x file.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,GraphicsStream,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

Mesh.FromFile Method

Loads a mesh from a .x file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials
);
C++ public:
static Mesh^ FromFile(
String^ filename,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] ExtendedMaterial% materials
);
JScript public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial
) : Mesh;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array that contains materials data. The array contains an array of Material structures, which in turn contain information from the .x file.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromFile(String,MeshFlags,Device,GraphicsStream,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromFile Method

Loads a mesh from a .x file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromFile(
string filename,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static Mesh^ FromFile(
String^ filename,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromFile(
filename : String,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array that contains materials data. The array contains an array of Material structures, which in turn contain information from the .x file.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Returns a Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the .x file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream Method ()

Loads a mesh from a Stream Leave Site.

Overload List

public static Mesh FromStream(Stream, int, MeshFlags, Device);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out EffectInstance);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out ExtendedMaterial);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out GraphicsStream);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial);
public static Mesh FromStream(Stream, int, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial, out EffectInstance);
public static Mesh FromStream(Stream, MeshFlags, Device);
public static Mesh FromStream(Stream, MeshFlags, Device, out EffectInstance);
public static Mesh FromStream(Stream, MeshFlags, Device, out ExtendedMaterial);
public static Mesh FromStream(Stream, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static Mesh FromStream(Stream, MeshFlags, Device, out GraphicsStream);
public static Mesh FromStream(Stream, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static Mesh FromStream(Stream, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial);

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out EffectInstance effects
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
MeshFlags options,
Device^ device,
[Out] EffectInstance% effects
);
JScript public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,GraphicsStream,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] EffectInstance% effects
);
JScript public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
MeshFlags options,
Device^ device
);
JScript public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency
);
JScript public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials
);
JScript public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,MeshFlags,Device,GraphicsStream,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] ExtendedMaterial% materials
);
JScript public static function FromStream(
stream : Stream,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out EffectInstance effects
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device,
[Out] EffectInstance% effects
);
JScript public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
readBytes System.Int32
Size of the file in memory in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,GraphicsStream,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] EffectInstance% effects
);
JScript public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
readBytes System.Int32
Size of the file in memory in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
readBytes System.Int32
Size of the file in memory in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device
);
JScript public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
readBytes System.Int32
Size of the file in memory in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency
);
JScript public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
readBytes System.Int32
Size of the file in memory in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials
);
JScript public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
readBytes System.Int32
Size of the file in memory in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,GraphicsStream,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] ExtendedMaterial% materials
);
JScript public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
readBytes System.Int32
Size of the file in memory in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromStream(Stream,Int32,MeshFlags,Device,GraphicsStream,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromStream Method

Loads a mesh from a Stream Leave Site.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromStream(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static Mesh^ FromStream(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromStream(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh data.
readBytes System.Int32
Size of the file in memory in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device to associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromX Method ()

Loads a mesh from an XFileData object.

Overload List

public static Mesh FromX(XFileData, MeshFlags, Device);
public static Mesh FromX(XFileData, MeshFlags, Device, out EffectInstance);
public static Mesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial);
public static Mesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static Mesh FromX(XFileData, MeshFlags, Device, out GraphicsStream);
public static Mesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static Mesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial, out EffectInstance);

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromX Method

Loads a mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out EffectInstance effects
);
C++ public:
static Mesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : Mesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromX Method

Loads a mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
C++ public:
static Mesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : Mesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromX Method

Loads a mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static Mesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device) Method (Microsoft.DirectX.Direct3D)

Mesh.FromX Method

Loads a mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device
);
C++ public:
static Mesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device
) : Mesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.FromX Method

Loads a mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

Mesh.FromX Method

Loads a mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
C++ public:
static Mesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : Mesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

Mesh.FromX Method

Loads a mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As Mesh
C# public static Mesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static Mesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial,
effects : EffectInstance
) : Mesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that contains the mesh data.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the loaded mesh.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. A default effect instance has default values that correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This variable contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Mesh.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Mesh.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXMesh, which allows unmanaged COM clients to create an instance of the managed Mesh class. Not supported.


Mesh.Intersect Method ()

Determines whether a ray intersects with a mesh.

Overload List

public bool Intersect(Vector3, Vector3);
public bool Intersect(Vector3, Vector3, out IntersectInformation);
public bool Intersect(Vector3, Vector3, out IntersectInformation, out IntersectInformation);
public bool Intersect(Vector3, Vector3, out IntersectInformation);

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.Intersect(Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

Mesh.Intersect Method

Determines whether a ray intersects with a mesh.

Definition

Visual Basic Public Function Intersect( _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3 _
) As Boolean
C# public bool Intersect(
Vector3 rayPos,
Vector3 rayDir
);
C++ public:
bool Intersect(
Vector3 rayPos,
Vector3 rayDir
);
JScript public function Intersect(
rayPos : Vector3,
rayDir : Vector3
) : boolean;

Parameters

rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.

Return Value

System.Boolean
Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.Intersect(Vector3,Vector3,IntersectInformation) Method (Microsoft.DirectX.Direct3D)

Mesh.Intersect Method

Determines whether a ray intersects with a mesh.

Definition

Visual Basic Public Function Intersect( _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef allHits As IntersectInformation _
) As Boolean
C# public bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation allHits
);
C++ public:
bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
[Out] IntersectInformation% allHits
);
JScript public function Intersect(
rayPos : Vector3,
rayDir : Vector3,
allHits : IntersectInformation
) : boolean;

Parameters

rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.
allHits Microsoft.DirectX.Direct3D.IntersectInformation[]
Array of IntersectInformation structures that describe all intersections of the ray and the mesh.

Return Value

System.Boolean
Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.Intersect(Vector3,Vector3,IntersectInformation) Method (Microsoft.DirectX.Direct3D)

Mesh.Intersect Method

Determines whether a ray intersects with a mesh.

Definition

Visual Basic Public Function Intersect( _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef closestHit As IntersectInformation _
) As Boolean
C# public bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation closestHit
);
C++ public:
bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
[Out] IntersectInformation% closestHit
);
JScript public function Intersect(
rayPos : Vector3,
rayDir : Vector3,
closestHit : IntersectInformation
) : boolean;

Parameters

rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.
closestHit Microsoft.DirectX.Direct3D.IntersectInformation
An IntersectInformation object that describes the closest intersection between the array and the mesh.

Return Value

System.Boolean
Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.Intersect(Vector3,Vector3,IntersectInformation,IntersectInformation) Method (Microsoft.DirectX.Direct3D)

Mesh.Intersect Method

Determines whether a ray intersects with a mesh.

Definition

Visual Basic Public Function Intersect( _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef closestHit As IntersectInformation, _
ByRef allHits As IntersectInformation _
) As Boolean
C# public bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation closestHit,
out IntersectInformation allHits
);
C++ public:
bool Intersect(
Vector3 rayPos,
Vector3 rayDir,
[Out] IntersectInformation% closestHit,
[Out] IntersectInformation% allHits
);
JScript public function Intersect(
rayPos : Vector3,
rayDir : Vector3,
closestHit : IntersectInformation,
allHits : IntersectInformation
) : boolean;

Parameters

rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.
closestHit Microsoft.DirectX.Direct3D.IntersectInformation
An IntersectInformation object that describes the closest intersection between the array and the mesh.
allHits Microsoft.DirectX.Direct3D.IntersectInformation[]
Array of IntersectInformation structures that describe all intersections of the ray and the mesh.

Return Value

System.Boolean
Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

The Intersect method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • IntersectSubset


Mesh.IntersectSubset Method ()

Intersects the specified ray with a given mesh subset.

Overload List

public bool IntersectSubset(int, Vector3, Vector3);
public bool IntersectSubset(int, Vector3, Vector3, out IntersectInformation);
public bool IntersectSubset(int, Vector3, Vector3, out IntersectInformation, out IntersectInformation);
public bool IntersectSubset(int, Vector3, Vector3, out IntersectInformation);

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.IntersectSubset(Int32,Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

Mesh.IntersectSubset Method

Intersects the specified ray with a given mesh subset.

Definition

Visual Basic Public Function IntersectSubset( _
ByVal attributeId As Integer, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3 _
) As Boolean
C# public bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir
);
C++ public:
bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir
);
JScript public function IntersectSubset(
attributeId : int,
rayPos : Vector3,
rayDir : Vector3
) : boolean;

Parameters

attributeId System.Int32
Attribute identifier of the subset to intersect with.
rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.

Return Value

System.Boolean
Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.IntersectSubset(Int32,Vector3,Vector3,IntersectInformation) Method (Microsoft.DirectX.Direct3D)

Mesh.IntersectSubset Method

Intersects the specified ray with a given mesh subset.

Definition

Visual Basic Public Function IntersectSubset( _
ByVal attributeId As Integer, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef allHits As IntersectInformation _
) As Boolean
C# public bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation allHits
);
C++ public:
bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
[Out] IntersectInformation% allHits
);
JScript public function IntersectSubset(
attributeId : int,
rayPos : Vector3,
rayDir : Vector3,
allHits : IntersectInformation
) : boolean;

Parameters

attributeId System.Int32
Attribute identifier of the subset to intersect with.
rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.
allHits Microsoft.DirectX.Direct3D.IntersectInformation[]
Array of IntersectInformation structures that describe all intersections of the ray and the mesh.

Return Value

System.Boolean
Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.IntersectSubset(Int32,Vector3,Vector3,IntersectInformation) Method (Microsoft.DirectX.Direct3D)

Mesh.IntersectSubset Method

Intersects the specified ray with a given mesh subset.

Definition

Visual Basic Public Function IntersectSubset( _
ByVal attributeId As Integer, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef closestHit As IntersectInformation _
) As Boolean
C# public bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation closestHit
);
C++ public:
bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
[Out] IntersectInformation% closestHit
);
JScript public function IntersectSubset(
attributeId : int,
rayPos : Vector3,
rayDir : Vector3,
closestHit : IntersectInformation
) : boolean;

Parameters

attributeId System.Int32
Attribute identifier of the subset to intersect with.
rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.
closestHit Microsoft.DirectX.Direct3D.IntersectInformation
An IntersectInformation object that describes the closest intersection between the array and the mesh.

Return Value

System.Boolean
Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.IntersectSubset(Int32,Vector3,Vector3,IntersectInformation,IntersectInformation) Method (Microsoft.DirectX.Direct3D)

Mesh.IntersectSubset Method

Intersects the specified ray with a given mesh subset.

Definition

Visual Basic Public Function IntersectSubset( _
ByVal attributeId As Integer, _
ByVal rayPos As Vector3, _
ByVal rayDir As Vector3, _
ByRef closestHit As IntersectInformation, _
ByRef allHits As IntersectInformation _
) As Boolean
C# public bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
out IntersectInformation closestHit,
out IntersectInformation allHits
);
C++ public:
bool IntersectSubset(
int attributeId,
Vector3 rayPos,
Vector3 rayDir,
[Out] IntersectInformation% closestHit,
[Out] IntersectInformation% allHits
);
JScript public function IntersectSubset(
attributeId : int,
rayPos : Vector3,
rayDir : Vector3,
closestHit : IntersectInformation,
allHits : IntersectInformation
) : boolean;

Parameters

attributeId System.Int32
Attribute identifier of the subset to intersect with.
rayPos Microsoft.DirectX.Vector3
A Vector3 structure that specifies the origin coordinate of the ray.
rayDir Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.
closestHit Microsoft.DirectX.Direct3D.IntersectInformation
An IntersectInformation object that describes the closest intersection between the array and the mesh.
allHits Microsoft.DirectX.Direct3D.IntersectInformation[]
Array of IntersectInformation structures that describe all intersections of the ray and the mesh.

Return Value

System.Boolean
Value that is true if the ray intersects a triangular face on the mesh; otherwise, the value is false.

Remarks

This method provides functionality that is similar to that of Intersect.

The IntersectSubset method provides a way to understand points in and around a triangle, independent of where the triangle is actually located. This method returns the resulting point by using the following equation:

V1 + U(V2-V1) + V(V3-V1)

Any point in the plane V1V2V3 can be represented by the barycentric coordinate (U,V). The U parameter controls how much V2 gets weighted into the result, and the V parameter controls how much V3 gets weighted into the result. Lastly, 1-U-V controls how much V1 gets weighted into the result.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.LoadHierarchy Method ()

Loads the first frame hierarchy from a Stream Leave Site.

Overload List

public static AnimationRootFrame LoadHierarchy(Stream, int, MeshFlags, Device, AllocateHierarchy, LoadUserData);
public static AnimationRootFrame LoadHierarchy(Stream, MeshFlags, Device, AllocateHierarchy, LoadUserData);

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.LoadHierarchy(Stream,MeshFlags,Device,AllocateHierarchy,LoadUserData) Method (Microsoft.DirectX.Direct3D)

Mesh.LoadHierarchy Method

Loads the first frame hierarchy from a Stream Leave Site.

Definition

Visual Basic Public Shared Function LoadHierarchy( _
ByVal stream As Stream, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByVal allocHierarchy As AllocateHierarchy, _
ByVal userDataLoader As LoadUserData _
) As AnimationRootFrame
C# public static AnimationRootFrame LoadHierarchy(
Stream stream,
MeshFlags options,
Device device,
AllocateHierarchy allocHierarchy,
LoadUserData userDataLoader
);
C++ public:
static AnimationRootFrame LoadHierarchy(
Stream^ stream,
MeshFlags options,
Device^ device,
AllocateHierarchy^ allocHierarchy,
LoadUserData^ userDataLoader
);
JScript public static function LoadHierarchy(
stream : Stream,
options : MeshFlags,
device : Device,
allocHierarchy : AllocateHierarchy,
userDataLoader : LoadUserData
) : AnimationRootFrame;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh hierarchy to load.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.
allocHierarchy Microsoft.DirectX.Direct3D.AllocateHierarchy
An AllocateHierarchy object.
userDataLoader Microsoft.DirectX.Direct3D.LoadUserData
Application-provided object that allows loading of user data. For more information, see LoadUserData.

Return Value

Microsoft.DirectX.Direct3D.AnimationRootFrame
An AnimationRootFrame. The AnimationRootFrame.AnimationController property contains an AnimationController that corresponds to an animation, created with default tracks and events, in the DirectX (.x) file.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.LoadHierarchy(Stream,Int32,MeshFlags,Device,AllocateHierarchy,LoadUserData) Method (Microsoft.DirectX.Direct3D)

Mesh.LoadHierarchy Method

Loads the first frame hierarchy from a Stream Leave Site.

Definition

Visual Basic Public Shared Function LoadHierarchy( _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByVal allocHierarchy As AllocateHierarchy, _
ByVal userDataLoader As LoadUserData _
) As AnimationRootFrame
C# public static AnimationRootFrame LoadHierarchy(
Stream stream,
int readBytes,
MeshFlags options,
Device device,
AllocateHierarchy allocHierarchy,
LoadUserData userDataLoader
);
C++ public:
static AnimationRootFrame LoadHierarchy(
Stream^ stream,
int readBytes,
MeshFlags options,
Device^ device,
AllocateHierarchy^ allocHierarchy,
LoadUserData^ userDataLoader
);
JScript public static function LoadHierarchy(
stream : Stream,
readBytes : int,
options : MeshFlags,
device : Device,
allocHierarchy : AllocateHierarchy,
userDataLoader : LoadUserData
) : AnimationRootFrame;

Parameters

stream System.IO.Stream
A Stream Leave Site object that contains the mesh hierarchy to load.
readBytes System.Int32
Size of the param_Stream_stream in bytes.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the Mesh enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Deviceto associate with the mesh.
allocHierarchy Microsoft.DirectX.Direct3D.AllocateHierarchy
An AllocateHierarchy object.
userDataLoader Microsoft.DirectX.Direct3D.LoadUserData
Application-provided object that allows loading of user data. For more information, see LoadUserData.

Return Value

Microsoft.DirectX.Direct3D.AnimationRootFrame
An AnimationRootFrame. The AnimationRootFrame.AnimationController property contains an AnimationController that corresponds to an animation, created with default tracks and events, in the DirectX (.x) file.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.LoadHierarchyFromFile(String,MeshFlags,Device,AllocateHierarchy,LoadUserData) Method (Microsoft.DirectX.Direct3D)

Mesh.LoadHierarchyFromFile Method

Loads the first frame hierarchy in a DirectX (.x) file.

Definition

Visual Basic Public Shared Function LoadHierarchyFromFile( _
ByVal filename As String, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByVal allocHierarchy As AllocateHierarchy, _
ByVal userDataLoader As LoadUserData _
) As AnimationRootFrame
C# public static AnimationRootFrame LoadHierarchyFromFile(
string filename,
MeshFlags options,
Device device,
AllocateHierarchy allocHierarchy,
LoadUserData userDataLoader
);
C++ public:
static AnimationRootFrame LoadHierarchyFromFile(
String^ filename,
MeshFlags options,
Device^ device,
AllocateHierarchy^ allocHierarchy,
LoadUserData^ userDataLoader
);
JScript public static function LoadHierarchyFromFile(
filename : String,
options : MeshFlags,
device : Device,
allocHierarchy : AllocateHierarchy,
userDataLoader : LoadUserData
) : AnimationRootFrame;

Parameters

filename System.String
String that specifies the file name.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.
allocHierarchy Microsoft.DirectX.Direct3D.AllocateHierarchy
An AllocateHierarchy object. See Remarks.
userDataLoader Microsoft.DirectX.Direct3D.LoadUserData
Application-provided object that allows loading of user data. For more information, see LoadUserData.

Return Value

Microsoft.DirectX.Direct3D.AnimationRootFrame
An AnimationRootFrame. The AnimationRootFrame.AnimationController property contains an AnimationController that corresponds to an animation, created with default tracks and events, in the .x file.

Remarks

All meshes in the file are collapsed into one output mesh. If the file contains a frame hierarchy, all of the transformations are applied to the mesh.

The LoadHierarchyFromFile method loads the animation data and frame hierarchy from a .x file. It scans the .x file and builds a frame hierarchy and animation controller according to the object, derived from AllocateHierarchy, that is passed to it through param_AllocateHierarchy_allocHierarchy. Loading the data requires the following steps.

  1. Derive AllocateHierarchy, implementing each method. This controls how frames and meshes are allocated and freed.
  2. Derive LoadUserData, implementing each method. If the .x file has no embedded user-defined data, or if it is not needed, this step can be skipped.
  3. Create an object of the AllocateHierarchy class, and optionally of the LoadUserData class. You do not need to call any methods of these objects yourself.
  4. Call LoadHierarchyFromFile, passing in the AllocateHierarchy and LoadUserData objects (or null) to create the frame hierarchy and animation controller. All of the animation sets and frames are automatically registered to the animation controller.

During the load, AllocateHierarchy.CreateFrame and LoadUserData.LoadFrameChildData are called back on each frame to control its loading and allocation. The application defines these methods to control how frames are stored.

The AllocateHierarchy.CreateMeshContainer and LoadUserData.LoadMeshChildData methods are called back on each mesh object to control their loading and allocation. The LoadUserData.LoadTopLevelData method is called back for each top-level object that is not loaded by the other methods.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.LockAttributeBuffer(LockFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.LockAttributeBuffer Method

Locks an attribute buffer and obtains its memory.

Definition

Visual Basic Public Function LockAttributeBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockAttributeBuffer(
LockFlags flags
);
C++ public:
GraphicsStream^ LockAttributeBuffer(
LockFlags flags
);
JScript public function LockAttributeBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream

Remarks

If Mesh.Optimize is called, the mesh attribute buffer contains an attribute table.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetAttributeTable
  • UnlockAttributeBuffer


Mesh.LockAttributeBufferArray(LockFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.LockAttributeBufferArray Method

Locks an attribute buffer and obtains its memory.

Definition

Visual Basic Public Function LockAttributeBufferArray( _
ByVal flags As LockFlags _
) As Integer()
C# public int[] LockAttributeBufferArray(
LockFlags flags
);
C++ public:
array<int>^ LockAttributeBufferArray(
LockFlags flags
);
JScript public function LockAttributeBufferArray(
flags : LockFlags
) : int[];

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly.

Return Value

System.Int32[]
Returns an array that contains Int32 Leave Site values, one for each face in the mesh, that specify the attribute ID of each face.

Remarks

If Mesh.Optimize is called, the mesh attribute buffer contains an attribute table.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SetAttributeTable
  • UnlockAttributeBuffer


Mesh.Mesh Constructor ()

How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Overload List

public Mesh(ID3DXMesh);
public Mesh(int, int, MeshFlags, GraphicsStream, Device);
public Mesh(int, int, MeshFlags, VertexElement[], Device);
public Mesh(int, int, MeshFlags, VertexFormats, Device);
public Mesh(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(ID3DXMesh) Constructor (Microsoft.DirectX.Direct3D)

Mesh.Mesh Constructor

How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As ID3DXMesh _
)
C# public Mesh(
ID3DXMesh pInterop
);
C++ public:
Mesh(
ID3DXMesh pInterop
);
JScript public function Mesh(
pInterop : ID3DXMesh
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXMesh
Unmanaged Component Object Model (COM) ID3DXMesh interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Mesh.Mesh Constructor

How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Mesh(
IntPtr unmanagedObject
);
C++ public:
Mesh(
IntPtr unmanagedObject
);
JScript public function Mesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(Int32,Int32,MeshFlags,VertexFormats,Device) Constructor (Microsoft.DirectX.Direct3D)

Mesh.Mesh Constructor

How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic Public Sub New( _
ByVal numFaces As Integer, _
ByVal numVertices As Integer, _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
)
C# public Mesh(
int numFaces,
int numVertices,
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
C++ public:
Mesh(
int numFaces,
int numVertices,
MeshFlags options,
VertexFormats vertexFormat,
Device^ device
);
JScript public function Mesh(
numFaces : int,
numVertices : int,
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
);

Parameters

numFaces System.Int32
Number of faces for the mesh. The valid range is greater than 0 and one less than the maximum Int32 Leave Site (typically 65534), because the last index is reserved.
numVertices System.Int32
Number of vertices for the mesh. This parameter must be greater than 0.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
One or more flags from the VertexFormats enumeration that specify the format of the mesh vertices.
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(Int32,Int32,MeshFlags,GraphicsStream,Device) Constructor (Microsoft.DirectX.Direct3D)

Mesh.Mesh Constructor

How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic Public Sub New( _
ByVal numFaces As Integer, _
ByVal numVertices As Integer, _
ByVal options As MeshFlags, _
ByVal declaration As GraphicsStream, _
ByVal device As Device _
)
C# public Mesh(
int numFaces,
int numVertices,
MeshFlags options,
GraphicsStream declaration,
Device device
);
C++ public:
Mesh(
int numFaces,
int numVertices,
MeshFlags options,
GraphicsStream^ declaration,
Device^ device
);
JScript public function Mesh(
numFaces : int,
numVertices : int,
options : MeshFlags,
declaration : GraphicsStream,
device : Device
);

Parameters

numFaces System.Int32
Number of faces for the mesh. The valid range is greater than 0 and one less than the maximum Int32 Leave Site (typically 65534), because the last index is reserved.
numVertices System.Int32
Number of vertices for the mesh. This parameter must be greater than 0.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
declaration Microsoft.DirectX.GraphicsStream
A GraphicsStream containing an array of VertexFormats enumeration values that specify the format of the mesh vertices.
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.Mesh(Int32,Int32,MeshFlags,VertexElement[],Device) Constructor (Microsoft.DirectX.Direct3D)

Mesh.Mesh Constructor

How Do I...?
  • Create a Mesh Object

Creates a new Mesh instance.

Definition

Visual Basic Public Sub New( _
ByVal numFaces As Integer, _
ByVal numVertices As Integer, _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
)
C# public Mesh(
int numFaces,
int numVertices,
MeshFlags options,
VertexElement[] declaration,
Device device
);
C++ public:
Mesh(
int numFaces,
int numVertices,
MeshFlags options,
array<VertexElement>^ declaration,
Device^ device
);
JScript public function Mesh(
numFaces : int,
numVertices : int,
options : MeshFlags,
declaration : VertexElement[],
device : Device
);

Parameters

numFaces System.Int32
Number of faces for the mesh. The valid range is greater than 0 and one less than the maximum Int32 Leave Site (typically 65534), because the last index is reserved.
numVertices System.Int32
Number of vertices for the mesh. This parameter must be greater than 0.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more flags from the MeshFlags enumeration that specify creation options for the mesh (excepting the Simplify* and Optimize* flags).
declaration Microsoft.DirectX.Direct3D.VertexElement[]
An array of VertexElement objects, that describes the vertex format for the returned mesh. This parameter must map directly to a flexible vertex format (FVF).
device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


Mesh.op_Equality(Mesh,Mesh) Method (Microsoft.DirectX.Direct3D)

Mesh.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Mesh, _
ByVal right As Mesh _
) As Boolean
C# public static bool op_Equality(
Mesh left,
Mesh right
);
C++ public:
static bool operator==(
Mesh^ left,
Mesh^ right
);
JScript public static function op_Equality(
left : Mesh,
right : Mesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Mesh
The Mesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Mesh
The Mesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Mesh.op_Inequality(Mesh,Mesh) Method (Microsoft.DirectX.Direct3D)

Mesh.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Mesh, _
ByVal right As Mesh _
) As Boolean
C# public static bool op_Inequality(
Mesh left,
Mesh right
);
C++ public:
static bool operator!=(
Mesh^ left,
Mesh^ right
);
JScript public static function op_Inequality(
left : Mesh,
right : Mesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Mesh
The Mesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Mesh
The Mesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Mesh.Optimize Method ()

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Overload List

public Mesh Optimize(MeshFlags, GraphicsStream);
public Mesh Optimize(MeshFlags, GraphicsStream, out int, out int, out GraphicsStream);
public Mesh Optimize(MeshFlags, int[]);
public Mesh Optimize(MeshFlags, int[], out int, out int, out GraphicsStream);

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.Optimize(MeshFlags,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Optimize Method

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Definition

Visual Basic Public Function Optimize( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn As GraphicsStream _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
GraphicsStream adjacencyIn
);
C++ public:
Mesh^ Optimize(
MeshFlags flags,
GraphicsStream^ adjacencyIn
);
JScript public function Optimize(
flags : MeshFlags,
adjacencyIn : GraphicsStream
) : Mesh;

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform; can be set to one or more MeshFlags flags (except Use32Bit, IbWriteOnly, and WriteOnly).
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the optimized mesh.

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.Optimize(MeshFlags,GraphicsStream,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Optimize Method

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Definition

Visual Basic Public Function Optimize( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
GraphicsStream adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
Mesh^ Optimize(
MeshFlags flags,
GraphicsStream^ adjacencyIn,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function Optimize(
flags : MeshFlags,
adjacencyIn : GraphicsStream,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform; can be set to one or more MeshFlags flags (except Use32Bit, IbWriteOnly, and WriteOnly).
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.
adjacencyOut System.Int32[]
[in, out] Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap System.Int32[]
[in, out] Destination buffer that contains the new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains the new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the optimized mesh.

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.Optimize(MeshFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

Mesh.Optimize Method

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Definition

Visual Basic Public Function Optimize( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn() As Integer _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
int[] adjacencyIn
);
C++ public:
Mesh^ Optimize(
MeshFlags flags,
array<int>^ adjacencyIn
);
JScript public function Optimize(
flags : MeshFlags,
adjacencyIn : int[]
) : Mesh;

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform; can be set to one or more MeshFlags flags (except Use32Bit, IbWriteOnly, and WriteOnly).
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the optimized mesh.

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.Optimize(MeshFlags,Int32[],Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Optimize Method

Controls the reordering of mesh faces and vertices to optimize performance and generate an output mesh.

Definition

Visual Basic Public Function Optimize( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
int[] adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
Mesh^ Optimize(
MeshFlags flags,
array<int>^ adjacencyIn,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function Optimize(
flags : MeshFlags,
adjacencyIn : int[],
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform; can be set to one or more MeshFlags flags (except Use32Bit, IbWriteOnly, and WriteOnly).
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.
adjacencyOut System.Int32[]
[in, out] Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap System.Int32[]
[in, out] Destination buffer that contains the new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains the new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the optimized mesh.

Remarks

This method is similar to the BaseMesh.CloneMesh method, except that it can perform optimization while generating the new clone of the mesh.

The output mesh inherits all of the creation parameters of the input mesh.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • OptimizeInPlace


Mesh.OptimizeInPlace Method ()

Controls the reordering of mesh faces and vertices to optimize performance.

Overload List

public void OptimizeInPlace(MeshFlags, GraphicsStream);
public void OptimizeInPlace(MeshFlags, GraphicsStream, out int, out int, out GraphicsStream);
public void OptimizeInPlace(MeshFlags, int[]);
public void OptimizeInPlace(MeshFlags, int[], out int, out int, out GraphicsStream);

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.OptimizeInPlace(MeshFlags,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.OptimizeInPlace Method

Controls the reordering of mesh faces and vertices to optimize performance.

Definition

Visual Basic Public Sub OptimizeInPlace( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn As GraphicsStream _
)
C# public void OptimizeInPlace(
MeshFlags flags,
GraphicsStream adjacencyIn
);
C++ public:
void OptimizeInPlace(
MeshFlags flags,
GraphicsStream^ adjacencyIn
);
JScript public function OptimizeInPlace(
flags : MeshFlags,
adjacencyIn : GraphicsStream
);

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform; can be set to one or more of the MeshFlags Optimize* flags.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.OptimizeInPlace(MeshFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

Mesh.OptimizeInPlace Method

Controls the reordering of mesh faces and vertices to optimize performance.

Definition

Visual Basic Public Sub OptimizeInPlace( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn() As Integer _
)
C# public void OptimizeInPlace(
MeshFlags flags,
int[] adjacencyIn
);
C++ public:
void OptimizeInPlace(
MeshFlags flags,
array<int>^ adjacencyIn
);
JScript public function OptimizeInPlace(
flags : MeshFlags,
adjacencyIn : int[]
);

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform; can be set to one or more of the MeshFlags Optimize* flags.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.OptimizeInPlace(MeshFlags,GraphicsStream,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.OptimizeInPlace Method

Controls the reordering of mesh faces and vertices to optimize performance.

Definition

Visual Basic Public Sub OptimizeInPlace( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void OptimizeInPlace(
MeshFlags flags,
GraphicsStream adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
void OptimizeInPlace(
MeshFlags flags,
GraphicsStream^ adjacencyIn,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function OptimizeInPlace(
flags : MeshFlags,
adjacencyIn : GraphicsStream,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
);

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform; can be set to one or more of the MeshFlags Optimize* flags.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.
adjacencyOut System.Int32[]
[in, out] Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap System.Int32[]
[in, out] Destination buffer that contains the new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains the new index for each vertex.

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.OptimizeInPlace(MeshFlags,Int32[],Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.OptimizeInPlace Method

Controls the reordering of mesh faces and vertices to optimize performance.

Definition

Visual Basic Public Sub OptimizeInPlace( _
ByVal flags As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void OptimizeInPlace(
MeshFlags flags,
int[] adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
void OptimizeInPlace(
MeshFlags flags,
array<int>^ adjacencyIn,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function OptimizeInPlace(
flags : MeshFlags,
adjacencyIn : int[],
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
);

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform; can be set to one or more of the MeshFlags Optimize* flags.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0.
adjacencyOut System.Int32[]
[in, out] Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap System.Int32[]
[in, out] Destination buffer that contains the new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains the new index for each vertex.

Remarks

Note: This method fails if the mesh is sharing its vertex buffer with another mesh, unless the MeshFlags.OptimizeIgnoreVerts flag is set in the param_MeshFlags_flags parameter.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort (OptimizeAttrSort) is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Optimize


Mesh.Polygon Method ()

Uses a left-handed coordinate system to create a mesh that contains an n-sided polygon.

Overload List

public static Mesh Polygon(Device, float, int);
public static Mesh Polygon(Device, float, int, out GraphicsStream);

Remarks

The created polygon is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Cylinder
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Polygon(Device,Single,Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.Polygon Method

Uses a left-handed coordinate system to create a mesh that contains an n-sided polygon.

Definition

Visual Basic Public Shared Function Polygon( _
ByVal device As Device, _
ByVal length As Single, _
ByVal sides As Integer _
) As Mesh
C# public static Mesh Polygon(
Device device,
float length,
int sides
);
C++ public:
static Mesh^ Polygon(
Device^ device,
float length,
int sides
);
JScript public static function Polygon(
device : Device,
length : float,
sides : int
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created polygon mesh.
length System.Single
Length of each side.
sides System.Int32
Number of sides for the polygon; must be greater than or equal to 3.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the polygon mesh.

Remarks

The created polygon is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Cylinder
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Polygon(Device,Single,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Polygon Method

Uses a left-handed coordinate system to create a mesh that contains an n-sided polygon.

Definition

Visual Basic Public Shared Function Polygon( _
ByVal device As Device, _
ByVal length As Single, _
ByVal sides As Integer, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Polygon(
Device device,
float length,
int sides,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ Polygon(
Device^ device,
float length,
int sides,
[Out] GraphicsStream^% adjacency
);
JScript public static function Polygon(
device : Device,
length : float,
sides : int,
adjacency : GraphicsStream
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created polygon mesh.
length System.Single
Length of each side.
sides System.Int32
Number of sides for the polygon; must be greater than or equal to 3.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the polygon mesh.

Remarks

The created polygon is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Cylinder
  • Mesh.Box
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Mesh.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Mesh.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Mesh.Save Method ()

Saves the mesh to the specified stream object.

Overload List

public void Save(Stream, GraphicsStream, ExtendedMaterial[], EffectInstance[], XFileFormat);
public void Save(Stream, GraphicsStream, ExtendedMaterial[], XFileFormat);
public void Save(Stream, int[], ExtendedMaterial[], EffectInstance[], XFileFormat);
public void Save(Stream, int[], ExtendedMaterial[], XFileFormat);
public void Save(string, GraphicsStream, ExtendedMaterial[], EffectInstance[], XFileFormat);
public void Save(string, GraphicsStream, ExtendedMaterial[], XFileFormat);
public void Save(string, int[], ExtendedMaterial[], EffectInstance[], XFileFormat);
public void Save(string, int[], ExtendedMaterial[], XFileFormat);

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(String,GraphicsStream,ExtendedMaterial[],XFileFormat) Method (Microsoft.DirectX.Direct3D)

Mesh.Save Method

Saves the mesh to the specified stream object.

Definition

Visual Basic Public Sub Save( _
ByVal filename As String, _
ByVal adjacency As GraphicsStream, _
ByVal materials() As ExtendedMaterial, _
ByVal format As XFileFormat _
)
C# public void Save(
string filename,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
XFileFormat format
);
C++ public:
void Save(
String^ filename,
GraphicsStream^ adjacency,
array<ExtendedMaterial>^ materials,
XFileFormat format
);
JScript public function Save(
filename : String,
adjacency : GraphicsStream,
materials : ExtendedMaterial[],
format : XFileFormat
);

Parameters

filename System.String
String that specifies the file name.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(String,GraphicsStream,ExtendedMaterial[],EffectInstance[],XFileFormat) Method (Microsoft.DirectX.Direct3D)

Mesh.Save Method

Saves the mesh to the specified stream object.

Definition

Visual Basic Public Sub Save( _
ByVal filename As String, _
ByVal adjacency As GraphicsStream, _
ByVal materials() As ExtendedMaterial, _
ByVal effects() As EffectInstance, _
ByVal format As XFileFormat _
)
C# public void Save(
string filename,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
EffectInstance[] effects,
XFileFormat format
);
C++ public:
void Save(
String^ filename,
GraphicsStream^ adjacency,
array<ExtendedMaterial>^ materials,
array<EffectInstance>^ effects,
XFileFormat format
);
JScript public function Save(
filename : String,
adjacency : GraphicsStream,
materials : ExtendedMaterial[],
effects : EffectInstance[],
format : XFileFormat
);

Parameters

filename System.String
String that specifies the file name.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
Array of EffectInstance structures, one per attribute group in the mesh. An effect instance is a particular instance of state information used to initialize an effect.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(String,Int32[],ExtendedMaterial[],XFileFormat) Method (Microsoft.DirectX.Direct3D)

Mesh.Save Method

Saves the mesh to the specified stream object.

Definition

Visual Basic Public Sub Save( _
ByVal filename As String, _
ByVal adjacency() As Integer, _
ByVal materials() As ExtendedMaterial, _
ByVal format As XFileFormat _
)
C# public void Save(
string filename,
int[] adjacency,
ExtendedMaterial[] materials,
XFileFormat format
);
C++ public:
void Save(
String^ filename,
array<int>^ adjacency,
array<ExtendedMaterial>^ materials,
XFileFormat format
);
JScript public function Save(
filename : String,
adjacency : int[],
materials : ExtendedMaterial[],
format : XFileFormat
);

Parameters

filename System.String
String that specifies the file name.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(String,Int32[],ExtendedMaterial[],EffectInstance[],XFileFormat) Method (Microsoft.DirectX.Direct3D)

Mesh.Save Method

Saves the mesh to the specified stream object.

Definition

Visual Basic Public Sub Save( _
ByVal filename As String, _
ByVal adjacency() As Integer, _
ByVal materials() As ExtendedMaterial, _
ByVal effects() As EffectInstance, _
ByVal format As XFileFormat _
)
C# public void Save(
string filename,
int[] adjacency,
ExtendedMaterial[] materials,
EffectInstance[] effects,
XFileFormat format
);
C++ public:
void Save(
String^ filename,
array<int>^ adjacency,
array<ExtendedMaterial>^ materials,
array<EffectInstance>^ effects,
XFileFormat format
);
JScript public function Save(
filename : String,
adjacency : int[],
materials : ExtendedMaterial[],
effects : EffectInstance[],
format : XFileFormat
);

Parameters

filename System.String
String that specifies the file name.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
Array of EffectInstance structures, one per attribute group in the mesh. An effect instance is a particular instance of state information used to initialize an effect.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(Stream,GraphicsStream,ExtendedMaterial[],XFileFormat) Method (Microsoft.DirectX.Direct3D)

Mesh.Save Method

Saves the mesh to the specified stream object.

Definition

Visual Basic Public Sub Save( _
ByVal stream As Stream, _
ByVal adjacency As GraphicsStream, _
ByVal materials() As ExtendedMaterial, _
ByVal format As XFileFormat _
)
C# public void Save(
Stream stream,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
XFileFormat format
);
C++ public:
void Save(
Stream^ stream,
GraphicsStream^ adjacency,
array<ExtendedMaterial>^ materials,
XFileFormat format
);
JScript public function Save(
stream : Stream,
adjacency : GraphicsStream,
materials : ExtendedMaterial[],
format : XFileFormat
);

Parameters

stream System.IO.Stream
The Stream Leave Site in which to save the .x file.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(Stream,GraphicsStream,ExtendedMaterial[],EffectInstance[],XFileFormat) Method (Microsoft.DirectX.Direct3D)

Mesh.Save Method

Saves the mesh to the specified stream object.

Definition

Visual Basic Public Sub Save( _
ByVal stream As Stream, _
ByVal adjacency As GraphicsStream, _
ByVal materials() As ExtendedMaterial, _
ByVal effects() As EffectInstance, _
ByVal format As XFileFormat _
)
C# public void Save(
Stream stream,
GraphicsStream adjacency,
ExtendedMaterial[] materials,
EffectInstance[] effects,
XFileFormat format
);
C++ public:
void Save(
Stream^ stream,
GraphicsStream^ adjacency,
array<ExtendedMaterial>^ materials,
array<EffectInstance>^ effects,
XFileFormat format
);
JScript public function Save(
stream : Stream,
adjacency : GraphicsStream,
materials : ExtendedMaterial[],
effects : EffectInstance[],
format : XFileFormat
);

Parameters

stream System.IO.Stream
The Stream Leave Site in which to save the .x file.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
Array of EffectInstance structures, one per attribute group in the mesh. An effect instance is a particular instance of state information used to initialize an effect.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(Stream,Int32[],ExtendedMaterial[],XFileFormat) Method (Microsoft.DirectX.Direct3D)

Mesh.Save Method

Saves the mesh to the specified stream object.

Definition

Visual Basic Public Sub Save( _
ByVal stream As Stream, _
ByVal adjacency() As Integer, _
ByVal materials() As ExtendedMaterial, _
ByVal format As XFileFormat _
)
C# public void Save(
Stream stream,
int[] adjacency,
ExtendedMaterial[] materials,
XFileFormat format
);
C++ public:
void Save(
Stream^ stream,
array<int>^ adjacency,
array<ExtendedMaterial>^ materials,
XFileFormat format
);
JScript public function Save(
stream : Stream,
adjacency : int[],
materials : ExtendedMaterial[],
format : XFileFormat
);

Parameters

stream System.IO.Stream
The Stream Leave Site in which to save the .x file.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.Save(Stream,Int32[],ExtendedMaterial[],EffectInstance[],XFileFormat) Method (Microsoft.DirectX.Direct3D)

Mesh.Save Method

Saves the mesh to the specified stream object.

Definition

Visual Basic Public Sub Save( _
ByVal stream As Stream, _
ByVal adjacency() As Integer, _
ByVal materials() As ExtendedMaterial, _
ByVal effects() As EffectInstance, _
ByVal format As XFileFormat _
)
C# public void Save(
Stream stream,
int[] adjacency,
ExtendedMaterial[] materials,
EffectInstance[] effects,
XFileFormat format
);
C++ public:
void Save(
Stream^ stream,
array<int>^ adjacency,
array<ExtendedMaterial>^ materials,
array<EffectInstance>^ effects,
XFileFormat format
);
JScript public function Save(
stream : Stream,
adjacency : int[],
materials : ExtendedMaterial[],
effects : EffectInstance[],
format : XFileFormat
);

Parameters

stream System.IO.Stream
The Stream Leave Site in which to save the .x file.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information to save in the DirectX (.x) file.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
Array of EffectInstance structures, one per attribute group in the mesh. An effect instance is a particular instance of state information used to initialize an effect.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • EffectDefault
  • EffectInstance
  • Mesh.SaveHierarchyToFile


Mesh.SaveHierarchyToFile(String,XFileFormat,Frame,AnimationController,SaveUserData) Method (Microsoft.DirectX.Direct3D)

Mesh.SaveHierarchyToFile Method

Creates a DirectX (.x) file and saves the mesh hierarchy and corresponding animations in it.

Definition

Visual Basic Public Shared Sub SaveHierarchyToFile( _
ByVal filename As String, _
ByVal format As XFileFormat, _
ByVal frameRoot As Frame, _
ByVal animationMixer As AnimationController, _
ByVal saveUserData As SaveUserData _
)
C# public static void SaveHierarchyToFile(
string filename,
XFileFormat format,
Frame frameRoot,
AnimationController animationMixer,
SaveUserData saveUserData
);
C++ public:
static void SaveHierarchyToFile(
String^ filename,
XFileFormat format,
Frame^ frameRoot,
AnimationController^ animationMixer,
SaveUserData^ saveUserData
);
JScript public static function SaveHierarchyToFile(
filename : String,
format : XFileFormat,
frameRoot : Frame,
animationMixer : AnimationController,
saveUserData : SaveUserData
);

Parameters

filename System.String
String that specifies the file name.
format Microsoft.DirectX.Direct3D.XFileFormat
An XFileFormat that indicates the format to use when saving the .x file. See Remarks.
frameRoot Microsoft.DirectX.Direct3D.Frame
Root node of the hierarchy to save. For more information, see Frame.
animationMixer Microsoft.DirectX.Direct3D.AnimationController
An AnimationController whose animation sets will be stored.
saveUserData Microsoft.DirectX.Direct3D.SaveUserData
Application-provided object that allows saving of user data. For more information, see SaveUserData.

Remarks

The default value for the file format is Binary. The Compressed file format can be combined (using a logical or) with either the Text or Binary flag to reduce the file size. If a file is specified with both Binary and text Text flags, it is saved as a text file.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Mesh.Save


Mesh.SetAttributeTable(AttributeRange[]) Method (Microsoft.DirectX.Direct3D)

Mesh.SetAttributeTable Method

Sets a mesh's attribute table and specifies the number of entries stored in it.

Definition

Visual Basic Public Sub SetAttributeTable( _
ByVal table() As AttributeRange _
)
C# public void SetAttributeTable(
AttributeRange[] table
);
C++ public:
void SetAttributeTable(
array<AttributeRange>^ table
);
JScript public function SetAttributeTable(
table : AttributeRange[]
);

Parameters

table Microsoft.DirectX.Direct3D.AttributeRange[]
Array of AttributeRange structures that represent the entries in the mesh attribute table.

Remarks

If an application tracks the information in an attribute table and rearranges the table as a result of changes to attributes or faces, the SetAttributeTable method allows the application to update the attribute tables instead of calling Optimize again.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • UnlockAttributeBuffer
  • LockAttributeBuffer


Mesh.Simplify Method ()

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Overload List

public static Mesh Simplify(Mesh, GraphicsStream, AttributeWeights, GraphicsStream, int, MeshFlags);
public static Mesh Simplify(Mesh, GraphicsStream, GraphicsStream, int, MeshFlags);
public static Mesh Simplify(Mesh, int[], AttributeWeights, int, MeshFlags);
public static Mesh Simplify(Mesh, int[], AttributeWeights, float[], int, MeshFlags);
public static Mesh Simplify(Mesh, int[], int, MeshFlags);
public static Mesh Simplify(Mesh, int[], float[], int, MeshFlags);

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,Int32[],Int32,MeshFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.Simplify Method

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
int[] adjacency,
int minValue,
MeshFlags options
);
C++ public:
static Mesh^ Simplify(
Mesh^ mesh,
array<int>^ adjacency,
int minValue,
MeshFlags options
);
JScript public static function Simplify(
mesh : Mesh,
adjacency : int[],
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
minValue System.Int32
Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,Int32[],Single[],Int32,MeshFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.Simplify Method

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexWeights() As Single, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
int[] adjacency,
float[] vertexWeights,
int minValue,
MeshFlags options
);
C++ public:
static Mesh^ Simplify(
Mesh^ mesh,
array<int>^ adjacency,
array<float>^ vertexWeights,
int minValue,
MeshFlags options
);
JScript public static function Simplify(
mesh : Mesh,
adjacency : int[],
vertexWeights : float[],
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexWeights System.Single[]
Array of vertex weights. If this parameter is set to 0, all vertex weights are set to 1.0.
minValue System.Int32
Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,Int32[],AttributeWeights,Int32,MeshFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.Simplify Method

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
int minValue,
MeshFlags options
);
C++ public:
static Mesh^ Simplify(
Mesh^ mesh,
array<int>^ adjacency,
AttributeWeights vertexAttributeWeights,
int minValue,
MeshFlags options
);
JScript public static function Simplify(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
minValue System.Int32
Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,Int32[],AttributeWeights,Single[],Int32,MeshFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.Simplify Method

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights() As Single, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
float[] vertexWeights,
int minValue,
MeshFlags options
);
C++ public:
static Mesh^ Simplify(
Mesh^ mesh,
array<int>^ adjacency,
AttributeWeights vertexAttributeWeights,
array<float>^ vertexWeights,
int minValue,
MeshFlags options
);
JScript public static function Simplify(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
vertexWeights : float[],
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights System.Single[]
Array of vertex weights. If this parameter is set to 0, all vertex weights are set to 1.0.
minValue System.Int32
Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,GraphicsStream,GraphicsStream,Int32,MeshFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.Simplify Method

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexWeights As GraphicsStream, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream vertexWeights,
int minValue,
MeshFlags options
);
C++ public:
static Mesh^ Simplify(
Mesh^ mesh,
GraphicsStream^ adjacency,
GraphicsStream^ vertexWeights,
int minValue,
MeshFlags options
);
JScript public static function Simplify(
mesh : Mesh,
adjacency : GraphicsStream,
vertexWeights : GraphicsStream,
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency Microsoft.DirectX.GraphicsStream
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexWeights Microsoft.DirectX.GraphicsStream
A GraphicsStream of vertex weights. If this parameter is set to 0, all vertex weights are set to 1.0.
minValue System.Int32
Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Simplify(Mesh,GraphicsStream,AttributeWeights,GraphicsStream,Int32,MeshFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.Simplify Method

Generates a simplified mesh using the provided weights that come as close as possible to the given minValue.

Definition

Visual Basic Public Shared Function Simplify( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights As GraphicsStream, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
) As Mesh
C# public static Mesh Simplify(
Mesh mesh,
GraphicsStream adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream vertexWeights,
int minValue,
MeshFlags options
);
C++ public:
static Mesh^ Simplify(
Mesh^ mesh,
GraphicsStream^ adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream^ vertexWeights,
int minValue,
MeshFlags options
);
JScript public static function Simplify(
mesh : Mesh,
adjacency : GraphicsStream,
vertexAttributeWeights : AttributeWeights,
vertexWeights : GraphicsStream,
minValue : int,
options : MeshFlags
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency Microsoft.DirectX.GraphicsStream
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights Microsoft.DirectX.GraphicsStream
A GraphicsStream of vertex weights. If this parameter is set to 0, all vertex weights are set to 1.0.
minValue System.Int32
Number of vertices or faces, depending on the flag set in the options parameter, by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh; can be one of the Simplify* flags in MeshFlags.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned simplification mesh.

Remarks

This method generates a mesh that has minValue vertices or faces.

If the simplification process cannot reduce the mesh to minValue, the call still succeeds, because minValue is a desired minimum, not an absolute minimum.

If vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use, because it considers only geometric and normal adjustment. Only in special cases will the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Sphere Method ()

Uses a left-handed coordinate system to create a mesh that contains a sphere.

Overload List

public static Mesh Sphere(Device, float, int, int);
public static Mesh Sphere(Device, float, int, int, out GraphicsStream);

Remarks

The created sphere is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Sphere(Device,Single,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.Sphere Method

Uses a left-handed coordinate system to create a mesh that contains a sphere.

Definition

Visual Basic Public Shared Function Sphere( _
ByVal device As Device, _
ByVal radius As Single, _
ByVal slices As Integer, _
ByVal stacks As Integer _
) As Mesh
C# public static Mesh Sphere(
Device device,
float radius,
int slices,
int stacks
);
C++ public:
static Mesh^ Sphere(
Device^ device,
float radius,
int slices,
int stacks
);
JScript public static function Sphere(
device : Device,
radius : float,
slices : int,
stacks : int
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created sphere mesh.
radius System.Single
Radius of the sphere. This value should be greater than or equal to 0.0f.
slices System.Int32
Number of slices around the main axis.
stacks System.Int32
Number of stacks along the main axis.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the sphere mesh.

Remarks

The created sphere is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Sphere(Device,Single,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Sphere Method

Uses a left-handed coordinate system to create a mesh that contains a sphere.

Definition

Visual Basic Public Shared Function Sphere( _
ByVal device As Device, _
ByVal radius As Single, _
ByVal slices As Integer, _
ByVal stacks As Integer, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Sphere(
Device device,
float radius,
int slices,
int stacks,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ Sphere(
Device^ device,
float radius,
int slices,
int stacks,
[Out] GraphicsStream^% adjacency
);
JScript public static function Sphere(
device : Device,
radius : float,
slices : int,
stacks : int,
adjacency : GraphicsStream
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created sphere mesh.
radius System.Single
Radius of the sphere. This value should be greater than or equal to 0.0f.
slices System.Int32
Number of slices around the main axis.
stacks System.Int32
Number of stacks along the main axis.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the sphere mesh.

Remarks

The created sphere is centered at the origin, and its axis is aligned with the z-axis.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus
  • Mesh.Teapot


Mesh.Split Method ()

Splits a mesh into multiple meshes that are smaller than the specified size.

Overload List

public static Mesh[] Split(Mesh, int[], int, MeshFlags);
public static Mesh[] Split(Mesh, int[], int, MeshFlags, out GraphicsStream, out GraphicsStream, out GraphicsStream);

Remarks

This method is commonly used to split a mesh with 32-bit indices (more than 65,535 vertices) into multiple meshes, each of which has 16-bit indices.

The param_GraphicsStreamR_adjacencyArrayOut, param_GraphicsStreamR_vertRemapArrayOut, and param_GraphicsStreamR_faceRemapArrayOut arrays have two dimensions. The first dimension specifies the mesh, and the second specifies the data. For example, to obtain the face remap information for face 3 in mesh 2, the following C# code could be used, assuming the face remap data is returned in a variable named faceRemapArrayOut.

[C#]
int remap = FaceRemapArrayOut[2][3];

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Split(Mesh,Int32[],Int32,MeshFlags) Method (Microsoft.DirectX.Direct3D)

Mesh.Split Method

Splits a mesh into multiple meshes that are smaller than the specified size.

Definition

Visual Basic Public Shared Function Split( _
ByVal mesh As Mesh, _
ByVal adjacencyIn() As Integer, _
ByVal maxSize As Integer, _
ByVal options As MeshFlags _
) As Mesh()
C# public static Mesh[] Split(
Mesh mesh,
int[] adjacencyIn,
int maxSize,
MeshFlags options
);
C++ public:
static array<Mesh^>^ Split(
Mesh^ mesh,
array<int>^ adjacencyIn,
int maxSize,
MeshFlags options
);
JScript public static function Split(
mesh : Mesh,
adjacencyIn : int[],
maxSize : int,
options : MeshFlags
) : Mesh[];

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
maxSize System.Int32
Maximum number of vertices in the resulting mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more of the Option* MeshFlags for the new meshes.

Return Value

Microsoft.DirectX.Direct3D.Mesh[]
Array of Mesh objects for the new meshes. For a source mesh split into n meshes, the ret_MeshA value is an array of n Mesh objects.

Remarks

This method is commonly used to split a mesh with 32-bit indices (more than 65,535 vertices) into multiple meshes, each of which has 16-bit indices.

The param_GraphicsStreamR_adjacencyArrayOut, param_GraphicsStreamR_vertRemapArrayOut, and param_GraphicsStreamR_faceRemapArrayOut arrays have two dimensions. The first dimension specifies the mesh, and the second specifies the data. For example, to obtain the face remap information for face 3 in mesh 2, the following C# code could be used, assuming the face remap data is returned in a variable named faceRemapArrayOut.

[C#]
int remap = FaceRemapArrayOut[2][3];

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Split(Mesh,Int32[],Int32,MeshFlags,GraphicsStream,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Split Method

Splits a mesh into multiple meshes that are smaller than the specified size.

Definition

Visual Basic Public Shared Function Split( _
ByVal mesh As Mesh, _
ByVal adjacencyIn() As Integer, _
ByVal maxSize As Integer, _
ByVal options As MeshFlags, _
ByRef adjacencyArrayOut As GraphicsStream, _
ByRef faceRemapArrayOut As GraphicsStream, _
ByRef vertRemapArrayOut As GraphicsStream _
) As Mesh()
C# public static Mesh[] Split(
Mesh mesh,
int[] adjacencyIn,
int maxSize,
MeshFlags options,
out GraphicsStream adjacencyArrayOut,
out GraphicsStream faceRemapArrayOut,
out GraphicsStream vertRemapArrayOut
);
C++ public:
static array<Mesh^>^ Split(
Mesh^ mesh,
array<int>^ adjacencyIn,
int maxSize,
MeshFlags options,
[Out] GraphicsStream^% adjacencyArrayOut,
[Out] GraphicsStream^% faceRemapArrayOut,
[Out] GraphicsStream^% vertRemapArrayOut
);
JScript public static function Split(
mesh : Mesh,
adjacencyIn : int[],
maxSize : int,
options : MeshFlags,
adjacencyArrayOut : GraphicsStream,
faceRemapArrayOut : GraphicsStream,
vertRemapArrayOut : GraphicsStream
) : Mesh[];

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be simplified.
maxSize System.Int32
Maximum number of vertices in the resulting mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more of the Option* MeshFlags for the new meshes.
adjacencyArrayOut Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains adjacency arrays (Int32 Leave Site values) for the new meshes.
faceRemapArrayOut Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains an array of face remap arrays (Int32 Leave Site values) for the new meshes.
vertRemapArrayOut Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains an array of vertex remap arrays for the new meshes.

Return Value

Microsoft.DirectX.Direct3D.Mesh[]
Array of Mesh objects for the new meshes. For a source mesh split into n meshes, the ret_MeshA value is an array of n Mesh objects.

Remarks

This method is commonly used to split a mesh with 32-bit indices (more than 65,535 vertices) into multiple meshes, each of which has 16-bit indices.

The param_GraphicsStreamR_adjacencyArrayOut, param_GraphicsStreamR_vertRemapArrayOut, and param_GraphicsStreamR_faceRemapArrayOut arrays have two dimensions. The first dimension specifies the mesh, and the second specifies the data. For example, to obtain the face remap information for face 3 in mesh 2, the following C# code could be used, assuming the face remap data is returned in a variable named faceRemapArrayOut.

[C#]
int remap = FaceRemapArrayOut[2][3];

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Teapot Method ()

Uses a left-handed coordinate system to create a mesh that contains a teapot.

Overload List

public static Mesh Teapot(Device);
public static Mesh Teapot(Device, out GraphicsStream);

Remarks

The created mesh is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus


Mesh.Teapot(Device) Method (Microsoft.DirectX.Direct3D)

Mesh.Teapot Method

Uses a left-handed coordinate system to create a mesh that contains a teapot.

Definition

Visual Basic Public Shared Function Teapot( _
ByVal device As Device _
) As Mesh
C# public static Mesh Teapot(
Device device
);
C++ public:
static Mesh^ Teapot(
Device^ device
);
JScript public static function Teapot(
device : Device
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created teapot mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the teapot mesh.

Remarks

The created mesh is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus


Mesh.Teapot(Device,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Teapot Method

Uses a left-handed coordinate system to create a mesh that contains a teapot.

Definition

Visual Basic Public Shared Function Teapot( _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Teapot(
Device device,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ Teapot(
Device^ device,
[Out] GraphicsStream^% adjacency
);
JScript public static function Teapot(
device : Device,
adjacency : GraphicsStream
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the created teapot mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing an array filled with three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the teapot mesh.

Remarks

The created mesh is centered at the origin.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Box
  • Mesh.TextFromFont
  • Mesh.Torus


Mesh.TessellateNPatches Method ()

Tessellates the given mesh using the N-patch tessellation scheme.

Overload List

public static Mesh TessellateNPatches(Mesh, GraphicsStream, float, bool);
public static Mesh TessellateNPatches(Mesh, GraphicsStream, float, bool, out GraphicsStream);
public static Mesh TessellateNPatches(Mesh, int[], float, bool);
public static Mesh TessellateNPatches(Mesh, int[], float, bool, out GraphicsStream);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.TessellateNPatches(Mesh,GraphicsStream,Single,Boolean) Method (Microsoft.DirectX.Direct3D)

Mesh.TessellateNPatches Method

Tessellates the given mesh using the N-patch tessellation scheme.

Definition

Visual Basic Public Shared Function TessellateNPatches( _
ByVal mesh As Mesh, _
ByVal adjacencyIn As GraphicsStream, _
ByVal numSegs As Single, _
ByVal quadraticInterpNormals As Boolean _
) As Mesh
C# public static Mesh TessellateNPatches(
Mesh mesh,
GraphicsStream adjacencyIn,
float numSegs,
bool quadraticInterpNormals
);
C++ public:
static Mesh^ TessellateNPatches(
Mesh^ mesh,
GraphicsStream^ adjacencyIn,
float numSegs,
bool quadraticInterpNormals
);
JScript public static function TessellateNPatches(
mesh : Mesh,
adjacencyIn : GraphicsStream,
numSegs : float,
quadraticInterpNormals : boolean
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to tessellate.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
numSegs System.Single
Number of segments per edge to tessellate.
quadraticInterpNormals System.Boolean
Set to true if quadratic interpolation for normals is used. Set to false if linear interpolation is used.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned tessellated mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.TessellateNPatches(Mesh,GraphicsStream,Single,Boolean,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.TessellateNPatches Method

Tessellates the given mesh using the N-patch tessellation scheme.

Definition

Visual Basic Public Shared Function TessellateNPatches( _
ByVal mesh As Mesh, _
ByVal adjacencyIn As GraphicsStream, _
ByVal numSegs As Single, _
ByVal quadraticInterpNormals As Boolean, _
ByRef adjacencyOut As GraphicsStream _
) As Mesh
C# public static Mesh TessellateNPatches(
Mesh mesh,
GraphicsStream adjacencyIn,
float numSegs,
bool quadraticInterpNormals,
out GraphicsStream adjacencyOut
);
C++ public:
static Mesh^ TessellateNPatches(
Mesh^ mesh,
GraphicsStream^ adjacencyIn,
float numSegs,
bool quadraticInterpNormals,
[Out] GraphicsStream^% adjacencyOut
);
JScript public static function TessellateNPatches(
mesh : Mesh,
adjacencyIn : GraphicsStream,
numSegs : float,
quadraticInterpNormals : boolean,
adjacencyOut : GraphicsStream
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to tessellate.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
numSegs System.Single
Number of segments per edge to tessellate.
quadraticInterpNormals System.Boolean
Set to true if quadratic interpolation for normals is used. Set to false if linear interpolation is used.
adjacencyOut Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned tessellated mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.TessellateNPatches(Mesh,Int32[],Single,Boolean) Method (Microsoft.DirectX.Direct3D)

Mesh.TessellateNPatches Method

Tessellates the given mesh using the N-patch tessellation scheme.

Definition

Visual Basic Public Shared Function TessellateNPatches( _
ByVal mesh As Mesh, _
ByVal adjacencyIn() As Integer, _
ByVal numSegs As Single, _
ByVal quadraticInterpNormals As Boolean _
) As Mesh
C# public static Mesh TessellateNPatches(
Mesh mesh,
int[] adjacencyIn,
float numSegs,
bool quadraticInterpNormals
);
C++ public:
static Mesh^ TessellateNPatches(
Mesh^ mesh,
array<int>^ adjacencyIn,
float numSegs,
bool quadraticInterpNormals
);
JScript public static function TessellateNPatches(
mesh : Mesh,
adjacencyIn : int[],
numSegs : float,
quadraticInterpNormals : boolean
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to tessellate.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
numSegs System.Single
Number of segments per edge to tessellate.
quadraticInterpNormals System.Boolean
Set to true if quadratic interpolation for normals is used. Set to false if linear interpolation is used.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned tessellated mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.TessellateNPatches(Mesh,Int32[],Single,Boolean,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.TessellateNPatches Method

Tessellates the given mesh using the N-patch tessellation scheme.

Definition

Visual Basic Public Shared Function TessellateNPatches( _
ByVal mesh As Mesh, _
ByVal adjacencyIn() As Integer, _
ByVal numSegs As Single, _
ByVal quadraticInterpNormals As Boolean, _
ByRef adjacencyOut As GraphicsStream _
) As Mesh
C# public static Mesh TessellateNPatches(
Mesh mesh,
int[] adjacencyIn,
float numSegs,
bool quadraticInterpNormals,
out GraphicsStream adjacencyOut
);
C++ public:
static Mesh^ TessellateNPatches(
Mesh^ mesh,
array<int>^ adjacencyIn,
float numSegs,
bool quadraticInterpNormals,
[Out] GraphicsStream^% adjacencyOut
);
JScript public static function TessellateNPatches(
mesh : Mesh,
adjacencyIn : int[],
numSegs : float,
quadraticInterpNormals : boolean,
adjacencyOut : GraphicsStream
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to tessellate.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
numSegs System.Single
Number of segments per edge to tessellate.
quadraticInterpNormals System.Boolean
Set to true if quadratic interpolation for normals is used. Set to false if linear interpolation is used.
adjacencyOut Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the returned tessellated mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.TextFromFont Method ()

Creates a mesh that contains the specified text, using a .NET font object.

Overload List

public static Mesh TextFromFont(Device, Font, string, float, float);
public static Mesh TextFromFont(Device, Font, string, float, float, out GlyphMetricsFloat);
public static Mesh TextFromFont(Device, Font, string, float, float, out GraphicsStream);
public static Mesh TextFromFont(Device, Font, string, float, float, out GraphicsStream, out GlyphMetricsFloat);

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.TextFromFont(Device,Font,String,Single,Single) Method (Microsoft.DirectX.Direct3D)

Mesh.TextFromFont Method

Creates a mesh that contains the specified text, using a .NET font object.

Definition

Visual Basic Public Shared Function TextFromFont( _
ByVal device As Device, _
ByVal font As Font, _
ByVal text As String, _
ByVal deviation As Single, _
ByVal extrusion As Single _
) As Mesh
C# public static Mesh TextFromFont(
Device device,
Font font,
string text,
float deviation,
float extrusion
);
C++ public:
static Mesh^ TextFromFont(
Device^ device,
Font^ font,
String^ text,
float deviation,
float extrusion
);
JScript public static function TextFromFont(
device : Device,
font : Font,
text : String,
deviation : float,
extrusion : float
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the text mesh.
font System.Drawing.Font
A Font Leave Site object that creates the mesh.
text System.String
String that specifies the text to generate.
deviation System.Single
Maximum chordal deviation from font outlines.
extrusion System.Single
Amount to extrude text in the negative z-direction.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the cylinder mesh.

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.TextFromFont(Device,Font,String,Single,Single,GlyphMetricsFloat) Method (Microsoft.DirectX.Direct3D)

Mesh.TextFromFont Method

Creates a mesh that contains the specified text, using a .NET font object.

Definition

Visual Basic Public Shared Function TextFromFont( _
ByVal device As Device, _
ByVal font As Font, _
ByVal text As String, _
ByVal deviation As Single, _
ByVal extrusion As Single, _
ByRef glyphMetrics As GlyphMetricsFloat _
) As Mesh
C# public static Mesh TextFromFont(
Device device,
Font font,
string text,
float deviation,
float extrusion,
out GlyphMetricsFloat glyphMetrics
);
C++ public:
static Mesh^ TextFromFont(
Device^ device,
Font^ font,
String^ text,
float deviation,
float extrusion,
[Out] GlyphMetricsFloat% glyphMetrics
);
JScript public static function TextFromFont(
device : Device,
font : Font,
text : String,
deviation : float,
extrusion : float,
glyphMetrics : GlyphMetricsFloat
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the text mesh.
font System.Drawing.Font
A Font Leave Site object that creates the mesh.
text System.String
String that specifies the text to generate.
deviation System.Single
Maximum chordal deviation from font outlines.
extrusion System.Single
Amount to extrude text in the negative z-direction.
glyphMetrics Microsoft.DirectX.Direct3D.GlyphMetricsFloat[]
Array of GlyphMetricsFloat structures that contain the glyph metric data. See Remarks. If glyph sizes are not a concern, this parameter can be omitted.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the cylinder mesh.

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.TextFromFont(Device,Font,String,Single,Single,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.TextFromFont Method

Creates a mesh that contains the specified text, using a .NET font object.

Definition

Visual Basic Public Shared Function TextFromFont( _
ByVal device As Device, _
ByVal font As Font, _
ByVal text As String, _
ByVal deviation As Single, _
ByVal extrusion As Single, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh TextFromFont(
Device device,
Font font,
string text,
float deviation,
float extrusion,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ TextFromFont(
Device^ device,
Font^ font,
String^ text,
float deviation,
float extrusion,
[Out] GraphicsStream^% adjacency
);
JScript public static function TextFromFont(
device : Device,
font : Font,
text : String,
deviation : float,
extrusion : float,
adjacency : GraphicsStream
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the text mesh.
font System.Drawing.Font
A Font Leave Site object that creates the mesh.
text System.String
String that specifies the text to generate.
deviation System.Single
Maximum chordal deviation from font outlines.
extrusion System.Single
Amount to extrude text in the negative z-direction.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the cylinder mesh.

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.TextFromFont(Device,Font,String,Single,Single,GraphicsStream,GlyphMetricsFloat) Method (Microsoft.DirectX.Direct3D)

Mesh.TextFromFont Method

Creates a mesh that contains the specified text, using a .NET font object.

Definition

Visual Basic Public Shared Function TextFromFont( _
ByVal device As Device, _
ByVal font As Font, _
ByVal text As String, _
ByVal deviation As Single, _
ByVal extrusion As Single, _
ByRef adjacency As GraphicsStream, _
ByRef glyphMetrics As GlyphMetricsFloat _
) As Mesh
C# public static Mesh TextFromFont(
Device device,
Font font,
string text,
float deviation,
float extrusion,
out GraphicsStream adjacency,
out GlyphMetricsFloat glyphMetrics
);
C++ public:
static Mesh^ TextFromFont(
Device^ device,
Font^ font,
String^ text,
float deviation,
float extrusion,
[Out] GraphicsStream^% adjacency,
[Out] GlyphMetricsFloat% glyphMetrics
);
JScript public static function TextFromFont(
device : Device,
font : Font,
text : String,
deviation : float,
extrusion : float,
adjacency : GraphicsStream,
glyphMetrics : GlyphMetricsFloat
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the text mesh.
font System.Drawing.Font
A Font Leave Site object that creates the mesh.
text System.String
String that specifies the text to generate.
deviation System.Single
Maximum chordal deviation from font outlines.
extrusion System.Single
Amount to extrude text in the negative z-direction.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
glyphMetrics Microsoft.DirectX.Direct3D.GlyphMetricsFloat[]
Array of GlyphMetricsFloat structures that contain the glyph metric data. See Remarks. If glyph sizes are not a concern, this parameter can be omitted.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the cylinder mesh.

Remarks

Each element contains information about the position and orientation of the corresponding glyph in the string. The number of elements in the array should be equal to the number of characters in the string. Note that the origin in each structure is not relative to the entire string, but rather is relative to that character cell. To compute the entire bounding box, add the increment for each glyph while traversing the string.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.Torus


Mesh.Torus Method ()

Uses a left-handed coordinate system to create a mesh that contains a torus.

Overload List

public static Mesh Torus(Device, float, float, int, int);
public static Mesh Torus(Device, float, float, int, int, out GraphicsStream);

Remarks

The Mesh.Torus method draws a doughnut shape, centered at (0, 0, 0), whose axis is aligned with the z-axis. The inner radius of the torus is the radius of the cross section (the minor radius), and the outer radius of the torus is the radius of the central hole.

The mesh that this method returns can later be used by the application for drawing or manipulation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont


Mesh.Torus(Device,Single,Single,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

Mesh.Torus Method

Uses a left-handed coordinate system to create a mesh that contains a torus.

Definition

Visual Basic Public Shared Function Torus( _
ByVal device As Device, _
ByVal innerRadius As Single, _
ByVal outerRadius As Single, _
ByVal sides As Integer, _
ByVal rings As Integer _
) As Mesh
C# public static Mesh Torus(
Device device,
float innerRadius,
float outerRadius,
int sides,
int rings
);
C++ public:
static Mesh^ Torus(
Device^ device,
float innerRadius,
float outerRadius,
int sides,
int rings
);
JScript public static function Torus(
device : Device,
innerRadius : float,
outerRadius : float,
sides : int,
rings : int
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the text mesh.
innerRadius System.Single
Inner radius of the torus; should be greater than or equal to 0.0f.
outerRadius System.Single
Outer radius of the torus; should be greater than or equal to 0.0f.
sides System.Int32
Number of sides in a cross section; must be greater than or equal to 3.
rings System.Int32
Number of rings in the torus; must be greater than or equal to 3.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the torus mesh.

Remarks

The Mesh.Torus method draws a doughnut shape, centered at (0, 0, 0), whose axis is aligned with the z-axis. The inner radius of the torus is the radius of the cross section (the minor radius), and the outer radius of the torus is the radius of the central hole.

The mesh that this method returns can later be used by the application for drawing or manipulation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont


Mesh.Torus(Device,Single,Single,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Torus Method

Uses a left-handed coordinate system to create a mesh that contains a torus.

Definition

Visual Basic Public Shared Function Torus( _
ByVal device As Device, _
ByVal innerRadius As Single, _
ByVal outerRadius As Single, _
ByVal sides As Integer, _
ByVal rings As Integer, _
ByRef adjacency As GraphicsStream _
) As Mesh
C# public static Mesh Torus(
Device device,
float innerRadius,
float outerRadius,
int sides,
int rings,
out GraphicsStream adjacency
);
C++ public:
static Mesh^ Torus(
Device^ device,
float innerRadius,
float outerRadius,
int sides,
int rings,
[Out] GraphicsStream^% adjacency
);
JScript public static function Torus(
device : Device,
innerRadius : float,
outerRadius : float,
sides : int,
rings : int,
adjacency : GraphicsStream
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device associated with the text mesh.
innerRadius System.Single
Inner radius of the torus; should be greater than or equal to 0.0f.
outerRadius System.Single
Outer radius of the torus; should be greater than or equal to 0.0f.
sides System.Int32
Number of sides in a cross section; must be greater than or equal to 3.
rings System.Int32
Number of rings in the torus; must be greater than or equal to 3.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the torus mesh.

Remarks

The Mesh.Torus method draws a doughnut shape, centered at (0, 0, 0), whose axis is aligned with the z-axis. The inner radius of the torus is the radius of the cross section (the minor radius), and the outer radius of the torus is the radius of the central hole.

The mesh that this method returns can later be used by the application for drawing or manipulation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Mesh.Polygon
  • Mesh.Cylinder
  • Mesh.Sphere
  • Mesh.Teapot
  • Mesh.Box
  • Mesh.TextFromFont


Mesh.UnlockAttributeBuffer Method ()

Unlocks an attribute buffer.

Overload List

public void UnlockAttributeBuffer();
public void UnlockAttributeBuffer(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
ArgumentException Leave Site | The buffer must be locked before it is unlocked.

See Also

  • SetAttributeTable
  • LockAttributeBuffer


Mesh.UnlockAttributeBuffer() Method (Microsoft.DirectX.Direct3D)

Mesh.UnlockAttributeBuffer Method

Unlocks an attribute buffer.

Definition

Visual Basic | Public Sub UnlockAttributeBuffer()
C# | public void UnlockAttributeBuffer();
C++ public:
void UnlockAttributeBuffer();
JScript | public function UnlockAttributeBuffer();

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
ArgumentException Leave Site | The buffer must be locked before it is unlocked.

See Also

  • SetAttributeTable
  • LockAttributeBuffer


Mesh.UnlockAttributeBuffer(Int32[]) Method (Microsoft.DirectX.Direct3D)

Mesh.UnlockAttributeBuffer Method

Unlocks an attribute buffer.

Definition

Visual Basic Public Sub UnlockAttributeBuffer( _
ByVal dataAttribute() As Integer _
)
C# public void UnlockAttributeBuffer(
int[] dataAttribute
);
C++ public:
void UnlockAttributeBuffer(
array<int>^ dataAttribute
);
JScript public function UnlockAttributeBuffer(
dataAttribute : int[]
);

Parameters

dataAttribute System.Int32[]
Array of pointers that represents the attribute buffer to unlock.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
ArgumentException Leave Site | The buffer must be locked before it is unlocked.

See Also

  • SetAttributeTable
  • LockAttributeBuffer


Mesh.UpdateUnmanagedPointer(ID3DXMesh) Method (Microsoft.DirectX.Direct3D)

Mesh.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Mesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXMesh pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXMesh pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXMesh
Pointer to the ID3DXMesh structure used to update the unmanaged pointer for this Mesh object.


Mesh.Validate Method ()

Validates a mesh.

Overload List

public void Validate(GraphicsStream);
public void Validate(GraphicsStream, out string);
public void Validate(int[]);
public void Validate(int[], out string);

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Validate(Int32[]) Method (Microsoft.DirectX.Direct3D)

Mesh.Validate Method

Validates a mesh.

Definition

Visual Basic Public Sub Validate( _
ByVal adjacency() As Integer _
)
C# public void Validate(
int[] adjacency
);
C++ public:
void Validate(
array<int>^ adjacency
);
JScript public function Validate(
adjacency : int[]
);

Parameters

adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be tested.

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Validate(Int32[],String) Method (Microsoft.DirectX.Direct3D)

Mesh.Validate Method

Validates a mesh.

Definition

Visual Basic Public Sub Validate( _
ByVal adjacency() As Integer, _
ByRef errorsAndWarnings As String _
)
C# public void Validate(
int[] adjacency,
out string errorsAndWarnings
);
C++ public:
void Validate(
array<int>^ adjacency,
[Out] String^% errorsAndWarnings
);
JScript public function Validate(
adjacency : int[],
errorsAndWarnings : String
);

Parameters

adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be tested.
errorsAndWarnings System.String
Returns a buffer that contains a string of errors and warnings, which explain the problems found in the mesh.

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Validate(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.Validate Method

Validates a mesh.

Definition

Visual Basic Public Sub Validate( _
ByVal adjacency As GraphicsStream _
)
C# public void Validate(
GraphicsStream adjacency
);
C++ public:
void Validate(
GraphicsStream^ adjacency
);
JScript public function Validate(
adjacency : GraphicsStream
);

Parameters

adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be tested.

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Validate(GraphicsStream,String) Method (Microsoft.DirectX.Direct3D)

Mesh.Validate Method

Validates a mesh.

Definition

Visual Basic Public Sub Validate( _
ByVal adjacency As GraphicsStream, _
ByRef errorsAndWarnings As String _
)
C# public void Validate(
GraphicsStream adjacency,
out string errorsAndWarnings
);
C++ public:
void Validate(
GraphicsStream^ adjacency,
[Out] String^% errorsAndWarnings
);
JScript public function Validate(
adjacency : GraphicsStream,
errorsAndWarnings : String
);

Parameters

adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh to be tested.
errorsAndWarnings System.String
Returns a buffer that contains a string of errors and warnings, which explain the problems found in the mesh.

Remarks

This method validates the mesh by checking for invalid indices. Error information is available in the debug output.

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.WeldVertices Method ()

Welds together replicated vertices that have equal attributes.

Overload List

public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, GraphicsStream, out GraphicsStream);
public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, GraphicsStream, out GraphicsStream, out int, out GraphicsStream);
public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, int[]);
public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, int[], out GraphicsStream);
public void WeldVertices(WeldEpsilonsFlags, WeldEpsilons, int[], out int, out int, out GraphicsStream);

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,Int32[],GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.WeldVertices Method

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn() As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int[] adjacencyIn,
out GraphicsStream vertexRemap
);
C++ public:
void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
array<int>^ adjacencyIn,
[Out] GraphicsStream^% vertexRemap
);
JScript public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : int[],
vertexRemap : GraphicsStream
);

Parameters

flags Microsoft.DirectX.Direct3D.WeldEpsilonsFlags
One or more flags from WeldEpsilonsFlags.
epsilons Microsoft.DirectX.Direct3D.WeldEpsilons
A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the new index for each vertex.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,Int32[]) Method (Microsoft.DirectX.Direct3D)

Mesh.WeldVertices Method

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn() As Integer _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int[] adjacencyIn
);
C++ public:
void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
array<int>^ adjacencyIn
);
JScript public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : int[]
);

Parameters

flags Microsoft.DirectX.Direct3D.WeldEpsilonsFlags
One or more flags from WeldEpsilonsFlags.
epsilons Microsoft.DirectX.Direct3D.WeldEpsilons
A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,Int32[],Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.WeldVertices Method

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn() As Integer, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
int[] adjacencyIn,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
array<int>^ adjacencyIn,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : int[],
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
);

Parameters

flags Microsoft.DirectX.Direct3D.WeldEpsilonsFlags
One or more flags from WeldEpsilonsFlags.
epsilons Microsoft.DirectX.Direct3D.WeldEpsilons
A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.
adjacencyOut System.Int32[]
[in, out] Face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh.
faceRemap System.Int32[]
Array that contains the new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the new index for each vertex.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.WeldVertices Method

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn As GraphicsStream, _
ByVal adjacencyOut As GraphicsStream _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
GraphicsStream adjacencyIn,
out GraphicsStream adjacencyOut
);
C++ public:
void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
GraphicsStream^ adjacencyIn,
[Out] GraphicsStream^ adjacencyOut
);
JScript public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : GraphicsStream,
adjacencyOut : GraphicsStream
);

Parameters

flags Microsoft.DirectX.Direct3D.WeldEpsilonsFlags
One or more flags from WeldEpsilonsFlags.
epsilons Microsoft.DirectX.Direct3D.WeldEpsilons
A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.
adjacencyOut Microsoft.DirectX.GraphicsStream
[in, out] A GraphicsStream that contains the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outer array is one set of face adjacencies per triangle in the mesh.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.WeldVertices(WeldEpsilonsFlags,WeldEpsilons,GraphicsStream,GraphicsStream,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

Mesh.WeldVertices Method

Welds together replicated vertices that have equal attributes.

Definition

Visual Basic Public Sub WeldVertices( _
ByVal flags As WeldEpsilonsFlags, _
ByVal epsilons As WeldEpsilons, _
ByVal adjacencyIn As GraphicsStream, _
ByVal adjacencyOut As GraphicsStream, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
)
C# public void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
GraphicsStream adjacencyIn,
out GraphicsStream adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
void WeldVertices(
WeldEpsilonsFlags flags,
WeldEpsilons epsilons,
GraphicsStream^ adjacencyIn,
[Out] GraphicsStream^ adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function WeldVertices(
flags : WeldEpsilonsFlags,
epsilons : WeldEpsilons,
adjacencyIn : GraphicsStream,
adjacencyOut : GraphicsStream,
faceRemap : int,
vertexRemap : GraphicsStream
);

Parameters

flags Microsoft.DirectX.Direct3D.WeldEpsilonsFlags
One or more flags from WeldEpsilonsFlags.
epsilons Microsoft.DirectX.Direct3D.WeldEpsilons
A WeldEpsilons structure that specifies the epsilon values to use for this method.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh. If the edge has no adjacent faces, the value is 0. If this parameter is omitted, BaseMesh.GenerateAdjacency is called to create logical adjacency information.
adjacencyOut Microsoft.DirectX.GraphicsStream
[in, out] A GraphicsStream that contains the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outer array is one set of face adjacencies per triangle in the mesh.
faceRemap System.Int32[]
Array that contains the new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the new index for each vertex.

Remarks

This method compares logically-welded vertices and combines those with similar components, such as normals or texture coordinates within param_WeldEpsilons_epsilons. It uses the provided adjacency information to determine which points are replicated, and performs an epsilon comparison to merge vertices. Those vertices with equal positions must already have been calculated and represented by point-representative data.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


Mesh.Disposed Property (Microsoft.DirectX.Direct3D)

Mesh.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public Shadows ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Mesh.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Mesh.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXMesh interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As ID3DXMesh
C# | public ID3DXMesh UnmanagedComPointer { get; }
C++ public:
property ID3DXMesh UnmanagedComPointer {
ID3DXMesh get();
}
JScript | public function get UnmanagedComPointer() : ID3DXMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXMesh
Unmanaged ID3DXMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Mesh.Disposing Event (Microsoft.DirectX.Direct3D)

Mesh.Disposing Event

Occurs when the Dispose method is called or when the Mesh object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Mesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Mesh object indicates whether that object has been disposed.


MeshContainer Class (Microsoft.DirectX.Direct3D)

MeshContainer Class

Encapsulates a mesh object in a transformation frame hierarchy.

Definition

Visual Basic MustInherit Public Class MeshContainer
Inherits Object
C# | public abstract class MeshContainer : Object
C++ | public ref class MeshContainer abstract : Object
JScript | public abstract class MeshContainer extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Finalize | Allows the MeshContainer object to free resources before it is destroyed by the garbage collector.
GetAdjacency | Retrieves an array that contains the mesh adjacency information.
GetAdjacencyStream | Retrieves a GraphicsStream object that contains the mesh adjacency information.
GetEffectInstances | Retrieves an array of EffectInstance objects that contain the effects for the mesh.
GetMaterials | Retrieves an array of mesh materials.
MeshContainer | Initializes a new instance of the MeshContainer class.
SetAdjacency | Sets the mesh adjacency information.
SetEffectInstances | Sets an array of EffectInstance objects that contain the effects for the mesh.
SetMaterials | Sets an array of mesh materials.

Properties

Property | Description
MeshData | Retrieves or sets a MeshData object that contains the type of data in the mesh.
Name | Retrieves or sets the mesh name.
NextContainer | Retrieves the next mesh container.
SkinInformation | Retrieves or sets a SkinInformation object that contains information about animating bones in a skin mesh.

Inheritance Hierarchy

Object Leave Site
MeshContainer

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MeshContainer.Finalize() Method (Microsoft.DirectX.Direct3D)

MeshContainer.Finalize Method

Allows the MeshContainer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~MeshContainer();
C++ | !MeshContainer();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


MeshContainer.GetAdjacency() Method (Microsoft.DirectX.Direct3D)

MeshContainer.GetAdjacency Method

Retrieves an array that contains the mesh adjacency information.

Definition

Visual Basic | Public Function GetAdjacency() As Integer()
C# | public int[] GetAdjacency();
C++ public:
array<int>^ GetAdjacency();
JScript | public function GetAdjacency() : int[];

Return Value

System.Int32[]
Array of integers that represent the adjacency information.

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outermost array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.


MeshContainer.GetAdjacencyStream() Method (Microsoft.DirectX.Direct3D)

MeshContainer.GetAdjacencyStream Method

Retrieves a GraphicsStream object that contains the mesh adjacency information.

Definition

Visual Basic | Public Function GetAdjacencyStream() As GraphicsStream
C# | public GraphicsStream GetAdjacencyStream();
C++ public:
GraphicsStream^ GetAdjacencyStream();
JScript | public function GetAdjacencyStream() : GraphicsStream;

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the adjacency information.

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outer array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.


MeshContainer.GetEffectInstances() Method (Microsoft.DirectX.Direct3D)

MeshContainer.GetEffectInstances Method

Retrieves an array of EffectInstance objects that contain the effects for the mesh.

Definition

Visual Basic | Public Function GetEffectInstances() As EffectInstance()
C# | public EffectInstance[] GetEffectInstances();
C++ public:
array<EffectInstance>^ GetEffectInstances();
JScript | public function GetEffectInstances() : EffectInstance[];

Return Value

Microsoft.DirectX.Direct3D.EffectInstance[]
Returns an array of EffectInstance objects.


MeshContainer.GetMaterials() Method (Microsoft.DirectX.Direct3D)

MeshContainer.GetMaterials Method

Retrieves an array of mesh materials.

Definition

Visual Basic | Public Function GetMaterials() As ExtendedMaterial()
C# | public ExtendedMaterial[] GetMaterials();
C++ public:
array<ExtendedMaterial>^ GetMaterials();
JScript | public function GetMaterials() : ExtendedMaterial[];

Return Value

Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial objects that contain the mesh materials.


MeshContainer.MeshContainer() Constructor (Microsoft.DirectX.Direct3D)

MeshContainer.MeshContainer Constructor

Initializes a new instance of the MeshContainer class.

Definition

Visual Basic | Public Sub New()
C# | public MeshContainer();
C++ public:
MeshContainer();
JScript | public function MeshContainer();


MeshContainer.SetAdjacency Method ()

Sets the mesh adjacency information.

Overload List

public void SetAdjacency(GraphicsStream);
public void SetAdjacency(int[]);

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outermost array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.

Exceptions
OutOfMemoryException Leave Site Microsoft Direct3D could not allocate sufficient memory to complete the call.


MeshContainer.SetAdjacency(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

MeshContainer.SetAdjacency Method

Sets the mesh adjacency information.

Definition

Visual Basic Public Sub SetAdjacency( _
ByVal adj As GraphicsStream _
)
C# public void SetAdjacency(
GraphicsStream adj
);
C++ public:
void SetAdjacency(
GraphicsStream^ adj
);
JScript public function SetAdjacency(
adj : GraphicsStream
);

Parameters

adj Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the adjacency information.

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outermost array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.

Exceptions
OutOfMemoryException Leave Site Microsoft Direct3D could not allocate sufficient memory to complete the call.


MeshContainer.SetAdjacency(Int32[]) Method (Microsoft.DirectX.Direct3D)

MeshContainer.SetAdjacency Method

Sets the mesh adjacency information.

Definition

Visual Basic Public Sub SetAdjacency( _
ByVal adj() As Integer _
)
C# public void SetAdjacency(
int[] adj
);
C++ public:
void SetAdjacency(
array<int>^ adj
);
JScript public function SetAdjacency(
adj : int[]
);

Parameters

adj System.Int32[]
Array of integers that represent the adjacency information.

Remarks

The size of the adjacency array is the maximum number of faces multiplied by 3.

The face adjacency is stored as an array of arrays. The innermost array contains three indices of adjacent triangles, and the outermost array contains one face adjacency set per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff.

Exceptions
OutOfMemoryException Leave Site Microsoft Direct3D could not allocate sufficient memory to complete the call.


MeshContainer.SetEffectInstances(EffectInstance[]) Method (Microsoft.DirectX.Direct3D)

MeshContainer.SetEffectInstances Method

Sets an array of EffectInstance objects that contain the effects for the mesh.

Definition

Visual Basic Public Sub SetEffectInstances( _
ByVal effects() As EffectInstance _
)
C# public void SetEffectInstances(
EffectInstance[] effects
);
C++ public:
void SetEffectInstances(
array<EffectInstance>^ effects
);
JScript public function SetEffectInstances(
effects : EffectInstance[]
);

Parameters

effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance objects.


MeshContainer.SetMaterials(ExtendedMaterial[]) Method (Microsoft.DirectX.Direct3D)

MeshContainer.SetMaterials Method

Sets an array of mesh materials.

Definition

Visual Basic Public Sub SetMaterials( _
ByVal mtrl() As ExtendedMaterial _
)
C# public void SetMaterials(
ExtendedMaterial[] mtrl
);
C++ public:
void SetMaterials(
array<ExtendedMaterial>^ mtrl
);
JScript public function SetMaterials(
mtrl : ExtendedMaterial[]
);

Parameters

mtrl Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial objects that contain the mesh materials to set.

Remarks

Exceptions
OutOfMemoryException Leave Site Microsoft Direct3D could not allocate sufficient memory to complete the call.


MeshContainer.MeshData Property (Microsoft.DirectX.Direct3D)

MeshContainer.MeshData Property

Retrieves or sets a MeshData object that contains the type of data in the mesh.

Definition

Visual Basic | Public Property MeshData As MeshData
C# | public MeshData MeshData { get; set; }
C++ public:
property MeshData MeshData {
MeshData get();
void set(MeshData value);
}
JScript public function get MeshData() : MeshData
public function set MeshData(MeshData);

Property Value

Microsoft.DirectX.Direct3D.MeshData
A MeshData object that represents the type of mesh data.

This property is read/write.


MeshContainer.Name Property (Microsoft.DirectX.Direct3D)

MeshContainer.Name Property

Retrieves or sets the mesh name.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String
String that contains the name of the mesh.

This property is read/write.


MeshContainer.NextContainer Property (Microsoft.DirectX.Direct3D)

MeshContainer.NextContainer Property

Retrieves the next mesh container.

Definition

Visual Basic | Public ReadOnly Property NextContainer As MeshContainer
C# | public MeshContainer NextContainer { get; }
C++ public:
property MeshContainer^ NextContainer {
MeshContainer^ get();
}
JScript | public function get NextContainer() : MeshContainer

Property Value

Microsoft.DirectX.Direct3D.MeshContainer
A MeshContainer object to retrieve.

This property is read-only.


MeshContainer.SkinInformation Property (Microsoft.DirectX.Direct3D)

MeshContainer.SkinInformation Property

Retrieves or sets a SkinInformation object that contains information about animating bones in a skin mesh.

Definition

Visual Basic | Public Property SkinInformation As SkinInformation
C# | public SkinInformation SkinInformation { get; set; }
C++ public:
property SkinInformation^ SkinInformation {
SkinInformation^ get();
void set(SkinInformation^ value);
}
JScript public function get SkinInformation() : SkinInformation
public function set SkinInformation(SkinInformation);

Property Value

Microsoft.DirectX.Direct3D.SkinInformation
A SkinInformation object.

This property is read/write.


MoreDataException Class (Microsoft.DirectX.Direct3D)

MoreDataException Class

More data is available than the specified buffer size can hold.

Definition

Visual Basic Public Class MoreDataException
Inherits GraphicsException
C# | public class MoreDataException : GraphicsException
C++ | public ref class MoreDataException : GraphicsException
JScript | public class MoreDataException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
MoreDataException | Initializes a new instance of the MoreDataException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
MoreDataException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MoreDataException.MoreDataException Constructor ()

Initializes a new instance of the MoreDataException class.

Overload List

public MoreDataException();
protected MoreDataException(SerializationInfo, StreamingContext);
public MoreDataException(string);
public MoreDataException(string, Exception);


MoreDataException.MoreDataException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

MoreDataException.MoreDataException Constructor

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected MoreDataException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
MoreDataException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function MoreDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


MoreDataException.MoreDataException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

MoreDataException.MoreDataException Constructor

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public MoreDataException(
string message,
Exception inner
);
C++ public:
MoreDataException(
String^ message,
Exception^ inner
);
JScript public function MoreDataException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


MoreDataException.MoreDataException(String) Constructor (Microsoft.DirectX.Direct3D)

MoreDataException.MoreDataException Constructor

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public MoreDataException(
string message
);
C++ public:
MoreDataException(
String^ message
);
JScript public function MoreDataException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


MoreDataException.MoreDataException() Constructor (Microsoft.DirectX.Direct3D)

MoreDataException.MoreDataException Constructor

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic | Public Sub New()
C# | public MoreDataException();
C++ public:
MoreDataException();
JScript | public function MoreDataException();


NotAvailableException Class (Microsoft.DirectX.Direct3D)

NotAvailableException Class

This device does not support the queried technique.

Definition

Visual Basic Public Class NotAvailableException
Inherits GraphicsException
C# | public class NotAvailableException : GraphicsException
C++ | public ref class NotAvailableException : GraphicsException
JScript | public class NotAvailableException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAvailableException | Initializes a new instance of the NotAvailableException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotAvailableException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotAvailableException.NotAvailableException Constructor ()

Initializes a new instance of the NotAvailableException class.

Overload List

public NotAvailableException();
protected NotAvailableException(SerializationInfo, StreamingContext);
public NotAvailableException(string);
public NotAvailableException(string, Exception);


NotAvailableException.NotAvailableException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

NotAvailableException.NotAvailableException Constructor

Initializes a new instance of the NotAvailableException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAvailableException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotAvailableException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotAvailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


NotAvailableException.NotAvailableException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

NotAvailableException.NotAvailableException Constructor

Initializes a new instance of the NotAvailableException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAvailableException(
string message,
Exception inner
);
C++ public:
NotAvailableException(
String^ message,
Exception^ inner
);
JScript public function NotAvailableException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


NotAvailableException.NotAvailableException(String) Constructor (Microsoft.DirectX.Direct3D)

NotAvailableException.NotAvailableException Constructor

Initializes a new instance of the NotAvailableException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotAvailableException(
string message
);
C++ public:
NotAvailableException(
String^ message
);
JScript public function NotAvailableException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


NotAvailableException.NotAvailableException() Constructor (Microsoft.DirectX.Direct3D)

NotAvailableException.NotAvailableException Constructor

Initializes a new instance of the NotAvailableException class.

Definition

Visual Basic | Public Sub New()
C# | public NotAvailableException();
C++ public:
NotAvailableException();
JScript | public function NotAvailableException();


NotFoundException Class (Microsoft.DirectX.Direct3D)

NotFoundException Class

The requested item was not found.

Definition

Visual Basic Public Class NotFoundException
Inherits GraphicsException
C# | public class NotFoundException : GraphicsException
C++ | public ref class NotFoundException : GraphicsException
JScript | public class NotFoundException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotFoundException | Initializes a new instance of the NotFoundException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotFoundException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotFoundException.NotFoundException Constructor ()

Initializes a new instance of the NotFoundException class.

Overload List

public NotFoundException();
protected NotFoundException(SerializationInfo, StreamingContext);
public NotFoundException(string);
public NotFoundException(string, Exception);


NotFoundException.NotFoundException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

NotFoundException.NotFoundException Constructor

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotFoundException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotFoundException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotFoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


NotFoundException.NotFoundException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

NotFoundException.NotFoundException Constructor

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotFoundException(
string message,
Exception inner
);
C++ public:
NotFoundException(
String^ message,
Exception^ inner
);
JScript public function NotFoundException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


NotFoundException.NotFoundException(String) Constructor (Microsoft.DirectX.Direct3D)

NotFoundException.NotFoundException Constructor

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotFoundException(
string message
);
C++ public:
NotFoundException(
String^ message
);
JScript public function NotFoundException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


NotFoundException.NotFoundException() Constructor (Microsoft.DirectX.Direct3D)

NotFoundException.NotFoundException Constructor

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic | Public Sub New()
C# | public NotFoundException();
C++ public:
NotFoundException();
JScript | public function NotFoundException();


OutOfVideoMemoryException Class (Microsoft.DirectX.Direct3D)

OutOfVideoMemoryException Class

Microsoft Direct3D does not have enough display memory to perform the operation.

Definition

Visual Basic Public Class OutOfVideoMemoryException
Inherits GraphicsException
C# | public class OutOfVideoMemoryException : GraphicsException
C++ | public ref class OutOfVideoMemoryException : GraphicsException
JScript | public class OutOfVideoMemoryException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OutOfVideoMemoryException | Initializes a new instance of the OutOfVideoMemoryException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OutOfVideoMemoryException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OutOfVideoMemoryException.OutOfVideoMemoryException Constructor ()

Initializes a new instance of the OutOfVideoMemoryException class.

Overload List

public OutOfVideoMemoryException();
protected OutOfVideoMemoryException(SerializationInfo, StreamingContext);
public OutOfVideoMemoryException(string);
public OutOfVideoMemoryException(string, Exception);


OutOfVideoMemoryException.OutOfVideoMemoryException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:

Initializes a new instance of the OutOfVideoMemoryException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OutOfVideoMemoryException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OutOfVideoMemoryException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OutOfVideoMemoryException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


OutOfVideoMemoryException.OutOfVideoMemoryException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:

Initializes a new instance of the OutOfVideoMemoryException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OutOfVideoMemoryException(
string message,
Exception inner
);
C++ public:
OutOfVideoMemoryException(
String^ message,
Exception^ inner
);
JScript public function OutOfVideoMemoryException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


OutOfVideoMemoryException.OutOfVideoMemoryException(String) Constructor (Microsoft.DirectX.Direct3D)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:

Initializes a new instance of the OutOfVideoMemoryException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OutOfVideoMemoryException(
string message
);
C++ public:
OutOfVideoMemoryException(
String^ message
);
JScript public function OutOfVideoMemoryException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


OutOfVideoMemoryException.OutOfVideoMemoryException() Constructor (Microsoft.DirectX.Direct3D)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:

Initializes a new instance of the OutOfVideoMemoryException class.

Definition

Visual Basic | Public Sub New()
C# | public OutOfVideoMemoryException();
C++ public:
OutOfVideoMemoryException();
JScript | public function OutOfVideoMemoryException();


PatchMesh Class (Microsoft.DirectX.Direct3D)

PatchMesh Class

Provides patch mesh functionality.

Definition

Visual Basic NotInheritable Public Class PatchMesh
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class PatchMesh : MarshalByRefObject, IDisposable
C++ | public ref class PatchMesh sealed : MarshalByRefObject, IDisposable
JScript | public final class PatchMesh extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PatchMesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Clone | Creates a new patch mesh with the specified vertex declaration.
static (Shared in Visual Basic) CreateNPatchMesh | Creates an N-patch mesh from a triangle mesh.
Dispose | Immediately releases the unmanaged resources used by the PatchMesh object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the PatchMesh object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FromX | Loads a patch mesh from an XFileData object.
GenerateAdjacency | Generates adjacency information based on mesh indices.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetTessellateSize | Retrieves the size of the tessellated mesh, given a tessellation level.
LockAttributeBuffer | Locks the attribute buffer and obtains its memory.
LockAttributeBufferArray | Locks the attribute buffer and obtains its memory.
LockIndexBuffer | Locks the index buffer.
LockVertexBuffer | Locks the vertex buffer.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Optimize | Optimizes the patch mesh for efficient tessellation.
PatchMesh | Creates a mesh from a control patch mesh.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PatchMesh.Disposing event when called from within a derived class.
SetIndexBufferData | Sets index buffer data.
SetVertexBufferData | Sets vertex buffer data.
Tessellate | Performs uniform tessellation based on the tessellation level.
TessellateAdaptive | Performs adaptive tessellation based on the z-based adaptive tessellation criterion.
UnlockAttributeBuffer | Unlocks the attribute buffer.
UnlockIndexBuffer | Unlocks the index buffer.
UnlockVertexBuffer | Unlocks the vertex buffer.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PatchMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
Validate | Validates a patch mesh.

Properties

Property | Description
ControlVerticesPerPatch | Retrieves the number of control vertices per patch.
Declaration | Retrieves the vertex declaration.
Device | Retrieves the Device that created the mesh.
DisplacementParameter | Retrieves or sets mesh geometry displacement parameters.
Disposed | Gets a value that indicates whether the object is disposed.
IndexBuffer | Retrieves the mesh index buffer.
NumberPatches | Retrieves the number of patches in a mesh.
NumberVertices | Retrieves the number of vertices for a mesh.
Options | Retrieves a MeshOptions structure that contains information about the patch mesh.
PatchInformation | Retrieves the attributes of the patch mesh.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXPatchMesh interface pointer.
VertexBuffer | Retrieves the mesh vertex buffer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PatchMesh

Remarks

A patch mesh is a mesh that consists of a series of patches.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PatchMesh.Clone Method ()

Creates a new patch mesh with the specified vertex declaration.

Overload List

public PatchMesh Clone(MeshFlags, GraphicsStream);
public PatchMesh Clone(MeshFlags, VertexElement[]);

Remarks

The PatchMesh.Clone method converts the vertex buffer to the new vertex declaration. Entries in the vertex declaration that are new to the original mesh are set to 0. If the current mesh has adjacency, the new mesh will have it also.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.Clone(MeshFlags,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

PatchMesh.Clone Method

Creates a new patch mesh with the specified vertex declaration.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal decl As GraphicsStream _
) As PatchMesh
C# public PatchMesh Clone(
MeshFlags options,
GraphicsStream decl
);
C++ public:
PatchMesh^ Clone(
MeshFlags options,
GraphicsStream^ decl
);
JScript public function Clone(
options : MeshFlags,
decl : GraphicsStream
) : PatchMesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
decl Microsoft.DirectX.GraphicsStream
A GraphicsStream containing VertexElement structures that specify the vertex format for the vertices in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh
Cloned patch mesh.

Remarks

The PatchMesh.Clone method converts the vertex buffer to the new vertex declaration. Entries in the vertex declaration that are new to the original mesh are set to 0. If the current mesh has adjacency, the new mesh will have it also.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.Clone(MeshFlags,VertexElement[]) Method (Microsoft.DirectX.Direct3D)

PatchMesh.Clone Method

Creates a new patch mesh with the specified vertex declaration.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal decl() As VertexElement _
) As PatchMesh
C# public PatchMesh Clone(
MeshFlags options,
VertexElement[] decl
);
C++ public:
PatchMesh^ Clone(
MeshFlags options,
array<VertexElement>^ decl
);
JScript public function Clone(
options : MeshFlags,
decl : VertexElement[]
) : PatchMesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
decl Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that specify the vertex format for the vertices in the output mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh
Cloned patch mesh.

Remarks

The PatchMesh.Clone method converts the vertex buffer to the new vertex declaration. Entries in the vertex declaration that are new to the original mesh are set to 0. If the current mesh has adjacency, the new mesh will have it also.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.CreateNPatchMesh(Mesh) Method (Microsoft.DirectX.Direct3D)

PatchMesh.CreateNPatchMesh Method

Creates an N-patch mesh from a triangle mesh.

Definition

Visual Basic Public Shared Function CreateNPatchMesh( _
ByVal mesh As Mesh _
) As PatchMesh
C# public static PatchMesh CreateNPatchMesh(
Mesh mesh
);
C++ public:
static PatchMesh^ CreateNPatchMesh(
Mesh^ mesh
);
JScript public static function CreateNPatchMesh(
mesh : Mesh
) : PatchMesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh triangle mesh object to convert to a patch mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh
A PatchMesh object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.Dispose() Method (Microsoft.DirectX.Direct3D)

PatchMesh.Dispose Method

Immediately releases the unmanaged resources used by the PatchMesh object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~PatchMesh();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PatchMesh.Disposed
  • Microsoft.DirectX.Direct3D.PatchMesh.Disposing


PatchMesh.Equals(Object) Method (Microsoft.DirectX.Direct3D)

PatchMesh.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PatchMesh.Finalize() Method (Microsoft.DirectX.Direct3D)

PatchMesh.Finalize Method

Allows the PatchMesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~PatchMesh();
C++ | !PatchMesh();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


PatchMesh.FromX Method ()

Loads a patch mesh from an XFileData object.

Overload List

public static PatchMesh FromX(XFileData, MeshFlags, Device);
public static PatchMesh FromX(XFileData, MeshFlags, Device, out EffectInstance);
public static PatchMesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial);
public static PatchMesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.FromX(XFileData,MeshFlags,Device,EffectInstance) Method (Microsoft.DirectX.Direct3D)

PatchMesh.FromX Method

Loads a patch mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef effects As EffectInstance _
) As PatchMesh
C# public static PatchMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out EffectInstance effects
);
C++ public:
static PatchMesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
effects : EffectInstance
) : PatchMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more MeshFlags that specify creation options for the mesh (excepting the Simplify* or Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh
Returns a PatchMesh object that represents the loaded patch mesh.

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.FromX(XFileData,MeshFlags,Device) Method (Microsoft.DirectX.Direct3D)

PatchMesh.FromX Method

Loads a patch mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As PatchMesh
C# public static PatchMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device
);
C++ public:
static PatchMesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device
) : PatchMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more MeshFlags that specify creation options for the mesh (excepting the Simplify* or Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh
Returns a PatchMesh object that represents the loaded patch mesh.

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

PatchMesh.FromX Method

Loads a patch mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial _
) As PatchMesh
C# public static PatchMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials
);
C++ public:
static PatchMesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial
) : PatchMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more MeshFlags that specify creation options for the mesh (excepting the Simplify* or Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh
Returns a PatchMesh object that represents the loaded patch mesh.

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

PatchMesh.FromX Method

Loads a patch mesh from an XFileData object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As PatchMesh
C# public static PatchMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static PatchMesh^ FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : PatchMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
One or more MeshFlags that specify creation options for the mesh (excepting the Simplify* or Optimize* flags).
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial structures that contain material information saved in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.PatchMesh
Returns a PatchMesh object that represents the loaded patch mesh.

Remarks

For mesh files that do not contain effect instance information, default effect instances are generated from the material information in the DirectX (.x) file. The default values of a default effect instance correspond to the members of the Material structure.

The default texture name also is filled in, but is handled differently. The name is Texture0@Name, which corresponds to an effect variable by the name of "Texture0" with an annotation called "Name." This contains the string file name for the texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.GenerateAdjacency(Single) Method (Microsoft.DirectX.Direct3D)

PatchMesh.GenerateAdjacency Method

Generates adjacency information based on mesh indices.

Definition

Visual Basic Public Sub GenerateAdjacency( _
ByVal tolerance As Single _
)
C# public void GenerateAdjacency(
float tolerance
);
C++ public:
void GenerateAdjacency(
float tolerance
);
JScript public function GenerateAdjacency(
tolerance : float
);

Parameters

tolerance System.Single
Specifies that vertices that differ in position by less than the tolerance be treated as coincident.

Remarks

This method determines which patches are adjacent (within the provided tolerance). This information is used internally to optimize tessellation.

Exceptions
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.GetHashCode() Method (Microsoft.DirectX.Direct3D)

PatchMesh.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


PatchMesh.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

PatchMesh.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPatchMesh, which allows unmanaged COM clients to create an instance of the managed PatchMesh class. Not supported.


PatchMesh.GetTessellateSize(Single,Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

PatchMesh.GetTessellateSize Method

Retrieves the size of the tessellated mesh, given a tessellation level.

Definition

Visual Basic Public Sub GetTessellateSize( _
ByVal tessLevel As Single, _
ByVal adaptive As Integer, _
ByRef numTriangles As Integer, _
ByRef numVertices As Integer _
)
C# public void GetTessellateSize(
float tessLevel,
int adaptive,
out int numTriangles,
out int numVertices
);
C++ public:
void GetTessellateSize(
float tessLevel,
int adaptive,
[Out] int% numTriangles,
[Out] int% numVertices
);
JScript public function GetTessellateSize(
tessLevel : float,
adaptive : int,
numTriangles : int,
numVertices : int
);

Parameters

tessLevel System.Single
Tessellation level.
adaptive System.Int32
Value that specifies adaptive tessellation. For adaptive tessellation, set this parameter to -1 and set param_Single_tessLevel to the maximum tessellation value. This results in the maximum mesh size necessary for adaptive tessellation. To specify no tessellation, set this parameter to 0.
numTriangles System.Int32
Number of triangles generated by the tessellated mesh.
numVertices System.Int32
Number of vertices generated by the tessellated mesh.

Remarks

This method assumes uniform tessellation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.LockAttributeBuffer(LockFlags) Method (Microsoft.DirectX.Direct3D)

PatchMesh.LockAttributeBuffer Method

Locks the attribute buffer and obtains its memory.

Definition

Visual Basic Public Function LockAttributeBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockAttributeBuffer(
LockFlags flags
);
C++ public:
GraphicsStream^ LockAttributeBuffer(
LockFlags flags
);
JScript public function LockAttributeBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. Valid flags for this method are Discard, NoDirtyUpdate, NoSysLock, and ReadOnly.

Return Value

Microsoft.DirectX.GraphicsStream
Returns the locked buffer as a GraphicsStream object.

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • UnlockAttributeBuffer


PatchMesh.LockAttributeBufferArray(LockFlags) Method (Microsoft.DirectX.Direct3D)

PatchMesh.LockAttributeBufferArray Method

Locks the attribute buffer and obtains its memory.

Definition

Visual Basic Public Function LockAttributeBufferArray( _
ByVal flags As LockFlags _
) As Integer()
C# public int[] LockAttributeBufferArray(
LockFlags flags
);
C++ public:
array<int>^ LockAttributeBufferArray(
LockFlags flags
);
JScript public function LockAttributeBufferArray(
flags : LockFlags
) : int[];

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. Valid flags for this method are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly.

Return Value

System.Int32[]
Returns the locked buffer in an array.

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • UnlockAttributeBuffer


PatchMesh.LockIndexBuffer Method ()

Locks the index buffer.

Overload List

public GraphicsStream LockIndexBuffer(LockFlags);
public Array LockIndexBuffer(Type, LockFlags, int[]);

Remarks

The index buffer is usually locked, written to, and then unlocked for reading. Patch mesh index buffers are 16-bit buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PatchMesh.PatchMesh


PatchMesh.LockIndexBuffer(Type,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

PatchMesh.LockIndexBuffer Method

Locks the index buffer.

Definition

Visual Basic Public Function LockIndexBuffer( _
ByVal typeIndex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockIndexBuffer(
Type typeIndex,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockIndexBuffer(
Type^ typeIndex,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockIndexBuffer(
typeIndex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeIndex System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSysLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked index buffer.

Remarks

The index buffer is usually locked, written to, and then unlocked for reading. Patch mesh index buffers are 16-bit buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PatchMesh.PatchMesh


PatchMesh.LockIndexBuffer(LockFlags) Method (Microsoft.DirectX.Direct3D)

PatchMesh.LockIndexBuffer Method

Locks the index buffer.

Definition

Visual Basic Public Function LockIndexBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockIndexBuffer(
LockFlags flags
);
C++ public:
GraphicsStream^ LockIndexBuffer(
LockFlags flags
);
JScript public function LockIndexBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSysLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked index buffer.

Remarks

The index buffer is usually locked, written to, and then unlocked for reading. Patch mesh index buffers are 16-bit buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PatchMesh.PatchMesh


PatchMesh.LockVertexBuffer Method ()

Locks the vertex buffer.

Overload List

public GraphicsStream LockVertexBuffer(LockFlags);
public Array LockVertexBuffer(Type, LockFlags, int[]);

Remarks

The vertex buffer is usually locked, written to, and then unlocked for reading.

Patch meshes use 16-bit index buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.LockVertexBuffer(LockFlags) Method (Microsoft.DirectX.Direct3D)

PatchMesh.LockVertexBuffer Method

Locks the vertex buffer.

Definition

Visual Basic Public Function LockVertexBuffer( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockVertexBuffer(
LockFlags flags
);
C++ public:
GraphicsStream^ LockVertexBuffer(
LockFlags flags
);
JScript public function LockVertexBuffer(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked vertex buffer.

Remarks

The vertex buffer is usually locked, written to, and then unlocked for reading.

Patch meshes use 16-bit index buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.LockVertexBuffer(Type,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

PatchMesh.LockVertexBuffer Method

Locks the vertex buffer.

Definition

Visual Basic Public Function LockVertexBuffer( _
ByVal typeVertex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockVertexBuffer(
Type typeVertex,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockVertexBuffer(
Type^ typeVertex,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockVertexBuffer(
typeVertex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeVertex System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked vertex buffer.

Remarks

The vertex buffer is usually locked, written to, and then unlocked for reading.

Patch meshes use 16-bit index buffers.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.op_Equality(PatchMesh,PatchMesh) Method (Microsoft.DirectX.Direct3D)

PatchMesh.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As PatchMesh, _
ByVal right As PatchMesh _
) As Boolean
C# public static bool op_Equality(
PatchMesh left,
PatchMesh right
);
C++ public:
static bool operator==(
PatchMesh^ left,
PatchMesh^ right
);
JScript public static function op_Equality(
left : PatchMesh,
right : PatchMesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PatchMesh
The PatchMesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PatchMesh
The PatchMesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PatchMesh.op_Inequality(PatchMesh,PatchMesh) Method (Microsoft.DirectX.Direct3D)

PatchMesh.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As PatchMesh, _
ByVal right As PatchMesh _
) As Boolean
C# public static bool op_Inequality(
PatchMesh left,
PatchMesh right
);
C++ public:
static bool operator!=(
PatchMesh^ left,
PatchMesh^ right
);
JScript public static function op_Inequality(
left : PatchMesh,
right : PatchMesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PatchMesh
The PatchMesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PatchMesh
The PatchMesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


PatchMesh.Optimize() Method (Microsoft.DirectX.Direct3D)

PatchMesh.Optimize Method

Optimizes the patch mesh for efficient tessellation.

Definition

Visual Basic | Public Sub Optimize()
C# | public void Optimize();
C++ public:
void Optimize();
JScript | public function Optimize();

Remarks

The Optimize method performs one-time optimization for patch meshes that need to be tessellated repeatedly (by calling the Tessellate method). The optimization is independent of the actual tessellation level used. If vertices are changed, this method must be called again.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.PatchMesh Constructor ()

Creates a mesh from a control patch mesh.

Overload List

public PatchMesh(Device, PatchInformation, int, int, VertexElement[]);
public PatchMesh(ID3DXPatchMesh);
public PatchMesh(IntPtr);

Remarks

This method converts an input patch mesh to a tessellated mesh. Patch meshes use 16-bit index buffers. Therefore, indices to LockIndexBuffer are 16 bits.


PatchMesh.PatchMesh(ID3DXPatchMesh) Constructor (Microsoft.DirectX.Direct3D)

PatchMesh.PatchMesh Constructor

Creates a mesh from a control patch mesh.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXPatchMesh _
)
C# public PatchMesh(
ID3DXPatchMesh pUnk
);
C++ public:
PatchMesh(
ID3DXPatchMesh pUnk
);
JScript public function PatchMesh(
pUnk : ID3DXPatchMesh
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXPatchMesh
Unmanaged Component Object Model (COM) ID3DXPatchMesh interface pointer.

Remarks

This method converts an input patch mesh to a tessellated mesh. Patch meshes use 16-bit index buffers. Therefore, indices to LockIndexBuffer are 16 bits.


PatchMesh.PatchMesh(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

PatchMesh.PatchMesh Constructor

Creates a mesh from a control patch mesh.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PatchMesh(
IntPtr unmanagedObject
);
C++ public:
PatchMesh(
IntPtr unmanagedObject
);
JScript public function PatchMesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXPatchMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

This method converts an input patch mesh to a tessellated mesh. Patch meshes use 16-bit index buffers. Therefore, indices to LockIndexBuffer are 16 bits.


PatchMesh.PatchMesh(Device,PatchInformation,Int32,Int32,VertexElement[]) Constructor (Microsoft.DirectX.Direct3D)

PatchMesh.PatchMesh Constructor

Creates a mesh from a control patch mesh.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal information As PatchInformation, _
ByVal numberPatches As Integer, _
ByVal numberVertices As Integer, _
ByVal declaration() As VertexElement _
)
C# public PatchMesh(
Device device,
PatchInformation information,
int numberPatches,
int numberVertices,
VertexElement[] declaration
);
C++ public:
PatchMesh(
Device^ device,
PatchInformation information,
int numberPatches,
int numberVertices,
array<VertexElement>^ declaration
);
JScript public function PatchMesh(
device : Device,
information : PatchInformation,
numberPatches : int,
numberVertices : int,
declaration : VertexElement[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device to associate with the patch mesh.
information Microsoft.DirectX.Direct3D.PatchInformation
Patch information structure. For more information, see PatchInformation.
numberPatches System.Int32
Number of patches.
numberVertices System.Int32
Number of control vertices in the patch.
declaration Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that describe the vertex format for the returned mesh.

Remarks

This method converts an input patch mesh to a tessellated mesh. Patch meshes use 16-bit index buffers. Therefore, indices to LockIndexBuffer are 16 bits.


PatchMesh.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

PatchMesh.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.PatchMesh.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


PatchMesh.SetIndexBufferData(Object,LockFlags) Method (Microsoft.DirectX.Direct3D)

PatchMesh.SetIndexBufferData Method

Sets index buffer data.

Definition

Visual Basic Public Sub SetIndexBufferData( _
ByVal data As Object, _
ByVal flags As LockFlags _
)
C# public void SetIndexBufferData(
object data,
LockFlags flags
);
C++ public:
void SetIndexBufferData(
Object^ data,
LockFlags flags
);
JScript public function SetIndexBufferData(
data : Object,
flags : LockFlags
);

Parameters

data System.Object
An Object Leave Site that contains the data to copy into the index buffer. This can be any value type or array of value types. The Int32 Leave Site and Int16 Leave Site values are commonly used.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform when setting the data. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Remarks

The SetIndexBufferData method locks, sets, and then unlocks the index buffer. A call to UnlockIndexBuffer is not required.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PatchMesh.SetVertexBufferData(Object,LockFlags) Method (Microsoft.DirectX.Direct3D)

PatchMesh.SetVertexBufferData Method

Sets vertex buffer data.

Definition

Visual Basic Public Sub SetVertexBufferData( _
ByVal data As Object, _
ByVal flags As LockFlags _
)
C# public void SetVertexBufferData(
object data,
LockFlags flags
);
C++ public:
void SetVertexBufferData(
Object^ data,
LockFlags flags
);
JScript public function SetVertexBufferData(
data : Object,
flags : LockFlags
);

Parameters

data System.Object
An Object Leave Site that contains the data to copy into the vertex buffer. This can be any value type or array of value types. The Int32 Leave Site and Int16 Leave Site values are commonly used.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags that describe the type of lock to perform when setting the data. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Remarks

The SetVertexBufferData method locks, sets, and then unlocks the vertex buffer. A call to UnlockVertexBuffer is not required.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PatchMesh.Tessellate(Single,Mesh) Method (Microsoft.DirectX.Direct3D)

PatchMesh.Tessellate Method

Performs uniform tessellation based on the tessellation level.

Definition

Visual Basic Public Sub Tessellate( _
ByVal tessLevel As Single, _
ByVal mesh As Mesh _
)
C# public void Tessellate(
float tessLevel,
Mesh mesh
);
C++ public:
void Tessellate(
float tessLevel,
Mesh^ mesh
);
JScript public function Tessellate(
tessLevel : float,
mesh : Mesh
);

Parameters

tessLevel System.Single
Tessellation level. This is the number of vertices introduced between existing vertices. The range of this floating-point parameter is between 0 and 32.
mesh Microsoft.DirectX.Direct3D.Mesh
Resulting tessellated mesh. For more information, see Mesh.

Remarks

This method performs most efficiently if the patch mesh is optimized using PatchMesh.Optimize.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.TessellateAdaptive(Vector4,Int32,Int32,Mesh) Method (Microsoft.DirectX.Direct3D)

PatchMesh.TessellateAdaptive Method

Performs adaptive tessellation based on the z-based adaptive tessellation criterion.

Definition

Visual Basic Public Sub TessellateAdaptive( _
ByVal trans As Vector4, _
ByVal maxTessellate As Integer, _
ByVal minTessellate As Integer, _
ByVal mesh As Mesh _
)
C# public void TessellateAdaptive(
Vector4 trans,
int maxTessellate,
int minTessellate,
Mesh mesh
);
C++ public:
void TessellateAdaptive(
Vector4 trans,
int maxTessellate,
int minTessellate,
Mesh^ mesh
);
JScript public function TessellateAdaptive(
trans : Vector4,
maxTessellate : int,
minTessellate : int,
mesh : Mesh
);

Parameters

trans Microsoft.DirectX.Vector4
Specifies a 4-D vector (Vector4) that is dotted with the vertices to get the per-vertex adaptive tessellation amount. Each edge is tessellated to the average value of the tessellation levels for the two vertices it connects.
maxTessellate System.Int32
Maximum limit for adaptive tessellation. This is the number of vertices introduced between existing vertices. The range of this integer value is between param_Int32_minTessellate and 32.
minTessellate System.Int32
Minimum limit for adaptive tessellation. This is the number of vertices introduced between existing vertices. The range of this integer value is between 1 and param_Int32_maxTessellate.
mesh Microsoft.DirectX.Direct3D.Mesh
Resulting tessellated mesh. For more information, see Mesh.

Remarks

This method performs most efficiently if the patch mesh is optimized using PatchMesh.Optimize.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.UnlockAttributeBuffer Method ()

Unlocks the attribute buffer.

Overload List

public void UnlockAttributeBuffer();
public void UnlockAttributeBuffer(int[]);

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.UnlockAttributeBuffer() Method (Microsoft.DirectX.Direct3D)

PatchMesh.UnlockAttributeBuffer Method

Unlocks the attribute buffer.

Definition

Visual Basic | Public Sub UnlockAttributeBuffer()
C# | public void UnlockAttributeBuffer();
C++ public:
void UnlockAttributeBuffer();
JScript | public function UnlockAttributeBuffer();

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.UnlockAttributeBuffer(Int32[]) Method (Microsoft.DirectX.Direct3D)

PatchMesh.UnlockAttributeBuffer Method

Unlocks the attribute buffer.

Definition

Visual Basic Public Sub UnlockAttributeBuffer( _
ByVal dataAttribute() As Integer _
)
C# public void UnlockAttributeBuffer(
int[] dataAttribute
);
C++ public:
void UnlockAttributeBuffer(
array<int>^ dataAttribute
);
JScript public function UnlockAttributeBuffer(
dataAttribute : int[]
);

Parameters

dataAttribute System.Int32[]
Array of values that contains the attribute buffer to unlock.

Remarks

The attribute buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.UnlockIndexBuffer() Method (Microsoft.DirectX.Direct3D)

PatchMesh.UnlockIndexBuffer Method

Unlocks the index buffer.

Definition

Visual Basic | Public Sub UnlockIndexBuffer()
C# | public void UnlockIndexBuffer();
C++ public:
void UnlockIndexBuffer();
JScript | public function UnlockIndexBuffer();

Remarks

The index buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.UnlockVertexBuffer() Method (Microsoft.DirectX.Direct3D)

PatchMesh.UnlockVertexBuffer Method

Unlocks the vertex buffer.

Definition

Visual Basic | Public Sub UnlockVertexBuffer()
C# | public void UnlockVertexBuffer();
C++ public:
void UnlockVertexBuffer();
JScript | public function UnlockVertexBuffer();

Remarks

The vertex buffer is usually locked, written to, and then unlocked for reading.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.UpdateUnmanagedPointer(ID3DXPatchMesh) Method (Microsoft.DirectX.Direct3D)

PatchMesh.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this PatchMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPatchMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXPatchMesh pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXPatchMesh pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXPatchMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPatchMesh
Pointer to the ID3DXPatchMesh structure used to update the unmanaged pointer for this PatchMesh object.


PatchMesh.Validate Method ()

Validates a patch mesh.

Overload List

public DegenerateItems Validate();
public DegenerateItems Validate(out string);

Remarks

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.Validate() Method (Microsoft.DirectX.Direct3D)

PatchMesh.Validate Method

Validates a patch mesh.

Definition

Visual Basic | Public Function Validate() As DegenerateItems
C# | public DegenerateItems Validate();
C++ public:
DegenerateItems Validate();
JScript | public function Validate() : DegenerateItems;

Return Value

Microsoft.DirectX.Direct3D.DegenerateItems
Returns a DegenerateItems structure that contains the indexes of patches and vertices that caused validation to fail.

Remarks

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.Validate(String) Method (Microsoft.DirectX.Direct3D)

PatchMesh.Validate Method

Validates a patch mesh.

Definition

Visual Basic Public Function Validate( _
ByRef errorsAndWarnings As String _
) As DegenerateItems
C# public DegenerateItems Validate(
out string errorsAndWarnings
);
C++ public:
DegenerateItems Validate(
[Out] String^% errorsAndWarnings
);
JScript public function Validate(
errorsAndWarnings : String
) : DegenerateItems;

Parameters

errorsAndWarnings System.String
Returns a buffer that contains a string of errors and warnings, which explain the problems found in the mesh.

Return Value

Microsoft.DirectX.Direct3D.DegenerateItems
Returns a DegenerateItems structure that contains the indexes of patches and vertices that caused validation to fail.

Remarks

Exceptions
InvalidMeshException | The mesh is invalid.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.ControlVerticesPerPatch Property (Microsoft.DirectX.Direct3D)

PatchMesh.ControlVerticesPerPatch Property

Retrieves the number of control vertices per patch.

Definition

Visual Basic | Public ReadOnly Property ControlVerticesPerPatch As Integer
C# | public int ControlVerticesPerPatch { get; }
C++ public:
property int ControlVerticesPerPatch {
int get();
}
JScript | public function get ControlVerticesPerPatch() : int

Property Value

System.Int32
Number of control vertices per patch.

This property is read-only.


PatchMesh.Declaration Property (Microsoft.DirectX.Direct3D)

PatchMesh.Declaration Property

Retrieves the vertex declaration.

Definition

Visual Basic | Public ReadOnly Property Declaration As VertexElement()
C# | public VertexElement[] Declaration { get; }
C++ public:
property array<VertexElement>^ Declaration {
array<VertexElement>^ get();
}
JScript | public function get Declaration() : VertexElement[]

Property Value

Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement elements that describe the vertex format of the mesh vertices. The vertex element array ends with the value found in the VertexDeclarationEnd field.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.Device Property (Microsoft.DirectX.Direct3D)

PatchMesh.Device Property

Retrieves the Device that created the mesh.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device associated with the patch mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.DisplacementParameter Property (Microsoft.DirectX.Direct3D)

PatchMesh.DisplacementParameter Property

Retrieves or sets mesh geometry displacement parameters.

Definition

Visual Basic | Public Property DisplacementParameter As DisplacementParameter
C# | public DisplacementParameter DisplacementParameter { get; set; }
C++ public:
property DisplacementParameter DisplacementParameter {
DisplacementParameter get();
void set(DisplacementParameter value);
}
JScript public function get DisplacementParameter() : DisplacementParameter
public function set DisplacementParameter(DisplacementParameter);

Property Value

Microsoft.DirectX.Direct3D.DisplacementParameter
The DisplacementParameter for the mesh.

This property is read/write.

Remarks

Displacement maps can only be 2-D textures. Mipmapping is ignored for nonadaptive tessellating.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.Disposed Property (Microsoft.DirectX.Direct3D)

PatchMesh.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


PatchMesh.IndexBuffer Property (Microsoft.DirectX.Direct3D)

PatchMesh.IndexBuffer Property

Retrieves the mesh index buffer.

Definition

Visual Basic | Public ReadOnly Property IndexBuffer As IndexBuffer
C# | public IndexBuffer IndexBuffer { get; }
C++ public:
property IndexBuffer^ IndexBuffer {
IndexBuffer^ get();
}
JScript | public function get IndexBuffer() : IndexBuffer

Property Value

Microsoft.DirectX.Direct3D.IndexBuffer
The IndexBuffer for the mesh.

This property is read-only.

Remarks

The index buffer contains the vertex ordering in the vertex buffer. The index buffer is used to access the vertex buffer when the mesh is rendered.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.NumberPatches Property (Microsoft.DirectX.Direct3D)

PatchMesh.NumberPatches Property

Retrieves the number of patches in a mesh.

Definition

Visual Basic | Public ReadOnly Property NumberPatches As Integer
C# | public int NumberPatches { get; }
C++ public:
property int NumberPatches {
int get();
}
JScript | public function get NumberPatches() : int

Property Value

System.Int32
Number of patches.

This property is read-only.


PatchMesh.NumberVertices Property (Microsoft.DirectX.Direct3D)

PatchMesh.NumberVertices Property

Retrieves the number of vertices for a mesh.

Definition

Visual Basic | Public ReadOnly Property NumberVertices As Integer
C# | public int NumberVertices { get; }
C++ public:
property int NumberVertices {
int get();
}
JScript | public function get NumberVertices() : int

Property Value

System.Int32
Number of vertices.

This property is read-only.


PatchMesh.Options Property (Microsoft.DirectX.Direct3D)

PatchMesh.Options Property

Retrieves a MeshOptions structure that contains information about the patch mesh.

Definition

Visual Basic | Public ReadOnly Property Options As MeshOptions
C# | public MeshOptions Options { get; }
C++ public:
property MeshOptions Options {
MeshOptions get();
}
JScript | public function get Options() : MeshOptions

Property Value

Microsoft.DirectX.Direct3D.MeshOptions
A MeshOptions structure that contains information about the patch mesh.

This property is read-only.


PatchMesh.PatchInformation Property (Microsoft.DirectX.Direct3D)

PatchMesh.PatchInformation Property

Retrieves the attributes of the patch mesh.

Definition

Visual Basic | Public ReadOnly Property PatchInformation As PatchInformation
C# | public PatchInformation PatchInformation { get; }
C++ public:
property PatchInformation PatchInformation {
PatchInformation get();
}
JScript | public function get PatchInformation() : PatchInformation

Property Value

Microsoft.DirectX.Direct3D.PatchInformation
A PatchInformation structure that contains information about the patch mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

PatchMesh.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXPatchMesh interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXPatchMesh
C# | public ID3DXPatchMesh UnmanagedComPointer { get; }
C++ public:
property ID3DXPatchMesh UnmanagedComPointer {
ID3DXPatchMesh get();
}
JScript | public function get UnmanagedComPointer() : ID3DXPatchMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPatchMesh
Unmanaged ID3DXPatchMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


PatchMesh.VertexBuffer Property (Microsoft.DirectX.Direct3D)

PatchMesh.VertexBuffer Property

Retrieves the mesh vertex buffer.

Definition

Visual Basic | Public ReadOnly Property VertexBuffer As VertexBuffer
C# | public VertexBuffer VertexBuffer { get; }
C++ public:
property VertexBuffer^ VertexBuffer {
VertexBuffer^ get();
}
JScript | public function get VertexBuffer() : VertexBuffer

Property Value

Microsoft.DirectX.Direct3D.VertexBuffer
A VertexBuffer object that represents the mesh vertex buffer.

This property is read-only.

Remarks

This method assumes uniform tessellation.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PatchMesh.Disposing Event (Microsoft.DirectX.Direct3D)

PatchMesh.Disposing Event

Occurs when the Dispose method is called or when the PatchMesh object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PatchMesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PatchMesh object indicates whether that object has been disposed.


PixelShader Class (Microsoft.DirectX.Direct3D)

PixelShader Class

Encapsulates the functionality of a pixel shader.

Definition

Visual Basic NotInheritable Public Class PixelShader
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class PixelShader : MarshalByRefObject, IDisposable
C++ | public ref class PixelShader sealed : MarshalByRefObject, IDisposable
JScript | public final class PixelShader extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PixelShader object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the PixelShader object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the PixelShader object to free resources before it is destroyed by the garbage collector.
GetFunction | Retrieves an array that contains the shader data.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PixelShader | Initializes a new instance of the PixelShader class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PixelShader.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PixelShader object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the Microsoft Direct3D device associated with a pixel shader object.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PixelShader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PixelShader.Dispose() Method (Microsoft.DirectX.Direct3D)

PixelShader.Dispose Method

Immediately releases the unmanaged resources used by the PixelShader object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~PixelShader();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PixelShader.Disposed
  • Microsoft.DirectX.Direct3D.PixelShader.Disposing


PixelShader.Equals(Object) Method (Microsoft.DirectX.Direct3D)

PixelShader.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PixelShader.Finalize() Method (Microsoft.DirectX.Direct3D)

PixelShader.Finalize Method

Allows the PixelShader object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~PixelShader();
C++ | !PixelShader();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


PixelShader.GetFunction() Method (Microsoft.DirectX.Direct3D)

PixelShader.GetFunction Method

Retrieves an array that contains the shader data.

Definition

Visual Basic | Public Function GetFunction() As Integer()
C# | public int[] GetFunction();
C++ public:
array<int>^ GetFunction();
JScript | public function GetFunction() : int[];

Return Value

System.Int32[]
Array that contains the shader data.

Remarks

Exceptions
ArgumentException Leave Site | An error occurred while trying to retrieve the shader data.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.


PixelShader.GetHashCode() Method (Microsoft.DirectX.Direct3D)

PixelShader.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


PixelShader.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

PixelShader.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DPixelShader9, which allows unmanaged COM clients to create an instance of the managed PixelShader class. Not supported.


PixelShader.op_Equality(PixelShader,PixelShader) Method (Microsoft.DirectX.Direct3D)

PixelShader.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As PixelShader, _
ByVal right As PixelShader _
) As Boolean
C# public static bool op_Equality(
PixelShader left,
PixelShader right
);
C++ public:
static bool operator==(
PixelShader^ left,
PixelShader^ right
);
JScript public static function op_Equality(
left : PixelShader,
right : PixelShader
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PixelShader
The PixelShader object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PixelShader
The PixelShader object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PixelShader.op_Inequality(PixelShader,PixelShader) Method (Microsoft.DirectX.Direct3D)

PixelShader.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As PixelShader, _
ByVal right As PixelShader _
) As Boolean
C# public static bool op_Inequality(
PixelShader left,
PixelShader right
);
C++ public:
static bool operator!=(
PixelShader^ left,
PixelShader^ right
);
JScript public static function op_Inequality(
left : PixelShader,
right : PixelShader
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PixelShader
The PixelShader object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PixelShader
The PixelShader object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


PixelShader.PixelShader Constructor ()

Initializes a new instance of the PixelShader class.

Overload List

public PixelShader(Device, GraphicsStream);
public PixelShader(Device, int[]);
public PixelShader(IDirect3DPixelShader9);
public PixelShader(IDirect3DPixelShader9, Device);
public PixelShader(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(IDirect3DPixelShader9) Constructor (Microsoft.DirectX.Direct3D)

PixelShader.PixelShader Constructor

Initializes a new instance of the PixelShader class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DPixelShader9 _
)
C# public PixelShader(
IDirect3DPixelShader9 pUnk
);
C++ public:
PixelShader(
IDirect3DPixelShader9 pUnk
);
JScript public function PixelShader(
pUnk : IDirect3DPixelShader9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DPixelShader9
Unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

PixelShader.PixelShader Constructor

Initializes a new instance of the PixelShader class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PixelShader(
IntPtr unmanagedObject
);
C++ public:
PixelShader(
IntPtr unmanagedObject
);
JScript public function PixelShader(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(IDirect3DPixelShader9,Device) Constructor (Microsoft.DirectX.Direct3D)

PixelShader.PixelShader Constructor

Initializes a new instance of the PixelShader class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DPixelShader9, _
ByVal device As Device _
)
C# public PixelShader(
IDirect3DPixelShader9 lp,
Device device
);
C++ public:
PixelShader(
IDirect3DPixelShader9 lp,
Device^ device
);
JScript public function PixelShader(
lp : IDirect3DPixelShader9,
device : Device
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DPixelShader9
Unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
Reference to an instance of a Device object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(Device,Int32[]) Constructor (Microsoft.DirectX.Direct3D)

PixelShader.PixelShader Constructor

Initializes a new instance of the PixelShader class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal functionToken() As Integer _
)
C# public PixelShader(
Device device,
int[] functionToken
);
C++ public:
PixelShader(
Device^ device,
array<int>^ functionToken
);
JScript public function PixelShader(
device : Device,
functionToken : int[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to an instance of a Device object.
functionToken System.Int32[]
Integer array representing the pixel shader function tokens that specify the blending operations.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.PixelShader(Device,GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

PixelShader.PixelShader Constructor

Initializes a new instance of the PixelShader class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal functionToken As GraphicsStream _
)
C# public PixelShader(
Device device,
GraphicsStream functionToken
);
C++ public:
PixelShader(
Device^ device,
GraphicsStream^ functionToken
);
JScript public function PixelShader(
device : Device,
functionToken : GraphicsStream
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to an instance of a Device object.
functionToken Microsoft.DirectX.GraphicsStream
Reference to a GraphicsStream object that represents the pixel shader function tokens to use.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


PixelShader.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

PixelShader.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.PixelShader.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


PixelShader.UpdateUnmanagedPointer(IDirect3DPixelShader9) Method (Microsoft.DirectX.Direct3D)

PixelShader.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this PixelShader object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DPixelShader9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DPixelShader9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DPixelShader9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DPixelShader9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DPixelShader9
Pointer to the IDirect3DPixelShader9 structure used to update the unmanaged pointer for this PixelShader object.


PixelShader.Device Property (Microsoft.DirectX.Direct3D)

PixelShader.Device Property

Retrieves the Microsoft Direct3D device associated with a pixel shader object.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
A Device reference that represents the Direct3D device object associated with the pixel shader object.

This property is read-only.


PixelShader.Disposed Property (Microsoft.DirectX.Direct3D)

PixelShader.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


PixelShader.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

PixelShader.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DPixelShader9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DPixelShader9
C# | public IDirect3DPixelShader9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DPixelShader9 UnmanagedComPointer {
IDirect3DPixelShader9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DPixelShader9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DPixelShader9
Unmanaged IDirect3DPixelShader9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


PixelShader.Disposing Event (Microsoft.DirectX.Direct3D)

PixelShader.Disposing Event

Occurs when the Dispose method is called or when the PixelShader object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PixelShader.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PixelShader object indicates whether that object has been disposed.


PresentParameters Class (Microsoft.DirectX.Direct3D)

PresentParameters Class

Describes the presentation parameters.

Definition

Visual Basic NotInheritable Public Class PresentParameters
Inherits Object
Implements ICloneable
C# | public sealed class PresentParameters : Object, ICloneable
C++ | public ref class PresentParameters sealed : Object, ICloneable
JScript | public final class PresentParameters extends Object implements ICloneable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) DefaultPresentRate | Returns the default rate at which a swap chain's back buffers can be presented.

Methods

Method | Description
Clone | Clones, or copies, a PresentParameters object.
PresentParameters | Creates a new instance of the PresentParameters class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AutoDepthStencilFormat | Retrieves or sets the DepthFormat of the depth stencil surface the device creates.
BackBufferCount | Retrieves or sets the number of back buffers.
BackBufferFormat | Retrieves or sets the format of the back buffer.
BackBufferHeight | Retrieves or sets the height of a swap chain's back buffers, in pixels.
BackBufferWidth | Retrieves or sets the width of a swap chain's back buffers, in pixels.
DeviceWindow | Retrieves or sets the display window.
DeviceWindowHandle | Retrieves or sets the display window.
EnableAutoDepthStencil | Retrieves or sets a Boolean value that indicates whether Microsoft Direct3D manages depth buffers for an application.
ForceNoMultiThreadedFlag | Retrieves or sets a Boolean value that indicates whether an application can use multithreading.
FullScreenRefreshRateInHz | Retrieves or sets the rate at which the display adapter refreshes the screen.
MultiSample | Retrieves or sets the MultiSampleType.
MultiSampleQuality | Retrieves or sets the multisample quality level.
PresentationInterval | Retrieves or sets the maximum rate at which the swap chain's back buffers can be presented.
PresentFlag | Retrieves or sets the present flag.
SwapEffect | Retrieves or sets the swap effect.
Windowed | Boolean value that indicates whether an application is running in a windowed mode.

Inheritance Hierarchy

Object Leave Site
PresentParameters

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Device
  • SwapChain
  • Device.Present
  • Device.Reset


PresentParameters.Clone() Method (Microsoft.DirectX.Direct3D)

PresentParameters.Clone Method

Clones, or copies, a PresentParameters object.

Definition

Visual Basic | Overrides Public Function Clone() As Object
C# | public override object Clone();
C++ public:
virtual Object^ Clone() override;
JScript | public override function Clone() : Object;

Return Value

System.Object
An Object Leave Site that represents the copied device.

Remarks

Exceptions
OutOfMemoryException Leave Site Microsoft Direct3D could not allocate sufficient memory to complete the call.


PresentParameters.PresentParameters Constructor ()

Creates a new instance of the PresentParameters class.

Overload List

public PresentParameters();
public PresentParameters(PresentParameters);


PresentParameters.PresentParameters() Constructor (Microsoft.DirectX.Direct3D)

PresentParameters.PresentParameters Constructor

Creates a new instance of the PresentParameters class.

Definition

Visual Basic | Public Sub New()
C# | public PresentParameters();
C++ public:
PresentParameters();
JScript | public function PresentParameters();


PresentParameters.PresentParameters(PresentParameters) Constructor (Microsoft.DirectX.Direct3D)

PresentParameters.PresentParameters Constructor

Creates a new instance of the PresentParameters class.

Definition

Visual Basic Public Sub New( _
ByVal original As PresentParameters _
)
C# public PresentParameters(
PresentParameters original
);
C++ public:
PresentParameters(
PresentParameters^ original
);
JScript public function PresentParameters(
original : PresentParameters
);

Parameters

original Microsoft.DirectX.Direct3D.PresentParameters
A PresentParameters object from which to create the new object.


PresentParameters.ToString() Method (Microsoft.DirectX.Direct3D)

PresentParameters.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PresentParameters.AutoDepthStencilFormat Property (Microsoft.DirectX.Direct3D)

PresentParameters.AutoDepthStencilFormat Property

Retrieves or sets the DepthFormat of the depth stencil surface the device creates.

Definition

Visual Basic | Public Property AutoDepthStencilFormat As DepthFormat
C# | public DepthFormat AutoDepthStencilFormat { get; set; }
C++ public:
property DepthFormat AutoDepthStencilFormat {
DepthFormat get();
void set(DepthFormat value);
}
JScript public function get AutoDepthStencilFormat() : DepthFormat
public function set AutoDepthStencilFormat(DepthFormat);

Property Value

Microsoft.DirectX.Direct3D.DepthFormat
A DepthFormat enumerated type that describes the format of the automatic depth stencil surface the device creates.

This property is read/write.

Remarks

This member is ignored unless EnableAutoDepthStencil is set to true.


PresentParameters.BackBufferCount Property (Microsoft.DirectX.Direct3D)

PresentParameters.BackBufferCount Property

Retrieves or sets the number of back buffers.

Definition

Visual Basic | Public Property BackBufferCount As Integer
C# | public int BackBufferCount { get; set; }
C++ public:
property int BackBufferCount {
int get();
void set(int value);
}
JScript public function get BackBufferCount() : int
public function set BackBufferCount(int);

Property Value

System.Int32
Number of back buffers.

This property is read/write.

Remarks

This value can be 0 (or 1), 2, or 3. Zero is treated as 1. If the specified number of back buffers cannot be created, the runtime fails the method call and fills the value with the number of back buffers that it was able to create. This behavior means that an application can call the method twice with the same PresentParameters structure and expect it to work the second time.

The method fails if one back buffer cannot be created. The value of BackBufferCount influences which set of swap effects is allowed; specifically, any SwapEffect.Copy swap effect requires that there be exactly one back buffer.


PresentParameters.BackBufferFormat Property (Microsoft.DirectX.Direct3D)

PresentParameters.BackBufferFormat Property

Retrieves or sets the format of the back buffer.

Definition

Visual Basic | Public Property BackBufferFormat As Format
C# | public Format BackBufferFormat { get; set; }
C++ public:
property Format BackBufferFormat {
Format get();
void set(Format value);
}
JScript public function get BackBufferFormat() : Format
public function set BackBufferFormat(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
Back buffer Format.

This property is read/write.

Remarks

This value must be one of the render target formats as validated by Manager.CheckDeviceType. Use Device.DisplayMode to obtain the current format. For more information about formats, see Format.

While in windowed mode, Unknown can be specified for the BackBufferFormat. This tells the runtime to use the current display-mode format and eliminates the need to call Device.DisplayMode.

For windowed applications, the back buffer format does not need to match the display-mode format because color conversion can be done by the hardware (provided the hardware supports it). The set of possible back buffer formats is constrained, but the runtime allows any valid back buffer format to be presented to any desktop format. The device also must be operable in desktop mode, since devices typically do not operate in 8-bits-per-pixel modes.

Full-screen applications cannot perform color conversion.


PresentParameters.BackBufferHeight Property (Microsoft.DirectX.Direct3D)

PresentParameters.BackBufferHeight Property

Retrieves or sets the height of a swap chain's back buffers, in pixels.

Definition

Visual Basic | Public Property BackBufferHeight As Integer
C# | public int BackBufferHeight { get; set; }
C++ public:
property int BackBufferHeight {
int get();
void set(int value);
}
JScript public function get BackBufferHeight() : int
public function set BackBufferHeight(int);

Property Value

System.Int32
Height of the swap chain's back buffers, in pixels.

This property is read/write.

Remarks

If the Windowed property is false (that is, if the presentation is full-screen), the height must equal the height of one of the enumerated display modes found through the DisplayModeCollection. If Windowed is true and height is 0, the corresponding dimension of the client area of the DeviceWindow (or the focus window, if DeviceWindow is null) is taken.


PresentParameters.BackBufferWidth Property (Microsoft.DirectX.Direct3D)

PresentParameters.BackBufferWidth Property

Retrieves or sets the width of a swap chain's back buffers, in pixels.

Definition

Visual Basic | Public Property BackBufferWidth As Integer
C# | public int BackBufferWidth { get; set; }
C++ public:
property int BackBufferWidth {
int get();
void set(int value);
}
JScript public function get BackBufferWidth() : int
public function set BackBufferWidth(int);

Property Value

System.Int32
Width of the swap chain's back buffers, in pixels.

This property is read/write.

Remarks

If the Windowed property is false (that is, if the presentation is full-screen), the width must equal the width of one of the enumerated display modes found through the DisplayModeCollection. If Windowed is true and width is 0, the corresponding dimension of the client area of the DeviceWindow (or the focus window, if DeviceWindow is null) is taken.


PresentParameters.DeviceWindow Property (Microsoft.DirectX.Direct3D)

PresentParameters.DeviceWindow Property

Retrieves or sets the display window.

Definition

Visual Basic | Public Property DeviceWindow As Control
C# | public Control DeviceWindow { get; set; }
C++ public:
property Control^ DeviceWindow {
Control^ get();
void set(Control^ value);
}
JScript public function get DeviceWindow() : Control
public function set DeviceWindow(Control);

Property Value

System.Windows.Forms.Control
A Control Leave Site that represents the display window.

This property is read/write.

Remarks

For a full-screen application, the display window is the cover window. For applications that use multiple full-screen devices (such as a system with multiple monitors), exactly one device can use the focus window as the device window. All other devices must have unique device windows.

For a windowed-mode application, the display window is the default target window for Device.Present. If this property is null, the focus window is taken.

Note that the runtime does not attempt to reflect user changes in window size. The back buffer is not implicitly reset when this window is reset. However, the Device.Present method does automatically track window position changes.


PresentParameters.DeviceWindowHandle Property (Microsoft.DirectX.Direct3D)

PresentParameters.DeviceWindowHandle Property

Retrieves or sets the display window.

Definition

Visual Basic | Public Property DeviceWindowHandle As IntPtr
C# | public IntPtr DeviceWindowHandle { get; set; }
C++ public:
property IntPtr DeviceWindowHandle {
IntPtr get();
void set(IntPtr value);
}
JScript public function get DeviceWindowHandle() : IntPtr
public function set DeviceWindowHandle(IntPtr);

Property Value

System.IntPtr
Pointer to an object that represents the display window.

This property is read/write.

Remarks

For a full-screen application, the display window is the cover window. For applications that use multiple full-screen devices (such as a system with multiple monitors), exactly one device can use the focus window as the device window. All other devices must have unique device windows.

For a windowed-mode application, the display window is the default target window for Device.Present. If this property is null, the focus window is taken.

Note that the runtime does not attempt to reflect user changes in window size. The back buffer is not implicitly reset when this window is reset. However, the Device.Present method does automatically track window position changes.


PresentParameters.EnableAutoDepthStencil Property (Microsoft.DirectX.Direct3D)

PresentParameters.EnableAutoDepthStencil Property

Retrieves or sets a Boolean value that indicates whether Microsoft Direct3D manages depth buffers for an application.

Definition

Visual Basic | Public Property EnableAutoDepthStencil As Boolean
C# | public bool EnableAutoDepthStencil { get; set; }
C++ public:
property bool EnableAutoDepthStencil {
bool get();
void set(bool value);
}
JScript public function get EnableAutoDepthStencil() : boolean
public function set EnableAutoDepthStencil(boolean);

Property Value

System.Boolean
Value that is true if Direct3D manages the depth buffers, or false if it does not.

This property is read/write.

Remarks

When the device is created, it creates a depth stencil buffer that is automatically set as its render target. When the device is reset, the depth stencil buffer is automatically destroyed and re-created in the new size.

If EnableAutoDepthStencil is true, AutoDepthStencilFormat must be a valid depth stencil format.


PresentParameters.ForceNoMultiThreadedFlag Property (Microsoft.DirectX.Direct3D)

PresentParameters.ForceNoMultiThreadedFlag Property

Retrieves or sets a Boolean value that indicates whether an application can use multithreading.

Definition

Visual Basic | Public Property ForceNoMultiThreadedFlag As Boolean
C# | public bool ForceNoMultiThreadedFlag { get; set; }
C++ public:
property bool ForceNoMultiThreadedFlag {
bool get();
void set(bool value);
}
JScript public function get ForceNoMultiThreadedFlag() : boolean
public function set ForceNoMultiThreadedFlag(boolean);

Property Value

System.Boolean
Value that is true if multithreading is allowed in the application, or false if it is not.

This property is read/write.


PresentParameters.FullScreenRefreshRateInHz Property (Microsoft.DirectX.Direct3D)

PresentParameters.FullScreenRefreshRateInHz Property

Retrieves or sets the rate at which the display adapter refreshes the screen.

Definition

Visual Basic | Public Property FullScreenRefreshRateInHz As Integer
C# | public int FullScreenRefreshRateInHz { get; set; }
C++ public:
property int FullScreenRefreshRateInHz {
int get();
void set(int value);
}
JScript public function get FullScreenRefreshRateInHz() : int
public function set FullScreenRefreshRateInHz(int);

Property Value

System.Int32
Refresh rate in hertz.

This property is read/write.

Remarks

The value depends on the mode in which the application is running. For windowed mode, the refresh rate must be 0. For full-screen mode, the refresh rate is one of those found through DisplayModeCollection.


PresentParameters.MultiSample Property (Microsoft.DirectX.Direct3D)

PresentParameters.MultiSample Property

Retrieves or sets the MultiSampleType.

Definition

Visual Basic | Public Property MultiSample As MultiSampleType
C# | public MultiSampleType MultiSample { get; set; }
C++ public:
property MultiSampleType MultiSample {
MultiSampleType get();
void set(MultiSampleType value);
}
JScript public function get MultiSample() : MultiSampleType
public function set MultiSample(MultiSampleType);

Property Value

Microsoft.DirectX.Direct3D.MultiSampleType
Member of the MultiSampleType enumeration that indicates the level of multisampling used by the swap chain.

This property is read/write.

Remarks

The value must be None unless the SwapEffect property is set to SwapEffect.Discard. Multisampling is supported only if the swap effect is SwapEffect.Discard.


PresentParameters.MultiSampleQuality Property (Microsoft.DirectX.Direct3D)

PresentParameters.MultiSampleQuality Property

Retrieves or sets the multisample quality level.

Definition

Visual Basic | Public Property MultiSampleQuality As Integer
C# | public int MultiSampleQuality { get; set; }
C++ public:
property int MultiSampleQuality {
int get();
void set(int value);
}
JScript public function get MultiSampleQuality() : int
public function set MultiSampleQuality(int);

Property Value

System.Int32
Multisample quality level.

This property is read/write.

Remarks

The valid range is between 0 and one less than the level returned by the param_Int32R_qualityLevels parameter used by Manager.CheckDeviceMultiSampleType. Passing a larger value causes an InvalidCallException. Paired values of render targets or depth stencil surfaces must match MultiSample.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PresentParameters.PresentationInterval Property (Microsoft.DirectX.Direct3D)

PresentParameters.PresentationInterval Property

Retrieves or sets the maximum rate at which the swap chain's back buffers can be presented.

Definition

Visual Basic | Public Property PresentationInterval As PresentInterval
C# | public PresentInterval PresentationInterval { get; set; }
C++ public:
property PresentInterval PresentationInterval {
PresentInterval get();
void set(PresentInterval value);
}
JScript public function get PresentationInterval() : PresentInterval
public function set PresentationInterval(PresentInterval);

Property Value

Microsoft.DirectX.Direct3D.PresentInterval
Maximum rate at which the swap chain's back buffers can be presented.

This property is read/write.

Remarks

For a windowed swap chain, this value must be PresentInterval.Default (0). For a full-screen swap chain, it can be PresentInterval.Default or the value that corresponds exactly to one of the flags enumerated in Present.


PresentParameters.PresentFlag Property (Microsoft.DirectX.Direct3D)

PresentParameters.PresentFlag Property

Retrieves or sets the present flag.

Definition

Visual Basic | Public Property PresentFlag As PresentFlag
C# | public PresentFlag PresentFlag { get; set; }
C++ public:
property PresentFlag PresentFlag {
PresentFlag get();
void set(PresentFlag value);
}
JScript public function get PresentFlag() : PresentFlag
public function set PresentFlag(PresentFlag);

Property Value

Microsoft.DirectX.Direct3D.PresentFlag
A PresentFlag value.

This property is read/write.

Remarks

The present flag controls a Device.Present operation.


PresentParameters.SwapEffect Property (Microsoft.DirectX.Direct3D)

PresentParameters.SwapEffect Property

Retrieves or sets the swap effect.

Definition

Visual Basic | Public Property SwapEffect As SwapEffect
C# | public SwapEffect SwapEffect { get; set; }
C++ public:
property SwapEffect SwapEffect {
SwapEffect get();
void set(SwapEffect value);
}
JScript public function get SwapEffect() : SwapEffect
public function set SwapEffect(SwapEffect);

Property Value

Microsoft.DirectX.Direct3D.SwapEffect
Member of the SwapEffect enumerated type that indicates how buffers are swapped.

This property is read/write.

Remarks

The runtime guarantees the implied semantics concerning buffer swap behavior. So if Windowed is set to true and SwapEffect is set to SwapEffect.Flip, the runtime creates one extra back buffer and copies whichever becomes the front buffer at presentation time.

The SwapEffect.Copy setting requires that BackBufferCount be set to 1. This setting is enforced in the debug runtime, which fills any buffer with noise after it is presented.


PresentParameters.Windowed Property (Microsoft.DirectX.Direct3D)

PresentParameters.Windowed Property

Boolean value that indicates whether an application is running in a windowed mode.

Definition

Visual Basic | Public Property Windowed As Boolean
C# | public bool Windowed { get; set; }
C++ public:
property bool Windowed {
bool get();
void set(bool value);
}
JScript public function get Windowed() : boolean
public function set Windowed(boolean);

Property Value

System.Boolean
Value that is true if the application is running windowed, or false if it is running full-screen.

This property is read/write.


PresentParameters.DefaultPresentRate Field (Microsoft.DirectX.Direct3D)

PresentParameters.DefaultPresentRate Field

Returns the default rate at which a swap chain's back buffers can be presented.

Definition

Visual Basic | Public Shared DefaultPresentRate As Int32
C# | public static Int32 DefaultPresentRate;
C++ | public: static Int32 DefaultPresentRate;
JScript | public static var DefaultPresentRate : Int32

Field Value

System.Int32
An Int32 Leave Site value that indicates the default present rate.

This field is read-only.


ProgressiveMesh Class (Microsoft.DirectX.Direct3D)

ProgressiveMesh Class

Manipulates progressive mesh objects.

Definition

Visual Basic NotInheritable Public Class ProgressiveMesh
Inherits BaseMesh
C# | public sealed class ProgressiveMesh : BaseMesh
C++ | public ref class ProgressiveMesh sealed : BaseMesh
JScript | public final class ProgressiveMesh extends BaseMesh

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the ProgressiveMesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Clone | Clones, or copies, a mesh object. Inherited from BaseMesh.
ComputeNormals | Computes normals for each vertex in a mesh. Inherited from BaseMesh.
ConvertAdjacencyToPointReps | Converts mesh adjacency information to an array of point representatives. Inherited from BaseMesh.
ConvertPointRepsToAdjacency | Converts point representative data to mesh adjacency information. Inherited from BaseMesh.
Dispose | Immediately releases the unmanaged resources used by the ProgressiveMesh object.
DrawSubset | Draws a subset of a mesh. Inherited from BaseMesh.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the ProgressiveMesh object to free resources before it is destroyed by the garbage collector.
GenerateAdjacency | Generates adjacency information based on mesh indices. Inherited from BaseMesh.
GetAttributeTable | Retrieves an attribute table for a mesh. Inherited from BaseMesh.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
LockIndexBuffer | Locks an index buffer and obtains the index buffer data. Inherited from BaseMesh.
LockVertexBuffer | Locks a vertex buffer and obtains a pointer to the vertex buffer memory. Inherited from BaseMesh.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseMesh.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseMesh.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Optimize | Generates an output mesh with reordered faces and vertices to optimize performance.
OptimizeBaseLevelOfDetail | Optimizes the base level of detail (LOD) part of a ProgressiveMesh object.
ProgressiveMesh | Creates a new instance of the ProgressiveMesh class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposing event when called from within a derived class.
SetIndexBufferData | Sets index buffer data. Inherited from BaseMesh.
SetVertexBufferData | Sets vertex buffer data. Inherited from BaseMesh.
TrimByFaces | Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.
TrimByVertices | Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.
UnlockIndexBuffer | Unlocks an index buffer. Inherited from BaseMesh.
UnlockVertexBuffer | Unlocks a vertex buffer. Inherited from BaseMesh.
UpdateSemantics Allows the user to change the mesh declaration without changing the data layout of the vertex buffer.

The call is valid only if the old and new declaration formats have the same vertex size. Inherited from BaseMesh.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseMesh.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this ProgressiveMesh object. This method supports the Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Adjacency | Retrieves the face adjacency array of the mesh.
Declaration | Retrieves a declaration that describes the vertices in a mesh. Inherited from BaseMesh.
Device | Retrieves the device associated with a mesh. Inherited from BaseMesh.
Disposed | Gets a value that indicates whether the object is disposed.
IndexBuffer | Retrieves the data in an index buffer. Inherited from BaseMesh.
MaxFaces | Retrieves the maximum number of faces that a progressive mesh can support.
MaxVertices | Retrieves the maximum number of vertices that a progressive mesh can support.
MinFaces | Retrieves the minimum number of faces that a progressive mesh can support.
MinVertices | Retrieves the minimum number of vertices that a progressive mesh can support.
NumberAttributes | Retrieves the number of entries stored in an attribute table for a mesh. Inherited from BaseMesh.
NumberBytesPerVertex | Retrieves the number of bytes per vertex. Inherited from BaseMesh.
NumberFaces | Retrieves the currently set number of faces, or sets the current level of detail (LOD) to as close to the specified number of faces as possible.
NumberVertices | Sets the current level of detail (LOD) to as close to the specified number of vertices as possible.
Options | Retrieves the mesh options enabled for the current mesh at creation time. Inherited from BaseMesh.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXBaseMesh interface pointer. Inherited from BaseMesh.
UnmanagedComPointer | Returns the unmanaged COM ID3DXPMesh interface pointer.
VertexBuffer | Retrieves the vertex buffer of a mesh. Inherited from BaseMesh.
VertexFormat | Retrieves the vertex format that describes the contents of vertices. Inherited from BaseMesh.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BaseMesh
ProgressiveMesh

Remarks

A progressive mesh enables progressive refinement of the mesh object.

This interface inherits additional functionality from the BaseMesh class.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ProgressiveMesh.Dispose() Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Dispose Method

Immediately releases the unmanaged resources used by the ProgressiveMesh object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~ProgressiveMesh();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposed
  • Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposing


ProgressiveMesh.Equals(Object) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


ProgressiveMesh.Finalize() Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Finalize Method

Allows the ProgressiveMesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~ProgressiveMesh();
C++ | !ProgressiveMesh();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


ProgressiveMesh.GetHashCode() Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


ProgressiveMesh.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPMesh, which allows unmanaged COM clients to create an instance of the managed ProgressiveMesh class. Not supported.


ProgressiveMesh.op_Equality(ProgressiveMesh,ProgressiveMesh) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As ProgressiveMesh, _
ByVal right As ProgressiveMesh _
) As Boolean
C# public static bool op_Equality(
ProgressiveMesh left,
ProgressiveMesh right
);
C++ public:
static bool operator==(
ProgressiveMesh^ left,
ProgressiveMesh^ right
);
JScript public static function op_Equality(
left : ProgressiveMesh,
right : ProgressiveMesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.ProgressiveMesh
The ProgressiveMesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.ProgressiveMesh
The ProgressiveMesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


ProgressiveMesh.op_Inequality(ProgressiveMesh,ProgressiveMesh) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As ProgressiveMesh, _
ByVal right As ProgressiveMesh _
) As Boolean
C# public static bool op_Inequality(
ProgressiveMesh left,
ProgressiveMesh right
);
C++ public:
static bool operator!=(
ProgressiveMesh^ left,
ProgressiveMesh^ right
);
JScript public static function op_Inequality(
left : ProgressiveMesh,
right : ProgressiveMesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.ProgressiveMesh
The ProgressiveMesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.ProgressiveMesh
The ProgressiveMesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


ProgressiveMesh.Optimize Method ()

Generates an output mesh with reordered faces and vertices to optimize performance.

Overload List

public Mesh Optimize(MeshFlags);
public Mesh Optimize(MeshFlags, out int, out int);
public Mesh Optimize(MeshFlags, out int, out int, out GraphicsStream);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.Optimize(MeshFlags) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Optimize Method

Generates an output mesh with reordered faces and vertices to optimize performance.

Definition

Visual Basic Public Function Optimize( _
ByVal flags As MeshFlags _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags
);
C++ public:
Mesh^ Optimize(
MeshFlags flags
);
JScript public function Optimize(
flags : MeshFlags
) : Mesh;

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform. This parameter can be set to one or more flags from MeshFlags (except Use32Bit, WriteOnly, IbWriteOnly, SimplifyFace, or SimplifyVertex).

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the optimized mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.Optimize(MeshFlags,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Optimize Method

Generates an output mesh with reordered faces and vertices to optimize performance.

Definition

Visual Basic Public Function Optimize( _
ByVal flags As MeshFlags, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
out int adjacencyOut,
out int faceRemap
);
C++ public:
Mesh^ Optimize(
MeshFlags flags,
[Out] int% adjacencyOut,
[Out] int% faceRemap
);
JScript public function Optimize(
flags : MeshFlags,
adjacencyOut : int,
faceRemap : int
) : Mesh;

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform. This parameter can be set to one or more flags from MeshFlags (except Use32Bit, WriteOnly, IbWriteOnly, SimplifyFace, or SimplifyVertex).
adjacencyOut System.Int32[]
Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh. The size of this array is the maximum number of faces multiplied by 3.
faceRemap System.Int32[]
Array that contains the new index for each face.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the optimized mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.Optimize(MeshFlags,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Optimize Method

Generates an output mesh with reordered faces and vertices to optimize performance.

Definition

Visual Basic Public Function Optimize( _
ByVal flags As MeshFlags, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh Optimize(
MeshFlags flags,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
Mesh^ Optimize(
MeshFlags flags,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function Optimize(
flags : MeshFlags,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
Type of optimization to perform. This parameter can be set to one or more flags from MeshFlags (except Use32Bit, WriteOnly, IbWriteOnly, SimplifyFace, or SimplifyVertex).
adjacencyOut System.Int32[]
Array for the face adjacency array of the optimized mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh. The size of this array is the maximum number of faces multiplied by 3.
faceRemap System.Int32[]
Array that contains the new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the optimized mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.OptimizeBaseLevelOfDetail Method ()

Optimizes the base level of detail (LOD) part of a ProgressiveMesh object.

Overload List

public void OptimizeBaseLevelOfDetail(MeshFlags);
public void OptimizeBaseLevelOfDetail(MeshFlags, out int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.OptimizeBaseLevelOfDetail(MeshFlags) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.OptimizeBaseLevelOfDetail Method

Optimizes the base level of detail (LOD) part of a ProgressiveMesh object.

Definition

Visual Basic Public Sub OptimizeBaseLevelOfDetail( _
ByVal flags As MeshFlags _
)
C# public void OptimizeBaseLevelOfDetail(
MeshFlags flags
);
C++ public:
void OptimizeBaseLevelOfDetail(
MeshFlags flags
);
JScript public function OptimizeBaseLevelOfDetail(
flags : MeshFlags
);

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
One or more Optimize* flags from the MeshFlags enumeration that specify the type of optimization to perform.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.OptimizeBaseLevelOfDetail(MeshFlags,Int32) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.OptimizeBaseLevelOfDetail Method

Optimizes the base level of detail (LOD) part of a ProgressiveMesh object.

Definition

Visual Basic Public Sub OptimizeBaseLevelOfDetail( _
ByVal flags As MeshFlags, _
ByRef faceRemap As Integer _
)
C# public void OptimizeBaseLevelOfDetail(
MeshFlags flags,
out int faceRemap
);
C++ public:
void OptimizeBaseLevelOfDetail(
MeshFlags flags,
[Out] int% faceRemap
);
JScript public function OptimizeBaseLevelOfDetail(
flags : MeshFlags,
faceRemap : int
);

Parameters

flags Microsoft.DirectX.Direct3D.MeshFlags
One or more Optimize* flags from the MeshFlags enumeration that specify the type of optimization to perform.
faceRemap System.Int32[]
Array of Int32 Leave Site values that indicate how the triangles were rearranged.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh Constructor ()

Creates a new instance of the ProgressiveMesh class.

Overload List

public ProgressiveMesh(ID3DXPMesh);
public ProgressiveMesh(IntPtr);
public ProgressiveMesh(Mesh, GraphicsStream, AttributeWeights, GraphicsStream, int, MeshFlags);
public ProgressiveMesh(Mesh, GraphicsStream, GraphicsStream, int, MeshFlags);
public ProgressiveMesh(Mesh, int[], AttributeWeights, int, MeshFlags);
public ProgressiveMesh(Mesh, int[], AttributeWeights, float[], int, MeshFlags);
public ProgressiveMesh(Mesh, int[], int, MeshFlags);
public ProgressiveMesh(Mesh, int[], float[], int, MeshFlags);

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(ID3DXPMesh) Constructor (Microsoft.DirectX.Direct3D)

ProgressiveMesh.ProgressiveMesh Constructor

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As ID3DXPMesh _
)
C# public ProgressiveMesh(
ID3DXPMesh pInterop
);
C++ public:
ProgressiveMesh(
ID3DXPMesh pInterop
);
JScript public function ProgressiveMesh(
pInterop : ID3DXPMesh
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.ID3DXPMesh
Unmanaged Component Object Model (COM) ID3DXPMesh interface pointer.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

ProgressiveMesh.ProgressiveMesh Constructor

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public ProgressiveMesh(
IntPtr unmanagedObject
);
C++ public:
ProgressiveMesh(
IntPtr unmanagedObject
);
JScript public function ProgressiveMesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXPMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,Int32[],Int32,MeshFlags) Constructor (Microsoft.DirectX.Direct3D)

ProgressiveMesh.ProgressiveMesh Constructor

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
int[] adjacency,
int minValue,
MeshFlags options
);
C++ public:
ProgressiveMesh(
Mesh^ mesh,
array<int>^ adjacency,
int minValue,
MeshFlags options
);
JScript public function ProgressiveMesh(
mesh : Mesh,
adjacency : int[],
minValue : int,
options : MeshFlags
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
minValue System.Int32
Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,Int32[],Single[],Int32,MeshFlags) Constructor (Microsoft.DirectX.Direct3D)

ProgressiveMesh.ProgressiveMesh Constructor

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexWeights() As Single, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
int[] adjacency,
float[] vertexWeights,
int minValue,
MeshFlags options
);
C++ public:
ProgressiveMesh(
Mesh^ mesh,
array<int>^ adjacency,
array<float>^ vertexWeights,
int minValue,
MeshFlags options
);
JScript public function ProgressiveMesh(
mesh : Mesh,
adjacency : int[],
vertexWeights : float[],
minValue : int,
options : MeshFlags
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexWeights System.Single[]
Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight for a given vertex, the less likely it is to be simplified out of existence.
minValue System.Int32
Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,Int32[],AttributeWeights,Int32,MeshFlags) Constructor (Microsoft.DirectX.Direct3D)

ProgressiveMesh.ProgressiveMesh Constructor

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
int minValue,
MeshFlags options
);
C++ public:
ProgressiveMesh(
Mesh^ mesh,
array<int>^ adjacency,
AttributeWeights vertexAttributeWeights,
int minValue,
MeshFlags options
);
JScript public function ProgressiveMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
minValue : int,
options : MeshFlags
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
minValue System.Int32
Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,Int32[],AttributeWeights,Single[],Int32,MeshFlags) Constructor (Microsoft.DirectX.Direct3D)

ProgressiveMesh.ProgressiveMesh Constructor

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights() As Single, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
float[] vertexWeights,
int minValue,
MeshFlags options
);
C++ public:
ProgressiveMesh(
Mesh^ mesh,
array<int>^ adjacency,
AttributeWeights vertexAttributeWeights,
array<float>^ vertexWeights,
int minValue,
MeshFlags options
);
JScript public function ProgressiveMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
vertexWeights : float[],
minValue : int,
options : MeshFlags
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights System.Single[]
Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight for a given vertex, the less likely it is to be simplified out of existence.
minValue System.Int32
Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,GraphicsStream,GraphicsStream,Int32,MeshFlags) Constructor (Microsoft.DirectX.Direct3D)

ProgressiveMesh.ProgressiveMesh Constructor

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexWeights As GraphicsStream, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream vertexWeights,
int minValue,
MeshFlags options
);
C++ public:
ProgressiveMesh(
Mesh^ mesh,
GraphicsStream^ adjacency,
GraphicsStream^ vertexWeights,
int minValue,
MeshFlags options
);
JScript public function ProgressiveMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexWeights : GraphicsStream,
minValue : int,
options : MeshFlags
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexWeights Microsoft.DirectX.GraphicsStream
A GraphicsStream of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight for a given vertex, the less likely it is to be simplified out of existence.
minValue System.Int32
Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.ProgressiveMesh(Mesh,GraphicsStream,AttributeWeights,GraphicsStream,Int32,MeshFlags) Constructor (Microsoft.DirectX.Direct3D)

ProgressiveMesh.ProgressiveMesh Constructor

Creates a new instance of the ProgressiveMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights As GraphicsStream, _
ByVal minValue As Integer, _
ByVal options As MeshFlags _
)
C# public ProgressiveMesh(
Mesh mesh,
GraphicsStream adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream vertexWeights,
int minValue,
MeshFlags options
);
C++ public:
ProgressiveMesh(
Mesh^ mesh,
GraphicsStream^ adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream^ vertexWeights,
int minValue,
MeshFlags options
);
JScript public function ProgressiveMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexAttributeWeights : AttributeWeights,
vertexWeights : GraphicsStream,
minValue : int,
options : MeshFlags
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the source mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the created progressive mesh.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An AttributeWeights structure that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights Microsoft.DirectX.GraphicsStream
A GraphicsStream of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight for a given vertex, the less likely it is to be simplified out of existence.
minValue System.Int32
Number of vertices or faces (depending on which flag is set in the param_MeshFlags_options parameter) by which to simplify the source mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
Simplification options for the mesh. Either SimplifyFace or SimplifyVertex can be set.

Remarks

This method generates a mesh in which the level of detail (LOD) can be adjusted from the current value to the param_Int32_minValue vertices or faces.

If the simplification process cannot reduce the mesh to param_Int32_minValue, the call still succeeds, because param_Int32_minValue is a desired minimum, not an absolute minimum.

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
CannotAttributeSortException | Attribute sort (D3DXMESHOPT_ATTRSORT) is not supported as an optimization technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ProgressiveMesh.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


ProgressiveMesh.TrimByFaces Method ()

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Overload List

public void TrimByFaces(int, int);
public void TrimByFaces(int, int, out int, out int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • TrimByVertices


ProgressiveMesh.TrimByFaces(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.TrimByFaces Method

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Definition

Visual Basic Public Sub TrimByFaces( _
ByVal newFacesMin As Integer, _
ByVal newFacesMax As Integer _
)
C# public void TrimByFaces(
int newFacesMin,
int newFacesMax
);
C++ public:
void TrimByFaces(
int newFacesMin,
int newFacesMax
);
JScript public function TrimByFaces(
newFacesMin : int,
newFacesMax : int
);

Parameters

newFacesMin System.Int32
New minimum number of faces. This value must fall between the current minimum and maximum number of faces.
newFacesMax System.Int32
New maximum number of faces. This value must fall between the current minimum and maximum number of faces.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • TrimByVertices


ProgressiveMesh.TrimByFaces(Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.TrimByFaces Method

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Definition

Visual Basic Public Sub TrimByFaces( _
ByVal newFacesMin As Integer, _
ByVal newFacesMax As Integer, _
ByRef faceRemap As Integer, _
ByRef vertRemap As Integer _
)
C# public void TrimByFaces(
int newFacesMin,
int newFacesMax,
out int faceRemap,
out int vertRemap
);
C++ public:
void TrimByFaces(
int newFacesMin,
int newFacesMax,
[Out] int% faceRemap,
[Out] int% vertRemap
);
JScript public function TrimByFaces(
newFacesMin : int,
newFacesMax : int,
faceRemap : int,
vertRemap : int
);

Parameters

newFacesMin System.Int32
New minimum number of faces. This value must fall between the current minimum and maximum number of faces.
newFacesMax System.Int32
New maximum number of faces. This value must fall between the current minimum and maximum number of faces.
faceRemap System.Int32[]
Array of one Int32 Leave Site value per face that contains face remap information.
vertRemap System.Int32[]
Array of one Int32 Leave Site value per vertex that contains vertex remap information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • TrimByVertices


ProgressiveMesh.TrimByVertices Method ()

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Overload List

public void TrimByVertices(int, int);
public void TrimByVertices(int, int, out int, out int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • TrimByFaces


ProgressiveMesh.TrimByVertices(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.TrimByVertices Method

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Definition

Visual Basic Public Sub TrimByVertices( _
ByVal newVerticesMin As Integer, _
ByVal newVerticesMax As Integer _
)
C# public void TrimByVertices(
int newVerticesMin,
int newVerticesMax
);
C++ public:
void TrimByVertices(
int newVerticesMin,
int newVerticesMax
);
JScript public function TrimByVertices(
newVerticesMin : int,
newVerticesMax : int
);

Parameters

newVerticesMin System.Int32
New minimum number of vertices. This value must fall between the current minimum and maximum number of vertices.
newVerticesMax System.Int32
New maximum number of vertices. This value must fall between the current minimum and maximum number of vertices.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • TrimByFaces


ProgressiveMesh.TrimByVertices(Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.TrimByVertices Method

Modifies the minimum and maximum level of detail (LOD) of a ProgressiveMesh object.

Definition

Visual Basic Public Sub TrimByVertices( _
ByVal newVerticesMin As Integer, _
ByVal newVerticesMax As Integer, _
ByRef faceRemap As Integer, _
ByRef vertRemap As Integer _
)
C# public void TrimByVertices(
int newVerticesMin,
int newVerticesMax,
out int faceRemap,
out int vertRemap
);
C++ public:
void TrimByVertices(
int newVerticesMin,
int newVerticesMax,
[Out] int% faceRemap,
[Out] int% vertRemap
);
JScript public function TrimByVertices(
newVerticesMin : int,
newVerticesMax : int,
faceRemap : int,
vertRemap : int
);

Parameters

newVerticesMin System.Int32
New minimum number of vertices. This value must fall between the current minimum and maximum number of vertices.
newVerticesMax System.Int32
New maximum number of vertices. This value must fall between the current minimum and maximum number of vertices.
faceRemap System.Int32[]
Array of one Int32 Leave Site value per face that contains face remap information.
vertRemap System.Int32[]
Array of one Int32 Leave Site value per vertex that contains vertex remap information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • TrimByFaces


ProgressiveMesh.UpdateUnmanagedPointer(ID3DXPMesh) Method (Microsoft.DirectX.Direct3D)

ProgressiveMesh.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this ProgressiveMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXPMesh pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXPMesh pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXPMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPMesh
Pointer to the ID3DXPMesh structure used to update the unmanaged pointer for this ProgressiveMesh object.


ProgressiveMesh.Adjacency Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Adjacency Property

Retrieves the face adjacency array of the mesh.

Definition

Visual Basic | Public ReadOnly Property Adjacency As Integer()
C# | public int[] Adjacency { get; }
C++ public:
property array<int>^ Adjacency {
array<int>^ get();
}
JScript | public function get Adjacency() : int[]

Property Value

System.Int32[]
Returned face adjacency array of the mesh. The face adjacency is stored as an array of arrays. The innermost array is three indices of adjacent triangles, and the outermost array is one set of face adjacencies per triangle in the mesh. If the edge has no adjacent faces, the value is 0xffffffff. The size of the adjacency array is the maximum number of faces multiplied by 3.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MaxFaces


ProgressiveMesh.Disposed Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public Shadows ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


ProgressiveMesh.MaxFaces Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.MaxFaces Property

Retrieves the maximum number of faces that a progressive mesh can support.

Definition

Visual Basic | Public ReadOnly Property MaxFaces As Integer
C# | public int MaxFaces { get; }
C++ public:
property int MaxFaces {
int get();
}
JScript | public function get MaxFaces() : int

Property Value

System.Int32
Maximum number of supported faces.

This property is read-only.


ProgressiveMesh.MaxVertices Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.MaxVertices Property

Retrieves the maximum number of vertices that a progressive mesh can support.

Definition

Visual Basic | Public ReadOnly Property MaxVertices As Integer
C# | public int MaxVertices { get; }
C++ public:
property int MaxVertices {
int get();
}
JScript | public function get MaxVertices() : int

Property Value

System.Int32
Maximum number of supported vertices.

This property is read-only.


ProgressiveMesh.MinFaces Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.MinFaces Property

Retrieves the minimum number of faces that a progressive mesh can support.

Definition

Visual Basic | Public ReadOnly Property MinFaces As Integer
C# | public int MinFaces { get; }
C++ public:
property int MinFaces {
int get();
}
JScript | public function get MinFaces() : int

Property Value

System.Int32
Minimum number of supported faces.

This property is read-only.


ProgressiveMesh.MinVertices Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.MinVertices Property

Retrieves the minimum number of vertices that a progressive mesh can support.

Definition

Visual Basic | Public ReadOnly Property MinVertices As Integer
C# | public int MinVertices { get; }
C++ public:
property int MinVertices {
int get();
}
JScript | public function get MinVertices() : int

Property Value

System.Int32
Minimum number of supported vertices.

This property is read-only.


ProgressiveMesh.NumberFaces Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.NumberFaces Property

Retrieves the currently set number of faces, or sets the current level of detail (LOD) to as close to the specified number of faces as possible.

Definition

Visual Basic Public Property NumberFaces( _
ByVal faces As Integer _
) As Integer
C# public int this[
int faces
] { set; }
C++ public:
property int NumberFaces [int] {
void set(int faces, int value);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

faces System.Int32
Target number of faces. This value specifies the desired change in the LOD.

Property Value

System.Int32

This property is write-only.

Remarks

If the current number of faces is greater than the maximum allowed, it is capped at the maximum number of faces returned by ProgressiveMesh.MaxFaces. If the current number of faces is less than the minimum required, it is capped at the minimum number of faces returned by ProgressiveMesh.MinFaces.

After this method is called, the number of faces might be slightly off, because edge collapse can sometimes introduce or remove a few faces. For example, setting the number of faces to an intermediate value such as 5, when 4 and 6 are possible, always produces a result of 4.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ProgressiveMesh.NumberVertices Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.NumberVertices Property

Sets the current level of detail (LOD) to as close to the specified number of vertices as possible.

Definition

Visual Basic Public Property NumberVertices( _
ByVal vertices As Integer _
) As Integer
C# public int this[
int vertices
] { set; }
C++ public:
property int NumberVertices [int] {
void set(int vertices, int value);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

vertices System.Int32
Target number of vertices. This value specifies the desired change in the LOD.

Property Value

System.Int32

This property is write-only.

Remarks

If the number of vertices is greater than the maximum allowed, it is capped at the maximum number of vertices returned by ProgressiveMesh.MaxVertices. If the number of vertices is less than the minimum required, it is capped at the minimum number of vertices returned by ProgressiveMesh.MinVertices.

After this method is called, the number of faces might be slightly off, because edge collapse can sometimes introduce or remove a few faces. For example, setting the number of faces to an intermediate value such as 5, when 4 and 6 are possible, always produces a result of 4.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


ProgressiveMesh.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

ProgressiveMesh.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXPMesh interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As ID3DXPMesh
C# | public ID3DXPMesh UnmanagedComPointer { get; }
C++ public:
property ID3DXPMesh UnmanagedComPointer {
ID3DXPMesh get();
}
JScript | public function get UnmanagedComPointer() : ID3DXPMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPMesh
Unmanaged ID3DXPMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


ProgressiveMesh.Disposing Event (Microsoft.DirectX.Direct3D)

ProgressiveMesh.Disposing Event

Occurs when the Dispose method is called or when the ProgressiveMesh object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.ProgressiveMesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the ProgressiveMesh object indicates whether that object has been disposed.


PrtBuffer Class (Microsoft.DirectX.Direct3D)

PrtBuffer Class

Used as a data buffer to store vertex and pixel data for use with precomputed radiance transfer (PRT) methods and functions.

Definition

Visual Basic Public Class PrtBuffer
Inherits MarshalByRefObject
Implements IDisposable
C# | public class PrtBuffer : MarshalByRefObject, IDisposable
C++ | public ref class PrtBuffer : MarshalByRefObject, IDisposable
JScript | public class PrtBuffer extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PrtBuffer object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddBuffer | Adds another buffer to the PrtBuffer and stores the results in PrtBuffer.
AttachGutterHelper | Associates a TextureGutterHelper object with the PrtBuffer object.
Dispose | Immediately releases the unmanaged resources used by the PrtBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
EvaluateGutterHelper | Applies stored texture gutter data to a PrtBuffer texture buffer.
ExtractTexture | Extracts coefficient data from a color channel of the buffer for a specified range of coefficients, and adds the data to a Texture object.
ExtractToMesh | Extracts coefficient data from a single-channel buffer and adds the data to a Mesh object.
Finalize | Allows the PrtBuffer object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FromFile | Loads into memory a PRT buffer that was saved to disk.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
LockBuffer | Locks a range of vertex or texel sample data and returns a GraphicsStream object containing the locked buffer memory.
LockBufferSingleArray | Locks a range of vertex or texel sample data and returns an array containing the locked buffer memory.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PrtBuffer | Initializes a new instance of the PrtBuffer class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PrtBuffer.Disposing event when called from within a derived class.
ReleaseGutterHelper | Disassociates an attached TextureGutterHelper object with the PrtBuffer object.
Resize | Changes the number of samples contained in the buffer.
Save | Saves a PRT buffer to disk.
ScaleBuffer | Multiplies every value in the buffer by a constant value.
UnlockBuffer | Unlocks the buffer locked by PrtBuffer.LockBuffer or PrtBuffer.LockBufferSingleArray.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PrtBuffer object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Height | Retrieves the height of the texture, in pixels.
IsTexture | Indicates whether the buffer contains a texture.
NumberChannels | Retrieves the number of color channels used in memory to store samples.
NumberCoefficients | Retrieves the number of scalars per color channel used in memory to store samples.
NumberSamples | Retrieves the number of vertices (or texels) sampled.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXPRTBuffer interface pointer.
Width | Retrieves the width of the texture, in pixels.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PrtBuffer

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PrtBuffer.AddBuffer(PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.AddBuffer Method

Adds another buffer to the PrtBuffer and stores the results in PrtBuffer.

Definition

Visual Basic Public Sub AddBuffer( _
ByVal buffer As PrtBuffer _
)
C# public void AddBuffer(
PrtBuffer buffer
);
C++ public:
void AddBuffer(
PrtBuffer^ buffer
);
JScript public function AddBuffer(
buffer : PrtBuffer
);

Parameters

buffer Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer that contains members to be added to the respective members of the PrtBuffer buffer.

Remarks

buffer and PrtBuffer must have the same number of samples, coefficients, and color channels; otherwise, the method will fail.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtBuffer.AttachGutterHelper(TextureGutterHelper) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.AttachGutterHelper Method

Associates a TextureGutterHelper object with the PrtBuffer object.

Definition

Visual Basic Public Sub AttachGutterHelper( _
ByVal helper As TextureGutterHelper _
)
C# public void AttachGutterHelper(
TextureGutterHelper helper
);
C++ public:
void AttachGutterHelper(
TextureGutterHelper^ helper
);
JScript public function AttachGutterHelper(
helper : TextureGutterHelper
);

Parameters

helper Microsoft.DirectX.Direct3D.TextureGutterHelper
A TextureGutterHelper object that contains texture gutter data.

Remarks

You must ensure that the number of PrtBuffer.AttachGutterHelper calls matches the number of PrtBuffer.ReleaseGutterHelper calls.

See Also

  • PrtBuffer.ReleaseGutterHelper


PrtBuffer.Dispose() Method (Microsoft.DirectX.Direct3D)

PrtBuffer.Dispose Method

Immediately releases the unmanaged resources used by the PrtBuffer object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~PrtBuffer();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PrtBuffer.Disposed
  • Microsoft.DirectX.Direct3D.PrtBuffer.Disposing


PrtBuffer.Equals(Object) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PrtBuffer.EvaluateGutterHelper() Method (Microsoft.DirectX.Direct3D)

PrtBuffer.EvaluateGutterHelper Method

Applies stored texture gutter data to a PrtBuffer texture buffer.

Definition

Visual Basic | Public Sub EvaluateGutterHelper()
C# | public void EvaluateGutterHelper();
C++ public:
void EvaluateGutterHelper();
JScript | public function EvaluateGutterHelper();

Remarks

This method makes an internal call to TextureGutterHelper.ApplyGutters to retrieve and apply texture gutter data.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtBuffer.ExtractTexture(Int32,Int32,Int32,Texture) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.ExtractTexture Method

Extracts coefficient data from a color channel of the buffer for a specified range of coefficients, and adds the data to a Texture object.

Definition

Visual Basic Public Sub ExtractTexture( _
ByVal channel As Integer, _
ByVal startCoefficient As Integer, _
ByVal numberCoefficients As Integer, _
ByVal texture As Texture _
)
C# public void ExtractTexture(
int channel,
int startCoefficient,
int numberCoefficients,
Texture texture
);
C++ public:
void ExtractTexture(
int channel,
int startCoefficient,
int numberCoefficients,
Texture^ texture
);
JScript public function ExtractTexture(
channel : int,
startCoefficient : int,
numberCoefficients : int,
texture : Texture
);

Parameters

channel System.Int32
Buffer color channel from which to extract texture data.
startCoefficient System.Int32
Starting value of the buffer coefficient from which to extract texture data.
numberCoefficients System.Int32
Number of scalars, beginning at startCoefficient, from which to extract texture data.
texture Microsoft.DirectX.Direct3D.Texture
A Texture object that will store coefficients.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.ExtractToMesh(Int32,DeclarationUsage,Int32,Mesh) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.ExtractToMesh Method

Extracts coefficient data from a single-channel buffer and adds the data to a Mesh object.

Definition

Visual Basic Public Sub ExtractToMesh( _
ByVal numberCoefficients As Integer, _
ByVal usage As DeclarationUsage, _
ByVal usageIndexStart As Integer, _
ByVal scene As Mesh _
)
C# public void ExtractToMesh(
int numberCoefficients,
DeclarationUsage usage,
int usageIndexStart,
Mesh scene
);
C++ public:
void ExtractToMesh(
int numberCoefficients,
DeclarationUsage usage,
int usageIndexStart,
Mesh^ scene
);
JScript public function ExtractToMesh(
numberCoefficients : int,
usage : DeclarationUsage,
usageIndexStart : int,
scene : Mesh
);

Parameters

numberCoefficients System.Int32
Number of coefficients per sample location. When using spherical harmonic (SH) precomputed radiance transfer (PRT), the number of coefficients should be Order2, where Order is the order of the SH evaluation. Order must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive.
usage Microsoft.DirectX.Direct3D.DeclarationUsage
A DeclarationUsage object that describes vertex usage of the mesh.
usageIndexStart System.Int32
Starting index for coefficients to be stored in the mesh.
scene Microsoft.DirectX.Direct3D.Mesh
A Mesh object that will store coefficients.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.Finalize() Method (Microsoft.DirectX.Direct3D)

PrtBuffer.Finalize Method

Allows the PrtBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~PrtBuffer();
C++ | !PrtBuffer();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


PrtBuffer.FromFile(String) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.FromFile Method

Loads into memory a precomputed radiance transfer (PRT) buffer that was saved to disk.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String _
) As PrtBuffer
C# public static PrtBuffer FromFile(
string filename
);
C++ public:
static PrtBuffer^ FromFile(
String^ filename
);
JScript public static function FromFile(
filename : String
) : PrtBuffer;

Parameters

filename System.String
Name of the file from which to load the buffer data.

Return Value

Microsoft.DirectX.Direct3D.PrtBuffer
Returns a PrtBuffer object that contains the PRT buffer data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PrtBuffer.Save


PrtBuffer.GetHashCode() Method (Microsoft.DirectX.Direct3D)

PrtBuffer.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


PrtBuffer.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPRTBuffer, which allows unmanaged COM clients to create an instance of the managed PrtBuffer class. Not supported.


PrtBuffer.LockBuffer(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.LockBuffer Method

Locks a range of vertex or texel sample data and returns a GraphicsStream object containing the locked buffer memory.

Definition

Visual Basic Public Function LockBuffer( _
ByVal start As Integer, _
ByVal numberSamples As Integer _
) As GraphicsStream
C# public GraphicsStream LockBuffer(
int start,
int numberSamples
);
C++ public:
GraphicsStream^ LockBuffer(
int start,
int numberSamples
);
JScript public function LockBuffer(
start : int,
numberSamples : int
) : GraphicsStream;

Parameters

start System.Int32
Starting index of the sample of vertex or texel data.
numberSamples System.Int32
Number of vertices (or texels) sampled.

Return Value

Microsoft.DirectX.GraphicsStream
Returns a GraphicsStream object containing the locked buffer memory.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.LockBufferSingleArray(Int32,Int32) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.LockBufferSingleArray Method

Locks a range of vertex or texel sample data and returns an array containing the locked buffer memory.

Definition

Visual Basic Public Function LockBufferSingleArray( _
ByVal start As Integer, _
ByVal numberSamples As Integer _
) As Single()
C# public float[] LockBufferSingleArray(
int start,
int numberSamples
);
C++ public:
array<float>^ LockBufferSingleArray(
int start,
int numberSamples
);
JScript public function LockBufferSingleArray(
start : int,
numberSamples : int
) : float[];

Parameters

start System.Int32
Starting index of the sample of vertex or texel data.
numberSamples System.Int32
Number of vertices (or texels) sampled.

Return Value

System.Single[]
Returns a floating-point array containing the locked buffer memory.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.op_Equality(PrtBuffer,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As PrtBuffer, _
ByVal right As PrtBuffer _
) As Boolean
C# public static bool op_Equality(
PrtBuffer left,
PrtBuffer right
);
C++ public:
static bool operator==(
PrtBuffer^ left,
PrtBuffer^ right
);
JScript public static function op_Equality(
left : PrtBuffer,
right : PrtBuffer
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PrtBuffer
The PrtBuffer object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PrtBuffer
The PrtBuffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PrtBuffer.op_Inequality(PrtBuffer,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As PrtBuffer, _
ByVal right As PrtBuffer _
) As Boolean
C# public static bool op_Inequality(
PrtBuffer left,
PrtBuffer right
);
C++ public:
static bool operator!=(
PrtBuffer^ left,
PrtBuffer^ right
);
JScript public static function op_Inequality(
left : PrtBuffer,
right : PrtBuffer
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PrtBuffer
The PrtBuffer object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PrtBuffer
The PrtBuffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


PrtBuffer.PrtBuffer Constructor ()

Initializes a new instance of the PrtBuffer class.

Overload List

public PrtBuffer(ID3DXPRTBuffer);
public PrtBuffer(int, int, int);
public PrtBuffer(int, int, int, int);
public PrtBuffer(IntPtr);
public PrtBuffer(string);

Remarks

The PrtBuffer constructor creates a PRT buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(ID3DXPRTBuffer) Constructor (Microsoft.DirectX.Direct3D)

PrtBuffer.PrtBuffer Constructor

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXPRTBuffer _
)
C# public PrtBuffer(
ID3DXPRTBuffer pUnk
);
C++ public:
PrtBuffer(
ID3DXPRTBuffer pUnk
);
JScript public function PrtBuffer(
pUnk : ID3DXPRTBuffer
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTBuffer
Unmanaged Component Object Model (COM) ID3DXPRTBuffer interface pointer.

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

PrtBuffer.PrtBuffer Constructor

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PrtBuffer(
IntPtr unmanagedObject
);
C++ public:
PrtBuffer(
IntPtr unmanagedObject
);
JScript public function PrtBuffer(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXPRTBuffer interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(String) Constructor (Microsoft.DirectX.Direct3D)

PrtBuffer.PrtBuffer Constructor

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal filename As String _
)
C# public PrtBuffer(
string filename
);
C++ public:
PrtBuffer(
String^ filename
);
JScript public function PrtBuffer(
filename : String
);

Parameters

filename System.String
Name of the file from which to load the buffer data.

Remarks

The PrtBuffer constructor creates a precomputed radiance transfer (PRT) buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(Int32,Int32,Int32,Int32) Constructor (Microsoft.DirectX.Direct3D)

PrtBuffer.PrtBuffer Constructor

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal numberCoefficients As Integer, _
ByVal numberChannels As Integer _
)
C# public PrtBuffer(
int width,
int height,
int numberCoefficients,
int numberChannels
);
C++ public:
PrtBuffer(
int width,
int height,
int numberCoefficients,
int numberChannels
);
JScript public function PrtBuffer(
width : int,
height : int,
numberCoefficients : int,
numberChannels : int
);

Parameters

width System.Int32
Width of the texture, in pixels
height System.Int32
Height of the texture, in pixels.
numberCoefficients System.Int32
Number of coefficients per sample location. When using spherical harmonic (SH) precomputed radiance transfer (PRT), the number of coefficients should be Order2, where Order is the order of the SH evaluation. Order must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The degree of the evaluation is Order - 1.
numberChannels System.Int32
Number of color channels to set in the mesh. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.

Remarks

The PrtBuffer constructor creates a PRT buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.PrtBuffer(Int32,Int32,Int32) Constructor (Microsoft.DirectX.Direct3D)

PrtBuffer.PrtBuffer Constructor

Initializes a new instance of the PrtBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal numberSamples As Integer, _
ByVal numberCoefficients As Integer, _
ByVal numberChannels As Integer _
)
C# public PrtBuffer(
int numberSamples,
int numberCoefficients,
int numberChannels
);
C++ public:
PrtBuffer(
int numberSamples,
int numberCoefficients,
int numberChannels
);
JScript public function PrtBuffer(
numberSamples : int,
numberCoefficients : int,
numberChannels : int
);

Parameters

numberSamples System.Int32
Number of vertices (or texels) sampled.
numberCoefficients System.Int32
Number of coefficients per sample location. When using spherical harmonic (SH) precomputed radiance transfer (PRT), the number of coefficients should be Order2, where Order is the order of the SH evaluation. Order must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The degree of the evaluation is Order - 1.
numberChannels System.Int32
Number of color channels to set in the mesh. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.

Remarks

The PrtBuffer constructor creates a PRT buffer that can be compressed or filled by a simulator. This method creates per-pixel, per-vertex, or volume buffers.

When the buffer is created, all values are initialized to zero.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.PrtBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


PrtBuffer.ReleaseGutterHelper() Method (Microsoft.DirectX.Direct3D)

PrtBuffer.ReleaseGutterHelper Method

Disassociates an attached TextureGutterHelper object with the PrtBuffer object.

Definition

Visual Basic | Public Sub ReleaseGutterHelper()
C# | public void ReleaseGutterHelper();
C++ public:
void ReleaseGutterHelper();
JScript | public function ReleaseGutterHelper();

Remarks

You must ensure that the number of PrtBuffer.AttachGutterHelper calls matches the number of PrtBuffer.ReleaseGutterHelper calls.

See Also

  • PrtBuffer.AttachGutterHelper


PrtBuffer.Resize(Int32) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.Resize Method

Changes the number of samples contained in the buffer.

Definition

Visual Basic Public Sub Resize( _
ByVal newSize As Integer _
)
C# public void Resize(
int newSize
);
C++ public:
void Resize(
int newSize
);
JScript public function Resize(
newSize : int
);

Parameters

newSize System.Int32
Number of samples to be contained in the buffer.

Remarks

Exceptions
OutOfMemoryException Leave Site Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtBuffer.Save Method ()

Saves a precomputed radiance transfer (PRT) buffer to disk.

Overload List

public static void Save(PrtBuffer, string);
public void Save(string);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtBuffer.FromFile


PrtBuffer.Save(String) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.Save Method

Saves a precomputed radiance transfer (PRT) buffer to disk.

Definition

Visual Basic Public Sub Save( _
ByVal filename As String _
)
C# public void Save(
string filename
);
C++ public:
void Save(
String^ filename
);
JScript public function Save(
filename : String
);

Parameters

filename System.String
Name of the file to which the buffer is to be saved.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtBuffer.FromFile


PrtBuffer.Save(PrtBuffer,String) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.Save Method

Saves a precomputed radiance transfer (PRT) buffer to disk.

Definition

Visual Basic Public Shared Sub Save( _
ByVal buffer As PrtBuffer, _
ByVal filename As String _
)
C# public static void Save(
PrtBuffer buffer,
string filename
);
C++ public:
static void Save(
PrtBuffer^ buffer,
String^ filename
);
JScript public static function Save(
buffer : PrtBuffer,
filename : String
);

Parameters

buffer Microsoft.DirectX.Direct3D.PrtBuffer
PrtBuffer object to be saved.
filename System.String
Name of the file to which the buffer is to be saved.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtBuffer.FromFile


PrtBuffer.ScaleBuffer(Single) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.ScaleBuffer Method

Multiplies every value in the buffer by a constant value.

Definition

Visual Basic Public Sub ScaleBuffer( _
ByVal scaleFactor As Single _
)
C# public void ScaleBuffer(
float scaleFactor
);
C++ public:
void ScaleBuffer(
float scaleFactor
);
JScript public function ScaleBuffer(
scaleFactor : float
);

Parameters

scaleFactor System.Single
Constant value used to scale the buffer. Every value in the buffer is replaced by the product of this value and the original buffer value.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtBuffer.UnlockBuffer() Method (Microsoft.DirectX.Direct3D)

PrtBuffer.UnlockBuffer Method

Unlocks the buffer locked by PrtBuffer.LockBuffer or PrtBuffer.LockBufferSingleArray.

Definition

Visual Basic | Public Sub UnlockBuffer()
C# | public void UnlockBuffer();
C++ public:
void UnlockBuffer();
JScript | public function UnlockBuffer();


PrtBuffer.UpdateUnmanagedPointer(ID3DXPRTBuffer) Method (Microsoft.DirectX.Direct3D)

PrtBuffer.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this PrtBuffer object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPRTBuffer _
)
C# public void UpdateUnmanagedPointer(
ID3DXPRTBuffer pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXPRTBuffer pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXPRTBuffer
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTBuffer
Pointer to the ID3DXPRTBuffer structure used to update the unmanaged pointer for this PrtBuffer object.


PrtBuffer.Disposed Property (Microsoft.DirectX.Direct3D)

PrtBuffer.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


PrtBuffer.Height Property (Microsoft.DirectX.Direct3D)

PrtBuffer.Height Property

Retrieves the height of the texture, in pixels.

Definition

Visual Basic | Public ReadOnly Property Height As Integer
C# | public int Height { get; }
C++ public:
property int Height {
int get();
}
JScript | public function get Height() : int

Property Value

System.Int32
An integer that represents the height of the texture, in pixels.

This property is read-only.

See Also

  • PrtBuffer.Width


PrtBuffer.IsTexture Property (Microsoft.DirectX.Direct3D)

PrtBuffer.IsTexture Property

Indicates whether the buffer contains a texture.

Definition

Visual Basic | Public ReadOnly Property IsTexture As Boolean
C# | public bool IsTexture { get; }
C++ public:
property bool IsTexture {
bool get();
}
JScript | public function get IsTexture() : boolean

Property Value

System.Boolean
A value that is true if the buffer contains a texture; otherwise, false.

This property is read-only.


PrtBuffer.NumberChannels Property (Microsoft.DirectX.Direct3D)

PrtBuffer.NumberChannels Property

Retrieves the number of color channels used in memory to store samples.

Definition

Visual Basic | Public ReadOnly Property NumberChannels As Integer
C# | public int NumberChannels { get; }
C++ public:
property int NumberChannels {
int get();
}
JScript | public function get NumberChannels() : int

Property Value

System.Int32
An integer that represents the number of color channels used in memory to store samples. The value generally will be either 1 to represent luminance values, or 3 to represent RGB values.

This property is read-only.


PrtBuffer.NumberCoefficients Property (Microsoft.DirectX.Direct3D)

PrtBuffer.NumberCoefficients Property

Retrieves the number of scalars per color channel used in memory to store samples.

Definition

Visual Basic | Public ReadOnly Property NumberCoefficients As Integer
C# | public int NumberCoefficients { get; }
C++ public:
property int NumberCoefficients {
int get();
}
JScript | public function get NumberCoefficients() : int

Property Value

System.Int32
An integer that represents the number of scalars per color channel used in memory to store samples.

This property is read-only.


PrtBuffer.NumberSamples Property (Microsoft.DirectX.Direct3D)

PrtBuffer.NumberSamples Property

Retrieves the number of vertices (or texels) sampled.

Definition

Visual Basic | Public ReadOnly Property NumberSamples As Integer
C# | public int NumberSamples { get; }
C++ public:
property int NumberSamples {
int get();
}
JScript | public function get NumberSamples() : int

Property Value

System.Int32
An integer that represents the number of vertices (or texels) sampled.

This property is read-only.


PrtBuffer.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

PrtBuffer.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXPRTBuffer interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXPRTBuffer
C# | public ID3DXPRTBuffer UnmanagedComPointer { get; }
C++ public:
property ID3DXPRTBuffer UnmanagedComPointer {
ID3DXPRTBuffer get();
}
JScript | public function get UnmanagedComPointer() : ID3DXPRTBuffer

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTBuffer
Unmanaged ID3DXPRTBuffer interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


PrtBuffer.Width Property (Microsoft.DirectX.Direct3D)

PrtBuffer.Width Property

Retrieves the width of the texture, in pixels.

Definition

Visual Basic | Public ReadOnly Property Width As Integer
C# | public int Width { get; }
C++ public:
property int Width {
int get();
}
JScript | public function get Width() : int

Property Value

System.Int32
An integer that represents the width of the texture, in pixels.

This property is read-only.

See Also

  • PrtBuffer.Height


PrtBuffer.Disposing Event (Microsoft.DirectX.Direct3D)

PrtBuffer.Disposing Event

Occurs when the Dispose method is called or when the PrtBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PrtBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PrtBuffer object indicates whether that object has been disposed.


PrtCompressedBuffer Class (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer Class

Stores a compressed version of a PrtBuffer object for use with principal component analysis (PCA).

Definition

Visual Basic Public Class PrtCompressedBuffer
Inherits MarshalByRefObject
Implements IDisposable
C# | public class PrtCompressedBuffer : MarshalByRefObject, IDisposable
C++ | public ref class PrtCompressedBuffer : MarshalByRefObject, IDisposable
JScript | public class PrtCompressedBuffer extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PrtCompressedBuffer object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the PrtCompressedBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
ExtractBasis | Extracts the mean and PCA basis vectors for a given cluster from a PrtCompressedBuffer object.
ExtractClusterIDs | Extracts the per-sample cluster identifiers (IDs) from a PrtCompressedBuffer object.
ExtractPca | Extracts the per-sample PCA projection coefficients from a PrtCompressedBuffer object.
ExtractTexture | Extracts the per-sample PCA projection coefficients from a PrtCompressedBuffer object and adds the data to a Texture object.
ExtractToMesh | Extracts the per-sample PCA projection coefficients from a PrtCompressedBuffer object and adds the data to a Mesh object.
Finalize | Allows the PrtCompressedBuffer object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FromFile | Loads into memory a compressed PRT buffer that was saved to disk.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
NormalizeData | Normalizes all PCA weights so that they are between -1 and 1. Basis vectors are modified to reflect this normalization.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PrtCompressedBuffer | Initializes a new instance of the PrtCompressedBuffer class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposing event when called from within a derived class.
Save | Saves a compressed precomputed radiance transfer (PRT) buffer to disk.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PrtCompressedBuffer object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Height | Retrieves the height of the texture, in pixels.
IsTexture | Indicates whether the compressed buffer contains a texture.
NumberChannels | Retrieves the number of color channels used in memory to store samples.
NumberClusters | Retrieves the number of clusters to use for compression.
NumberCoefficients | Retrieves the number of scalars per color channel used in memory to store samples.
NumberPcaVectors | Retrieves the number of PCA basis vectors to use in each cluster.
NumberSamples | Retrieves the number of vertices (or texels) sampled.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXPRTCompBuffer interface pointer.
Width | Retrieves the width of the texture, in pixels.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PrtCompressedBuffer

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PrtCompressedBuffer.Dispose() Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Dispose Method

Immediately releases the unmanaged resources used by the PrtCompressedBuffer object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~PrtCompressedBuffer();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposed
  • Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposing


PrtCompressedBuffer.Equals(Object) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PrtCompressedBuffer.ExtractBasis(Int32,Single[]) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.ExtractBasis Method

Extracts the mean and principal component analysis (PCA) basis vectors for a given cluster from a PrtCompressedBuffer object.

Definition

Visual Basic Public Sub ExtractBasis( _
ByVal cluster As Integer, _
ByVal clusterBasis() As Single _
)
C# public void ExtractBasis(
int cluster,
float[] clusterBasis
);
C++ public:
void ExtractBasis(
int cluster,
array<float>^ clusterBasis
);
JScript public function ExtractBasis(
cluster : int,
clusterBasis : float[]
);

Parameters

cluster System.Int32
Cluster for which the basis will be extracted.
clusterBasis System.Single[]
An array of basis vector data for cluster.

Remarks

The size of the clusterBasis data will be:

(1 + Number of PCA vectors per cluster) * (Number of coefficients) * (Number of color channels)

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.ExtractClusterIDs(Int32[]) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.ExtractClusterIDs Method

Extracts the per-sample cluster identifiers (IDs) from a PrtCompressedBuffer object.

Definition

Visual Basic Public Sub ExtractClusterIDs( _
ByVal clusterIds() As Integer _
)
C# public void ExtractClusterIDs(
int[] clusterIds
);
C++ public:
void ExtractClusterIDs(
array<int>^ clusterIds
);
JScript public function ExtractClusterIDs(
clusterIds : int[]
);

Parameters

clusterIds System.Int32[]
An integer array that will contain the cluster IDs. The required size of the array is the value returned by PrtCompressedBuffer.NumberSamples.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.ExtractPca(Int32,Int32,Single[]) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.ExtractPca Method

Extracts the per-sample principal component analysis (PCA) projection coefficients from a PrtCompressedBuffer object.

Definition

Visual Basic Public Sub ExtractPca( _
ByVal startPca As Integer, _
ByVal numberExtract As Integer, _
ByVal pcaCoefficients() As Single _
)
C# public void ExtractPca(
int startPca,
int numberExtract,
float[] pcaCoefficients
);
C++ public:
void ExtractPca(
int startPca,
int numberExtract,
array<float>^ pcaCoefficients
);
JScript public function ExtractPca(
startPca : int,
numberExtract : int,
pcaCoefficients : float[]
);

Parameters

startPca System.Int32
Starting index for PCA projection coefficients to extract from the buffer.
numberExtract System.Int32
Number of PCA projection coefficients to extract from the buffer.
pcaCoefficients System.Single[]
Pointer to the location where clustered principal component analysis (CPCA) coefficients are written. The size of the data written is (Number of Samples) * (Number of PCA Coefficients).

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.ExtractTexture(Int32,Int32,Texture) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.ExtractTexture Method

Extracts the per-sample principal component analysis (PCA) projection coefficients from a PrtCompressedBuffer object and adds the data to a Texture object.

Definition

Visual Basic Public Sub ExtractTexture( _
ByVal startPca As Integer, _
ByVal numberPca As Integer, _
ByVal texture As Texture _
)
C# public void ExtractTexture(
int startPca,
int numberPca,
Texture texture
);
C++ public:
void ExtractTexture(
int startPca,
int numberPca,
Texture^ texture
);
JScript public function ExtractTexture(
startPca : int,
numberPca : int,
texture : Texture
);

Parameters

startPca System.Int32
Starting value of the buffer coefficient from which to extract texture data.
numberPca System.Int32
Number of PCA coefficients to extract from the buffer.
texture Microsoft.DirectX.Direct3D.Texture
A Texture object that will store PCA coefficients.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.ExtractToMesh(Int32,DeclarationUsage,Int32,Mesh) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.ExtractToMesh Method

Extracts the per-sample principal component analysis (PCA) projection coefficients from a PrtCompressedBuffer object and adds the data to a Mesh object.

Definition

Visual Basic Public Sub ExtractToMesh( _
ByVal numberPca As Integer, _
ByVal usage As DeclarationUsage, _
ByVal usageIndexStart As Integer, _
ByVal scene As Mesh _
)
C# public void ExtractToMesh(
int numberPca,
DeclarationUsage usage,
int usageIndexStart,
Mesh scene
);
C++ public:
void ExtractToMesh(
int numberPca,
DeclarationUsage usage,
int usageIndexStart,
Mesh^ scene
);
JScript public function ExtractToMesh(
numberPca : int,
usage : DeclarationUsage,
usageIndexStart : int,
scene : Mesh
);

Parameters

numberPca System.Int32
Number of PCA coefficients to extract from the buffer.
usage Microsoft.DirectX.Direct3D.DeclarationUsage
Vertex usage descriptions of the mesh.
usageIndexStart System.Int32
Starting index for PCA coefficients to be stored in the mesh.
scene Microsoft.DirectX.Direct3D.Mesh
A Mesh object that will store PCA coefficients.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.Finalize() Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Finalize Method

Allows the PrtCompressedBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~PrtCompressedBuffer();
C++ | !PrtCompressedBuffer();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


PrtCompressedBuffer.FromFile(String) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.FromFile Method

Loads into memory a compressed precomputed radiance transfer (PRT) buffer that was saved to disk.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal filename As String _
) As PrtCompressedBuffer
C# public static PrtCompressedBuffer FromFile(
string filename
);
C++ public:
static PrtCompressedBuffer^ FromFile(
String^ filename
);
JScript public static function FromFile(
filename : String
) : PrtCompressedBuffer;

Parameters

filename System.String
Name of the file from which to load the compressed buffer data.

Return Value

Microsoft.DirectX.Direct3D.PrtCompressedBuffer
Returns a PrtCompressedBuffer object that contains the compressed PRT buffer data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PrtCompressedBuffer.Save


PrtCompressedBuffer.GetHashCode() Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


PrtCompressedBuffer.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPRTCompBuffer, which allows unmanaged COM clients to create an instance of the managed PrtCompressedBuffer class. Not supported.


PrtCompressedBuffer.NormalizeData() Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.NormalizeData Method

Normalizes all principal component analysis (PCA) weights so that they are between -1 and 1. Basis vectors are modified to reflect this normalization.

Definition

Visual Basic | Public Sub NormalizeData()
C# | public void NormalizeData();
C++ public:
void NormalizeData();
JScript | public function NormalizeData();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtCompressedBuffer.op_Equality(PrtCompressedBuffer,PrtCompressedBuffer) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As PrtCompressedBuffer, _
ByVal right As PrtCompressedBuffer _
) As Boolean
C# public static bool op_Equality(
PrtCompressedBuffer left,
PrtCompressedBuffer right
);
C++ public:
static bool operator==(
PrtCompressedBuffer^ left,
PrtCompressedBuffer^ right
);
JScript public static function op_Equality(
left : PrtCompressedBuffer,
right : PrtCompressedBuffer
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PrtCompressedBuffer
The PrtCompressedBuffer object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PrtCompressedBuffer
The PrtCompressedBuffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PrtCompressedBuffer.op_Inequality(PrtCompressedBuffer,PrtCompressedBuffer) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As PrtCompressedBuffer, _
ByVal right As PrtCompressedBuffer _
) As Boolean
C# public static bool op_Inequality(
PrtCompressedBuffer left,
PrtCompressedBuffer right
);
C++ public:
static bool operator!=(
PrtCompressedBuffer^ left,
PrtCompressedBuffer^ right
);
JScript public static function op_Inequality(
left : PrtCompressedBuffer,
right : PrtCompressedBuffer
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PrtCompressedBuffer
The PrtCompressedBuffer object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PrtCompressedBuffer
The PrtCompressedBuffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


PrtCompressedBuffer.PrtCompressedBuffer Constructor ()

Initializes a new instance of the PrtCompressedBuffer class.

Overload List

public PrtCompressedBuffer(CompressionQuality, int, int, PercentageCompleteCallback, PrtBuffer);
public PrtCompressedBuffer(ID3DXPRTCompBuffer);
public PrtCompressedBuffer(IntPtr);
public PrtCompressedBuffer(string);

Remarks

The PrtCompressedBuffer constructor creates a compressed PRT buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.PrtCompressedBuffer(ID3DXPRTCompBuffer) Constructor (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

Initializes a new instance of the PrtCompressedBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXPRTCompBuffer _
)
C# public PrtCompressedBuffer(
ID3DXPRTCompBuffer pUnk
);
C++ public:
PrtCompressedBuffer(
ID3DXPRTCompBuffer pUnk
);
JScript public function PrtCompressedBuffer(
pUnk : ID3DXPRTCompBuffer
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTCompBuffer
Unmanaged Component Object Model (COM) ID3DXPRTCompBuffer interface pointer.

Remarks

The PrtCompressedBuffer constructor creates a compressed precomputed radiance transfer (PRT) buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.PrtCompressedBuffer(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

Initializes a new instance of the PrtCompressedBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PrtCompressedBuffer(
IntPtr unmanagedObject
);
C++ public:
PrtCompressedBuffer(
IntPtr unmanagedObject
);
JScript public function PrtCompressedBuffer(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXPRTCompBuffer interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The PrtCompressedBuffer constructor creates a compressed precomputed radiance transfer (PRT) buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.PrtCompressedBuffer(String) Constructor (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

Initializes a new instance of the PrtCompressedBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal filename As String _
)
C# public PrtCompressedBuffer(
string filename
);
C++ public:
PrtCompressedBuffer(
String^ filename
);
JScript public function PrtCompressedBuffer(
filename : String
);

Parameters

filename System.String
Name of the file from which to load the buffer data.

Remarks

The PrtCompressedBuffer constructor creates a compressed precomputed radiance transfer (PRT) buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.PrtCompressedBuffer(CompressionQuality,Int32,Int32,PercentageCompleteCallback,PrtBuffer) Constructor (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.PrtCompressedBuffer Constructor

Initializes a new instance of the PrtCompressedBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal quality As CompressionQuality, _
ByVal numberClusters As Integer, _
ByVal numberPca As Integer, _
ByVal callback As PercentageCompleteCallback, _
ByVal buffer As PrtBuffer _
)
C# public PrtCompressedBuffer(
CompressionQuality quality,
int numberClusters,
int numberPca,
PercentageCompleteCallback callback,
PrtBuffer buffer
);
C++ public:
PrtCompressedBuffer(
CompressionQuality quality,
int numberClusters,
int numberPca,
PercentageCompleteCallback^ callback,
PrtBuffer^ buffer
);
JScript public function PrtCompressedBuffer(
quality : CompressionQuality,
numberClusters : int,
numberPca : int,
callback : PercentageCompleteCallback,
buffer : PrtBuffer
);

Parameters

quality Microsoft.DirectX.Direct3D.CompressionQuality
Quality of spherical harmonic (SH) compression.
numberClusters System.Int32
Number of clusters to use for compression.
numberPca System.Int32
Number of principal component analysis (PCA) basis vectors to use in each cluster.
callback Microsoft.DirectX.Direct3D.PercentageCompleteCallback
PercentageCompleteCallback delegate that represents the optional callback method used to compute the percentage of precomputed radiance transfer (PRT) compression computations completed.
buffer Microsoft.DirectX.Direct3D.PrtBuffer
Uncompressed PrtBuffer object to compress.

Remarks

The PrtCompressedBuffer constructor creates a compressed PRT buffer from an uncompressed PrtBuffer object.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtCompressedBuffer.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


PrtCompressedBuffer.Save Method ()

Saves a compressed precomputed radiance transfer (PRT) buffer to disk.

Overload List

public static void Save(PrtCompressedBuffer, string);
public void Save(string);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtCompressedBuffer.FromFile


PrtCompressedBuffer.Save(String) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Save Method

Saves a compressed precomputed radiance transfer (PRT) buffer to disk.

Definition

Visual Basic Public Sub Save( _
ByVal filename As String _
)
C# public void Save(
string filename
);
C++ public:
void Save(
String^ filename
);
JScript public function Save(
filename : String
);

Parameters

filename System.String
Name of the file to which the buffer is to be saved.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtCompressedBuffer.FromFile


PrtCompressedBuffer.Save(PrtCompressedBuffer,String) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Save Method

Saves a compressed precomputed radiance transfer (PRT) buffer to disk.

Definition

Visual Basic Public Shared Sub Save( _
ByVal buffer As PrtCompressedBuffer, _
ByVal filename As String _
)
C# public static void Save(
PrtCompressedBuffer buffer,
string filename
);
C++ public:
static void Save(
PrtCompressedBuffer^ buffer,
String^ filename
);
JScript public static function Save(
buffer : PrtCompressedBuffer,
filename : String
);

Parameters

buffer Microsoft.DirectX.Direct3D.PrtCompressedBuffer
PrtCompressedBuffer object to be saved.
filename System.String
Name of the file to which the buffer is to be saved.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • PrtCompressedBuffer.FromFile


PrtCompressedBuffer.UpdateUnmanagedPointer(ID3DXPRTCompBuffer) Method (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this PrtCompressedBuffer object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPRTCompBuffer _
)
C# public void UpdateUnmanagedPointer(
ID3DXPRTCompBuffer pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXPRTCompBuffer pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXPRTCompBuffer
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTCompBuffer
Pointer to the ID3DXPRTCompBuffer structure used to update the unmanaged pointer for this PrtCompressedBuffer object.


PrtCompressedBuffer.Disposed Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


PrtCompressedBuffer.Height Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Height Property

Retrieves the height of the texture, in pixels.

Definition

Visual Basic | Public ReadOnly Property Height As Integer
C# | public int Height { get; }
C++ public:
property int Height {
int get();
}
JScript | public function get Height() : int

Property Value

System.Int32
An integer that represents the height of the texture, in pixels.

This property is read-only.

See Also

  • PrtCompressedBuffer.Width


PrtCompressedBuffer.IsTexture Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.IsTexture Property

Indicates whether the compressed buffer contains a texture.

Definition

Visual Basic | Public ReadOnly Property IsTexture As Boolean
C# | public bool IsTexture { get; }
C++ public:
property bool IsTexture {
bool get();
}
JScript | public function get IsTexture() : boolean

Property Value

System.Boolean
A value that is true if the compressed buffer contains a texture, or false if it does not.

This property is read-only.


PrtCompressedBuffer.NumberChannels Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.NumberChannels Property

Retrieves the number of color channels used in memory to store samples.

Definition

Visual Basic | Public ReadOnly Property NumberChannels As Integer
C# | public int NumberChannels { get; }
C++ public:
property int NumberChannels {
int get();
}
JScript | public function get NumberChannels() : int

Property Value

System.Int32
An integer that represents the number of color channels used in memory to store samples. The value generally will be either 1 to represent luminance values, or 3 to represent RGB values.

This property is read-only.


PrtCompressedBuffer.NumberClusters Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.NumberClusters Property

Retrieves the number of clusters to use for compression.

Definition

Visual Basic | Public ReadOnly Property NumberClusters As Integer
C# | public int NumberClusters { get; }
C++ public:
property int NumberClusters {
int get();
}
JScript | public function get NumberClusters() : int

Property Value

System.Int32
An integer that represents the number of clusters to use for compression.

This property is read-only.


PrtCompressedBuffer.NumberCoefficients Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.NumberCoefficients Property

Retrieves the number of scalars per color channel used in memory to store samples.

Definition

Visual Basic | Public ReadOnly Property NumberCoefficients As Integer
C# | public int NumberCoefficients { get; }
C++ public:
property int NumberCoefficients {
int get();
}
JScript | public function get NumberCoefficients() : int

Property Value

System.Int32
An integer that represents the number of scalars per color channel used in memory to store samples.

This property is read-only.


PrtCompressedBuffer.NumberPcaVectors Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.NumberPcaVectors Property

Retrieves the number of principal component analysis (PCA) basis vectors to use in each cluster.

Definition

Visual Basic | Public ReadOnly Property NumberPcaVectors As Integer
C# | public int NumberPcaVectors { get; }
C++ public:
property int NumberPcaVectors {
int get();
}
JScript | public function get NumberPcaVectors() : int

Property Value

System.Int32
An integer that represents the number of PCA basis vectors to use in each cluster.

This property is read-only.


PrtCompressedBuffer.NumberSamples Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.NumberSamples Property

Retrieves the number of vertices (or texels) sampled.

Definition

Visual Basic | Public ReadOnly Property NumberSamples As Integer
C# | public int NumberSamples { get; }
C++ public:
property int NumberSamples {
int get();
}
JScript | public function get NumberSamples() : int

Property Value

System.Int32
An integer that represents the number of vertices (or texels) sampled.

This property is read-only.


PrtCompressedBuffer.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXPRTCompBuffer interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXPRTCompBuffer
C# | public ID3DXPRTCompBuffer UnmanagedComPointer { get; }
C++ public:
property ID3DXPRTCompBuffer UnmanagedComPointer {
ID3DXPRTCompBuffer get();
}
JScript | public function get UnmanagedComPointer() : ID3DXPRTCompBuffer

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTCompBuffer
Unmanaged ID3DXPRTCompBuffer interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


PrtCompressedBuffer.Width Property (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Width Property

Retrieves the width of the texture, in pixels.

Definition

Visual Basic | Public ReadOnly Property Width As Integer
C# | public int Width { get; }
C++ public:
property int Width {
int get();
}
JScript | public function get Width() : int

Property Value

System.Int32
An integer that represents the width of the texture, in pixels.

This property is read-only.

See Also

  • PrtCompressedBuffer.Height


PrtCompressedBuffer.Disposing Event (Microsoft.DirectX.Direct3D)

PrtCompressedBuffer.Disposing Event

Occurs when the Dispose method is called or when the PrtCompressedBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PrtCompressedBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PrtCompressedBuffer object indicates whether that object has been disposed.


PrtEngine Class (Microsoft.DirectX.Direct3D)

PrtEngine Class

The PrtEngine class is used to compute a precomputed radiance transfer (PRT) simulation. Its methods are typically used offline to compute per-vertex or per-texel transfer vectors in advance of real-time 3-D modeling.

Definition

Visual Basic Public Class PrtEngine
Inherits MarshalByRefObject
Implements IDisposable
C# | public class PrtEngine : MarshalByRefObject, IDisposable
C++ | public ref class PrtEngine : MarshalByRefObject, IDisposable
JScript | public class PrtEngine extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the PrtEngine object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
ClosestRayIntersects | Uses efficient ray-tracing in precomputed radiance transfer (PRT) simulations to determine whether a ray intersects a mesh. If an intersection is found, the method returns the index of the closest mesh face hit by the ray and the barycentric coordinates of the intersection point.
ComputeBounce | Computes the source radiance resulting from a single bounce of interreflected light. This method can be used for any lit scene, including a SH-based PRT model.
ComputeBounceAdaptive | Computes the source radiance resulting from a single bounce of interreflected light, using adaptive sampling. This method generates new vertices and faces on the mesh to more accurately approximate the PRT signal. This method can be used for any lit scene, including a SH-based PRT model.
ComputeDirectLightingSphericalHarmonics | Computes the direct-lighting contribution to 3-D objects where the source radiance is represented by a spherical harmonic (SH) approximation.
ComputeDirectLightingSphericalHarmonicsAdaptive | Computes the direct-lighting contribution to 3-D objects where the source radiance is represented by a SH approximation, using adaptive sampling. This method generates new vertices and faces on the mesh to more accurately approximate the PRT signal.
ComputeDirectLightingSphericalHarmonicsGpu | Uses the graphics processing unit (GPU) to compute the direct-lighting contribution to 3-D objects where the source radiance is represented by a SH approximation. Computing the lighting on the GPU will generally be much faster than on the CPU.
ComputeLDPrtCoefficients | Computes locally-deformable precomputed radiance transfer (LDPRT) coefficients relative to per-sample normal vectors to minimize the least-squares error with respect to input PrtBuffer data. These coefficients can be used with skinned or transformed normal vectors to model global effects on dynamic objects.
ComputeSubsurfaceScattering | Computes the source radiance resulting from subsurface scattering, using material properties set by PrtEngine.SetMeshMaterials. This method can be used only for materials defined per-vertex in a mesh object.
ComputeSubsurfaceScatteringAdaptive | Computes a transfer vector that maps source radiance to exit radiance resulting from subsurface scattering, using adaptive sampling and material properties set by PrtEngine.SetMeshMaterials. The method generates new vertices and faces on the mesh to more accurately approximate the PRT signal. This method can be used only for materials defined per-vertex in a mesh object.
static (Shared in Visual Basic) ComputeSuperClusters | Used with compressed results of the vertex version of the PRT simulator. Generates "superclusters," which are groups of clusters that can be drawn in the same draw call. A greedy algorithm that minimizes overdraw is used to group the clusters.
ComputeSurfSamplesBounce | Computes PRT samples for an arbitrary point (and normal vector).
ComputeSurfSamplesDirectSphericalHarmonics | Computes, at an arbitrary point not on a mesh, a transfer vector that maps source radiance (represented by a SH approximation) to exit radiance.
ComputeVolumeSamples | Computes a projection of the direct lighting from the previous light bounce into SH basis vectors that represent incident radiance at specified locations.
ComputeVolumeSamplesDirectSphericalHarmonics | Computes a projection of distant lighting into SH basis vectors that represent incident radiance at specified locations.
static (Shared in Visual Basic) ConcatenateMeshes | Concatenates a group of meshes into one common mesh. This method can optionally apply a matrix transformation to each input mesh and its texture coordinates.
Dispose | Immediately releases the unmanaged resources used by the PrtEngine object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
ExtractPerVertexAlbedo | Copies per-vertex albedo values from a mesh.
Finalize | Allows the PrtEngine object to free resources before it is destroyed by the garbage collector.
FreeBounceData | Frees memory used for temporary bounced-light simulation data.
FreeSubsurfaceScatteringData | Frees memory used for temporary subsurface light scattering simulation data.
GetAdaptedMesh | Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetVertexAlbedo | Retrieves albedo values of the mesh vertices.
MultiplyAlbedo | Multiplies each PRT vector by the per-vertex albedo.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PrtEngine | Initializes a new instance of the PrtEngine class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.PrtEngine.Disposing event when called from within a derived class.
ResampleBuffer | Resamples an input PrtBuffer object and saves it to an output PrtBuffer object. This method can be used to convert a vertex buffer to a texture buffer and vice-versa. It can also be used to convert single-channel buffers to 3-channel buffers and vice-versa.
RobustMeshRefine | Subdivides faces on a mesh, allowing for conservative adaptive sampling that will not eliminate features on the mesh.
ScaleMeshChunk | Scales all the samples associated with a given submesh. The method is useful for computing subsurface scattering.
SetCallback | Sets a delegate to an optional callback method that computes the percentage of SH computations completed and gives the caller the option of aborting the simulator.
SetMeshMaterials | Sets mesh material properties in the 3-D scene. Use this method to specify subsurface scattering parameters.
SetMinMaxIntersection | Sets the minimum and maximum distances of intersection between 3-D objects. These distance values can be used to control the minimum or maximum distance that objects can shadow or reflect light. For example, the method can be used to limit the shadowing of nearby features of a 3-D model.
SetPerTexelAlbedo | Sets an albedo value for each texel, overwriting previous albedo values.
SetPerTexelNormal | Sets a normal vector for each texel in a texture object. This method is used to store vertex normal vectors from a mesh (or interpolated vertex normals if pixel-based PRT is being computed).
SetPerVertexAlbedo | Sets an albedo value for each mesh vertex, overwriting previous albedo values.
SetSamplingInfo | Sets sampling properties used by the PRT simulator.
ShadowRayIntersects | Uses efficient ray-tracing in precomputed radiance transfer (PRT) simulations to determine whether a ray intersects a mesh. Typically used to determine whether a given point is in shadow.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this PrtEngine object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
NumberFaces | Retrieves the number of faces in the mesh, including any new faces added as a result of adaptive spatial sampling.
NumberVertices | Retrieves the number of vertices in the mesh, including any new vertices added as a result of adaptive spatial sampling.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXPRTEngine interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
PrtEngine

Remarks

To convert from RGB to luminance values, the following formula is used:

Luminance = R * 0.2125 + G * 0.7154 + B * 0.0721

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PrtEngine.ClosestRayIntersects(Vector3,Vector3,IntersectInformation) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ClosestRayIntersects Method

Uses efficient ray-tracing in precomputed radiance transfer (PRT) simulations to determine whether a ray intersects a mesh. If an intersection is found, the method returns the index of the closest mesh face hit by the ray and the barycentric coordinates of the intersection point.

Definition

Visual Basic Public Function ClosestRayIntersects( _
ByVal rayPosition As Vector3, _
ByVal rayDirection As Vector3, _
ByRef intersection As IntersectInformation _
) As Boolean
C# public bool ClosestRayIntersects(
Vector3 rayPosition,
Vector3 rayDirection,
out IntersectInformation intersection
);
C++ public:
bool ClosestRayIntersects(
Vector3 rayPosition,
Vector3 rayDirection,
[Out] IntersectInformation% intersection
);
JScript public function ClosestRayIntersects(
rayPosition : Vector3,
rayDirection : Vector3,
intersection : IntersectInformation
) : boolean;

Parameters

rayPosition Microsoft.DirectX.Vector3
A Vector3 structure that specifies the point where the ray begins.
rayDirection Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.
intersection Microsoft.DirectX.Direct3D.IntersectInformation
An IntersectInformation structure that represents the intersection point and the current mesh face that is first hit by the given ray, based upon stacking all blocker mesh faces in front of the current mesh.

Return Value

System.Boolean
true if the ray intersects the current mesh; false if it does not.

Remarks

Use SetMinMaxIntersection to set minimum and maximum distances of intersection with the ray.

The barycentric coordinate of the third vertex (vertex 2) of the triangle is 1 - ( U + V ).

This method executes slower than ShadowRayIntersects. Use ShadowRayIntersects if the location of the intersection point is not needed.


PrtEngine.ComputeBounce(PrtBuffer,PrtBuffer,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeBounce Method

Computes the source radiance resulting from a single bounce of interreflected light. This method can be used for any lit scene, including a spherical harmonic (SH)-based precomputed radiance transfer (PRT) model.

Definition

Visual Basic Public Sub ComputeBounce( _
ByVal bufferIn As PrtBuffer, _
ByVal bufferOut As PrtBuffer, _
ByVal dataComputed As PrtBuffer _
)
C# public void ComputeBounce(
PrtBuffer bufferIn,
PrtBuffer bufferOut,
PrtBuffer dataComputed
);
C++ public:
void ComputeBounce(
PrtBuffer^ bufferIn,
PrtBuffer^ bufferOut,
PrtBuffer^ dataComputed
);
JScript public function ComputeBounce(
bufferIn : PrtBuffer,
bufferOut : PrtBuffer,
dataComputed : PrtBuffer
);

Parameters

bufferIn Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that represents the 3-D object from the previous light bounce. This input buffer must have the proper number of color channels allocated for the simulation.
bufferOut Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that models a single bounce of the interreflected light. This output buffer must have the proper number of color channels allocated for the simulation.
dataComputed Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that is the running sum of all previous bufferOut outputs.

Remarks

The output does not include albedo, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each PRT vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.ComputeBounceAdaptive(PrtBuffer,Single,Single,Int32,PrtBuffer,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeBounceAdaptive Method

Computes the source radiance resulting from a single bounce of interreflected light, using adaptive sampling. This method generates new vertices and faces on the mesh to more accurately approximate the precomputed radiance transfer (PRT) signal. This method can be used for any lit scene, including a spherical harmonic (SH)-based PRT model.

Definition

Visual Basic Public Sub ComputeBounceAdaptive( _
ByVal bufferIn As PrtBuffer, _
ByVal adaptiveThreshold As Single, _
ByVal minEdgeLength As Single, _
ByVal maxSubDiv As Integer, _
ByVal bufferOut As PrtBuffer, _
ByVal dataComputed As PrtBuffer _
)
C# public void ComputeBounceAdaptive(
PrtBuffer bufferIn,
float adaptiveThreshold,
float minEdgeLength,
int maxSubDiv,
PrtBuffer bufferOut,
PrtBuffer dataComputed
);
C++ public:
void ComputeBounceAdaptive(
PrtBuffer^ bufferIn,
float adaptiveThreshold,
float minEdgeLength,
int maxSubDiv,
PrtBuffer^ bufferOut,
PrtBuffer^ dataComputed
);
JScript public function ComputeBounceAdaptive(
bufferIn : PrtBuffer,
adaptiveThreshold : float,
minEdgeLength : float,
maxSubDiv : int,
bufferOut : PrtBuffer,
dataComputed : PrtBuffer
);

Parameters

bufferIn Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that represents the 3-D object from the previous light bounce. This input buffer must have the proper number of color channels allocated for the simulation.
adaptiveThreshold System.Single
Threshold on the PRT vector to use for subdividing mesh vertices and faces. If less than 1e-6f, a default value of 1e-6f is specified.
minEdgeLength System.Single
Minimum face edge length that will be generated in adaptive sampling. If the method determines that the value is too small, a model-dependent value is specified. If zero, a default value of 4 is specified.
maxSubDiv System.Int32
Maximum level of subdivision of a face that will be used in adaptive sampling.
bufferOut Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that models a single bounce of the interreflected light. This output buffer must have the proper number of color channels allocated for the simulation.
dataComputed Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that is the running sum of all previous bufferOut outputs.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.ComputeDirectLightingSphericalHarmonics(Int32,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeDirectLightingSphericalHarmonics Method

Computes the direct-lighting contribution to 3-D objects where the source radiance is represented by a spherical harmonic (SH) approximation.

Definition

Visual Basic Public Sub ComputeDirectLightingSphericalHarmonics( _
ByVal shOrder As Integer, _
ByVal data As PrtBuffer _
)
C# public void ComputeDirectLightingSphericalHarmonics(
int shOrder,
PrtBuffer data
);
C++ public:
void ComputeDirectLightingSphericalHarmonics(
int shOrder,
PrtBuffer^ data
);
JScript public function ComputeDirectLightingSphericalHarmonics(
shOrder : int,
data : PrtBuffer
);

Parameters

shOrder System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
data Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that models the direct lighting contribution with the SH approximation. This buffer must have the proper number of color channels allocated for the simulation.

Remarks

The output does not include albedo, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each precomputed radiance transfer (PRT) vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.ComputeDirectLightingSphericalHarmonicsAdaptive(Int32,Single,Single,Int32,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeDirectLightingSphericalHarmonicsAdaptive Method

 Language:

Computes the direct-lighting contribution to 3-D objects where the source radiance is represented by a spherical harmonic (SH) approximation, using adaptive sampling. This method generates new vertices and faces on the mesh to more accurately approximate the precomputed radiance transfer (PRT) signal.

Definition

Visual Basic Public Sub ComputeDirectLightingSphericalHarmonicsAdaptive( _
ByVal shOrder As Integer, _
ByVal adaptiveThreshold As Single, _
ByVal minEdgeLength As Single, _
ByVal maxSubDiv As Integer, _
ByVal data As PrtBuffer _
)
C# public void ComputeDirectLightingSphericalHarmonicsAdaptive(
int shOrder,
float adaptiveThreshold,
float minEdgeLength,
int maxSubDiv,
PrtBuffer data
);
C++ public:
void ComputeDirectLightingSphericalHarmonicsAdaptive(
int shOrder,
float adaptiveThreshold,
float minEdgeLength,
int maxSubDiv,
PrtBuffer^ data
);
JScript public function ComputeDirectLightingSphericalHarmonicsAdaptive(
shOrder : int,
adaptiveThreshold : float,
minEdgeLength : float,
maxSubDiv : int,
data : PrtBuffer
);

Parameters

shOrder System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
adaptiveThreshold System.Single
Threshold on the PRT vector to use for subdividing mesh vertices and faces. If less than 1e-6f, a default value of 1e-6f is specified.
minEdgeLength System.Single
Minimum face edge length that will be generated in adaptive sampling. If the method determines that the value is too small, a model-dependent value is specified. If zero, a default value of 4 is specified.
maxSubDiv System.Int32
Maximum level of subdivision of a face that will be used in adaptive sampling.
data Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that contains the output data. This buffer must have the proper number of color channels allocated for the simulation.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.RobustMeshRefine


PrtEngine.ComputeDirectLightingSphericalHarmonicsGpu(Device,GpuSimulatorOption,Int32,Single,Single,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeDirectLightingSphericalHarmonicsGpu Method

Uses the graphics processing unit (GPU) to compute the direct-lighting contribution to 3-D objects where the source radiance is represented by a spherical harmonic (SH) approximation. Computing the lighting on the GPU will generally be much faster than on the CPU.

Definition

Visual Basic Public Sub ComputeDirectLightingSphericalHarmonicsGpu( _
ByVal device As Device, _
ByVal flags As GpuSimulatorOption, _
ByVal shOrder As Integer, _
ByVal zbias As Single, _
ByVal zangleBias As Single, _
ByVal data As PrtBuffer _
)
C# public void ComputeDirectLightingSphericalHarmonicsGpu(
Device device,
GpuSimulatorOption flags,
int shOrder,
float zbias,
float zangleBias,
PrtBuffer data
);
C++ public:
void ComputeDirectLightingSphericalHarmonicsGpu(
Device^ device,
GpuSimulatorOption flags,
int shOrder,
float zbias,
float zangleBias,
PrtBuffer^ data
);
JScript public function ComputeDirectLightingSphericalHarmonicsGpu(
device : Device,
flags : GpuSimulatorOption,
shOrder : int,
zbias : float,
zangleBias : float,
data : PrtBuffer
);

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device used to run the simulation on the GPU. The device must support pixel shader version 2.0 or higher.
flags Microsoft.DirectX.Direct3D.GpuSimulatorOption
The GPU simulation parameter that defines the resolution of the shadow z-buffer. Should be set to one of the GpuSimulatorOption enumeration values. To specifiy higher precision simulation, the GpuSimulatorOption.HighQuality value may be combined with one of the GpuSimulatorOption.ShadowResxxxx values.
shOrder System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
zbias System.Single
Bias in the normal direction.
zangleBias System.Single
Bias in the normal direction, scaled by one minus the cosine of the angle with the light ray.
data Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that contains the output data. This buffer must have the proper number of color channels allocated for the simulation.

Remarks

In this method, the albedo is not multiplied by the light signal, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each precomputed radiance transfer (PRT) vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.ComputeLDPrtCoefficients(PrtBuffer,Int32,Vector3[],PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeLDPrtCoefficients Method

Computes locally-deformable precomputed radiance transfer (LDPRT) coefficients relative to per-sample normal vectors to minimize the least-squares error with respect to input PrtBuffer data. These coefficients can be used with skinned or transformed normal vectors to model global effects on dynamic objects.

Definition

Visual Basic Public Sub ComputeLDPrtCoefficients( _
ByVal bufferIn As PrtBuffer, _
ByVal shOrder As Integer, _
ByVal normalData() As Vector3, _
ByVal bufferOut As PrtBuffer _
)
C# public void ComputeLDPrtCoefficients(
PrtBuffer bufferIn,
int shOrder,
Vector3[] normalData,
PrtBuffer bufferOut
);
C++ public:
void ComputeLDPrtCoefficients(
PrtBuffer^ bufferIn,
int shOrder,
array<Vector3>^ normalData,
PrtBuffer^ bufferOut
);
JScript public function ComputeLDPrtCoefficients(
bufferIn : PrtBuffer,
shOrder : int,
normalData : Vector3[],
bufferOut : PrtBuffer
);

Parameters

bufferIn Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that represents the spherical harmonic (SH) precomputed radiance transfer (PRT) data.
shOrder System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
normalData Microsoft.DirectX.Vector3[]
A Vector3 array to be filled with shader-optimal normal vectors for which LDPRT coefficients are optimized. This array must be the same size as the number of samples in bufferIn.
bufferOut Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that contains shOrder zonal harmonic coefficients per color channel per sample.

Remarks

Solutions for shading normal vectors can optionally be obtained with this method. These normal vectors, along with the LDPRT coefficients, can more accurately represent the PRT signal. In this case, the coefficients represent zonal harmonics oriented in the normal direction.

This method cannot be used with results from ComputeSurfSamplesBounce or ComputeSurfSamplesDirectSphericalHarmonics.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


PrtEngine.ComputeSubsurfaceScattering(PrtBuffer,PrtBuffer,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeSubsurfaceScattering Method

Computes the source radiance resulting from subsurface scattering, using material properties set by PrtEngine.SetMeshMaterials. This method can be used only for materials defined per-vertex in a mesh object.

Definition

Visual Basic Public Sub ComputeSubsurfaceScattering( _
ByVal bufferIn As PrtBuffer, _
ByVal bufferOut As PrtBuffer, _
ByVal dataComputed As PrtBuffer _
)
C# public void ComputeSubsurfaceScattering(
PrtBuffer bufferIn,
PrtBuffer bufferOut,
PrtBuffer dataComputed
);
C++ public:
void ComputeSubsurfaceScattering(
PrtBuffer^ bufferIn,
PrtBuffer^ bufferOut,
PrtBuffer^ dataComputed
);
JScript public function ComputeSubsurfaceScattering(
bufferIn : PrtBuffer,
bufferOut : PrtBuffer,
dataComputed : PrtBuffer
);

Parameters

bufferIn Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that represents the 3-D object from the previous light bounce. This input buffer must have the proper number of color channels allocated for the simulation.
bufferOut Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that models a single bounce of the subsurface-scattered light. This output buffer must have the proper number of color channels allocated for the simulation.
dataComputed Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that is the running sum of all previous bufferOut outputs.

Remarks

To model subsurface scattering, call this method for each bounce after a PrtEngine.ComputeDirectLighting... method is called.

The output does not include albedo, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each precomputed radiance transfer (PRT) vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • ComputeSubsurfaceScatteringAdaptive


PrtEngine.ComputeSubsurfaceScatteringAdaptive(PrtBuffer,Single,Single,Int32,PrtBuffer,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeSubsurfaceScatteringAdaptive Method

Computes a transfer vector that maps source radiance to exit radiance resulting from subsurface scattering, using adaptive sampling and material properties set by PrtEngine.SetMeshMaterials. The method generates new vertices and faces on the mesh to more accurately approximate the precomputed radiance transfer (PRT) signal. This method can be used only for materials defined per-vertex in a mesh object.

Definition

Visual Basic Public Sub ComputeSubsurfaceScatteringAdaptive( _
ByVal bufferIn As PrtBuffer, _
ByVal adaptiveThresh As Single, _
ByVal minEdgeLength As Single, _
ByVal maxSubdiv As Integer, _
ByVal bufferOut As PrtBuffer, _
ByVal dataComputed As PrtBuffer _
)
C# public void ComputeSubsurfaceScatteringAdaptive(
PrtBuffer bufferIn,
float adaptiveThresh,
float minEdgeLength,
int maxSubdiv,
PrtBuffer bufferOut,
PrtBuffer dataComputed
);
C++ public:
void ComputeSubsurfaceScatteringAdaptive(
PrtBuffer^ bufferIn,
float adaptiveThresh,
float minEdgeLength,
int maxSubdiv,
PrtBuffer^ bufferOut,
PrtBuffer^ dataComputed
);
JScript public function ComputeSubsurfaceScatteringAdaptive(
bufferIn : PrtBuffer,
adaptiveThresh : float,
minEdgeLength : float,
maxSubdiv : int,
bufferOut : PrtBuffer,
dataComputed : PrtBuffer
);

Parameters

bufferIn Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that represents the 3-D object from the previous light bounce. This input buffer must have the proper number of color channels allocated for the simulation.
adaptiveThresh System.Single
Threshold on the PRT vector to use for subdividing mesh vertices and faces. If less than 1e-6f, a default value of 1e-6f is specified.
minEdgeLength System.Single
Minimum face edge length that will be generated in adaptive sampling. If the method determines that the value is too small, a model-dependent value is specified.
maxSubdiv System.Int32
Maximum level of subdivision of a face that will be used in adaptive sampling. If zero, a default value of 4 is specified.
bufferOut Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that models a single bounce of the subsurface-scattered light. This output buffer must have the proper number of color channels allocated for the simulation.
dataComputed Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that is the running sum of all previous bufferOut outputs.

Remarks

To model subsurface scattering, call this method for each bounce after a PrtEngine.ComputeDirectLighting... method is called.

The output does not include albedo, and only incoming light is integrated in the simulator. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

Call PrtEngine.MultiplyAlbedo to multiply each PRT vector by the albedo.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • ComputeSubsurfaceScattering

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


PrtEngine.ComputeSuperClusters(Int32[],Mesh,Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeSuperClusters Method

Used with compressed results of the vertex version of the precomputed radiance transfer (PRT) simulator. Generates "superclusters," which are groups of clusters that can be drawn in the same draw call. A greedy algorithm that minimizes overdraw is used to group the clusters.

Definition

Visual Basic Public Shared Function ComputeSuperClusters( _
ByVal clusterIds() As Integer, _
ByVal scene As Mesh, _
ByVal maxNumberClusters As Integer, _
ByVal superClusterIds() As Integer _
) As Integer
C# public static int ComputeSuperClusters(
int[] clusterIds,
Mesh scene,
int maxNumberClusters,
int[] superClusterIds
);
C++ public:
static int ComputeSuperClusters(
array<int>^ clusterIds,
Mesh^ scene,
int maxNumberClusters,
array<int>^ superClusterIds
);
JScript public static function ComputeSuperClusters(
clusterIds : int[],
scene : Mesh,
maxNumberClusters : int,
superClusterIds : int[]
) : int;

Parameters

clusterIds System.Int32[]
An array of cluster identifiers (IDs) extracted from a compressed buffer by calling PrtCompressedBuffer.ExtractClusterIDs.
scene Microsoft.DirectX.Direct3D.Mesh
A Mesh that represents the composite scene passed to the simulator.
maxNumberClusters System.Int32
Maximum number of clusters allocated per super cluster.
superClusterIds System.Int32[]
An integer array that contains the index of the super cluster to which the corresponding cluster was assigned.

Return Value

System.Int32
Number of super clusters allocated.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.ComputeSurfSamplesBounce(PrtBuffer,Vector3[],Vector3[],PrtBuffer,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeSurfSamplesBounce Method

Computes precomputed radiance transfer (PRT) samples for an arbitrary point (and normal vector).

Definition

Visual Basic Public Sub ComputeSurfSamplesBounce( _
ByVal bufferIn As PrtBuffer, _
ByVal sampleLocations() As Vector3, _
ByVal sampleNormals() As Vector3, _
ByVal bufferOut As PrtBuffer, _
ByVal dataComputed As PrtBuffer _
)
C# public void ComputeSurfSamplesBounce(
PrtBuffer bufferIn,
Vector3[] sampleLocations,
Vector3[] sampleNormals,
PrtBuffer bufferOut,
PrtBuffer dataComputed
);
C++ public:
void ComputeSurfSamplesBounce(
PrtBuffer^ bufferIn,
array<Vector3>^ sampleLocations,
array<Vector3>^ sampleNormals,
PrtBuffer^ bufferOut,
PrtBuffer^ dataComputed
);
JScript public function ComputeSurfSamplesBounce(
bufferIn : PrtBuffer,
sampleLocations : Vector3[],
sampleNormals : Vector3[],
bufferOut : PrtBuffer,
dataComputed : PrtBuffer
);

Parameters

bufferIn Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that represents the 3-D object from the previous light bounce. This input buffer must have the proper number of color channels allocated for the simulation.
sampleLocations Microsoft.DirectX.Vector3[]
Number of sample locations.
sampleNormals Microsoft.DirectX.Vector3[]
Position for each sample.
bufferOut Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that models the direct lighting contribution to the point, using the spherical harmonic (SH) approximation. This output buffer must have the proper number of color channels allocated for the simulation.
dataComputed Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that is the running sum of all previous bufferOut outputs.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


PrtEngine.ComputeSurfSamplesDirectSphericalHarmonics(Int32,Vector3[],Vector3[],PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeSurfSamplesDirectSphericalHarmonics Method

Computes, at an arbitrary point not on a mesh, a transfer vector that maps source radiance (represented by a spherical harmonic (SH) approximation) to exit radiance.

Definition

Visual Basic Public Sub ComputeSurfSamplesDirectSphericalHarmonics( _
ByVal shOrder As Integer, _
ByVal sampleLocations() As Vector3, _
ByVal sampleNormals() As Vector3, _
ByVal data As PrtBuffer _
)
C# public void ComputeSurfSamplesDirectSphericalHarmonics(
int shOrder,
Vector3[] sampleLocations,
Vector3[] sampleNormals,
PrtBuffer data
);
C++ public:
void ComputeSurfSamplesDirectSphericalHarmonics(
int shOrder,
array<Vector3>^ sampleLocations,
array<Vector3>^ sampleNormals,
PrtBuffer^ data
);
JScript public function ComputeSurfSamplesDirectSphericalHarmonics(
shOrder : int,
sampleLocations : Vector3[],
sampleNormals : Vector3[],
data : PrtBuffer
);

Parameters

shOrder System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
sampleLocations Microsoft.DirectX.Vector3[]
Position for each sample.
sampleNormals Microsoft.DirectX.Vector3[]
Normal vector for each sample location.
data Microsoft.DirectX.Direct3D.PrtBuffer
Output PrtBuffer object that models the direct lighting contribution to the point, using the SH approximation.

Remarks

Do not use a texture buffer when calling this method.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


PrtEngine.ComputeVolumeSamples(PrtBuffer,Int32,Vector3[],PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeVolumeSamples Method

Computes a projection of the direct lighting from the previous light bounce into spherical harmonic (SH) basis vectors that represent incident radiance at specified locations.

Definition

Visual Basic Public Sub ComputeVolumeSamples( _
ByVal previousData As PrtBuffer, _
ByVal shOrder As Integer, _
ByVal sampleLocations() As Vector3, _
ByVal dataOut As PrtBuffer _
)
C# public void ComputeVolumeSamples(
PrtBuffer previousData,
int shOrder,
Vector3[] sampleLocations,
PrtBuffer dataOut
);
C++ public:
void ComputeVolumeSamples(
PrtBuffer^ previousData,
int shOrder,
array<Vector3>^ sampleLocations,
PrtBuffer^ dataOut
);
JScript public function ComputeVolumeSamples(
previousData : PrtBuffer,
shOrder : int,
sampleLocations : Vector3[],
dataOut : PrtBuffer
);

Parameters

previousData Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that represents the 3-D object from the previous light bounce. This buffer must have the proper number of color channels allocated for the simulation.
shOrder System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates shOrder2 coefficients. The degree of the evaluation is shOrder - 1.
sampleLocations Microsoft.DirectX.Vector3[]
An integer array that contains the position for each sample.
dataOut Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that projects the direct lighting from the previous light bounce into SH basis vectors. This buffer must have the proper number of color channels allocated for the simulation.

Remarks

This method computes how the light from the source radiance function is reflected off the surface that represents the scene (previousData) and arrives at each point in space specified by sampleLocations. The SH coefficients represent the mapping, at each sampleLocations point, of source radiance to transferred incident radiance.

To use this method successfully, you must set sampling over a sphere with the parameter isUsingSphere set to true and the parameter isUsingCosine set to false in a call to PrtEngine.SetSamplingInfo, otherwise an exception is thrown.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.ComputeVolumeSamplesDirectSphericalHarmonics


PrtEngine.ComputeVolumeSamplesDirectSphericalHarmonics(Int32,Int32,Vector3[],PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ComputeVolumeSamplesDirectSphericalHarmonics Method

 Language:

Computes a projection of distant lighting into spherical harmonic (SH) basis vectors that represent incident radiance at specified locations.

Definition

Visual Basic Public Sub ComputeVolumeSamplesDirectSphericalHarmonics( _
ByVal shOrderIn As Integer, _
ByVal shOrder As Integer, _
ByVal sampleLocations() As Vector3, _
ByVal dataOut As PrtBuffer _
)
C# public void ComputeVolumeSamplesDirectSphericalHarmonics(
int shOrderIn,
int shOrder,
Vector3[] sampleLocations,
PrtBuffer dataOut
);
C++ public:
void ComputeVolumeSamplesDirectSphericalHarmonics(
int shOrderIn,
int shOrder,
array<Vector3>^ sampleLocations,
PrtBuffer^ dataOut
);
JScript public function ComputeVolumeSamplesDirectSphericalHarmonics(
shOrderIn : int,
shOrder : int,
sampleLocations : Vector3[],
dataOut : PrtBuffer
);

Parameters

shOrderIn System.Int32
Order of the SH representation of distant lighting. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The degree of the evaluation is shOrderIn - 1.
shOrder System.Int32
Order of the SH representation of local lighting. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The degree of the evaluation is shOrder - 1.
sampleLocations Microsoft.DirectX.Vector3[]
An integer array that contains the position for each sample.
dataOut Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object that projects the distant lighting into SH basis vectors. This buffer must have the proper number of color channels allocated for the simulation. This method generates shOrderIn2 * shOrder2 scalars per channel at each sample location.

Remarks

This method computes how light from a distant source arrives at each point in space specified by sampleLocations. The SH coefficients represent the mapping, at each sampleLocations point, of source radiance to transferred incident radiance.

To use this method successfully, you must set sampling over a sphere with the parameter isUsingSphere set to true and the parameter isUsingCosine set to false in a call to PrtEngine.SetSamplingInfo, otherwise an exception is thrown.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.ComputeVolumeSamples


PrtEngine.ConcatenateMeshes(Mesh[],MeshFlags,Matrix[],Matrix[],VertexElement[],Device) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ConcatenateMeshes Method

Concatenates a group of meshes into one common mesh. This method can optionally apply a matrix transformation to each input mesh and its texture coordinates.

Definition

Visual Basic Public Shared Function ConcatenateMeshes( _
ByVal meshes() As Mesh, _
ByVal options As MeshFlags, _
ByVal geometryTransforms() As Matrix, _
ByVal textureTransforms() As Matrix, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As Mesh
C# public static Mesh ConcatenateMeshes(
Mesh[] meshes,
MeshFlags options,
Matrix[] geometryTransforms,
Matrix[] textureTransforms,
VertexElement[] declaration,
Device device
);
C++ public:
static Mesh^ ConcatenateMeshes(
array<Mesh^>^ meshes,
MeshFlags options,
array<Matrix>^ geometryTransforms,
array<Matrix>^ textureTransforms,
array<VertexElement>^ declaration,
Device^ device
);
JScript public static function ConcatenateMeshes(
meshes : Mesh[],
options : MeshFlags,
geometryTransforms : Matrix[],
textureTransforms : Matrix[],
declaration : VertexElement[],
device : Device
) : Mesh;

Parameters

meshes Microsoft.DirectX.Direct3D.Mesh[]
An array of Mesh objects to concatenate. These meshes can store precomputed radiance transfer (PRT) vectors.
options Microsoft.DirectX.Direct3D.MeshFlags
Combination of one or more flags from the MeshFlags enumeration, specifying creation options for the output mesh. Equivalent to the options parameter of the Mesh constructor.
geometryTransforms Microsoft.DirectX.Matrix[]
A geometry transformation Matrix array to apply to each submesh.
textureTransforms Microsoft.DirectX.Matrix[]
A texture transformation Matrix array to apply to the (u, v) coordinates of each submesh.
declaration Microsoft.DirectX.Direct3D.VertexElement[]
An array of VertexElement objects representing the vertex declaration to use for merging mesh data.
device Microsoft.DirectX.Direct3D.Device
A Device that is used to create the new mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
An Mesh object that represents the concatenated meshes.

Remarks

If no vertex declaration is given as part of the options parameter in the Mesh constructor, the method will generate a union of all of the vertex declarations of the submeshes, promoting channels and types if necessary.

The method will create an attribute table from attribute tables of the input meshes. To ensure creation of an attribute table, call ProgressiveMesh.Optimize with flags set to MeshFlags.OptimizeCompact and MeshFlags.OptimizeAttributeSort.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.Dispose() Method (Microsoft.DirectX.Direct3D)

PrtEngine.Dispose Method

Immediately releases the unmanaged resources used by the PrtEngine object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~PrtEngine();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.PrtEngine.Disposed
  • Microsoft.DirectX.Direct3D.PrtEngine.Disposing


PrtEngine.Equals(Object) Method (Microsoft.DirectX.Direct3D)

PrtEngine.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PrtEngine.ExtractPerVertexAlbedo(Mesh,DeclarationUsage,Int32) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ExtractPerVertexAlbedo Method

Copies per-vertex albedo values from a mesh.

Definition

Visual Basic Public Sub ExtractPerVertexAlbedo( _
ByVal mesh As Mesh, _
ByVal usage As DeclarationUsage, _
ByVal numberChannels As Integer _
)
C# public void ExtractPerVertexAlbedo(
Mesh mesh,
DeclarationUsage usage,
int numberChannels
);
C++ public:
void ExtractPerVertexAlbedo(
Mesh^ mesh,
DeclarationUsage usage,
int numberChannels
);
JScript public function ExtractPerVertexAlbedo(
mesh : Mesh,
usage : DeclarationUsage,
numberChannels : int
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
The Mesh object used to create the PrtEngine.
usage Microsoft.DirectX.Direct3D.DeclarationUsage
Vertex DeclarationUsage descriptions to copy from the mesh.
numberChannels System.Int32
Number of color channels to copy from the mesh. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.Finalize() Method (Microsoft.DirectX.Direct3D)

PrtEngine.Finalize Method

Allows the PrtEngine object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~PrtEngine();
C++ | !PrtEngine();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


PrtEngine.FreeBounceData() Method (Microsoft.DirectX.Direct3D)

PrtEngine.FreeBounceData Method

Frees memory used for temporary bounced-light simulation data.

Definition

Visual Basic | Public Sub FreeBounceData()
C# | public void FreeBounceData();
C++ public:
void FreeBounceData();
JScript | public function FreeBounceData();


PrtEngine.FreeSubsurfaceScatteringData() Method (Microsoft.DirectX.Direct3D)

PrtEngine.FreeSubsurfaceScatteringData Method

Frees memory used for temporary subsurface light scattering simulation data.

Definition

Visual Basic | Public Sub FreeSubsurfaceScatteringData()
C# | public void FreeSubsurfaceScatteringData();
C++ public:
void FreeSubsurfaceScatteringData();
JScript | public function FreeSubsurfaceScatteringData();


PrtEngine.GetAdaptedMesh Method ()

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Overload List

public Mesh GetAdaptedMesh(Device);
public Mesh GetAdaptedMesh(Device, int[]);
public Mesh GetAdaptedMesh(Device, int[], int[], float[]);
public Mesh GetAdaptedMesh(Device, int[], float[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetAdaptedMesh(Device) Method (Microsoft.DirectX.Direct3D)

PrtEngine.GetAdaptedMesh Method

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Definition

Visual Basic Public Function GetAdaptedMesh( _
ByVal device As Device _
) As Mesh
C# public Mesh GetAdaptedMesh(
Device device
);
C++ public:
Mesh^ GetAdaptedMesh(
Device^ device
);
JScript public function GetAdaptedMesh(
device : Device
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device used to create the output mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
The output Mesh object.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetAdaptedMesh(Device,Int32[],Single[]) Method (Microsoft.DirectX.Direct3D)

PrtEngine.GetAdaptedMesh Method

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Definition

Visual Basic Public Function GetAdaptedMesh( _
ByVal device As Device, _
ByVal vertRemap() As Integer, _
ByVal vertWeights() As Single _
) As Mesh
C# public Mesh GetAdaptedMesh(
Device device,
int[] vertRemap,
float[] vertWeights
);
C++ public:
Mesh^ GetAdaptedMesh(
Device^ device,
array<int>^ vertRemap,
array<float>^ vertWeights
);
JScript public function GetAdaptedMesh(
device : Device,
vertRemap : int[],
vertWeights : float[]
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device used to create the output mesh.
vertRemap System.Int32[]
A destination array containing the three original mesh vertices that are the parents of the current vertex.
vertWeights System.Single[]
A destination array containing blending factors for the vertRemap vertices.

Return Value

Microsoft.DirectX.Direct3D.Mesh
The output Mesh object.

Remarks

vertRemap and vertWeights can be used to interpolate any per-vertex value over the mesh.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetAdaptedMesh(Device,Int32[]) Method (Microsoft.DirectX.Direct3D)

PrtEngine.GetAdaptedMesh Method

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Definition

Visual Basic Public Function GetAdaptedMesh( _
ByVal device As Device, _
ByVal faceRemap() As Integer _
) As Mesh
C# public Mesh GetAdaptedMesh(
Device device,
int[] faceRemap
);
C++ public:
Mesh^ GetAdaptedMesh(
Device^ device,
array<int>^ faceRemap
);
JScript public function GetAdaptedMesh(
device : Device,
faceRemap : int[]
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device used to create the output mesh.
faceRemap System.Int32[]
The original mesh face that was split to generate the current face.

Return Value

Microsoft.DirectX.Direct3D.Mesh
The output Mesh object.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetAdaptedMesh(Device,Int32[],Int32[],Single[]) Method (Microsoft.DirectX.Direct3D)

PrtEngine.GetAdaptedMesh Method

Returns a mesh with modifications resulting from adaptive spatial sampling. The returned mesh contains only positions, normals, and texture coordinates (if defined).

Definition

Visual Basic Public Function GetAdaptedMesh( _
ByVal device As Device, _
ByVal faceRemap() As Integer, _
ByVal vertRemap() As Integer, _
ByVal vertWeights() As Single _
) As Mesh
C# public Mesh GetAdaptedMesh(
Device device,
int[] faceRemap,
int[] vertRemap,
float[] vertWeights
);
C++ public:
Mesh^ GetAdaptedMesh(
Device^ device,
array<int>^ faceRemap,
array<int>^ vertRemap,
array<float>^ vertWeights
);
JScript public function GetAdaptedMesh(
device : Device,
faceRemap : int[],
vertRemap : int[],
vertWeights : float[]
) : Mesh;

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device used to create the output mesh.
faceRemap System.Int32[]
The original mesh face that was split to generate the current face.
vertRemap System.Int32[]
A destination array containing the three original mesh vertices that are the parents of the current vertex.
vertWeights System.Single[]
A destination array containing blending factors for the vertRemap vertices.

Return Value

Microsoft.DirectX.Direct3D.Mesh
The output Mesh object.

Remarks

vertRemap and vertWeights can be used to interpolate any per-vertex value over the mesh.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


PrtEngine.GetHashCode() Method (Microsoft.DirectX.Direct3D)

PrtEngine.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


PrtEngine.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

PrtEngine.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXPRTEngine, which allows unmanaged COM clients to create an instance of the managed PrtEngine class. Not supported.


PrtEngine.GetVertexAlbedo(Int32) Method (Microsoft.DirectX.Direct3D)

PrtEngine.GetVertexAlbedo Method

Retrieves albedo values of the mesh vertices.

Definition

Visual Basic Public Function GetVertexAlbedo( _
ByVal numberVerts As Integer _
) As ColorValue()
C# public ColorValue[] GetVertexAlbedo(
int numberVerts
);
C++ public:
array<ColorValue>^ GetVertexAlbedo(
int numberVerts
);
JScript public function GetVertexAlbedo(
numberVerts : int
) : ColorValue[];

Parameters

numberVerts System.Int32
Number of vertices in the mesh.

Return Value

Microsoft.DirectX.Direct3D.ColorValue[]
A ColorValue array that contains albedo values of the mesh vertices.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.MultiplyAlbedo(PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.MultiplyAlbedo Method

Multiplies each precomputed radiance transfer (PRT) vector by the per-vertex albedo.

Definition

Visual Basic Public Sub MultiplyAlbedo( _
ByVal data As PrtBuffer _
)
C# public void MultiplyAlbedo(
PrtBuffer data
);
C++ public:
void MultiplyAlbedo(
PrtBuffer^ data
);
JScript public function MultiplyAlbedo(
data : PrtBuffer
);

Parameters

data Microsoft.DirectX.Direct3D.PrtBuffer
An output PrtBuffer object that will contain PRT vectors multiplied by the per-vertex albedo.

Remarks

If this output buffer is a texture object, then care must be taken to store the albedo of the texture at the same resolution as the simulation buffer.

The Compute... methods compute output buffers in which the light signal has not been multiplied by albedo. By not multiplying the albedo, you can model albedo variation at a finer scale than the source radiance, thereby yielding more accurate results from compression.

To include albedo in the rendered light model, call this method after one of the Compute... methods.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.ComputeDirectLightingSphericalHarmonics


PrtEngine.op_Equality(PrtEngine,PrtEngine) Method (Microsoft.DirectX.Direct3D)

PrtEngine.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As PrtEngine, _
ByVal right As PrtEngine _
) As Boolean
C# public static bool op_Equality(
PrtEngine left,
PrtEngine right
);
C++ public:
static bool operator==(
PrtEngine^ left,
PrtEngine^ right
);
JScript public static function op_Equality(
left : PrtEngine,
right : PrtEngine
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PrtEngine
The PrtEngine object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PrtEngine
The PrtEngine object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


PrtEngine.op_Inequality(PrtEngine,PrtEngine) Method (Microsoft.DirectX.Direct3D)

PrtEngine.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As PrtEngine, _
ByVal right As PrtEngine _
) As Boolean
C# public static bool op_Inequality(
PrtEngine left,
PrtEngine right
);
C++ public:
static bool operator!=(
PrtEngine^ left,
PrtEngine^ right
);
JScript public static function op_Inequality(
left : PrtEngine,
right : PrtEngine
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.PrtEngine
The PrtEngine object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.PrtEngine
The PrtEngine object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


PrtEngine.PrtEngine Constructor ()

Initializes a new instance of the PrtEngine class.

Overload List

public PrtEngine(ID3DXPRTEngine);
public PrtEngine(IntPtr);
public PrtEngine(Mesh, GraphicsStream, bool, Mesh);

Remarks

The PrtEngine class efficiently generates PRT simulations of a 3-D scene.

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.PrtEngine(ID3DXPRTEngine) Constructor (Microsoft.DirectX.Direct3D)

PrtEngine.PrtEngine Constructor

Initializes a new instance of the PrtEngine class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXPRTEngine _
)
C# public PrtEngine(
ID3DXPRTEngine pUnk
);
C++ public:
PrtEngine(
ID3DXPRTEngine pUnk
);
JScript public function PrtEngine(
pUnk : ID3DXPRTEngine
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTEngine
Unmanaged Component Object Model (COM) ID3DXPRTEngine interface pointer.

Remarks

The PrtEngine class efficiently generates precomputed radiance transfer (PRT) simulations of a 3-D scene.

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.PrtEngine(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

PrtEngine.PrtEngine Constructor

Initializes a new instance of the PrtEngine class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public PrtEngine(
IntPtr unmanagedObject
);
C++ public:
PrtEngine(
IntPtr unmanagedObject
);
JScript public function PrtEngine(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXPRTEngine interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The PrtEngine class efficiently generates precomputed radiance transfer (PRT) simulations of a 3-D scene.

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.PrtEngine(Mesh,GraphicsStream,Boolean,Mesh) Constructor (Microsoft.DirectX.Direct3D)

PrtEngine.PrtEngine Constructor

Initializes a new instance of the PrtEngine class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal extractUvs As Boolean, _
ByVal blockerMesh As Mesh _
)
C# public PrtEngine(
Mesh mesh,
GraphicsStream adjacency,
bool extractUvs,
Mesh blockerMesh
);
C++ public:
PrtEngine(
Mesh^ mesh,
GraphicsStream^ adjacency,
bool extractUvs,
Mesh^ blockerMesh
);
JScript public function PrtEngine(
mesh : Mesh,
adjacency : GraphicsStream,
extractUvs : boolean,
blockerMesh : Mesh
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
An input Mesh object that models the 3-D scene. This mesh must have an attribute table in which vertices are in a unique attribute.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
extractUvs System.Boolean
Set to true if textures will be used to store albedos or precomputed radiance transfer (PRT) vectors; otherwise, false.
blockerMesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that blocks the 3-D scene.

Remarks

The PrtEngine class efficiently generates PRT simulations of a 3-D scene.

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

PrtEngine.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.PrtEngine.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


PrtEngine.ResampleBuffer(PrtBuffer,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ResampleBuffer Method

Resamples an input PrtBuffer object and saves it to an output PrtBuffer object. This method can be used to convert a vertex buffer to a texture buffer and vice-versa. It can also be used to convert single-channel buffers to 3-channel buffers and vice-versa.

Definition

Visual Basic Public Sub ResampleBuffer( _
ByVal bufferIn As PrtBuffer, _
ByVal bufferOut As PrtBuffer _
)
C# public void ResampleBuffer(
PrtBuffer bufferIn,
PrtBuffer bufferOut
);
C++ public:
void ResampleBuffer(
PrtBuffer^ bufferIn,
PrtBuffer^ bufferOut
);
JScript public function ResampleBuffer(
bufferIn : PrtBuffer,
bufferOut : PrtBuffer
);

Parameters

bufferIn Microsoft.DirectX.Direct3D.PrtBuffer
The input PrtBuffer object.
bufferOut Microsoft.DirectX.Direct3D.PrtBuffer
The output PrtBuffer object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.RobustMeshRefine(Single,Int32) Method (Microsoft.DirectX.Direct3D)

PrtEngine.RobustMeshRefine Method

Subdivides faces on a mesh, allowing for conservative adaptive sampling that will not eliminate features on the mesh.

Definition

Visual Basic Public Sub RobustMeshRefine( _
ByVal minEdgeLength As Single, _
ByVal maxSubDiv As Integer _
)
C# public void RobustMeshRefine(
float minEdgeLength,
int maxSubDiv
);
C++ public:
void RobustMeshRefine(
float minEdgeLength,
int maxSubDiv
);
JScript public function RobustMeshRefine(
minEdgeLength : float,
maxSubDiv : int
);

Parameters

minEdgeLength System.Single
Minimum face edge length that will be generated in adaptive sampling. If zero, a reasonable default value will be substituted.
maxSubDiv System.Int32
Maximum level of subdivision of a face that will be used in adaptive sampling. If zero, a default value of 5 will be substituted.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • PrtEngine.ComputeBounceAdaptive
  • PrtEngine.ComputeDirectLightingSphericalHarmonicsAdaptive


PrtEngine.ScaleMeshChunk(Int32,Single,PrtBuffer) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ScaleMeshChunk Method

Scales all the samples associated with a given submesh. The method is useful for computing subsurface scattering.

Definition

Visual Basic Public Sub ScaleMeshChunk( _
ByVal meshChunk As Integer, _
ByVal scale As Single, _
ByVal data As PrtBuffer _
)
C# public void ScaleMeshChunk(
int meshChunk,
float scale,
PrtBuffer data
);
C++ public:
void ScaleMeshChunk(
int meshChunk,
float scale,
PrtBuffer^ data
);
JScript public function ScaleMeshChunk(
meshChunk : int,
scale : float,
data : PrtBuffer
);

Parameters

meshChunk System.Int32
Location in the mesh at which to start scaling samples.
scale System.Single
Value by which to multiply each vector in the submesh.
data Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object to receive rescaled samples in the submesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.SetCallback(PercentageCompleteCallback,Single) Method (Microsoft.DirectX.Direct3D)

PrtEngine.SetCallback Method

Sets a delegate to an optional callback method that computes the percentage of spherical harmonic (SH) computations completed and gives the caller the option of aborting the simulator.

Definition

Visual Basic Public Sub SetCallback( _
ByVal callback As PercentageCompleteCallback, _
ByVal frequency As Single _
)
C# public void SetCallback(
PercentageCompleteCallback callback,
float frequency
);
C++ public:
void SetCallback(
PercentageCompleteCallback^ callback,
float frequency
);
JScript public function SetCallback(
callback : PercentageCompleteCallback,
frequency : float
);

Parameters

callback Microsoft.DirectX.Direct3D.PercentageCompleteCallback
A PercentageCompleteCallback delegate to assign as the callback method.
frequency System.Single
Frequency of callback calls. The inverse of frequency is approximately the number of times the callback method will be called.


PrtEngine.SetMeshMaterials(SphericalHarmonicMaterial[],Int32,Boolean,Single) Method (Microsoft.DirectX.Direct3D)

PrtEngine.SetMeshMaterials Method

Sets mesh material properties in the 3-D scene. Use this method to specify subsurface scattering parameters.

Definition

Visual Basic Public Sub SetMeshMaterials( _
ByVal materials() As SphericalHarmonicMaterial, _
ByVal numberChannels As Integer, _
ByVal setAlbedo As Boolean, _
ByVal lengthScale As Single _
)
C# public void SetMeshMaterials(
SphericalHarmonicMaterial[] materials,
int numberChannels,
bool setAlbedo,
float lengthScale
);
C++ public:
void SetMeshMaterials(
array<SphericalHarmonicMaterial>^ materials,
int numberChannels,
bool setAlbedo,
float lengthScale
);
JScript public function SetMeshMaterials(
materials : SphericalHarmonicMaterial[],
numberChannels : int,
setAlbedo : boolean,
lengthScale : float
);

Parameters

materials Microsoft.DirectX.Direct3D.SphericalHarmonicMaterial[]
An array of SphericalHarmonicMaterial structures that contain the mesh material properties to set.
numberChannels System.Int32
Number of color channels to set in the mesh. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects. If you intend to change this parameter, first set the albedo using another method such as PrtEngine.SetPerTexelAlbedo or PrtEngine.SetPerVertexAlbedo.
setAlbedo System.Boolean
Set to true to set the albedo of the mesh to materials, overwriting all existing texel and vertex albedo values. Set to false to preserve all existing texel and vertex albedo values set by other methods; numberChannels must match the numberChannels parameter of the PrtBuffer constructor used to create the buffer.
lengthScale System.Single
Scale of the 3-D scene relative to a 1 mm cube. Used for subsurface scattering computations.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.SetMinMaxIntersection(Single,Single) Method (Microsoft.DirectX.Direct3D)

PrtEngine.SetMinMaxIntersection Method

Sets the minimum and maximum distances of intersection between 3-D objects. These distance values can be used to control the minimum or maximum distance that objects can shadow or reflect light. For example, the method can be used to limit the shadowing of nearby features of a 3-D model.

Definition

Visual Basic Public Sub SetMinMaxIntersection( _
ByVal min As Single, _
ByVal max As Single _
)
C# public void SetMinMaxIntersection(
float min,
float max
);
C++ public:
void SetMinMaxIntersection(
float min,
float max
);
JScript public function SetMinMaxIntersection(
min : float,
max : float
);

Parameters

min System.Single
Minimum intersection distance. Must be positive and less than max.
max System.Single
Maximum intersection distance. If 0.0f, the previous value will be used; otherwise, must be greater than min.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


PrtEngine.SetPerTexelAlbedo(Texture,Int32,TextureGutterHelper) Method (Microsoft.DirectX.Direct3D)

PrtEngine.SetPerTexelAlbedo Method

Sets an albedo value for each texel, overwriting previous albedo values.

Definition

Visual Basic Public Sub SetPerTexelAlbedo( _
ByVal albedoTexture As Texture, _
ByVal numberChannels As Integer, _
ByVal gutterHelper As TextureGutterHelper _
)
C# public void SetPerTexelAlbedo(
Texture albedoTexture,
int numberChannels,
TextureGutterHelper gutterHelper
);
C++ public:
void SetPerTexelAlbedo(
Texture^ albedoTexture,
int numberChannels,
TextureGutterHelper^ gutterHelper
);
JScript public function SetPerTexelAlbedo(
albedoTexture : Texture,
numberChannels : int,
gutterHelper : TextureGutterHelper
);

Parameters

albedoTexture Microsoft.DirectX.Direct3D.Texture
A Texture object in which to store albedo values.
numberChannels System.Int32
Number of color channels to set. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.
gutterHelper Microsoft.DirectX.Direct3D.TextureGutterHelper
A TextureGutterHelper object used to set gutter regions for the texture.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
WasStillDrawingException | The previous blit operation that is transferring information to or from this surface is incomplete.


PrtEngine.SetPerTexelNormal(Texture) Method (Microsoft.DirectX.Direct3D)

PrtEngine.SetPerTexelNormal Method

Sets a normal vector for each texel in a texture object. This method is used to store vertex normal vectors from a mesh (or interpolated vertex normals if pixel-based precomputed radiance transfer (PRT) is being computed).

Definition

Visual Basic Public Sub SetPerTexelNormal( _
ByVal normalTexture As Texture _
)
C# public void SetPerTexelNormal(
Texture normalTexture
);
C++ public:
void SetPerTexelNormal(
Texture^ normalTexture
);
JScript public function SetPerTexelNormal(
normalTexture : Texture
);

Parameters

normalTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that serves as an object space normal map in which to store normal vectors. The texture must have the same dimensions as PrtBuffer and must be able to store signed texture formats.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.SetPerVertexAlbedo(Array,Int32) Method (Microsoft.DirectX.Direct3D)

PrtEngine.SetPerVertexAlbedo Method

Sets an albedo value for each mesh vertex, overwriting previous albedo values.

Definition

Visual Basic Public Sub SetPerVertexAlbedo( _
ByVal dataIn As Array, _
ByVal numberChannel As Integer _
)
C# public void SetPerVertexAlbedo(
Array dataIn,
int numberChannel
);
C++ public:
void SetPerVertexAlbedo(
Array^ dataIn,
int numberChannel
);
JScript public function SetPerVertexAlbedo(
dataIn : Array,
numberChannel : int
);

Parameters

dataIn System.Array
An array of albedo data of the first sample.
numberChannel System.Int32
Number of color channels to set. Set to 1 to specify gray materials (R = G = B), or 3 to enable color bleeding effects.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.SetSamplingInfo(Int32,Boolean,Boolean,Boolean,Single) Method (Microsoft.DirectX.Direct3D)

PrtEngine.SetSamplingInfo Method

Sets sampling properties used by the precomputed radiance transfer (PRT) simulator.

Definition

Visual Basic Public Sub SetSamplingInfo( _
ByVal numberRays As Integer, _
ByVal isUsingSphere As Boolean, _
ByVal isUsingCosine As Boolean, _
ByVal isAdaptive As Boolean, _
ByVal adaptiveThreshold As Single _
)
C# public void SetSamplingInfo(
int numberRays,
bool isUsingSphere,
bool isUsingCosine,
bool isAdaptive,
float adaptiveThreshold
);
C++ public:
void SetSamplingInfo(
int numberRays,
bool isUsingSphere,
bool isUsingCosine,
bool isAdaptive,
float adaptiveThreshold
);
JScript public function SetSamplingInfo(
numberRays : int,
isUsingSphere : boolean,
isUsingCosine : boolean,
isAdaptive : boolean,
adaptiveThreshold : float
);

Parameters

numberRays System.Int32
Number of light rays to direct at each sample. Must be greater than zero.
isUsingSphere System.Boolean
Set to true if samples will be computed over a full sphere. Set to false if samples will be computed over a hemisphere.
isUsingCosine System.Boolean
Set to true to use a cosine weighting of samples. If both isUsingCosine and isUsingSphere are true, the method will fail.
isAdaptive System.Boolean
Must be false. Adaptive sampling is currently not implemented.
adaptiveThreshold System.Single
Ignored.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotImplementedException Leave Site | Not implemented.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


PrtEngine.ShadowRayIntersects(Vector3,Vector3) Method (Microsoft.DirectX.Direct3D)

PrtEngine.ShadowRayIntersects Method

Uses efficient ray-tracing in precomputed radiance transfer (PRT) simulations to determine whether a ray intersects a mesh. Typically used to determine whether a given point is in shadow.

Definition

Visual Basic Public Function ShadowRayIntersects( _
ByVal rayPosition As Vector3, _
ByVal rayDirection As Vector3 _
) As Boolean
C# public bool ShadowRayIntersects(
Vector3 rayPosition,
Vector3 rayDirection
);
C++ public:
bool ShadowRayIntersects(
Vector3 rayPosition,
Vector3 rayDirection
);
JScript public function ShadowRayIntersects(
rayPosition : Vector3,
rayDirection : Vector3
) : boolean;

Parameters

rayPosition Microsoft.DirectX.Vector3
A Vector3 structure that specifies the point where the ray begins.
rayDirection Microsoft.DirectX.Vector3
A Vector3 structure that specifies the direction of the ray.

Return Value

System.Boolean
true if the ray intersects the current mesh, or false if it does not.

Remarks

Use SetMinMaxIntersection to set minimum and maximum distances of intersection with the ray.

This method executes faster than ClosestRayIntersects.


PrtEngine.UpdateUnmanagedPointer(ID3DXPRTEngine) Method (Microsoft.DirectX.Direct3D)

PrtEngine.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this PrtEngine object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXPRTEngine _
)
C# public void UpdateUnmanagedPointer(
ID3DXPRTEngine pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXPRTEngine pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXPRTEngine
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTEngine
Pointer to the ID3DXPRTEngine structure used to update the unmanaged pointer for this PrtEngine object.


PrtEngine.Disposed Property (Microsoft.DirectX.Direct3D)

PrtEngine.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


PrtEngine.NumberFaces Property (Microsoft.DirectX.Direct3D)

PrtEngine.NumberFaces Property

Retrieves the number of faces in the mesh, including any new faces added as a result of adaptive spatial sampling.

Definition

Visual Basic | Public ReadOnly Property NumberFaces As Integer
C# | public int NumberFaces { get; }
C++ public:
property int NumberFaces {
int get();
}
JScript | public function get NumberFaces() : int

Property Value

System.Int32
Number of faces in the mesh, including any new faces added as a result of adaptive sampling.

This property is read-only.


PrtEngine.NumberVertices Property (Microsoft.DirectX.Direct3D)

PrtEngine.NumberVertices Property

Retrieves the number of vertices in the mesh, including any new vertices added as a result of adaptive spatial sampling.

Definition

Visual Basic | Public ReadOnly Property NumberVertices As Integer
C# | public int NumberVertices { get; }
C++ public:
property int NumberVertices {
int get();
}
JScript | public function get NumberVertices() : int

Property Value

System.Int32
Number of vertices in the mesh, including any new vertices added as a result of adaptive sampling.

This property is read-only.


PrtEngine.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

PrtEngine.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXPRTEngine interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXPRTEngine
C# | public ID3DXPRTEngine UnmanagedComPointer { get; }
C++ public:
property ID3DXPRTEngine UnmanagedComPointer {
ID3DXPRTEngine get();
}
JScript | public function get UnmanagedComPointer() : ID3DXPRTEngine

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXPRTEngine
Unmanaged ID3DXPRTEngine interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


PrtEngine.Disposing Event (Microsoft.DirectX.Direct3D)

PrtEngine.Disposing Event

Occurs when the Dispose method is called or when the PrtEngine object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.PrtEngine.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the PrtEngine object indicates whether that object has been disposed.


Query Class (Microsoft.DirectX.Direct3D)

Query Class

Performs asynchronous queries on a driver.

Definition

Visual Basic NotInheritable Public Class Query
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class Query : MarshalByRefObject, IDisposable
C++ | public ref class Query sealed : MarshalByRefObject, IDisposable
JScript | public final class Query extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Query object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Query object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Query object to free resources before it is destroyed by the garbage collector.
GetData | Retrieves the query information.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
Issue | Issues a query.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Query | Initializes a new instance of the Query class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Query.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Query object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the Device for the current query.
Disposed | Gets a value that indicates whether the object is disposed.
QueryType | Retrieves the query type for the current query.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DQuery9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Query

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Query.Dispose() Method (Microsoft.DirectX.Direct3D)

Query.Dispose Method

Immediately releases the unmanaged resources used by the Query object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Query();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Query.Disposed
  • Microsoft.DirectX.Direct3D.Query.Disposing


Query.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Query.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Query.Finalize() Method (Microsoft.DirectX.Direct3D)

Query.Finalize Method

Allows the Query object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Query();
C++ | !Query();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Query.GetData Method ()

Retrieves the query information.

Overload List

public object GetData(Type, bool);
public object GetData(Type, bool, out bool);


Query.GetData(Type,Boolean) Method (Microsoft.DirectX.Direct3D)

Query.GetData Method

Retrieves the query information.

Definition

Visual Basic Public Function GetData( _
ByVal returnDataType As Type, _
ByVal flush As Boolean _
) As Object
C# public object GetData(
Type returnDataType,
bool flush
);
C++ public:
Object^ GetData(
Type^ returnDataType,
bool flush
);
JScript public function GetData(
returnDataType : Type,
flush : boolean
) : Object;

Parameters

returnDataType System.Type
Specifies the Type Leave Site of the data to be queried.
flush System.Boolean
Set to true to flush the internally batched queries to the driver. Set to false to take no action.

Return Value

System.Object
An Object Leave Site that represents the returned query data.


Query.GetData(Type,Boolean,Boolean) Method (Microsoft.DirectX.Direct3D)

Query.GetData Method

Retrieves the query information.

Definition

Visual Basic Public Function GetData( _
ByVal returnDataType As Type, _
ByVal flush As Boolean, _
ByRef dataReturned As Boolean _
) As Object
C# public object GetData(
Type returnDataType,
bool flush,
out bool dataReturned
);
C++ public:
Object^ GetData(
Type^ returnDataType,
bool flush,
[Out] bool% dataReturned
);
JScript public function GetData(
returnDataType : Type,
flush : boolean,
dataReturned : boolean
) : Object;

Parameters

returnDataType System.Type
Specifies the Type Leave Site of the data to be queried.
flush System.Boolean
Set to true to flush the internally batched queries to the driver. Set to false to take no action.
dataReturned System.Boolean
Set to true if data is returned immediately; otherwise, false.

Return Value

System.Object
An Object Leave Site that represents the returned query data.


Query.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Query.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Query.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Query.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DQuery9, which allows unmanaged COM clients to create an instance of the managed Query class. Not supported.


Query.Issue(IssueFlags) Method (Microsoft.DirectX.Direct3D)

Query.Issue Method

Issues a query.

Definition

Visual Basic Public Sub Issue( _
ByVal flags As IssueFlags _
)
C# public void Issue(
IssueFlags flags
);
C++ public:
void Issue(
IssueFlags flags
);
JScript public function Issue(
flags : IssueFlags
);

Parameters

flags Microsoft.DirectX.Direct3D.IssueFlags
Member of the IssueFlags enumeration that specifies the type of state change for the query.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Query.op_Equality(Query,Query) Method (Microsoft.DirectX.Direct3D)

Query.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Query, _
ByVal right As Query _
) As Boolean
C# public static bool op_Equality(
Query left,
Query right
);
C++ public:
static bool operator==(
Query^ left,
Query^ right
);
JScript public static function op_Equality(
left : Query,
right : Query
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Query
The Query object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Query
The Query object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Query.op_Inequality(Query,Query) Method (Microsoft.DirectX.Direct3D)

Query.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Query, _
ByVal right As Query _
) As Boolean
C# public static bool op_Inequality(
Query left,
Query right
);
C++ public:
static bool operator!=(
Query^ left,
Query^ right
);
JScript public static function op_Inequality(
left : Query,
right : Query
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Query
The Query object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Query
The Query object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Query.Query Constructor ()

Initializes a new instance of the Query class.

Overload List

public Query(Device, QueryType);
public Query(IDirect3DQuery9);
public Query(IDirect3DQuery9, Device);
public Query(IntPtr);


Query.Query(IDirect3DQuery9) Constructor (Microsoft.DirectX.Direct3D)

Query.Query Constructor

Initializes a new instance of the Query class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DQuery9 _
)
C# public Query(
IDirect3DQuery9 pUnk
);
C++ public:
Query(
IDirect3DQuery9 pUnk
);
JScript public function Query(
pUnk : IDirect3DQuery9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DQuery9
Unmanaged Component Object Model (COM) IDirect3DQuery9 interface pointer.


Query.Query(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Query.Query Constructor

Initializes a new instance of the Query class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Query(
IntPtr unmanagedObject
);
C++ public:
Query(
IntPtr unmanagedObject
);
JScript public function Query(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DQuery9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Query.Query(IDirect3DQuery9,Device) Constructor (Microsoft.DirectX.Direct3D)

Query.Query Constructor

Initializes a new instance of the Query class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DQuery9, _
ByVal device As Device _
)
C# public Query(
IDirect3DQuery9 lp,
Device device
);
C++ public:
Query(
IDirect3DQuery9 lp,
Device^ device
);
JScript public function Query(
lp : IDirect3DQuery9,
device : Device
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DQuery9
Unmanaged Component Object Model (COM) IDirect3DQuery9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
Reference to the Device being queried.


Query.Query(Device,QueryType) Constructor (Microsoft.DirectX.Direct3D)

Query.Query Constructor

Initializes a new instance of the Query class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal queryType As QueryType _
)
C# public Query(
Device device,
QueryType queryType
);
C++ public:
Query(
Device^ device,
QueryType queryType
);
JScript public function Query(
device : Device,
queryType : QueryType
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to the Device being queried.
queryType Microsoft.DirectX.Direct3D.QueryType
Member of the QueryType enumeration that specifies the query type.


Query.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Query.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Query.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Query.UpdateUnmanagedPointer(IDirect3DQuery9) Method (Microsoft.DirectX.Direct3D)

Query.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Query object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DQuery9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DQuery9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DQuery9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DQuery9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DQuery9
Pointer to the IDirect3DQuery9 structure used to update the unmanaged pointer for this Query object.


Query.Device Property (Microsoft.DirectX.Direct3D)

Query.Device Property

Retrieves the Device for the current query.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device object associated with the current query.

This property is read-only.


Query.Disposed Property (Microsoft.DirectX.Direct3D)

Query.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Query.QueryType Property (Microsoft.DirectX.Direct3D)

Query.QueryType Property

Retrieves the query type for the current query.

Definition

Visual Basic | Public ReadOnly Property QueryType As QueryType
C# | public QueryType QueryType { get; }
C++ public:
property QueryType QueryType {
QueryType get();
}
JScript | public function get QueryType() : QueryType

Property Value

Microsoft.DirectX.Direct3D.QueryType
Member of the QueryType enumeration to retrieve.

This property is read-only.


Query.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Query.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DQuery9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DQuery9
C# | public IDirect3DQuery9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DQuery9 UnmanagedComPointer {
IDirect3DQuery9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DQuery9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DQuery9
Unmanaged IDirect3DQuery9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Query.Disposing Event (Microsoft.DirectX.Direct3D)

Query.Disposing Event

Occurs when the Dispose method is called or when the Query object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Query.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Query object indicates whether that object has been disposed.


RenderStateManager Class (Microsoft.DirectX.Direct3D)

RenderStateManager Class

Defines device render states.

Definition

Visual Basic NotInheritable Public Class RenderStateManager
Inherits Object
C# | public sealed class RenderStateManager : Object
C++ | public ref class RenderStateManager sealed : Object
JScript | public final class RenderStateManager extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AdaptiveTessellateW | Amount to adaptively tessellate in the w direction. The default value is 0.0f.
AdaptiveTessellateX | Amount to adaptively tessellate in the x direction. The default value is 0.0f.
AdaptiveTessellateY | Amount to adaptively tessellate in the y direction. The default value is 0.0f.
AdaptiveTessellateZ | Amount to adaptively tessellate in the z direction. The default value is 1.0f.
AlphaBlendEnable | Retrieves or sets a value to enable alpha-blended transparency.
AlphaBlendOperation | Retrieves or sets a value to select the arithmetic operation applied to the separate for the alpha channel (also known as separate alpha blending) when the render state, RenderStateManager.SeparateAlphaBlendEnabled, is set to true.
AlphaDestinationBlend | Contains a member of the Blend enumeration that represents the destination .
AlphaFunction | Retrieves or sets the comparison function for the alpha test.
AlphaSourceBlend | Contains a member of the Blend enumeration that represents the source .
AlphaTestEnable | Retrieves or sets a render state that enables a per-pixel alpha test.
Ambient | Retrieves or sets the ambient light color.
AmbientColor | Retrieves or sets the ambient light color.
AmbientMaterialSource | Retrieves or sets the ambient color source for lighting calculations.
AntiAliasedLineEnable | Retrieves or sets antialiasing of lines.
BlendFactor | Retrieves or sets a Color Leave Site object to use for a constant blend factor during alpha blending.
BlendFactorColor | Retrieves or sets a Color Leave Site object to use for a constant blend factor during alpha blending.
BlendOperation | Retrieves or sets a value used to select the arithmetic operation to apply when the alpha blend render state, RenderStateManager.AlphaBlendEnable, is set to true.
Clipping | Retrieves or sets a value to enable primitive clipping by Microsoft Direct3D.
ColorVertex | Retrieves or sets a value to enable or disable per-vertex color.
ColorWriteEnable | Retrieves or sets a value that enables a per-channel write for the render target color buffer.
ColorWriteEnable1 | Retrieves or sets additional RenderStateManager.ColorWriteEnable values for the device.
ColorWriteEnable2 | Retrieves or sets additional RenderStateManager.ColorWriteEnable values for devices.
ColorWriteEnable3 | Retrieves or sets additional RenderStateManager.ColorWriteEnable values for devices.
CounterClockwiseStencilFail | Retrieves the StencilOperation or sets it to perform if the counterclockwise (CCW) stencil test fails.
CounterClockwiseStencilFunction | Retrieves or sets the comparison function used by the counterclockwise (CCW) stencil test.
CounterClockwiseStencilPass | Retrieves the StencilOperation or sets it to perform, if both counterclockwise (CCW) stencil and z-tests pass.
CounterClockwiseStencilZBufferFail | Retrieves the StencilOperation or sets it to perform if the counterclockwise (CCW) stencil test passes and the z-test fails.
CullMode | Specifies how back-facing triangles are culled, if at all.
DebugMonitorTokenEnabled | Enables or disables the debug monitor token.
DepthBias | Sets or retrieves the depth bias for polygons.
DestinationBlend | Contains a member of the Blend enumeration that represents the destination .
DiffuseMaterialSource | Retrieves or sets the diffuse color source for lighting calculations.
DitherEnable | Enables or disables dithering.
EmissiveMaterialSource | Retrieves or sets the emissive color source for lighting calculations.
EnableAdaptiveTessellation | Enables or disables adaptive tessellation.
FillMode | Contains a member of the FillMode enumeration that represents the fill mode.
FogColor | Retrieves or sets the fog color.
FogColorValue | Retrieves or sets the fog color.
FogDensity | Retrieves or sets the fog density for pixel or vertex fog used in exponential fog modes.
FogEnable | Enables or disables fog blending.
FogEnd | Retrieves or sets the depth at which pixel or vertex fog effects end for linear fog mode.
FogStart | Retrieves or sets the depth at which pixel or vertex fog effects begin for linear fog mode.
FogTableMode | Retrieves or sets the fog formula to use for pixel fog.
FogVertexMode | Retrieves or sets the fog formula to use for vertex fog.
IndexedVertexBlendEnable | Enables or disables indexed vertex blending.
LastPixel | Enables or disables drawing of the last pixel in a line.
Lighting | Enables or disables Direct3D lighting.
LocalViewer | Specifies whether to use camera-relative specular highlights or orthogonal specular highlights.
MaxTessellationLevel | Retrieves or sets the maximum tessellation level.
MinTessellationLevel | Retrieves or sets the minimum tessellation level.
MultiSampleAntiAlias | Determines how individual samples are computed when using a multisample render target buffer.
MultiSampleMask | Retrieves or sets a render state that enables use of a multisample buffer as an accumulation buffer.
NormalDegree | Retrieves or sets the degree of interpolation (linear, cubic, quadratic, or quintic) using the N-patch normal.
NormalizeNormals | Enables or disables automatic normalization of vertex normals.
PatchEdgeStyle | Retrieves or sets the tessellation mode for patch edges.
PointScaleA | Controls the distance-based size attenuation for point primitives.
PointScaleB | Controls the distance-based size attenuation for point primitives.
PointScaleC | Controls the distance-based size attenuation for point primitives.
PointScaleEnable | Controls how the computation of size for point sprites is handled.
PointSize | Specifies the size to use for point size computation in cases in which point size is not specified for each vertex.
PointSizeMax | Specifies the maximum size to which point sprites can be set.
PointSizeMin | Specifies the minimum size to which point sprites can be set.
PointSpriteEnable | Controls how point sprites are rendered.
PositionDegree | Retrieves or sets the N-patch position interpolation degree.
RangeFogEnable | Retrieves or sets enabling of range-based vertex fog.
ReferenceAlpha | Specifies a reference alpha value against which pixels are tested when alpha testing is enabled.
ReferenceStencil | Specifies a reference value to use for the stencil test.
ScissorTestEnable | Enables or disables scissor testing.
SeparateAlphaBlendEnabled | Enables or disables the separate for the alpha channel.
ShadeMode | Contains one or more members of the ShadeMode enumeration.
SlopeScaleDepthBias | Retrieves or sets a value used to determine how much bias can be applied to coplanar primitives to reduce z-fighting.
SourceBlend | Contains a member of the Blend enumeration.
SpecularEnable | Retrieves or sets a render state that enables specular highlights.
SpecularMaterialSource | Retrieves or sets the specular color source for lighting calculations.
SrgbWriteEnable | Retrieves or sets a render state that enables render-target writes to be gamma corrected to sRGB.
StencilEnable | Retrieves or sets stencil enabling.
StencilFail | Retrieves or sets the stencil operation to perform if the stencil test fails.
StencilFunction | Retrieves or sets the comparison function for the stencil test.
StencilMask | Retrieves or sets the mask applied to the reference value and each stencil buffer entry to determine the significant bits for the stencil test.
StencilPass | Retrieves or sets the stencil operation to perform if both the stencil test and the depth test (z-test) pass.
StencilWriteMask | Retrieves or sets the write mask applied to values written into the stencil buffer.
StencilZBufferFail | Retrieves or sets the stencil operation to perform if the stencil test passes and the depth test (z-test) fails.
TextureFactor | Retrieves or sets the color used for multiple-texture blending with the TextureArgument.TFactor texture blending argument or the TextureOperation.BlendFactorAlpha texture blending operation.
TweenFactor | Retrieves or sets a floating-point value that controls the tween factor.
TwoSidedStencilMode | Enables or disables two-sided stenciling.
UseWBuffer | Enables or disables w-buffering.
VertexBlend | Retrieves or sets the number of matrices to use to perform geometry blending.
Wrap0 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap1 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap10 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap11 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap12 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap13 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap14 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap15 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap2 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap3 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap4 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap5 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap6 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap7 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap8 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
Wrap9 | Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.
ZBufferEnable | Enables or disables depth buffering.
ZBufferFunction | Retrieves or sets the comparison function for the z-buffer test.
ZBufferWriteEnable | Enables or disables writing to the depth buffer.

Inheritance Hierarchy

Object Leave Site
RenderStateManager

Remarks

The Device.RenderState property can be used to obtain the RenderStateManager object for the device.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ToString() Method (Microsoft.DirectX.Direct3D)

RenderStateManager.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AdaptiveTessellateW Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AdaptiveTessellateW Property

Amount to adaptively tessellate in the w direction. The default value is 0.0f.

Definition

Visual Basic | Public Property AdaptiveTessellateW As Single
C# | public float AdaptiveTessellateW { get; set; }
C++ public:
property float AdaptiveTessellateW {
float get();
void set(float value);
}
JScript public function get AdaptiveTessellateW() : float
public function set AdaptiveTessellateW(float);

Property Value

System.Single
A Single Leave Site that sets or receives the value.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AdaptiveTessellateX Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AdaptiveTessellateX Property

Amount to adaptively tessellate in the x direction. The default value is 0.0f.

Definition

Visual Basic | Public Property AdaptiveTessellateX As Single
C# | public float AdaptiveTessellateX { get; set; }
C++ public:
property float AdaptiveTessellateX {
float get();
void set(float value);
}
JScript public function get AdaptiveTessellateX() : float
public function set AdaptiveTessellateX(float);

Property Value

System.Single
A Single Leave Site that sets or receives the value.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AdaptiveTessellateY Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AdaptiveTessellateY Property

Amount to adaptively tessellate in the y direction. The default value is 0.0f.

Definition

Visual Basic | Public Property AdaptiveTessellateY As Single
C# | public float AdaptiveTessellateY { get; set; }
C++ public:
property float AdaptiveTessellateY {
float get();
void set(float value);
}
JScript public function get AdaptiveTessellateY() : float
public function set AdaptiveTessellateY(float);

Property Value

System.Single
A Single Leave Site that sets or receives the value.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AdaptiveTessellateZ Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AdaptiveTessellateZ Property

Amount to adaptively tessellate in the z direction. The default value is 1.0f.

Definition

Visual Basic | Public Property AdaptiveTessellateZ As Single
C# | public float AdaptiveTessellateZ { get; set; }
C++ public:
property float AdaptiveTessellateZ {
float get();
void set(float value);
}
JScript public function get AdaptiveTessellateZ() : float
public function set AdaptiveTessellateZ(float);

Property Value

System.Single
A Single Leave Site that sets or receives the value.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaBlendEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AlphaBlendEnable Property

Retrieves or sets a value to enable alpha-blended transparency.

Definition

Visual Basic | Public Property AlphaBlendEnable As Boolean
C# | public bool AlphaBlendEnable { get; set; }
C++ public:
property bool AlphaBlendEnable {
bool get();
void set(bool value);
}
JScript public function get AlphaBlendEnable() : boolean
public function set AlphaBlendEnable(boolean);

Property Value

System.Boolean
Set to true to enable alpha-blended transparency, or false to disable it.

This property is read/write.

Remarks

The default value is false. The type of alpha blending is determined by the RenderStateManager.SourceBlend and RenderStateManager.DestinationBlend render states.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaBlendOperation Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AlphaBlendOperation Property

Retrieves or sets a value to select the arithmetic operation applied to the separate for the alpha channel (also known as separate alpha blending) when the render state, RenderStateManager.SeparateAlphaBlendEnabled, is set to true.

Definition

Visual Basic | Public Property AlphaBlendOperation As BlendOperation
C# | public BlendOperation AlphaBlendOperation { get; set; }
C++ public:
property BlendOperation AlphaBlendOperation {
BlendOperation get();
void set(BlendOperation value);
}
JScript public function get AlphaBlendOperation() : BlendOperation
public function set AlphaBlendOperation(BlendOperation);

Property Value

Microsoft.DirectX.Direct3D.BlendOperation
A value of the BlendOperation enumeration that represents the blend operation to set or retrieve.

This property is read/write.

Remarks

Valid values are defined by the BlendOperation enumeration. The default value is BlendOperation.Add.

If the MiscCaps.SupportsBlendOperation device capability is not supported, BlendOperation.Add is performed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaDestinationBlend Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AlphaDestinationBlend Property

Contains a member of the Blend enumeration that represents the destination .

Definition

Visual Basic | Public Property AlphaDestinationBlend As Blend
C# | public Blend AlphaDestinationBlend { get; set; }
C++ public:
property Blend AlphaDestinationBlend {
Blend get();
void set(Blend value);
}
JScript public function get AlphaDestinationBlend() : Blend
public function set AlphaDestinationBlend(Blend);

Property Value

Microsoft.DirectX.Direct3D.Blend
A Blend object that represents the current blend mode or the blend mode to set.

This property is read/write.

Remarks

This value is ignored unless RenderStateManager.SeparateAlphaBlendEnabled is true. The default value is Blend.Zero.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaFunction Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AlphaFunction Property

Retrieves or sets the comparison function for the alpha test.

Definition

Visual Basic | Public Property AlphaFunction As Compare
C# | public Compare AlphaFunction { get; set; }
C++ public:
property Compare AlphaFunction {
Compare get();
void set(Compare value);
}
JScript public function get AlphaFunction() : Compare
public function set AlphaFunction(Compare);

Property Value

Microsoft.DirectX.Direct3D.Compare
Value of the Compare enumeration that represents the comparison function to set or retrieve.

This property is read/write.

Remarks

The default value is Compare.Always.

The AlphaFunction property enables an application to accept or reject a pixel based on its alpha value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaSourceBlend Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AlphaSourceBlend Property

Contains a member of the Blend enumeration that represents the source .

Definition

Visual Basic | Public Property AlphaSourceBlend As Blend
C# | public Blend AlphaSourceBlend { get; set; }
C++ public:
property Blend AlphaSourceBlend {
Blend get();
void set(Blend value);
}
JScript public function get AlphaSourceBlend() : Blend
public function set AlphaSourceBlend(Blend);

Property Value

Microsoft.DirectX.Direct3D.Blend
A Blend object that represents the current blend mode or the blend mode to set.

This property is read/write.

Remarks

This value is ignored unless RenderStateManager.SeparateAlphaBlendEnabled is true. The default value is Blend.One.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AlphaTestEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AlphaTestEnable Property

Retrieves or sets a render state that enables a per-pixel alpha test.

Definition

Visual Basic | Public Property AlphaTestEnable As Boolean
C# | public bool AlphaTestEnable { get; set; }
C++ public:
property bool AlphaTestEnable {
bool get();
void set(bool value);
}
JScript public function get AlphaTestEnable() : boolean
public function set AlphaTestEnable(boolean);

Property Value

System.Boolean
Set to true to enable per-pixel alpha testing, or false to disable it. The default value is false.

This property is read/write.

Remarks

If the test passes, the pixel is processed by the frame buffer. Otherwise, all frame-buffer processing is skipped for the pixel. The test is done by comparing the incoming alpha value with the reference alpha value, using the comparison function provided by RenderStateManager.AlphaFunction. The reference alpha value is determined by the value set for RenderStateManager.ReferenceAlpha.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Ambient Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Ambient Property

Retrieves or sets the ambient light color.

Definition

Visual Basic | Public Property Ambient As Color
C# | public Color Ambient { get; set; }
C++ public:
property Color Ambient {
Color get();
void set(Color value);
}
JScript public function get Ambient() : Color
public function set Ambient(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that specifies the ambient color value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AmbientColor Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AmbientColor Property

Retrieves or sets the ambient light color.

Definition

Visual Basic | Public Property AmbientColor As Integer
C# | public int AmbientColor { get; set; }
C++ public:
property int AmbientColor {
int get();
void set(int value);
}
JScript public function get AmbientColor() : int
public function set AmbientColor(int);

Property Value

System.Int32
An Int32 Leave Site that specifies the ambient color value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AmbientMaterialSource Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AmbientMaterialSource Property

Retrieves or sets the ambient color source for lighting calculations.

Definition

Visual Basic | Public Property AmbientMaterialSource As ColorSource
C# | public ColorSource AmbientMaterialSource { get; set; }
C++ public:
property ColorSource AmbientMaterialSource {
ColorSource get();
void set(ColorSource value);
}
JScript public function get AmbientMaterialSource() : ColorSource
public function set AmbientMaterialSource(ColorSource);

Property Value

Microsoft.DirectX.Direct3D.ColorSource
Value of the ColorSource enumeration that specifies the ambient color source value to set or retrieve.

This property is read/write.

Remarks

Valid values are members of the ColorSource enumeration. The default value is ColorSource.Material.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.AntiAliasedLineEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.AntiAliasedLineEnable Property

Retrieves or sets antialiasing of lines.

Definition

Visual Basic | Public Property AntiAliasedLineEnable As Boolean
C# | public bool AntiAliasedLineEnable { get; set; }
C++ public:
property bool AntiAliasedLineEnable {
bool get();
void set(bool value);
}
JScript public function get AntiAliasedLineEnable() : boolean
public function set AntiAliasedLineEnable(boolean);

Property Value

System.Boolean
Set to true to enable antialiasing of lines, or false to disable it. The default value is false.

This property is read/write.

Remarks

The AntiAliasedLineEnable property applies to triangles drawn in wireframe mode as well as line-drawing primitive types.

When rendering to a multisample render target, this render state is ignored, and all lines are rendered aliased. For antialiased line rendering in multisample render targets, use a Line object, which generates textured polygons.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.BlendFactor Property (Microsoft.DirectX.Direct3D)

RenderStateManager.BlendFactor Property

Retrieves or sets a Color Leave Site object to use for a constant blend factor during alpha blending.

Definition

Visual Basic | Public Property BlendFactor As Color
C# | public Color BlendFactor { get; set; }
C++ public:
property Color BlendFactor {
Color get();
void set(Color value);
}
JScript public function get BlendFactor() : Color
public function set BlendFactor(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that specifies the constant blend factor to set or retrieve.

This property is read/write.

Remarks

The BlendFactor property is available if BlendCaps.SupportsBlendFactor is set in Caps.SourceBlendCaps or Caps.DestinationBlendCaps for the device.

See Also

  • SourceBlend
  • AlphaBlendEnable

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.BlendFactorColor Property (Microsoft.DirectX.Direct3D)

RenderStateManager.BlendFactorColor Property

Retrieves or sets a Color Leave Site object to use for a constant blend factor during alpha blending.

Definition

Visual Basic | Public Property BlendFactorColor As Integer
C# | public int BlendFactorColor { get; set; }
C++ public:
property int BlendFactorColor {
int get();
void set(int value);
}
JScript public function get BlendFactorColor() : int
public function set BlendFactorColor(int);

Property Value

System.Int32
An Int32 Leave Site that specifies the constant blend factor to set or retrieve.

This property is read/write.

Remarks

The BlendFactor property is available if BlendCaps.SupportsBlendFactor is set in Caps.SourceBlendCaps or Caps.DestinationBlendCaps for the device.

See Also

  • SourceBlend
  • AlphaBlendEnable

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.BlendOperation Property (Microsoft.DirectX.Direct3D)

RenderStateManager.BlendOperation Property

Retrieves or sets a value used to select the arithmetic operation to apply when the alpha blend render state, RenderStateManager.AlphaBlendEnable, is set to true.

Definition

Visual Basic | Public Property BlendOperation As BlendOperation
C# | public BlendOperation BlendOperation { get; set; }
C++ public:
property BlendOperation BlendOperation {
BlendOperation get();
void set(BlendOperation value);
}
JScript public function get BlendOperation() : BlendOperation
public function set BlendOperation(BlendOperation);

Property Value

Microsoft.DirectX.Direct3D.BlendOperation
Value of the BlendOperation enumeration that represents the blend operation to set or retrieve.

This property is read/write.

Remarks

Valid values are defined by the BlendOperation enumeration. The default value is BlendOperation.Add.

If the MiscCaps.SupportsBlendOperation device capability is not supported, BlendOperation.Add is performed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Clipping Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Clipping Property

Retrieves or sets a value to enable primitive clipping by Microsoft Direct3D.

Definition

Visual Basic | Public Property Clipping As Boolean
C# | public bool Clipping { get; set; }
C++ public:
property bool Clipping {
bool get();
void set(bool value);
}
JScript public function get Clipping() : boolean
public function set Clipping(boolean);

Property Value

System.Boolean
Set to true to enable primitive clipping, or false to disable it.

This property is read/write.

Remarks

The default value is true.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorVertex Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ColorVertex Property

Retrieves or sets a value to enable or disable per-vertex color.

Definition

Visual Basic | Public Property ColorVertex As Boolean
C# | public bool ColorVertex { get; set; }
C++ public:
property bool ColorVertex {
bool get();
void set(bool value);
}
JScript public function get ColorVertex() : boolean
public function set ColorVertex(boolean);

Property Value

System.Boolean
Set to true to enable per-vertex color, or false to disable it.

This property is read/write.

Remarks

The default value is true.

Enabling per-vertex color allows the system to include the color defined for individual vertices in its lighting calculations. For more information, see the following topics.

  • DiffuseMaterialSource
  • SpecularMaterialSource
  • AmbientMaterialSource
  • EmissiveMaterialSource

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorWriteEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ColorWriteEnable Property

Retrieves or sets a value that enables a per-channel write for the render target color buffer.

Definition

Visual Basic | Public Property ColorWriteEnable As ColorWriteEnable
C# | public ColorWriteEnable ColorWriteEnable { get; set; }
C++ public:
property ColorWriteEnable ColorWriteEnable {
ColorWriteEnable get();
void set(ColorWriteEnable value);
}
JScript public function get ColorWriteEnable() : ColorWriteEnable
public function set ColorWriteEnable(ColorWriteEnable);

Property Value

Microsoft.DirectX.Direct3D.ColorWriteEnable
Value of the ColorWriteEnable enumeration that specifies the color channel to set or retrieve.

This property is read/write.

Remarks

Additional ColorWriteEnable* properties are available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.

Pixel shader color output registers (oC#) are write-only registers that output results to multiple render targets. The ColorWriteEnable* properties determine which components of oC# ultimately get written to the render target (after blend, if applicable).

Use the additional ColorWriteEnable* properties if the device supports independent write masks for multiple element textures or multiple render targets.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorWriteEnable1 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ColorWriteEnable1 Property

Retrieves or sets additional RenderStateManager.ColorWriteEnable values for the device.

Definition

Visual Basic | Public Property ColorWriteEnable1 As ColorWriteEnable
C# | public ColorWriteEnable ColorWriteEnable1 { get; set; }
C++ public:
property ColorWriteEnable ColorWriteEnable1 {
ColorWriteEnable get();
void set(ColorWriteEnable value);
}
JScript public function get ColorWriteEnable1() : ColorWriteEnable
public function set ColorWriteEnable1(ColorWriteEnable);

Property Value

Microsoft.DirectX.Direct3D.ColorWriteEnable
Value of the ColorWriteEnable enumeration that specifies the color channel(s) to write enable.

This property is read/write.

Remarks

The ColorWriteEnable1 property is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.

Pixel shader color output registers (oC#) are write-only registers that output results to multiple render targets. The ColorWriteEnable* properties determine which components of oC# ultimately get written to the render target (after blend, if applicable).

Use the additional ColorWriteEnable* properties if the device supports independent write masks for multiple element textures or multiple render targets.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorWriteEnable2 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ColorWriteEnable2 Property

Retrieves or sets additional RenderStateManager.ColorWriteEnable values for devices.

Definition

Visual Basic | Public Property ColorWriteEnable2 As ColorWriteEnable
C# | public ColorWriteEnable ColorWriteEnable2 { get; set; }
C++ public:
property ColorWriteEnable ColorWriteEnable2 {
ColorWriteEnable get();
void set(ColorWriteEnable value);
}
JScript public function get ColorWriteEnable2() : ColorWriteEnable
public function set ColorWriteEnable2(ColorWriteEnable);

Property Value

Microsoft.DirectX.Direct3D.ColorWriteEnable
Value of the ColorWriteEnable enumeration that specifies the color channel(s) to write enable.

This property is read/write.

Remarks

The ColorWriteEnable2 property is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.

Pixel shader color output registers (oC#) are write-only registers that output results to multiple render targets. The ColorWriteEnable* properties determine which components of oC# ultimately get written to the render target (after blend, if applicable).

Use the additional ColorWriteEnable* properties if the device supports independent write masks for multiple element textures or multiple render targets.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ColorWriteEnable3 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ColorWriteEnable3 Property

Retrieves or sets additional RenderStateManager.ColorWriteEnable values for devices.

Definition

Visual Basic | Public Property ColorWriteEnable3 As ColorWriteEnable
C# | public ColorWriteEnable ColorWriteEnable3 { get; set; }
C++ public:
property ColorWriteEnable ColorWriteEnable3 {
ColorWriteEnable get();
void set(ColorWriteEnable value);
}
JScript public function get ColorWriteEnable3() : ColorWriteEnable
public function set ColorWriteEnable3(ColorWriteEnable);

Property Value

Microsoft.DirectX.Direct3D.ColorWriteEnable
Value of the ColorWriteEnable enumeration that specifies the color channel(s) to write enable.

This property is read/write.

Remarks

The ColorWriteEnable3 property is available if the MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.

Pixel shader color output registers (oC#) are write-only registers that output results to multiple render targets. The ColorWriteEnable* properties determine which components of oC# ultimately get written to the render target (after blend, if applicable).

Use the additional ColorWriteEnable* properties if the device supports independent write masks for multiple element textures or multiple render targets.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CounterClockwiseStencilFail Property (Microsoft.DirectX.Direct3D)

RenderStateManager.CounterClockwiseStencilFail Property

Retrieves the StencilOperation or sets it to perform if the counterclockwise (CCW) stencil test fails.

Definition

Visual Basic | Public Property CounterClockwiseStencilFail As StencilOperation
C# | public StencilOperation CounterClockwiseStencilFail { get; set; }
C++ public:
property StencilOperation CounterClockwiseStencilFail {
StencilOperation get();
void set(StencilOperation value);
}
JScript public function get CounterClockwiseStencilFail() : StencilOperation
public function set CounterClockwiseStencilFail(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation
Value of the StencilOperation enumeration that specifies the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CounterClockwiseStencilFunction Property (Microsoft.DirectX.Direct3D)

RenderStateManager.CounterClockwiseStencilFunction Property

Retrieves or sets the comparison function used by the counterclockwise (CCW) stencil test.

Definition

Visual Basic | Public Property CounterClockwiseStencilFunction As Compare
C# | public Compare CounterClockwiseStencilFunction { get; set; }
C++ public:
property Compare CounterClockwiseStencilFunction {
Compare get();
void set(Compare value);
}
JScript public function get CounterClockwiseStencilFunction() : Compare
public function set CounterClockwiseStencilFunction(Compare);

Property Value

Microsoft.DirectX.Direct3D.Compare
Value of the Compare enumeration that specifies the comparison operation to set or retrieve.

This property is read/write.

Remarks

The test passes if ((ref & mask) stencil_compare_function (stencil & mask)) == true.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CounterClockwiseStencilPass Property (Microsoft.DirectX.Direct3D)

RenderStateManager.CounterClockwiseStencilPass Property

Retrieves the StencilOperation or sets it to perform, if both counterclockwise (CCW) stencil and z-tests pass.

Definition

Visual Basic | Public Property CounterClockwiseStencilPass As StencilOperation
C# | public StencilOperation CounterClockwiseStencilPass { get; set; }
C++ public:
property StencilOperation CounterClockwiseStencilPass {
StencilOperation get();
void set(StencilOperation value);
}
JScript public function get CounterClockwiseStencilPass() : StencilOperation
public function set CounterClockwiseStencilPass(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation
Value of the StencilOperation enumeration that specifies the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CounterClockwiseStencilZBufferFail Property (Microsoft.DirectX.Direct3D)

RenderStateManager.CounterClockwiseStencilZBufferFail Property

Language:

Retrieves the StencilOperation or sets it to perform if the counterclockwise (CCW) stencil test passes and the z-test fails.

Definition

Visual Basic | Public Property CounterClockwiseStencilZBufferFail As StencilOperation
C# | public StencilOperation CounterClockwiseStencilZBufferFail { get; set; }
C++ public:
property StencilOperation CounterClockwiseStencilZBufferFail {
StencilOperation get();
void set(StencilOperation value);
}
JScript public function get CounterClockwiseStencilZBufferFail() : StencilOperation
public function set CounterClockwiseStencilZBufferFail(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation
Value of the StencilOperation enumeration that specifies the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.CullMode Property (Microsoft.DirectX.Direct3D)

RenderStateManager.CullMode Property

Specifies how back-facing triangles are culled, if at all.

Definition

Visual Basic | Public Property CullMode As Cull
C# | public Cull CullMode { get; set; }
C++ public:
property Cull CullMode {
Cull get();
void set(Cull value);
}
JScript public function get CullMode() : Cull
public function set CullMode(Cull);

Property Value

Microsoft.DirectX.Direct3D.Cull
Value of the Cull enumeration that specifies the culling mode to set or retrieve.

This property is read/write.

Remarks

The default value is Cull.CounterClockwise.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DebugMonitorTokenEnabled Property (Microsoft.DirectX.Direct3D)

RenderStateManager.DebugMonitorTokenEnabled Property

Enables or disables the debug monitor token.

Definition

Visual Basic | Public Property DebugMonitorTokenEnabled As Boolean
C# | public bool DebugMonitorTokenEnabled { get; set; }
C++ public:
property bool DebugMonitorTokenEnabled {
bool get();
void set(bool value);
}
JScript public function get DebugMonitorTokenEnabled() : boolean
public function set DebugMonitorTokenEnabled(boolean);

Property Value

System.Boolean
Set to true to enable the debug monitor, or false to disable it.

This property is read/write.

Remarks

The default value for the debug monitor is true.

This property should be set only for debugging the monitor. It is useful for debug builds only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DepthBias Property (Microsoft.DirectX.Direct3D)

RenderStateManager.DepthBias Property

Sets or retrieves the depth bias for polygons.

Definition

Visual Basic | Public Property DepthBias As Single
C# | public float DepthBias { get; set; }
C++ public:
property float DepthBias {
float get();
void set(float value);
}
JScript public function get DepthBias() : float
public function set DepthBias(float);

Property Value

System.Single
Depth bias for polygons.

This property is read/write.

Remarks

The DepthBias property specifies an integer value in the range of 0 through 16 that causes polygons that are physically coplanar to appear separate.

Polygons with a high z-bias value appear in front of polygons with a low value, without requiring sorting for drawing order. For example, polygons with a value of 1 appear in front of polygons with a value of 0.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DestinationBlend Property (Microsoft.DirectX.Direct3D)

RenderStateManager.DestinationBlend Property

Contains a member of the Blend enumeration that represents the destination .

Definition

Visual Basic | Public Property DestinationBlend As Blend
C# | public Blend DestinationBlend { get; set; }
C++ public:
property Blend DestinationBlend {
Blend get();
void set(Blend value);
}
JScript public function get DestinationBlend() : Blend
public function set DestinationBlend(Blend);

Property Value

Microsoft.DirectX.Direct3D.Blend
A Blend object that represents the current blend mode or the blend mode to set.

This property is read/write.

Remarks

The default value is Blend.Zero.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DiffuseMaterialSource Property (Microsoft.DirectX.Direct3D)

RenderStateManager.DiffuseMaterialSource Property

Retrieves or sets the diffuse color source for lighting calculations.

Definition

Visual Basic | Public Property DiffuseMaterialSource As ColorSource
C# | public ColorSource DiffuseMaterialSource { get; set; }
C++ public:
property ColorSource DiffuseMaterialSource {
ColorSource get();
void set(ColorSource value);
}
JScript public function get DiffuseMaterialSource() : ColorSource
public function set DiffuseMaterialSource(ColorSource);

Property Value

Microsoft.DirectX.Direct3D.ColorSource
A ColorSource object that specifies the diffuse color source value to set or retrieve.

This property is read/write.

Remarks

Valid values are members of the ColorSource enumerated type. The default value is ColorSource.Color1. The value for this render state is used only if RenderStateManager.ColorVertex is set to true.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.DitherEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.DitherEnable Property

Enables or disables dithering.

Definition

Visual Basic | Public Property DitherEnable As Boolean
C# | public bool DitherEnable { get; set; }
C++ public:
property bool DitherEnable {
bool get();
void set(bool value);
}
JScript public function get DitherEnable() : boolean
public function set DitherEnable(boolean);

Property Value

System.Boolean
Set to true to enable dithering, or false to disable it.

This property is read/write.

Remarks

The default value is false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.EmissiveMaterialSource Property (Microsoft.DirectX.Direct3D)

RenderStateManager.EmissiveMaterialSource Property

Retrieves or sets the emissive color source for lighting calculations.

Definition

Visual Basic | Public Property EmissiveMaterialSource As ColorSource
C# | public ColorSource EmissiveMaterialSource { get; set; }
C++ public:
property ColorSource EmissiveMaterialSource {
ColorSource get();
void set(ColorSource value);
}
JScript public function get EmissiveMaterialSource() : ColorSource
public function set EmissiveMaterialSource(ColorSource);

Property Value

Microsoft.DirectX.Direct3D.ColorSource
A ColorSource object that specifies the emissive color source value to set or retrieve.

This property is read/write.

Remarks

Valid values are members of the ColorSource enumeration. The default value is ColorSource.Material.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.EnableAdaptiveTessellation Property (Microsoft.DirectX.Direct3D)

RenderStateManager.EnableAdaptiveTessellation Property

Enables or disables adaptive tessellation.

Definition

Visual Basic | Public Property EnableAdaptiveTessellation As Boolean
C# | public bool EnableAdaptiveTessellation { get; set; }
C++ public:
property bool EnableAdaptiveTessellation {
bool get();
void set(bool value);
}
JScript public function get EnableAdaptiveTessellation() : boolean
public function set EnableAdaptiveTessellation(boolean);

Property Value

System.Boolean
Set to true to enable adaptive tessellation, or false to disable it.

This property is read/write.

Remarks

The default value is false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FillMode Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FillMode Property

Contains a member of the FillMode enumeration that represents the fill mode.

Definition

Visual Basic | Public Property FillMode As FillMode
C# | public FillMode FillMode { get; set; }
C++ public:
property FillMode FillMode {
FillMode get();
void set(FillMode value);
}
JScript public function get FillMode() : FillMode
public function set FillMode(FillMode);

Property Value

Microsoft.DirectX.Direct3D.FillMode
Value of the FillMode enumeration that specifies the fill mode to set or retrieve.

This property is read/write.

Remarks

The default value is FillMode.Solid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogColor Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FogColor Property

Retrieves or sets the fog color.

Definition

Visual Basic | Public Property FogColor As Color
C# | public Color FogColor { get; set; }
C++ public:
property Color FogColor {
Color get();
void set(Color value);
}
JScript public function get FogColor() : Color
public function set FogColor(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that specifies the fog color to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogColorValue Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FogColorValue Property

Retrieves or sets the fog color.

Definition

Visual Basic | Public Property FogColorValue As Integer
C# | public int FogColorValue { get; set; }
C++ public:
property int FogColorValue {
int get();
void set(int value);
}
JScript public function get FogColorValue() : int
public function set FogColorValue(int);

Property Value

System.Int32
An integer that specifies the fog color to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogDensity Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FogDensity Property

Retrieves or sets the fog density for pixel or vertex fog used in exponential fog modes.

Definition

Visual Basic | Public Property FogDensity As Single
C# | public float FogDensity { get; set; }
C++ public:
property float FogDensity {
float get();
void set(float value);
}
JScript public function get FogDensity() : float
public function set FogDensity(float);

Property Value

System.Single
Floating-point value that represents the fog density to set or retrieve.

This property is read/write.

Remarks

Valid fog density values range from 0.0 through 1.0. The default value is 1.0.

See Also

  • Fog

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FogEnable Property

Enables or disables fog blending.

Definition

Visual Basic | Public Property FogEnable As Boolean
C# | public bool FogEnable { get; set; }
C++ public:
property bool FogEnable {
bool get();
void set(bool value);
}
JScript public function get FogEnable() : boolean
public function set FogEnable(boolean);

Property Value

System.Boolean
Set to true to enable fog blending, or false to disable it.

This property is read/write.

Remarks

The default value is false.

See Also

  • Fog

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogEnd Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FogEnd Property

Retrieves or sets the depth at which pixel or vertex fog effects end for linear fog mode.

Definition

Visual Basic | Public Property FogEnd As Single
C# | public float FogEnd { get; set; }
C++ public:
property float FogEnd {
float get();
void set(float value);
}
JScript public function get FogEnd() : float
public function set FogEnd(float);

Property Value

System.Single
Floating-point value that represents the ending depth to set or retrieve.

This property is read/write.

Remarks

The default value is 1.0f. Depth is specified in world space for vertex fog, and in either device space [0.0, 1.0] or world space for pixel fog. For pixel fog, these values are in device space when the system uses z for fog calculations, or in world space when the system uses eye-relative fog (w-fog).

See Also

  • Fog

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogStart Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FogStart Property

Retrieves or sets the depth at which pixel or vertex fog effects begin for linear fog mode.

Definition

Visual Basic | Public Property FogStart As Single
C# | public float FogStart { get; set; }
C++ public:
property float FogStart {
float get();
void set(float value);
}
JScript public function get FogStart() : float
public function set FogStart(float);

Property Value

System.Single
Floating-point value that represents the beginning depth to set or retrieve.

This property is read/write.

Remarks

The default value is 0.0f. Depth is specified in world space for vertex fog, and in either device space [0.0, 1.0] or world space for pixel fog. For pixel fog, these values are in device space when the system uses z for fog calculations, or in world space when the system uses eye-relative fog (w-fog).

See Also

  • Fog

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogTableMode Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FogTableMode Property

Retrieves or sets the fog formula to use for pixel fog.

Definition

Visual Basic | Public Property FogTableMode As FogMode
C# | public FogMode FogTableMode { get; set; }
C++ public:
property FogMode FogTableMode {
FogMode get();
void set(FogMode value);
}
JScript public function get FogTableMode() : FogMode
public function set FogTableMode(FogMode);

Property Value

Microsoft.DirectX.Direct3D.FogMode
Value of the FogMode enumeration that specifies the fog mode to set or retrieve.

This property is read/write.

Remarks

The default fog mode is FogMode.None.

See Also

  • Fog

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.FogVertexMode Property (Microsoft.DirectX.Direct3D)

RenderStateManager.FogVertexMode Property

Retrieves or sets the fog formula to use for vertex fog.

Definition

Visual Basic | Public Property FogVertexMode As FogMode
C# | public FogMode FogVertexMode { get; set; }
C++ public:
property FogMode FogVertexMode {
FogMode get();
void set(FogMode value);
}
JScript public function get FogVertexMode() : FogMode
public function set FogVertexMode(FogMode);

Property Value

Microsoft.DirectX.Direct3D.FogMode
Value of the FogMode enumeration that specifies the fog mode to set or retrieve.

This property is read/write.

Remarks

The default fog mode is FogMode.None.

See Also

  • Fog

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.IndexedVertexBlendEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.IndexedVertexBlendEnable Property

Enables or disables indexed vertex blending.

Definition

Visual Basic | Public Property IndexedVertexBlendEnable As Boolean
C# | public bool IndexedVertexBlendEnable { get; set; }
C++ public:
property bool IndexedVertexBlendEnable {
bool get();
void set(bool value);
}
JScript public function get IndexedVertexBlendEnable() : boolean
public function set IndexedVertexBlendEnable(boolean);

Property Value

System.Boolean
Set to true to enable indexed vertex blending, or false to disable it.

This property is read/write.

Remarks

The default value is false.

When indexed vertex blending is disabled and vertex blending is enabled through RenderStateManager.VertexBlend, it is equivalent to having matrix indices 0, 1, 2, and 3 in every vertex.

If indexed vertex blending is enabled (set to true), the user must pass matrix indices with every vertex.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.LastPixel Property (Microsoft.DirectX.Direct3D)

RenderStateManager.LastPixel Property

Enables or disables drawing of the last pixel in a line.

Definition

Visual Basic | Public Property LastPixel As Boolean
C# | public bool LastPixel { get; set; }
C++ public:
property bool LastPixel {
bool get();
void set(bool value);
}
JScript public function get LastPixel() : boolean
public function set LastPixel(boolean);

Property Value

System.Boolean
Set to true to enable drawing of the last pixel in a line, or false to prevent it.

This property is read/write.

Remarks

The default value is true.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Lighting Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Lighting Property

Enables or disables Microsoft Direct3D lighting.

Definition

Visual Basic | Public Property Lighting As Boolean
C# | public bool Lighting { get; set; }
C++ public:
property bool Lighting {
bool get();
void set(bool value);
}
JScript public function get Lighting() : boolean
public function set Lighting(boolean);

Property Value

System.Boolean
Set to true to enable Direct3D lighting, or false to disable it.

This property is read/write.

Remarks

The default value is true.

Only vertices that include a vertex normal are properly lit; vertices that do not contain a vertex normal employ a dot product of 0 in all lighting calculations.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.LocalViewer Property (Microsoft.DirectX.Direct3D)

RenderStateManager.LocalViewer Property

Specifies whether to use camera-relative specular highlights or orthogonal specular highlights.

Definition

Visual Basic | Public Property LocalViewer As Boolean
C# | public bool LocalViewer { get; set; }
C++ public:
property bool LocalViewer {
bool get();
void set(bool value);
}
JScript public function get LocalViewer() : boolean
public function set LocalViewer(boolean);

Property Value

System.Boolean
Set to true to enable camera-relative specular highlights, or false to use orthogonal specular highlights.

This property is read/write.

Remarks

The default value is true.

Applications that use orthogonal projection should specify false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.MaxTessellationLevel Property (Microsoft.DirectX.Direct3D)

RenderStateManager.MaxTessellationLevel Property

Retrieves or sets the maximum tessellation level.

Definition

Visual Basic | Public Property MaxTessellationLevel As Single
C# | public float MaxTessellationLevel { get; set; }
C++ public:
property float MaxTessellationLevel {
float get();
void set(float value);
}
JScript public function get MaxTessellationLevel() : float
public function set MaxTessellationLevel(float);

Property Value

System.Single
Floating-point value that represents the maximum tessellation level to set or retrieve.

This property is read/write.

Remarks

The default value is 1.0f.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.MinTessellationLevel Property (Microsoft.DirectX.Direct3D)

RenderStateManager.MinTessellationLevel Property

Retrieves or sets the minimum tessellation level.

Definition

Visual Basic | Public Property MinTessellationLevel As Single
C# | public float MinTessellationLevel { get; set; }
C++ public:
property float MinTessellationLevel {
float get();
void set(float value);
}
JScript public function get MinTessellationLevel() : float
public function set MinTessellationLevel(float);

Property Value

System.Single
Floating-point value that represents the minimum tessellation level to set or retrieve.

This property is read/write.

Remarks

The default value is 1.0f.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.MultiSampleAntiAlias Property (Microsoft.DirectX.Direct3D)

RenderStateManager.MultiSampleAntiAlias Property

Determines how individual samples are computed when using a multisample render target buffer.

Definition

Visual Basic | Public Property MultiSampleAntiAlias As Boolean
C# | public bool MultiSampleAntiAlias { get; set; }
C++ public:
property bool MultiSampleAntiAlias {
bool get();
void set(bool value);
}
JScript public function get MultiSampleAntiAlias() : boolean
public function set MultiSampleAntiAlias(boolean);

Property Value

System.Boolean
When set to true, the multiple samples are computed so that full-scene antialiasing is performed by sampling at different sample positions for each multiple sample. When set to false, the multiple samples are all written with the same sample value, sampled at the pixel center, which allows non-antialiased rendering to a multisample buffer.

This property is read/write.

Remarks

The default value is true.

This render state has no effect when rendering to a single sample buffer.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.MultiSampleMask Property (Microsoft.DirectX.Direct3D)

RenderStateManager.MultiSampleMask Property

Retrieves or sets a render state that enables use of a multisample buffer as an accumulation buffer.

Definition

Visual Basic | Public Property MultiSampleMask As Integer
C# | public int MultiSampleMask { get; set; }
C++ public:
property int MultiSampleMask {
int get();
void set(int value);
}
JScript public function get MultiSampleMask() : int
public function set MultiSampleMask(int);

Property Value

System.Int32
Integer value that represents the multisample mask to set or retrieve.

This property is read/write.

Remarks

The default value is 0xFFFFFFFF.

This render state allows multipass rendering of geometry, in which each pass updates a subset of samples. The state has no effect when rendering to a single sample buffer.

Each bit in the MultiSampleMask, starting at the least significant bit (LSB), controls modification of one of the samples in a multisample render target. Thus, for an 8-sample render target, the low byte contains the eight write enables for each of the eight samples. This property enables use of a multisample buffer as an accumulation buffer. If there are n multisamples and k enabled samples, the resulting intensity of the rendered image should be k/n. Each component RGB of every pixel is factored by k/n.

See Also

  • MultiSampleType

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.NormalDegree Property (Microsoft.DirectX.Direct3D)

RenderStateManager.NormalDegree Property

Retrieves or sets the degree of interpolation (linear, cubic, quadratic, or quintic) using the N-patch normal.

Definition

Visual Basic | Public Property NormalDegree As DegreeType
C# | public DegreeType NormalDegree { get; set; }
C++ public:
property DegreeType NormalDegree {
DegreeType get();
void set(DegreeType value);
}
JScript public function get NormalDegree() : DegreeType
public function set NormalDegree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType
Value of the DegreeType enumeration that represents the degree of interpolation to set or retrieve.

This property is read/write.

Remarks

The default render state is DegreeType.Linear.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.NormalizeNormals Property (Microsoft.DirectX.Direct3D)

RenderStateManager.NormalizeNormals Property

Enables or disables automatic normalization of vertex normals.

Definition

Visual Basic | Public Property NormalizeNormals As Boolean
C# | public bool NormalizeNormals { get; set; }
C++ public:
property bool NormalizeNormals {
bool get();
void set(bool value);
}
JScript public function get NormalizeNormals() : boolean
public function set NormalizeNormals(boolean);

Property Value

System.Boolean
Set to true to enable normalization of vertex normals, or false to disable it.

This property is read/write.

Remarks

The default value is false.

Enabling this feature causes the system to normalize the vertex normals for vertices after transforming them to camera space, an operation that can slow down the system.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PatchEdgeStyle Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PatchEdgeStyle Property

Retrieves or sets the tessellation mode for patch edges.

Definition

Visual Basic | Public Property PatchEdgeStyle As PatchEdge
C# | public PatchEdge PatchEdgeStyle { get; set; }
C++ public:
property PatchEdge PatchEdgeStyle {
PatchEdge get();
void set(PatchEdge value);
}
JScript public function get PatchEdgeStyle() : PatchEdge
public function set PatchEdgeStyle(PatchEdge);

Property Value

Microsoft.DirectX.Direct3D.PatchEdge
Value of the PatchEdge enumeration that represents the degree of interpolation to set or retrieve.

This property is read/write.

Remarks

The default render state is PatchEdge.Discrete.

Using the PatchEdge.Continuous tessellation mode helps reduce rendering artifacts.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointScaleA Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PointScaleA Property

Controls the distance-based size attenuation for point primitives.

Definition

Visual Basic | Public Property PointScaleA As Single
C# | public float PointScaleA { get; set; }
C++ public:
property float PointScaleA {
float get();
void set(float value);
}
JScript public function get PointScaleA() : float
public function set PointScaleA(float);

Property Value

System.Single
Floating-point value that specifies the range or size of the attenuation for point primitives.

This property is read/write.

Remarks

The default value is 1.0f.

This property is active only when RenderStateManager.PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointScaleB Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PointScaleB Property

Controls the distance-based size attenuation for point primitives.

Definition

Visual Basic | Public Property PointScaleB As Single
C# | public float PointScaleB { get; set; }
C++ public:
property float PointScaleB {
float get();
void set(float value);
}
JScript public function get PointScaleB() : float
public function set PointScaleB(float);

Property Value

System.Single
Floating-point value that specifies the range or size of the attenuation for point primitives.

This property is read/write.

Remarks

The default value is 1.0f.

This property is active only when RenderStateManager.PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointScaleC Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PointScaleC Property

Controls the distance-based size attenuation for point primitives.

Definition

Visual Basic | Public Property PointScaleC As Single
C# | public float PointScaleC { get; set; }
C++ public:
property float PointScaleC {
float get();
void set(float value);
}
JScript public function get PointScaleC() : float
public function set PointScaleC(float);

Property Value

System.Single
Floating-point value that specifies the range or size of the attenuation for point primitives.

This property is read/write.

Remarks

The default value is 1.0f.

This property is active only when RenderStateManager.PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointScaleEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PointScaleEnable Property

Controls how the computation of size for point sprites is handled.

Definition

Visual Basic | Public Property PointScaleEnable As Boolean
C# | public bool PointScaleEnable { get; set; }
C++ public:
property bool PointScaleEnable {
bool get();
void set(bool value);
}
JScript public function get PointScaleEnable() : boolean
public function set PointScaleEnable(boolean);

Property Value

System.Boolean
When set to true, the point size is interpreted as a camera space value. To compute the final screen-space point size, it is scaled by the distance function and the frustum to viewport y-axis scaling. When set to false, the point size is interpreted as screen space and used directly.

This property is read/write.

Remarks

The default value is false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointSize Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PointSize Property

Specifies the size to use for point size computation in cases in which point size is not specified for each vertex.

Definition

Visual Basic | Public Property PointSize As Single
C# | public float PointSize { get; set; }
C++ public:
property float PointSize {
float get();
void set(float value);
}
JScript public function get PointSize() : float
public function set PointSize(float);

Property Value

System.Single
Floating-point value that specifies the point size to set or retrieve.

This property is read/write.

Remarks

The default value is 1.0f.

This value is not used when the vertex contains a point size. The value is defined in screen space units if RenderStateManager.PointScaleEnable is set to false; otherwise, it is defined in world space units. The range for the value is greater than or equal to 0.0f.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointSizeMax Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PointSizeMax Property

Specifies the maximum size to which point sprites can be set.

Definition

Visual Basic | Public Property PointSizeMax As Single
C# | public float PointSizeMax { get; set; }
C++ public:
property float PointSizeMax {
float get();
void set(float value);
}
JScript public function get PointSizeMax() : float
public function set PointSizeMax(float);

Property Value

System.Single
Floating-point value that specifies the maximum size of point sprites.

This property is read/write.

Remarks

The default value is 64.0f.

The value must be less than or equal to Caps.MaxPointSize and greater than or equal to RenderStateManager.PointSizeMin.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointSizeMin Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PointSizeMin Property

Specifies the minimum size to which point sprites can be set.

Definition

Visual Basic | Public Property PointSizeMin As Single
C# | public float PointSizeMin { get; set; }
C++ public:
property float PointSizeMin {
float get();
void set(float value);
}
JScript public function get PointSizeMin() : float
public function set PointSizeMin(float);

Property Value

System.Single
Floating-point value that specifies the minimum size of point sprites.

This property is read/write.

Remarks

The default value is 1.0f. The range for this value is greater than or equal to 0.0f.

Point sprites are clamped to the specified size during rendering.

Setting the size to less than 1.0 results in points dropping out if the point does not cover a pixel center and antialiasing is disabled. Points also will drop out if the size is less than 1.0, if they are being rendered with reduced intensity, and if antialiasing is enabled.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PointSpriteEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PointSpriteEnable Property

Controls how point sprites are rendered.

Definition

Visual Basic | Public Property PointSpriteEnable As Boolean
C# | public bool PointSpriteEnable { get; set; }
C++ public:
property bool PointSpriteEnable {
bool get();
void set(bool value);
}
JScript public function get PointSpriteEnable() : boolean
public function set PointSpriteEnable(boolean);

Property Value

System.Boolean
When set to true, the texture coordinates of point sprites are set so that full textures are mapped on each point. When set to false, the vertex texture coordinates are used for the entire point.

This property is read/write.

Remarks

The default value is false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.PositionDegree Property (Microsoft.DirectX.Direct3D)

RenderStateManager.PositionDegree Property

Retrieves or sets the N-patch position interpolation degree.

Definition

Visual Basic | Public Property PositionDegree As DegreeType
C# | public DegreeType PositionDegree { get; set; }
C++ public:
property DegreeType PositionDegree {
DegreeType get();
void set(DegreeType value);
}
JScript public function get PositionDegree() : DegreeType
public function set PositionDegree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType
Value of the DegreeType enumeration that specifies the degree.

This property is read/write.

Remarks

The default value is DegreeType.Cubic. The DegreeType.Linear value also can be used.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.RangeFogEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.RangeFogEnable Property

Retrieves or sets enabling of range-based vertex fog.

Definition

Visual Basic | Public Property RangeFogEnable As Boolean
C# | public bool RangeFogEnable { get; set; }
C++ public:
property bool RangeFogEnable {
bool get();
void set(bool value);
}
JScript public function get RangeFogEnable() : boolean
public function set RangeFogEnable(boolean);

Property Value

System.Boolean
Set to true to enable range-based vertex fog, or false to use depth-based fog.

This property is read/write.

Remarks

The default value is false.

In range-based fog, the distance of an object from the viewer is used to compute fog effects, not the depth of the object (that is, the z-coordinate) in the scene. All fog methods work as usual, except that they use range instead of depth in the computations.

Range is the correct factor to use for fog computations, but depth is commonly used instead because it is generally already available, and range is resource-intensive to compute. Using depth to calculate fog has the undesirable effect of making the fogginess of peripheral objects change as the viewer's eye moves; in this case, the depth changes and the range remains constant.

Because no hardware currently supports per-pixel range-based fog, range correction is offered only for Vertex Fog.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ReferenceAlpha Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ReferenceAlpha Property

Specifies a reference alpha value against which pixels are tested when alpha testing is enabled.

Definition

Visual Basic | Public Property ReferenceAlpha As Integer
C# | public int ReferenceAlpha { get; set; }
C++ public:
property int ReferenceAlpha {
int get();
void set(int value);
}
JScript public function get ReferenceAlpha() : int
public function set ReferenceAlpha(int);

Property Value

System.Int32
Integer that specifies the reference alpha value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Values can range from 0x00000000 to 0x000000FF.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ReferenceStencil Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ReferenceStencil Property

Specifies a reference value to use for the stencil test.

Definition

Visual Basic | Public Property ReferenceStencil As Integer
C# | public int ReferenceStencil { get; set; }
C++ public:
property int ReferenceStencil {
int get();
void set(int value);
}
JScript public function get ReferenceStencil() : int
public function set ReferenceStencil(int);

Property Value

System.Int32
Integer that specifies the stencil test value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ScissorTestEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ScissorTestEnable Property

Enables or disables scissor testing.

Definition

Visual Basic | Public Property ScissorTestEnable As Boolean
C# | public bool ScissorTestEnable { get; set; }
C++ public:
property bool ScissorTestEnable {
bool get();
void set(bool value);
}
JScript public function get ScissorTestEnable() : boolean
public function set ScissorTestEnable(boolean);

Property Value

System.Boolean
Set to true to enable scissor testing, or false to disable it.

This property is read/write.

Remarks

The default value is false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SeparateAlphaBlendEnabled Property (Microsoft.DirectX.Direct3D)

RenderStateManager.SeparateAlphaBlendEnabled Property

Enables or disables the separate for the alpha channel.

Definition

Visual Basic | Public Property SeparateAlphaBlendEnabled As Boolean
C# | public bool SeparateAlphaBlendEnabled { get; set; }
C++ public:
property bool SeparateAlphaBlendEnabled {
bool get();
void set(bool value);
}
JScript public function get SeparateAlphaBlendEnabled() : boolean
public function set SeparateAlphaBlendEnabled(boolean);

Property Value

System.Boolean
Set to true to enable separate alpha blend, or false to disable it.

This property is read/write.

Remarks

The default value is false.

When set to false, the render target blending factors and operations applied to alpha are forced to be the same as those defined for color. This mode is effectively hard-wired to false on implementations that do not set MiscCaps.SupportsSeparateAlphaBlend.

The type of separate alpha blending is determined by RenderStateManager.AlphaSourceBlend and RenderStateManager.AlphaDestinationBlend.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ShadeMode Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ShadeMode Property

Contains one or more members of the ShadeMode enumeration.

Definition

Visual Basic | Public Property ShadeMode As ShadeMode
C# | public ShadeMode ShadeMode { get; set; }
C++ public:
property ShadeMode ShadeMode {
ShadeMode get();
void set(ShadeMode value);
}
JScript public function get ShadeMode() : ShadeMode
public function set ShadeMode(ShadeMode);

Property Value

Microsoft.DirectX.Direct3D.ShadeMode
Value of the ShadeMode enumeration to set or retrieve.

This property is read/write.

Remarks

The default value is ShadeMode.Gouraud.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SlopeScaleDepthBias Property (Microsoft.DirectX.Direct3D)

RenderStateManager.SlopeScaleDepthBias Property

Retrieves or sets a value used to determine how much bias can be applied to coplanar primitives to reduce z-fighting.

Definition

Visual Basic | Public Property SlopeScaleDepthBias As Single
C# | public float SlopeScaleDepthBias { get; set; }
C++ public:
property float SlopeScaleDepthBias {
float get();
void set(float value);
}
JScript public function get SlopeScaleDepthBias() : float
public function set SlopeScaleDepthBias(float);

Property Value

System.Single
Floating-point value that specifies the slope scale bias to apply.

This property is read/write.

Remarks

The default value is 0.

Polygons that are coplanar in your 3-D space can be made to appear as if they are not coplanar by adding a z-bias to each one. An application can help ensure that coplanar polygons are rendered properly by adding a bias to the z-values that the system uses when rendering sets of coplanar polygons.

The following formula shows how to calculate the bias to be applied to coplanar primitives.

bias = (m * SlopeScaleDepthBias) + DepthBias

where m is the maximum depth slope of the triangle being rendered, defined as:

m = max(abs(delta z / delta x), abs(delta z / delta y))

See Also

  • Depth Buffers

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SourceBlend Property (Microsoft.DirectX.Direct3D)

RenderStateManager.SourceBlend Property

Contains a member of the Blend enumeration.

Definition

Visual Basic | Public Property SourceBlend As Blend
C# | public Blend SourceBlend { get; set; }
C++ public:
property Blend SourceBlend {
Blend get();
void set(Blend value);
}
JScript public function get SourceBlend() : Blend
public function set SourceBlend(Blend);

Property Value

Microsoft.DirectX.Direct3D.Blend
The Blend mode to set or retrieve.

This property is read/write.

Remarks

The default value is Blend.One.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SpecularEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.SpecularEnable Property

Retrieves or sets a render state that enables specular highlights.

Definition

Visual Basic | Public Property SpecularEnable As Boolean
C# | public bool SpecularEnable { get; set; }
C++ public:
property bool SpecularEnable {
bool get();
void set(bool value);
}
JScript public function get SpecularEnable() : boolean
public function set SpecularEnable(boolean);

Property Value

System.Boolean
Set to true to enable specular highlights, or false to disable them.

This property is read/write.

Remarks

The default value is false.

Specular highlights are calculated as though every vertex in the object being lit is at the object's origin. This gives the expected results as long as the object is modeled around the origin and the distance from the light to the object is relatively large. In other cases, the results are undefined.

When this state is set to true, the specular color is added to the base color after the texture cascade but before alpha blending.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SpecularMaterialSource Property (Microsoft.DirectX.Direct3D)

RenderStateManager.SpecularMaterialSource Property

Retrieves or sets the specular color source for lighting calculations.

Definition

Visual Basic | Public Property SpecularMaterialSource As ColorSource
C# | public ColorSource SpecularMaterialSource { get; set; }
C++ public:
property ColorSource SpecularMaterialSource {
ColorSource get();
void set(ColorSource value);
}
JScript public function get SpecularMaterialSource() : ColorSource
public function set SpecularMaterialSource(ColorSource);

Property Value

Microsoft.DirectX.Direct3D.ColorSource
Value of the ColorSource enumeration that specifies the specular color source value to set or retrieve.

This property is read/write.

Remarks

The default value is ColorSource.Color2.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.SrgbWriteEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.SrgbWriteEnable Property

Retrieves or sets a render state that enables render-target writes to be gamma corrected to sRGB.

Definition

Visual Basic | Public Property SrgbWriteEnable As Boolean
C# | public bool SrgbWriteEnable { get; set; }
C++ public:
property bool SrgbWriteEnable {
bool get();
void set(bool value);
}
JScript public function get SrgbWriteEnable() : boolean
public function set SrgbWriteEnable(boolean);

Property Value

System.Boolean
Set to true to enable sRGB writes, or false to disable it. The default value is false.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.StencilEnable Property

Retrieves or sets stencil enabling.

Definition

Visual Basic | Public Property StencilEnable As Boolean
C# | public bool StencilEnable { get; set; }
C++ public:
property bool StencilEnable {
bool get();
void set(bool value);
}
JScript public function get StencilEnable() : boolean
public function set StencilEnable(boolean);

Property Value

System.Boolean
Set to true to enable stenciling, or false to disable it.

This property is read/write.

Remarks

The default value is false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilFail Property (Microsoft.DirectX.Direct3D)

RenderStateManager.StencilFail Property

Retrieves or sets the stencil operation to perform if the stencil test fails.

Definition

Visual Basic | Public Property StencilFail As StencilOperation
C# | public StencilOperation StencilFail { get; set; }
C++ public:
property StencilOperation StencilFail {
StencilOperation get();
void set(StencilOperation value);
}
JScript public function get StencilFail() : StencilOperation
public function set StencilFail(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation
Value of the StencilOperation enumeration that represents the value of the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilFunction Property (Microsoft.DirectX.Direct3D)

RenderStateManager.StencilFunction Property

Retrieves or sets the comparison function for the stencil test.

Definition

Visual Basic | Public Property StencilFunction As Compare
C# | public Compare StencilFunction { get; set; }
C++ public:
property Compare StencilFunction {
Compare get();
void set(Compare value);
}
JScript public function get StencilFunction() : Compare
public function set StencilFunction(Compare);

Property Value

Microsoft.DirectX.Direct3D.Compare
A value of the Compare enumeration that represents the comparison function to set or retrieve.

This property is read/write.

Remarks

The default value is Compare.Always.

The comparison function is used to compare the reference value to a stencil buffer entry. This comparison applies only to the bits in the reference value and stencil buffer entry that are set in the stencil mask (by RenderStateManager.StencilMask). If the comparison is true, the stencil test passes.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilMask Property (Microsoft.DirectX.Direct3D)

RenderStateManager.StencilMask Property

Retrieves or sets the mask applied to the reference value and each stencil buffer entry to determine the significant bits for the stencil test.

Definition

Visual Basic | Public Property StencilMask As Integer
C# | public int StencilMask { get; set; }
C++ public:
property int StencilMask {
int get();
void set(int value);
}
JScript public function get StencilMask() : int
public function set StencilMask(int);

Property Value

System.Int32
Integer value that represents the mask to set or retrieve.

This property is read/write.

Remarks

The default mask is 0xFFFFFFFF.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilPass Property (Microsoft.DirectX.Direct3D)

RenderStateManager.StencilPass Property

Retrieves or sets the stencil operation to perform if both the stencil test and the depth test (z-test) pass.

Definition

Visual Basic | Public Property StencilPass As StencilOperation
C# | public StencilOperation StencilPass { get; set; }
C++ public:
property StencilOperation StencilPass {
StencilOperation get();
void set(StencilOperation value);
}
JScript public function get StencilPass() : StencilOperation
public function set StencilPass(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation
Value of the StencilOperation enumeration that represents the value of the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilWriteMask Property (Microsoft.DirectX.Direct3D)

RenderStateManager.StencilWriteMask Property

Retrieves or sets the write mask applied to values written into the stencil buffer.

Definition

Visual Basic | Public Property StencilWriteMask As Integer
C# | public int StencilWriteMask { get; set; }
C++ public:
property int StencilWriteMask {
int get();
void set(int value);
}
JScript public function get StencilWriteMask() : int
public function set StencilWriteMask(int);

Property Value

System.Int32
Integer value that represents the write mask to set or retrieve.

This property is read/write.

Remarks

The default mask is 0xFFFFFFFF.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.StencilZBufferFail Property (Microsoft.DirectX.Direct3D)

RenderStateManager.StencilZBufferFail Property

Retrieves or sets the stencil operation to perform if the stencil test passes and the depth test (z-test) fails.

Definition

Visual Basic | Public Property StencilZBufferFail As StencilOperation
C# | public StencilOperation StencilZBufferFail { get; set; }
C++ public:
property StencilOperation StencilZBufferFail {
StencilOperation get();
void set(StencilOperation value);
}
JScript public function get StencilZBufferFail() : StencilOperation
public function set StencilZBufferFail(StencilOperation);

Property Value

Microsoft.DirectX.Direct3D.StencilOperation
Value of the StencilOperation enumeration that represents the value of the stencil operation to set or retrieve.

This property is read/write.

Remarks

The default value is StencilOperation.Keep.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.TextureFactor Property (Microsoft.DirectX.Direct3D)

RenderStateManager.TextureFactor Property

Retrieves or sets the color used for multiple-texture blending with the TextureArgument.TFactor texture blending argument or the TextureOperation.BlendFactorAlpha texture blending operation.

Definition

Visual Basic | Public Property TextureFactor As Integer
C# | public int TextureFactor { get; set; }
C++ public:
property int TextureFactor {
int get();
void set(int value);
}
JScript public function get TextureFactor() : int
public function set TextureFactor(int);

Property Value

System.Int32
Integer value that represents the color value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.TweenFactor Property (Microsoft.DirectX.Direct3D)

RenderStateManager.TweenFactor Property

Retrieves or sets a floating-point value that controls the tween factor.

Definition

Visual Basic | Public Property TweenFactor As Single
C# | public float TweenFactor { get; set; }
C++ public:
property float TweenFactor {
float get();
void set(float value);
}
JScript public function get TweenFactor() : float
public function set TweenFactor(float);

Property Value

System.Single
Value that controls the tween factor.

This property is read/write.

Remarks

The default value is 0.0f.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.TwoSidedStencilMode Property (Microsoft.DirectX.Direct3D)

RenderStateManager.TwoSidedStencilMode Property

Enables or disables two-sided stenciling.

Definition

Visual Basic | Public Property TwoSidedStencilMode As Boolean
C# | public bool TwoSidedStencilMode { get; set; }
C++ public:
property bool TwoSidedStencilMode {
bool get();
void set(bool value);
}
JScript public function get TwoSidedStencilMode() : boolean
public function set TwoSidedStencilMode(boolean);

Property Value

System.Boolean
Set to true to enable two-sided stenciling, or false to disable it.

This property is read/write.

Remarks

The application should set RenderStateManager.CullMode to Cull.None to enable two-sided stencil mode. If the triangle winding order is clockwise, the RenderStateManager.Stencil* operations are used. If the winding order is counterclockwise, the RenderStateManager.CounterClockwiseStencil* operations are used.

See Also

  • StencilOperation

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.UseWBuffer Property (Microsoft.DirectX.Direct3D)

RenderStateManager.UseWBuffer Property

Enables or disables w-buffering.

Definition

Visual Basic | Public Property UseWBuffer As Boolean
C# | public bool UseWBuffer { get; set; }
C++ public:
property bool UseWBuffer {
bool get();
void set(bool value);
}
JScript public function get UseWBuffer() : boolean
public function set UseWBuffer(boolean);

Property Value

System.Boolean
Value that is set to true to enable w-buffering, or false to disable it.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.VertexBlend Property (Microsoft.DirectX.Direct3D)

RenderStateManager.VertexBlend Property

Retrieves or sets the number of matrices to use to perform geometry blending.

Definition

Visual Basic | Public Property VertexBlend As VertexBlend
C# | public VertexBlend VertexBlend { get; set; }
C++ public:
property VertexBlend VertexBlend {
VertexBlend get();
void set(VertexBlend value);
}
JScript public function get VertexBlend() : VertexBlend
public function set VertexBlend(VertexBlend);

Property Value

Microsoft.DirectX.Direct3D.VertexBlend
Value of the VertexBlend enumeration to set or retrieve.

This property is read/write.

Remarks

The default value is VertexBlend.Disable.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap0 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap0 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap0 As WrapCoordinates
C# | public WrapCoordinates Wrap0 { get; set; }
C++ public:
property WrapCoordinates Wrap0 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap0() : WrapCoordinates
public function set Wrap0(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap1 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap1 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap1 As WrapCoordinates
C# | public WrapCoordinates Wrap1 { get; set; }
C++ public:
property WrapCoordinates Wrap1 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap1() : WrapCoordinates
public function set Wrap1(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap10 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap10 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap10 As WrapCoordinates
C# | public WrapCoordinates Wrap10 { get; set; }
C++ public:
property WrapCoordinates Wrap10 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap10() : WrapCoordinates
public function set Wrap10(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap11 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap11 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap11 As WrapCoordinates
C# | public WrapCoordinates Wrap11 { get; set; }
C++ public:
property WrapCoordinates Wrap11 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap11() : WrapCoordinates
public function set Wrap11(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap12 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap12 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap12 As WrapCoordinates
C# | public WrapCoordinates Wrap12 { get; set; }
C++ public:
property WrapCoordinates Wrap12 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap12() : WrapCoordinates
public function set Wrap12(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap13 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap13 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap13 As WrapCoordinates
C# | public WrapCoordinates Wrap13 { get; set; }
C++ public:
property WrapCoordinates Wrap13 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap13() : WrapCoordinates
public function set Wrap13(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap14 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap14 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap14 As WrapCoordinates
C# | public WrapCoordinates Wrap14 { get; set; }
C++ public:
property WrapCoordinates Wrap14 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap14() : WrapCoordinates
public function set Wrap14(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap15 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap15 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap15 As WrapCoordinates
C# | public WrapCoordinates Wrap15 { get; set; }
C++ public:
property WrapCoordinates Wrap15 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap15() : WrapCoordinates
public function set Wrap15(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap2 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap2 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap2 As WrapCoordinates
C# | public WrapCoordinates Wrap2 { get; set; }
C++ public:
property WrapCoordinates Wrap2 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap2() : WrapCoordinates
public function set Wrap2(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap3 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap3 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap3 As WrapCoordinates
C# | public WrapCoordinates Wrap3 { get; set; }
C++ public:
property WrapCoordinates Wrap3 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap3() : WrapCoordinates
public function set Wrap3(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap4 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap4 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap4 As WrapCoordinates
C# | public WrapCoordinates Wrap4 { get; set; }
C++ public:
property WrapCoordinates Wrap4 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap4() : WrapCoordinates
public function set Wrap4(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap5 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap5 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap5 As WrapCoordinates
C# | public WrapCoordinates Wrap5 { get; set; }
C++ public:
property WrapCoordinates Wrap5 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap5() : WrapCoordinates
public function set Wrap5(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap6 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap6 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap6 As WrapCoordinates
C# | public WrapCoordinates Wrap6 { get; set; }
C++ public:
property WrapCoordinates Wrap6 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap6() : WrapCoordinates
public function set Wrap6(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap7 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap7 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap7 As WrapCoordinates
C# | public WrapCoordinates Wrap7 { get; set; }
C++ public:
property WrapCoordinates Wrap7 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap7() : WrapCoordinates
public function set Wrap7(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap8 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap8 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap8 As WrapCoordinates
C# | public WrapCoordinates Wrap8 { get; set; }
C++ public:
property WrapCoordinates Wrap8 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap8() : WrapCoordinates
public function set Wrap8(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.Wrap9 Property (Microsoft.DirectX.Direct3D)

RenderStateManager.Wrap9 Property

Retrieves or sets the texture-wrapping behavior for multiple sets of texture coordinates.

Definition

Visual Basic | Public Property Wrap9 As WrapCoordinates
C# | public WrapCoordinates Wrap9 { get; set; }
C++ public:
property WrapCoordinates Wrap9 {
WrapCoordinates get();
void set(WrapCoordinates value);
}
JScript public function get Wrap9() : WrapCoordinates
public function set Wrap9(WrapCoordinates);

Property Value

Microsoft.DirectX.Direct3D.WrapCoordinates
Combination of values from the WrapCoordinates enumeration to set or retrieve.

This property is read/write.

Remarks

The default value for this render state is 0 (wrapping disabled in all directions).

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ZBufferEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ZBufferEnable Property

Enables or disables depth buffering.

Definition

Visual Basic | Public Property ZBufferEnable As Boolean
C# | public bool ZBufferEnable { get; set; }
C++ public:
property bool ZBufferEnable {
bool get();
void set(bool value);
}
JScript public function get ZBufferEnable() : boolean
public function set ZBufferEnable(boolean);

Property Value

System.Boolean
Set to true to enable depth buffering, or false to disable it.

This property is read/write.

Remarks

The default value is true.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ZBufferFunction Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ZBufferFunction Property

Retrieves or sets the comparison function for the z-buffer test.

Definition

Visual Basic | Public Property ZBufferFunction As Compare
C# | public Compare ZBufferFunction { get; set; }
C++ public:
property Compare ZBufferFunction {
Compare get();
void set(Compare value);
}
JScript public function get ZBufferFunction() : Compare
public function set ZBufferFunction(Compare);

Property Value

Microsoft.DirectX.Direct3D.Compare
Value of the Compare enumeration that represents the comparison function to set or retrieve.

This property is read/write.

Remarks

The depth value of the pixel is compared to the depth-buffer value. If the depth value of the pixel passes the comparison function, the pixel is written.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderStateManager.ZBufferWriteEnable Property (Microsoft.DirectX.Direct3D)

RenderStateManager.ZBufferWriteEnable Property

Enables or disables writing to the depth buffer.

Definition

Visual Basic | Public Property ZBufferWriteEnable As Boolean
C# | public bool ZBufferWriteEnable { get; set; }
C++ public:
property bool ZBufferWriteEnable {
bool get();
void set(bool value);
}
JScript public function get ZBufferWriteEnable() : boolean
public function set ZBufferWriteEnable(boolean);

Property Value

System.Boolean
Set to true to enable writing to the depth buffer, or false to disable it.

This property is read/write.

Remarks

The default value is true.

This member enables an application to prevent the system from updating the depth buffer with new depth values.

If false, depth comparisons are still made according to the render state ZBufferFunction, assuming that depth buffering is taking place, but depth values are not written to the buffer.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderToEnvironmentMap Class (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap Class

Generalizes the process of rendering to environment maps. An environment map is used to texture-map scene geometry to provide a more sophisticated scene without using complex geometry. This class supports the creation of surfaces for the following kinds of geometry: cube, half sphere or hemispheric, parabolic, and sphere.

Definition

Visual Basic NotInheritable Public Class RenderToEnvironmentMap
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class RenderToEnvironmentMap : MarshalByRefObject, IDisposable
C++ | public ref class RenderToEnvironmentMap sealed : MarshalByRefObject, IDisposable
JScript | public final class RenderToEnvironmentMap extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the RenderToEnvironmentMap object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally immediately prior to a device reset.
Reset | Occurs after the RenderToEnvironmentMap.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
BeginCube | Initiates the rendering of a cubic environment map.
BeginHemisphere | Initiates the rendering of a hemisphere environment map.
BeginParabolic | Initiates the rendering of a parabolic environment map.
BeginSphere | Initiates the rendering of a spherical environment map.
Dispose | Immediately releases the unmanaged resources used by the RenderToEnvironmentMap object.
End | Ends a scene for an environmental map.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Face | Initiates the drawing of each face of an environment map.
Finalize | Allows the RenderToEnvironmentMap object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposing event when called from within a derived class.
raise_Lost | Raises a RenderToEnvironmentMap.Lost event when called from within a derived class.
raise_Reset | Raises a RenderToEnvironmentMap.Reset event when called from within a derived class.
RenderToEnvironmentMap | Initializes a new instance of the RenderToEnvironmentMap class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this RenderToEnvironmentMap object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves the description of the render surface.
Device | Retrieves the Device associated with the environment map.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXRenderToEnvMap interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
RenderToEnvironmentMap

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RenderToEnvironmentMap.BeginCube(CubeTexture) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.BeginCube Method

Initiates the rendering of a cubic environment map.

Definition

Visual Basic Public Sub BeginCube( _
ByVal cubeTexture As CubeTexture _
)
C# public void BeginCube(
CubeTexture cubeTexture
);
C++ public:
void BeginCube(
CubeTexture^ cubeTexture
);
JScript public function BeginCube(
cubeTexture : CubeTexture
);

Parameters

cubeTexture Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the cube texture to render.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • RenderToEnvironmentMap.End
  • RenderToEnvironmentMap.Face


RenderToEnvironmentMap.BeginHemisphere(Texture,Texture) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.BeginHemisphere Method

Initiates the rendering of a hemisphere environment map.

Definition

Visual Basic Public Sub BeginHemisphere( _
ByVal textureZPos As Texture, _
ByVal textureZNeg As Texture _
)
C# public void BeginHemisphere(
Texture textureZPos,
Texture textureZNeg
);
C++ public:
void BeginHemisphere(
Texture^ textureZPos,
Texture^ textureZNeg
);
JScript public function BeginHemisphere(
textureZPos : Texture,
textureZNeg : Texture
);

Parameters

textureZPos Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the positive texture render surface.
textureZNeg Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the negative texture render surface.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • RenderToEnvironmentMap.End
  • RenderToEnvironmentMap.Face


RenderToEnvironmentMap.BeginParabolic(Texture,Texture) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.BeginParabolic Method

Initiates the rendering of a parabolic environment map.

Definition

Visual Basic Public Sub BeginParabolic( _
ByVal textureZPos As Texture, _
ByVal textureZNeg As Texture _
)
C# public void BeginParabolic(
Texture textureZPos,
Texture textureZNeg
);
C++ public:
void BeginParabolic(
Texture^ textureZPos,
Texture^ textureZNeg
);
JScript public function BeginParabolic(
textureZPos : Texture,
textureZNeg : Texture
);

Parameters

textureZPos Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the positive render texture.
textureZNeg Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the negative render texture.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • RenderToEnvironmentMap.End
  • RenderToEnvironmentMap.Face


RenderToEnvironmentMap.BeginSphere(Texture) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.BeginSphere Method

Initiates the rendering of a spherical environment map.

Definition

Visual Basic Public Sub BeginSphere( _
ByVal texture As Texture _
)
C# public void BeginSphere(
Texture texture
);
C++ public:
void BeginSphere(
Texture^ texture
);
JScript public function BeginSphere(
texture : Texture
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the texture to render.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • RenderToEnvironmentMap.End
  • RenderToEnvironmentMap.Face


RenderToEnvironmentMap.Dispose() Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Dispose Method

Immediately releases the unmanaged resources used by the RenderToEnvironmentMap object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~RenderToEnvironmentMap();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposed
  • Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposing


RenderToEnvironmentMap.End(Int32) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.End Method

Ends a scene for an environmental map.

Definition

Visual Basic Public Sub End( _
ByVal faceMapFilter As Integer _
)
C# public void End(
int faceMapFilter
);
C++ public:
void End(
int faceMapFilter
);
JScript public function End(
faceMapFilter : int
);

Parameters

faceMapFilter System.Int32
Valid combination of Filter enumeration values.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.Equals(Object) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


RenderToEnvironmentMap.Face(CubeMapFace,Int32) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Face Method

Initiates the drawing of each face of an environment map.

Definition

Visual Basic Public Sub Face( _
ByVal face As CubeMapFace, _
ByVal faceMapFilter As Integer _
)
C# public void Face(
CubeMapFace face,
int faceMapFilter
);
C++ public:
void Face(
CubeMapFace face,
int faceMapFilter
);
JScript public function Face(
face : CubeMapFace,
faceMapFilter : int
);

Parameters

face Microsoft.DirectX.Direct3D.CubeMapFace
A CubeMapFace object that represents the first face of the environmental cube map.
faceMapFilter System.Int32
Valid combination of Filter enumeration values.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.Finalize() Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Finalize Method

Allows the RenderToEnvironmentMap object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~RenderToEnvironmentMap();
C++ | !RenderToEnvironmentMap();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


RenderToEnvironmentMap.GetHashCode() Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


RenderToEnvironmentMap.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXRenderToEnvMap, which allows unmanaged COM clients to create an instance of the managed RenderToEnvironmentMap class. Not supported.


RenderToEnvironmentMap.OnLostDevice() Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.OnLostDevice Method

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic | Public Sub OnLostDevice()
C# | public void OnLostDevice();
C++ public:
void OnLostDevice();
JScript | public function OnLostDevice();

Remarks

This method should be called whenever a device is lost. Before the object can be used again, the device must be reset and the RenderToEnvironmentMap.OnResetDevice method called.


RenderToEnvironmentMap.OnResetDevice() Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.OnResetDevice Method

Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic | Public Sub OnResetDevice()
C# | public void OnResetDevice();
C++ public:
void OnResetDevice();
JScript | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, under normal circumstances it is unnecessary to call RenderToEnvironmentMap.OnResetDevice. However, if at any point Device.IsUsingEventHandlers is set to false, RenderToEnvironmentMap.OnResetDevice should be called immediately after the device is reset.


RenderToEnvironmentMap.op_Equality(RenderToEnvironmentMap,RenderToEnvironmentMap) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As RenderToEnvironmentMap, _
ByVal right As RenderToEnvironmentMap _
) As Boolean
C# public static bool op_Equality(
RenderToEnvironmentMap left,
RenderToEnvironmentMap right
);
C++ public:
static bool operator==(
RenderToEnvironmentMap^ left,
RenderToEnvironmentMap^ right
);
JScript public static function op_Equality(
left : RenderToEnvironmentMap,
right : RenderToEnvironmentMap
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.RenderToEnvironmentMap
The RenderToEnvironmentMap object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.RenderToEnvironmentMap
The RenderToEnvironmentMap object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


RenderToEnvironmentMap.op_Inequality(RenderToEnvironmentMap,RenderToEnvironmentMap) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As RenderToEnvironmentMap, _
ByVal right As RenderToEnvironmentMap _
) As Boolean
C# public static bool op_Inequality(
RenderToEnvironmentMap left,
RenderToEnvironmentMap right
);
C++ public:
static bool operator!=(
RenderToEnvironmentMap^ left,
RenderToEnvironmentMap^ right
);
JScript public static function op_Inequality(
left : RenderToEnvironmentMap,
right : RenderToEnvironmentMap
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.RenderToEnvironmentMap
The RenderToEnvironmentMap object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.RenderToEnvironmentMap
The RenderToEnvironmentMap object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


RenderToEnvironmentMap.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


RenderToEnvironmentMap.raise_Lost(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.raise_Lost Method

Raises a RenderToEnvironmentMap.Lost event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
C++ protected:
void raise_Lost(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


RenderToEnvironmentMap.raise_Reset(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.raise_Reset Method

Raises a RenderToEnvironmentMap.Reset event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
C++ protected:
void raise_Reset(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


RenderToEnvironmentMap.RenderToEnvironmentMap Constructor ()

Initializes a new instance of the RenderToEnvironmentMap class.

Overload List

public RenderToEnvironmentMap(Device, int, int, Format, bool, DepthFormat);
public RenderToEnvironmentMap(ID3DXRenderToEnvMap);
public RenderToEnvironmentMap(IntPtr);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.RenderToEnvironmentMap(ID3DXRenderToEnvMap) Constructor (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.RenderToEnvironmentMap Constructor

Initializes a new instance of the RenderToEnvironmentMap class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXRenderToEnvMap _
)
C# public RenderToEnvironmentMap(
ID3DXRenderToEnvMap pUnk
);
C++ public:
RenderToEnvironmentMap(
ID3DXRenderToEnvMap pUnk
);
JScript public function RenderToEnvironmentMap(
pUnk : ID3DXRenderToEnvMap
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToEnvMap
Unmanaged Component Object Model (COM) ID3DXRenderToEnvMap interface pointer.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.RenderToEnvironmentMap(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.RenderToEnvironmentMap Constructor

Initializes a new instance of the RenderToEnvironmentMap class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public RenderToEnvironmentMap(
IntPtr unmanagedObject
);
C++ public:
RenderToEnvironmentMap(
IntPtr unmanagedObject
);
JScript public function RenderToEnvironmentMap(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXRenderToEnvMap interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.RenderToEnvironmentMap(Device,Int32,Int32,Format,Boolean,DepthFormat) Constructor (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.RenderToEnvironmentMap Constructor

Initializes a new instance of the RenderToEnvironmentMap class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal format As Format, _
ByVal depthStencil As Boolean, _
ByVal depthStencilFormat As DepthFormat _
)
C# public RenderToEnvironmentMap(
Device device,
int size,
int mipLevels,
Format format,
bool depthStencil,
DepthFormat depthStencilFormat
);
C++ public:
RenderToEnvironmentMap(
Device^ device,
int size,
int mipLevels,
Format format,
bool depthStencil,
DepthFormat depthStencilFormat
);
JScript public function RenderToEnvironmentMap(
device : Device,
size : int,
mipLevels : int,
format : Format,
depthStencil : boolean,
depthStencilFormat : DepthFormat
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device to associate with the render surface.
size System.Int32
Value that represents the size of the render surface.
mipLevels System.Int32
Value that represents the number of mipmap levels.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that describes the pixel format of the environment map.
depthStencil System.Boolean
Set to true if the render surface supports a depth-stencil surface; otherwise, false.
depthStencilFormat Microsoft.DirectX.Direct3D.DepthFormat
If depthStencil is true, this parameter is a member of the Format enumeration that describes the environment map's depth-stencil format.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


RenderToEnvironmentMap.UpdateUnmanagedPointer(ID3DXRenderToEnvMap) Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this RenderToEnvironmentMap object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXRenderToEnvMap _
)
C# public void UpdateUnmanagedPointer(
ID3DXRenderToEnvMap pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXRenderToEnvMap pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXRenderToEnvMap
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToEnvMap
Pointer to the ID3DXRenderToEnvMap structure used to update the unmanaged pointer for this RenderToEnvironmentMap object.


RenderToEnvironmentMap.Description Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Description Property

Retrieves the description of the render surface.

Definition

Visual Basic | Public ReadOnly Property Description As RenderToEnvironmentDescription
C# | public RenderToEnvironmentDescription Description { get; }
C++ public:
property RenderToEnvironmentDescription Description {
RenderToEnvironmentDescription get();
}
JScript | public function get Description() : RenderToEnvironmentDescription

Property Value

Microsoft.DirectX.Direct3D.RenderToEnvironmentDescription
A RenderToEnvironmentDescription object that contains the render surface description.

This property is read-only.


RenderToEnvironmentMap.Device Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Device Property

Retrieves the Device associated with the environment map.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device object associated with the environment map.

This property is read-only.


RenderToEnvironmentMap.Disposed Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


RenderToEnvironmentMap.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXRenderToEnvMap interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXRenderToEnvMap
C# | public ID3DXRenderToEnvMap UnmanagedComPointer { get; }
C++ public:
property ID3DXRenderToEnvMap UnmanagedComPointer {
ID3DXRenderToEnvMap get();
}
JScript | public function get UnmanagedComPointer() : ID3DXRenderToEnvMap

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToEnvMap
Unmanaged ID3DXRenderToEnvMap interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


RenderToEnvironmentMap.Disposing Event (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Disposing Event

Occurs when the Dispose method is called or when the RenderToEnvironmentMap object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.RenderToEnvironmentMap.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the RenderToEnvironmentMap object indicates whether that object has been disposed.


RenderToEnvironmentMap.Lost Event (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Lost Event

Occurs when an object is lost, normally immediately prior to a device reset.

Definition

Visual Basic | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
C++ public:
event EventHandler^ Lost;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a RenderToEnvironmentMap.Lost event, use the following C# code.

[C#]
rtem.Lost += new System.EventHandler(this.LostEventHandler);


RenderToEnvironmentMap.Reset Event (Microsoft.DirectX.Direct3D)

RenderToEnvironmentMap.Reset Event

Occurs after the RenderToEnvironmentMap.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
C++ public:
event EventHandler^ Reset;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a RenderToEnvironmentMap.OnResetDevice event, use the following C# code.

[C#]
rtem.Reset += new System.EventHandler(this.ResetEventHandler);


RenderToSurface Class (Microsoft.DirectX.Direct3D)

RenderToSurface Class

Generalizes the process of rendering to surfaces. Surfaces can be used in a variety of ways; for example, as render targets, or for off-screen rendering and rendering to textures.

Definition

Visual Basic NotInheritable Public Class RenderToSurface
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class RenderToSurface : MarshalByRefObject, IDisposable
C++ | public ref class RenderToSurface sealed : MarshalByRefObject, IDisposable
JScript | public final class RenderToSurface extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the RenderToSurface object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally immediately prior to a device reset.
Reset | Occurs after the RenderToSurface.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
BeginScene | Begins a scene.
Dispose | Immediately releases the unmanaged resources used by the RenderToSurface object.
EndScene | Ends a scene.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the RenderToSurface object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.RenderToSurface.Disposing event when called from within a derived class.
raise_Lost | Raises a RenderToSurface.Lost event when called from within a derived class.
raise_Reset | Raises a RenderToSurface.Reset event when called from within a derived class.
RenderToSurface | Initializes a new instance of the RenderToSurface class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this RenderToSurface object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Description | Retrieves the description of the render surface.
Device | Retrieves the Device associated with the render surface.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXRenderToSurface interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
RenderToSurface

Remarks

To provide a custom render view, a surface can be configured using a separate viewport by calling RenderToSurface.BeginScene.

If the surface is not a render target, a compatible render target is used, and the result is copied to the surface at the end of the scene.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RenderToSurface.BeginScene Method ()

Begins a scene.

Overload List

public void BeginScene(Surface);
public void BeginScene(Surface, Viewport);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • RenderToSurface.EndScene


RenderToSurface.BeginScene(Surface) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.BeginScene Method

Begins a scene.

Definition

Visual Basic Public Sub BeginScene( _
ByVal surface As Surface _
)
C# public void BeginScene(
Surface surface
);
C++ public:
void BeginScene(
Surface^ surface
);
JScript public function BeginScene(
surface : Surface
);

Parameters

surface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the render surface.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • RenderToSurface.EndScene


RenderToSurface.BeginScene(Surface,Viewport) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.BeginScene Method

Begins a scene.

Definition

Visual Basic Public Sub BeginScene( _
ByVal surface As Surface, _
ByVal viewport As Viewport _
)
C# public void BeginScene(
Surface surface,
Viewport viewport
);
C++ public:
void BeginScene(
Surface^ surface,
Viewport viewport
);
JScript public function BeginScene(
surface : Surface,
viewport : Viewport
);

Parameters

surface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the render surface.
viewport Microsoft.DirectX.Direct3D.Viewport
A Viewport object that describes the viewport for the scene.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • RenderToSurface.EndScene


RenderToSurface.Dispose() Method (Microsoft.DirectX.Direct3D)

RenderToSurface.Dispose Method

Immediately releases the unmanaged resources used by the RenderToSurface object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~RenderToSurface();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.RenderToSurface.Disposed
  • Microsoft.DirectX.Direct3D.RenderToSurface.Disposing


RenderToSurface.EndScene(Filter) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.EndScene Method

Ends a scene.

Definition

Visual Basic Public Sub EndScene( _
ByVal mipFilter As Filter _
)
C# public void EndScene(
Filter mipFilter
);
C++ public:
void EndScene(
Filter mipFilter
);
JScript public function EndScene(
mipFilter : Filter
);

Parameters

mipFilter Microsoft.DirectX.Direct3D.Filter
Valid combination of Filter enumeration values.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • RenderToSurface.BeginScene


RenderToSurface.Equals(Object) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


RenderToSurface.Finalize() Method (Microsoft.DirectX.Direct3D)

RenderToSurface.Finalize Method

Allows the RenderToSurface object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~RenderToSurface();
C++ | !RenderToSurface();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


RenderToSurface.GetHashCode() Method (Microsoft.DirectX.Direct3D)

RenderToSurface.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


RenderToSurface.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXRenderToSurface, which allows unmanaged COM clients to create an instance of the managed RenderToSurface class. Not supported.


RenderToSurface.OnLostDevice() Method (Microsoft.DirectX.Direct3D)

RenderToSurface.OnLostDevice Method

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic | Public Sub OnLostDevice()
C# | public void OnLostDevice();
C++ public:
void OnLostDevice();
JScript | public function OnLostDevice();

Remarks

This method should be called whenever the device is lost. Before the object can be used again, the device must be reset and the RenderToSurface.OnResetDevice method called.


RenderToSurface.OnResetDevice() Method (Microsoft.DirectX.Direct3D)

RenderToSurface.OnResetDevice Method

Should be called after a device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic | Public Sub OnResetDevice()
C# | public void OnResetDevice();
C++ public:
void OnResetDevice();
JScript | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, under normal circumstances it is unnecessary to call RenderToSurface.OnResetDevice. However, if at any point Device.IsUsingEventHandlers is set to false, RenderToSurface.OnResetDevice should be called immediately after the device is reset.


RenderToSurface.op_Equality(RenderToSurface,RenderToSurface) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As RenderToSurface, _
ByVal right As RenderToSurface _
) As Boolean
C# public static bool op_Equality(
RenderToSurface left,
RenderToSurface right
);
C++ public:
static bool operator==(
RenderToSurface^ left,
RenderToSurface^ right
);
JScript public static function op_Equality(
left : RenderToSurface,
right : RenderToSurface
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.RenderToSurface
The RenderToSurface object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.RenderToSurface
The RenderToSurface object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


RenderToSurface.op_Inequality(RenderToSurface,RenderToSurface) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As RenderToSurface, _
ByVal right As RenderToSurface _
) As Boolean
C# public static bool op_Inequality(
RenderToSurface left,
RenderToSurface right
);
C++ public:
static bool operator!=(
RenderToSurface^ left,
RenderToSurface^ right
);
JScript public static function op_Inequality(
left : RenderToSurface,
right : RenderToSurface
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.RenderToSurface
The RenderToSurface object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.RenderToSurface
The RenderToSurface object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


RenderToSurface.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.RenderToSurface.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


RenderToSurface.raise_Lost(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.raise_Lost Method

Raises a RenderToSurface.Lost event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
C++ protected:
void raise_Lost(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


RenderToSurface.raise_Reset(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.raise_Reset Method

Raises a RenderToSurface.Reset event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
C++ protected:
void raise_Reset(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


RenderToSurface.RenderToSurface Constructor ()

Initializes a new instance of the RenderToSurface class.

Overload List

public RenderToSurface(Device, int, int, Format, bool, DepthFormat);
public RenderToSurface(ID3DXRenderToSurface);
public RenderToSurface(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


RenderToSurface.RenderToSurface(ID3DXRenderToSurface) Constructor (Microsoft.DirectX.Direct3D)

RenderToSurface.RenderToSurface Constructor

Initializes a new instance of the RenderToSurface class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXRenderToSurface _
)
C# public RenderToSurface(
ID3DXRenderToSurface pUnk
);
C++ public:
RenderToSurface(
ID3DXRenderToSurface pUnk
);
JScript public function RenderToSurface(
pUnk : ID3DXRenderToSurface
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToSurface
Unmanaged Component Object Model (COM) ID3DXRenderToSurface interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


RenderToSurface.RenderToSurface(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

RenderToSurface.RenderToSurface Constructor

Initializes a new instance of the RenderToSurface class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public RenderToSurface(
IntPtr unmanagedObject
);
C++ public:
RenderToSurface(
IntPtr unmanagedObject
);
JScript public function RenderToSurface(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXRenderToSurface interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


RenderToSurface.RenderToSurface(Device,Int32,Int32,Format,Boolean,DepthFormat) Constructor (Microsoft.DirectX.Direct3D)

RenderToSurface.RenderToSurface Constructor

Initializes a new instance of the RenderToSurface class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal format As Format, _
ByVal depthStencil As Boolean, _
ByVal depthStencilFormat As DepthFormat _
)
C# public RenderToSurface(
Device device,
int width,
int height,
Format format,
bool depthStencil,
DepthFormat depthStencilFormat
);
C++ public:
RenderToSurface(
Device^ device,
int width,
int height,
Format format,
bool depthStencil,
DepthFormat depthStencilFormat
);
JScript public function RenderToSurface(
device : Device,
width : int,
height : int,
format : Format,
depthStencil : boolean,
depthStencilFormat : DepthFormat
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device to associate with the render surface.
width System.Int32
Value that represents the width of the render surface, in pixels.
height System.Int32
Value that represents the height of the render surface, in pixels.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration that describes the pixel format of the render surface.
depthStencil System.Boolean
Set to true if the render surface supports a depth-stencil surface; otherwise, false.
depthStencilFormat Microsoft.DirectX.Direct3D.DepthFormat
If depthStencil is set to true, this parameter is a member of the Format enumeration that describes the depth-stencil format of the render surface.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


RenderToSurface.UpdateUnmanagedPointer(ID3DXRenderToSurface) Method (Microsoft.DirectX.Direct3D)

RenderToSurface.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this RenderToSurface object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXRenderToSurface _
)
C# public void UpdateUnmanagedPointer(
ID3DXRenderToSurface pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXRenderToSurface pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXRenderToSurface
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToSurface
Pointer to the ID3DXRenderToSurface structure used to update the unmanaged pointer for this RenderToSurface object.


RenderToSurface.Description Property (Microsoft.DirectX.Direct3D)

RenderToSurface.Description Property

Retrieves the description of the render surface.

Definition

Visual Basic | Public ReadOnly Property Description As RenderToSurfaceDescription
C# | public RenderToSurfaceDescription Description { get; }
C++ public:
property RenderToSurfaceDescription Description {
RenderToSurfaceDescription get();
}
JScript | public function get Description() : RenderToSurfaceDescription

Property Value

Microsoft.DirectX.Direct3D.RenderToSurfaceDescription
A RenderToSurfaceDescription object that contains the render surface description.

This property is read-only.


RenderToSurface.Device Property (Microsoft.DirectX.Direct3D)

RenderToSurface.Device Property

Retrieves the Device associated with the render surface.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device object associated with the render surface.

This property is read-only.


RenderToSurface.Disposed Property (Microsoft.DirectX.Direct3D)

RenderToSurface.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


RenderToSurface.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

RenderToSurface.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXRenderToSurface interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXRenderToSurface
C# | public ID3DXRenderToSurface UnmanagedComPointer { get; }
C++ public:
property ID3DXRenderToSurface UnmanagedComPointer {
ID3DXRenderToSurface get();
}
JScript | public function get UnmanagedComPointer() : ID3DXRenderToSurface

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXRenderToSurface
Unmanaged ID3DXRenderToSurface interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


RenderToSurface.Disposing Event (Microsoft.DirectX.Direct3D)

RenderToSurface.Disposing Event

Occurs when the Dispose method is called or when the RenderToSurface object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.RenderToSurface.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the RenderToSurface object indicates whether that object has been disposed.


RenderToSurface.Lost Event (Microsoft.DirectX.Direct3D)

RenderToSurface.Lost Event

Occurs when an object is lost, normally immediately prior to a device reset.

Definition

Visual Basic | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
C++ public:
event EventHandler^ Lost;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a RenderToSurface.Lost event, use the following C# code.

[C#]
rts.Lost += new System.EventHandler(this.LostEventHandler);


RenderToSurface.Reset Event (Microsoft.DirectX.Direct3D)

RenderToSurface.Reset Event

Occurs after the RenderToSurface.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
C++ public:
event EventHandler^ Reset;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a RenderToSurface.OnResetDevice event, use the following C# code.

[C#]
rts.Reset += new System.EventHandler(this.ResetEventHandler);


Resource Class (Microsoft.DirectX.Direct3D)

Resource Class

Queries and prepares resources.

Definition

Visual Basic MustInherit Public Class Resource
Inherits MarshalByRefObject
C# | public abstract class Resource : MarshalByRefObject
C++ | public ref class Resource abstract : MarshalByRefObject
JScript | public abstract class Resource extends MarshalByRefObject

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Resource object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
FreePrivateData | Frees the specified private data associated with the current resource.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PreLoad | Preloads a managed resource.
Resource | Initializes a new instance of the Resource class.
SetPriority | Assigns the resource-management priority for the current resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the device associated with a resource.
Priority | Retrieves or sets the priority for the current resource.
Type | Retrieves the type of a resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
IndexBuffer
Surface
VertexBuffer

Remarks

To create a texture resource, use one of the following objects.

  • CubeTexture
  • Texture
  • VolumeTexture

To create a geometry-oriented resource, call one of the following methods.

  • IndexBuffer
  • VertexBuffer

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Resource.Dispose() Method (Microsoft.DirectX.Direct3D)

Resource.Dispose Method

Immediately releases the unmanaged resources used by the Resource object.

Definition

Visual Basic | MustOverride Public Sub Dispose()
C# | public abstract void Dispose();
C++ | ~Resource();
JScript | public abstract function Dispose();

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Resource.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.FreePrivateData(Guid) Method (Microsoft.DirectX.Direct3D)

Resource.FreePrivateData Method

Frees the specified private data associated with the current resource.

Definition

Visual Basic Public Sub FreePrivateData( _
ByVal guidData As Guid _
)
C# public void FreePrivateData(
Guid guidData
);
C++ public:
void FreePrivateData(
Guid guidData
);
JScript public function FreePrivateData(
guidData : Guid
);

Parameters

guidData System.Guid
Represents a globally unique identifier (GUID) that identifies the private data to free.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested Guid Leave Site was not found.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Resource.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Resource.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DResource9, which allows unmanaged COM clients to create an instance of the managed Resource class. Not supported.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.GetPrivateData(Guid) Method (Microsoft.DirectX.Direct3D)

Resource.GetPrivateData Method

Copies the private data associated with a resource to a buffer.

Definition

Visual Basic Public Function GetPrivateData( _
ByVal guidData As Guid _
) As Byte()
C# public byte[] GetPrivateData(
Guid guidData
);
C++ public:
array<unsigned char>^ GetPrivateData(
Guid guidData
);
JScript public function GetPrivateData(
guidData : Guid
) : byte[];

Parameters

guidData System.Guid
Represents a globally unique identifier (GUID) that identifies the private data to retrieve.

Return Value

System.Byte[]
Returns an array of bytes Leave Site that contains the requested private data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested Guid Leave Site was not found.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.op_Equality(Resource,Resource) Method (Microsoft.DirectX.Direct3D)

Resource.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Resource, _
ByVal right As Resource _
) As Boolean
C# public static bool op_Equality(
Resource left,
Resource right
);
C++ public:
static bool operator==(
Resource^ left,
Resource^ right
);
JScript public static function op_Equality(
left : Resource,
right : Resource
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Resource
The Resource object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Resource
The Resource object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.op_Inequality(Resource,Resource) Method (Microsoft.DirectX.Direct3D)

Resource.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Resource, _
ByVal right As Resource _
) As Boolean
C# public static bool op_Inequality(
Resource left,
Resource right
);
C++ public:
static bool operator!=(
Resource^ left,
Resource^ right
);
JScript public static function op_Inequality(
left : Resource,
right : Resource
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Resource
The Resource object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Resource
The Resource object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.PreLoad() Method (Microsoft.DirectX.Direct3D)

Resource.PreLoad Method

Preloads a managed resource.

Definition

Visual Basic | Public Sub PreLoad()
C# | public void PreLoad();
C++ public:
void PreLoad();
JScript | public function PreLoad();

Remarks

Calling this method indicates that the application will need the managed resource shortly. This method has no effect on nonmanaged resources.

Resource.PreLoad detects "thrashing" conditions, in which more resources are used in each frame than can fit in video memory simultaneously. Under such circumstances, Resource.PreLoad silently does nothing.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Resource Constructor ()

Initializes a new instance of the Resource class.

Overload List

public Resource(IDirect3DResource9);
public Resource(IntPtr);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Resource.Resource(IDirect3DResource9) Constructor (Microsoft.DirectX.Direct3D)

Resource.Resource Constructor

Initializes a new instance of the Resource class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DResource9 _
)
C# public Resource(
IDirect3DResource9 pUnk
);
C++ public:
Resource(
IDirect3DResource9 pUnk
);
JScript public function Resource(
pUnk : IDirect3DResource9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DResource9
Unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Resource.Resource(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Resource.Resource Constructor

Initializes a new instance of the Resource class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Resource(
IntPtr unmanagedObject
);
C++ public:
Resource(
IntPtr unmanagedObject
);
JScript public function Resource(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DResource9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Resource.SetPriority(Int32) Method (Microsoft.DirectX.Direct3D)

Resource.SetPriority Method

Assigns the resource-management priority for the current resource.

Definition

Visual Basic Public Function SetPriority( _
ByVal priorityNew As Integer _
) As Integer
C# public int SetPriority(
int priorityNew
);
C++ public:
int SetPriority(
int priorityNew
);
JScript public function SetPriority(
priorityNew : int
) : int;

Parameters

priorityNew System.Int32
New resource-management priority for the resource.

Return Value

System.Int32
Previous priority value for the resource.

Remarks

Resource.SetPriority is used for priority control of managed resources. This method returns 0 on nonmanaged resources.

Priorities are used to determine when managed resources should be removed from memory. A resource assigned a low priority is removed before a resource with a high priority. If two resources have the same priority, the one that was used more recently is kept in memory, while the other is removed. Managed resources have a default priority of 0.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.SetPrivateData(Guid,Byte[]) Method (Microsoft.DirectX.Direct3D)

Resource.SetPrivateData Method

Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource.

Definition

Visual Basic Public Sub SetPrivateData( _
ByVal guidData As Guid, _
ByVal privateData() As Byte _
)
C# public void SetPrivateData(
Guid guidData,
byte[] privateData
);
C++ public:
void SetPrivateData(
Guid guidData,
array<unsigned char>^ privateData
);
JScript public function SetPrivateData(
guidData : Guid,
privateData : byte[]
);

Parameters

guidData System.Guid
A globally unique identifier (GUID) that identifies the private data to set.
privateData System.Byte[]
A Byte Leave Site array that contains the private data to associate with the resource.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft DirectX could not allocate sufficient memory to complete the method call.
ArgumentNullException Leave Site | The privateData parameter is null.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.UpdateUnmanagedPointer(IDirect3DResource9) Method (Microsoft.DirectX.Direct3D)

Resource.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Resource object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DResource9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DResource9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DResource9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DResource9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DResource9
Pointer to the IDirect3DResource9 structure used to update the unmanaged pointer for this Resource object.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Device Property (Microsoft.DirectX.Direct3D)

Resource.Device Property

Retrieves the device associated with a resource.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
Returns a Device object for the resource.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Priority Property (Microsoft.DirectX.Direct3D)

Resource.Priority Property

Retrieves or sets the priority for the current resource.

Definition

Visual Basic | Public Property Priority As Integer
C# | public int Priority { get; set; }
C++ public:
property int Priority {
int get();
void set(int value);
}
JScript public function get Priority() : int
public function set Priority(int);

Property Value

System.Int32
An Int32 Leave Site that represents the current priority of the resource, or a value to set that specifies the new priority for the resource.

This property is read/write.

Remarks

Resource.Priority is used for priority control of managed resources. It returns 0 on nonmanaged resources.

Priorities are used to determine when managed resources should be removed from memory. A resource assigned a low priority is removed before one with a high priority. If two resources have the same priority, the one that was used more recently is kept in memory, while the other is removed. Managed resources have a default priority of 0.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.Type Property (Microsoft.DirectX.Direct3D)

Resource.Type Property

Retrieves the type of a resource.

Definition

Visual Basic | Public ReadOnly Property Type As ResourceType
C# | public ResourceType Type { get; }
C++ public:
property ResourceType Type {
ResourceType get();
}
JScript | public function get Type() : ResourceType

Property Value

Microsoft.DirectX.Direct3D.ResourceType
Returns the ResourceType that identifies the type of the resource.

This property is read-only.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


Resource.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Resource.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DResource9
C# | public IDirect3DResource9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DResource9 UnmanagedComPointer {
IDirect3DResource9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DResource9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DResource9
Unmanaged IDirect3DResource9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.

Applies To

BaseTexture, IndexBuffer, Surface, VertexBuffer


SamplerStateManager Class (Microsoft.DirectX.Direct3D)

SamplerStateManager Class

Contains sampler states for the device.

Definition

Visual Basic NotInheritable Public Class SamplerStateManager
Inherits Object
C# | public sealed class SamplerStateManager : Object
C++ | public ref class SamplerStateManager sealed : Object
JScript | public final class SamplerStateManager extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AddressU | Retrieves or sets the texture-address mode for the u-coordinate.
AddressV | Retrieves or sets the texture-address mode for the v-coordinate.
AddressW | Retrieves or sets the texture-address mode for the w-coordinate.
BorderColor | Retrieves or sets the border color.
BorderColorValue | Retrieves or sets the border color.
DMapOffset | Retrieves or sets the vertex offset in the presampled displacement map.
ElementIndex | Retrieves or sets the element index to use when an element with multiple textures is assigned to the sampler.
MagFilter | Retrieves or sets a magnification filter.
MaxAnisotropy | Retrieves or sets the maximum anisotropy.
MaxMipLevel | Retrieves or sets the LOD index of the largest map to use.
MinFilter | Retrieves or sets a minification filter.
MipFilter | Retrieves or sets a mipmap filter to use during minification.
MipMapLevelOfDetailBias | Retrieves or sets the mipmap level of detail (LOD) bias.
SrgbTexture | Determines whether to use gamma correction.

Inheritance Hierarchy

Object Leave Site
SamplerStateManager

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.ToString() Method (Microsoft.DirectX.Direct3D)

SamplerStateManager.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.AddressU Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.AddressU Property

Retrieves or sets the texture-address mode for the u-coordinate.

Definition

Visual Basic | Public Property AddressU As TextureAddress
C# | public TextureAddress AddressU { get; set; }
C++ public:
property TextureAddress AddressU {
TextureAddress get();
void set(TextureAddress value);
}
JScript public function get AddressU() : TextureAddress
public function set AddressU(TextureAddress);

Property Value

Microsoft.DirectX.Direct3D.TextureAddress
Member of the TextureAddress enumeration to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.AddressV Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.AddressV Property

Retrieves or sets the texture-address mode for the v-coordinate.

Definition

Visual Basic | Public Property AddressV As TextureAddress
C# | public TextureAddress AddressV { get; set; }
C++ public:
property TextureAddress AddressV {
TextureAddress get();
void set(TextureAddress value);
}
JScript public function get AddressV() : TextureAddress
public function set AddressV(TextureAddress);

Property Value

Microsoft.DirectX.Direct3D.TextureAddress
Member of the TextureAddress enumeration to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.AddressW Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.AddressW Property

Retrieves or sets the texture-address mode for the w-coordinate.

Definition

Visual Basic | Public Property AddressW As TextureAddress
C# | public TextureAddress AddressW { get; set; }
C++ public:
property TextureAddress AddressW {
TextureAddress get();
void set(TextureAddress value);
}
JScript public function get AddressW() : TextureAddress
public function set AddressW(TextureAddress);

Property Value

Microsoft.DirectX.Direct3D.TextureAddress
Member of the TextureAddress enumeration to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.BorderColor Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.BorderColor Property

Retrieves or sets the border color.

Definition

Visual Basic | Public Property BorderColor As Color
C# | public Color BorderColor { get; set; }
C++ public:
property Color BorderColor {
Color get();
void set(Color value);
}
JScript public function get BorderColor() : Color
public function set BorderColor(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the border color to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.BorderColorValue Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.BorderColorValue Property

Retrieves or sets the border color.

Definition

Visual Basic | Public Property BorderColorValue As Integer
C# | public int BorderColorValue { get; set; }
C++ public:
property int BorderColorValue {
int get();
void set(int value);
}
JScript public function get BorderColorValue() : int
public function set BorderColorValue(int);

Property Value

System.Int32
Integer that represents the border color to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.DMapOffset Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.DMapOffset Property

Retrieves or sets the vertex offset in the presampled displacement map.

Definition

Visual Basic | Public Property DMapOffset As Integer
C# | public int DMapOffset { get; set; }
C++ public:
property int DMapOffset {
int get();
void set(int value);
}
JScript public function get DMapOffset() : int
public function set DMapOffset(int);

Property Value

System.Int32
Integer that represents the vertex offset in the displacement map to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.ElementIndex Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.ElementIndex Property

Retrieves or sets the element index to use when an element with multiple textures is assigned to the sampler.

Definition

Visual Basic | Public Property ElementIndex As Integer
C# | public int ElementIndex { get; set; }
C++ public:
property int ElementIndex {
int get();
void set(int value);
}
JScript public function get ElementIndex() : int
public function set ElementIndex(int);

Property Value

System.Int32
Integer that represents the element index to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MagFilter Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.MagFilter Property

Retrieves or sets a magnification filter.

Definition

Visual Basic | Public Property MagFilter As TextureFilter
C# | public TextureFilter MagFilter { get; set; }
C++ public:
property TextureFilter MagFilter {
TextureFilter get();
void set(TextureFilter value);
}
JScript public function get MagFilter() : TextureFilter
public function set MagFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter
Member of the TextureFilter enumeration that represents the magnification filter to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MaxAnisotropy Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.MaxAnisotropy Property

Retrieves or sets the maximum anisotropy.

Definition

Visual Basic | Public Property MaxAnisotropy As Integer
C# | public int MaxAnisotropy { get; set; }
C++ public:
property int MaxAnisotropy {
int get();
void set(int value);
}
JScript public function get MaxAnisotropy() : int
public function set MaxAnisotropy(int);

Property Value

System.Int32
Integer that represents the maximum anisotropy value to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MaxMipLevel Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.MaxMipLevel Property

Retrieves or sets the level of detail (LOD) index of the largest map to use.

Definition

Visual Basic | Public Property MaxMipLevel As Integer
C# | public int MaxMipLevel { get; set; }
C++ public:
property int MaxMipLevel {
int get();
void set(int value);
}
JScript public function get MaxMipLevel() : int
public function set MaxMipLevel(int);

Property Value

System.Int32
Integer that represents the maximum LOD to set or retrieve.

This property is read/write.

Remarks

The index value can range from 0 to (n-1), where 0 is the largest map.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MinFilter Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.MinFilter Property

Retrieves or sets a minification filter.

Definition

Visual Basic | Public Property MinFilter As TextureFilter
C# | public TextureFilter MinFilter { get; set; }
C++ public:
property TextureFilter MinFilter {
TextureFilter get();
void set(TextureFilter value);
}
JScript public function get MinFilter() : TextureFilter
public function set MinFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter
Member of the TextureFilter enumeration that represents the minification filter to set or retrieve.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MipFilter Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.MipFilter Property

Retrieves or sets a mipmap filter to use during minification.

Definition

Visual Basic | Public Property MipFilter As TextureFilter
C# | public TextureFilter MipFilter { get; set; }
C++ public:
property TextureFilter MipFilter {
TextureFilter get();
void set(TextureFilter value);
}
JScript public function get MipFilter() : TextureFilter
public function set MipFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter
Member of the TextureFilter enumeration that represents the minification filter to set or retrieve.

This property is read/write.

See Also

  • MaxMipLevel

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.MipMapLevelOfDetailBias Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.MipMapLevelOfDetailBias Property

Retrieves or sets the mipmap level of detail (LOD) bias.

Definition

Visual Basic | Public Property MipMapLevelOfDetailBias As Single
C# | public float MipMapLevelOfDetailBias { get; set; }
C++ public:
property float MipMapLevelOfDetailBias {
float get();
void set(float value);
}
JScript public function get MipMapLevelOfDetailBias() : float
public function set MipMapLevelOfDetailBias(float);

Property Value

System.Single
Floating-point value that represents the mipmap bias to set or retrieve.

This property is read/write.

Remarks

The default value is 0.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManager.SrgbTexture Property (Microsoft.DirectX.Direct3D)

SamplerStateManager.SrgbTexture Property

Determines whether to use gamma correction.

Definition

Visual Basic | Public Property SrgbTexture As Boolean
C# | public bool SrgbTexture { get; set; }
C++ public:
property bool SrgbTexture {
bool get();
void set(bool value);
}
JScript public function get SrgbTexture() : boolean
public function set SrgbTexture(boolean);

Property Value

System.Boolean
Value that is true if gamma correction is used, or false if it is not.

This property is read/write.

Remarks

The default value is false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManagerCollection Class (Microsoft.DirectX.Direct3D)

SamplerStateManagerCollection Class

Collection of SamplerStateManager objects.

Definition

Visual Basic NotInheritable Public Class SamplerStateManagerCollection
Inherits Object
C# | public sealed class SamplerStateManagerCollection : Object
C++ | public ref class SamplerStateManagerCollection sealed : Object
JScript | public final class SamplerStateManagerCollection extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property | Description
SamplerState | Retrieves the SamplerStateManager object at the given index.

Inheritance Hierarchy

Object Leave Site
SamplerStateManagerCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SamplerStateManagerCollection.SamplerState Property (Microsoft.DirectX.Direct3D)

SamplerStateManagerCollection.SamplerState Property

Retrieves the SamplerStateManager object at the given index.

Definition

Visual Basic Public ReadOnly Property SamplerState( _
ByVal index As Integer _
) As SamplerStateManager
C# public SamplerStateManager this[
int index
] { get; }
C++ public:
property SamplerStateManager^ SamplerState [int] {
SamplerStateManager^ get(int index);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32
Integer that represents the SamplerStateManager object to retrieve.

Property Value

Microsoft.DirectX.Direct3D.SamplerStateManager
A SamplerStateManager object retrieved from the given index.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SaveUserData Class (Microsoft.DirectX.Direct3D)

SaveUserData Class

Implemented by the application to save frame and mesh container objects.

Definition

Visual Basic MustInherit Public Class SaveUserData
Inherits Object
C# | public abstract class SaveUserData : Object
C++ | public ref class SaveUserData abstract : Object
JScript | public abstract class SaveUserData extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AddFrameChildData | Adds child data to a frame.
AddMeshChildData | Adds child data to a mesh.
AddTopLevelDataObjectsPost | Adds a top-level object after the frame hierarchy.
AddTopLevelDataObjectsPre | Adds a top-level object before the frame hierarchy.
Finalize | Allows the SaveUserData object to free resources before it is destroyed by the garbage collector.
RegisterTemplates | Registers a .x file template.
SaveTemplates | Saves a .x file template.
SaveUserData | Initializes a new instance of the SaveUserData class.

Inheritance Hierarchy

Object Leave Site
SaveUserData

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SaveUserData.AddFrameChildData(Frame,XFileSaveObject,XFileSaveData) Method (Microsoft.DirectX.Direct3D)

SaveUserData.AddFrameChildData Method

Adds child data to a frame.

Definition

Visual Basic MustOverride Public Sub AddFrameChildData( _
ByVal frame As Frame, _
ByVal xofSave As XFileSaveObject, _
ByVal xofFrameData As XFileSaveData _
)
C# public abstract void AddFrameChildData(
Frame frame,
XFileSaveObject xofSave,
XFileSaveData xofFrameData
);
C++ public:
virtual void AddFrameChildData(
Frame^ frame,
XFileSaveObject^ xofSave,
XFileSaveData^ xofFrameData
) abstract;
JScript public abstract function AddFrameChildData(
frame : Frame,
xofSave : XFileSaveObject,
xofFrameData : XFileSaveData
);

Parameters

frame Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the frame hierarchy to which to add child data.
xofSave Microsoft.DirectX.Direct3D.XFileSaveObject
Reference to an XFileSaveObject object.
xofFrameData Microsoft.DirectX.Direct3D.XFileSaveData


SaveUserData.AddMeshChildData(MeshContainer,XFileSaveObject,XFileSaveData) Method (Microsoft.DirectX.Direct3D)

SaveUserData.AddMeshChildData Method

Adds child data to a mesh.

Definition

Visual Basic MustOverride Public Sub AddMeshChildData( _
ByVal meshContainer As MeshContainer, _
ByVal xofSave As XFileSaveObject, _
ByVal xofFrameData As XFileSaveData _
)
C# public abstract void AddMeshChildData(
MeshContainer meshContainer,
XFileSaveObject xofSave,
XFileSaveData xofFrameData
);
C++ public:
virtual void AddMeshChildData(
MeshContainer^ meshContainer,
XFileSaveObject^ xofSave,
XFileSaveData^ xofFrameData
) abstract;
JScript public abstract function AddMeshChildData(
meshContainer : MeshContainer,
xofSave : XFileSaveObject,
xofFrameData : XFileSaveData
);

Parameters

meshContainer Microsoft.DirectX.Direct3D.MeshContainer
A MeshContainer object that represents the mesh container to which to add child data.
xofSave Microsoft.DirectX.Direct3D.XFileSaveObject
Reference to an XFileSaveObject object.
xofFrameData Microsoft.DirectX.Direct3D.XFileSaveData


SaveUserData.AddTopLevelDataObjectsPost(XFileSaveObject) Method (Microsoft.DirectX.Direct3D)

SaveUserData.AddTopLevelDataObjectsPost Method

Adds a top-level object after the frame hierarchy.

Definition

Visual Basic MustOverride Public Sub AddTopLevelDataObjectsPost( _
ByVal xofSave As XFileSaveObject _
)
C# public abstract void AddTopLevelDataObjectsPost(
XFileSaveObject xofSave
);
C++ public:
virtual void AddTopLevelDataObjectsPost(
XFileSaveObject^ xofSave
) abstract;
JScript public abstract function AddTopLevelDataObjectsPost(
xofSave : XFileSaveObject
);

Parameters

xofSave Microsoft.DirectX.Direct3D.XFileSaveObject
An XFileSaveObject that contains the .x file save data to add to the frame hierarchy.


SaveUserData.AddTopLevelDataObjectsPre(XFileSaveObject) Method (Microsoft.DirectX.Direct3D)

SaveUserData.AddTopLevelDataObjectsPre Method

Adds a top-level object before the frame hierarchy.

Definition

Visual Basic MustOverride Public Sub AddTopLevelDataObjectsPre( _
ByVal xofSave As XFileSaveObject _
)
C# public abstract void AddTopLevelDataObjectsPre(
XFileSaveObject xofSave
);
C++ public:
virtual void AddTopLevelDataObjectsPre(
XFileSaveObject^ xofSave
) abstract;
JScript public abstract function AddTopLevelDataObjectsPre(
xofSave : XFileSaveObject
);

Parameters

xofSave Microsoft.DirectX.Direct3D.XFileSaveObject
An XFileSaveObject that contains the .x file save data to add to the frame hierarchy.


SaveUserData.Finalize() Method (Microsoft.DirectX.Direct3D)

SaveUserData.Finalize Method

Allows the SaveUserData object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~SaveUserData();
C++ | !SaveUserData();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


SaveUserData.RegisterTemplates(XFileManager) Method (Microsoft.DirectX.Direct3D)

SaveUserData.RegisterTemplates Method

Registers a .x file template.

Definition

Visual Basic MustOverride Public Sub RegisterTemplates( _
ByVal xfileApi As XFileManager _
)
C# public abstract void RegisterTemplates(
XFileManager xfileApi
);
C++ public:
virtual void RegisterTemplates(
XFileManager^ xfileApi
) abstract;
JScript public abstract function RegisterTemplates(
xfileApi : XFileManager
);

Parameters

xfileApi Microsoft.DirectX.Direct3D.XFileManager
An XFileManager object that contains data about the .x file template to register.

Remarks

The SaveUserData.RegisterTemplates and SaveUserData.SaveTemplates methods provide a mechanism for saving user data by adding a template to a .x file.


SaveUserData.SaveTemplates(XFileSaveObject) Method (Microsoft.DirectX.Direct3D)

SaveUserData.SaveTemplates Method

Saves a .x file template.

Definition

Visual Basic MustOverride Public Sub SaveTemplates( _
ByVal xofSave As XFileSaveObject _
)
C# public abstract void SaveTemplates(
XFileSaveObject xofSave
);
C++ public:
virtual void SaveTemplates(
XFileSaveObject^ xofSave
) abstract;
JScript public abstract function SaveTemplates(
xofSave : XFileSaveObject
);

Parameters

xofSave Microsoft.DirectX.Direct3D.XFileSaveObject
An XFileSaveObject object that contains data about the .x file template to save.

Remarks

The SaveUserData.RegisterTemplates and SaveUserData.SaveTemplates methods provide a mechanism for saving user data by adding a template to a .x file.


SaveUserData.SaveUserData() Constructor (Microsoft.DirectX.Direct3D)

SaveUserData.SaveUserData Constructor

Initializes a new instance of the SaveUserData class.

Definition

Visual Basic | Public Sub New()
C# | public SaveUserData();
C++ public:
SaveUserData();
JScript | public function SaveUserData();


ShaderLoader Class (Microsoft.DirectX.Direct3D)

ShaderLoader Class

Encapsulates the functionality for loading shader objects.

Definition

Visual Basic NotInheritable MustInherit Public Class ShaderLoader
Inherits Object
C# | public abstract sealed class ShaderLoader : Object
C++ | public ref class ShaderLoader abstract sealed : Object
JScript | public final abstract class ShaderLoader extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) CompileShader
static (Shared in Visual Basic) CompileShaderFromFile
static (Shared in Visual Basic) CompileShaderFromStream
static (Shared in Visual Basic) DisassembleShader | Disassembles a shader.
static (Shared in Visual Basic) FromFile | Assembles a shader from a file.
static (Shared in Visual Basic) FromStream | Assembles a shader from a stream.
static (Shared in Visual Basic) FromString | Assembles a shader from a string.
static (Shared in Visual Basic) GetPixelShaderProfile | Returns the name of the high-level shader language (HLSL) profile that is best suited to a given device.
static (Shared in Visual Basic) GetSamplers | Gets the sampler names referenced in a shader.
static (Shared in Visual Basic) GetShaderInputSemantics | Retrieves the semantics for all shader input elements.
static (Shared in Visual Basic) GetShaderOutputSemantics | Retrieves the semantics for all shader output elements.
static (Shared in Visual Basic) GetShaderSize | Returns the size of the shader byte code, in bytes.
static (Shared in Visual Basic) GetShaderVersion | Returns the version of the compiled shader.
static (Shared in Visual Basic) GetVertexShaderProfile | Returns the name of the high-level shader language (HLSL) profile that is best suited to a given device.

Inheritance Hierarchy

Object Leave Site
ShaderLoader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderLoader.CompileShader Method ()

Overload List

public static GraphicsStream CompileShader(string, string, Include, string, ShaderFlags);
public static GraphicsStream CompileShader(string, string, Macro[], Include, string, ShaderFlags);
public static GraphicsStream CompileShader(string, string, Macro[], Include, string, ShaderFlags, out string, out ConstantTable);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShader(String,String,Include,String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShader Method

Definition

Visual Basic Public Shared Function CompileShader( _
ByVal data As String, _
ByVal functionName As String, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShader(
string data,
string functionName,
Include includeFile,
string profile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ CompileShader(
String^ data,
String^ functionName,
Include^ includeFile,
String^ profile,
ShaderFlags flags
);
JScript public static function CompileShader(
data : String,
functionName : String,
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.String
String that contains the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShader(String,String,Macro[],Include,String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShader Method

Definition

Visual Basic Public Shared Function CompileShader( _
ByVal data As String, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShader(
string data,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ CompileShader(
String^ data,
String^ functionName,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ profile,
ShaderFlags flags
);
JScript public static function CompileShader(
data : String,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.String
String that contains the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShader(String,String,Macro[],Include,String,ShaderFlags,String,ConstantTable) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShader Method

Definition

Visual Basic Public Shared Function CompileShader( _
ByVal data As String, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public static GraphicsStream CompileShader(
string data,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags,
out string errorMessages,
out ConstantTable table
);
C++ public:
static GraphicsStream^ CompileShader(
String^ data,
String^ functionName,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ profile,
ShaderFlags flags,
[Out] String^% errorMessages,
[Out] ConstantTable^% table
);
JScript public static function CompileShader(
data : String,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags,
errorMessages : String,
table : ConstantTable
) : GraphicsStream;

Parameters

data System.String
String that contains the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags
errorMessages System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.
table Microsoft.DirectX.Direct3D.ConstantTable
Reference to a ConstantTable object that can be used to access shader constants.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromFile Method ()

Overload List

public static GraphicsStream CompileShaderFromFile(string, string, Include, string, ShaderFlags);
public static GraphicsStream CompileShaderFromFile(string, string, Macro[], Include, string, ShaderFlags);
public static GraphicsStream CompileShaderFromFile(string, string, Macro[], Include, string, ShaderFlags, out string, out ConstantTable);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromFile(String,String,Include,String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShaderFromFile Method

Definition

Visual Basic Public Shared Function CompileShaderFromFile( _
ByVal file As String, _
ByVal functionName As String, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromFile(
string file,
string functionName,
Include includeFile,
string profile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ CompileShaderFromFile(
String^ file,
String^ functionName,
Include^ includeFile,
String^ profile,
ShaderFlags flags
);
JScript public static function CompileShaderFromFile(
file : String,
functionName : String,
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file System.String
String that specifies the file name containing the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromFile(String,String,Macro[],Include,String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShaderFromFile Method

Definition

Visual Basic Public Shared Function CompileShaderFromFile( _
ByVal file As String, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromFile(
string file,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ CompileShaderFromFile(
String^ file,
String^ functionName,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ profile,
ShaderFlags flags
);
JScript public static function CompileShaderFromFile(
file : String,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

file System.String
String that specifies the file name containing the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromFile(String,String,Macro[],Include,String,ShaderFlags,String,ConstantTable) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShaderFromFile Method

Definition

Visual Basic Public Shared Function CompileShaderFromFile( _
ByVal file As String, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromFile(
string file,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags,
out string errorMessages,
out ConstantTable table
);
C++ public:
static GraphicsStream^ CompileShaderFromFile(
String^ file,
String^ functionName,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ profile,
ShaderFlags flags,
[Out] String^% errorMessages,
[Out] ConstantTable^% table
);
JScript public static function CompileShaderFromFile(
file : String,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags,
errorMessages : String,
table : ConstantTable
) : GraphicsStream;

Parameters

file System.String
String that specifies the file name containing the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags
errorMessages System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.
table Microsoft.DirectX.Direct3D.ConstantTable
Reference to a ConstantTable object that can be used to access shader constants.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromStream Method ()

Overload List

public static GraphicsStream CompileShaderFromStream(Stream, string, Include, string, ShaderFlags);
public static GraphicsStream CompileShaderFromStream(Stream, string, Macro[], Include, string, ShaderFlags);
public static GraphicsStream CompileShaderFromStream(Stream, string, Macro[], Include, string, ShaderFlags, out string, out ConstantTable);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromStream(Stream,String,Include,String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShaderFromStream Method

Definition

Visual Basic Public Shared Function CompileShaderFromStream( _
ByVal data As Stream, _
ByVal functionName As String, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromStream(
Stream data,
string functionName,
Include includeFile,
string profile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ CompileShaderFromStream(
Stream^ data,
String^ functionName,
Include^ includeFile,
String^ profile,
ShaderFlags flags
);
JScript public static function CompileShaderFromStream(
data : Stream,
functionName : String,
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.IO.Stream
A Stream Leave Site object that contains the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromStream(Stream,String,Macro[],Include,String,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShaderFromStream Method

Definition

Visual Basic Public Shared Function CompileShaderFromStream( _
ByVal data As Stream, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromStream(
Stream data,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ CompileShaderFromStream(
Stream^ data,
String^ functionName,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ profile,
ShaderFlags flags
);
JScript public static function CompileShaderFromStream(
data : Stream,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags
) : GraphicsStream;

Parameters

data System.IO.Stream
A Stream Leave Site object that contains the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.CompileShaderFromStream(Stream,String,Macro[],Include,String,ShaderFlags,String,ConstantTable) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.CompileShaderFromStream Method

Definition

Visual Basic Public Shared Function CompileShaderFromStream( _
ByVal data As Stream, _
ByVal functionName As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal profile As String, _
ByVal flags As ShaderFlags, _
ByRef errorMessages As String, _
ByRef table As ConstantTable _
) As GraphicsStream
C# public static GraphicsStream CompileShaderFromStream(
Stream data,
string functionName,
Macro[] preprocessorDefines,
Include includeFile,
string profile,
ShaderFlags flags,
out string errorMessages,
out ConstantTable table
);
C++ public:
static GraphicsStream^ CompileShaderFromStream(
Stream^ data,
String^ functionName,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
String^ profile,
ShaderFlags flags,
[Out] String^% errorMessages,
[Out] ConstantTable^% table
);
JScript public static function CompileShaderFromStream(
data : Stream,
functionName : String,
preprocessorDefines : Macro[],
includeFile : Include,
profile : String,
flags : ShaderFlags,
errorMessages : String,
table : ConstantTable
) : GraphicsStream;

Parameters

data System.IO.Stream
A Stream Leave Site object that contains the shader code to compile.
functionName System.String
String that contains the name of the shader entry-point function where execution begins.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
profile System.String
String containing the shader profile that determines the shader instruction set to use.
flags Microsoft.DirectX.Direct3D.ShaderFlags
errorMessages System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.
table Microsoft.DirectX.Direct3D.ConstantTable
Reference to a ConstantTable object that can be used to access shader constants.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.DisassembleShader Method ()

Disassembles a shader.

Overload List

public static string DisassembleShader(GraphicsStream, bool, string);
public static string DisassembleShader(int, bool, string);
public static string DisassembleShader(int[], bool, string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.DisassembleShader(Int32[],Boolean,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.DisassembleShader Method

Disassembles a shader.

Definition

Visual Basic Public Shared Function DisassembleShader( _
ByVal function() As Integer, _
ByVal enableColorCode As Boolean, _
ByVal comments As String _
) As String
C# public static string DisassembleShader(
int[] function,
bool enableColorCode,
string comments
);
C++ public:
static String^ DisassembleShader(
array<int>^ function,
bool enableColorCode,
String^ comments
);
JScript public static function DisassembleShader(
function : int[],
enableColorCode : boolean,
comments : String
) : String;

Parameters

function System.Int32[]
An integer array that contains the compiled shader code.
enableColorCode System.Boolean
Set to true to enable color code to make it easier to read the disassembly; otherwise, false.
comments System.String
String that contains comments about the disassembly.

Return Value

System.String
Returns a string containing the disassembled shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.DisassembleShader(GraphicsStream,Boolean,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.DisassembleShader Method

Disassembles a shader.

Definition

Visual Basic Public Shared Function DisassembleShader( _
ByVal function As GraphicsStream, _
ByVal enableColorCode As Boolean, _
ByVal comments As String _
) As String
C# public static string DisassembleShader(
GraphicsStream function,
bool enableColorCode,
string comments
);
C++ public:
static String^ DisassembleShader(
GraphicsStream^ function,
bool enableColorCode,
String^ comments
);
JScript public static function DisassembleShader(
function : GraphicsStream,
enableColorCode : boolean,
comments : String
) : String;

Parameters

function Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the compiled shader code.
enableColorCode System.Boolean
Set to true to enable color code to make it easier to read the disassembly; otherwise, false.
comments System.String
String that contains comments about the disassembly.

Return Value

System.String
Returns a string containing the disassembled shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.DisassembleShader(Int32,Boolean,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.DisassembleShader Method

Disassembles a shader.

Definition

Visual Basic Public Shared Function DisassembleShader( _
ByVal pFunction As Integer, _
ByVal enableColorCode As Boolean, _
ByVal comments As String _
) As String
C# public static string DisassembleShader(
int pFunction,
bool enableColorCode,
string comments
);
C++ public:
static String^ DisassembleShader(
int pFunction,
bool enableColorCode,
String^ comments
);
JScript public static function DisassembleShader(
pFunction : int,
enableColorCode : boolean,
comments : String
) : String;

Parameters

pFunction System.Int32
An integer pointer that represents the compiled shader code.
enableColorCode System.Boolean
Set to true to enable color code to make it easier to read the disassembly; otherwise, false.
comments System.String
String that contains comments about the disassembly.

Return Value

System.String
Returns a string containing the disassembled shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromFile Method ()

Assembles a shader from a file.

Overload List

public static GraphicsStream FromFile(string, Include, ShaderFlags);
public static GraphicsStream FromFile(string, Include, ShaderFlags, out string);
public static GraphicsStream FromFile(string, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromFile(String,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromFile Method

Assembles a shader from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream FromFile(
string sourceFile,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ FromFile(
String^ sourceFile,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function FromFile(
sourceFile : String,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

sourceFile System.String
String that specifies the file name containing the shader code to assemble.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromFile(String,Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromFile Method

Assembles a shader from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromFile(
string sourceFile,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ FromFile(
String^ sourceFile,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromFile(
sourceFile : String,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceFile System.String
String that specifies the file name containing the shader code to assemble.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromFile(String,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromFile Method

Assembles a shader from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal sourceFile As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromFile(
string sourceFile,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ FromFile(
String^ sourceFile,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromFile(
sourceFile : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceFile System.String
String that specifies the file name containing the shader code to assemble.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromStream Method ()

Assembles a shader from a stream.

Overload List

public static GraphicsStream FromStream(Stream, Include, ShaderFlags);
public static GraphicsStream FromStream(Stream, Include, ShaderFlags, out string);
public static GraphicsStream FromStream(Stream, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromStream(Stream,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromStream Method

Assembles a shader from a stream.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream FromStream(
Stream sourceData,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ FromStream(
Stream^ sourceData,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function FromStream(
sourceData : Stream,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

sourceData System.IO.Stream
A Stream Leave Site object that contains the shader code to assemble.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromStream(Stream,Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromStream Method

Assembles a shader from a stream.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromStream(
Stream sourceData,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ FromStream(
Stream^ sourceData,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromStream(
sourceData : Stream,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceData System.IO.Stream
A Stream Leave Site object that contains the shader code to assemble.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromStream(Stream,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromStream Method

Assembles a shader from a stream.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal sourceData As Stream, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromStream(
Stream sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ FromStream(
Stream^ sourceData,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromStream(
sourceData : Stream,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceData System.IO.Stream
A Stream Leave Site object that contains the shader code to assemble.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromString Method ()

Assembles a shader from a string.

Overload List

public static GraphicsStream FromString(string, Include, ShaderFlags);
public static GraphicsStream FromString(string, Include, ShaderFlags, out string);
public static GraphicsStream FromString(string, Macro[], Include, ShaderFlags, out string);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromString(String,Include,ShaderFlags) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromString Method

Assembles a shader from a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags _
) As GraphicsStream
C# public static GraphicsStream FromString(
string sourceData,
Include includeFile,
ShaderFlags flags
);
C++ public:
static GraphicsStream^ FromString(
String^ sourceData,
Include^ includeFile,
ShaderFlags flags
);
JScript public static function FromString(
sourceData : String,
includeFile : Include,
flags : ShaderFlags
) : GraphicsStream;

Parameters

sourceData System.String
String that contains the shader code to assemble.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromString(String,Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromString Method

Assembles a shader from a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromString(
string sourceData,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ FromString(
String^ sourceData,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromString(
sourceData : String,
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceData System.String
String that contains the shader code to assemble.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.FromString(String,Macro[],Include,ShaderFlags,String) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.FromString Method

Assembles a shader from a string.

Definition

Visual Basic Public Shared Function FromString( _
ByVal sourceData As String, _
ByVal preprocessorDefines() As Macro, _
ByVal includeFile As Include, _
ByVal flags As ShaderFlags, _
ByRef compilationErrors As String _
) As GraphicsStream
C# public static GraphicsStream FromString(
string sourceData,
Macro[] preprocessorDefines,
Include includeFile,
ShaderFlags flags,
out string compilationErrors
);
C++ public:
static GraphicsStream^ FromString(
String^ sourceData,
array<Macro>^ preprocessorDefines,
Include^ includeFile,
ShaderFlags flags,
[Out] String^% compilationErrors
);
JScript public static function FromString(
sourceData : String,
preprocessorDefines : Macro[],
includeFile : Include,
flags : ShaderFlags,
compilationErrors : String
) : GraphicsStream;

Parameters

sourceData System.String
String that contains the shader code to assemble.
preprocessorDefines Microsoft.DirectX.Direct3D.Macro[]
Reference to a Macro object that describes the preprocessor definitions to use.
includeFile Microsoft.DirectX.Direct3D.Include
Reference to an Include object that provides access to include-file directives.
flags Microsoft.DirectX.Direct3D.ShaderFlags
Value of the ShaderFlags enumeration that represents the shader compiler options to use.
compilationErrors System.String
String containing a listing of errors and warnings that were encountered during compilation. These are the same messages the debugger displays in debug mode.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the assembled shader code, as well as any embedded debug and symbol table information.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetPixelShaderProfile(Device) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetPixelShaderProfile Method

Returns the name of the high-level shader language (HLSL) profile that is best suited to a given device.

Definition

Visual Basic Public Shared Function GetPixelShaderProfile( _
ByVal device As Device _
) As String
C# public static string GetPixelShaderProfile(
Device device
);
C++ public:
static String^ GetPixelShaderProfile(
Device^ device
);
JScript public static function GetPixelShaderProfile(
device : Device
) : String;

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to the Device.

Return Value

System.String
String that contains the HLSL profile name.

Remarks

A shader profile specifies the assembly shader version to use and the capabilities available to the HLSL compiler when compiling a shader. The following table lists the supported pixel shader profiles.

Shader Profile | Description
ps_1_1 | Compile to ps_1_1 version.
ps_1_2 | Compile to ps_1_2 version.
ps_1_3 | Compile to ps_1_3 version.
ps_1_4 | Compile to ps_1_4 version.
ps_2_0 | Compile to ps_2_0 version.
ps_2_a Same as the ps_2_0 profile, with the following additional capabilities available for the compiler to target:
  • Number of temporary registers (r#) is greater than or equal to 28.
  • Arbitrary source swizzle.
  • Gradient instructions: dsx, dsy.
  • Predication.
  • No dependent texture read limit.
  • No limit for the number of texture instructions.
ps_2_sw | Compile to ps_2_sw version.


ShaderLoader.GetSamplers Method ()

Gets the sampler names referenced in a shader.

Overload List

public static string[] GetSamplers(GraphicsStream);
public static string[] GetSamplers(int);
public static string[] GetSamplers(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetSamplers(Int32[]) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetSamplers Method

Gets the sampler names referenced in a shader.

Definition

Visual Basic Public Shared Function GetSamplers( _
ByVal function() As Integer _
) As String()
C# public static string[] GetSamplers(
int[] function
);
C++ public:
static array<String^>^ GetSamplers(
array<int>^ function
);
JScript public static function GetSamplers(
function : int[]
) : String[];

Parameters

function System.Int32[]
An integer array that contains the shader function stream.

Return Value

System.String[]
Returns a string array that contains the sampler names in the shader function stream.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetSamplers(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetSamplers Method

Gets the sampler names referenced in a shader.

Definition

Visual Basic Public Shared Function GetSamplers( _
ByVal function As GraphicsStream _
) As String()
C# public static string[] GetSamplers(
GraphicsStream function
);
C++ public:
static array<String^>^ GetSamplers(
GraphicsStream^ function
);
JScript public static function GetSamplers(
function : GraphicsStream
) : String[];

Parameters

function Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader function stream.

Return Value

System.String[]
Returns a string array that contains the sampler names in the shader function stream.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetSamplers(Int32) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetSamplers Method

Gets the sampler names referenced in a shader.

Definition

Visual Basic Public Shared Function GetSamplers( _
ByVal function As Integer _
) As String()
C# public static string[] GetSamplers(
int function
);
C++ public:
static array<String^>^ GetSamplers(
int function
);
JScript public static function GetSamplers(
function : int
) : String[];

Parameters

function System.Int32
An integer pointer that represents the shader function stream.

Return Value

System.String[]
Returns a string array that contains the sampler names in the shader function stream.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderInputSemantics Method ()

Retrieves the semantics for all shader input elements.

Overload List

public static Semantic[] GetShaderInputSemantics(GraphicsStream);
public static Semantic[] GetShaderInputSemantics(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderInputSemantics(Int32[]) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetShaderInputSemantics Method

Retrieves the semantics for all shader input elements.

Definition

Visual Basic Public Shared Function GetShaderInputSemantics( _
ByVal function() As Integer _
) As Semantic()
C# public static Semantic[] GetShaderInputSemantics(
int[] function
);
C++ public:
static array<Semantic>^ GetShaderInputSemantics(
array<int>^ function
);
JScript public static function GetShaderInputSemantics(
function : int[]
) : Semantic[];

Parameters

function System.Int32[]
Integer that represents a pointer to the shader function stream.

Return Value

Microsoft.DirectX.Direct3D.Semantic[]
Array of Semantic objects that represent the semantics for each input element referenced by the shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderInputSemantics(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetShaderInputSemantics Method

Retrieves the semantics for all shader input elements.

Definition

Visual Basic Public Shared Function GetShaderInputSemantics( _
ByVal function As GraphicsStream _
) As Semantic()
C# public static Semantic[] GetShaderInputSemantics(
GraphicsStream function
);
C++ public:
static array<Semantic>^ GetShaderInputSemantics(
GraphicsStream^ function
);
JScript public static function GetShaderInputSemantics(
function : GraphicsStream
) : Semantic[];

Parameters

function Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents a pointer to the shader function stream.

Return Value

Microsoft.DirectX.Direct3D.Semantic[]
Array of Semantic objects that represent the semantics for each input element referenced by the shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderOutputSemantics Method ()

Retrieves the semantics for all shader output elements.

Overload List

public static Semantic[] GetShaderOutputSemantics(GraphicsStream);
public static Semantic[] GetShaderOutputSemantics(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderOutputSemantics(Int32[]) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetShaderOutputSemantics Method

Retrieves the semantics for all shader output elements.

Definition

Visual Basic Public Shared Function GetShaderOutputSemantics( _
ByVal function() As Integer _
) As Semantic()
C# public static Semantic[] GetShaderOutputSemantics(
int[] function
);
C++ public:
static array<Semantic>^ GetShaderOutputSemantics(
array<int>^ function
);
JScript public static function GetShaderOutputSemantics(
function : int[]
) : Semantic[];

Parameters

function System.Int32[]
Integer that represents a pointer to the shader function stream.

Return Value

Microsoft.DirectX.Direct3D.Semantic[]
Array of Semantic objects that represent the semantics for each output element referenced by the shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderOutputSemantics(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetShaderOutputSemantics Method

Retrieves the semantics for all shader output elements.

Definition

Visual Basic Public Shared Function GetShaderOutputSemantics( _
ByVal function As GraphicsStream _
) As Semantic()
C# public static Semantic[] GetShaderOutputSemantics(
GraphicsStream function
);
C++ public:
static array<Semantic>^ GetShaderOutputSemantics(
GraphicsStream^ function
);
JScript public static function GetShaderOutputSemantics(
function : GraphicsStream
) : Semantic[];

Parameters

function Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents a pointer to the shader function stream.

Return Value

Microsoft.DirectX.Direct3D.Semantic[]
Array of Semantic objects that represent the semantics for each output element referenced by the shader.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderSize Method ()

Returns the size of the shader byte code, in bytes.

Overload List

public static int GetShaderSize(GraphicsStream);
public static int GetShaderSize(int[]);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderSize(Int32[]) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetShaderSize Method

Returns the size of the shader byte code, in bytes.

Definition

Visual Basic Public Shared Function GetShaderSize( _
ByVal function() As Integer _
) As Integer
C# public static int GetShaderSize(
int[] function
);
C++ public:
static int GetShaderSize(
array<int>^ function
);
JScript public static function GetShaderSize(
function : int[]
) : int;

Parameters

function System.Int32[]
An integer array that contains the shader function stream.

Return Value

System.Int32
An integer that represents the size of the shader byte code, in bytes.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderSize(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetShaderSize Method

Returns the size of the shader byte code, in bytes.

Definition

Visual Basic Public Shared Function GetShaderSize( _
ByVal function As GraphicsStream _
) As Integer
C# public static int GetShaderSize(
GraphicsStream function
);
C++ public:
static int GetShaderSize(
GraphicsStream^ function
);
JScript public static function GetShaderSize(
function : GraphicsStream
) : int;

Parameters

function Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader function stream.

Return Value

System.Int32
An integer that represents the size of the shader byte code, in bytes.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


ShaderLoader.GetShaderVersion Method ()

Returns the version of the compiled shader.

Overload List

public static Version GetShaderVersion(GraphicsStream);
public static Version GetShaderVersion(int[]);


ShaderLoader.GetShaderVersion(Int32[]) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetShaderVersion Method

Returns the version of the compiled shader.

Definition

Visual Basic Public Shared Function GetShaderVersion( _
ByVal function() As Integer _
) As Version
C# public static Version GetShaderVersion(
int[] function
);
C++ public:
static Version^ GetShaderVersion(
array<int>^ function
);
JScript public static function GetShaderVersion(
function : int[]
) : Version;

Parameters

function System.Int32[]
Integer that represents a pointer to the shader function stream.

Return Value

System.Version
A Version Leave Site object that represents the shader version.


ShaderLoader.GetShaderVersion(GraphicsStream) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetShaderVersion Method

Returns the version of the compiled shader.

Definition

Visual Basic Public Shared Function GetShaderVersion( _
ByVal function As GraphicsStream _
) As Version
C# public static Version GetShaderVersion(
GraphicsStream function
);
C++ public:
static Version^ GetShaderVersion(
GraphicsStream^ function
);
JScript public static function GetShaderVersion(
function : GraphicsStream
) : Version;

Parameters

function Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents a pointer to the shader function stream.

Return Value

System.Version
A Version Leave Site object that represents the shader version.


ShaderLoader.GetVertexShaderProfile(Device) Method (Microsoft.DirectX.Direct3D)

ShaderLoader.GetVertexShaderProfile Method

Returns the name of the high-level shader language (HLSL) profile that is best suited to a given device.

Definition

Visual Basic Public Shared Function GetVertexShaderProfile( _
ByVal device As Device _
) As String
C# public static string GetVertexShaderProfile(
Device device
);
C++ public:
static String^ GetVertexShaderProfile(
Device^ device
);
JScript public static function GetVertexShaderProfile(
device : Device
) : String;

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to the Device.

Return Value

System.String
String that contains the HLSL profile name.

Remarks

A shader profile specifies the assembly shader version to use and the capabilities available to the HLSL compiler when compiling a shader. The following table lists the supported vertex shader profiles.

Shader Profile | Description
vs_1_1 | Compile to vs_1_1 version.
vs_2_0 | Compile to vs_2_0 version.
vs_2_a Same as the vs_2_0 profile, with the following additional capabilities available for the compiler to target:
  • Number of temporary registers (r#) is greater than or equal to 13.
  • Dynamic flow control instruction.
  • Predication.
vs_2_sw | Compile to vs_2_sw version.


SimplificationMesh Class (Microsoft.DirectX.Direct3D)

SimplificationMesh Class

Manipulates simplification mesh objects.

Definition

Visual Basic NotInheritable Public Class SimplificationMesh
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class SimplificationMesh : MarshalByRefObject, IDisposable
C++ | public ref class SimplificationMesh sealed : MarshalByRefObject, IDisposable
JScript | public final class SimplificationMesh extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the SimplificationMesh object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Clone | Clones, or copies, a SimplificationMesh object.
CloneProgressiveMesh | Clones a progressive mesh object.
Dispose | Immediately releases the unmanaged resources used by the SimplificationMesh object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the SimplificationMesh object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.SimplificationMesh.Disposing event when called from within a derived class.
ReduceFaces | Reduces the number of faces in a simplification mesh.
ReduceVertices | Reduces the number of vertices in a simplification mesh.
SimplificationMesh | Creates a new instance of the SimplificationMesh class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this SimplificationMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Declaration | Retrieves a declaration that describes the vertices in a mesh.
Device | Retrieves the device object associated with a simplification mesh.
Disposed | Gets a value that indicates whether the object is disposed.
MaxFaces | Retrieves the maximum number of faces that a simplification mesh can support.
MaxVertices | Retrieves the maximum number of vertices that a simplification mesh can support.
NumberFaces | Retrieves the number of faces in the simplification mesh.
NumberVertices | Retrieves the number of vertices in the simplification mesh.
Options | Retrieves the mesh options enabled for the current simplification mesh at creation time.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXSPMesh interface pointer.
VertexAttributeWeights | Retrieves the per-vertex attribute weights used to create a SimplificationMesh object.
VertexFormat | Retrieves the VertexFormats of the vertices in the SimplificationMesh.
VertexWeights | Retrieves the per-vertex weights used to create the SimplificationMesh object.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
SimplificationMesh

Remarks

A simplification mesh is used to simplify a given mesh to a lower number of faces.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SimplificationMesh.Clone Method ()

How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Overload List

public Mesh Clone(MeshFlags, VertexElement[], Device);
public Mesh Clone(MeshFlags, VertexElement[], Device, out int, out int);
public Mesh Clone(MeshFlags, VertexFormats, Device);
public Mesh Clone(MeshFlags, VertexFormats, Device, out int, out int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.Clone(MeshFlags,VertexElement[],Device) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.Clone Method

How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexElement[] declaration,
Device device
);
C++ public:
Mesh^ Clone(
MeshFlags options,
array<VertexElement>^ declaration,
Device^ device
);
JScript public function Clone(
options : MeshFlags,
declaration : VertexElement[],
device : Device
) : Mesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
declaration Microsoft.DirectX.Direct3D.VertexElement[]
Vertex data, defined with an array of VertexElement structures.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Address of a pointer to a Mesh object that represents the cloned mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.Clone(MeshFlags,VertexElement[],Device,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.Clone Method

How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device, _
ByRef adjacencyOut As Integer, _
ByRef vertexRemap As Integer _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexElement[] declaration,
Device device,
out int adjacencyOut,
out int vertexRemap
);
C++ public:
Mesh^ Clone(
MeshFlags options,
array<VertexElement>^ declaration,
Device^ device,
[Out] int% adjacencyOut,
[Out] int% vertexRemap
);
JScript public function Clone(
options : MeshFlags,
declaration : VertexElement[],
device : Device,
adjacencyOut : int,
vertexRemap : int
) : Mesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
declaration Microsoft.DirectX.Direct3D.VertexElement[]
Vertex data, defined with an array of VertexElement structures.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.
adjacencyOut System.Int32[]
Array of three Int32 Leave Site values per face that specifies the three neighbors for each face in the source mesh.
vertexRemap System.Int32[]
Array that contains the index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Address of a pointer to a Mesh object that represents the cloned mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.Clone(MeshFlags,VertexFormats,Device) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.Clone Method

How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
C++ public:
Mesh^ Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device^ device
);
JScript public function Clone(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
) : Mesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Vertex format of the mesh, indicated by one or more VertexFormats members.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Address of a pointer to a Mesh object that represents the cloned mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.Clone(MeshFlags,VertexFormats,Device,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.Clone Method

How Do I...?
  • Simplify a Mesh

Clones, or copies, a SimplificationMesh object.

Definition

Visual Basic Public Function Clone( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device, _
ByRef adjacencyOut As Integer, _
ByRef vertexRemap As Integer _
) As Mesh
C# public Mesh Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device device,
out int adjacencyOut,
out int vertexRemap
);
C++ public:
Mesh^ Clone(
MeshFlags options,
VertexFormats vertexFormat,
Device^ device,
[Out] int% adjacencyOut,
[Out] int% vertexRemap
);
JScript public function Clone(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device,
adjacencyOut : int,
vertexRemap : int
) : Mesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated through one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Vertex format of the mesh, indicated by one or more VertexFormats members.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.
adjacencyOut System.Int32[]
Array of three Int32 Leave Site values per face that specifies the three neighbors for each face in the source mesh.
vertexRemap System.Int32[]
Array that contains the index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
Address of a pointer to a Mesh object that represents the cloned mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();

See Also

  • SimplificationMesh.Declaration


SimplificationMesh.CloneProgressiveMesh Method ()

Clones a progressive mesh object.

Overload List

public ProgressiveMesh CloneProgressiveMesh(MeshFlags, VertexElement[], Device);
public ProgressiveMesh CloneProgressiveMesh(MeshFlags, VertexElement[], Device, out int, out float);
public ProgressiveMesh CloneProgressiveMesh(MeshFlags, VertexFormats, Device);
public ProgressiveMesh CloneProgressiveMesh(MeshFlags, VertexFormats, Device, out int, out float);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SimplificationMesh.CloneProgressiveMesh(MeshFlags,VertexElement[],Device) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.CloneProgressiveMesh Method

Clones a progressive mesh object.

Definition

Visual Basic Public Function CloneProgressiveMesh( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device _
) As ProgressiveMesh
C# public ProgressiveMesh CloneProgressiveMesh(
MeshFlags options,
VertexElement[] declaration,
Device device
);
C++ public:
ProgressiveMesh^ CloneProgressiveMesh(
MeshFlags options,
array<VertexElement>^ declaration,
Device^ device
);
JScript public function CloneProgressiveMesh(
options : MeshFlags,
declaration : VertexElement[],
device : Device
) : ProgressiveMesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated by one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
declaration Microsoft.DirectX.Direct3D.VertexElement[]
Vertex data, defined with an array of VertexElement structures. This parameter must map directly to a flexible vertex format (FVF).
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh
A ProgressiveMesh object that represents the cloned progressive mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SimplificationMesh.CloneProgressiveMesh(MeshFlags,VertexElement[],Device,Int32,Single) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.CloneProgressiveMesh Method

Clones a progressive mesh object.

Definition

Visual Basic Public Function CloneProgressiveMesh( _
ByVal options As MeshFlags, _
ByVal declaration() As VertexElement, _
ByVal device As Device, _
ByRef vertexRemapOut As Integer, _
ByRef errorsByFace As Single _
) As ProgressiveMesh
C# public ProgressiveMesh CloneProgressiveMesh(
MeshFlags options,
VertexElement[] declaration,
Device device,
out int vertexRemapOut,
out float errorsByFace
);
C++ public:
ProgressiveMesh^ CloneProgressiveMesh(
MeshFlags options,
array<VertexElement>^ declaration,
Device^ device,
[Out] int% vertexRemapOut,
[Out] float% errorsByFace
);
JScript public function CloneProgressiveMesh(
options : MeshFlags,
declaration : VertexElement[],
device : Device,
vertexRemapOut : int,
errorsByFace : float
) : ProgressiveMesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated by one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
declaration Microsoft.DirectX.Direct3D.VertexElement[]
Vertex data, defined with an array of VertexElement structures. This parameter must map directly to a flexible vertex format (FVF).
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.
vertexRemapOut System.Int32[]
Array that contains the index for each vertex.
errorsByFace System.Single[]
Array that contains error values.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh
A ProgressiveMesh object that represents the cloned progressive mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SimplificationMesh.CloneProgressiveMesh(MeshFlags,VertexFormats,Device) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.CloneProgressiveMesh Method

Clones a progressive mesh object.

Definition

Visual Basic Public Function CloneProgressiveMesh( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device _
) As ProgressiveMesh
C# public ProgressiveMesh CloneProgressiveMesh(
MeshFlags options,
VertexFormats vertexFormat,
Device device
);
C++ public:
ProgressiveMesh^ CloneProgressiveMesh(
MeshFlags options,
VertexFormats vertexFormat,
Device^ device
);
JScript public function CloneProgressiveMesh(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device
) : ProgressiveMesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated by one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Vertex format of the mesh, indicated by one or more VertexFormats members.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh
A ProgressiveMesh object that represents the cloned progressive mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SimplificationMesh.CloneProgressiveMesh(MeshFlags,VertexFormats,Device,Int32,Single) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.CloneProgressiveMesh Method

Clones a progressive mesh object.

Definition

Visual Basic Public Function CloneProgressiveMesh( _
ByVal options As MeshFlags, _
ByVal vertexFormat As VertexFormats, _
ByVal device As Device, _
ByRef vertexRemapOut As Integer, _
ByRef errorsByFace As Single _
) As ProgressiveMesh
C# public ProgressiveMesh CloneProgressiveMesh(
MeshFlags options,
VertexFormats vertexFormat,
Device device,
out int vertexRemapOut,
out float errorsByFace
);
C++ public:
ProgressiveMesh^ CloneProgressiveMesh(
MeshFlags options,
VertexFormats vertexFormat,
Device^ device,
[Out] int% vertexRemapOut,
[Out] float% errorsByFace
);
JScript public function CloneProgressiveMesh(
options : MeshFlags,
vertexFormat : VertexFormats,
device : Device,
vertexRemapOut : int,
errorsByFace : float
) : ProgressiveMesh;

Parameters

options Microsoft.DirectX.Direct3D.MeshFlags
Mesh creation options, indicated by one or more MeshFlags flags (excepting the Simplify* and Optimize* flags).
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Vertex format of the mesh, indicated by one or more VertexFormats members.
device Microsoft.DirectX.Direct3D.Device
The Device object associated with the mesh.
vertexRemapOut System.Int32[]
Array that contains the index for each vertex.
errorsByFace System.Single[]
Array that contains error values.

Return Value

Microsoft.DirectX.Direct3D.ProgressiveMesh
A ProgressiveMesh object that represents the cloned progressive mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SimplificationMesh.Dispose() Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.Dispose Method

Immediately releases the unmanaged resources used by the SimplificationMesh object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~SimplificationMesh();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.SimplificationMesh.Disposed
  • Microsoft.DirectX.Direct3D.SimplificationMesh.Disposing


SimplificationMesh.Equals(Object) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


SimplificationMesh.Finalize() Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.Finalize Method

Allows the SimplificationMesh object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~SimplificationMesh();
C++ | !SimplificationMesh();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


SimplificationMesh.GetHashCode() Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


SimplificationMesh.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXSPMesh, which allows unmanaged COM clients to create an instance of the managed SimplificationMesh class. Not supported.


SimplificationMesh.op_Equality(SimplificationMesh,SimplificationMesh) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As SimplificationMesh, _
ByVal right As SimplificationMesh _
) As Boolean
C# public static bool op_Equality(
SimplificationMesh left,
SimplificationMesh right
);
C++ public:
static bool operator==(
SimplificationMesh^ left,
SimplificationMesh^ right
);
JScript public static function op_Equality(
left : SimplificationMesh,
right : SimplificationMesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.SimplificationMesh
The SimplificationMesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.SimplificationMesh
The SimplificationMesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


SimplificationMesh.op_Inequality(SimplificationMesh,SimplificationMesh) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As SimplificationMesh, _
ByVal right As SimplificationMesh _
) As Boolean
C# public static bool op_Inequality(
SimplificationMesh left,
SimplificationMesh right
);
C++ public:
static bool operator!=(
SimplificationMesh^ left,
SimplificationMesh^ right
);
JScript public static function op_Inequality(
left : SimplificationMesh,
right : SimplificationMesh
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.SimplificationMesh
The SimplificationMesh object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.SimplificationMesh
The SimplificationMesh object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


SimplificationMesh.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.SimplificationMesh.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


SimplificationMesh.ReduceFaces(Int32) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.ReduceFaces Method

How Do I...?
  • Simplify a Mesh

Reduces the number of faces in a simplification mesh.

Definition

Visual Basic Public Sub ReduceFaces( _
ByVal faces As Integer _
)
C# public void ReduceFaces(
int faces
);
C++ public:
void ReduceFaces(
int faces
);
JScript public function ReduceFaces(
faces : int
);

Parameters

faces System.Int32
Target number of faces by which to reduce the primitive count.

Remarks

This method performs edge collapses to reduce the number of primitives to the value specified in param_Int32_faces. Note that, due to certain restrictions, it is not always possible to reduce a mesh to the requested value.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.ReduceVertices(Int32) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.ReduceVertices Method

How Do I...?
  • Simplify a Mesh

Reduces the number of vertices in a simplification mesh.

Definition

Visual Basic Public Sub ReduceVertices( _
ByVal vertices As Integer _
)
C# public void ReduceVertices(
int vertices
);
C++ public:
void ReduceVertices(
int vertices
);
JScript public function ReduceVertices(
vertices : int
);

Parameters

vertices System.Int32
Number of vertices by which to reduce the primitive count.

Remarks

This method performs edge collapses to reduce the number of primitives to the value specified in param_Int32_vertices. Note that, due to certain restrictions, it is not always possible to reduce a mesh to the requested value.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh Constructor ()

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Overload List

public SimplificationMesh(ID3DXSPMesh);
public SimplificationMesh(IntPtr);
public SimplificationMesh(Mesh, GraphicsStream);
public SimplificationMesh(Mesh, GraphicsStream, AttributeWeights);
public SimplificationMesh(Mesh, GraphicsStream, AttributeWeights, GraphicsStream);
public SimplificationMesh(Mesh, GraphicsStream, GraphicsStream);
public SimplificationMesh(Mesh, GraphicsStream, float[]);
public SimplificationMesh(Mesh, int[]);
public SimplificationMesh(Mesh, int[], AttributeWeights);
public SimplificationMesh(Mesh, int[], AttributeWeights, GraphicsStream);
public SimplificationMesh(Mesh, int[], AttributeWeights, float[]);
public SimplificationMesh(Mesh, int[], GraphicsStream);
public SimplificationMesh(Mesh, int[], float[]);

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(ID3DXSPMesh) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXSPMesh _
)
C# public SimplificationMesh(
ID3DXSPMesh pUnk
);
C++ public:
SimplificationMesh(
ID3DXSPMesh pUnk
);
JScript public function SimplificationMesh(
pUnk : ID3DXSPMesh
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXSPMesh
Unmanaged Component Object Model (COM) ID3DXSPMesh interface pointer.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public SimplificationMesh(
IntPtr unmanagedObject
);
C++ public:
SimplificationMesh(
IntPtr unmanagedObject
);
JScript public function SimplificationMesh(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXSPMesh interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexWeights As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
GraphicsStream vertexWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
array<int>^ adjacency,
GraphicsStream^ vertexWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexWeights : GraphicsStream
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexWeights Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains an array of Single Leave Site values that represent vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],AttributeWeights,GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream vertexWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
array<int>^ adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream^ vertexWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
vertexWeights : GraphicsStream
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains an array of Single Leave Site values that represent vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream,Single[]) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexWeights() As Single _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency,
float[] vertexWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
GraphicsStream^ adjacency,
array<float>^ vertexWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexWeights : float[]
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
vertexWeights System.Single[]
Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
GraphicsStream^ adjacency
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream,GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexWeights As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency,
GraphicsStream vertexWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
GraphicsStream^ adjacency,
GraphicsStream^ vertexWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexWeights : GraphicsStream
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
vertexWeights Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains an array of Single Leave Site values that represent vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream,AttributeWeights) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexAttributeWeights As AttributeWeights _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency,
AttributeWeights vertexAttributeWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
GraphicsStream^ adjacency,
AttributeWeights vertexAttributeWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexAttributeWeights : AttributeWeights
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,GraphicsStream,AttributeWeights,GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency As GraphicsStream, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights As GraphicsStream _
)
C# public SimplificationMesh(
Mesh mesh,
GraphicsStream adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream vertexWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
GraphicsStream^ adjacency,
AttributeWeights vertexAttributeWeights,
GraphicsStream^ vertexWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : GraphicsStream,
vertexAttributeWeights : AttributeWeights,
vertexWeights : GraphicsStream
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream containing three Int32 Leave Site values per face that specify the three neighbors for each face in the source mesh.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains an array of Single Leave Site values that represent vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[]) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
array<int>^ adjacency
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : int[]
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],Single[]) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexWeights() As Single _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
float[] vertexWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
array<int>^ adjacency,
array<float>^ vertexWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexWeights : float[]
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexWeights System.Single[]
Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],AttributeWeights) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
array<int>^ adjacency,
AttributeWeights vertexAttributeWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.SimplificationMesh(Mesh,Int32[],AttributeWeights,Single[]) Constructor (Microsoft.DirectX.Direct3D)

SimplificationMesh.SimplificationMesh Constructor

How Do I...?
  • Simplify a Mesh

Creates a new instance of the SimplificationMesh class.

Definition

Visual Basic Public Sub New( _
ByVal mesh As Mesh, _
ByVal adjacency() As Integer, _
ByVal vertexAttributeWeights As AttributeWeights, _
ByVal vertexWeights() As Single _
)
C# public SimplificationMesh(
Mesh mesh,
int[] adjacency,
AttributeWeights vertexAttributeWeights,
float[] vertexWeights
);
C++ public:
SimplificationMesh(
Mesh^ mesh,
array<int>^ adjacency,
AttributeWeights vertexAttributeWeights,
array<float>^ vertexWeights
);
JScript public function SimplificationMesh(
mesh : Mesh,
adjacency : int[],
vertexAttributeWeights : AttributeWeights,
vertexWeights : float[]
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the mesh to simplify.
adjacency System.Int32[]
Array of three Int32 Leave Site values per face that specify the three neighbors for each face in the created simplification mesh.
vertexAttributeWeights Microsoft.DirectX.Direct3D.AttributeWeights
An param_AttributeWeights_vertexAttributeWeights object that contains the weight for each vertex component. If this parameter is omitted, a default structure is used. See Remarks.
vertexWeights System.Single[]
Array of vertex weights. If this parameter is omitted, all vertex weights are set to 1.0. Note that the higher the vertex weight is for a given vertex, the less likely it is to be simplified away.

Remarks

If param_AttributeWeights_vertexAttributeWeights is omitted, the following values are assigned to the default AttributeWeights structure (C# code shown).

[C#]
AttributeWeights aWeights;

aWeights.Position  = 1.0;
aWeights.Boundary =  1.0;
aWeights.Normal   =  1.0;
aWeights.Diffuse  =  0.0;
aWeights.Specular =  0.0;
aWeights.Tex[8]   =  {0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0, 0.0};

This default structure is what most applications should use because it considers only geometric and normal adjustment. Only in special cases do the other member fields need to be modified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
CannotAttributeSortException | Attribute sort is not supported as an optimization technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Simplify a Mesh

This example demonstrates how to simplify a mesh.

The mesh is simplified by 25 vertices.

In the following C# code example, mesh is assumed to be a Mesh instance that has been properly loaded and cleaned, adjacency is a GraphicsStream instance that contains the mesh adjacency data, and device is the rendering Device.

              [C#]

SimplificationMesh simplifiedMesh = new SimplificationMesh(mesh, adjacency);

simplifiedMesh.ReduceVertices(mesh.NumberVertices - 25);

mesh.Dispose();
mesh = simplifiedMesh.Clone(simplifiedMesh.Options.Value,
                            simplifiedMesh.VertexFormat, device);
simplifiedMesh.Dispose();


SimplificationMesh.UpdateUnmanagedPointer(ID3DXSPMesh) Method (Microsoft.DirectX.Direct3D)

SimplificationMesh.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this SimplificationMesh object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXSPMesh _
)
C# public void UpdateUnmanagedPointer(
ID3DXSPMesh pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXSPMesh pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXSPMesh
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXSPMesh
Pointer to the ID3DXSPMesh structure used to update the unmanaged pointer for this SimplificationMesh object.


SimplificationMesh.Declaration Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.Declaration Property

Retrieves a declaration that describes the vertices in a mesh.

Definition

Visual Basic | Public ReadOnly Property Declaration As VertexElement()
C# | public VertexElement[] Declaration { get; }
C++ public:
property array<VertexElement>^ Declaration {
array<VertexElement>^ get();
}
JScript | public function get Declaration() : VertexElement[]

Property Value

Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that describe the vertex format of the mesh vertices. The vertex element array ends with the value found in the VertexDeclarationEnd field.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SimplificationMesh.Device Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.Device Property

Retrieves the device object associated with a simplification mesh.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
A Device object that represents the Microsoft Direct3D device object associated with the simplification mesh.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SimplificationMesh.Disposed Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


SimplificationMesh.MaxFaces Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.MaxFaces Property

Retrieves the maximum number of faces that a simplification mesh can support.

Definition

Visual Basic | Public ReadOnly Property MaxFaces As Integer
C# | public int MaxFaces { get; }
C++ public:
property int MaxFaces {
int get();
}
JScript | public function get MaxFaces() : int

Property Value

System.Int32
Maximum number of faces in the original mesh.

This property is read-only.


SimplificationMesh.MaxVertices Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.MaxVertices Property

Retrieves the maximum number of vertices that a simplification mesh can support.

Definition

Visual Basic | Public ReadOnly Property MaxVertices As Integer
C# | public int MaxVertices { get; }
C++ public:
property int MaxVertices {
int get();
}
JScript | public function get MaxVertices() : int

Property Value

System.Int32
Maximum number of vertices in the original mesh.

This property is read-only.


SimplificationMesh.NumberFaces Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.NumberFaces Property

Retrieves the number of faces in the simplification mesh.

Definition

Visual Basic | Public ReadOnly Property NumberFaces As Integer
C# | public int NumberFaces { get; }
C++ public:
property int NumberFaces {
int get();
}
JScript | public function get NumberFaces() : int

Property Value

System.Int32
Number of faces in the simplification mesh.

This property is read-only.


SimplificationMesh.NumberVertices Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.NumberVertices Property

Retrieves the number of vertices in the simplification mesh.

Definition

Visual Basic | Public ReadOnly Property NumberVertices As Integer
C# | public int NumberVertices { get; }
C++ public:
property int NumberVertices {
int get();
}
JScript | public function get NumberVertices() : int

Property Value

System.Int32
Number of vertices in the simplification mesh.

This property is read-only.


SimplificationMesh.Options Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.Options Property

Retrieves the mesh options enabled for the current simplification mesh at creation time.

Definition

Visual Basic | Public ReadOnly Property Options As MeshOptions
C# | public MeshOptions Options { get; }
C++ public:
property MeshOptions Options {
MeshOptions get();
}
JScript | public function get Options() : MeshOptions

Property Value

Microsoft.DirectX.Direct3D.MeshOptions
One or more flags from the MeshFlags enumeration that indicate the options enabled for the mesh at creation time.

This property is read-only.


SimplificationMesh.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXSPMesh interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXSPMesh
C# | public ID3DXSPMesh UnmanagedComPointer { get; }
C++ public:
property ID3DXSPMesh UnmanagedComPointer {
ID3DXSPMesh get();
}
JScript | public function get UnmanagedComPointer() : ID3DXSPMesh

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXSPMesh
Unmanaged ID3DXSPMesh interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


SimplificationMesh.VertexAttributeWeights Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.VertexAttributeWeights Property

Retrieves the per-vertex attribute weights used to create a SimplificationMesh object.

Definition

Visual Basic | Public ReadOnly Property VertexAttributeWeights As AttributeWeights()
C# | public AttributeWeights[] VertexAttributeWeights { get; }
C++ public:
property array<AttributeWeights>^ VertexAttributeWeights {
array<AttributeWeights>^ get();
}
JScript | public function get VertexAttributeWeights() : AttributeWeights[]

Property Value

Microsoft.DirectX.Direct3D.AttributeWeights[]
Array of vertex attribute weights. For more information, see AttributeWeights.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • SimplificationMesh


SimplificationMesh.VertexFormat Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.VertexFormat Property

Retrieves the VertexFormats of the vertices in the SimplificationMesh.

Definition

Visual Basic | Public ReadOnly Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; }
C++ public:
property VertexFormats VertexFormat {
VertexFormats get();
}
JScript | public function get VertexFormat() : VertexFormats

Property Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object that contains the format of the vertices in the SimplificationMesh.

This property is read-only.


SimplificationMesh.VertexWeights Property (Microsoft.DirectX.Direct3D)

SimplificationMesh.VertexWeights Property

Retrieves the per-vertex weights used to create the SimplificationMesh object.

Definition

Visual Basic | Public ReadOnly Property VertexWeights As Single()
C# | public float[] VertexWeights { get; }
C++ public:
property array<float>^ VertexWeights {
array<float>^ get();
}
JScript | public function get VertexWeights() : float[]

Property Value

System.Single[]
Array of Single Leave Site values to be filled with vertex weights. Each floating-point value contains one vertex.

This property is read-only.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.

See Also

  • SimplificationMesh


SimplificationMesh.Disposing Event (Microsoft.DirectX.Direct3D)

SimplificationMesh.Disposing Event

Occurs when the Dispose method is called or when the SimplificationMesh object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.SimplificationMesh.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the SimplificationMesh object indicates whether that object has been disposed.


SkinInformation Class (Microsoft.DirectX.Direct3D)

SkinInformation Class

Manipulates bone matrices, which are used to skin vertex data for animation.

Definition

Visual Basic NotInheritable Public Class SkinInformation
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class SkinInformation : MarshalByRefObject, IDisposable
C++ | public ref class SkinInformation sealed : MarshalByRefObject, IDisposable
JScript | public final class SkinInformation extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the SkinInformation object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Clone | Clones a SkinInformation object.
ConvertToBlendedMesh | Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.
ConvertToIndexedBlendedMesh | Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.
Dispose | Immediately releases the unmanaged resources used by the SkinInformation object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the SkinInformation object to free resources before it is destroyed by the garbage collector.
GetBoneInfluence | Retrieves the vertices and weights that a bone influences.
GetBoneName | Retrieves the bone name from the bone index.
GetBoneOffsetMatrix | Retrieves the bone offset matrix.
GetHashCode | Returns the hash code for the current instance.
GetMaxFaceInfluences | Retrieves the maximum face influences in a triangle mesh with the specified index buffer.
GetNumBoneInfluences | Retrieves the number of influences for a bone.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.SkinInformation.Disposing event when called from within a derived class.
Remap | Updates bone influence information to match vertices after they are reordered.
SetBoneInfluence | Sets the influence value for a bone.
SetBoneName | Sets the bone name associated with a bone number.
SetBoneOffsetMatrix | Sets the bone offset matrix.
SkinInformation | Initializes a new instance of the SkinInformation class.
UpdateSkinnedMesh | Applies software skinning to target vertices that are based on the current matrices.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this SkinInformation object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Declaration | Retrieves or sets the vertex declaration.
Disposed | Gets a value that indicates whether the object is disposed.
MaxVertexInfluences | Retrieves the maximum number of influences for any vertex in a mesh.
MinBoneInfluence | Retrieves or sets the minimum bone influence.
NumberBones | Retrieves the number of bones in a mesh.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXSkinInfo interface pointer.
VertexFormat | Retrieves or sets the fixed function vertex value.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
SkinInformation

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SkinInformation.Clone() Method (Microsoft.DirectX.Direct3D)

SkinInformation.Clone Method

Clones a SkinInformation object.

Definition

Visual Basic | Public Function Clone() As SkinInformation
C# | public SkinInformation Clone();
C++ public:
SkinInformation^ Clone();
JScript | public function Clone() : SkinInformation;

Return Value

Microsoft.DirectX.Direct3D.SkinInformation
A SkinInformation object that contains the cloned object.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh Method ()

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Overload List

public Mesh ConvertToBlendedMesh(Mesh, MeshFlags, GraphicsStream, out int, out BoneCombination);
public Mesh ConvertToBlendedMesh(Mesh, MeshFlags, GraphicsStream, out int, out BoneCombination, out int, out int, out GraphicsStream);
public Mesh ConvertToBlendedMesh(Mesh, MeshFlags, int[], out int, out BoneCombination);
public Mesh ConvertToBlendedMesh(Mesh, MeshFlags, int[], out int, out BoneCombination, out int, out int, out GraphicsStream);

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh(Mesh,MeshFlags,Int32[],Int32,BoneCombination) Method (Microsoft.DirectX.Direct3D)

SkinInformation.ConvertToBlendedMesh Method

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Definition

Visual Basic Public Function ConvertToBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination _
) As Mesh
C# public Mesh ConvertToBlendedMesh(
Mesh mesh,
MeshFlags options,
int[] adjacencyIn,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable
);
C++ public:
Mesh^ ConvertToBlendedMesh(
Mesh^ mesh,
MeshFlags options,
array<int>^ adjacencyIn,
[Out] int% maxFaceInfluence,
[Out] BoneCombination% boneCombinationTable
);
JScript public function ConvertToBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : int[],
maxFaceInfluence : int,
boneCombinationTable : BoneCombination
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Source Mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn System.Int32[]
Array that contains the input mesh adjacency information.
maxFaceInfluence System.Int32
Integer that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh(Mesh,MeshFlags,Int32[],Int32,BoneCombination,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SkinInformation.ConvertToBlendedMesh Method

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Definition

Visual Basic Public Function ConvertToBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh ConvertToBlendedMesh(
Mesh mesh,
MeshFlags options,
int[] adjacencyIn,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
Mesh^ ConvertToBlendedMesh(
Mesh^ mesh,
MeshFlags options,
array<int>^ adjacencyIn,
[Out] int% maxFaceInfluence,
[Out] BoneCombination% boneCombinationTable,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function ConvertToBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : int[],
maxFaceInfluence : int,
boneCombinationTable : BoneCombination,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Source Mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn System.Int32[]
Array that contains the input mesh adjacency information.
maxFaceInfluence System.Int32
Integer that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.
adjacencyOut System.Int32[]
Array that contains the output mesh adjacency information.
faceRemap System.Int32[]
Array that contains a new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains a new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh(Mesh,MeshFlags,GraphicsStream,Int32,BoneCombination) Method (Microsoft.DirectX.Direct3D)

SkinInformation.ConvertToBlendedMesh Method

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Definition

Visual Basic Public Function ConvertToBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination _
) As Mesh
C# public Mesh ConvertToBlendedMesh(
Mesh mesh,
MeshFlags options,
GraphicsStream adjacencyIn,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable
);
C++ public:
Mesh^ ConvertToBlendedMesh(
Mesh^ mesh,
MeshFlags options,
GraphicsStream^ adjacencyIn,
[Out] int% maxFaceInfluence,
[Out] BoneCombination% boneCombinationTable
);
JScript public function ConvertToBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : GraphicsStream,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Source Mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the input mesh adjacency information.
maxFaceInfluence System.Int32
Integer that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToBlendedMesh(Mesh,MeshFlags,GraphicsStream,Int32,BoneCombination,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SkinInformation.ConvertToBlendedMesh Method

Takes an existing mesh and returns a new mesh with per-vertex blend weights and a bone combination table. The table describes which bones affect which subsets of the mesh.

Definition

Visual Basic Public Function ConvertToBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh ConvertToBlendedMesh(
Mesh mesh,
MeshFlags options,
GraphicsStream adjacencyIn,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
Mesh^ ConvertToBlendedMesh(
Mesh^ mesh,
MeshFlags options,
GraphicsStream^ adjacencyIn,
[Out] int% maxFaceInfluence,
[Out] BoneCombination% boneCombinationTable,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function ConvertToBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : GraphicsStream,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Source Mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the input mesh adjacency information.
maxFaceInfluence System.Int32
Integer that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.
adjacencyOut System.Int32[]
Array that contains the output mesh adjacency information.
faceRemap System.Int32[]
Array that contains a new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains a new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh Method ()

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Overload List

public Mesh ConvertToIndexedBlendedMesh(Mesh, MeshFlags, GraphicsStream, int, out int, out BoneCombination);
public Mesh ConvertToIndexedBlendedMesh(Mesh, MeshFlags, GraphicsStream, int, out int, out BoneCombination, out int, out int, out GraphicsStream);
public Mesh ConvertToIndexedBlendedMesh(Mesh, MeshFlags, int[], int, out int, out BoneCombination);
public Mesh ConvertToIndexedBlendedMesh(Mesh, MeshFlags, int[], int, out int, out BoneCombination, out int, out int, out GraphicsStream);

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh(Mesh,MeshFlags,Int32[],Int32,Int32,BoneCombination) Method (Microsoft.DirectX.Direct3D)

SkinInformation.ConvertToIndexedBlendedMesh Method

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Definition

Visual Basic Public Function ConvertToIndexedBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByVal paletteSize As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination _
) As Mesh
C# public Mesh ConvertToIndexedBlendedMesh(
Mesh mesh,
MeshFlags options,
int[] adjacencyIn,
int paletteSize,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable
);
C++ public:
Mesh^ ConvertToIndexedBlendedMesh(
Mesh^ mesh,
MeshFlags options,
array<int>^ adjacencyIn,
int paletteSize,
[Out] int% maxFaceInfluence,
[Out] BoneCombination% boneCombinationTable
);
JScript public function ConvertToIndexedBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : int[],
paletteSize : int,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Source Mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn System.Int32[]
Array that contains the input mesh adjacency information.
paletteSize System.Int32
Value that contains the number of bone matrices available for matrix palette skinning.
maxFaceInfluence System.Int32
Value that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh(Mesh,MeshFlags,Int32[],Int32,Int32,BoneCombination,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SkinInformation.ConvertToIndexedBlendedMesh Method

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Definition

Visual Basic Public Function ConvertToIndexedBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn() As Integer, _
ByVal paletteSize As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh ConvertToIndexedBlendedMesh(
Mesh mesh,
MeshFlags options,
int[] adjacencyIn,
int paletteSize,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
Mesh^ ConvertToIndexedBlendedMesh(
Mesh^ mesh,
MeshFlags options,
array<int>^ adjacencyIn,
int paletteSize,
[Out] int% maxFaceInfluence,
[Out] BoneCombination% boneCombinationTable,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function ConvertToIndexedBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : int[],
paletteSize : int,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Source Mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn System.Int32[]
Array that contains the input mesh adjacency information.
paletteSize System.Int32
Value that contains the number of bone matrices available for matrix palette skinning.
maxFaceInfluence System.Int32
Value that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.
adjacencyOut System.Int32[]
Array that contains the output mesh adjacency information.
faceRemap System.Int32[]
Array that contains a new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains a new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh(Mesh,MeshFlags,GraphicsStream,Int32,Int32,BoneCombination) Method (Microsoft.DirectX.Direct3D)

SkinInformation.ConvertToIndexedBlendedMesh Method

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Definition

Visual Basic Public Function ConvertToIndexedBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByVal paletteSize As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination _
) As Mesh
C# public Mesh ConvertToIndexedBlendedMesh(
Mesh mesh,
MeshFlags options,
GraphicsStream adjacencyIn,
int paletteSize,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable
);
C++ public:
Mesh^ ConvertToIndexedBlendedMesh(
Mesh^ mesh,
MeshFlags options,
GraphicsStream^ adjacencyIn,
int paletteSize,
[Out] int% maxFaceInfluence,
[Out] BoneCombination% boneCombinationTable
);
JScript public function ConvertToIndexedBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : GraphicsStream,
paletteSize : int,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Source Mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the input mesh adjacency information.
paletteSize System.Int32
Value that contains the number of bone matrices available for matrix palette skinning.
maxFaceInfluence System.Int32
Value that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.ConvertToIndexedBlendedMesh(Mesh,MeshFlags,GraphicsStream,Int32,Int32,BoneCombination,Int32,Int32,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SkinInformation.ConvertToIndexedBlendedMesh Method

Takes an existing mesh and returns a new mesh with per-vertex blend weights, indices, and a bone combination table. The table describes which bone palettes affect which subsets of the mesh.

Definition

Visual Basic Public Function ConvertToIndexedBlendedMesh( _
ByVal mesh As Mesh, _
ByVal options As MeshFlags, _
ByVal adjacencyIn As GraphicsStream, _
ByVal paletteSize As Integer, _
ByRef maxFaceInfluence As Integer, _
ByRef boneCombinationTable As BoneCombination, _
ByRef adjacencyOut As Integer, _
ByRef faceRemap As Integer, _
ByRef vertexRemap As GraphicsStream _
) As Mesh
C# public Mesh ConvertToIndexedBlendedMesh(
Mesh mesh,
MeshFlags options,
GraphicsStream adjacencyIn,
int paletteSize,
out int maxFaceInfluence,
out BoneCombination boneCombinationTable,
out int adjacencyOut,
out int faceRemap,
out GraphicsStream vertexRemap
);
C++ public:
Mesh^ ConvertToIndexedBlendedMesh(
Mesh^ mesh,
MeshFlags options,
GraphicsStream^ adjacencyIn,
int paletteSize,
[Out] int% maxFaceInfluence,
[Out] BoneCombination% boneCombinationTable,
[Out] int% adjacencyOut,
[Out] int% faceRemap,
[Out] GraphicsStream^% vertexRemap
);
JScript public function ConvertToIndexedBlendedMesh(
mesh : Mesh,
options : MeshFlags,
adjacencyIn : GraphicsStream,
paletteSize : int,
maxFaceInfluence : int,
boneCombinationTable : BoneCombination,
adjacencyOut : int,
faceRemap : int,
vertexRemap : GraphicsStream
) : Mesh;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Source Mesh.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies creation options for the new mesh.
adjacencyIn Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the input mesh adjacency information.
paletteSize System.Int32
Value that contains the number of bone matrices available for matrix palette skinning.
maxFaceInfluence System.Int32
Value that contains the maximum number of bone influences required per vertex for the current skinning method.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.
adjacencyOut System.Int32[]
Array that contains the output mesh adjacency information.
faceRemap System.Int32[]
Array that contains a new index for each face.
vertexRemap Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains a new index for each vertex.

Return Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object that represents the new mesh.

Remarks

Each element in the remap arrays specifies the previous index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertexRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.Dispose() Method (Microsoft.DirectX.Direct3D)

SkinInformation.Dispose Method

Immediately releases the unmanaged resources used by the SkinInformation object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~SkinInformation();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.SkinInformation.Disposed
  • Microsoft.DirectX.Direct3D.SkinInformation.Disposing


SkinInformation.Equals(Object) Method (Microsoft.DirectX.Direct3D)

SkinInformation.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


SkinInformation.Finalize() Method (Microsoft.DirectX.Direct3D)

SkinInformation.Finalize Method

Allows the SkinInformation object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~SkinInformation();
C++ | !SkinInformation();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


SkinInformation.GetBoneInfluence(Int32) Method (Microsoft.DirectX.Direct3D)

SkinInformation.GetBoneInfluence Method

Retrieves the vertices and weights that a bone influences.

Definition

Visual Basic Public Function GetBoneInfluence( _
ByVal bone As Integer _
) As BoneInfluences
C# public BoneInfluences GetBoneInfluence(
int bone
);
C++ public:
BoneInfluences GetBoneInfluence(
int bone
);
JScript public function GetBoneInfluence(
bone : int
) : BoneInfluences;

Parameters

bone System.Int32
Integer that represents the bone number.

Return Value

Microsoft.DirectX.Direct3D.BoneInfluences
A BoneInfluences object that contains the bone influences.

Remarks

Use SkinInformation.GetNumBoneInfluences to determine how many vertices the bone influences.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SkinInformation.SetBoneInfluence


SkinInformation.GetBoneName(Int32) Method (Microsoft.DirectX.Direct3D)

SkinInformation.GetBoneName Method

Retrieves the bone name from the bone index.

Definition

Visual Basic Public Function GetBoneName( _
ByVal bone As Integer _
) As String
C# public string GetBoneName(
int bone
);
C++ public:
String^ GetBoneName(
int bone
);
JScript public function GetBoneName(
bone : int
) : String;

Parameters

bone System.Int32
Value that represents the bone number of the bone name to retrieve.

Return Value

System.String
String that contains the bone name.

See Also

  • SkinInformation.NumberBones
  • SkinInformation.SetBoneName


SkinInformation.GetBoneOffsetMatrix(Int32) Method (Microsoft.DirectX.Direct3D)

SkinInformation.GetBoneOffsetMatrix Method

Retrieves the bone offset matrix.

Definition

Visual Basic Public Function GetBoneOffsetMatrix( _
ByVal bone As Integer _
) As Matrix
C# public Matrix GetBoneOffsetMatrix(
int bone
);
C++ public:
Matrix GetBoneOffsetMatrix(
int bone
);
JScript public function GetBoneOffsetMatrix(
bone : int
) : Matrix;

Parameters

bone System.Int32
Value that represents the bone number of the bone offset matrix to retrieve.

Return Value

Microsoft.DirectX.Matrix
A Matrix object that represents the bone offset matrix.

See Also

  • SkinInformation.NumberBones
  • SkinInformation.SetBoneOffsetMatrix


SkinInformation.GetHashCode() Method (Microsoft.DirectX.Direct3D)

SkinInformation.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


SkinInformation.GetMaxFaceInfluences(IndexBuffer,Int32) Method (Microsoft.DirectX.Direct3D)

SkinInformation.GetMaxFaceInfluences Method

Retrieves the maximum face influences in a triangle mesh with the specified index buffer.

Definition

Visual Basic Public Function GetMaxFaceInfluences( _
ByVal indexBuffer As IndexBuffer, _
ByVal numFaces As Integer _
) As Integer
C# public int GetMaxFaceInfluences(
IndexBuffer indexBuffer,
int numFaces
);
C++ public:
int GetMaxFaceInfluences(
IndexBuffer^ indexBuffer,
int numFaces
);
JScript public function GetMaxFaceInfluences(
indexBuffer : IndexBuffer,
numFaces : int
) : int;

Parameters

indexBuffer Microsoft.DirectX.Direct3D.IndexBuffer
An IndexBuffer object that contains the mesh index data.
numFaces System.Int32
Value that represents the number of faces in the mesh.

Return Value

System.Int32
Value that contains the maximum face influences.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.GetNumBoneInfluences(Int32) Method (Microsoft.DirectX.Direct3D)

SkinInformation.GetNumBoneInfluences Method

Retrieves the number of influences for a bone.

Definition

Visual Basic Public Function GetNumBoneInfluences( _
ByVal bone As Integer _
) As Integer
C# public int GetNumBoneInfluences(
int bone
);
C++ public:
int GetNumBoneInfluences(
int bone
);
JScript public function GetNumBoneInfluences(
bone : int
) : int;

Parameters

bone System.Int32
Value that represents the bone number for which to retrieve the number of influences.

Return Value

System.Int32
Value that contains the number of influences for the bone.


SkinInformation.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

SkinInformation.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXSkinInfo, which allows unmanaged COM clients to create an instance of the managed SkinInformation class. Not supported.


SkinInformation.op_Equality(SkinInformation,SkinInformation) Method (Microsoft.DirectX.Direct3D)

SkinInformation.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As SkinInformation, _
ByVal right As SkinInformation _
) As Boolean
C# public static bool op_Equality(
SkinInformation left,
SkinInformation right
);
C++ public:
static bool operator==(
SkinInformation^ left,
SkinInformation^ right
);
JScript public static function op_Equality(
left : SkinInformation,
right : SkinInformation
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.SkinInformation
The SkinInformation object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.SkinInformation
The SkinInformation object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


SkinInformation.op_Inequality(SkinInformation,SkinInformation) Method (Microsoft.DirectX.Direct3D)

SkinInformation.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As SkinInformation, _
ByVal right As SkinInformation _
) As Boolean
C# public static bool op_Inequality(
SkinInformation left,
SkinInformation right
);
C++ public:
static bool operator!=(
SkinInformation^ left,
SkinInformation^ right
);
JScript public static function op_Inequality(
left : SkinInformation,
right : SkinInformation
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.SkinInformation
The SkinInformation object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.SkinInformation
The SkinInformation object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


SkinInformation.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

SkinInformation.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.SkinInformation.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


SkinInformation.Remap(Int32[]) Method (Microsoft.DirectX.Direct3D)

SkinInformation.Remap Method

Updates bone influence information to match vertices after they are reordered.

Definition

Visual Basic Public Sub Remap( _
ByVal vertRemap() As Integer _
)
C# public void Remap(
int[] vertRemap
);
C++ public:
void Remap(
array<int>^ vertRemap
);
JScript public function Remap(
vertRemap : int[]
);

Parameters

vertRemap System.Int32[]
Array of integers that represent the vertices to remap.

Remarks

This method should be called if the target vertex buffer is reordered externally.

Each element in vertRemap specifies the previous vertex index for that position. For example, if a vertex is in position 3 but is remapped to position 5, the fifth element of vertRemap contains 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.SetBoneInfluence(Int32,Int32,Int32[],Single[]) Method (Microsoft.DirectX.Direct3D)

SkinInformation.SetBoneInfluence Method

Sets the influence value for a bone.

Definition

Visual Basic Public Sub SetBoneInfluence( _
ByVal bone As Integer, _
ByVal numInfluences As Integer, _
ByVal vertices() As Integer, _
ByVal weights() As Single _
)
C# public void SetBoneInfluence(
int bone,
int numInfluences,
int[] vertices,
float[] weights
);
C++ public:
void SetBoneInfluence(
int bone,
int numInfluences,
array<int>^ vertices,
array<float>^ weights
);
JScript public function SetBoneInfluence(
bone : int,
numInfluences : int,
vertices : int[],
weights : float[]
);

Parameters

bone System.Int32
Value that represents the bone number.
numInfluences System.Int32
Value that represents the number of influences.
vertices System.Int32[]
Array of integers that represent the vertices influenced by the bone.
weights System.Single[]
Array of floating-point values that represent the weights influenced by the bone.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SkinInformation.GetBoneInfluence
  • SkinInformation.GetNumBoneInfluences


SkinInformation.SetBoneName(Int32,String) Method (Microsoft.DirectX.Direct3D)

SkinInformation.SetBoneName Method

Sets the bone name associated with a bone number.

Definition

Visual Basic Public Sub SetBoneName( _
ByVal bone As Integer, _
ByVal name As String _
)
C# public void SetBoneName(
int bone,
string name
);
C++ public:
void SetBoneName(
int bone,
String^ name
);
JScript public function SetBoneName(
bone : int,
name : String
);

Parameters

bone System.Int32
Value that represents the bone number.
name System.String
String that contains the bone name.

See Also

  • SkinInformation.NumberBones
  • SkinInformation.SetBoneName


SkinInformation.SetBoneOffsetMatrix(Int32,Matrix) Method (Microsoft.DirectX.Direct3D)

SkinInformation.SetBoneOffsetMatrix Method

Sets the bone offset matrix.

Definition

Visual Basic Public Sub SetBoneOffsetMatrix( _
ByVal bone As Integer, _
ByVal boneTransform As Matrix _
)
C# public void SetBoneOffsetMatrix(
int bone,
Matrix boneTransform
);
C++ public:
void SetBoneOffsetMatrix(
int bone,
Matrix boneTransform
);
JScript public function SetBoneOffsetMatrix(
bone : int,
boneTransform : Matrix
);

Parameters

bone System.Int32
Value that represents the bone number of the bone offset matrix.
boneTransform Microsoft.DirectX.Matrix
A Matrix object that represents the bone offset matrix.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SkinInformation.GetBoneOffsetMatrix


SkinInformation.SkinInformation Constructor ()

Initializes a new instance of the SkinInformation class.

Overload List

public SkinInformation(BaseMesh, BoneCombination[]);
public SkinInformation(BaseMesh, int, GraphicsStream);
public SkinInformation(ID3DXSkinInfo);
public SkinInformation(int, GraphicsStream, int);
public SkinInformation(int, VertexElement[], int);
public SkinInformation(int, VertexFormats, int);
public SkinInformation(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(ID3DXSkinInfo) Constructor (Microsoft.DirectX.Direct3D)

SkinInformation.SkinInformation Constructor

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXSkinInfo _
)
C# public SkinInformation(
ID3DXSkinInfo pUnk
);
C++ public:
SkinInformation(
ID3DXSkinInfo pUnk
);
JScript public function SkinInformation(
pUnk : ID3DXSkinInfo
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXSkinInfo
Unmanaged Component Object Model (COM) ID3DXSkinInfo interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

SkinInformation.SkinInformation Constructor

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public SkinInformation(
IntPtr unmanagedObject
);
C++ public:
SkinInformation(
IntPtr unmanagedObject
);
JScript public function SkinInformation(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXSkinInfo interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(BaseMesh,Int32,GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

SkinInformation.SkinInformation Constructor

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic Public Sub New( _
ByVal baseMesh As BaseMesh, _
ByVal boneCombinationTableLength As Integer, _
ByVal boneCombinationTable As GraphicsStream _
)
C# public SkinInformation(
BaseMesh baseMesh,
int boneCombinationTableLength,
GraphicsStream boneCombinationTable
);
C++ public:
SkinInformation(
BaseMesh^ baseMesh,
int boneCombinationTableLength,
GraphicsStream^ boneCombinationTable
);
JScript public function SkinInformation(
baseMesh : BaseMesh,
boneCombinationTableLength : int,
boneCombinationTable : GraphicsStream
);

Parameters

baseMesh Microsoft.DirectX.Direct3D.BaseMesh
A BaseMesh object from which to create the skin mesh.
boneCombinationTableLength System.Int32
Value that represents the bone combination table length.
boneCombinationTable Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the bone combinations.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(BaseMesh,BoneCombination[]) Constructor (Microsoft.DirectX.Direct3D)

SkinInformation.SkinInformation Constructor

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic Public Sub New( _
ByVal baseMesh As BaseMesh, _
ByVal boneCombinationTable() As BoneCombination _
)
C# public SkinInformation(
BaseMesh baseMesh,
BoneCombination[] boneCombinationTable
);
C++ public:
SkinInformation(
BaseMesh^ baseMesh,
array<BoneCombination>^ boneCombinationTable
);
JScript public function SkinInformation(
baseMesh : BaseMesh,
boneCombinationTable : BoneCombination[]
);

Parameters

baseMesh Microsoft.DirectX.Direct3D.BaseMesh
A BaseMesh object from which to create the skin mesh.
boneCombinationTable Microsoft.DirectX.Direct3D.BoneCombination[]
Array of BoneCombination objects.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(Int32,VertexFormats,Int32) Constructor (Microsoft.DirectX.Direct3D)

SkinInformation.SkinInformation Constructor

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic Public Sub New( _
ByVal numVertices As Integer, _
ByVal vertexFormat As VertexFormats, _
ByVal numBones As Integer _
)
C# public SkinInformation(
int numVertices,
VertexFormats vertexFormat,
int numBones
);
C++ public:
SkinInformation(
int numVertices,
VertexFormats vertexFormat,
int numBones
);
JScript public function SkinInformation(
numVertices : int,
vertexFormat : VertexFormats,
numBones : int
);

Parameters

numVertices System.Int32
Value that represents the number of vertices in the skin mesh.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object that describes the vertex format for the skin mesh.
numBones System.Int32
Value that represents the number of bones for the skin mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(Int32,VertexElement[],Int32) Constructor (Microsoft.DirectX.Direct3D)

SkinInformation.SkinInformation Constructor

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic Public Sub New( _
ByVal numVertices As Integer, _
ByVal decl() As VertexElement, _
ByVal numBones As Integer _
)
C# public SkinInformation(
int numVertices,
VertexElement[] decl,
int numBones
);
C++ public:
SkinInformation(
int numVertices,
array<VertexElement>^ decl,
int numBones
);
JScript public function SkinInformation(
numVertices : int,
decl : VertexElement[],
numBones : int
);

Parameters

numVertices System.Int32
Value that represents the number of vertices in the skin mesh.
decl Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement objects that describe the vertex format for the skin mesh.
numBones System.Int32
Value that represents the number of bones for the skin mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SkinInformation.SkinInformation(Int32,GraphicsStream,Int32) Constructor (Microsoft.DirectX.Direct3D)

SkinInformation.SkinInformation Constructor

Initializes a new instance of the SkinInformation class.

Definition

Visual Basic Public Sub New( _
ByVal numVertices As Integer, _
ByVal declaration As GraphicsStream, _
ByVal numBones As Integer _
)
C# public SkinInformation(
int numVertices,
GraphicsStream declaration,
int numBones
);
C++ public:
SkinInformation(
int numVertices,
GraphicsStream^ declaration,
int numBones
);
JScript public function SkinInformation(
numVertices : int,
declaration : GraphicsStream,
numBones : int
);

Parameters

numVertices System.Int32
Value that represents the number of vertices in the skin mesh.
declaration Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains vertex format data for the skin mesh.
numBones System.Int32
Value that represents the number of bones for the skin mesh.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


SkinInformation.UpdateSkinnedMesh Method ()

Applies software skinning to target vertices that are based on the current matrices.

Overload List

public Array UpdateSkinnedMesh(Matrix[], Matrix[], Array);
public void UpdateSkinnedMesh(Matrix[], Matrix[], GraphicsStream, GraphicsStream);

Remarks

When used to skin vertices with two position elements, this method skins the second position element with the inverse of the bone instead of the bone itself.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.UpdateSkinnedMesh(Matrix[],Matrix[],GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SkinInformation.UpdateSkinnedMesh Method

Applies software skinning to target vertices that are based on the current matrices.

Definition

Visual Basic Public Sub UpdateSkinnedMesh( _
ByVal boneTransforms() As Matrix, _
ByVal boneInvTransforms() As Matrix, _
ByVal sourceVertices As GraphicsStream, _
ByVal destinationVertices As GraphicsStream _
)
C# public void UpdateSkinnedMesh(
Matrix[] boneTransforms,
Matrix[] boneInvTransforms,
GraphicsStream sourceVertices,
GraphicsStream destinationVertices
);
C++ public:
void UpdateSkinnedMesh(
array<Matrix>^ boneTransforms,
array<Matrix>^ boneInvTransforms,
GraphicsStream^ sourceVertices,
GraphicsStream^ destinationVertices
);
JScript public function UpdateSkinnedMesh(
boneTransforms : Matrix[],
boneInvTransforms : Matrix[],
sourceVertices : GraphicsStream,
destinationVertices : GraphicsStream
);

Parameters

boneTransforms Microsoft.DirectX.Matrix[]
Array of Matrix objects that represent bone transforms.
boneInvTransforms Microsoft.DirectX.Matrix[]
Array of Matrix objects that represent the inverse transpose of the bone transform matrix.
sourceVertices Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the source vertices.
destinationVertices Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains destination vertices.

Remarks

When used to skin vertices with two position elements, this method skins the second position element with the inverse of the bone instead of the bone itself.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.UpdateSkinnedMesh(Matrix[],Matrix[],Array) Method (Microsoft.DirectX.Direct3D)

SkinInformation.UpdateSkinnedMesh Method

Applies software skinning to target vertices that are based on the current matrices.

Definition

Visual Basic Public Function UpdateSkinnedMesh( _
ByVal boneTransforms() As Matrix, _
ByVal boneInvTransforms() As Matrix, _
ByVal verticesSource As Array _
) As Array
C# public Array UpdateSkinnedMesh(
Matrix[] boneTransforms,
Matrix[] boneInvTransforms,
Array verticesSource
);
C++ public:
Array^ UpdateSkinnedMesh(
array<Matrix>^ boneTransforms,
array<Matrix>^ boneInvTransforms,
Array^ verticesSource
);
JScript public function UpdateSkinnedMesh(
boneTransforms : Matrix[],
boneInvTransforms : Matrix[],
verticesSource : Array
) : Array;

Parameters

boneTransforms Microsoft.DirectX.Matrix[]
Array of Matrix objects that represent bone transforms.
boneInvTransforms Microsoft.DirectX.Matrix[]
Array of Matrix objects that represent the inverse transpose of the bone transform matrix.
verticesSource System.Array
An Array Leave Site of source vertices.

Return Value

System.Array
An Array Leave Site of destination vertices.

Remarks

When used to skin vertices with two position elements, this method skins the second position element with the inverse of the bone instead of the bone itself.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.UpdateUnmanagedPointer(ID3DXSkinInfo) Method (Microsoft.DirectX.Direct3D)

SkinInformation.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this SkinInformation object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXSkinInfo _
)
C# public void UpdateUnmanagedPointer(
ID3DXSkinInfo pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXSkinInfo pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXSkinInfo
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXSkinInfo
Pointer to the ID3DXSkinInfo structure used to update the unmanaged pointer for this SkinInformation object.


SkinInformation.Declaration Property (Microsoft.DirectX.Direct3D)

SkinInformation.Declaration Property

Retrieves or sets the vertex declaration.

Definition

Visual Basic | Public Property Declaration As VertexElement()
C# | public VertexElement[] Declaration { get; set; }
C++ public:
property array<VertexElement>^ Declaration {
array<VertexElement>^ get();
void set(array<VertexElement>^ value);
}
JScript public function get Declaration() : VertexElement[]
public function set Declaration(VertexElement[]);

Property Value

Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that contain the vertex declarations.

This property is read/write.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.Disposed Property (Microsoft.DirectX.Direct3D)

SkinInformation.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


SkinInformation.MaxVertexInfluences Property (Microsoft.DirectX.Direct3D)

SkinInformation.MaxVertexInfluences Property

Retrieves the maximum number of influences for any vertex in a mesh.

Definition

Visual Basic | Public ReadOnly Property MaxVertexInfluences As Integer
C# | public int MaxVertexInfluences { get; }
C++ public:
property int MaxVertexInfluences {
int get();
}
JScript | public function get MaxVertexInfluences() : int

Property Value

System.Int32
Value that represents the maximum vertex influence.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.MinBoneInfluence Property (Microsoft.DirectX.Direct3D)

SkinInformation.MinBoneInfluence Property

Retrieves or sets the minimum bone influence.

Definition

Visual Basic | Public Property MinBoneInfluence As Single
C# | public float MinBoneInfluence { get; set; }
C++ public:
property float MinBoneInfluence {
float get();
void set(float value);
}
JScript public function get MinBoneInfluence() : float
public function set MinBoneInfluence(float);

Property Value

System.Single
Floating-point value that represents the minimum bone influence.

This property is read/write.

Remarks

Influence values smaller than the minimum value are ignored.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SkinInformation.NumberBones Property (Microsoft.DirectX.Direct3D)

SkinInformation.NumberBones Property

Retrieves the number of bones in a mesh.

Definition

Visual Basic | Public ReadOnly Property NumberBones As Integer
C# | public int NumberBones { get; }
C++ public:
property int NumberBones {
int get();
}
JScript | public function get NumberBones() : int

Property Value

System.Int32
Value that represents the number of bones.

This property is read-only.


SkinInformation.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

SkinInformation.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXSkinInfo interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXSkinInfo
C# | public ID3DXSkinInfo UnmanagedComPointer { get; }
C++ public:
property ID3DXSkinInfo UnmanagedComPointer {
ID3DXSkinInfo get();
}
JScript | public function get UnmanagedComPointer() : ID3DXSkinInfo

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXSkinInfo
Unmanaged ID3DXSkinInfo interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


SkinInformation.VertexFormat Property (Microsoft.DirectX.Direct3D)

SkinInformation.VertexFormat Property

Retrieves or sets the fixed function vertex value.

Definition

Visual Basic | Public Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; set; }
C++ public:
property VertexFormats VertexFormat {
VertexFormats get();
void set(VertexFormats value);
}
JScript public function get VertexFormat() : VertexFormats
public function set VertexFormat(VertexFormats);

Property Value

Microsoft.DirectX.Direct3D.VertexFormats
Valid combination of VertexFormats enumeration values that describe the vertex format.

This property is read/write.


SkinInformation.Disposing Event (Microsoft.DirectX.Direct3D)

SkinInformation.Disposing Event

Occurs when the Dispose method is called or when the SkinInformation object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.SkinInformation.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the SkinInformation object indicates whether that object has been disposed.


SkinningNotSupportedException Class (Microsoft.DirectX.Direct3D)

SkinningNotSupportedException Class

Skinning is not supported.

Definition

Visual Basic Public Class SkinningNotSupportedException
Inherits Direct3DXException
C# | public class SkinningNotSupportedException : Direct3DXException
C++ | public ref class SkinningNotSupportedException : Direct3DXException
JScript | public class SkinningNotSupportedException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SkinningNotSupportedException | Initializes a new instance of the SkinningNotSupportedException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
SkinningNotSupportedException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SkinningNotSupportedException.SkinningNotSupportedException Constructor ()

Initializes a new instance of the SkinningNotSupportedException class.

Overload List

public SkinningNotSupportedException();
protected SkinningNotSupportedException(SerializationInfo, StreamingContext);
public SkinningNotSupportedException(string);
public SkinningNotSupportedException(string, Exception);


SkinningNotSupportedException.SkinningNotSupportedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:

Initializes a new instance of the SkinningNotSupportedException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SkinningNotSupportedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SkinningNotSupportedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SkinningNotSupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


SkinningNotSupportedException.SkinningNotSupportedException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:

Initializes a new instance of the SkinningNotSupportedException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SkinningNotSupportedException(
string message,
Exception inner
);
C++ public:
SkinningNotSupportedException(
String^ message,
Exception^ inner
);
JScript public function SkinningNotSupportedException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


SkinningNotSupportedException.SkinningNotSupportedException(String) Constructor (Microsoft.DirectX.Direct3D)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:

Initializes a new instance of the SkinningNotSupportedException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SkinningNotSupportedException(
string message
);
C++ public:
SkinningNotSupportedException(
String^ message
);
JScript public function SkinningNotSupportedException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


SkinningNotSupportedException.SkinningNotSupportedException() Constructor (Microsoft.DirectX.Direct3D)

SkinningNotSupportedException.SkinningNotSupportedException Constructor

 Language:

Initializes a new instance of the SkinningNotSupportedException class.

Definition

Visual Basic | Public Sub New()
C# | public SkinningNotSupportedException();
C++ public:
SkinningNotSupportedException();
JScript | public function SkinningNotSupportedException();


SphericalHarmonics Class (Microsoft.DirectX.Direct3D)

SphericalHarmonics Class

Encapsulates spherical harmonic (SH) mathematical functions.

Definition

Visual Basic NotInheritable MustInherit Public Class SphericalHarmonics
Inherits Object
C# | public abstract sealed class SphericalHarmonics : Object
C++ | public ref class SphericalHarmonics abstract sealed : Object
JScript | public final abstract class SphericalHarmonics extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) MaximumOrder | Retrieves the maximum order for SH evaluation.
static (Shared in Visual Basic) MinimumOrder | Retrieves the minimum order for SH evaluation.

Methods

Method | Description
static (Shared in Visual Basic) Add | Adds two SH vectors together; in other words, Out[i] = A[i] + B[i].
static (Shared in Visual Basic) Dot | Computes the dot product of two SH vectors.
static (Shared in Visual Basic) EvaluateConeLight | Evaluates a light that is a cone of constant intensity and returns spectral SH data.
static (Shared in Visual Basic) EvaluateDirection | Evaluates the SH basis functions from an input direction vector.
static (Shared in Visual Basic) EvaluateDirectionalLight | Evaluates a directional light and returns spectral SH data.
static (Shared in Visual Basic) EvaluateHemisphereLight | Evaluates a light that is a linear interpolation between two colors over the sphere.
static (Shared in Visual Basic) EvaluateSphericalLight | Evaluates a spherical light and returns spectral SH data.
static (Shared in Visual Basic) ProjectCubeMap | Projects a function represented on a cube map into SH.
static (Shared in Visual Basic) Rotate | Rotates the SH vector by the given matrix.
static (Shared in Visual Basic) RotateZ | Rotates the SH vector in the z-axis by the given angle.
static (Shared in Visual Basic) Scale | Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Inheritance Hierarchy

Object Leave Site
SphericalHarmonics

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SphericalHarmonics.Add Method ()

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Overload List

public static void Add(GraphicsStream, int, GraphicsStream, GraphicsStream);
public static void Add(GraphicsStream, int, float[], float[]);
public static void Add(float[], int, GraphicsStream, GraphicsStream);
public static void Add(float[], int, float[], float[]);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Add(Single[],Int32,Single[],Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Add Method

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Definition

Visual Basic Public Shared Sub Add( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal vectorA() As Single, _
ByVal vectorB() As Single _
)
C# public static void Add(
float[] output,
int order,
float[] vectorA,
float[] vectorB
);
C++ public:
static void Add(
array<float>^ output,
int order,
array<float>^ vectorA,
array<float>^ vectorB
);
JScript public static function Add(
output : float[],
order : int,
vectorA : float[],
vectorB : float[]
);

Parameters

output System.Single[]
An array of floating point values that represent the output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA System.Single[]
An array of floating point values that represent the first SH vector to add to the second vector.
vectorB System.Single[]
An array of floating point values that represent the second SH vector to add to the first vector.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Add(Single[],Int32,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Add Method

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Definition

Visual Basic Public Shared Sub Add( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal vectorA As GraphicsStream, _
ByVal vectorB As GraphicsStream _
)
C# public static void Add(
float[] output,
int order,
GraphicsStream vectorA,
GraphicsStream vectorB
);
C++ public:
static void Add(
array<float>^ output,
int order,
GraphicsStream^ vectorA,
GraphicsStream^ vectorB
);
JScript public static function Add(
output : float[],
order : int,
vectorA : GraphicsStream,
vectorB : GraphicsStream
);

Parameters

output System.Single[]
An array of floating point values that represent the output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the first SH vector to add to the second vector.
vectorB Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the second SH vector to add to the first vector.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Add(GraphicsStream,Int32,Single[],Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Add Method

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Definition

Visual Basic Public Shared Sub Add( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal vectorA() As Single, _
ByVal vectorB() As Single _
)
C# public static void Add(
GraphicsStream output,
int order,
float[] vectorA,
float[] vectorB
);
C++ public:
static void Add(
GraphicsStream^ output,
int order,
array<float>^ vectorA,
array<float>^ vectorB
);
JScript public static function Add(
output : GraphicsStream,
order : int,
vectorA : float[],
vectorB : float[]
);

Parameters

output Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA System.Single[]
An array of floating point values that represent the first SH vector to add to the second vector.
vectorB System.Single[]
An array of floating point values that represent the second SH vector to add to the first vector.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Add(GraphicsStream,Int32,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Add Method

Adds two spherical harmonic (SH) vectors together; in other words, Out[i] = A[i] + B[i].

Definition

Visual Basic Public Shared Sub Add( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal vectorA As GraphicsStream, _
ByVal vectorB As GraphicsStream _
)
C# public static void Add(
GraphicsStream output,
int order,
GraphicsStream vectorA,
GraphicsStream vectorB
);
C++ public:
static void Add(
GraphicsStream^ output,
int order,
GraphicsStream^ vectorA,
GraphicsStream^ vectorB
);
JScript public static function Add(
output : GraphicsStream,
order : int,
vectorA : GraphicsStream,
vectorB : GraphicsStream
);

Parameters

output Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the first SH vector to add to the second vector.
vectorB Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the second SH vector to add to the first vector.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Dot Method ()

Computes the dot product of two spherical harmonic (SH) vectors.

Overload List

public static float Dot(int, GraphicsStream, GraphicsStream);
public static float Dot(int, float[], float[]);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Dot(Int32,Single[],Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Dot Method

Computes the dot product of two spherical harmonic (SH) vectors.

Definition

Visual Basic Public Shared Function Dot( _
ByVal order As Integer, _
ByVal vectorA() As Single, _
ByVal vectorB() As Single _
) As Single
C# public static float Dot(
int order,
float[] vectorA,
float[] vectorB
);
C++ public:
static float Dot(
int order,
array<float>^ vectorA,
array<float>^ vectorB
);
JScript public static function Dot(
order : int,
vectorA : float[],
vectorB : float[]
) : float;

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA System.Single[]
An array of floating point values that represent the first SH vector.
vectorB System.Single[]
An array of floating point values that represent the second SH vector.

Return Value

System.Single
A floating point value that represents the dot product of the two vectors.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Dot(Int32,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Dot Method

Computes the dot product of two spherical harmonic (SH) vectors.

Definition

Visual Basic Public Shared Function Dot( _
ByVal order As Integer, _
ByVal vectorA As GraphicsStream, _
ByVal vectorB As GraphicsStream _
) As Single
C# public static float Dot(
int order,
GraphicsStream vectorA,
GraphicsStream vectorB
);
C++ public:
static float Dot(
int order,
GraphicsStream^ vectorA,
GraphicsStream^ vectorB
);
JScript public static function Dot(
order : int,
vectorA : GraphicsStream,
vectorB : GraphicsStream
) : float;

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
vectorA Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the first SH vector.
vectorB Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the second SH vector.

Return Value

System.Single
A floating point value that represents the dot product of the two vectors.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.EvaluateConeLight Method ()

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data.

Overload List

public static void EvaluateConeLight(int, Vector3, float, float, float, float, GraphicsStream, GraphicsStream, GraphicsStream);
public static void EvaluateConeLight(int, Vector3, float, float, float, float, float[], float[], float[]);

Remarks

Evaluates a light that is a cone of constant intensity and returns spectral SH data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the exit radiance of a point directly under the light (oriented in the cone direction on a diffuse object with an albedo of 1) would be 1.0. This will compute 3 spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateConeLight(Int32,Vector3,Single,Single,Single,Single,Single[],Single[],Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateConeLight Method

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic Public Shared Sub EvaluateConeLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal radius As Single, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void EvaluateConeLight(
int order,
Vector3 direction,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
C++ public:
static void EvaluateConeLight(
int order,
Vector3 direction,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
array<float>^ redOutput,
array<float>^ greenOutput,
array<float>^ blueOutput
);
JScript public static function EvaluateConeLight(
order : int,
direction : Vector3,
radius : float,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction Microsoft.DirectX.Vector3
The (x, y, z) hemisphere axis direction vector in which to evaluate the SH basis functions. See Remarks.
radius System.Single
Radius of the light cone in radians.
redIntensity System.Single
The red intensity of the light.
greenIntensity System.Single
The green intensity of the light.
blueIntensity System.Single
The blue intensity of the light.
redOutput System.Single[]
Output SH vector for the red component.
greenOutput System.Single[]
Output SH vector for the green component.
blueOutput System.Single[]
Output SH vector for the red component.

Remarks

Evaluates a light that is a cone of constant intensity and returns spectral SH data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the exit radiance of a point directly under the light (oriented in the cone direction on a diffuse object with an albedo of 1) would be 1.0. This will compute 3 spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateConeLight(Int32,Vector3,Single,Single,Single,Single,GraphicsStream,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateConeLight Method

Evaluates a light that is a cone of constant intensity and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic Public Shared Sub EvaluateConeLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal radius As Single, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void EvaluateConeLight(
int order,
Vector3 direction,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
C++ public:
static void EvaluateConeLight(
int order,
Vector3 direction,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream^ redOutput,
GraphicsStream^ greenOutput,
GraphicsStream^ blueOutput
);
JScript public static function EvaluateConeLight(
order : int,
direction : Vector3,
radius : float,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction Microsoft.DirectX.Vector3
The (x, y, z) hemisphere axis direction vector in which to evaluate the SH basis functions. See Remarks.
radius System.Single
Radius of the light cone in radians.
redIntensity System.Single
The red intensity of the light.
greenIntensity System.Single
The green intensity of the light.
blueIntensity System.Single
The blue intensity of the light.
redOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.
greenOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the green component.
blueOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.

Remarks

Evaluates a light that is a cone of constant intensity and returns spectral SH data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the exit radiance of a point directly under the light (oriented in the cone direction on a diffuse object with an albedo of 1) would be 1.0. This will compute 3 spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateDirection Method ()

Evaluates the spherical harmonic (SH) basis functions from an input direction vector.

Overload List

public static void EvaluateDirection(GraphicsStream, int, Vector3);
public static void EvaluateDirection(float[], int, Vector3);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations


SphericalHarmonics.EvaluateDirection(Single[],Int32,Vector3) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateDirection Method

Evaluates the spherical harmonic (SH) basis functions from an input direction vector.

Definition

Visual Basic Public Shared Sub EvaluateDirection( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal direction As Vector3 _
)
C# public static void EvaluateDirection(
float[] output,
int order,
Vector3 direction
);
C++ public:
static void EvaluateDirection(
array<float>^ output,
int order,
Vector3 direction
);
JScript public static function EvaluateDirection(
output : float[],
order : int,
direction : Vector3
);

Parameters

output System.Single[]
SH output coefficients. The basis function Ylm is stored at location l2 + m + l.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction Microsoft.DirectX.Vector3
(x, y, z) direction vector in which to evaluate the SH basis functions. Must be normalized. See Remarks.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations


SphericalHarmonics.EvaluateDirection(GraphicsStream,Int32,Vector3) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateDirection Method

Evaluates the spherical harmonic (SH) basis functions from an input direction vector.

Definition

Visual Basic Public Shared Sub EvaluateDirection( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal direction As Vector3 _
)
C# public static void EvaluateDirection(
GraphicsStream output,
int order,
Vector3 direction
);
C++ public:
static void EvaluateDirection(
GraphicsStream^ output,
int order,
Vector3 direction
);
JScript public static function EvaluateDirection(
output : GraphicsStream,
order : int,
direction : Vector3
);

Parameters

output Microsoft.DirectX.GraphicsStream
SH output coefficients. The basis function Ylm is stored at location l2 + m + l.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction Microsoft.DirectX.Vector3
(x, y, z) direction vector in which to evaluate the SH basis functions. Must be normalized. See Remarks.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations


SphericalHarmonics.EvaluateDirectionalLight Method ()

Evaluates a directional light and returns spectral spherical harmonic (SH) data.

Overload List

public static void EvaluateDirectionalLight(int, Vector3, float, float, float, GraphicsStream, GraphicsStream, GraphicsStream);
public static void EvaluateDirectionalLight(int, Vector3, float, float, float, float[], float[], float[]);

Remarks

Evaluates a directional light and returns spectral SH data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the resulting exit radiance of a point directly under the light on a diffuse object with an albedo of 1 would be 1.0. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateDirectionalLight(Int32,Vector3,Single,Single,Single,Single[],Single[],Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateDirectionalLight Method

Evaluates a directional light and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic Public Shared Sub EvaluateDirectionalLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void EvaluateDirectionalLight(
int order,
Vector3 direction,
float redIntensity,
float greenIntensity,
float blueIntensity,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
C++ public:
static void EvaluateDirectionalLight(
int order,
Vector3 direction,
float redIntensity,
float greenIntensity,
float blueIntensity,
array<float>^ redOutput,
array<float>^ greenOutput,
array<float>^ blueOutput
);
JScript public static function EvaluateDirectionalLight(
order : int,
direction : Vector3,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction Microsoft.DirectX.Vector3
The (x, y, z) hemisphere axis direction vector in which to evaluate the SH basis functions. See Remarks.
redIntensity System.Single
The red intensity of the light.
greenIntensity System.Single
The green intensity of the light.
blueIntensity System.Single
The blue intensity of the light.
redOutput System.Single[]
Output SH vector for the red component.
greenOutput System.Single[]
Output SH vector for the green component.
blueOutput System.Single[]
Output SH vector for the red component.

Remarks

Evaluates a directional light and returns spectral SH data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the resulting exit radiance of a point directly under the light on a diffuse object with an albedo of 1 would be 1.0. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateDirectionalLight(Int32,Vector3,Single,Single,Single,GraphicsStream,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateDirectionalLight Method

Evaluates a directional light and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic Public Shared Sub EvaluateDirectionalLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void EvaluateDirectionalLight(
int order,
Vector3 direction,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
C++ public:
static void EvaluateDirectionalLight(
int order,
Vector3 direction,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream^ redOutput,
GraphicsStream^ greenOutput,
GraphicsStream^ blueOutput
);
JScript public static function EvaluateDirectionalLight(
order : int,
direction : Vector3,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction Microsoft.DirectX.Vector3
The (x, y, z) hemisphere axis direction vector in which to evaluate the SH basis functions. See Remarks.
redIntensity System.Single
The red intensity of the light.
greenIntensity System.Single
The green intensity of the light.
blueIntensity System.Single
The blue intensity of the light.
redOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.
greenOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the green component.
blueOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.

Remarks

Evaluates a directional light and returns spectral SH data. The output vector is computed so that if the intensity ratio R/G/B is equal to 1, the resulting exit radiance of a point directly under the light on a diffuse object with an albedo of 1 would be 1.0. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateHemisphereLight Method ()

Evaluates a light that is a linear interpolation between two colors over the sphere.

Overload List

public static void EvaluateHemisphereLight(int, Vector3, ColorValue, ColorValue, GraphicsStream, GraphicsStream, GraphicsStream);
public static void EvaluateHemisphereLight(int, Vector3, ColorValue, ColorValue, float[], float[], float[]);

Remarks

The interpolation is done linearly between the two points, not over the surface of the sphere (that is, if the axis were (0,0,1), it is linear in Z, not in the azimuthal angle). The resulting spherical lighting function is normalized so that a point on a perfectly diffuse surface with no shadowing and a normal pointed towards direction would result in exit radiance with a value of 1 (if the top color were white and the bottom color were black). This is a very simple model where top represents the intensity of the "sky" and bottom represents the intensity of the "ground".

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateHemisphereLight(Int32,Vector3,ColorValue,ColorValue,Single[],Single[],Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateHemisphereLight Method

Evaluates a light that is a linear interpolation between two colors over the sphere.

Definition

Visual Basic Public Shared Sub EvaluateHemisphereLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal top As ColorValue, _
ByVal bottom As ColorValue, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void EvaluateHemisphereLight(
int order,
Vector3 direction,
ColorValue top,
ColorValue bottom,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
C++ public:
static void EvaluateHemisphereLight(
int order,
Vector3 direction,
ColorValue top,
ColorValue bottom,
array<float>^ redOutput,
array<float>^ greenOutput,
array<float>^ blueOutput
);
JScript public static function EvaluateHemisphereLight(
order : int,
direction : Vector3,
top : ColorValue,
bottom : ColorValue,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order System.Int32
Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction Microsoft.DirectX.Vector3
The (x, y, z) hemisphere axis direction vector in which to evaluate the SH basis functions. See Remarks.
top Microsoft.DirectX.Direct3D.ColorValue
The sky color.
bottom Microsoft.DirectX.Direct3D.ColorValue
The ground color.
redOutput System.Single[]
Output SH vector for the red component.
greenOutput System.Single[]
Output SH vector for the green component.
blueOutput System.Single[]
Output SH vector for the red component.

Remarks

The interpolation is done linearly between the two points, not over the surface of the sphere (that is, if the axis were (0,0,1), it is linear in Z, not in the azimuthal angle). The resulting spherical lighting function is normalized so that a point on a perfectly diffuse surface with no shadowing and a normal pointed towards direction would result in exit radiance with a value of 1 (if the top color were white and the bottom color were black). This is a very simple model where top represents the intensity of the "sky" and bottom represents the intensity of the "ground".

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateHemisphereLight(Int32,Vector3,ColorValue,ColorValue,GraphicsStream,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateHemisphereLight Method

Evaluates a light that is a linear interpolation between two colors over the sphere.

Definition

Visual Basic Public Shared Sub EvaluateHemisphereLight( _
ByVal order As Integer, _
ByVal direction As Vector3, _
ByVal top As ColorValue, _
ByVal bottom As ColorValue, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void EvaluateHemisphereLight(
int order,
Vector3 direction,
ColorValue top,
ColorValue bottom,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
C++ public:
static void EvaluateHemisphereLight(
int order,
Vector3 direction,
ColorValue top,
ColorValue bottom,
GraphicsStream^ redOutput,
GraphicsStream^ greenOutput,
GraphicsStream^ blueOutput
);
JScript public static function EvaluateHemisphereLight(
order : int,
direction : Vector3,
top : ColorValue,
bottom : ColorValue,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order System.Int32
Order of the spherical harmonic (SH) evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
direction Microsoft.DirectX.Vector3
The (x, y, z) hemisphere axis direction vector in which to evaluate the SH basis functions. See Remarks.
top Microsoft.DirectX.Direct3D.ColorValue
The sky color.
bottom Microsoft.DirectX.Direct3D.ColorValue
The ground color.
redOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.
greenOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the green component.
blueOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.

Remarks

The interpolation is done linearly between the two points, not over the surface of the sphere (that is, if the axis were (0,0,1), it is linear in Z, not in the azimuthal angle). The resulting spherical lighting function is normalized so that a point on a perfectly diffuse surface with no shadowing and a normal pointed towards direction would result in exit radiance with a value of 1 (if the top color were white and the bottom color were black). This is a very simple model where top represents the intensity of the "sky" and bottom represents the intensity of the "ground".

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateSphericalLight Method ()

Evaluates a spherical light and returns spectral spherical harmonic (SH) data.

Overload List

public static void EvaluateSphericalLight(int, Vector3, float, float, float, float, GraphicsStream, GraphicsStream, GraphicsStream);
public static void EvaluateSphericalLight(int, Vector3, float, float, float, float, float[], float[], float[]);

Remarks

Evaluates a spherical light and returns spectral SH data. There is no normalization of the intensity of the light like there is for directional lights, so care has to be taken when specifying the intensities. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateSphericalLight(Int32,Vector3,Single,Single,Single,Single,Single[],Single[],Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateSphericalLight Method

Evaluates a spherical light and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic Public Shared Sub EvaluateSphericalLight( _
ByVal order As Integer, _
ByVal position As Vector3, _
ByVal radius As Single, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void EvaluateSphericalLight(
int order,
Vector3 position,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
C++ public:
static void EvaluateSphericalLight(
int order,
Vector3 position,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
array<float>^ redOutput,
array<float>^ greenOutput,
array<float>^ blueOutput
);
JScript public static function EvaluateSphericalLight(
order : int,
position : Vector3,
radius : float,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
position Microsoft.DirectX.Vector3
The (x, y, z) hemisphere axis direction vector in which to evaluate the SH basis functions. See Remarks.
radius System.Single
Radius of the spherical light source.
redIntensity System.Single
The red intensity of the light.
greenIntensity System.Single
The green intensity of the light.
blueIntensity System.Single
The blue intensity of the light.
redOutput System.Single[]
Output SH vector for the red component.
greenOutput System.Single[]
Output SH vector for the green component.
blueOutput System.Single[]
Output SH vector for the red component.

Remarks

Evaluates a spherical light and returns spectral SH data. There is no normalization of the intensity of the light like there is for directional lights, so care has to be taken when specifying the intensities. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.EvaluateSphericalLight(Int32,Vector3,Single,Single,Single,Single,GraphicsStream,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.EvaluateSphericalLight Method

Evaluates a spherical light and returns spectral spherical harmonic (SH) data.

Definition

Visual Basic Public Shared Sub EvaluateSphericalLight( _
ByVal order As Integer, _
ByVal position As Vector3, _
ByVal radius As Single, _
ByVal redIntensity As Single, _
ByVal greenIntensity As Single, _
ByVal blueIntensity As Single, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void EvaluateSphericalLight(
int order,
Vector3 position,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
C++ public:
static void EvaluateSphericalLight(
int order,
Vector3 position,
float radius,
float redIntensity,
float greenIntensity,
float blueIntensity,
GraphicsStream^ redOutput,
GraphicsStream^ greenOutput,
GraphicsStream^ blueOutput
);
JScript public static function EvaluateSphericalLight(
order : int,
position : Vector3,
radius : float,
redIntensity : float,
greenIntensity : float,
blueIntensity : float,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
position Microsoft.DirectX.Vector3
The (x, y, z) hemisphere axis direction vector in which to evaluate the SH basis functions. See Remarks.
radius System.Single
Radius of the spherical light source.
redIntensity System.Single
The red intensity of the light.
greenIntensity System.Single
The green intensity of the light.
blueIntensity System.Single
The blue intensity of the light.
redOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.
greenOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the green component.
blueOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.

Remarks

Evaluates a spherical light and returns spectral SH data. There is no normalization of the intensity of the light like there is for directional lights, so care has to be taken when specifying the intensities. This will compute three spectral samples; redOutput will be returned, while greenOutput and blueOutput may be returned.

On the sphere with unit radius as shown, direction can be specified simply with theta, the angle about the z-axis in the right-handed direction, and phi, the angle from z.

The following equations show the relationship between Cartesian (x, y, z) and spherical (theta, phi) coordinates on the unit sphere. The angle theta varies over the range of 0 to 2 pi, while phi varies from 0 to pi.

Spherical coordinates equations

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.ProjectCubeMap Method ()

Projects a function represented on a cube map into spherical harmonics (SH).

Overload List

public static void ProjectCubeMap(int, CubeTexture, GraphicsStream, GraphicsStream, GraphicsStream);
public static void ProjectCubeMap(int, CubeTexture, float[], float[], float[]);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.ProjectCubeMap(Int32,CubeTexture,Single[],Single[],Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.ProjectCubeMap Method

Projects a function represented on a cube map into spherical harmonics (SH).

Definition

Visual Basic Public Shared Sub ProjectCubeMap( _
ByVal order As Integer, _
ByVal cubeMap As CubeTexture, _
ByVal redOutput() As Single, _
ByVal greenOutput() As Single, _
ByVal blueOutput() As Single _
)
C# public static void ProjectCubeMap(
int order,
CubeTexture cubeMap,
float[] redOutput,
float[] greenOutput,
float[] blueOutput
);
C++ public:
static void ProjectCubeMap(
int order,
CubeTexture^ cubeMap,
array<float>^ redOutput,
array<float>^ greenOutput,
array<float>^ blueOutput
);
JScript public static function ProjectCubeMap(
order : int,
cubeMap : CubeTexture,
redOutput : float[],
greenOutput : float[],
blueOutput : float[]
);

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
cubeMap Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object used as the source cube map.
redOutput System.Single[]
Output SH vector for the red component.
greenOutput System.Single[]
Output SH vector for the green component.
blueOutput System.Single[]
Output SH vector for the red component.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.ProjectCubeMap(Int32,CubeTexture,GraphicsStream,GraphicsStream,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.ProjectCubeMap Method

Projects a function represented on a cube map into spherical harmonics (SH).

Definition

Visual Basic Public Shared Sub ProjectCubeMap( _
ByVal order As Integer, _
ByVal cubeMap As CubeTexture, _
ByVal redOutput As GraphicsStream, _
ByVal greenOutput As GraphicsStream, _
ByVal blueOutput As GraphicsStream _
)
C# public static void ProjectCubeMap(
int order,
CubeTexture cubeMap,
GraphicsStream redOutput,
GraphicsStream greenOutput,
GraphicsStream blueOutput
);
C++ public:
static void ProjectCubeMap(
int order,
CubeTexture^ cubeMap,
GraphicsStream^ redOutput,
GraphicsStream^ greenOutput,
GraphicsStream^ blueOutput
);
JScript public static function ProjectCubeMap(
order : int,
cubeMap : CubeTexture,
redOutput : GraphicsStream,
greenOutput : GraphicsStream,
blueOutput : GraphicsStream
);

Parameters

order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
cubeMap Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object used as the source cube map.
redOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.
greenOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the green component.
blueOutput Microsoft.DirectX.GraphicsStream
Output SH vector for the blue component.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SphericalHarmonics.Rotate Method ()

Rotates the spherical harmonic (SH) vector by the given matrix.

Overload List

public static void Rotate(GraphicsStream, int, Matrix, GraphicsStream);
public static void Rotate(GraphicsStream, int, Matrix, float[]);
public static void Rotate(float[], int, Matrix, GraphicsStream);
public static void Rotate(float[], int, Matrix, float[]);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Rotate(Single[],Int32,Matrix,Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Rotate Method

Rotates the spherical harmonic (SH) vector by the given matrix.

Definition

Visual Basic Public Shared Sub Rotate( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal rotation As Matrix, _
ByVal input() As Single _
)
C# public static void Rotate(
float[] output,
int order,
Matrix rotation,
float[] input
);
C++ public:
static void Rotate(
array<float>^ output,
int order,
Matrix rotation,
array<float>^ input
);
JScript public static function Rotate(
output : float[],
order : int,
rotation : Matrix,
input : float[]
);

Parameters

output System.Single[]
An array of floating point values that represent SH output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
rotation Microsoft.DirectX.Matrix
The rotation Matrix. The rotation sub-matrix must be orthogonal, with a unit determinant.
input System.Single[]
An array of floating point values that represent rotated SH coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Rotate(Single[],Int32,Matrix,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Rotate Method

Rotates the spherical harmonic (SH) vector by the given matrix.

Definition

Visual Basic Public Shared Sub Rotate( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal rotation As Matrix, _
ByVal input As GraphicsStream _
)
C# public static void Rotate(
float[] output,
int order,
Matrix rotation,
GraphicsStream input
);
C++ public:
static void Rotate(
array<float>^ output,
int order,
Matrix rotation,
GraphicsStream^ input
);
JScript public static function Rotate(
output : float[],
order : int,
rotation : Matrix,
input : GraphicsStream
);

Parameters

output System.Single[]
An array of floating point values that represent SH output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
rotation Microsoft.DirectX.Matrix
The rotation Matrix. The rotation sub-matrix must be orthogonal, with a unit determinant.
input Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents rotated SH coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Rotate(GraphicsStream,Int32,Matrix,Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Rotate Method

Rotates the spherical harmonic (SH) vector by the given matrix.

Definition

Visual Basic Public Shared Sub Rotate( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal rotation As Matrix, _
ByVal input() As Single _
)
C# public static void Rotate(
GraphicsStream output,
int order,
Matrix rotation,
float[] input
);
C++ public:
static void Rotate(
GraphicsStream^ output,
int order,
Matrix rotation,
array<float>^ input
);
JScript public static function Rotate(
output : GraphicsStream,
order : int,
rotation : Matrix,
input : float[]
);

Parameters

output Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents SH output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
rotation Microsoft.DirectX.Matrix
The rotation Matrix. The rotation sub-matrix must be orthogonal, with a unit determinant.
input System.Single[]
An array of floating point values that represent rotated SH coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Rotate(GraphicsStream,Int32,Matrix,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Rotate Method

Rotates the spherical harmonic (SH) vector by the given matrix.

Definition

Visual Basic Public Shared Sub Rotate( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal rotation As Matrix, _
ByVal input As GraphicsStream _
)
C# public static void Rotate(
GraphicsStream output,
int order,
Matrix rotation,
GraphicsStream input
);
C++ public:
static void Rotate(
GraphicsStream^ output,
int order,
Matrix rotation,
GraphicsStream^ input
);
JScript public static function Rotate(
output : GraphicsStream,
order : int,
rotation : Matrix,
input : GraphicsStream
);

Parameters

output Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents SH output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
rotation Microsoft.DirectX.Matrix
The rotation Matrix. The rotation sub-matrix must be orthogonal, with a unit determinant.
input Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents rotated SH coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ Method ()

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Overload List

public static void RotateZ(GraphicsStream, int, float, GraphicsStream);
public static void RotateZ(GraphicsStream, int, float, float[]);
public static void RotateZ(float[], int, float, GraphicsStream);
public static void RotateZ(float[], int, float, float[]);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ(Single[],Int32,Single,Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.RotateZ Method

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Definition

Visual Basic Public Shared Sub RotateZ( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal angle As Single, _
ByVal input() As Single _
)
C# public static void RotateZ(
float[] output,
int order,
float angle,
float[] input
);
C++ public:
static void RotateZ(
array<float>^ output,
int order,
float angle,
array<float>^ input
);
JScript public static function RotateZ(
output : float[],
order : int,
angle : float,
input : float[]
);

Parameters

output System.Single[]
An array of floating point values that represent SH output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
angle System.Single
Rotation angle in radians. The rotation is performed around the z-axis.
input System.Single[]
An array of floating point values that represent rotated SH coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ(Single[],Int32,Single,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.RotateZ Method

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Definition

Visual Basic Public Shared Sub RotateZ( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal angle As Single, _
ByVal input As GraphicsStream _
)
C# public static void RotateZ(
float[] output,
int order,
float angle,
GraphicsStream input
);
C++ public:
static void RotateZ(
array<float>^ output,
int order,
float angle,
GraphicsStream^ input
);
JScript public static function RotateZ(
output : float[],
order : int,
angle : float,
input : GraphicsStream
);

Parameters

output System.Single[]
An array of floating point values that represent SH output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
angle System.Single
Rotation angle in radians. The rotation is performed around the z-axis.
input Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents rotated SH coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ(GraphicsStream,Int32,Single,Single[]) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.RotateZ Method

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Definition

Visual Basic Public Shared Sub RotateZ( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal angle As Single, _
ByVal input() As Single _
)
C# public static void RotateZ(
GraphicsStream output,
int order,
float angle,
float[] input
);
C++ public:
static void RotateZ(
GraphicsStream^ output,
int order,
float angle,
array<float>^ input
);
JScript public static function RotateZ(
output : GraphicsStream,
order : int,
angle : float,
input : float[]
);

Parameters

output Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents SH output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
angle System.Single
Rotation angle in radians. The rotation is performed around the z-axis.
input System.Single[]
An array of floating point values that represent rotated SH coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.RotateZ(GraphicsStream,Int32,Single,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.RotateZ Method

Rotates the spherical harmonic (SH) vector in the z-axis by the given angle.

Definition

Visual Basic Public Shared Sub RotateZ( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal angle As Single, _
ByVal input As GraphicsStream _
)
C# public static void RotateZ(
GraphicsStream output,
int order,
float angle,
GraphicsStream input
);
C++ public:
static void RotateZ(
GraphicsStream^ output,
int order,
float angle,
GraphicsStream^ input
);
JScript public static function RotateZ(
output : GraphicsStream,
order : int,
angle : float,
input : GraphicsStream
);

Parameters

output Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents SH output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
angle System.Single
Rotation angle in radians. The rotation is performed around the z-axis.
input Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents rotated SH coefficients.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale Method ()

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Overload List

public static void Scale(GraphicsStream, int, GraphicsStream, float);
public static void Scale(GraphicsStream, int, float[], float);
public static void Scale(float[], int, GraphicsStream, float);
public static void Scale(float[], int, float[], float);

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale(Single[],Int32,Single[],Single) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Scale Method

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Definition

Visual Basic Public Shared Sub Scale( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal input() As Single, _
ByVal scaleFactor As Single _
)
C# public static void Scale(
float[] output,
int order,
float[] input,
float scaleFactor
);
C++ public:
static void Scale(
array<float>^ output,
int order,
array<float>^ input,
float scaleFactor
);
JScript public static function Scale(
output : float[],
order : int,
input : float[],
scaleFactor : float
);

Parameters

output System.Single[]
An array of floating point values that represent spherical harmonic (SH) output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
input System.Single[]
An array of floating point values that represents the SH vector to scale.
scaleFactor System.Single
The scale value.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale(Single[],Int32,GraphicsStream,Single) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Scale Method

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Definition

Visual Basic Public Shared Sub Scale( _
ByVal output() As Single, _
ByVal order As Integer, _
ByVal input As GraphicsStream, _
ByVal scaleFactor As Single _
)
C# public static void Scale(
float[] output,
int order,
GraphicsStream input,
float scaleFactor
);
C++ public:
static void Scale(
array<float>^ output,
int order,
GraphicsStream^ input,
float scaleFactor
);
JScript public static function Scale(
output : float[],
order : int,
input : GraphicsStream,
scaleFactor : float
);

Parameters

output System.Single[]
An array of floating point values that represent spherical harmonic (SH) output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
input Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the SH vector to scale.
scaleFactor System.Single
The scale value.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale(GraphicsStream,Int32,Single[],Single) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Scale Method

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Definition

Visual Basic Public Shared Sub Scale( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal input() As Single, _
ByVal scaleFactor As Single _
)
C# public static void Scale(
GraphicsStream output,
int order,
float[] input,
float scaleFactor
);
C++ public:
static void Scale(
GraphicsStream^ output,
int order,
array<float>^ input,
float scaleFactor
);
JScript public static function Scale(
output : GraphicsStream,
order : int,
input : float[],
scaleFactor : float
);

Parameters

output Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents spherical harmonic (SH) output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
input System.Single[]
An array of floating point values that represents the SH vector to scale.
scaleFactor System.Single
The scale value.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.Scale(GraphicsStream,Int32,GraphicsStream,Single) Method (Microsoft.DirectX.Direct3D)

SphericalHarmonics.Scale Method

Scales a spherical harmonic (SH) vector, in other words, Out[i] = A[i] * Scale.

Definition

Visual Basic Public Shared Sub Scale( _
ByVal output As GraphicsStream, _
ByVal order As Integer, _
ByVal input As GraphicsStream, _
ByVal scaleFactor As Single _
)
C# public static void Scale(
GraphicsStream output,
int order,
GraphicsStream input,
float scaleFactor
);
C++ public:
static void Scale(
GraphicsStream^ output,
int order,
GraphicsStream^ input,
float scaleFactor
);
JScript public static function Scale(
output : GraphicsStream,
order : int,
input : GraphicsStream,
scaleFactor : float
);

Parameters

output Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents spherical harmonic (SH) output coefficients.
order System.Int32
Order of the SH evaluation. Must be in the range of SphericalHarmonics.MinimumOrder to SphericalHarmonics.MaximumOrder, inclusive. The evaluation generates order2 coefficients. The degree of the evaluation is order - 1.
input Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the SH vector to scale.
scaleFactor System.Single
The scale value.

Remarks

Each coefficient of the basis function Ylm is stored at location l2 + m + l, where:

  • l is the degree of the basis function.
  • m is the basis function index for the given l value and ranges from -l to l, inclusive.


SphericalHarmonics.MaximumOrder Field (Microsoft.DirectX.Direct3D)

SphericalHarmonics.MaximumOrder Field

Retrieves the maximum order for spherical harmonic (SH) evaluation.

Definition

Visual Basic | Public Shared MaximumOrder As Int32
C# | public static Int32 MaximumOrder;
C++ | public: static Int32 MaximumOrder;
JScript | public static var MaximumOrder : Int32

Field Value

System.Int32
Returns the maximum order for SH evaluation; which is 6.

This field is read-only.

Remarks

The maximum order for SH evaluation is 6 to maintain the mathematical complexity at a manageable level.


SphericalHarmonics.MinimumOrder Field (Microsoft.DirectX.Direct3D)

SphericalHarmonics.MinimumOrder Field

Retrieves the minimum order for spherical harmonic (SH) evaluation.

Definition

Visual Basic | Public Shared MinimumOrder As Int32
C# | public static Int32 MinimumOrder;
C++ | public: static Int32 MinimumOrder;
JScript | public static var MinimumOrder : Int32

Field Value

System.Int32
Returns the minimum order for SH evaluation, which is 2.

This field is read-only.

Remarks

The lowest minimum order for SH evaluation is 2 because anything less than that would have no effect.


Sprite Class (Microsoft.DirectX.Direct3D)

Sprite Class

Provides methods and properties that simplify the process of drawing sprites using Microsoft Direct3D.

Definition

Visual Basic NotInheritable Public Class Sprite
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class Sprite : MarshalByRefObject, IDisposable
C++ | public ref class Sprite sealed : MarshalByRefObject, IDisposable
JScript | public final class Sprite extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Sprite object is finalized and collected by the garbage collector of the .NET common language runtime.
Lost | Occurs when an object is lost, normally immediately prior to a device reset.
Reset | Occurs after the Sprite.OnResetDevice method is called or after the Device is reset.

Methods

Method | Description
Begin | Prepares a device for drawing sprites.
Dispose | Immediately releases the unmanaged resources used by the Sprite object.
Draw | Adds a sprite to the list of batched sprites.
Draw2D | Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.
End | Restores the device to the state it was in before Sprite.Begin was called.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Sprite object to free resources before it is destroyed by the garbage collector.
Flush | Forces all batched sprites to be submitted to the device.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
OnLostDevice | Releases all references to video memory resources and deletes all state blocks.
OnResetDevice | Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Sprite.Disposing event when called from within a derived class.
raise_Lost | Raises a Sprite.Lost event when called from within a derived class.
raise_Reset | Raises a Sprite.Reset event when called from within a derived class.
SetWorldViewLH Sets the left-handed world-view transform for a sprite.

A call to this method is required before billboarding or sorting sprites.
SetWorldViewRH Sets the right-handed world-view transform for a sprite.

A call to this method is required before billboarding or sorting sprites.
Sprite | Initializes a new instance of the Sprite class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Sprite object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the Direct3D device associated with a sprite object.
Disposed | Gets a value that indicates whether the object is disposed.
Transform | Retrieves or sets a Matrix object.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXSprite interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Sprite

Remarks

Typically, the application first calls Sprite.Begin, which allows control over the device render state, alpha blending, and sprite transformation and sorting. Then, for each sprite to display, the application calls Sprite.Draw, which can be called repeatedly to store any number of sprites. To display the batched sprites to the device, the application calls Sprite.End or Sprite.Flush.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Sprite.Begin(SpriteFlags) Method (Microsoft.DirectX.Direct3D)

Sprite.Begin Method

How Do I...?
  • Draw A Sprite

Prepares a device for drawing sprites.

Definition

Visual Basic Public Sub Begin( _
ByVal flags As SpriteFlags _
)
C# public void Begin(
SpriteFlags flags
);
C++ public:
void Begin(
SpriteFlags flags
);
JScript public function Begin(
flags : SpriteFlags
);

Parameters

flags Microsoft.DirectX.Direct3D.SpriteFlags
Combination of zero or more values from the SpriteFlags enumeration that describe sprite rendering options.

Remarks

This method must be called from inside of a Device.BeginScene . . . Device.EndScene pair. Sprite.Begin cannot be used as a substitute for either Device.BeginScene or RenderToSurface.BeginScene.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.End


Sprite.Dispose() Method (Microsoft.DirectX.Direct3D)

Sprite.Dispose Method

Immediately releases the unmanaged resources used by the Sprite object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Sprite();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Sprite.Disposed
  • Microsoft.DirectX.Direct3D.Sprite.Disposing


Sprite.Draw Method ()

Adds a sprite to the list of batched sprites.

Overload List

public void Draw(Texture, Rectangle, Vector3, Vector3, Color);
public void Draw(Texture, Rectangle, Vector3, Vector3, int);
public void Draw(Texture, Rectangle, Vector3, Vector3, int);
public void Draw(Texture, Vector3, Vector3, int);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Sprite.Draw2D


Sprite.Draw(Texture,Rectangle,Vector3,Vector3,Color) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw Method

Adds a sprite to the list of batched sprites.

Definition

Visual Basic Public Sub Draw( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal center As Vector3, _
ByVal position As Vector3, _
ByVal color As Color _
)
C# public void Draw(
Texture srcTexture,
Rectangle srcRectangle,
Vector3 center,
Vector3 position,
Color color
);
C++ public:
void Draw(
Texture^ srcTexture,
Rectangle srcRectangle,
Vector3 center,
Vector3 position,
Color color
);
JScript public function Draw(
srcTexture : Texture,
srcRectangle : Rectangle,
center : Vector3,
position : Vector3,
color : Color
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
center Microsoft.DirectX.Vector3
A Vector3 structure that identifies the center of the sprite. A value of (0,0,0) indicates the upper-left corner.
position Microsoft.DirectX.Vector3
A Vector3 structure that identifies the position of the sprite. A value of (0,0,0) indicates the upper-left corner.
color System.Drawing.Color
A Color Leave Site structure. The color and alpha channels are modulated by this value. The Color.Transparent Leave Site value maintains the original source color and alpha data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Sprite.Draw2D


Sprite.Draw(Texture,Vector3,Vector3,Int32) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw Method

Adds a sprite to the list of batched sprites.

Definition

Visual Basic Public Sub Draw( _
ByVal srcTexture As Texture, _
ByVal center As Vector3, _
ByVal position As Vector3, _
ByVal color As Integer _
)
C# public void Draw(
Texture srcTexture,
Vector3 center,
Vector3 position,
int color
);
C++ public:
void Draw(
Texture^ srcTexture,
Vector3 center,
Vector3 position,
int color
);
JScript public function Draw(
srcTexture : Texture,
center : Vector3,
position : Vector3,
color : int
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
center Microsoft.DirectX.Vector3
A Vector3 structure that identifies the center of the sprite. A value of (0,0,0) indicates the upper-left corner.
position Microsoft.DirectX.Vector3
A Vector3 structure that identifies the position of the sprite. A value of (0,0,0) indicates the upper-left corner.
color System.Int32
Color value represented as an integer. The color and alpha channels are modulated by this value. A value of 16777215 maintains the original source color and alpha data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Sprite.Draw2D


Sprite.Draw(Texture,Rectangle,Vector3,Vector3,Int32) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw Method

Adds a sprite to the list of batched sprites.

Definition

Visual Basic Public Sub Draw( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal center As Vector3, _
ByVal position As Vector3, _
ByVal color As Integer _
)
C# public void Draw(
Texture srcTexture,
Rectangle srcRectangle,
Vector3 center,
Vector3 position,
int color
);
C++ public:
void Draw(
Texture^ srcTexture,
Rectangle srcRectangle,
Vector3 center,
Vector3 position,
int color
);
JScript public function Draw(
srcTexture : Texture,
srcRectangle : Rectangle,
center : Vector3,
position : Vector3,
color : int
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
center Microsoft.DirectX.Vector3
A Vector3 structure that identifies the center of the sprite. A value of (0,0,0) indicates the upper-left corner.
position Microsoft.DirectX.Vector3
A Vector3 structure that identifies the position of the sprite. A value of (0,0,0) indicates the upper-left corner.
color System.Int32
Color value represented as an integer. The color and alpha channels are modulated by this value. A value of 16777215 maintains the original source color and alpha data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • Sprite.Draw2D


Sprite.Draw2D Method ()

How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.

Overload List

public void Draw2D(Texture, Point, float, Point, Color);
public void Draw2D(Texture, Point, float, Point, int);
public void Draw2D(Texture, Rectangle, Rectangle, Point, Color);
public void Draw2D(Texture, Rectangle, Rectangle, Point, int);
public void Draw2D(Texture, Rectangle, Rectangle, Point, float, Point, Color);
public void Draw2D(Texture, Rectangle, Rectangle, Point, float, Point, int);
public void Draw2D(Texture, Rectangle, Rectangle, Point, float, Point, int);

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Draw


Sprite.Draw2D(Texture,Point,Single,Point,Color) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw2D Method

How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.

Definition

Visual Basic Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal rotationCenter As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Color _
)
C# public void Draw2D(
Texture srcTexture,
Point rotationCenter,
float rotationAngle,
Point position,
Color color
);
C++ public:
void Draw2D(
Texture^ srcTexture,
Point rotationCenter,
float rotationAngle,
Point position,
Color color
);
JScript public function Draw2D(
srcTexture : Texture,
rotationCenter : Point,
rotationAngle : float,
position : Point,
color : Color
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
rotationCenter System.Drawing.Point
A Point Leave Site object that represents the sprite's rotational center.
rotationAngle System.Single
A floating point value that specifies the rotation angle around the rotational center of the sprite.
position System.Drawing.Point
A Point Leave Site object that represents the position of the sprite in 2-D-space.
color System.Drawing.Color
A Color Leave Site structure. The color and alpha channels are modulated by this value. The Color.Transparent Leave Site value maintains the original source color and alpha data.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Draw


Sprite.Draw2D(Texture,Point,Single,Point,Int32) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw2D Method

How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.

Definition

Visual Basic Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal rotationCenter As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Integer _
)
C# public void Draw2D(
Texture srcTexture,
Point rotationCenter,
float rotationAngle,
Point position,
int color
);
C++ public:
void Draw2D(
Texture^ srcTexture,
Point rotationCenter,
float rotationAngle,
Point position,
int color
);
JScript public function Draw2D(
srcTexture : Texture,
rotationCenter : Point,
rotationAngle : float,
position : Point,
color : int
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
rotationCenter System.Drawing.Point
A Point Leave Site object that represents the sprite's rotational center.
rotationAngle System.Single
A floating point value that specifies the rotation angle around the rotational center of the sprite.
position System.Drawing.Point
A Point Leave Site object that represents the position of the sprite in 2-D-space.
color System.Int32
Color value represented as an integer.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Draw


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Single,Point,Color) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw2D Method

How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.

Definition

Visual Basic Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal rotationCenter As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Color _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point rotationCenter,
float rotationAngle,
Point position,
Color color
);
C++ public:
void Draw2D(
Texture^ srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point rotationCenter,
float rotationAngle,
Point position,
Color color
);
JScript public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
rotationCenter : Point,
rotationAngle : float,
position : Point,
color : Color
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the size of the destination rectangle.
rotationCenter System.Drawing.Point
A Point Leave Site object that represents the sprite's rotational center.
rotationAngle System.Single
A floating point value that specifies the rotation angle around the rotational center of the sprite.
position System.Drawing.Point
A Point Leave Site object that represents the position of the sprite in 2-D-space.
color System.Drawing.Color
A Color Leave Site structure. The color and alpha channels are modulated by this value. The Color.Transparent Leave Site value maintains the original source color and alpha data.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Draw


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Single,Point,Int32) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw2D Method

How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.

Definition

Visual Basic Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal rotationCenter As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Integer _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point rotationCenter,
float rotationAngle,
Point position,
int color
);
C++ public:
void Draw2D(
Texture^ srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point rotationCenter,
float rotationAngle,
Point position,
int color
);
JScript public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
rotationCenter : Point,
rotationAngle : float,
position : Point,
color : int
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the size of the destination rectangle.
rotationCenter System.Drawing.Point
A Point Leave Site object that represents the sprite's rotational center.
rotationAngle System.Single
A floating point value that specifies the rotation angle around the rotational center of the sprite.
position System.Drawing.Point
A Point Leave Site object that represents the position of the sprite in 2-D-space.
color System.Int32
Color value represented as an integer.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Draw


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Color) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw2D Method

How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.

Definition

Visual Basic Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal position As Point, _
ByVal color As Color _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point position,
Color color
);
C++ public:
void Draw2D(
Texture^ srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point position,
Color color
);
JScript public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
position : Point,
color : Color
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the size of the destination rectangle.
position System.Drawing.Point
A Point Leave Site object that represents the position of the sprite in 2-D-space.
color System.Drawing.Color
A Color Leave Site structure. The color and alpha channels are modulated by this value. The Color.Transparent Leave Site value maintains the original source color and alpha data.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Draw


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Int32) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw2D Method

How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.

Definition

Visual Basic Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal position As Point, _
ByVal color As Integer _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point position,
int color
);
C++ public:
void Draw2D(
Texture^ srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point position,
int color
);
JScript public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
position : Point,
color : int
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the size of the destination rectangle.
position System.Drawing.Point
A Point Leave Site object that represents the position of the sprite in 2-D-space.
color System.Int32
Color value represented as an integer.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Draw


Sprite.Draw2D(Texture,Rectangle,Rectangle,Point,Single,Point,Int32) Method (Microsoft.DirectX.Direct3D)

Sprite.Draw2D Method

How Do I...?
  • Draw A Sprite

Adds a sprite to the list of batched sprites. Used for presentation in 2-D space.

Definition

Visual Basic Public Sub Draw2D( _
ByVal srcTexture As Texture, _
ByVal srcRectangle As Rectangle, _
ByVal destinationRectangle As Rectangle, _
ByVal center As Point, _
ByVal rotationAngle As Single, _
ByVal position As Point, _
ByVal color As Integer _
)
C# public void Draw2D(
Texture srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point center,
float rotationAngle,
Point position,
int color
);
C++ public:
void Draw2D(
Texture^ srcTexture,
Rectangle srcRectangle,
Rectangle destinationRectangle,
Point center,
float rotationAngle,
Point position,
int color
);
JScript public function Draw2D(
srcTexture : Texture,
srcRectangle : Rectangle,
destinationRectangle : Rectangle,
center : Point,
rotationAngle : float,
position : Point,
color : int
);

Parameters

srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the sprite texture.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the portion of the source texture to use for the sprite. Specify Rectangle.Empty Leave Site to use the entire source image for the sprite.
destinationRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that indicates the size of the destination rectangle.
center System.Drawing.Point
A Vector3 structure that identifies the center of the sprite. A value of (0,0) indicates the upper-left corner.
rotationAngle System.Single
A floating point value that specifies the rotation angle around the rotational center of the sprite.
position System.Drawing.Point
A Point Leave Site object that represents the position of the sprite in 2-D-space.
color System.Int32
Color value represented as an integer.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Draw


Sprite.End() Method (Microsoft.DirectX.Direct3D)

Sprite.End Method

How Do I...?
  • Draw A Sprite

Restores the device to the state it was in before Sprite.Begin was called.

Definition

Visual Basic | Public Sub End()
C# | public void End();
C++ public:
void End();
JScript | public function End();

Remarks

Sprite.End cannot be used as a substitute for either Device.EndScene or RenderToSurface.EndScene.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Draw A Sprite

This example demonstrates how to draw a sprite.

To draw a sprite:

  1. Call Sprite.Begin to prepare the device for drawing sprites.
  2. Call Sprite.Draw2D to render the sprite.
  3. Call Sprite.End to signal the end of this batch of sprites.

In the following C# code example, sprite is assumed to be the rendered Sprite object. The texture variable is a loaded Texture object.

              [C#]

sprite.Begin(SpriteFlags.None);

sprite.Draw2D(texture, Rectangle.Empty, Rectangle.Empty,
              new Point(5.0f, 5.0f), Color.White);
sprite.End();

See Also

  • Sprite.Begin


Sprite.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Sprite.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Sprite.Finalize() Method (Microsoft.DirectX.Direct3D)

Sprite.Finalize Method

Allows the Sprite object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Sprite();
C++ | !Sprite();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Sprite.Flush() Method (Microsoft.DirectX.Direct3D)

Sprite.Flush Method

Forces all batched sprites to be submitted to the device.

Definition

Visual Basic | Public Sub Flush()
C# | public void Flush();
C++ public:
void Flush();
JScript | public function Flush();

Remarks

Device states remain as they were after the last call to Sprite.Begin. The list of batched sprites is then cleared.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Sprite.End


Sprite.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Sprite.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Sprite.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Sprite.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXSprite, which allows unmanaged COM clients to create an instance of the managed Sprite class. Not supported.


Sprite.OnLostDevice() Method (Microsoft.DirectX.Direct3D)

Sprite.OnLostDevice Method

Releases all references to video memory resources and deletes all state blocks.

Definition

Visual Basic | Public Sub OnLostDevice()
C# | public void OnLostDevice();
C++ public:
void OnLostDevice();
JScript | public function OnLostDevice();

Remarks

This method should be called whenever the device is lost. Before the object can be used again, the device must be reset and the Sprite.OnResetDevice method called.


Sprite.OnResetDevice() Method (Microsoft.DirectX.Direct3D)

Sprite.OnResetDevice Method

Should be called after the device is reset and before any other methods are called, if Device.IsUsingEventHandlers is set to false.

Definition

Visual Basic | Public Sub OnResetDevice()
C# | public void OnResetDevice();
C++ public:
void OnResetDevice();
JScript | public function OnResetDevice();

Remarks

Because Device.IsUsingEventHandlers is set to true by default, it is unnecessary to call Sprite.OnResetDevice under normal circumstances. However, if at any point Device.IsUsingEventHandlers is set to false, Sprite.OnResetDevice should be called immediately after the device is reset.


Sprite.op_Equality(Sprite,Sprite) Method (Microsoft.DirectX.Direct3D)

Sprite.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Sprite, _
ByVal right As Sprite _
) As Boolean
C# public static bool op_Equality(
Sprite left,
Sprite right
);
C++ public:
static bool operator==(
Sprite^ left,
Sprite^ right
);
JScript public static function op_Equality(
left : Sprite,
right : Sprite
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Sprite
The Sprite object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Sprite
The Sprite object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Sprite.op_Inequality(Sprite,Sprite) Method (Microsoft.DirectX.Direct3D)

Sprite.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Sprite, _
ByVal right As Sprite _
) As Boolean
C# public static bool op_Inequality(
Sprite left,
Sprite right
);
C++ public:
static bool operator!=(
Sprite^ left,
Sprite^ right
);
JScript public static function op_Inequality(
left : Sprite,
right : Sprite
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Sprite
The Sprite object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Sprite
The Sprite object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Sprite.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Sprite.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Sprite.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Sprite.raise_Lost(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Sprite.raise_Lost Method

Raises a Sprite.Lost event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Lost( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Lost(
object i1,
EventArgs i2
);
C++ protected:
void raise_Lost(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Lost(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Sprite.raise_Reset(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Sprite.raise_Reset Method

Raises a Sprite.Reset event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Reset( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Reset(
object i1,
EventArgs i2
);
C++ protected:
void raise_Reset(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Reset(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


Sprite.SetWorldViewLH(Matrix,Matrix) Method (Microsoft.DirectX.Direct3D)

Sprite.SetWorldViewLH Method

Sets the left-handed world-view transform for a sprite.

A call to this method is required before billboarding or sorting sprites.

Definition

Visual Basic Public Sub SetWorldViewLH( _
ByVal world As Matrix, _
ByVal view As Matrix _
)
C# public void SetWorldViewLH(
Matrix world,
Matrix view
);
C++ public:
void SetWorldViewLH(
Matrix world,
Matrix view
);
JScript public function SetWorldViewLH(
world : Matrix,
view : Matrix
);

Parameters

world Microsoft.DirectX.Matrix
A Matrix object that contains a world transform.
view Microsoft.DirectX.Matrix
A Matrix object that contains a view transform.

Remarks

A call to this method (or to Sprite.SetWorldViewRH) is required if the sprite will be rendered with the Billboard, SortDepthFrontToBack, or SortDepthBackToFront flags parameter in Sprite.Begin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • 3-D Coordinate Systems


Sprite.SetWorldViewRH(Matrix,Matrix) Method (Microsoft.DirectX.Direct3D)

Sprite.SetWorldViewRH Method

Sets the right-handed world-view transform for a sprite.

A call to this method is required before billboarding or sorting sprites.

Definition

Visual Basic Public Sub SetWorldViewRH( _
ByVal world As Matrix, _
ByVal view As Matrix _
)
C# public void SetWorldViewRH(
Matrix world,
Matrix view
);
C++ public:
void SetWorldViewRH(
Matrix world,
Matrix view
);
JScript public function SetWorldViewRH(
world : Matrix,
view : Matrix
);

Parameters

world Microsoft.DirectX.Matrix
A Matrix object that contains a world transform.
view Microsoft.DirectX.Matrix
A Matrix object that contains a view transform.

Remarks

A call to this method (or to Sprite.SetWorldViewLH) is required if the sprite will be rendered with the Billboard, SortDepthFrontToBack, or SortDepthBackToFront flags parameter in Sprite.Begin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • 3-D Coordinate Systems


Sprite.Sprite Constructor ()

Initializes a new instance of the Sprite class.

Overload List

public Sprite(Device);
public Sprite(ID3DXSprite);
public Sprite(IntPtr);


Sprite.Sprite(ID3DXSprite) Constructor (Microsoft.DirectX.Direct3D)

Sprite.Sprite Constructor

Initializes a new instance of the Sprite class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXSprite _
)
C# public Sprite(
ID3DXSprite pUnk
);
C++ public:
Sprite(
ID3DXSprite pUnk
);
JScript public function Sprite(
pUnk : ID3DXSprite
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXSprite
Unmanaged Component Object Model (COM) ID3DXSprite interface pointer.


Sprite.Sprite(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Sprite.Sprite Constructor

Initializes a new instance of the Sprite class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Sprite(
IntPtr unmanagedObject
);
C++ public:
Sprite(
IntPtr unmanagedObject
);
JScript public function Sprite(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXSprite interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Sprite.Sprite(Device) Constructor (Microsoft.DirectX.Direct3D)

Sprite.Sprite Constructor

Initializes a new instance of the Sprite class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device _
)
C# public Sprite(
Device device
);
C++ public:
Sprite(
Device^ device
);
JScript public function Sprite(
device : Device
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to an instance of a Device object.


Sprite.UpdateUnmanagedPointer(ID3DXSprite) Method (Microsoft.DirectX.Direct3D)

Sprite.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Sprite object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXSprite _
)
C# public void UpdateUnmanagedPointer(
ID3DXSprite pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXSprite pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXSprite
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXSprite
Pointer to the ID3DXSprite structure used to update the unmanaged pointer for this Sprite object.


Sprite.Device Property (Microsoft.DirectX.Direct3D)

Sprite.Device Property

Retrieves the Microsoft Direct3D device associated with a sprite object.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
A Device reference that represents the Direct3D device object associated with the sprite object.

This property is read-only.


Sprite.Disposed Property (Microsoft.DirectX.Direct3D)

Sprite.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Sprite.Transform Property (Microsoft.DirectX.Direct3D)

Sprite.Transform Property

Retrieves or sets a Matrix object.

Definition

Visual Basic | Public Property Transform As Matrix
C# | public Matrix Transform { get; set; }
C++ public:
property Matrix Transform {
Matrix get();
void set(Matrix value);
}
JScript public function get Transform() : Matrix
public function set Transform(Matrix);

Property Value

Microsoft.DirectX.Matrix
A Matrix object used to transform a Sprite object.

This property is read/write.

Remarks

The following C# code fragment demonstrates the use of Transform.

              [C#]

using Microsoft.DirectX.Direct3D;

Sprite s = new Sprite(device);
Matrix m = new Matrix();

// Set Sprite.Transform
s.Transform = m;

// Retrieve the matrix
m = s.Transform;

Exceptions
Direct3DXException Occurs if the method fails.


Sprite.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Sprite.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXSprite interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXSprite
C# | public ID3DXSprite UnmanagedComPointer { get; }
C++ public:
property ID3DXSprite UnmanagedComPointer {
ID3DXSprite get();
}
JScript | public function get UnmanagedComPointer() : ID3DXSprite

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXSprite
Unmanaged ID3DXSprite interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Sprite.Disposing Event (Microsoft.DirectX.Direct3D)

Sprite.Disposing Event

Occurs when the Dispose method is called or when the Sprite object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Sprite.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Sprite object indicates whether that object has been disposed.


Sprite.Lost Event (Microsoft.DirectX.Direct3D)

Sprite.Lost Event

Occurs when an object is lost, normally immediately prior to a device reset.

Definition

Visual Basic | Public Event Lost As EventHandler
C# | public event EventHandler Lost;
C++ public:
event EventHandler^ Lost;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Sprite.Lost event, use the following C# code.

[C#]
sprite.Lost += new System.EventHandler(this.LostEventHandler);


Sprite.Reset Event (Microsoft.DirectX.Direct3D)

Sprite.Reset Event

Occurs after the Sprite.OnResetDevice method is called or after the Device is reset.

Definition

Visual Basic | Public Event Reset As EventHandler
C# | public event EventHandler Reset;
C++ public:
event EventHandler^ Reset;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Sprite.OnResetDevice event, use the following C# code.

[C#]
sprite.Reset += new System.EventHandler(this.ResetEventHandler);


StateBlock Class (Microsoft.DirectX.Direct3D)

StateBlock Class

Encapsulates render states.

Definition

Visual Basic NotInheritable Public Class StateBlock
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class StateBlock : MarshalByRefObject, IDisposable
C++ | public ref class StateBlock sealed : MarshalByRefObject, IDisposable
JScript | public final class StateBlock extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the StateBlock object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Apply | Applies the state block to the current device state.
Capture | Captures a device's current state.
Dispose | Immediately releases the unmanaged resources used by the StateBlock object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the StateBlock object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.StateBlock.Disposing event when called from within a derived class.
StateBlock | Initializes a new instance of the StateBlock class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this StateBlock object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the Device associated with a state block.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
StateBlock

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StateBlock.Apply() Method (Microsoft.DirectX.Direct3D)

StateBlock.Apply Method

How Do I...?
  • Record and Apply StateBlocks

Applies the state block to the current device state.

Definition

Visual Basic | Public Sub Apply()
C# | public void Apply();
C++ public:
void Apply();
JScript | public function Apply();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Record and Apply StateBlocks

This example demonstrates how to use state blocks to set and retrieve a device's state.

A StateBlock instance can be used to return a device to a default state. It also can be stored as a member of a class to quickly restore a desired rendering state for that class. A StateBlock is most useful when used to save default device state once a device is created. This allows for rapid restoration of default state when needed during rendering.

To record and apply a state block:

  1. Call Device.BeginStateBlock to begin recording device state.
  2. Tell the device the states and values to record.
  3. Call Device.EndStateBlock to stop recording device state and return a StateBlock instance containing the recorded states.
  4. Capture the device's current state by calling StateBlock.Capture using the previously obtained StateBlock instance.
  5. Do some processing that changes device state.
  6. Restore the device's saved states by calling StateBlock.Apply.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

// begin recording device state
device.BeginStateBlock();

// tell device the states and values to record
device.RenderState.FogStart = 0.3f;
device.RenderState.FogEnd = 100.0f;
device.RenderState.FogColor = Color.Gray;

// stop recording device state
StateBlock sb = device.EndStateBlock();

// save device states recorded above
sb.Capture;

// change device states
device.RenderState.FogStart = 2000.0f;
device.RenderState.FogEnd = 35000.0f;
device.RenderState.FogColor = Color.Yellow;

// render scene w/changed states
device.DrawPrimitives();

// restore device's saved states
sb.Apply();

// render scene w/saved states
device.DrawPrimitives();


StateBlock.Capture() Method (Microsoft.DirectX.Direct3D)

StateBlock.Capture Method

How Do I...?
  • Record and Apply StateBlocks

Captures a device's current state.

Definition

Visual Basic | Public Sub Capture()
C# | public void Capture();
C++ public:
void Capture();
JScript | public function Capture();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Record and Apply StateBlocks

This example demonstrates how to use state blocks to set and retrieve a device's state.

A StateBlock instance can be used to return a device to a default state. It also can be stored as a member of a class to quickly restore a desired rendering state for that class. A StateBlock is most useful when used to save default device state once a device is created. This allows for rapid restoration of default state when needed during rendering.

To record and apply a state block:

  1. Call Device.BeginStateBlock to begin recording device state.
  2. Tell the device the states and values to record.
  3. Call Device.EndStateBlock to stop recording device state and return a StateBlock instance containing the recorded states.
  4. Capture the device's current state by calling StateBlock.Capture using the previously obtained StateBlock instance.
  5. Do some processing that changes device state.
  6. Restore the device's saved states by calling StateBlock.Apply.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

// begin recording device state
device.BeginStateBlock();

// tell device the states and values to record
device.RenderState.FogStart = 0.3f;
device.RenderState.FogEnd = 100.0f;
device.RenderState.FogColor = Color.Gray;

// stop recording device state
StateBlock sb = device.EndStateBlock();

// save device states recorded above
sb.Capture;

// change device states
device.RenderState.FogStart = 2000.0f;
device.RenderState.FogEnd = 35000.0f;
device.RenderState.FogColor = Color.Yellow;

// render scene w/changed states
device.DrawPrimitives();

// restore device's saved states
sb.Apply();

// render scene w/saved states
device.DrawPrimitives();


StateBlock.Dispose() Method (Microsoft.DirectX.Direct3D)

StateBlock.Dispose Method

Immediately releases the unmanaged resources used by the StateBlock object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~StateBlock();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.StateBlock.Disposed
  • Microsoft.DirectX.Direct3D.StateBlock.Disposing


StateBlock.Equals(Object) Method (Microsoft.DirectX.Direct3D)

StateBlock.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


StateBlock.Finalize() Method (Microsoft.DirectX.Direct3D)

StateBlock.Finalize Method

Allows the StateBlock object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~StateBlock();
C++ | !StateBlock();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


StateBlock.GetHashCode() Method (Microsoft.DirectX.Direct3D)

StateBlock.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


StateBlock.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

StateBlock.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DStateBlock9, which allows unmanaged COM clients to create an instance of the managed StateBlock class. Not supported.


StateBlock.op_Equality(StateBlock,StateBlock) Method (Microsoft.DirectX.Direct3D)

StateBlock.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As StateBlock, _
ByVal right As StateBlock _
) As Boolean
C# public static bool op_Equality(
StateBlock left,
StateBlock right
);
C++ public:
static bool operator==(
StateBlock^ left,
StateBlock^ right
);
JScript public static function op_Equality(
left : StateBlock,
right : StateBlock
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.StateBlock
The StateBlock object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.StateBlock
The StateBlock object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


StateBlock.op_Inequality(StateBlock,StateBlock) Method (Microsoft.DirectX.Direct3D)

StateBlock.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As StateBlock, _
ByVal right As StateBlock _
) As Boolean
C# public static bool op_Inequality(
StateBlock left,
StateBlock right
);
C++ public:
static bool operator!=(
StateBlock^ left,
StateBlock^ right
);
JScript public static function op_Inequality(
left : StateBlock,
right : StateBlock
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.StateBlock
The StateBlock object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.StateBlock
The StateBlock object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


StateBlock.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

StateBlock.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.StateBlock.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


StateBlock.StateBlock Constructor ()

Initializes a new instance of the StateBlock class.

Overload List

public StateBlock(Device, StateBlockType);
public StateBlock(IDirect3DStateBlock9);
public StateBlock(IDirect3DStateBlock9, Device);
public StateBlock(IntPtr);


StateBlock.StateBlock(IDirect3DStateBlock9) Constructor (Microsoft.DirectX.Direct3D)

StateBlock.StateBlock Constructor

Initializes a new instance of the StateBlock class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DStateBlock9 _
)
C# public StateBlock(
IDirect3DStateBlock9 pUnk
);
C++ public:
StateBlock(
IDirect3DStateBlock9 pUnk
);
JScript public function StateBlock(
pUnk : IDirect3DStateBlock9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DStateBlock9
Unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface pointer.


StateBlock.StateBlock(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

StateBlock.StateBlock Constructor

Initializes a new instance of the StateBlock class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public StateBlock(
IntPtr unmanagedObject
);
C++ public:
StateBlock(
IntPtr unmanagedObject
);
JScript public function StateBlock(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


StateBlock.StateBlock(IDirect3DStateBlock9,Device) Constructor (Microsoft.DirectX.Direct3D)

StateBlock.StateBlock Constructor

Initializes a new instance of the StateBlock class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DStateBlock9, _
ByVal device As Device _
)
C# public StateBlock(
IDirect3DStateBlock9 lp,
Device device
);
C++ public:
StateBlock(
IDirect3DStateBlock9 lp,
Device^ device
);
JScript public function StateBlock(
lp : IDirect3DStateBlock9,
device : Device
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DStateBlock9
Unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
Reference to the Device associated with the current state block.


StateBlock.StateBlock(Device,StateBlockType) Constructor (Microsoft.DirectX.Direct3D)

StateBlock.StateBlock Constructor

Initializes a new instance of the StateBlock class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal stateBlockType As StateBlockType _
)
C# public StateBlock(
Device device,
StateBlockType stateBlockType
);
C++ public:
StateBlock(
Device^ device,
StateBlockType stateBlockType
);
JScript public function StateBlock(
device : Device,
stateBlockType : StateBlockType
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to the Device associated with the current state block.
stateBlockType Microsoft.DirectX.Direct3D.StateBlockType
Member of the StateBlockType enumeration that specifies the state block type.


StateBlock.UpdateUnmanagedPointer(IDirect3DStateBlock9) Method (Microsoft.DirectX.Direct3D)

StateBlock.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this StateBlock object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DStateBlock9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DStateBlock9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DStateBlock9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DStateBlock9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DStateBlock9
Pointer to the IDirect3DStateBlock9 structure used to update the unmanaged pointer for this StateBlock object.


StateBlock.Device Property (Microsoft.DirectX.Direct3D)

StateBlock.Device Property

Retrieves the Device associated with a state block.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device object associated with the state block.

This property is read-only.


StateBlock.Disposed Property (Microsoft.DirectX.Direct3D)

StateBlock.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


StateBlock.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

StateBlock.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DStateBlock9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DStateBlock9
C# | public IDirect3DStateBlock9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DStateBlock9 UnmanagedComPointer {
IDirect3DStateBlock9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DStateBlock9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DStateBlock9
Unmanaged IDirect3DStateBlock9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


StateBlock.Disposing Event (Microsoft.DirectX.Direct3D)

StateBlock.Disposing Event

Occurs when the Dispose method is called or when the StateBlock object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.StateBlock.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the StateBlock object indicates whether that object has been disposed.


Surface Class (Microsoft.DirectX.Direct3D)

Surface Class

Queries and prepares surfaces.

Definition

Visual Basic NotInheritable Public Class Surface
Inherits Resource
Implements IDisposable
C# | public sealed class Surface : Resource, IDisposable
C++ | public ref class Surface sealed : Resource, IDisposable
JScript | public final class Surface extends Resource implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Surface object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Surface object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object. Inherited from Resource.
Finalize | Allows the Surface object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
static (Shared in Visual Basic) FromBitmap | Creates a surface from a .NET bitmap object.
static (Shared in Visual Basic) FromStream | Creates a surface from a Microsoft .NET stream object.
GetContainer | Provides access to the parent cube texture or texture (mipmap) object.
GetGraphics | Retrieves a device context.
GetHashCode | Returns the hash code for the current instance. Inherited from Resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
LockRectangle | Locks a rectangle on a surface.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Surface.Disposing event when called from within a derived class.
ReleaseGraphics | Releases the device context obtained by calling Surface.GetGraphics.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
Surface | Initializes a new instance of the Surface class.
UnlockRectangle | Unlocks a rectangle on a surface.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Surface object. This method supports the .NET Framework infrastructure and is not intended to be used directly in your code.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.

Properties

Property | Description
Description | Retrieves the description of a surface.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DSurface9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
Surface

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Surface.Dispose() Method (Microsoft.DirectX.Direct3D)

Surface.Dispose Method

Immediately releases the unmanaged resources used by the Surface object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Surface();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Surface.Disposed
  • Microsoft.DirectX.Direct3D.Surface.Disposing


Surface.Finalize() Method (Microsoft.DirectX.Direct3D)

Surface.Finalize Method

Allows the Surface object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Surface();
C++ | !Surface();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Surface.FromBitmap(Device,Bitmap,Pool) Method (Microsoft.DirectX.Direct3D)

Surface.FromBitmap Method

Creates a surface from a Microsoft .NET bitmap object.

Definition

Visual Basic Public Shared Function FromBitmap( _
ByVal device As Device, _
ByVal image As Bitmap, _
ByVal pool As Pool _
) As Surface
C# public static Surface FromBitmap(
Device device,
Bitmap image,
Pool pool
);
C++ public:
static Surface^ FromBitmap(
Device^ device,
Bitmap^ image,
Pool pool
);
JScript public static function FromBitmap(
device : Device,
image : Bitmap,
pool : Pool
) : Surface;

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to the Device associated with the surface.
image System.Drawing.Bitmap
Reference to a Bitmap Leave Site object that contains the bitmap for the surface.
pool Microsoft.DirectX.Direct3D.Pool
A Pool object that defines the memory class of the surface.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the newly created surface.


Surface.FromStream(Device,Stream,Pool) Method (Microsoft.DirectX.Direct3D)

Surface.FromStream Method

Creates a surface from a Microsoft .NET stream object.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal pool As Pool _
) As Surface
C# public static Surface FromStream(
Device device,
Stream data,
Pool pool
);
C++ public:
static Surface^ FromStream(
Device^ device,
Stream^ data,
Pool pool
);
JScript public static function FromStream(
device : Device,
data : Stream,
pool : Pool
) : Surface;

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to the Device associated with the surface.
data System.IO.Stream
Reference to a Stream Leave Site object that contains image data for the surface.
pool Microsoft.DirectX.Direct3D.Pool
A Pool object that defines the memory class of the surface.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the newly created surface.


Surface.GetContainer(Guid) Method (Microsoft.DirectX.Direct3D)

Surface.GetContainer Method

Provides access to the parent cube texture or texture (mipmap) object.

Definition

Visual Basic Public Function GetContainer( _
ByVal interfaceId As Guid _
) As Object
C# public object GetContainer(
Guid interfaceId
);
C++ public:
Object^ GetContainer(
Guid interfaceId
);
JScript public function GetContainer(
interfaceId : Guid
) : Object;

Parameters

interfaceId System.Guid

Return Value

System.Object
An Object Leave Site that represents the newly created container.

Remarks

This method provides access to the parent cube texture or texture mipmap object if the surface is a child level of a cube texture or mipmap. It also can provide access to the parent swap chain if the surface is a back buffer child.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • InterfaceGuid


Surface.GetGraphics() Method (Microsoft.DirectX.Direct3D)

Surface.GetGraphics Method

Retrieves a device context.

Definition

Visual Basic | Public Function GetGraphics() As Graphics
C# | public Graphics GetGraphics();
C++ public:
Graphics^ GetGraphics();
JScript | public function GetGraphics() : Graphics;

Return Value

System.Drawing.Graphics
A Graphics Leave Site object that represents the device context for the surface.

Remarks

The following restrictions apply.

  • The GetGraphics method is valid only on the following formats: Format.R5G6B5, Format.X1R5G5B5, Format.R8G8B8, and Format.X8R8G8B8. Formats that contain alpha are not supported because the Microsoft Windows Graphics Device Interface (GDI) implementations do not have a well-defined behavior on the alpha channel. For more information about formats, see Format.
  • Only one device context per surface can be returned at a time.
  • This method fails if the surface is already locked. It also fails if the surface is a member of a mipmap or cube map, and any other mipmap or cube map member is locked.
  • This method fails on render targets unless they were created as lockable (or, in the case of back buffers, with PresentFlag.LockableBackBuffer).
  • It fails on surfaces created with Pool.Default, unless they are Usage.Dynamic or are lockable render targets.
  • It fails on surfaces created with Pool.Scratch.

When a device context is outstanding on a surface, the application cannot call the following methods.

  • CubeTexture.LockRectangle
  • Device.ColorFill
  • Device.StretchRectangle
  • Device.UpdateSurface
  • Device.UpdateTexture
  • Surface.LockRectangle
  • SwapChain.Present (on a swap chain that contains the surface)
  • Texture.LockRectangle

The GetGraphics method causes an implicit lock; do not retain the device context for later use. Call Surface.ReleaseGraphics to release it.

It is valid to call Surface.GetGraphics and Surface.ReleaseGraphics on levels of a mipmap or cube map; however, these calls are slow to all mip levels except the topmost level, and GDI operations to these mip levels are not accelerated.

The Graphics Leave Site object provides access to Microsoft Win32 and GDI functionality.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.ReleaseGraphics
  • Pool
  • Usage


Surface.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Surface.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DSurface9, which allows unmanaged COM clients to create an instance of the managed Surface class. Not supported.


Surface.LockRectangle Method ()

Locks a rectangle on a surface.

Overload List

public GraphicsStream LockRectangle(LockFlags);
public GraphicsStream LockRectangle(LockFlags, out int);
public GraphicsStream LockRectangle(Rectangle, LockFlags);
public GraphicsStream LockRectangle(Rectangle, LockFlags, out int);
public Array LockRectangle(Type, LockFlags, out int, int[]);
public Array LockRectangle(Type, LockFlags, int[]);
public Array LockRectangle(Type, Rectangle, LockFlags, out int, int[]);
public Array LockRectangle(Type, Rectangle, LockFlags, int[]);

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Rectangle,LockFlags,Int32) Method (Microsoft.DirectX.Direct3D)

Surface.LockRectangle Method

Locks a rectangle on a surface.

Definition

Visual Basic Public Function LockRectangle( _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
Rectangle rect,
LockFlags flags,
out int pitch
);
C++ public:
GraphicsStream^ LockRectangle(
Rectangle rect,
LockFlags flags,
[Out] int% pitch
);
JScript public function LockRectangle(
rect : Rectangle,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

rect System.Drawing.Rectangle
A Rectangle Leave Site object that represents the rectangle to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
A LockFlags object that specifies the type of lock to apply.
pitch System.Int32
Integer that represents the returned pitch value of the locked region.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(LockFlags,Int32) Method (Microsoft.DirectX.Direct3D)

Surface.LockRectangle Method

Locks a rectangle on a surface.

Definition

Visual Basic Public Function LockRectangle( _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
LockFlags flags,
out int pitch
);
C++ public:
GraphicsStream^ LockRectangle(
LockFlags flags,
[Out] int% pitch
);
JScript public function LockRectangle(
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
A LockFlags object that specifies the type of lock to apply.
pitch System.Int32
Integer that represents the returned pitch value of the locked region.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Rectangle,LockFlags) Method (Microsoft.DirectX.Direct3D)

Surface.LockRectangle Method

Locks a rectangle on a surface.

Definition

Visual Basic Public Function LockRectangle( _
ByVal rect As Rectangle, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
Rectangle rect,
LockFlags flags
);
C++ public:
GraphicsStream^ LockRectangle(
Rectangle rect,
LockFlags flags
);
JScript public function LockRectangle(
rect : Rectangle,
flags : LockFlags
) : GraphicsStream;

Parameters

rect System.Drawing.Rectangle
A Rectangle Leave Site object that represents the rectangle to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
A LockFlags object that specifies the type of lock to apply.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(LockFlags) Method (Microsoft.DirectX.Direct3D)

Surface.LockRectangle Method

Locks a rectangle on a surface.

Definition

Visual Basic Public Function LockRectangle( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
LockFlags flags
);
C++ public:
GraphicsStream^ LockRectangle(
LockFlags flags
);
JScript public function LockRectangle(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
A LockFlags object that specifies the type of lock to apply.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Type,Rectangle,LockFlags,Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

Surface.LockRectangle Method

Locks a rectangle on a surface.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
Rectangle rect,
LockFlags flags,
out int pitch,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
Rectangle rect,
LockFlags flags,
[Out] int% pitch,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
rect : Rectangle,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that specifies the type of array to create.
rect System.Drawing.Rectangle
A Rectangle Leave Site object that represents the rectangle to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
A LockFlags object that specifies the type of lock to apply.
pitch System.Int32
Integer that represents the returned pitch value of the locked region.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Type,LockFlags,Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

Surface.LockRectangle Method

Locks a rectangle on a surface.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
LockFlags flags,
out int pitch,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
LockFlags flags,
[Out] int% pitch,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that specifies the type of array to create.
flags Microsoft.DirectX.Direct3D.LockFlags
A LockFlags object that specifies the type of lock to apply.
pitch System.Int32
Integer that represents the returned pitch value of the locked region.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Type,Rectangle,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

Surface.LockRectangle Method

Locks a rectangle on a surface.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
Rectangle rect,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
Rectangle rect,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
rect : Rectangle,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that specifies the type of array to create.
rect System.Drawing.Rectangle
A Rectangle Leave Site object that represents the rectangle to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
A LockFlags object that specifies the type of lock to apply.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.LockRectangle(Type,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

Surface.LockRectangle Method

Locks a rectangle on a surface.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that specifies the type of array to create.
flags Microsoft.DirectX.Direct3D.LockFlags
A LockFlags object that specifies the type of lock to apply.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site that describes the locked region.

Remarks

If LockFlags.DoNotWait is specified and the driver cannot lock the surface immediately, Surface.LockRectangle throws WasStillDrawingException so that an application can use the CPU cycles while waiting for the driver to lock the surface.

The only lockable format for a depth-stencil surface is Format.D16Lockable.

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Surface.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

A multisample back buffer cannot be locked.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.UnlockRectangle


Surface.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Surface.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Surface.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Surface.ReleaseGraphics() Method (Microsoft.DirectX.Direct3D)

Surface.ReleaseGraphics Method

Releases the device context obtained by calling Surface.GetGraphics.

Definition

Visual Basic | Public Sub ReleaseGraphics()
C# | public void ReleaseGraphics();
C++ public:
void ReleaseGraphics();
JScript | public function ReleaseGraphics();

Remarks

A device context is a Microsoft Windows resource and must be released after use so the operating system can return it to the pool of available resources.

This method releases only the device context returned by Surface.GetGraphics, otherwise the method fails.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Surface.GetGraphics


Surface.Surface Constructor ()

Initializes a new instance of the Surface class.

Overload List

public Surface(Device, Bitmap, Pool);
public Surface(Device, Stream, Pool);
public Surface(IDirect3DSurface9);
public Surface(IDirect3DSurface9, object);
public Surface(IntPtr);


Surface.Surface(IDirect3DSurface9) Constructor (Microsoft.DirectX.Direct3D)

Surface.Surface Constructor

Initializes a new instance of the Surface class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As IDirect3DSurface9 _
)
C# public Surface(
IDirect3DSurface9 pInterop
);
C++ public:
Surface(
IDirect3DSurface9 pInterop
);
JScript public function Surface(
pInterop : IDirect3DSurface9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSurface9
Unmanaged Component Object Model (COM) IDirect3DSurface9 interface pointer.


Surface.Surface(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Surface.Surface Constructor

Initializes a new instance of the Surface class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Surface(
IntPtr unmanagedObject
);
C++ public:
Surface(
IntPtr unmanagedObject
);
JScript public function Surface(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DSurface9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Surface.Surface(IDirect3DSurface9,Object) Constructor (Microsoft.DirectX.Direct3D)

Surface.Surface Constructor

Initializes a new instance of the Surface class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DSurface9, _
ByVal device As Object _
)
C# public Surface(
IDirect3DSurface9 lp,
object device
);
C++ public:
Surface(
IDirect3DSurface9 lp,
Object^ device
);
JScript public function Surface(
lp : IDirect3DSurface9,
device : Object
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSurface9
Unmanaged Component Object Model (COM) IDirect3DSurface9 interface pointer.
device System.Object
Object reference of the device associated with the surface.


Surface.Surface(Device,Stream,Pool) Constructor (Microsoft.DirectX.Direct3D)

Surface.Surface Constructor

Initializes a new instance of the Surface class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal pool As Pool _
)
C# public Surface(
Device device,
Stream data,
Pool pool
);
C++ public:
Surface(
Device^ device,
Stream^ data,
Pool pool
);
JScript public function Surface(
device : Device,
data : Stream,
pool : Pool
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to the Device associated with the surface.
data System.IO.Stream
Reference to a Stream Leave Site object that contains image data for the surface.
pool Microsoft.DirectX.Direct3D.Pool
A Pool object that defines the memory class of the surface.


Surface.Surface(Device,Bitmap,Pool) Constructor (Microsoft.DirectX.Direct3D)

Surface.Surface Constructor

Initializes a new instance of the Surface class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal image As Bitmap, _
ByVal pool As Pool _
)
C# public Surface(
Device device,
Bitmap image,
Pool pool
);
C++ public:
Surface(
Device^ device,
Bitmap^ image,
Pool pool
);
JScript public function Surface(
device : Device,
image : Bitmap,
pool : Pool
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to the Device associated with the surface.
image System.Drawing.Bitmap
Reference to a Bitmap Leave Site object that contains the bitmap for the surface.
pool Microsoft.DirectX.Direct3D.Pool
A Pool object that defines the memory class of the surface.


Surface.UnlockRectangle() Method (Microsoft.DirectX.Direct3D)

Surface.UnlockRectangle Method

Unlocks a rectangle on a surface.

Definition

Visual Basic | Public Sub UnlockRectangle()
C# | public void UnlockRectangle();
C++ public:
void UnlockRectangle();
JScript | public function UnlockRectangle();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Surface.UpdateUnmanagedPointer(IDirect3DSurface9) Method (Microsoft.DirectX.Direct3D)

Surface.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Surface object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DSurface9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DSurface9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DSurface9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DSurface9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSurface9
Pointer to the IDirect3DSurface9 structure used to update the unmanaged pointer for this Surface object.


Surface.Description Property (Microsoft.DirectX.Direct3D)

Surface.Description Property

Retrieves the description of a surface.

Definition

Visual Basic | Public ReadOnly Property Description As SurfaceDescription
C# | public SurfaceDescription Description { get; }
C++ public:
property SurfaceDescription Description {
SurfaceDescription get();
}
JScript | public function get Description() : SurfaceDescription

Property Value

Microsoft.DirectX.Direct3D.SurfaceDescription
A SurfaceDescription object that contains the surface description.

This property is read-only.


Surface.Disposed Property (Microsoft.DirectX.Direct3D)

Surface.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Surface.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Surface.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DSurface9 interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As IDirect3DSurface9
C# | public IDirect3DSurface9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DSurface9 UnmanagedComPointer {
IDirect3DSurface9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DSurface9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSurface9
Unmanaged IDirect3DSurface9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Surface.Disposing Event (Microsoft.DirectX.Direct3D)

Surface.Disposing Event

Occurs when the Dispose method is called or when the Surface object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Surface.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Surface object indicates whether that object has been disposed.


SurfaceLoader Class (Microsoft.DirectX.Direct3D)

SurfaceLoader Class

Loads and saves surfaces.

Definition

Visual Basic NotInheritable MustInherit Public Class SurfaceLoader
Inherits Object
C# | public abstract sealed class SurfaceLoader : Object
C++ | public ref class SurfaceLoader abstract sealed : Object
JScript | public final abstract class SurfaceLoader extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) FromFile | Loads a surface from a file.
static (Shared in Visual Basic) FromStream | Loads a surface from a stream.
static (Shared in Visual Basic) FromSurface | Loads a surface from another surface with color conversion.
static (Shared in Visual Basic) Save | Saves a surface to a file.
static (Shared in Visual Basic) SaveToStream | Saves a surface to a stream.

Inheritance Hierarchy

Object Leave Site
SurfaceLoader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfaceLoader.FromFile Method ()

Loads a surface from a file.

Overload List

public static void FromFile(Surface, out PaletteEntry, Rectangle, string, Filter, int);
public static void FromFile(Surface, out PaletteEntry, Rectangle, string, Filter, int, ref ImageInformation);
public static void FromFile(Surface, out PaletteEntry, Rectangle, string, Rectangle, Filter, int);
public static void FromFile(Surface, out PaletteEntry, Rectangle, string, Rectangle, Filter, int, ref ImageInformation);
public static void FromFile(Surface, out PaletteEntry, string, Filter, int);
public static void FromFile(Surface, out PaletteEntry, string, Filter, int, ref ImageInformation);
public static void FromFile(Surface, out PaletteEntry, string, Rectangle, Filter, int);
public static void FromFile(Surface, out PaletteEntry, string, Rectangle, Filter, int, ref ImageInformation);
public static void FromFile(Surface, Rectangle, string, Rectangle, Filter, int);
public static void FromFile(Surface, Rectangle, string, Rectangle, Filter, int, ref ImageInformation);
public static void FromFile(Surface, string, Filter, int);
public static void FromFile(Surface, string, Filter, int, ref ImageInformation);
public static void FromFile(Surface, string, Rectangle, Filter, int);
public static void FromFile(Surface, string, Rectangle, Filter, int, ref ImageInformation);

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,Rectangle,String,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
Rectangle destRectangle,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Surface^ destSurface,
Rectangle destRectangle,
String^ srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destSurface : Surface,
destRectangle : Rectangle,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcFile System.String
String that contains the source file name.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,Rectangle,String,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
Rectangle destRectangle,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Surface^ destSurface,
Rectangle destRectangle,
String^ srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destSurface : Surface,
destRectangle : Rectangle,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcFile System.String
String that contains the source file name.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,String,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Surface^ destSurface,
String^ srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destSurface : Surface,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
srcFile System.String
String that contains the source file name.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,String,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Surface^ destSurface,
String^ srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destSurface : Surface,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
srcFile System.String
String that contains the source file name.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,String,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
String^ srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
srcFile System.String
String that contains the source file name.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,String,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
String^ srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
srcFile System.String
String that contains the source file name.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,String,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
string srcFile,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Surface^ destSurface,
String^ srcFile,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destSurface : Surface,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
srcFile System.String
String that contains the source file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,String,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Surface^ destSurface,
String^ srcFile,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destSurface : Surface,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
srcFile System.String
String that contains the source file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,String,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
String^ srcFile,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
srcFile System.String
String that contains the source file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,Rectangle,String,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
String^ srcFile,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcFile System.String
String that contains the source file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,String,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
string srcFile,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
String^ srcFile,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
srcFile System.String
String that contains the source file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,Rectangle,String,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
string srcFile,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
String^ srcFile,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcFile System.String
String that contains the source file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,Rectangle,String,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
String^ srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcFile System.String
String that contains the source file name.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromFile(Surface,PaletteEntry,Rectangle,String,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromFile Method

Loads a surface from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcFile As String, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
string srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
String^ srcFile,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcFile : String,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcFile System.String
String that contains the source file name.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromFile is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream Method ()

Loads a surface from a stream.

Overload List

public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, int, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, int, Rectangle, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, int, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, Rectangle, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Rectangle, Stream, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Stream, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Stream, int, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Stream, int, Rectangle, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Stream, int, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, out PaletteEntry, Stream, Rectangle, Filter, int);
public static void FromStream(Surface, out PaletteEntry, Stream, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Rectangle, Stream, int, Rectangle, Filter, int);
public static void FromStream(Surface, Rectangle, Stream, int, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Rectangle, Stream, Rectangle, Filter, int);
public static void FromStream(Surface, Rectangle, Stream, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Stream, Filter, int);
public static void FromStream(Surface, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Stream, int, Filter, int);
public static void FromStream(Surface, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Stream, int, Rectangle, Filter, int);
public static void FromStream(Surface, Stream, int, Rectangle, Filter, int, ref ImageInformation);
public static void FromStream(Surface, Stream, Rectangle, Filter, int);
public static void FromStream(Surface, Stream, Rectangle, Filter, int, ref ImageInformation);

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Rectangle,Stream,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Rectangle destRectangle,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
Rectangle destRectangle,
Stream^ stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destRectangle : Rectangle,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Rectangle,Stream,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Rectangle destRectangle,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
Rectangle destRectangle,
Stream^ stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destRectangle : Rectangle,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
Stream^ stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
Stream^ stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Stream^ stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Stream^ stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
Stream^ stream,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
Stream^ stream,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Stream^ stream,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Stream^ stream,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Stream^ stream,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Stream^ stream,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Stream^ stream,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Stream^ stream,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Rectangle,Stream,Int32,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Rectangle destRectangle,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
Rectangle destRectangle,
Stream^ stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Rectangle,Stream,Int32,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Rectangle destRectangle,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
Rectangle destRectangle,
Stream^ stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Int32,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
Stream^ stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Int32,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
Stream^ stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Int32,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Stream^ stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Int32,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Stream^ stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Int32,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,Stream,Int32,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Int32,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Int32,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Stream,Int32,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Int32,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Int32,Rectangle,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Stream^ stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[ref] An ImageInformation structure that represents the source image information.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromStream(Surface,PaletteEntry,Rectangle,Stream,Int32,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromStream Method

Loads a surface from a stream.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Stream stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Stream^ stream,
int readBytes,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
stream : Stream,
readBytes : int,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
stream System.IO.Stream
A Stream Leave Site object that contains the source surface data.
readBytes System.Int32
Size, in bytes, of the stream data in memory.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

This method handles conversion to and from compressed texture formats and supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. For more information, see ImageFileFormat.

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromStream is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


SurfaceLoader.FromSurface Method ()

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Overload List

public static void FromSurface(Surface, out PaletteEntry, Rectangle, Surface, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Rectangle, Surface, out PaletteEntry, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Rectangle, Surface, out PaletteEntry, Rectangle, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Rectangle, Surface, Rectangle, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Surface, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Surface, out PaletteEntry, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Surface, out PaletteEntry, Rectangle, Filter, int);
public static void FromSurface(Surface, out PaletteEntry, Surface, Rectangle, Filter, int);
public static void FromSurface(Surface, Rectangle, Surface, Filter, int);
public static void FromSurface(Surface, Rectangle, Surface, out PaletteEntry, Filter, int);
public static void FromSurface(Surface, Rectangle, Surface, out PaletteEntry, Rectangle, Filter, int);
public static void FromSurface(Surface, Rectangle, Surface, Rectangle, Filter, int);
public static void FromSurface(Surface, Surface, Filter, int);
public static void FromSurface(Surface, Surface, out PaletteEntry, Filter, int);
public static void FromSurface(Surface, Surface, out PaletteEntry, Rectangle, Filter, int);
public static void FromSurface(Surface, Surface, Rectangle, Filter, int);

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Rectangle,Surface,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Rectangle destRectangle,
Surface srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
Rectangle destRectangle,
Surface^ srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destRectangle : Rectangle,
srcSurface : Surface,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Surface,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Surface srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
Surface^ srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
srcSurface : Surface,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Surface,PaletteEntry,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Surface srcSurface,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
srcSurface : Surface,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Rectangle,Surface,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Rectangle destRectangle,
Surface srcSurface,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
Rectangle destRectangle,
Surface^ srcSurface,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destRectangle : Rectangle,
srcSurface : Surface,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Surface,PaletteEntry,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Surface srcSurface,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
srcSurface : Surface,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Surface,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcSurface As Surface, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Surface srcSurface,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Surface^ srcSurface,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
srcSurface : Surface,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Surface,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal srcSurface As Surface, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Surface srcSurface,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
Surface^ srcSurface,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
srcSurface : Surface,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Rectangle,Surface,PaletteEntry,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Rectangle destRectangle,
Surface srcSurface,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
Rectangle destRectangle,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destRectangle : Rectangle,
srcSurface : Surface,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Surface,PaletteEntry,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Surface,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Surface srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Surface^ srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
srcSurface : Surface,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Rectangle,Surface,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Surface srcSurface,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Surface^ srcSurface,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcSurface : Surface,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,Rectangle,Surface,PaletteEntry,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
Rectangle destRectangle,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
Rectangle destRectangle,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destRectangle : Rectangle,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Surface,PaletteEntry,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Rectangle,Surface,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Surface srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Surface^ srcSurface,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcSurface : Surface,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Rectangle,Surface,PaletteEntry,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Surface srcSurface,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcSurface : Surface,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.FromSurface(Surface,PaletteEntry,Rectangle,Surface,PaletteEntry,Rectangle,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.FromSurface Method

How Do I...?
  • Copy a Texture

Loads a surface from another surface with color conversion.

Definition

Visual Basic Public Shared Sub FromSurface( _
ByVal destSurface As Surface, _
ByRef destPalette As PaletteEntry, _
ByVal destRectangle As Rectangle, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromSurface(
Surface destSurface,
out PaletteEntry destPalette,
Rectangle destRectangle,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
C++ public:
static void FromSurface(
Surface^ destSurface,
[Out] PaletteEntry% destPalette,
Rectangle destRectangle,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Rectangle srcRectangle,
Filter filter,
int colorKey
);
JScript public static function FromSurface(
destSurface : Surface,
destPalette : PaletteEntry,
destRectangle : Rectangle,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle,
filter : Filter,
colorKey : int
);

Parameters

destSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the destination surface.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the destination palette entries.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the destination rectangle.
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.
filter Microsoft.DirectX.Direct3D.Filter
One or more members of the Filter enumeration that control how the image is filtered.
colorKey System.Int32
Integer value that represents the color to replace with transparent black, or 0 to disable the colorKey. This value is always a 32-bit ARGB color, regardless of the source image format. alpha is significant and should usually be set to 0xFF for opaque color keys. Thus, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to a surface level other than zero does not cause the dirty rectangle to be updated. If SurfaceLoader.FromSurface is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRect on the surface.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

How Do I...?

Copy a Texture

This example demonstrates how to copy a texture.

A texture is loaded from a file and duplicated, and all of its AliceBlue color is replaced with transparent black. An area that is ten pixels square from the top right corner of the texture is copied.

In the following C# code example, device is assumed to be the rendering Device, and FlagColorsInverted.bmp is assumed to be in the current directory.

              [C#]

using Microsoft.DirectX.Direct3D;
using System.Drawing;

Surface s = null;

PaletteEntry[] pal = new PaletteEntry[256];

// Set up the surface for our surface loader.
s = device.CreateOffscreenPlainSurface(32, 32, Format.A8R8G8B8,	Pool.Default);

Surface k = TextureLoader.FromFile(device,
                          "FlagColorsInverted.bmp").GetSurfaceLevel(0);

SurfaceLoader.FromSurface(s, out pal, new Rectangle(0,0,9,9), k, out pal,
               new Rectangle(0,0,9,9), Filter.Box, Color.AliceBlue.ToArgb());


SurfaceLoader.Save Method ()

How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Overload List

public static void Save(string, ImageFileFormat, Surface);
public static void Save(string, ImageFileFormat, Surface, out PaletteEntry);
public static void Save(string, ImageFileFormat, Surface, out PaletteEntry, Rectangle);
public static void Save(string, ImageFileFormat, Surface, Rectangle);

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.Save(String,ImageFileFormat,Surface) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.Save Method

How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Surface srcSurface
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
Surface^ srcSurface
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcSurface : Surface
);

Parameters

destFile System.String
String that contains the destination file name.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat object that specifies the file format to use when saving the surface to a file. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface to save to a file.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.Save(String,ImageFileFormat,Surface,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.Save Method

How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Surface srcSurface,
out PaletteEntry sourcePalette
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcSurface : Surface,
sourcePalette : PaletteEntry
);

Parameters

destFile System.String
String that contains the destination file name.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat object that specifies the file format to use when saving the surface to a file. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface to save to a file.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.Save(String,ImageFileFormat,Surface,Rectangle) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.Save Method

How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Surface srcSurface,
Rectangle srcRectangle
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
Surface^ srcSurface,
Rectangle srcRectangle
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcSurface : Surface,
srcRectangle : Rectangle
);

Parameters

destFile System.String
String that contains the destination file name.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat object that specifies the file format to use when saving the surface to a file. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface to save to a file.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.Save(String,ImageFileFormat,Surface,PaletteEntry,Rectangle) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.Save Method

How Do I...?
  • Save a Screenshot

Saves a surface to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Rectangle srcRectangle
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle
);

Parameters

destFile System.String
String that contains the destination file name.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat object that specifies the file format to use when saving the surface to a file. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface to save to a file.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Save a Screenshot

This example demonstrates how to save a screen shot to a file.

The back buffer is retrieved and saved as a bitmap image.

In the following C# code example, device is assumed to be the rendering Device. This code is called after rendering is complete.

              [C#]

using Microsoft.DirectX.Direct3D;

Surface backbuffer = device.GetBackBuffer(0, 0, BackBufferType.Mono);
SurfaceLoader.Save("Screenshot.bmp", ImageFileFormat.Bmp, backbuffer);
backbuffer.Dispose();


SurfaceLoader.SaveToStream Method ()

Saves a surface to a stream.

Overload List

public static GraphicsStream SaveToStream(ImageFileFormat, Surface);
public static GraphicsStream SaveToStream(ImageFileFormat, Surface, out PaletteEntry);
public static GraphicsStream SaveToStream(ImageFileFormat, Surface, out PaletteEntry, Rectangle);
public static GraphicsStream SaveToStream(ImageFileFormat, Surface, Rectangle);

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SurfaceLoader.SaveToStream(ImageFileFormat,Surface) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.SaveToStream Method

Saves a surface to a stream.

Definition

Visual Basic Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
Surface srcSurface
);
C++ public:
static GraphicsStream^ SaveToStream(
ImageFileFormat destFormat,
Surface^ srcSurface
);
JScript public static function SaveToStream(
destFormat : ImageFileFormat,
srcSurface : Surface
) : GraphicsStream;

Parameters

destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat object that specifies the file format to use when saving the surface to a stream. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface to save to a file.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the saved surface data.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SurfaceLoader.SaveToStream(ImageFileFormat,Surface,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.SaveToStream Method

Saves a surface to a stream.

Definition

Visual Basic Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
Surface srcSurface,
out PaletteEntry sourcePalette
);
C++ public:
static GraphicsStream^ SaveToStream(
ImageFileFormat destFormat,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette
);
JScript public static function SaveToStream(
destFormat : ImageFileFormat,
srcSurface : Surface,
sourcePalette : PaletteEntry
) : GraphicsStream;

Parameters

destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat object that specifies the file format to use when saving the surface to a stream. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface to save to a file.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the saved surface data.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SurfaceLoader.SaveToStream(ImageFileFormat,Surface,Rectangle) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.SaveToStream Method

Saves a surface to a stream.

Definition

Visual Basic Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByVal srcRectangle As Rectangle _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
Surface srcSurface,
Rectangle srcRectangle
);
C++ public:
static GraphicsStream^ SaveToStream(
ImageFileFormat destFormat,
Surface^ srcSurface,
Rectangle srcRectangle
);
JScript public static function SaveToStream(
destFormat : ImageFileFormat,
srcSurface : Surface,
srcRectangle : Rectangle
) : GraphicsStream;

Parameters

destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat object that specifies the file format to use when saving the surface to a stream. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface to save to a file.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the saved surface data.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SurfaceLoader.SaveToStream(ImageFileFormat,Surface,PaletteEntry,Rectangle) Method (Microsoft.DirectX.Direct3D)

SurfaceLoader.SaveToStream Method

Saves a surface to a stream.

Definition

Visual Basic Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcSurface As Surface, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcRectangle As Rectangle _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
Surface srcSurface,
out PaletteEntry sourcePalette,
Rectangle srcRectangle
);
C++ public:
static GraphicsStream^ SaveToStream(
ImageFileFormat destFormat,
Surface^ srcSurface,
[Out] PaletteEntry% sourcePalette,
Rectangle srcRectangle
);
JScript public static function SaveToStream(
destFormat : ImageFileFormat,
srcSurface : Surface,
sourcePalette : PaletteEntry,
srcRectangle : Rectangle
) : GraphicsStream;

Parameters

destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat object that specifies the file format to use when saving the surface to a stream. This method supports saving to all ImageFileFormat types except Portable Pixmap (.ppm) and Targa/Truevision Graphics Adapter (.tga).
srcSurface Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the source surface to save to a file.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry array that contains the source palette entries.
srcRectangle System.Drawing.Rectangle
A Rectangle Leave Site object that represents the source rectangle.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the saved surface data.

Remarks

This method handles conversion to and from compressed texture formats.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SwapChain Class (Microsoft.DirectX.Direct3D)

SwapChain Class

How Do I...?
  • Create an Additional Swap Chain

Manipulates a swap chain.

Definition

Visual Basic NotInheritable Public Class SwapChain
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class SwapChain : MarshalByRefObject, IDisposable
C++ | public ref class SwapChain sealed : MarshalByRefObject, IDisposable
JScript | public final class SwapChain extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the SwapChain object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the SwapChain object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the SwapChain object to free resources before it is destroyed by the garbage collector.
GetBackBuffer | Retrieves a back buffer from the swap chain of a device.
GetFrontBufferData | Generates a copy of the swap chain's front buffer and places it in a Surface object provided by the application.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Present | Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.SwapChain.Disposing event when called from within a derived class.
SwapChain | Creates a new instance of the SwapChain class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this SwapChain object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Device | Retrieves the device associated with a swap chain.
DisplayMode | Retrieves the display mode's spatial resolution, color resolution, and refresh frequency.
Disposed | Gets a value that indicates whether the object is disposed.
PresentParameters | Retrieves the presentation parameters associated with a swap chain.
RasterStatus | Returns information that describes the raster of the monitor on which the swap chain is presented.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
SwapChain

Remarks

Each device always has at least one swap chain, which is known as the implicit swap chain. Additional SwapChain objects can be created for rendering multiple views from the same device.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SwapChain.Dispose() Method (Microsoft.DirectX.Direct3D)

SwapChain.Dispose Method

Immediately releases the unmanaged resources used by the SwapChain object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~SwapChain();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.SwapChain.Disposed
  • Microsoft.DirectX.Direct3D.SwapChain.Disposing


SwapChain.Equals(Object) Method (Microsoft.DirectX.Direct3D)

SwapChain.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


SwapChain.Finalize() Method (Microsoft.DirectX.Direct3D)

SwapChain.Finalize Method

Allows the SwapChain object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~SwapChain();
C++ | !SwapChain();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


SwapChain.GetBackBuffer(Int32,BackBufferType) Method (Microsoft.DirectX.Direct3D)

SwapChain.GetBackBuffer Method

Retrieves a back buffer from the swap chain of a device.

Definition

Visual Basic Public Function GetBackBuffer( _
ByVal backBuffer As Integer, _
ByVal typeBuffer As BackBufferType _
) As Surface
C# public Surface GetBackBuffer(
int backBuffer,
BackBufferType typeBuffer
);
C++ public:
Surface^ GetBackBuffer(
int backBuffer,
BackBufferType typeBuffer
);
JScript public function GetBackBuffer(
backBuffer : int,
typeBuffer : BackBufferType
) : Surface;

Parameters

backBuffer System.Int32
Index of the back buffer object to return. See Remarks.
typeBuffer Microsoft.DirectX.Direct3D.BackBufferType
Because stereo view is not supported in Microsoft DirectX 9.0, the only valid value for this parameter is Mono.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the returned back buffer surface.

Remarks

Back buffers are numbered from 0 to the total number of back buffers - 1. A value of 0 returns the first back buffer, not the front buffer. The front buffer is not accessible through this method.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SwapChain.GetFrontBufferData(Surface) Method (Microsoft.DirectX.Direct3D)

SwapChain.GetFrontBufferData Method

Generates a copy of the swap chain's front buffer and places it in a Surface object provided by the application.

Definition

Visual Basic Public Sub GetFrontBufferData( _
ByVal frontBuffer As Surface _
)
C# public void GetFrontBufferData(
Surface frontBuffer
);
C++ public:
void GetFrontBufferData(
Surface^ frontBuffer
);
JScript public function GetFrontBufferData(
frontBuffer : Surface
);

Parameters

frontBuffer Microsoft.DirectX.Direct3D.Surface
[in, out] A Surface object that receives a copy of the swap chain's front buffer. The data is returned in successive rows with no intervening space, from the vertically highest row to the lowest.

Remarks

For windowed mode, the size of the destination surface should be the size of the desktop. For full-screen mode, the size of the destination surface should be the screen size.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SwapChain.GetHashCode() Method (Microsoft.DirectX.Direct3D)

SwapChain.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


SwapChain.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

SwapChain.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DSwapChain9, which allows unmanaged COM clients to create an instance of the managed SwapChain class. Not supported.


SwapChain.op_Equality(SwapChain,SwapChain) Method (Microsoft.DirectX.Direct3D)

SwapChain.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As SwapChain, _
ByVal right As SwapChain _
) As Boolean
C# public static bool op_Equality(
SwapChain left,
SwapChain right
);
C++ public:
static bool operator==(
SwapChain^ left,
SwapChain^ right
);
JScript public static function op_Equality(
left : SwapChain,
right : SwapChain
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.SwapChain
The SwapChain object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.SwapChain
The SwapChain object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


SwapChain.op_Inequality(SwapChain,SwapChain) Method (Microsoft.DirectX.Direct3D)

SwapChain.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As SwapChain, _
ByVal right As SwapChain _
) As Boolean
C# public static bool op_Inequality(
SwapChain left,
SwapChain right
);
C++ public:
static bool operator!=(
SwapChain^ left,
SwapChain^ right
);
JScript public static function op_Inequality(
left : SwapChain,
right : SwapChain
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.SwapChain
The SwapChain object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.SwapChain
The SwapChain object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


SwapChain.Present Method ()

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Overload List

public void Present();
public void Present(Control);
public void Present(Control, Present);
public void Present(IntPtr);
public void Present(IntPtr, Present);
public void Present(Present);
public void Present(Rectangle, bool);
public void Present(Rectangle, Control, bool);
public void Present(Rectangle, Control, Present, bool);
public void Present(Rectangle, IntPtr, bool);
public void Present(Rectangle, IntPtr, Present, bool);
public void Present(Rectangle, Present, bool);
public void Present(Rectangle, Rectangle, Control);
public void Present(Rectangle, Rectangle, Control, Present);
public void Present(Rectangle, Rectangle, IntPtr);
public void Present(Rectangle, Rectangle, IntPtr, Present);

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,IntPtr,Present,Boolean) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindowHandle As IntPtr, _
ByVal flags As Present, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
Present flags,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
Present flags,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
overrideWindowHandle : IntPtr,
flags : Present,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags Microsoft.DirectX.Direct3D.Present
Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(IntPtr,Present) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal overrideWindowHandle As IntPtr, _
ByVal flags As Present _
)
C# public void Present(
IntPtr overrideWindowHandle,
Present flags
);
C++ public:
void Present(
IntPtr overrideWindowHandle,
Present flags
);
JScript public function Present(
overrideWindowHandle : IntPtr,
flags : Present
);

Parameters

overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags Microsoft.DirectX.Direct3D.Present
Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Rectangle,IntPtr,Present) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindowHandle As IntPtr, _
ByVal flags As Present _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle,
Present flags
);
C++ public:
void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle,
Present flags
);
JScript public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindowHandle : IntPtr,
flags : Present
);

Parameters

sourceRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the destination rectangle in window client coordinates. This value can be used only if the swap chain was created with SwapEffect.Copy. If the value is omitted, the entire client area is filled. If the rectangle exceeds the destination client area, it is clipped to fit.
overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags Microsoft.DirectX.Direct3D.Present
Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,IntPtr,Boolean) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindowHandle As IntPtr, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
IntPtr overrideWindowHandle,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
overrideWindowHandle : IntPtr,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(IntPtr) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal overrideWindowHandle As IntPtr _
)
C# public void Present(
IntPtr overrideWindowHandle
);
C++ public:
void Present(
IntPtr overrideWindowHandle
);
JScript public function Present(
overrideWindowHandle : IntPtr
);

Parameters

overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Rectangle,IntPtr) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindowHandle As IntPtr _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle
);
C++ public:
void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
IntPtr overrideWindowHandle
);
JScript public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindowHandle : IntPtr
);

Parameters

sourceRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the destination rectangle in window client coordinates. This value can be used only if the swap chain was created with SwapEffect.Copy. If the value is omitted, the entire client area is filled. If the rectangle exceeds the destination client area, it is clipped to fit.
overrideWindowHandle System.IntPtr
Destination window whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Present,Boolean) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal flags As Present, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
Present flags,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
Present flags,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
flags : Present,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
flags Microsoft.DirectX.Direct3D.Present
Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Control,Present,Boolean) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindow As Control, _
ByVal flags As Present, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
Control overrideWindow,
Present flags,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
Control^ overrideWindow,
Present flags,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
overrideWindow : Control,
flags : Present,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
overrideWindow System.Windows.Forms.Control
A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags Microsoft.DirectX.Direct3D.Present
Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Control,Present) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal overrideWindow As Control, _
ByVal flags As Present _
)
C# public void Present(
Control overrideWindow,
Present flags
);
C++ public:
void Present(
Control^ overrideWindow,
Present flags
);
JScript public function Present(
overrideWindow : Control,
flags : Present
);

Parameters

overrideWindow System.Windows.Forms.Control
A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags Microsoft.DirectX.Direct3D.Present
Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Present) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal flags As Present _
)
C# public void Present(
Present flags
);
C++ public:
void Present(
Present flags
);
JScript public function Present(
flags : Present
);

Parameters

flags Microsoft.DirectX.Direct3D.Present
Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Rectangle,Control,Present) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindow As Control, _
ByVal flags As Present _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control overrideWindow,
Present flags
);
C++ public:
void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control^ overrideWindow,
Present flags
);
JScript public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindow : Control,
flags : Present
);

Parameters

sourceRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the destination rectangle in window client coordinates. This value can be used only if the swap chain was created with SwapEffect.Copy. If the value is omitted, the entire client area is filled. If the rectangle exceeds the destination client area, it is clipped to fit.
overrideWindow System.Windows.Forms.Control
A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
flags Microsoft.DirectX.Direct3D.Present
Allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation. Valid values are 0, Present.DoNotWait, Present.LinearContent or a combination of these values. See Remarks.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Boolean) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Control,Boolean) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal rectPresent As Rectangle, _
ByVal overrideWindow As Control, _
ByVal sourceRectangle As Boolean _
)
C# public void Present(
Rectangle rectPresent,
Control overrideWindow,
bool sourceRectangle
);
C++ public:
void Present(
Rectangle rectPresent,
Control^ overrideWindow,
bool sourceRectangle
);
JScript public function Present(
rectPresent : Rectangle,
overrideWindow : Control,
sourceRectangle : boolean
);

Parameters

rectPresent System.Drawing.Rectangle
A Rectangle Leave Site structure that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
overrideWindow System.Windows.Forms.Control
A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.
sourceRectangle System.Boolean
Set to true if a Rectangle Leave Site is being passed to the param_Rectangle_rectPresent parameter; otherwise, false.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Control) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal overrideWindow As Control _
)
C# public void Present(
Control overrideWindow
);
C++ public:
void Present(
Control^ overrideWindow
);
JScript public function Present(
overrideWindow : Control
);

Parameters

overrideWindow System.Windows.Forms.Control
A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present() Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic | Public Sub Present()
C# | public void Present();
C++ public:
void Present();
JScript | public function Present();

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.Present(Rectangle,Rectangle,Control) Method (Microsoft.DirectX.Direct3D)

SwapChain.Present Method

Presents the contents of the next buffer in the sequence of back buffers owned by the swap chain.

Definition

Visual Basic Public Sub Present( _
ByVal sourceRectangle As Rectangle, _
ByVal destRectangle As Rectangle, _
ByVal overrideWindow As Control _
)
C# public void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control overrideWindow
);
C++ public:
void Present(
Rectangle sourceRectangle,
Rectangle destRectangle,
Control^ overrideWindow
);
JScript public function Present(
sourceRectangle : Rectangle,
destRectangle : Rectangle,
overrideWindow : Control
);

Parameters

sourceRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the source rectangle. This value must be omitted unless the swap chain was created with Copy. If the value is omitted, the entire source surface is presented. If the rectangle exceeds the source surface, it is clipped to fit.
destRectangle System.Drawing.Rectangle
A Rectangle Leave Site that contains the destination rectangle in window client coordinates. This value can be used only if the swap chain was created with SwapEffect.Copy. If the value is omitted, the entire client area is filled. If the rectangle exceeds the destination client area, it is clipped to fit.
overrideWindow System.Windows.Forms.Control
A Control Leave Site object whose client area is taken as the target for the current presentation. If this parameter is omitted, the PresentParameters.DeviceWindowHandle member is used.

Remarks

If param_Present_flags = 0, Present spins without returning an error until the hardware is free.

If param_Present_flags = Present.DoNotWait and the hardware is busy processing or waiting for a vertical sync interval, the method throws a WasStillDrawingException.

If param_Present_flags = Present.LinearContent, gamma correction is performed from linear space to sRGB for windowed swap chains. This flag takes effect only when the Caps.DriverCaps.SupportsLinearToSrgbPresentation property is set to true.

The Device.Present method is a shortcut to SwapChain.Present. The swap chain method has been updated to include a flag that allows the application to request that the method return immediately when the driver reports that it cannot schedule a presentation.

If necessary, a stretch operation is applied to transfer the pixels in the source rectangle to the destination rectangle in the target window's client area.

The Device.Present method fails if it is called between a Device.BeginScene ... Device.EndScene pair, unless the render target is not the current render target (for example, the back buffer that results from the creation of an additional swap chain).

Exceptions
DriverInternalErrorException | Internal driver error. Applications should generally shut down when receiving this error.
DeviceLostException | The device is lost but cannot be reset at this time. Therefore, rendering is not possible.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Reset


SwapChain.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

SwapChain.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.SwapChain.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


SwapChain.SwapChain Constructor ()

How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Overload List

public SwapChain(Device, PresentParameters);
public SwapChain(IDirect3DSwapChain9);
public SwapChain(IDirect3DSwapChain9, Device);
public SwapChain(IntPtr);

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft Direct3D sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.SwapChain(IDirect3DSwapChain9) Constructor (Microsoft.DirectX.Direct3D)

SwapChain.SwapChain Constructor

How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DSwapChain9 _
)
C# public SwapChain(
IDirect3DSwapChain9 pUnk
);
C++ public:
SwapChain(
IDirect3DSwapChain9 pUnk
);
JScript public function SwapChain(
pUnk : IDirect3DSwapChain9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSwapChain9
Unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface pointer.

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft Direct3D sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.SwapChain(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

SwapChain.SwapChain Constructor

How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public SwapChain(
IntPtr unmanagedObject
);
C++ public:
SwapChain(
IntPtr unmanagedObject
);
JScript public function SwapChain(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft Direct3D sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.SwapChain(IDirect3DSwapChain9,Device) Constructor (Microsoft.DirectX.Direct3D)

SwapChain.SwapChain Constructor

How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DSwapChain9, _
ByVal device As Device _
)
C# public SwapChain(
IDirect3DSwapChain9 lp,
Device device
);
C++ public:
SwapChain(
IDirect3DSwapChain9 lp,
Device^ device
);
JScript public function SwapChain(
lp : IDirect3DSwapChain9,
device : Device
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSwapChain9
Unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
The Device object that represents the device to associate with the swap chain.

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft Direct3D sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.SwapChain(Device,PresentParameters) Constructor (Microsoft.DirectX.Direct3D)

SwapChain.SwapChain Constructor

How Do I...?
  • Create an Additional Swap Chain

Creates a new instance of the SwapChain class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal presentationParameters As PresentParameters _
)
C# public SwapChain(
Device device,
PresentParameters presentationParameters
);
C++ public:
SwapChain(
Device^ device,
PresentParameters^ presentationParameters
);
JScript public function SwapChain(
device : Device,
presentationParameters : PresentParameters
);

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device object that represents the device to associate with the swap chain.
presentationParameters Microsoft.DirectX.Direct3D.PresentParameters
A PresentParameters object that contains the presentation parameters for the new swap chain. See Remarks.

Remarks

Calling this method changes the value of members of the PresentParameters object in the following ways.

  • If BackBufferCount == 0, calling SwapChain increases it to 1.
  • If the application is in windowed mode and if either the BackBufferWidth or BackBufferHeight == 0, they are set to the width and height of the client area window.

Each device always has at least one swap chain (the implicit swap chain), because Microsoft Direct3D sets a swap chain as a device property.

Note that any given device can support only one full-screen swap chain.

It is permissible to specify Format.Unknown for the windowed-mode back buffer format when calling the Device and SwapChain constructors and Device.Reset. If this is done, the application need not query the current desktop format before it calls the Device constructor for windowed mode. For full-screen mode, the back buffer format must be specified.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried multisample type.
DeviceLostException | The device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

How Do I...?

Create an Additional Swap Chain

This example demonstrates how to create an additional swap chain using the SwapChain class. Additional swap chains are useful for supporting multiple viewports; for example, a single window partitioned into four sub-windows, each with different views of the same scene.

In Microsoft DirectX 9.0 for Managed Code, each Device is created with a default swap chain known as the implicit swap chain. Using the SwapChain class allows creation of additional swap chains for rendering operations.

To create a new swap chain:

  1. Create an instance of the PresentParameters class, or use an existing instance and set the presentation properties to the values you need for the swap chain.
  2. Then create a swap chain object using the SwapChain class constructor.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

    // Create a swap chain using an existing instance of PresentParameters.
    SwapChain sc = new SwapChain(device, presentParams);


SwapChain.UpdateUnmanagedPointer(IDirect3DSwapChain9) Method (Microsoft.DirectX.Direct3D)

SwapChain.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this SwapChain object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DSwapChain9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DSwapChain9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DSwapChain9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DSwapChain9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSwapChain9
Pointer to the IDirect3DSwapChain9 structure used to update the unmanaged pointer for this SwapChain object.


SwapChain.Device Property (Microsoft.DirectX.Direct3D)

SwapChain.Device Property

Retrieves the device associated with a swap chain.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
The Device object associated with the swap chain.

This property is read-only.


SwapChain.DisplayMode Property (Microsoft.DirectX.Direct3D)

SwapChain.DisplayMode Property

Retrieves the display mode's spatial resolution, color resolution, and refresh frequency.

Definition

Visual Basic | Public ReadOnly Property DisplayMode As DisplayMode
C# | public DisplayMode DisplayMode { get; }
C++ public:
property DisplayMode DisplayMode {
DisplayMode get();
}
JScript | public function get DisplayMode() : DisplayMode

Property Value

Microsoft.DirectX.Direct3D.DisplayMode
A DisplayMode structure that contains data about the display mode of the adapter. This is different than the display mode of the device, which might not be active if the device does not own full-screen mode.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


SwapChain.Disposed Property (Microsoft.DirectX.Direct3D)

SwapChain.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


SwapChain.PresentParameters Property (Microsoft.DirectX.Direct3D)

SwapChain.PresentParameters Property

Retrieves the presentation parameters associated with a swap chain.

Definition

Visual Basic | Public ReadOnly Property PresentParameters As PresentParameters
C# | public PresentParameters PresentParameters { get; }
C++ public:
property PresentParameters^ PresentParameters {
PresentParameters^ get();
}
JScript | public function get PresentParameters() : PresentParameters

Property Value

Microsoft.DirectX.Direct3D.PresentParameters
Presentation parameters. For more information, see PresentParameters.

This property is read-only.

Remarks

This method can be used to view the presentation parameters of the parent swap chain of a surface (a back buffer, for instance). The parent swap chain can be retrieved with Surface.GetContainer.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SwapChain.RasterStatus Property (Microsoft.DirectX.Direct3D)

SwapChain.RasterStatus Property

Returns information that describes the raster of the monitor on which the swap chain is presented.

Definition

Visual Basic | Public ReadOnly Property RasterStatus As RasterStatus
C# | public RasterStatus RasterStatus { get; }
C++ public:
property RasterStatus RasterStatus {
RasterStatus get();
}
JScript | public function get RasterStatus() : RasterStatus

Property Value

Microsoft.DirectX.Direct3D.RasterStatus
A RasterStatus structure that contains information about the position or other status of the raster on the monitor driven by the current adapter.

This property is read-only.

Remarks

This method does not return device state for a device created using PureDevice. To use this method, create a device with any of the other values in CreateFlags.

Exceptions
InvalidCallException Occurs if ret_RasterStatus_get is invalid or if the device does not support reading the current scan line. To determine whether the device supports reading the scan line, check the Caps.DriverCaps.ReadScanLine property. It should be set to true.


SwapChain.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

SwapChain.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DSwapChain9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DSwapChain9
C# | public IDirect3DSwapChain9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DSwapChain9 UnmanagedComPointer {
IDirect3DSwapChain9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DSwapChain9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DSwapChain9
Unmanaged IDirect3DSwapChain9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


SwapChain.Disposing Event (Microsoft.DirectX.Direct3D)

SwapChain.Disposing Event

Occurs when the Dispose method is called or when the SwapChain object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.SwapChain.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the SwapChain object indicates whether that object has been disposed.


Texture Class (Microsoft.DirectX.Direct3D)

Texture Class

Manipulates a texture resource.

Definition

Visual Basic NotInheritable Public Class Texture
Inherits BaseTexture
Implements IDisposable
C# | public sealed class Texture : BaseTexture, IDisposable
C++ | public ref class Texture sealed : BaseTexture, IDisposable
JScript | public final class Texture extends BaseTexture implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Texture object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDirtyRectangle | Adds a dirty region to a texture resource.
Dispose | Immediately releases the unmanaged resources used by the Texture object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Texture object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
static (Shared in Visual Basic) FromBitmap | Creates a texture resource from a bitmap.
static (Shared in Visual Basic) FromStream | Creates a texture resource from a stream object.
GenerateMipSubLevels | Generates mipmap sublevels. Inherited from BaseTexture.
GetHashCode | Returns the hash code for the current instance.
GetLevelDescription | Retrieves a level description of a texture resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
GetSurfaceLevel | Retrieves the specified texture surface level.
LockRectangle | Locks a rectangle on a texture resource.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseTexture.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseTexture.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Texture.Disposing event when called from within a derived class.
SetLevelOfDetail | Sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
Texture | Creates a new instance of the Texture class.
UnlockRectangle | Unlocks a rectangle on a texture resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseTexture object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseTexture.

Properties

Property | Description
AutoGenerateFilterType | Retrieves or sets the filter type used for automatically generated sublevels. Inherited from BaseTexture.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
LevelCount | Retrieves the number of texture levels in a multilevel texture. Inherited from BaseTexture.
LevelOfDetail | Retrieves or sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DTexture9 interface pointer.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DBaseTexture9 interface pointer. Inherited from BaseTexture.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
Texture

Remarks

This object inherits additional functionality from the BaseTexture object.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Texture.AddDirtyRectangle Method ()

Adds a dirty region to a texture resource.

Overload List

public void AddDirtyRectangle();
public void AddDirtyRectangle(Rectangle);

Remarks

Omitting the param_Rectangle_rect parameter expands the dirty region to cover the entire texture.

For performance reasons, dirty regions are recorded only for level zero of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box also is dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Texture.AddDirtyRectangle() Method (Microsoft.DirectX.Direct3D)

Texture.AddDirtyRectangle Method

Adds a dirty region to a texture resource.

Definition

Visual Basic | Public Sub AddDirtyRectangle()
C# | public void AddDirtyRectangle();
C++ public:
void AddDirtyRectangle();
JScript | public function AddDirtyRectangle();

Remarks

Omitting the param_Rectangle_rect parameter expands the dirty region to cover the entire texture.

For performance reasons, dirty regions are recorded only for level zero of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box also is dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Texture.AddDirtyRectangle(Rectangle) Method (Microsoft.DirectX.Direct3D)

Texture.AddDirtyRectangle Method

Adds a dirty region to a texture resource.

Definition

Visual Basic Public Sub AddDirtyRectangle( _
ByVal rect As Rectangle _
)
C# public void AddDirtyRectangle(
Rectangle rect
);
C++ public:
void AddDirtyRectangle(
Rectangle rect
);
JScript public function AddDirtyRectangle(
rect : Rectangle
);

Parameters

rect System.Drawing.Rectangle
A Rectangle Leave Site structure that specifies the dirty region to add.

Remarks

Omitting the param_Rectangle_rect parameter expands the dirty region to cover the entire texture.

For performance reasons, dirty regions are recorded only for level zero of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box also is dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Texture.Dispose() Method (Microsoft.DirectX.Direct3D)

Texture.Dispose Method

Immediately releases the unmanaged resources used by the Texture object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Texture();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Texture.Disposed
  • Microsoft.DirectX.Direct3D.Texture.Disposing


Texture.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Texture.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Texture.Finalize() Method (Microsoft.DirectX.Direct3D)

Texture.Finalize Method

Allows the Texture object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Texture();
C++ | !Texture();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Texture.FromBitmap(Device,Bitmap,Usage,Pool) Method (Microsoft.DirectX.Direct3D)

Texture.FromBitmap Method

Creates a texture resource from a bitmap.

Definition

Visual Basic Public Shared Function FromBitmap( _
ByVal device As Device, _
ByVal image As Bitmap, _
ByVal usage As Usage, _
ByVal pool As Pool _
) As Texture
C# public static Texture FromBitmap(
Device device,
Bitmap image,
Usage usage,
Pool pool
);
C++ public:
static Texture^ FromBitmap(
Device^ device,
Bitmap^ image,
Usage usage,
Pool pool
);
JScript public static function FromBitmap(
device : Device,
image : Bitmap,
usage : Usage,
pool : Pool
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the Texture.
image System.Drawing.Bitmap
A Bitmap Leave Site used to create the texture.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • Texture


Texture.FromStream(Device,Stream,Usage,Pool) Method (Microsoft.DirectX.Direct3D)

Texture.FromStream Method

Creates a texture resource from a stream object.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal usage As Usage, _
ByVal pool As Pool _
) As Texture
C# public static Texture FromStream(
Device device,
Stream data,
Usage usage,
Pool pool
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ data,
Usage usage,
Pool pool
);
JScript public static function FromStream(
device : Device,
data : Stream,
usage : Usage,
pool : Pool
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the Texture object.
data System.IO.Stream
A Stream Leave Site used to create the texture.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromBitmap
  • Texture


Texture.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Texture.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Texture.GetLevelDescription(Int32) Method (Microsoft.DirectX.Direct3D)

Texture.GetLevelDescription Method

Retrieves a level description of a texture resource.

Definition

Visual Basic Public Function GetLevelDescription( _
ByVal level As Integer _
) As SurfaceDescription
C# public SurfaceDescription GetLevelDescription(
int level
);
C++ public:
SurfaceDescription GetLevelDescription(
int level
);
JScript public function GetLevelDescription(
level : int
) : SurfaceDescription;

Parameters

level System.Int32
Level of the texture resource. This method returns a surface description for the level specified by this parameter.

Return Value

Microsoft.DirectX.Direct3D.SurfaceDescription
A SurfaceDescription structure that describes the returned level.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Texture.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Texture.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DTexture9, which allows unmanaged COM clients to create an instance of the managed Texture class. Not supported.


Texture.GetSurfaceLevel(Int32) Method (Microsoft.DirectX.Direct3D)

Texture.GetSurfaceLevel Method

Retrieves the specified texture surface level.

Definition

Visual Basic Public Function GetSurfaceLevel( _
ByVal level As Integer _
) As Surface
C# public Surface GetSurfaceLevel(
int level
);
C++ public:
Surface^ GetSurfaceLevel(
int level
);
JScript public function GetSurfaceLevel(
level : int
) : Surface;

Parameters

level System.Int32
Level of the texture resource. This method returns a surface for the level specified by this parameter. The top-level surface is denoted by 0.

Return Value

Microsoft.DirectX.Direct3D.Surface
A Surface object that represents the returned surface.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


Texture.LockRectangle Method ()

Locks a rectangle on a texture resource.

Overload List

public GraphicsStream LockRectangle(int, LockFlags);
public GraphicsStream LockRectangle(int, LockFlags, out int);
public GraphicsStream LockRectangle(int, Rectangle, LockFlags);
public GraphicsStream LockRectangle(int, Rectangle, LockFlags, out int);
public Array LockRectangle(Type, int, LockFlags, out int, int[]);
public Array LockRectangle(Type, int, LockFlags, int[]);
public Array LockRectangle(Type, int, Rectangle, LockFlags, out int, int[]);
public Array LockRectangle(Type, int, Rectangle, LockFlags, int[]);

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Int32,Rectangle,LockFlags,Int32) Method (Microsoft.DirectX.Direct3D)

Texture.LockRectangle Method

Locks a rectangle on a texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
int level,
Rectangle rect,
LockFlags flags,
out int pitch
);
C++ public:
GraphicsStream^ LockRectangle(
int level,
Rectangle rect,
LockFlags flags,
[Out] int% pitch
);
JScript public function LockRectangle(
level : int,
rect : Rectangle,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

level System.Int32
A level of the texture resource to lock.
rect System.Drawing.Rectangle
A Rectangle Leave Site to lock. To expand the dirty region to cover the entire texture, omit this parameter.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
pitch System.Int32
Pitch of the returning data.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Int32,LockFlags,Int32) Method (Microsoft.DirectX.Direct3D)

Texture.LockRectangle Method

Locks a rectangle on a texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef pitch As Integer _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
int level,
LockFlags flags,
out int pitch
);
C++ public:
GraphicsStream^ LockRectangle(
int level,
LockFlags flags,
[Out] int% pitch
);
JScript public function LockRectangle(
level : int,
flags : LockFlags,
pitch : int
) : GraphicsStream;

Parameters

level System.Int32
A level of the texture resource to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
pitch System.Int32
Pitch of the returning data.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Int32,Rectangle,LockFlags) Method (Microsoft.DirectX.Direct3D)

Texture.LockRectangle Method

Locks a rectangle on a texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
int level,
Rectangle rect,
LockFlags flags
);
C++ public:
GraphicsStream^ LockRectangle(
int level,
Rectangle rect,
LockFlags flags
);
JScript public function LockRectangle(
level : int,
rect : Rectangle,
flags : LockFlags
) : GraphicsStream;

Parameters

level System.Int32
A level of the texture resource to lock.
rect System.Drawing.Rectangle
A Rectangle Leave Site to lock. To expand the dirty region to cover the entire texture, omit this parameter.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

Texture.LockRectangle Method

Locks a rectangle on a texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal level As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockRectangle(
int level,
LockFlags flags
);
C++ public:
GraphicsStream^ LockRectangle(
int level,
LockFlags flags
);
JScript public function LockRectangle(
level : int,
flags : LockFlags
) : GraphicsStream;

Parameters

level System.Int32
A level of the texture resource to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Type,Int32,Rectangle,LockFlags,Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

Texture.LockRectangle Method

Locks a rectangle on a texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
int level,
Rectangle rect,
LockFlags flags,
out int pitch,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
int level,
Rectangle rect,
LockFlags flags,
[Out] int% pitch,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
level : int,
rect : Rectangle,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level System.Int32
A level of the texture resource to lock.
rect System.Drawing.Rectangle
A Rectangle Leave Site to lock. To expand the dirty region to cover the entire texture, omit this parameter.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
pitch System.Int32
Pitch of the returning data.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Type,Int32,LockFlags,Int32,Int32[]) Method (Microsoft.DirectX.Direct3D)

Texture.LockRectangle Method

Locks a rectangle on a texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef pitch As Integer, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
int level,
LockFlags flags,
out int pitch,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
int level,
LockFlags flags,
[Out] int% pitch,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
level : int,
flags : LockFlags,
pitch : int,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level System.Int32
A level of the texture resource to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
pitch System.Int32
Pitch of the returning data.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Type,Int32,Rectangle,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

Texture.LockRectangle Method

Locks a rectangle on a texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal rect As Rectangle, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
int level,
Rectangle rect,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
int level,
Rectangle rect,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
level : int,
rect : Rectangle,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level System.Int32
A level of the texture resource to lock.
rect System.Drawing.Rectangle
A Rectangle Leave Site to lock. To expand the dirty region to cover the entire texture, omit this parameter.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.LockRectangle(Type,Int32,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

Texture.LockRectangle Method

Locks a rectangle on a texture resource.

Definition

Visual Basic Public Function LockRectangle( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockRectangle(
Type typeLock,
int level,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockRectangle(
Type^ typeLock,
int level,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockRectangle(
typeLock : Type,
level : int,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level System.Int32
A level of the texture resource to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site object that describes the locked region.

Remarks

Textures created with Pool.Default are not lockable. Textures created in video memory are lockable when created with Usage.Dynamic. For more information about usages, see Usage.

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without Lock.NoDirtyUpdate or Lock.ReadOnly. For more information, see Device.UpdateTexture.

The only lockable format for a depth stencil texture is Format.D16Lockable.

Video memory textures cannot be locked, but must be modified by calling Device.UpdateSurface or Device.UpdateTexture. There are exceptions for some proprietary driver pixel formats that Microsoft DirectX 9.0 does not recognize. These can be locked.

See Also

  • Texture.UnlockRectangle


Texture.op_Equality(Texture,Texture) Method (Microsoft.DirectX.Direct3D)

Texture.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Texture, _
ByVal right As Texture _
) As Boolean
C# public static bool op_Equality(
Texture left,
Texture right
);
C++ public:
static bool operator==(
Texture^ left,
Texture^ right
);
JScript public static function op_Equality(
left : Texture,
right : Texture
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Texture
The Texture object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Texture
The Texture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Texture.op_Inequality(Texture,Texture) Method (Microsoft.DirectX.Direct3D)

Texture.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Texture, _
ByVal right As Texture _
) As Boolean
C# public static bool op_Inequality(
Texture left,
Texture right
);
C++ public:
static bool operator!=(
Texture^ left,
Texture^ right
);
JScript public static function op_Inequality(
left : Texture,
right : Texture
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Texture
The Texture object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Texture
The Texture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Texture.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Texture.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Texture.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Texture.Texture Constructor ()

Creates a new instance of the Texture class.

Overload List

public Texture(Device, Bitmap, Usage, Pool);
public Texture(Device, int, int, int, Usage, Format, Pool);
public Texture(Device, Stream, Usage, Pool);
public Texture(IDirect3DTexture9);
public Texture(IDirect3DTexture9, Device, Pool);
public Texture(IntPtr);

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(IDirect3DTexture9) Constructor (Microsoft.DirectX.Direct3D)

Texture.Texture Constructor

Creates a new instance of the Texture class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As IDirect3DTexture9 _
)
C# public Texture(
IDirect3DTexture9 pInterop
);
C++ public:
Texture(
IDirect3DTexture9 pInterop
);
JScript public function Texture(
pInterop : IDirect3DTexture9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DTexture9
Unmanaged Component Object Model (COM) IDirect3DTexture9 interface pointer.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Texture.Texture Constructor

Creates a new instance of the Texture class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Texture(
IntPtr unmanagedObject
);
C++ public:
Texture(
IntPtr unmanagedObject
);
JScript public function Texture(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DTexture9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(IDirect3DTexture9,Device,Pool) Constructor (Microsoft.DirectX.Direct3D)

Texture.Texture Constructor

Creates a new instance of the Texture class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DTexture9, _
ByVal device As Device, _
ByVal pool As Pool _
)
C# public Texture(
IDirect3DTexture9 lp,
Device device,
Pool pool
);
C++ public:
Texture(
IDirect3DTexture9 lp,
Device^ device,
Pool pool
);
JScript public function Texture(
lp : IDirect3DTexture9,
device : Device,
pool : Pool
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DTexture9
Unmanaged Component Object Model (COM) IDirect3DTexture9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the Texture.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(Device,Stream,Usage,Pool) Constructor (Microsoft.DirectX.Direct3D)

Texture.Texture Constructor

Creates a new instance of the Texture class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal data As Stream, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public Texture(
Device device,
Stream data,
Usage usage,
Pool pool
);
C++ public:
Texture(
Device^ device,
Stream^ data,
Usage usage,
Pool pool
);
JScript public function Texture(
device : Device,
data : Stream,
usage : Usage,
pool : Pool
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the Texture.
data System.IO.Stream
A Stream Leave Site object that contains the image data. The texture is created with the data in the stream.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(Device,Bitmap,Usage,Pool) Constructor (Microsoft.DirectX.Direct3D)

Texture.Texture Constructor

Creates a new instance of the Texture class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal image As Bitmap, _
ByVal usage As Usage, _
ByVal pool As Pool _
)
C# public Texture(
Device device,
Bitmap image,
Usage usage,
Pool pool
);
C++ public:
Texture(
Device^ device,
Bitmap^ image,
Usage usage,
Pool pool
);
JScript public function Texture(
device : Device,
image : Bitmap,
usage : Usage,
pool : Pool
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the Texture.
image System.Drawing.Bitmap
A Bitmap Leave Site used to create the texture.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.Texture(Device,Int32,Int32,Int32,Usage,Format,Pool) Constructor (Microsoft.DirectX.Direct3D)

Texture.Texture Constructor

Creates a new instance of the Texture class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal numLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool _
)
C# public Texture(
Device device,
int width,
int height,
int numLevels,
Usage usage,
Format format,
Pool pool
);
C++ public:
Texture(
Device^ device,
int width,
int height,
int numLevels,
Usage usage,
Format format,
Pool pool
);
JScript public function Texture(
device : Device,
width : int,
height : int,
numLevels : int,
usage : Usage,
format : Format,
pool : Pool
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the Texture.
width System.Int32
Width of the texture's top level, in pixels. The pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of one pixel. Thus, if the division by 2 results in 0, 1 is taken instead.
height System.Int32
Height of the texture's top level, in pixels. The pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of one pixel. Thus, if the division by 2 results in 0, 1 is taken instead.
numLevels System.Int32
Number of levels in the texture. If this is 0, Microsoft Direct3D generates all texture sublevels down to 1 by 1 pixels for hardware that supports mipmapped textures. Check the BaseTexture.LevelCount parameter to see the number of levels generated.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use one or more Usage constants. It is good practice to match the usage parameter with the CreateFlags in the Device constructor.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the format of all levels in the texture.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.

Remarks

An application can discover support for automatic generation of mipmaps in a particular format by calling Manager.CheckDeviceFormat with Usage.AutoGenerateMipMap. If Manager.CheckDeviceFormat returns false, the Texture constructor succeeds, but returns a single-level texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream
  • FromBitmap


Texture.UnlockRectangle(Int32) Method (Microsoft.DirectX.Direct3D)

Texture.UnlockRectangle Method

Unlocks a rectangle on a texture resource.

Definition

Visual Basic Public Sub UnlockRectangle( _
ByVal level As Integer _
)
C# public void UnlockRectangle(
int level
);
C++ public:
void UnlockRectangle(
int level
);
JScript public function UnlockRectangle(
level : int
);

Parameters

level System.Int32
Level of the texture resource to unlock.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.

See Also

  • Texture.LockRectangle


Texture.Disposed Property (Microsoft.DirectX.Direct3D)

Texture.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Texture.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Texture.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DTexture9 interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As IDirect3DTexture9
C# | public IDirect3DTexture9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DTexture9 UnmanagedComPointer {
IDirect3DTexture9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DTexture9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DTexture9
Unmanaged IDirect3DTexture9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Texture.Disposing Event (Microsoft.DirectX.Direct3D)

Texture.Disposing Event

Occurs when the Dispose method is called or when the Texture object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Texture.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Texture object indicates whether that object has been disposed.


TextureGutterHelper Class (Microsoft.DirectX.Direct3D)

TextureGutterHelper Class

Used to build and manage gutter regions in a texture. Gutter regions separate textures and allow for bilinear interpolation to avoid rendering artifacts at texture boundaries.

Definition

Visual Basic Public Class TextureGutterHelper
Inherits MarshalByRefObject
Implements IDisposable
C# | public class TextureGutterHelper : MarshalByRefObject, IDisposable
C++ | public ref class TextureGutterHelper : MarshalByRefObject, IDisposable
JScript | public class TextureGutterHelper extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the TextureGutterHelper object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
ApplyGutters | Applies gutters to a texture object.
Dispose | Immediately releases the unmanaged resources used by the TextureGutterHelper object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the TextureGutterHelper object to free resources before it is destroyed by the garbage collector.
GetBaryMap | Retrieves texel barycentric coordinates.
GetFaceMap | Retrieves the index of the mesh face to which each texel belongs.
GetGutterMap | Receives a texel class value that indicates texel class according to each texel's location.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetTexelMap | Retrieves the (u, v) texture coordinates of each texel.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposing event when called from within a derived class.
ResampleTexture | Resamples a texture into this gutterhelper's parameterization.
SetBaryMap | Sets texel barycentric coordinates.
SetFaceMap | Sets the index of the mesh face to which each texel belongs.
SetGutterMap | Sets a texel class value that indicates texel class according to each texel's location.
SetTexelMap | Sets the (u, v) texture coordinates of each texel.
TextureGutterHelper | Initializes a new instance of the TextureGutterHelper class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this TextureGutterHelper object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Height | Retrieves the height of the texture, in pixels.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXTextureGutterHelper interface pointer.
Width | Retrieves the width of the texture, in pixels.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
TextureGutterHelper

Remarks

Note: When used with precomputed radiance transfer (PRT), this class requires a unique parameterization of the model. Every texel must correspond to a single point on the surface of the model and vice-versa. If the model includes multiple textures, it must be split into separate pieces that each contain one gutter helper object per texture.

This class can be used to generate a map in texture space in which each texel is in one of four classes.

Texel Class | Texel Location
0 | Invalid point; texel will not be used.
1 | Inside triangle.
2 | Inside gutter.
4 | Inside gutter; texel will be evaluated as a full sample in the ApplyGutters method.

For classes 1 and 2, a texel is stored with the face it belongs to, along with barycentric coordinates of the first two vertices of that face. Gutter vertices are assigned to the closest edge in texture space.

There is no texel class 3.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureGutterHelper.ApplyGutters Method ()

Applies gutters to a texture object.

Overload List

public void ApplyGutters(GraphicsStream, int, int, int);
public void ApplyGutters(PrtBuffer);
public void ApplyGutters(float[], int, int, int);
public void ApplyGutters(Texture);

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.


TextureGutterHelper.ApplyGutters(PrtBuffer) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.ApplyGutters Method

Applies gutters to a texture object.

Definition

Visual Basic Public Sub ApplyGutters( _
ByVal buffer As PrtBuffer _
)
C# public void ApplyGutters(
PrtBuffer buffer
);
C++ public:
void ApplyGutters(
PrtBuffer^ buffer
);
JScript public function ApplyGutters(
buffer : PrtBuffer
);

Parameters

buffer Microsoft.DirectX.Direct3D.PrtBuffer
A PrtBuffer object to add gutters to.

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureGutterHelper.ApplyGutters(Texture) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.ApplyGutters Method

Applies gutters to a texture object.

Definition

Visual Basic Public Sub ApplyGutters( _
ByVal texture As Texture _
)
C# public void ApplyGutters(
Texture texture
);
C++ public:
void ApplyGutters(
Texture^ texture
);
JScript public function ApplyGutters(
texture : Texture
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture
A Texture object to added gutters to.

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
WasStillDrawingException | The previous blit operation that is transferring information to or from this surface is incomplete.


TextureGutterHelper.ApplyGutters(Single[],Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.ApplyGutters Method

Applies gutters to a texture object.

Definition

Visual Basic Public Sub ApplyGutters( _
ByVal data() As Single, _
ByVal numCoefficients As Integer, _
ByVal width As Integer, _
ByVal height As Integer _
)
C# public void ApplyGutters(
float[] data,
int numCoefficients,
int width,
int height
);
C++ public:
void ApplyGutters(
array<float>^ data,
int numCoefficients,
int width,
int height
);
JScript public function ApplyGutters(
data : float[],
numCoefficients : int,
width : int,
height : int
);

Parameters

data System.Single[]
A floating-point array of texture data to add gutters to.
numCoefficients System.Int32
Number of scalars per color channel used in memory to store samples.
width System.Int32
Width of the texture, in pixels, obtained from the TextureGutterHelper.Width property.
height System.Int32
Height of the texture, in pixels, obtained from the TextureGutterHelper.Height property.

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureGutterHelper.ApplyGutters(GraphicsStream,Int32,Int32,Int32) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.ApplyGutters Method

Applies gutters to a texture object.

Definition

Visual Basic Public Sub ApplyGutters( _
ByVal data As GraphicsStream, _
ByVal numCoefficients As Integer, _
ByVal width As Integer, _
ByVal height As Integer _
)
C# public void ApplyGutters(
GraphicsStream data,
int numCoefficients,
int width,
int height
);
C++ public:
void ApplyGutters(
GraphicsStream^ data,
int numCoefficients,
int width,
int height
);
JScript public function ApplyGutters(
data : GraphicsStream,
numCoefficients : int,
width : int,
height : int
);

Parameters

data Microsoft.DirectX.GraphicsStream
A GraphicsStream object of texture data to add gutters to.
numCoefficients System.Int32
Number of scalars per color channel used in memory to store samples.
width System.Int32
Width of the texture, in pixels, obtained from the TextureGutterHelper.Width property.
height System.Int32
Height of the texture, in pixels, obtained from the TextureGutterHelper.Height property.

Remarks

Class 2 texels are generated by resampling class 1 and class 4 texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureGutterHelper.Dispose() Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.Dispose Method

Immediately releases the unmanaged resources used by the TextureGutterHelper object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~TextureGutterHelper();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposed
  • Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposing


TextureGutterHelper.Equals(Object) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


TextureGutterHelper.Finalize() Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.Finalize Method

Allows the TextureGutterHelper object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~TextureGutterHelper();
C++ | !TextureGutterHelper();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


TextureGutterHelper.GetBaryMap(Vector2[]) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.GetBaryMap Method

Retrieves texel barycentric coordinates.

Definition

Visual Basic Public Sub GetBaryMap( _
ByVal baryData() As Vector2 _
)
C# public void GetBaryMap(
Vector2[] baryData
);
C++ public:
void GetBaryMap(
array<Vector2>^ baryData
);
JScript public function GetBaryMap(
baryData : Vector2[]
);

Parameters

baryData Microsoft.DirectX.Vector2[]
An array of Vector2 objects that contain the first two barycentric coordinates of each texel.

Remarks

The third barycentric coordinate is given by:

1 - (baryData.x + baryData.y)

Barycentric coordinates are always specified with respect to the triangle returned by TextureGutterHelper.GetFaceMap.

The barycentric coordinates returned by this method are valid only for valid (non-class 0) texels. TextureGutterHelper.GetGutterMap will return nonzero values for valid texels.

Class 2 texels are mapped to the nearest point on the triangle in texel space.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.SetBaryMap


TextureGutterHelper.GetFaceMap(Int32[]) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.GetFaceMap Method

Retrieves the index of the mesh face to which each texel belongs.

Definition

Visual Basic Public Sub GetFaceMap( _
ByVal faceData() As Integer _
)
C# public void GetFaceMap(
int[] faceData
);
C++ public:
void GetFaceMap(
array<int>^ faceData
);
JScript public function GetFaceMap(
faceData : int[]
);

Parameters

faceData System.Int32[]
An integer array containing index values of the mesh face to which each texel belongs.

Remarks

The mesh face data returned by this method is valid only for valid (non-class 0) texels. TextureGutterHelper.GetGutterMap will return nonzero values for valid (non-class 0) texels.

This method retrieves the closest face for class 2 texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.SetFaceMap


TextureGutterHelper.GetGutterMap(Byte[]) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.GetGutterMap Method

Receives a texel class value that indicates texel class according to each texel's location.

Definition

Visual Basic Public Sub GetGutterMap( _
ByVal gutterData() As Byte _
)
C# public void GetGutterMap(
byte[] gutterData
);
C++ public:
void GetGutterMap(
array<unsigned char>^ gutterData
);
JScript public function GetGutterMap(
gutterData : byte[]
);

Parameters

gutterData System.Byte[]
A Byte Leave Site array that receives the texel class.

Remarks

Possible texel classes are as follows:

Texel Class | Texel Location
0 | Invalid point; texel will not be used.
1 | Inside triangle.
2 | Inside gutter.
4 | Inside gutter; texel will be evaluated as a full sample in the ApplyGutters method.

There is no texel class 3.

The application must allocate and manage gutterData, with size given by:

size = texture width * texture height * sizeof(BYTE)

Texture width and height are obtained from the TextureGutterHelper.Width and TextureGutterHelper.Height properties.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.SetGutterMap


TextureGutterHelper.GetHashCode() Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


TextureGutterHelper.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXTextureGutterHelper, which allows unmanaged COM clients to create an instance of the managed TextureGutterHelper class. Not supported.


TextureGutterHelper.GetTexelMap(Vector2[]) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.GetTexelMap Method

Retrieves the (u, v) texture coordinates of each texel.

Definition

Visual Basic Public Sub GetTexelMap( _
ByVal texelData() As Vector2 _
)
C# public void GetTexelMap(
Vector2[] texelData
);
C++ public:
void GetTexelMap(
array<Vector2>^ texelData
);
JScript public function GetTexelMap(
texelData : Vector2[]
);

Parameters

texelData Microsoft.DirectX.Vector2[]
An array of Vector2 objects that contain the location in pixel (u, v) texture coordinates where each texel is located.

Remarks

For class 2 and 4 texels, the returned (u, v) texture coordinates correspond to the closest point on the closest triangle.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.SetTexelMap


TextureGutterHelper.op_Equality(TextureGutterHelper,TextureGutterHelper) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As TextureGutterHelper, _
ByVal right As TextureGutterHelper _
) As Boolean
C# public static bool op_Equality(
TextureGutterHelper left,
TextureGutterHelper right
);
C++ public:
static bool operator==(
TextureGutterHelper^ left,
TextureGutterHelper^ right
);
JScript public static function op_Equality(
left : TextureGutterHelper,
right : TextureGutterHelper
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.TextureGutterHelper
The TextureGutterHelper object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.TextureGutterHelper
The TextureGutterHelper object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


TextureGutterHelper.op_Inequality(TextureGutterHelper,TextureGutterHelper) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As TextureGutterHelper, _
ByVal right As TextureGutterHelper _
) As Boolean
C# public static bool op_Inequality(
TextureGutterHelper left,
TextureGutterHelper right
);
C++ public:
static bool operator!=(
TextureGutterHelper^ left,
TextureGutterHelper^ right
);
JScript public static function op_Inequality(
left : TextureGutterHelper,
right : TextureGutterHelper
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.TextureGutterHelper
The TextureGutterHelper object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.TextureGutterHelper
The TextureGutterHelper object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


TextureGutterHelper.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


TextureGutterHelper.ResampleTexture(Texture, Mesh, DeclarationUsage, Texture) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.ResampleTexture Method

Resamples a texture into this gutterhelper's parameterization.

Definition

Visual Basic Public Sub ResampleTexture( _
ByVal texture As Texture, _
ByVal mesh As Mesh, _
ByVal usage As DeclarationUsage, _
ByVal usageIndex As Integer, _
ByVal textureOut As Texture _
)
C# public void ResampleTexture(
Texture texture,
Mesh mesh,
DeclarationUsage usage,
int usageIndex,
Texture textureOut
);
C++ public:
void ResampleTexture(
Texture texture,
Mesh mesh,
DeclarationUsage usage,
int usageIndex,
Texture textureOut
);
JScript public function ResampleTexture(
texture : Texture,
mesh : Mesh,
usage : DeclarationUsage,
usageIndex : int,
textureOut : Texture
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture
A Texture object that corresponds to the original parameterization stored in mesh. This texture will be used to create textureOut.
mesh Microsoft.DirectX.Direct3D.Mesh
A Mesh object containing the original and new parameterizations. It is required to store the new parameterization in TextureCoordinate index 0.
usage Microsoft.DirectX.Direct3D.DeclarationUsage
A DeclarationUsage object (used in combination with usageIndex) which identifies the component of the vertex declaration that contains the original parameterization in mesh.
usageIndex System.Int32
Zero-based index (used in combination with usage), which identifies the component of the vertex declaration that contains the original parameterization in mesh. The combination of TextureCoordinate and index 0 is required for the new parameterization; any other usage/index combination may be used.
textureOut Microsoft.DirectX.Direct3D.Texture
The resampled Texture object.

Remarks

A parameterization in the case of this function is a set of texture coordinates that maps the triangles of a mesh to the triangles on a texture. The new parameterization is the set of texture coordinates contained in the gutter helper interface, and the original parameterization is the set of texture coordinates contained within the input mesh.

It is assumed that texture coordinates are between 0 and 1, inclusive, and the new parameterization must be declared in the vertex declaration as texture coordinate index 0. The original texture and the resampled texture must have the same width and height.

One common scenario might be to use UVAtlas to create a texture atlas and then use ResampleTexture to resample the texture into the new parameterization.


TextureGutterHelper.SetBaryMap(Vector2[]) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.SetBaryMap Method

Sets texel barycentric coordinates.

Definition

Visual Basic Public Sub SetBaryMap( _
ByVal baryData() As Vector2 _
)
C# public void SetBaryMap(
Vector2[] baryData
);
C++ public:
void SetBaryMap(
array<Vector2>^ baryData
);
JScript public function SetBaryMap(
baryData : Vector2[]
);

Parameters

baryData Microsoft.DirectX.Vector2[]
An array of Vector2 objects that contain the first two barycentric coordinates of each texel.

Remarks

The third barycentric coordinate is given by:

1 - (baryData.x + baryData.y)

The barycentric coordinates input to this method are valid only for valid (non-class 0) texels. TextureGutterHelper.GetGutterMap will return non-zero values for valid texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.GetBaryMap


TextureGutterHelper.SetFaceMap(Int32[]) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.SetFaceMap Method

Sets the index of the mesh face to which each texel belongs.

Definition

Visual Basic Public Sub SetFaceMap( _
ByVal faceData() As Integer _
)
C# public void SetFaceMap(
int[] faceData
);
C++ public:
void SetFaceMap(
array<int>^ faceData
);
JScript public function SetFaceMap(
faceData : int[]
);

Parameters

faceData System.Int32[]
An integer array containing index values of the mesh face to which each texel belongs.

Remarks

The mesh face data input to this method is valid only for valid (non-class 0) texels. TextureGutterHelper.GetGutterMap will return nonzero values for valid (non-class 0) texels.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.GetFaceMap


TextureGutterHelper.SetGutterMap(Byte[]) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.SetGutterMap Method

Sets a texel class value that indicates texel class according to each texel's location.

Definition

Visual Basic Public Sub SetGutterMap( _
ByVal gutterData() As Byte _
)
C# public void SetGutterMap(
byte[] gutterData
);
C++ public:
void SetGutterMap(
array<unsigned char>^ gutterData
);
JScript public function SetGutterMap(
gutterData : byte[]
);

Parameters

gutterData System.Byte[]
A Byte Leave Site array that contains texel class data, to set.

Remarks

Possible texel classes are as follows:

Texel Class | Texel Location
0 | Invalid point; texel will not be used.
1 | Inside triangle.
2 | Inside gutter.
4 | Inside gutter; texel will be evaluated as a full sample in the ApplyGutters method.

There is no texel class 3.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.GetGutterMap


TextureGutterHelper.SetTexelMap(Vector2[]) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.SetTexelMap Method

Sets the (u, v) texture coordinates of each texel.

Definition

Visual Basic Public Sub SetTexelMap( _
ByVal texelData() As Vector2 _
)
C# public void SetTexelMap(
Vector2[] texelData
);
C++ public:
void SetTexelMap(
array<Vector2>^ texelData
);
JScript public function SetTexelMap(
texelData : Vector2[]
);

Parameters

texelData Microsoft.DirectX.Vector2[]
An array of Vector2 objects that contain the location in pixel (u, v) texture coordinates where each texel is located.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • TextureGutterHelper.GetTexelMap


TextureGutterHelper.TextureGutterHelper Constructor ()

Initializes a new instance of the TextureGutterHelper class.

Overload List

public TextureGutterHelper(ID3DXTextureGutterHelper);
public TextureGutterHelper(int, int, float, Mesh);
public TextureGutterHelper(IntPtr);

Remarks

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


TextureGutterHelper.TextureGutterHelper(ID3DXTextureGutterHelper) Constructor (Microsoft.DirectX.Direct3D)

TextureGutterHelper.TextureGutterHelper Constructor

Initializes a new instance of the TextureGutterHelper class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXTextureGutterHelper _
)
C# public TextureGutterHelper(
ID3DXTextureGutterHelper pUnk
);
C++ public:
TextureGutterHelper(
ID3DXTextureGutterHelper pUnk
);
JScript public function TextureGutterHelper(
pUnk : ID3DXTextureGutterHelper
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureGutterHelper
Unmanaged Component Object Model (COM) ID3DXTextureGutterHelper interface pointer.

Remarks

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


TextureGutterHelper.TextureGutterHelper(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

TextureGutterHelper.TextureGutterHelper Constructor

Initializes a new instance of the TextureGutterHelper class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public TextureGutterHelper(
IntPtr unmanagedObject
);
C++ public:
TextureGutterHelper(
IntPtr unmanagedObject
);
JScript public function TextureGutterHelper(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXTextureGutterHelper interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


TextureGutterHelper.TextureGutterHelper(Int32,Int32,Single,Mesh) Constructor (Microsoft.DirectX.Direct3D)

TextureGutterHelper.TextureGutterHelper Constructor

Initializes a new instance of the TextureGutterHelper class.

Definition

Visual Basic Public Sub New( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal gutterSize As Single, _
ByVal mesh As Mesh _
)
C# public TextureGutterHelper(
int width,
int height,
float gutterSize,
Mesh mesh
);
C++ public:
TextureGutterHelper(
int width,
int height,
float gutterSize,
Mesh^ mesh
);
JScript public function TextureGutterHelper(
width : int,
height : int,
gutterSize : float,
mesh : Mesh
);

Parameters

width System.Int32
Width of the texture, in pixels
height System.Int32
Height of the texture, in pixels.
gutterSize System.Single
Number of texels by which to over-sample the texture and create the gutter region. Must be at least 1.
mesh Microsoft.DirectX.Direct3D.Mesh
An input Mesh object.

Remarks

Use PrtEngine.ConcatenateMeshes to transform a scene to new coordinates.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Microsoft Direct3D could not allocate sufficient memory to complete the call.


TextureGutterHelper.UpdateUnmanagedPointer(ID3DXTextureGutterHelper) Method (Microsoft.DirectX.Direct3D)

TextureGutterHelper.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this TextureGutterHelper object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXTextureGutterHelper _
)
C# public void UpdateUnmanagedPointer(
ID3DXTextureGutterHelper pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXTextureGutterHelper pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXTextureGutterHelper
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureGutterHelper
Pointer to the ID3DXTextureGutterHelper structure used to update the unmanaged pointer for this TextureGutterHelper object.


TextureGutterHelper.Disposed Property (Microsoft.DirectX.Direct3D)

TextureGutterHelper.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


TextureGutterHelper.Height Property (Microsoft.DirectX.Direct3D)

TextureGutterHelper.Height Property

Retrieves the height of the texture, in pixels.

Definition

Visual Basic | Public ReadOnly Property Height As Integer
C# | public int Height { get; }
C++ public:
property int Height {
int get();
}
JScript | public function get Height() : int

Property Value

System.Int32
The height of the texture, in pixels.

This property is read-only.

See Also

  • TextureGutterHelper.Width


TextureGutterHelper.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

TextureGutterHelper.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXTextureGutterHelper interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXTextureGutterHelper
C# | public ID3DXTextureGutterHelper UnmanagedComPointer { get; }
C++ public:
property ID3DXTextureGutterHelper UnmanagedComPointer {
ID3DXTextureGutterHelper get();
}
JScript | public function get UnmanagedComPointer() : ID3DXTextureGutterHelper

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureGutterHelper
Unmanaged ID3DXTextureGutterHelper interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


TextureGutterHelper.Width Property (Microsoft.DirectX.Direct3D)

TextureGutterHelper.Width Property

Retrieves the width of the texture, in pixels.

Definition

Visual Basic | Public ReadOnly Property Width As Integer
C# | public int Width { get; }
C++ public:
property int Width {
int get();
}
JScript | public function get Width() : int

Property Value

System.Int32
The width of the texture, in pixels.

This property is read-only.

See Also

  • TextureGutterHelper.Height


TextureGutterHelper.Disposing Event (Microsoft.DirectX.Direct3D)

TextureGutterHelper.Disposing Event

Occurs when the Dispose method is called or when the TextureGutterHelper object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.TextureGutterHelper.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the TextureGutterHelper object indicates whether that object has been disposed.


TextureLoader Class (Microsoft.DirectX.Direct3D)

TextureLoader Class

Contains functions to load and save textures.

Definition

Visual Basic NotInheritable MustInherit Public Class TextureLoader
Inherits Object
C# | public abstract sealed class TextureLoader : Object
C++ | public ref class TextureLoader abstract sealed : Object
JScript | public final abstract class TextureLoader extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) CheckCubeTextureRequirements | Checks creation parameters for a cube texture.
static (Shared in Visual Basic) CheckTextureRequirements | Checks creation parameters for a texture.
static (Shared in Visual Basic) CheckVolumeTextureRequirements | Checks creation parameters for a volume texture.
static (Shared in Visual Basic) ComputeNormalMap | Converts a height map into a normal map.
static (Shared in Visual Basic) FillTexture | Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.
static (Shared in Visual Basic) FilterTexture | Filters mipmap levels of a texture.
static (Shared in Visual Basic) FromCubeFile | Creates a cube texture from a file.
static (Shared in Visual Basic) FromCubeStream | Creates a cube texture from a file in memory.
static (Shared in Visual Basic) FromFile | Creates a texture from a file.
static (Shared in Visual Basic) FromStream | Creates a texture from a file in memory.
static (Shared in Visual Basic) FromVolumeFile | Creates a volume texture from a file.
static (Shared in Visual Basic) FromVolumeStream | Creates a volume texture from a file in memory.
static (Shared in Visual Basic) ImageInformationFromFile | Retrieves information about a given image file.
static (Shared in Visual Basic) ImageInformationFromStream | Retrieves information about an image file in memory.
static (Shared in Visual Basic) Save | Saves a texture to a file.
static (Shared in Visual Basic) SaveToStream | Saves a volume to a graphics stream.

Inheritance Hierarchy

Object Leave Site
TextureLoader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureLoader.CheckCubeTextureRequirements(Device,Usage,Pool,CubeTextureRequirements) Method (Microsoft.DirectX.Direct3D)

TextureLoader.CheckCubeTextureRequirements Method

How Do I...?
  • Create a Cube Texture

Checks creation parameters for a cube texture.

Definition

Visual Basic Public Shared Sub CheckCubeTextureRequirements( _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool, _
ByRef requirements As CubeTextureRequirements _
)
C# public static void CheckCubeTextureRequirements(
Device device,
Usage usage,
Pool pool,
out CubeTextureRequirements requirements
);
C++ public:
static void CheckCubeTextureRequirements(
Device^ device,
Usage usage,
Pool pool,
[Out] CubeTextureRequirements% requirements
);
JScript public static function CheckCubeTextureRequirements(
device : Device,
usage : Usage,
pool : Pool,
requirements : CubeTextureRequirements
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device class that represents the device to associate with the cube texture.
usage Microsoft.DirectX.Direct3D.Usage
Value that is either 0 or Usage.RenderTarget. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.
requirements Microsoft.DirectX.Direct3D.CubeTextureRequirements
A CubeTextureRequirements structure that contains the cube texture creation parameters.

Remarks

If invalid parameters are passed to this method, it returns corrected parameters.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

Exceptions
NotAvailableException | This device does not support the queried technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );

See Also

  • CheckTextureRequirements
  • CheckVolumeTextureRequirements


TextureLoader.CheckTextureRequirements(Device,Usage,Pool,TextureRequirements) Method (Microsoft.DirectX.Direct3D)

TextureLoader.CheckTextureRequirements Method

Checks creation parameters for a texture.

Definition

Visual Basic Public Shared Sub CheckTextureRequirements( _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal pool As Pool, _
ByRef requirements As TextureRequirements _
)
C# public static void CheckTextureRequirements(
Device device,
Usage usage,
Pool pool,
out TextureRequirements requirements
);
C++ public:
static void CheckTextureRequirements(
Device^ device,
Usage usage,
Pool pool,
[Out] TextureRequirements% requirements
);
JScript public static function CheckTextureRequirements(
device : Device,
usage : Usage,
pool : Pool,
requirements : TextureRequirements
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
usage Microsoft.DirectX.Direct3D.Usage
Value that is either 0 or Usage.RenderTarget. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.
requirements Microsoft.DirectX.Direct3D.TextureRequirements
A TextureRequirements structure that contains the texture creation parameters.

Remarks

If invalid parameters are passed to this method, it returns corrected parameters.

Exceptions
NotAvailableException | This device does not support the queried technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CheckCubeTextureRequirements
  • CheckVolumeTextureRequirements


TextureLoader.CheckVolumeTextureRequirements(Device,Pool,VolumeTextureRequirements) Method (Microsoft.DirectX.Direct3D)

TextureLoader.CheckVolumeTextureRequirements Method

Checks creation parameters for a volume texture.

Definition

Visual Basic Public Shared Sub CheckVolumeTextureRequirements( _
ByVal device As Device, _
ByVal pool As Pool, _
ByRef requirements As VolumeTextureRequirements _
)
C# public static void CheckVolumeTextureRequirements(
Device device,
Pool pool,
out VolumeTextureRequirements requirements
);
C++ public:
static void CheckVolumeTextureRequirements(
Device^ device,
Pool pool,
[Out] VolumeTextureRequirements% requirements
);
JScript public static function CheckVolumeTextureRequirements(
device : Device,
pool : Pool,
requirements : VolumeTextureRequirements
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the texture should be placed.
requirements Microsoft.DirectX.Direct3D.VolumeTextureRequirements
A VolumeTextureRequirements structure that contains the volume texture creation parameters.

Remarks

If invalid parameters are passed to this method, it returns corrected parameters.

Exceptions
NotAvailableException | This device does not support the queried technique.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • CheckTextureRequirements
  • CheckCubeTextureRequirements


TextureLoader.ComputeNormalMap Method ()

Converts a height map into a normal map.

Overload List

public static void ComputeNormalMap(Texture, Texture, NormalMap, Channel, float);
public static void ComputeNormalMap(Texture, Texture, out PaletteEntry, NormalMap, Channel, float);

Remarks

This method computes the normal by using the central difference with a kernel size of 3x3. The (x,y,z) components of each normal are mapped to the (r,g,b) channels of the output texture. RGB channels in the destination contain biased (x,y,z) components of the normal.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ComputeNormalMap(Texture,Texture,NormalMap,Channel,Single) Method (Microsoft.DirectX.Direct3D)

TextureLoader.ComputeNormalMap Method

Converts a height map into a normal map.

Definition

Visual Basic Public Shared Sub ComputeNormalMap( _
ByVal texture As Texture, _
ByVal srcTexture As Texture, _
ByVal flags As NormalMap, _
ByVal channel As Channel, _
ByVal amplitude As Single _
)
C# public static void ComputeNormalMap(
Texture texture,
Texture srcTexture,
NormalMap flags,
Channel channel,
float amplitude
);
C++ public:
static void ComputeNormalMap(
Texture^ texture,
Texture^ srcTexture,
NormalMap flags,
Channel channel,
float amplitude
);
JScript public static function ComputeNormalMap(
texture : Texture,
srcTexture : Texture,
flags : NormalMap,
channel : Channel,
amplitude : float
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the destination texture.
srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the source height-map texture.
flags Microsoft.DirectX.Direct3D.NormalMap
One or more NormalMap flags that indicate creation options.
channel Microsoft.DirectX.Direct3D.Channel
A Channel flag that specifies the source of the height information.
amplitude System.Single
Constant value by which the height information is multiplied.

Remarks

This method computes the normal by using the central difference with a kernel size of 3x3. The (x,y,z) components of each normal are mapped to the (r,g,b) channels of the output texture. RGB channels in the destination contain biased (x,y,z) components of the normal.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ComputeNormalMap(Texture,Texture,PaletteEntry,NormalMap,Channel,Single) Method (Microsoft.DirectX.Direct3D)

TextureLoader.ComputeNormalMap Method

Converts a height map into a normal map.

Definition

Visual Basic Public Shared Sub ComputeNormalMap( _
ByVal texture As Texture, _
ByVal srcTexture As Texture, _
ByRef sourcePalette As PaletteEntry, _
ByVal flags As NormalMap, _
ByVal channel As Channel, _
ByVal amplitude As Single _
)
C# public static void ComputeNormalMap(
Texture texture,
Texture srcTexture,
out PaletteEntry sourcePalette,
NormalMap flags,
Channel channel,
float amplitude
);
C++ public:
static void ComputeNormalMap(
Texture^ texture,
Texture^ srcTexture,
[Out] PaletteEntry% sourcePalette,
NormalMap flags,
Channel channel,
float amplitude
);
JScript public static function ComputeNormalMap(
texture : Texture,
srcTexture : Texture,
sourcePalette : PaletteEntry,
flags : NormalMap,
channel : Channel,
amplitude : float
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the destination texture.
srcTexture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the source height-map texture.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the mapped normals.
flags Microsoft.DirectX.Direct3D.NormalMap
One or more NormalMap flags that indicate creation options.
channel Microsoft.DirectX.Direct3D.Channel
A Channel flag that specifies the source of the height information.
amplitude System.Single
Constant value by which the height information is multiplied.

Remarks

This method computes the normal by using the central difference with a kernel size of 3x3. The (x,y,z) components of each normal are mapped to the (r,g,b) channels of the output texture. RGB channels in the destination contain biased (x,y,z) components of the normal.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.FillTexture Method ()

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Overload List

public static void FillTexture(CubeTexture, Fill3DTextureCallback);
public static void FillTexture(CubeTexture, TextureShader);
public static void FillTexture(Texture, Fill2DTextureCallback);
public static void FillTexture(Texture, TextureShader);
public static void FillTexture(VolumeTexture, Fill3DTextureCallback);
public static void FillTexture(VolumeTexture, TextureShader);

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(VolumeTexture,TextureShader) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FillTexture Method

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic Public Shared Sub FillTexture( _
ByVal texture As VolumeTexture, _
ByVal textureShader As TextureShader _
)
C# public static void FillTexture(
VolumeTexture texture,
TextureShader textureShader
);
C++ public:
static void FillTexture(
VolumeTexture^ texture,
TextureShader^ textureShader
);
JScript public static function FillTexture(
texture : VolumeTexture,
textureShader : TextureShader
);

Parameters

texture Microsoft.DirectX.Direct3D.VolumeTexture
A VolumeTexture object that represents the filled texture.
textureShader Microsoft.DirectX.Direct3D.TextureShader
A TextureShader object that contains the compiled HLSL function. This can be created using ShaderLoader.CompileShader, ShaderLoader.CompileShaderFromStream, or ShaderLoader.CompileShaderFromFile.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(CubeTexture,TextureShader) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FillTexture Method

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic Public Shared Sub FillTexture( _
ByVal texture As CubeTexture, _
ByVal textureShader As TextureShader _
)
C# public static void FillTexture(
CubeTexture texture,
TextureShader textureShader
);
C++ public:
static void FillTexture(
CubeTexture^ texture,
TextureShader^ textureShader
);
JScript public static function FillTexture(
texture : CubeTexture,
textureShader : TextureShader
);

Parameters

texture Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the filled texture.
textureShader Microsoft.DirectX.Direct3D.TextureShader
A TextureShader object that contains the compiled HLSL function. This can be created using ShaderLoader.CompileShader, ShaderLoader.CompileShaderFromStream, or ShaderLoader.CompileShaderFromFile.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(Texture,TextureShader) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FillTexture Method

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic Public Shared Sub FillTexture( _
ByVal texture As Texture, _
ByVal textureShader As TextureShader _
)
C# public static void FillTexture(
Texture texture,
TextureShader textureShader
);
C++ public:
static void FillTexture(
Texture^ texture,
TextureShader^ textureShader
);
JScript public static function FillTexture(
texture : Texture,
textureShader : TextureShader
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the filled texture.
textureShader Microsoft.DirectX.Direct3D.TextureShader
A TextureShader object that contains the compiled HLSL function. This can be created using ShaderLoader.CompileShader, ShaderLoader.CompileShaderFromStream, or ShaderLoader.CompileShaderFromFile.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(VolumeTexture,Fill3DTextureCallback) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FillTexture Method

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic Public Shared Sub FillTexture( _
ByVal texture As VolumeTexture, _
ByVal callbackFunction As Fill3DTextureCallback _
)
C# public static void FillTexture(
VolumeTexture texture,
Fill3DTextureCallback callbackFunction
);
C++ public:
static void FillTexture(
VolumeTexture^ texture,
Fill3DTextureCallback^ callbackFunction
);
JScript public static function FillTexture(
texture : VolumeTexture,
callbackFunction : Fill3DTextureCallback
);

Parameters

texture Microsoft.DirectX.Direct3D.VolumeTexture
A VolumeTexture object that represents the filled texture.
callbackFunction Microsoft.DirectX.Direct3D.Fill3DTextureCallback
User-provided Fill3DTextureCallback delegate that is used to compute the value of each texel.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(CubeTexture,Fill3DTextureCallback) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FillTexture Method

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic Public Shared Sub FillTexture( _
ByVal texture As CubeTexture, _
ByVal callbackFunction As Fill3DTextureCallback _
)
C# public static void FillTexture(
CubeTexture texture,
Fill3DTextureCallback callbackFunction
);
C++ public:
static void FillTexture(
CubeTexture^ texture,
Fill3DTextureCallback^ callbackFunction
);
JScript public static function FillTexture(
texture : CubeTexture,
callbackFunction : Fill3DTextureCallback
);

Parameters

texture Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the filled texture.
callbackFunction Microsoft.DirectX.Direct3D.Fill3DTextureCallback
User-provided Fill3DTextureCallback delegate that is used to compute the value of each texel.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FillTexture(Texture,Fill2DTextureCallback) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FillTexture Method

Uses a user-provided function or a compiled high-level shader language (HLSL) function to fill each texel of each mip level of a given texture.

Definition

Visual Basic Public Shared Sub FillTexture( _
ByVal texture As Texture, _
ByVal callbackFunction As Fill2DTextureCallback _
)
C# public static void FillTexture(
Texture texture,
Fill2DTextureCallback callbackFunction
);
C++ public:
static void FillTexture(
Texture^ texture,
Fill2DTextureCallback^ callbackFunction
);
JScript public static function FillTexture(
texture : Texture,
callbackFunction : Fill2DTextureCallback
);

Parameters

texture Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the filled texture.
callbackFunction Microsoft.DirectX.Direct3D.Fill2DTextureCallback
User-provided Fill2DTextureCallback delegate that is used to compute the value of each texel.

Remarks

If the param_GraphicsStream_compiledCode parameter is used, the HLSL function must contain the following semantics:

  • One input parameter must use a POSITION semantic.
  • One input parameter must use a PSIZE semantic.
  • The function must return a parameter that uses the COLOR semantic.

The following is a C# code example of such an HLSL function:

[C#]
float4 TextureGradientFill(
  float2 vTexCoord : POSITION,
  float2 vTexelSize : PSIZE) : COLOR
  {
    float r,g, b, xSq,ySq, a;
    xSq = 2.f*vTexCoord.x-1.f; xSq *= xSq;
    ySq = 2.f*vTexCoord.y-1.f; ySq *= ySq;
    a = sqrt(xSq+ySq);
    if (a > 1.0f) {
        a = 1.0f-(a-1.0f);
    }
    else if (a < 0.2f) {
        a = 0.2f;
    }
    r = 1-vTexCoord.x;
    g = 1-vTexCoord.y;
    b = vTexCoord.x;
    return float4(r, g, b, a);

  };

Note that the input parameters can be in any order, but both input semantics must be represented.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotAvailableException | This device does not support the queried technique.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureLoader.FilterTexture Method ()

Filters mipmap levels of a texture.

Overload List

public static void FilterTexture(BaseTexture, int, Filter);
public static void FilterTexture(BaseTexture, out PaletteEntry, int, Filter);

Remarks

A filter is recursively applied to each texture level to generate the next texture level.

Writing to a surface that is not on the "zero" level of the texture does not cause the dirty rectangle to be updated. If FilterTexture is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRectangle on the texture.

Textures created in the default pool (Pool.Default) cannot be used with FilterTexture (unless created with Usage.Dynamic), because a lock operation on the object is necessary. Note that locks are prohibited on textures in the default pool (unless they are dynamic).

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


TextureLoader.FilterTexture(BaseTexture,Int32,Filter) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FilterTexture Method

Filters mipmap levels of a texture.

Definition

Visual Basic Public Shared Sub FilterTexture( _
ByVal baseTexture As BaseTexture, _
ByVal srcLevel As Integer, _
ByVal filter As Filter _
)
C# public static void FilterTexture(
BaseTexture baseTexture,
int srcLevel,
Filter filter
);
C++ public:
static void FilterTexture(
BaseTexture^ baseTexture,
int srcLevel,
Filter filter
);
JScript public static function FilterTexture(
baseTexture : BaseTexture,
srcLevel : int,
filter : Filter
);

Parameters

baseTexture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that represents the texture object to filter.
srcLevel System.Int32
Level whose image is used to generate subsequent levels. A common value for this parameter is 0.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter values that control how the mipmap is filtered.

Remarks

A filter is recursively applied to each texture level to generate the next texture level.

Writing to a surface that is not on the "zero" level of the texture does not cause the dirty rectangle to be updated. If FilterTexture is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRectangle on the texture.

Textures created in the default pool (Pool.Default) cannot be used with FilterTexture (unless created with Usage.Dynamic), because a lock operation on the object is necessary. Note that locks are prohibited on textures in the default pool (unless they are dynamic).

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


TextureLoader.FilterTexture(BaseTexture,PaletteEntry,Int32,Filter) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FilterTexture Method

Filters mipmap levels of a texture.

Definition

Visual Basic Public Shared Sub FilterTexture( _
ByVal baseTexture As BaseTexture, _
ByRef palette As PaletteEntry, _
ByVal srcLevel As Integer, _
ByVal filter As Filter _
)
C# public static void FilterTexture(
BaseTexture baseTexture,
out PaletteEntry palette,
int srcLevel,
Filter filter
);
C++ public:
static void FilterTexture(
BaseTexture^ baseTexture,
[Out] PaletteEntry% palette,
int srcLevel,
Filter filter
);
JScript public static function FilterTexture(
baseTexture : BaseTexture,
palette : PaletteEntry,
srcLevel : int,
filter : Filter
);

Parameters

baseTexture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that represents the texture object to filter.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in. For formats that are not palletized, use 0. If a palette is not specified, the default Microsoft Direct3D palette (an all-opaque white palette) is provided. See Remarks.
srcLevel System.Int32
Level whose image is used to generate subsequent levels. A common value for this parameter is 0.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter values that control how the mipmap is filtered.

Remarks

A filter is recursively applied to each texture level to generate the next texture level.

Writing to a surface that is not on the "zero" level of the texture does not cause the dirty rectangle to be updated. If FilterTexture is called and the surface is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call Texture.AddDirtyRectangle on the texture.

Textures created in the default pool (Pool.Default) cannot be used with FilterTexture (unless created with Usage.Dynamic), because a lock operation on the object is necessary. Note that locks are prohibited on textures in the default pool (unless they are dynamic).

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.


TextureLoader.FromCubeFile Method ()

Creates a cube texture from a file.

Overload List

public static CubeTexture FromCubeFile(Device, string);
public static CubeTexture FromCubeFile(Device, string, int, int, Usage, Format, Pool, Filter, Filter, int);
public static CubeTexture FromCubeFile(Device, string, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static CubeTexture FromCubeFile(Device, string, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static CubeTexture FromCubeFile(Device, string, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeFile Method

Creates a cube texture from a file.

Definition

Visual Basic Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static CubeTexture^ FromCubeFile(
Device^ device,
String^ srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromCubeFile(
device : Device,
srcFile : String,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
srcFile System.String
String that specifies the file name.
size System.Int32
Width and height of the cube texture, in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This value is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeFile Method

Creates a cube texture from a file.

Definition

Visual Basic Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static CubeTexture^ FromCubeFile(
Device^ device,
String^ srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromCubeFile(
device : Device,
srcFile : String,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
srcFile System.String
String that specifies the file name.
size System.Int32
Width and height of the cube texture, in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This value is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeFile Method

Creates a cube texture from a file.

Definition

Visual Basic Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static CubeTexture^ FromCubeFile(
Device^ device,
String^ srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromCubeFile(
device : Device,
srcFile : String,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
srcFile System.String
String that specifies the file name.
size System.Int32
Width and height of the cube texture, in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This value is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeFile Method

Creates a cube texture from a file.

Definition

Visual Basic Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
C++ public:
static CubeTexture^ FromCubeFile(
Device^ device,
String^ srcFile,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation,
[Out] PaletteEntry% palette
);
JScript public static function FromCubeFile(
device : Device,
srcFile : String,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
srcFile System.String
String that specifies the file name.
size System.Int32
Width and height of the cube texture, in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This value is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure to fill with a description of the data in the source image file, or 0.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeFile(Device,String) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeFile Method

Creates a cube texture from a file.

Definition

Visual Basic Public Shared Function FromCubeFile( _
ByVal device As Device, _
ByVal srcFile As String _
) As CubeTexture
C# public static CubeTexture FromCubeFile(
Device device,
string srcFile
);
C++ public:
static CubeTexture^ FromCubeFile(
Device^ device,
String^ srcFile
);
JScript public static function FromCubeFile(
device : Device,
srcFile : String
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
srcFile System.String
String that specifies the file name.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromCubeStream Method ()

Creates a cube texture from a file in memory.

Overload List

public static CubeTexture FromCubeStream(Device, Stream);
public static CubeTexture FromCubeStream(Device, Stream, int);
public static CubeTexture FromCubeStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static CubeTexture FromCubeStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static CubeTexture FromCubeStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static CubeTexture FromCubeStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);
public static CubeTexture FromCubeStream(Device, Stream, int, int, Usage, Format, Pool, Filter, Filter, int);
public static CubeTexture FromCubeStream(Device, Stream, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static CubeTexture FromCubeStream(Device, Stream, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.
size System.Int32
Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.
size System.Int32
Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.
size System.Int32
Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes System.Int32
Size of the file in memory, in bytes.
size System.Int32
Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes System.Int32
Size of the file in memory, in bytes.
size System.Int32
Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes System.Int32
Size of the file in memory, in bytes.
size System.Int32
Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal size As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream,
int readBytes,
int size,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation,
[Out] PaletteEntry% palette
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int,
size : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes System.Int32
Size of the file in memory, in bytes.
size System.Int32
Width and height of the cube texture in pixels. For example, if the cube texture is an 8-pixel by 8-pixel cube, the value is 8. If the value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface should be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. The color key is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value equals 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromCubeStream(Device,Stream,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromCubeStream Method

Creates a cube texture from a file in memory.

Definition

Visual Basic Public Shared Function FromCubeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer _
) As CubeTexture
C# public static CubeTexture FromCubeStream(
Device device,
Stream stream,
int readBytes
);
C++ public:
static CubeTexture^ FromCubeStream(
Device^ device,
Stream^ stream,
int readBytes
);
JScript public static function FromCubeStream(
device : Device,
stream : Stream,
readBytes : int
) : CubeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the cube texture.
stream System.IO.Stream
A Stream Leave Site from which to create the cube texture. See Remarks.
readBytes System.Int32
Size of the file in memory, in bytes.

Return Value

Microsoft.DirectX.Direct3D.CubeTexture
A CubeTexture object that represents the created cube texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

The TextureLoader.FromCubeFile method uses the Microsoft DirectDraw surface (DDS) file format. The DXTex tool enables generation of a cube map from other file formats, and saves it as a .dds file.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromStream


TextureLoader.FromFile Method ()

Creates a texture from a file.

Overload List

public static Texture FromFile(Device, string);
public static Texture FromFile(Device, string, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static Texture FromFile(Device, string, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static Texture FromFile(Device, string, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static Texture FromFile(Device, string, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft DirectX texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromFile Method

Creates a texture from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static Texture^ FromFile(
Device^ device,
String^ srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromFile(
device : Device,
srcFile : String,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
srcFile System.String
String that specifies the file name.
width System.Int32
Width of the texture in pixels. If this value is zero, the dimensions are taken from the file.
height System.Int32
Height of the texture in pixels. If this value is zero, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft DirectX texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromFile Method

Creates a texture from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static Texture^ FromFile(
Device^ device,
String^ srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromFile(
device : Device,
srcFile : String,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
srcFile System.String
String that specifies the file name.
width System.Int32
Width of the texture in pixels. If this value is zero, the dimensions are taken from the file.
height System.Int32
Height of the texture in pixels. If this value is zero, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered. In addition, use bits 27-31 to specify the number of mip levels to be skipped (from the top of the mipmap chain) when a .dds texture is loaded into memory; this allows you to skip up to 32 levels.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft DirectX texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromFile Method

Creates a texture from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static Texture^ FromFile(
Device^ device,
String^ srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
device : Device,
srcFile : String,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
srcFile System.String
String that specifies the file name.
width System.Int32
Width of the texture in pixels. If this value is zero, the dimensions are taken from the file.
height System.Int32
Height of the texture in pixels. If this value is zero, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered. In addition, use bits 27-31 to specify the number of mip levels to be skipped (from the top of the mipmap chain) when a .dds texture is loaded into memory; this allows you to skip up to 32 levels.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft DirectX texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromFile Method

Creates a texture from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
C++ public:
static Texture^ FromFile(
Device^ device,
String^ srcFile,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation,
[Out] PaletteEntry% palette
);
JScript public static function FromFile(
device : Device,
srcFile : String,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
srcFile System.String
String that specifies the file name.
width System.Int32
Width of the texture in pixels. If this value is zero, the dimensions are taken from the file.
height System.Int32
Height of the texture in pixels. If this value is zero, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered. In addition, use bits 27-31 to specify the number of mip levels to be skipped (from the top of the mipmap chain) when a .dds texture is loaded into memory; this allows you to skip up to 32 levels.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft DirectX texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromFile(Device,String) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromFile Method

Creates a texture from a file.

Definition

Visual Basic Public Shared Function FromFile( _
ByVal device As Device, _
ByVal srcFile As String _
) As Texture
C# public static Texture FromFile(
Device device,
string srcFile
);
C++ public:
static Texture^ FromFile(
Device^ device,
String^ srcFile
);
JScript public static function FromFile(
device : Device,
srcFile : String
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
srcFile System.String
String that specifies the file name.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Cube textures differ from other surfaces in that they are collections of surfaces. To call Device.SetRenderTarget with a cube texture, select an individual face using CubeTexture.GetCubeMapSurface and pass the resulting surface to Device.SetRenderTarget.

To get the best performance when using FromFile, consider the following:

  • Doing image scaling and format conversion at load time can be slow. Store images in the format and resolution in which they will be used. If the target hardware requires power of 2 dimensions, use it to create and store images.
  • For mipmap image creation at load time, filter using Box. A box filter is much faster than other filter types such as Triangle.
  • Consider using DDS files. Since they can be used to represent any Microsoft DirectX texture format, they are easily read by this method. Also, they can store mipmaps, which means that any mipmap-generation algorithms can be used to author the images.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeFile


TextureLoader.FromStream Method ()

Creates a texture from a file in memory.

Overload List

public static Texture FromStream(Device, Stream);
public static Texture FromStream(Device, Stream, int);
public static Texture FromStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static Texture FromStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static Texture FromStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static Texture FromStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);
public static Texture FromStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static Texture FromStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static Texture FromStream(Device, Stream, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromStream(
device : Device,
stream : Stream,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromStream(
device : Device,
stream : Stream,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
device : Device,
stream : Stream,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.
readBytes System.Int32
Size, in bytes, of the file in memory.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.
readBytes System.Int32
Size, in bytes, of the file in memory.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.
readBytes System.Int32
Size, in bytes, of the file in memory.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream,
int readBytes,
int width,
int height,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation,
[Out] PaletteEntry% palette
);
JScript public static function FromStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.
readBytes System.Int32
Size, in bytes, of the file in memory.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure that contains a description of the data in the source image file, or 0.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream
);
JScript public static function FromStream(
device : Device,
stream : Stream
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromStream(Device,Stream,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromStream Method

Creates a texture from a file in memory.

Definition

Visual Basic Public Shared Function FromStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer _
) As Texture
C# public static Texture FromStream(
Device device,
Stream stream,
int readBytes
);
C++ public:
static Texture^ FromStream(
Device^ device,
Stream^ stream,
int readBytes
);
JScript public static function FromStream(
device : Device,
stream : Stream,
readBytes : int
) : Texture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture. See Remarks.
readBytes System.Int32
Size, in bytes, of the file in memory.

Return Value

Microsoft.DirectX.Direct3D.Texture
A Texture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromFile
  • FromCubeStream


TextureLoader.FromVolumeFile Method ()

Creates a volume texture from a file.

Overload List

public static VolumeTexture FromVolumeFile(Device, string);
public static VolumeTexture FromVolumeFile(Device, string, int, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static VolumeTexture FromVolumeFile(Device, string, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static VolumeTexture FromVolumeFile(Device, string, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static VolumeTexture FromVolumeFile(Device, string, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeFile Method

Creates a volume texture from a file.

Definition

Visual Basic Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static VolumeTexture^ FromVolumeFile(
Device^ device,
String^ srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromVolumeFile(
device : Device,
srcFile : String,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
srcFile System.String
String that specifies the file name.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeFile Method

Creates a volume texture from a file.

Definition

Visual Basic Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static VolumeTexture^ FromVolumeFile(
Device^ device,
String^ srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromVolumeFile(
device : Device,
srcFile : String,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
srcFile System.String
String that specifies the file name.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeFile Method

Creates a volume texture from a file.

Definition

Visual Basic Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static VolumeTexture^ FromVolumeFile(
Device^ device,
String^ srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromVolumeFile(
device : Device,
srcFile : String,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
srcFile System.String
String that specifies the file name.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeFile Method

Creates a volume texture from a file.

Definition

Visual Basic Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
C++ public:
static VolumeTexture^ FromVolumeFile(
Device^ device,
String^ srcFile,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation,
[Out] PaletteEntry% palette
);
JScript public static function FromVolumeFile(
device : Device,
srcFile : String,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
srcFile System.String
String that specifies the file name.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeFile(Device,String) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeFile Method

Creates a volume texture from a file.

Definition

Visual Basic Public Shared Function FromVolumeFile( _
ByVal device As Device, _
ByVal srcFile As String _
) As VolumeTexture
C# public static VolumeTexture FromVolumeFile(
Device device,
string srcFile
);
C++ public:
static VolumeTexture^ FromVolumeFile(
Device^ device,
String^ srcFile
);
JScript public static function FromVolumeFile(
device : Device,
srcFile : String
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
srcFile System.String
String that specifies the file name.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Each level of a mipmapped texture is automatically filled with the loaded volume texture. When loading images into mipmapped textures, some devices are unable to switch to a 1x1 image. If this happens, the method fails, and the images must be loaded manually.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromCubeFile
  • FromVolumeStream
  • FromFile


TextureLoader.FromVolumeStream Method ()

Creates a volume texture from a file in memory.

Overload List

public static VolumeTexture FromVolumeStream(Device, Stream);
public static VolumeTexture FromVolumeStream(Device, Stream, int);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation, out PaletteEntry);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, ref ImageInformation);
public static VolumeTexture FromVolumeStream(Device, Stream, int, int, int, int, Usage, Format, Pool, Filter, Filter, int, out PaletteEntry);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.
readBytes System.Int32
Size, in bytes, of the file in memory.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
out PaletteEntry palette
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
[Out] PaletteEntry% palette
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.
readBytes System.Int32
Size, in bytes, of the file in memory.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.
readBytes System.Int32
Size, in bytes, of the file in memory.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32,Int32,Int32,Int32,Int32,Usage,Format,Pool,Filter,Filter,Int32,ImageInformation,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal mipLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool, _
ByVal filter As Filter, _
ByVal mipFilter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation, _
ByRef palette As PaletteEntry _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ref ImageInformation srcInformation,
out PaletteEntry palette
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream,
int readBytes,
int width,
int height,
int depth,
int mipLevels,
Usage usage,
Format format,
Pool pool,
Filter filter,
Filter mipFilter,
int colorKey,
ImageInformation% srcInformation,
[Out] PaletteEntry% palette
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int,
width : int,
height : int,
depth : int,
mipLevels : int,
usage : Usage,
format : Format,
pool : Pool,
filter : Filter,
mipFilter : Filter,
colorKey : int,
srcInformation : ImageInformation,
palette : PaletteEntry
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.
readBytes System.Int32
Size, in bytes, of the file in memory.
width System.Int32
Width in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
height System.Int32
Height in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
depth System.Int32
Depth in pixels. If this value is 0, the dimensions are taken from the file. The maximum dimension that a driver supports (for width, height, and depth) can be found in the Caps.MaxVolumeExtent property.
mipLevels System.Int32
Number of mip levels requested. If this value is 0, a complete mipmap chain is created.
usage Microsoft.DirectX.Direct3D.Usage
Zero or Usage.RenderTarget, or Usage.Dynamic. Setting this flag to Usage.RenderTarget indicates that the surface will be used as a render target. The resource can then be passed to the param_Surface_renderTarget parameter of the Device.SetRenderTarget method. If Usage.RenderTarget is specified, the application should determine whether the device supports this operation by calling Manager.CheckDeviceFormat. The Usage.Dynamic value indicates that the surface should be handled dynamically.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the requested pixel format for the cube texture. The returned cube texture might have a different format from that specified by param_Format_format. Applications should check the format of the returned cube texture. If param_Format_format is Unknown, the format is taken from the file.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the cube texture should be placed.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
mipFilter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the mipmaps are filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
[in, out] An ImageInformation structure that contains a description of the data in the source image file, or 0.
palette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.FromVolumeStream(Device,Stream,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.FromVolumeStream Method

Creates a volume texture from a file in memory.

Definition

Visual Basic Public Shared Function FromVolumeStream( _
ByVal device As Device, _
ByVal stream As Stream, _
ByVal readBytes As Integer _
) As VolumeTexture
C# public static VolumeTexture FromVolumeStream(
Device device,
Stream stream,
int readBytes
);
C++ public:
static VolumeTexture^ FromVolumeStream(
Device^ device,
Stream^ stream,
int readBytes
);
JScript public static function FromVolumeStream(
device : Device,
stream : Stream,
readBytes : int
) : VolumeTexture;

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object that represents the device to associate with the volume texture.
stream System.IO.Stream
A Stream Leave Site from which to create the texture.
readBytes System.Int32
Size, in bytes, of the file in memory.

Return Value

Microsoft.DirectX.Direct3D.VolumeTexture
Address of a pointer to a VolumeTexture object that represents the created texture object.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
NotAvailableException | This device does not support the queried technique.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • FromVolumeFile
  • FromFile


TextureLoader.ImageInformationFromFile(String) Method (Microsoft.DirectX.Direct3D)

TextureLoader.ImageInformationFromFile Method

Retrieves information about a given image file.

Definition

Visual Basic Public Shared Function ImageInformationFromFile( _
ByVal srcFile As String _
) As ImageInformation
C# public static ImageInformation ImageInformationFromFile(
string srcFile
);
C++ public:
static ImageInformation ImageInformationFromFile(
String^ srcFile
);
JScript public static function ImageInformationFromFile(
srcFile : String
) : ImageInformation;

Parameters

srcFile System.String
File name of the image whose information is being retrieved.

Return Value

Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure that contains the description of the data in the source file.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ImageInformationFromStream Method ()

Retrieves information about an image file in memory.

Overload List

public static ImageInformation ImageInformationFromStream(Stream);
public static ImageInformation ImageInformationFromStream(Stream, int);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ImageInformationFromStream(Stream) Method (Microsoft.DirectX.Direct3D)

TextureLoader.ImageInformationFromStream Method

Retrieves information about an image file in memory.

Definition

Visual Basic Public Shared Function ImageInformationFromStream( _
ByVal sourceStream As Stream _
) As ImageInformation
C# public static ImageInformation ImageInformationFromStream(
Stream sourceStream
);
C++ public:
static ImageInformation ImageInformationFromStream(
Stream^ sourceStream
);
JScript public static function ImageInformationFromStream(
sourceStream : Stream
) : ImageInformation;

Parameters

sourceStream System.IO.Stream
A Stream Leave Site object containing the image whose information is being retrieved.

Return Value

Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure that contains the description of the data in sourceStream.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.ImageInformationFromStream(Stream,Int32) Method (Microsoft.DirectX.Direct3D)

TextureLoader.ImageInformationFromStream Method

Retrieves information about an image file in memory.

Definition

Visual Basic Public Shared Function ImageInformationFromStream( _
ByVal sourceStream As Stream, _
ByVal readLength As Integer _
) As ImageInformation
C# public static ImageInformation ImageInformationFromStream(
Stream sourceStream,
int readLength
);
C++ public:
static ImageInformation ImageInformationFromStream(
Stream^ sourceStream,
int readLength
);
JScript public static function ImageInformationFromStream(
sourceStream : Stream,
readLength : int
) : ImageInformation;

Parameters

sourceStream System.IO.Stream
A Stream Leave Site object containing the image whose information is being retrieved.
readLength System.Int32
The size of the sourceStream data to read.

Return Value

Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure that contains the description of the data in sourceStream.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureLoader.Save Method ()

Saves a texture to a file.

Overload List

public static void Save(string, ImageFileFormat, BaseTexture);
public static void Save(string, ImageFileFormat, BaseTexture, out PaletteEntry);

Remarks

The Save method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is not dynamic (because a usage parameter was set to 0 at its creation) and is located in video memory (that is, the memory pool set to Default), this method fails because Microsoft Direct3D cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SurfaceLoader.Save
  • VolumeLoader.Save


TextureLoader.Save(String,ImageFileFormat,BaseTexture) Method (Microsoft.DirectX.Direct3D)

TextureLoader.Save Method

Saves a texture to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcTexture As BaseTexture _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
BaseTexture srcTexture
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
BaseTexture^ srcTexture
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcTexture : BaseTexture
);

Parameters

destFile System.String
String that specifies the file name of the source image.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat flag that specifies the file format to use when saving. See Remarks.
srcTexture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that contains the texture to save.

Remarks

The Save method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is not dynamic (because a usage parameter was set to 0 at its creation) and is located in video memory (that is, the memory pool set to Default), this method fails because Microsoft Direct3D cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SurfaceLoader.Save
  • VolumeLoader.Save


TextureLoader.Save(String,ImageFileFormat,BaseTexture,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.Save Method

Saves a texture to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcTexture As BaseTexture, _
ByRef sourcePalette As PaletteEntry _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
BaseTexture srcTexture,
out PaletteEntry sourcePalette
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
BaseTexture^ srcTexture,
[Out] PaletteEntry% sourcePalette
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcTexture : BaseTexture,
sourcePalette : PaletteEntry
);

Parameters

destFile System.String
String that specifies the file name of the source image.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat flag that specifies the file format to use when saving. See Remarks.
srcTexture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that contains the texture to save.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry structure that contains a 256-color palette. This parameter can be 0.

Remarks

The Save method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is not dynamic (because a usage parameter was set to 0 at its creation) and is located in video memory (that is, the memory pool set to Default), this method fails because Microsoft Direct3D cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • SurfaceLoader.Save
  • VolumeLoader.Save


TextureLoader.SaveToStream Method ()

Saves a volume to a graphics stream.

Overload List

public static GraphicsStream SaveToStream(ImageFileFormat, BaseTexture);
public static GraphicsStream SaveToStream(ImageFileFormat, BaseTexture, out PaletteEntry);

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Save


TextureLoader.SaveToStream(ImageFileFormat,BaseTexture) Method (Microsoft.DirectX.Direct3D)

TextureLoader.SaveToStream Method

Saves a volume to a graphics stream.

Definition

Visual Basic Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcTexture As BaseTexture _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
BaseTexture srcTexture
);
C++ public:
static GraphicsStream^ SaveToStream(
ImageFileFormat destFormat,
BaseTexture^ srcTexture
);
JScript public static function SaveToStream(
destFormat : ImageFileFormat,
srcTexture : BaseTexture
) : GraphicsStream;

Parameters

destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat flag that specifies the file format to use when saving. See Remarks.
srcTexture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that contains the texture to save.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the source image.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Save


TextureLoader.SaveToStream(ImageFileFormat,BaseTexture,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

TextureLoader.SaveToStream Method

Saves a volume to a graphics stream.

Definition

Visual Basic Public Shared Function SaveToStream( _
ByVal destFormat As ImageFileFormat, _
ByVal srcTexture As BaseTexture, _
ByRef sourcePalette As PaletteEntry _
) As GraphicsStream
C# public static GraphicsStream SaveToStream(
ImageFileFormat destFormat,
BaseTexture srcTexture,
out PaletteEntry sourcePalette
);
C++ public:
static GraphicsStream^ SaveToStream(
ImageFileFormat destFormat,
BaseTexture^ srcTexture,
[Out] PaletteEntry% sourcePalette
);
JScript public static function SaveToStream(
destFormat : ImageFileFormat,
srcTexture : BaseTexture,
sourcePalette : PaletteEntry
) : GraphicsStream;

Parameters

destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat flag that specifies the file format to use when saving. See Remarks.
srcTexture Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture object that contains the texture to save.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
A PaletteEntry structure that contains a 256-color palette. This parameter can be 0.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the source image.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Save


TextureShader Class (Microsoft.DirectX.Direct3D)

TextureShader Class

Encapsulates the functionality of a texture shader.

Definition

Visual Basic NotInheritable Public Class TextureShader
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class TextureShader : MarshalByRefObject, IDisposable
C++ | public ref class TextureShader sealed : MarshalByRefObject, IDisposable
JScript | public final class TextureShader extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the TextureShader object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the TextureShader object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the TextureShader object to free resources before it is destroyed by the garbage collector.
GetConstant | Retrieves an effect constant.
GetConstantDescription | Retrieves an array of effect constants in the effect's constant table.
GetConstantElement | Retrieves an effect constant element.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.TextureShader.Disposing event when called from within a derived class.
SetDefaults | Sets the effect constants to the default values declared in the texture shader.
SetValue | Sets the constant table with the data in the buffer.
SetValueTranspose | Sets a transposed matrix.
TextureShader | Initializes a new instance of the TextureShader class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this TextureShader object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
ConstantBuffer | Retrieves the constant table.
Description | Retrieves a description of the constant table.
Disposed | Gets a value that indicates whether the object is disposed.
Function | Retrieves the shader function stream.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXTextureShader interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
TextureShader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureShader.Dispose() Method (Microsoft.DirectX.Direct3D)

TextureShader.Dispose Method

Immediately releases the unmanaged resources used by the TextureShader object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~TextureShader();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.TextureShader.Disposed
  • Microsoft.DirectX.Direct3D.TextureShader.Disposing


TextureShader.Equals(Object) Method (Microsoft.DirectX.Direct3D)

TextureShader.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


TextureShader.Finalize() Method (Microsoft.DirectX.Direct3D)

TextureShader.Finalize Method

Allows the TextureShader object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~TextureShader();
C++ | !TextureShader();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


TextureShader.GetConstant Method ()

Retrieves an effect constant.

Overload List

public EffectHandle GetConstant(EffectHandle, int);
public EffectHandle GetConstant(EffectHandle, string);


TextureShader.GetConstant(EffectHandle,String) Method (Microsoft.DirectX.Direct3D)

TextureShader.GetConstant Method

Retrieves an effect constant.

Definition

Visual Basic Public Function GetConstant( _
ByVal constant As EffectHandle, _
ByVal name As String _
) As EffectHandle
C# public EffectHandle GetConstant(
EffectHandle constant,
string name
);
C++ public:
EffectHandle^ GetConstant(
EffectHandle^ constant,
String^ name
);
JScript public function GetConstant(
constant : EffectHandle,
name : String
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the parent data structure. If the constant is a top-level parameter (there is no parent data structure), use null.
name System.String
A string that contains the name of the constant to retrieve.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents the effect constant.


TextureShader.GetConstant(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

TextureShader.GetConstant Method

Retrieves an effect constant.

Definition

Visual Basic Public Function GetConstant( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetConstant(
EffectHandle constant,
int index
);
C++ public:
EffectHandle^ GetConstant(
EffectHandle^ constant,
int index
);
JScript public function GetConstant(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the parent data structure. If the constant is a top-level parameter (there is no parent data structure), use null.
index System.Int32
Zero-based index of the constant.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle that represents the effect constant.


TextureShader.GetConstantDescription(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

TextureShader.GetConstantDescription Method

Retrieves an array of effect constants in the effect's constant table.

Definition

Visual Basic Public Function GetConstantDescription( _
ByVal constant As EffectHandle, _
ByVal numberConstants As Integer _
) As ConstantDescription()
C# public ConstantDescription[] GetConstantDescription(
EffectHandle constant,
int numberConstants
);
C++ public:
array<ConstantDescription>^ GetConstantDescription(
EffectHandle^ constant,
int numberConstants
);
JScript public function GetConstantDescription(
constant : EffectHandle,
numberConstants : int
) : ConstantDescription[];

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the effect constant.
numberConstants System.Int32
Number of constants to retrieve.

Return Value

Microsoft.DirectX.Direct3D.ConstantDescription[]
Returns an array of ConstantDescription objects that represent the effect constant descriptions.

Remarks

Samplers can appear more than once in a constant table, therefore, GetConstantDescription can return an array of descriptions each with a different register index.


TextureShader.GetConstantElement(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

TextureShader.GetConstantElement Method

Retrieves an effect constant element.

Definition

Visual Basic Public Function GetConstantElement( _
ByVal constant As EffectHandle, _
ByVal index As Integer _
) As EffectHandle
C# public EffectHandle GetConstantElement(
EffectHandle constant,
int index
);
C++ public:
EffectHandle^ GetConstantElement(
EffectHandle^ constant,
int index
);
JScript public function GetConstantElement(
constant : EffectHandle,
index : int
) : EffectHandle;

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the array of constants.
index System.Int32
Zero-based index of the element in the constant table.

Return Value

Microsoft.DirectX.Direct3D.EffectHandle
Returns an EffectHandle that represents the effect constant element.


TextureShader.GetHashCode() Method (Microsoft.DirectX.Direct3D)

TextureShader.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


TextureShader.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

TextureShader.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXTextureShader, which allows unmanaged COM clients to create an instance of the managed TextureShader class. Not supported.


TextureShader.op_Equality(TextureShader,TextureShader) Method (Microsoft.DirectX.Direct3D)

TextureShader.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As TextureShader, _
ByVal right As TextureShader _
) As Boolean
C# public static bool op_Equality(
TextureShader left,
TextureShader right
);
C++ public:
static bool operator==(
TextureShader^ left,
TextureShader^ right
);
JScript public static function op_Equality(
left : TextureShader,
right : TextureShader
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.TextureShader
The TextureShader object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.TextureShader
The TextureShader object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


TextureShader.op_Inequality(TextureShader,TextureShader) Method (Microsoft.DirectX.Direct3D)

TextureShader.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As TextureShader, _
ByVal right As TextureShader _
) As Boolean
C# public static bool op_Inequality(
TextureShader left,
TextureShader right
);
C++ public:
static bool operator!=(
TextureShader^ left,
TextureShader^ right
);
JScript public static function op_Inequality(
left : TextureShader,
right : TextureShader
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.TextureShader
The TextureShader object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.TextureShader
The TextureShader object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


TextureShader.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

TextureShader.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.TextureShader.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


TextureShader.SetDefaults() Method (Microsoft.DirectX.Direct3D)

TextureShader.SetDefaults Method

Sets the effect constants to the default values declared in the texture shader.

Definition

Visual Basic | Public Sub SetDefaults()
C# | public void SetDefaults();
C++ public:
void SetDefaults();
JScript | public function SetDefaults();


TextureShader.SetValue Method ()

Sets the constant table with the data in the buffer.

Overload List

public void SetValue(EffectHandle, bool);
public void SetValue(EffectHandle, bool[]);
public void SetValue(EffectHandle, ColorValue);
public void SetValue(EffectHandle, ColorValue[]);
public void SetValue(EffectHandle, GraphicsStream);
public void SetValue(EffectHandle, int);
public void SetValue(EffectHandle, int[]);
public void SetValue(EffectHandle, Matrix);
public void SetValue(EffectHandle, Matrix[]);
public void SetValue(EffectHandle, float);
public void SetValue(EffectHandle, float[]);
public void SetValue(EffectHandle, Vector4);
public void SetValue(EffectHandle, Vector4[]);
public void SetValue(EffectHandle, void, int);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Matrix[]) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets an array of Matrix objects.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValue(
EffectHandle constant,
Matrix[] matrix
);
C++ public:
void SetValue(
EffectHandle^ constant,
array<Matrix>^ matrix
);
JScript public function SetValue(
constant : EffectHandle,
matrix : Matrix[]
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
matrix Microsoft.DirectX.Matrix[]
An array of Matrix objects to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Matrix) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets a Matrix object.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValue(
EffectHandle constant,
Matrix matrix
);
C++ public:
void SetValue(
EffectHandle^ constant,
Matrix matrix
);
JScript public function SetValue(
constant : EffectHandle,
matrix : Matrix
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
matrix Microsoft.DirectX.Matrix
A Matrix object to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,ColorValue[]) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets an array of ColorValue objects.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal color() As ColorValue _
)
C# public void SetValue(
EffectHandle constant,
ColorValue[] color
);
C++ public:
void SetValue(
EffectHandle^ constant,
array<ColorValue>^ color
);
JScript public function SetValue(
constant : EffectHandle,
color : ColorValue[]
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
color Microsoft.DirectX.Direct3D.ColorValue[]
An array of ColorValue objects to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,ColorValue) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets a ColorValue object.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal color As ColorValue _
)
C# public void SetValue(
EffectHandle constant,
ColorValue color
);
C++ public:
void SetValue(
EffectHandle^ constant,
ColorValue color
);
JScript public function SetValue(
constant : EffectHandle,
color : ColorValue
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
color Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Vector4[]) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets an array of Vector4 objects.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal vector() As Vector4 _
)
C# public void SetValue(
EffectHandle constant,
Vector4[] vector
);
C++ public:
void SetValue(
EffectHandle^ constant,
array<Vector4>^ vector
);
JScript public function SetValue(
constant : EffectHandle,
vector : Vector4[]
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
vector Microsoft.DirectX.Vector4[]
An array of Vector4 objects to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Vector4) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets a Vector4 object.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal vector As Vector4 _
)
C# public void SetValue(
EffectHandle constant,
Vector4 vector
);
C++ public:
void SetValue(
EffectHandle^ constant,
Vector4 vector
);
JScript public function SetValue(
constant : EffectHandle,
vector : Vector4
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
vector Microsoft.DirectX.Vector4
A Vector4 object to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Single[]) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets an array of Single Leave Site values.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal f() As Single _
)
C# public void SetValue(
EffectHandle constant,
float[] f
);
C++ public:
void SetValue(
EffectHandle^ constant,
array<float>^ f
);
JScript public function SetValue(
constant : EffectHandle,
f : float[]
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
f System.Single[]
An array of Single Leave Site values to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Single) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets a Single Leave Site value.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal f As Single _
)
C# public void SetValue(
EffectHandle constant,
float f
);
C++ public:
void SetValue(
EffectHandle^ constant,
float f
);
JScript public function SetValue(
constant : EffectHandle,
f : float
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
f System.Single
A Single Leave Site value to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Int32[]) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets an array of Int32 Leave Site values.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal n() As Integer _
)
C# public void SetValue(
EffectHandle constant,
int[] n
);
C++ public:
void SetValue(
EffectHandle^ constant,
array<int>^ n
);
JScript public function SetValue(
constant : EffectHandle,
n : int[]
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
n System.Int32[]
An array of Int32 Leave Site values to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Int32) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets a Int32 Leave Site value.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal n As Integer _
)
C# public void SetValue(
EffectHandle constant,
int n
);
C++ public:
void SetValue(
EffectHandle^ constant,
int n
);
JScript public function SetValue(
constant : EffectHandle,
n : int
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
n System.Int32
An Int32 Leave Site value to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Boolean[]) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets an array of Boolean Leave Site values.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal b() As Boolean _
)
C# public void SetValue(
EffectHandle constant,
bool[] b
);
C++ public:
void SetValue(
EffectHandle^ constant,
array<bool>^ b
);
JScript public function SetValue(
constant : EffectHandle,
b : boolean[]
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
b System.Boolean[]
An array of Boolean Leave Site values to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Boolean) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets a Boolean Leave Site value.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal b As Boolean _
)
C# public void SetValue(
EffectHandle constant,
bool b
);
C++ public:
void SetValue(
EffectHandle^ constant,
bool b
);
JScript public function SetValue(
constant : EffectHandle,
b : boolean
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
b System.Boolean
A Boolean Leave Site value to set.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets the constant table with the data in the buffer.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal data As GraphicsStream _
)
C# public void SetValue(
EffectHandle constant,
GraphicsStream data
);
C++ public:
void SetValue(
EffectHandle^ constant,
GraphicsStream^ data
);
JScript public function SetValue(
constant : EffectHandle,
data : GraphicsStream
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
data Microsoft.DirectX.GraphicsStream
A GraphicsStream object the contains the texture shader constant data.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValue(EffectHandle,Void,Int32) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValue Method

Sets the constant table with the data in the buffer.

Definition

Visual Basic Public Sub SetValue( _
ByVal constant As EffectHandle, _
ByVal data As Void, _
ByVal dataSize As Integer _
)
C# public void SetValue(
EffectHandle constant,
void data,
int dataSize
);
C++ public:
void SetValue(
EffectHandle^ constant,
void data,
int dataSize
);
JScript public function SetValue(
constant : EffectHandle,
data : void,
dataSize : int
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
data System.Void
A buffer containing the data to set.
dataSize System.Int32
Number of bytes in the data buffer.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureShader.SetValueTranspose Method ()

Sets a transposed matrix.

Overload List

public void SetValueTranspose(EffectHandle, Matrix);
public void SetValueTranspose(EffectHandle, Matrix[]);

Remarks

A transposed matrix contains column-major data; that is, each vector is contained in a column.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureShader.SetValueTranspose(EffectHandle,Matrix[]) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValueTranspose Method

Sets a transposed matrix.

Definition

Visual Basic Public Sub SetValueTranspose( _
ByVal constant As EffectHandle, _
ByVal matrix() As Matrix _
)
C# public void SetValueTranspose(
EffectHandle constant,
Matrix[] matrix
);
C++ public:
void SetValueTranspose(
EffectHandle^ constant,
array<Matrix>^ matrix
);
JScript public function SetValueTranspose(
constant : EffectHandle,
matrix : Matrix[]
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
matrix Microsoft.DirectX.Matrix[]
An array of transposed Matrix objects to set.

Remarks

A transposed matrix contains column-major data; that is, each vector is contained in a column.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureShader.SetValueTranspose(EffectHandle,Matrix) Method (Microsoft.DirectX.Direct3D)

TextureShader.SetValueTranspose Method

Sets a transposed matrix.

Definition

Visual Basic Public Sub SetValueTranspose( _
ByVal constant As EffectHandle, _
ByVal matrix As Matrix _
)
C# public void SetValueTranspose(
EffectHandle constant,
Matrix matrix
);
C++ public:
void SetValueTranspose(
EffectHandle^ constant,
Matrix matrix
);
JScript public function SetValueTranspose(
constant : EffectHandle,
matrix : Matrix
);

Parameters

constant Microsoft.DirectX.Direct3D.EffectHandle
An EffectHandle object that represents the unique identifier to a constant.
matrix Microsoft.DirectX.Matrix
A transposed Matrix object to set.

Remarks

A transposed matrix contains column-major data; that is, each vector is contained in a column.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


TextureShader.TextureShader Constructor ()

Initializes a new instance of the TextureShader class.

Overload List

public TextureShader(GraphicsStream);
public TextureShader(ID3DXTextureShader);
public TextureShader(int[]);
public TextureShader(IntPtr);


TextureShader.TextureShader(ID3DXTextureShader) Constructor (Microsoft.DirectX.Direct3D)

TextureShader.TextureShader Constructor

Initializes a new instance of the TextureShader class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXTextureShader _
)
C# public TextureShader(
ID3DXTextureShader pUnk
);
C++ public:
TextureShader(
ID3DXTextureShader pUnk
);
JScript public function TextureShader(
pUnk : ID3DXTextureShader
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureShader
Unmanaged Component Object Model (COM) ID3DXTextureShader interface pointer.


TextureShader.TextureShader(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

TextureShader.TextureShader Constructor

Initializes a new instance of the TextureShader class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public TextureShader(
IntPtr unmanagedObject
);
C++ public:
TextureShader(
IntPtr unmanagedObject
);
JScript public function TextureShader(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXTextureShader interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


TextureShader.TextureShader(Int32[]) Constructor (Microsoft.DirectX.Direct3D)

TextureShader.TextureShader Constructor

Initializes a new instance of the TextureShader class.

Definition

Visual Basic Public Sub New( _
ByVal function() As Integer _
)
C# public TextureShader(
int[] function
);
C++ public:
TextureShader(
array<int>^ function
);
JScript public function TextureShader(
function : int[]
);

Parameters

function System.Int32[]
An integer array that contains the texture shader function stream.


TextureShader.TextureShader(GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

TextureShader.TextureShader Constructor

Initializes a new instance of the TextureShader class.

Definition

Visual Basic Public Sub New( _
ByVal function As GraphicsStream _
)
C# public TextureShader(
GraphicsStream function
);
C++ public:
TextureShader(
GraphicsStream^ function
);
JScript public function TextureShader(
function : GraphicsStream
);

Parameters

function Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the texture shader function stream.


TextureShader.UpdateUnmanagedPointer(ID3DXTextureShader) Method (Microsoft.DirectX.Direct3D)

TextureShader.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this TextureShader object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXTextureShader _
)
C# public void UpdateUnmanagedPointer(
ID3DXTextureShader pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXTextureShader pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXTextureShader
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureShader
Pointer to the ID3DXTextureShader structure used to update the unmanaged pointer for this TextureShader object.


TextureShader.ConstantBuffer Property (Microsoft.DirectX.Direct3D)

TextureShader.ConstantBuffer Property

Retrieves the constant table.

Definition

Visual Basic | Public ReadOnly Property ConstantBuffer As GraphicsStream
C# | public GraphicsStream ConstantBuffer { get; }
C++ public:
property GraphicsStream^ ConstantBuffer {
GraphicsStream^ get();
}
JScript | public function get ConstantBuffer() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the constant table.

This property is read-only.


TextureShader.Description Property (Microsoft.DirectX.Direct3D)

TextureShader.Description Property

Retrieves a description of the constant table.

Definition

Visual Basic | Public ReadOnly Property Description As ConstantTableDescription
C# | public ConstantTableDescription Description { get; }
C++ public:
property ConstantTableDescription Description {
ConstantTableDescription get();
}
JScript | public function get Description() : ConstantTableDescription

Property Value

Microsoft.DirectX.Direct3D.ConstantTableDescription
A ConstantTableDescription object that contains the attributes of the constant table.

This property is read-only.


TextureShader.Disposed Property (Microsoft.DirectX.Direct3D)

TextureShader.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


TextureShader.Function Property (Microsoft.DirectX.Direct3D)

TextureShader.Function Property

Retrieves the shader function stream.

Definition

Visual Basic | Public ReadOnly Property Function As GraphicsStream
C# | public GraphicsStream Function { get; }
C++ public:
property GraphicsStream^ Function {
GraphicsStream^ get();
}
JScript | public function get Function() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the shader function stream.

This property is read-only.


TextureShader.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

TextureShader.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXTextureShader interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXTextureShader
C# | public ID3DXTextureShader UnmanagedComPointer { get; }
C++ public:
property ID3DXTextureShader UnmanagedComPointer {
ID3DXTextureShader get();
}
JScript | public function get UnmanagedComPointer() : ID3DXTextureShader

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXTextureShader
Unmanaged ID3DXTextureShader interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


TextureShader.Disposing Event (Microsoft.DirectX.Direct3D)

TextureShader.Disposing Event

Occurs when the Dispose method is called or when the TextureShader object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.TextureShader.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the TextureShader object indicates whether that object has been disposed.


TextureStateManager Class (Microsoft.DirectX.Direct3D)

TextureStateManager Class

Contains texture states for the device.

Definition

Visual Basic NotInheritable Public Class TextureStateManager
Inherits Object
C# | public sealed class TextureStateManager : Object
C++ | public ref class TextureStateManager sealed : Object
JScript | public final class TextureStateManager extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AlphaArgument0 | Defines settings for the alpha channel selector operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.
AlphaArgument1 | Defines the texture-stage state as the first alpha argument for the stage identified by the TextureArgument enumeration.
AlphaArgument2 | Defines the texture-stage state as the second alpha argument for the stage identified by the TextureArgument enumeration.
AlphaOperation | Defines the texture-stage state as a texture alpha-blending operation identified by the TextureOperation enumeration.
BumpEnvironmentLuminanceOffset | Defines a floating-point offset value for bump-map luminance.
BumpEnvironmentLuminanceScale | Defines a floating-point scale value for bump-map luminance.
BumpEnvironmentMaterial00 | Defines the texture-stage state as a floating-point value for the [0][0] coefficient in a bump-mapping matrix.
BumpEnvironmentMaterial01 | Defines the texture-stage state as a floating-point value for the [0][1] coefficient in a bump-mapping matrix.
BumpEnvironmentMaterial10 | Defines the texture-stage state as a floating-point value for the [1][0] coefficient in a bump-mapping matrix.
BumpEnvironmentMaterial11 | Defines the texture-stage state as a floating-point value for the [1][1] coefficient in a bump-mapping matrix.
ColorArgument0 | Defines settings for the third color operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.
ColorArgument1 | Defines the texture-stage state as the first color argument for the stage identified by the TextureArgument enumeration.
ColorArgument2 | Defines the texture-stage state as the second color argument for the stage identified by the TextureArgument enumeration.
ColorOperation | Defines the texture-stage state as a texture color-blending operation identified by the TextureOperation enumeration.
ConstantColor | Defines the per-stage constant color.
ConstantColorValue | Defines the per-stage constant color.
ResultArgument | Selects the destination register for the result of the current stage identified by TextureArgument.
TextureCoordinateIndex | Defines the index of the texture coordinate set to use with the current texture stage.
TextureTransform | Controls the transformation of texture coordinates for the current texture stage.

Inheritance Hierarchy

Object Leave Site
TextureStateManager

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ToString() Method (Microsoft.DirectX.Direct3D)

TextureStateManager.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.AlphaArgument0 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.AlphaArgument0 Property

Defines settings for the alpha channel selector operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.

Definition

Visual Basic | Public Property AlphaArgument0 As TextureArgument
C# | public TextureArgument AlphaArgument0 { get; set; }
C++ public:
property TextureArgument AlphaArgument0 {
TextureArgument get();
void set(TextureArgument value);
}
JScript public function get AlphaArgument0() : TextureArgument
public function set AlphaArgument0(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument
A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

AlphaArgument0 is supported if the TextureOperationCaps.SupportsMultiplyAdd or TextureOperationCaps.SupportsLerp device capabilities are present. The default argument is TextureArgument.Current. To select a temporary register color for read or write, specify TextureArgument.Temp, which is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default argument is (0.0, 0.0, 0.0, 0.0).

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.AlphaArgument1 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.AlphaArgument1 Property

Defines the texture-stage state as the first alpha argument for the stage identified by the TextureArgument enumeration.

Definition

Visual Basic | Public Property AlphaArgument1 As TextureArgument
C# | public TextureArgument AlphaArgument1 { get; set; }
C++ public:
property TextureArgument AlphaArgument1 {
TextureArgument get();
void set(TextureArgument value);
}
JScript public function get AlphaArgument1() : TextureArgument
public function set AlphaArgument1(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument
A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

The default argument is TextureArgument.TextureColor. If no texture is set for this stage, the default argument is TextureArgument.Diffuse. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.AlphaArgument2 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.AlphaArgument2 Property

Defines the texture-stage state as the second alpha argument for the stage identified by the TextureArgument enumeration.

Definition

Visual Basic | Public Property AlphaArgument2 As TextureArgument
C# | public TextureArgument AlphaArgument2 { get; set; }
C++ public:
property TextureArgument AlphaArgument2 {
TextureArgument get();
void set(TextureArgument value);
}
JScript public function get AlphaArgument2() : TextureArgument
public function set AlphaArgument2(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument
A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.AlphaOperation Property (Microsoft.DirectX.Direct3D)

TextureStateManager.AlphaOperation Property

Defines the texture-stage state as a texture alpha-blending operation identified by the TextureOperation enumeration.

Definition

Visual Basic | Public Property AlphaOperation As TextureOperation
C# | public TextureOperation AlphaOperation { get; set; }
C++ public:
property TextureOperation AlphaOperation {
TextureOperation get();
void set(TextureOperation value);
}
JScript public function get AlphaOperation() : TextureOperation
public function set AlphaOperation(TextureOperation);

Property Value

Microsoft.DirectX.Direct3D.TextureOperation
A TextureOperation object that represents the current texture operation.

This property is read/write.

Remarks

The default value for the first texture stage (stage 0) is TextureOperation.SelectArg1, and for all other stages is TextureOperation.Disable.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentLuminanceOffset Property (Microsoft.DirectX.Direct3D)

TextureStateManager.BumpEnvironmentLuminanceOffset Property

Defines a floating-point offset value for bump-map luminance.

Definition

Visual Basic | Public Property BumpEnvironmentLuminanceOffset As Single
C# | public float BumpEnvironmentLuminanceOffset { get; set; }
C++ public:
property float BumpEnvironmentLuminanceOffset {
float get();
void set(float value);
}
JScript public function get BumpEnvironmentLuminanceOffset() : float
public function set BumpEnvironmentLuminanceOffset(float);

Property Value

System.Single
Floating-point value that represents the offset for bump-map luminance. The default value is 0.0.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentLuminanceScale Property (Microsoft.DirectX.Direct3D)

TextureStateManager.BumpEnvironmentLuminanceScale Property

Defines a floating-point scale value for bump-map luminance.

Definition

Visual Basic | Public Property BumpEnvironmentLuminanceScale As Single
C# | public float BumpEnvironmentLuminanceScale { get; set; }
C++ public:
property float BumpEnvironmentLuminanceScale {
float get();
void set(float value);
}
JScript public function get BumpEnvironmentLuminanceScale() : float
public function set BumpEnvironmentLuminanceScale(float);

Property Value

System.Single
Floating-point value that represents the scale for bump-map luminance. The default value is 0.0.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentMaterial00 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.BumpEnvironmentMaterial00 Property

Defines the texture-stage state as a floating-point value for the [0][0] coefficient in a bump-mapping matrix.

Definition

Visual Basic | Public Property BumpEnvironmentMaterial00 As Single
C# | public float BumpEnvironmentMaterial00 { get; set; }
C++ public:
property float BumpEnvironmentMaterial00 {
float get();
void set(float value);
}
JScript public function get BumpEnvironmentMaterial00() : float
public function set BumpEnvironmentMaterial00(float);

Property Value

System.Single
Floating-point value that represents the [0][0] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentMaterial01 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.BumpEnvironmentMaterial01 Property

Defines the texture-stage state as a floating-point value for the [0][1] coefficient in a bump-mapping matrix.

Definition

Visual Basic | Public Property BumpEnvironmentMaterial01 As Single
C# | public float BumpEnvironmentMaterial01 { get; set; }
C++ public:
property float BumpEnvironmentMaterial01 {
float get();
void set(float value);
}
JScript public function get BumpEnvironmentMaterial01() : float
public function set BumpEnvironmentMaterial01(float);

Property Value

System.Single
Floating-point value that represents the [0][1] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentMaterial10 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.BumpEnvironmentMaterial10 Property

Defines the texture-stage state as a floating-point value for the [1][0] coefficient in a bump-mapping matrix.

Definition

Visual Basic | Public Property BumpEnvironmentMaterial10 As Single
C# | public float BumpEnvironmentMaterial10 { get; set; }
C++ public:
property float BumpEnvironmentMaterial10 {
float get();
void set(float value);
}
JScript public function get BumpEnvironmentMaterial10() : float
public function set BumpEnvironmentMaterial10(float);

Property Value

System.Single
Floating-point value that represents the [1][0] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.BumpEnvironmentMaterial11 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.BumpEnvironmentMaterial11 Property

Defines the texture-stage state as a floating-point value for the [1][1] coefficient in a bump-mapping matrix.

Definition

Visual Basic | Public Property BumpEnvironmentMaterial11 As Single
C# | public float BumpEnvironmentMaterial11 { get; set; }
C++ public:
property float BumpEnvironmentMaterial11 {
float get();
void set(float value);
}
JScript public function get BumpEnvironmentMaterial11() : float
public function set BumpEnvironmentMaterial11(float);

Property Value

System.Single
Floating-point value that represents the [1][1] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ColorArgument0 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.ColorArgument0 Property

Defines settings for the third color operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.

Definition

Visual Basic | Public Property ColorArgument0 As TextureArgument
C# | public TextureArgument ColorArgument0 { get; set; }
C++ public:
property TextureArgument ColorArgument0 {
TextureArgument get();
void set(TextureArgument value);
}
JScript public function get ColorArgument0() : TextureArgument
public function set ColorArgument0(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument
A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

This setting is supported if the TextureOperationCaps.SupportsMultiplyAdd or TextureOperationCaps.SupportsLerp device capabilities are present. The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ColorArgument1 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.ColorArgument1 Property

Defines the texture-stage state as the first color argument for the stage identified by the TextureArgument enumeration.

Definition

Visual Basic | Public Property ColorArgument1 As TextureArgument
C# | public TextureArgument ColorArgument1 { get; set; }
C++ public:
property TextureArgument ColorArgument1 {
TextureArgument get();
void set(TextureArgument value);
}
JScript public function get ColorArgument1() : TextureArgument
public function set ColorArgument1(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument
A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

The default argument is TextureArgument.Texture. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ColorArgument2 Property (Microsoft.DirectX.Direct3D)

TextureStateManager.ColorArgument2 Property

Defines the texture-stage state as the second color argument for the stage identified by the TextureArgument enumeration.

Definition

Visual Basic | Public Property ColorArgument2 As TextureArgument
C# | public TextureArgument ColorArgument2 { get; set; }
C++ public:
property TextureArgument ColorArgument2 {
TextureArgument get();
void set(TextureArgument value);
}
JScript public function get ColorArgument2() : TextureArgument
public function set ColorArgument2(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument
A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ColorOperation Property (Microsoft.DirectX.Direct3D)

TextureStateManager.ColorOperation Property

Defines the texture-stage state as a texture color-blending operation identified by the TextureOperation enumeration.

Definition

Visual Basic | Public Property ColorOperation As TextureOperation
C# | public TextureOperation ColorOperation { get; set; }
C++ public:
property TextureOperation ColorOperation {
TextureOperation get();
void set(TextureOperation value);
}
JScript public function get ColorOperation() : TextureOperation
public function set ColorOperation(TextureOperation);

Property Value

Microsoft.DirectX.Direct3D.TextureOperation
A TextureOperation object that represents the current texture operation.

This property is read/write.

Remarks

The default value for the first texture stage (stage 0) is TextureOperation.Modulate, and for all other stages is TextureOperation.Disable.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ConstantColor Property (Microsoft.DirectX.Direct3D)

TextureStateManager.ConstantColor Property

Defines the per-stage constant color.

Definition

Visual Basic | Public Property ConstantColor As Color
C# | public Color ConstantColor { get; set; }
C++ public:
property Color ConstantColor {
Color get();
void set(Color value);
}
JScript public function get ConstantColor() : Color
public function set ConstantColor(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the drawing color.

This property is read/write.

Remarks

To determine whether the current device supports a per-stage constant color, use the MiscCaps.SupportsPerStageConstant property. The ConstantColor property is used by TextureArgument.Constant.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ConstantColorValue Property (Microsoft.DirectX.Direct3D)

TextureStateManager.ConstantColorValue Property

Defines the per-stage constant color.

Definition

Visual Basic | Public Property ConstantColorValue As Integer
C# | public int ConstantColorValue { get; set; }
C++ public:
property int ConstantColorValue {
int get();
void set(int value);
}
JScript public function get ConstantColorValue() : int
public function set ConstantColorValue(int);

Property Value

System.Int32
An Int32 Leave Site that represents the drawing color.

This property is read/write.

Remarks

To determine whether the current device supports a per-stage constant color, use the MiscCaps.SupportsPerStageConstant property. The ConstantColorValue property is used by TextureArgument.Constant.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.ResultArgument Property (Microsoft.DirectX.Direct3D)

TextureStateManager.ResultArgument Property

Selects the destination register for the result of the current stage identified by TextureArgument.

Definition

Visual Basic | Public Property ResultArgument As TextureArgument
C# | public TextureArgument ResultArgument { get; set; }
C++ public:
property TextureArgument ResultArgument {
TextureArgument get();
void set(TextureArgument value);
}
JScript public function get ResultArgument() : TextureArgument
public function set ResultArgument(TextureArgument);

Property Value

Microsoft.DirectX.Direct3D.TextureArgument
A TextureArgument object that represents the current texture arguments.

This property is read/write.

Remarks

This value can be set to TextureArgument.Current (the default value) or to TextureArgument.Temp, which is a single temporary register that can be read into subsequent stages as an input argument. The final color passed to the fog blender and frame buffer is taken from TextureArgument.Current, so the last active texture stage state must be set to TextureArgument.Current. This setting is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.TextureCoordinateIndex Property (Microsoft.DirectX.Direct3D)

TextureStateManager.TextureCoordinateIndex Property

Defines the index of the texture coordinate set to use with the current texture stage.

Definition

Visual Basic | Public Property TextureCoordinateIndex As Integer
C# | public int TextureCoordinateIndex { get; set; }
C++ public:
property int TextureCoordinateIndex {
int get();
void set(int value);
}
JScript public function get TextureCoordinateIndex() : int
public function set TextureCoordinateIndex(int);

Property Value

System.Int32
Index of the texture coordinate set.

This property is read/write.

Remarks

Up to eight sets of texture coordinates per vertex can be specified. If a vertex does not include a set of texture coordinates at the specified index, the system reverts to the u and v coordinates (0,0) by default.

When rendering with vertex shaders, each stage's texture coordinate index must be set to its default value. The default index for each stage is equal to the stage index. Set this state to the zero-based index of the coordinate set for each vertex that this texture stage uses.

Additionally, applications can include TextureCoordinateIndex values as part of a logical OR with the index being set, to request that Microsoft DirectX automatically generate the input texture coordinates for a texture transformation.

The system uses the index strictly to determine texture wrapping mode when using a TextureCoordinateIndex value other than PassThru, which resolves to zero. These flags are most useful when performing environment mapping.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManager.TextureTransform Property (Microsoft.DirectX.Direct3D)

TextureStateManager.TextureTransform Property

Controls the transformation of texture coordinates for the current texture stage.

Definition

Visual Basic | Public Property TextureTransform As TextureTransform
C# | public TextureTransform TextureTransform { get; set; }
C++ public:
property TextureTransform TextureTransform {
TextureTransform get();
void set(TextureTransform value);
}
JScript public function get TextureTransform() : TextureTransform
public function set TextureTransform(TextureTransform);

Property Value

Microsoft.DirectX.Direct3D.TextureTransform
A TextureTransform object that represents the texture-stage state values.

This property is read/write.

Remarks

The default value is TextureTransform.Disable.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManagerCollection Class (Microsoft.DirectX.Direct3D)

TextureStateManagerCollection Class

Collection of TextureStateManager objects.

Definition

Visual Basic NotInheritable Public Class TextureStateManagerCollection
Inherits Object
C# | public sealed class TextureStateManagerCollection : Object
C++ | public ref class TextureStateManagerCollection sealed : Object
JScript | public final class TextureStateManagerCollection extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property | Description
TextureState | Retrieves the TextureStateManager object at the given index.

Inheritance Hierarchy

Object Leave Site
TextureStateManagerCollection

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureStateManagerCollection.TextureState Property (Microsoft.DirectX.Direct3D)

TextureStateManagerCollection.TextureState Property

Retrieves the TextureStateManager object at the given index.

Definition

Visual Basic Public ReadOnly Property TextureState( _
ByVal index As Integer _
) As TextureStateManager
C# public TextureStateManager this[
int index
] { get; }
C++ public:
property TextureStateManager^ TextureState [int] {
TextureStateManager^ get(int index);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32
Integer that represents the TextureStateManager object to retrieve.

Property Value

Microsoft.DirectX.Direct3D.TextureStateManager
A TextureStateManager object retrieved from the given index.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TooManyInfluencesException Class (Microsoft.DirectX.Direct3D)

TooManyInfluencesException Class

Too many influences specified.

Definition

Visual Basic Public Class TooManyInfluencesException
Inherits Direct3DXException
C# | public class TooManyInfluencesException : Direct3DXException
C++ | public ref class TooManyInfluencesException : Direct3DXException
JScript | public class TooManyInfluencesException extends Direct3DXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from Direct3DXException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooManyInfluencesException | Initializes a new instance of the TooManyInfluencesException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
TooManyInfluencesException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TooManyInfluencesException.TooManyInfluencesException Constructor ()

Initializes a new instance of the TooManyInfluencesException class.

Overload List

public TooManyInfluencesException();
protected TooManyInfluencesException(SerializationInfo, StreamingContext);
public TooManyInfluencesException(string);
public TooManyInfluencesException(string, Exception);


TooManyInfluencesException.TooManyInfluencesException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:

Initializes a new instance of the TooManyInfluencesException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooManyInfluencesException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TooManyInfluencesException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TooManyInfluencesException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


TooManyInfluencesException.TooManyInfluencesException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:

Initializes a new instance of the TooManyInfluencesException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooManyInfluencesException(
string message,
Exception inner
);
C++ public:
TooManyInfluencesException(
String^ message,
Exception^ inner
);
JScript public function TooManyInfluencesException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


TooManyInfluencesException.TooManyInfluencesException(String) Constructor (Microsoft.DirectX.Direct3D)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:

Initializes a new instance of the TooManyInfluencesException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TooManyInfluencesException(
string message
);
C++ public:
TooManyInfluencesException(
String^ message
);
JScript public function TooManyInfluencesException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


TooManyInfluencesException.TooManyInfluencesException() Constructor (Microsoft.DirectX.Direct3D)

TooManyInfluencesException.TooManyInfluencesException Constructor

 Language:

Initializes a new instance of the TooManyInfluencesException class.

Definition

Visual Basic | Public Sub New()
C# | public TooManyInfluencesException();
C++ public:
TooManyInfluencesException();
JScript | public function TooManyInfluencesException();


TooManyOperationsException Class (Microsoft.DirectX.Direct3D)

TooManyOperationsException Class

The application is requesting more texture-filtering operations than the device supports.

Definition

Visual Basic Public Class TooManyOperationsException
Inherits GraphicsException
C# | public class TooManyOperationsException : GraphicsException
C++ | public ref class TooManyOperationsException : GraphicsException
JScript | public class TooManyOperationsException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooManyOperationsException | Initializes a new instance of the TooManyOperationsException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TooManyOperationsException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TooManyOperationsException.TooManyOperationsException Constructor ()

Initializes a new instance of the TooManyOperationsException class.

Overload List

public TooManyOperationsException();
protected TooManyOperationsException(SerializationInfo, StreamingContext);
public TooManyOperationsException(string);
public TooManyOperationsException(string, Exception);


TooManyOperationsException.TooManyOperationsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:

Initializes a new instance of the TooManyOperationsException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooManyOperationsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TooManyOperationsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TooManyOperationsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


TooManyOperationsException.TooManyOperationsException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:

Initializes a new instance of the TooManyOperationsException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooManyOperationsException(
string message,
Exception inner
);
C++ public:
TooManyOperationsException(
String^ message,
Exception^ inner
);
JScript public function TooManyOperationsException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


TooManyOperationsException.TooManyOperationsException(String) Constructor (Microsoft.DirectX.Direct3D)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:

Initializes a new instance of the TooManyOperationsException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TooManyOperationsException(
string message
);
C++ public:
TooManyOperationsException(
String^ message
);
JScript public function TooManyOperationsException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


TooManyOperationsException.TooManyOperationsException() Constructor (Microsoft.DirectX.Direct3D)

TooManyOperationsException.TooManyOperationsException Constructor

 Language:

Initializes a new instance of the TooManyOperationsException class.

Definition

Visual Basic | Public Sub New()
C# | public TooManyOperationsException();
C++ public:
TooManyOperationsException();
JScript | public function TooManyOperationsException();


Transforms Class (Microsoft.DirectX.Direct3D)

Transforms Class

Allows applications to specify and obtain matrix transformations; for example, the world, view, and transformation matrices used for Microsoft Direct3D object rendering.

Definition

Visual Basic NotInheritable Public Class Transforms
Inherits Object
C# | public sealed class Transforms : Object
C++ | public ref class Transforms sealed : Object
JScript | public final class Transforms extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetWorldMatrixByIndex | Retrieves a world matrix transform by its index.
SetWorldMatrixByIndex | Sets the world matrix by its index.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Projection | Retrieves or sets the projection transformation Matrix.
Texture0 | Retrieves or sets the Texture0 transformation Matrix.
Texture1 | Retrieves or sets the Texture1 transformation Matrix.
Texture2 | Retrieves or sets the Texture2 transformation Matrix.
Texture3 | Retrieves or sets the Texture3 transformation Matrix.
Texture4 | Retrieves or sets the Texture4 transformation Matrix.
Texture5 | Retrieves or sets the Texture5 transformation Matrix.
Texture6 | Retrieves or sets the Texture6 transformation Matrix.
Texture7 | Retrieves or sets the Texture7 transformation Matrix.
View | Retrieves or sets the view transformation matrix.
World | Retrieves or sets the first world matrix.
World1 | Retrieves or sets the second world matrix.
World2 | Retrieves or sets the third world matrix.
World3 | Retrieves or sets the fourth world matrix.

Inheritance Hierarchy

Object Leave Site
Transforms

Remarks

An instance of this class is stored in the Device.Transform property, which is typically used to manipulate matrices. For instance, the following line of C# code moves the View transform back five units, points the view at the origin, and defines "up" as the y-direction.

[C#]

device.Transform.View = Matrix.LookAtLH(
            new Vector3( 0.0f, 3.0f,-5.0f ),
                        new Vector3( 0.0f, 0.0f, 0.0f ),
                        new Vector3( 0.0f, 1.0f, 0.0f ) );

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Tutorial 3: Using Matrices
  • GetTransform
  • SetTransform


Transforms.GetWorldMatrixByIndex(Int32) Method (Microsoft.DirectX.Direct3D)

Transforms.GetWorldMatrixByIndex Method

Retrieves a world matrix transform by its index.

Definition

Visual Basic Public Function GetWorldMatrixByIndex( _
ByVal index As Integer _
) As Matrix
C# public Matrix GetWorldMatrixByIndex(
int index
);
C++ public:
Matrix GetWorldMatrixByIndex(
int index
);
JScript public function GetWorldMatrixByIndex(
index : int
) : Matrix;

Parameters

index System.Int32
Value between 0 and 255 that indicates the index of the world matrix to retrieve.

Return Value

Microsoft.DirectX.Matrix

See Also

  • GetTransform


Transforms.SetWorldMatrixByIndex(Int32,Matrix) Method (Microsoft.DirectX.Direct3D)

Transforms.SetWorldMatrixByIndex Method

Sets the world matrix by its index.

Definition

Visual Basic Public Sub SetWorldMatrixByIndex( _
ByVal index As Integer, _
ByVal value As Matrix _
)
C# public void SetWorldMatrixByIndex(
int index,
Matrix value
);
C++ public:
void SetWorldMatrixByIndex(
int index,
Matrix value
);
JScript public function SetWorldMatrixByIndex(
index : int,
value : Matrix
);

Parameters

index System.Int32
Value between 0 and 255 that indicates the index of the world matrix to set.
value Microsoft.DirectX.Matrix
A Matrix value to which the specified world matrix is set.

See Also

  • SetTransform


Transforms.ToString() Method (Microsoft.DirectX.Direct3D)

Transforms.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Transforms.Projection Property (Microsoft.DirectX.Direct3D)

Transforms.Projection Property

How Do I...?
  • Set Up a Projection Matrix

Retrieves or sets the projection transformation Matrix.

Definition

Visual Basic | Public Property Projection As Matrix
C# | public Matrix Projection { get; set; }
C++ public:
property Matrix Projection {
Matrix get();
void set(Matrix value);
}
JScript public function get Projection() : Matrix
public function set Projection(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

Remarks

The default projection transformation Matrix is the identity Matrix.

How Do I...?

Set Up a Projection Matrix

This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.

See the following C# code example, the Projection transformation matrix is set to be equal to the left-handed (LH) PerspectiveFovLH matrix. Input arguments to PerspectiveFovLH are as follows.

  1. Field of view in radians: pi/4.
  2. Aspect ratio, or view-space height divided by width: 1, for a square window.
  3. Near clipping plane distance: 1 unit.
  4. Far clipping plane distance: 100 units.

              [C#]

using Microsoft.DirectX;

Direct3D.Device device = null;  // Create rendering device.

// For the projection matrix, you set up a perspective transform (which
//   transforms geometry from 3-D view space to 2-D viewport space, with
//   a perspective divide making objects smaller in the distance). To build
//   a perspective transform, you need the field of view (1/4 pi is common),
//   the aspect ratio, and the near and far clipping planes (which define
//   the distances at which geometry should no longer be rendered).

device.Transform.Projection = Matrix.PerspectiveFovLH(
                              (float)Math.PI / 4, 1.0f, 1.0f, 100.0f );

See Also

  • SetTransform


Transforms.Texture0 Property (Microsoft.DirectX.Direct3D)

Transforms.Texture0 Property

Retrieves or sets the Texture0 transformation Matrix.

Definition

Visual Basic | Public Property Texture0 As Matrix
C# | public Matrix Texture0 { get; set; }
C++ public:
property Matrix Texture0 {
Matrix get();
void set(Matrix value);
}
JScript public function get Texture0() : Matrix
public function set Texture0(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture1 Property (Microsoft.DirectX.Direct3D)

Transforms.Texture1 Property

Retrieves or sets the Texture1 transformation Matrix.

Definition

Visual Basic | Public Property Texture1 As Matrix
C# | public Matrix Texture1 { get; set; }
C++ public:
property Matrix Texture1 {
Matrix get();
void set(Matrix value);
}
JScript public function get Texture1() : Matrix
public function set Texture1(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture2 Property (Microsoft.DirectX.Direct3D)

Transforms.Texture2 Property

Retrieves or sets the Texture2 transformation Matrix.

Definition

Visual Basic | Public Property Texture2 As Matrix
C# | public Matrix Texture2 { get; set; }
C++ public:
property Matrix Texture2 {
Matrix get();
void set(Matrix value);
}
JScript public function get Texture2() : Matrix
public function set Texture2(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture3 Property (Microsoft.DirectX.Direct3D)

Transforms.Texture3 Property

Retrieves or sets the Texture3 transformation Matrix.

Definition

Visual Basic | Public Property Texture3 As Matrix
C# | public Matrix Texture3 { get; set; }
C++ public:
property Matrix Texture3 {
Matrix get();
void set(Matrix value);
}
JScript public function get Texture3() : Matrix
public function set Texture3(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture4 Property (Microsoft.DirectX.Direct3D)

Transforms.Texture4 Property

Retrieves or sets the Texture4 transformation Matrix.

Definition

Visual Basic | Public Property Texture4 As Matrix
C# | public Matrix Texture4 { get; set; }
C++ public:
property Matrix Texture4 {
Matrix get();
void set(Matrix value);
}
JScript public function get Texture4() : Matrix
public function set Texture4(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture5 Property (Microsoft.DirectX.Direct3D)

Transforms.Texture5 Property

Retrieves or sets the Texture5 transformation Matrix.

Definition

Visual Basic | Public Property Texture5 As Matrix
C# | public Matrix Texture5 { get; set; }
C++ public:
property Matrix Texture5 {
Matrix get();
void set(Matrix value);
}
JScript public function get Texture5() : Matrix
public function set Texture5(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture6 Property (Microsoft.DirectX.Direct3D)

Transforms.Texture6 Property

Retrieves or sets the Texture6 transformation Matrix.

Definition

Visual Basic | Public Property Texture6 As Matrix
C# | public Matrix Texture6 { get; set; }
C++ public:
property Matrix Texture6 {
Matrix get();
void set(Matrix value);
}
JScript public function get Texture6() : Matrix
public function set Texture6(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.Texture7 Property (Microsoft.DirectX.Direct3D)

Transforms.Texture7 Property

Retrieves or sets the Texture7 transformation Matrix.

Definition

Visual Basic | Public Property Texture7 As Matrix
C# | public Matrix Texture7 { get; set; }
C++ public:
property Matrix Texture7 {
Matrix get();
void set(Matrix value);
}
JScript public function get Texture7() : Matrix
public function set Texture7(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.View Property (Microsoft.DirectX.Direct3D)

Transforms.View Property

How Do I...?
  • Set Up a View Matrix

Retrieves or sets the view transformation matrix.

Definition

Visual Basic | Public Property View As Matrix
C# | public Matrix View { get; set; }
C++ public:
property Matrix View {
Matrix get();
void set(Matrix value);
}
JScript public function get View() : Matrix
public function set View(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

Remarks

The default view transformation matrix is the identity matrix.

How Do I...?

Set Up a View Matrix

This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.

In the following C# code example, the vector components of the Vector3 structure form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The View transformation matrix is set to be equal to this look-at matrix.

The three input vectors represent the following, respectively:

  1. The eye point: [0, 3, -5].
  2. The camera look-at target: the origin [0, 0, 0].
  3. The current world's up-direction: usually [0, 1, 0].

              [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;  // Create rendering device.

// Set up the view matrix. A view matrix can be defined given an eye point,
//   a point to view, and a direction for which way is up. Here, you set
//   the eye five units back along the z-axis and up three units, view the
//   origin, and define "up" to be in the y-direction.

device.Transform.View = Microsoft.DirectX.Matrix.LookAtLH(
                            new Vector3(0.0f, 3.0f, -5.0f),
                            new Vector3(0.0f, 0.0f, 0.0f),
                            new Vector3(0.0f, 1.0f, 0.0f));

See Also

  • GetTransform
  • SetTransform


Transforms.World Property (Microsoft.DirectX.Direct3D)

Transforms.World Property

Retrieves or sets the first world matrix.

Definition

Visual Basic | Public Property World As Matrix
C# | public Matrix World { get; set; }
C++ public:
property Matrix World {
Matrix get();
void set(Matrix value);
}
JScript public function get World() : Matrix
public function set World(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.World1 Property (Microsoft.DirectX.Direct3D)

Transforms.World1 Property

Retrieves or sets the second world matrix.

Definition

Visual Basic | Public Property World1 As Matrix
C# | public Matrix World1 { get; set; }
C++ public:
property Matrix World1 {
Matrix get();
void set(Matrix value);
}
JScript public function get World1() : Matrix
public function set World1(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.World2 Property (Microsoft.DirectX.Direct3D)

Transforms.World2 Property

Retrieves or sets the third world matrix.

Definition

Visual Basic | Public Property World2 As Matrix
C# | public Matrix World2 { get; set; }
C++ public:
property Matrix World2 {
Matrix get();
void set(Matrix value);
}
JScript public function get World2() : Matrix
public function set World2(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


Transforms.World3 Property (Microsoft.DirectX.Direct3D)

Transforms.World3 Property

Retrieves or sets the fourth world matrix.

Definition

Visual Basic | Public Property World3 As Matrix
C# | public Matrix World3 { get; set; }
C++ public:
property Matrix World3 {
Matrix get();
void set(Matrix value);
}
JScript public function get World3() : Matrix
public function set World3(Matrix);

Property Value

Microsoft.DirectX.Matrix

This property is read/write.

See Also

  • GetTransform
  • SetTransform


UnsupportedAlphaArgumentException Class (Microsoft.DirectX.Direct3D)

UnsupportedAlphaArgumentException Class

The device does not support a specified texture-blending argument for the alpha channel.

Definition

Visual Basic Public Class UnsupportedAlphaArgumentException
Inherits GraphicsException
C# | public class UnsupportedAlphaArgumentException : GraphicsException
C++ | public ref class UnsupportedAlphaArgumentException : GraphicsException
JScript | public class UnsupportedAlphaArgumentException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedAlphaArgumentException | Initializes a new instance of the UnsupportedAlphaArgumentException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedAlphaArgumentException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor ()

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Overload List

public UnsupportedAlphaArgumentException();
protected UnsupportedAlphaArgumentException(SerializationInfo, StreamingContext);
public UnsupportedAlphaArgumentException(string);
public UnsupportedAlphaArgumentException(string, Exception);


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedAlphaArgumentException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedAlphaArgumentException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedAlphaArgumentException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedAlphaArgumentException(
string message,
Exception inner
);
C++ public:
UnsupportedAlphaArgumentException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedAlphaArgumentException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException(String) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedAlphaArgumentException(
string message
);
C++ public:
UnsupportedAlphaArgumentException(
String^ message
);
JScript public function UnsupportedAlphaArgumentException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException() Constructor (Microsoft.DirectX.Direct3D)

UnsupportedAlphaArgumentException.UnsupportedAlphaArgumentException Constructor

 Language:

Initializes a new instance of the UnsupportedAlphaArgumentException class.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedAlphaArgumentException();
C++ public:
UnsupportedAlphaArgumentException();
JScript | public function UnsupportedAlphaArgumentException();


UnsupportedAlphaOperationException Class (Microsoft.DirectX.Direct3D)

UnsupportedAlphaOperationException Class

The device does not support a specified texture-blending operation for the alpha channel.

Definition

Visual Basic Public Class UnsupportedAlphaOperationException
Inherits GraphicsException
C# | public class UnsupportedAlphaOperationException : GraphicsException
C++ | public ref class UnsupportedAlphaOperationException : GraphicsException
JScript | public class UnsupportedAlphaOperationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedAlphaOperationException | Initializes a new instance of the UnsupportedAlphaOperationException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedAlphaOperationException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor ()

Initializes a new instance of the UnsupportedAlphaOperationException class.

Overload List

public UnsupportedAlphaOperationException();
protected UnsupportedAlphaOperationException(SerializationInfo, StreamingContext);
public UnsupportedAlphaOperationException(string);
public UnsupportedAlphaOperationException(string, Exception);


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:

Initializes a new instance of the UnsupportedAlphaOperationException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedAlphaOperationException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedAlphaOperationException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedAlphaOperationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:

Initializes a new instance of the UnsupportedAlphaOperationException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedAlphaOperationException(
string message,
Exception inner
);
C++ public:
UnsupportedAlphaOperationException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedAlphaOperationException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException(String) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:

Initializes a new instance of the UnsupportedAlphaOperationException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedAlphaOperationException(
string message
);
C++ public:
UnsupportedAlphaOperationException(
String^ message
);
JScript public function UnsupportedAlphaOperationException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


UnsupportedAlphaOperationException.UnsupportedAlphaOperationException() Constructor (Microsoft.DirectX.Direct3D)

UnsupportedAlphaOperationException.UnsupportedAlphaOperationException Constructor

 Language:

Initializes a new instance of the UnsupportedAlphaOperationException class.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedAlphaOperationException();
C++ public:
UnsupportedAlphaOperationException();
JScript | public function UnsupportedAlphaOperationException();


UnsupportedColorArgumentException Class (Microsoft.DirectX.Direct3D)

UnsupportedColorArgumentException Class

The device does not support a specified texture-blending argument for color values.

Definition

Visual Basic Public Class UnsupportedColorArgumentException
Inherits GraphicsException
C# | public class UnsupportedColorArgumentException : GraphicsException
C++ | public ref class UnsupportedColorArgumentException : GraphicsException
JScript | public class UnsupportedColorArgumentException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedColorArgumentException | Initializes a new instance of the UnsupportedColorArgumentException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedColorArgumentException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor ()

Initializes a new instance of the UnsupportedColorArgumentException class.

Overload List

public UnsupportedColorArgumentException();
protected UnsupportedColorArgumentException(SerializationInfo, StreamingContext);
public UnsupportedColorArgumentException(string);
public UnsupportedColorArgumentException(string, Exception);


UnsupportedColorArgumentException.UnsupportedColorArgumentException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:

Initializes a new instance of the UnsupportedColorArgumentException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedColorArgumentException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedColorArgumentException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedColorArgumentException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedColorArgumentException.UnsupportedColorArgumentException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:

Initializes a new instance of the UnsupportedColorArgumentException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedColorArgumentException(
string message,
Exception inner
);
C++ public:
UnsupportedColorArgumentException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedColorArgumentException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedColorArgumentException.UnsupportedColorArgumentException(String) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:

Initializes a new instance of the UnsupportedColorArgumentException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedColorArgumentException(
string message
);
C++ public:
UnsupportedColorArgumentException(
String^ message
);
JScript public function UnsupportedColorArgumentException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


UnsupportedColorArgumentException.UnsupportedColorArgumentException() Constructor (Microsoft.DirectX.Direct3D)

UnsupportedColorArgumentException.UnsupportedColorArgumentException Constructor

 Language:

Initializes a new instance of the UnsupportedColorArgumentException class.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedColorArgumentException();
C++ public:
UnsupportedColorArgumentException();
JScript | public function UnsupportedColorArgumentException();


UnsupportedColorOperationException Class (Microsoft.DirectX.Direct3D)

UnsupportedColorOperationException Class

The device does not support a specified texture-blending operation for color values.

Definition

Visual Basic Public Class UnsupportedColorOperationException
Inherits GraphicsException
C# | public class UnsupportedColorOperationException : GraphicsException
C++ | public ref class UnsupportedColorOperationException : GraphicsException
JScript | public class UnsupportedColorOperationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedColorOperationException | Initializes a new instance of the UnsupportedColorOperationException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedColorOperationException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedColorOperationException.UnsupportedColorOperationException Constructor ()

Initializes a new instance of the UnsupportedColorOperationException class.

Overload List

public UnsupportedColorOperationException();
protected UnsupportedColorOperationException(SerializationInfo, StreamingContext);
public UnsupportedColorOperationException(string);
public UnsupportedColorOperationException(string, Exception);


UnsupportedColorOperationException.UnsupportedColorOperationException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:

Initializes a new instance of the UnsupportedColorOperationException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedColorOperationException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedColorOperationException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedColorOperationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedColorOperationException.UnsupportedColorOperationException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:

Initializes a new instance of the UnsupportedColorOperationException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedColorOperationException(
string message,
Exception inner
);
C++ public:
UnsupportedColorOperationException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedColorOperationException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedColorOperationException.UnsupportedColorOperationException(String) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:

Initializes a new instance of the UnsupportedColorOperationException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedColorOperationException(
string message
);
C++ public:
UnsupportedColorOperationException(
String^ message
);
JScript public function UnsupportedColorOperationException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


UnsupportedColorOperationException.UnsupportedColorOperationException() Constructor (Microsoft.DirectX.Direct3D)

UnsupportedColorOperationException.UnsupportedColorOperationException Constructor

 Language:

Initializes a new instance of the UnsupportedColorOperationException class.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedColorOperationException();
C++ public:
UnsupportedColorOperationException();
JScript | public function UnsupportedColorOperationException();


UnsupportedFactorValueException Class (Microsoft.DirectX.Direct3D)

UnsupportedFactorValueException Class

The device does not support the specified texture factor value. Not used; provided only to support older drivers.

Definition

Visual Basic Public Class UnsupportedFactorValueException
Inherits GraphicsException
C# | public class UnsupportedFactorValueException : GraphicsException
C++ | public ref class UnsupportedFactorValueException : GraphicsException
JScript | public class UnsupportedFactorValueException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedFactorValueException | Initializes a new instance of the UnsupportedFactorValueException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedFactorValueException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedFactorValueException.UnsupportedFactorValueException Constructor ()

Initializes a new instance of the UnsupportedFactorValueException class.

Overload List

public UnsupportedFactorValueException();
protected UnsupportedFactorValueException(SerializationInfo, StreamingContext);
public UnsupportedFactorValueException(string);
public UnsupportedFactorValueException(string, Exception);


UnsupportedFactorValueException.UnsupportedFactorValueException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:

Initializes a new instance of the UnsupportedFactorValueException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedFactorValueException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedFactorValueException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedFactorValueException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedFactorValueException.UnsupportedFactorValueException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:

Initializes a new instance of the UnsupportedFactorValueException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedFactorValueException(
string message,
Exception inner
);
C++ public:
UnsupportedFactorValueException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedFactorValueException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedFactorValueException.UnsupportedFactorValueException(String) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:

Initializes a new instance of the UnsupportedFactorValueException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedFactorValueException(
string message
);
C++ public:
UnsupportedFactorValueException(
String^ message
);
JScript public function UnsupportedFactorValueException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


UnsupportedFactorValueException.UnsupportedFactorValueException() Constructor (Microsoft.DirectX.Direct3D)

UnsupportedFactorValueException.UnsupportedFactorValueException Constructor

 Language:

Initializes a new instance of the UnsupportedFactorValueException class.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedFactorValueException();
C++ public:
UnsupportedFactorValueException();
JScript | public function UnsupportedFactorValueException();


UnsupportedTextureFilterException Class (Microsoft.DirectX.Direct3D)

UnsupportedTextureFilterException Class

The device does not support the specified texture filter.

Definition

Visual Basic Public Class UnsupportedTextureFilterException
Inherits GraphicsException
C# | public class UnsupportedTextureFilterException : GraphicsException
C++ | public ref class UnsupportedTextureFilterException : GraphicsException
JScript | public class UnsupportedTextureFilterException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedTextureFilterException | Initializes a new instance of the UnsupportedTextureFilterException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedTextureFilterException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor ()

Initializes a new instance of the UnsupportedTextureFilterException class.

Overload List

public UnsupportedTextureFilterException();
protected UnsupportedTextureFilterException(SerializationInfo, StreamingContext);
public UnsupportedTextureFilterException(string);
public UnsupportedTextureFilterException(string, Exception);


UnsupportedTextureFilterException.UnsupportedTextureFilterException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:

Initializes a new instance of the UnsupportedTextureFilterException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedTextureFilterException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedTextureFilterException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedTextureFilterException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedTextureFilterException.UnsupportedTextureFilterException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:

Initializes a new instance of the UnsupportedTextureFilterException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedTextureFilterException(
string message,
Exception inner
);
C++ public:
UnsupportedTextureFilterException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedTextureFilterException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedTextureFilterException.UnsupportedTextureFilterException(String) Constructor (Microsoft.DirectX.Direct3D)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:

Initializes a new instance of the UnsupportedTextureFilterException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedTextureFilterException(
string message
);
C++ public:
UnsupportedTextureFilterException(
String^ message
);
JScript public function UnsupportedTextureFilterException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


UnsupportedTextureFilterException.UnsupportedTextureFilterException() Constructor (Microsoft.DirectX.Direct3D)

UnsupportedTextureFilterException.UnsupportedTextureFilterException Constructor

 Language:

Initializes a new instance of the UnsupportedTextureFilterException class.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedTextureFilterException();
C++ public:
UnsupportedTextureFilterException();
JScript | public function UnsupportedTextureFilterException();


UVAtlas Class (Microsoft.DirectX.Direct3D)

UVAtlas Class

Contains methods for creating UV texture atlases.

Definition

Visual Basic Public Class UVAtlas
Inherits Object
C# | public class UVAtlas : Object
C++ | public ref class UVAtlas : Object
JScript | public class UVAtlas extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) Create | Creates one or more UV texture atlases.
static (Shared in Visual Basic) Pack | Packs the face partitioning data into a texture atlas.
static (Shared in Visual Basic) Partition | Creates one or more UV texture atlases (like UVAtlas.Create), without performing the final packing step.

Inheritance Hierarchy

Object Leave Site
UVAtlas

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • UVAtlasOutput

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlas.Create Method ()

Creates one or more UV texture atlases.

Overload List

public static UVAtlasOutput Create(Mesh, int, float, int, int, float, int, GraphicsStream, float[], PercentageCompleteCallback, float);
public static UVAtlasOutput Create(Mesh, int, float, int, int, float, int, int[], float[], PercentageCompleteCallback, float);

Remarks

This function has two modes of operation:

  • Based on the number of charts
  • Based on the maximum allowed stretch. If the maximum allowed stretch is 0, each triangle will likely be in its own chart.

Integrated Metric Tensor Array

The IMTArray is an array of integrated metric tensors. Each element uses 3 Singles to describe an IMT for a single face. The IMT controls how the triangle is stretched in the atlas. The IMT (3 singles - (a,b,c)) contains a symmetric 2x2 matrix as shown here:

a b
b c

Given a vector (s,t) and two vectors v1 and v2:

vector v1
vector v2 = v1 + (s,t)

The distance between vector v1 and v2 is:

sqrt((s, t) * M * (s, t)^T)

In other words, the vector (s,t) enables you to specify the magnitude of the stretch in an arbitrary direction in u-v space; where s is the direction from the first to the second vertex, and t is the cross product of the normal and s. For example: a = b = 1 would scale the vector (1,1) by 2, and the vector (1,-1) by 0. Note that this is multiplying the edge length by the square of the matrix; if you want the face to stretch to twice its size with no shearing, the IMT value should be (2, 0, 2), which is the identity matrix times 2.

You can calculate IMTs from texture or vertex signal data by using the methods in the IntegratedMetricTensor class.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlas.Create(Mesh,Int32,Single,Int32,Int32,Single,Int32,Int32[],Single[],PercentageCompleteCallback,Single) Method (Microsoft.DirectX.Direct3D)

UVAtlas.Create Method

Creates one or more UV texture atlases.

Definition

Visual Basic Public Shared Function Create( _
ByVal mesh As Mesh, _
ByVal maxChartNumber As Integer, _
ByVal maxStretch As Single, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal gutter As Single, _
ByVal textureIndex As Integer, _
ByVal adjacency() As Integer, _
ByVal imtArray() As Single, _
ByVal callback As PercentageCompleteCallback, _
ByVal callbackFrequency As Single _
) As UVAtlasOutput
C# public static UVAtlasOutput Create(
Mesh mesh,
int maxChartNumber,
float maxStretch,
int width,
int height,
float gutter,
int textureIndex,
int[] adjacency,
float[] imtArray,
PercentageCompleteCallback callback,
float callbackFrequency
);
C++ public:
static UVAtlasOutput Create(
Mesh^ mesh,
int maxChartNumber,
float maxStretch,
int width,
int height,
float gutter,
int textureIndex,
array<int>^ adjacency,
array<float>^ imtArray,
PercentageCompleteCallback^ callback,
float callbackFrequency
);
JScript public static function Create(
mesh : Mesh,
maxChartNumber : int,
maxStretch : float,
width : int,
height : int,
gutter : float,
textureIndex : int,
adjacency : int[],
imtArray : float[],
callback : PercentageCompleteCallback,
callbackFrequency : float
) : UVAtlasOutput;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Input mesh used to calculate the atlas. The atlas must have a position channel and at least a 2-D texture channel.
maxChartNumber System.Int32
The maximum number of charts required for the atlas. If this is 0, the atlas will be parameterized based solely on stretch.
maxStretch System.Single
The maximum stretch resulting from the atlasing algorithm. 0 means do not stretch; 1 means any amount of stretching is allowed.
width System.Int32
The width of the texture the atlas will be used on.
height System.Int32
The height of the texture the atlas will be used on.
gutter System.Single
The minimum distance, in texels between two charts on the atlas. The gutter is scaled by the width. For example, if a gutter of 2.5 is used on a 512x512 texture, then the minimum distance between two charts (in texels) will be 2.5 / 512.0 in uv space.
textureIndex System.Int32
Specifies which texture coordinate to write to in the output mesh (which is cloned from the input mesh). Useful if your vertex has multiple texture coordinates.
adjacency System.Int32[]
An array with 3 Int32s per face, indicating which triangles are adjacent to each other.
imtArray System.Single[]
An array with 3 floating-point values per face, describing the integrated metric tensor for that face. See remarks.
callback Microsoft.DirectX.Direct3D.PercentageCompleteCallback
A callback function that can be used to monitor progress.
callbackFrequency System.Single
How often the callback specified by will be used. Use 0.0001f as a default value.

Return Value

Microsoft.DirectX.Direct3D.UVAtlasOutput
Contains data about the created texture atlases.

Remarks

This function has two modes of operation:

  • Based on the number of charts
  • Based on the maximum allowed stretch. If the maximum allowed stretch is 0, each triangle will likely be in its own chart.

Integrated Metric Tensor Array

The IMTArray is an array of integrated metric tensors. Each element uses 3 Singles to describe an IMT for a single face. The IMT controls how the triangle is stretched in the atlas. The IMT (3 singles - (a,b,c)) contains a symmetric 2x2 matrix as shown here:

a b
b c

Given a vector (s,t) and two vectors v1 and v2:

vector v1
vector v2 = v1 + (s,t)

The distance between vector v1 and v2 is:

sqrt((s, t) * M * (s, t)^T)

In other words, the vector (s,t) enables you to specify the magnitude of the stretch in an arbitrary direction in u-v space; where s is the direction from the first to the second vertex, and t is the cross product of the normal and s. For example: a = b = 1 would scale the vector (1,1) by 2, and the vector (1,-1) by 0. Note that this is multiplying the edge length by the square of the matrix; if you want the face to stretch to twice its size with no shearing, the IMT value should be (2, 0, 2), which is the identity matrix times 2.

You can calculate IMTs from texture or vertex signal data by using the methods in the IntegratedMetricTensor class.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlas.Create(Mesh,Int32,Single,Int32,Int32,Single,Int32,GraphicsStream,Single[],PercentageCompleteCallback,Single) Method (Microsoft.DirectX.Direct3D)

UVAtlas.Create Method

Creates one or more UV texture atlases.

Definition

Visual Basic Public Shared Function Create( _
ByVal mesh As Mesh, _
ByVal maxChartNumber As Integer, _
ByVal maxStretch As Single, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal gutter As Single, _
ByVal textureIndex As Integer, _
ByVal adjacency As GraphicsStream, _
ByVal imtArray() As Single, _
ByVal callback As PercentageCompleteCallback, _
ByVal callbackFrequency As Single _
) As UVAtlasOutput
C# public static UVAtlasOutput Create(
Mesh mesh,
int maxChartNumber,
float maxStretch,
int width,
int height,
float gutter,
int textureIndex,
GraphicsStream adjacency,
float[] imtArray,
PercentageCompleteCallback callback,
float callbackFrequency
);
C++ public:
static UVAtlasOutput Create(
Mesh^ mesh,
int maxChartNumber,
float maxStretch,
int width,
int height,
float gutter,
int textureIndex,
GraphicsStream^ adjacency,
array<float>^ imtArray,
PercentageCompleteCallback^ callback,
float callbackFrequency
);
JScript public static function Create(
mesh : Mesh,
maxChartNumber : int,
maxStretch : float,
width : int,
height : int,
gutter : float,
textureIndex : int,
adjacency : GraphicsStream,
imtArray : float[],
callback : PercentageCompleteCallback,
callbackFrequency : float
) : UVAtlasOutput;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Input mesh used to calculate the atlas. The atlas must have a position channel and at least a 2-D texture channel.
maxChartNumber System.Int32
The maximum number of charts required for the atlas. If this is 0, the atlas will be parameterized based solely on stretch.
maxStretch System.Single
The maximum stretch resulting from the atlasing algorithm. 0 means do not stretch; 1 means any amount of stretching is allowed.
width System.Int32
The width of the texture the atlas will be used on.
height System.Int32
The height of the texture the atlas will be used on.
gutter System.Single
The minimum distance, in texels between two charts on the atlas. The gutter is scaled by the width. For example, if a gutter of 2.5 is used on a 512x512 texture, then the minimum distance between two charts (in texels) will be 2.5 / 512.0 in uv space.
textureIndex System.Int32
Specifies which texture coordinate to write to in the output mesh (which is cloned from the input mesh). Useful if your vertex has multiple texture coordinates.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream that indicates which triangles are adjacent to each other.
imtArray System.Single[]
An array with 3 floating-point values per face, describing the integrated metric tensor for that face. See remarks.
callback Microsoft.DirectX.Direct3D.PercentageCompleteCallback
A callback function that can be used to monitor progress.
callbackFrequency System.Single
How often the callback specified by will be used. Use 0.0001f as a default value.

Return Value

Microsoft.DirectX.Direct3D.UVAtlasOutput
Contains data about the created texture atlases.

Remarks

This function has two modes of operation:

  • Based on the number of charts
  • Based on the maximum allowed stretch. If the maximum allowed stretch is 0, each triangle will likely be in its own chart.

Integrated Metric Tensor Array

The IMTArray is an array of integrated metric tensors. Each element uses 3 Singles to describe an IMT for a single face. The IMT controls how the triangle is stretched in the atlas. The IMT (3 singles - (a,b,c)) contains a symmetric 2x2 matrix as shown here:

a b
b c

Given a vector (s,t) and two vectors v1 and v2:

vector v1
vector v2 = v1 + (s,t)

The distance between vector v1 and v2 is:

sqrt((s, t) * M * (s, t)^T)

In other words, the vector (s,t) enables you to specify the magnitude of the stretch in an arbitrary direction in u-v space; where s is the direction from the first to the second vertex, and t is the cross product of the normal and s. For example: a = b = 1 would scale the vector (1,1) by 2, and the vector (1,-1) by 0. Note that this is multiplying the edge length by the square of the matrix; if you want the face to stretch to twice its size with no shearing, the IMT value should be (2, 0, 2), which is the identity matrix times 2.

You can calculate IMTs from texture or vertex signal data by using the methods in the IntegratedMetricTensor class.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlas.Pack(Mesh,Int32,Int32,Single,Int32,PercentageCompleteCallback,Single,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

UVAtlas.Pack Method

Packs the face partitioning data into a texture atlas.

Definition

Visual Basic Public Shared Sub Pack( _
ByVal mesh As Mesh, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal gutter As Single, _
ByVal textureIndex As Integer, _
ByVal callback As PercentageCompleteCallback, _
ByVal callbackFrequency As Single, _
ByVal facePartitioning As GraphicsStream _
)
C# public static void Pack(
Mesh mesh,
int width,
int height,
float gutter,
int textureIndex,
PercentageCompleteCallback callback,
float callbackFrequency,
GraphicsStream facePartitioning
);
C++ public:
static void Pack(
Mesh^ mesh,
int width,
int height,
float gutter,
int textureIndex,
PercentageCompleteCallback^ callback,
float callbackFrequency,
GraphicsStream^ facePartitioning
);
JScript public static function Pack(
mesh : Mesh,
width : int,
height : int,
gutter : float,
textureIndex : int,
callback : PercentageCompleteCallback,
callbackFrequency : float,
facePartitioning : GraphicsStream
);

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Input mesh used to calculate the atlas. The atlas must have a position channel and at least a 2-D texture channel.
width System.Int32
The width of the texture the atlas will be used on.
height System.Int32
The height of the texture the atlas will be used on.
gutter System.Single
The minimum distance, in texels between two charts on the atlas. The gutter is scaled by the width. For example, if a gutter of 2.5 is used on a 512x512 texture, then the minimum distance between two charts (in texels) will be 2.5 / 512.0 in UV space.
textureIndex System.Int32
Specifies which texture coordinate to write to in the output mesh (which is cloned from the input mesh). Useful if your vertex has multiple texture coordinates.
callback Microsoft.DirectX.Direct3D.PercentageCompleteCallback
A callback function that can be used to monitor progress.
callbackFrequency System.Single
How often the callback will be called. Use 0.0001f as a default value.
facePartitioning Microsoft.DirectX.GraphicsStream
A GraphicsStream that contains the final face partitioning data.

Remarks

Use UVAtlas.Partition to create an unpacked texture atlas.

Use UVAtlas.Partition to create multiple texture sizes. You may not modify the partitioning data before calling Pack.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlas.Partition Method ()

Creates one or more UV texture atlases (like UVAtlas.Create), without performing the final packing step.

Overload List

public static UVAtlasOutput Partition(Mesh, int, float, int, GraphicsStream, float[], PercentageCompleteCallback, float);
public static UVAtlasOutput Partition(Mesh, int, float, int, int[], float[], PercentageCompleteCallback, float);

Remarks

Integrated Metric Tensor Array

The IMTArray is an array of integrated metric tensors. Each element uses 3 Singles to describe an IMT for a single face. The IMT controls how the triangle is stretched in the atlas. The IMT (3 singles - (a,b,c)) contains a symmetric 2x2 matrix as shown here:

a b
b c

Given a vector (s,t) and two vectors v1 and v2:

vector v1
vector v2 = v1 + (s,t)

The distance between vector v1 and v2 is:

sqrt((s, t) * M * (s, t)^T)

In other words, the vector (s,t) enables you to specify the magnitude of the stretch in an arbitrary direction in UV space; where s is the direction from the first to the second vertex, and t is the cross product of the normal and s. For example: a = b = 1 would scale the vector (1,1) by 2, and the vector (1,-1) by 0. Note that this is multiplying the edge length by the square of the matrix; if you want the face to stretch to twice its size with no shearing, the IMT value should be (2, 0, 2), which is the identity matrix times 2.

You can calculate IMTs from texture or vertex signal data by using the methods in the IntegratedMetricTensor class.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlas.Partition(Mesh,Int32,Single,Int32,Int32[],Single[],PercentageCompleteCallback,Single) Method (Microsoft.DirectX.Direct3D)

UVAtlas.Partition Method

Creates one or more UV texture atlases (like UVAtlas.Create), without performing the final packing step.

Definition

Visual Basic Public Shared Function Partition( _
ByVal mesh As Mesh, _
ByVal maxChartNumber As Integer, _
ByVal maxStretch As Single, _
ByVal textureIndex As Integer, _
ByVal adjacency() As Integer, _
ByVal imtArray() As Single, _
ByVal callback As PercentageCompleteCallback, _
ByVal callbackFrequency As Single _
) As UVAtlasOutput
C# public static UVAtlasOutput Partition(
Mesh mesh,
int maxChartNumber,
float maxStretch,
int textureIndex,
int[] adjacency,
float[] imtArray,
PercentageCompleteCallback callback,
float callbackFrequency
);
C++ public:
static UVAtlasOutput Partition(
Mesh^ mesh,
int maxChartNumber,
float maxStretch,
int textureIndex,
array<int>^ adjacency,
array<float>^ imtArray,
PercentageCompleteCallback^ callback,
float callbackFrequency
);
JScript public static function Partition(
mesh : Mesh,
maxChartNumber : int,
maxStretch : float,
textureIndex : int,
adjacency : int[],
imtArray : float[],
callback : PercentageCompleteCallback,
callbackFrequency : float
) : UVAtlasOutput;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Input mesh used to calculate the atlas. The atlas must have a position channel and at least a 2-D texture channel.
maxChartNumber System.Int32
The maximum number of charts required for the atlas. If this is 0, the atlas will be parameterized based solely on stretch.
maxStretch System.Single
The maximum stretch resulting from the atlasing algorithm. 0 means do not stretch; 1 means any amount of stretching is allowed.
textureIndex System.Int32
Specifies which texture coordinate to write to in the output mesh (which is cloned from the input mesh). Useful if your vertex has multiple texture coordinates.
adjacency System.Int32[]
An array with 3 Int32s per face, indicating which triangles are adjacent to each other.
imtArray System.Single[]
An array with 3 floating-point values per face, describing the integrated metric tensor for that face. See remarks.
callback Microsoft.DirectX.Direct3D.PercentageCompleteCallback
A callback function that can be used to monitor progress.
callbackFrequency System.Single
How often the callback specified by will be used. Use 0.0001f as a default value.

Return Value

Microsoft.DirectX.Direct3D.UVAtlasOutput
Contains data about the created texture atlases.

Remarks

Integrated Metric Tensor Array

The IMTArray is an array of integrated metric tensors. Each element uses 3 Singles to describe an IMT for a single face. The IMT controls how the triangle is stretched in the atlas. The IMT (3 singles - (a,b,c)) contains a symmetric 2x2 matrix as shown here:

a b
b c

Given a vector (s,t) and two vectors v1 and v2:

vector v1
vector v2 = v1 + (s,t)

The distance between vector v1 and v2 is:

sqrt((s, t) * M * (s, t)^T)

In other words, the vector (s,t) enables you to specify the magnitude of the stretch in an arbitrary direction in UV space; where s is the direction from the first to the second vertex, and t is the cross product of the normal and s. For example: a = b = 1 would scale the vector (1,1) by 2, and the vector (1,-1) by 0. Note that this is multiplying the edge length by the square of the matrix; if you want the face to stretch to twice its size with no shearing, the IMT value should be (2, 0, 2), which is the identity matrix times 2.

You can calculate IMTs from texture or vertex signal data by using the methods in the IntegratedMetricTensor class.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlas.Partition(Mesh,Int32,Single,Int32,GraphicsStream,Single[],PercentageCompleteCallback,Single) Method (Microsoft.DirectX.Direct3D)

UVAtlas.Partition Method

Creates one or more UV texture atlases (like UVAtlas.Create), without performing the final packing step.

Definition

Visual Basic Public Shared Function Partition( _
ByVal mesh As Mesh, _
ByVal maxChartNumber As Integer, _
ByVal maxStretch As Single, _
ByVal textureIndex As Integer, _
ByVal adjacency As GraphicsStream, _
ByVal imtArray() As Single, _
ByVal callback As PercentageCompleteCallback, _
ByVal callbackFrequency As Single _
) As UVAtlasOutput
C# public static UVAtlasOutput Partition(
Mesh mesh,
int maxChartNumber,
float maxStretch,
int textureIndex,
GraphicsStream adjacency,
float[] imtArray,
PercentageCompleteCallback callback,
float callbackFrequency
);
C++ public:
static UVAtlasOutput Partition(
Mesh^ mesh,
int maxChartNumber,
float maxStretch,
int textureIndex,
GraphicsStream^ adjacency,
array<float>^ imtArray,
PercentageCompleteCallback^ callback,
float callbackFrequency
);
JScript public static function Partition(
mesh : Mesh,
maxChartNumber : int,
maxStretch : float,
textureIndex : int,
adjacency : GraphicsStream,
imtArray : float[],
callback : PercentageCompleteCallback,
callbackFrequency : float
) : UVAtlasOutput;

Parameters

mesh Microsoft.DirectX.Direct3D.Mesh
Input mesh used to calculate the atlas. The atlas must have a position channel and at least a 2-D texture channel.
maxChartNumber System.Int32
The maximum number of charts required for the atlas. If this is 0, the atlas will be parameterized based solely on stretch.
maxStretch System.Single
The maximum stretch resulting from the atlasing algorithm. 0 means do not stretch; 1 means any amount of stretching is allowed.
textureIndex System.Int32
Specifies which texture coordinate to write to in the output mesh (which is cloned from the input mesh). Useful if your vertex has multiple texture coordinates.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream that indicates which triangles are adjacent to each other.
imtArray System.Single[]
An array with 3 floating-point values per face, describing the integrated metric tensor for that face. See remarks.
callback Microsoft.DirectX.Direct3D.PercentageCompleteCallback
A callback function that can be used to monitor progress.
callbackFrequency System.Single
How often the callback specified by will be used. Use 0.0001f as a default value.

Return Value

Microsoft.DirectX.Direct3D.UVAtlasOutput
Contains data about the created texture atlases.

Remarks

Integrated Metric Tensor Array

The IMTArray is an array of integrated metric tensors. Each element uses 3 Singles to describe an IMT for a single face. The IMT controls how the triangle is stretched in the atlas. The IMT (3 singles - (a,b,c)) contains a symmetric 2x2 matrix as shown here:

a b
b c

Given a vector (s,t) and two vectors v1 and v2:

vector v1
vector v2 = v1 + (s,t)

The distance between vector v1 and v2 is:

sqrt((s, t) * M * (s, t)^T)

In other words, the vector (s,t) enables you to specify the magnitude of the stretch in an arbitrary direction in UV space; where s is the direction from the first to the second vertex, and t is the cross product of the normal and s. For example: a = b = 1 would scale the vector (1,1) by 2, and the vector (1,-1) by 0. Note that this is multiplying the edge length by the square of the matrix; if you want the face to stretch to twice its size with no shearing, the IMT value should be (2, 0, 2), which is the identity matrix times 2.

You can calculate IMTs from texture or vertex signal data by using the methods in the IntegratedMetricTensor class.

Exceptions
Direct3DXException The operation failed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


VertexBuffer Class (Microsoft.DirectX.Direct3D)

VertexBuffer Class

How Do I...?
  • Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams
  • Read and Write VertexBuffer Data With Arrays

Manipulates vertex buffer resources.

Definition

Visual Basic NotInheritable Public Class VertexBuffer
Inherits Resource
Implements IDisposable
C# | public sealed class VertexBuffer : Resource, IDisposable
C++ | public ref class VertexBuffer sealed : Resource, IDisposable
JScript | public final class VertexBuffer extends Resource implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Created | Occurs after a device is reset and the VertexBuffer is re-created.
Disposing | Occurs when the Dispose method is called or when the VertexBuffer object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the VertexBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object. Inherited from Resource.
Finalize | Allows the VertexBuffer object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GetHashCode | Returns the hash code for the current instance. Inherited from Resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
Lock | Locks a range of vertex data and obtains the vertex buffer memory.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Created | Raises a VertexBuffer.Created event when called from within a derived class.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.VertexBuffer.Disposing event when called from within a derived class.
SetData | Locks, sets, and unlocks a range of vertex data.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
Unlock | Unlocks vertex data.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this VertexBuffer object. This method supports the Framework infrastructure and is not intended to be used directly in your code.
VertexBuffer | Creates a new instance of the VertexBuffer class.

Properties

Property | Description
Description | Retrieves a description of the vertex buffer resource.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
SizeInBytes | Retrieves the size of the VertexBuffer data, in bytes.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DVertexBuffer9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
VertexBuffer

Remarks

This object inherits additional functionality from the Resource object.

How Do I...?

Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams

This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The vertex buffer data is then locked using its offset and size in bytes. A GraphicsStream object is returned which is derived from Stream Leave Site and can be used in a similar fashon. In the code example, the Write method is used to copy data into the stream from an array of vertex data.

The second part of the method shows use of GraphicsStream using unsafe data access. The InternalDataPointerGraphicsStream.InternalData property returns a void pointer to the vertex buffer data. In this code example, the data is cast to an array of PositionNormalTexVertex structures which makes data manipulation more readable.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public  float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}
public class Example
{
    public unsafe void  GraphicsStreamReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTexVertex.FVF, Pool.Managed);

        //First, fill an array of PositionNormalTexVertex elements with data.
        PositionNormalTexVertex[] vertices = new PositionNormalTexVertex[50];
        for(int i=0; i<50; i++)
        {
            //fill the vertices with some data...
            vertices[i].Position = new Vector3(3f,4f,5f);
        }

        //The size of the verticies are 32-bytes each (float3 (12) + float3 (12) + float(4) + float(4))
        //To lock 50 verticies, the size of the lock would be 1600 (32 * 50)
        GraphicsStream vbData =  vb.Lock(0,1600, LockFlags.None);

        //copy the vertex data into the vertex buffer
        vbData.Write(vertices);

        //Unlock the VB
        vb.Unlock();

        //This time, lock the entire VertexBuffer
        vbData =  vb.Lock(0, 3200, LockFlags.None);

        //Cast the InternalDataPointer (a void pointer) to an array of verticies
        PositionNormalTexVertex* vbArray = (PositionNormalTexVertex*) vbData.InternalDataPointer;

        for(int i=0; i<100; i++)
        {
            //perform some operations on the data
            vbArray[i].Tu0 = i;
            vbArray[i].Tv0 = vbArray[i].Tu0 * 2;

            Console.WriteLine(vbArray[i].Tv0.ToString());
        }

        //Unlock the buffer
        vb.Unlock();
        vb.Dispose();
    }
}

Read and Write VertexBuffer Data With Arrays

This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a FVF type defined by the PositionNormalTexVertex structure. The first part of the code sample shows the use of Lock to lock an arbitrary number of vertices and fill them with data. The second part shows how to lock an entire VertexBuffer for reading and retrieving data from the array. A similar procedure can be used to write to and read from nearly all Microsoft Direct3D resource types.

Using Arrays Leave Site is not the most efficient method for filling and reading from Direct3D resources; it requires extra memory and cycles to copy the unmanaged resources into managed arrays. However, it makes for very readable code with no unsafe access.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}

public class Example
{
    public void ArrayBasedReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTex1Vertex.FVF, Pool.Managed);

        //Fill an array of the appropriate type with the VB data using Lock()
        PositionNormalTexVertex[] vbData = (PositionNormalTexVertex[]) vb.Lock(0, typeof(PositionNormalTexVertex), LockFlags.None, 50);
        for(int i=0; i<50; i++)
        {
            //set your vertices to something...
            vbData[i].Position = new Vector3(2f,2f,2f);
            vbData[i].Normal = new Vector3(1f,0f,0f);
            vbData[i].Tu0 = i;
            vbData[i].Tv0 = i;
        }
        //Unlock the vb before you can use it elsewhere
        vb.Unlock();

        //This lock overload simply locks the entire VB -- setting ReadOnly can improve perf when reading a vertexbuffer
        vbData = (PositionNormalTexVertex[]) vb.Lock(0, LockFlags.ReadOnly);
        for(int i=0; i<100; i++)
        {
            //read some vertex data
            Console.WriteLine("Vertex " + i + "Tu: " +  vbData[i].Tu0 + " , Tv: " + vbData[i].Tv0);
        }

        //Unlock the buffer
        vb.Unlock();

        vb.Dispose();
    }
}

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


VertexBuffer.Dispose() Method (Microsoft.DirectX.Direct3D)

VertexBuffer.Dispose Method

Immediately releases the unmanaged resources used by the VertexBuffer object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~VertexBuffer();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.VertexBuffer.Disposed
  • Microsoft.DirectX.Direct3D.VertexBuffer.Disposing


VertexBuffer.Finalize() Method (Microsoft.DirectX.Direct3D)

VertexBuffer.Finalize Method

Allows the VertexBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~VertexBuffer();
C++ | !VertexBuffer();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


VertexBuffer.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

VertexBuffer.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVertexBuffer9, which allows unmanaged COM clients to create an instance of the managed VertexBuffer class. Not supported.


VertexBuffer.Lock Method ()

How Do I...?
  • Create a Mesh Object

Locks a range of vertex data and obtains the vertex buffer memory.

Overload List

public GraphicsStream Lock(int, int, LockFlags);
public Array Lock(int, LockFlags);
public Array Lock(int, Type, LockFlags, int[]);

Remarks

When working with vertex buffers, multiple lock calls are allowed; however, the number of lock calls must match the number of unlock calls. Any outstanding lock count on any currently set vertex buffer causes the DrawPrimitives calls to fail.

When using a Lock method to retrieve an Array Leave Site from a resource that was not created with a Type Leave Site, always use the overload that accepts a Type Leave Site. Use the ranks parameter to indicate the number of members in the returned Array Leave Site.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • UnlockVertexBuffer


VertexBuffer.Lock(Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

VertexBuffer.Lock Method

How Do I...?
  • Create a Mesh Object

Locks a range of vertex data and obtains the vertex buffer memory.

Definition

Visual Basic Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal flags As LockFlags _
) As Array
C# public Array Lock(
int offsetToLock,
LockFlags flags
);
C++ public:
Array^ Lock(
int offsetToLock,
LockFlags flags
);
JScript public function Lock(
offsetToLock : int,
flags : LockFlags
) : Array;

Parameters

offsetToLock System.Int32
Offset into the vertex data to lock, in bytes. To lock the entire vertex buffer, specify 0 for both param_Int32_sizeToLock and param_Int32_offsetToLock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Return Value

System.Array
An Array Leave Site that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed; however, the number of lock calls must match the number of unlock calls. Any outstanding lock count on any currently set vertex buffer causes the DrawPrimitives calls to fail.

When using a Lock method to retrieve an Array Leave Site from a resource that was not created with a Type Leave Site, always use the overload that accepts a Type Leave Site. Use the ranks parameter to indicate the number of members in the returned Array Leave Site.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • UnlockVertexBuffer


VertexBuffer.Lock(Int32,Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

VertexBuffer.Lock Method

How Do I...?
  • Create a Mesh Object

Locks a range of vertex data and obtains the vertex buffer memory.

Definition

Visual Basic Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal sizeToLock As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream Lock(
int offsetToLock,
int sizeToLock,
LockFlags flags
);
C++ public:
GraphicsStream^ Lock(
int offsetToLock,
int sizeToLock,
LockFlags flags
);
JScript public function Lock(
offsetToLock : int,
sizeToLock : int,
flags : LockFlags
) : GraphicsStream;

Parameters

offsetToLock System.Int32
Offset into the vertex data to lock, in bytes. To lock the entire vertex buffer, specify 0 for both param_Int32_sizeToLock and param_Int32_offsetToLock.
sizeToLock System.Int32
Size of the vertex data to lock, in bytes. To lock the entire vertex buffer, specify 0 for both param_Int32_sizeToLock and param_Int32_offsetToLock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed; however, the number of lock calls must match the number of unlock calls. Any outstanding lock count on any currently set vertex buffer causes the DrawPrimitives calls to fail.

When using a Lock method to retrieve an Array Leave Site from a resource that was not created with a Type Leave Site, always use the overload that accepts a Type Leave Site. Use the ranks parameter to indicate the number of members in the returned Array Leave Site.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • UnlockVertexBuffer


VertexBuffer.Lock(Int32,Type,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

VertexBuffer.Lock Method

How Do I...?
  • Create a Mesh Object

Locks a range of vertex data and obtains the vertex buffer memory.

Definition

Visual Basic Public Function Lock( _
ByVal offsetToLock As Integer, _
ByVal typeVertex As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array Lock(
int offsetToLock,
Type typeVertex,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ Lock(
int offsetToLock,
Type^ typeVertex,
LockFlags flags,
array<int>^ ranks
);
JScript public function Lock(
offsetToLock : int,
typeVertex : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

offsetToLock System.Int32
Offset into the vertex data to lock, in bytes. To lock the entire vertex buffer, specify 0 for both param_Int32_sizeToLock and param_Int32_offsetToLock.
typeVertex System.Type
A Type Leave Site object that indicates the type of array data to return. This can be a value type or any type that contains only value types.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site that represents the locked vertex buffer.

Remarks

When working with vertex buffers, multiple lock calls are allowed; however, the number of lock calls must match the number of unlock calls. Any outstanding lock count on any currently set vertex buffer causes the DrawPrimitives calls to fail.

When using a Lock method to retrieve an Array Leave Site from a resource that was not created with a Type Leave Site, always use the overload that accepts a Type Leave Site. Use the ranks parameter to indicate the number of members in the returned Array Leave Site.

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

See Also

  • UnlockVertexBuffer


VertexBuffer.raise_Created(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

VertexBuffer.raise_Created Method

Raises a VertexBuffer.Created event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Created( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Created(
object i1,
EventArgs i2
);
C++ protected:
void raise_Created(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Created(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass into the event handler.


VertexBuffer.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

VertexBuffer.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.VertexBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


VertexBuffer.SetData(Object,Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

VertexBuffer.SetData Method

Locks, sets, and unlocks a range of vertex data.

Definition

Visual Basic Public Sub SetData( _
ByVal data As Object, _
ByVal lockAtOffset As Integer, _
ByVal flags As LockFlags _
)
C# public void SetData(
object data,
int lockAtOffset,
LockFlags flags
);
C++ public:
void SetData(
Object^ data,
int lockAtOffset,
LockFlags flags
);
JScript public function SetData(
data : Object,
lockAtOffset : int,
flags : LockFlags
);

Parameters

data System.Object
An Object Leave Site that contains the data to copy into the vertex buffer. This can be any value type or any type that contains only value types.
lockAtOffset System.Int32
Offset in the vertex buffer to set. To set the entire buffer, set this parameter to 0.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more LockFlags locking flags that describe the type of lock to perform when setting the buffer. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, ReadOnly, and NoOverWrite. For a description of the flags, see LockFlags.

Remarks

The Lock.Discard and NoOverWrite flags are valid only on buffers created with Dynamic.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VertexBuffer.Unlock() Method (Microsoft.DirectX.Direct3D)

VertexBuffer.Unlock Method

How Do I...?
  • Create a Mesh Object

Unlocks vertex data.

Definition

Visual Basic | Public Sub Unlock()
C# | public void Unlock();
C++ public:
void Unlock();
JScript | public function Unlock();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


VertexBuffer.UpdateUnmanagedPointer(IDirect3DVertexBuffer9) Method (Microsoft.DirectX.Direct3D)

VertexBuffer.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this VertexBuffer object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVertexBuffer9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVertexBuffer9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DVertexBuffer9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DVertexBuffer9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9
Pointer to the IDirect3DVertexBuffer9 structure used to update the unmanaged pointer for this VertexBuffer object.


VertexBuffer.VertexBuffer Constructor ()

Creates a new instance of the VertexBuffer class.

Overload List

public VertexBuffer(Device, int, Usage, VertexFormats, Pool);
public VertexBuffer(IDirect3DVertexBuffer9);
public VertexBuffer(IDirect3DVertexBuffer9, Device, Usage, VertexFormats, Pool);
public VertexBuffer(IDirect3DVertexBuffer9, Type, int, Device, Usage, VertexFormats, Pool);
public VertexBuffer(IntPtr);
public VertexBuffer(Type, int, Device, Usage, VertexFormats, Pool);

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(IDirect3DVertexBuffer9) Constructor (Microsoft.DirectX.Direct3D)

VertexBuffer.VertexBuffer Constructor

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As IDirect3DVertexBuffer9 _
)
C# public VertexBuffer(
IDirect3DVertexBuffer9 pInterop
);
C++ public:
VertexBuffer(
IDirect3DVertexBuffer9 pInterop
);
JScript public function VertexBuffer(
pInterop : IDirect3DVertexBuffer9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9
Unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface pointer.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

VertexBuffer.VertexBuffer Constructor

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public VertexBuffer(
IntPtr unmanagedObject
);
C++ public:
VertexBuffer(
IntPtr unmanagedObject
);
JScript public function VertexBuffer(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(IDirect3DVertexBuffer9,Type,Int32,Device,Usage,VertexFormats,Pool) Constructor (Microsoft.DirectX.Direct3D)

VertexBuffer.VertexBuffer Constructor

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DVertexBuffer9, _
ByVal tType As Type, _
ByVal iNumVerts As Integer, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal vertexFormat As VertexFormats, _
ByVal Pool As Pool _
)
C# public VertexBuffer(
IDirect3DVertexBuffer9 lp,
Type tType,
int iNumVerts,
Device device,
Usage usage,
VertexFormats vertexFormat,
Pool Pool
);
C++ public:
VertexBuffer(
IDirect3DVertexBuffer9 lp,
Type^ tType,
int iNumVerts,
Device^ device,
Usage usage,
VertexFormats vertexFormat,
Pool Pool
);
JScript public function VertexBuffer(
lp : IDirect3DVertexBuffer9,
tType : Type,
iNumVerts : int,
device : Device,
usage : Usage,
vertexFormat : VertexFormats,
Pool : Pool
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9
Unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface pointer.
tType System.Type
iNumVerts System.Int32
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the vertex buffer.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the usage parameter in the VertexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Combination of VertexFormats flags that describe the vertex format of the vertices in the buffer.
Pool Microsoft.DirectX.Direct3D.Pool

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(IDirect3DVertexBuffer9,Device,Usage,VertexFormats,Pool) Constructor (Microsoft.DirectX.Direct3D)

VertexBuffer.VertexBuffer Constructor

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DVertexBuffer9, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal vertexFormat As VertexFormats, _
ByVal pool As Pool _
)
C# public VertexBuffer(
IDirect3DVertexBuffer9 lp,
Device device,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
C++ public:
VertexBuffer(
IDirect3DVertexBuffer9 lp,
Device^ device,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
JScript public function VertexBuffer(
lp : IDirect3DVertexBuffer9,
device : Device,
usage : Usage,
vertexFormat : VertexFormats,
pool : Pool
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9
Unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the vertex buffer.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the usage parameter in the VertexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Combination of VertexFormats flags that describe the vertex format of the vertices in the buffer.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes a valid memory class in which to place the resource.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(Device,Int32,Usage,VertexFormats,Pool) Constructor (Microsoft.DirectX.Direct3D)

VertexBuffer.VertexBuffer Constructor

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal sizeOfBufferInBytes As Integer, _
ByVal usage As Usage, _
ByVal vertexFormat As VertexFormats, _
ByVal pool As Pool _
)
C# public VertexBuffer(
Device device,
int sizeOfBufferInBytes,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
C++ public:
VertexBuffer(
Device^ device,
int sizeOfBufferInBytes,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
JScript public function VertexBuffer(
device : Device,
sizeOfBufferInBytes : int,
usage : Usage,
vertexFormat : VertexFormats,
pool : Pool
);

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the vertex buffer.
sizeOfBufferInBytes System.Int32
Size of the vertex buffer in bytes. If param_VertexFormats_vertexFormat is set to 0, param_Int32_sizeOfBufferInBytes must be large enough to contain at least one vertex, but it need not be a multiple of the vertex size. If param_VertexFormats_vertexFormat is not set to 0, param_Int32_sizeOfBufferInBytes is not validated. See Remarks.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the usage parameter in the VertexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Combination of VertexFormats flags that describe the vertex format of the vertices in the buffer.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes a valid memory class in which to place the resource.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.VertexBuffer(Type,Int32,Device,Usage,VertexFormats,Pool) Constructor (Microsoft.DirectX.Direct3D)

VertexBuffer.VertexBuffer Constructor

Creates a new instance of the VertexBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal typeVertexType As Type, _
ByVal numVerts As Integer, _
ByVal device As Device, _
ByVal usage As Usage, _
ByVal vertexFormat As VertexFormats, _
ByVal pool As Pool _
)
C# public VertexBuffer(
Type typeVertexType,
int numVerts,
Device device,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
C++ public:
VertexBuffer(
Type^ typeVertexType,
int numVerts,
Device^ device,
Usage usage,
VertexFormats vertexFormat,
Pool pool
);
JScript public function VertexBuffer(
typeVertexType : Type,
numVerts : int,
device : Device,
usage : Usage,
vertexFormat : VertexFormats,
pool : Pool
);

Parameters

typeVertexType System.Type
Member of the Type Leave Site enumerated type that indicates the type of vertex data the buffer holds. This can be a value type or any type that contains only value types.
numVerts System.Int32
Maximum number of vertices the buffer can hold.
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the vertex buffer.
usage Microsoft.DirectX.Direct3D.Usage
Usage can be 0, which indicates no usage value. However, if usage is desired, use a combination of one or more Usage flags. It is good practice to match the usage parameter in the VertexBuffer constructor with the behavior flags in the Device constructor. See Remarks.
vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Combination of VertexFormats flags that describe the vertex format of the vertices in the buffer.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes a valid memory class in which to place the resource.

Remarks

A vertex buffer can be used with either hardware or software vertex processing. The type of processing is determined by the way the device and the vertex buffer are created.

When a device is created, the Device constructor uses the behavior flag to determine whether to process vertices in hardware or software. The options are:

  • Process vertices in hardware by setting HardwareVertexProcessing.
  • Process vertices in software by setting SoftwareVertexProcessing.
  • Process vertices in either hardware or software by setting MixedVertexProcessing.

After the device is created, mixed-mode devices might need to switch between software and hardware processing (using Device.SoftwareVertexProcessing).

When a vertex buffer is created, the VertexBuffer constructor uses the param_Usage_usage parameter to determine whether to process vertices in hardware or software. The following rules apply.

  • If the Device constructor uses HardwareVertexProcessing, the VertexBuffer constructor must use 0.
  • If the Device constructor uses SoftwareVertexProcessing, the VertexBuffer constructor must use either 0 or SoftwareVertexProcessing. For either value, vertices are processed in software.
  • If the Device constructor uses MixedVertexProcessing, the VertexBuffer constructor can use either 0 or SoftwareVertexProcessing.

To use a vertex buffer with a mixed-mode device, create one that can be used for both hardware and software processing. Use Device.SetStreamSource to set the current vertex buffer and Device.RenderState, if necessary, to change the device behavior to match. It is recommended that the vertex buffer usage match the device behavior. Note that a vertex buffer created for software processing cannot be located in video memory.

The Device object supports rendering of primitives using vertex data stored in vertex buffer objects. Vertex buffers are created from the Device, and are usable only with the Device object from which they are created.

Those VertexBuffer constructors that are created with the param_VertexFormats_vertexFormat parameter set to 0 can be used to interleave data during multipass or multitexture rendering in a single pass. To do this, one buffer contains geometry data and the others contain texture coordinates for each texture to render. When rendering, the buffer that contains the geometry data is interleaved with each of the buffers that contain the texture coordinates. If the param_VertexFormats_vertexFormat parameter is set to a non-zero value, each buffer must contain identical geometry data in addition to the texture coordinate data specific to each rendered texture. This results in either a speed or memory penalty, depending on the strategy used.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Description
  • Device.ProcessVertices


VertexBuffer.Description Property (Microsoft.DirectX.Direct3D)

VertexBuffer.Description Property

Retrieves a description of the vertex buffer resource.

Definition

Visual Basic | Public ReadOnly Property Description As VertexBufferDescription
C# | public VertexBufferDescription Description { get; }
C++ public:
property VertexBufferDescription Description {
VertexBufferDescription get();
}
JScript | public function get Description() : VertexBufferDescription

Property Value

Microsoft.DirectX.Direct3D.VertexBufferDescription
A VertexBufferDescription structure that describes the returned vertex buffer.

This property is read-only.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VertexBuffer.Disposed Property (Microsoft.DirectX.Direct3D)

VertexBuffer.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


VertexBuffer.SizeInBytes Property (Microsoft.DirectX.Direct3D)

VertexBuffer.SizeInBytes Property

Retrieves the size of the VertexBuffer data, in bytes.

Definition

Visual Basic | Public ReadOnly Property SizeInBytes As Integer
C# | public int SizeInBytes { get; }
C++ public:
property int SizeInBytes {
int get();
}
JScript | public function get SizeInBytes() : int

Property Value

System.Int32
The size of the VertexBuffer data, in bytes.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


VertexBuffer.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

VertexBuffer.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DVertexBuffer9 interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As IDirect3DVertexBuffer9
C# | public IDirect3DVertexBuffer9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DVertexBuffer9 UnmanagedComPointer {
IDirect3DVertexBuffer9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DVertexBuffer9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexBuffer9
Unmanaged IDirect3DVertexBuffer9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


VertexBuffer.Created Event (Microsoft.DirectX.Direct3D)

VertexBuffer.Created Event

Occurs after a device is reset and the VertexBuffer is re-created.

Definition

Visual Basic | Public Event Created As EventHandler
C# | public event EventHandler Created;
C++ public:
event EventHandler^ Created;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

Note: This event occurs only on Pool.Default resources.

To add an event handler that listens for a VertexBuffer.Created event, use the following C# code.

[C#]
vBuffer.Created += new System.EventHandler(this.CreatedEventHandler);


VertexBuffer.Disposing Event (Microsoft.DirectX.Direct3D)

VertexBuffer.Disposing Event

Occurs when the Dispose method is called or when the VertexBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.VertexBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the VertexBuffer object indicates whether that object has been disposed.


VertexDeclaration Class (Microsoft.DirectX.Direct3D)

VertexDeclaration Class

How Do I...?
  • Create a Vertex Declaration

Encapsulates the vertex shader declaration.

Definition

Visual Basic NotInheritable Public Class VertexDeclaration
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class VertexDeclaration : MarshalByRefObject, IDisposable
C++ | public ref class VertexDeclaration sealed : MarshalByRefObject, IDisposable
JScript | public final class VertexDeclaration extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the VertexDeclaration object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the VertexDeclaration object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the VertexDeclaration object to free resources before it is destroyed by the garbage collector.
GetDeclaration | Gets the vertex shader declaration.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.VertexDeclaration.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this VertexDeclaration object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
VertexDeclaration | Creates a new instance of the VertexDeclaration class.

Properties

Property | Description
Device | Retrieves the Device used to create the current vertex declaration.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
VertexDeclaration

Remarks

A vertex shader declaration is made up of an array of vertex elements.

How Do I...?

Create a Vertex Declaration

This example demonstrates how to create a vertex declaration.

[C#]

As shown in the following C# code example, first declare a VertexElement array to hold the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).

Create a VertexDeclaration instance using the Device and VertexElement array previously created.

Note: The offset parameter of each element is the cumulative offset of the elements from the start of the declaration. For example, the second element is offset 12 bytes, since it is three floats of four bytes each, or (3 * sizeof(float) = 12).

// Create the vertex element array.
VertexElement[] elements = new VertexElement[]
{
    new VertexElement(0, 0, DeclarationType.Float3,
                            DeclarationMethod.Default,
                            DeclarationUsage.Position, 0),

    new VertexElement(0, 12, DeclarationType.Float3,
                             DeclarationMethod.Default,
                             DeclarationUsage.Normal, 0),

    new VertexElement(0, 24, DeclarationType.Float2,
                             DeclarationMethod.Default,
                             DeclarationUsage.TextureCoordinate, 0),

    VertexElement.VertexDeclarationEnd
};

// Use the vertex element array to create a vertex declaration.
VertexDeclaration decl = new VertexDeclaration(device, elements);

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexDeclaration.Dispose() Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.Dispose Method

Immediately releases the unmanaged resources used by the VertexDeclaration object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~VertexDeclaration();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.VertexDeclaration.Disposed
  • Microsoft.DirectX.Direct3D.VertexDeclaration.Disposing


VertexDeclaration.Equals(Object) Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


VertexDeclaration.Finalize() Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.Finalize Method

Allows the VertexDeclaration object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~VertexDeclaration();
C++ | !VertexDeclaration();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


VertexDeclaration.GetDeclaration() Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.GetDeclaration Method

Gets the vertex shader declaration.

Definition

Visual Basic | Public Function GetDeclaration() As VertexElement()
C# | public VertexElement[] GetDeclaration();
C++ public:
array<VertexElement>^ GetDeclaration();
JScript | public function GetDeclaration() : VertexElement[];

Return Value

Microsoft.DirectX.Direct3D.VertexElement[]
Array of vertex elements that make up a vertex shader declaration. The array ends with the value in the VertexDeclarationEnd field.

Remarks

The size of the array includes the VertexDeclarationEnd field, which ends the declaration. This means that the array count is actually higher than the number of valid vertex elements by one.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VertexDeclaration.GetHashCode() Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


VertexDeclaration.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVertexDeclaration9, which allows unmanaged COM clients to create an instance of the managed VertexDeclaration class. Not supported.


VertexDeclaration.op_Equality(VertexDeclaration,VertexDeclaration) Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As VertexDeclaration, _
ByVal right As VertexDeclaration _
) As Boolean
C# public static bool op_Equality(
VertexDeclaration left,
VertexDeclaration right
);
C++ public:
static bool operator==(
VertexDeclaration^ left,
VertexDeclaration^ right
);
JScript public static function op_Equality(
left : VertexDeclaration,
right : VertexDeclaration
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.VertexDeclaration
The VertexDeclaration object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.VertexDeclaration
The VertexDeclaration object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


VertexDeclaration.op_Inequality(VertexDeclaration,VertexDeclaration) Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As VertexDeclaration, _
ByVal right As VertexDeclaration _
) As Boolean
C# public static bool op_Inequality(
VertexDeclaration left,
VertexDeclaration right
);
C++ public:
static bool operator!=(
VertexDeclaration^ left,
VertexDeclaration^ right
);
JScript public static function op_Inequality(
left : VertexDeclaration,
right : VertexDeclaration
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.VertexDeclaration
The VertexDeclaration object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.VertexDeclaration
The VertexDeclaration object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


VertexDeclaration.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.VertexDeclaration.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


VertexDeclaration.UpdateUnmanagedPointer(IDirect3DVertexDeclaration9) Method (Microsoft.DirectX.Direct3D)

VertexDeclaration.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this VertexDeclaration object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVertexDeclaration9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVertexDeclaration9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DVertexDeclaration9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DVertexDeclaration9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexDeclaration9
Pointer to the IDirect3DVertexDeclaration9 structure used to update the unmanaged pointer for this VertexDeclaration object.


VertexDeclaration.VertexDeclaration Constructor ()

Creates a new instance of the VertexDeclaration class.

Overload List

public VertexDeclaration(Device, GraphicsStream);
public VertexDeclaration(Device, VertexElement[]);
public VertexDeclaration(IDirect3DVertexDeclaration9);
public VertexDeclaration(IDirect3DVertexDeclaration9, Device);
public VertexDeclaration(IntPtr);


VertexDeclaration.VertexDeclaration(IDirect3DVertexDeclaration9) Constructor (Microsoft.DirectX.Direct3D)

VertexDeclaration.VertexDeclaration Constructor

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DVertexDeclaration9 _
)
C# public VertexDeclaration(
IDirect3DVertexDeclaration9 pUnk
);
C++ public:
VertexDeclaration(
IDirect3DVertexDeclaration9 pUnk
);
JScript public function VertexDeclaration(
pUnk : IDirect3DVertexDeclaration9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexDeclaration9
Unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface pointer.


VertexDeclaration.VertexDeclaration(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

VertexDeclaration.VertexDeclaration Constructor

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public VertexDeclaration(
IntPtr unmanagedObject
);
C++ public:
VertexDeclaration(
IntPtr unmanagedObject
);
JScript public function VertexDeclaration(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


VertexDeclaration.VertexDeclaration(IDirect3DVertexDeclaration9,Device) Constructor (Microsoft.DirectX.Direct3D)

VertexDeclaration.VertexDeclaration Constructor

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DVertexDeclaration9, _
ByVal device As Device _
)
C# public VertexDeclaration(
IDirect3DVertexDeclaration9 lp,
Device device
);
C++ public:
VertexDeclaration(
IDirect3DVertexDeclaration9 lp,
Device^ device
);
JScript public function VertexDeclaration(
lp : IDirect3DVertexDeclaration9,
device : Device
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexDeclaration9
Unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the VertexDeclaration.


VertexDeclaration.VertexDeclaration(Device,VertexElement[]) Constructor (Microsoft.DirectX.Direct3D)

VertexDeclaration.VertexDeclaration Constructor

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal vertexElements() As VertexElement _
)
C# public VertexDeclaration(
Device device,
VertexElement[] vertexElements
);
C++ public:
VertexDeclaration(
Device^ device,
array<VertexElement>^ vertexElements
);
JScript public function VertexDeclaration(
device : Device,
vertexElements : VertexElement[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the VertexDeclaration.
vertexElements Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement flags that make up a vertex shader declaration. The array must end with the value in the VertexElement.VertexDeclarationEnd field.


VertexDeclaration.VertexDeclaration(Device,GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

VertexDeclaration.VertexDeclaration Constructor

Creates a new instance of the VertexDeclaration class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal vertexElements As GraphicsStream _
)
C# public VertexDeclaration(
Device device,
GraphicsStream vertexElements
);
C++ public:
VertexDeclaration(
Device^ device,
GraphicsStream^ vertexElements
);
JScript public function VertexDeclaration(
device : Device,
vertexElements : GraphicsStream
);

Parameters

device Microsoft.DirectX.Direct3D.Device
The Device object to associate with the VertexDeclaration.
vertexElements Microsoft.DirectX.GraphicsStream
A GraphicsStream object containing VertexElement flags that make up a vertex shader declaration.


VertexDeclaration.Device Property (Microsoft.DirectX.Direct3D)

VertexDeclaration.Device Property

Retrieves the Device used to create the current vertex declaration.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
Device used to create the vertex declaration.

This property is read-only.


VertexDeclaration.Disposed Property (Microsoft.DirectX.Direct3D)

VertexDeclaration.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


VertexDeclaration.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

VertexDeclaration.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DVertexDeclaration9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DVertexDeclaration9
C# | public IDirect3DVertexDeclaration9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DVertexDeclaration9 UnmanagedComPointer {
IDirect3DVertexDeclaration9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DVertexDeclaration9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexDeclaration9
Unmanaged IDirect3DVertexDeclaration9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


VertexDeclaration.Disposing Event (Microsoft.DirectX.Direct3D)

VertexDeclaration.Disposing Event

Occurs when the Dispose method is called or when the VertexDeclaration object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.VertexDeclaration.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the VertexDeclaration object indicates whether that object has been disposed.


VertexInformation Class (Microsoft.DirectX.Direct3D)

VertexInformation Class

Retrieves vertex information.

Definition

Visual Basic NotInheritable MustInherit Public Class VertexInformation
Inherits Object
C# | public abstract sealed class VertexInformation : Object
C++ | public ref class VertexInformation abstract sealed : Object
JScript | public final abstract class VertexInformation extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) DeclaratorFromFormat | Returns a declaration from a vertex format.
static (Shared in Visual Basic) FormatFromDeclarator | Returns a VertexFormats structure from a declaration.
static (Shared in Visual Basic) GenerateDeclaration | Generates an output vertex declaration from the input declaration.
static (Shared in Visual Basic) GetDeclarationVertexSize | Returns the size of the vertex declaration for a flexible vertex format (FVF).
static (Shared in Visual Basic) GetFormatSize | Returns the size of the vertex format.

Inheritance Hierarchy

Object Leave Site
VertexInformation

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexInformation.DeclaratorFromFormat(VertexFormats) Method (Microsoft.DirectX.Direct3D)

VertexInformation.DeclaratorFromFormat Method

Returns a declaration from a vertex format.

Definition

Visual Basic Public Shared Function DeclaratorFromFormat( _
ByVal vertexFormat As VertexFormats _
) As VertexElement()
C# public static VertexElement[] DeclaratorFromFormat(
VertexFormats vertexFormat
);
C++ public:
static array<VertexElement>^ DeclaratorFromFormat(
VertexFormats vertexFormat
);
JScript public static function DeclaratorFromFormat(
vertexFormat : VertexFormats
) : VertexElement[];

Parameters

vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
One or more VertexFormats flags that describe the vertex format from which to generate the returned declaration array.

Return Value

Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that describe the vertex format of the mesh vertices.

Remarks

Exceptions
InvalidMeshException The mesh is invalid.

See Also

  • FormatFromDeclarator


VertexInformation.FormatFromDeclarator(VertexElement[]) Method (Microsoft.DirectX.Direct3D)

VertexInformation.FormatFromDeclarator Method

Returns a VertexFormats structure from a declaration.

Definition

Visual Basic Public Shared Function FormatFromDeclarator( _
ByVal declarator() As VertexElement _
) As VertexFormats
C# public static VertexFormats FormatFromDeclarator(
VertexElement[] declarator
);
C++ public:
static VertexFormats FormatFromDeclarator(
array<VertexElement>^ declarator
);
JScript public static function FormatFromDeclarator(
declarator : VertexElement[]
) : VertexFormats;

Parameters

declarator Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that describe the VertexFormats code.

Return Value

Microsoft.DirectX.Direct3D.VertexFormats
Combination of VertexFormats flags that describe the vertex format returned from the declaration.

Remarks

This method fails for any declaration that does not map directly to a vertex format.

Exceptions
InvalidCallException The call is invalid.

See Also

  • DeclaratorFromFormat


VertexInformation.GenerateDeclaration(VertexElement[]) Method (Microsoft.DirectX.Direct3D)

VertexInformation.GenerateDeclaration Method

Generates an output vertex declaration from the input declaration.

Definition

Visual Basic Public Shared Function GenerateDeclaration( _
ByVal declarator() As VertexElement _
) As VertexElement()
C# public static VertexElement[] GenerateDeclaration(
VertexElement[] declarator
);
C++ public:
static array<VertexElement>^ GenerateDeclaration(
array<VertexElement>^ declarator
);
JScript public static function GenerateDeclaration(
declarator : VertexElement[]
) : VertexElement[];

Parameters

declarator Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that represent the input vertex declaration.

Return Value

Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that represent the output vertex declaration.

Remarks

The output declaration is used by the mesh tessellation functions.

Exceptions
InvalidCallException The call is invalid.


VertexInformation.GetDeclarationVertexSize(VertexElement[],Int32) Method (Microsoft.DirectX.Direct3D)

VertexInformation.GetDeclarationVertexSize Method

Returns the size of the vertex declaration for a flexible vertex format (FVF).

Definition

Visual Basic Public Shared Function GetDeclarationVertexSize( _
ByVal declarator() As VertexElement, _
ByVal stream As Integer _
) As Integer
C# public static int GetDeclarationVertexSize(
VertexElement[] declarator,
int stream
);
C++ public:
static int GetDeclarationVertexSize(
array<VertexElement>^ declarator,
int stream
);
JScript public static function GetDeclarationVertexSize(
declarator : VertexElement[],
stream : int
) : int;

Parameters

declarator Microsoft.DirectX.Direct3D.VertexElement[]
Array of VertexElement structures that represent the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).
stream System.Int32
Specifies the vertex data stream, in the range from 0 to the maximum number of streams -1.

Return Value

System.Int32
The vertex declaration size, in bytes.

Remarks

A stream is defined as a uniform array of component data, where each component consists of one or more elements representing a single entity such as position, normal, color, and so on.


VertexInformation.GetFormatSize(VertexFormats) Method (Microsoft.DirectX.Direct3D)

VertexInformation.GetFormatSize Method

Returns the size of the vertex format.

Definition

Visual Basic Public Shared Function GetFormatSize( _
ByVal vertexFormat As VertexFormats _
) As Integer
C# public static int GetFormatSize(
VertexFormats vertexFormat
);
C++ public:
static int GetFormatSize(
VertexFormats vertexFormat
);
JScript public static function GetFormatSize(
vertexFormat : VertexFormats
) : int;

Parameters

vertexFormat Microsoft.DirectX.Direct3D.VertexFormats
Vertex format for which to return size.

Return Value

System.Int32
An Int32 Leave Site value that indicates the size of the vertex format.

Remarks

Exceptions
InvalidMeshException The mesh is invalid.


VertexShader Class (Microsoft.DirectX.Direct3D)

VertexShader Class

Encapsulates the functionality of a vertex shader.

Definition

Visual Basic Public Class VertexShader
Inherits MarshalByRefObject
Implements IDisposable
C# | public class VertexShader : MarshalByRefObject, IDisposable
C++ | public ref class VertexShader : MarshalByRefObject, IDisposable
JScript | public class VertexShader extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the VertexShader object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the VertexShader object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the VertexShader object to free resources before it is destroyed by the garbage collector.
GetFunction | Retrieves an array that contains shader data.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.VertexShader.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this VertexShader object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
VertexShader | Initializes a new instance of the VertexShader class.

Properties

Property | Description
Device | Retrieves the Microsoft Direct3D device associated with a vertex shader object.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
VertexShader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexShader.Dispose() Method (Microsoft.DirectX.Direct3D)

VertexShader.Dispose Method

Immediately releases the unmanaged resources used by the VertexShader object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~VertexShader();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.VertexShader.Disposed
  • Microsoft.DirectX.Direct3D.VertexShader.Disposing


VertexShader.Equals(Object) Method (Microsoft.DirectX.Direct3D)

VertexShader.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


VertexShader.Finalize() Method (Microsoft.DirectX.Direct3D)

VertexShader.Finalize Method

Allows the VertexShader object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~VertexShader();
C++ | !VertexShader();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


VertexShader.GetFunction() Method (Microsoft.DirectX.Direct3D)

VertexShader.GetFunction Method

Retrieves an array that contains shader data.

Definition

Visual Basic | Public Function GetFunction() As Integer()
C# | public int[] GetFunction();
C++ public:
array<int>^ GetFunction();
JScript | public function GetFunction() : int[];

Return Value

System.Int32[]
Array that contains the shader data.

Remarks

Exceptions
ArgumentException Leave Site | An error occurred while trying to retrieve the shader data.
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.


VertexShader.GetHashCode() Method (Microsoft.DirectX.Direct3D)

VertexShader.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


VertexShader.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

VertexShader.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVertexShader9, which allows unmanaged COM clients to create an instance of the managed VertexShader class. Not supported.


VertexShader.op_Equality(VertexShader,VertexShader) Method (Microsoft.DirectX.Direct3D)

VertexShader.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As VertexShader, _
ByVal right As VertexShader _
) As Boolean
C# public static bool op_Equality(
VertexShader left,
VertexShader right
);
C++ public:
static bool operator==(
VertexShader^ left,
VertexShader^ right
);
JScript public static function op_Equality(
left : VertexShader,
right : VertexShader
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.VertexShader
The VertexShader object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.VertexShader
The VertexShader object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


VertexShader.op_Inequality(VertexShader,VertexShader) Method (Microsoft.DirectX.Direct3D)

VertexShader.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As VertexShader, _
ByVal right As VertexShader _
) As Boolean
C# public static bool op_Inequality(
VertexShader left,
VertexShader right
);
C++ public:
static bool operator!=(
VertexShader^ left,
VertexShader^ right
);
JScript public static function op_Inequality(
left : VertexShader,
right : VertexShader
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.VertexShader
The VertexShader object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.VertexShader
The VertexShader object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


VertexShader.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

VertexShader.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.VertexShader.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


VertexShader.UpdateUnmanagedPointer(IDirect3DVertexShader9) Method (Microsoft.DirectX.Direct3D)

VertexShader.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this VertexShader object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVertexShader9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVertexShader9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DVertexShader9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DVertexShader9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexShader9
Pointer to the IDirect3DVertexShader9 structure used to update the unmanaged pointer for this VertexShader object.


VertexShader.VertexShader Constructor ()

Initializes a new instance of the VertexShader class.

Overload List

public VertexShader(Device, GraphicsStream);
public VertexShader(Device, int[]);
public VertexShader(IDirect3DVertexShader9);
public VertexShader(IDirect3DVertexShader9, Device);
public VertexShader(IntPtr);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(IDirect3DVertexShader9) Constructor (Microsoft.DirectX.Direct3D)

VertexShader.VertexShader Constructor

Initializes a new instance of the VertexShader class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DVertexShader9 _
)
C# public VertexShader(
IDirect3DVertexShader9 pUnk
);
C++ public:
VertexShader(
IDirect3DVertexShader9 pUnk
);
JScript public function VertexShader(
pUnk : IDirect3DVertexShader9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexShader9
Unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface pointer.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

VertexShader.VertexShader Constructor

Initializes a new instance of the VertexShader class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public VertexShader(
IntPtr unmanagedObject
);
C++ public:
VertexShader(
IntPtr unmanagedObject
);
JScript public function VertexShader(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(IDirect3DVertexShader9,Device) Constructor (Microsoft.DirectX.Direct3D)

VertexShader.VertexShader Constructor

Initializes a new instance of the VertexShader class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DVertexShader9, _
ByVal device As Device _
)
C# public VertexShader(
IDirect3DVertexShader9 lp,
Device device
);
C++ public:
VertexShader(
IDirect3DVertexShader9 lp,
Device^ device
);
JScript public function VertexShader(
lp : IDirect3DVertexShader9,
device : Device
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexShader9
Unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
Reference to an instance of a Device object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(Device,GraphicsStream) Constructor (Microsoft.DirectX.Direct3D)

VertexShader.VertexShader Constructor

Initializes a new instance of the VertexShader class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal functionToken As GraphicsStream _
)
C# public VertexShader(
Device device,
GraphicsStream functionToken
);
C++ public:
VertexShader(
Device^ device,
GraphicsStream^ functionToken
);
JScript public function VertexShader(
device : Device,
functionToken : GraphicsStream
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to an instance of a Device object.
functionToken Microsoft.DirectX.GraphicsStream
Reference to a GraphicsStream object that represents the vertex shader function tokens to use.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.VertexShader(Device,Int32[]) Constructor (Microsoft.DirectX.Direct3D)

VertexShader.VertexShader Constructor

Initializes a new instance of the VertexShader class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal functionToken() As Integer _
)
C# public VertexShader(
Device device,
int[] functionToken
);
C++ public:
VertexShader(
Device^ device,
array<int>^ functionToken
);
JScript public function VertexShader(
device : Device,
functionToken : int[]
);

Parameters

device Microsoft.DirectX.Direct3D.Device
Reference to an instance of a Device object.
functionToken System.Int32[]
Integer array representing the vertex shader function tokens that specify the blending operations.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VertexShader.Device Property (Microsoft.DirectX.Direct3D)

VertexShader.Device Property

Retrieves the Microsoft Direct3D device associated with a vertex shader object.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
A Device reference that represents the Direct3D device object associated with the vertex shader object.

This property is read-only.


VertexShader.Disposed Property (Microsoft.DirectX.Direct3D)

VertexShader.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


VertexShader.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

VertexShader.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DVertexShader9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DVertexShader9
C# | public IDirect3DVertexShader9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DVertexShader9 UnmanagedComPointer {
IDirect3DVertexShader9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DVertexShader9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVertexShader9
Unmanaged IDirect3DVertexShader9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


VertexShader.Disposing Event (Microsoft.DirectX.Direct3D)

VertexShader.Disposing Event

Occurs when the Dispose method is called or when the VertexShader object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.VertexShader.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the VertexShader object indicates whether that object has been disposed.


VertexTextureCoordinate Class (Microsoft.DirectX.Direct3D)

VertexTextureCoordinate Class

Constructs bit patterns that are used to identify texture coordinate formats in a flexible vertex format description.

Definition

Visual Basic NotInheritable MustInherit Public Class VertexTextureCoordinate
Inherits Object
C# | public abstract sealed class VertexTextureCoordinate : Object
C++ | public ref class VertexTextureCoordinate abstract sealed : Object
JScript | public final abstract class VertexTextureCoordinate extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) Size1 | Constructs bit patterns that are used to identify texture coordinate size-1 formats within a flexible vertex format description.
static (Shared in Visual Basic) Size2 | Constructs bit patterns that are used to identify texture coordinate size-2 formats within a flexible vertex format description.
static (Shared in Visual Basic) Size3 | Constructs bit patterns that are used to identify texture coordinate size-3 formats within a flexible vertex format description.
static (Shared in Visual Basic) Size4 | Constructs bit patterns that are used to identify texture coordinate size-4 formats within a flexible vertex format description.

Inheritance Hierarchy

Object Leave Site
VertexTextureCoordinate

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexTextureCoordinate.Size1(Int32) Method (Microsoft.DirectX.Direct3D)

VertexTextureCoordinate.Size1 Method

Constructs bit patterns that are used to identify texture coordinate size-1 formats within a flexible vertex format description.

Definition

Visual Basic Public Shared Function Size1( _
ByVal coordIndex As Integer _
) As VertexFormats
C# public static VertexFormats Size1(
int coordIndex
);
C++ public:
static VertexFormats Size1(
int coordIndex
);
JScript public static function Size1(
coordIndex : int
) : VertexFormats;

Parameters

coordIndex System.Int32
Value that identifies the texture coordinate set to which the texture coordinate size (1-, 2-, 3-, or 4-dimensional) applies.

Return Value

Microsoft.DirectX.Direct3D.VertexFormats
One or more VertexFormats flags that indicate the texture coordinate.


VertexTextureCoordinate.Size2() Method (Microsoft.DirectX.Direct3D)

VertexTextureCoordinate.Size2 Method

Constructs bit patterns that are used to identify texture coordinate size-2 formats within a flexible vertex format description.

Definition

Visual Basic | Public Shared Function Size2() As VertexFormats
C# | public static VertexFormats Size2();
C++ public:
static VertexFormats Size2();
JScript | public static function Size2() : VertexFormats;

Return Value

Microsoft.DirectX.Direct3D.VertexFormats
One or more VertexFormats flags that indicate the texture coordinate.


VertexTextureCoordinate.Size3(Int32) Method (Microsoft.DirectX.Direct3D)

VertexTextureCoordinate.Size3 Method

Constructs bit patterns that are used to identify texture coordinate size-3 formats within a flexible vertex format description.

Definition

Visual Basic Public Shared Function Size3( _
ByVal coordIndex As Integer _
) As VertexFormats
C# public static VertexFormats Size3(
int coordIndex
);
C++ public:
static VertexFormats Size3(
int coordIndex
);
JScript public static function Size3(
coordIndex : int
) : VertexFormats;

Parameters

coordIndex System.Int32
Value that identifies the texture coordinate set to which the texture coordinate size (1-, 2-, 3-, or 4-dimensional) applies.

Return Value

Microsoft.DirectX.Direct3D.VertexFormats
One or more VertexFormats flags that indicate the texture coordinate.


VertexTextureCoordinate.Size4(Int32) Method (Microsoft.DirectX.Direct3D)

VertexTextureCoordinate.Size4 Method

Constructs bit patterns that are used to identify texture coordinate size-4 formats within a flexible vertex format description.

Definition

Visual Basic Public Shared Function Size4( _
ByVal coordIndex As Integer _
) As VertexFormats
C# public static VertexFormats Size4(
int coordIndex
);
C++ public:
static VertexFormats Size4(
int coordIndex
);
JScript public static function Size4(
coordIndex : int
) : VertexFormats;

Parameters

coordIndex System.Int32
Value that identifies the texture coordinate set to which the texture coordinate size (1-, 2-, 3-, or 4-dimensional) applies.

Return Value

Microsoft.DirectX.Direct3D.VertexFormats
One or more VertexFormats flags that indicate the texture coordinate.


Volume Class (Microsoft.DirectX.Direct3D)

Volume Class

Manipulates volume resources.

Definition

Visual Basic NotInheritable Public Class Volume
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class Volume : MarshalByRefObject, IDisposable
C++ | public ref class Volume sealed : MarshalByRefObject, IDisposable
JScript | public final class Volume extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Volume object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Volume object.
Finalize | Allows the Volume object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current volume.
GetContainer | Provides access to the parent volume texture object, if the current surface is a child level of a volume texture.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with the volume to a provided buffer.
LockBox | Locks a box on a volume resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.Volume.Disposing event when called from within a derived class.
SetPrivateData | Associates data with the volume that is intended for use by the application, not by Microsoft Direct3D.
UnlockBox | Unlocks a box on a volume resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Volume object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
Volume | Initializes a new instance of the Volume class.

Properties

Property | Description
Description | Retrieves the description of a volume.
Device | Retrieves the Direct3D device associated with a sprite object.
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DVolume9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Volume

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Volume.Dispose() Method (Microsoft.DirectX.Direct3D)

Volume.Dispose Method

Immediately releases the unmanaged resources used by the Volume object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Volume();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.Volume.Disposed
  • Microsoft.DirectX.Direct3D.Volume.Disposing


Volume.Finalize() Method (Microsoft.DirectX.Direct3D)

Volume.Finalize Method

Allows the Volume object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Volume();
C++ | !Volume();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Volume.FreePrivateData(Guid) Method (Microsoft.DirectX.Direct3D)

Volume.FreePrivateData Method

Frees the specified private data associated with the current volume.

Definition

Visual Basic Public Sub FreePrivateData( _
ByVal guidData As Guid _
)
C# public void FreePrivateData(
Guid guidData
);
C++ public:
void FreePrivateData(
Guid guidData
);
JScript public function FreePrivateData(
guidData : Guid
);

Parameters

guidData System.Guid
A Guid Leave Site that identifies the private data to free.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested item was not found.

See Also

  • Volume.GetPrivateData
  • Volume.SetPrivateData


Volume.GetContainer(Guid) Method (Microsoft.DirectX.Direct3D)

Volume.GetContainer Method

Provides access to the parent volume texture object, if the current surface is a child level of a volume texture.

Definition

Visual Basic Public Function GetContainer( _
ByVal interfaceId As Guid _
) As Object
C# public object GetContainer(
Guid interfaceId
);
C++ public:
Object^ GetContainer(
Guid interfaceId
);
JScript public function GetContainer(
interfaceId : Guid
) : Object;

Parameters

interfaceId System.Guid

Return Value

System.Object
An Object Leave Site that represents the returned container.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

Volume.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVolume9, which allows unmanaged COM clients to create an instance of the managed Volume class. Not supported.


Volume.GetPrivateData(Guid) Method (Microsoft.DirectX.Direct3D)

Volume.GetPrivateData Method

Copies the private data associated with the volume to a provided buffer.

Definition

Visual Basic Public Function GetPrivateData( _
ByVal guidData As Guid _
) As Byte()
C# public byte[] GetPrivateData(
Guid guidData
);
C++ public:
array<unsigned char>^ GetPrivateData(
Guid guidData
);
JScript public function GetPrivateData(
guidData : Guid
) : byte[];

Parameters

guidData System.Guid
A Guid Leave Site that represents the identifier of the private data being requested.

Return Value

System.Byte[]
A Byte Leave Site array that contains the requested data.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
NotFoundException | The requested item was not found.
MoreDataException | More data is available than the specified buffer size can hold.

See Also

  • Volume.FreePrivateData
  • Volume.SetPrivateData


Volume.LockBox Method ()

Locks a box on a volume resource.

Overload List

public GraphicsStream LockBox(Box, LockFlags);
public GraphicsStream LockBox(Box, LockFlags, out LockedBox);
public GraphicsStream LockBox(LockFlags);
public GraphicsStream LockBox(LockFlags, out LockedBox);
public Array LockBox(Type, Box, LockFlags, int[]);
public Array LockBox(Type, Box, LockFlags, out LockedBox, int[]);
public Array LockBox(Type, LockFlags, int[]);
public Array LockBox(Type, LockFlags, out LockedBox, int[]);

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Box,LockFlags,LockedBox) Method (Microsoft.DirectX.Direct3D)

Volume.LockBox Method

Locks a box on a volume resource.

Definition

Visual Basic Public Function LockBox( _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox _
) As GraphicsStream
C# public GraphicsStream LockBox(
Box box,
LockFlags flags,
out LockedBox lockedVolume
);
C++ public:
GraphicsStream^ LockBox(
Box box,
LockFlags flags,
[Out] LockedBox% lockedVolume
);
JScript public function LockBox(
box : Box,
flags : LockFlags,
lockedVolume : LockedBox
) : GraphicsStream;

Parameters

box Microsoft.DirectX.Direct3D.Box
A Box object that represents the box to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
lockedVolume Microsoft.DirectX.Direct3D.LockedBox
A LockedBox object that describes the locked region.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(LockFlags,LockedBox) Method (Microsoft.DirectX.Direct3D)

Volume.LockBox Method

Locks a box on a volume resource.

Definition

Visual Basic Public Function LockBox( _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox _
) As GraphicsStream
C# public GraphicsStream LockBox(
LockFlags flags,
out LockedBox lockedVolume
);
C++ public:
GraphicsStream^ LockBox(
LockFlags flags,
[Out] LockedBox% lockedVolume
);
JScript public function LockBox(
flags : LockFlags,
lockedVolume : LockedBox
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
lockedVolume Microsoft.DirectX.Direct3D.LockedBox
A LockedBox object that describes the locked region.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Box,LockFlags) Method (Microsoft.DirectX.Direct3D)

Volume.LockBox Method

Locks a box on a volume resource.

Definition

Visual Basic Public Function LockBox( _
ByVal box As Box, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockBox(
Box box,
LockFlags flags
);
C++ public:
GraphicsStream^ LockBox(
Box box,
LockFlags flags
);
JScript public function LockBox(
box : Box,
flags : LockFlags
) : GraphicsStream;

Parameters

box Microsoft.DirectX.Direct3D.Box
A Box object that represents the box to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(LockFlags) Method (Microsoft.DirectX.Direct3D)

Volume.LockBox Method

Locks a box on a volume resource.

Definition

Visual Basic Public Function LockBox( _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockBox(
LockFlags flags
);
C++ public:
GraphicsStream^ LockBox(
LockFlags flags
);
JScript public function LockBox(
flags : LockFlags
) : GraphicsStream;

Parameters

flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Type,Box,LockFlags,LockedBox,Int32[]) Method (Microsoft.DirectX.Direct3D)

Volume.LockBox Method

Locks a box on a volume resource.

Definition

Visual Basic Public Function LockBox( _
ByVal typeLock As Type, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
Box box,
LockFlags flags,
out LockedBox lockedVolume,
int[] ranks
);
C++ public:
Array^ LockBox(
Type^ typeLock,
Box box,
LockFlags flags,
[Out] LockedBox% lockedVolume,
array<int>^ ranks
);
JScript public function LockBox(
typeLock : Type,
box : Box,
flags : LockFlags,
lockedVolume : LockedBox,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
Value that specifies the Type Leave Site of the lock.
box Microsoft.DirectX.Direct3D.Box
A Box object that represents the box to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
lockedVolume Microsoft.DirectX.Direct3D.LockedBox
A LockedBox object that describes the locked region.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Type,LockFlags,LockedBox,Int32[]) Method (Microsoft.DirectX.Direct3D)

Volume.LockBox Method

Locks a box on a volume resource.

Definition

Visual Basic Public Function LockBox( _
ByVal typeLock As Type, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
LockFlags flags,
out LockedBox lockedVolume,
int[] ranks
);
C++ public:
Array^ LockBox(
Type^ typeLock,
LockFlags flags,
[Out] LockedBox% lockedVolume,
array<int>^ ranks
);
JScript public function LockBox(
typeLock : Type,
flags : LockFlags,
lockedVolume : LockedBox,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
Value that specifies the Type Leave Site of the lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
lockedVolume Microsoft.DirectX.Direct3D.LockedBox
A LockedBox object that describes the locked region.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Type,Box,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

Volume.LockBox Method

Locks a box on a volume resource.

Definition

Visual Basic Public Function LockBox( _
ByVal typeLock As Type, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
Box box,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockBox(
Type^ typeLock,
Box box,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockBox(
typeLock : Type,
box : Box,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
Value that specifies the Type Leave Site of the lock.
box Microsoft.DirectX.Direct3D.Box
A Box object that represents the box to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.LockBox(Type,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

Volume.LockBox Method

Locks a box on a volume resource.

Definition

Visual Basic Public Function LockBox( _
ByVal typeLock As Type, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockBox(
Type^ typeLock,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockBox(
typeLock : Type,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
Value that specifies the Type Leave Site of the lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Combination of zero or more LockFlags that describe the type of lock to perform. See Remarks.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returned array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site that represents the locked box region.

Remarks

The valid lock flags for this method are:

  • LockFlags.Discard
  • LockFlags.NoDirtyUpdate
  • LockFlags.NoSystemLock
  • LockFlags.ReadOnly

For performance reasons, dirty regions are recorded only for level zero of a texture. Dirty regions are automatically recorded when Volume.LockBox is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


Volume.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

Volume.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.Volume.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Volume.SetPrivateData(Guid,Byte[]) Method (Microsoft.DirectX.Direct3D)

Volume.SetPrivateData Method

Associates data with the volume that is intended for use by the application, not by Microsoft Direct3D.

Definition

Visual Basic Public Sub SetPrivateData( _
ByVal guidData As Guid, _
ByVal privateData() As Byte _
)
C# public void SetPrivateData(
Guid guidData,
byte[] privateData
);
C++ public:
void SetPrivateData(
Guid guidData,
array<unsigned char>^ privateData
);
JScript public function SetPrivateData(
guidData : Guid,
privateData : byte[]
);

Parameters

guidData System.Guid
A Guid Leave Site that represents the identifier of the private data to set.
privateData System.Byte[]
A Byte Leave Site array that contains the private data for the current volume.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.

See Also

  • Volume.FreePrivateData
  • Volume.GetPrivateData


Volume.UnlockBox() Method (Microsoft.DirectX.Direct3D)

Volume.UnlockBox Method

Unlocks a box on a volume resource.

Definition

Visual Basic | Public Sub UnlockBox()
C# | public void UnlockBox();
C++ public:
void UnlockBox();
JScript | public function UnlockBox();

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • Volume.LockBox


Volume.UpdateUnmanagedPointer(IDirect3DVolume9) Method (Microsoft.DirectX.Direct3D)

Volume.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this Volume object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As IDirect3DVolume9 _
)
C# public void UpdateUnmanagedPointer(
IDirect3DVolume9 pInterface
);
C++ public:
void UpdateUnmanagedPointer(
IDirect3DVolume9 pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : IDirect3DVolume9
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolume9
Pointer to the IDirect3DVolume9 structure used to update the unmanaged pointer for this Volume object.


Volume.Volume Constructor ()

Initializes a new instance of the Volume class.

Overload List

public Volume(IDirect3DVolume9);
public Volume(IDirect3DVolume9, VolumeTexture);
public Volume(IntPtr);


Volume.Volume(IDirect3DVolume9) Constructor (Microsoft.DirectX.Direct3D)

Volume.Volume Constructor

Initializes a new instance of the Volume class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As IDirect3DVolume9 _
)
C# public Volume(
IDirect3DVolume9 pUnk
);
C++ public:
Volume(
IDirect3DVolume9 pUnk
);
JScript public function Volume(
pUnk : IDirect3DVolume9
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolume9
Unmanaged Component Object Model (COM) IDirect3DVolume9 interface pointer.


Volume.Volume(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

Volume.Volume Constructor

Initializes a new instance of the Volume class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public Volume(
IntPtr unmanagedObject
);
C++ public:
Volume(
IntPtr unmanagedObject
);
JScript public function Volume(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DVolume9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


Volume.Volume(IDirect3DVolume9,VolumeTexture) Constructor (Microsoft.DirectX.Direct3D)

Volume.Volume Constructor

Initializes a new instance of the Volume class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DVolume9, _
ByVal device As VolumeTexture _
)
C# public Volume(
IDirect3DVolume9 lp,
VolumeTexture device
);
C++ public:
Volume(
IDirect3DVolume9 lp,
VolumeTexture^ device
);
JScript public function Volume(
lp : IDirect3DVolume9,
device : VolumeTexture
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolume9
Unmanaged Component Object Model (COM) IDirect3DVolume9 interface pointer.
device Microsoft.DirectX.Direct3D.VolumeTexture
A VolumeTexture associated with the volume.


Volume.Description Property (Microsoft.DirectX.Direct3D)

Volume.Description Property

Retrieves the description of a volume.

Definition

Visual Basic | Public ReadOnly Property Description As VolumeDescription
C# | public VolumeDescription Description { get; }
C++ public:
property VolumeDescription Description {
VolumeDescription get();
}
JScript | public function get Description() : VolumeDescription

Property Value

Microsoft.DirectX.Direct3D.VolumeDescription
A VolumeDescription object that contains the volume description.

This property is read-only.


Volume.Device Property (Microsoft.DirectX.Direct3D)

Volume.Device Property

Retrieves the Microsoft Direct3D device associated with a sprite object.

Definition

Visual Basic | Public ReadOnly Property Device As Device
C# | public Device Device { get; }
C++ public:
property Device^ Device {
Device^ get();
}
JScript | public function get Device() : Device

Property Value

Microsoft.DirectX.Direct3D.Device
A Device reference that represents the Direct3D device object associated with the sprite object.

This property is read-only.


Volume.Disposed Property (Microsoft.DirectX.Direct3D)

Volume.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Volume.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

Volume.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DVolume9 interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As IDirect3DVolume9
C# | public IDirect3DVolume9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DVolume9 UnmanagedComPointer {
IDirect3DVolume9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DVolume9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolume9
Unmanaged IDirect3DVolume9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


Volume.Disposing Event (Microsoft.DirectX.Direct3D)

Volume.Disposing Event

Occurs when the Dispose method is called or when the Volume object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.Volume.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Volume object indicates whether that object has been disposed.


VolumeLoader Class (Microsoft.DirectX.Direct3D)

VolumeLoader Class

Contains functions for loading and saving volumes.

Definition

Visual Basic NotInheritable MustInherit Public Class VolumeLoader
Inherits Object
C# | public abstract sealed class VolumeLoader : Object
C++ | public ref class VolumeLoader abstract sealed : Object
JScript | public final abstract class VolumeLoader extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) FromFile | Loads a volume from a file.
static (Shared in Visual Basic) FromStream | Creates a volume from a file in memory.
static (Shared in Visual Basic) FromVolume | Loads a volume from another volume.
static (Shared in Visual Basic) Save | Saves a volume to a file.

Inheritance Hierarchy

Object Leave Site
VolumeLoader

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VolumeLoader.FromFile Method ()

Loads a volume from a file.

Overload List

public static void FromFile(Volume, Box, string, Box, Filter, int);
public static void FromFile(Volume, Box, string, Box, Filter, int, ref ImageInformation);
public static void FromFile(Volume, out PaletteEntry, Box, string, Box, Filter, int);
public static void FromFile(Volume, out PaletteEntry, Box, string, Box, Filter, int, ref ImageInformation);
public static void FromFile(Volume, out PaletteEntry, Box, string, Filter, int);
public static void FromFile(Volume, out PaletteEntry, Box, string, Filter, int, ref ImageInformation);
public static void FromFile(Volume, out PaletteEntry, string, Box, Filter, int);
public static void FromFile(Volume, out PaletteEntry, string, Box, Filter, int, ref ImageInformation);
public static void FromFile(Volume, out PaletteEntry, string, Filter, int);
public static void FromFile(Volume, out PaletteEntry, string, Filter, int, ref ImageInformation);
public static void FromFile(Volume, string, Box, Filter, int);
public static void FromFile(Volume, string, Box, Filter, int, ref ImageInformation);
public static void FromFile(Volume, string, Filter, int);
public static void FromFile(Volume, string, Filter, int, ref ImageInformation);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,Box,String,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
Box destBox,
string srcFile,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Volume^ destVolume,
Box destBox,
String^ srcFile,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destVolume : Volume,
destBox : Box,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile System.String
String that specifies the file name.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,Box,String,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
Box destBox,
string srcFile,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Volume^ destVolume,
Box destBox,
String^ srcFile,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destVolume : Volume,
destBox : Box,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile System.String
String that specifies the file name.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,String,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
string srcFile,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Volume^ destVolume,
String^ srcFile,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destVolume : Volume,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
srcFile System.String
String that specifies the file name.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,String,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
string srcFile,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Volume^ destVolume,
String^ srcFile,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destVolume : Volume,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
srcFile System.String
String that specifies the file name.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,String,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
string srcFile,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
String^ srcFile,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
srcFile System.String
String that specifies the file name.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,String,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
string srcFile,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
String^ srcFile,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
srcFile System.String
String that specifies the file name.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,String,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
string srcFile,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Volume^ destVolume,
String^ srcFile,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destVolume : Volume,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
srcFile System.String
String that specifies the file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,String,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Volume^ destVolume,
String^ srcFile,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destVolume : Volume,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
srcFile System.String
String that specifies the file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,String,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
String^ srcFile,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
srcFile System.String
String that specifies the file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,Box,String,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
string srcFile,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
String^ srcFile,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcFile : String,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile System.String
String that specifies the file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,String,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
string srcFile,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
String^ srcFile,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
srcFile System.String
String that specifies the file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,Box,String,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
string srcFile,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
String^ srcFile,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcFile : String,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile System.String
String that specifies the file name.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,Box,String,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
string srcFile,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromFile(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
String^ srcFile,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile System.String
String that specifies the file name.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromFile(Volume,PaletteEntry,Box,String,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromFile Method

Loads a volume from a file.

Definition

Visual Basic Public Shared Sub FromFile( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcFile As String, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromFile(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
string srcFile,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromFile(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
String^ srcFile,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromFile(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcFile : String,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcFile System.String
String that specifies the file name.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream
  • FromVolume


VolumeLoader.FromStream Method ()

Creates a volume from a file in memory.

Overload List

public static void FromStream(Volume, Box, Stream, Box, Filter, int);
public static void FromStream(Volume, Box, Stream, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Box, Stream, int, Box, Filter, int);
public static void FromStream(Volume, Box, Stream, int, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, Box, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, int, Box, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, int, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, int, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Box, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Stream, Box, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Stream, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Stream, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Stream, int, Box, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Stream, int, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, out PaletteEntry, Stream, int, Filter, int);
public static void FromStream(Volume, out PaletteEntry, Stream, int, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Stream, Box, Filter, int);
public static void FromStream(Volume, Stream, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Stream, Filter, int);
public static void FromStream(Volume, Stream, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Stream, int, Box, Filter, int);
public static void FromStream(Volume, Stream, int, Box, Filter, int, ref ImageInformation);
public static void FromStream(Volume, Stream, int, Filter, int);
public static void FromStream(Volume, Stream, int, Filter, int, ref ImageInformation);

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Box,Stream,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Box destBox,
Stream stream,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
Box destBox,
Stream^ stream,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destBox : Box,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Box,Stream,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Box destBox,
Stream stream,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
Box destBox,
Stream^ stream,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destBox : Box,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
Stream^ stream,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
Stream^ stream,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Stream^ stream,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Stream^ stream,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
Stream^ stream,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
Stream^ stream,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Stream^ stream,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Stream^ stream,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Stream^ stream,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Stream^ stream,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Stream^ stream,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Stream^ stream,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Box,Stream,Int32,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Box destBox,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
Box destBox,
Stream^ stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destBox : Box,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Box,Stream,Int32,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Box destBox,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
Box destBox,
Stream^ stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destBox : Box,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Int32,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
Stream^ stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Int32,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
Stream^ stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Int32,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Stream^ stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Int32,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Stream^ stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Int32,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,Stream,Int32,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Int32,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Int32,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
int readBytes,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Stream,Int32,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Int32,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
int readBytes,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Stream^ stream,
int readBytes,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
readBytes : int,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Int32,Box,Filter,Int32,ImageInformation) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer, _
ByRef srcInformation As ImageInformation _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ref ImageInformation srcInformation
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Stream^ stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey,
ImageInformation% srcInformation
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int,
srcInformation : ImageInformation
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.
srcInformation Microsoft.DirectX.Direct3D.ImageInformation
An ImageInformation structure to fill with a description of the data in the source image file, or 0.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromStream(Volume,PaletteEntry,Box,Stream,Int32,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromStream Method

Creates a volume from a file in memory.

Definition

Visual Basic Public Shared Sub FromStream( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal stream As Stream, _
ByVal readBytes As Integer, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromStream(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Stream stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromStream(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Stream^ stream,
int readBytes,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromStream(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
stream : Stream,
readBytes : int,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that represent a 256-color palette to fill in, or 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
stream System.IO.Stream
A Stream Leave Site that contains the source volume texture in memory.
readBytes System.Int32
Size of the file in memory, in bytes.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

This method supports the following file formats: .bmp, .dds, .dib, .hdr, .jpg, .pfm, .png, .ppm, and .tga. It handles conversion to and from compressed texture formats.

Writing to a non-level-zero surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromVolume


VolumeLoader.FromVolume Method ()

Loads a volume from another volume.

Overload List

public static void FromVolume(Volume, Box, Volume, Box, Filter, int);
public static void FromVolume(Volume, Box, Volume, Filter, int);
public static void FromVolume(Volume, Box, Volume, out PaletteEntry, Box, Filter, int);
public static void FromVolume(Volume, Box, Volume, out PaletteEntry, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Box, Volume, Box, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Box, Volume, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Box, Volume, out PaletteEntry, Box, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Box, Volume, out PaletteEntry, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Volume, Box, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Volume, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Volume, out PaletteEntry, Box, Filter, int);
public static void FromVolume(Volume, out PaletteEntry, Volume, out PaletteEntry, Filter, int);
public static void FromVolume(Volume, Volume, Box, Filter, int);
public static void FromVolume(Volume, Volume, Filter, int);
public static void FromVolume(Volume, Volume, out PaletteEntry, Box, Filter, int);
public static void FromVolume(Volume, Volume, out PaletteEntry, Filter, int);

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Box,Volume,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Box destBox,
Volume srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
Box destBox,
Volume^ srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destBox : Box,
srcVolume : Volume,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Volume,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Volume srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
Volume^ srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
srcVolume : Volume,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Volume,PaletteEntry,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Volume srcVolume,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
srcVolume : Volume,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Box,Volume,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Box destBox,
Volume srcVolume,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
Box destBox,
Volume^ srcVolume,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destBox : Box,
srcVolume : Volume,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Volume,PaletteEntry,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Volume srcVolume,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
srcVolume : Volume,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Volume,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcVolume As Volume, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Volume srcVolume,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Volume^ srcVolume,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
srcVolume : Volume,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Volume,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal srcVolume As Volume, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Volume srcVolume,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
Volume^ srcVolume,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
srcVolume : Volume,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Box,Volume,PaletteEntry,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Box destBox,
Volume srcVolume,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
Box destBox,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destBox : Box,
srcVolume : Volume,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Volume,PaletteEntry,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Volume,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Volume srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Volume^ srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
srcVolume : Volume,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Box,Volume,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Volume srcVolume,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Volume^ srcVolume,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcVolume : Volume,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,Box,Volume,PaletteEntry,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
Box destBox,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
Box destBox,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destBox : Box,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Volume,PaletteEntry,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Box,Volume,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Volume srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Volume^ srcVolume,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcVolume : Volume,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Box,Volume,PaletteEntry,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Volume srcVolume,
out PaletteEntry sourcePalette,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcVolume : Volume,
sourcePalette : PaletteEntry,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.FromVolume(Volume,PaletteEntry,Box,Volume,PaletteEntry,Box,Filter,Int32) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.FromVolume Method

Loads a volume from another volume.

Definition

Visual Basic Public Shared Sub FromVolume( _
ByVal destVolume As Volume, _
ByRef destPalette As PaletteEntry, _
ByVal destBox As Box, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box, _
ByVal filter As Filter, _
ByVal colorKey As Integer _
)
C# public static void FromVolume(
Volume destVolume,
out PaletteEntry destPalette,
Box destBox,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
C++ public:
static void FromVolume(
Volume^ destVolume,
[Out] PaletteEntry% destPalette,
Box destBox,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Box srcBox,
Filter filter,
int colorKey
);
JScript public static function FromVolume(
destVolume : Volume,
destPalette : PaletteEntry,
destBox : Box,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box,
filter : Filter,
colorKey : int
);

Parameters

destVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the destination volume.
destPalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the destination volume. This parameter can be 0.
destBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the destination box. Omit this parameter to specify the entire volume.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that specifies the source volume.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures containing a 256-color palette that represents the palette for the source volume. This parameter can be 0.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.
filter Microsoft.DirectX.Direct3D.Filter
One or more Filter flags that control how the image is filtered.
colorKey System.Int32
An Int32 Leave Site value to replace with transparent black, or 0 to disable the color key. This is always a 32-bit ARGB color that is independent of the source image format. Alpha is significant, and usually should be set to FF for opaque color keys. For example, for opaque black, the value is equal to 0xFF000000.

Remarks

Writing to any surface except the "zero" level surface of the volume texture does not cause the dirty rectangle to be updated. If FromFile is called and the texture is not already dirty (which is unlikely under normal usage scenarios), the application must explicitly call VolumeTexture.AddDirtyBox on the volume texture.

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.

See Also

  • FromStream


VolumeLoader.Save Method ()

Saves a volume to a file.

Overload List

public static void Save(string, ImageFileFormat, Volume);
public static void Save(string, ImageFileFormat, Volume, Box);
public static void Save(string, ImageFileFormat, Volume, out PaletteEntry);
public static void Save(string, ImageFileFormat, Volume, out PaletteEntry, Box);

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft Direct3D cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeLoader.Save(String,ImageFileFormat,Volume) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.Save Method

Saves a volume to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcVolume As Volume _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Volume srcVolume
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
Volume^ srcVolume
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcVolume : Volume
);

Parameters

destFile System.String
String that specifies the file name of the source image.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat that specifies the file format to use when saving. See Remarks.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that contains the image to save.

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft Direct3D cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeLoader.Save(String,ImageFileFormat,Volume,PaletteEntry) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.Save Method

Saves a volume to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Volume srcVolume,
out PaletteEntry sourcePalette
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcVolume : Volume,
sourcePalette : PaletteEntry
);

Parameters

destFile System.String
String that specifies the file name of the source image.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat that specifies the file format to use when saving. See Remarks.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that contains the image to save.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that contain a 256-color palette. This parameter can be 0.

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft Direct3D cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeLoader.Save(String,ImageFileFormat,Volume,Box) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.Save Method

Saves a volume to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcVolume As Volume, _
ByVal srcBox As Box _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Volume srcVolume,
Box srcBox
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
Volume^ srcVolume,
Box srcBox
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcVolume : Volume,
srcBox : Box
);

Parameters

destFile System.String
String that specifies the file name of the source image.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat that specifies the file format to use when saving. See Remarks.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that contains the image to save.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft Direct3D cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeLoader.Save(String,ImageFileFormat,Volume,PaletteEntry,Box) Method (Microsoft.DirectX.Direct3D)

VolumeLoader.Save Method

Saves a volume to a file.

Definition

Visual Basic Public Shared Sub Save( _
ByVal destFile As String, _
ByVal destFormat As ImageFileFormat, _
ByVal srcVolume As Volume, _
ByRef sourcePalette As PaletteEntry, _
ByVal srcBox As Box _
)
C# public static void Save(
string destFile,
ImageFileFormat destFormat,
Volume srcVolume,
out PaletteEntry sourcePalette,
Box srcBox
);
C++ public:
static void Save(
String^ destFile,
ImageFileFormat destFormat,
Volume^ srcVolume,
[Out] PaletteEntry% sourcePalette,
Box srcBox
);
JScript public static function Save(
destFile : String,
destFormat : ImageFileFormat,
srcVolume : Volume,
sourcePalette : PaletteEntry,
srcBox : Box
);

Parameters

destFile System.String
String that specifies the file name of the source image.
destFormat Microsoft.DirectX.Direct3D.ImageFileFormat
An ImageFileFormat that specifies the file format to use when saving. See Remarks.
srcVolume Microsoft.DirectX.Direct3D.Volume
A Volume object that contains the image to save.
sourcePalette Microsoft.DirectX.Direct3D.PaletteEntry[]
Array of PaletteEntry structures that contain a 256-color palette. This parameter can be 0.
srcBox Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the source box. Omit this parameter to specify the entire volume.

Remarks

This method supports the .bmp and .dds file formats. It handles conversion to and from compressed texture formats.

If the volume is non-dynamic (because a usage parameter was set to 0 at creation) and is located in video memory (the memory pool set to Default), VolumeLoader.Save fails because Microsoft Direct3D cannot lock non-dynamic volumes located in video memory.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeTexture Class (Microsoft.DirectX.Direct3D)

VolumeTexture Class

Manipulates a volume texture resource.

Definition

Visual Basic NotInheritable Public Class VolumeTexture
Inherits BaseTexture
Implements IDisposable
C# | public sealed class VolumeTexture : BaseTexture, IDisposable
C++ | public ref class VolumeTexture sealed : BaseTexture, IDisposable
JScript | public final class VolumeTexture extends BaseTexture implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the VolumeTexture object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDirtyBox | Adds a dirty region to a volume texture resource.
Dispose | Immediately releases the unmanaged resources used by the VolumeTexture object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the VolumeTexture object to free resources before it is destroyed by the garbage collector.
FreePrivateData | Frees the specified private data associated with the current resource. Inherited from Resource.
GenerateMipSubLevels | Generates mipmap sublevels. Inherited from BaseTexture.
GetHashCode | Returns the hash code for the current instance.
GetLevelDescription | Retrieves a level description of a volume texture resource.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetPrivateData | Copies the private data associated with a resource to a buffer. Inherited from Resource.
GetVolumeLevel | Retrieves the specified volume texture level.
LockBox | Locks a box on a volume texture resource.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Resource.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from BaseTexture.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from BaseTexture.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Resource.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
PreLoad | Preloads a managed resource. Inherited from Resource.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.VolumeTexture.Disposing event when called from within a derived class.
SetLevelOfDetail | Sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
SetPriority | Assigns the resource-management priority for the current resource. Inherited from Resource.
SetPrivateData | Associates data with the resource that is intended for use by the application. Data is passed by value, and multiple sets of data can be associated with a single resource. Inherited from Resource.
UnlockBox | Unlocks a box on a volume texture resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this Resource object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code. Inherited from Resource.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this BaseTexture object. This method supports the Framework infrastructure and is not intended to be used directly in your code. Inherited from BaseTexture.
VolumeTexture | Creates a new instance of the VolumeTexture class.

Properties

Property | Description
AutoGenerateFilterType | Retrieves or sets the filter type used for automatically generated sublevels. Inherited from BaseTexture.
Device | Retrieves the device associated with a resource. Inherited from Resource.
Disposed | Gets a value that indicates whether the object is disposed.
LevelCount | Retrieves the number of texture levels in a multilevel texture. Inherited from BaseTexture.
LevelOfDetail | Retrieves or sets the most detailed level of detail (LOD) for a managed texture. Inherited from BaseTexture.
Priority | Retrieves or sets the priority for the current resource. Inherited from Resource.
Type | Retrieves the type of a resource. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) IDirect3DResource9 interface pointer. Inherited from Resource.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DBaseTexture9 interface pointer. Inherited from BaseTexture.
UnmanagedComPointer | Returns the unmanaged COM IDirect3DVolumeTexture9 interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Resource
BaseTexture
VolumeTexture

Remarks

This object inherits additional functionality from the BaseTexture class.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VolumeTexture.AddDirtyBox Method ()

Adds a dirty region to a volume texture resource.

Overload List

public void AddDirtyBox();
public void AddDirtyBox(Box);

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeTexture.AddDirtyBox(Box) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.AddDirtyBox Method

Adds a dirty region to a volume texture resource.

Definition

Visual Basic Public Sub AddDirtyBox( _
ByVal box As Box _
)
C# public void AddDirtyBox(
Box box
);
C++ public:
void AddDirtyBox(
Box box
);
JScript public function AddDirtyBox(
box : Box
);

Parameters

box Microsoft.DirectX.Direct3D.Box
A Box structure that specifies the dirty region to add. Omitting this parameter expands the dirty region to cover the entire volume texture.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeTexture.AddDirtyBox() Method (Microsoft.DirectX.Direct3D)

VolumeTexture.AddDirtyBox Method

Adds a dirty region to a volume texture resource.

Definition

Visual Basic | Public Sub AddDirtyBox()
C# | public void AddDirtyBox();
C++ public:
void AddDirtyBox();
JScript | public function AddDirtyBox();

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. For sublevels, it is assumed that the corresponding (scaled) rectangle or box is also dirty. Dirty regions are automatically recorded when CubeTexture.LockRectangle is called without LockFlags.NoDirtyUpdate or LockFlags.ReadOnly.

Applications can specify which subset of a resource is copied in a Device.UpdateTexture call by specifying dirty regions. This can be used for optimization.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


VolumeTexture.Dispose() Method (Microsoft.DirectX.Direct3D)

VolumeTexture.Dispose Method

Immediately releases the unmanaged resources used by the VolumeTexture object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~VolumeTexture();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.VolumeTexture.Disposed
  • Microsoft.DirectX.Direct3D.VolumeTexture.Disposing


VolumeTexture.Equals(Object) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


VolumeTexture.Finalize() Method (Microsoft.DirectX.Direct3D)

VolumeTexture.Finalize Method

Allows the VolumeTexture object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~VolumeTexture();
C++ | !VolumeTexture();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


VolumeTexture.GetHashCode() Method (Microsoft.DirectX.Direct3D)

VolumeTexture.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


VolumeTexture.GetLevelDescription(Int32) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.GetLevelDescription Method

Retrieves a level description of a volume texture resource.

Definition

Visual Basic Public Function GetLevelDescription( _
ByVal level As Integer _
) As VolumeDescription
C# public VolumeDescription GetLevelDescription(
int level
);
C++ public:
VolumeDescription GetLevelDescription(
int level
);
JScript public function GetLevelDescription(
level : int
) : VolumeDescription;

Parameters

level System.Int32
Value that identifies a level of the volume texture resource.

Return Value

Microsoft.DirectX.Direct3D.VolumeDescription
A VolumeDescription structure that describes the returned volume texture level.

Remarks

This method returns a volume description for the level specified by the level parameter.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


VolumeTexture.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public hide function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirect3DVolumeTexture9, which allows unmanaged COM clients to create an instance of the managed VolumeTexture class. Not supported.


VolumeTexture.GetVolumeLevel(Int32) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.GetVolumeLevel Method

Retrieves the specified volume texture level.

Definition

Visual Basic Public Function GetVolumeLevel( _
ByVal level As Integer _
) As Volume
C# public Volume GetVolumeLevel(
int level
);
C++ public:
Volume^ GetVolumeLevel(
int level
);
JScript public function GetVolumeLevel(
level : int
) : Volume;

Parameters

level System.Int32
Value that identifies a level of the volume texture resource.

Return Value

Microsoft.DirectX.Direct3D.Volume
A Volume object that represents the returned volume level.

Remarks

This method returns a volume for the level specified by the level parameter.

Exceptions
InvalidCallException The method call is invalid. For example, a parameter might contain an invalid value.


VolumeTexture.LockBox Method ()

Locks a box on a volume texture resource.

Overload List

public GraphicsStream LockBox(int, Box, LockFlags);
public GraphicsStream LockBox(int, Box, LockFlags, out LockedBox);
public GraphicsStream LockBox(int, LockFlags);
public GraphicsStream LockBox(int, LockFlags, out LockedBox);
public Array LockBox(Type, int, Box, LockFlags, int[]);
public Array LockBox(Type, int, Box, LockFlags, out LockedBox, int[]);
public Array LockBox(Type, int, LockFlags, int[]);
public Array LockBox(Type, int, LockFlags, out LockedBox, int[]);

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Int32,Box,LockFlags,LockedBox) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.LockBox Method

Locks a box on a volume texture resource.

Definition

Visual Basic Public Function LockBox( _
ByVal level As Integer, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox _
) As GraphicsStream
C# public GraphicsStream LockBox(
int level,
Box box,
LockFlags flags,
out LockedBox lockedVolume
);
C++ public:
GraphicsStream^ LockBox(
int level,
Box box,
LockFlags flags,
[Out] LockedBox% lockedVolume
);
JScript public function LockBox(
level : int,
box : Box,
flags : LockFlags,
lockedVolume : LockedBox
) : GraphicsStream;

Parameters

level System.Int32
Value that specifies a level of the texture resource to lock.
box Microsoft.DirectX.Direct3D.Box
A Box structure that indicates the region to lock. Omitting this parameter locks the entire volume level.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
lockedVolume Microsoft.DirectX.Direct3D.LockedBox
A LockedBox structure that describes the locked region.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Int32,LockFlags,LockedBox) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.LockBox Method

Locks a box on a volume texture resource.

Definition

Visual Basic Public Function LockBox( _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox _
) As GraphicsStream
C# public GraphicsStream LockBox(
int level,
LockFlags flags,
out LockedBox lockedVolume
);
C++ public:
GraphicsStream^ LockBox(
int level,
LockFlags flags,
[Out] LockedBox% lockedVolume
);
JScript public function LockBox(
level : int,
flags : LockFlags,
lockedVolume : LockedBox
) : GraphicsStream;

Parameters

level System.Int32
Value that specifies a level of the texture resource to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
lockedVolume Microsoft.DirectX.Direct3D.LockedBox
A LockedBox structure that describes the locked region.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Int32,Box,LockFlags) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.LockBox Method

Locks a box on a volume texture resource.

Definition

Visual Basic Public Function LockBox( _
ByVal level As Integer, _
ByVal box As Box, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockBox(
int level,
Box box,
LockFlags flags
);
C++ public:
GraphicsStream^ LockBox(
int level,
Box box,
LockFlags flags
);
JScript public function LockBox(
level : int,
box : Box,
flags : LockFlags
) : GraphicsStream;

Parameters

level System.Int32
Value that specifies a level of the texture resource to lock.
box Microsoft.DirectX.Direct3D.Box
A Box structure that indicates the region to lock. Omitting this parameter locks the entire volume level.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Int32,LockFlags) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.LockBox Method

Locks a box on a volume texture resource.

Definition

Visual Basic Public Function LockBox( _
ByVal level As Integer, _
ByVal flags As LockFlags _
) As GraphicsStream
C# public GraphicsStream LockBox(
int level,
LockFlags flags
);
C++ public:
GraphicsStream^ LockBox(
int level,
LockFlags flags
);
JScript public function LockBox(
level : int,
flags : LockFlags
) : GraphicsStream;

Parameters

level System.Int32
Value that specifies a level of the texture resource to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Type,Int32,Box,LockFlags,LockedBox,Int32[]) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.LockBox Method

Locks a box on a volume texture resource.

Definition

Visual Basic Public Function LockBox( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
int level,
Box box,
LockFlags flags,
out LockedBox lockedVolume,
int[] ranks
);
C++ public:
Array^ LockBox(
Type^ typeLock,
int level,
Box box,
LockFlags flags,
[Out] LockedBox% lockedVolume,
array<int>^ ranks
);
JScript public function LockBox(
typeLock : Type,
level : int,
box : Box,
flags : LockFlags,
lockedVolume : LockedBox,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level System.Int32
Value that specifies a level of the texture resource to lock.
box Microsoft.DirectX.Direct3D.Box
A Box structure that indicates the region to lock. Omitting this parameter locks the entire volume level.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
lockedVolume Microsoft.DirectX.Direct3D.LockedBox
A LockedBox structure that describes the locked region.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Type,Int32,LockFlags,LockedBox,Int32[]) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.LockBox Method

Locks a box on a volume texture resource.

Definition

Visual Basic Public Function LockBox( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByRef lockedVolume As LockedBox, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
int level,
LockFlags flags,
out LockedBox lockedVolume,
int[] ranks
);
C++ public:
Array^ LockBox(
Type^ typeLock,
int level,
LockFlags flags,
[Out] LockedBox% lockedVolume,
array<int>^ ranks
);
JScript public function LockBox(
typeLock : Type,
level : int,
flags : LockFlags,
lockedVolume : LockedBox,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level System.Int32
Value that specifies a level of the texture resource to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
lockedVolume Microsoft.DirectX.Direct3D.LockedBox
A LockedBox structure that describes the locked region.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Type,Int32,Box,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.LockBox Method

Locks a box on a volume texture resource.

Definition

Visual Basic Public Function LockBox( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal box As Box, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
int level,
Box box,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockBox(
Type^ typeLock,
int level,
Box box,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockBox(
typeLock : Type,
level : int,
box : Box,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level System.Int32
Value that specifies a level of the texture resource to lock.
box Microsoft.DirectX.Direct3D.Box
A Box structure that indicates the region to lock. Omitting this parameter locks the entire volume level.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.LockBox(Type,Int32,LockFlags,Int32[]) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.LockBox Method

Locks a box on a volume texture resource.

Definition

Visual Basic Public Function LockBox( _
ByVal typeLock As Type, _
ByVal level As Integer, _
ByVal flags As LockFlags, _
ByVal ranks() As Integer _
) As Array
C# public Array LockBox(
Type typeLock,
int level,
LockFlags flags,
int[] ranks
);
C++ public:
Array^ LockBox(
Type^ typeLock,
int level,
LockFlags flags,
array<int>^ ranks
);
JScript public function LockBox(
typeLock : Type,
level : int,
flags : LockFlags,
ranks : int[]
) : Array;

Parameters

typeLock System.Type
A Type Leave Site object that indicates the type of data to return. This can be a value type or any type that contains only value types.
level System.Int32
Value that specifies a level of the texture resource to lock.
flags Microsoft.DirectX.Direct3D.LockFlags
Zero or more locking flags that describe the type of lock to perform. For this method, the valid flags are Discard, NoDirtyUpdate, NoSystemLock, and ReadOnly. For a description of the flags, see LockFlags.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array Leave Site.

Return Value

System.Array
An Array Leave Site object that describes the locked region.

Remarks

For performance reasons, dirty regions are recorded only for level 0 of a texture. Dirty regions are automatically recorded when Texture.LockRectangle is called without NoDirtyUpdate or ReadOnly. For more information, see Device.UpdateTexture.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • UnlockBox


VolumeTexture.op_Equality(VolumeTexture,VolumeTexture) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As VolumeTexture, _
ByVal right As VolumeTexture _
) As Boolean
C# public static bool op_Equality(
VolumeTexture left,
VolumeTexture right
);
C++ public:
static bool operator==(
VolumeTexture^ left,
VolumeTexture^ right
);
JScript public static function op_Equality(
left : VolumeTexture,
right : VolumeTexture
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.VolumeTexture
The VolumeTexture object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.VolumeTexture
The VolumeTexture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


VolumeTexture.op_Inequality(VolumeTexture,VolumeTexture) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As VolumeTexture, _
ByVal right As VolumeTexture _
) As Boolean
C# public static bool op_Inequality(
VolumeTexture left,
VolumeTexture right
);
C++ public:
static bool operator!=(
VolumeTexture^ left,
VolumeTexture^ right
);
JScript public static function op_Inequality(
left : VolumeTexture,
right : VolumeTexture
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.VolumeTexture
The VolumeTexture object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.VolumeTexture
The VolumeTexture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


VolumeTexture.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.VolumeTexture.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


VolumeTexture.UnlockBox(Int32) Method (Microsoft.DirectX.Direct3D)

VolumeTexture.UnlockBox Method

Unlocks a box on a volume texture resource.

Definition

Visual Basic Public Sub UnlockBox( _
ByVal level As Integer _
)
C# public void UnlockBox(
int level
);
C++ public:
void UnlockBox(
int level
);
JScript public function UnlockBox(
level : int
);

Parameters

level System.Int32
Value that specifies a level of the volume texture resource to unlock.

Remarks

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • LockBox


VolumeTexture.VolumeTexture Constructor ()

Creates a new instance of the VolumeTexture class.

Overload List

public VolumeTexture(Device, int, int, int, int, Usage, Format, Pool);
public VolumeTexture(IDirect3DVolumeTexture9);
public VolumeTexture(IDirect3DVolumeTexture9, Device, Pool);
public VolumeTexture(IntPtr);

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.VolumeTexture(IDirect3DVolumeTexture9) Constructor (Microsoft.DirectX.Direct3D)

VolumeTexture.VolumeTexture Constructor

Creates a new instance of the VolumeTexture class.

Definition

Visual Basic Public Sub New( _
ByVal pInterop As IDirect3DVolumeTexture9 _
)
C# public VolumeTexture(
IDirect3DVolumeTexture9 pInterop
);
C++ public:
VolumeTexture(
IDirect3DVolumeTexture9 pInterop
);
JScript public function VolumeTexture(
pInterop : IDirect3DVolumeTexture9
);

Parameters

pInterop Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolumeTexture9
Unmanaged Component Object Model (COM) IDirect3DVolumeTexture9 interface pointer.

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.VolumeTexture(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

VolumeTexture.VolumeTexture Constructor

Creates a new instance of the VolumeTexture class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public VolumeTexture(
IntPtr unmanagedObject
);
C++ public:
VolumeTexture(
IntPtr unmanagedObject
);
JScript public function VolumeTexture(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) IDirect3DVolumeTexture9 interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.VolumeTexture(IDirect3DVolumeTexture9,Device,Pool) Constructor (Microsoft.DirectX.Direct3D)

VolumeTexture.VolumeTexture Constructor

Creates a new instance of the VolumeTexture class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IDirect3DVolumeTexture9, _
ByVal device As Device, _
ByVal pool As Pool _
)
C# public VolumeTexture(
IDirect3DVolumeTexture9 lp,
Device device,
Pool pool
);
C++ public:
VolumeTexture(
IDirect3DVolumeTexture9 lp,
Device^ device,
Pool pool
);
JScript public function VolumeTexture(
lp : IDirect3DVolumeTexture9,
device : Device,
pool : Pool
);

Parameters

lp Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolumeTexture9
Unmanaged Component Object Model (COM) IDirect3DVolumeTexture9 interface pointer.
device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the VolumeTexture object.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the volume texture should be placed.

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Microsoft Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.VolumeTexture(Device,Int32,Int32,Int32,Int32,Usage,Format,Pool) Constructor (Microsoft.DirectX.Direct3D)

VolumeTexture.VolumeTexture Constructor

Creates a new instance of the VolumeTexture class.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal depth As Integer, _
ByVal numLevels As Integer, _
ByVal usage As Usage, _
ByVal format As Format, _
ByVal pool As Pool _
)
C# public VolumeTexture(
Device device,
int width,
int height,
int depth,
int numLevels,
Usage usage,
Format format,
Pool pool
);
C++ public:
VolumeTexture(
Device^ device,
int width,
int height,
int depth,
int numLevels,
Usage usage,
Format format,
Pool pool
);
JScript public function VolumeTexture(
device : Device,
width : int,
height : int,
depth : int,
numLevels : int,
usage : Usage,
format : Format,
pool : Pool
);

Parameters

device Microsoft.DirectX.Direct3D.Device
A Device object to associate with the VolumeTexture object.
width System.Int32
Width of the top level of the volume texture, in pixels. This value must be a power of two if the Caps.TextureCaps.SupportsVolumeMapPower2 member is set. See Remarks.
height System.Int32
Height of the top level of the volume texture, in pixels. This value must be a power of two if the Caps.TextureCaps.SupportsVolumeMapPower2 member is set. See Remarks.
depth System.Int32
Depth of the top level of the volume texture, in pixels. This value must be a power of two if the Caps.TextureCaps.SupportsVolumeMapPower2 member is set. See Remarks.
numLevels System.Int32
Number of levels in the texture. If this value is 0, Microsoft Direct3D generates all texture sublevels down to 1x1 pixels for hardware that supports mipmapped volume textures. Check the BaseTexture.LevelCount parameter for the number of levels generated.
usage Microsoft.DirectX.Direct3D.Usage
Usage type for this VolumeTexture.
format Microsoft.DirectX.Direct3D.Format
Member of the Format enumerated type that describes the format of all levels in the volume texture.
pool Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumerated type that describes the memory class into which the volume texture should be placed.

Remarks

For the width, height, and depth parameters, the pixel dimensions of subsequent levels are the truncated value of half of the previous level's pixel dimension (independently). Each dimension clamps at a size of 1 pixel. Thus, if the division by 2 results in 0 (zero), 1 is taken instead. The maximum dimension that a driver supports (for width, height, and depth) can be found in Caps.MaxVolumeExtent.

Exceptions
InvalidCallException | The method call is invalid. For example, a parameter might contain an invalid value.
OutOfVideoMemoryException | Direct3D does not have enough display memory to perform the operation.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


VolumeTexture.Disposed Property (Microsoft.DirectX.Direct3D)

VolumeTexture.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


VolumeTexture.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

VolumeTexture.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) IDirect3DVolumeTexture9 interface pointer.

Definition

Visual Basic | Public Shadows ReadOnly Property UnmanagedComPointer As IDirect3DVolumeTexture9
C# | public IDirect3DVolumeTexture9 UnmanagedComPointer { get; }
C++ public:
property IDirect3DVolumeTexture9 UnmanagedComPointer {
IDirect3DVolumeTexture9 get();
}
JScript | public function get UnmanagedComPointer() : IDirect3DVolumeTexture9

Property Value

Microsoft.DirectX.PrivateImplementationDetails.IDirect3DVolumeTexture9
Unmanaged IDirect3DVolumeTexture9 interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


VolumeTexture.Disposing Event (Microsoft.DirectX.Direct3D)

VolumeTexture.Disposing Event

Occurs when the Dispose method is called or when the VolumeTexture object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.VolumeTexture.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the VolumeTexture object indicates whether that object has been disposed.


WasStillDrawingException Class (Microsoft.DirectX.Direct3D)

WasStillDrawingException Class

The device was still drawing.

Definition

Visual Basic Public Class WasStillDrawingException
Inherits GraphicsException
C# | public class WasStillDrawingException : GraphicsException
C++ | public ref class WasStillDrawingException : GraphicsException
JScript | public class WasStillDrawingException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WasStillDrawingException | Initializes a new instance of the WasStillDrawingException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WasStillDrawingException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WasStillDrawingException.WasStillDrawingException Constructor ()

Initializes a new instance of the WasStillDrawingException class.

Overload List

public WasStillDrawingException();
protected WasStillDrawingException(SerializationInfo, StreamingContext);
public WasStillDrawingException(string);
public WasStillDrawingException(string, Exception);


WasStillDrawingException.WasStillDrawingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:

Initializes a new instance of the WasStillDrawingException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WasStillDrawingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
WasStillDrawingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function WasStillDrawingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


WasStillDrawingException.WasStillDrawingException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:

Initializes a new instance of the WasStillDrawingException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WasStillDrawingException(
string message,
Exception inner
);
C++ public:
WasStillDrawingException(
String^ message,
Exception^ inner
);
JScript public function WasStillDrawingException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


WasStillDrawingException.WasStillDrawingException(String) Constructor (Microsoft.DirectX.Direct3D)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:

Initializes a new instance of the WasStillDrawingException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public WasStillDrawingException(
string message
);
C++ public:
WasStillDrawingException(
String^ message
);
JScript public function WasStillDrawingException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


WasStillDrawingException.WasStillDrawingException() Constructor (Microsoft.DirectX.Direct3D)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:

Initializes a new instance of the WasStillDrawingException class.

Definition

Visual Basic | Public Sub New()
C# | public WasStillDrawingException();
C++ public:
WasStillDrawingException();
JScript | public function WasStillDrawingException();


WrongTextureFormatException Class (Microsoft.DirectX.Direct3D)

WrongTextureFormatException Class

The pixel format of the texture surface is not valid.

Definition

Visual Basic Public Class WrongTextureFormatException
Inherits GraphicsException
C# | public class WrongTextureFormatException : GraphicsException
C++ | public ref class WrongTextureFormatException : GraphicsException
JScript | public class WrongTextureFormatException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WrongTextureFormatException | Initializes a new instance of the WrongTextureFormatException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WrongTextureFormatException

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WrongTextureFormatException.WrongTextureFormatException Constructor ()

Initializes a new instance of the WrongTextureFormatException class.

Overload List

public WrongTextureFormatException();
protected WrongTextureFormatException(SerializationInfo, StreamingContext);
public WrongTextureFormatException(string);
public WrongTextureFormatException(string, Exception);


WrongTextureFormatException.WrongTextureFormatException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.Direct3D)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:

Initializes a new instance of the WrongTextureFormatException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WrongTextureFormatException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
WrongTextureFormatException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function WrongTextureFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


WrongTextureFormatException.WrongTextureFormatException(String,Exception) Constructor (Microsoft.DirectX.Direct3D)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:

Initializes a new instance of the WrongTextureFormatException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WrongTextureFormatException(
string message,
Exception inner
);
C++ public:
WrongTextureFormatException(
String^ message,
Exception^ inner
);
JScript public function WrongTextureFormatException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


WrongTextureFormatException.WrongTextureFormatException(String) Constructor (Microsoft.DirectX.Direct3D)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:

Initializes a new instance of the WrongTextureFormatException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public WrongTextureFormatException(
string message
);
C++ public:
WrongTextureFormatException(
String^ message
);
JScript public function WrongTextureFormatException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


WrongTextureFormatException.WrongTextureFormatException() Constructor (Microsoft.DirectX.Direct3D)

WrongTextureFormatException.WrongTextureFormatException Constructor

 Language:

Initializes a new instance of the WrongTextureFormatException class.

Definition

Visual Basic | Public Sub New()
C# | public WrongTextureFormatException();
C++ public:
WrongTextureFormatException();
JScript | public function WrongTextureFormatException();


XFile Class (Microsoft.DirectX.Direct3D)

XFile Class

Retrieves information about XFile file objects.

Definition

Visual Basic NotInheritable Public Class XFile
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class XFile : MarshalByRefObject, IDisposable
C++ | public ref class XFile sealed : MarshalByRefObject, IDisposable
JScript | public final class XFile extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFile object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the XFile object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFile object to free resources before it is destroyed by the garbage collector.
GetChild | Retrieves an XFileData child object in this XFile object.
GetDataObject | Retrieves the XFileData object referenced by name or by a globally unique identifier (GUID).
GetHashCode | Returns the hash code for the current instance.
GetManager | Returns an XFileManager instance for this XFile object.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFile.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFile object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
XFile | Initializes a new instance of the XFile class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
NumberChildren | Retrieves the number of child objects in this file data object.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFileEnumObject interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFile

Remarks

The object for which information is being retrieved should be disposed immediately when it is no longer needed.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


XFile.Dispose() Method (Microsoft.DirectX.Direct3D)

XFile.Dispose Method

Immediately releases the unmanaged resources used by the XFile object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~XFile();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFile.Disposed
  • Microsoft.DirectX.Direct3D.XFile.Disposing


XFile.Equals(Object) Method (Microsoft.DirectX.Direct3D)

XFile.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.Finalize() Method (Microsoft.DirectX.Direct3D)

XFile.Finalize Method

Allows the XFile object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~XFile();
C++ | !XFile();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


XFile.GetChild(Int32) Method (Microsoft.DirectX.Direct3D)

XFile.GetChild Method

Retrieves an XFileData child object in this XFile object.

Definition

Visual Basic Public Function GetChild( _
ByVal index As Integer _
) As XFileData
C# public XFileData GetChild(
int index
);
C++ public:
XFileData^ GetChild(
int index
);
JScript public function GetChild(
index : int
) : XFileData;

Parameters

index System.Int32
Identifier (ID) of the child object to retrieve.

Return Value

Microsoft.DirectX.Direct3D.XFileData
The XFileData child object retrieved.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NoMoreObjects | No more child objects are available.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.GetDataObject Method ()

Retrieves the XFileData object referenced by name or by a globally unique identifier (GUID).

Overload List

public XFileData GetDataObject(Guid);
public XFileData GetDataObject(string);

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NotFound | Object could not be found from the specified parameters.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.GetDataObject(String) Method (Microsoft.DirectX.Direct3D)

XFile.GetDataObject Method

Retrieves the XFileData object referenced by name or by a globally unique identifier (GUID).

Definition

Visual Basic Public Function GetDataObject( _
ByVal dataName As String _
) As XFileData
C# public XFileData GetDataObject(
string dataName
);
C++ public:
XFileData^ GetDataObject(
String^ dataName
);
JScript public function GetDataObject(
dataName : String
) : XFileData;

Parameters

dataName System.String
Specifies the name of the data object to retrieve.

Return Value

Microsoft.DirectX.Direct3D.XFileData
The XFileData object retrieved.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NotFound | Object could not be found from the specified parameters.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.GetDataObject(Guid) Method (Microsoft.DirectX.Direct3D)

XFile.GetDataObject Method

Retrieves the XFileData object referenced by name or by a globally unique identifier (GUID).

Definition

Visual Basic Public Function GetDataObject( _
ByVal dataId As Guid _
) As XFileData
C# public XFileData GetDataObject(
Guid dataId
);
C++ public:
XFileData^ GetDataObject(
Guid dataId
);
JScript public function GetDataObject(
dataId : Guid
) : XFileData;

Parameters

dataId System.Guid
Specifies the GUID of the data object to retrieve.

Return Value

Microsoft.DirectX.Direct3D.XFileData
The XFileData object retrieved.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NotFound | Object could not be found from the specified parameters.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.GetHashCode() Method (Microsoft.DirectX.Direct3D)

XFile.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.GetManager() Method (Microsoft.DirectX.Direct3D)

XFile.GetManager Method

Returns an XFileManager instance for this XFile object.

Definition

Visual Basic | Public Function GetManager() As XFileManager
C# | public XFileManager GetManager();
C++ public:
XFileManager^ GetManager();
JScript | public function GetManager() : XFileManager;

Return Value

Microsoft.DirectX.Direct3D.XFileManager
The XFileManager instance for this XFile object.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

XFile.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFile, which allows unmanaged COM clients to create an instance of the managed XFile class. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.op_Equality(XFile,XFile) Method (Microsoft.DirectX.Direct3D)

XFile.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As XFile, _
ByVal right As XFile _
) As Boolean
C# public static bool op_Equality(
XFile left,
XFile right
);
C++ public:
static bool operator==(
XFile^ left,
XFile^ right
);
JScript public static function op_Equality(
left : XFile,
right : XFile
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFile
The XFile object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFile
The XFile object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.op_Inequality(XFile,XFile) Method (Microsoft.DirectX.Direct3D)

XFile.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As XFile, _
ByVal right As XFile _
) As Boolean
C# public static bool op_Inequality(
XFile left,
XFile right
);
C++ public:
static bool operator!=(
XFile^ left,
XFile^ right
);
JScript public static function op_Inequality(
left : XFile,
right : XFile
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFile
The XFile object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFile
The XFile object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

XFile.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.XFile.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.UpdateUnmanagedPointer(ID3DXFileEnumObject) Method (Microsoft.DirectX.Direct3D)

XFile.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this XFile object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFileEnumObject _
)
C# public void UpdateUnmanagedPointer(
ID3DXFileEnumObject pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXFileEnumObject pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXFileEnumObject
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileEnumObject
Pointer to the ID3DXFileEnumObject structure used to update the unmanaged pointer for this XFile object.


XFile.XFile Constructor ()

Initializes a new instance of the XFile class.

Overload List

public XFile(ID3DXFileEnumObject);
public XFile(IntPtr);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.XFile(ID3DXFileEnumObject) Constructor (Microsoft.DirectX.Direct3D)

XFile.XFile Constructor

Initializes a new instance of the XFile class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXFileEnumObject _
)
C# public XFile(
ID3DXFileEnumObject pUnk
);
C++ public:
XFile(
ID3DXFileEnumObject pUnk
);
JScript public function XFile(
pUnk : ID3DXFileEnumObject
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileEnumObject
Unmanaged Component Object Model (COM) ID3DXFileEnumObject interface pointer.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.XFile(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

XFile.XFile Constructor

Initializes a new instance of the XFile class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFile(
IntPtr unmanagedObject
);
C++ public:
XFile(
IntPtr unmanagedObject
);
JScript public function XFile(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXFileEnumObject interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.Disposed Property (Microsoft.DirectX.Direct3D)

XFile.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.NumberChildren Property (Microsoft.DirectX.Direct3D)

XFile.NumberChildren Property

Retrieves the number of child objects in this file data object.

Definition

Visual Basic | Public ReadOnly Property NumberChildren As Integer
C# | public int NumberChildren { get; }
C++ public:
property int NumberChildren {
int get();
}
JScript | public function get NumberChildren() : int

Property Value

System.Int32
Number of child objects.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFile.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

XFile.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXFileEnumObject interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXFileEnumObject
C# | public ID3DXFileEnumObject UnmanagedComPointer { get; }
C++ public:
property ID3DXFileEnumObject UnmanagedComPointer {
ID3DXFileEnumObject get();
}
JScript | public function get UnmanagedComPointer() : ID3DXFileEnumObject

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileEnumObject
Unmanaged ID3DXFileEnumObject interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


XFile.Disposing Event (Microsoft.DirectX.Direct3D)

XFile.Disposing Event

Occurs when the Dispose method is called or when the XFile object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFile.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFile object indicates whether that object has been disposed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData Class (Microsoft.DirectX.Direct3D)

XFileData Class

Builds or accesses the immediate hierarchy of a data object.

Definition

Visual Basic NotInheritable Public Class XFileData
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class XFileData : MarshalByRefObject, IDisposable
C++ | public ref class XFileData sealed : MarshalByRefObject, IDisposable
JScript | public final class XFileData extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFileData object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the XFileData object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFileData object to free resources before it is destroyed by the garbage collector.
GetChild | Retrieves an XFileData child object in this XFileData object.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetXFile | Retrieves an XFile instance for this XFileData object.
Lock | Accesses the .x file data.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFileData.Disposing event when called from within a derived class.
SetData | Sets a range of data.
Unlock | Ends access to the GraphicsStream object returned by XFileData.Lock.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFileData object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
XFileData | Initializes a new instance of the XFileData class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Id | Retrieves the GUID of this file data object.
IsReference | Indicates whether this file data object is a reference object that points to another child data object.
Name | Retrieves the name of this file data object.
NumberChildren | Retrieves the number of children in this file data object.
Type | Retrieves the globally unique identifier (GUID) of an object's template.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFileData interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFileData

Remarks

Template restrictions determine the hierarchy of data objects. Data types allowed by the template are called optional members. While optional members are not required, an object might miss important information without them. These members, which are saved as child members of the data object, can be additional data objects, references to earlier data objects, or binary objects.

The object should be disposed immediately when it is no longer needed.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


XFileData.Dispose() Method (Microsoft.DirectX.Direct3D)

XFileData.Dispose Method

Immediately releases the unmanaged resources used by the XFileData object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~XFileData();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFileData.Disposed
  • Microsoft.DirectX.Direct3D.XFileData.Disposing

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.Equals(Object) Method (Microsoft.DirectX.Direct3D)

XFileData.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.Finalize() Method (Microsoft.DirectX.Direct3D)

XFileData.Finalize Method

Allows the XFileData object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~XFileData();
C++ | !XFileData();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


XFileData.GetChild(Int32) Method (Microsoft.DirectX.Direct3D)

XFileData.GetChild Method

Retrieves an XFileData child object in this XFileData object.

Definition

Visual Basic Public Function GetChild( _
ByVal index As Integer _
) As XFileData
C# public XFileData GetChild(
int index
);
C++ public:
XFileData^ GetChild(
int index
);
JScript public function GetChild(
index : int
) : XFileData;

Parameters

index System.Int32
Identifier (ID) of the child object to retrieve.

Return Value

Microsoft.DirectX.Direct3D.XFileData
The XFileData child object retrieved.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NoMoreObjects | No more child objects are available.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.GetHashCode() Method (Microsoft.DirectX.Direct3D)

XFileData.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

XFileData.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFileData, which allows unmanaged COM clients to create an instance of the managed XFileData class. Not supported.


XFileData.GetXFile() Method (Microsoft.DirectX.Direct3D)

XFileData.GetXFile Method

Retrieves an XFile instance for this XFileData object.

Definition

Visual Basic | Public Function GetXFile() As XFile
C# | public XFile GetXFile();
C++ public:
XFile^ GetXFile();
JScript | public function GetXFile() : XFile;

Return Value

Microsoft.DirectX.Direct3D.XFile
The XFile instance for this XFileData object.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.Lock() Method (Microsoft.DirectX.Direct3D)

XFileData.Lock Method

Accesses the .x file data.

Definition

Visual Basic | Public Function Lock() As GraphicsStream
C# | public GraphicsStream Lock();
C++ public:
GraphicsStream^ Lock();
JScript | public function Lock() : GraphicsStream;

Return Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the locked data buffer.

Remarks

You can make multiple lock calls. However, you must ensure that the number of lock calls matches the number of unlock calls.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.op_Equality(XFileData,XFileData) Method (Microsoft.DirectX.Direct3D)

XFileData.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As XFileData, _
ByVal right As XFileData _
) As Boolean
C# public static bool op_Equality(
XFileData left,
XFileData right
);
C++ public:
static bool operator==(
XFileData^ left,
XFileData^ right
);
JScript public static function op_Equality(
left : XFileData,
right : XFileData
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFileData
The XFileData object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFileData
The XFileData object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.op_Inequality(XFileData,XFileData) Method (Microsoft.DirectX.Direct3D)

XFileData.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As XFileData, _
ByVal right As XFileData _
) As Boolean
C# public static bool op_Inequality(
XFileData left,
XFileData right
);
C++ public:
static bool operator!=(
XFileData^ left,
XFileData^ right
);
JScript public static function op_Inequality(
left : XFileData,
right : XFileData
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFileData
The XFileData object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFileData
The XFileData object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

XFileData.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.XFileData.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.SetData(Object) Method (Microsoft.DirectX.Direct3D)

XFileData.SetData Method

Sets a range of data.

Definition

Visual Basic Public Sub SetData( _
ByVal data As Object _
)
C# public void SetData(
object data
);
C++ public:
void SetData(
Object^ data
);
JScript public function SetData(
data : Object
);

Parameters

data System.Object
An Object Leave Site that contains the data to set into this XFileData object.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.NoMoreObjects | No more child objects are available.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.Unlock() Method (Microsoft.DirectX.Direct3D)

XFileData.Unlock Method

Ends access to the GraphicsStream object returned by XFileData.Lock.

Definition

Visual Basic | Public Sub Unlock()
C# | public void Unlock();
C++ public:
void Unlock();
JScript | public function Unlock();

Remarks

You must ensure that the number of lock calls matches the number of unlock calls.

After calling XFileData.Unlock, the GraphicsStream object returned by XFileData.Lock should no longer be used.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.UpdateUnmanagedPointer(ID3DXFileData) Method (Microsoft.DirectX.Direct3D)

XFileData.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this XFileData object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFileData _
)
C# public void UpdateUnmanagedPointer(
ID3DXFileData pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXFileData pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXFileData
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileData
Pointer to the ID3DXFileData structure used to update the unmanaged pointer for this XFileData object.


XFileData.XFileData Constructor ()

Initializes a new instance of the XFileData class.

Overload List

public XFileData(ID3DXFileData);
public XFileData(IntPtr);

Remarks

The object should be disposed immediately when it is no longer needed.


XFileData.XFileData(ID3DXFileData) Constructor (Microsoft.DirectX.Direct3D)

XFileData.XFileData Constructor

Initializes a new instance of the XFileData class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXFileData _
)
C# public XFileData(
ID3DXFileData pUnk
);
C++ public:
XFileData(
ID3DXFileData pUnk
);
JScript public function XFileData(
pUnk : ID3DXFileData
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileData
Unmanaged Component Object Model (COM) ID3DXFileData interface pointer.

Remarks

The object should be disposed immediately when it is no longer needed.


XFileData.XFileData(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

XFileData.XFileData Constructor

Initializes a new instance of the XFileData class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFileData(
IntPtr unmanagedObject
);
C++ public:
XFileData(
IntPtr unmanagedObject
);
JScript public function XFileData(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXFileData interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The object should be disposed immediately when it is no longer needed.


XFileData.Disposed Property (Microsoft.DirectX.Direct3D)

XFileData.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.Id Property (Microsoft.DirectX.Direct3D)

XFileData.Id Property

Retrieves the globally unique identifier (GUID) of this file data object.

Definition

Visual Basic | Public ReadOnly Property Id As Guid
C# | public Guid Id { get; }
C++ public:
property Guid Id {
Guid get();
}
JScript | public function get Id() : Guid

Property Value

System.Guid
A GUID that represents this file data object.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.IsReference Property (Microsoft.DirectX.Direct3D)

XFileData.IsReference Property

Indicates whether this file data object is a reference object that points to another child data object.

Definition

Visual Basic | Public ReadOnly Property IsReference As Boolean
C# | public bool IsReference { get; }
C++ public:
property bool IsReference {
bool get();
}
JScript | public function get IsReference() : boolean

Property Value

System.Boolean
A value that is true if the file data object is a reference object; otherwise, the value is false.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.Name Property (Microsoft.DirectX.Direct3D)

XFileData.Name Property

Retrieves the name of this file data object.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
The name of this file data object.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
OutOfMemoryException Leave Site | N/A | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.NumberChildren Property (Microsoft.DirectX.Direct3D)

XFileData.NumberChildren Property

Retrieves the number of children in this file data object.

Definition

Visual Basic | Public ReadOnly Property NumberChildren As Integer
C# | public int NumberChildren { get; }
C++ public:
property int NumberChildren {
int get();
}
JScript | public function get NumberChildren() : int

Property Value

System.Int32
The number of children in this file data object.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileData.Type Property (Microsoft.DirectX.Direct3D)

XFileData.Type Property

Retrieves the globally unique identifier (GUID) of an object's template.

Definition

Visual Basic | Public ReadOnly Property Type As Guid
C# | public Guid Type { get; }
C++ public:
property Guid Type {
Guid get();
}
JScript | public function get Type() : Guid

Property Value

System.Guid
A Guid Leave Site instance that contains the GUID of the object's template.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | If a variable is outside its expected range; typically returned when an object is invalid.


XFileData.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

XFileData.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXFileData interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXFileData
C# | public ID3DXFileData UnmanagedComPointer { get; }
C++ public:
property ID3DXFileData UnmanagedComPointer {
ID3DXFileData get();
}
JScript | public function get UnmanagedComPointer() : ID3DXFileData

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileData
Unmanaged ID3DXFileData interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


XFileData.Disposing Event (Microsoft.DirectX.Direct3D)

XFileData.Disposing Event

Occurs when the Dispose method is called or when the XFileData object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFileData.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFileData object indicates whether that object has been disposed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileGuid Class (Microsoft.DirectX.Direct3D)

XFileGuid Class

Provides various globally unique identifier (GUID) values for use with XFiles (.x files).

Definition

Visual Basic NotInheritable MustInherit Public Class XFileGuid
Inherits Object
C# | public abstract sealed class XFileGuid : Object
C++ | public ref class XFileGuid abstract sealed : Object
JScript | public final abstract class XFileGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) Animation | Retrieves the GUID for animation.
static (Shared in Visual Basic) AnimationKey | Retrieves the GUID for animation keys.
static (Shared in Visual Basic) AnimationOptions | Retrieves the GUID for animation options.
static (Shared in Visual Basic) AnimationSet | Retrieves the GUID for an animation set.
static (Shared in Visual Basic) ApplicationData | Retrieves the GUID for application data. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) Boolean | Retrieves the GUID for simple Boolean types.
static (Shared in Visual Basic) Boolean2d | Retrieves the GUID for a set of two Boolean values that are used in the MeshFaceWraps template to define the texture topology of an individual face.
static (Shared in Visual Basic) Camera | Retrieves the GUID for a camera. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) ColorRgb | Retrieves the GUID for a basic RGB color object.
static (Shared in Visual Basic) ColorRgba | Retrieves the GUID for an RGB color object that has an alpha component.
static (Shared in Visual Basic) Coordinates2D | Retrieves the GUID for a two-dimensional vector that is used to define a mesh's (u, v) texture coordinates.
static (Shared in Visual Basic) ExternalVisual | Retrieves the GUID for an external visual. Used internally by DirectX. Do not use.
static (Shared in Visual Basic) FloatKeys | Retrieves the GUID for an array of floating-point numbers (floats) and the number of floats in the array.
static (Shared in Visual Basic) Frame | Retrieves the GUID for a frame.
static (Shared in Visual Basic) FramePosition | Retrieves the GUID for a frame position. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) FrameRotation | Retrieves the GUID for a frame rotation. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) FrameTransformMatrix | Retrieves the GUID for a frame transform matrix.
static (Shared in Visual Basic) FrameVelocity | Retrieves the GUID for a frame velocity. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) IndexedColor | Retrieves the GUID for indexed color.
static (Shared in Visual Basic) Info | Retrieves the GUID for information. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) InlineData | Retrieves the GUID for inline data. Used internally by DirectX. Do not use.
static (Shared in Visual Basic) Light | Retrieves the GUID for light templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) LightAttenuation | Retrieves the GUID for light attenuation templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) LightPenumbra | Retrieves the GUID for light penumbra templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) LightRange | Retrieves the GUID for light range templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) LightUmbra | Retrieves the GUID for light umbra templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) Material | Retrieves the GUID for material templates.
static (Shared in Visual Basic) MaterialAmbientColor | Retrieves the GUID for material ambient color templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) MaterialArray | Retrieves the GUID for material array templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) MaterialDiffuseColor | Retrieves the GUID for material diffuse color templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) MaterialEmissiveColor | Retrieves the GUID for material emissive color templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) MaterialPower | Retrieves the GUID for material power templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) MaterialSpecularColor | Retrieves the GUID for material specular color templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) MaterialWrap | Retrieves the GUID for material wrap templates.
static (Shared in Visual Basic) Matrix4x4 | Retrieves the GUID for matrix 4x4 templates.
static (Shared in Visual Basic) Mesh | Retrieves the GUID for mesh templates.
static (Shared in Visual Basic) MeshFace | Retrieves the GUID for mesh face templates.
static (Shared in Visual Basic) MeshFaceWraps | Retrieves the GUID for mesh face wrap templates.
static (Shared in Visual Basic) MeshMaterialList | Retrieves the GUID for mesh material list templates.
static (Shared in Visual Basic) MeshNormals | Retrieves the GUID for mesh normal templates.
static (Shared in Visual Basic) MeshTextureCoords | Retrieves the GUID for mesh texture coordinate templates.
static (Shared in Visual Basic) MeshVertexColors | Retrieves the GUID for mesh vertex color templates.
static (Shared in Visual Basic) ProgressiveMesh | Retrieves the GUID for progressive mesh templates. Used internally by DirectX. Do not use.
static (Shared in Visual Basic) PropertyBag | Retrieves the GUID for property bag templates. Used internally by DirectX. Do not use.
static (Shared in Visual Basic) RightHanded | Retrieves the GUID for right-handed templates. Used internally by DirectX. Do not use.
static (Shared in Visual Basic) RmGuid | Retrieves the GUID for RMGuid templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) StringProperty | Retrieves the GUID for string property templates. Used internally by DirectX. Do not use.
static (Shared in Visual Basic) TextureFilename | Retrieves the GUID for texture file-name templates.
static (Shared in Visual Basic) TextureReference | Retrieves the GUID for texture reference templates. Provided for legacy applications. Not supported.
static (Shared in Visual Basic) TimedFloatKeys | Retrieves the GUID for timed float-key templates.
static (Shared in Visual Basic) Url | Retrieves the GUID for URL templates. Used internally by Microsoft DirectX. Do not use.
static (Shared in Visual Basic) Vector | Retrieves the GUID for vector templates.

Inheritance Hierarchy

Object Leave Site
XFileGuid

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


XFileGuid.Animation Field (Microsoft.DirectX.Direct3D)

XFileGuid.Animation Field

Retrieves the globally unique identifier (GUID) for animation.

Definition

Visual Basic | Public Shared Animation As Guid
C# | public static Guid Animation;
C++ | public: static Guid Animation;
JScript | public static var Animation : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for animation templates in XFiles (.x files).

This field is read-only.

Remarks

Animation templates in XFiles contain animations that reference a previous frame. The template should contain one reference to a frame and at least one set of AnimationKey templates. It also can contain an AnimationOptions data object. The following C# code provides an example.

              [C#]

template Animation
{
    < 3D82AB4F-62DA-11cf-AB39-0020AF71E433 >
    [...]
}
Where:
  • [ ... ] - Any .x file template can be used here making the architecture extensible.


XFileGuid.AnimationKey Field (Microsoft.DirectX.Direct3D)

XFileGuid.AnimationKey Field

Retrieves the globally unique identifier (GUID) for animation keys.

Definition

Visual Basic | Public Shared AnimationKey As Guid
C# | public static Guid AnimationKey;
C++ | public: static Guid AnimationKey;
JScript | public static var AnimationKey : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for animation key templates in XFiles (.x files).

This field is read-only.

Remarks

The following C# code is an AnimationKey template.

[C#]
template AnimationKey
{
    < 10DD46A8-775B-11CF-8F52-0040333594A3 >
    DWORD keyType;
    DWORD nKeys;
    array TimedFloatKeys keys[nKeys];
}
Where:
  • keyType - Specifies whether the keys are rotation, scale, position, or matrix keys (using the integers 0, 1, 2, or 3 respectively).
  • nKeys - Number of keys.
  • keys - Array of keys. See TimedFloatKeys.


XFileGuid.AnimationOptions Field (Microsoft.DirectX.Direct3D)

XFileGuid.AnimationOptions Field

Retrieves the globally unique identifier (GUID) for animation options.

Definition

Visual Basic | Public Shared AnimationOptions As Guid
C# | public static Guid AnimationOptions;
C++ | public: static Guid AnimationOptions;
JScript | public static var AnimationOptions : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for animation option templates in XFiles (.x files).

This field is read-only.

Remarks

The following C# code provides an example of an AnimationOptions template.

[C#]
template AnimationOptions
{
    < E2BF56C0-840F-11cf-8F52-0040333594A3 >
    DWORD openclosed;
    DWORD positionquality;
}
Where:
  • openclosed - Use 0 for a closed animation, or 1 for an open animation. An animation is closed by default.
  • positionquality - Set the position quality for any position keys specified. Use 0 for spline positions, or 1 for linear positions.


XFileGuid.AnimationSet Field (Microsoft.DirectX.Direct3D)

XFileGuid.AnimationSet Field

Retrieves the globally unique identifier (GUID) for an animation set.

Definition

Visual Basic | Public Shared AnimationSet As Guid
C# | public static Guid AnimationSet;
C++ | public: static Guid AnimationSet;
JScript | public static var AnimationSet : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for animation set templates in XFiles (.x files).

This field is read-only.

Remarks

Animation sets contain one or more Animation objects. Each animation within a set has the same time at any given point, so increasing the animation set's time increases the time for all animations it contains.

The following C# code provides an example of an AnimationSet template.

[C#]
template AnimationSet
{
    < 3D82AB50-62DA-11cf-AB39-0020AF71E433 >
    [ Animation < 3D82AB4F-62DA-11cf-AB39-0020AF71E433 > ]
}
Where:
  • [ Animation < 3D82AB4F-62DA-11cf-AB39-0020AF71E433 > ] - Optional animation template.


XFileGuid.ApplicationData Field (Microsoft.DirectX.Direct3D)

XFileGuid.ApplicationData Field

Retrieves the globally unique identifier (GUID) for application data. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared ApplicationData As Guid
C# | public static Guid ApplicationData;
C++ | public: static Guid ApplicationData;
JScript | public static var ApplicationData : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for application data templates in XFiles (.x files).

This field is read-only.


XFileGuid.Boolean Field (Microsoft.DirectX.Direct3D)

XFileGuid.Boolean Field

Retrieves the globally unique identifier (GUID) for simple Boolean types.

Definition

Visual Basic | Public Shared Boolean As Guid
C# | public static Guid Boolean;
C++ | public: static Guid Boolean;
JScript | public static var Boolean : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for simple Boolean type templates in XFiles (.x files).

This field is read-only.

Remarks

Boolean templates define a simple boolean type, as shown in the following example.

[C#]
template Boolean
{
    < 537da6a0-ca37-11d0-941c-0080c80cfa7b >
    DWORD truefalse;
}
Where:
  • truefalse - True for a Boolean, otherwise false.


XFileGuid.Boolean2d Field (Microsoft.DirectX.Direct3D)

XFileGuid.Boolean2d Field

Retrieves the globally unique identifier (GUID) for a set of two Boolean values that are used in the MeshFaceWraps template to define the texture topology of an individual face.

Definition

Visual Basic | Public Shared Boolean2d As Guid
C# | public static Guid Boolean2d;
C++ | public: static Guid Boolean2d;
JScript | public static var Boolean2d : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for templates with a set of two Boolean values in XFiles (.x files).

This field is read-only.

Remarks

The following is a Boolean2d template

[C#]
template Boolean2d
{
    < 4885AE63-78E8-11cf-8F52-0040333594A3 >
    Boolean u;
    Boolean v;
}
Where:
  • u - Boolean value. See Boolean.
  • v - Boolean value. See Boolean.


XFileGuid.Camera Field (Microsoft.DirectX.Direct3D)

XFileGuid.Camera Field

Retrieves the globally unique identifier (GUID) for a camera. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared Camera As Guid
C# | public static Guid Camera;
C++ | public: static Guid Camera;
JScript | public static var Camera : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for camera templates in XFiles (.x files).

This field is read-only.


XFileGuid.ColorRgb Field (Microsoft.DirectX.Direct3D)

XFileGuid.ColorRgb Field

Retrieves the globally unique identifier (GUID) for a basic RGB color object.

Definition

Visual Basic | Public Shared ColorRgb As Guid
C# | public static Guid ColorRgb;
C++ | public: static Guid ColorRgb;
JScript | public static var ColorRgb : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for basic RGB color object templates in XFiles (.x files).

This field is read-only.

Remarks

The following is an example of a ColorRGB template.

[C#]
template ColorRGB
{
    < D3E16E81-7835-11cf-8F52-0040333594A3 >
    float red;
    float green;
    float blue;
}


XFileGuid.ColorRgba Field (Microsoft.DirectX.Direct3D)

XFileGuid.ColorRgba Field

Retrieves the globally unique identifier (GUID) for an RGB color object that has an alpha component.

Definition

Visual Basic | Public Shared ColorRgba As Guid
C# | public static Guid ColorRgba;
C++ | public: static Guid ColorRgba;
JScript | public static var ColorRgba : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for an RGB color object that has alpha component templates in XFiles (.x files).

This field is read-only.

Remarks

The following template is used for the face color in the material template definition.

              [C#]

template ColorRGBA
{
    < 35FF44E0-6C7C-11cf-8F52-0040333594A3 >
    float red;
    float green;
    float blue;
    float alpha;
}


XFileGuid.Coordinates2D Field (Microsoft.DirectX.Direct3D)

XFileGuid.Coordinates2D Field

Retrieves the globally unique identifier (GUID) for a two-dimensional vector that is used to define a mesh's (u, v) texture coordinates.

Definition

Visual Basic | Public Shared Coordinates2D As Guid
C# | public static Guid Coordinates2D;
C++ | public: static Guid Coordinates2D;
JScript | public static var Coordinates2D : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for 2-D vector templates in XFiles (.x files).

This field is read-only.

Remarks

The following is a Coords2d template.

[C#]
template Coords2d
{
    < F6F23F44-7686-11cf-8F52-0040333594A3 >
    float u;
    float v;
}
Where:
  • u - u coordinate value.
  • v - v coordinate value.


XFileGuid.ExternalVisual Field (Microsoft.DirectX.Direct3D)

XFileGuid.ExternalVisual Field

Retrieves the globally unique identifier (GUID) for an external visual. Used internally by Microsoft DirectX. Do not use.

Definition

Visual Basic | Public Shared ExternalVisual As Guid
C# | public static Guid ExternalVisual;
C++ | public: static Guid ExternalVisual;
JScript | public static var ExternalVisual : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for external visual templates in XFiles (.x files).

This field is read-only.


XFileGuid.FloatKeys Field (Microsoft.DirectX.Direct3D)

XFileGuid.FloatKeys Field

Retrieves the globally unique identifier (GUID) for an array of floating-point numbers (floats) and the number of floats in the array.

Definition

Visual Basic | Public Shared FloatKeys As Guid
C# | public static Guid FloatKeys;
C++ | public: static Guid FloatKeys;
JScript | public static var FloatKeys : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for templates that consist of an array of floating-point numbers, and the number of floats in that array in XFiles (.x).

This field is read-only.

Remarks

This field is used for defining sets of animation keys.

The following is a FloatKeys template.

[C#]
template FloatKeys
{
    < 10DD46A9-775B-11cf-8F52-0040333594A3 >
    DWORD nValues;
    array float values[nValues];
}
Where:
  • nValues - Number of floats.
  • values[nValues] - Array of float values.


XFileGuid.Frame Field (Microsoft.DirectX.Direct3D)

XFileGuid.Frame Field

Retrieves the globally unique identifier (GUID) for a frame.

Definition

Visual Basic | Public Shared Frame As Guid
C# | public static Guid Frame;
C++ | public: static Guid Frame;
JScript | public static var Frame : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for frames.

This field is read-only.

Remarks

A frame is a coordinate frame, or "frame of reference." The Frame template is open and can contain any object. The mesh-loading functions recognize Mesh, FrameTransformMatrix, and Frame template instances as child objects when loading a Frame instance.

The following is a Frame template.

[C#]
template Frame
{
    < 3D82AB46-62DA-11CF-AB39-0020AF71E433 >
    [...]
}
  • [ ... ] - Any .x file template can be used here making the architecture extensible.
The frame template recognizes child Frame and Mesh nodes inside of a frame, and user-defined templates through a callback function.


XFileGuid.FramePosition Field (Microsoft.DirectX.Direct3D)

XFileGuid.FramePosition Field

Retrieves the globally unique identifier (GUID) for a frame position. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared FramePosition As Guid
C# | public static Guid FramePosition;
C++ | public: static Guid FramePosition;
JScript | public static var FramePosition : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for frame positions.

This field is read-only.


XFileGuid.FrameRotation Field (Microsoft.DirectX.Direct3D)

XFileGuid.FrameRotation Field

Retrieves the globally unique identifier (GUID) for a frame rotation. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared FrameRotation As Guid
C# | public static Guid FrameRotation;
C++ | public: static Guid FrameRotation;
JScript | public static var FrameRotation : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for frame rotation templates.

This field is read-only.


XFileGuid.FrameTransformMatrix Field (Microsoft.DirectX.Direct3D)

XFileGuid.FrameTransformMatrix Field

Retrieves the globally unique identifier (GUID) for a frame transform matrix.

Definition

Visual Basic | Public Shared FrameTransformMatrix As Guid
C# | public static Guid FrameTransformMatrix;
C++ | public: static Guid FrameTransformMatrix;
JScript | public static var FrameTransformMatrix : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for frame transform matrix templates.

This field is read-only.

Remarks

A frame transform matrix template defines a local transform for a frame and all of its child objects, as shown in the following example.

[C#]
template FrameTransformMatrix
{
    < F6F23F41-7686-11cf-8F52-0040333594A3 >
    Matrix4x4 frameMatrix;
}
Where:
  • frameMatrix - A Matrix4x4 template. For more information, see Matrix4x4.


XFileGuid.FrameVelocity Field (Microsoft.DirectX.Direct3D)

XFileGuid.FrameVelocity Field

Retrieves the globally unique identifier (GUID) for a frame velocity. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared FrameVelocity As Guid
C# | public static Guid FrameVelocity;
C++ | public: static Guid FrameVelocity;
JScript | public static var FrameVelocity : Guid

Field Value

System.Guid
A Guid Leave Site value that is used for frame velocity templates.

This field is read-only.


XFileGuid.IndexedColor Field (Microsoft.DirectX.Direct3D)

XFileGuid.IndexedColor Field

Retrieves the globally unique identifier (GUID) for indexed color.

Definition

Visual Basic | Public Shared IndexedColor As Guid
C# | public static Guid IndexedColor;
C++ | public: static Guid IndexedColor;
JScript | public static var IndexedColor : Guid

Field Value

System.Guid
A Guid Leave Site instance that contains the GUID for indexed color templates.

This field is read-only.

Remarks

An index color template contains an index parameter and an RGBA color, and is used to define mesh vertex colors. The index defines the vertex to which the color is applied, as shown in the following example.

[C#]
template IndexedColor
{
    < 1630B820-7842-11cf-8F52-0040333594A3 >
    DWORD index;
    ColorRGBA indexColor;
}
Where:
  • index - A DWORD. See the description above.
  • indexColor - A ColorRgba template.


XFileGuid.Info Field (Microsoft.DirectX.Direct3D)

XFileGuid.Info Field

Retrieves the globally unique identifier (GUID) for information. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared Info As Guid
C# | public static Guid Info;
C++ | public: static Guid Info;
JScript | public static var Info : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for information templates.

This field is read-only.


XFileGuid.InlineData Field (Microsoft.DirectX.Direct3D)

XFileGuid.InlineData Field

Retrieves the globally unique identifier (GUID) for inline data. Used internally by Microsoft DirectX. Do not use.

Definition

Visual Basic | Public Shared InlineData As Guid
C# | public static Guid InlineData;
C++ | public: static Guid InlineData;
JScript | public static var InlineData : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for inline data templates.

This field is read-only.


XFileGuid.Light Field (Microsoft.DirectX.Direct3D)

XFileGuid.Light Field

Retrieves the globally unique identifier (GUID) for light templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared Light As Guid
C# | public static Guid Light;
C++ | public: static Guid Light;
JScript | public static var Light : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for light templates.

This field is read-only.


XFileGuid.LightAttenuation Field (Microsoft.DirectX.Direct3D)

XFileGuid.LightAttenuation Field

Retrieves the globally unique identifier (GUID) for light attenuation templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared LightAttenuation As Guid
C# | public static Guid LightAttenuation;
C++ | public: static Guid LightAttenuation;
JScript | public static var LightAttenuation : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for light attenuation templates.

This field is read-only.


XFileGuid.LightPenumbra Field (Microsoft.DirectX.Direct3D)

XFileGuid.LightPenumbra Field

Retrieves the globally unique identifier (GUID) for light penumbra templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared LightPenumbra As Guid
C# | public static Guid LightPenumbra;
C++ | public: static Guid LightPenumbra;
JScript | public static var LightPenumbra : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for light penumbra templates.

This field is read-only.


XFileGuid.LightRange Field (Microsoft.DirectX.Direct3D)

XFileGuid.LightRange Field

Retrieves the globally unique identifier (GUID) for light range templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared LightRange As Guid
C# | public static Guid LightRange;
C++ | public: static Guid LightRange;
JScript | public static var LightRange : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for light range templates.

This field is read-only.


XFileGuid.LightUmbra Field (Microsoft.DirectX.Direct3D)

XFileGuid.LightUmbra Field

Retrieves the globally unique identifier (GUID) for light umbra templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared LightUmbra As Guid
C# | public static Guid LightUmbra;
C++ | public: static Guid LightUmbra;
JScript | public static var LightUmbra : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for light umbra templates.

This field is read-only.


XFileGuid.Material Field (Microsoft.DirectX.Direct3D)

XFileGuid.Material Field

Retrieves the globally unique identifier (GUID) for material templates.

Definition

Visual Basic | Public Shared Material As Guid
C# | public static Guid Material;
C++ | public: static Guid Material;
JScript | public static var Material : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for material templates.

This field is read-only.

Remarks

Material templates define a basic material color that can be applied to a complete mesh or a mesh's individual faces. The power is the specular exponent of the material.

Note: The ambient color requires an alpha component.
TextureFilename is an optional data object. If it is not present, the face is not textured. The following is a Material template.
[C#]
template Material
{
    < 3D82AB4D-62DA-11CF-AB39-0020AF71E433 >
    ColorRGBA faceColor;
    FLOAT power;
    ColorRGB specularColor;
    ColorRGB emissiveColor;
    [...]
}
 Where:
  • faceColor - Face color. A ColorRgba template.
  • power - Material specular color exponent.
  • specularColor - Material specular color. A ColorRgb template.
  • emissiveColor - Material emissive color. A ColorRgb template.


XFileGuid.MaterialAmbientColor Field (Microsoft.DirectX.Direct3D)

XFileGuid.MaterialAmbientColor Field

Retrieves the globally unique identifier (GUID) for material ambient color templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared MaterialAmbientColor As Guid
C# | public static Guid MaterialAmbientColor;
C++ | public: static Guid MaterialAmbientColor;
JScript | public static var MaterialAmbientColor : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for material ambient color templates.

This field is read-only.


XFileGuid.MaterialArray Field (Microsoft.DirectX.Direct3D)

XFileGuid.MaterialArray Field

Retrieves the globally unique identifier (GUID) for material array templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared MaterialArray As Guid
C# | public static Guid MaterialArray;
C++ | public: static Guid MaterialArray;
JScript | public static var MaterialArray : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for material array templates.

This field is read-only.


XFileGuid.MaterialDiffuseColor Field (Microsoft.DirectX.Direct3D)

XFileGuid.MaterialDiffuseColor Field

Retrieves the globally unique identifier (GUID) for material diffuse color templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared MaterialDiffuseColor As Guid
C# | public static Guid MaterialDiffuseColor;
C++ | public: static Guid MaterialDiffuseColor;
JScript | public static var MaterialDiffuseColor : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for material diffuse color templates.

This field is read-only.


XFileGuid.MaterialEmissiveColor Field (Microsoft.DirectX.Direct3D)

XFileGuid.MaterialEmissiveColor Field

Retrieves the globally unique identifier (GUID) for material emissive color templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared MaterialEmissiveColor As Guid
C# | public static Guid MaterialEmissiveColor;
C++ | public: static Guid MaterialEmissiveColor;
JScript | public static var MaterialEmissiveColor : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for material emissive color templates.

This field is read-only.


XFileGuid.MaterialPower Field (Microsoft.DirectX.Direct3D)

XFileGuid.MaterialPower Field

Retrieves the globally unique identifier (GUID) for material power templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared MaterialPower As Guid
C# | public static Guid MaterialPower;
C++ | public: static Guid MaterialPower;
JScript | public static var MaterialPower : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for material power templates.

This field is read-only.


XFileGuid.MaterialSpecularColor Field (Microsoft.DirectX.Direct3D)

XFileGuid.MaterialSpecularColor Field

Retrieves the globally unique identifier (GUID) for material specular color templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared MaterialSpecularColor As Guid
C# | public static Guid MaterialSpecularColor;
C++ | public: static Guid MaterialSpecularColor;
JScript | public static var MaterialSpecularColor : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for material specular color templates.

This field is read-only.


XFileGuid.MaterialWrap Field (Microsoft.DirectX.Direct3D)

XFileGuid.MaterialWrap Field

Retrieves the globally unique identifier (GUID) for material wrap templates.

Definition

Visual Basic | Public Shared MaterialWrap As Guid
C# | public static Guid MaterialWrap;
C++ | public: static Guid MaterialWrap;
JScript | public static var MaterialWrap : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for material wrap templates.

This field is read-only.

Remarks

Material wrap templates define a set of two Boolean values that are used in the MeshFaceWraps template to define the texture topology of an individual face. Use this template instead of Boolean2d when the texture coordinates (u, v) span the range of 0 to 2 instead of 0 to 1. The following is a MaterialWrap template.

[C#]
template MaterialWrap
{
    < 4885ae60-78e8-11cf-8f52-0040333594a3 >
    Boolean u;
    Boolean v;
}
Where:
  • u - Boolean value.
  • v - Boolean value.
Note: The MeshFaceWraps template is no longer used.


XFileGuid.Matrix4x4 Field (Microsoft.DirectX.Direct3D)

XFileGuid.Matrix4x4 Field

Retrieves the globally unique identifier (GUID) for matrix 4x4 templates.

Definition

Visual Basic | Public Shared Matrix4x4 As Guid
C# | public static Guid Matrix4x4;
C++ | public: static Guid Matrix4x4;
JScript | public static var Matrix4x4 : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for matrix 4x4 templates.

This field is read-only.

Remarks

Material wrap templates define a 4x4 matrix, which is used as a frame transformation matrix. The following is a Matrix4x4.

[C#]
template Matrix4x4
{
    < F6F23F45-7686-11cf-8F52-0040333594A3 >
    array float matrix[16];
}
Where:
  • array float matrix[16] - Array of 16 floats.


XFileGuid.Mesh Field (Microsoft.DirectX.Direct3D)

XFileGuid.Mesh Field

Retrieves the globally unique identifier (GUID) for mesh templates.

Definition

Visual Basic | Public Shared Mesh As Guid
C# | public static Guid Mesh;
C++ | public: static Guid Mesh;
JScript | public static var Mesh : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for mesh templates.

This field is read-only.

Remarks

Mesh templates define a simple mesh. In the following Mesh template, the first array is a list of vertices, and the second array defines the faces of the mesh by indexing into the vertex array.

[C#]
template Mesh
{
    <3D82AB44-62DA-11CF-AB39-0020AF71E433>
    DWORD nVertices;
    array Vector vertices[nVertices];
    DWORD nFaces;
    array MeshFace faces[nFaces];
    [...]
}
Where:
  • nVertices - Number of vertices.
  • array Vector vertices[nVertices] - Array of vertices, each of type Vector.
  • nFaces - Number of faces.
  • array MeshFace faces[nFaces] - Array of faces, each of type MeshFace.
  • [ ... ] - Any .x file template which makes the architecture extensible. The Material and TextureFilename templates typically are used.


XFileGuid.MeshFace Field (Microsoft.DirectX.Direct3D)

XFileGuid.MeshFace Field

Retrieves the globally unique identifier (GUID) for mesh face templates.

Definition

Visual Basic | Public Shared MeshFace As Guid
C# | public static Guid MeshFace;
C++ | public: static Guid MeshFace;
JScript | public static var MeshFace : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for mesh face templates.

This field is read-only.

Remarks

Mesh face templates are used by the Mesh template to define a mesh's faces. In the following MeshFace, each element of the nFaceVertexIndices array references a mesh vertex used to build the face.

[C#]
template MeshFace
{
    < 3D82AB5F-62DA-11cf-AB39-0020AF71E433 >
    DWORD nFaceVertexIndices;
    array DWORD faceVertexIndices[nFaceVertexIndices];
}
Where:
  • nFaceVertexIndices - Number of indices.
  • array DWORD faceVertexIndices[nFaceVertexIndices] - Array of indices.


XFileGuid.MeshFaceWraps Field (Microsoft.DirectX.Direct3D)

XFileGuid.MeshFaceWraps Field

Retrieves the globally unique identifier (GUID) for mesh face wrap templates.

Definition

Visual Basic | Public Shared MeshFaceWraps As Guid
C# | public static Guid MeshFaceWraps;
C++ | public: static Guid MeshFaceWraps;
JScript | public static var MeshFaceWraps : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for mesh face wrap templates.

This field is read-only.

Remarks

Mesh face wrap templates are used to define the texture topology of each face in a wrap. The value of the nFaceWrapValues member should be equal to the number of faces in a mesh, as in the following example.

[C#]
template MeshFaceWraps
{
    < ED1EC5C0-C0A8-11D0-941C-0080C80CFA7B >
    DWORD nFaceWrapValues;
    array Boolean2d faceWrapValues[nFaceWrapValues];
}
Note: This template is provided for backward compatibility and is no longer used.


XFileGuid.MeshMaterialList Field (Microsoft.DirectX.Direct3D)

XFileGuid.MeshMaterialList Field

Retrieves the globally unique identifier (GUID) for mesh material list templates.

Definition

Visual Basic | Public Shared MeshMaterialList As Guid
C# | public static Guid MeshMaterialList;
C++ | public: static Guid MeshMaterialList;
JScript | public static var MeshMaterialList : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for mesh material list templates.

This field is read-only.

Remarks

Mesh material list templates are used in a mesh object to specify which material applies to particular faces. In the following MeshMaterialList, the nMaterials member specifies how many materials are present, and the materials member specifies which material to apply.

[C#]
template MeshMaterialList
{
    < F6F23F42-7686-11CF-8F52-0040333594A3 >
    DWORD nMaterials;
    DWORD nFaceIndexes;
    array DWORD faceIndexes[nFaceIndexes];
    [Material <3D82AB4D-62DA-11CF-AB39-0020AF71E433>]
}
Where:
  • nMaterials - A DWORD. The number of materials.
  • nFaceIndexes - A DWORD. The number of indices.
  • faceIndexes[nFaceIndexes] - An array of DWORDs that contain the face indices.


XFileGuid.MeshNormals Field (Microsoft.DirectX.Direct3D)

XFileGuid.MeshNormals Field

Retrieves the globally unique identifier (GUID) for mesh normal templates.

Definition

Visual Basic | Public Shared MeshNormals As Guid
C# | public static Guid MeshNormals;
C++ | public: static Guid MeshNormals;
JScript | public static var MeshNormals : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for mesh normal templates.

This field is read-only.

Remarks

Mesh normal templates define normals for a mesh. The first array of vectors is the normal vectors themselves, and the second array is an array of indexes that specify which normals should be applied to a given face. The value of the nFaceNormals member should be equal to the number of faces in a mesh. The following is a MeshNormals template .

[C#]
template MeshNormals
{
    < F6F23F43-7686-11cf-8F52-0040333594A3 >
    DWORD nNormals;
    array Vector normals[nNormals];
    DWORD nFaceNormals;
    array MeshFace meshFaces[nFaceNormals];
}
Where:
  • nNormals - Number of normals.
  • array Vector normals[nNormals] - Array of normals. See Vector.
  • nFaceNormals - Number of face normals.
  • array MeshFace meshFaces[nFaceNormals] - Array of mesh face normals. For more information, see MeshFace.


XFileGuid.MeshTextureCoords Field (Microsoft.DirectX.Direct3D)

XFileGuid.MeshTextureCoords Field

Retrieves the globally unique identifier (GUID) for mesh texture coordinate templates.

Definition

Visual Basic | Public Shared MeshTextureCoords As Guid
C# | public static Guid MeshTextureCoords;
C++ | public: static Guid MeshTextureCoords;
JScript | public static var MeshTextureCoords : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for mesh coordinate templates.

This field is read-only.

Remarks

Mesh texture coordinate templates define a mesh's texture coordinates, as shown in the following example.

[C#]
template MeshTextureCoords
{
    < F6F23F40-7686-11cf-8F52-0040333594A3 >
    DWORD nTextureCoords;
    array Coords2d textureCoords[nTextureCoords] ;
}
Where:
  • nTextureCoords - Number of texture coordinates.
  • array Coords2d textureCoords[nTextureCoords] - Array of 2-D texture coordinates. For more information, see Coordinates2D.


XFileGuid.MeshVertexColors Field (Microsoft.DirectX.Direct3D)

XFileGuid.MeshVertexColors Field

Retrieves the globally unique identifier (GUID) for mesh vertex color templates.

Definition

Visual Basic | Public Shared MeshVertexColors As Guid
C# | public static Guid MeshVertexColors;
C++ | public: static Guid MeshVertexColors;
JScript | public static var MeshVertexColors : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for mesh vertex color templates.

This field is read-only.

Remarks

Mesh vertex color templates specify vertex colors for a mesh, rather than applying a material per face or per mesh. The following is an example of a MeshVertexColors template.

[C#]
template MeshVertexColors
{
    <1630B821-7842-11cf-8F52-0040333594A3>
    DWORD nVertexColors;
    array IndexColor vertexColors[nVertexColors];
}
Where:
  • nVertexColors - Number of colors. This matches the number of vertices in the mesh.
  • array IndexColor vertexColors[nVertexColors] - Array of indexed colors. For more information, see IndexedColor.


XFileGuid.ProgressiveMesh Field (Microsoft.DirectX.Direct3D)

XFileGuid.ProgressiveMesh Field

Retrieves the globally unique identifier (GUID) for progressive mesh templates. Used internally by Microsoft DirectX. Do not use.

Definition

Visual Basic | Public Shared ProgressiveMesh As Guid
C# | public static Guid ProgressiveMesh;
C++ | public: static Guid ProgressiveMesh;
JScript | public static var ProgressiveMesh : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for progressive mesh templates.

This field is read-only.


XFileGuid.PropertyBag Field (Microsoft.DirectX.Direct3D)

XFileGuid.PropertyBag Field

Retrieves the globally unique identifier (GUID) for property bag templates. Used internally by Microsoft DirectX. Do not use.

Definition

Visual Basic | Public Shared PropertyBag As Guid
C# | public static Guid PropertyBag;
C++ | public: static Guid PropertyBag;
JScript | public static var PropertyBag : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for property bag templates.

This field is read-only.


XFileGuid.RightHanded Field (Microsoft.DirectX.Direct3D)

XFileGuid.RightHanded Field

Retrieves the globally unique identifier (GUID) for right-handed templates. Used internally by Microsoft DirectX. Do not use.

Definition

Visual Basic | Public Shared RightHanded As Guid
C# | public static Guid RightHanded;
C++ | public: static Guid RightHanded;
JScript | public static var RightHanded : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for right-handed templates.

This field is read-only.


XFileGuid.RmGuid Field (Microsoft.DirectX.Direct3D)

XFileGuid.RmGuid Field

Retrieves the globally unique identifier (GUID) for RMGuid templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared RmGuid As Guid
C# | public static Guid RmGuid;
C++ | public: static Guid RmGuid;
JScript | public static var RmGuid : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for RMGuid templates.

This field is read-only.


XFileGuid.StringProperty Field (Microsoft.DirectX.Direct3D)

XFileGuid.StringProperty Field

Retrieves the globally unique identifier (GUID) for string property templates. Used internally by Microsoft DirectX. Do not use.

Definition

Visual Basic | Public Shared StringProperty As Guid
C# | public static Guid StringProperty;
C++ | public: static Guid StringProperty;
JScript | public static var StringProperty : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for string property templates.

This field is read-only.


XFileGuid.TextureFilename Field (Microsoft.DirectX.Direct3D)

XFileGuid.TextureFilename Field

Retrieves the globally unique identifier (GUID) for texture file-name templates.

Definition

Visual Basic | Public Shared TextureFilename As Guid
C# | public static Guid TextureFilename;
C++ | public: static Guid TextureFilename;
JScript | public static var TextureFilename : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for texture file-name templates.

This field is read-only.

Remarks

Texture file-name templates enable the specification of a texture's file name to apply to a mesh or face. This template should appear within a material object. The following is a TextureFilename template.

[C#]
template TextureFilename
{
    < A42790E1-7810-11cf-8F52-0040333594A3 >
    string filename;
}


XFileGuid.TextureReference Field (Microsoft.DirectX.Direct3D)

XFileGuid.TextureReference Field

Retrieves the globally unique identifier (GUID) for texture reference templates. Provided for legacy applications. Not supported.

Definition

Visual Basic | Public Shared TextureReference As Guid
C# | public static Guid TextureReference;
C++ | public: static Guid TextureReference;
JScript | public static var TextureReference : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for texture reference templates.

This field is read-only.


XFileGuid.TimedFloatKeys Field (Microsoft.DirectX.Direct3D)

XFileGuid.TimedFloatKeys Field

Retrieves the globally unique identifier (GUID) for timed float-key templates.

Definition

Visual Basic | Public Shared TimedFloatKeys As Guid
C# | public static Guid TimedFloatKeys;
C++ | public: static Guid TimedFloatKeys;
JScript | public static var TimedFloatKeys : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for timed float-key templates.

This field is read-only.

Remarks

Timed float-key templates define a set of floating-point values (floats) and a positive time for use in animations. The following is a TimedFloatKeys template.

[C#]
template TimedFloatKeys
{
    < F406B180-7B3B-11cf-8F52-0040333594A3 >
    DWORD time;
    FloatKeys tfkeys;
}
Where: tfkeys - See FloatKeys.


XFileGuid.Url Field (Microsoft.DirectX.Direct3D)

XFileGuid.Url Field

Retrieves the globally unique identifier (GUID) for URL templates. Used internally by Microsoft DirectX. Do not use.

Definition

Visual Basic | Public Shared Url As Guid
C# | public static Guid Url;
C++ | public: static Guid Url;
JScript | public static var Url : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for URL templates.

This field is read-only.


XFileGuid.Vector Field (Microsoft.DirectX.Direct3D)

XFileGuid.Vector Field

Retrieves the globally unique identifier (GUID) for vector templates.

Definition

Visual Basic | Public Shared Vector As Guid
C# | public static Guid Vector;
C++ | public: static Guid Vector;
JScript | public static var Vector : Guid

Field Value

System.Guid
A Guid Leave Site value that contains the GUID for vector templates.

This field is read-only.

Remarks

Vector templates define a vector, as shown in the following example.

[C#]
template Vector
{
    < 3D82AB5E-62DA-11cf-AB39-0020AF71E433 >
    float x;
    float y;
    float z;
}


XFileManager Class (Microsoft.DirectX.Direct3D)

XFileManager Class

Manages XFile (.x) objects.

Definition

Visual Basic NotInheritable Public Class XFileManager
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class XFileManager : MarshalByRefObject, IDisposable
C++ | public ref class XFileManager sealed : MarshalByRefObject, IDisposable
JScript | public final class XFileManager extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFileManager object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
CreateSaveObject | Creates a save object.
Dispose | Immediately releases the unmanaged resources used by the XFileManager object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFileManager object to free resources before it is destroyed by the garbage collector.
FromFile | Creates an XFile object used to read a .x file.
FromStream | Creates an XFile object from a data stream.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFileManager.Disposing event when called from within a derived class.
RegisterDefaultTemplates | Registers default templates.
RegisterTemplates | Registers custom templates.
RegisterXFileTemplates | Registers custom templates from an XFile object.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFileManager object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
XFileManager | Initializes a new instance of the XFileManager class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFile interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFileManager

Remarks

The object should be disposed immediately when it is no longer needed.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


XFileManager.CreateSaveObject(String,XFileFormat) Method (Microsoft.DirectX.Direct3D)

XFileManager.CreateSaveObject Method

Creates a save object.

Definition

Visual Basic Public Function CreateSaveObject( _
ByVal fileName As String, _
ByVal fileFormat As XFileFormat _
) As XFileSaveObject
C# public XFileSaveObject CreateSaveObject(
string fileName,
XFileFormat fileFormat
);
C++ public:
XFileSaveObject^ CreateSaveObject(
String^ fileName,
XFileFormat fileFormat
);
JScript public function CreateSaveObject(
fileName : String,
fileFormat : XFileFormat
) : XFileSaveObject;

Parameters

fileName System.String
A String Leave Site instance that contains the name of the file to use for saving data.
fileFormat Microsoft.DirectX.Direct3D.XFileFormat
Format to use when saving the XFile (.x file). This value can be one of the XFileFormat enumerated vales. See Remarks.

Return Value

Microsoft.DirectX.Direct3D.XFileSaveObject
An XFileSaveObject instance that represents the created save object.

Remarks

The object should be disposed immediately when it is no longer needed.

To create data objects and to save templates or data, use methods of the XFileSaveObject after using this method.

The default value for the file format is Binary. File format values can be combined in a logical or to create compressed text or binary files. If a file is specified as both binary (0) and text (1), it is saved as a text file, because the value is indistinguishable from the text file format value (0 + 1 = 1). If a file is specified as text and compressed, it is first written out as text and then compressed. However, because compressed text files are not as efficient as binary text files, specifying binary and compressed is recommended in most cases. Setting a file to be compressed without specifying a format results in a binary compressed file.

Exceptions
GraphicsException If a parameter is invalid, the GraphicsException.ErrorCode member contains the XFileErrorCodes.BadValue enumerated value. If the file is invalid, GraphicsException.ErrorCode contains the XFileErrorCodes.BadFile enumerated value. If the memory allocation failed, GraphicsException.ErrorCode contains the XFileErrorCodes.BadAlloc enumerated value.

See Also

  • XFileSaveObject


XFileManager.Dispose() Method (Microsoft.DirectX.Direct3D)

XFileManager.Dispose Method

Immediately releases the unmanaged resources used by the XFileManager object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~XFileManager();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFileManager.Disposed
  • Microsoft.DirectX.Direct3D.XFileManager.Disposing


XFileManager.Equals(Object) Method (Microsoft.DirectX.Direct3D)

XFileManager.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.Finalize() Method (Microsoft.DirectX.Direct3D)

XFileManager.Finalize Method

Allows the XFileManager object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~XFileManager();
C++ | !XFileManager();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


XFileManager.FromFile(String) Method (Microsoft.DirectX.Direct3D)

XFileManager.FromFile Method

Creates an XFile object used to read a .x file.

Definition

Visual Basic Public Function FromFile( _
ByVal filename As String _
) As XFile
C# public XFile FromFile(
string filename
);
C++ public:
XFile^ FromFile(
String^ filename
);
JScript public function FromFile(
filename : String
) : XFile;

Parameters

filename System.String
The filename of the .x file to read.

Return Value

Microsoft.DirectX.Direct3D.XFile
A newly created XFile object to read the .x file.

Remarks

After using this method, use one of the XFile methods to retrieve a data object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.ParseError | Data stream could not be parsed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.FromStream Method ()

Creates an XFile object from a data stream.

Overload List

public XFile FromStream(Stream);
public XFile FromStream(Stream, int);

Remarks

After using this method, use one of the XFile methods to retrieve a data object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.ParseError | Data stream could not be parsed.
ArgumentOutOfRangeException Leave Site | N/A | Length must be greater than zero.
NotSupportedException Leave Site | N/A | The stream must support reading.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.FromStream(Stream) Method (Microsoft.DirectX.Direct3D)

XFileManager.FromStream Method

Creates an XFile object from a data stream.

Definition

Visual Basic Public Function FromStream( _
ByVal data As Stream _
) As XFile
C# public XFile FromStream(
Stream data
);
C++ public:
XFile^ FromStream(
Stream^ data
);
JScript public function FromStream(
data : Stream
) : XFile;

Parameters

data System.IO.Stream
A Stream Leave Site that contains the .x file data.

Return Value

Microsoft.DirectX.Direct3D.XFile
A newly created XFile object.

Remarks

After using this method, use one of the XFile methods to retrieve a data object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.ParseError | Data stream could not be parsed.
ArgumentOutOfRangeException Leave Site | N/A | Length must be greater than zero.
NotSupportedException Leave Site | N/A | The stream must support reading.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.FromStream(Stream,Int32) Method (Microsoft.DirectX.Direct3D)

XFileManager.FromStream Method

Creates an XFile object from a data stream.

Definition

Visual Basic Public Function FromStream( _
ByVal data As Stream, _
ByVal length As Integer _
) As XFile
C# public XFile FromStream(
Stream data,
int length
);
C++ public:
XFile^ FromStream(
Stream^ data,
int length
);
JScript public function FromStream(
data : Stream,
length : int
) : XFile;

Parameters

data System.IO.Stream
A Stream Leave Site that contains the .x file data.
length System.Int32
The length of the data stream.

Return Value

Microsoft.DirectX.Direct3D.XFile
A newly created XFile object.

Remarks

After using this method, use one of the XFile methods to retrieve a data object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
XFileErrorCodes.ParseError | Data stream could not be parsed.
ArgumentOutOfRangeException Leave Site | N/A | Length must be greater than zero.
NotSupportedException Leave Site | N/A | The stream must support reading.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.GetHashCode() Method (Microsoft.DirectX.Direct3D)

XFileManager.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

XFileManager.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFile, which allows unmanaged COM clients to create an instance of the managed XFileManager class. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.op_Equality(XFileManager,XFileManager) Method (Microsoft.DirectX.Direct3D)

XFileManager.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As XFileManager, _
ByVal right As XFileManager _
) As Boolean
C# public static bool op_Equality(
XFileManager left,
XFileManager right
);
C++ public:
static bool operator==(
XFileManager^ left,
XFileManager^ right
);
JScript public static function op_Equality(
left : XFileManager,
right : XFileManager
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFileManager
The XFileManager object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFileManager
The XFileManager object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.op_Inequality(XFileManager,XFileManager) Method (Microsoft.DirectX.Direct3D)

XFileManager.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As XFileManager, _
ByVal right As XFileManager _
) As Boolean
C# public static bool op_Inequality(
XFileManager left,
XFileManager right
);
C++ public:
static bool operator!=(
XFileManager^ left,
XFileManager^ right
);
JScript public static function op_Inequality(
left : XFileManager,
right : XFileManager
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFileManager
The XFileManager object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFileManager
The XFileManager object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

XFileManager.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.XFileManager.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.RegisterDefaultTemplates() Method (Microsoft.DirectX.Direct3D)

XFileManager.RegisterDefaultTemplates Method

Registers default templates.

Definition

Visual Basic | Public Sub RegisterDefaultTemplates()
C# | public void RegisterDefaultTemplates();
C++ public:
void RegisterDefaultTemplates();
JScript | public function RegisterDefaultTemplates();


XFileManager.RegisterTemplates(Byte[]) Method (Microsoft.DirectX.Direct3D)

XFileManager.RegisterTemplates Method

Registers custom templates.

Definition

Visual Basic Public Sub RegisterTemplates( _
ByVal data() As Byte _
)
C# public void RegisterTemplates(
byte[] data
);
C++ public:
void RegisterTemplates(
array<unsigned char>^ data
);
JScript public function RegisterTemplates(
data : byte[]
);

Parameters

data System.Byte[]
Array of Byte Leave Site values that contain the templates.

Remarks

The data parameter takes either a buffer that holds a compiled binary XFile, or a string that defines an XFile template, converted into an array of bytes. To convert a string into a byte array, use the GetBytes function, as in the following example, using stringVar as the string:

byte[] stringData = System.Text.Encoding.ASCII.GetBytes(stringVar);

The object should be disposed immediately when it is no longer needed.

Exceptions
GraphicsException
  • If a floating-point size is invalid, the GraphicsException.ErrorCode member contains the XFileErrorCodes.BadFileFloatSize enumerated value.
  • If the file is not an XFile (.x file), GraphicsException.ErrorCode contains the XFileErrorCodes.BadFileType enumerated value.
  • If the file version is not valid, GraphicsException.ErrorCode contains the XFileErrorCodes.BadFileVersion enumerated value.
  • If a parameter is invalid, GraphicsException.ErrorCode contains the XFileErrorCodes.BadValue enumerated value.
  • If the file could not be parsed, GraphicsException.ErrorCode contains the XFileErrorCodes.ParseError enumerated value.


XFileManager.RegisterXFileTemplates(XFile) Method (Microsoft.DirectX.Direct3D)

XFileManager.RegisterXFileTemplates Method

Registers custom templates from an XFile object.

Definition

Visual Basic Public Sub RegisterXFileTemplates( _
ByVal xfileObj As XFile _
)
C# public void RegisterXFileTemplates(
XFile xfileObj
);
C++ public:
void RegisterXFileTemplates(
XFile^ xfileObj
);
JScript public function RegisterXFileTemplates(
xfileObj : XFile
);

Parameters

xfileObj Microsoft.DirectX.Direct3D.XFile
An XFile object that contains the templates to register.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

See Also

  • XFileManager.RegisterTemplates

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.UpdateUnmanagedPointer(ID3DXFile) Method (Microsoft.DirectX.Direct3D)

XFileManager.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this XFileManager object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFile _
)
C# public void UpdateUnmanagedPointer(
ID3DXFile pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXFile pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXFile
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFile
Pointer to the ID3DXFile structure used to update the unmanaged pointer for this XFileManager object.


XFileManager.XFileManager Constructor ()

Initializes a new instance of the XFileManager class.

Overload List

public XFileManager();
public XFileManager(ID3DXFile);
public XFileManager(IntPtr);


XFileManager.XFileManager(ID3DXFile) Constructor (Microsoft.DirectX.Direct3D)

XFileManager.XFileManager Constructor

Initializes a new instance of the XFileManager class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXFile _
)
C# public XFileManager(
ID3DXFile pUnk
);
C++ public:
XFileManager(
ID3DXFile pUnk
);
JScript public function XFileManager(
pUnk : ID3DXFile
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFile
Unmanaged Component Object Model (COM) ID3DXFile interface pointer.


XFileManager.XFileManager(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

XFileManager.XFileManager Constructor

Initializes a new instance of the XFileManager class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFileManager(
IntPtr unmanagedObject
);
C++ public:
XFileManager(
IntPtr unmanagedObject
);
JScript public function XFileManager(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXFile interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.


XFileManager.XFileManager() Constructor (Microsoft.DirectX.Direct3D)

XFileManager.XFileManager Constructor

Initializes a new instance of the XFileManager class.

Definition

Visual Basic | Public Sub New()
C# | public XFileManager();
C++ public:
XFileManager();
JScript | public function XFileManager();


XFileManager.Disposed Property (Microsoft.DirectX.Direct3D)

XFileManager.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileManager.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

XFileManager.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXFile interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXFile
C# | public ID3DXFile UnmanagedComPointer { get; }
C++ public:
property ID3DXFile UnmanagedComPointer {
ID3DXFile get();
}
JScript | public function get UnmanagedComPointer() : ID3DXFile

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFile
Unmanaged ID3DXFile interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


XFileManager.Disposing Event (Microsoft.DirectX.Direct3D)

XFileManager.Disposing Event

Occurs when the Dispose method is called or when the XFileManager object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFileManager.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFileManager object indicates whether that object has been disposed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData Class (Microsoft.DirectX.Direct3D)

XFileSaveData Class

Applications use the methods of the XFileSaveData class to add data objects as children of a .x file data node.

Definition

Visual Basic NotInheritable Public Class XFileSaveData
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class XFileSaveData : MarshalByRefObject, IDisposable
C++ | public ref class XFileSaveData sealed : MarshalByRefObject, IDisposable
JScript | public final class XFileSaveData extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFileSaveData object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDataObject | Adds a data object as a child of the XFileSaveData file data node.
AddDataReference | Adds a data reference as a child of this XFileSaveData file data node. The data reference points to a file data object.
Dispose | Immediately releases the unmanaged resources used by the XFileSaveData object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFileSaveData object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetSaveObject | Retrieves the XFileSaveObject for this file data node.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFileSaveData.Disposing event when called from within a derived class.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFileSaveData object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
XFileSaveData | Initializes a new instance of the XFileSaveData class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
Id | Retrieves the GUID of this XFileSaveData file data node.
Name | Retrieves the name of this XFileSaveData file data node.
Type | Retrieves the template globally unique identifier (GUID) of this file data node.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFileSaveData interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFileSaveData

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.AddDataObject(Guid,String,Guid,Byte[]) Method (Microsoft.DirectX.Direct3D)

XFileSaveData.AddDataObject Method

Adds a data object as a child of the XFileSaveData file data node.

Definition

Visual Basic Public Function AddDataObject( _
ByVal guidTemplate As Guid, _
ByVal name As String, _
ByVal guidData As Guid, _
ByVal data() As Byte _
) As XFileSaveData
C# public XFileSaveData AddDataObject(
Guid guidTemplate,
string name,
Guid guidData,
byte[] data
);
C++ public:
XFileSaveData^ AddDataObject(
Guid guidTemplate,
String^ name,
Guid guidData,
array<unsigned char>^ data
);
JScript public function AddDataObject(
guidTemplate : Guid,
name : String,
guidData : Guid,
data : byte[]
) : XFileSaveData;

Parameters

guidTemplate System.Guid
The globally unique identifier (GUID) representing the data object's template.
name System.String
The name of the data object to add.
guidData System.Guid
A GUID representing the data object. The data object must have been registered with XFileManager.RegisterTemplates or XFileManager.RegisterXFileTemplates. Specify null if the object does not have a GUID.
data System.Byte[]
A Byte Leave Site array representing the buffer containing all required data in the data object.

Return Value

Microsoft.DirectX.Direct3D.XFileSaveData
An XFileSaveData object representing the file data node to which the data object will be added.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.
XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
OutOfMemoryException Leave Site | N/A | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.AddDataReference(String,Guid) Method (Microsoft.DirectX.Direct3D)

XFileSaveData.AddDataReference Method

Adds a data reference as a child of this XFileSaveData file data node. The data reference points to a file data object.

Definition

Visual Basic Public Sub AddDataReference( _
ByVal name As String, _
ByVal guidData As Guid _
)
C# public void AddDataReference(
string name,
Guid guidData
);
C++ public:
void AddDataReference(
String^ name,
Guid guidData
);
JScript public function AddDataReference(
name : String,
guidData : Guid
);

Parameters

name System.String
The name of the data object to add by reference. Specify null if the data object does not have a name.
guidData System.Guid
The globally unique identifier (GUID) representing the data object to add by reference. If null, a reference will be added that points to the data object with the given name.

Remarks

The file data object being referenced must have either a name or a GUID. The file data object must also derive from a different parent XFileSaveData object.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.
XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
OutOfMemoryException Leave Site | N/A | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Dispose() Method (Microsoft.DirectX.Direct3D)

XFileSaveData.Dispose Method

Immediately releases the unmanaged resources used by the XFileSaveData object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~XFileSaveData();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFileSaveData.Disposed
  • Microsoft.DirectX.Direct3D.XFileSaveData.Disposing

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Equals(Object) Method (Microsoft.DirectX.Direct3D)

XFileSaveData.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Finalize() Method (Microsoft.DirectX.Direct3D)

XFileSaveData.Finalize Method

Allows the XFileSaveData object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~XFileSaveData();
C++ | !XFileSaveData();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.GetHashCode() Method (Microsoft.DirectX.Direct3D)

XFileSaveData.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

XFileSaveData.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFileSaveData, which allows unmanaged COM clients to create an instance of the managed XFileSaveData class. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.GetSaveObject() Method (Microsoft.DirectX.Direct3D)

XFileSaveData.GetSaveObject Method

Retrieves the XFileSaveObject for this file data node.

Definition

Visual Basic | Public Function GetSaveObject() As XFileSaveObject
C# | public XFileSaveObject GetSaveObject();
C++ public:
XFileSaveObject^ GetSaveObject();
JScript | public function GetSaveObject() : XFileSaveObject;

Return Value

Microsoft.DirectX.Direct3D.XFileSaveObject
An XFileSaveObject representing this file data node.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.op_Equality(XFileSaveData,XFileSaveData) Method (Microsoft.DirectX.Direct3D)

XFileSaveData.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As XFileSaveData, _
ByVal right As XFileSaveData _
) As Boolean
C# public static bool op_Equality(
XFileSaveData left,
XFileSaveData right
);
C++ public:
static bool operator==(
XFileSaveData^ left,
XFileSaveData^ right
);
JScript public static function op_Equality(
left : XFileSaveData,
right : XFileSaveData
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFileSaveData
The XFileSaveData object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFileSaveData
The XFileSaveData object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.op_Inequality(XFileSaveData,XFileSaveData) Method (Microsoft.DirectX.Direct3D)

XFileSaveData.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As XFileSaveData, _
ByVal right As XFileSaveData _
) As Boolean
C# public static bool op_Inequality(
XFileSaveData left,
XFileSaveData right
);
C++ public:
static bool operator!=(
XFileSaveData^ left,
XFileSaveData^ right
);
JScript public static function op_Inequality(
left : XFileSaveData,
right : XFileSaveData
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFileSaveData
The XFileSaveData object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFileSaveData
The XFileSaveData object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

XFileSaveData.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.XFileSaveData.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.UpdateUnmanagedPointer(ID3DXFileSaveData) Method (Microsoft.DirectX.Direct3D)

XFileSaveData.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this XFileSaveData object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFileSaveData _
)
C# public void UpdateUnmanagedPointer(
ID3DXFileSaveData pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXFileSaveData pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXFileSaveData
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveData
Pointer to the ID3DXFileSaveData structure used to update the unmanaged pointer for this XFileSaveData object.


XFileSaveData.XFileSaveData Constructor ()

Initializes a new instance of the XFileSaveData class.

Overload List

public XFileSaveData(ID3DXFileSaveData);
public XFileSaveData(IntPtr);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.XFileSaveData(ID3DXFileSaveData) Constructor (Microsoft.DirectX.Direct3D)

XFileSaveData.XFileSaveData Constructor

Initializes a new instance of the XFileSaveData class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXFileSaveData _
)
C# public XFileSaveData(
ID3DXFileSaveData pUnk
);
C++ public:
XFileSaveData(
ID3DXFileSaveData pUnk
);
JScript public function XFileSaveData(
pUnk : ID3DXFileSaveData
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveData
Unmanaged Component Object Model (COM) ID3DXFileSaveData interface pointer.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.XFileSaveData(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

XFileSaveData.XFileSaveData Constructor

Initializes a new instance of the XFileSaveData class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFileSaveData(
IntPtr unmanagedObject
);
C++ public:
XFileSaveData(
IntPtr unmanagedObject
);
JScript public function XFileSaveData(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXFileSaveData interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Disposed Property (Microsoft.DirectX.Direct3D)

XFileSaveData.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Id Property (Microsoft.DirectX.Direct3D)

XFileSaveData.Id Property

Retrieves the globally unique identifier (GUID) of this XFileSaveData file data node.

Definition

Visual Basic | Public ReadOnly Property Id As Guid
C# | public Guid Id { get; }
C++ public:
property Guid Id {
Guid get();
}
JScript | public function get Id() : Guid

Property Value

System.Guid
The GUID of this file data node. If the object has no GUID, the returned value will be GUID_NULL.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Name Property (Microsoft.DirectX.Direct3D)

XFileSaveData.Name Property

Retrieves the name of this XFileSaveData file data node.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
The name of this file data node.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.Type Property (Microsoft.DirectX.Direct3D)

XFileSaveData.Type Property

Retrieves the template globally unique identifier (GUID) of this file data node.

Definition

Visual Basic | Public ReadOnly Property Type As Guid
C# | public Guid Type { get; }
C++ public:
property Guid Type {
Guid get();
}
JScript | public function get Type() : Guid

Property Value

System.Guid
The GUID representing the template in this file data node.

This property is read-only.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.
XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveData.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

XFileSaveData.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXFileSaveData interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXFileSaveData
C# | public ID3DXFileSaveData UnmanagedComPointer { get; }
C++ public:
property ID3DXFileSaveData UnmanagedComPointer {
ID3DXFileSaveData get();
}
JScript | public function get UnmanagedComPointer() : ID3DXFileSaveData

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveData
Unmanaged ID3DXFileSaveData interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


XFileSaveData.Disposing Event (Microsoft.DirectX.Direct3D)

XFileSaveData.Disposing Event

Occurs when the Dispose method is called or when the XFileSaveData object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFileSaveData.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFileSaveData object indicates whether that object has been disposed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject Class (Microsoft.DirectX.Direct3D)

XFileSaveObject Class

Creates and saves data objects and templates.

Definition

Visual Basic NotInheritable Public Class XFileSaveObject
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class XFileSaveObject : MarshalByRefObject, IDisposable
C++ | public ref class XFileSaveObject sealed : MarshalByRefObject, IDisposable
JScript | public final class XFileSaveObject extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the XFileSaveObject object is finalized and collected by the garbage collector of the .NET common language runtime.

Methods

Method | Description
AddDataObject | Adds a data object as a child of the XFileSaveData object.
Dispose | Immediately releases the unmanaged resources used by the XFileSaveObject object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the XFileSaveObject object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetManager | Retrieves the XFileManager object of the object that created this XFileSaveObject object.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Microsoft.DirectX.Direct3D.XFileSaveObject.Disposing event when called from within a derived class.
Save | Saves a data object and its children to a .x file on disk.
UpdateUnmanagedPointer | Updates the unmanaged pointer for this XFileSaveObject object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.
XFileSaveObject | Initializes a new instance of the XFileSaveObject class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.
UnmanagedComPointer | Returns the unmanaged Component Object Model (COM) ID3DXFileSaveObject interface pointer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
XFileSaveObject

Remarks

Templates are not required in every file. For example, all templates can be placed in a single XFile file rather than being duplicated in every XFile.

The object should be disposed immediately when it is no longer needed.

Class Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


XFileSaveObject.AddDataObject(Guid,String,Guid,Byte[]) Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.AddDataObject Method

Adds a data object as a child of the XFileSaveData object.

Definition

Visual Basic Public Function AddDataObject( _
ByVal guidTemplate As Guid, _
ByVal name As String, _
ByVal guidData As Guid, _
ByVal data() As Byte _
) As XFileSaveData
C# public XFileSaveData AddDataObject(
Guid guidTemplate,
string name,
Guid guidData,
byte[] data
);
C++ public:
XFileSaveData^ AddDataObject(
Guid guidTemplate,
String^ name,
Guid guidData,
array<unsigned char>^ data
);
JScript public function AddDataObject(
guidTemplate : Guid,
name : String,
guidData : Guid,
data : byte[]
) : XFileSaveData;

Parameters

guidTemplate System.Guid
The globally unique identifier (GUID) representing the data object's template.
name System.String
The name of the data object. Specify null if the data object does not have a name.
guidData System.Guid
A GUID representing the data object. Specify null if the object does not have a GUID.
data System.Byte[]
A Byte Leave Site array as a buffer containing all required data in the data object.

Return Value

Microsoft.DirectX.Direct3D.XFileSaveData
An XFileSaveData object representing the file data node to which the data object will be added.

Remarks

If a data reference object will reference the data object, either the name or guidData parameter must be non-null.

Save the created data to disk by using the XFileSaveObject.Save method.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.
XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
OutOfMemoryException Leave Site | N/A | Microsoft Direct3D could not allocate sufficient memory to complete the call.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.Dispose() Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.Dispose Method

Immediately releases the unmanaged resources used by the XFileSaveObject object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~XFileSaveObject();
JScript | public override function Dispose();

See Also

  • Microsoft.DirectX.Direct3D.XFileSaveObject.Disposed
  • Microsoft.DirectX.Direct3D.XFileSaveObject.Disposing


XFileSaveObject.Equals(Object) Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.Finalize() Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.Finalize Method

Allows the XFileSaveObject object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~XFileSaveObject();
C++ | !XFileSaveObject();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


XFileSaveObject.GetHashCode() Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.GetManager() Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.GetManager Method

Retrieves the XFileManager object of the object that created this XFileSaveObject object.

Definition

Visual Basic | Public Function GetManager() As XFileManager
C# | public XFileManager GetManager();
C++ public:
XFileManager^ GetManager();
JScript | public function GetManager() : XFileManager;

Return Value

Microsoft.DirectX.Direct3D.XFileManager
The XFileManager object of the object that created this XFileSaveObject object.

Remarks

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadValue | A variable is outside its expected range; typically returned when an object is invalid.
InvalidCastException Leave Site | N/A | No object interface is available.
NullReferenceException Leave Site | N/A | An invalid pointer, usually null, was passed as a parameter.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.GetObjectByValue(Int32) Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal uniqueKey As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int uniqueKey
);
C++ public:
IntPtr GetObjectByValue(
int uniqueKey
);
JScript public function GetObjectByValue(
uniqueKey : int
) : IntPtr;

Parameters

uniqueKey System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, ID3DXFileSaveObject, which allows unmanaged COM clients to create an instance of the managed XFileSaveObject class. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.op_Equality(XFileSaveObject,XFileSaveObject) Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As XFileSaveObject, _
ByVal right As XFileSaveObject _
) As Boolean
C# public static bool op_Equality(
XFileSaveObject left,
XFileSaveObject right
);
C++ public:
static bool operator==(
XFileSaveObject^ left,
XFileSaveObject^ right
);
JScript public static function op_Equality(
left : XFileSaveObject,
right : XFileSaveObject
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFileSaveObject
The XFileSaveObject object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFileSaveObject
The XFileSaveObject object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.op_Inequality(XFileSaveObject,XFileSaveObject) Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As XFileSaveObject, _
ByVal right As XFileSaveObject _
) As Boolean
C# public static bool op_Inequality(
XFileSaveObject left,
XFileSaveObject right
);
C++ public:
static bool operator!=(
XFileSaveObject^ left,
XFileSaveObject^ right
);
JScript public static function op_Inequality(
left : XFileSaveObject,
right : XFileSaveObject
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.XFileSaveObject
The XFileSaveObject object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.XFileSaveObject
The XFileSaveObject object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.raise_Disposing Method

Raises the Microsoft.DirectX.Direct3D.XFileSaveObject.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.Save() Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.Save Method

Saves a data object and its children to a .x file on disk.

Definition

Visual Basic | Public Sub Save()
C# | public void Save();
C++ public:
void Save();
JScript | public function Save();

Remarks

After this method succeeds, XFileSaveObject.AddDataObject, XFileSaveData.AddDataObject, and XFileSaveData.AddDataReference can no longer be called until a new XFile object is created.

Exception | GraphicsException.ErrorCode | Cause
GraphicsException | XFileErrorCodes.BadObject | Data could not be read from or written to an object.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.UpdateUnmanagedPointer(ID3DXFileSaveObject) Method (Microsoft.DirectX.Direct3D)

XFileSaveObject.UpdateUnmanagedPointer Method

Updates the unmanaged pointer for this XFileSaveObject object. This method supports the Microsoft .NET Framework infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub UpdateUnmanagedPointer( _
ByVal pInterface As ID3DXFileSaveObject _
)
C# public void UpdateUnmanagedPointer(
ID3DXFileSaveObject pInterface
);
C++ public:
void UpdateUnmanagedPointer(
ID3DXFileSaveObject pInterface
);
JScript public function UpdateUnmanagedPointer(
pInterface : ID3DXFileSaveObject
);

Parameters

pInterface Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveObject
Pointer to the ID3DXFileSaveObject structure used to update the unmanaged pointer for this XFileSaveObject object.


XFileSaveObject.XFileSaveObject Constructor ()

Initializes a new instance of the XFileSaveObject class.

Overload List

public XFileSaveObject(ID3DXFileSaveObject);
public XFileSaveObject(IntPtr);

Remarks

The object should be disposed immediately when it is no longer needed.


XFileSaveObject.XFileSaveObject(ID3DXFileSaveObject) Constructor (Microsoft.DirectX.Direct3D)

XFileSaveObject.XFileSaveObject Constructor

Initializes a new instance of the XFileSaveObject class.

Definition

Visual Basic Public Sub New( _
ByVal pUnk As ID3DXFileSaveObject _
)
C# public XFileSaveObject(
ID3DXFileSaveObject pUnk
);
C++ public:
XFileSaveObject(
ID3DXFileSaveObject pUnk
);
JScript public function XFileSaveObject(
pUnk : ID3DXFileSaveObject
);

Parameters

pUnk Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveObject
Unmanaged Component Object Model (COM) ID3DXFileSaveObject interface pointer.

Remarks

The object should be disposed immediately when it is no longer needed.


XFileSaveObject.XFileSaveObject(IntPtr) Constructor (Microsoft.DirectX.Direct3D)

XFileSaveObject.XFileSaveObject Constructor

Initializes a new instance of the XFileSaveObject class.

Definition

Visual Basic Public Sub New( _
ByVal unmanagedObject As IntPtr _
)
C# public XFileSaveObject(
IntPtr unmanagedObject
);
C++ public:
XFileSaveObject(
IntPtr unmanagedObject
);
JScript public function XFileSaveObject(
unmanagedObject : IntPtr
);

Parameters

unmanagedObject System.IntPtr
Pointer to an unmanaged Component Object Model (COM) ID3DXFileSaveObject interface. This parameter is useful for working with unmanaged applications from managed code. Not supported.

Remarks

The object should be disposed immediately when it is no longer needed.


XFileSaveObject.Disposed Property (Microsoft.DirectX.Direct3D)

XFileSaveObject.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


XFileSaveObject.UnmanagedComPointer Property (Microsoft.DirectX.Direct3D)

XFileSaveObject.UnmanagedComPointer Property

Returns the unmanaged Component Object Model (COM) ID3DXFileSaveObject interface pointer.

Definition

Visual Basic | Public ReadOnly Property UnmanagedComPointer As ID3DXFileSaveObject
C# | public ID3DXFileSaveObject UnmanagedComPointer { get; }
C++ public:
property ID3DXFileSaveObject UnmanagedComPointer {
ID3DXFileSaveObject get();
}
JScript | public function get UnmanagedComPointer() : ID3DXFileSaveObject

Property Value

Microsoft.DirectX.PrivateImplementationDetails.ID3DXFileSaveObject
Unmanaged ID3DXFileSaveObject interface pointer.

This property is read-only.

Remarks

The Microsoft.DirectX.PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.


XFileSaveObject.Disposing Event (Microsoft.DirectX.Direct3D)

XFileSaveObject.Disposing Event

Occurs when the Dispose method is called or when the XFileSaveObject object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Microsoft.DirectX.Direct3D.XFileSaveObject.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the XFileSaveObject object indicates whether that object has been disposed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AnimationOutputFlags Enumeration (Microsoft.DirectX.Direct3D)

AnimationOutputFlags Enumeration

Defines the flags used to create an AnimationOutput object.

Definition

Visual Basic | Public Enum AnimationOutputFlags
C# | public enum AnimationOutputFlags
C++ | public enum class AnimationOutputFlags
JScript | public enum AnimationOutputFlags

Members

Member | Value | Description
Rotation | 8 | Enable retrieval of the animation's rotation data.
Scale | 2 | Enable retrieval of the animation's scaling data.
Translation | 4 | Enable retrieval of the animation's translation data.
TransformationMatrix | 1 | Enable retrieval of the animation's matrix transformation data.
None | 0 | No output desired.

Remarks

These flags control the outputs an AnimationOutput object encapsulates. A combination of one or more flags is valid when creating an AnimationOutput object.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BackBufferType Enumeration (Microsoft.DirectX.Direct3D)

BackBufferType Enumeration

Defines constants that identify the type of back buffers in a swap chain.

Definition

Visual Basic | Public Enum BackBufferType
C# | public enum BackBufferType
C++ | public enum class BackBufferType
JScript | public enum BackBufferType

Members

Member | Value | Description
Right | 2 | Not supported.
Left | 1 | Not supported.
Mono | 0 | Nonstereo swap chain (one or more nonstereo back buffers).

Remarks

In stereo view, a stereo pair contains both a right-eye and a left-eye view of a 3-D scene. Microsoft DirectX 9.0 does not support stereo view, so neither the Right nor the Left values of this enumerated type are supported.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Device.GetBackBuffer
  • SwapChain.GetBackBuffer


BasisType Enumeration (Microsoft.DirectX.Direct3D)

BasisType Enumeration

Defines the basis type of a high-order patch surface.

Definition

Visual Basic | Public Enum BasisType
C# | public enum BasisType
C++ | public enum class BasisType
JScript | public enum BasisType

Members

Member | Value | Description
CatMullRom | 2 | An interpolating basis defines the surface so that it passes through all of the specified input vertices.
BSpline | 1 | Input vertices are treated as control points of a B-spline surface. In general, the generated surface does not contain the specified control vertices.
Bezier | 0 | Input vertices are treated as a series of Bezier patches. The number of vertices specified must be divisible by 3 + 1; portions of the mesh beyond this criterion are not rendered. Full continuity is assumed between sub-patches in the interior of the surface rendered by each call. Only the vertices at the corners of each sub-patch are guaranteed to lie on the resulting surface.

Remarks

The flags in this type specify the formulation to use in evaluating the high-order patch surface primitive during tessellation.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • RectanglePatchInformation
  • TrianglePatchInformation


Blend Enumeration (Microsoft.DirectX.Direct3D)

Blend Enumeration

Defines the supported . (The RGBA values of the source and destination are indicated by the subscripts s and d.)

Definition

Visual Basic | Public Enum Blend
C# | public enum Blend
C++ | public enum class Blend
JScript | public enum Blend

Members

Member | Value | Description
Zero | 1 | Blend factor is (0, 0, 0, 0).
InvBlendFactor | 15 | Inverted constant color blending factor used by the frame-buffer blender. This blend mode is supported only if the BlendCaps.SupportsBlendFactor property is set to true.
BlendFactor | 14 | Constant color blending factor used by the frame-buffer blender. This blend mode is supported only if the BlendCaps.SupportsBlendFactor property is set to true.
BothInvSourceAlpha | 13 | Source blend factor is (1 - As, 1 - As, 1 - As, 1 - As), and destination blend factor is (As, As, As, As); the destination blend selection is overridden. This blend mode is supported only if the RenderStateManager.SourceBlend property is set to true.
BothSourceAlpha | 12 | Obsolete. To achieve the same effect, set the source and destination blend factors to SourceAlpha and InvSourceAlpha in separate calls.
SourceAlphaSat | 11 | Blend factor is (f, f, f, 1); f = min(A, 1 - Ad).
InvDestinationColor | 10 | Blend factor is (1 - Rd, 1 - Gd, 1 - Bd, 1 - Ad).
DestinationColor | 9 | Blend factor is (Rd, Gd, Bd, Ad).
InvDestinationAlpha | 8 | Blend factor is (1 - Ad, 1 - Ad, 1 - Ad, 1 - Ad).
DestinationAlpha | 7 | Blend factor is (Ad, Ad, Ad, Ad).
InvSourceAlpha | 6 | Blend factor is ( 1 - As, 1 - As, 1 - As, 1 - As).
SourceAlpha | 5 | Blend factor is (As, As, As, As).
InvSourceColor | 4 | Blend factor is (1 - Rs, 1 - Gs, 1 - Bs, 1 - As).
SourceColor | 3 | Blend factor is (Rs, Gs, Bs, As).
One | 2 | Blend factor is (1, 1, 1, 1).

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BlendOperation Enumeration (Microsoft.DirectX.Direct3D)

BlendOperation Enumeration

Defines the supported blend operations.

Definition

Visual Basic | Public Enum BlendOperation
C# | public enum BlendOperation
C++ | public enum class BlendOperation
JScript | public enum BlendOperation

Members

Member Value Description
Subtract 2 Result is the destination subtracted from the source.

Result = Source - Destination
Max 5 Result is the maximum of the source and destination.

Result = MAX(Source, Destination)
Min 4 Result is the minimum of the source and destination.

Result = MIN(Source, Destination)
RevSubtract 3 Result is the source subtracted from the destination.

Result = Destination - Source
Add 1 Result is the destination added to the source.

Result = Source + Destination

Remarks

This enumeration is used by the RenderStateManager.BlendOperation property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • DeviceCaps
  • RenderStateManager


CallbackSearchFlags Enumeration (Microsoft.DirectX.Direct3D)

CallbackSearchFlags Enumeration

Defines the flags used to obtain callback information.

Definition

Visual Basic | Public Enum CallbackSearchFlags
C# | public enum CallbackSearchFlags
C++ | public enum class CallbackSearchFlags
JScript | public enum CallbackSearchFlags

Members

Member | Value | Description
BehindInitialPosition | 2 | Reverses the direction of the callback search.
ExcludingInitialPosition | 1 | Excludes callbacks at the initial position from the search.

Remarks

This enumeration is used by the AnimationSet.GetCallback method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Channel Enumeration (Microsoft.DirectX.Direct3D)

Channel Enumeration

Defines flags that specify which channels in a texture to operate on.

Definition

Visual Basic | Public Enum Channel
C# | public enum Channel
C++ | public enum class Channel
JScript | public enum Channel

Members

Member | Value | Description
Alpha | 8 | Operation is performed on the alpha channel.
Green | 4 | Operation is performed on the green channel.
Blue | 2 | Operation is performed on the blue channel.
Red | 1 | Operation is performed on the red channel.
Luminance | 16 | Operation is performed on the luminance channel.

Remarks

This enumeration is used by the TextureLoader.ComputeNormalMap method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CharacterSet Enumeration (Microsoft.DirectX.Direct3D)

CharacterSet Enumeration

Defines a character set.

Definition

Visual Basic | Public Enum CharacterSet
C# | public enum CharacterSet
C++ | public enum class CharacterSet
JScript | public enum CharacterSet

Members

Member | Value | Description
Baltic | 186 | Baltic character set.
Mac | 77 | Characters used by Macintosh.
Russian | 204 | Russian character set.
EastEurope | 238 | Eastern European character set.
Thai | 222 | Thai character set.
Vietnamese | 163 | Vietnamese character set.
Turkish | 162 | Turkish character set.
Greek | 161 | Greek character set.
Arabic | 178 | Arabic character set.
Hebrew | 177 | Hebrew character set.
Johab | 130 | Korean character set.
Oem | 255 | Extended ASCII character set used with disk operating system (DOS) and some Microsoft Windows fonts.
ChineseBig5 | 136 | Chinese character set used mostly in Hong Kong SAR and Taiwan.
GB2312 | 134 | Chinese character set used in mainland China.
Hangul | 129 | Korean character set.
Hangeul | 129 | Another common spelling of the Korean character set.
ShiftJIS | 128 | Japanese character set.
Symbol | 2 | Symbol character set.
Default | 1 | System default character set.
Ansi | 0 | ASCII character set.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Font


CleanType Enumeration (Microsoft.DirectX.Direct3D)

CleanType Enumeration

Defines vertex operations to perform in preparation for mesh cleaning.

Definition

Visual Basic | Public Enum CleanType
C# | public enum CleanType
C++ | public enum class CleanType
JScript | public enum CleanType

Members

Member | Value | Description
Simplification | 3 | Use the Skinning or BowTies flags only as required to prevent infinite loops during mesh operations.
Optimization | 1 | Use the BackFacing flag only as required to prevent infinite loops during mesh operations.
Skinning | 1 | Use the BackFacing flag only as required to prevent infinite loops during mesh operations. Typically used to avoid breaking skinning operations.
BowTies | 2 | If a vertex is the apex of two triangle fans (a bowtie) and mesh operations will affect one of the fans, then split the shared vertex into two new vertices.
BackFacing | 1 | Merge triangles that share the same vertex indices but have face normals pointing in opposite directions (back-facing triangles). Unless vertex indices are corrected so that the triangles have the same vertex winding order, mesh adjacency data from the two triangles may conflict.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ClearFlags Enumeration (Microsoft.DirectX.Direct3D)

ClearFlags Enumeration

Specifies the buffer to use when calling the Device.Clear method.

Definition

Visual Basic | Public Enum ClearFlags
C# | public enum ClearFlags
C++ | public enum class ClearFlags
JScript | public enum ClearFlags

Members

Member | Value | Description
Target | 1 | Specifies a render target.
Stencil | 4 | Specifies a stencil buffer.
ZBuffer | 2 | Specifies a z-buffer.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClipStatusFlags Enumeration (Microsoft.DirectX.Direct3D)

ClipStatusFlags Enumeration

Defines the current clip status.

Definition

Visual Basic | Public Enum ClipStatusFlags
C# | public enum ClipStatusFlags
C++ | public enum class ClipStatusFlags
JScript | public enum ClipStatusFlags

Members

Member | Value | Description
Back | 32 | All vertices are clipped by the back plane of the viewing frustum.
Front | 16 | All vertices are clipped by the front plane of the viewing frustum.
Plane5 | 2048 | All vertices are clipped by the application-defined clipping plane.
Plane4 | 1024 | All vertices are clipped by the application-defined clipping plane.
Plane3 | 512 | All vertices are clipped by the application-defined clipping plane.
Plane2 | 256 | All vertices are clipped by the application-defined clipping plane.
Plane1 | 128 | All vertices are clipped by the application-defined clipping plane.
Plane0 | 64 | All vertices are clipped by the application-defined clipping plane.
All | 4095 | Combination of all clip flags.
Bottom | 8 | All vertices are clipped by the bottom plane of the viewing frustum.
Top | 4 | All vertices are clipped by the top plane of the viewing frustum.
Right | 2 | All vertices are clipped by the right plane of the viewing frustum.
Left | 1 | All vertices are clipped by the left plane of the viewing frustum.

Remarks

When clipping is enabled during vertex processing (by Device.ProcessVertices, Device.DrawPrimitives, or other drawing functions), Microsoft Direct3D computes a clip code for every vertex. The clip code is a combination of ClipStatusFlags. When a vertex is outside a particular clipping plane, the corresponding bit is set in the clip code. Direct3D maintains the clip status using ClipStatus, which has ClipIntersection and ClipUnion properties. ClipUnion is a bitwise OR of all vertex clip codes, and ClipIntersection is a bitwise AND of all vertex clip codes. Initial values are 0 for ClipUnion and 0xFFFFFFFF for ClipIntersection. When the RenderStateManager.Clipping property is set to false, ClipUnion and ClipIntersection are set to 0. Direct3D updates the clip status during drawing calls. To compute clip status for a particular object, set ClipUnion and ClipIntersection to their initial values and continue drawing.

Clip status is not updated by Device.DrawRectanglePatch and Device.DrawTrianglePatch because there is no software emulation for these methods.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorSource Enumeration (Microsoft.DirectX.Direct3D)

ColorSource Enumeration

Defines the location at which a color or color component must be accessed for lighting calculations.

Definition

Visual Basic | Public Enum ColorSource
C# | public enum ColorSource
C++ | public enum class ColorSource
JScript | public enum ColorSource

Members

Member | Value | Description
Color2 | 2 | Use the specular vertex color.
Color1 | 1 | Use the diffuse vertex color.
Material | 0 | Use the color from the current material.

Remarks

This enumeration is used to set the DiffuseMaterialSource, EmissiveMaterialSource, SpecularMaterialSource, and AmbientMaterialSource properties in the RenderStateManager class type.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorWriteEnable Enumeration (Microsoft.DirectX.Direct3D)

ColorWriteEnable Enumeration

Defines values that are used to specify a channel in the RenderStateManager class type.

Definition

Visual Basic | Public Enum ColorWriteEnable
C# | public enum ColorWriteEnable
C++ | public enum class ColorWriteEnable
JScript | public enum ColorWriteEnable

Members

Member | Value | Description
Alpha | 8 | Alpha channel of a buffer.
Blue | 4 | Blue channel of a buffer.
Green | 2 | Green channel of a buffer.
Red | 1 | Red channel of a buffer.
RedGreenBlueAlpha | 15 | All channels of a buffer.
RedGreenBlue | 7 | The red, green, and blue channels of a buffer.

Remarks

This enumeration is used by the ColorWriteEnable, ColorWriteEnable1, ColorWriteEnable2, and ColorWriteEnable3 properties.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • RenderStates


Compare Enumeration (Microsoft.DirectX.Direct3D)

Compare Enumeration

Defines the supported compare functions in the RenderStateManager class type.

Definition

Visual Basic | Public Enum Compare
C# | public enum Compare
C++ | public enum class Compare
JScript | public enum Compare

Members

Member | Value | Description
Always | 8 | Always pass the test.
Never | 1 | Always fail the test.
GreaterEqual | 7 | Accept the new pixel if its value is greater than or equal to the value of the current pixel.
NotEqual | 6 | Accept the new pixel if its value does not equal the value of the current pixel.
Greater | 5 | Accept the new pixel if its value is greater than the value of the current pixel.
LessEqual | 4 | Accept the new pixel if its value is less than or equal to the value of the current pixel.
Equal | 3 | Accept the new pixel if its value is equal to the value of the current pixel.
Less | 2 | Accept the new pixel if its value is less than the value of the current pixel.

Remarks

The StencilFunction, AlphaFunction, CounterClockwiseStencilFunction, and ZBufferFunction properties use this enumeration.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • RenderStateManager


CompressionFlags Enumeration (Microsoft.DirectX.Direct3D)

CompressionFlags Enumeration

Defines the compression mode to use for storing compressed animation set data.

Definition

Visual Basic | Public Enum CompressionFlags
C# | public enum CompressionFlags
C++ | public enum class CompressionFlags
JScript | public enum CompressionFlags

Members

Member | Value | Description
Default | 0 | Implements fast compression.

Remarks

This enumeration is used by the KeyframedAnimationSet.Compress method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • KeyframedAnimationSet


CompressionQuality Enumeration (Microsoft.DirectX.Direct3D)

CompressionQuality Enumeration

Defines spherical harmonic (SH) compression settings.

Definition

Visual Basic | Public Enum CompressionQuality
C# | public enum CompressionQuality
C++ | public enum class CompressionQuality
JScript | public enum CompressionQuality

Members

Member | Value | Description
SlowHighQuality | 2 | The data compression is high quality, but is slow to compress.
FastLowQuality | 1 | The data compression is low quality, but is fast to compress.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CreateFlags Enumeration (Microsoft.DirectX.Direct3D)

CreateFlags Enumeration

Defines the flags to use when creating a device.

Definition

Visual Basic | Public Enum CreateFlags
C# | public enum CreateFlags
C++ | public enum class CreateFlags
JScript | public enum CreateFlags

Members

Member | Value | Description
NoWindowChanges | 2048 | Indicates to the Microsoft Direct3D runtime not to alter the focus window in any way. Use with caution! The burden of supporting focus management events (ALT-TAB, and so on) falls on the application, and appropriate responses (switching display mode, and so on) should be coded.
DisableDriverManagementEx | 1024 | Specifies that resources be managed by Direct3D instead of the driver. Direct3D calls will fail for resource errors such as insufficient video memory.
AdapterGroupDevice | 512 | The application requests that the device drive all heads that the master adapter owns (this flag is illegal on nonmaster adapters). If the flag is set, the presentation parameters passed to Device should be an array of PresentParameters that contains exactly NumberOfAdaptersInGroup elements. The runtime assigns each element to each head in AdapterOrdinalInGroup numeric order.
DisableDriverManagement | 256 | Specifies that resources be managed by Direct3D instead of the driver. Direct3D calls will not fail for resource errors such as insufficient video memory.
MixedVertexProcessing | 128 | Specifies mixed vertex processing (both software and hardware).
HardwareVertexProcessing | 64 | Specifies hardware vertex processing.
SoftwareVertexProcessing | 32 | Specifies software vertex processing.
PureDevice | 16 | Specifies that Direct3D not support Get calls for anything that can be stored in a state block. Also instructs Direct3D to withhold emulation services for vertex processing, which means that if the device does not support vertex processing, the application can use only post-transformed vertices.
MultiThreaded | 4 | Indicates that the application requested multithread safety in Direct3D. This causes Direct3D to check its global critical section more frequently, which can degrade performance. Starting in the Microsoft DirectX 9.0 SDK Update (Summer 2003), this enumerated value is always specified unless the PresentParameters.ForceNoMultiThreadedFlag is set to true.
FpuPreserve 2 Indicates that the application needs either floating-point unit (FPU) exceptions or double-precision FPU exceptions enabled. By default, Direct3D uses single precision.

Because Direct3D sets the FPU state every time it is called, setting this flag reduces Direct3D performance.

Remarks

This enumeration is used by the Device constructor. The HardwareVertexProcessing, MixedVertexProcessing, and SoftwareVertexProcessing constants are mutually exclusive. One of them must be specified during creation of a device.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Creating a Device
  • Processing Vertex Data
  • BehaviorFlags


CubeMapFace Enumeration (Microsoft.DirectX.Direct3D)

CubeMapFace Enumeration

Defines the faces of a cube map in the CubeTexture class type.

Definition

Visual Basic | Public Enum CubeMapFace
C# | public enum CubeMapFace
C++ | public enum class CubeMapFace
JScript | public enum CubeMapFace

Members

Member | Value | Description
NegativeZ | 5 | Negative z-face of the cube map.
PositiveZ | 4 | Positive z-face of the cube map.
NegativeY | 3 | Negative y-face of the cube map.
PositiveY | 2 | Positive y-face of the cube map.
NegativeX | 1 | Negative x-face of the cube map.
PositiveX | 0 | Positive x-face of the cube map.

Remarks

This enumeration is used by the AddDirtyRectangle, GetCubeMapSurface, LockRectangle, and UnlockRectangle methods.

The values in this enumerated type also define faces of a cube map in the RenderToEnvironmentMap.Face method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • RenderToEnvironmentMap


Cull Enumeration (Microsoft.DirectX.Direct3D)

Cull Enumeration

Defines the supported culling modes, which specify how back faces are culled during geometry rendering.

Definition

Visual Basic | Public Enum Cull
C# | public enum Cull
C++ | public enum class Cull
JScript | public enum Cull

Members

Member | Value | Description
CounterClockwise | 3 | Cull back faces with counterclockwise vertices.
Clockwise | 2 | Cull back faces with clockwise vertices.
None | 1 | Do not cull back faces.

Remarks

This enumeration is used by the RenderStateManager.CullMode property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeclarationMethod Enumeration (Microsoft.DirectX.Direct3D)

DeclarationMethod Enumeration

Defines the declaration methods for a vertex declaration.

Definition

Visual Basic | Public Enum DeclarationMethod
C# | public enum DeclarationMethod
C++ | public enum class DeclarationMethod
JScript | public enum DeclarationMethod

Members

Member | Value | Description
LookUpPresampled | 6 | Looks up a pre-sampled displacement map. The input type must be set to Unused, and the stream index and stream offset must be set to 0. The output type for this operation is always Float1. The device must support displacement mapping. This constant is supported only by the programmable pipeline on N-patch data, if N-patches are enabled.
LookUp | 5 | Looks up a displacement map. The input type can be Float2, Float3, or Float4. Only the .x and .y components are used for the texture map lookup. The output type is always Float1. The device must support displacement mapping. This constant is supported only by the programmable pipeline on N-patch data, if N-patches are enabled.
UV | 4 | Copies out the u and v values at a point on the rectangle or triangle patch. This results in a 2-D float. The input type must be set to Unused; the output type is always Float2. The input stream and offset also are unused, but must be set to 0.
CrossUv | 3 | Computes the normal at a point on the rectangle or triangle patch as the cross product of the two tangents. The input type can be any of the DeclarationType float values, Color, Ubyte4, or Short4. The output type is always Float3.
PartialV | 2 | Computes the tangent at a point on the rectangle or triangle patch in the v direction. The input type can be Float3, Float4, Color, Ubyte4, or Short4. The output type is always Float3.
PartialU | 1 | Computes the tangent at a point on the rectangle or triangle patch in the u direction. The input type can be Float3, Float4, Color, Ubyte4, or Short4. The output type is always Float3.
Default | 0 | Default value. The tessellator copies the vertex data (or the spline data if it is operating on a patch) without performing additional calculations on it. The input and output types can be any value. When the tessellator is used, this element is interpolated; otherwise, vertex data is copied into the input register.

Remarks

The VertexElement structure uses DeclarationMethod values to determine which vertex data to calculate during tessellation. These values can be passed into the constructor or to the DeclarationMethod property. Mesh data should use the default value. Patches can use any of the other implemented types.

Vertex data is declared with an array of VertexElement structures. Each element in the array contains a vertex declaration method.

In addition to using Default, a normal mesh can use LookUp and LookUpPresampled when N-patches are enabled.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeclarationType Enumeration (Microsoft.DirectX.Direct3D)

DeclarationType Enumeration

Defines declaration types for a vertex declaration.

Definition

Visual Basic | Public Enum DeclarationType
C# | public enum DeclarationType
C++ | public enum class DeclarationType
JScript | public enum DeclarationType

Members

Member | Value | Description
Float16Four | 16 | Four 16-bit floating-point values expanded to (value, value, value, value). This type is valid for vertex shader version 2.0 or higher.
Float16Two | 15 | Two 16-bit floating-point values expanded to (value, value, 0, 1). This type is valid for vertex shader version 2.0 or higher.
Dec3N | 14 | 3-D signed 10 10 10 format, normalized and expanded to (v[0]/511.0, v[1]/511.0, v[2]/511.0, 1).
UDec3 | 13 | 3-D unsigned 10 10 10 format, expanded to (value, value, value, 1).
UShort4N | 12 | Normalized 4-D unsigned short, expanded to (First byte/65535.0, second byte/65535.0, third byte/65535.0, fourth byte/65535.0). This type is valid for vertex shader version 2.0 or higher.
UShort2N | 11 | Normalized, 2-D unsigned short, expanded to (First byte/65535.0, second byte/65535.0, 0, 1). This type is valid for vertex shader version 2.0 or higher.
Short4N | 10 | Normalized, 4-D signed short, expanded to (First byte/32767.0, second byte/32767.0, third byte/32767.0, fourth byte/32767.0). This type is valid for vertex shader version 2.0 or higher.
Short2N | 9 | Normalized, 2-D signed short, expanded to (First byte/32767.0, second byte/32767.0, 0, 1). This type is valid for vertex shader version 2.0 or higher.
Ubyte4N | 8 | Each of 4 bytes is normalized by dividing to 255.0. This type is valid for vertex shader version 2.0 or higher.
Short4 | 7 | 4-D signed short, expanded to (value, value, value, value).
Short2 | 6 | 2-D signed short, expanded to (value, value, 0, 1).
Ubyte4 | 5 | 4-D unsigned byte.
Float4 | 3 | 4-D float, expanded to (float, float, float, float).
Float3 | 2 | 3-D float, expanded to (float, float, float, 1).
Float2 | 1 | 2-D float, expanded to (float, float, 0, 1).
Float1 | 0 | 1-D float, expanded to (float, 0, 0, 1).
Unused | 17 | Type field in the declaration is unused. This is designed for use with UV and LookUpPresampled.
Color | 4 | 4-D packed unsigned bytes, mapped to 0 to 1 range. Input is in Int32 Leave Site format (ARGB) expanded to (R, G, B, A).

Remarks

Vertex data is declared with an array of VertexElement structures. Each element in the array contains a vertex declaration method. These values can be passed into the constructor or to the DeclarationMethod property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeclarationUsage Enumeration (Microsoft.DirectX.Direct3D)

DeclarationUsage Enumeration

Defines declaration usage for a vertex declaration.

Definition

Visual Basic | Public Enum DeclarationUsage
C# | public enum DeclarationUsage
C++ | public enum class DeclarationUsage
JScript | public enum DeclarationUsage

Members

Member | Value | Description
Depth | 12 | Vertex data contains depth data.
Sample | 13 | Vertex data contains sampler data. (Sample with VertexElement.UsageIndex = 0) specifies the displacement value to look up. This flag can be used only with LookUpPresampled or LookUp.
Fog | 11 | Vertex data contains fog data. (Fog with VertexElement.UsageIndex = 0) specifies a fog blend value to use after pixel shading is finished. This flag applies to pixel shaders prior to version ps_3_0.
PositionTransformed | 9 | Vertex data contains transformed position data. (PositionTransformed with VertexElement.UsageIndex = 0) specifies the transformed position. When a declaration that contains this flag is set, the pipeline does not perform vertex processing.
TessellateFactor | 8 | Single positive floating-point value. (TessellateFactor with VertexElement.UsageIndex = 0) specifies a tessellation factor used in the tessellation unit to control the rate of tessellation. For more information about the data type, see Float1.
BiNormal | 7 | Vertex binormal data.
Tangent | 6 | Vertex tangent data.
TextureCoordinate | 5 | Texture coordinate data. (TextureCoordinate, n) specifies texture coordinates in fixed function vertex processing and in pixel shaders prior to ps_3_0. These coordinates can be used to pass user-defined data.
BlendIndices | 2 | Blending indices data. (BlendIndices with VertexElement.UsageIndex = 0) specifies matrix indices for fixed function vertex processing using indexed paletted skinning.
BlendWeight | 1 | Blending weight data. (BlendWeight with VertexElement.UsageIndex = 0) specifies the blend weights in fixed function vertex processing.
Color | 10 | Vertex data contains diffuse or specular color. (Color with VertexElement.UsageIndex = 0) specifies the diffuse color in the fixed function vertex shader and in pixel shaders prior to ps_3_0. (Color with VertexElement.UsageIndex = 1) specifies the specular color in the fixed function vertex shader and in pixel shaders prior to ps_3_0.
PointSize | 4 | Point size data. (PointSize with VertexElement.UsageIndex = 0) specifies the point-size attribute used by the setup engine of the rasterizer to expand a point into a quad for the point-sprite functionality.
Normal | 3 | Vertex normal data. (Normal with VertexElement.UsageIndex = 0) specifies vertex normals for fixed function vertex processing and the N-patch tessellator. (Normal with VertexElement.UsageIndex = 1) specifies vertex normals for fixed function vertex processing for skinning.
Position | 0 | Position data. (Position with VertexElement.UsageIndex = 0 ) specifies the nontransformed position in fixed function vertex processing and the N-patch tessellator. (Position with VertexElement.UsageIndex = 1) specifies the nontransformed position in the fixed function vertex shader for skinning.

Remarks

Vertex data is declared with an array of VertexElement structures. Each element in the array contains a usage type.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DegreeType Enumeration (Microsoft.DirectX.Direct3D)

DegreeType Enumeration

Defines the degree of the variables in an equation that describes a curve.

Definition

Visual Basic | Public Enum DegreeType
C# | public enum DegreeType
C++ | public enum class DegreeType
JScript | public enum DegreeType

Members

Member | Value | Description
Quintic | 5 | Curve is described by variables of fourth order.
Cubic | 3 | Curve is described by variables of third order.
Quadratic | 2 | Curve is described by variables of second order.
Linear | 1 | Curve is described by variables of first order.

Remarks

This enumeration is used to describe the curves used by rectangle and triangle patches.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • RenderStateManager
  • Caps


DepthFormat Enumeration (Microsoft.DirectX.Direct3D)

DepthFormat Enumeration

Defines depth buffer formats.

Definition

Visual Basic | Public Enum DepthFormat
C# | public enum DepthFormat
C++ | public enum class DepthFormat
JScript | public enum DepthFormat

Members

Member | Value | Description
Unknown | 0 | Format is unknown.
D24SingleS8 | 83 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 8 bits for the stencil channel.
D32SingleLockable | 82 | A lockable format in which the depth value is represented as a standard IEEE floating-point number.
D24X4S4 | 79 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 4 bits for the stencil channel.
D24X8 | 77 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel.
L16 | 81 | A 16-bit luminance format.
D16 | 80 | A 16-bit z-buffer bit depth.
D24S8 | 75 | A nonlockable format that contains 24 bits of depth (in a 24-bit floating-point format - 20E4) and 8 bits of stencil.
D15S1 | 73 | A 16-bit z-buffer bit depth in which 15 bits are reserved for the depth channel and 1 bit is reserved for the stencil channel.
D32 | 71 | A 32-bit z-buffer bit depth.
D16Lockable | 70 | A 16-bit z-buffer bit depth.

Remarks

All depth-stencil formats except D16Lockable indicate no particular bit ordering per pixel, and the driver is allowed to consume more than the indicated number of bits per depth channel (but not stencil channel).

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CreateDepthStencilSurface
  • Tutorial 4: Using Materials and Lights


DeviceType Enumeration (Microsoft.DirectX.Direct3D)

DeviceType Enumeration

Specifies a device type.

Definition

Visual Basic | Public Enum DeviceType
C# | public enum DeviceType
C++ | public enum class DeviceType
JScript | public enum DeviceType

Members

Member | Value | Description
NullReference | 4 | A null version of the reference rasterizer.
Software | 3 | A pluggable software device.
Reference | 2 | Microsoft Direct3D features are implemented in software; however, the reference rasterizer uses special CPU instructions whenever possible.
Hardware | 1 | Hardware rasterization. Shading is done with software, hardware, or mixed transform and lighting.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Manager
  • GetDeviceCaps
  • Caps
  • DeviceType
  • DeviceCreationParameters
  • DeviceType


DisplacementMap Enumeration (Microsoft.DirectX.Direct3D)

DisplacementMap Enumeration

Identifies a texture sampler stage.

Definition

Visual Basic | Public Enum DisplacementMap
C# | public enum DisplacementMap
C++ | public enum class DisplacementMap
JScript | public enum DisplacementMap

Members

Member | Value | Description
VertexTextureSampler3 | 260 | Texture sampler stage 3.
VertexTextureSampler2 | 259 | Texture sampler stage 2.
VertexTextureSampler1 | 258 | Texture sampler stage 1.
VertexTextureSampler0 | 257 | Texture sampler stage 0.
Sampler | 256 | Internal constant used by the texture sampler in the tessellator.

Remarks

These values are returned by the Manager.CheckDeviceFormat method. They also can be used in the Device.SetTexture method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrawTextFormat Enumeration (Microsoft.DirectX.Direct3D)

DrawTextFormat Enumeration

Specifies the method of formatting text.

Definition

Visual Basic | Public Enum DrawTextFormat
C# | public enum DrawTextFormat
C++ | public enum class DrawTextFormat
JScript | public enum DrawTextFormat

Members

Member | Value | Description
WordBreak | 16 | Breaks words. Lines are automatically broken between words if a word extends past the edge of the rectangle specified by the rect parameter. A carriage return/line feed sequence also breaks the line.
VerticalCenter | 4 | Centers text vertically (on a single line only).
SingleLine | 32 | Displays text on a single line only. Carriage returns and line feeds do not break the line.
RightToLeftReading | 131072 | Displays text in right-to-left reading order for bidirectional text when a Hebrew or Arabic font is selected. The default reading order for all text is left-to-right.
NoClip | 256 | Draws without clipping. Font.DrawText is somewhat faster when NoClip is used.
ExpandTabs | 64 | Expands tab characters. The default number of characters per tab is eight. The PathEllipsis and EndEllipsis values cannot be used with the ExpandTabs value.
Center | 1 | Centers text horizontally in the rectangle.
Top | 0 | Top-justifies text (on a single line only).
Right | 2 | Aligns text to right.
Left | 0 | Aligns text to left.
Bottom | 8 | Justifies text to the bottom of the rectangle. This value must be combined with SingleLine.
None | 0 | Specifies no formatting.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectDefaultType Enumeration (Microsoft.DirectX.Direct3D)

EffectDefaultType Enumeration

Defines effect data types.

Definition

Visual Basic | Public Enum EffectDefaultType
C# | public enum EffectDefaultType
C++ | public enum class EffectDefaultType
JScript | public enum EffectDefaultType

Members

Member | Value | Description
Floats | 2 | Data type is an array of floating-point values.
Integer | 3 | Forces this enumeration to compile to 32 bits in size. This value is not used.
String | 1 | Data type is a String Leave Site object.

Remarks

This enumeration is used by the EffectDefault.Data property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EventType Enumeration (Microsoft.DirectX.Direct3D)

EventType Enumeration

Defines the types of events that can be keyed by the animation controller.

Definition

Visual Basic | Public Enum EventType
C# | public enum EventType
C++ | public enum class EventType
JScript | public enum EventType

Members

Member | Value | Description
PriorityBlend | 4 | Priority blend value.
TrackEnable | 3 | Enable flag.
TrackPosition | 2 | Track position.
TrackWeight | 1 | Track weight.
TrackSpeed | 0 | Track speed.

Remarks

This enumeration is used by the EventDescription.EventType property, which can be passed to an AnimationController class type.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FillMode Enumeration (Microsoft.DirectX.Direct3D)

FillMode Enumeration

Defines constants that describe the fill mode.

Definition

Visual Basic | Public Enum FillMode
C# | public enum FillMode
C++ | public enum class FillMode
JScript | public enum FillMode

Members

Member | Value | Description
Solid | 3 | Fill solids.
WireFrame | 2 | Fill wireframes.
Point | 1 | Fill points.

Remarks

This enumeration is used by the RenderStateManager.FillMode property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Filter Enumeration (Microsoft.DirectX.Direct3D)

Filter Enumeration

Defines texture filtering modes for a texture stage.

Definition

Visual Basic | Public Enum Filter
C# | public enum Filter
C++ | public enum class Filter
JScript | public enum Filter

Members

Member | Value | Description
Box | 5 | Each pixel is computed by averaging a 2x2(x2) box of pixels from the source image. This filter works only when the dimensions of the destination are half those of the source, as is the case with mipmaps.
Point | 2 | Each destination pixel is computed by sampling the nearest pixel from the source image.
Srgb | 6291456 | Same as specifying SrgbIn | SrgbOut.
SrgbOut | 4194304 | Output data is in sRGB (gamma 2.2) color space.
SrgbIn | 2097152 | Input data is in sRGB (gamma 2.2) color space.
DitherDiffusion | 1048576 | Resulting image must be dithered using a 4x4 ordered dither algorithm.
Dither | 524288 | Resulting image must be dithered using a 4x4 ordered dither algorithm.
Mirror | 458752 | Same as specifying the MirrorU, MirrorV, and MirrorW flags. This flag is always used internally for this function.
MirrorW | 262144 | Pixels off the edge of the texture on the w-axis should be mirrored, not wrapped.
MirrorV | 131072 | Pixels off the edge of the texture on the v-axis should be mirrored, not wrapped.
MirrorU | 65536 | Pixels off the edge of the texture on the u-axis should be mirrored, not wrapped.
Triangle | 4 | Each pixel in the source image contributes equally to the destination image. This is the slowest of the filters.
Linear | 3 | Bilinear interpolation filtering is used as a texture magnification or minification filter. A weighted average of a 2x2 area of texels surrounding the desired pixel is used. The texture filter to use between mipmap levels is trilinear mipmap interpolation. The rasterizer interpolates pixel color in a linear manner, using the texels of the two nearest textures.
None | 1 | Mipmapping disabled. The rasterizer uses the magnification filter instead.

Remarks

Each valid filter must contain exactly one of the following flags: None, Point, Linear, Triangle, or Box. In addition, the bitwise OR operator can be used to specify zero or more of the following optional flags with a valid filter: MirrorU, MirrorV, MirrorW, Mirror, or Dither.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • TextureLoader
  • VolumeLoader
  • SurfaceLoader


FogMode Enumeration (Microsoft.DirectX.Direct3D)

FogMode Enumeration

Defines constants that describe the fog mode.

Definition

Visual Basic | Public Enum FogMode
C# | public enum FogMode
C++ | public enum class FogMode
JScript | public enum FogMode

Members

Member | Value | Description
Linear 3 Fog effect intensifies in a linear manner between the start and end points, according to the following formula.

Linear fog equation

Exp2 2 Fog effect intensifies exponentially with the square of the distance, according to the following formula.

Exponential square fog equation

Exp 1 Fog effect intensifies exponentially, according to the following formula.

Exponential fog equation

None | 0 | No fog effect.

Remarks

This enumeration is used by the RenderStateManager.FogTableMode and RenderStateManager.FogVertexMode properties.

Fog can be considered a measure of visibility. The lower the fog value produced by a fog equation, the less visible an object is.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FontQuality Enumeration (Microsoft.DirectX.Direct3D)

FontQuality Enumeration

Specifies the level of font quality.

Definition

Visual Basic | Public Enum FontQuality
C# | public enum FontQuality
C++ | public enum class FontQuality
JScript | public enum FontQuality

Members

Member | Value | Description
ClearTypeNatural | 6 | Text is rendered using the Microsoft ClearType antialiasing (smoothing) method when possible. The font quality is given more importance than maintaining the text size; thus, the text width can change. When using this mode for measuring and rendering, ensure that the application does not cache any layout information. If it does, remote users who do not have ClearType enabled will view different width and metrics.
ClearType | 5 | Microsoft Windows XP: Text is rendered using the ClearType antialiasing method when possible. The font quality is given less importance than maintaining the text size.
AntiAliased 4 Microsoft Windows NT 4.0 and later: Font is antialiased, if it supports antialiasing and if its size falls within the accepted range.

Windows 95 with Microsoft Plus!, Windows 98/Windows Millennium Edition (Windows Me): The display must be greater than 8-bit color, must be a single plane device, cannot be a palette display, and cannot be part of a multiple-display monitor setup. In addition, a TrueType® font must be selected into a screen device context before it is used in a DIBSection (a structure that contains information about a device-independent bitmap); otherwise, antialiasing does not occur.
NonAntiAliased | 3 | Windows 95 with Plus!, Windows 98/Windows Me, Windows NT 4.0 and later: Font is never antialiased.
Proof | 2 | Font's character quality is given more importance than exact matching of the logical-font attributes. For Windows Graphics Device Interface (GDI) raster fonts, scaling is disabled and the font closest in size is chosen. Although this size might not correspond exactly when Proof is used, the font's quality is high and its appearance is not distorted. Bold, italic, underline, and strikeout fonts are synthesized if necessary.
Draft | 1 | Font's appearance is given less importance than when the Proof value is used. Scaling is enabled for GDI raster fonts, which means that more font sizes are available, but their quality might be lower. Bold, italic, underline, and strikeout fonts are synthesized if necessary.
Default | 0 | Font's appearance does not matter.

Remarks

In Windows XP, the following situations do not support ClearType antialiasing:

  • Text rendered on a printer.
  • A display set for 256 colors or less.
  • Text rendered on a Terminal Server client.
  • The font is not a TrueType font or an OpenType® font with TrueType outlines. For example, the following do not support ClearType antialiasing:

    Type 1 fonts, Postscript OpenType® fonts without TrueType outlines, bitmap fonts, vector fonts, and device fonts.

  • The font has tuned embedded bitmaps only for the font sizes that contain the embedded bitmaps. For example, this occurs commonly in East Asian fonts.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FontWeight Enumeration (Microsoft.DirectX.Direct3D)

FontWeight Enumeration

Specifies font weights.

Definition

Visual Basic | Public Enum FontWeight
C# | public enum FontWeight
C++ | public enum class FontWeight
JScript | public enum FontWeight

Members

Member | Value | Description
Black | 900 | 900 font weight.
UltraBold | 800 | 800 font weight.
DemiBold | 600 | 600 font weight.
Regular | 400 | 400 font weight.
UltraLight | 200 | 200 font weight.
Heavy | 900 | 900 font weight.
ExtraBold | 800 | 800 font weight.
Bold | 700 | 700 font weight.
SemiBold | 600 | 600 font weight.
Medium | 500 | 500 font weight.
ExtraLight | 200 | 200 font weight.
Thin | 100 | 100 font weight.
DoNotCare | 0 | 0 font weight.
Normal | 400 | 400 font weight.
Light | 300 | 300 font weight.

Remarks

These enumerated values are defined as a convenience for different numerical font weights.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Format Enumeration (Microsoft.DirectX.Direct3D)

Format Enumeration

Defines various types of surface formats. For a more complete discussion, see Surface Formats.

Definition

Visual Basic | Public Enum Format
C# | public enum Format
C++ | public enum class Format
JScript | public enum Format

Members

Member | Value | Description
D24SingleS8 | 83 | Nonlockable format that contains 24 bits of depth (in a 24-bit floating-point format - 20e4) and 8 bits of stencil.
D32SingleLockable | 82 | Lockable format in which the depth value is represented as a standard IEEE floating-point number.
D24X4S4 | 79 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 4 bits for the stencil channel.
D24X8 | 77 | A 2-bit z-buffer bit depth that uses 24 bits for the depth channel.
L16 | 81 | 16-bit luminance only.
D16 | 80 | A 16-bit z-buffer bit depth.
D24S8 | 75 | A 32-bit z-buffer bit depth that uses 24 bits for the depth channel and 8 bits for the stencil channel.
D15S1 | 73 | A 16-bit z-buffer bit depth that reserves 15 bits for the depth channel and 1 bit for the stencil channel.
D32 | 71 | A 32-bit z-buffer bit depth.
D16Lockable | 70 | A 16-bit z-buffer bit depth.
G8R8G8B8 | 1111970375 | A 16-bit packed RGB format analogous to YUY2 (Y0U0, Y1V0, Y2U2, etc.). It requires a pixel pair to properly represent the color value. The first pixel in the pair contains 8 bits of green (in the high 8 bits) and 8 bits of red (in the low 8 bits). The second pixel contains 8 bits of green (in the high 8 bits) and 8 bits of blue (in the low 8 bits). Together, the two pixels share the red and blue components, and each has a unique green component (G0R0, G1B0, G2R2, etc.). The texture sampler does not normalize the colors when looking up into a pixel shader; they remain in the range of 0.0f to 255.0f. This is true for all programmable pixel shader models. For the fixed function pixel shader, the hardware should normalize to the range of 0.f to 1.f and treat it as the YUY2 texture. Hardware that exposes this format must have Caps.PixelShader1xMaxValue set to a value capable of handling that range.
R8G8B8G8 | 1195525970 | A 16-bit packed RGB format analogous to UYVY (U0Y0, V0Y1, U2Y2, etc.). It requires a pixel pair to properly represent the color value. The first pixel in the pair contains 8 bits of green (in the low 8 bits) and 8 bits of red (in the high 8 bits). The second pixel contains 8 bits of green (in the low 8 bits) and 8 bits of blue (in the high 8 bits). Together, the two pixels share the red and blue components, and each has a unique green component (R0G0, B0G1, R2G2, etc.). The texture sampler does not normalize the colors when looking up into a pixel shader; they remain in the range of 0.0f to 255.0f. This is true for all programmable pixel shader models. For the fixed function pixel shader, the hardware should normalize to the range of 0.f to 1.f and treat it as the YUY2 texture. Hardware that exposes this format must have Caps.PixelShader1xMaxValue set to a value capable of handling that range.
CxV8U8 | 117 | A 32-bit normal compression format. The texture sampler computes the C channel from the signed most significant byte and least significant byte values.
A32B32G32R32F | 116 | Floating-point surface format that uses 32 bits per channel.
G32R32F | 115 | Floating-point surface format that uses 32 bits per channel.
R32F | 114 | Floating-point surface format that uses 32 bits per channel.
A16B16G16R16F | 113 | A 64-bit float format that uses 16 bits per channel (alpha, blue, green, red).
G16R16F | 112 | Floating-point surface format that uses 16 bits per channel.
R16F | 111 | Floating-point surface format that uses 16 bits per channel.
Multi2Argb8 | 827606349 | MET1 compression texture format.
Q16W16V16U16 | 110 | A 64-bit bump-map format that uses 16 bits for each component.
VertexData | 100 | Vertex buffer surface.
Dxt5 | 894720068 | DXT5 compression texture format.
Dxt4 | 877942852 | DXT4 compression texture format.
Dxt3 | 861165636 | DXT3 compression texture format.
Dxt2 | 844388420 | DXT2 compression texture format.
Dxt1 | 827611204 | DXT1 compression texture format.
Yuy2 | 844715353 | YUY2 format (PC98 compliance).
Uyvy | 1498831189 | UYVY format (PC98 compliance).
A2W10V10U10 | 67 | A 32-bit bump-map format that uses 2 bits for alpha and 10 bits each for w, v, and u data.
V16U16 | 64 | A 32-bit bump-map format that uses 16 bits per channel.
Q8W8V8U8 | 63 | A 32-bit bump-map format that uses 8 bits per channel.
X8L8V8U8 | 62 | A 32-bit bump-map format with luminance that uses 8 bits per channel.
L6V5U5 | 61 | A 16-bit bump-map format with luminance that uses 6 bits for luminance and 5 bits each for v and u data.
V8U8 | 60 | A 16-bit bump-map format that uses 8 bits each for u and v data.
A4L4 | 52 | An 8-bit format that uses 4 bits each for alpha and luminance.
A8L8 | 51 | A 16-bit format that uses 8 bits each for alpha and luminance.
L8 | 50 | An 8-bit format with luminance only.
P8 | 41 | An 8-bit format, color indexed.
A8P8 | 40 | An 8-bit format, color indexed with 8 bits of alpha.
A16B16G16R16 | 36 | A 64-bit pixel format that uses 16 bits per component.
A2R10G10B10 | 35 | A 32-bit pixel format that uses 10 bits each for red, green, and blue, and 2 bits for alpha.
G16R16 | 34 | A 32-bit pixel format that uses 16 bits each for green and red.
X8B8G8R8 | 33 | A 32-bit RGB pixel format that reserves 8 bits for each color.
A8B8G8R8 | 32 | A 32-bit ARGB pixel format, with alpha, that uses 8 bits per channel.
A2B10G10R10 | 31 | A 32-bit pixel format that uses 10 bits for each color and 2 bits for alpha.
X4R4G4B4 | 30 | A 16-bit RGB pixel format that uses 4 bits per color.
A8R3G3B2 | 29 | A 16-bit ARGB texture format that uses 8 bits for alpha, 3 bits each for red and green, and 2 bits for blue.
A8 | 28 | 8-bit alpha only.
R3G3B2 | 27 | An 8-bit RGB texture format that uses 3 bits for red, 3 bits for green, and 2 bits for blue.
A4R4G4B4 | 26 | A 16-bit ARGB pixel format that uses 4 bits per channel.
A1R5G5B5 | 25 | A 16-bit pixel format that reserves 5 bits for each color and 1 bit for alpha.
X1R5G5B5 | 24 | A 16-bit pixel format that reserves 5 bits for each color.
R5G6B5 | 23 | A 16-bit RGB pixel format that uses 5 bits for red, 6 bits for green, and 5 bits for blue.
X8R8G8B8 | 22 | A 32-bit RGB pixel format that reserves 8 bits for each color.
A8R8G8B8 | 21 | A 32-bit ARGB pixel format, with alpha, that uses 8 bits per channel.
R8G8B8 | 20 | A 24-bit RGB pixel format that uses 8 bits per channel.
Unknown | 0 | Unknown surface format.

Remarks

For a more complete discussion, see Surface Formats.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Surface Formats
  • Resource Properties
  • CheckDeviceFormat


FX Enumeration (Microsoft.DirectX.Direct3D)

FX Enumeration

Defines flags for saving shader state.

Definition

Visual Basic | Public Enum FX
C# | public enum FX
C++ | public enum class FX
JScript | public enum FX

Members

Member | Value | Description
None | 0 | No state is saved or restored.
DoNotSaveSamplerState | 4 | Sampler state is not saved when calling Effect.Begin, or restored when calling Effect.End.
DoNotSaveShaderState | 2 | Shader state is not saved when calling Effect.Begin, or restored when calling Effect.End.
DoNotSaveState | 1 | Device state is not saved when calling Effect.Begin, or restored when calling Effect.End.

Remarks

This enumeration is used in the Effect class to determine whether the state modified by an effect is saved and restored.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GpuSimulatorOption Enumeration (Microsoft.DirectX.Direct3D)

GpuSimulatorOption Enumeration

Describes the resolution of the shadow z-buffer that will be used in precomputed radiance transfer (PRT) direct lighting simulation on the graphics processing unit (GPU). A higher quality z-buffer can also be specified to reduce noise in the results of the direct lighting simulation, although the simulation will be slower.

Definition

Visual Basic | Public Enum GpuSimulatorOption
C# | public enum GpuSimulatorOption
C++ | public enum class GpuSimulatorOption
JScript | public enum GpuSimulatorOption

Members

Member | Value | Description
Default | 0 | Same as ShadowRes512.
HighQuality | 4 | The simulation is of high precision, regardless of the selected resolution. Setting this value will reduce noise in the results of the direct lighting simulation, although the simulation will be slower. May be combined with one of the other values.
ShadowRes2048 | 3 | Highest resolution simulation. A 2048 x 2048 pixel texture is used in the simulation to encode the shadow z-buffer.
ShadowRes1024 | 2 | High resolution simulation. A 1024 x 1024 pixel texture is used in the simulation to encode the shadow z-buffer.
ShadowRes512 | 0 | Medium resolution simulation. A 512 x 512 pixel texture is used in the simulation to encode the shadow z-buffer. This is the default value.
ShadowRes256 | 1 | Low resolution simulation. A 256 x 256 pixel texture is used in the simulation to encode the shadow z-buffer.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ImageFileFormat Enumeration (Microsoft.DirectX.Direct3D)

ImageFileFormat Enumeration

Defines the supported image file formats.

Definition

Visual Basic | Public Enum ImageFileFormat
C# | public enum ImageFileFormat
C++ | public enum class ImageFileFormat
JScript | public enum ImageFileFormat

Members

Member | Value | Description
Pfm | 8 | Portable float map file format.
Hdr | 7 | High dynamic-range file format.
Dib | 6 | Microsoft Windows bitmap file format.
Ppm | 5 | Portable pixmap file format.
Dds | 4 | DirectDrawSurface file format.
Png | 3 | Portable Network Graphics file format.
Tga | 2 | Truevision Targa image file format.
Jpg | 1 | Joint Photographic Experts Group (JPEG) compressed file format.
Bmp | 0 | Microsoft Windows bitmap file format.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • ImageFileFormat
  • Save
  • Save


ImtWrap Enumeration (Microsoft.DirectX.Direct3D)

ImtWrap Enumeration

Flags used by IntegratedMetricTensor methods.

Definition

Visual Basic | Public Enum ImtWrap
C# | public enum ImtWrap
C++ | public enum class ImtWrap
JScript | public enum ImtWrap

Members

Member | Value | Description
V | 2 | The texture wraps in the V direction.
U | 1 | The texture wraps in the U direction.
UV | 3 | The texture wraps in both the U and the V directions.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IncludeType Enumeration (Microsoft.DirectX.Direct3D)

IncludeType Enumeration

Defines an include file.

Definition

Visual Basic | Public Enum IncludeType
C# | public enum IncludeType
C++ | public enum class IncludeType
JScript | public enum IncludeType

Members

Member | Value | Description
System | 1 | Indicates a system resource.
Local | 0 | Indicates a local resource.

Remarks

This enumeration is used by the Include.Open method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IssueFlags Enumeration (Microsoft.DirectX.Direct3D)

IssueFlags Enumeration

Defines issue flags.

Definition

Visual Basic | Public Enum IssueFlags
C# | public enum IssueFlags
C++ | public enum class IssueFlags
JScript | public enum IssueFlags

Members

Member | Value | Description
End | 1 | Specifies that the runtime issue the end of a query.
Begin | 2 | Specifies that the runtime issue the beginning of a query.

Remarks

This enumeration is used with the Query.Issue method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LightType Enumeration (Microsoft.DirectX.Direct3D)

LightType Enumeration

Defines the light type.

Definition

Visual Basic | Public Enum LightType
C# | public enum LightType
C++ | public enum class LightType
JScript | public enum LightType

Members

Member | Value | Description
Directional | 3 | Light is a directional light source. It is equivalent to using a point light source at an infinite distance.
Spot | 2 | Light is a spotlight source. It is similar to a point light, except that the area of illumination is limited to a cone. This light type has a direction and several other parameters that determine the shape of the cone it produces. For more information, see the Light class.
Point | 1 | Light is a point source. The light has a position in space and radiates light in all directions.

Remarks

Directional lights are slightly faster than point lights, but point lights look a little better. Spotlights offer interesting visual effects but are slow.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LockFlags Enumeration (Microsoft.DirectX.Direct3D)

LockFlags Enumeration

Defines the type of lock to perform.

Definition

Visual Basic | Public Enum LockFlags
C# | public enum LockFlags
C++ | public enum class LockFlags
JScript | public enum LockFlags

Members

Member | Value | Description
Discard 8192 The application overwrites every location within the region being locked, using a write-only operation. This is a valid option when using dynamic textures, dynamic vertex buffers, and dynamic index buffers.

For vertex and index buffers, the application discards the entire buffer. A pointer to a new memory area is returned so that the direct memory access (DMA) and rendering from the previous area do not stall. For textures, the application overwrites every location within the region being locked, using a write-only operation.
DoNotWait 16384 The application is allowed to gain back CPU cycles if the driver cannot lock the surface immediately. When this is the case, the lock call throws WasStillDrawingException.

This flag can be used only when calling Surface.LockRectangle on surfaces created using Device.CreateOffscreenPlainSurface, Device.CreateRenderTarget, or Device.CreateDepthStencilSurface. It also can be used with a back buffer.
NoDirtyUpdate | 32768 | By default, a lock on a resource adds a dirty region to that resource. This flag prevents any changes to the dirty state of the resource. Applications should use this flag when they have additional information about the set of regions changed during the lock operation.
NoSystemLock 2048 By default, a video memory lock reserves a system-wide critical section, guaranteeing that no display mode changes will occur for the duration of the lock. This flag prevents the system-wide critical section from being held while the lock is on.

While the lock operation is time-consuming, it enables the system to perform other duties, such as moving the mouse cursor. This flag is useful for locks of long duration; for example, locking the back buffer for software rendering that otherwise would slow the system.
NoOverwrite | 4096 | The application is guaranteed not to overwrite any data in the vertex and index buffers. This flag allows the driver to return immediately and continue rendering, using this vertex buffer. If the flag is not used, the driver must finish rendering before returning from locking.
ReadOnly | 16 | The application does not write to the buffer. This flag enables resources stored in non-native formats to save the recompression step when unlocking.
None | 0 | Use no locks.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Locking Resources


MeshFlags Enumeration (Microsoft.DirectX.Direct3D)

MeshFlags Enumeration

Defines flags used to specify creation options for a mesh.

Definition

Visual Basic | Public Enum MeshFlags
C# | public enum MeshFlags
C++ | public enum class MeshFlags
JScript | public enum MeshFlags

Members

Member | Value | Description
SimplifyFace | 2 | Simplifies the mesh by the number of faces specified in the minValue parameter of the Mesh.Simplify method.
SimplifyVertex | 1 | Simplifies the mesh by the number of vertices specified in the minValue parameter of the Mesh.Simplify method.
OptimizeDeviceIndependent | 4194304 | Specifies a default vertex cache size that works well on older hardware.
OptimizeDoNotSplit | 536870912 | Specifies that vertices shared between attribute groups should not be split during attribute sorting.
OptimizeIgnoreVerts | 268435456 | Optimizes the faces only; does not optimize the vertices.
OptimizeStripeReorder | 134217728 | Reorders faces to maximize the length of adjacent triangles.
OptimizeVertexCache | 67108864 | Reorders faces to increase the cache hit rate of vertex caches.
OptimizeAttributeSort | 33554432 | Reorders faces to optimize for fewer attribute bundle state changes and enhanced BaseMesh.DrawSubset performance.
OptimizeCompact | 16777216 | Reorders faces to remove unused vertices and faces.
SoftwareProcessing | 98304 | Equivalent to specifying both VbSoftwareProcessing and IbSoftwareProcessing.
Dynamic | 2176 | Equivalent to specifying both VbDynamic and IbDynamic.
WriteOnly | 1088 | Equivalent to specifying both VbWriteOnly and IbWriteOnly.
Managed | 544 | Equivalent to specifying both VbManaged and IbManaged.
SystemMemory | 272 | Equivalent to specifying both VbSystemMem and IbSystemMem.
UseHardwareOnly | 8192 | Specifies use of hardware processing only. For mixed-mode devices, this flag causes the system to use hardware processing if it is supported, and software processing otherwise.
VbShare | 4096 | Forces the cloned meshes to share vertex buffers.
IbSoftwareProcessing | 65536 | Specifies use of the SoftwareProcessing usage flag for index buffers.
IbDynamic | 2048 | Specifies use of the Dynamic usage flag for index buffers.
IbWriteOnly | 1024 | Specifies use of the WriteOnly usage flag for index buffers.
IbManaged | 512 | Specifies use of the Managed memory class for index buffers.
IbSystemMem | 256 | Specifies use of the SystemMemory memory class for index buffers.
VbSoftwareProcessing | 32768 | Specifies use of the SoftwareProcessing usage flag for vertex buffers.
VbDynamic | 128 | Specifies use of the Dynamic usage flag for vertex buffers.
VbWriteOnly | 64 | Specifies use of the WriteOnly usage flag for vertex buffers.
VbManaged | 32 | Specifies use of the Managed memory class for vertex buffers.
VbSystemMem | 16 | Specifies use of the SystemMemory memory class for vertex buffers.
NPatches | 16384 | Causes the vertex and index buffer of the mesh to be created with the NPatches flag. This is required if the mesh object will be rendered using N-patch enhancement with Microsoft Direct3D.
RtPatches | 8 | Used for vertex and index buffers.
Points | 4 | Used for vertex and index buffers.
DoNotClip | 2 | Used for vertex and index buffers.
Use32Bit | 1 | Specifies 32-bit indices instead of 16-bit indices for the mesh.

Remarks

A 32-bit mesh can theoretically support (232)-1 faces and vertices. However, allocating memory for such a large mesh is not practical on a 32-bit operating system.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Tutorial 6: Using Meshes


MultiSampleType Enumeration (Microsoft.DirectX.Direct3D)

MultiSampleType Enumeration

Defines the levels of full-scene multisampling that the device can apply.

Definition

Visual Basic | Public Enum MultiSampleType
C# | public enum MultiSampleType
C++ | public enum class MultiSampleType
JScript | public enum MultiSampleType

Members

Member | Value | Description
SixteenSamples | 16 | Enables 16 levels of full-scene multisampling.
FifteenSamples | 15 | Enables 15 levels of full-scene multisampling.
FourteenSamples | 14 | Enables 14 levels of full-scene multisampling.
ThirteenSamples | 13 | Enables 13 levels of full-scene multisampling.
TwelveSamples | 12 | Enables 12 levels of full-scene multisampling.
ElevenSamples | 11 | Enables 11 levels of full-scene multisampling.
TenSamples | 10 | Enables 10 levels of full-scene multisampling.
NineSamples | 9 | Enables nine levels of full-scene multisampling.
EightSamples | 8 | Enables eight levels of full-scene multisampling.
SevenSamples | 7 | Enables seven levels of full-scene multisampling.
SixSamples | 6 | Enables six levels of full-scene multisampling.
FiveSamples | 5 | Enables five levels of full-scene multisampling.
FourSamples | 4 | Enables four levels of full-scene multisampling.
ThreeSamples | 3 | Enables three levels of full-scene multisampling.
TwoSamples | 2 | Enables two levels of full-scene multisampling.
NonMaskable | 1 | Enables the multisample quality value.
None | 0 | Specifies no full-scene multisampling, and enables swap effects other than SwapEffect.Discard.

Remarks

When multisampling is enabled, all subsamples of a pixel are updated in one pass. However, when subsamples are used for other effects that involve multiple rendering passes, the application can specify that only some of them be affected by a given rendering pass. This latter approach enables simulation of motion blur, depth-of-field focus effects, reflection blur, and other effects.

In addition to enabling full-scene multisampling when a Device.Reset occurs, there are render states that turn various multisampling aspects on and off at fine-grained levels. For more information, see RenderStateManager.

Multisampling is valid only on a swap chain that is created or reset with SwapEffect.Discard.

The multisampling antialiasing value can be set with the parameters or sub-parameters in the following methods.

Module | Parameters | Sub-Parameters
Manager.CheckDeviceMultiSampleType | multiSampleType, qualityLevels | None
Device.CreateDepthStencilSurface | multiSample, multiSampleQuality | None
Device.CreateRenderTarget | multiSample, multiSampleQuality | None
SwapChain.SwapChain | presentationParameters | multiSample, multiSampleQuality
Device.Device | presentationParameters | multiSample, multiSampleQuality
Device.Reset | presentationParameters | multiSample, multiSampleQuality

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • PresentParameters
  • SurfaceDescription


NormalMap Enumeration (Microsoft.DirectX.Direct3D)

NormalMap Enumeration

Defines the flags used to convert a height map into a normal map.

Definition

Visual Basic | Public Enum NormalMap
C# | public enum NormalMap
C++ | public enum class NormalMap
JScript | public enum NormalMap

Members

Member | Value | Description
ComputeOcclusion | 1048576 | Computes the per-pixel occlusion term and encodes it into the alpha. An alpha of 1 means that the pixel is not obscured in any way; an alpha of 0 means that the pixel is completely obscured.
InvertSign | 524288 | Inverts the direction of each normal.
Mirror | 196608 | Same as specifying MirrorU and MirrorV.
MirrorV | 131072 | Indicates that pixels off the edge of the texture on the v-axis should be mirrored, not wrapped.
MirrorU | 65536 | Indicates that pixels off the edge of the texture on the u-axis should be mirrored, not wrapped.

Remarks

The (x,y,z) components of each normal are mapped to the (r,g,b) channels of the output texture.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • TextureLoader.ComputeNormalMap


ParameterClass Enumeration (Microsoft.DirectX.Direct3D)

ParameterClass Enumeration

Defines the class of the object.

Definition

Visual Basic | Public Enum ParameterClass
C# | public enum ParameterClass
C++ | public enum class ParameterClass
JScript | public enum ParameterClass

Members

Member | Value | Description
Struct | 5 | Object is a structure.
Object | 4 | Object is a texture, a shader, or a string.
MatrixColumns | 3 | Object is a column major matrix.
MatrixRows | 2 | Object is a row major matrix.
Vector | 1 | Object is a vector.
Scalar | 0 | Object is a scalar.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • ShaderTypeInformation
  • ConstantDescription


ParameterFlags Enumeration (Microsoft.DirectX.Direct3D)

ParameterFlags Enumeration

Defines shader and effect constants.

Definition

Visual Basic | Public Enum ParameterFlags
C# | public enum ParameterFlags
C++ | public enum class ParameterFlags
JScript | public enum ParameterFlags

Members

Member | Value | Description
Annotation | 4 | The parameter is marked as an annotation.
Shared | 1 | The value of a parameter will be shared by all effects in the same namespace. Changing the value in one effect will change it in all shared effects.
Literal | 2 | The parameter is marked as a literal value. Literal parameters cannot change after compile, allowing the compiler to optimize their usage. Shared parameters cannot be marked as a literal.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ParameterType Enumeration (Microsoft.DirectX.Direct3D)

ParameterType Enumeration

Defines the data contained by the enumeration.

Definition

Visual Basic | Public Enum ParameterType
C# | public enum ParameterType
C++ | public enum class ParameterType
JScript | public enum ParameterType

Members

Member | Value | Description
Sampler | 10 | Parameter is a sampler.
Boolean | 1 | Parameter is a Boolean Leave Site value.
Void | 0 | Parameter is a Void Leave Site object.
SamplerCube | 14 | Parameter is a cube sampler.
Sampler3D | 13 | Parameter is a 3-D sampler.
Sampler2D | 12 | Parameter is a 2-D sampler.
Sampler1D | 11 | Parameter is a 1-D sampler.
TextureCube | 9 | Parameter is a cube texture.
Texture3D | 8 | Parameter is a 3-D texture.
Texture2D | 7 | Parameter is a 2-D texture.
Texture1D | 6 | Parameter is a 1-D texture.
String | 4 | Parameter is a String Leave Site object.
Float | 3 | Parameter is a floating-point number.
Integer | 2 | Parameter is an Int32 Leave Site value.
VertexShader | 16 | Parameter is a vertex shader.
PixelShader | 15 | Parameter is a pixel shader.
Texture | 5 | Parameter is a texture.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • ShaderTypeInformation
  • ConstantDescription


PatchEdge Enumeration (Microsoft.DirectX.Direct3D)

PatchEdge Enumeration

Defines whether the current tessellation mode is discrete or continuous.

Definition

Visual Basic | Public Enum PatchEdge
C# | public enum PatchEdge
C++ | public enum class PatchEdge
JScript | public enum PatchEdge

Members

Member | Value | Description
Continuous | 1 | Continuous edge style. Tessellation is specified as float values, which can be varied smoothly to reduce popping artifacts.
Discrete | 0 | Discrete edge style. Tessellation can be specified as float values, but they will be truncated to integers.

Remarks

Continuous and discrete tessellation produce completely different patterns for the same tessellation values; for example, 4.0 continuous is not the same as 4 discrete. This difference is more apparent in wireframe mode than when rendering fully textured or color-filled scenes.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • RenderStateManager.PatchEdgeStyle


PatchType Enumeration (Microsoft.DirectX.Direct3D)

PatchType Enumeration

Defines mesh patch types.

Definition

Visual Basic | Public Enum PatchType
C# | public enum PatchType
C++ | public enum class PatchType
JScript | public enum PatchType

Members

Member | Value | Description
Rectangle | 1 | Rectangle patch mesh type.
NPatch | 3 | N-patch mesh type.
Triangle | 2 | Triangle patch mesh type.

Remarks

Triangle patches are three-sided; rectangle patches are four-sided. For more information, see TrianglePatchInformation and RectanglePatchInformation.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • PatchInformation


PitchAndFamily Enumeration (Microsoft.DirectX.Direct3D)

PitchAndFamily Enumeration

Defines font families.

Definition

Visual Basic | Public Enum PitchAndFamily
C# | public enum PitchAndFamily
C++ | public enum class PitchAndFamily
JScript | public enum PitchAndFamily

Members

Member | Value | Description
FamilyDecorative | 80 | Specifies a novelty font; for example, Old English.
FamilyScript | 64 | Specifies a font that is designed to look like handwriting; for example, Script and Cursive.
FamilyModern | 48 | Specifies a monospace font with or without serifs. Monospace fonts are usually modern; examples include Pica, Elite, and Courier New.
FamilySwiss | 32 | Specifies a proportional font without serifs; for example, Arial.
FamilyRoman | 16 | Specifies a proportional font with serifs; for example, Times New Roman.
FamilyDoNotCare | 0 | Specifies a generic family name, which is used when information about a font does not exist or does not matter. The default font is used.
MonoFont | 8 | Specifies a monospace font.
VariablePitch | 2 | Specifies a variable-pitch font.
FixedPitch | 1 | Specifies a fixed-pitch font.
DefaultPitch | 0 | Specifies default pitch.

Remarks

A font family is a set of fonts that have common stroke width and serif characteristics. There are five font families; a sixth family allows an application to use the default font.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlaybackType Enumeration (Microsoft.DirectX.Direct3D)

PlaybackType Enumeration

Defines the type of looping mode to use for playback of an animation set.

Definition

Visual Basic | Public Enum PlaybackType
C# | public enum PlaybackType
C++ | public enum class PlaybackType
JScript | public enum PlaybackType

Members

Member | Value | Description
PingPong | 2 | Animation alternates endlessly between playing forward and playing backward.
Once | 1 | Animation plays once, then stops on the last frame.
Loop | 0 | Animation repeats endlessly.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Pool Enumeration (Microsoft.DirectX.Direct3D)

Pool Enumeration

Defines the memory class that holds buffers for a resource.

Definition

Visual Basic | Public Enum Pool
C# | public enum Pool
C++ | public enum class Pool
JScript | public enum Pool

Members

Member | Value | Description
Scratch | 3 | Resources are placed in system RAM and do not need to be re-created when a device is lost. These resources are not bound by device size or format restrictions; therefore, they cannot be accessed by the Microsoft Direct3D device or set as textures or render targets. They can, however, always be created, locked, and copied.
SystemMemory | 2 | Resources consume system RAM but do not reduce pageable RAM. System memory is not typically accessible by the 3-D device. These resources do not need to be re-created when a device is lost. They can be locked and also used as the source for a Device.UpdateSurface or Device.UpdateTexture operation to a memory resource created with Default.
Managed | 1 | Resources are copied automatically to device-accessible memory as needed. Managed resources are backed by system memory and do not need to be re-created when a device is lost. For more information, see Managing Resources.
Default 0 Resources are placed in the memory pool most appropriate for the set of usages requested for the given resource. This is usually video memory, including both local video memory and accelerated graphics port memory. The Default pool is separate from Managed and SystemMemory, and it specifies that the resource be placed in the preferred memory for device access. Note that Default never indicates that either Managed or SystemMemory should be chosen as the memory pool type for this resource.

Textures placed in the Default pool cannot be locked unless they are dynamic textures or private four-character code (FOURCC) driver formats. Accessing unlockable textures requires the use of functions such as Device.UpdateSurface or Device.UpdateTexture. Managed is probably a better choice than Default for most applications.

Some textures can be locked; for example, those created in driver proprietary pixel formats that are unknown to the Direct3D runtime. Swap-chain back buffers, render targets, vertex buffers, and index buffers can be locked. When a device is lost, resources created using Default must be disposed of before calling Device.Reset. Microsoft DirectX 9.0 for Managed Code automatically handles disposal of resources that need it, provided the Device.IsUsingEventHandlers property is set to true (the default setting). For more information, see Lost Devices.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Resource Properties


Precision Enumeration (Microsoft.DirectX.Direct3D)

Precision Enumeration

Specifies the desired output precision.

Definition

Visual Basic | Public Enum Precision
C# | public enum Precision
C++ | public enum class Precision
JScript | public enum Precision

Members

Member | Value | Description
Device | 5 | When more than one font has a given name, use the device font if available.
PsOnly | 10 | Microsoft Windows 2000/Windows XP: When more than one font has a given name, choose a PostScript font if available.
ScreenOutline | 9 | Specifies an outline-based screen font.
Outline | 8 | Microsoft Windows NT/Windows 2000/Windows XP: This value instructs the font mapper to choose from TrueType and other outline-based fonts.
TtOnly | 7 | Windows 2000/Windows XP: When more than one font has a given name, use the TrueType® font if available.
Raster | 6 | When more than one font has a given name, use the raster font if available.
Tt | 4 | When more than one font has a given name, use the TrueType font if available.
Stroke | 3 | Specifies a font with attributes that exactly match the requested attributes.
Character | 2 | Specifies the font with a size (height and width) that most closely matches the requested size. The driver may disregard the requested orientation, but other attributes must match.
String | 1 | Specifies a font with a size (height and width) that most closely matches the requested size. The driver may disregard the requested orientation and escapement, but other attributes must match.
Default | 0 | Specifies any reasonable font.

Remarks

The output precision defines how closely the output must match the requested fonts height, width, character orientation, escapement, and pitch.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Present Enumeration (Microsoft.DirectX.Direct3D)

Present Enumeration

Defines flags that allow the application to request that the SwapChain.Present return immediately when the driver reports that it cannot schedule a presentation.

Definition

Visual Basic | Public Enum Present
C# | public enum Present
C++ | public enum class Present
JScript | public enum Present

Members

Member | Value | Description
LinearContent | 2 | Performs gamma correction from linear space to sRGB for windowed swap chains. This flag takes effect only when the driver exposes SupportsLinearToSrgbPresentation.
DoNotWait | 1 | Performs the presentation operation without waiting. If the hardware is busy processing or waiting for a vertical sync interval, the method throws WasStillDrawingException.
BackBuffersMax | 3 | Returns the maximum number of back buffers supported.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PresentFlag Enumeration (Microsoft.DirectX.Direct3D)

PresentFlag Enumeration

Defines flags that control a Device.Present operation.

Definition

Visual Basic | Public Enum PresentFlag
C# | public enum PresentFlag
C++ | public enum class PresentFlag
JScript | public enum PresentFlag

Members

Member | Value | Description
Video | 16 | Informs the driver that the back buffers contain video data.
DeviceClip | 4 | Clips a windowed Device.Present blit into the window client area, within the monitor screen area of the video adapter that created the Microsoft Direct3D device. This flag works only on Microsoft Windows 2000 and Windows XP.
DiscardDepthStencil 2 Enables z-buffer discarding if set when the device or swap chain is created. When this flag is set, the contents of the depth stencil buffer are invalid after either Device.Present or Device.DepthStencilSurface are called.

Discarding z-buffer data can increase performance and is dependent on the driver. The debug runtime enforces discarding by clearing the z-buffer to some constant value after calling either Device.Present or Device.DepthStencilSurface with a different depth surface.

Discarding z-buffer data is illegal for all lockable formats, D16Lockable, and D32Lockable. Using Device.Device to specify a lockable format and z-buffer discarding will result in failure. For more information about formats, see Format.
LockableBackBuffer 1 Gives the application the ability to lock the back buffer directly. Note that back buffers are not lockable unless the application specifies LockableBackBuffer when calling Device.Device or Device.Reset. Lockable back buffers incur a performance cost on some graphics hardware configurations.

Performing a lock operation (or using Device.UpdateSurface to write on the lockable back buffer) decreases performance on many cards. In this case, consider using textured triangles to move data to the back buffer.
None | 0 | Use no presentation flags.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PresentInterval Enumeration (Microsoft.DirectX.Direct3D)

PresentInterval Enumeration

Defines flags that describe the relationship between the adapter refresh rate and the rate at which Device.Present operations are completed.

Definition

Visual Basic | Public Enum PresentInterval
C# | public enum PresentInterval
C++ | public enum class PresentInterval
JScript | public enum PresentInterval

Members

Member | Value | Description
Immediate | -2147483648 | The runtime updates the window client area immediately, and might do so more than once during the adapter refresh period. Device.Present operations might be affected immediately. This option is always available for both windowed and full-screen swap chains.
Four | 8 | The driver waits for the vertical retrace period. Device.Present operations are not affected more frequently than every fourth screen refresh. Check the Caps.PresentationIntervals property to determine whether the driver supports this option.
Three | 4 | The driver waits for the vertical retrace period. Device.Present operations are not affected more frequently than every third screen refresh. Check the Caps.PresentationIntervals property to determine whether the driver supports this option.
Two | 2 | The driver waits for the vertical retrace period. Device.Present operations are not affected more frequently than every second screen refresh. Check the Caps.PresentationIntervals property to determine whether the driver supports this option.
One | 1 | The driver waits for the vertical retrace period (the runtime will beam trace to prevent tearing). Device.Present operations are not affected more frequently than the screen refresh rate; the runtime completes one Device.Present operation per adapter refresh period, at most. This option is always available for both windowed and full-screen swap chains.
Default | 0 | Equivalent to setting One.

Remarks

This enumeration is used by the Caps.PresentationIntervals and PresentParameters.PresentationInterval properties.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PrimitiveType Enumeration (Microsoft.DirectX.Direct3D)

PrimitiveType Enumeration

How Do I...?
  • Generate a Scene

Defines the primitives supported by Microsoft Direct3D.

Definition

Visual Basic | Public Enum PrimitiveType
C# | public enum PrimitiveType
C++ | public enum class PrimitiveType
JScript | public enum PrimitiveType

Members

Member | Value | Description
TriangleFan | 6 | Renders the vertices as a triangle fan.
TriangleStrip | 5 | Renders the vertices as a triangle strip. The back face culling flag is flipped automatically on even-numbered triangles.
TriangleList | 4 | Renders the specified vertices as a sequence of isolated triangles. Each group of three vertices defines a separate triangle. Back face culling is affected by the current winding-order render state.
LineStrip | 3 | Renders the vertices as a single polyline. Calls that use this primitive type fail if the count is less than two.
LineList | 2 | Renders the vertices as a list of isolated straight line segments. Calls that use this primitive type fail if the count is less than two or is odd.
PointList | 1 | Renders the vertices as a collection of isolated points. This value is unsupported for indexed primitives.

Remarks

Using Triangle Strips or Triangle Fans is often more efficient than using Triangle Lists because fewer vertices are duplicated.

How Do I...?

Generate a Scene

This example shows how to begin scene generation and draw primitives.

The SetStreamSource method binds a vertex buffer to a device data stream to create an association between the vertex data and one of several data stream ports that feed the primitive processing functions. The parameters for this method are the number of the data stream, the name of the VertexBuffer object, and the stream vertex stride.

In the following C# code example, it is assumed that the device is the rendering Device, and vBuffer is a vertex buffer filled with CustomVertex.PositionNormal data.

              [C#]

device.BeginScene();

device.SetStreamSource(0, vBuffer, 0);
device.VertexFormat = CustomVertex.PositionNormal.Format;
device.DrawPrimitives(PrimitiveType.TriangleList, 0, 1);

device.EndScene();

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Device-Supported Primitive Types


PriorityType Enumeration (Microsoft.DirectX.Direct3D)

PriorityType Enumeration

Defines the priority type an animation track is assigned to.

Definition

Visual Basic | Public Enum PriorityType
C# | public enum PriorityType
C++ | public enum class PriorityType
JScript | public enum PriorityType

Members

Member | Value | Description
High | 1 | Blends the track with all high-priority tracks before the high-priority blend is mixed with the low-priority blend.
Low | 0 | Blends the track with all low-priority tracks before the low-priority blend is mixed with the high-priority blend.

Remarks

Tracks with the same priority are blended together, and the two resulting values are then blended using the priority blend factor.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


QueryType Enumeration (Microsoft.DirectX.Direct3D)

QueryType Enumeration

Defines the query type.

Definition

Visual Basic | Public Enum QueryType
C# | public enum QueryType
C++ | public enum class QueryType
JScript | public enum QueryType

Members

Member | Value | Description
Event | 8 | Queries for any asynchronous events issued from application programming interface (API) calls.
CacheUtilization | 18 | Queries for the cache hit rate performance measurement for textures and indexed vertices.
BandwidthTimings | 17 | Queries throughput measurement comparisons for help in understanding the performance of an application.
PixelTimings | 16 | Queries for the percentage of time spent processing pixel shader data.
VertexTimings | 15 | Queries for the percentage of time spent processing vertex shader data.
InterfaceTimings | 14 | Queries for the percentage of time spent processing data in the driver.
PipelineTimings | 13 | Queries for the percentage of time spent processing pipeline data.
TimeStampFrequency | 12 | This query result is true if the values from TimeStamp queries cannot be guarenteed to be continuous throughout the duration of the TimeStampDisjoint query. Otherwise, the query result is false.
TimeStampDisjoint | 11 | This query notifies an application if the counter frequency has changed from the TimeStamp.
TimeStamp | 10 | Returns a 64-bit timestamp.
Occlusion | 9 | Queries for the number of pixels that pass z-testing. These pixels are for primitives drawn between Begin and End. This option enables an application to check the occlusion result against zero. Zero is fully occluded, which means the pixels are not visible from the current camera position.
VertexStats | 6 | Queries vertex statistics. For more information, see VertexStats.
VertexCache | 4 | Queries for driver hints about data layout for vertex caching.
ResourceManager | 5 | Queries the resource manager. For more information, see ResourceManager.

Remarks

Available query types are given in the following table.

QueryType | Valid issue flag | GetData buffer | Runtime | Implicit beginning of query
VertexCache | End | VertexCache | Retail/Debug | Device
ResourceManager | End | ResourceManager | Debug only | Present
VertexStats | End | VertexStats | Debug only | Present
Occlusion | End | Boolean Leave Site | Retail/Debug | Device
Event | Begin, End | UInt32 Leave Site | Retail/Debug | Not applicable

For a ResourceManager query, the device behavior flags must include CreateFlags.DisableDriverManagement.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Query


RegisterSet Enumeration (Microsoft.DirectX.Direct3D)

RegisterSet Enumeration

Defines the data type of the register.

Definition

Visual Basic | Public Enum RegisterSet
C# | public enum RegisterSet
C++ | public enum class RegisterSet
JScript | public enum RegisterSet

Members

Member | Value | Description
Sampler | 3 | 4-D sampler data.
Boolean | 0 | Boolean value.
Float4 | 2 | 4-D floating-point number.
Int4 | 1 | 4-D integer number.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • ShaderConstantInformation
  • ConstantDescription


RenderStates Enumeration (Microsoft.DirectX.Direct3D)

RenderStates Enumeration

Defines device render states.

Definition

Visual Basic | Public Enum RenderStates
C# | public enum RenderStates
C++ | public enum class RenderStates
JScript | public enum RenderStates

Members

Member | Value | Description
Wrap15 | 205 | See Wrap0
Wrap14 | 204 | See Wrap0
Wrap13 | 203 | See Wrap0
Wrap12 | 202 | See Wrap0
Wrap11 | 201 | See Wrap0
Wrap10 | 200 | See Wrap0
Wrap9 | 199 | See Wrap0
Wrap8 | 198 | See Wrap0
PointScaleA 158 Controls the distance-based size attenuation for point primitives. The default value is 1.0f.

This render state is active only when PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.
PointScaleEnable 157 Controls how point sprites are rendered. When set to true, texture coordinates of point sprites are set so that full textures are mapped on each point. When set to false, the vertex texture coordinates are used for the entire point.

The default value is false.
PointSpriteEnable 156 Controls how point sprites are rendered. When set to true, texture coordinates of point sprites are set so that full textures are mapped on each point. When set to false, the vertex texture coordinates are used for the entire point.

The default value is false.
PointSizeMin 155 Specifies the minimum size to which point sprites can be set. The default value is 1.0f. The range for this value is greater than or equal to 0.0f.

Point sprites are clamped to the specified size during rendering. Setting the size to less than 1.0 results in points dropping out, if the point does not cover a pixel center and antialiasing is disabled.

Points also will drop out if the size is less than 1.0, if they are being rendered with reduced intensity, and if antialiasing is enabled.
EmissiveMaterialSource | 148 | Emissive color source for lighting calculations. Valid values are members of the ColorSource enumeration. The default value is ColorSource.Material.
AmbientMaterialSource | 147 | Ambient color source for lighting calculations. Valid values are members of the ColorSource enumeration. The default value is ColorSource.Material.
SpecularMaterialSource | 146 | Specular color source for lighting calculations. Valid values are members of the ColorSource enumeration. The default value is ColorSource.Color2.
DiffuseMaterialSource | 145 | Diffuse color source for lighting calculations. Valid values are members of the ColorSource enumerated type. The default value is ColorSource.Color1. The value for this render state is used only if ColorVertex is set to true.
NormalizeNormals 143 Enables or disables automatic normalization of vertex normals. Set to true to enable normalization of vertex normals, or false to disable it. The default value is false.

Enabling this feature causes the system to normalize the vertex normals for vertices after transforming them to camera space, an operation that can slow down the system.
LocalViewer | 142 | Specifies whether to use camera-relative specular highlights or orthogonal specular highlights. Set to true to enable camera-relative specular highlights, or false to use orthogonal specular highlights. The default value is true. Applications that use orthogonal projection should specify false.
ColorVertex 141 Enables or disables per-vertex color. Set to true to enable per-vertex color, or false to disable it. The default value is true.

Enabling per-vertex color allows the system to include the color defined for individual vertices in its lighting calculations. For more information, see the following topics.

  • AmbientMaterialSource
  • DiffuseMaterialSource
  • EmissiveMaterialSource
  • SpecularMaterialSource
FogVertexMode | 140 | The fog formula to use for vertex fog. Valid values are from the FogMode enumeration. The default fog mode is FogMode.None. See Fog.
Ambient | 139 | Ambient light color. This value is a Color Leave Site object that specifies the ambient color value. The default value is 0.
Lighting 137 Enables or disables Microsoft Direct3D lighting. Set to true to enable Direct3D lighting, or false to disable it. The default value is true.

Only vertices that include a vertex normal are properly lit; vertices that do not contain a vertex normal employ a dot product of 0 in all lighting calculations.
Clipping | 136 | Enables or disables primitive clipping by Direct3D. Set to true to enable primitive clipping, or false to disable it. The default value is true.
Wrap7 | 135 | See Wrap0
Wrap6 | 134 | See Wrap0
Wrap5 | 133 | See Wrap0
Wrap4 | 132 | See Wrap0
Wrap3 | 131 | See Wrap0
Wrap2 | 130 | See Wrap0
Wrap1 | 129 | See Wrap0
Wrap0 128 Texture-wrapping behavior for multiple sets of texture coordinates.

Valid values for this render state can be any combination of WrapCoordinates.Zero (or Wrap.U), WrapCoordinates.One (or Wrap.V), WrapCoordinates.Two (or Wrap.W), and WrapCoordinates.Three. These cause the system to wrap in the direction of the first, second, third, and fourth dimensions, sometimes referred to as the s, t, r, and q directions, for a given texture.

The default value for this render state is 0 (wrapping disabled in all directions).
TextureFactor | 60 | Specifies the color used for multiple-texture blending with the TextureArgument.TFactor texture blending argument or the TextureOperation.BlendFactorAlpha texture blending operation. The default value is 0.
StencilWriteMask | 59 | Specifies the write mask applied to values written into the stencil buffer. The default mask is 0xFFFFFFFF.
StencilMask | 58 | Specifies the stencil mask to apply to the reference value and each stencil buffer entry to determine the significant bits for the stencil test. The default mask is 0xFFFFFFFF.
ReferenceStencil | 57 | Specifies a reference value to use for the stencil test. The default value is 0.
StencilFunction 56 Specifies the comparison function to use for the stencil test. Valid values are members of the Compare enumeration. The default value is Compare.Always.

The comparison function is used to compare the reference value to a stencil buffer entry. This comparison applies only to the bits in the reference value and stencil buffer entry that are set in the stencil mask (by StencilMask).

If the comparison is true, the stencil test passes.
StencilPass | 55 | Specifies the stencil operation to perform if both the stencil test and the depth test (z-test) pass. Valid values are members of the StencilOperation enumeration. The default value is StencilOperation.Keep.
StencilZBufferFail | 54 | Specifies the stencil operation to perform if the stencil test passes and the depth test (z-test) fails. Valid values are members of the StencilOperation enumeration. The default value is StencilOperation.Keep.
StencilFail | 53 | Specifies the stencil operation to perform if the stencil test fails. Valid values are from the StencilOperation enumeration. The default value is StencilOperation.Keep.
StencilEnable | 52 | Enables or disables stenciling. Set to true to enable stenciling, or false to disable it. The default value is false.
RangeFogEnable 48 Enables or disables range-based vertex fog. Set to true to enable range-based vertex fog, or false to use depth-based fog. The default value is false.

In range-based fog, the distance of an object from the viewer is used to compute fog effects, not the depth of the object (that is, the z-coordinate) in the scene. All fog methods work as usual, except that they use range instead of depth in the computations. See Fog.

Range is the correct factor to use for fog computations, but depth is commonly used instead because it is generally already available, and range is resource-intensive to compute. Using depth to calculate fog has the undesirable effect of making the fogginess of peripheral objects change as the viewer's eye moves; in this case, the depth changes and the range remains constant. Because no hardware currently supports per-pixel range-based fog, range correction is offered only for Vertex Fog.
FogDensity | 38 | Fog density for pixel or vertex fog used in exponential fog modes. Valid fog density values range from 0.0 through 1.0. The default value is 1.0. See Fog.
FogEnd 37 The depth at which pixel or vertex fog effects end for linear fog mode. The default value is 1.0f.

Depth is specified in world space for vertex fog, and in either device space [0.0, 1.0] or world space for pixel fog. For pixel fog, these values are in device space when the system uses z for fog calculations, or in world space when the system uses eye-relative fog (w-fog). See Fog.
FogStart 36 The depth at which pixel or vertex fog effects begin for linear fog mode. The default value is 0.0f.

Depth is specified in world space for vertex fog, and in either device space [0.0, 1.0] or world space for pixel fog. For pixel fog, these values are in device space when the system uses z for fog calculations, or in world space when the system uses eye-relative fog (w-fog). See Fog.
FogTableMode | 35 | The fog formula to use for pixel fog. Valid values are from the FogMode enumeration. The default fog mode is FogMode.None. See Fog.
SpecularEnable 29 Enables or disables specular highlights. Set to true to enable specular highlights, or false to disable them. The default value is false.

Specular highlights are calculated as though every vertex in the object being lit is at the object's origin. This gives the expected results as long as the object is modeled around the origin and the distance from the light to the object is relatively large. In other cases, the results are undefined.

When this state is set to true, the specular color is added to the base color after the texture cascade but before alpha blending.
FogEnable | 28 | Enables or disables fog blending. Set to true to enable fog blending, or false to disable it. The default value is false. See Fog.
AlphaBlendEnable 27 Set to true to enable alpha-blended transparency, or false to disable it.

The default value is false. The type of alpha blending is determined by the SourceBlend and DestinationBlend render states.
DitherEnable | 26 | Enables or disables dither. Set to true to enable dithering, or false to disable it. The default value is false.
AlphaFunction 25 A member of the Compare enumeration that represents the alpha comparison function.

The default value is Compare.Always.

The AlphaFunction member enables an application to accept or reject a pixel based on its alpha value.
ReferenceAlpha | 24 | Specifies a reference alpha value against which pixels are tested when alpha testing is enabled. The default value is 0. Values can range from 0x00000000 to 0x000000FF.
ZBufferFunction 23 Specifies the comparison function for the z-buffer test. Valid values are members of the Compare enumeration.

The depth value of the pixel is compared to the depth-buffer value. If the depth value of the pixel passes the comparison function, the pixel is written.
CullMode | 22 | Specifies how back-facing triangles are culled, if at all. Set to a member of the Cull enumeration that specifies the culling mode. The default value is Cull.CounterClockwise.
DestinationBlend | 20 | Contains a member of the Blend enumeration that represents the destination . The default value is Blend.Zero.
SourceBlend | 19 | Contains a member of the Blend enumeration that represents the source . The default value is Blend.One.
LastPixel | 16 | Enables or disables drawing of the last pixel in a line. Set to true to enable drawing of the last pixel in a line, or false to prevent it. The default value is true.
AlphaTestEnable 15 Enables a per-pixel alpha test. Set to true to enable per-pixel alpha testing, or false to disable it.

If the test passes, the pixel is processed by the frame buffer. Otherwise, all frame-buffer processing is skipped for the pixel.

The test is done by comparing the incoming alpha value with the reference alpha value, using the comparison function provided by AlphaFunction. The reference alpha value is determined by the value set for ReferenceAlpha.

The default value is false.
ZBufferWriteEnable 14 Set to true to enable writing to the depth buffer, or false to disable it.

The default value is true.

This member enables an application to prevent the system from updating the depth buffer with new depth values.

If false, depth comparisons are still made according to the render state ZBufferFunction, assuming that depth buffering is taking place, but depth values are not written to the buffer.
BlendOperationAlpha 209 Value used to select the arithmetic operation applied to separate alpha blend when the render state, SeparateAlphaBlendEnabled, is set to true.

Valid values are defined by the BlendOperation enumeration. The default value is BlendOperation.Add.

If the MiscCaps.SupportsBlendOperation device capability is not supported, BlendOperation.Add is performed.
DestinationBlendAlpha 208 A member of the Blend enumeration that represents the destination .

This value is ignored unless SeparateAlphaBlendEnabled is true.

The default value is Blend.Zero.
SourceBlendAlpha 207 A member of the Blend enumeration that represents the source .

This value is ignored unless SeparateAlphaBlendEnabled is true.

The default value is Blend.One.
SeparateAlphaBlendEnable 206 Enables or disables the separate for the alpha channel. Set to true to enable separate alpha blend, or false disable it. The default value is false.

When set to false, the render target blending factors and operations applied to alpha are forced to be the same as those defined for color. This mode is effectively hardwired to false on implementations that do not set MiscCaps.SupportsSeparateAlphaBlend.

The type of separate alpha blending is determined by SourceBlendAlpha and DestinationBlendAlpha.
DepthBias 195 Sets or retrieves the depth bias for polygons.

The DepthBias value is an integer in the range of 0 through 16 which causes polygons that are physically coplanar to appear separate. Polygons with a high z-bias value appear in front of polygons with a low value, without requiring sorting for drawing order. For example, polygons with a value of 1 appear in front of polygons with a value of 0.
SrgbWriteEnable | 194 | Enables render-target writes to be gamma corrected to sRGB. Set to true to enable sRGB writes, or false to disable them. The default value is false.
BlendFactor 193 A Color Leave Site object used for a constant blend factor during alpha blending.

BlendFactor member is available if BlendCaps.SupportsBlendFactor is set in Caps.SourceBlendCaps or Caps.DestinationBlendCaps for the device.
ColorWriteEnable3 192 Additional ColorWriteEnable values for a device. See ColorWriteEnable.

ColorWriteEnable3 is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.
ColorWriteEnable2 191 Additional ColorWriteEnable values for a device. See ColorWriteEnable.

ColorWriteEnable2 is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.
ColorWriteEnable1 190 Additional ColorWriteEnable values for a device. See ColorWriteEnable.

ColorWriteEnable1 is available if MiscCaps.SupportsIndependentWriteMasks is set in Caps.PrimitiveMiscCaps for the device.
CounterClockwiseStencilFunction 189 The comparison function used by the counterclockwise (CCW) stencil test. Valid values are from the Compare enumeration.

The test passes if ((ref & mask) stencil_compare_function (stencil & mask)) == true.
CounterClockwiseStencilPass | 188 | The StencilOperation to perform if both counterclockwise (CCW) stencil and z-tests pass. Valid values are from the StencilOperation enumeration. The default value is StencilOperation.Keep.
CounterClockwiseStencilZBufferFail | 187 | The StencilOperation to perform if the counterclockwise (CCW) stencil test passes and the z-test fails. Valid values are from the StencilOperation enumeration. The default value is StencilOperation.Keep.
CounterClockwiseStencilFail | 186 | The StencilOperation to perform if the counterclockwise (CCW) stencil test fails. Valid values are from the StencilOperation enumeration. The default value is StencilOperation.Keep.
TwoSidedStencilMode 185 Enables or disables two-sided stenciling. Set to true to enable two-sided stenciling, or false to disable it.

The application should set CullMode to Cull.None to enable two-sided stencil mode. If the triangle winding order is clockwise, the Stencil* operations are used. If the winding order is counterclockwise, the CounterClockwiseStencil* operations are used. See StencilOperation
EnableAdaptiveTessellation | 184 | Enables or disables adaptive tessellation. Set to true to enable adaptive tessellation, or false to disable it. The default value is false.
AdaptiveTessellateW | 183 | Amount to adaptively tessellate in the w direction. The default value is 0.0f.
AdaptiveTessellateZ | 182 | Amount to adaptively tessellate in the z direction. The default value is 1.0f.
AdaptiveTessellateY | 181 | Amount to adaptively tessellate in the y direction. The default value is 0.0f.
AdaptiveTessellateX | 180 | Amount to adaptively tessellate in the x direction. The default value is 0.0f.
MaxTessellationLevel | 179 | The maximum tessellation level. The default value is 1.0f.
MinTessellationLevel | 178 | The minimum tessellation level. The default value is 1.0f.
AntialiasedLineEnable 176 Set to true to enable antialiasing of lines, or false to disable it. The default value is false.

The AntialiasedLineEnable member applies to triangles drawn in wireframe mode as well as line-drawing primitive types.

When rendering to a multisample render target, this render state is ignored, and all lines are rendered aliased. For antialiased line rendering in multisample render targets, use a Line object, which generates textured polygons.
SlopeScaleDepthBias 175 Used to determine how much bias can be applied to coplanar primitives to reduce z-fighting. The default value is 0.

bias = (max * SlopeScaleDepthBias) + DepthBias

where max is the maximum depth slope of the triangle being rendered. See Depth Buffers.
ScissorTestEnable | 174 | Enables or disables scissor testing. Set to true to enable scissor testing, or false to disable it. The default value is false.
NormalDegree | 173 | The degree of interpolation (linear, cubic, quadratic, or quintic) using the N-patch normal. Valid values are from the DegreeType enumeration. The default render state is DegreeType.Linear.
PositionDegree 172 The N-patch position interpolation degree. Valid values are from the DegreeType enumeration that specifies the degree. The default value is DegreeType.Cubic.

The DegreeType.Linear value also can be used.
BlendOperation 171 A value used to select the arithmetic operation to apply when the alpha blend render state, AlphaBlendEnable is set to true.

Valid values are defined by the BlendOperation enumeration. The default value is BlendOperation.Add.

If the MiscCaps.SupportsBlendOperation device capability is not supported, BlendOperation.Add is performed.
TweenFactor | 170 | Specifies a floating-point value that controls the tween factor. The default value is 0.0f.
ColorWriteEnable | 168 | Enables a per-channel write for the render target color buffer. Valid values for this render state can be any combination of ColorWriteEnable enumeration members.
IndexedVertexBlendEnable 167 Enables or disables indexed vertex blending. Set to true to enable indexed vertex blending, or false to disable it. The default value is false.

When indexed vertex blending is disabled and vertex blending is enabled through VertexBlend, it is equivalent to having matrix indices 0, 1, 2, and 3 in every vertex. If indexed vertex blending is enabled (set to true), the user must pass matrix indices with every vertex.
PointSizeMax | 166 | Specifies the maximum size to which point sprites can be set. The default value is 64.0f. The value must be less than or equal to Caps.MaxPointSize and greater than or equal to PointSizeMin.
DebugMonitorToken 165 Enables or disables the debug monitor token. Set to true to enable the debug monitor, or false to disable it. Should be set only for debugging the monitor and is useful for debug builds only.

The default value for the debug monitor is true.
PatchEdgeStyle 163 The tessellation mode for patch edges. Valid value are from the PatchEdge enumeration. The default render state is PatchEdge.Discrete.

Using the PatchEdge.Continuous tessellation mode helps reduce rendering artifacts.
MultisampleMask 162 Enables use of a multisample buffer as an accumulation buffer. The default value is 0xFFFFFFFF.

This render state allows multipass rendering of geometry, in which each pass updates a subset of samples. The state has no effect when rendering to a single sample buffer.

Each bit in the MultisampleMask, starting at the least significant bit (LSB), controls modification of one of the samples in a multisample render target. Thus, for an 8-sample render target, the low byte contains the eight write enables for each of the eight samples. This property enables use of a multisample buffer as an accumulation buffer. If there are n multisamples and k enabled samples, the resulting intensity of the rendered image should be k/n. Each component RGB of every pixel is factored by k/n. See MultiSampleType
MultisampleAntiAlias 161 Determines how individual samples are computed when using a multisample render target buffer.

When set to true, the multiple samples are computed so that full-scene antialiasing is performed by sampling at different sample positions for each multiple sample.

When set to false, the multiple samples are all written with the same sample value, sampled at the pixel center, which allows non-antialiased rendering to a multisample buffer. The default value is true. This render state has no effect when rendering to a single sample buffer.
PointScaleC 160 Controls the distance-based size attenuation for point primitives. The default value is 1.0f.

This render state is active only when PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.
PointScaleB 159 Controls the distance-based size attenuation for point primitives. The default value is 1.0f.

This render state is active only when PointScaleEnable is set to true. The range for this value is greater than or equal to 0.0f.
ClipPlaneEnable 152 Enables or disables user-defined clipping planes. Valid values are any DWORD in which the status of each bit (set or not set) toggles the activation state of a corresponding user-defined clipping plane. The default value is 0.

The least significant bit (bit 0) controls the first clipping plane at index 0, and subsequent bits control the activation of clipping planes at higher indexes. If a bit is set, the system applies the appropriate clipping plane during scene rendering.
VertexBlend | 151 | Specifies the number of matrices to use to perform geometry blending. Valid values are members of the VertexBlend enumeration. The default value is VertexBlend.Disable.
FogColor | 34 | Retrieves or sets the fog color as a Color Leave Site object.
ShadeMode | 9 | Specifies the shade mode to use for rendering. Valid values are from the ShadeMode enumeration. The default value is ShadeMode.Gouraud.
ZEnable | 7 | Enables or disables depth buffering. Set to true to enable depth buffering, or false to disable it. The default value is true.
PointSize 154 Specifies the size to use for point size computation in cases in which point size is not specified for each vertex. The default value is 1.0f.

This value is not used when the vertex contains a point size. The value is defined in screen space units if PointScaleEnable is set to false; otherwise, it is defined in world space units. The range for the value is greater than or equal to 0.0f.
FillMode | 8 | A value from the FillMode enumeration that represents the fill mode to apply. The default value is FillMode.Solid.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • RenderStateManager

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


RenderTargetsMax Enumeration (Microsoft.DirectX.Direct3D)

RenderTargetsMax Enumeration

Defines the maximum number of simultaneous render targets supported.

Definition

Visual Basic | Public Enum RenderTargetsMax
C# | public enum RenderTargetsMax
C++ | public enum class RenderTargetsMax
JScript | public enum RenderTargetsMax

Members

Member | Value | Description
Simultaneous | 4 | Allows four simultaneous render targets.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ResourceType Enumeration (Microsoft.DirectX.Direct3D)

ResourceType Enumeration

Defines resource types.

Definition

Visual Basic | Public Enum ResourceType
C# | public enum ResourceType
C++ | public enum class ResourceType
JScript | public enum ResourceType

Members

Member | Value | Description
IndexBuffer | 7 | Index buffer resource.
VertexBuffer | 6 | Vertex buffer resource.
CubeTexture | 5 | Cube texture resource.
VolumeTexture | 4 | Volume texture resource.
Volume | 2 | Volume resource.
Surface | 1 | Surface resource.
Textures | 3 | Texture resource.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Resource Properties


ResultCode Enumeration (Microsoft.DirectX.Direct3D)

ResultCode Enumeration

Defines result codes.

Definition

Visual Basic | Public Enum ResultCode
C# | public enum ResultCode
C++ | public enum class ResultCode
JScript | public enum ResultCode

Members

Member | Value | Description
InvalidCall | -2005530516 | Method call is invalid; for example, a method's parameter might not be a valid pointer.
InvalidDevice | -2005530517 | Requested device type is not valid.
NotAvailable | -2005530518 | Device does not support the queried technique.
DeviceNotReset | -2005530519 | Device has been lost but can be reset at this time.
DeviceLost | -2005530520 | Device has been lost but cannot be reset at this time. Therefore, rendering is not possible.
UnsupportedTextureFilter | -2005530590 | Device does not support the specified texture filter.
UnsupportedFactorValue | -2005530593 | Device does not support the specified texture factor value.
ConflictingTextureFilter | -2005530594 | Current texture filters cannot be used together.
TooManyOperations | -2005530595 | Application is requesting more texture-filtering operations than the device supports.
UnsupportedAlphaArgument | -2005530596 | Device does not support a specified texture-blending argument for the alpha channel.
UnsupportedAlphaOperation | -2005530597 | Device does not support a specified texture-blending operation for the alpha channel.
UnsupportedColorArgument | -2005530598 | Device does not support a specified texture-blending argument for color values.
UnsupportedColorOperation | -2005530599 | Device does not support a specified texture-blending operation for color values.
WrongTextureFormat | -2005530600 | Pixel format of the texture surface is not valid.
Success | 0 | Operation was successful.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SamplerStageStates Enumeration (Microsoft.DirectX.Direct3D)

SamplerStageStates Enumeration

Defines the sampler state types.

Definition

Visual Basic | Public Enum SamplerStageStates
C# | public enum SamplerStageStates
C++ | public enum class SamplerStageStates
JScript | public enum SamplerStageStates

Members

Member | Value | Description
DMapOffset | 13 | Vertex offset in the presampled displacement map. This is a constant used by the tessellator, its default value is zero.
ElementIndex | 12 | Element index to use when an element with multiple textures is assigned to the sampler.
SrgbTexture | 11 | Determines whether to use gamma correction. Set to true to enable gamma correction. The default value is false.
MaxMipLevel | 9 | The level of detail (LOD) index of the largest map to use. Index values range from 0 to (n-1) where 0 is the largest map. The default value is zero.
MipMapLevelOfDetailBias | 8 | Mipmap LOD bias. The default value is zero.
BorderColor | 4 | Border color represented as a member of the Color Leave Site structure.
AddressW | 3 | Texture-address mode for the w coordinate. The default value is TextureAddress.Wrap. See TextureAddress.
AddressV | 2 | Texture-address mode for the v coordinate. The default value is TextureAddress.Wrap. See TextureAddress.
AddressU | 1 | Texture-address mode for the u coordinate. The default value is TextureAddress.Wrap. See TextureAddress.
MinFilter | 6 | Minification filter. The default value is TextureFilter.None. See TextureFilter.
MagFilter | 5 | Magnification filter. The default value is TextureFilter.None. See TextureFilter.
MaxAnisotropy | 10 | Maximum anisotropy value. The default value is zero.
MipFilter | 7 | Mipmap filter to use during minification. The default value is TextureFilter.None. See TextureFilter.

Remarks

These enumeration constants and values are used by the Device.SetSamplerState method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • SamplerStateManager

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ShadeMode Enumeration (Microsoft.DirectX.Direct3D)

ShadeMode Enumeration

Defines constants that describe the supported shading modes.

Definition

Visual Basic | Public Enum ShadeMode
C# | public enum ShadeMode
C++ | public enum class ShadeMode
JScript | public enum ShadeMode

Members

Member | Value | Description
Phong | 3 | Not supported.
Gouraud | 2 | Gouraud shading mode. The color and specular components of the face are determined by a linear interpolation between all three of the triangle's vertices.
Flat | 1 | Flat shading mode. The color and specular component of the first vertex in the triangle are used to determine the color and specular component of the face. These colors remain constant across the triangle; that is, they are not interpolated. The specular alpha is interpolated.

Remarks

The first vertex of a triangle for flat shading mode is defined in the following manner.

  • For a Triangle Lists, the first vertex of the triangle i is i * 3.
  • For a Triangle Strips, the first vertex of the triangle i is vertex i.
  • For a Triangle Fans, the first vertex of the triangle i is vertex i + 1.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderFlags Enumeration (Microsoft.DirectX.Direct3D)

ShaderFlags Enumeration

Defines the compiler options to use during a shader compilation.

Definition

Visual Basic | Public Enum ShaderFlags
C# | public enum ShaderFlags
C++ | public enum class ShaderFlags
JScript | public enum ShaderFlags

Members

Member | Value | Description
Debug | 1 | Inserts debug file name and line number information during compilation.
None | 0 | Instructs the compiler to use no options during compilation. Value resolves to 0.
NotCloneable | 2048 | Instructs the effect runtime that the effect will never be cloned (i.e. by using the Effect.Clone method). This reduces the memory usage for the effect by eliminating the need to keep a copy of the effect's shaders in memory.
PreferFlowControl | 1024 | Instructs the compiler to prefer using flow-control instructions.
AvoidFlowControl | 512 | Instructs the compiler to avoid using flow-control instructions.
NoPreShader | 256 | Disables preshaders; that is, the compiler will not pull out static expressions for evaluation on the host CPU.
ForcePixelShaderSoftwareNoOptimizations | 128 | Instructs the compiler to use software pixel shaders.
ForceVertexShaderSoftwareNoOptimizations | 64 | Instructs the compiler to use software vertex shaders.
PartialPrecision | 32 | Indicates to the device that the operation can be performed and the result stored at a lower precision (at least s10e5).
PackMatrixColumnMajor | 16 | Instructs the compiler to pack matrices in column major order (that is, each vector in a single column).
PackMatrixRowMajor | 8 | Instructs the compiler to pack matrices in row major order (that is, each vector in a single row).
SkipOptimization | 4 | Instructs the compiler to skip optimization steps during code generation. This option is valid only when calling ShaderLoader.CompileShader; it is not recommended unless you are trying to isolate a code problem that you suspect originates in the compiler.
SkipValidation | 2 | Prevents the compiler from validating the generated code against known capabilities and constraints. This option is recommended only when compiling shaders that are known to work (that is, those that have compiled before without this option). Shaders are always validated before they are set to the device.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SpriteFlags Enumeration (Microsoft.DirectX.Direct3D)

SpriteFlags Enumeration

Defines flags used to specify sprite rendering options.

Definition

Visual Basic | Public Enum SpriteFlags
C# | public enum SpriteFlags
C++ | public enum class SpriteFlags
JScript | public enum SpriteFlags

Members

Member | Value | Description
AlphaBlend | 16 | Enables alpha blending with RenderStateManager.AlphaTestEnable set to true (for nonzero alpha). SourceAlpha is the source blend state, and InvSourceAlpha is the destination blend state in calls to RenderStateManager. The Font class requires this flag to be set when drawing text.
SortDepthBackToFront | 128 | Sorts sprites by depth in back-to-front order prior to drawing. This option is recommended when drawing transparent sprites of varying depths. You may combine SortDepthBackToFront with SortTexture to sort first by depth, and second by texture.
SortDepthFrontToBack | 64 | Sorts sprites by depth in front-to-back order prior to drawing. This option is recommended when drawing opaque sprites of varying depths. You may combine SortDepthFrontToBack with SortTexture to sort first by depth, and second by texture.
SortTexture | 32 | Sorts sprites by texture prior to drawing. This option is recommended when drawing non-overlapping sprites of uniform depth; for example, drawing screen-aligned text with Font. You may also combine SortTexture with either SortDepthFrontToBack or SortDepthBackToFront. This will sort the list of sprites by depth first and texture second.
Billboard | 8 | Rotates each sprite around its center so that it is facing the viewer. Sprite.SetWorldViewLH or Sprite.SetWorldViewRH must be called first.
ObjectSpace | 4 | Specifies no modification of the world, view, and projection transforms. The transforms currently set to the device are used to transform sprites when the batched sprites are drawn (that is, when Sprite.Flush or Sprite.End is called). If this option is not specified, the world, view, and projection transforms are modified so that sprites are drawn in screen-space coordinates.
DoNotModifyRenderState | 2 | Specifies no changes to the device render state when Sprite.Begin is called. The device is assumed to be in a valid state to draw vertices when the VertexElement.UsageIndex property equals 0 and VertexElement.DeclarationUsage is set to DeclarationUsage.Position, DeclarationUsage.TextureCoordinate, or DeclarationUsage.Color.
DoNotSaveState | 1 | Prevents the device state from being saved or restored when Sprite.Begin or Sprite.End is called.
None | 0 | Resolves the value to 0.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StateBlockType Enumeration (Microsoft.DirectX.Direct3D)

StateBlockType Enumeration

Defines logical groups of device states.

Definition

Visual Basic | Public Enum StateBlockType
C# | public enum StateBlockType
C++ | public enum class StateBlockType
JScript | public enum StateBlockType

Members

Member | Value | Description
VertexState | 3 | Captures all of the current lights, the current vertex shader and its constants, and the texture stage states specified by TextureCoordinateIndex and TextureTransform.
PixelState | 2 | Captures the current pixel shader and its constants.
All | 1 | Captures all device states.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StencilOperation Enumeration (Microsoft.DirectX.Direct3D)

StencilOperation Enumeration

Defines the supported stencil operations.

Definition

Visual Basic | Public Enum StencilOperation
C# | public enum StencilOperation
C++ | public enum class StencilOperation
JScript | public enum StencilOperation

Members

Member | Value | Description
Zero | 2 | Sets the stencil-buffer entry to 0.
Decrement | 8 | Decrements the stencil-buffer entry, wrapping to the maximum value if the new value is less than 0.
Increment | 7 | Increments the stencil-buffer entry, wrapping to 0 if the new value exceeds the maximum value.
Invert | 6 | Inverts the bits in the stencil-buffer entry.
DecrementSaturation | 5 | Decrements the stencil-buffer entry, clamping to 0.
IncrementSaturation | 4 | Increments the stencil-buffer entry, clamping to the maximum value.
Keep | 1 | Does not update the stencil-buffer entry. This is the default value.
Replace | 3 | Replaces the stencil-buffer entry with a reference value.

Remarks

Stencil buffer entries are integer values that range from 0 to 2n - 1, where n is the bit depth of the stencil buffer.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SwapEffect Enumeration (Microsoft.DirectX.Direct3D)

SwapEffect Enumeration

Defines swap effects.

Definition

Visual Basic | Public Enum SwapEffect
C# | public enum SwapEffect
C++ | public enum class SwapEffect
JScript | public enum SwapEffect

Members

Member Value Description
Discard 1 When a swap chain is created with a swap effect of Flip or Copy, the runtime guarantees that a Present operation will not affect the content of any of the back buffers. However, meeting this guarantee can involve substantial video memory or processing overheads, especially when implementing flip semantics for a windowed swap chain or copy semantics for a full-screen swap chain.

An application can use the Discard swap effect to avoid these overheads and to enable the display driver to choose the most efficient presentation technique for the swap chain.

Discard is also the only swap effect that can be used when specifying a value other than None for PresentParameters.MultiSampleType. Like a swap chain that uses Flip, a swap chain that uses Discard might include more than one back buffer, any of which can be accessed using Device.GetBackBuffer or SwapChain.GetBackBuffer.

The swap chain is essentially a queue where 0 always indexes the back buffer that will be displayed by the next Present operation and from which buffers are discarded once they have been displayed. An application that uses this swap effect should update an entire back buffer before invoking a Present operation that displays it.

The debug version of the runtime overwrites the contents of discarded back buffers with random data, to enable developers to verify that their applications are updating the entire back buffer surface correctly.

For a full-screen swap chain, the presentation rate is determined by the value assigned to PresentParameters.PresentationInterval when the device or swap chain is created. Unless this value is Immediate, the presentation is synchronized with the vertical sync of the monitor. For a windowed swap chain, the presentation is implemented by means of copy operations, and always occurs immediately.
Copy 3 This swap effect can be specified only for a swap chain that comprises a single back buffer.

Whether the swap chain is windowed or full-screen, the runtime guarantees the semantics implied by a copy-based Present operation; specifically, that the operation leaves the content of the back buffer unchanged, instead of replacing it with the content of the front buffer as a flip-based Present operation would.

For a windowed swap chain, a Present operation causes the back buffer content to be copied immediately to the client area of the target window. No attempt is made to synchronize the copy with the vertical retrace period of the display adapter, so tearing effects may be observed.

For a full-screen swap chain, the runtime uses a combination of flip and copy operations, which are supported by hidden back buffers if necessary, to accomplish the Present operation. Accordingly, the presentation is synchronized with the display adapter's vertical retrace and its rate is constrained by the chosen presentation interval. A swap chain specified with the Immediate flag is the only exception. (For more information, see PresentParameters.PresentationInterval.) In this case, a Present operation copies the back buffer content directly to the front buffer without waiting for the vertical retrace.
Flip 2 The swap chain might include multiple back buffers and is essentially a circular queue that includes the front buffer. Within this queue, the back buffers are always numbered sequentially from 0 to (n - 1), where n is the number of back buffers, so that 0 denotes the least recently presented buffer.

When Present is invoked, the queue is rotated so that the front buffer becomes the back buffer (n - 1), while the back buffer 0 becomes the new front buffer.

For a full-screen swap chain, the presentation rate is determined by the value assigned to the PresentParameters.PresentationInterval when the device or swap chain is created. Unless this value is Immediate, the presentation is synchronized with the vertical sync of the monitor.

For a windowed swap chain, the flipping is implemented by means of copy operations, and the presentation always occurs immediately.

Remarks

The state of the back buffer after a call to Present is well-defined by each of these swap effects, and whether the Microsoft Direct3D device was created with a full-screen swap chain or a windowed swap chain has no effect on this state. In particular, the Flip swap effect operates the same whether windowed or full-screen, and the Direct3D runtime guarantees this by creating extra buffers. As a result, it is recommended that applications use Discard whenever possible to avoid any performance penalties, because the current swap effect is always the most efficient in terms of memory consumption and performance.

Full-screen destination alpha will not work with applications that use Flip or Discard. This means that the DestinationBlend render state will not work as expected because, from the driver's point of view, full-screen swap chains with these swap effects do not have an explicit pixel format. The driver infers that it should take on the display format, which does not have an alpha channel. To work around this, use Copy and check the DriverCaps.SupportsAlphaFullscreenFlipOrDiscard property, which indicates whether the driver can perform alpha blending when Flip or Discard are used.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Reset


TangentOptions Enumeration (Microsoft.DirectX.Direct3D)

TangentOptions Enumeration

Defines settings used for mesh tangent frame computations.

Definition

Visual Basic | Public Enum TangentOptions
C# | public enum TangentOptions
C++ | public enum class TangentOptions
JScript | public enum TangentOptions

Members

Member | Value | Description
GenerateInPlace | 1024 | The results are stored in the original input mesh, and the output mesh is not used.
CalculateNormals | 512 | Compute the per-vertex normal vector for each triangle of the input mesh, and ignore any normal vectors already in the input mesh.
WindClockwise | 256 | Vertices are ordered in a clockwise direction around each triangle. The computed normal vector direction is therefore inverted 180 degrees from the direction computed using counterclockwise vertex ordering.
WeightEqual | 128 | Compute a unit-length normal vector for each triangle of the input mesh. Mutually exclusive with WeightByArea.
WeightByArea | 64 | Weight the direction of the computed per-vertex normal or partial derivative vector according to the areas of triangles attached to that vertex. Mutually exclusive with WeightEqual.
OrthogonalizeFromU | 32 | Compute the partial derivative with respect to texture coordinate u independently for each vertex, and then compute the partial derivative with respect to v as the cross product of the normal vector and the partial derivative with respect to u. Mutually exclusive with DontOrthogonalize and OrthogonalizeFromV.
OrthogonalizeFromV | 16 | Compute the partial derivative with respect to texture coordinate v independently for each vertex, and then compute the partial derivative with respect to u as the cross product of the partial derivative with respect to v and the normal vector. Mutually exclusive with DontOrthogonalize and OrthogonalizeFromU.
DontOrthogonalize | 8 | Transform texture coordinates to orthogonal Cartesian coordinates. Mutually exclusive with OrthogonalizeFromU and OrthogonalizeFromV.
DontNormalizePartials | 4 | Do not normalize partial derivatives with respect to texture coordinates. If not normalized, the scale of the partial derivatives is proportional to the scale of the 3-D model divided by the scale of the triangle in (u, v) space. This scale value provides a measure of how much the texture is stretched in a given direction. The resulting vector length is a weighted sum of the lengths of the partial derivatives.
WrapUV | 3 | Texture coordinate values in both u and v directions are between 0 and 1. In this case a texture coordinate set will be chosen that minimizes the perimeter of the triangle.
WrapV | 2 | Texture coordinate values in the v direction are between 0 and 1. In this case a texture coordinate set will be chosen that minimizes the perimeter of the triangle.
WrapU | 1 | Texture coordinate values in the u direction are between 0 and 1. In this case a texture coordinate set will be chosen that minimizes the perimeter of the triangle.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureAddress Enumeration (Microsoft.DirectX.Direct3D)

TextureAddress Enumeration

Defines constants that describe the supported texture-addressing modes.

Definition

Visual Basic | Public Enum TextureAddress
C# | public enum TextureAddress
C++ | public enum class TextureAddress
JScript | public enum TextureAddress

Members

Member | Value | Description
MirrorOnce | 5 | Similar to Mirror and Clamp. Takes the absolute value of the texture coordinate (thus, mirroring around 0), and then clamps to the maximum value. The most common usage is for volume textures, where support for the full MirrorOnce texture-addressing mode is not necessary, but the data is symmetrical around the one axis.
Border | 4 | Texture coordinates outside the range [0.0, 1.0] are set to the border color.
Clamp | 3 | Texture coordinates outside the range [0.0, 1.0] are set to the texture color at 0.0 or 1.0, respectively.
Mirror | 2 | Similar to Wrap, except that the texture is flipped at every integer junction. For u values between 0 and 1, for example, the texture is addressed normally; between 1 and 2, the texture is flipped (mirrored); between 2 and 3, the texture is normal again, and so on.
Wrap | 1 | Tiles the texture at every integer junction. For example, for u values between 0 and 3, the texture is repeated three times. No mirroring is performed.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • SamplerStateManagerCollection


TextureArgument Enumeration (Microsoft.DirectX.Direct3D)

TextureArgument Enumeration

Defines the supported texture arguments.

Definition

Visual Basic | Public Enum TextureArgument
C# | public enum TextureArgument
C++ | public enum class TextureArgument
JScript | public enum TextureArgument

Members

Member | Value | Description
Constant | 6 | Select a constant from a texture stage.
AlphaReplicate | 32 | Replicate the alpha value to the color components. During sampling, AlphaReplicate acts as a read modifier.
Complement | 16 | Take the complement, or 1.0 - x. This is a read modifier.
Temp | 5 | Specifies a temporary register color for read or write. Temp is supported if the SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0). Permissions are read/write.
TFactor | 3 | Specifies the texture factor set in the RenderStateManager.TextureFactor property. Permissions are read-only.
TextureColor | 2 | Contains the texture color for the current texture stage. Permissions are read-only.
SelectMask | 15 | Mask value for all arguments; not used when setting texture arguments.
Specular | 4 | Specifies the specular color interpolated from vertex components during Gouraud shading. If the vertex does not contain a specular color, the default color is 0xFFFFFFFF. Permissions are read-only.
Current | 1 | Gets the current element in the collection.
Diffuse | 0 | Specifies the diffuse color interpolated from vertex components during Gouraud shading. If the vertex does not contain a diffuse color, the default color is 0xFFFFFFFF. Permissions are read-only.

Remarks

This enumeration is used by the ColorArgument0, ColorArgument1, ColorArgument2, AlphaArgument0, AlphaArgument1, AlphaArgument2, and ResultArgument members of the TextureStateManager class.

Use the TextureState property to set and retrieve texture arguments.

An argument flag can be combined with a modifier, but two argument flags cannot be combined.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureCoordinateIndex Enumeration (Microsoft.DirectX.Direct3D)

TextureCoordinateIndex Enumeration

Defines the supported texture coordinate index values.

Definition

Visual Basic | Public Enum TextureCoordinateIndex
C# | public enum TextureCoordinateIndex
C++ | public enum class TextureCoordinateIndex
JScript | public enum TextureCoordinateIndex

Members

Member | Value | Description
SphereMap | 262144 | Uses the specified texture coordinates for sphere mapping.
CameraSpaceReflectionVector | 196608 | Uses the reflection vector, transformed to camera space, as the input texture coordinate for the current stage's texture transformation. The reflection vector is computed from the input vertex position and normal vector.
CameraSpacePosition | 131072 | Uses the vertex position, transformed to camera space, as the input texture coordinates for the current stage's texture transformation.
CameraSpaceNormal | 65536 | Uses the vertex normal, transformed to camera space, as the input texture coordinates for the current stage's texture transformation.
PassThru | 0 | Uses the specified texture coordinates contained in the vertex format. This value resolves to 0.

Remarks

This enumeration is used by the TextureStateManager.TextureCoordinateIndex property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureFilter Enumeration (Microsoft.DirectX.Direct3D)

TextureFilter Enumeration

Defines texture filtering modes for a texture stage.

Definition

Visual Basic | Public Enum TextureFilter
C# | public enum TextureFilter
C++ | public enum class TextureFilter
JScript | public enum TextureFilter

Members

Member | Value | Description
GaussianQuad | 7 | A 4-sample Gaussian filter used as a texture magnification or minification filter.
PyramidalQuad | 6 | A 4-sample tent filter used as a texture magnification or minification filter.
Anisotropic | 3 | Anisotropic texture filtering used as a texture magnification or minification filter. This type of filtering compensates for distortion caused by the difference in angle between the texture polygon and the plane of the screen.
Linear | 2 | Bilinear interpolation filtering used as a texture magnification or minification filter. A weighted average of a 2x2 area of texels surrounding the desired pixel is used. The texture filter used between mipmap levels is trilinear mipmap interpolation, in which the rasterizer performs linear interpolation on pixel color, using the texels of the two nearest mipmap textures.
Point | 1 | Point filtering used as a texture magnification or minification filter. The texel with coordinates nearest to the desired pixel value is used. The texture filter used between mipmap levels is based on the nearest point; that is, the rasterizer uses the color from the texel of the nearest mipmap texture.
None | 0 | Mipmapping disabled. The rasterizer uses the magnification filter instead.

Remarks

To determine whether a format supports texture filter types other than Point (which is always supported), call Manager.CheckDeviceFormat with QueryFilter.

The following C# example shows how to set a texture stage's magnification filter by setting the SamplerStateManager.MagFilter property to a member of this enumeration.

              [C#]

     ...
       device.SamplerState[0].MagFilter = TextureFilter.Linear;
     ...

The following C# code example shows how to set a texture stage's minification filter by setting the SamplerStateManager.MinFilter property to a member of this enumeration.

              [C#]

     ...
       device.SamplerState[0].MinFilter = TextureFilter.Linear;
     ...

The following C# code example shows how to set the texture filter to use between mipmap levels by setting the SamplerStateManager.MipFilter property to a member of this enumeration.

              [C#]

     ...
       device.SamplerState[0].MipFilter = TextureFilter.Linear;
     ...

Not all valid filtering modes for a device apply to volume maps. In general, Point and Linear magnification filters are supported for volume maps. If the TextureCaps.SupportsMipVolumeMap property is set to true (the TextureCaps can be found in the Caps.TextureCaps property), the Point mipmap filter and the Point and Linear minification filters are supported for volume maps. The device might or might not support the Linear mipmap filter for volume maps. Devices that support anisotropic filtering for 2-D maps do not necessarily support it for volume maps. However, applications that enable anisotropic filtering, even if they do not support it, receive the best available filtering (probably linear).

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureOperation Enumeration (Microsoft.DirectX.Direct3D)

TextureOperation Enumeration

Defines per-stage texture-blending operations.

Definition

Visual Basic | Public Enum TextureOperation
C# | public enum TextureOperation
C++ | public enum class TextureOperation
JScript | public enum TextureOperation

Members

Member | Value | Description
Subtract 10 Subtracts the components of the second argument from those of the first argument.

SRGBA = Arg1 - Arg2
Lerp 26 Performs linear interpolation between the second and third source arguments by a proportion specified in the first source argument.

SRGBA = (Arg1) * Arg2 + (1- Arg1) * Arg3.
MultiplyAdd 25 Performs a multiply-accumulate operation, in which it multiplies the last two arguments, adds them to the remaining input/source argument, and places that into the result.

SRGBA = Arg1 + Arg2 *Arg3
DotProduct3 24 Modulates the components of each argument as signed components, adds their products, and replicates the sum to all color channels, including alpha. This operation is supported for color and alpha operations.

SRGBA = (Arg1R * Arg2R + Arg1G * Arg2G + Arg1B * Arg2B)
BumpEnvironmentMapLuminance | 23 | Performs per-pixel bump mapping, using the environment map in the next texture stage with luminance. This operation is supported only for color operations (TextureState.ColorOperation).
BumpEnvironmentMap | 22 | Performs bump mapping on each pixel, using the environment map in the next texture stage without luminance. This operation is supported only for color operations (TextureState.ColorOperation).
ModulateInvColorAddAlpha 21 Similar to ModulateColorAddAlpha, but uses the inverse of the color of the first argument. This operation is supported only for color operations (TextureState.ColorOperation).

SRGBA = (1 - Arg1RGB) * Arg2RGB + Arg1A
ModulateInvAlphaAddColor 20 Similar to ModulateAlphaAddColor, but uses the inverse of the alpha of the first argument. This operation is supported only for color operations (TextureState.ColorOperation).

SRGBA = (1 - Arg1A) * Arg2RGB + Arg1RGB
ModulateColorAddAlpha 19 Modulates the arguments, then adds the alpha of the first argument. This operation is supported only for color operations (TextureState.ColorOperation).

SRGBA = Arg1RGB * Arg2RGB + Arg1A
ModulateAlphaAddColor 18 Modulates the color of the second argument using the alpha of the first argument, then adds the result to argument one. This operation is supported only for color operations (TextureStateManager.ColorOperation).

SRGBA = Arg1RGB + Arg1A * Arg2RGB
PreModulate | 17 | This flag is set in stage n, the output of which is arg1. If stage n + 1 contains a texture, any Current value in stage n + 1 is premultiplied by that texture.
BlendCurrentAlpha 16 Performs linear blending on the current texture stage, using the alpha taken from the previous texture stage.

SRGBA = Arg1 * (Alpha) + Arg2 * (1 - Alpha)
BlendTextureAlphaPM 15 Performs linear blending on the current texture stage that uses a premultiplied alpha.

SRGBA = Arg1 + Arg2 * (1 - Alpha)
BlendFactorAlpha 14 Performs linear blending on the current texture stage, using a scalar alpha set with the RenderStateManager.TextureFactor property.

SRGBA = Arg1 * (Alpha) + Arg2 * (1 - Alpha)
BlendTextureAlpha 13 Performs linear blending on the current texture stage, using the interpolated alpha from each vertex.

SRGBA = Arg1 * (Alpha) + Arg2 * (1 - Alpha)
BlendDiffuseAlpha 12 Performs linear blending on the current texture stage, using the interpolated alpha from each vertex.

SRGBA = Arg1 * (Alpha) + Arg2 * (1 - Alpha)
AddSmooth 11 Adds the first and second arguments, then subtracts their product from the sum.

SRGBA = Arg1 + Arg2 - Arg1 * Arg2
AddSigned2X 9 Adds the components of the arguments with a -0.5 bias and shifts the products 1 bit to the left.

SRGBA = (Arg1 + Arg2 - 0.5) << 1
AddSigned 8 Adds the components of the arguments with a -0.5 bias, making the effective range of values -0.5 through 0.5.

SRGBA = Arg1 + Arg2 -0.5
Add 7 Adds the components of the arguments.

SRGBA = Arg1 + Arg2
Modulate4X 6 Multiplies the components of the arguments, then shifts the products 2 bits to the left (effectively multiplying them by 4) for brightening.

SRGBA = (Arg1 * Arg2) << 2
Modulate2X 5 Multiplies the components of the arguments, then shifts the products 1 bit to the left (effectively multiplying them by 2) for brightening.

SRGBA = (Arg1 * Arg2) << 1
Modulate 4 Multiplies the components of the arguments.

SRGBA = Arg1 * Arg2
SelectArg2 3 Uses this texture stage's second color or alpha argument, unmodified, as the output. This operation affects the color argument when used with the TextureStateManager.ColorOperation property, and the alpha argument when used with the TextureStateManager.AlphaOperation property.

SRGBA = Arg2
SelectArg1 2 Uses this texture stage's first color or alpha argument, unmodified, as the output. This operation affects the color argument when used with the TextureStateManager.ColorOperation property, and the alpha argument when used with the TextureStateManager.AlphaOperation property.

SRGBA = Arg1
Disable | 1 | Disables output from the texture stage and all stages with a higher index. To disable texture mapping, set this flag as the color operation for the first texture stage (stage 0). Alpha operations cannot be disabled when color operations are enabled. Setting the alpha operation to Disable when color blending is enabled causes undefined behavior.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • TextureOperationCaps


TextureStageStates Enumeration (Microsoft.DirectX.Direct3D)

TextureStageStates Enumeration

Defines texture stage states.

Definition

Visual Basic | Public Enum TextureStageStates
C# | public enum TextureStageStates
C++ | public enum class TextureStageStates
JScript | public enum TextureStageStates

Members

Member | Value | Description
ResultArgument 28 Selects the destination register for the result of the current stage identified by TextureArgument.

This value can be set to TextureArgument.Current (the default value) or to TextureArgument.Temp, which is a single temporary register that can be read into subsequent stages as an input argument. The final color passed to the fog blender and frame buffer is taken from TextureArgument.Current, so the last active texture stage state must be set to TextureArgument.Current. This setting is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present.
AlphaArgument0 27 Defines settings for the alpha channel selector operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.

AlphaArgument0 is supported if the TextureOperationCaps.SupportsMultiplyAdd or TextureOperationCaps.SupportsLerp device capabilities are present. The default argument is TextureArgument.Current.

To select a temporary register color for read or write, specify TextureArgument.Temp, which is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default argument is (0.0, 0.0, 0.0, 0.0).
ColorArgument0 26 Defines settings for the third color operand for triadic (multiply, add, and linear interpolation) operations identified by the TextureArgument enumeration.

This setting is supported if the TextureOperationCaps.SupportsMultiplyAdd or TextureOperationCaps.SupportsLerp device capabilities are present. The default argument is TextureArgument.Current.

Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
TextureTransform | 24 | Controls the transformation of texture coordinates for the current texture stage. The default value is TextureTransform.Disable.
BumpEnvironmentLuminanceOffset | 23 | Defines a floating-point offset value for bump-map luminance. The default value is 0.0.
BumpEnvironmentLuminanceScale | 22 | Defines a floating-point scale value for bump-map luminance. The default value is 0.0.
BumpEnvironmentMaterial11 | 10 | Defines the texture-stage state as a floating-point value for the [1][1] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.
BumpEnvironmentMaterial10 | 9 | Defines the texture-stage state as a floating-point value for the [1][0] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.
BumpEnvironmentMaterial01 | 8 | Defines the texture-stage state as a floating-point value for the [0][1] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.
BumpEnvironmentMaterial00 | 7 | Defines the texture-stage state as a floating-point value for the [0][0] coefficient in a bump-mapping matrix. The valid range of values for bump-mapping matrix coefficients is greater than or equal to -8.0 and less than 8.0. This range, expressed in mathematical notation, is (-8.0,8.0). The default value is 0.0.
AlphaArgument2 6 Defines the texture-stage state as the second alpha argument for the stage identified by the TextureArgument enumeration.

The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
Constant | 32 | Defines the per-stage constant color. To determine whether the current device supports a per-stage constant color, use the MiscCaps.SupportsPerStageConstant property. The ConstantColor property is used by TextureArgument.Constant.
TextureCoordinateIndex 11 Defines the index of the texture coordinate set to use with the current texture stage.

Up to eight sets of texture coordinates per vertex can be specified. If a vertex does not include a set of texture coordinates at the specified index, the system reverts to the u and v coordinates (0, 0) by default.

When rendering with vertex shaders, each stage's texture coordinate index must be set to its default value. The default index for each stage is equal to the stage index. Set this state to the zero-based index of the coordinate set for each vertex that this texture stage uses.

Additionally, applications can include TextureCoordinateIndex values as part of a logical OR with the index being set, to request that Microsoft DirectX automatically generate the input texture coordinates for a texture transformation.

The system uses the index strictly to determine texture wrapping mode when using a TextureCoordinateIndex value other than PassThru, which resolves to zero. These flags are most useful when performing environment mapping.
AlphaArgument1 5 Defines the texture-stage state as the first alpha argument for the stage identified by the TextureArgument enumeration.

The default argument is TextureArgument.TextureColor. If no texture is set for this stage, the default argument is TextureArgument.Diffuse. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
AlphaOperation 4 Defines the texture-stage state as a texture alpha-blending operation identified by the TextureOperation enumeration.

The default value for the first texture stage (stage 0) is TextureOperation.SelectArg1, and for all other stages is TextureOperation.Disable.
ColorArgument2 3 Defines the texture-stage state as the second color argument for the stage identified by the TextureArgument enumeration.

The default argument is TextureArgument.Current. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
ColorArgument1 2 Defines the texture-stage state as the first color argument for the stage identified by the TextureArgument enumeration.

The default argument is TextureArgument.Texture. Specify TextureArgument.Temp to select a temporary register color for read or write. TextureArgument.Temp is supported if the MiscCaps.SupportsTextureStageStateArgumentTemp device capability is present. The default value for the register is (0.0, 0.0, 0.0, 0.0).
ColorOperation 1 Defines the texture-stage state as a texture color-blending operation identified by the TextureOperation enumeration.

The default value for the first texture stage (stage 0) is TextureOperation.Modulate, and for all other stages is TextureOperation.Disable.

Remarks

These enumeration constants and values are used by the Device.SetTextureStageState method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • TextureStateManager

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


TextureTransform Enumeration (Microsoft.DirectX.Direct3D)

TextureTransform Enumeration

Defines texture-stage state values.

Definition

Visual Basic | Public Enum TextureTransform
C# | public enum TextureTransform
C++ | public enum class TextureTransform
JScript | public enum TextureTransform

Members

Member | Value | Description
Projected | 256 | All texture coordinates are divided by the last element before being passed to the rasterizer. For example, if this flag is specified with the Count3 flag, the first and second texture coordinates are divided by the third coordinate before being passed to the rasterizer.
Count4 | 4 | 4-D texture coordinates are passed to the rasterizer.
Count3 | 3 | 3-D texture coordinates are passed to the rasterizer.
Count2 | 2 | 2-D texture coordinates are passed to the rasterizer.
Count1 | 1 | 1-D texture coordinates are passed to the rasterizer.
Disable | 0 | Texture coordinates are passed directly to the rasterizer.

Remarks

This enumeration is used by the TextureStateManager.TextureTransform property.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TransformType Enumeration (Microsoft.DirectX.Direct3D)

TransformType Enumeration

Defines constants that describe transformation state values.

Definition

Visual Basic | Public Enum TransformType
C# | public enum TransformType
C++ | public enum class TransformType
JScript | public enum TransformType

Members

Member | Value | Description
World3 | 259 | Identifies the world matrix being set for the specified texture stage.
World2 | 258 | Identifies the world matrix being set for the specified texture stage.
World1 | 257 | Identifies the world matrix being set for the specified texture stage.
World | 256 | Identifies the world matrix being set for the specified texture stage.
Texture7 | 23 | Identifies the transformation matrix being set for the specified texture stage.
Texture6 | 22 | Identifies the transformation matrix being set for the specified texture stage.
Texture5 | 21 | Identifies the transformation matrix being set for the specified texture stage.
Texture4 | 20 | Identifies the transformation matrix being set for the specified texture stage.
Texture3 | 19 | Identifies the transformation matrix being set for the specified texture stage.
Texture2 | 18 | Identifies the transformation matrix being set for the specified texture stage.
Texture1 | 17 | Identifies the transformation matrix being set for the specified texture stage.
Texture0 | 16 | Identifies the transformation matrix being set for the specified texture stage.
Projection | 3 | Identifies the transformation matrix being set as the projection transformation matrix. The default value is the identity matrix.
View | 2 | Identifies the transformation matrix being set as the view transformation matrix. The default value is the identity matrix.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • SetTransform
  • GetTransform
  • MultiplyTransform


TransitionType Enumeration (Microsoft.DirectX.Direct3D)

TransitionType Enumeration

Defines the transition style between values of a mesh animation.

Definition

Visual Basic | Public Enum TransitionType
C# | public enum TransitionType
C++ | public enum class TransitionType
JScript | public enum TransitionType

Members

Member | Value | Description
EaseInEaseOut | 1 | Ease-in, ease-out spline transition between values.
Linear | 0 | Linear transition between values.

Remarks

The calculation for the ramp from ease-in to ease-out is calculated as follows.

Q(t) = 2(x - y)t3 + 3(y - x)t2 + x.

where the ramp is a function Q(t) with the following properties:

  • Q(t) is a cubic spline.
  • Q(t) interpolates between x and y as t ranges from 0 to 1.
  • Q(t) is horizontal when t = 0 and t = 1.

Mathematically, this translates into:

Q(t) = At3 + Bt2 + Ct + D (and therefore, Q'(t) = 3At2 + 2Bt + C)

Q(0) = x (2a)

Q(1) = y (2b)

Q'(0) = 0 (3a)

Q'(1) = 0 (3b)

Solving for A, B, C, D:

D = x (from 2a)

C = 0 (from 3a)

3A + 2B = 0 (from 3b)

A + B = y - x (from 2b and D = x)

Therefore:

A = 2(x - y), B = 3(y - x), C = 0, D = x.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • AnimationController


Usage Enumeration (Microsoft.DirectX.Direct3D)

Usage Enumeration

Defines supported usage types for the current resource.

Definition

Visual Basic | Public Enum Usage
C# | public enum Usage
C++ | public enum class Usage
JScript | public enum Usage

Members

Member | Value | Description
None | 0 | Specifies no usage type for the current resource.
QueryWrapAndMip | 2097152 | Queries the resource to verify support for texture wrapping and mip-mapping.
QueryVertexTexture | 1048576 | Queries the resource to verify support for vertex shader texture sampling.
QueryPostPixelShaderBlending | 524288 | Queries the resource to verify support for post pixel shader blending. If Manager.CheckDeviceFormat fails with QueryPostPixelShaderBlending, post pixel blending operations are not supported. These operations include alpha test, pixel fog, render-target blending, color write enable, and dither.
QuerySrgbWrite | 262144 | Queries the resource to determine whether a texture supports gamma correction during a write operation.
QueryFilter | 131072 | Queries the resource format to determine whether it supports texture filter types other than Point (which is always supported).
QuerySrgbRead | 65536 | Queries the resource to determine whether a texture supports gamma correction during a read operation.
QueryLegacyBumpMap | 32768 | Queries the resource about a legacy bump map.
QueryDisplacementMap | 16384 | Queries the resource to determine whether it will be a displacement map.
AutoGenerateMipMap | 1024 | Specifies that the resource automatically generate mipmaps. Automatic mipmap generation is not supported for volume textures and depth stencil surfaces/textures. This usage is not valid for resources in system memory (SystemMemory).
Dynamic | 512 | Indicates that the vertex buffer requires dynamic memory use, which is useful for drivers because it enables them to determine where to place the buffer. In general, static vertex buffers are placed in video memory and dynamic vertex buffers are placed in accelerated graphics port (AGP) memory. Note that there is no separate static use. If Dynamic is not specified, the vertex buffer is made static.
NPatches | 256 | Indicates when the vertex buffer will be used for drawing N-patches.
RTPatches | 128 | Indicates when the vertex buffer will be used for drawing high-order primitives.
Points | 64 | Indicates when the vertex buffer will be used for drawing points.
DoNotClip | 32 | Indicates that the vertex buffer content will never require clipping. When rendering with buffers that have this flag set, the RenderStateManager.Clipping property must be set to false.
SoftwareProcessing | 16 | Specifies that vertex processing be done in software. If this flag is not used, vertex processing is done in hardware. SoftwareProcessing is used with Manager.CheckDeviceFormat to determine whether a particular texture format can be used as a vertex texture during software vertex processing. If it can, the texture must be created with Scratch.
WriteOnly | 8 | Informs the system that the application writes only to the vertex buffer. Using this flag enables the driver to choose the best memory location, which results in efficient write operations and rendering. Attempts to read from a vertex buffer created with this capability will fail. Buffers that are created with Default and that do not specify WriteOnly might experience significant drops in performance.
DepthStencil | 2 | Specifies that the resource will be a depth stencil buffer. DepthStencil can be used only with Default.
RenderTarget | 1 | Specifies that the resource will be a render target. RenderTarget can be used only with Default.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Resource Properties
  • SurfaceDescription.Usage
  • VertexBufferDescription.Usage
  • IndexBufferDescription.Usage


VertexBlend Enumeration (Microsoft.DirectX.Direct3D)

VertexBlend Enumeration

Defines enumerated values used to control the number of matrices that the system applies when performing multimatrix vertex blending.

Definition

Visual Basic | Public Enum VertexBlend
C# | public enum VertexBlend
C++ | public enum class VertexBlend
JScript | public enum VertexBlend

Members

Member | Value | Description
ZeroWeights | 256 | Uses a single matrix with a weight of 1.0.
Tweening | 255 | Uses the value assigned to RenderStateManager.TweenFactor.
ThreeWeights | 3 | Enables vertex blending between the four matrices set by the Transforms.SetWorldMatrixByIndex method, where the index values for the transformation states are 0, 1, 2, and 3. These matrices also can be set using the device.Transform.World, device.Transform.World1, device.Transform.World2, and device.Transform.World3 properties.
TwoWeights | 2 | Enables vertex blending between the three matrices set by the Transforms.SetWorldMatrixByIndex method, where the index values for the transformation states are 0, 1, and 2. These matrices also can be set using the device.Transform.World, device.Transform.World1, and device.Transform.World2 properties.
OneWeights | 1 | Enables vertex blending between the two matrices set by the Transforms.SetWorldMatrixByIndex method, where the index values for the transformation states are 0 and 1. These matrices also can be set using the device.Transform.World and device.Transform.World1 properties.
Disable | 0 | Disables vertex blending and applies only the world matrix (set by the Transforms.SetWorldMatrixByIndex method, where the index value for the transformation state is 0, or with the Device.Transform.World property).

Remarks

This enumeration is used by the RenderStateManager.VertexBlend parameters.

Multimatrix vertex blending (also known as geometry blending) requires that an application use a vertex format that has blending (beta) weights for each vertex.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexFormats Enumeration (Microsoft.DirectX.Direct3D)

VertexFormats Enumeration

Describes values that define a vertex format used to describe the contents of vertices that are stored interleaved in a single data stream.

Definition

Visual Basic | Public Enum VertexFormats
C# | public enum VertexFormats
C++ | public enum class VertexFormats
JScript | public enum VertexFormats

Members

Member | Value | Description
PositionNormal | 18 | Vertex format includes a vertex normal vector. This value cannot be used with the Transformed value.
LastBetaD3DColor | 32768 | Last beta field in the vertex position data will be of type Int32 Leave Site. The data in the beta fields are used with matrix palette skinning to specify matrix indices.
LastBetaUByte4 | 4096 | Last beta field in the vertex position data will be of type UBYTE4. The data in the beta fields are used with matrix palette skinning to specify matrix indices. The vertex format is declared as PositionBlend5 | LastBetaUByte4. Both weights and MatrixIndices are included in beta[], where LastBetaUByte4 directs the compiler to interpret the last uint (beta[5]) as type UBYTE4. The last beta is determined by VertexBlend, not by the number of betas in the position format. For example, if VertexBlend is TwoWeights, and the position format is as specified above, the last beta will be beta[2] and will be used as a uint with 4-byte indices.
Texture8 | 2048 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture7 | 1792 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture6 | 1536 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture5 | 1280 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture4 | 1024 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture3 | 768 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture2 | 512 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture1 | 256 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
Texture0 | 0 | Number of texture coordinate sets for this vertex. The actual values for these flags are not sequential.
TextureCountShift | 8 | Number of bits by which to shift an integer value that identifies the number of texture coordinates for a vertex.
TextureCountMask | 3840 | Mask value for texture flag bits.
Specular | 128 | Vertex format includes a specular color component.
Diffuse | 64 | Vertex format includes a diffuse color component.
PointSize | 32 | Vertex format is specified in point size. This size is expressed in camera space units for vertices that are not transformed and lit, and in device-space units for vertices that are transformed and lit.
Normal | 16 | Vertex format includes a vertex normal vector. This value cannot be used with the Transformed flag.
PositionW | 16386 | Vertex format contains transformed and clipped x, y, z, w data. Device.ProcessVertices does not invoke the clipper, but instead outputs data in clip coordinates. This constant is designed for, and can only be used with, the programmable vertex pipeline.
PositionBlend5 | 14 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Microsoft Direct3D can blend with up to three weighting values and four blending matrices.
PositionBlend4 | 12 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Direct3D can blend with up to three weighting values and four blending matrices.
PositionBlend3 | 10 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Direct3D can blend with up to three weighting values and four blending matrices.
PositionBlend2 | 8 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Direct3D can blend with up to three weighting values and four blending matrices.
PositionBlend1 | 6 | Vertex format contains position data and a corresponding number of weighting (beta) values to use for multimatrix vertex blending operations. Currently, Direct3D can blend with up to three weighting values and four blending matrices.
Transformed | 4 | Vertex format includes the position of a transformed vertex. This flag cannot be used with the Position or Normal flags.
Position | 2 | Mask for position bits.
PositionMask | 16398 | Mask for position bits.
None | 0 | No vertex format.

Remarks

Vertex format codes generally are used to specify data to be processed by fixed function vertex processing.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WeldEpsilonsFlags Enumeration (Microsoft.DirectX.Direct3D)

WeldEpsilonsFlags Enumeration

Defines the options for welding vertices together.

Definition

Visual Basic | Public Enum WeldEpsilonsFlags
C# | public enum WeldEpsilonsFlags
C++ | public enum class WeldEpsilonsFlags
JScript | public enum WeldEpsilonsFlags

Members

Member | Value | Description
DoNotSplit | 8 | Instructs the weld to allow vertices to be modified only, not removed. This flag is valid only if WeldPartialMatches is set. It is useful to modify vertices so that they are equal, but not to allow vertices to be removed.
DoNotRemoveVertices | 4 | Instructs the weld to allow vertices to be modified only, not removed. This flag is valid only if WeldPartialMatches is set. It is useful to modify vertices to be equal, but not to allow vertices to be removed.
WeldPartialMatches | 2 | If a given vertex component is within epsilon, instructs the weld to modify partially matched vertices so that both components are equal. If all components are equal, one of the vertices is removed.
WeldAll | 1 | Welds all vertices that are marked by adjacency as being overlapping.

Remarks

This enumeration is used with the Mesh.WeldVertices method.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Wrap Enumeration (Microsoft.DirectX.Direct3D)

Wrap Enumeration

Defines texture wrapping.

Definition

Visual Basic | Public Enum Wrap
C# | public enum Wrap
C++ | public enum class Wrap
JScript | public enum Wrap

Members

Member | Value | Description
W | 4 | W texture wrapping (wrapping in the direction of the third dimension).
V | 2 | V texture wrapping (wrapping in the direction of the second dimension).
U | 1 | U texture wrapping (wrapping in the direction of the first dimension).

Remarks

This enumeration is used by the RenderStateManager.Wrap0 property and the Wrap1 through Wrap15 properties.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • WrapCoordinates


WrapCoordinates Enumeration (Microsoft.DirectX.Direct3D)

WrapCoordinates Enumeration

Defines supported wrap coordinates.

Definition

Visual Basic | Public Enum WrapCoordinates
C# | public enum WrapCoordinates
C++ | public enum class WrapCoordinates
JScript | public enum WrapCoordinates

Members

Member | Value | Description
Zero | 1 | U texture wrapping (wrapping in the direction of the first dimension).
Three | 8 | Texture wrapping in the direction of the fourth dimension.
Two | 4 | W texture wrapping (wrapping in the direction of the third dimension).
One | 2 | V texture wrapping (wrapping in the direction of the second dimension).

Remarks

This enumeration is used by the RenderStateManager.Wrap0 property and the Wrap1 through Wrap15 properties.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Wrap


XFileErrorCodes Enumeration (Microsoft.DirectX.Direct3D)

XFileErrorCodes Enumeration

Defines XFile error codes. The methods used to work with Microsoft DirectX XFiles can return the following return values. Exceptions thrown from methods that use XFiles can also contain these values.

Definition

Visual Basic | Public Enum XFileErrorCodes
C# | public enum XFileErrorCodes
C++ | public enum class XFileErrorCodes
JScript | public enum XFileErrorCodes

Members

Member | Value | Description
BadCacheFile | -2005531755 | A cache file could not be read.
NoMoreData | -2005531756 | No further data is available.
NoMoreObjects | -2005531757 | All objects have been enumerated.
BadDataReference | -2005531758 | Template member data could not be retrieved.
BadArraySize | -2005531759 | Array size exceeds the allowable size.
ParseError | -2005531760 | File could not be parsed.
BadFile | -2005531761 | A file read or write operation failed.
BadFileFloatSize | -2005531762 | File is not the expected size.
BadFileVersion | -2005531763 | File has an invalid format version.
BadFileType | -2005531764 | File has an invalid format.
BadResource | -2005531765 | Resource is invalid.
ResourceNotFound | -2005531766 | Resource could not be found.
FileNotFound | -2005531767 | File could not be found.
NotDoneYet | -2005531768 | Operation has not completed.
NotFound | -2005531769 | Object could not be found.
BadType | -2005531770 | File did not match known template types.
BadValue | -2005531771 | A variable is outside its expected range; typically returned when an object is invalid.
BadObject | -2005531772 | Data could not be read from or written to an object.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


XFileFormat Enumeration (Microsoft.DirectX.Direct3D)

XFileFormat Enumeration

Defines file formats for XFiles.

Definition

Visual Basic | Public Enum XFileFormat
C# | public enum XFileFormat
C++ | public enum class XFileFormat
JScript | public enum XFileFormat

Members

Member | Value | Description
Compressed | 2 | Indicates a compressed file.
Text | 1 | Indicates a text file.
Binary | 0 | Indicates a binary file.

Remarks

This enumeration is used by Mesh.Save and XFileManager.CreateSaveObject.

Enumeration Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AdapterDetails Structure (Microsoft.DirectX.Direct3D)

AdapterDetails Structure

Contains information that identifies the adapter.

Definition

Visual Basic | Public Structure AdapterDetails
C# | public struct AdapterDetails
C++ | public value class AdapterDetails sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AdapterDetails | Creates a new instance of the AdapterDetails structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Description | Retrieves a string used for presentation to the user.
DeviceId | Retrieves a value that is used to help identify a particular chip set.
DeviceIdentifier | Retrieves a globally unique identifier (GUID) object that can be used to check changes in the driver and chip set.
DeviceName | Retrieves a string that contains the device name for a Microsoft Windows Graphics Device Interface (GDI).
DriverName | Retrieves a string that is used to present the driver name to the user.
DriverVersion | Retrieves a value that identifies the version of the Microsoft Direct3D driver.
Revision | Retrieves a value used to help identify the revision level of a particular chip set.
SubSystemId | Retrieves a value used to identify the subsystem.
VendorId | Retrieves a value used to identify the manufacturer.
WhqlLevel | Retrieves a value that is used to determine the Windows Hardware Quality Labs (WHQL) validation level for the driver and device pair.

Remarks

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AdapterDetails.AdapterDetails() Constructor (Microsoft.DirectX.Direct3D)

AdapterDetails.AdapterDetails Constructor

Creates a new instance of the AdapterDetails structure.

Definition

Visual Basic | Public Sub New()
C# | public AdapterDetails();
C++ public:
AdapterDetails();
JScript | public function AdapterDetails();


AdapterDetails.ToString() Method (Microsoft.DirectX.Direct3D)

AdapterDetails.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


AdapterDetails.Description Property (Microsoft.DirectX.Direct3D)

AdapterDetails.Description Property

Retrieves a string used for presentation to the user.

Definition

Visual Basic | Public ReadOnly Property Description As String
C# | public string Description { get; }
C++ public:
property String^ Description {
String^ get();
}
JScript | public function get Description() : String

Property Value

System.String
A String Leave Site object that describes the adapter to the user.

This property is read-only.


AdapterDetails.DeviceId Property (Microsoft.DirectX.Direct3D)

AdapterDetails.DeviceId Property

Retrieves a value that is used to help identify a particular chip set.

Definition

Visual Basic | Public ReadOnly Property DeviceId As Integer
C# | public int DeviceId { get; }
C++ public:
property int DeviceId {
int get();
}
JScript | public function get DeviceId() : int

Property Value

System.Int32
Value that helps identify the chip set.

This property is read-only.

Remarks

The returned value can be zero if it is unknown.

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.


AdapterDetails.DeviceIdentifier Property (Microsoft.DirectX.Direct3D)

AdapterDetails.DeviceIdentifier Property

Retrieves a globally unique identifier (GUID) object that can be used to check changes in the driver and chip set.

Definition

Visual Basic | Public ReadOnly Property DeviceIdentifier As Guid
C# | public Guid DeviceIdentifier { get; }
C++ public:
property Guid DeviceIdentifier {
Guid get();
}
JScript | public function get DeviceIdentifier() : Guid

Property Value

System.Guid
A Guid Leave Site object that is used as a unique identifier for the driver and chip set pair.

This property is read-only.

Remarks

Use this member to track changes to the driver and chip set to generate a new profile for the graphics subsystem. It also can be used to identify problematic drivers.


AdapterDetails.DeviceName Property (Microsoft.DirectX.Direct3D)

AdapterDetails.DeviceName Property

Retrieves a string that contains the device name for a Microsoft Windows Graphics Device Interface (GDI).

Definition

Visual Basic | Public ReadOnly Property DeviceName As String
C# | public string DeviceName { get; }
C++ public:
property String^ DeviceName {
String^ get();
}
JScript | public function get DeviceName() : String

Property Value

System.String
A String Leave Site object that contains the name of the device.

This property is read-only.


AdapterDetails.DriverName Property (Microsoft.DirectX.Direct3D)

AdapterDetails.DriverName Property

Retrieves a string that is used to present the driver name to the user.

Definition

Visual Basic | Public ReadOnly Property DriverName As String
C# | public string DriverName { get; }
C++ public:
property String^ DriverName {
String^ get();
}
JScript | public function get DriverName() : String

Property Value

System.String
A String Leave Site object that contains the driver name.

This property is read-only.

Remarks

This member should not be used to identify particular drivers, because many different strings might be associated with the same device and driver from different vendors.


AdapterDetails.DriverVersion Property (Microsoft.DirectX.Direct3D)

AdapterDetails.DriverVersion Property

Retrieves a value that identifies the version of the Microsoft Direct3D driver.

Definition

Visual Basic | Public ReadOnly Property DriverVersion As Version
C# | public Version DriverVersion { get; }
C++ public:
property Version^ DriverVersion {
Version^ get();
}
JScript | public function get DriverVersion() : Version

Property Value

System.Version
A Version Leave Site object that represents the driver version.

This property is read-only.


AdapterDetails.Revision Property (Microsoft.DirectX.Direct3D)

AdapterDetails.Revision Property

Retrieves a value used to help identify the revision level of a particular chip set.

Definition

Visual Basic | Public ReadOnly Property Revision As Integer
C# | public int Revision { get; }
C++ public:
property int Revision {
int get();
}
JScript | public function get Revision() : int

Property Value

System.Int32
Value used to help identify the revision level of the chip set.

This property is read-only.

Remarks

The value can be zero if it is unknown.

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.


AdapterDetails.SubSystemId Property (Microsoft.DirectX.Direct3D)

AdapterDetails.SubSystemId Property

Retrieves a value used to identify the subsystem.

Definition

Visual Basic | Public ReadOnly Property SubSystemId As Integer
C# | public int SubSystemId { get; }
C++ public:
property int SubSystemId {
int get();
}
JScript | public function get SubSystemId() : int

Property Value

System.Int32
Value used to identify the subsystem, typically the particular board.

This property is read-only.

Remarks

The value can be zero if it is unknown.

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.


AdapterDetails.VendorId Property (Microsoft.DirectX.Direct3D)

AdapterDetails.VendorId Property

Retrieves a value used to identify the manufacturer.

Definition

Visual Basic | Public ReadOnly Property VendorId As Integer
C# | public int VendorId { get; }
C++ public:
property int VendorId {
int get();
}
JScript | public function get VendorId() : int

Property Value

System.Int32
Value used to identify the manufacturer.

This property is read-only.

Remarks

The value can be zero if it is unknown.

The VendorId, DeviceId, SubSystemId, and Revision members can be used in tandem to identify particular chip sets. However, these members should be used with caution.


AdapterDetails.WhqlLevel Property (Microsoft.DirectX.Direct3D)

AdapterDetails.WhqlLevel Property

Retrieves a value that is used to determine the Microsoft Windows Hardware Quality Labs (WHQL) validation level for the driver and device pair.

Definition

Visual Basic | Public ReadOnly Property WhqlLevel As Integer
C# | public int WhqlLevel { get; }
C++ public:
property int WhqlLevel {
int get();
}
JScript | public function get WhqlLevel() : int

Property Value

System.Int32
Value used to determine the validation level for the driver and device pair.

This property is read-only.

Remarks

The Int32 Leave Site is a packed date structure that defines the date of the release of the most recent WHQL test passed by the driver. It is permissible to perform "greater than" and "less than" operations on this value. The following table illustrates the date format.

Bits | Description
31-16 | The year, a decimal number from 1999 upwards.
15-8 | The month, a decimal number from 1 to 12.
7-0 | The day, a decimal number from 1 to 31.

The following values also are used.

Value | Description
0 | Not certified.
1 | Validated by WHQL, but no date information is available.


AddressCaps Structure (Microsoft.DirectX.Direct3D)

AddressCaps Structure

Contains the texture addressing capabilities for Texture objects.

Definition

Visual Basic | Public Structure AddressCaps
C# | public struct AddressCaps
C++ | public value class AddressCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsBorder | Retrieves a value that determines whether the device supports the setting of coordinates outside the range [0.0, 1.0] to the border color.
SupportsClamp | Retrieves a value that indicates whether the device supports the clamping of textures to addresses.
SupportsIndependentUV | Retrieves a value that indicates whether the device can separate the texture-addressing modes of the texture's u and v coordinates.
SupportsMirror | Retrieves a value that indicates whether a device can mirror textures to addresses.
SupportsMirrorOnce | Retrieves a value that indicates whether a device can take the absolute value of the texture coordinate (thus, mirroring around 0) and then clamp to the maximum value.
SupportsWrap | Retrieves a value that indicates whether a device can wrap textures to addresses.

Remarks

This structure is found in the Caps.TextureAddressCaps and Caps.VolumeTextureAddressCaps members.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AddressCaps.ToString() Method (Microsoft.DirectX.Direct3D)

AddressCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


AddressCaps.SupportsBorder Property (Microsoft.DirectX.Direct3D)

AddressCaps.SupportsBorder Property

Retrieves a value that determines whether the device supports the setting of coordinates outside the range [0.0, 1.0] to the border color.

Definition

Visual Basic | Public ReadOnly Property SupportsBorder As Boolean
C# | public bool SupportsBorder { get; }
C++ public:
property bool SupportsBorder {
bool get();
}
JScript | public function get SupportsBorder() : boolean

Property Value

System.Boolean
Value that is true if the device supports the setting of coordinates outside the range to the border color, or false if it does not.

This property is read-only.

Remarks

The SamplerStateManager.BorderColor member sets the border color.


AddressCaps.SupportsClamp Property (Microsoft.DirectX.Direct3D)

AddressCaps.SupportsClamp Property

Retrieves a value that indicates whether the device supports the clamping of textures to addresses.

Definition

Visual Basic | Public ReadOnly Property SupportsClamp As Boolean
C# | public bool SupportsClamp { get; }
C++ public:
property bool SupportsClamp {
bool get();
}
JScript | public function get SupportsClamp() : boolean

Property Value

System.Boolean
Value that is true if the device supports clamping textures to addresses, or false if it does not.

This property is read-only.


AddressCaps.SupportsIndependentUV Property (Microsoft.DirectX.Direct3D)

AddressCaps.SupportsIndependentUV Property

Retrieves a value that indicates whether the device can separate the texture-addressing modes of the texture's u and v coordinates.

Definition

Visual Basic | Public ReadOnly Property SupportsIndependentUV As Boolean
C# | public bool SupportsIndependentUV { get; }
C++ public:
property bool SupportsIndependentUV {
bool get();
}
JScript | public function get SupportsIndependentUV() : boolean

Property Value

System.Boolean
Value that is true if the device supports separating the texture-addressing modes of the u and v coordinates, or false if it does not.

This property is read-only.

Remarks

This property's ability corresponds to the SamplerStateManager.AddressU and SamplerStateManager.AddressV render-state values.


AddressCaps.SupportsMirror Property (Microsoft.DirectX.Direct3D)

AddressCaps.SupportsMirror Property

Retrieves a value that indicates whether a device can mirror textures to addresses.

Definition

Visual Basic | Public ReadOnly Property SupportsMirror As Boolean
C# | public bool SupportsMirror { get; }
C++ public:
property bool SupportsMirror {
bool get();
}
JScript | public function get SupportsMirror() : boolean

Property Value

System.Boolean
Value that is true if the device supports mirroring textures to addresses, or false if it does not.

This property is read-only.


AddressCaps.SupportsMirrorOnce Property (Microsoft.DirectX.Direct3D)

AddressCaps.SupportsMirrorOnce Property

Retrieves a value that indicates whether a device can take the absolute value of the texture coordinate (thus, mirroring around 0) and then clamp to the maximum value.

Definition

Visual Basic | Public ReadOnly Property SupportsMirrorOnce As Boolean
C# | public bool SupportsMirrorOnce { get; }
C++ public:
property bool SupportsMirrorOnce {
bool get();
}
JScript | public function get SupportsMirrorOnce() : boolean

Property Value

System.Boolean
Value that is true if the device can take the absolute value of the texture coordinate and then clamp to the maximum value, or false if it cannot.

This property is read-only.


AddressCaps.SupportsWrap Property (Microsoft.DirectX.Direct3D)

AddressCaps.SupportsWrap Property

Retrieves a value that indicates whether a device can wrap textures to addresses.

Definition

Visual Basic | Public ReadOnly Property SupportsWrap As Boolean
C# | public bool SupportsWrap { get; }
C++ public:
property bool SupportsWrap {
bool get();
}
JScript | public function get SupportsWrap() : boolean

Property Value

System.Boolean
Value that is true if the device can wrap textures to addresses, or false if it cannot.

This property is read-only.


AnimationRootFrame Structure (Microsoft.DirectX.Direct3D)

AnimationRootFrame Structure

Contains the root frame and animation controller in a frame hierarchy.

Definition

Visual Basic | Public Structure AnimationRootFrame
C# | public struct AnimationRootFrame
C++ | public value class AnimationRootFrame sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AnimationRootFrame | Creates a new instance of the AnimationRootFrame structure.

Properties

Property | Description
AnimationController | Retrieves the animation controller.
FrameHierarchy | Retrieves the root node reference of the loaded frame hierarchy.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AnimationRootFrame.AnimationRootFrame() Constructor (Microsoft.DirectX.Direct3D)

AnimationRootFrame.AnimationRootFrame Constructor

Creates a new instance of the AnimationRootFrame structure.

Definition

Visual Basic | Public Sub New()
C# | public AnimationRootFrame();
C++ public:
AnimationRootFrame();
JScript | public function AnimationRootFrame();

See Also

  • LoadHierarchyFromFile


AnimationRootFrame.AnimationController Property (Microsoft.DirectX.Direct3D)

AnimationRootFrame.AnimationController Property

Retrieves the animation controller.

Definition

Visual Basic | Public ReadOnly Property AnimationController As AnimationController
C# | public AnimationController AnimationController { get; }
C++ public:
property AnimationController^ AnimationController {
AnimationController^ get();
}
JScript | public function get AnimationController() : AnimationController

Property Value

Microsoft.DirectX.Direct3D.AnimationController
The AnimationController object.

This property is read-only.

Remarks

Animations loaded from a DirectX (.x) file have an AnimationController object that corresponds to the animation in the .x file. The controller is created with default maximum tracks and events.

See Also

  • LoadHierarchyFromFile


AnimationRootFrame.FrameHierarchy Property (Microsoft.DirectX.Direct3D)

AnimationRootFrame.FrameHierarchy Property

Retrieves the root node reference of the loaded frame hierarchy.

Definition

Visual Basic | Public ReadOnly Property FrameHierarchy As Frame
C# | public Frame FrameHierarchy { get; }
C++ public:
property Frame^ FrameHierarchy {
Frame^ get();
}
JScript | public function get FrameHierarchy() : Frame

Property Value

Microsoft.DirectX.Direct3D.Frame
A Frame object that represents the root node of the frame hierarchy.

This property is read-only.


AttributeRange Structure (Microsoft.DirectX.Direct3D)

AttributeRange Structure

Stores an attribute table entry.

Definition

Visual Basic | Public Structure AttributeRange
C# | public struct AttributeRange
C++ | public value class AttributeRange sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AttributeRange | Creates a new instance of the AttributeRange structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AttributeId | Retrieves or sets the attribute table identifier.
FaceCount | Retrieves or sets the number of faces included in an attribute table entry.
FaceStart | Retrieves or sets the first face in an attribute group.
VertexCount | Retrieves or sets the number of vertices in the attribute group.
VertexStart | Retrieves or sets the first vertex in an attribute group.

Remarks

An attribute table is used to identify areas of the mesh that need to be drawn with different textures, render states, and materials. In addition, an application can use the attribute table to hide portions of a mesh by not drawing a given attribute identifier (AttributeRange.AttribId) when it draws the frame. Attribute tables also can be used to identify application-defined areas of a mesh that are handled by custom code.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • BaseMesh.DrawSubset


AttributeRange.AttributeRange() Constructor (Microsoft.DirectX.Direct3D)

AttributeRange.AttributeRange Constructor

Creates a new instance of the AttributeRange structure.

Definition

Visual Basic | Public Sub New()
C# | public AttributeRange();
C++ public:
AttributeRange();
JScript | public function AttributeRange();


AttributeRange.ToString() Method (Microsoft.DirectX.Direct3D)

AttributeRange.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


AttributeRange.AttributeId Property (Microsoft.DirectX.Direct3D)

AttributeRange.AttributeId Property

Retrieves or sets the attribute table identifier.

Definition

Visual Basic | Public Property AttributeId As Integer
C# | public int AttributeId { get; set; }
C++ public:
property int AttributeId {
int get();
void set(int value);
}
JScript public function get AttributeId() : int
public function set AttributeId(int);

Property Value

System.Int32
An Int32 Leave Site value that specifies the number used to identify the attribute table entry.

This property is read/write.

Remarks

An attribute table is used to identify areas of the mesh that need to be drawn with different textures, render states, and materials. In addition, an application can use the attribute table to hide portions of a mesh by not drawing a given attribute identifier (attributeID) when it draws the frame. Attribute tables also can be used to identify application-defined areas of a mesh that are handled by custom code.

See Also

  • BaseMesh.DrawSubset

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


AttributeRange.FaceCount Property (Microsoft.DirectX.Direct3D)

AttributeRange.FaceCount Property

Retrieves or sets the number of faces included in an attribute table entry.

Definition

Visual Basic | Public Property FaceCount As Integer
C# | public int FaceCount { get; set; }
C++ public:
property int FaceCount {
int get();
void set(int value);
}
JScript public function get FaceCount() : int
public function set FaceCount(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of faces in the attribute range.

This property is read/write.


AttributeRange.FaceStart Property (Microsoft.DirectX.Direct3D)

AttributeRange.FaceStart Property

Retrieves or sets the first face in an attribute group.

Definition

Visual Basic | Public Property FaceStart As Integer
C# | public int FaceStart { get; set; }
C++ public:
property int FaceStart {
int get();
void set(int value);
}
JScript public function get FaceStart() : int
public function set FaceStart(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the index of the first face in the attribute group.

This property is read/write.


AttributeRange.VertexCount Property (Microsoft.DirectX.Direct3D)

AttributeRange.VertexCount Property

Retrieves or sets the number of vertices in the attribute group.

Definition

Visual Basic | Public Property VertexCount As Integer
C# | public int VertexCount { get; set; }
C++ public:
property int VertexCount {
int get();
void set(int value);
}
JScript public function get VertexCount() : int
public function set VertexCount(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of vertices in the attribute group.

This property is read/write.


AttributeRange.VertexStart Property (Microsoft.DirectX.Direct3D)

AttributeRange.VertexStart Property

Retrieves or sets the first vertex in an attribute group.

Definition

Visual Basic | Public Property VertexStart As Integer
C# | public int VertexStart { get; set; }
C++ public:
property int VertexStart {
int get();
void set(int value);
}
JScript public function get VertexStart() : int
public function set VertexStart(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the index of the first vertex in the attribute group.

This property is read/write.


AttributeWeights Structure (Microsoft.DirectX.Direct3D)

AttributeWeights Structure

Specifies mesh weight attributes.

Definition

Visual Basic | Public Structure AttributeWeights
C# | public struct AttributeWeights
C++ | public value class AttributeWeights sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
AttributeWeights | Creates a new instance of the AttributeWeights structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Binormal | Retrieves or sets a numerical value that indicates the degree to which binormal data is used in simplification operations.
Boundary | Retrieves or sets a numerical value that indicates the degree to which boundary data is used in simplification operations.
Diffuse | Retrieves or sets a numerical value that indicates the degree to which diffuse data is used in simplification operations.
Normal | Retrieves or sets a numerical value that indicates the degree to which normal data is used in simplification operations.
Position | Retrieves or sets a numerical value that indicates the degree to which position data is used in simplification operations.
Specular | Retrieves or sets a numerical value that indicates the degree to which specular data is used in simplification operations.
Tangent | Retrieves or sets a numerical value that indicates the degree to which tangent data is used in simplification operations.
TextureCoordinate | Retrieves or sets a numerical value that indicates the degree to which texture coordinate data is used in simplification operations.

Remarks

This structure describes how a simplification operation considers vertex data when calculating relative costs between collapsing edges. For example, if the Normal field is 0.0, the simplification operation ignores the vertex normal component when it calculates the error for the collapse. However, if the Normal field is 1.0, the simplification operation uses the vertex normal component. If the Normal field is 2.0, double the amount of errors; if the Binormal field is 4.0, quadruple the number of errors, and so on.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.AttributeWeights() Constructor (Microsoft.DirectX.Direct3D)

AttributeWeights.AttributeWeights Constructor

Creates a new instance of the AttributeWeights structure.

Definition

Visual Basic | Public Sub New()
C# | public AttributeWeights();
C++ public:
AttributeWeights();
JScript | public function AttributeWeights();


AttributeWeights.ToString() Method (Microsoft.DirectX.Direct3D)

AttributeWeights.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


AttributeWeights.Binormal Property (Microsoft.DirectX.Direct3D)

AttributeWeights.Binormal Property

Retrieves or sets a numerical value that indicates the degree to which binormal data is used in simplification operations.

Definition

Visual Basic | Public Property Binormal As Single
C# | public float Binormal { get; set; }
C++ public:
property float Binormal {
float get();
void set(float value);
}
JScript public function get Binormal() : float
public function set Binormal(float);

Property Value

System.Single
A Single Leave Site value that indicates the degree to which binormal data is used in simplification operations.

This property is read/write.

Remarks

If the Binormal field is 0.0, the simplification operation ignores the vertex binormal component when it calculates the error for collapsing the edges of a mesh. However, if the Binormal field is 1.0, the simplification operation uses the vertex binormal component. If the Binormal field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Boundary Property (Microsoft.DirectX.Direct3D)

AttributeWeights.Boundary Property

Retrieves or sets a numerical value that indicates the degree to which boundary data is used in simplification operations.

Definition

Visual Basic | Public Property Boundary As Single
C# | public float Boundary { get; set; }
C++ public:
property float Boundary {
float get();
void set(float value);
}
JScript public function get Boundary() : float
public function set Boundary(float);

Property Value

System.Single
A Single Leave Site value that indicates the degree to which boundary data is used in simplification operations.

This property is read/write.

Remarks

If the Boundary field is 0.0, the simplification operation ignores the boundary component when it calculates the error for collapsing the edges of a mesh. However, if the Boundary field is 1.0, the simplification operation uses the boundary component. If the Boundary field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Diffuse Property (Microsoft.DirectX.Direct3D)

AttributeWeights.Diffuse Property

Retrieves or sets a numerical value that indicates the degree to which diffuse data is used in simplification operations.

Definition

Visual Basic | Public Property Diffuse As Single
C# | public float Diffuse { get; set; }
C++ public:
property float Diffuse {
float get();
void set(float value);
}
JScript public function get Diffuse() : float
public function set Diffuse(float);

Property Value

System.Single
A Single Leave Site value that indicates the degree to which diffuse data is used in simplification operations.

This property is read/write.

Remarks

If the Diffuse field is 0.0, the simplification operation ignores the diffuse component when it calculates the error for collapsing the edges of a mesh. However, if the Diffuse field is 1.0, the simplification operation uses the diffuse component. If the Diffuse field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Normal Property (Microsoft.DirectX.Direct3D)

AttributeWeights.Normal Property

Retrieves or sets a numerical value that indicates the degree to which normal data is used in simplification operations.

Definition

Visual Basic | Public Property Normal As Single
C# | public float Normal { get; set; }
C++ public:
property float Normal {
float get();
void set(float value);
}
JScript public function get Normal() : float
public function set Normal(float);

Property Value

System.Single
A Single Leave Site value that indicates the degree to which normal data is used in simplification operations.

This property is read/write.

Remarks

This structure describes how a simplification operation considers vertex data when calculating relative costs between collapsing edges. For example, if the Normal field is 0.0, the simplification operation ignores the vertex normal component when it calculates the error for the collapse. However, if the Normal field is 1.0, the simplification operation uses the vertex normal component. If the Normal field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Position Property (Microsoft.DirectX.Direct3D)

AttributeWeights.Position Property

Retrieves or sets a numerical value that indicates the degree to which position data is used in simplification operations.

Definition

Visual Basic | Public Property Position As Single
C# | public float Position { get; set; }
C++ public:
property float Position {
float get();
void set(float value);
}
JScript public function get Position() : float
public function set Position(float);

Property Value

System.Single
A Single Leave Site value that indicates the degree to which position data is used in simplification operations.

This property is read/write.

Remarks

If the Position field is 0.0, the simplification operation ignores the position component when it calculates the error for collapsing the edges of a mesh. However, if the Position field is 1.0, the simplification operation uses the position component. If the Position field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Specular Property (Microsoft.DirectX.Direct3D)

AttributeWeights.Specular Property

Retrieves or sets a numerical value that indicates the degree to which specular data is used in simplification operations.

Definition

Visual Basic | Public Property Specular As Single
C# | public float Specular { get; set; }
C++ public:
property float Specular {
float get();
void set(float value);
}
JScript public function get Specular() : float
public function set Specular(float);

Property Value

System.Single
A Single Leave Site value that indicates the degree to which specular data is used in simplification operations.

This property is read/write.

Remarks

If the Specular field is 0.0, the simplification operation ignores the specular component when it calculates the error for collapsing the edges of a mesh. However, if the Specular field is 1.0, the simplification operation uses the specular component. If the Specular field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.Tangent Property (Microsoft.DirectX.Direct3D)

AttributeWeights.Tangent Property

Retrieves or sets a numerical value that indicates the degree to which tangent data is used in simplification operations.

Definition

Visual Basic | Public Property Tangent As Single
C# | public float Tangent { get; set; }
C++ public:
property float Tangent {
float get();
void set(float value);
}
JScript public function get Tangent() : float
public function set Tangent(float);

Property Value

System.Single
A Single Leave Site value that indicates the degree to which tangent data is used in simplification operations.

This property is read/write.

Remarks

If the Tangent field is 0.0, the simplification operation ignores the tangent component when it calculates the error for collapsing the edges of a mesh. However, if the Tangent field is 1.0, the simplification operation uses the tangent component. If the Tangent field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


AttributeWeights.TextureCoordinate Property (Microsoft.DirectX.Direct3D)

AttributeWeights.TextureCoordinate Property

Retrieves or sets a numerical value that indicates the degree to which texture coordinate data is used in simplification operations.

Definition

Visual Basic | Public Property TextureCoordinate As Single()
C# | public float[] TextureCoordinate { get; set; }
C++ public:
property array<float>^ TextureCoordinate {
array<float>^ get();
void set(array<float>^ value);
}
JScript public function get TextureCoordinate() : float[]
public function set TextureCoordinate(float[]);

Property Value

System.Single[]

This property is read/write.

Remarks

If the TextureCoordinate field is 0.0, the simplification operation ignores the texture coordinate component when it calculates the error for collapsing the edges of a mesh. However, if the TextureCoordinate field is 1.0, the simplification operation uses the texture coordinate component. If the TextureCoordinate field is 2.0, double the amount of errors; if it is 4.0, quadruple the number of errors, and so on.

See Also

  • SimplificationMesh
  • ProgressiveMesh
  • Mesh.Simplify


BandwidthTimings Structure (Microsoft.DirectX.Direct3D)

BandwidthTimings Structure

Provides throughput measurement comparisons for help in understanding the performance of an application.

Definition

Visual Basic | Public Structure BandwidthTimings
C# | public struct BandwidthTimings
C++ | public value class BandwidthTimings sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BandwidthTimings | Creates a new instance of the BandwidthTimings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
FillRateUtilizedPercent | Retrieves the pixel fill throughput percentage. This is the number of pixels that are filled compared to the theoretical pixel fill.
FrontEndUploadMemoryUtilizedPercent | Retrieves the bandwidth or maximum data transfer rate for uploading data from the host GPU to the CPU.
MaxBandwidthUtilized | Retrieves the bandwidth or maximum data transfer rate from the host CPU to the graphics processing unit (GPU). This is typically the bandwidth of the Peripheral Component Interconnect (PCI) or accelerated graphics port (AGP) bus which connects the CPU and the GPU.
TriangleSetupRateUtilizedPercent | Retrieves the triangle set-up throughput percentage. This is the number of triangles that are set-up for rasterization compared to the theoretical maximum triangle set-up rate.
VertexRateUtilizedPercent | Retrieves the vertex throughput percentage. This is the number of vertices processed compared to the theoretical maximum vertex processing rate. A high percentage is the target.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BandwidthTimings.BandwidthTimings() Constructor (Microsoft.DirectX.Direct3D)

BandwidthTimings.BandwidthTimings Constructor

Creates a new instance of the BandwidthTimings structure.

Definition

Visual Basic | Public Sub New()
C# | public BandwidthTimings();
C++ public:
BandwidthTimings();
JScript | public function BandwidthTimings();


BandwidthTimings.ToString() Method (Microsoft.DirectX.Direct3D)

BandwidthTimings.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


BandwidthTimings.FillRateUtilizedPercent Property (Microsoft.DirectX.Direct3D)

BandwidthTimings.FillRateUtilizedPercent Property

Retrieves the pixel fill throughput percentage. This is the number of pixels that are filled compared to the theoretical pixel fill.

Definition

Visual Basic | Public ReadOnly Property FillRateUtilizedPercent As Single
C# | public float FillRateUtilizedPercent { get; }
C++ public:
property float FillRateUtilizedPercent {
float get();
}
JScript | public function get FillRateUtilizedPercent() : float

Property Value

System.Single
A Single Leave Site value that represents the pixel fill throughput percentage.

This property is read-only.


BandwidthTimings.FrontEndUploadMemoryUtilizedPercent Property (Microsoft.DirectX.Direct3D)

BandwidthTimings.FrontEndUploadMemoryUtilizedPercent Property

Language:

Retrieves the bandwidth or maximum data transfer rate for uploading data from the host graphics processing unit (GPU) to the CPU.

Definition

Visual Basic | Public ReadOnly Property FrontEndUploadMemoryUtilizedPercent As Single
C# | public float FrontEndUploadMemoryUtilizedPercent { get; }
C++ public:
property float FrontEndUploadMemoryUtilizedPercent {
float get();
}
JScript | public function get FrontEndUploadMemoryUtilizedPercent() : float

Property Value

System.Single
A Single Leave Site value that represents the bandwidth or maximum data transfer rate for uploading data from the host GPU to the CPU.

This property is read-only.


BandwidthTimings.MaxBandwidthUtilized Property (Microsoft.DirectX.Direct3D)

BandwidthTimings.MaxBandwidthUtilized Property

Retrieves the bandwidth or maximum data transfer rate from the host CPU to the graphics processing unit (GPU). This is typically the bandwidth of the Peripheral Component Interconnect (PCI) or accelerated graphics port (AGP) bus which connects the CPU and the GPU.

Definition

Visual Basic | Public ReadOnly Property MaxBandwidthUtilized As Single
C# | public float MaxBandwidthUtilized { get; }
C++ public:
property float MaxBandwidthUtilized {
float get();
}
JScript | public function get MaxBandwidthUtilized() : float

Property Value

System.Single
A Single Leave Site value that represents the bandwidth or maximum data transfer rate from the host CPU to the GPU.

This property is read-only.


BandwidthTimings.TriangleSetupRateUtilizedPercent Property (Microsoft.DirectX.Direct3D)

BandwidthTimings.TriangleSetupRateUtilizedPercent Property

Retrieves the triangle set-up throughput percentage. This is the number of triangles that are set-up for rasterization compared to the theoretical maximum triangle set-up rate.

Definition

Visual Basic | Public ReadOnly Property TriangleSetupRateUtilizedPercent As Single
C# | public float TriangleSetupRateUtilizedPercent { get; }
C++ public:
property float TriangleSetupRateUtilizedPercent {
float get();
}
JScript | public function get TriangleSetupRateUtilizedPercent() : float

Property Value

System.Single
A Single Leave Site value that represents the triangle set-up throughput percentage.

This property is read-only.


BandwidthTimings.VertexRateUtilizedPercent Property (Microsoft.DirectX.Direct3D)

BandwidthTimings.VertexRateUtilizedPercent Property

Retrieves the vertex throughput percentage. This is the number of vertices processed compared to the theoretical maximum vertex processing rate. A high percentage is the target.

Definition

Visual Basic | Public ReadOnly Property VertexRateUtilizedPercent As Single
C# | public float VertexRateUtilizedPercent { get; }
C++ public:
property float VertexRateUtilizedPercent {
float get();
}
JScript | public function get VertexRateUtilizedPercent() : float

Property Value

System.Single
A Single Leave Site value that represents the vertex throughput percentage.

This property is read-only.


BehaviorFlags Structure (Microsoft.DirectX.Direct3D)

BehaviorFlags Structure

Contains a set of properties that indicate the global behavior of a device.

Definition

Visual Basic | Public Structure BehaviorFlags
C# | public struct BehaviorFlags
C++ | public value class BehaviorFlags sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BehaviorFlags | Creates a new instance of the BehaviorFlags structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AdapterGroupDevice | Retrieves a value that indicates whether the device should drive all of the heads that the master adapter owns.
DisableDriverManagement | Retrieves a value that indicates whether Direct3D, rather than the driver, manages resources.
FpuPreserve | Retrieves a value that indicates whether floating-point unit (FPU) exceptions or double-precision FPU exceptions are enabled in an application.
HardwareVertexProcessing | Retrieves a value that indicates whether hardware vertex processing is enabled.
MixedVertexProcessing | Retrieves a value that indicates whether mixed vertex processing (for both software and hardware) is enabled.
MultiThreaded | Retrieves a value that indicates whether Microsoft Direct3D is set to be multithread safe.
PureDevice | Retrieves a value that indicates whether Direct3D supports Get calls for anything that can be stored in a state block. This value also indicates whether Direct3D is withholding emulation services for vertex processing.
SoftwareVertexProcessing | Retrieves a value that specifies whether software vertex processing is being used.
Value | Retrieves or sets one or more CreateFlags values.

Remarks

The values in the BehaviorFlags structure mirror the creation options used to create the device.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BehaviorFlags.BehaviorFlags Constructor ()

Creates a new instance of the BehaviorFlags structure.

Overload List

public BehaviorFlags();
public BehaviorFlags(CreateFlags);
public BehaviorFlags(CreateFlags[]);


BehaviorFlags.BehaviorFlags(CreateFlags[]) Constructor (Microsoft.DirectX.Direct3D)

BehaviorFlags.BehaviorFlags Constructor

Creates a new instance of the BehaviorFlags structure.

Definition

Visual Basic Public Sub New( _
ByVal newBehavior() As CreateFlags _
)
C# public BehaviorFlags(
CreateFlags[] newBehavior
);
C++ public:
BehaviorFlags(
array<CreateFlags>^ newBehavior
);
JScript public function BehaviorFlags(
newBehavior : CreateFlags[]
);

Parameters

newBehavior Microsoft.DirectX.Direct3D.CreateFlags[]
Array of CreateFlags that indicate the initial values with which to set the BehaviorFlags properties.


BehaviorFlags.BehaviorFlags(CreateFlags) Constructor (Microsoft.DirectX.Direct3D)

BehaviorFlags.BehaviorFlags Constructor

Creates a new instance of the BehaviorFlags structure.

Definition

Visual Basic Public Sub New( _
ByVal initialBehavior As CreateFlags _
)
C# public BehaviorFlags(
CreateFlags initialBehavior
);
C++ public:
BehaviorFlags(
CreateFlags initialBehavior
);
JScript public function BehaviorFlags(
initialBehavior : CreateFlags
);

Parameters

initialBehavior Microsoft.DirectX.Direct3D.CreateFlags
A combination of CreateFlags that indicate the initial values with which to set the BehaviorFlags properties.


BehaviorFlags.BehaviorFlags() Constructor (Microsoft.DirectX.Direct3D)

BehaviorFlags.BehaviorFlags Constructor

Creates a new instance of the BehaviorFlags structure.

Definition

Visual Basic | Public Sub New()
C# | public BehaviorFlags();
C++ public:
BehaviorFlags();
JScript | public function BehaviorFlags();


BehaviorFlags.ToString() Method (Microsoft.DirectX.Direct3D)

BehaviorFlags.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


BehaviorFlags.AdapterGroupDevice Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.AdapterGroupDevice Property

Retrieves a value that indicates whether the device should drive all of the heads that the master adapter owns.

Definition

Visual Basic | Public ReadOnly Property AdapterGroupDevice As Boolean
C# | public bool AdapterGroupDevice { get; }
C++ public:
property bool AdapterGroupDevice {
bool get();
}
JScript | public function get AdapterGroupDevice() : boolean

Property Value

System.Boolean
Value that is true if the device drives all of the heads the master adapter owns, or false if it does not.

This property is read-only.

See Also

  • CreateFlags.AdapterGroupDevice


BehaviorFlags.DisableDriverManagement Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.DisableDriverManagement Property

Retrieves a value that indicates whether Microsoft Direct3D, rather than the driver, manages resources.

Definition

Visual Basic | Public ReadOnly Property DisableDriverManagement As Boolean
C# | public bool DisableDriverManagement { get; }
C++ public:
property bool DisableDriverManagement {
bool get();
}
JScript | public function get DisableDriverManagement() : boolean

Property Value

System.Boolean
Value that is true if Direct3D manages resources, or false if it does not.

This property is read-only.

See Also

  • CreateFlags.DisableDriverManagement


BehaviorFlags.FpuPreserve Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.FpuPreserve Property

Retrieves a value that indicates whether floating-point unit (FPU) exceptions or double-precision FPU exceptions are enabled in an application.

Definition

Visual Basic | Public ReadOnly Property FpuPreserve As Boolean
C# | public bool FpuPreserve { get; }
C++ public:
property bool FpuPreserve {
bool get();
}
JScript | public function get FpuPreserve() : boolean

Property Value

System.Boolean
Value that is true if FPU exceptions or double-precision FPU exceptions are enabled, or false if they are not.

This property is read-only.

Remarks

If this value is true, Microsoft Direct3D performance can degrade.

See Also

  • CreateFlags.FpuPreserve


BehaviorFlags.HardwareVertexProcessing Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.HardwareVertexProcessing Property

Retrieves a value that indicates whether hardware vertex processing is enabled.

Definition

Visual Basic | Public ReadOnly Property HardwareVertexProcessing As Boolean
C# | public bool HardwareVertexProcessing { get; }
C++ public:
property bool HardwareVertexProcessing {
bool get();
}
JScript | public function get HardwareVertexProcessing() : boolean

Property Value

System.Boolean
Value that is true if hardware vertex processing is enabled, or false if it is not.

This property is read-only.

See Also

  • CreateFlags.HardwareVertexProcessing


BehaviorFlags.MixedVertexProcessing Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.MixedVertexProcessing Property

Retrieves a value that indicates whether mixed vertex processing (for both software and hardware) is enabled.

Definition

Visual Basic | Public ReadOnly Property MixedVertexProcessing As Boolean
C# | public bool MixedVertexProcessing { get; }
C++ public:
property bool MixedVertexProcessing {
bool get();
}
JScript | public function get MixedVertexProcessing() : boolean

Property Value

System.Boolean
Value that is true if mixed vertex processing is enabled, or false if it is not.

This property is read-only.

See Also

  • CreateFlags.MixedVertexProcessing


BehaviorFlags.MultiThreaded Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.MultiThreaded Property

Retrieves a value that indicates whether Microsoft Direct3D is set to be multithread safe.

Definition

Visual Basic | Public ReadOnly Property MultiThreaded As Boolean
C# | public bool MultiThreaded { get; }
C++ public:
property bool MultiThreaded {
bool get();
}
JScript | public function get MultiThreaded() : boolean

Property Value

System.Boolean
Value that is true if Direct3D is set to be multithread safe, or false if it is not.

This property is read-only.

Remarks

An application with Direct3D set to be safe for multithreading might experience degraded performance.

See Also

  • CreateFlags.MultiThreaded


BehaviorFlags.PureDevice Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.PureDevice Property

Retrieves a value that indicates whether Microsoft Direct3D supports Get calls for anything that can be stored in a state block. This value also indicates whether Direct3D is withholding emulation services for vertex processing.

Definition

Visual Basic | Public ReadOnly Property PureDevice As Boolean
C# | public bool PureDevice { get; }
C++ public:
property bool PureDevice {
bool get();
}
JScript | public function get PureDevice() : boolean

Property Value

System.Boolean
Value that is true if Direct3D does not support Get calls for anything that can be stored in a state block. A true value also indicates that Direct3D is withholding emulation services for vertex processing. If Get calls are supported and Direct3D is not withholding emulation services, the value is false.

This property is read-only.

Remarks

If the device is withholding emulation services for vertex processing, it does not support vertex processing, and the application can use only post-transformed vertices.

See Also

  • CreateFlags.PureDevice
  • StateBlock


BehaviorFlags.SoftwareVertexProcessing Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.SoftwareVertexProcessing Property

Retrieves a value that specifies whether software vertex processing is being used.

Definition

Visual Basic | Public ReadOnly Property SoftwareVertexProcessing As Boolean
C# | public bool SoftwareVertexProcessing { get; }
C++ public:
property bool SoftwareVertexProcessing {
bool get();
}
JScript | public function get SoftwareVertexProcessing() : boolean

Property Value

System.Boolean
Value that is true if software vertex processing is in use, or false if it is not.

This property is read-only.

See Also

  • CreateFlags.SoftwareVertexProcessing


BehaviorFlags.Value Property (Microsoft.DirectX.Direct3D)

BehaviorFlags.Value Property

Retrieves or sets one or more CreateFlags values.

Definition

Visual Basic | Public Property Value As CreateFlags
C# | public CreateFlags Value { get; set; }
C++ public:
property CreateFlags Value {
CreateFlags get();
void set(CreateFlags value);
}
JScript public function get Value() : CreateFlags
public function set Value(CreateFlags);

Property Value

Microsoft.DirectX.Direct3D.CreateFlags
One or more CreateFlags values that reflect the values of the other BehaviorFlags properties.

This property is read/write.

See Also

  • CreateFlags


BlendCaps Structure (Microsoft.DirectX.Direct3D)

BlendCaps Structure

Indicates the supported capabilities.

Definition

Visual Basic | Public Structure BlendCaps
C# | public struct BlendCaps
C++ | public value class BlendCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsBlendFactor | Indicates that the driver supports the BlendFactor and InvBlendFactor constants.
SupportsBothInverseSourceAlpha | Indicates that the driver supports a in which the source blend factor is (1 - As, 1 - As, 1 - As, 1 - As), the destination blend factor is (As, As, As, As), and the destination blend selection is overridden.
SupportsBothSourceAlpha | Indicates that the driver supports the SourceAlpha and InvSourceAlpha blend modes. The SupportsBothSourceAlpha blend mode is obsolete. To achieve the same effect, set the source and destination blend factors to Blend.SourceAlpha and Blend.InvSourceAlpha in separate calls.
SupportsDestinationAlpha | Indicates that the driver supports the DestinationAlpha blend mode.
SupportsDestinationColor | Indicates that the driver supports the DestinationColor blend mode.
SupportsInverseDestinationAlpha | Indicates that the driver supports the InvDestinationAlpha blend mode.
SupportsInverseDestinationColor | Indicates that the driver supports the InvDestinationColor blend mode.
SupportsInverseSourceAlpha | Indicates that the driver supports the InvSourceAlpha blend mode.
SupportsInverseSourceColor | Indicates that the driver supports the InvSourceColor blend mode.
SupportsOne | Indicates that the driver supports the One blend mode.
SupportsSourceAlpha | Indicates that the driver supports the SourceAlpha blend mode.
SupportsSourceAlphaSat | Indicates that the driver supports the SourceAlphaSat blend mode.
SupportsSourceColor | Indicates that the driver supports the SourceColor blend mode.
SupportsZero | Indicates that the driver supports the Zero blend mode.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BlendCaps.ToString() Method (Microsoft.DirectX.Direct3D)

BlendCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


BlendCaps.SupportsBlendFactor Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsBlendFactor Property

Indicates that the driver supports the BlendFactor and InvBlendFactor constants.

Definition

Visual Basic | Public ReadOnly Property SupportsBlendFactor As Boolean
C# | public bool SupportsBlendFactor { get; }
C++ public:
property bool SupportsBlendFactor {
bool get();
}
JScript | public function get SupportsBlendFactor() : boolean

Property Value

System.Boolean
Value that is true if the driver supports BlendFactor and InvBlendFactor.

This property is read-only.


BlendCaps.SupportsBothInverseSourceAlpha Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsBothInverseSourceAlpha Property

Indicates that the driver supports a in which the source blend factor is (1 - As, 1 - As, 1 - As, 1 - As), the destination blend factor is (As, As, As, As), and the destination blend selection is overridden.

Definition

Visual Basic | Public ReadOnly Property SupportsBothInverseSourceAlpha As Boolean
C# | public bool SupportsBothInverseSourceAlpha { get; }
C++ public:
property bool SupportsBothInverseSourceAlpha {
bool get();
}
JScript | public function get SupportsBothInverseSourceAlpha() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the SupportsBothInverseSourceAlpha blend mode, or false if it does not.

This property is read-only.

See Also

  • Blend


BlendCaps.SupportsBothSourceAlpha Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsBothSourceAlpha Property

Indicates that the driver supports the SourceAlpha and InvSourceAlpha blend modes. The SupportsBothSourceAlpha blend mode is obsolete. To achieve the same effect, set the source and destination blend factors to Blend.SourceAlpha and Blend.InvSourceAlpha in separate calls.

Definition

Visual Basic | Public ReadOnly Property SupportsBothSourceAlpha As Boolean
C# | public bool SupportsBothSourceAlpha { get; }
C++ public:
property bool SupportsBothSourceAlpha {
bool get();
}
JScript | public function get SupportsBothSourceAlpha() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the SourceAlpha and InvSourceAlpha blend modes, or false if it does not.

This property is read-only.


BlendCaps.SupportsDestinationAlpha Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsDestinationAlpha Property

Indicates that the driver supports the DestinationAlpha blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsDestinationAlpha As Boolean
C# | public bool SupportsDestinationAlpha { get; }
C++ public:
property bool SupportsDestinationAlpha {
bool get();
}
JScript | public function get SupportsDestinationAlpha() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the DestinationAlpha blend mode, or false if it does not.

This property is read-only.

Remarks

The DestinationAlpha blend factor is (Ad, Ad, Ad, Ad), where Ad is the destination alpha value.


BlendCaps.SupportsDestinationColor Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsDestinationColor Property

Indicates that the driver supports the DestinationColor blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsDestinationColor As Boolean
C# | public bool SupportsDestinationColor { get; }
C++ public:
property bool SupportsDestinationColor {
bool get();
}
JScript | public function get SupportsDestinationColor() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the DestinationColor blend mode, or false if it does not.

This property is read-only.

Remarks

The DestinationColor blend factor is (Rd, Gd, Bd, Ad), where R, G, B, and A respectively stand for red, green, blue, and alpha destination values.


BlendCaps.SupportsInverseDestinationAlpha Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsInverseDestinationAlpha Property

Indicates that the driver supports the InvDestinationAlpha blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsInverseDestinationAlpha As Boolean
C# | public bool SupportsInverseDestinationAlpha { get; }
C++ public:
property bool SupportsInverseDestinationAlpha {
bool get();
}
JScript | public function get SupportsInverseDestinationAlpha() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the InvDestinationAlpha blend mode, or false if it does not.

This property is read-only.

Remarks

The InvDestinationAlpha blend factor is (1 - Ad, 1 - Ad, 1 - Ad, 1 - Ad), where Ad is the alpha destination value.


BlendCaps.SupportsInverseDestinationColor Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsInverseDestinationColor Property

Indicates that the driver supports the InvDestinationColor blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsInverseDestinationColor As Boolean
C# | public bool SupportsInverseDestinationColor { get; }
C++ public:
property bool SupportsInverseDestinationColor {
bool get();
}
JScript | public function get SupportsInverseDestinationColor() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the InvDestinationColor blend mode, or false if it does not.

This property is read-only.

Remarks

The InvDestinationColor blend factor is (1 - Rd, 1 - Gd, 1 - Bd, 1 - Ad), where Rd, Gd, Bd, and Ad respectively stand for the red, green, blue, and alpha destination values.


BlendCaps.SupportsInverseSourceAlpha Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsInverseSourceAlpha Property

Indicates that the driver supports the InvSourceAlpha blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsInverseSourceAlpha As Boolean
C# | public bool SupportsInverseSourceAlpha { get; }
C++ public:
property bool SupportsInverseSourceAlpha {
bool get();
}
JScript | public function get SupportsInverseSourceAlpha() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the InvSourceAlpha blend mode, or false if it does not.

This property is read-only.

Remarks

The InvSourceAlpha blend factor is ( 1 - As, 1 - As, 1 - As, 1 - As), where As is the alpha destination value.


BlendCaps.SupportsInverseSourceColor Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsInverseSourceColor Property

Indicates that the driver supports the InvSourceColor blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsInverseSourceColor As Boolean
C# | public bool SupportsInverseSourceColor { get; }
C++ public:
property bool SupportsInverseSourceColor {
bool get();
}
JScript | public function get SupportsInverseSourceColor() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the InvSourceColor blend mode, or false if it does not.

This property is read-only.

Remarks

The InvSourceColor blend factor is (1 - Rs, 1 - Gs, 1 - Bs, 1 - As) where R, G, B, and A respectively stand for the red, green, blue, and alpha destination values.


BlendCaps.SupportsOne Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsOne Property

Indicates that the driver supports the One blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsOne As Boolean
C# | public bool SupportsOne { get; }
C++ public:
property bool SupportsOne {
bool get();
}
JScript | public function get SupportsOne() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the One blend mode, or false if it does not.

This property is read-only.

Remarks

The InvSourceColor blend factor is (1, 1, 1, 1).


BlendCaps.SupportsSourceAlpha Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsSourceAlpha Property

Indicates that the driver supports the SourceAlpha blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsSourceAlpha As Boolean
C# | public bool SupportsSourceAlpha { get; }
C++ public:
property bool SupportsSourceAlpha {
bool get();
}
JScript | public function get SupportsSourceAlpha() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the SourceAlpha blend mode, or false if it does not.

This property is read-only.

Remarks

The SourceAlpha blend factor is (As, As, As, As), where As is the alpha source value.


BlendCaps.SupportsSourceAlphaSat Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsSourceAlphaSat Property

Indicates that the driver supports the SourceAlphaSat blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsSourceAlphaSat As Boolean
C# | public bool SupportsSourceAlphaSat { get; }
C++ public:
property bool SupportsSourceAlphaSat {
bool get();
}
JScript | public function get SupportsSourceAlphaSat() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the SourceAlphaSat blend mode, or false if it does not.

This property is read-only.

Remarks

The SourceAlphaSat blend factor is (f, f, f, 1), where f = min(A, 1 - Ad).


BlendCaps.SupportsSourceColor Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsSourceColor Property

Indicates that the driver supports the SourceColor blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsSourceColor As Boolean
C# | public bool SupportsSourceColor { get; }
C++ public:
property bool SupportsSourceColor {
bool get();
}
JScript | public function get SupportsSourceColor() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the SourceColor blend mode, or false if it does not.

This property is read-only.

Remarks

The SourceColor blend factor is (Rs, Gs, Bs, As), where R, G, B, and A respectively stand for the red, green, blue, and alpha source values.


BlendCaps.SupportsZero Property (Microsoft.DirectX.Direct3D)

BlendCaps.SupportsZero Property

Indicates that the driver supports the Zero blend mode.

Definition

Visual Basic | Public ReadOnly Property SupportsZero As Boolean
C# | public bool SupportsZero { get; }
C++ public:
property bool SupportsZero {
bool get();
}
JScript | public function get SupportsZero() : boolean

Property Value

System.Boolean
Value that is true if the driver supports the Zero blend mode, or false if it does not.

This property is read-only.

Remarks

The Zero blend factor is (0, 0, 0, 0).


BoneCombination Structure (Microsoft.DirectX.Direct3D)

BoneCombination Structure

Describes a subset of the mesh that has the same attribute and bone combination.

Definition

Visual Basic | Public Structure BoneCombination
C# | public struct BoneCombination
C++ | public value class BoneCombination sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BoneCombination | Creates a new instance of the BoneCombination structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AttributeId | Retrieves or sets the attribute table identifier.
BoneId | Retrieves or sets an array of values that identify each of the bones that can be drawn in a single drawing call.
FaceCount | Retrieves or sets the face count for the bone combination.
FaceStart | Retrieves or sets the starting face for the bone combination.
VertexCount | Retrieves or sets the vertex count of the bone combination.
VertexStart | Retrieves or sets the starting vertex in the bone combination.

Remarks

The subset of the mesh that BoneCombination describes can be rendered in a single drawing call.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BoneCombination.BoneCombination() Constructor (Microsoft.DirectX.Direct3D)

BoneCombination.BoneCombination Constructor

Creates a new instance of the BoneCombination structure.

Definition

Visual Basic | Public Sub New()
C# | public BoneCombination();
C++ public:
BoneCombination();
JScript | public function BoneCombination();


BoneCombination.ToString() Method (Microsoft.DirectX.Direct3D)

BoneCombination.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


BoneCombination.AttributeId Property (Microsoft.DirectX.Direct3D)

BoneCombination.AttributeId Property

Retrieves or sets the attribute table identifier.

Definition

Visual Basic | Public Property AttributeId As Integer
C# | public int AttributeId { get; set; }
C++ public:
property int AttributeId {
int get();
void set(int value);
}
JScript public function get AttributeId() : int
public function set AttributeId(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the attribute table identifier for the BoneCombination.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


BoneCombination.BoneId Property (Microsoft.DirectX.Direct3D)

BoneCombination.BoneId Property

Retrieves or sets an array of values that identify each of the bones that can be drawn in a single drawing call.

Definition

Visual Basic | Public Property BoneId As Integer()
C# | public int[] BoneId { get; set; }
C++ public:
property array<int>^ BoneId {
array<int>^ get();
void set(array<int>^ value);
}
JScript public function get BoneId() : int[]
public function set BoneId(int[]);

Property Value

System.Int32[]
Array of Int32 Leave Site values that identify the bones that can be drawn in a single drawing call.

This property is read/write.

Remarks

The array can be of variable length to accommodate variable-length bone combinations of SkinInformation.ConvertToIndexedBlendedMesh. The size of the array varies based on the type of mesh generated. A non-indexed mesh array size is equal to the number of weights per vertex. An indexed mesh array size is equal to the number of bone matrix palette entries.


BoneCombination.FaceCount Property (Microsoft.DirectX.Direct3D)

BoneCombination.FaceCount Property

Retrieves or sets the face count for the bone combination.

Definition

Visual Basic | Public Property FaceCount As Integer
C# | public int FaceCount { get; set; }
C++ public:
property int FaceCount {
int get();
void set(int value);
}
JScript public function get FaceCount() : int
public function set FaceCount(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the face count for the bone combination.

This property is read/write.


BoneCombination.FaceStart Property (Microsoft.DirectX.Direct3D)

BoneCombination.FaceStart Property

Retrieves or sets the starting face for the bone combination.

Definition

Visual Basic | Public Property FaceStart As Integer
C# | public int FaceStart { get; set; }
C++ public:
property int FaceStart {
int get();
void set(int value);
}
JScript public function get FaceStart() : int
public function set FaceStart(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the starting face.

This property is read/write.


BoneCombination.VertexCount Property (Microsoft.DirectX.Direct3D)

BoneCombination.VertexCount Property

Retrieves or sets the vertex count of the bone combination.

Definition

Visual Basic | Public Property VertexCount As Integer
C# | public int VertexCount { get; set; }
C++ public:
property int VertexCount {
int get();
void set(int value);
}
JScript public function get VertexCount() : int
public function set VertexCount(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of vertices in the bone combination.

This property is read/write.


BoneCombination.VertexStart Property (Microsoft.DirectX.Direct3D)

BoneCombination.VertexStart Property

Retrieves or sets the starting vertex in the bone combination.

Definition

Visual Basic | Public Property VertexStart As Integer
C# | public int VertexStart { get; set; }
C++ public:
property int VertexStart {
int get();
void set(int value);
}
JScript public function get VertexStart() : int
public function set VertexStart(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the starting vertex.

This property is read/write.


BoneInfluences Structure (Microsoft.DirectX.Direct3D)

BoneInfluences Structure

Describes the vertices and weights that a bone influences.

Definition

Visual Basic | Public Structure BoneInfluences
C# | public struct BoneInfluences
C++ | public value class BoneInfluences sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BoneInfluences | Creates a new instance of the BoneInfluences structure.
GetVertices | Retrieves or sets an array of vertices that are influenced by the bone associated with the current BoneInfluences structure.
GetWeights | Retrieves or sets an array of weights associated with the current BoneInfluences structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BoneInfluences.BoneInfluences() Constructor (Microsoft.DirectX.Direct3D)

BoneInfluences.BoneInfluences Constructor

Creates a new instance of the BoneInfluences structure.

Definition

Visual Basic | Public Sub New()
C# | public BoneInfluences();
C++ public:
BoneInfluences();
JScript | public function BoneInfluences();


BoneInfluences.GetVertices() Method (Microsoft.DirectX.Direct3D)

BoneInfluences.GetVertices Method

Retrieves or sets an array of vertices that are influenced by the bone associated with the current BoneInfluences structure.

Definition

Visual Basic | Public Function GetVertices() As Integer()
C# | public int[] GetVertices();
C++ public:
array<int>^ GetVertices();
JScript | public function GetVertices() : int[];

Return Value

System.Int32[]
Array of Int32 Leave Site values indicating the vertices that are influenced by the bone associated with the current BoneInfluences structure.


BoneInfluences.GetWeights() Method (Microsoft.DirectX.Direct3D)

BoneInfluences.GetWeights Method

Retrieves or sets an array of weights associated with the current BoneInfluences structure.

Definition

Visual Basic | Public Function GetWeights() As Single()
C# | public float[] GetWeights();
C++ public:
array<float>^ GetWeights();
JScript | public function GetWeights() : float[];

Return Value

System.Single[]
Array of Single Leave Site values indicating the weight values that the bone exerts on the vertices associated with the current BoneInfluences structure.


Box Structure (Microsoft.DirectX.Direct3D)

Box Structure

Defines a volume.

Definition

Visual Basic | Public Structure Box
C# | public struct Box
C++ | public value class Box sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Box | Creates a new instance of the Box structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Back | Retrieves or sets the position of the back of a box on the z-axis.
Bottom | Retrieves or sets the position of the bottom of a box on the y-axis.
Front | Retrieves or sets the position of the front of a box on the z-axis.
Left | Retrieves or sets the position of the left side of a box on the x-axis.
Right | Retrieves or sets the position of the right side of a box on the x-axis.
Top | Retrieves or sets the position of the top of a box on the y-axis.

Remarks

The Box structure includes the left, top, and front edges, but not the right, bottom, or back edges. For example, a box that is 100 units wide and begins at 0 (thus, including the points up to and including 99) would be expressed with a value of 0 for the Left member and a value of 100 for the Right member. Note that a value of 99 is not used for the Right member.

The restrictions on side ordering for Box are left to right, top to bottom, and front to back.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Box.Box() Constructor (Microsoft.DirectX.Direct3D)

Box.Box Constructor

Creates a new instance of the Box structure.

Definition

Visual Basic | Public Sub New()
C# | public Box();
C++ public:
Box();
JScript | public function Box();


Box.ToString() Method (Microsoft.DirectX.Direct3D)

Box.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Box.Back Property (Microsoft.DirectX.Direct3D)

Box.Back Property

Retrieves or sets the position of the back of a box on the z-axis.

Definition

Visual Basic | Public Property Back As Integer
C# | public int Back { get; set; }
C++ public:
property int Back {
int get();
void set(int value);
}
JScript public function get Back() : int
public function set Back(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the position of the back of the box.

This property is read/write.

Remarks

This value indicates the distance of the back from the front of the box on the z-axis.


Box.Bottom Property (Microsoft.DirectX.Direct3D)

Box.Bottom Property

Retrieves or sets the position of the bottom of a box on the y-axis.

Definition

Visual Basic | Public Property Bottom As Integer
C# | public int Bottom { get; set; }
C++ public:
property int Bottom {
int get();
void set(int value);
}
JScript public function get Bottom() : int
public function set Bottom(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the position of the bottom of the box.

This property is read/write.

Remarks

This value indicates the distance of the bottom from the top of the box on the y-axis.


Box.Front Property (Microsoft.DirectX.Direct3D)

Box.Front Property

Retrieves or sets the position of the front of a box on the z-axis.

Definition

Visual Basic | Public Property Front As Integer
C# | public int Front { get; set; }
C++ public:
property int Front {
int get();
void set(int value);
}
JScript public function get Front() : int
public function set Front(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the position of the front of the box on the z-axis.

This property is read/write.


Box.Left Property (Microsoft.DirectX.Direct3D)

Box.Left Property

Retrieves or sets the position of the left side of a box on the x-axis.

Definition

Visual Basic | Public Property Left As Integer
C# | public int Left { get; set; }
C++ public:
property int Left {
int get();
void set(int value);
}
JScript public function get Left() : int
public function set Left(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the position of the left side of the box.

This property is read/write.


Box.Right Property (Microsoft.DirectX.Direct3D)

Box.Right Property

Retrieves or sets the position of the right side of a box on the x-axis.

Definition

Visual Basic | Public Property Right As Integer
C# | public int Right { get; set; }
C++ public:
property int Right {
int get();
void set(int value);
}
JScript public function get Right() : int
public function set Right(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the right side of the box on the x-axis.

This property is read/write.

Remarks

This value indicates the distance of the right side from the left side of the box on the x-axis.


Box.Top Property (Microsoft.DirectX.Direct3D)

Box.Top Property

Retrieves or sets the position of the top of a box on the y-axis.

Definition

Visual Basic | Public Property Top As Integer
C# | public int Top { get; set; }
C++ public:
property int Top {
int get();
void set(int value);
}
JScript public function get Top() : int
public function set Top(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the position of the top of the box.

This property is read/write.


CacheUtilization Structure (Microsoft.DirectX.Direct3D)

CacheUtilization Structure

Measures the cache hit rate performance for textures and indexed vertices.

Definition

Visual Basic | Public Structure CacheUtilization
C# | public struct CacheUtilization
C++ | public value class CacheUtilization sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CacheUtilization | Creates a new instance of the CacheUtilization structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
PostTransformVertexCacheHitRate | Retrieves the hit rate for finding transformed vertices in the vertex cache.
TextureCacheHitRate | Retrieves the hit rate for finding a texture in the texture cache.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CacheUtilization.CacheUtilization() Constructor (Microsoft.DirectX.Direct3D)

CacheUtilization.CacheUtilization Constructor

Creates a new instance of the CacheUtilization structure.

Definition

Visual Basic | Public Sub New()
C# | public CacheUtilization();
C++ public:
CacheUtilization();
JScript | public function CacheUtilization();


CacheUtilization.ToString() Method (Microsoft.DirectX.Direct3D)

CacheUtilization.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CacheUtilization.PostTransformVertexCacheHitRate Property (Microsoft.DirectX.Direct3D)

CacheUtilization.PostTransformVertexCacheHitRate Property

Retrieves the hit rate for finding transformed vertices in the vertex cache.

Definition

Visual Basic | Public ReadOnly Property PostTransformVertexCacheHitRate As Single
C# | public float PostTransformVertexCacheHitRate { get; }
C++ public:
property float PostTransformVertexCacheHitRate {
float get();
}
JScript | public function get PostTransformVertexCacheHitRate() : float

Property Value

System.Single
A Single Leave Site value that represents the hit rate for finding transformed vertices in the vertex cache.

This property is read-only.

Remarks

The graphics processing unit (GPU) is designed to transform indexed vertices and store them in a vertex cache. If you are using meshes, Mesh.Optimize may result in better vertex cache utilization.


CacheUtilization.TextureCacheHitRate Property (Microsoft.DirectX.Direct3D)

CacheUtilization.TextureCacheHitRate Property

Retrieves the hit rate for finding a texture in the texture cache.

Definition

Visual Basic | Public ReadOnly Property TextureCacheHitRate As Single
C# | public float TextureCacheHitRate { get; }
C++ public:
property float TextureCacheHitRate {
float get();
}
JScript | public function get TextureCacheHitRate() : float

Property Value

System.Single
A Single Leave Site value that represents the hit rate for finding a texture in the texture cache.

This property is read-only.

Remarks

This assumes there is a texture cache. Increasing the level of detail (LOD) bias to use the most detailed texture, using many large textures, or producing a near random texture access pattern on large textures with custom shader code can dramatically affect the texture cache hit rate.


CallbackData Structure (Microsoft.DirectX.Direct3D)

CallbackData Structure

Retrieves information about animation callbacks.

Definition

Visual Basic | Public Structure CallbackData
C# | public struct CallbackData
C++ | public value class CallbackData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CallbackData | Initializes a new instance of the CallbackData class.

Properties

Property | Description
CallbackPosition | Retrieves or sets a value that indicates the position of the callback.
Data | Points to data for the callback.

Remarks

This structure is typically found in the KeyCallback.CallBackData member. The KeyCallback is used to pass information to a HandleAnimationCallback delegate.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CallbackData.CallbackData() Constructor (Microsoft.DirectX.Direct3D)

CallbackData.CallbackData Constructor

Initializes a new instance of the CallbackData class.

Definition

Visual Basic | Public Sub New()
C# | public CallbackData();
C++ public:
CallbackData();
JScript | public function CallbackData();


CallbackData.CallbackPosition Property (Microsoft.DirectX.Direct3D)

CallbackData.CallbackPosition Property

Retrieves or sets a value that indicates the position of the callback.

Definition

Visual Basic | Public Property CallbackPosition As Double
C# | public double CallbackPosition { get; set; }
C++ public:
property double CallbackPosition {
double get();
void set(double value);
}
JScript public function get CallbackPosition() : double
public function set CallbackPosition(double);

Property Value

System.Double
A Double Leave Site value that indicates the position of the callback.

This property is read/write.


CallbackData.Data Property (Microsoft.DirectX.Direct3D)

CallbackData.Data Property

Points to data for the callback.

Definition

Visual Basic | Public Property Data As IntPtr
C# | public IntPtr Data { get; set; }
C++ public:
property IntPtr Data {
IntPtr get();
void set(IntPtr value);
}
JScript public function get Data() : IntPtr
public function set Data(IntPtr);

Property Value

System.IntPtr
An IntPtr Leave Site instance that points to data for the callback.

This property is read/write.


Caps Structure (Microsoft.DirectX.Direct3D)

Caps Structure

Represents the capabilities of the hardware exposed through the Microsoft Direct3D object.

Definition

Visual Basic | Public Structure Caps
C# | public struct Caps
C++ | public value class Caps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Caps | Creates a new instance of the Caps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AdapterOrdinal | Retrieves a number that represents the ordinal of the adapter on which the Device was created.
AdapterOrdinalInGroup | Retrieves a number that indicates the order in which heads are referenced by the application programming object.
AlphaCompareCaps | Retrieves an object that contains all alpha-test comparison capabilities.
CubeTextureFilterCaps | Retrieves texture-filtering capabilities for a CubeTexture object.
CursorCaps | Retrieves an object that indicates the available hardware support for cursors.
DeclTypes | Retrieves an object that describes the vertex data types a device supports.
DestinationBlendCaps | Retrieves an object that indicates a device's destination blending capabilities.
DeviceCaps | Retrieves an object that identifies a device's capabilities.
DeviceType | Retrieves an object that identifies the type of resources used for processing vertices.
DriverCaps | Retrieves an object that identifies driver-specific capabilities.
ExtentsAdjust | Retrieves a value that indicates the number of pixels to adjust the extents rectangle outward to accommodate antialiasing kernels.
GuardBandBottom | Retrieves a value that indicates the screen-space coordinate of the bottom guard band clipping region.
GuardBandLeft | Retrieves a value that indicates the screen-space coordinate of the left guard band clipping region.
GuardBandRight | Retrieves a value that indicates the screen-space coordinate of the right guard band clipping region.
GuardBandTop | Retrieves a value that indicates the screen-space coordinate of the top guard band clipping region.
LineCaps | Retrieves an object that defines the capabilities for line-drawing primitives.
MasterAdapterOrdinal | Retrieves a value that indicates which device is the master for the current subordinate.
MaxActiveLights | Retrieves the maximum number of lights that can be active simultaneously.
MaxAnisotropy | Retrieves a value that indicates the maximum valid value for anisotropic filtering.
MaxNPatchTessellationLevel | Retrieves a value that indicates the maximum number of N-patch subdivision levels.
MaxPixelShader30InstructionSlots | Retrieves a value that indicates the maximum number of vertex shader instruction slots supported.
MaxPointSize | Retrieves the maximum size of a point primitive.
MaxPrimitiveCount | Retrieves the maximum number of primitives for each Device.DrawPrimitives call.
MaxSimultaneousTextures | Retrieves the maximum number of textures that can simultaneously be bound to the texture-blending stages.
MaxStreams | Indicates the maximum number of concurrent data streams for Device.SetStreamSource.
MaxStreamStride | Retrieves the maximum stride for Device.SetStreamSource.
MaxTextureAspectRatio | Retrieves the maximum texture aspect ratio supported by the hardware.
MaxTextureBlendStages | Retrieves the maximum number of texture-blending stages supported.
MaxTextureHeight | Retrieves the maximum texture height for the current device.
MaxTextureRepeat | Retrieves the maximum range of the integer bits for post-normalized texture coordinates.
MaxTextureWidth | Retrieves the maximum texture width for the current device.
MaxUserClipPlanes | Retrieves the maximum number of user-defined clipping planes supported.
MaxVertexBlendMatrices | Retrieves the maximum number of matrices that the current device can apply when performing multimatrix vertex blending.
MaxVertexBlendMatrixIndex | Retrieves the maximum matrix index that can be indexed into using pre-vertex indices.
MaxVertexIndex | Retrieves the maximum size of indices supported for hardware vertex processing.
MaxVertexShader30InstructionSlots | Retrieves the maximum number of vertex shader instruction slots supported.
MaxVertexShaderConst | Retrieves the number of vertex shader registers that are reserved for constants.
MaxVertexW | Retrieves the maximum w-based depth value that a device supports.
MaxVolumeExtent | Retrieves the maximum value for any of the three dimensions (width, height, and depth) of a volume texture.
NumberOfAdaptersInGroup | Retrieves the number of adapters in the current adapter group.
NumberSimultaneousRts | Retrieves the number of simultaneous render targets.
PixelShader1xMaxValue | Retrieves the maximum value of a pixel shader arithmetic component.
PixelShaderCaps | Retrieves a structure that contains the supported pixel shader capabilities.
PixelShaderVersion | Retrieves an object that reports the main and subordinate pixel shader versions.
PresentationIntervals | Retrieves a set of values that represent the available presentation swap intervals.
PrimitiveMiscCaps | Retrieves miscellaneous driver primitive capabilities.
RasterCaps | Retrieves information about raster drawing capabilities.
ShadeCaps | Retrieves shading operation capabilities.
SourceBlendCaps | Retrieves the source-blending capabilities.
StencilCaps | Retrieves an object that indicates the supported stencil buffer operations.
StretchRectangleFilterCaps | Retrieves a structure that describes the operations supported by StretchRectangle.
TextureAddressCaps | Retrieves a structure that contains texture-addressing capabilities for Texture objects.
TextureCaps | Retrieves a structure that contains miscellaneous texture-mapping capabilities.
TextureFilterCaps | Retrieves a structure that contains texture-filtering capabilities for Texture objects.
TextureOperationCaps | Retrieves a structure that describes supported texture operations.
VertexFormatCaps | Retrieves a structure that describes supported vertex format capabilities.
VertexProcessingCaps | Retrieves a structure that contains supported vertex processing capabilities.
VertexShaderCaps | Retrieves a structure that contains supported vertex shader capabilities.
VertexShaderVersion | Retrieves a structure that indicates the main and subordinate vertex shader versions supported by a device.
VertexTextureFilterCaps | Retrieves a structure that indicates which types of vertex shader texture filters are supported.
VolumeTextureAddressCaps | Retrieves a structure that indicates the supported texture-addressing capabilities for VolumeTexture objects.
VolumeTextureFilterCaps | Retrieves a structure that indicates the texture-filtering capabilities of VolumeTexture objects.
ZCompareCaps | Retrieves a structure that contains the supported z-buffer comparison capabilities.

Remarks

The MaxTextureBlendStages and MaxSimultaneousTextures members might seem similar, but they contain different information. The MaxTextureBlendStages member contains the total number of texture-blending stages supported by the current device, while the MaxSimultaneousTextures member describes how many of those stages can have textures bound to them by using the Device.SetTexture method.

Performance problems can occur if a texture is used and then modified during a scene. Ensure that no texture used in the current Device.BeginScene ... Device.EndScene block is evicted unless absolutely necessary. In the case of extremely high texture usage within a scene, the results are undefined. This occurs when a texture used in the scene is modified and no spare texture memory is available. For such systems, the contents of the z-buffer become invalid at Device.EndScene. Applications should not call Device.UpdateSurface to or from the back buffer on this type of hardware inside a BeginScene ... EndScene pair. In addition, applications should not try to access the z-buffer if the Caps.RasterCaps.SupportsZBufferLessHsr capability flag is set to true. Finally, applications should not lock the back buffer or the z-buffer inside a BeginScene ... EndScene pair.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • DeviceCaps


Caps.Caps() Constructor (Microsoft.DirectX.Direct3D)

Caps.Caps Constructor

Creates a new instance of the Caps structure.

Definition

Visual Basic | Public Sub New()
C# | public Caps();
C++ public:
Caps();
JScript | public function Caps();


Caps.ToString() Method (Microsoft.DirectX.Direct3D)

Caps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Caps.AdapterOrdinal Property (Microsoft.DirectX.Direct3D)

Caps.AdapterOrdinal Property

Retrieves a number that represents the ordinal of the adapter on which the Device was created.

Definition

Visual Basic | Public ReadOnly Property AdapterOrdinal As Integer
C# | public int AdapterOrdinal { get; }
C++ public:
property int AdapterOrdinal {
int get();
}
JScript | public function get AdapterOrdinal() : int

Property Value

System.Int32
An Int32 Leave Site value that represents the ordinal of the adapter on which the Device was created.

This property is read-only.

Remarks

This ordinal is valid only for passing to methods of the Manager object.


Caps.AdapterOrdinalInGroup Property (Microsoft.DirectX.Direct3D)

Caps.AdapterOrdinalInGroup Property

Retrieves a number that indicates the order in which heads are referenced by the application programming object.

Definition

Visual Basic | Public ReadOnly Property AdapterOrdinalInGroup As Integer
C# | public int AdapterOrdinalInGroup { get; }
C++ public:
property int AdapterOrdinalInGroup {
int get();
}
JScript | public function get AdapterOrdinalInGroup() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the order in which heads are referenced by the application programming object.

This property is read-only.

Remarks

The master adapter always sets AdapterOrdinalInGroup to 0. These values do not correspond to the adapter ordinals passed to the Manager. They apply only to heads within a group.


Caps.AlphaCompareCaps Property (Microsoft.DirectX.Direct3D)

Caps.AlphaCompareCaps Property

Retrieves an object that contains all alpha-test comparison capabilities.

Definition

Visual Basic | Public ReadOnly Property AlphaCompareCaps As ComparisonCaps
C# | public ComparisonCaps AlphaCompareCaps { get; }
C++ public:
property ComparisonCaps AlphaCompareCaps {
ComparisonCaps get();
}
JScript | public function get AlphaCompareCaps() : ComparisonCaps

Property Value

Microsoft.DirectX.Direct3D.ComparisonCaps
A ComparisonCaps object that contains the alpha-test comparison capabilities.

This property is read-only.

Remarks

This member can include the same capability flags defined for the Caps member. If this member contains a comparison Caps object with only the ComparisonCaps.SupportsAlways member or the ComparisonCaps.SupportsNever member set to true, the driver does not support alpha tests. Otherwise, the Caps members identify the individual comparisons that are supported for alpha testing.


Caps.CubeTextureFilterCaps Property (Microsoft.DirectX.Direct3D)

Caps.CubeTextureFilterCaps Property

Retrieves texture-filtering capabilities for a CubeTexture object.

Definition

Visual Basic | Public ReadOnly Property CubeTextureFilterCaps As FilterCaps
C# | public FilterCaps CubeTextureFilterCaps { get; }
C++ public:
property FilterCaps CubeTextureFilterCaps {
FilterCaps get();
}
JScript | public function get CubeTextureFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps
A FilterCaps structure that contains supported cube texture filtering capabilities.

This property is read-only.

Remarks

Per-stage filtering capabilities reflect which filtering modes are supported for texture stages during performance of multiple-texture blending with the Device object. This member can be any combination of the per-stage texture-filtering flags defined for the Caps.FilterCaps member.


Caps.CursorCaps Property (Microsoft.DirectX.Direct3D)

Caps.CursorCaps Property

Retrieves an object that indicates the available hardware support for cursors.

Definition

Visual Basic | Public ReadOnly Property CursorCaps As CursorCaps
C# | public CursorCaps CursorCaps { get; }
C++ public:
property CursorCaps CursorCaps {
CursorCaps get();
}
JScript | public function get CursorCaps() : CursorCaps

Property Value

Microsoft.DirectX.Direct3D.CursorCaps
A CursorCaps object that contains indicators of available hardware support for cursors.

This property is read-only.

Remarks

Alpha-blending cursor capabilities are not defined.


Caps.DeclTypes Property (Microsoft.DirectX.Direct3D)

Caps.DeclTypes Property

Retrieves an object that describes the vertex data types a device supports.

Definition

Visual Basic | Public ReadOnly Property DeclTypes As DeclarationTypeCaps
C# | public DeclarationTypeCaps DeclTypes { get; }
C++ public:
property DeclarationTypeCaps DeclTypes {
DeclarationTypeCaps get();
}
JScript | public function get DeclTypes() : DeclarationTypeCaps

Property Value

Microsoft.DirectX.Direct3D.DeclarationTypeCaps
A DeclarationTypeCaps object that describes the vertex data types the device supports.

This property is read-only.


Caps.DestinationBlendCaps Property (Microsoft.DirectX.Direct3D)

Caps.DestinationBlendCaps Property

Retrieves an object that indicates a device's destination blending capabilities.

Definition

Visual Basic | Public ReadOnly Property DestinationBlendCaps As BlendCaps
C# | public BlendCaps DestinationBlendCaps { get; }
C++ public:
property BlendCaps DestinationBlendCaps {
BlendCaps get();
}
JScript | public function get DestinationBlendCaps() : BlendCaps

Property Value

Microsoft.DirectX.Direct3D.BlendCaps
A BlendCaps object that indicates the device's destination blending capabilities.

This property is read-only.

Remarks

This member can indicate the same capabilities that are defined in the SourceBlendCaps member.


Caps.DeviceCaps Property (Microsoft.DirectX.Direct3D)

Caps.DeviceCaps Property

Retrieves an object that identifies a device's capabilities.

Definition

Visual Basic | Public ReadOnly Property DeviceCaps As DeviceCaps
C# | public DeviceCaps DeviceCaps { get; }
C++ public:
property DeviceCaps DeviceCaps {
DeviceCaps get();
}
JScript | public function get DeviceCaps() : DeviceCaps

Property Value

Microsoft.DirectX.Direct3D.DeviceCaps
A DeviceCaps object that identifies the device's capabilities.

This property is read-only.


Caps.DeviceType Property (Microsoft.DirectX.Direct3D)

Caps.DeviceType Property

Retrieves an object that identifies the type of resources used for processing vertices.

Definition

Visual Basic | Public ReadOnly Property DeviceType As DeviceType
C# | public DeviceType DeviceType { get; }
C++ public:
property DeviceType DeviceType {
DeviceType get();
}
JScript | public function get DeviceType() : DeviceType

Property Value

Microsoft.DirectX.Direct3D.DeviceType
A DeviceType object that identifies the type of resources used for processing vertices.

This property is read-only.


Caps.DriverCaps Property (Microsoft.DirectX.Direct3D)

Caps.DriverCaps Property

Retrieves an object that identifies driver-specific capabilities.

Definition

Visual Basic | Public ReadOnly Property DriverCaps As DriverCaps
C# | public DriverCaps DriverCaps { get; }
C++ public:
property DriverCaps DriverCaps {
DriverCaps get();
}
JScript | public function get DriverCaps() : DriverCaps

Property Value

Microsoft.DirectX.Direct3D.DriverCaps
A DriverCaps object that identifies driver-specific capabilities.

This property is read-only.


Caps.ExtentsAdjust Property (Microsoft.DirectX.Direct3D)

Caps.ExtentsAdjust Property

Retrieves a value that indicates the number of pixels to adjust the extents rectangle outward to accommodate antialiasing kernels.

Definition

Visual Basic | Public ReadOnly Property ExtentsAdjust As Single
C# | public float ExtentsAdjust { get; }
C++ public:
property float ExtentsAdjust {
float get();
}
JScript | public function get ExtentsAdjust() : float

Property Value

System.Single
A Single Leave Site value that indicates the number of pixels to adjust the extents rectangle outward.

This property is read-only.


Caps.GuardBandBottom Property (Microsoft.DirectX.Direct3D)

Caps.GuardBandBottom Property

Retrieves a value that indicates the screen-space coordinate of the bottom guard band clipping region.

Definition

Visual Basic | Public ReadOnly Property GuardBandBottom As Single
C# | public float GuardBandBottom { get; }
C++ public:
property float GuardBandBottom {
float get();
}
JScript | public function get GuardBandBottom() : float

Property Value

System.Single
A Single Leave Site value that indicates the screen-space coordinate of the bottom guard-band clipping region.

This property is read-only.

Remarks

Coordinates that are inside of the guard-band clipping region but outside of the viewport rectangle are automatically clipped.


Caps.GuardBandLeft Property (Microsoft.DirectX.Direct3D)

Caps.GuardBandLeft Property

Retrieves a value that indicates the screen-space coordinate of the left guard band clipping region.

Definition

Visual Basic | Public ReadOnly Property GuardBandLeft As Single
C# | public float GuardBandLeft { get; }
C++ public:
property float GuardBandLeft {
float get();
}
JScript | public function get GuardBandLeft() : float

Property Value

System.Single
A Single Leave Site value that indicates the screen-space coordinate of the left guard-band clipping region.

This property is read-only.

Remarks

Coordinates that are inside of the guard-band clipping region but outside of the viewport rectangle are automatically clipped.


Caps.GuardBandRight Property (Microsoft.DirectX.Direct3D)

Caps.GuardBandRight Property

Retrieves a value that indicates the screen-space coordinate of the right guard band clipping region.

Definition

Visual Basic | Public ReadOnly Property GuardBandRight As Single
C# | public float GuardBandRight { get; }
C++ public:
property float GuardBandRight {
float get();
}
JScript | public function get GuardBandRight() : float

Property Value

System.Single
A Single Leave Site value that indicates the right guard-band clipping region.

This property is read-only.

Remarks

Coordinates that are inside of the guard-band clipping region but outside of the viewport rectangle are automatically clipped.


Caps.GuardBandTop Property (Microsoft.DirectX.Direct3D)

Caps.GuardBandTop Property

Retrieves a value that indicates the screen-space coordinate of the top guard band clipping region.

Definition

Visual Basic | Public ReadOnly Property GuardBandTop As Single
C# | public float GuardBandTop { get; }
C++ public:
property float GuardBandTop {
float get();
}
JScript | public function get GuardBandTop() : float

Property Value

System.Single
A Single Leave Site value that indicates the screen-space coordinate of the top guard-band clipping region.

This property is read-only.

Remarks

Coordinates that are inside of the guard-band clipping region but outside of the viewport rectangle are automatically clipped.


Caps.LineCaps Property (Microsoft.DirectX.Direct3D)

Caps.LineCaps Property

Retrieves an object that defines the capabilities for line-drawing primitives.

Definition

Visual Basic | Public ReadOnly Property LineCaps As LineCaps
C# | public LineCaps LineCaps { get; }
C++ public:
property LineCaps LineCaps {
LineCaps get();
}
JScript | public function get LineCaps() : LineCaps

Property Value

Microsoft.DirectX.Direct3D.LineCaps
A LineCaps object that defines the capabilities for line-drawing primitives.

This property is read-only.


Caps.MasterAdapterOrdinal Property (Microsoft.DirectX.Direct3D)

Caps.MasterAdapterOrdinal Property

Retrieves a value that indicates which device is the master for the current subordinate.

Definition

Visual Basic | Public ReadOnly Property MasterAdapterOrdinal As Integer
C# | public int MasterAdapterOrdinal { get; }
C++ public:
property int MasterAdapterOrdinal {
int get();
}
JScript | public function get MasterAdapterOrdinal() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates which device is the master for the current subordinate.

This property is read-only.

Remarks

This number is taken from the adapter values passed into the Manager.Adapters member.

For multihead support, one head is denoted the master head, and all other heads on the same card are denoted subordinate heads. If more than one multihead adapter is present in a system, the master and its subordinates from one multihead adapter are referred to as a group.


Caps.MaxActiveLights Property (Microsoft.DirectX.Direct3D)

Caps.MaxActiveLights Property

Retrieves the maximum number of lights that can be active simultaneously.

Definition

Visual Basic | Public ReadOnly Property MaxActiveLights As Integer
C# | public int MaxActiveLights { get; }
C++ public:
property int MaxActiveLights {
int get();
}
JScript | public function get MaxActiveLights() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum number of lights that can be active simultaneously.

This property is read-only.

Remarks

For a given physical device, this capability might vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.MaxAnisotropy Property (Microsoft.DirectX.Direct3D)

Caps.MaxAnisotropy Property

Retrieves a value that indicates the maximum valid value for anisotropic filtering.

Definition

Visual Basic | Public ReadOnly Property MaxAnisotropy As Integer
C# | public int MaxAnisotropy { get; }
C++ public:
property int MaxAnisotropy {
int get();
}
JScript | public function get MaxAnisotropy() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum valid value for anisotropic filtering.

This property is read-only.

Remarks

This property indicates the maximum valid value for the SamplerStateManager.MaxAnisotropy property.


Caps.MaxNPatchTessellationLevel Property (Microsoft.DirectX.Direct3D)

Caps.MaxNPatchTessellationLevel Property

Retrieves a value that indicates the maximum number of N-patch subdivision levels.

Definition

Visual Basic | Public ReadOnly Property MaxNPatchTessellationLevel As Single
C# | public float MaxNPatchTessellationLevel { get; }
C++ public:
property float MaxNPatchTessellationLevel {
float get();
}
JScript | public function get MaxNPatchTessellationLevel() : float

Property Value

System.Single
A Single Leave Site value that indicates the maximum number of N-patch subdivision levels.

This property is read-only.

Remarks

The driver clamps applications to this value, provided they are using presampled displacement mapping.


Caps.MaxPixelShader30InstructionSlots Property (Microsoft.DirectX.Direct3D)

Caps.MaxPixelShader30InstructionSlots Property

Retrieves a value that indicates the maximum number of vertex shader instruction slots supported.

Definition

Visual Basic | Public ReadOnly Property MaxPixelShader30InstructionSlots As Integer
C# | public int MaxPixelShader30InstructionSlots { get; }
C++ public:
property int MaxPixelShader30InstructionSlots {
int get();
}
JScript | public function get MaxPixelShader30InstructionSlots() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum number of vertex shader instruction slots supported.

This property is read-only.

Remarks

The maximum value that this member can have is 32768. Devices that support vs_3_0 are required to support at least 512 instruction slots.


Caps.MaxPointSize Property (Microsoft.DirectX.Direct3D)

Caps.MaxPointSize Property

Retrieves the maximum size of a point primitive.

Definition

Visual Basic | Public ReadOnly Property MaxPointSize As Single
C# | public float MaxPointSize { get; }
C++ public:
property float MaxPointSize {
float get();
}
JScript | public function get MaxPointSize() : float

Property Value

System.Single
A Single Leave Site value that indicates the maximum size of a point primitive.

This property is read-only.

Remarks

If this member is 1.0f, the device does not support point-size control. The range is greater than or equal to 1.0f.


Caps.MaxPrimitiveCount Property (Microsoft.DirectX.Direct3D)

Caps.MaxPrimitiveCount Property

Retrieves the maximum number of primitives for each Device.DrawPrimitives call.

Definition

Visual Basic | Public ReadOnly Property MaxPrimitiveCount As Integer
C# | public int MaxPrimitiveCount { get; }
C++ public:
property int MaxPrimitiveCount {
int get();
}
JScript | public function get MaxPrimitiveCount() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum number of primitives for each Device.DrawPrimitives call.

This property is read-only.

Remarks

Note that when Microsoft Direct3D is working with a Microsoft DirectX 6.0 or DirectX 7.0 driver, this field is set to 0xFFFF. This means that not only the number of primitives but also the number of vertices is limited by this value.


Caps.MaxSimultaneousTextures Property (Microsoft.DirectX.Direct3D)

Caps.MaxSimultaneousTextures Property

Retrieves the maximum number of textures that can simultaneously be bound to the texture-blending stages.

Definition

Visual Basic | Public ReadOnly Property MaxSimultaneousTextures As Integer
C# | public int MaxSimultaneousTextures { get; }
C++ public:
property int MaxSimultaneousTextures {
int get();
}
JScript | public function get MaxSimultaneousTextures() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum number of textures that can simultaneously be bound to the texture-blending stages.

This property is read-only.

Remarks

This value is the number of textures that can be used in a single pass. If the same texture is used in two blending stages, it counts as two when compared to the MaxSimultaneousTextures value. In the programmable pipeline, the value indicates the number of texture/sampler registers supported by pixel shaders on this particular piece of hardware, as well as the number of texture-declaration instructions that can be present.


Caps.MaxStreams Property (Microsoft.DirectX.Direct3D)

Caps.MaxStreams Property

Indicates the maximum number of concurrent data streams for Device.SetStreamSource.

Definition

Visual Basic | Public ReadOnly Property MaxStreams As Integer
C# | public int MaxStreams { get; }
C++ public:
property int MaxStreams {
int get();
}
JScript | public function get MaxStreams() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum number of concurrent data streams for Device.SetStreamSource.

This property is read-only.

Remarks

The valid range is 1 to 16. Note that if this value is 0, the driver is not a Microsoft DirectX 9.0 driver.


Caps.MaxStreamStride Property (Microsoft.DirectX.Direct3D)

Caps.MaxStreamStride Property

Retrieves the maximum stride for Device.SetStreamSource.

Definition

Visual Basic | Public ReadOnly Property MaxStreamStride As Integer
C# | public int MaxStreamStride { get; }
C++ public:
property int MaxStreamStride {
int get();
}
JScript | public function get MaxStreamStride() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum stride for Device.SetStreamSource.

This property is read-only.


Caps.MaxTextureAspectRatio Property (Microsoft.DirectX.Direct3D)

Caps.MaxTextureAspectRatio Property

Retrieves the maximum texture aspect ratio supported by the hardware.

Definition

Visual Basic | Public ReadOnly Property MaxTextureAspectRatio As Integer
C# | public int MaxTextureAspectRatio { get; }
C++ public:
property int MaxTextureAspectRatio {
int get();
}
JScript | public function get MaxTextureAspectRatio() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum texture aspect ratio.

This property is read-only.

Remarks

This value is typically a power of 2.


Caps.MaxTextureBlendStages Property (Microsoft.DirectX.Direct3D)

Caps.MaxTextureBlendStages Property

Retrieves the maximum number of texture-blending stages supported.

Definition

Visual Basic | Public ReadOnly Property MaxTextureBlendStages As Integer
C# | public int MaxTextureBlendStages { get; }
C++ public:
property int MaxTextureBlendStages {
int get();
}
JScript | public function get MaxTextureBlendStages() : int

Property Value

System.Int32
An Int32 Leave Site that indicates the number of texture-blending stages supported.

This property is read-only.

Remarks

This value corresponds to the number of unique texture registers used by pixel shader instructions.


Caps.MaxTextureHeight Property (Microsoft.DirectX.Direct3D)

Caps.MaxTextureHeight Property

Retrieves the maximum texture height for the current device.

Definition

Visual Basic | Public ReadOnly Property MaxTextureHeight As Integer
C# | public int MaxTextureHeight { get; }
C++ public:
property int MaxTextureHeight {
int get();
}
JScript | public function get MaxTextureHeight() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum texture height for the current device.

This property is read-only.


Caps.MaxTextureRepeat Property (Microsoft.DirectX.Direct3D)

Caps.MaxTextureRepeat Property

Retrieves the maximum range of the integer bits for post-normalized texture coordinates.

Definition

Visual Basic | Public ReadOnly Property MaxTextureRepeat As Integer
C# | public int MaxTextureRepeat { get; }
C++ public:
property int MaxTextureRepeat {
int get();
}
JScript | public function get MaxTextureRepeat() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum range of the integer bits for the post-normalized texture coordinates.

This property is read-only.

Remarks

A texture coordinate is stored as a 32-bit signed integer that uses 27 bits to store the integer and five bits to store the floating-point fraction. The maximum integer index, 227, is used to determine the maximum texture coordinate, depending on how the hardware performs texture-coordinate scaling.

Some hardware sets the Caps.TextureCaps.SupportsTextureRepeatNotScaledBySize capability to true. In this case, the device defers the scaling of texture coordinates by texture size until after interpolation and application of the texture address mode. This means that the number of times a texture can be wrapped is specified by the integer value in MaxTextureRepeat.

Other hardware sets the Caps.TextureCaps.SupportsTextureRepeatNotScaledBySize capability to false, and the device scales the texture coordinates by texture size (using the highest level of detail) before interpolation. This limits the number of times a texture can be wrapped to MaxTextureRepeat / texture size.

For example, assume that MaxTextureRepeat is equal to 32 KB, and the size of the texture is 4 KB. If the hardware sets Caps.TextureCaps.SupportsTextureRepeatNotScaledBySize to true, the number of times a texture can be wrapped is equal to MaxTextureRepeat, which is 32 KB. Otherwise, the number of times a texture can be wrapped is equal to MaxTextureRepeat divided by texture size, which is 227 / 4 KB.


Caps.MaxTextureWidth Property (Microsoft.DirectX.Direct3D)

Caps.MaxTextureWidth Property

Retrieves the maximum texture width for the current device.

Definition

Visual Basic | Public ReadOnly Property MaxTextureWidth As Integer
C# | public int MaxTextureWidth { get; }
C++ public:
property int MaxTextureWidth {
int get();
}
JScript | public function get MaxTextureWidth() : int

Property Value

System.Int32
Maximum texture width for the device.

This property is read-only.


Caps.MaxUserClipPlanes Property (Microsoft.DirectX.Direct3D)

Caps.MaxUserClipPlanes Property

Retrieves the maximum number of user-defined clipping planes supported.

Definition

Visual Basic | Public ReadOnly Property MaxUserClipPlanes As Integer
C# | public int MaxUserClipPlanes { get; }
C++ public:
property int MaxUserClipPlanes {
int get();
}
JScript | public function get MaxUserClipPlanes() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum number of user-defined clipping planes supported.

This property is read-only.

Remarks

For a given physical device, this capability can vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.MaxVertexBlendMatrices Property (Microsoft.DirectX.Direct3D)

Caps.MaxVertexBlendMatrices Property

Retrieves the maximum number of matrices that the current device can apply when performing multimatrix vertex blending.

Definition

Visual Basic | Public ReadOnly Property MaxVertexBlendMatrices As Integer
C# | public int MaxVertexBlendMatrices { get; }
C++ public:
property int MaxVertexBlendMatrices {
int get();
}
JScript | public function get MaxVertexBlendMatrices() : int

Property Value

System.Int32
Maximum number of matrices that the device can apply when performing multimatrix vertex blending.

This property is read-only.

Remarks

For a given physical device, this capability can vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.MaxVertexBlendMatrixIndex Property (Microsoft.DirectX.Direct3D)

Caps.MaxVertexBlendMatrixIndex Property

Retrieves the maximum matrix index that can be indexed into using pre-vertex indices.

Definition

Visual Basic | Public ReadOnly Property MaxVertexBlendMatrixIndex As Integer
C# | public int MaxVertexBlendMatrixIndex { get; }
C++ public:
property int MaxVertexBlendMatrixIndex {
int get();
}
JScript | public function get MaxVertexBlendMatrixIndex() : int

Property Value

System.Int32
Maximum matrix index that can be indexed into using pre-vertex indices.

This property is read-only.

Remarks

The number of matrices is MaxVertexBlendMatrixIndex + 1, which is the size of the matrix palette. If normals are present in the vertex data that need to be blended for lighting, the number of matrices is half the number specified by this capability flag. If MaxVertexBlendMatrixIndex is 0, the driver does not support indexed vertex blending. If the value is not 0, the valid range of indices is 0 through MaxVertexBlendMatrixIndex.

A 0 value for MaxVertexBlendMatrixIndex indicates that the driver does not support indexed matrices.

When software vertex processing is used, 256 matrices can be used for indexed vertex blending, with or without normal blending.

For a given physical device, this capability can vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.MaxVertexIndex Property (Microsoft.DirectX.Direct3D)

Caps.MaxVertexIndex Property

Retrieves the maximum size of indices supported for hardware vertex processing.

Definition

Visual Basic | Public ReadOnly Property MaxVertexIndex As Integer
C# | public int MaxVertexIndex { get; }
C++ public:
property int MaxVertexIndex {
int get();
}
JScript | public function get MaxVertexIndex() : int

Property Value

System.Int32
Maximum size of indices supported for hardware vertex processing.

This property is read-only.

Remarks

It is possible to create 32-bit index buffers by specifying that the sixteenBitIndices parameter is false in the IndexBuffer constructor; however, rendering with the index buffer is not possible unless MaxVertexIndex is greater than 0x0000FFFF.


Caps.MaxVertexShader30InstructionSlots Property (Microsoft.DirectX.Direct3D)

Caps.MaxVertexShader30InstructionSlots Property

Retrieves the maximum number of vertex shader instruction slots supported.

Definition

Visual Basic | Public ReadOnly Property MaxVertexShader30InstructionSlots As Integer
C# | public int MaxVertexShader30InstructionSlots { get; }
C++ public:
property int MaxVertexShader30InstructionSlots {
int get();
}
JScript | public function get MaxVertexShader30InstructionSlots() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the maximum number of vertex shader instruction slots supported.

This property is read-only.

Remarks

The maximum value that can be set is 32768. Devices that support vs_3_0 are required to support at least 512 instruction slots.


Caps.MaxVertexShaderConst Property (Microsoft.DirectX.Direct3D)

Caps.MaxVertexShaderConst Property

Retrieves the number of vertex shader registers that are reserved for constants.

Definition

Visual Basic | Public ReadOnly Property MaxVertexShaderConst As Integer
C# | public int MaxVertexShaderConst { get; }
C++ public:
property int MaxVertexShaderConst {
int get();
}
JScript | public function get MaxVertexShaderConst() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of vertex shader registers that are reserved for constants.

This property is read-only.


Caps.MaxVertexW Property (Microsoft.DirectX.Direct3D)

Caps.MaxVertexW Property

Retrieves the maximum w-based depth value that a device supports.

Definition

Visual Basic | Public ReadOnly Property MaxVertexW As Single
C# | public float MaxVertexW { get; }
C++ public:
property float MaxVertexW {
float get();
}
JScript | public function get MaxVertexW() : float

Property Value

System.Single
Indicates the maximum w-based depth value that a device supports.

This property is read-only.


Caps.MaxVolumeExtent Property (Microsoft.DirectX.Direct3D)

Caps.MaxVolumeExtent Property

Retrieves the maximum value for any of the three dimensions (width, height, and depth) of a volume texture.

Definition

Visual Basic | Public ReadOnly Property MaxVolumeExtent As Integer
C# | public int MaxVolumeExtent { get; }
C++ public:
property int MaxVolumeExtent {
int get();
}
JScript | public function get MaxVolumeExtent() : int

Property Value

System.Int32
Maximum value for any of the three dimensions of a volume texture.

This property is read-only.


Caps.NumberOfAdaptersInGroup Property (Microsoft.DirectX.Direct3D)

Caps.NumberOfAdaptersInGroup Property

Retrieves the number of adapters in the current adapter group.

Definition

Visual Basic | Public ReadOnly Property NumberOfAdaptersInGroup As Integer
C# | public int NumberOfAdaptersInGroup { get; }
C++ public:
property int NumberOfAdaptersInGroup {
int get();
}
JScript | public function get NumberOfAdaptersInGroup() : int

Property Value

System.Int32
Number of adapters in the current adapter group.

This property is read-only.

Remarks

If the current Caps object is associated with a conventional adapter, this property reports 1. It reports a value greater than 1 for the master adapter of a multihead card, and 0 for a subordinate adapter of a multihead card. Each card can have only one master, but many subordinates.


Caps.NumberSimultaneousRts Property (Microsoft.DirectX.Direct3D)

Caps.NumberSimultaneousRts Property

Retrieves the number of simultaneous render targets.

Definition

Visual Basic | Public ReadOnly Property NumberSimultaneousRts As Integer
C# | public int NumberSimultaneousRts { get; }
C++ public:
property int NumberSimultaneousRts {
int get();
}
JScript | public function get NumberSimultaneousRts() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of simultaneous render targets.

This property is read-only.

Remarks

This property value must be at least 1.


Caps.PixelShader1xMaxValue Property (Microsoft.DirectX.Direct3D)

Caps.PixelShader1xMaxValue Property

Retrieves the maximum value of a pixel shader arithmetic component.

Definition

Visual Basic | Public ReadOnly Property PixelShader1xMaxValue As Single
C# | public float PixelShader1xMaxValue { get; }
C++ public:
property float PixelShader1xMaxValue {
float get();
}
JScript | public function get PixelShader1xMaxValue() : float

Property Value

System.Single
A Single Leave Site value that indicates the maximum value of the pixel shader arithmetic component.

This property is read-only.

Remarks

This property's value indicates the internal range of values supported for pixel color-blending operations. Implementations must allow data within this range to pass through pixel processing unmodified (that is, unclamped).

Normally, the value of this member is absolute. For example, a value of 1.0 indicates that the range is -1.0 to 1, and an 8.0 indicates that the range is -8.0 to 8.0. The value is >= 1.0 for any hardware that supports pixel shaders.


Caps.PixelShaderCaps Property (Microsoft.DirectX.Direct3D)

Caps.PixelShaderCaps Property

Retrieves a structure that contains the supported pixel shader capabilities.

Definition

Visual Basic | Public ReadOnly Property PixelShaderCaps As PixelShaderCaps
C# | public PixelShaderCaps PixelShaderCaps { get; }
C++ public:
property PixelShaderCaps PixelShaderCaps {
PixelShaderCaps get();
}
JScript | public function get PixelShaderCaps() : PixelShaderCaps

Property Value

Microsoft.DirectX.Direct3D.PixelShaderCaps
A PixelShaderCaps structure that contains the supported pixel shader capabilities.

This property is read-only.


Caps.PixelShaderVersion Property (Microsoft.DirectX.Direct3D)

Caps.PixelShaderVersion Property

Retrieves an object that reports the main and subordinate pixel shader versions.

Definition

Visual Basic | Public ReadOnly Property PixelShaderVersion As Version
C# | public Version PixelShaderVersion { get; }
C++ public:
property Version^ PixelShaderVersion {
Version^ get();
}
JScript | public function get PixelShaderVersion() : Version

Property Value

System.Version
A Version Leave Site object that contains the main and subordinate pixel shader versions.

This property is read-only.


Caps.PresentationIntervals Property (Microsoft.DirectX.Direct3D)

Caps.PresentationIntervals Property

Retrieves a set of values that represent the available presentation swap intervals.

Definition

Visual Basic | Public ReadOnly Property PresentationIntervals As PresentInterval
C# | public PresentInterval PresentationIntervals { get; }
C++ public:
property PresentInterval PresentationIntervals {
PresentInterval get();
}
JScript | public function get PresentationIntervals() : PresentInterval

Property Value

Microsoft.DirectX.Direct3D.PresentInterval
A combination of PresentInterval values that indicate the available presentation swap intervals.

This property is read-only.


Caps.PrimitiveMiscCaps Property (Microsoft.DirectX.Direct3D)

Caps.PrimitiveMiscCaps Property

Retrieves miscellaneous driver primitive capabilities.

Definition

Visual Basic | Public ReadOnly Property PrimitiveMiscCaps As MiscCaps
C# | public MiscCaps PrimitiveMiscCaps { get; }
C++ public:
property MiscCaps PrimitiveMiscCaps {
MiscCaps get();
}
JScript | public function get PrimitiveMiscCaps() : MiscCaps

Property Value

Microsoft.DirectX.Direct3D.MiscCaps
A MiscCaps structure that contains miscellaneous driver primitive capabilities.

This property is read-only.


Caps.RasterCaps Property (Microsoft.DirectX.Direct3D)

Caps.RasterCaps Property

Retrieves information about raster drawing capabilities.

Definition

Visual Basic | Public ReadOnly Property RasterCaps As RasterCaps
C# | public RasterCaps RasterCaps { get; }
C++ public:
property RasterCaps RasterCaps {
RasterCaps get();
}
JScript | public function get RasterCaps() : RasterCaps

Property Value

Microsoft.DirectX.Direct3D.RasterCaps
A RasterCaps structure that contains raster drawing capabilities.

This property is read-only.


Caps.ShadeCaps Property (Microsoft.DirectX.Direct3D)

Caps.ShadeCaps Property

Retrieves shading operation capabilities.

Definition

Visual Basic | Public ReadOnly Property ShadeCaps As ShadeCaps
C# | public ShadeCaps ShadeCaps { get; }
C++ public:
property ShadeCaps ShadeCaps {
ShadeCaps get();
}
JScript | public function get ShadeCaps() : ShadeCaps

Property Value

Microsoft.DirectX.Direct3D.ShadeCaps
A ShadeCaps structure that contains shading operation capabilities.

This property is read-only.

Remarks

Generally, it is assumed that if a device supports a shading operation at all, it at least supports flat shading. For more information, see ShadeMode.

When alpha components are not supported, the alpha value of generated colors is implicitly 255. This is the maximum possible alpha (that is, the alpha component is at full intensity).


Caps.SourceBlendCaps Property (Microsoft.DirectX.Direct3D)

Caps.SourceBlendCaps Property

Retrieves the source-blending capabilities.

Definition

Visual Basic | Public ReadOnly Property SourceBlendCaps As BlendCaps
C# | public BlendCaps SourceBlendCaps { get; }
C++ public:
property BlendCaps SourceBlendCaps {
BlendCaps get();
}
JScript | public function get SourceBlendCaps() : BlendCaps

Property Value

Microsoft.DirectX.Direct3D.BlendCaps
A BlendCaps object that contains the source-blending capabilities.

This property is read-only.


Caps.StencilCaps Property (Microsoft.DirectX.Direct3D)

Caps.StencilCaps Property

Retrieves an object that indicates the supported stencil buffer operations.

Definition

Visual Basic | Public ReadOnly Property StencilCaps As StencilCaps
C# | public StencilCaps StencilCaps { get; }
C++ public:
property StencilCaps StencilCaps {
StencilCaps get();
}
JScript | public function get StencilCaps() : StencilCaps

Property Value

Microsoft.DirectX.Direct3D.StencilCaps
A StencilCaps object that indicates the supported stencil-buffer operations.

This property is read-only.

Remarks

The supported stencil operations are assumed to be valid for all three stencil-buffer operation render states (RenderStateManager.StencilFail, RenderStateManager.StencilPass, and RenderStateManager.StencilZBufferFail). For more information, see the StencilOperation enumerated type.


Caps.StretchRectangleFilterCaps Property (Microsoft.DirectX.Direct3D)

Caps.StretchRectangleFilterCaps Property

Retrieves a structure that describes the operations supported by StretchRectangle.

Definition

Visual Basic | Public ReadOnly Property StretchRectangleFilterCaps As FilterCaps
C# | public FilterCaps StretchRectangleFilterCaps { get; }
C++ public:
property FilterCaps StretchRectangleFilterCaps {
FilterCaps get();
}
JScript | public function get StretchRectangleFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps
A FilterCaps structure that describes the operations supported by Device.StretchRectangle.

This property is read-only.


Caps.TextureAddressCaps Property (Microsoft.DirectX.Direct3D)

Caps.TextureAddressCaps Property

Retrieves a structure that contains texture-addressing capabilities for Texture objects.

Definition

Visual Basic | Public ReadOnly Property TextureAddressCaps As AddressCaps
C# | public AddressCaps TextureAddressCaps { get; }
C++ public:
property AddressCaps TextureAddressCaps {
AddressCaps get();
}
JScript | public function get TextureAddressCaps() : AddressCaps

Property Value

Microsoft.DirectX.Direct3D.AddressCaps
An AddressCaps structure that contains the texture-addressing capabilities for Texture objects.

This property is read-only.


Caps.TextureCaps Property (Microsoft.DirectX.Direct3D)

Caps.TextureCaps Property

Retrieves a structure that contains miscellaneous texture-mapping capabilities.

Definition

Visual Basic | Public ReadOnly Property TextureCaps As TextureCaps
C# | public TextureCaps TextureCaps { get; }
C++ public:
property TextureCaps TextureCaps {
TextureCaps get();
}
JScript | public function get TextureCaps() : TextureCaps

Property Value

Microsoft.DirectX.Direct3D.TextureCaps
A TextureCaps structure that contains miscellaneous texture-mapping capabilities.

This property is read-only.


Caps.TextureFilterCaps Property (Microsoft.DirectX.Direct3D)

Caps.TextureFilterCaps Property

Retrieves a structure that contains texture-filtering capabilities for Texture objects.

Definition

Visual Basic | Public ReadOnly Property TextureFilterCaps As FilterCaps
C# | public FilterCaps TextureFilterCaps { get; }
C++ public:
property FilterCaps TextureFilterCaps {
FilterCaps get();
}
JScript | public function get TextureFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps
A FilterCaps structure that contains the texture-filtering capabilities for Texture objects.

This property is read-only.

Remarks

Per-stage filtering capabilities reflect which filtering modes are supported for texture stages when multiple-texture blending is performed.


Caps.TextureOperationCaps Property (Microsoft.DirectX.Direct3D)

Caps.TextureOperationCaps Property

Retrieves a structure that describes supported texture operations.

Definition

Visual Basic | Public ReadOnly Property TextureOperationCaps As TextureOperationCaps
C# | public TextureOperationCaps TextureOperationCaps { get; }
C++ public:
property TextureOperationCaps TextureOperationCaps {
TextureOperationCaps get();
}
JScript | public function get TextureOperationCaps() : TextureOperationCaps

Property Value

Microsoft.DirectX.Direct3D.TextureOperationCaps
A TextureOperationCaps structure that describes the supported texture operations.

This property is read-only.


Caps.VertexFormatCaps Property (Microsoft.DirectX.Direct3D)

Caps.VertexFormatCaps Property

Retrieves a structure that describes supported vertex format capabilities.

Definition

Visual Basic | Public ReadOnly Property VertexFormatCaps As VertexFormatCaps
C# | public VertexFormatCaps VertexFormatCaps { get; }
C++ public:
property VertexFormatCaps VertexFormatCaps {
VertexFormatCaps get();
}
JScript | public function get VertexFormatCaps() : VertexFormatCaps

Property Value

Microsoft.DirectX.Direct3D.VertexFormatCaps
A VertexFormatCaps structure that describes supported vertex format capabilities.

This property is read-only.


Caps.VertexProcessingCaps Property (Microsoft.DirectX.Direct3D)

Caps.VertexProcessingCaps Property

Retrieves a structure that contains supported vertex processing capabilities.

Definition

Visual Basic | Public ReadOnly Property VertexProcessingCaps As VertexProcessingCaps
C# | public VertexProcessingCaps VertexProcessingCaps { get; }
C++ public:
property VertexProcessingCaps VertexProcessingCaps {
VertexProcessingCaps get();
}
JScript | public function get VertexProcessingCaps() : VertexProcessingCaps

Property Value

Microsoft.DirectX.Direct3D.VertexProcessingCaps
A VertexProcessingCaps structure that contains the supported vertex processing capabilities.

This property is read-only.

Remarks

For a given physical device, this capability can vary across Device objects, depending on the parameters supplied to the Device constructor.


Caps.VertexShaderCaps Property (Microsoft.DirectX.Direct3D)

Caps.VertexShaderCaps Property

Retrieves a structure that contains supported vertex shader capabilities.

Definition

Visual Basic | Public ReadOnly Property VertexShaderCaps As VertexShaderCaps
C# | public VertexShaderCaps VertexShaderCaps { get; }
C++ public:
property VertexShaderCaps VertexShaderCaps {
VertexShaderCaps get();
}
JScript | public function get VertexShaderCaps() : VertexShaderCaps

Property Value

Microsoft.DirectX.Direct3D.VertexShaderCaps
A VertexShaderCaps structure that contains the supported vertex shader capabilities.

This property is read-only.


Caps.VertexShaderVersion Property (Microsoft.DirectX.Direct3D)

Caps.VertexShaderVersion Property

How Do I...?
  • Check for Shader Support

Retrieves a structure that indicates the main and subordinate vertex shader versions supported by a device.

Definition

Visual Basic | Public ReadOnly Property VertexShaderVersion As Version
C# | public Version VertexShaderVersion { get; }
C++ public:
property Version^ VertexShaderVersion {
Version^ get();
}
JScript | public function get VertexShaderVersion() : Version

Property Value

System.Version
A Version Leave Site object that indicates the main and subordinate vertex shader versions supported by the device.

This property is read-only.

Remarks

Only vertex shaders with version numbers equal to or less than the value indicated by this member succeed in calls to the VertexShader constructor.

How Do I...?

Check for Shader Support

This example shows how to check the hardware device for shader support.

To determine whether the hardware device supports shaders, Microsoft Direct3D allows the application to check the shader version.

To check for shader support:

  1. Obtain the device's capabilities by using the Manager.GetDeviceCaps method.
  2. Using the capabilities object obtained with the previous call, check the shader version by calling Caps.VertexShaderVersion.

              [C#]

public bool CheckShaderSupport()
{
    Version v1_1 = new Version(1,1); // check version is at least shader 1.1

    // retrieve the device caps
    Caps caps = Manager.GetDeviceCaps(0, DeviceType.Hardware);

    // check the supported shader version
    if ((caps.VertexShaderVersion >= v1_1) && (caps.PixelShaderVersion >= v1_1))
    {
        return true;
    }

    return false;
}


Caps.VertexTextureFilterCaps Property (Microsoft.DirectX.Direct3D)

Caps.VertexTextureFilterCaps Property

Retrieves a structure that indicates which types of vertex shader texture filters are supported.

Definition

Visual Basic | Public ReadOnly Property VertexTextureFilterCaps As FilterCaps
C# | public FilterCaps VertexTextureFilterCaps { get; }
C++ public:
property FilterCaps VertexTextureFilterCaps {
FilterCaps get();
}
JScript | public function get VertexTextureFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps
A FilterCaps structure that indicates which types of vertex shader texture filters are supported.

This property is read-only.


Caps.VolumeTextureAddressCaps Property (Microsoft.DirectX.Direct3D)

Caps.VolumeTextureAddressCaps Property

Retrieves a structure that indicates the supported texture-addressing capabilities for VolumeTexture objects.

Definition

Visual Basic | Public ReadOnly Property VolumeTextureAddressCaps As AddressCaps
C# | public AddressCaps VolumeTextureAddressCaps { get; }
C++ public:
property AddressCaps VolumeTextureAddressCaps {
AddressCaps get();
}
JScript | public function get VolumeTextureAddressCaps() : AddressCaps

Property Value

Microsoft.DirectX.Direct3D.AddressCaps
An AddressCaps structure that indicates the supported texture-addressing capabilities for VolumeTexture objects.

This property is read-only.


Caps.VolumeTextureFilterCaps Property (Microsoft.DirectX.Direct3D)

Caps.VolumeTextureFilterCaps Property

Retrieves a structure that indicates the texture-filtering capabilities of VolumeTexture objects.

Definition

Visual Basic | Public ReadOnly Property VolumeTextureFilterCaps As FilterCaps
C# | public FilterCaps VolumeTextureFilterCaps { get; }
C++ public:
property FilterCaps VolumeTextureFilterCaps {
FilterCaps get();
}
JScript | public function get VolumeTextureFilterCaps() : FilterCaps

Property Value

Microsoft.DirectX.Direct3D.FilterCaps
A FilterCaps structure that indicates the texture-filtering capabilities of VolumeTexture objects.

This property is read-only.

Remarks

Per-stage filtering capabilities reflect which filtering modes are supported for texture stages when multiple-texture blending is performed with the Device object.


Caps.ZCompareCaps Property (Microsoft.DirectX.Direct3D)

Caps.ZCompareCaps Property

Retrieves a structure that contains the supported z-buffer comparison capabilities.

Definition

Visual Basic | Public ReadOnly Property ZCompareCaps As ComparisonCaps
C# | public ComparisonCaps ZCompareCaps { get; }
C++ public:
property ComparisonCaps ZCompareCaps {
ComparisonCaps get();
}
JScript | public function get ZCompareCaps() : ComparisonCaps

Property Value

Microsoft.DirectX.Direct3D.ComparisonCaps
A ComparisonCaps structure that contains the supported z-buffer comparison capabilities.

This property is read-only.

Remarks

This member can be one or more of the following ComparisonCaps:

  • SupportsAlways: Always pass the z-test.
  • SupportsEqual: Pass the z-test if the new z equals the current z.
  • SupportsGreater: Pass the z-test if the new z is greater than the current z.
  • SupportsGreaterEqual: Pass the z-test if the new z is greater than or equal to the current z.
  • SupportsLess: Pass the z-test if the new z is less than the current z.
  • SupportsLessEqual: Pass the z-test if the new z is less than or equal to the current z.
  • SupportsNever: Always fail the z-test.
  • SupportsNotEqual: Pass the z-test if the new z does not equal the current z.


ClipStatus Structure (Microsoft.DirectX.Direct3D)

ClipStatus Structure

Describes the current clip status.

Definition

Visual Basic | Public Structure ClipStatus
C# | public struct ClipStatus
C++ | public value class ClipStatus sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ClipStatus | Initializes a new instance of the ClipStatus class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ClipIntersection | Retrieves or sets a value that is the bitwise intersection of all current clip status flags.
ClipUnion | Retrieves or sets a value that is the bitwise union of all current clip status flags.

Remarks

When clipping is enabled during vertex processing (by Device.ProcessVertices, Device.DrawPrimitives, or other drawing functions), Microsoft Direct3D computes a clip code for each vertex. When a vertex is outside of a particular clipping plane, the corresponding bit is set in the clipping code. Direct3D maintains the clip status using ClipStatus, which has ClipUnion and ClipIntersection members. ClipUnion is a bitwise OR of all vertex clip codes and ClipIntersection is a bitwise AND of all vertex clip codes. Initial values are zero for ClipUnion and 0xFFFFFFFF for ClipIntersection. When RenderStateManager is set to false, ClipUnion and ClipIntersection are set to zero. Direct3D updates the clip status during drawing calls. To compute clip status for a particular object, set ClipUnion and ClipIntersection to their initial values and continue drawing.

Clip status is not updated by Device.DrawRectanglePatch and Device.DrawTrianglePatch because there is no software emulation for them.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClipStatus.ClipStatus() Constructor (Microsoft.DirectX.Direct3D)

ClipStatus.ClipStatus Constructor

Initializes a new instance of the ClipStatus class.

Definition

Visual Basic | Public Sub New()
C# | public ClipStatus();
C++ public:
ClipStatus();
JScript | public function ClipStatus();


ClipStatus.ToString() Method (Microsoft.DirectX.Direct3D)

ClipStatus.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ClipStatus.ClipIntersection Property (Microsoft.DirectX.Direct3D)

ClipStatus.ClipIntersection Property

Retrieves or sets a value that is the bitwise intersection of all current clip status flags.

Definition

Visual Basic | Public Property ClipIntersection As ClipStatusFlags
C# | public ClipStatusFlags ClipIntersection { get; set; }
C++ public:
property ClipStatusFlags ClipIntersection {
ClipStatusFlags get();
void set(ClipStatusFlags value);
}
JScript public function get ClipIntersection() : ClipStatusFlags
public function set ClipIntersection(ClipStatusFlags);

Property Value

Microsoft.DirectX.Direct3D.ClipStatusFlags
Value that represents a bitwise AND of all current ClipStatusFlags.

This property is read/write.

Remarks

Microsoft Direct3D updates the clip status during drawing calls. To compute clip status for a particular object, set ClipIntersection to its initial value and continue drawing.

See Also

  • ClipUnion


ClipStatus.ClipUnion Property (Microsoft.DirectX.Direct3D)

ClipStatus.ClipUnion Property

Retrieves or sets a value that is the bitwise union of all current clip status flags.

Definition

Visual Basic | Public Property ClipUnion As ClipStatusFlags
C# | public ClipStatusFlags ClipUnion { get; set; }
C++ public:
property ClipStatusFlags ClipUnion {
ClipStatusFlags get();
void set(ClipStatusFlags value);
}
JScript public function get ClipUnion() : ClipStatusFlags
public function set ClipUnion(ClipStatusFlags);

Property Value

Microsoft.DirectX.Direct3D.ClipStatusFlags
Value that represents a bitwise OR of all current ClipStatusFlags.

This property is read/write.

Remarks

Microsoft Direct3D updates the clip status during drawing calls. To compute clip status for a particular object, set ClipUnion to its initial value and continue drawing.

See Also

  • ClipIntersection


ColorValue Structure (Microsoft.DirectX.Direct3D)

ColorValue Structure

Stores the red, green, blue, and alpha channel values that together define a specific color.

Definition

Visual Basic | Public Structure ColorValue
C# | public struct ColorValue
C++ | public value class ColorValue sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ColorValue | Initializes a new instance of the ColorValue structure.
FillD3DColor | Fills a _D3DCOLORVALUE structure with the color values of the current instance.
static (Shared in Visual Basic) FromArgb | Initializes and returns an instance of a ColorValue structure using an Int32 Leave Site value.
static (Shared in Visual Basic) FromColor | Initializes and returns an instance of a ColorValue structure using a Color Leave Site value.
static (Shared in Visual Basic) FromD3DColor | Initializes and returns an instance of a ColorValue structure using an _D3DCOLORVALUE value.
ToArgb | Returns an Int32 Leave Site value that represents the color value of the current instance.

Properties

Property | Description
Alpha | Retrieves or sets the alpha channel value of the current color.
Blue | Retrieves or sets the blue value of the current color.
Green | Retrieves or sets the green value of the current color.
Red | Retrieves or sets the red value of the current color.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorValue.ColorValue Constructor ()

Initializes a new instance of the ColorValue structure.

Overload List

public ColorValue(int, int, int);
public ColorValue(int, int, int, int);
public ColorValue(float, float, float);
public ColorValue(float, float, float, float);


ColorValue.ColorValue(Int32,Int32,Int32) Constructor (Microsoft.DirectX.Direct3D)

ColorValue.ColorValue Constructor

Initializes a new instance of the ColorValue structure.

Definition

Visual Basic Public Sub New( _
ByVal r As Integer, _
ByVal g As Integer, _
ByVal b As Integer _
)
C# public ColorValue(
int r,
int g,
int b
);
C++ public:
ColorValue(
int r,
int g,
int b
);
JScript public function ColorValue(
r : int,
g : int,
b : int
);

Parameters

r System.Int32
An integer value that represents the level of red in the color.
g System.Int32
An integer value that represents the level of green in the color.
b System.Int32
An integer value that represents the level of blue in the color.


ColorValue.ColorValue(Int32,Int32,Int32,Int32) Constructor (Microsoft.DirectX.Direct3D)

ColorValue.ColorValue Constructor

Initializes a new instance of the ColorValue structure.

Definition

Visual Basic Public Sub New( _
ByVal r As Integer, _
ByVal g As Integer, _
ByVal b As Integer, _
ByVal a As Integer _
)
C# public ColorValue(
int r,
int g,
int b,
int a
);
C++ public:
ColorValue(
int r,
int g,
int b,
int a
);
JScript public function ColorValue(
r : int,
g : int,
b : int,
a : int
);

Parameters

r System.Int32
An integer value that represents the level of red in the color.
g System.Int32
An integer value that represents the level of green in the color.
b System.Int32
An integer value that represents the level of blue in the color.
a System.Int32
An integer value that represents the alpha channel value of the color.


ColorValue.ColorValue(Single,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

ColorValue.ColorValue Constructor

Initializes a new instance of the ColorValue structure.

Definition

Visual Basic Public Sub New( _
ByVal r As Single, _
ByVal g As Single, _
ByVal b As Single _
)
C# public ColorValue(
float r,
float g,
float b
);
C++ public:
ColorValue(
float r,
float g,
float b
);
JScript public function ColorValue(
r : float,
g : float,
b : float
);

Parameters

r System.Single
A Single Leave Site value that represents the level of red in the color.
g System.Single
A Single Leave Site value that represents the level of green in the color.
b System.Single
A Single Leave Site value that represents the level of blue in the color.


ColorValue.ColorValue(Single,Single,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

ColorValue.ColorValue Constructor

Initializes a new instance of the ColorValue structure.

Definition

Visual Basic Public Sub New( _
ByVal r As Single, _
ByVal g As Single, _
ByVal b As Single, _
ByVal a As Single _
)
C# public ColorValue(
float r,
float g,
float b,
float a
);
C++ public:
ColorValue(
float r,
float g,
float b,
float a
);
JScript public function ColorValue(
r : float,
g : float,
b : float,
a : float
);

Parameters

r System.Single
A Single Leave Site value that represents the level of red in the color.
g System.Single
A Single Leave Site value that represents the level of green in the color.
b System.Single
A Single Leave Site value that represents the level of blue in the color.
a System.Single
A Single Leave Site value that represents the alpha channel value of the color.


ColorValue.FillD3DColor(_D3DCOLORVALUE) Method (Microsoft.DirectX.Direct3D)

ColorValue.FillD3DColor Method

Fills a _D3DCOLORVALUE structure with the color values of the current instance.

Definition

Visual Basic Public Sub FillD3DColor( _
ByVal pColor As _D3DCOLORVALUE _
)
C# public void FillD3DColor(
_D3DCOLORVALUE pColor
);
C++ public:
void FillD3DColor(
_D3DCOLORVALUE pColor
);
JScript public function FillD3DColor(
pColor : _D3DCOLORVALUE
);

Parameters

pColor Microsoft.DirectX.PrivateImplementationDetails._D3DCOLORVALUE
A _D3DCOLORVALUE structure to contain the current color values.


ColorValue.FromArgb(Int32) Method (Microsoft.DirectX.Direct3D)

ColorValue.FromArgb Method

Initializes and returns an instance of a ColorValue structure using an Int32 Leave Site value.

Definition

Visual Basic Public Shared Function FromArgb( _
ByVal color As Integer _
) As ColorValue
C# public static ColorValue FromArgb(
int color
);
C++ public:
static ColorValue FromArgb(
int color
);
JScript public static function FromArgb(
color : int
) : ColorValue;

Parameters

color System.Int32
An Int32 Leave Site value that is used to initialize a ColorValue structure.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure whose properties are initialized to the color value.


ColorValue.FromColor(Color) Method (Microsoft.DirectX.Direct3D)

ColorValue.FromColor Method

Initializes and returns an instance of a ColorValue structure using a Color Leave Site value.

Definition

Visual Basic Public Shared Function FromColor( _
ByVal color As Color _
) As ColorValue
C# public static ColorValue FromColor(
Color color
);
C++ public:
static ColorValue FromColor(
Color color
);
JScript public static function FromColor(
color : Color
) : ColorValue;

Parameters

color System.Drawing.Color
A ColorValue used to initialize a ColorValue structure.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure whose properties are initialized to the color value.


ColorValue.FromD3DColor(_D3DCOLORVALUE) Method (Microsoft.DirectX.Direct3D)

ColorValue.FromD3DColor Method

Initializes and returns an instance of a ColorValue structure using an _D3DCOLORVALUE value.

Definition

Visual Basic Public Shared Function FromD3DColor( _
ByVal color As _D3DCOLORVALUE _
) As ColorValue
C# public static ColorValue FromD3DColor(
_D3DCOLORVALUE color
);
C++ public:
static ColorValue FromD3DColor(
_D3DCOLORVALUE color
);
JScript public static function FromD3DColor(
color : _D3DCOLORVALUE
) : ColorValue;

Parameters

color Microsoft.DirectX.PrivateImplementationDetails._D3DCOLORVALUE
A _D3DCOLORVALUE used to initialize a ColorValue structure.

Return Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure whose properties are initialized to the color value.


ColorValue.ToArgb() Method (Microsoft.DirectX.Direct3D)

ColorValue.ToArgb Method

Returns an Int32 Leave Site value that represents the color value of the current instance.

Definition

Visual Basic | Public Function ToArgb() As Integer
C# | public int ToArgb();
C++ public:
int ToArgb();
JScript | public function ToArgb() : int;

Return Value

System.Int32
An Int32 Leave Site value that represents the color value of the current instance.


ColorValue.Alpha Property (Microsoft.DirectX.Direct3D)

ColorValue.Alpha Property

Retrieves or sets the alpha channel value of the current color.

Definition

Visual Basic | Public Property Alpha As Single
C# | public float Alpha { get; set; }
C++ public:
property float Alpha {
float get();
void set(float value);
}
JScript public function get Alpha() : float
public function set Alpha(float);

Property Value

System.Single
A Single Leave Site value that represents the alpha value of the current color.

This property is read/write.


ColorValue.Blue Property (Microsoft.DirectX.Direct3D)

ColorValue.Blue Property

Retrieves or sets the blue value of the current color.

Definition

Visual Basic | Public Property Blue As Single
C# | public float Blue { get; set; }
C++ public:
property float Blue {
float get();
void set(float value);
}
JScript public function get Blue() : float
public function set Blue(float);

Property Value

System.Single
A Single Leave Site value that represents the blue value of the current color.

This property is read/write.


ColorValue.Green Property (Microsoft.DirectX.Direct3D)

ColorValue.Green Property

Retrieves or sets the green value of the current color.

Definition

Visual Basic | Public Property Green As Single
C# | public float Green { get; set; }
C++ public:
property float Green {
float get();
void set(float value);
}
JScript public function get Green() : float
public function set Green(float);

Property Value

System.Single
A Single Leave Site value that represents the green value of the current color.

This property is read/write.


ColorValue.Red Property (Microsoft.DirectX.Direct3D)

ColorValue.Red Property

Retrieves or sets the red value of the current color.

Definition

Visual Basic | Public Property Red As Single
C# | public float Red { get; set; }
C++ public:
property float Red {
float get();
void set(float value);
}
JScript public function get Red() : float
public function set Red(float);

Property Value

System.Single
A Single Leave Site value that represents the red value of the current color.

This property is read/write.


ComparisonCaps Structure (Microsoft.DirectX.Direct3D)

ComparisonCaps Structure

Retrieves comparison capabilities.

Definition

Visual Basic | Public Structure ComparisonCaps
C# | public struct ComparisonCaps
C++ | public value class ComparisonCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAlways | Retrieves a value that indicates whether always passing the comparison test is supported.
SupportsEqual | Retrieves a value that indicates whether comparison tests in which the new value equals the current value are supported.
SupportsGreater | Retrieves a value that indicates whether comparison tests in which the new value is greater than the current value are supported.
SupportsGreaterEqual | Retrieves a value that indicates whether comparison tests in which the new value is greater than or equal to the current value are supported.
SupportsLess | Retrieves a value that indicates whether comparison tests in which the new value is less than the current value are supported.
SupportsLessEqual | Retrieves a value that indicates whether comparison tests in which the new value is less than or equal to the current value are supported.
SupportsNever | Retrieves a value that indicates whether never passing the comparison test is supported.
SupportsNotEqual | Retrieves a value that indicates whether comparison tests in which the new value does not equal the current value are supported.

Remarks

Comparison capabilities are used in Caps.ZCompareCaps and Caps.AlphaCompareCaps to indicate the supported comparison operations.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ComparisonCaps.ToString() Method (Microsoft.DirectX.Direct3D)

ComparisonCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ComparisonCaps.SupportsAlways Property (Microsoft.DirectX.Direct3D)

ComparisonCaps.SupportsAlways Property

Retrieves a value that indicates whether always passing the comparison test is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsAlways As Boolean
C# | public bool SupportsAlways { get; }
C++ public:
property bool SupportsAlways {
bool get();
}
JScript | public function get SupportsAlways() : boolean

Property Value

System.Boolean
Value that is true if always passing the comparison test is supported, or false if it is not.

This property is read-only.


ComparisonCaps.SupportsEqual Property (Microsoft.DirectX.Direct3D)

ComparisonCaps.SupportsEqual Property

Retrieves a value that indicates whether comparison tests in which the new value equals the current value are supported.

Definition

Visual Basic | Public ReadOnly Property SupportsEqual As Boolean
C# | public bool SupportsEqual { get; }
C++ public:
property bool SupportsEqual {
bool get();
}
JScript | public function get SupportsEqual() : boolean

Property Value

System.Boolean
Value that is true if comparison tests in which the new value equals the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsGreater Property (Microsoft.DirectX.Direct3D)

ComparisonCaps.SupportsGreater Property

Retrieves a value that indicates whether comparison tests in which the new value is greater than the current value are supported.

Definition

Visual Basic | Public ReadOnly Property SupportsGreater As Boolean
C# | public bool SupportsGreater { get; }
C++ public:
property bool SupportsGreater {
bool get();
}
JScript | public function get SupportsGreater() : boolean

Property Value

System.Boolean
Value that is true if comparison tests in which the new value is greater than the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsGreaterEqual Property (Microsoft.DirectX.Direct3D)

ComparisonCaps.SupportsGreaterEqual Property

Retrieves a value that indicates whether comparison tests in which the new value is greater than or equal to the current value are supported.

Definition

Visual Basic | Public ReadOnly Property SupportsGreaterEqual As Boolean
C# | public bool SupportsGreaterEqual { get; }
C++ public:
property bool SupportsGreaterEqual {
bool get();
}
JScript | public function get SupportsGreaterEqual() : boolean

Property Value

System.Boolean
Value that is true if comparison tests in which the new value is greater than or equal to the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsLess Property (Microsoft.DirectX.Direct3D)

ComparisonCaps.SupportsLess Property

Retrieves a value that indicates whether comparison tests in which the new value is less than the current value are supported.

Definition

Visual Basic | Public ReadOnly Property SupportsLess As Boolean
C# | public bool SupportsLess { get; }
C++ public:
property bool SupportsLess {
bool get();
}
JScript | public function get SupportsLess() : boolean

Property Value

System.Boolean
Value that is true if comparison tests in which the new value is less than the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsLessEqual Property (Microsoft.DirectX.Direct3D)

ComparisonCaps.SupportsLessEqual Property

Retrieves a value that indicates whether comparison tests in which the new value is less than or equal to the current value are supported.

Definition

Visual Basic | Public ReadOnly Property SupportsLessEqual As Boolean
C# | public bool SupportsLessEqual { get; }
C++ public:
property bool SupportsLessEqual {
bool get();
}
JScript | public function get SupportsLessEqual() : boolean

Property Value

System.Boolean
Value that is true if comparison tests in which the new value is less than or equal to the current value are supported, or false if they are not.

This property is read-only.


ComparisonCaps.SupportsNever Property (Microsoft.DirectX.Direct3D)

ComparisonCaps.SupportsNever Property

Retrieves a value that indicates whether never passing the comparison test is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsNever As Boolean
C# | public bool SupportsNever { get; }
C++ public:
property bool SupportsNever {
bool get();
}
JScript | public function get SupportsNever() : boolean

Property Value

System.Boolean
Value that is true if never passing the comparison test is supported, or false if it is not.

This property is read-only.


ComparisonCaps.SupportsNotEqual Property (Microsoft.DirectX.Direct3D)

ComparisonCaps.SupportsNotEqual Property

Retrieves a value that indicates whether comparison tests in which the new value does not equal the current value are supported.

Definition

Visual Basic | Public ReadOnly Property SupportsNotEqual As Boolean
C# | public bool SupportsNotEqual { get; }
C++ public:
property bool SupportsNotEqual {
bool get();
}
JScript | public function get SupportsNotEqual() : boolean

Property Value

System.Boolean
Value that is true if comparison tests in which the new value does not equal the current value are supported, or false if they are not.

This property is read-only.


ConstantDescription Structure (Microsoft.DirectX.Direct3D)

ConstantDescription Structure

Describes a constant in a constant table.

Definition

Visual Basic | Public Structure ConstantDescription
C# | public struct ConstantDescription
C++ | public value class ConstantDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ConstantDescription | Initializes a new instance of the ConstantDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Class | Retrieves or sets the parameter class of the constant.
Columns | Retrieves or sets a value that indicates the number of columns.
DefaultData | Retrieves or sets a reference to the default value for the constant.
Elements | Retrieves or sets the number of elements in the array.
Name | Retrieves or sets the name of the constant.
ParameterType | Retrieves or sets the parameter type of the constant.
RegisterCount | Retrieves or sets the number of registers that contain data.
RegisterIndex | Retrieves or sets the index of the constant in the constant table.
RegisterSet | Retrieves or sets the constant data type.
Rows | Retrieves or sets a value that indicates the number of rows.
StructMembers | Retrieves or sets a value that indicates the number of structure member sub-parameters.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • ConstantTable.GetConstantDescription
  • ConstantTableDescription


ConstantDescription.ConstantDescription() Constructor (Microsoft.DirectX.Direct3D)

ConstantDescription.ConstantDescription Constructor

Initializes a new instance of the ConstantDescription class.

Definition

Visual Basic | Public Sub New()
C# | public ConstantDescription();
C++ public:
ConstantDescription();
JScript | public function ConstantDescription();


ConstantDescription.ToString() Method (Microsoft.DirectX.Direct3D)

ConstantDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConstantDescription.Class Property (Microsoft.DirectX.Direct3D)

ConstantDescription.Class Property

Retrieves or sets the parameter class of the constant.

Definition

Visual Basic | Public Property Class As ParameterClass
C# | public ParameterClass Class { get; set; }
C++ public:
property ParameterClass Class {
ParameterClass get();
void set(ParameterClass value);
}
JScript public function get Class() : ParameterClass
public function set Class(ParameterClass);

Property Value

Microsoft.DirectX.Direct3D.ParameterClass
The ParameterClass object of the constant.

This property is read/write.


ConstantDescription.Columns Property (Microsoft.DirectX.Direct3D)

ConstantDescription.Columns Property

Retrieves or sets a value that indicates the number of columns.

Definition

Visual Basic | Public Property Columns As Integer
C# | public int Columns { get; set; }
C++ public:
property int Columns {
int get();
void set(int value);
}
JScript public function get Columns() : int
public function set Columns(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of columns.

This property is read/write.


ConstantDescription.DefaultData Property (Microsoft.DirectX.Direct3D)

ConstantDescription.DefaultData Property

Retrieves or sets a reference to the default value for the constant.

Definition

Visual Basic | Public Property DefaultData As GraphicsStream
C# | public GraphicsStream DefaultData { get; set; }
C++ public:
property GraphicsStream^ DefaultData {
GraphicsStream^ get();
void set(GraphicsStream^ value);
}
JScript public function get DefaultData() : GraphicsStream
public function set DefaultData(GraphicsStream);

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the default value for the constant.

This property is read/write.


ConstantDescription.Elements Property (Microsoft.DirectX.Direct3D)

ConstantDescription.Elements Property

Retrieves or sets the number of elements in the array.

Definition

Visual Basic | Public Property Elements As Integer
C# | public int Elements { get; set; }
C++ public:
property int Elements {
int get();
void set(int value);
}
JScript public function get Elements() : int
public function set Elements(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of elements in the array.

This property is read/write.


ConstantDescription.Name Property (Microsoft.DirectX.Direct3D)

ConstantDescription.Name Property

Retrieves or sets the name of the constant.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String
A String Leave Site object that contains the name of the constant.

This property is read/write.


ConstantDescription.ParameterType Property (Microsoft.DirectX.Direct3D)

ConstantDescription.ParameterType Property

Retrieves or sets the parameter type of the constant.

Definition

Visual Basic | Public Property ParameterType As ParameterType
C# | public ParameterType ParameterType { get; set; }
C++ public:
property ParameterType ParameterType {
ParameterType get();
void set(ParameterType value);
}
JScript public function get ParameterType() : ParameterType
public function set ParameterType(ParameterType);

Property Value

Microsoft.DirectX.Direct3D.ParameterType
A ParameterType instance that indicates the parameter type of the constant.

This property is read/write.


ConstantDescription.RegisterCount Property (Microsoft.DirectX.Direct3D)

ConstantDescription.RegisterCount Property

Retrieves or sets the number of registers that contain data.

Definition

Visual Basic | Public Property RegisterCount As Integer
C# | public int RegisterCount { get; set; }
C++ public:
property int RegisterCount {
int get();
void set(int value);
}
JScript public function get RegisterCount() : int
public function set RegisterCount(int);

Property Value

System.Int32
An Int32 Leave Site object that indicates the number of registers that contain data.

This property is read/write.


ConstantDescription.RegisterIndex Property (Microsoft.DirectX.Direct3D)

ConstantDescription.RegisterIndex Property

Retrieves or sets the index of the constant in the constant table.

Definition

Visual Basic | Public Property RegisterIndex As Integer
C# | public int RegisterIndex { get; set; }
C++ public:
property int RegisterIndex {
int get();
void set(int value);
}
JScript public function get RegisterIndex() : int
public function set RegisterIndex(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the index of the constant in the ConstantTable.

This property is read/write.

Remarks

The constant table index is zero-based.


ConstantDescription.RegisterSet Property (Microsoft.DirectX.Direct3D)

ConstantDescription.RegisterSet Property

Retrieves or sets the constant data type.

Definition

Visual Basic | Public Property RegisterSet As RegisterSet
C# | public RegisterSet RegisterSet { get; set; }
C++ public:
property RegisterSet RegisterSet {
RegisterSet get();
void set(RegisterSet value);
}
JScript public function get RegisterSet() : RegisterSet
public function set RegisterSet(RegisterSet);

Property Value

Microsoft.DirectX.Direct3D.RegisterSet
A RegisterSet instance that indicates the constant data type.

This property is read/write.


ConstantDescription.Rows Property (Microsoft.DirectX.Direct3D)

ConstantDescription.Rows Property

Retrieves or sets a value that indicates the number of rows.

Definition

Visual Basic | Public Property Rows As Integer
C# | public int Rows { get; set; }
C++ public:
property int Rows {
int get();
void set(int value);
}
JScript public function get Rows() : int
public function set Rows(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of rows.

This property is read/write.


ConstantDescription.StructMembers Property (Microsoft.DirectX.Direct3D)

ConstantDescription.StructMembers Property

Retrieves or sets a value that indicates the number of structure member sub-parameters.

Definition

Visual Basic | Public Property StructMembers As Integer
C# | public int StructMembers { get; set; }
C++ public:
property int StructMembers {
int get();
void set(int value);
}
JScript public function get StructMembers() : int
public function set StructMembers(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of structure member sub-parameters.

This property is read/write.


ConstantTableDescription Structure (Microsoft.DirectX.Direct3D)

ConstantTableDescription Structure

Describes the constant table.

Definition

Visual Basic | Public Structure ConstantTableDescription
C# | public struct ConstantTableDescription
C++ | public value class ConstantTableDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ConstantTableDescription | Initializes a new instance of the ConstantTableDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Constants | Retrieves or sets the number of constants in the constant table.
Creator | Retrieves or sets the name of the constant table creator.
Version | Retrieves or sets a value that indicates the shader version of the constant table.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • ConstantDescription


ConstantTableDescription.ConstantTableDescription() Constructor (Microsoft.DirectX.Direct3D)

ConstantTableDescription.ConstantTableDescription Constructor

 Language:

Initializes a new instance of the ConstantTableDescription class.

Definition

Visual Basic | Public Sub New()
C# | public ConstantTableDescription();
C++ public:
ConstantTableDescription();
JScript | public function ConstantTableDescription();


ConstantTableDescription.ToString() Method (Microsoft.DirectX.Direct3D)

ConstantTableDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConstantTableDescription.Constants Property (Microsoft.DirectX.Direct3D)

ConstantTableDescription.Constants Property

Retrieves or sets the number of constants in the constant table.

Definition

Visual Basic | Public Property Constants As Integer
C# | public int Constants { get; set; }
C++ public:
property int Constants {
int get();
void set(int value);
}
JScript public function get Constants() : int
public function set Constants(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of constants in the ConstantTable.

This property is read/write.


ConstantTableDescription.Creator Property (Microsoft.DirectX.Direct3D)

ConstantTableDescription.Creator Property

Retrieves or sets the name of the constant table creator.

Definition

Visual Basic | Public Property Creator As String
C# | public string Creator { get; set; }
C++ public:
property String^ Creator {
String^ get();
void set(String^ value);
}
JScript public function get Creator() : String
public function set Creator(String);

Property Value

System.String
A String Leave Site object that contains the name of the constant table creator.

This property is read/write.


ConstantTableDescription.Version Property (Microsoft.DirectX.Direct3D)

ConstantTableDescription.Version Property

Retrieves or sets a value that indicates the shader version of the constant table.

Definition

Visual Basic | Public Property Version As Integer
C# | public int Version { get; set; }
C++ public:
property int Version {
int get();
void set(int value);
}
JScript public function get Version() : int
public function set Version(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the shader version of the constant table.

This property is read/write.


CubeTextureRequirements Structure (Microsoft.DirectX.Direct3D)

CubeTextureRequirements Structure

Contains cube texture creation parameters.

Definition

Visual Basic | Public Structure CubeTextureRequirements
C# | public struct CubeTextureRequirements
C++ | public value class CubeTextureRequirements sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CubeTextureRequirements | Initializes a new instance of the CubeTextureRequirements class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Format | Retrieves or sets the desired pixel format.
NumberMipLevels | Retrieves or sets the number of mipmap levels for a cube texture.
Size | Retrieves or sets the size of a cube texture.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CubeTextureRequirements.CubeTextureRequirements() Constructor (Microsoft.DirectX.Direct3D)

CubeTextureRequirements.CubeTextureRequirements Constructor

How Do I...?
  • Create a Cube Texture

Initializes a new instance of the CubeTextureRequirements class.

Definition

Visual Basic | Public Sub New()
C# | public CubeTextureRequirements();
C++ public:
CubeTextureRequirements();
JScript | public function CubeTextureRequirements();

How Do I...?

Create a Cube Texture

This example demonstrates how to create a cube texture.

A cube texture is created after the hardware is checked to ensure that cube textures are supported. The new cube texture has an edge length of 16 pixels, and no Usage value. Provided the hardware supports mipmap cube textures, all cube texture sublevels down to 1x1 pixels for each face are automatically generated.

In the following C# code example, device is assumed to be the rendering Device. Developers should also check to ensure that the hardware supports the X8R8G8B8 format.

              [C#]

//Check cube texture requirements.
CubeTextureRequirements tr = new CubeTextureRequirements();

tr.Format = Format.A8R8G8B8;

TextureLoader.CheckCubeTextureRequirements(device, 0,
                                           Pool.Managed, out tr);

//Create texture.
CubeTexture cube = new CubeTexture( device, 16, 0, 0, Format.X8R8G8B8, Pool.Managed );


CubeTextureRequirements.ToString() Method (Microsoft.DirectX.Direct3D)

CubeTextureRequirements.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CubeTextureRequirements.Format Property (Microsoft.DirectX.Direct3D)

CubeTextureRequirements.Format Property

Retrieves or sets the desired pixel format.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
A Format value that specifies the pixel format to set or retrieve.

This property is read/write.


CubeTextureRequirements.NumberMipLevels Property (Microsoft.DirectX.Direct3D)

CubeTextureRequirements.NumberMipLevels Property

Retrieves or sets the number of mipmap levels for a cube texture.

Definition

Visual Basic | Public Property NumberMipLevels As Integer
C# | public int NumberMipLevels { get; set; }
C++ public:
property int NumberMipLevels {
int get();
void set(int value);
}
JScript public function get NumberMipLevels() : int
public function set NumberMipLevels(int);

Property Value

System.Int32
Integer value that represents the mipmap levels to set or retrieve.

This property is read/write.


CubeTextureRequirements.Size Property (Microsoft.DirectX.Direct3D)

CubeTextureRequirements.Size Property

Retrieves or sets the size of a cube texture.

Definition

Visual Basic | Public Property Size As Integer
C# | public int Size { get; set; }
C++ public:
property int Size {
int get();
void set(int value);
}
JScript public function get Size() : int
public function set Size(int);

Property Value

System.Int32
Integer value that represents the height and width of the cube texture, in pixels.

This property is read/write.


CursorCaps Structure (Microsoft.DirectX.Direct3D)

CursorCaps Structure

Indicates the hardware support that is available for cursors.

Definition

Visual Basic | Public Structure CursorCaps
C# | public struct CursorCaps
C++ | public value class CursorCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsColor | Retrieves a value that indicates that a full-color cursor is supported in hardware.
SupportsLowResolution | Retrieves a value that indicates that a full-color cursor is supported in both high-resolution and low-resolution modes.

Remarks

Microsoft DirectX 9.0 does not define alpha-blending cursor capabilities.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CursorCaps.ToString() Method (Microsoft.DirectX.Direct3D)

CursorCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CursorCaps.SupportsColor Property (Microsoft.DirectX.Direct3D)

CursorCaps.SupportsColor Property

Retrieves a value that indicates that a full-color cursor is supported in hardware.

Definition

Visual Basic | Public ReadOnly Property SupportsColor As Boolean
C# | public bool SupportsColor { get; }
C++ public:
property bool SupportsColor {
bool get();
}
JScript | public function get SupportsColor() : boolean

Property Value

System.Boolean
Value that is true if a full-color cursor is supported in hardware, or false otherwise.

This property is read-only.

Remarks

Specifically, this flag indicates that the driver supports at least a hardware color cursor in high-resolution modes (with scan lines greater than or equal to 400).


CursorCaps.SupportsLowResolution Property (Microsoft.DirectX.Direct3D)

CursorCaps.SupportsLowResolution Property

Retrieves a value that indicates that a full-color cursor is supported in both high-resolution and low-resolution modes.

Definition

Visual Basic | Public ReadOnly Property SupportsLowResolution As Boolean
C# | public bool SupportsLowResolution { get; }
C++ public:
property bool SupportsLowResolution {
bool get();
}
JScript | public function get SupportsLowResolution() : boolean

Property Value

System.Boolean
Value that is true if a full-color cursor is supported in both high-resolution and low-resolution modes, or false otherwise.

This property is read-only.


DeclarationTypeCaps Structure (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps Structure

Indicates the type of data formats that are supported in a vertex declaration.

Definition

Visual Basic | Public Structure DeclarationTypeCaps
C# | public struct DeclarationTypeCaps
C++ | public value class DeclarationTypeCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsDec3N | Indicates that a 3-dimension signed 10 10 10 format is supported for vertex declarations.
SupportsFloat16Four | Indicates that a 4-dimension 16-bit floating-point numbers format is supported for vertex declarations.
SupportsFloat16Two | Indicates that a 2-dimension 16-bit floating-point numbers format is supported for vertex declarations.
SupportsShort2N | Indicates that a normalized, 2-D signed short format is supported for vertex declarations.
SupportsShort4N | Indicates that a normalized, 4-D signed short format is supported for vertex declarations.
SupportsUByte4 | Indicates that a 4-dimension unsigned byte format is supported for vertex declarations.
SupportsUByte4N | Indicates that a normalized, 4-dimension unsigned byte format is supported for vertex declarations.
SupportsUDec3 | Indicates that a 3-dimension unsigned 10 10 10 format is supported for vertex declarations.
SupportsUShort2N | Indicates that a normalized, 2-dimension unsigned short format is supported for vertex declarations.
SupportsUShort4N | Indicates that a normalized 4-D unsigned short format is supported for vertex declarations.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeclarationTypeCaps.ToString() Method (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeclarationTypeCaps.SupportsDec3N Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsDec3N Property

Indicates that a 3-dimension signed 10 10 10 format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsDec3N As Boolean
C# | public bool SupportsDec3N { get; }
C++ public:
property bool SupportsDec3N {
bool get();
}
JScript | public function get SupportsDec3N() : boolean

Property Value

System.Boolean
Value that is true if a 3-dimension signed 10 10 10 format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (v[0]/511.0, v[1]/511.0, v[2]/511.0, 1).


DeclarationTypeCaps.SupportsFloat16Four Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsFloat16Four Property

Indicates that a 4-dimension 16-bit floating-point numbers format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsFloat16Four As Boolean
C# | public bool SupportsFloat16Four { get; }
C++ public:
property bool SupportsFloat16Four {
bool get();
}
JScript | public function get SupportsFloat16Four() : boolean

Property Value

System.Boolean
Value that is true if a 4-dimension 16-bit floating-point numbers format is supported for vertex declarations, or false if it is not.

This property is read-only.


DeclarationTypeCaps.SupportsFloat16Two Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsFloat16Two Property

Indicates that a 2-dimension 16-bit floating-point numbers format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsFloat16Two As Boolean
C# | public bool SupportsFloat16Two { get; }
C++ public:
property bool SupportsFloat16Two {
bool get();
}
JScript | public function get SupportsFloat16Two() : boolean

Property Value

System.Boolean
Value that is true if a 2-dimension 16-bit floating-point numbers format is supported for vertex declarations, or false if it is not.

This property is read-only.


DeclarationTypeCaps.SupportsShort2N Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsShort2N Property

Indicates that a normalized, 2-D signed short format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsShort2N As Boolean
C# | public bool SupportsShort2N { get; }
C++ public:
property bool SupportsShort2N {
bool get();
}
JScript | public function get SupportsShort2N() : boolean

Property Value

System.Boolean
Value that is true if a 2-D signed short format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (first byte/32767.0, second byte/32767.0, 0, 1).


DeclarationTypeCaps.SupportsShort4N Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsShort4N Property

Indicates that a normalized, 4-D signed short format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsShort4N As Boolean
C# | public bool SupportsShort4N { get; }
C++ public:
property bool SupportsShort4N {
bool get();
}
JScript | public function get SupportsShort4N() : boolean

Property Value

System.Boolean
Value that is true if a normalized, 4-D signed short format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (first byte/65535.0, second byte/65535.0, third byte/65535.0, fourth byte/65535.0).


DeclarationTypeCaps.SupportsUByte4 Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsUByte4 Property

Indicates that a 4-dimension unsigned byte format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsUByte4 As Boolean
C# | public bool SupportsUByte4 { get; }
C++ public:
property bool SupportsUByte4 {
bool get();
}
JScript | public function get SupportsUByte4() : boolean

Property Value

System.Boolean
Value that is true if a normalized, 4-dimension unsigned byte format is supported for vertex declarations, or false if it is not.

This property is read-only.


DeclarationTypeCaps.SupportsUByte4N Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsUByte4N Property

Indicates that a normalized, 4-dimension unsigned byte format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsUByte4N As Boolean
C# | public bool SupportsUByte4N { get; }
C++ public:
property bool SupportsUByte4N {
bool get();
}
JScript | public function get SupportsUByte4N() : boolean

Property Value

System.Boolean
Value that is true if a normalized, 4-dimension unsigned byte format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

Each of the four bytes is normalized by dividing by 255.0.


DeclarationTypeCaps.SupportsUDec3 Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsUDec3 Property

Indicates that a 3-dimension unsigned 10 10 10 format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsUDec3 As Boolean
C# | public bool SupportsUDec3 { get; }
C++ public:
property bool SupportsUDec3 {
bool get();
}
JScript | public function get SupportsUDec3() : boolean

Property Value

System.Boolean
Value that is true if a 3-dimension unsigned 10 10 10 format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (value, value, value, 1).


DeclarationTypeCaps.SupportsUShort2N Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsUShort2N Property

Indicates that a normalized, 2-dimension unsigned short format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsUShort2N As Boolean
C# | public bool SupportsUShort2N { get; }
C++ public:
property bool SupportsUShort2N {
bool get();
}
JScript | public function get SupportsUShort2N() : boolean

Property Value

System.Boolean
Value that is true if a normalized, 2-dimension unsigned short format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (first byte/32767.0, second byte/32767.0, 0, 1).


DeclarationTypeCaps.SupportsUShort4N Property (Microsoft.DirectX.Direct3D)

DeclarationTypeCaps.SupportsUShort4N Property

Indicates that a normalized 4-D unsigned short format is supported for vertex declarations.

Definition

Visual Basic | Public ReadOnly Property SupportsUShort4N As Boolean
C# | public bool SupportsUShort4N { get; }
C++ public:
property bool SupportsUShort4N {
bool get();
}
JScript | public function get SupportsUShort4N() : boolean

Property Value

System.Boolean
Value that is true if a normalized 4-D unsigned short format is supported for vertex declarations, or false if it is not.

This property is read-only.

Remarks

This format expands to (first byte/32767.0, second byte/32767.0, third byte/32767.0, fourth byte/32767.0).


DegenerateItems Structure (Microsoft.DirectX.Direct3D)

DegenerateItems Structure

Indicates the index of patches and vertices that cause the PatchMesh.Validate method to fail.

Definition

Visual Basic | Public Structure DegenerateItems
C# | public struct DegenerateItems
C++ | public value class DegenerateItems sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DegenerateItems | Initializes a new instance of the DegenerateItems class.

Properties

Property | Description
DegeneratePatches | Retrieves the index of patches that cause the PatchMesh.Validate method to fail.
DegenerateVertices | Retrieves the index of vertices that cause the PatchMesh.Validate method to fail.

Remarks

The PatchMesh.Validate method returns an instance of this class.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DegenerateItems.DegenerateItems() Constructor (Microsoft.DirectX.Direct3D)

DegenerateItems.DegenerateItems Constructor

Initializes a new instance of the DegenerateItems class.

Definition

Visual Basic | Public Sub New()
C# | public DegenerateItems();
C++ public:
DegenerateItems();
JScript | public function DegenerateItems();


DegenerateItems.DegeneratePatches Property (Microsoft.DirectX.Direct3D)

DegenerateItems.DegeneratePatches Property

Retrieves the index of patches that cause the PatchMesh.Validate method to fail.

Definition

Visual Basic | Public ReadOnly Property DegeneratePatches As Integer
C# | public int DegeneratePatches { get; }
C++ public:
property int DegeneratePatches {
int get();
}
JScript | public function get DegeneratePatches() : int

Property Value

System.Int32
An Int32 Leave Site value that represents the index of patches that cause the PatchMesh.Validate method to fail.

This property is read-only.


DegenerateItems.DegenerateVertices Property (Microsoft.DirectX.Direct3D)

DegenerateItems.DegenerateVertices Property

Retrieves the index of vertices that cause the PatchMesh.Validate method to fail.

Definition

Visual Basic | Public ReadOnly Property DegenerateVertices As Integer
C# | public int DegenerateVertices { get; }
C++ public:
property int DegenerateVertices {
int get();
}
JScript | public function get DegenerateVertices() : int

Property Value

System.Int32
An Int32 Leave Site value that represents the index of vertices that cause the PatchMesh.Validate method to fail.

This property is read-only.


DeviceCaps Structure (Microsoft.DirectX.Direct3D)

DeviceCaps Structure

Retrieves device-specific information about a device.

Definition

Visual Basic | Public Structure DeviceCaps
C# | public struct DeviceCaps
C++ | public value class DeviceCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
CanDrawSystemToNonLocal | Indicates whether the device supports copying from system memory textures to nonlocal video memory textures.
CanRenderAfterFlip | Indicates whether the device supports queue-rendering commands after a page flip.
CanStretchRectangleFromTextures | Indicates whether the device supports Device.StretchRectangle using a texture as the source.
SupportsAdaptiveTessellateNPatch | Indicates whether the device supports adaptive tessellation of N-patches.
SupportsAdaptiveTessellateRtPatch | Indicates whether the device supports adaptive tessellation of RT-patches.
SupportsDMapNPatch | Indicates whether the device supports displacement maps for N-patches.
SupportsDrawPrimitives2 | Indicates whether the device supports DrawPrimitives2.
SupportsDrawPrimitives2Ex | Indicates whether the device supports extended DrawPrimitives2.
SupportsDrawPrimitivesTransformedVertex | Indicates whether the device exports a hardware abstraction layer (HAL) that is aware of DrawPrimitives.
SupportsExecuteSystemMemory | Indicates whether the device uses executable buffers from system memory.
SupportsExecuteVideoMemory | Indicates whether the device uses executable buffers from video memory.
SupportsHardwareRasterization | Indicates whether the device has hardware acceleration for scene rasterization.
SupportsHardwareTransformAndLight | Indicates whether the device supports transformation and lighting in hardware.
SupportsNPatches | Indicates whether the device supports N-patches.
SupportsPreSampledDMapNPatch | Indicates whether the device supports presampled displacement maps for N-patches.
SupportsPureDevice | Indicates whether the device supports rasterization, transformations, lighting, and shading in hardware.
SupportsQuinticRtPatches | Indicates whether the device supports quintic cubic Bezier curves and B-splines.
SupportsRtPatches | Indicates whether the device supports rectangular and triangular patches.
SupportsRtPatchHandleZero | Indicates whether the hardware architecture does not require caching of any information and whether uncached (handle-zero) patches are drawn as efficiently as cached ones.
SupportsSeparateTextureMemories | Indicates whether the device is texturing from separate memory pools.
SupportsStreamOffset | Indicates whether the device supports stream offsets.
SupportsTextureNonLocalVideoMemory | Indicates whether the device can retrieve textures from nonlocal video memory.
SupportsTextureSystemMemory | Indicates whether the device can retrieve textures from system memory.
SupportsTextureVideoMemory | Indicates whether the device can retrieve textures from device memory.
SupportsTransformedVertexSystemMemory | Indicates whether the device uses buffers from system memory for transformed and lit vertices.
SupportsTransformedVertexVideoMemory | Indicates whether the device uses buffers from video memory for transformed and lit vertices.
VertexElementScanSharesStreamOffset | Indicates whether multiple vertex elements share the same offset in a stream.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceCaps.ToString() Method (Microsoft.DirectX.Direct3D)

DeviceCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String representation of the object.


DeviceCaps.CanDrawSystemToNonLocal Property (Microsoft.DirectX.Direct3D)

DeviceCaps.CanDrawSystemToNonLocal Property

Indicates whether the device supports copying from system memory textures to nonlocal video memory textures.

Definition

Visual Basic | Public ReadOnly Property CanDrawSystemToNonLocal As Boolean
C# | public bool CanDrawSystemToNonLocal { get; }
C++ public:
property bool CanDrawSystemToNonLocal {
bool get();
}
JScript | public function get CanDrawSystemToNonLocal() : boolean

Property Value

System.Boolean
Value that is true if the device supports copying from system memory textures to nonlocal video memory textures, or false if it does not.

This property is read-only.


DeviceCaps.CanRenderAfterFlip Property (Microsoft.DirectX.Direct3D)

DeviceCaps.CanRenderAfterFlip Property

Indicates whether the device supports queue-rendering commands after a page flip.

Definition

Visual Basic | Public ReadOnly Property CanRenderAfterFlip As Boolean
C# | public bool CanRenderAfterFlip { get; }
C++ public:
property bool CanRenderAfterFlip {
bool get();
}
JScript | public function get CanRenderAfterFlip() : boolean

Property Value

System.Boolean
Value that is true if the device supports queue-rendering commands after a page flip, or false if it does not.

This property is read-only.

Remarks

Applications do not change their behavior if this flag is set; this capability means that the device is relatively fast.


DeviceCaps.CanStretchRectangleFromTextures Property (Microsoft.DirectX.Direct3D)

DeviceCaps.CanStretchRectangleFromTextures Property

Indicates whether the device supports Device.StretchRectangle using a texture as the source.

Definition

Visual Basic | Public ReadOnly Property CanStretchRectangleFromTextures As Boolean
C# | public bool CanStretchRectangleFromTextures { get; }
C++ public:
property bool CanStretchRectangleFromTextures {
bool get();
}
JScript | public function get CanStretchRectangleFromTextures() : boolean

Property Value

System.Boolean
Value that is true if the device supports Device.StretchRectangle using a texture as the source, or false if it does not.

This property is read-only.


DeviceCaps.SupportsAdaptiveTessellateNPatch Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsAdaptiveTessellateNPatch Property

Indicates whether the device supports adaptive tessellation of N-patches.

Definition

Visual Basic | Public ReadOnly Property SupportsAdaptiveTessellateNPatch As Boolean
C# | public bool SupportsAdaptiveTessellateNPatch { get; }
C++ public:
property bool SupportsAdaptiveTessellateNPatch {
bool get();
}
JScript | public function get SupportsAdaptiveTessellateNPatch() : boolean

Property Value

System.Boolean
Value that is true if the device supports adaptive tessellation of N-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsAdaptiveTessellateRtPatch Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsAdaptiveTessellateRtPatch Property

Indicates whether the device supports adaptive tessellation of RT-patches.

Definition

Visual Basic | Public ReadOnly Property SupportsAdaptiveTessellateRtPatch As Boolean
C# | public bool SupportsAdaptiveTessellateRtPatch { get; }
C++ public:
property bool SupportsAdaptiveTessellateRtPatch {
bool get();
}
JScript | public function get SupportsAdaptiveTessellateRtPatch() : boolean

Property Value

System.Boolean
Value that is true if the device supports adaptive tessellation of RT-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsDMapNPatch Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsDMapNPatch Property

Indicates whether the device supports displacement maps for N-patches.

Definition

Visual Basic | Public ReadOnly Property SupportsDMapNPatch As Boolean
C# | public bool SupportsDMapNPatch { get; }
C++ public:
property bool SupportsDMapNPatch {
bool get();
}
JScript | public function get SupportsDMapNPatch() : boolean

Property Value

System.Boolean
Value that is true if the device supports displacement maps for N-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsDrawPrimitives2 Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsDrawPrimitives2 Property

Indicates whether the device supports DrawPrimitives2.

Definition

Visual Basic | Public ReadOnly Property SupportsDrawPrimitives2 As Boolean
C# | public bool SupportsDrawPrimitives2 { get; }
C++ public:
property bool SupportsDrawPrimitives2 {
bool get();
}
JScript | public function get SupportsDrawPrimitives2() : boolean

Property Value

System.Boolean
Value that is true if the device supports DrawPrimitives2, or false if it does not.

This property is read-only.


DeviceCaps.SupportsDrawPrimitives2Ex Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsDrawPrimitives2Ex Property

Indicates whether the device supports extended DrawPrimitives2.

Definition

Visual Basic | Public ReadOnly Property SupportsDrawPrimitives2Ex As Boolean
C# | public bool SupportsDrawPrimitives2Ex { get; }
C++ public:
property bool SupportsDrawPrimitives2Ex {
bool get();
}
JScript | public function get SupportsDrawPrimitives2Ex() : boolean

Property Value

System.Boolean
Value that is true if the device supports extended DrawPrimitives2, or false if it does not.

This property is read-only.

Remarks

DrawPrimitives2 is a Microsoft DirectX 7.0 method.


DeviceCaps.SupportsDrawPrimitivesTransformedVertex Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsDrawPrimitivesTransformedVertex Property

Indicates whether the device exports a hardware abstraction layer (HAL) that is aware of DrawPrimitives.

Definition

Visual Basic | Public ReadOnly Property SupportsDrawPrimitivesTransformedVertex As Boolean
C# | public bool SupportsDrawPrimitivesTransformedVertex { get; }
C++ public:
property bool SupportsDrawPrimitivesTransformedVertex {
bool get();
}
JScript | public function get SupportsDrawPrimitivesTransformedVertex() : boolean

Property Value

System.Boolean
Value that is true if the device exports a HAL that is aware of DrawPrimitives, or false if it does not.

This property is read-only.


DeviceCaps.SupportsExecuteSystemMemory Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsExecuteSystemMemory Property

Indicates whether the device uses executable buffers from system memory.

Definition

Visual Basic | Public ReadOnly Property SupportsExecuteSystemMemory As Boolean
C# | public bool SupportsExecuteSystemMemory { get; }
C++ public:
property bool SupportsExecuteSystemMemory {
bool get();
}
JScript | public function get SupportsExecuteSystemMemory() : boolean

Property Value

System.Boolean
Value that is true if the device uses executable buffers from system memory, or false if it does not.

This property is read-only.

Remarks

This property is provided for legacy compatibility. Executable buffers are a Microsoft DirectX 5.0 feature.


DeviceCaps.SupportsExecuteVideoMemory Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsExecuteVideoMemory Property

Indicates whether the device uses executable buffers from video memory.

Definition

Visual Basic | Public ReadOnly Property SupportsExecuteVideoMemory As Boolean
C# | public bool SupportsExecuteVideoMemory { get; }
C++ public:
property bool SupportsExecuteVideoMemory {
bool get();
}
JScript | public function get SupportsExecuteVideoMemory() : boolean

Property Value

System.Boolean
Value that is true if the device uses executable buffers from video memory, or false if it cannot.

This property is read-only.


DeviceCaps.SupportsHardwareRasterization Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsHardwareRasterization Property

Indicates whether the device has hardware acceleration for scene rasterization.

Definition

Visual Basic | Public ReadOnly Property SupportsHardwareRasterization As Boolean
C# | public bool SupportsHardwareRasterization { get; }
C++ public:
property bool SupportsHardwareRasterization {
bool get();
}
JScript | public function get SupportsHardwareRasterization() : boolean

Property Value

System.Boolean
Value that is true if the device has hardware acceleration for scene rasterization, or false if it does not.

This property is read-only.


DeviceCaps.SupportsHardwareTransformAndLight Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsHardwareTransformAndLight Property

How Do I...?
  • Check for Shader Support

Indicates whether the device supports transformation and lighting in hardware.

Definition

Visual Basic | Public ReadOnly Property SupportsHardwareTransformAndLight As Boolean
C# | public bool SupportsHardwareTransformAndLight { get; }
C++ public:
property bool SupportsHardwareTransformAndLight {
bool get();
}
JScript | public function get SupportsHardwareTransformAndLight() : boolean

Property Value

System.Boolean
Value that is true if the device supports transformation and lighting in hardware, or false if it does not.

This property is read-only.

How Do I...?

Check for Shader Support

This example shows how to check the hardware device for shader support.

To determine whether the hardware device supports shaders, Microsoft Direct3D allows the application to check the shader version.

To check for shader support:

  1. Obtain the device's capabilities by using the Manager.GetDeviceCaps method.
  2. Using the capabilities object obtained with the previous call, check the shader version by calling Caps.VertexShaderVersion.

              [C#]

public bool CheckShaderSupport()
{
    Version v1_1 = new Version(1,1); // check version is at least shader 1.1

    // retrieve the device caps
    Caps caps = Manager.GetDeviceCaps(0, DeviceType.Hardware);

    // check the supported shader version
    if ((caps.VertexShaderVersion >= v1_1) && (caps.PixelShaderVersion >= v1_1))
    {
        return true;
    }

    return false;
}


DeviceCaps.SupportsNPatches Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsNPatches Property

Indicates whether the device supports N-patches.

Definition

Visual Basic | Public ReadOnly Property SupportsNPatches As Boolean
C# | public bool SupportsNPatches { get; }
C++ public:
property bool SupportsNPatches {
bool get();
}
JScript | public function get SupportsNPatches() : boolean

Property Value

System.Boolean
Value that is true if the device supports N-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsPreSampledDMapNPatch Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsPreSampledDMapNPatch Property

Indicates whether the device supports presampled displacement maps for N-patches.

Definition

Visual Basic | Public ReadOnly Property SupportsPreSampledDMapNPatch As Boolean
C# | public bool SupportsPreSampledDMapNPatch { get; }
C++ public:
property bool SupportsPreSampledDMapNPatch {
bool get();
}
JScript | public function get SupportsPreSampledDMapNPatch() : boolean

Property Value

System.Boolean
Value that is true if the device supports presampled displacement maps for N-patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsPureDevice Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsPureDevice Property

Indicates whether the device supports rasterization, transformations, lighting, and shading in hardware.

Definition

Visual Basic | Public ReadOnly Property SupportsPureDevice As Boolean
C# | public bool SupportsPureDevice { get; }
C++ public:
property bool SupportsPureDevice {
bool get();
}
JScript | public function get SupportsPureDevice() : boolean

Property Value

System.Boolean
Value that is true if the device supports rasterization, transformations, lighting, and shading in hardware, or false if it does not.

This property is read-only.


DeviceCaps.SupportsQuinticRtPatches Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsQuinticRtPatches Property

Indicates whether the device supports quintic cubic Bezier curves and B-splines.

Definition

Visual Basic | Public ReadOnly Property SupportsQuinticRtPatches As Boolean
C# | public bool SupportsQuinticRtPatches { get; }
C++ public:
property bool SupportsQuinticRtPatches {
bool get();
}
JScript | public function get SupportsQuinticRtPatches() : boolean

Property Value

System.Boolean
Value that is true if the device supports quintic cubic Bezier curves and B-splines, or false if it does not.

This property is read-only.


DeviceCaps.SupportsRtPatches Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsRtPatches Property

Indicates whether the device supports rectangular and triangular patches.

Definition

Visual Basic | Public ReadOnly Property SupportsRtPatches As Boolean
C# | public bool SupportsRtPatches { get; }
C++ public:
property bool SupportsRtPatches {
bool get();
}
JScript | public function get SupportsRtPatches() : boolean

Property Value

System.Boolean
Value that is true if the device supports rectangular and triangular patches, or false if it does not.

This property is read-only.


DeviceCaps.SupportsRtPatchHandleZero Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsRtPatchHandleZero Property

Indicates whether the hardware architecture does not require caching of any information and whether uncached (handle-zero) patches are drawn as efficiently as cached ones.

Definition

Visual Basic | Public ReadOnly Property SupportsRtPatchHandleZero As Boolean
C# | public bool SupportsRtPatchHandleZero { get; }
C++ public:
property bool SupportsRtPatchHandleZero {
bool get();
}
JScript | public function get SupportsRtPatchHandleZero() : boolean

Property Value

System.Boolean
Value that is true if the hardware architecture does not require caching of any information, or false if it does.

This property is read-only.

Remarks

Note that a handle-zero patch can always be drawn, regardless of whether this capability is set.


DeviceCaps.SupportsSeparateTextureMemories Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsSeparateTextureMemories Property

Indicates whether the device is texturing from separate memory pools.

Definition

Visual Basic | Public ReadOnly Property SupportsSeparateTextureMemories As Boolean
C# | public bool SupportsSeparateTextureMemories { get; }
C++ public:
property bool SupportsSeparateTextureMemories {
bool get();
}
JScript | public function get SupportsSeparateTextureMemories() : boolean

Property Value

System.Boolean
Value that is true if the device is texturing from separate memory pools, or false if it is not.

This property is read-only.


DeviceCaps.SupportsStreamOffset Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsStreamOffset Property

Indicates whether the device supports stream offsets.

Definition

Visual Basic | Public ReadOnly Property SupportsStreamOffset As Boolean
C# | public bool SupportsStreamOffset { get; }
C++ public:
property bool SupportsStreamOffset {
bool get();
}
JScript | public function get SupportsStreamOffset() : boolean

Property Value

System.Boolean
Value that is true if the device supports stream offsets, or false if it does not.

This property is read-only.


DeviceCaps.SupportsTextureNonLocalVideoMemory Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsTextureNonLocalVideoMemory Property

Indicates whether the device can retrieve textures from nonlocal video memory.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureNonLocalVideoMemory As Boolean
C# | public bool SupportsTextureNonLocalVideoMemory { get; }
C++ public:
property bool SupportsTextureNonLocalVideoMemory {
bool get();
}
JScript | public function get SupportsTextureNonLocalVideoMemory() : boolean

Property Value

System.Boolean
Value that is true if the device can retrieve textures from nonlocal video memory, or false if it cannot.

This property is read-only.


DeviceCaps.SupportsTextureSystemMemory Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsTextureSystemMemory Property

Indicates whether the device can retrieve textures from system memory.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureSystemMemory As Boolean
C# | public bool SupportsTextureSystemMemory { get; }
C++ public:
property bool SupportsTextureSystemMemory {
bool get();
}
JScript | public function get SupportsTextureSystemMemory() : boolean

Property Value

System.Boolean
Value that is true if the device can retrieve textures from system memory, or false if it cannot.

This property is read-only.


DeviceCaps.SupportsTextureVideoMemory Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsTextureVideoMemory Property

Indicates whether the device can retrieve textures from device memory.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureVideoMemory As Boolean
C# | public bool SupportsTextureVideoMemory { get; }
C++ public:
property bool SupportsTextureVideoMemory {
bool get();
}
JScript | public function get SupportsTextureVideoMemory() : boolean

Property Value

System.Boolean
Value that is true if the device can retrieve textures from device memory, or false if it cannot.

This property is read-only.


DeviceCaps.SupportsTransformedVertexSystemMemory Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsTransformedVertexSystemMemory Property

Indicates whether the device uses buffers from system memory for transformed and lit vertices.

Definition

Visual Basic | Public ReadOnly Property SupportsTransformedVertexSystemMemory As Boolean
C# | public bool SupportsTransformedVertexSystemMemory { get; }
C++ public:
property bool SupportsTransformedVertexSystemMemory {
bool get();
}
JScript | public function get SupportsTransformedVertexSystemMemory() : boolean

Property Value

System.Boolean
Value that is true if the device uses buffers from system memory for transformed and lit vertices, or false if it does not.

This property is read-only.


DeviceCaps.SupportsTransformedVertexVideoMemory Property (Microsoft.DirectX.Direct3D)

DeviceCaps.SupportsTransformedVertexVideoMemory Property

Indicates whether the device uses buffers from video memory for transformed and lit vertices.

Definition

Visual Basic | Public ReadOnly Property SupportsTransformedVertexVideoMemory As Boolean
C# | public bool SupportsTransformedVertexVideoMemory { get; }
C++ public:
property bool SupportsTransformedVertexVideoMemory {
bool get();
}
JScript | public function get SupportsTransformedVertexVideoMemory() : boolean

Property Value

System.Boolean
Value that is true if the device uses buffers from video memory for transformed and lit vertices, or false if it does not.

This property is read-only.


DeviceCaps.VertexElementScanSharesStreamOffset Property (Microsoft.DirectX.Direct3D)

DeviceCaps.VertexElementScanSharesStreamOffset Property

Indicates whether multiple vertex elements share the same offset in a stream.

Definition

Visual Basic | Public ReadOnly Property VertexElementScanSharesStreamOffset As Boolean
C# | public bool VertexElementScanSharesStreamOffset { get; }
C++ public:
property bool VertexElementScanSharesStreamOffset {
bool get();
}
JScript | public function get VertexElementScanSharesStreamOffset() : boolean

Property Value

System.Boolean
Value that is true if multiple vertex elements share the same offset in a stream, or false if they do not.

This property is read-only.

Remarks

For multiple vertex elements to share the same offset in a stream, the vertex declaration must not have an element that contains DeclarationUsage.Position.


DeviceCreationParameters Structure (Microsoft.DirectX.Direct3D)

DeviceCreationParameters Structure

Describes the creation parameters for a device.

Definition

Visual Basic | Public Structure DeviceCreationParameters
C# | public struct DeviceCreationParameters
C++ | public value class DeviceCreationParameters sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceCreationParameters | Initializes a new instance of the DeviceCreationParameters class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AdapterOrdinal | Retrieves an ordinal number that denotes the display adapter.
Behavior | Retrieves a BehaviorFlags structure with properties that indicate the global behavior of a device.
DeviceType | Retrieves a DeviceType instance that denotes the amount of emulated functionality for the device.
FocusWindow | Retrieves the window to which focus belongs for the current device.
FocusWindowHandle | Retrieves a pointer to the window to which focus belongs for the current device.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceCreationParameters.DeviceCreationParameters() Constructor (Microsoft.DirectX.Direct3D)

DeviceCreationParameters.DeviceCreationParameters Constructor

 Language:

Initializes a new instance of the DeviceCreationParameters class.

Definition

Visual Basic | Public Sub New()
C# | public DeviceCreationParameters();
C++ public:
DeviceCreationParameters();
JScript | public function DeviceCreationParameters();


DeviceCreationParameters.ToString() Method (Microsoft.DirectX.Direct3D)

DeviceCreationParameters.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String representation of the object.


DeviceCreationParameters.AdapterOrdinal Property (Microsoft.DirectX.Direct3D)

DeviceCreationParameters.AdapterOrdinal Property

Retrieves an ordinal number that denotes the display adapter.

Definition

Visual Basic | Public ReadOnly Property AdapterOrdinal As Integer
C# | public int AdapterOrdinal { get; }
C++ public:
property int AdapterOrdinal {
int get();
}
JScript | public function get AdapterOrdinal() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates an ordinal number that denotes the display adapter.

This property is read-only.

Remarks

Use this ordinal as the adapter parameter for any of the Manager methods.

Note that different instances of Microsoft Direct3D objects can use different ordinals. For example, adapters can enter or leave a system when users add or remove monitors from a multiple-monitor system, or when they hot-swap a laptop. Consequently, this ordinal should be used only in a Direct3D instance known to be valid, such as the Direct3D object that created this Device.


DeviceCreationParameters.Behavior Property (Microsoft.DirectX.Direct3D)

DeviceCreationParameters.Behavior Property

Retrieves a BehaviorFlags structure with properties that indicate the global behavior of a device.

Definition

Visual Basic | Public ReadOnly Property Behavior As BehaviorFlags
C# | public BehaviorFlags Behavior { get; }
C++ public:
property BehaviorFlags Behavior {
BehaviorFlags get();
}
JScript | public function get Behavior() : BehaviorFlags

Property Value

Microsoft.DirectX.Direct3D.BehaviorFlags
A BehaviorFlags structure with properties that indicate the global behavior of a device.

This property is read-only.


DeviceCreationParameters.DeviceType Property (Microsoft.DirectX.Direct3D)

DeviceCreationParameters.DeviceType Property

Retrieves a DeviceType instance that denotes the amount of emulated functionality for the device.

Definition

Visual Basic | Public ReadOnly Property DeviceType As DeviceType
C# | public DeviceType DeviceType { get; }
C++ public:
property DeviceType DeviceType {
DeviceType get();
}
JScript | public function get DeviceType() : DeviceType

Property Value

Microsoft.DirectX.Direct3D.DeviceType
A DeviceType instance that denotes the amount of emulated functionality for the device.

This property is read-only.

Remarks

The value of these parameters mirrors the value passed to the Device constructor call that created the device.


DeviceCreationParameters.FocusWindow Property (Microsoft.DirectX.Direct3D)

DeviceCreationParameters.FocusWindow Property

Retrieves the window to which focus belongs for the current device.

Definition

Visual Basic | Public ReadOnly Property FocusWindow As Control
C# | public Control FocusWindow { get; }
C++ public:
property Control^ FocusWindow {
Control^ get();
}
JScript | public function get FocusWindow() : Control

Property Value

System.Windows.Forms.Control
A Control Leave Site instance that represents the window to which focus belongs for the device.

This property is read-only.


DeviceCreationParameters.FocusWindowHandle Property (Microsoft.DirectX.Direct3D)

DeviceCreationParameters.FocusWindowHandle Property

Retrieves a pointer to the window to which focus belongs for the current device.

Definition

Visual Basic | Public ReadOnly Property FocusWindowHandle As IntPtr
C# | public IntPtr FocusWindowHandle { get; }
C++ public:
property IntPtr FocusWindowHandle {
IntPtr get();
}
JScript | public function get FocusWindowHandle() : IntPtr

Property Value

System.IntPtr
An IntPtr Leave Site value that points to the window to which focus belongs for the device.

This property is read-only.


DisplacementParameter Structure (Microsoft.DirectX.Direct3D)

DisplacementParameter Structure

Contains mesh geometry displacement parameters.

Definition

Visual Basic | Public Structure DisplacementParameter
C# | public struct DisplacementParameter
C++ | public value class DisplacementParameter sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DisplacementParameter | Initializes a new instance of the DisplacementParameter class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
LevelOfDetailBias | Retrieves or sets the level-of-detail bias value.
MagFilter | Retrieves or sets the texture filter to use in magnification.
MinFilter | Retrieves or sets the texture filter to use in minification.
MipFilter | Retrieves or sets the texture filter for mipmapping.
Texture | Retrieves or sets a texture for displacement mapping.
Wrap | Retrieves or sets the texture address wrap mode.

Remarks

Displacement maps can be 2-D textures only. Mipmapping is ignored for nonadaptive tessellation.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisplacementParameter.DisplacementParameter() Constructor (Microsoft.DirectX.Direct3D)

DisplacementParameter.DisplacementParameter Constructor

Initializes a new instance of the DisplacementParameter class.

Definition

Visual Basic | Public Sub New()
C# | public DisplacementParameter();
C++ public:
DisplacementParameter();
JScript | public function DisplacementParameter();


DisplacementParameter.ToString() Method (Microsoft.DirectX.Direct3D)

DisplacementParameter.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DisplacementParameter.LevelOfDetailBias Property (Microsoft.DirectX.Direct3D)

DisplacementParameter.LevelOfDetailBias Property

Retrieves or sets the level-of-detail bias value.

Definition

Visual Basic | Public Property LevelOfDetailBias As Integer
C# | public int LevelOfDetailBias { get; set; }
C++ public:
property int LevelOfDetailBias {
int get();
void set(int value);
}
JScript public function get LevelOfDetailBias() : int
public function set LevelOfDetailBias(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the level-of-detail bias value.

This property is read/write.


DisplacementParameter.MagFilter Property (Microsoft.DirectX.Direct3D)

DisplacementParameter.MagFilter Property

Retrieves or sets the texture filter to use in magnification.

Definition

Visual Basic | Public Property MagFilter As TextureFilter
C# | public TextureFilter MagFilter { get; set; }
C++ public:
property TextureFilter MagFilter {
TextureFilter get();
void set(TextureFilter value);
}
JScript public function get MagFilter() : TextureFilter
public function set MagFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter
A TextureFilter instance that represents the filter to use in magnification.

This property is read/write.


DisplacementParameter.MinFilter Property (Microsoft.DirectX.Direct3D)

DisplacementParameter.MinFilter Property

Retrieves or sets the texture filter to use in minification.

Definition

Visual Basic | Public Property MinFilter As TextureFilter
C# | public TextureFilter MinFilter { get; set; }
C++ public:
property TextureFilter MinFilter {
TextureFilter get();
void set(TextureFilter value);
}
JScript public function get MinFilter() : TextureFilter
public function set MinFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter
A TextureFilter instance that represents the filter to use in minification.

This property is read/write.


DisplacementParameter.MipFilter Property (Microsoft.DirectX.Direct3D)

DisplacementParameter.MipFilter Property

Retrieves or sets the texture filter for mipmapping.

Definition

Visual Basic | Public Property MipFilter As TextureFilter
C# | public TextureFilter MipFilter { get; set; }
C++ public:
property TextureFilter MipFilter {
TextureFilter get();
void set(TextureFilter value);
}
JScript public function get MipFilter() : TextureFilter
public function set MipFilter(TextureFilter);

Property Value

Microsoft.DirectX.Direct3D.TextureFilter
A TextureFilter instance that represents the filters to use in mipmapping.

This property is read/write.

Remarks

Mipmapping is ignored for nonadaptive tessellation.


DisplacementParameter.Texture Property (Microsoft.DirectX.Direct3D)

DisplacementParameter.Texture Property

Retrieves or sets a texture for displacement mapping.

Definition

Visual Basic | Public Property Texture As BaseTexture
C# | public BaseTexture Texture { get; set; }
C++ public:
property BaseTexture^ Texture {
BaseTexture^ get();
void set(BaseTexture^ value);
}
JScript public function get Texture() : BaseTexture
public function set Texture(BaseTexture);

Property Value

Microsoft.DirectX.Direct3D.BaseTexture
A BaseTexture instance that contains displacement data.

This property is read/write.

Remarks

Displacement maps can be 2-D textures only.


DisplacementParameter.Wrap Property (Microsoft.DirectX.Direct3D)

DisplacementParameter.Wrap Property

Retrieves or sets the texture address wrap mode.

Definition

Visual Basic | Public Property Wrap As TextureAddress
C# | public TextureAddress Wrap { get; set; }
C++ public:
property TextureAddress Wrap {
TextureAddress get();
void set(TextureAddress value);
}
JScript public function get Wrap() : TextureAddress
public function set Wrap(TextureAddress);

Property Value

Microsoft.DirectX.Direct3D.TextureAddress
A TextureAddress instance that represents the texture address wrap mode.

This property is read/write.

See Also

  • TextureAddress


DisplayMode Structure (Microsoft.DirectX.Direct3D)

DisplayMode Structure

Describes the display mode.

Definition

Visual Basic | Public Structure DisplayMode
C# | public struct DisplayMode
C++ | public value class DisplayMode sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DisplayMode | Initializes a new instance of the DisplayMode class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Format | Retrieves or sets the surface format of the display mode.
Height | Retrieves or sets the screen height, in pixels.
RefreshRate | Retrieves or sets the refresh rate.
Width | Retrieves or sets the screen width, in pixels.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisplayMode.DisplayMode() Constructor (Microsoft.DirectX.Direct3D)

DisplayMode.DisplayMode Constructor

Initializes a new instance of the DisplayMode class.

Definition

Visual Basic | Public Sub New()
C# | public DisplayMode();
C++ public:
DisplayMode();
JScript | public function DisplayMode();


DisplayMode.ToString() Method (Microsoft.DirectX.Direct3D)

DisplayMode.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DisplayMode.Format Property (Microsoft.DirectX.Direct3D)

DisplayMode.Format Property

Retrieves or sets the surface format of the display mode.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
A Format value that represents the surface format of the display mode.

This property is read/write.


DisplayMode.Height Property (Microsoft.DirectX.Direct3D)

DisplayMode.Height Property

Retrieves or sets the screen height, in pixels.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the screen height in pixels.

This property is read/write.


DisplayMode.RefreshRate Property (Microsoft.DirectX.Direct3D)

DisplayMode.RefreshRate Property

Retrieves or sets the refresh rate.

Definition

Visual Basic | Public Property RefreshRate As Integer
C# | public int RefreshRate { get; set; }
C++ public:
property int RefreshRate {
int get();
void set(int value);
}
JScript public function get RefreshRate() : int
public function set RefreshRate(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the refresh rate.

This property is read/write.

Remarks

A value of 0 indicates the adapter default refresh rate.


DisplayMode.Width Property (Microsoft.DirectX.Direct3D)

DisplayMode.Width Property

Retrieves or sets the screen width, in pixels.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
An Int32 Leave Site value that indicates the screen width in pixels.

This property is read/write.


DriverCaps Structure (Microsoft.DirectX.Direct3D)

DriverCaps Structure

Indicates driver-specific capabilities.

Definition

Visual Basic | Public Structure DriverCaps
C# | public struct DriverCaps
C++ | public value class DriverCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
CanAutoGenerateMipMap | Indicates that the driver is capable of automatically generating mipmaps.
CanCalibrateGamma | Indicates that the system has a calibrator installed that can automatically adjust the gamma ramp so that the result is identical on all systems that have a calibrator.
CanManageResource | Indicates that the driver is capable of managing resources.
ReadScanLine | Indicates that the display hardware is capable of returning the current scan line.
SupportsAlphaFullscreenFlipOrDiscard | Indicates that the device can respect RenderStateManager.AlphaBlendEnable in full-screen mode while using the RenderStateManager.Flip or RenderStateManager.Discard swap effect.
SupportsCopyToSystemMemory | Indicates that the device can accelerate a memory copy from local video memory to system memory.
SupportsCopyToVideoMemory | Indicates that the device can accelerate a memory copy from system memory to local video memory.
SupportsDynamicTextures | Indicates whether the driver supports dynamic textures.
SupportsFullscreenGamma | Indicates whether the driver supports dynamic gamma-ramp adjustment in full-screen mode.
SupportsLinearToSrgbPresentation | Indicates whether the device can perform gamma correction from a windowed back buffer (that contains linear content) to an sRGB desktop.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DriverCaps.ToString() Method (Microsoft.DirectX.Direct3D)

DriverCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DriverCaps.CanAutoGenerateMipMap Property (Microsoft.DirectX.Direct3D)

DriverCaps.CanAutoGenerateMipMap Property

Indicates that the driver is capable of automatically generating mipmaps.

Definition

Visual Basic | Public ReadOnly Property CanAutoGenerateMipMap As Boolean
C# | public bool CanAutoGenerateMipMap { get; }
C++ public:
property bool CanAutoGenerateMipMap {
bool get();
}
JScript | public function get CanAutoGenerateMipMap() : boolean

Property Value

System.Boolean
Value that is true if the driver can automatically generate mipmaps, or false if it cannot.

This property is read-only.


DriverCaps.CanCalibrateGamma Property (Microsoft.DirectX.Direct3D)

DriverCaps.CanCalibrateGamma Property

Indicates that the system has a calibrator installed that can automatically adjust the gamma ramp so that the result is identical on all systems that have a calibrator.

Definition

Visual Basic | Public ReadOnly Property CanCalibrateGamma As Boolean
C# | public bool CanCalibrateGamma { get; }
C++ public:
property bool CanCalibrateGamma {
bool get();
}
JScript | public function get CanCalibrateGamma() : boolean

Property Value

System.Boolean
Value that is true if the system has a calibrator installed, or false if it does not.

This property is read-only.

Remarks

To invoke the calibrator when setting new gamma levels, set the param_Boolean_calibrate parameter to true during a call to Device.SetGammaRamp. Calibrating gamma ramps incurs some processing overhead and should not be used frequently.


DriverCaps.CanManageResource Property (Microsoft.DirectX.Direct3D)

DriverCaps.CanManageResource Property

Indicates that the driver is capable of managing resources.

Definition

Visual Basic | Public ReadOnly Property CanManageResource As Boolean
C# | public bool CanManageResource { get; }
C++ public:
property bool CanManageResource {
bool get();
}
JScript | public function get CanManageResource() : boolean

Property Value

System.Boolean
Value that is true if the driver can manage resources, or false if it cannot.

This property is read-only.

Remarks

On drivers that are capable of managing resources, Pool.Managed resources are managed by the driver.


DriverCaps.ReadScanLine Property (Microsoft.DirectX.Direct3D)

DriverCaps.ReadScanLine Property

Indicates that the display hardware is capable of returning the current scan line.

Definition

Visual Basic | Public ReadOnly Property ReadScanLine As Boolean
C# | public bool ReadScanLine { get; }
C++ public:
property bool ReadScanLine {
bool get();
}
JScript | public function get ReadScanLine() : boolean

Property Value

System.Boolean
Value that is true if the display hardware can return the current scan line, or false if it cannot.

This property is read-only.


DriverCaps.SupportsAlphaFullscreenFlipOrDiscard Property (Microsoft.DirectX.Direct3D)

DriverCaps.SupportsAlphaFullscreenFlipOrDiscard Property

Indicates that the device can respect RenderStateManager.AlphaBlendEnable in full-screen mode while using the RenderStateManager.Flip or RenderStateManager.Discard swap effect.

Definition

Visual Basic | Public ReadOnly Property SupportsAlphaFullscreenFlipOrDiscard As Boolean
C# | public bool SupportsAlphaFullscreenFlipOrDiscard { get; }
C++ public:
property bool SupportsAlphaFullscreenFlipOrDiscard {
bool get();
}
JScript | public function get SupportsAlphaFullscreenFlipOrDiscard() : boolean

Property Value

System.Boolean
Value that is true if the device can respect RenderStateManager.AlphaBlendEnable in full-screen mode while using RenderStateManager.Flip or RenderStateManager.Discard, or false if it cannot.

This property is read-only.

Remarks

The RenderStateManager.Copy swap effect works regardless of whether this flag is set.

This property is relevant only when RenderStateManager.AlphaSourceBlend or RenderStateManager.AlphaDestinationBlend are set to DestinationAlpha, InvDestinationAlpha, DestinationColor, or InvDestinationColor.


DriverCaps.SupportsCopyToSystemMemory Property (Microsoft.DirectX.Direct3D)

DriverCaps.SupportsCopyToSystemMemory Property

Indicates that the device can accelerate a memory copy from local video memory to system memory.

Definition

Visual Basic | Public ReadOnly Property SupportsCopyToSystemMemory As Boolean
C# | public bool SupportsCopyToSystemMemory { get; }
C++ public:
property bool SupportsCopyToSystemMemory {
bool get();
}
JScript | public function get SupportsCopyToSystemMemory() : boolean

Property Value

System.Boolean
Value that is true if the device can accelerate a memory copy from local video memory to system memory, or false if it cannot.

This property is read-only.

Remarks

This capability guarantees that Device.GetRenderTargetData calls are hardware-accelerated. If this capability is absent, the call succeeds, but is slower.


DriverCaps.SupportsCopyToVideoMemory Property (Microsoft.DirectX.Direct3D)

DriverCaps.SupportsCopyToVideoMemory Property

Indicates that the device can accelerate a memory copy from system memory to local video memory.

Definition

Visual Basic | Public ReadOnly Property SupportsCopyToVideoMemory As Boolean
C# | public bool SupportsCopyToVideoMemory { get; }
C++ public:
property bool SupportsCopyToVideoMemory {
bool get();
}
JScript | public function get SupportsCopyToVideoMemory() : boolean

Property Value

System.Boolean
Value that is true if the device can accelerate a memory copy from system memory to local video memory, or false if it cannot.

This property is read-only.

Remarks

This capability guarantees that Device.UpdateSurface and Device.UpdateTexture calls are hardware-accelerated. If this capability is absent, the calls succeed, but are slower.


DriverCaps.SupportsDynamicTextures Property (Microsoft.DirectX.Direct3D)

DriverCaps.SupportsDynamicTextures Property

Indicates whether the driver supports dynamic textures.

Definition

Visual Basic | Public ReadOnly Property SupportsDynamicTextures As Boolean
C# | public bool SupportsDynamicTextures { get; }
C++ public:
property bool SupportsDynamicTextures {
bool get();
}
JScript | public function get SupportsDynamicTextures() : boolean

Property Value

System.Boolean
Value that is true if the driver supports dynamic textures, or false if it does not.

This property is read-only.


DriverCaps.SupportsFullscreenGamma Property (Microsoft.DirectX.Direct3D)

DriverCaps.SupportsFullscreenGamma Property

Indicates whether the driver supports dynamic gamma-ramp adjustment in full-screen mode.

Definition

Visual Basic | Public ReadOnly Property SupportsFullscreenGamma As Boolean
C# | public bool SupportsFullscreenGamma { get; }
C++ public:
property bool SupportsFullscreenGamma {
bool get();
}
JScript | public function get SupportsFullscreenGamma() : boolean

Property Value

System.Boolean
Value that is true if the driver supports dynamic gamma-ramp adjustment in full-screen mode, or false if it does not.

This property is read-only.


DriverCaps.SupportsLinearToSrgbPresentation Property (Microsoft.DirectX.Direct3D)

DriverCaps.SupportsLinearToSrgbPresentation Property

Indicates whether the device can perform gamma correction from a windowed back buffer (that contains linear content) to an sRGB desktop.

Definition

Visual Basic | Public ReadOnly Property SupportsLinearToSrgbPresentation As Boolean
C# | public bool SupportsLinearToSrgbPresentation { get; }
C++ public:
property bool SupportsLinearToSrgbPresentation {
bool get();
}
JScript | public function get SupportsLinearToSrgbPresentation() : boolean

Property Value

System.Boolean
Value that is true if the device can perform gamma correction from a windowed back buffer to an sRGB desktop, or false if it cannot.

This property is read-only.


EffectDefault Structure (Microsoft.DirectX.Direct3D)

EffectDefault Structure

Manages a default effect parameter.

Definition

Visual Basic | Public Structure EffectDefault
C# | public struct EffectDefault
C++ | public value class EffectDefault sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectDefault | Initializes a new instance of the EffectDefault class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Data | Retrieves or sets the effect parameter data.
ParameterName | Retrieves or sets the parameter name.
Type | Retrieves or sets the data type in the Data property.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectDefault.EffectDefault() Constructor (Microsoft.DirectX.Direct3D)

EffectDefault.EffectDefault Constructor

Initializes a new instance of the EffectDefault class.

Definition

Visual Basic | Public Sub New()
C# | public EffectDefault();
C++ public:
EffectDefault();
JScript | public function EffectDefault();


EffectDefault.ToString() Method (Microsoft.DirectX.Direct3D)

EffectDefault.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectDefault.Data Property (Microsoft.DirectX.Direct3D)

EffectDefault.Data Property

Retrieves or sets the effect parameter data.

Definition

Visual Basic | Public Property Data As Object
C# | public object Data { get; set; }
C++ public:
property Object^ Data {
Object^ get();
void set(Object^ value);
}
JScript public function get Data() : Object
public function set Data(Object);

Property Value

System.Object
An Object Leave Site that contains the effect parameter data.

This property is read/write.

Remarks

The type of data passed into this property should match the EffectDefault.Type property.


EffectDefault.ParameterName Property (Microsoft.DirectX.Direct3D)

EffectDefault.ParameterName Property

Retrieves or sets the parameter name.

Definition

Visual Basic | Public Property ParameterName As String
C# | public string ParameterName { get; set; }
C++ public:
property String^ ParameterName {
String^ get();
void set(String^ value);
}
JScript public function get ParameterName() : String
public function set ParameterName(String);

Property Value

System.String
A String Leave Site object that contains the name of the parameter.

This property is read/write.


EffectDefault.Type Property (Microsoft.DirectX.Direct3D)

EffectDefault.Type Property

Retrieves or sets the data type in the Data property.

Definition

Visual Basic | Public Property Type As EffectDefaultType
C# | public EffectDefaultType Type { get; set; }
C++ public:
property EffectDefaultType Type {
EffectDefaultType get();
void set(EffectDefaultType value);
}
JScript public function get Type() : EffectDefaultType
public function set Type(EffectDefaultType);

Property Value

Microsoft.DirectX.Direct3D.EffectDefaultType
An EffectDefaultType value that indicates the data type in the Data property.

This property is read/write.


EffectDescription Structure (Microsoft.DirectX.Direct3D)

EffectDescription Structure

Describes an effect object.

Definition

Visual Basic | Public Structure EffectDescription
C# | public struct EffectDescription
C++ | public value class EffectDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectDescription | Initializes a new instance of the EffectDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Creator | Retrieves the name of the effect creator.
Functions | Retrieves the number of functions that can render the effect.
Parameters | Retrieves the number of parameters used for the effect.
Techniques | Retrieves the number of techniques that can render the effect.

Remarks

An effect object can contain multiple rendering techniques and parameters for the same effect.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectDescription.EffectDescription() Constructor (Microsoft.DirectX.Direct3D)

EffectDescription.EffectDescription Constructor

Initializes a new instance of the EffectDescription class.

Definition

Visual Basic | Public Sub New()
C# | public EffectDescription();
C++ public:
EffectDescription();
JScript | public function EffectDescription();


EffectDescription.ToString() Method (Microsoft.DirectX.Direct3D)

EffectDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectDescription.Creator Property (Microsoft.DirectX.Direct3D)

EffectDescription.Creator Property

Retrieves the name of the effect creator.

Definition

Visual Basic | Public ReadOnly Property Creator As String
C# | public string Creator { get; }
C++ public:
property String^ Creator {
String^ get();
}
JScript | public function get Creator() : String

Property Value

System.String
A String Leave Site object that contains the name of the effect creator.

This property is read-only.


EffectDescription.Functions Property (Microsoft.DirectX.Direct3D)

EffectDescription.Functions Property

Retrieves the number of functions that can render the effect.

Definition

Visual Basic | Public ReadOnly Property Functions As Integer
C# | public int Functions { get; }
C++ public:
property int Functions {
int get();
}
JScript | public function get Functions() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of functions that can render the effect.

This property is read-only.


EffectDescription.Parameters Property (Microsoft.DirectX.Direct3D)

EffectDescription.Parameters Property

Retrieves the number of parameters used for the effect.

Definition

Visual Basic | Public ReadOnly Property Parameters As Integer
C# | public int Parameters { get; }
C++ public:
property int Parameters {
int get();
}
JScript | public function get Parameters() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of parameters used for the effect.

This property is read-only.


EffectDescription.Techniques Property (Microsoft.DirectX.Direct3D)

EffectDescription.Techniques Property

Retrieves the number of techniques that can render the effect.

Definition

Visual Basic | Public ReadOnly Property Techniques As Integer
C# | public int Techniques { get; }
C++ public:
property int Techniques {
int get();
}
JScript | public function get Techniques() : int

Property Value

System.Int32
An Int32 Leave Site value that indicates the number of techniques that can render the effect.

This property is read-only.


EffectInstance Structure (Microsoft.DirectX.Direct3D)

EffectInstance Structure

Manages a set of default effect parameters.

Definition

Visual Basic | Public Structure EffectInstance
C# | public struct EffectInstance
C++ | public value class EffectInstance sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectInstance | Initializes a new instance of the EffectInstance class.
GetDefaults | Retrieves the default effect parameters managed by the current EffectInstance.
SetDefaults | Sets the default effect parameters managed by the current EffectInstance.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
EffectFilename | Retrieves or sets the name of the effect file.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectInstance.EffectInstance() Constructor (Microsoft.DirectX.Direct3D)

EffectInstance.EffectInstance Constructor

Initializes a new instance of the EffectInstance class.

Definition

Visual Basic | Public Sub New()
C# | public EffectInstance();
C++ public:
EffectInstance();
JScript | public function EffectInstance();


EffectInstance.GetDefaults() Method (Microsoft.DirectX.Direct3D)

EffectInstance.GetDefaults Method

Retrieves the default effect parameters managed by the current EffectInstance.

Definition

Visual Basic | Public Function GetDefaults() As EffectDefault()
C# | public EffectDefault[] GetDefaults();
C++ public:
array<EffectDefault>^ GetDefaults();
JScript | public function GetDefaults() : EffectDefault[];

Return Value

Microsoft.DirectX.Direct3D.EffectDefault[]
Array of EffectDefault instances that represent the default effect parameters managed by the EffectInstance.


EffectInstance.SetDefaults(EffectDefault[]) Method (Microsoft.DirectX.Direct3D)

EffectInstance.SetDefaults Method

Sets the default effect parameters managed by the current EffectInstance.

Definition

Visual Basic Public Sub SetDefaults( _
ByVal value() As EffectDefault _
)
C# public void SetDefaults(
EffectDefault[] value
);
C++ public:
void SetDefaults(
array<EffectDefault>^ value
);
JScript public function SetDefaults(
value : EffectDefault[]
);

Parameters

value Microsoft.DirectX.Direct3D.EffectDefault[]
Array of EffectDefault instances that represent the default effect parameters managed by the EffectInstance.


EffectInstance.ToString() Method (Microsoft.DirectX.Direct3D)

EffectInstance.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectInstance.EffectFilename Property (Microsoft.DirectX.Direct3D)

EffectInstance.EffectFilename Property

Retrieves or sets the name of the effect file.

Definition

Visual Basic | Public Property EffectFilename As String
C# | public string EffectFilename { get; set; }
C++ public:
property String^ EffectFilename {
String^ get();
void set(String^ value);
}
JScript public function get EffectFilename() : String
public function set EffectFilename(String);

Property Value

System.String
A String Leave Site instance that contains the name of the effect file.

This property is read/write.


EventDescription Structure (Microsoft.DirectX.Direct3D)

EventDescription Structure

Describes an animation event.

Definition

Visual Basic | Public Structure EventDescription
C# | public struct EventDescription
C++ | public value class EventDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EventDescription | Initializes a new instance of an object.

Properties

Property | Description
Duration | Retrieves the duration of the event in global time.
Enable | Retrieves the enable flag.
EventType | Retrieves the event type as defined in EventType.
Position | Retrieves the track position for the event.
Speed | Retrieves the track speed for the event.
StartTime | Retrieves the start time of the event in global time.
Track | Retrieves the event track identifier.
TransitionType | Retrieves the transition style of the event as defined in TransitionType.
Weight | Retrieves the track weight for the event.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EventDescription.EventDescription() Constructor (Microsoft.DirectX.Direct3D)

EventDescription.EventDescription Constructor

Initializes a new instance of an object.

Definition

Visual Basic | Public Sub New()
C# | public EventDescription();
C++ public:
EventDescription();
JScript | public function EventDescription();


EventDescription.Duration Property (Microsoft.DirectX.Direct3D)

EventDescription.Duration Property

Retrieves the duration of the event in global time.

Definition

Visual Basic | Public ReadOnly Property Duration As Double
C# | public double Duration { get; }
C++ public:
property double Duration {
double get();
}
JScript | public function get Duration() : double

Property Value

System.Double
Duration of the event.

This property is read-only.


EventDescription.Enable Property (Microsoft.DirectX.Direct3D)

EventDescription.Enable Property

Retrieves the enable flag.

Definition

Visual Basic | Public ReadOnly Property Enable As Boolean
C# | public bool Enable { get; }
C++ public:
property bool Enable {
bool get();
}
JScript | public function get Enable() : boolean

Property Value

System.Boolean
Enable flag.

This property is read-only.


EventDescription.EventType Property (Microsoft.DirectX.Direct3D)

EventDescription.EventType Property

Retrieves the event type as defined in EventType.

Definition

Visual Basic | Public ReadOnly Property EventType As EventType
C# | public EventType EventType { get; }
C++ public:
property EventType EventType {
EventType get();
}
JScript | public function get EventType() : EventType

Property Value

Microsoft.DirectX.Direct3D.EventType
Event type.

This property is read-only.


EventDescription.Position Property (Microsoft.DirectX.Direct3D)

EventDescription.Position Property

Retrieves the track position for the event.

Definition

Visual Basic | Public ReadOnly Property Position As Double
C# | public double Position { get; }
C++ public:
property double Position {
double get();
}
JScript | public function get Position() : double

Property Value

System.Double
Track position for the event.

This property is read-only.


EventDescription.Speed Property (Microsoft.DirectX.Direct3D)

EventDescription.Speed Property

Retrieves the track speed for the event.

Definition

Visual Basic | Public ReadOnly Property Speed As Single
C# | public float Speed { get; }
C++ public:
property float Speed {
float get();
}
JScript | public function get Speed() : float

Property Value

System.Single
Track speed for the event.

This property is read-only.


EventDescription.StartTime Property (Microsoft.DirectX.Direct3D)

EventDescription.StartTime Property

Retrieves the start time of the event in global time.

Definition

Visual Basic | Public ReadOnly Property StartTime As Double
C# | public double StartTime { get; }
C++ public:
property double StartTime {
double get();
}
JScript | public function get StartTime() : double

Property Value

System.Double
Start time of the event.

This property is read-only.


EventDescription.Track Property (Microsoft.DirectX.Direct3D)

EventDescription.Track Property

Retrieves the event track identifier.

Definition

Visual Basic | Public ReadOnly Property Track As Integer
C# | public int Track { get; }
C++ public:
property int Track {
int get();
}
JScript | public function get Track() : int

Property Value

System.Int32
Event track identifier.

This property is read-only.


EventDescription.TransitionType Property (Microsoft.DirectX.Direct3D)

EventDescription.TransitionType Property

Retrieves the transition style of the event as defined in TransitionType.

Definition

Visual Basic | Public ReadOnly Property TransitionType As TransitionType
C# | public TransitionType TransitionType { get; }
C++ public:
property TransitionType TransitionType {
TransitionType get();
}
JScript | public function get TransitionType() : TransitionType

Property Value

Microsoft.DirectX.Direct3D.TransitionType
Transition style of the event.

This property is read-only.


EventDescription.Weight Property (Microsoft.DirectX.Direct3D)

EventDescription.Weight Property

Retrieves the track weight for the event.

Definition

Visual Basic | Public ReadOnly Property Weight As Single
C# | public float Weight { get; }
C++ public:
property float Weight {
float get();
}
JScript | public function get Weight() : float

Property Value

System.Single
Track weight for the event.

This property is read-only.


ExtendedMaterial Structure (Microsoft.DirectX.Direct3D)

ExtendedMaterial Structure

Returns material information that is saved in DirectX (.x) files.

Definition

Visual Basic | Public Structure ExtendedMaterial
C# | public struct ExtendedMaterial
C++ | public value class ExtendedMaterial sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ExtendedMaterial | Initializes a new instance of the ExtendedMaterial class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Material3D | Retrieves or sets the Material structure that describes the material properties.
TextureFilename | Retrieves or sets a string that specifies the file name of the texture.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Tutorial 6: Using Meshes


ExtendedMaterial.ExtendedMaterial() Constructor (Microsoft.DirectX.Direct3D)

ExtendedMaterial.ExtendedMaterial Constructor

Initializes a new instance of the ExtendedMaterial class.

Definition

Visual Basic | Public Sub New()
C# | public ExtendedMaterial();
C++ public:
ExtendedMaterial();
JScript | public function ExtendedMaterial();


ExtendedMaterial.ToString() Method (Microsoft.DirectX.Direct3D)

ExtendedMaterial.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ExtendedMaterial.Material3D Property (Microsoft.DirectX.Direct3D)

ExtendedMaterial.Material3D Property

Retrieves or sets the Material structure that describes the material properties.

Definition

Visual Basic | Public Property Material3D As Material
C# | public Material Material3D { get; set; }
C++ public:
property Material Material3D {
Material get();
void set(Material value);
}
JScript public function get Material3D() : Material
public function set Material3D(Material);

Property Value

Microsoft.DirectX.Direct3D.Material
A Material structure that describes the material properties.

This property is read/write.


ExtendedMaterial.TextureFilename Property (Microsoft.DirectX.Direct3D)

ExtendedMaterial.TextureFilename Property

Retrieves or sets a string that specifies the file name of the texture.

Definition

Visual Basic | Public Property TextureFilename As String
C# | public string TextureFilename { get; set; }
C++ public:
property String^ TextureFilename {
String^ get();
void set(String^ value);
}
JScript public function get TextureFilename() : String
public function set TextureFilename(String);

Property Value

System.String
A String Leave Site instance that specifies the file name of the texture.

This property is read/write.


FilterCaps Structure (Microsoft.DirectX.Direct3D)

FilterCaps Structure

Indicates texture filter capabilities.

Definition

Visual Basic | Public Structure FilterCaps
C# | public struct FilterCaps
C++ | public value class FilterCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsMagnifyAnisotropic | Indicates that the device supports per-stage anisotropic filtering for magnifying textures.
SupportsMagnifyGaussianQuad | Indicates that the device supports per-stage Guassian quad filtering for textures.
SupportsMagnifyLinear | Indicates that the device supports per-stage bilinear interpolation filtering for magnifying textures.
SupportsMagnifyPoint | Indicates that the device supports per-stage point-sample filtering for magnifying textures.
SupportsMagnifyPyramidalQuad | Indicates that the device supports per-stage pyramidal quad filtering for magnifying textures.
SupportsMinifyAnisotropic | Indicates that the device supports per-stage anisotropic filtering for minifying textures.
SupportsMinifyGaussianQuad | Indicates that the device supports per-stage Guassian quad filtering for minifying textures.
SupportsMinifyLinear | Indicates that the device supports per-stage bilinear interpolation filtering for minifying textures.
SupportsMinifyPoint | Indicates that the device supports per-stage point-sample filtering for minifying textures.
SupportsMinifyPyramidalQuad | Indicates that the device supports per-stage pyramidal quad filtering for minifying textures.
SupportsMipMapLinear | Indicates that the device supports per-stage trilinear interpolation filtering for mipmaps.
SupportsMipMapPoint | Indicates that the device supports per-stage point-sample filtering for mipmaps.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FilterCaps.ToString() Method (Microsoft.DirectX.Direct3D)

FilterCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FilterCaps.SupportsMagnifyAnisotropic Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMagnifyAnisotropic Property

Indicates that the device supports per-stage anisotropic filtering for magnifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMagnifyAnisotropic As Boolean
C# | public bool SupportsMagnifyAnisotropic { get; }
C++ public:
property bool SupportsMagnifyAnisotropic {
bool get();
}
JScript | public function get SupportsMagnifyAnisotropic() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage anisotropic filtering for magnifying textures, or false if it does not.

This property is read-only.

Remarks

Anisotropic filters compensate for distortion caused by the difference in angle between the texture polygon and the plane of the screen.

The anisotropic magnification filter is represented by the TextureFilter.Anisotropic enumerated value.


FilterCaps.SupportsMagnifyGaussianQuad Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMagnifyGaussianQuad Property

Indicates that the device supports per-stage Guassian quad filtering for textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMagnifyGaussianQuad As Boolean
C# | public bool SupportsMagnifyGaussianQuad { get; }
C++ public:
property bool SupportsMagnifyGaussianQuad {
bool get();
}
JScript | public function get SupportsMagnifyGaussianQuad() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage Guassian quad filtering for textures, or false if it does not.

This property is read-only.


FilterCaps.SupportsMagnifyLinear Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMagnifyLinear Property

Indicates that the device supports per-stage bilinear interpolation filtering for magnifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMagnifyLinear As Boolean
C# | public bool SupportsMagnifyLinear { get; }
C++ public:
property bool SupportsMagnifyLinear {
bool get();
}
JScript | public function get SupportsMagnifyLinear() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage bilinear interpolation filtering for magnifying textures, or false if it does not.

This property is read-only.

Remarks

The bilinear interpolation mipmapping filter is represented by the TextureFilter.Linear enumerated value.


FilterCaps.SupportsMagnifyPoint Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMagnifyPoint Property

Indicates that the device supports per-stage point-sample filtering for magnifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMagnifyPoint As Boolean
C# | public bool SupportsMagnifyPoint { get; }
C++ public:
property bool SupportsMagnifyPoint {
bool get();
}
JScript | public function get SupportsMagnifyPoint() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage point-sample filtering for magnifying textures, or false if it does not.

This property is read-only.

Remarks

The point-sample magnification filter is represented by the TextureFilter.Point enumerated value.


FilterCaps.SupportsMagnifyPyramidalQuad Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMagnifyPyramidalQuad Property

Indicates that the device supports per-stage pyramidal quad filtering for magnifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMagnifyPyramidalQuad As Boolean
C# | public bool SupportsMagnifyPyramidalQuad { get; }
C++ public:
property bool SupportsMagnifyPyramidalQuad {
bool get();
}
JScript | public function get SupportsMagnifyPyramidalQuad() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage pyramidal quad filtering for magnifying textures, or false if it does not.

This property is read-only.

Remarks

The pyramidal magnifying filter is represented by the TextureFilter.PyramidalQuad enumerated value.


FilterCaps.SupportsMinifyAnisotropic Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMinifyAnisotropic Property

Indicates that the device supports per-stage anisotropic filtering for minifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMinifyAnisotropic As Boolean
C# | public bool SupportsMinifyAnisotropic { get; }
C++ public:
property bool SupportsMinifyAnisotropic {
bool get();
}
JScript | public function get SupportsMinifyAnisotropic() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage anisotropic filtering for minifying textures, or false if it does not.

This property is read-only.

Remarks

The anisotropic minification filter is represented by the TextureFilter.Anisotropic enumerated value.


FilterCaps.SupportsMinifyGaussianQuad Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMinifyGaussianQuad Property

Indicates that the device supports per-stage Guassian quad filtering for minifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMinifyGaussianQuad As Boolean
C# | public bool SupportsMinifyGaussianQuad { get; }
C++ public:
property bool SupportsMinifyGaussianQuad {
bool get();
}
JScript | public function get SupportsMinifyGaussianQuad() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage Guassian quad filtering for minifying textures, or false if it does not.

This property is read-only.


FilterCaps.SupportsMinifyLinear Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMinifyLinear Property

Indicates that the device supports per-stage bilinear interpolation filtering for minifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMinifyLinear As Boolean
C# | public bool SupportsMinifyLinear { get; }
C++ public:
property bool SupportsMinifyLinear {
bool get();
}
JScript | public function get SupportsMinifyLinear() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage bilinear interpolation filtering for minifying textures, or false if it does not.

This property is read-only.

Remarks

The linear minification filter is represented by the TextureFilter.Linear enumerated value.


FilterCaps.SupportsMinifyPoint Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMinifyPoint Property

Indicates that the device supports per-stage point-sample filtering for minifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMinifyPoint As Boolean
C# | public bool SupportsMinifyPoint { get; }
C++ public:
property bool SupportsMinifyPoint {
bool get();
}
JScript | public function get SupportsMinifyPoint() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage point-sample filtering for minifying textures, or false if it does not.

This property is read-only.

Remarks

The point-sample minification filter is represented by the TextureFilter.Point enumerated value.


FilterCaps.SupportsMinifyPyramidalQuad Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMinifyPyramidalQuad Property

Indicates that the device supports per-stage pyramidal quad filtering for minifying textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMinifyPyramidalQuad As Boolean
C# | public bool SupportsMinifyPyramidalQuad { get; }
C++ public:
property bool SupportsMinifyPyramidalQuad {
bool get();
}
JScript | public function get SupportsMinifyPyramidalQuad() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage pyramidal quad filtering for minifying textures, or false if it does not.

This property is read-only.


FilterCaps.SupportsMipMapLinear Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMipMapLinear Property

Indicates that the device supports per-stage trilinear interpolation filtering for mipmaps.

Definition

Visual Basic | Public ReadOnly Property SupportsMipMapLinear As Boolean
C# | public bool SupportsMipMapLinear { get; }
C++ public:
property bool SupportsMipMapLinear {
bool get();
}
JScript | public function get SupportsMipMapLinear() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage trilinear interpolation filtering for mipmaps, or false if it does not.

This property is read-only.

Remarks

The bilinear interpolation mipmapping filter is represented by the TextureFilter.Linear enumerated value.


FilterCaps.SupportsMipMapPoint Property (Microsoft.DirectX.Direct3D)

FilterCaps.SupportsMipMapPoint Property

Indicates that the device supports per-stage point-sample filtering for mipmaps.

Definition

Visual Basic | Public ReadOnly Property SupportsMipMapPoint As Boolean
C# | public bool SupportsMipMapPoint { get; }
C++ public:
property bool SupportsMipMapPoint {
bool get();
}
JScript | public function get SupportsMipMapPoint() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage point-sample filtering for mipmaps, or false if it does not.

This property is read-only.

Remarks

The point-sample mipmapping filter is represented by the TextureFilter.Point enumerated value.


FontDescription Structure (Microsoft.DirectX.Direct3D)

FontDescription Structure

Defines the attributes of a font.

Definition

Visual Basic | Public Structure FontDescription
C# | public struct FontDescription
C++ | public value class FontDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FontDescription | Initializes a new instance of the FontDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
CharSet | Retrieves or sets the character set for the font.
FaceName | Retrieves or sets the name of the font.
Height | Retrieves or sets the height of the font in logical units.
IsItalic | Determines whether a font is italic.
MipLevels | Retrieves or sets the number of mip levels requested.
OutputPrecision | Retrieves or sets the output precision for a font.
PitchAndFamily | Retrieves or sets the pitch and family of a font.
Quality | Retrieves or sets the output quality of a font.
Weight | Retrieves or sets the weight of a font.
Width | Retrieves or sets the width of a font in logical units.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FontDescription.FontDescription() Constructor (Microsoft.DirectX.Direct3D)

FontDescription.FontDescription Constructor

Initializes a new instance of the FontDescription class.

Definition

Visual Basic | Public Sub New()
C# | public FontDescription();
C++ public:
FontDescription();
JScript | public function FontDescription();


FontDescription.ToString() Method (Microsoft.DirectX.Direct3D)

FontDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FontDescription.CharSet Property (Microsoft.DirectX.Direct3D)

FontDescription.CharSet Property

Retrieves or sets the character set for the font.

Definition

Visual Basic | Public Property CharSet As CharacterSet
C# | public CharacterSet CharSet { get; set; }
C++ public:
property CharacterSet CharSet {
CharacterSet get();
void set(CharacterSet value);
}
JScript public function get CharSet() : CharacterSet
public function set CharSet(CharacterSet);

Property Value

Microsoft.DirectX.Direct3D.CharacterSet
A CharacterSet enumeration that represents the character set associated with the font.

This property is read/write.


FontDescription.FaceName Property (Microsoft.DirectX.Direct3D)

FontDescription.FaceName Property

Retrieves or sets the name of the font.

Definition

Visual Basic | Public Property FaceName As String
C# | public string FaceName { get; set; }
C++ public:
property String^ FaceName {
String^ get();
void set(String^ value);
}
JScript public function get FaceName() : String
public function set FaceName(String);

Property Value

System.String
String up to 32 characters in length that represents the font name.

This property is read/write.

Remarks

If FaceName is an empty string, the first font that matches the other specified attributes is used.


FontDescription.Height Property (Microsoft.DirectX.Direct3D)

FontDescription.Height Property

Retrieves or sets the height of the font in logical units.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer that represents the height of the font in logical units.

This property is read/write.


FontDescription.IsItalic Property (Microsoft.DirectX.Direct3D)

FontDescription.IsItalic Property

Determines whether a font is italic.

Definition

Visual Basic | Public Property IsItalic As Boolean
C# | public bool IsItalic { get; set; }
C++ public:
property bool IsItalic {
bool get();
void set(bool value);
}
JScript public function get IsItalic() : boolean
public function set IsItalic(boolean);

Property Value

System.Boolean
Value that is true if the font is italic, or false if it is not.

This property is read/write.


FontDescription.MipLevels Property (Microsoft.DirectX.Direct3D)

FontDescription.MipLevels Property

Retrieves or sets the number of mip levels requested.

Definition

Visual Basic | Public Property MipLevels As Integer
C# | public int MipLevels { get; set; }
C++ public:
property int MipLevels {
int get();
void set(int value);
}
JScript public function get MipLevels() : int
public function set MipLevels(int);

Property Value

System.Int32
Integer that represents the number of mip levels.

This property is read/write.

Remarks

If this value is 0, a complete mipmap chain is created. If the value is 1, the texture space is mapped identically to the screen space.


FontDescription.OutputPrecision Property (Microsoft.DirectX.Direct3D)

FontDescription.OutputPrecision Property

Retrieves or sets the output precision for a font.

Definition

Visual Basic | Public Property OutputPrecision As Precision
C# | public Precision OutputPrecision { get; set; }
C++ public:
property Precision OutputPrecision {
Precision get();
void set(Precision value);
}
JScript public function get OutputPrecision() : Precision
public function set OutputPrecision(Precision);

Property Value

Microsoft.DirectX.Direct3D.Precision
Member of the Precision enumeration to set or retrieve.

This property is read/write.

Remarks

The output precision defines how closely the output must match the requested font height, width, character orientation, escapement, pitch, and font type.


FontDescription.PitchAndFamily Property (Microsoft.DirectX.Direct3D)

FontDescription.PitchAndFamily Property

Retrieves or sets the pitch and family of a font.

Definition

Visual Basic | Public Property PitchAndFamily As PitchAndFamily
C# | public PitchAndFamily PitchAndFamily { get; set; }
C++ public:
property PitchAndFamily PitchAndFamily {
PitchAndFamily get();
void set(PitchAndFamily value);
}
JScript public function get PitchAndFamily() : PitchAndFamily
public function set PitchAndFamily(PitchAndFamily);

Property Value

Microsoft.DirectX.Direct3D.PitchAndFamily
Member of the PitchAndFamily enumeration to set or retrieve.

This property is read/write.


FontDescription.Quality Property (Microsoft.DirectX.Direct3D)

FontDescription.Quality Property

Retrieves or sets the output quality of a font.

Definition

Visual Basic | Public Property Quality As FontQuality
C# | public FontQuality Quality { get; set; }
C++ public:
property FontQuality Quality {
FontQuality get();
void set(FontQuality value);
}
JScript public function get Quality() : FontQuality
public function set Quality(FontQuality);

Property Value

Microsoft.DirectX.Direct3D.FontQuality
Member of the FontQuality enumeration to set or retrieve.

This property is read/write.


FontDescription.Weight Property (Microsoft.DirectX.Direct3D)

FontDescription.Weight Property

Retrieves or sets the weight of a font.

Definition

Visual Basic | Public Property Weight As FontWeight
C# | public FontWeight Weight { get; set; }
C++ public:
property FontWeight Weight {
FontWeight get();
void set(FontWeight value);
}
JScript public function get Weight() : FontWeight
public function set Weight(FontWeight);

Property Value

Microsoft.DirectX.Direct3D.FontWeight
Member of the FontWeight enumeration to set or retrieve.

This property is read/write.


FontDescription.Width Property (Microsoft.DirectX.Direct3D)

FontDescription.Width Property

Retrieves or sets the width of a font in logical units.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer that represents the width of the font in logical units.

This property is read/write.


FormatList Structure (Microsoft.DirectX.Direct3D)

FormatList Structure

Contains a list of formats supported by the device.

Definition

Visual Basic | Public Structure FormatList
C# | public struct FormatList
C++ | public value class FormatList sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FormatList | Initializes a new instance of the FormatList class.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FormatList.FormatList() Constructor (Microsoft.DirectX.Direct3D)

FormatList.FormatList Constructor

Initializes a new instance of the FormatList class.

Definition

Visual Basic | Public Sub New()
C# | public FormatList();
C++ public:
FormatList();
JScript | public function FormatList();


FragmentDescription Structure (Microsoft.DirectX.Direct3D)

FragmentDescription Structure

Describes an annotation used by an effect object.

Definition

Visual Basic | Public Structure FragmentDescription
C# | public struct FragmentDescription
C++ | public value class FragmentDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FragmentDescription | Initializes a new instance of the FragmentDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Name | Retrieves or sets a fragment name.
Target | Retrieves or sets a fragment compile target.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FragmentDescription.FragmentDescription() Constructor (Microsoft.DirectX.Direct3D)

FragmentDescription.FragmentDescription Constructor

Initializes a new instance of the FragmentDescription class.

Definition

Visual Basic | Public Sub New()
C# | public FragmentDescription();
C++ public:
FragmentDescription();
JScript | public function FragmentDescription();


FragmentDescription.ToString() Method (Microsoft.DirectX.Direct3D)

FragmentDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FragmentDescription.Name Property (Microsoft.DirectX.Direct3D)

FragmentDescription.Name Property

Retrieves or sets a fragment name.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String
String that contains the fragment name.

This property is read/write.


FragmentDescription.Target Property (Microsoft.DirectX.Direct3D)

FragmentDescription.Target Property

Retrieves or sets a fragment compile target.

Definition

Visual Basic | Public Property Target As Integer
C# | public int Target { get; set; }
C++ public:
property int Target {
int get();
void set(int value);
}
JScript public function get Target() : int
public function set Target(int);

Property Value

System.Int32
Integer that represents the compile target.

This property is read/write.

Remarks

The compile target identifies the shader type (vertex or pixel) and the version number.


FunctionDescription Structure (Microsoft.DirectX.Direct3D)

FunctionDescription Structure

Describes a function used by an effect.

Definition

Visual Basic | Public Structure FunctionDescription
C# | public struct FunctionDescription
C++ | public value class FunctionDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
FunctionDescription | Initializes a new instance of the FunctionDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Annotations | Unused. This member is always set to 0 by BaseEffect.GetFunctionDescription.
Name | Retrieves the function name.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FunctionDescription.FunctionDescription() Constructor (Microsoft.DirectX.Direct3D)

FunctionDescription.FunctionDescription Constructor

Initializes a new instance of the FunctionDescription class.

Definition

Visual Basic | Public Sub New()
C# | public FunctionDescription();
C++ public:
FunctionDescription();
JScript | public function FunctionDescription();


FunctionDescription.ToString() Method (Microsoft.DirectX.Direct3D)

FunctionDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FunctionDescription.Annotations Property (Microsoft.DirectX.Direct3D)

FunctionDescription.Annotations Property

Unused. This member is always set to 0 by BaseEffect.GetFunctionDescription.

Definition

Visual Basic | Public ReadOnly Property Annotations As Integer
C# | public int Annotations { get; }
C++ public:
property int Annotations {
int get();
}
JScript | public function get Annotations() : int

Property Value

System.Int32

This property is read-only.


FunctionDescription.Name Property (Microsoft.DirectX.Direct3D)

FunctionDescription.Name Property

Retrieves the function name.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
String that contains the function name to retrieve.

This property is read-only.


GammaRamp Structure (Microsoft.DirectX.Direct3D)

GammaRamp Structure

Contains red, green, and blue ramp data.

Definition

Visual Basic | Public Structure GammaRamp
C# | public struct GammaRamp
C++ | public value class GammaRamp sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GammaRamp | Initializes a new instance of the GammaRamp class.
GetBlue | Retrieves the blue component of the gamma ramp.
GetGreen | Retrieves the green component of the gamma ramp.
GetRed | Retrieves the red component of the gamma ramp.
SetBlue | Sets the blue component of the gamma ramp.
SetGreen | Sets the green component of the gamma ramp.
SetRed | Sets the red component of the gamma ramp.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GammaRamp.GammaRamp() Constructor (Microsoft.DirectX.Direct3D)

GammaRamp.GammaRamp Constructor

Initializes a new instance of the GammaRamp class.

Definition

Visual Basic | Public Sub New()
C# | public GammaRamp();
C++ public:
GammaRamp();
JScript | public function GammaRamp();


GammaRamp.GetBlue() Method (Microsoft.DirectX.Direct3D)

GammaRamp.GetBlue Method

Retrieves the blue component of the gamma ramp.

Definition

Visual Basic | Public Function GetBlue() As Short()
C# | public short[] GetBlue();
C++ public:
array<short>^ GetBlue();
JScript | public function GetBlue() : short[];

Return Value

System.Int16[]
A 256-element integer array that represents the blue component.


GammaRamp.GetGreen() Method (Microsoft.DirectX.Direct3D)

GammaRamp.GetGreen Method

Retrieves the green component of the gamma ramp.

Definition

Visual Basic | Public Function GetGreen() As Short()
C# | public short[] GetGreen();
C++ public:
array<short>^ GetGreen();
JScript | public function GetGreen() : short[];

Return Value

System.Int16[]
A 256-element integer array that represents the green component.


GammaRamp.GetRed() Method (Microsoft.DirectX.Direct3D)

GammaRamp.GetRed Method

Retrieves the red component of the gamma ramp.

Definition

Visual Basic | Public Function GetRed() As Short()
C# | public short[] GetRed();
C++ public:
array<short>^ GetRed();
JScript | public function GetRed() : short[];

Return Value

System.Int16[]
A 256-element integer array that represents the red component.


GammaRamp.SetBlue(Int16[]) Method (Microsoft.DirectX.Direct3D)

GammaRamp.SetBlue Method

Sets the blue component of the gamma ramp.

Definition

Visual Basic Public Sub SetBlue( _
ByVal value() As Short _
)
C# public void SetBlue(
short[] value
);
C++ public:
void SetBlue(
array<short>^ value
);
JScript public function SetBlue(
value : short[]
);

Parameters

value System.Int16[]
A 256-element integer array that represents the blue component.

Remarks

Exceptions
ArgumentException Leave Site The value parameter is not a 256-element integer array. The array must have a size of 256.


GammaRamp.SetGreen(Int16[]) Method (Microsoft.DirectX.Direct3D)

GammaRamp.SetGreen Method

Sets the green component of the gamma ramp.

Definition

Visual Basic Public Sub SetGreen( _
ByVal value() As Short _
)
C# public void SetGreen(
short[] value
);
C++ public:
void SetGreen(
array<short>^ value
);
JScript public function SetGreen(
value : short[]
);

Parameters

value System.Int16[]
A 256-element integer array that represents the green component.

Remarks

Exceptions
ArgumentException Leave Site The value parameter is not a 256-element integer array. The array must have a size of 256.


GammaRamp.SetRed(Int16[]) Method (Microsoft.DirectX.Direct3D)

GammaRamp.SetRed Method

Sets the red component of the gamma ramp.

Definition

Visual Basic Public Sub SetRed( _
ByVal value() As Short _
)
C# public void SetRed(
short[] value
);
C++ public:
void SetRed(
array<short>^ value
);
JScript public function SetRed(
value : short[]
);

Parameters

value System.Int16[]
A 256-element integer array that represents the red component.

Remarks

Exceptions
ArgumentException Leave Site The value parameter is not a 256-element integer array. The array must have a size of 256.


GlyphMetricsFloat Structure (Microsoft.DirectX.Direct3D)

GlyphMetricsFloat Structure

Contains information about the position and orientation of the corresponding glyph in the string.

Definition

Visual Basic | Public Structure GlyphMetricsFloat
C# | public struct GlyphMetricsFloat
C++ | public value class GlyphMetricsFloat sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GlyphMetricsFloat | Initializes a new instance of the GlyphMetricsFloat class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BlackBoxX | Specifies the width of the smallest rectangle (the glyph's black box) that completely encloses the glyph.
BlackBoxY | Specifies the height of the smallest rectangle (the glyph's black box) that completely encloses the glyph.
CellIncX | Specifies the horizontal distance from the origin of the current character cell to the origin of the next character cell.
CellIncY | Specifies the vertical distance from the origin of the current character cell to the origin of the next character cell.
GlyphOrigin | Specifies the x and y coordinates of the upper-left corner of the smallest rectangle that completely encloses the glyph.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GlyphMetricsFloat.GlyphMetricsFloat() Constructor (Microsoft.DirectX.Direct3D)

GlyphMetricsFloat.GlyphMetricsFloat Constructor

Initializes a new instance of the GlyphMetricsFloat class.

Definition

Visual Basic | Public Sub New()
C# | public GlyphMetricsFloat();
C++ public:
GlyphMetricsFloat();
JScript | public function GlyphMetricsFloat();


GlyphMetricsFloat.ToString() Method (Microsoft.DirectX.Direct3D)

GlyphMetricsFloat.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


GlyphMetricsFloat.BlackBoxX Property (Microsoft.DirectX.Direct3D)

GlyphMetricsFloat.BlackBoxX Property

Specifies the width of the smallest rectangle (the glyph's black box) that completely encloses the glyph.

Definition

Visual Basic | Public Property BlackBoxX As Single
C# | public float BlackBoxX { get; set; }
C++ public:
property float BlackBoxX {
float get();
void set(float value);
}
JScript public function get BlackBoxX() : float
public function set BlackBoxX(float);

Property Value

System.Single
Floating-point value that represents the width of the glyph's black box.

This property is read/write.


GlyphMetricsFloat.BlackBoxY Property (Microsoft.DirectX.Direct3D)

GlyphMetricsFloat.BlackBoxY Property

Specifies the height of the smallest rectangle (the glyph's black box) that completely encloses the glyph.

Definition

Visual Basic | Public Property BlackBoxY As Single
C# | public float BlackBoxY { get; set; }
C++ public:
property float BlackBoxY {
float get();
void set(float value);
}
JScript public function get BlackBoxY() : float
public function set BlackBoxY(float);

Property Value

System.Single
Floating-point value that represents the height of the glyph's black box.

This property is read/write.


GlyphMetricsFloat.CellIncX Property (Microsoft.DirectX.Direct3D)

GlyphMetricsFloat.CellIncX Property

Specifies the horizontal distance from the origin of the current character cell to the origin of the next character cell.

Definition

Visual Basic | Public Property CellIncX As Single
C# | public float CellIncX { get; set; }
C++ public:
property float CellIncX {
float get();
void set(float value);
}
JScript public function get CellIncX() : float
public function set CellIncX(float);

Property Value

System.Single
Floating-point value that represents the horizontal distance between character-cell origin points.

This property is read/write.


GlyphMetricsFloat.CellIncY Property (Microsoft.DirectX.Direct3D)

GlyphMetricsFloat.CellIncY Property

Specifies the vertical distance from the origin of the current character cell to the origin of the next character cell.

Definition

Visual Basic | Public Property CellIncY As Single
C# | public float CellIncY { get; set; }
C++ public:
property float CellIncY {
float get();
void set(float value);
}
JScript public function get CellIncY() : float
public function set CellIncY(float);

Property Value

System.Single
Floating-point value that represents the vertical distance between character-cell origin points.

This property is read/write.


GlyphMetricsFloat.GlyphOrigin Property (Microsoft.DirectX.Direct3D)

GlyphMetricsFloat.GlyphOrigin Property

Specifies the x and y coordinates of the upper-left corner of the smallest rectangle that completely encloses the glyph.

Definition

Visual Basic | Public Property GlyphOrigin As PointF
C# | public PointF GlyphOrigin { get; set; }
C++ public:
property PointF GlyphOrigin {
PointF get();
void set(PointF value);
}
JScript public function get GlyphOrigin() : PointF
public function set GlyphOrigin(PointF);

Property Value

System.Drawing.PointF
A PointF Leave Site object to set or retrieve.

This property is read/write.


ImageInformation Structure (Microsoft.DirectX.Direct3D)

ImageInformation Structure

Contains a description of the original contents of an image file.

Definition

Visual Basic | Public Structure ImageInformation
C# | public struct ImageInformation
C++ | public value class ImageInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ImageInformation | Initializes a new instance of the ImageInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Depth | Retrieves or sets the depth of the original image.
Format | Retrieves or sets a value that most closely describes the data in the original image.
Height | Retrieves or sets the height of the original image.
ImageFileFormat | Retrieves or sets the format of the image file.
MipLevels | Retrieves or sets the number of mip levels in the original image.
ResourceType | Retrieves or sets a value that represents the type of the texture stored in the file.
Width | Retrieves or sets the width of the original image.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ImageInformation.ImageInformation() Constructor (Microsoft.DirectX.Direct3D)

ImageInformation.ImageInformation Constructor

Initializes a new instance of the ImageInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ImageInformation();
C++ public:
ImageInformation();
JScript | public function ImageInformation();


ImageInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ImageInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ImageInformation.Depth Property (Microsoft.DirectX.Direct3D)

ImageInformation.Depth Property

Retrieves or sets the depth of the original image.

Definition

Visual Basic | Public Property Depth As Integer
C# | public int Depth { get; set; }
C++ public:
property int Depth {
int get();
void set(int value);
}
JScript public function get Depth() : int
public function set Depth(int);

Property Value

System.Int32
Integer that represents the depth of the original image in pixels.

This property is read/write.


ImageInformation.Format Property (Microsoft.DirectX.Direct3D)

ImageInformation.Format Property

Retrieves or sets a value that most closely describes the data in the original image.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration to set or retrieve.

This property is read/write.


ImageInformation.Height Property (Microsoft.DirectX.Direct3D)

ImageInformation.Height Property

Retrieves or sets the height of the original image.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer that represents the height of the original image in pixels.

This property is read/write.


ImageInformation.ImageFileFormat Property (Microsoft.DirectX.Direct3D)

ImageInformation.ImageFileFormat Property

Retrieves or sets the format of the image file.

Definition

Visual Basic | Public Property ImageFileFormat As ImageFileFormat
C# | public ImageFileFormat ImageFileFormat { get; set; }
C++ public:
property ImageFileFormat ImageFileFormat {
ImageFileFormat get();
void set(ImageFileFormat value);
}
JScript public function get ImageFileFormat() : ImageFileFormat
public function set ImageFileFormat(ImageFileFormat);

Property Value

Microsoft.DirectX.Direct3D.ImageFileFormat
Member of the ImageFileFormat enumeration to set or retrieve.

This property is read/write.


ImageInformation.MipLevels Property (Microsoft.DirectX.Direct3D)

ImageInformation.MipLevels Property

Retrieves or sets the number of mip levels in the original image.

Definition

Visual Basic | Public Property MipLevels As Integer
C# | public int MipLevels { get; set; }
C++ public:
property int MipLevels {
int get();
void set(int value);
}
JScript public function get MipLevels() : int
public function set MipLevels(int);

Property Value

System.Int32
Integer that represents the number of mip levels.

This property is read/write.


ImageInformation.ResourceType Property (Microsoft.DirectX.Direct3D)

ImageInformation.ResourceType Property

Retrieves or sets a value that represents the type of the texture stored in the file.

Definition

Visual Basic | Public Property ResourceType As ResourceType
C# | public ResourceType ResourceType { get; set; }
C++ public:
property ResourceType ResourceType {
ResourceType get();
void set(ResourceType value);
}
JScript public function get ResourceType() : ResourceType
public function set ResourceType(ResourceType);

Property Value

Microsoft.DirectX.Direct3D.ResourceType
Member of the ResourceType enumeration to set or retrieve.

This property is read/write.

Remarks

The type of texture stored in the file can be ResourceType.Texture, ResourceType.VolumeTexture, or ResourceType.CubeTexture.


ImageInformation.Width Property (Microsoft.DirectX.Direct3D)

ImageInformation.Width Property

Retrieves or sets the width of the original image.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer that represents the width of the original image in pixels.

This property is read/write.


IndexBufferDescription Structure (Microsoft.DirectX.Direct3D)

IndexBufferDescription Structure

Describes an index buffer.

Definition

Visual Basic | Public Structure IndexBufferDescription
C# | public struct IndexBufferDescription
C++ | public value class IndexBufferDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
IndexBufferDescription | Initializes a new instance of the IndexBufferDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Is16BitIndices | Determines whether the index buffer has 16-bit indices or 32-bit indices.
Pool | Retrieves a value that specifies the class of memory allocated for the current index buffer.
Size | Retrieves the size of the index buffer.
Type | Retrieves a value that identifies the current resource as an index buffer.
Usage | Retrieves values that specify usage for the current resource.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IndexBufferDescription.IndexBufferDescription() Constructor (Microsoft.DirectX.Direct3D)

IndexBufferDescription.IndexBufferDescription Constructor

Initializes a new instance of the IndexBufferDescription class.

Definition

Visual Basic | Public Sub New()
C# | public IndexBufferDescription();
C++ public:
IndexBufferDescription();
JScript | public function IndexBufferDescription();


IndexBufferDescription.ToString() Method (Microsoft.DirectX.Direct3D)

IndexBufferDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


IndexBufferDescription.Is16BitIndices Property (Microsoft.DirectX.Direct3D)

IndexBufferDescription.Is16BitIndices Property

Determines whether the index buffer has 16-bit indices or 32-bit indices.

Definition

Visual Basic | Public ReadOnly Property Is16BitIndices As Boolean
C# | public bool Is16BitIndices { get; }
C++ public:
property bool Is16BitIndices {
bool get();
}
JScript | public function get Is16BitIndices() : boolean

Property Value

System.Boolean
Returns true if the index buffer has 16-bit indices, or false if the index buffer has 32-bit indices.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


IndexBufferDescription.Pool Property (Microsoft.DirectX.Direct3D)

IndexBufferDescription.Pool Property

Retrieves a value that specifies the class of memory allocated for the current index buffer.

Definition

Visual Basic | Public ReadOnly Property Pool As Pool
C# | public Pool Pool { get; }
C++ public:
property Pool Pool {
Pool get();
}
JScript | public function get Pool() : Pool

Property Value

Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumeration to retrieve.

This property is read-only.


IndexBufferDescription.Size Property (Microsoft.DirectX.Direct3D)

IndexBufferDescription.Size Property

Retrieves the size of the index buffer.

Definition

Visual Basic | Public ReadOnly Property Size As Integer
C# | public int Size { get; }
C++ public:
property int Size {
int get();
}
JScript | public function get Size() : int

Property Value

System.Int32
An integer that specifies the size of the index buffer, in bytes.

This property is read-only.


IndexBufferDescription.Type Property (Microsoft.DirectX.Direct3D)

IndexBufferDescription.Type Property

Retrieves a value that identifies the current resource as an index buffer.

Definition

Visual Basic | Public ReadOnly Property Type As ResourceType
C# | public ResourceType Type { get; }
C++ public:
property ResourceType Type {
ResourceType get();
}
JScript | public function get Type() : ResourceType

Property Value

Microsoft.DirectX.Direct3D.ResourceType
Member of the ResourceType enumeration that identifies the current resource.

This property is read-only.


IndexBufferDescription.Usage Property (Microsoft.DirectX.Direct3D)

IndexBufferDescription.Usage Property

Retrieves values that specify usage for the current resource.

Definition

Visual Basic | Public ReadOnly Property Usage As Usage
C# | public Usage Usage { get; }
C++ public:
property Usage Usage {
Usage get();
}
JScript | public function get Usage() : Usage

Property Value

Microsoft.DirectX.Direct3D.Usage
One or more members of the Usage enumeration to retrieve.

This property is read-only.


InterfaceTimings Structure (Microsoft.DirectX.Direct3D)

InterfaceTimings Structure

Provides percentage of time processing data in the driver. These statistics may help identify cases when the driver is waiting for other resources.

Definition

Visual Basic | Public Structure InterfaceTimings
C# | public struct InterfaceTimings
C++ | public value class InterfaceTimings sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
InterfaceTimings | Creates a new instance of the InterfaceTimings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
WaitingForGpuExclusiveResourceTimePercent | Retrieves the percentage of time the driver spent waiting for a resource that cannot be pipelined (that is, operated in parallel).
WaitingForGpuOtherTimePercent | Retrieves the percentage of time the driver spent waiting for other GPU processing.
WaitingForGpuToAcceptMoreCommandsTimePercent | Retrieves the percentage of time the driver spent waiting for the GPU to finish processing some commands before the driver could send more. This indicates the driver has run out of room to send commands to the GPU.
WaitingForGpuToStayWithinLatencyTimePercent | Retrieves the percentage of time the driver spent waiting for the graphics processing unit (GPU) latency to reduce to less than 3 rendering frames.
WaitingForGpuToUseApplicationResourceTimePercent | Retrieves the percentage of time the driver spent waiting for the GPU to finish using a locked resource (and LockFlags.DoNotWait wasn't specified).

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InterfaceTimings.InterfaceTimings() Constructor (Microsoft.DirectX.Direct3D)

InterfaceTimings.InterfaceTimings Constructor

Creates a new instance of the InterfaceTimings structure.

Definition

Visual Basic | Public Sub New()
C# | public InterfaceTimings();
C++ public:
InterfaceTimings();
JScript | public function InterfaceTimings();


InterfaceTimings.ToString() Method (Microsoft.DirectX.Direct3D)

InterfaceTimings.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


InterfaceTimings.WaitingForGpuExclusiveResourceTimePercent Property (Microsoft.DirectX.Direct3D)

InterfaceTimings.WaitingForGpuExclusiveResourceTimePercent Property

Language:

Retrieves the percentage of time the driver spent waiting for a resource that cannot be pipelined (that is, operated in parallel).

Definition

Visual Basic | Public ReadOnly Property WaitingForGpuExclusiveResourceTimePercent As Single
C# | public float WaitingForGpuExclusiveResourceTimePercent { get; }
C++ public:
property float WaitingForGpuExclusiveResourceTimePercent {
float get();
}
JScript | public function get WaitingForGpuExclusiveResourceTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time the driver spent waiting for a resource that cannot be pipelined.

This property is read-only.

Remarks

Generally, this indicates the possible absence of first-class support of a certain feature. An application may want to avoid using a non-pipelined resource for performance reasons.


InterfaceTimings.WaitingForGpuOtherTimePercent Property (Microsoft.DirectX.Direct3D)

InterfaceTimings.WaitingForGpuOtherTimePercent Property

Retrieves the percentage of time the driver spent waiting for other graphics processing unit (GPU) processing.

Definition

Visual Basic | Public ReadOnly Property WaitingForGpuOtherTimePercent As Single
C# | public float WaitingForGpuOtherTimePercent { get; }
C++ public:
property float WaitingForGpuOtherTimePercent {
float get();
}
JScript | public function get WaitingForGpuOtherTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time the driver spent waiting for other GPU processing.

This property is read-only.


InterfaceTimings.WaitingForGpuToAcceptMoreCommandsTimePercent Property (Microsoft.DirectX.Direct3D)

InterfaceTimings.WaitingForGpuToAcceptMoreCommandsTimePercent Property

Language:

Retrieves the percentage of time the driver spent waiting for the graphics processing unit (GPU) to finish processing some commands before the driver could send more. This indicates the driver has run out of room to send commands to the GPU.

Definition

Visual Basic | Public ReadOnly Property WaitingForGpuToAcceptMoreCommandsTimePercent As Single
C# | public float WaitingForGpuToAcceptMoreCommandsTimePercent { get; }
C++ public:
property float WaitingForGpuToAcceptMoreCommandsTimePercent {
float get();
}
JScript | public function get WaitingForGpuToAcceptMoreCommandsTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time the driver spent waiting for the GPU to finish processing some commands before the driver could send more.

This property is read-only.


InterfaceTimings.WaitingForGpuToStayWithinLatencyTimePercent Property (Microsoft.DirectX.Direct3D)

InterfaceTimings.WaitingForGpuToStayWithinLatencyTimePercent Property

Language:

Retrieves the percentage of time the driver spent waiting for the graphics processing unit (GPU) latency to reduce to less than 3 rendering frames.

Definition

Visual Basic | Public ReadOnly Property WaitingForGpuToStayWithinLatencyTimePercent As Single
C# | public float WaitingForGpuToStayWithinLatencyTimePercent { get; }
C++ public:
property float WaitingForGpuToStayWithinLatencyTimePercent {
float get();
}
JScript | public function get WaitingForGpuToStayWithinLatencyTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time the driver spent waiting for the GPU latency to reduce to less than 3 rendering frames.

This property is read-only.

Remarks

If an application is GPU limited, the driver must stall the CPU until the GPU gets within 3 frames. This prevents an application from queueing up many seconds' worth of rendering calls which may dramatically increase the latency between when the user provides new data and when the user sees the results of that input. In general, the driver can track the number of times Device.Present is called to prevent queueing up more than three frames of rendering work.


InterfaceTimings.WaitingForGpuToUseApplicationResourceTimePercent Property (Microsoft.DirectX.Direct3D)

InterfaceTimings.WaitingForGpuToUseApplicationResourceTimePercent Property

Language:

Retrieves the percentage of time the driver spent waiting for the graphics processing unit (GPU) to finish using a locked resource (and LockFlags.DoNotWait wasn't specified).

Definition

Visual Basic | Public ReadOnly Property WaitingForGpuToUseApplicationResourceTimePercent As Single
C# | public float WaitingForGpuToUseApplicationResourceTimePercent { get; }
C++ public:
property float WaitingForGpuToUseApplicationResourceTimePercent {
float get();
}
JScript | public function get WaitingForGpuToUseApplicationResourceTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time the driver spent waiting for the GPU to finish using a locked resource.

This property is read-only.


IntersectInformation Structure (Microsoft.DirectX.Direct3D)

IntersectInformation Structure

Describes the intersection of a ray and a triangle.

Definition

Visual Basic | Public Structure IntersectInformation
C# | public struct IntersectInformation
C++ | public value class IntersectInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
IntersectInformation | Initializes a new instance of the IntersectInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Dist | Retrieves or sets the distance along the ray where the intersection occurred.
FaceIndex | Retrieves or sets the index of the triangle that intersected the ray.
U | Retrieves or sets the barycentric coordinate within the triangle where the ray intersects.
V | Retrieves or sets the barycentric coordinate within the triangle where the ray intersects.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IntersectInformation.IntersectInformation() Constructor (Microsoft.DirectX.Direct3D)

IntersectInformation.IntersectInformation Constructor

Initializes a new instance of the IntersectInformation class.

Definition

Visual Basic | Public Sub New()
C# | public IntersectInformation();
C++ public:
IntersectInformation();
JScript | public function IntersectInformation();


IntersectInformation.ToString() Method (Microsoft.DirectX.Direct3D)

IntersectInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


IntersectInformation.Dist Property (Microsoft.DirectX.Direct3D)

IntersectInformation.Dist Property

Retrieves or sets the distance along the ray where the intersection occurred.

Definition

Visual Basic | Public Property Dist As Single
C# | public float Dist { get; set; }
C++ public:
property float Dist {
float get();
void set(float value);
}
JScript public function get Dist() : float
public function set Dist(float);

Property Value

System.Single
Floating-point value that represents the distance of the intersection.

This property is read/write.


IntersectInformation.FaceIndex Property (Microsoft.DirectX.Direct3D)

IntersectInformation.FaceIndex Property

Retrieves or sets the index of the triangle that intersected the ray.

Definition

Visual Basic | Public Property FaceIndex As Integer
C# | public int FaceIndex { get; set; }
C++ public:
property int FaceIndex {
int get();
void set(int value);
}
JScript public function get FaceIndex() : int
public function set FaceIndex(int);

Property Value

System.Int32
Integer that represents the triangle ray.

This property is read/write.


IntersectInformation.U Property (Microsoft.DirectX.Direct3D)

IntersectInformation.U Property

Retrieves or sets the barycentric coordinate within the triangle where the ray intersects.

Definition

Visual Basic | Public Property U As Single
C# | public float U { get; set; }
C++ public:
property float U {
float get();
void set(float value);
}
JScript public function get U() : float
public function set U(float);

Property Value

System.Single
Floating-point value that represents the barycentric coordinate.

This property is read/write.


IntersectInformation.V Property (Microsoft.DirectX.Direct3D)

IntersectInformation.V Property

Retrieves or sets the barycentric coordinate within the triangle where the ray intersects.

Definition

Visual Basic | Public Property V As Single
C# | public float V { get; set; }
C++ public:
property float V {
float get();
void set(float value);
}
JScript public function get V() : float
public function set V(float);

Property Value

System.Single
Floating-point value that represents the barycentric coordinate.

This property is read/write.


KeyCallback Structure (Microsoft.DirectX.Direct3D)

KeyCallback Structure

Describes a callback key for use in keyframe animation.

Definition

Visual Basic | Public Structure KeyCallback
C# | public struct KeyCallback
C++ | public value class KeyCallback sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
CallBackData | Retrieves or sets user callback data.
Time | Retrieves or sets a time value that indicates when the callback is triggered.

Methods

Method | Description
KeyCallback | Creates a new instance of a KeyCallback structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


KeyCallback.KeyCallback() Constructor (Microsoft.DirectX.Direct3D)

KeyCallback.KeyCallback Constructor

Creates a new instance of a KeyCallback structure.

Definition

Visual Basic | Public Sub New()
C# | public KeyCallback();
C++ public:
KeyCallback();
JScript | public function KeyCallback();


KeyCallback.CallBackData Field (Microsoft.DirectX.Direct3D)

KeyCallback.CallBackData Field

Retrieves or sets user callback data.

Definition

Visual Basic | Public CallBackData As IntPtr
C# | public IntPtr CallBackData;
C++ | public: IntPtr CallBackData;
JScript | public var CallBackData : IntPtr

Field Value

System.IntPtr
User callback data.

This field is read/write.


KeyCallback.Time Field (Microsoft.DirectX.Direct3D)

KeyCallback.Time Field

Retrieves or sets a time value that indicates when the callback is triggered.

Definition

Visual Basic | Public Time As Single
C# | public Single Time;
C++ | public: Single Time;
JScript | public var Time : Single

Field Value

System.Single
Time value.

This field is read/write.


KeyQuaternion Structure (Microsoft.DirectX.Direct3D)

KeyQuaternion Structure

Describes a quaternion key for use in keyframe animation, and specifies a quaternion value at a given time.

Definition

Visual Basic | Public Structure KeyQuaternion
C# | public struct KeyQuaternion
C++ | public value class KeyQuaternion sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Time | Retrieves or sets the time of the quaternion key.
Value | Retrieves or sets the value of the quaternion key.

Methods

Method | Description
KeyQuaternion | Initializes a new instance of the KeyQuaternion class.

Remarks

This structure is used for rotation keys.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


KeyQuaternion.KeyQuaternion() Constructor (Microsoft.DirectX.Direct3D)

KeyQuaternion.KeyQuaternion Constructor

Initializes a new instance of the KeyQuaternion class.

Definition

Visual Basic | Public Sub New()
C# | public KeyQuaternion();
C++ public:
KeyQuaternion();
JScript | public function KeyQuaternion();


KeyQuaternion.Time Field (Microsoft.DirectX.Direct3D)

KeyQuaternion.Time Field

Retrieves or sets the time of the quaternion key.

Definition

Visual Basic | Public Time As Single
C# | public Single Time;
C++ | public: Single Time;
JScript | public var Time : Single

Field Value

System.Single
Floating-point value that represents the time of the quaternion key.

This field is read/write.


KeyQuaternion.Value Field (Microsoft.DirectX.Direct3D)

KeyQuaternion.Value Field

Retrieves or sets the value of the quaternion key.

Definition

Visual Basic | Public Value As Quaternion
C# | public Quaternion Value;
C++ | public: Quaternion Value;
JScript | public var Value : Quaternion

Field Value

Microsoft.DirectX.Quaternion
A Quaternion that supplies rotation values.

This field is read/write.


KeyVector3 Structure (Microsoft.DirectX.Direct3D)

KeyVector3 Structure

Describes a vector key for use in keyframe animation, and specifies a vector at a given time.

Definition

Visual Basic | Public Structure KeyVector3
C# | public struct KeyVector3
C++ | public value class KeyVector3 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Time | Retrieves or sets the keyframe time stamp.
Value | Retrieves or sets a Vector3 object that supplies scale and/or translation values.

Methods

Method | Description
KeyVector3 | Initializes a new instance of the KeyVector3 class.

Remarks

This structure is used for scale and translation keys.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


KeyVector3.KeyVector3() Constructor (Microsoft.DirectX.Direct3D)

KeyVector3.KeyVector3 Constructor

Initializes a new instance of the KeyVector3 class.

Definition

Visual Basic | Public Sub New()
C# | public KeyVector3();
C++ public:
KeyVector3();
JScript | public function KeyVector3();


KeyVector3.Time Field (Microsoft.DirectX.Direct3D)

KeyVector3.Time Field

Retrieves or sets the keyframe time stamp.

Definition

Visual Basic | Public Time As Single
C# | public Single Time;
C++ | public: Single Time;
JScript | public var Time : Single

Field Value

System.Single
Floating-point value that represents the keyframe time stamp.

This field is read/write.


KeyVector3.Value Field (Microsoft.DirectX.Direct3D)

KeyVector3.Value Field

Retrieves or sets a Vector3 object that supplies scale and/or translation values.

Definition

Visual Basic | Public Value As Vector3
C# | public Vector3 Value;
C++ | public: Vector3 Value;
JScript | public var Value : Vector3

Field Value

Microsoft.DirectX.Vector3
A Vector3 object to set or retrieve.

This field is read/write.


LineCaps Structure (Microsoft.DirectX.Direct3D)

LineCaps Structure

Defines the capabilities for line-drawing primitives.

Definition

Visual Basic | Public Structure LineCaps
C# | public struct LineCaps
C++ | public value class LineCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAlphaCompare | Specifies whether the device supports alpha-test comparisons.
SupportsAntiAlias | Specifies whether the device supports antialiased lines.
SupportsBlend | Specifies whether the device supports source blending.
SupportsFog | Specifies whether the device supports fog.
SupportsTextureMapping | Specifies whether the device supports texture mapping.
SupportsZBufferTest | Specifies whether the device supports z-buffer comparisons.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LineCaps.ToString() Method (Microsoft.DirectX.Direct3D)

LineCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


LineCaps.SupportsAlphaCompare Property (Microsoft.DirectX.Direct3D)

LineCaps.SupportsAlphaCompare Property

Specifies whether the device supports alpha-test comparisons.

Definition

Visual Basic | Public ReadOnly Property SupportsAlphaCompare As Boolean
C# | public bool SupportsAlphaCompare { get; }
C++ public:
property bool SupportsAlphaCompare {
bool get();
}
JScript | public function get SupportsAlphaCompare() : boolean

Property Value

System.Boolean
Value that is true if the device supports alpha-test comparisons, or false if it does not.

This property is read-only.


LineCaps.SupportsAntiAlias Property (Microsoft.DirectX.Direct3D)

LineCaps.SupportsAntiAlias Property

Specifies whether the device supports antialiased lines.

Definition

Visual Basic | Public ReadOnly Property SupportsAntiAlias As Boolean
C# | public bool SupportsAntiAlias { get; }
C++ public:
property bool SupportsAntiAlias {
bool get();
}
JScript | public function get SupportsAntiAlias() : boolean

Property Value

System.Boolean
Value that is true if the device supports antialiased lines, or false if it does not.

This property is read-only.


LineCaps.SupportsBlend Property (Microsoft.DirectX.Direct3D)

LineCaps.SupportsBlend Property

Specifies whether the device supports source blending.

Definition

Visual Basic | Public ReadOnly Property SupportsBlend As Boolean
C# | public bool SupportsBlend { get; }
C++ public:
property bool SupportsBlend {
bool get();
}
JScript | public function get SupportsBlend() : boolean

Property Value

System.Boolean
Value that is true if the device supports source blending, or false if it does not.

This property is read-only.


LineCaps.SupportsFog Property (Microsoft.DirectX.Direct3D)

LineCaps.SupportsFog Property

Specifies whether the device supports fog.

Definition

Visual Basic | Public ReadOnly Property SupportsFog As Boolean
C# | public bool SupportsFog { get; }
C++ public:
property bool SupportsFog {
bool get();
}
JScript | public function get SupportsFog() : boolean

Property Value

System.Boolean
Value that is true if the device supports fog, or false if it does not.

This property is read-only.


LineCaps.SupportsTextureMapping Property (Microsoft.DirectX.Direct3D)

LineCaps.SupportsTextureMapping Property

Specifies whether the device supports texture mapping.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureMapping As Boolean
C# | public bool SupportsTextureMapping { get; }
C++ public:
property bool SupportsTextureMapping {
bool get();
}
JScript | public function get SupportsTextureMapping() : boolean

Property Value

System.Boolean
Value that is true if the device supports texture mapping, or false if it does not.

This property is read-only.


LineCaps.SupportsZBufferTest Property (Microsoft.DirectX.Direct3D)

LineCaps.SupportsZBufferTest Property

Specifies whether the device supports z-buffer comparisons.

Definition

Visual Basic | Public ReadOnly Property SupportsZBufferTest As Boolean
C# | public bool SupportsZBufferTest { get; }
C++ public:
property bool SupportsZBufferTest {
bool get();
}
JScript | public function get SupportsZBufferTest() : boolean

Property Value

System.Boolean
Value that is true if the device supports z-buffer comparisons, or false if it does not.

This property is read-only.


LinePattern Structure (Microsoft.DirectX.Direct3D)

LinePattern Structure

Describes a line pattern.

Definition

Visual Basic | Public Structure LinePattern
C# | public struct LinePattern
C++ | public value class LinePattern sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
LinePattern | Initializes a new instance of the LinePattern class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Linepattern | Retrieves or sets bits that specify the line pattern.
RepeatFactor | Retrieves or sets the number of times to repeat each series of ones and zeros specified in the Linepattern property.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LinePattern.LinePattern() Constructor (Microsoft.DirectX.Direct3D)

LinePattern.LinePattern Constructor

Initializes a new instance of the LinePattern class.

Definition

Visual Basic | Public Sub New()
C# | public LinePattern();
C++ public:
LinePattern();
JScript | public function LinePattern();


LinePattern.ToString() Method (Microsoft.DirectX.Direct3D)

LinePattern.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


LinePattern.Linepattern Property (Microsoft.DirectX.Direct3D)

LinePattern.Linepattern Property

Retrieves or sets bits that specify the line pattern.

Definition

Visual Basic | Public Property Linepattern As Short
C# | public short Linepattern { get; set; }
C++ public:
property short Linepattern {
short get();
void set(short value);
}
JScript public function get Linepattern() : short
public function set Linepattern(short);

Property Value

System.Int16
Integer that contains the line pattern bits.

This property is read/write.

Remarks

For example, the following value produces a dotted line: 1100110011001100.


LinePattern.RepeatFactor Property (Microsoft.DirectX.Direct3D)

LinePattern.RepeatFactor Property

Retrieves or sets the number of times to repeat each series of ones and zeros specified in the Linepattern property.

Definition

Visual Basic | Public Property RepeatFactor As Short
C# | public short RepeatFactor { get; set; }
C++ public:
property short RepeatFactor {
short get();
void set(short value);
}
JScript public function get RepeatFactor() : short
public function set RepeatFactor(short);

Property Value

System.Int16
Integer that represents the number of times to repeat the Linepattern.

This property is read/write.

Remarks

This property allows an application to stretch the line pattern.


LockedBox Structure (Microsoft.DirectX.Direct3D)

LockedBox Structure

Describes a locked box (volume).

Definition

Visual Basic | Public Structure LockedBox
C# | public struct LockedBox
C++ | public value class LockedBox sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
LockedBox | Initializes a new instance of the LockedBox class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
RowPitch | Retrieves or sets the byte offset from the left edge of one row to the left edge of the next row.
SlicePitch | Retrieves or sets the byte offset from the top left of one slice to the top left of the next-deepest slice.

Remarks

Volumes can be visualized as being organized into slices of width x height 2-D surfaces that are stacked up to make a width x height x depth volume.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LockedBox.LockedBox() Constructor (Microsoft.DirectX.Direct3D)

LockedBox.LockedBox Constructor

Initializes a new instance of the LockedBox class.

Definition

Visual Basic | Public Sub New()
C# | public LockedBox();
C++ public:
LockedBox();
JScript | public function LockedBox();


LockedBox.ToString() Method (Microsoft.DirectX.Direct3D)

LockedBox.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


LockedBox.RowPitch Property (Microsoft.DirectX.Direct3D)

LockedBox.RowPitch Property

Retrieves or sets the byte offset from the left edge of one row to the left edge of the next row.

Definition

Visual Basic | Public Property RowPitch As Integer
C# | public int RowPitch { get; set; }
C++ public:
property int RowPitch {
int get();
void set(int value);
}
JScript public function get RowPitch() : int
public function set RowPitch(int);

Property Value

System.Int32
Integer that represents the row pitch in bytes.

This property is read/write.


LockedBox.SlicePitch Property (Microsoft.DirectX.Direct3D)

LockedBox.SlicePitch Property

Retrieves or sets the byte offset from the top left of one slice to the top left of the next-deepest slice.

Definition

Visual Basic | Public Property SlicePitch As Integer
C# | public int SlicePitch { get; set; }
C++ public:
property int SlicePitch {
int get();
void set(int value);
}
JScript public function get SlicePitch() : int
public function set SlicePitch(int);

Property Value

System.Int32
Integer that represents the slice pitch in bytes.

This property is read/write.


Macro Structure (Microsoft.DirectX.Direct3D)

Macro Structure

Describes preprocessor definitions used by an effect object.

Definition

Visual Basic | Public Structure Macro
C# | public struct Macro
C++ | public value class Macro sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Macro | Initializes a new instance of the Macro class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Definition | Retrieves or sets the definition name.
Name | Retrieves or sets the preprocessor name.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Macro.Macro() Constructor (Microsoft.DirectX.Direct3D)

Macro.Macro Constructor

Initializes a new instance of the Macro class.

Definition

Visual Basic | Public Sub New()
C# | public Macro();
C++ public:
Macro();
JScript | public function Macro();


Macro.ToString() Method (Microsoft.DirectX.Direct3D)

Macro.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Macro.Definition Property (Microsoft.DirectX.Direct3D)

Macro.Definition Property

Retrieves or sets the definition name.

Definition

Visual Basic | Public Property Definition As String
C# | public string Definition { get; set; }
C++ public:
property String^ Definition {
String^ get();
void set(String^ value);
}
JScript public function get Definition() : String
public function set Definition(String);

Property Value

System.String
String that represents the definition name.

This property is read/write.


Macro.Name Property (Microsoft.DirectX.Direct3D)

Macro.Name Property

Retrieves or sets the preprocessor name.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String
String that represents the preprocessor name.

This property is read/write.


Material Structure (Microsoft.DirectX.Direct3D)

Material Structure

Specifies material properties.

Definition

Visual Basic | Public Structure Material
C# | public struct Material
C++ | public value class Material sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
Material | Initializes a new instance of the Material class.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Ambient | Retrieves or sets a value that specifies the ambient color.
AmbientColor | Retrieves or sets the ambient ColorValue.
Diffuse | Retrieves or sets a value that specifies the diffuse color.
DiffuseColor | Retrieves or sets the diffuse ColorValue.
Emissive | Retrieves or sets a value that specifies the emissive color.
EmissiveColor | Retrieves or sets the emissive ColorValue.
Specular | Retrieves or sets a value that specifies the specular color.
SpecularColor | Retrieves or sets the specular ColorValue.
SpecularSharpness | Retrieves or sets a value that specifies the sharpness of specular highlights.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • ExtendedMaterial
  • Tutorial 6: Using Meshes


Material.Equals(Object) Method (Microsoft.DirectX.Direct3D)

Material.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Material.GetHashCode() Method (Microsoft.DirectX.Direct3D)

Material.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Material.Material() Constructor (Microsoft.DirectX.Direct3D)

Material.Material Constructor

Initializes a new instance of the Material class.

Definition

Visual Basic | Public Sub New()
C# | public Material();
C++ public:
Material();
JScript | public function Material();


Material.op_Equality(Material,Material) Method (Microsoft.DirectX.Direct3D)

Material.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Material, _
ByVal right As Material _
) As Boolean
C# public static bool op_Equality(
Material left,
Material right
);
C++ public:
static bool operator==(
Material left,
Material right
);
JScript public static function op_Equality(
left : Material,
right : Material
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Material
The Material object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Material
The Material object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Material.op_Inequality(Material,Material) Method (Microsoft.DirectX.Direct3D)

Material.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Material, _
ByVal right As Material _
) As Boolean
C# public static bool op_Inequality(
Material left,
Material right
);
C++ public:
static bool operator!=(
Material left,
Material right
);
JScript public static function op_Inequality(
left : Material,
right : Material
) : boolean;

Parameters

left Microsoft.DirectX.Direct3D.Material
The Material object to the left of the equality operator.
right Microsoft.DirectX.Direct3D.Material
The Material object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Material.ToString() Method (Microsoft.DirectX.Direct3D)

Material.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Material.Ambient Property (Microsoft.DirectX.Direct3D)

Material.Ambient Property

Retrieves or sets a value that specifies the ambient color.

Definition

Visual Basic | Public Property Ambient As Color
C# | public Color Ambient { get; set; }
C++ public:
property Color Ambient {
Color get();
void set(Color value);
}
JScript public function get Ambient() : Color
public function set Ambient(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the ambient color.

This property is read/write.


Material.AmbientColor Property (Microsoft.DirectX.Direct3D)

Material.AmbientColor Property

Retrieves or sets the ambient ColorValue.

Definition

Visual Basic | Public Property AmbientColor As ColorValue
C# | public ColorValue AmbientColor { get; set; }
C++ public:
property ColorValue AmbientColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get AmbientColor() : ColorValue
public function set AmbientColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure to set or retrieve.

This property is read/write.


Material.Diffuse Property (Microsoft.DirectX.Direct3D)

Material.Diffuse Property

Retrieves or sets a value that specifies the diffuse color.

Definition

Visual Basic | Public Property Diffuse As Color
C# | public Color Diffuse { get; set; }
C++ public:
property Color Diffuse {
Color get();
void set(Color value);
}
JScript public function get Diffuse() : Color
public function set Diffuse(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the diffuse color to set or retrieve.

This property is read/write.


Material.DiffuseColor Property (Microsoft.DirectX.Direct3D)

Material.DiffuseColor Property

Retrieves or sets the diffuse ColorValue.

Definition

Visual Basic | Public Property DiffuseColor As ColorValue
C# | public ColorValue DiffuseColor { get; set; }
C++ public:
property ColorValue DiffuseColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get DiffuseColor() : ColorValue
public function set DiffuseColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure to set or retrieve.

This property is read/write.


Material.Emissive Property (Microsoft.DirectX.Direct3D)

Material.Emissive Property

Retrieves or sets a value that specifies the emissive color.

Definition

Visual Basic | Public Property Emissive As Color
C# | public Color Emissive { get; set; }
C++ public:
property Color Emissive {
Color get();
void set(Color value);
}
JScript public function get Emissive() : Color
public function set Emissive(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the emissive color to set or retrieve.

This property is read/write.


Material.EmissiveColor Property (Microsoft.DirectX.Direct3D)

Material.EmissiveColor Property

Retrieves or sets the emissive ColorValue.

Definition

Visual Basic | Public Property EmissiveColor As ColorValue
C# | public ColorValue EmissiveColor { get; set; }
C++ public:
property ColorValue EmissiveColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get EmissiveColor() : ColorValue
public function set EmissiveColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure to set or retrieve.

This property is read/write.


Material.Specular Property (Microsoft.DirectX.Direct3D)

Material.Specular Property

Retrieves or sets a value that specifies the specular color.

Definition

Visual Basic | Public Property Specular As Color
C# | public Color Specular { get; set; }
C++ public:
property Color Specular {
Color get();
void set(Color value);
}
JScript public function get Specular() : Color
public function set Specular(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the specular color to set or retrieve.

This property is read/write.


Material.SpecularColor Property (Microsoft.DirectX.Direct3D)

Material.SpecularColor Property

Retrieves or sets the specular ColorValue.

Definition

Visual Basic | Public Property SpecularColor As ColorValue
C# | public ColorValue SpecularColor { get; set; }
C++ public:
property ColorValue SpecularColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get SpecularColor() : ColorValue
public function set SpecularColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue structure to set or retrieve.

This property is read/write.


Material.SpecularSharpness Property (Microsoft.DirectX.Direct3D)

Material.SpecularSharpness Property

Retrieves or sets a value that specifies the sharpness of specular highlights.

Definition

Visual Basic | Public Property SpecularSharpness As Single
C# | public float SpecularSharpness { get; set; }
C++ public:
property float SpecularSharpness {
float get();
void set(float value);
}
JScript public function get SpecularSharpness() : float
public function set SpecularSharpness(float);

Property Value

System.Single
Floating-point value that represents the sharpness of specular highlights.

This property is read/write.

Remarks

The higher the value, the sharper the highlight.


MeshData Structure (Microsoft.DirectX.Direct3D)

MeshData Structure

Contains mesh data.

Definition

Visual Basic | Public Structure MeshData
C# | public struct MeshData
C++ | public value class MeshData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
MeshData | Initializes a new instance of the MeshData class.

Properties

Property | Description
Mesh | Retrieves or sets the Mesh contained in the current object.
PatchMesh | Retrieves or sets the PatchMesh contained in the current object.
ProgressiveMesh | Retrieves or sets the ProgressiveMesh contained in the current object.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MeshData.MeshData() Constructor (Microsoft.DirectX.Direct3D)

MeshData.MeshData Constructor

Initializes a new instance of the MeshData class.

Definition

Visual Basic | Public Sub New()
C# | public MeshData();
C++ public:
MeshData();
JScript | public function MeshData();


MeshData.Mesh Property (Microsoft.DirectX.Direct3D)

MeshData.Mesh Property

Retrieves or sets the Mesh contained in the current object.

Definition

Visual Basic | Public Property Mesh As Mesh
C# | public Mesh Mesh { get; set; }
C++ public:
property Mesh^ Mesh {
Mesh^ get();
void set(Mesh^ value);
}
JScript public function get Mesh() : Mesh
public function set Mesh(Mesh);

Property Value

Microsoft.DirectX.Direct3D.Mesh
The Mesh object contained in the current object.

This property is read/write.


MeshData.PatchMesh Property (Microsoft.DirectX.Direct3D)

MeshData.PatchMesh Property

Retrieves or sets the PatchMesh contained in the current object.

Definition

Visual Basic | Public Property PatchMesh As PatchMesh
C# | public PatchMesh PatchMesh { get; set; }
C++ public:
property PatchMesh^ PatchMesh {
PatchMesh^ get();
void set(PatchMesh^ value);
}
JScript public function get PatchMesh() : PatchMesh
public function set PatchMesh(PatchMesh);

Property Value

Microsoft.DirectX.Direct3D.PatchMesh
The PatchMesh object contained in the current object.

This property is read/write.


MeshData.ProgressiveMesh Property (Microsoft.DirectX.Direct3D)

MeshData.ProgressiveMesh Property

Retrieves or sets the ProgressiveMesh contained in the current object.

Definition

Visual Basic | Public Property ProgressiveMesh As ProgressiveMesh
C# | public ProgressiveMesh ProgressiveMesh { get; set; }
C++ public:
property ProgressiveMesh^ ProgressiveMesh {
ProgressiveMesh^ get();
void set(ProgressiveMesh^ value);
}
JScript public function get ProgressiveMesh() : ProgressiveMesh
public function set ProgressiveMesh(ProgressiveMesh);

Property Value

Microsoft.DirectX.Direct3D.ProgressiveMesh
The ProgressiveMesh object contained in the current object.

This property is read/write.


MeshOptions Structure (Microsoft.DirectX.Direct3D)

MeshOptions Structure

Specifies the type of mesh optimization to perform.

Definition

Visual Basic | Public Structure MeshOptions
C# | public struct MeshOptions
C++ | public value class MeshOptions sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
MeshOptions | Initializes a new instance of the MeshOptions class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DoNotClip | Specifies whether Usage.DoNotClip should be used for vertex and index buffers.
Dynamic | Specifies whether Usage.Dynamic should be used for vertex and index buffers.
IndexBufferDynamic | Specifies whether Usage.Dynamic should be used for index buffers.
IndexBufferManaged | Specifies whether Pool.Managed should be used for index buffers.
IndexBufferSoftwareProcessing | Specifies whether Usage.SoftwareProcessing should be used for index buffers.
IndexBufferSystemMem | Specifies whether Pool.SystemMemory should be used for index buffers.
IndexBufferWriteOnly | Specifies whether Usage.WriteOnly should be used for index buffers.
Managed | Specifies whether Pool.Managed should be used for vertex and index buffers.
NPatches | Specifies whether the index and vertex buffers of the mesh should be created with Usage.NPatches.
Points | Specifies whether Usage.Points should be used for index and vertex buffers.
RtPatches | Specifies whether Usage.RTPatches should be used for index and vertex buffers.
SoftwareProcessing | Specifies whether Usage.SoftwareProcessing should be used for vertex and index buffers.
SystemMem | Specifies whether Pool.SystemMemory should be used for vertex and index buffers.
Use32Bit | Specifies whether the mesh uses 32-bit indices instead of 16-bit indices.
Value | Specifies creation options for a mesh.
VertexBufferDynamic | Specifies whether Usage.Dynamic should be used for vertex buffers.
VertexBufferManaged | Specifies whether Pool.Managed should be used for vertex buffers.
VertexBufferSoftwareProcessing | Specifies whether Usage.SoftwareProcessing should be used for vertex buffers.
VertexBufferSystemMem | Specifies whether Pool.SystemMemory should be used for vertex buffers.
VertexBufferWriteOnly | Specifies whether Usage.WriteOnly should be used for vertex buffers.
WriteOnly | Specifies whether Usage.WriteOnly should be used for vertex and index buffers.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MeshOptions.MeshOptions Constructor ()

Initializes a new instance of the MeshOptions class.

Overload List

public MeshOptions();
public MeshOptions(MeshFlags);
public MeshOptions(MeshFlags[]);


MeshOptions.MeshOptions(MeshFlags[]) Constructor (Microsoft.DirectX.Direct3D)

MeshOptions.MeshOptions Constructor

Initializes a new instance of the MeshOptions class.

Definition

Visual Basic Public Sub New( _
ByVal initialFlags() As MeshFlags _
)
C# public MeshOptions(
MeshFlags[] initialFlags
);
C++ public:
MeshOptions(
array<MeshFlags>^ initialFlags
);
JScript public function MeshOptions(
initialFlags : MeshFlags[]
);

Parameters

initialFlags Microsoft.DirectX.Direct3D.MeshFlags[]
Array of MeshFlags objects that specify the mesh creation options.


MeshOptions.MeshOptions(MeshFlags) Constructor (Microsoft.DirectX.Direct3D)

MeshOptions.MeshOptions Constructor

Initializes a new instance of the MeshOptions class.

Definition

Visual Basic Public Sub New( _
ByVal initialFlag As MeshFlags _
)
C# public MeshOptions(
MeshFlags initialFlag
);
C++ public:
MeshOptions(
MeshFlags initialFlag
);
JScript public function MeshOptions(
initialFlag : MeshFlags
);

Parameters

initialFlag Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags object that specifies the mesh creation options.


MeshOptions.MeshOptions() Constructor (Microsoft.DirectX.Direct3D)

MeshOptions.MeshOptions Constructor

Initializes a new instance of the MeshOptions class.

Definition

Visual Basic | Public Sub New()
C# | public MeshOptions();
C++ public:
MeshOptions();
JScript | public function MeshOptions();


MeshOptions.ToString() Method (Microsoft.DirectX.Direct3D)

MeshOptions.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


MeshOptions.DoNotClip Property (Microsoft.DirectX.Direct3D)

MeshOptions.DoNotClip Property

Specifies whether Usage.DoNotClip should be used for vertex and index buffers.

Definition

Visual Basic | Public ReadOnly Property DoNotClip As Boolean
C# | public bool DoNotClip { get; }
C++ public:
property bool DoNotClip {
bool get();
}
JScript | public function get DoNotClip() : boolean

Property Value

System.Boolean
Value that is true if Usage.DoNotClip should be used, or false if it should not.

This property is read-only.


MeshOptions.Dynamic Property (Microsoft.DirectX.Direct3D)

MeshOptions.Dynamic Property

Specifies whether Usage.Dynamic should be used for vertex and index buffers.

Definition

Visual Basic | Public ReadOnly Property Dynamic As Boolean
C# | public bool Dynamic { get; }
C++ public:
property bool Dynamic {
bool get();
}
JScript | public function get Dynamic() : boolean

Property Value

System.Boolean
Value that is true if Usage.Dynamic should be used, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferDynamic and MeshOptions.VertexBufferDynamic.


MeshOptions.IndexBufferDynamic Property (Microsoft.DirectX.Direct3D)

MeshOptions.IndexBufferDynamic Property

Specifies whether Usage.Dynamic should be used for index buffers.

Definition

Visual Basic | Public ReadOnly Property IndexBufferDynamic As Boolean
C# | public bool IndexBufferDynamic { get; }
C++ public:
property bool IndexBufferDynamic {
bool get();
}
JScript | public function get IndexBufferDynamic() : boolean

Property Value

System.Boolean
Value that is true if Usage.Dynamic should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.IndexBufferManaged Property (Microsoft.DirectX.Direct3D)

MeshOptions.IndexBufferManaged Property

Specifies whether Pool.Managed should be used for index buffers.

Definition

Visual Basic | Public ReadOnly Property IndexBufferManaged As Boolean
C# | public bool IndexBufferManaged { get; }
C++ public:
property bool IndexBufferManaged {
bool get();
}
JScript | public function get IndexBufferManaged() : boolean

Property Value

System.Boolean
Value that is true if Pool.Managed should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.IndexBufferSoftwareProcessing Property (Microsoft.DirectX.Direct3D)

MeshOptions.IndexBufferSoftwareProcessing Property

Specifies whether Usage.SoftwareProcessing should be used for index buffers.

Definition

Visual Basic | Public ReadOnly Property IndexBufferSoftwareProcessing As Boolean
C# | public bool IndexBufferSoftwareProcessing { get; }
C++ public:
property bool IndexBufferSoftwareProcessing {
bool get();
}
JScript | public function get IndexBufferSoftwareProcessing() : boolean

Property Value

System.Boolean
Value that is true if Usage.SoftwareProcessing should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.IndexBufferSystemMem Property (Microsoft.DirectX.Direct3D)

MeshOptions.IndexBufferSystemMem Property

Specifies whether Pool.SystemMemory should be used for index buffers.

Definition

Visual Basic | Public ReadOnly Property IndexBufferSystemMem As Boolean
C# | public bool IndexBufferSystemMem { get; }
C++ public:
property bool IndexBufferSystemMem {
bool get();
}
JScript | public function get IndexBufferSystemMem() : boolean

Property Value

System.Boolean
Value that is true if Pool.SystemMemory should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.IndexBufferWriteOnly Property (Microsoft.DirectX.Direct3D)

MeshOptions.IndexBufferWriteOnly Property

Specifies whether Usage.WriteOnly should be used for index buffers.

Definition

Visual Basic | Public ReadOnly Property IndexBufferWriteOnly As Boolean
C# | public bool IndexBufferWriteOnly { get; }
C++ public:
property bool IndexBufferWriteOnly {
bool get();
}
JScript | public function get IndexBufferWriteOnly() : boolean

Property Value

System.Boolean
Value that is true if Usage.WriteOnly should be used for index buffers, or false if it should not.

This property is read-only.


MeshOptions.Managed Property (Microsoft.DirectX.Direct3D)

MeshOptions.Managed Property

Specifies whether Pool.Managed should be used for vertex and index buffers.

Definition

Visual Basic | Public ReadOnly Property Managed As Boolean
C# | public bool Managed { get; }
C++ public:
property bool Managed {
bool get();
}
JScript | public function get Managed() : boolean

Property Value

System.Boolean
Value that is true if Pool.Managed should be used for vertex and index buffers, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferManaged and MeshOptions.VertexBufferManaged.


MeshOptions.NPatches Property (Microsoft.DirectX.Direct3D)

MeshOptions.NPatches Property

Specifies whether the index and vertex buffers of the mesh should be created with Usage.NPatches.

Definition

Visual Basic | Public ReadOnly Property NPatches As Boolean
C# | public bool NPatches { get; }
C++ public:
property bool NPatches {
bool get();
}
JScript | public function get NPatches() : boolean

Property Value

System.Boolean
Value that is true if Usage.NPatches should be used, or false if it should not.

This property is read-only.

Remarks

This property is required if the mesh object is rendered with N-patch enhancement using Microsoft Direct3D.


MeshOptions.Points Property (Microsoft.DirectX.Direct3D)

MeshOptions.Points Property

Specifies whether Usage.Points should be used for index and vertex buffers.

Definition

Visual Basic | Public ReadOnly Property Points As Boolean
C# | public bool Points { get; }
C++ public:
property bool Points {
bool get();
}
JScript | public function get Points() : boolean

Property Value

System.Boolean
Value that is true if Usage.Points should be used for index and vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.RtPatches Property (Microsoft.DirectX.Direct3D)

MeshOptions.RtPatches Property

Specifies whether Usage.RTPatches should be used for index and vertex buffers.

Definition

Visual Basic | Public ReadOnly Property RtPatches As Boolean
C# | public bool RtPatches { get; }
C++ public:
property bool RtPatches {
bool get();
}
JScript | public function get RtPatches() : boolean

Property Value

System.Boolean
Value that is true if Usage.RTPatches should be used for index and vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.SoftwareProcessing Property (Microsoft.DirectX.Direct3D)

MeshOptions.SoftwareProcessing Property

Specifies whether Usage.SoftwareProcessing should be used for vertex and index buffers.

Definition

Visual Basic | Public ReadOnly Property SoftwareProcessing As Boolean
C# | public bool SoftwareProcessing { get; }
C++ public:
property bool SoftwareProcessing {
bool get();
}
JScript | public function get SoftwareProcessing() : boolean

Property Value

System.Boolean
Value that is true if Usage.SoftwareProcessing should be used, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferSoftwareProcessing and MeshOptions.VertexBufferSoftwareProcessing.


MeshOptions.SystemMem Property (Microsoft.DirectX.Direct3D)

MeshOptions.SystemMem Property

Specifies whether Pool.SystemMemory should be used for vertex and index buffers.

Definition

Visual Basic | Public ReadOnly Property SystemMem As Boolean
C# | public bool SystemMem { get; }
C++ public:
property bool SystemMem {
bool get();
}
JScript | public function get SystemMem() : boolean

Property Value

System.Boolean
Value that is true if Pool.SystemMemory should be used, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferSystemMemory and MeshOptions.VertexBufferSystemMemory.


MeshOptions.Use32Bit Property (Microsoft.DirectX.Direct3D)

MeshOptions.Use32Bit Property

Specifies whether the mesh uses 32-bit indices instead of 16-bit indices.

Definition

Visual Basic | Public ReadOnly Property Use32Bit As Boolean
C# | public bool Use32Bit { get; }
C++ public:
property bool Use32Bit {
bool get();
}
JScript | public function get Use32Bit() : boolean

Property Value

System.Boolean
Value that is true if the mesh uses 32-bit indices, or false if it uses 16-bit indices.

This property is read-only.


MeshOptions.Value Property (Microsoft.DirectX.Direct3D)

MeshOptions.Value Property

Specifies creation options for a mesh.

Definition

Visual Basic | Public Property Value As MeshFlags
C# | public MeshFlags Value { get; set; }
C++ public:
property MeshFlags Value {
MeshFlags get();
void set(MeshFlags value);
}
JScript public function get Value() : MeshFlags
public function set Value(MeshFlags);

Property Value

Microsoft.DirectX.Direct3D.MeshFlags
One or more values of the MeshFlags enumeration to set or retrieve.

This property is read/write.


MeshOptions.VertexBufferDynamic Property (Microsoft.DirectX.Direct3D)

MeshOptions.VertexBufferDynamic Property

Specifies whether Usage.Dynamic should be used for vertex buffers.

Definition

Visual Basic | Public ReadOnly Property VertexBufferDynamic As Boolean
C# | public bool VertexBufferDynamic { get; }
C++ public:
property bool VertexBufferDynamic {
bool get();
}
JScript | public function get VertexBufferDynamic() : boolean

Property Value

System.Boolean
Value that is true if Usage.Dynamic should be used, or false if it should not.

This property is read-only.


MeshOptions.VertexBufferManaged Property (Microsoft.DirectX.Direct3D)

MeshOptions.VertexBufferManaged Property

Specifies whether Pool.Managed should be used for vertex buffers.

Definition

Visual Basic | Public ReadOnly Property VertexBufferManaged As Boolean
C# | public bool VertexBufferManaged { get; }
C++ public:
property bool VertexBufferManaged {
bool get();
}
JScript | public function get VertexBufferManaged() : boolean

Property Value

System.Boolean
Value that is true if Pool.Managed should be used for vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.VertexBufferSoftwareProcessing Property (Microsoft.DirectX.Direct3D)

MeshOptions.VertexBufferSoftwareProcessing Property

Specifies whether Usage.SoftwareProcessing should be used for vertex buffers.

Definition

Visual Basic | Public ReadOnly Property VertexBufferSoftwareProcessing As Boolean
C# | public bool VertexBufferSoftwareProcessing { get; }
C++ public:
property bool VertexBufferSoftwareProcessing {
bool get();
}
JScript | public function get VertexBufferSoftwareProcessing() : boolean

Property Value

System.Boolean
Value that is true if Usage.SoftwareProcessing should be used for vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.VertexBufferSystemMem Property (Microsoft.DirectX.Direct3D)

MeshOptions.VertexBufferSystemMem Property

Specifies whether Pool.SystemMemory should be used for vertex buffers.

Definition

Visual Basic | Public ReadOnly Property VertexBufferSystemMem As Boolean
C# | public bool VertexBufferSystemMem { get; }
C++ public:
property bool VertexBufferSystemMem {
bool get();
}
JScript | public function get VertexBufferSystemMem() : boolean

Property Value

System.Boolean
Value that is true if Pool.SystemMemory should be used for vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.VertexBufferWriteOnly Property (Microsoft.DirectX.Direct3D)

MeshOptions.VertexBufferWriteOnly Property

Specifies whether Usage.WriteOnly should be used for vertex buffers.

Definition

Visual Basic | Public ReadOnly Property VertexBufferWriteOnly As Boolean
C# | public bool VertexBufferWriteOnly { get; }
C++ public:
property bool VertexBufferWriteOnly {
bool get();
}
JScript | public function get VertexBufferWriteOnly() : boolean

Property Value

System.Boolean
Value that is true if Usage.WriteOnly should be used for vertex buffers, or false if it should not.

This property is read-only.


MeshOptions.WriteOnly Property (Microsoft.DirectX.Direct3D)

MeshOptions.WriteOnly Property

Specifies whether Usage.WriteOnly should be used for vertex and index buffers.

Definition

Visual Basic | Public ReadOnly Property WriteOnly As Boolean
C# | public bool WriteOnly { get; }
C++ public:
property bool WriteOnly {
bool get();
}
JScript | public function get WriteOnly() : boolean

Property Value

System.Boolean
Value that is true if Usage.WriteOnly should be used, or false if it should not.

This property is read-only.

Remarks

This property is equivalent to specifying both MeshOptions.IndexBufferWriteOnly and MeshOptions.VertexBufferWriteOnly.


MiscCaps Structure (Microsoft.DirectX.Direct3D)

MiscCaps Structure

Contains miscellaneous driver primitive capabilities.

Definition

Visual Basic | Public Structure MiscCaps
C# | public struct MiscCaps
C++ | public value class MiscCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
HasFogVertexClamped | Specifies whether the device clamps the fog blend factor per vertex.
IsNullReference | Specifies whether the device is a reference device that does not render.
SupportsBlendOperation | Specifies whether the device supports alpha blend operations other than BlendOperation.Add.
SupportsClipPlaneScaledPoints | Specifies whether the device correctly clips scaled points (that is, those whose size is greater than 1.0) to user-defined clipping planes.
SupportsClipTransformedVertices | Specifies whether the device clips post-transformed vertex primitives.
SupportsColorWrite | Specifies whether the device supports per-channel writes for the render target color buffer.
SupportsCullClockwise | Specifies whether the driver supports clockwise triangle culling through RenderStateManager.CullMode.
SupportsCullCounterClockwise | Specifies whether the driver supports counterclockwise triangle culling through RenderStateManager.CullMode.
SupportsCullNone | Specifies whether the driver does not perform triangle culling.
SupportsFogAndSpecularAlpha | Specifies whether the device supports separate fog and specular alpha.
SupportsIndependentWriteMasks | Specifies whether the device supports independent write masks for multiple element textures or multiple render targets.
SupportsMaskZ | Specifies whether the device can enable and disable modification of the depth buffer on pixel operations.
SupportsMultipleRenderTargetsIndependentBitDepths | Specifies whether the device supports independent bit depths for multiple render targets.
SupportsMultipleRenderTargetsPostPixelShaderBlending | Specifies whether the device supports multiple render targets after pixel shader blending.
SupportsPerStageConstant | Specifies whether the device supports per-stage constants.
SupportsSeparateAlphaBlend | Specifies whether the device supports separate alpha blending.
SupportsTextureStageStateArgumentTemp | Specifies whether the device supports TextureArgument for temporary registers.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MiscCaps.ToString() Method (Microsoft.DirectX.Direct3D)

MiscCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


MiscCaps.HasFogVertexClamped Property (Microsoft.DirectX.Direct3D)

MiscCaps.HasFogVertexClamped Property

Specifies whether the device clamps the fog blend factor per vertex.

Definition

Visual Basic | Public ReadOnly Property HasFogVertexClamped As Boolean
C# | public bool HasFogVertexClamped { get; }
C++ public:
property bool HasFogVertexClamped {
bool get();
}
JScript | public function get HasFogVertexClamped() : boolean

Property Value

System.Boolean
Value that is true if the device clamps vertex fog, or false if it does not.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


MiscCaps.IsNullReference Property (Microsoft.DirectX.Direct3D)

MiscCaps.IsNullReference Property

Specifies whether the device is a reference device that does not render.

Definition

Visual Basic | Public ReadOnly Property IsNullReference As Boolean
C# | public bool IsNullReference { get; }
C++ public:
property bool IsNullReference {
bool get();
}
JScript | public function get IsNullReference() : boolean

Property Value

System.Boolean
Value that is true if the device is a reference device that does not render, or false otherwise.

This property is read-only.


MiscCaps.SupportsBlendOperation Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsBlendOperation Property

Specifies whether the device supports alpha blend operations other than BlendOperation.Add.

Definition

Visual Basic | Public ReadOnly Property SupportsBlendOperation As Boolean
C# | public bool SupportsBlendOperation { get; }
C++ public:
property bool SupportsBlendOperation {
bool get();
}
JScript | public function get SupportsBlendOperation() : boolean

Property Value

System.Boolean
Value that is true if the device supports other alpha blending operations, or false if it does not.

This property is read-only.


MiscCaps.SupportsClipPlaneScaledPoints Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsClipPlaneScaledPoints Property

Specifies whether the device correctly clips scaled points (that is, those whose size is greater than 1.0) to user-defined clipping planes.

Definition

Visual Basic | Public ReadOnly Property SupportsClipPlaneScaledPoints As Boolean
C# | public bool SupportsClipPlaneScaledPoints { get; }
C++ public:
property bool SupportsClipPlaneScaledPoints {
bool get();
}
JScript | public function get SupportsClipPlaneScaledPoints() : boolean

Property Value

System.Boolean
Value that is true if the device correctly clips scaled points, or false if it does not.

This property is read-only.


MiscCaps.SupportsClipTransformedVertices Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsClipTransformedVertices Property

Specifies whether the device clips post-transformed vertex primitives.

Definition

Visual Basic | Public ReadOnly Property SupportsClipTransformedVertices As Boolean
C# | public bool SupportsClipTransformedVertices { get; }
C++ public:
property bool SupportsClipTransformedVertices {
bool get();
}
JScript | public function get SupportsClipTransformedVertices() : boolean

Property Value

System.Boolean
Value that is true if the device clips post-transformed vertex primitives, or false if it does not.

This property is read-only.


MiscCaps.SupportsColorWrite Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsColorWrite Property

Specifies whether the device supports per-channel writes for the render target color buffer.

Definition

Visual Basic | Public ReadOnly Property SupportsColorWrite As Boolean
C# | public bool SupportsColorWrite { get; }
C++ public:
property bool SupportsColorWrite {
bool get();
}
JScript | public function get SupportsColorWrite() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-channel writes for the render-target color buffer, or false if it does not.

This property is read-only.


MiscCaps.SupportsCullClockwise Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsCullClockwise Property

Specifies whether the driver supports clockwise triangle culling through RenderStateManager.CullMode.

Definition

Visual Basic | Public ReadOnly Property SupportsCullClockwise As Boolean
C# | public bool SupportsCullClockwise { get; }
C++ public:
property bool SupportsCullClockwise {
bool get();
}
JScript | public function get SupportsCullClockwise() : boolean

Property Value

System.Boolean
Value that is true if the driver supports clockwise triangle culling, or false if it does not.

This property is read-only.


MiscCaps.SupportsCullCounterClockwise Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsCullCounterClockwise Property

Specifies whether the driver supports counterclockwise triangle culling through RenderStateManager.CullMode.

Definition

Visual Basic | Public ReadOnly Property SupportsCullCounterClockwise As Boolean
C# | public bool SupportsCullCounterClockwise { get; }
C++ public:
property bool SupportsCullCounterClockwise {
bool get();
}
JScript | public function get SupportsCullCounterClockwise() : boolean

Property Value

System.Boolean
Value that is true if the driver supports counterclockwise triangle culling, or false if it does not.

This property is read-only.


MiscCaps.SupportsCullNone Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsCullNone Property

Specifies whether the driver does not perform triangle culling.

Definition

Visual Basic | Public ReadOnly Property SupportsCullNone As Boolean
C# | public bool SupportsCullNone { get; }
C++ public:
property bool SupportsCullNone {
bool get();
}
JScript | public function get SupportsCullNone() : boolean

Property Value

System.Boolean
Value that is true if the driver does not perform triangle culling, or false if it does.

This property is read-only.


MiscCaps.SupportsFogAndSpecularAlpha Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsFogAndSpecularAlpha Property

Specifies whether the device supports separate fog and specular alpha.

Definition

Visual Basic | Public ReadOnly Property SupportsFogAndSpecularAlpha As Boolean
C# | public bool SupportsFogAndSpecularAlpha { get; }
C++ public:
property bool SupportsFogAndSpecularAlpha {
bool get();
}
JScript | public function get SupportsFogAndSpecularAlpha() : boolean

Property Value

System.Boolean
Value that is true if the device supports separate fog and specular alpha, or false if it does not.

This property is read-only.

Remarks

Many devices use the specular alpha channel to store the fog factor.


MiscCaps.SupportsIndependentWriteMasks Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsIndependentWriteMasks Property

Specifies whether the device supports independent write masks for multiple element textures or multiple render targets.

Definition

Visual Basic | Public ReadOnly Property SupportsIndependentWriteMasks As Boolean
C# | public bool SupportsIndependentWriteMasks { get; }
C++ public:
property bool SupportsIndependentWriteMasks {
bool get();
}
JScript | public function get SupportsIndependentWriteMasks() : boolean

Property Value

System.Boolean
Value that is true if the device supports independent write masks, or false if it does not.

This property is read-only.


MiscCaps.SupportsMaskZ Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsMaskZ Property

Specifies whether the device can enable and disable modification of the depth buffer on pixel operations.

Definition

Visual Basic | Public ReadOnly Property SupportsMaskZ As Boolean
C# | public bool SupportsMaskZ { get; }
C++ public:
property bool SupportsMaskZ {
bool get();
}
JScript | public function get SupportsMaskZ() : boolean

Property Value

System.Boolean
Value that is true if the device can enable and disable modification of the depth buffer, or false if it cannot.

This property is read-only.


MiscCaps.SupportsMultipleRenderTargetsIndependentBitDepths Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsMultipleRenderTargetsIndependentBitDepths Property

Language:

Specifies whether the device supports independent bit depths for multiple render targets.

Definition

Visual Basic | Public ReadOnly Property SupportsMultipleRenderTargetsIndependentBitDepths As Boolean
C# | public bool SupportsMultipleRenderTargetsIndependentBitDepths { get; }
C++ public:
property bool SupportsMultipleRenderTargetsIndependentBitDepths {
bool get();
}
JScript | public function get SupportsMultipleRenderTargetsIndependentBitDepths() : boolean

Property Value

System.Boolean
Value that is true if the device supports independent bit depths, or false if it does not.

This property is read-only.


MiscCaps.SupportsMultipleRenderTargetsPostPixelShaderBlending Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsMultipleRenderTargetsPostPixelShaderBlending Property

Language:

Specifies whether the device supports multiple render targets after pixel shader blending.

Definition

Visual Basic | Public ReadOnly Property SupportsMultipleRenderTargetsPostPixelShaderBlending As Boolean
C# | public bool SupportsMultipleRenderTargetsPostPixelShaderBlending { get; }
C++ public:
property bool SupportsMultipleRenderTargetsPostPixelShaderBlending {
bool get();
}
JScript | public function get SupportsMultipleRenderTargetsPostPixelShaderBlending() : boolean

Property Value

System.Boolean
Value that is true if the device supports multiple render targets after pixel shader blending, or false if it does not.

This property is read-only.


MiscCaps.SupportsPerStageConstant Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsPerStageConstant Property

Specifies whether the device supports per-stage constants.

Definition

Visual Basic | Public ReadOnly Property SupportsPerStageConstant As Boolean
C# | public bool SupportsPerStageConstant { get; }
C++ public:
property bool SupportsPerStageConstant {
bool get();
}
JScript | public function get SupportsPerStageConstant() : boolean

Property Value

System.Boolean
Value that is true if the device supports per-stage constants, or false if it does not.

This property is read-only.


MiscCaps.SupportsSeparateAlphaBlend Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsSeparateAlphaBlend Property

Specifies whether the device supports separate alpha blending.

Definition

Visual Basic | Public ReadOnly Property SupportsSeparateAlphaBlend As Boolean
C# | public bool SupportsSeparateAlphaBlend { get; }
C++ public:
property bool SupportsSeparateAlphaBlend {
bool get();
}
JScript | public function get SupportsSeparateAlphaBlend() : boolean

Property Value

System.Boolean
Value that is true if the device supports separate alpha blending, or false if it does not.

This property is read-only.


MiscCaps.SupportsTextureStageStateArgumentTemp Property (Microsoft.DirectX.Direct3D)

MiscCaps.SupportsTextureStageStateArgumentTemp Property

Specifies whether the device supports TextureArgument for temporary registers.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureStageStateArgumentTemp As Boolean
C# | public bool SupportsTextureStageStateArgumentTemp { get; }
C++ public:
property bool SupportsTextureStageStateArgumentTemp {
bool get();
}
JScript | public function get SupportsTextureStageStateArgumentTemp() : boolean

Property Value

System.Boolean
Value that is true if the device supports TextureArgument for temporary registers, or false if it does not.

This property is read-only.


MyD3DXAllocateHierarchy Structure (Microsoft.DirectX.Direct3D)

MyD3DXAllocateHierarchy Structure

Not supported.

Definition

Visual Basic | Public Structure MyD3DXAllocateHierarchy
C# | public struct MyD3DXAllocateHierarchy
C++ | public value class MyD3DXAllocateHierarchy sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MyD3DXAnimationCallback Structure (Microsoft.DirectX.Direct3D)

MyD3DXAnimationCallback Structure

Not supported.

Definition

Visual Basic | Public Structure MyD3DXAnimationCallback
C# | public struct MyD3DXAnimationCallback
C++ | public value class MyD3DXAnimationCallback sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MyD3DXFrame Structure (Microsoft.DirectX.Direct3D)

MyD3DXFrame Structure

Not supported.

Definition

Visual Basic | Public Structure MyD3DXFrame
C# | public struct MyD3DXFrame
C++ | public value class MyD3DXFrame sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MyD3DXIncludeClass Structure (Microsoft.DirectX.Direct3D)

MyD3DXIncludeClass Structure

Not supported.

Definition

Visual Basic | Public Structure MyD3DXIncludeClass
C# | public struct MyD3DXIncludeClass
C++ | public value class MyD3DXIncludeClass sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MyD3DXLoadUserData Structure (Microsoft.DirectX.Direct3D)

MyD3DXLoadUserData Structure

Not supported.

Definition

Visual Basic | Public Structure MyD3DXLoadUserData
C# | public struct MyD3DXLoadUserData
C++ | public value class MyD3DXLoadUserData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MyD3DXMeshContainer Structure (Microsoft.DirectX.Direct3D)

MyD3DXMeshContainer Structure

Not supported.

Definition

Visual Basic | Public Structure MyD3DXMeshContainer
C# | public struct MyD3DXMeshContainer
C++ | public value class MyD3DXMeshContainer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MyD3DXSaveUserData Structure (Microsoft.DirectX.Direct3D)

MyD3DXSaveUserData Structure

Not supported.

Definition

Visual Basic | Public Structure MyD3DXSaveUserData
C# | public struct MyD3DXSaveUserData
C++ | public value class MyD3DXSaveUserData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PaletteEntry Structure (Microsoft.DirectX.Direct3D)

PaletteEntry Structure

Specifies the color and usage of an entry in a logical palette.

Definition

Visual Basic | Public Structure PaletteEntry
C# | public struct PaletteEntry
C++ | public value class PaletteEntry sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PaletteEntry | Initializes a new instance of the PaletteEntry class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Blue | Retrieves or sets the blue intensity value for the palette entry.
Flags | Retrieves or sets the alpha intensity value for the palette entry.
Green | Retrieves or sets the green intensity value for the palette entry.
Red | Retrieves or sets the red intensity value for the palette entry.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PaletteEntry.PaletteEntry Constructor ()

Initializes a new instance of the PaletteEntry class.

Overload List

public PaletteEntry();
public PaletteEntry(byte, byte, byte, byte);


PaletteEntry.PaletteEntry() Constructor (Microsoft.DirectX.Direct3D)

PaletteEntry.PaletteEntry Constructor

Initializes a new instance of the PaletteEntry class.

Definition

Visual Basic | Public Sub New()
C# | public PaletteEntry();
C++ public:
PaletteEntry();
JScript | public function PaletteEntry();


PaletteEntry.PaletteEntry(Byte,Byte,Byte,Byte) Constructor (Microsoft.DirectX.Direct3D)

PaletteEntry.PaletteEntry Constructor

Initializes a new instance of the PaletteEntry class.

Definition

Visual Basic Public Sub New( _
ByVal red As Byte, _
ByVal green As Byte, _
ByVal blue As Byte, _
ByVal flags As Byte _
)
C# public PaletteEntry(
byte red,
byte green,
byte blue,
byte flags
);
C++ public:
PaletteEntry(
unsigned char red,
unsigned char green,
unsigned char blue,
unsigned char flags
);
JScript public function PaletteEntry(
red : byte,
green : byte,
blue : byte,
flags : byte
);

Parameters

red System.Byte
Red intensity value for the palette entry.
green System.Byte
Green intensity value for the palette entry.
blue System.Byte
Blue intensity value for the palette entry.
flags System.Byte
Alpha intensity value for the palette entry.


PaletteEntry.ToString() Method (Microsoft.DirectX.Direct3D)

PaletteEntry.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PaletteEntry.Blue Property (Microsoft.DirectX.Direct3D)

PaletteEntry.Blue Property

Retrieves or sets the blue intensity value for the palette entry.

Definition

Visual Basic | Public Property Blue As Byte
C# | public byte Blue { get; set; }
C++ public:
property unsigned char Blue {
unsigned char get();
void set(unsigned char value);
}
JScript public function get Blue() : byte
public function set Blue(byte);

Property Value

System.Byte
A Byte Leave Site value that represents the blue intensity for the palette entry.

This property is read/write.


PaletteEntry.Flags Property (Microsoft.DirectX.Direct3D)

PaletteEntry.Flags Property

Retrieves or sets the alpha intensity value for the palette entry.

Definition

Visual Basic | Public Property Flags As Byte
C# | public byte Flags { get; set; }
C++ public:
property unsigned char Flags {
unsigned char get();
void set(unsigned char value);
}
JScript public function get Flags() : byte
public function set Flags(byte);

Property Value

System.Byte
A Byte Leave Site value that represents the alpha intensity for the palette entry.

This property is read/write.


PaletteEntry.Green Property (Microsoft.DirectX.Direct3D)

PaletteEntry.Green Property

Retrieves or sets the green intensity value for the palette entry.

Definition

Visual Basic | Public Property Green As Byte
C# | public byte Green { get; set; }
C++ public:
property unsigned char Green {
unsigned char get();
void set(unsigned char value);
}
JScript public function get Green() : byte
public function set Green(byte);

Property Value

System.Byte
A Byte Leave Site value that represents the green intensity for the palette entry.

This property is read/write.


PaletteEntry.Red Property (Microsoft.DirectX.Direct3D)

PaletteEntry.Red Property

Retrieves or sets the red intensity value for the palette entry.

Definition

Visual Basic | Public Property Red As Byte
C# | public byte Red { get; set; }
C++ public:
property unsigned char Red {
unsigned char get();
void set(unsigned char value);
}
JScript public function get Red() : byte
public function set Red(byte);

Property Value

System.Byte
A Byte Leave Site value that represents the red intensity for the palette entry.

This property is read/write.


ParameterDescription Structure (Microsoft.DirectX.Direct3D)

ParameterDescription Structure

Describes a parameter that is used for an effect object.

Definition

Visual Basic | Public Structure ParameterDescription
C# | public struct ParameterDescription
C++ | public value class ParameterDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ParameterDescription | Initializes a new instance of the ParameterDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Annotations | Retrieves the number of annotations for the parameter description.
Bytes | Contains the size of the parameter in bytes.
Class | Retrieves the parameter class, which is one of the values in the ParameterClass enumeration.
Columns | Retrieves the number of columns in the array.
Elements | Retrieves the number of elements in the array.
Flags | Retrieves the parameter attributes.
Name | Retrieves the name of the parameter.
Rows | Retrieves the number of rows in the array.
Semantic | Retrieves the semantic meaning, also called the usage.
StructMembers | Retrieves the number of structure members.
Type | Retrieves the parameter type, which is one of the values in the ParameterType enumeration.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ParameterDescription.ParameterDescription() Constructor (Microsoft.DirectX.Direct3D)

ParameterDescription.ParameterDescription Constructor

Initializes a new instance of the ParameterDescription class.

Definition

Visual Basic | Public Sub New()
C# | public ParameterDescription();
C++ public:
ParameterDescription();
JScript | public function ParameterDescription();


ParameterDescription.ToString() Method (Microsoft.DirectX.Direct3D)

ParameterDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ParameterDescription.Annotations Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Annotations Property

Retrieves the number of annotations for the parameter description.

Definition

Visual Basic | Public ReadOnly Property Annotations As Integer
C# | public int Annotations { get; }
C++ public:
property int Annotations {
int get();
}
JScript | public function get Annotations() : int

Property Value

System.Int32
Integer that represents the number of annotations.

This property is read-only.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.


ParameterDescription.Bytes Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Bytes Property

Contains the size of the parameter in bytes.

Definition

Visual Basic | Public ReadOnly Property Bytes As Integer
C# | public int Bytes { get; }
C++ public:
property int Bytes {
int get();
}
JScript | public function get Bytes() : int

Property Value

System.Int32
Integer that represents the size of the parameter in bytes.

This property is read-only.


ParameterDescription.Class Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Class Property

Retrieves the parameter class, which is one of the values in the ParameterClass enumeration.

Definition

Visual Basic | Public ReadOnly Property Class As ParameterClass
C# | public ParameterClass Class { get; }
C++ public:
property ParameterClass Class {
ParameterClass get();
}
JScript | public function get Class() : ParameterClass

Property Value

Microsoft.DirectX.Direct3D.ParameterClass
Value of the ParameterClass enumeration to retrieve.

This property is read-only.


ParameterDescription.Columns Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Columns Property

Retrieves the number of columns in the array.

Definition

Visual Basic | Public ReadOnly Property Columns As Integer
C# | public int Columns { get; }
C++ public:
property int Columns {
int get();
}
JScript | public function get Columns() : int

Property Value

System.Int32
Integer that represents the number of columns in the array.

This property is read-only.


ParameterDescription.Elements Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Elements Property

Retrieves the number of elements in the array.

Definition

Visual Basic | Public ReadOnly Property Elements As Integer
C# | public int Elements { get; }
C++ public:
property int Elements {
int get();
}
JScript | public function get Elements() : int

Property Value

System.Int32
Integer that represents the number of elements in the array.

This property is read-only.


ParameterDescription.Flags Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Flags Property

Retrieves the parameter attributes.

Definition

Visual Basic | Public ReadOnly Property Flags As ParameterFlags
C# | public ParameterFlags Flags { get; }
C++ public:
property ParameterFlags Flags {
ParameterFlags get();
}
JScript | public function get Flags() : ParameterFlags

Property Value

Microsoft.DirectX.Direct3D.ParameterFlags

This property is read-only.


ParameterDescription.Name Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Name Property

Retrieves the name of the parameter.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
String that contains the parameter name.

This property is read-only.


ParameterDescription.Rows Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Rows Property

Retrieves the number of rows in the array.

Definition

Visual Basic | Public ReadOnly Property Rows As Integer
C# | public int Rows { get; }
C++ public:
property int Rows {
int get();
}
JScript | public function get Rows() : int

Property Value

System.Int32
Integer that represents the number of rows in the array.

This property is read-only.


ParameterDescription.Semantic Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Semantic Property

Retrieves the semantic meaning, also called the usage.

Definition

Visual Basic | Public ReadOnly Property Semantic As String
C# | public string Semantic { get; }
C++ public:
property String^ Semantic {
String^ get();
}
JScript | public function get Semantic() : String

Property Value

System.String
String that contains the semantic meaning.

This property is read-only.


ParameterDescription.StructMembers Property (Microsoft.DirectX.Direct3D)

ParameterDescription.StructMembers Property

Retrieves the number of structure members.

Definition

Visual Basic | Public ReadOnly Property StructMembers As Integer
C# | public int StructMembers { get; }
C++ public:
property int StructMembers {
int get();
}
JScript | public function get StructMembers() : int

Property Value

System.Int32
Integer that represents the number of structure members.

This property is read-only.


ParameterDescription.Type Property (Microsoft.DirectX.Direct3D)

ParameterDescription.Type Property

Retrieves the parameter type, which is one of the values in the ParameterType enumeration.

Definition

Visual Basic | Public ReadOnly Property Type As ParameterType
C# | public ParameterType Type { get; }
C++ public:
property ParameterType Type {
ParameterType get();
}
JScript | public function get Type() : ParameterType

Property Value

Microsoft.DirectX.Direct3D.ParameterType
Value of the ParameterType enumeration to retrieve.

This property is read-only.


PassDescription Structure (Microsoft.DirectX.Direct3D)

PassDescription Structure

Describes a pass for an effect object.

Definition

Visual Basic | Public Structure PassDescription
C# | public struct PassDescription
C++ | public value class PassDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PassDescription | Initializes a new instance of the PassDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Annotations | Retrieves the number of annotations for the current pass description.
Name | Retrieves the name used for the pass.
PixelShaderFunction | Retrieves a GraphicsStream object that contains the pixel shader function.
VertexShaderFunction | Retrieves a GraphicsStream object that contains the vertex shader function.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PassDescription.PassDescription() Constructor (Microsoft.DirectX.Direct3D)

PassDescription.PassDescription Constructor

Initializes a new instance of the PassDescription class.

Definition

Visual Basic | Public Sub New()
C# | public PassDescription();
C++ public:
PassDescription();
JScript | public function PassDescription();


PassDescription.ToString() Method (Microsoft.DirectX.Direct3D)

PassDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PassDescription.Annotations Property (Microsoft.DirectX.Direct3D)

PassDescription.Annotations Property

Retrieves the number of annotations for the current pass description.

Definition

Visual Basic | Public ReadOnly Property Annotations As Integer
C# | public int Annotations { get; }
C++ public:
property int Annotations {
int get();
}
JScript | public function get Annotations() : int

Property Value

System.Int32
Integer that represents the number of annotations to retrieve.

This property is read-only.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.


PassDescription.Name Property (Microsoft.DirectX.Direct3D)

PassDescription.Name Property

Retrieves the name used for the pass.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
String that represents the pass name.

This property is read-only.


PassDescription.PixelShaderFunction Property (Microsoft.DirectX.Direct3D)

PassDescription.PixelShaderFunction Property

Retrieves a GraphicsStream object that contains the pixel shader function.

Definition

Visual Basic | Public ReadOnly Property PixelShaderFunction As GraphicsStream
C# | public GraphicsStream PixelShaderFunction { get; }
C++ public:
property GraphicsStream^ PixelShaderFunction {
GraphicsStream^ get();
}
JScript | public function get PixelShaderFunction() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the pixel shader function to retrieve.

This property is read-only.


PassDescription.VertexShaderFunction Property (Microsoft.DirectX.Direct3D)

PassDescription.VertexShaderFunction Property

Retrieves a GraphicsStream object that contains the vertex shader function.

Definition

Visual Basic | Public ReadOnly Property VertexShaderFunction As GraphicsStream
C# | public GraphicsStream VertexShaderFunction { get; }
C++ public:
property GraphicsStream^ VertexShaderFunction {
GraphicsStream^ get();
}
JScript | public function get VertexShaderFunction() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the vertex shader function to retrieve.

This property is read-only.


PatchInformation Structure (Microsoft.DirectX.Direct3D)

PatchInformation Structure

Contains the attributes of a patch mesh.

Definition

Visual Basic | Public Structure PatchInformation
C# | public struct PatchInformation
C++ | public value class PatchInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PatchInformation | Initializes a new instance of the PatchInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BasisType | Retrieves or sets the type of curve used to construct the patch.
Degree | Retrieves or sets the degree of the curves used to construct the patch.
PatchType | Retrieves or sets the patch type.
TessellateLevel | Retrieves or sets the tessellation level.

Remarks

A mesh is a set of faces, each of which is described by a simple polygon. Objects can be created by connecting several meshes together. A patch mesh is made up of patches, which are four-sided pieces of geometry that are constructed from curves. The type of curve used and the curve's order can be varied so that the patch surface fits almost any surface shape.

The following types of patch combinations are supported.

Patch Type | Basis | Degree
Rectangle | Bezier | 2,3,5
Rectangle | B-spline | 2,3,5
Rectangle | Catmull-Rom | 3
Triangle | Bezier | 2,3,5
N-patch | N/A | 3

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PatchInformation.PatchInformation() Constructor (Microsoft.DirectX.Direct3D)

PatchInformation.PatchInformation Constructor

Initializes a new instance of the PatchInformation class.

Definition

Visual Basic | Public Sub New()
C# | public PatchInformation();
C++ public:
PatchInformation();
JScript | public function PatchInformation();


PatchInformation.ToString() Method (Microsoft.DirectX.Direct3D)

PatchInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PatchInformation.BasisType Property (Microsoft.DirectX.Direct3D)

PatchInformation.BasisType Property

Retrieves or sets the type of curve used to construct the patch.

Definition

Visual Basic | Public Property BasisType As BasisType
C# | public BasisType BasisType { get; set; }
C++ public:
property BasisType BasisType {
BasisType get();
void set(BasisType value);
}
JScript public function get BasisType() : BasisType
public function set BasisType(BasisType);

Property Value

Microsoft.DirectX.Direct3D.BasisType
Value of the BasisType enumeration to set or retrieve.

This property is read/write.


PatchInformation.Degree Property (Microsoft.DirectX.Direct3D)

PatchInformation.Degree Property

Retrieves or sets the degree of the curves used to construct the patch.

Definition

Visual Basic | Public Property Degree As DegreeType
C# | public DegreeType Degree { get; set; }
C++ public:
property DegreeType Degree {
DegreeType get();
void set(DegreeType value);
}
JScript public function get Degree() : DegreeType
public function set Degree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType
Value of the DegreeType enumeration to set or retrieve.

This property is read/write.


PatchInformation.PatchType Property (Microsoft.DirectX.Direct3D)

PatchInformation.PatchType Property

Retrieves or sets the patch type.

Definition

Visual Basic | Public Property PatchType As PatchType
C# | public PatchType PatchType { get; set; }
C++ public:
property PatchType PatchType {
PatchType get();
void set(PatchType value);
}
JScript public function get PatchType() : PatchType
public function set PatchType(PatchType);

Property Value

Microsoft.DirectX.Direct3D.PatchType
Value of the PatchType enumeration to set or retrieve.

This property is read/write.


PatchInformation.TessellateLevel Property (Microsoft.DirectX.Direct3D)

PatchInformation.TessellateLevel Property

Retrieves or sets the tessellation level.

Definition

Visual Basic | Public Property TessellateLevel As Single()
C# | public float[] TessellateLevel { get; set; }
C++ public:
property array<float>^ TessellateLevel {
array<float>^ get();
void set(array<float>^ value);
}
JScript public function get TessellateLevel() : float[]
public function set TessellateLevel(float[]);

Property Value

System.Single[]
Array of four floating-point values that represent the tessellation level to set or retrieve.

This property is read/write.


PipelineTimings Structure (Microsoft.DirectX.Direct3D)

PipelineTimings Structure

Provides percentage of time spent processing data in the pipeline.

Definition

Visual Basic | Public Structure PipelineTimings
C# | public struct PipelineTimings
C++ | public value class PipelineTimings sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PipelineTimings | Creates a new instance of the PipelineTimings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
GpuIdleTimePercent | Retrieves the percentage of time not processing anything.
OtherGpuProcessingTimePercent | Retrieves the percentage of time spent doing other processing.
PixelProcessingTimePercent | Retrieves the percentage of time spent running pixel shaders.
VertexProcessingTimePercent | Retrieves the percentage of time spent running vertex shaders.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PipelineTimings.PipelineTimings() Constructor (Microsoft.DirectX.Direct3D)

PipelineTimings.PipelineTimings Constructor

Creates a new instance of the PipelineTimings structure.

Definition

Visual Basic | Public Sub New()
C# | public PipelineTimings();
C++ public:
PipelineTimings();
JScript | public function PipelineTimings();


PipelineTimings.ToString() Method (Microsoft.DirectX.Direct3D)

PipelineTimings.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PipelineTimings.GpuIdleTimePercent Property (Microsoft.DirectX.Direct3D)

PipelineTimings.GpuIdleTimePercent Property

Retrieves the percentage of time not processing anything.

Definition

Visual Basic | Public ReadOnly Property GpuIdleTimePercent As Single
C# | public float GpuIdleTimePercent { get; }
C++ public:
property float GpuIdleTimePercent {
float get();
}
JScript | public function get GpuIdleTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time not processing anything.

This property is read-only.


PipelineTimings.OtherGpuProcessingTimePercent Property (Microsoft.DirectX.Direct3D)

PipelineTimings.OtherGpuProcessingTimePercent Property

Retrieves the percentage of time spent doing other processing.

Definition

Visual Basic | Public ReadOnly Property OtherGpuProcessingTimePercent As Single
C# | public float OtherGpuProcessingTimePercent { get; }
C++ public:
property float OtherGpuProcessingTimePercent {
float get();
}
JScript | public function get OtherGpuProcessingTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time spent doing other processing.

This property is read-only.


PipelineTimings.PixelProcessingTimePercent Property (Microsoft.DirectX.Direct3D)

PipelineTimings.PixelProcessingTimePercent Property

Retrieves the percentage of time spent running pixel shaders.

Definition

Visual Basic | Public ReadOnly Property PixelProcessingTimePercent As Single
C# | public float PixelProcessingTimePercent { get; }
C++ public:
property float PixelProcessingTimePercent {
float get();
}
JScript | public function get PixelProcessingTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time spent running pixel shaders.

This property is read-only.


PipelineTimings.VertexProcessingTimePercent Property (Microsoft.DirectX.Direct3D)

PipelineTimings.VertexProcessingTimePercent Property

Retrieves the percentage of time spent running vertex shaders.

Definition

Visual Basic | Public ReadOnly Property VertexProcessingTimePercent As Single
C# | public float VertexProcessingTimePercent { get; }
C++ public:
property float VertexProcessingTimePercent {
float get();
}
JScript | public function get VertexProcessingTimePercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time spent running vertex shaders.

This property is read-only.


PixelShaderCaps Structure (Microsoft.DirectX.Direct3D)

PixelShaderCaps Structure

Contains pixel shader capabilities.

Definition

Visual Basic | Public Structure PixelShaderCaps
C# | public struct PixelShaderCaps
C++ | public value class PixelShaderCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) MaxDynamicFlowControlDepth | Specifies the maximum level of nesting of dynamic flow control instructions (break, breakc, and ifc).
static (Shared in Visual Basic) MaxNumberInstructionSlots | Specifies the maximum number of instruction slots the driver supports.
static (Shared in Visual Basic) MaxNumberTemps | Specifies the maximum number of temporary registers the driver supports.
static (Shared in Visual Basic) MaxStaticFlowControlDepth | Specifies the maximum nesting depth of loop/rep and call/callnz bool instructions.
static (Shared in Visual Basic) MinDynamicFlowControlDepth | Specifies the minimum level of nesting of dynamic flow control instructions (break, breakc, and ifc).
static (Shared in Visual Basic) MinNumberInstructionSlots | Specifies the minimum number of instruction slots the driver supports.
static (Shared in Visual Basic) MinNumberTemps | Specifies the minimum number of temporary registers supported.
static (Shared in Visual Basic) MinStaticFlowControlDepth | Specifies the minimum nesting depth of loop/rep and call/callnz bool instructions.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DynamicFlowControlDepth | Retrieves a value that represents the depth of the dynamic flow-control instruction nesting.
NumberInstructionSlots | Retrieves the number of instruction slots the device supports.
NumberTemps | Retrieves the number of temporary registers the device supports.
StaticFlowControlDepth | Retrieves the depth of nesting of the loop/rep and call/callnz bool instructions.
SupportsArbitrarySwizzle | Determines whether arbitrary swizzle is supported.
SupportsGradientInstructions | Determines whether gradient instructions are supported.
SupportsNoDependentReadLimit | Determines whether there are no dependent read limits.
SupportsNoTextureInstructionLimit | Determines whether there are no limits on texture instructions.
SupportsPredication | Determines whether instruction predication as defined in the predication section is supported.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PixelShaderCaps.ToString() Method (Microsoft.DirectX.Direct3D)

PixelShaderCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PixelShaderCaps.DynamicFlowControlDepth Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.DynamicFlowControlDepth Property

Retrieves a value that represents the depth of the dynamic flow-control instruction nesting.

Definition

Visual Basic | Public ReadOnly Property DynamicFlowControlDepth As Integer
C# | public int DynamicFlowControlDepth { get; }
C++ public:
property int DynamicFlowControlDepth {
int get();
}
JScript | public function get DynamicFlowControlDepth() : int

Property Value

System.Int32
Integer that represents the level of instruction nesting allowed. The acceptable range of values is 0 to 24.

This property is read-only.

Remarks

If this value is 0, the device does not support dynamic flow control. If it is non-zero, the device supports dynamic flow control (instructions if, break, and breakc).


PixelShaderCaps.NumberInstructionSlots Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.NumberInstructionSlots Property

Retrieves the number of instruction slots the device supports.

Definition

Visual Basic | Public ReadOnly Property NumberInstructionSlots As Integer
C# | public int NumberInstructionSlots { get; }
C++ public:
property int NumberInstructionSlots {
int get();
}
JScript | public function get NumberInstructionSlots() : int

Property Value

System.Int32
Integer that represents the number of instruction slots supported. The acceptable range of values is 96 to 512.

This property is read-only.


PixelShaderCaps.NumberTemps Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.NumberTemps Property

Retrieves the number of temporary registers the device supports.

Definition

Visual Basic | Public ReadOnly Property NumberTemps As Integer
C# | public int NumberTemps { get; }
C++ public:
property int NumberTemps {
int get();
}
JScript | public function get NumberTemps() : int

Property Value

System.Int32
Integer that represents the number of temporary registers supported. The acceptable range of values is 12 to 32.

This property is read-only.


PixelShaderCaps.StaticFlowControlDepth Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.StaticFlowControlDepth Property

Retrieves the depth of nesting of the loop/rep and call/callnz bool instructions.

Definition

Visual Basic | Public ReadOnly Property StaticFlowControlDepth As Integer
C# | public int StaticFlowControlDepth { get; }
C++ public:
property int StaticFlowControlDepth {
int get();
}
JScript | public function get StaticFlowControlDepth() : int

Property Value

System.Int32
Integer that represents instruction nesting depth. The acceptable range of values is 0 to 4.

This property is read-only.

Remarks

If this value is 0, the device does not support static flow control.


PixelShaderCaps.SupportsArbitrarySwizzle Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.SupportsArbitrarySwizzle Property

Determines whether arbitrary swizzle is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsArbitrarySwizzle As Boolean
C# | public bool SupportsArbitrarySwizzle { get; }
C++ public:
property bool SupportsArbitrarySwizzle {
bool get();
}
JScript | public function get SupportsArbitrarySwizzle() : boolean

Property Value

System.Boolean
Value that is true if arbitrary swizzle is supported, or false if it is not.

This property is read-only.


PixelShaderCaps.SupportsGradientInstructions Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.SupportsGradientInstructions Property

Determines whether gradient instructions are supported.

Definition

Visual Basic | Public ReadOnly Property SupportsGradientInstructions As Boolean
C# | public bool SupportsGradientInstructions { get; }
C++ public:
property bool SupportsGradientInstructions {
bool get();
}
JScript | public function get SupportsGradientInstructions() : boolean

Property Value

System.Boolean
Value that is true if gradient instructions are supported, or false if they are not.

This property is read-only.


PixelShaderCaps.SupportsNoDependentReadLimit Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.SupportsNoDependentReadLimit Property

Determines whether there are no dependent read limits.

Definition

Visual Basic | Public ReadOnly Property SupportsNoDependentReadLimit As Boolean
C# | public bool SupportsNoDependentReadLimit { get; }
C++ public:
property bool SupportsNoDependentReadLimit {
bool get();
}
JScript | public function get SupportsNoDependentReadLimit() : boolean

Property Value

System.Boolean
Value that is true if there are no dependent read limits, or false if there are dependent read limits.

This property is read-only.


PixelShaderCaps.SupportsNoTextureInstructionLimit Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.SupportsNoTextureInstructionLimit Property

Determines whether there are no limits on texture instructions.

Definition

Visual Basic | Public ReadOnly Property SupportsNoTextureInstructionLimit As Boolean
C# | public bool SupportsNoTextureInstructionLimit { get; }
C++ public:
property bool SupportsNoTextureInstructionLimit {
bool get();
}
JScript | public function get SupportsNoTextureInstructionLimit() : boolean

Property Value

System.Boolean
Value that is true if there are no limits on texture instructions, or false if there are limits on texture instructions.

This property is read-only.


PixelShaderCaps.SupportsPredication Property (Microsoft.DirectX.Direct3D)

PixelShaderCaps.SupportsPredication Property

Determines whether instruction predication as defined in the predication section is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsPredication As Boolean
C# | public bool SupportsPredication { get; }
C++ public:
property bool SupportsPredication {
bool get();
}
JScript | public function get SupportsPredication() : boolean

Property Value

System.Boolean
Value that is true if instruction predication is supported, or false if it is not.

This property is read-only.


PixelShaderCaps.MaxDynamicFlowControlDepth Field (Microsoft.DirectX.Direct3D)

PixelShaderCaps.MaxDynamicFlowControlDepth Field

Specifies the maximum level of nesting of dynamic flow control instructions (break, breakc, and ifc).

Definition

Visual Basic | Public Shared MaxDynamicFlowControlDepth As Int32
C# | public static Int32 MaxDynamicFlowControlDepth;
C++ | public: static Int32 MaxDynamicFlowControlDepth;
JScript | public static var MaxDynamicFlowControlDepth : Int32

Field Value

System.Int32
Value of 24.

This field is read-only.


PixelShaderCaps.MaxNumberInstructionSlots Field (Microsoft.DirectX.Direct3D)

PixelShaderCaps.MaxNumberInstructionSlots Field

Specifies the maximum number of instruction slots the driver supports.

Definition

Visual Basic | Public Shared MaxNumberInstructionSlots As Int32
C# | public static Int32 MaxNumberInstructionSlots;
C++ | public: static Int32 MaxNumberInstructionSlots;
JScript | public static var MaxNumberInstructionSlots : Int32

Field Value

System.Int32
Value of 512.

This field is read-only.


PixelShaderCaps.MaxNumberTemps Field (Microsoft.DirectX.Direct3D)

PixelShaderCaps.MaxNumberTemps Field

Specifies the maximum number of temporary registers the driver supports.

Definition

Visual Basic | Public Shared MaxNumberTemps As Int32
C# | public static Int32 MaxNumberTemps;
C++ | public: static Int32 MaxNumberTemps;
JScript | public static var MaxNumberTemps : Int32

Field Value

System.Int32
Value of 512.

This field is read-only.


PixelShaderCaps.MaxStaticFlowControlDepth Field (Microsoft.DirectX.Direct3D)

PixelShaderCaps.MaxStaticFlowControlDepth Field

Specifies the maximum nesting depth of loop/rep and call/callnz bool instructions.

Definition

Visual Basic | Public Shared MaxStaticFlowControlDepth As Int32
C# | public static Int32 MaxStaticFlowControlDepth;
C++ | public: static Int32 MaxStaticFlowControlDepth;
JScript | public static var MaxStaticFlowControlDepth : Int32

Field Value

System.Int32
Value of 4.

This field is read-only.


PixelShaderCaps.MinDynamicFlowControlDepth Field (Microsoft.DirectX.Direct3D)

PixelShaderCaps.MinDynamicFlowControlDepth Field

Specifies the minimum level of nesting of dynamic flow control instructions (break, breakc, and ifc).

Definition

Visual Basic | Public Shared MinDynamicFlowControlDepth As Int32
C# | public static Int32 MinDynamicFlowControlDepth;
C++ | public: static Int32 MinDynamicFlowControlDepth;
JScript | public static var MinDynamicFlowControlDepth : Int32

Field Value

System.Int32
Value of 0.

This field is read-only.


PixelShaderCaps.MinNumberInstructionSlots Field (Microsoft.DirectX.Direct3D)

PixelShaderCaps.MinNumberInstructionSlots Field

Specifies the minimum number of instruction slots the driver supports.

Definition

Visual Basic | Public Shared MinNumberInstructionSlots As Int32
C# | public static Int32 MinNumberInstructionSlots;
C++ | public: static Int32 MinNumberInstructionSlots;
JScript | public static var MinNumberInstructionSlots : Int32

Field Value

System.Int32
Value of 96.

This field is read-only.


PixelShaderCaps.MinNumberTemps Field (Microsoft.DirectX.Direct3D)

PixelShaderCaps.MinNumberTemps Field

Specifies the minimum number of temporary registers supported.

Definition

Visual Basic | Public Shared MinNumberTemps As Int32
C# | public static Int32 MinNumberTemps;
C++ | public: static Int32 MinNumberTemps;
JScript | public static var MinNumberTemps : Int32

Field Value

System.Int32
Value of 12.

This field is read-only.


PixelShaderCaps.MinStaticFlowControlDepth Field (Microsoft.DirectX.Direct3D)

PixelShaderCaps.MinStaticFlowControlDepth Field

Specifies the minimum nesting depth of loop/rep and call/callnz bool instructions.

Definition

Visual Basic | Public Shared MinStaticFlowControlDepth As Int32
C# | public static Int32 MinStaticFlowControlDepth;
C++ | public: static Int32 MinStaticFlowControlDepth;
JScript | public static var MinStaticFlowControlDepth : Int32

Field Value

System.Int32
Value of 1.

This field is read-only.


CustomVertex.PositionColored Structure (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored Structure

Describes a custom vertex format structure that contains position and color information.

Definition

Visual Basic | Public Structure PositionColored
C# | public struct PositionColored
C++ | public value class PositionColored sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionColored | Initializes a new instance of the CustomVertex.PositionColored class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.PositionColored structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.PositionColored.PositionColored Constructor ()

Initializes a new instance of the CustomVertex.PositionColored class.

Overload List

public PositionColored(float, float, float, int);
public PositionColored(Vector3, int);


CustomVertex.PositionColored.PositionColored(Vector3,Int32) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.PositionColored Constructor

Initializes a new instance of the CustomVertex.PositionColored class.

Definition

Visual Basic Public Sub New( _
ByVal value As Vector3, _
ByVal c As Integer _
)
C# public PositionColored(
Vector3 value,
int c
);
C++ public:
PositionColored(
Vector3 value,
int c
);
JScript public function PositionColored(
value : Vector3,
c : int
);

Parameters

value Microsoft.DirectX.Vector3
A Vector3 object that contains the position.
c System.Int32
Integer that represents the diffuse color value.


CustomVertex.PositionColored.PositionColored(Single,Single,Single,Int32) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.PositionColored Constructor

Initializes a new instance of the CustomVertex.PositionColored class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal c As Integer _
)
C# public PositionColored(
float xvalue,
float yvalue,
float zvalue,
int c
);
C++ public:
PositionColored(
float xvalue,
float yvalue,
float zvalue,
int c
);
JScript public function PositionColored(
xvalue : float,
yvalue : float,
zvalue : float,
c : int
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
c System.Int32
Integer that represents the diffuse color value.


CustomVertex.PositionColored.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.PositionColored.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.Position Property

Retrieves or sets the vertex position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionColored.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.StrideSize Property

Retrieves the size of the CustomVertex.PositionColored structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure in bytes.

This property is read-only.


CustomVertex.PositionColored.Color Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.Color Field

Retrieves or sets the vertex color.

Definition

Visual Basic | Public Color As Int32
C# | public Int32 Color;
C++ | public: Int32 Color;
JScript | public var Color : Int32

Field Value

System.Int32
Integer that represents the vertex color.

This field is read/write.


CustomVertex.PositionColored.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionColored.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionColored.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionColored.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColored.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionColoredTextured Structure (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured Structure

Describes a custom vertex format structure that contains position, color, and one set of texture coordinates.

Definition

Visual Basic | Public Structure PositionColoredTextured
C# | public struct PositionColoredTextured
C++ | public value class PositionColoredTextured sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionColoredTextured | Initializes a new instance of the CustomVertex.PositionColoredTextured class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.PositionColoredTextured structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.PositionColoredTextured.PositionColoredTextured Constructor ()

Initializes a new instance of the CustomVertex.PositionColoredTextured class.

Overload List

public PositionColoredTextured(float, float, float, int, float, float);
public PositionColoredTextured(Vector3, int, float, float);


CustomVertex.PositionColoredTextured.PositionColoredTextured(Vector3,Int32,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.PositionColoredTextured Constructor

 Language:

Initializes a new instance of the CustomVertex.PositionColoredTextured class.

Definition

Visual Basic Public Sub New( _
ByVal value As Vector3, _
ByVal c As Integer, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionColoredTextured(
Vector3 value,
int c,
float u,
float v
);
C++ public:
PositionColoredTextured(
Vector3 value,
int c,
float u,
float v
);
JScript public function PositionColoredTextured(
value : Vector3,
c : int,
u : float,
v : float
);

Parameters

value Microsoft.DirectX.Vector3
A Vector3 object that contains the position.
c System.Int32
Integer that represents the vertex color value.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionColoredTextured.PositionColoredTextured(Single,Single,Single,Int32,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.PositionColoredTextured Constructor

 Language:

Initializes a new instance of the CustomVertex.PositionColoredTextured class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal c As Integer, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionColoredTextured(
float xvalue,
float yvalue,
float zvalue,
int c,
float u,
float v
);
C++ public:
PositionColoredTextured(
float xvalue,
float yvalue,
float zvalue,
int c,
float u,
float v
);
JScript public function PositionColoredTextured(
xvalue : float,
yvalue : float,
zvalue : float,
c : int,
u : float,
v : float
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
c System.Int32
Integer that represents the vertex color value.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionColoredTextured.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.PositionColoredTextured.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.Position Property

Retrieves or sets the vertex position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionColoredTextured.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.StrideSize Property

Retrieves the size of the CustomVertex.PositionColoredTextured structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure in bytes.

This property is read-only.


CustomVertex.PositionColoredTextured.Color Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.Color Field

Retrieves or sets the vertex color.

Definition

Visual Basic | Public Color As Int32
C# | public Int32 Color;
C++ | public: Int32 Color;
JScript | public var Color : Int32

Field Value

System.Int32
Integer that represents the vertex color.

This field is read/write.


CustomVertex.PositionColoredTextured.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionColoredTextured.Tu Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.Tu Field

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic | Public Tu As Single
C# | public Single Tu;
C++ | public: Single Tu;
JScript | public var Tu : Single

Field Value

System.Single
Floating-point value that represents the u component of the texture coordinate.

This field is read/write.


CustomVertex.PositionColoredTextured.Tv Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.Tv Field

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic | Public Tv As Single
C# | public Single Tv;
C++ | public: Single Tv;
JScript | public var Tv : Single

Field Value

System.Single
Floating-point value that represents the v component of the texture coordinate.

This field is read/write.


CustomVertex.PositionColoredTextured.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionColoredTextured.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionColoredTextured.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionColoredTextured.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionNormal Structure (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal Structure

Describes a custom vertex format structure that contains position and normal data.

Definition

Visual Basic | Public Structure PositionNormal
C# | public struct PositionNormal
C++ | public value class PositionNormal sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Nx | Retrieves or sets the nx component of the vertex normal.
Ny | Retrieves or sets the ny component of the vertex normal.
Nz | Retrieves or sets the nz component of the vertex normal.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionNormal | Initializes a new instance of the CustomVertex.PositionNormal class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Normal | Retrieves or sets the vertex normal data.
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.PositionNormal structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.PositionNormal.PositionNormal Constructor ()

Initializes a new instance of the CustomVertex.PositionNormal class.

Overload List

public PositionNormal(float, float, float, float, float, float);
public PositionNormal(Vector3, Vector3);


CustomVertex.PositionNormal.PositionNormal(Vector3,Vector3) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.PositionNormal Constructor

Initializes a new instance of the CustomVertex.PositionNormal class.

Definition

Visual Basic Public Sub New( _
ByVal pos As Vector3, _
ByVal nor As Vector3 _
)
C# public PositionNormal(
Vector3 pos,
Vector3 nor
);
C++ public:
PositionNormal(
Vector3 pos,
Vector3 nor
);
JScript public function PositionNormal(
pos : Vector3,
nor : Vector3
);

Parameters

pos Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.
nor Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex normal data.


CustomVertex.PositionNormal.PositionNormal(Single,Single,Single,Single,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.PositionNormal Constructor

Initializes a new instance of the CustomVertex.PositionNormal class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal nxvalue As Single, _
ByVal nyvalue As Single, _
ByVal nzvalue As Single _
)
C# public PositionNormal(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue
);
C++ public:
PositionNormal(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue
);
JScript public function PositionNormal(
xvalue : float,
yvalue : float,
zvalue : float,
nxvalue : float,
nyvalue : float,
nzvalue : float
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
nxvalue System.Single
Floating-point value that represents the nx coordinate of the vertex normal.
nyvalue System.Single
Floating-point value that represents the ny coordinate of the vertex normal.
nzvalue System.Single
Floating-point value that represents the nz coordinate of the vertex normal.


CustomVertex.PositionNormal.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.PositionNormal.Normal Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.Normal Property

Retrieves or sets the vertex normal data.

Definition

Visual Basic | Public Property Normal As Vector3
C# | public Vector3 Normal { get; set; }
C++ public:
property Vector3 Normal {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Normal() : Vector3
public function set Normal(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex normal data.

This property is read/write.


CustomVertex.PositionNormal.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.Position Property

Retrieves or sets the vertex position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionNormal.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.StrideSize Property

Retrieves the size of the CustomVertex.PositionNormal structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionNormal.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionNormal.Nx Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.Nx Field

Retrieves or sets the nx component of the vertex normal.

Definition

Visual Basic | Public Nx As Single
C# | public Single Nx;
C++ | public: Single Nx;
JScript | public var Nx : Single

Field Value

System.Single
Floating-point value that represents the nx component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormal.Ny Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.Ny Field

Retrieves or sets the ny component of the vertex normal.

Definition

Visual Basic | Public Ny As Single
C# | public Single Ny;
C++ | public: Single Ny;
JScript | public var Ny : Single

Field Value

System.Single
Floating-point value that represents the ny component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormal.Nz Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.Nz Field

Retrieves or sets the nz component of the vertex normal.

Definition

Visual Basic | Public Nz As Single
C# | public Single Nz;
C++ | public: Single Nz;
JScript | public var Nz : Single

Field Value

System.Single
Floating-point value that represents the nz component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormal.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionNormal.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionNormal.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormal.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionNormalColored Structure (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored Structure

Describes a custom vertex format structure that contains position, color, and normal data.

Definition

Visual Basic | Public Structure PositionNormalColored
C# | public struct PositionNormalColored
C++ | public value class PositionNormalColored sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Nx | Retrieves or sets the nx component of the vertex normal.
Ny | Retrieves or sets the ny component of the vertex normal.
Nz | Retrieves or sets the nz component of the vertex normal.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionNormalColored | Initializes a new instance of the CustomVertex.PositionNormalColored class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Normal | Retrieves or sets the vertex normal data.
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.PositionNormalColored structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.PositionNormalColored.PositionNormalColored Constructor ()

Initializes a new instance of the CustomVertex.PositionNormalColored class.

Overload List

public PositionNormalColored(float, float, float, float, float, float, int);
public PositionNormalColored(Vector3, Vector3, int);


CustomVertex.PositionNormalColored.PositionNormalColored(Vector3,Vector3,Int32) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.PositionNormalColored Constructor

 Language:

Initializes a new instance of the CustomVertex.PositionNormalColored class.

Definition

Visual Basic Public Sub New( _
ByVal pos As Vector3, _
ByVal nor As Vector3, _
ByVal c As Integer _
)
C# public PositionNormalColored(
Vector3 pos,
Vector3 nor,
int c
);
C++ public:
PositionNormalColored(
Vector3 pos,
Vector3 nor,
int c
);
JScript public function PositionNormalColored(
pos : Vector3,
nor : Vector3,
c : int
);

Parameters

pos Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.
nor Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex normal data.
c System.Int32
Integer that represents the vertex color value.


CustomVertex.PositionNormalColored.PositionNormalColored(Single,Single,Single,Single,Single,Single,Int32) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.PositionNormalColored Constructor

 Language:

Initializes a new instance of the CustomVertex.PositionNormalColored class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal nxvalue As Single, _
ByVal nyvalue As Single, _
ByVal nzvalue As Single, _
ByVal c As Integer _
)
C# public PositionNormalColored(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue,
int c
);
C++ public:
PositionNormalColored(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue,
int c
);
JScript public function PositionNormalColored(
xvalue : float,
yvalue : float,
zvalue : float,
nxvalue : float,
nyvalue : float,
nzvalue : float,
c : int
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
nxvalue System.Single
Floating-point value that represents the nx coordinate of the vertex normal.
nyvalue System.Single
Floating-point value that represents the ny coordinate of the vertex normal.
nzvalue System.Single
Floating-point value that represents the nz coordinate of the vertex normal.
c System.Int32
Integer that represents the vertex color value.


CustomVertex.PositionNormalColored.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.PositionNormalColored.Normal Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Normal Property

Retrieves or sets the vertex normal data.

Definition

Visual Basic | Public Property Normal As Vector3
C# | public Vector3 Normal { get; set; }
C++ public:
property Vector3 Normal {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Normal() : Vector3
public function set Normal(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex normal data.

This property is read/write.


CustomVertex.PositionNormalColored.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Position Property

Retrieves or sets the vertex position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionNormalColored.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.StrideSize Property

Retrieves the size of the CustomVertex.PositionNormalColored structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionNormalColored.Color Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Color Field

Retrieves or sets the vertex color.

Definition

Visual Basic | Public Color As Int32
C# | public Int32 Color;
C++ | public: Int32 Color;
JScript | public var Color : Int32

Field Value

System.Int32
Integer that represents the vertex color.

This field is read/write.


CustomVertex.PositionNormalColored.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionNormalColored.Nx Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Nx Field

Retrieves or sets the nx component of the vertex normal.

Definition

Visual Basic | Public Nx As Single
C# | public Single Nx;
C++ | public: Single Nx;
JScript | public var Nx : Single

Field Value

System.Single
Floating-point value that represents the nx component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormalColored.Ny Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Ny Field

Retrieves or sets the ny component of the vertex normal.

Definition

Visual Basic | Public Ny As Single
C# | public Single Ny;
C++ | public: Single Ny;
JScript | public var Ny : Single

Field Value

System.Single
Floating-point value that represents the ny component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormalColored.Nz Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Nz Field

Retrieves or sets the nz component of the vertex normal.

Definition

Visual Basic | Public Nz As Single
C# | public Single Nz;
C++ | public: Single Nz;
JScript | public var Nz : Single

Field Value

System.Single
Floating-point value that represents the nz component of the vertex normal.

This field is read/write.


CustomVertex.PositionNormalColored.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionNormalColored.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionNormalColored.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalColored.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionNormalTextured Structure (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured Structure

How Do I...?
  • Create a Mesh Object

Describes a custom vertex format structure that contains position, normal data, and one set of texture coordinates.

Definition

Visual Basic | Public Structure PositionNormalTextured
C# | public struct PositionNormalTextured
C++ | public value class PositionNormalTextured sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Nx | Retrieves or sets the nx component of the vertex normal.
Ny | Retrieves or sets the ny component of the vertex normal.
Nz | Retrieves or sets the nz component of the vertex normal.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionNormalTextured | Initializes a new instance of the CustomVertex.PositionNormalTextured class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Normal | Retrieves or sets the vertex normal data.
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.PositionNormalTextured structure.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.PositionNormalTextured.PositionNormalTextured Constructor ()

Initializes a new instance of the CustomVertex.PositionNormalTextured class.

Overload List

public PositionNormalTextured(float, float, float, float, float, float, float, float);
public PositionNormalTextured(Vector3, Vector3, float, float);


CustomVertex.PositionNormalTextured.PositionNormalTextured(Vector3,Vector3,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.PositionNormalTextured Constructor

 Language:

Initializes a new instance of the CustomVertex.PositionNormalTextured class.

Definition

Visual Basic Public Sub New( _
ByVal pos As Vector3, _
ByVal nor As Vector3, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionNormalTextured(
Vector3 pos,
Vector3 nor,
float u,
float v
);
C++ public:
PositionNormalTextured(
Vector3 pos,
Vector3 nor,
float u,
float v
);
JScript public function PositionNormalTextured(
pos : Vector3,
nor : Vector3,
u : float,
v : float
);

Parameters

pos Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.
nor Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex normal data.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionNormalTextured.PositionNormalTextured(Single,Single,Single,Single,Single,Single,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.PositionNormalTextured Constructor

 Language:

Initializes a new instance of the CustomVertex.PositionNormalTextured class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal nxvalue As Single, _
ByVal nyvalue As Single, _
ByVal nzvalue As Single, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionNormalTextured(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue,
float u,
float v
);
C++ public:
PositionNormalTextured(
float xvalue,
float yvalue,
float zvalue,
float nxvalue,
float nyvalue,
float nzvalue,
float u,
float v
);
JScript public function PositionNormalTextured(
xvalue : float,
yvalue : float,
zvalue : float,
nxvalue : float,
nyvalue : float,
nzvalue : float,
u : float,
v : float
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
nxvalue System.Single
Floating-point value that represents the nx coordinate of the vertex normal.
nyvalue System.Single
Floating-point value that represents the ny coordinate of the vertex normal.
nzvalue System.Single
Floating-point value that represents the nz coordinate of the vertex normal.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionNormalTextured.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.PositionNormalTextured.Normal Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Normal Property

Retrieves or sets the vertex normal data.

Definition

Visual Basic | Public Property Normal As Vector3
C# | public Vector3 Normal { get; set; }
C++ public:
property Vector3 Normal {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Normal() : Vector3
public function set Normal(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex normal data.

This property is read/write.


CustomVertex.PositionNormalTextured.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Position Property

Retrieves or sets the vertex position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionNormalTextured.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.StrideSize Property

Retrieves the size of the CustomVertex.PositionNormalTextured structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionNormalTextured.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionNormalTextured.Nx Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Nx Field

How Do I...?
  • Create a Mesh Object

Retrieves or sets the nx component of the vertex normal.

Definition

Visual Basic | Public Nx As Single
C# | public Single Nx;
C++ | public: Single Nx;
JScript | public var Nx : Single

Field Value

System.Single
Floating-point value that represents the nx component of the vertex normal.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.Ny Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Ny Field

How Do I...?
  • Create a Mesh Object

Retrieves or sets the ny component of the vertex normal.

Definition

Visual Basic | Public Ny As Single
C# | public Single Ny;
C++ | public: Single Ny;
JScript | public var Ny : Single

Field Value

System.Single
Floating-point value that represents the ny component of the vertex normal.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.Nz Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Nz Field

How Do I...?
  • Create a Mesh Object

Retrieves or sets the nz component of the vertex normal.

Definition

Visual Basic | Public Nz As Single
C# | public Single Nz;
C++ | public: Single Nz;
JScript | public var Nz : Single

Field Value

System.Single
Floating-point value that represents the nz component of the vertex normal.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.Tu Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Tu Field

How Do I...?
  • Create a Mesh Object

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic | Public Tu As Single
C# | public Single Tu;
C++ | public: Single Tu;
JScript | public var Tu : Single

Field Value

System.Single
Floating-point value that represents the u component of the texture coordinate.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.Tv Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Tv Field

How Do I...?
  • Create a Mesh Object

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic | Public Tv As Single
C# | public Single Tv;
C++ | public: Single Tv;
JScript | public var Tv : Single

Field Value

System.Single
Floating-point value that represents the v component of the texture coordinate.

This field is read/write.

How Do I...?

Create a Mesh Object

This example shows how to create a Mesh object.

In the following C# code example, device is assumed to be the rendering Device.

              [C#]

int numberVerts = 8;
short[] indices = {
    0,1,2, // Front Face
    1,3,2, // Front Face
    4,5,6, // Back Face
    6,5,7, // Back Face
    0,5,4, // Top Face
    0,2,5, // Top Face
    1,6,7, // Bottom Face
    1,7,3, // Bottom Face
    0,6,1, // Left Face
    4,6,0, // Left Face
    2,3,7, // Right Face
    5,2,7 // Right Face
};

Mesh mesh = new Mesh(numberVerts * 3, numberVerts, MeshFlags.Managed,
                     CustomVertex.PositionColored.Format, device);

using(VertexBuffer vb = mesh.VertexBuffer)
{
    GraphicsStream data = vb.Lock(0, 0, LockFlags.None);

    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, 1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, 1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(-1.0f, -1.0f, -1.0f, 0x00ff00ff));
    data.Write(new CustomVertex.PositionColored(1.0f, -1.0f, -1.0f, 0x00ff00ff));

    vb.Unlock();
}

using (IndexBuffer ib = mesh.IndexBuffer)
{
    ib.SetData(indices, 0, LockFlags.None);
}


CustomVertex.PositionNormalTextured.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionNormalTextured.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionNormalTextured.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionNormalTextured.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionOnly Structure (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly Structure

Describes a custom vertex format structure that contains only position data.

Definition

Visual Basic | Public Structure PositionOnly
C# | public struct PositionOnly
C++ | public value class PositionOnly sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionOnly | Initializes a new instance of the CustomVertex.PositionOnly class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.PositionOnly structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.PositionOnly.PositionOnly Constructor ()

Initializes a new instance of the CustomVertex.PositionOnly class.

Overload List

public PositionOnly(float, float, float);
public PositionOnly(Vector3);


CustomVertex.PositionOnly.PositionOnly(Vector3) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.PositionOnly Constructor

Initializes a new instance of the CustomVertex.PositionOnly class.

Definition

Visual Basic Public Sub New( _
ByVal value As Vector3 _
)
C# public PositionOnly(
Vector3 value
);
C++ public:
PositionOnly(
Vector3 value
);
JScript public function PositionOnly(
value : Vector3
);

Parameters

value Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.


CustomVertex.PositionOnly.PositionOnly(Single,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.PositionOnly Constructor

Initializes a new instance of the CustomVertex.PositionOnly class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single _
)
C# public PositionOnly(
float xvalue,
float yvalue,
float zvalue
);
C++ public:
PositionOnly(
float xvalue,
float yvalue,
float zvalue
);
JScript public function PositionOnly(
xvalue : float,
yvalue : float,
zvalue : float
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.


CustomVertex.PositionOnly.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.PositionOnly.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.Position Property

Retrieves or sets the vertex position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionOnly.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.StrideSize Property

Retrieves the size of the CustomVertex.PositionOnly structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionOnly.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionOnly.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionOnly.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionOnly.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionOnly.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.PositionTextured Structure (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured Structure

Describes a custom vertex format structure that contains position and one set of texture coordinates.

Definition

Visual Basic | Public Structure PositionTextured
C# | public struct PositionTextured
C++ | public value class PositionTextured sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
PositionTextured | Initializes a new instance of the CustomVertex.PositionTextured class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Position | Retrieves or sets the vertex position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.PositionTextured structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.PositionTextured.PositionTextured Constructor ()

Initializes a new instance of the CustomVertex.PositionTextured class.

Overload List

public PositionTextured(float, float, float, float, float);
public PositionTextured(Vector3, float, float);


CustomVertex.PositionTextured.PositionTextured(Vector3,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.PositionTextured Constructor

Initializes a new instance of the CustomVertex.PositionTextured class.

Definition

Visual Basic Public Sub New( _
ByVal pos As Vector3, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionTextured(
Vector3 pos,
float u,
float v
);
C++ public:
PositionTextured(
Vector3 pos,
float u,
float v
);
JScript public function PositionTextured(
pos : Vector3,
u : float,
v : float
);

Parameters

pos Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionTextured.PositionTextured(Single,Single,Single,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.PositionTextured Constructor

Initializes a new instance of the CustomVertex.PositionTextured class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal u As Single, _
ByVal v As Single _
)
C# public PositionTextured(
float xvalue,
float yvalue,
float zvalue,
float u,
float v
);
C++ public:
PositionTextured(
float xvalue,
float yvalue,
float zvalue,
float u,
float v
);
JScript public function PositionTextured(
xvalue : float,
yvalue : float,
zvalue : float,
u : float,
v : float
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.PositionTextured.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.PositionTextured.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.Position Property

Retrieves or sets the vertex position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that contains the vertex position.

This property is read/write.


CustomVertex.PositionTextured.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.StrideSize Property

Retrieves the size of the CustomVertex.PositionTextured structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.PositionTextured.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.PositionTextured.Tu Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.Tu Field

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic | Public Tu As Single
C# | public Single Tu;
C++ | public: Single Tu;
JScript | public var Tu : Single

Field Value

System.Single
Floating-point value that represents the u component of the texture coordinate.

This field is read/write.


CustomVertex.PositionTextured.Tv Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.Tv Field

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic | Public Tv As Single
C# | public Single Tv;
C++ | public: Single Tv;
JScript | public var Tv : Single

Field Value

System.Single
Floating-point value that represents the v component of the texture coordinate.

This field is read/write.


CustomVertex.PositionTextured.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.PositionTextured.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.PositionTextured.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.PositionTextured.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


PropertyDescription Structure (Microsoft.DirectX.Direct3D)

PropertyDescription Structure

Describes a property used for an effect object.

Definition

Visual Basic | Public Structure PropertyDescription
C# | public struct PropertyDescription
C++ | public value class PropertyDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PropertyDescription | Initializes a new instance of the PropertyDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Bytes | Retrieves or sets the size of the property, in bytes.
Dimension | Retrieves or sets the dimension of the property.
Index | Retrieves or sets the index of the property.
Name | Retrieves or sets the name of the property.
Type | Retrieves or sets the property type.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PropertyDescription.PropertyDescription() Constructor (Microsoft.DirectX.Direct3D)

PropertyDescription.PropertyDescription Constructor

Initializes a new instance of the PropertyDescription class.

Definition

Visual Basic | Public Sub New()
C# | public PropertyDescription();
C++ public:
PropertyDescription();
JScript | public function PropertyDescription();


PropertyDescription.ToString() Method (Microsoft.DirectX.Direct3D)

PropertyDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PropertyDescription.Bytes Property (Microsoft.DirectX.Direct3D)

PropertyDescription.Bytes Property

Retrieves or sets the size of the property, in bytes.

Definition

Visual Basic | Public Property Bytes As Integer
C# | public int Bytes { get; set; }
C++ public:
property int Bytes {
int get();
void set(int value);
}
JScript public function get Bytes() : int
public function set Bytes(int);

Property Value

System.Int32
Integer that represents the property size to set or retrieve.

This property is read/write.


PropertyDescription.Dimension Property (Microsoft.DirectX.Direct3D)

PropertyDescription.Dimension Property

Retrieves or sets the dimension of the property.

Definition

Visual Basic | Public Property Dimension As Integer
C# | public int Dimension { get; set; }
C++ public:
property int Dimension {
int get();
void set(int value);
}
JScript public function get Dimension() : int
public function set Dimension(int);

Property Value

System.Int32
Integer that represents the property dimension to set or retrieve.

This property is read/write.


PropertyDescription.Index Property (Microsoft.DirectX.Direct3D)

PropertyDescription.Index Property

Retrieves or sets the index of the property.

Definition

Visual Basic | Public Property Index As String
C# | public string Index { get; set; }
C++ public:
property String^ Index {
String^ get();
void set(String^ value);
}
JScript public function get Index() : String
public function set Index(String);

Property Value

System.String
String that represents the index of the property to set or retrieve.

This property is read/write.


PropertyDescription.Name Property (Microsoft.DirectX.Direct3D)

PropertyDescription.Name Property

Retrieves or sets the name of the property.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String
String that contains the property name to set or retrieve.

This property is read/write.


PropertyDescription.Type Property (Microsoft.DirectX.Direct3D)

PropertyDescription.Type Property

Retrieves or sets the property type.

Definition

Visual Basic | Public Property Type As ParameterType
C# | public ParameterType Type { get; set; }
C++ public:
property ParameterType Type {
ParameterType get();
void set(ParameterType value);
}
JScript public function get Type() : ParameterType
public function set Type(ParameterType);

Property Value

Microsoft.DirectX.Direct3D.ParameterType
A ParameterType enumeration value that represents the property type to set or retrieve.

This property is read/write.


PrtSplitMeshClusterData Structure (Microsoft.DirectX.Direct3D)

PrtSplitMeshClusterData Structure

Contains precomputed radiance transfer (PRT) split mesh cluster data.

Definition

Visual Basic | Public Structure PrtSplitMeshClusterData
C# | public struct PrtSplitMeshClusterData
C++ | public value class PrtSplitMeshClusterData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PrtSplitMeshClusterData | Initializes a new instance of the PrtSplitMeshClusterData structure.

Properties

Property | Description
ClusterLength | Retrieves or sets the number of clusters in this supercluster.
ClusterStart | Retrieves or sets the initial index into cluster array.
FaceLength | Retrieves or sets the number of faces in this supercluster.
FaceStart | Retrieves or sets the initial index into face array.
VertexLength | Retrieves or sets the number of vertices in this supercluster.
VertexStart | Retrieves or sets the initial vertex into remapped vertex array.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PrtSplitMeshClusterData.PrtSplitMeshClusterData() Constructor (Microsoft.DirectX.Direct3D)

PrtSplitMeshClusterData.PrtSplitMeshClusterData Constructor

Initializes a new instance of the PrtSplitMeshClusterData structure.

Definition

Visual Basic | Public Sub New()
C# | public PrtSplitMeshClusterData();
C++ public:
PrtSplitMeshClusterData();
JScript | public function PrtSplitMeshClusterData();


PrtSplitMeshClusterData.ClusterLength Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshClusterData.ClusterLength Property

Retrieves or sets the number of clusters in this supercluster.

Definition

Visual Basic | Public Property ClusterLength As Integer
C# | public int ClusterLength { get; set; }
C++ public:
property int ClusterLength {
int get();
void set(int value);
}
JScript public function get ClusterLength() : int
public function set ClusterLength(int);

Property Value

System.Int32
Number of clusters in this supercluster.

This property is read/write.


PrtSplitMeshClusterData.ClusterStart Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshClusterData.ClusterStart Property

Retrieves or sets the initial index into cluster array.

Definition

Visual Basic | Public Property ClusterStart As Integer
C# | public int ClusterStart { get; set; }
C++ public:
property int ClusterStart {
int get();
void set(int value);
}
JScript public function get ClusterStart() : int
public function set ClusterStart(int);

Property Value

System.Int32
Initial index into cluster array.

This property is read/write.


PrtSplitMeshClusterData.FaceLength Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshClusterData.FaceLength Property

Retrieves or sets the number of faces in this supercluster.

Definition

Visual Basic | Public Property FaceLength As Integer
C# | public int FaceLength { get; set; }
C++ public:
property int FaceLength {
int get();
void set(int value);
}
JScript public function get FaceLength() : int
public function set FaceLength(int);

Property Value

System.Int32
Number of faces in this supercluster.

This property is read/write.


PrtSplitMeshClusterData.FaceStart Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshClusterData.FaceStart Property

Retrieves or sets the initial index into face array.

Definition

Visual Basic | Public Property FaceStart As Integer
C# | public int FaceStart { get; set; }
C++ public:
property int FaceStart {
int get();
void set(int value);
}
JScript public function get FaceStart() : int
public function set FaceStart(int);

Property Value

System.Int32
Initial index into face array.

This property is read/write.


PrtSplitMeshClusterData.VertexLength Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshClusterData.VertexLength Property

Retrieves or sets the number of vertices in this supercluster.

Definition

Visual Basic | Public Property VertexLength As Integer
C# | public int VertexLength { get; set; }
C++ public:
property int VertexLength {
int get();
void set(int value);
}
JScript public function get VertexLength() : int
public function set VertexLength(int);

Property Value

System.Int32
Number of vertices in this supercluster.

This property is read/write.


PrtSplitMeshClusterData.VertexStart Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshClusterData.VertexStart Property

Retrieves or sets the initial vertex into remapped vertex array.

Definition

Visual Basic | Public Property VertexStart As Integer
C# | public int VertexStart { get; set; }
C++ public:
property int VertexStart {
int get();
void set(int value);
}
JScript public function get VertexStart() : int
public function set VertexStart(int);

Property Value

System.Int32
Initial vertex into remapped vertex array.

This property is read/write.


PrtSplitMeshVertexData Structure (Microsoft.DirectX.Direct3D)

PrtSplitMeshVertexData Structure

Contains precomputed radiance transfer (PRT) split mesh vertex data.

Definition

Visual Basic | Public Structure PrtSplitMeshVertexData
C# | public struct PrtSplitMeshVertexData
C++ | public value class PrtSplitMeshVertexData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
PrtSplitMeshVertexData | Initializes a new instance of the PrtSplitMeshVertexData structure.

Properties

Property | Description
SubCluster | Retrieves or sets the cluster index, relative to the supercluster.
VertexRemap | Retrieves or sets the vertex in the original mesh to which this split mesh vertex corresponds.
VertexStatus | Retrieves or sets the vertex status.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PrtSplitMeshVertexData.PrtSplitMeshVertexData() Constructor (Microsoft.DirectX.Direct3D)

PrtSplitMeshVertexData.PrtSplitMeshVertexData Constructor

Initializes a new instance of the PrtSplitMeshVertexData structure.

Definition

Visual Basic | Public Sub New()
C# | public PrtSplitMeshVertexData();
C++ public:
PrtSplitMeshVertexData();
JScript | public function PrtSplitMeshVertexData();


PrtSplitMeshVertexData.SubCluster Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshVertexData.SubCluster Property

Retrieves or sets the cluster index, relative to the supercluster.

Definition

Visual Basic | Public Property SubCluster As Integer
C# | public int SubCluster { get; set; }
C++ public:
property int SubCluster {
int get();
void set(int value);
}
JScript public function get SubCluster() : int
public function set SubCluster(int);

Property Value

System.Int32
Cluster index, relative to the supercluster.

This property is read/write.


PrtSplitMeshVertexData.VertexRemap Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshVertexData.VertexRemap Property

Retrieves or sets the vertex in the original mesh to which this split mesh vertex corresponds.

Definition

Visual Basic | Public Property VertexRemap As Integer
C# | public int VertexRemap { get; set; }
C++ public:
property int VertexRemap {
int get();
void set(int value);
}
JScript public function get VertexRemap() : int
public function set VertexRemap(int);

Property Value

System.Int32
Vertex in the original mesh to which this split mesh vertex corresponds.

This property is read/write.


PrtSplitMeshVertexData.VertexStatus Property (Microsoft.DirectX.Direct3D)

PrtSplitMeshVertexData.VertexStatus Property

Retrieves or sets the vertex status.

Definition

Visual Basic | Public Property VertexStatus As Byte
C# | public byte VertexStatus { get; set; }
C++ public:
property unsigned char VertexStatus {
unsigned char get();
void set(unsigned char value);
}
JScript public function get VertexStatus() : byte
public function set VertexStatus(byte);

Property Value

System.Byte
Vertex status. A value of 1 if the vertex has valid data, 0 if it is "full".

This property is read/write.


RasterCaps Structure (Microsoft.DirectX.Direct3D)

RasterCaps Structure

Contains information about raster drawing capabilities.

Definition

Visual Basic | Public Structure RasterCaps
C# | public struct RasterCaps
C++ | public value class RasterCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAnisotropy | Determines whether the device supports anisotropic filtering.
SupportsColorPerspective | Determines whether the device iterates color perspective correctly.
SupportsDepthBias | Determines whether the device supports legacy depth bias.
SupportsDither | Determines whether the device supports dithering to improve color resolution.
SupportsFogRange | Determines whether the device supports supports range-based fog.
SupportsFogTable | Determines whether the device supports using a fog table.
SupportsFogVertex | Determines whether the device supports vertex fog.
SupportsMipMapLevelOfDetailBias | Determines whether the device supports level of detail (LOD) bias adjustments.
SupportsMultisampleToggle | Determines whether the device supports toggling multisampling on and off between Device.BeginScene and Device.EndScene.
SupportsScissorTest | Determines whether the device supports scissor testing.
SupportsSlopeScaleDepthBias | Determines whether the device supports performing true slope scale-based depth bias.
SupportsWBuffer | Determines whether the device supports depth buffering using the w-buffer (w-buffering).
SupportsWFog | Determines whether the device supports w-based fog.
SupportsZBufferLessHsr | Determines whether a device can perform hidden-surface removal (HSR) without requiring the application to sort polygons and without requiring a depth buffer to be allocated.
SupportsZBufferTest | Determines whether the device can perform z-test operations.
SupportsZFog | Determines whether the device supports z-based fog.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RasterCaps.ToString() Method (Microsoft.DirectX.Direct3D)

RasterCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RasterCaps.SupportsAnisotropy Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsAnisotropy Property

Determines whether the device supports anisotropic filtering.

Definition

Visual Basic | Public ReadOnly Property SupportsAnisotropy As Boolean
C# | public bool SupportsAnisotropy { get; }
C++ public:
property bool SupportsAnisotropy {
bool get();
}
JScript | public function get SupportsAnisotropy() : boolean

Property Value

System.Boolean
Value that is true if the device supports anisotropic filtering, or false if it does not.

This property is read-only.


RasterCaps.SupportsColorPerspective Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsColorPerspective Property

Determines whether the device iterates color perspective correctly.

Definition

Visual Basic | Public ReadOnly Property SupportsColorPerspective As Boolean
C# | public bool SupportsColorPerspective { get; }
C++ public:
property bool SupportsColorPerspective {
bool get();
}
JScript | public function get SupportsColorPerspective() : boolean

Property Value

System.Boolean
Value that is true if the device supports iterating color perspective correctly, or false if it does not.

This property is read-only.


RasterCaps.SupportsDepthBias Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsDepthBias Property

Determines whether the device supports legacy depth bias.

Definition

Visual Basic | Public ReadOnly Property SupportsDepthBias As Boolean
C# | public bool SupportsDepthBias { get; }
C++ public:
property bool SupportsDepthBias {
bool get();
}
JScript | public function get SupportsDepthBias() : boolean

Property Value

System.Boolean
Value that is true if the device supports legacy depth bias, or false if it does not.

This property is read-only.


RasterCaps.SupportsDither Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsDither Property

Determines whether the device supports dithering to improve color resolution.

Definition

Visual Basic | Public ReadOnly Property SupportsDither As Boolean
C# | public bool SupportsDither { get; }
C++ public:
property bool SupportsDither {
bool get();
}
JScript | public function get SupportsDither() : boolean

Property Value

System.Boolean
Value that is true if the device supports dithering, or false if it does not.

This property is read-only.


RasterCaps.SupportsFogRange Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsFogRange Property

Determines whether the device supports supports range-based fog.

Definition

Visual Basic | Public ReadOnly Property SupportsFogRange As Boolean
C# | public bool SupportsFogRange { get; }
C++ public:
property bool SupportsFogRange {
bool get();
}
JScript | public function get SupportsFogRange() : boolean

Property Value

System.Boolean
Value that is true if the device supports range-based fog, or false if it does not.

This property is read-only.

Remarks

In range-based fog, the distance of an object from the viewer, not the depth of the object (that is, the z-coordinate) is used to compute fog effects in the scene.


RasterCaps.SupportsFogTable Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsFogTable Property

Determines whether the device supports using a fog table.

Definition

Visual Basic | Public ReadOnly Property SupportsFogTable As Boolean
C# | public bool SupportsFogTable { get; }
C++ public:
property bool SupportsFogTable {
bool get();
}
JScript | public function get SupportsFogTable() : boolean

Property Value

System.Boolean
Value that is true if the device supports using a fog table, or false if it does not.

This property is read-only.

Remarks

The device calculates the fog value by referring to a lookup table containing fog values that are indexed to the depth of a given pixel.


RasterCaps.SupportsFogVertex Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsFogVertex Property

Determines whether the device supports vertex fog.

Definition

Visual Basic | Public ReadOnly Property SupportsFogVertex As Boolean
C# | public bool SupportsFogVertex { get; }
C++ public:
property bool SupportsFogVertex {
bool get();
}
JScript | public function get SupportsFogVertex() : boolean

Property Value

System.Boolean
Value that is true if the device supports vertex fog, or false if it does not.

This property is read-only.

Remarks

The device calculates the fog value during the lighting operation and interpolates it during rasterization.


RasterCaps.SupportsMipMapLevelOfDetailBias Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsMipMapLevelOfDetailBias Property

Determines whether the device supports level of detail (LOD) bias adjustments.

Definition

Visual Basic | Public ReadOnly Property SupportsMipMapLevelOfDetailBias As Boolean
C# | public bool SupportsMipMapLevelOfDetailBias { get; }
C++ public:
property bool SupportsMipMapLevelOfDetailBias {
bool get();
}
JScript | public function get SupportsMipMapLevelOfDetailBias() : boolean

Property Value

System.Boolean
Value that is true if the device supports LOD bias adjustments, or false if it does not.

This property is read-only.

Remarks

LOD bias adjustments enable an application to make a mipmap appear crisper or less sharp than it normally would.

See Also

  • SamplerStateManager.MipMapLevelOfDetailBias


RasterCaps.SupportsMultisampleToggle Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsMultisampleToggle Property

Determines whether the device supports toggling multisampling on and off between Device.BeginScene and Device.EndScene.

Definition

Visual Basic | Public ReadOnly Property SupportsMultisampleToggle As Boolean
C# | public bool SupportsMultisampleToggle { get; }
C++ public:
property bool SupportsMultisampleToggle {
bool get();
}
JScript | public function get SupportsMultisampleToggle() : boolean

Property Value

System.Boolean
Value that is true if the device supports toggling multisampling on and off, or false if it does not.

This property is read-only.


RasterCaps.SupportsScissorTest Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsScissorTest Property

Determines whether the device supports scissor testing.

Definition

Visual Basic | Public ReadOnly Property SupportsScissorTest As Boolean
C# | public bool SupportsScissorTest { get; }
C++ public:
property bool SupportsScissorTest {
bool get();
}
JScript | public function get SupportsScissorTest() : boolean

Property Value

System.Boolean
Value that is true if the device supports scissor testing, or false if it does not.

This property is read-only.


RasterCaps.SupportsSlopeScaleDepthBias Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsSlopeScaleDepthBias Property

Determines whether the device supports performing true slope scale-based depth bias.

Definition

Visual Basic | Public ReadOnly Property SupportsSlopeScaleDepthBias As Boolean
C# | public bool SupportsSlopeScaleDepthBias { get; }
C++ public:
property bool SupportsSlopeScaleDepthBias {
bool get();
}
JScript | public function get SupportsSlopeScaleDepthBias() : boolean

Property Value

System.Boolean
Value that is true if the device supports true slope scale-based depth bias, or false if it does not.

This property is read-only.


RasterCaps.SupportsWBuffer Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsWBuffer Property

Determines whether the device supports depth buffering using the w-buffer (w-buffering).

Definition

Visual Basic | Public ReadOnly Property SupportsWBuffer As Boolean
C# | public bool SupportsWBuffer { get; }
C++ public:
property bool SupportsWBuffer {
bool get();
}
JScript | public function get SupportsWBuffer() : boolean

Property Value

System.Boolean
Value that is true if the device supports depth buffering using the w-buffer, or false if it does not.

This property is read-only.

See Also

  • Depth Buffers


RasterCaps.SupportsWFog Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsWFog Property

Determines whether the device supports w-based fog.

Definition

Visual Basic | Public ReadOnly Property SupportsWFog As Boolean
C# | public bool SupportsWFog { get; }
C++ public:
property bool SupportsWFog {
bool get();
}
JScript | public function get SupportsWFog() : boolean

Property Value

System.Boolean
Value that is true if the device supports w-based fog, or false if it does not.

This property is read-only.

Remarks

W-based fog is used when a perspective projection matrix is specified, but affine projections still use z-based fog. The system considers a projection matrix that contains a nonzero value in the [3][4] element to be a perspective projection matrix.


RasterCaps.SupportsZBufferLessHsr Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsZBufferLessHsr Property

Determines whether a device can perform hidden-surface removal (HSR) without requiring the application to sort polygons and without requiring a depth buffer to be allocated.

Definition

Visual Basic | Public ReadOnly Property SupportsZBufferLessHsr As Boolean
C# | public bool SupportsZBufferLessHsr { get; }
C++ public:
property bool SupportsZBufferLessHsr {
bool get();
}
JScript | public function get SupportsZBufferLessHsr() : boolean

Property Value

System.Boolean
Value that is true if the device supports bufferless HSR, or false if it does not.

This property is read-only.

Remarks

Z-bufferless HSR leaves more video memory for textures. The method used to perform HSR is hardware-dependent and transparent to the application.

Z-bufferless HSR is performed if no depth-buffer surface is associated with the render target surface and the depth-buffer comparison test is enabled (that is, when the state value associated with RenderStateManager.ZBufferEnable is set to true).


RasterCaps.SupportsZBufferTest Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsZBufferTest Property

Determines whether the device can perform z-test operations.

Definition

Visual Basic | Public ReadOnly Property SupportsZBufferTest As Boolean
C# | public bool SupportsZBufferTest { get; }
C++ public:
property bool SupportsZBufferTest {
bool get();
}
JScript | public function get SupportsZBufferTest() : boolean

Property Value

System.Boolean
Value that is true if the device can perform z-test operations, or false if it cannot.

This property is read-only.

Remarks

This property effectively renders a primitive and indicates whether any z pixels have been rendered.


RasterCaps.SupportsZFog Property (Microsoft.DirectX.Direct3D)

RasterCaps.SupportsZFog Property

Determines whether the device supports z-based fog.

Definition

Visual Basic | Public ReadOnly Property SupportsZFog As Boolean
C# | public bool SupportsZFog { get; }
C++ public:
property bool SupportsZFog {
bool get();
}
JScript | public function get SupportsZFog() : boolean

Property Value

System.Boolean
Value that is true if the device supports z-based fog, or false if it does not.

This property is read-only.


RasterStatus Structure (Microsoft.DirectX.Direct3D)

RasterStatus Structure

Describes the raster status.

Definition

Visual Basic | Public Structure RasterStatus
C# | public struct RasterStatus
C++ | public value class RasterStatus sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RasterStatus | Initializes a new instance of the RasterStatus class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
InVBlank | Retrieves or sets the status of the vertical blank period.
ScanLine | Retrieves or sets a value that roughly corresponds to the current scan line painted by the raster.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RasterStatus.RasterStatus() Constructor (Microsoft.DirectX.Direct3D)

RasterStatus.RasterStatus Constructor

Initializes a new instance of the RasterStatus class.

Definition

Visual Basic | Public Sub New()
C# | public RasterStatus();
C++ public:
RasterStatus();
JScript | public function RasterStatus();


RasterStatus.ToString() Method (Microsoft.DirectX.Direct3D)

RasterStatus.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RasterStatus.InVBlank Property (Microsoft.DirectX.Direct3D)

RasterStatus.InVBlank Property

Retrieves or sets the status of the vertical blank period.

Definition

Visual Basic | Public Property InVBlank As Boolean
C# | public bool InVBlank { get; set; }
C++ public:
property bool InVBlank {
bool get();
void set(bool value);
}
JScript public function get InVBlank() : boolean
public function set InVBlank(boolean);

Property Value

System.Boolean
Value that is true if the raster is in the vertical blank period, or false if it is not.

This property is read/write.


RasterStatus.ScanLine Property (Microsoft.DirectX.Direct3D)

RasterStatus.ScanLine Property

Retrieves or sets a value that roughly corresponds to the current scan line painted by the raster.

Definition

Visual Basic | Public Property ScanLine As Integer
C# | public int ScanLine { get; set; }
C++ public:
property int ScanLine {
int get();
void set(int value);
}
JScript public function get ScanLine() : int
public function set ScanLine(int);

Property Value

System.Int32
Integer that roughly corresponds to the current scan line to set or retrieve.

This property is read/write.

Remarks

If InVBlank is false, this property's value is an integer that roughly corresponds to the current scan line painted by the raster. Scan lines are numbered in the same way as Microsoft Direct3D surface coordinates: 0 is the top of the primary surface, extending to the value (height of the surface - 1) at the bottom of the display.

If InVBlank is true, this value is set to 0 and can be ignored.


RectanglePatchInformation Structure (Microsoft.DirectX.Direct3D)

RectanglePatchInformation Structure

Describes a rectangular high-order patch.

Definition

Visual Basic | Public Structure RectanglePatchInformation
C# | public struct RectanglePatchInformation
C++ | public value class RectanglePatchInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RectanglePatchInformation | Initializes a new instance of the RectanglePatchInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BasisType | Retrieves or sets a value of the BasisType enumeration that defines the basis type for the rectangular high-order patch.
Degree | Retrieves or sets a value of the DegreeType enumeration that defines the degree for the rectangular patch.
Height | Retrieves or sets the height of each vertex, in number of vertices.
StartVertexOffsetHeight | Retrieves or sets the starting vertex offset height, in number of vertices.
StartVertexOffsetWidth | Retrieves or sets the starting vertex offset width, in number of vertices.
Stride | Retrieves or sets the width of the imaginary two-dimensional vertex array, which occupies the same space as the vertex buffer.
Width | Retrieves or sets the width of each vertex, in number of vertices.

Remarks

The following diagram identifies the parameters that specify a rectangle patch.

Rectangle patch information

Each of the vertices in the vertex buffer is shown as a black dot. In this case, the vertex buffer has 20 vertices in it, 16 of which are in the rectangle patch. The stride (also called the pitch) is the number of vertices in the width of the vertex buffer (five in this case). The x offset to the first vertex is called the StartIndexVertexWidth and has a value of 1; the y offset is called the StartIndexVertexHeight and has a value of 0.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RectanglePatchInformation.RectanglePatchInformation() Constructor (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.RectanglePatchInformation Constructor

 Language:

Initializes a new instance of the RectanglePatchInformation class.

Definition

Visual Basic | Public Sub New()
C# | public RectanglePatchInformation();
C++ public:
RectanglePatchInformation();
JScript | public function RectanglePatchInformation();


RectanglePatchInformation.ToString() Method (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RectanglePatchInformation.BasisType Property (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.BasisType Property

Retrieves or sets a value of the BasisType enumeration that defines the basis type for the rectangular high-order patch.

Definition

Visual Basic | Public Property BasisType As BasisType
C# | public BasisType BasisType { get; set; }
C++ public:
property BasisType BasisType {
BasisType get();
void set(BasisType value);
}
JScript public function get BasisType() : BasisType
public function set BasisType(BasisType);

Property Value

Microsoft.DirectX.Direct3D.BasisType
Value of the BasisType enumeration to set or retrieve.

This property is read/write.

Remarks

Value | Order supported | Width and height
Bezier | Linear, cubic, and quintic | Width = height = order + 1
BSpline | Linear, cubic, and quintic | Width = height > order
CatMullRom | Cubic | Width = height > order


RectanglePatchInformation.Degree Property (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.Degree Property

Retrieves or sets a value of the DegreeType enumeration that defines the degree for the rectangular patch.

Definition

Visual Basic | Public Property Degree As DegreeType
C# | public DegreeType Degree { get; set; }
C++ public:
property DegreeType Degree {
DegreeType get();
void set(DegreeType value);
}
JScript public function get Degree() : DegreeType
public function set Degree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType
Value of the DegreeType enumeration to set or retrieve.

This property is read/write.


RectanglePatchInformation.Height Property (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.Height Property

Retrieves or sets the height of each vertex, in number of vertices.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer that represents the height, in number of vertices, of each vertex to set or retrieve.

This property is read/write.


RectanglePatchInformation.StartVertexOffsetHeight Property (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.StartVertexOffsetHeight Property

Retrieves or sets the starting vertex offset height, in number of vertices.

Definition

Visual Basic | Public Property StartVertexOffsetHeight As Integer
C# | public int StartVertexOffsetHeight { get; set; }
C++ public:
property int StartVertexOffsetHeight {
int get();
void set(int value);
}
JScript public function get StartVertexOffsetHeight() : int
public function set StartVertexOffsetHeight(int);

Property Value

System.Int32
Integer that represents the starting vertex offset height, in number of vertices, to set or retrieve.

This property is read/write.


RectanglePatchInformation.StartVertexOffsetWidth Property (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.StartVertexOffsetWidth Property

Retrieves or sets the starting vertex offset width, in number of vertices.

Definition

Visual Basic | Public Property StartVertexOffsetWidth As Integer
C# | public int StartVertexOffsetWidth { get; set; }
C++ public:
property int StartVertexOffsetWidth {
int get();
void set(int value);
}
JScript public function get StartVertexOffsetWidth() : int
public function set StartVertexOffsetWidth(int);

Property Value

System.Int32
Integer that represents the starting vertex offset width, in number of vertices, to set or retrieve.

This property is read/write.


RectanglePatchInformation.Stride Property (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.Stride Property

Retrieves or sets the width of the imaginary two-dimensional vertex array, which occupies the same space as the vertex buffer.

Definition

Visual Basic | Public Property Stride As Integer
C# | public int Stride { get; set; }
C++ public:
property int Stride {
int get();
void set(int value);
}
JScript public function get Stride() : int
public function set Stride(int);

Property Value

System.Int32
Integer that represents the width of the imaginary two-dimensional vertex array to set or retrieve.

This property is read/write.


RectanglePatchInformation.Width Property (Microsoft.DirectX.Direct3D)

RectanglePatchInformation.Width Property

Retrieves or sets the width of each vertex, in number of vertices.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer that represents the width, in number of vertices, of each vertex to set or retrieve.

This property is read/write.


RenderToEnvironmentDescription Structure (Microsoft.DirectX.Direct3D)

RenderToEnvironmentDescription Structure

Describes an off-screen render target.

Definition

Visual Basic | Public Structure RenderToEnvironmentDescription
C# | public struct RenderToEnvironmentDescription
C++ | public value class RenderToEnvironmentDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RenderToEnvironmentDescription | Initializes a new instance of the RenderToEnvironmentDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DepthStencil | Retrieves or sets a value that indicates whether the z-buffer is needed.
DepthStencilFormat | Retrieves or sets the depth stencil format.
Format | Retrieves or sets the color buffer format.
MipLevels | Retrieves or sets the maximum level of detail (LOD) number.
Size | Retrieves or sets the size of the render target.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RenderToEnvironmentDescription.RenderToEnvironmentDescription() Constructor (Microsoft.DirectX.Direct3D)

RenderToEnvironmentDescription.RenderToEnvironmentDescription Constructor

 Language:

Initializes a new instance of the RenderToEnvironmentDescription class.

Definition

Visual Basic | Public Sub New()
C# | public RenderToEnvironmentDescription();
C++ public:
RenderToEnvironmentDescription();
JScript | public function RenderToEnvironmentDescription();


RenderToEnvironmentDescription.ToString() Method (Microsoft.DirectX.Direct3D)

RenderToEnvironmentDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RenderToEnvironmentDescription.DepthStencil Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentDescription.DepthStencil Property

Retrieves or sets a value that indicates whether the z-buffer is needed.

Definition

Visual Basic | Public Property DepthStencil As Boolean
C# | public bool DepthStencil { get; set; }
C++ public:
property bool DepthStencil {
bool get();
void set(bool value);
}
JScript public function get DepthStencil() : boolean
public function set DepthStencil(boolean);

Property Value

System.Boolean
Value that is true if the z-buffer is needed, or false if it is not.

This property is read/write.


RenderToEnvironmentDescription.DepthStencilFormat Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentDescription.DepthStencilFormat Property

Retrieves or sets the depth stencil format.

Definition

Visual Basic | Public Property DepthStencilFormat As DepthFormat
C# | public DepthFormat DepthStencilFormat { get; set; }
C++ public:
property DepthFormat DepthStencilFormat {
DepthFormat get();
void set(DepthFormat value);
}
JScript public function get DepthStencilFormat() : DepthFormat
public function set DepthStencilFormat(DepthFormat);

Property Value

Microsoft.DirectX.Direct3D.DepthFormat
Value of the DepthFormat enumeration that describes the depth stencil format to set or retrieve.

This property is read/write.


RenderToEnvironmentDescription.Format Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentDescription.Format Property

Retrieves or sets the color buffer format.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
Value of the Format enumeration that describes the format of the color buffer to set or retrieve.

This property is read/write.


RenderToEnvironmentDescription.MipLevels Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentDescription.MipLevels Property

Retrieves or sets the maximum level of detail (LOD) number.

Definition

Visual Basic | Public Property MipLevels As Integer
C# | public int MipLevels { get; set; }
C++ public:
property int MipLevels {
int get();
void set(int value);
}
JScript public function get MipLevels() : int
public function set MipLevels(int);

Property Value

System.Int32
Integer that represents the maximum mipmap level to set or retrieve.

This property is read/write.


RenderToEnvironmentDescription.Size Property (Microsoft.DirectX.Direct3D)

RenderToEnvironmentDescription.Size Property

Retrieves or sets the size of the render target.

Definition

Visual Basic | Public Property Size As Integer
C# | public int Size { get; set; }
C++ public:
property int Size {
int get();
void set(int value);
}
JScript public function get Size() : int
public function set Size(int);

Property Value

System.Int32
Integer that represents the width and height, in pixels, of the render target to set or retrieve.

This property is read/write.


RenderToSurfaceDescription Structure (Microsoft.DirectX.Direct3D)

RenderToSurfaceDescription Structure

Describes a render surface.

Definition

Visual Basic | Public Structure RenderToSurfaceDescription
C# | public struct RenderToSurfaceDescription
C++ | public value class RenderToSurfaceDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RenderToSurfaceDescription | Initializes a new instance of the RenderToSurfaceDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DepthStencil | Retrieves or sets a value that specifies whether the render surface supports a depth stencil surface.
DepthStencilFormat | Retrieves or sets the depth stencil format of the render surface.
Format | Retrieves or sets the format of the render surface.
Height | Retrieves or sets the height of the render surface.
Width | Retrieves or sets the width of the render surface.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RenderToSurfaceDescription.RenderToSurfaceDescription() Constructor (Microsoft.DirectX.Direct3D)

RenderToSurfaceDescription.RenderToSurfaceDescription Constructor

 Language:

Initializes a new instance of the RenderToSurfaceDescription class.

Definition

Visual Basic | Public Sub New()
C# | public RenderToSurfaceDescription();
C++ public:
RenderToSurfaceDescription();
JScript | public function RenderToSurfaceDescription();


RenderToSurfaceDescription.ToString() Method (Microsoft.DirectX.Direct3D)

RenderToSurfaceDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RenderToSurfaceDescription.DepthStencil Property (Microsoft.DirectX.Direct3D)

RenderToSurfaceDescription.DepthStencil Property

Retrieves or sets a value that specifies whether the render surface supports a depth stencil surface.

Definition

Visual Basic | Public Property DepthStencil As Boolean
C# | public bool DepthStencil { get; set; }
C++ public:
property bool DepthStencil {
bool get();
void set(bool value);
}
JScript public function get DepthStencil() : boolean
public function set DepthStencil(boolean);

Property Value

System.Boolean
Value that is true if the render surface supports a depth stencil surface, or false if it does not.

This property is read/write.


RenderToSurfaceDescription.DepthStencilFormat Property (Microsoft.DirectX.Direct3D)

RenderToSurfaceDescription.DepthStencilFormat Property

Retrieves or sets the depth stencil format of the render surface.

Definition

Visual Basic | Public Property DepthStencilFormat As DepthFormat
C# | public DepthFormat DepthStencilFormat { get; set; }
C++ public:
property DepthFormat DepthStencilFormat {
DepthFormat get();
void set(DepthFormat value);
}
JScript public function get DepthStencilFormat() : DepthFormat
public function set DepthStencilFormat(DepthFormat);

Property Value

Microsoft.DirectX.Direct3D.DepthFormat
Value of the DepthFormat enumeration that describes the depth stencil format of the render surface to set or retrieve.

This property is read/write.


RenderToSurfaceDescription.Format Property (Microsoft.DirectX.Direct3D)

RenderToSurfaceDescription.Format Property

Retrieves or sets the format of the render surface.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
Value of the Format enumeration that describes the format of the render surface to set or retrieve.

This property is read/write.


RenderToSurfaceDescription.Height Property (Microsoft.DirectX.Direct3D)

RenderToSurfaceDescription.Height Property

Retrieves or sets the height of the render surface.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer that represents the height of the render surface in pixels.

This property is read/write.


RenderToSurfaceDescription.Width Property (Microsoft.DirectX.Direct3D)

RenderToSurfaceDescription.Width Property

Retrieves or sets the width of the render surface.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer that represents the width of the render surface in pixels.

This property is read/write.


ResourceManager Structure (Microsoft.DirectX.Direct3D)

ResourceManager Structure

Contains resource manager usage statistics.

Definition

Visual Basic | Public Structure ResourceManager
C# | public struct ResourceManager
C++ | public value class ResourceManager sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetStatistics | Retrieves an array of resource usage statistics.
ResourceManager | Initializes a new instance of the ResourceManager class.
ToString | Obtains a string representation of the current instance.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ResourceManager.GetStatistics() Method (Microsoft.DirectX.Direct3D)

ResourceManager.GetStatistics Method

Retrieves an array of resource usage statistics.

Definition

Visual Basic | Public Function GetStatistics() As ResourceStats()
C# | public ResourceStats[] GetStatistics();
C++ public:
array<ResourceStats>^ GetStatistics();
JScript | public function GetStatistics() : ResourceStats[];

Return Value

Microsoft.DirectX.Direct3D.ResourceStats[]
Array of ResourceStats structures that contain the usage statistics of the resource manager.


ResourceManager.ResourceManager() Constructor (Microsoft.DirectX.Direct3D)

ResourceManager.ResourceManager Constructor

Initializes a new instance of the ResourceManager class.

Definition

Visual Basic | Public Sub New()
C# | public ResourceManager();
C++ public:
ResourceManager();
JScript | public function ResourceManager();


ResourceManager.ToString() Method (Microsoft.DirectX.Direct3D)

ResourceManager.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ResourceStats Structure (Microsoft.DirectX.Direct3D)

ResourceStats Structure

Contains information about the resource manager.

Definition

Visual Basic | Public Structure ResourceStats
C# | public struct ResourceStats
C++ | public value class ResourceStats sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ResourceStats | Initializes a new instance of the ResourceStats class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ApproximateBytesDownloaded | Retrieves the approximate number of bytes downloaded by the resource manager.
LastObjectPriority | Retrieves the priority value of the last object evicted.
NumberEvicts | Retrieves the number of objects evicted.
NumberObjectsCreatedInVideoMemory | Retrieves the number of objects created in video memory.
NumberObjectsUsed | Retrieves the number of objects set to the device.
NumberObjectsUsedInVideoMemory | Retrieves the number of objects set to the device that are already in video memory.
Thrashing | Retrieves a value that indicates whether thrashing is occurring.
TotalManaged | Retrieves the total number of managed objects.
TotalManagedBytes | Retrieves the total number of bytes used by the managed objects.
WorkingSet | Retrieves the number of objects in video memory.
WorkingSetBytes | Retrieves the number of bytes in video memory.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ResourceStats.ResourceStats() Constructor (Microsoft.DirectX.Direct3D)

ResourceStats.ResourceStats Constructor

Initializes a new instance of the ResourceStats class.

Definition

Visual Basic | Public Sub New()
C# | public ResourceStats();
C++ public:
ResourceStats();
JScript | public function ResourceStats();


ResourceStats.ToString() Method (Microsoft.DirectX.Direct3D)

ResourceStats.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ResourceStats.ApproximateBytesDownloaded Property (Microsoft.DirectX.Direct3D)

ResourceStats.ApproximateBytesDownloaded Property

Retrieves the approximate number of bytes downloaded by the resource manager.

Definition

Visual Basic | Public ReadOnly Property ApproximateBytesDownloaded As Integer
C# | public int ApproximateBytesDownloaded { get; }
C++ public:
property int ApproximateBytesDownloaded {
int get();
}
JScript | public function get ApproximateBytesDownloaded() : int

Property Value

System.Int32
Integer that represents the approximate number of bytes downloaded.

This property is read-only.


ResourceStats.LastObjectPriority Property (Microsoft.DirectX.Direct3D)

ResourceStats.LastObjectPriority Property

Retrieves the priority value of the last object evicted.

Definition

Visual Basic | Public ReadOnly Property LastObjectPriority As Integer
C# | public int LastObjectPriority { get; }
C++ public:
property int LastObjectPriority {
int get();
}
JScript | public function get LastObjectPriority() : int

Property Value

System.Int32
Integer that represents the priority of the last object.

This property is read-only.


ResourceStats.NumberEvicts Property (Microsoft.DirectX.Direct3D)

ResourceStats.NumberEvicts Property

Retrieves the number of objects evicted.

Definition

Visual Basic | Public ReadOnly Property NumberEvicts As Integer
C# | public int NumberEvicts { get; }
C++ public:
property int NumberEvicts {
int get();
}
JScript | public function get NumberEvicts() : int

Property Value

System.Int32
Integer that represents the number of evicted objects.

This property is read-only.


ResourceStats.NumberObjectsCreatedInVideoMemory Property (Microsoft.DirectX.Direct3D)

ResourceStats.NumberObjectsCreatedInVideoMemory Property

Retrieves the number of objects created in video memory.

Definition

Visual Basic | Public ReadOnly Property NumberObjectsCreatedInVideoMemory As Integer
C# | public int NumberObjectsCreatedInVideoMemory { get; }
C++ public:
property int NumberObjectsCreatedInVideoMemory {
int get();
}
JScript | public function get NumberObjectsCreatedInVideoMemory() : int

Property Value

System.Int32
Integer that represents the number of objects created in video memory.

This property is read-only.


ResourceStats.NumberObjectsUsed Property (Microsoft.DirectX.Direct3D)

ResourceStats.NumberObjectsUsed Property

Retrieves the number of objects set to the device.

Definition

Visual Basic | Public ReadOnly Property NumberObjectsUsed As Integer
C# | public int NumberObjectsUsed { get; }
C++ public:
property int NumberObjectsUsed {
int get();
}
JScript | public function get NumberObjectsUsed() : int

Property Value

System.Int32
Integer that represents the number of objects set to the device.

This property is read-only.


ResourceStats.NumberObjectsUsedInVideoMemory Property (Microsoft.DirectX.Direct3D)

ResourceStats.NumberObjectsUsedInVideoMemory Property

Retrieves the number of objects set to the device that are already in video memory.

Definition

Visual Basic | Public ReadOnly Property NumberObjectsUsedInVideoMemory As Integer
C# | public int NumberObjectsUsedInVideoMemory { get; }
C++ public:
property int NumberObjectsUsedInVideoMemory {
int get();
}
JScript | public function get NumberObjectsUsedInVideoMemory() : int

Property Value

System.Int32
Integer that represents the number of objects already in video memory.

This property is read-only.


ResourceStats.Thrashing Property (Microsoft.DirectX.Direct3D)

ResourceStats.Thrashing Property

Retrieves a value that indicates whether thrashing is occurring.

Definition

Visual Basic | Public ReadOnly Property Thrashing As Boolean
C# | public bool Thrashing { get; }
C++ public:
property bool Thrashing {
bool get();
}
JScript | public function get Thrashing() : boolean

Property Value

System.Boolean
Value that is true if thrashing is occurring, or false if it is not.

This property is read-only.


ResourceStats.TotalManaged Property (Microsoft.DirectX.Direct3D)

ResourceStats.TotalManaged Property

Retrieves the total number of managed objects.

Definition

Visual Basic | Public ReadOnly Property TotalManaged As Integer
C# | public int TotalManaged { get; }
C++ public:
property int TotalManaged {
int get();
}
JScript | public function get TotalManaged() : int

Property Value

System.Int32
Integer that represents the total number of managed objects.

This property is read-only.


ResourceStats.TotalManagedBytes Property (Microsoft.DirectX.Direct3D)

ResourceStats.TotalManagedBytes Property

Retrieves the total number of bytes used by the managed objects.

Definition

Visual Basic | Public ReadOnly Property TotalManagedBytes As Integer
C# | public int TotalManagedBytes { get; }
C++ public:
property int TotalManagedBytes {
int get();
}
JScript | public function get TotalManagedBytes() : int

Property Value

System.Int32
Integer that represents the total number of bytes of managed objects.

This property is read-only.


ResourceStats.WorkingSet Property (Microsoft.DirectX.Direct3D)

ResourceStats.WorkingSet Property

Retrieves the number of objects in video memory.

Definition

Visual Basic | Public ReadOnly Property WorkingSet As Integer
C# | public int WorkingSet { get; }
C++ public:
property int WorkingSet {
int get();
}
JScript | public function get WorkingSet() : int

Property Value

System.Int32
Integer that represents the number of objects in video memory.

This property is read-only.


ResourceStats.WorkingSetBytes Property (Microsoft.DirectX.Direct3D)

ResourceStats.WorkingSetBytes Property

Retrieves the number of bytes in video memory.

Definition

Visual Basic | Public ReadOnly Property WorkingSetBytes As Integer
C# | public int WorkingSetBytes { get; }
C++ public:
property int WorkingSetBytes {
int get();
}
JScript | public function get WorkingSetBytes() : int

Property Value

System.Int32
Integer that represents the number of bytes in video memory.

This property is read-only.


ScaleRotateTranslate Structure (Microsoft.DirectX.Direct3D)

ScaleRotateTranslate Structure

Encapsulates scale, rotate and translate structures.

Definition

Visual Basic | Public Structure ScaleRotateTranslate
C# | public struct ScaleRotateTranslate
C++ | public value class ScaleRotateTranslate sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ScaleRotateTranslate | Initializes a new instance of the ScaleRotateTranslate class.

Properties

Property | Description
Rotation | Retrieves or sets a Quaternion structure.
Scaling | Retrieves or sets a Vector3 structure.
Translation | Retrieves or sets a Vector3 structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ScaleRotateTranslate.ScaleRotateTranslate() Constructor (Microsoft.DirectX.Direct3D)

ScaleRotateTranslate.ScaleRotateTranslate Constructor

Initializes a new instance of the ScaleRotateTranslate class.

Definition

Visual Basic | Public Sub New()
C# | public ScaleRotateTranslate();
C++ public:
ScaleRotateTranslate();
JScript | public function ScaleRotateTranslate();


ScaleRotateTranslate.Rotation Property (Microsoft.DirectX.Direct3D)

ScaleRotateTranslate.Rotation Property

Retrieves or sets a Quaternion structure.

Definition

Visual Basic | Public Property Rotation As Quaternion
C# | public Quaternion Rotation { get; set; }
C++ public:
property Quaternion Rotation {
Quaternion get();
void set(Quaternion value);
}
JScript public function get Rotation() : Quaternion
public function set Rotation(Quaternion);

Property Value

Microsoft.DirectX.Quaternion
A Quaternion structure that contains values used for rotation operations.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ScaleRotateTranslate.Scaling Property (Microsoft.DirectX.Direct3D)

ScaleRotateTranslate.Scaling Property

Retrieves or sets a Vector3 structure.

Definition

Visual Basic | Public Property Scaling As Vector3
C# | public Vector3 Scaling { get; set; }
C++ public:
property Vector3 Scaling {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Scaling() : Vector3
public function set Scaling(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 structure that contains values used for scaling operations.

This property is read/write.


ScaleRotateTranslate.Translation Property (Microsoft.DirectX.Direct3D)

ScaleRotateTranslate.Translation Property

Retrieves or sets a Vector3 structure.

Definition

Visual Basic | Public Property Translation As Vector3
C# | public Vector3 Translation { get; set; }
C++ public:
property Vector3 Translation {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Translation() : Vector3
public function set Translation(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 structure that contains values used for translation operations.

This property is read/write.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Semantic Structure (Microsoft.DirectX.Direct3D)

Semantic Structure

Maps a parameter to vertex or pixel shader registers.

Definition

Visual Basic | Public Structure Semantic
C# | public struct Semantic
C++ | public value class Semantic sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Semantic | Initializes a new instance of the Semantic class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Usage | Retrieves or sets options that identify how resources are used.
UsageIndex | Retrieves or sets options that modify how usage is interpreted.

Remarks

Semantics also can be used as optional descriptive strings attached to non-register parameters.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Semantic.Semantic() Constructor (Microsoft.DirectX.Direct3D)

Semantic.Semantic Constructor

Initializes a new instance of the Semantic class.

Definition

Visual Basic | Public Sub New()
C# | public Semantic();
C++ public:
Semantic();
JScript | public function Semantic();


Semantic.ToString() Method (Microsoft.DirectX.Direct3D)

Semantic.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Semantic.Usage Property (Microsoft.DirectX.Direct3D)

Semantic.Usage Property

Retrieves or sets options that identify how resources are used.

Definition

Visual Basic | Public Property Usage As Integer
C# | public int Usage { get; set; }
C++ public:
property int Usage {
int get();
void set(int value);
}
JScript public function get Usage() : int
public function set Usage(int);

Property Value

System.Int32
Integer that represents a value from the Usage enumeration that specifies how resources are used.

This property is read/write.


Semantic.UsageIndex Property (Microsoft.DirectX.Direct3D)

Semantic.UsageIndex Property

Retrieves or sets options that modify how usage is interpreted.

Definition

Visual Basic | Public Property UsageIndex As Integer
C# | public int UsageIndex { get; set; }
C++ public:
property int UsageIndex {
int get();
void set(int value);
}
JScript public function get UsageIndex() : int
public function set UsageIndex(int);

Property Value

System.Int32
Integer that represents the usage index value to set or retrieve.

This property is read/write.


ShadeCaps Structure (Microsoft.DirectX.Direct3D)

ShadeCaps Structure

Defines shading operation capabilities.

Definition

Visual Basic | Public Structure ShadeCaps
C# | public struct ShadeCaps
C++ | public value class ShadeCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAlphaGouraudBlend | Specifies whether the device supports an alpha component for Gouraud-blended transparency.
SupportsColorGouraudRgb | Specifies whether the device supports colored Gouraud shading in the RGB color model.
SupportsFogGouraud | Specifies whether the device supports fog in the Gouraud shading mode.
SupportsSpecularGouraudRgb | Specifies whether the device supports Gouraud shading of specular highlights.

Remarks

It is generally assumed that if a device supports a shading operation at all, it at least supports flat shading.

When alpha components are not supported, the alpha value of generated colors is implicitly 255. This is the maximum possible alpha (that is, the alpha component is at full intensity).

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShadeCaps.ToString() Method (Microsoft.DirectX.Direct3D)

ShadeCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShadeCaps.SupportsAlphaGouraudBlend Property (Microsoft.DirectX.Direct3D)

ShadeCaps.SupportsAlphaGouraudBlend Property

Specifies whether the device supports an alpha component for Gouraud-blended transparency.

Definition

Visual Basic | Public ReadOnly Property SupportsAlphaGouraudBlend As Boolean
C# | public bool SupportsAlphaGouraudBlend { get; }
C++ public:
property bool SupportsAlphaGouraudBlend {
bool get();
}
JScript | public function get SupportsAlphaGouraudBlend() : boolean

Property Value

System.Boolean
Value that is true if the device supports an alpha component for Gouraud-blended transparency, or false if it does not.

This property is read-only.

Remarks

In this mode, the alpha color component of a primitive is provided at vertices and interpolated across a face along with the other color components.


ShadeCaps.SupportsColorGouraudRgb Property (Microsoft.DirectX.Direct3D)

ShadeCaps.SupportsColorGouraudRgb Property

Specifies whether the device supports colored Gouraud shading in the RGB color model.

Definition

Visual Basic | Public ReadOnly Property SupportsColorGouraudRgb As Boolean
C# | public bool SupportsColorGouraudRgb { get; }
C++ public:
property bool SupportsColorGouraudRgb {
bool get();
}
JScript | public function get SupportsColorGouraudRgb() : boolean

Property Value

System.Boolean
Value that is true if the device supports colored Gouraud shading in the RGB color model, or false if it does not.

This property is read-only.

Remarks

In this mode, the color component for a primitive is provided at vertices and interpolated across a face along with the other color components. In the RGB lighting model, the red, green, and blue components are interpolated.


ShadeCaps.SupportsFogGouraud Property (Microsoft.DirectX.Direct3D)

ShadeCaps.SupportsFogGouraud Property

Specifies whether the device supports fog in the Gouraud shading mode.

Definition

Visual Basic | Public ReadOnly Property SupportsFogGouraud As Boolean
C# | public bool SupportsFogGouraud { get; }
C++ public:
property bool SupportsFogGouraud {
bool get();
}
JScript | public function get SupportsFogGouraud() : boolean

Property Value

System.Boolean
Value that is true if the device supports fog in the Gouraud shading mode, or false if it does not.

This property is read-only.


ShadeCaps.SupportsSpecularGouraudRgb Property (Microsoft.DirectX.Direct3D)

ShadeCaps.SupportsSpecularGouraudRgb Property

Specifies whether the device supports Gouraud shading of specular highlights.

Definition

Visual Basic | Public ReadOnly Property SupportsSpecularGouraudRgb As Boolean
C# | public bool SupportsSpecularGouraudRgb { get; }
C++ public:
property bool SupportsSpecularGouraudRgb {
bool get();
}
JScript | public function get SupportsSpecularGouraudRgb() : boolean

Property Value

System.Boolean
Value that is true if the device supports Gouraud shading of specular highlights, or false if it does not.

This property is read-only.


ShaderConstantInformation Structure (Microsoft.DirectX.Direct3D)

ShaderConstantInformation Structure

Contains shader constant information.

Definition

Visual Basic | Public Structure ShaderConstantInformation
C# | public struct ShaderConstantInformation
C++ | public value class ShaderConstantInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderConstantInformation | Initializes a new instance of the ShaderConstantInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DefaultValue | Retrieves or sets the offset, in bytes, to the string that contains the default value of the shader constant.
Name | Retrieves or sets the offset, in bytes, to the name of the shader constant.
RegisterCount | Retrieves or sets the number of registers.
RegisterIndex | Retrieves or sets the register index.
RegisterSet | Retrieves or sets a value from the RegisterSet enumeration that specifies the shader register data type.
TypeInformation | Retrieves or sets the offset, in bytes, to the type information of a shader constant.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderConstantInformation.ShaderConstantInformation() Constructor (Microsoft.DirectX.Direct3D)

ShaderConstantInformation.ShaderConstantInformation Constructor

 Language:

Initializes a new instance of the ShaderConstantInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderConstantInformation();
C++ public:
ShaderConstantInformation();
JScript | public function ShaderConstantInformation();


ShaderConstantInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderConstantInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderConstantInformation.DefaultValue Property (Microsoft.DirectX.Direct3D)

ShaderConstantInformation.DefaultValue Property

Retrieves or sets the offset, in bytes, to the string that contains the default value of the shader constant.

Definition

Visual Basic | Public Property DefaultValue As Integer
C# | public int DefaultValue { get; set; }
C++ public:
property int DefaultValue {
int get();
void set(int value);
}
JScript public function get DefaultValue() : int
public function set DefaultValue(int);

Property Value

System.Int32
Integer that represents the string offset of the shader constant default value.

This property is read/write.


ShaderConstantInformation.Name Property (Microsoft.DirectX.Direct3D)

ShaderConstantInformation.Name Property

Retrieves or sets the offset, in bytes, to the name of the shader constant.

Definition

Visual Basic | Public Property Name As Integer
C# | public int Name { get; set; }
C++ public:
property int Name {
int get();
void set(int value);
}
JScript public function get Name() : int
public function set Name(int);

Property Value

System.Int32
Integer that represents the shader constant name offset.

This property is read/write.


ShaderConstantInformation.RegisterCount Property (Microsoft.DirectX.Direct3D)

ShaderConstantInformation.RegisterCount Property

Retrieves or sets the number of registers.

Definition

Visual Basic | Public Property RegisterCount As Short
C# | public short RegisterCount { get; set; }
C++ public:
property short RegisterCount {
short get();
void set(short value);
}
JScript public function get RegisterCount() : short
public function set RegisterCount(short);

Property Value

System.Int16
Integer that represents the number of registers to set or retrieve.

This property is read/write.


ShaderConstantInformation.RegisterIndex Property (Microsoft.DirectX.Direct3D)

ShaderConstantInformation.RegisterIndex Property

Retrieves or sets the register index.

Definition

Visual Basic | Public Property RegisterIndex As Short
C# | public short RegisterIndex { get; set; }
C++ public:
property short RegisterIndex {
short get();
void set(short value);
}
JScript public function get RegisterIndex() : short
public function set RegisterIndex(short);

Property Value

System.Int16
Integer that represents the register index to set or retrieve.

This property is read/write.


ShaderConstantInformation.RegisterSet Property (Microsoft.DirectX.Direct3D)

ShaderConstantInformation.RegisterSet Property

Retrieves or sets a value from the RegisterSet enumeration that specifies the shader register data type.

Definition

Visual Basic | Public Property RegisterSet As Short
C# | public short RegisterSet { get; set; }
C++ public:
property short RegisterSet {
short get();
void set(short value);
}
JScript public function get RegisterSet() : short
public function set RegisterSet(short);

Property Value

System.Int16
Value from the RegisterSet enumeration to set or retrieve.

This property is read/write.


ShaderConstantInformation.TypeInformation Property (Microsoft.DirectX.Direct3D)

ShaderConstantInformation.TypeInformation Property

Retrieves or sets the offset, in bytes, to the type information of a shader constant.

Definition

Visual Basic | Public Property TypeInformation As Integer
C# | public int TypeInformation { get; set; }
C++ public:
property int TypeInformation {
int get();
void set(int value);
}
JScript public function get TypeInformation() : int
public function set TypeInformation(int);

Property Value

System.Int32
Integer that represents the offset to the type information.

This property is read/write.


ShaderConstantTable Structure (Microsoft.DirectX.Direct3D)

ShaderConstantTable Structure

Contains the shader constant table that is embedded inside the shader.

Definition

Visual Basic | Public Structure ShaderConstantTable
C# | public struct ShaderConstantTable
C++ | public value class ShaderConstantTable sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderConstantTable | Initializes a new instance of the ShaderConstantTable class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BuildInfo | Retrieves or sets the offset, in bytes, to the build information.
ConstantInformation | Retrieves or sets the offset, in bytes, to the constant information.
Constants | Retrieves or sets the number of constants.
Creator | Retrieves or sets the offset, in bytes, to the name of the effect creator.
Flags | Retrieves or sets one or more values from the ShaderFlags enumeration that specify the compiler flags used to build the shader.
Size | Retrieves or sets the size of a constant.
Target | Retrieves or sets the offset, in bytes, into the string that contains the target.
Version | Retrieves or sets the shader version.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderConstantTable.ShaderConstantTable() Constructor (Microsoft.DirectX.Direct3D)

ShaderConstantTable.ShaderConstantTable Constructor

Initializes a new instance of the ShaderConstantTable class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderConstantTable();
C++ public:
ShaderConstantTable();
JScript | public function ShaderConstantTable();


ShaderConstantTable.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderConstantTable.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderConstantTable.BuildInfo Property (Microsoft.DirectX.Direct3D)

ShaderConstantTable.BuildInfo Property

Retrieves or sets the offset, in bytes, to the build information.

Definition

Visual Basic | Public Property BuildInfo As Integer
C# | public int BuildInfo { get; set; }
C++ public:
property int BuildInfo {
int get();
void set(int value);
}
JScript public function get BuildInfo() : int
public function set BuildInfo(int);

Property Value

System.Int32
Integer that represents the offset to the build information.

This property is read/write.


ShaderConstantTable.ConstantInformation Property (Microsoft.DirectX.Direct3D)

ShaderConstantTable.ConstantInformation Property

Retrieves or sets the offset, in bytes, to the constant information.

Definition

Visual Basic | Public Property ConstantInformation As Integer
C# | public int ConstantInformation { get; set; }
C++ public:
property int ConstantInformation {
int get();
void set(int value);
}
JScript public function get ConstantInformation() : int
public function set ConstantInformation(int);

Property Value

System.Int32
Integer that represents the offset to the constant information.

This property is read/write.


ShaderConstantTable.Constants Property (Microsoft.DirectX.Direct3D)

ShaderConstantTable.Constants Property

Retrieves or sets the number of constants.

Definition

Visual Basic | Public Property Constants As Integer
C# | public int Constants { get; set; }
C++ public:
property int Constants {
int get();
void set(int value);
}
JScript public function get Constants() : int
public function set Constants(int);

Property Value

System.Int32
Integer that represents the number of constants to set or retrieve.

This property is read/write.


ShaderConstantTable.Creator Property (Microsoft.DirectX.Direct3D)

ShaderConstantTable.Creator Property

Retrieves or sets the offset, in bytes, to the name of the effect creator.

Definition

Visual Basic | Public Property Creator As Integer
C# | public int Creator { get; set; }
C++ public:
property int Creator {
int get();
void set(int value);
}
JScript public function get Creator() : int
public function set Creator(int);

Property Value

System.Int32
Integer that represents the offset to the effect creator name.

This property is read/write.


ShaderConstantTable.Flags Property (Microsoft.DirectX.Direct3D)

ShaderConstantTable.Flags Property

Retrieves or sets one or more values from the ShaderFlags enumeration that specify the compiler flags used to build the shader.

Definition

Visual Basic | Public Property Flags As ShaderFlags
C# | public ShaderFlags Flags { get; set; }
C++ public:
property ShaderFlags Flags {
ShaderFlags get();
void set(ShaderFlags value);
}
JScript public function get Flags() : ShaderFlags
public function set Flags(ShaderFlags);

Property Value

Microsoft.DirectX.Direct3D.ShaderFlags
One or more values of the ShaderFlags enumeration to set or retrieve.

This property is read/write.


ShaderConstantTable.Size Property (Microsoft.DirectX.Direct3D)

ShaderConstantTable.Size Property

Retrieves or sets the size of a constant.

Definition

Visual Basic | Public Property Size As Integer
C# | public int Size { get; set; }
C++ public:
property int Size {
int get();
void set(int value);
}
JScript public function get Size() : int
public function set Size(int);

Property Value

System.Int32
Integer that represents the size of the constant.

This property is read/write.

Remarks

Shader constant information is included in a tab-delimited table of comments. All offsets are measured in bytes from the beginning of the structure. Entries in the constant table are sorted by Creator in ascending order.


ShaderConstantTable.Target Property (Microsoft.DirectX.Direct3D)

ShaderConstantTable.Target Property

Retrieves or sets the offset, in bytes, into the string that contains the target.

Definition

Visual Basic | Public Property Target As Integer
C# | public int Target { get; set; }
C++ public:
property int Target {
int get();
void set(int value);
}
JScript public function get Target() : int
public function set Target(int);

Property Value

System.Int32
Integer that represents the string offset of the target.

This property is read/write.


ShaderConstantTable.Version Property (Microsoft.DirectX.Direct3D)

ShaderConstantTable.Version Property

Retrieves or sets the shader version.

Definition

Visual Basic | Public Property Version As Integer
C# | public int Version { get; set; }
C++ public:
property int Version {
int get();
void set(int value);
}
JScript public function get Version() : int
public function set Version(int);

Property Value

System.Int32
Integer that represents the shader version.

This property is read/write.


ShaderDebugInformation Structure (Microsoft.DirectX.Direct3D)

ShaderDebugInformation Structure

Contains shader debug information.

Definition

Visual Basic | Public Structure ShaderDebugInformation
C# | public struct ShaderDebugInformation
C++ | public value class ShaderDebugInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderDebugInformation | Initializes a new instance of the ShaderDebugInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Creator | Retrieves or sets the offset to the shader creator information.
EntryPointName | Retrieves or sets the offset to the entry-point name.
FileInformation | Retrieves or sets the offset to the shader file information.
Files | Retrieves or sets the number of source files.
InstructionInformation | Retrieves or sets the offset, in bytes, from the start of the structure to the instructions.
Instructions | Retrieves or sets the number of instructions.
Size | Retrieves or sets the size, in bytes, of the debug information structure.
SourceCode | Retrieves or sets the offset, in bytes, from the start of the structure to the source code.
VariableInformation | Retrieves or sets the offset, in bytes, from the start of the structure to the variable information.
Variables | Retrieves or sets the number of variables.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderDebugInformation.ShaderDebugInformation() Constructor (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.ShaderDebugInformation Constructor

Initializes a new instance of the ShaderDebugInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderDebugInformation();
C++ public:
ShaderDebugInformation();
JScript | public function ShaderDebugInformation();


ShaderDebugInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderDebugInformation.Creator Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.Creator Property

Retrieves or sets the offset to the shader creator information.

Definition

Visual Basic | Public Property Creator As Integer
C# | public int Creator { get; set; }
C++ public:
property int Creator {
int get();
void set(int value);
}
JScript public function get Creator() : int
public function set Creator(int);

Property Value

System.Int32
Integer that represents the offset to the shader creator information.

This property is read/write.


ShaderDebugInformation.EntryPointName Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.EntryPointName Property

Retrieves or sets the offset to the entry-point name.

Definition

Visual Basic | Public Property EntryPointName As Integer
C# | public int EntryPointName { get; set; }
C++ public:
property int EntryPointName {
int get();
void set(int value);
}
JScript public function get EntryPointName() : int
public function set EntryPointName(int);

Property Value

System.Int32
Integer that represents the offset to the entry-point name.

This property is read/write.


ShaderDebugInformation.FileInformation Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.FileInformation Property

Retrieves or sets the offset to the shader file information.

Definition

Visual Basic | Public Property FileInformation As Integer
C# | public int FileInformation { get; set; }
C++ public:
property int FileInformation {
int get();
void set(int value);
}
JScript public function get FileInformation() : int
public function set FileInformation(int);

Property Value

System.Int32
Integer that represents the offset to the shader file information.

This property is read/write.


ShaderDebugInformation.Files Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.Files Property

Retrieves or sets the number of source files.

Definition

Visual Basic | Public Property Files As Integer
C# | public int Files { get; set; }
C++ public:
property int Files {
int get();
void set(int value);
}
JScript public function get Files() : int
public function set Files(int);

Property Value

System.Int32
Integer that represents the number of source files to set or retrieve.

This property is read/write.


ShaderDebugInformation.InstructionInformation Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.InstructionInformation Property

Retrieves or sets the offset, in bytes, from the start of the structure to the instructions.

Definition

Visual Basic | Public Property InstructionInformation As Integer
C# | public int InstructionInformation { get; set; }
C++ public:
property int InstructionInformation {
int get();
void set(int value);
}
JScript public function get InstructionInformation() : int
public function set InstructionInformation(int);

Property Value

System.Int32
Integer that represents the offset to the instructions to set or retrieve.

This property is read/write.


ShaderDebugInformation.Instructions Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.Instructions Property

Retrieves or sets the number of instructions.

Definition

Visual Basic | Public Property Instructions As Integer
C# | public int Instructions { get; set; }
C++ public:
property int Instructions {
int get();
void set(int value);
}
JScript public function get Instructions() : int
public function set Instructions(int);

Property Value

System.Int32
Integer that represents the number of instructions to set or retrieve.

This property is read/write.


ShaderDebugInformation.Size Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.Size Property

Retrieves or sets the size, in bytes, of the debug information structure.

Definition

Visual Basic | Public Property Size As Integer
C# | public int Size { get; set; }
C++ public:
property int Size {
int get();
void set(int value);
}
JScript public function get Size() : int
public function set Size(int);

Property Value

System.Int32
Integer that represents the size of the debug information structure.

This property is read/write.


ShaderDebugInformation.SourceCode Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.SourceCode Property

Retrieves or sets the offset, in bytes, from the start of the structure to the source code.

Definition

Visual Basic | Public Property SourceCode As Integer
C# | public int SourceCode { get; set; }
C++ public:
property int SourceCode {
int get();
void set(int value);
}
JScript public function get SourceCode() : int
public function set SourceCode(int);

Property Value

System.Int32
Integer that represents the offset to the source code.

This property is read/write.


ShaderDebugInformation.VariableInformation Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.VariableInformation Property

Retrieves or sets the offset, in bytes, from the start of the structure to the variable information.

Definition

Visual Basic | Public Property VariableInformation As Integer
C# | public int VariableInformation { get; set; }
C++ public:
property int VariableInformation {
int get();
void set(int value);
}
JScript public function get VariableInformation() : int
public function set VariableInformation(int);

Property Value

System.Int32
Integer that represents the offset to the variable information.

This property is read/write.


ShaderDebugInformation.Variables Property (Microsoft.DirectX.Direct3D)

ShaderDebugInformation.Variables Property

Retrieves or sets the number of variables.

Definition

Visual Basic | Public Property Variables As Integer
C# | public int Variables { get; set; }
C++ public:
property int Variables {
int get();
void set(int value);
}
JScript public function get Variables() : int
public function set Variables(int);

Property Value

System.Int32
Integer that represents the number of variables to set or retrieve.

This property is read/write.


ShaderFileInformation Structure (Microsoft.DirectX.Direct3D)

ShaderFileInformation Structure

Contains information about the shader file.

Definition

Visual Basic | Public Structure ShaderFileInformation
C# | public struct ShaderFileInformation
C++ | public value class ShaderFileInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderFileInformation | Initializes a new instance of the ShaderFileInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Name | Retrieves or sets the offset, in bytes, to the shader name.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderFileInformation.ShaderFileInformation() Constructor (Microsoft.DirectX.Direct3D)

ShaderFileInformation.ShaderFileInformation Constructor

Initializes a new instance of the ShaderFileInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderFileInformation();
C++ public:
ShaderFileInformation();
JScript | public function ShaderFileInformation();


ShaderFileInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderFileInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderFileInformation.Name Property (Microsoft.DirectX.Direct3D)

ShaderFileInformation.Name Property

Retrieves or sets the offset, in bytes, to the shader name.

Definition

Visual Basic | Public Property Name As Integer
C# | public int Name { get; set; }
C++ public:
property int Name {
int get();
void set(int value);
}
JScript public function get Name() : int
public function set Name(int);

Property Value

System.Int32
Integer that represents the shader name offset.

This property is read/write.


ShaderInstructionInformation Structure (Microsoft.DirectX.Direct3D)

ShaderInstructionInformation Structure

Contains data for retrieving shader instruction information.

Definition

Visual Basic | Public Structure ShaderInstructionInformation
C# | public struct ShaderInstructionInformation
C++ | public value class ShaderInstructionInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderInstructionInformation | Initializes a new instance of the ShaderInstructionInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
File | Retrieves or sets the offset, in bytes, from the beginning of the debug information to the file-name string.
Line | Retrieves or sets the shader line number that contains the instruction.
Offset | Retrieves or sets the offset for the shader instruction.

Remarks

This structure is used to maintain information about a shader instruction, such as the offset of the file name string or the offset of the point at which the instruction begins.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderInstructionInformation.ShaderInstructionInformation() Constructor (Microsoft.DirectX.Direct3D)

ShaderInstructionInformation.ShaderInstructionInformation Constructor

 Language:

Initializes a new instance of the ShaderInstructionInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderInstructionInformation();
C++ public:
ShaderInstructionInformation();
JScript | public function ShaderInstructionInformation();


ShaderInstructionInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderInstructionInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderInstructionInformation.File Property (Microsoft.DirectX.Direct3D)

ShaderInstructionInformation.File Property

Retrieves or sets the offset, in bytes, from the beginning of the debug information to the file-name string.

Definition

Visual Basic | Public Property File As Short
C# | public short File { get; set; }
C++ public:
property short File {
short get();
void set(short value);
}
JScript public function get File() : short
public function set File(short);

Property Value

System.Int16
Integer that represents the file-name string offset in bytes.

This property is read/write.


ShaderInstructionInformation.Line Property (Microsoft.DirectX.Direct3D)

ShaderInstructionInformation.Line Property

Retrieves or sets the shader line number that contains the instruction.

Definition

Visual Basic | Public Property Line As Short
C# | public short Line { get; set; }
C++ public:
property short Line {
short get();
void set(short value);
}
JScript public function get Line() : short
public function set Line(short);

Property Value

System.Int16
Integer that represents the shader instruction line number to set or retrieve.

This property is read/write.


ShaderInstructionInformation.Offset Property (Microsoft.DirectX.Direct3D)

ShaderInstructionInformation.Offset Property

Retrieves or sets the offset for the shader instruction.

Definition

Visual Basic | Public Property Offset As Integer
C# | public int Offset { get; set; }
C++ public:
property int Offset {
int get();
void set(int value);
}
JScript public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32
Integer that represents the shader instruction offset.

This property is read/write.


ShaderStructMemberInformation Structure (Microsoft.DirectX.Direct3D)

ShaderStructMemberInformation Structure

Contains the shader structure member information.

Definition

Visual Basic | Public Structure ShaderStructMemberInformation
C# | public struct ShaderStructMemberInformation
C++ | public value class ShaderStructMemberInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderStructMemberInformation | Initializes a new instance of the ShaderStructMemberInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Name | Retrieves or sets the shader structure member name.
TypeInformation | Retrieves or sets the offset of the string that contains the type information.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderStructMemberInformation.ShaderStructMemberInformation() Constructor (Microsoft.DirectX.Direct3D)

ShaderStructMemberInformation.ShaderStructMemberInformation Constructor

 Language:

Initializes a new instance of the ShaderStructMemberInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderStructMemberInformation();
C++ public:
ShaderStructMemberInformation();
JScript | public function ShaderStructMemberInformation();


ShaderStructMemberInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderStructMemberInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderStructMemberInformation.Name Property (Microsoft.DirectX.Direct3D)

ShaderStructMemberInformation.Name Property

Retrieves or sets the shader structure member name.

Definition

Visual Basic | Public Property Name As Integer
C# | public int Name { get; set; }
C++ public:
property int Name {
int get();
void set(int value);
}
JScript public function get Name() : int
public function set Name(int);

Property Value

System.Int32
Integer that represents the offset of the structure member name.

This property is read/write.


ShaderStructMemberInformation.TypeInformation Property (Microsoft.DirectX.Direct3D)

ShaderStructMemberInformation.TypeInformation Property

Retrieves or sets the offset of the string that contains the type information.

Definition

Visual Basic | Public Property TypeInformation As Integer
C# | public int TypeInformation { get; set; }
C++ public:
property int TypeInformation {
int get();
void set(int value);
}
JScript public function get TypeInformation() : int
public function set TypeInformation(int);

Property Value

System.Int32
Integer that represents the offset of the type information string.

This property is read/write.


ShaderTypeInformation Structure (Microsoft.DirectX.Direct3D)

ShaderTypeInformation Structure

Contains shader type information.

Definition

Visual Basic | Public Structure ShaderTypeInformation
C# | public struct ShaderTypeInformation
C++ | public value class ShaderTypeInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderTypeInformation | Initializes a new instance of the ShaderTypeInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Class | Retrieves or sets the class for shader type information.
Columns | Retrieves or sets the number of columns for vectors and matrices.
Elements | Retrieves or sets the number of elements, or the array dimensions, for the shader type information.
StructMemberInformation | Retrieves or sets the offset of the structure member information.
StructMembers | Retrieves or sets the number of structure members.
Type | Retrieves or sets the type for shader type information.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderTypeInformation.ShaderTypeInformation() Constructor (Microsoft.DirectX.Direct3D)

ShaderTypeInformation.ShaderTypeInformation Constructor

Initializes a new instance of the ShaderTypeInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderTypeInformation();
C++ public:
ShaderTypeInformation();
JScript | public function ShaderTypeInformation();


ShaderTypeInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderTypeInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderTypeInformation.Class Property (Microsoft.DirectX.Direct3D)

ShaderTypeInformation.Class Property

Retrieves or sets the class for shader type information.

Definition

Visual Basic | Public Property Class As Short
C# | public short Class { get; set; }
C++ public:
property short Class {
short get();
void set(short value);
}
JScript public function get Class() : short
public function set Class(short);

Property Value

System.Int16
Member of the ParameterClass enumeration that represents the class of the object.

This property is read/write.


ShaderTypeInformation.Columns Property (Microsoft.DirectX.Direct3D)

ShaderTypeInformation.Columns Property

Retrieves or sets the number of columns for vectors and matrices.

Definition

Visual Basic | Public Property Columns As Short
C# | public short Columns { get; set; }
C++ public:
property short Columns {
short get();
void set(short value);
}
JScript public function get Columns() : short
public function set Columns(short);

Property Value

System.Int16
Integer that represents the number of columns.

This property is read/write.


ShaderTypeInformation.Elements Property (Microsoft.DirectX.Direct3D)

ShaderTypeInformation.Elements Property

Retrieves or sets the number of elements, or the array dimensions, for the shader type information.

Definition

Visual Basic | Public Property Elements As Short
C# | public short Elements { get; set; }
C++ public:
property short Elements {
short get();
void set(short value);
}
JScript public function get Elements() : short
public function set Elements(short);

Property Value

System.Int16
Integer that represents the number of elements in the array.

This property is read/write.


ShaderTypeInformation.StructMemberInformation Property (Microsoft.DirectX.Direct3D)

ShaderTypeInformation.StructMemberInformation Property

Retrieves or sets the offset of the structure member information.

Definition

Visual Basic | Public Property StructMemberInformation As Integer
C# | public int StructMemberInformation { get; set; }
C++ public:
property int StructMemberInformation {
int get();
void set(int value);
}
JScript public function get StructMemberInformation() : int
public function set StructMemberInformation(int);

Property Value

System.Int32
Integer that represents the offset.

This property is read/write.


ShaderTypeInformation.StructMembers Property (Microsoft.DirectX.Direct3D)

ShaderTypeInformation.StructMembers Property

Retrieves or sets the number of structure members.

Definition

Visual Basic | Public Property StructMembers As Short
C# | public short StructMembers { get; set; }
C++ public:
property short StructMembers {
short get();
void set(short value);
}
JScript public function get StructMembers() : short
public function set StructMembers(short);

Property Value

System.Int16
Integer that represents the number of structure members.

This property is read/write.


ShaderTypeInformation.Type Property (Microsoft.DirectX.Direct3D)

ShaderTypeInformation.Type Property

Retrieves or sets the type for shader type information.

Definition

Visual Basic | Public Property Type As Short
C# | public short Type { get; set; }
C++ public:
property short Type {
short get();
void set(short value);
}
JScript public function get Type() : short
public function set Type(short);

Property Value

System.Int16
Member of the ParameterType enumeration that represents the type of the object.

This property is read/write.


ShaderVariableInformation Structure (Microsoft.DirectX.Direct3D)

ShaderVariableInformation Structure

Contains shader variable information.

Definition

Visual Basic | Public Structure ShaderVariableInformation
C# | public struct ShaderVariableInformation
C++ | public value class ShaderVariableInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderVariableInformation | Initializes a new instance of the ShaderVariableInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Name | Retrieves or sets the shader variable name.
Scope | Retrieves or sets the scope of the shader variable.
TypeInformation | Retrieves or sets the type of the shader variable.
WriteInformation | Retrieves or sets the write information for the variable.
Writes | Retrieves or sets the number of writes.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderVariableInformation.ShaderVariableInformation() Constructor (Microsoft.DirectX.Direct3D)

ShaderVariableInformation.ShaderVariableInformation Constructor

 Language:

Initializes a new instance of the ShaderVariableInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderVariableInformation();
C++ public:
ShaderVariableInformation();
JScript | public function ShaderVariableInformation();


ShaderVariableInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderVariableInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderVariableInformation.Name Property (Microsoft.DirectX.Direct3D)

ShaderVariableInformation.Name Property

Retrieves or sets the shader variable name.

Definition

Visual Basic | Public Property Name As Integer
C# | public int Name { get; set; }
C++ public:
property int Name {
int get();
void set(int value);
}
JScript public function get Name() : int
public function set Name(int);

Property Value

System.Int32
Integer that represents the offset of the shader variable name.

This property is read/write.


ShaderVariableInformation.Scope Property (Microsoft.DirectX.Direct3D)

ShaderVariableInformation.Scope Property

Retrieves or sets the scope of the shader variable.

Definition

Visual Basic | Public Property Scope As Integer
C# | public int Scope { get; set; }
C++ public:
property int Scope {
int get();
void set(int value);
}
JScript public function get Scope() : int
public function set Scope(int);

Property Value

System.Int32
Integer that represents the scope identifier.

This property is read/write.


ShaderVariableInformation.TypeInformation Property (Microsoft.DirectX.Direct3D)

ShaderVariableInformation.TypeInformation Property

Retrieves or sets the type of the shader variable.

Definition

Visual Basic | Public Property TypeInformation As Integer
C# | public int TypeInformation { get; set; }
C++ public:
property int TypeInformation {
int get();
void set(int value);
}
JScript public function get TypeInformation() : int
public function set TypeInformation(int);

Property Value

System.Int32
Integer that represents the offset of the shader-variable type information.

This property is read/write.


ShaderVariableInformation.WriteInformation Property (Microsoft.DirectX.Direct3D)

ShaderVariableInformation.WriteInformation Property

Retrieves or sets the write information for the variable.

Definition

Visual Basic | Public Property WriteInformation As Integer
C# | public int WriteInformation { get; set; }
C++ public:
property int WriteInformation {
int get();
void set(int value);
}
JScript public function get WriteInformation() : int
public function set WriteInformation(int);

Property Value

System.Int32
Integer that represents the offset of the write information.

This property is read/write.


ShaderVariableInformation.Writes Property (Microsoft.DirectX.Direct3D)

ShaderVariableInformation.Writes Property

Retrieves or sets the number of writes.

Definition

Visual Basic | Public Property Writes As Integer
C# | public int Writes { get; set; }
C++ public:
property int Writes {
int get();
void set(int value);
}
JScript public function get Writes() : int
public function set Writes(int);

Property Value

System.Int32
Integer that represents the number of writes.

This property is read/write.


ShaderWriteInformation Structure (Microsoft.DirectX.Direct3D)

ShaderWriteInformation Structure

Contains the shader write information.

Definition

Visual Basic | Public Structure ShaderWriteInformation
C# | public struct ShaderWriteInformation
C++ | public value class ShaderWriteInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ShaderWriteInformation | Initializes a new instance of the ShaderWriteInformation class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Instruction | Retrieves or sets the shader instruction to write.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ShaderWriteInformation.ShaderWriteInformation() Constructor (Microsoft.DirectX.Direct3D)

ShaderWriteInformation.ShaderWriteInformation Constructor

Initializes a new instance of the ShaderWriteInformation class.

Definition

Visual Basic | Public Sub New()
C# | public ShaderWriteInformation();
C++ public:
ShaderWriteInformation();
JScript | public function ShaderWriteInformation();


ShaderWriteInformation.ToString() Method (Microsoft.DirectX.Direct3D)

ShaderWriteInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ShaderWriteInformation.Instruction Property (Microsoft.DirectX.Direct3D)

ShaderWriteInformation.Instruction Property

Retrieves or sets the shader instruction to write.

Definition

Visual Basic | Public Property Instruction As Integer
C# | public int Instruction { get; set; }
C++ public:
property int Instruction {
int get();
void set(int value);
}
JScript public function get Instruction() : int
public function set Instruction(int);

Property Value

System.Int32
Integer that represents the shader instruction to set or retrieve.

This property is read/write.


SkinMesh Structure (Microsoft.DirectX.Direct3D)

SkinMesh Structure

Contains skin information and mesh data.

Definition

Visual Basic | Public Structure SkinMesh
C# | public struct SkinMesh
C++ | public value class SkinMesh sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) FromX | Loads skin information and mesh data from a Microsoft Direct3D .x file data object.
SkinMesh | Initializes a new instance of the SkinMesh class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Mesh | Retrieves or sets the Mesh object associated with the current skin information.
SkinInformation | Retrieves or sets the SkinInformation object used for skinning.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SkinMesh.FromX Method ()

Loads skin information and mesh data from a Microsoft Direct3D .x file data object.

Overload List

public static SkinMesh FromX(XFileData, MeshFlags, Device);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out ExtendedMaterial, out EffectInstance);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out GraphicsStream);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out EffectInstance);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial);
public static SkinMesh FromX(XFileData, MeshFlags, Device, out GraphicsStream, out ExtendedMaterial, out EffectInstance);

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

SkinMesh.FromX Method

Loads skin information and mesh data from a Microsoft Direct3D .x file data object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static SkinMesh FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
materials : ExtendedMaterial,
effects : EffectInstance
) : SkinMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the Microsoft DirectX file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags enumeration that specifies creation options for the mesh.
device Microsoft.DirectX.Direct3D.Device
A Device object associated with the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial objects loaded from the .x file data object.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh
A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,EffectInstance) Method (Microsoft.DirectX.Direct3D)

SkinMesh.FromX Method

Loads skin information and mesh data from a Microsoft Direct3D .x file data object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef effects As EffectInstance _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out EffectInstance effects
);
C++ public:
static SkinMesh FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
effects : EffectInstance
) : SkinMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the Microsoft DirectX file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags enumeration that specifies creation options for the mesh.
device Microsoft.DirectX.Direct3D.Device
A Device object associated with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object representing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh
A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,ExtendedMaterial) Method (Microsoft.DirectX.Direct3D)

SkinMesh.FromX Method

Loads skin information and mesh data from a Microsoft Direct3D .x file data object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials
);
C++ public:
static SkinMesh FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] ExtendedMaterial% materials
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial
) : SkinMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the Microsoft DirectX file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags enumeration that specifies creation options for the mesh.
device Microsoft.DirectX.Direct3D.Device
A Device object associated with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object representing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial objects loaded from the .x file data object.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh
A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,GraphicsStream) Method (Microsoft.DirectX.Direct3D)

SkinMesh.FromX Method

Loads skin information and mesh data from a Microsoft Direct3D .x file data object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency
);
C++ public:
static SkinMesh FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream
) : SkinMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the Microsoft DirectX file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags enumeration that specifies creation options for the mesh.
device Microsoft.DirectX.Direct3D.Device
A Device object associated with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object representing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh
A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device) Method (Microsoft.DirectX.Direct3D)

SkinMesh.FromX Method

Loads skin information and mesh data from a Microsoft Direct3D .x file data object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device
);
C++ public:
static SkinMesh FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device
) : SkinMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the Microsoft DirectX file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags enumeration that specifies creation options for the mesh.
device Microsoft.DirectX.Direct3D.Device
A Device object associated with the mesh.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh
A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


SkinMesh.FromX(XFileData,MeshFlags,Device,GraphicsStream,ExtendedMaterial,EffectInstance) Method (Microsoft.DirectX.Direct3D)

SkinMesh.FromX Method

Loads skin information and mesh data from a Microsoft Direct3D .x file data object.

Definition

Visual Basic Public Shared Function FromX( _
ByVal xofObjMesh As XFileData, _
ByVal options As MeshFlags, _
ByVal device As Device, _
ByRef adjacency As GraphicsStream, _
ByRef materials As ExtendedMaterial, _
ByRef effects As EffectInstance _
) As SkinMesh
C# public static SkinMesh FromX(
XFileData xofObjMesh,
MeshFlags options,
Device device,
out GraphicsStream adjacency,
out ExtendedMaterial materials,
out EffectInstance effects
);
C++ public:
static SkinMesh FromX(
XFileData^ xofObjMesh,
MeshFlags options,
Device^ device,
[Out] GraphicsStream^% adjacency,
[Out] ExtendedMaterial% materials,
[Out] EffectInstance% effects
);
JScript public static function FromX(
xofObjMesh : XFileData,
options : MeshFlags,
device : Device,
adjacency : GraphicsStream,
materials : ExtendedMaterial,
effects : EffectInstance
) : SkinMesh;

Parameters

xofObjMesh Microsoft.DirectX.Direct3D.XFileData
An XFileData object that represents the Microsoft DirectX file data object to load.
options Microsoft.DirectX.Direct3D.MeshFlags
A MeshFlags enumeration that specifies creation options for the mesh.
device Microsoft.DirectX.Direct3D.Device
A Device object associated with the mesh.
adjacency Microsoft.DirectX.GraphicsStream
A GraphicsStream object representing an array of three Int32 Leave Site values per face that specify the three neighbors for each face in the mesh.
materials Microsoft.DirectX.Direct3D.ExtendedMaterial[]
Array of ExtendedMaterial objects loaded from the .x file data object.
effects Microsoft.DirectX.Direct3D.EffectInstance[]
An array of EffectInstance structures, where each structure contains a set of EffectDefault structures. Each EffectDefault represents an attribute group in the returned mesh. The data in these structures represent a particular instance of state information used to initialize an effect. For more information, see EffectInstance.

Return Value

Microsoft.DirectX.Direct3D.SkinMesh
A SkinMesh structure that contains the skin and mesh data from the .x file object.

Remarks

Exceptions
InvalidCallException | The method call is invalid. For example, a method's parameter might contain an invalid value.
InvalidDataException | The data is invalid.
OutOfMemoryException Leave Site | Direct3D could not allocate sufficient memory to complete the call.


SkinMesh.SkinMesh() Constructor (Microsoft.DirectX.Direct3D)

SkinMesh.SkinMesh Constructor

Initializes a new instance of the SkinMesh class.

Definition

Visual Basic | Public Sub New()
C# | public SkinMesh();
C++ public:
SkinMesh();
JScript | public function SkinMesh();


SkinMesh.ToString() Method (Microsoft.DirectX.Direct3D)

SkinMesh.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


SkinMesh.Mesh Property (Microsoft.DirectX.Direct3D)

SkinMesh.Mesh Property

Retrieves or sets the Mesh object associated with the current skin information.

Definition

Visual Basic | Public Property Mesh As Mesh
C# | public Mesh Mesh { get; set; }
C++ public:
property Mesh^ Mesh {
Mesh^ get();
void set(Mesh^ value);
}
JScript public function get Mesh() : Mesh
public function set Mesh(Mesh);

Property Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object to set or retrieve.

This property is read/write.


SkinMesh.SkinInformation Property (Microsoft.DirectX.Direct3D)

SkinMesh.SkinInformation Property

Retrieves or sets the SkinInformation object used for skinning.

Definition

Visual Basic | Public Property SkinInformation As SkinInformation
C# | public SkinInformation SkinInformation { get; set; }
C++ public:
property SkinInformation^ SkinInformation {
SkinInformation^ get();
void set(SkinInformation^ value);
}
JScript public function get SkinInformation() : SkinInformation
public function set SkinInformation(SkinInformation);

Property Value

Microsoft.DirectX.Direct3D.SkinInformation
A SkinInformation object to set or retrieve.

This property is read/write.


SphericalHarmonicMaterial Structure (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial Structure

Contains spherical harmonic (SH) precomputed radiance transfer (PRT) material characteristics.

Definition

Visual Basic | Public Structure SphericalHarmonicMaterial
C# | public struct SphericalHarmonicMaterial
C++ | public value class SphericalHarmonicMaterial sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
SphericalHarmonicMaterial | Initializes a new instance of the SphericalHarmonicMaterial structure.

Properties

Property | Description
Absorption | Retrieves or sets the absorption coefficient used to model light propagation in a participating medium.
AbsorptionColor | Retrieves or sets the absorption coefficient used to model light propagation in a participating medium.
Diffuse | Retrieves or sets the diffuse albedo of the surface.
DiffuseColor | Retrieves or sets the diffuse albedo of the surface.
IsMirror | Determines whether the material is a mirror.
IsSubsurfaceScattering | Enables or disables subsurface scattering.
ReducedScattering | Retrieves or sets the reduced scattering coefficient used to model light propagation in a participating medium.
ReducedScatteringColor | Retrieves or sets the reduced scattering coefficient used to model light propagation in a participating medium.
RelativeIndexOfRefraction | Retrieves or sets the relative index of refraction as the ratio between two absolute indices of refraction.

Remarks

Non-spectral scenes use the red channel from the materials instead of the luminance value.

For more information about PRT see:

  • Jensen et al., Siggraph Proceedings: A Practical Model for Subsurface Light Transport, 2001.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • PrtEngine.SetMeshMaterials


SphericalHarmonicMaterial.SphericalHarmonicMaterial() Constructor (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.SphericalHarmonicMaterial Constructor

 Language:

Initializes a new instance of the SphericalHarmonicMaterial structure.

Definition

Visual Basic | Public Sub New()
C# | public SphericalHarmonicMaterial();
C++ public:
SphericalHarmonicMaterial();
JScript | public function SphericalHarmonicMaterial();


SphericalHarmonicMaterial.Absorption Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.Absorption Property

Retrieves or sets the absorption coefficient used to model light propagation in a participating medium.

Definition

Visual Basic | Public Property Absorption As Color
C# | public Color Absorption { get; set; }
C++ public:
property Color Absorption {
Color get();
void set(Color value);
}
JScript public function get Absorption() : Color
public function set Absorption(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the absorption coefficient.

This property is read/write.

Remarks

The absorption coefficient is a parameter to the volume rendering equation.


SphericalHarmonicMaterial.AbsorptionColor Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.AbsorptionColor Property

Retrieves or sets the absorption coefficient used to model light propagation in a participating medium.

Definition

Visual Basic | Public Property AbsorptionColor As ColorValue
C# | public ColorValue AbsorptionColor { get; set; }
C++ public:
property ColorValue AbsorptionColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get AbsorptionColor() : ColorValue
public function set AbsorptionColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the absorption coefficient.

This property is read/write.

Remarks

The absorption coefficient is a parameter to the volume rendering equation.


SphericalHarmonicMaterial.Diffuse Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.Diffuse Property

Retrieves or sets the diffuse albedo of the surface.

Definition

Visual Basic | Public Property Diffuse As Color
C# | public Color Diffuse { get; set; }
C++ public:
property Color Diffuse {
Color get();
void set(Color value);
}
JScript public function get Diffuse() : Color
public function set Diffuse(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the diffuse albedo of the surface.

This property is read/write.

Remarks

This value is ignored if the object is a mirror.


SphericalHarmonicMaterial.DiffuseColor Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.DiffuseColor Property

Retrieves or sets the diffuse albedo of the surface.

Definition

Visual Basic | Public Property DiffuseColor As ColorValue
C# | public ColorValue DiffuseColor { get; set; }
C++ public:
property ColorValue DiffuseColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get DiffuseColor() : ColorValue
public function set DiffuseColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the diffuse albedo of the surface.

This property is read/write.

Remarks

This value is ignored if the object is a mirror.


SphericalHarmonicMaterial.IsMirror Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.IsMirror Property

Determines whether the material is a mirror.

Definition

Visual Basic | Public Property IsMirror As Boolean
C# | public bool IsMirror { get; set; }
C++ public:
property bool IsMirror {
bool get();
void set(bool value);
}
JScript public function get IsMirror() : boolean
public function set IsMirror(boolean);

Property Value

System.Boolean
Must be set to false. A setting of true is not currently supported.

This property is read/write.


SphericalHarmonicMaterial.IsSubsurfaceScattering Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.IsSubsurfaceScattering Property

Enables or disables subsurface scattering.

Definition

Visual Basic | Public Property IsSubsurfaceScattering As Boolean
C# | public bool IsSubsurfaceScattering { get; set; }
C++ public:
property bool IsSubsurfaceScattering {
bool get();
void set(bool value);
}
JScript public function get IsSubsurfaceScattering() : boolean
public function set IsSubsurfaceScattering(boolean);

Property Value

System.Boolean
Set to true to enable subsurface scattering, or false to disable it.

This property is read/write.

Remarks

Any object that does subsurface scattering cannot be a mirror.


SphericalHarmonicMaterial.ReducedScattering Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.ReducedScattering Property

Retrieves or sets the reduced scattering coefficient used to model light propagation in a participating medium.

Definition

Visual Basic | Public Property ReducedScattering As Color
C# | public Color ReducedScattering { get; set; }
C++ public:
property Color ReducedScattering {
Color get();
void set(Color value);
}
JScript public function get ReducedScattering() : Color
public function set ReducedScattering(Color);

Property Value

System.Drawing.Color
A Color Leave Site object that represents the reduced scattering coefficient.

This property is read/write.

Remarks

The reduced scattering coefficient is a parameter to the volume rendering equation.


SphericalHarmonicMaterial.ReducedScatteringColor Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.ReducedScatteringColor Property

Retrieves or sets the reduced scattering coefficient used to model light propagation in a participating medium.

Definition

Visual Basic | Public Property ReducedScatteringColor As ColorValue
C# | public ColorValue ReducedScatteringColor { get; set; }
C++ public:
property ColorValue ReducedScatteringColor {
ColorValue get();
void set(ColorValue value);
}
JScript public function get ReducedScatteringColor() : ColorValue
public function set ReducedScatteringColor(ColorValue);

Property Value

Microsoft.DirectX.Direct3D.ColorValue
A ColorValue object that represents the reduced scattering coefficient.

This property is read/write.

Remarks

The reduced scattering coefficient is a parameter to the volume rendering equation.


SphericalHarmonicMaterial.RelativeIndexOfRefraction Property (Microsoft.DirectX.Direct3D)

SphericalHarmonicMaterial.RelativeIndexOfRefraction Property

Retrieves or sets the relative index of refraction as the ratio between two absolute indices of refraction.

Definition

Visual Basic | Public Property RelativeIndexOfRefraction As Single
C# | public float RelativeIndexOfRefraction { get; set; }
C++ public:
property float RelativeIndexOfRefraction {
float get();
void set(float value);
}
JScript public function get RelativeIndexOfRefraction() : float
public function set RelativeIndexOfRefraction(float);

Property Value

System.Single
A floating-point value that represents the relative index of refraction.

This property is read/write.

Remarks

The relative index of refraction is the ratio between two absolute indices of refraction. An index of refraction is the ratio of the sine of the angle of incidence to the sine of the angle of refraction.


StageTimings Structure (Microsoft.DirectX.Direct3D)

StageTimings Structure

Provides percentage of time spent processing shader data.

Definition

Visual Basic | Public Structure StageTimings
C# | public struct StageTimings
C++ | public value class StageTimings sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
StageTimings | Creates a new instance of the StageTimings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ComputationProcessingPercent | Retrieves the percentage of time processing (moving data around in registers or doing mathematical operations).
MemoryProcessingPercent | Retrieves the percentage of time in the shader spent on memory accesses.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StageTimings.StageTimings() Constructor (Microsoft.DirectX.Direct3D)

StageTimings.StageTimings Constructor

Creates a new instance of the StageTimings structure.

Definition

Visual Basic | Public Sub New()
C# | public StageTimings();
C++ public:
StageTimings();
JScript | public function StageTimings();


StageTimings.ToString() Method (Microsoft.DirectX.Direct3D)

StageTimings.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


StageTimings.ComputationProcessingPercent Property (Microsoft.DirectX.Direct3D)

StageTimings.ComputationProcessingPercent Property

Retrieves the percentage of time processing (moving data around in registers or doing mathematical operations).

Definition

Visual Basic | Public ReadOnly Property ComputationProcessingPercent As Single
C# | public float ComputationProcessingPercent { get; }
C++ public:
property float ComputationProcessingPercent {
float get();
}
JScript | public function get ComputationProcessingPercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time processing.

This property is read-only.


StageTimings.MemoryProcessingPercent Property (Microsoft.DirectX.Direct3D)

StageTimings.MemoryProcessingPercent Property

Retrieves the percentage of time in the shader spent on memory accesses.

Definition

Visual Basic | Public ReadOnly Property MemoryProcessingPercent As Single
C# | public float MemoryProcessingPercent { get; }
C++ public:
property float MemoryProcessingPercent {
float get();
}
JScript | public function get MemoryProcessingPercent() : float

Property Value

System.Single
A Single Leave Site that represents the percentage of time in the shader spent on memory accesses.

This property is read-only.


StencilCaps Structure (Microsoft.DirectX.Direct3D)

StencilCaps Structure

Contains flags that specify supported stencil-buffer operations.

Definition

Visual Basic | Public Structure StencilCaps
C# | public struct StencilCaps
C++ | public value class StencilCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsDecrement | Specifies whether the stencil buffer entry can be decremented, wrapping to the maximum value if the new value is less than zero.
SupportsDecrementSaturation | Specifies whether the stencil buffer entry can be decremented, clamping to zero.
SupportsIncrement | Specifies whether the stencil buffer entry can be incremented, wrapping to zero if the new value exceeds the maximum value.
SupportsIncrementSaturation | Specifies whether the stencil buffer entry can be incremented, clamping to the maximum value.
SupportsInvert | Specifies whether the bits in the stencil buffer entry can be inverted.
SupportsKeep | Specifies whether to keep the stencil buffer entry unmodified or allow it to be updated.
SupportsReplace | Specifies whether to replace the stencil buffer entry with a reference value.
SupportsTwoSided | Specifies whether the device supports two-sided stenciling.
SupportsZero | Specifies whether the device supports setting the stencil buffer entry to 0.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StencilCaps.ToString() Method (Microsoft.DirectX.Direct3D)

StencilCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


StencilCaps.SupportsDecrement Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsDecrement Property

Specifies whether the stencil buffer entry can be decremented, wrapping to the maximum value if the new value is less than zero.

Definition

Visual Basic | Public ReadOnly Property SupportsDecrement As Boolean
C# | public bool SupportsDecrement { get; }
C++ public:
property bool SupportsDecrement {
bool get();
}
JScript | public function get SupportsDecrement() : boolean

Property Value

System.Boolean
Value that is true if the stencil-buffer entry can be decremented, or false if it cannot.

This property is read-only.


StencilCaps.SupportsDecrementSaturation Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsDecrementSaturation Property

Specifies whether the stencil buffer entry can be decremented, clamping to zero.

Definition

Visual Basic | Public ReadOnly Property SupportsDecrementSaturation As Boolean
C# | public bool SupportsDecrementSaturation { get; }
C++ public:
property bool SupportsDecrementSaturation {
bool get();
}
JScript | public function get SupportsDecrementSaturation() : boolean

Property Value

System.Boolean
Value that is true if the stencil-buffer entry can be decremented, or false if it cannot.

This property is read-only.


StencilCaps.SupportsIncrement Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsIncrement Property

Specifies whether the stencil buffer entry can be incremented, wrapping to zero if the new value exceeds the maximum value.

Definition

Visual Basic | Public ReadOnly Property SupportsIncrement As Boolean
C# | public bool SupportsIncrement { get; }
C++ public:
property bool SupportsIncrement {
bool get();
}
JScript | public function get SupportsIncrement() : boolean

Property Value

System.Boolean
Value that is true if the stencil-buffer entry can be incremented, or false if it cannot.

This property is read-only.


StencilCaps.SupportsIncrementSaturation Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsIncrementSaturation Property

Specifies whether the stencil buffer entry can be incremented, clamping to the maximum value.

Definition

Visual Basic | Public ReadOnly Property SupportsIncrementSaturation As Boolean
C# | public bool SupportsIncrementSaturation { get; }
C++ public:
property bool SupportsIncrementSaturation {
bool get();
}
JScript | public function get SupportsIncrementSaturation() : boolean

Property Value

System.Boolean
Value that is true if the stencil-buffer entry can be incremented, or false if it cannot.

This property is read-only.


StencilCaps.SupportsInvert Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsInvert Property

Specifies whether the bits in the stencil buffer entry can be inverted.

Definition

Visual Basic | Public ReadOnly Property SupportsInvert As Boolean
C# | public bool SupportsInvert { get; }
C++ public:
property bool SupportsInvert {
bool get();
}
JScript | public function get SupportsInvert() : boolean

Property Value

System.Boolean
Value that is true if the stencil-buffer bits can be inverted, or false if they cannot.

This property is read-only.


StencilCaps.SupportsKeep Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsKeep Property

Specifies whether to keep the stencil buffer entry unmodified or allow it to be updated.

Definition

Visual Basic | Public ReadOnly Property SupportsKeep As Boolean
C# | public bool SupportsKeep { get; }
C++ public:
property bool SupportsKeep {
bool get();
}
JScript | public function get SupportsKeep() : boolean

Property Value

System.Boolean
Value that is true to keep the stencil-buffer entry unmodified, or false to allow it to be updated.

This property is read-only.


StencilCaps.SupportsReplace Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsReplace Property

Specifies whether to replace the stencil buffer entry with a reference value.

Definition

Visual Basic | Public ReadOnly Property SupportsReplace As Boolean
C# | public bool SupportsReplace { get; }
C++ public:
property bool SupportsReplace {
bool get();
}
JScript | public function get SupportsReplace() : boolean

Property Value

System.Boolean
Value that is true to replace the stencil-buffer entry with a reference value, or false otherwise.

This property is read-only.


StencilCaps.SupportsTwoSided Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsTwoSided Property

Specifies whether the device supports two-sided stenciling.

Definition

Visual Basic | Public ReadOnly Property SupportsTwoSided As Boolean
C# | public bool SupportsTwoSided { get; }
C++ public:
property bool SupportsTwoSided {
bool get();
}
JScript | public function get SupportsTwoSided() : boolean

Property Value

System.Boolean
Value that is true if two-sided stenciling is supported, or false if it is not.

This property is read-only.


StencilCaps.SupportsZero Property (Microsoft.DirectX.Direct3D)

StencilCaps.SupportsZero Property

Specifies whether the device supports setting the stencil buffer entry to 0.

Definition

Visual Basic | Public ReadOnly Property SupportsZero As Boolean
C# | public bool SupportsZero { get; }
C++ public:
property bool SupportsZero {
bool get();
}
JScript | public function get SupportsZero() : boolean

Property Value

System.Boolean
Value that is true if setting the stencil-buffer entry to 0 is supported, or false if it is not.

This property is read-only.


SurfaceDescription Structure (Microsoft.DirectX.Direct3D)

SurfaceDescription Structure

Describes a surface.

Definition

Visual Basic | Public Structure SurfaceDescription
C# | public struct SurfaceDescription
C++ | public value class SurfaceDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
SurfaceDescription | Initializes a new instance of the SurfaceDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Format | Retrieves or sets a value of the Format enumeration that describes the surface format.
Height | Retrieves or sets the height of the surface.
MultiSampleQuality | Retrieves or sets the multisample quality level.
MultiSampleType | Retrieves or sets a member of the MultiSampleType enumeration that specifies the levels of full-scene multisampling supported by the surface.
Pool | Retrieves or sets a member of the Pool enumeration that specifies the class of memory allocated for the current surface.
Type | Retrieves or sets a member of the ResourceType enumeration that identifies the current resource as a surface.
Usage | Retrieves or sets a member of the Usage enumeration that specifies the usage type of the surface.
Width | Retrieves or sets the width of the surface.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfaceDescription.SurfaceDescription() Constructor (Microsoft.DirectX.Direct3D)

SurfaceDescription.SurfaceDescription Constructor

Initializes a new instance of the SurfaceDescription class.

Definition

Visual Basic | Public Sub New()
C# | public SurfaceDescription();
C++ public:
SurfaceDescription();
JScript | public function SurfaceDescription();


SurfaceDescription.ToString() Method (Microsoft.DirectX.Direct3D)

SurfaceDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


SurfaceDescription.Format Property (Microsoft.DirectX.Direct3D)

SurfaceDescription.Format Property

Retrieves or sets a value of the Format enumeration that describes the surface format.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
Member of the Format enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Height Property (Microsoft.DirectX.Direct3D)

SurfaceDescription.Height Property

Retrieves or sets the height of the surface.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer that represents the height of the surface, in pixels.

This property is read/write.


SurfaceDescription.MultiSampleQuality Property (Microsoft.DirectX.Direct3D)

SurfaceDescription.MultiSampleQuality Property

Retrieves or sets the multisample quality level.

Definition

Visual Basic | Public Property MultiSampleQuality As Integer
C# | public int MultiSampleQuality { get; set; }
C++ public:
property int MultiSampleQuality {
int get();
void set(int value);
}
JScript public function get MultiSampleQuality() : int
public function set MultiSampleQuality(int);

Property Value

System.Int32
Integer that represents the quality level.

This property is read/write.

Remarks

The valid quality level range is between zero and one less than the level returned by the qualityLevels parameter of Manager.CheckDeviceMultiSampleType.


SurfaceDescription.MultiSampleType Property (Microsoft.DirectX.Direct3D)

SurfaceDescription.MultiSampleType Property

Retrieves or sets a member of the MultiSampleType enumeration that specifies the levels of full-scene multisampling supported by the surface.

Definition

Visual Basic | Public Property MultiSampleType As MultiSampleType
C# | public MultiSampleType MultiSampleType { get; set; }
C++ public:
property MultiSampleType MultiSampleType {
MultiSampleType get();
void set(MultiSampleType value);
}
JScript public function get MultiSampleType() : MultiSampleType
public function set MultiSampleType(MultiSampleType);

Property Value

Microsoft.DirectX.Direct3D.MultiSampleType
Member of the MultiSampleType enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Pool Property (Microsoft.DirectX.Direct3D)

SurfaceDescription.Pool Property

Retrieves or sets a member of the Pool enumeration that specifies the class of memory allocated for the current surface.

Definition

Visual Basic | Public Property Pool As Pool
C# | public Pool Pool { get; set; }
C++ public:
property Pool Pool {
Pool get();
void set(Pool value);
}
JScript public function get Pool() : Pool
public function set Pool(Pool);

Property Value

Microsoft.DirectX.Direct3D.Pool
Member of the Pool enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Type Property (Microsoft.DirectX.Direct3D)

SurfaceDescription.Type Property

Retrieves or sets a member of the ResourceType enumeration that identifies the current resource as a surface.

Definition

Visual Basic | Public Property Type As ResourceType
C# | public ResourceType Type { get; set; }
C++ public:
property ResourceType Type {
ResourceType get();
void set(ResourceType value);
}
JScript public function get Type() : ResourceType
public function set Type(ResourceType);

Property Value

Microsoft.DirectX.Direct3D.ResourceType
Member of the ResourceType enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Usage Property (Microsoft.DirectX.Direct3D)

SurfaceDescription.Usage Property

Retrieves or sets a member of the Usage enumeration that specifies the usage type of the surface.

Definition

Visual Basic | Public Property Usage As Usage
C# | public Usage Usage { get; set; }
C++ public:
property Usage Usage {
Usage get();
void set(Usage value);
}
JScript public function get Usage() : Usage
public function set Usage(Usage);

Property Value

Microsoft.DirectX.Direct3D.Usage
Member of the Usage enumeration to set or retrieve.

This property is read/write.


SurfaceDescription.Width Property (Microsoft.DirectX.Direct3D)

SurfaceDescription.Width Property

Retrieves or sets the width of the surface.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer that represents the width of the surface, in pixels.

This property is read/write.


TechniqueDescription Structure (Microsoft.DirectX.Direct3D)

TechniqueDescription Structure

Describes a technique used by an effect.

Definition

Visual Basic | Public Structure TechniqueDescription
C# | public struct TechniqueDescription
C++ | public value class TechniqueDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
TechniqueDescription | Initializes a new instance of the TechniqueDescription class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Annotations | Retrieves the number of annotations for the current technique.
Name | Retrieves the technique name.
Passes | Retrieves the number of rendering passes the technique requires.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TechniqueDescription.TechniqueDescription() Constructor (Microsoft.DirectX.Direct3D)

TechniqueDescription.TechniqueDescription Constructor

Initializes a new instance of the TechniqueDescription class.

Definition

Visual Basic | Public Sub New()
C# | public TechniqueDescription();
C++ public:
TechniqueDescription();
JScript | public function TechniqueDescription();


TechniqueDescription.ToString() Method (Microsoft.DirectX.Direct3D)

TechniqueDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


TechniqueDescription.Annotations Property (Microsoft.DirectX.Direct3D)

TechniqueDescription.Annotations Property

Retrieves the number of annotations for the current technique.

Definition

Visual Basic | Public ReadOnly Property Annotations As Integer
C# | public int Annotations { get; }
C++ public:
property int Annotations {
int get();
}
JScript | public function get Annotations() : int

Property Value

System.Int32
Integer that represents the number of annotations.

This property is read-only.

Remarks

Annotations are user-specific data that can be attached to any technique, pass, or parameter.


TechniqueDescription.Name Property (Microsoft.DirectX.Direct3D)

TechniqueDescription.Name Property

Retrieves the technique name.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String
String that contains the technique name.

This property is read-only.


TechniqueDescription.Passes Property (Microsoft.DirectX.Direct3D)

TechniqueDescription.Passes Property

Retrieves the number of rendering passes the technique requires.

Definition

Visual Basic | Public ReadOnly Property Passes As Integer
C# | public int Passes { get; }
C++ public:
property int Passes {
int get();
}
JScript | public function get Passes() : int

Property Value

System.Int32
Integer that represents the number of rendering passes required.

This property is read-only.

Remarks

Some video cards can render two textures in a single pass. However, if a card does not have this capability, it is often possible to render the same effect in two passes, using one texture for each pass.


TextureCaps Structure (Microsoft.DirectX.Direct3D)

TextureCaps Structure

Contains miscellaneous texture-mapping capabilities.

Definition

Visual Basic | Public Structure TextureCaps
C# | public struct TextureCaps
C++ | public value class TextureCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAlpha | Specifies whether alpha in texture pixels is supported.
SupportsAlphaPalette | Specifies whether the device can draw alpha from texture palettes.
SupportsCubeMap | Specifies whether cube textures are supported.
SupportsCubeMapPower2 | Specifies whether the device requires that cube texture maps have dimensions specified as powers of two.
SupportsMipCubeMap | Specifies whether the device supports mipmapped cube textures.
SupportsMipMap | Specifies whether the device supports mipmapped textures.
SupportsMipVolumeMap | Specifies whether the device supports mipmapped volume textures.
SupportsNonPower2Conditional | Specifies whether the device conditionally supports the use of 2-D textures with dimensions that are not powers of two.
SupportsNoProjectedBumpEnvironment | Specifies whether the device does not support a projected bump-environment lookup operation in programmable and fixed-function shaders.
SupportsPerspective | Specifies whether perspective correction texturing is supported.
SupportsPower2 | Specifies whether the device supports all textures having widths and heights that are specified as powers of two.
SupportsProjected | Specifies whether TextureTransform.Projected is supported.
SupportsSquareOnly | Specifies whether all textures must be square.
SupportsTextureRepeatNotScaledBySize | Specifies whether texture indices are not scaled by the texture size prior to interpolation.
SupportsVolumeMap | Specifies whether the device supports volume textures.
SupportsVolumeMapPower2 | Specifies whether the device requires that volume texture maps have dimensions that are specified as powers of two.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureCaps.ToString() Method (Microsoft.DirectX.Direct3D)

TextureCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


TextureCaps.SupportsAlpha Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsAlpha Property

Specifies whether alpha in texture pixels is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsAlpha As Boolean
C# | public bool SupportsAlpha { get; }
C++ public:
property bool SupportsAlpha {
bool get();
}
JScript | public function get SupportsAlpha() : boolean

Property Value

System.Boolean
Value that is true if alpha in texture pixels is supported, or false if it is not.

This property is read-only.


TextureCaps.SupportsAlphaPalette Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsAlphaPalette Property

Specifies whether the device can draw alpha from texture palettes.

Definition

Visual Basic | Public ReadOnly Property SupportsAlphaPalette As Boolean
C# | public bool SupportsAlphaPalette { get; }
C++ public:
property bool SupportsAlphaPalette {
bool get();
}
JScript | public function get SupportsAlphaPalette() : boolean

Property Value

System.Boolean
Value that is true if the device can draw alpha from texture palettes, or false if it cannot.

This property is read-only.


TextureCaps.SupportsCubeMap Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsCubeMap Property

Specifies whether cube textures are supported.

Definition

Visual Basic | Public ReadOnly Property SupportsCubeMap As Boolean
C# | public bool SupportsCubeMap { get; }
C++ public:
property bool SupportsCubeMap {
bool get();
}
JScript | public function get SupportsCubeMap() : boolean

Property Value

System.Boolean
Value that is true if cube textures are supported, or false if they are not.

This property is read-only.


TextureCaps.SupportsCubeMapPower2 Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsCubeMapPower2 Property

Specifies whether the device requires that cube texture maps have dimensions specified as powers of two.

Definition

Visual Basic | Public ReadOnly Property SupportsCubeMapPower2 As Boolean
C# | public bool SupportsCubeMapPower2 { get; }
C++ public:
property bool SupportsCubeMapPower2 {
bool get();
}
JScript | public function get SupportsCubeMapPower2() : boolean

Property Value

System.Boolean
Value that is true if the device requires cube map dimensions to be a power of two, or false if it does not.

This property is read-only.


TextureCaps.SupportsMipCubeMap Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsMipCubeMap Property

Specifies whether the device supports mipmapped cube textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMipCubeMap As Boolean
C# | public bool SupportsMipCubeMap { get; }
C++ public:
property bool SupportsMipCubeMap {
bool get();
}
JScript | public function get SupportsMipCubeMap() : boolean

Property Value

System.Boolean
Value that is true if mipmapped cube textures are supported, or false if they are not.

This property is read-only.


TextureCaps.SupportsMipMap Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsMipMap Property

Specifies whether the device supports mipmapped textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMipMap As Boolean
C# | public bool SupportsMipMap { get; }
C++ public:
property bool SupportsMipMap {
bool get();
}
JScript | public function get SupportsMipMap() : boolean

Property Value

System.Boolean
Value that is true if the device supports mipmapped textures, or false if it does not.

This property is read-only.


TextureCaps.SupportsMipVolumeMap Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsMipVolumeMap Property

Specifies whether the device supports mipmapped volume textures.

Definition

Visual Basic | Public ReadOnly Property SupportsMipVolumeMap As Boolean
C# | public bool SupportsMipVolumeMap { get; }
C++ public:
property bool SupportsMipVolumeMap {
bool get();
}
JScript | public function get SupportsMipVolumeMap() : boolean

Property Value

System.Boolean
Value that is true if the device supports mipmapped volume textures, or false if it does not.

This property is read-only.


TextureCaps.SupportsNonPower2Conditional Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsNonPower2Conditional Property

Specifies whether the device conditionally supports the use of 2-D textures with dimensions that are not powers of two.

Definition

Visual Basic | Public ReadOnly Property SupportsNonPower2Conditional As Boolean
C# | public bool SupportsNonPower2Conditional { get; }
C++ public:
property bool SupportsNonPower2Conditional {
bool get();
}
JScript | public function get SupportsNonPower2Conditional() : boolean

Property Value

System.Boolean
Value that is true if the device conditionally supports dimensions that are not powers of two, or false if it does not.

This property is read-only.

Remarks

A device that exposes this capability can use a texture whose dimensions are not powers of two, provided all of the following requirements are met.

  • The texture-addressing mode for the texture stage is set to TextureAddress.Clamp.
  • Texture wrapping for the texture stage is disabled (that is, RenderStateManager.Wrap0 is set to 0).
  • Mipmapping is not in use (that is, only the magnification filter is in use).
  • Texture formats are not DXT1-5.

A texture that is not a power of two cannot be set at a stage that will be read based on a shader computation (such as the bem, beml, or texm3x3 instructions in pixel shaders versions 1_0 to 1_3). For example, these textures can be used to store bumps that are fed into texture reads, but not the environment maps that are used in texbem, texbeml, or texm3x3spec. This means that a texture with dimensions that are not powers of two cannot be addressed or sampled using texture coordinates computed within the shader. This type of operation is known as a dependent read, and cannot be performed on these types of textures.


TextureCaps.SupportsNoProjectedBumpEnvironment Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsNoProjectedBumpEnvironment Property

Specifies whether the device does not support a projected bump-environment lookup operation in programmable and fixed-function shaders.

Definition

Visual Basic | Public ReadOnly Property SupportsNoProjectedBumpEnvironment As Boolean
C# | public bool SupportsNoProjectedBumpEnvironment { get; }
C++ public:
property bool SupportsNoProjectedBumpEnvironment {
bool get();
}
JScript | public function get SupportsNoProjectedBumpEnvironment() : boolean

Property Value

System.Boolean
Value that is true if the device does not support a projected bump-environment lookup operation, or false if it does.

This property is read-only.


TextureCaps.SupportsPerspective Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsPerspective Property

Specifies whether perspective correction texturing is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsPerspective As Boolean
C# | public bool SupportsPerspective { get; }
C++ public:
property bool SupportsPerspective {
bool get();
}
JScript | public function get SupportsPerspective() : boolean

Property Value

System.Boolean
Value that is true if perspective correction texturing is supported, or false if it is not.

This property is read-only.


TextureCaps.SupportsPower2 Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsPower2 Property

Specifies whether the device supports all textures having widths and heights that are specified as powers of two.

Definition

Visual Basic | Public ReadOnly Property SupportsPower2 As Boolean
C# | public bool SupportsPower2 { get; }
C++ public:
property bool SupportsPower2 {
bool get();
}
JScript | public function get SupportsPower2() : boolean

Property Value

System.Boolean
Value that is true if the device supports texture dimensions as powers of two, or false if it does not.

This property is read-only.

Remarks

This requirement does not apply to cube textures or volume textures.


TextureCaps.SupportsProjected Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsProjected Property

Specifies whether TextureTransform.Projected is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsProjected As Boolean
C# | public bool SupportsProjected { get; }
C++ public:
property bool SupportsProjected {
bool get();
}
JScript | public function get SupportsProjected() : boolean

Property Value

System.Boolean
Value that is true if TextureTransform.Projected is supported, or false if it is not.

This property is read-only.

Remarks

When applied, the device divides transformed texture coordinates by the last texture coordinate. If this property's capability is present, the projective divide occurs on a per-pixel basis. If the capability is not present but the projective divide needs to occur anyway, the Microsoft Direct3D runtime performs it on a per-vertex basis.


TextureCaps.SupportsSquareOnly Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsSquareOnly Property

Specifies whether all textures must be square.

Definition

Visual Basic | Public ReadOnly Property SupportsSquareOnly As Boolean
C# | public bool SupportsSquareOnly { get; }
C++ public:
property bool SupportsSquareOnly {
bool get();
}
JScript | public function get SupportsSquareOnly() : boolean

Property Value

System.Boolean
Value that is true if all textures are required to be square, or false if they are not.

This property is read-only.


TextureCaps.SupportsTextureRepeatNotScaledBySize Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsTextureRepeatNotScaledBySize Property

Specifies whether texture indices are not scaled by the texture size prior to interpolation.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureRepeatNotScaledBySize As Boolean
C# | public bool SupportsTextureRepeatNotScaledBySize { get; }
C++ public:
property bool SupportsTextureRepeatNotScaledBySize {
bool get();
}
JScript | public function get SupportsTextureRepeatNotScaledBySize() : boolean

Property Value

System.Boolean
Value that is true if texture indices are not scaled prior to interpolation, or false if they are.

This property is read-only.


TextureCaps.SupportsVolumeMap Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsVolumeMap Property

Specifies whether the device supports volume textures.

Definition

Visual Basic | Public ReadOnly Property SupportsVolumeMap As Boolean
C# | public bool SupportsVolumeMap { get; }
C++ public:
property bool SupportsVolumeMap {
bool get();
}
JScript | public function get SupportsVolumeMap() : boolean

Property Value

System.Boolean
Value that is true if volume textures are supported, or false if they are not.

This property is read-only.


TextureCaps.SupportsVolumeMapPower2 Property (Microsoft.DirectX.Direct3D)

TextureCaps.SupportsVolumeMapPower2 Property

Specifies whether the device requires that volume texture maps have dimensions that are specified as powers of two.

Definition

Visual Basic | Public ReadOnly Property SupportsVolumeMapPower2 As Boolean
C# | public bool SupportsVolumeMapPower2 { get; }
C++ public:
property bool SupportsVolumeMapPower2 {
bool get();
}
JScript | public function get SupportsVolumeMapPower2() : boolean

Property Value

System.Boolean
Value that is true if the device requires volume map dimensions to be a power of two, or false if it does not.

This property is read-only.


TextureOperationCaps Structure (Microsoft.DirectX.Direct3D)

TextureOperationCaps Structure

Contains values that describe the texture operations that the current device supports.

Definition

Visual Basic | Public Structure TextureOperationCaps
C# | public struct TextureOperationCaps
C++ | public value class TextureOperationCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsAdd | Specifies whether the TextureOperation.Add texture blending operation is supported.
SupportsAddSigned | Specifies whether the TextureOperation.AddSigned texture blending operation is supported.
SupportsAddSigned2X | Specifies whether the TextureOperation.AddSigned2X texture blending operation is supported.
SupportsAddSmooth | Specifies whether the TextureOperation.AddSmooth texture blending operation is supported.
SupportsBlendCurrentAlpha | Specifies whether the TextureOperation.BlendCurrentAlpha texture blending operation is supported.
SupportsBlendDiffuseAlpha | Specifies whether the TextureOperation.BlendDiffuseAlpha texture blending operation is supported.
SupportsBlendFactorAlpha | Specifies whether the TextureOperation.BlendFactorAlpha texture blending operation is supported.
SupportsBlendTextureAlpha | Specifies whether the TextureOperation.BlendTextureAlpha texture blending operation is supported.
SupportsBlendTextureAlphaPM | Specifies whether the TextureOperation.BlendTextureAlphaPM texture blending operation is supported.
SupportsBumpEnvironmentMap | Specifies whether the TextureOperation.BumpEnvironmentMap texture blending operation is supported.
SupportsBumpEnvironmentMapLuminance | Specifies whether the TextureOperation.BumpEnvironmentMapLuminance texture blending operation is supported.
SupportsDisable | Specifies whether the TextureOperation.Disable texture blending operation is supported.
SupportsDotProduct3 | Specifies whether the TextureOperation.DotProduct3 texture blending operation is supported.
SupportsLerp | Specifies whether the TextureOperation.Lerp texture blending operation is supported.
SupportsModulate | Specifies whether the TextureOperation.Modulate texture blending operation is supported.
SupportsModulate2X | Specifies whether the TextureOperation.Modulate2X texture blending operation is supported.
SupportsModulate4X | Specifies whether the TextureOperation.Modulate4X texture blending operation is supported.
SupportsModulateAlphaAddColor | Specifies whether the TextureOperation.ModulateAddColor texture blending operation is supported.
SupportsModulateColorAddAlpha | Specifies whether the TextureOperation.ModulateColorAddAlpha texture blending operation is supported.
SupportsModulateInvAlphaAddColor | Specifies whether the TextureOperation.ModulateInvAlphaAddColor texture blending operation is supported.
SupportsModulateInvColorAddAlpha | Specifies whether the TextureOperation.ModulateInvColorAddAlpha texture blending operation is supported.
SupportsMultiplyAdd | Specifies whether the TextureOperation.MultiplyAdd texture blending operation is supported.
SupportsPreModulate | Specifies whether the TextureOperation.PreModulate texture blending operation is supported.
SupportsSelectArgument1 | Specifies whether the TextureOperation.SelectArgument1 texture blending operation is supported.
SupportsSelectArgument2 | Specifies whether the TextureOperation.SelectArgument2 texture blending operation is supported.
SupportsSubtract | Specifies whether the TextureOperation.Subtract texture blending operation is supported.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureOperationCaps.ToString() Method (Microsoft.DirectX.Direct3D)

TextureOperationCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


TextureOperationCaps.SupportsAdd Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsAdd Property

Specifies whether the TextureOperation.Add texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsAdd As Boolean
C# | public bool SupportsAdd { get; }
C++ public:
property bool SupportsAdd {
bool get();
}
JScript | public function get SupportsAdd() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.Add is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsAddSigned Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsAddSigned Property

Specifies whether the TextureOperation.AddSigned texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsAddSigned As Boolean
C# | public bool SupportsAddSigned { get; }
C++ public:
property bool SupportsAddSigned {
bool get();
}
JScript | public function get SupportsAddSigned() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.AddSigned is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsAddSigned2X Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsAddSigned2X Property

Specifies whether the TextureOperation.AddSigned2X texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsAddSigned2X As Boolean
C# | public bool SupportsAddSigned2X { get; }
C++ public:
property bool SupportsAddSigned2X {
bool get();
}
JScript | public function get SupportsAddSigned2X() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.AddSigned2X is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsAddSmooth Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsAddSmooth Property

Specifies whether the TextureOperation.AddSmooth texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsAddSmooth As Boolean
C# | public bool SupportsAddSmooth { get; }
C++ public:
property bool SupportsAddSmooth {
bool get();
}
JScript | public function get SupportsAddSmooth() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.AddSmooth is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendCurrentAlpha Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsBlendCurrentAlpha Property

Specifies whether the TextureOperation.BlendCurrentAlpha texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsBlendCurrentAlpha As Boolean
C# | public bool SupportsBlendCurrentAlpha { get; }
C++ public:
property bool SupportsBlendCurrentAlpha {
bool get();
}
JScript | public function get SupportsBlendCurrentAlpha() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.BlendCurrentAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendDiffuseAlpha Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsBlendDiffuseAlpha Property

Specifies whether the TextureOperation.BlendDiffuseAlpha texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsBlendDiffuseAlpha As Boolean
C# | public bool SupportsBlendDiffuseAlpha { get; }
C++ public:
property bool SupportsBlendDiffuseAlpha {
bool get();
}
JScript | public function get SupportsBlendDiffuseAlpha() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.BlendDiffuseAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendFactorAlpha Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsBlendFactorAlpha Property

Specifies whether the TextureOperation.BlendFactorAlpha texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsBlendFactorAlpha As Boolean
C# | public bool SupportsBlendFactorAlpha { get; }
C++ public:
property bool SupportsBlendFactorAlpha {
bool get();
}
JScript | public function get SupportsBlendFactorAlpha() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.BlendFactorAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendTextureAlpha Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsBlendTextureAlpha Property

Specifies whether the TextureOperation.BlendTextureAlpha texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsBlendTextureAlpha As Boolean
C# | public bool SupportsBlendTextureAlpha { get; }
C++ public:
property bool SupportsBlendTextureAlpha {
bool get();
}
JScript | public function get SupportsBlendTextureAlpha() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.BlendTextureAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBlendTextureAlphaPM Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsBlendTextureAlphaPM Property

Specifies whether the TextureOperation.BlendTextureAlphaPM texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsBlendTextureAlphaPM As Boolean
C# | public bool SupportsBlendTextureAlphaPM { get; }
C++ public:
property bool SupportsBlendTextureAlphaPM {
bool get();
}
JScript | public function get SupportsBlendTextureAlphaPM() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.BlendTextureAlphaPM is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBumpEnvironmentMap Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsBumpEnvironmentMap Property

Specifies whether the TextureOperation.BumpEnvironmentMap texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsBumpEnvironmentMap As Boolean
C# | public bool SupportsBumpEnvironmentMap { get; }
C++ public:
property bool SupportsBumpEnvironmentMap {
bool get();
}
JScript | public function get SupportsBumpEnvironmentMap() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.BumpEnvironmentMap is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsBumpEnvironmentMapLuminance Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsBumpEnvironmentMapLuminance Property

Language:

Specifies whether the TextureOperation.BumpEnvironmentMapLuminance texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsBumpEnvironmentMapLuminance As Boolean
C# | public bool SupportsBumpEnvironmentMapLuminance { get; }
C++ public:
property bool SupportsBumpEnvironmentMapLuminance {
bool get();
}
JScript | public function get SupportsBumpEnvironmentMapLuminance() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.BumpEnvironmentMapLuminance is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsDisable Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsDisable Property

Specifies whether the TextureOperation.Disable texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsDisable As Boolean
C# | public bool SupportsDisable { get; }
C++ public:
property bool SupportsDisable {
bool get();
}
JScript | public function get SupportsDisable() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.Disable is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsDotProduct3 Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsDotProduct3 Property

Specifies whether the TextureOperation.DotProduct3 texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsDotProduct3 As Boolean
C# | public bool SupportsDotProduct3 { get; }
C++ public:
property bool SupportsDotProduct3 {
bool get();
}
JScript | public function get SupportsDotProduct3() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.DotProduct3 is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsLerp Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsLerp Property

Specifies whether the TextureOperation.Lerp texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsLerp As Boolean
C# | public bool SupportsLerp { get; }
C++ public:
property bool SupportsLerp {
bool get();
}
JScript | public function get SupportsLerp() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.Lerp is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulate Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsModulate Property

Specifies whether the TextureOperation.Modulate texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsModulate As Boolean
C# | public bool SupportsModulate { get; }
C++ public:
property bool SupportsModulate {
bool get();
}
JScript | public function get SupportsModulate() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.Modulate is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulate2X Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsModulate2X Property

Specifies whether the TextureOperation.Modulate2X texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsModulate2X As Boolean
C# | public bool SupportsModulate2X { get; }
C++ public:
property bool SupportsModulate2X {
bool get();
}
JScript | public function get SupportsModulate2X() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.Modulate2X is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulate4X Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsModulate4X Property

Specifies whether the TextureOperation.Modulate4X texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsModulate4X As Boolean
C# | public bool SupportsModulate4X { get; }
C++ public:
property bool SupportsModulate4X {
bool get();
}
JScript | public function get SupportsModulate4X() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.Modulate4X is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulateAlphaAddColor Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsModulateAlphaAddColor Property

Specifies whether the TextureOperation.ModulateAddColor texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsModulateAlphaAddColor As Boolean
C# | public bool SupportsModulateAlphaAddColor { get; }
C++ public:
property bool SupportsModulateAlphaAddColor {
bool get();
}
JScript | public function get SupportsModulateAlphaAddColor() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.ModulateAddColor is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulateColorAddAlpha Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsModulateColorAddAlpha Property

Specifies whether the TextureOperation.ModulateColorAddAlpha texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsModulateColorAddAlpha As Boolean
C# | public bool SupportsModulateColorAddAlpha { get; }
C++ public:
property bool SupportsModulateColorAddAlpha {
bool get();
}
JScript | public function get SupportsModulateColorAddAlpha() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.ModulateColorAddAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulateInvAlphaAddColor Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsModulateInvAlphaAddColor Property

Language:

Specifies whether the TextureOperation.ModulateInvAlphaAddColor texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsModulateInvAlphaAddColor As Boolean
C# | public bool SupportsModulateInvAlphaAddColor { get; }
C++ public:
property bool SupportsModulateInvAlphaAddColor {
bool get();
}
JScript | public function get SupportsModulateInvAlphaAddColor() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.ModulateInvAlphaAddColor is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsModulateInvColorAddAlpha Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsModulateInvColorAddAlpha Property

Language:

Specifies whether the TextureOperation.ModulateInvColorAddAlpha texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsModulateInvColorAddAlpha As Boolean
C# | public bool SupportsModulateInvColorAddAlpha { get; }
C++ public:
property bool SupportsModulateInvColorAddAlpha {
bool get();
}
JScript | public function get SupportsModulateInvColorAddAlpha() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.ModulateInvColorAddAlpha is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsMultiplyAdd Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsMultiplyAdd Property

Specifies whether the TextureOperation.MultiplyAdd texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsMultiplyAdd As Boolean
C# | public bool SupportsMultiplyAdd { get; }
C++ public:
property bool SupportsMultiplyAdd {
bool get();
}
JScript | public function get SupportsMultiplyAdd() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.MultiplyAdd is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsPreModulate Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsPreModulate Property

Specifies whether the TextureOperation.PreModulate texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsPreModulate As Boolean
C# | public bool SupportsPreModulate { get; }
C++ public:
property bool SupportsPreModulate {
bool get();
}
JScript | public function get SupportsPreModulate() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.PreModulate is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsSelectArgument1 Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsSelectArgument1 Property

Specifies whether the TextureOperation.SelectArgument1 texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsSelectArgument1 As Boolean
C# | public bool SupportsSelectArgument1 { get; }
C++ public:
property bool SupportsSelectArgument1 {
bool get();
}
JScript | public function get SupportsSelectArgument1() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.SelectArgument1 is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsSelectArgument2 Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsSelectArgument2 Property

Specifies whether the TextureOperation.SelectArgument2 texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsSelectArgument2 As Boolean
C# | public bool SupportsSelectArgument2 { get; }
C++ public:
property bool SupportsSelectArgument2 {
bool get();
}
JScript | public function get SupportsSelectArgument2() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.SelectArgument2 is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureOperationCaps.SupportsSubtract Property (Microsoft.DirectX.Direct3D)

TextureOperationCaps.SupportsSubtract Property

Specifies whether the TextureOperation.Subtract texture blending operation is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsSubtract As Boolean
C# | public bool SupportsSubtract { get; }
C++ public:
property bool SupportsSubtract {
bool get();
}
JScript | public function get SupportsSubtract() : boolean

Property Value

System.Boolean
Value that is true if TextureOperation.Subtract is supported, or false if it is not.

This property is read-only.

See Also

  • TextureOperation


TextureRequirements Structure (Microsoft.DirectX.Direct3D)

TextureRequirements Structure

Contains texture creation parameters.

Definition

Visual Basic | Public Structure TextureRequirements
C# | public struct TextureRequirements
C++ | public value class TextureRequirements sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
TextureRequirements | Initializes a new instance of the TextureRequirements class.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Format | Retrieves or sets the desired pixel format.
Height | Retrieves or sets the height for a texture.
NumberMipLevels | Retrieves or sets the number of mipmap levels for a texture.
Width | Retrieves or sets the width for a texture.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextureRequirements.TextureRequirements() Constructor (Microsoft.DirectX.Direct3D)

TextureRequirements.TextureRequirements Constructor

Initializes a new instance of the TextureRequirements class.

Definition

Visual Basic | Public Sub New()
C# | public TextureRequirements();
C++ public:
TextureRequirements();
JScript | public function TextureRequirements();


TextureRequirements.ToString() Method (Microsoft.DirectX.Direct3D)

TextureRequirements.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


TextureRequirements.Format Property (Microsoft.DirectX.Direct3D)

TextureRequirements.Format Property

Retrieves or sets the desired pixel format.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
Value of the Format class that specifies the pixel format to set or retrieve.

This property is read/write.


TextureRequirements.Height Property (Microsoft.DirectX.Direct3D)

TextureRequirements.Height Property

Retrieves or sets the height for a texture.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer value that represents the height of the texture, in pixels.

This property is read/write.


TextureRequirements.NumberMipLevels Property (Microsoft.DirectX.Direct3D)

TextureRequirements.NumberMipLevels Property

Retrieves or sets the number of mipmap levels for a texture.

Definition

Visual Basic | Public Property NumberMipLevels As Integer
C# | public int NumberMipLevels { get; set; }
C++ public:
property int NumberMipLevels {
int get();
void set(int value);
}
JScript public function get NumberMipLevels() : int
public function set NumberMipLevels(int);

Property Value

System.Int32
Integer value that represents the mipmap levels to set or retrieve.

This property is read/write.


TextureRequirements.Width Property (Microsoft.DirectX.Direct3D)

TextureRequirements.Width Property

Retrieves or sets the width for a texture.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer value that represents the width of the texture in pixels.

This property is read/write.


TrackDescription Structure (Microsoft.DirectX.Direct3D)

TrackDescription Structure

Describes an animation track and specifies its weight and speed at a given time.

Definition

Visual Basic | Public Structure TrackDescription
C# | public struct TrackDescription
C++ | public value class TrackDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TrackDescription | Initializes a new instance of the TrackDescription class.

Properties

Property | Description
Enable | Retrieves or sets a track's enable/disable parameter.
Position | Retrieves or sets a track's time position in the local time frame of its current animation set.
Priority | Retrieves or sets a track's priority type as defined in PriorityType.
Speed | Retrieves or sets the speed value.
Weight | Retrieves or sets the weight value.

Remarks

The data that this method returns is used to scale and translate animation key frames.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TrackDescription.ToString() Method (Microsoft.DirectX.Direct3D)

TrackDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


TrackDescription.TrackDescription() Constructor (Microsoft.DirectX.Direct3D)

TrackDescription.TrackDescription Constructor

Initializes a new instance of the TrackDescription class.

Definition

Visual Basic | Public Sub New()
C# | public TrackDescription();
C++ public:
TrackDescription();
JScript | public function TrackDescription();


TrackDescription.Enable Property (Microsoft.DirectX.Direct3D)

TrackDescription.Enable Property

Retrieves or sets a track's enable/disable parameter.

Definition

Visual Basic | Public Property Enable As Boolean
C# | public bool Enable { get; set; }
C++ public:
property bool Enable {
bool get();
void set(bool value);
}
JScript public function get Enable() : boolean
public function set Enable(boolean);

Property Value

System.Boolean
Value that is true to enable the track, or false to disable it.

This property is read/write.


TrackDescription.Position Property (Microsoft.DirectX.Direct3D)

TrackDescription.Position Property

Retrieves or sets a track's time position in the local time frame of its current animation set.

Definition

Visual Basic | Public Property Position As Double
C# | public double Position { get; set; }
C++ public:
property double Position {
double get();
void set(double value);
}
JScript public function get Position() : double
public function set Position(double);

Property Value

System.Double
Time position of the track.

This property is read/write.


TrackDescription.Priority Property (Microsoft.DirectX.Direct3D)

TrackDescription.Priority Property

Retrieves or sets a track's priority type as defined in PriorityType.

Definition

Visual Basic | Public Property Priority As PriorityType
C# | public PriorityType Priority { get; set; }
C++ public:
property PriorityType Priority {
PriorityType get();
void set(PriorityType value);
}
JScript public function get Priority() : PriorityType
public function set Priority(PriorityType);

Property Value

Microsoft.DirectX.Direct3D.PriorityType
Priority type of the track.

This property is read/write.


TrackDescription.Speed Property (Microsoft.DirectX.Direct3D)

TrackDescription.Speed Property

Retrieves or sets the speed value.

Definition

Visual Basic | Public Property Speed As Single
C# | public float Speed { get; set; }
C++ public:
property float Speed {
float get();
void set(float value);
}
JScript public function get Speed() : float
public function set Speed(float);

Property Value

System.Single
Speed value.

This property is read/write.

Remarks

This value is used as a multiplier to scale a track's period.


TrackDescription.Weight Property (Microsoft.DirectX.Direct3D)

TrackDescription.Weight Property

Retrieves or sets the weight value.

Definition

Visual Basic | Public Property Weight As Single
C# | public float Weight { get; set; }
C++ public:
property float Weight {
float get();
void set(float value);
}
JScript public function get Weight() : float
public function set Weight(float);

Property Value

System.Single
Weight value.

This property is read/write.

Remarks

The weight determines how much of a track to blend with other tracks in the mixer.


CustomVertex.Transformed Structure (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed Structure

Describes a custom vertex format structure that contains transformed vertices.

Definition

Visual Basic | Public Structure Transformed
C# | public struct Transformed
C++ | public value class Transformed sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Rhw | Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
Transformed | Initializes a new instance of the CustomVertex.Transformed class.

Properties

Property | Description
Position | Retrieves or sets the transformed position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.Transformed structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.Transformed.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.Transformed.Transformed Constructor ()

Initializes a new instance of the CustomVertex.Transformed class.

Overload List

public Transformed(float, float, float, float);
public Transformed(Vector4);


CustomVertex.Transformed.Transformed(Vector4) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.Transformed Constructor

Initializes a new instance of the CustomVertex.Transformed class.

Definition

Visual Basic Public Sub New( _
ByVal value As Vector4 _
)
C# public Transformed(
Vector4 value
);
C++ public:
Transformed(
Vector4 value
);
JScript public function Transformed(
value : Vector4
);

Parameters

value Microsoft.DirectX.Vector4
A Vector4 object that contains the position.


CustomVertex.Transformed.Transformed(Single,Single,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.Transformed Constructor

Initializes a new instance of the CustomVertex.Transformed class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal rhwvalue As Single _
)
C# public Transformed(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue
);
C++ public:
Transformed(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue
);
JScript public function Transformed(
xvalue : float,
yvalue : float,
zvalue : float,
rhwvalue : float
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
rhwvalue System.Single
Floating-point value that represents the reciprocal homogeneous w (RHW) component of the transformed vertex.


CustomVertex.Transformed.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.Position Property

Retrieves or sets the transformed position.

Definition

Visual Basic | Public Property Position As Vector4
C# | public Vector4 Position { get; set; }
C++ public:
property Vector4 Position {
Vector4 get();
void set(Vector4 value);
}
JScript public function get Position() : Vector4
public function set Position(Vector4);

Property Value

Microsoft.DirectX.Vector4
A Vector4 object that contains the transformed position.

This property is read/write.


CustomVertex.Transformed.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.StrideSize Property

Retrieves the size of the CustomVertex.Transformed structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.Transformed.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.Transformed.Rhw Field (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.Rhw Field

Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.

Definition

Visual Basic | Public Rhw As Single
C# | public Single Rhw;
C++ | public: Single Rhw;
JScript | public var Rhw : Single

Field Value

System.Single
Floating-point value that represents the RHW component of the position.

This field is read/write.


CustomVertex.Transformed.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.Transformed.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.Transformed.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.Transformed.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.TransformedColored Structure (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored Structure

Describes a custom vertex format structure that contains transformed vertices and color information.

Definition

Visual Basic | Public Structure TransformedColored
C# | public struct TransformedColored
C++ | public value class TransformedColored sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Rhw | Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TransformedColored | Initializes a new instance of the CustomVertex.TransformedColored class.

Properties

Property | Description
Position | Retrieves or sets the transformed position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.TransformedColored structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.TransformedColored.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.TransformedColored.TransformedColored Constructor ()

Initializes a new instance of the CustomVertex.TransformedColored class.

Overload List

public TransformedColored(float, float, float, float, int);
public TransformedColored(Vector4, int);


CustomVertex.TransformedColored.TransformedColored(Vector4,Int32) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.TransformedColored Constructor

 Language:

Initializes a new instance of the CustomVertex.TransformedColored class.

Definition

Visual Basic Public Sub New( _
ByVal value As Vector4, _
ByVal c As Integer _
)
C# public TransformedColored(
Vector4 value,
int c
);
C++ public:
TransformedColored(
Vector4 value,
int c
);
JScript public function TransformedColored(
value : Vector4,
c : int
);

Parameters

value Microsoft.DirectX.Vector4
A Vector4 object that contains the position.
c System.Int32
Integer that represents the vertex color value.


CustomVertex.TransformedColored.TransformedColored(Single,Single,Single,Single,Int32) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.TransformedColored Constructor

 Language:

Initializes a new instance of the CustomVertex.TransformedColored class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal rhwvalue As Single, _
ByVal c As Integer _
)
C# public TransformedColored(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
int c
);
C++ public:
TransformedColored(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
int c
);
JScript public function TransformedColored(
xvalue : float,
yvalue : float,
zvalue : float,
rhwvalue : float,
c : int
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
rhwvalue System.Single
Floating-point value that represents the reciprocal homogeneous w (RHW) component of the transformed vertex.
c System.Int32
Integer that represents the vertex color value.


CustomVertex.TransformedColored.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.Position Property

Retrieves or sets the transformed position.

Definition

Visual Basic | Public Property Position As Vector4
C# | public Vector4 Position { get; set; }
C++ public:
property Vector4 Position {
Vector4 get();
void set(Vector4 value);
}
JScript public function get Position() : Vector4
public function set Position(Vector4);

Property Value

Microsoft.DirectX.Vector4
A Vector4 object that contains the transformed position.

This property is read/write.


CustomVertex.TransformedColored.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.StrideSize Property

Retrieves the size of the CustomVertex.TransformedColored structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.TransformedColored.Color Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.Color Field

Retrieves or sets the vertex color.

Definition

Visual Basic | Public Color As Int32
C# | public Int32 Color;
C++ | public: Int32 Color;
JScript | public var Color : Int32

Field Value

System.Int32
Integer that represents the vertex color.

This field is read/write.


CustomVertex.TransformedColored.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.TransformedColored.Rhw Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.Rhw Field

Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.

Definition

Visual Basic | Public Rhw As Single
C# | public Single Rhw;
C++ | public: Single Rhw;
JScript | public var Rhw : Single

Field Value

System.Single
Floating-point value that represents the RHW component of the position.

This field is read/write.


CustomVertex.TransformedColored.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.TransformedColored.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.TransformedColored.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColored.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.TransformedColoredTextured Structure (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured Structure

Describes a custom vertex format structure that contains transformed vertices, color, and one set of texture coordinates.

Definition

Visual Basic | Public Structure TransformedColoredTextured
C# | public struct TransformedColoredTextured
C++ | public value class TransformedColoredTextured sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
Color | Retrieves or sets the vertex color.
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Rhw | Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TransformedColoredTextured | Initializes a new instance of the CustomVertex.TransformedColoredTextured class.

Properties

Property | Description
Position | Retrieves or sets the transformed position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.TransformedColoredTextured structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.TransformedColoredTextured.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.TransformedColoredTextured.TransformedColoredTextured Constructor ()

Initializes a new instance of the CustomVertex.TransformedColoredTextured class.

Overload List

public TransformedColoredTextured(float, float, float, float, int, float, float);
public TransformedColoredTextured(Vector4, int, float, float);


CustomVertex.TransformedColoredTextured.TransformedColoredTextured(Vector4,Int32,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.TransformedColoredTextured Constructor

 Language:

Initializes a new instance of the CustomVertex.TransformedColoredTextured class.

Definition

Visual Basic Public Sub New( _
ByVal value As Vector4, _
ByVal c As Integer, _
ByVal u As Single, _
ByVal v As Single _
)
C# public TransformedColoredTextured(
Vector4 value,
int c,
float u,
float v
);
C++ public:
TransformedColoredTextured(
Vector4 value,
int c,
float u,
float v
);
JScript public function TransformedColoredTextured(
value : Vector4,
c : int,
u : float,
v : float
);

Parameters

value Microsoft.DirectX.Vector4
A Vector4 object that contains the position.
c System.Int32
Integer that represents the vertex color value.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.TransformedColoredTextured.TransformedColoredTextured(Single,Single,Single,Single,Int32,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.TransformedColoredTextured Constructor

 Language:

Initializes a new instance of the CustomVertex.TransformedColoredTextured class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal rhwvalue As Single, _
ByVal c As Integer, _
ByVal u As Single, _
ByVal v As Single _
)
C# public TransformedColoredTextured(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
int c,
float u,
float v
);
C++ public:
TransformedColoredTextured(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
int c,
float u,
float v
);
JScript public function TransformedColoredTextured(
xvalue : float,
yvalue : float,
zvalue : float,
rhwvalue : float,
c : int,
u : float,
v : float
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
rhwvalue System.Single
Floating-point value that represents the reciprocal homogeneous w (RHW) component of the transformed vertex.
c System.Int32
Integer that represents the vertex color value.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.TransformedColoredTextured.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.Position Property

Retrieves or sets the transformed position.

Definition

Visual Basic | Public Property Position As Vector4
C# | public Vector4 Position { get; set; }
C++ public:
property Vector4 Position {
Vector4 get();
void set(Vector4 value);
}
JScript public function get Position() : Vector4
public function set Position(Vector4);

Property Value

Microsoft.DirectX.Vector4
A Vector4 object that contains the transformed position.

This property is read/write.


CustomVertex.TransformedColoredTextured.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.StrideSize Property

Retrieves the size of the CustomVertex.TransformedColoredTextured structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.TransformedColoredTextured.Color Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.Color Field

Retrieves or sets the vertex color.

Definition

Visual Basic | Public Color As Int32
C# | public Int32 Color;
C++ | public: Int32 Color;
JScript | public var Color : Int32

Field Value

System.Int32
Integer that represents the vertex color.

This field is read/write.


CustomVertex.TransformedColoredTextured.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.TransformedColoredTextured.Rhw Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.Rhw Field

Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.

Definition

Visual Basic | Public Rhw As Single
C# | public Single Rhw;
C++ | public: Single Rhw;
JScript | public var Rhw : Single

Field Value

System.Single
Floating-point value that represents the RHW component of the position.

This field is read/write.


CustomVertex.TransformedColoredTextured.Tu Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.Tu Field

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic | Public Tu As Single
C# | public Single Tu;
C++ | public: Single Tu;
JScript | public var Tu : Single

Field Value

System.Single
Floating-point value that represents the u component of the texture coordinate.

This field is read/write.


CustomVertex.TransformedColoredTextured.Tv Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.Tv Field

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic | Public Tv As Single
C# | public Single Tv;
C++ | public: Single Tv;
JScript | public var Tv : Single

Field Value

System.Single
Floating-point value that represents the v component of the texture coordinate.

This field is read/write.


CustomVertex.TransformedColoredTextured.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.TransformedColoredTextured.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.TransformedColoredTextured.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedColoredTextured.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


CustomVertex.TransformedTextured Structure (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured Structure

Describes a custom vertex format structure that contains transformed vertices and one set of texture coordinates.

Definition

Visual Basic | Public Structure TransformedTextured
C# | public struct TransformedTextured
C++ | public value class TransformedTextured sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) Format | Retrieves the VertexFormats for the current custom vertex.
Rhw | Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.
Tu | Retrieves or sets the u component of the texture coordinate.
Tv | Retrieves or sets the v component of the texture coordinate.
X | Retrieves or sets the x component of the position.
Y | Retrieves or sets the y component of the position.
Z | Retrieves or sets the z component of the position.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TransformedTextured | Initializes a new instance of the CustomVertex.TransformedTextured class.

Properties

Property | Description
Position | Retrieves or sets the transformed position.
static (Shared in Visual Basic) StrideSize | Retrieves the size of the CustomVertex.TransformedTextured structure.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CustomVertex Class


CustomVertex.TransformedTextured.ToString() Method (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomVertex.TransformedTextured.TransformedTextured Constructor ()

Initializes a new instance of the CustomVertex.TransformedTextured class.

Overload List

public TransformedTextured(float, float, float, float, float, float);
public TransformedTextured(Vector4, float, float);


CustomVertex.TransformedTextured.TransformedTextured(Vector4,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.TransformedTextured Constructor

 Language:

Initializes a new instance of the CustomVertex.TransformedTextured class.

Definition

Visual Basic Public Sub New( _
ByVal value As Vector4, _
ByVal u As Single, _
ByVal v As Single _
)
C# public TransformedTextured(
Vector4 value,
float u,
float v
);
C++ public:
TransformedTextured(
Vector4 value,
float u,
float v
);
JScript public function TransformedTextured(
value : Vector4,
u : float,
v : float
);

Parameters

value Microsoft.DirectX.Vector4
A Vector4 object that contains the position.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.TransformedTextured.TransformedTextured(Single,Single,Single,Single,Single,Single) Constructor (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.TransformedTextured Constructor

 Language:

Initializes a new instance of the CustomVertex.TransformedTextured class.

Definition

Visual Basic Public Sub New( _
ByVal xvalue As Single, _
ByVal yvalue As Single, _
ByVal zvalue As Single, _
ByVal rhwvalue As Single, _
ByVal u As Single, _
ByVal v As Single _
)
C# public TransformedTextured(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
float u,
float v
);
C++ public:
TransformedTextured(
float xvalue,
float yvalue,
float zvalue,
float rhwvalue,
float u,
float v
);
JScript public function TransformedTextured(
xvalue : float,
yvalue : float,
zvalue : float,
rhwvalue : float,
u : float,
v : float
);

Parameters

xvalue System.Single
Floating-point value that represents the x coordinate of the position.
yvalue System.Single
Floating-point value that represents the y coordinate of the position.
zvalue System.Single
Floating-point value that represents the z coordinate of the position.
rhwvalue System.Single
Floating-point value that represents the reciprocal homogeneous w (RHW) component of the transformed vertex.
u System.Single
Floating-point value that represents the u component of the texture coordinate.
v System.Single
Floating-point value that represents the v component of the texture coordinate.


CustomVertex.TransformedTextured.Position Property (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.Position Property

Retrieves or sets the transformed position.

Definition

Visual Basic | Public Property Position As Vector4
C# | public Vector4 Position { get; set; }
C++ public:
property Vector4 Position {
Vector4 get();
void set(Vector4 value);
}
JScript public function get Position() : Vector4
public function set Position(Vector4);

Property Value

Microsoft.DirectX.Vector4
A Vector4 object that contains the transformed position.

This property is read/write.


CustomVertex.TransformedTextured.StrideSize Property (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.StrideSize Property

Retrieves the size of the CustomVertex.TransformedTextured structure.

Definition

Visual Basic | Public Shared ReadOnly Property StrideSize As Integer
C# | public static int StrideSize { get; }
C++ public:
static property int StrideSize {
int get();
}
JScript | public static function get StrideSize() : int

Property Value

System.Int32
Size of the structure, in bytes.

This property is read-only.


CustomVertex.TransformedTextured.Format Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.Format Field

Retrieves the VertexFormats for the current custom vertex.

Definition

Visual Basic | Public Shared Format As VertexFormats
C# | public static VertexFormats Format;
C++ | public: static VertexFormats Format;
JScript | public static var Format : VertexFormats

Field Value

Microsoft.DirectX.Direct3D.VertexFormats
A VertexFormats object to retrieve.

This field is read-only.


CustomVertex.TransformedTextured.Rhw Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.Rhw Field

Retrieves or sets the reciprocal homogeneous w (RHW) component of the position.

Definition

Visual Basic | Public Rhw As Single
C# | public Single Rhw;
C++ | public: Single Rhw;
JScript | public var Rhw : Single

Field Value

System.Single
Floating-point value that represents the RHW component of the position.

This field is read/write.


CustomVertex.TransformedTextured.Tu Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.Tu Field

Retrieves or sets the u component of the texture coordinate.

Definition

Visual Basic | Public Tu As Single
C# | public Single Tu;
C++ | public: Single Tu;
JScript | public var Tu : Single

Field Value

System.Single
Floating-point value that represents the u component of the texture coordinate.

This field is read/write.


CustomVertex.TransformedTextured.Tv Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.Tv Field

Retrieves or sets the v component of the texture coordinate.

Definition

Visual Basic | Public Tv As Single
C# | public Single Tv;
C++ | public: Single Tv;
JScript | public var Tv : Single

Field Value

System.Single
Floating-point value that represents the v component of the texture coordinate.

This field is read/write.


CustomVertex.TransformedTextured.X Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.X Field

Retrieves or sets the x component of the position.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
Floating-point value that represents the x component of the position.

This field is read/write.


CustomVertex.TransformedTextured.Y Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.Y Field

Retrieves or sets the y component of the position.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
Floating-point value that represents the y component of the position.

This field is read/write.


CustomVertex.TransformedTextured.Z Field (Microsoft.DirectX.Direct3D)

CustomVertex.TransformedTextured.Z Field

Retrieves or sets the z component of the position.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
Floating-point value that represents the z component of the position.

This field is read/write.


TrianglePatchInformation Structure (Microsoft.DirectX.Direct3D)

TrianglePatchInformation Structure

Describes a triangular high-order patch.

Definition

Visual Basic | Public Structure TrianglePatchInformation
C# | public struct TrianglePatchInformation
C++ | public value class TrianglePatchInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
TrianglePatchInformation | Initializes a new instance of the TrianglePatchInformation class.

Properties

Property | Description
BasisType | Retrieves or sets a value that defines the basis type for the triangular high-order patch.
Degree | Retrieves or sets a value that defines the degree type for the triangular high-order patch.
NumberVertices | Retrieves or sets the number of vertices for the triangular high-order patch.
StartVertexOffset | Retrieves or sets the starting vertex offset, in number of vertices.

Remarks

The following diagram identifies the vertex order and segment numbers for a cubic Bezier triangle patch. The vertex order determines the segment numbers used by Device.DrawTrianglePatch. The offset is the number of bytes to the first triangle patch vertex in the vertex buffer.

Triangle patch information

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TrianglePatchInformation.ToString() Method (Microsoft.DirectX.Direct3D)

TrianglePatchInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


TrianglePatchInformation.TrianglePatchInformation() Constructor (Microsoft.DirectX.Direct3D)

TrianglePatchInformation.TrianglePatchInformation Constructor

 Language:

Initializes a new instance of the TrianglePatchInformation class.

Definition

Visual Basic | Public Sub New()
C# | public TrianglePatchInformation();
C++ public:
TrianglePatchInformation();
JScript | public function TrianglePatchInformation();


TrianglePatchInformation.BasisType Property (Microsoft.DirectX.Direct3D)

TrianglePatchInformation.BasisType Property

Retrieves or sets a value that defines the basis type for the triangular high-order patch.

Definition

Visual Basic | Public Property BasisType As BasisType
C# | public BasisType BasisType { get; set; }
C++ public:
property BasisType BasisType {
BasisType get();
void set(BasisType value);
}
JScript public function get BasisType() : BasisType
public function set BasisType(BasisType);

Property Value

Microsoft.DirectX.Direct3D.BasisType
Value from the BasisType enumeration to set or retrieve.

This property is read/write.

Remarks

The only valid value for this member is Basis.Bezier.


TrianglePatchInformation.Degree Property (Microsoft.DirectX.Direct3D)

TrianglePatchInformation.Degree Property

Retrieves or sets a value that defines the degree type for the triangular high-order patch.

Definition

Visual Basic | Public Property Degree As DegreeType
C# | public DegreeType Degree { get; set; }
C++ public:
property DegreeType Degree {
DegreeType get();
void set(DegreeType value);
}
JScript public function get Degree() : DegreeType
public function set Degree(DegreeType);

Property Value

Microsoft.DirectX.Direct3D.DegreeType
Value from the DegreeType enumeration to set or retrieve.

This property is read/write.

Remarks

The following values define the degree type for the triangular high-order patch.

Value | Number of vertices
Cubic | 10
Linear | 3
Quadratic | Not supported.
Quintic | 21


TrianglePatchInformation.NumberVertices Property (Microsoft.DirectX.Direct3D)

TrianglePatchInformation.NumberVertices Property

Retrieves or sets the number of vertices for the triangular high-order patch.

Definition

Visual Basic | Public Property NumberVertices As Integer
C# | public int NumberVertices { get; set; }
C++ public:
property int NumberVertices {
int get();
void set(int value);
}
JScript public function get NumberVertices() : int
public function set NumberVertices(int);

Property Value

System.Int32
Integer value that represents the number of vertices to set or retrieve.

This property is read/write.


TrianglePatchInformation.StartVertexOffset Property (Microsoft.DirectX.Direct3D)

TrianglePatchInformation.StartVertexOffset Property

Retrieves or sets the starting vertex offset, in number of vertices.

Definition

Visual Basic | Public Property StartVertexOffset As Integer
C# | public int StartVertexOffset { get; set; }
C++ public:
property int StartVertexOffset {
int get();
void set(int value);
}
JScript public function get StartVertexOffset() : int
public function set StartVertexOffset(int);

Property Value

System.Int32
Integer value that represents the number of vertices that specify the starting vertex offset.

This property is read/write.


UVAtlasOutput Structure (Microsoft.DirectX.Direct3D)

UVAtlasOutput Structure

Contains texture atlas data returned from UVAtlas member methods.

Definition

Visual Basic | Public Structure UVAtlasOutput
C# | public struct UVAtlasOutput
C++ | public value class UVAtlasOutput sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
UVAtlasOutput | Initializes a new instance of the UVAtlasOutput class.

Properties

Property | Description
FacePartitioning | Gets face partitioning data created as a result of a UVAtlas method.
MaximumStretch | Gets the maximum stretch value output as a result of a UVAtlas method.
Mesh | Gets the mesh created as the result of a UVAtlas method.
NumberCharts | Gets the number of charts created as a result of a UVAtlas method, or the number of charts required to create a texture atlas.
VertexRemapArray | Gets a GraphicsStream that describes the remapping of the vertices of the mesh created by a UVAtlas texture atlas operation.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • UVAtlas

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlasOutput.UVAtlasOutput() Constructor (Microsoft.DirectX.Direct3D)

UVAtlasOutput.UVAtlasOutput Constructor

Initializes a new instance of the UVAtlasOutput class.

Definition

Visual Basic | Public Sub New()
C# | public UVAtlasOutput();
C++ public:
UVAtlasOutput();
JScript | public function UVAtlasOutput();

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlasOutput.FacePartitioning Property (Microsoft.DirectX.Direct3D)

UVAtlasOutput.FacePartitioning Property

Gets face partitioning data created as a result of a UVAtlas method.

Definition

Visual Basic | Public ReadOnly Property FacePartitioning As GraphicsStream
C# | public GraphicsStream FacePartitioning { get; }
C++ public:
property GraphicsStream^ FacePartitioning {
GraphicsStream^ get();
}
JScript | public function get FacePartitioning() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream object that contains the final face partitioning data.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlasOutput.MaximumStretch Property (Microsoft.DirectX.Direct3D)

UVAtlasOutput.MaximumStretch Property

Gets the maximum stretch value output as a result of a UVAtlas method.

Definition

Visual Basic | Public ReadOnly Property MaximumStretch As Single
C# | public float MaximumStretch { get; }
C++ public:
property float MaximumStretch {
float get();
}
JScript | public function get MaximumStretch() : float

Property Value

System.Single
A Single Leave Site value that represents the maximum stretch value generated by the atlas algorithm.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlasOutput.Mesh Property (Microsoft.DirectX.Direct3D)

UVAtlasOutput.Mesh Property

Gets the mesh created as the result of a UVAtlas method.

Definition

Visual Basic | Public ReadOnly Property Mesh As Mesh
C# | public Mesh Mesh { get; }
C++ public:
property Mesh^ Mesh {
Mesh^ get();
}
JScript | public function get Mesh() : Mesh

Property Value

Microsoft.DirectX.Direct3D.Mesh
A Mesh object created from the atlas operation.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlasOutput.NumberCharts Property (Microsoft.DirectX.Direct3D)

UVAtlasOutput.NumberCharts Property

Gets the number of charts created as a result of a UVAtlas method, or the number of charts required to create a texture atlas.

Definition

Visual Basic | Public ReadOnly Property NumberCharts As Integer
C# | public int NumberCharts { get; }
C++ public:
property int NumberCharts {
int get();
}
JScript | public function get NumberCharts() : int

Property Value

System.Int32
An Int32 Leave Site value that represents the number of charts created in the case of a successful UVAtlas texture atlas creation, or the number of charts required to create an atlas. See Remarks.

This property is read-only.

Remarks

If UVAtlas.Pack or UVAtlas.Partition is called with the value of maxChartNumber set too low, a Direct3DXException will be thrown and this property will return the minimum number of charts required to create an atlas.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


UVAtlasOutput.VertexRemapArray Property (Microsoft.DirectX.Direct3D)

UVAtlasOutput.VertexRemapArray Property

Gets a GraphicsStream that describes the remapping of the vertices of the mesh created by a UVAtlas texture atlas operation.

Definition

Visual Basic | Public ReadOnly Property VertexRemapArray As GraphicsStream
C# | public GraphicsStream VertexRemapArray { get; }
C++ public:
property GraphicsStream^ VertexRemapArray {
GraphicsStream^ get();
}
JScript | public function get VertexRemapArray() : GraphicsStream

Property Value

Microsoft.DirectX.GraphicsStream
A GraphicsStream identifying the original vertex each final vertex came from, if the vertex needed to be split.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


ValidateDeviceParams Structure (Microsoft.DirectX.Direct3D)

ValidateDeviceParams Structure

Describes the number of passes and the result code returned from a ValidateDevice call.

Definition

Visual Basic | Public Structure ValidateDeviceParams
C# | public struct ValidateDeviceParams
C++ | public value class ValidateDeviceParams sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
ValidateDeviceParams | Initializes a new instance of the ValidateDeviceParams class.

Properties

Property | Description
Passes | Retrieves the number of rendering passes needed to complete the desired effect through multipass rendering.
Result | Retrieves the result code of a validation.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ValidateDeviceParams.ToString() Method (Microsoft.DirectX.Direct3D)

ValidateDeviceParams.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ValidateDeviceParams.ValidateDeviceParams() Constructor (Microsoft.DirectX.Direct3D)

ValidateDeviceParams.ValidateDeviceParams Constructor

Initializes a new instance of the ValidateDeviceParams class.

Definition

Visual Basic | Public Sub New()
C# | public ValidateDeviceParams();
C++ public:
ValidateDeviceParams();
JScript | public function ValidateDeviceParams();


ValidateDeviceParams.Passes Property (Microsoft.DirectX.Direct3D)

ValidateDeviceParams.Passes Property

Retrieves the number of rendering passes needed to complete the desired effect through multipass rendering.

Definition

Visual Basic | Public ReadOnly Property Passes As Integer
C# | public int Passes { get; }
C++ public:
property int Passes {
int get();
}
JScript | public function get Passes() : int

Property Value

System.Int32
Integer that represents the number of rendering passes to retrieve.

This property is read-only.


ValidateDeviceParams.Result Property (Microsoft.DirectX.Direct3D)

ValidateDeviceParams.Result Property

Retrieves the result code of a validation.

Definition

Visual Basic | Public ReadOnly Property Result As ResultCode
C# | public ResultCode Result { get; }
C++ public:
property ResultCode Result {
ResultCode get();
}
JScript | public function get Result() : ResultCode

Property Value

Microsoft.DirectX.Direct3D.ResultCode
Value of the ResultCode enumeration to retrieve.

This property is read-only.


VertexBufferDescription Structure (Microsoft.DirectX.Direct3D)

VertexBufferDescription Structure

Describes a vertex buffer.

Definition

Visual Basic | Public Structure VertexBufferDescription
C# | public struct VertexBufferDescription
C++ | public value class VertexBufferDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VertexBufferDescription | Initializes a new instance of the VertexBufferDescription class.

Properties

Property | Description
Format | Retrieves or sets a member of the Format enumeration that describes the surface format of the vertex buffer data.
Pool | Retrieves or sets a member of the Pool enumeration that specifies the class of memory allocated for the current vertex buffer.
Size | Retrieves or sets the size of the vertex buffer.
Type | Retrieves or sets a member of the ResourceType enumeration that identifies the current resource as a vertex buffer.
Usage | Retrieves or sets a combination of Usage enumeration values.
VertexFormat | Retrieves or sets a combination of VertexFormats enumeration values that describe the vertex format of the vertices in the current buffer.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexBufferDescription.ToString() Method (Microsoft.DirectX.Direct3D)

VertexBufferDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VertexBufferDescription.VertexBufferDescription() Constructor (Microsoft.DirectX.Direct3D)

VertexBufferDescription.VertexBufferDescription Constructor

Initializes a new instance of the VertexBufferDescription class.

Definition

Visual Basic | Public Sub New()
C# | public VertexBufferDescription();
C++ public:
VertexBufferDescription();
JScript | public function VertexBufferDescription();


VertexBufferDescription.Format Property (Microsoft.DirectX.Direct3D)

VertexBufferDescription.Format Property

Retrieves or sets a member of the Format enumeration that describes the surface format of the vertex buffer data.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
Value of the Format enumeration to set or retrieve.

This property is read/write.


VertexBufferDescription.Pool Property (Microsoft.DirectX.Direct3D)

VertexBufferDescription.Pool Property

Retrieves or sets a member of the Pool enumeration that specifies the class of memory allocated for the current vertex buffer.

Definition

Visual Basic | Public Property Pool As Pool
C# | public Pool Pool { get; set; }
C++ public:
property Pool Pool {
Pool get();
void set(Pool value);
}
JScript public function get Pool() : Pool
public function set Pool(Pool);

Property Value

Microsoft.DirectX.Direct3D.Pool
Value of the Pool enumeration to set or retrieve. Can not be Pool.Scratch.

This property is read/write.


VertexBufferDescription.Size Property (Microsoft.DirectX.Direct3D)

VertexBufferDescription.Size Property

Retrieves or sets the size of the vertex buffer.

Definition

Visual Basic | Public Property Size As Integer
C# | public int Size { get; set; }
C++ public:
property int Size {
int get();
void set(int value);
}
JScript public function get Size() : int
public function set Size(int);

Property Value

System.Int32
Integer value that specifies the number of bytes in the vertex buffer.

This property is read/write.


VertexBufferDescription.Type Property (Microsoft.DirectX.Direct3D)

VertexBufferDescription.Type Property

Retrieves or sets a member of the ResourceType enumeration that identifies the current resource as a vertex buffer.

Definition

Visual Basic | Public Property Type As ResourceType
C# | public ResourceType Type { get; set; }
C++ public:
property ResourceType Type {
ResourceType get();
void set(ResourceType value);
}
JScript public function get Type() : ResourceType
public function set Type(ResourceType);

Property Value

Microsoft.DirectX.Direct3D.ResourceType
Value of the ResourceType enumeration to set or retrieve.

This property is read/write.


VertexBufferDescription.Usage Property (Microsoft.DirectX.Direct3D)

VertexBufferDescription.Usage Property

Retrieves or sets a combination of Usage enumeration values.

Definition

Visual Basic | Public Property Usage As Usage
C# | public Usage Usage { get; set; }
C++ public:
property Usage Usage {
Usage get();
void set(Usage value);
}
JScript public function get Usage() : Usage
public function set Usage(Usage);

Property Value

Microsoft.DirectX.Direct3D.Usage
Values of the Usage enumeration to set or retrieve.

This property is read/write.


VertexBufferDescription.VertexFormat Property (Microsoft.DirectX.Direct3D)

VertexBufferDescription.VertexFormat Property

Retrieves or sets a combination of VertexFormats enumeration values that describe the vertex format of the vertices in the current buffer.

Definition

Visual Basic | Public Property VertexFormat As VertexFormats
C# | public VertexFormats VertexFormat { get; set; }
C++ public:
property VertexFormats VertexFormat {
VertexFormats get();
void set(VertexFormats value);
}
JScript public function get VertexFormat() : VertexFormats
public function set VertexFormat(VertexFormats);

Property Value

Microsoft.DirectX.Direct3D.VertexFormats
Values of the VertexFormats enumeration to set or retrieve.

This property is read/write.


VertexCache Structure (Microsoft.DirectX.Direct3D)

VertexCache Structure

Defines vertex cache optimization hints.

Definition

Visual Basic | Public Structure VertexCache
C# | public struct VertexCache
C++ | public value class VertexCache sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VertexCache | Initializes a new instance of the VertexCache class.

Properties

Property | Description
CacheSize | Retrieves the cache size, which is used as a target for optimization.
MagicNumber | Retrieves a value that is used by internal optimization methods to determine when to restart strips.
OptimizationMethod | Retrieves the optimization method.
Pattern | Retrieves the bit pattern of the vertex cache.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexCache.ToString() Method (Microsoft.DirectX.Direct3D)

VertexCache.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VertexCache.VertexCache() Constructor (Microsoft.DirectX.Direct3D)

VertexCache.VertexCache Constructor

Initializes a new instance of the VertexCache class.

Definition

Visual Basic | Public Sub New()
C# | public VertexCache();
C++ public:
VertexCache();
JScript | public function VertexCache();


VertexCache.CacheSize Property (Microsoft.DirectX.Direct3D)

VertexCache.CacheSize Property

Retrieves the cache size, which is used as a target for optimization.

Definition

Visual Basic | Public ReadOnly Property CacheSize As Integer
C# | public int CacheSize { get; }
C++ public:
property int CacheSize {
int get();
}
JScript | public function get CacheSize() : int

Property Value

System.Int32
Cache size for which to optimize.

This property is read-only.

Remarks

The cache size is required only if OptimizationMethod is set to 1.


VertexCache.MagicNumber Property (Microsoft.DirectX.Direct3D)

VertexCache.MagicNumber Property

Retrieves a value that is used by internal optimization methods to determine when to restart strips.

Definition

Visual Basic | Public ReadOnly Property MagicNumber As Integer
C# | public int MagicNumber { get; }
C++ public:
property int MagicNumber {
int get();
}
JScript | public function get MagicNumber() : int

Property Value

System.Int32
Value that determines when to restart strips.

This property is read-only.

Remarks

This value cannot be set or modified by a user. It is required only if OptimizationMethod is set to 1.


VertexCache.OptimizationMethod Property (Microsoft.DirectX.Direct3D)

VertexCache.OptimizationMethod Property

Retrieves the optimization method.

Definition

Visual Basic | Public ReadOnly Property OptimizationMethod As Integer
C# | public int OptimizationMethod { get; }
C++ public:
property int OptimizationMethod {
int get();
}
JScript | public function get OptimizationMethod() : int

Property Value

System.Int32
Value that is 0 to get the longest strips, or 1 to optimize the vertex cache.

This property is read-only.


VertexCache.Pattern Property (Microsoft.DirectX.Direct3D)

VertexCache.Pattern Property

Retrieves the bit pattern of the vertex cache.

Definition

Visual Basic | Public ReadOnly Property Pattern As Integer
C# | public int Pattern { get; }
C++ public:
property int Pattern {
int get();
}
JScript | public function get Pattern() : int

Property Value

System.Int32
Value in the four-character code (FOURCC) ('C', 'A', 'C', 'H') format that specifies the bit pattern.

This property is read-only.


VertexElement Structure (Microsoft.DirectX.Direct3D)

VertexElement Structure

How Do I...?
  • Create a Vertex Declaration

Defines input vertex data to the pipeline.

Definition

Visual Basic | Public Structure VertexElement
C# | public struct VertexElement
C++ | public value class VertexElement sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) VertexDeclarationEnd | Retrieves a VertexElement structure that is considered to be the end of vertex shader declaration.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VertexElement | Initializes a new instance of the VertexElement class.

Properties

Property | Description
DeclarationMethod | Retrieves or sets the tessellator processing method.
DeclarationType | Retrieves or sets the data type that defines the data size for the vertex element.
DeclarationUsage | Retrieves or sets one or more usage values that define the intended use of the vertex data.
Offset | Retrieves or sets the offset (if any) from the beginning of the stream to the beginning of the vertex data.
Stream | Retrieves or sets the stream number (or index) to use.
UsageIndex | Modifies the usage data to allow the user to specify multiple usage types.

How Do I...?

Create a Vertex Declaration

This example demonstrates how to create a vertex declaration.

[C#]

As shown in the following C# code example, first declare a VertexElement array to hold the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).

Create a VertexDeclaration instance using the Device and VertexElement array previously created.

Note: The offset parameter of each element is the cumulative offset of the elements from the start of the declaration. For example, the second element is offset 12 bytes, since it is three floats of four bytes each, or (3 * sizeof(float) = 12).

// Create the vertex element array.
VertexElement[] elements = new VertexElement[]
{
    new VertexElement(0, 0, DeclarationType.Float3,
                            DeclarationMethod.Default,
                            DeclarationUsage.Position, 0),

    new VertexElement(0, 12, DeclarationType.Float3,
                             DeclarationMethod.Default,
                             DeclarationUsage.Normal, 0),

    new VertexElement(0, 24, DeclarationType.Float2,
                             DeclarationMethod.Default,
                             DeclarationUsage.TextureCoordinate, 0),

    VertexElement.VertexDeclarationEnd
};

// Use the vertex element array to create a vertex declaration.
VertexDeclaration decl = new VertexDeclaration(device, elements);

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexElement.ToString() Method (Microsoft.DirectX.Direct3D)

VertexElement.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VertexElement.VertexElement(Int16,Int16,DeclarationType,DeclarationMethod,DeclarationUsage,Byte) Constructor (Microsoft.DirectX.Direct3D)

VertexElement.VertexElement Constructor

Initializes a new instance of the VertexElement class.

Definition

Visual Basic Public Sub New( _
ByVal stream As Short, _
ByVal offset As Short, _
ByVal declType As DeclarationType, _
ByVal declMethod As DeclarationMethod, _
ByVal declUsage As DeclarationUsage, _
ByVal usageIndex As Byte _
)
C# public VertexElement(
short stream,
short offset,
DeclarationType declType,
DeclarationMethod declMethod,
DeclarationUsage declUsage,
byte usageIndex
);
C++ public:
VertexElement(
short stream,
short offset,
DeclarationType declType,
DeclarationMethod declMethod,
DeclarationUsage declUsage,
unsigned char usageIndex
);
JScript public function VertexElement(
stream : short,
offset : short,
declType : DeclarationType,
declMethod : DeclarationMethod,
declUsage : DeclarationUsage,
usageIndex : byte
);

Parameters

stream System.Int16
Stream number (or index) to use.
offset System.Int16
Offset (if any) from the beginning of the stream to the beginning of the vertex data.
declType Microsoft.DirectX.Direct3D.DeclarationType
A DeclarationType enumeration value specifying one of several predefined types that define the vertex data size.
declMethod Microsoft.DirectX.Direct3D.DeclarationMethod
A DeclarationMethod enumeration value that specifies the tessellator processing method. These methods determine how the tessellator interprets/operates on the vertex data.
declUsage Microsoft.DirectX.Direct3D.DeclarationUsage
A DeclarationUsage enumeration value that defines the intended use of the vertex data.
usageIndex System.Byte
Modifies the usage data to allow the user to specify multiple usage types.

Remarks

Vertex data is defined using an array of VertexElement structures. The size of the array includes the VertexDeclarationEnd field, which ends the declaration. The inclusion of this field means that the array count is actually higher than the number of valid vertex elements by one.


VertexElement.DeclarationMethod Property (Microsoft.DirectX.Direct3D)

VertexElement.DeclarationMethod Property

Retrieves or sets the tessellator processing method.

Definition

Visual Basic | Public Property DeclarationMethod As DeclarationMethod
C# | public DeclarationMethod DeclarationMethod { get; set; }
C++ public:
property DeclarationMethod DeclarationMethod {
DeclarationMethod get();
void set(DeclarationMethod value);
}
JScript public function get DeclarationMethod() : DeclarationMethod
public function set DeclarationMethod(DeclarationMethod);

Property Value

Microsoft.DirectX.Direct3D.DeclarationMethod
Value of the DeclarationMethod enumeration that specifies the tessellator processing method to set or retrieve.

This property is read/write.


VertexElement.DeclarationType Property (Microsoft.DirectX.Direct3D)

VertexElement.DeclarationType Property

Retrieves or sets the data type that defines the data size for the vertex element.

Definition

Visual Basic | Public Property DeclarationType As DeclarationType
C# | public DeclarationType DeclarationType { get; set; }
C++ public:
property DeclarationType DeclarationType {
DeclarationType get();
void set(DeclarationType value);
}
JScript public function get DeclarationType() : DeclarationType
public function set DeclarationType(DeclarationType);

Property Value

Microsoft.DirectX.Direct3D.DeclarationType
Value of the DeclarationType enumeration to set or retrieve.

This property is read/write.


VertexElement.DeclarationUsage Property (Microsoft.DirectX.Direct3D)

VertexElement.DeclarationUsage Property

Retrieves or sets one or more usage values that define the intended use of the vertex data.

Definition

Visual Basic | Public Property DeclarationUsage As DeclarationUsage
C# | public DeclarationUsage DeclarationUsage { get; set; }
C++ public:
property DeclarationUsage DeclarationUsage {
DeclarationUsage get();
void set(DeclarationUsage value);
}
JScript public function get DeclarationUsage() : DeclarationUsage
public function set DeclarationUsage(DeclarationUsage);

Property Value

Microsoft.DirectX.Direct3D.DeclarationUsage
Value of the DeclarationUsage enumeration to set or retrieve.

This property is read/write.


VertexElement.Offset Property (Microsoft.DirectX.Direct3D)

VertexElement.Offset Property

Retrieves or sets the offset (if any) from the beginning of the stream to the beginning of the vertex data.

Definition

Visual Basic | Public Property Offset As Short
C# | public short Offset { get; set; }
C++ public:
property short Offset {
short get();
void set(short value);
}
JScript public function get Offset() : short
public function set Offset(short);

Property Value

System.Int16
Offset, in bytes, to the start of the vertex data.

This property is read/write.


VertexElement.Stream Property (Microsoft.DirectX.Direct3D)

VertexElement.Stream Property

Retrieves or sets the stream number (or index) to use.

Definition

Visual Basic | Public Property Stream As Short
C# | public short Stream { get; set; }
C++ public:
property short Stream {
short get();
void set(short value);
}
JScript public function get Stream() : short
public function set Stream(short);

Property Value

System.Int16
Stream number (or index) to use.

This property is read/write.


VertexElement.UsageIndex Property (Microsoft.DirectX.Direct3D)

VertexElement.UsageIndex Property

Modifies the usage data to allow the user to specify multiple usage types.

Definition

Visual Basic | Public Property UsageIndex As Byte
C# | public byte UsageIndex { get; set; }
C++ public:
property unsigned char UsageIndex {
unsigned char get();
void set(unsigned char value);
}
JScript public function get UsageIndex() : byte
public function set UsageIndex(byte);

Property Value

System.Byte
Byte that represents the usage index.

This property is read/write.

Remarks

The UsageIndex structure is used in conjunction with VertexElement.DeclarationUsage to specify the semantic of a vertex element.


VertexElement.VertexDeclarationEnd Field (Microsoft.DirectX.Direct3D)

VertexElement.VertexDeclarationEnd Field

How Do I...?
  • Create a Vertex Declaration

Retrieves a VertexElement structure that is considered to be the end of vertex shader declaration.

Definition

Visual Basic | Public Shared VertexDeclarationEnd As VertexElement
C# | public static VertexElement VertexDeclarationEnd;
C++ | public: static VertexElement VertexDeclarationEnd;
JScript | public static var VertexDeclarationEnd : VertexElement

Field Value

Microsoft.DirectX.Direct3D.VertexElement
A VertexElement structure that marks the end of vertex shader declaration.

This field is read-only.

Remarks

Vertex data is defined using an array of VertexElement structures. The size of the array includes the VertexDeclarationEnd field, which ends the declaration. The inclusion of this field means that the array count is actually higher than the number of valid vertex elements by one.

How Do I...?

Create a Vertex Declaration

This example demonstrates how to create a vertex declaration.

[C#]

As shown in the following C# code example, first declare a VertexElement array to hold the vertex shader declaration. The declaration array must end with VertexElement.VertexDeclarationEnd as the last element (the size of the vertex element array will be one more than the number of actual vertex elements).

Create a VertexDeclaration instance using the Device and VertexElement array previously created.

Note: The offset parameter of each element is the cumulative offset of the elements from the start of the declaration. For example, the second element is offset 12 bytes, since it is three floats of four bytes each, or (3 * sizeof(float) = 12).

// Create the vertex element array.
VertexElement[] elements = new VertexElement[]
{
    new VertexElement(0, 0, DeclarationType.Float3,
                            DeclarationMethod.Default,
                            DeclarationUsage.Position, 0),

    new VertexElement(0, 12, DeclarationType.Float3,
                             DeclarationMethod.Default,
                             DeclarationUsage.Normal, 0),

    new VertexElement(0, 24, DeclarationType.Float2,
                             DeclarationMethod.Default,
                             DeclarationUsage.TextureCoordinate, 0),

    VertexElement.VertexDeclarationEnd
};

// Use the vertex element array to create a vertex declaration.
VertexDeclaration decl = new VertexDeclaration(device, elements);


VertexFormatCaps Structure (Microsoft.DirectX.Direct3D)

VertexFormatCaps Structure

Specifies the flexible vertex format (FVF) capabilities supported by a device.

Definition

Visual Basic | Public Structure VertexFormatCaps
C# | public struct VertexFormatCaps
C++ | public value class VertexFormatCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsDoNotStripElements | Specifies whether a device supports keeping vertex elements or stripping them if they are not needed for rendering.
SupportsPointSize | Specifies whether the vertex point size is determined by RenderStateManager.PointSize or the vertex data.
SupportsTextureCoordinateCountMask | Specifies whether the device supports the texture coordinate count mask.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexFormatCaps.ToString() Method (Microsoft.DirectX.Direct3D)

VertexFormatCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VertexFormatCaps.SupportsDoNotStripElements Property (Microsoft.DirectX.Direct3D)

VertexFormatCaps.SupportsDoNotStripElements Property

Specifies whether a device supports keeping vertex elements or stripping them if they are not needed for rendering.

Definition

Visual Basic | Public ReadOnly Property SupportsDoNotStripElements As Boolean
C# | public bool SupportsDoNotStripElements { get; }
C++ public:
property bool SupportsDoNotStripElements {
bool get();
}
JScript | public function get SupportsDoNotStripElements() : boolean

Property Value

System.Boolean
Value that is true if the device supports keeping vertex elements, or false if it supports stripping vertex elements.

This property is read-only.

Remarks

It is preferable that vertex elements not be stripped. That is, if the vertex format contains elements that are not used with the current render states, there is no need to regenerate the vertices. If this capability flag is not present, stripping extraneous elements from the vertex format results in better performance.


VertexFormatCaps.SupportsPointSize Property (Microsoft.DirectX.Direct3D)

VertexFormatCaps.SupportsPointSize Property

Specifies whether the vertex point size is determined by RenderStateManager.PointSize or the vertex data.

Definition

Visual Basic | Public ReadOnly Property SupportsPointSize As Boolean
C# | public bool SupportsPointSize { get; }
C++ public:
property bool SupportsPointSize {
bool get();
}
JScript | public function get SupportsPointSize() : boolean

Property Value

System.Boolean
Value that is true if the point size is determined by the vertex data, or false if it is determined by RenderStateManager.PointSize.

This property is read-only.

Remarks

If the application provides point size in both the render state and the flexible vertex format (FVF) data, the vertex data overrides the render-state data.


VertexFormatCaps.SupportsTextureCoordinateCountMask Property (Microsoft.DirectX.Direct3D)

VertexFormatCaps.SupportsTextureCoordinateCountMask Property

Specifies whether the device supports the texture coordinate count mask.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureCoordinateCountMask As Boolean
C# | public bool SupportsTextureCoordinateCountMask { get; }
C++ public:
property bool SupportsTextureCoordinateCountMask {
bool get();
}
JScript | public function get SupportsTextureCoordinateCountMask() : boolean

Property Value

System.Boolean
Value that is true if the device supports the texture coordinate count mask, or false if it does not.

This property is read-only.


VertexProcessingCaps Structure (Microsoft.DirectX.Direct3D)

VertexProcessingCaps Structure

Describes vertex processing capabilities.

Definition

Visual Basic | Public Structure VertexProcessingCaps
C# | public struct VertexProcessingCaps
C++ | public value class VertexProcessingCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
SupportsDirectionalLights | Specifies whether directional lights are supported on a device.
SupportsLocalViewer | Specifies whether a device supports the local viewer mode.
SupportsMaterialSource | Specifies whether a device can perform Microsoft DirectX 7.0 colormaterialsource operations.
SupportsNoTextureGenerationNonLocalViewer | Specifies whether a device supports texture generation in non-local viewer mode.
SupportsPositionalLights | Specifies whether positional lights, including point and spot, are supported on a device.
SupportsTextureGeneration | Specifies whether a device supports texture generation.
SupportsTextureGenerationSphereMap | Specifies whether a device supports texture generation for sphere maps.
SupportsTweening | Specifies whether a device supports vertex tweening.

Remarks

For a given physical device, these capabilities might vary across Device objects, depending on the parameters supplied to the Device constructor.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexProcessingCaps.ToString() Method (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VertexProcessingCaps.SupportsDirectionalLights Property (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.SupportsDirectionalLights Property

Specifies whether directional lights are supported on a device.

Definition

Visual Basic | Public ReadOnly Property SupportsDirectionalLights As Boolean
C# | public bool SupportsDirectionalLights { get; }
C++ public:
property bool SupportsDirectionalLights {
bool get();
}
JScript | public function get SupportsDirectionalLights() : boolean

Property Value

System.Boolean
Value that is true if directional lights are supported, or false if they are not.

This property is read-only.


VertexProcessingCaps.SupportsLocalViewer Property (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.SupportsLocalViewer Property

Specifies whether a device supports the local viewer mode.

Definition

Visual Basic | Public ReadOnly Property SupportsLocalViewer As Boolean
C# | public bool SupportsLocalViewer { get; }
C++ public:
property bool SupportsLocalViewer {
bool get();
}
JScript | public function get SupportsLocalViewer() : boolean

Property Value

System.Boolean
Value that is true if local viewer is supported, or false if it is not.

This property is read-only.


VertexProcessingCaps.SupportsMaterialSource Property (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.SupportsMaterialSource Property

Specifies whether a device can perform Microsoft DirectX 7.0 colormaterialsource operations.

Definition

Visual Basic | Public ReadOnly Property SupportsMaterialSource As Boolean
C# | public bool SupportsMaterialSource { get; }
C++ public:
property bool SupportsMaterialSource {
bool get();
}
JScript | public function get SupportsMaterialSource() : boolean

Property Value

System.Boolean
Value that is true if colormaterialsource operations are supported, or false if they are not.

This property is read-only.


VertexProcessingCaps.SupportsNoTextureGenerationNonLocalViewer Property (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.SupportsNoTextureGenerationNonLocalViewer Property

Language:

Specifies whether a device supports texture generation in non-local viewer mode.

Definition

Visual Basic | Public ReadOnly Property SupportsNoTextureGenerationNonLocalViewer As Boolean
C# | public bool SupportsNoTextureGenerationNonLocalViewer { get; }
C++ public:
property bool SupportsNoTextureGenerationNonLocalViewer {
bool get();
}
JScript | public function get SupportsNoTextureGenerationNonLocalViewer() : boolean

Property Value

System.Boolean
Value that is true if the device does not support texture generation in non-local viewer mode, or false if it does.

This property is read-only.


VertexProcessingCaps.SupportsPositionalLights Property (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.SupportsPositionalLights Property

Specifies whether positional lights, including point and spot, are supported on a device.

Definition

Visual Basic | Public ReadOnly Property SupportsPositionalLights As Boolean
C# | public bool SupportsPositionalLights { get; }
C++ public:
property bool SupportsPositionalLights {
bool get();
}
JScript | public function get SupportsPositionalLights() : boolean

Property Value

System.Boolean
Value that is true if positional lights are supported, or false if they are not.

This property is read-only.


VertexProcessingCaps.SupportsTextureGeneration Property (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.SupportsTextureGeneration Property

Specifies whether a device supports texture generation.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureGeneration As Boolean
C# | public bool SupportsTextureGeneration { get; }
C++ public:
property bool SupportsTextureGeneration {
bool get();
}
JScript | public function get SupportsTextureGeneration() : boolean

Property Value

System.Boolean
Value that is true if texture generation is supported, or false if it is not.

This property is read-only.


VertexProcessingCaps.SupportsTextureGenerationSphereMap Property (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.SupportsTextureGenerationSphereMap Property

Language:

Specifies whether a device supports texture generation for sphere maps.

Definition

Visual Basic | Public ReadOnly Property SupportsTextureGenerationSphereMap As Boolean
C# | public bool SupportsTextureGenerationSphereMap { get; }
C++ public:
property bool SupportsTextureGenerationSphereMap {
bool get();
}
JScript | public function get SupportsTextureGenerationSphereMap() : boolean

Property Value

System.Boolean
Value that is true if texture generation for sphere maps is supported, or false if it is not.

This property is read-only.


VertexProcessingCaps.SupportsTweening Property (Microsoft.DirectX.Direct3D)

VertexProcessingCaps.SupportsTweening Property

Specifies whether a device supports vertex tweening.

Definition

Visual Basic | Public ReadOnly Property SupportsTweening As Boolean
C# | public bool SupportsTweening { get; }
C++ public:
property bool SupportsTweening {
bool get();
}
JScript | public function get SupportsTweening() : boolean

Property Value

System.Boolean
Value that is true if vertex tweening is supported, or false if it is not.

This property is read-only.


VertexShaderCaps Structure (Microsoft.DirectX.Direct3D)

VertexShaderCaps Structure

Describes vertex shader capabilities.

Definition

Visual Basic | Public Structure VertexShaderCaps
C# | public struct VertexShaderCaps
C++ | public value class VertexShaderCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) MaxDynamicFlowControlDepth | Specifies the maximum level of nesting of dynamic flow control instructions (break, breakc, ifc).
static (Shared in Visual Basic) MaxNumberTemps | Specifies the maximum number of temporary registers supported.
static (Shared in Visual Basic) MaxStaticFlowControlDepth | Specifies the maximum nesting depth of loop/rep and call/callnz bool instructions.
static (Shared in Visual Basic) MinDynamicFlowControlDepth | Specifies the minimum level of nesting of dynamic flow control instructions (break, breakc, ifc).
static (Shared in Visual Basic) MinNumberTemps | Specifies the minimum number of temporary registers supported.
static (Shared in Visual Basic) MinStaticFlowControlDepth | Specifies the minimum nesting depth of loop/rep and call/callnz bool instructions.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DynamicFlowControlDepth | Retrieves a value that represents the depth of the dynamic flow control instruction nesting.
NumberTemps | Retrieves the number of temporary registers supported by the device.
StaticFlowControlDepth | Retrieves the depth of nesting of the loop/rep and call/callnz bool instructions.
SupportsPredication | Determines whether instruction predication as defined in the predication section is supported.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexShaderCaps.ToString() Method (Microsoft.DirectX.Direct3D)

VertexShaderCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VertexShaderCaps.DynamicFlowControlDepth Property (Microsoft.DirectX.Direct3D)

VertexShaderCaps.DynamicFlowControlDepth Property

Retrieves a value that represents the depth of the dynamic flow control instruction nesting.

Definition

Visual Basic | Public ReadOnly Property DynamicFlowControlDepth As Integer
C# | public int DynamicFlowControlDepth { get; }
C++ public:
property int DynamicFlowControlDepth {
int get();
}
JScript | public function get DynamicFlowControlDepth() : int

Property Value

System.Int32
Integer that represents the level of instruction nesting allowed. The acceptable range of values is 0 to 24.

This property is read-only.

Remarks

If this value is zero, the device does not support dynamic flow control. If it is non-zero, the device supports dynamic flow control (instructions if, break, and breakc).


VertexShaderCaps.NumberTemps Property (Microsoft.DirectX.Direct3D)

VertexShaderCaps.NumberTemps Property

Retrieves the number of temporary registers supported by the device.

Definition

Visual Basic | Public ReadOnly Property NumberTemps As Integer
C# | public int NumberTemps { get; }
C++ public:
property int NumberTemps {
int get();
}
JScript | public function get NumberTemps() : int

Property Value

System.Int32
Integer that represents the number of temporary registers supported. The acceptable range of values is 12 to 32.

This property is read-only.


VertexShaderCaps.StaticFlowControlDepth Property (Microsoft.DirectX.Direct3D)

VertexShaderCaps.StaticFlowControlDepth Property

Retrieves the depth of nesting of the loop/rep and call/callnz bool instructions.

Definition

Visual Basic | Public ReadOnly Property StaticFlowControlDepth As Integer
C# | public int StaticFlowControlDepth { get; }
C++ public:
property int StaticFlowControlDepth {
int get();
}
JScript | public function get StaticFlowControlDepth() : int

Property Value

System.Int32
Integer that represents instruction nesting depth. The acceptable range of values is 0 to 4.

This property is read-only.

Remarks

If this value is zero, the device does not support static flow control.


VertexShaderCaps.SupportsPredication Property (Microsoft.DirectX.Direct3D)

VertexShaderCaps.SupportsPredication Property

Determines whether instruction predication as defined in the predication section is supported.

Definition

Visual Basic | Public ReadOnly Property SupportsPredication As Boolean
C# | public bool SupportsPredication { get; }
C++ public:
property bool SupportsPredication {
bool get();
}
JScript | public function get SupportsPredication() : boolean

Property Value

System.Boolean
Value that is true if instruction predication is supported, or false if it is not.

This property is read-only.


VertexShaderCaps.MaxDynamicFlowControlDepth Field (Microsoft.DirectX.Direct3D)

VertexShaderCaps.MaxDynamicFlowControlDepth Field

Specifies the maximum level of nesting of dynamic flow control instructions (break, breakc, ifc).

Definition

Visual Basic | Public Shared MaxDynamicFlowControlDepth As Int32
C# | public static Int32 MaxDynamicFlowControlDepth;
C++ | public: static Int32 MaxDynamicFlowControlDepth;
JScript | public static var MaxDynamicFlowControlDepth : Int32

Field Value

System.Int32
Value of 24.

This field is read-only.


VertexShaderCaps.MaxNumberTemps Field (Microsoft.DirectX.Direct3D)

VertexShaderCaps.MaxNumberTemps Field

Specifies the maximum number of temporary registers supported.

Definition

Visual Basic | Public Shared MaxNumberTemps As Int32
C# | public static Int32 MaxNumberTemps;
C++ | public: static Int32 MaxNumberTemps;
JScript | public static var MaxNumberTemps : Int32

Field Value

System.Int32
Value of 32.

This field is read-only.


VertexShaderCaps.MaxStaticFlowControlDepth Field (Microsoft.DirectX.Direct3D)

VertexShaderCaps.MaxStaticFlowControlDepth Field

Specifies the maximum nesting depth of loop/rep and call/callnz bool instructions.

Definition

Visual Basic | Public Shared MaxStaticFlowControlDepth As Int32
C# | public static Int32 MaxStaticFlowControlDepth;
C++ | public: static Int32 MaxStaticFlowControlDepth;
JScript | public static var MaxStaticFlowControlDepth : Int32

Field Value

System.Int32
Value of 4.

This field is read-only.


VertexShaderCaps.MinDynamicFlowControlDepth Field (Microsoft.DirectX.Direct3D)

VertexShaderCaps.MinDynamicFlowControlDepth Field

Specifies the minimum level of nesting of dynamic flow control instructions (break, breakc, ifc).

Definition

Visual Basic | Public Shared MinDynamicFlowControlDepth As Int32
C# | public static Int32 MinDynamicFlowControlDepth;
C++ | public: static Int32 MinDynamicFlowControlDepth;
JScript | public static var MinDynamicFlowControlDepth : Int32

Field Value

System.Int32
Value of 0.

This field is read-only.


VertexShaderCaps.MinNumberTemps Field (Microsoft.DirectX.Direct3D)

VertexShaderCaps.MinNumberTemps Field

Specifies the minimum number of temporary registers supported.

Definition

Visual Basic | Public Shared MinNumberTemps As Int32
C# | public static Int32 MinNumberTemps;
C++ | public: static Int32 MinNumberTemps;
JScript | public static var MinNumberTemps : Int32

Field Value

System.Int32
Value of 12.

This field is read-only.


VertexShaderCaps.MinStaticFlowControlDepth Field (Microsoft.DirectX.Direct3D)

VertexShaderCaps.MinStaticFlowControlDepth Field

Specifies the minimum nesting depth of loop/rep and call/callnz bool instructions.

Definition

Visual Basic | Public Shared MinStaticFlowControlDepth As Int32
C# | public static Int32 MinStaticFlowControlDepth;
C++ | public: static Int32 MinStaticFlowControlDepth;
JScript | public static var MinStaticFlowControlDepth : Int32

Field Value

System.Int32
Value of 1.

This field is read-only.


VertexStats Structure (Microsoft.DirectX.Direct3D)

VertexStats Structure

Reports the number of triangles that have been processed and clipped by the runtime's software vertex processing.

Definition

Visual Basic | Public Structure VertexStats
C# | public struct VertexStats
C++ | public value class VertexStats sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VertexStats | Initializes a new instance of the VertexStats class.

Properties

Property | Description
NumberExtraClippingTriangles | Retrieves the number of new triangles generated by clipping.
NumberRenderedTriangles | Retrieves the total number of triangles that are not clipped in the current frame.

Remarks

Use the debug runtime and software vertex processing to get the number of non-clipped and clipped primitives for a particular scene. Primitives typically are clipped based on a guard band, if one is present. The clipping guard band is set with parameters such as Caps.GuardBandLeft.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VertexStats.ToString() Method (Microsoft.DirectX.Direct3D)

VertexStats.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VertexStats.VertexStats() Constructor (Microsoft.DirectX.Direct3D)

VertexStats.VertexStats Constructor

Initializes a new instance of the VertexStats class.

Definition

Visual Basic | Public Sub New()
C# | public VertexStats();
C++ public:
VertexStats();
JScript | public function VertexStats();


VertexStats.NumberExtraClippingTriangles Property (Microsoft.DirectX.Direct3D)

VertexStats.NumberExtraClippingTriangles Property

Retrieves the number of new triangles generated by clipping.

Definition

Visual Basic | Public ReadOnly Property NumberExtraClippingTriangles As Integer
C# | public int NumberExtraClippingTriangles { get; }
C++ public:
property int NumberExtraClippingTriangles {
int get();
}
JScript | public function get NumberExtraClippingTriangles() : int

Property Value

System.Int32
Integer that represents the number of new triangles generated by clipping.

This property is read-only.


VertexStats.NumberRenderedTriangles Property (Microsoft.DirectX.Direct3D)

VertexStats.NumberRenderedTriangles Property

Retrieves the total number of triangles that are not clipped in the current frame.

Definition

Visual Basic | Public ReadOnly Property NumberRenderedTriangles As Integer
C# | public int NumberRenderedTriangles { get; }
C++ public:
property int NumberRenderedTriangles {
int get();
}
JScript | public function get NumberRenderedTriangles() : int

Property Value

System.Int32
Integer that represents the number of triangles rendered.

This property is read-only.


Viewport Structure (Microsoft.DirectX.Direct3D)

Viewport Structure

Defines the window dimensions of a render target surface onto which a 3-D volume projects.

Definition

Visual Basic | Public Structure Viewport
C# | public struct Viewport
C++ | public value class Viewport sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
Viewport | Initializes a new instance of the Viewport class.

Properties

Property | Description
Height | Retrieves or sets the height dimension of the viewport on the render target surface, in pixels.
MaxZ | Retrieves or sets the maximum value of the clip volume.
MinZ | Retrieves or sets the minimum value of the clip volume.
Width | Retrieves or sets the width dimension of the viewport on the render target surface, in pixels.
X | Retrieves or sets the pixel coordinate of the upper-left corner of the viewport on the render target surface.
Y | Retrieves or sets the pixel coordinate of the upper-left corner of the viewport on the render target surface.

Remarks

The X, Y, Width, and Height members describe the position and dimensions of the viewport on the render-target surface. Usually, applications render to the entire target surface; when rendering on a 640x480 surface, these members should be 0, 0, 640, and 480, respectively. The MinZ and MaxZ properties typically are set to 0.0 and 1.0, but can be set to other values to achieve specific effects. For example, setting them both to 0.0 can force the system to render objects to the foreground of a scene, while setting both to 1.0 can force the objects into the background.

When the viewport parameters for a device change (due to the use of the Device.Viewport property), the driver builds a new transformation matrix.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Viewport.ToString() Method (Microsoft.DirectX.Direct3D)

Viewport.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Viewport.Viewport() Constructor (Microsoft.DirectX.Direct3D)

Viewport.Viewport Constructor

Initializes a new instance of the Viewport class.

Definition

Visual Basic | Public Sub New()
C# | public Viewport();
C++ public:
Viewport();
JScript | public function Viewport();


Viewport.Height Property (Microsoft.DirectX.Direct3D)

Viewport.Height Property

Retrieves or sets the height dimension of the viewport on the render target surface, in pixels.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer that represents the height of the viewport to set or retrieve.

This property is read/write.

Remarks

Unless rendering is being done only to a subset of the surface, this member should be set to the height dimension of the render target surface.


Viewport.MaxZ Property (Microsoft.DirectX.Direct3D)

Viewport.MaxZ Property

Retrieves or sets the maximum value of the clip volume.

Definition

Visual Basic | Public Property MaxZ As Single
C# | public float MaxZ { get; set; }
C++ public:
property float MaxZ {
float get();
void set(float value);
}
JScript public function get MaxZ() : float
public function set MaxZ(float);

Property Value

System.Single
Integer that represents the maximum z-value of the clipping volume.

This property is read/write.

Remarks

MaxZ, together with MinZ, specifies the range of depth values into which a scene is rendered. Most applications set this value to 1.0. Clipping is performed after the projection matrix is applied.


Viewport.MinZ Property (Microsoft.DirectX.Direct3D)

Viewport.MinZ Property

Retrieves or sets the minimum value of the clip volume.

Definition

Visual Basic | Public Property MinZ As Single
C# | public float MinZ { get; set; }
C++ public:
property float MinZ {
float get();
void set(float value);
}
JScript public function get MinZ() : float
public function set MinZ(float);

Property Value

System.Single
Integer that represents the minimum z-value of the clipping volume.

This property is read/write.

Remarks

MinZ, together with MaxZ, specifies the range of depth values into which a scene is rendered. Most applications set this value to 0.0. Clipping is performed after the projection matrix is applied.


Viewport.Width Property (Microsoft.DirectX.Direct3D)

Viewport.Width Property

Retrieves or sets the width dimension of the viewport on the render target surface, in pixels.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer that represents the width of the viewport to set or retrieve.

This property is read/write.

Remarks

Unless rendering is being done only to a subset of the surface, this member should be set to the width dimension of the render target surface.


Viewport.X Property (Microsoft.DirectX.Direct3D)

Viewport.X Property

Retrieves or sets the pixel coordinate of the upper-left corner of the viewport on the render target surface.

Definition

Visual Basic | Public Property X As Integer
C# | public int X { get; set; }
C++ public:
property int X {
int get();
void set(int value);
}
JScript public function get X() : int
public function set X(int);

Property Value

System.Int32
Integer that represents the upper-left corner of the viewport to set or retrieve.

This property is read/write.

Remarks

Unless rendering is being done only to a subset of the surface, this member can be set to 0.


Viewport.Y Property (Microsoft.DirectX.Direct3D)

Viewport.Y Property

Retrieves or sets the pixel coordinate of the upper-left corner of the viewport on the render target surface.

Definition

Visual Basic | Public Property Y As Integer
C# | public int Y { get; set; }
C++ public:
property int Y {
int get();
void set(int value);
}
JScript public function get Y() : int
public function set Y(int);

Property Value

System.Int32
Integer that represents the upper-left corner of the viewport to set or retrieve.

This property is read/write.

Remarks

Unless rendering is being done only to a subset of the surface, this member can be set to 0.


VolumeDescription Structure (Microsoft.DirectX.Direct3D)

VolumeDescription Structure

Describes a volume.

Definition

Visual Basic | Public Structure VolumeDescription
C# | public struct VolumeDescription
C++ | public value class VolumeDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VolumeDescription | Initializes a new instance of the VolumeDescription class.

Properties

Property | Description
Depth | Retrieves or sets the depth of the volume, in pixels.
Format | Retrieves or sets the desired surface format of a volume.
Height | Retrieves or sets the height of the volume in pixels.
Pool | Retrieves or sets a Pool value that specifies the class of memory allocated for the current volume.
Type | Retrieves or sets a ResourceType value that identifies the current resource as a volume.
Usage | Not used at this time. This member's value should always be 0.
Width | Retrieves or sets the width of a volume in pixels.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VolumeDescription.ToString() Method (Microsoft.DirectX.Direct3D)

VolumeDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VolumeDescription.VolumeDescription() Constructor (Microsoft.DirectX.Direct3D)

VolumeDescription.VolumeDescription Constructor

Initializes a new instance of the VolumeDescription class.

Definition

Visual Basic | Public Sub New()
C# | public VolumeDescription();
C++ public:
VolumeDescription();
JScript | public function VolumeDescription();


VolumeDescription.Depth Property (Microsoft.DirectX.Direct3D)

VolumeDescription.Depth Property

Retrieves or sets the depth of the volume, in pixels.

Definition

Visual Basic | Public Property Depth As Integer
C# | public int Depth { get; set; }
C++ public:
property int Depth {
int get();
void set(int value);
}
JScript public function get Depth() : int
public function set Depth(int);

Property Value

System.Int32
Integer that represents the depth of the volume to set or retrieve.

This property is read/write.


VolumeDescription.Format Property (Microsoft.DirectX.Direct3D)

VolumeDescription.Format Property

Retrieves or sets the desired surface format of a volume.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
A Format object that specifies the surface format to set or retrieve.

This property is read/write.


VolumeDescription.Height Property (Microsoft.DirectX.Direct3D)

VolumeDescription.Height Property

Retrieves or sets the height of the volume in pixels.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer that represents the height of the volume to set or retrieve.

This property is read/write.


VolumeDescription.Pool Property (Microsoft.DirectX.Direct3D)

VolumeDescription.Pool Property

Retrieves or sets a Pool value that specifies the class of memory allocated for the current volume.

Definition

Visual Basic | Public Property Pool As Pool
C# | public Pool Pool { get; set; }
C++ public:
property Pool Pool {
Pool get();
void set(Pool value);
}
JScript public function get Pool() : Pool
public function set Pool(Pool);

Property Value

Microsoft.DirectX.Direct3D.Pool
Value of the Pool enumeration to set or retrieve.

This property is read/write.


VolumeDescription.Type Property (Microsoft.DirectX.Direct3D)

VolumeDescription.Type Property

Retrieves or sets a ResourceType value that identifies the current resource as a volume.

Definition

Visual Basic | Public Property Type As ResourceType
C# | public ResourceType Type { get; set; }
C++ public:
property ResourceType Type {
ResourceType get();
void set(ResourceType value);
}
JScript public function get Type() : ResourceType
public function set Type(ResourceType);

Property Value

Microsoft.DirectX.Direct3D.ResourceType
Value of the ResourceType enumeration to set or retrieve.

This property is read/write.


VolumeDescription.Usage Property (Microsoft.DirectX.Direct3D)

VolumeDescription.Usage Property

Not used at this time. This member's value should always be 0.

Definition

Visual Basic | Public Property Usage As Usage
C# | public Usage Usage { get; set; }
C++ public:
property Usage Usage {
Usage get();
void set(Usage value);
}
JScript public function get Usage() : Usage
public function set Usage(Usage);

Property Value

Microsoft.DirectX.Direct3D.Usage

This property is read/write.


VolumeDescription.Width Property (Microsoft.DirectX.Direct3D)

VolumeDescription.Width Property

Retrieves or sets the width of a volume in pixels.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer that represents the width of the volume to set or retrieve.

This property is read/write.


VolumeTextureRequirements Structure (Microsoft.DirectX.Direct3D)

VolumeTextureRequirements Structure

Contains volume texture creation parameters.

Definition

Visual Basic | Public Structure VolumeTextureRequirements
C# | public struct VolumeTextureRequirements
C++ | public value class VolumeTextureRequirements sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
VolumeTextureRequirements | Initializes a new instance of the VolumeTextureRequirements class.

Properties

Property | Description
Depth | Retrieves or sets the volume texture depth, in pixels.
Format | Retrieves or sets the desired pixel format.
Height | Retrieves or sets the volume texture height, in pixels.
NumberMipLevels | Retrieves or sets the number of mipmap levels of a volume texture.
Width | Retrieves or sets the volume texture width, in pixels.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VolumeTextureRequirements.ToString() Method (Microsoft.DirectX.Direct3D)

VolumeTextureRequirements.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


VolumeTextureRequirements.VolumeTextureRequirements() Constructor (Microsoft.DirectX.Direct3D)

VolumeTextureRequirements.VolumeTextureRequirements Constructor

 Language:

Initializes a new instance of the VolumeTextureRequirements class.

Definition

Visual Basic | Public Sub New()
C# | public VolumeTextureRequirements();
C++ public:
VolumeTextureRequirements();
JScript | public function VolumeTextureRequirements();


VolumeTextureRequirements.Depth Property (Microsoft.DirectX.Direct3D)

VolumeTextureRequirements.Depth Property

Retrieves or sets the volume texture depth, in pixels.

Definition

Visual Basic | Public Property Depth As Integer
C# | public int Depth { get; set; }
C++ public:
property int Depth {
int get();
void set(int value);
}
JScript public function get Depth() : int
public function set Depth(int);

Property Value

System.Int32
Integer that represents the depth to set or retrieve.

This property is read/write.


VolumeTextureRequirements.Format Property (Microsoft.DirectX.Direct3D)

VolumeTextureRequirements.Format Property

Retrieves or sets the desired pixel format.

Definition

Visual Basic | Public Property Format As Format
C# | public Format Format { get; set; }
C++ public:
property Format Format {
Format get();
void set(Format value);
}
JScript public function get Format() : Format
public function set Format(Format);

Property Value

Microsoft.DirectX.Direct3D.Format
A Format object that specifies the pixel format to set or retrieve.

This property is read/write.


VolumeTextureRequirements.Height Property (Microsoft.DirectX.Direct3D)

VolumeTextureRequirements.Height Property

Retrieves or sets the volume texture height, in pixels.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32
Integer that represents the height to set or retrieve.

This property is read/write.


VolumeTextureRequirements.NumberMipLevels Property (Microsoft.DirectX.Direct3D)

VolumeTextureRequirements.NumberMipLevels Property

Retrieves or sets the number of mipmap levels of a volume texture.

Definition

Visual Basic | Public Property NumberMipLevels As Integer
C# | public int NumberMipLevels { get; set; }
C++ public:
property int NumberMipLevels {
int get();
void set(int value);
}
JScript public function get NumberMipLevels() : int
public function set NumberMipLevels(int);

Property Value

System.Int32
Integer that represents the number of mipmap levels to set or retrieve.

This property is read/write.


VolumeTextureRequirements.Width Property (Microsoft.DirectX.Direct3D)

VolumeTextureRequirements.Width Property

Retrieves or sets the volume texture width, in pixels.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32
Integer that represents the width to set or retrieve.

This property is read/write.


WeldEpsilons Structure (Microsoft.DirectX.Direct3D)

WeldEpsilons Structure

Specifies a per-vertex value that is used to weld similar vertices together.

Definition

Visual Basic | Public Structure WeldEpsilons
C# | public struct WeldEpsilons
C++ | public value class WeldEpsilons sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
WeldEpsilons | Initializes a new instance of the WeldEpsilons class.

Properties

Property | Description
Binormal | Retrieves or sets the allowable tolerance value of a binormal, or the cross product of the tangent and normal vectors, to compare between vertices.
BlendWeights | Retrieves or sets the allowable tolerance value of the blend weights to compare between vertices.
Diffuse | Retrieves or sets the allowable tolerance value of the diffuse lighting to compare between vertices.
Normal | Retrieves or sets the allowable tolerance value of a normal to compare between vertices.
PointSize | Retrieves or sets the allowable tolerance value of a point size to compare between vertices.
Position | Retrieves or sets the allowable tolerance value of a position to compare between vertices.
Specular | Retrieves or sets the allowable tolerance value of specular lighting to compare between vertices.
Tangent | Retrieves or sets the allowable tolerance value of a tangent to compare between vertices.
TessellateFactor | Retrieves or sets the allowable tolerance value of a tessellation factor to compare between vertices.
TextureCoordinate | Retrieves or sets the allowable tolerance value of texture coordinates to compare between vertices.

Structure Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WeldEpsilons.ToString() Method (Microsoft.DirectX.Direct3D)

WeldEpsilons.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


WeldEpsilons.WeldEpsilons() Constructor (Microsoft.DirectX.Direct3D)

WeldEpsilons.WeldEpsilons Constructor

Initializes a new instance of the WeldEpsilons class.

Definition

Visual Basic | Public Sub New()
C# | public WeldEpsilons();
C++ public:
WeldEpsilons();
JScript | public function WeldEpsilons();


WeldEpsilons.Binormal Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.Binormal Property

Retrieves or sets the allowable tolerance value of a binormal, or the cross product of the tangent and normal vectors, to compare between vertices.

Definition

Visual Basic | Public Property Binormal As Single
C# | public float Binormal { get; set; }
C++ public:
property float Binormal {
float get();
void set(float value);
}
JScript public function get Binormal() : float
public function set Binormal(float);

Property Value

System.Single
Floating-point value that represents the binormal epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.BlendWeights Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.BlendWeights Property

Retrieves or sets the allowable tolerance value of the blend weights to compare between vertices.

Definition

Visual Basic | Public Property BlendWeights As Single
C# | public float BlendWeights { get; set; }
C++ public:
property float BlendWeights {
float get();
void set(float value);
}
JScript public function get BlendWeights() : float
public function set BlendWeights(float);

Property Value

System.Single
Floating-point value that represents the blend weight epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Diffuse Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.Diffuse Property

Retrieves or sets the allowable tolerance value of the diffuse lighting to compare between vertices.

Definition

Visual Basic | Public Property Diffuse As Single
C# | public float Diffuse { get; set; }
C++ public:
property float Diffuse {
float get();
void set(float value);
}
JScript public function get Diffuse() : float
public function set Diffuse(float);

Property Value

System.Single
Floating-point value that represents the diffuse lighting epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Normal Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.Normal Property

Retrieves or sets the allowable tolerance value of a normal to compare between vertices.

Definition

Visual Basic | Public Property Normal As Single
C# | public float Normal { get; set; }
C++ public:
property float Normal {
float get();
void set(float value);
}
JScript public function get Normal() : float
public function set Normal(float);

Property Value

System.Single
Floating-point value that represents the normal epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.PointSize Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.PointSize Property

Retrieves or sets the allowable tolerance value of a point size to compare between vertices.

Definition

Visual Basic | Public Property PointSize As Single
C# | public float PointSize { get; set; }
C++ public:
property float PointSize {
float get();
void set(float value);
}
JScript public function get PointSize() : float
public function set PointSize(float);

Property Value

System.Single
Floating-point value that represents the point size epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Position Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.Position Property

Retrieves or sets the allowable tolerance value of a position to compare between vertices.

Definition

Visual Basic | Public Property Position As Single
C# | public float Position { get; set; }
C++ public:
property float Position {
float get();
void set(float value);
}
JScript public function get Position() : float
public function set Position(float);

Property Value

System.Single
Floating-point value that represents the position epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Specular Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.Specular Property

Retrieves or sets the allowable tolerance value of specular lighting to compare between vertices.

Definition

Visual Basic | Public Property Specular As Single
C# | public float Specular { get; set; }
C++ public:
property float Specular {
float get();
void set(float value);
}
JScript public function get Specular() : float
public function set Specular(float);

Property Value

System.Single
Floating-point value that represents the specular lighting epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.Tangent Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.Tangent Property

Retrieves or sets the allowable tolerance value of a tangent to compare between vertices.

Definition

Visual Basic | Public Property Tangent As Single
C# | public float Tangent { get; set; }
C++ public:
property float Tangent {
float get();
void set(float value);
}
JScript public function get Tangent() : float
public function set Tangent(float);

Property Value

System.Single
Floating-point value that represents the tangent epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.TessellateFactor Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.TessellateFactor Property

Retrieves or sets the allowable tolerance value of a tessellation factor to compare between vertices.

Definition

Visual Basic | Public Property TessellateFactor As Single
C# | public float TessellateFactor { get; set; }
C++ public:
property float TessellateFactor {
float get();
void set(float value);
}
JScript public function get TessellateFactor() : float
public function set TessellateFactor(float);

Property Value

System.Single
Floating-point value that represents the tessellation factor epsilon to set or retrieve.

This property is read/write.


WeldEpsilons.TextureCoordinate Property (Microsoft.DirectX.Direct3D)

WeldEpsilons.TextureCoordinate Property

Retrieves or sets the allowable tolerance value of texture coordinates to compare between vertices.

Definition

Visual Basic | Public Property TextureCoordinate As Single()
C# | public float[] TextureCoordinate { get; set; }
C++ public:
property array<float>^ TextureCoordinate {
array<float>^ get();
void set(array<float>^ value);
}
JScript public function get TextureCoordinate() : float[]
public function set TextureCoordinate(float[]);

Property Value

System.Single[]
Array of eight floating-point values that represent the texture coordinate epsilons to set or retrieve.

This property is read/write.


Fill2DTextureCallback(Vector2,Vector2) Delegate (Microsoft.DirectX.Direct3D)

Fill2DTextureCallback Delegate

Represents the method that handles the FillTexture(Texture,Fill2DTextureCallback) call.

Definition

Visual Basic Public Delegate Sub Fill2DTextureCallback( _
ByVal texCoord As Vector2, _
ByVal texelSize As Vector2 _
)
C# public delegate void Fill2DTextureCallback(
Vector2 texCoord,
Vector2 texelSize
);
C++ public delegate void Fill2DTextureCallback(
Vector2 texCoord,
Vector2 texelSize
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

texCoord Microsoft.DirectX.Vector2
A Vector2 object that contains the coordinates of the texel currently being evaluated. See Remarks.
texelSize Microsoft.DirectX.Vector2
A Vector2 object that contains the dimensions of the current texel.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Remarks

Texture coordinate components range from 0 to 1 for textures and volume textures, and from -1 to 1 for cube textures.

See Also

  • Fill3DTextureCallback


Fill3DTextureCallback(Vector3,Vector3) Delegate (Microsoft.DirectX.Direct3D)

Fill3DTextureCallback Delegate

Represents the method that handles the FillTexture(VolumeTexture,Fill3DTextureCallback) or FillTexture(CubeTexture,Fill3DTextureCallback) call.

Definition

Visual Basic Public Delegate Sub Fill3DTextureCallback( _
ByVal texCoord As Vector3, _
ByVal texelSize As Vector3 _
)
C# public delegate void Fill3DTextureCallback(
Vector3 texCoord,
Vector3 texelSize
);
C++ public delegate void Fill3DTextureCallback(
Vector3 texCoord,
Vector3 texelSize
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

texCoord Microsoft.DirectX.Vector3
A Vector3 object that contains the coordinates of the texel currently being evaluated. See Remarks.
texelSize Microsoft.DirectX.Vector3
A Vector3 object that contains the dimensions of the current texel.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Remarks

Texture coordinate components range from 0 to 1 for textures and volume textures, and from -1 to 1 for cube textures.

See Also

  • Fill2DTextureCallback


HandleAnimationCallback(Int32,IntPtr) Delegate (Microsoft.DirectX.Direct3D)

HandleAnimationCallback Delegate

This delegate is used to handle callbacks triggered by KeyCallbacks in an animation track.

Definition

Visual Basic Public Delegate Sub HandleAnimationCallback( _
ByVal track As Integer, _
ByVal callbackData As IntPtr _
)
C# public delegate void HandleAnimationCallback(
int track,
IntPtr callbackData
);
C++ public delegate void HandleAnimationCallback(
int track,
IntPtr callbackData
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

track System.Int32
Identifier of the track on which the callback occurs.
callbackData System.IntPtr
Callback data specified in the KeyCallback.CallBackData field.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ImtSignalCallback(Vector2,Int32) Delegate (Microsoft.DirectX.Direct3D)

ImtSignalCallback Delegate

Callback method for IntegratedMetricTensor.ComputeFromSignal.

Definition

Visual Basic Public Delegate Sub ImtSignalCallback( _
ByVal uv As Vector2, _
ByVal signalDimension As Integer _
) As Single()
C# public delegate float[] ImtSignalCallback(
Vector2 uv,
int signalDimension
);
C++ public delegate array<float>^ ImtSignalCallback(
Vector2 uv,
int signalDimension
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

uv Microsoft.DirectX.Vector2
The texture coordinate for the vertex.
signalDimension System.Int32
The number of single-precision floating point to store in the return value.

Return Value

System.Single[]
An array of single-precision floating point values that describes the signal data for the vertex.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


PercentageCompleteCallback(Single) Delegate (Microsoft.DirectX.Direct3D)

PercentageCompleteCallback Delegate

Callback for methods associated with UVAtlas and precomputed radiance transfer (PRT) operations.

Definition

Visual Basic Public Delegate Sub PercentageCompleteCallback( _
ByVal percentComplete As Single _
) As Boolean
C# public delegate bool PercentageCompleteCallback(
float percentComplete
);
C++ public delegate bool PercentageCompleteCallback(
float percentComplete
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

percentComplete System.Single
Single-precision floating-point number between 0 and 1.0 that represents the percentage of calculations completed (between 0 and 100 percent).

Return Value

System.Boolean
Boolean Leave Site that continues the simulation if true, halts the simulation if false.

Delegate Information

Namespace | Microsoft.DirectX.Direct3D
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Microsoft.DirectX.DirectDraw

Warning: Microsoft DirectDraw has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw enables you to directly manipulate display memory, the hardware blitter, hardware overlay support, and flipping surface support. The following tables list the members exposed by the Microsoft.DirectX.DirectDraw namespace.

Classes

CannotCloneException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Primary surfaces, or surfaces that are implicitly created, cannot be duplicated. Deprecated.
CannotCreateDeviceContextException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Windows cannot create any more device contexts (DCs), or a DC has requested a palette-indexed surface when the surface had no palette and the display mode was not palette-indexed (in this case DirectDraw cannot select a proper palette into the DC). Deprecated.
CannotLockSurfaceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to this surface is refused because an attempt was made to lock the primary surface without DCI support. Deprecated.
CannotPageLockException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to page-lock a surface failed. Page lock does not work on a display-memory surface or an emulated primary surface. Deprecated.
CannotPageUnlockException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to page-unlock a surface failed. Page unlock does not work on a display-memory surface or an emulated primary surface. Deprecated.
CapsComplexRequiredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface requires the Complex flag. Deprecated.
Clipper
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Clipper object to manage clip lists. Deprecated.
ClipperIsUsingWindowException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to set a clip list for a DirectDrawClipper object that is already monitoring a window handle. Deprecated.
ColorControl
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ColorControl object allows you to get and set color controls. Deprecated.
ColorKeyNotSetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No source color key is specified for this operation. Deprecated.
CurrentlyNotAvailableException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No support is currently available. Deprecated.
DDrawHelper
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Utility class Deprecated.
Device
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Device object to create DirectDraw objects and work with system-level variables. Deprecated.
DeviceDoesNotOwnSurfaceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Surfaces created by one DirectDraw device cannot be used directly by another DirectDraw device. Deprecated.
DevicesCollection
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Collection of devices. Deprecated.
DisplayModesCollection
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Collection of display modes. Deprecated.
DrawFastCannotClipException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A DirectDrawClipper object is attached to a source surface that has passed into a call to the DrawFast method. Deprecated.
ExclusiveModeAlreadySetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to set the cooperative level when it was already set to exclusive. Deprecated.
ExpiredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data has expired and is therefore no longer valid. Deprecated.
GammaControl
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the GammaControl object to adjust the red, green, and blue gamma ramp levels of the primary surface. Deprecated.
GraphicsAlreadyCreatedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A device context (DC) has already been returned for this surface. Only one DC can be retrieved for each surface. Deprecated.
GraphicsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception class for all DirectDraw exceptions. Derives from DirectXException. Deprecated.
HeightAlignException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The height of the provided rectangle is not a multiple of the required alignment. Deprecated.
ImplicitlyCreatedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface cannot be restored because it is an implicitly created surface. Deprecated.
IncompatiblePrimaryException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The primary surface creation request does not match the existing primary surface. Deprecated.
InvalidCapsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One or more of the capability bits passed to the callback function are incorrect. Deprecated.
InvalidClipListException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not support the provided clip list. Deprecated.
InvalidDirectDrawGuidException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The globally unique identifier (Guid) passed to the constructor is not a valid DirectDraw driver identifier. Deprecated.
InvalidModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not support the requested mode. Deprecated.
InvalidObjectException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw received a reference that was an invalid DirectDraw object. Deprecated.
InvalidPixelFormatException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format was invalid as specified. Deprecated.
InvalidPositionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The position of the overlay on the destination is no longer legal. Deprecated.
InvalidRectangleException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The provided rectangle was invalid. Deprecated.
InvalidStreamException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified stream contains invalid data. Deprecated.
InvalidSurfaceTypeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface was of the wrong type. Deprecated.
LockedSurfacesException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One or more surfaces are locked, causing the failure of the requested operation. Deprecated.
MoreDataException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is more data available than the specified buffer size can hold. Deprecated.
NewModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When StartModeTest is called with the IsTestRequired flag, it may throw this exception to denote that some or all of the resolutions can and should be tested. EvaluateMode throws this exception to indicate that the test has switched to a new display mode. Deprecated.
NoAlphaHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No alpha-acceleration hardware is present or available, causing the failure of the requested operation. Deprecated.
NoClipListException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No clip list is available. Deprecated.
NoClipperAttachedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No DirectDrawClipper object is attached to the surface object. Deprecated.
NoColorConversionHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No color-conversion hardware is present or available. Deprecated.
NoColorKeyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface does not currently have a color key. Deprecated.
NoColorKeyHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for the destination color key. Deprecated.
NoCooperativeLevelSetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A create function was called without the SetCooperativeLevel method. Deprecated.
NoDeviceContextException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No device context (DC) has ever been created for this surface. Deprecated.
NoDirectDrawHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware-only DirectDraw object creation is not possible; the driver does not support any hardware. Deprecated.
NoDirectDrawSupportException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw support is not possible with the current display driver. Deprecated.
NoDrawHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No blitter hardware is present. Deprecated.
NoDriverSupportException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Testing cannot proceed because the display adapter driver does not enumerate refresh rates. Deprecated.
NoEmulationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Software emulation is not available. Deprecated.
NoExclusiveModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation requires the application to have exclusive mode, but the application does not have exclusive mode. Deprecated.
NoFlipHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flipping visible surfaces is not supported. Deprecated.
NoFocusWindowException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to create or set a device window without first setting the focus window. Deprecated.
NoGdiException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No GDI is present. Deprecated.
NoMirrorHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No mirroring hardware is present or available. Deprecated.
NoMonitorInformationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Testing cannot proceed because the monitor has no associated EDID data. Deprecated.
NoNonLocalVideoMemoryException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to allocate nonlocal video memory from a device that does not support nonlocal video memory. Deprecated.
NoOptimizeHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The device does not support optimized surfaces. Deprecated.
NoOverlayDestinationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The GetOverlayPosition method is called on an overlay that the UpdateOverlay method has not been called on to establish as a destination. Deprecated.
NoOverlayHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No overlay hardware is present or available. Deprecated.
NoPaletteAttachedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No palette object is attached to this surface. Deprecated.
NoPaletteHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for 16- or 256-color palettes. Deprecated.
NoRasterOperationHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No appropriate raster-operation hardware is present or available. Deprecated.
NoRotationHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No rotation hardware is present or available. Deprecated.
NoStereoHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no stereo hardware present or available. Deprecated.
NoStretchHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for stretching. Deprecated.
NoSurfaceLeftException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware present that supports stereo surfaces. Deprecated.
Not4BitColorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using a 4-bit color palette, and the requested operation requires a 4-bit color palette. Deprecated.
Not4BitColorIndexException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using a 4-bit color index palette, and the requested operation requires a 4-bit color index palette. Deprecated.
Not8BitColorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using an 8-bit color palette, and the requested operation requires an 8-bit color palette. Deprecated.
NotAnOverlaySurfaceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An overlay component is called for a nonoverlay surface. Deprecated.
NotFlippableException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to flip a surface that cannot be flipped. Deprecated.
NotFoundException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The requested item was not found. Deprecated.
NotLoadedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is an optimized surface, but it has not yet been allocated any memory. Deprecated.
NotLockedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to unlock a surface that was not locked. Deprecated.
NotPageLockedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to page-unlock a surface with no outstanding page locks. Deprecated.
NotPalettizedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface being used is not a palette-based surface. Deprecated.
NoVideoSyncHardwareException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for vertical blank-synchronized operations. Deprecated.
NoWindowException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Clipper notification requires a window, or no window has been previously set as the cooperative level window Deprecated.
OutOfCapsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The hardware needed for the requested operation has already been allocated. Deprecated.
OutOfVideoMemoryException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not have enough display memory to perform the operation. Deprecated.
OverlappingRectanglesException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The source and destination rectangles are on the same surface and overlap each other. Deprecated.
OverlayCantClipException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The hardware does not support clipped overlays. Deprecated.
OverlayColorKeyOnlyOneActiveException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to have more than one color key active on an overlay. Deprecated.
OverlayNotVisibleException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The GetOverlayPosition method was called on a hidden overlay. Deprecated.
Palette
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Palette object to create DirectDrawPalette objects Deprecated.
PaletteBusyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to this palette is refused because the palette is locked by another thread. Deprecated.
PrimarySurfaceAlreadyExistsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This process has already created a primary surface. Deprecated.
RegionTooSmallException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The region passed to the Clipper.ClipList property is too small. Deprecated.
Surface
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A surface represents a linear area of display memory. A surface usually resides in the display memory of the display card, although surfaces can exist in system memory. Unless specifically instructed otherwise during the creation of the Surface object, DirectDraw will put the Surface object wherever the best performance can be achieved given the requested capabilities. Surface objects can take advantage of specialized processors on display cards, not only to perform certain tasks faster, but to perform some tasks in parallel with the system CPU. Deprecated.
SurfaceBusyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface is locked by another thread. Deprecated.
SurfaceCaps
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Defines the capabilities of a DirectDrawSurface object. Deprecated.
SurfaceDescription
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A description of a surface. Deprecated.
SurfaceIsObscuredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface is obscured. Deprecated.
SurfaceLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface memory is gone. Call the Surface.Restore method on this surface to restore the memory associated Deprecated.
SurfaceNotAttachedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The requested surface is not attached. Deprecated.
SurfacesCollection
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A collection of surfaces. Deprecated.
TestFinishedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When thrown by StartModeTest method, this value means that no test could be initiated because all the resolutions chosen for testing already have refresh rate information in the registry. Deprecated.
TooBigHeightException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The height requested by DirectDraw is too large. Deprecated.
TooBigSizeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The size requested by DirectDraw is too large. However, the individual height and width are valid sizes. Deprecated.
TooBigWidthException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The width requested by DirectDraw is too large. Deprecated.
UnsupportedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is not supported. Deprecated.
UnsupportedFormatException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format requested is not supported by DirectDraw. Deprecated.
UnsupportedMaskException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The bitmask in the pixel format requested is not supported by DirectDraw. Deprecated.
UnsupportedModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display is currently in an unsupported mode. Deprecated.
VerticalBlankInProgressException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A vertical blank is in progress. Deprecated.
VideoNotActiveException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The video port is not active. Deprecated.
WasStillDrawingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The previous blit operation that is transferring information to or from this surface is incomplete. Deprecated.
WindowAlreadySetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDraw cooperative-level window has already been set. It cannot be reset while the process has surfaces or palettes created. Deprecated.
WindowSubclassedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is prevented from restoring state because the DirectDraw cooperative-level window handle has been subclassed. Deprecated.
WrongModeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface cannot be restored because it was created in a different mode. Deprecated.
XAlignException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The provided rectangle was not horizontally aligned on a required boundary. Deprecated.

Enumerations

ColorKeyFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines which color key is requested. Deprecated.
CooperativeLevelFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines the top-level behavior of the application. Deprecated.
CreateFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creation flags. Deprecated.
DrawFastFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Type of transfer. Deprecated.
DrawFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A combination of flags that determine the valid members of the associated DrawEffects structure, specify color-key information, or request special behavior from the method. Deprecated.
FlipFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags specifying flip options. Deprecated.
FourCc
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
FourCc codes Deprecated.
GetDeviceFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GetDeviceFlags Deprecated.
GetDevicesFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GetDevicesFlags Deprecated.
GetDisplayModeFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Getting displaymode flags, can be used to enumerate Standard VGA Modes, or RefreshRates. Deprecated.
GetSurfacesFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The search type flag determines how the method searches for matching surfaces; The matching flag determines whether the method enumerates all surfaces, only those that match, or only those that do not match the description. Deprecated.
LockFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags describing locking. Deprecated.
OverlayEffectsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for overlay effects. Deprecated.
OverlayFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.
OverlayZFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.
OverlayZOrdersFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.
StartModeTestFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for the StartModeTest call. Deprecated.
StereoViewCapsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for Stereo View caps... Deprecated.
WaitVbFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines how long to wait for the vertical blank. Deprecated.

Structures

Caps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the capabilities of the hardware exposed through the DirectDraw object. Deprecated.
ColorControlObject
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Defines the color controls associated with an overlay surface, or a primary surface. Deprecated.
ColorKey
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes a source color key, destination color key, or color space. Deprecated.
ColorKeyCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color Key capabilities Deprecated.
DeviceIdentifier
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.
DeviceInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.
DrawEffects
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations (ROPs), effects, and override information. Deprecated.
FXAlphaCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific alpha capabilities Deprecated.
FXCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.
GammaRamps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that stretching is available. Deprecated.
GetCapsStruct
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware and Hardware Emulation Layer (HEL) capabilities Deprecated.
LockedData
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
OverlayEffects
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Override information to the UpdateOverlay method. Deprecated.
PaletteCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Palette capabilities Deprecated.
PaletteEntry
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the color and usage of an entry in a logical color palette. Deprecated.
PixelFormat
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the pixel format of a DirectDrawSurface. Deprecated.


CannotCloneException Class (Microsoft.DirectX.DirectDraw)

CannotCloneException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Primary surfaces, or surfaces that are implicitly created, cannot be duplicated. Deprecated.

Definition

Visual Basic Public Class CannotCloneException
Inherits GraphicsException
C# | public class CannotCloneException : GraphicsException
C++ | public ref class CannotCloneException : GraphicsException
JScript | public class CannotCloneException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCloneException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotCloneException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotCloneException.CannotCloneException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCloneException();
protected CannotCloneException(SerializationInfo, StreamingContext);
public CannotCloneException(string);
public CannotCloneException(string, Exception);


CannotCloneException.CannotCloneException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

CannotCloneException.CannotCloneException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCloneException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotCloneException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotCloneException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotCloneException.CannotCloneException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

CannotCloneException.CannotCloneException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCloneException(
string message,
Exception inner
);
C++ public:
CannotCloneException(
String^ message,
Exception^ inner
);
JScript public function CannotCloneException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotCloneException.CannotCloneException(String) Constructor (Microsoft.DirectX.DirectDraw)

CannotCloneException.CannotCloneException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotCloneException(
string message
);
C++ public:
CannotCloneException(
String^ message
);
JScript public function CannotCloneException(
message : String
);

Parameters

message System.String


CannotCloneException.CannotCloneException() Constructor (Microsoft.DirectX.DirectDraw)

CannotCloneException.CannotCloneException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotCloneException();
C++ public:
CannotCloneException();
JScript | public function CannotCloneException();


CannotCreateDeviceContextException Class (Microsoft.DirectX.DirectDraw)

CannotCreateDeviceContextException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Windows cannot create any more device contexts (DCs), or a DC has requested a palette-indexed surface when the surface had no palette and the display mode was not palette-indexed (in this case DirectDraw cannot select a proper palette into the DC). Deprecated.

Definition

Visual Basic Public Class CannotCreateDeviceContextException
Inherits GraphicsException
C# | public class CannotCreateDeviceContextException : GraphicsException
C++ | public ref class CannotCreateDeviceContextException : GraphicsException
JScript | public class CannotCreateDeviceContextException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCreateDeviceContextException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotCreateDeviceContextException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCreateDeviceContextException();
protected CannotCreateDeviceContextException(SerializationInfo, StreamingContext);
public CannotCreateDeviceContextException(string);
public CannotCreateDeviceContextException(string, Exception);


CannotCreateDeviceContextException.CannotCreateDeviceContextException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCreateDeviceContextException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotCreateDeviceContextException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotCreateDeviceContextException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotCreateDeviceContextException.CannotCreateDeviceContextException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCreateDeviceContextException(
string message,
Exception inner
);
C++ public:
CannotCreateDeviceContextException(
String^ message,
Exception^ inner
);
JScript public function CannotCreateDeviceContextException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotCreateDeviceContextException.CannotCreateDeviceContextException(String) Constructor (Microsoft.DirectX.DirectDraw)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotCreateDeviceContextException(
string message
);
C++ public:
CannotCreateDeviceContextException(
String^ message
);
JScript public function CannotCreateDeviceContextException(
message : String
);

Parameters

message System.String


CannotCreateDeviceContextException.CannotCreateDeviceContextException() Constructor (Microsoft.DirectX.DirectDraw)

CannotCreateDeviceContextException.CannotCreateDeviceContextException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotCreateDeviceContextException();
C++ public:
CannotCreateDeviceContextException();
JScript | public function CannotCreateDeviceContextException();


CannotLockSurfaceException Class (Microsoft.DirectX.DirectDraw)

CannotLockSurfaceException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to this surface is refused because an attempt was made to lock the primary surface without DCI support. Deprecated.

Definition

Visual Basic Public Class CannotLockSurfaceException
Inherits GraphicsException
C# | public class CannotLockSurfaceException : GraphicsException
C++ | public ref class CannotLockSurfaceException : GraphicsException
JScript | public class CannotLockSurfaceException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotLockSurfaceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotLockSurfaceException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotLockSurfaceException.CannotLockSurfaceException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotLockSurfaceException();
protected CannotLockSurfaceException(SerializationInfo, StreamingContext);
public CannotLockSurfaceException(string);
public CannotLockSurfaceException(string, Exception);


CannotLockSurfaceException.CannotLockSurfaceException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotLockSurfaceException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotLockSurfaceException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotLockSurfaceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotLockSurfaceException.CannotLockSurfaceException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotLockSurfaceException(
string message,
Exception inner
);
C++ public:
CannotLockSurfaceException(
String^ message,
Exception^ inner
);
JScript public function CannotLockSurfaceException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotLockSurfaceException.CannotLockSurfaceException(String) Constructor (Microsoft.DirectX.DirectDraw)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotLockSurfaceException(
string message
);
C++ public:
CannotLockSurfaceException(
String^ message
);
JScript public function CannotLockSurfaceException(
message : String
);

Parameters

message System.String


CannotLockSurfaceException.CannotLockSurfaceException() Constructor (Microsoft.DirectX.DirectDraw)

CannotLockSurfaceException.CannotLockSurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotLockSurfaceException();
C++ public:
CannotLockSurfaceException();
JScript | public function CannotLockSurfaceException();


CannotPageLockException Class (Microsoft.DirectX.DirectDraw)

CannotPageLockException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to page-lock a surface failed. Page lock does not work on a display-memory surface or an emulated primary surface. Deprecated.

Definition

Visual Basic Public Class CannotPageLockException
Inherits GraphicsException
C# | public class CannotPageLockException : GraphicsException
C++ | public ref class CannotPageLockException : GraphicsException
JScript | public class CannotPageLockException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotPageLockException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotPageLockException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotPageLockException.CannotPageLockException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotPageLockException();
protected CannotPageLockException(SerializationInfo, StreamingContext);
public CannotPageLockException(string);
public CannotPageLockException(string, Exception);


CannotPageLockException.CannotPageLockException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

CannotPageLockException.CannotPageLockException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotPageLockException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotPageLockException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotPageLockException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotPageLockException.CannotPageLockException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

CannotPageLockException.CannotPageLockException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotPageLockException(
string message,
Exception inner
);
C++ public:
CannotPageLockException(
String^ message,
Exception^ inner
);
JScript public function CannotPageLockException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotPageLockException.CannotPageLockException(String) Constructor (Microsoft.DirectX.DirectDraw)

CannotPageLockException.CannotPageLockException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotPageLockException(
string message
);
C++ public:
CannotPageLockException(
String^ message
);
JScript public function CannotPageLockException(
message : String
);

Parameters

message System.String


CannotPageLockException.CannotPageLockException() Constructor (Microsoft.DirectX.DirectDraw)

CannotPageLockException.CannotPageLockException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotPageLockException();
C++ public:
CannotPageLockException();
JScript | public function CannotPageLockException();


CannotPageUnlockException Class (Microsoft.DirectX.DirectDraw)

CannotPageUnlockException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to page-unlock a surface failed. Page unlock does not work on a display-memory surface or an emulated primary surface. Deprecated.

Definition

Visual Basic Public Class CannotPageUnlockException
Inherits GraphicsException
C# | public class CannotPageUnlockException : GraphicsException
C++ | public ref class CannotPageUnlockException : GraphicsException
JScript | public class CannotPageUnlockException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotPageUnlockException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotPageUnlockException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotPageUnlockException.CannotPageUnlockException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotPageUnlockException();
protected CannotPageUnlockException(SerializationInfo, StreamingContext);
public CannotPageUnlockException(string);
public CannotPageUnlockException(string, Exception);


CannotPageUnlockException.CannotPageUnlockException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotPageUnlockException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotPageUnlockException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotPageUnlockException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotPageUnlockException.CannotPageUnlockException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotPageUnlockException(
string message,
Exception inner
);
C++ public:
CannotPageUnlockException(
String^ message,
Exception^ inner
);
JScript public function CannotPageUnlockException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotPageUnlockException.CannotPageUnlockException(String) Constructor (Microsoft.DirectX.DirectDraw)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotPageUnlockException(
string message
);
C++ public:
CannotPageUnlockException(
String^ message
);
JScript public function CannotPageUnlockException(
message : String
);

Parameters

message System.String


CannotPageUnlockException.CannotPageUnlockException() Constructor (Microsoft.DirectX.DirectDraw)

CannotPageUnlockException.CannotPageUnlockException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotPageUnlockException();
C++ public:
CannotPageUnlockException();
JScript | public function CannotPageUnlockException();


CapsComplexRequiredException Class (Microsoft.DirectX.DirectDraw)

CapsComplexRequiredException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface requires the Complex flag. Deprecated.

Definition

Visual Basic Public Class CapsComplexRequiredException
Inherits GraphicsException
C# | public class CapsComplexRequiredException : GraphicsException
C++ | public ref class CapsComplexRequiredException : GraphicsException
JScript | public class CapsComplexRequiredException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CapsComplexRequiredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CapsComplexRequiredException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CapsComplexRequiredException.CapsComplexRequiredException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CapsComplexRequiredException();
protected CapsComplexRequiredException(SerializationInfo, StreamingContext);
public CapsComplexRequiredException(string);
public CapsComplexRequiredException(string, Exception);


CapsComplexRequiredException.CapsComplexRequiredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CapsComplexRequiredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CapsComplexRequiredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CapsComplexRequiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CapsComplexRequiredException.CapsComplexRequiredException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CapsComplexRequiredException(
string message,
Exception inner
);
C++ public:
CapsComplexRequiredException(
String^ message,
Exception^ inner
);
JScript public function CapsComplexRequiredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CapsComplexRequiredException.CapsComplexRequiredException(String) Constructor (Microsoft.DirectX.DirectDraw)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CapsComplexRequiredException(
string message
);
C++ public:
CapsComplexRequiredException(
String^ message
);
JScript public function CapsComplexRequiredException(
message : String
);

Parameters

message System.String


CapsComplexRequiredException.CapsComplexRequiredException() Constructor (Microsoft.DirectX.DirectDraw)

CapsComplexRequiredException.CapsComplexRequiredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CapsComplexRequiredException();
C++ public:
CapsComplexRequiredException();
JScript | public function CapsComplexRequiredException();


Clipper Class (Microsoft.DirectX.DirectDraw)

Clipper Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Clipper object to manage clip lists. Deprecated.

Definition

Visual Basic Public Class Clipper
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Clipper : MarshalByRefObject, IDisposable
C++ | public ref class Clipper : MarshalByRefObject, IDisposable
JScript | public class Clipper extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
Clipper
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ClipList
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets a copy of the clip list associated with a Clipper object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
Window
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the window previously associated with this Clipper object. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Clipper

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Clipper.Clipper Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Clipper();
public Clipper(Device);


Clipper.Clipper(Device) Constructor (Microsoft.DirectX.DirectDraw)

Clipper.Clipper Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dev As Device _
)
C# public Clipper(
Device dev
);
C++ public:
Clipper(
Device^ dev
);
JScript public function Clipper(
dev : Device
);

Parameters

dev Microsoft.DirectX.DirectDraw.Device


Clipper.Clipper() Constructor (Microsoft.DirectX.DirectDraw)

Clipper.Clipper Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Clipper();
C++ public:
Clipper();
JScript | public function Clipper();


Clipper.Dispose() Method (Microsoft.DirectX.DirectDraw)

Clipper.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Clipper();
JScript | public override function Dispose();

See Also

  • Clipper.Disposed
  • Clipper.Disposing


Clipper.Equals(Object) Method (Microsoft.DirectX.DirectDraw)

Clipper.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Clipper.Finalize() Method (Microsoft.DirectX.DirectDraw)

Clipper.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Clipper();
C++ | !Clipper();
JScript | protected override function Finalize();


Clipper.GetHashCode() Method (Microsoft.DirectX.DirectDraw)

Clipper.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Clipper.op_Equality(Clipper,Clipper) Method (Microsoft.DirectX.DirectDraw)

Clipper.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Clipper, _
ByVal right As Clipper _
) As Boolean
C# public static bool op_Equality(
Clipper left,
Clipper right
);
C++ public:
static bool operator==(
Clipper^ left,
Clipper^ right
);
JScript public static function op_Equality(
left : Clipper,
right : Clipper
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.Clipper
The Clipper structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.Clipper
The Clipper structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Clipper.op_Inequality(Clipper,Clipper) Method (Microsoft.DirectX.DirectDraw)

Clipper.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Clipper, _
ByVal right As Clipper _
) As Boolean
C# public static bool op_Inequality(
Clipper left,
Clipper right
);
C++ public:
static bool operator!=(
Clipper^ left,
Clipper^ right
);
JScript public static function op_Inequality(
left : Clipper,
right : Clipper
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.Clipper
The Clipper structure to the left of the inequality operator.
right Microsoft.DirectX.DirectDraw.Clipper
The Clipper structure to the right of the inequality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Clipper.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectDraw)

Clipper.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Clipper.ClipList Property (Microsoft.DirectX.DirectDraw)

Clipper.ClipList Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets a copy of the clip list associated with a Clipper object. Deprecated.

Definition

Visual Basic | Public Property ClipList As Rectangle()
C# | public Rectangle[] ClipList { get; set; }
C++ public:
property array<Rectangle>^ ClipList {
array<Rectangle>^ get();
void set(array<Rectangle>^ value);
}
JScript public function get ClipList() : Rectangle[]
public function set ClipList(Rectangle[]);

Property Value

System.Drawing.Rectangle[]

This property is read/write.


Clipper.Disposed Property (Microsoft.DirectX.DirectDraw)

Clipper.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Clipper.Window Property (Microsoft.DirectX.DirectDraw)

Clipper.Window Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the window previously associated with this Clipper object. Deprecated.

Definition

Visual Basic | Public Property Window As Control
C# | public Control Window { get; set; }
C++ public:
property Control^ Window {
Control^ get();
void set(Control^ value);
}
JScript public function get Window() : Control
public function set Window(Control);

Property Value

System.Windows.Forms.Control

This property is read/write.


Clipper.Disposing Event (Microsoft.DirectX.DirectDraw)

Clipper.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Clipper.Disposing event, use the following code.

clipper.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


ClipperIsUsingWindowException Class (Microsoft.DirectX.DirectDraw)

ClipperIsUsingWindowException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to set a clip list for a DirectDrawClipper object that is already monitoring a window handle. Deprecated.

Definition

Visual Basic Public Class ClipperIsUsingWindowException
Inherits GraphicsException
C# | public class ClipperIsUsingWindowException : GraphicsException
C++ | public ref class ClipperIsUsingWindowException : GraphicsException
JScript | public class ClipperIsUsingWindowException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ClipperIsUsingWindowException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ClipperIsUsingWindowException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ClipperIsUsingWindowException();
protected ClipperIsUsingWindowException(SerializationInfo, StreamingContext);
public ClipperIsUsingWindowException(string);
public ClipperIsUsingWindowException(string, Exception);


ClipperIsUsingWindowException.ClipperIsUsingWindowException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ClipperIsUsingWindowException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ClipperIsUsingWindowException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ClipperIsUsingWindowException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ClipperIsUsingWindowException.ClipperIsUsingWindowException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ClipperIsUsingWindowException(
string message,
Exception inner
);
C++ public:
ClipperIsUsingWindowException(
String^ message,
Exception^ inner
);
JScript public function ClipperIsUsingWindowException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ClipperIsUsingWindowException.ClipperIsUsingWindowException(String) Constructor (Microsoft.DirectX.DirectDraw)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ClipperIsUsingWindowException(
string message
);
C++ public:
ClipperIsUsingWindowException(
String^ message
);
JScript public function ClipperIsUsingWindowException(
message : String
);

Parameters

message System.String


ClipperIsUsingWindowException.ClipperIsUsingWindowException() Constructor (Microsoft.DirectX.DirectDraw)

ClipperIsUsingWindowException.ClipperIsUsingWindowException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ClipperIsUsingWindowException();
C++ public:
ClipperIsUsingWindowException();
JScript | public function ClipperIsUsingWindowException();


ColorControl Class (Microsoft.DirectX.DirectDraw)

ColorControl Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ColorControl object allows you to get and set color controls. Deprecated.

Definition

Visual Basic Public Class ColorControl
Inherits MarshalByRefObject
Implements IDisposable
C# | public class ColorControl : MarshalByRefObject, IDisposable
C++ | public ref class ColorControl : MarshalByRefObject, IDisposable
JScript | public class ColorControl extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
ColorControl
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ColorControls
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Values to be applied to the specified surface. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
ColorControl

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorControl.ColorControl(Surface) Constructor (Microsoft.DirectX.DirectDraw)

ColorControl.ColorControl Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal surf As Surface _
)
C# public ColorControl(
Surface surf
);
C++ public:
ColorControl(
Surface^ surf
);
JScript public function ColorControl(
surf : Surface
);

Parameters

surf Microsoft.DirectX.DirectDraw.Surface


ColorControl.Dispose() Method (Microsoft.DirectX.DirectDraw)

ColorControl.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~ColorControl();
JScript | public override function Dispose();

See Also

  • ColorControl.Disposed
  • ColorControl.Disposing


ColorControl.Equals(Object) Method (Microsoft.DirectX.DirectDraw)

ColorControl.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


ColorControl.Finalize() Method (Microsoft.DirectX.DirectDraw)

ColorControl.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~ColorControl();
C++ | !ColorControl();
JScript | protected override function Finalize();


ColorControl.GetHashCode() Method (Microsoft.DirectX.DirectDraw)

ColorControl.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


ColorControl.op_Equality(ColorControl,ColorControl) Method (Microsoft.DirectX.DirectDraw)

ColorControl.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As ColorControl, _
ByVal right As ColorControl _
) As Boolean
C# public static bool op_Equality(
ColorControl left,
ColorControl right
);
C++ public:
static bool operator==(
ColorControl^ left,
ColorControl^ right
);
JScript public static function op_Equality(
left : ColorControl,
right : ColorControl
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.ColorControl
The ColorControl structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.ColorControl
The ColorControl structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


ColorControl.op_Inequality(ColorControl,ColorControl) Method (Microsoft.DirectX.DirectDraw)

ColorControl.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As ColorControl, _
ByVal right As ColorControl _
) As Boolean
C# public static bool op_Inequality(
ColorControl left,
ColorControl right
);
C++ public:
static bool operator!=(
ColorControl^ left,
ColorControl^ right
);
JScript public static function op_Inequality(
left : ColorControl,
right : ColorControl
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.ColorControl
The ColorControl structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.ColorControl
The ColorControl structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


ColorControl.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectDraw)

ColorControl.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


ColorControl.ColorControls Property (Microsoft.DirectX.DirectDraw)

ColorControl.ColorControls Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Values to be applied to the specified surface. Deprecated.

Definition

Visual Basic | Public Property ColorControls As ColorControlObject
C# | public ColorControlObject ColorControls { get; set; }
C++ public:
property ColorControlObject ColorControls {
ColorControlObject get();
void set(ColorControlObject value);
}
JScript public function get ColorControls() : ColorControlObject
public function set ColorControls(ColorControlObject);

Property Value

Microsoft.DirectX.DirectDraw.ColorControlObject

This property is read/write.


ColorControl.Disposed Property (Microsoft.DirectX.DirectDraw)

ColorControl.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


ColorControl.Disposing Event (Microsoft.DirectX.DirectDraw)

ColorControl.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a ColorControl.Disposing event, use the following code.

colorControl.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


ColorKeyNotSetException Class (Microsoft.DirectX.DirectDraw)

ColorKeyNotSetException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No source color key is specified for this operation. Deprecated.

Definition

Visual Basic Public Class ColorKeyNotSetException
Inherits GraphicsException
C# | public class ColorKeyNotSetException : GraphicsException
C++ | public ref class ColorKeyNotSetException : GraphicsException
JScript | public class ColorKeyNotSetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ColorKeyNotSetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ColorKeyNotSetException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorKeyNotSetException.ColorKeyNotSetException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ColorKeyNotSetException();
protected ColorKeyNotSetException(SerializationInfo, StreamingContext);
public ColorKeyNotSetException(string);
public ColorKeyNotSetException(string, Exception);


ColorKeyNotSetException.ColorKeyNotSetException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ColorKeyNotSetException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ColorKeyNotSetException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ColorKeyNotSetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ColorKeyNotSetException.ColorKeyNotSetException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ColorKeyNotSetException(
string message,
Exception inner
);
C++ public:
ColorKeyNotSetException(
String^ message,
Exception^ inner
);
JScript public function ColorKeyNotSetException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ColorKeyNotSetException.ColorKeyNotSetException(String) Constructor (Microsoft.DirectX.DirectDraw)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ColorKeyNotSetException(
string message
);
C++ public:
ColorKeyNotSetException(
String^ message
);
JScript public function ColorKeyNotSetException(
message : String
);

Parameters

message System.String


ColorKeyNotSetException.ColorKeyNotSetException() Constructor (Microsoft.DirectX.DirectDraw)

ColorKeyNotSetException.ColorKeyNotSetException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ColorKeyNotSetException();
C++ public:
ColorKeyNotSetException();
JScript | public function ColorKeyNotSetException();


CurrentlyNotAvailableException Class (Microsoft.DirectX.DirectDraw)

CurrentlyNotAvailableException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No support is currently available. Deprecated.

Definition

Visual Basic Public Class CurrentlyNotAvailableException
Inherits GraphicsException
C# | public class CurrentlyNotAvailableException : GraphicsException
C++ | public ref class CurrentlyNotAvailableException : GraphicsException
JScript | public class CurrentlyNotAvailableException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CurrentlyNotAvailableException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CurrentlyNotAvailableException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CurrentlyNotAvailableException();
protected CurrentlyNotAvailableException(SerializationInfo, StreamingContext);
public CurrentlyNotAvailableException(string);
public CurrentlyNotAvailableException(string, Exception);


CurrentlyNotAvailableException.CurrentlyNotAvailableException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CurrentlyNotAvailableException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CurrentlyNotAvailableException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CurrentlyNotAvailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CurrentlyNotAvailableException.CurrentlyNotAvailableException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CurrentlyNotAvailableException(
string message,
Exception inner
);
C++ public:
CurrentlyNotAvailableException(
String^ message,
Exception^ inner
);
JScript public function CurrentlyNotAvailableException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CurrentlyNotAvailableException.CurrentlyNotAvailableException(String) Constructor (Microsoft.DirectX.DirectDraw)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CurrentlyNotAvailableException(
string message
);
C++ public:
CurrentlyNotAvailableException(
String^ message
);
JScript public function CurrentlyNotAvailableException(
message : String
);

Parameters

message System.String


CurrentlyNotAvailableException.CurrentlyNotAvailableException() Constructor (Microsoft.DirectX.DirectDraw)

CurrentlyNotAvailableException.CurrentlyNotAvailableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CurrentlyNotAvailableException();
C++ public:
CurrentlyNotAvailableException();
JScript | public function CurrentlyNotAvailableException();


DDrawHelper Class (Microsoft.DirectX.DirectDraw)

DDrawHelper Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Utility class Deprecated.

Definition

Visual Basic NotInheritable Public Class DDrawHelper
Inherits Object
C# | public sealed class DDrawHelper : Object
C++ | public ref class DDrawHelper sealed : Object
JScript | public final class DDrawHelper extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic) KeyHardwareDescription
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyHardwareDriverName
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) PathHardware
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
DDrawHelper
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) GetWhqlDay
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Day. Deprecated.
static (Shared in Visual Basic) GetWhqlMonth
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Month. Deprecated.
static (Shared in Visual Basic) GetWhqlYear
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Year. Deprecated.

Inheritance Hierarchy

Object Leave Site
DDrawHelper

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DDrawHelper.DDrawHelper() Constructor (Microsoft.DirectX.DirectDraw)

DDrawHelper.DDrawHelper Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DDrawHelper();
C++ public:
DDrawHelper();
JScript | public function DDrawHelper();


DDrawHelper.GetWhqlDay(Int32) Method (Microsoft.DirectX.DirectDraw)

DDrawHelper.GetWhqlDay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Day. Deprecated.

Definition

Visual Basic Public Shared Function GetWhqlDay( _
ByVal whqlLevel As Integer _
) As Integer
C# public static int GetWhqlDay(
int whqlLevel
);
C++ public:
static int GetWhqlDay(
int whqlLevel
);
JScript public static function GetWhqlDay(
whqlLevel : int
) : int;

Parameters

whqlLevel System.Int32

Return Value

System.Int32


DDrawHelper.GetWhqlMonth(Int32) Method (Microsoft.DirectX.DirectDraw)

DDrawHelper.GetWhqlMonth Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Month. Deprecated.

Definition

Visual Basic Public Shared Function GetWhqlMonth( _
ByVal whqlLevel As Integer _
) As Integer
C# public static int GetWhqlMonth(
int whqlLevel
);
C++ public:
static int GetWhqlMonth(
int whqlLevel
);
JScript public static function GetWhqlMonth(
whqlLevel : int
) : int;

Parameters

whqlLevel System.Int32

Return Value

System.Int32


DDrawHelper.GetWhqlYear(Int32) Method (Microsoft.DirectX.DirectDraw)

DDrawHelper.GetWhqlYear Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the Windows Hardware Quality Labs Year. Deprecated.

Definition

Visual Basic Public Shared Function GetWhqlYear( _
ByVal whqlLevel As Integer _
) As Integer
C# public static int GetWhqlYear(
int whqlLevel
);
C++ public:
static int GetWhqlYear(
int whqlLevel
);
JScript public static function GetWhqlYear(
whqlLevel : int
) : int;

Parameters

whqlLevel System.Int32

Return Value

System.Int32


DDrawHelper.KeyHardwareDescription Field (Microsoft.DirectX.DirectDraw)

DDrawHelper.KeyHardwareDescription Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyHardwareDescription As String
C# | public static String KeyHardwareDescription;
C++ | public: static String KeyHardwareDescription;
JScript | public static var KeyHardwareDescription : String

Field Value

System.String

This field is read/write.


DDrawHelper.KeyHardwareDriverName Field (Microsoft.DirectX.DirectDraw)

DDrawHelper.KeyHardwareDriverName Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyHardwareDriverName As String
C# | public static String KeyHardwareDriverName;
C++ | public: static String KeyHardwareDriverName;
JScript | public static var KeyHardwareDriverName : String

Field Value

System.String

This field is read/write.


DDrawHelper.PathHardware Field (Microsoft.DirectX.DirectDraw)

DDrawHelper.PathHardware Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared PathHardware As String
C# | public static String PathHardware;
C++ | public: static String PathHardware;
JScript | public static var PathHardware : String

Field Value

System.String

This field is read/write.


Device Class (Microsoft.DirectX.DirectDraw)

Device Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Device object to create DirectDraw objects and work with system-level variables. Deprecated.

Definition

Visual Basic Public Class Device
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Device : MarshalByRefObject, IDisposable
C++ | public ref class Device : MarshalByRefObject, IDisposable
JScript | public class Device extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
Device
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
FlipToGdiSurface
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes the surface that the GDI writes to the primary surface. Deprecated.
GetAvailableVideoMemory
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the total amount of display memory available and the amount of display memory currently free for a given type of surface. Deprecated.
GetCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills in the capabilities of the device driver for the hardware and the hardware emulation layer (HEL). Deprecated.
GetDeviceInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains information about the driver. This method can be used, with caution, to recognize specific hardware installations to implement workarounds for poor driver or chipset behavior. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetSurfaceFromDC
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the Surface object for a surface, based on its GDI device context handle. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RestoreAllSurfaces
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Restores all the surfaces created for the DirectDraw object, in the order that they were created. Deprecated.
RestoreDisplayMode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Resets the mode of the display device hardware for the primary surface to what it was before the SetDisplayMode method was called. Exclusive-level access is required to use this method. Deprecated.
SetCooperativeLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines the top-level behavior of the application. Deprecated.
SetDisplayMode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the mode of the display-device hardware. Deprecated.
TestCooperativeLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reports the current cooperative-level status of the device for a windowed or full-screen application. Deprecated.
WaitForVerticalBlank
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Helps the application synchronize itself with the vertical-blank interval. Deprecated.

Properties

Property Description
DeviceInformation
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.
DisplayMode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the current display mode. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
FourCCCodes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the FOURCC codes supported by the DirectDraw object. Deprecated.
GdiSurface
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the DirectDrawSurface object that currently represents the surface memory that GDI is treating as the primary surface. Deprecated.
HardwareCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Capabilities of the device driver for the hardware. Deprecated.
HardwareEmulationCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Capabilities of the device driver for the hardware emulation layer (HEL). Deprecated.
MonitorFrequency
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the frequency of the monitor being driven by the DirectDraw object. Deprecated.
ScanLine
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the scan line that is currently being drawn on the monitor. Deprecated.
VerticalBlankStatus
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the status of the vertical blank. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Device

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Device.Device Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Device();
public Device(CreateFlags);
public Device(Guid);


Device.Device(CreateFlags) Constructor (Microsoft.DirectX.DirectDraw)

Device.Device Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As CreateFlags _
)
C# public Device(
CreateFlags flags
);
C++ public:
Device(
CreateFlags flags
);
JScript public function Device(
flags : CreateFlags
);

Parameters

flags Microsoft.DirectX.DirectDraw.CreateFlags


Device.Device(Guid) Constructor (Microsoft.DirectX.DirectDraw)

Device.Device Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal guidDevice As Guid _
)
C# public Device(
Guid guidDevice
);
C++ public:
Device(
Guid guidDevice
);
JScript public function Device(
guidDevice : Guid
);

Parameters

guidDevice System.Guid


Device.Device() Constructor (Microsoft.DirectX.DirectDraw)

Device.Device Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Device();
C++ public:
Device();
JScript | public function Device();


Device.Dispose() Method (Microsoft.DirectX.DirectDraw)

Device.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Device();
JScript | public override function Dispose();

See Also

  • Device.Disposed
  • Device.Disposing


Device.Equals(Object) Method (Microsoft.DirectX.DirectDraw)

Device.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Device.Finalize() Method (Microsoft.DirectX.DirectDraw)

Device.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Device();
C++ | !Device();
JScript | protected override function Finalize();


Device.FlipToGdiSurface() Method (Microsoft.DirectX.DirectDraw)

Device.FlipToGdiSurface Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes the surface that the GDI writes to the primary surface. Deprecated.

Definition

Visual Basic | Public Sub FlipToGdiSurface()
C# | public void FlipToGdiSurface();
C++ public:
void FlipToGdiSurface();
JScript | public function FlipToGdiSurface();


Device.GetAvailableVideoMemory(SurfaceCaps,Int32,Int32) Method (Microsoft.DirectX.DirectDraw)

Device.GetAvailableVideoMemory Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the total amount of display memory available and the amount of display memory currently free for a given type of surface. Deprecated.

Definition

Visual Basic Public Sub GetAvailableVideoMemory( _
ByVal caps As SurfaceCaps, _
ByRef totalMem As Integer, _
ByRef freeMem As Integer _
)
C# public void GetAvailableVideoMemory(
SurfaceCaps caps,
out int totalMem,
out int freeMem
);
C++ public:
void GetAvailableVideoMemory(
SurfaceCaps^ caps,
[Out] int% totalMem,
[Out] int% freeMem
);
JScript public function GetAvailableVideoMemory(
caps : SurfaceCaps,
totalMem : int,
freeMem : int
);

Parameters

caps Microsoft.DirectX.DirectDraw.SurfaceCaps
totalMem System.Int32
freeMem System.Int32


Device.GetCaps() Method (Microsoft.DirectX.DirectDraw)

Device.GetCaps Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills in the capabilities of the device driver for the hardware and the hardware emulation layer (HEL). Deprecated.

Definition

Visual Basic | Public Function GetCaps() As GetCapsStruct
C# | public GetCapsStruct GetCaps();
C++ public:
GetCapsStruct GetCaps();
JScript | public function GetCaps() : GetCapsStruct;

Return Value

Microsoft.DirectX.DirectDraw.GetCapsStruct


Device.GetDeviceInformation(GetDeviceFlags) Method (Microsoft.DirectX.DirectDraw)

Device.GetDeviceInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains information about the driver. This method can be used, with caution, to recognize specific hardware installations to implement workarounds for poor driver or chipset behavior. Deprecated.

Definition

Visual Basic Public Function GetDeviceInformation( _
ByVal flags As GetDeviceFlags _
) As DeviceIdentifier
C# public DeviceIdentifier GetDeviceInformation(
GetDeviceFlags flags
);
C++ public:
DeviceIdentifier GetDeviceInformation(
GetDeviceFlags flags
);
JScript public function GetDeviceInformation(
flags : GetDeviceFlags
) : DeviceIdentifier;

Parameters

flags Microsoft.DirectX.DirectDraw.GetDeviceFlags

Return Value

Microsoft.DirectX.DirectDraw.DeviceIdentifier


Device.GetHashCode() Method (Microsoft.DirectX.DirectDraw)

Device.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Device.GetSurfaceFromDC(IntPtr) Method (Microsoft.DirectX.DirectDraw)

Device.GetSurfaceFromDC Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the Surface object for a surface, based on its GDI device context handle. Deprecated.

Definition

Visual Basic Public Function GetSurfaceFromDC( _
ByVal dcHandle As IntPtr _
) As Surface
C# public Surface GetSurfaceFromDC(
IntPtr dcHandle
);
C++ public:
Surface^ GetSurfaceFromDC(
IntPtr dcHandle
);
JScript public function GetSurfaceFromDC(
dcHandle : IntPtr
) : Surface;

Parameters

dcHandle System.IntPtr

Return Value

Microsoft.DirectX.DirectDraw.Surface


Device.op_Equality(Device,Device) Method (Microsoft.DirectX.DirectDraw)

Device.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Equality(
Device left,
Device right
);
C++ public:
static bool operator==(
Device^ left,
Device^ right
);
JScript public static function op_Equality(
left : Device,
right : Device
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.Device
The Device structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.Device
The Device structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Device.op_Inequality(Device,Device) Method (Microsoft.DirectX.DirectDraw)

Device.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Inequality(
Device left,
Device right
);
C++ public:
static bool operator!=(
Device^ left,
Device^ right
);
JScript public static function op_Inequality(
left : Device,
right : Device
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.Device
The Device structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.Device
The Device structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Device.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectDraw)

Device.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Device.RestoreAllSurfaces() Method (Microsoft.DirectX.DirectDraw)

Device.RestoreAllSurfaces Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Restores all the surfaces created for the DirectDraw object, in the order that they were created. Deprecated.

Definition

Visual Basic | Public Sub RestoreAllSurfaces()
C# | public void RestoreAllSurfaces();
C++ public:
void RestoreAllSurfaces();
JScript | public function RestoreAllSurfaces();


Device.RestoreDisplayMode() Method (Microsoft.DirectX.DirectDraw)

Device.RestoreDisplayMode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Resets the mode of the display device hardware for the primary surface to what it was before the SetDisplayMode method was called. Exclusive-level access is required to use this method. Deprecated.

Definition

Visual Basic | Public Sub RestoreDisplayMode()
C# | public void RestoreDisplayMode();
C++ public:
void RestoreDisplayMode();
JScript | public function RestoreDisplayMode();


Device.SetCooperativeLevel(Control,CooperativeLevelFlags) Method (Microsoft.DirectX.DirectDraw)

Device.SetCooperativeLevel Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines the top-level behavior of the application. Deprecated.

Definition

Visual Basic Public Sub SetCooperativeLevel( _
ByVal parent As Control, _
ByVal flags As CooperativeLevelFlags _
)
C# public void SetCooperativeLevel(
Control parent,
CooperativeLevelFlags flags
);
C++ public:
void SetCooperativeLevel(
Control^ parent,
CooperativeLevelFlags flags
);
JScript public function SetCooperativeLevel(
parent : Control,
flags : CooperativeLevelFlags
);

Parameters

parent System.Windows.Forms.Control
flags Microsoft.DirectX.DirectDraw.CooperativeLevelFlags


Device.SetDisplayMode(Int32,Int32,Int32,Int32,Boolean) Method (Microsoft.DirectX.DirectDraw)

Device.SetDisplayMode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the mode of the display-device hardware. Deprecated.

Definition

Visual Basic Public Sub SetDisplayMode( _
ByVal width As Integer, _
ByVal height As Integer, _
ByVal bitPerPixel As Integer, _
ByVal refreshRate As Integer, _
ByVal standardVgaMode As Boolean _
)
C# public void SetDisplayMode(
int width,
int height,
int bitPerPixel,
int refreshRate,
bool standardVgaMode
);
C++ public:
void SetDisplayMode(
int width,
int height,
int bitPerPixel,
int refreshRate,
bool standardVgaMode
);
JScript public function SetDisplayMode(
width : int,
height : int,
bitPerPixel : int,
refreshRate : int,
standardVgaMode : boolean
);

Parameters

width System.Int32
height System.Int32
bitPerPixel System.Int32
refreshRate System.Int32
standardVgaMode System.Boolean


Device.TestCooperativeLevel() Method (Microsoft.DirectX.DirectDraw)

Device.TestCooperativeLevel Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reports the current cooperative-level status of the device for a windowed or full-screen application. Deprecated.

Definition

Visual Basic | Public Function TestCooperativeLevel() As Boolean
C# | public bool TestCooperativeLevel();
C++ public:
bool TestCooperativeLevel();
JScript | public function TestCooperativeLevel() : boolean;

Return Value

System.Boolean


Device.WaitForVerticalBlank(WaitVbFlags) Method (Microsoft.DirectX.DirectDraw)

Device.WaitForVerticalBlank Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Helps the application synchronize itself with the vertical-blank interval. Deprecated.

Definition

Visual Basic Public Sub WaitForVerticalBlank( _
ByVal flags As WaitVbFlags _
)
C# public void WaitForVerticalBlank(
WaitVbFlags flags
);
C++ public:
void WaitForVerticalBlank(
WaitVbFlags flags
);
JScript public function WaitForVerticalBlank(
flags : WaitVbFlags
);

Parameters

flags Microsoft.DirectX.DirectDraw.WaitVbFlags


Device.DeviceInformation Property (Microsoft.DirectX.DirectDraw)

Device.DeviceInformation Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DeviceInformation As DeviceIdentifier
C# | public DeviceIdentifier DeviceInformation { get; }
C++ public:
property DeviceIdentifier DeviceInformation {
DeviceIdentifier get();
}
JScript | public function get DeviceInformation() : DeviceIdentifier

Property Value

Microsoft.DirectX.DirectDraw.DeviceIdentifier

This property is read-only.


Device.DisplayMode Property (Microsoft.DirectX.DirectDraw)

Device.DisplayMode Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the current display mode. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DisplayMode As SurfaceDescription
C# | public SurfaceDescription DisplayMode { get; }
C++ public:
property SurfaceDescription^ DisplayMode {
SurfaceDescription^ get();
}
JScript | public function get DisplayMode() : SurfaceDescription

Property Value

Microsoft.DirectX.DirectDraw.SurfaceDescription

This property is read-only.


Device.Disposed Property (Microsoft.DirectX.DirectDraw)

Device.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Device.FourCCCodes Property (Microsoft.DirectX.DirectDraw)

Device.FourCCCodes Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the FOURCC codes supported by the DirectDraw object. Deprecated.

Definition

Visual Basic | Public ReadOnly Property FourCCCodes As Integer()
C# | public int[] FourCCCodes { get; }
C++ public:
property array<int>^ FourCCCodes {
array<int>^ get();
}
JScript | public function get FourCCCodes() : int[]

Property Value

System.Int32[]

This property is read-only.


Device.GdiSurface Property (Microsoft.DirectX.DirectDraw)

Device.GdiSurface Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the DirectDrawSurface object that currently represents the surface memory that GDI is treating as the primary surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GdiSurface As Surface
C# | public Surface GdiSurface { get; }
C++ public:
property Surface^ GdiSurface {
Surface^ get();
}
JScript | public function get GdiSurface() : Surface

Property Value

Microsoft.DirectX.DirectDraw.Surface

This property is read-only.


Device.HardwareCaps Property (Microsoft.DirectX.DirectDraw)

Device.HardwareCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Capabilities of the device driver for the hardware. Deprecated.

Definition

Visual Basic | Public ReadOnly Property HardwareCaps As Caps
C# | public Caps HardwareCaps { get; }
C++ public:
property Caps HardwareCaps {
Caps get();
}
JScript | public function get HardwareCaps() : Caps

Property Value

Microsoft.DirectX.DirectDraw.Caps

This property is read-only.


Device.HardwareEmulationCaps Property (Microsoft.DirectX.DirectDraw)

Device.HardwareEmulationCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Capabilities of the device driver for the hardware emulation layer (HEL). Deprecated.

Definition

Visual Basic | Public ReadOnly Property HardwareEmulationCaps As Caps
C# | public Caps HardwareEmulationCaps { get; }
C++ public:
property Caps HardwareEmulationCaps {
Caps get();
}
JScript | public function get HardwareEmulationCaps() : Caps

Property Value

Microsoft.DirectX.DirectDraw.Caps

This property is read-only.


Device.MonitorFrequency Property (Microsoft.DirectX.DirectDraw)

Device.MonitorFrequency Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the frequency of the monitor being driven by the DirectDraw object. Deprecated.

Definition

Visual Basic | Public ReadOnly Property MonitorFrequency As Integer
C# | public int MonitorFrequency { get; }
C++ public:
property int MonitorFrequency {
int get();
}
JScript | public function get MonitorFrequency() : int

Property Value

System.Int32

This property is read-only.


Device.ScanLine Property (Microsoft.DirectX.DirectDraw)

Device.ScanLine Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the scan line that is currently being drawn on the monitor. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ScanLine As Integer
C# | public int ScanLine { get; }
C++ public:
property int ScanLine {
int get();
}
JScript | public function get ScanLine() : int

Property Value

System.Int32

This property is read-only.


Device.VerticalBlankStatus Property (Microsoft.DirectX.DirectDraw)

Device.VerticalBlankStatus Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the status of the vertical blank. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VerticalBlankStatus As Boolean
C# | public bool VerticalBlankStatus { get; }
C++ public:
property bool VerticalBlankStatus {
bool get();
}
JScript | public function get VerticalBlankStatus() : boolean

Property Value

System.Boolean

This property is read-only.


Device.Disposing Event (Microsoft.DirectX.DirectDraw)

Device.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Device.Disposing event, use the following code.

device.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


DeviceDoesNotOwnSurfaceException Class (Microsoft.DirectX.DirectDraw)

DeviceDoesNotOwnSurfaceException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Surfaces created by one DirectDraw device cannot be used directly by another DirectDraw device. Deprecated.

Definition

Visual Basic Public Class DeviceDoesNotOwnSurfaceException
Inherits GraphicsException
C# | public class DeviceDoesNotOwnSurfaceException : GraphicsException
C++ | public ref class DeviceDoesNotOwnSurfaceException : GraphicsException
JScript | public class DeviceDoesNotOwnSurfaceException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceDoesNotOwnSurfaceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DeviceDoesNotOwnSurfaceException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DeviceDoesNotOwnSurfaceException();
protected DeviceDoesNotOwnSurfaceException(SerializationInfo, StreamingContext);
public DeviceDoesNotOwnSurfaceException(string);
public DeviceDoesNotOwnSurfaceException(string, Exception);


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceDoesNotOwnSurfaceException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DeviceDoesNotOwnSurfaceException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DeviceDoesNotOwnSurfaceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceDoesNotOwnSurfaceException(
string message,
Exception inner
);
C++ public:
DeviceDoesNotOwnSurfaceException(
String^ message,
Exception^ inner
);
JScript public function DeviceDoesNotOwnSurfaceException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException(String) Constructor (Microsoft.DirectX.DirectDraw)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DeviceDoesNotOwnSurfaceException(
string message
);
C++ public:
DeviceDoesNotOwnSurfaceException(
String^ message
);
JScript public function DeviceDoesNotOwnSurfaceException(
message : String
);

Parameters

message System.String


DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException() Constructor (Microsoft.DirectX.DirectDraw)

DeviceDoesNotOwnSurfaceException.DeviceDoesNotOwnSurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DeviceDoesNotOwnSurfaceException();
C++ public:
DeviceDoesNotOwnSurfaceException();
JScript | public function DeviceDoesNotOwnSurfaceException();


DevicesCollection Class (Microsoft.DirectX.DirectDraw)

DevicesCollection Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Collection of devices. Deprecated.

Definition

Visual Basic NotInheritable Public Class DevicesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class DevicesCollection : Object, IEnumerable, IEnumerator
C++ | public ref class DevicesCollection sealed : Object, IEnumerable, IEnumerator
JScript | public final class DevicesCollection extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DevicesCollection
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetEnumerator
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.
MoveNext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.
Reset
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Properties

Property Description
Count
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.
Current
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Inheritance Hierarchy

Object Leave Site
DevicesCollection

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DevicesCollection.DevicesCollection Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DevicesCollection();
public DevicesCollection(GetDevicesFlags);


DevicesCollection.DevicesCollection(GetDevicesFlags) Constructor (Microsoft.DirectX.DirectDraw)

DevicesCollection.DevicesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As GetDevicesFlags _
)
C# public DevicesCollection(
GetDevicesFlags flags
);
C++ public:
DevicesCollection(
GetDevicesFlags flags
);
JScript public function DevicesCollection(
flags : GetDevicesFlags
);

Parameters

flags Microsoft.DirectX.DirectDraw.GetDevicesFlags


DevicesCollection.DevicesCollection() Constructor (Microsoft.DirectX.DirectDraw)

DevicesCollection.DevicesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DevicesCollection();
C++ public:
DevicesCollection();
JScript | public function DevicesCollection();


DevicesCollection.GetEnumerator() Method (Microsoft.DirectX.DirectDraw)

DevicesCollection.GetEnumerator Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


DevicesCollection.MoveNext() Method (Microsoft.DirectX.DirectDraw)

DevicesCollection.MoveNext Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean


DevicesCollection.Reset() Method (Microsoft.DirectX.DirectDraw)

DevicesCollection.Reset Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();


DevicesCollection.Count Property (Microsoft.DirectX.DirectDraw)

DevicesCollection.Count Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


DevicesCollection.Current Property (Microsoft.DirectX.DirectDraw)

DevicesCollection.Current Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object

This property is read-only.


DisplayModesCollection Class (Microsoft.DirectX.DirectDraw)

DisplayModesCollection Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Collection of display modes. Deprecated.

Definition

Visual Basic NotInheritable Public Class DisplayModesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class DisplayModesCollection : Object, IEnumerable, IEnumerator
C++ | public ref class DisplayModesCollection sealed : Object, IEnumerable, IEnumerator
JScript | public final class DisplayModesCollection extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DisplayModesCollection
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetEnumerator
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.
MoveNext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.
Reset
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Properties

Property Description
Count
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.
Current
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Inheritance Hierarchy

Object Leave Site
DisplayModesCollection

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisplayModesCollection.DisplayModesCollection Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DisplayModesCollection(Device);
public DisplayModesCollection(GetDisplayModeFlags, SurfaceDescription, Device);
public DisplayModesCollection(SurfaceDescription, Device);


DisplayModesCollection.DisplayModesCollection(Device) Constructor (Microsoft.DirectX.DirectDraw)

DisplayModesCollection.DisplayModesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dev As Device _
)
C# public DisplayModesCollection(
Device dev
);
C++ public:
DisplayModesCollection(
Device^ dev
);
JScript public function DisplayModesCollection(
dev : Device
);

Parameters

dev Microsoft.DirectX.DirectDraw.Device


DisplayModesCollection.DisplayModesCollection(SurfaceDescription,Device) Constructor (Microsoft.DirectX.DirectDraw)

DisplayModesCollection.DisplayModesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public DisplayModesCollection(
SurfaceDescription desc,
Device dev
);
C++ public:
DisplayModesCollection(
SurfaceDescription^ desc,
Device^ dev
);
JScript public function DisplayModesCollection(
desc : SurfaceDescription,
dev : Device
);

Parameters

desc Microsoft.DirectX.DirectDraw.SurfaceDescription
dev Microsoft.DirectX.DirectDraw.Device


DisplayModesCollection.DisplayModesCollection(GetDisplayModeFlags,SurfaceDescription,Device) Constructor (Microsoft.DirectX.DirectDraw)

DisplayModesCollection.DisplayModesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As GetDisplayModeFlags, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public DisplayModesCollection(
GetDisplayModeFlags flags,
SurfaceDescription desc,
Device dev
);
C++ public:
DisplayModesCollection(
GetDisplayModeFlags flags,
SurfaceDescription^ desc,
Device^ dev
);
JScript public function DisplayModesCollection(
flags : GetDisplayModeFlags,
desc : SurfaceDescription,
dev : Device
);

Parameters

flags Microsoft.DirectX.DirectDraw.GetDisplayModeFlags
desc Microsoft.DirectX.DirectDraw.SurfaceDescription
dev Microsoft.DirectX.DirectDraw.Device


DisplayModesCollection.GetEnumerator() Method (Microsoft.DirectX.DirectDraw)

DisplayModesCollection.GetEnumerator Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


DisplayModesCollection.MoveNext() Method (Microsoft.DirectX.DirectDraw)

DisplayModesCollection.MoveNext Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean


DisplayModesCollection.Reset() Method (Microsoft.DirectX.DirectDraw)

DisplayModesCollection.Reset Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();


DisplayModesCollection.Count Property (Microsoft.DirectX.DirectDraw)

DisplayModesCollection.Count Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


DisplayModesCollection.Current Property (Microsoft.DirectX.DirectDraw)

DisplayModesCollection.Current Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object

This property is read-only.


DrawFastCannotClipException Class (Microsoft.DirectX.DirectDraw)

DrawFastCannotClipException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A DirectDrawClipper object is attached to a source surface that has passed into a call to the DrawFast method. Deprecated.

Definition

Visual Basic Public Class DrawFastCannotClipException
Inherits GraphicsException
C# | public class DrawFastCannotClipException : GraphicsException
C++ | public ref class DrawFastCannotClipException : GraphicsException
JScript | public class DrawFastCannotClipException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DrawFastCannotClipException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
DrawFastCannotClipException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrawFastCannotClipException.DrawFastCannotClipException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DrawFastCannotClipException();
protected DrawFastCannotClipException(SerializationInfo, StreamingContext);
public DrawFastCannotClipException(string);
public DrawFastCannotClipException(string, Exception);


DrawFastCannotClipException.DrawFastCannotClipException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DrawFastCannotClipException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DrawFastCannotClipException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DrawFastCannotClipException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


DrawFastCannotClipException.DrawFastCannotClipException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DrawFastCannotClipException(
string message,
Exception inner
);
C++ public:
DrawFastCannotClipException(
String^ message,
Exception^ inner
);
JScript public function DrawFastCannotClipException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


DrawFastCannotClipException.DrawFastCannotClipException(String) Constructor (Microsoft.DirectX.DirectDraw)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DrawFastCannotClipException(
string message
);
C++ public:
DrawFastCannotClipException(
String^ message
);
JScript public function DrawFastCannotClipException(
message : String
);

Parameters

message System.String


DrawFastCannotClipException.DrawFastCannotClipException() Constructor (Microsoft.DirectX.DirectDraw)

DrawFastCannotClipException.DrawFastCannotClipException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DrawFastCannotClipException();
C++ public:
DrawFastCannotClipException();
JScript | public function DrawFastCannotClipException();


ExclusiveModeAlreadySetException Class (Microsoft.DirectX.DirectDraw)

ExclusiveModeAlreadySetException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to set the cooperative level when it was already set to exclusive. Deprecated.

Definition

Visual Basic Public Class ExclusiveModeAlreadySetException
Inherits GraphicsException
C# | public class ExclusiveModeAlreadySetException : GraphicsException
C++ | public ref class ExclusiveModeAlreadySetException : GraphicsException
JScript | public class ExclusiveModeAlreadySetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ExclusiveModeAlreadySetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ExclusiveModeAlreadySetException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ExclusiveModeAlreadySetException();
protected ExclusiveModeAlreadySetException(SerializationInfo, StreamingContext);
public ExclusiveModeAlreadySetException(string);
public ExclusiveModeAlreadySetException(string, Exception);


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ExclusiveModeAlreadySetException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ExclusiveModeAlreadySetException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ExclusiveModeAlreadySetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ExclusiveModeAlreadySetException(
string message,
Exception inner
);
C++ public:
ExclusiveModeAlreadySetException(
String^ message,
Exception^ inner
);
JScript public function ExclusiveModeAlreadySetException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException(String) Constructor (Microsoft.DirectX.DirectDraw)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ExclusiveModeAlreadySetException(
string message
);
C++ public:
ExclusiveModeAlreadySetException(
String^ message
);
JScript public function ExclusiveModeAlreadySetException(
message : String
);

Parameters

message System.String


ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException() Constructor (Microsoft.DirectX.DirectDraw)

ExclusiveModeAlreadySetException.ExclusiveModeAlreadySetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ExclusiveModeAlreadySetException();
C++ public:
ExclusiveModeAlreadySetException();
JScript | public function ExclusiveModeAlreadySetException();


ExpiredException Class (Microsoft.DirectX.DirectDraw)

ExpiredException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data has expired and is therefore no longer valid. Deprecated.

Definition

Visual Basic Public Class ExpiredException
Inherits GraphicsException
C# | public class ExpiredException : GraphicsException
C++ | public ref class ExpiredException : GraphicsException
JScript | public class ExpiredException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ExpiredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ExpiredException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ExpiredException.ExpiredException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ExpiredException();
protected ExpiredException(SerializationInfo, StreamingContext);
public ExpiredException(string);
public ExpiredException(string, Exception);


ExpiredException.ExpiredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

ExpiredException.ExpiredException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ExpiredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ExpiredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ExpiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ExpiredException.ExpiredException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

ExpiredException.ExpiredException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ExpiredException(
string message,
Exception inner
);
C++ public:
ExpiredException(
String^ message,
Exception^ inner
);
JScript public function ExpiredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ExpiredException.ExpiredException(String) Constructor (Microsoft.DirectX.DirectDraw)

ExpiredException.ExpiredException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ExpiredException(
string message
);
C++ public:
ExpiredException(
String^ message
);
JScript public function ExpiredException(
message : String
);

Parameters

message System.String


ExpiredException.ExpiredException() Constructor (Microsoft.DirectX.DirectDraw)

ExpiredException.ExpiredException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ExpiredException();
C++ public:
ExpiredException();
JScript | public function ExpiredException();


GammaControl Class (Microsoft.DirectX.DirectDraw)

GammaControl Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the GammaControl object to adjust the red, green, and blue gamma ramp levels of the primary surface. Deprecated.

Definition

Visual Basic Public Class GammaControl
Inherits MarshalByRefObject
Implements IDisposable
C# | public class GammaControl : MarshalByRefObject, IDisposable
C++ | public ref class GammaControl : MarshalByRefObject, IDisposable
JScript | public class GammaControl extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GammaControl
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
SetGammaRamp
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the red, green, and blue gamma ramps for the primary surface. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
GammaRamp
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the red, green, and blue gamma ramps for the primary surface. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
GammaControl

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GammaControl.Dispose() Method (Microsoft.DirectX.DirectDraw)

GammaControl.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~GammaControl();
JScript | public override function Dispose();

See Also

  • GammaControl.Disposed
  • GammaControl.Disposing


GammaControl.Equals(Object) Method (Microsoft.DirectX.DirectDraw)

GammaControl.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


GammaControl.Finalize() Method (Microsoft.DirectX.DirectDraw)

GammaControl.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~GammaControl();
C++ | !GammaControl();
JScript | protected override function Finalize();


GammaControl.GammaControl(Surface) Constructor (Microsoft.DirectX.DirectDraw)

GammaControl.GammaControl Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal surf As Surface _
)
C# public GammaControl(
Surface surf
);
C++ public:
GammaControl(
Surface^ surf
);
JScript public function GammaControl(
surf : Surface
);

Parameters

surf Microsoft.DirectX.DirectDraw.Surface


GammaControl.GetHashCode() Method (Microsoft.DirectX.DirectDraw)

GammaControl.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


GammaControl.op_Equality(GammaControl,GammaControl) Method (Microsoft.DirectX.DirectDraw)

GammaControl.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As GammaControl, _
ByVal right As GammaControl _
) As Boolean
C# public static bool op_Equality(
GammaControl left,
GammaControl right
);
C++ public:
static bool operator==(
GammaControl^ left,
GammaControl^ right
);
JScript public static function op_Equality(
left : GammaControl,
right : GammaControl
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.GammaControl
The GammaControl structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.GammaControl
The GammaControl structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


GammaControl.op_Inequality(GammaControl,GammaControl) Method (Microsoft.DirectX.DirectDraw)

GammaControl.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As GammaControl, _
ByVal right As GammaControl _
) As Boolean
C# public static bool op_Inequality(
GammaControl left,
GammaControl right
);
C++ public:
static bool operator!=(
GammaControl^ left,
GammaControl^ right
);
JScript public static function op_Inequality(
left : GammaControl,
right : GammaControl
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.GammaControl
The GammaControl structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.GammaControl
The GammaControl structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


GammaControl.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectDraw)

GammaControl.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


GammaControl.SetGammaRamp(Boolean,GammaRamps) Method (Microsoft.DirectX.DirectDraw)

GammaControl.SetGammaRamp Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the red, green, and blue gamma ramps for the primary surface. Deprecated.

Definition

Visual Basic Public Sub SetGammaRamp( _
ByVal calibrate As Boolean, _
ByVal ramps As GammaRamps _
)
C# public void SetGammaRamp(
bool calibrate,
GammaRamps ramps
);
C++ public:
void SetGammaRamp(
bool calibrate,
GammaRamps ramps
);
JScript public function SetGammaRamp(
calibrate : boolean,
ramps : GammaRamps
);

Parameters

calibrate System.Boolean
ramps Microsoft.DirectX.DirectDraw.GammaRamps


GammaControl.Disposed Property (Microsoft.DirectX.DirectDraw)

GammaControl.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


GammaControl.GammaRamp Property (Microsoft.DirectX.DirectDraw)

GammaControl.GammaRamp Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the red, green, and blue gamma ramps for the primary surface. Deprecated.

Definition

Visual Basic | Public Property GammaRamp As GammaRamps
C# | public GammaRamps GammaRamp { get; set; }
C++ public:
property GammaRamps GammaRamp {
GammaRamps get();
void set(GammaRamps value);
}
JScript public function get GammaRamp() : GammaRamps
public function set GammaRamp(GammaRamps);

Property Value

Microsoft.DirectX.DirectDraw.GammaRamps

This property is read/write.


GammaControl.Disposing Event (Microsoft.DirectX.DirectDraw)

GammaControl.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a GammaControl.Disposing event, use the following code.

gammaControl.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


GraphicsAlreadyCreatedException Class (Microsoft.DirectX.DirectDraw)

GraphicsAlreadyCreatedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A device context (DC) has already been returned for this surface. Only one DC can be retrieved for each surface. Deprecated.

Definition

Visual Basic Public Class GraphicsAlreadyCreatedException
Inherits GraphicsException
C# | public class GraphicsAlreadyCreatedException : GraphicsException
C++ | public ref class GraphicsAlreadyCreatedException : GraphicsException
JScript | public class GraphicsAlreadyCreatedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
GraphicsAlreadyCreatedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
GraphicsAlreadyCreatedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public GraphicsAlreadyCreatedException();
protected GraphicsAlreadyCreatedException(SerializationInfo, StreamingContext);
public GraphicsAlreadyCreatedException(string);
public GraphicsAlreadyCreatedException(string, Exception);


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected GraphicsAlreadyCreatedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
GraphicsAlreadyCreatedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function GraphicsAlreadyCreatedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public GraphicsAlreadyCreatedException(
string message,
Exception inner
);
C++ public:
GraphicsAlreadyCreatedException(
String^ message,
Exception^ inner
);
JScript public function GraphicsAlreadyCreatedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException(String) Constructor (Microsoft.DirectX.DirectDraw)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public GraphicsAlreadyCreatedException(
string message
);
C++ public:
GraphicsAlreadyCreatedException(
String^ message
);
JScript public function GraphicsAlreadyCreatedException(
message : String
);

Parameters

message System.String


GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException() Constructor (Microsoft.DirectX.DirectDraw)

GraphicsAlreadyCreatedException.GraphicsAlreadyCreatedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public GraphicsAlreadyCreatedException();
C++ public:
GraphicsAlreadyCreatedException();
JScript | public function GraphicsAlreadyCreatedException();


GraphicsException Class (Microsoft.DirectX.DirectDraw)

GraphicsException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception class for all DirectDraw exceptions. Derives from DirectXException. Deprecated.

Definition

Visual Basic Public Class GraphicsException
Inherits DirectXException
C# | public class GraphicsException : DirectXException
C++ | public ref class GraphicsException : DirectXException
JScript | public class GraphicsException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
GraphicsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
CannotCloneException
CannotCreateDeviceContextException
CannotLockSurfaceException
CannotPageLockException
CannotPageUnlockException
CapsComplexRequiredException
ClipperIsUsingWindowException
ColorKeyNotSetException
CurrentlyNotAvailableException
DeviceDoesNotOwnSurfaceException
DrawFastCannotClipException
ExclusiveModeAlreadySetException
ExpiredException
GraphicsAlreadyCreatedException
HeightAlignException
ImplicitlyCreatedException
IncompatiblePrimaryException
InvalidCapsException
InvalidClipListException
InvalidDirectDrawGuidException
InvalidModeException
InvalidObjectException
InvalidPixelFormatException
InvalidPositionException
InvalidRectangleException
InvalidStreamException
InvalidSurfaceTypeException
LockedSurfacesException
MoreDataException
NewModeException
NoAlphaHardwareException
NoClipListException
NoClipperAttachedException
NoColorConversionHardwareException
NoColorKeyException
NoColorKeyHardwareException
NoCooperativeLevelSetException
NoDeviceContextException
NoDirectDrawHardwareException
NoDirectDrawSupportException
NoDrawHardwareException
NoDriverSupportException
NoEmulationException
NoExclusiveModeException
NoFlipHardwareException
NoFocusWindowException
NoGdiException
NoMirrorHardwareException
NoMonitorInformationException
NoNonLocalVideoMemoryException
NoOptimizeHardwareException
NoOverlayDestinationException
NoOverlayHardwareException
NoPaletteAttachedException
NoPaletteHardwareException
NoRasterOperationHardwareException
NoRotationHardwareException
NoStereoHardwareException
NoStretchHardwareException
NoSurfaceLeftException
Not4BitColorException
Not4BitColorIndexException
Not8BitColorException
NotAnOverlaySurfaceException
NotFlippableException
NotFoundException
NotLoadedException
NotLockedException
NotPageLockedException
NotPalettizedException
NoVideoSyncHardwareException
NoWindowException
OutOfCapsException
OutOfVideoMemoryException
OverlappingRectanglesException
OverlayCantClipException
OverlayColorKeyOnlyOneActiveException
OverlayNotVisibleException
PaletteBusyException
PrimarySurfaceAlreadyExistsException
RegionTooSmallException
SurfaceBusyException
SurfaceIsObscuredException
SurfaceLostException
SurfaceNotAttachedException
TestFinishedException
TooBigHeightException
TooBigSizeException
TooBigWidthException
UnsupportedException
UnsupportedFormatException
UnsupportedMaskException
UnsupportedModeException
VerticalBlankInProgressException
VideoNotActiveException
WasStillDrawingException
WindowAlreadySetException
WindowSubclassedException
WrongModeException
XAlignException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GraphicsException.GetExceptionFromResultInternal(Int32) Method (Microsoft.DirectX.DirectDraw)

GraphicsException.GetExceptionFromResultInternal Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Shadows Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public new static Exception GetExceptionFromResultInternal(
int resultCode
);
C++ public:
static Exception^ GetExceptionFromResultInternal(
int resultCode
);
JScript public hide static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32

Return Value

System.Exception

Applies To

This object applies to a large number of classes.


GraphicsException.GraphicsException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public GraphicsException();
protected GraphicsException(SerializationInfo, StreamingContext);
public GraphicsException(string);
public GraphicsException(string, Exception);


GraphicsException.GraphicsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

GraphicsException.GraphicsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected GraphicsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
GraphicsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function GraphicsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


GraphicsException.GraphicsException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

GraphicsException.GraphicsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public GraphicsException(
string message,
Exception inner
);
C++ public:
GraphicsException(
String^ message,
Exception^ inner
);
JScript public function GraphicsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


GraphicsException.GraphicsException(String) Constructor (Microsoft.DirectX.DirectDraw)

GraphicsException.GraphicsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public GraphicsException(
string message
);
C++ public:
GraphicsException(
String^ message
);
JScript public function GraphicsException(
message : String
);

Parameters

message System.String


GraphicsException.GraphicsException() Constructor (Microsoft.DirectX.DirectDraw)

GraphicsException.GraphicsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public GraphicsException();
C++ public:
GraphicsException();
JScript | public function GraphicsException();


HeightAlignException Class (Microsoft.DirectX.DirectDraw)

HeightAlignException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The height of the provided rectangle is not a multiple of the required alignment. Deprecated.

Definition

Visual Basic Public Class HeightAlignException
Inherits GraphicsException
C# | public class HeightAlignException : GraphicsException
C++ | public ref class HeightAlignException : GraphicsException
JScript | public class HeightAlignException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
HeightAlignException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
HeightAlignException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HeightAlignException.HeightAlignException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public HeightAlignException();
protected HeightAlignException(SerializationInfo, StreamingContext);
public HeightAlignException(string);
public HeightAlignException(string, Exception);


HeightAlignException.HeightAlignException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

HeightAlignException.HeightAlignException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected HeightAlignException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
HeightAlignException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function HeightAlignException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


HeightAlignException.HeightAlignException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

HeightAlignException.HeightAlignException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public HeightAlignException(
string message,
Exception inner
);
C++ public:
HeightAlignException(
String^ message,
Exception^ inner
);
JScript public function HeightAlignException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


HeightAlignException.HeightAlignException(String) Constructor (Microsoft.DirectX.DirectDraw)

HeightAlignException.HeightAlignException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public HeightAlignException(
string message
);
C++ public:
HeightAlignException(
String^ message
);
JScript public function HeightAlignException(
message : String
);

Parameters

message System.String


HeightAlignException.HeightAlignException() Constructor (Microsoft.DirectX.DirectDraw)

HeightAlignException.HeightAlignException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public HeightAlignException();
C++ public:
HeightAlignException();
JScript | public function HeightAlignException();


ImplicitlyCreatedException Class (Microsoft.DirectX.DirectDraw)

ImplicitlyCreatedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface cannot be restored because it is an implicitly created surface. Deprecated.

Definition

Visual Basic Public Class ImplicitlyCreatedException
Inherits GraphicsException
C# | public class ImplicitlyCreatedException : GraphicsException
C++ | public ref class ImplicitlyCreatedException : GraphicsException
JScript | public class ImplicitlyCreatedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ImplicitlyCreatedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
ImplicitlyCreatedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ImplicitlyCreatedException.ImplicitlyCreatedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ImplicitlyCreatedException();
protected ImplicitlyCreatedException(SerializationInfo, StreamingContext);
public ImplicitlyCreatedException(string);
public ImplicitlyCreatedException(string, Exception);


ImplicitlyCreatedException.ImplicitlyCreatedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ImplicitlyCreatedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ImplicitlyCreatedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ImplicitlyCreatedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ImplicitlyCreatedException.ImplicitlyCreatedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ImplicitlyCreatedException(
string message,
Exception inner
);
C++ public:
ImplicitlyCreatedException(
String^ message,
Exception^ inner
);
JScript public function ImplicitlyCreatedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ImplicitlyCreatedException.ImplicitlyCreatedException(String) Constructor (Microsoft.DirectX.DirectDraw)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ImplicitlyCreatedException(
string message
);
C++ public:
ImplicitlyCreatedException(
String^ message
);
JScript public function ImplicitlyCreatedException(
message : String
);

Parameters

message System.String


ImplicitlyCreatedException.ImplicitlyCreatedException() Constructor (Microsoft.DirectX.DirectDraw)

ImplicitlyCreatedException.ImplicitlyCreatedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ImplicitlyCreatedException();
C++ public:
ImplicitlyCreatedException();
JScript | public function ImplicitlyCreatedException();


IncompatiblePrimaryException Class (Microsoft.DirectX.DirectDraw)

IncompatiblePrimaryException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The primary surface creation request does not match the existing primary surface. Deprecated.

Definition

Visual Basic Public Class IncompatiblePrimaryException
Inherits GraphicsException
C# | public class IncompatiblePrimaryException : GraphicsException
C++ | public ref class IncompatiblePrimaryException : GraphicsException
JScript | public class IncompatiblePrimaryException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
IncompatiblePrimaryException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
IncompatiblePrimaryException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IncompatiblePrimaryException.IncompatiblePrimaryException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public IncompatiblePrimaryException();
protected IncompatiblePrimaryException(SerializationInfo, StreamingContext);
public IncompatiblePrimaryException(string);
public IncompatiblePrimaryException(string, Exception);


IncompatiblePrimaryException.IncompatiblePrimaryException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected IncompatiblePrimaryException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
IncompatiblePrimaryException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function IncompatiblePrimaryException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


IncompatiblePrimaryException.IncompatiblePrimaryException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public IncompatiblePrimaryException(
string message,
Exception inner
);
C++ public:
IncompatiblePrimaryException(
String^ message,
Exception^ inner
);
JScript public function IncompatiblePrimaryException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


IncompatiblePrimaryException.IncompatiblePrimaryException(String) Constructor (Microsoft.DirectX.DirectDraw)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public IncompatiblePrimaryException(
string message
);
C++ public:
IncompatiblePrimaryException(
String^ message
);
JScript public function IncompatiblePrimaryException(
message : String
);

Parameters

message System.String


IncompatiblePrimaryException.IncompatiblePrimaryException() Constructor (Microsoft.DirectX.DirectDraw)

IncompatiblePrimaryException.IncompatiblePrimaryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public IncompatiblePrimaryException();
C++ public:
IncompatiblePrimaryException();
JScript | public function IncompatiblePrimaryException();


InvalidCapsException Class (Microsoft.DirectX.DirectDraw)

InvalidCapsException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One or more of the capability bits passed to the callback function are incorrect. Deprecated.

Definition

Visual Basic Public Class InvalidCapsException
Inherits GraphicsException
C# | public class InvalidCapsException : GraphicsException
C++ | public ref class InvalidCapsException : GraphicsException
JScript | public class InvalidCapsException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidCapsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidCapsException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidCapsException.InvalidCapsException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidCapsException();
protected InvalidCapsException(SerializationInfo, StreamingContext);
public InvalidCapsException(string);
public InvalidCapsException(string, Exception);


InvalidCapsException.InvalidCapsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidCapsException.InvalidCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidCapsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidCapsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidCapsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidCapsException.InvalidCapsException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidCapsException.InvalidCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidCapsException(
string message,
Exception inner
);
C++ public:
InvalidCapsException(
String^ message,
Exception^ inner
);
JScript public function InvalidCapsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidCapsException.InvalidCapsException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidCapsException.InvalidCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidCapsException(
string message
);
C++ public:
InvalidCapsException(
String^ message
);
JScript public function InvalidCapsException(
message : String
);

Parameters

message System.String


InvalidCapsException.InvalidCapsException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidCapsException.InvalidCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidCapsException();
C++ public:
InvalidCapsException();
JScript | public function InvalidCapsException();


InvalidClipListException Class (Microsoft.DirectX.DirectDraw)

InvalidClipListException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not support the provided clip list. Deprecated.

Definition

Visual Basic Public Class InvalidClipListException
Inherits GraphicsException
C# | public class InvalidClipListException : GraphicsException
C++ | public ref class InvalidClipListException : GraphicsException
JScript | public class InvalidClipListException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidClipListException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidClipListException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidClipListException.InvalidClipListException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidClipListException();
protected InvalidClipListException(SerializationInfo, StreamingContext);
public InvalidClipListException(string);
public InvalidClipListException(string, Exception);


InvalidClipListException.InvalidClipListException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidClipListException.InvalidClipListException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidClipListException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidClipListException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidClipListException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidClipListException.InvalidClipListException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidClipListException.InvalidClipListException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidClipListException(
string message,
Exception inner
);
C++ public:
InvalidClipListException(
String^ message,
Exception^ inner
);
JScript public function InvalidClipListException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidClipListException.InvalidClipListException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidClipListException.InvalidClipListException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidClipListException(
string message
);
C++ public:
InvalidClipListException(
String^ message
);
JScript public function InvalidClipListException(
message : String
);

Parameters

message System.String


InvalidClipListException.InvalidClipListException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidClipListException.InvalidClipListException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidClipListException();
C++ public:
InvalidClipListException();
JScript | public function InvalidClipListException();


InvalidDirectDrawGuidException Class (Microsoft.DirectX.DirectDraw)

InvalidDirectDrawGuidException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The globally unique identifier (Guid) passed to the constructor is not a valid DirectDraw driver identifier. Deprecated.

Definition

Visual Basic Public Class InvalidDirectDrawGuidException
Inherits GraphicsException
C# | public class InvalidDirectDrawGuidException : GraphicsException
C++ | public ref class InvalidDirectDrawGuidException : GraphicsException
JScript | public class InvalidDirectDrawGuidException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDirectDrawGuidException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidDirectDrawGuidException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidDirectDrawGuidException();
protected InvalidDirectDrawGuidException(SerializationInfo, StreamingContext);
public InvalidDirectDrawGuidException(string);
public InvalidDirectDrawGuidException(string, Exception);


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDirectDrawGuidException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidDirectDrawGuidException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidDirectDrawGuidException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDirectDrawGuidException(
string message,
Exception inner
);
C++ public:
InvalidDirectDrawGuidException(
String^ message,
Exception^ inner
);
JScript public function InvalidDirectDrawGuidException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidDirectDrawGuidException(
string message
);
C++ public:
InvalidDirectDrawGuidException(
String^ message
);
JScript public function InvalidDirectDrawGuidException(
message : String
);

Parameters

message System.String


InvalidDirectDrawGuidException.InvalidDirectDrawGuidException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidDirectDrawGuidException.InvalidDirectDrawGuidException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidDirectDrawGuidException();
C++ public:
InvalidDirectDrawGuidException();
JScript | public function InvalidDirectDrawGuidException();


InvalidModeException Class (Microsoft.DirectX.DirectDraw)

InvalidModeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not support the requested mode. Deprecated.

Definition

Visual Basic Public Class InvalidModeException
Inherits GraphicsException
C# | public class InvalidModeException : GraphicsException
C++ | public ref class InvalidModeException : GraphicsException
JScript | public class InvalidModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidModeException.InvalidModeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidModeException();
protected InvalidModeException(SerializationInfo, StreamingContext);
public InvalidModeException(string);
public InvalidModeException(string, Exception);


InvalidModeException.InvalidModeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidModeException.InvalidModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidModeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidModeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidModeException.InvalidModeException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidModeException.InvalidModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidModeException(
string message,
Exception inner
);
C++ public:
InvalidModeException(
String^ message,
Exception^ inner
);
JScript public function InvalidModeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidModeException.InvalidModeException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidModeException.InvalidModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidModeException(
string message
);
C++ public:
InvalidModeException(
String^ message
);
JScript public function InvalidModeException(
message : String
);

Parameters

message System.String


InvalidModeException.InvalidModeException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidModeException.InvalidModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidModeException();
C++ public:
InvalidModeException();
JScript | public function InvalidModeException();


InvalidObjectException Class (Microsoft.DirectX.DirectDraw)

InvalidObjectException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw received a reference that was an invalid DirectDraw object. Deprecated.

Definition

Visual Basic Public Class InvalidObjectException
Inherits GraphicsException
C# | public class InvalidObjectException : GraphicsException
C++ | public ref class InvalidObjectException : GraphicsException
JScript | public class InvalidObjectException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidObjectException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidObjectException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidObjectException.InvalidObjectException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidObjectException();
protected InvalidObjectException(SerializationInfo, StreamingContext);
public InvalidObjectException(string);
public InvalidObjectException(string, Exception);


InvalidObjectException.InvalidObjectException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidObjectException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidObjectException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidObjectException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidObjectException.InvalidObjectException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidObjectException(
string message,
Exception inner
);
C++ public:
InvalidObjectException(
String^ message,
Exception^ inner
);
JScript public function InvalidObjectException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidObjectException.InvalidObjectException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidObjectException(
string message
);
C++ public:
InvalidObjectException(
String^ message
);
JScript public function InvalidObjectException(
message : String
);

Parameters

message System.String


InvalidObjectException.InvalidObjectException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidObjectException();
C++ public:
InvalidObjectException();
JScript | public function InvalidObjectException();


InvalidPixelFormatException Class (Microsoft.DirectX.DirectDraw)

InvalidPixelFormatException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format was invalid as specified. Deprecated.

Definition

Visual Basic Public Class InvalidPixelFormatException
Inherits GraphicsException
C# | public class InvalidPixelFormatException : GraphicsException
C++ | public ref class InvalidPixelFormatException : GraphicsException
JScript | public class InvalidPixelFormatException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPixelFormatException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidPixelFormatException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidPixelFormatException.InvalidPixelFormatException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPixelFormatException();
protected InvalidPixelFormatException(SerializationInfo, StreamingContext);
public InvalidPixelFormatException(string);
public InvalidPixelFormatException(string, Exception);


InvalidPixelFormatException.InvalidPixelFormatException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPixelFormatException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidPixelFormatException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidPixelFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidPixelFormatException.InvalidPixelFormatException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPixelFormatException(
string message,
Exception inner
);
C++ public:
InvalidPixelFormatException(
String^ message,
Exception^ inner
);
JScript public function InvalidPixelFormatException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidPixelFormatException.InvalidPixelFormatException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidPixelFormatException(
string message
);
C++ public:
InvalidPixelFormatException(
String^ message
);
JScript public function InvalidPixelFormatException(
message : String
);

Parameters

message System.String


InvalidPixelFormatException.InvalidPixelFormatException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidPixelFormatException.InvalidPixelFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidPixelFormatException();
C++ public:
InvalidPixelFormatException();
JScript | public function InvalidPixelFormatException();


InvalidPositionException Class (Microsoft.DirectX.DirectDraw)

InvalidPositionException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The position of the overlay on the destination is no longer legal. Deprecated.

Definition

Visual Basic Public Class InvalidPositionException
Inherits GraphicsException
C# | public class InvalidPositionException : GraphicsException
C++ | public ref class InvalidPositionException : GraphicsException
JScript | public class InvalidPositionException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPositionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidPositionException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidPositionException.InvalidPositionException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPositionException();
protected InvalidPositionException(SerializationInfo, StreamingContext);
public InvalidPositionException(string);
public InvalidPositionException(string, Exception);


InvalidPositionException.InvalidPositionException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidPositionException.InvalidPositionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPositionException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidPositionException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidPositionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidPositionException.InvalidPositionException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidPositionException.InvalidPositionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPositionException(
string message,
Exception inner
);
C++ public:
InvalidPositionException(
String^ message,
Exception^ inner
);
JScript public function InvalidPositionException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidPositionException.InvalidPositionException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidPositionException.InvalidPositionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidPositionException(
string message
);
C++ public:
InvalidPositionException(
String^ message
);
JScript public function InvalidPositionException(
message : String
);

Parameters

message System.String


InvalidPositionException.InvalidPositionException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidPositionException.InvalidPositionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidPositionException();
C++ public:
InvalidPositionException();
JScript | public function InvalidPositionException();


InvalidRectangleException Class (Microsoft.DirectX.DirectDraw)

InvalidRectangleException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The provided rectangle was invalid. Deprecated.

Definition

Visual Basic Public Class InvalidRectangleException
Inherits GraphicsException
C# | public class InvalidRectangleException : GraphicsException
C++ | public ref class InvalidRectangleException : GraphicsException
JScript | public class InvalidRectangleException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidRectangleException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidRectangleException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidRectangleException.InvalidRectangleException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidRectangleException();
protected InvalidRectangleException(SerializationInfo, StreamingContext);
public InvalidRectangleException(string);
public InvalidRectangleException(string, Exception);


InvalidRectangleException.InvalidRectangleException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidRectangleException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidRectangleException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidRectangleException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidRectangleException.InvalidRectangleException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidRectangleException(
string message,
Exception inner
);
C++ public:
InvalidRectangleException(
String^ message,
Exception^ inner
);
JScript public function InvalidRectangleException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidRectangleException.InvalidRectangleException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidRectangleException(
string message
);
C++ public:
InvalidRectangleException(
String^ message
);
JScript public function InvalidRectangleException(
message : String
);

Parameters

message System.String


InvalidRectangleException.InvalidRectangleException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidRectangleException.InvalidRectangleException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidRectangleException();
C++ public:
InvalidRectangleException();
JScript | public function InvalidRectangleException();


InvalidStreamException Class (Microsoft.DirectX.DirectDraw)

InvalidStreamException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified stream contains invalid data. Deprecated.

Definition

Visual Basic Public Class InvalidStreamException
Inherits GraphicsException
C# | public class InvalidStreamException : GraphicsException
C++ | public ref class InvalidStreamException : GraphicsException
JScript | public class InvalidStreamException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidStreamException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidStreamException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidStreamException.InvalidStreamException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidStreamException();
protected InvalidStreamException(SerializationInfo, StreamingContext);
public InvalidStreamException(string);
public InvalidStreamException(string, Exception);


InvalidStreamException.InvalidStreamException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidStreamException.InvalidStreamException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidStreamException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidStreamException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidStreamException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidStreamException.InvalidStreamException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidStreamException.InvalidStreamException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidStreamException(
string message,
Exception inner
);
C++ public:
InvalidStreamException(
String^ message,
Exception^ inner
);
JScript public function InvalidStreamException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidStreamException.InvalidStreamException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidStreamException.InvalidStreamException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidStreamException(
string message
);
C++ public:
InvalidStreamException(
String^ message
);
JScript public function InvalidStreamException(
message : String
);

Parameters

message System.String


InvalidStreamException.InvalidStreamException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidStreamException.InvalidStreamException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidStreamException();
C++ public:
InvalidStreamException();
JScript | public function InvalidStreamException();


InvalidSurfaceTypeException Class (Microsoft.DirectX.DirectDraw)

InvalidSurfaceTypeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface was of the wrong type. Deprecated.

Definition

Visual Basic Public Class InvalidSurfaceTypeException
Inherits GraphicsException
C# | public class InvalidSurfaceTypeException : GraphicsException
C++ | public ref class InvalidSurfaceTypeException : GraphicsException
JScript | public class InvalidSurfaceTypeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidSurfaceTypeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
InvalidSurfaceTypeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidSurfaceTypeException();
protected InvalidSurfaceTypeException(SerializationInfo, StreamingContext);
public InvalidSurfaceTypeException(string);
public InvalidSurfaceTypeException(string, Exception);


InvalidSurfaceTypeException.InvalidSurfaceTypeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidSurfaceTypeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidSurfaceTypeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidSurfaceTypeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidSurfaceTypeException.InvalidSurfaceTypeException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidSurfaceTypeException(
string message,
Exception inner
);
C++ public:
InvalidSurfaceTypeException(
String^ message,
Exception^ inner
);
JScript public function InvalidSurfaceTypeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidSurfaceTypeException.InvalidSurfaceTypeException(String) Constructor (Microsoft.DirectX.DirectDraw)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidSurfaceTypeException(
string message
);
C++ public:
InvalidSurfaceTypeException(
String^ message
);
JScript public function InvalidSurfaceTypeException(
message : String
);

Parameters

message System.String


InvalidSurfaceTypeException.InvalidSurfaceTypeException() Constructor (Microsoft.DirectX.DirectDraw)

InvalidSurfaceTypeException.InvalidSurfaceTypeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidSurfaceTypeException();
C++ public:
InvalidSurfaceTypeException();
JScript | public function InvalidSurfaceTypeException();


LockedSurfacesException Class (Microsoft.DirectX.DirectDraw)

LockedSurfacesException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One or more surfaces are locked, causing the failure of the requested operation. Deprecated.

Definition

Visual Basic Public Class LockedSurfacesException
Inherits GraphicsException
C# | public class LockedSurfacesException : GraphicsException
C++ | public ref class LockedSurfacesException : GraphicsException
JScript | public class LockedSurfacesException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
LockedSurfacesException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
LockedSurfacesException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LockedSurfacesException.LockedSurfacesException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public LockedSurfacesException();
protected LockedSurfacesException(SerializationInfo, StreamingContext);
public LockedSurfacesException(string);
public LockedSurfacesException(string, Exception);


LockedSurfacesException.LockedSurfacesException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

LockedSurfacesException.LockedSurfacesException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected LockedSurfacesException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
LockedSurfacesException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function LockedSurfacesException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


LockedSurfacesException.LockedSurfacesException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

LockedSurfacesException.LockedSurfacesException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public LockedSurfacesException(
string message,
Exception inner
);
C++ public:
LockedSurfacesException(
String^ message,
Exception^ inner
);
JScript public function LockedSurfacesException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


LockedSurfacesException.LockedSurfacesException(String) Constructor (Microsoft.DirectX.DirectDraw)

LockedSurfacesException.LockedSurfacesException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public LockedSurfacesException(
string message
);
C++ public:
LockedSurfacesException(
String^ message
);
JScript public function LockedSurfacesException(
message : String
);

Parameters

message System.String


LockedSurfacesException.LockedSurfacesException() Constructor (Microsoft.DirectX.DirectDraw)

LockedSurfacesException.LockedSurfacesException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public LockedSurfacesException();
C++ public:
LockedSurfacesException();
JScript | public function LockedSurfacesException();


MoreDataException Class (Microsoft.DirectX.DirectDraw)

MoreDataException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is more data available than the specified buffer size can hold. Deprecated.

Definition

Visual Basic Public Class MoreDataException
Inherits GraphicsException
C# | public class MoreDataException : GraphicsException
C++ | public ref class MoreDataException : GraphicsException
JScript | public class MoreDataException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
MoreDataException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
MoreDataException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MoreDataException.MoreDataException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public MoreDataException();
protected MoreDataException(SerializationInfo, StreamingContext);
public MoreDataException(string);
public MoreDataException(string, Exception);


MoreDataException.MoreDataException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

MoreDataException.MoreDataException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected MoreDataException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
MoreDataException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function MoreDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


MoreDataException.MoreDataException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

MoreDataException.MoreDataException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public MoreDataException(
string message,
Exception inner
);
C++ public:
MoreDataException(
String^ message,
Exception^ inner
);
JScript public function MoreDataException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


MoreDataException.MoreDataException(String) Constructor (Microsoft.DirectX.DirectDraw)

MoreDataException.MoreDataException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public MoreDataException(
string message
);
C++ public:
MoreDataException(
String^ message
);
JScript public function MoreDataException(
message : String
);

Parameters

message System.String


MoreDataException.MoreDataException() Constructor (Microsoft.DirectX.DirectDraw)

MoreDataException.MoreDataException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public MoreDataException();
C++ public:
MoreDataException();
JScript | public function MoreDataException();


NewModeException Class (Microsoft.DirectX.DirectDraw)

NewModeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When StartModeTest is called with the IsTestRequired flag, it may throw this exception to denote that some or all of the resolutions can and should be tested. EvaluateMode throws this exception to indicate that the test has switched to a new display mode. Deprecated.

Definition

Visual Basic Public Class NewModeException
Inherits GraphicsException
C# | public class NewModeException : GraphicsException
C++ | public ref class NewModeException : GraphicsException
JScript | public class NewModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NewModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NewModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NewModeException.NewModeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NewModeException();
protected NewModeException(SerializationInfo, StreamingContext);
public NewModeException(string);
public NewModeException(string, Exception);


NewModeException.NewModeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NewModeException.NewModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NewModeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NewModeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NewModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NewModeException.NewModeException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NewModeException.NewModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NewModeException(
string message,
Exception inner
);
C++ public:
NewModeException(
String^ message,
Exception^ inner
);
JScript public function NewModeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NewModeException.NewModeException(String) Constructor (Microsoft.DirectX.DirectDraw)

NewModeException.NewModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NewModeException(
string message
);
C++ public:
NewModeException(
String^ message
);
JScript public function NewModeException(
message : String
);

Parameters

message System.String


NewModeException.NewModeException() Constructor (Microsoft.DirectX.DirectDraw)

NewModeException.NewModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NewModeException();
C++ public:
NewModeException();
JScript | public function NewModeException();


NoAlphaHardwareException Class (Microsoft.DirectX.DirectDraw)

NoAlphaHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No alpha-acceleration hardware is present or available, causing the failure of the requested operation. Deprecated.

Definition

Visual Basic Public Class NoAlphaHardwareException
Inherits GraphicsException
C# | public class NoAlphaHardwareException : GraphicsException
C++ | public ref class NoAlphaHardwareException : GraphicsException
JScript | public class NoAlphaHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoAlphaHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoAlphaHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoAlphaHardwareException.NoAlphaHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoAlphaHardwareException();
protected NoAlphaHardwareException(SerializationInfo, StreamingContext);
public NoAlphaHardwareException(string);
public NoAlphaHardwareException(string, Exception);


NoAlphaHardwareException.NoAlphaHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoAlphaHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoAlphaHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoAlphaHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoAlphaHardwareException.NoAlphaHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoAlphaHardwareException(
string message,
Exception inner
);
C++ public:
NoAlphaHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoAlphaHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoAlphaHardwareException.NoAlphaHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoAlphaHardwareException(
string message
);
C++ public:
NoAlphaHardwareException(
String^ message
);
JScript public function NoAlphaHardwareException(
message : String
);

Parameters

message System.String


NoAlphaHardwareException.NoAlphaHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoAlphaHardwareException.NoAlphaHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoAlphaHardwareException();
C++ public:
NoAlphaHardwareException();
JScript | public function NoAlphaHardwareException();


NoClipListException Class (Microsoft.DirectX.DirectDraw)

NoClipListException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No clip list is available. Deprecated.

Definition

Visual Basic Public Class NoClipListException
Inherits GraphicsException
C# | public class NoClipListException : GraphicsException
C++ | public ref class NoClipListException : GraphicsException
JScript | public class NoClipListException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoClipListException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoClipListException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoClipListException.NoClipListException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoClipListException();
protected NoClipListException(SerializationInfo, StreamingContext);
public NoClipListException(string);
public NoClipListException(string, Exception);


NoClipListException.NoClipListException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoClipListException.NoClipListException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoClipListException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoClipListException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoClipListException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoClipListException.NoClipListException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoClipListException.NoClipListException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoClipListException(
string message,
Exception inner
);
C++ public:
NoClipListException(
String^ message,
Exception^ inner
);
JScript public function NoClipListException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoClipListException.NoClipListException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoClipListException.NoClipListException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoClipListException(
string message
);
C++ public:
NoClipListException(
String^ message
);
JScript public function NoClipListException(
message : String
);

Parameters

message System.String


NoClipListException.NoClipListException() Constructor (Microsoft.DirectX.DirectDraw)

NoClipListException.NoClipListException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoClipListException();
C++ public:
NoClipListException();
JScript | public function NoClipListException();


NoClipperAttachedException Class (Microsoft.DirectX.DirectDraw)

NoClipperAttachedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No DirectDrawClipper object is attached to the surface object. Deprecated.

Definition

Visual Basic Public Class NoClipperAttachedException
Inherits GraphicsException
C# | public class NoClipperAttachedException : GraphicsException
C++ | public ref class NoClipperAttachedException : GraphicsException
JScript | public class NoClipperAttachedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoClipperAttachedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoClipperAttachedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoClipperAttachedException.NoClipperAttachedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoClipperAttachedException();
protected NoClipperAttachedException(SerializationInfo, StreamingContext);
public NoClipperAttachedException(string);
public NoClipperAttachedException(string, Exception);


NoClipperAttachedException.NoClipperAttachedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoClipperAttachedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoClipperAttachedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoClipperAttachedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoClipperAttachedException.NoClipperAttachedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoClipperAttachedException(
string message,
Exception inner
);
C++ public:
NoClipperAttachedException(
String^ message,
Exception^ inner
);
JScript public function NoClipperAttachedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoClipperAttachedException.NoClipperAttachedException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoClipperAttachedException(
string message
);
C++ public:
NoClipperAttachedException(
String^ message
);
JScript public function NoClipperAttachedException(
message : String
);

Parameters

message System.String


NoClipperAttachedException.NoClipperAttachedException() Constructor (Microsoft.DirectX.DirectDraw)

NoClipperAttachedException.NoClipperAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoClipperAttachedException();
C++ public:
NoClipperAttachedException();
JScript | public function NoClipperAttachedException();


NoColorConversionHardwareException Class (Microsoft.DirectX.DirectDraw)

NoColorConversionHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No color-conversion hardware is present or available. Deprecated.

Definition

Visual Basic Public Class NoColorConversionHardwareException
Inherits GraphicsException
C# | public class NoColorConversionHardwareException : GraphicsException
C++ | public ref class NoColorConversionHardwareException : GraphicsException
JScript | public class NoColorConversionHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoColorConversionHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoColorConversionHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoColorConversionHardwareException.NoColorConversionHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoColorConversionHardwareException();
protected NoColorConversionHardwareException(SerializationInfo, StreamingContext);
public NoColorConversionHardwareException(string);
public NoColorConversionHardwareException(string, Exception);


NoColorConversionHardwareException.NoColorConversionHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoColorConversionHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoColorConversionHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoColorConversionHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoColorConversionHardwareException.NoColorConversionHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoColorConversionHardwareException(
string message,
Exception inner
);
C++ public:
NoColorConversionHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoColorConversionHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoColorConversionHardwareException.NoColorConversionHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoColorConversionHardwareException(
string message
);
C++ public:
NoColorConversionHardwareException(
String^ message
);
JScript public function NoColorConversionHardwareException(
message : String
);

Parameters

message System.String


NoColorConversionHardwareException.NoColorConversionHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoColorConversionHardwareException.NoColorConversionHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoColorConversionHardwareException();
C++ public:
NoColorConversionHardwareException();
JScript | public function NoColorConversionHardwareException();


NoColorKeyException Class (Microsoft.DirectX.DirectDraw)

NoColorKeyException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface does not currently have a color key. Deprecated.

Definition

Visual Basic Public Class NoColorKeyException
Inherits GraphicsException
C# | public class NoColorKeyException : GraphicsException
C++ | public ref class NoColorKeyException : GraphicsException
JScript | public class NoColorKeyException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoColorKeyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoColorKeyException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoColorKeyException.NoColorKeyException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoColorKeyException();
protected NoColorKeyException(SerializationInfo, StreamingContext);
public NoColorKeyException(string);
public NoColorKeyException(string, Exception);


NoColorKeyException.NoColorKeyException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoColorKeyException.NoColorKeyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoColorKeyException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoColorKeyException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoColorKeyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoColorKeyException.NoColorKeyException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoColorKeyException.NoColorKeyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoColorKeyException(
string message,
Exception inner
);
C++ public:
NoColorKeyException(
String^ message,
Exception^ inner
);
JScript public function NoColorKeyException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoColorKeyException.NoColorKeyException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoColorKeyException.NoColorKeyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoColorKeyException(
string message
);
C++ public:
NoColorKeyException(
String^ message
);
JScript public function NoColorKeyException(
message : String
);

Parameters

message System.String


NoColorKeyException.NoColorKeyException() Constructor (Microsoft.DirectX.DirectDraw)

NoColorKeyException.NoColorKeyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoColorKeyException();
C++ public:
NoColorKeyException();
JScript | public function NoColorKeyException();


NoColorKeyHardwareException Class (Microsoft.DirectX.DirectDraw)

NoColorKeyHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for the destination color key. Deprecated.

Definition

Visual Basic Public Class NoColorKeyHardwareException
Inherits GraphicsException
C# | public class NoColorKeyHardwareException : GraphicsException
C++ | public ref class NoColorKeyHardwareException : GraphicsException
JScript | public class NoColorKeyHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoColorKeyHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoColorKeyHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoColorKeyHardwareException.NoColorKeyHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoColorKeyHardwareException();
protected NoColorKeyHardwareException(SerializationInfo, StreamingContext);
public NoColorKeyHardwareException(string);
public NoColorKeyHardwareException(string, Exception);


NoColorKeyHardwareException.NoColorKeyHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoColorKeyHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoColorKeyHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoColorKeyHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoColorKeyHardwareException.NoColorKeyHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoColorKeyHardwareException(
string message,
Exception inner
);
C++ public:
NoColorKeyHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoColorKeyHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoColorKeyHardwareException.NoColorKeyHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoColorKeyHardwareException(
string message
);
C++ public:
NoColorKeyHardwareException(
String^ message
);
JScript public function NoColorKeyHardwareException(
message : String
);

Parameters

message System.String


NoColorKeyHardwareException.NoColorKeyHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoColorKeyHardwareException.NoColorKeyHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoColorKeyHardwareException();
C++ public:
NoColorKeyHardwareException();
JScript | public function NoColorKeyHardwareException();


NoCooperativeLevelSetException Class (Microsoft.DirectX.DirectDraw)

NoCooperativeLevelSetException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A create function was called without the SetCooperativeLevel method. Deprecated.

Definition

Visual Basic Public Class NoCooperativeLevelSetException
Inherits GraphicsException
C# | public class NoCooperativeLevelSetException : GraphicsException
C++ | public ref class NoCooperativeLevelSetException : GraphicsException
JScript | public class NoCooperativeLevelSetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoCooperativeLevelSetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoCooperativeLevelSetException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoCooperativeLevelSetException();
protected NoCooperativeLevelSetException(SerializationInfo, StreamingContext);
public NoCooperativeLevelSetException(string);
public NoCooperativeLevelSetException(string, Exception);


NoCooperativeLevelSetException.NoCooperativeLevelSetException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoCooperativeLevelSetException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoCooperativeLevelSetException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoCooperativeLevelSetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoCooperativeLevelSetException.NoCooperativeLevelSetException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoCooperativeLevelSetException(
string message,
Exception inner
);
C++ public:
NoCooperativeLevelSetException(
String^ message,
Exception^ inner
);
JScript public function NoCooperativeLevelSetException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoCooperativeLevelSetException.NoCooperativeLevelSetException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoCooperativeLevelSetException(
string message
);
C++ public:
NoCooperativeLevelSetException(
String^ message
);
JScript public function NoCooperativeLevelSetException(
message : String
);

Parameters

message System.String


NoCooperativeLevelSetException.NoCooperativeLevelSetException() Constructor (Microsoft.DirectX.DirectDraw)

NoCooperativeLevelSetException.NoCooperativeLevelSetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoCooperativeLevelSetException();
C++ public:
NoCooperativeLevelSetException();
JScript | public function NoCooperativeLevelSetException();


NoDeviceContextException Class (Microsoft.DirectX.DirectDraw)

NoDeviceContextException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No device context (DC) has ever been created for this surface. Deprecated.

Definition

Visual Basic Public Class NoDeviceContextException
Inherits GraphicsException
C# | public class NoDeviceContextException : GraphicsException
C++ | public ref class NoDeviceContextException : GraphicsException
JScript | public class NoDeviceContextException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDeviceContextException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDeviceContextException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoDeviceContextException.NoDeviceContextException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDeviceContextException();
protected NoDeviceContextException(SerializationInfo, StreamingContext);
public NoDeviceContextException(string);
public NoDeviceContextException(string, Exception);


NoDeviceContextException.NoDeviceContextException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDeviceContextException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoDeviceContextException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoDeviceContextException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoDeviceContextException.NoDeviceContextException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDeviceContextException(
string message,
Exception inner
);
C++ public:
NoDeviceContextException(
String^ message,
Exception^ inner
);
JScript public function NoDeviceContextException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoDeviceContextException.NoDeviceContextException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoDeviceContextException(
string message
);
C++ public:
NoDeviceContextException(
String^ message
);
JScript public function NoDeviceContextException(
message : String
);

Parameters

message System.String


NoDeviceContextException.NoDeviceContextException() Constructor (Microsoft.DirectX.DirectDraw)

NoDeviceContextException.NoDeviceContextException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoDeviceContextException();
C++ public:
NoDeviceContextException();
JScript | public function NoDeviceContextException();


NoDirectDrawHardwareException Class (Microsoft.DirectX.DirectDraw)

NoDirectDrawHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware-only DirectDraw object creation is not possible; the driver does not support any hardware. Deprecated.

Definition

Visual Basic Public Class NoDirectDrawHardwareException
Inherits GraphicsException
C# | public class NoDirectDrawHardwareException : GraphicsException
C++ | public ref class NoDirectDrawHardwareException : GraphicsException
JScript | public class NoDirectDrawHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDirectDrawHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDirectDrawHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDirectDrawHardwareException();
protected NoDirectDrawHardwareException(SerializationInfo, StreamingContext);
public NoDirectDrawHardwareException(string);
public NoDirectDrawHardwareException(string, Exception);


NoDirectDrawHardwareException.NoDirectDrawHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDirectDrawHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoDirectDrawHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoDirectDrawHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoDirectDrawHardwareException.NoDirectDrawHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDirectDrawHardwareException(
string message,
Exception inner
);
C++ public:
NoDirectDrawHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoDirectDrawHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoDirectDrawHardwareException.NoDirectDrawHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoDirectDrawHardwareException(
string message
);
C++ public:
NoDirectDrawHardwareException(
String^ message
);
JScript public function NoDirectDrawHardwareException(
message : String
);

Parameters

message System.String


NoDirectDrawHardwareException.NoDirectDrawHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoDirectDrawHardwareException.NoDirectDrawHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoDirectDrawHardwareException();
C++ public:
NoDirectDrawHardwareException();
JScript | public function NoDirectDrawHardwareException();


NoDirectDrawSupportException Class (Microsoft.DirectX.DirectDraw)

NoDirectDrawSupportException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw support is not possible with the current display driver. Deprecated.

Definition

Visual Basic Public Class NoDirectDrawSupportException
Inherits GraphicsException
C# | public class NoDirectDrawSupportException : GraphicsException
C++ | public ref class NoDirectDrawSupportException : GraphicsException
JScript | public class NoDirectDrawSupportException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDirectDrawSupportException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDirectDrawSupportException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoDirectDrawSupportException.NoDirectDrawSupportException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDirectDrawSupportException();
protected NoDirectDrawSupportException(SerializationInfo, StreamingContext);
public NoDirectDrawSupportException(string);
public NoDirectDrawSupportException(string, Exception);


NoDirectDrawSupportException.NoDirectDrawSupportException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDirectDrawSupportException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoDirectDrawSupportException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoDirectDrawSupportException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoDirectDrawSupportException.NoDirectDrawSupportException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDirectDrawSupportException(
string message,
Exception inner
);
C++ public:
NoDirectDrawSupportException(
String^ message,
Exception^ inner
);
JScript public function NoDirectDrawSupportException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoDirectDrawSupportException.NoDirectDrawSupportException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoDirectDrawSupportException(
string message
);
C++ public:
NoDirectDrawSupportException(
String^ message
);
JScript public function NoDirectDrawSupportException(
message : String
);

Parameters

message System.String


NoDirectDrawSupportException.NoDirectDrawSupportException() Constructor (Microsoft.DirectX.DirectDraw)

NoDirectDrawSupportException.NoDirectDrawSupportException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoDirectDrawSupportException();
C++ public:
NoDirectDrawSupportException();
JScript | public function NoDirectDrawSupportException();


NoDrawHardwareException Class (Microsoft.DirectX.DirectDraw)

NoDrawHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No blitter hardware is present. Deprecated.

Definition

Visual Basic Public Class NoDrawHardwareException
Inherits GraphicsException
C# | public class NoDrawHardwareException : GraphicsException
C++ | public ref class NoDrawHardwareException : GraphicsException
JScript | public class NoDrawHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDrawHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDrawHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoDrawHardwareException.NoDrawHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDrawHardwareException();
protected NoDrawHardwareException(SerializationInfo, StreamingContext);
public NoDrawHardwareException(string);
public NoDrawHardwareException(string, Exception);


NoDrawHardwareException.NoDrawHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoDrawHardwareException.NoDrawHardwareException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDrawHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoDrawHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoDrawHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoDrawHardwareException.NoDrawHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoDrawHardwareException.NoDrawHardwareException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDrawHardwareException(
string message,
Exception inner
);
C++ public:
NoDrawHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoDrawHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoDrawHardwareException.NoDrawHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoDrawHardwareException.NoDrawHardwareException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoDrawHardwareException(
string message
);
C++ public:
NoDrawHardwareException(
String^ message
);
JScript public function NoDrawHardwareException(
message : String
);

Parameters

message System.String


NoDrawHardwareException.NoDrawHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoDrawHardwareException.NoDrawHardwareException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoDrawHardwareException();
C++ public:
NoDrawHardwareException();
JScript | public function NoDrawHardwareException();


NoDriverSupportException Class (Microsoft.DirectX.DirectDraw)

NoDriverSupportException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Testing cannot proceed because the display adapter driver does not enumerate refresh rates. Deprecated.

Definition

Visual Basic Public Class NoDriverSupportException
Inherits GraphicsException
C# | public class NoDriverSupportException : GraphicsException
C++ | public ref class NoDriverSupportException : GraphicsException
JScript | public class NoDriverSupportException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDriverSupportException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoDriverSupportException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoDriverSupportException.NoDriverSupportException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoDriverSupportException();
protected NoDriverSupportException(SerializationInfo, StreamingContext);
public NoDriverSupportException(string);
public NoDriverSupportException(string, Exception);


NoDriverSupportException.NoDriverSupportException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDriverSupportException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoDriverSupportException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoDriverSupportException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoDriverSupportException.NoDriverSupportException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDriverSupportException(
string message,
Exception inner
);
C++ public:
NoDriverSupportException(
String^ message,
Exception^ inner
);
JScript public function NoDriverSupportException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoDriverSupportException.NoDriverSupportException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoDriverSupportException(
string message
);
C++ public:
NoDriverSupportException(
String^ message
);
JScript public function NoDriverSupportException(
message : String
);

Parameters

message System.String


NoDriverSupportException.NoDriverSupportException() Constructor (Microsoft.DirectX.DirectDraw)

NoDriverSupportException.NoDriverSupportException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoDriverSupportException();
C++ public:
NoDriverSupportException();
JScript | public function NoDriverSupportException();


NoEmulationException Class (Microsoft.DirectX.DirectDraw)

NoEmulationException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Software emulation is not available. Deprecated.

Definition

Visual Basic Public Class NoEmulationException
Inherits GraphicsException
C# | public class NoEmulationException : GraphicsException
C++ | public ref class NoEmulationException : GraphicsException
JScript | public class NoEmulationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoEmulationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoEmulationException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoEmulationException.NoEmulationException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoEmulationException();
protected NoEmulationException(SerializationInfo, StreamingContext);
public NoEmulationException(string);
public NoEmulationException(string, Exception);


NoEmulationException.NoEmulationException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoEmulationException.NoEmulationException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoEmulationException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoEmulationException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoEmulationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoEmulationException.NoEmulationException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoEmulationException.NoEmulationException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoEmulationException(
string message,
Exception inner
);
C++ public:
NoEmulationException(
String^ message,
Exception^ inner
);
JScript public function NoEmulationException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoEmulationException.NoEmulationException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoEmulationException.NoEmulationException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoEmulationException(
string message
);
C++ public:
NoEmulationException(
String^ message
);
JScript public function NoEmulationException(
message : String
);

Parameters

message System.String


NoEmulationException.NoEmulationException() Constructor (Microsoft.DirectX.DirectDraw)

NoEmulationException.NoEmulationException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoEmulationException();
C++ public:
NoEmulationException();
JScript | public function NoEmulationException();


NoExclusiveModeException Class (Microsoft.DirectX.DirectDraw)

NoExclusiveModeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation requires the application to have exclusive mode, but the application does not have exclusive mode. Deprecated.

Definition

Visual Basic Public Class NoExclusiveModeException
Inherits GraphicsException
C# | public class NoExclusiveModeException : GraphicsException
C++ | public ref class NoExclusiveModeException : GraphicsException
JScript | public class NoExclusiveModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoExclusiveModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoExclusiveModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoExclusiveModeException.NoExclusiveModeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoExclusiveModeException();
protected NoExclusiveModeException(SerializationInfo, StreamingContext);
public NoExclusiveModeException(string);
public NoExclusiveModeException(string, Exception);


NoExclusiveModeException.NoExclusiveModeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoExclusiveModeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoExclusiveModeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoExclusiveModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoExclusiveModeException.NoExclusiveModeException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoExclusiveModeException(
string message,
Exception inner
);
C++ public:
NoExclusiveModeException(
String^ message,
Exception^ inner
);
JScript public function NoExclusiveModeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoExclusiveModeException.NoExclusiveModeException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoExclusiveModeException(
string message
);
C++ public:
NoExclusiveModeException(
String^ message
);
JScript public function NoExclusiveModeException(
message : String
);

Parameters

message System.String


NoExclusiveModeException.NoExclusiveModeException() Constructor (Microsoft.DirectX.DirectDraw)

NoExclusiveModeException.NoExclusiveModeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoExclusiveModeException();
C++ public:
NoExclusiveModeException();
JScript | public function NoExclusiveModeException();


NoFlipHardwareException Class (Microsoft.DirectX.DirectDraw)

NoFlipHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flipping visible surfaces is not supported. Deprecated.

Definition

Visual Basic Public Class NoFlipHardwareException
Inherits GraphicsException
C# | public class NoFlipHardwareException : GraphicsException
C++ | public ref class NoFlipHardwareException : GraphicsException
JScript | public class NoFlipHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoFlipHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoFlipHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoFlipHardwareException.NoFlipHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoFlipHardwareException();
protected NoFlipHardwareException(SerializationInfo, StreamingContext);
public NoFlipHardwareException(string);
public NoFlipHardwareException(string, Exception);


NoFlipHardwareException.NoFlipHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoFlipHardwareException.NoFlipHardwareException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoFlipHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoFlipHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoFlipHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoFlipHardwareException.NoFlipHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoFlipHardwareException.NoFlipHardwareException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoFlipHardwareException(
string message,
Exception inner
);
C++ public:
NoFlipHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoFlipHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoFlipHardwareException.NoFlipHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoFlipHardwareException.NoFlipHardwareException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoFlipHardwareException(
string message
);
C++ public:
NoFlipHardwareException(
String^ message
);
JScript public function NoFlipHardwareException(
message : String
);

Parameters

message System.String


NoFlipHardwareException.NoFlipHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoFlipHardwareException.NoFlipHardwareException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoFlipHardwareException();
C++ public:
NoFlipHardwareException();
JScript | public function NoFlipHardwareException();


NoFocusWindowException Class (Microsoft.DirectX.DirectDraw)

NoFocusWindowException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to create or set a device window without first setting the focus window. Deprecated.

Definition

Visual Basic Public Class NoFocusWindowException
Inherits GraphicsException
C# | public class NoFocusWindowException : GraphicsException
C++ | public ref class NoFocusWindowException : GraphicsException
JScript | public class NoFocusWindowException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoFocusWindowException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoFocusWindowException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoFocusWindowException.NoFocusWindowException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoFocusWindowException();
protected NoFocusWindowException(SerializationInfo, StreamingContext);
public NoFocusWindowException(string);
public NoFocusWindowException(string, Exception);


NoFocusWindowException.NoFocusWindowException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoFocusWindowException.NoFocusWindowException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoFocusWindowException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoFocusWindowException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoFocusWindowException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoFocusWindowException.NoFocusWindowException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoFocusWindowException.NoFocusWindowException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoFocusWindowException(
string message,
Exception inner
);
C++ public:
NoFocusWindowException(
String^ message,
Exception^ inner
);
JScript public function NoFocusWindowException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoFocusWindowException.NoFocusWindowException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoFocusWindowException.NoFocusWindowException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoFocusWindowException(
string message
);
C++ public:
NoFocusWindowException(
String^ message
);
JScript public function NoFocusWindowException(
message : String
);

Parameters

message System.String


NoFocusWindowException.NoFocusWindowException() Constructor (Microsoft.DirectX.DirectDraw)

NoFocusWindowException.NoFocusWindowException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoFocusWindowException();
C++ public:
NoFocusWindowException();
JScript | public function NoFocusWindowException();


NoGdiException Class (Microsoft.DirectX.DirectDraw)

NoGdiException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No GDI is present. Deprecated.

Definition

Visual Basic Public Class NoGdiException
Inherits GraphicsException
C# | public class NoGdiException : GraphicsException
C++ | public ref class NoGdiException : GraphicsException
JScript | public class NoGdiException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoGdiException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoGdiException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoGdiException.NoGdiException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoGdiException();
protected NoGdiException(SerializationInfo, StreamingContext);
public NoGdiException(string);
public NoGdiException(string, Exception);


NoGdiException.NoGdiException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoGdiException.NoGdiException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoGdiException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoGdiException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoGdiException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoGdiException.NoGdiException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoGdiException.NoGdiException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoGdiException(
string message,
Exception inner
);
C++ public:
NoGdiException(
String^ message,
Exception^ inner
);
JScript public function NoGdiException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoGdiException.NoGdiException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoGdiException.NoGdiException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoGdiException(
string message
);
C++ public:
NoGdiException(
String^ message
);
JScript public function NoGdiException(
message : String
);

Parameters

message System.String


NoGdiException.NoGdiException() Constructor (Microsoft.DirectX.DirectDraw)

NoGdiException.NoGdiException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoGdiException();
C++ public:
NoGdiException();
JScript | public function NoGdiException();


NoMirrorHardwareException Class (Microsoft.DirectX.DirectDraw)

NoMirrorHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No mirroring hardware is present or available. Deprecated.

Definition

Visual Basic Public Class NoMirrorHardwareException
Inherits GraphicsException
C# | public class NoMirrorHardwareException : GraphicsException
C++ | public ref class NoMirrorHardwareException : GraphicsException
JScript | public class NoMirrorHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoMirrorHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoMirrorHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoMirrorHardwareException.NoMirrorHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoMirrorHardwareException();
protected NoMirrorHardwareException(SerializationInfo, StreamingContext);
public NoMirrorHardwareException(string);
public NoMirrorHardwareException(string, Exception);


NoMirrorHardwareException.NoMirrorHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoMirrorHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoMirrorHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoMirrorHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoMirrorHardwareException.NoMirrorHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoMirrorHardwareException(
string message,
Exception inner
);
C++ public:
NoMirrorHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoMirrorHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoMirrorHardwareException.NoMirrorHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoMirrorHardwareException(
string message
);
C++ public:
NoMirrorHardwareException(
String^ message
);
JScript public function NoMirrorHardwareException(
message : String
);

Parameters

message System.String


NoMirrorHardwareException.NoMirrorHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoMirrorHardwareException.NoMirrorHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoMirrorHardwareException();
C++ public:
NoMirrorHardwareException();
JScript | public function NoMirrorHardwareException();


NoMonitorInformationException Class (Microsoft.DirectX.DirectDraw)

NoMonitorInformationException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Testing cannot proceed because the monitor has no associated EDID data. Deprecated.

Definition

Visual Basic Public Class NoMonitorInformationException
Inherits GraphicsException
C# | public class NoMonitorInformationException : GraphicsException
C++ | public ref class NoMonitorInformationException : GraphicsException
JScript | public class NoMonitorInformationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoMonitorInformationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoMonitorInformationException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoMonitorInformationException.NoMonitorInformationException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoMonitorInformationException();
protected NoMonitorInformationException(SerializationInfo, StreamingContext);
public NoMonitorInformationException(string);
public NoMonitorInformationException(string, Exception);


NoMonitorInformationException.NoMonitorInformationException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoMonitorInformationException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoMonitorInformationException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoMonitorInformationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoMonitorInformationException.NoMonitorInformationException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoMonitorInformationException(
string message,
Exception inner
);
C++ public:
NoMonitorInformationException(
String^ message,
Exception^ inner
);
JScript public function NoMonitorInformationException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoMonitorInformationException.NoMonitorInformationException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoMonitorInformationException(
string message
);
C++ public:
NoMonitorInformationException(
String^ message
);
JScript public function NoMonitorInformationException(
message : String
);

Parameters

message System.String


NoMonitorInformationException.NoMonitorInformationException() Constructor (Microsoft.DirectX.DirectDraw)

NoMonitorInformationException.NoMonitorInformationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoMonitorInformationException();
C++ public:
NoMonitorInformationException();
JScript | public function NoMonitorInformationException();


NoNonLocalVideoMemoryException Class (Microsoft.DirectX.DirectDraw)

NoNonLocalVideoMemoryException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to allocate nonlocal video memory from a device that does not support nonlocal video memory. Deprecated.

Definition

Visual Basic Public Class NoNonLocalVideoMemoryException
Inherits GraphicsException
C# | public class NoNonLocalVideoMemoryException : GraphicsException
C++ | public ref class NoNonLocalVideoMemoryException : GraphicsException
JScript | public class NoNonLocalVideoMemoryException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoNonLocalVideoMemoryException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoNonLocalVideoMemoryException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoNonLocalVideoMemoryException();
protected NoNonLocalVideoMemoryException(SerializationInfo, StreamingContext);
public NoNonLocalVideoMemoryException(string);
public NoNonLocalVideoMemoryException(string, Exception);


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoNonLocalVideoMemoryException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoNonLocalVideoMemoryException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoNonLocalVideoMemoryException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoNonLocalVideoMemoryException(
string message,
Exception inner
);
C++ public:
NoNonLocalVideoMemoryException(
String^ message,
Exception^ inner
);
JScript public function NoNonLocalVideoMemoryException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoNonLocalVideoMemoryException(
string message
);
C++ public:
NoNonLocalVideoMemoryException(
String^ message
);
JScript public function NoNonLocalVideoMemoryException(
message : String
);

Parameters

message System.String


NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException() Constructor (Microsoft.DirectX.DirectDraw)

NoNonLocalVideoMemoryException.NoNonLocalVideoMemoryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoNonLocalVideoMemoryException();
C++ public:
NoNonLocalVideoMemoryException();
JScript | public function NoNonLocalVideoMemoryException();


NoOptimizeHardwareException Class (Microsoft.DirectX.DirectDraw)

NoOptimizeHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The device does not support optimized surfaces. Deprecated.

Definition

Visual Basic Public Class NoOptimizeHardwareException
Inherits GraphicsException
C# | public class NoOptimizeHardwareException : GraphicsException
C++ | public ref class NoOptimizeHardwareException : GraphicsException
JScript | public class NoOptimizeHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoOptimizeHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoOptimizeHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoOptimizeHardwareException.NoOptimizeHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoOptimizeHardwareException();
protected NoOptimizeHardwareException(SerializationInfo, StreamingContext);
public NoOptimizeHardwareException(string);
public NoOptimizeHardwareException(string, Exception);


NoOptimizeHardwareException.NoOptimizeHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoOptimizeHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoOptimizeHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoOptimizeHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoOptimizeHardwareException.NoOptimizeHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoOptimizeHardwareException(
string message,
Exception inner
);
C++ public:
NoOptimizeHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoOptimizeHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoOptimizeHardwareException.NoOptimizeHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoOptimizeHardwareException(
string message
);
C++ public:
NoOptimizeHardwareException(
String^ message
);
JScript public function NoOptimizeHardwareException(
message : String
);

Parameters

message System.String


NoOptimizeHardwareException.NoOptimizeHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoOptimizeHardwareException.NoOptimizeHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoOptimizeHardwareException();
C++ public:
NoOptimizeHardwareException();
JScript | public function NoOptimizeHardwareException();


NoOverlayDestinationException Class (Microsoft.DirectX.DirectDraw)

NoOverlayDestinationException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The GetOverlayPosition method is called on an overlay that the UpdateOverlay method has not been called on to establish as a destination. Deprecated.

Definition

Visual Basic Public Class NoOverlayDestinationException
Inherits GraphicsException
C# | public class NoOverlayDestinationException : GraphicsException
C++ | public ref class NoOverlayDestinationException : GraphicsException
JScript | public class NoOverlayDestinationException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoOverlayDestinationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoOverlayDestinationException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoOverlayDestinationException.NoOverlayDestinationException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoOverlayDestinationException();
protected NoOverlayDestinationException(SerializationInfo, StreamingContext);
public NoOverlayDestinationException(string);
public NoOverlayDestinationException(string, Exception);


NoOverlayDestinationException.NoOverlayDestinationException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoOverlayDestinationException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoOverlayDestinationException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoOverlayDestinationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoOverlayDestinationException.NoOverlayDestinationException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoOverlayDestinationException(
string message,
Exception inner
);
C++ public:
NoOverlayDestinationException(
String^ message,
Exception^ inner
);
JScript public function NoOverlayDestinationException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoOverlayDestinationException.NoOverlayDestinationException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoOverlayDestinationException(
string message
);
C++ public:
NoOverlayDestinationException(
String^ message
);
JScript public function NoOverlayDestinationException(
message : String
);

Parameters

message System.String


NoOverlayDestinationException.NoOverlayDestinationException() Constructor (Microsoft.DirectX.DirectDraw)

NoOverlayDestinationException.NoOverlayDestinationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoOverlayDestinationException();
C++ public:
NoOverlayDestinationException();
JScript | public function NoOverlayDestinationException();


NoOverlayHardwareException Class (Microsoft.DirectX.DirectDraw)

NoOverlayHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No overlay hardware is present or available. Deprecated.

Definition

Visual Basic Public Class NoOverlayHardwareException
Inherits GraphicsException
C# | public class NoOverlayHardwareException : GraphicsException
C++ | public ref class NoOverlayHardwareException : GraphicsException
JScript | public class NoOverlayHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoOverlayHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoOverlayHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoOverlayHardwareException.NoOverlayHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoOverlayHardwareException();
protected NoOverlayHardwareException(SerializationInfo, StreamingContext);
public NoOverlayHardwareException(string);
public NoOverlayHardwareException(string, Exception);


NoOverlayHardwareException.NoOverlayHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoOverlayHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoOverlayHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoOverlayHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoOverlayHardwareException.NoOverlayHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoOverlayHardwareException(
string message,
Exception inner
);
C++ public:
NoOverlayHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoOverlayHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoOverlayHardwareException.NoOverlayHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoOverlayHardwareException(
string message
);
C++ public:
NoOverlayHardwareException(
String^ message
);
JScript public function NoOverlayHardwareException(
message : String
);

Parameters

message System.String


NoOverlayHardwareException.NoOverlayHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoOverlayHardwareException.NoOverlayHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoOverlayHardwareException();
C++ public:
NoOverlayHardwareException();
JScript | public function NoOverlayHardwareException();


NoPaletteAttachedException Class (Microsoft.DirectX.DirectDraw)

NoPaletteAttachedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No palette object is attached to this surface. Deprecated.

Definition

Visual Basic Public Class NoPaletteAttachedException
Inherits GraphicsException
C# | public class NoPaletteAttachedException : GraphicsException
C++ | public ref class NoPaletteAttachedException : GraphicsException
JScript | public class NoPaletteAttachedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoPaletteAttachedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoPaletteAttachedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoPaletteAttachedException.NoPaletteAttachedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoPaletteAttachedException();
protected NoPaletteAttachedException(SerializationInfo, StreamingContext);
public NoPaletteAttachedException(string);
public NoPaletteAttachedException(string, Exception);


NoPaletteAttachedException.NoPaletteAttachedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoPaletteAttachedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoPaletteAttachedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoPaletteAttachedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoPaletteAttachedException.NoPaletteAttachedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoPaletteAttachedException(
string message,
Exception inner
);
C++ public:
NoPaletteAttachedException(
String^ message,
Exception^ inner
);
JScript public function NoPaletteAttachedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoPaletteAttachedException.NoPaletteAttachedException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoPaletteAttachedException(
string message
);
C++ public:
NoPaletteAttachedException(
String^ message
);
JScript public function NoPaletteAttachedException(
message : String
);

Parameters

message System.String


NoPaletteAttachedException.NoPaletteAttachedException() Constructor (Microsoft.DirectX.DirectDraw)

NoPaletteAttachedException.NoPaletteAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoPaletteAttachedException();
C++ public:
NoPaletteAttachedException();
JScript | public function NoPaletteAttachedException();


NoPaletteHardwareException Class (Microsoft.DirectX.DirectDraw)

NoPaletteHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for 16- or 256-color palettes. Deprecated.

Definition

Visual Basic Public Class NoPaletteHardwareException
Inherits GraphicsException
C# | public class NoPaletteHardwareException : GraphicsException
C++ | public ref class NoPaletteHardwareException : GraphicsException
JScript | public class NoPaletteHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoPaletteHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoPaletteHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoPaletteHardwareException.NoPaletteHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoPaletteHardwareException();
protected NoPaletteHardwareException(SerializationInfo, StreamingContext);
public NoPaletteHardwareException(string);
public NoPaletteHardwareException(string, Exception);


NoPaletteHardwareException.NoPaletteHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoPaletteHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoPaletteHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoPaletteHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoPaletteHardwareException.NoPaletteHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoPaletteHardwareException(
string message,
Exception inner
);
C++ public:
NoPaletteHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoPaletteHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoPaletteHardwareException.NoPaletteHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoPaletteHardwareException(
string message
);
C++ public:
NoPaletteHardwareException(
String^ message
);
JScript public function NoPaletteHardwareException(
message : String
);

Parameters

message System.String


NoPaletteHardwareException.NoPaletteHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoPaletteHardwareException.NoPaletteHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoPaletteHardwareException();
C++ public:
NoPaletteHardwareException();
JScript | public function NoPaletteHardwareException();


NoRasterOperationHardwareException Class (Microsoft.DirectX.DirectDraw)

NoRasterOperationHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No appropriate raster-operation hardware is present or available. Deprecated.

Definition

Visual Basic Public Class NoRasterOperationHardwareException
Inherits GraphicsException
C# | public class NoRasterOperationHardwareException : GraphicsException
C++ | public ref class NoRasterOperationHardwareException : GraphicsException
JScript | public class NoRasterOperationHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoRasterOperationHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoRasterOperationHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoRasterOperationHardwareException();
protected NoRasterOperationHardwareException(SerializationInfo, StreamingContext);
public NoRasterOperationHardwareException(string);
public NoRasterOperationHardwareException(string, Exception);


NoRasterOperationHardwareException.NoRasterOperationHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoRasterOperationHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoRasterOperationHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoRasterOperationHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoRasterOperationHardwareException.NoRasterOperationHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoRasterOperationHardwareException(
string message,
Exception inner
);
C++ public:
NoRasterOperationHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoRasterOperationHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoRasterOperationHardwareException.NoRasterOperationHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoRasterOperationHardwareException(
string message
);
C++ public:
NoRasterOperationHardwareException(
String^ message
);
JScript public function NoRasterOperationHardwareException(
message : String
);

Parameters

message System.String


NoRasterOperationHardwareException.NoRasterOperationHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoRasterOperationHardwareException.NoRasterOperationHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoRasterOperationHardwareException();
C++ public:
NoRasterOperationHardwareException();
JScript | public function NoRasterOperationHardwareException();


NoRotationHardwareException Class (Microsoft.DirectX.DirectDraw)

NoRotationHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No rotation hardware is present or available. Deprecated.

Definition

Visual Basic Public Class NoRotationHardwareException
Inherits GraphicsException
C# | public class NoRotationHardwareException : GraphicsException
C++ | public ref class NoRotationHardwareException : GraphicsException
JScript | public class NoRotationHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoRotationHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoRotationHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoRotationHardwareException.NoRotationHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoRotationHardwareException();
protected NoRotationHardwareException(SerializationInfo, StreamingContext);
public NoRotationHardwareException(string);
public NoRotationHardwareException(string, Exception);


NoRotationHardwareException.NoRotationHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoRotationHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoRotationHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoRotationHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoRotationHardwareException.NoRotationHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoRotationHardwareException(
string message,
Exception inner
);
C++ public:
NoRotationHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoRotationHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoRotationHardwareException.NoRotationHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoRotationHardwareException(
string message
);
C++ public:
NoRotationHardwareException(
String^ message
);
JScript public function NoRotationHardwareException(
message : String
);

Parameters

message System.String


NoRotationHardwareException.NoRotationHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoRotationHardwareException.NoRotationHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoRotationHardwareException();
C++ public:
NoRotationHardwareException();
JScript | public function NoRotationHardwareException();


NoStereoHardwareException Class (Microsoft.DirectX.DirectDraw)

NoStereoHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no stereo hardware present or available. Deprecated.

Definition

Visual Basic Public Class NoStereoHardwareException
Inherits GraphicsException
C# | public class NoStereoHardwareException : GraphicsException
C++ | public ref class NoStereoHardwareException : GraphicsException
JScript | public class NoStereoHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoStereoHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoStereoHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoStereoHardwareException.NoStereoHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoStereoHardwareException();
protected NoStereoHardwareException(SerializationInfo, StreamingContext);
public NoStereoHardwareException(string);
public NoStereoHardwareException(string, Exception);


NoStereoHardwareException.NoStereoHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoStereoHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoStereoHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoStereoHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoStereoHardwareException.NoStereoHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoStereoHardwareException(
string message,
Exception inner
);
C++ public:
NoStereoHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoStereoHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoStereoHardwareException.NoStereoHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoStereoHardwareException(
string message
);
C++ public:
NoStereoHardwareException(
String^ message
);
JScript public function NoStereoHardwareException(
message : String
);

Parameters

message System.String


NoStereoHardwareException.NoStereoHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoStereoHardwareException.NoStereoHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoStereoHardwareException();
C++ public:
NoStereoHardwareException();
JScript | public function NoStereoHardwareException();


NoStretchHardwareException Class (Microsoft.DirectX.DirectDraw)

NoStretchHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for stretching. Deprecated.

Definition

Visual Basic Public Class NoStretchHardwareException
Inherits GraphicsException
C# | public class NoStretchHardwareException : GraphicsException
C++ | public ref class NoStretchHardwareException : GraphicsException
JScript | public class NoStretchHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoStretchHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoStretchHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoStretchHardwareException.NoStretchHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoStretchHardwareException();
protected NoStretchHardwareException(SerializationInfo, StreamingContext);
public NoStretchHardwareException(string);
public NoStretchHardwareException(string, Exception);


NoStretchHardwareException.NoStretchHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoStretchHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoStretchHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoStretchHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoStretchHardwareException.NoStretchHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoStretchHardwareException(
string message,
Exception inner
);
C++ public:
NoStretchHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoStretchHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoStretchHardwareException.NoStretchHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoStretchHardwareException(
string message
);
C++ public:
NoStretchHardwareException(
String^ message
);
JScript public function NoStretchHardwareException(
message : String
);

Parameters

message System.String


NoStretchHardwareException.NoStretchHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoStretchHardwareException.NoStretchHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoStretchHardwareException();
C++ public:
NoStretchHardwareException();
JScript | public function NoStretchHardwareException();


NoSurfaceLeftException Class (Microsoft.DirectX.DirectDraw)

NoSurfaceLeftException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware present that supports stereo surfaces. Deprecated.

Definition

Visual Basic Public Class NoSurfaceLeftException
Inherits GraphicsException
C# | public class NoSurfaceLeftException : GraphicsException
C++ | public ref class NoSurfaceLeftException : GraphicsException
JScript | public class NoSurfaceLeftException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoSurfaceLeftException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoSurfaceLeftException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoSurfaceLeftException.NoSurfaceLeftException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoSurfaceLeftException();
protected NoSurfaceLeftException(SerializationInfo, StreamingContext);
public NoSurfaceLeftException(string);
public NoSurfaceLeftException(string, Exception);


NoSurfaceLeftException.NoSurfaceLeftException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoSurfaceLeftException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoSurfaceLeftException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoSurfaceLeftException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoSurfaceLeftException.NoSurfaceLeftException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoSurfaceLeftException(
string message,
Exception inner
);
C++ public:
NoSurfaceLeftException(
String^ message,
Exception^ inner
);
JScript public function NoSurfaceLeftException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoSurfaceLeftException.NoSurfaceLeftException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoSurfaceLeftException(
string message
);
C++ public:
NoSurfaceLeftException(
String^ message
);
JScript public function NoSurfaceLeftException(
message : String
);

Parameters

message System.String


NoSurfaceLeftException.NoSurfaceLeftException() Constructor (Microsoft.DirectX.DirectDraw)

NoSurfaceLeftException.NoSurfaceLeftException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoSurfaceLeftException();
C++ public:
NoSurfaceLeftException();
JScript | public function NoSurfaceLeftException();


Not4BitColorException Class (Microsoft.DirectX.DirectDraw)

Not4BitColorException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using a 4-bit color palette, and the requested operation requires a 4-bit color palette. Deprecated.

Definition

Visual Basic Public Class Not4BitColorException
Inherits GraphicsException
C# | public class Not4BitColorException : GraphicsException
C++ | public ref class Not4BitColorException : GraphicsException
JScript | public class Not4BitColorException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
Not4BitColorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
Not4BitColorException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Not4BitColorException.Not4BitColorException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Not4BitColorException();
protected Not4BitColorException(SerializationInfo, StreamingContext);
public Not4BitColorException(string);
public Not4BitColorException(string, Exception);


Not4BitColorException.Not4BitColorException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

Not4BitColorException.Not4BitColorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected Not4BitColorException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
Not4BitColorException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function Not4BitColorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


Not4BitColorException.Not4BitColorException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

Not4BitColorException.Not4BitColorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public Not4BitColorException(
string message,
Exception inner
);
C++ public:
Not4BitColorException(
String^ message,
Exception^ inner
);
JScript public function Not4BitColorException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


Not4BitColorException.Not4BitColorException(String) Constructor (Microsoft.DirectX.DirectDraw)

Not4BitColorException.Not4BitColorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public Not4BitColorException(
string message
);
C++ public:
Not4BitColorException(
String^ message
);
JScript public function Not4BitColorException(
message : String
);

Parameters

message System.String


Not4BitColorException.Not4BitColorException() Constructor (Microsoft.DirectX.DirectDraw)

Not4BitColorException.Not4BitColorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Not4BitColorException();
C++ public:
Not4BitColorException();
JScript | public function Not4BitColorException();


Not4BitColorIndexException Class (Microsoft.DirectX.DirectDraw)

Not4BitColorIndexException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using a 4-bit color index palette, and the requested operation requires a 4-bit color index palette. Deprecated.

Definition

Visual Basic Public Class Not4BitColorIndexException
Inherits GraphicsException
C# | public class Not4BitColorIndexException : GraphicsException
C++ | public ref class Not4BitColorIndexException : GraphicsException
JScript | public class Not4BitColorIndexException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
Not4BitColorIndexException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
Not4BitColorIndexException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Not4BitColorIndexException.Not4BitColorIndexException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Not4BitColorIndexException();
protected Not4BitColorIndexException(SerializationInfo, StreamingContext);
public Not4BitColorIndexException(string);
public Not4BitColorIndexException(string, Exception);


Not4BitColorIndexException.Not4BitColorIndexException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected Not4BitColorIndexException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
Not4BitColorIndexException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function Not4BitColorIndexException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


Not4BitColorIndexException.Not4BitColorIndexException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public Not4BitColorIndexException(
string message,
Exception inner
);
C++ public:
Not4BitColorIndexException(
String^ message,
Exception^ inner
);
JScript public function Not4BitColorIndexException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


Not4BitColorIndexException.Not4BitColorIndexException(String) Constructor (Microsoft.DirectX.DirectDraw)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public Not4BitColorIndexException(
string message
);
C++ public:
Not4BitColorIndexException(
String^ message
);
JScript public function Not4BitColorIndexException(
message : String
);

Parameters

message System.String


Not4BitColorIndexException.Not4BitColorIndexException() Constructor (Microsoft.DirectX.DirectDraw)

Not4BitColorIndexException.Not4BitColorIndexException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Not4BitColorIndexException();
C++ public:
Not4BitColorIndexException();
JScript | public function Not4BitColorIndexException();


Not8BitColorException Class (Microsoft.DirectX.DirectDraw)

Not8BitColorException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDrawSurface object is not using an 8-bit color palette, and the requested operation requires an 8-bit color palette. Deprecated.

Definition

Visual Basic Public Class Not8BitColorException
Inherits GraphicsException
C# | public class Not8BitColorException : GraphicsException
C++ | public ref class Not8BitColorException : GraphicsException
JScript | public class Not8BitColorException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
Not8BitColorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
Not8BitColorException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Not8BitColorException.Not8BitColorException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Not8BitColorException();
protected Not8BitColorException(SerializationInfo, StreamingContext);
public Not8BitColorException(string);
public Not8BitColorException(string, Exception);


Not8BitColorException.Not8BitColorException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

Not8BitColorException.Not8BitColorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected Not8BitColorException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
Not8BitColorException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function Not8BitColorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


Not8BitColorException.Not8BitColorException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

Not8BitColorException.Not8BitColorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public Not8BitColorException(
string message,
Exception inner
);
C++ public:
Not8BitColorException(
String^ message,
Exception^ inner
);
JScript public function Not8BitColorException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


Not8BitColorException.Not8BitColorException(String) Constructor (Microsoft.DirectX.DirectDraw)

Not8BitColorException.Not8BitColorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public Not8BitColorException(
string message
);
C++ public:
Not8BitColorException(
String^ message
);
JScript public function Not8BitColorException(
message : String
);

Parameters

message System.String


Not8BitColorException.Not8BitColorException() Constructor (Microsoft.DirectX.DirectDraw)

Not8BitColorException.Not8BitColorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Not8BitColorException();
C++ public:
Not8BitColorException();
JScript | public function Not8BitColorException();


NotAnOverlaySurfaceException Class (Microsoft.DirectX.DirectDraw)

NotAnOverlaySurfaceException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An overlay component is called for a nonoverlay surface. Deprecated.

Definition

Visual Basic Public Class NotAnOverlaySurfaceException
Inherits GraphicsException
C# | public class NotAnOverlaySurfaceException : GraphicsException
C++ | public ref class NotAnOverlaySurfaceException : GraphicsException
JScript | public class NotAnOverlaySurfaceException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAnOverlaySurfaceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotAnOverlaySurfaceException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotAnOverlaySurfaceException();
protected NotAnOverlaySurfaceException(SerializationInfo, StreamingContext);
public NotAnOverlaySurfaceException(string);
public NotAnOverlaySurfaceException(string, Exception);


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAnOverlaySurfaceException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotAnOverlaySurfaceException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotAnOverlaySurfaceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAnOverlaySurfaceException(
string message,
Exception inner
);
C++ public:
NotAnOverlaySurfaceException(
String^ message,
Exception^ inner
);
JScript public function NotAnOverlaySurfaceException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException(String) Constructor (Microsoft.DirectX.DirectDraw)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotAnOverlaySurfaceException(
string message
);
C++ public:
NotAnOverlaySurfaceException(
String^ message
);
JScript public function NotAnOverlaySurfaceException(
message : String
);

Parameters

message System.String


NotAnOverlaySurfaceException.NotAnOverlaySurfaceException() Constructor (Microsoft.DirectX.DirectDraw)

NotAnOverlaySurfaceException.NotAnOverlaySurfaceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotAnOverlaySurfaceException();
C++ public:
NotAnOverlaySurfaceException();
JScript | public function NotAnOverlaySurfaceException();


NotFlippableException Class (Microsoft.DirectX.DirectDraw)

NotFlippableException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to flip a surface that cannot be flipped. Deprecated.

Definition

Visual Basic Public Class NotFlippableException
Inherits GraphicsException
C# | public class NotFlippableException : GraphicsException
C++ | public ref class NotFlippableException : GraphicsException
JScript | public class NotFlippableException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotFlippableException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotFlippableException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotFlippableException.NotFlippableException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotFlippableException();
protected NotFlippableException(SerializationInfo, StreamingContext);
public NotFlippableException(string);
public NotFlippableException(string, Exception);


NotFlippableException.NotFlippableException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NotFlippableException.NotFlippableException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotFlippableException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotFlippableException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotFlippableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotFlippableException.NotFlippableException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NotFlippableException.NotFlippableException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotFlippableException(
string message,
Exception inner
);
C++ public:
NotFlippableException(
String^ message,
Exception^ inner
);
JScript public function NotFlippableException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotFlippableException.NotFlippableException(String) Constructor (Microsoft.DirectX.DirectDraw)

NotFlippableException.NotFlippableException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotFlippableException(
string message
);
C++ public:
NotFlippableException(
String^ message
);
JScript public function NotFlippableException(
message : String
);

Parameters

message System.String


NotFlippableException.NotFlippableException() Constructor (Microsoft.DirectX.DirectDraw)

NotFlippableException.NotFlippableException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotFlippableException();
C++ public:
NotFlippableException();
JScript | public function NotFlippableException();


NotFoundException Class (Microsoft.DirectX.DirectDraw)

NotFoundException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The requested item was not found. Deprecated.

Definition

Visual Basic Public Class NotFoundException
Inherits GraphicsException
C# | public class NotFoundException : GraphicsException
C++ | public ref class NotFoundException : GraphicsException
JScript | public class NotFoundException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotFoundException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotFoundException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotFoundException.NotFoundException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotFoundException();
protected NotFoundException(SerializationInfo, StreamingContext);
public NotFoundException(string);
public NotFoundException(string, Exception);


NotFoundException.NotFoundException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NotFoundException.NotFoundException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotFoundException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotFoundException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotFoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotFoundException.NotFoundException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NotFoundException.NotFoundException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotFoundException(
string message,
Exception inner
);
C++ public:
NotFoundException(
String^ message,
Exception^ inner
);
JScript public function NotFoundException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotFoundException.NotFoundException(String) Constructor (Microsoft.DirectX.DirectDraw)

NotFoundException.NotFoundException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotFoundException(
string message
);
C++ public:
NotFoundException(
String^ message
);
JScript public function NotFoundException(
message : String
);

Parameters

message System.String


NotFoundException.NotFoundException() Constructor (Microsoft.DirectX.DirectDraw)

NotFoundException.NotFoundException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotFoundException();
C++ public:
NotFoundException();
JScript | public function NotFoundException();


NotLoadedException Class (Microsoft.DirectX.DirectDraw)

NotLoadedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is an optimized surface, but it has not yet been allocated any memory. Deprecated.

Definition

Visual Basic Public Class NotLoadedException
Inherits GraphicsException
C# | public class NotLoadedException : GraphicsException
C++ | public ref class NotLoadedException : GraphicsException
JScript | public class NotLoadedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotLoadedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotLoadedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotLoadedException.NotLoadedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotLoadedException();
protected NotLoadedException(SerializationInfo, StreamingContext);
public NotLoadedException(string);
public NotLoadedException(string, Exception);


NotLoadedException.NotLoadedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NotLoadedException.NotLoadedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotLoadedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotLoadedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotLoadedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotLoadedException.NotLoadedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NotLoadedException.NotLoadedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotLoadedException(
string message,
Exception inner
);
C++ public:
NotLoadedException(
String^ message,
Exception^ inner
);
JScript public function NotLoadedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotLoadedException.NotLoadedException(String) Constructor (Microsoft.DirectX.DirectDraw)

NotLoadedException.NotLoadedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotLoadedException(
string message
);
C++ public:
NotLoadedException(
String^ message
);
JScript public function NotLoadedException(
message : String
);

Parameters

message System.String


NotLoadedException.NotLoadedException() Constructor (Microsoft.DirectX.DirectDraw)

NotLoadedException.NotLoadedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotLoadedException();
C++ public:
NotLoadedException();
JScript | public function NotLoadedException();


NotLockedException Class (Microsoft.DirectX.DirectDraw)

NotLockedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to unlock a surface that was not locked. Deprecated.

Definition

Visual Basic Public Class NotLockedException
Inherits GraphicsException
C# | public class NotLockedException : GraphicsException
C++ | public ref class NotLockedException : GraphicsException
JScript | public class NotLockedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotLockedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotLockedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotLockedException.NotLockedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotLockedException();
protected NotLockedException(SerializationInfo, StreamingContext);
public NotLockedException(string);
public NotLockedException(string, Exception);


NotLockedException.NotLockedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NotLockedException.NotLockedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotLockedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotLockedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotLockedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotLockedException.NotLockedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NotLockedException.NotLockedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotLockedException(
string message,
Exception inner
);
C++ public:
NotLockedException(
String^ message,
Exception^ inner
);
JScript public function NotLockedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotLockedException.NotLockedException(String) Constructor (Microsoft.DirectX.DirectDraw)

NotLockedException.NotLockedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotLockedException(
string message
);
C++ public:
NotLockedException(
String^ message
);
JScript public function NotLockedException(
message : String
);

Parameters

message System.String


NotLockedException.NotLockedException() Constructor (Microsoft.DirectX.DirectDraw)

NotLockedException.NotLockedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotLockedException();
C++ public:
NotLockedException();
JScript | public function NotLockedException();


NotPageLockedException Class (Microsoft.DirectX.DirectDraw)

NotPageLockedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to page-unlock a surface with no outstanding page locks. Deprecated.

Definition

Visual Basic Public Class NotPageLockedException
Inherits GraphicsException
C# | public class NotPageLockedException : GraphicsException
C++ | public ref class NotPageLockedException : GraphicsException
JScript | public class NotPageLockedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotPageLockedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotPageLockedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotPageLockedException.NotPageLockedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotPageLockedException();
protected NotPageLockedException(SerializationInfo, StreamingContext);
public NotPageLockedException(string);
public NotPageLockedException(string, Exception);


NotPageLockedException.NotPageLockedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NotPageLockedException.NotPageLockedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotPageLockedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotPageLockedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotPageLockedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotPageLockedException.NotPageLockedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NotPageLockedException.NotPageLockedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotPageLockedException(
string message,
Exception inner
);
C++ public:
NotPageLockedException(
String^ message,
Exception^ inner
);
JScript public function NotPageLockedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotPageLockedException.NotPageLockedException(String) Constructor (Microsoft.DirectX.DirectDraw)

NotPageLockedException.NotPageLockedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotPageLockedException(
string message
);
C++ public:
NotPageLockedException(
String^ message
);
JScript public function NotPageLockedException(
message : String
);

Parameters

message System.String


NotPageLockedException.NotPageLockedException() Constructor (Microsoft.DirectX.DirectDraw)

NotPageLockedException.NotPageLockedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotPageLockedException();
C++ public:
NotPageLockedException();
JScript | public function NotPageLockedException();


NotPalettizedException Class (Microsoft.DirectX.DirectDraw)

NotPalettizedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface being used is not a palette-based surface. Deprecated.

Definition

Visual Basic Public Class NotPalettizedException
Inherits GraphicsException
C# | public class NotPalettizedException : GraphicsException
C++ | public ref class NotPalettizedException : GraphicsException
JScript | public class NotPalettizedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotPalettizedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NotPalettizedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotPalettizedException.NotPalettizedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotPalettizedException();
protected NotPalettizedException(SerializationInfo, StreamingContext);
public NotPalettizedException(string);
public NotPalettizedException(string, Exception);


NotPalettizedException.NotPalettizedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NotPalettizedException.NotPalettizedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotPalettizedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotPalettizedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotPalettizedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotPalettizedException.NotPalettizedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NotPalettizedException.NotPalettizedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotPalettizedException(
string message,
Exception inner
);
C++ public:
NotPalettizedException(
String^ message,
Exception^ inner
);
JScript public function NotPalettizedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotPalettizedException.NotPalettizedException(String) Constructor (Microsoft.DirectX.DirectDraw)

NotPalettizedException.NotPalettizedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotPalettizedException(
string message
);
C++ public:
NotPalettizedException(
String^ message
);
JScript public function NotPalettizedException(
message : String
);

Parameters

message System.String


NotPalettizedException.NotPalettizedException() Constructor (Microsoft.DirectX.DirectDraw)

NotPalettizedException.NotPalettizedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotPalettizedException();
C++ public:
NotPalettizedException();
JScript | public function NotPalettizedException();


NoVideoSyncHardwareException Class (Microsoft.DirectX.DirectDraw)

NoVideoSyncHardwareException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support for vertical blank-synchronized operations. Deprecated.

Definition

Visual Basic Public Class NoVideoSyncHardwareException
Inherits GraphicsException
C# | public class NoVideoSyncHardwareException : GraphicsException
C++ | public ref class NoVideoSyncHardwareException : GraphicsException
JScript | public class NoVideoSyncHardwareException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoVideoSyncHardwareException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoVideoSyncHardwareException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoVideoSyncHardwareException();
protected NoVideoSyncHardwareException(SerializationInfo, StreamingContext);
public NoVideoSyncHardwareException(string);
public NoVideoSyncHardwareException(string, Exception);


NoVideoSyncHardwareException.NoVideoSyncHardwareException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoVideoSyncHardwareException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoVideoSyncHardwareException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoVideoSyncHardwareException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoVideoSyncHardwareException.NoVideoSyncHardwareException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoVideoSyncHardwareException(
string message,
Exception inner
);
C++ public:
NoVideoSyncHardwareException(
String^ message,
Exception^ inner
);
JScript public function NoVideoSyncHardwareException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoVideoSyncHardwareException.NoVideoSyncHardwareException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoVideoSyncHardwareException(
string message
);
C++ public:
NoVideoSyncHardwareException(
String^ message
);
JScript public function NoVideoSyncHardwareException(
message : String
);

Parameters

message System.String


NoVideoSyncHardwareException.NoVideoSyncHardwareException() Constructor (Microsoft.DirectX.DirectDraw)

NoVideoSyncHardwareException.NoVideoSyncHardwareException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoVideoSyncHardwareException();
C++ public:
NoVideoSyncHardwareException();
JScript | public function NoVideoSyncHardwareException();


NoWindowException Class (Microsoft.DirectX.DirectDraw)

NoWindowException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Clipper notification requires a window, or no window has been previously set as the cooperative level window Deprecated.

Definition

Visual Basic Public Class NoWindowException
Inherits GraphicsException
C# | public class NoWindowException : GraphicsException
C++ | public ref class NoWindowException : GraphicsException
JScript | public class NoWindowException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoWindowException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
NoWindowException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoWindowException.NoWindowException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoWindowException();
protected NoWindowException(SerializationInfo, StreamingContext);
public NoWindowException(string);
public NoWindowException(string, Exception);


NoWindowException.NoWindowException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

NoWindowException.NoWindowException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoWindowException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoWindowException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoWindowException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoWindowException.NoWindowException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

NoWindowException.NoWindowException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoWindowException(
string message,
Exception inner
);
C++ public:
NoWindowException(
String^ message,
Exception^ inner
);
JScript public function NoWindowException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoWindowException.NoWindowException(String) Constructor (Microsoft.DirectX.DirectDraw)

NoWindowException.NoWindowException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoWindowException(
string message
);
C++ public:
NoWindowException(
String^ message
);
JScript public function NoWindowException(
message : String
);

Parameters

message System.String


NoWindowException.NoWindowException() Constructor (Microsoft.DirectX.DirectDraw)

NoWindowException.NoWindowException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoWindowException();
C++ public:
NoWindowException();
JScript | public function NoWindowException();


OutOfCapsException Class (Microsoft.DirectX.DirectDraw)

OutOfCapsException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The hardware needed for the requested operation has already been allocated. Deprecated.

Definition

Visual Basic Public Class OutOfCapsException
Inherits GraphicsException
C# | public class OutOfCapsException : GraphicsException
C++ | public ref class OutOfCapsException : GraphicsException
JScript | public class OutOfCapsException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OutOfCapsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OutOfCapsException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OutOfCapsException.OutOfCapsException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OutOfCapsException();
protected OutOfCapsException(SerializationInfo, StreamingContext);
public OutOfCapsException(string);
public OutOfCapsException(string, Exception);


OutOfCapsException.OutOfCapsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

OutOfCapsException.OutOfCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OutOfCapsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OutOfCapsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OutOfCapsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


OutOfCapsException.OutOfCapsException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

OutOfCapsException.OutOfCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OutOfCapsException(
string message,
Exception inner
);
C++ public:
OutOfCapsException(
String^ message,
Exception^ inner
);
JScript public function OutOfCapsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


OutOfCapsException.OutOfCapsException(String) Constructor (Microsoft.DirectX.DirectDraw)

OutOfCapsException.OutOfCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OutOfCapsException(
string message
);
C++ public:
OutOfCapsException(
String^ message
);
JScript public function OutOfCapsException(
message : String
);

Parameters

message System.String


OutOfCapsException.OutOfCapsException() Constructor (Microsoft.DirectX.DirectDraw)

OutOfCapsException.OutOfCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public OutOfCapsException();
C++ public:
OutOfCapsException();
JScript | public function OutOfCapsException();


OutOfVideoMemoryException Class (Microsoft.DirectX.DirectDraw)

OutOfVideoMemoryException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw does not have enough display memory to perform the operation. Deprecated.

Definition

Visual Basic Public Class OutOfVideoMemoryException
Inherits GraphicsException
C# | public class OutOfVideoMemoryException : GraphicsException
C++ | public ref class OutOfVideoMemoryException : GraphicsException
JScript | public class OutOfVideoMemoryException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OutOfVideoMemoryException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OutOfVideoMemoryException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OutOfVideoMemoryException.OutOfVideoMemoryException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OutOfVideoMemoryException();
protected OutOfVideoMemoryException(SerializationInfo, StreamingContext);
public OutOfVideoMemoryException(string);
public OutOfVideoMemoryException(string, Exception);


OutOfVideoMemoryException.OutOfVideoMemoryException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OutOfVideoMemoryException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OutOfVideoMemoryException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OutOfVideoMemoryException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


OutOfVideoMemoryException.OutOfVideoMemoryException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OutOfVideoMemoryException(
string message,
Exception inner
);
C++ public:
OutOfVideoMemoryException(
String^ message,
Exception^ inner
);
JScript public function OutOfVideoMemoryException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


OutOfVideoMemoryException.OutOfVideoMemoryException(String) Constructor (Microsoft.DirectX.DirectDraw)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OutOfVideoMemoryException(
string message
);
C++ public:
OutOfVideoMemoryException(
String^ message
);
JScript public function OutOfVideoMemoryException(
message : String
);

Parameters

message System.String


OutOfVideoMemoryException.OutOfVideoMemoryException() Constructor (Microsoft.DirectX.DirectDraw)

OutOfVideoMemoryException.OutOfVideoMemoryException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public OutOfVideoMemoryException();
C++ public:
OutOfVideoMemoryException();
JScript | public function OutOfVideoMemoryException();


OverlappingRectanglesException Class (Microsoft.DirectX.DirectDraw)

OverlappingRectanglesException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The source and destination rectangles are on the same surface and overlap each other. Deprecated.

Definition

Visual Basic Public Class OverlappingRectanglesException
Inherits GraphicsException
C# | public class OverlappingRectanglesException : GraphicsException
C++ | public ref class OverlappingRectanglesException : GraphicsException
JScript | public class OverlappingRectanglesException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OverlappingRectanglesException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OverlappingRectanglesException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlappingRectanglesException.OverlappingRectanglesException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OverlappingRectanglesException();
protected OverlappingRectanglesException(SerializationInfo, StreamingContext);
public OverlappingRectanglesException(string);
public OverlappingRectanglesException(string, Exception);


OverlappingRectanglesException.OverlappingRectanglesException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OverlappingRectanglesException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OverlappingRectanglesException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OverlappingRectanglesException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


OverlappingRectanglesException.OverlappingRectanglesException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OverlappingRectanglesException(
string message,
Exception inner
);
C++ public:
OverlappingRectanglesException(
String^ message,
Exception^ inner
);
JScript public function OverlappingRectanglesException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


OverlappingRectanglesException.OverlappingRectanglesException(String) Constructor (Microsoft.DirectX.DirectDraw)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OverlappingRectanglesException(
string message
);
C++ public:
OverlappingRectanglesException(
String^ message
);
JScript public function OverlappingRectanglesException(
message : String
);

Parameters

message System.String


OverlappingRectanglesException.OverlappingRectanglesException() Constructor (Microsoft.DirectX.DirectDraw)

OverlappingRectanglesException.OverlappingRectanglesException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public OverlappingRectanglesException();
C++ public:
OverlappingRectanglesException();
JScript | public function OverlappingRectanglesException();


OverlayCantClipException Class (Microsoft.DirectX.DirectDraw)

OverlayCantClipException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The hardware does not support clipped overlays. Deprecated.

Definition

Visual Basic Public Class OverlayCantClipException
Inherits GraphicsException
C# | public class OverlayCantClipException : GraphicsException
C++ | public ref class OverlayCantClipException : GraphicsException
JScript | public class OverlayCantClipException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OverlayCantClipException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OverlayCantClipException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlayCantClipException.OverlayCantClipException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OverlayCantClipException();
protected OverlayCantClipException(SerializationInfo, StreamingContext);
public OverlayCantClipException(string);
public OverlayCantClipException(string, Exception);


OverlayCantClipException.OverlayCantClipException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OverlayCantClipException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OverlayCantClipException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OverlayCantClipException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


OverlayCantClipException.OverlayCantClipException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OverlayCantClipException(
string message,
Exception inner
);
C++ public:
OverlayCantClipException(
String^ message,
Exception^ inner
);
JScript public function OverlayCantClipException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


OverlayCantClipException.OverlayCantClipException(String) Constructor (Microsoft.DirectX.DirectDraw)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OverlayCantClipException(
string message
);
C++ public:
OverlayCantClipException(
String^ message
);
JScript public function OverlayCantClipException(
message : String
);

Parameters

message System.String


OverlayCantClipException.OverlayCantClipException() Constructor (Microsoft.DirectX.DirectDraw)

OverlayCantClipException.OverlayCantClipException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public OverlayCantClipException();
C++ public:
OverlayCantClipException();
JScript | public function OverlayCantClipException();


OverlayColorKeyOnlyOneActiveException Class (Microsoft.DirectX.DirectDraw)

OverlayColorKeyOnlyOneActiveException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt was made to have more than one color key active on an overlay. Deprecated.

Definition

Visual Basic Public Class OverlayColorKeyOnlyOneActiveException
Inherits GraphicsException
C# | public class OverlayColorKeyOnlyOneActiveException : GraphicsException
C++ | public ref class OverlayColorKeyOnlyOneActiveException : GraphicsException
JScript | public class OverlayColorKeyOnlyOneActiveException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OverlayColorKeyOnlyOneActiveException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OverlayColorKeyOnlyOneActiveException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OverlayColorKeyOnlyOneActiveException();
protected OverlayColorKeyOnlyOneActiveException(SerializationInfo, StreamingContext);
public OverlayColorKeyOnlyOneActiveException(string);
public OverlayColorKeyOnlyOneActiveException(string, Exception);


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OverlayColorKeyOnlyOneActiveException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OverlayColorKeyOnlyOneActiveException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OverlayColorKeyOnlyOneActiveException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OverlayColorKeyOnlyOneActiveException(
string message,
Exception inner
);
C++ public:
OverlayColorKeyOnlyOneActiveException(
String^ message,
Exception^ inner
);
JScript public function OverlayColorKeyOnlyOneActiveException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException(String) Constructor (Microsoft.DirectX.DirectDraw)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OverlayColorKeyOnlyOneActiveException(
string message
);
C++ public:
OverlayColorKeyOnlyOneActiveException(
String^ message
);
JScript public function OverlayColorKeyOnlyOneActiveException(
message : String
);

Parameters

message System.String


OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException() Constructor (Microsoft.DirectX.DirectDraw)

OverlayColorKeyOnlyOneActiveException.OverlayColorKeyOnlyOneActiveException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public OverlayColorKeyOnlyOneActiveException();
C++ public:
OverlayColorKeyOnlyOneActiveException();
JScript | public function OverlayColorKeyOnlyOneActiveException();


OverlayNotVisibleException Class (Microsoft.DirectX.DirectDraw)

OverlayNotVisibleException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The GetOverlayPosition method was called on a hidden overlay. Deprecated.

Definition

Visual Basic Public Class OverlayNotVisibleException
Inherits GraphicsException
C# | public class OverlayNotVisibleException : GraphicsException
C++ | public ref class OverlayNotVisibleException : GraphicsException
JScript | public class OverlayNotVisibleException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OverlayNotVisibleException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
OverlayNotVisibleException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlayNotVisibleException.OverlayNotVisibleException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public OverlayNotVisibleException();
protected OverlayNotVisibleException(SerializationInfo, StreamingContext);
public OverlayNotVisibleException(string);
public OverlayNotVisibleException(string, Exception);


OverlayNotVisibleException.OverlayNotVisibleException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OverlayNotVisibleException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OverlayNotVisibleException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OverlayNotVisibleException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


OverlayNotVisibleException.OverlayNotVisibleException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OverlayNotVisibleException(
string message,
Exception inner
);
C++ public:
OverlayNotVisibleException(
String^ message,
Exception^ inner
);
JScript public function OverlayNotVisibleException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


OverlayNotVisibleException.OverlayNotVisibleException(String) Constructor (Microsoft.DirectX.DirectDraw)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OverlayNotVisibleException(
string message
);
C++ public:
OverlayNotVisibleException(
String^ message
);
JScript public function OverlayNotVisibleException(
message : String
);

Parameters

message System.String


OverlayNotVisibleException.OverlayNotVisibleException() Constructor (Microsoft.DirectX.DirectDraw)

OverlayNotVisibleException.OverlayNotVisibleException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public OverlayNotVisibleException();
C++ public:
OverlayNotVisibleException();
JScript | public function OverlayNotVisibleException();


Palette Class (Microsoft.DirectX.DirectDraw)

Palette Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Palette object to create DirectDrawPalette objects Deprecated.

Definition

Visual Basic Public Class Palette
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Palette : MarshalByRefObject, IDisposable
C++ | public ref class Palette : MarshalByRefObject, IDisposable
JScript | public class Palette extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetEntries
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Queries palette values from a DirectDrawPalette object. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
Palette
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
SetEntries
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes entries in a DirectDrawPalette object immediately. Deprecated.

Properties

Property Description
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the capabilities of this palette object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Palette

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Palette.Dispose() Method (Microsoft.DirectX.DirectDraw)

Palette.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Palette();
JScript | public override function Dispose();

See Also

  • Palette.Disposed
  • Palette.Disposing


Palette.Equals(Object) Method (Microsoft.DirectX.DirectDraw)

Palette.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Palette.Finalize() Method (Microsoft.DirectX.DirectDraw)

Palette.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Palette();
C++ | !Palette();
JScript | protected override function Finalize();


Palette.GetEntries(Int32,Int32) Method (Microsoft.DirectX.DirectDraw)

Palette.GetEntries Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Queries palette values from a DirectDrawPalette object. Deprecated.

Definition

Visual Basic Public Function GetEntries( _
ByVal base As Integer, _
ByVal numEntries As Integer _
) As PaletteEntry()
C# public PaletteEntry[] GetEntries(
int base,
int numEntries
);
C++ public:
array<PaletteEntry>^ GetEntries(
int base,
int numEntries
);
JScript public function GetEntries(
base : int,
numEntries : int
) : PaletteEntry[];

Parameters

base System.Int32
numEntries System.Int32

Return Value

Microsoft.DirectX.DirectDraw.PaletteEntry[]


Palette.GetHashCode() Method (Microsoft.DirectX.DirectDraw)

Palette.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Palette.op_Equality(Palette,Palette) Method (Microsoft.DirectX.DirectDraw)

Palette.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Palette, _
ByVal right As Palette _
) As Boolean
C# public static bool op_Equality(
Palette left,
Palette right
);
C++ public:
static bool operator==(
Palette^ left,
Palette^ right
);
JScript public static function op_Equality(
left : Palette,
right : Palette
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.Palette
The Palette structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.Palette
The Palette structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Palette.op_Inequality(Palette,Palette) Method (Microsoft.DirectX.DirectDraw)

Palette.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Palette, _
ByVal right As Palette _
) As Boolean
C# public static bool op_Inequality(
Palette left,
Palette right
);
C++ public:
static bool operator!=(
Palette^ left,
Palette^ right
);
JScript public static function op_Inequality(
left : Palette,
right : Palette
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.Palette
The Palette structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.Palette
The Palette structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Palette.Palette Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Palette(Device, PaletteCaps, PaletteEntry[]);
public Palette(Device, string);
public Palette(Surface);


Palette.Palette(Device,String) Constructor (Microsoft.DirectX.DirectDraw)

Palette.Palette Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal file As String _
)
C# public Palette(
Device device,
string file
);
C++ public:
Palette(
Device^ device,
String^ file
);
JScript public function Palette(
device : Device,
file : String
);

Parameters

device Microsoft.DirectX.DirectDraw.Device
file System.String


Palette.Palette(Device,PaletteCaps,PaletteEntry[]) Constructor (Microsoft.DirectX.DirectDraw)

Palette.Palette Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal device As Device, _
ByVal flags As PaletteCaps, _
ByVal palette() As PaletteEntry _
)
C# public Palette(
Device device,
PaletteCaps flags,
PaletteEntry[] palette
);
C++ public:
Palette(
Device^ device,
PaletteCaps flags,
array<PaletteEntry>^ palette
);
JScript public function Palette(
device : Device,
flags : PaletteCaps,
palette : PaletteEntry[]
);

Parameters

device Microsoft.DirectX.DirectDraw.Device
flags Microsoft.DirectX.DirectDraw.PaletteCaps
palette Microsoft.DirectX.DirectDraw.PaletteEntry[]


Palette.Palette(Surface) Constructor (Microsoft.DirectX.DirectDraw)

Palette.Palette Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal surf As Surface _
)
C# public Palette(
Surface surf
);
C++ public:
Palette(
Surface^ surf
);
JScript public function Palette(
surf : Surface
);

Parameters

surf Microsoft.DirectX.DirectDraw.Surface


Palette.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectDraw)

Palette.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Palette.SetEntries(Int32,PaletteEntry[]) Method (Microsoft.DirectX.DirectDraw)

Palette.SetEntries Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes entries in a DirectDrawPalette object immediately. Deprecated.

Definition

Visual Basic Public Sub SetEntries( _
ByVal base As Integer, _
ByVal entries() As PaletteEntry _
)
C# public void SetEntries(
int base,
PaletteEntry[] entries
);
C++ public:
void SetEntries(
int base,
array<PaletteEntry>^ entries
);
JScript public function SetEntries(
base : int,
entries : PaletteEntry[]
);

Parameters

base System.Int32
entries Microsoft.DirectX.DirectDraw.PaletteEntry[]


Palette.Caps Property (Microsoft.DirectX.DirectDraw)

Palette.Caps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the capabilities of this palette object. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Caps As PaletteCaps
C# | public PaletteCaps Caps { get; }
C++ public:
property PaletteCaps Caps {
PaletteCaps get();
}
JScript | public function get Caps() : PaletteCaps

Property Value

Microsoft.DirectX.DirectDraw.PaletteCaps

This property is read-only.


Palette.Disposed Property (Microsoft.DirectX.DirectDraw)

Palette.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Palette.Disposing Event (Microsoft.DirectX.DirectDraw)

Palette.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Palette.Disposing event, use the following code.

palette.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


PaletteBusyException Class (Microsoft.DirectX.DirectDraw)

PaletteBusyException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to this palette is refused because the palette is locked by another thread. Deprecated.

Definition

Visual Basic Public Class PaletteBusyException
Inherits GraphicsException
C# | public class PaletteBusyException : GraphicsException
C++ | public ref class PaletteBusyException : GraphicsException
JScript | public class PaletteBusyException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PaletteBusyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
PaletteBusyException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PaletteBusyException.PaletteBusyException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PaletteBusyException();
protected PaletteBusyException(SerializationInfo, StreamingContext);
public PaletteBusyException(string);
public PaletteBusyException(string, Exception);


PaletteBusyException.PaletteBusyException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

PaletteBusyException.PaletteBusyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PaletteBusyException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PaletteBusyException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PaletteBusyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


PaletteBusyException.PaletteBusyException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

PaletteBusyException.PaletteBusyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PaletteBusyException(
string message,
Exception inner
);
C++ public:
PaletteBusyException(
String^ message,
Exception^ inner
);
JScript public function PaletteBusyException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


PaletteBusyException.PaletteBusyException(String) Constructor (Microsoft.DirectX.DirectDraw)

PaletteBusyException.PaletteBusyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PaletteBusyException(
string message
);
C++ public:
PaletteBusyException(
String^ message
);
JScript public function PaletteBusyException(
message : String
);

Parameters

message System.String


PaletteBusyException.PaletteBusyException() Constructor (Microsoft.DirectX.DirectDraw)

PaletteBusyException.PaletteBusyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PaletteBusyException();
C++ public:
PaletteBusyException();
JScript | public function PaletteBusyException();


PrimarySurfaceAlreadyExistsException Class (Microsoft.DirectX.DirectDraw)

PrimarySurfaceAlreadyExistsException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This process has already created a primary surface. Deprecated.

Definition

Visual Basic Public Class PrimarySurfaceAlreadyExistsException
Inherits GraphicsException
C# | public class PrimarySurfaceAlreadyExistsException : GraphicsException
C++ | public ref class PrimarySurfaceAlreadyExistsException : GraphicsException
JScript | public class PrimarySurfaceAlreadyExistsException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PrimarySurfaceAlreadyExistsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
PrimarySurfaceAlreadyExistsException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PrimarySurfaceAlreadyExistsException();
protected PrimarySurfaceAlreadyExistsException(SerializationInfo, StreamingContext);
public PrimarySurfaceAlreadyExistsException(string);
public PrimarySurfaceAlreadyExistsException(string, Exception);


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PrimarySurfaceAlreadyExistsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PrimarySurfaceAlreadyExistsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PrimarySurfaceAlreadyExistsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PrimarySurfaceAlreadyExistsException(
string message,
Exception inner
);
C++ public:
PrimarySurfaceAlreadyExistsException(
String^ message,
Exception^ inner
);
JScript public function PrimarySurfaceAlreadyExistsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException(String) Constructor (Microsoft.DirectX.DirectDraw)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PrimarySurfaceAlreadyExistsException(
string message
);
C++ public:
PrimarySurfaceAlreadyExistsException(
String^ message
);
JScript public function PrimarySurfaceAlreadyExistsException(
message : String
);

Parameters

message System.String


PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException() Constructor (Microsoft.DirectX.DirectDraw)

PrimarySurfaceAlreadyExistsException.PrimarySurfaceAlreadyExistsException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PrimarySurfaceAlreadyExistsException();
C++ public:
PrimarySurfaceAlreadyExistsException();
JScript | public function PrimarySurfaceAlreadyExistsException();


RegionTooSmallException Class (Microsoft.DirectX.DirectDraw)

RegionTooSmallException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The region passed to the Clipper.ClipList property is too small. Deprecated.

Definition

Visual Basic Public Class RegionTooSmallException
Inherits GraphicsException
C# | public class RegionTooSmallException : GraphicsException
C++ | public ref class RegionTooSmallException : GraphicsException
JScript | public class RegionTooSmallException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
RegionTooSmallException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
RegionTooSmallException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RegionTooSmallException.RegionTooSmallException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public RegionTooSmallException();
protected RegionTooSmallException(SerializationInfo, StreamingContext);
public RegionTooSmallException(string);
public RegionTooSmallException(string, Exception);


RegionTooSmallException.RegionTooSmallException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

RegionTooSmallException.RegionTooSmallException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected RegionTooSmallException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
RegionTooSmallException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function RegionTooSmallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


RegionTooSmallException.RegionTooSmallException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

RegionTooSmallException.RegionTooSmallException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public RegionTooSmallException(
string message,
Exception inner
);
C++ public:
RegionTooSmallException(
String^ message,
Exception^ inner
);
JScript public function RegionTooSmallException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


RegionTooSmallException.RegionTooSmallException(String) Constructor (Microsoft.DirectX.DirectDraw)

RegionTooSmallException.RegionTooSmallException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public RegionTooSmallException(
string message
);
C++ public:
RegionTooSmallException(
String^ message
);
JScript public function RegionTooSmallException(
message : String
);

Parameters

message System.String


RegionTooSmallException.RegionTooSmallException() Constructor (Microsoft.DirectX.DirectDraw)

RegionTooSmallException.RegionTooSmallException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public RegionTooSmallException();
C++ public:
RegionTooSmallException();
JScript | public function RegionTooSmallException();


Surface Class (Microsoft.DirectX.DirectDraw)

Surface Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A surface represents a linear area of display memory. A surface usually resides in the display memory of the display card, although surfaces can exist in system memory. Unless specifically instructed otherwise during the creation of the Surface object, DirectDraw will put the Surface object wherever the best performance can be achieved given the requested capabilities. Surface objects can take advantage of specialized processors on display cards, not only to perform certain tasks faster, but to perform some tasks in parallel with the system CPU. Deprecated.

Definition

Visual Basic Public Class Surface
Inherits MarshalByRefObject
Implements ICloneable, IDisposable
C# | public class Surface : MarshalByRefObject, ICloneable, IDisposable
C++ | public ref class Surface : MarshalByRefObject, ICloneable, IDisposable
JScript | public class Surface extends MarshalByRefObject implements ICloneable, IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method | Description
ChangeUniquenessValue
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Manually updates the uniqueness value for this surface. Deprecated.
Clone
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Duplicates the object. Deprecated.
ColorFill
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.
Draw
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.
DrawBox
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawCircle
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawEllipse
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawFast
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a source copy blit or transparent blit by using a source color key or destination color key. Deprecated.
DrawLine
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawRoundedBox
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawText
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
DrawToDc
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
Flip
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes the surface memory associated with the BackBuffer surface become associated with the front-buffer surface. Deprecated.
GetAttachedSurface
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains the attached surface that has the specified capabilities. Deprecated.
GetColorKey
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the color key value for the DirectDrawSurface object. Deprecated.
GetDc
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetOverlayPosition
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Given a visible, active overlay surface, the GetOverlayPosition method returns the display coordinates of the surface Deprecated.
Lock | Allows manipulation of surface memory.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
PageLock
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Prevents a system-memory surface from being paged out while a blit operation that uses direct memory access (DMA) transfers to or from system memory is in progress. Deprecated.
PageUnlock
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unlocks a system-memory surface, allowing it to be paged out. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
ReleaseDc
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Release a device context handle. Deprecated.
Restore
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Restores a surface that has been lost. This occurs when the surface memory associated with the DirectDrawSurface object has been freed. Deprecated.
SetColorKey
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the color key value for the DirectDrawSurface object if the hardware supports color keys on a per-surface basis. Deprecated.
SetOverlayPosition
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes the display coordinates of an overlay surface. Deprecated.
Surface
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Unlock
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
UpdateOverlay
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.
UpdateOverlayZOrder
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the z-order of an overlay. Deprecated.

Properties

Property Description
CanDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether a blit involving this surface can occur immediately. Deprecated.
CanFlip
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether this surface can be flipped immediately. Deprecated.
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the capabilities of the surface. These capabilities are not necessarily related to the capabilities of the display device. Deprecated.
Clipper
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Clipper object associated with this surface. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
DrawDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrives the device that was used to create the surface. Deprecated.
DrawStyle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current drawing style. Deprecated.
DrawWidth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current draw width Deprecated.
FillColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current fill color. Deprecated.
FillStyle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current fill style. Deprecated.
FontBackColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font back color. Deprecated.
FontHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font handle. Deprecated.
FontTransparency
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font transparency. Deprecated.
ForeColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font foreground color. Deprecated.
IsDrawDone
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether the blit is done, and returns true if the last blit on this surface has completed. Deprecated.
IsFlipDone
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether the flip has finished, and returns true if the last flip on this surface has completed. Deprecated.
IsLost
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines whether the surface memory associated with a DirectDrawSurface object has been freed. Deprecated.
Palette
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Palette object associated with this surface. Deprecated.
PixelFormat
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the color and pixel format of the surface. Deprecated.
SurfaceDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a description of the surface in its current condition. Deprecated.
UniquenessValue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the current uniqueness value for this surface. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Surface

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Surface.ChangeUniquenessValue() Method (Microsoft.DirectX.DirectDraw)

Surface.ChangeUniquenessValue Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Manually updates the uniqueness value for this surface. Deprecated.

Definition

Visual Basic | Public Sub ChangeUniquenessValue()
C# | public void ChangeUniquenessValue();
C++ public:
void ChangeUniquenessValue();
JScript | public function ChangeUniquenessValue();


Surface.Clone() Method (Microsoft.DirectX.DirectDraw)

Surface.Clone Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Duplicates the object. Deprecated.

Definition

Visual Basic | Overrides Public Function Clone() As Object
C# | public override object Clone();
C++ public:
virtual Object^ Clone() override;
JScript | public override function Clone() : Object;

Return Value

System.Object


Surface.ColorFill Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Overload List

public void ColorFill(Color);
public void ColorFill(int);
public void ColorFill(Rectangle, Color);
public void ColorFill(Rectangle, int);


Surface.ColorFill(Color) Method (Microsoft.DirectX.DirectDraw)

Surface.ColorFill Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Definition

Visual Basic Public Sub ColorFill( _
ByVal fillValue As Color _
)
C# public void ColorFill(
Color fillValue
);
C++ public:
void ColorFill(
Color fillValue
);
JScript public function ColorFill(
fillValue : Color
);

Parameters

fillValue System.Drawing.Color


Surface.ColorFill(Rectangle,Color) Method (Microsoft.DirectX.DirectDraw)

Surface.ColorFill Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Definition

Visual Basic Public Sub ColorFill( _
ByVal destRectangle As Rectangle, _
ByVal fillValue As Color _
)
C# public void ColorFill(
Rectangle destRectangle,
Color fillValue
);
C++ public:
void ColorFill(
Rectangle destRectangle,
Color fillValue
);
JScript public function ColorFill(
destRectangle : Rectangle,
fillValue : Color
);

Parameters

destRectangle System.Drawing.Rectangle
fillValue System.Drawing.Color


Surface.ColorFill(Int32) Method (Microsoft.DirectX.DirectDraw)

Surface.ColorFill Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Definition

Visual Basic Public Sub ColorFill( _
ByVal fillValue As Integer _
)
C# public void ColorFill(
int fillValue
);
C++ public:
void ColorFill(
int fillValue
);
JScript public function ColorFill(
fillValue : int
);

Parameters

fillValue System.Int32


Surface.ColorFill(Rectangle,Int32) Method (Microsoft.DirectX.DirectDraw)

Surface.ColorFill Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Fills a surface with a color. Deprecated.

Definition

Visual Basic Public Sub ColorFill( _
ByVal destRectangle As Rectangle, _
ByVal fillValue As Integer _
)
C# public void ColorFill(
Rectangle destRectangle,
int fillValue
);
C++ public:
void ColorFill(
Rectangle destRectangle,
int fillValue
);
JScript public function ColorFill(
destRectangle : Rectangle,
fillValue : int
);

Parameters

destRectangle System.Drawing.Rectangle
fillValue System.Int32


Surface.Dispose() Method (Microsoft.DirectX.DirectDraw)

Surface.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Surface();
JScript | public override function Dispose();


Surface.Draw Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Overload List

public void Draw(Rectangle, Surface, DrawFlags);
public void Draw(Rectangle, Surface, DrawFlags, DrawEffects);
public void Draw(Rectangle, Surface, Rectangle, DrawFlags);
public void Draw(Rectangle, Surface, Rectangle, DrawFlags, DrawEffects);
public void Draw(Surface, DrawFlags);
public void Draw(Surface, DrawFlags, DrawEffects);
public void Draw(Surface, Rectangle, DrawFlags);
public void Draw(Surface, Rectangle, DrawFlags, DrawEffects);


Surface.Draw(Surface,DrawFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.Draw Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic Public Sub Draw( _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFlags _
)
C# public void Draw(
Surface sourceSurface,
DrawFlags flags
);
C++ public:
void Draw(
Surface^ sourceSurface,
DrawFlags flags
);
JScript public function Draw(
sourceSurface : Surface,
flags : DrawFlags
);

Parameters

sourceSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.DrawFlags


Surface.Draw(Rectangle,Surface,DrawFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.Draw Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic Public Sub Draw( _
ByVal destRectangle As Rectangle, _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFlags _
)
C# public void Draw(
Rectangle destRectangle,
Surface sourceSurface,
DrawFlags flags
);
C++ public:
void Draw(
Rectangle destRectangle,
Surface^ sourceSurface,
DrawFlags flags
);
JScript public function Draw(
destRectangle : Rectangle,
sourceSurface : Surface,
flags : DrawFlags
);

Parameters

destRectangle System.Drawing.Rectangle
sourceSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.DrawFlags


Surface.Draw(Surface,Rectangle,DrawFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.Draw Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic Public Sub Draw( _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFlags _
)
C# public void Draw(
Surface sourceSurface,
Rectangle srcRectangle,
DrawFlags flags
);
C++ public:
void Draw(
Surface^ sourceSurface,
Rectangle srcRectangle,
DrawFlags flags
);
JScript public function Draw(
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFlags
);

Parameters

sourceSurface Microsoft.DirectX.DirectDraw.Surface
srcRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.DrawFlags


Surface.Draw(Rectangle,Surface,Rectangle,DrawFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.Draw Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic Public Sub Draw( _
ByVal destRectangle As Rectangle, _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFlags _
)
C# public void Draw(
Rectangle destRectangle,
Surface sourceSurface,
Rectangle srcRectangle,
DrawFlags flags
);
C++ public:
void Draw(
Rectangle destRectangle,
Surface^ sourceSurface,
Rectangle srcRectangle,
DrawFlags flags
);
JScript public function Draw(
destRectangle : Rectangle,
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFlags
);

Parameters

destRectangle System.Drawing.Rectangle
sourceSurface Microsoft.DirectX.DirectDraw.Surface
srcRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.DrawFlags


Surface.Draw(Surface,DrawFlags,DrawEffects) Method (Microsoft.DirectX.DirectDraw)

Surface.Draw Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic Public Sub Draw( _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFlags, _
ByVal bltEffects As DrawEffects _
)
C# public void Draw(
Surface sourceSurface,
DrawFlags flags,
DrawEffects bltEffects
);
C++ public:
void Draw(
Surface^ sourceSurface,
DrawFlags flags,
DrawEffects bltEffects
);
JScript public function Draw(
sourceSurface : Surface,
flags : DrawFlags,
bltEffects : DrawEffects
);

Parameters

sourceSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.DrawFlags
bltEffects Microsoft.DirectX.DirectDraw.DrawEffects


Surface.Draw(Rectangle,Surface,DrawFlags,DrawEffects) Method (Microsoft.DirectX.DirectDraw)

Surface.Draw Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic Public Sub Draw( _
ByVal destRectangle As Rectangle, _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFlags, _
ByVal bltEffects As DrawEffects _
)
C# public void Draw(
Rectangle destRectangle,
Surface sourceSurface,
DrawFlags flags,
DrawEffects bltEffects
);
C++ public:
void Draw(
Rectangle destRectangle,
Surface^ sourceSurface,
DrawFlags flags,
DrawEffects bltEffects
);
JScript public function Draw(
destRectangle : Rectangle,
sourceSurface : Surface,
flags : DrawFlags,
bltEffects : DrawEffects
);

Parameters

destRectangle System.Drawing.Rectangle
sourceSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.DrawFlags
bltEffects Microsoft.DirectX.DirectDraw.DrawEffects


Surface.Draw(Surface,Rectangle,DrawFlags,DrawEffects) Method (Microsoft.DirectX.DirectDraw)

Surface.Draw Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic Public Sub Draw( _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFlags, _
ByVal bltEffects As DrawEffects _
)
C# public void Draw(
Surface sourceSurface,
Rectangle srcRectangle,
DrawFlags flags,
DrawEffects bltEffects
);
C++ public:
void Draw(
Surface^ sourceSurface,
Rectangle srcRectangle,
DrawFlags flags,
DrawEffects bltEffects
);
JScript public function Draw(
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFlags,
bltEffects : DrawEffects
);

Parameters

sourceSurface Microsoft.DirectX.DirectDraw.Surface
srcRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.DrawFlags
bltEffects Microsoft.DirectX.DirectDraw.DrawEffects


Surface.Draw(Rectangle,Surface,Rectangle,DrawFlags,DrawEffects) Method (Microsoft.DirectX.DirectDraw)

Surface.Draw Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a bit block transfer (blit). Deprecated.

Definition

Visual Basic Public Sub Draw( _
ByVal destRectangle As Rectangle, _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFlags, _
ByVal bltEffects As DrawEffects _
)
C# public void Draw(
Rectangle destRectangle,
Surface sourceSurface,
Rectangle srcRectangle,
DrawFlags flags,
DrawEffects bltEffects
);
C++ public:
void Draw(
Rectangle destRectangle,
Surface^ sourceSurface,
Rectangle srcRectangle,
DrawFlags flags,
DrawEffects bltEffects
);
JScript public function Draw(
destRectangle : Rectangle,
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFlags,
bltEffects : DrawEffects
);

Parameters

destRectangle System.Drawing.Rectangle
sourceSurface Microsoft.DirectX.DirectDraw.Surface
srcRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.DrawFlags
bltEffects Microsoft.DirectX.DirectDraw.DrawEffects


Surface.DrawBox(Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawBox Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic Public Sub DrawBox( _
ByVal left As Integer, _
ByVal top As Integer, _
ByVal right As Integer, _
ByVal bottom As Integer _
)
C# public void DrawBox(
int left,
int top,
int right,
int bottom
);
C++ public:
void DrawBox(
int left,
int top,
int right,
int bottom
);
JScript public function DrawBox(
left : int,
top : int,
right : int,
bottom : int
);

Parameters

left System.Int32
top System.Int32
right System.Int32
bottom System.Int32


Surface.DrawCircle(Int32,Int32,Int32) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawCircle Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic Public Sub DrawCircle( _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal radius As Integer _
)
C# public void DrawCircle(
int x,
int y,
int radius
);
C++ public:
void DrawCircle(
int x,
int y,
int radius
);
JScript public function DrawCircle(
x : int,
y : int,
radius : int
);

Parameters

x System.Int32
y System.Int32
radius System.Int32


Surface.DrawEllipse(Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawEllipse Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic Public Sub DrawEllipse( _
ByVal x1 As Integer, _
ByVal y1 As Integer, _
ByVal x2 As Integer, _
ByVal y2 As Integer _
)
C# public void DrawEllipse(
int x1,
int y1,
int x2,
int y2
);
C++ public:
void DrawEllipse(
int x1,
int y1,
int x2,
int y2
);
JScript public function DrawEllipse(
x1 : int,
y1 : int,
x2 : int,
y2 : int
);

Parameters

x1 System.Int32
y1 System.Int32
x2 System.Int32
y2 System.Int32


Surface.DrawFast Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a source copy blit or transparent blit by using a source color key or destination color key. Deprecated.

Overload List

public void DrawFast(int, int, Surface, DrawFastFlags);
public void DrawFast(int, int, Surface, Rectangle, DrawFastFlags);


Surface.DrawFast(Int32,Int32,Surface,DrawFastFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawFast Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a source copy blit or transparent blit by using a source color key or destination color key. Deprecated.

Definition

Visual Basic Public Sub DrawFast( _
ByVal xcoord As Integer, _
ByVal ycoord As Integer, _
ByVal sourceSurface As Surface, _
ByVal flags As DrawFastFlags _
)
C# public void DrawFast(
int xcoord,
int ycoord,
Surface sourceSurface,
DrawFastFlags flags
);
C++ public:
void DrawFast(
int xcoord,
int ycoord,
Surface^ sourceSurface,
DrawFastFlags flags
);
JScript public function DrawFast(
xcoord : int,
ycoord : int,
sourceSurface : Surface,
flags : DrawFastFlags
);

Parameters

xcoord System.Int32
ycoord System.Int32
sourceSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.DrawFastFlags


Surface.DrawFast(Int32,Int32,Surface,Rectangle,DrawFastFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawFast Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs a source copy blit or transparent blit by using a source color key or destination color key. Deprecated.

Definition

Visual Basic Public Sub DrawFast( _
ByVal xcoord As Integer, _
ByVal ycoord As Integer, _
ByVal sourceSurface As Surface, _
ByVal srcRectangle As Rectangle, _
ByVal flags As DrawFastFlags _
)
C# public void DrawFast(
int xcoord,
int ycoord,
Surface sourceSurface,
Rectangle srcRectangle,
DrawFastFlags flags
);
C++ public:
void DrawFast(
int xcoord,
int ycoord,
Surface^ sourceSurface,
Rectangle srcRectangle,
DrawFastFlags flags
);
JScript public function DrawFast(
xcoord : int,
ycoord : int,
sourceSurface : Surface,
srcRectangle : Rectangle,
flags : DrawFastFlags
);

Parameters

xcoord System.Int32
ycoord System.Int32
sourceSurface Microsoft.DirectX.DirectDraw.Surface
srcRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.DrawFastFlags


Surface.DrawLine(Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawLine Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic Public Sub DrawLine( _
ByVal x1 As Integer, _
ByVal y1 As Integer, _
ByVal x2 As Integer, _
ByVal y2 As Integer _
)
C# public void DrawLine(
int x1,
int y1,
int x2,
int y2
);
C++ public:
void DrawLine(
int x1,
int y1,
int x2,
int y2
);
JScript public function DrawLine(
x1 : int,
y1 : int,
x2 : int,
y2 : int
);

Parameters

x1 System.Int32
y1 System.Int32
x2 System.Int32
y2 System.Int32


Surface.DrawRoundedBox(Int32,Int32,Int32,Int32,Int32,Int32) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawRoundedBox Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic Public Sub DrawRoundedBox( _
ByVal left As Integer, _
ByVal top As Integer, _
ByVal right As Integer, _
ByVal bottom As Integer, _
ByVal rw As Integer, _
ByVal rh As Integer _
)
C# public void DrawRoundedBox(
int left,
int top,
int right,
int bottom,
int rw,
int rh
);
C++ public:
void DrawRoundedBox(
int left,
int top,
int right,
int bottom,
int rw,
int rh
);
JScript public function DrawRoundedBox(
left : int,
top : int,
right : int,
bottom : int,
rw : int,
rh : int
);

Parameters

left System.Int32
top System.Int32
right System.Int32
bottom System.Int32
rw System.Int32
rh System.Int32


Surface.DrawText(Int32,Int32,String,Boolean) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawText Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic Public Sub DrawText( _
ByVal x As Integer, _
ByVal y As Integer, _
ByVal text As String, _
ByVal drawAtLastPosition As Boolean _
)
C# public void DrawText(
int x,
int y,
string text,
bool drawAtLastPosition
);
C++ public:
void DrawText(
int x,
int y,
String^ text,
bool drawAtLastPosition
);
JScript public function DrawText(
x : int,
y : int,
text : String,
drawAtLastPosition : boolean
);

Parameters

x System.Int32
y System.Int32
text System.String
drawAtLastPosition System.Boolean


Surface.DrawToDc(IntPtr,Rectangle,Rectangle) Method (Microsoft.DirectX.DirectDraw)

Surface.DrawToDc Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic Public Sub DrawToDc( _
ByVal hdc As IntPtr, _
ByVal destRect As Rectangle, _
ByVal srcRect As Rectangle _
)
C# public void DrawToDc(
IntPtr hdc,
Rectangle destRect,
Rectangle srcRect
);
C++ public:
void DrawToDc(
IntPtr hdc,
Rectangle destRect,
Rectangle srcRect
);
JScript public function DrawToDc(
hdc : IntPtr,
destRect : Rectangle,
srcRect : Rectangle
);

Parameters

hdc System.IntPtr
destRect System.Drawing.Rectangle
srcRect System.Drawing.Rectangle


Surface.Equals(Object) Method (Microsoft.DirectX.DirectDraw)

Surface.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Surface.Finalize() Method (Microsoft.DirectX.DirectDraw)

Surface.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Surface();
C++ | !Surface();
JScript | protected override function Finalize();


Surface.Flip(Surface,FlipFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.Flip Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes the surface memory associated with the BackBuffer surface become associated with the front-buffer surface. Deprecated.

Definition

Visual Basic Public Sub Flip( _
ByVal surface As Surface, _
ByVal flags As FlipFlags _
)
C# public void Flip(
Surface surface,
FlipFlags flags
);
C++ public:
void Flip(
Surface^ surface,
FlipFlags flags
);
JScript public function Flip(
surface : Surface,
flags : FlipFlags
);

Parameters

surface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.FlipFlags


Surface.GetAttachedSurface(SurfaceCaps) Method (Microsoft.DirectX.DirectDraw)

Surface.GetAttachedSurface Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains the attached surface that has the specified capabilities. Deprecated.

Definition

Visual Basic Public Function GetAttachedSurface( _
ByVal caps As SurfaceCaps _
) As Surface
C# public Surface GetAttachedSurface(
SurfaceCaps caps
);
C++ public:
Surface^ GetAttachedSurface(
SurfaceCaps^ caps
);
JScript public function GetAttachedSurface(
caps : SurfaceCaps
) : Surface;

Parameters

caps Microsoft.DirectX.DirectDraw.SurfaceCaps

Return Value

Microsoft.DirectX.DirectDraw.Surface


Surface.GetColorKey(ColorKeyFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.GetColorKey Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the color key value for the DirectDrawSurface object. Deprecated.

Definition

Visual Basic Public Function GetColorKey( _
ByVal flags As ColorKeyFlags _
) As ColorKey
C# public ColorKey GetColorKey(
ColorKeyFlags flags
);
C++ public:
ColorKey GetColorKey(
ColorKeyFlags flags
);
JScript public function GetColorKey(
flags : ColorKeyFlags
) : ColorKey;

Parameters

flags Microsoft.DirectX.DirectDraw.ColorKeyFlags

Return Value

Microsoft.DirectX.DirectDraw.ColorKey


Surface.GetDc() Method (Microsoft.DirectX.DirectDraw)

Surface.GetDc Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a device context. Deprecated.

Definition

Visual Basic | Public Function GetDc() As IntPtr
C# | public IntPtr GetDc();
C++ public:
IntPtr GetDc();
JScript | public function GetDc() : IntPtr;

Return Value

System.IntPtr


Surface.GetHashCode() Method (Microsoft.DirectX.DirectDraw)

Surface.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Surface.GetOverlayPosition() Method (Microsoft.DirectX.DirectDraw)

Surface.GetOverlayPosition Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Given a visible, active overlay surface, the GetOverlayPosition method returns the display coordinates of the surface Deprecated.

Definition

Visual Basic | Public Function GetOverlayPosition() As Point
C# | public Point GetOverlayPosition();
C++ public:
Point GetOverlayPosition();
JScript | public function GetOverlayPosition() : Point;

Return Value

System.Drawing.Point


Surface.Lock Method ()

Allows manipulation of surface memory.

Overload List

public LockedData Lock(LockFlags);
public LockedData Lock(Rectangle, LockFlags);


Surface.Lock(LockFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.Lock Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Allows manipulation of surface memory. Deprecated.

Definition

Visual Basic Public Function Lock( _
ByVal flags As LockFlags _
) As LockedData
C# public LockedData Lock(
LockFlags flags
);
C++ public:
LockedData Lock(
LockFlags flags
);
JScript public function Lock(
flags : LockFlags
) : LockedData;

Parameters

flags Microsoft.DirectX.DirectDraw.LockFlags

Return Value

Microsoft.DirectX.DirectDraw.LockedData


Surface.Lock(Rectangle,LockFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.Lock Method

Allows manipulation of surface memory.

Definition

Visual Basic Public Function Lock( _
ByVal destRectangle As Rectangle, _
ByVal flags As LockFlags _
) As LockedData
C# public LockedData Lock(
Rectangle destRectangle,
LockFlags flags
);
C++ public:
LockedData Lock(
Rectangle destRectangle,
LockFlags flags
);
JScript public function Lock(
destRectangle : Rectangle,
flags : LockFlags
) : LockedData;

Parameters

destRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.LockFlags

Return Value

Microsoft.DirectX.DirectDraw.LockedData


Surface.op_Equality(Surface,Surface) Method (Microsoft.DirectX.DirectDraw)

Surface.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Surface, _
ByVal right As Surface _
) As Boolean
C# public static bool op_Equality(
Surface left,
Surface right
);
C++ public:
static bool operator==(
Surface^ left,
Surface^ right
);
JScript public static function op_Equality(
left : Surface,
right : Surface
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.Surface
The Surface structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.Surface
The Surface structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Surface.op_Inequality(Surface,Surface) Method (Microsoft.DirectX.DirectDraw)

Surface.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Surface, _
ByVal right As Surface _
) As Boolean
C# public static bool op_Inequality(
Surface left,
Surface right
);
C++ public:
static bool operator!=(
Surface^ left,
Surface^ right
);
JScript public static function op_Inequality(
left : Surface,
right : Surface
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.Surface
The Surface structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.Surface
The Surface structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Surface.PageLock() Method (Microsoft.DirectX.DirectDraw)

Surface.PageLock Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Prevents a system-memory surface from being paged out while a blit operation that uses direct memory access (DMA) transfers to or from system memory is in progress. Deprecated.

Definition

Visual Basic | Public Sub PageLock()
C# | public void PageLock();
C++ public:
void PageLock();
JScript | public function PageLock();


Surface.PageUnlock() Method (Microsoft.DirectX.DirectDraw)

Surface.PageUnlock Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unlocks a system-memory surface, allowing it to be paged out. Deprecated.

Definition

Visual Basic | Public Sub PageUnlock()
C# | public void PageUnlock();
C++ public:
void PageUnlock();
JScript | public function PageUnlock();


Surface.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectDraw)

Surface.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Surface.ReleaseDc(IntPtr) Method (Microsoft.DirectX.DirectDraw)

Surface.ReleaseDc Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Release a device context handle. Deprecated.

Definition

Visual Basic Public Sub ReleaseDc( _
ByVal hdc As IntPtr _
)
C# public void ReleaseDc(
IntPtr hdc
);
C++ public:
void ReleaseDc(
IntPtr hdc
);
JScript public function ReleaseDc(
hdc : IntPtr
);

Parameters

hdc System.IntPtr


Surface.Restore() Method (Microsoft.DirectX.DirectDraw)

Surface.Restore Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Restores a surface that has been lost. This occurs when the surface memory associated with the DirectDrawSurface object has been freed. Deprecated.

Definition

Visual Basic | Public Sub Restore()
C# | public void Restore();
C++ public:
void Restore();
JScript | public function Restore();


Surface.SetColorKey(ColorKeyFlags,ColorKey) Method (Microsoft.DirectX.DirectDraw)

Surface.SetColorKey Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the color key value for the DirectDrawSurface object if the hardware supports color keys on a per-surface basis. Deprecated.

Definition

Visual Basic Public Sub SetColorKey( _
ByVal flags As ColorKeyFlags, _
ByVal value As ColorKey _
)
C# public void SetColorKey(
ColorKeyFlags flags,
ColorKey value
);
C++ public:
void SetColorKey(
ColorKeyFlags flags,
ColorKey value
);
JScript public function SetColorKey(
flags : ColorKeyFlags,
value : ColorKey
);

Parameters

flags Microsoft.DirectX.DirectDraw.ColorKeyFlags
value Microsoft.DirectX.DirectDraw.ColorKey


Surface.SetOverlayPosition(Point) Method (Microsoft.DirectX.DirectDraw)

Surface.SetOverlayPosition Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes the display coordinates of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub SetOverlayPosition( _
ByVal position As Point _
)
C# public void SetOverlayPosition(
Point position
);
C++ public:
void SetOverlayPosition(
Point position
);
JScript public function SetOverlayPosition(
position : Point
);

Parameters

position System.Drawing.Point


Surface.Surface Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Surface(Bitmap, SurfaceDescription, Device);
public Surface(Stream, SurfaceDescription, Device);
public Surface(string, SurfaceDescription, Device);
public Surface(SurfaceDescription, Device);


Surface.Surface(Stream,SurfaceDescription,Device) Constructor (Microsoft.DirectX.DirectDraw)

Surface.Surface Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public Surface(
Stream source,
SurfaceDescription desc,
Device dev
);
C++ public:
Surface(
Stream^ source,
SurfaceDescription^ desc,
Device^ dev
);
JScript public function Surface(
source : Stream,
desc : SurfaceDescription,
dev : Device
);

Parameters

source System.IO.Stream
desc Microsoft.DirectX.DirectDraw.SurfaceDescription
dev Microsoft.DirectX.DirectDraw.Device


Surface.Surface(Bitmap,SurfaceDescription,Device) Constructor (Microsoft.DirectX.DirectDraw)

Surface.Surface Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal source As Bitmap, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public Surface(
Bitmap source,
SurfaceDescription desc,
Device dev
);
C++ public:
Surface(
Bitmap^ source,
SurfaceDescription^ desc,
Device^ dev
);
JScript public function Surface(
source : Bitmap,
desc : SurfaceDescription,
dev : Device
);

Parameters

source System.Drawing.Bitmap
desc Microsoft.DirectX.DirectDraw.SurfaceDescription
dev Microsoft.DirectX.DirectDraw.Device


Surface.Surface(String,SurfaceDescription,Device) Constructor (Microsoft.DirectX.DirectDraw)

Surface.Surface Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal filename As String, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public Surface(
string filename,
SurfaceDescription desc,
Device dev
);
C++ public:
Surface(
String^ filename,
SurfaceDescription^ desc,
Device^ dev
);
JScript public function Surface(
filename : String,
desc : SurfaceDescription,
dev : Device
);

Parameters

filename System.String
desc Microsoft.DirectX.DirectDraw.SurfaceDescription
dev Microsoft.DirectX.DirectDraw.Device


Surface.Surface(SurfaceDescription,Device) Constructor (Microsoft.DirectX.DirectDraw)

Surface.Surface Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public Surface(
SurfaceDescription desc,
Device dev
);
C++ public:
Surface(
SurfaceDescription^ desc,
Device^ dev
);
JScript public function Surface(
desc : SurfaceDescription,
dev : Device
);

Parameters

desc Microsoft.DirectX.DirectDraw.SurfaceDescription
dev Microsoft.DirectX.DirectDraw.Device


Surface.Unlock Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Overload List

public void Unlock();
public void Unlock(Rectangle);


Surface.Unlock() Method (Microsoft.DirectX.DirectDraw)

Surface.Unlock Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Sub Unlock()
C# | public void Unlock();
C++ public:
void Unlock();
JScript | public function Unlock();


Surface.Unlock(Rectangle) Method (Microsoft.DirectX.DirectDraw)

Surface.Unlock Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub Unlock( _
ByVal destRectangle As Rectangle _
)
C# public void Unlock(
Rectangle destRectangle
);
C++ public:
void Unlock(
Rectangle destRectangle
);
JScript public function Unlock(
destRectangle : Rectangle
);

Parameters

destRectangle System.Drawing.Rectangle


Surface.UpdateOverlay Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Overload List

public void UpdateOverlay(Rectangle, Surface, OverlayFlags);
public void UpdateOverlay(Rectangle, Surface, OverlayFlags, OverlayEffects);
public void UpdateOverlay(Rectangle, Surface, Rectangle, OverlayFlags);
public void UpdateOverlay(Rectangle, Surface, Rectangle, OverlayFlags, OverlayEffects);
public void UpdateOverlay(Surface, OverlayFlags);
public void UpdateOverlay(Surface, OverlayFlags, OverlayEffects);
public void UpdateOverlay(Surface, Rectangle, OverlayFlags);
public void UpdateOverlay(Surface, Rectangle, OverlayFlags, OverlayEffects);


Surface.UpdateOverlay(Surface,OverlayFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlay( _
ByVal destSurface As Surface, _
ByVal flags As OverlayFlags _
)
C# public void UpdateOverlay(
Surface destSurface,
OverlayFlags flags
);
C++ public:
void UpdateOverlay(
Surface^ destSurface,
OverlayFlags flags
);
JScript public function UpdateOverlay(
destSurface : Surface,
flags : OverlayFlags
);

Parameters

destSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.OverlayFlags


Surface.UpdateOverlay(Rectangle,Surface,OverlayFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlay( _
ByVal srcRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal flags As OverlayFlags _
)
C# public void UpdateOverlay(
Rectangle srcRectangle,
Surface destSurface,
OverlayFlags flags
);
C++ public:
void UpdateOverlay(
Rectangle srcRectangle,
Surface^ destSurface,
OverlayFlags flags
);
JScript public function UpdateOverlay(
srcRectangle : Rectangle,
destSurface : Surface,
flags : OverlayFlags
);

Parameters

srcRectangle System.Drawing.Rectangle
destSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.OverlayFlags


Surface.UpdateOverlay(Surface,Rectangle,OverlayFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlay( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal flags As OverlayFlags _
)
C# public void UpdateOverlay(
Surface destSurface,
Rectangle destRectangle,
OverlayFlags flags
);
C++ public:
void UpdateOverlay(
Surface^ destSurface,
Rectangle destRectangle,
OverlayFlags flags
);
JScript public function UpdateOverlay(
destSurface : Surface,
destRectangle : Rectangle,
flags : OverlayFlags
);

Parameters

destSurface Microsoft.DirectX.DirectDraw.Surface
destRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.OverlayFlags


Surface.UpdateOverlay(Rectangle,Surface,Rectangle,OverlayFlags) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlay( _
ByVal srcRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal flags As OverlayFlags _
)
C# public void UpdateOverlay(
Rectangle srcRectangle,
Surface destSurface,
Rectangle destRectangle,
OverlayFlags flags
);
C++ public:
void UpdateOverlay(
Rectangle srcRectangle,
Surface^ destSurface,
Rectangle destRectangle,
OverlayFlags flags
);
JScript public function UpdateOverlay(
srcRectangle : Rectangle,
destSurface : Surface,
destRectangle : Rectangle,
flags : OverlayFlags
);

Parameters

srcRectangle System.Drawing.Rectangle
destSurface Microsoft.DirectX.DirectDraw.Surface
destRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.OverlayFlags


Surface.UpdateOverlay(Surface,OverlayFlags,OverlayEffects) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlay( _
ByVal destSurface As Surface, _
ByVal flags As OverlayFlags, _
ByVal effects As OverlayEffects _
)
C# public void UpdateOverlay(
Surface destSurface,
OverlayFlags flags,
OverlayEffects effects
);
C++ public:
void UpdateOverlay(
Surface^ destSurface,
OverlayFlags flags,
OverlayEffects effects
);
JScript public function UpdateOverlay(
destSurface : Surface,
flags : OverlayFlags,
effects : OverlayEffects
);

Parameters

destSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.OverlayFlags
effects Microsoft.DirectX.DirectDraw.OverlayEffects


Surface.UpdateOverlay(Rectangle,Surface,OverlayFlags,OverlayEffects) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlay( _
ByVal srcRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal flags As OverlayFlags, _
ByVal effects As OverlayEffects _
)
C# public void UpdateOverlay(
Rectangle srcRectangle,
Surface destSurface,
OverlayFlags flags,
OverlayEffects effects
);
C++ public:
void UpdateOverlay(
Rectangle srcRectangle,
Surface^ destSurface,
OverlayFlags flags,
OverlayEffects effects
);
JScript public function UpdateOverlay(
srcRectangle : Rectangle,
destSurface : Surface,
flags : OverlayFlags,
effects : OverlayEffects
);

Parameters

srcRectangle System.Drawing.Rectangle
destSurface Microsoft.DirectX.DirectDraw.Surface
flags Microsoft.DirectX.DirectDraw.OverlayFlags
effects Microsoft.DirectX.DirectDraw.OverlayEffects


Surface.UpdateOverlay(Surface,Rectangle,OverlayFlags,OverlayEffects) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlay( _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal flags As OverlayFlags, _
ByVal effects As OverlayEffects _
)
C# public void UpdateOverlay(
Surface destSurface,
Rectangle destRectangle,
OverlayFlags flags,
OverlayEffects effects
);
C++ public:
void UpdateOverlay(
Surface^ destSurface,
Rectangle destRectangle,
OverlayFlags flags,
OverlayEffects effects
);
JScript public function UpdateOverlay(
destSurface : Surface,
destRectangle : Rectangle,
flags : OverlayFlags,
effects : OverlayEffects
);

Parameters

destSurface Microsoft.DirectX.DirectDraw.Surface
destRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.OverlayFlags
effects Microsoft.DirectX.DirectDraw.OverlayEffects


Surface.UpdateOverlay(Rectangle,Surface,Rectangle,OverlayFlags,OverlayEffects) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlay Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Repositions or modifies the visual attributes of an overlay surface. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlay( _
ByVal srcRectangle As Rectangle, _
ByVal destSurface As Surface, _
ByVal destRectangle As Rectangle, _
ByVal flags As OverlayFlags, _
ByVal effects As OverlayEffects _
)
C# public void UpdateOverlay(
Rectangle srcRectangle,
Surface destSurface,
Rectangle destRectangle,
OverlayFlags flags,
OverlayEffects effects
);
C++ public:
void UpdateOverlay(
Rectangle srcRectangle,
Surface^ destSurface,
Rectangle destRectangle,
OverlayFlags flags,
OverlayEffects effects
);
JScript public function UpdateOverlay(
srcRectangle : Rectangle,
destSurface : Surface,
destRectangle : Rectangle,
flags : OverlayFlags,
effects : OverlayEffects
);

Parameters

srcRectangle System.Drawing.Rectangle
destSurface Microsoft.DirectX.DirectDraw.Surface
destRectangle System.Drawing.Rectangle
flags Microsoft.DirectX.DirectDraw.OverlayFlags
effects Microsoft.DirectX.DirectDraw.OverlayEffects


Surface.UpdateOverlayZOrder(OverlayZFlags,Surface) Method (Microsoft.DirectX.DirectDraw)

Surface.UpdateOverlayZOrder Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the z-order of an overlay. Deprecated.

Definition

Visual Basic Public Sub UpdateOverlayZOrder( _
ByVal flags As OverlayZFlags, _
ByVal surface As Surface _
)
C# public void UpdateOverlayZOrder(
OverlayZFlags flags,
Surface surface
);
C++ public:
void UpdateOverlayZOrder(
OverlayZFlags flags,
Surface^ surface
);
JScript public function UpdateOverlayZOrder(
flags : OverlayZFlags,
surface : Surface
);

Parameters

flags Microsoft.DirectX.DirectDraw.OverlayZFlags
surface Microsoft.DirectX.DirectDraw.Surface


Surface.CanDraw Property (Microsoft.DirectX.DirectDraw)

Surface.CanDraw Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether a blit involving this surface can occur immediately. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CanDraw As Boolean
C# | public bool CanDraw { get; }
C++ public:
property bool CanDraw {
bool get();
}
JScript | public function get CanDraw() : boolean

Property Value

System.Boolean

This property is read-only.


Surface.CanFlip Property (Microsoft.DirectX.DirectDraw)

Surface.CanFlip Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether this surface can be flipped immediately. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CanFlip As Boolean
C# | public bool CanFlip { get; }
C++ public:
property bool CanFlip {
bool get();
}
JScript | public function get CanFlip() : boolean

Property Value

System.Boolean

This property is read-only.


Surface.Caps Property (Microsoft.DirectX.DirectDraw)

Surface.Caps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the capabilities of the surface. These capabilities are not necessarily related to the capabilities of the display device. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Caps As SurfaceCaps
C# | public SurfaceCaps Caps { get; }
C++ public:
property SurfaceCaps^ Caps {
SurfaceCaps^ get();
}
JScript | public function get Caps() : SurfaceCaps

Property Value

Microsoft.DirectX.DirectDraw.SurfaceCaps

This property is read-only.


Surface.Clipper Property (Microsoft.DirectX.DirectDraw)

Surface.Clipper Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Clipper object associated with this surface. Deprecated.

Definition

Visual Basic | Public Property Clipper As Clipper
C# | public Clipper Clipper { get; set; }
C++ public:
property Clipper^ Clipper {
Clipper^ get();
void set(Clipper^ value);
}
JScript public function get Clipper() : Clipper
public function set Clipper(Clipper);

Property Value

Microsoft.DirectX.DirectDraw.Clipper

This property is read/write.


Surface.Disposed Property (Microsoft.DirectX.DirectDraw)

Surface.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Surface.DrawDevice Property (Microsoft.DirectX.DirectDraw)

Surface.DrawDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrives the device that was used to create the surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawDevice As Device
C# | public Device DrawDevice { get; }
C++ public:
property Device^ DrawDevice {
Device^ get();
}
JScript | public function get DrawDevice() : Device

Property Value

Microsoft.DirectX.DirectDraw.Device

This property is read-only.


Surface.DrawStyle Property (Microsoft.DirectX.DirectDraw)

Surface.DrawStyle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current drawing style. Deprecated.

Definition

Visual Basic | Public Property DrawStyle As Integer
C# | public int DrawStyle { get; set; }
C++ public:
property int DrawStyle {
int get();
void set(int value);
}
JScript public function get DrawStyle() : int
public function set DrawStyle(int);

Property Value

System.Int32

This property is read/write.


Surface.DrawWidth Property (Microsoft.DirectX.DirectDraw)

Surface.DrawWidth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current draw width Deprecated.

Definition

Visual Basic | Public Property DrawWidth As Integer
C# | public int DrawWidth { get; set; }
C++ public:
property int DrawWidth {
int get();
void set(int value);
}
JScript public function get DrawWidth() : int
public function set DrawWidth(int);

Property Value

System.Int32

This property is read/write.


Surface.FillColor Property (Microsoft.DirectX.DirectDraw)

Surface.FillColor Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current fill color. Deprecated.

Definition

Visual Basic | Public Property FillColor As Color
C# | public Color FillColor { get; set; }
C++ public:
property Color FillColor {
Color get();
void set(Color value);
}
JScript public function get FillColor() : Color
public function set FillColor(Color);

Property Value

System.Drawing.Color

This property is read/write.


Surface.FillStyle Property (Microsoft.DirectX.DirectDraw)

Surface.FillStyle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current fill style. Deprecated.

Definition

Visual Basic | Public Property FillStyle As Integer
C# | public int FillStyle { get; set; }
C++ public:
property int FillStyle {
int get();
void set(int value);
}
JScript public function get FillStyle() : int
public function set FillStyle(int);

Property Value

System.Int32

This property is read/write.


Surface.FontBackColor Property (Microsoft.DirectX.DirectDraw)

Surface.FontBackColor Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font back color. Deprecated.

Definition

Visual Basic | Public Property FontBackColor As Color
C# | public Color FontBackColor { get; set; }
C++ public:
property Color FontBackColor {
Color get();
void set(Color value);
}
JScript public function get FontBackColor() : Color
public function set FontBackColor(Color);

Property Value

System.Drawing.Color

This property is read/write.


Surface.FontHandle Property (Microsoft.DirectX.DirectDraw)

Surface.FontHandle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font handle. Deprecated.

Definition

Visual Basic Public Property FontHandle( _
ByVal value As IntPtr _
) As IntPtr
C# public IntPtr this[
IntPtr value
] { set; }
C++ public:
property IntPtr FontHandle [IntPtr] {
void set(IntPtr value, IntPtr value);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

value System.IntPtr

Property Value

System.IntPtr

This property is write-only.


Surface.FontTransparency Property (Microsoft.DirectX.DirectDraw)

Surface.FontTransparency Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font transparency. Deprecated.

Definition

Visual Basic | Public Property FontTransparency As Boolean
C# | public bool FontTransparency { get; set; }
C++ public:
property bool FontTransparency {
bool get();
void set(bool value);
}
JScript public function get FontTransparency() : boolean
public function set FontTransparency(boolean);

Property Value

System.Boolean

This property is read/write.


Surface.ForeColor Property (Microsoft.DirectX.DirectDraw)

Surface.ForeColor Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current font foreground color. Deprecated.

Definition

Visual Basic | Public Property ForeColor As Color
C# | public Color ForeColor { get; set; }
C++ public:
property Color ForeColor {
Color get();
void set(Color value);
}
JScript public function get ForeColor() : Color
public function set ForeColor(Color);

Property Value

System.Drawing.Color

This property is read/write.


Surface.IsDrawDone Property (Microsoft.DirectX.DirectDraw)

Surface.IsDrawDone Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether the blit is done, and returns true if the last blit on this surface has completed. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsDrawDone As Boolean
C# | public bool IsDrawDone { get; }
C++ public:
property bool IsDrawDone {
bool get();
}
JScript | public function get IsDrawDone() : boolean

Property Value

System.Boolean

This property is read-only.


Surface.IsFlipDone Property (Microsoft.DirectX.DirectDraw)

Surface.IsFlipDone Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Inquires whether the flip has finished, and returns true if the last flip on this surface has completed. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsFlipDone As Boolean
C# | public bool IsFlipDone { get; }
C++ public:
property bool IsFlipDone {
bool get();
}
JScript | public function get IsFlipDone() : boolean

Property Value

System.Boolean

This property is read-only.


Surface.IsLost Property (Microsoft.DirectX.DirectDraw)

Surface.IsLost Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines whether the surface memory associated with a DirectDrawSurface object has been freed. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsLost As Boolean
C# | public bool IsLost { get; }
C++ public:
property bool IsLost {
bool get();
}
JScript | public function get IsLost() : boolean

Property Value

System.Boolean

This property is read-only.


Surface.Palette Property (Microsoft.DirectX.DirectDraw)

Surface.Palette Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Palette object associated with this surface. Deprecated.

Definition

Visual Basic | Public Property Palette As Palette
C# | public Palette Palette { get; set; }
C++ public:
property Palette^ Palette {
Palette^ get();
void set(Palette^ value);
}
JScript public function get Palette() : Palette
public function set Palette(Palette);

Property Value

Microsoft.DirectX.DirectDraw.Palette

This property is read/write.


Surface.PixelFormat Property (Microsoft.DirectX.DirectDraw)

Surface.PixelFormat Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the color and pixel format of the surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PixelFormat As PixelFormat
C# | public PixelFormat PixelFormat { get; }
C++ public:
property PixelFormat PixelFormat {
PixelFormat get();
}
JScript | public function get PixelFormat() : PixelFormat

Property Value

Microsoft.DirectX.DirectDraw.PixelFormat

This property is read-only.


Surface.SurfaceDescription Property (Microsoft.DirectX.DirectDraw)

Surface.SurfaceDescription Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a description of the surface in its current condition. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SurfaceDescription As SurfaceDescription
C# | public SurfaceDescription SurfaceDescription { get; }
C++ public:
property SurfaceDescription^ SurfaceDescription {
SurfaceDescription^ get();
}
JScript | public function get SurfaceDescription() : SurfaceDescription

Property Value

Microsoft.DirectX.DirectDraw.SurfaceDescription

This property is read-only.


Surface.UniquenessValue Property (Microsoft.DirectX.DirectDraw)

Surface.UniquenessValue Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the current uniqueness value for this surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property UniquenessValue As Integer
C# | public int UniquenessValue { get; }
C++ public:
property int UniquenessValue {
int get();
}
JScript | public function get UniquenessValue() : int

Property Value

System.Int32

This property is read-only.


Surface.Disposing Event (Microsoft.DirectX.DirectDraw)

Surface.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Surface.Disposing event, use the following code.

surface.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


SurfaceBusyException Class (Microsoft.DirectX.DirectDraw)

SurfaceBusyException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface is locked by another thread. Deprecated.

Definition

Visual Basic Public Class SurfaceBusyException
Inherits GraphicsException
C# | public class SurfaceBusyException : GraphicsException
C++ | public ref class SurfaceBusyException : GraphicsException
JScript | public class SurfaceBusyException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SurfaceBusyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
SurfaceBusyException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfaceBusyException.SurfaceBusyException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceBusyException();
protected SurfaceBusyException(SerializationInfo, StreamingContext);
public SurfaceBusyException(string);
public SurfaceBusyException(string, Exception);


SurfaceBusyException.SurfaceBusyException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceBusyException.SurfaceBusyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SurfaceBusyException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SurfaceBusyException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SurfaceBusyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SurfaceBusyException.SurfaceBusyException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceBusyException.SurfaceBusyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SurfaceBusyException(
string message,
Exception inner
);
C++ public:
SurfaceBusyException(
String^ message,
Exception^ inner
);
JScript public function SurfaceBusyException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SurfaceBusyException.SurfaceBusyException(String) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceBusyException.SurfaceBusyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SurfaceBusyException(
string message
);
C++ public:
SurfaceBusyException(
String^ message
);
JScript public function SurfaceBusyException(
message : String
);

Parameters

message System.String


SurfaceBusyException.SurfaceBusyException() Constructor (Microsoft.DirectX.DirectDraw)

SurfaceBusyException.SurfaceBusyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SurfaceBusyException();
C++ public:
SurfaceBusyException();
JScript | public function SurfaceBusyException();


SurfaceCaps Class (Microsoft.DirectX.DirectDraw)

SurfaceCaps Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Defines the capabilities of a DirectDrawSurface object. Deprecated.

Definition

Visual Basic NotInheritable Public Class SurfaceCaps
Inherits Object
C# | public sealed class SurfaceCaps : Object
C++ | public ref class SurfaceCaps sealed : Object
JScript | public final class SurfaceCaps extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Clear
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Remove all set capabilities. Deprecated.
SurfaceCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
Alpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface contains alpha-only information. Deprecated.
BackBuffer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is the back buffer of a surface flipping structure. Deprecated.
Complex
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A complex surface is being described. A complex surface results in the creation of more than one surface. The additional surfaces are attached to the root surface. The complex surface can be destroyed only by destroying the root. Deprecated.
Flip
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a part of a surface-flipping structure. Deprecated.
FrontBuffer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is the front buffer of a surface-flipping structure. Deprecated.
HardwareCodec
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can have a stream decompressed to it by the hardware. Deprecated.
LiveVideo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can receive live video. Deprecated.
LocalVideoMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in true, local video memory, rather than nonlocal video memory. If this flag is specified, VideoMemory must be specified, as well. This flag cannot be used with the NonLocalVideoMemory flag. Deprecated.
ModeX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a 320×200 or 320×240 Mode X surface. Deprecated.
NonLocalVideoMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in nonlocal video memory, rather than true, local video memory. If this flag is specified, VideoMemory flag must be specified, as well. This cannot be used with the LocalVideoMemory flag. Deprecated.
OffScreenPlain
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is any off-screen surface that is not an overlay, front-buffer, back-buffer, or alpha surface. It is used to identify plain surfaces. Deprecated.
Overlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is an overlay. It might or might not be directly visible, depending on whether it is currently being overlaid onto the primary surface. Deprecated.
OwnGraphics
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface has a device context (DC) association for a long period of time. Deprecated.
Palette
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This device driver allows unique DirectDrawPalette objects to be created and attached to this surface. Deprecated.
PrimarySurface
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is the primary surface. It represents what is currently visible. Deprecated.
StandardVgaMode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a standard VGA mode surface, and not a Mode X surface. This flag cannot be used in combination with the ModeX flag. Deprecated.
StereoSurfaceLeft
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is part of a stereo flipping chain. Deprecated.
SystemMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface memory was allocated in system memory. Deprecated.
VideoMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in display memory. Deprecated.
VideoPort
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can receive data from a video port. Deprecated.
Visible
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes made to this surface are immediately visible. It is always set for the primary surface, as well as for overlays while they are being overlaid and texture maps while they are being textured. Deprecated.
WriteAccessOnly
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Only write access is permitted to the surface. Read access from the surface can cause a general protection (GP) fault, and the read results from this surface would not be meaningful. Deprecated.

Inheritance Hierarchy

Object Leave Site
SurfaceCaps

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfaceCaps.Clear() Method (Microsoft.DirectX.DirectDraw)

SurfaceCaps.Clear Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Remove all set capabilities. Deprecated.

Definition

Visual Basic | Public Sub Clear()
C# | public void Clear();
C++ public:
void Clear();
JScript | public function Clear();


SurfaceCaps.SurfaceCaps() Constructor (Microsoft.DirectX.DirectDraw)

SurfaceCaps.SurfaceCaps Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SurfaceCaps();
C++ public:
SurfaceCaps();
JScript | public function SurfaceCaps();


SurfaceCaps.Alpha Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.Alpha Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface contains alpha-only information. Deprecated.

Definition

Visual Basic | Public Property Alpha As Boolean
C# | public bool Alpha { get; set; }
C++ public:
property bool Alpha {
bool get();
void set(bool value);
}
JScript public function get Alpha() : boolean
public function set Alpha(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.BackBuffer Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.BackBuffer Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is the back buffer of a surface flipping structure. Deprecated.

Definition

Visual Basic | Public Property BackBuffer As Boolean
C# | public bool BackBuffer { get; set; }
C++ public:
property bool BackBuffer {
bool get();
void set(bool value);
}
JScript public function get BackBuffer() : boolean
public function set BackBuffer(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.Complex Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.Complex Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A complex surface is being described. A complex surface results in the creation of more than one surface. The additional surfaces are attached to the root surface. The complex surface can be destroyed only by destroying the root. Deprecated.

Definition

Visual Basic | Public Property Complex As Boolean
C# | public bool Complex { get; set; }
C++ public:
property bool Complex {
bool get();
void set(bool value);
}
JScript public function get Complex() : boolean
public function set Complex(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.Flip Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.Flip Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a part of a surface-flipping structure. Deprecated.

Definition

Visual Basic | Public Property Flip As Boolean
C# | public bool Flip { get; set; }
C++ public:
property bool Flip {
bool get();
void set(bool value);
}
JScript public function get Flip() : boolean
public function set Flip(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.FrontBuffer Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.FrontBuffer Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is the front buffer of a surface-flipping structure. Deprecated.

Definition

Visual Basic | Public Property FrontBuffer As Boolean
C# | public bool FrontBuffer { get; set; }
C++ public:
property bool FrontBuffer {
bool get();
void set(bool value);
}
JScript public function get FrontBuffer() : boolean
public function set FrontBuffer(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.HardwareCodec Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.HardwareCodec Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can have a stream decompressed to it by the hardware. Deprecated.

Definition

Visual Basic | Public Property HardwareCodec As Boolean
C# | public bool HardwareCodec { get; set; }
C++ public:
property bool HardwareCodec {
bool get();
void set(bool value);
}
JScript public function get HardwareCodec() : boolean
public function set HardwareCodec(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.LiveVideo Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.LiveVideo Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can receive live video. Deprecated.

Definition

Visual Basic | Public Property LiveVideo As Boolean
C# | public bool LiveVideo { get; set; }
C++ public:
property bool LiveVideo {
bool get();
void set(bool value);
}
JScript public function get LiveVideo() : boolean
public function set LiveVideo(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.LocalVideoMemory Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.LocalVideoMemory Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in true, local video memory, rather than nonlocal video memory. If this flag is specified, VideoMemory must be specified, as well. This flag cannot be used with the NonLocalVideoMemory flag. Deprecated.

Definition

Visual Basic | Public Property LocalVideoMemory As Boolean
C# | public bool LocalVideoMemory { get; set; }
C++ public:
property bool LocalVideoMemory {
bool get();
void set(bool value);
}
JScript public function get LocalVideoMemory() : boolean
public function set LocalVideoMemory(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.ModeX Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.ModeX Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a 320×200 or 320×240 Mode X surface. Deprecated.

Definition

Visual Basic | Public Property ModeX As Boolean
C# | public bool ModeX { get; set; }
C++ public:
property bool ModeX {
bool get();
void set(bool value);
}
JScript public function get ModeX() : boolean
public function set ModeX(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.NonLocalVideoMemory Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.NonLocalVideoMemory Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in nonlocal video memory, rather than true, local video memory. If this flag is specified, VideoMemory flag must be specified, as well. This cannot be used with the LocalVideoMemory flag. Deprecated.

Definition

Visual Basic | Public Property NonLocalVideoMemory As Boolean
C# | public bool NonLocalVideoMemory { get; set; }
C++ public:
property bool NonLocalVideoMemory {
bool get();
void set(bool value);
}
JScript public function get NonLocalVideoMemory() : boolean
public function set NonLocalVideoMemory(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.OffScreenPlain Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.OffScreenPlain Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is any off-screen surface that is not an overlay, front-buffer, back-buffer, or alpha surface. It is used to identify plain surfaces. Deprecated.

Definition

Visual Basic | Public Property OffScreenPlain As Boolean
C# | public bool OffScreenPlain { get; set; }
C++ public:
property bool OffScreenPlain {
bool get();
void set(bool value);
}
JScript public function get OffScreenPlain() : boolean
public function set OffScreenPlain(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.Overlay Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.Overlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is an overlay. It might or might not be directly visible, depending on whether it is currently being overlaid onto the primary surface. Deprecated.

Definition

Visual Basic | Public Property Overlay As Boolean
C# | public bool Overlay { get; set; }
C++ public:
property bool Overlay {
bool get();
void set(bool value);
}
JScript public function get Overlay() : boolean
public function set Overlay(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.OwnGraphics Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.OwnGraphics Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface has a device context (DC) association for a long period of time. Deprecated.

Definition

Visual Basic | Public Property OwnGraphics As Boolean
C# | public bool OwnGraphics { get; set; }
C++ public:
property bool OwnGraphics {
bool get();
void set(bool value);
}
JScript public function get OwnGraphics() : boolean
public function set OwnGraphics(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.Palette Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.Palette Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This device driver allows unique DirectDrawPalette objects to be created and attached to this surface. Deprecated.

Definition

Visual Basic | Public Property Palette As Boolean
C# | public bool Palette { get; set; }
C++ public:
property bool Palette {
bool get();
void set(bool value);
}
JScript public function get Palette() : boolean
public function set Palette(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.PrimarySurface Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.PrimarySurface Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is the primary surface. It represents what is currently visible. Deprecated.

Definition

Visual Basic | Public Property PrimarySurface As Boolean
C# | public bool PrimarySurface { get; set; }
C++ public:
property bool PrimarySurface {
bool get();
void set(bool value);
}
JScript public function get PrimarySurface() : boolean
public function set PrimarySurface(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.StandardVgaMode Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.StandardVgaMode Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is a standard VGA mode surface, and not a Mode X surface. This flag cannot be used in combination with the ModeX flag. Deprecated.

Definition

Visual Basic | Public Property StandardVgaMode As Boolean
C# | public bool StandardVgaMode { get; set; }
C++ public:
property bool StandardVgaMode {
bool get();
void set(bool value);
}
JScript public function get StandardVgaMode() : boolean
public function set StandardVgaMode(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.StereoSurfaceLeft Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.StereoSurfaceLeft Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface is part of a stereo flipping chain. Deprecated.

Definition

Visual Basic | Public Property StereoSurfaceLeft As Boolean
C# | public bool StereoSurfaceLeft { get; set; }
C++ public:
property bool StereoSurfaceLeft {
bool get();
void set(bool value);
}
JScript public function get StereoSurfaceLeft() : boolean
public function set StereoSurfaceLeft(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.SystemMemory Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.SystemMemory Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface memory was allocated in system memory. Deprecated.

Definition

Visual Basic | Public Property SystemMemory As Boolean
C# | public bool SystemMemory { get; set; }
C++ public:
property bool SystemMemory {
bool get();
void set(bool value);
}
JScript public function get SystemMemory() : boolean
public function set SystemMemory(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.VideoMemory Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.VideoMemory Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface exists in display memory. Deprecated.

Definition

Visual Basic | Public Property VideoMemory As Boolean
C# | public bool VideoMemory { get; set; }
C++ public:
property bool VideoMemory {
bool get();
void set(bool value);
}
JScript public function get VideoMemory() : boolean
public function set VideoMemory(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.VideoPort Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.VideoPort Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface can receive data from a video port. Deprecated.

Definition

Visual Basic | Public Property VideoPort As Boolean
C# | public bool VideoPort { get; set; }
C++ public:
property bool VideoPort {
bool get();
void set(bool value);
}
JScript public function get VideoPort() : boolean
public function set VideoPort(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.Visible Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.Visible Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes made to this surface are immediately visible. It is always set for the primary surface, as well as for overlays while they are being overlaid and texture maps while they are being textured. Deprecated.

Definition

Visual Basic | Public Property Visible As Boolean
C# | public bool Visible { get; set; }
C++ public:
property bool Visible {
bool get();
void set(bool value);
}
JScript public function get Visible() : boolean
public function set Visible(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceCaps.WriteAccessOnly Property (Microsoft.DirectX.DirectDraw)

SurfaceCaps.WriteAccessOnly Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Only write access is permitted to the surface. Read access from the surface can cause a general protection (GP) fault, and the read results from this surface would not be meaningful. Deprecated.

Definition

Visual Basic | Public Property WriteAccessOnly As Boolean
C# | public bool WriteAccessOnly { get; set; }
C++ public:
property bool WriteAccessOnly {
bool get();
void set(bool value);
}
JScript public function get WriteAccessOnly() : boolean
public function set WriteAccessOnly(boolean);

Property Value

System.Boolean

This property is read/write.


SurfaceDescription Class (Microsoft.DirectX.DirectDraw)

SurfaceDescription Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A description of a surface. Deprecated.

Definition

Visual Basic NotInheritable Public Class SurfaceDescription
Inherits Object
C# | public sealed class SurfaceDescription : Object
C++ | public ref class SurfaceDescription sealed : Object
JScript | public final class SurfaceDescription extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Clear
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reset the object back to defaults. Deprecated.
SurfaceDescription
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
AlphaBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The AlphaBitDepth member is valid. Deprecated.
BackBufferCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The BackBufferCount member is valid. Deprecated.
DestinationDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the destination color key for blit operations. Deprecated.
DestinationOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for an overlay surface. Deprecated.
EmptyFaceColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Empty face color Deprecated.
Height
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Dimensions of the surface to be created, in pixels. Deprecated.
LinearSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Size of the buffer. Currently returned only for compressed texture surfaces. Deprecated.
Pitch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Distance, in bytes, to the start of next line. Deprecated.
PixelFormatStructure
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the pixel format of the surface. Deprecated.
RefreshRate
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Refresh rate (used when the display mode is described). The value of 0 indicates an adapter default. Deprecated.
SourceDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for blit operations. Deprecated.
SourceOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for an overlay surface. Deprecated.
SurfaceCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The capabilities of the surface. Deprecated.
Width
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Dimensions of the surface to be created, in pixels. Deprecated.

Inheritance Hierarchy

Object Leave Site
SurfaceDescription

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfaceDescription.Clear() Method (Microsoft.DirectX.DirectDraw)

SurfaceDescription.Clear Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reset the object back to defaults. Deprecated.

Definition

Visual Basic | Public Sub Clear()
C# | public void Clear();
C++ public:
void Clear();
JScript | public function Clear();


SurfaceDescription.SurfaceDescription Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceDescription();
public SurfaceDescription(SurfaceCaps);


SurfaceDescription.SurfaceDescription(SurfaceCaps) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceDescription.SurfaceDescription Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal caps As SurfaceCaps _
)
C# public SurfaceDescription(
SurfaceCaps caps
);
C++ public:
SurfaceDescription(
SurfaceCaps^ caps
);
JScript public function SurfaceDescription(
caps : SurfaceCaps
);

Parameters

caps Microsoft.DirectX.DirectDraw.SurfaceCaps


SurfaceDescription.SurfaceDescription() Constructor (Microsoft.DirectX.DirectDraw)

SurfaceDescription.SurfaceDescription Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SurfaceDescription();
C++ public:
SurfaceDescription();
JScript | public function SurfaceDescription();


SurfaceDescription.AlphaBitDepth Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.AlphaBitDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The AlphaBitDepth member is valid. Deprecated.

Definition

Visual Basic | Public Property AlphaBitDepth As Integer
C# | public int AlphaBitDepth { get; set; }
C++ public:
property int AlphaBitDepth {
int get();
void set(int value);
}
JScript public function get AlphaBitDepth() : int
public function set AlphaBitDepth(int);

Property Value

System.Int32

This property is read/write.


SurfaceDescription.BackBufferCount Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.BackBufferCount Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The BackBufferCount member is valid. Deprecated.

Definition

Visual Basic | Public Property BackBufferCount As Integer
C# | public int BackBufferCount { get; set; }
C++ public:
property int BackBufferCount {
int get();
void set(int value);
}
JScript public function get BackBufferCount() : int
public function set BackBufferCount(int);

Property Value

System.Int32

This property is read/write.


SurfaceDescription.DestinationDraw Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.DestinationDraw Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the destination color key for blit operations. Deprecated.

Definition

Visual Basic | Public Property DestinationDraw As ColorKey
C# | public ColorKey DestinationDraw { get; set; }
C++ public:
property ColorKey DestinationDraw {
ColorKey get();
void set(ColorKey value);
}
JScript public function get DestinationDraw() : ColorKey
public function set DestinationDraw(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey

This property is read/write.


SurfaceDescription.DestinationOverlay Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.DestinationOverlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for an overlay surface. Deprecated.

Definition

Visual Basic | Public Property DestinationOverlay As ColorKey
C# | public ColorKey DestinationOverlay { get; set; }
C++ public:
property ColorKey DestinationOverlay {
ColorKey get();
void set(ColorKey value);
}
JScript public function get DestinationOverlay() : ColorKey
public function set DestinationOverlay(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey

This property is read/write.


SurfaceDescription.EmptyFaceColor Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.EmptyFaceColor Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Empty face color Deprecated.

Definition

Visual Basic | Public Property EmptyFaceColor As Integer
C# | public int EmptyFaceColor { get; set; }
C++ public:
property int EmptyFaceColor {
int get();
void set(int value);
}
JScript public function get EmptyFaceColor() : int
public function set EmptyFaceColor(int);

Property Value

System.Int32

This property is read/write.


SurfaceDescription.Height Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.Height Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Dimensions of the surface to be created, in pixels. Deprecated.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32

This property is read/write.


SurfaceDescription.LinearSize Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.LinearSize Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Size of the buffer. Currently returned only for compressed texture surfaces. Deprecated.

Definition

Visual Basic | Public Property LinearSize As Integer
C# | public int LinearSize { get; set; }
C++ public:
property int LinearSize {
int get();
void set(int value);
}
JScript public function get LinearSize() : int
public function set LinearSize(int);

Property Value

System.Int32

This property is read/write.


SurfaceDescription.Pitch Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.Pitch Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Distance, in bytes, to the start of next line. Deprecated.

Definition

Visual Basic | Public Property Pitch As Integer
C# | public int Pitch { get; set; }
C++ public:
property int Pitch {
int get();
void set(int value);
}
JScript public function get Pitch() : int
public function set Pitch(int);

Property Value

System.Int32

This property is read/write.


SurfaceDescription.PixelFormatStructure Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.PixelFormatStructure Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the pixel format of the surface. Deprecated.

Definition

Visual Basic | Public Property PixelFormatStructure As PixelFormat
C# | public PixelFormat PixelFormatStructure { get; set; }
C++ public:
property PixelFormat PixelFormatStructure {
PixelFormat get();
void set(PixelFormat value);
}
JScript public function get PixelFormatStructure() : PixelFormat
public function set PixelFormatStructure(PixelFormat);

Property Value

Microsoft.DirectX.DirectDraw.PixelFormat

This property is read/write.


SurfaceDescription.RefreshRate Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.RefreshRate Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Refresh rate (used when the display mode is described). The value of 0 indicates an adapter default. Deprecated.

Definition

Visual Basic | Public Property RefreshRate As Integer
C# | public int RefreshRate { get; set; }
C++ public:
property int RefreshRate {
int get();
void set(int value);
}
JScript public function get RefreshRate() : int
public function set RefreshRate(int);

Property Value

System.Int32

This property is read/write.


SurfaceDescription.SourceDraw Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.SourceDraw Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for blit operations. Deprecated.

Definition

Visual Basic | Public Property SourceDraw As ColorKey
C# | public ColorKey SourceDraw { get; set; }
C++ public:
property ColorKey SourceDraw {
ColorKey get();
void set(ColorKey value);
}
JScript public function get SourceDraw() : ColorKey
public function set SourceDraw(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey

This property is read/write.


SurfaceDescription.SourceOverlay Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.SourceOverlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the source color key for an overlay surface. Deprecated.

Definition

Visual Basic | Public Property SourceOverlay As ColorKey
C# | public ColorKey SourceOverlay { get; set; }
C++ public:
property ColorKey SourceOverlay {
ColorKey get();
void set(ColorKey value);
}
JScript public function get SourceOverlay() : ColorKey
public function set SourceOverlay(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey

This property is read/write.


SurfaceDescription.SurfaceCaps Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.SurfaceCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The capabilities of the surface. Deprecated.

Definition

Visual Basic | Public Property SurfaceCaps As SurfaceCaps
C# | public SurfaceCaps SurfaceCaps { get; set; }
C++ public:
property SurfaceCaps^ SurfaceCaps {
SurfaceCaps^ get();
void set(SurfaceCaps^ value);
}
JScript public function get SurfaceCaps() : SurfaceCaps
public function set SurfaceCaps(SurfaceCaps);

Property Value

Microsoft.DirectX.DirectDraw.SurfaceCaps

This property is read/write.


SurfaceDescription.Width Property (Microsoft.DirectX.DirectDraw)

SurfaceDescription.Width Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Dimensions of the surface to be created, in pixels. Deprecated.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32

This property is read/write.


SurfaceIsObscuredException Class (Microsoft.DirectX.DirectDraw)

SurfaceIsObscuredException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface is obscured. Deprecated.

Definition

Visual Basic Public Class SurfaceIsObscuredException
Inherits GraphicsException
C# | public class SurfaceIsObscuredException : GraphicsException
C++ | public ref class SurfaceIsObscuredException : GraphicsException
JScript | public class SurfaceIsObscuredException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SurfaceIsObscuredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
SurfaceIsObscuredException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfaceIsObscuredException.SurfaceIsObscuredException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceIsObscuredException();
protected SurfaceIsObscuredException(SerializationInfo, StreamingContext);
public SurfaceIsObscuredException(string);
public SurfaceIsObscuredException(string, Exception);


SurfaceIsObscuredException.SurfaceIsObscuredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SurfaceIsObscuredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SurfaceIsObscuredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SurfaceIsObscuredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SurfaceIsObscuredException.SurfaceIsObscuredException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SurfaceIsObscuredException(
string message,
Exception inner
);
C++ public:
SurfaceIsObscuredException(
String^ message,
Exception^ inner
);
JScript public function SurfaceIsObscuredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SurfaceIsObscuredException.SurfaceIsObscuredException(String) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SurfaceIsObscuredException(
string message
);
C++ public:
SurfaceIsObscuredException(
String^ message
);
JScript public function SurfaceIsObscuredException(
message : String
);

Parameters

message System.String


SurfaceIsObscuredException.SurfaceIsObscuredException() Constructor (Microsoft.DirectX.DirectDraw)

SurfaceIsObscuredException.SurfaceIsObscuredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SurfaceIsObscuredException();
C++ public:
SurfaceIsObscuredException();
JScript | public function SurfaceIsObscuredException();


SurfaceLostException Class (Microsoft.DirectX.DirectDraw)

SurfaceLostException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Access to the surface is refused because the surface memory is gone. Call the Surface.Restore method on this surface to restore the memory associated Deprecated.

Definition

Visual Basic Public Class SurfaceLostException
Inherits GraphicsException
C# | public class SurfaceLostException : GraphicsException
C++ | public ref class SurfaceLostException : GraphicsException
JScript | public class SurfaceLostException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SurfaceLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
SurfaceLostException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfaceLostException.SurfaceLostException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceLostException();
protected SurfaceLostException(SerializationInfo, StreamingContext);
public SurfaceLostException(string);
public SurfaceLostException(string, Exception);


SurfaceLostException.SurfaceLostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceLostException.SurfaceLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SurfaceLostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SurfaceLostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SurfaceLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SurfaceLostException.SurfaceLostException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceLostException.SurfaceLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SurfaceLostException(
string message,
Exception inner
);
C++ public:
SurfaceLostException(
String^ message,
Exception^ inner
);
JScript public function SurfaceLostException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SurfaceLostException.SurfaceLostException(String) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceLostException.SurfaceLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SurfaceLostException(
string message
);
C++ public:
SurfaceLostException(
String^ message
);
JScript public function SurfaceLostException(
message : String
);

Parameters

message System.String


SurfaceLostException.SurfaceLostException() Constructor (Microsoft.DirectX.DirectDraw)

SurfaceLostException.SurfaceLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SurfaceLostException();
C++ public:
SurfaceLostException();
JScript | public function SurfaceLostException();


SurfaceNotAttachedException Class (Microsoft.DirectX.DirectDraw)

SurfaceNotAttachedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The requested surface is not attached. Deprecated.

Definition

Visual Basic Public Class SurfaceNotAttachedException
Inherits GraphicsException
C# | public class SurfaceNotAttachedException : GraphicsException
C++ | public ref class SurfaceNotAttachedException : GraphicsException
JScript | public class SurfaceNotAttachedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SurfaceNotAttachedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
SurfaceNotAttachedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfaceNotAttachedException.SurfaceNotAttachedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfaceNotAttachedException();
protected SurfaceNotAttachedException(SerializationInfo, StreamingContext);
public SurfaceNotAttachedException(string);
public SurfaceNotAttachedException(string, Exception);


SurfaceNotAttachedException.SurfaceNotAttachedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SurfaceNotAttachedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SurfaceNotAttachedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SurfaceNotAttachedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SurfaceNotAttachedException.SurfaceNotAttachedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SurfaceNotAttachedException(
string message,
Exception inner
);
C++ public:
SurfaceNotAttachedException(
String^ message,
Exception^ inner
);
JScript public function SurfaceNotAttachedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SurfaceNotAttachedException.SurfaceNotAttachedException(String) Constructor (Microsoft.DirectX.DirectDraw)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SurfaceNotAttachedException(
string message
);
C++ public:
SurfaceNotAttachedException(
String^ message
);
JScript public function SurfaceNotAttachedException(
message : String
);

Parameters

message System.String


SurfaceNotAttachedException.SurfaceNotAttachedException() Constructor (Microsoft.DirectX.DirectDraw)

SurfaceNotAttachedException.SurfaceNotAttachedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SurfaceNotAttachedException();
C++ public:
SurfaceNotAttachedException();
JScript | public function SurfaceNotAttachedException();


SurfacesCollection Class (Microsoft.DirectX.DirectDraw)

SurfacesCollection Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A collection of surfaces. Deprecated.

Definition

Visual Basic NotInheritable Public Class SurfacesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class SurfacesCollection : Object, IEnumerable, IEnumerator
C++ | public ref class SurfacesCollection sealed : Object, IEnumerable, IEnumerator
JScript | public final class SurfacesCollection extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetEnumerator
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.
MoveNext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.
Reset
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.
SurfacesCollection
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
Count
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.
Current
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Inheritance Hierarchy

Object Leave Site
SurfacesCollection

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SurfacesCollection.GetEnumerator() Method (Microsoft.DirectX.DirectDraw)

SurfacesCollection.GetEnumerator Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


SurfacesCollection.MoveNext() Method (Microsoft.DirectX.DirectDraw)

SurfacesCollection.MoveNext Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean


SurfacesCollection.Reset() Method (Microsoft.DirectX.DirectDraw)

SurfacesCollection.Reset Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();


SurfacesCollection.SurfacesCollection Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SurfacesCollection(Device);
public SurfacesCollection(GetSurfacesFlags, SurfaceDescription, Device);
public SurfacesCollection(OverlayZOrdersFlags, Surface, Device);
public SurfacesCollection(Surface, Device);
public SurfacesCollection(SurfaceDescription, Device);


SurfacesCollection.SurfacesCollection(OverlayZOrdersFlags,Surface,Device) Constructor (Microsoft.DirectX.DirectDraw)

SurfacesCollection.SurfacesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As OverlayZOrdersFlags, _
ByVal surf As Surface, _
ByVal dev As Device _
)
C# public SurfacesCollection(
OverlayZOrdersFlags flags,
Surface surf,
Device dev
);
C++ public:
SurfacesCollection(
OverlayZOrdersFlags flags,
Surface^ surf,
Device^ dev
);
JScript public function SurfacesCollection(
flags : OverlayZOrdersFlags,
surf : Surface,
dev : Device
);

Parameters

flags Microsoft.DirectX.DirectDraw.OverlayZOrdersFlags
surf Microsoft.DirectX.DirectDraw.Surface
dev Microsoft.DirectX.DirectDraw.Device


SurfacesCollection.SurfacesCollection(Surface,Device) Constructor (Microsoft.DirectX.DirectDraw)

SurfacesCollection.SurfacesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal surf As Surface, _
ByVal dev As Device _
)
C# public SurfacesCollection(
Surface surf,
Device dev
);
C++ public:
SurfacesCollection(
Surface^ surf,
Device^ dev
);
JScript public function SurfacesCollection(
surf : Surface,
dev : Device
);

Parameters

surf Microsoft.DirectX.DirectDraw.Surface
dev Microsoft.DirectX.DirectDraw.Device


SurfacesCollection.SurfacesCollection(GetSurfacesFlags,SurfaceDescription,Device) Constructor (Microsoft.DirectX.DirectDraw)

SurfacesCollection.SurfacesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As GetSurfacesFlags, _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public SurfacesCollection(
GetSurfacesFlags flags,
SurfaceDescription desc,
Device dev
);
C++ public:
SurfacesCollection(
GetSurfacesFlags flags,
SurfaceDescription^ desc,
Device^ dev
);
JScript public function SurfacesCollection(
flags : GetSurfacesFlags,
desc : SurfaceDescription,
dev : Device
);

Parameters

flags Microsoft.DirectX.DirectDraw.GetSurfacesFlags
desc Microsoft.DirectX.DirectDraw.SurfaceDescription
dev Microsoft.DirectX.DirectDraw.Device


SurfacesCollection.SurfacesCollection(SurfaceDescription,Device) Constructor (Microsoft.DirectX.DirectDraw)

SurfacesCollection.SurfacesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal desc As SurfaceDescription, _
ByVal dev As Device _
)
C# public SurfacesCollection(
SurfaceDescription desc,
Device dev
);
C++ public:
SurfacesCollection(
SurfaceDescription^ desc,
Device^ dev
);
JScript public function SurfacesCollection(
desc : SurfaceDescription,
dev : Device
);

Parameters

desc Microsoft.DirectX.DirectDraw.SurfaceDescription
dev Microsoft.DirectX.DirectDraw.Device


SurfacesCollection.SurfacesCollection(Device) Constructor (Microsoft.DirectX.DirectDraw)

SurfacesCollection.SurfacesCollection Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dev As Device _
)
C# public SurfacesCollection(
Device dev
);
C++ public:
SurfacesCollection(
Device^ dev
);
JScript public function SurfacesCollection(
dev : Device
);

Parameters

dev Microsoft.DirectX.DirectDraw.Device


SurfacesCollection.Count Property (Microsoft.DirectX.DirectDraw)

SurfacesCollection.Count Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


SurfacesCollection.Current Property (Microsoft.DirectX.DirectDraw)

SurfacesCollection.Current Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object

This property is read-only.


TestFinishedException Class (Microsoft.DirectX.DirectDraw)

TestFinishedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When thrown by StartModeTest method, this value means that no test could be initiated because all the resolutions chosen for testing already have refresh rate information in the registry. Deprecated.

Definition

Visual Basic Public Class TestFinishedException
Inherits GraphicsException
C# | public class TestFinishedException : GraphicsException
C++ | public ref class TestFinishedException : GraphicsException
JScript | public class TestFinishedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TestFinishedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TestFinishedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TestFinishedException.TestFinishedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TestFinishedException();
protected TestFinishedException(SerializationInfo, StreamingContext);
public TestFinishedException(string);
public TestFinishedException(string, Exception);


TestFinishedException.TestFinishedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

TestFinishedException.TestFinishedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TestFinishedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TestFinishedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TestFinishedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TestFinishedException.TestFinishedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

TestFinishedException.TestFinishedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TestFinishedException(
string message,
Exception inner
);
C++ public:
TestFinishedException(
String^ message,
Exception^ inner
);
JScript public function TestFinishedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TestFinishedException.TestFinishedException(String) Constructor (Microsoft.DirectX.DirectDraw)

TestFinishedException.TestFinishedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TestFinishedException(
string message
);
C++ public:
TestFinishedException(
String^ message
);
JScript public function TestFinishedException(
message : String
);

Parameters

message System.String


TestFinishedException.TestFinishedException() Constructor (Microsoft.DirectX.DirectDraw)

TestFinishedException.TestFinishedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TestFinishedException();
C++ public:
TestFinishedException();
JScript | public function TestFinishedException();


TooBigHeightException Class (Microsoft.DirectX.DirectDraw)

TooBigHeightException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The height requested by DirectDraw is too large. Deprecated.

Definition

Visual Basic Public Class TooBigHeightException
Inherits GraphicsException
C# | public class TooBigHeightException : GraphicsException
C++ | public ref class TooBigHeightException : GraphicsException
JScript | public class TooBigHeightException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooBigHeightException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TooBigHeightException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TooBigHeightException.TooBigHeightException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TooBigHeightException();
protected TooBigHeightException(SerializationInfo, StreamingContext);
public TooBigHeightException(string);
public TooBigHeightException(string, Exception);


TooBigHeightException.TooBigHeightException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

TooBigHeightException.TooBigHeightException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooBigHeightException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TooBigHeightException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TooBigHeightException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TooBigHeightException.TooBigHeightException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

TooBigHeightException.TooBigHeightException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooBigHeightException(
string message,
Exception inner
);
C++ public:
TooBigHeightException(
String^ message,
Exception^ inner
);
JScript public function TooBigHeightException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TooBigHeightException.TooBigHeightException(String) Constructor (Microsoft.DirectX.DirectDraw)

TooBigHeightException.TooBigHeightException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TooBigHeightException(
string message
);
C++ public:
TooBigHeightException(
String^ message
);
JScript public function TooBigHeightException(
message : String
);

Parameters

message System.String


TooBigHeightException.TooBigHeightException() Constructor (Microsoft.DirectX.DirectDraw)

TooBigHeightException.TooBigHeightException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TooBigHeightException();
C++ public:
TooBigHeightException();
JScript | public function TooBigHeightException();


TooBigSizeException Class (Microsoft.DirectX.DirectDraw)

TooBigSizeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The size requested by DirectDraw is too large. However, the individual height and width are valid sizes. Deprecated.

Definition

Visual Basic Public Class TooBigSizeException
Inherits GraphicsException
C# | public class TooBigSizeException : GraphicsException
C++ | public ref class TooBigSizeException : GraphicsException
JScript | public class TooBigSizeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooBigSizeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TooBigSizeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TooBigSizeException.TooBigSizeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TooBigSizeException();
protected TooBigSizeException(SerializationInfo, StreamingContext);
public TooBigSizeException(string);
public TooBigSizeException(string, Exception);


TooBigSizeException.TooBigSizeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

TooBigSizeException.TooBigSizeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooBigSizeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TooBigSizeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TooBigSizeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TooBigSizeException.TooBigSizeException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

TooBigSizeException.TooBigSizeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooBigSizeException(
string message,
Exception inner
);
C++ public:
TooBigSizeException(
String^ message,
Exception^ inner
);
JScript public function TooBigSizeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TooBigSizeException.TooBigSizeException(String) Constructor (Microsoft.DirectX.DirectDraw)

TooBigSizeException.TooBigSizeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TooBigSizeException(
string message
);
C++ public:
TooBigSizeException(
String^ message
);
JScript public function TooBigSizeException(
message : String
);

Parameters

message System.String


TooBigSizeException.TooBigSizeException() Constructor (Microsoft.DirectX.DirectDraw)

TooBigSizeException.TooBigSizeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TooBigSizeException();
C++ public:
TooBigSizeException();
JScript | public function TooBigSizeException();


TooBigWidthException Class (Microsoft.DirectX.DirectDraw)

TooBigWidthException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The width requested by DirectDraw is too large. Deprecated.

Definition

Visual Basic Public Class TooBigWidthException
Inherits GraphicsException
C# | public class TooBigWidthException : GraphicsException
C++ | public ref class TooBigWidthException : GraphicsException
JScript | public class TooBigWidthException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TooBigWidthException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
TooBigWidthException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TooBigWidthException.TooBigWidthException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TooBigWidthException();
protected TooBigWidthException(SerializationInfo, StreamingContext);
public TooBigWidthException(string);
public TooBigWidthException(string, Exception);


TooBigWidthException.TooBigWidthException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

TooBigWidthException.TooBigWidthException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TooBigWidthException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TooBigWidthException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TooBigWidthException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TooBigWidthException.TooBigWidthException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

TooBigWidthException.TooBigWidthException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TooBigWidthException(
string message,
Exception inner
);
C++ public:
TooBigWidthException(
String^ message,
Exception^ inner
);
JScript public function TooBigWidthException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TooBigWidthException.TooBigWidthException(String) Constructor (Microsoft.DirectX.DirectDraw)

TooBigWidthException.TooBigWidthException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TooBigWidthException(
string message
);
C++ public:
TooBigWidthException(
String^ message
);
JScript public function TooBigWidthException(
message : String
);

Parameters

message System.String


TooBigWidthException.TooBigWidthException() Constructor (Microsoft.DirectX.DirectDraw)

TooBigWidthException.TooBigWidthException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TooBigWidthException();
C++ public:
TooBigWidthException();
JScript | public function TooBigWidthException();


UnsupportedException Class (Microsoft.DirectX.DirectDraw)

UnsupportedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is not supported. Deprecated.

Definition

Visual Basic Public Class UnsupportedException
Inherits GraphicsException
C# | public class UnsupportedException : GraphicsException
C++ | public ref class UnsupportedException : GraphicsException
JScript | public class UnsupportedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedException.UnsupportedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UnsupportedException();
protected UnsupportedException(SerializationInfo, StreamingContext);
public UnsupportedException(string);
public UnsupportedException(string, Exception);


UnsupportedException.UnsupportedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedException.UnsupportedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UnsupportedException.UnsupportedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedException.UnsupportedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedException(
string message,
Exception inner
);
C++ public:
UnsupportedException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UnsupportedException.UnsupportedException(String) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedException.UnsupportedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedException(
string message
);
C++ public:
UnsupportedException(
String^ message
);
JScript public function UnsupportedException(
message : String
);

Parameters

message System.String


UnsupportedException.UnsupportedException() Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedException.UnsupportedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedException();
C++ public:
UnsupportedException();
JScript | public function UnsupportedException();


UnsupportedFormatException Class (Microsoft.DirectX.DirectDraw)

UnsupportedFormatException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format requested is not supported by DirectDraw. Deprecated.

Definition

Visual Basic Public Class UnsupportedFormatException
Inherits GraphicsException
C# | public class UnsupportedFormatException : GraphicsException
C++ | public ref class UnsupportedFormatException : GraphicsException
JScript | public class UnsupportedFormatException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedFormatException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedFormatException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedFormatException.UnsupportedFormatException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UnsupportedFormatException();
protected UnsupportedFormatException(SerializationInfo, StreamingContext);
public UnsupportedFormatException(string);
public UnsupportedFormatException(string, Exception);


UnsupportedFormatException.UnsupportedFormatException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedFormatException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedFormatException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UnsupportedFormatException.UnsupportedFormatException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedFormatException(
string message,
Exception inner
);
C++ public:
UnsupportedFormatException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedFormatException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UnsupportedFormatException.UnsupportedFormatException(String) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedFormatException(
string message
);
C++ public:
UnsupportedFormatException(
String^ message
);
JScript public function UnsupportedFormatException(
message : String
);

Parameters

message System.String


UnsupportedFormatException.UnsupportedFormatException() Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedFormatException.UnsupportedFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedFormatException();
C++ public:
UnsupportedFormatException();
JScript | public function UnsupportedFormatException();


UnsupportedMaskException Class (Microsoft.DirectX.DirectDraw)

UnsupportedMaskException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The bitmask in the pixel format requested is not supported by DirectDraw. Deprecated.

Definition

Visual Basic Public Class UnsupportedMaskException
Inherits GraphicsException
C# | public class UnsupportedMaskException : GraphicsException
C++ | public ref class UnsupportedMaskException : GraphicsException
JScript | public class UnsupportedMaskException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedMaskException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedMaskException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedMaskException.UnsupportedMaskException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UnsupportedMaskException();
protected UnsupportedMaskException(SerializationInfo, StreamingContext);
public UnsupportedMaskException(string);
public UnsupportedMaskException(string, Exception);


UnsupportedMaskException.UnsupportedMaskException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedMaskException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedMaskException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedMaskException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UnsupportedMaskException.UnsupportedMaskException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedMaskException(
string message,
Exception inner
);
C++ public:
UnsupportedMaskException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedMaskException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UnsupportedMaskException.UnsupportedMaskException(String) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedMaskException(
string message
);
C++ public:
UnsupportedMaskException(
String^ message
);
JScript public function UnsupportedMaskException(
message : String
);

Parameters

message System.String


UnsupportedMaskException.UnsupportedMaskException() Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedMaskException.UnsupportedMaskException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedMaskException();
C++ public:
UnsupportedMaskException();
JScript | public function UnsupportedMaskException();


UnsupportedModeException Class (Microsoft.DirectX.DirectDraw)

UnsupportedModeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display is currently in an unsupported mode. Deprecated.

Definition

Visual Basic Public Class UnsupportedModeException
Inherits GraphicsException
C# | public class UnsupportedModeException : GraphicsException
C++ | public ref class UnsupportedModeException : GraphicsException
JScript | public class UnsupportedModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
UnsupportedModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedModeException.UnsupportedModeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UnsupportedModeException();
protected UnsupportedModeException(SerializationInfo, StreamingContext);
public UnsupportedModeException(string);
public UnsupportedModeException(string, Exception);


UnsupportedModeException.UnsupportedModeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedModeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedModeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UnsupportedModeException.UnsupportedModeException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedModeException(
string message,
Exception inner
);
C++ public:
UnsupportedModeException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedModeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UnsupportedModeException.UnsupportedModeException(String) Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedModeException(
string message
);
C++ public:
UnsupportedModeException(
String^ message
);
JScript public function UnsupportedModeException(
message : String
);

Parameters

message System.String


UnsupportedModeException.UnsupportedModeException() Constructor (Microsoft.DirectX.DirectDraw)

UnsupportedModeException.UnsupportedModeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedModeException();
C++ public:
UnsupportedModeException();
JScript | public function UnsupportedModeException();


VerticalBlankInProgressException Class (Microsoft.DirectX.DirectDraw)

VerticalBlankInProgressException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A vertical blank is in progress. Deprecated.

Definition

Visual Basic Public Class VerticalBlankInProgressException
Inherits GraphicsException
C# | public class VerticalBlankInProgressException : GraphicsException
C++ | public ref class VerticalBlankInProgressException : GraphicsException
JScript | public class VerticalBlankInProgressException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
VerticalBlankInProgressException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
VerticalBlankInProgressException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VerticalBlankInProgressException.VerticalBlankInProgressException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public VerticalBlankInProgressException();
protected VerticalBlankInProgressException(SerializationInfo, StreamingContext);
public VerticalBlankInProgressException(string);
public VerticalBlankInProgressException(string, Exception);


VerticalBlankInProgressException.VerticalBlankInProgressException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected VerticalBlankInProgressException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
VerticalBlankInProgressException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function VerticalBlankInProgressException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


VerticalBlankInProgressException.VerticalBlankInProgressException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public VerticalBlankInProgressException(
string message,
Exception inner
);
C++ public:
VerticalBlankInProgressException(
String^ message,
Exception^ inner
);
JScript public function VerticalBlankInProgressException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


VerticalBlankInProgressException.VerticalBlankInProgressException(String) Constructor (Microsoft.DirectX.DirectDraw)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public VerticalBlankInProgressException(
string message
);
C++ public:
VerticalBlankInProgressException(
String^ message
);
JScript public function VerticalBlankInProgressException(
message : String
);

Parameters

message System.String


VerticalBlankInProgressException.VerticalBlankInProgressException() Constructor (Microsoft.DirectX.DirectDraw)

VerticalBlankInProgressException.VerticalBlankInProgressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public VerticalBlankInProgressException();
C++ public:
VerticalBlankInProgressException();
JScript | public function VerticalBlankInProgressException();


VideoNotActiveException Class (Microsoft.DirectX.DirectDraw)

VideoNotActiveException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The video port is not active. Deprecated.

Definition

Visual Basic Public Class VideoNotActiveException
Inherits GraphicsException
C# | public class VideoNotActiveException : GraphicsException
C++ | public ref class VideoNotActiveException : GraphicsException
JScript | public class VideoNotActiveException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
VideoNotActiveException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
VideoNotActiveException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VideoNotActiveException.VideoNotActiveException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public VideoNotActiveException();
protected VideoNotActiveException(SerializationInfo, StreamingContext);
public VideoNotActiveException(string);
public VideoNotActiveException(string, Exception);


VideoNotActiveException.VideoNotActiveException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

VideoNotActiveException.VideoNotActiveException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected VideoNotActiveException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
VideoNotActiveException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function VideoNotActiveException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


VideoNotActiveException.VideoNotActiveException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

VideoNotActiveException.VideoNotActiveException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public VideoNotActiveException(
string message,
Exception inner
);
C++ public:
VideoNotActiveException(
String^ message,
Exception^ inner
);
JScript public function VideoNotActiveException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


VideoNotActiveException.VideoNotActiveException(String) Constructor (Microsoft.DirectX.DirectDraw)

VideoNotActiveException.VideoNotActiveException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public VideoNotActiveException(
string message
);
C++ public:
VideoNotActiveException(
String^ message
);
JScript public function VideoNotActiveException(
message : String
);

Parameters

message System.String


VideoNotActiveException.VideoNotActiveException() Constructor (Microsoft.DirectX.DirectDraw)

VideoNotActiveException.VideoNotActiveException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public VideoNotActiveException();
C++ public:
VideoNotActiveException();
JScript | public function VideoNotActiveException();


WasStillDrawingException Class (Microsoft.DirectX.DirectDraw)

WasStillDrawingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The previous blit operation that is transferring information to or from this surface is incomplete. Deprecated.

Definition

Visual Basic Public Class WasStillDrawingException
Inherits GraphicsException
C# | public class WasStillDrawingException : GraphicsException
C++ | public ref class WasStillDrawingException : GraphicsException
JScript | public class WasStillDrawingException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WasStillDrawingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WasStillDrawingException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WasStillDrawingException.WasStillDrawingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public WasStillDrawingException();
protected WasStillDrawingException(SerializationInfo, StreamingContext);
public WasStillDrawingException(string);
public WasStillDrawingException(string, Exception);


WasStillDrawingException.WasStillDrawingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WasStillDrawingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
WasStillDrawingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function WasStillDrawingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


WasStillDrawingException.WasStillDrawingException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WasStillDrawingException(
string message,
Exception inner
);
C++ public:
WasStillDrawingException(
String^ message,
Exception^ inner
);
JScript public function WasStillDrawingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


WasStillDrawingException.WasStillDrawingException(String) Constructor (Microsoft.DirectX.DirectDraw)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public WasStillDrawingException(
string message
);
C++ public:
WasStillDrawingException(
String^ message
);
JScript public function WasStillDrawingException(
message : String
);

Parameters

message System.String


WasStillDrawingException.WasStillDrawingException() Constructor (Microsoft.DirectX.DirectDraw)

WasStillDrawingException.WasStillDrawingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public WasStillDrawingException();
C++ public:
WasStillDrawingException();
JScript | public function WasStillDrawingException();


WindowAlreadySetException Class (Microsoft.DirectX.DirectDraw)

WindowAlreadySetException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectDraw cooperative-level window has already been set. It cannot be reset while the process has surfaces or palettes created. Deprecated.

Definition

Visual Basic Public Class WindowAlreadySetException
Inherits GraphicsException
C# | public class WindowAlreadySetException : GraphicsException
C++ | public ref class WindowAlreadySetException : GraphicsException
JScript | public class WindowAlreadySetException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WindowAlreadySetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WindowAlreadySetException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WindowAlreadySetException.WindowAlreadySetException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public WindowAlreadySetException();
protected WindowAlreadySetException(SerializationInfo, StreamingContext);
public WindowAlreadySetException(string);
public WindowAlreadySetException(string, Exception);


WindowAlreadySetException.WindowAlreadySetException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WindowAlreadySetException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
WindowAlreadySetException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function WindowAlreadySetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


WindowAlreadySetException.WindowAlreadySetException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WindowAlreadySetException(
string message,
Exception inner
);
C++ public:
WindowAlreadySetException(
String^ message,
Exception^ inner
);
JScript public function WindowAlreadySetException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


WindowAlreadySetException.WindowAlreadySetException(String) Constructor (Microsoft.DirectX.DirectDraw)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public WindowAlreadySetException(
string message
);
C++ public:
WindowAlreadySetException(
String^ message
);
JScript public function WindowAlreadySetException(
message : String
);

Parameters

message System.String


WindowAlreadySetException.WindowAlreadySetException() Constructor (Microsoft.DirectX.DirectDraw)

WindowAlreadySetException.WindowAlreadySetException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public WindowAlreadySetException();
C++ public:
WindowAlreadySetException();
JScript | public function WindowAlreadySetException();


WindowSubclassedException Class (Microsoft.DirectX.DirectDraw)

WindowSubclassedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is prevented from restoring state because the DirectDraw cooperative-level window handle has been subclassed. Deprecated.

Definition

Visual Basic Public Class WindowSubclassedException
Inherits GraphicsException
C# | public class WindowSubclassedException : GraphicsException
C++ | public ref class WindowSubclassedException : GraphicsException
JScript | public class WindowSubclassedException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WindowSubclassedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WindowSubclassedException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WindowSubclassedException.WindowSubclassedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public WindowSubclassedException();
protected WindowSubclassedException(SerializationInfo, StreamingContext);
public WindowSubclassedException(string);
public WindowSubclassedException(string, Exception);


WindowSubclassedException.WindowSubclassedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WindowSubclassedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
WindowSubclassedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function WindowSubclassedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


WindowSubclassedException.WindowSubclassedException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WindowSubclassedException(
string message,
Exception inner
);
C++ public:
WindowSubclassedException(
String^ message,
Exception^ inner
);
JScript public function WindowSubclassedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


WindowSubclassedException.WindowSubclassedException(String) Constructor (Microsoft.DirectX.DirectDraw)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public WindowSubclassedException(
string message
);
C++ public:
WindowSubclassedException(
String^ message
);
JScript public function WindowSubclassedException(
message : String
);

Parameters

message System.String


WindowSubclassedException.WindowSubclassedException() Constructor (Microsoft.DirectX.DirectDraw)

WindowSubclassedException.WindowSubclassedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public WindowSubclassedException();
C++ public:
WindowSubclassedException();
JScript | public function WindowSubclassedException();


WrongModeException Class (Microsoft.DirectX.DirectDraw)

WrongModeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This surface cannot be restored because it was created in a different mode. Deprecated.

Definition

Visual Basic Public Class WrongModeException
Inherits GraphicsException
C# | public class WrongModeException : GraphicsException
C++ | public ref class WrongModeException : GraphicsException
JScript | public class WrongModeException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
WrongModeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
WrongModeException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WrongModeException.WrongModeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public WrongModeException();
protected WrongModeException(SerializationInfo, StreamingContext);
public WrongModeException(string);
public WrongModeException(string, Exception);


WrongModeException.WrongModeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

WrongModeException.WrongModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected WrongModeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
WrongModeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function WrongModeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


WrongModeException.WrongModeException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

WrongModeException.WrongModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public WrongModeException(
string message,
Exception inner
);
C++ public:
WrongModeException(
String^ message,
Exception^ inner
);
JScript public function WrongModeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


WrongModeException.WrongModeException(String) Constructor (Microsoft.DirectX.DirectDraw)

WrongModeException.WrongModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public WrongModeException(
string message
);
C++ public:
WrongModeException(
String^ message
);
JScript public function WrongModeException(
message : String
);

Parameters

message System.String


WrongModeException.WrongModeException() Constructor (Microsoft.DirectX.DirectDraw)

WrongModeException.WrongModeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public WrongModeException();
C++ public:
WrongModeException();
JScript | public function WrongModeException();


XAlignException Class (Microsoft.DirectX.DirectDraw)

XAlignException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The provided rectangle was not horizontally aligned on a required boundary. Deprecated.

Definition

Visual Basic Public Class XAlignException
Inherits GraphicsException
C# | public class XAlignException : GraphicsException
C++ | public ref class XAlignException : GraphicsException
JScript | public class XAlignException extends GraphicsException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from GraphicsException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
XAlignException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
GraphicsException
XAlignException

Class Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


XAlignException.XAlignException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public XAlignException();
protected XAlignException(SerializationInfo, StreamingContext);
public XAlignException(string);
public XAlignException(string, Exception);


XAlignException.XAlignException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectDraw)

XAlignException.XAlignException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected XAlignException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
XAlignException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function XAlignException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


XAlignException.XAlignException(String,Exception) Constructor (Microsoft.DirectX.DirectDraw)

XAlignException.XAlignException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public XAlignException(
string message,
Exception inner
);
C++ public:
XAlignException(
String^ message,
Exception^ inner
);
JScript public function XAlignException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


XAlignException.XAlignException(String) Constructor (Microsoft.DirectX.DirectDraw)

XAlignException.XAlignException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public XAlignException(
string message
);
C++ public:
XAlignException(
String^ message
);
JScript public function XAlignException(
message : String
);

Parameters

message System.String


XAlignException.XAlignException() Constructor (Microsoft.DirectX.DirectDraw)

XAlignException.XAlignException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public XAlignException();
C++ public:
XAlignException();
JScript | public function XAlignException();


ColorKeyFlags Enumeration (Microsoft.DirectX.DirectDraw)

ColorKeyFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines which color key is requested. Deprecated.

Definition

Visual Basic | Public Enum ColorKeyFlags
C# | public enum ColorKeyFlags
C++ | public enum class ColorKeyFlags
JScript | public enum ColorKeyFlags

Members

Member | Value | Description
SourceOverlay | 16
SourceDraw | 8
DestinationOverlay | 4
DestinationDraw | 2
ColorSpace | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CooperativeLevelFlags Enumeration (Microsoft.DirectX.DirectDraw)

CooperativeLevelFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines the top-level behavior of the application. Deprecated.

Definition

Visual Basic | Public Enum CooperativeLevelFlags
C# | public enum CooperativeLevelFlags
C++ | public enum class CooperativeLevelFlags
JScript | public enum CooperativeLevelFlags

Members

Member | Value | Description
FullscreenExclusiveAllowModex | 81
FullscreenExclusive | 17
CreateDeviceWindow | 512
SetDeviceWindow | 256
SetFocusWindow | 128
AllowModeX | 64
Exclusive | 16
Normal | 8
NoWindowChanges | 4
AllowReboot | 2
Fullscreen | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CreateFlags Enumeration (Microsoft.DirectX.DirectDraw)

CreateFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creation flags. Deprecated.

Definition

Visual Basic | Public Enum CreateFlags
C# | public enum CreateFlags
C++ | public enum class CreateFlags
JScript | public enum CreateFlags

Members

Member | Value | Description
Default | 0
EmulationOnly | 2
HardwareOnly | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrawFastFlags Enumeration (Microsoft.DirectX.DirectDraw)

DrawFastFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Type of transfer. Deprecated.

Definition

Visual Basic | Public Enum DrawFastFlags
C# | public enum DrawFastFlags
C++ | public enum class DrawFastFlags
JScript | public enum DrawFastFlags

Members

Member | Value | Description
DoNotWait | 32
Wait | 16
DestinationColorKey | 2
SourceColorKey | 1
NoColorKey | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrawFlags Enumeration (Microsoft.DirectX.DirectDraw)

DrawFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A combination of flags that determine the valid members of the associated DrawEffects structure, specify color-key information, or request special behavior from the method. Deprecated.

Definition

Visual Basic | Public Enum DrawFlags
C# | public enum DrawFlags
C++ | public enum class DrawFlags
JScript | public enum DrawFlags

Members

Member | Value | Description
DoNotWait | 134217728
DepthFill | 33554432
Wait | 16777216
RotationAngle | 262144
RasterOperation | 131072
KeySourceOverride | 65536
KeySource | 32768
KeyDestinationOverride | 16384
KeyDestination | 8192
RasterOperations | 4096
Effects | 2048
ColorFix | 1024
Async | 512
AlphaSourceSurfaceOverride | 256
AlphaSourceNegative | 128
AlphaSourceConstOverride | 64
AlphaSource | 32
AlphaEdgeBlend | 16
AlphaDestinationSurfaceOverride | 8
AlphaDestinationNegative | 4
AlphaDestinationConstOverride | 2
AlphaDestination | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FlipFlags Enumeration (Microsoft.DirectX.DirectDraw)

FlipFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags specifying flip options. Deprecated.

Definition

Visual Basic | Public Enum FlipFlags
C# | public enum FlipFlags
C++ | public enum class FlipFlags
JScript | public enum FlipFlags

Members

Member | Value | Description
DoNotWait | 32
Stereo | 16
Interval4 | 67108864
Interval3 | 50331648
Interval2 | 33554432
NoVSync | 8
Odd | 4
Even | 2
Wait | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FourCc Enumeration (Microsoft.DirectX.DirectDraw)

FourCc Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
FourCc codes Deprecated.

Definition

Visual Basic | Public Enum FourCc
C# | public enum FourCc
C++ | public enum class FourCc
JScript | public enum FourCc

Members

Member | Value | Description
Dxt5 | 894720068
Dxt4 | 877942852
Dxt3 | 861165636
Dxt2 | 844388420
Dxt1 | 827611204

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GetDeviceFlags Enumeration (Microsoft.DirectX.DirectDraw)

GetDeviceFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GetDeviceFlags Deprecated.

Definition

Visual Basic | Public Enum GetDeviceFlags
C# | public enum GetDeviceFlags
C++ | public enum class GetDeviceFlags
JScript | public enum GetDeviceFlags

Members

Member | Value | Description
Default | 0
GetHostIdentifier | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GetDevicesFlags Enumeration (Microsoft.DirectX.DirectDraw)

GetDevicesFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GetDevicesFlags Deprecated.

Definition

Visual Basic | Public Enum GetDevicesFlags
C# | public enum GetDevicesFlags
C++ | public enum class GetDevicesFlags
JScript | public enum GetDevicesFlags

Members

Member | Value | Description
All | 7
NonDisplayDevices | 4
DetachedSecondaryDevice | 2
AttachedSecondaryDevice | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GetDisplayModeFlags Enumeration (Microsoft.DirectX.DirectDraw)

GetDisplayModeFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Getting displaymode flags, can be used to enumerate Standard VGA Modes, or RefreshRates. Deprecated.

Definition

Visual Basic | Public Enum GetDisplayModeFlags
C# | public enum GetDisplayModeFlags
C++ | public enum class GetDisplayModeFlags
JScript | public enum GetDisplayModeFlags

Members

Member | Value | Description
StandardVgaModes | 2
RefreshRates | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GetSurfacesFlags Enumeration (Microsoft.DirectX.DirectDraw)

GetSurfacesFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The search type flag determines how the method searches for matching surfaces; The matching flag determines whether the method enumerates all surfaces, only those that match, or only those that do not match the description. Deprecated.

Definition

Visual Basic | Public Enum GetSurfacesFlags
C# | public enum GetSurfacesFlags
C++ | public enum class GetSurfacesFlags
JScript | public enum GetSurfacesFlags

Members

Member | Value | Description
AllMatched | 3
DoesExist | 16
CanBeCreated | 8
NoMatch | 4
All | 1
Match | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LockFlags Enumeration (Microsoft.DirectX.DirectDraw)

LockFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags describing locking. Deprecated.

Definition

Visual Basic | Public Enum LockFlags
C# | public enum LockFlags
C++ | public enum class LockFlags
JScript | public enum LockFlags

Members

Member | Value | Description
DoNotWait | 16384
NoSystemLock | 2048
WriteOnly | 32
ReadOnly | 16
Wait | 1
SurfaceMemoryPointer | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlayEffectsFlags Enumeration (Microsoft.DirectX.DirectDraw)

OverlayEffectsFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for overlay effects. Deprecated.

Definition

Visual Basic | Public Enum OverlayEffectsFlags
C# | public enum OverlayEffectsFlags
C++ | public enum class OverlayEffectsFlags
JScript | public enum OverlayEffectsFlags

Members

Member | Value | Description
Deinterlace | 8
MirrorUpDown | 4
MirrorLeftRight | 2
ArithmeticStretchY | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlayFlags Enumeration (Microsoft.DirectX.DirectDraw)

OverlayFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.

Definition

Visual Basic | Public Enum OverlayFlags
C# | public enum OverlayFlags
C++ | public enum class OverlayFlags
JScript | public enum OverlayFlags

Members

Member | Value | Description
DegradeArgbScaling | 67108864
ArgbScaleFactors | 33554432
BobHardware | 16777216
Interleaved | 8388608
OverrideBobWeave | 4194304
Bob | 2097152
AutoFlip | 1048576
Effects | 524288
RefreshAll | 131072
RefreshDirtyRectangles | 65536
AddDirtyRectangle | 32768
Show | 16384
KeySourceOverride | 8192
KeySource | 4096
KeyDestinationOverride | 2048
KeyDestination | 1024
Hide | 512
AlphaSurfaceOverride | 256
AlphaSourceNegative | 128
AlphaSourceConstOverride | 64
AlphaSource | 32
AlphaEdgeBlend | 16
AlphaDestinationSurfaceOverride | 8
AlphaDestinationNegative | 4
AlphaDestinationOverride | 2
AlphaDestination | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlayZFlags Enumeration (Microsoft.DirectX.DirectDraw)

OverlayZFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.

Definition

Visual Basic | Public Enum OverlayZFlags
C# | public enum OverlayZFlags
C++ | public enum class OverlayZFlags
JScript | public enum OverlayZFlags

Members

Member | Value | Description
InsertInBackOf | 5
InsertInFrontOf | 4
MoveBackward | 3
MoveForward | 2
SendToBack | 1
SendToFront | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlayZOrdersFlags Enumeration (Microsoft.DirectX.DirectDraw)

OverlayZOrdersFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay flags. Deprecated.

Definition

Visual Basic | Public Enum OverlayZOrdersFlags
C# | public enum OverlayZOrdersFlags
C++ | public enum class OverlayZOrdersFlags
JScript | public enum OverlayZOrdersFlags

Members

Member | Value | Description
FrontToBack | 1
BackToFront | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StartModeTestFlags Enumeration (Microsoft.DirectX.DirectDraw)

StartModeTestFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for the StartModeTest call. Deprecated.

Definition

Visual Basic | Public Enum StartModeTestFlags
C# | public enum StartModeTestFlags
C++ | public enum class StartModeTestFlags
JScript | public enum StartModeTestFlags

Members

Member | Value | Description
IsTestRequired | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StereoViewCapsFlags Enumeration (Microsoft.DirectX.DirectDraw)

StereoViewCapsFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for Stereo View caps... Deprecated.

Definition

Visual Basic | Public Enum StereoViewCapsFlags
C# | public enum StereoViewCapsFlags
C++ | public enum class StereoViewCapsFlags
JScript | public enum StereoViewCapsFlags

Members

Member | Value | Description
StereoSequential | 16

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


WaitVbFlags Enumeration (Microsoft.DirectX.DirectDraw)

WaitVbFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines how long to wait for the vertical blank. Deprecated.

Definition

Visual Basic | Public Enum WaitVbFlags
C# | public enum WaitVbFlags
C++ | public enum class WaitVbFlags
JScript | public enum WaitVbFlags

Members

Member | Value | Description
BlockEnd | 4
BlockBeginEvent | 2
BlockBegin | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Caps Structure (Microsoft.DirectX.DirectDraw)

Caps Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the capabilities of the hardware exposed through the DirectDraw object. Deprecated.

Definition

Visual Basic | Public Structure Caps
C# | public struct Caps
C++ | public value class Caps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Caps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AlignBoundaryDestination
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination-rectangle alignment for an overlay surface, in pixels. Deprecated.
AlignBoundaryDestinationCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay destination rectangles with the x-axis aligned to the AlignBoundaryDest boundaries of the surface. Deprecated.
AlignBoundarySource
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source-rectangle alignment for an overlay surface, in pixels. Deprecated.
AlignBoundarySourceCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay source rectangles with the x-axis aligned to the AlignBoundarySource boundaries of the surface. Deprecated.
AlignSizeDestination
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination-rectangle size alignment for an overlay surface, in pixels. Overlay destination rectangles must have a pixel width that is a multiple of this value. Deprecated.
AlignSizeDestinationCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay destination rectangles whose x-axis sizes, in pixels, are AlignSizeDest multiples. Deprecated.
AlignSizeSource
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source-rectangle size alignment for an overlay surface, in pixels. Overlay source rectangles must have a pixel width that is a multiple of this value. Deprecated.
AlignSizeSourceCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay source rectangles whose x-axis sizes, in pixels, are AlignSizeSource multiples. Deprecated.
AlignStride
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stride alignment. Deprecated.
AlignStrideAlign
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stride alignment. Deprecated.
Alpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display hardware supports alpha-only surfaces. Deprecated.
AlphaDrawConstBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 2, 4, or 8 bits per pixel. Deprecated.
AlphaDrawPixelBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.
AlphaDrawSurfaceBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel.) Deprecated.
AlphaOverlayConstBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.
AlphaOverlayPixelBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.
AlphaOverlaySurfaceBitDepths
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.
AutoFlipOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay can be automatically flipped to the next surface in the flipping chain each time that a video port VSYNC occurs, allowing the video port and the overlay to double-buffer the video without CPU overhead. This option is only valid when the surface is receiving data from a video port. If the video port data is noninterlaced or noninterleaved, it flips on every VSYNC. If the data is being interleaved in memory, it flips on every other VSYNC. Deprecated.
BankSwitched
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display hardware is bank-switched and is potentially very slow at random access to display memory. Deprecated.
CanClip
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of clipping with blitting. Deprecated.
CanClipStretched
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of clipping while stretch blitting. Deprecated.
CanDrawSystemMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of blitting to or from system memory. Deprecated.
CanFlipOddEven
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver is capable of performing odd and even flip operations. Deprecated.
CertifiedHardware
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is certified. Deprecated.
ColorControlOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay surface contains color controls (such as brightness and sharpness) Deprecated.
ColorControlPrimary
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The primary surface contains color controls (for instance, gamma) Deprecated.
ColorFill
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of color filling with a blitter. Deprecated.
ColorKeyCapable
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports some form of color key in either overlay or blit operations. Deprecated.
ColorKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color Key cababilities Deprecated.
ColorKeyHardwareAssisted
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The color key is partially hardware-assisted. This means that other resources (CPU or video memory) might be used. If this bit is not set, full hardware support is in place. Deprecated.
CopyFourCc
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver supports blitting any FOURCC surface to another surface of the same FOURCC. Deprecated.
CurrentVideoPorts
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current number of live video ports. Deprecated.
CurrentVisibleOverlays
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current number of visible overlays or overlay sprites. Deprecated.
Draw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of blit operations. Deprecated.
DrawFourCc
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of color-space conversions during blit operations. Deprecated.
DrawQueue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of asynchronous blit operations. Deprecated.
DrawStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of stretching during blit operations. Deprecated.
FlipInterval
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver responds to the FileInterval flags Deprecated.
FlipNoVSync
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver responds to the NoVsync flag. Deprecated.
FXAlphaCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.
FXCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.
GammaCalibration
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The system has a calibrator installed that can automatically adjust the gamma ramp so that the result is identical on all systems that have a calibrator. Deprecated.
GdiShared
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is shared with GDI Deprecated.
MaxHardwareCodecStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obsolete; do not use. Deprecated.
MaxOverlayStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
maximum overlay stretch factors, multiplied by 1000. For example, 1.3 = 1300. Deprecated.
MaxVideoPorts
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum video ports. Deprecated.
MaxVisibleOverlays
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of visible overlays Deprecated.
MinHardwareCodecStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obsolete; do not use. Deprecated.
MinOverlayStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Minimum overlay stretch factors, multiplied by 1000. For example, 1.3 = 1300. Deprecated.
NlVbCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from nonlocal to local video memory. Deprecated.
NlVbCKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits form nonlocal to local video memory. Deprecated.
NlVbEffectsCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from nonlocal to local video memory. Deprecated.
NlVbExtendedCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver extended capabilities for blits from nonlocal to local video memory. Deprecated.
NlVbRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from nonlocal to local video memory. Deprecated.
NoHardware
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support. Deprecated.
NonLocalVideoMemory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display driver supports surfaces in nonlocal video memory. Deprecated.
NoPageLockRequired
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DMA blit operations are supported on system-memory surfaces that are not page-locked. Deprecated.
NumberFourCcCodes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of FourCC codes. Deprecated.
Overlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports overlays. Deprecated.
OverlayCannotClip
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports overlays but cannot clip them. Deprecated.
OverlayFourCc
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay hardware is capable of color-space conversions during overlay operations. Deprecated.
OverlayHardwareDisplaysInterlacedVideo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually. Deprecated.
OverlayHardwareDisplaysInterleavedVideo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually while it is interleaved in memory without causing any artifacts that might normally occur without special hardware support. This option is only valid when the surface is receiving data from a video port and the video is zoomed at least twice in the vertical direction. Deprecated.
OverlayHardwareDisplaysNonInterleavedVideo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually while it is not interleaved in memory without causing any artifacts that might normally occur without special hardware support. This option is only valid when the surface is receiving data from a video port and the video is zoomed at least twice in the vertical direction. Deprecated.
OverlayStretch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay hardware is capable of stretching. Deprecated.
Palette
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is capable of creating and supporting DirectDrawPalette objects for surfaces other than the primary surface. Deprecated.
PaletteCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Palette capabilities. Deprecated.
PaletteVerticalSync
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is capable of updating a palette synchronized with the vertical refresh. Deprecated.
PrimaryGamma
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports dynamic gamma ramps for the primary surface. Deprecated.
RasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported. Deprecated.
ReadScanLine
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of returning the current scan line. Deprecated.
SsbCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from system memory to system memory. Deprecated.
SsbCKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from system memory to system memory. Deprecated.
SsbEffectsCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from system memory to system memory. Deprecated.
SsbRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from system memory to system memory. Deprecated.
Stereo
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns on the bit to support stereo mode. The driver can do stereo in at least one mode other than the current mode. Deprecated.
StereoVisionSequential
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver can do stereo in at least one mode other than the current mode. Deprecated.
SurfaceCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
General surface capabilities. Deprecated.
SvbCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from system memory to display memory. Deprecated.
SvbcKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from system memory to display memory. Deprecated.
SvbEffectsCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from system memory to display memory. Deprecated.
SvbExtendedCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver extended capabilities for blits from system memory to display memory. Deprecated.
SvbRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from system memory to display memory. Deprecated.
SvCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stereo-vision capabilities Deprecated.
VerticalBlankInterrupt
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of generating a vertical-blank interrupt. Deprecated.
VideoMemoryFree
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Free display memory. Deprecated.
VideoMemoryTotal
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Total amount of display memory on the device, in bytes, minus memory reserved for the primary surface and any private data structures reserved by the driver. Deprecated.
VideoPort
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports live video. Deprecated.
VsbCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from display memory to system memory. Deprecated.
VsbCKeyCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from display memory to system memory. Deprecated.
VsbEffectsCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from display memory to system memory. Deprecated.
VsbRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from display memory to system memory. Deprecated.
WideSurfaces
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display surface supports surfaces wider than the primary surface. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Caps.Caps() Constructor (Microsoft.DirectX.DirectDraw)

Caps.Caps Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Caps();
C++ public:
Caps();
JScript | public function Caps();


Caps.ToString() Method (Microsoft.DirectX.DirectDraw)

Caps.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Caps.AlignBoundaryDestination Property (Microsoft.DirectX.DirectDraw)

Caps.AlignBoundaryDestination Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination-rectangle alignment for an overlay surface, in pixels. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignBoundaryDestination As Integer
C# | public int AlignBoundaryDestination { get; }
C++ public:
property int AlignBoundaryDestination {
int get();
}
JScript | public function get AlignBoundaryDestination() : int

Property Value

System.Int32

This property is read-only.


Caps.AlignBoundaryDestinationCaps Property (Microsoft.DirectX.DirectDraw)

Caps.AlignBoundaryDestinationCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay destination rectangles with the x-axis aligned to the AlignBoundaryDest boundaries of the surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignBoundaryDestinationCaps As Boolean
C# | public bool AlignBoundaryDestinationCaps { get; }
C++ public:
property bool AlignBoundaryDestinationCaps {
bool get();
}
JScript | public function get AlignBoundaryDestinationCaps() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.AlignBoundarySource Property (Microsoft.DirectX.DirectDraw)

Caps.AlignBoundarySource Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source-rectangle alignment for an overlay surface, in pixels. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignBoundarySource As Integer
C# | public int AlignBoundarySource { get; }
C++ public:
property int AlignBoundarySource {
int get();
}
JScript | public function get AlignBoundarySource() : int

Property Value

System.Int32

This property is read-only.


Caps.AlignBoundarySourceCaps Property (Microsoft.DirectX.DirectDraw)

Caps.AlignBoundarySourceCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay source rectangles with the x-axis aligned to the AlignBoundarySource boundaries of the surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignBoundarySourceCaps As Boolean
C# | public bool AlignBoundarySourceCaps { get; }
C++ public:
property bool AlignBoundarySourceCaps {
bool get();
}
JScript | public function get AlignBoundarySourceCaps() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.AlignSizeDestination Property (Microsoft.DirectX.DirectDraw)

Caps.AlignSizeDestination Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination-rectangle size alignment for an overlay surface, in pixels. Overlay destination rectangles must have a pixel width that is a multiple of this value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignSizeDestination As Integer
C# | public int AlignSizeDestination { get; }
C++ public:
property int AlignSizeDestination {
int get();
}
JScript | public function get AlignSizeDestination() : int

Property Value

System.Int32

This property is read-only.


Caps.AlignSizeDestinationCaps Property (Microsoft.DirectX.DirectDraw)

Caps.AlignSizeDestinationCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay destination rectangles whose x-axis sizes, in pixels, are AlignSizeDest multiples. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignSizeDestinationCaps As Boolean
C# | public bool AlignSizeDestinationCaps { get; }
C++ public:
property bool AlignSizeDestinationCaps {
bool get();
}
JScript | public function get AlignSizeDestinationCaps() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.AlignSizeSource Property (Microsoft.DirectX.DirectDraw)

Caps.AlignSizeSource Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source-rectangle size alignment for an overlay surface, in pixels. Overlay source rectangles must have a pixel width that is a multiple of this value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignSizeSource As Integer
C# | public int AlignSizeSource { get; }
C++ public:
property int AlignSizeSource {
int get();
}
JScript | public function get AlignSizeSource() : int

Property Value

System.Int32

This property is read-only.


Caps.AlignSizeSourceCaps Property (Microsoft.DirectX.DirectDraw)

Caps.AlignSizeSourceCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw supports only those overlay source rectangles whose x-axis sizes, in pixels, are AlignSizeSource multiples. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignSizeSourceCaps As Boolean
C# | public bool AlignSizeSourceCaps { get; }
C++ public:
property bool AlignSizeSourceCaps {
bool get();
}
JScript | public function get AlignSizeSourceCaps() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.AlignStride Property (Microsoft.DirectX.DirectDraw)

Caps.AlignStride Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stride alignment. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignStride As Boolean
C# | public bool AlignStride { get; }
C++ public:
property bool AlignStride {
bool get();
}
JScript | public function get AlignStride() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.AlignStrideAlign Property (Microsoft.DirectX.DirectDraw)

Caps.AlignStrideAlign Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stride alignment. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlignStrideAlign As Integer
C# | public int AlignStrideAlign { get; }
C++ public:
property int AlignStrideAlign {
int get();
}
JScript | public function get AlignStrideAlign() : int

Property Value

System.Int32

This property is read-only.


Caps.Alpha Property (Microsoft.DirectX.DirectDraw)

Caps.Alpha Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display hardware supports alpha-only surfaces. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Alpha As Boolean
C# | public bool Alpha { get; }
C++ public:
property bool Alpha {
bool get();
}
JScript | public function get Alpha() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.AlphaDrawConstBitDepths Property (Microsoft.DirectX.DirectDraw)

Caps.AlphaDrawConstBitDepths Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlphaDrawConstBitDepths As Integer
C# | public int AlphaDrawConstBitDepths { get; }
C++ public:
property int AlphaDrawConstBitDepths {
int get();
}
JScript | public function get AlphaDrawConstBitDepths() : int

Property Value

System.Int32

This property is read-only.


Caps.AlphaDrawPixelBitDepths Property (Microsoft.DirectX.DirectDraw)

Caps.AlphaDrawPixelBitDepths Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlphaDrawPixelBitDepths As Integer
C# | public int AlphaDrawPixelBitDepths { get; }
C++ public:
property int AlphaDrawPixelBitDepths {
int get();
}
JScript | public function get AlphaDrawPixelBitDepths() : int

Property Value

System.Int32

This property is read-only.


Caps.AlphaDrawSurfaceBitDepths Property (Microsoft.DirectX.DirectDraw)

Caps.AlphaDrawSurfaceBitDepths Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel.) Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlphaDrawSurfaceBitDepths As Integer
C# | public int AlphaDrawSurfaceBitDepths { get; }
C++ public:
property int AlphaDrawSurfaceBitDepths {
int get();
}
JScript | public function get AlphaDrawSurfaceBitDepths() : int

Property Value

System.Int32

This property is read-only.


Caps.AlphaOverlayConstBitDepths Property (Microsoft.DirectX.DirectDraw)

Caps.AlphaOverlayConstBitDepths Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlphaOverlayConstBitDepths As Integer
C# | public int AlphaOverlayConstBitDepths { get; }
C++ public:
property int AlphaOverlayConstBitDepths {
int get();
}
JScript | public function get AlphaOverlayConstBitDepths() : int

Property Value

System.Int32

This property is read-only.


Caps.AlphaOverlayPixelBitDepths Property (Microsoft.DirectX.DirectDraw)

Caps.AlphaOverlayPixelBitDepths Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlphaOverlayPixelBitDepths As Integer
C# | public int AlphaOverlayPixelBitDepths { get; }
C++ public:
property int AlphaOverlayPixelBitDepths {
int get();
}
JScript | public function get AlphaOverlayPixelBitDepths() : int

Property Value

System.Int32

This property is read-only.


Caps.AlphaOverlaySurfaceBitDepths Property (Microsoft.DirectX.DirectDraw)

Caps.AlphaOverlaySurfaceBitDepths Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicate 1, 2, 4, or 8 bits per pixel. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AlphaOverlaySurfaceBitDepths As Integer
C# | public int AlphaOverlaySurfaceBitDepths { get; }
C++ public:
property int AlphaOverlaySurfaceBitDepths {
int get();
}
JScript | public function get AlphaOverlaySurfaceBitDepths() : int

Property Value

System.Int32

This property is read-only.


Caps.AutoFlipOverlay Property (Microsoft.DirectX.DirectDraw)

Caps.AutoFlipOverlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay can be automatically flipped to the next surface in the flipping chain each time that a video port VSYNC occurs, allowing the video port and the overlay to double-buffer the video without CPU overhead. This option is only valid when the surface is receiving data from a video port. If the video port data is noninterlaced or noninterleaved, it flips on every VSYNC. If the data is being interleaved in memory, it flips on every other VSYNC. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AutoFlipOverlay As Boolean
C# | public bool AutoFlipOverlay { get; }
C++ public:
property bool AutoFlipOverlay {
bool get();
}
JScript | public function get AutoFlipOverlay() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.BankSwitched Property (Microsoft.DirectX.DirectDraw)

Caps.BankSwitched Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display hardware is bank-switched and is potentially very slow at random access to display memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property BankSwitched As Boolean
C# | public bool BankSwitched { get; }
C++ public:
property bool BankSwitched {
bool get();
}
JScript | public function get BankSwitched() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.CanClip Property (Microsoft.DirectX.DirectDraw)

Caps.CanClip Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of clipping with blitting. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CanClip As Boolean
C# | public bool CanClip { get; }
C++ public:
property bool CanClip {
bool get();
}
JScript | public function get CanClip() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.CanClipStretched Property (Microsoft.DirectX.DirectDraw)

Caps.CanClipStretched Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of clipping while stretch blitting. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CanClipStretched As Boolean
C# | public bool CanClipStretched { get; }
C++ public:
property bool CanClipStretched {
bool get();
}
JScript | public function get CanClipStretched() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.CanDrawSystemMemory Property (Microsoft.DirectX.DirectDraw)

Caps.CanDrawSystemMemory Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of blitting to or from system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CanDrawSystemMemory As Boolean
C# | public bool CanDrawSystemMemory { get; }
C++ public:
property bool CanDrawSystemMemory {
bool get();
}
JScript | public function get CanDrawSystemMemory() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.CanFlipOddEven Property (Microsoft.DirectX.DirectDraw)

Caps.CanFlipOddEven Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver is capable of performing odd and even flip operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CanFlipOddEven As Boolean
C# | public bool CanFlipOddEven { get; }
C++ public:
property bool CanFlipOddEven {
bool get();
}
JScript | public function get CanFlipOddEven() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.CertifiedHardware Property (Microsoft.DirectX.DirectDraw)

Caps.CertifiedHardware Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is certified. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CertifiedHardware As Boolean
C# | public bool CertifiedHardware { get; }
C++ public:
property bool CertifiedHardware {
bool get();
}
JScript | public function get CertifiedHardware() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.ColorControlOverlay Property (Microsoft.DirectX.DirectDraw)

Caps.ColorControlOverlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay surface contains color controls (such as brightness and sharpness) Deprecated.

Definition

Visual Basic | Public ReadOnly Property ColorControlOverlay As Boolean
C# | public bool ColorControlOverlay { get; }
C++ public:
property bool ColorControlOverlay {
bool get();
}
JScript | public function get ColorControlOverlay() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.ColorControlPrimary Property (Microsoft.DirectX.DirectDraw)

Caps.ColorControlPrimary Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The primary surface contains color controls (for instance, gamma) Deprecated.

Definition

Visual Basic | Public ReadOnly Property ColorControlPrimary As Boolean
C# | public bool ColorControlPrimary { get; }
C++ public:
property bool ColorControlPrimary {
bool get();
}
JScript | public function get ColorControlPrimary() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.ColorFill Property (Microsoft.DirectX.DirectDraw)

Caps.ColorFill Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of color filling with a blitter. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ColorFill As Boolean
C# | public bool ColorFill { get; }
C++ public:
property bool ColorFill {
bool get();
}
JScript | public function get ColorFill() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.ColorKeyCapable Property (Microsoft.DirectX.DirectDraw)

Caps.ColorKeyCapable Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports some form of color key in either overlay or blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ColorKeyCapable As Boolean
C# | public bool ColorKeyCapable { get; }
C++ public:
property bool ColorKeyCapable {
bool get();
}
JScript | public function get ColorKeyCapable() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.ColorKeyCaps Property (Microsoft.DirectX.DirectDraw)

Caps.ColorKeyCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color Key cababilities Deprecated.

Definition

Visual Basic | Public ReadOnly Property ColorKeyCaps As ColorKeyCaps
C# | public ColorKeyCaps ColorKeyCaps { get; }
C++ public:
property ColorKeyCaps ColorKeyCaps {
ColorKeyCaps get();
}
JScript | public function get ColorKeyCaps() : ColorKeyCaps

Property Value

Microsoft.DirectX.DirectDraw.ColorKeyCaps

This property is read-only.


Caps.ColorKeyHardwareAssisted Property (Microsoft.DirectX.DirectDraw)

Caps.ColorKeyHardwareAssisted Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The color key is partially hardware-assisted. This means that other resources (CPU or video memory) might be used. If this bit is not set, full hardware support is in place. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ColorKeyHardwareAssisted As Boolean
C# | public bool ColorKeyHardwareAssisted { get; }
C++ public:
property bool ColorKeyHardwareAssisted {
bool get();
}
JScript | public function get ColorKeyHardwareAssisted() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.CopyFourCc Property (Microsoft.DirectX.DirectDraw)

Caps.CopyFourCc Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver supports blitting any FOURCC surface to another surface of the same FOURCC. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CopyFourCc As Boolean
C# | public bool CopyFourCc { get; }
C++ public:
property bool CopyFourCc {
bool get();
}
JScript | public function get CopyFourCc() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.CurrentVideoPorts Property (Microsoft.DirectX.DirectDraw)

Caps.CurrentVideoPorts Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current number of live video ports. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CurrentVideoPorts As Integer
C# | public int CurrentVideoPorts { get; }
C++ public:
property int CurrentVideoPorts {
int get();
}
JScript | public function get CurrentVideoPorts() : int

Property Value

System.Int32

This property is read-only.


Caps.CurrentVisibleOverlays Property (Microsoft.DirectX.DirectDraw)

Caps.CurrentVisibleOverlays Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current number of visible overlays or overlay sprites. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CurrentVisibleOverlays As Integer
C# | public int CurrentVisibleOverlays { get; }
C++ public:
property int CurrentVisibleOverlays {
int get();
}
JScript | public function get CurrentVisibleOverlays() : int

Property Value

System.Int32

This property is read-only.


Caps.Draw Property (Microsoft.DirectX.DirectDraw)

Caps.Draw Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Draw As Boolean
C# | public bool Draw { get; }
C++ public:
property bool Draw {
bool get();
}
JScript | public function get Draw() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.DrawFourCc Property (Microsoft.DirectX.DirectDraw)

Caps.DrawFourCc Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of color-space conversions during blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawFourCc As Boolean
C# | public bool DrawFourCc { get; }
C++ public:
property bool DrawFourCc {
bool get();
}
JScript | public function get DrawFourCc() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.DrawQueue Property (Microsoft.DirectX.DirectDraw)

Caps.DrawQueue Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of asynchronous blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawQueue As Boolean
C# | public bool DrawQueue { get; }
C++ public:
property bool DrawQueue {
bool get();
}
JScript | public function get DrawQueue() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.DrawStretch Property (Microsoft.DirectX.DirectDraw)

Caps.DrawStretch Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of stretching during blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawStretch As Boolean
C# | public bool DrawStretch { get; }
C++ public:
property bool DrawStretch {
bool get();
}
JScript | public function get DrawStretch() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.FlipInterval Property (Microsoft.DirectX.DirectDraw)

Caps.FlipInterval Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver responds to the FileInterval flags Deprecated.

Definition

Visual Basic | Public ReadOnly Property FlipInterval As Boolean
C# | public bool FlipInterval { get; }
C++ public:
property bool FlipInterval {
bool get();
}
JScript | public function get FlipInterval() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.FlipNoVSync Property (Microsoft.DirectX.DirectDraw)

Caps.FlipNoVSync Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver responds to the NoVsync flag. Deprecated.

Definition

Visual Basic | Public ReadOnly Property FlipNoVSync As Boolean
C# | public bool FlipNoVSync { get; }
C++ public:
property bool FlipNoVSync {
bool get();
}
JScript | public function get FlipNoVSync() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.FXAlphaCaps Property (Microsoft.DirectX.DirectDraw)

Caps.FXAlphaCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.

Definition

Visual Basic | Public ReadOnly Property FXAlphaCaps As FXAlphaCaps
C# | public FXAlphaCaps FXAlphaCaps { get; }
C++ public:
property FXAlphaCaps FXAlphaCaps {
FXAlphaCaps get();
}
JScript | public function get FXAlphaCaps() : FXAlphaCaps

Property Value

Microsoft.DirectX.DirectDraw.FXAlphaCaps

This property is read-only.


Caps.FXCaps Property (Microsoft.DirectX.DirectDraw)

Caps.FXCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.

Definition

Visual Basic | Public ReadOnly Property FXCaps As FXCaps
C# | public FXCaps FXCaps { get; }
C++ public:
property FXCaps FXCaps {
FXCaps get();
}
JScript | public function get FXCaps() : FXCaps

Property Value

Microsoft.DirectX.DirectDraw.FXCaps

This property is read-only.


Caps.GammaCalibration Property (Microsoft.DirectX.DirectDraw)

Caps.GammaCalibration Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The system has a calibrator installed that can automatically adjust the gamma ramp so that the result is identical on all systems that have a calibrator. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GammaCalibration As Boolean
C# | public bool GammaCalibration { get; }
C++ public:
property bool GammaCalibration {
bool get();
}
JScript | public function get GammaCalibration() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.GdiShared Property (Microsoft.DirectX.DirectDraw)

Caps.GdiShared Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is shared with GDI Deprecated.

Definition

Visual Basic | Public ReadOnly Property GdiShared As Boolean
C# | public bool GdiShared { get; }
C++ public:
property bool GdiShared {
bool get();
}
JScript | public function get GdiShared() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.MaxHardwareCodecStretch Property (Microsoft.DirectX.DirectDraw)

Caps.MaxHardwareCodecStretch Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obsolete; do not use. Deprecated.

Definition

Visual Basic | Public ReadOnly Property MaxHardwareCodecStretch As Integer
C# | public int MaxHardwareCodecStretch { get; }
C++ public:
property int MaxHardwareCodecStretch {
int get();
}
JScript | public function get MaxHardwareCodecStretch() : int

Property Value

System.Int32

This property is read-only.


Caps.MaxOverlayStretch Property (Microsoft.DirectX.DirectDraw)

Caps.MaxOverlayStretch Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
maximum overlay stretch factors, multiplied by 1000. For example, 1.3 = 1300. Deprecated.

Definition

Visual Basic | Public ReadOnly Property MaxOverlayStretch As Integer
C# | public int MaxOverlayStretch { get; }
C++ public:
property int MaxOverlayStretch {
int get();
}
JScript | public function get MaxOverlayStretch() : int

Property Value

System.Int32

This property is read-only.


Caps.MaxVideoPorts Property (Microsoft.DirectX.DirectDraw)

Caps.MaxVideoPorts Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum video ports. Deprecated.

Definition

Visual Basic | Public ReadOnly Property MaxVideoPorts As Integer
C# | public int MaxVideoPorts { get; }
C++ public:
property int MaxVideoPorts {
int get();
}
JScript | public function get MaxVideoPorts() : int

Property Value

System.Int32

This property is read-only.


Caps.MaxVisibleOverlays Property (Microsoft.DirectX.DirectDraw)

Caps.MaxVisibleOverlays Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of visible overlays Deprecated.

Definition

Visual Basic | Public ReadOnly Property MaxVisibleOverlays As Integer
C# | public int MaxVisibleOverlays { get; }
C++ public:
property int MaxVisibleOverlays {
int get();
}
JScript | public function get MaxVisibleOverlays() : int

Property Value

System.Int32

This property is read-only.


Caps.MinHardwareCodecStretch Property (Microsoft.DirectX.DirectDraw)

Caps.MinHardwareCodecStretch Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obsolete; do not use. Deprecated.

Definition

Visual Basic | Public ReadOnly Property MinHardwareCodecStretch As Integer
C# | public int MinHardwareCodecStretch { get; }
C++ public:
property int MinHardwareCodecStretch {
int get();
}
JScript | public function get MinHardwareCodecStretch() : int

Property Value

System.Int32

This property is read-only.


Caps.MinOverlayStretch Property (Microsoft.DirectX.DirectDraw)

Caps.MinOverlayStretch Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Minimum overlay stretch factors, multiplied by 1000. For example, 1.3 = 1300. Deprecated.

Definition

Visual Basic | Public ReadOnly Property MinOverlayStretch As Integer
C# | public int MinOverlayStretch { get; }
C++ public:
property int MinOverlayStretch {
int get();
}
JScript | public function get MinOverlayStretch() : int

Property Value

System.Int32

This property is read-only.


Caps.NlVbCaps Property (Microsoft.DirectX.DirectDraw)

Caps.NlVbCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from nonlocal to local video memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NlVbCaps As Integer
C# | public int NlVbCaps { get; }
C++ public:
property int NlVbCaps {
int get();
}
JScript | public function get NlVbCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.NlVbCKeyCaps Property (Microsoft.DirectX.DirectDraw)

Caps.NlVbCKeyCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits form nonlocal to local video memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NlVbCKeyCaps As Integer
C# | public int NlVbCKeyCaps { get; }
C++ public:
property int NlVbCKeyCaps {
int get();
}
JScript | public function get NlVbCKeyCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.NlVbEffectsCaps Property (Microsoft.DirectX.DirectDraw)

Caps.NlVbEffectsCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from nonlocal to local video memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NlVbEffectsCaps As Integer
C# | public int NlVbEffectsCaps { get; }
C++ public:
property int NlVbEffectsCaps {
int get();
}
JScript | public function get NlVbEffectsCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.NlVbExtendedCaps Property (Microsoft.DirectX.DirectDraw)

Caps.NlVbExtendedCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver extended capabilities for blits from nonlocal to local video memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NlVbExtendedCaps As Integer
C# | public int NlVbExtendedCaps { get; }
C++ public:
property int NlVbExtendedCaps {
int get();
}
JScript | public function get NlVbExtendedCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.NlVbRasterOperations Property (Microsoft.DirectX.DirectDraw)

Caps.NlVbRasterOperations Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from nonlocal to local video memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NlVbRasterOperations As Integer()
C# | public int[] NlVbRasterOperations { get; }
C++ public:
property array<int>^ NlVbRasterOperations {
array<int>^ get();
}
JScript | public function get NlVbRasterOperations() : int[]

Property Value

System.Int32[]

This property is read-only.


Caps.NoHardware Property (Microsoft.DirectX.DirectDraw)

Caps.NoHardware Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no hardware support. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NoHardware As Boolean
C# | public bool NoHardware { get; }
C++ public:
property bool NoHardware {
bool get();
}
JScript | public function get NoHardware() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.NonLocalVideoMemory Property (Microsoft.DirectX.DirectDraw)

Caps.NonLocalVideoMemory Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display driver supports surfaces in nonlocal video memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NonLocalVideoMemory As Boolean
C# | public bool NonLocalVideoMemory { get; }
C++ public:
property bool NonLocalVideoMemory {
bool get();
}
JScript | public function get NonLocalVideoMemory() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.NoPageLockRequired Property (Microsoft.DirectX.DirectDraw)

Caps.NoPageLockRequired Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DMA blit operations are supported on system-memory surfaces that are not page-locked. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NoPageLockRequired As Boolean
C# | public bool NoPageLockRequired { get; }
C++ public:
property bool NoPageLockRequired {
bool get();
}
JScript | public function get NoPageLockRequired() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.NumberFourCcCodes Property (Microsoft.DirectX.DirectDraw)

Caps.NumberFourCcCodes Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of FourCC codes. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NumberFourCcCodes As Integer
C# | public int NumberFourCcCodes { get; }
C++ public:
property int NumberFourCcCodes {
int get();
}
JScript | public function get NumberFourCcCodes() : int

Property Value

System.Int32

This property is read-only.


Caps.Overlay Property (Microsoft.DirectX.DirectDraw)

Caps.Overlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports overlays. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Overlay As Boolean
C# | public bool Overlay { get; }
C++ public:
property bool Overlay {
bool get();
}
JScript | public function get Overlay() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.OverlayCannotClip Property (Microsoft.DirectX.DirectDraw)

Caps.OverlayCannotClip Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports overlays but cannot clip them. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayCannotClip As Boolean
C# | public bool OverlayCannotClip { get; }
C++ public:
property bool OverlayCannotClip {
bool get();
}
JScript | public function get OverlayCannotClip() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.OverlayFourCc Property (Microsoft.DirectX.DirectDraw)

Caps.OverlayFourCc Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay hardware is capable of color-space conversions during overlay operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayFourCc As Boolean
C# | public bool OverlayFourCc { get; }
C++ public:
property bool OverlayFourCc {
bool get();
}
JScript | public function get OverlayFourCc() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.OverlayHardwareDisplaysInterlacedVideo Property (Microsoft.DirectX.DirectDraw)

Caps.OverlayHardwareDisplaysInterlacedVideo Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayHardwareDisplaysInterlacedVideo As Boolean
C# | public bool OverlayHardwareDisplaysInterlacedVideo { get; }
C++ public:
property bool OverlayHardwareDisplaysInterlacedVideo {
bool get();
}
JScript | public function get OverlayHardwareDisplaysInterlacedVideo() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.OverlayHardwareDisplaysInterleavedVideo Property (Microsoft.DirectX.DirectDraw)

Caps.OverlayHardwareDisplaysInterleavedVideo Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually while it is interleaved in memory without causing any artifacts that might normally occur without special hardware support. This option is only valid when the surface is receiving data from a video port and the video is zoomed at least twice in the vertical direction. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayHardwareDisplaysInterleavedVideo As Boolean
C# | public bool OverlayHardwareDisplaysInterleavedVideo { get; }
C++ public:
property bool OverlayHardwareDisplaysInterleavedVideo {
bool get();
}
JScript | public function get OverlayHardwareDisplaysInterleavedVideo() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.OverlayHardwareDisplaysNonInterleavedVideo Property (Microsoft.DirectX.DirectDraw)

Caps.OverlayHardwareDisplaysNonInterleavedVideo Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The overlay hardware can display each field of an interlaced video stream individually while it is not interleaved in memory without causing any artifacts that might normally occur without special hardware support. This option is only valid when the surface is receiving data from a video port and the video is zoomed at least twice in the vertical direction. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayHardwareDisplaysNonInterleavedVideo As Boolean
C# | public bool OverlayHardwareDisplaysNonInterleavedVideo { get; }
C++ public:
property bool OverlayHardwareDisplaysNonInterleavedVideo {
bool get();
}
JScript | public function get OverlayHardwareDisplaysNonInterleavedVideo() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.OverlayStretch Property (Microsoft.DirectX.DirectDraw)

Caps.OverlayStretch Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay hardware is capable of stretching. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayStretch As Boolean
C# | public bool OverlayStretch { get; }
C++ public:
property bool OverlayStretch {
bool get();
}
JScript | public function get OverlayStretch() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.Palette Property (Microsoft.DirectX.DirectDraw)

Caps.Palette Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is capable of creating and supporting DirectDrawPalette objects for surfaces other than the primary surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Palette As Boolean
C# | public bool Palette { get; }
C++ public:
property bool Palette {
bool get();
}
JScript | public function get Palette() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.PaletteCaps Property (Microsoft.DirectX.DirectDraw)

Caps.PaletteCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Palette capabilities. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PaletteCaps As PaletteCaps
C# | public PaletteCaps PaletteCaps { get; }
C++ public:
property PaletteCaps PaletteCaps {
PaletteCaps get();
}
JScript | public function get PaletteCaps() : PaletteCaps

Property Value

Microsoft.DirectX.DirectDraw.PaletteCaps

This property is read-only.


Caps.PaletteVerticalSync Property (Microsoft.DirectX.DirectDraw)

Caps.PaletteVerticalSync Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw is capable of updating a palette synchronized with the vertical refresh. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PaletteVerticalSync As Boolean
C# | public bool PaletteVerticalSync { get; }
C++ public:
property bool PaletteVerticalSync {
bool get();
}
JScript | public function get PaletteVerticalSync() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.PrimaryGamma Property (Microsoft.DirectX.DirectDraw)

Caps.PrimaryGamma Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports dynamic gamma ramps for the primary surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PrimaryGamma As Boolean
C# | public bool PrimaryGamma { get; }
C++ public:
property bool PrimaryGamma {
bool get();
}
JScript | public function get PrimaryGamma() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.RasterOperations Property (Microsoft.DirectX.DirectDraw)

Caps.RasterOperations Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported. Deprecated.

Definition

Visual Basic | Public ReadOnly Property RasterOperations As Integer()
C# | public int[] RasterOperations { get; }
C++ public:
property array<int>^ RasterOperations {
array<int>^ get();
}
JScript | public function get RasterOperations() : int[]

Property Value

System.Int32[]

This property is read-only.


Caps.ReadScanLine Property (Microsoft.DirectX.DirectDraw)

Caps.ReadScanLine Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of returning the current scan line. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ReadScanLine As Boolean
C# | public bool ReadScanLine { get; }
C++ public:
property bool ReadScanLine {
bool get();
}
JScript | public function get ReadScanLine() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.SsbCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SsbCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from system memory to system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SsbCaps As Integer
C# | public int SsbCaps { get; }
C++ public:
property int SsbCaps {
int get();
}
JScript | public function get SsbCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.SsbCKeyCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SsbCKeyCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from system memory to system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SsbCKeyCaps As Integer
C# | public int SsbCKeyCaps { get; }
C++ public:
property int SsbCKeyCaps {
int get();
}
JScript | public function get SsbCKeyCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.SsbEffectsCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SsbEffectsCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from system memory to system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SsbEffectsCaps As Integer
C# | public int SsbEffectsCaps { get; }
C++ public:
property int SsbEffectsCaps {
int get();
}
JScript | public function get SsbEffectsCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.SsbRasterOperations Property (Microsoft.DirectX.DirectDraw)

Caps.SsbRasterOperations Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from system memory to system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SsbRasterOperations As Integer()
C# | public int[] SsbRasterOperations { get; }
C++ public:
property array<int>^ SsbRasterOperations {
array<int>^ get();
}
JScript | public function get SsbRasterOperations() : int[]

Property Value

System.Int32[]

This property is read-only.


Caps.Stereo Property (Microsoft.DirectX.DirectDraw)

Caps.Stereo Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns on the bit to support stereo mode. The driver can do stereo in at least one mode other than the current mode. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Stereo As Boolean
C# | public bool Stereo { get; }
C++ public:
property bool Stereo {
bool get();
}
JScript | public function get Stereo() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.StereoVisionSequential Property (Microsoft.DirectX.DirectDraw)

Caps.StereoVisionSequential Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The driver can do stereo in at least one mode other than the current mode. Deprecated.

Definition

Visual Basic | Public ReadOnly Property StereoVisionSequential As Boolean
C# | public bool StereoVisionSequential { get; }
C++ public:
property bool StereoVisionSequential {
bool get();
}
JScript | public function get StereoVisionSequential() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.SurfaceCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SurfaceCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
General surface capabilities. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SurfaceCaps As SurfaceCaps
C# | public SurfaceCaps SurfaceCaps { get; }
C++ public:
property SurfaceCaps^ SurfaceCaps {
SurfaceCaps^ get();
}
JScript | public function get SurfaceCaps() : SurfaceCaps

Property Value

Microsoft.DirectX.DirectDraw.SurfaceCaps

This property is read-only.


Caps.SvbCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SvbCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from system memory to display memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SvbCaps As Integer
C# | public int SvbCaps { get; }
C++ public:
property int SvbCaps {
int get();
}
JScript | public function get SvbCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.SvbcKeyCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SvbcKeyCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from system memory to display memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SvbcKeyCaps As Integer
C# | public int SvbcKeyCaps { get; }
C++ public:
property int SvbcKeyCaps {
int get();
}
JScript | public function get SvbcKeyCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.SvbEffectsCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SvbEffectsCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from system memory to display memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SvbEffectsCaps As Integer
C# | public int SvbEffectsCaps { get; }
C++ public:
property int SvbEffectsCaps {
int get();
}
JScript | public function get SvbEffectsCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.SvbExtendedCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SvbExtendedCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver extended capabilities for blits from system memory to display memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SvbExtendedCaps As Integer
C# | public int SvbExtendedCaps { get; }
C++ public:
property int SvbExtendedCaps {
int get();
}
JScript | public function get SvbExtendedCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.SvbRasterOperations Property (Microsoft.DirectX.DirectDraw)

Caps.SvbRasterOperations Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from system memory to display memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SvbRasterOperations As Integer()
C# | public int[] SvbRasterOperations { get; }
C++ public:
property array<int>^ SvbRasterOperations {
array<int>^ get();
}
JScript | public function get SvbRasterOperations() : int[]

Property Value

System.Int32[]

This property is read-only.


Caps.SvCaps Property (Microsoft.DirectX.DirectDraw)

Caps.SvCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stereo-vision capabilities Deprecated.

Definition

Visual Basic | Public ReadOnly Property SvCaps As Integer
C# | public int SvCaps { get; }
C++ public:
property int SvCaps {
int get();
}
JScript | public function get SvCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.VerticalBlankInterrupt Property (Microsoft.DirectX.DirectDraw)

Caps.VerticalBlankInterrupt Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware is capable of generating a vertical-blank interrupt. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VerticalBlankInterrupt As Boolean
C# | public bool VerticalBlankInterrupt { get; }
C++ public:
property bool VerticalBlankInterrupt {
bool get();
}
JScript | public function get VerticalBlankInterrupt() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.VideoMemoryFree Property (Microsoft.DirectX.DirectDraw)

Caps.VideoMemoryFree Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Free display memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VideoMemoryFree As Integer
C# | public int VideoMemoryFree { get; }
C++ public:
property int VideoMemoryFree {
int get();
}
JScript | public function get VideoMemoryFree() : int

Property Value

System.Int32

This property is read-only.


Caps.VideoMemoryTotal Property (Microsoft.DirectX.DirectDraw)

Caps.VideoMemoryTotal Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Total amount of display memory on the device, in bytes, minus memory reserved for the primary surface and any private data structures reserved by the driver. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VideoMemoryTotal As Integer
C# | public int VideoMemoryTotal { get; }
C++ public:
property int VideoMemoryTotal {
int get();
}
JScript | public function get VideoMemoryTotal() : int

Property Value

System.Int32

This property is read-only.


Caps.VideoPort Property (Microsoft.DirectX.DirectDraw)

Caps.VideoPort Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Display hardware supports live video. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VideoPort As Boolean
C# | public bool VideoPort { get; }
C++ public:
property bool VideoPort {
bool get();
}
JScript | public function get VideoPort() : boolean

Property Value

System.Boolean

This property is read-only.


Caps.VsbCaps Property (Microsoft.DirectX.DirectDraw)

Caps.VsbCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific capabilities for blits from display memory to system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VsbCaps As Integer
C# | public int VsbCaps { get; }
C++ public:
property int VsbCaps {
int get();
}
JScript | public function get VsbCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.VsbCKeyCaps Property (Microsoft.DirectX.DirectDraw)

Caps.VsbCKeyCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver color-key capabilities for blits from display memory to system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VsbCKeyCaps As Integer
C# | public int VsbCKeyCaps { get; }
C++ public:
property int VsbCKeyCaps {
int get();
}
JScript | public function get VsbCKeyCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.VsbEffectsCaps Property (Microsoft.DirectX.DirectDraw)

Caps.VsbEffectsCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver FX capabilities for blits from display memory to system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VsbEffectsCaps As Integer
C# | public int VsbEffectsCaps { get; }
C++ public:
property int VsbEffectsCaps {
int get();
}
JScript | public function get VsbEffectsCaps() : int

Property Value

System.Int32

This property is read-only.


Caps.VsbRasterOperations Property (Microsoft.DirectX.DirectDraw)

Caps.VsbRasterOperations Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations supported for blits from display memory to system memory. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VsbRasterOperations As Integer()
C# | public int[] VsbRasterOperations { get; }
C++ public:
property array<int>^ VsbRasterOperations {
array<int>^ get();
}
JScript | public function get VsbRasterOperations() : int[]

Property Value

System.Int32[]

This property is read-only.


Caps.WideSurfaces Property (Microsoft.DirectX.DirectDraw)

Caps.WideSurfaces Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The display surface supports surfaces wider than the primary surface. Deprecated.

Definition

Visual Basic | Public ReadOnly Property WideSurfaces As Boolean
C# | public bool WideSurfaces { get; }
C++ public:
property bool WideSurfaces {
bool get();
}
JScript | public function get WideSurfaces() : boolean

Property Value

System.Boolean

This property is read-only.


ColorControlObject Structure (Microsoft.DirectX.DirectDraw)

ColorControlObject Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Defines the color controls associated with an overlay surface, or a primary surface. Deprecated.

Definition

Visual Basic | Public Structure ColorControlObject
C# | public struct ColorControlObject
C++ | public value class ColorControlObject sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ColorControlObject
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Brightness
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Luminance intensity, in IRE units times 100. The valid range is from 0 through 10,000. The default is 750, which translates to 7.5 IRE. Deprecated.
ColorEnable
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag indicating whether color is used. Deprecated.
Contrast
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Relative difference between higher and lower intensity luminance values in IRE units times 100. The valid range is from 0 through 20,000. The default value is 10,000 (100 IRE). Higher values of contrast cause darker luminance values to tend toward black and lighter luminance values to tend toward white. Lower values of contrast cause all luminance values to move toward the middle of the scale. Deprecated.
Gamma
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the amount of gamma correction applied to the luminance values. The valid range is from 1 through 500 gamma units, with a default of 1. Deprecated.
Hue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Phase relationship of the chrominance components. Hue is specified in degrees, and the valid range is from -180 through 180, with a default of 0. Deprecated.
IsBrightnessValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Brightness member contains valid data. Deprecated.
IsColorEnableValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ColorEnable member contains valid data. Deprecated.
IsContrastValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Contrast member contains valid data. Deprecated.
IsGammaValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Gamma member contains valid data. Deprecated.
IsHueValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Hue member contains valid data. Deprecated.
IsSaturationValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Saturation member contains valid data. Deprecated.
IsSharpnessValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Sharpness member contains valid data. Deprecated.
Saturation
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color intensity, in IRE units times 100. The valid range is from 0 through 20,000. The default value is 10,000, which translates to 100 IRE. Deprecated.
Sharpness
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sharpness, in arbitrary units. The valid range is from 0 through 10, with a default of 5. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorControlObject.ColorControlObject() Constructor (Microsoft.DirectX.DirectDraw)

ColorControlObject.ColorControlObject Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ColorControlObject();
C++ public:
ColorControlObject();
JScript | public function ColorControlObject();


ColorControlObject.ToString() Method (Microsoft.DirectX.DirectDraw)

ColorControlObject.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ColorControlObject.Brightness Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.Brightness Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Luminance intensity, in IRE units times 100. The valid range is from 0 through 10,000. The default is 750, which translates to 7.5 IRE. Deprecated.

Definition

Visual Basic | Public Property Brightness As Integer
C# | public int Brightness { get; set; }
C++ public:
property int Brightness {
int get();
void set(int value);
}
JScript public function get Brightness() : int
public function set Brightness(int);

Property Value

System.Int32

This property is read/write.


ColorControlObject.ColorEnable Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.ColorEnable Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag indicating whether color is used. Deprecated.

Definition

Visual Basic | Public Property ColorEnable As Integer
C# | public int ColorEnable { get; set; }
C++ public:
property int ColorEnable {
int get();
void set(int value);
}
JScript public function get ColorEnable() : int
public function set ColorEnable(int);

Property Value

System.Int32

This property is read/write.


ColorControlObject.Contrast Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.Contrast Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Relative difference between higher and lower intensity luminance values in IRE units times 100. The valid range is from 0 through 20,000. The default value is 10,000 (100 IRE). Higher values of contrast cause darker luminance values to tend toward black and lighter luminance values to tend toward white. Lower values of contrast cause all luminance values to move toward the middle of the scale. Deprecated.

Definition

Visual Basic | Public Property Contrast As Integer
C# | public int Contrast { get; set; }
C++ public:
property int Contrast {
int get();
void set(int value);
}
JScript public function get Contrast() : int
public function set Contrast(int);

Property Value

System.Int32

This property is read/write.


ColorControlObject.Gamma Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.Gamma Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the amount of gamma correction applied to the luminance values. The valid range is from 1 through 500 gamma units, with a default of 1. Deprecated.

Definition

Visual Basic | Public Property Gamma As Integer
C# | public int Gamma { get; set; }
C++ public:
property int Gamma {
int get();
void set(int value);
}
JScript public function get Gamma() : int
public function set Gamma(int);

Property Value

System.Int32

This property is read/write.


ColorControlObject.Hue Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.Hue Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Phase relationship of the chrominance components. Hue is specified in degrees, and the valid range is from -180 through 180, with a default of 0. Deprecated.

Definition

Visual Basic | Public Property Hue As Integer
C# | public int Hue { get; set; }
C++ public:
property int Hue {
int get();
void set(int value);
}
JScript public function get Hue() : int
public function set Hue(int);

Property Value

System.Int32

This property is read/write.


ColorControlObject.IsBrightnessValid Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.IsBrightnessValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Brightness member contains valid data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsBrightnessValid As Boolean
C# | public bool IsBrightnessValid { get; }
C++ public:
property bool IsBrightnessValid {
bool get();
}
JScript | public function get IsBrightnessValid() : boolean

Property Value

System.Boolean

This property is read-only.


ColorControlObject.IsColorEnableValid Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.IsColorEnableValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ColorEnable member contains valid data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsColorEnableValid As Boolean
C# | public bool IsColorEnableValid { get; }
C++ public:
property bool IsColorEnableValid {
bool get();
}
JScript | public function get IsColorEnableValid() : boolean

Property Value

System.Boolean

This property is read-only.


ColorControlObject.IsContrastValid Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.IsContrastValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Contrast member contains valid data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsContrastValid As Boolean
C# | public bool IsContrastValid { get; }
C++ public:
property bool IsContrastValid {
bool get();
}
JScript | public function get IsContrastValid() : boolean

Property Value

System.Boolean

This property is read-only.


ColorControlObject.IsGammaValid Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.IsGammaValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Gamma member contains valid data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsGammaValid As Boolean
C# | public bool IsGammaValid { get; }
C++ public:
property bool IsGammaValid {
bool get();
}
JScript | public function get IsGammaValid() : boolean

Property Value

System.Boolean

This property is read-only.


ColorControlObject.IsHueValid Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.IsHueValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Hue member contains valid data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsHueValid As Boolean
C# | public bool IsHueValid { get; }
C++ public:
property bool IsHueValid {
bool get();
}
JScript | public function get IsHueValid() : boolean

Property Value

System.Boolean

This property is read-only.


ColorControlObject.IsSaturationValid Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.IsSaturationValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Saturation member contains valid data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsSaturationValid As Boolean
C# | public bool IsSaturationValid { get; }
C++ public:
property bool IsSaturationValid {
bool get();
}
JScript | public function get IsSaturationValid() : boolean

Property Value

System.Boolean

This property is read-only.


ColorControlObject.IsSharpnessValid Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.IsSharpnessValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Sharpness member contains valid data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property IsSharpnessValid As Boolean
C# | public bool IsSharpnessValid { get; }
C++ public:
property bool IsSharpnessValid {
bool get();
}
JScript | public function get IsSharpnessValid() : boolean

Property Value

System.Boolean

This property is read-only.


ColorControlObject.Saturation Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.Saturation Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color intensity, in IRE units times 100. The valid range is from 0 through 20,000. The default value is 10,000, which translates to 100 IRE. Deprecated.

Definition

Visual Basic | Public Property Saturation As Integer
C# | public int Saturation { get; set; }
C++ public:
property int Saturation {
int get();
void set(int value);
}
JScript public function get Saturation() : int
public function set Saturation(int);

Property Value

System.Int32

This property is read/write.


ColorControlObject.Sharpness Property (Microsoft.DirectX.DirectDraw)

ColorControlObject.Sharpness Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sharpness, in arbitrary units. The valid range is from 0 through 10, with a default of 5. Deprecated.

Definition

Visual Basic | Public Property Sharpness As Integer
C# | public int Sharpness { get; set; }
C++ public:
property int Sharpness {
int get();
void set(int value);
}
JScript public function get Sharpness() : int
public function set Sharpness(int);

Property Value

System.Int32

This property is read/write.


ColorKey Structure (Microsoft.DirectX.DirectDraw)

ColorKey Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes a source color key, destination color key, or color space. Deprecated.

Definition

Visual Basic | Public Structure ColorKey
C# | public struct ColorKey
C++ | public value class ColorKey sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ColorKey
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ColorSpaceHighValue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
High value of the color range that is to be used as the color key. Deprecated.
ColorSpaceLowValue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Low value of the color range that is to be used as the color key. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorKey.ColorKey() Constructor (Microsoft.DirectX.DirectDraw)

ColorKey.ColorKey Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ColorKey();
C++ public:
ColorKey();
JScript | public function ColorKey();


ColorKey.Equals(Object) Method (Microsoft.DirectX.DirectDraw)

ColorKey.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


ColorKey.GetHashCode() Method (Microsoft.DirectX.DirectDraw)

ColorKey.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


ColorKey.op_Equality(ColorKey,ColorKey) Method (Microsoft.DirectX.DirectDraw)

ColorKey.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As ColorKey, _
ByVal right As ColorKey _
) As Boolean
C# public static bool op_Equality(
ColorKey left,
ColorKey right
);
C++ public:
static bool operator==(
ColorKey left,
ColorKey right
);
JScript public static function op_Equality(
left : ColorKey,
right : ColorKey
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.ColorKey
The ColorKey structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.ColorKey
The ColorKey structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


ColorKey.op_Inequality(ColorKey,ColorKey) Method (Microsoft.DirectX.DirectDraw)

ColorKey.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As ColorKey, _
ByVal right As ColorKey _
) As Boolean
C# public static bool op_Inequality(
ColorKey left,
ColorKey right
);
C++ public:
static bool operator!=(
ColorKey left,
ColorKey right
);
JScript public static function op_Inequality(
left : ColorKey,
right : ColorKey
) : boolean;

Parameters

left Microsoft.DirectX.DirectDraw.ColorKey
The ColorKey structure to the left of the equality operator.
right Microsoft.DirectX.DirectDraw.ColorKey
The ColorKey structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


ColorKey.ToString() Method (Microsoft.DirectX.DirectDraw)

ColorKey.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ColorKey.ColorSpaceHighValue Property (Microsoft.DirectX.DirectDraw)

ColorKey.ColorSpaceHighValue Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
High value of the color range that is to be used as the color key. Deprecated.

Definition

Visual Basic | Public Property ColorSpaceHighValue As Integer
C# | public int ColorSpaceHighValue { get; set; }
C++ public:
property int ColorSpaceHighValue {
int get();
void set(int value);
}
JScript public function get ColorSpaceHighValue() : int
public function set ColorSpaceHighValue(int);

Property Value

System.Int32

This property is read/write.


ColorKey.ColorSpaceLowValue Property (Microsoft.DirectX.DirectDraw)

ColorKey.ColorSpaceLowValue Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Low value of the color range that is to be used as the color key. Deprecated.

Definition

Visual Basic | Public Property ColorSpaceLowValue As Integer
C# | public int ColorSpaceLowValue { get; set; }
C++ public:
property int ColorSpaceLowValue {
int get();
void set(int value);
}
JScript public function get ColorSpaceLowValue() : int
public function set ColorSpaceLowValue(int);

Property Value

System.Int32

This property is read/write.


ColorKeyCaps Structure (Microsoft.DirectX.DirectDraw)

ColorKeyCaps Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color Key capabilities Deprecated.

Definition

Visual Basic | Public Structure ColorKeyCaps
C# | public struct ColorKeyCaps
C++ | public value class ColorKeyCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
DestinationDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for RGB colors. Deprecated.
DestinationDrawColorSpace
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color space that identifies the replaceable bits of the destination surface for RGB colors. Deprecated.
DestinationDrawColorSpaceYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for YUV colors. Deprecated.
DestinationDrawYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for YUV colors. Deprecated.
DestinationOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying with color keying of the replaceable bits of the destination surface to be overlaid for RGB colors. Deprecated.
DestinationOverlayColorSpace
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports a color space as the color key for the destination of RGB colors. Deprecated.
DestinationOverlayColorSpaceYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports a color space as the color key for the destination of YUV colors. Deprecated.
DestinationOverlayOneActive
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports only one active destination color key value for visible overlay surfaces Deprecated.
DestinationOverlayYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using color keying of the replaceable bits of the destination surface to be overlaid for YUV colors. Deprecated.
NoCostOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that there are no bandwidth trade-offs for using the color key with an overlay. Deprecated.
SourceDraw
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using the color key for the source with this surface for RGB colors. Deprecated.
SourceDrawColorSpace
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using a color space for the source with this surface for RGB colors. Deprecated.
SourceDrawColorSpaceYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using a color space for the source with this surface for YUV colors. Deprecated.
SourceDrawYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using the color key for the source with this surface for YUV colors. Deprecated.
SourceOverlay
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using the color key for the source with this overlay surface for RGB colors. Deprecated.
SourceOverlayColorSpace
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using a color space as the source color key for the overlay surface for RGB colors. Deprecated.
SourceOverlayColorSpaceYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using a color space as the source color key for the overlay surface for YUV colors. Deprecated.
SourceOverlayOneActive
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports only one active source color key value for visible overlay surfaces. Deprecated.
SourceOverlayYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using the color key for the source with this overlay surface for YUV colors. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorKeyCaps.ToString() Method (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ColorKeyCaps.DestinationDraw Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationDraw Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for RGB colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationDraw As Boolean
C# | public bool DestinationDraw { get; }
C++ public:
property bool DestinationDraw {
bool get();
}
JScript | public function get DestinationDraw() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.DestinationDrawColorSpace Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationDrawColorSpace Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color space that identifies the replaceable bits of the destination surface for RGB colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationDrawColorSpace As Boolean
C# | public bool DestinationDrawColorSpace { get; }
C++ public:
property bool DestinationDrawColorSpace {
bool get();
}
JScript | public function get DestinationDrawColorSpace() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.DestinationDrawColorSpaceYuv Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationDrawColorSpaceYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for YUV colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationDrawColorSpaceYuv As Boolean
C# | public bool DestinationDrawColorSpaceYuv { get; }
C++ public:
property bool DestinationDrawColorSpaceYuv {
bool get();
}
JScript | public function get DestinationDrawColorSpaceYuv() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.DestinationDrawYuv Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationDrawYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting with a color key that identifies the replaceable bits of the destination surface for YUV colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationDrawYuv As Boolean
C# | public bool DestinationDrawYuv { get; }
C++ public:
property bool DestinationDrawYuv {
bool get();
}
JScript | public function get DestinationDrawYuv() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.DestinationOverlay Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationOverlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying with color keying of the replaceable bits of the destination surface to be overlaid for RGB colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationOverlay As Boolean
C# | public bool DestinationOverlay { get; }
C++ public:
property bool DestinationOverlay {
bool get();
}
JScript | public function get DestinationOverlay() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.DestinationOverlayColorSpace Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationOverlayColorSpace Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports a color space as the color key for the destination of RGB colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationOverlayColorSpace As Boolean
C# | public bool DestinationOverlayColorSpace { get; }
C++ public:
property bool DestinationOverlayColorSpace {
bool get();
}
JScript | public function get DestinationOverlayColorSpace() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.DestinationOverlayColorSpaceYuv Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationOverlayColorSpaceYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports a color space as the color key for the destination of YUV colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationOverlayColorSpaceYuv As Boolean
C# | public bool DestinationOverlayColorSpaceYuv { get; }
C++ public:
property bool DestinationOverlayColorSpaceYuv {
bool get();
}
JScript | public function get DestinationOverlayColorSpaceYuv() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.DestinationOverlayOneActive Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationOverlayOneActive Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports only one active destination color key value for visible overlay surfaces Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationOverlayOneActive As Boolean
C# | public bool DestinationOverlayOneActive { get; }
C++ public:
property bool DestinationOverlayOneActive {
bool get();
}
JScript | public function get DestinationOverlayOneActive() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.DestinationOverlayYuv Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.DestinationOverlayYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using color keying of the replaceable bits of the destination surface to be overlaid for YUV colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DestinationOverlayYuv As Boolean
C# | public bool DestinationOverlayYuv { get; }
C++ public:
property bool DestinationOverlayYuv {
bool get();
}
JScript | public function get DestinationOverlayYuv() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.NoCostOverlay Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.NoCostOverlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that there are no bandwidth trade-offs for using the color key with an overlay. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NoCostOverlay As Boolean
C# | public bool NoCostOverlay { get; }
C++ public:
property bool NoCostOverlay {
bool get();
}
JScript | public function get NoCostOverlay() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceDraw Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceDraw Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using the color key for the source with this surface for RGB colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceDraw As Boolean
C# | public bool SourceDraw { get; }
C++ public:
property bool SourceDraw {
bool get();
}
JScript | public function get SourceDraw() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceDrawColorSpace Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceDrawColorSpace Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using a color space for the source with this surface for RGB colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceDrawColorSpace As Boolean
C# | public bool SourceDrawColorSpace { get; }
C++ public:
property bool SourceDrawColorSpace {
bool get();
}
JScript | public function get SourceDrawColorSpace() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceDrawColorSpaceYuv Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceDrawColorSpaceYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using a color space for the source with this surface for YUV colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceDrawColorSpaceYuv As Boolean
C# | public bool SourceDrawColorSpaceYuv { get; }
C++ public:
property bool SourceDrawColorSpaceYuv {
bool get();
}
JScript | public function get SourceDrawColorSpaceYuv() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceDrawYuv Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceDrawYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports transparent blitting, using the color key for the source with this surface for YUV colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceDrawYuv As Boolean
C# | public bool SourceDrawYuv { get; }
C++ public:
property bool SourceDrawYuv {
bool get();
}
JScript | public function get SourceDrawYuv() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceOverlay Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceOverlay Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using the color key for the source with this overlay surface for RGB colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceOverlay As Boolean
C# | public bool SourceOverlay { get; }
C++ public:
property bool SourceOverlay {
bool get();
}
JScript | public function get SourceOverlay() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceOverlayColorSpace Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceOverlayColorSpace Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using a color space as the source color key for the overlay surface for RGB colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceOverlayColorSpace As Boolean
C# | public bool SourceOverlayColorSpace { get; }
C++ public:
property bool SourceOverlayColorSpace {
bool get();
}
JScript | public function get SourceOverlayColorSpace() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceOverlayColorSpaceYuv Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceOverlayColorSpaceYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using a color space as the source color key for the overlay surface for YUV colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceOverlayColorSpaceYuv As Boolean
C# | public bool SourceOverlayColorSpaceYuv { get; }
C++ public:
property bool SourceOverlayColorSpaceYuv {
bool get();
}
JScript | public function get SourceOverlayColorSpaceYuv() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceOverlayOneActive Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceOverlayOneActive Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports only one active source color key value for visible overlay surfaces. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceOverlayOneActive As Boolean
C# | public bool SourceOverlayOneActive { get; }
C++ public:
property bool SourceOverlayOneActive {
bool get();
}
JScript | public function get SourceOverlayOneActive() : boolean

Property Value

System.Boolean

This property is read-only.


ColorKeyCaps.SourceOverlayYuv Property (Microsoft.DirectX.DirectDraw)

ColorKeyCaps.SourceOverlayYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports overlaying, using the color key for the source with this overlay surface for YUV colors. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourceOverlayYuv As Boolean
C# | public bool SourceOverlayYuv { get; }
C++ public:
property bool SourceOverlayYuv {
bool get();
}
JScript | public function get SourceOverlayYuv() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceIdentifier Structure (Microsoft.DirectX.DirectDraw)

DeviceIdentifier Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.

Definition

Visual Basic | Public Structure DeviceIdentifier
C# | public struct DeviceIdentifier
C++ | public value class DeviceIdentifier sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DeviceIdentifier
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Description
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Description of the driver. Deprecated.
DeviceGuid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unique identifier for the driver/chipset pair. Use this value if you want to track changes to the driver or chipset to reprofile the graphics subsystem. It can also be used to identify particular problematic drivers. Deprecated.
DeviceId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the type of chipset. Can be 0 if unknown. Deprecated.
Driver
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.
DriverVersion
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Version of the driver. Deprecated.
Revision
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the revision level of the chipset. Can be 0 if unknown. Deprecated.
SubSystemId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the subsystem. Typically, this means the particular board. Can be 0 if unknown. Deprecated.
VendorId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the manufacturer. Can be 0 if unknown. Deprecated.
WhqlLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Windows Hardware Quality Lab (WHQL) certification level for the device/driver pair. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceIdentifier.DeviceIdentifier() Constructor (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.DeviceIdentifier Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DeviceIdentifier();
C++ public:
DeviceIdentifier();
JScript | public function DeviceIdentifier();


DeviceIdentifier.ToString() Method (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceIdentifier.Description Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.Description Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Description of the driver. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Description As String
C# | public string Description { get; }
C++ public:
property String^ Description {
String^ get();
}
JScript | public function get Description() : String

Property Value

System.String

This property is read-only.


DeviceIdentifier.DeviceGuid Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.DeviceGuid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unique identifier for the driver/chipset pair. Use this value if you want to track changes to the driver or chipset to reprofile the graphics subsystem. It can also be used to identify particular problematic drivers. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DeviceGuid As Guid
C# | public Guid DeviceGuid { get; }
C++ public:
property Guid DeviceGuid {
Guid get();
}
JScript | public function get DeviceGuid() : Guid

Property Value

System.Guid

This property is read-only.


DeviceIdentifier.DeviceId Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.DeviceId Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the type of chipset. Can be 0 if unknown. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DeviceId As Integer
C# | public int DeviceId { get; }
C++ public:
property int DeviceId {
int get();
}
JScript | public function get DeviceId() : int

Property Value

System.Int32

This property is read-only.


DeviceIdentifier.Driver Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.Driver Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Driver As String
C# | public string Driver { get; }
C++ public:
property String^ Driver {
String^ get();
}
JScript | public function get Driver() : String

Property Value

System.String

This property is read-only.


DeviceIdentifier.DriverVersion Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.DriverVersion Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Version of the driver. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DriverVersion As Long
C# | public long DriverVersion { get; }
C++ public:
property long DriverVersion {
long get();
}
JScript | public function get DriverVersion() : long

Property Value

System.Int64

This property is read-only.


DeviceIdentifier.Revision Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.Revision Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the revision level of the chipset. Can be 0 if unknown. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Revision As Integer
C# | public int Revision { get; }
C++ public:
property int Revision {
int get();
}
JScript | public function get Revision() : int

Property Value

System.Int32

This property is read-only.


DeviceIdentifier.SubSystemId Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.SubSystemId Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the subsystem. Typically, this means the particular board. Can be 0 if unknown. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SubSystemId As Integer
C# | public int SubSystemId { get; }
C++ public:
property int SubSystemId {
int get();
}
JScript | public function get SubSystemId() : int

Property Value

System.Int32

This property is read-only.


DeviceIdentifier.VendorId Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.VendorId Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Identifier of the manufacturer. Can be 0 if unknown. Deprecated.

Definition

Visual Basic | Public ReadOnly Property VendorId As Integer
C# | public int VendorId { get; }
C++ public:
property int VendorId {
int get();
}
JScript | public function get VendorId() : int

Property Value

System.Int32

This property is read-only.


DeviceIdentifier.WhqlLevel Property (Microsoft.DirectX.DirectDraw)

DeviceIdentifier.WhqlLevel Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Windows Hardware Quality Lab (WHQL) certification level for the device/driver pair. Deprecated.

Definition

Visual Basic | Public ReadOnly Property WhqlLevel As Integer
C# | public int WhqlLevel { get; }
C++ public:
property int WhqlLevel {
int get();
}
JScript | public function get WhqlLevel() : int

Property Value

System.Int32

This property is read-only.


DeviceInformation Structure (Microsoft.DirectX.DirectDraw)

DeviceInformation Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Information about a device. Deprecated.

Definition

Visual Basic | Public Structure DeviceInformation
C# | public struct DeviceInformation
C++ | public value class DeviceInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DeviceInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Description
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Description of the driver. Deprecated.
Driver
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceInformation.DeviceInformation() Constructor (Microsoft.DirectX.DirectDraw)

DeviceInformation.DeviceInformation Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DeviceInformation();
C++ public:
DeviceInformation();
JScript | public function DeviceInformation();


DeviceInformation.ToString() Method (Microsoft.DirectX.DirectDraw)

DeviceInformation.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceInformation.Description Property (Microsoft.DirectX.DirectDraw)

DeviceInformation.Description Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Description of the driver. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Description As String
C# | public string Description { get; }
C++ public:
property String^ Description {
String^ get();
}
JScript | public function get Description() : String

Property Value

System.String

This property is read-only.


DeviceInformation.Driver Property (Microsoft.DirectX.DirectDraw)

DeviceInformation.Driver Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Driver As Guid
C# | public Guid Driver { get; }
C++ public:
property Guid Driver {
Guid get();
}
JScript | public function get Driver() : Guid

Property Value

System.Guid

This property is read-only.


DeviceInformation.Name Property (Microsoft.DirectX.DirectDraw)

DeviceInformation.Name Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the driver. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String

This property is read-only.


DrawEffects Structure (Microsoft.DirectX.DirectDraw)

DrawEffects Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Raster operations (ROPs), effects, and override information. Deprecated.

Definition

Visual Basic | Public Structure DrawEffects
C# | public struct DrawEffects
C++ | public value class DrawEffects sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DrawEffects
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AlphaDestinationConstant
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant used as the alpha channel destination. Deprecated.
AlphaDestinationConstantBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the destination alpha constant. Deprecated.
AlphaEdgeBlend
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Alpha constant used for edge blending. Deprecated.
AlphaEdgeBlendBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the constant for an alpha edge blend. Deprecated.
AlphaSourceConstant
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant used as the alpha channel source. Deprecated.
AlphaSourceConstantBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the source alpha constant. Deprecated.
DestinationColorKey
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination color key override. Deprecated.
DrawRasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw raster operations. Deprecated.
EffectOperationArithmeticStretchy
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic stretching along the y-axis for this blit. Deprecated.
EffectOperationMirrorLeftRight
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns the surface on its y-axis. This blit mirrors the surface from left to right. Deprecated.
EffectOperationMirrorUpDown
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns the surface on its x-axis. This blit mirrors the surface from top to bottom. Deprecated.
EffectOperationNoTearing
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Schedules this blit to avoid tearing. Deprecated.
EffectOperationRotate180
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 180 degrees clockwise during this blit. Deprecated.
EffectOperationRotate270
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 270 degrees clockwise during this blit. Deprecated.
EffectOperationRotate90
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 90 degrees clockwise during this blit. Deprecated.
FillColor
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color used to fill a surface. Deprecated.
FillDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Depth value for the z-buffer. Deprecated.
FillPixel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pixel value for RGBA or RGBZ fills. Applications that use RGBZ fills should use this member. Deprecated.
FXOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Type of FX operations. Deprecated.
RasterOperations
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Win32 raster operations. Deprecated.
RotationAngle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotation angle for the blit. Deprecated.
SourceColorKey
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source color key override. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrawEffects.DrawEffects() Constructor (Microsoft.DirectX.DirectDraw)

DrawEffects.DrawEffects Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DrawEffects();
C++ public:
DrawEffects();
JScript | public function DrawEffects();


DrawEffects.ToString() Method (Microsoft.DirectX.DirectDraw)

DrawEffects.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DrawEffects.AlphaDestinationConstant Property (Microsoft.DirectX.DirectDraw)

DrawEffects.AlphaDestinationConstant Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant used as the alpha channel destination. Deprecated.

Definition

Visual Basic | Public Property AlphaDestinationConstant As Integer
C# | public int AlphaDestinationConstant { get; set; }
C++ public:
property int AlphaDestinationConstant {
int get();
void set(int value);
}
JScript public function get AlphaDestinationConstant() : int
public function set AlphaDestinationConstant(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.AlphaDestinationConstantBitDepth Property (Microsoft.DirectX.DirectDraw)

DrawEffects.AlphaDestinationConstantBitDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the destination alpha constant. Deprecated.

Definition

Visual Basic | Public Property AlphaDestinationConstantBitDepth As Integer
C# | public int AlphaDestinationConstantBitDepth { get; set; }
C++ public:
property int AlphaDestinationConstantBitDepth {
int get();
void set(int value);
}
JScript public function get AlphaDestinationConstantBitDepth() : int
public function set AlphaDestinationConstantBitDepth(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.AlphaEdgeBlend Property (Microsoft.DirectX.DirectDraw)

DrawEffects.AlphaEdgeBlend Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Alpha constant used for edge blending. Deprecated.

Definition

Visual Basic | Public Property AlphaEdgeBlend As Integer
C# | public int AlphaEdgeBlend { get; set; }
C++ public:
property int AlphaEdgeBlend {
int get();
void set(int value);
}
JScript public function get AlphaEdgeBlend() : int
public function set AlphaEdgeBlend(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.AlphaEdgeBlendBitDepth Property (Microsoft.DirectX.DirectDraw)

DrawEffects.AlphaEdgeBlendBitDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the constant for an alpha edge blend. Deprecated.

Definition

Visual Basic | Public Property AlphaEdgeBlendBitDepth As Integer
C# | public int AlphaEdgeBlendBitDepth { get; set; }
C++ public:
property int AlphaEdgeBlendBitDepth {
int get();
void set(int value);
}
JScript public function get AlphaEdgeBlendBitDepth() : int
public function set AlphaEdgeBlendBitDepth(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.AlphaSourceConstant Property (Microsoft.DirectX.DirectDraw)

DrawEffects.AlphaSourceConstant Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant used as the alpha channel source. Deprecated.

Definition

Visual Basic | Public Property AlphaSourceConstant As Integer
C# | public int AlphaSourceConstant { get; set; }
C++ public:
property int AlphaSourceConstant {
int get();
void set(int value);
}
JScript public function get AlphaSourceConstant() : int
public function set AlphaSourceConstant(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.AlphaSourceConstantBitDepth Property (Microsoft.DirectX.DirectDraw)

DrawEffects.AlphaSourceConstantBitDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth of the source alpha constant. Deprecated.

Definition

Visual Basic | Public Property AlphaSourceConstantBitDepth As Integer
C# | public int AlphaSourceConstantBitDepth { get; set; }
C++ public:
property int AlphaSourceConstantBitDepth {
int get();
void set(int value);
}
JScript public function get AlphaSourceConstantBitDepth() : int
public function set AlphaSourceConstantBitDepth(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.DestinationColorKey Property (Microsoft.DirectX.DirectDraw)

DrawEffects.DestinationColorKey Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination color key override. Deprecated.

Definition

Visual Basic | Public Property DestinationColorKey As ColorKey
C# | public ColorKey DestinationColorKey { get; set; }
C++ public:
property ColorKey DestinationColorKey {
ColorKey get();
void set(ColorKey value);
}
JScript public function get DestinationColorKey() : ColorKey
public function set DestinationColorKey(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey

This property is read/write.


DrawEffects.DrawRasterOperations Property (Microsoft.DirectX.DirectDraw)

DrawEffects.DrawRasterOperations Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectDraw raster operations. Deprecated.

Definition

Visual Basic | Public Property DrawRasterOperations As Integer
C# | public int DrawRasterOperations { get; set; }
C++ public:
property int DrawRasterOperations {
int get();
void set(int value);
}
JScript public function get DrawRasterOperations() : int
public function set DrawRasterOperations(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.EffectOperationArithmeticStretchy Property (Microsoft.DirectX.DirectDraw)

DrawEffects.EffectOperationArithmeticStretchy Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic stretching along the y-axis for this blit. Deprecated.

Definition

Visual Basic | Public Property EffectOperationArithmeticStretchy As Boolean
C# | public bool EffectOperationArithmeticStretchy { get; set; }
C++ public:
property bool EffectOperationArithmeticStretchy {
bool get();
void set(bool value);
}
JScript public function get EffectOperationArithmeticStretchy() : boolean
public function set EffectOperationArithmeticStretchy(boolean);

Property Value

System.Boolean

This property is read/write.


DrawEffects.EffectOperationMirrorLeftRight Property (Microsoft.DirectX.DirectDraw)

DrawEffects.EffectOperationMirrorLeftRight Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns the surface on its y-axis. This blit mirrors the surface from left to right. Deprecated.

Definition

Visual Basic | Public Property EffectOperationMirrorLeftRight As Boolean
C# | public bool EffectOperationMirrorLeftRight { get; set; }
C++ public:
property bool EffectOperationMirrorLeftRight {
bool get();
void set(bool value);
}
JScript public function get EffectOperationMirrorLeftRight() : boolean
public function set EffectOperationMirrorLeftRight(boolean);

Property Value

System.Boolean

This property is read/write.


DrawEffects.EffectOperationMirrorUpDown Property (Microsoft.DirectX.DirectDraw)

DrawEffects.EffectOperationMirrorUpDown Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Turns the surface on its x-axis. This blit mirrors the surface from top to bottom. Deprecated.

Definition

Visual Basic | Public Property EffectOperationMirrorUpDown As Boolean
C# | public bool EffectOperationMirrorUpDown { get; set; }
C++ public:
property bool EffectOperationMirrorUpDown {
bool get();
void set(bool value);
}
JScript public function get EffectOperationMirrorUpDown() : boolean
public function set EffectOperationMirrorUpDown(boolean);

Property Value

System.Boolean

This property is read/write.


DrawEffects.EffectOperationNoTearing Property (Microsoft.DirectX.DirectDraw)

DrawEffects.EffectOperationNoTearing Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Schedules this blit to avoid tearing. Deprecated.

Definition

Visual Basic | Public Property EffectOperationNoTearing As Boolean
C# | public bool EffectOperationNoTearing { get; set; }
C++ public:
property bool EffectOperationNoTearing {
bool get();
void set(bool value);
}
JScript public function get EffectOperationNoTearing() : boolean
public function set EffectOperationNoTearing(boolean);

Property Value

System.Boolean

This property is read/write.


DrawEffects.EffectOperationRotate180 Property (Microsoft.DirectX.DirectDraw)

DrawEffects.EffectOperationRotate180 Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 180 degrees clockwise during this blit. Deprecated.

Definition

Visual Basic | Public Property EffectOperationRotate180 As Boolean
C# | public bool EffectOperationRotate180 { get; set; }
C++ public:
property bool EffectOperationRotate180 {
bool get();
void set(bool value);
}
JScript public function get EffectOperationRotate180() : boolean
public function set EffectOperationRotate180(boolean);

Property Value

System.Boolean

This property is read/write.


DrawEffects.EffectOperationRotate270 Property (Microsoft.DirectX.DirectDraw)

DrawEffects.EffectOperationRotate270 Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 270 degrees clockwise during this blit. Deprecated.

Definition

Visual Basic | Public Property EffectOperationRotate270 As Boolean
C# | public bool EffectOperationRotate270 { get; set; }
C++ public:
property bool EffectOperationRotate270 {
bool get();
void set(bool value);
}
JScript public function get EffectOperationRotate270() : boolean
public function set EffectOperationRotate270(boolean);

Property Value

System.Boolean

This property is read/write.


DrawEffects.EffectOperationRotate90 Property (Microsoft.DirectX.DirectDraw)

DrawEffects.EffectOperationRotate90 Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotates the surface 90 degrees clockwise during this blit. Deprecated.

Definition

Visual Basic | Public Property EffectOperationRotate90 As Boolean
C# | public bool EffectOperationRotate90 { get; set; }
C++ public:
property bool EffectOperationRotate90 {
bool get();
void set(bool value);
}
JScript public function get EffectOperationRotate90() : boolean
public function set EffectOperationRotate90(boolean);

Property Value

System.Boolean

This property is read/write.


DrawEffects.FillColor Property (Microsoft.DirectX.DirectDraw)

DrawEffects.FillColor Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Color used to fill a surface. Deprecated.

Definition

Visual Basic | Public Property FillColor As Integer
C# | public int FillColor { get; set; }
C++ public:
property int FillColor {
int get();
void set(int value);
}
JScript public function get FillColor() : int
public function set FillColor(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.FillDepth Property (Microsoft.DirectX.DirectDraw)

DrawEffects.FillDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Depth value for the z-buffer. Deprecated.

Definition

Visual Basic | Public Property FillDepth As Integer
C# | public int FillDepth { get; set; }
C++ public:
property int FillDepth {
int get();
void set(int value);
}
JScript public function get FillDepth() : int
public function set FillDepth(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.FillPixel Property (Microsoft.DirectX.DirectDraw)

DrawEffects.FillPixel Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pixel value for RGBA or RGBZ fills. Applications that use RGBZ fills should use this member. Deprecated.

Definition

Visual Basic | Public Property FillPixel As Integer
C# | public int FillPixel { get; set; }
C++ public:
property int FillPixel {
int get();
void set(int value);
}
JScript public function get FillPixel() : int
public function set FillPixel(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.FXOperations Property (Microsoft.DirectX.DirectDraw)

DrawEffects.FXOperations Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Type of FX operations. Deprecated.

Definition

Visual Basic | Public Property FXOperations As Integer
C# | public int FXOperations { get; set; }
C++ public:
property int FXOperations {
int get();
void set(int value);
}
JScript public function get FXOperations() : int
public function set FXOperations(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.RasterOperations Property (Microsoft.DirectX.DirectDraw)

DrawEffects.RasterOperations Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Win32 raster operations. Deprecated.

Definition

Visual Basic | Public Property RasterOperations As Integer
C# | public int RasterOperations { get; set; }
C++ public:
property int RasterOperations {
int get();
void set(int value);
}
JScript public function get RasterOperations() : int
public function set RasterOperations(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.RotationAngle Property (Microsoft.DirectX.DirectDraw)

DrawEffects.RotationAngle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Rotation angle for the blit. Deprecated.

Definition

Visual Basic | Public Property RotationAngle As Integer
C# | public int RotationAngle { get; set; }
C++ public:
property int RotationAngle {
int get();
void set(int value);
}
JScript public function get RotationAngle() : int
public function set RotationAngle(int);

Property Value

System.Int32

This property is read/write.


DrawEffects.SourceColorKey Property (Microsoft.DirectX.DirectDraw)

DrawEffects.SourceColorKey Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source color key override. Deprecated.

Definition

Visual Basic | Public Property SourceColorKey As ColorKey
C# | public ColorKey SourceColorKey { get; set; }
C++ public:
property ColorKey SourceColorKey {
ColorKey get();
void set(ColorKey value);
}
JScript public function get SourceColorKey() : ColorKey
public function set SourceColorKey(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey

This property is read/write.


FXAlphaCaps Structure (Microsoft.DirectX.DirectDraw)

FXAlphaCaps Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific alpha capabilities Deprecated.

Definition

Visual Basic | Public Structure FXAlphaCaps
C# | public struct FXAlphaCaps
C++ | public value class FXAlphaCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
DrawAlphaEdgeBlend
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha blending around the edge of a source color-keyed surface. Used for draw operations. Deprecated.
DrawAlphaPixels
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in the pixel format can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for blit operations. Deprecated.
DrawAlphaPixelsNegative
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in the pixel format can be 1, 2, 4, or 8. The alpha value becomes more transparent as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha is set. Used for draw operations. Deprecated.
DrawAlphaSurfaces
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-only surfaces. The bit depth of an alpha-only surface can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for blit operations. Deprecated.
DrawAlphaSurfacesNegative
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that the alpha channel becomes more transparent as the alpha value increases. The depth of the alpha channel-data can be 1, 2, 4, or 8. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be set only if Alpha has been set. Used for blit operations. Deprecated.
OverlayAlphaEdgeBlend
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha blending around the edge of a source color-keyed surface. Used for overlays. Deprecated.
OverlayAlphaPixels
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in pixel format can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for overlays. Deprecated.
OverlayAlphaPixelsNegative
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in pixel format can be 1, 2, 4, or 8. The alpha value becomes more transparent as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha has been set. Used for overlays. Deprecated.
OverlayAlphaSurfaces
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-only surfaces. The bit depth of an alpha-only surface can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for overlays. Deprecated.
OverlayAlphaSurfacesNegative
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that the alpha channel becomes more transparent as the alpha value increases. The depth of the alpha-channel data can be 1, 2, 4, or 8. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha has been set. Used for overlays. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FXAlphaCaps.ToString() Method (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FXAlphaCaps.DrawAlphaEdgeBlend Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.DrawAlphaEdgeBlend Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha blending around the edge of a source color-keyed surface. Used for draw operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawAlphaEdgeBlend As Boolean
C# | public bool DrawAlphaEdgeBlend { get; }
C++ public:
property bool DrawAlphaEdgeBlend {
bool get();
}
JScript | public function get DrawAlphaEdgeBlend() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.DrawAlphaPixels Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.DrawAlphaPixels Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in the pixel format can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawAlphaPixels As Boolean
C# | public bool DrawAlphaPixels { get; }
C++ public:
property bool DrawAlphaPixels {
bool get();
}
JScript | public function get DrawAlphaPixels() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.DrawAlphaPixelsNegative Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.DrawAlphaPixelsNegative Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in the pixel format can be 1, 2, 4, or 8. The alpha value becomes more transparent as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha is set. Used for draw operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawAlphaPixelsNegative As Boolean
C# | public bool DrawAlphaPixelsNegative { get; }
C++ public:
property bool DrawAlphaPixelsNegative {
bool get();
}
JScript | public function get DrawAlphaPixelsNegative() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.DrawAlphaSurfaces Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.DrawAlphaSurfaces Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-only surfaces. The bit depth of an alpha-only surface can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawAlphaSurfaces As Boolean
C# | public bool DrawAlphaSurfaces { get; }
C++ public:
property bool DrawAlphaSurfaces {
bool get();
}
JScript | public function get DrawAlphaSurfaces() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.DrawAlphaSurfacesNegative Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.DrawAlphaSurfacesNegative Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that the alpha channel becomes more transparent as the alpha value increases. The depth of the alpha channel-data can be 1, 2, 4, or 8. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be set only if Alpha has been set. Used for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawAlphaSurfacesNegative As Boolean
C# | public bool DrawAlphaSurfacesNegative { get; }
C++ public:
property bool DrawAlphaSurfacesNegative {
bool get();
}
JScript | public function get DrawAlphaSurfacesNegative() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.OverlayAlphaEdgeBlend Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.OverlayAlphaEdgeBlend Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha blending around the edge of a source color-keyed surface. Used for overlays. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayAlphaEdgeBlend As Boolean
C# | public bool OverlayAlphaEdgeBlend { get; }
C++ public:
property bool OverlayAlphaEdgeBlend {
bool get();
}
JScript | public function get OverlayAlphaEdgeBlend() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.OverlayAlphaPixels Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.OverlayAlphaPixels Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in pixel format can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for overlays. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayAlphaPixels As Boolean
C# | public bool OverlayAlphaPixels { get; }
C++ public:
property bool OverlayAlphaPixels {
bool get();
}
JScript | public function get OverlayAlphaPixels() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.OverlayAlphaPixelsNegative Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.OverlayAlphaPixelsNegative Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha information in pixel format. The bit depth of alpha information in pixel format can be 1, 2, 4, or 8. The alpha value becomes more transparent as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha has been set. Used for overlays. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayAlphaPixelsNegative As Boolean
C# | public bool OverlayAlphaPixelsNegative { get; }
C++ public:
property bool OverlayAlphaPixelsNegative {
bool get();
}
JScript | public function get OverlayAlphaPixelsNegative() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.OverlayAlphaSurfaces Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.OverlayAlphaSurfaces Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-only surfaces. The bit depth of an alpha-only surface can be 1, 2, 4, or 8. The alpha value becomes more opaque as the alpha value increases. Regardless of the depth of the alpha information, 0 is always the fully transparent value. Used for overlays. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayAlphaSurfaces As Boolean
C# | public bool OverlayAlphaSurfaces { get; }
C++ public:
property bool OverlayAlphaSurfaces {
bool get();
}
JScript | public function get OverlayAlphaSurfaces() : boolean

Property Value

System.Boolean

This property is read-only.


FXAlphaCaps.OverlayAlphaSurfacesNegative Property (Microsoft.DirectX.DirectDraw)

FXAlphaCaps.OverlayAlphaSurfacesNegative Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Indicates that the alpha channel becomes more transparent as the alpha value increases. The depth of the alpha-channel data can be 1, 2, 4, or 8. Regardless of the depth of the alpha information, 0 is always the fully opaque value. This flag can be used only if Alpha has been set. Used for overlays. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayAlphaSurfacesNegative As Boolean
C# | public bool OverlayAlphaSurfacesNegative { get; }
C++ public:
property bool OverlayAlphaSurfacesNegative {
bool get();
}
JScript | public function get OverlayAlphaSurfacesNegative() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps Structure (Microsoft.DirectX.DirectDraw)

FXCaps Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver-specific stretching and effects capabilities. Deprecated.

Definition

Visual Basic | Public Structure FXCaps
C# | public struct FXCaps
C++ | public value class FXCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
DrawAlpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-blended blit operations. Deprecated.
DrawArithmeticStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink surfaces during a blit operation. Occurs along the y-axis (vertically). Deprecated.
DrawArithmeticStretchYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink surfaces during a blit operation. Occurs along the y-axis (vertically), and works only for integer stretching (×1, ×2, and so on). Deprecated.
DrawFilter
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver can do surface-reconstruction filtering for warped blits. Deprecated.
DrawMirrorLeftRight
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring left to right in a blit operation. Deprecated.
DrawMirrorUpDown
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring top to bottom in a blit operation. Deprecated.
DrawRotation
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary rotation in a blit operation. Deprecated.
DrawRotation90Degrees
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports 90-degree rotations in a blit operation. Deprecated.
DrawShrinkX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.
DrawShrinkXn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.
DrawShrinkY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.
DrawShrinkYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.
DrawStretchX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.
DrawStretchXn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer stretching (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.
DrawStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.
DrawStretchYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer stretching (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.
OverlayAlpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports geometric transformations (or warps) for blitted sprites. Transformations are not currently supported for explicit blit operations. Deprecated.
OverlayArithmeticStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink overlay surfaces. Occurs along the y-axis (vertically). Deprecated.
OverlayArithmeticStretchYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink overlay surfaces. Occurs along the y-axis (vertically), and works only for integer stretching (×1, ×2, and so on). Deprecated.
OverlayFilter
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports surface-reconstruction filtering for warped overlay sprites. Deprecated.
OverlayMirrorLeftRight
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring of overlays across the vertical axis. Deprecated.
OverlayMirrorUpDown
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring of overlays across the horizontal axis. Deprecated.
OverlayShrinkX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayShrinkXn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayShrinkY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayShrinkYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayStretchX
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that stretching is available. Deprecated.
OverlayStretchXn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.
OverlayStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available Deprecated.
OverlayStretchYn
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FXCaps.ToString() Method (Microsoft.DirectX.DirectDraw)

FXCaps.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FXCaps.DrawAlpha Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawAlpha Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports alpha-blended blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawAlpha As Boolean
C# | public bool DrawAlpha { get; }
C++ public:
property bool DrawAlpha {
bool get();
}
JScript | public function get DrawAlpha() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawArithmeticStretchY Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawArithmeticStretchY Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink surfaces during a blit operation. Occurs along the y-axis (vertically). Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawArithmeticStretchY As Boolean
C# | public bool DrawArithmeticStretchY { get; }
C++ public:
property bool DrawArithmeticStretchY {
bool get();
}
JScript | public function get DrawArithmeticStretchY() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawArithmeticStretchYn Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawArithmeticStretchYn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink surfaces during a blit operation. Occurs along the y-axis (vertically), and works only for integer stretching (×1, ×2, and so on). Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawArithmeticStretchYn As Boolean
C# | public bool DrawArithmeticStretchYn { get; }
C++ public:
property bool DrawArithmeticStretchYn {
bool get();
}
JScript | public function get DrawArithmeticStretchYn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawFilter Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawFilter Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Driver can do surface-reconstruction filtering for warped blits. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawFilter As Boolean
C# | public bool DrawFilter { get; }
C++ public:
property bool DrawFilter {
bool get();
}
JScript | public function get DrawFilter() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawMirrorLeftRight Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawMirrorLeftRight Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring left to right in a blit operation. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawMirrorLeftRight As Boolean
C# | public bool DrawMirrorLeftRight { get; }
C++ public:
property bool DrawMirrorLeftRight {
bool get();
}
JScript | public function get DrawMirrorLeftRight() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawMirrorUpDown Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawMirrorUpDown Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring top to bottom in a blit operation. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawMirrorUpDown As Boolean
C# | public bool DrawMirrorUpDown { get; }
C++ public:
property bool DrawMirrorUpDown {
bool get();
}
JScript | public function get DrawMirrorUpDown() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawRotation Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawRotation Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary rotation in a blit operation. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawRotation As Boolean
C# | public bool DrawRotation { get; }
C++ public:
property bool DrawRotation {
bool get();
}
JScript | public function get DrawRotation() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawRotation90Degrees Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawRotation90Degrees Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports 90-degree rotations in a blit operation. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawRotation90Degrees As Boolean
C# | public bool DrawRotation90Degrees { get; }
C++ public:
property bool DrawRotation90Degrees {
bool get();
}
JScript | public function get DrawRotation90Degrees() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawShrinkX Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawShrinkX Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawShrinkX As Boolean
C# | public bool DrawShrinkX { get; }
C++ public:
property bool DrawShrinkX {
bool get();
}
JScript | public function get DrawShrinkX() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawShrinkXn Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawShrinkXn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawShrinkXn As Boolean
C# | public bool DrawShrinkXn { get; }
C++ public:
property bool DrawShrinkXn {
bool get();
}
JScript | public function get DrawShrinkXn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawShrinkY Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawShrinkY Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawShrinkY As Boolean
C# | public bool DrawShrinkY { get; }
C++ public:
property bool DrawShrinkY {
bool get();
}
JScript | public function get DrawShrinkY() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawShrinkYn Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawShrinkYn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawShrinkYn As Boolean
C# | public bool DrawShrinkYn { get; }
C++ public:
property bool DrawShrinkYn {
bool get();
}
JScript | public function get DrawShrinkYn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawStretchX Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawStretchX Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawStretchX As Boolean
C# | public bool DrawStretchX { get; }
C++ public:
property bool DrawStretchX {
bool get();
}
JScript | public function get DrawStretchX() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawStretchXn Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawStretchXn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer stretching (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawStretchXn As Boolean
C# | public bool DrawStretchXn { get; }
C++ public:
property bool DrawStretchXn {
bool get();
}
JScript | public function get DrawStretchXn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawStretchY Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawStretchY Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawStretchY As Boolean
C# | public bool DrawStretchY { get; }
C++ public:
property bool DrawStretchY {
bool get();
}
JScript | public function get DrawStretchY() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.DrawStretchYn Property (Microsoft.DirectX.DirectDraw)

FXCaps.DrawStretchYn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer stretching (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DrawStretchYn As Boolean
C# | public bool DrawStretchYn { get; }
C++ public:
property bool DrawStretchYn {
bool get();
}
JScript | public function get DrawStretchYn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayAlpha Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayAlpha Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports geometric transformations (or warps) for blitted sprites. Transformations are not currently supported for explicit blit operations. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayAlpha As Boolean
C# | public bool OverlayAlpha { get; }
C++ public:
property bool OverlayAlpha {
bool get();
}
JScript | public function get OverlayAlpha() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayArithmeticStretchY Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayArithmeticStretchY Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink overlay surfaces. Occurs along the y-axis (vertically). Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayArithmeticStretchY As Boolean
C# | public bool OverlayArithmeticStretchY { get; }
C++ public:
property bool OverlayArithmeticStretchY {
bool get();
}
JScript | public function get OverlayArithmeticStretchY() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayArithmeticStretchYn Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayArithmeticStretchYn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Uses arithmetic operations, rather than pixel-doubling techniques, to stretch and shrink overlay surfaces. Occurs along the y-axis (vertically), and works only for integer stretching (×1, ×2, and so on). Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayArithmeticStretchYn As Boolean
C# | public bool OverlayArithmeticStretchYn { get; }
C++ public:
property bool OverlayArithmeticStretchYn {
bool get();
}
JScript | public function get OverlayArithmeticStretchYn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayFilter Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayFilter Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports surface-reconstruction filtering for warped overlay sprites. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayFilter As Boolean
C# | public bool OverlayFilter { get; }
C++ public:
property bool OverlayFilter {
bool get();
}
JScript | public function get OverlayFilter() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayMirrorLeftRight Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayMirrorLeftRight Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring of overlays across the vertical axis. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayMirrorLeftRight As Boolean
C# | public bool OverlayMirrorLeftRight { get; }
C++ public:
property bool OverlayMirrorLeftRight {
bool get();
}
JScript | public function get OverlayMirrorLeftRight() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayMirrorUpDown Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayMirrorUpDown Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports mirroring of overlays across the horizontal axis. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayMirrorUpDown As Boolean
C# | public bool OverlayMirrorUpDown { get; }
C++ public:
property bool OverlayMirrorUpDown {
bool get();
}
JScript | public function get OverlayMirrorUpDown() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayShrinkX Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayShrinkX Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayShrinkX As Boolean
C# | public bool OverlayShrinkX { get; }
C++ public:
property bool OverlayShrinkX {
bool get();
}
JScript | public function get OverlayShrinkX() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayShrinkXn Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayShrinkXn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayShrinkXn As Boolean
C# | public bool OverlayShrinkXn { get; }
C++ public:
property bool OverlayShrinkXn {
bool get();
}
JScript | public function get OverlayShrinkXn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayShrinkY Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayShrinkY Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayShrinkY As Boolean
C# | public bool OverlayShrinkY { get; }
C++ public:
property bool OverlayShrinkY {
bool get();
}
JScript | public function get OverlayShrinkY() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayShrinkYn Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayShrinkYn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayShrinkYn As Boolean
C# | public bool OverlayShrinkYn { get; }
C++ public:
property bool OverlayShrinkYn {
bool get();
}
JScript | public function get OverlayShrinkYn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayStretchX Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayStretchX Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that stretching is available. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayStretchX As Boolean
C# | public bool OverlayStretchX { get; }
C++ public:
property bool OverlayStretchX {
bool get();
}
JScript | public function get OverlayStretchX() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayStretchXn Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayStretchXn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayStretchXn As Boolean
C# | public bool OverlayStretchXn { get; }
C++ public:
property bool OverlayStretchXn {
bool get();
}
JScript | public function get OverlayStretchXn() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayStretchY Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayStretchY Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary shrinking of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayStretchY As Boolean
C# | public bool OverlayStretchY { get; }
C++ public:
property bool OverlayStretchY {
bool get();
}
JScript | public function get OverlayStretchY() : boolean

Property Value

System.Boolean

This property is read-only.


FXCaps.OverlayStretchYn Property (Microsoft.DirectX.DirectDraw)

FXCaps.OverlayStretchYn Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports integer shrinking (×1, ×2, and so on) of a surface along the y-axis (vertically). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that shrinking is available. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OverlayStretchYn As Boolean
C# | public bool OverlayStretchYn { get; }
C++ public:
property bool OverlayStretchYn {
bool get();
}
JScript | public function get OverlayStretchYn() : boolean

Property Value

System.Boolean

This property is read-only.


GammaRamps Structure (Microsoft.DirectX.DirectDraw)

GammaRamps Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports arbitrary stretching of a surface along the x-axis (horizontally). This flag is valid only for overlay surfaces. This flag indicates only the capabilities of a surface; it does not indicate that stretching is available. Deprecated.

Definition

Visual Basic | Public Structure GammaRamps
C# | public struct GammaRamps
C++ | public value class GammaRamps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GammaRamps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetBlue
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the blue gamma ramps. Deprecated.
GetGreen
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the green gamma ramps. Deprecated.
GetRed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the red gamma ramps. Deprecated.
SetBlue
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the blue gamma ramps. Deprecated.
SetGreen
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the green gamma ramps. Deprecated.
SetRed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the red gamma ramps. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GammaRamps.GammaRamps() Constructor (Microsoft.DirectX.DirectDraw)

GammaRamps.GammaRamps Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public GammaRamps();
C++ public:
GammaRamps();
JScript | public function GammaRamps();


GammaRamps.GetBlue() Method (Microsoft.DirectX.DirectDraw)

GammaRamps.GetBlue Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the blue gamma ramps. Deprecated.

Definition

Visual Basic | Public Function GetBlue() As Short()
C# | public short[] GetBlue();
C++ public:
array<short>^ GetBlue();
JScript | public function GetBlue() : short[];

Return Value

System.Int16[]


GammaRamps.GetGreen() Method (Microsoft.DirectX.DirectDraw)

GammaRamps.GetGreen Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the green gamma ramps. Deprecated.

Definition

Visual Basic | Public Function GetGreen() As Short()
C# | public short[] GetGreen();
C++ public:
array<short>^ GetGreen();
JScript | public function GetGreen() : short[];

Return Value

System.Int16[]


GammaRamps.GetRed() Method (Microsoft.DirectX.DirectDraw)

GammaRamps.GetRed Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the red gamma ramps. Deprecated.

Definition

Visual Basic | Public Function GetRed() As Short()
C# | public short[] GetRed();
C++ public:
array<short>^ GetRed();
JScript | public function GetRed() : short[];

Return Value

System.Int16[]


GammaRamps.SetBlue(Int16[]) Method (Microsoft.DirectX.DirectDraw)

GammaRamps.SetBlue Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the blue gamma ramps. Deprecated.

Definition

Visual Basic Public Sub SetBlue( _
ByVal value() As Short _
)
C# public void SetBlue(
short[] value
);
C++ public:
void SetBlue(
array<short>^ value
);
JScript public function SetBlue(
value : short[]
);

Parameters

value System.Int16[]


GammaRamps.SetGreen(Int16[]) Method (Microsoft.DirectX.DirectDraw)

GammaRamps.SetGreen Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the green gamma ramps. Deprecated.

Definition

Visual Basic Public Sub SetGreen( _
ByVal value() As Short _
)
C# public void SetGreen(
short[] value
);
C++ public:
void SetGreen(
array<short>^ value
);
JScript public function SetGreen(
value : short[]
);

Parameters

value System.Int16[]


GammaRamps.SetRed(Int16[]) Method (Microsoft.DirectX.DirectDraw)

GammaRamps.SetRed Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Set the red gamma ramps. Deprecated.

Definition

Visual Basic Public Sub SetRed( _
ByVal value() As Short _
)
C# public void SetRed(
short[] value
);
C++ public:
void SetRed(
array<short>^ value
);
JScript public function SetRed(
value : short[]
);

Parameters

value System.Int16[]


GetCapsStruct Structure (Microsoft.DirectX.DirectDraw)

GetCapsStruct Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware and Hardware Emulation Layer (HEL) capabilities Deprecated.

Definition

Visual Basic | Public Structure GetCapsStruct
C# | public struct GetCapsStruct
C++ | public value class GetCapsStruct sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetCapsStruct
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
HardwareCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware capabilities Deprecated.
HardwareEmulationCaps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware emulation layer (HEL) capabilities Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GetCapsStruct.GetCapsStruct() Constructor (Microsoft.DirectX.DirectDraw)

GetCapsStruct.GetCapsStruct Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public GetCapsStruct();
C++ public:
GetCapsStruct();
JScript | public function GetCapsStruct();


GetCapsStruct.ToString() Method (Microsoft.DirectX.DirectDraw)

GetCapsStruct.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


GetCapsStruct.HardwareCaps Property (Microsoft.DirectX.DirectDraw)

GetCapsStruct.HardwareCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware capabilities Deprecated.

Definition

Visual Basic | Public Property HardwareCaps As Caps
C# | public Caps HardwareCaps { get; set; }
C++ public:
property Caps HardwareCaps {
Caps get();
void set(Caps value);
}
JScript public function get HardwareCaps() : Caps
public function set HardwareCaps(Caps);

Property Value

Microsoft.DirectX.DirectDraw.Caps

This property is read/write.


GetCapsStruct.HardwareEmulationCaps Property (Microsoft.DirectX.DirectDraw)

GetCapsStruct.HardwareEmulationCaps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Hardware emulation layer (HEL) capabilities Deprecated.

Definition

Visual Basic | Public Property HardwareEmulationCaps As Caps
C# | public Caps HardwareEmulationCaps { get; set; }
C++ public:
property Caps HardwareEmulationCaps {
Caps get();
void set(Caps value);
}
JScript public function get HardwareEmulationCaps() : Caps
public function set HardwareEmulationCaps(Caps);

Property Value

Microsoft.DirectX.DirectDraw.Caps

This property is read/write.


LockedData Structure (Microsoft.DirectX.DirectDraw)

LockedData Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Structure LockedData
C# | public struct LockedData
C++ | public value class LockedData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
LockedData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
Data
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Height
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Pitch
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RGBBitCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Width
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LockedData.LockedData() Constructor (Microsoft.DirectX.DirectDraw)

LockedData.LockedData Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public LockedData();
C++ public:
LockedData();
JScript | public function LockedData();


LockedData.Data Property (Microsoft.DirectX.DirectDraw)

LockedData.Data Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Property Data As GraphicsStream
C# | public GraphicsStream Data { get; set; }
C++ public:
property GraphicsStream^ Data {
GraphicsStream^ get();
void set(GraphicsStream^ value);
}
JScript public function get Data() : GraphicsStream
public function set Data(GraphicsStream);

Property Value

Microsoft.DirectX.GraphicsStream

This property is read/write.


LockedData.Height Property (Microsoft.DirectX.DirectDraw)

LockedData.Height Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Property Height As Integer
C# | public int Height { get; set; }
C++ public:
property int Height {
int get();
void set(int value);
}
JScript public function get Height() : int
public function set Height(int);

Property Value

System.Int32

This property is read/write.


LockedData.Pitch Property (Microsoft.DirectX.DirectDraw)

LockedData.Pitch Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Property Pitch As Integer
C# | public int Pitch { get; set; }
C++ public:
property int Pitch {
int get();
void set(int value);
}
JScript public function get Pitch() : int
public function set Pitch(int);

Property Value

System.Int32

This property is read/write.


LockedData.RGBBitCount Property (Microsoft.DirectX.DirectDraw)

LockedData.RGBBitCount Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Property RGBBitCount As Integer
C# | public int RGBBitCount { get; set; }
C++ public:
property int RGBBitCount {
int get();
void set(int value);
}
JScript public function get RGBBitCount() : int
public function set RGBBitCount(int);

Property Value

System.Int32

This property is read/write.


LockedData.Width Property (Microsoft.DirectX.DirectDraw)

LockedData.Width Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Property Width As Integer
C# | public int Width { get; set; }
C++ public:
property int Width {
int get();
void set(int value);
}
JScript public function get Width() : int
public function set Width(int);

Property Value

System.Int32

This property is read/write.


OverlayEffects Structure (Microsoft.DirectX.DirectDraw)

OverlayEffects Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Override information to the UpdateOverlay method. Deprecated.

Definition

Visual Basic | Public Structure OverlayEffects
C# | public struct OverlayEffects
C++ | public value class OverlayEffects sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
OverlayEffects
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AlphaDestinationConstant
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha channel for a destination. Deprecated.
AlphaDestinationConstantBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the alpha constant for a destination. Deprecated.
AlphaEdgeBlend
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha for an edge blend. Deprecated.
AlphaEdgeBlendBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the constant for an alpha edge blend. Deprecated.
AlphaSourceConstant
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha channel for a source. Deprecated.
AlphaSourceConstantBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the alpha constant for a source. Deprecated.
ArithmeticStretchY
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If stretching, use arithmetic stretching along the y-axis for this overlay. Deprecated.
DestinationColorKey
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination color key override. Deprecated.
Effects
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay FX flags. Deprecated.
MirrorLeftRight
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mirror the overlay around the vertical axis. Deprecated.
MirrorUpDown
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mirror the overlay around the horizontal axis. Deprecated.
SourceColorKey
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source color key override. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OverlayEffects.OverlayEffects() Constructor (Microsoft.DirectX.DirectDraw)

OverlayEffects.OverlayEffects Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public OverlayEffects();
C++ public:
OverlayEffects();
JScript | public function OverlayEffects();


OverlayEffects.ToString() Method (Microsoft.DirectX.DirectDraw)

OverlayEffects.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


OverlayEffects.AlphaDestinationConstant Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.AlphaDestinationConstant Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha channel for a destination. Deprecated.

Definition

Visual Basic | Public Property AlphaDestinationConstant As Integer
C# | public int AlphaDestinationConstant { get; set; }
C++ public:
property int AlphaDestinationConstant {
int get();
void set(int value);
}
JScript public function get AlphaDestinationConstant() : int
public function set AlphaDestinationConstant(int);

Property Value

System.Int32

This property is read/write.


OverlayEffects.AlphaDestinationConstantBitDepth Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.AlphaDestinationConstantBitDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the alpha constant for a destination. Deprecated.

Definition

Visual Basic | Public Property AlphaDestinationConstantBitDepth As Integer
C# | public int AlphaDestinationConstantBitDepth { get; set; }
C++ public:
property int AlphaDestinationConstantBitDepth {
int get();
void set(int value);
}
JScript public function get AlphaDestinationConstantBitDepth() : int
public function set AlphaDestinationConstantBitDepth(int);

Property Value

System.Int32

This property is read/write.


OverlayEffects.AlphaEdgeBlend Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.AlphaEdgeBlend Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha for an edge blend. Deprecated.

Definition

Visual Basic | Public Property AlphaEdgeBlend As Integer
C# | public int AlphaEdgeBlend { get; set; }
C++ public:
property int AlphaEdgeBlend {
int get();
void set(int value);
}
JScript public function get AlphaEdgeBlend() : int
public function set AlphaEdgeBlend(int);

Property Value

System.Int32

This property is read/write.


OverlayEffects.AlphaEdgeBlendBitDepth Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.AlphaEdgeBlendBitDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the constant for an alpha edge blend. Deprecated.

Definition

Visual Basic | Public Property AlphaEdgeBlendBitDepth As Integer
C# | public int AlphaEdgeBlendBitDepth { get; set; }
C++ public:
property int AlphaEdgeBlendBitDepth {
int get();
void set(int value);
}
JScript public function get AlphaEdgeBlendBitDepth() : int
public function set AlphaEdgeBlendBitDepth(int);

Property Value

System.Int32

This property is read/write.


OverlayEffects.AlphaSourceConstant Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.AlphaSourceConstant Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Constant to use as the alpha channel for a source. Deprecated.

Definition

Visual Basic | Public Property AlphaSourceConstant As Integer
C# | public int AlphaSourceConstant { get; set; }
C++ public:
property int AlphaSourceConstant {
int get();
void set(int value);
}
JScript public function get AlphaSourceConstant() : int
public function set AlphaSourceConstant(int);

Property Value

System.Int32

This property is read/write.


OverlayEffects.AlphaSourceConstantBitDepth Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.AlphaSourceConstantBitDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bit depth used to specify the alpha constant for a source. Deprecated.

Definition

Visual Basic | Public Property AlphaSourceConstantBitDepth As Integer
C# | public int AlphaSourceConstantBitDepth { get; set; }
C++ public:
property int AlphaSourceConstantBitDepth {
int get();
void set(int value);
}
JScript public function get AlphaSourceConstantBitDepth() : int
public function set AlphaSourceConstantBitDepth(int);

Property Value

System.Int32

This property is read/write.


OverlayEffects.ArithmeticStretchY Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.ArithmeticStretchY Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If stretching, use arithmetic stretching along the y-axis for this overlay. Deprecated.

Definition

Visual Basic | Public Property ArithmeticStretchY As Boolean
C# | public bool ArithmeticStretchY { get; set; }
C++ public:
property bool ArithmeticStretchY {
bool get();
void set(bool value);
}
JScript public function get ArithmeticStretchY() : boolean
public function set ArithmeticStretchY(boolean);

Property Value

System.Boolean

This property is read/write.


OverlayEffects.DestinationColorKey Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.DestinationColorKey Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Destination color key override. Deprecated.

Definition

Visual Basic | Public Property DestinationColorKey As ColorKey
C# | public ColorKey DestinationColorKey { get; set; }
C++ public:
property ColorKey DestinationColorKey {
ColorKey get();
void set(ColorKey value);
}
JScript public function get DestinationColorKey() : ColorKey
public function set DestinationColorKey(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey

This property is read/write.


OverlayEffects.Effects Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.Effects Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Overlay FX flags. Deprecated.

Definition

Visual Basic | Public Property Effects As Integer
C# | public int Effects { get; set; }
C++ public:
property int Effects {
int get();
void set(int value);
}
JScript public function get Effects() : int
public function set Effects(int);

Property Value

System.Int32

This property is read/write.


OverlayEffects.MirrorLeftRight Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.MirrorLeftRight Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mirror the overlay around the vertical axis. Deprecated.

Definition

Visual Basic | Public Property MirrorLeftRight As Boolean
C# | public bool MirrorLeftRight { get; set; }
C++ public:
property bool MirrorLeftRight {
bool get();
void set(bool value);
}
JScript public function get MirrorLeftRight() : boolean
public function set MirrorLeftRight(boolean);

Property Value

System.Boolean

This property is read/write.


OverlayEffects.MirrorUpDown Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.MirrorUpDown Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mirror the overlay around the horizontal axis. Deprecated.

Definition

Visual Basic | Public Property MirrorUpDown As Boolean
C# | public bool MirrorUpDown { get; set; }
C++ public:
property bool MirrorUpDown {
bool get();
void set(bool value);
}
JScript public function get MirrorUpDown() : boolean
public function set MirrorUpDown(boolean);

Property Value

System.Boolean

This property is read/write.


OverlayEffects.SourceColorKey Property (Microsoft.DirectX.DirectDraw)

OverlayEffects.SourceColorKey Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Source color key override. Deprecated.

Definition

Visual Basic | Public Property SourceColorKey As ColorKey
C# | public ColorKey SourceColorKey { get; set; }
C++ public:
property ColorKey SourceColorKey {
ColorKey get();
void set(ColorKey value);
}
JScript public function get SourceColorKey() : ColorKey
public function set SourceColorKey(ColorKey);

Property Value

Microsoft.DirectX.DirectDraw.ColorKey

This property is read/write.


PaletteCaps Structure (Microsoft.DirectX.DirectDraw)

PaletteCaps Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Palette capabilities Deprecated.

Definition

Visual Basic | Public Structure PaletteCaps
C# | public struct PaletteCaps
C++ | public value class PaletteCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Allow256
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that can have all 256 entries defined. Deprecated.
Alpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that include an alpha component. Deprecated.
EightBit
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 8-bit color entries (256 colors). Deprecated.
EightBitEntries
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies an index to an 8-bit color index. Deprecated.
FourBit
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 4-bit color entries (16 colors). Deprecated.
OneBit
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 1-bit color entries (two colors). Deprecated.
PrimarySurface
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette is attached to the primary surface. Changing the palette has an immediate effect on the display unless the VSync capability is specified and supported. Deprecated.
PrimarySurfaceLeft
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette is attached to the primary surface on the left. Changing the palette has an immediate effect on the display unless the VSync capability is specified and supported Deprecated.
TwoBit
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 2-bit color entries (four colors). Deprecated.
VerticalSync
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette can be modified synchronously with the monitor's refresh rate. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PaletteCaps.ToString() Method (Microsoft.DirectX.DirectDraw)

PaletteCaps.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PaletteCaps.Allow256 Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.Allow256 Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that can have all 256 entries defined. Deprecated.

Definition

Visual Basic | Public Property Allow256 As Boolean
C# | public bool Allow256 { get; set; }
C++ public:
property bool Allow256 {
bool get();
void set(bool value);
}
JScript public function get Allow256() : boolean
public function set Allow256(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.Alpha Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.Alpha Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that include an alpha component. Deprecated.

Definition

Visual Basic | Public Property Alpha As Boolean
C# | public bool Alpha { get; set; }
C++ public:
property bool Alpha {
bool get();
void set(bool value);
}
JScript public function get Alpha() : boolean
public function set Alpha(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.EightBit Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.EightBit Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 8-bit color entries (256 colors). Deprecated.

Definition

Visual Basic | Public Property EightBit As Boolean
C# | public bool EightBit { get; set; }
C++ public:
property bool EightBit {
bool get();
void set(bool value);
}
JScript public function get EightBit() : boolean
public function set EightBit(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.EightBitEntries Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.EightBitEntries Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies an index to an 8-bit color index. Deprecated.

Definition

Visual Basic | Public Property EightBitEntries As Boolean
C# | public bool EightBitEntries { get; set; }
C++ public:
property bool EightBitEntries {
bool get();
void set(bool value);
}
JScript public function get EightBitEntries() : boolean
public function set EightBitEntries(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.FourBit Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.FourBit Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 4-bit color entries (16 colors). Deprecated.

Definition

Visual Basic | Public Property FourBit As Boolean
C# | public bool FourBit { get; set; }
C++ public:
property bool FourBit {
bool get();
void set(bool value);
}
JScript public function get FourBit() : boolean
public function set FourBit(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.OneBit Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.OneBit Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 1-bit color entries (two colors). Deprecated.

Definition

Visual Basic | Public Property OneBit As Boolean
C# | public bool OneBit { get; set; }
C++ public:
property bool OneBit {
bool get();
void set(bool value);
}
JScript public function get OneBit() : boolean
public function set OneBit(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.PrimarySurface Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.PrimarySurface Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette is attached to the primary surface. Changing the palette has an immediate effect on the display unless the VSync capability is specified and supported. Deprecated.

Definition

Visual Basic | Public Property PrimarySurface As Boolean
C# | public bool PrimarySurface { get; set; }
C++ public:
property bool PrimarySurface {
bool get();
void set(bool value);
}
JScript public function get PrimarySurface() : boolean
public function set PrimarySurface(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.PrimarySurfaceLeft Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.PrimarySurfaceLeft Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette is attached to the primary surface on the left. Changing the palette has an immediate effect on the display unless the VSync capability is specified and supported Deprecated.

Definition

Visual Basic | Public Property PrimarySurfaceLeft As Boolean
C# | public bool PrimarySurfaceLeft { get; set; }
C++ public:
property bool PrimarySurfaceLeft {
bool get();
void set(bool value);
}
JScript public function get PrimarySurfaceLeft() : boolean
public function set PrimarySurfaceLeft(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.TwoBit Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.TwoBit Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supports palettes that contain 2-bit color entries (four colors). Deprecated.

Definition

Visual Basic | Public Property TwoBit As Boolean
C# | public bool TwoBit { get; set; }
C++ public:
property bool TwoBit {
bool get();
void set(bool value);
}
JScript public function get TwoBit() : boolean
public function set TwoBit(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteCaps.VerticalSync Property (Microsoft.DirectX.DirectDraw)

PaletteCaps.VerticalSync Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The palette can be modified synchronously with the monitor's refresh rate. Deprecated.

Definition

Visual Basic | Public Property VerticalSync As Boolean
C# | public bool VerticalSync { get; set; }
C++ public:
property bool VerticalSync {
bool get();
void set(bool value);
}
JScript public function get VerticalSync() : boolean
public function set VerticalSync(boolean);

Property Value

System.Boolean

This property is read/write.


PaletteEntry Structure (Microsoft.DirectX.DirectDraw)

PaletteEntry Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the color and usage of an entry in a logical color palette. Deprecated.

Definition

Visual Basic | Public Structure PaletteEntry
C# | public struct PaletteEntry
C++ | public value class PaletteEntry sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PaletteEntry
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Blue
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a blue intensity value for the palette entry. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies how the palette entry is to be used. Deprecated.
Green
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a green intensity value for the palette entry. Deprecated.
Red
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a red intensity value for the palette entry. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PaletteEntry.PaletteEntry() Constructor (Microsoft.DirectX.DirectDraw)

PaletteEntry.PaletteEntry Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PaletteEntry();
C++ public:
PaletteEntry();
JScript | public function PaletteEntry();


PaletteEntry.ToString() Method (Microsoft.DirectX.DirectDraw)

PaletteEntry.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PaletteEntry.Blue Property (Microsoft.DirectX.DirectDraw)

PaletteEntry.Blue Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a blue intensity value for the palette entry. Deprecated.

Definition

Visual Basic | Public Property Blue As Byte
C# | public byte Blue { get; set; }
C++ public:
property unsigned char Blue {
unsigned char get();
void set(unsigned char value);
}
JScript public function get Blue() : byte
public function set Blue(byte);

Property Value

System.Byte

This property is read/write.


PaletteEntry.Flags Property (Microsoft.DirectX.DirectDraw)

PaletteEntry.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies how the palette entry is to be used. Deprecated.

Definition

Visual Basic | Public Property Flags As Byte
C# | public byte Flags { get; set; }
C++ public:
property unsigned char Flags {
unsigned char get();
void set(unsigned char value);
}
JScript public function get Flags() : byte
public function set Flags(byte);

Property Value

System.Byte

This property is read/write.


PaletteEntry.Green Property (Microsoft.DirectX.DirectDraw)

PaletteEntry.Green Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a green intensity value for the palette entry. Deprecated.

Definition

Visual Basic | Public Property Green As Byte
C# | public byte Green { get; set; }
C++ public:
property unsigned char Green {
unsigned char get();
void set(unsigned char value);
}
JScript public function get Green() : byte
public function set Green(byte);

Property Value

System.Byte

This property is read/write.


PaletteEntry.Red Property (Microsoft.DirectX.DirectDraw)

PaletteEntry.Red Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies a red intensity value for the palette entry. Deprecated.

Definition

Visual Basic | Public Property Red As Byte
C# | public byte Red { get; set; }
C++ public:
property unsigned char Red {
unsigned char get();
void set(unsigned char value);
}
JScript public function get Red() : byte
public function set Red(byte);

Property Value

System.Byte

This property is read/write.


PixelFormat Structure (Microsoft.DirectX.DirectDraw)

PixelFormat Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the pixel format of a DirectDrawSurface. Deprecated.

Definition

Visual Basic | Public Structure PixelFormat
C# | public struct PixelFormat
C++ | public value class PixelFormat sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PixelFormat
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Alpha
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format describes an alpha-only surface. Deprecated.
AlphaBitDepth
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Alpha channel bit depth (1, 2, 4, or 8) for an alpha-only surface. Deprecated.
AlphaPixels
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface has alpha channel information in the pixel format. Deprecated.
AlphaPremultiplied
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface uses the premultiplied alpha format. That is, the color components in each pixel are premultiplied by the alpha component. Deprecated.
BBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for blue bits. Deprecated.
Compressed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface accepts pixel data in the specified format and compress it during the write operation. Deprecated.
DrawMsTypes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Types of multisample draws. Deprecated.
FlipMsTypes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Types of multisample flips. Deprecated.
FourCC
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
FourCC code. Deprecated.
FourCcIsValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The FourCC member is valid and contains a FOURCC code describing a non-RGB pixel format. Deprecated.
GBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for green bits. Deprecated.
PaletteIndexed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is 1-, 2-, 4-, or 8-bit color-indexed. Deprecated.
PaletteIndexedTo8
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is 1-, 2-, or 4-bit color-indexed to an 8-bit palette. Deprecated.
RBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for red bits. Deprecated.
Rgb
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The RGB data in the pixel format structure is valid. Deprecated.
RgbAlphaBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Masks for the alpha channel. Deprecated.
RgbBitCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
RGB bits per pixel (4, 8, 16, 24, or 32). Deprecated.
RgbToYuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface accepts RGB data and translates it during the write operation to YUV data. The format of the data to be written is contained in the pixel format structure. The Rgb flag is set. Deprecated.
YBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for Y bits. Deprecated.
Yuv
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The YUV data in the pixel format structure is valid. Deprecated.
YuvAlphaBitMask
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Masks for the alpha channel. Deprecated.
YuvBitCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
YUV bits per pixel (4, 8, 16, 24, or 32). Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectDraw
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PixelFormat.PixelFormat() Constructor (Microsoft.DirectX.DirectDraw)

PixelFormat.PixelFormat Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PixelFormat();
C++ public:
PixelFormat();
JScript | public function PixelFormat();


PixelFormat.ToString() Method (Microsoft.DirectX.DirectDraw)

PixelFormat.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PixelFormat.Alpha Property (Microsoft.DirectX.DirectDraw)

PixelFormat.Alpha Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The pixel format describes an alpha-only surface. Deprecated.

Definition

Visual Basic | Public Property Alpha As Boolean
C# | public bool Alpha { get; set; }
C++ public:
property bool Alpha {
bool get();
void set(bool value);
}
JScript public function get Alpha() : boolean
public function set Alpha(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.AlphaBitDepth Property (Microsoft.DirectX.DirectDraw)

PixelFormat.AlphaBitDepth Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Alpha channel bit depth (1, 2, 4, or 8) for an alpha-only surface. Deprecated.

Definition

Visual Basic | Public Property AlphaBitDepth As Integer
C# | public int AlphaBitDepth { get; set; }
C++ public:
property int AlphaBitDepth {
int get();
void set(int value);
}
JScript public function get AlphaBitDepth() : int
public function set AlphaBitDepth(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.AlphaPixels Property (Microsoft.DirectX.DirectDraw)

PixelFormat.AlphaPixels Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface has alpha channel information in the pixel format. Deprecated.

Definition

Visual Basic | Public Property AlphaPixels As Boolean
C# | public bool AlphaPixels { get; set; }
C++ public:
property bool AlphaPixels {
bool get();
void set(bool value);
}
JScript public function get AlphaPixels() : boolean
public function set AlphaPixels(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.AlphaPremultiplied Property (Microsoft.DirectX.DirectDraw)

PixelFormat.AlphaPremultiplied Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface uses the premultiplied alpha format. That is, the color components in each pixel are premultiplied by the alpha component. Deprecated.

Definition

Visual Basic | Public Property AlphaPremultiplied As Boolean
C# | public bool AlphaPremultiplied { get; set; }
C++ public:
property bool AlphaPremultiplied {
bool get();
void set(bool value);
}
JScript public function get AlphaPremultiplied() : boolean
public function set AlphaPremultiplied(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.BBitMask Property (Microsoft.DirectX.DirectDraw)

PixelFormat.BBitMask Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for blue bits. Deprecated.

Definition

Visual Basic | Public Property BBitMask As Integer
C# | public int BBitMask { get; set; }
C++ public:
property int BBitMask {
int get();
void set(int value);
}
JScript public function get BBitMask() : int
public function set BBitMask(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.Compressed Property (Microsoft.DirectX.DirectDraw)

PixelFormat.Compressed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface accepts pixel data in the specified format and compress it during the write operation. Deprecated.

Definition

Visual Basic | Public Property Compressed As Boolean
C# | public bool Compressed { get; set; }
C++ public:
property bool Compressed {
bool get();
void set(bool value);
}
JScript public function get Compressed() : boolean
public function set Compressed(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.DrawMsTypes Property (Microsoft.DirectX.DirectDraw)

PixelFormat.DrawMsTypes Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Types of multisample draws. Deprecated.

Definition

Visual Basic | Public Property DrawMsTypes As Short
C# | public short DrawMsTypes { get; set; }
C++ public:
property short DrawMsTypes {
short get();
void set(short value);
}
JScript public function get DrawMsTypes() : short
public function set DrawMsTypes(short);

Property Value

System.Int16

This property is read/write.


PixelFormat.FlipMsTypes Property (Microsoft.DirectX.DirectDraw)

PixelFormat.FlipMsTypes Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Types of multisample flips. Deprecated.

Definition

Visual Basic | Public Property FlipMsTypes As Short
C# | public short FlipMsTypes { get; set; }
C++ public:
property short FlipMsTypes {
short get();
void set(short value);
}
JScript public function get FlipMsTypes() : short
public function set FlipMsTypes(short);

Property Value

System.Int16

This property is read/write.


PixelFormat.FourCC Property (Microsoft.DirectX.DirectDraw)

PixelFormat.FourCC Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
FourCC code. Deprecated.

Definition

Visual Basic | Public Property FourCC As Integer
C# | public int FourCC { get; set; }
C++ public:
property int FourCC {
int get();
void set(int value);
}
JScript public function get FourCC() : int
public function set FourCC(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.FourCcIsValid Property (Microsoft.DirectX.DirectDraw)

PixelFormat.FourCcIsValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The FourCC member is valid and contains a FOURCC code describing a non-RGB pixel format. Deprecated.

Definition

Visual Basic | Public Property FourCcIsValid As Boolean
C# | public bool FourCcIsValid { get; set; }
C++ public:
property bool FourCcIsValid {
bool get();
void set(bool value);
}
JScript public function get FourCcIsValid() : boolean
public function set FourCcIsValid(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.GBitMask Property (Microsoft.DirectX.DirectDraw)

PixelFormat.GBitMask Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for green bits. Deprecated.

Definition

Visual Basic | Public Property GBitMask As Integer
C# | public int GBitMask { get; set; }
C++ public:
property int GBitMask {
int get();
void set(int value);
}
JScript public function get GBitMask() : int
public function set GBitMask(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.PaletteIndexed Property (Microsoft.DirectX.DirectDraw)

PixelFormat.PaletteIndexed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is 1-, 2-, 4-, or 8-bit color-indexed. Deprecated.

Definition

Visual Basic | Public Property PaletteIndexed As Integer
C# | public int PaletteIndexed { get; set; }
C++ public:
property int PaletteIndexed {
int get();
void set(int value);
}
JScript public function get PaletteIndexed() : int
public function set PaletteIndexed(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.PaletteIndexedTo8 Property (Microsoft.DirectX.DirectDraw)

PixelFormat.PaletteIndexedTo8 Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface is 1-, 2-, or 4-bit color-indexed to an 8-bit palette. Deprecated.

Definition

Visual Basic | Public Property PaletteIndexedTo8 As Boolean
C# | public bool PaletteIndexedTo8 { get; set; }
C++ public:
property bool PaletteIndexedTo8 {
bool get();
void set(bool value);
}
JScript public function get PaletteIndexedTo8() : boolean
public function set PaletteIndexedTo8(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.RBitMask Property (Microsoft.DirectX.DirectDraw)

PixelFormat.RBitMask Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for red bits. Deprecated.

Definition

Visual Basic | Public Property RBitMask As Integer
C# | public int RBitMask { get; set; }
C++ public:
property int RBitMask {
int get();
void set(int value);
}
JScript public function get RBitMask() : int
public function set RBitMask(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.Rgb Property (Microsoft.DirectX.DirectDraw)

PixelFormat.Rgb Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The RGB data in the pixel format structure is valid. Deprecated.

Definition

Visual Basic | Public Property Rgb As Boolean
C# | public bool Rgb { get; set; }
C++ public:
property bool Rgb {
bool get();
void set(bool value);
}
JScript public function get Rgb() : boolean
public function set Rgb(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.RgbAlphaBitMask Property (Microsoft.DirectX.DirectDraw)

PixelFormat.RgbAlphaBitMask Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Masks for the alpha channel. Deprecated.

Definition

Visual Basic | Public Property RgbAlphaBitMask As Integer
C# | public int RgbAlphaBitMask { get; set; }
C++ public:
property int RgbAlphaBitMask {
int get();
void set(int value);
}
JScript public function get RgbAlphaBitMask() : int
public function set RgbAlphaBitMask(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.RgbBitCount Property (Microsoft.DirectX.DirectDraw)

PixelFormat.RgbBitCount Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
RGB bits per pixel (4, 8, 16, 24, or 32). Deprecated.

Definition

Visual Basic | Public Property RgbBitCount As Integer
C# | public int RgbBitCount { get; set; }
C++ public:
property int RgbBitCount {
int get();
void set(int value);
}
JScript public function get RgbBitCount() : int
public function set RgbBitCount(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.RgbToYuv Property (Microsoft.DirectX.DirectDraw)

PixelFormat.RgbToYuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The surface accepts RGB data and translates it during the write operation to YUV data. The format of the data to be written is contained in the pixel format structure. The Rgb flag is set. Deprecated.

Definition

Visual Basic | Public Property RgbToYuv As Boolean
C# | public bool RgbToYuv { get; set; }
C++ public:
property bool RgbToYuv {
bool get();
void set(bool value);
}
JScript public function get RgbToYuv() : boolean
public function set RgbToYuv(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.YBitMask Property (Microsoft.DirectX.DirectDraw)

PixelFormat.YBitMask Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Mask for Y bits. Deprecated.

Definition

Visual Basic | Public Property YBitMask As Integer
C# | public int YBitMask { get; set; }
C++ public:
property int YBitMask {
int get();
void set(int value);
}
JScript public function get YBitMask() : int
public function set YBitMask(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.Yuv Property (Microsoft.DirectX.DirectDraw)

PixelFormat.Yuv Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The YUV data in the pixel format structure is valid. Deprecated.

Definition

Visual Basic | Public Property Yuv As Boolean
C# | public bool Yuv { get; set; }
C++ public:
property bool Yuv {
bool get();
void set(bool value);
}
JScript public function get Yuv() : boolean
public function set Yuv(boolean);

Property Value

System.Boolean

This property is read/write.


PixelFormat.YuvAlphaBitMask Property (Microsoft.DirectX.DirectDraw)

PixelFormat.YuvAlphaBitMask Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Masks for the alpha channel. Deprecated.

Definition

Visual Basic | Public Property YuvAlphaBitMask As Integer
C# | public int YuvAlphaBitMask { get; set; }
C++ public:
property int YuvAlphaBitMask {
int get();
void set(int value);
}
JScript public function get YuvAlphaBitMask() : int
public function set YuvAlphaBitMask(int);

Property Value

System.Int32

This property is read/write.


PixelFormat.YuvBitCount Property (Microsoft.DirectX.DirectDraw)

PixelFormat.YuvBitCount Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
YUV bits per pixel (4, 8, 16, 24, or 32). Deprecated.

Definition

Visual Basic | Public Property YuvBitCount As Integer
C# | public int YuvBitCount { get; set; }
C++ public:
property int YuvBitCount {
int get();
void set(int value);
}
JScript public function get YuvBitCount() : int
public function set YuvBitCount(int);

Property Value

System.Int32

This property is read/write.


Microsoft.DirectX.DirectInput

Microsoft DirectInput is used to process data from a keyboard, mouse, joystick, or other game controller. The following tables list the members exposed by the Microsoft.DirectX.DirectInput namespace.

Classes

AcquiredException | The operation cannot be performed while the device is acquired.
Action | Describes a mapping of one game action to one device semantic. An array of Diaction structures is contained by a Diactionformat structure.
ActionCollection | A collection of actions.
ActionFormat | Contains information about the calling application and acts as a container for an array of Diaction structures that define action-to-control mappings for a genre.
BadDriverVersionException | The object could not be created due to an incompatible driver version or mismatched or incomplete driver components.
BufferedData | Contains buffered device information. This structure is used with the Inputdevice9Getdevicedata and the Inputdevice9Senddevicedata methods.
BufferedDataCollection | Collection of buffered data.
ConfigureDevicesParameters
Device | Applications use the methods of the Device object to gain and release access to Microsoft® DirectInput® devices, manage device properties and information, set behavior, perform initialization, create and play force-feedback effects, and invoke a device's control panel.
DeviceFullException | The device is full.
DeviceList | Collection of devices.
DeviceNotRegisteredException | The device or device instance is not registered with DirectInput.
DeviceObjectList | A collection of device objects.
DeviceProperties | Various properties you can get or set on a device.
DInputHelper | Utility class for DirectInput
EffectList | A collection of effects.
EffectObject | Applications use the methods of the EffectObject to manage effects of force-feedback devices.
EffectPlayingException | The parameters were updated in memory but were not downloaded to the device because the device does not support updating an effect while it is still playing.
ForceFeedbackGuid | Force feedback guid.
HasEffectsException | The device cannot be reinitialized because effects are attached to it.
IncompleteEffectException | The effect could not be downloaded because essential information is missing. For example, no axes have been associated with the effect, or no type-specific information has been supplied.
InputException | Base exception type for all DirectInput exceptions. Derives from DirectXException.
InputLostException | Access to the input device has been lost. It must be reacquired.
InsufficientPriveledgesException | Insufficient priveledges for this call.
KeyboardState | Contains the keyboard state.
Manager | Applications use the methods of the Manager object to enumerate, create, and retrieve the status of DirectInput devices.
MapFileFailException | An error has occurred either reading the vendor-supplied action-mapping file for the device or reading or writing the user configuration mapping file for the device.
MoreDataException | Not all the requested information fit into the buffer.
NotAcquiredException | The operation cannot be performed unless the device is acquired.
NotBufferedException | The device is not buffered. Set the BufferSize property to enable buffering.
NotDownloadedException | The effect is not downloaded.
NotExclusivelyAcquiredException | The operation cannot be performed unless the device is acquired in Exclusive mode.
NotFoundException | The requested object does not exist.
ObjectTypeGuid | Object type guid.
OtherApplicationHasPriorityException | Another application has a higher priority level, preventing this call from succeeding.
PendingException | Data is not yet available.
ReportFullException | More information was requested to be sent than can be sent to the device.
SystemGuid | Contains system guids for common device types.
UnpluggedException | The operation could not be completed because the device is not plugged in.
UnsupportedException | The function called is not supported at this time.

Enumerations

ActionAttributeFlags | Flags used to request specific attributes or processing.
ActionMapControl | Flags to control the mapping.
ActionMechanism | Mapping mechanism used by DirectInput to configure the action.
Any | The following constants are used in the dwSemantic member of the Diaction structure to map an action to any matching control on the device.
ApplyActionMap | Value that specifies how the action map is applied.
ArcadePlatform | The genre contains controls for an arcade-style game.
ArcadeSideToSide | The genre contains controls for an arcade-style game.
AxesDataFormat | Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.
BrowserControl | The genre contains controls for browser control.
Button | A button.
Cad2DControl | The genre contains controls for a 2D CAD control
Cad3DControl | The genre contains controls for a 3-D CAD control
CadFlyBy | The genre contains controls for a CAD Fly By.
CadModel | The genre contains controls for a CAD model.
ConfigureDevicesFlags | Flags for configuring devices.
CooperativeLevelFlags | The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.
DataFormatFlags | Data format flags.
DeviceClass | Used when enumerating a class of devices.
DeviceData | Contains buffered device information. This structure is used with the Inputdevice9Getdevicedata and the Inputdevice9Senddevicedata methods.
DeviceDataFormat | Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.
DeviceObjectTypeFlags
DeviceType
DeviceTypeControl
DeviceTypeDriving
DeviceTypeFirstPerson
DeviceTypeFlight
DeviceTypeGamePad
DeviceTypeJoystick
DeviceTypeKeyboard | All keyboards. Equivalent to DI8DEVTYPE_KEYBOARD.
DeviceTypeMouse
DeviceTypeRemote
DeviceTypeScreenPtr
DeviceTypeSupplemental
DI
DrivingCombat
DrivingMecha
DrivingRace
DrivingTank
EffectFlags
EffectParameterFlags
EffectStartFlags
EffectType
EnumBySemanticsReason
EnumDevicesBySemanticsFlags
EnumDevicesFlags
FightingFps
FightingHandToHand
FightingThirdPerson
FileEffectsFlags
FlyingCivilian
FlyingHelicopter
FlyingMilitary
ForceFeedbackCommand
ForceFeedbackStates
ImageFileType
JoystickOffset
Key
Keyboard | The following constants are used in the dwSemantic member of the Diaction structure to map an action to a physical key.
MaxPoints
Mouse | The following constants are used in the dwSemantic member of the Diaction structure to map an action to a physical axis or button on a mouse.
MouseOffset | Mouse device constants, defined in Dinput.h, represent offsets within a mouse device's data packet, the Dimousestate or Dimousestate2 structure.
ObjectInstanceFlags
ParameterHow
PropertyType
PropRangeFlags | Retrieves the range of values an object can possibly report. For some devices, this is a read-only property.
RemoteControl
ReturnCode
SetActionMapReturnCodes
SpaceSim
SportsBaseballBatting
SportsBaseBallField
SportsBaseballPitch
SportsBasketballDefense
SportsBasketballOffense
SportsBikingMountain
SportsFishing
SportsFootballDefense
SportsFootballField
SportsFootballOffense
SportsFootballQuarterback
SportsGolf
SportsHockeyDefense
SportsHockeyGoalie
SportsHockeyOffense
SportsHunting
SportsRaquet
SportsSkiing
SportsSoccerDefense
SportsSoccerOffense
StandardEffect
StrategyRolePlaying
StrategyTurn
TextAlign
TimeStamp
Voice

Structures

CalibrationPoint | Describes a calibration point. An array of Cpoint structures is contained by a Dipropcpoints structure.
ColorSet | Describes a set of colors used to draw the device configuration user object. It is part of the Diconfiguredevicesparams structure.
Condition | Contains type-specific information for effects that are marked as DIEFT_CONDITION.A reference to an array of Dicondition structures for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure. The number of elements in the array must be either one, or equal to the number of axes associated with the effect.
ConstantForce | Contains type-specific information for effects that are marked as DIEFT_CONSTANTFORCE.The structure describes a constant force effect.A reference to a single Diconstantforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
CustomForce | Contains type-specific information for effects that are marked as DIEFT_CUSTOMFORCE.The structure describes a custom or user-defined force.A reference to a Dicustomforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
DataFormat | Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.
DeviceArrival
DeviceCaps | Describes a Microsoft® DirectInput® device's capabilities. This structure is used with the Inputdevice9Getcapabilities method.
DeviceImageInformation | Carries information required to display a device image or an overlay image with a callout. This structure is passed to the Inputdevice9Getimageinfo method as an array within a Dideviceimageinfoheader structure.
DeviceImageInformationHeader | Contains information about device images. Used in the Inputdevice9Getimageinfo method.
DeviceInstance | Describes an instance of a Microsoft® DirectInput® device. This structure is used with the Input9Enumdevices, Input9Enumdevicesbysemantics, and Inputdevice9Getdeviceinfo methods.
DeviceObjectInstance | Describes a device object instance. This structure is used with the Inputdevice9Enumobjects method to provide the Dienumdeviceobjectscallback callback function with information about a particular object associated with a device, such as an axis or button. It is also used with the Inputdevice9Getobjectinfo method to retrieve information about a device object.
Effect | Used by the Inputdevice9Createeffect method to initialize a new Inputeffect object. It is also used by the InputeffectSetparameters and InputeffectGetparameters methods.
EffectInformation | Used by the Inputdevice9Enumeffects and Inputdevice9Geteffectinfo methods to return information about a particular effect supported by a device.
EffectStatus
Envelope | Used by the Dieffect structure to specify the optional TermEnvelope parameters for an effect. The TermSustain level for the envelope is represented by the dwMagnitude member of the Diperiodic structure and the lMagnitude member of the Diconstantforce structure. The sustain time is represented by dwDuration member of the Dieffect structure.
FileEffect | Describes data for a force-feedback effect stored in a file. It is used in conjunction with the Inputdevice9Enumeffectsinfile and Inputdevice9Writeeffecttofile methods.
InputRange
JoystickState | Describes the state of a joystick device. This structure is used with the Inputdevice9Getdevicestate method.
MouseState | Describes the state of a mouse device that has up to four buttons, or another device that is being accessed as if it were a mouse device. This structure is used with the Inputdevice9Getdevicestate method.
ObjectDataFormat | Describes a device object's data format for use with the Inputdevice9Setdataformat method.
Periodic | Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
RampForce | Contains type-specific information for effects that are marked as DIEFT_RAMPFORCE. The structure describes a ramp force effect.A reference to a single Dirampforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
SemanticsInstance


AcquiredException Class (Microsoft.DirectX.DirectInput)

AcquiredException Class

The operation cannot be performed while the device is acquired.

Definition

Visual Basic Public Class AcquiredException
Inherits InputException
C# | public class AcquiredException : InputException
C++ | public ref class AcquiredException : InputException
JScript | public class AcquiredException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AcquiredException | Initializes a new instance of the object.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
AcquiredException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AcquiredException.AcquiredException Constructor ()

Initializes a new instance of the object.

Overload List

public AcquiredException();
protected AcquiredException(SerializationInfo, StreamingContext);
public AcquiredException(string);
public AcquiredException(string, Exception);


AcquiredException.AcquiredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

AcquiredException.AcquiredException Constructor

Initializes a new instance of the AcquiredException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AcquiredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AcquiredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AcquiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AcquiredException.AcquiredException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

AcquiredException.AcquiredException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AcquiredException(
string message,
Exception inner
);
C++ public:
AcquiredException(
String^ message,
Exception^ inner
);
JScript public function AcquiredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AcquiredException.AcquiredException(String) Constructor (Microsoft.DirectX.DirectInput)

AcquiredException.AcquiredException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AcquiredException(
string message
);
C++ public:
AcquiredException(
String^ message
);
JScript public function AcquiredException(
message : String
);

Parameters

message System.String


AcquiredException.AcquiredException() Constructor (Microsoft.DirectX.DirectInput)

AcquiredException.AcquiredException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public AcquiredException();
C++ public:
AcquiredException();
JScript | public function AcquiredException();


Action Class (Microsoft.DirectX.DirectInput)

Action Class

Describes a mapping of one game action to one device semantic. An array of Diaction structures is contained by a Diactionformat structure.

Definition

Visual Basic Public Class Action
Inherits Object
C# | public class Action : Object
C++ | public ref class Action : Object
JScript | public class Action extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Action | Initializes a new instance of the object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Properties

Property | Description
ActionName | Handle of the module containing string resources for action names, as specified in the uResIdString member of the Diaction structure for each action. Can be zero if action names are specified in the lptszActionName member of the Diaction structure for each action.
ApplicationData | Retrieves or sets an identifier, or a function reference, for the application-specific action associated with the device object.
Flags | Flags used to request specific attributes or processing. Can be zero or one or more of the following values.
guidInstance | Device instance GUID if a specific device is requested. Otherwise GUID_NULL.
How | When the structure is returned by Inputdevice9Buildactionmap, this member receives a value to indicate the mapping mechanism used by Microsoft® DirectInput® to configure the action. This memeber is ignored when the action map is passed to Inputdevice9Setactionmap. The following values are defined.
ObjectId | Gets or retrieves a control identifier.
Semantic | For a joystick, a predefined action mapping constant for this application genre representing a virtual control or a constant for a control not defined in the genre. For a keyboard, mouse, or Microsoft® DirectPlay® voice device, a constant that represents a particular device object. See ActionMappingConstants.

Inheritance Hierarchy

Object Leave Site
Action

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Action.Action() Constructor (Microsoft.DirectX.DirectInput)

Action.Action Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public Action();
C++ public:
Action();
JScript | public function Action();


Action.Finalize() Method (Microsoft.DirectX.DirectInput)

Action.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Action();
C++ | !Action();
JScript | protected override function Finalize();


Action.ActionName Property (Microsoft.DirectX.DirectInput)

Action.ActionName Property

Handle of the module containing string resources for action names, as specified in the uResIdString member of the Diaction structure for each action. Can be zero if action names are specified in the lptszActionName member of the Diaction structure for each action.

Definition

Visual Basic | Public Property ActionName As String
C# | public string ActionName { get; set; }
C++ public:
property String^ ActionName {
String^ get();
void set(String^ value);
}
JScript public function get ActionName() : String
public function set ActionName(String);

Property Value

System.String

This property is read/write.


Action.ApplicationData Property (Microsoft.DirectX.DirectInput)

Action.ApplicationData Property

Retrieves or sets an identifier, or a function reference, for the application-specific action associated with the device object.

Definition

Visual Basic | Public Property ApplicationData As Object
C# | public object ApplicationData { get; set; }
C++ public:
property Object^ ApplicationData {
Object^ get();
void set(Object^ value);
}
JScript public function get ApplicationData() : Object
public function set ApplicationData(Object);

Property Value

System.Object

This property is read/write.


Action.Flags Property (Microsoft.DirectX.DirectInput)

Action.Flags Property

Flags used to request specific attributes or processing. Can be zero or one or more of the following values.

Definition

Visual Basic | Public Property Flags As ActionAttributeFlags
C# | public ActionAttributeFlags Flags { get; set; }
C++ public:
property ActionAttributeFlags Flags {
ActionAttributeFlags get();
void set(ActionAttributeFlags value);
}
JScript public function get Flags() : ActionAttributeFlags
public function set Flags(ActionAttributeFlags);

Property Value

Microsoft.DirectX.DirectInput.ActionAttributeFlags

This property is read/write.


Action.guidInstance Property (Microsoft.DirectX.DirectInput)

Action.guidInstance Property

Device instance GUID if a specific device is requested. Otherwise GUID_NULL.

Definition

Visual Basic | Public Property guidInstance As Guid
C# | public Guid guidInstance { get; set; }
C++ public:
property Guid guidInstance {
Guid get();
void set(Guid value);
}
JScript public function get guidInstance() : Guid
public function set guidInstance(Guid);

Property Value

System.Guid

This property is read/write.


Action.How Property (Microsoft.DirectX.DirectInput)

Action.How Property

When the structure is returned by Inputdevice9Buildactionmap, this member receives a value to indicate the mapping mechanism used by Microsoft® DirectInput® to configure the action. This memeber is ignored when the action map is passed to Inputdevice9Setactionmap. The following values are defined.

Definition

Visual Basic | Public Property How As ActionMechanism
C# | public ActionMechanism How { get; set; }
C++ public:
property ActionMechanism How {
ActionMechanism get();
void set(ActionMechanism value);
}
JScript public function get How() : ActionMechanism
public function set How(ActionMechanism);

Property Value

Microsoft.DirectX.DirectInput.ActionMechanism

This property is read/write.


Action.ObjectId Property (Microsoft.DirectX.DirectInput)

Action.ObjectId Property

Gets or retrieves a control identifier.

Definition

Visual Basic | Public Property ObjectId As Integer
C# | public int ObjectId { get; set; }
C++ public:
property int ObjectId {
int get();
void set(int value);
}
JScript public function get ObjectId() : int
public function set ObjectId(int);

Property Value

System.Int32

This property is read/write.


Action.Semantic Property (Microsoft.DirectX.DirectInput)

Action.Semantic Property

For a joystick, a predefined action mapping constant for this application genre representing a virtual control or a constant for a control not defined in the genre. For a keyboard, mouse, or Microsoft® DirectPlay® voice device, a constant that represents a particular device object. See ActionMappingConstants.

Definition

Visual Basic | Public Property Semantic As Integer
C# | public int Semantic { get; set; }
C++ public:
property int Semantic {
int get();
void set(int value);
}
JScript public function get Semantic() : int
public function set Semantic(int);

Property Value

System.Int32

This property is read/write.


ActionCollection Class (Microsoft.DirectX.DirectInput)

ActionCollection Class

A collection of actions.

Definition

Visual Basic Public Class ActionCollection
Inherits Object
Implements ICloneable, IEnumerable
C# | public class ActionCollection : Object, ICloneable, IEnumerable
C++ | public ref class ActionCollection : Object, ICloneable, IEnumerable
JScript | public class ActionCollection extends Object implements ICloneable, IEnumerable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ActionCollection | Initializes a new instance of the object.
Add | Add an element to the collection.
Clear | Clear all of the elements from the collection.
Clone | Duplicates the object.
Contains | Determines whether an element is in the collection.
CopyTo | Copies the collection or a portion of it to a one-dimensional array.
GetEnumerator | Gets an enumerator for this collection.
IndexOf | Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.

Properties

Property | Description
Count | Gets the number of elements.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection is read only.
Item

Inheritance Hierarchy

Object Leave Site
ActionCollection

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ActionCollection.ActionCollection() Constructor (Microsoft.DirectX.DirectInput)

ActionCollection.ActionCollection Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public ActionCollection();
C++ public:
ActionCollection();
JScript | public function ActionCollection();


ActionCollection.Add(Action) Method (Microsoft.DirectX.DirectInput)

ActionCollection.Add Method

Add an element to the collection.

Definition

Visual Basic Public Function Add( _
ByVal value As Action _
) As Integer
C# public int Add(
Action value
);
C++ public:
int Add(
Action^ value
);
JScript public function Add(
value : Action
) : int;

Parameters

value Microsoft.DirectX.DirectInput.Action

Return Value

System.Int32


ActionCollection.Clear() Method (Microsoft.DirectX.DirectInput)

ActionCollection.Clear Method

Clear all of the elements from the collection.

Definition

Visual Basic | Public Sub Clear()
C# | public void Clear();
C++ public:
void Clear();
JScript | public function Clear();


ActionCollection.Clone() Method (Microsoft.DirectX.DirectInput)

ActionCollection.Clone Method

Duplicates the object.

Definition

Visual Basic | Overrides Public Function Clone() As Object
C# | public override object Clone();
C++ public:
virtual Object^ Clone() override;
JScript | public override function Clone() : Object;

Return Value

System.Object


ActionCollection.Contains(Action) Method (Microsoft.DirectX.DirectInput)

ActionCollection.Contains Method

Determines whether an element is in the collection.

Definition

Visual Basic Public Function Contains( _
ByVal value As Action _
) As Boolean
C# public bool Contains(
Action value
);
C++ public:
bool Contains(
Action^ value
);
JScript public function Contains(
value : Action
) : boolean;

Parameters

value Microsoft.DirectX.DirectInput.Action

Return Value

System.Boolean


ActionCollection.CopyTo(Array,Int32) Method (Microsoft.DirectX.DirectInput)

ActionCollection.CopyTo Method

Copies the collection or a portion of it to a one-dimensional array.

Definition

Visual Basic Public Sub CopyTo( _
ByVal data As Array, _
ByVal index As Integer _
)
C# public void CopyTo(
Array data,
int index
);
C++ public:
void CopyTo(
Array^ data,
int index
);
JScript public function CopyTo(
data : Array,
index : int
);

Parameters

data System.Array
index System.Int32


ActionCollection.GetEnumerator() Method (Microsoft.DirectX.DirectInput)

ActionCollection.GetEnumerator Method

Gets an enumerator for this collection.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


ActionCollection.IndexOf(Action) Method (Microsoft.DirectX.DirectInput)

ActionCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.

Definition

Visual Basic Public Function IndexOf( _
ByVal value As Action _
) As Integer
C# public int IndexOf(
Action value
);
C++ public:
int IndexOf(
Action^ value
);
JScript public function IndexOf(
value : Action
) : int;

Parameters

value Microsoft.DirectX.DirectInput.Action

Return Value

System.Int32


ActionCollection.Insert(Int32,Action) Method (Microsoft.DirectX.DirectInput)

ActionCollection.Insert Method

Inserts an element into the collection at the specified index.

Definition

Visual Basic Public Sub Insert( _
ByVal index As Integer, _
ByVal value As Action _
)
C# public void Insert(
int index,
Action value
);
C++ public:
void Insert(
int index,
Action^ value
);
JScript public function Insert(
index : int,
value : Action
);

Parameters

index System.Int32
value Microsoft.DirectX.DirectInput.Action


ActionCollection.Remove(Action) Method (Microsoft.DirectX.DirectInput)

ActionCollection.Remove Method

Removes the first occurrence of a specific object from the collection.

Definition

Visual Basic Public Sub Remove( _
ByVal value As Action _
)
C# public void Remove(
Action value
);
C++ public:
void Remove(
Action^ value
);
JScript public function Remove(
value : Action
);

Parameters

value Microsoft.DirectX.DirectInput.Action


ActionCollection.RemoveAt(Int32) Method (Microsoft.DirectX.DirectInput)

ActionCollection.RemoveAt Method

Removes the element at the specified index of the collection.

Definition

Visual Basic Public Sub RemoveAt( _
ByVal index As Integer _
)
C# public void RemoveAt(
int index
);
C++ public:
void RemoveAt(
int index
);
JScript public function RemoveAt(
index : int
);

Parameters

index System.Int32


ActionCollection.Count Property (Microsoft.DirectX.DirectInput)

ActionCollection.Count Property

Gets the number of elements.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


ActionCollection.IsFixedSize Property (Microsoft.DirectX.DirectInput)

ActionCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

Definition

Visual Basic | Public ReadOnly Property IsFixedSize As Boolean
C# | public bool IsFixedSize { get; }
C++ public:
property bool IsFixedSize {
bool get();
}
JScript | public function get IsFixedSize() : boolean

Property Value

System.Boolean

This property is read-only.


ActionCollection.IsReadOnly Property (Microsoft.DirectX.DirectInput)

ActionCollection.IsReadOnly Property

Gets a value indicating whether the collection is read only.

Definition

Visual Basic | Public ReadOnly Property IsReadOnly As Boolean
C# | public bool IsReadOnly { get; }
C++ public:
property bool IsReadOnly {
bool get();
}
JScript | public function get IsReadOnly() : boolean

Property Value

System.Boolean

This property is read-only.


ActionCollection.Item Property (Microsoft.DirectX.DirectInput)

ActionCollection.Item Property

Definition

Visual Basic Public Property Item( _
ByVal index As Integer _
) As Action
C# public Action this[
int index
] { get; set; }
C++ public:
property Action^ default [int] {
Action^ get(int index);
void set(int index, Action^ value);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32

Property Value

Microsoft.DirectX.DirectInput.Action

This property is read/write.


ActionFormat Class (Microsoft.DirectX.DirectInput)

ActionFormat Class

Contains information about the calling application and acts as a container for an array of Diaction structures that define action-to-control mappings for a genre.

Definition

Visual Basic Public Class ActionFormat
Inherits Object
C# | public class ActionFormat : Object
C++ | public ref class ActionFormat : Object
JScript | public class ActionFormat extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ActionFormat | Initializes a new instance of the object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Properties

Property | Description
ActionMap | GUID that identifies the action map. Device manufacturers can use this value to tune mappings for a specific title.
ActionMapGuid | GUID that identifies the action map. Device manufacturers can use this value to tune mappings for a specific title.
Actions | Collection of actions.
AxisMax | Maximum value for the range of scaled data to be returned for all axes. This value is ignored for a specific action axis if the DIA_NORANGE flag is set in Diaction.dwFlags. This value is valid only for axis actions and should be set to zero for all other actions. It is used as the Diproprange.lMax value to set the range property on an absolute axis when the action map is applied using Inputdevice9Setactionmap.
AxisMin | Minimum value for the range of scaled data to be returned for all axes. This value is ignored for a specific action axis if the DIA_NORANGE flag is set in Diaction.dwFlags. This value is valid only for axis actions and should be set to zero for all other actions. It is used as the Diproprange.lMin value to set the range property on an absolute axis when the action map is applied using Inputdevice9Setactionmap.
BufferSize | Retrieves or sets a value that specifies the number of input data packets in the buffer for each device to which this action-to-control mapping is to be applied.
Genre | DWORD value that specifies the genre of the application. For possible values, see ActionMappingConstants.
Instance | Handle of the module containing string resources for action names, as specified in the uResIdString member of the Diaction structure for each action. Can be zero if action names are specified in the lptszActionName member of the Diaction structure for each action.
InstanceHandle | Handle of the module containing string resources for action names.
TimeStamp | FILETIME structure that receives the time at which this action map was last written to disk. See Remarks.

Inheritance Hierarchy

Object Leave Site
ActionFormat

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ActionFormat.ActionFormat() Constructor (Microsoft.DirectX.DirectInput)

ActionFormat.ActionFormat Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public ActionFormat();
C++ public:
ActionFormat();
JScript | public function ActionFormat();


ActionFormat.Finalize() Method (Microsoft.DirectX.DirectInput)

ActionFormat.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~ActionFormat();
C++ | !ActionFormat();
JScript | protected override function Finalize();


ActionFormat.ActionMap Property (Microsoft.DirectX.DirectInput)

ActionFormat.ActionMap Property

GUID that identifies the action map. Device manufacturers can use this value to tune mappings for a specific title.

Definition

Visual Basic | Public Property ActionMap As String
C# | public string ActionMap { get; set; }
C++ public:
property String^ ActionMap {
String^ get();
void set(String^ value);
}
JScript public function get ActionMap() : String
public function set ActionMap(String);

Property Value

System.String

This property is read/write.


ActionFormat.ActionMapGuid Property (Microsoft.DirectX.DirectInput)

ActionFormat.ActionMapGuid Property

GUID that identifies the action map. Device manufacturers can use this value to tune mappings for a specific title.

Definition

Visual Basic | Public Property ActionMapGuid As Guid
C# | public Guid ActionMapGuid { get; set; }
C++ public:
property Guid ActionMapGuid {
Guid get();
void set(Guid value);
}
JScript public function get ActionMapGuid() : Guid
public function set ActionMapGuid(Guid);

Property Value

System.Guid

This property is read/write.


ActionFormat.Actions Property (Microsoft.DirectX.DirectInput)

ActionFormat.Actions Property

Collection of actions.

Definition

Visual Basic | Public ReadOnly Property Actions As ActionCollection
C# | public ActionCollection Actions { get; }
C++ public:
property ActionCollection^ Actions {
ActionCollection^ get();
}
JScript | public function get Actions() : ActionCollection

Property Value

Microsoft.DirectX.DirectInput.ActionCollection

This property is read-only.


ActionFormat.AxisMax Property (Microsoft.DirectX.DirectInput)

ActionFormat.AxisMax Property

Maximum value for the range of scaled data to be returned for all axes. This value is ignored for a specific action axis if the DIA_NORANGE flag is set in Diaction.dwFlags. This value is valid only for axis actions and should be set to zero for all other actions. It is used as the Diproprange.lMax value to set the range property on an absolute axis when the action map is applied using Inputdevice9Setactionmap.

Definition

Visual Basic | Public Property AxisMax As Integer
C# | public int AxisMax { get; set; }
C++ public:
property int AxisMax {
int get();
void set(int value);
}
JScript public function get AxisMax() : int
public function set AxisMax(int);

Property Value

System.Int32

This property is read/write.


ActionFormat.AxisMin Property (Microsoft.DirectX.DirectInput)

ActionFormat.AxisMin Property

Minimum value for the range of scaled data to be returned for all axes. This value is ignored for a specific action axis if the DIA_NORANGE flag is set in Diaction.dwFlags. This value is valid only for axis actions and should be set to zero for all other actions. It is used as the Diproprange.lMin value to set the range property on an absolute axis when the action map is applied using Inputdevice9Setactionmap.

Definition

Visual Basic | Public Property AxisMin As Integer
C# | public int AxisMin { get; set; }
C++ public:
property int AxisMin {
int get();
void set(int value);
}
JScript public function get AxisMin() : int
public function set AxisMin(int);

Property Value

System.Int32

This property is read/write.


ActionFormat.BufferSize Property (Microsoft.DirectX.DirectInput)

ActionFormat.BufferSize Property

Retrieves or sets a value that specifies the number of input data packets in the buffer for each device to which this action-to-control mapping is to be applied.

Definition

Visual Basic | Public Property BufferSize As Integer
C# | public int BufferSize { get; set; }
C++ public:
property int BufferSize {
int get();
void set(int value);
}
JScript public function get BufferSize() : int
public function set BufferSize(int);

Property Value

System.Int32

This property is read/write.


ActionFormat.Genre Property (Microsoft.DirectX.DirectInput)

ActionFormat.Genre Property

DWORD value that specifies the genre of the application. For possible values, see ActionMappingConstants.

Definition

Visual Basic | Public Property Genre As Integer
C# | public int Genre { get; set; }
C++ public:
property int Genre {
int get();
void set(int value);
}
JScript public function get Genre() : int
public function set Genre(int);

Property Value

System.Int32

This property is read/write.


ActionFormat.Instance Property (Microsoft.DirectX.DirectInput)

ActionFormat.Instance Property

Handle of the module containing string resources for action names, as specified in the uResIdString member of the Diaction structure for each action. Can be zero if action names are specified in the lptszActionName member of the Diaction structure for each action.

Definition

Visual Basic Public Property Instance( _
ByVal value As IntPtr _
) As IntPtr
C# public IntPtr this[
IntPtr value
] { set; }
C++ public:
property IntPtr Instance [IntPtr] {
void set(IntPtr value, IntPtr value);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

value System.IntPtr

Property Value

System.IntPtr

This property is write-only.


ActionFormat.InstanceHandle Property (Microsoft.DirectX.DirectInput)

ActionFormat.InstanceHandle Property

Handle of the module containing string resources for action names.

Definition

Visual Basic | Public ReadOnly Property InstanceHandle As IntPtr
C# | public IntPtr InstanceHandle { get; }
C++ public:
property IntPtr InstanceHandle {
IntPtr get();
}
JScript | public function get InstanceHandle() : IntPtr

Property Value

System.IntPtr

This property is read-only.


ActionFormat.TimeStamp Property (Microsoft.DirectX.DirectInput)

ActionFormat.TimeStamp Property

FILETIME structure that receives the time at which this action map was last written to disk. See Remarks.

Definition

Visual Basic | Public Property TimeStamp As FILETIME
C# | public FILETIME TimeStamp { get; set; }
C++ public:
property FILETIME TimeStamp {
FILETIME get();
void set(FILETIME value);
}
JScript public function get TimeStamp() : FILETIME
public function set TimeStamp(FILETIME);

Property Value

System.Runtime.InteropServices.FILETIME

This property is read/write.


BadDriverVersionException Class (Microsoft.DirectX.DirectInput)

BadDriverVersionException Class

The object could not be created due to an incompatible driver version or mismatched or incomplete driver components.

Definition

Visual Basic Public Class BadDriverVersionException
Inherits InputException
C# | public class BadDriverVersionException : InputException
C++ | public ref class BadDriverVersionException : InputException
JScript | public class BadDriverVersionException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BadDriverVersionException | Initializes a new instance of the object.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
BadDriverVersionException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BadDriverVersionException.BadDriverVersionException Constructor ()

Initializes a new instance of the object.

Overload List

public BadDriverVersionException();
protected BadDriverVersionException(SerializationInfo, StreamingContext);
public BadDriverVersionException(string);
public BadDriverVersionException(string, Exception);


BadDriverVersionException.BadDriverVersionException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:

Initializes a new instance of the BadDriverVersionException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BadDriverVersionException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
BadDriverVersionException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function BadDriverVersionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


BadDriverVersionException.BadDriverVersionException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BadDriverVersionException(
string message,
Exception inner
);
C++ public:
BadDriverVersionException(
String^ message,
Exception^ inner
);
JScript public function BadDriverVersionException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


BadDriverVersionException.BadDriverVersionException(String) Constructor (Microsoft.DirectX.DirectInput)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public BadDriverVersionException(
string message
);
C++ public:
BadDriverVersionException(
String^ message
);
JScript public function BadDriverVersionException(
message : String
);

Parameters

message System.String


BadDriverVersionException.BadDriverVersionException() Constructor (Microsoft.DirectX.DirectInput)

BadDriverVersionException.BadDriverVersionException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public BadDriverVersionException();
C++ public:
BadDriverVersionException();
JScript | public function BadDriverVersionException();


BufferedData Class (Microsoft.DirectX.DirectInput)

BufferedData Class

Contains buffered device information. This structure is used with the Inputdevice9Getdevicedata and the Inputdevice9Senddevicedata methods.

Definition

Visual Basic Public Class BufferedData
Inherits Object
C# | public class BufferedData : Object
C++ | public ref class BufferedData : Object
JScript | public class BufferedData extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_GreaterThan
static (Shared in Visual Basic) op_GreaterThanOrEqual
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_LessThan
static (Shared in Visual Basic) op_LessThanOrEqual
static (Shared in Visual Basic) op_LogicalAnd
static (Shared in Visual Basic) op_LogicalOr

Properties

Property | Description
ApplicationData | Application-defined action value assigned to this object in the last call to Inputdevice9Setactionmap. This is the value in the uAppData member of the Diaction structure associated with the object. Ignore this value if you are not using action mapping. When the structure is used with the Inputdevice9Senddevicedata method, this member must be zero.
ButtonPressedData
Data | Data obtained from or sent to the device. For axis input, if the device is in relative axis mode, the relative axis motion is reported. If the device is in absolute axis mode, the absolute axis coordinate is reported.For button input, only the low byte of DwData is significant. The high bit of the low byte is set if the button was pressed; it is clear if the button was released.
Offset | The offset into the current data format of the object whose data is being reported.
Sequence | Microsoft® DirectInput® sequence number for this event. All input events are assigned an increasing sequence number. This enables events from different devices to be sorted chronologically.
TimeStamp | System time at which the input event was generated, in milliseconds. This value wraps around approximately every 50 days. See Remarks. When the structure is used with the Inputdevice9Senddevicedata method, this member must be 0.

Inheritance Hierarchy

Object Leave Site
BufferedData

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BufferedData.op_Equality(BufferedData,BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedData.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_Equality(
BufferedData a,
BufferedData b
);
C++ public:
static bool operator==(
BufferedData^ a,
BufferedData^ b
);
JScript public static function op_Equality(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a Microsoft.DirectX.DirectInput.BufferedData
b Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


BufferedData.op_GreaterThan(BufferedData,BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedData.op_GreaterThan Method

Definition

Visual Basic Public Shared Function op_GreaterThan( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_GreaterThan(
BufferedData a,
BufferedData b
);
C++ public:
static bool operator>(
BufferedData^ a,
BufferedData^ b
);
JScript public static function op_GreaterThan(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a Microsoft.DirectX.DirectInput.BufferedData
b Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean


BufferedData.op_GreaterThanOrEqual(BufferedData,BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedData.op_GreaterThanOrEqual Method

Definition

Visual Basic Public Shared Function op_GreaterThanOrEqual( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_GreaterThanOrEqual(
BufferedData a,
BufferedData b
);
C++ public:
static bool operator>=(
BufferedData^ a,
BufferedData^ b
);
JScript public static function op_GreaterThanOrEqual(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a Microsoft.DirectX.DirectInput.BufferedData
b Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean


BufferedData.op_Inequality(BufferedData,BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedData.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_Inequality(
BufferedData a,
BufferedData b
);
C++ public:
static bool operator!=(
BufferedData^ a,
BufferedData^ b
);
JScript public static function op_Inequality(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a Microsoft.DirectX.DirectInput.BufferedData
b Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


BufferedData.op_LessThan(BufferedData,BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedData.op_LessThan Method

Definition

Visual Basic Public Shared Function op_LessThan( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_LessThan(
BufferedData a,
BufferedData b
);
C++ public:
static bool operator<(
BufferedData^ a,
BufferedData^ b
);
JScript public static function op_LessThan(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a Microsoft.DirectX.DirectInput.BufferedData
b Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean


BufferedData.op_LessThanOrEqual(BufferedData,BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedData.op_LessThanOrEqual Method

Definition

Visual Basic Public Shared Function op_LessThanOrEqual( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_LessThanOrEqual(
BufferedData a,
BufferedData b
);
C++ public:
static bool operator<=(
BufferedData^ a,
BufferedData^ b
);
JScript public static function op_LessThanOrEqual(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a Microsoft.DirectX.DirectInput.BufferedData
b Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean


BufferedData.op_LogicalAnd(BufferedData,BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedData.op_LogicalAnd Method

Definition

Visual Basic Public Shared Function op_LogicalAnd( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_LogicalAnd(
BufferedData a,
BufferedData b
);
C++ public:
static bool operator&&(
BufferedData^ a,
BufferedData^ b
);
JScript public static function op_LogicalAnd(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a Microsoft.DirectX.DirectInput.BufferedData
b Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean


BufferedData.op_LogicalOr(BufferedData,BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedData.op_LogicalOr Method

Definition

Visual Basic Public Shared Function op_LogicalOr( _
ByVal a As BufferedData, _
ByVal b As BufferedData _
) As Boolean
C# public static bool op_LogicalOr(
BufferedData a,
BufferedData b
);
C++ public:
static bool operator||(
BufferedData^ a,
BufferedData^ b
);
JScript public static function op_LogicalOr(
a : BufferedData,
b : BufferedData
) : boolean;

Parameters

a Microsoft.DirectX.DirectInput.BufferedData
b Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean


BufferedData.ApplicationData Property (Microsoft.DirectX.DirectInput)

BufferedData.ApplicationData Property

Application-defined action value assigned to this object in the last call to Inputdevice9Setactionmap. This is the value in the uAppData member of the Diaction structure associated with the object. Ignore this value if you are not using action mapping. When the structure is used with the Inputdevice9Senddevicedata method, this member must be zero.

Definition

Visual Basic | Public ReadOnly Property ApplicationData As Object
C# | public object ApplicationData { get; }
C++ public:
property Object^ ApplicationData {
Object^ get();
}
JScript | public function get ApplicationData() : Object

Property Value

System.Object

This property is read-only.


BufferedData.ButtonPressedData Property (Microsoft.DirectX.DirectInput)

BufferedData.ButtonPressedData Property

Definition

Visual Basic | Public ReadOnly Property ButtonPressedData As Integer
C# | public int ButtonPressedData { get; }
C++ public:
property int ButtonPressedData {
int get();
}
JScript | public function get ButtonPressedData() : int

Property Value

System.Int32

This property is read-only.


BufferedData.Data Property (Microsoft.DirectX.DirectInput)

BufferedData.Data Property

Data obtained from or sent to the device. For axis input, if the device is in relative axis mode, the relative axis motion is reported. If the device is in absolute axis mode, the absolute axis coordinate is reported.For button input, only the low byte of DwData is significant. The high bit of the low byte is set if the button was pressed; it is clear if the button was released.

Definition

Visual Basic | Public ReadOnly Property Data As Integer
C# | public int Data { get; }
C++ public:
property int Data {
int get();
}
JScript | public function get Data() : int

Property Value

System.Int32

This property is read-only.


BufferedData.Offset Property (Microsoft.DirectX.DirectInput)

BufferedData.Offset Property

The offset into the current data format of the object whose data is being reported.

Definition

Visual Basic | Public ReadOnly Property Offset As Integer
C# | public int Offset { get; }
C++ public:
property int Offset {
int get();
}
JScript | public function get Offset() : int

Property Value

System.Int32

This property is read-only.


BufferedData.Sequence Property (Microsoft.DirectX.DirectInput)

BufferedData.Sequence Property

Microsoft® DirectInput® sequence number for this event. All input events are assigned an increasing sequence number. This enables events from different devices to be sorted chronologically.

Definition

Visual Basic | Public ReadOnly Property Sequence As Integer
C# | public int Sequence { get; }
C++ public:
property int Sequence {
int get();
}
JScript | public function get Sequence() : int

Property Value

System.Int32

This property is read-only.


BufferedData.TimeStamp Property (Microsoft.DirectX.DirectInput)

BufferedData.TimeStamp Property

System time at which the input event was generated, in milliseconds. This value wraps around approximately every 50 days. See Remarks. When the structure is used with the Inputdevice9Senddevicedata method, this member must be 0.

Definition

Visual Basic | Public ReadOnly Property TimeStamp As Integer
C# | public int TimeStamp { get; }
C++ public:
property int TimeStamp {
int get();
}
JScript | public function get TimeStamp() : int

Property Value

System.Int32

This property is read-only.


BufferedDataCollection Class (Microsoft.DirectX.DirectInput)

BufferedDataCollection Class

Collection of buffered data.

Definition

Visual Basic Public Class BufferedDataCollection
Inherits Object
Implements ICloneable, IEnumerable
C# | public class BufferedDataCollection : Object, ICloneable, IEnumerable
C++ | public ref class BufferedDataCollection : Object, ICloneable, IEnumerable
JScript | public class BufferedDataCollection extends Object implements ICloneable, IEnumerable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Add | Adds a new element to the collection.
BufferedDataCollection | Initializes a new instance of the object.
Clear | Clears all elements from the collection.
Clone | Duplicates the object.
Contains | Determines whether an element is in the collection.
CopyTo | Copies the collection or a portion of it to a one-dimensional array.
DeviceDataAverage | Return the average of all data in the collection.
DeviceDataInstanceCount | Return the count of all the data in the collection.
DeviceDataSum | Return the sum of all the data in the collection.
GetEnumerator | Gets an enumerator for this collection.
IndexOf | Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
SortBySequence | Sort the collection by sequence.

Properties

Property | Description
Count | Gets the number of elements.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection is read only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread-safe).
Item
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Inheritance Hierarchy

Object Leave Site
BufferedDataCollection

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BufferedDataCollection.Add(Object) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Add Method

Adds a new element to the collection.

Definition

Visual Basic Public Function Add( _
ByVal value As Object _
) As Integer
C# public int Add(
object value
);
C++ public:
int Add(
Object^ value
);
JScript public function Add(
value : Object
) : int;

Parameters

value System.Object

Return Value

System.Int32


BufferedDataCollection.BufferedDataCollection() Constructor (Microsoft.DirectX.DirectInput)

BufferedDataCollection.BufferedDataCollection Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public BufferedDataCollection();
C++ public:
BufferedDataCollection();
JScript | public function BufferedDataCollection();


BufferedDataCollection.Clear() Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Clear Method

Clears all elements from the collection.

Definition

Visual Basic | Public Sub Clear()
C# | public void Clear();
C++ public:
void Clear();
JScript | public function Clear();


BufferedDataCollection.Clone() Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Clone Method

Duplicates the object.

Definition

Visual Basic | Overrides Public Function Clone() As Object
C# | public override object Clone();
C++ public:
virtual Object^ Clone() override;
JScript | public override function Clone() : Object;

Return Value

System.Object


BufferedDataCollection.Contains Method ()

Determines whether an element is in the collection.

Overload List

public bool Contains(BufferedData);
public bool Contains(object);


BufferedDataCollection.Contains(Object) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Contains Method

Determines whether an element is in the collection.

Definition

Visual Basic Public Function Contains( _
ByVal obj As Object _
) As Boolean
C# public bool Contains(
object obj
);
C++ public:
bool Contains(
Object^ obj
);
JScript public function Contains(
obj : Object
) : boolean;

Parameters

obj System.Object

Return Value

System.Boolean


BufferedDataCollection.Contains(BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Contains Method

Determines whether an element is in the collection.

Definition

Visual Basic Public Function Contains( _
ByVal value As BufferedData _
) As Boolean
C# public bool Contains(
BufferedData value
);
C++ public:
bool Contains(
BufferedData^ value
);
JScript public function Contains(
value : BufferedData
) : boolean;

Parameters

value Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Boolean


BufferedDataCollection.CopyTo(Array,Int32) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.CopyTo Method

Copies the collection or a portion of it to a one-dimensional array.

Definition

Visual Basic Public Sub CopyTo( _
ByVal data As Array, _
ByVal index As Integer _
)
C# public void CopyTo(
Array data,
int index
);
C++ public:
void CopyTo(
Array^ data,
int index
);
JScript public function CopyTo(
data : Array,
index : int
);

Parameters

data System.Array
index System.Int32


BufferedDataCollection.DeviceDataAverage Method ()

Return the average of all data in the collection.

Overload List

public int DeviceDataAverage(int);
public int DeviceDataAverage(object);


BufferedDataCollection.DeviceDataAverage(Int32) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.DeviceDataAverage Method

Return the average of all data in the collection.

Definition

Visual Basic Public Function DeviceDataAverage( _
ByVal offset As Integer _
) As Integer
C# public int DeviceDataAverage(
int offset
);
C++ public:
int DeviceDataAverage(
int offset
);
JScript public function DeviceDataAverage(
offset : int
) : int;

Parameters

offset System.Int32

Return Value

System.Int32


BufferedDataCollection.DeviceDataAverage(Object) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.DeviceDataAverage Method

Return the average of all data in the collection.

Definition

Visual Basic Public Function DeviceDataAverage( _
ByVal applicationData As Object _
) As Integer
C# public int DeviceDataAverage(
object applicationData
);
C++ public:
int DeviceDataAverage(
Object^ applicationData
);
JScript public function DeviceDataAverage(
applicationData : Object
) : int;

Parameters

applicationData System.Object

Return Value

System.Int32


BufferedDataCollection.DeviceDataInstanceCount Method ()

Return the count of all the data in the collection.

Overload List

public int DeviceDataInstanceCount(int);
public int DeviceDataInstanceCount(object);


BufferedDataCollection.DeviceDataInstanceCount(Int32) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.DeviceDataInstanceCount Method

Return the count of all the data in the collection.

Definition

Visual Basic Public Function DeviceDataInstanceCount( _
ByVal offset As Integer _
) As Integer
C# public int DeviceDataInstanceCount(
int offset
);
C++ public:
int DeviceDataInstanceCount(
int offset
);
JScript public function DeviceDataInstanceCount(
offset : int
) : int;

Parameters

offset System.Int32

Return Value

System.Int32


BufferedDataCollection.DeviceDataInstanceCount(Object) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.DeviceDataInstanceCount Method

Return the count of all the data in the collection.

Definition

Visual Basic Public Function DeviceDataInstanceCount( _
ByVal applicationData As Object _
) As Integer
C# public int DeviceDataInstanceCount(
object applicationData
);
C++ public:
int DeviceDataInstanceCount(
Object^ applicationData
);
JScript public function DeviceDataInstanceCount(
applicationData : Object
) : int;

Parameters

applicationData System.Object

Return Value

System.Int32


BufferedDataCollection.DeviceDataSum Method ()

Return the sum of all the data in the collection.

Overload List

public int DeviceDataSum(int);
public int DeviceDataSum(object);


BufferedDataCollection.DeviceDataSum(Int32) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.DeviceDataSum Method

Return the sum of all the data in the collection.

Definition

Visual Basic Public Function DeviceDataSum( _
ByVal offset As Integer _
) As Integer
C# public int DeviceDataSum(
int offset
);
C++ public:
int DeviceDataSum(
int offset
);
JScript public function DeviceDataSum(
offset : int
) : int;

Parameters

offset System.Int32

Return Value

System.Int32


BufferedDataCollection.DeviceDataSum(Object) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.DeviceDataSum Method

Return the sum of all the data in the collection.

Definition

Visual Basic Public Function DeviceDataSum( _
ByVal applicationData As Object _
) As Integer
C# public int DeviceDataSum(
object applicationData
);
C++ public:
int DeviceDataSum(
Object^ applicationData
);
JScript public function DeviceDataSum(
applicationData : Object
) : int;

Parameters

applicationData System.Object

Return Value

System.Int32


BufferedDataCollection.GetEnumerator() Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.GetEnumerator Method

Gets an enumerator for this collection.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


BufferedDataCollection.IndexOf Method ()

Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.

Overload List

public int IndexOf(BufferedData);
public int IndexOf(object);


BufferedDataCollection.IndexOf(Object) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.

Definition

Visual Basic Public Function IndexOf( _
ByVal obj As Object _
) As Integer
C# public int IndexOf(
object obj
);
C++ public:
int IndexOf(
Object^ obj
);
JScript public function IndexOf(
obj : Object
) : int;

Parameters

obj System.Object

Return Value

System.Int32


BufferedDataCollection.IndexOf(BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a value in the collection or in a portion of it.

Definition

Visual Basic Public Function IndexOf( _
ByVal value As BufferedData _
) As Integer
C# public int IndexOf(
BufferedData value
);
C++ public:
int IndexOf(
BufferedData^ value
);
JScript public function IndexOf(
value : BufferedData
) : int;

Parameters

value Microsoft.DirectX.DirectInput.BufferedData

Return Value

System.Int32


BufferedDataCollection.Insert(Int32,Object) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Insert Method

Inserts an element into the collection at the specified index.

Definition

Visual Basic Public Sub Insert( _
ByVal __unnamed000 As Integer, _
ByVal __unnamed001 As Object _
)
C# public void Insert(
int __unnamed000,
object __unnamed001
);
C++ public:
void Insert(
int __unnamed000,
Object^ __unnamed001
);
JScript public function Insert(
__unnamed000 : int,
__unnamed001 : Object
);

Parameters

__unnamed000 System.Int32
__unnamed001 System.Object


BufferedDataCollection.Remove Method ()

Removes the first occurrence of a specific object from the collection.

Overload List

public void Remove(BufferedData);
public void Remove(object);


BufferedDataCollection.Remove(Object) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Remove Method

Removes the first occurrence of a specific object from the collection.

Definition

Visual Basic Public Sub Remove( _
ByVal __unnamed000 As Object _
)
C# public void Remove(
object __unnamed000
);
C++ public:
void Remove(
Object^ __unnamed000
);
JScript public function Remove(
__unnamed000 : Object
);

Parameters

__unnamed000 System.Object


BufferedDataCollection.Remove(BufferedData) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Remove Method

Removes the first occurrence of a specific object from the collection.

Definition

Visual Basic Public Sub Remove( _
ByVal value As BufferedData _
)
C# public void Remove(
BufferedData value
);
C++ public:
void Remove(
BufferedData^ value
);
JScript public function Remove(
value : BufferedData
);

Parameters

value Microsoft.DirectX.DirectInput.BufferedData


BufferedDataCollection.RemoveAt(Int32) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.RemoveAt Method

Removes the element at the specified index of the collection.

Definition

Visual Basic Public Sub RemoveAt( _
ByVal index As Integer _
)
C# public void RemoveAt(
int index
);
C++ public:
void RemoveAt(
int index
);
JScript public function RemoveAt(
index : int
);

Parameters

index System.Int32


BufferedDataCollection.SortBySequence Method ()

Sort the collection by sequence.

Overload List

public void SortBySequence();
public void SortBySequence(bool);


BufferedDataCollection.SortBySequence(Boolean) Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.SortBySequence Method

Sort the collection by sequence.

Definition

Visual Basic Public Sub SortBySequence( _
ByVal Descending As Boolean _
)
C# public void SortBySequence(
bool Descending
);
C++ public:
void SortBySequence(
bool Descending
);
JScript public function SortBySequence(
Descending : boolean
);

Parameters

Descending System.Boolean


BufferedDataCollection.SortBySequence() Method (Microsoft.DirectX.DirectInput)

BufferedDataCollection.SortBySequence Method

Sort the collection by sequence.

Definition

Visual Basic | Public Sub SortBySequence()
C# | public void SortBySequence();
C++ public:
void SortBySequence();
JScript | public function SortBySequence();


BufferedDataCollection.Count Property (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Count Property

Gets the number of elements.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


BufferedDataCollection.IsFixedSize Property (Microsoft.DirectX.DirectInput)

BufferedDataCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

Definition

Visual Basic | Public ReadOnly Property IsFixedSize As Boolean
C# | public bool IsFixedSize { get; }
C++ public:
property bool IsFixedSize {
bool get();
}
JScript | public function get IsFixedSize() : boolean

Property Value

System.Boolean

This property is read-only.


BufferedDataCollection.IsReadOnly Property (Microsoft.DirectX.DirectInput)

BufferedDataCollection.IsReadOnly Property

Gets a value indicating whether the collection is read only.

Definition

Visual Basic | Public ReadOnly Property IsReadOnly As Boolean
C# | public bool IsReadOnly { get; }
C++ public:
property bool IsReadOnly {
bool get();
}
JScript | public function get IsReadOnly() : boolean

Property Value

System.Boolean

This property is read-only.


BufferedDataCollection.IsSynchronized Property (Microsoft.DirectX.DirectInput)

BufferedDataCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread-safe).

Definition

Visual Basic | Public ReadOnly Property IsSynchronized As Boolean
C# | public bool IsSynchronized { get; }
C++ public:
property bool IsSynchronized {
bool get();
}
JScript | public function get IsSynchronized() : boolean

Property Value

System.Boolean

This property is read-only.


BufferedDataCollection.Item Property (Microsoft.DirectX.DirectInput)

BufferedDataCollection.Item Property

Definition

Visual Basic Public Property Item( _
ByVal index As Integer _
) As BufferedData
C# public BufferedData this[
int index
] { get; set; }
C++ public:
property BufferedData^ default [int] {
BufferedData^ get(int index);
void set(int index, BufferedData^ value);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32

Property Value

Microsoft.DirectX.DirectInput.BufferedData

This property is read/write.


BufferedDataCollection.SyncRoot Property (Microsoft.DirectX.DirectInput)

BufferedDataCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

Definition

Visual Basic | Public ReadOnly Property SyncRoot As Object
C# | public object SyncRoot { get; }
C++ public:
property Object^ SyncRoot {
Object^ get();
}
JScript | public function get SyncRoot() : Object

Property Value

System.Object

This property is read-only.


ConfigureDevicesParameters Class (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters Class

Definition

Visual Basic Public Class ConfigureDevicesParameters
Inherits Object
C# | public class ConfigureDevicesParameters : Object
C++ | public ref class ConfigureDevicesParameters : Object
JScript | public class ConfigureDevicesParameters extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ConfigureDevicesParameters | Initializes a new instance of the object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
GetActionFormats
GetUserNames
SetActionFormats
SetUserNames
ToString | Obtains a string representation of the current instance.

Properties

Property Description
ColorSetStruct
Window

Inheritance Hierarchy

Object Leave Site
ConfigureDevicesParameters

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConfigureDevicesParameters.ConfigureDevicesParameters() Constructor (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.ConfigureDevicesParameters Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public ConfigureDevicesParameters();
C++ public:
ConfigureDevicesParameters();
JScript | public function ConfigureDevicesParameters();


ConfigureDevicesParameters.Finalize() Method (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~ConfigureDevicesParameters();
C++ | !ConfigureDevicesParameters();
JScript | protected override function Finalize();


ConfigureDevicesParameters.GetActionFormats() Method (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.GetActionFormats Method

Definition

Visual Basic | Public Function GetActionFormats() As ActionFormat()
C# | public ActionFormat[] GetActionFormats();
C++ public:
array<ActionFormat^>^ GetActionFormats();
JScript | public function GetActionFormats() : ActionFormat[];

Return Value

Microsoft.DirectX.DirectInput.ActionFormat[]


ConfigureDevicesParameters.GetUserNames() Method (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.GetUserNames Method

Definition

Visual Basic | Public Function GetUserNames() As String()
C# | public string[] GetUserNames();
C++ public:
array<String^>^ GetUserNames();
JScript | public function GetUserNames() : String[];

Return Value

System.String[]


ConfigureDevicesParameters.SetActionFormats(ActionFormat[]) Method (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.SetActionFormats Method

Definition

Visual Basic Public Sub SetActionFormats( _
ByVal value() As ActionFormat _
)
C# public void SetActionFormats(
ActionFormat[] value
);
C++ public:
void SetActionFormats(
array<ActionFormat^>^ value
);
JScript public function SetActionFormats(
value : ActionFormat[]
);

Parameters

value Microsoft.DirectX.DirectInput.ActionFormat[]


ConfigureDevicesParameters.SetUserNames(String[]) Method (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.SetUserNames Method

Definition

Visual Basic Public Sub SetUserNames( _
ByVal value() As String _
)
C# public void SetUserNames(
string[] value
);
C++ public:
void SetUserNames(
array<String^>^ value
);
JScript public function SetUserNames(
value : String[]
);

Parameters

value System.String[]


ConfigureDevicesParameters.ToString() Method (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConfigureDevicesParameters.ColorSetStruct Property (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.ColorSetStruct Property

Definition

Visual Basic | Public Property ColorSetStruct As ColorSet
C# | public ColorSet ColorSetStruct { get; set; }
C++ public:
property ColorSet ColorSetStruct {
ColorSet get();
void set(ColorSet value);
}
JScript public function get ColorSetStruct() : ColorSet
public function set ColorSetStruct(ColorSet);

Property Value

Microsoft.DirectX.DirectInput.ColorSet

This property is read/write.


ConfigureDevicesParameters.Window Property (Microsoft.DirectX.DirectInput)

ConfigureDevicesParameters.Window Property

Definition

Visual Basic | Public Property Window As Control
C# | public Control Window { get; set; }
C++ public:
property Control^ Window {
Control^ get();
void set(Control^ value);
}
JScript public function get Window() : Control
public function set Window(Control);

Property Value

System.Windows.Forms.Control

This property is read/write.


Device Class (Microsoft.DirectX.DirectInput)

Device Class

Applications use the methods of the Device object to gain and release access to Microsoft® DirectInput® devices, manage device properties and information, set behavior, perform initialization, create and play force-feedback effects, and invoke a device's control panel.

Definition

Visual Basic NotInheritable Public Class Device
Inherits MarshalByRefObject
Implements IDisposable
C# | public sealed class Device : MarshalByRefObject, IDisposable
C++ | public ref class Device sealed : MarshalByRefObject, IDisposable
JScript | public final class Device extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Acquire | Obtains access to the input device.
BuildActionMap | Builds an action map for the device and retrieves information about it.
Device | Initializes a new instance of the object.
Dispose | Immediately releases the unmanaged resources used by an object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
GetBufferedData | Retrieves buffered data from the device.
GetCurrentKeyboardState | Retrieves immediate data from the device.
GetDeviceState
GetEffectInformation
GetEffects | Enumerates all the effects supported by the force-feedback system on the device. The enumerated GUIDs can represent predefined effects, as well as effects peculiar to the device manufacturer.
GetHashCode | Returns the hash code for the current instance.
GetObjectInformation | Retrieves information about a device object, such as a button or axis.
GetObjects | Enumerates the input and output objects available on a device.
GetPressedKeys | Retrieves the currently pressed keys on a keyboard device.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Poll | Retrieves data from polled objects on a Microsoft® DirectInput® device. If the device does not require polling, calling this method has no effect. If a device that requires polling is not polled periodically, no new data is received from the device. Calling this method causes Microsoft® DirectInput® to update the device state, generate input events (if buffered data is enabled), and set notification events (if notification is enabled).
RunControlPanel | Runs the Microsoft® DirectInput® control panel associated with this device. If the device does not have a control panel associated with it, the default device control panel is launched.
SendForceFeedbackCommand | Sends a command to the device's force-feedback system.
SendHardwareCommand | Sends a hardware-specific command to the force-feedback driver.
SetActionMap | Sets the data format for a device and maps application-defined actions to device objects. It also sets the buffer size for buffered data.
SetCooperativeLevel | Establishes the cooperative level for this instance of the device. The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.
SetDataFormat | Sets the data format for the Microsoft® DirectInput® device.
SetEventNotification | Specifies an event that is to be set when the device state changes. It is also used to turn off event notification.
Unacquire | Releases access to the device.
WriteEffect | Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Properties

Property | Description
Caps | Obtains the capabilities of the DirectInputDevice object.
CreatedEffects | Enumerates all the currently created effects for this device. Effects created by Inputdevice9Createeffect are enumerated.
CurrentJoystickState | Retrieves immediate data from the joystick device.
CurrentMouseState | Retrieves immediate data from the mouse device.
DeviceInformation | Obtains information about the device's identity.
ForceFeedbackState | Retrieves the state of the device's force-feedback system.
ImageInformation | Retrieves information about a device image for use in a configuration property sheet.
Objects | Enumerates the input and output objects available on a device.
Properties | Retrieves information about the input device.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Device

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Device.Acquire() Method (Microsoft.DirectX.DirectInput)

Device.Acquire Method

Obtains access to the input device.

Definition

Visual Basic | Public Sub Acquire()
C# | public void Acquire();
C++ public:
void Acquire();
JScript | public function Acquire();


Device.BuildActionMap Method ()

Builds an action map for the device and retrieves information about it.

Overload List

public void BuildActionMap(ActionFormat, ActionMapControl);
public void BuildActionMap(ActionFormat, string, ActionMapControl);


Device.BuildActionMap(ActionFormat,ActionMapControl) Method (Microsoft.DirectX.DirectInput)

Device.BuildActionMap Method

Builds an action map for the device and retrieves information about it.

Definition

Visual Basic Public Sub BuildActionMap( _
ByVal af As ActionFormat, _
ByVal flags As ActionMapControl _
)
C# public void BuildActionMap(
ActionFormat af,
ActionMapControl flags
);
C++ public:
void BuildActionMap(
ActionFormat^ af,
ActionMapControl flags
);
JScript public function BuildActionMap(
af : ActionFormat,
flags : ActionMapControl
);

Parameters

af Microsoft.DirectX.DirectInput.ActionFormat
flags Microsoft.DirectX.DirectInput.ActionMapControl


Device.BuildActionMap(ActionFormat,String,ActionMapControl) Method (Microsoft.DirectX.DirectInput)

Device.BuildActionMap Method

Builds an action map for the device and retrieves information about it.

Definition

Visual Basic Public Sub BuildActionMap( _
ByVal af As ActionFormat, _
ByVal userName As String, _
ByVal flags As ActionMapControl _
)
C# public void BuildActionMap(
ActionFormat af,
string userName,
ActionMapControl flags
);
C++ public:
void BuildActionMap(
ActionFormat^ af,
String^ userName,
ActionMapControl flags
);
JScript public function BuildActionMap(
af : ActionFormat,
userName : String,
flags : ActionMapControl
);

Parameters

af Microsoft.DirectX.DirectInput.ActionFormat
userName System.String
flags Microsoft.DirectX.DirectInput.ActionMapControl


Device.Device(Guid) Constructor (Microsoft.DirectX.DirectInput)

Device.Device Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal deviceGuid As Guid _
)
C# public Device(
Guid deviceGuid
);
C++ public:
Device(
Guid deviceGuid
);
JScript public function Device(
deviceGuid : Guid
);

Parameters

deviceGuid System.Guid


Device.Dispose() Method (Microsoft.DirectX.DirectInput)

Device.Dispose Method

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Device();
JScript | public override function Dispose();


Device.Equals(Object) Method (Microsoft.DirectX.DirectInput)

Device.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Device.Finalize() Method (Microsoft.DirectX.DirectInput)

Device.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Device();
C++ | !Device();
JScript | protected override function Finalize();


Device.GetBufferedData() Method (Microsoft.DirectX.DirectInput)

Device.GetBufferedData Method

Retrieves buffered data from the device.

Definition

Visual Basic | Public Function GetBufferedData() As BufferedDataCollection
C# | public BufferedDataCollection GetBufferedData();
C++ public:
BufferedDataCollection^ GetBufferedData();
JScript | public function GetBufferedData() : BufferedDataCollection;

Return Value

Microsoft.DirectX.DirectInput.BufferedDataCollection


Device.GetCurrentKeyboardState() Method (Microsoft.DirectX.DirectInput)

Device.GetCurrentKeyboardState Method

Retrieves immediate data from the device.

Definition

Visual Basic | Public Function GetCurrentKeyboardState() As KeyboardState
C# | public KeyboardState GetCurrentKeyboardState();
C++ public:
KeyboardState^ GetCurrentKeyboardState();
JScript | public function GetCurrentKeyboardState() : KeyboardState;

Return Value

Microsoft.DirectX.DirectInput.KeyboardState


Device.GetDeviceState(Type) Method (Microsoft.DirectX.DirectInput)

Device.GetDeviceState Method

Definition

Visual Basic Public Function GetDeviceState( _
ByVal customFormatType As Type _
) As Object
C# public object GetDeviceState(
Type customFormatType
);
C++ public:
Object^ GetDeviceState(
Type^ customFormatType
);
JScript public function GetDeviceState(
customFormatType : Type
) : Object;

Parameters

customFormatType System.Type

Return Value

System.Object


Device.GetEffectInformation(Guid) Method (Microsoft.DirectX.DirectInput)

Device.GetEffectInformation Method

Definition

Visual Basic Public Function GetEffectInformation( _
ByVal rguid As Guid _
) As EffectInformation
C# public EffectInformation GetEffectInformation(
Guid rguid
);
C++ public:
EffectInformation GetEffectInformation(
Guid rguid
);
JScript public function GetEffectInformation(
rguid : Guid
) : EffectInformation;

Parameters

rguid System.Guid

Return Value

Microsoft.DirectX.DirectInput.EffectInformation


Device.GetEffects Method ()

Enumerates all the effects supported by the force-feedback system on the device. The enumerated GUIDs can represent predefined effects, as well as effects peculiar to the device manufacturer.

Overload List

public EffectList GetEffects(EffectType);
public EffectList GetEffects(string, FileEffectsFlags);


Device.GetEffects(String,FileEffectsFlags) Method (Microsoft.DirectX.DirectInput)

Device.GetEffects Method

Enumerates all the effects supported by the force-feedback system on the device. The enumerated GUIDs can represent predefined effects, as well as effects peculiar to the device manufacturer.

Definition

Visual Basic Public Function GetEffects( _
ByVal fileName As String, _
ByVal flags As FileEffectsFlags _
) As EffectList
C# public EffectList GetEffects(
string fileName,
FileEffectsFlags flags
);
C++ public:
EffectList^ GetEffects(
String^ fileName,
FileEffectsFlags flags
);
JScript public function GetEffects(
fileName : String,
flags : FileEffectsFlags
) : EffectList;

Parameters

fileName System.String
flags Microsoft.DirectX.DirectInput.FileEffectsFlags

Return Value

Microsoft.DirectX.DirectInput.EffectList


Device.GetEffects(EffectType) Method (Microsoft.DirectX.DirectInput)

Device.GetEffects Method

Enumerates all the effects supported by the force-feedback system on the device. The enumerated GUIDs can represent predefined effects, as well as effects peculiar to the device manufacturer.

Definition

Visual Basic Public Function GetEffects( _
ByVal effType As EffectType _
) As EffectList
C# public EffectList GetEffects(
EffectType effType
);
C++ public:
EffectList^ GetEffects(
EffectType effType
);
JScript public function GetEffects(
effType : EffectType
) : EffectList;

Parameters

effType Microsoft.DirectX.DirectInput.EffectType

Return Value

Microsoft.DirectX.DirectInput.EffectList


Device.GetHashCode() Method (Microsoft.DirectX.DirectInput)

Device.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Device.GetObjectInformation(Int32,ParameterHow) Method (Microsoft.DirectX.DirectInput)

Device.GetObjectInformation Method

Retrieves information about a device object, such as a button or axis.

Definition

Visual Basic Public Function GetObjectInformation( _
ByVal obj As Integer, _
ByVal how As ParameterHow _
) As DeviceObjectInstance
C# public DeviceObjectInstance GetObjectInformation(
int obj,
ParameterHow how
);
C++ public:
DeviceObjectInstance GetObjectInformation(
int obj,
ParameterHow how
);
JScript public function GetObjectInformation(
obj : int,
how : ParameterHow
) : DeviceObjectInstance;

Parameters

obj System.Int32
how Microsoft.DirectX.DirectInput.ParameterHow

Return Value

Microsoft.DirectX.DirectInput.DeviceObjectInstance


Device.GetObjects(DeviceObjectTypeFlags) Method (Microsoft.DirectX.DirectInput)

Device.GetObjects Method

Enumerates the input and output objects available on a device.

Definition

Visual Basic Public Function GetObjects( _
ByVal flags As DeviceObjectTypeFlags _
) As DeviceObjectList
C# public DeviceObjectList GetObjects(
DeviceObjectTypeFlags flags
);
C++ public:
DeviceObjectList^ GetObjects(
DeviceObjectTypeFlags flags
);
JScript public function GetObjects(
flags : DeviceObjectTypeFlags
) : DeviceObjectList;

Parameters

flags Microsoft.DirectX.DirectInput.DeviceObjectTypeFlags

Return Value

Microsoft.DirectX.DirectInput.DeviceObjectList


Device.GetPressedKeys() Method (Microsoft.DirectX.DirectInput)

Device.GetPressedKeys Method

Retrieves the currently pressed keys on a keyboard device.

Definition

Visual Basic | Public Function GetPressedKeys() As Key()
C# | public Key[] GetPressedKeys();
C++ public:
array<Key>^ GetPressedKeys();
JScript | public function GetPressedKeys() : Key[];

Return Value

Microsoft.DirectX.DirectInput.Key[]


Device.op_Equality(Device,Device) Method (Microsoft.DirectX.DirectInput)

Device.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Equality(
Device left,
Device right
);
C++ public:
static bool operator==(
Device^ left,
Device^ right
);
JScript public static function op_Equality(
left : Device,
right : Device
) : boolean;

Parameters

left Microsoft.DirectX.DirectInput.Device
The Device structure to the left of the equality operator.
right Microsoft.DirectX.DirectInput.Device
The Device structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Device.op_Inequality(Device,Device) Method (Microsoft.DirectX.DirectInput)

Device.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Inequality(
Device left,
Device right
);
C++ public:
static bool operator!=(
Device^ left,
Device^ right
);
JScript public static function op_Inequality(
left : Device,
right : Device
) : boolean;

Parameters

left Microsoft.DirectX.DirectInput.Device
The Device structure to the left of the equality operator.
right Microsoft.DirectX.DirectInput.Device
The Device structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Device.Poll() Method (Microsoft.DirectX.DirectInput)

Device.Poll Method

Retrieves data from polled objects on a Microsoft® DirectInput® device. If the device does not require polling, calling this method has no effect. If a device that requires polling is not polled periodically, no new data is received from the device. Calling this method causes Microsoft® DirectInput® to update the device state, generate input events (if buffered data is enabled), and set notification events (if notification is enabled).

Definition

Visual Basic | Public Sub Poll()
C# | public void Poll();
C++ public:
void Poll();
JScript | public function Poll();


Device.RunControlPanel Method ()

Runs the Microsoft® DirectInput® control panel associated with this device. If the device does not have a control panel associated with it, the default device control panel is launched.

Overload List

public void RunControlPanel();
public void RunControlPanel(Control);


Device.RunControlPanel() Method (Microsoft.DirectX.DirectInput)

Device.RunControlPanel Method

Runs the Microsoft® DirectInput® control panel associated with this device. If the device does not have a control panel associated with it, the default device control panel is launched.

Definition

Visual Basic | Public Sub RunControlPanel()
C# | public void RunControlPanel();
C++ public:
void RunControlPanel();
JScript | public function RunControlPanel();


Device.RunControlPanel(Control) Method (Microsoft.DirectX.DirectInput)

Device.RunControlPanel Method

Runs the Microsoft® DirectInput® control panel associated with this device. If the device does not have a control panel associated with it, the default device control panel is launched.

Definition

Visual Basic Public Sub RunControlPanel( _
ByVal owner As Control _
)
C# public void RunControlPanel(
Control owner
);
C++ public:
void RunControlPanel(
Control^ owner
);
JScript public function RunControlPanel(
owner : Control
);

Parameters

owner System.Windows.Forms.Control


Device.SendForceFeedbackCommand(ForceFeedbackCommand) Method (Microsoft.DirectX.DirectInput)

Device.SendForceFeedbackCommand Method

Sends a command to the device's force-feedback system.

Definition

Visual Basic Public Sub SendForceFeedbackCommand( _
ByVal command As ForceFeedbackCommand _
)
C# public void SendForceFeedbackCommand(
ForceFeedbackCommand command
);
C++ public:
void SendForceFeedbackCommand(
ForceFeedbackCommand command
);
JScript public function SendForceFeedbackCommand(
command : ForceFeedbackCommand
);

Parameters

command Microsoft.DirectX.DirectInput.ForceFeedbackCommand


Device.SendHardwareCommand(Int32,Byte[]) Method (Microsoft.DirectX.DirectInput)

Device.SendHardwareCommand Method

Sends a hardware-specific command to the force-feedback driver.

Definition

Visual Basic Public Function SendHardwareCommand( _
ByVal command As Integer, _
ByVal data() As Byte _
) As Byte()
C# public byte[] SendHardwareCommand(
int command,
byte[] data
);
C++ public:
array<unsigned char>^ SendHardwareCommand(
int command,
array<unsigned char>^ data
);
JScript public function SendHardwareCommand(
command : int,
data : byte[]
) : byte[];

Parameters

command System.Int32
data System.Byte[]

Return Value

System.Byte[]


Device.SetActionMap Method ()

Sets the data format for a device and maps application-defined actions to device objects. It also sets the buffer size for buffered data.

Overload List

public SetActionMapReturnCodes SetActionMap(ActionFormat, ApplyActionMap);
public SetActionMapReturnCodes SetActionMap(ActionFormat, string, ApplyActionMap);


Device.SetActionMap(ActionFormat,ApplyActionMap) Method (Microsoft.DirectX.DirectInput)

Device.SetActionMap Method

Sets the data format for a device and maps application-defined actions to device objects. It also sets the buffer size for buffered data.

Definition

Visual Basic Public Function SetActionMap( _
ByVal af As ActionFormat, _
ByVal flags As ApplyActionMap _
) As SetActionMapReturnCodes
C# public SetActionMapReturnCodes SetActionMap(
ActionFormat af,
ApplyActionMap flags
);
C++ public:
SetActionMapReturnCodes SetActionMap(
ActionFormat^ af,
ApplyActionMap flags
);
JScript public function SetActionMap(
af : ActionFormat,
flags : ApplyActionMap
) : SetActionMapReturnCodes;

Parameters

af Microsoft.DirectX.DirectInput.ActionFormat
flags Microsoft.DirectX.DirectInput.ApplyActionMap

Return Value

Microsoft.DirectX.DirectInput.SetActionMapReturnCodes


Device.SetActionMap(ActionFormat,String,ApplyActionMap) Method (Microsoft.DirectX.DirectInput)

Device.SetActionMap Method

Sets the data format for a device and maps application-defined actions to device objects. It also sets the buffer size for buffered data.

Definition

Visual Basic Public Function SetActionMap( _
ByVal af As ActionFormat, _
ByVal userName As String, _
ByVal flags As ApplyActionMap _
) As SetActionMapReturnCodes
C# public SetActionMapReturnCodes SetActionMap(
ActionFormat af,
string userName,
ApplyActionMap flags
);
C++ public:
SetActionMapReturnCodes SetActionMap(
ActionFormat^ af,
String^ userName,
ApplyActionMap flags
);
JScript public function SetActionMap(
af : ActionFormat,
userName : String,
flags : ApplyActionMap
) : SetActionMapReturnCodes;

Parameters

af Microsoft.DirectX.DirectInput.ActionFormat
userName System.String
flags Microsoft.DirectX.DirectInput.ApplyActionMap

Return Value

Microsoft.DirectX.DirectInput.SetActionMapReturnCodes


Device.SetCooperativeLevel Method ()

Establishes the cooperative level for this instance of the device. The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.

Overload List

public void SetCooperativeLevel(Control, CooperativeLevelFlags);
public void SetCooperativeLevel(IntPtr, CooperativeLevelFlags);


Device.SetCooperativeLevel(Control,CooperativeLevelFlags) Method (Microsoft.DirectX.DirectInput)

Device.SetCooperativeLevel Method

Establishes the cooperative level for this instance of the device. The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.

Definition

Visual Basic Public Sub SetCooperativeLevel( _
ByVal parent As Control, _
ByVal flags As CooperativeLevelFlags _
)
C# public void SetCooperativeLevel(
Control parent,
CooperativeLevelFlags flags
);
C++ public:
void SetCooperativeLevel(
Control^ parent,
CooperativeLevelFlags flags
);
JScript public function SetCooperativeLevel(
parent : Control,
flags : CooperativeLevelFlags
);

Parameters

parent System.Windows.Forms.Control
flags Microsoft.DirectX.DirectInput.CooperativeLevelFlags


Device.SetCooperativeLevel(IntPtr,CooperativeLevelFlags) Method (Microsoft.DirectX.DirectInput)

Device.SetCooperativeLevel Method

Establishes the cooperative level for this instance of the device. The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.

Definition

Visual Basic Public Sub SetCooperativeLevel( _
ByVal hwnd As IntPtr, _
ByVal flags As CooperativeLevelFlags _
)
C# public void SetCooperativeLevel(
IntPtr hwnd,
CooperativeLevelFlags flags
);
C++ public:
void SetCooperativeLevel(
IntPtr hwnd,
CooperativeLevelFlags flags
);
JScript public function SetCooperativeLevel(
hwnd : IntPtr,
flags : CooperativeLevelFlags
);

Parameters

hwnd System.IntPtr
flags Microsoft.DirectX.DirectInput.CooperativeLevelFlags


Device.SetDataFormat Method ()

Sets the data format for the Microsoft® DirectInput® device.

Overload List

public void SetDataFormat(DataFormat);
public void SetDataFormat(DeviceDataFormat);


Device.SetDataFormat(DeviceDataFormat) Method (Microsoft.DirectX.DirectInput)

Device.SetDataFormat Method

Sets the data format for the Microsoft® DirectInput® device.

Definition

Visual Basic Public Sub SetDataFormat( _
ByVal df As DeviceDataFormat _
)
C# public void SetDataFormat(
DeviceDataFormat df
);
C++ public:
void SetDataFormat(
DeviceDataFormat df
);
JScript public function SetDataFormat(
df : DeviceDataFormat
);

Parameters

df Microsoft.DirectX.DirectInput.DeviceDataFormat


Device.SetDataFormat(DataFormat) Method (Microsoft.DirectX.DirectInput)

Device.SetDataFormat Method

Sets the data format for the Microsoft® DirectInput® device.

Definition

Visual Basic Public Sub SetDataFormat( _
ByVal df As DataFormat _
)
C# public void SetDataFormat(
DataFormat df
);
C++ public:
void SetDataFormat(
DataFormat df
);
JScript public function SetDataFormat(
df : DataFormat
);

Parameters

df Microsoft.DirectX.DirectInput.DataFormat


Device.SetEventNotification(WaitHandle) Method (Microsoft.DirectX.DirectInput)

Device.SetEventNotification Method

Specifies an event that is to be set when the device state changes. It is also used to turn off event notification.

Definition

Visual Basic Public Sub SetEventNotification( _
ByVal deviceEvent As WaitHandle _
)
C# public void SetEventNotification(
WaitHandle deviceEvent
);
C++ public:
void SetEventNotification(
WaitHandle^ deviceEvent
);
JScript public function SetEventNotification(
deviceEvent : WaitHandle
);

Parameters

deviceEvent System.Threading.WaitHandle


Device.Unacquire() Method (Microsoft.DirectX.DirectInput)

Device.Unacquire Method

Releases access to the device.

Definition

Visual Basic | Public Sub Unacquire()
C# | public void Unacquire();
C++ public:
void Unacquire();
JScript | public function Unacquire();


Device.WriteEffect Method ()

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Overload List

public void WriteEffect(Stream, FileEffect[]);
public void WriteEffect(Stream, FileEffect[], FileEffectsFlags);
public void WriteEffect(string, FileEffect[]);
public void WriteEffect(string, FileEffect[], FileEffectsFlags);


Device.WriteEffect(Stream,FileEffect[]) Method (Microsoft.DirectX.DirectInput)

Device.WriteEffect Method

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Definition

Visual Basic Public Sub WriteEffect( _
ByVal stream As Stream, _
ByVal fileEffect() As FileEffect _
)
C# public void WriteEffect(
Stream stream,
FileEffect[] fileEffect
);
C++ public:
void WriteEffect(
Stream^ stream,
array<FileEffect>^ fileEffect
);
JScript public function WriteEffect(
stream : Stream,
fileEffect : FileEffect[]
);

Parameters

stream System.IO.Stream
fileEffect Microsoft.DirectX.DirectInput.FileEffect[]


Device.WriteEffect(Stream,FileEffect[],FileEffectsFlags) Method (Microsoft.DirectX.DirectInput)

Device.WriteEffect Method

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Definition

Visual Basic Public Sub WriteEffect( _
ByVal stream As Stream, _
ByVal fileEffect() As FileEffect, _
ByVal flags As FileEffectsFlags _
)
C# public void WriteEffect(
Stream stream,
FileEffect[] fileEffect,
FileEffectsFlags flags
);
C++ public:
void WriteEffect(
Stream^ stream,
array<FileEffect>^ fileEffect,
FileEffectsFlags flags
);
JScript public function WriteEffect(
stream : Stream,
fileEffect : FileEffect[],
flags : FileEffectsFlags
);

Parameters

stream System.IO.Stream
fileEffect Microsoft.DirectX.DirectInput.FileEffect[]
flags Microsoft.DirectX.DirectInput.FileEffectsFlags


Device.WriteEffect(String,FileEffect[]) Method (Microsoft.DirectX.DirectInput)

Device.WriteEffect Method

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Definition

Visual Basic Public Sub WriteEffect( _
ByVal fileName As String, _
ByVal fileEffect() As FileEffect _
)
C# public void WriteEffect(
string fileName,
FileEffect[] fileEffect
);
C++ public:
void WriteEffect(
String^ fileName,
array<FileEffect>^ fileEffect
);
JScript public function WriteEffect(
fileName : String,
fileEffect : FileEffect[]
);

Parameters

fileName System.String
fileEffect Microsoft.DirectX.DirectInput.FileEffect[]


Device.WriteEffect(String,FileEffect[],FileEffectsFlags) Method (Microsoft.DirectX.DirectInput)

Device.WriteEffect Method

Saves information about one or more force-feedback effects to a file that can be read by using Inputdevice9Enumeffectsinfile. This method is chiefly of interest to those wanting to write their own force-authoring applications.

Definition

Visual Basic Public Sub WriteEffect( _
ByVal fileName As String, _
ByVal fileEffect() As FileEffect, _
ByVal flags As FileEffectsFlags _
)
C# public void WriteEffect(
string fileName,
FileEffect[] fileEffect,
FileEffectsFlags flags
);
C++ public:
void WriteEffect(
String^ fileName,
array<FileEffect>^ fileEffect,
FileEffectsFlags flags
);
JScript public function WriteEffect(
fileName : String,
fileEffect : FileEffect[],
flags : FileEffectsFlags
);

Parameters

fileName System.String
fileEffect Microsoft.DirectX.DirectInput.FileEffect[]
flags Microsoft.DirectX.DirectInput.FileEffectsFlags


Device.Caps Property (Microsoft.DirectX.DirectInput)

Device.Caps Property

Obtains the capabilities of the DirectInputDevice object.

Definition

Visual Basic | Public ReadOnly Property Caps As DeviceCaps
C# | public DeviceCaps Caps { get; }
C++ public:
property DeviceCaps Caps {
DeviceCaps get();
}
JScript | public function get Caps() : DeviceCaps

Property Value

Microsoft.DirectX.DirectInput.DeviceCaps

This property is read-only.


Device.CreatedEffects Property (Microsoft.DirectX.DirectInput)

Device.CreatedEffects Property

Enumerates all the currently created effects for this device. Effects created by Inputdevice9Createeffect are enumerated.

Definition

Visual Basic | Public ReadOnly Property CreatedEffects As EffectList
C# | public EffectList CreatedEffects { get; }
C++ public:
property EffectList^ CreatedEffects {
EffectList^ get();
}
JScript | public function get CreatedEffects() : EffectList

Property Value

Microsoft.DirectX.DirectInput.EffectList

This property is read-only.


Device.CurrentJoystickState Property (Microsoft.DirectX.DirectInput)

Device.CurrentJoystickState Property

Retrieves immediate data from the joystick device.

Definition

Visual Basic | Public ReadOnly Property CurrentJoystickState As JoystickState
C# | public JoystickState CurrentJoystickState { get; }
C++ public:
property JoystickState CurrentJoystickState {
JoystickState get();
}
JScript | public function get CurrentJoystickState() : JoystickState

Property Value

Microsoft.DirectX.DirectInput.JoystickState

This property is read-only.


Device.CurrentMouseState Property (Microsoft.DirectX.DirectInput)

Device.CurrentMouseState Property

Retrieves immediate data from the mouse device.

Definition

Visual Basic | Public ReadOnly Property CurrentMouseState As MouseState
C# | public MouseState CurrentMouseState { get; }
C++ public:
property MouseState CurrentMouseState {
MouseState get();
}
JScript | public function get CurrentMouseState() : MouseState

Property Value

Microsoft.DirectX.DirectInput.MouseState

This property is read-only.


Device.DeviceInformation Property (Microsoft.DirectX.DirectInput)

Device.DeviceInformation Property

Obtains information about the device's identity.

Definition

Visual Basic | Public ReadOnly Property DeviceInformation As DeviceInstance
C# | public DeviceInstance DeviceInformation { get; }
C++ public:
property DeviceInstance DeviceInformation {
DeviceInstance get();
}
JScript | public function get DeviceInformation() : DeviceInstance

Property Value

Microsoft.DirectX.DirectInput.DeviceInstance

This property is read-only.


Device.ForceFeedbackState Property (Microsoft.DirectX.DirectInput)

Device.ForceFeedbackState Property

Retrieves the state of the device's force-feedback system.

Definition

Visual Basic | Public ReadOnly Property ForceFeedbackState As ForceFeedbackStates
C# | public ForceFeedbackStates ForceFeedbackState { get; }
C++ public:
property ForceFeedbackStates ForceFeedbackState {
ForceFeedbackStates get();
}
JScript | public function get ForceFeedbackState() : ForceFeedbackStates

Property Value

Microsoft.DirectX.DirectInput.ForceFeedbackStates

This property is read-only.


Device.ImageInformation Property (Microsoft.DirectX.DirectInput)

Device.ImageInformation Property

Retrieves information about a device image for use in a configuration property sheet.

Definition

Visual Basic | Public ReadOnly Property ImageInformation As DeviceImageInformationHeader
C# | public DeviceImageInformationHeader ImageInformation { get; }
C++ public:
property DeviceImageInformationHeader ImageInformation {
DeviceImageInformationHeader get();
}
JScript | public function get ImageInformation() : DeviceImageInformationHeader

Property Value

Microsoft.DirectX.DirectInput.DeviceImageInformationHeader

This property is read-only.


Device.Objects Property (Microsoft.DirectX.DirectInput)

Device.Objects Property

Enumerates the input and output objects available on a device.

Definition

Visual Basic | Public ReadOnly Property Objects As DeviceObjectList
C# | public DeviceObjectList Objects { get; }
C++ public:
property DeviceObjectList^ Objects {
DeviceObjectList^ get();
}
JScript | public function get Objects() : DeviceObjectList

Property Value

Microsoft.DirectX.DirectInput.DeviceObjectList

This property is read-only.


Device.Properties Property (Microsoft.DirectX.DirectInput)

Device.Properties Property

Retrieves information about the input device.

Definition

Visual Basic | Public ReadOnly Property Properties As DeviceProperties
C# | public DeviceProperties Properties { get; }
C++ public:
property DeviceProperties^ Properties {
DeviceProperties^ get();
}
JScript | public function get Properties() : DeviceProperties

Property Value

Microsoft.DirectX.DirectInput.DeviceProperties

This property is read-only.


DeviceFullException Class (Microsoft.DirectX.DirectInput)

DeviceFullException Class

The device is full.

Definition

Visual Basic Public Class DeviceFullException
Inherits InputException
C# | public class DeviceFullException : InputException
C++ | public ref class DeviceFullException : InputException
JScript | public class DeviceFullException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceFullException | Initializes a new instance of the object.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
DeviceFullException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceFullException.DeviceFullException Constructor ()

Initializes a new instance of the object.

Overload List

public DeviceFullException();
protected DeviceFullException(SerializationInfo, StreamingContext);
public DeviceFullException(string);
public DeviceFullException(string, Exception);


DeviceFullException.DeviceFullException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

DeviceFullException.DeviceFullException Constructor

Initializes a new instance of the DeviceFullException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceFullException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DeviceFullException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DeviceFullException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


DeviceFullException.DeviceFullException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

DeviceFullException.DeviceFullException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceFullException(
string message,
Exception inner
);
C++ public:
DeviceFullException(
String^ message,
Exception^ inner
);
JScript public function DeviceFullException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


DeviceFullException.DeviceFullException(String) Constructor (Microsoft.DirectX.DirectInput)

DeviceFullException.DeviceFullException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DeviceFullException(
string message
);
C++ public:
DeviceFullException(
String^ message
);
JScript public function DeviceFullException(
message : String
);

Parameters

message System.String


DeviceFullException.DeviceFullException() Constructor (Microsoft.DirectX.DirectInput)

DeviceFullException.DeviceFullException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DeviceFullException();
C++ public:
DeviceFullException();
JScript | public function DeviceFullException();


DeviceList Class (Microsoft.DirectX.DirectInput)

DeviceList Class

Collection of devices.

Definition

Visual Basic NotInheritable Public Class DeviceList
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class DeviceList : Object, IEnumerable, IEnumerator
C++ | public ref class DeviceList sealed : Object, IEnumerable, IEnumerator
JScript | public final class DeviceList extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Gets an enumerator for this collection.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

Property | Description
Count | Gets the number of elements.
Current | Gets the current element in the collection.

Inheritance Hierarchy

Object Leave Site
DeviceList

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceList.GetEnumerator() Method (Microsoft.DirectX.DirectInput)

DeviceList.GetEnumerator Method

Gets an enumerator for this collection.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


DeviceList.MoveNext() Method (Microsoft.DirectX.DirectInput)

DeviceList.MoveNext Method

Advances the enumerator to the next element of the collection.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean


DeviceList.Reset() Method (Microsoft.DirectX.DirectInput)

DeviceList.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();


DeviceList.Count Property (Microsoft.DirectX.DirectInput)

DeviceList.Count Property

Gets the number of elements.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


DeviceList.Current Property (Microsoft.DirectX.DirectInput)

DeviceList.Current Property

Gets the current element in the collection.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object

This property is read-only.


DeviceNotRegisteredException Class (Microsoft.DirectX.DirectInput)

DeviceNotRegisteredException Class

The device or device instance is not registered with DirectInput.

Definition

Visual Basic Public Class DeviceNotRegisteredException
Inherits InputException
C# | public class DeviceNotRegisteredException : InputException
C++ | public ref class DeviceNotRegisteredException : InputException
JScript | public class DeviceNotRegisteredException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DeviceNotRegisteredException | Initializes a new instance of the object.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
DeviceNotRegisteredException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceNotRegisteredException.DeviceNotRegisteredException Constructor ()

Initializes a new instance of the object.

Overload List

public DeviceNotRegisteredException();
protected DeviceNotRegisteredException(SerializationInfo, StreamingContext);
public DeviceNotRegisteredException(string);
public DeviceNotRegisteredException(string, Exception);


DeviceNotRegisteredException.DeviceNotRegisteredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DeviceNotRegisteredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DeviceNotRegisteredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DeviceNotRegisteredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


DeviceNotRegisteredException.DeviceNotRegisteredException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DeviceNotRegisteredException(
string message,
Exception inner
);
C++ public:
DeviceNotRegisteredException(
String^ message,
Exception^ inner
);
JScript public function DeviceNotRegisteredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


DeviceNotRegisteredException.DeviceNotRegisteredException(String) Constructor (Microsoft.DirectX.DirectInput)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DeviceNotRegisteredException(
string message
);
C++ public:
DeviceNotRegisteredException(
String^ message
);
JScript public function DeviceNotRegisteredException(
message : String
);

Parameters

message System.String


DeviceNotRegisteredException.DeviceNotRegisteredException() Constructor (Microsoft.DirectX.DirectInput)

DeviceNotRegisteredException.DeviceNotRegisteredException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DeviceNotRegisteredException();
C++ public:
DeviceNotRegisteredException();
JScript | public function DeviceNotRegisteredException();


DeviceObjectList Class (Microsoft.DirectX.DirectInput)

DeviceObjectList Class

A collection of device objects.

Definition

Visual Basic NotInheritable Public Class DeviceObjectList
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class DeviceObjectList : Object, IEnumerable, IEnumerator
C++ | public ref class DeviceObjectList sealed : Object, IEnumerable, IEnumerator
JScript | public final class DeviceObjectList extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Gets an enumerator for this collection.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

Property | Description
Count | Gets the number of elements.
Current | Gets the current element in the collection.

Inheritance Hierarchy

Object Leave Site
DeviceObjectList

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceObjectList.GetEnumerator() Method (Microsoft.DirectX.DirectInput)

DeviceObjectList.GetEnumerator Method

Gets an enumerator for this collection.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


DeviceObjectList.MoveNext() Method (Microsoft.DirectX.DirectInput)

DeviceObjectList.MoveNext Method

Advances the enumerator to the next element of the collection.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean


DeviceObjectList.Reset() Method (Microsoft.DirectX.DirectInput)

DeviceObjectList.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();


DeviceObjectList.Count Property (Microsoft.DirectX.DirectInput)

DeviceObjectList.Count Property

Gets the number of elements.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


DeviceObjectList.Current Property (Microsoft.DirectX.DirectInput)

DeviceObjectList.Current Property

Gets the current element in the collection.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object

This property is read-only.


DeviceProperties Class (Microsoft.DirectX.DirectInput)

DeviceProperties Class

Various properties you can get or set on a device.

Definition

Visual Basic Public Class DeviceProperties
Inherits Object
C# | public class DeviceProperties : Object
C++ | public ref class DeviceProperties : Object
JScript | public class DeviceProperties extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetApplicationData | Retrieves the application-defined value associated with an in-game action.
GetCalibrationPoints | Retrieves calibration points used for the adjustment of incoming raw data.
GetDeadZone | Retrieves a value for the dead zone of a joystick, in the range from 0 through 10,000, where 0 indicates that there is no dead zone, 5,000 indicates that the dead zone extends over 50 percent of the physical range of the axis on both sides of center, and 10,000 indicates that the entire physical range of the axis is dead. When the axis is within the dead zone, it is reported as being at the center of its range.
GetGranularity | Retrieves the input granularity. Granularity represents the smallest distance over which the object reports movement. Most axis objects have a granularity of one; that is, all values are possible. Some axes have a larger granularity. For example, the wheel axis on a mouse can have a granularity of 20; that is, all reported changes in position are multiples of 20. In other words, when the user turns the wheel slowly, the device reports a position of 0, then 20, then 40, and so on. This is a read-only property.
GetKeyName | Retrieves the localized key name for a keyboard key
GetLogicalRange | Retrieves the range of the raw data returned for axes on a HID. Devices can return negative values.
GetPhysicalRange | Retrieves the range of data for axes as suggested by the manufacturer of a HID. Values can be negative. Normally DirectInput returns values from 0 through 0×FFFF, but the range can be made to conform to the manufacturer's suggested range by using the Range property.
GetRange | Retrieves the range of values an object can possibly report. For some devices, this is a read-only property.
GetSaturation | Retrieves a value for the saturation zones of a joystick, in the range from 0 through 10,000. The saturation level is the point at which the axis is considered to be at its most extreme position. For example, if the saturation level is set to 9,500, the axis reaches the extreme of its range when it has moved 95 percent of the physical distance from its center position (or from the dead zone).
GetScanCode | Retrieves the scan code for a keyboard key.
SetApplicationData | Sets the application-defined value associated with an in-game action.
SetCalibrationPoints | Sets calibration points used for the adjustment of incoming raw data.
SetDeadZone | Sets the value for the dead zone of a joystick, in the range from 0 through 10,000, where 0 indicates that there is no dead zone, 5,000 indicates that the dead zone extends over 50 percent of the physical range of the axis on both sides of center, and 10,000 indicates that the entire physical range of the axis is dead. When the axis is within the dead zone, it is reported as being at the center of its range. This setting can be applied to either the entire device or to a specific axis.
SetRange | Sets the range of values an object can possibly report.
SetSaturation | Sets the value for the saturation zones of a joystick, in the range from 0 through 10,000. The saturation level is the point at which the axis is considered to be at its most extreme position. For example, if the saturation level is set to 9,500, the axis reaches the extreme of its range when it has moved 95 percent of the physical distance from its center position (or from the dead zone). This setting can be applied to either the entire device or a specific axis.

Properties

Property | Description
AutoCenter | Specifies whether device objects are self centering. This setting applies to the entire device, rather than to any particular object.
AxisModeAbsolute | Gets or sets a value showing the the axis mode as absolute.
BufferSize | Sets the input buffer size.
ForceFeedbackGain | Sets the gain for the device.
ForceFeedbackLoad | Retrieves the memory load for a device.
JoystickId | Returns the instance number of a joystick.
PortDisplayName | Retrieves the human-readable display name of the port to which this device is connected. Not generally used by applications.
ProductName | Retrieves the friendly product name of the device.
TypeName | Predefined property that retrieves the type name of a device. For most game controllers, this is the registry key name under REGSTR_PATH_JOYOEM from which static device settings can be retrieved, but predefined joystick types have special names consisting of a number sign (#) followed by a character dependent on the type. This value might not be available for all devices.
UserName | Retrieves the user name for a user currently assigned to a device
VendorIdentityProductId | Read-only device property that retrieves the vendor identity (ID) and product ID of a HID device.

Inheritance Hierarchy

Object Leave Site
DeviceProperties

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceProperties.GetApplicationData(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetApplicationData Method

Retrieves the application-defined value associated with an in-game action.

Definition

Visual Basic Public Function GetApplicationData( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Object
C# public object GetApplicationData(
ParameterHow how,
int objectId
);
C++ public:
Object^ GetApplicationData(
ParameterHow how,
int objectId
);
JScript public function GetApplicationData(
how : ParameterHow,
objectId : int
) : Object;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

System.Object


DeviceProperties.GetCalibrationPoints(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetCalibrationPoints Method

Retrieves calibration points used for the adjustment of incoming raw data.

Definition

Visual Basic Public Function GetCalibrationPoints( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As CalibrationPoint()
C# public CalibrationPoint[] GetCalibrationPoints(
ParameterHow how,
int objectId
);
C++ public:
array<CalibrationPoint>^ GetCalibrationPoints(
ParameterHow how,
int objectId
);
JScript public function GetCalibrationPoints(
how : ParameterHow,
objectId : int
) : CalibrationPoint[];

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

Microsoft.DirectX.DirectInput.CalibrationPoint[]


DeviceProperties.GetDeadZone(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetDeadZone Method

Retrieves a value for the dead zone of a joystick, in the range from 0 through 10,000, where 0 indicates that there is no dead zone, 5,000 indicates that the dead zone extends over 50 percent of the physical range of the axis on both sides of center, and 10,000 indicates that the entire physical range of the axis is dead. When the axis is within the dead zone, it is reported as being at the center of its range.

Definition

Visual Basic Public Function GetDeadZone( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Integer
C# public int GetDeadZone(
ParameterHow how,
int objectId
);
C++ public:
int GetDeadZone(
ParameterHow how,
int objectId
);
JScript public function GetDeadZone(
how : ParameterHow,
objectId : int
) : int;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

System.Int32


DeviceProperties.GetGranularity(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetGranularity Method

Retrieves the input granularity. Granularity represents the smallest distance over which the object reports movement. Most axis objects have a granularity of one; that is, all values are possible. Some axes have a larger granularity. For example, the wheel axis on a mouse can have a granularity of 20; that is, all reported changes in position are multiples of 20. In other words, when the user turns the wheel slowly, the device reports a position of 0, then 20, then 40, and so on. This is a read-only property.

Definition

Visual Basic Public Function GetGranularity( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Integer
C# public int GetGranularity(
ParameterHow how,
int objectId
);
C++ public:
int GetGranularity(
ParameterHow how,
int objectId
);
JScript public function GetGranularity(
how : ParameterHow,
objectId : int
) : int;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

System.Int32


DeviceProperties.GetKeyName(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetKeyName Method

Retrieves the localized key name for a keyboard key

Definition

Visual Basic Public Function GetKeyName( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As String
C# public string GetKeyName(
ParameterHow how,
int objectId
);
C++ public:
String^ GetKeyName(
ParameterHow how,
int objectId
);
JScript public function GetKeyName(
how : ParameterHow,
objectId : int
) : String;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

System.String


DeviceProperties.GetLogicalRange(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetLogicalRange Method

Retrieves the range of the raw data returned for axes on a HID. Devices can return negative values.

Definition

Visual Basic Public Function GetLogicalRange( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As InputRange
C# public InputRange GetLogicalRange(
ParameterHow how,
int objectId
);
C++ public:
InputRange GetLogicalRange(
ParameterHow how,
int objectId
);
JScript public function GetLogicalRange(
how : ParameterHow,
objectId : int
) : InputRange;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

Microsoft.DirectX.DirectInput.InputRange


DeviceProperties.GetPhysicalRange(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetPhysicalRange Method

Retrieves the range of data for axes as suggested by the manufacturer of a HID. Values can be negative. Normally DirectInput returns values from 0 through 0×FFFF, but the range can be made to conform to the manufacturer's suggested range by using the Range property.

Definition

Visual Basic Public Function GetPhysicalRange( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As InputRange
C# public InputRange GetPhysicalRange(
ParameterHow how,
int objectId
);
C++ public:
InputRange GetPhysicalRange(
ParameterHow how,
int objectId
);
JScript public function GetPhysicalRange(
how : ParameterHow,
objectId : int
) : InputRange;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

Microsoft.DirectX.DirectInput.InputRange


DeviceProperties.GetRange(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetRange Method

Retrieves the range of values an object can possibly report. For some devices, this is a read-only property.

Definition

Visual Basic Public Function GetRange( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As InputRange
C# public InputRange GetRange(
ParameterHow how,
int objectId
);
C++ public:
InputRange GetRange(
ParameterHow how,
int objectId
);
JScript public function GetRange(
how : ParameterHow,
objectId : int
) : InputRange;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

Microsoft.DirectX.DirectInput.InputRange


DeviceProperties.GetSaturation(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetSaturation Method

Retrieves a value for the saturation zones of a joystick, in the range from 0 through 10,000. The saturation level is the point at which the axis is considered to be at its most extreme position. For example, if the saturation level is set to 9,500, the axis reaches the extreme of its range when it has moved 95 percent of the physical distance from its center position (or from the dead zone).

Definition

Visual Basic Public Function GetSaturation( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Integer
C# public int GetSaturation(
ParameterHow how,
int objectId
);
C++ public:
int GetSaturation(
ParameterHow how,
int objectId
);
JScript public function GetSaturation(
how : ParameterHow,
objectId : int
) : int;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

System.Int32


DeviceProperties.GetScanCode(ParameterHow,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.GetScanCode Method

Retrieves the scan code for a keyboard key.

Definition

Visual Basic Public Function GetScanCode( _
ByVal how As ParameterHow, _
ByVal objectId As Integer _
) As Integer
C# public int GetScanCode(
ParameterHow how,
int objectId
);
C++ public:
int GetScanCode(
ParameterHow how,
int objectId
);
JScript public function GetScanCode(
how : ParameterHow,
objectId : int
) : int;

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32

Return Value

System.Int32


DeviceProperties.SetApplicationData(ParameterHow,Int32,Object) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.SetApplicationData Method

Sets the application-defined value associated with an in-game action.

Definition

Visual Basic Public Sub SetApplicationData( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value As Object _
)
C# public void SetApplicationData(
ParameterHow how,
int objectId,
object value
);
C++ public:
void SetApplicationData(
ParameterHow how,
int objectId,
Object^ value
);
JScript public function SetApplicationData(
how : ParameterHow,
objectId : int,
value : Object
);

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32
value System.Object


DeviceProperties.SetCalibrationPoints(ParameterHow,Int32,CalibrationPoint[]) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.SetCalibrationPoints Method

Sets calibration points used for the adjustment of incoming raw data.

Definition

Visual Basic Public Sub SetCalibrationPoints( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value() As CalibrationPoint _
)
C# public void SetCalibrationPoints(
ParameterHow how,
int objectId,
CalibrationPoint[] value
);
C++ public:
void SetCalibrationPoints(
ParameterHow how,
int objectId,
array<CalibrationPoint>^ value
);
JScript public function SetCalibrationPoints(
how : ParameterHow,
objectId : int,
value : CalibrationPoint[]
);

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32
value Microsoft.DirectX.DirectInput.CalibrationPoint[]


DeviceProperties.SetDeadZone(ParameterHow,Int32,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.SetDeadZone Method

Sets the value for the dead zone of a joystick, in the range from 0 through 10,000, where 0 indicates that there is no dead zone, 5,000 indicates that the dead zone extends over 50 percent of the physical range of the axis on both sides of center, and 10,000 indicates that the entire physical range of the axis is dead. When the axis is within the dead zone, it is reported as being at the center of its range. This setting can be applied to either the entire device or to a specific axis.

Definition

Visual Basic Public Sub SetDeadZone( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value As Integer _
)
C# public void SetDeadZone(
ParameterHow how,
int objectId,
int value
);
C++ public:
void SetDeadZone(
ParameterHow how,
int objectId,
int value
);
JScript public function SetDeadZone(
how : ParameterHow,
objectId : int,
value : int
);

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32
value System.Int32


DeviceProperties.SetRange(ParameterHow,Int32,InputRange) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.SetRange Method

Sets the range of values an object can possibly report.

Definition

Visual Basic Public Sub SetRange( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value As InputRange _
)
C# public void SetRange(
ParameterHow how,
int objectId,
InputRange value
);
C++ public:
void SetRange(
ParameterHow how,
int objectId,
InputRange value
);
JScript public function SetRange(
how : ParameterHow,
objectId : int,
value : InputRange
);

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32
value Microsoft.DirectX.DirectInput.InputRange


DeviceProperties.SetSaturation(ParameterHow,Int32,Int32) Method (Microsoft.DirectX.DirectInput)

DeviceProperties.SetSaturation Method

Sets the value for the saturation zones of a joystick, in the range from 0 through 10,000. The saturation level is the point at which the axis is considered to be at its most extreme position. For example, if the saturation level is set to 9,500, the axis reaches the extreme of its range when it has moved 95 percent of the physical distance from its center position (or from the dead zone). This setting can be applied to either the entire device or a specific axis.

Definition

Visual Basic Public Sub SetSaturation( _
ByVal how As ParameterHow, _
ByVal objectId As Integer, _
ByVal value As Integer _
)
C# public void SetSaturation(
ParameterHow how,
int objectId,
int value
);
C++ public:
void SetSaturation(
ParameterHow how,
int objectId,
int value
);
JScript public function SetSaturation(
how : ParameterHow,
objectId : int,
value : int
);

Parameters

how Microsoft.DirectX.DirectInput.ParameterHow
objectId System.Int32
value System.Int32


DeviceProperties.AutoCenter Property (Microsoft.DirectX.DirectInput)

DeviceProperties.AutoCenter Property

Specifies whether device objects are self centering. This setting applies to the entire device, rather than to any particular object.

Definition

Visual Basic | Public Property AutoCenter As Boolean
C# | public bool AutoCenter { get; set; }
C++ public:
property bool AutoCenter {
bool get();
void set(bool value);
}
JScript public function get AutoCenter() : boolean
public function set AutoCenter(boolean);

Property Value

System.Boolean

This property is read/write.


DeviceProperties.AxisModeAbsolute Property (Microsoft.DirectX.DirectInput)

DeviceProperties.AxisModeAbsolute Property

Gets or sets a value showing the the axis mode as absolute.

Definition

Visual Basic | Public Property AxisModeAbsolute As Boolean
C# | public bool AxisModeAbsolute { get; set; }
C++ public:
property bool AxisModeAbsolute {
bool get();
void set(bool value);
}
JScript public function get AxisModeAbsolute() : boolean
public function set AxisModeAbsolute(boolean);

Property Value

System.Boolean

This property is read/write.


DeviceProperties.BufferSize Property (Microsoft.DirectX.DirectInput)

DeviceProperties.BufferSize Property

Sets the input buffer size.

Definition

Visual Basic | Public Property BufferSize As Integer
C# | public int BufferSize { get; set; }
C++ public:
property int BufferSize {
int get();
void set(int value);
}
JScript public function get BufferSize() : int
public function set BufferSize(int);

Property Value

System.Int32

This property is read/write.


DeviceProperties.ForceFeedbackGain Property (Microsoft.DirectX.DirectInput)

DeviceProperties.ForceFeedbackGain Property

Sets the gain for the device.

Definition

Visual Basic | Public Property ForceFeedbackGain As Integer
C# | public int ForceFeedbackGain { get; set; }
C++ public:
property int ForceFeedbackGain {
int get();
void set(int value);
}
JScript public function get ForceFeedbackGain() : int
public function set ForceFeedbackGain(int);

Property Value

System.Int32

This property is read/write.


DeviceProperties.ForceFeedbackLoad Property (Microsoft.DirectX.DirectInput)

DeviceProperties.ForceFeedbackLoad Property

Retrieves the memory load for a device.

Definition

Visual Basic | Public ReadOnly Property ForceFeedbackLoad As Integer
C# | public int ForceFeedbackLoad { get; }
C++ public:
property int ForceFeedbackLoad {
int get();
}
JScript | public function get ForceFeedbackLoad() : int

Property Value

System.Int32

This property is read-only.


DeviceProperties.JoystickId Property (Microsoft.DirectX.DirectInput)

DeviceProperties.JoystickId Property

Returns the instance number of a joystick.

Definition

Visual Basic | Public ReadOnly Property JoystickId As Integer
C# | public int JoystickId { get; }
C++ public:
property int JoystickId {
int get();
}
JScript | public function get JoystickId() : int

Property Value

System.Int32

This property is read-only.


DeviceProperties.PortDisplayName Property (Microsoft.DirectX.DirectInput)

DeviceProperties.PortDisplayName Property

Retrieves the human-readable display name of the port to which this device is connected. Not generally used by applications.

Definition

Visual Basic | Public ReadOnly Property PortDisplayName As String
C# | public string PortDisplayName { get; }
C++ public:
property String^ PortDisplayName {
String^ get();
}
JScript | public function get PortDisplayName() : String

Property Value

System.String

This property is read-only.


DeviceProperties.ProductName Property (Microsoft.DirectX.DirectInput)

DeviceProperties.ProductName Property

Retrieves the friendly product name of the device.

Definition

Visual Basic | Public ReadOnly Property ProductName As String
C# | public string ProductName { get; }
C++ public:
property String^ ProductName {
String^ get();
}
JScript | public function get ProductName() : String

Property Value

System.String

This property is read-only.


DeviceProperties.TypeName Property (Microsoft.DirectX.DirectInput)

DeviceProperties.TypeName Property

Predefined property that retrieves the type name of a device. For most game controllers, this is the registry key name under REGSTR_PATH_JOYOEM from which static device settings can be retrieved, but predefined joystick types have special names consisting of a number sign (#) followed by a character dependent on the type. This value might not be available for all devices.

Definition

Visual Basic | Public ReadOnly Property TypeName As String
C# | public string TypeName { get; }
C++ public:
property String^ TypeName {
String^ get();
}
JScript | public function get TypeName() : String

Property Value

System.String

This property is read-only.


DeviceProperties.UserName Property (Microsoft.DirectX.DirectInput)

DeviceProperties.UserName Property

Retrieves the user name for a user currently assigned to a device

Definition

Visual Basic | Public ReadOnly Property UserName As String
C# | public string UserName { get; }
C++ public:
property String^ UserName {
String^ get();
}
JScript | public function get UserName() : String

Property Value

System.String

This property is read-only.


DeviceProperties.VendorIdentityProductId Property (Microsoft.DirectX.DirectInput)

DeviceProperties.VendorIdentityProductId Property

Read-only device property that retrieves the vendor identity (ID) and product ID of a HID device.

Definition

Visual Basic | Public ReadOnly Property VendorIdentityProductId As Integer
C# | public int VendorIdentityProductId { get; }
C++ public:
property int VendorIdentityProductId {
int get();
}
JScript | public function get VendorIdentityProductId() : int

Property Value

System.Int32

This property is read-only.


DInputHelper Class (Microsoft.DirectX.DirectInput)

DInputHelper Class

Utility class for DirectInput

Definition

Visual Basic NotInheritable MustInherit Public Class DInputHelper
Inherits Object
C# | public abstract sealed class DInputHelper : Object
C++ | public ref class DInputHelper abstract sealed : Object
JScript | public final abstract class DInputHelper extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) ButtonAny | Any button. This is a function that takes a button number as its argument.
static (Shared in Visual Basic) EnumCollection | An object that belongs to HID link collection number n.
static (Shared in Visual Basic) GetInstance | Extracts the object instance number code from a data format type.
static (Shared in Visual Basic) GetTypeCode
static (Shared in Visual Basic) MakeInstance | Creates an instance identifier of a device object.
static (Shared in Visual Basic) MarshalDeviceArrival | Marshal a device arrival during enumeration.

Inheritance Hierarchy

Object Leave Site
DInputHelper

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DInputHelper.ButtonAny(Int32) Method (Microsoft.DirectX.DirectInput)

DInputHelper.ButtonAny Method

Any button. This is a function that takes a button number as its argument.

Definition

Visual Basic Public Shared Function ButtonAny( _
ByVal instance As Integer _
) As Integer
C# public static int ButtonAny(
int instance
);
C++ public:
static int ButtonAny(
int instance
);
JScript public static function ButtonAny(
instance : int
) : int;

Parameters

instance System.Int32

Return Value

System.Int32


DInputHelper.EnumCollection(Int32) Method (Microsoft.DirectX.DirectInput)

DInputHelper.EnumCollection Method

An object that belongs to HID link collection number n.

Definition

Visual Basic Public Shared Function EnumCollection( _
ByVal n As Integer _
) As Integer
C# public static int EnumCollection(
int n
);
C++ public:
static int EnumCollection(
int n
);
JScript public static function EnumCollection(
n : int
) : int;

Parameters

n System.Int32

Return Value

System.Int32


DInputHelper.GetInstance(Int32) Method (Microsoft.DirectX.DirectInput)

DInputHelper.GetInstance Method

Extracts the object instance number code from a data format type.

Definition

Visual Basic Public Shared Function GetInstance( _
ByVal n As Integer _
) As Integer
C# public static int GetInstance(
int n
);
C++ public:
static int GetInstance(
int n
);
JScript public static function GetInstance(
n : int
) : int;

Parameters

n System.Int32

Return Value

System.Int32


DInputHelper.GetTypeCode(Int32) Method (Microsoft.DirectX.DirectInput)

DInputHelper.GetTypeCode Method

Definition

Visual Basic Public Shared Function GetTypeCode( _
ByVal n As Integer _
) As Integer
C# public static int GetTypeCode(
int n
);
C++ public:
static int GetTypeCode(
int n
);
JScript public static function GetTypeCode(
n : int
) : int;

Parameters

n System.Int32

Return Value

System.Int32


DInputHelper.MakeInstance(Int32) Method (Microsoft.DirectX.DirectInput)

DInputHelper.MakeInstance Method

Creates an instance identifier of a device object.

Definition

Visual Basic Public Shared Function MakeInstance( _
ByVal n As Integer _
) As Integer
C# public static int MakeInstance(
int n
);
C++ public:
static int MakeInstance(
int n
);
JScript public static function MakeInstance(
n : int
) : int;

Parameters

n System.Int32

Return Value

System.Int32


DInputHelper.MarshalDeviceArrival(IntPtr,DeviceArrival) Method (Microsoft.DirectX.DirectInput)

DInputHelper.MarshalDeviceArrival Method

Marshal a device arrival during enumeration.

Definition

Visual Basic Public Shared Function MarshalDeviceArrival( _
ByVal arrival As IntPtr, _
ByRef da As DeviceArrival _
) As Boolean
C# public static bool MarshalDeviceArrival(
IntPtr arrival,
ref DeviceArrival da
);
C++ public:
static bool MarshalDeviceArrival(
IntPtr arrival,
DeviceArrival% da
);
JScript public static function MarshalDeviceArrival(
arrival : IntPtr,
da : DeviceArrival
) : boolean;

Parameters

arrival System.IntPtr
da Microsoft.DirectX.DirectInput.DeviceArrival

Return Value

System.Boolean


EffectList Class (Microsoft.DirectX.DirectInput)

EffectList Class

A collection of effects.

Definition

Visual Basic NotInheritable Public Class EffectList
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class EffectList : Object, IEnumerable, IEnumerator
C++ | public ref class EffectList sealed : Object, IEnumerable, IEnumerator
JScript | public final class EffectList extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetEnumerator | Gets an enumerator for this collection.
MoveNext | Advances the enumerator to the next element of the collection.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

Properties

Property | Description
Count | Gets the number of elements.
Current | Gets the current element in the collection.

Inheritance Hierarchy

Object Leave Site
EffectList

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectList.GetEnumerator() Method (Microsoft.DirectX.DirectInput)

EffectList.GetEnumerator Method

Gets an enumerator for this collection.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


EffectList.MoveNext() Method (Microsoft.DirectX.DirectInput)

EffectList.MoveNext Method

Advances the enumerator to the next element of the collection.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean


EffectList.Reset() Method (Microsoft.DirectX.DirectInput)

EffectList.Reset Method

Sets the enumerator to its initial position, which is before the first element in the collection.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();


EffectList.Count Property (Microsoft.DirectX.DirectInput)

EffectList.Count Property

Gets the number of elements.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


EffectList.Current Property (Microsoft.DirectX.DirectInput)

EffectList.Current Property

Gets the current element in the collection.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object

This property is read-only.


EffectObject Class (Microsoft.DirectX.DirectInput)

EffectObject Class

Applications use the methods of the EffectObject to manage effects of force-feedback devices.

Definition

Visual Basic Public Class EffectObject
Inherits MarshalByRefObject
Implements IDisposable
C# | public class EffectObject : MarshalByRefObject, IDisposable
C++ | public ref class EffectObject : MarshalByRefObject, IDisposable
JScript | public class EffectObject extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by an object.
Download | Places the effect on the device. If the effect is already on the device, the existing effect is updated to match the values set by the method.
EffectObject | Initializes a new instance of the object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetParameters | Retrieves information about an effect.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
SendHardwareCommand | Sends a hardware-specific command to the driver.
SetParameters | Sets the characteristics of an effect.
Start | Begins playing an effect. If the effect is already playing, it is restarted from the beginning. If the effect has not been downloaded or has been modified since its last download, it is downloaded before being started. This default behavior can be suppressed by passing the DIES_NODOWNLOAD flag.
Stop | Stops playing an effect.
Unload | Removes the effect from the device. If the effect is playing, it is automatically stopped before it is unloaded.

Properties

Property | Description
EffectGuid | Retrieves the GUID for the effect represented by the Inputeffect object.
EffectStatus | Retrieves the status of an effect.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
EffectObject

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectObject.Dispose() Method (Microsoft.DirectX.DirectInput)

EffectObject.Dispose Method

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~EffectObject();
JScript | public override function Dispose();


EffectObject.Download() Method (Microsoft.DirectX.DirectInput)

EffectObject.Download Method

Places the effect on the device. If the effect is already on the device, the existing effect is updated to match the values set by the method.

Definition

Visual Basic | Public Sub Download()
C# | public void Download();
C++ public:
void Download();
JScript | public function Download();


EffectObject.EffectObject Constructor ()

Initializes a new instance of the object.

Overload List

public EffectObject(Guid, Device);
public EffectObject(Guid, Effect, Device);


EffectObject.EffectObject(Guid,Effect,Device) Constructor (Microsoft.DirectX.DirectInput)

EffectObject.EffectObject Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal eff As Guid, _
ByVal die As Effect, _
ByVal dev As Device _
)
C# public EffectObject(
Guid eff,
Effect die,
Device dev
);
C++ public:
EffectObject(
Guid eff,
Effect die,
Device^ dev
);
JScript public function EffectObject(
eff : Guid,
die : Effect,
dev : Device
);

Parameters

eff System.Guid
die Microsoft.DirectX.DirectInput.Effect
dev Microsoft.DirectX.DirectInput.Device


EffectObject.EffectObject(Guid,Device) Constructor (Microsoft.DirectX.DirectInput)

EffectObject.EffectObject Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal eff As Guid, _
ByVal dev As Device _
)
C# public EffectObject(
Guid eff,
Device dev
);
C++ public:
EffectObject(
Guid eff,
Device^ dev
);
JScript public function EffectObject(
eff : Guid,
dev : Device
);

Parameters

eff System.Guid
dev Microsoft.DirectX.DirectInput.Device


EffectObject.Equals(Object) Method (Microsoft.DirectX.DirectInput)

EffectObject.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


EffectObject.Finalize() Method (Microsoft.DirectX.DirectInput)

EffectObject.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~EffectObject();
C++ | !EffectObject();
JScript | protected override function Finalize();


EffectObject.GetHashCode() Method (Microsoft.DirectX.DirectInput)

EffectObject.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


EffectObject.GetParameters(Effect,EffectParameterFlags) Method (Microsoft.DirectX.DirectInput)

EffectObject.GetParameters Method

Retrieves information about an effect.

Definition

Visual Basic Public Sub GetParameters( _
ByRef eff As Effect, _
ByVal flags As EffectParameterFlags _
)
C# public void GetParameters(
ref Effect eff,
EffectParameterFlags flags
);
C++ public:
void GetParameters(
Effect% eff,
EffectParameterFlags flags
);
JScript public function GetParameters(
eff : Effect,
flags : EffectParameterFlags
);

Parameters

eff Microsoft.DirectX.DirectInput.Effect
flags Microsoft.DirectX.DirectInput.EffectParameterFlags


EffectObject.op_Equality(EffectObject,EffectObject) Method (Microsoft.DirectX.DirectInput)

EffectObject.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As EffectObject, _
ByVal right As EffectObject _
) As Boolean
C# public static bool op_Equality(
EffectObject left,
EffectObject right
);
C++ public:
static bool operator==(
EffectObject^ left,
EffectObject^ right
);
JScript public static function op_Equality(
left : EffectObject,
right : EffectObject
) : boolean;

Parameters

left Microsoft.DirectX.DirectInput.EffectObject
The EffectObject structure to the left of the equality operator.
right Microsoft.DirectX.DirectInput.EffectObject
The EffectObject structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


EffectObject.op_Inequality(EffectObject,EffectObject) Method (Microsoft.DirectX.DirectInput)

EffectObject.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As EffectObject, _
ByVal right As EffectObject _
) As Boolean
C# public static bool op_Inequality(
EffectObject left,
EffectObject right
);
C++ public:
static bool operator!=(
EffectObject^ left,
EffectObject^ right
);
JScript public static function op_Inequality(
left : EffectObject,
right : EffectObject
) : boolean;

Parameters

left Microsoft.DirectX.DirectInput.EffectObject
The EffectObject structure to the left of the equality operator.
right Microsoft.DirectX.DirectInput.EffectObject
The EffectObject structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


EffectObject.SendHardwareCommand(Int32,Byte[]) Method (Microsoft.DirectX.DirectInput)

EffectObject.SendHardwareCommand Method

Sends a hardware-specific command to the driver.

Definition

Visual Basic Public Function SendHardwareCommand( _
ByVal command As Integer, _
ByVal data() As Byte _
) As Byte()
C# public byte[] SendHardwareCommand(
int command,
byte[] data
);
C++ public:
array<unsigned char>^ SendHardwareCommand(
int command,
array<unsigned char>^ data
);
JScript public function SendHardwareCommand(
command : int,
data : byte[]
) : byte[];

Parameters

command System.Int32
data System.Byte[]

Return Value

System.Byte[]


EffectObject.SetParameters(Effect,EffectParameterFlags) Method (Microsoft.DirectX.DirectInput)

EffectObject.SetParameters Method

Sets the characteristics of an effect.

Definition

Visual Basic Public Sub SetParameters( _
ByVal eff As Effect, _
ByVal flags As EffectParameterFlags _
)
C# public void SetParameters(
Effect eff,
EffectParameterFlags flags
);
C++ public:
void SetParameters(
Effect eff,
EffectParameterFlags flags
);
JScript public function SetParameters(
eff : Effect,
flags : EffectParameterFlags
);

Parameters

eff Microsoft.DirectX.DirectInput.Effect
flags Microsoft.DirectX.DirectInput.EffectParameterFlags


EffectObject.Start Method ()

Begins playing an effect. If the effect is already playing, it is restarted from the beginning. If the effect has not been downloaded or has been modified since its last download, it is downloaded before being started. This default behavior can be suppressed by passing the DIES_NODOWNLOAD flag.

Overload List

public void Start(int);
public void Start(int, EffectStartFlags);


EffectObject.Start(Int32) Method (Microsoft.DirectX.DirectInput)

EffectObject.Start Method

Begins playing an effect. If the effect is already playing, it is restarted from the beginning. If the effect has not been downloaded or has been modified since its last download, it is downloaded before being started. This default behavior can be suppressed by passing the DIES_NODOWNLOAD flag.

Definition

Visual Basic Public Sub Start( _
ByVal iterations As Integer _
)
C# public void Start(
int iterations
);
C++ public:
void Start(
int iterations
);
JScript public function Start(
iterations : int
);

Parameters

iterations System.Int32


EffectObject.Start(Int32,EffectStartFlags) Method (Microsoft.DirectX.DirectInput)

EffectObject.Start Method

Begins playing an effect. If the effect is already playing, it is restarted from the beginning. If the effect has not been downloaded or has been modified since its last download, it is downloaded before being started. This default behavior can be suppressed by passing the DIES_NODOWNLOAD flag.

Definition

Visual Basic Public Sub Start( _
ByVal iterations As Integer, _
ByVal flags As EffectStartFlags _
)
C# public void Start(
int iterations,
EffectStartFlags flags
);
C++ public:
void Start(
int iterations,
EffectStartFlags flags
);
JScript public function Start(
iterations : int,
flags : EffectStartFlags
);

Parameters

iterations System.Int32
flags Microsoft.DirectX.DirectInput.EffectStartFlags


EffectObject.Stop() Method (Microsoft.DirectX.DirectInput)

EffectObject.Stop Method

Stops playing an effect.

Definition

Visual Basic | Public Sub Stop()
C# | public void Stop();
C++ public:
void Stop();
JScript | public function Stop();


EffectObject.Unload() Method (Microsoft.DirectX.DirectInput)

EffectObject.Unload Method

Removes the effect from the device. If the effect is playing, it is automatically stopped before it is unloaded.

Definition

Visual Basic | Public Sub Unload()
C# | public void Unload();
C++ public:
void Unload();
JScript | public function Unload();


EffectObject.EffectGuid Property (Microsoft.DirectX.DirectInput)

EffectObject.EffectGuid Property

Retrieves the GUID for the effect represented by the Inputeffect object.

Definition

Visual Basic | Public ReadOnly Property EffectGuid As Guid
C# | public Guid EffectGuid { get; }
C++ public:
property Guid EffectGuid {
Guid get();
}
JScript | public function get EffectGuid() : Guid

Property Value

System.Guid

This property is read-only.


EffectObject.EffectStatus Property (Microsoft.DirectX.DirectInput)

EffectObject.EffectStatus Property

Retrieves the status of an effect.

Definition

Visual Basic | Public ReadOnly Property EffectStatus As EffectStatus
C# | public EffectStatus EffectStatus { get; }
C++ public:
property EffectStatus EffectStatus {
EffectStatus get();
}
JScript | public function get EffectStatus() : EffectStatus

Property Value

Microsoft.DirectX.DirectInput.EffectStatus

This property is read-only.


EffectPlayingException Class (Microsoft.DirectX.DirectInput)

EffectPlayingException Class

The parameters were updated in memory but were not downloaded to the device because the device does not support updating an effect while it is still playing.

Definition

Visual Basic Public Class EffectPlayingException
Inherits InputException
C# | public class EffectPlayingException : InputException
C++ | public ref class EffectPlayingException : InputException
JScript | public class EffectPlayingException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
EffectPlayingException | Initializes a new instance of the object.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
EffectPlayingException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectPlayingException.EffectPlayingException Constructor ()

Initializes a new instance of the object.

Overload List

public EffectPlayingException();
protected EffectPlayingException(SerializationInfo, StreamingContext);
public EffectPlayingException(string);
public EffectPlayingException(string, Exception);


EffectPlayingException.EffectPlayingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

EffectPlayingException.EffectPlayingException Constructor

Initializes a new instance of the EffectPlayingException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected EffectPlayingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
EffectPlayingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function EffectPlayingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


EffectPlayingException.EffectPlayingException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

EffectPlayingException.EffectPlayingException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public EffectPlayingException(
string message,
Exception inner
);
C++ public:
EffectPlayingException(
String^ message,
Exception^ inner
);
JScript public function EffectPlayingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


EffectPlayingException.EffectPlayingException(String) Constructor (Microsoft.DirectX.DirectInput)

EffectPlayingException.EffectPlayingException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public EffectPlayingException(
string message
);
C++ public:
EffectPlayingException(
String^ message
);
JScript public function EffectPlayingException(
message : String
);

Parameters

message System.String


EffectPlayingException.EffectPlayingException() Constructor (Microsoft.DirectX.DirectInput)

EffectPlayingException.EffectPlayingException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public EffectPlayingException();
C++ public:
EffectPlayingException();
JScript | public function EffectPlayingException();


ForceFeedbackGuid Class (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid Class

Force feedback guid.

Definition

Visual Basic NotInheritable MustInherit Public Class ForceFeedbackGuid
Inherits Object
C# | public abstract sealed class ForceFeedbackGuid : Object
C++ | public ref class ForceFeedbackGuid abstract sealed : Object
JScript | public final abstract class ForceFeedbackGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic) ConstantForce
static (Shared in Visual Basic) CustomForce
static (Shared in Visual Basic) Damper
static (Shared in Visual Basic) Friction
static (Shared in Visual Basic) Inertia
static (Shared in Visual Basic) RampForce
static (Shared in Visual Basic) SawtoothDown
static (Shared in Visual Basic) SawtoothUp
static (Shared in Visual Basic) Sine
static (Shared in Visual Basic) Spring
static (Shared in Visual Basic) Square
static (Shared in Visual Basic) Triangle

Inheritance Hierarchy

Object Leave Site
ForceFeedbackGuid

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ForceFeedbackGuid.ConstantForce Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.ConstantForce Field

Definition

Visual Basic | Public Shared ConstantForce As Guid
C# | public static Guid ConstantForce;
C++ | public: static Guid ConstantForce;
JScript | public static var ConstantForce : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.CustomForce Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.CustomForce Field

Definition

Visual Basic | Public Shared CustomForce As Guid
C# | public static Guid CustomForce;
C++ | public: static Guid CustomForce;
JScript | public static var CustomForce : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.Damper Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.Damper Field

Definition

Visual Basic | Public Shared Damper As Guid
C# | public static Guid Damper;
C++ | public: static Guid Damper;
JScript | public static var Damper : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.Friction Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.Friction Field

Definition

Visual Basic | Public Shared Friction As Guid
C# | public static Guid Friction;
C++ | public: static Guid Friction;
JScript | public static var Friction : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.Inertia Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.Inertia Field

Definition

Visual Basic | Public Shared Inertia As Guid
C# | public static Guid Inertia;
C++ | public: static Guid Inertia;
JScript | public static var Inertia : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.RampForce Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.RampForce Field

Definition

Visual Basic | Public Shared RampForce As Guid
C# | public static Guid RampForce;
C++ | public: static Guid RampForce;
JScript | public static var RampForce : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.SawtoothDown Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.SawtoothDown Field

Definition

Visual Basic | Public Shared SawtoothDown As Guid
C# | public static Guid SawtoothDown;
C++ | public: static Guid SawtoothDown;
JScript | public static var SawtoothDown : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.SawtoothUp Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.SawtoothUp Field

Definition

Visual Basic | Public Shared SawtoothUp As Guid
C# | public static Guid SawtoothUp;
C++ | public: static Guid SawtoothUp;
JScript | public static var SawtoothUp : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.Sine Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.Sine Field

Definition

Visual Basic | Public Shared Sine As Guid
C# | public static Guid Sine;
C++ | public: static Guid Sine;
JScript | public static var Sine : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.Spring Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.Spring Field

Definition

Visual Basic | Public Shared Spring As Guid
C# | public static Guid Spring;
C++ | public: static Guid Spring;
JScript | public static var Spring : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.Square Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.Square Field

Definition

Visual Basic | Public Shared Square As Guid
C# | public static Guid Square;
C++ | public: static Guid Square;
JScript | public static var Square : Guid

Field Value

System.Guid

This field is read-only.


ForceFeedbackGuid.Triangle Field (Microsoft.DirectX.DirectInput)

ForceFeedbackGuid.Triangle Field

Definition

Visual Basic | Public Shared Triangle As Guid
C# | public static Guid Triangle;
C++ | public: static Guid Triangle;
JScript | public static var Triangle : Guid

Field Value

System.Guid

This field is read-only.


HasEffectsException Class (Microsoft.DirectX.DirectInput)

HasEffectsException Class

The device cannot be reinitialized because effects are attached to it.

Definition

Visual Basic Public Class HasEffectsException
Inherits InputException
C# | public class HasEffectsException : InputException
C++ | public ref class HasEffectsException : InputException
JScript | public class HasEffectsException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
HasEffectsException | Initializes a new instance of the object.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
HasEffectsException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HasEffectsException.HasEffectsException Constructor ()

Initializes a new instance of the object.

Overload List

public HasEffectsException();
protected HasEffectsException(SerializationInfo, StreamingContext);
public HasEffectsException(string);
public HasEffectsException(string, Exception);


HasEffectsException.HasEffectsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

HasEffectsException.HasEffectsException Constructor

Initializes a new instance of the HasEffectsException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected HasEffectsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
HasEffectsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function HasEffectsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


HasEffectsException.HasEffectsException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

HasEffectsException.HasEffectsException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public HasEffectsException(
string message,
Exception inner
);
C++ public:
HasEffectsException(
String^ message,
Exception^ inner
);
JScript public function HasEffectsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


HasEffectsException.HasEffectsException(String) Constructor (Microsoft.DirectX.DirectInput)

HasEffectsException.HasEffectsException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public HasEffectsException(
string message
);
C++ public:
HasEffectsException(
String^ message
);
JScript public function HasEffectsException(
message : String
);

Parameters

message System.String


HasEffectsException.HasEffectsException() Constructor (Microsoft.DirectX.DirectInput)

HasEffectsException.HasEffectsException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public HasEffectsException();
C++ public:
HasEffectsException();
JScript | public function HasEffectsException();


IncompleteEffectException Class (Microsoft.DirectX.DirectInput)

IncompleteEffectException Class

The effect could not be downloaded because essential information is missing. For example, no axes have been associated with the effect, or no type-specific information has been supplied.

Definition

Visual Basic Public Class IncompleteEffectException
Inherits InputException
C# | public class IncompleteEffectException : InputException
C++ | public ref class IncompleteEffectException : InputException
JScript | public class IncompleteEffectException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
IncompleteEffectException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
IncompleteEffectException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IncompleteEffectException.IncompleteEffectException Constructor ()

Initializes a new instance of the object.

Overload List

public IncompleteEffectException();
protected IncompleteEffectException(SerializationInfo, StreamingContext);
public IncompleteEffectException(string);
public IncompleteEffectException(string, Exception);


IncompleteEffectException.IncompleteEffectException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:

Initializes a new instance of the IncompleteEffectException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected IncompleteEffectException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
IncompleteEffectException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function IncompleteEffectException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


IncompleteEffectException.IncompleteEffectException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public IncompleteEffectException(
string message,
Exception inner
);
C++ public:
IncompleteEffectException(
String^ message,
Exception^ inner
);
JScript public function IncompleteEffectException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


IncompleteEffectException.IncompleteEffectException(String) Constructor (Microsoft.DirectX.DirectInput)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public IncompleteEffectException(
string message
);
C++ public:
IncompleteEffectException(
String^ message
);
JScript public function IncompleteEffectException(
message : String
);

Parameters

message System.String


IncompleteEffectException.IncompleteEffectException() Constructor (Microsoft.DirectX.DirectInput)

IncompleteEffectException.IncompleteEffectException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public IncompleteEffectException();
C++ public:
IncompleteEffectException();
JScript | public function IncompleteEffectException();


InputException Class (Microsoft.DirectX.DirectInput)

InputException Class

Base exception type for all DirectInput exceptions. Derives from DirectXException.

Definition

Visual Basic Public Class InputException
Inherits DirectXException
C# | public class InputException : DirectXException
C++ | public ref class InputException : DirectXException
JScript | public class InputException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InputException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
AcquiredException
BadDriverVersionException
DeviceFullException
DeviceNotRegisteredException
EffectPlayingException
HasEffectsException
IncompleteEffectException
InputLostException
InsufficientPriveledgesException
MapFileFailException
MoreDataException
NotAcquiredException
NotBufferedException
NotDownloadedException
NotExclusivelyAcquiredException
NotFoundException
OtherApplicationHasPriorityException
PendingException
ReportFullException
UnpluggedException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputException.GetExceptionFromResultInternal(Int32) Method (Microsoft.DirectX.DirectInput)

InputException.GetExceptionFromResultInternal Method

Definition

Visual Basic Public Shadows Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public new static Exception GetExceptionFromResultInternal(
int resultCode
);
C++ public:
static Exception^ GetExceptionFromResultInternal(
int resultCode
);
JScript public hide static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32

Return Value

System.Exception

Applies To

AcquiredException, BadDriverVersionException, DeviceFullException, DeviceNotRegisteredException, EffectPlayingException, HasEffectsException, IncompleteEffectException, InputLostException, InsufficientPriveledgesException, MapFileFailException, MoreDataException, NotAcquiredException, NotBufferedException, NotDownloadedException, NotExclusivelyAcquiredException, NotFoundException, OtherApplicationHasPriorityException, PendingException, ReportFullException, UnpluggedException, UnsupportedException


InputException.InputException Constructor ()

Initializes a new instance of the object.

Overload List

public InputException();
protected InputException(SerializationInfo, StreamingContext);
public InputException(string);
public InputException(string, Exception);


InputException.InputException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

InputException.InputException Constructor

Initializes a new instance of the InputException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InputException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InputException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InputException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InputException.InputException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

InputException.InputException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InputException(
string message,
Exception inner
);
C++ public:
InputException(
String^ message,
Exception^ inner
);
JScript public function InputException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InputException.InputException(String) Constructor (Microsoft.DirectX.DirectInput)

InputException.InputException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InputException(
string message
);
C++ public:
InputException(
String^ message
);
JScript public function InputException(
message : String
);

Parameters

message System.String


InputException.InputException() Constructor (Microsoft.DirectX.DirectInput)

InputException.InputException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public InputException();
C++ public:
InputException();
JScript | public function InputException();


InputLostException Class (Microsoft.DirectX.DirectInput)

InputLostException Class

Access to the input device has been lost. It must be reacquired.

Definition

Visual Basic Public Class InputLostException
Inherits InputException
C# | public class InputLostException : InputException
C++ | public ref class InputLostException : InputException
JScript | public class InputLostException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InputLostException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
InputLostException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputLostException.InputLostException Constructor ()

Initializes a new instance of the object.

Overload List

public InputLostException();
protected InputLostException(SerializationInfo, StreamingContext);
public InputLostException(string);
public InputLostException(string, Exception);


InputLostException.InputLostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

InputLostException.InputLostException Constructor

Initializes a new instance of the InputLostException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InputLostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InputLostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InputLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InputLostException.InputLostException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

InputLostException.InputLostException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InputLostException(
string message,
Exception inner
);
C++ public:
InputLostException(
String^ message,
Exception^ inner
);
JScript public function InputLostException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InputLostException.InputLostException(String) Constructor (Microsoft.DirectX.DirectInput)

InputLostException.InputLostException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InputLostException(
string message
);
C++ public:
InputLostException(
String^ message
);
JScript public function InputLostException(
message : String
);

Parameters

message System.String


InputLostException.InputLostException() Constructor (Microsoft.DirectX.DirectInput)

InputLostException.InputLostException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public InputLostException();
C++ public:
InputLostException();
JScript | public function InputLostException();


InsufficientPriveledgesException Class (Microsoft.DirectX.DirectInput)

InsufficientPriveledgesException Class

Insufficient priveledges for this call.

Definition

Visual Basic Public Class InsufficientPriveledgesException
Inherits InputException
C# | public class InsufficientPriveledgesException : InputException
C++ | public ref class InsufficientPriveledgesException : InputException
JScript | public class InsufficientPriveledgesException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InsufficientPriveledgesException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
InsufficientPriveledgesException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InsufficientPriveledgesException.InsufficientPriveledgesException Constructor ()

Initializes a new instance of the object.

Overload List

public InsufficientPriveledgesException();
protected InsufficientPriveledgesException(SerializationInfo, StreamingContext);
public InsufficientPriveledgesException(string);
public InsufficientPriveledgesException(string, Exception);


InsufficientPriveledgesException.InsufficientPriveledgesException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:

Initializes a new instance of the InsufficientPriveledgesException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InsufficientPriveledgesException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InsufficientPriveledgesException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InsufficientPriveledgesException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InsufficientPriveledgesException.InsufficientPriveledgesException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InsufficientPriveledgesException(
string message,
Exception inner
);
C++ public:
InsufficientPriveledgesException(
String^ message,
Exception^ inner
);
JScript public function InsufficientPriveledgesException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InsufficientPriveledgesException.InsufficientPriveledgesException(String) Constructor (Microsoft.DirectX.DirectInput)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InsufficientPriveledgesException(
string message
);
C++ public:
InsufficientPriveledgesException(
String^ message
);
JScript public function InsufficientPriveledgesException(
message : String
);

Parameters

message System.String


InsufficientPriveledgesException.InsufficientPriveledgesException() Constructor (Microsoft.DirectX.DirectInput)

InsufficientPriveledgesException.InsufficientPriveledgesException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public InsufficientPriveledgesException();
C++ public:
InsufficientPriveledgesException();
JScript | public function InsufficientPriveledgesException();


KeyboardState Class (Microsoft.DirectX.DirectInput)

KeyboardState Class

Contains the keyboard state.

Definition

Visual Basic Public Class KeyboardState
Inherits Object
C# | public class KeyboardState : Object
C++ | public ref class KeyboardState : Object
JScript | public class KeyboardState extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property Description
Item

Inheritance Hierarchy

Object Leave Site
KeyboardState

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


KeyboardState.Item Property (Microsoft.DirectX.DirectInput)

KeyboardState.Item Property

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal index As Key _
) As Boolean
C# public bool this[
Key index
] { get; }
C++ public:
property bool default [Key] {
bool get(Key index);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index Microsoft.DirectX.DirectInput.Key

Property Value

System.Boolean

This property is read-only.


Manager Class (Microsoft.DirectX.DirectInput)

Manager Class

Applications use the methods of the Manager object to enumerate, create, and retrieve the status of Microsoft DirectInput devices.

Definition

Visual Basic Public Class Manager
Inherits MarshalByRefObject
C# | public class Manager : MarshalByRefObject
C++ | public ref class Manager : MarshalByRefObject
JScript | public class Manager extends MarshalByRefObject

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) ConfigureDevices
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
static (Shared in Visual Basic) FindDevice
static (Shared in Visual Basic) GetDeviceAttached
static (Shared in Visual Basic) GetDevices | Enumerates available devices.
static (Shared in Visual Basic) RunControlPanel | Runs Control Panel to enable the user to install a new input device or modify configurations.

Properties

Property | Description
static (Shared in Visual Basic) Devices | Enumerates available devices.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Manager

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Manager.ConfigureDevices(ConfigureDevicesParameters,ConfigureDevicesFlags) Method (Microsoft.DirectX.DirectInput)

Manager.ConfigureDevices Method

Definition

Visual Basic Public Shared Sub ConfigureDevices( _
ByVal params As ConfigureDevicesParameters, _
ByVal flags As ConfigureDevicesFlags _
)
C# public static void ConfigureDevices(
ConfigureDevicesParameters params,
ConfigureDevicesFlags flags
);
C++ public:
static void ConfigureDevices(
ConfigureDevicesParameters^ params,
ConfigureDevicesFlags flags
);
JScript public static function ConfigureDevices(
params : ConfigureDevicesParameters,
flags : ConfigureDevicesFlags
);

Parameters

params Microsoft.DirectX.DirectInput.ConfigureDevicesParameters
flags Microsoft.DirectX.DirectInput.ConfigureDevicesFlags


Manager.Finalize() Method (Microsoft.DirectX.DirectInput)

Manager.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Manager();
C++ | !Manager();
JScript | protected override function Finalize();


Manager.FindDevice(Guid,String) Method (Microsoft.DirectX.DirectInput)

Manager.FindDevice Method

Definition

Visual Basic Public Shared Function FindDevice( _
ByVal guidClass As Guid, _
ByVal name As String _
) As Guid
C# public static Guid FindDevice(
Guid guidClass,
string name
);
C++ public:
static Guid FindDevice(
Guid guidClass,
String^ name
);
JScript public static function FindDevice(
guidClass : Guid,
name : String
) : Guid;

Parameters

guidClass System.Guid
name System.String

Return Value

System.Guid


Manager.GetDeviceAttached(Guid) Method (Microsoft.DirectX.DirectInput)

Manager.GetDeviceAttached Method

Definition

Visual Basic Public Shared Function GetDeviceAttached( _
ByVal rguid As Guid _
) As Boolean
C# public static bool GetDeviceAttached(
Guid rguid
);
C++ public:
static bool GetDeviceAttached(
Guid rguid
);
JScript public static function GetDeviceAttached(
rguid : Guid
) : boolean;

Parameters

rguid System.Guid

Return Value

System.Boolean


Manager.GetDevices Method ()

Enumerates available devices.

Overload List

public static DeviceList GetDevices(ActionFormat, EnumDevicesBySemanticsFlags);
public static DeviceList GetDevices(DeviceClass, EnumDevicesFlags);
public static DeviceList GetDevices(DeviceType, EnumDevicesFlags);
public static DeviceList GetDevices(string, ActionFormat, EnumDevicesBySemanticsFlags);


Manager.GetDevices(ActionFormat,EnumDevicesBySemanticsFlags) Method (Microsoft.DirectX.DirectInput)

Manager.GetDevices Method

Enumerates available devices.

Definition

Visual Basic Public Shared Function GetDevices( _
ByVal actionFormat As ActionFormat, _
ByVal flags As EnumDevicesBySemanticsFlags _
) As DeviceList
C# public static DeviceList GetDevices(
ActionFormat actionFormat,
EnumDevicesBySemanticsFlags flags
);
C++ public:
static DeviceList^ GetDevices(
ActionFormat^ actionFormat,
EnumDevicesBySemanticsFlags flags
);
JScript public static function GetDevices(
actionFormat : ActionFormat,
flags : EnumDevicesBySemanticsFlags
) : DeviceList;

Parameters

actionFormat Microsoft.DirectX.DirectInput.ActionFormat
flags Microsoft.DirectX.DirectInput.EnumDevicesBySemanticsFlags

Return Value

Microsoft.DirectX.DirectInput.DeviceList


Manager.GetDevices(String,ActionFormat,EnumDevicesBySemanticsFlags) Method (Microsoft.DirectX.DirectInput)

Manager.GetDevices Method

Enumerates available devices.

Definition

Visual Basic Public Shared Function GetDevices( _
ByVal name As String, _
ByVal actionFormat As ActionFormat, _
ByVal flags As EnumDevicesBySemanticsFlags _
) As DeviceList
C# public static DeviceList GetDevices(
string name,
ActionFormat actionFormat,
EnumDevicesBySemanticsFlags flags
);
C++ public:
static DeviceList^ GetDevices(
String^ name,
ActionFormat^ actionFormat,
EnumDevicesBySemanticsFlags flags
);
JScript public static function GetDevices(
name : String,
actionFormat : ActionFormat,
flags : EnumDevicesBySemanticsFlags
) : DeviceList;

Parameters

name System.String
actionFormat Microsoft.DirectX.DirectInput.ActionFormat
flags Microsoft.DirectX.DirectInput.EnumDevicesBySemanticsFlags

Return Value

Microsoft.DirectX.DirectInput.DeviceList


Manager.GetDevices(DeviceType,EnumDevicesFlags) Method (Microsoft.DirectX.DirectInput)

Manager.GetDevices Method

Enumerates available devices.

Definition

Visual Basic Public Shared Function GetDevices( _
ByVal deviceType As DeviceType, _
ByVal flags As EnumDevicesFlags _
) As DeviceList
C# public static DeviceList GetDevices(
DeviceType deviceType,
EnumDevicesFlags flags
);
C++ public:
static DeviceList^ GetDevices(
DeviceType deviceType,
EnumDevicesFlags flags
);
JScript public static function GetDevices(
deviceType : DeviceType,
flags : EnumDevicesFlags
) : DeviceList;

Parameters

deviceType Microsoft.DirectX.DirectInput.DeviceType
flags Microsoft.DirectX.DirectInput.EnumDevicesFlags

Return Value

Microsoft.DirectX.DirectInput.DeviceList


Manager.GetDevices(DeviceClass,EnumDevicesFlags) Method (Microsoft.DirectX.DirectInput)

Manager.GetDevices Method

Enumerates available devices.

Definition

Visual Basic Public Shared Function GetDevices( _
ByVal deviceType As DeviceClass, _
ByVal flags As EnumDevicesFlags _
) As DeviceList
C# public static DeviceList GetDevices(
DeviceClass deviceType,
EnumDevicesFlags flags
);
C++ public:
static DeviceList^ GetDevices(
DeviceClass deviceType,
EnumDevicesFlags flags
);
JScript public static function GetDevices(
deviceType : DeviceClass,
flags : EnumDevicesFlags
) : DeviceList;

Parameters

deviceType Microsoft.DirectX.DirectInput.DeviceClass
flags Microsoft.DirectX.DirectInput.EnumDevicesFlags

Return Value

Microsoft.DirectX.DirectInput.DeviceList


Manager.RunControlPanel Method ()

Runs Control Panel to enable the user to install a new input device or modify configurations.

Overload List

public static void RunControlPanel();
public static void RunControlPanel(Control);


Manager.RunControlPanel() Method (Microsoft.DirectX.DirectInput)

Manager.RunControlPanel Method

Runs Control Panel to enable the user to install a new input device or modify configurations.

Definition

Visual Basic | Public Shared Sub RunControlPanel()
C# | public static void RunControlPanel();
C++ public:
static void RunControlPanel();
JScript | public static function RunControlPanel();


Manager.RunControlPanel(Control) Method (Microsoft.DirectX.DirectInput)

Manager.RunControlPanel Method

Runs Control Panel to enable the user to install a new input device or modify configurations.

Definition

Visual Basic Public Shared Sub RunControlPanel( _
ByVal owner As Control _
)
C# public static void RunControlPanel(
Control owner
);
C++ public:
static void RunControlPanel(
Control^ owner
);
JScript public static function RunControlPanel(
owner : Control
);

Parameters

owner System.Windows.Forms.Control


Manager.Devices Property (Microsoft.DirectX.DirectInput)

Manager.Devices Property

Enumerates available devices.

Definition

Visual Basic | Public Shared ReadOnly Property Devices As DeviceList
C# | public static DeviceList Devices { get; }
C++ public:
static property DeviceList^ Devices {
DeviceList^ get();
}
JScript | public static function get Devices() : DeviceList

Property Value

Microsoft.DirectX.DirectInput.DeviceList

This property is read-only.


MapFileFailException Class (Microsoft.DirectX.DirectInput)

MapFileFailException Class

An error has occurred either reading the vendor-supplied action-mapping file for the device or reading or writing the user configuration mapping file for the device.

Definition

Visual Basic Public Class MapFileFailException
Inherits InputException
C# | public class MapFileFailException : InputException
C++ | public ref class MapFileFailException : InputException
JScript | public class MapFileFailException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
MapFileFailException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
MapFileFailException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MapFileFailException.MapFileFailException Constructor ()

Initializes a new instance of the object.

Overload List

public MapFileFailException();
protected MapFileFailException(SerializationInfo, StreamingContext);
public MapFileFailException(string);
public MapFileFailException(string, Exception);


MapFileFailException.MapFileFailException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

MapFileFailException.MapFileFailException Constructor

Initializes a new instance of the MapFileFailException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected MapFileFailException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
MapFileFailException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function MapFileFailException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


MapFileFailException.MapFileFailException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

MapFileFailException.MapFileFailException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public MapFileFailException(
string message,
Exception inner
);
C++ public:
MapFileFailException(
String^ message,
Exception^ inner
);
JScript public function MapFileFailException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


MapFileFailException.MapFileFailException(String) Constructor (Microsoft.DirectX.DirectInput)

MapFileFailException.MapFileFailException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public MapFileFailException(
string message
);
C++ public:
MapFileFailException(
String^ message
);
JScript public function MapFileFailException(
message : String
);

Parameters

message System.String


MapFileFailException.MapFileFailException() Constructor (Microsoft.DirectX.DirectInput)

MapFileFailException.MapFileFailException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public MapFileFailException();
C++ public:
MapFileFailException();
JScript | public function MapFileFailException();


MoreDataException Class (Microsoft.DirectX.DirectInput)

MoreDataException Class

Not all the requested information fit into the buffer.

Definition

Visual Basic Public Class MoreDataException
Inherits InputException
C# | public class MoreDataException : InputException
C++ | public ref class MoreDataException : InputException
JScript | public class MoreDataException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
MoreDataException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
MoreDataException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MoreDataException.MoreDataException Constructor ()

Initializes a new instance of the object.

Overload List

public MoreDataException();
protected MoreDataException(SerializationInfo, StreamingContext);
public MoreDataException(string);
public MoreDataException(string, Exception);


MoreDataException.MoreDataException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

MoreDataException.MoreDataException Constructor

Initializes a new instance of the MoreDataException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected MoreDataException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
MoreDataException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function MoreDataException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


MoreDataException.MoreDataException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

MoreDataException.MoreDataException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public MoreDataException(
string message,
Exception inner
);
C++ public:
MoreDataException(
String^ message,
Exception^ inner
);
JScript public function MoreDataException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


MoreDataException.MoreDataException(String) Constructor (Microsoft.DirectX.DirectInput)

MoreDataException.MoreDataException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public MoreDataException(
string message
);
C++ public:
MoreDataException(
String^ message
);
JScript public function MoreDataException(
message : String
);

Parameters

message System.String


MoreDataException.MoreDataException() Constructor (Microsoft.DirectX.DirectInput)

MoreDataException.MoreDataException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public MoreDataException();
C++ public:
MoreDataException();
JScript | public function MoreDataException();


NotAcquiredException Class (Microsoft.DirectX.DirectInput)

NotAcquiredException Class

The operation cannot be performed unless the device is acquired.

Definition

Visual Basic Public Class NotAcquiredException
Inherits InputException
C# | public class NotAcquiredException : InputException
C++ | public ref class NotAcquiredException : InputException
JScript | public class NotAcquiredException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAcquiredException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotAcquiredException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotAcquiredException.NotAcquiredException Constructor ()

Initializes a new instance of the object.

Overload List

public NotAcquiredException();
protected NotAcquiredException(SerializationInfo, StreamingContext);
public NotAcquiredException(string);
public NotAcquiredException(string, Exception);


NotAcquiredException.NotAcquiredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

NotAcquiredException.NotAcquiredException Constructor

Initializes a new instance of the NotAcquiredException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAcquiredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotAcquiredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotAcquiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotAcquiredException.NotAcquiredException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

NotAcquiredException.NotAcquiredException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAcquiredException(
string message,
Exception inner
);
C++ public:
NotAcquiredException(
String^ message,
Exception^ inner
);
JScript public function NotAcquiredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotAcquiredException.NotAcquiredException(String) Constructor (Microsoft.DirectX.DirectInput)

NotAcquiredException.NotAcquiredException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotAcquiredException(
string message
);
C++ public:
NotAcquiredException(
String^ message
);
JScript public function NotAcquiredException(
message : String
);

Parameters

message System.String


NotAcquiredException.NotAcquiredException() Constructor (Microsoft.DirectX.DirectInput)

NotAcquiredException.NotAcquiredException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public NotAcquiredException();
C++ public:
NotAcquiredException();
JScript | public function NotAcquiredException();


NotBufferedException Class (Microsoft.DirectX.DirectInput)

NotBufferedException Class

The device is not buffered. Set the BufferSize property to enable buffering.

Definition

Visual Basic Public Class NotBufferedException
Inherits InputException
C# | public class NotBufferedException : InputException
C++ | public ref class NotBufferedException : InputException
JScript | public class NotBufferedException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotBufferedException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotBufferedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotBufferedException.NotBufferedException Constructor ()

Initializes a new instance of the object.

Overload List

public NotBufferedException();
protected NotBufferedException(SerializationInfo, StreamingContext);
public NotBufferedException(string);
public NotBufferedException(string, Exception);


NotBufferedException.NotBufferedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

NotBufferedException.NotBufferedException Constructor

Initializes a new instance of the NotBufferedException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotBufferedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotBufferedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotBufferedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotBufferedException.NotBufferedException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

NotBufferedException.NotBufferedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotBufferedException(
string message,
Exception inner
);
C++ public:
NotBufferedException(
String^ message,
Exception^ inner
);
JScript public function NotBufferedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotBufferedException.NotBufferedException(String) Constructor (Microsoft.DirectX.DirectInput)

NotBufferedException.NotBufferedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotBufferedException(
string message
);
C++ public:
NotBufferedException(
String^ message
);
JScript public function NotBufferedException(
message : String
);

Parameters

message System.String


NotBufferedException.NotBufferedException() Constructor (Microsoft.DirectX.DirectInput)

NotBufferedException.NotBufferedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public NotBufferedException();
C++ public:
NotBufferedException();
JScript | public function NotBufferedException();


NotDownloadedException Class (Microsoft.DirectX.DirectInput)

NotDownloadedException Class

The effect is not downloaded.

Definition

Visual Basic Public Class NotDownloadedException
Inherits InputException
C# | public class NotDownloadedException : InputException
C++ | public ref class NotDownloadedException : InputException
JScript | public class NotDownloadedException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotDownloadedException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotDownloadedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotDownloadedException.NotDownloadedException Constructor ()

Initializes a new instance of the object.

Overload List

public NotDownloadedException();
protected NotDownloadedException(SerializationInfo, StreamingContext);
public NotDownloadedException(string);
public NotDownloadedException(string, Exception);


NotDownloadedException.NotDownloadedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

NotDownloadedException.NotDownloadedException Constructor

Initializes a new instance of the NotDownloadedException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotDownloadedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotDownloadedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotDownloadedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotDownloadedException.NotDownloadedException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

NotDownloadedException.NotDownloadedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotDownloadedException(
string message,
Exception inner
);
C++ public:
NotDownloadedException(
String^ message,
Exception^ inner
);
JScript public function NotDownloadedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotDownloadedException.NotDownloadedException(String) Constructor (Microsoft.DirectX.DirectInput)

NotDownloadedException.NotDownloadedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotDownloadedException(
string message
);
C++ public:
NotDownloadedException(
String^ message
);
JScript public function NotDownloadedException(
message : String
);

Parameters

message System.String


NotDownloadedException.NotDownloadedException() Constructor (Microsoft.DirectX.DirectInput)

NotDownloadedException.NotDownloadedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public NotDownloadedException();
C++ public:
NotDownloadedException();
JScript | public function NotDownloadedException();


NotExclusivelyAcquiredException Class (Microsoft.DirectX.DirectInput)

NotExclusivelyAcquiredException Class

The operation cannot be performed unless the device is acquired in Exclusive mode.

Definition

Visual Basic Public Class NotExclusivelyAcquiredException
Inherits InputException
C# | public class NotExclusivelyAcquiredException : InputException
C++ | public ref class NotExclusivelyAcquiredException : InputException
JScript | public class NotExclusivelyAcquiredException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotExclusivelyAcquiredException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotExclusivelyAcquiredException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor ()

Initializes a new instance of the object.

Overload List

public NotExclusivelyAcquiredException();
protected NotExclusivelyAcquiredException(SerializationInfo, StreamingContext);
public NotExclusivelyAcquiredException(string);
public NotExclusivelyAcquiredException(string, Exception);


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:

Initializes a new instance of the NotExclusivelyAcquiredException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotExclusivelyAcquiredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotExclusivelyAcquiredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotExclusivelyAcquiredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotExclusivelyAcquiredException(
string message,
Exception inner
);
C++ public:
NotExclusivelyAcquiredException(
String^ message,
Exception^ inner
);
JScript public function NotExclusivelyAcquiredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException(String) Constructor (Microsoft.DirectX.DirectInput)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotExclusivelyAcquiredException(
string message
);
C++ public:
NotExclusivelyAcquiredException(
String^ message
);
JScript public function NotExclusivelyAcquiredException(
message : String
);

Parameters

message System.String


NotExclusivelyAcquiredException.NotExclusivelyAcquiredException() Constructor (Microsoft.DirectX.DirectInput)

NotExclusivelyAcquiredException.NotExclusivelyAcquiredException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public NotExclusivelyAcquiredException();
C++ public:
NotExclusivelyAcquiredException();
JScript | public function NotExclusivelyAcquiredException();


NotFoundException Class (Microsoft.DirectX.DirectInput)

NotFoundException Class

The requested object does not exist.

Definition

Visual Basic Public Class NotFoundException
Inherits InputException
C# | public class NotFoundException : InputException
C++ | public ref class NotFoundException : InputException
JScript | public class NotFoundException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotFoundException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
NotFoundException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotFoundException.NotFoundException Constructor ()

Initializes a new instance of the object.

Overload List

public NotFoundException();
protected NotFoundException(SerializationInfo, StreamingContext);
public NotFoundException(string);
public NotFoundException(string, Exception);


NotFoundException.NotFoundException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

NotFoundException.NotFoundException Constructor

Initializes a new instance of the NotFoundException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotFoundException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotFoundException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotFoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotFoundException.NotFoundException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

NotFoundException.NotFoundException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotFoundException(
string message,
Exception inner
);
C++ public:
NotFoundException(
String^ message,
Exception^ inner
);
JScript public function NotFoundException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotFoundException.NotFoundException(String) Constructor (Microsoft.DirectX.DirectInput)

NotFoundException.NotFoundException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotFoundException(
string message
);
C++ public:
NotFoundException(
String^ message
);
JScript public function NotFoundException(
message : String
);

Parameters

message System.String


NotFoundException.NotFoundException() Constructor (Microsoft.DirectX.DirectInput)

NotFoundException.NotFoundException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public NotFoundException();
C++ public:
NotFoundException();
JScript | public function NotFoundException();


ObjectTypeGuid Class (Microsoft.DirectX.DirectInput)

ObjectTypeGuid Class

Object type guid.

Definition

Visual Basic NotInheritable MustInherit Public Class ObjectTypeGuid
Inherits Object
C# | public abstract sealed class ObjectTypeGuid : Object
C++ | public ref class ObjectTypeGuid abstract sealed : Object
JScript | public final abstract class ObjectTypeGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic) Button
static (Shared in Visual Basic) Key
static (Shared in Visual Basic) PointOfView
static (Shared in Visual Basic) RxAxis
static (Shared in Visual Basic) RyAxis
static (Shared in Visual Basic) RzAxis
static (Shared in Visual Basic) Slider
static (Shared in Visual Basic) Unknown
static (Shared in Visual Basic) XAxis
static (Shared in Visual Basic) YAxis
static (Shared in Visual Basic) ZAxis

Inheritance Hierarchy

Object Leave Site
ObjectTypeGuid

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ObjectTypeGuid.Button Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.Button Field

Definition

Visual Basic | Public Shared Button As Guid
C# | public static Guid Button;
C++ | public: static Guid Button;
JScript | public static var Button : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.Key Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.Key Field

Definition

Visual Basic | Public Shared Key As Guid
C# | public static Guid Key;
C++ | public: static Guid Key;
JScript | public static var Key : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.PointOfView Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.PointOfView Field

Definition

Visual Basic | Public Shared PointOfView As Guid
C# | public static Guid PointOfView;
C++ | public: static Guid PointOfView;
JScript | public static var PointOfView : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.RxAxis Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.RxAxis Field

Definition

Visual Basic | Public Shared RxAxis As Guid
C# | public static Guid RxAxis;
C++ | public: static Guid RxAxis;
JScript | public static var RxAxis : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.RyAxis Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.RyAxis Field

Definition

Visual Basic | Public Shared RyAxis As Guid
C# | public static Guid RyAxis;
C++ | public: static Guid RyAxis;
JScript | public static var RyAxis : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.RzAxis Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.RzAxis Field

Definition

Visual Basic | Public Shared RzAxis As Guid
C# | public static Guid RzAxis;
C++ | public: static Guid RzAxis;
JScript | public static var RzAxis : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.Slider Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.Slider Field

Definition

Visual Basic | Public Shared Slider As Guid
C# | public static Guid Slider;
C++ | public: static Guid Slider;
JScript | public static var Slider : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.Unknown Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.Unknown Field

Definition

Visual Basic | Public Shared Unknown As Guid
C# | public static Guid Unknown;
C++ | public: static Guid Unknown;
JScript | public static var Unknown : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.XAxis Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.XAxis Field

Definition

Visual Basic | Public Shared XAxis As Guid
C# | public static Guid XAxis;
C++ | public: static Guid XAxis;
JScript | public static var XAxis : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.YAxis Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.YAxis Field

Definition

Visual Basic | Public Shared YAxis As Guid
C# | public static Guid YAxis;
C++ | public: static Guid YAxis;
JScript | public static var YAxis : Guid

Field Value

System.Guid

This field is read-only.


ObjectTypeGuid.ZAxis Field (Microsoft.DirectX.DirectInput)

ObjectTypeGuid.ZAxis Field

Definition

Visual Basic | Public Shared ZAxis As Guid
C# | public static Guid ZAxis;
C++ | public: static Guid ZAxis;
JScript | public static var ZAxis : Guid

Field Value

System.Guid

This field is read-only.


OtherApplicationHasPriorityException Class (Microsoft.DirectX.DirectInput)

OtherApplicationHasPriorityException Class

Another application has a higher priority level, preventing this call from succeeding.

Definition

Visual Basic Public Class OtherApplicationHasPriorityException
Inherits InputException
C# | public class OtherApplicationHasPriorityException : InputException
C++ | public ref class OtherApplicationHasPriorityException : InputException
JScript | public class OtherApplicationHasPriorityException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OtherApplicationHasPriorityException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
OtherApplicationHasPriorityException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor ()

Initializes a new instance of the object.

Overload List

public OtherApplicationHasPriorityException();
protected OtherApplicationHasPriorityException(SerializationInfo, StreamingContext);
public OtherApplicationHasPriorityException(string);
public OtherApplicationHasPriorityException(string, Exception);


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OtherApplicationHasPriorityException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OtherApplicationHasPriorityException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OtherApplicationHasPriorityException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OtherApplicationHasPriorityException(
string message,
Exception inner
);
C++ public:
OtherApplicationHasPriorityException(
String^ message,
Exception^ inner
);
JScript public function OtherApplicationHasPriorityException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(String) Constructor (Microsoft.DirectX.DirectInput)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OtherApplicationHasPriorityException(
string message
);
C++ public:
OtherApplicationHasPriorityException(
String^ message
);
JScript public function OtherApplicationHasPriorityException(
message : String
);

Parameters

message System.String


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException() Constructor (Microsoft.DirectX.DirectInput)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public OtherApplicationHasPriorityException();
C++ public:
OtherApplicationHasPriorityException();
JScript | public function OtherApplicationHasPriorityException();


PendingException Class (Microsoft.DirectX.DirectInput)

PendingException Class

Data is not yet available.

Definition

Visual Basic Public Class PendingException
Inherits InputException
C# | public class PendingException : InputException
C++ | public ref class PendingException : InputException
JScript | public class PendingException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PendingException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
PendingException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PendingException.PendingException Constructor ()

Initializes a new instance of the object.

Overload List

public PendingException();
protected PendingException(SerializationInfo, StreamingContext);
public PendingException(string);
public PendingException(string, Exception);


PendingException.PendingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

PendingException.PendingException Constructor

Initializes a new instance of the PendingException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PendingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PendingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PendingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


PendingException.PendingException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

PendingException.PendingException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PendingException(
string message,
Exception inner
);
C++ public:
PendingException(
String^ message,
Exception^ inner
);
JScript public function PendingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


PendingException.PendingException(String) Constructor (Microsoft.DirectX.DirectInput)

PendingException.PendingException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PendingException(
string message
);
C++ public:
PendingException(
String^ message
);
JScript public function PendingException(
message : String
);

Parameters

message System.String


PendingException.PendingException() Constructor (Microsoft.DirectX.DirectInput)

PendingException.PendingException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public PendingException();
C++ public:
PendingException();
JScript | public function PendingException();


ReportFullException Class (Microsoft.DirectX.DirectInput)

ReportFullException Class

More information was requested to be sent than can be sent to the device.

Definition

Visual Basic Public Class ReportFullException
Inherits InputException
C# | public class ReportFullException : InputException
C++ | public ref class ReportFullException : InputException
JScript | public class ReportFullException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ReportFullException | Initializes a new instance of the object.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
ReportFullException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ReportFullException.ReportFullException Constructor ()

Initializes a new instance of the object.

Overload List

public ReportFullException();
protected ReportFullException(SerializationInfo, StreamingContext);
public ReportFullException(string);
public ReportFullException(string, Exception);


ReportFullException.ReportFullException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

ReportFullException.ReportFullException Constructor

Initializes a new instance of the ReportFullException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ReportFullException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ReportFullException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ReportFullException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ReportFullException.ReportFullException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

ReportFullException.ReportFullException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ReportFullException(
string message,
Exception inner
);
C++ public:
ReportFullException(
String^ message,
Exception^ inner
);
JScript public function ReportFullException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ReportFullException.ReportFullException(String) Constructor (Microsoft.DirectX.DirectInput)

ReportFullException.ReportFullException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ReportFullException(
string message
);
C++ public:
ReportFullException(
String^ message
);
JScript public function ReportFullException(
message : String
);

Parameters

message System.String


ReportFullException.ReportFullException() Constructor (Microsoft.DirectX.DirectInput)

ReportFullException.ReportFullException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public ReportFullException();
C++ public:
ReportFullException();
JScript | public function ReportFullException();


SystemGuid Class (Microsoft.DirectX.DirectInput)

SystemGuid Class

Contains system guids for common device types.

Definition

Visual Basic NotInheritable MustInherit Public Class SystemGuid
Inherits Object
C# | public abstract sealed class SystemGuid : Object
C++ | public ref class SystemGuid abstract sealed : Object
JScript | public final abstract class SystemGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic) Keyboard
static (Shared in Visual Basic) Mouse

Inheritance Hierarchy

Object Leave Site
SystemGuid

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SystemGuid.Keyboard Field (Microsoft.DirectX.DirectInput)

SystemGuid.Keyboard Field

Definition

Visual Basic | Public Shared Keyboard As Guid
C# | public static Guid Keyboard;
C++ | public: static Guid Keyboard;
JScript | public static var Keyboard : Guid

Field Value

System.Guid

This field is read-only.


SystemGuid.Mouse Field (Microsoft.DirectX.DirectInput)

SystemGuid.Mouse Field

Definition

Visual Basic | Public Shared Mouse As Guid
C# | public static Guid Mouse;
C++ | public: static Guid Mouse;
JScript | public static var Mouse : Guid

Field Value

System.Guid

This field is read-only.


UnpluggedException Class (Microsoft.DirectX.DirectInput)

UnpluggedException Class

The operation could not be completed because the device is not plugged in.

Definition

Visual Basic Public Class UnpluggedException
Inherits InputException
C# | public class UnpluggedException : InputException
C++ | public ref class UnpluggedException : InputException
JScript | public class UnpluggedException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnpluggedException | Initializes a new instance of the object.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
UnpluggedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnpluggedException.UnpluggedException Constructor ()

Initializes a new instance of the object.

Overload List

public UnpluggedException();
protected UnpluggedException(SerializationInfo, StreamingContext);
public UnpluggedException(string);
public UnpluggedException(string, Exception);


UnpluggedException.UnpluggedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

UnpluggedException.UnpluggedException Constructor

Initializes a new instance of the UnpluggedException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnpluggedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnpluggedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnpluggedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UnpluggedException.UnpluggedException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

UnpluggedException.UnpluggedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnpluggedException(
string message,
Exception inner
);
C++ public:
UnpluggedException(
String^ message,
Exception^ inner
);
JScript public function UnpluggedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UnpluggedException.UnpluggedException(String) Constructor (Microsoft.DirectX.DirectInput)

UnpluggedException.UnpluggedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnpluggedException(
string message
);
C++ public:
UnpluggedException(
String^ message
);
JScript public function UnpluggedException(
message : String
);

Parameters

message System.String


UnpluggedException.UnpluggedException() Constructor (Microsoft.DirectX.DirectInput)

UnpluggedException.UnpluggedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public UnpluggedException();
C++ public:
UnpluggedException();
JScript | public function UnpluggedException();


UnsupportedException Class (Microsoft.DirectX.DirectInput)

UnsupportedException Class

The function called is not supported at this time.

Definition

Visual Basic Public Class UnsupportedException
Inherits InputException
C# | public class UnsupportedException : InputException
C++ | public ref class UnsupportedException : InputException
JScript | public class UnsupportedException extends InputException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Inherited from InputException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedException | Initializes a new instance of the object.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
InputException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedException.UnsupportedException Constructor ()

Initializes a new instance of the object.

Overload List

public UnsupportedException();
protected UnsupportedException(SerializationInfo, StreamingContext);
public UnsupportedException(string);
public UnsupportedException(string, Exception);


UnsupportedException.UnsupportedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectInput)

UnsupportedException.UnsupportedException Constructor

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UnsupportedException.UnsupportedException(String,Exception) Constructor (Microsoft.DirectX.DirectInput)

UnsupportedException.UnsupportedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedException(
string message,
Exception inner
);
C++ public:
UnsupportedException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UnsupportedException.UnsupportedException(String) Constructor (Microsoft.DirectX.DirectInput)

UnsupportedException.UnsupportedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedException(
string message
);
C++ public:
UnsupportedException(
String^ message
);
JScript public function UnsupportedException(
message : String
);

Parameters

message System.String


UnsupportedException.UnsupportedException() Constructor (Microsoft.DirectX.DirectInput)

UnsupportedException.UnsupportedException Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedException();
C++ public:
UnsupportedException();
JScript | public function UnsupportedException();


ActionAttributeFlags Enumeration (Microsoft.DirectX.DirectInput)

ActionAttributeFlags Enumeration

Flags used to request specific attributes or processing.

Definition

Visual Basic | Public Enum ActionAttributeFlags
C# | public enum ActionAttributeFlags
C++ | public enum class ActionAttributeFlags
JScript | public enum ActionAttributeFlags

Members

Member | Value | Description
NoAttribute | 0
AppFixed | 16
NoRange | 8
AppNoMap | 4
AppMapped | 2
ForceFeedback | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ActionMapControl Enumeration (Microsoft.DirectX.DirectInput)

ActionMapControl Enumeration

Flags to control the mapping.

Definition

Visual Basic | Public Enum ActionMapControl
C# | public enum ActionMapControl
C++ | public enum class ActionMapControl
JScript | public enum ActionMapControl

Members

Member | Value | Description
Initialize | 2
HardwareDefaults | 4
Preserve | 1
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ActionMechanism Enumeration (Microsoft.DirectX.DirectInput)

ActionMechanism Enumeration

Mapping mechanism used by DirectInput to configure the action.

Definition

Visual Basic | Public Enum ActionMechanism
C# | public enum ActionMechanism
C++ | public enum class ActionMechanism
JScript | public enum ActionMechanism

Members

Member | Value | Description
Error | -2147483648
HardwareDefault | 8
HardwareApp | 4
AppRequested | 2
UserConfig | 1
Unmapped | 0
Default | 32

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Any Enumeration (Microsoft.DirectX.DirectInput)

Any Enumeration

The following constants are used in the dwSemantic member of the Diaction structure to map an action to any matching control on the device.

Definition

Visual Basic | Public Enum Any
C# | public enum Any
C++ | public enum class Any
JScript | public enum Any

Members

Member | Value | Description
PointOfView3 | -16759293
PointOfView2 | -16759294
PointOfView1 | -16759295
PointOfView4 | -16759292
Axis4 | -16760316
Axis3 | -16760317 | Any axis
Axis2 | -16760318 | Any axis
Axis1 | -16760319 | Any axis
AxisS2 | -16432638 | Any s-axis
AxisS1 | -16432639 | Any s-axis
AxisC2 | -16465406 | Any clutch
AxisC1 | -16465407 | Any clutch
AxisB2 | -16498174 | Any brake
AxisB1 | -16498175 | Any brake
AxisA2 | -16530942 | Any axis
AxisA1 | -16530943 | Any accelerator
AxisV2 | -16563710 | Any v-axis
AxisV1 | -16563711 | Any v-axis
AxisU2 | -16596478 | Any u-axis
AxisU1 | -16596479 | Any u-axis
AxisR2 | -16629246 | Any r-axis
AxisR1 | -16629247 | Any r-axis
AxisZ2 | -16662014 | Any z-axis
AxisZ1 | -16662015 | Any z-axis
AxisY2 | -16694782 | Any axis
AxisY1 | -16694783 | Any axis
AxisX2 | -16727550 | Any x-axis
AxisX1 | -16727551 | Any x-axis

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ApplyActionMap Enumeration (Microsoft.DirectX.DirectInput)

ApplyActionMap Enumeration

Value that specifies how the action map is applied.

Definition

Visual Basic | Public Enum ApplyActionMap
C# | public enum ApplyActionMap
C++ | public enum class ApplyActionMap
JScript | public enum ApplyActionMap

Members

Member | Value | Description
ForceSave | 2
NoUser | 1
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ArcadePlatform Enumeration (Microsoft.DirectX.DirectInput)

ArcadePlatform Enumeration

The genre contains controls for an arcade-style game.

Definition

Visual Basic | Public Enum ArcadePlatform
C# | public enum ArcadePlatform
C++ | public enum class ArcadePlatform
JScript | public enum ArcadePlatform

Members

Member | Value | Description
ButtonPause | 570443004
ButtonDevice | 570443006
ButtonViewRightLink | 570934508
ButtonViewLeftLink | 570934500
ButtonViewDownLink | 570934504
ButtonViewUpLink | 570934496
ButtonBackLink | 570508520
ButtonForwardLink | 570508512
ButtonRightLink | 570475756
ButtonLeftLink | 570475748
ButtonFireSecondary | 570442758
HatSwitchView | 570443265
ButtonMenu | 570426621
ButtonSelect | 570426373
ButtonSpecial | 570426372
ButtonCrouch | 570426371
ButtonFire | 570426370
ButtonJump | 570426369
AxisMove | 570491394
AxisLateral | 570458625
ArcadePlatform | 570425344

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ArcadeSideToSide Enumeration (Microsoft.DirectX.DirectInput)

ArcadeSideToSide Enumeration

The genre contains controls for an arcade-style game.

Definition

Visual Basic | Public Enum ArcadeSideToSide
C# | public enum ArcadeSideToSide
C++ | public enum class ArcadeSideToSide
JScript | public enum ArcadeSideToSide

Members

Member | Value | Description
ButtonPause | 553665788
ButtonDevice | 553665790
ButtonViewRightLink | 554157292
ButtonViewLeftLink | 554157284
ButtonViewDownLink | 554157288
ButtonViewUpLink | 554157280
ButtonBackLink | 553731304
ButtonForwardLink | 553731296
ButtonRightLink | 553698540
ButtonLeftLink | 553698532
HatSwitchView | 553666049
ButtonMenu | 553649405
ButtonSelect | 553649157
ButtonSpecial | 553649156
ButtonAttack | 553649155
ButtonCarry | 553649154
ButtonThrow | 553649153
AxisMove | 553714178
AxisLateral | 553681409
ArcadeSideToSide | 553648128

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AxesDataFormat Enumeration (Microsoft.DirectX.DirectInput)

AxesDataFormat Enumeration

Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.

Definition

Visual Basic | Public Enum AxesDataFormat
C# | public enum AxesDataFormat
C++ | public enum class AxesDataFormat
JScript | public enum AxesDataFormat

Members

Member | Value | Description
Axis | 3
RelativeAxis | 1
AbsoluteAxis | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BrowserControl Enumeration (Microsoft.DirectX.DirectInput)

BrowserControl Enumeration

The genre contains controls for browser control.

Definition

Visual Basic | Public Enum BrowserControl
C# | public enum BrowserControl
C++ | public enum class BrowserControl
JScript | public enum BrowserControl

Members

Member | Value | Description
ButtonPause | 671106300
ButtonDevice | 671106302
ButtonMenu | 671089917
ButtonSelect | 671089665
AxisMove | 671154690
AxisLateral | 671121921
ButtonPrint | 671106058
ButtonHistory | 671106057
ButtonPrevious | 671106056
ButtonNext | 671106055
ButtonFavorites | 671106054
ButtonHome | 671106053
ButtonStop | 671106052
ButtonSearch | 671106051
ButtonRefresh | 671089666
AxisView | 671187459
BrowserControl | 671088640

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Button Enumeration (Microsoft.DirectX.DirectInput)

Button Enumeration

A button.

Definition

Visual Basic | Public Enum Button
C# | public enum Button
C++ | public enum class Button
JScript | public enum Button

Members

Member | Value | Description
NoTrigger | -1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Cad2DControl Enumeration (Microsoft.DirectX.DirectInput)

Cad2DControl Enumeration

The genre contains controls for a 2D CAD control

Definition

Visual Basic | Public Enum Cad2DControl
C# | public enum Cad2DControl
C++ | public enum class Cad2DControl
JScript | public enum Cad2DControl

Members

Member | Value | Description
ButtonPause | 587220220
ButtonDevice | 587220222
ButtonDisplay | 587219973
AxisRotateZ | 587350532
HatSwitch | 587220481
ButtonMenu | 587203837
ButtonSpecial2 | 587203588
ButtonSpecial | 587203587
ButtonSpecial1 | 587203586
ButtonSelect | 587203585
AxisInOut | 587301379
AxisMove | 587268610
AxisLateral | 587235841
Cad2DControl | 587202560

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Cad3DControl Enumeration (Microsoft.DirectX.DirectInput)

Cad3DControl Enumeration

The genre contains controls for a 3-D CAD control

Definition

Visual Basic | Public Enum Cad3DControl
C# | public enum Cad3DControl
C++ | public enum class Cad3DControl
JScript | public enum Cad3DControl

Members

Member | Value | Description
ButtonPause | 603997436
ButtonDevice | 603997438
ButtonDisplay | 603997189
AxisRotateZ | 604127750
AxisRotateY | 604160517
AxisRotateX | 604193284
HatSwitch | 603997697
ButtonMenu | 603981053
ButtonSpecial2 | 603980804
ButtonSpecial | 603980803
ButtonSpecial1 | 603980802
ButtonSelect | 603980801
AxisInOut | 604078595
AxisMove | 604045826
AxisLateral | 604013057
Cad3DControl | 603979776

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CadFlyBy Enumeration (Microsoft.DirectX.DirectInput)

CadFlyBy Enumeration

The genre contains controls for a CAD Fly By.

Definition

Visual Basic | Public Enum CadFlyBy
C# | public enum CadFlyBy
C++ | public enum class CadFlyBy
JScript | public enum CadFlyBy

Members

Member | Value | Description
ButtonPause | 620774652
ButtonDevice | 620774654
ButtonDisplay | 620774405
AxisRotateZ | 620904966
AxisRotateY | 620937733
AxisRotateX | 620970500
HatSwitch | 620774913
ButtonMenu | 620758269
ButtonSpecial2 | 620758020
ButtonSpecial | 620758019
ButtonSpecial1 | 620758018
ButtonSelect | 620758017
AxisInOut | 620855811
AxisMove | 620823042
AxisLateral | 620790273
CadFlyBy | 620756992

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CadModel Enumeration (Microsoft.DirectX.DirectInput)

CadModel Enumeration

The genre contains controls for a CAD model.

Definition

Visual Basic | Public Enum CadModel
C# | public enum CadModel
C++ | public enum class CadModel
JScript | public enum CadModel

Members

Member | Value | Description
ButtonPause | 637551868
ButtonDevice | 637551870
ButtonDisplay | 637551621
AxisRotateZ | 637682182
AxisRotateY | 637714949
AxisRotateX | 637747716
HatSwitch | 637552129
ButtonMenu | 637535485
ButtonSpecial2 | 637535236
ButtonSpecial | 637535235
ButtonSpecial1 | 637535234
ButtonSelect | 637535233
AxisInOut | 637633027
AxisMove | 637600258
AxisLateral | 637567489
CadModel | 637534208

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConfigureDevicesFlags Enumeration (Microsoft.DirectX.DirectInput)

ConfigureDevicesFlags Enumeration

Flags for configuring devices.

Definition

Visual Basic | Public Enum ConfigureDevicesFlags
C# | public enum ConfigureDevicesFlags
C++ | public enum class ConfigureDevicesFlags
JScript | public enum ConfigureDevicesFlags

Members

Member | Value | Description
Edit | 1
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CooperativeLevelFlags Enumeration (Microsoft.DirectX.DirectInput)

CooperativeLevelFlags Enumeration

The cooperative level determines how this instance of the device interacts with other instances of the device and the rest of the system.

Definition

Visual Basic | Public Enum CooperativeLevelFlags
C# | public enum CooperativeLevelFlags
C++ | public enum class CooperativeLevelFlags
JScript | public enum CooperativeLevelFlags

Members

Member | Value | Description
NoWindowsKey | 16
Background | 8
Foreground | 4
NonExclusive | 2
Exclusive | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DataFormatFlags Enumeration (Microsoft.DirectX.DirectInput)

DataFormatFlags Enumeration

Data format flags.

Definition

Visual Basic | Public Enum DataFormatFlags
C# | public enum DataFormatFlags
C++ | public enum class DataFormatFlags
JScript | public enum DataFormatFlags

Members

Member | Value | Description
RelativeAxis | 2
AbsoluteAxis | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceClass Enumeration (Microsoft.DirectX.DirectInput)

DeviceClass Enumeration

Used when enumerating a class of devices.

Definition

Visual Basic | Public Enum DeviceClass
C# | public enum DeviceClass
C++ | public enum class DeviceClass
JScript | public enum DeviceClass

Members

Member | Value | Description
Pointer | 2 | All devices of type DI8DEVTYPE_MOUSE and DI8DEVTYPE_SCREENPOINTER.
Keyboard | 3 | All keyboards. Equivalent to DI8DEVTYPE_KEYBOARD.
GameControl | 4 | All game controllers.
Other | 1
All | 0 | All devices.

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceData Enumeration (Microsoft.DirectX.DirectInput)

DeviceData Enumeration

Contains buffered device information. This structure is used with the Inputdevice9Getdevicedata and the Inputdevice9Senddevicedata methods.

Definition

Visual Basic | Public Enum DeviceData
C# | public enum DeviceData
C++ | public enum class DeviceData
JScript | public enum DeviceData

Members

Member | Value | Description
Continue | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceDataFormat Enumeration (Microsoft.DirectX.DirectInput)

DeviceDataFormat Enumeration

Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.

Definition

Visual Basic | Public Enum DeviceDataFormat
C# | public enum DeviceDataFormat
C++ | public enum class DeviceDataFormat
JScript | public enum DeviceDataFormat

Members

Member | Value | Description
Mouse | 1
Keyboard | 0
Joystick | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceObjectTypeFlags Enumeration (Microsoft.DirectX.DirectInput)

DeviceObjectTypeFlags Enumeration

Definition

Visual Basic | Public Enum DeviceObjectTypeFlags
C# | public enum DeviceObjectTypeFlags
C++ | public enum class DeviceObjectTypeFlags
JScript | public enum DeviceObjectTypeFlags

Members

Member | Value | Description
Button | 12
NoCollection | 16776960
Alias | 134217728 | Flags describing other attributes of the data format. This value can be one of the following:
VendorDefined | 67108864
Output | 268435456
ForceFeedbackEffectTrigger | 33554432
ForceFeedbackActuator | 16777216
InstanceMask | 16776960
AnyInstance | 16776960
NoData | 128
Collection | 64
Pov | 16
ToggleButton | 8
PushButton | 4
Axis | 3
AbsoluteAxis | 2
RelativeAxis | 1
All | 0 | Flags describing other attributes of the data format. This value can be one of the following:

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceType Enumeration (Microsoft.DirectX.DirectInput)

DeviceType Enumeration

Definition

Visual Basic | Public Enum DeviceType
C# | public enum DeviceType
C++ | public enum class DeviceType
JScript | public enum DeviceType

Members

Member | Value | Description
Keyboard | 19
Mouse | 18
Supplemental | 28
Remote | 27
ScreenPointer | 26
DeviceControl | 25
FirstPerson | 24
Flight | 23
Driving | 22
Gamepad | 21
Joystick | 20
Device | 17 | All devices that do not fall into another class.
LimitedGameSubtype | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeControl Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeControl Enumeration

Definition

Visual Basic | Public Enum DeviceTypeControl
C# | public enum DeviceTypeControl
C++ | public enum class DeviceTypeControl
JScript | public enum DeviceTypeControl

Members

Member | Value | Description
CommsSelectionHardwired | 4
CommsSelection | 3
Unknown | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeDriving Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeDriving Enumeration

Definition

Visual Basic | Public Enum DeviceTypeDriving
C# | public enum DeviceTypeDriving
C++ | public enum class DeviceTypeDriving
JScript | public enum DeviceTypeDriving

Members

Member | Value | Description
HandHeld | 5
ThreePedals | 4
DualPedals | 3
CombinedPedals | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeFirstPerson Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeFirstPerson Enumeration

Definition

Visual Basic | Public Enum DeviceTypeFirstPerson
C# | public enum DeviceTypeFirstPerson
C++ | public enum class DeviceTypeFirstPerson
JScript | public enum DeviceTypeFirstPerson

Members

Member | Value | Description
Shooter | 4
SixDegreesOfFreedom | 3
Unknown | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeFlight Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeFlight Enumeration

Definition

Visual Basic | Public Enum DeviceTypeFlight
C# | public enum DeviceTypeFlight
C++ | public enum class DeviceTypeFlight
JScript | public enum DeviceTypeFlight

Members

Member | Value | Description
RemoteControl | 4
Yoke | 3
Stick | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeGamePad Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeGamePad Enumeration

Definition

Visual Basic | Public Enum DeviceTypeGamePad
C# | public enum DeviceTypeGamePad
C++ | public enum class DeviceTypeGamePad
JScript | public enum DeviceTypeGamePad

Members

Member | Value | Description
Tilt | 3
Standard | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeJoystick Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeJoystick Enumeration

Definition

Visual Basic | Public Enum DeviceTypeJoystick
C# | public enum DeviceTypeJoystick
C++ | public enum class DeviceTypeJoystick
JScript | public enum DeviceTypeJoystick

Members

Member | Value | Description
Standard | 2
Limited | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeKeyboard Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeKeyboard Enumeration

All keyboards. Equivalent to DI8DEVTYPE_KEYBOARD.

Definition

Visual Basic | Public Enum DeviceTypeKeyboard
C# | public enum DeviceTypeKeyboard
C++ | public enum class DeviceTypeKeyboard
JScript | public enum DeviceTypeKeyboard

Members

Member | Value | Description
J3100 | 12
JapanAX | 11
Japan106 | 10
Nec98106 | 9
Nec98Laptop | 8
Nec98 | 7
Nokia9140 | 6
Nokia1050 | 5
PcEnh | 4
PcAt | 3
Olivetti | 2
PcXt | 1
Unknown | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeMouse Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeMouse Enumeration

Definition

Visual Basic | Public Enum DeviceTypeMouse
C# | public enum DeviceTypeMouse
C++ | public enum class DeviceTypeMouse
JScript | public enum DeviceTypeMouse

Members

Member | Value | Description
Absolute | 6
Trackball | 5
Touchpad | 4
Fingerstick | 3
Traditional | 2
Unknown | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeRemote Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeRemote Enumeration

Definition

Visual Basic | Public Enum DeviceTypeRemote
C# | public enum DeviceTypeRemote
C++ | public enum class DeviceTypeRemote
JScript | public enum DeviceTypeRemote

Members

Member | Value | Description
Unknown | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeScreenPtr Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeScreenPtr Enumeration

Definition

Visual Basic | Public Enum DeviceTypeScreenPtr
C# | public enum DeviceTypeScreenPtr
C++ | public enum class DeviceTypeScreenPtr
JScript | public enum DeviceTypeScreenPtr

Members

Member | Value | Description
Touch | 5
LightPen | 4
LightGun | 3
Unknown | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceTypeSupplemental Enumeration (Microsoft.DirectX.DirectInput)

DeviceTypeSupplemental Enumeration

Definition

Visual Basic | Public Enum DeviceTypeSupplemental
C# | public enum DeviceTypeSupplemental
C++ | public enum class DeviceTypeSupplemental
JScript | public enum DeviceTypeSupplemental

Members

Member | Value | Description
RudderPedals | 13
ThreePedals | 12
DualPedals | 11
CombinedPedals | 10
SplitThrottle | 9
Throttle | 8
Shifter | 7
ShiftStickGate | 6
HandTracker | 5
HeadTracker | 4
SecondHandController | 3
Unknown | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DI Enumeration (Microsoft.DirectX.DirectInput)

DI Enumeration

Definition

Visual Basic | Public Enum DI
C# | public enum DI
C++ | public enum class DI
JScript | public enum DI

Members

Member | Value | Description
Infinite | -1
Seconds | 1000000
NominalMax | 10000
Degrees | 100

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrivingCombat Enumeration (Microsoft.DirectX.DirectInput)

DrivingCombat Enumeration

Definition

Visual Basic | Public Enum DrivingCombat
C# | public enum DrivingCombat
C++ | public enum class DrivingCombat
JScript | public enum DrivingCombat

Members

Member | Value | Description
ButtonPause | 33572092
ButtonDevice | 33572094
ButtonGlanceRightLink | 34063596
ButtonGlanceLeftLink | 34063588
ButtonSteerRightLink | 33606892
ButtonSteerLeftLink | 33606884
ButtonAccelerateLink | 33805536
ButtonFireSecondary | 33573897
ButtonBrake | 33573896
ButtonAids | 33571847
ButtonDashboard | 33571846
ButtonShiftDown | 33573893
ButtonShiftUp | 33573892
HatSwitchGlance | 33572353
AxisAccelAndBrake | 33638916
ButtonMenu | 33555709
ButtonTarget | 33557507
ButtonWeapons | 33557506
ButtonFire | 33557505
AxisBrake | 33821187
AxisAccelerate | 33788418
AxisSteer | 33589761
Combat | 33554432

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrivingMecha Enumeration (Microsoft.DirectX.DirectInput)

DrivingMecha Enumeration

Definition

Visual Basic | Public Enum DrivingMecha
C# | public enum DrivingMecha
C++ | public enum class DrivingMecha
JScript | public enum DrivingMecha

Members

Member | Value | Description
ButtonPause | 687883516
ButtonDevice | 687883518
ButtonSlowerLink | 688112872
ButtonFasterLink | 688112864
ButtonRotateRightLink | 688014572
ButtonRotateLeftLink | 688014564
ButtonBackLink | 687949032
ButtonForwardLink | 687949024
ButtonRightLink | 687916268
ButtonLeftLink | 687916260
ButtonFireSecondary | 687883273
ButtonView | 687883272
HatSwitchGlance | 687883777
ButtonMenu | 687867133
ButtonJump | 687866886
ButtonZoom | 687866885
ButtonTarget | 687866883
ButtonWeapons | 687866882
ButtonFire | 687866881
AxisThrottle | 688095748
AxisRotate | 687997443
AxisSteer | 687899137
ButtonCenter | 687883271
ButtonReverse | 687866884
AxisTorso | 687931906
DrivingMecha | 687865856

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrivingRace Enumeration (Microsoft.DirectX.DirectInput)

DrivingRace Enumeration

Definition

Visual Basic | Public Enum DrivingRace
C# | public enum DrivingRace
C++ | public enum class DrivingRace
JScript | public enum DrivingRace

Members

Member | Value | Description
ButtonPause | 16794876
ButtonDevice | 16794878
ButtonGlanceRightLink | 17286380
ButtonGlanceLeftLink | 17286372
ButtonSteerRightLink | 16829676
ButtonSteerLeftLink | 16829668
ButtonAccelerateLink | 17028320
ButtonPit | 16794633
ButtonBoost | 16794632
ButtonMap | 16794631
ButtonAids | 16794630
ButtonDashboard | 16794629
ButtonBrake | 16796676
HatSwitchGlance | 16795137
AxisAccelAndBrake | 16861700
ButtonMenu | 16778493
ButtonView | 16784387
ButtonShiftDown | 16780290
ButtonShiftUp | 16780289
AxisBrake | 17043971
AxisAccelerate | 17011202
AxisSteer | 16812545
Race | 16777216

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DrivingTank Enumeration (Microsoft.DirectX.DirectInput)

DrivingTank Enumeration

Definition

Visual Basic | Public Enum DrivingTank
C# | public enum DrivingTank
C++ | public enum class DrivingTank
JScript | public enum DrivingTank

Members

Member | Value | Description
ButtonPause | 50349308
ButtonDevice | 50349310
ButtonGlanceRightLink | 50840812
ButtonGlanceLeftLink | 50840804
ButtonRotateRightLink | 50480364
ButtonRotateLeftLink | 50480356
ButtonBarrelDownLink | 50414824
ButtonBarrelUpLink | 50414816
ButtonSteerRightLink | 50384108
ButtonSteerLeftLink | 50384100
ButtonAccelerateLink | 50582752
ButtonFireSecondary | 50351111
ButtonBrake | 50351110
ButtonDashboard | 50355205
ButtonView | 50355204
AxisAccelAndBrake | 50416134
AxisBrake | 50614789
HatSwitchGlance | 50349569
ButtonMenu | 50332925
ButtonTarget | 50334723
ButtonWeapons | 50334722
ButtonFire | 50334721
AxisRotate | 50463236
AxisAccelerate | 50565635
AxisBarrel | 50397698
AxisSteer | 50366977
Tank | 50331648

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectFlags Enumeration (Microsoft.DirectX.DirectInput)

EffectFlags Enumeration

Definition

Visual Basic | Public Enum EffectFlags
C# | public enum EffectFlags
C++ | public enum class EffectFlags
JScript | public enum EffectFlags

Members

Member | Value | Description
Spherical | 64
Polar | 32
Cartesian | 16
ObjectOffsets | 2
ObjectIds | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectParameterFlags Enumeration (Microsoft.DirectX.DirectInput)

EffectParameterFlags Enumeration

Definition

Visual Basic | Public Enum EffectParameterFlags
C# | public enum EffectParameterFlags
C++ | public enum class EffectParameterFlags
JScript | public enum EffectParameterFlags

Members

Member | Value | Description
NoDownload | -2147483648
NoRestart | 1073741824
AllParams | 1023
TypeSpecificParams | 256
Envelope | 128
Direction | 64
Axes | 32
TriggerRepeatInterval | 16
TriggerButton | 8
Gain | 4
SamplePeriod | 2
Duration | 1
Start | 536870912
StartDelay | 512

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectStartFlags Enumeration (Microsoft.DirectX.DirectInput)

EffectStartFlags Enumeration

Definition

Visual Basic | Public Enum EffectStartFlags
C# | public enum EffectStartFlags
C++ | public enum class EffectStartFlags
JScript | public enum EffectStartFlags

Members

Member | Value | Description
NoDownload | -2147483648
Solo | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectType Enumeration (Microsoft.DirectX.DirectInput)

EffectType Enumeration

Definition

Visual Basic | Public Enum EffectType
C# | public enum EffectType
C++ | public enum class EffectType
JScript | public enum EffectType

Members

Member | Value | Description
CustomForce | 5
Condition | 4 | Contains type-specific information for effects that are marked as DIEFT_CONDITION.A reference to an array of Dicondition structures for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure. The number of elements in the array must be either one, or equal to the number of axes associated with the effect.
RampForce | 2
ConstantForce | 1
StartDelay | 32768
DeadBand | 16384
PosNegSaturation | 8192
PosNegCoeffecients | 4096
Saturation | 2048 | Retrieves a value for the
ForceFeedbackFade | 1024
ForceFeedbackAttack | 512
Hardware | 255
Periodic | 3 | Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
All | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EnumBySemanticsReason Enumeration (Microsoft.DirectX.DirectInput)

EnumBySemanticsReason Enumeration

Definition

Visual Basic | Public Enum EnumBySemanticsReason
C# | public enum EnumBySemanticsReason
C++ | public enum class EnumBySemanticsReason
JScript | public enum EnumBySemanticsReason

Members

Member | Value | Description
NewDevice | 32
RecentDevice | 16
MappedPriorityTwo | 2
MappedPriorityOne | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EnumDevicesBySemanticsFlags Enumeration (Microsoft.DirectX.DirectInput)

EnumDevicesBySemanticsFlags Enumeration

Definition

Visual Basic | Public Enum EnumDevicesBySemanticsFlags
C# | public enum EnumDevicesBySemanticsFlags
C++ | public enum class EnumDevicesBySemanticsFlags
JScript | public enum EnumDevicesBySemanticsFlags

Members

Member | Value | Description
Valid | 28944
NonGamingDevices | 16384
MultiMiceKeyboards | 8192
AvailableDevices | 4096
ForceFeedback | 256
ThisUser | 16
AttachedOnly | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EnumDevicesFlags Enumeration (Microsoft.DirectX.DirectInput)

EnumDevicesFlags Enumeration

Definition

Visual Basic | Public Enum EnumDevicesFlags
C# | public enum EnumDevicesFlags
C++ | public enum class EnumDevicesFlags
JScript | public enum EnumDevicesFlags

Members

Member | Value | Description
IncludeHidden | 262144
IncludePhantoms | 131072
IncludeAliases | 65536
ForceFeeback | 256
AttachedOnly | 1
AllDevices | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FightingFps Enumeration (Microsoft.DirectX.DirectInput)

FightingFps Enumeration

Definition

Visual Basic | Public Enum FightingFps
C# | public enum FightingFps
C++ | public enum class FightingFps
JScript | public enum FightingFps

Members

Member | Value | Description
ButtonPause | 151012604
ButtonDevice | 151012606
ButtonStepRightLink | 151143660
ButtonStepLeftLink | 151143652
ButtonGlanceDownLink | 151110888
ButtonGlanceUpLink | 151110880
ButtonBackwardLink | 151078120
ButtonForwardLink | 151078112
ButtonRotateRightLink | 151045356
ButtonRotateLeftLink | 151045348
ButtonFireSecondary | 151012364
ButtonGlanceR | 151012363
ButtonGlanceL | 151012362
ButtonDodge | 151012361
AxisSideStep | 151142916
ButtonDisplay | 151012360
HatSwitchGlance | 151012865
ButtonMenu | 150996221
ButtonStrafe | 150995975
AxisLookUpDown | 151093763
ButtonJump | 150995974
ButtonCrouch | 150995973
ButtonSelect | 150995972
ButtonApply | 150995971
ButtonWeapons | 150995970
ButtonFire | 150995969
AxisMove | 151060994
AxisRotate | 151028225
FightingFps | 150994944

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FightingHandToHand Enumeration (Microsoft.DirectX.DirectInput)

FightingHandToHand Enumeration

Definition

Visual Basic | Public Enum FightingHandToHand
C# | public enum FightingHandToHand
C++ | public enum class FightingHandToHand
JScript | public enum FightingHandToHand

Members

Member | Value | Description
ButtonPause | 134235388
ButtonDevice | 134235390
ButtonBackwardLink | 134300904
ButtonForwardLink | 134300896
ButtonRightLink | 134268140
ButtonLeftLink | 134268132
ButtonDodge | 134235146
AxisRotate | 134365699
ButtonDisplay | 134235145
HatSwitchSlide | 134235649
ButtonSelect | 134235144
ButtonMenu | 134219005
ButtonSpecial2 | 134218759
ButtonSpecial1 | 134218758
ButtonJump | 134218757
ButtonCrouch | 134218756
ButtonBlock | 134218755
ButtonKick | 134218754
ButtonPunch | 134218753
AxisMove | 134283778
AxisLateral | 134251009
FightingHandToHand | 134217728

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FightingThirdPerson Enumeration (Microsoft.DirectX.DirectInput)

FightingThirdPerson Enumeration

Definition

Visual Basic | Public Enum FightingThirdPerson
C# | public enum FightingThirdPerson
C++ | public enum class FightingThirdPerson
JScript | public enum FightingThirdPerson

Members

Member | Value | Description
ButtonPause | 167789820
ButtonDevice | 167789822
ButtonGlanceRightLink | 168281324
ButtonGlanceLeftLink | 168281316
ButtonGlanceDownLink | 168281320
ButtonGlanceUpLink | 168281312
ButtonBackwardLink | 167855336
ButtonForwardLink | 167855328
ButtonTurnRightLink | 167920876
ButtonTurnLeftLink | 167920868
ButtonInventory | 167789578
ButtonDodge | 167789577
AxisStep | 167821827
ButtonStepRight | 167789576
ButtonStepLeft | 167789575
ButtonView | 167789574
HatSwitchGlance | 167790081
ButtonMenu | 167773437
ButtonJump | 167773189
ButtonUse | 167773188
ButtonSelect | 167773187
ButtonAction | 167773186
ButtonRun | 167773185
AxisMove | 167838210
AxisTurn | 167903745
FightingThirdPerson | 167772160

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FileEffectsFlags Enumeration (Microsoft.DirectX.DirectInput)

FileEffectsFlags Enumeration

Definition

Visual Basic | Public Enum FileEffectsFlags
C# | public enum FileEffectsFlags
C++ | public enum class FileEffectsFlags
JScript | public enum FileEffectsFlags

Members

Member | Value | Description
ModifyIfNeeded | 16
IncludeNonStandard | 1
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FlyingCivilian Enumeration (Microsoft.DirectX.DirectInput)

FlyingCivilian Enumeration

Definition

Visual Basic | Public Enum FlyingCivilian
C# | public enum FlyingCivilian
C++ | public enum class FlyingCivilian
JScript | public enum FlyingCivilian

Members

Member | Value | Description
ButtonPause | 67126524
ButtonDevice | 67126526
ButtonGlanceDownLink | 67618024
ButtonGlanceUpLink | 67618016
ButtonGlanceRightLink | 67618028
ButtonGlanceLeftLink | 67618020
ButtonSlowerLink | 67359976
ButtonFasterLink | 67359968
ButtonBrakeLink | 67398880
ButtonFlapsDown | 67134469
ButtonFlapsUp | 67134468
AxisFlaps | 67459590
AxisRudder | 67260933
AxisBrake | 67398148
HatSwitchGlance | 67126785
ButtonMenu | 67110141
ButtonGear | 67120131
ButtonDisplay | 67118082
ButtonView | 67118081
AxisThrottle | 67342851
AxisPitch | 67176962
AxisBank | 67144193
Civilian | 67108864

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FlyingHelicopter Enumeration (Microsoft.DirectX.DirectInput)

FlyingHelicopter Enumeration

Definition

Visual Basic | Public Enum FlyingHelicopter
C# | public enum FlyingHelicopter
C++ | public enum class FlyingHelicopter
JScript | public enum FlyingHelicopter

Members

Member | Value | Description
ButtonPause | 100680956
ButtonDevice | 100680958
ButtonGlanceDownLink | 101172456
ButtonGlanceUpLink | 101172448
ButtonGlanceRightLink | 101172460
ButtonGlanceLeftLink | 101172452
ButtonSlowerLink | 100916456
ButtonFasterLink | 100916448
ButtonFireSecondary | 100682759
ButtonGear | 100688902
ButtonView | 100688901
ButtonCounter | 100684804
AxisThrottle | 100915717
AxisTorque | 100817412
HatSwitchGlance | 100681217
ButtonMenu | 100664573
ButtonTarget | 100668419
ButtonWeapons | 100668418
ButtonFire | 100668417
AxisCollective | 100764163
AxisPitch | 100731394
AxisBank | 100698625
Helicopter | 100663296

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FlyingMilitary Enumeration (Microsoft.DirectX.DirectInput)

FlyingMilitary Enumeration

Definition

Visual Basic | Public Enum FlyingMilitary
C# | public enum FlyingMilitary
C++ | public enum class FlyingMilitary
JScript | public enum FlyingMilitary

Members

Member | Value | Description
ButtonPause | 83903740
ButtonDevice | 83903742
ButtonGlanceDownLink | 84395240
ButtonGlanceUpLink | 84395232
ButtonGlanceRightLink | 84395244
ButtonGlanceLeftLink | 84395236
ButtonSlowerLink | 84137192
ButtonFasterLink | 84137184
ButtonBrakeLink | 84174048
ButtonGear | 83911690
ButtonFireSecondary | 83905545
ButtonFlapsDown | 83907592
ButtonFlapsUp | 83907591
AxisFlaps | 84234758
ButtonDisplay | 83911686
ButtonView | 83911685
AxisBrake | 84173317
AxisRudder | 84036100
ButtonCounter | 83909636
HatSwitchGlance | 83904001
ButtonMenu | 83887357
ButtonTarget | 83889155
ButtonWeapons | 83889154
ButtonFire | 83889153
AxisThrottle | 84120067
AxisPitch | 83954178
AxisBank | 83921409
Military | 83886080

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ForceFeedbackCommand Enumeration (Microsoft.DirectX.DirectInput)

ForceFeedbackCommand Enumeration

Definition

Visual Basic | Public Enum ForceFeedbackCommand
C# | public enum ForceFeedbackCommand
C++ | public enum class ForceFeedbackCommand
JScript | public enum ForceFeedbackCommand

Members

Member | Value | Description
Reset | 1 | Sets the enumerator to its initial position, which is before the first element in the collection.
SetActuatorsOff | 32
SetActuatorsOn | 16
Continue | 8
Pause | 4 | Sends a command to the device's force-feedback system.
StopAll | 2 | Sends a command to the device's force-feedback system.

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ForceFeedbackStates Enumeration (Microsoft.DirectX.DirectInput)

ForceFeedbackStates Enumeration

Definition

Visual Basic | Public Enum ForceFeedbackStates
C# | public enum ForceFeedbackStates
C++ | public enum class ForceFeedbackStates
JScript | public enum ForceFeedbackStates

Members

Member | Value | Description
Empty | 1 | Retrieves the state of the device's force-feedback system.
DeviceLost | -2147483648
UserForceFeedbackSwitchOff | 2048
UserForceFeedbackSwitchOn | 1024
SafterSwitchOff | 512
SafetySwitchOn | 256
PowerOff | 128
PowerOn | 64 | Retrieves the state of the device's force-feedback system.
ActuatorsOff | 32
ActuatorsOn | 16
Paused | 4 | Retrieves the state of the device's force-feedback system.
Stopped | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ImageFileType Enumeration (Microsoft.DirectX.DirectInput)

ImageFileType Enumeration

Definition

Visual Basic | Public Enum ImageFileType
C# | public enum ImageFileType
C++ | public enum class ImageFileType
JScript | public enum ImageFileType

Members

Member | Value | Description
Overlay | 2
Configuration | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


JoystickOffset Enumeration (Microsoft.DirectX.DirectInput)

JoystickOffset Enumeration

Definition

Visual Basic | Public Enum JoystickOffset
C# | public enum JoystickOffset
C++ | public enum class JoystickOffset
JScript | public enum JoystickOffset

Members

Member | Value | Description
Y | 4
X | 0
Button62 | 110
Button61 | 109
Button60 | 108
Button59 | 107
Button58 | 106
Button57 | 105
Button56 | 104
Button55 | 103
Button54 | 102
Button53 | 101
Button52 | 100
Button51 | 99
Button50 | 98
Button49 | 97
Button48 | 96
Button47 | 95
Button46 | 94
Button45 | 93
Button44 | 92
Button43 | 91
Button42 | 90
Button41 | 89
Button40 | 88
Button39 | 87
Button38 | 86
Button37 | 85
Button36 | 84
Button35 | 83
Button34 | 82
Button33 | 81
Button32 | 80
Button31 | 79
Button30 | 78
Button29 | 77
Button28 | 76
Button27 | 75
Button26 | 74
Button25 | 73
Button24 | 72
Button23 | 71
Button22 | 70
Button21 | 69
Button20 | 68
Button19 | 67
Button18 | 66
Button17 | 65
Button16 | 64
Button15 | 63
Button14 | 62
Button13 | 61
Button12 | 60
Button11 | 59
Button10 | 58
Button9 | 57
Button8 | 56
Button7 | 55
Button6 | 54
Button5 | 53
Button4 | 52
Button3 | 51
Button2 | 50
Button1 | 49
Button0 | 48
PointOfView3 | 44
PointOfView2 | 40
PointOfView1 | 36
PointOfView0 | 32
Slider1 | 28 | Two additional axis values (formerly called the u-axis and v-axis) whose semantics depend on the joystick. Use the Inputdevice9Getobjectinfo method to obtain semantic information about these values.
Slider0 | 24 | Two additional axis values (formerly called the u-axis and v-axis) whose semantics depend on the joystick. Use the Inputdevice9Getobjectinfo method to obtain semantic information about these values.
RZ | 20 | Z-axis rotation (often called the rudder). If the joystick does not have this axis, the value is 0.
RY | 16 | Y-axis rotation. If the joystick does not have this axis, the value is 0.
RX | 12 | X-axis rotation. If the joystick does not have this axis, the value is 0.
Z | 8
Button128 | 176
Button127 | 175
Button126 | 174
Button125 | 173
Button124 | 172
Button123 | 171
Button122 | 170
Button121 | 169
Button120 | 168
Button119 | 167
Button118 | 166
Button117 | 165
Button116 | 164
Button115 | 163
Button114 | 162
Button113 | 161
Button112 | 160
Button111 | 159
Button110 | 158
Button109 | 157
Button108 | 156
Button107 | 155
Button106 | 154
Button105 | 153
Button104 | 152
Button103 | 151
Button102 | 150
Button101 | 149
Button100 | 148
Button99 | 147
Button98 | 146
Button97 | 145
Button96 | 144
Button95 | 143
Button94 | 142
Button93 | 141
Button92 | 140
Button91 | 139
Button90 | 138
Button89 | 137
Button88 | 136
Button87 | 135
Button86 | 134
Button85 | 133
Button84 | 132
Button83 | 131
Button82 | 130
Button81 | 129
Button80 | 128
Button79 | 127
Button78 | 126
Button77 | 125
Button76 | 124
Button75 | 123
Button74 | 122
Button73 | 121
Button72 | 120
Button71 | 119
Button70 | 118
Button69 | 117
Button68 | 116
Button67 | 115
Button66 | 114
Button65 | 113
Button64 | 112
Button63 | 111

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Key Enumeration (Microsoft.DirectX.DirectInput)

Key Enumeration

Definition

Visual Basic | Public Enum Key
C# | public enum Key
C++ | public enum class Key
JScript | public enum Key

Members

Member | Value | Description
Sleep | 223
Next | 209
Stop | 149
Convert | 121
Decimal | 83
X | 45
Y | 21
Escape | 1
Circumflex | 144
PageDown | 209
DownArrow | 208
RightArrow | 205
LeftArrow | 203
PageUp | 201
UpArrow | 200
RightAlt | 184
NumPadSlash | 181
NumPadPeriod | 83
NumPadPlus | 78
NumPadMinus | 74
CapsLock | 58
LeftAlt | 56
NumPadStar | 55
BackSpace | 14
MediaSelect | 237
Mail | 236
MyComputer | 235
WebBack | 234
WebForward | 233
WebStop | 232
WebRefresh | 231
WebFavorites | 230
WebSearch | 229
Wake | 227
Power | 222
Apps | 221
RightWindows | 220
LeftWindows | 219
Down | 208
End | 207
Prior | 201
Up | 200
Home | 199
RightMenu | 184
SysRq | 183
Divide | 181
NumPadComma | 179
WebHome | 178
VolumeUp | 176
VolumeDown | 174
MediaStop | 164
PlayPause | 162
Calculator | 161
Mute | 160
RightControl | 157
NumPadEnter | 156
NextTrack | 153
Unlabeled | 151
AX | 150
Kanji | 148
Underline | 147
Colon | 146
At | 145
PrevTrack | 144
NumPadEquals | 141
AbntC2 | 126
Yen | 125
NoConvert | 123
AbntC1 | 115
Kana | 112
F15 | 102
F14 | 101
F13 | 100
F12 | 88
F11 | 87
OEM102 | 86
NumPad0 | 82
NumPad3 | 81
NumPad2 | 80
NumPad1 | 79
NumPad6 | 77
NumPad5 | 76
NumPad4 | 75
Subtract | 74
NumPad9 | 73
NumPad8 | 72
NumPad7 | 71
Scroll | 70
Numlock | 69
F10 | 68
F9 | 67
F8 | 66
F7 | 65
F6 | 64
F5 | 63
F4 | 62
F3 | 61
F2 | 60
F1 | 59
Capital | 58
Space | 57
LeftMenu | 56
Multiply | 55
RightShift | 54
Slash | 53
Period | 52
Comma | 51
M | 50
N | 49
B | 48
V | 47
C | 46
Z | 44
BackSlash | 43
LeftShift | 42
Grave | 41
Apostrophe | 40
SemiColon | 39
L | 38
K | 37
J | 36
H | 35
G | 34
F | 33
D | 32
S | 31
A | 30
LeftControl | 29
Return | 28
RightBracket | 27
LeftBracket | 26
P | 25
O | 24
I | 23
U | 22
T | 20
R | 19
E | 18
W | 17
Tab | 15
Back | 14
Equals | 13 | Returns a value indicating whether this instance is equal to a specified object.
Minus | 12
D0 | 11
D9 | 10
D8 | 9
D7 | 8
D6 | 7
D5 | 6
D4 | 5
D3 | 4
D2 | 3
D1 | 2
Insert | 210 | Inserts an element into the collection at the specified index.
Right | 205
Left | 203
Pause | 197
Add | 78
Delete | 211
Q | 16

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Keyboard Enumeration (Microsoft.DirectX.DirectInput)

Keyboard Enumeration

The following constants are used in the dwSemantic member of the Diaction structure to map an action to a physical key.

Definition

Visual Basic | Public Enum Keyboard
C# | public enum Keyboard
C++ | public enum class Keyboard
JScript | public enum Keyboard

Members

Member | Value | Description
Sleep | -2130705185
Next | -2130705199 | PAGE DOWN
Stop | -2130705259 | On NEC PC-98 Japanese keyboard
Convert | -2130705287 | On Japanese keyboard
Decimal | -2130705325 | PERIOD (decimal point) on numeric keypad
X | -2130705363
Y | -2130705387
Escape | -2130705407
MediaSelect | -2130705171 | MEDIA SELECT key, which displays a selection of supported media players on the system
Mail | -2130705172
MyComputer | -2130705173
WebBack | -2130705174
WebForward | -2130705175
WebStop | -2130705176
WebRefresh | -2130705177
WebFavorites | -2130705178 | Displays the Microsoft Internet Explorer Favorites list, the Microsoft Windows® Favorites folder, or the Netscape Bookmarks list
WebSearch | -2130705179
Wake | -2130705181
Power | -2130705186
Apps | -2130705187 | Application key
RightWindows | -2130705188
LeftWindows | -2130705189
Down | -2130705200 | DOWN ARROW
End | -2130705201
Prior | -2130705207 | PAGE UP
Up | -2130705208 | UP ARROW
Home | -2130705209
RightMenu | -2130705224 | Right ALT
SysRq | -2130705225
Divide | -2130705227 | FORWARD SLASH (/) on numeric keypad
NumPadComma | -2130705229 | On numeric keypad of NEC PC-98 Japanese keyboard
WebHome | -2130705230
VolumeUp | -2130705232
VolumeDown | -2130705234
MediaStop | -2130705244
PlayPause | -2130705246
Calculator | -2130705247
Mute | -2130705248
RightControl | -2130705251
NumPadEnter | -2130705252
NextTrack | -2130705255 | NEXT TRACK
Unlabeled | -2130705257 | On Japanese keyboard
AX | -2130705258 | On Japanese keyboard
Kanji | -2130705260 | On Japanese keyboard
Underline | -2130705261 | On NEC PC-98 Japanese keyboard
Colon | -2130705262 | On Japanese keyboard
At | -2130705263 | On Japanese keyboard
PrevTrack | -2130705264 | PREVIOUS TRACK; CIRCUMFLEX (^) on Japanese keyboard
NumPadEquals | -2130705267
AbntC2 | -2130705282 | On numeric pad of Brazilian keyboards
Yen | -2130705283 | On Japanese keyboard
NoConvert | -2130705285 | On Japanese keyboard
AbntC1 | -2130705293 | On numeric pad of Brazilian keyboards
Kana | -2130705296 | On Japanese keyboard
F15 | -2130705306 | On NEC PC-98 Japanese keyboard
F14 | -2130705307 | On NEC PC-98 Japanese keyboard
F13 | -2130705308 | On NEC PC-98 Japanese keyboard
F12 | -2130705320
F11 | -2130705321
OEM102 | -2130705322 | On British and German keyboards
NumPad0 | -2130705326
NumPad3 | -2130705327
NumPad2 | -2130705328
NumPad1 | -2130705329
NumPad6 | -2130705331
NumPad5 | -2130705332
NumPad4 | -2130705333
Subtract | -2130705334 | MINUS SIGN (-) on numeric keypad
NumPad9 | -2130705335
NumPad8 | -2130705336
NumPad7 | -2130705337
Scroll | -2130705338 | SCROLL LOCK
Numlock | -2130705339
F10 | -2130705340
F9 | -2130705341
F8 | -2130705342
F7 | -2130705343
F6 | -2130705344
F5 | -2130705345
F4 | -2130705346
F3 | -2130705347
F2 | -2130705348
F1 | -2130705349
Capital | -2130705350 | CAPS LOCK
Space | -2130705351 | SPACEBAR
LeftMenu | -2130705352 | Left ALT
Multiply | -2130705353 | ASTERISK (*) on numeric keypad
RightShift | -2130705354 | RIGHT ARROW
Slash | -2130705355 | FORWARD SLASH (/) on main keyboard
Period | -2130705356 | On main keyboard
Comma | -2130705357
M | -2130705358
N | -2130705359
B | -2130705360
V | -2130705361
C | -2130705362
Z | -2130705364
BackSlash | -2130705365
LeftShift | -2130705366 | LEFT ARROW
Grave | -2130705367 | GRAVE ACCENT (`)
Apostrophe | -2130705368
SemiColon | -2130705369
L | -2130705370
K | -2130705371
J | -2130705372
H | -2130705373
G | -2130705374
F | -2130705375
D | -2130705376
S | -2130705377
A | -2130705378
LeftControl | -2130705379
Return | -2130705380 | ENTER on main keyboard
RightBracket | -2130705381
LeftBracket | -2130705382
P | -2130705383
O | -2130705384
I | -2130705385
U | -2130705386
T | -2130705388
R | -2130705389
E | -2130705390
W | -2130705391
Tab | -2130705393
Back | -2130705394 | BACKSPACE
Equals | -2130705395 | Returns a value indicating whether this instance is equal to a specified object.
Minus | -2130705396 | On main keyboard
D0 | -2130705397 | On main keyboard
D9 | -2130705398 | On main keyboard
D8 | -2130705399 | On main keyboard
D7 | -2130705400 | On main keyboard
D6 | -2130705401 | On main keyboard
D5 | -2130705402 | On main keyboard
D4 | -2130705403 | On main keyboard
D3 | -2130705404 | On main keyboard
D2 | -2130705405 | On main keyboard
D1 | -2130705406 | On main keyboard
Insert | -2130705198 | Inserts an element into the collection at the specified index.
Right | -2130705203 | RIGHT ARROW
Left | -2130705205 | LEFT ARROW
Pause | -2130705211
Add | -2130705330 | PLUS SIGN (+) on numeric keypad
Delete | -2130705197
Q | -2130705392

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MaxPoints Enumeration (Microsoft.DirectX.DirectInput)

MaxPoints Enumeration

Definition

Visual Basic | Public Enum MaxPoints
C# | public enum MaxPoints
C++ | public enum class MaxPoints
JScript | public enum MaxPoints

Members

Member | Value | Description
Value | 8

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Mouse Enumeration (Microsoft.DirectX.DirectInput)

Mouse Enumeration

The following constants are used in the dwSemantic member of the Diaction structure to map an action to a physical axis or button on a mouse.

Definition

Visual Basic | Public Enum Mouse
C# | public enum Mouse
C++ | public enum class Mouse
JScript | public enum Mouse

Members

Member | Value | Description
Button7 | -2113928173
Button6 | -2113928174
Button5 | -2113928175
Button4 | -2113928176
Button3 | -2113928177
Button2 | -2113928178
Button1 | -2113928179
Button0 | -2113928180
Wheel | -2113928440
YAxis | -2113928444
XAxis | -2113928448
YAxisAB | -2113928700
XAxisAB | -2113928704

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MouseOffset Enumeration (Microsoft.DirectX.DirectInput)

MouseOffset Enumeration

Mouse device constants, defined in Dinput.h, represent offsets within a mouse device's data packet, the Dimousestate or Dimousestate2 structure.

Definition

Visual Basic | Public Enum MouseOffset
C# | public enum MouseOffset
C++ | public enum class MouseOffset
JScript | public enum MouseOffset

Members

Member | Value | Description
Y | 4
X | 0
Button7 | 19 | Dimousestate2 only
Button6 | 18 | Dimousestate2 only
Button5 | 17 | Dimousestate2 only
Button4 | 16 | Dimousestate2 only
Button3 | 15
Button2 | 14
Button1 | 13
Button0 | 12
Z | 8

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ObjectInstanceFlags Enumeration (Microsoft.DirectX.DirectInput)

ObjectInstanceFlags Enumeration

Definition

Visual Basic | Public Enum ObjectInstanceFlags
C# | public enum ObjectInstanceFlags
C++ | public enum class ObjectInstanceFlags
JScript | public enum ObjectInstanceFlags

Members

Member | Value | Description
Mask | 3840 | Flags describing other attributes of the data format. This value can be one of the following:
GuidUsage | 65536
Force | 1024 | The magnitude of the maximum force that can be created by the actuator associated with this object. Force is expressed in newtons and measured in relation to where the hand would be during normal operation of the device.
Acceleration | 768
Velocity | 512
Position | 256
Polled | 32768
EffectTrigger | 2
Actuator | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ParameterHow Enumeration (Microsoft.DirectX.DirectInput)

ParameterHow Enumeration

Definition

Visual Basic | Public Enum ParameterHow
C# | public enum ParameterHow
C++ | public enum class ParameterHow
JScript | public enum ParameterHow

Members

Member | Value | Description
ByUsage | 3
ById | 2
ByOffset | 1
ByDevice | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PropertyType Enumeration (Microsoft.DirectX.DirectInput)

PropertyType Enumeration

Definition

Visual Basic | Public Enum PropertyType
C# | public enum PropertyType
C++ | public enum class PropertyType
JScript | public enum PropertyType

Members

Member | Value | Description
UserName | 25
Granularity | 3
BufferSize | 1
TypeName | 26
VendorIdentityProductId | 24
ScanCode | 23
AppData | 22
CalibrationPoints | 21
KeyName | 20
LogicalRange | 19
PhysicalRange | 18
GetPortDisplayName | 16
JoystickId | 15
ProductName | 14
InstanceName | 13
GuidAndPath | 12
Calibration | 11
CalibrationMode | 10
AutoCenter | 9
ForceFeedbackLoad | 8
ForceFeedbackGain | 7
Saturation | 6
DeadZone | 5
Range | 4
AxisMode | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PropRangeFlags Enumeration (Microsoft.DirectX.DirectInput)

PropRangeFlags Enumeration

Retrieves the range of values an object can possibly report. For some devices, this is a read-only property.

Definition

Visual Basic | Public Enum PropRangeFlags
C# | public enum PropRangeFlags
C++ | public enum class PropRangeFlags
JScript | public enum PropRangeFlags

Members

Member | Value | Description
NoMax | 2147483647
NoMin | -2147483648

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RemoteControl Enumeration (Microsoft.DirectX.DirectInput)

RemoteControl Enumeration

Definition

Visual Basic | Public Enum RemoteControl
C# | public enum RemoteControl
C++ | public enum class RemoteControl
JScript | public enum RemoteControl

Members

Member | Value | Description
ButtonPause | 654329084
ButtonDevice | 654329086
ButtonMenu | 654312701
ButtonPlay | 654320643
ButtonSelect | 654312450
RemoteControl | 654311424
ButtonDigit9 | 654332952
ButtonDigit8 | 654332951
ButtonDigit7 | 654332950
ButtonDigit6 | 654332949
ButtonDigit5 | 654332948
ButtonDigit4 | 654332947
ButtonDigit3 | 654332946
ButtonDigit2 | 654332945
ButtonDigit1 | 654332944
ButtonDigit0 | 654332943
ButtonAdjust | 654334990
ButtonDvd | 654334989
ButtonTuner | 654334988
ButtonVcr | 654334987
ButtonCD | 654334986
ButtonCable | 654334985
ButtonTV | 654334984
AxisSlider2 | 654656002
ButtonRecord | 654320647
ButtonChange | 654320646
ButtonReview | 654320645
ButtonCue | 654320644
ButtonMute | 654312449
AxisSlider | 654639617

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ReturnCode Enumeration (Microsoft.DirectX.DirectInput)

ReturnCode Enumeration

Definition

Visual Basic | Public Enum ReturnCode
C# | public enum ReturnCode
C++ | public enum class ReturnCode
JScript | public enum ReturnCode

Members

Member | Value | Description
WriteProtect | 19
TruncatedAndRestarted | 12
SettingsNotSaved | 11
Truncated | 8
EffectRestarted | 4
DownloadSkipped | 3
PolledDevice | 2
NoEffect | 1
PropNoEffect | 1
BufferOverflow | 1
NotAttached | 1
Ok | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SetActionMapReturnCodes Enumeration (Microsoft.DirectX.DirectInput)

SetActionMapReturnCodes Enumeration

Definition

Visual Basic | Public Enum SetActionMapReturnCodes
C# | public enum SetActionMapReturnCodes
C++ | public enum class SetActionMapReturnCodes
JScript | public enum SetActionMapReturnCodes

Members

Member | Value | Description
WriteProtected | 19
SettingsNotSaved | 11
Success | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SpaceSim Enumeration (Microsoft.DirectX.DirectInput)

SpaceSim Enumeration

Definition

Visual Basic | Public Enum SpaceSim
C# | public enum SpaceSim
C++ | public enum class SpaceSim
JScript | public enum SpaceSim

Members

Member | Value | Description
ButtonPause | 117458172
ButtonDevice | 117458174
ButtonGlanceDownLink | 117949672
ButtonGlanceUpLink | 117949664
ButtonGlanceRightLink | 117949676
ButtonGlanceLeftLink | 117949668
ButtonTurnRightLink | 117589228
ButtonTurnLeftLink | 117589220
ButtonSlowerLink | 117687528
ButtonFasterLink | 117687520
ButtonBackwardLink | 117523688
ButtonForwardLink | 117523680
ButtonRightLink | 117490924
ButtonLeftLink | 117490916
ButtonFireSecondary | 117457929
ButtonGear | 117457928
ButtonLower | 117457927
ButtonRaise | 117457926
ButtonDisplay | 117457925
ButtonView | 117457924
AxisRotate | 117588485
AxisClimb | 117555716
HatSwitchGlance | 117458433
ButtonMenu | 117441789
ButtonTarget | 117441539
ButtonWeapons | 117441538
ButtonFire | 117441537
AxisThrottle | 117670403
AxisMove | 117506562
AxisLateral | 117473793
SpaceSim | 117440512

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsBaseballBatting Enumeration (Microsoft.DirectX.DirectInput)

SportsBaseballBatting Enumeration

Definition

Visual Basic | Public Enum SportsBaseballBatting
C# | public enum SportsBaseballBatting
C++ | public enum class SportsBaseballBatting
JScript | public enum SportsBaseballBatting

Members

Member | Value | Description
ButtonPause | 251675900
ButtonDevice | 251675902
ButtonBackLink | 251741416
ButtonForwardLink | 251741408
ButtonRightLink | 251708652
ButtonLeftLink | 251708644
ButtonBox | 251675658
ButtonNoSteal | 251675657
ButtonMenu | 251659517
ButtonContact | 251659272
ButtonSlide | 251659271
ButtonBurst | 251659270
ButtonSteal | 251659269
ButtonBunt | 251659268
ButtonPower | 251659267
ButtonNormal | 251659266
ButtonSelect | 251659265
AxisMove | 251724290
AxisLateral | 251691521
SportsBaseballBatting | 251658240

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsBaseBallField Enumeration (Microsoft.DirectX.DirectInput)

SportsBaseBallField Enumeration

Definition

Visual Basic | Public Enum SportsBaseBallField
C# | public enum SportsBaseBallField
C++ | public enum class SportsBaseBallField
JScript | public enum SportsBaseBallField

Members

Member | Value | Description
ButtonPause | 285230332
ButtonDevice | 285230334
ButtonBackLink | 285295848
ButtonForwardLink | 285295840
ButtonAimRightLink | 285263084
ButtonAimLeftLink | 285263076
ButtonShiftOut | 285230088
ButtonShiftIn | 285230087
ButtonMenu | 285213949
ButtonDive | 285213702
ButtonJump | 285213701
ButtonBurst | 285213700
ButtonThrow2 | 285213699
ButtonThrow1 | 285213698
ButtonNearest | 285213697
AxisMove | 285278722
AxisLateral | 285245953
SportsBaseBallField | 285212672

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsBaseballPitch Enumeration (Microsoft.DirectX.DirectInput)

SportsBaseballPitch Enumeration

Definition

Visual Basic | Public Enum SportsBaseballPitch
C# | public enum SportsBaseballPitch
C++ | public enum class SportsBaseballPitch
JScript | public enum SportsBaseballPitch

Members

Member | Value | Description
ButtonBase | 268436483
ButtonPause | 268453116
ButtonDevice | 268453118
ButtonBackLink | 268518632
ButtonForwardLink | 268518624
ButtonRightLink | 268485868
ButtonLeftLink | 268485860
ButtonLook | 268452871
ButtonWalk | 268452870
ButtonMenu | 268436733
ButtonFake | 268436485
ButtonThrow | 268436484
ButtonPitch | 268436482
ButtonSelect | 268436481
AxisMove | 268501506
AxisLateral | 268468737
SportsBaseballPitch | 268435456

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsBasketballDefense Enumeration (Microsoft.DirectX.DirectInput)

SportsBasketballDefense Enumeration

Definition

Visual Basic | Public Enum SportsBasketballDefense
C# | public enum SportsBasketballDefense
C++ | public enum class SportsBasketballDefense
JScript | public enum SportsBasketballDefense

Members

Member | Value | Description
ButtonPause | 318784764
ButtonDevice | 318784766
ButtonBackLink | 318850280
ButtonForwardLink | 318850272
ButtonRightLink | 318817516
ButtonLeftLink | 318817508
ButtonSubstitute | 318784521
ButtonTimeout | 318784520
HatSwitchGlance | 318785025
ButtonMenu | 318768381
ButtonPlay | 318768135
ButtonBurst | 318768134
ButtonPlayer | 318768133
ButtonSpecial | 318768132
ButtonFake | 318768131
ButtonSteal | 318768130
ButtonJump | 318768129
AxisMove | 318833154
AxisLateral | 318800385
SportsBasketballDefense | 318767104

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsBasketballOffense Enumeration (Microsoft.DirectX.DirectInput)

SportsBasketballOffense Enumeration

Definition

Visual Basic | Public Enum SportsBasketballOffense
C# | public enum SportsBasketballOffense
C++ | public enum class SportsBasketballOffense
JScript | public enum SportsBasketballOffense

Members

Member | Value | Description
ButtonPause | 302007548
ButtonDevice | 302007550
ButtonBackLink | 302073064
ButtonForwardLink | 302073056
ButtonRightLink | 302040300
ButtonLeftLink | 302040292
ButtonSubstitute | 302007310
ButtonTimeout | 302007309
ButtonPost | 302007308
ButtonJab | 302007307
ButtonPlay | 302007306
ButtonScreen | 302007305
HatSwitchGlance | 302007809
ButtonMenu | 301991165
ButtonCall | 301990920
ButtonBurst | 301990919
ButtonPlayer | 301990918
ButtonSpecial | 301990917
ButtonFake | 301990916
ButtonPass | 301990915
ButtonDunk | 301990914
ButtonShoot | 301990913
AxisMove | 302055938
AxisLateral | 302023169
SportsBasketballOffense | 301989888

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsBikingMountain Enumeration (Microsoft.DirectX.DirectInput)

SportsBikingMountain Enumeration

Definition

Visual Basic | Public Enum SportsBikingMountain
C# | public enum SportsBikingMountain
C++ | public enum class SportsBikingMountain
JScript | public enum SportsBikingMountain

Members

Member | Value | Description
ButtonPause | 469779708
ButtonDevice | 469779710
ButtonBrakeLink | 470041832
ButtonSlowerLink | 469845224
ButtonFasterLink | 469845216
ButtonRightLink | 469812460
ButtonLeftLink | 469812452
AxisBrake | 470041091
ButtonZoom | 469779462
HatSwitchScroll | 469779969
ButtonMenu | 469763325
ButtonSpecial2 | 469763077
ButtonSelect | 469763076
ButtonSpecial1 | 469763075
ButtonCamera | 469763074
ButtonJump | 469763073
AxisPedal | 469828098
AxisTurn | 469795329
SportsBikingMountain | 469762048

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsFishing Enumeration (Microsoft.DirectX.DirectInput)

SportsFishing Enumeration

Definition

Visual Basic | Public Enum SportsFishing
C# | public enum SportsFishing
C++ | public enum class SportsFishing
JScript | public enum SportsFishing

Members

Member | Value | Description
ButtonPause | 234898684
ButtonDevice | 234898686
ButtonRotateRightLink | 235029740
ButtonRotateLeftLink | 235029732
ButtonBackLink | 234964200
ButtonForwardLink | 234964192
ButtonRightLink | 234931436
ButtonLeftLink | 234931428
ButtonJump | 234898440
ButtonCrouch | 234898439
AxisRotate | 235028995
ButtonDisplay | 234898438
HatSwitchGlance | 234898945
ButtonMenu | 234882301
ButtonMap | 234882053
ButtonBait | 234882052
ButtonBinocular | 234882051
ButtonType | 234882050
ButtonCast | 234882049
AxisMove | 234947074
AxisLateral | 234914305
SportsFishing | 234881024

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsFootballDefense Enumeration (Microsoft.DirectX.DirectInput)

SportsFootballDefense Enumeration

Definition

Visual Basic | Public Enum SportsFootballDefense
C# | public enum SportsFootballDefense
C++ | public enum class SportsFootballDefense
JScript | public enum SportsFootballDefense

Members

Member | Value | Description
ButtonPause | 385893628
ButtonDevice | 385893630
ButtonBackLink | 385959144
ButtonForwardLink | 385959136
ButtonRightLink | 385926380
ButtonLeftLink | 385926372
ButtonSubstitute | 385893389
ButtonZoom | 385893388
ButtonAudible | 385893387
ButtonRip | 385893386
ButtonBullRush | 385893385
ButtonSwim | 385893384
ButtonSpin | 385893383
ButtonMenu | 385877245
ButtonSuperTackle | 385876998
ButtonFake | 385876997
ButtonTackle | 385876996
ButtonJump | 385876995
ButtonSelect | 385876994
ButtonPlay | 385876993
AxisMove | 385942018
AxisLateral | 385909249
SportsFootballDefense | 385875968

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsFootballField Enumeration (Microsoft.DirectX.DirectInput)

SportsFootballField Enumeration

Definition

Visual Basic | Public Enum SportsFootballField
C# | public enum SportsFootballField
C++ | public enum class SportsFootballField
JScript | public enum SportsFootballField

Members

Member | Value | Description
ButtonPause | 335561980
ButtonDevice | 335561982
ButtonMenu | 335545597
ButtonHelp | 335545347
ButtonSelect | 335545346
ButtonPlay | 335545345
SportsFootballField | 335544320

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsFootballOffense Enumeration (Microsoft.DirectX.DirectInput)

SportsFootballOffense Enumeration

Definition

Visual Basic | Public Enum SportsFootballOffense
C# | public enum SportsFootballOffense
C++ | public enum class SportsFootballOffense
JScript | public enum SportsFootballOffense

Members

Member | Value | Description
ButtonPause | 369116412
ButtonDevice | 369116414
ButtonBackLink | 369181928
ButtonForwardLink | 369181920
ButtonRightLink | 369149164
ButtonLeftLink | 369149156
ButtonSubstitute | 369116171
ButtonZoom | 369116170
ButtonDive | 369116169
ButtonTurbo | 369116168
ButtonShoulder | 369116167
ButtonJuke | 369116166
ButtonMenu | 369100029
ButtonSpin | 369099781
ButtonThrow | 369099780
ButtonRightArm | 369099779
ButtonLeftArm | 369099778
ButtonJump | 369099777
AxisMove | 369164802
AxisLateral | 369132033
SportsFootballOffense | 369098752

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsFootballQuarterback Enumeration (Microsoft.DirectX.DirectInput)

SportsFootballQuarterback Enumeration

Definition

Visual Basic | Public Enum SportsFootballQuarterback
C# | public enum SportsFootballQuarterback
C++ | public enum class SportsFootballQuarterback
JScript | public enum SportsFootballQuarterback

Members

Member | Value | Description
ButtonPause | 352339196
ButtonDevice | 352339198
ButtonBackLink | 352404712
ButtonForwardLink | 352404704
ButtonRightLink | 352371948
ButtonLeftLink | 352371940
ButtonAudible | 352338953
ButtonMotion | 352338952
ButtonFakeSnap | 352338951
ButtonMenu | 352322813
ButtonFake | 352322566
ButtonPass | 352322565
ButtonSlide | 352322564
ButtonJump | 352322563
ButtonSnap | 352322562
ButtonSelect | 352322561
AxisMove | 352387586
AxisLateral | 352354817
SportsFootballQuarterback | 352321536

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsGolf Enumeration (Microsoft.DirectX.DirectInput)

SportsGolf Enumeration

Definition

Visual Basic | Public Enum SportsGolf
C# | public enum SportsGolf
C++ | public enum class SportsGolf
JScript | public enum SportsGolf

Members

Member | Value | Description
ButtonPause | 402670844
ButtonDevice | 402670846
ButtonBackLink | 402736360
ButtonForwardLink | 402736352
ButtonRightLink | 402703596
ButtonLeftLink | 402703588
ButtonSubstitute | 402670601
ButtonTimeout | 402670600
ButtonZoom | 402670599
HatSwitchScroll | 402671105
ButtonMenu | 402654461
ButtonFlyBy | 402654214
ButtonTerrain | 402654213
ButtonDown | 402654212
ButtonUp | 402654211
ButtonSelect | 402654210
ButtonSwing | 402654209
AxisMove | 402719234
AxisLateral | 402686465
SportsGolf | 402653184

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsHockeyDefense Enumeration (Microsoft.DirectX.DirectInput)

SportsHockeyDefense Enumeration

Definition

Visual Basic | Public Enum SportsHockeyDefense
C# | public enum SportsHockeyDefense
C++ | public enum class SportsHockeyDefense
JScript | public enum SportsHockeyDefense

Members

Member | Value | Description
ButtonPause | 436225276
ButtonDevice | 436225278
ButtonBackLink | 436290792
ButtonForwardLink | 436290784
ButtonRightLink | 436258028
ButtonLeftLink | 436258020
ButtonSubstitute | 436225033
ButtonTimeout | 436225032
ButtonStrategy | 436225031
ButtonZoom | 436225030
HatSwitchScroll | 436225537
ButtonMenu | 436208893
ButtonFake | 436208645
ButtonBlock | 436208644
ButtonBurst | 436208643
ButtonSteal | 436208642
ButtonPlayer | 436208641
AxisMove | 436273666
AxisLateral | 436240897
SportsHockeyDefense | 436207616

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsHockeyGoalie Enumeration (Microsoft.DirectX.DirectInput)

SportsHockeyGoalie Enumeration

Definition

Visual Basic | Public Enum SportsHockeyGoalie
C# | public enum SportsHockeyGoalie
C++ | public enum class SportsHockeyGoalie
JScript | public enum SportsHockeyGoalie

Members

Member | Value | Description
ButtonPause | 453002492
ButtonDevice | 453002494
ButtonBackLink | 453068008
ButtonForwardLink | 453068000
ButtonRightLink | 453035244
ButtonLeftLink | 453035236
ButtonSubstitute | 453002248
ButtonTimeout | 453002247
ButtonStrategy | 453002246
ButtonZoom | 453002245
HatSwitchScroll | 453002753
ButtonMenu | 452986109
ButtonBlock | 452985860
ButtonSteal | 452985859
ButtonPoke | 452985858
ButtonPass | 452985857
AxisMove | 453050882
AxisLateral | 453018113
SportsHockeyGoalie | 452984832

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsHockeyOffense Enumeration (Microsoft.DirectX.DirectInput)

SportsHockeyOffense Enumeration

Definition

Visual Basic | Public Enum SportsHockeyOffense
C# | public enum SportsHockeyOffense
C++ | public enum class SportsHockeyOffense
JScript | public enum SportsHockeyOffense

Members

Member | Value | Description
ButtonPause | 419448060
ButtonDevice | 419448062
ButtonBackLink | 419513576
ButtonForwardLink | 419513568
ButtonRightLink | 419480812
ButtonLeftLink | 419480804
ButtonSubstitute | 419447817
ButtonTimeout | 419447816
ButtonStrategy | 419447815
ButtonZoom | 419447814
HatSwitchScroll | 419448321
ButtonMenu | 419431677
ButtonFake | 419431429
ButtonSpecial | 419431428
ButtonBurst | 419431427
ButtonPass | 419431426
ButtonShoot | 419431425
AxisMove | 419496450
AxisLateral | 419463681
SportsHockeyOffense | 419430400

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsHunting Enumeration (Microsoft.DirectX.DirectInput)

SportsHunting Enumeration

Definition

Visual Basic | Public Enum SportsHunting
C# | public enum SportsHunting
C++ | public enum class SportsHunting
JScript | public enum SportsHunting

Members

Member | Value | Description
ButtonPause | 218121468
ButtonDevice | 218121470
ButtonRotateRightLink | 218252524
ButtonRotateLeftLink | 218252516
ButtonBackLink | 218186984
ButtonForwardLink | 218186976
ButtonRightLink | 218154220
ButtonLeftLink | 218154212
ButtonFireSecondary | 218121227
ButtonJump | 218121226
ButtonCrouch | 218121225
AxisRotate | 218251779
ButtonDisplay | 218121224
HatSwitchGlance | 218121729
ButtonMenu | 218105085
ButtonSpecial | 218104839
ButtonMap | 218104838
ButtonCall | 218104837
ButtonBinocular | 218104836
ButtonWeapon | 218104835
ButtonAim | 218104834
ButtonFire | 218104833
AxisMove | 218169858
AxisLateral | 218137089
SportsHunting | 218103808

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsRaquet Enumeration (Microsoft.DirectX.DirectInput)

SportsRaquet Enumeration

Definition

Visual Basic | Public Enum SportsRaquet
C# | public enum SportsRaquet
C++ | public enum class SportsRaquet
JScript | public enum SportsRaquet

Members

Member | Value | Description
ButtonPause | 536888572
ButtonDevice | 536888574
ButtonBackLink | 536954088
ButtonForwardLink | 536954080
ButtonRightLink | 536921324
ButtonLeftLink | 536921316
ButtonSubstitute | 536888327
ButtonTimeout | 536888326
HatSwitchGlance | 536888833
ButtonMenu | 536872189
ButtonSelect | 536871941
ButtonSpecial | 536871940
ButtonSmash | 536871939
ButtonBackswing | 536871938
ButtonSwing | 536871937
AxisMove | 536936962
AxisLateral | 536904193
SportsRaquet | 536870912

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsSkiing Enumeration (Microsoft.DirectX.DirectInput)

SportsSkiing Enumeration

Definition

Visual Basic | Public Enum SportsSkiing
C# | public enum SportsSkiing
C++ | public enum class SportsSkiing
JScript | public enum SportsSkiing

Members

Member | Value | Description
ButtonPause | 486556924
ButtonDevice | 486556926
ButtonSlowerLink | 486622440
ButtonFasterLink | 486622432
ButtonRightLink | 486589676
ButtonLeftLink | 486589668
ButtonZoom | 486556679
HatSwitchGlance | 486557185
ButtonMenu | 486540541
ButtonSpecial2 | 486540294
ButtonSelect | 486540293
ButtonSpecial1 | 486540292
ButtonCamera | 486540291
ButtonCrouch | 486540290
ButtonJump | 486540289
AxisSpeed | 486605314
AxisTurn | 486572545
SportsSkiing | 486539264

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsSoccerDefense Enumeration (Microsoft.DirectX.DirectInput)

SportsSoccerDefense Enumeration

Definition

Visual Basic | Public Enum SportsSoccerDefense
C# | public enum SportsSoccerDefense
C++ | public enum class SportsSoccerDefense
JScript | public enum SportsSoccerDefense

Members

Member | Value | Description
ButtonPause | 520111356
ButtonDevice | 520111358
ButtonBackLink | 520176872
ButtonForwardLink | 520176864
ButtonRightLink | 520144108
ButtonLeftLink | 520144100
ButtonSubstitute | 520111116
ButtonGoalieCharge | 520111115
ButtonClear | 520111114
ButtonHead | 520111113
ButtonFoul | 520111112
HatSwitchGlance | 520111617
ButtonMenu | 520094973
ButtonSlide | 520094727
ButtonSelect | 520094726
ButtonSpecial | 520094725
ButtonPlayer | 520094724
ButtonFake | 520094723
ButtonSteal | 520094722
ButtonBlock | 520094721
AxisMove | 520159746
AxisLateral | 520126977
SportsSoccerDefense | 520093696

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SportsSoccerOffense Enumeration (Microsoft.DirectX.DirectInput)

SportsSoccerOffense Enumeration

Definition

Visual Basic | Public Enum SportsSoccerOffense
C# | public enum SportsSoccerOffense
C++ | public enum class SportsSoccerOffense
JScript | public enum SportsSoccerOffense

Members

Member | Value | Description
ButtonPause | 503334140
ButtonDevice | 503334142
ButtonBackLink | 503399656
ButtonForwardLink | 503399648
ButtonRightLink | 503366892
ButtonLeftLink | 503366884
ButtonHead | 503333901
ButtonControl | 503333900
ButtonSprint | 503333899
ButtonPassThru | 503333898
ButtonShootHigh | 503333897
ButtonShootLow | 503333896
ButtonSubstitute | 503333895
HatSwitchGlance | 503334401
ButtonMenu | 503317757
ButtonSelect | 503317510
ButtonSpecial1 | 503317509
ButtonPlayer | 503317508
ButtonFake | 503317507
ButtonPass | 503317506
ButtonShoot | 503317505
AxisBend | 503415299
AxisMove | 503382530
AxisLateral | 503349761
SportsSoccerOffense | 503316480

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StandardEffect Enumeration (Microsoft.DirectX.DirectInput)

StandardEffect Enumeration

Definition

Visual Basic | Public Enum StandardEffect
C# | public enum StandardEffect
C++ | public enum class StandardEffect
JScript | public enum StandardEffect

Members

Member | Value | Description
ConditionEffect | 13
PeriodicEffect | 12
CustomForceEffect | 11
FrictionEffect | 10
InertiaEffect | 9
DamperEffect | 8
SpringEffect | 7
SawtoothDownEffect | 6
SawtoothUpEffect | 5
TriangleEffect | 4
SineEffect | 3
SquareEffect | 2
RampForceEffect | 1
ConstantForceEffect | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StrategyRolePlaying Enumeration (Microsoft.DirectX.DirectInput)

StrategyRolePlaying Enumeration

Definition

Visual Basic | Public Enum StrategyRolePlaying
C# | public enum StrategyRolePlaying
C++ | public enum class StrategyRolePlaying
JScript | public enum StrategyRolePlaying

Members

Member | Value | Description
ButtonPause | 184567036
ButtonDevice | 184567038
ButtonRotateRightLink | 184698092
ButtonRotateLeftLink | 184698084
ButtonBackLink | 184632552
ButtonForwardLink | 184632544
ButtonRightLink | 184599788
ButtonLeftLink | 184599780
AxisRotate | 184697347
ButtonDisplay | 184566793
ButtonMap | 184566792
HatSwitchGlance | 184567297
ButtonMenu | 184550653
ButtonJump | 184550407
ButtonCrouch | 184550406
ButtonCast | 184550405
ButtonAttack | 184550404
ButtonSelect | 184550403
ButtonApply | 184550402
ButtonGet | 184550401
AxisMove | 184615426
AxisLateral | 184582657
StrategyRolePlaying | 184549376

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StrategyTurn Enumeration (Microsoft.DirectX.DirectInput)

StrategyTurn Enumeration

Definition

Visual Basic | Public Enum StrategyTurn
C# | public enum StrategyTurn
C++ | public enum class StrategyTurn
JScript | public enum StrategyTurn

Members

Member | Value | Description
ButtonPause | 201344252
ButtonDevice | 201344254
ButtonBackLink | 201409768
ButtonForwardLink | 201409760
ButtonRightLink | 201377004
ButtonLeftLink | 201376996
ButtonDisplay | 201344008
ButtonMap | 201344007
ButtonZoom | 201344006
ButtonMenu | 201327869
ButtonTurn | 201327621
ButtonTeam | 201327620
ButtonApply | 201327619
ButtonInstruct | 201327618
ButtonSelect | 201327617
AxisMove | 201392642
AxisLateral | 201359873
StrategyTurn | 201326592

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TextAlign Enumeration (Microsoft.DirectX.DirectInput)

TextAlign Enumeration

Definition

Visual Basic | Public Enum TextAlign
C# | public enum TextAlign
C++ | public enum class TextAlign
JScript | public enum TextAlign

Members

Member | Value | Description
BottomAligned | 8
TopAligned | 4
Middle | 0
RightAligned | 2
LeftAlign | 1
Centered | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TimeStamp Enumeration (Microsoft.DirectX.DirectInput)

TimeStamp Enumeration

Definition

Visual Basic | Public Enum TimeStamp
C# | public enum TimeStamp
C++ | public enum class TimeStamp
JScript | public enum TimeStamp

Members

Member | Value | Description
UnusedDeviceHigh | 0
UnusedDeviceLow | 0
NewDeviceHigh | -1
NewDeviceLow | -1

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Voice Enumeration (Microsoft.DirectX.DirectInput)

Voice Enumeration

Definition

Visual Basic | Public Enum Voice
C# | public enum Voice
C++ | public enum class Voice
JScript | public enum Voice

Members

Member | Value | Description
VoiceCommand | -2097150960
Transmit | -2097150963
PlaybackMute | -2097150964
RecordMute | -2097150965
Team | -2097150967
Channel8 | -2097150968
Channel7 | -2097150969
Channel6 | -2097150970
Channel5 | -2097150971
Channel4 | -2097150972
Channel3 | -2097150973
Channel2 | -2097150974
Channel1 | -2097150975
All | -2097150966

Enumeration Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CalibrationPoint Structure (Microsoft.DirectX.DirectInput)

CalibrationPoint Structure

Describes a calibration point. An array of Cpoint structures is contained by a Dipropcpoints structure.

Definition

Visual Basic | Public Structure CalibrationPoint
C# | public struct CalibrationPoint
C++ | public value class CalibrationPoint sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CalibrationPoint | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
RawData
ScalingValue | Scaling value to be associated with the LP number. The percentage of the maximum value multiplied by 10000.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CalibrationPoint.CalibrationPoint() Constructor (Microsoft.DirectX.DirectInput)

CalibrationPoint.CalibrationPoint Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public CalibrationPoint();
C++ public:
CalibrationPoint();
JScript | public function CalibrationPoint();


CalibrationPoint.ToString() Method (Microsoft.DirectX.DirectInput)

CalibrationPoint.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CalibrationPoint.RawData Property (Microsoft.DirectX.DirectInput)

CalibrationPoint.RawData Property

Definition

Visual Basic | Public Property RawData As Integer
C# | public int RawData { get; set; }
C++ public:
property int RawData {
int get();
void set(int value);
}
JScript public function get RawData() : int
public function set RawData(int);

Property Value

System.Int32

This property is read/write.


CalibrationPoint.ScalingValue Property (Microsoft.DirectX.DirectInput)

CalibrationPoint.ScalingValue Property

Scaling value to be associated with the LP number. The percentage of the maximum value multiplied by 10000.

Definition

Visual Basic | Public Property ScalingValue As Integer
C# | public int ScalingValue { get; set; }
C++ public:
property int ScalingValue {
int get();
void set(int value);
}
JScript public function get ScalingValue() : int
public function set ScalingValue(int);

Property Value

System.Int32

This property is read/write.


ColorSet Structure (Microsoft.DirectX.DirectInput)

ColorSet Structure

Describes a set of colors used to draw the device configuration user object. It is part of the Diconfiguredevicesparams structure.

Definition

Visual Basic | Public Structure ColorSet
C# | public struct ColorSet
C++ | public value class ColorSet sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ColorSet | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AreaFill | Fill color for areas outside controls such as tabs and buttons.
Border | Border color, used to display lines around controls such as tabs and buttons.
CalloutHighlight | Color used to display callout lines.
CalloutLine | Color used to display callout lines.
ControlFill | Fill color for controls such as tabs and buttons.
HighlightFill | Fill color for highlighted controls.
TextFore | Foreground text color.
TextHighlight | Foreground color for highlighted text.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ColorSet.ColorSet() Constructor (Microsoft.DirectX.DirectInput)

ColorSet.ColorSet Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public ColorSet();
C++ public:
ColorSet();
JScript | public function ColorSet();


ColorSet.ToString() Method (Microsoft.DirectX.DirectInput)

ColorSet.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ColorSet.AreaFill Property (Microsoft.DirectX.DirectInput)

ColorSet.AreaFill Property

Fill color for areas outside controls such as tabs and buttons.

Definition

Visual Basic | Public Property AreaFill As Integer
C# | public int AreaFill { get; set; }
C++ public:
property int AreaFill {
int get();
void set(int value);
}
JScript public function get AreaFill() : int
public function set AreaFill(int);

Property Value

System.Int32

This property is read/write.


ColorSet.Border Property (Microsoft.DirectX.DirectInput)

ColorSet.Border Property

Border color, used to display lines around controls such as tabs and buttons.

Definition

Visual Basic | Public Property Border As Integer
C# | public int Border { get; set; }
C++ public:
property int Border {
int get();
void set(int value);
}
JScript public function get Border() : int
public function set Border(int);

Property Value

System.Int32

This property is read/write.


ColorSet.CalloutHighlight Property (Microsoft.DirectX.DirectInput)

ColorSet.CalloutHighlight Property

Color used to display callout lines.

Definition

Visual Basic | Public Property CalloutHighlight As Integer
C# | public int CalloutHighlight { get; set; }
C++ public:
property int CalloutHighlight {
int get();
void set(int value);
}
JScript public function get CalloutHighlight() : int
public function set CalloutHighlight(int);

Property Value

System.Int32

This property is read/write.


ColorSet.CalloutLine Property (Microsoft.DirectX.DirectInput)

ColorSet.CalloutLine Property

Color used to display callout lines.

Definition

Visual Basic | Public Property CalloutLine As Integer
C# | public int CalloutLine { get; set; }
C++ public:
property int CalloutLine {
int get();
void set(int value);
}
JScript public function get CalloutLine() : int
public function set CalloutLine(int);

Property Value

System.Int32

This property is read/write.


ColorSet.ControlFill Property (Microsoft.DirectX.DirectInput)

ColorSet.ControlFill Property

Fill color for controls such as tabs and buttons.

Definition

Visual Basic | Public Property ControlFill As Integer
C# | public int ControlFill { get; set; }
C++ public:
property int ControlFill {
int get();
void set(int value);
}
JScript public function get ControlFill() : int
public function set ControlFill(int);

Property Value

System.Int32

This property is read/write.


ColorSet.HighlightFill Property (Microsoft.DirectX.DirectInput)

ColorSet.HighlightFill Property

Fill color for highlighted controls.

Definition

Visual Basic | Public Property HighlightFill As Integer
C# | public int HighlightFill { get; set; }
C++ public:
property int HighlightFill {
int get();
void set(int value);
}
JScript public function get HighlightFill() : int
public function set HighlightFill(int);

Property Value

System.Int32

This property is read/write.


ColorSet.TextFore Property (Microsoft.DirectX.DirectInput)

ColorSet.TextFore Property

Foreground text color.

Definition

Visual Basic | Public Property TextFore As Integer
C# | public int TextFore { get; set; }
C++ public:
property int TextFore {
int get();
void set(int value);
}
JScript public function get TextFore() : int
public function set TextFore(int);

Property Value

System.Int32

This property is read/write.


ColorSet.TextHighlight Property (Microsoft.DirectX.DirectInput)

ColorSet.TextHighlight Property

Foreground color for highlighted text.

Definition

Visual Basic | Public Property TextHighlight As Integer
C# | public int TextHighlight { get; set; }
C++ public:
property int TextHighlight {
int get();
void set(int value);
}
JScript public function get TextHighlight() : int
public function set TextHighlight(int);

Property Value

System.Int32

This property is read/write.


Condition Structure (Microsoft.DirectX.DirectInput)

Condition Structure

Contains type-specific information for effects that are marked as DIEFT_CONDITION.A reference to an array of Dicondition structures for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure. The number of elements in the array must be either one, or equal to the number of axes associated with the effect.

Definition

Visual Basic | Public Structure Condition
C# | public struct Condition
C++ | public value class Condition sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Condition | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DeadBand | Region around LOffset in which the condition is not active, in the range from 0 through 10,000. In other words, the condition is not active between LOffset minus LDeadBand and LOffset plus LDeadBand.
NegativeCoefficient | Coefficient constant on the negative side of the offset, in the range from -10,000 through 10,000. If the device does not support separate positive and negative coefficients, the value of LNegative
NegativeSaturation | Maximum force output on the negative side of the offset, in the range from 0 through 10,000.If the device does not support force saturation, the value of this member is ignored.If the device does not support separate positive and negative saturation, the value of DwNegativeSaturation is ignored, and the value of DwPositiveSaturation is used as both the positive and negative saturation.
Offset | Offset for the condition, in the range from -10,000 through 10,000.
PositiveCoefficient | Coefficient constant on the positive side of the offset, in the range from -10,000 through 10,000.
PositiveSaturation | Maximum force output on the positive side of the offset, in the range from 0 through 10,000.If the device does not support force TermSaturation, the value of this member is ignored.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Condition.Condition() Constructor (Microsoft.DirectX.DirectInput)

Condition.Condition Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public Condition();
C++ public:
Condition();
JScript | public function Condition();


Condition.ToString() Method (Microsoft.DirectX.DirectInput)

Condition.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Condition.DeadBand Property (Microsoft.DirectX.DirectInput)

Condition.DeadBand Property

Region around LOffset in which the condition is not active, in the range from 0 through 10,000. In other words, the condition is not active between LOffset minus LDeadBand and LOffset plus LDeadBand.

Definition

Visual Basic | Public Property DeadBand As Integer
C# | public int DeadBand { get; set; }
C++ public:
property int DeadBand {
int get();
void set(int value);
}
JScript public function get DeadBand() : int
public function set DeadBand(int);

Property Value

System.Int32

This property is read/write.


Condition.NegativeCoefficient Property (Microsoft.DirectX.DirectInput)

Condition.NegativeCoefficient Property

Coefficient constant on the negative side of the offset, in the range from -10,000 through 10,000. If the device does not support separate positive and negative coefficients, the value of LNegative

Definition

Visual Basic | Public Property NegativeCoefficient As Integer
C# | public int NegativeCoefficient { get; set; }
C++ public:
property int NegativeCoefficient {
int get();
void set(int value);
}
JScript public function get NegativeCoefficient() : int
public function set NegativeCoefficient(int);

Property Value

System.Int32

This property is read/write.


Condition.NegativeSaturation Property (Microsoft.DirectX.DirectInput)

Condition.NegativeSaturation Property

Maximum force output on the negative side of the offset, in the range from 0 through 10,000.If the device does not support force saturation, the value of this member is ignored.If the device does not support separate positive and negative saturation, the value of DwNegativeSaturation is ignored, and the value of DwPositiveSaturation is used as both the positive and negative saturation.

Definition

Visual Basic | Public Property NegativeSaturation As Integer
C# | public int NegativeSaturation { get; set; }
C++ public:
property int NegativeSaturation {
int get();
void set(int value);
}
JScript public function get NegativeSaturation() : int
public function set NegativeSaturation(int);

Property Value

System.Int32

This property is read/write.


Condition.Offset Property (Microsoft.DirectX.DirectInput)

Condition.Offset Property

Offset for the condition, in the range from -10,000 through 10,000.

Definition

Visual Basic | Public Property Offset As Integer
C# | public int Offset { get; set; }
C++ public:
property int Offset {
int get();
void set(int value);
}
JScript public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32

This property is read/write.


Condition.PositiveCoefficient Property (Microsoft.DirectX.DirectInput)

Condition.PositiveCoefficient Property

Coefficient constant on the positive side of the offset, in the range from -10,000 through 10,000.

Definition

Visual Basic | Public Property PositiveCoefficient As Integer
C# | public int PositiveCoefficient { get; set; }
C++ public:
property int PositiveCoefficient {
int get();
void set(int value);
}
JScript public function get PositiveCoefficient() : int
public function set PositiveCoefficient(int);

Property Value

System.Int32

This property is read/write.


Condition.PositiveSaturation Property (Microsoft.DirectX.DirectInput)

Condition.PositiveSaturation Property

Maximum force output on the positive side of the offset, in the range from 0 through 10,000.If the device does not support force TermSaturation, the value of this member is ignored.

Definition

Visual Basic | Public Property PositiveSaturation As Integer
C# | public int PositiveSaturation { get; set; }
C++ public:
property int PositiveSaturation {
int get();
void set(int value);
}
JScript public function get PositiveSaturation() : int
public function set PositiveSaturation(int);

Property Value

System.Int32

This property is read/write.


ConstantForce Structure (Microsoft.DirectX.DirectInput)

ConstantForce Structure

Contains type-specific information for effects that are marked as DIEFT_CONSTANTFORCE.The structure describes a constant force effect.A reference to a single Diconstantforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic | Public Structure ConstantForce
C# | public struct ConstantForce
C++ | public value class ConstantForce sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ConstantForce | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Magnitude | The magnitude of the effect, in the range from -10,000 through 10,000. If an TermEnvelope is applied to this effect, the value represents the magnitude of the TermSustain. If no envelope is applied, the value represents the amplitude of the entire effect.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConstantForce.ConstantForce() Constructor (Microsoft.DirectX.DirectInput)

ConstantForce.ConstantForce Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public ConstantForce();
C++ public:
ConstantForce();
JScript | public function ConstantForce();


ConstantForce.ToString() Method (Microsoft.DirectX.DirectInput)

ConstantForce.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConstantForce.Magnitude Property (Microsoft.DirectX.DirectInput)

ConstantForce.Magnitude Property

The magnitude of the effect, in the range from -10,000 through 10,000. If an TermEnvelope is applied to this effect, the value represents the magnitude of the TermSustain. If no envelope is applied, the value represents the amplitude of the entire effect.

Definition

Visual Basic | Public Property Magnitude As Integer
C# | public int Magnitude { get; set; }
C++ public:
property int Magnitude {
int get();
void set(int value);
}
JScript public function get Magnitude() : int
public function set Magnitude(int);

Property Value

System.Int32

This property is read/write.


CustomForce Structure (Microsoft.DirectX.DirectInput)

CustomForce Structure

Contains type-specific information for effects that are marked as DIEFT_CUSTOMFORCE.The structure describes a custom or user-defined force.A reference to a Dicustomforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic | Public Structure CustomForce
C# | public struct CustomForce
C++ | public value class CustomForce sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CustomForce | Initializes a new instance of the object.
GetForceData
SetForceData
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Channels | Number of channels (axes) affected by this force. The first channel is applied to the first axis associated with the effect, the second to the second, and so on. If there are fewer channels than axes, nothing is associated with the extra axes.If there is only a single channel, the effect is rotated in the direction specified by the rglDirection member of the Dieffect structure. If there is more than one channel, rotation is not allowed.Not all devices support rotation of custom effects.
SamplePeriod | Sample period, in microseconds.
Samples | Total number of samples in the RglForceData. It must be an integral multiple of the CChannels.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CustomForce.CustomForce() Constructor (Microsoft.DirectX.DirectInput)

CustomForce.CustomForce Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public CustomForce();
C++ public:
CustomForce();
JScript | public function CustomForce();


CustomForce.GetForceData() Method (Microsoft.DirectX.DirectInput)

CustomForce.GetForceData Method

Definition

Visual Basic | Public Function GetForceData() As Integer()
C# | public int[] GetForceData();
C++ public:
array<int>^ GetForceData();
JScript | public function GetForceData() : int[];

Return Value

System.Int32[]


CustomForce.SetForceData(Int32[]) Method (Microsoft.DirectX.DirectInput)

CustomForce.SetForceData Method

Definition

Visual Basic Public Sub SetForceData( _
ByVal value() As Integer _
)
C# public void SetForceData(
int[] value
);
C++ public:
void SetForceData(
array<int>^ value
);
JScript public function SetForceData(
value : int[]
);

Parameters

value System.Int32[]


CustomForce.ToString() Method (Microsoft.DirectX.DirectInput)

CustomForce.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CustomForce.Channels Property (Microsoft.DirectX.DirectInput)

CustomForce.Channels Property

Number of channels (axes) affected by this force. The first channel is applied to the first axis associated with the effect, the second to the second, and so on. If there are fewer channels than axes, nothing is associated with the extra axes.If there is only a single channel, the effect is rotated in the direction specified by the rglDirection member of the Dieffect structure. If there is more than one channel, rotation is not allowed.Not all devices support rotation of custom effects.

Definition

Visual Basic | Public Property Channels As Integer
C# | public int Channels { get; set; }
C++ public:
property int Channels {
int get();
void set(int value);
}
JScript public function get Channels() : int
public function set Channels(int);

Property Value

System.Int32

This property is read/write.


CustomForce.SamplePeriod Property (Microsoft.DirectX.DirectInput)

CustomForce.SamplePeriod Property

Sample period, in microseconds.

Definition

Visual Basic | Public Property SamplePeriod As Integer
C# | public int SamplePeriod { get; set; }
C++ public:
property int SamplePeriod {
int get();
void set(int value);
}
JScript public function get SamplePeriod() : int
public function set SamplePeriod(int);

Property Value

System.Int32

This property is read/write.


CustomForce.Samples Property (Microsoft.DirectX.DirectInput)

CustomForce.Samples Property

Total number of samples in the RglForceData. It must be an integral multiple of the CChannels.

Definition

Visual Basic | Public Property Samples As Integer
C# | public int Samples { get; set; }
C++ public:
property int Samples {
int get();
void set(int value);
}
JScript public function get Samples() : int
public function set Samples(int);

Property Value

System.Int32

This property is read/write.


DataFormat Structure (Microsoft.DirectX.DirectInput)

DataFormat Structure

Describes a device's data format. This structure is used with the Inputdevice9Setdataformat method.

Definition

Visual Basic | Public Structure DataFormat
C# | public struct DataFormat
C++ | public value class DataFormat sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
ObjectDataFormat

Methods

Method | Description
DataFormat | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DataSize | Size of a data packet returned by the device, in bytes. This value must be a multiple of 4 and must exceed the largest offset value for an object's data within the data packet.
Flags | Flags describing other attributes of the data format. This value can be one of the following:

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DataFormat.DataFormat() Constructor (Microsoft.DirectX.DirectInput)

DataFormat.DataFormat Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DataFormat();
C++ public:
DataFormat();
JScript | public function DataFormat();


DataFormat.ToString() Method (Microsoft.DirectX.DirectInput)

DataFormat.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DataFormat.DataSize Property (Microsoft.DirectX.DirectInput)

DataFormat.DataSize Property

Size of a data packet returned by the device, in bytes. This value must be a multiple of 4 and must exceed the largest offset value for an object's data within the data packet.

Definition

Visual Basic | Public Property DataSize As Integer
C# | public int DataSize { get; set; }
C++ public:
property int DataSize {
int get();
void set(int value);
}
JScript public function get DataSize() : int
public function set DataSize(int);

Property Value

System.Int32

This property is read/write.


DataFormat.Flags Property (Microsoft.DirectX.DirectInput)

DataFormat.Flags Property

Flags describing other attributes of the data format. This value can be one of the following:

Definition

Visual Basic | Public Property Flags As DataFormatFlags
C# | public DataFormatFlags Flags { get; set; }
C++ public:
property DataFormatFlags Flags {
DataFormatFlags get();
void set(DataFormatFlags value);
}
JScript public function get Flags() : DataFormatFlags
public function set Flags(DataFormatFlags);

Property Value

Microsoft.DirectX.DirectInput.DataFormatFlags

This property is read/write.


DataFormat.ObjectDataFormat Field (Microsoft.DirectX.DirectInput)

DataFormat.ObjectDataFormat Field

Definition

Visual Basic | Public ObjectDataFormat As ObjectDataFormat
C# | public ObjectDataFormat ObjectDataFormat;
C++ | public: ObjectDataFormat ObjectDataFormat;
JScript | public var ObjectDataFormat : ObjectDataFormat

Field Value

Microsoft.DirectX.DirectInput.ObjectDataFormat[]

This field is read/write.


DeviceArrival Structure (Microsoft.DirectX.DirectInput)

DeviceArrival Structure

Definition

Visual Basic | Public Structure DeviceArrival
C# | public struct DeviceArrival
C++ | public value class DeviceArrival sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceArrival | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property Description
Class
Name

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceArrival.DeviceArrival() Constructor (Microsoft.DirectX.DirectInput)

DeviceArrival.DeviceArrival Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DeviceArrival();
C++ public:
DeviceArrival();
JScript | public function DeviceArrival();


DeviceArrival.ToString() Method (Microsoft.DirectX.DirectInput)

DeviceArrival.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceArrival.Class Property (Microsoft.DirectX.DirectInput)

DeviceArrival.Class Property

Definition

Visual Basic | Public Property Class As Guid
C# | public Guid Class { get; set; }
C++ public:
property Guid Class {
Guid get();
void set(Guid value);
}
JScript public function get Class() : Guid
public function set Class(Guid);

Property Value

System.Guid

This property is read/write.


DeviceArrival.Name Property (Microsoft.DirectX.DirectInput)

DeviceArrival.Name Property

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String

This property is read/write.


DeviceCaps Structure (Microsoft.DirectX.DirectInput)

DeviceCaps Structure

Describes a Microsoft® DirectInput® device's capabilities. This structure is used with the Inputdevice9Getcapabilities method.

Definition

Visual Basic | Public Structure DeviceCaps
C# | public struct DeviceCaps
C++ | public value class DeviceCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceCaps | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Alias
Attack
Attatched
DeadBand
DeviceSubType | Device type specifier. This member can contain values identical to those in the dwDevType member of the Dideviceinstance structure.
DeviceType | Device type specifier. This member can contain values identical to those in the dwDevType member of the Dideviceinstance structure.
Emulated
Fade
FFDriverVersion | Version number of the device driver.
FFMinTimeResolution | Minimum time, in microseconds, that the device can resolve. The device rounds any times to the nearest supported increment. For example, if the value of DwFFMinTimeResolution is 1000, the device would round any times to the nearest millisecond.
FFSamplePeriod | Minimum time between playback of consecutive raw force commands, in microseconds.
FirmwareRevision | Firmware revision of the device.
ForceFeedback
HardwareRevision | Hardware revision of the device.
Hidden
NumberAxes | Number of axes available on the device.
NumberButtons | Number of buttons available on the device.
NumberPointOfViews | Number of point-of-view controllers available on the device.
Phantom
PolledDataFormat
PolledDevice
PosNegCoefficients
PosNegSaturation
Saturation
StartDelay

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceCaps.DeviceCaps() Constructor (Microsoft.DirectX.DirectInput)

DeviceCaps.DeviceCaps Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DeviceCaps();
C++ public:
DeviceCaps();
JScript | public function DeviceCaps();


DeviceCaps.ToString() Method (Microsoft.DirectX.DirectInput)

DeviceCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceCaps.Alias Property (Microsoft.DirectX.DirectInput)

DeviceCaps.Alias Property

Definition

Visual Basic | Public ReadOnly Property Alias As Boolean
C# | public bool Alias { get; }
C++ public:
property bool Alias {
bool get();
}
JScript | public function get Alias() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.Attack Property (Microsoft.DirectX.DirectInput)

DeviceCaps.Attack Property

Definition

Visual Basic | Public ReadOnly Property Attack As Boolean
C# | public bool Attack { get; }
C++ public:
property bool Attack {
bool get();
}
JScript | public function get Attack() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.Attatched Property (Microsoft.DirectX.DirectInput)

DeviceCaps.Attatched Property

Definition

Visual Basic | Public ReadOnly Property Attatched As Boolean
C# | public bool Attatched { get; }
C++ public:
property bool Attatched {
bool get();
}
JScript | public function get Attatched() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.DeadBand Property (Microsoft.DirectX.DirectInput)

DeviceCaps.DeadBand Property

Definition

Visual Basic | Public ReadOnly Property DeadBand As Boolean
C# | public bool DeadBand { get; }
C++ public:
property bool DeadBand {
bool get();
}
JScript | public function get DeadBand() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.DeviceSubType Property (Microsoft.DirectX.DirectInput)

DeviceCaps.DeviceSubType Property

Device type specifier. This member can contain values identical to those in the dwDevType member of the Dideviceinstance structure.

Definition

Visual Basic | Public ReadOnly Property DeviceSubType As Integer
C# | public int DeviceSubType { get; }
C++ public:
property int DeviceSubType {
int get();
}
JScript | public function get DeviceSubType() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.DeviceType Property (Microsoft.DirectX.DirectInput)

DeviceCaps.DeviceType Property

Device type specifier. This member can contain values identical to those in the dwDevType member of the Dideviceinstance structure.

Definition

Visual Basic | Public ReadOnly Property DeviceType As DeviceType
C# | public DeviceType DeviceType { get; }
C++ public:
property DeviceType DeviceType {
DeviceType get();
}
JScript | public function get DeviceType() : DeviceType

Property Value

Microsoft.DirectX.DirectInput.DeviceType

This property is read-only.


DeviceCaps.Emulated Property (Microsoft.DirectX.DirectInput)

DeviceCaps.Emulated Property

Definition

Visual Basic | Public ReadOnly Property Emulated As Boolean
C# | public bool Emulated { get; }
C++ public:
property bool Emulated {
bool get();
}
JScript | public function get Emulated() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.Fade Property (Microsoft.DirectX.DirectInput)

DeviceCaps.Fade Property

Definition

Visual Basic | Public ReadOnly Property Fade As Boolean
C# | public bool Fade { get; }
C++ public:
property bool Fade {
bool get();
}
JScript | public function get Fade() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.FFDriverVersion Property (Microsoft.DirectX.DirectInput)

DeviceCaps.FFDriverVersion Property

Version number of the device driver.

Definition

Visual Basic | Public ReadOnly Property FFDriverVersion As Integer
C# | public int FFDriverVersion { get; }
C++ public:
property int FFDriverVersion {
int get();
}
JScript | public function get FFDriverVersion() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.FFMinTimeResolution Property (Microsoft.DirectX.DirectInput)

DeviceCaps.FFMinTimeResolution Property

Minimum time, in microseconds, that the device can resolve. The device rounds any times to the nearest supported increment. For example, if the value of DwFFMinTimeResolution is 1000, the device would round any times to the nearest millisecond.

Definition

Visual Basic | Public ReadOnly Property FFMinTimeResolution As Integer
C# | public int FFMinTimeResolution { get; }
C++ public:
property int FFMinTimeResolution {
int get();
}
JScript | public function get FFMinTimeResolution() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.FFSamplePeriod Property (Microsoft.DirectX.DirectInput)

DeviceCaps.FFSamplePeriod Property

Minimum time between playback of consecutive raw force commands, in microseconds.

Definition

Visual Basic | Public ReadOnly Property FFSamplePeriod As Integer
C# | public int FFSamplePeriod { get; }
C++ public:
property int FFSamplePeriod {
int get();
}
JScript | public function get FFSamplePeriod() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.FirmwareRevision Property (Microsoft.DirectX.DirectInput)

DeviceCaps.FirmwareRevision Property

Firmware revision of the device.

Definition

Visual Basic | Public ReadOnly Property FirmwareRevision As Integer
C# | public int FirmwareRevision { get; }
C++ public:
property int FirmwareRevision {
int get();
}
JScript | public function get FirmwareRevision() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.ForceFeedback Property (Microsoft.DirectX.DirectInput)

DeviceCaps.ForceFeedback Property

Definition

Visual Basic | Public ReadOnly Property ForceFeedback As Boolean
C# | public bool ForceFeedback { get; }
C++ public:
property bool ForceFeedback {
bool get();
}
JScript | public function get ForceFeedback() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.HardwareRevision Property (Microsoft.DirectX.DirectInput)

DeviceCaps.HardwareRevision Property

Hardware revision of the device.

Definition

Visual Basic | Public ReadOnly Property HardwareRevision As Integer
C# | public int HardwareRevision { get; }
C++ public:
property int HardwareRevision {
int get();
}
JScript | public function get HardwareRevision() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.Hidden Property (Microsoft.DirectX.DirectInput)

DeviceCaps.Hidden Property

Definition

Visual Basic | Public ReadOnly Property Hidden As Boolean
C# | public bool Hidden { get; }
C++ public:
property bool Hidden {
bool get();
}
JScript | public function get Hidden() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.NumberAxes Property (Microsoft.DirectX.DirectInput)

DeviceCaps.NumberAxes Property

Number of axes available on the device.

Definition

Visual Basic | Public ReadOnly Property NumberAxes As Integer
C# | public int NumberAxes { get; }
C++ public:
property int NumberAxes {
int get();
}
JScript | public function get NumberAxes() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.NumberButtons Property (Microsoft.DirectX.DirectInput)

DeviceCaps.NumberButtons Property

Number of buttons available on the device.

Definition

Visual Basic | Public ReadOnly Property NumberButtons As Integer
C# | public int NumberButtons { get; }
C++ public:
property int NumberButtons {
int get();
}
JScript | public function get NumberButtons() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.NumberPointOfViews Property (Microsoft.DirectX.DirectInput)

DeviceCaps.NumberPointOfViews Property

Number of point-of-view controllers available on the device.

Definition

Visual Basic | Public ReadOnly Property NumberPointOfViews As Integer
C# | public int NumberPointOfViews { get; }
C++ public:
property int NumberPointOfViews {
int get();
}
JScript | public function get NumberPointOfViews() : int

Property Value

System.Int32

This property is read-only.


DeviceCaps.Phantom Property (Microsoft.DirectX.DirectInput)

DeviceCaps.Phantom Property

Definition

Visual Basic | Public ReadOnly Property Phantom As Boolean
C# | public bool Phantom { get; }
C++ public:
property bool Phantom {
bool get();
}
JScript | public function get Phantom() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.PolledDataFormat Property (Microsoft.DirectX.DirectInput)

DeviceCaps.PolledDataFormat Property

Definition

Visual Basic | Public ReadOnly Property PolledDataFormat As Boolean
C# | public bool PolledDataFormat { get; }
C++ public:
property bool PolledDataFormat {
bool get();
}
JScript | public function get PolledDataFormat() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.PolledDevice Property (Microsoft.DirectX.DirectInput)

DeviceCaps.PolledDevice Property

Definition

Visual Basic | Public ReadOnly Property PolledDevice As Boolean
C# | public bool PolledDevice { get; }
C++ public:
property bool PolledDevice {
bool get();
}
JScript | public function get PolledDevice() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.PosNegCoefficients Property (Microsoft.DirectX.DirectInput)

DeviceCaps.PosNegCoefficients Property

Definition

Visual Basic | Public ReadOnly Property PosNegCoefficients As Boolean
C# | public bool PosNegCoefficients { get; }
C++ public:
property bool PosNegCoefficients {
bool get();
}
JScript | public function get PosNegCoefficients() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.PosNegSaturation Property (Microsoft.DirectX.DirectInput)

DeviceCaps.PosNegSaturation Property

Definition

Visual Basic | Public ReadOnly Property PosNegSaturation As Boolean
C# | public bool PosNegSaturation { get; }
C++ public:
property bool PosNegSaturation {
bool get();
}
JScript | public function get PosNegSaturation() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.Saturation Property (Microsoft.DirectX.DirectInput)

DeviceCaps.Saturation Property

Definition

Visual Basic | Public ReadOnly Property Saturation As Boolean
C# | public bool Saturation { get; }
C++ public:
property bool Saturation {
bool get();
}
JScript | public function get Saturation() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceCaps.StartDelay Property (Microsoft.DirectX.DirectInput)

DeviceCaps.StartDelay Property

Definition

Visual Basic | Public ReadOnly Property StartDelay As Boolean
C# | public bool StartDelay { get; }
C++ public:
property bool StartDelay {
bool get();
}
JScript | public function get StartDelay() : boolean

Property Value

System.Boolean

This property is read-only.


DeviceImageInformation Structure (Microsoft.DirectX.DirectInput)

DeviceImageInformation Structure

Carries information required to display a device image or an overlay image with a callout. This structure is passed to the Inputdevice9Getimageinfo method as an array within a Dideviceimageinfoheader structure.

Definition

Visual Basic | Public Structure DeviceImageInformation
C# | public struct DeviceImageInformation
C++ | public value class DeviceImageInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
CalloutLine | Array of POINT structures that specify coordinates of the points describing a callout line. A callout line connects a device control to a caption for the game action. Each line can have from one to four segments. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.
CalloutRectangle | RECT structure that describes the rectangle in which the game action string is displayed. If the string cannot fit within the rectangle, the application is responsible for handling clipping. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.
Overlay | Rectangle, using coordinates relative to the top-left pixel of the device configuration image, in which the overlay image should be painted. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Methods

Method | Description
DeviceImageInformation | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Flags | Flag that describes the intended use of the image.
ImagePath | Fully qualified path to the file that contains an image of the device. The file format is given in DwFlags. If no image is available for the device, this member will be set to NULL. If so, the application is responsible for enumerating controls on the device and displaying a default listing of actions to device controls (similar to the method used by most applications before Microsoft® DirectX® 8.0).
ObjectId | Control identifier, as a combination of DIDFT_* flags and an instance value, to which an overlay image corresponds for this device. Applications use the DIDFT_GETINSTANCE and DIDFT_GETTYPE macros to decode this value to its constituent parts. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.
TextAlign | DWORD value that specifies the alignment of the text in the rectangle described by the RcCalloutRect member. Must be one horizontal alignment flag combined with one vertical alignment flag. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.
ViewId | For device view images (DIDIFT_CONFIGURATION), this is the identifier of the device view.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceImageInformation.DeviceImageInformation() Constructor (Microsoft.DirectX.DirectInput)

DeviceImageInformation.DeviceImageInformation Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DeviceImageInformation();
C++ public:
DeviceImageInformation();
JScript | public function DeviceImageInformation();


DeviceImageInformation.ToString() Method (Microsoft.DirectX.DirectInput)

DeviceImageInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceImageInformation.Flags Property (Microsoft.DirectX.DirectInput)

DeviceImageInformation.Flags Property

Flag that describes the intended use of the image.

Definition

Visual Basic | Public Property Flags As ImageFileType
C# | public ImageFileType Flags { get; set; }
C++ public:
property ImageFileType Flags {
ImageFileType get();
void set(ImageFileType value);
}
JScript public function get Flags() : ImageFileType
public function set Flags(ImageFileType);

Property Value

Microsoft.DirectX.DirectInput.ImageFileType

This property is read/write.


DeviceImageInformation.ImagePath Property (Microsoft.DirectX.DirectInput)

DeviceImageInformation.ImagePath Property

Fully qualified path to the file that contains an image of the device. The file format is given in DwFlags. If no image is available for the device, this member will be set to NULL. If so, the application is responsible for enumerating controls on the device and displaying a default listing of actions to device controls (similar to the method used by most applications before Microsoft® DirectX® 8.0).

Definition

Visual Basic | Public Property ImagePath As String
C# | public string ImagePath { get; set; }
C++ public:
property String^ ImagePath {
String^ get();
void set(String^ value);
}
JScript public function get ImagePath() : String
public function set ImagePath(String);

Property Value

System.String

This property is read/write.


DeviceImageInformation.ObjectId Property (Microsoft.DirectX.DirectInput)

DeviceImageInformation.ObjectId Property

Control identifier, as a combination of DIDFT_* flags and an instance value, to which an overlay image corresponds for this device. Applications use the DIDFT_GETINSTANCE and DIDFT_GETTYPE macros to decode this value to its constituent parts. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic | Public Property ObjectId As Integer
C# | public int ObjectId { get; set; }
C++ public:
property int ObjectId {
int get();
void set(int value);
}
JScript public function get ObjectId() : int
public function set ObjectId(int);

Property Value

System.Int32

This property is read/write.


DeviceImageInformation.TextAlign Property (Microsoft.DirectX.DirectInput)

DeviceImageInformation.TextAlign Property

DWORD value that specifies the alignment of the text in the rectangle described by the RcCalloutRect member. Must be one horizontal alignment flag combined with one vertical alignment flag. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic | Public Property TextAlign As Integer
C# | public int TextAlign { get; set; }
C++ public:
property int TextAlign {
int get();
void set(int value);
}
JScript public function get TextAlign() : int
public function set TextAlign(int);

Property Value

System.Int32

This property is read/write.


DeviceImageInformation.ViewId Property (Microsoft.DirectX.DirectInput)

DeviceImageInformation.ViewId Property

For device view images (DIDIFT_CONFIGURATION), this is the identifier of the device view.

Definition

Visual Basic | Public Property ViewId As Integer
C# | public int ViewId { get; set; }
C++ public:
property int ViewId {
int get();
void set(int value);
}
JScript public function get ViewId() : int
public function set ViewId(int);

Property Value

System.Int32

This property is read/write.


DeviceImageInformation.CalloutLine Field (Microsoft.DirectX.DirectInput)

DeviceImageInformation.CalloutLine Field

Array of POINT structures that specify coordinates of the points describing a callout line. A callout line connects a device control to a caption for the game action. Each line can have from one to four segments. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic | Public CalloutLine As Point
C# | public Point CalloutLine;
C++ | public: Point CalloutLine;
JScript | public var CalloutLine : Point

Field Value

System.Drawing.Point[]

This field is read/write.


DeviceImageInformation.CalloutRectangle Field (Microsoft.DirectX.DirectInput)

DeviceImageInformation.CalloutRectangle Field

RECT structure that describes the rectangle in which the game action string is displayed. If the string cannot fit within the rectangle, the application is responsible for handling clipping. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic | Public CalloutRectangle As Rectangle
C# | public Rectangle CalloutRectangle;
C++ | public: Rectangle CalloutRectangle;
JScript | public var CalloutRectangle : Rectangle

Field Value

System.Drawing.Rectangle

This field is read/write.


DeviceImageInformation.Overlay Field (Microsoft.DirectX.DirectInput)

DeviceImageInformation.Overlay Field

Rectangle, using coordinates relative to the top-left pixel of the device configuration image, in which the overlay image should be painted. This member is valid only if the DIDIFT_OVERLAY flag is present in DwFlags.

Definition

Visual Basic | Public Overlay As Rectangle
C# | public Rectangle Overlay;
C++ | public: Rectangle Overlay;
JScript | public var Overlay : Rectangle

Field Value

System.Drawing.Rectangle

This field is read/write.


DeviceImageInformationHeader Structure (Microsoft.DirectX.DirectInput)

DeviceImageInformationHeader Structure

Contains information about device images. Used in the Inputdevice9Getimageinfo method.

Definition

Visual Basic | Public Structure DeviceImageInformationHeader
C# | public struct DeviceImageInformationHeader
C++ | public value class DeviceImageInformationHeader sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
ImageInformationArray | Pointer to a buffer that receives an array of Dideviceimageinfo structures describing all the device images and views, overlay images, and callout-string coordinates.

Methods

Method | Description
DeviceImageInformationHeader | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Buttons | DWORD variable that receives the number of buttons on the device.
NumberAxes | DWORD variable that receives the number of axes on the device.
POVs | DWORD variable that receives the number of point-of-view controllers on the device.
Views | DWORD variable that receives the number of views of this device.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceImageInformationHeader.DeviceImageInformationHeader() Constructor (Microsoft.DirectX.DirectInput)

DeviceImageInformationHeader.DeviceImageInformationHeader Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DeviceImageInformationHeader();
C++ public:
DeviceImageInformationHeader();
JScript | public function DeviceImageInformationHeader();


DeviceImageInformationHeader.ToString() Method (Microsoft.DirectX.DirectInput)

DeviceImageInformationHeader.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceImageInformationHeader.Buttons Property (Microsoft.DirectX.DirectInput)

DeviceImageInformationHeader.Buttons Property

DWORD variable that receives the number of buttons on the device.

Definition

Visual Basic | Public ReadOnly Property Buttons As Integer
C# | public int Buttons { get; }
C++ public:
property int Buttons {
int get();
}
JScript | public function get Buttons() : int

Property Value

System.Int32

This property is read-only.


DeviceImageInformationHeader.NumberAxes Property (Microsoft.DirectX.DirectInput)

DeviceImageInformationHeader.NumberAxes Property

DWORD variable that receives the number of axes on the device.

Definition

Visual Basic | Public ReadOnly Property NumberAxes As Integer
C# | public int NumberAxes { get; }
C++ public:
property int NumberAxes {
int get();
}
JScript | public function get NumberAxes() : int

Property Value

System.Int32

This property is read-only.


DeviceImageInformationHeader.POVs Property (Microsoft.DirectX.DirectInput)

DeviceImageInformationHeader.POVs Property

DWORD variable that receives the number of point-of-view controllers on the device.

Definition

Visual Basic | Public ReadOnly Property POVs As Integer
C# | public int POVs { get; }
C++ public:
property int POVs {
int get();
}
JScript | public function get POVs() : int

Property Value

System.Int32

This property is read-only.


DeviceImageInformationHeader.Views Property (Microsoft.DirectX.DirectInput)

DeviceImageInformationHeader.Views Property

DWORD variable that receives the number of views of this device.

Definition

Visual Basic | Public ReadOnly Property Views As Integer
C# | public int Views { get; }
C++ public:
property int Views {
int get();
}
JScript | public function get Views() : int

Property Value

System.Int32

This property is read-only.


DeviceImageInformationHeader.ImageInformationArray Field (Microsoft.DirectX.DirectInput)

DeviceImageInformationHeader.ImageInformationArray Field

Pointer to a buffer that receives an array of Dideviceimageinfo structures describing all the device images and views, overlay images, and callout-string coordinates.

Definition

Visual Basic | Public ImageInformationArray As DeviceImageInformation
C# | public DeviceImageInformation ImageInformationArray;
C++ | public: DeviceImageInformation ImageInformationArray;
JScript | public var ImageInformationArray : DeviceImageInformation

Field Value

Microsoft.DirectX.DirectInput.DeviceImageInformation[]

This field is read/write.


DeviceInstance Structure (Microsoft.DirectX.DirectInput)

DeviceInstance Structure

Describes an instance of a Microsoft® DirectInput® device. This structure is used with the Input9Enumdevices, Input9Enumdevicesbysemantics, and Inputdevice9Getdeviceinfo methods.

Definition

Visual Basic | Public Structure DeviceInstance
C# | public struct DeviceInstance
C++ | public value class DeviceInstance sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceInstance | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DeviceSubType | Device type specifier. The least-significant byte of the device type description code specifies the device type. The next-significant byte specifies the device subtype. This value can also be combined with DIDEVTYPE_HID, which specifies a Human Interface Device (TermHid).
DeviceType | Device type specifier. The least-significant byte of the device type description code specifies the device type. The next-significant byte specifies the device subtype. This value can also be combined with DIDEVTYPE_HID, which specifies a Human Interface Device (TermHid).
FFDriverGuid | Unique identifier for the driver being used for force feedback. The driver's manufacturer establishes this identifier.
InstanceGuid | Unique identifier for the instance of the device. An application can save the instance GUID into a configuration file and use it at a later time. Instance GUIDs are specific to a particular computer. An instance GUID obtained from one computer is unrelated to instance GUIDs on another.
InstanceName | Friendly name for the instance, for example, 'Joystick 1.'
ProductGuid | Unique identifier for the product. This identifier is established by the manufacturer of the device.
ProductName | Friendly name for the product.
Usage | If the device is a Human Interface Device (HID), this member contains the HID usage code.
UsagePage | If the device is a Human Interface Device (HID), this member contains the HID usage page code.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceInstance.DeviceInstance() Constructor (Microsoft.DirectX.DirectInput)

DeviceInstance.DeviceInstance Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DeviceInstance();
C++ public:
DeviceInstance();
JScript | public function DeviceInstance();


DeviceInstance.ToString() Method (Microsoft.DirectX.DirectInput)

DeviceInstance.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceInstance.DeviceSubType Property (Microsoft.DirectX.DirectInput)

DeviceInstance.DeviceSubType Property

Device type specifier. The least-significant byte of the device type description code specifies the device type. The next-significant byte specifies the device subtype. This value can also be combined with DIDEVTYPE_HID, which specifies a Human Interface Device (TermHid).

Definition

Visual Basic | Public ReadOnly Property DeviceSubType As Integer
C# | public int DeviceSubType { get; }
C++ public:
property int DeviceSubType {
int get();
}
JScript | public function get DeviceSubType() : int

Property Value

System.Int32

This property is read-only.


DeviceInstance.DeviceType Property (Microsoft.DirectX.DirectInput)

DeviceInstance.DeviceType Property

Device type specifier. The least-significant byte of the device type description code specifies the device type. The next-significant byte specifies the device subtype. This value can also be combined with DIDEVTYPE_HID, which specifies a Human Interface Device (TermHid).

Definition

Visual Basic | Public ReadOnly Property DeviceType As DeviceType
C# | public DeviceType DeviceType { get; }
C++ public:
property DeviceType DeviceType {
DeviceType get();
}
JScript | public function get DeviceType() : DeviceType

Property Value

Microsoft.DirectX.DirectInput.DeviceType

This property is read-only.


DeviceInstance.FFDriverGuid Property (Microsoft.DirectX.DirectInput)

DeviceInstance.FFDriverGuid Property

Unique identifier for the driver being used for force feedback. The driver's manufacturer establishes this identifier.

Definition

Visual Basic | Public ReadOnly Property FFDriverGuid As Guid
C# | public Guid FFDriverGuid { get; }
C++ public:
property Guid FFDriverGuid {
Guid get();
}
JScript | public function get FFDriverGuid() : Guid

Property Value

System.Guid

This property is read-only.


DeviceInstance.InstanceGuid Property (Microsoft.DirectX.DirectInput)

DeviceInstance.InstanceGuid Property

Unique identifier for the instance of the device. An application can save the instance GUID into a configuration file and use it at a later time. Instance GUIDs are specific to a particular computer. An instance GUID obtained from one computer is unrelated to instance GUIDs on another.

Definition

Visual Basic | Public ReadOnly Property InstanceGuid As Guid
C# | public Guid InstanceGuid { get; }
C++ public:
property Guid InstanceGuid {
Guid get();
}
JScript | public function get InstanceGuid() : Guid

Property Value

System.Guid

This property is read-only.


DeviceInstance.InstanceName Property (Microsoft.DirectX.DirectInput)

DeviceInstance.InstanceName Property

Friendly name for the instance, for example, 'Joystick 1.'

Definition

Visual Basic | Public ReadOnly Property InstanceName As String
C# | public string InstanceName { get; }
C++ public:
property String^ InstanceName {
String^ get();
}
JScript | public function get InstanceName() : String

Property Value

System.String

This property is read-only.


DeviceInstance.ProductGuid Property (Microsoft.DirectX.DirectInput)

DeviceInstance.ProductGuid Property

Unique identifier for the product. This identifier is established by the manufacturer of the device.

Definition

Visual Basic | Public ReadOnly Property ProductGuid As Guid
C# | public Guid ProductGuid { get; }
C++ public:
property Guid ProductGuid {
Guid get();
}
JScript | public function get ProductGuid() : Guid

Property Value

System.Guid

This property is read-only.


DeviceInstance.ProductName Property (Microsoft.DirectX.DirectInput)

DeviceInstance.ProductName Property

Friendly name for the product.

Definition

Visual Basic | Public ReadOnly Property ProductName As String
C# | public string ProductName { get; }
C++ public:
property String^ ProductName {
String^ get();
}
JScript | public function get ProductName() : String

Property Value

System.String

This property is read-only.


DeviceInstance.Usage Property (Microsoft.DirectX.DirectInput)

DeviceInstance.Usage Property

If the device is a Human Interface Device (HID), this member contains the HID usage code.

Definition

Visual Basic | Public ReadOnly Property Usage As Short
C# | public short Usage { get; }
C++ public:
property short Usage {
short get();
}
JScript | public function get Usage() : short

Property Value

System.Int16

This property is read-only.


DeviceInstance.UsagePage Property (Microsoft.DirectX.DirectInput)

DeviceInstance.UsagePage Property

If the device is a Human Interface Device (HID), this member contains the HID usage page code.

Definition

Visual Basic | Public ReadOnly Property UsagePage As Short
C# | public short UsagePage { get; }
C++ public:
property short UsagePage {
short get();
}
JScript | public function get UsagePage() : short

Property Value

System.Int16

This property is read-only.


DeviceObjectInstance Structure (Microsoft.DirectX.DirectInput)

DeviceObjectInstance Structure

Describes a device object instance. This structure is used with the Inputdevice9Enumobjects method to provide the Dienumdeviceobjectscallback callback function with information about a particular object associated with a device, such as an axis or button. It is also used with the Inputdevice9Getobjectinfo method to retrieve information about a device object.

Definition

Visual Basic | Public Structure DeviceObjectInstance
C# | public struct DeviceObjectInstance
C++ | public value class DeviceObjectInstance sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceObjectInstance | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
CollectionNumber | The Human Interface Device (TermHid) link collection to which the object belongs.
DesignatorIndex | An index that refers to a designator in the HID physical descriptor. This number can be passed to functions in the HID parsing library (Hidpi.h) to obtain additional information about the device object.
Dimension | A Human Interface Device (HID) code for the dimensional units in which the object's value is reported, if known, or 0 if not known.
Exponent | The exponent to associate with the dimension, if known. Dimensional units are always integral, so an exponent might be needed to convert them to nonintegral types.
Flags | Flags describing other attributes of the data format. This value can be one of the following:
ForceResolution | The force resolution of the actuator associated with this object. The returned value represents the number of gradations, or subdivisions, of the maximum force that can be expressed by the force-feedback system from 0 (no force) to maximum force.
MaxForce | The magnitude of the maximum force that can be created by the actuator associated with this object. Force is expressed in newtons and measured in relation to where the hand would be during normal operation of the device.
Name | Name of the object, for example, 'X-Axis' or 'Right Shift.'
ObjectId | An index that refers to a designator in the HID physical descriptor. This number can be passed to functions in the HID parsing library (Hidpi.h) to obtain additional information about the device object.
ObjectType | Unique identifier that indicates the object type. This member is optional. If present, it can be one of the following values:
Offset | Offset in the native data format of the device. The native data format corresponds to the raw device data. The DwOfs member does not correspond to the device constant, such as DIJOFS_BUTTON0, for this object.
ReportId | Reserved.
Usage | The HID usage associated with the object, if known. HIDs always report a usage. Non-HIDs can optionally report a usage; if they do not, the value of this member is 0.
UsagePage | The Human Interface Device (HID) usage page associated with the object, if known. HIDs always report a usage page. Non-HID devices can optionally report a usage page; if they do not, the value of this member is 0.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeviceObjectInstance.DeviceObjectInstance() Constructor (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.DeviceObjectInstance Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public DeviceObjectInstance();
C++ public:
DeviceObjectInstance();
JScript | public function DeviceObjectInstance();


DeviceObjectInstance.ToString() Method (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceObjectInstance.CollectionNumber Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.CollectionNumber Property

The Human Interface Device (TermHid) link collection to which the object belongs.

Definition

Visual Basic | Public Property CollectionNumber As Short
C# | public short CollectionNumber { get; set; }
C++ public:
property short CollectionNumber {
short get();
void set(short value);
}
JScript public function get CollectionNumber() : short
public function set CollectionNumber(short);

Property Value

System.Int16

This property is read/write.


DeviceObjectInstance.DesignatorIndex Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.DesignatorIndex Property

An index that refers to a designator in the HID physical descriptor. This number can be passed to functions in the HID parsing library (Hidpi.h) to obtain additional information about the device object.

Definition

Visual Basic | Public Property DesignatorIndex As Short
C# | public short DesignatorIndex { get; set; }
C++ public:
property short DesignatorIndex {
short get();
void set(short value);
}
JScript public function get DesignatorIndex() : short
public function set DesignatorIndex(short);

Property Value

System.Int16

This property is read/write.


DeviceObjectInstance.Dimension Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.Dimension Property

A Human Interface Device (HID) code for the dimensional units in which the object's value is reported, if known, or 0 if not known.

Definition

Visual Basic | Public Property Dimension As Integer
C# | public int Dimension { get; set; }
C++ public:
property int Dimension {
int get();
void set(int value);
}
JScript public function get Dimension() : int
public function set Dimension(int);

Property Value

System.Int32

This property is read/write.


DeviceObjectInstance.Exponent Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.Exponent Property

The exponent to associate with the dimension, if known. Dimensional units are always integral, so an exponent might be needed to convert them to nonintegral types.

Definition

Visual Basic | Public Property Exponent As Short
C# | public short Exponent { get; set; }
C++ public:
property short Exponent {
short get();
void set(short value);
}
JScript public function get Exponent() : short
public function set Exponent(short);

Property Value

System.Int16

This property is read/write.


DeviceObjectInstance.Flags Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.Flags Property

Flags describing other attributes of the data format. This value can be one of the following:

Definition

Visual Basic | Public Property Flags As Integer
C# | public int Flags { get; set; }
C++ public:
property int Flags {
int get();
void set(int value);
}
JScript public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32

This property is read/write.


DeviceObjectInstance.ForceResolution Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.ForceResolution Property

The force resolution of the actuator associated with this object. The returned value represents the number of gradations, or subdivisions, of the maximum force that can be expressed by the force-feedback system from 0 (no force) to maximum force.

Definition

Visual Basic | Public Property ForceResolution As Integer
C# | public int ForceResolution { get; set; }
C++ public:
property int ForceResolution {
int get();
void set(int value);
}
JScript public function get ForceResolution() : int
public function set ForceResolution(int);

Property Value

System.Int32

This property is read/write.


DeviceObjectInstance.MaxForce Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.MaxForce Property

The magnitude of the maximum force that can be created by the actuator associated with this object. Force is expressed in newtons and measured in relation to where the hand would be during normal operation of the device.

Definition

Visual Basic | Public Property MaxForce As Integer
C# | public int MaxForce { get; set; }
C++ public:
property int MaxForce {
int get();
void set(int value);
}
JScript public function get MaxForce() : int
public function set MaxForce(int);

Property Value

System.Int32

This property is read/write.


DeviceObjectInstance.Name Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.Name Property

Name of the object, for example, 'X-Axis' or 'Right Shift.'

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String

This property is read/write.


DeviceObjectInstance.ObjectId Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.ObjectId Property

An index that refers to a designator in the HID physical descriptor. This number can be passed to functions in the HID parsing library (Hidpi.h) to obtain additional information about the device object.

Definition

Visual Basic | Public Property ObjectId As Integer
C# | public int ObjectId { get; set; }
C++ public:
property int ObjectId {
int get();
void set(int value);
}
JScript public function get ObjectId() : int
public function set ObjectId(int);

Property Value

System.Int32

This property is read/write.


DeviceObjectInstance.ObjectType Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.ObjectType Property

Unique identifier that indicates the object type. This member is optional. If present, it can be one of the following values:

Definition

Visual Basic | Public Property ObjectType As Guid
C# | public Guid ObjectType { get; set; }
C++ public:
property Guid ObjectType {
Guid get();
void set(Guid value);
}
JScript public function get ObjectType() : Guid
public function set ObjectType(Guid);

Property Value

System.Guid

This property is read/write.


DeviceObjectInstance.Offset Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.Offset Property

Offset in the native data format of the device. The native data format corresponds to the raw device data. The DwOfs member does not correspond to the device constant, such as DIJOFS_BUTTON0, for this object.

Definition

Visual Basic | Public Property Offset As Integer
C# | public int Offset { get; set; }
C++ public:
property int Offset {
int get();
void set(int value);
}
JScript public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32

This property is read/write.


DeviceObjectInstance.ReportId Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.ReportId Property

Reserved.

Definition

Visual Basic | Public Property ReportId As Short
C# | public short ReportId { get; set; }
C++ public:
property short ReportId {
short get();
void set(short value);
}
JScript public function get ReportId() : short
public function set ReportId(short);

Property Value

System.Int16

This property is read/write.


DeviceObjectInstance.Usage Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.Usage Property

The HID usage associated with the object, if known. HIDs always report a usage. Non-HIDs can optionally report a usage; if they do not, the value of this member is 0.

Definition

Visual Basic | Public Property Usage As Short
C# | public short Usage { get; set; }
C++ public:
property short Usage {
short get();
void set(short value);
}
JScript public function get Usage() : short
public function set Usage(short);

Property Value

System.Int16

This property is read/write.


DeviceObjectInstance.UsagePage Property (Microsoft.DirectX.DirectInput)

DeviceObjectInstance.UsagePage Property

The Human Interface Device (HID) usage page associated with the object, if known. HIDs always report a usage page. Non-HID devices can optionally report a usage page; if they do not, the value of this member is 0.

Definition

Visual Basic | Public Property UsagePage As Short
C# | public short UsagePage { get; set; }
C++ public:
property short UsagePage {
short get();
void set(short value);
}
JScript public function get UsagePage() : short
public function set UsagePage(short);

Property Value

System.Int16

This property is read/write.


Effect Structure (Microsoft.DirectX.DirectInput)

Effect Structure

Used by the Inputdevice9Createeffect method to initialize a new Inputeffect object. It is also used by the InputeffectSetparameters and InputeffectGetparameters methods.

Definition

Visual Basic | Public Structure Effect
C# | public struct Effect
C++ | public value class Effect sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
ConditionStruct
Constant
CustomStruct
EnvelopeStruct
Periodic | Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.
RampStruct

Methods

Method | Description
Effect | Initializes a new instance of the object.
GetAxes
GetDirection
SetAxes
SetDirection
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Duration | The total duration of the effect, in microseconds. If this value is INFINITE, the effect has infinite duration. If an TermEnvelope has been applied to the effect, the TermAttack is applied, followed by an infinite TermSustain.
EffectType
Flags | Flags associated with the effect. This value can be a combination of one or more of the following values:
Gain | The gain to be applied to the effect, in the range from 0 through 10,000. The gain is a scaling factor applied to all magnitudes of the effect and its envelope.
SamplePeriod | The period at which the device should play back the effect, in microseconds. A value of 0 indicates that the default playback sample rate should be used. If the device is not capable of playing back the effect at the specified rate, it chooses the supported rate that is closest to the requested value.Setting a custom DwSamplePeriod can be used for special effects. For example, playing a sine wave at an artificially large sample period results in a rougher texture.
StartDelay | Time (in microseconds) that the device should wait after a InputeffectStart call before playing the effect. If this value is 0, effect playback begins immediately. This member is not present in versions prior to Microsoft® DirectX® 7.0.
TriggerButton | The identifier or offset of the button to be used to trigger playback of the effect. The flags DIEFF_OBJECTIDS and DIEFF_OBJECTOFFSETS determine the semantics of the value. If this member is set to DIEB_NOTRIGGER, no trigger button is associated with the effect.
TriggerRepeatInterval | The interval, in microseconds, between the end of one playback and the start of the next when the effect is triggered by a button press and the button is held down. Setting this value to INFINITE suppresses repetition. Support for trigger repeat for an effect is indicated by the presence of the DIEP_TRIGGERREPEATINTERVAL flag in the dwStaticParams member of the Dieffectinfo structure.
UsesEnvelope | Used by the Dieffect structure to specify the optional TermEnvelope parameters for an effect. The TermSustain level for the envelope is represented by the dwMagnitude member of the Diperiodic structure and the lMagnitude member of the Diconstantforce structure. The sustain time is represented by dwDuration member of the Dieffect structure.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Effect.Effect() Constructor (Microsoft.DirectX.DirectInput)

Effect.Effect Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public Effect();
C++ public:
Effect();
JScript | public function Effect();


Effect.GetAxes() Method (Microsoft.DirectX.DirectInput)

Effect.GetAxes Method

Definition

Visual Basic | Public Function GetAxes() As Integer()
C# | public int[] GetAxes();
C++ public:
array<int>^ GetAxes();
JScript | public function GetAxes() : int[];

Return Value

System.Int32[]


Effect.GetDirection() Method (Microsoft.DirectX.DirectInput)

Effect.GetDirection Method

Definition

Visual Basic | Public Function GetDirection() As Integer()
C# | public int[] GetDirection();
C++ public:
array<int>^ GetDirection();
JScript | public function GetDirection() : int[];

Return Value

System.Int32[]


Effect.SetAxes(Int32[]) Method (Microsoft.DirectX.DirectInput)

Effect.SetAxes Method

Definition

Visual Basic Public Sub SetAxes( _
ByVal value() As Integer _
)
C# public void SetAxes(
int[] value
);
C++ public:
void SetAxes(
array<int>^ value
);
JScript public function SetAxes(
value : int[]
);

Parameters

value System.Int32[]


Effect.SetDirection(Int32[]) Method (Microsoft.DirectX.DirectInput)

Effect.SetDirection Method

Definition

Visual Basic Public Sub SetDirection( _
ByVal value() As Integer _
)
C# public void SetDirection(
int[] value
);
C++ public:
void SetDirection(
array<int>^ value
);
JScript public function SetDirection(
value : int[]
);

Parameters

value System.Int32[]


Effect.ToString() Method (Microsoft.DirectX.DirectInput)

Effect.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Effect.Duration Property (Microsoft.DirectX.DirectInput)

Effect.Duration Property

The total duration of the effect, in microseconds. If this value is INFINITE, the effect has infinite duration. If an TermEnvelope has been applied to the effect, the TermAttack is applied, followed by an infinite TermSustain.

Definition

Visual Basic | Public Property Duration As Integer
C# | public int Duration { get; set; }
C++ public:
property int Duration {
int get();
void set(int value);
}
JScript public function get Duration() : int
public function set Duration(int);

Property Value

System.Int32

This property is read/write.


Effect.EffectType Property (Microsoft.DirectX.DirectInput)

Effect.EffectType Property

Definition

Visual Basic | Public Property EffectType As EffectType
C# | public EffectType EffectType { get; set; }
C++ public:
property EffectType EffectType {
EffectType get();
void set(EffectType value);
}
JScript public function get EffectType() : EffectType
public function set EffectType(EffectType);

Property Value

Microsoft.DirectX.DirectInput.EffectType

This property is read/write.


Effect.Flags Property (Microsoft.DirectX.DirectInput)

Effect.Flags Property

Flags associated with the effect. This value can be a combination of one or more of the following values:

Definition

Visual Basic | Public Property Flags As EffectFlags
C# | public EffectFlags Flags { get; set; }
C++ public:
property EffectFlags Flags {
EffectFlags get();
void set(EffectFlags value);
}
JScript public function get Flags() : EffectFlags
public function set Flags(EffectFlags);

Property Value

Microsoft.DirectX.DirectInput.EffectFlags

This property is read/write.


Effect.Gain Property (Microsoft.DirectX.DirectInput)

Effect.Gain Property

The gain to be applied to the effect, in the range from 0 through 10,000. The gain is a scaling factor applied to all magnitudes of the effect and its envelope.

Definition

Visual Basic | Public Property Gain As Integer
C# | public int Gain { get; set; }
C++ public:
property int Gain {
int get();
void set(int value);
}
JScript public function get Gain() : int
public function set Gain(int);

Property Value

System.Int32

This property is read/write.


Effect.SamplePeriod Property (Microsoft.DirectX.DirectInput)

Effect.SamplePeriod Property

The period at which the device should play back the effect, in microseconds. A value of 0 indicates that the default playback sample rate should be used. If the device is not capable of playing back the effect at the specified rate, it chooses the supported rate that is closest to the requested value.Setting a custom DwSamplePeriod can be used for special effects. For example, playing a sine wave at an artificially large sample period results in a rougher texture.

Definition

Visual Basic | Public Property SamplePeriod As Integer
C# | public int SamplePeriod { get; set; }
C++ public:
property int SamplePeriod {
int get();
void set(int value);
}
JScript public function get SamplePeriod() : int
public function set SamplePeriod(int);

Property Value

System.Int32

This property is read/write.


Effect.StartDelay Property (Microsoft.DirectX.DirectInput)

Effect.StartDelay Property

Time (in microseconds) that the device should wait after a InputeffectStart call before playing the effect. If this value is 0, effect playback begins immediately. This member is not present in versions prior to Microsoft® DirectX® 7.0.

Definition

Visual Basic | Public Property StartDelay As Integer
C# | public int StartDelay { get; set; }
C++ public:
property int StartDelay {
int get();
void set(int value);
}
JScript public function get StartDelay() : int
public function set StartDelay(int);

Property Value

System.Int32

This property is read/write.


Effect.TriggerButton Property (Microsoft.DirectX.DirectInput)

Effect.TriggerButton Property

The identifier or offset of the button to be used to trigger playback of the effect. The flags DIEFF_OBJECTIDS and DIEFF_OBJECTOFFSETS determine the semantics of the value. If this member is set to DIEB_NOTRIGGER, no trigger button is associated with the effect.

Definition

Visual Basic | Public Property TriggerButton As Integer
C# | public int TriggerButton { get; set; }
C++ public:
property int TriggerButton {
int get();
void set(int value);
}
JScript public function get TriggerButton() : int
public function set TriggerButton(int);

Property Value

System.Int32

This property is read/write.


Effect.TriggerRepeatInterval Property (Microsoft.DirectX.DirectInput)

Effect.TriggerRepeatInterval Property

The interval, in microseconds, between the end of one playback and the start of the next when the effect is triggered by a button press and the button is held down. Setting this value to INFINITE suppresses repetition. Support for trigger repeat for an effect is indicated by the presence of the DIEP_TRIGGERREPEATINTERVAL flag in the dwStaticParams member of the Dieffectinfo structure.

Definition

Visual Basic | Public Property TriggerRepeatInterval As Integer
C# | public int TriggerRepeatInterval { get; set; }
C++ public:
property int TriggerRepeatInterval {
int get();
void set(int value);
}
JScript public function get TriggerRepeatInterval() : int
public function set TriggerRepeatInterval(int);

Property Value

System.Int32

This property is read/write.


Effect.UsesEnvelope Property (Microsoft.DirectX.DirectInput)

Effect.UsesEnvelope Property

Used by the Dieffect structure to specify the optional TermEnvelope parameters for an effect. The TermSustain level for the envelope is represented by the dwMagnitude member of the Diperiodic structure and the lMagnitude member of the Diconstantforce structure. The sustain time is represented by dwDuration member of the Dieffect structure.

Definition

Visual Basic | Public Property UsesEnvelope As Boolean
C# | public bool UsesEnvelope { get; set; }
C++ public:
property bool UsesEnvelope {
bool get();
void set(bool value);
}
JScript public function get UsesEnvelope() : boolean
public function set UsesEnvelope(boolean);

Property Value

System.Boolean

This property is read/write.


Effect.ConditionStruct Field (Microsoft.DirectX.DirectInput)

Effect.ConditionStruct Field

Definition

Visual Basic | Public ConditionStruct As Condition
C# | public Condition ConditionStruct;
C++ | public: Condition ConditionStruct;
JScript | public var ConditionStruct : Condition

Field Value

Microsoft.DirectX.DirectInput.Condition[]

This field is read/write.


Effect.Constant Field (Microsoft.DirectX.DirectInput)

Effect.Constant Field

Definition

Visual Basic | Public Constant As ConstantForce
C# | public ConstantForce Constant;
C++ | public: ConstantForce Constant;
JScript | public var Constant : ConstantForce

Field Value

Microsoft.DirectX.DirectInput.ConstantForce

This field is read/write.


Effect.CustomStruct Field (Microsoft.DirectX.DirectInput)

Effect.CustomStruct Field

Definition

Visual Basic | Public CustomStruct As CustomForce
C# | public CustomForce CustomStruct;
C++ | public: CustomForce CustomStruct;
JScript | public var CustomStruct : CustomForce

Field Value

Microsoft.DirectX.DirectInput.CustomForce

This field is read/write.


Effect.EnvelopeStruct Field (Microsoft.DirectX.DirectInput)

Effect.EnvelopeStruct Field

Definition

Visual Basic | Public EnvelopeStruct As Envelope
C# | public Envelope EnvelopeStruct;
C++ | public: Envelope EnvelopeStruct;
JScript | public var EnvelopeStruct : Envelope

Field Value

Microsoft.DirectX.DirectInput.Envelope

This field is read/write.


Effect.Periodic Field (Microsoft.DirectX.DirectInput)

Effect.Periodic Field

Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic | Public Periodic As Periodic
C# | public Periodic Periodic;
C++ | public: Periodic Periodic;
JScript | public var Periodic : Periodic

Field Value

Microsoft.DirectX.DirectInput.Periodic

This field is read/write.


Effect.RampStruct Field (Microsoft.DirectX.DirectInput)

Effect.RampStruct Field

Definition

Visual Basic | Public RampStruct As RampForce
C# | public RampForce RampStruct;
C++ | public: RampForce RampStruct;
JScript | public var RampStruct : RampForce

Field Value

Microsoft.DirectX.DirectInput.RampForce

This field is read/write.


EffectInformation Structure (Microsoft.DirectX.DirectInput)

EffectInformation Structure

Used by the Inputdevice9Enumeffects and Inputdevice9Geteffectinfo methods to return information about a particular effect supported by a device.

Definition

Visual Basic | Public Structure EffectInformation
C# | public struct EffectInformation
C++ | public value class EffectInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectInformation | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DynamicParams | Zero or more DIEP_* values denoting parameters of the effect that can be modified while the effect is playing. For a list of possible values, see InputeffectGetparameters. If an application attempts to change a parameter while the effect is playing and the driver does not support modifying that effect dynamically, the driver is permitted to stop the effect, update the parameters, then restart it. For more information, see InputeffectSetparameters.
EffectGuid | Identifier of the effect.
EffectType | Zero or more of the following values:
Name | Name of the effect, for example, 'Sawtooth up' or 'Constant force'.
StaticParams | Zero or more DIEP_* values describing the parameters supported by the effect. For example, if DIEP_ENVELOPE is set, the effect supports an envelope. For a list of possible values, see InputeffectGetparameters. It is not an error for an application to attempt to use effect parameters that are not supported by the device. The unsupported parameters are ignored.This information is provided to enable the application to tailor its use of force feedback to the capabilities of the specific device.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectInformation.EffectInformation() Constructor (Microsoft.DirectX.DirectInput)

EffectInformation.EffectInformation Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public EffectInformation();
C++ public:
EffectInformation();
JScript | public function EffectInformation();


EffectInformation.ToString() Method (Microsoft.DirectX.DirectInput)

EffectInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectInformation.DynamicParams Property (Microsoft.DirectX.DirectInput)

EffectInformation.DynamicParams Property

Zero or more DIEP_* values denoting parameters of the effect that can be modified while the effect is playing. For a list of possible values, see InputeffectGetparameters. If an application attempts to change a parameter while the effect is playing and the driver does not support modifying that effect dynamically, the driver is permitted to stop the effect, update the parameters, then restart it. For more information, see InputeffectSetparameters.

Definition

Visual Basic | Public Property DynamicParams As Integer
C# | public int DynamicParams { get; set; }
C++ public:
property int DynamicParams {
int get();
void set(int value);
}
JScript public function get DynamicParams() : int
public function set DynamicParams(int);

Property Value

System.Int32

This property is read/write.


EffectInformation.EffectGuid Property (Microsoft.DirectX.DirectInput)

EffectInformation.EffectGuid Property

Identifier of the effect.

Definition

Visual Basic | Public Property EffectGuid As Guid
C# | public Guid EffectGuid { get; set; }
C++ public:
property Guid EffectGuid {
Guid get();
void set(Guid value);
}
JScript public function get EffectGuid() : Guid
public function set EffectGuid(Guid);

Property Value

System.Guid

This property is read/write.


EffectInformation.EffectType Property (Microsoft.DirectX.DirectInput)

EffectInformation.EffectType Property

Zero or more of the following values:

Definition

Visual Basic | Public Property EffectType As Integer
C# | public int EffectType { get; set; }
C++ public:
property int EffectType {
int get();
void set(int value);
}
JScript public function get EffectType() : int
public function set EffectType(int);

Property Value

System.Int32

This property is read/write.


EffectInformation.Name Property (Microsoft.DirectX.DirectInput)

EffectInformation.Name Property

Name of the effect, for example, 'Sawtooth up' or 'Constant force'.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String

This property is read/write.


EffectInformation.StaticParams Property (Microsoft.DirectX.DirectInput)

EffectInformation.StaticParams Property

Zero or more DIEP_* values describing the parameters supported by the effect. For example, if DIEP_ENVELOPE is set, the effect supports an envelope. For a list of possible values, see InputeffectGetparameters. It is not an error for an application to attempt to use effect parameters that are not supported by the device. The unsupported parameters are ignored.This information is provided to enable the application to tailor its use of force feedback to the capabilities of the specific device.

Definition

Visual Basic | Public Property StaticParams As Integer
C# | public int StaticParams { get; set; }
C++ public:
property int StaticParams {
int get();
void set(int value);
}
JScript public function get StaticParams() : int
public function set StaticParams(int);

Property Value

System.Int32

This property is read/write.


EffectStatus Structure (Microsoft.DirectX.DirectInput)

EffectStatus Structure

Definition

Visual Basic | Public Structure EffectStatus
C# | public struct EffectStatus
C++ | public value class EffectStatus sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectStatus | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Emulated
Playing | The effect is playing.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectStatus.EffectStatus() Constructor (Microsoft.DirectX.DirectInput)

EffectStatus.EffectStatus Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public EffectStatus();
C++ public:
EffectStatus();
JScript | public function EffectStatus();


EffectStatus.ToString() Method (Microsoft.DirectX.DirectInput)

EffectStatus.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectStatus.Emulated Property (Microsoft.DirectX.DirectInput)

EffectStatus.Emulated Property

Definition

Visual Basic | Public ReadOnly Property Emulated As Boolean
C# | public bool Emulated { get; }
C++ public:
property bool Emulated {
bool get();
}
JScript | public function get Emulated() : boolean

Property Value

System.Boolean

This property is read-only.


EffectStatus.Playing Property (Microsoft.DirectX.DirectInput)

EffectStatus.Playing Property

The effect is playing.

Definition

Visual Basic | Public ReadOnly Property Playing As Boolean
C# | public bool Playing { get; }
C++ public:
property bool Playing {
bool get();
}
JScript | public function get Playing() : boolean

Property Value

System.Boolean

This property is read-only.


Envelope Structure (Microsoft.DirectX.DirectInput)

Envelope Structure

Used by the Dieffect structure to specify the optional TermEnvelope parameters for an effect. The TermSustain level for the envelope is represented by the dwMagnitude member of the Diperiodic structure and the lMagnitude member of the Diconstantforce structure. The sustain time is represented by dwDuration member of the Dieffect structure.

Definition

Visual Basic | Public Structure Envelope
C# | public struct Envelope
C++ | public value class Envelope sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Envelope | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
AttackLevel | Amplitude for the start of the envelope, relative to the baseline, in the range from 0 through 10,000. If the effect's type-specific data does not specify a baseline, the amplitude is relative to 0.
AttackTime | The time, in microseconds, to reach the TermSustain level.
FadeLevel | Amplitude for the end of the envelope, relative to the baseline, in the range from 0 through 10,000. If the effect's type-specific data does not specify a baseline, the amplitude is relative to 0.
FadeTime | The time, in microseconds, to reach the fade level.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Envelope.Envelope() Constructor (Microsoft.DirectX.DirectInput)

Envelope.Envelope Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public Envelope();
C++ public:
Envelope();
JScript | public function Envelope();


Envelope.ToString() Method (Microsoft.DirectX.DirectInput)

Envelope.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Envelope.AttackLevel Property (Microsoft.DirectX.DirectInput)

Envelope.AttackLevel Property

Amplitude for the start of the envelope, relative to the baseline, in the range from 0 through 10,000. If the effect's type-specific data does not specify a baseline, the amplitude is relative to 0.

Definition

Visual Basic | Public Property AttackLevel As Integer
C# | public int AttackLevel { get; set; }
C++ public:
property int AttackLevel {
int get();
void set(int value);
}
JScript public function get AttackLevel() : int
public function set AttackLevel(int);

Property Value

System.Int32

This property is read/write.


Envelope.AttackTime Property (Microsoft.DirectX.DirectInput)

Envelope.AttackTime Property

The time, in microseconds, to reach the TermSustain level.

Definition

Visual Basic | Public Property AttackTime As Integer
C# | public int AttackTime { get; set; }
C++ public:
property int AttackTime {
int get();
void set(int value);
}
JScript public function get AttackTime() : int
public function set AttackTime(int);

Property Value

System.Int32

This property is read/write.


Envelope.FadeLevel Property (Microsoft.DirectX.DirectInput)

Envelope.FadeLevel Property

Amplitude for the end of the envelope, relative to the baseline, in the range from 0 through 10,000. If the effect's type-specific data does not specify a baseline, the amplitude is relative to 0.

Definition

Visual Basic | Public Property FadeLevel As Integer
C# | public int FadeLevel { get; set; }
C++ public:
property int FadeLevel {
int get();
void set(int value);
}
JScript public function get FadeLevel() : int
public function set FadeLevel(int);

Property Value

System.Int32

This property is read/write.


Envelope.FadeTime Property (Microsoft.DirectX.DirectInput)

Envelope.FadeTime Property

The time, in microseconds, to reach the fade level.

Definition

Visual Basic | Public Property FadeTime As Integer
C# | public int FadeTime { get; set; }
C++ public:
property int FadeTime {
int get();
void set(int value);
}
JScript public function get FadeTime() : int
public function set FadeTime(int);

Property Value

System.Int32

This property is read/write.


FileEffect Structure (Microsoft.DirectX.DirectInput)

FileEffect Structure

Describes data for a force-feedback effect stored in a file. It is used in conjunction with the Inputdevice9Enumeffectsinfile and Inputdevice9Writeeffecttofile methods.

Definition

Visual Basic | Public Structure FileEffect
C# | public struct FileEffect
C++ | public value class FileEffect sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
EffectStruct | Pointer to a Dieffect structure containing information about the effect.

Methods

Method | Description
FileEffect | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
EffectGuid | Unique identifier of the effect type. This can be one of the standard GUIDs defined in Dinput.h, such as GUID_ConstantForce, or one created by the designer.
Name | Name of the effect.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FileEffect.FileEffect() Constructor (Microsoft.DirectX.DirectInput)

FileEffect.FileEffect Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public FileEffect();
C++ public:
FileEffect();
JScript | public function FileEffect();


FileEffect.ToString() Method (Microsoft.DirectX.DirectInput)

FileEffect.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FileEffect.EffectGuid Property (Microsoft.DirectX.DirectInput)

FileEffect.EffectGuid Property

Unique identifier of the effect type. This can be one of the standard GUIDs defined in Dinput.h, such as GUID_ConstantForce, or one created by the designer.

Definition

Visual Basic | Public Property EffectGuid As Guid
C# | public Guid EffectGuid { get; set; }
C++ public:
property Guid EffectGuid {
Guid get();
void set(Guid value);
}
JScript public function get EffectGuid() : Guid
public function set EffectGuid(Guid);

Property Value

System.Guid

This property is read/write.


FileEffect.Name Property (Microsoft.DirectX.DirectInput)

FileEffect.Name Property

Name of the effect.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String

This property is read/write.


FileEffect.EffectStruct Field (Microsoft.DirectX.DirectInput)

FileEffect.EffectStruct Field

Pointer to a Dieffect structure containing information about the effect.

Definition

Visual Basic | Public EffectStruct As Effect
C# | public Effect EffectStruct;
C++ | public: Effect EffectStruct;
JScript | public var EffectStruct : Effect

Field Value

Microsoft.DirectX.DirectInput.Effect

This field is read/write.


InputRange Structure (Microsoft.DirectX.DirectInput)

InputRange Structure

Definition

Visual Basic | Public Structure InputRange
C# | public struct InputRange
C++ | public value class InputRange sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
InputRange | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property Description
Max
Min

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputRange.InputRange(Int32,Int32) Constructor (Microsoft.DirectX.DirectInput)

InputRange.InputRange Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal minimumRange As Integer, _
ByVal maximumRange As Integer _
)
C# public InputRange(
int minimumRange,
int maximumRange
);
C++ public:
InputRange(
int minimumRange,
int maximumRange
);
JScript public function InputRange(
minimumRange : int,
maximumRange : int
);

Parameters

minimumRange System.Int32
maximumRange System.Int32


InputRange.ToString() Method (Microsoft.DirectX.DirectInput)

InputRange.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


InputRange.Max Property (Microsoft.DirectX.DirectInput)

InputRange.Max Property

Definition

Visual Basic | Public Property Max As Integer
C# | public int Max { get; set; }
C++ public:
property int Max {
int get();
void set(int value);
}
JScript public function get Max() : int
public function set Max(int);

Property Value

System.Int32

This property is read/write.


InputRange.Min Property (Microsoft.DirectX.DirectInput)

InputRange.Min Property

Definition

Visual Basic | Public Property Min As Integer
C# | public int Min { get; set; }
C++ public:
property int Min {
int get();
void set(int value);
}
JScript public function get Min() : int
public function set Min(int);

Property Value

System.Int32

This property is read/write.


JoystickState Structure (Microsoft.DirectX.DirectInput)

JoystickState Structure

Describes the state of a joystick device. This structure is used with the Inputdevice9Getdevicestate method.

Definition

Visual Basic | Public Structure JoystickState
C# | public struct JoystickState
C++ | public value class JoystickState sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetASlider | Extra axis accelerations.
GetButtons | Array of buttons. The high-order bit of the byte is set if the corresponding button is down, and clear if the button is up or does not exist.
GetFSlider | Extra axis forces.
GetPointOfView | Direction controllers, such as point-of-view hats. The position is indicated in hundredths of a degree clockwise from north (away from the user). The center position is normally reported as -1; but see Remarks. For indicators that have only five positions, the value for a controller is -1, 0, 9,000, 18,000, or 27,000.
GetSlider | Two additional axes, formerly called the u-axis and v-axis, whose semantics depend on the joystick. Use the Inputdevice9Getobjectinfo method to obtain semantic information about these values.
GetVSlider | Extra axis velocities.
JoystickState | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ARx | X-axis angular acceleration.
ARy | Y-axis angular acceleration.
ARz | Z-axis angular acceleration.
AX | X-axis acceleration.
AY | Y-axis acceleration.
AZ | Z-axis acceleration.
FRx | X-axis torque.
FRy | Y-axis torque.
FRz | Z-axis torque.
FX | X-axis force.
FY | Y-axis force.
FZ | Z-axis force.
Rx | X-axis rotation. If the joystick does not have this axis, the value is 0.
Ry | Y-axis rotation. If the joystick does not have this axis, the value is 0.
Rz | Z-axis rotation (often called the rudder). If the joystick does not have this axis, the value is 0.
VRx | X-axis angular velocity.
VRy | Y-axis angular velocity.
VRz | Z-axis angular velocity.
VX | X-axis velocity.
VY | Y-axis velocity.
VZ | Z-axis velocity.
X | X-axis, usually the left-right movement of a stick.
Y | Y-axis, usually the forward-backward movement of a stick.
Z | Z-axis, often the throttle control. If the joystick does not have this axis, the value is 0.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


JoystickState.GetASlider() Method (Microsoft.DirectX.DirectInput)

JoystickState.GetASlider Method

Extra axis accelerations.

Definition

Visual Basic | Public Function GetASlider() As Integer()
C# | public int[] GetASlider();
C++ public:
array<int>^ GetASlider();
JScript | public function GetASlider() : int[];

Return Value

System.Int32[]


JoystickState.GetButtons() Method (Microsoft.DirectX.DirectInput)

JoystickState.GetButtons Method

Array of buttons. The high-order bit of the byte is set if the corresponding button is down, and clear if the button is up or does not exist.

Definition

Visual Basic | Public Function GetButtons() As Byte()
C# | public byte[] GetButtons();
C++ public:
array<unsigned char>^ GetButtons();
JScript | public function GetButtons() : byte[];

Return Value

System.Byte[]


JoystickState.GetFSlider() Method (Microsoft.DirectX.DirectInput)

JoystickState.GetFSlider Method

Extra axis forces.

Definition

Visual Basic | Public Function GetFSlider() As Integer()
C# | public int[] GetFSlider();
C++ public:
array<int>^ GetFSlider();
JScript | public function GetFSlider() : int[];

Return Value

System.Int32[]


JoystickState.GetPointOfView() Method (Microsoft.DirectX.DirectInput)

JoystickState.GetPointOfView Method

Direction controllers, such as point-of-view hats. The position is indicated in hundredths of a degree clockwise from north (away from the user). The center position is normally reported as -1; but see Remarks. For indicators that have only five positions, the value for a controller is -1, 0, 9,000, 18,000, or 27,000.

Definition

Visual Basic | Public Function GetPointOfView() As Integer()
C# | public int[] GetPointOfView();
C++ public:
array<int>^ GetPointOfView();
JScript | public function GetPointOfView() : int[];

Return Value

System.Int32[]


JoystickState.GetSlider() Method (Microsoft.DirectX.DirectInput)

JoystickState.GetSlider Method

Two additional axes, formerly called the u-axis and v-axis, whose semantics depend on the joystick. Use the Inputdevice9Getobjectinfo method to obtain semantic information about these values.

Definition

Visual Basic | Public Function GetSlider() As Integer()
C# | public int[] GetSlider();
C++ public:
array<int>^ GetSlider();
JScript | public function GetSlider() : int[];

Return Value

System.Int32[]


JoystickState.GetVSlider() Method (Microsoft.DirectX.DirectInput)

JoystickState.GetVSlider Method

Extra axis velocities.

Definition

Visual Basic | Public Function GetVSlider() As Integer()
C# | public int[] GetVSlider();
C++ public:
array<int>^ GetVSlider();
JScript | public function GetVSlider() : int[];

Return Value

System.Int32[]


JoystickState.JoystickState() Constructor (Microsoft.DirectX.DirectInput)

JoystickState.JoystickState Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public JoystickState();
C++ public:
JoystickState();
JScript | public function JoystickState();


JoystickState.ToString() Method (Microsoft.DirectX.DirectInput)

JoystickState.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


JoystickState.ARx Property (Microsoft.DirectX.DirectInput)

JoystickState.ARx Property

X-axis angular acceleration.

Definition

Visual Basic | Public ReadOnly Property ARx As Integer
C# | public int ARx { get; }
C++ public:
property int ARx {
int get();
}
JScript | public function get ARx() : int

Property Value

System.Int32

This property is read-only.


JoystickState.ARy Property (Microsoft.DirectX.DirectInput)

JoystickState.ARy Property

Y-axis angular acceleration.

Definition

Visual Basic | Public ReadOnly Property ARy As Integer
C# | public int ARy { get; }
C++ public:
property int ARy {
int get();
}
JScript | public function get ARy() : int

Property Value

System.Int32

This property is read-only.


JoystickState.ARz Property (Microsoft.DirectX.DirectInput)

JoystickState.ARz Property

Z-axis angular acceleration.

Definition

Visual Basic | Public ReadOnly Property ARz As Integer
C# | public int ARz { get; }
C++ public:
property int ARz {
int get();
}
JScript | public function get ARz() : int

Property Value

System.Int32

This property is read-only.


JoystickState.AX Property (Microsoft.DirectX.DirectInput)

JoystickState.AX Property

X-axis acceleration.

Definition

Visual Basic | Public ReadOnly Property AX As Integer
C# | public int AX { get; }
C++ public:
property int AX {
int get();
}
JScript | public function get AX() : int

Property Value

System.Int32

This property is read-only.


JoystickState.AY Property (Microsoft.DirectX.DirectInput)

JoystickState.AY Property

Y-axis acceleration.

Definition

Visual Basic | Public ReadOnly Property AY As Integer
C# | public int AY { get; }
C++ public:
property int AY {
int get();
}
JScript | public function get AY() : int

Property Value

System.Int32

This property is read-only.


JoystickState.AZ Property (Microsoft.DirectX.DirectInput)

JoystickState.AZ Property

Z-axis acceleration.

Definition

Visual Basic | Public ReadOnly Property AZ As Integer
C# | public int AZ { get; }
C++ public:
property int AZ {
int get();
}
JScript | public function get AZ() : int

Property Value

System.Int32

This property is read-only.


JoystickState.FRx Property (Microsoft.DirectX.DirectInput)

JoystickState.FRx Property

X-axis torque.

Definition

Visual Basic | Public ReadOnly Property FRx As Integer
C# | public int FRx { get; }
C++ public:
property int FRx {
int get();
}
JScript | public function get FRx() : int

Property Value

System.Int32

This property is read-only.


JoystickState.FRy Property (Microsoft.DirectX.DirectInput)

JoystickState.FRy Property

Y-axis torque.

Definition

Visual Basic | Public ReadOnly Property FRy As Integer
C# | public int FRy { get; }
C++ public:
property int FRy {
int get();
}
JScript | public function get FRy() : int

Property Value

System.Int32

This property is read-only.


JoystickState.FRz Property (Microsoft.DirectX.DirectInput)

JoystickState.FRz Property

Z-axis torque.

Definition

Visual Basic | Public ReadOnly Property FRz As Integer
C# | public int FRz { get; }
C++ public:
property int FRz {
int get();
}
JScript | public function get FRz() : int

Property Value

System.Int32

This property is read-only.


JoystickState.FX Property (Microsoft.DirectX.DirectInput)

JoystickState.FX Property

X-axis force.

Definition

Visual Basic | Public ReadOnly Property FX As Integer
C# | public int FX { get; }
C++ public:
property int FX {
int get();
}
JScript | public function get FX() : int

Property Value

System.Int32

This property is read-only.


JoystickState.FY Property (Microsoft.DirectX.DirectInput)

JoystickState.FY Property

Y-axis force.

Definition

Visual Basic | Public ReadOnly Property FY As Integer
C# | public int FY { get; }
C++ public:
property int FY {
int get();
}
JScript | public function get FY() : int

Property Value

System.Int32

This property is read-only.


JoystickState.FZ Property (Microsoft.DirectX.DirectInput)

JoystickState.FZ Property

Z-axis force.

Definition

Visual Basic | Public ReadOnly Property FZ As Integer
C# | public int FZ { get; }
C++ public:
property int FZ {
int get();
}
JScript | public function get FZ() : int

Property Value

System.Int32

This property is read-only.


JoystickState.Rx Property (Microsoft.DirectX.DirectInput)

JoystickState.Rx Property

X-axis rotation. If the joystick does not have this axis, the value is 0.

Definition

Visual Basic | Public ReadOnly Property Rx As Integer
C# | public int Rx { get; }
C++ public:
property int Rx {
int get();
}
JScript | public function get Rx() : int

Property Value

System.Int32

This property is read-only.


JoystickState.Ry Property (Microsoft.DirectX.DirectInput)

JoystickState.Ry Property

Y-axis rotation. If the joystick does not have this axis, the value is 0.

Definition

Visual Basic | Public ReadOnly Property Ry As Integer
C# | public int Ry { get; }
C++ public:
property int Ry {
int get();
}
JScript | public function get Ry() : int

Property Value

System.Int32

This property is read-only.


JoystickState.Rz Property (Microsoft.DirectX.DirectInput)

JoystickState.Rz Property

Z-axis rotation (often called the rudder). If the joystick does not have this axis, the value is 0.

Definition

Visual Basic | Public ReadOnly Property Rz As Integer
C# | public int Rz { get; }
C++ public:
property int Rz {
int get();
}
JScript | public function get Rz() : int

Property Value

System.Int32

This property is read-only.


JoystickState.VRx Property (Microsoft.DirectX.DirectInput)

JoystickState.VRx Property

X-axis angular velocity.

Definition

Visual Basic | Public ReadOnly Property VRx As Integer
C# | public int VRx { get; }
C++ public:
property int VRx {
int get();
}
JScript | public function get VRx() : int

Property Value

System.Int32

This property is read-only.


JoystickState.VRy Property (Microsoft.DirectX.DirectInput)

JoystickState.VRy Property

Y-axis angular velocity.

Definition

Visual Basic | Public ReadOnly Property VRy As Integer
C# | public int VRy { get; }
C++ public:
property int VRy {
int get();
}
JScript | public function get VRy() : int

Property Value

System.Int32

This property is read-only.


JoystickState.VRz Property (Microsoft.DirectX.DirectInput)

JoystickState.VRz Property

Z-axis angular velocity.

Definition

Visual Basic | Public ReadOnly Property VRz As Integer
C# | public int VRz { get; }
C++ public:
property int VRz {
int get();
}
JScript | public function get VRz() : int

Property Value

System.Int32

This property is read-only.


JoystickState.VX Property (Microsoft.DirectX.DirectInput)

JoystickState.VX Property

X-axis velocity.

Definition

Visual Basic | Public ReadOnly Property VX As Integer
C# | public int VX { get; }
C++ public:
property int VX {
int get();
}
JScript | public function get VX() : int

Property Value

System.Int32

This property is read-only.


JoystickState.VY Property (Microsoft.DirectX.DirectInput)

JoystickState.VY Property

Y-axis velocity.

Definition

Visual Basic | Public ReadOnly Property VY As Integer
C# | public int VY { get; }
C++ public:
property int VY {
int get();
}
JScript | public function get VY() : int

Property Value

System.Int32

This property is read-only.


JoystickState.VZ Property (Microsoft.DirectX.DirectInput)

JoystickState.VZ Property

Z-axis velocity.

Definition

Visual Basic | Public ReadOnly Property VZ As Integer
C# | public int VZ { get; }
C++ public:
property int VZ {
int get();
}
JScript | public function get VZ() : int

Property Value

System.Int32

This property is read-only.


JoystickState.X Property (Microsoft.DirectX.DirectInput)

JoystickState.X Property

X-axis, usually the left-right movement of a stick.

Definition

Visual Basic | Public ReadOnly Property X As Integer
C# | public int X { get; }
C++ public:
property int X {
int get();
}
JScript | public function get X() : int

Property Value

System.Int32

This property is read-only.


JoystickState.Y Property (Microsoft.DirectX.DirectInput)

JoystickState.Y Property

Y-axis, usually the forward-backward movement of a stick.

Definition

Visual Basic | Public ReadOnly Property Y As Integer
C# | public int Y { get; }
C++ public:
property int Y {
int get();
}
JScript | public function get Y() : int

Property Value

System.Int32

This property is read-only.


JoystickState.Z Property (Microsoft.DirectX.DirectInput)

JoystickState.Z Property

Z-axis, often the throttle control. If the joystick does not have this axis, the value is 0.

Definition

Visual Basic | Public ReadOnly Property Z As Integer
C# | public int Z { get; }
C++ public:
property int Z {
int get();
}
JScript | public function get Z() : int

Property Value

System.Int32

This property is read-only.


MouseState Structure (Microsoft.DirectX.DirectInput)

MouseState Structure

Describes the state of a mouse device that has up to four buttons, or another device that is being accessed as if it were a mouse device. This structure is used with the Inputdevice9Getdevicestate method.

Definition

Visual Basic | Public Structure MouseState
C# | public struct MouseState
C++ | public value class MouseState sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
GetMouseButtons | Array of buttons. The high-order bit of the byte is set if the corresponding button is down.
MouseState | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
X | X-axis.
Y | Y-axis.
Z | Z-axis, typically a wheel. If the mouse does not have a z-axis, the value is 0.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MouseState.GetMouseButtons() Method (Microsoft.DirectX.DirectInput)

MouseState.GetMouseButtons Method

Array of buttons. The high-order bit of the byte is set if the corresponding button is down.

Definition

Visual Basic | Public Function GetMouseButtons() As Byte()
C# | public byte[] GetMouseButtons();
C++ public:
array<unsigned char>^ GetMouseButtons();
JScript | public function GetMouseButtons() : byte[];

Return Value

System.Byte[]


MouseState.MouseState() Constructor (Microsoft.DirectX.DirectInput)

MouseState.MouseState Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public MouseState();
C++ public:
MouseState();
JScript | public function MouseState();


MouseState.ToString() Method (Microsoft.DirectX.DirectInput)

MouseState.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


MouseState.X Property (Microsoft.DirectX.DirectInput)

MouseState.X Property

X-axis.

Definition

Visual Basic | Public ReadOnly Property X As Integer
C# | public int X { get; }
C++ public:
property int X {
int get();
}
JScript | public function get X() : int

Property Value

System.Int32

This property is read-only.


MouseState.Y Property (Microsoft.DirectX.DirectInput)

MouseState.Y Property

Y-axis.

Definition

Visual Basic | Public ReadOnly Property Y As Integer
C# | public int Y { get; }
C++ public:
property int Y {
int get();
}
JScript | public function get Y() : int

Property Value

System.Int32

This property is read-only.


MouseState.Z Property (Microsoft.DirectX.DirectInput)

MouseState.Z Property

Z-axis, typically a wheel. If the mouse does not have a z-axis, the value is 0.

Definition

Visual Basic | Public ReadOnly Property Z As Integer
C# | public int Z { get; }
C++ public:
property int Z {
int get();
}
JScript | public function get Z() : int

Property Value

System.Int32

This property is read-only.


ObjectDataFormat Structure (Microsoft.DirectX.DirectInput)

ObjectDataFormat Structure

Describes a device object's data format for use with the Inputdevice9Setdataformat method.

Definition

Visual Basic | Public Structure ObjectDataFormat
C# | public struct ObjectDataFormat
C++ | public value class ObjectDataFormat sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ObjectDataFormat | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DeviceType | Device type that describes the object. It is a combination of the following flags describing the object type (axis, button, and so forth) and containing the object-instance number in the middle 16 bits. When requesting a data format, the instance portion must be set to DIDFT_ANYINSTANCE to indicate that any instance is permissible, or to DidftMakeinstance(n) to restrict the request to instance n. See the examples under Remarks.
Flags | Zero or more of the following values:
Offset | Offset within the data packet where the data for the input source is stored. This value must be a multiple of 4 for DWORD size data, such as axes. It can be byte-aligned for buttons.
SourceGuid | Unique identifier for the axis, button, or other input source. When requesting a data format, making this member NULL indicates that any type of object is permissible.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ObjectDataFormat.ObjectDataFormat() Constructor (Microsoft.DirectX.DirectInput)

ObjectDataFormat.ObjectDataFormat Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public ObjectDataFormat();
C++ public:
ObjectDataFormat();
JScript | public function ObjectDataFormat();


ObjectDataFormat.ToString() Method (Microsoft.DirectX.DirectInput)

ObjectDataFormat.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ObjectDataFormat.DeviceType Property (Microsoft.DirectX.DirectInput)

ObjectDataFormat.DeviceType Property

Device type that describes the object. It is a combination of the following flags describing the object type (axis, button, and so forth) and containing the object-instance number in the middle 16 bits. When requesting a data format, the instance portion must be set to DIDFT_ANYINSTANCE to indicate that any instance is permissible, or to DidftMakeinstance(n) to restrict the request to instance n. See the examples under Remarks.

Definition

Visual Basic | Public Property DeviceType As Integer
C# | public int DeviceType { get; set; }
C++ public:
property int DeviceType {
int get();
void set(int value);
}
JScript public function get DeviceType() : int
public function set DeviceType(int);

Property Value

System.Int32

This property is read/write.


ObjectDataFormat.Flags Property (Microsoft.DirectX.DirectInput)

ObjectDataFormat.Flags Property

Zero or more of the following values:

Definition

Visual Basic | Public Property Flags As Integer
C# | public int Flags { get; set; }
C++ public:
property int Flags {
int get();
void set(int value);
}
JScript public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32

This property is read/write.


ObjectDataFormat.Offset Property (Microsoft.DirectX.DirectInput)

ObjectDataFormat.Offset Property

Offset within the data packet where the data for the input source is stored. This value must be a multiple of 4 for DWORD size data, such as axes. It can be byte-aligned for buttons.

Definition

Visual Basic | Public Property Offset As Integer
C# | public int Offset { get; set; }
C++ public:
property int Offset {
int get();
void set(int value);
}
JScript public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32

This property is read/write.


ObjectDataFormat.SourceGuid Property (Microsoft.DirectX.DirectInput)

ObjectDataFormat.SourceGuid Property

Unique identifier for the axis, button, or other input source. When requesting a data format, making this member NULL indicates that any type of object is permissible.

Definition

Visual Basic | Public Property SourceGuid As Guid
C# | public Guid SourceGuid { get; set; }
C++ public:
property Guid SourceGuid {
Guid get();
void set(Guid value);
}
JScript public function get SourceGuid() : Guid
public function set SourceGuid(Guid);

Property Value

System.Guid

This property is read/write.


Periodic Structure (Microsoft.DirectX.DirectInput)

Periodic Structure

Contains type-specific information for effects that are marked as DIEFT_PERIODIC.The structure describes a periodic effect.A reference to a single Diperiodic structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic | Public Structure Periodic
C# | public struct Periodic
C++ | public value class Periodic sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Periodic | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Magnitude | Magnitude of the effect, in the range from 0 through 10,000. If an TermEnvelope is applied to this effect, the value represents the magnitude of the TermSustain. If no envelope is applied, the value represents the amplitude of the entire effect.
Offset | Offset of the effect. The range of forces generated by the effect is LOffset minus DwMagnitude to LOffset plus DwMagnitude. The value of the LOffset member is also the baseline for any envelope that is applied to the effect.
Period | Period of the effect, in microseconds.
Phase | Position in the cycle of the periodic effect at which playback begins, in the range from 0 through 35,999. See Remarks.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Periodic.Periodic() Constructor (Microsoft.DirectX.DirectInput)

Periodic.Periodic Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public Periodic();
C++ public:
Periodic();
JScript | public function Periodic();


Periodic.ToString() Method (Microsoft.DirectX.DirectInput)

Periodic.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Periodic.Magnitude Property (Microsoft.DirectX.DirectInput)

Periodic.Magnitude Property

Magnitude of the effect, in the range from 0 through 10,000. If an TermEnvelope is applied to this effect, the value represents the magnitude of the TermSustain. If no envelope is applied, the value represents the amplitude of the entire effect.

Definition

Visual Basic | Public Property Magnitude As Integer
C# | public int Magnitude { get; set; }
C++ public:
property int Magnitude {
int get();
void set(int value);
}
JScript public function get Magnitude() : int
public function set Magnitude(int);

Property Value

System.Int32

This property is read/write.


Periodic.Offset Property (Microsoft.DirectX.DirectInput)

Periodic.Offset Property

Offset of the effect. The range of forces generated by the effect is LOffset minus DwMagnitude to LOffset plus DwMagnitude. The value of the LOffset member is also the baseline for any envelope that is applied to the effect.

Definition

Visual Basic | Public Property Offset As Integer
C# | public int Offset { get; set; }
C++ public:
property int Offset {
int get();
void set(int value);
}
JScript public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32

This property is read/write.


Periodic.Period Property (Microsoft.DirectX.DirectInput)

Periodic.Period Property

Period of the effect, in microseconds.

Definition

Visual Basic | Public Property Period As Integer
C# | public int Period { get; set; }
C++ public:
property int Period {
int get();
void set(int value);
}
JScript public function get Period() : int
public function set Period(int);

Property Value

System.Int32

This property is read/write.


Periodic.Phase Property (Microsoft.DirectX.DirectInput)

Periodic.Phase Property

Position in the cycle of the periodic effect at which playback begins, in the range from 0 through 35,999. See Remarks.

Definition

Visual Basic | Public Property Phase As Integer
C# | public int Phase { get; set; }
C++ public:
property int Phase {
int get();
void set(int value);
}
JScript public function get Phase() : int
public function set Phase(int);

Property Value

System.Int32

This property is read/write.


RampForce Structure (Microsoft.DirectX.DirectInput)

RampForce Structure

Contains type-specific information for effects that are marked as DIEFT_RAMPFORCE. The structure describes a ramp force effect.A reference to a single Dirampforce structure for an effect is passed in the lpvTypeSpecificParams member of the Dieffect structure.

Definition

Visual Basic | Public Structure RampForce
C# | public struct RampForce
C++ | public value class RampForce sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
RampForce | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
End | Magnitude at the end of the effect, in the range from -10,000 through 10,000.
Start | Magnitude at the start of the effect, in the range from -10,000 through 10,000.

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RampForce.RampForce() Constructor (Microsoft.DirectX.DirectInput)

RampForce.RampForce Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public RampForce();
C++ public:
RampForce();
JScript | public function RampForce();


RampForce.ToString() Method (Microsoft.DirectX.DirectInput)

RampForce.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RampForce.End Property (Microsoft.DirectX.DirectInput)

RampForce.End Property

Magnitude at the end of the effect, in the range from -10,000 through 10,000.

Definition

Visual Basic | Public Property End As Integer
C# | public int End { get; set; }
C++ public:
property int End {
int get();
void set(int value);
}
JScript public function get End() : int
public function set End(int);

Property Value

System.Int32

This property is read/write.


RampForce.Start Property (Microsoft.DirectX.DirectInput)

RampForce.Start Property

Magnitude at the start of the effect, in the range from -10,000 through 10,000.

Definition

Visual Basic | Public Property Start As Integer
C# | public int Start { get; set; }
C++ public:
property int Start {
int get();
void set(int value);
}
JScript public function get Start() : int
public function set Start(int);

Property Value

System.Int32

This property is read/write.


SemanticsInstance Structure (Microsoft.DirectX.DirectInput)

SemanticsInstance Structure

Definition

Visual Basic | Public Structure SemanticsInstance
C# | public struct SemanticsInstance
C++ | public value class SemanticsInstance sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
SemanticsInstance | Initializes a new instance of the object.
ToString | Obtains a string representation of the current instance.

Properties

Property Description
Device
DeviceInstance
Flags
Remaining

Structure Information

Namespace | Microsoft.DirectX.DirectInput
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SemanticsInstance.SemanticsInstance() Constructor (Microsoft.DirectX.DirectInput)

SemanticsInstance.SemanticsInstance Constructor

Initializes a new instance of the object.

Definition

Visual Basic | Public Sub New()
C# | public SemanticsInstance();
C++ public:
SemanticsInstance();
JScript | public function SemanticsInstance();


SemanticsInstance.ToString() Method (Microsoft.DirectX.DirectInput)

SemanticsInstance.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


SemanticsInstance.Device Property (Microsoft.DirectX.DirectInput)

SemanticsInstance.Device Property

Definition

Visual Basic | Public Property Device As Device
C# | public Device Device { get; set; }
C++ public:
property Device^ Device {
Device^ get();
void set(Device^ value);
}
JScript public function get Device() : Device
public function set Device(Device);

Property Value

Microsoft.DirectX.DirectInput.Device

This property is read/write.


SemanticsInstance.DeviceInstance Property (Microsoft.DirectX.DirectInput)

SemanticsInstance.DeviceInstance Property

Definition

Visual Basic | Public Property DeviceInstance As DeviceInstance
C# | public DeviceInstance DeviceInstance { get; set; }
C++ public:
property DeviceInstance DeviceInstance {
DeviceInstance get();
void set(DeviceInstance value);
}
JScript public function get DeviceInstance() : DeviceInstance
public function set DeviceInstance(DeviceInstance);

Property Value

Microsoft.DirectX.DirectInput.DeviceInstance

This property is read/write.


SemanticsInstance.Flags Property (Microsoft.DirectX.DirectInput)

SemanticsInstance.Flags Property

Definition

Visual Basic | Public Property Flags As Integer
C# | public int Flags { get; set; }
C++ public:
property int Flags {
int get();
void set(int value);
}
JScript public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32

This property is read/write.


SemanticsInstance.Remaining Property (Microsoft.DirectX.DirectInput)

SemanticsInstance.Remaining Property

Definition

Visual Basic | Public Property Remaining As Integer
C# | public int Remaining { get; set; }
C++ public:
property int Remaining {
int get();
void set(int value);
}
JScript public function get Remaining() : int
public function set Remaining(int);

Property Value

System.Int32

This property is read/write.


Microsoft.DirectX.DirectPlay.Lobby

Warning: Microsoft DirectPlay Lobby has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay Lobby enables a DirectX application to interact with an application hosted on a remote server. The following tables list the members exposed by the Microsoft.DirectX.DirectPlay.Lobby namespace.

Classes

Application
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Application object is used by an application that supports lobbying. This object allows the application to register with the system so that it can be lobby launched. Additionally, it also lets the application get the connection information necessary to launch a game without querying the user. Lastly, this object allows the lobbied application to send messages and notifications to the lobby client that launched the application. Deprecated.
Client
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Client object is used by a lobby client application and is responsible for enumerating and launching lobby-enabled game applications on the local computer, and communicating with them once they are running. Deprecated.
ConnectEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a ConnectDplay message when a lobby client connects to the lobbied application through the method.The structure is passed with the ConnectDplay message. Deprecated.
ConnectionSettingsEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.
DisconnectEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a DisconnectDplay message when a lobby client disconnects from a lobbied application through the method.The structure contains information for the DisconnectDplay system message. Deprecated.
ReceiveEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.
SessionStatusEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the SessionStatusDplay message when the session has been updated with a call to the method.The structure contains the information for the SessionStatusDplay system message. Deprecated.

Enumerations

AvailableFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The default behavior for this method is to automatically mark the object as Unavailable when the first connection is established. By specifying this flag, the object is not automatically marked unavailable after the first connection is established, thereby allowing multiple connections. Deprecated.
ConnectFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.
ConnectionSettingsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flgas for connection settings. Deprecated.
Handle
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to represent system handles. Deprecated.
InitializeFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disable parameter validation for the current object. Deprecated.
SessionStatusFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for SessionStatus Deprecated.

Structures

ApplicationInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used in the pEnumData parameter of the Play8lobbyclientEnumlocalprogramsDplay method to describe the lobbied application. Deprecated.
ConnectInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to specify connection information for a lobby client when connecting to the lobby application in the Play8lobbyclientConnectapplicationDplay method. Deprecated.
ConnectionSettings
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to specify the settings you want to associate with a connection. These settings contain all the information required to create, initialize and connect/host a Microsoft® DirectPlay® object. Deprecated.
ConnectionSettingsMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.
ConnectMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a ConnectDplay message when a lobby client connects to the lobbied application through the method.The structure is passed with the ConnectDplay message. Deprecated.
DisconnectMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a DisconnectDplay message when a lobby client disconnects from a lobbied application through the method.The structure contains information for the DisconnectDplay system message. Deprecated.
ProgramDescription
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes a Microsoft® DirectPlay® lobby-aware application. Deprecated.
ReceiveMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.
SessionStatusMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the SessionStatusDplay message when the session has been updated with a call to the method.The structure contains the information for the SessionStatusDplay system message. Deprecated.

Delegates

ConnectEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Connect event. Deprecated.
ConnectionSettingsEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.
DisconnectEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.
ReceiveLobbyEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Receive event. Deprecated.
SessionStatusEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionStatus event. Deprecated.


Application Class (Microsoft.DirectX.DirectPlay.Lobby)

Application Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Application object is used by an application that supports lobbying. This object allows the application to register with the system so that it can be lobby launched. Additionally, it also lets the application get the connection information necessary to launch a game without querying the user. Lastly, this object allows the lobbied application to send messages and notifications to the lobby client that launched the application. Deprecated.

Definition

Visual Basic Public Class Application
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Application : MarshalByRefObject, IDisposable
C++ | public ref class Application : MarshalByRefObject, IDisposable
JScript | public class Application extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Connect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.
ConnectionSettings
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are done with the structure. Deprecated.
Disconnect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a disconnection has completed. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application receives data. Deprecated.
SessionStatus
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when session status has changed. Deprecated.

Methods

Method Description
Application
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are done with the structure. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disconnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionStatus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RegisterProgram
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Registers a lobby-aware application with . Applications must be registered to enable lobby launching. Deprecated.
Send
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sends a message from the lobbied application to the lobby client. Deprecated.
SetApplicationAvailable
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes an application available or unavailable for a lobby client to connect to. This method is typically called if a lobbied application is independently launched, that is, not launched by a lobby client. Additionally, this method should be called if a game has ended and the lobbied application needs to be available to connect to a lobby client at the start of another game. Deprecated.
SetConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the connection settings to be associated with the specified connection. Calling this method generates a DPL_MSGID_CONNECTION_SETTINGS message to be sent to the client specified by hConnection.When you set connection settings, the lobby application will add a reference to each of the address objects specified in the call. Deprecated.
UnregisterProgram
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unregisters a lobby-aware application that was registered through the method. Deprecated.
UpdateStatus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Updates the status of a connected lobby client. Deprecated.

Properties

Property Description
ConnectionHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection handle to the lobby client. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Application

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Application.Application Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Overload List

public Application();
public Application(InitializeFlags);
public Application(out int, ConnectEventHandler);
public Application(out int, InitializeFlags, ConnectEventHandler);


Application.Application(Int32,InitializeFlags,ConnectEventHandler) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

Application.Application Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub New( _
ByRef connectionHandle As Integer, _
ByVal flags As InitializeFlags, _
ByVal connectEventHandler As ConnectEventHandler _
)
C# public Application(
out int connectionHandle,
InitializeFlags flags,
ConnectEventHandler connectEventHandler
);
C++ public:
Application(
[Out] int% connectionHandle,
InitializeFlags flags,
ConnectEventHandler^ connectEventHandler
);
JScript public function Application(
connectionHandle : int,
flags : InitializeFlags,
connectEventHandler : ConnectEventHandler
);

Parameters

connectionHandle System.Int32
flags Microsoft.DirectX.DirectPlay.Lobby.InitializeFlags
connectEventHandler Microsoft.DirectX.DirectPlay.Lobby.ConnectEventHandler


Application.Application(Int32,ConnectEventHandler) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

Application.Application Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub New( _
ByRef connectionHandle As Integer, _
ByVal connectEventHandler As ConnectEventHandler _
)
C# public Application(
out int connectionHandle,
ConnectEventHandler connectEventHandler
);
C++ public:
Application(
[Out] int% connectionHandle,
ConnectEventHandler^ connectEventHandler
);
JScript public function Application(
connectionHandle : int,
connectEventHandler : ConnectEventHandler
);

Parameters

connectionHandle System.Int32
connectEventHandler Microsoft.DirectX.DirectPlay.Lobby.ConnectEventHandler


Application.Application(InitializeFlags) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

Application.Application Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Application(
InitializeFlags flags
);
C++ public:
Application(
InitializeFlags flags
);
JScript public function Application(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.Lobby.InitializeFlags


Application.Application() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

Application.Application Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Application();
C++ public:
Application();
JScript | public function Application();


Application.Dispose() Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Application();
JScript | public override function Dispose();

See Also

  • Application.Disposed
  • Application.Disposing


Application.Equals(Object) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Application.Finalize() Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Application();
C++ | !Application();
JScript | protected override function Finalize();


Application.GetConnectionSettings(Int32) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.GetConnectionSettings Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are done with the structure. Deprecated.

Definition

Visual Basic Public Function GetConnectionSettings( _
ByVal lobbyClient As Integer _
) As ConnectionSettings
C# public ConnectionSettings GetConnectionSettings(
int lobbyClient
);
C++ public:
ConnectionSettings GetConnectionSettings(
int lobbyClient
);
JScript public function GetConnectionSettings(
lobbyClient : int
) : ConnectionSettings;

Parameters

lobbyClient System.Int32

Return Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings


Application.GetHashCode() Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Application.op_Equality(Application,Application) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Application, _
ByVal right As Application _
) As Boolean
C# public static bool op_Equality(
Application left,
Application right
);
C++ public:
static bool operator==(
Application^ left,
Application^ right
);
JScript public static function op_Equality(
left : Application,
right : Application
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Lobby.Application
The Application structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Lobby.Application
The Application structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Application.op_Inequality(Application,Application) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Application, _
ByVal right As Application _
) As Boolean
C# public static bool op_Inequality(
Application left,
Application right
);
C++ public:
static bool operator!=(
Application^ left,
Application^ right
);
JScript public static function op_Inequality(
left : Application,
right : Application
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Lobby.Application
The Application structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Lobby.Application
The Application structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Application.raise_Connect(Object,ConnectEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.raise_Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Connect( _
ByVal i1 As Object, _
ByVal i2 As ConnectEventArgs _
)
C# protected void raise_Connect(
object i1,
ConnectEventArgs i2
);
C++ protected:
void raise_Connect(
Object^ i1,
ConnectEventArgs^ i2
);
JScript protected function raise_Connect(
i1 : Object,
i2 : ConnectEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.ConnectEventArgs


Application.raise_ConnectionSettings(Object,ConnectionSettingsEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.raise_ConnectionSettings Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ConnectionSettings( _
ByVal i1 As Object, _
ByVal i2 As ConnectionSettingsEventArgs _
)
C# protected void raise_ConnectionSettings(
object i1,
ConnectionSettingsEventArgs i2
);
C++ protected:
void raise_ConnectionSettings(
Object^ i1,
ConnectionSettingsEventArgs^ i2
);
JScript protected function raise_ConnectionSettings(
i1 : Object,
i2 : ConnectionSettingsEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsEventArgs


Application.raise_Disconnect(Object,DisconnectEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.raise_Disconnect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disconnect( _
ByVal i1 As Object, _
ByVal i2 As DisconnectEventArgs _
)
C# protected void raise_Disconnect(
object i1,
DisconnectEventArgs i2
);
C++ protected:
void raise_Disconnect(
Object^ i1,
DisconnectEventArgs^ i2
);
JScript protected function raise_Disconnect(
i1 : Object,
i2 : DisconnectEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.DisconnectEventArgs


Application.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Application.raise_Receive(Object,ReceiveEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.raise_Receive Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
C++ protected:
void raise_Receive(
Object^ i1,
ReceiveEventArgs^ i2
);
JScript protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.ReceiveEventArgs


Application.raise_SessionStatus(Object,SessionStatusEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.raise_SessionStatus Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SessionStatus( _
ByVal i1 As Object, _
ByVal i2 As SessionStatusEventArgs _
)
C# protected void raise_SessionStatus(
object i1,
SessionStatusEventArgs i2
);
C++ protected:
void raise_SessionStatus(
Object^ i1,
SessionStatusEventArgs^ i2
);
JScript protected function raise_SessionStatus(
i1 : Object,
i2 : SessionStatusEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.SessionStatusEventArgs


Application.RegisterProgram(ProgramDescription) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.RegisterProgram Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Registers a lobby-aware application with . Applications must be registered to enable lobby launching. Deprecated.

Definition

Visual Basic Public Sub RegisterProgram( _
ByVal programDescription As ProgramDescription _
)
C# public void RegisterProgram(
ProgramDescription programDescription
);
C++ public:
void RegisterProgram(
ProgramDescription programDescription
);
JScript public function RegisterProgram(
programDescription : ProgramDescription
);

Parameters

programDescription Microsoft.DirectX.DirectPlay.Lobby.ProgramDescription


Application.Send(Int32,NetworkPacket) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sends a message from the lobbied application to the lobby client. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal connectionHandle As Integer, _
ByVal data As NetworkPacket _
)
C# public void Send(
int connectionHandle,
NetworkPacket data
);
C++ public:
void Send(
int connectionHandle,
NetworkPacket^ data
);
JScript public function Send(
connectionHandle : int,
data : NetworkPacket
);

Parameters

connectionHandle System.Int32
data Microsoft.DirectX.DirectPlay.NetworkPacket


Application.SetApplicationAvailable(Boolean,AvailableFlags) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.SetApplicationAvailable Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Makes an application available or unavailable for a lobby client to connect to. This method is typically called if a lobbied application is independently launched, that is, not launched by a lobby client. Additionally, this method should be called if a game has ended and the lobbied application needs to be available to connect to a lobby client at the start of another game. Deprecated.

Definition

Visual Basic Public Sub SetApplicationAvailable( _
ByVal available As Boolean, _
ByVal flags As AvailableFlags _
)
C# public void SetApplicationAvailable(
bool available,
AvailableFlags flags
);
C++ public:
void SetApplicationAvailable(
bool available,
AvailableFlags flags
);
JScript public function SetApplicationAvailable(
available : boolean,
flags : AvailableFlags
);

Parameters

available System.Boolean
flags Microsoft.DirectX.DirectPlay.Lobby.AvailableFlags


Application.SetConnectionSettings(Int32,ConnectionSettings) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.SetConnectionSettings Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the connection settings to be associated with the specified connection. Calling this method generates a DPL_MSGID_CONNECTION_SETTINGS message to be sent to the client specified by hConnection.When you set connection settings, the lobby application will add a reference to each of the address objects specified in the call. Deprecated.

Definition

Visual Basic Public Sub SetConnectionSettings( _
ByVal lobbyClient As Integer, _
ByVal connectionSettings As ConnectionSettings _
)
C# public void SetConnectionSettings(
int lobbyClient,
ConnectionSettings connectionSettings
);
C++ public:
void SetConnectionSettings(
int lobbyClient,
ConnectionSettings connectionSettings
);
JScript public function SetConnectionSettings(
lobbyClient : int,
connectionSettings : ConnectionSettings
);

Parameters

lobbyClient System.Int32
connectionSettings Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings


Application.UnregisterProgram(Guid) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.UnregisterProgram Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Unregisters a lobby-aware application that was registered through the method. Deprecated.

Definition

Visual Basic Public Sub UnregisterProgram( _
ByVal guidApplication As Guid _
)
C# public void UnregisterProgram(
Guid guidApplication
);
C++ public:
void UnregisterProgram(
Guid guidApplication
);
JScript public function UnregisterProgram(
guidApplication : Guid
);

Parameters

guidApplication System.Guid


Application.UpdateStatus(Int32,SessionStatusFlags) Method (Microsoft.DirectX.DirectPlay.Lobby)

Application.UpdateStatus Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Updates the status of a connected lobby client. Deprecated.

Definition

Visual Basic Public Sub UpdateStatus( _
ByVal connectionHandle As Integer, _
ByVal flags As SessionStatusFlags _
)
C# public void UpdateStatus(
int connectionHandle,
SessionStatusFlags flags
);
C++ public:
void UpdateStatus(
int connectionHandle,
SessionStatusFlags flags
);
JScript public function UpdateStatus(
connectionHandle : int,
flags : SessionStatusFlags
);

Parameters

connectionHandle System.Int32
flags Microsoft.DirectX.DirectPlay.Lobby.SessionStatusFlags


Application.ConnectionHandle Property (Microsoft.DirectX.DirectPlay.Lobby)

Application.ConnectionHandle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection handle to the lobby client. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ConnectionHandle As Integer
C# | public int ConnectionHandle { get; }
C++ public:
property int ConnectionHandle {
int get();
}
JScript | public function get ConnectionHandle() : int

Property Value

System.Int32

This property is read-only.


Application.Disposed Property (Microsoft.DirectX.DirectPlay.Lobby)

Application.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Application.Connect Event (Microsoft.DirectX.DirectPlay.Lobby)

Application.Connect Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.

Definition

Visual Basic | Public Event Connect As ConnectEventHandler
C# | public event ConnectEventHandler Connect;
C++ public:
event ConnectEventHandler^ Connect;
JScript | In JScript, you can use events, but you cannot define your own.


Application.ConnectionSettings Event (Microsoft.DirectX.DirectPlay.Lobby)

Application.ConnectionSettings Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are done with the structure. Deprecated.

Definition

Visual Basic | Public Event ConnectionSettings As ConnectionSettingsEventHandler
C# | public event ConnectionSettingsEventHandler ConnectionSettings;
C++ public:
event ConnectionSettingsEventHandler^ ConnectionSettings;
JScript | In JScript, you can use events, but you cannot define your own.


Application.Disconnect Event (Microsoft.DirectX.DirectPlay.Lobby)

Application.Disconnect Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a disconnection has completed. Deprecated.

Definition

Visual Basic | Public Event Disconnect As DisconnectEventHandler
C# | public event DisconnectEventHandler Disconnect;
C++ public:
event DisconnectEventHandler^ Disconnect;
JScript | In JScript, you can use events, but you cannot define your own.


Application.Disposing Event (Microsoft.DirectX.DirectPlay.Lobby)

Application.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Application.Disposing event, use the following code.

application.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Application.Receive Event (Microsoft.DirectX.DirectPlay.Lobby)

Application.Receive Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application receives data. Deprecated.

Definition

Visual Basic | Public Event Receive As ReceiveLobbyEventHandler
C# | public event ReceiveLobbyEventHandler Receive;
C++ public:
event ReceiveLobbyEventHandler^ Receive;
JScript | In JScript, you can use events, but you cannot define your own.


Application.SessionStatus Event (Microsoft.DirectX.DirectPlay.Lobby)

Application.SessionStatus Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when session status has changed. Deprecated.

Definition

Visual Basic | Public Event SessionStatus As SessionStatusEventHandler
C# | public event SessionStatusEventHandler SessionStatus;
C++ public:
event SessionStatusEventHandler^ SessionStatus;
JScript | In JScript, you can use events, but you cannot define your own.


Client Class (Microsoft.DirectX.DirectPlay.Lobby)

Client Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Client object is used by a lobby client application and is responsible for enumerating and launching lobby-enabled game applications on the local computer, and communicating with them once they are running. Deprecated.

Definition

Visual Basic Public Class Client
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Client : MarshalByRefObject, IDisposable
C++ | public ref class Client : MarshalByRefObject, IDisposable
JScript | public class Client extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Connect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.
ConnectionSettings
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are finished with the structure. Deprecated.
Disconnect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disconnects the Microsoft® DirectPlay® Voice client from the existing Microsoft® DirectPlay® Voice session. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when data has been received. Deprecated.
SessionStatus
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when session status has changed. Deprecated.

Methods

Method Description
Client
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ConnectApplication
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Connects a lobby-enabled application to the session specified in the structure. If the application is not running, this method can be used to launch the application.When the connection is successfully established, the lobbied application generates a system message to the message handler. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are finished with the structure. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetLocalPrograms
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the lobbied applications that are registered on the system. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disconnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionStatus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
ReleaseApplication
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Releases a lobbied application and closes the connection between the lobby client and the application. This method should be called whenever a lobby client has finished its session with an application. Deprecated.
Send
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sends a message to a lobbied application that was launched by this lobby client or was connected by this lobby client. Deprecated.
SetConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the connection settings to be associated with the specified connection. Calling this method will generate a DPL_MSGID_CONNECTION_SETTINGS message to be sent to the client specified by hConnection.When you set connection settings, the lobby application will add a reference to each of the address objects specified in the call. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Client

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Client.Client Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Client();
public Client(InitializeFlags);


Client.Client(InitializeFlags) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

Client.Client Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Client(
InitializeFlags flags
);
C++ public:
Client(
InitializeFlags flags
);
JScript public function Client(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.Lobby.InitializeFlags


Client.Client() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

Client.Client Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Client();
C++ public:
Client();
JScript | public function Client();


Client.ConnectApplication(ConnectInformation,Int32,Object) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.ConnectApplication Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Connects a lobby-enabled application to the session specified in the structure. If the application is not running, this method can be used to launch the application.When the connection is successfully established, the lobbied application generates a system message to the message handler. Deprecated.

Definition

Visual Basic Public Function ConnectApplication( _
ByVal connectInformation As ConnectInformation, _
ByVal timeOut As Integer, _
ByVal applicationContext As Object _
) As Integer
C# public int ConnectApplication(
ConnectInformation connectInformation,
int timeOut,
object applicationContext
);
C++ public:
int ConnectApplication(
ConnectInformation connectInformation,
int timeOut,
Object^ applicationContext
);
JScript public function ConnectApplication(
connectInformation : ConnectInformation,
timeOut : int,
applicationContext : Object
) : int;

Parameters

connectInformation Microsoft.DirectX.DirectPlay.Lobby.ConnectInformation
timeOut System.Int32
applicationContext System.Object

Return Value

System.Int32


Client.Dispose() Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Client();
JScript | public override function Dispose();


Client.Equals(Object) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Client.Finalize() Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Client();
C++ | !Client();
JScript | protected override function Finalize();


Client.GetConnectionSettings(Int32) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.GetConnectionSettings Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are finished with the structure. Deprecated.

Definition

Visual Basic Public Function GetConnectionSettings( _
ByVal lobbyClient As Integer _
) As ConnectionSettings
C# public ConnectionSettings GetConnectionSettings(
int lobbyClient
);
C++ public:
ConnectionSettings GetConnectionSettings(
int lobbyClient
);
JScript public function GetConnectionSettings(
lobbyClient : int
) : ConnectionSettings;

Parameters

lobbyClient System.Int32

Return Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings


Client.GetHashCode() Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Client.GetLocalPrograms Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the lobbied applications that are registered on the system. Deprecated.

Overload List

public ApplicationInformation[] GetLocalPrograms();
public ApplicationInformation[] GetLocalPrograms(Guid);


Client.GetLocalPrograms() Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.GetLocalPrograms Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the lobbied applications that are registered on the system. Deprecated.

Definition

Visual Basic | Public Function GetLocalPrograms() As ApplicationInformation()
C# | public ApplicationInformation[] GetLocalPrograms();
C++ public:
array<ApplicationInformation>^ GetLocalPrograms();
JScript | public function GetLocalPrograms() : ApplicationInformation[];

Return Value

Microsoft.DirectX.DirectPlay.Lobby.ApplicationInformation[]


Client.GetLocalPrograms(Guid) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.GetLocalPrograms Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the lobbied applications that are registered on the system. Deprecated.

Definition

Visual Basic Public Function GetLocalPrograms( _
ByVal guidApplication As Guid _
) As ApplicationInformation()
C# public ApplicationInformation[] GetLocalPrograms(
Guid guidApplication
);
C++ public:
array<ApplicationInformation>^ GetLocalPrograms(
Guid guidApplication
);
JScript public function GetLocalPrograms(
guidApplication : Guid
) : ApplicationInformation[];

Parameters

guidApplication System.Guid

Return Value

Microsoft.DirectX.DirectPlay.Lobby.ApplicationInformation[]


Client.op_Equality(Client,Client) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Equality(
Client left,
Client right
);
C++ public:
static bool operator==(
Client^ left,
Client^ right
);
JScript public static function op_Equality(
left : Client,
right : Client
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Lobby.Client
The Client structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Lobby.Client
The Client structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Client.op_Inequality(Client,Client) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Inequality(
Client left,
Client right
);
C++ public:
static bool operator!=(
Client^ left,
Client^ right
);
JScript public static function op_Inequality(
left : Client,
right : Client
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Lobby.Client
The Client structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Lobby.Client
The Client structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Client.raise_Connect(Object,ConnectEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.raise_Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Connect( _
ByVal i1 As Object, _
ByVal i2 As ConnectEventArgs _
)
C# protected void raise_Connect(
object i1,
ConnectEventArgs i2
);
C++ protected:
void raise_Connect(
Object^ i1,
ConnectEventArgs^ i2
);
JScript protected function raise_Connect(
i1 : Object,
i2 : ConnectEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.ConnectEventArgs


Client.raise_ConnectionSettings(Object,ConnectionSettingsEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.raise_ConnectionSettings Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ConnectionSettings( _
ByVal i1 As Object, _
ByVal i2 As ConnectionSettingsEventArgs _
)
C# protected void raise_ConnectionSettings(
object i1,
ConnectionSettingsEventArgs i2
);
C++ protected:
void raise_ConnectionSettings(
Object^ i1,
ConnectionSettingsEventArgs^ i2
);
JScript protected function raise_ConnectionSettings(
i1 : Object,
i2 : ConnectionSettingsEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsEventArgs


Client.raise_Disconnect(Object,DisconnectEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.raise_Disconnect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disconnect( _
ByVal i1 As Object, _
ByVal i2 As DisconnectEventArgs _
)
C# protected void raise_Disconnect(
object i1,
DisconnectEventArgs i2
);
C++ protected:
void raise_Disconnect(
Object^ i1,
DisconnectEventArgs^ i2
);
JScript protected function raise_Disconnect(
i1 : Object,
i2 : DisconnectEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.DisconnectEventArgs


Client.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Client.raise_Receive(Object,ReceiveEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.raise_Receive Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
C++ protected:
void raise_Receive(
Object^ i1,
ReceiveEventArgs^ i2
);
JScript protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.ReceiveEventArgs


Client.raise_SessionStatus(Object,SessionStatusEventArgs) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.raise_SessionStatus Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SessionStatus( _
ByVal i1 As Object, _
ByVal i2 As SessionStatusEventArgs _
)
C# protected void raise_SessionStatus(
object i1,
SessionStatusEventArgs i2
);
C++ protected:
void raise_SessionStatus(
Object^ i1,
SessionStatusEventArgs^ i2
);
JScript protected function raise_SessionStatus(
i1 : Object,
i2 : SessionStatusEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Lobby.SessionStatusEventArgs


Client.ReleaseApplication(Int32) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.ReleaseApplication Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Releases a lobbied application and closes the connection between the lobby client and the application. This method should be called whenever a lobby client has finished its session with an application. Deprecated.

Definition

Visual Basic Public Sub ReleaseApplication( _
ByVal connectionHandle As Integer _
)
C# public void ReleaseApplication(
int connectionHandle
);
C++ public:
void ReleaseApplication(
int connectionHandle
);
JScript public function ReleaseApplication(
connectionHandle : int
);

Parameters

connectionHandle System.Int32


Client.Send(Int32,NetworkPacket) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sends a message to a lobbied application that was launched by this lobby client or was connected by this lobby client. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal connectionHandle As Integer, _
ByVal data As NetworkPacket _
)
C# public void Send(
int connectionHandle,
NetworkPacket data
);
C++ public:
void Send(
int connectionHandle,
NetworkPacket^ data
);
JScript public function Send(
connectionHandle : int,
data : NetworkPacket
);

Parameters

connectionHandle System.Int32
data Microsoft.DirectX.DirectPlay.NetworkPacket


Client.SetConnectionSettings(Int32,ConnectionSettings) Method (Microsoft.DirectX.DirectPlay.Lobby)

Client.SetConnectionSettings Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the connection settings to be associated with the specified connection. Calling this method will generate a DPL_MSGID_CONNECTION_SETTINGS message to be sent to the client specified by hConnection.When you set connection settings, the lobby application will add a reference to each of the address objects specified in the call. Deprecated.

Definition

Visual Basic Public Sub SetConnectionSettings( _
ByVal lobbyClient As Integer, _
ByVal connectionSettings As ConnectionSettings _
)
C# public void SetConnectionSettings(
int lobbyClient,
ConnectionSettings connectionSettings
);
C++ public:
void SetConnectionSettings(
int lobbyClient,
ConnectionSettings connectionSettings
);
JScript public function SetConnectionSettings(
lobbyClient : int,
connectionSettings : ConnectionSettings
);

Parameters

lobbyClient System.Int32
connectionSettings Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings


Client.Disposed Property (Microsoft.DirectX.DirectPlay.Lobby)

Client.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Client.Connect Event (Microsoft.DirectX.DirectPlay.Lobby)

Client.Connect Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic | Public Event Connect As ConnectEventHandler
C# | public event ConnectEventHandler Connect;
C++ public:
event ConnectEventHandler^ Connect;
JScript | In JScript, you can use events, but you cannot define your own.


Client.ConnectionSettings Event (Microsoft.DirectX.DirectPlay.Lobby)

Client.ConnectionSettings Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the set of connection settings for the specified connection. These settings can be set through a call to the , , or method.When you get connection settings, a reference will be added for each address object that is returned to the user. Therefore, users must be sure to call Release on each address object when they are finished with the structure. Deprecated.

Definition

Visual Basic | Public Event ConnectionSettings As ConnectionSettingsEventHandler
C# | public event ConnectionSettingsEventHandler ConnectionSettings;
C++ public:
event ConnectionSettingsEventHandler^ ConnectionSettings;
JScript | In JScript, you can use events, but you cannot define your own.


Client.Disconnect Event (Microsoft.DirectX.DirectPlay.Lobby)

Client.Disconnect Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disconnects the Microsoft® DirectPlay® Voice client from the existing Microsoft® DirectPlay® Voice session. Deprecated.

Definition

Visual Basic | Public Event Disconnect As DisconnectEventHandler
C# | public event DisconnectEventHandler Disconnect;
C++ public:
event DisconnectEventHandler^ Disconnect;
JScript | In JScript, you can use events, but you cannot define your own.


Client.Disposing Event (Microsoft.DirectX.DirectPlay.Lobby)

Client.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Client.Disposing event, use the following code.

client.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Client.Receive Event (Microsoft.DirectX.DirectPlay.Lobby)

Client.Receive Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when data has been received. Deprecated.

Definition

Visual Basic | Public Event Receive As ReceiveLobbyEventHandler
C# | public event ReceiveLobbyEventHandler Receive;
C++ public:
event ReceiveLobbyEventHandler^ Receive;
JScript | In JScript, you can use events, but you cannot define your own.


Client.SessionStatus Event (Microsoft.DirectX.DirectPlay.Lobby)

Client.SessionStatus Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when session status has changed. Deprecated.

Definition

Visual Basic | Public Event SessionStatus As SessionStatusEventHandler
C# | public event SessionStatusEventHandler SessionStatus;
C++ public:
event SessionStatusEventHandler^ SessionStatus;
JScript | In JScript, you can use events, but you cannot define your own.


ConnectEventArgs Class (Microsoft.DirectX.DirectPlay.Lobby)

ConnectEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a ConnectDplay message when a lobby client connects to the lobbied application through the method.The structure is passed with the ConnectDplay message. Deprecated.

Definition

Visual Basic NotInheritable Public Class ConnectEventArgs
Inherits EventArgs
C# | public sealed class ConnectEventArgs : EventArgs
C++ | public ref class ConnectEventArgs sealed : EventArgs
JScript | public final class ConnectEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ConnectEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectEventArgs.ConnectEventArgs(ConnectMessage) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ConnectEventArgs.ConnectEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As ConnectMessage _
)
C# public ConnectEventArgs(
ConnectMessage dpMessage
);
C++ public:
ConnectEventArgs(
ConnectMessage dpMessage
);
JScript public function ConnectEventArgs(
dpMessage : ConnectMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.ConnectMessage


ConnectEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Lobby)

ConnectEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As ConnectMessage
C# | public ConnectMessage Message;
C++ | public: ConnectMessage Message;
JScript | public var Message : ConnectMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectMessage

This field is read/write.


ConnectionSettingsEventArgs Class (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.

Definition

Visual Basic NotInheritable Public Class ConnectionSettingsEventArgs
Inherits EventArgs
C# | public sealed class ConnectionSettingsEventArgs : EventArgs
C++ | public ref class ConnectionSettingsEventArgs sealed : EventArgs
JScript | public final class ConnectionSettingsEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectionSettingsEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ConnectionSettingsEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectionSettingsEventArgs.ConnectionSettingsEventArgs(ConnectionSettingsMessage) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsEventArgs.ConnectionSettingsEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As ConnectionSettingsMessage _
)
C# public ConnectionSettingsEventArgs(
ConnectionSettingsMessage dpMessage
);
C++ public:
ConnectionSettingsEventArgs(
ConnectionSettingsMessage dpMessage
);
JScript public function ConnectionSettingsEventArgs(
dpMessage : ConnectionSettingsMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsMessage


ConnectionSettingsEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As ConnectionSettingsMessage
C# | public ConnectionSettingsMessage Message;
C++ | public: ConnectionSettingsMessage Message;
JScript | public var Message : ConnectionSettingsMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsMessage

This field is read/write.


DisconnectEventArgs Class (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a DisconnectDplay message when a lobby client disconnects from a lobbied application through the method.The structure contains information for the DisconnectDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class DisconnectEventArgs
Inherits EventArgs
C# | public sealed class DisconnectEventArgs : EventArgs
C++ | public ref class DisconnectEventArgs sealed : EventArgs
JScript | public final class DisconnectEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
DisconnectEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
DisconnectEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisconnectEventArgs.DisconnectEventArgs(DisconnectMessage) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectEventArgs.DisconnectEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As DisconnectMessage _
)
C# public DisconnectEventArgs(
DisconnectMessage dpMessage
);
C++ public:
DisconnectEventArgs(
DisconnectMessage dpMessage
);
JScript public function DisconnectEventArgs(
dpMessage : DisconnectMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.DisconnectMessage


DisconnectEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As DisconnectMessage
C# | public DisconnectMessage Message;
C++ | public: DisconnectMessage Message;
JScript | public var Message : DisconnectMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.DisconnectMessage

This field is read/write.


ReceiveEventArgs Class (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class ReceiveEventArgs
Inherits EventArgs
C# | public sealed class ReceiveEventArgs : EventArgs
C++ | public ref class ReceiveEventArgs sealed : EventArgs
JScript | public final class ReceiveEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ReceiveEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ReceiveEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ReceiveEventArgs.ReceiveEventArgs(ReceiveMessage) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveEventArgs.ReceiveEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As ReceiveMessage _
)
C# public ReceiveEventArgs(
ReceiveMessage dpMessage
);
C++ public:
ReceiveEventArgs(
ReceiveMessage dpMessage
);
JScript public function ReceiveEventArgs(
dpMessage : ReceiveMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.ReceiveMessage


ReceiveEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As ReceiveMessage
C# | public ReceiveMessage Message;
C++ | public: ReceiveMessage Message;
JScript | public var Message : ReceiveMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ReceiveMessage

This field is read/write.


SessionStatusEventArgs Class (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the SessionStatusDplay message when the session has been updated with a call to the method.The structure contains the information for the SessionStatusDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class SessionStatusEventArgs
Inherits EventArgs
C# | public sealed class SessionStatusEventArgs : EventArgs
C++ | public ref class SessionStatusEventArgs sealed : EventArgs
JScript | public final class SessionStatusEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SessionStatusEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SessionStatusEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionStatusEventArgs.SessionStatusEventArgs(SessionStatusMessage) Constructor (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusEventArgs.SessionStatusEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As SessionStatusMessage _
)
C# public SessionStatusEventArgs(
SessionStatusMessage dpMessage
);
C++ public:
SessionStatusEventArgs(
SessionStatusMessage dpMessage
);
JScript public function SessionStatusEventArgs(
dpMessage : SessionStatusMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Lobby.SessionStatusMessage


SessionStatusEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As SessionStatusMessage
C# | public SessionStatusMessage Message;
C++ | public: SessionStatusMessage Message;
JScript | public var Message : SessionStatusMessage

Field Value

Microsoft.DirectX.DirectPlay.Lobby.SessionStatusMessage

This field is read/write.


AvailableFlags Enumeration (Microsoft.DirectX.DirectPlay.Lobby)

AvailableFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The default behavior for this method is to automatically mark the object as Unavailable when the first connection is established. By specifying this flag, the object is not automatically marked unavailable after the first connection is established, thereby allowing multiple connections. Deprecated.

Definition

Visual Basic | Public Enum AvailableFlags
C# | public enum AvailableFlags
C++ | public enum class AvailableFlags
JScript | public enum AvailableFlags

Members

Member | Value | Description
AllowMultipleConnect | 1 | The default behavior for this method is to automatically mark the object as Unavailable when the first connection is established. By specifying this flag, the object is not automatically marked unavailable after the first connection is established, thereby allowing multiple connections.

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectFlags Enumeration (Microsoft.DirectX.DirectPlay.Lobby)

ConnectFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.

Definition

Visual Basic | Public Enum ConnectFlags
C# | public enum ConnectFlags
C++ | public enum class ConnectFlags
JScript | public enum ConnectFlags

Members

Member | Value | Description
LaunchNotFound | 2
LaunchNew | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectionSettingsFlags Enumeration (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flgas for connection settings. Deprecated.

Definition

Visual Basic | Public Enum ConnectionSettingsFlags
C# | public enum ConnectionSettingsFlags
C++ | public enum class ConnectionSettingsFlags
JScript | public enum ConnectionSettingsFlags

Members

Member | Value | Description
Host | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Handle Enumeration (Microsoft.DirectX.DirectPlay.Lobby)

Handle Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to represent system handles. Deprecated.

Definition

Visual Basic | Public Enum Handle
C# | public enum Handle
C++ | public enum class Handle
JScript | public enum Handle

Members

Member | Value | Description
AllConnections | -1 | The message you have specified will be sent to all lobby clients to which you are connected.

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InitializeFlags Enumeration (Microsoft.DirectX.DirectPlay.Lobby)

InitializeFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disable parameter validation for the current object. Deprecated.

Definition

Visual Basic | Public Enum InitializeFlags
C# | public enum InitializeFlags
C++ | public enum class InitializeFlags
JScript | public enum InitializeFlags

Members

Member | Value | Description
DisableParameterValidation | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionStatusFlags Enumeration (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for SessionStatus Deprecated.

Definition

Visual Basic | Public Enum SessionStatusFlags
C# | public enum SessionStatusFlags
C++ | public enum class SessionStatusFlags
JScript | public enum SessionStatusFlags

Members

Member | Value | Description
HostMigratedHere | 6
HostMigrated | 5
Terminated | 4
Disconnected | 3
CouldNotConnect | 2
Connected | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ApplicationInformation Structure (Microsoft.DirectX.DirectPlay.Lobby)

ApplicationInformation Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used in the pEnumData parameter of the Play8lobbyclientEnumlocalprogramsDplay method to describe the lobbied application. Deprecated.

Definition

Visual Basic | Public Structure ApplicationInformation
C# | public struct ApplicationInformation
C++ | public value class ApplicationInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ApplicationInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ApplicationName
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WSTR containing the name of the lobbied application. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.
GuidApplication
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the lobbied application. Deprecated.
NumberRunning
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of instances of the application. Deprecated.
NumberWaiting
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of clients waiting to connect to the lobbied application. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ApplicationInformation.ApplicationInformation() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ApplicationInformation.ApplicationInformation Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ApplicationInformation();
C++ public:
ApplicationInformation();
JScript | public function ApplicationInformation();


ApplicationInformation.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

ApplicationInformation.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ApplicationInformation.ApplicationName Property (Microsoft.DirectX.DirectPlay.Lobby)

ApplicationInformation.ApplicationName Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WSTR containing the name of the lobbied application. Deprecated.

Definition

Visual Basic | Public Property ApplicationName As String
C# | public string ApplicationName { get; set; }
C++ public:
property String^ ApplicationName {
String^ get();
void set(String^ value);
}
JScript public function get ApplicationName() : String
public function set ApplicationName(String);

Property Value

System.String

This property is read/write.


ApplicationInformation.Flags Property (Microsoft.DirectX.DirectPlay.Lobby)

ApplicationInformation.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic | Public Property Flags As Integer
C# | public int Flags { get; set; }
C++ public:
property int Flags {
int get();
void set(int value);
}
JScript public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32

This property is read/write.


ApplicationInformation.GuidApplication Property (Microsoft.DirectX.DirectPlay.Lobby)

ApplicationInformation.GuidApplication Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the lobbied application. Deprecated.

Definition

Visual Basic | Public Property GuidApplication As Guid
C# | public Guid GuidApplication { get; set; }
C++ public:
property Guid GuidApplication {
Guid get();
void set(Guid value);
}
JScript public function get GuidApplication() : Guid
public function set GuidApplication(Guid);

Property Value

System.Guid

This property is read/write.


ApplicationInformation.NumberRunning Property (Microsoft.DirectX.DirectPlay.Lobby)

ApplicationInformation.NumberRunning Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of instances of the application. Deprecated.

Definition

Visual Basic | Public Property NumberRunning As Integer
C# | public int NumberRunning { get; set; }
C++ public:
property int NumberRunning {
int get();
void set(int value);
}
JScript public function get NumberRunning() : int
public function set NumberRunning(int);

Property Value

System.Int32

This property is read/write.


ApplicationInformation.NumberWaiting Property (Microsoft.DirectX.DirectPlay.Lobby)

ApplicationInformation.NumberWaiting Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of clients waiting to connect to the lobbied application. Deprecated.

Definition

Visual Basic | Public Property NumberWaiting As Integer
C# | public int NumberWaiting { get; set; }
C++ public:
property int NumberWaiting {
int get();
void set(int value);
}
JScript public function get NumberWaiting() : int
public function set NumberWaiting(int);

Property Value

System.Int32

This property is read/write.


ConnectInformation Structure (Microsoft.DirectX.DirectPlay.Lobby)

ConnectInformation Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to specify connection information for a lobby client when connecting to the lobby application in the Play8lobbyclientConnectapplicationDplay method. Deprecated.

Definition

Visual Basic | Public Structure ConnectInformation
C# | public struct ConnectInformation
C++ | public value class ConnectInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
ConnectionSettings
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains the connection settings you want to associate with the connection when it is established. Deprecated.

Methods

Method Description
ConnectInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags, which determine connection behavior. Deprecated.
GuidApplication
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the application. Deprecated.
LobbyConnectData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to connection data passed to the lobbied application. Deprecated.
UseConnectionSettings
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets or sets a value that specifies whether or not the connection settings should be used. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectInformation.ConnectInformation() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ConnectInformation.ConnectInformation Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectInformation();
C++ public:
ConnectInformation();
JScript | public function ConnectInformation();


ConnectInformation.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

ConnectInformation.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConnectInformation.Flags Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectInformation.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags, which determine connection behavior. Deprecated.

Definition

Visual Basic | Public Property Flags As ConnectFlags
C# | public ConnectFlags Flags { get; set; }
C++ public:
property ConnectFlags Flags {
ConnectFlags get();
void set(ConnectFlags value);
}
JScript public function get Flags() : ConnectFlags
public function set Flags(ConnectFlags);

Property Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectFlags

This property is read/write.


ConnectInformation.GuidApplication Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectInformation.GuidApplication Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the application. Deprecated.

Definition

Visual Basic | Public Property GuidApplication As Guid
C# | public Guid GuidApplication { get; set; }
C++ public:
property Guid GuidApplication {
Guid get();
void set(Guid value);
}
JScript public function get GuidApplication() : Guid
public function set GuidApplication(Guid);

Property Value

System.Guid

This property is read/write.


ConnectInformation.LobbyConnectData Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectInformation.LobbyConnectData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to connection data passed to the lobbied application. Deprecated.

Definition

Visual Basic | Public Property LobbyConnectData As NetworkPacket
C# | public NetworkPacket LobbyConnectData { get; set; }
C++ public:
property NetworkPacket^ LobbyConnectData {
NetworkPacket^ get();
void set(NetworkPacket^ value);
}
JScript public function get LobbyConnectData() : NetworkPacket
public function set LobbyConnectData(NetworkPacket);

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read/write.


ConnectInformation.UseConnectionSettings Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectInformation.UseConnectionSettings Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets or sets a value that specifies whether or not the connection settings should be used. Deprecated.

Definition

Visual Basic | Public Property UseConnectionSettings As Boolean
C# | public bool UseConnectionSettings { get; set; }
C++ public:
property bool UseConnectionSettings {
bool get();
void set(bool value);
}
JScript public function get UseConnectionSettings() : boolean
public function set UseConnectionSettings(boolean);

Property Value

System.Boolean

This property is read/write.


ConnectInformation.ConnectionSettings Field (Microsoft.DirectX.DirectPlay.Lobby)

ConnectInformation.ConnectionSettings Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains the connection settings you want to associate with the connection when it is established. Deprecated.

Definition

Visual Basic | Public ConnectionSettings As ConnectionSettings
C# | public ConnectionSettings ConnectionSettings;
C++ | public: ConnectionSettings ConnectionSettings;
JScript | public var ConnectionSettings : ConnectionSettings

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings

This field is read/write.


ConnectionSettings Structure (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to specify the settings you want to associate with a connection. These settings contain all the information required to create, initialize and connect/host a Microsoft® DirectPlay® object. Deprecated.

Definition

Visual Basic | Public Structure ConnectionSettings
C# | public struct ConnectionSettings
C++ | public value class ConnectionSettings sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
ApplicationDescriptionChanged
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectionSettings
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
GetDeviceAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the array of device addresses. Deprecated.
SetDeviceAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The following flag can be specified. Deprecated.
HostAddress
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If DPLCONNECTSETTINGS_HOST is not specified, this is the address of the session the client should connect to. Deprecated.
PlayerName
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Can be used to pass the player name you want the DirectPlay object to use when launching. This member can be NULL. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectionSettings.ConnectionSettings() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings.ConnectionSettings Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectionSettings();
C++ public:
ConnectionSettings();
JScript | public function ConnectionSettings();


ConnectionSettings.GetDeviceAddresses() Method (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings.GetDeviceAddresses Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the array of device addresses. Deprecated.

Definition

Visual Basic | Public Function GetDeviceAddresses() As Address()
C# | public Address[] GetDeviceAddresses();
C++ public:
array<Address^>^ GetDeviceAddresses();
JScript | public function GetDeviceAddresses() : Address[];

Return Value

Microsoft.DirectX.DirectPlay.Address[]


ConnectionSettings.SetDeviceAddresses(Address[]) Method (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings.SetDeviceAddresses Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub SetDeviceAddresses( _
ByVal value() As Address _
)
C# public void SetDeviceAddresses(
Address[] value
);
C++ public:
void SetDeviceAddresses(
array<Address^>^ value
);
JScript public function SetDeviceAddresses(
value : Address[]
);

Parameters

value Microsoft.DirectX.DirectPlay.Address[]


ConnectionSettings.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConnectionSettings.Flags Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The following flag can be specified. Deprecated.

Definition

Visual Basic | Public Property Flags As ConnectionSettingsFlags
C# | public ConnectionSettingsFlags Flags { get; set; }
C++ public:
property ConnectionSettingsFlags Flags {
ConnectionSettingsFlags get();
void set(ConnectionSettingsFlags value);
}
JScript public function get Flags() : ConnectionSettingsFlags
public function set Flags(ConnectionSettingsFlags);

Property Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsFlags

This property is read/write.


ConnectionSettings.HostAddress Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings.HostAddress Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If DPLCONNECTSETTINGS_HOST is not specified, this is the address of the session the client should connect to. Deprecated.

Definition

Visual Basic | Public Property HostAddress As Address
C# | public Address HostAddress { get; set; }
C++ public:
property Address^ HostAddress {
Address^ get();
void set(Address^ value);
}
JScript public function get HostAddress() : Address
public function set HostAddress(Address);

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read/write.


ConnectionSettings.PlayerName Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings.PlayerName Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Can be used to pass the player name you want the DirectPlay object to use when launching. This member can be NULL. Deprecated.

Definition

Visual Basic | Public Property PlayerName As String
C# | public string PlayerName { get; set; }
C++ public:
property String^ PlayerName {
String^ get();
void set(String^ value);
}
JScript public function get PlayerName() : String
public function set PlayerName(String);

Property Value

System.String

This property is read/write.


ConnectionSettings.ApplicationDescriptionChanged Field (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettings.ApplicationDescriptionChanged Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public ApplicationDescriptionChanged As ApplicationDescription
C# | public ApplicationDescription ApplicationDescriptionChanged;
C++ | public: ApplicationDescription ApplicationDescriptionChanged;
JScript | public var ApplicationDescriptionChanged : ApplicationDescription

Field Value

Microsoft.DirectX.DirectPlay.ApplicationDescription

This field is read/write.


ConnectionSettingsMessage Structure (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.

Definition

Visual Basic | Public Structure ConnectionSettingsMessage
C# | public struct ConnectionSettingsMessage
C++ | public value class ConnectionSettingsMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
ConnectionSettings
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains a reference to a DplConnectionSettingsDplay structure describing the connection settings for the specified connection. Deprecated.

Methods

Method Description
ConnectionSettingsMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a context value that has been set for the connection. Deprecated.
Sender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains the handle to the connection that sent this message. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectionSettingsMessage.ConnectionSettingsMessage() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsMessage.ConnectionSettingsMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectionSettingsMessage();
C++ public:
ConnectionSettingsMessage();
JScript | public function ConnectionSettingsMessage();


ConnectionSettingsMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConnectionSettingsMessage.ConnectionContext Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsMessage.ConnectionContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a context value that has been set for the connection. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ConnectionContext As Object
C# | public object ConnectionContext { get; }
C++ public:
property Object^ ConnectionContext {
Object^ get();
}
JScript | public function get ConnectionContext() : Object

Property Value

System.Object

This property is read-only.


ConnectionSettingsMessage.Sender Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsMessage.Sender Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains the handle to the connection that sent this message. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Sender As Integer
C# | public int Sender { get; }
C++ public:
property int Sender {
int get();
}
JScript | public function get Sender() : int

Property Value

System.Int32

This property is read-only.


ConnectionSettingsMessage.ConnectionSettings Field (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsMessage.ConnectionSettings Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains a reference to a DplConnectionSettingsDplay structure describing the connection settings for the specified connection. Deprecated.

Definition

Visual Basic | Public ConnectionSettings As ConnectionSettings
C# | public ConnectionSettings ConnectionSettings;
C++ | public: ConnectionSettings ConnectionSettings;
JScript | public var ConnectionSettings : ConnectionSettings

Field Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings

This field is read/write.


ConnectMessage Structure (Microsoft.DirectX.DirectPlay.Lobby)

ConnectMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a ConnectDplay message when a lobby client connects to the lobbied application through the method.The structure is passed with the ConnectDplay message. Deprecated.

Definition

Visual Basic | Public Structure ConnectMessage
C# | public struct ConnectMessage
C++ | public value class ConnectMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ConnectMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value associated with this connection. For lobbied applications, set this parameter when this message is received in your message handler to associate the context value with the connection. This may be set to NULL to disable context values. Deprecated.
ConnectionHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle used to identify the connection. This handle is used in subsequent calls to Play8lobbyclientSendDplay and Play8lobbyclientReleaseapplicationDplay. Deprecated.
ConnectionSettings
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a DplConnectionSettingsDplay structure with connection information. Deprecated.
ConnectionSettingsValid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a DplConnectionSettingsDplay structure with connection information. Deprecated.
LobbyConnectData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to lobby connection data. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectMessage.ConnectMessage() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ConnectMessage.ConnectMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectMessage();
C++ public:
ConnectMessage();
JScript | public function ConnectMessage();


ConnectMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

ConnectMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConnectMessage.ConnectionContext Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectMessage.ConnectionContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value associated with this connection. For lobbied applications, set this parameter when this message is received in your message handler to associate the context value with the connection. This may be set to NULL to disable context values. Deprecated.

Definition

Visual Basic | Public Property ConnectionContext As Object
C# | public object ConnectionContext { get; set; }
C++ public:
property Object^ ConnectionContext {
Object^ get();
void set(Object^ value);
}
JScript public function get ConnectionContext() : Object
public function set ConnectionContext(Object);

Property Value

System.Object

This property is read/write.


ConnectMessage.ConnectionHandle Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectMessage.ConnectionHandle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle used to identify the connection. This handle is used in subsequent calls to Play8lobbyclientSendDplay and Play8lobbyclientReleaseapplicationDplay. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ConnectionHandle As Integer
C# | public int ConnectionHandle { get; }
C++ public:
property int ConnectionHandle {
int get();
}
JScript | public function get ConnectionHandle() : int

Property Value

System.Int32

This property is read-only.


ConnectMessage.ConnectionSettings Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectMessage.ConnectionSettings Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a DplConnectionSettingsDplay structure with connection information. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ConnectionSettings As ConnectionSettings
C# | public ConnectionSettings ConnectionSettings { get; }
C++ public:
property ConnectionSettings ConnectionSettings {
ConnectionSettings get();
}
JScript | public function get ConnectionSettings() : ConnectionSettings

Property Value

Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettings

This property is read-only.


ConnectMessage.ConnectionSettingsValid Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectMessage.ConnectionSettingsValid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a DplConnectionSettingsDplay structure with connection information. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ConnectionSettingsValid As Boolean
C# | public bool ConnectionSettingsValid { get; }
C++ public:
property bool ConnectionSettingsValid {
bool get();
}
JScript | public function get ConnectionSettingsValid() : boolean

Property Value

System.Boolean

This property is read-only.


ConnectMessage.LobbyConnectData Property (Microsoft.DirectX.DirectPlay.Lobby)

ConnectMessage.LobbyConnectData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to lobby connection data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property LobbyConnectData As NetworkPacket
C# | public NetworkPacket LobbyConnectData { get; }
C++ public:
property NetworkPacket^ LobbyConnectData {
NetworkPacket^ get();
}
JScript | public function get LobbyConnectData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read-only.


DisconnectMessage Structure (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates a DisconnectDplay message when a lobby client disconnects from a lobbied application through the method.The structure contains information for the DisconnectDplay system message. Deprecated.

Definition

Visual Basic | Public Structure DisconnectMessage
C# | public struct DisconnectMessage
C++ | public value class DisconnectMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DisconnectMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.
DisconnectId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle specifying the disconnection identifier. Deprecated.
Reason
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reason for the disconnection. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisconnectMessage.DisconnectMessage() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectMessage.DisconnectMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DisconnectMessage();
C++ public:
DisconnectMessage();
JScript | public function DisconnectMessage();


DisconnectMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DisconnectMessage.ConnectionContext Property (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectMessage.ConnectionContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ConnectionContext As Object
C# | public object ConnectionContext { get; }
C++ public:
property Object^ ConnectionContext {
Object^ get();
}
JScript | public function get ConnectionContext() : Object

Property Value

System.Object

This property is read-only.


DisconnectMessage.DisconnectId Property (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectMessage.DisconnectId Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle specifying the disconnection identifier. Deprecated.

Definition

Visual Basic | Public ReadOnly Property DisconnectId As Integer
C# | public int DisconnectId { get; }
C++ public:
property int DisconnectId {
int get();
}
JScript | public function get DisconnectId() : int

Property Value

System.Int32

This property is read-only.


DisconnectMessage.Reason Property (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectMessage.Reason Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reason for the disconnection. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Reason As ResultCode
C# | public ResultCode Reason { get; }
C++ public:
property ResultCode Reason {
ResultCode get();
}
JScript | public function get Reason() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode

This property is read-only.


ProgramDescription Structure (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes a Microsoft® DirectPlay® lobby-aware application. Deprecated.

Definition

Visual Basic | Public Structure ProgramDescription
C# | public struct ProgramDescription
C++ | public value class ProgramDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ProgramDescription
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ApplicationName
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the application name. Deprecated.
CommandLine
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the command-line arguments. Deprecated.
CurrentDirectory
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the directory that should be set as the application's working directory.. Deprecated.
Description
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the application description. Deprecated.
ExecutableFilename
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the file name of the application executable. Deprecated.
ExecutablePath
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the path of the application executable. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.
GuidApplication
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the application. Deprecated.
LauncherFilename
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the file name of the launcher executable. Deprecated.
LauncherPath
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the path of the launcher executable. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ProgramDescription.ProgramDescription() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.ProgramDescription Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ProgramDescription();
C++ public:
ProgramDescription();
JScript | public function ProgramDescription();


ProgramDescription.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ProgramDescription.ApplicationName Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.ApplicationName Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the application name. Deprecated.

Definition

Visual Basic | Public Property ApplicationName As String
C# | public string ApplicationName { get; set; }
C++ public:
property String^ ApplicationName {
String^ get();
void set(String^ value);
}
JScript public function get ApplicationName() : String
public function set ApplicationName(String);

Property Value

System.String

This property is read/write.


ProgramDescription.CommandLine Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.CommandLine Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the command-line arguments. Deprecated.

Definition

Visual Basic | Public Property CommandLine As String
C# | public string CommandLine { get; set; }
C++ public:
property String^ CommandLine {
String^ get();
void set(String^ value);
}
JScript public function get CommandLine() : String
public function set CommandLine(String);

Property Value

System.String

This property is read/write.


ProgramDescription.CurrentDirectory Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.CurrentDirectory Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the directory that should be set as the application's working directory.. Deprecated.

Definition

Visual Basic | Public Property CurrentDirectory As String
C# | public string CurrentDirectory { get; set; }
C++ public:
property String^ CurrentDirectory {
String^ get();
void set(String^ value);
}
JScript public function get CurrentDirectory() : String
public function set CurrentDirectory(String);

Property Value

System.String

This property is read/write.


ProgramDescription.Description Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.Description Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the application description. Deprecated.

Definition

Visual Basic | Public Property Description As String
C# | public string Description { get; set; }
C++ public:
property String^ Description {
String^ get();
void set(String^ value);
}
JScript public function get Description() : String
public function set Description(String);

Property Value

System.String

This property is read/write.


ProgramDescription.ExecutableFilename Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.ExecutableFilename Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the file name of the application executable. Deprecated.

Definition

Visual Basic | Public Property ExecutableFilename As String
C# | public string ExecutableFilename { get; set; }
C++ public:
property String^ ExecutableFilename {
String^ get();
void set(String^ value);
}
JScript public function get ExecutableFilename() : String
public function set ExecutableFilename(String);

Property Value

System.String

This property is read/write.


ProgramDescription.ExecutablePath Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.ExecutablePath Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the path of the application executable. Deprecated.

Definition

Visual Basic | Public Property ExecutablePath As String
C# | public string ExecutablePath { get; set; }
C++ public:
property String^ ExecutablePath {
String^ get();
void set(String^ value);
}
JScript public function get ExecutablePath() : String
public function set ExecutablePath(String);

Property Value

System.String

This property is read/write.


ProgramDescription.Flags Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic | Public Property Flags As Integer
C# | public int Flags { get; set; }
C++ public:
property int Flags {
int get();
void set(int value);
}
JScript public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32

This property is read/write.


ProgramDescription.GuidApplication Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.GuidApplication Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type GUID specifying the application. Deprecated.

Definition

Visual Basic | Public Property GuidApplication As Guid
C# | public Guid GuidApplication { get; set; }
C++ public:
property Guid GuidApplication {
Guid get();
void set(Guid value);
}
JScript public function get GuidApplication() : Guid
public function set GuidApplication(Guid);

Property Value

System.Guid

This property is read/write.


ProgramDescription.LauncherFilename Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.LauncherFilename Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the file name of the launcher executable. Deprecated.

Definition

Visual Basic | Public Property LauncherFilename As String
C# | public string LauncherFilename { get; set; }
C++ public:
property String^ LauncherFilename {
String^ get();
void set(String^ value);
}
JScript public function get LauncherFilename() : String
public function set LauncherFilename(String);

Property Value

System.String

This property is read/write.


ProgramDescription.LauncherPath Property (Microsoft.DirectX.DirectPlay.Lobby)

ProgramDescription.LauncherPath Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the path of the launcher executable. Deprecated.

Definition

Visual Basic | Public Property LauncherPath As String
C# | public string LauncherPath { get; set; }
C++ public:
property String^ LauncherPath {
String^ get();
void set(String^ value);
}
JScript public function get LauncherPath() : String
public function set LauncherPath(String);

Property Value

System.String

This property is read/write.


ReceiveMessage Structure (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.

Definition

Visual Basic | Public Structure ReceiveMessage
C# | public struct ReceiveMessage
C++ | public value class ReceiveMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ReceiveMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.
ReceiveData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the message data buffer. This buffer is normally only valid while the DpnMsgidReceiveDplay message is being processed by the callback message handler. Deprecated.
Sender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle of the client that sent the message. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ReceiveMessage.ReceiveMessage() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveMessage.ReceiveMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ReceiveMessage();
C++ public:
ReceiveMessage();
JScript | public function ReceiveMessage();


ReceiveMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ReceiveMessage.ConnectionContext Property (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveMessage.ConnectionContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ConnectionContext As Object
C# | public object ConnectionContext { get; }
C++ public:
property Object^ ConnectionContext {
Object^ get();
}
JScript | public function get ConnectionContext() : Object

Property Value

System.Object

This property is read-only.


ReceiveMessage.ReceiveData Property (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveMessage.ReceiveData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the message data buffer. This buffer is normally only valid while the DpnMsgidReceiveDplay message is being processed by the callback message handler. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ReceiveData As NetworkPacket
C# | public NetworkPacket ReceiveData { get; }
C++ public:
property NetworkPacket^ ReceiveData {
NetworkPacket^ get();
}
JScript | public function get ReceiveData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read-only.


ReceiveMessage.Sender Property (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveMessage.Sender Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle of the client that sent the message. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Sender As Integer
C# | public int Sender { get; }
C++ public:
property int Sender {
int get();
}
JScript | public function get Sender() : int

Property Value

System.Int32

This property is read-only.


SessionStatusMessage Structure (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the SessionStatusDplay message when the session has been updated with a call to the method.The structure contains the information for the SessionStatusDplay system message. Deprecated.

Definition

Visual Basic | Public Structure SessionStatusMessage
C# | public struct SessionStatusMessage
C++ | public value class SessionStatusMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SessionStatusMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectionContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.
Sender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle of the application that sent the status update message. Deprecated.
Status
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Updated status of the session. This member can be set to one of the following values. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionStatusMessage.SessionStatusMessage() Constructor (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusMessage.SessionStatusMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SessionStatusMessage();
C++ public:
SessionStatusMessage();
JScript | public function SessionStatusMessage();


SessionStatusMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


SessionStatusMessage.ConnectionContext Property (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusMessage.ConnectionContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Context value that has been set for the connection. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ConnectionContext As Object
C# | public object ConnectionContext { get; }
C++ public:
property Object^ ConnectionContext {
Object^ get();
}
JScript | public function get ConnectionContext() : Object

Property Value

System.Object

This property is read-only.


SessionStatusMessage.Sender Property (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusMessage.Sender Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle of the application that sent the status update message. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Sender As Integer
C# | public int Sender { get; }
C++ public:
property int Sender {
int get();
}
JScript | public function get Sender() : int

Property Value

System.Int32

This property is read-only.


SessionStatusMessage.Status Property (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusMessage.Status Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Updated status of the session. This member can be set to one of the following values. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Status As SessionStatusFlags
C# | public SessionStatusFlags Status { get; }
C++ public:
property SessionStatusFlags Status {
SessionStatusFlags get();
}
JScript | public function get Status() : SessionStatusFlags

Property Value

Microsoft.DirectX.DirectPlay.Lobby.SessionStatusFlags

This property is read-only.


ConnectEventHandler(Object,ConnectEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Lobby)

ConnectEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Connect event. Deprecated.

Definition

Visual Basic Public Delegate Sub ConnectEventHandler( _
ByVal sender As Object, _
ByVal e As ConnectEventArgs _
)
C# public delegate void ConnectEventHandler(
object sender,
ConnectEventArgs e
);
C++ public delegate void ConnectEventHandler(
Object^ sender,
ConnectEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Lobby.ConnectEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectionSettingsEventHandler(Object,ConnectionSettingsEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Lobby)

ConnectionSettingsEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The ConnectionSettingsDplay message is sent from the lobby client to the lobby application when is called. It is also sent from the lobby application to the lobby client when is called. Deprecated.

Definition

Visual Basic Public Delegate Sub ConnectionSettingsEventHandler( _
ByVal sender As Object, _
ByVal e As ConnectionSettingsEventArgs _
)
C# public delegate void ConnectionSettingsEventHandler(
object sender,
ConnectionSettingsEventArgs e
);
C++ public delegate void ConnectionSettingsEventHandler(
Object^ sender,
ConnectionSettingsEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Lobby.ConnectionSettingsEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisconnectEventHandler(Object,DisconnectEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Lobby)

DisconnectEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub DisconnectEventHandler( _
ByVal sender As Object, _
ByVal e As DisconnectEventArgs _
)
C# public delegate void DisconnectEventHandler(
object sender,
DisconnectEventArgs e
);
C++ public delegate void DisconnectEventHandler(
Object^ sender,
DisconnectEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Lobby.DisconnectEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ReceiveLobbyEventHandler(Object,ReceiveEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Lobby)

ReceiveLobbyEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Receive event. Deprecated.

Definition

Visual Basic Public Delegate Sub ReceiveLobbyEventHandler( _
ByVal sender As Object, _
ByVal e As ReceiveEventArgs _
)
C# public delegate void ReceiveLobbyEventHandler(
object sender,
ReceiveEventArgs e
);
C++ public delegate void ReceiveLobbyEventHandler(
Object^ sender,
ReceiveEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Lobby.ReceiveEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionStatusEventHandler(Object,SessionStatusEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Lobby)

SessionStatusEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionStatus event. Deprecated.

Definition

Visual Basic Public Delegate Sub SessionStatusEventHandler( _
ByVal sender As Object, _
ByVal e As SessionStatusEventArgs _
)
C# public delegate void SessionStatusEventHandler(
object sender,
SessionStatusEventArgs e
);
C++ public delegate void SessionStatusEventHandler(
Object^ sender,
SessionStatusEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Lobby.SessionStatusEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Lobby
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Microsoft.DirectX.DirectPlay.Voice

Warning: Microsoft DirectPlay Voice has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay Voice provides media-independent network transport and client management, but it does not duplicate DirectPlay session control features. The following tables list the members exposed by the Microsoft.DirectX.DirectPlay.Voice namespace.

Classes

AlreadyBufferedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data was already buffered. Deprecated.
AlreadyPendingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is already pending. Deprecated.
Client
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Client object to manage clients in a voice session. Deprecated.
CompressionGuid
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various compression codecs that can be used. Deprecated.
CompressionNotSupportedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified compression type is not supported on the local computer. Deprecated.
ConnectAbortedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connect operation was canceled before it could be completed. Deprecated.
ConnectAbortingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection is being disconnected. Deprecated.
ConnectedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay Voice object is connected. Deprecated.
ConnectionLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection to the voice session has been lost. Deprecated.
ConnectResultEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidConnectresultDplay message when the connect request generated through a call to the PlayvoiceclientConnectDplay method has completed.The structure contains information for the DvmsgidConnectresultDplay message. Deprecated.
DisconnectResultEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.
HostingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is the host of the session. Deprecated.
HostMigratedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.
IncompatibleVersionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The client connected to a voice session that is incompatible with the host. Deprecated.
InputLevelEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidInputlevelDplay message periodically to notify the user of the input level from the microphone.The structure contains information for the DvmsgidInputlevelDplay system message. Deprecated.
InvalidBufferException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A buffer specified as a parameter is invalid. Deprecated.
InvalidDeviceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified device is invalid. Deprecated.
InvalidFlagsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The flags passed to this method are invalid. Deprecated.
InvalidGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The group ID is not recognized as a valid group ID for this game session. Deprecated.
InvalidHandleException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle specified is invalid. Deprecated.
InvalidObjectException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay object is invalid. Deprecated.
InvalidPlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not recognized as a valid player ID for this game session. Deprecated.
InvalidTargetException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified target is not a valid player ID or group ID for this voice session. Deprecated.
LockedBufferException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The buffer is already locked. Deprecated.
No3DSoundException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The local computer does not support 3-D sound. Deprecated.
NoRecordVolumeAvailableException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The local computer does not support record volume. Deprecated.
NotAllowedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object does not have the permission to perform this operation. Deprecated.
NotBufferedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no user buffer for the specified ID. Deprecated.
NotConnectedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay Voice object is not connected. Deprecated.
NotHostingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not the host of the session. Deprecated.
NoTransportException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified object is not a valid transport. Deprecated.
NotSupportedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is not supported. Deprecated.
NoVoiceSessionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The session specified is not a voice session. Deprecated.
OutputLevelEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidOutputlevelDplay message periodically to notify the user of the output level of playback.The structure contains information for the DvmsgidOutputlevelDplay system message. Deprecated.
PlaybackSystemErrorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error in the playback system occurred. Deprecated.
PlayerOutputLevelEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.
PlayerStartedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerStarted event. Deprecated.
PlayerStoppedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerStopped event. Deprecated.
RecordStartedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the RecordStarted event. Deprecated.
RecordStoppedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the RecordStopped event. Deprecated.
RecordSystemErrorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error in the recording system occurred. Deprecated.
RunSetupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified audio configuration has not been tested. Call the Test.CheckAudioSetup method. Deprecated.
SendErrorException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error occurred while sending data. Deprecated.
Server
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Server object to manage the host of the voice session. Deprecated.
SessionLostEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidSessionlostDplay message when the voice session terminates.The structure contains information for the DvmsgidSessionlostDplay system message. Deprecated.
SessionLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The transport has lost the connection to the session. Deprecated.
SetTargetsEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the SetTargets event. Deprecated.
SoundInitializeFailureException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A failure was encountered initializing the sound card. Deprecated.
Test
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the Test.CheckAudioSetup method of the Test object to test the Microsoft® DirectPlay® Voice audio configuration. Deprecated.
TimedOutException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not complete because it has timed out. Deprecated.
TransportNoPlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified transport is connected/hosting but no local player exists. Deprecated.
TransportNoSessionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified transport is valid but is not connected/hosting. Deprecated.
TransportNotHostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not the host of the voice session. Deprecated.
UserBackException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user has pressed back on the first page of the CheckAudioSetup wizard. Deprecated.
UserCancelException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user canceled the operation. Deprecated.
VoiceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception type for DirectPlay Voice exceptions. Derives from DirectXException. Deprecated.
VoicePlayerCreatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerCreated event. Deprecated.
VoicePlayerDeletedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerDeleted event. Deprecated.

Enumerations

BufferAggressiveness
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for BufferAggressiveness. Deprecated.
BufferQuality
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for BufferQuality. Deprecated.
ClientConfigFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for client configuration. Deprecated.
InputLevelFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for input level. Deprecated.
NotifyPeriod
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for NotifyPeriod. Deprecated.
PlaybackVolume
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for PlaybackVolume. Deprecated.
PlayerCapsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player capability flags. Deprecated.
PlayerId
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
System wide player id's. Deprecated.
RecordVolume
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for RecordVolume. Deprecated.
ResultCode
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various codes that can be returned by events. Deprecated.
SessionFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for controlling sessions. Deprecated.
SessionType
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The type of DirectPlay Voice session to run. Deprecated.
SoundConfigFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags to control how the sound device is configured. Deprecated.
StopSessionFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for stopping a session. Deprecated.
TestFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines whether the user can press the Back button and whether the setup should be queried. Deprecated.
Threshold
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for Threshold. Deprecated.
VoiceFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various flags for DirectPlay Voice. Deprecated.

Structures

ClientConfig
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the run-time parameters for the client. Deprecated.
CompressionInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the attributes of a specific Microsoft® DirectPlay® Voice compression type. Deprecated.
ConnectResultMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidConnectresultDplay message when the connect request generated through a call to the PlayvoiceclientConnectDplay method has completed.The structure contains information for the DvmsgidConnectresultDplay message. Deprecated.
CreateVoicePlayerMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidCreatevoiceplayerDplay message when a new player joins the voice session.The structure contains information for the DvmsgidCreatevoiceplayerDplay message. Deprecated.
DeleteVoicePlayerMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
For clients, Microsoft® DirectPlay® Voice generates the DvmsgidDeletevoiceplayerDplay message when a player quits the voice session. This message is available only to clients in peer-to-peer voice sessions.For the host, Microsoft® DirectPlay® Voice generates the message when a player quits the voice session.The structure contains information for the DvmsgidDeletevoiceplayerDplay system message. Deprecated.
DisconnectResultMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.
HostMigratedMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.
InputLevelMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidInputlevelDplay message periodically to notify the user of the input level from the microphone.The structure contains information for the DvmsgidInputlevelDplay system message. Deprecated.
OutputLevelMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidOutputlevelDplay message periodically to notify the user of the output level of playback.The structure contains information for the DvmsgidOutputlevelDplay system message. Deprecated.
PlayerOutputLevelMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.
PlayerVoiceStartMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayervoicestartDplay message when an incoming audio stream begins playing back.The structure contains information for the DvmsgidPlayervoicestartDplay system message. Deprecated.
PlayerVoiceStopMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayervoicestopDplay message when an incoming audio stream stops.The DvmsgidPlayervoicestopDplay structure contains information for the DvmsgidPlayervoicestopDplay system message. Deprecated.
RecordStartMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidRecordstartDplay message when audio input on the local client begins.The structure contains information for the DvmsgidRecordstartDplay system message. Deprecated.
RecordStopMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidRecordstopDplay message when audio input on the local client stops.The structure contains information for the DvmsgidRecordstopDplay system message. Deprecated.
SessionDescription
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the desired or current session settings for the Microsoft® DirectPlay® Voice server. This structure is used by the voice session host to configure the session, and by the session host and clients to retrieve information about the current session. Deprecated.
SessionLostMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidSessionlostDplay message when the voice session terminates.The structure contains information for the DvmsgidSessionlostDplay system message. Deprecated.
SetTargetsMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
PdvmessagehandlerDplay is an application-defined callback function used by the PlayvoiceclientDplay and PlayvoiceserverDplay objects to send messages to the user. Deprecated.
SoundDeviceConfig
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to set and retrieve information about the sound device configuration and cannot be changed once a connection has been made. After a connection is made, you can retrieve the current sound device configuration by calling PlayvoiceclientGetsounddeviceconfigDplay. Deprecated.

Delegates

ConnectResultEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ConnectResult event. Deprecated.
DisconnectResultEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.
InputLevelEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the InputLevel event. Deprecated.
OutputLevelEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the OutputLevel event. Deprecated.
PlayerOutputLevelEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.
PlayerStartedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerStarted event. Deprecated.
PlayerStoppedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerStopped event. Deprecated.
RecordStartedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the RecordStarted event. Deprecated.
RecordStoppedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the RecordStopped event. Deprecated.
SessionLostEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionLost event. Deprecated.
SetTargetsEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SetTargets event. Deprecated.
VoiceHostMigratedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the HostMigrated event. Deprecated.
VoicePlayerCreatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerCreated event. Deprecated.
VoicePlayerDeletedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerDeleted event. Deprecated.


AlreadyBufferedException Class (Microsoft.DirectX.DirectPlay.Voice)

AlreadyBufferedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data was already buffered. Deprecated.

Definition

Visual Basic Public Class AlreadyBufferedException
Inherits VoiceException
C# | public class AlreadyBufferedException : VoiceException
C++ | public ref class AlreadyBufferedException : VoiceException
JScript | public class AlreadyBufferedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyBufferedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
AlreadyBufferedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AlreadyBufferedException.AlreadyBufferedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyBufferedException();
protected AlreadyBufferedException(SerializationInfo, StreamingContext);
public AlreadyBufferedException(string);
public AlreadyBufferedException(string, Exception);


AlreadyBufferedException.AlreadyBufferedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyBufferedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AlreadyBufferedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AlreadyBufferedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AlreadyBufferedException.AlreadyBufferedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyBufferedException(
string message,
Exception inner
);
C++ public:
AlreadyBufferedException(
String^ message,
Exception^ inner
);
JScript public function AlreadyBufferedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AlreadyBufferedException.AlreadyBufferedException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AlreadyBufferedException(
string message
);
C++ public:
AlreadyBufferedException(
String^ message
);
JScript public function AlreadyBufferedException(
message : String
);

Parameters

message System.String


AlreadyBufferedException.AlreadyBufferedException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

AlreadyBufferedException.AlreadyBufferedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AlreadyBufferedException();
C++ public:
AlreadyBufferedException();
JScript | public function AlreadyBufferedException();


AlreadyPendingException Class (Microsoft.DirectX.DirectPlay.Voice)

AlreadyPendingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is already pending. Deprecated.

Definition

Visual Basic Public Class AlreadyPendingException
Inherits VoiceException
C# | public class AlreadyPendingException : VoiceException
C++ | public ref class AlreadyPendingException : VoiceException
JScript | public class AlreadyPendingException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyPendingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
AlreadyPendingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AlreadyPendingException.AlreadyPendingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyPendingException();
protected AlreadyPendingException(SerializationInfo, StreamingContext);
public AlreadyPendingException(string);
public AlreadyPendingException(string, Exception);


AlreadyPendingException.AlreadyPendingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

AlreadyPendingException.AlreadyPendingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyPendingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AlreadyPendingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AlreadyPendingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AlreadyPendingException.AlreadyPendingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

AlreadyPendingException.AlreadyPendingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyPendingException(
string message,
Exception inner
);
C++ public:
AlreadyPendingException(
String^ message,
Exception^ inner
);
JScript public function AlreadyPendingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AlreadyPendingException.AlreadyPendingException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

AlreadyPendingException.AlreadyPendingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AlreadyPendingException(
string message
);
C++ public:
AlreadyPendingException(
String^ message
);
JScript public function AlreadyPendingException(
message : String
);

Parameters

message System.String


AlreadyPendingException.AlreadyPendingException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

AlreadyPendingException.AlreadyPendingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AlreadyPendingException();
C++ public:
AlreadyPendingException();
JScript | public function AlreadyPendingException();


Client Class (Microsoft.DirectX.DirectPlay.Voice)

Client Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Client object to manage clients in a voice session. Deprecated.

Definition

Visual Basic Public Class Client
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Client : MarshalByRefObject, IDisposable
C++ | public ref class Client : MarshalByRefObject, IDisposable
JScript | public class Client extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
ConnectResult
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.
DisconnectResult
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a disconnection has been completed. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
GainFocus
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application gains focus. Deprecated.
HostMigrated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the host has migrated. Deprecated.
InputLevel
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the input level has changed. Deprecated.
LostFocus
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application has lost focus. Deprecated.
OutputLevel
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the output level changes. Deprecated.
PlayerCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.
PlayerDeleted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.
PlayerOutputLevel
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a players output level has changed. Deprecated.
PlayerStarted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player starts talking. Deprecated.
PlayerStopped
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has stopped talking. Deprecated.
RecordStarted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the local player has started talking. Deprecated.
RecordStopped
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the local player has stopped talking. Deprecated.
SessionLost
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been lost. Deprecated.
SetTargets
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies which players and/or groups receive audio transmissions from the local client. Deprecated.

Methods

Method Description
Client
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.
Create3DSoundBuffer
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a 3-D sound buffer for a player or group. You can use the methods of the 3-D sound buffer object to change the virtual 3-D position of incoming voice transmissions from the specified group or player. Deprecated.
Delete3DSoundBuffer
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns exclusive control of the 3-D sound buffer object to the Microsoft® DirectPlay® voice client object. Deprecated.
Disconnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disconnects the Microsoft® DirectPlay® Voice client from the existing Microsoft® DirectPlay® Voice session. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_ConnectResult
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_DisconnectResult
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GainFocus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_HostMigrated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_InputLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_LostFocus
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_OutputLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerDeleted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerOutputLevel
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerStarted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerStopped
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_RecordStarted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_RecordStopped
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionLost
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SetTargets
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ClientConfig
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the client configuration. Deprecated.
CompressionTypes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the available compression types on the system. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
SessionDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the session properties. Deprecated.
SoundDeviceConfig
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the sound device configuration of the session. Deprecated.
TransmitTargets
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the transmit targets, if any, of the voice stream from this client. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Client

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Client.Client Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Client(object);
public Client(object, int[]);


Client.Client(Object,Int32[]) Constructor (Microsoft.DirectX.DirectPlay.Voice)

Client.Client Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dplayObject As Object, _
ByVal msgMask() As Integer _
)
C# public Client(
object dplayObject,
int[] msgMask
);
C++ public:
Client(
Object^ dplayObject,
array<int>^ msgMask
);
JScript public function Client(
dplayObject : Object,
msgMask : int[]
);

Parameters

dplayObject System.Object
msgMask System.Int32[]


Client.Client(Object) Constructor (Microsoft.DirectX.DirectPlay.Voice)

Client.Client Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dplayObject As Object _
)
C# public Client(
object dplayObject
);
C++ public:
Client(
Object^ dplayObject
);
JScript public function Client(
dplayObject : Object
);

Parameters

dplayObject System.Object


Client.Connect(SoundDeviceConfig,ClientConfig,VoiceFlags) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal soundConfig As SoundDeviceConfig, _
ByVal clientConfig As ClientConfig, _
ByVal flags As VoiceFlags _
)
C# public void Connect(
SoundDeviceConfig soundConfig,
ClientConfig clientConfig,
VoiceFlags flags
);
C++ public:
void Connect(
SoundDeviceConfig soundConfig,
ClientConfig clientConfig,
VoiceFlags flags
);
JScript public function Connect(
soundConfig : SoundDeviceConfig,
clientConfig : ClientConfig,
flags : VoiceFlags
);

Parameters

soundConfig Microsoft.DirectX.DirectPlay.Voice.SoundDeviceConfig
clientConfig Microsoft.DirectX.DirectPlay.Voice.ClientConfig
flags Microsoft.DirectX.DirectPlay.Voice.VoiceFlags


Client.Create3DSoundBuffer Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a 3-D sound buffer for a player or group. You can use the methods of the 3-D sound buffer object to change the virtual 3-D position of incoming voice transmissions from the specified group or player. Deprecated.

Overload List

public Buffer3D Create3DSoundBuffer(int);
public Buffer3D Create3DSoundBuffer(int, Buffer, int, int);


Client.Create3DSoundBuffer(Int32) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.Create3DSoundBuffer Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a 3-D sound buffer for a player or group. You can use the methods of the 3-D sound buffer object to change the virtual 3-D position of incoming voice transmissions from the specified group or player. Deprecated.

Definition

Visual Basic Public Function Create3DSoundBuffer( _
ByVal sourcePlayerID As Integer _
) As Buffer3D
C# public Buffer3D Create3DSoundBuffer(
int sourcePlayerID
);
C++ public:
Buffer3D^ Create3DSoundBuffer(
int sourcePlayerID
);
JScript public function Create3DSoundBuffer(
sourcePlayerID : int
) : Buffer3D;

Parameters

sourcePlayerID System.Int32

Return Value

Microsoft.DirectX.DirectSound.Buffer3D


Client.Create3DSoundBuffer(Int32,Buffer,Int32,Int32) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.Create3DSoundBuffer Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a 3-D sound buffer for a player or group. You can use the methods of the 3-D sound buffer object to change the virtual 3-D position of incoming voice transmissions from the specified group or player. Deprecated.

Definition

Visual Basic Public Function Create3DSoundBuffer( _
ByVal sourcePlayerID As Integer, _
ByVal sourceBuffer As Buffer, _
ByVal priority As Integer, _
ByVal flags As Integer _
) As Buffer3D
C# public Buffer3D Create3DSoundBuffer(
int sourcePlayerID,
Buffer sourceBuffer,
int priority,
int flags
);
C++ public:
Buffer3D^ Create3DSoundBuffer(
int sourcePlayerID,
Buffer^ sourceBuffer,
int priority,
int flags
);
JScript public function Create3DSoundBuffer(
sourcePlayerID : int,
sourceBuffer : Buffer,
priority : int,
flags : int
) : Buffer3D;

Parameters

sourcePlayerID System.Int32
sourceBuffer Microsoft.DirectX.DirectSound.Buffer
priority System.Int32
flags System.Int32

Return Value

Microsoft.DirectX.DirectSound.Buffer3D


Client.Delete3DSoundBuffer(Int32,Buffer3D) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.Delete3DSoundBuffer Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns exclusive control of the 3-D sound buffer object to the Microsoft® DirectPlay® voice client object. Deprecated.

Definition

Visual Basic Public Sub Delete3DSoundBuffer( _
ByVal sourcePlayerID As Integer, _
ByVal userBuffer As Buffer3D _
)
C# public void Delete3DSoundBuffer(
int sourcePlayerID,
Buffer3D userBuffer
);
C++ public:
void Delete3DSoundBuffer(
int sourcePlayerID,
Buffer3D^ userBuffer
);
JScript public function Delete3DSoundBuffer(
sourcePlayerID : int,
userBuffer : Buffer3D
);

Parameters

sourcePlayerID System.Int32
userBuffer Microsoft.DirectX.DirectSound.Buffer3D


Client.Disconnect(VoiceFlags) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.Disconnect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disconnects the Microsoft® DirectPlay® Voice client from the existing Microsoft® DirectPlay® Voice session. Deprecated.

Definition

Visual Basic Public Sub Disconnect( _
ByVal flags As VoiceFlags _
)
C# public void Disconnect(
VoiceFlags flags
);
C++ public:
void Disconnect(
VoiceFlags flags
);
JScript public function Disconnect(
flags : VoiceFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.Voice.VoiceFlags


Client.Dispose() Method (Microsoft.DirectX.DirectPlay.Voice)

Client.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Client();
JScript | public override function Dispose();


Client.Equals(Object) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Client.Finalize() Method (Microsoft.DirectX.DirectPlay.Voice)

Client.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Client();
C++ | !Client();
JScript | protected override function Finalize();


Client.GetHashCode() Method (Microsoft.DirectX.DirectPlay.Voice)

Client.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Client.op_Equality(Client,Client) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Equality(
Client left,
Client right
);
C++ public:
static bool operator==(
Client^ left,
Client^ right
);
JScript public static function op_Equality(
left : Client,
right : Client
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Voice.Client
The Client structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Voice.Client
The Client structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Client.op_Inequality(Client,Client) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Inequality(
Client left,
Client right
);
C++ public:
static bool operator!=(
Client^ left,
Client^ right
);
JScript public static function op_Inequality(
left : Client,
right : Client
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Voice.Client
The Client structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Voice.Client
The Client structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Client.raise_ConnectResult(Object,ConnectResultEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_ConnectResult Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ConnectResult( _
ByVal i1 As Object, _
ByVal i2 As ConnectResultEventArgs _
)
C# protected void raise_ConnectResult(
object i1,
ConnectResultEventArgs i2
);
C++ protected:
void raise_ConnectResult(
Object^ i1,
ConnectResultEventArgs^ i2
);
JScript protected function raise_ConnectResult(
i1 : Object,
i2 : ConnectResultEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.ConnectResultEventArgs


Client.raise_DisconnectResult(Object,DisconnectResultEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_DisconnectResult Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_DisconnectResult( _
ByVal i1 As Object, _
ByVal i2 As DisconnectResultEventArgs _
)
C# protected void raise_DisconnectResult(
object i1,
DisconnectResultEventArgs i2
);
C++ protected:
void raise_DisconnectResult(
Object^ i1,
DisconnectResultEventArgs^ i2
);
JScript protected function raise_DisconnectResult(
i1 : Object,
i2 : DisconnectResultEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.DisconnectResultEventArgs


Client.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Client.raise_GainFocus(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_GainFocus Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_GainFocus( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_GainFocus(
object i1,
EventArgs i2
);
C++ protected:
void raise_GainFocus(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_GainFocus(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Client.raise_HostMigrated(Object,HostMigratedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_HostMigrated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_HostMigrated( _
ByVal i1 As Object, _
ByVal i2 As HostMigratedEventArgs _
)
C# protected void raise_HostMigrated(
object i1,
HostMigratedEventArgs i2
);
C++ protected:
void raise_HostMigrated(
Object^ i1,
HostMigratedEventArgs^ i2
);
JScript protected function raise_HostMigrated(
i1 : Object,
i2 : HostMigratedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.HostMigratedEventArgs


Client.raise_InputLevel(Object,InputLevelEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_InputLevel Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_InputLevel( _
ByVal i1 As Object, _
ByVal i2 As InputLevelEventArgs _
)
C# protected void raise_InputLevel(
object i1,
InputLevelEventArgs i2
);
C++ protected:
void raise_InputLevel(
Object^ i1,
InputLevelEventArgs^ i2
);
JScript protected function raise_InputLevel(
i1 : Object,
i2 : InputLevelEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.InputLevelEventArgs


Client.raise_LostFocus(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_LostFocus Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_LostFocus( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_LostFocus(
object i1,
EventArgs i2
);
C++ protected:
void raise_LostFocus(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_LostFocus(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Client.raise_OutputLevel(Object,OutputLevelEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_OutputLevel Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_OutputLevel( _
ByVal i1 As Object, _
ByVal i2 As OutputLevelEventArgs _
)
C# protected void raise_OutputLevel(
object i1,
OutputLevelEventArgs i2
);
C++ protected:
void raise_OutputLevel(
Object^ i1,
OutputLevelEventArgs^ i2
);
JScript protected function raise_OutputLevel(
i1 : Object,
i2 : OutputLevelEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.OutputLevelEventArgs


Client.raise_PlayerCreated(Object,VoicePlayerCreatedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_PlayerCreated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerCreated( _
ByVal i1 As Object, _
ByVal i2 As VoicePlayerCreatedEventArgs _
)
C# protected void raise_PlayerCreated(
object i1,
VoicePlayerCreatedEventArgs i2
);
C++ protected:
void raise_PlayerCreated(
Object^ i1,
VoicePlayerCreatedEventArgs^ i2
);
JScript protected function raise_PlayerCreated(
i1 : Object,
i2 : VoicePlayerCreatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.VoicePlayerCreatedEventArgs


Client.raise_PlayerDeleted(Object,VoicePlayerDeletedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_PlayerDeleted Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerDeleted( _
ByVal i1 As Object, _
ByVal i2 As VoicePlayerDeletedEventArgs _
)
C# protected void raise_PlayerDeleted(
object i1,
VoicePlayerDeletedEventArgs i2
);
C++ protected:
void raise_PlayerDeleted(
Object^ i1,
VoicePlayerDeletedEventArgs^ i2
);
JScript protected function raise_PlayerDeleted(
i1 : Object,
i2 : VoicePlayerDeletedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.VoicePlayerDeletedEventArgs


Client.raise_PlayerOutputLevel(Object,PlayerOutputLevelEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_PlayerOutputLevel Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerOutputLevel( _
ByVal i1 As Object, _
ByVal i2 As PlayerOutputLevelEventArgs _
)
C# protected void raise_PlayerOutputLevel(
object i1,
PlayerOutputLevelEventArgs i2
);
C++ protected:
void raise_PlayerOutputLevel(
Object^ i1,
PlayerOutputLevelEventArgs^ i2
);
JScript protected function raise_PlayerOutputLevel(
i1 : Object,
i2 : PlayerOutputLevelEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelEventArgs


Client.raise_PlayerStarted(Object,PlayerStartedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_PlayerStarted Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerStarted( _
ByVal i1 As Object, _
ByVal i2 As PlayerStartedEventArgs _
)
C# protected void raise_PlayerStarted(
object i1,
PlayerStartedEventArgs i2
);
C++ protected:
void raise_PlayerStarted(
Object^ i1,
PlayerStartedEventArgs^ i2
);
JScript protected function raise_PlayerStarted(
i1 : Object,
i2 : PlayerStartedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.PlayerStartedEventArgs


Client.raise_PlayerStopped(Object,PlayerStoppedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_PlayerStopped Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerStopped( _
ByVal i1 As Object, _
ByVal i2 As PlayerStoppedEventArgs _
)
C# protected void raise_PlayerStopped(
object i1,
PlayerStoppedEventArgs i2
);
C++ protected:
void raise_PlayerStopped(
Object^ i1,
PlayerStoppedEventArgs^ i2
);
JScript protected function raise_PlayerStopped(
i1 : Object,
i2 : PlayerStoppedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.PlayerStoppedEventArgs


Client.raise_RecordStarted(Object,RecordStartedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_RecordStarted Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_RecordStarted( _
ByVal i1 As Object, _
ByVal i2 As RecordStartedEventArgs _
)
C# protected void raise_RecordStarted(
object i1,
RecordStartedEventArgs i2
);
C++ protected:
void raise_RecordStarted(
Object^ i1,
RecordStartedEventArgs^ i2
);
JScript protected function raise_RecordStarted(
i1 : Object,
i2 : RecordStartedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.RecordStartedEventArgs


Client.raise_RecordStopped(Object,RecordStoppedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_RecordStopped Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_RecordStopped( _
ByVal i1 As Object, _
ByVal i2 As RecordStoppedEventArgs _
)
C# protected void raise_RecordStopped(
object i1,
RecordStoppedEventArgs i2
);
C++ protected:
void raise_RecordStopped(
Object^ i1,
RecordStoppedEventArgs^ i2
);
JScript protected function raise_RecordStopped(
i1 : Object,
i2 : RecordStoppedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.RecordStoppedEventArgs


Client.raise_SessionLost(Object,SessionLostEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_SessionLost Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SessionLost( _
ByVal i1 As Object, _
ByVal i2 As SessionLostEventArgs _
)
C# protected void raise_SessionLost(
object i1,
SessionLostEventArgs i2
);
C++ protected:
void raise_SessionLost(
Object^ i1,
SessionLostEventArgs^ i2
);
JScript protected function raise_SessionLost(
i1 : Object,
i2 : SessionLostEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.SessionLostEventArgs


Client.raise_SetTargets(Object,SetTargetsEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Client.raise_SetTargets Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SetTargets( _
ByVal i1 As Object, _
ByVal i2 As SetTargetsEventArgs _
)
C# protected void raise_SetTargets(
object i1,
SetTargetsEventArgs i2
);
C++ protected:
void raise_SetTargets(
Object^ i1,
SetTargetsEventArgs^ i2
);
JScript protected function raise_SetTargets(
i1 : Object,
i2 : SetTargetsEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.SetTargetsEventArgs


Client.ClientConfig Property (Microsoft.DirectX.DirectPlay.Voice)

Client.ClientConfig Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the client configuration. Deprecated.

Definition

Visual Basic | Public Property ClientConfig As ClientConfig
C# | public ClientConfig ClientConfig { get; set; }
C++ public:
property ClientConfig ClientConfig {
ClientConfig get();
void set(ClientConfig value);
}
JScript public function get ClientConfig() : ClientConfig
public function set ClientConfig(ClientConfig);

Property Value

Microsoft.DirectX.DirectPlay.Voice.ClientConfig

This property is read/write.


Client.CompressionTypes Property (Microsoft.DirectX.DirectPlay.Voice)

Client.CompressionTypes Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the available compression types on the system. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CompressionTypes As CompressionInformation()
C# | public CompressionInformation[] CompressionTypes { get; }
C++ public:
property array<CompressionInformation>^ CompressionTypes {
array<CompressionInformation>^ get();
}
JScript | public function get CompressionTypes() : CompressionInformation[]

Property Value

Microsoft.DirectX.DirectPlay.Voice.CompressionInformation[]

This property is read-only.


Client.Disposed Property (Microsoft.DirectX.DirectPlay.Voice)

Client.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Client.SessionDescription Property (Microsoft.DirectX.DirectPlay.Voice)

Client.SessionDescription Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the session properties. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SessionDescription As SessionDescription
C# | public SessionDescription SessionDescription { get; }
C++ public:
property SessionDescription SessionDescription {
SessionDescription get();
}
JScript | public function get SessionDescription() : SessionDescription

Property Value

Microsoft.DirectX.DirectPlay.Voice.SessionDescription

This property is read-only.


Client.SoundDeviceConfig Property (Microsoft.DirectX.DirectPlay.Voice)

Client.SoundDeviceConfig Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the sound device configuration of the session. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SoundDeviceConfig As SoundDeviceConfig
C# | public SoundDeviceConfig SoundDeviceConfig { get; }
C++ public:
property SoundDeviceConfig SoundDeviceConfig {
SoundDeviceConfig get();
}
JScript | public function get SoundDeviceConfig() : SoundDeviceConfig

Property Value

Microsoft.DirectX.DirectPlay.Voice.SoundDeviceConfig

This property is read-only.


Client.TransmitTargets Property (Microsoft.DirectX.DirectPlay.Voice)

Client.TransmitTargets Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the transmit targets, if any, of the voice stream from this client. Deprecated.

Definition

Visual Basic | Public Property TransmitTargets As Integer()
C# | public int[] TransmitTargets { get; set; }
C++ public:
property array<int>^ TransmitTargets {
array<int>^ get();
void set(array<int>^ value);
}
JScript public function get TransmitTargets() : int[]
public function set TransmitTargets(int[]);

Property Value

System.Int32[]

This property is read/write.


Client.ConnectResult Event (Microsoft.DirectX.DirectPlay.Voice)

Client.ConnectResult Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.

Definition

Visual Basic | Public Event ConnectResult As ConnectResultEventHandler
C# | public event ConnectResultEventHandler ConnectResult;
C++ public:
event ConnectResultEventHandler^ ConnectResult;
JScript | In JScript, you can use events, but you cannot define your own.


Client.DisconnectResult Event (Microsoft.DirectX.DirectPlay.Voice)

Client.DisconnectResult Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a disconnection has been completed. Deprecated.

Definition

Visual Basic | Public Event DisconnectResult As DisconnectResultEventHandler
C# | public event DisconnectResultEventHandler DisconnectResult;
C++ public:
event DisconnectResultEventHandler^ DisconnectResult;
JScript | In JScript, you can use events, but you cannot define your own.


Client.Disposing Event (Microsoft.DirectX.DirectPlay.Voice)

Client.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Client.Disposing event, use the following code.

client.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Client.GainFocus Event (Microsoft.DirectX.DirectPlay.Voice)

Client.GainFocus Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application gains focus. Deprecated.

Definition

Visual Basic | Public Event GainFocus As EventHandler
C# | public event EventHandler GainFocus;
C++ public:
event EventHandler^ GainFocus;
JScript | In JScript, you can use events, but you cannot define your own.


Client.HostMigrated Event (Microsoft.DirectX.DirectPlay.Voice)

Client.HostMigrated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the host has migrated. Deprecated.

Definition

Visual Basic | Public Event HostMigrated As VoiceHostMigratedEventHandler
C# | public event VoiceHostMigratedEventHandler HostMigrated;
C++ public:
event VoiceHostMigratedEventHandler^ HostMigrated;
JScript | In JScript, you can use events, but you cannot define your own.


Client.InputLevel Event (Microsoft.DirectX.DirectPlay.Voice)

Client.InputLevel Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the input level has changed. Deprecated.

Definition

Visual Basic | Public Event InputLevel As InputLevelEventHandler
C# | public event InputLevelEventHandler InputLevel;
C++ public:
event InputLevelEventHandler^ InputLevel;
JScript | In JScript, you can use events, but you cannot define your own.


Client.LostFocus Event (Microsoft.DirectX.DirectPlay.Voice)

Client.LostFocus Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application has lost focus. Deprecated.

Definition

Visual Basic | Public Event LostFocus As EventHandler
C# | public event EventHandler LostFocus;
C++ public:
event EventHandler^ LostFocus;
JScript | In JScript, you can use events, but you cannot define your own.


Client.OutputLevel Event (Microsoft.DirectX.DirectPlay.Voice)

Client.OutputLevel Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the output level changes. Deprecated.

Definition

Visual Basic | Public Event OutputLevel As OutputLevelEventHandler
C# | public event OutputLevelEventHandler OutputLevel;
C++ public:
event OutputLevelEventHandler^ OutputLevel;
JScript | In JScript, you can use events, but you cannot define your own.


Client.PlayerCreated Event (Microsoft.DirectX.DirectPlay.Voice)

Client.PlayerCreated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.

Definition

Visual Basic | Public Event PlayerCreated As VoicePlayerCreatedEventHandler
C# | public event VoicePlayerCreatedEventHandler PlayerCreated;
C++ public:
event VoicePlayerCreatedEventHandler^ PlayerCreated;
JScript | In JScript, you can use events, but you cannot define your own.


Client.PlayerDeleted Event (Microsoft.DirectX.DirectPlay.Voice)

Client.PlayerDeleted Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.

Definition

Visual Basic | Public Event PlayerDeleted As VoicePlayerDeletedEventHandler
C# | public event VoicePlayerDeletedEventHandler PlayerDeleted;
C++ public:
event VoicePlayerDeletedEventHandler^ PlayerDeleted;
JScript | In JScript, you can use events, but you cannot define your own.


Client.PlayerOutputLevel Event (Microsoft.DirectX.DirectPlay.Voice)

Client.PlayerOutputLevel Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a players output level has changed. Deprecated.

Definition

Visual Basic | Public Event PlayerOutputLevel As PlayerOutputLevelEventHandler
C# | public event PlayerOutputLevelEventHandler PlayerOutputLevel;
C++ public:
event PlayerOutputLevelEventHandler^ PlayerOutputLevel;
JScript | In JScript, you can use events, but you cannot define your own.


Client.PlayerStarted Event (Microsoft.DirectX.DirectPlay.Voice)

Client.PlayerStarted Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player starts talking. Deprecated.

Definition

Visual Basic | Public Event PlayerStarted As PlayerStartedEventHandler
C# | public event PlayerStartedEventHandler PlayerStarted;
C++ public:
event PlayerStartedEventHandler^ PlayerStarted;
JScript | In JScript, you can use events, but you cannot define your own.


Client.PlayerStopped Event (Microsoft.DirectX.DirectPlay.Voice)

Client.PlayerStopped Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has stopped talking. Deprecated.

Definition

Visual Basic | Public Event PlayerStopped As PlayerStoppedEventHandler
C# | public event PlayerStoppedEventHandler PlayerStopped;
C++ public:
event PlayerStoppedEventHandler^ PlayerStopped;
JScript | In JScript, you can use events, but you cannot define your own.


Client.RecordStarted Event (Microsoft.DirectX.DirectPlay.Voice)

Client.RecordStarted Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the local player has started talking. Deprecated.

Definition

Visual Basic | Public Event RecordStarted As RecordStartedEventHandler
C# | public event RecordStartedEventHandler RecordStarted;
C++ public:
event RecordStartedEventHandler^ RecordStarted;
JScript | In JScript, you can use events, but you cannot define your own.


Client.RecordStopped Event (Microsoft.DirectX.DirectPlay.Voice)

Client.RecordStopped Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the local player has stopped talking. Deprecated.

Definition

Visual Basic | Public Event RecordStopped As RecordStoppedEventHandler
C# | public event RecordStoppedEventHandler RecordStopped;
C++ public:
event RecordStoppedEventHandler^ RecordStopped;
JScript | In JScript, you can use events, but you cannot define your own.


Client.SessionLost Event (Microsoft.DirectX.DirectPlay.Voice)

Client.SessionLost Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been lost. Deprecated.

Definition

Visual Basic | Public Event SessionLost As SessionLostEventHandler
C# | public event SessionLostEventHandler SessionLost;
C++ public:
event SessionLostEventHandler^ SessionLost;
JScript | In JScript, you can use events, but you cannot define your own.


Client.SetTargets Event (Microsoft.DirectX.DirectPlay.Voice)

Client.SetTargets Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies which players and/or groups receive audio transmissions from the local client. Deprecated.

Definition

Visual Basic | Public Event SetTargets As SetTargetsEventHandler
C# | public event SetTargetsEventHandler SetTargets;
C++ public:
event SetTargetsEventHandler^ SetTargets;
JScript | In JScript, you can use events, but you cannot define your own.


CompressionGuid Class (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various compression codecs that can be used. Deprecated.

Definition

Visual Basic NotInheritable MustInherit Public Class CompressionGuid
Inherits Object
C# | public abstract sealed class CompressionGuid : Object
C++ | public ref class CompressionGuid abstract sealed : Object
JScript | public final abstract class CompressionGuid extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
static (Shared in Visual Basic) AdPcm
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) Default
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) Gsm
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) None
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) Sc03
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) Sc06
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) TrueSpeech
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) Vr12
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Inheritance Hierarchy

Object Leave Site
CompressionGuid

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CompressionGuid.AdPcm Field (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid.AdPcm Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared AdPcm As Guid
C# | public static Guid AdPcm;
C++ | public: static Guid AdPcm;
JScript | public static var AdPcm : Guid

Field Value

System.Guid

This field is read-only.


CompressionGuid.Default Field (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid.Default Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared Default As Guid
C# | public static Guid Default;
C++ | public: static Guid Default;
JScript | public static var Default : Guid

Field Value

System.Guid

This field is read-only.


CompressionGuid.Gsm Field (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid.Gsm Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared Gsm As Guid
C# | public static Guid Gsm;
C++ | public: static Guid Gsm;
JScript | public static var Gsm : Guid

Field Value

System.Guid

This field is read-only.


CompressionGuid.None Field (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid.None Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared None As Guid
C# | public static Guid None;
C++ | public: static Guid None;
JScript | public static var None : Guid

Field Value

System.Guid

This field is read-only.


CompressionGuid.Sc03 Field (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid.Sc03 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared Sc03 As Guid
C# | public static Guid Sc03;
C++ | public: static Guid Sc03;
JScript | public static var Sc03 : Guid

Field Value

System.Guid

This field is read-only.


CompressionGuid.Sc06 Field (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid.Sc06 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared Sc06 As Guid
C# | public static Guid Sc06;
C++ | public: static Guid Sc06;
JScript | public static var Sc06 : Guid

Field Value

System.Guid

This field is read-only.


CompressionGuid.TrueSpeech Field (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid.TrueSpeech Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared TrueSpeech As Guid
C# | public static Guid TrueSpeech;
C++ | public: static Guid TrueSpeech;
JScript | public static var TrueSpeech : Guid

Field Value

System.Guid

This field is read-only.


CompressionGuid.Vr12 Field (Microsoft.DirectX.DirectPlay.Voice)

CompressionGuid.Vr12 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared Vr12 As Guid
C# | public static Guid Vr12;
C++ | public: static Guid Vr12;
JScript | public static var Vr12 : Guid

Field Value

System.Guid

This field is read-only.


CompressionNotSupportedException Class (Microsoft.DirectX.DirectPlay.Voice)

CompressionNotSupportedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified compression type is not supported on the local computer. Deprecated.

Definition

Visual Basic Public Class CompressionNotSupportedException
Inherits VoiceException
C# | public class CompressionNotSupportedException : VoiceException
C++ | public ref class CompressionNotSupportedException : VoiceException
JScript | public class CompressionNotSupportedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CompressionNotSupportedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
CompressionNotSupportedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CompressionNotSupportedException.CompressionNotSupportedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CompressionNotSupportedException();
protected CompressionNotSupportedException(SerializationInfo, StreamingContext);
public CompressionNotSupportedException(string);
public CompressionNotSupportedException(string, Exception);


CompressionNotSupportedException.CompressionNotSupportedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CompressionNotSupportedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CompressionNotSupportedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CompressionNotSupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CompressionNotSupportedException.CompressionNotSupportedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CompressionNotSupportedException(
string message,
Exception inner
);
C++ public:
CompressionNotSupportedException(
String^ message,
Exception^ inner
);
JScript public function CompressionNotSupportedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CompressionNotSupportedException.CompressionNotSupportedException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CompressionNotSupportedException(
string message
);
C++ public:
CompressionNotSupportedException(
String^ message
);
JScript public function CompressionNotSupportedException(
message : String
);

Parameters

message System.String


CompressionNotSupportedException.CompressionNotSupportedException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

CompressionNotSupportedException.CompressionNotSupportedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CompressionNotSupportedException();
C++ public:
CompressionNotSupportedException();
JScript | public function CompressionNotSupportedException();


ConnectAbortedException Class (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connect operation was canceled before it could be completed. Deprecated.

Definition

Visual Basic Public Class ConnectAbortedException
Inherits VoiceException
C# | public class ConnectAbortedException : VoiceException
C++ | public ref class ConnectAbortedException : VoiceException
JScript | public class ConnectAbortedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectAbortedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
ConnectAbortedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectAbortedException.ConnectAbortedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectAbortedException();
protected ConnectAbortedException(SerializationInfo, StreamingContext);
public ConnectAbortedException(string);
public ConnectAbortedException(string, Exception);


ConnectAbortedException.ConnectAbortedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortedException.ConnectAbortedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectAbortedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConnectAbortedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConnectAbortedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ConnectAbortedException.ConnectAbortedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortedException.ConnectAbortedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectAbortedException(
string message,
Exception inner
);
C++ public:
ConnectAbortedException(
String^ message,
Exception^ inner
);
JScript public function ConnectAbortedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ConnectAbortedException.ConnectAbortedException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortedException.ConnectAbortedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConnectAbortedException(
string message
);
C++ public:
ConnectAbortedException(
String^ message
);
JScript public function ConnectAbortedException(
message : String
);

Parameters

message System.String


ConnectAbortedException.ConnectAbortedException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortedException.ConnectAbortedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectAbortedException();
C++ public:
ConnectAbortedException();
JScript | public function ConnectAbortedException();


ConnectAbortingException Class (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection is being disconnected. Deprecated.

Definition

Visual Basic Public Class ConnectAbortingException
Inherits VoiceException
C# | public class ConnectAbortingException : VoiceException
C++ | public ref class ConnectAbortingException : VoiceException
JScript | public class ConnectAbortingException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectAbortingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
ConnectAbortingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectAbortingException.ConnectAbortingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectAbortingException();
protected ConnectAbortingException(SerializationInfo, StreamingContext);
public ConnectAbortingException(string);
public ConnectAbortingException(string, Exception);


ConnectAbortingException.ConnectAbortingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectAbortingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConnectAbortingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConnectAbortingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ConnectAbortingException.ConnectAbortingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectAbortingException(
string message,
Exception inner
);
C++ public:
ConnectAbortingException(
String^ message,
Exception^ inner
);
JScript public function ConnectAbortingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ConnectAbortingException.ConnectAbortingException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConnectAbortingException(
string message
);
C++ public:
ConnectAbortingException(
String^ message
);
JScript public function ConnectAbortingException(
message : String
);

Parameters

message System.String


ConnectAbortingException.ConnectAbortingException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectAbortingException.ConnectAbortingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectAbortingException();
C++ public:
ConnectAbortingException();
JScript | public function ConnectAbortingException();


ConnectedException Class (Microsoft.DirectX.DirectPlay.Voice)

ConnectedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay Voice object is connected. Deprecated.

Definition

Visual Basic Public Class ConnectedException
Inherits VoiceException
C# | public class ConnectedException : VoiceException
C++ | public ref class ConnectedException : VoiceException
JScript | public class ConnectedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
ConnectedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectedException.ConnectedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectedException();
protected ConnectedException(SerializationInfo, StreamingContext);
public ConnectedException(string);
public ConnectedException(string, Exception);


ConnectedException.ConnectedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectedException.ConnectedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConnectedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConnectedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ConnectedException.ConnectedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectedException.ConnectedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectedException(
string message,
Exception inner
);
C++ public:
ConnectedException(
String^ message,
Exception^ inner
);
JScript public function ConnectedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ConnectedException.ConnectedException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectedException.ConnectedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConnectedException(
string message
);
C++ public:
ConnectedException(
String^ message
);
JScript public function ConnectedException(
message : String
);

Parameters

message System.String


ConnectedException.ConnectedException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectedException.ConnectedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectedException();
C++ public:
ConnectedException();
JScript | public function ConnectedException();


ConnectionLostException Class (Microsoft.DirectX.DirectPlay.Voice)

ConnectionLostException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The connection to the voice session has been lost. Deprecated.

Definition

Visual Basic Public Class ConnectionLostException
Inherits VoiceException
C# | public class ConnectionLostException : VoiceException
C++ | public ref class ConnectionLostException : VoiceException
JScript | public class ConnectionLostException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectionLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
ConnectionLostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectionLostException.ConnectionLostException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectionLostException();
protected ConnectionLostException(SerializationInfo, StreamingContext);
public ConnectionLostException(string);
public ConnectionLostException(string, Exception);


ConnectionLostException.ConnectionLostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectionLostException.ConnectionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectionLostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConnectionLostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConnectionLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ConnectionLostException.ConnectionLostException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectionLostException.ConnectionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectionLostException(
string message,
Exception inner
);
C++ public:
ConnectionLostException(
String^ message,
Exception^ inner
);
JScript public function ConnectionLostException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ConnectionLostException.ConnectionLostException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectionLostException.ConnectionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConnectionLostException(
string message
);
C++ public:
ConnectionLostException(
String^ message
);
JScript public function ConnectionLostException(
message : String
);

Parameters

message System.String


ConnectionLostException.ConnectionLostException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectionLostException.ConnectionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectionLostException();
C++ public:
ConnectionLostException();
JScript | public function ConnectionLostException();


ConnectResultEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

ConnectResultEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidConnectresultDplay message when the connect request generated through a call to the PlayvoiceclientConnectDplay method has completed.The structure contains information for the DvmsgidConnectresultDplay message. Deprecated.

Definition

Visual Basic NotInheritable Public Class ConnectResultEventArgs
Inherits EventArgs
C# | public sealed class ConnectResultEventArgs : EventArgs
C++ | public ref class ConnectResultEventArgs sealed : EventArgs
JScript | public final class ConnectResultEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectResultEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ConnectResultEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectResultEventArgs.ConnectResultEventArgs(ConnectResultMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectResultEventArgs.ConnectResultEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As ConnectResultMessage _
)
C# public ConnectResultEventArgs(
ConnectResultMessage dpMessage
);
C++ public:
ConnectResultEventArgs(
ConnectResultMessage dpMessage
);
JScript public function ConnectResultEventArgs(
dpMessage : ConnectResultMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.ConnectResultMessage


ConnectResultEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

ConnectResultEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As ConnectResultMessage
C# | public ConnectResultMessage Message;
C++ | public: ConnectResultMessage Message;
JScript | public var Message : ConnectResultMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.ConnectResultMessage

This field is read/write.


DisconnectResultEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

DisconnectResultEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class DisconnectResultEventArgs
Inherits EventArgs
C# | public sealed class DisconnectResultEventArgs : EventArgs
C++ | public ref class DisconnectResultEventArgs sealed : EventArgs
JScript | public final class DisconnectResultEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
DisconnectResultEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
DisconnectResultEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisconnectResultEventArgs.DisconnectResultEventArgs(DisconnectResultMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

DisconnectResultEventArgs.DisconnectResultEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As DisconnectResultMessage _
)
C# public DisconnectResultEventArgs(
DisconnectResultMessage dpMessage
);
C++ public:
DisconnectResultEventArgs(
DisconnectResultMessage dpMessage
);
JScript public function DisconnectResultEventArgs(
dpMessage : DisconnectResultMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.DisconnectResultMessage


DisconnectResultEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

DisconnectResultEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As DisconnectResultMessage
C# | public DisconnectResultMessage Message;
C++ | public: DisconnectResultMessage Message;
JScript | public var Message : DisconnectResultMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.DisconnectResultMessage

This field is read/write.


HostingException Class (Microsoft.DirectX.DirectPlay.Voice)

HostingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is the host of the session. Deprecated.

Definition

Visual Basic Public Class HostingException
Inherits VoiceException
C# | public class HostingException : VoiceException
C++ | public ref class HostingException : VoiceException
JScript | public class HostingException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
HostingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
HostingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HostingException.HostingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public HostingException();
protected HostingException(SerializationInfo, StreamingContext);
public HostingException(string);
public HostingException(string, Exception);


HostingException.HostingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

HostingException.HostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected HostingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
HostingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function HostingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


HostingException.HostingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

HostingException.HostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public HostingException(
string message,
Exception inner
);
C++ public:
HostingException(
String^ message,
Exception^ inner
);
JScript public function HostingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


HostingException.HostingException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

HostingException.HostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public HostingException(
string message
);
C++ public:
HostingException(
String^ message
);
JScript public function HostingException(
message : String
);

Parameters

message System.String


HostingException.HostingException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

HostingException.HostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public HostingException();
C++ public:
HostingException();
JScript | public function HostingException();


HostMigratedEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

HostMigratedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class HostMigratedEventArgs
Inherits EventArgs
C# | public sealed class HostMigratedEventArgs : EventArgs
C++ | public ref class HostMigratedEventArgs sealed : EventArgs
JScript | public final class HostMigratedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
HostMigratedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
HostMigratedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HostMigratedEventArgs.HostMigratedEventArgs(HostMigratedMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

HostMigratedEventArgs.HostMigratedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As HostMigratedMessage _
)
C# public HostMigratedEventArgs(
HostMigratedMessage dpMessage
);
C++ public:
HostMigratedEventArgs(
HostMigratedMessage dpMessage
);
JScript public function HostMigratedEventArgs(
dpMessage : HostMigratedMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.HostMigratedMessage


HostMigratedEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

HostMigratedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As HostMigratedMessage
C# | public HostMigratedMessage Message;
C++ | public: HostMigratedMessage Message;
JScript | public var Message : HostMigratedMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.HostMigratedMessage

This field is read/write.


IncompatibleVersionException Class (Microsoft.DirectX.DirectPlay.Voice)

IncompatibleVersionException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The client connected to a voice session that is incompatible with the host. Deprecated.

Definition

Visual Basic Public Class IncompatibleVersionException
Inherits VoiceException
C# | public class IncompatibleVersionException : VoiceException
C++ | public ref class IncompatibleVersionException : VoiceException
JScript | public class IncompatibleVersionException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
IncompatibleVersionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
IncompatibleVersionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IncompatibleVersionException.IncompatibleVersionException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public IncompatibleVersionException();
protected IncompatibleVersionException(SerializationInfo, StreamingContext);
public IncompatibleVersionException(string);
public IncompatibleVersionException(string, Exception);


IncompatibleVersionException.IncompatibleVersionException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected IncompatibleVersionException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
IncompatibleVersionException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function IncompatibleVersionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


IncompatibleVersionException.IncompatibleVersionException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public IncompatibleVersionException(
string message,
Exception inner
);
C++ public:
IncompatibleVersionException(
String^ message,
Exception^ inner
);
JScript public function IncompatibleVersionException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


IncompatibleVersionException.IncompatibleVersionException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public IncompatibleVersionException(
string message
);
C++ public:
IncompatibleVersionException(
String^ message
);
JScript public function IncompatibleVersionException(
message : String
);

Parameters

message System.String


IncompatibleVersionException.IncompatibleVersionException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

IncompatibleVersionException.IncompatibleVersionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public IncompatibleVersionException();
C++ public:
IncompatibleVersionException();
JScript | public function IncompatibleVersionException();


InputLevelEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

InputLevelEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidInputlevelDplay message periodically to notify the user of the input level from the microphone.The structure contains information for the DvmsgidInputlevelDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class InputLevelEventArgs
Inherits EventArgs
C# | public sealed class InputLevelEventArgs : EventArgs
C++ | public ref class InputLevelEventArgs sealed : EventArgs
JScript | public final class InputLevelEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
InputLevelEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
InputLevelEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputLevelEventArgs.InputLevelEventArgs(InputLevelMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InputLevelEventArgs.InputLevelEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As InputLevelMessage _
)
C# public InputLevelEventArgs(
InputLevelMessage dpMessage
);
C++ public:
InputLevelEventArgs(
InputLevelMessage dpMessage
);
JScript public function InputLevelEventArgs(
dpMessage : InputLevelMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.InputLevelMessage


InputLevelEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

InputLevelEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As InputLevelMessage
C# | public InputLevelMessage Message;
C++ | public: InputLevelMessage Message;
JScript | public var Message : InputLevelMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.InputLevelMessage

This field is read/write.


InvalidBufferException Class (Microsoft.DirectX.DirectPlay.Voice)

InvalidBufferException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A buffer specified as a parameter is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidBufferException
Inherits VoiceException
C# | public class InvalidBufferException : VoiceException
C++ | public ref class InvalidBufferException : VoiceException
JScript | public class InvalidBufferException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidBufferException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidBufferException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidBufferException.InvalidBufferException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidBufferException();
protected InvalidBufferException(SerializationInfo, StreamingContext);
public InvalidBufferException(string);
public InvalidBufferException(string, Exception);


InvalidBufferException.InvalidBufferException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidBufferException.InvalidBufferException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidBufferException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidBufferException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidBufferException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidBufferException.InvalidBufferException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidBufferException.InvalidBufferException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidBufferException(
string message,
Exception inner
);
C++ public:
InvalidBufferException(
String^ message,
Exception^ inner
);
JScript public function InvalidBufferException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidBufferException.InvalidBufferException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidBufferException.InvalidBufferException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidBufferException(
string message
);
C++ public:
InvalidBufferException(
String^ message
);
JScript public function InvalidBufferException(
message : String
);

Parameters

message System.String


InvalidBufferException.InvalidBufferException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidBufferException.InvalidBufferException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidBufferException();
C++ public:
InvalidBufferException();
JScript | public function InvalidBufferException();


InvalidDeviceException Class (Microsoft.DirectX.DirectPlay.Voice)

InvalidDeviceException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified device is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidDeviceException
Inherits VoiceException
C# | public class InvalidDeviceException : VoiceException
C++ | public ref class InvalidDeviceException : VoiceException
JScript | public class InvalidDeviceException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDeviceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidDeviceException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidDeviceException.InvalidDeviceException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidDeviceException();
protected InvalidDeviceException(SerializationInfo, StreamingContext);
public InvalidDeviceException(string);
public InvalidDeviceException(string, Exception);


InvalidDeviceException.InvalidDeviceException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidDeviceException.InvalidDeviceException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDeviceException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidDeviceException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidDeviceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidDeviceException.InvalidDeviceException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidDeviceException.InvalidDeviceException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDeviceException(
string message,
Exception inner
);
C++ public:
InvalidDeviceException(
String^ message,
Exception^ inner
);
JScript public function InvalidDeviceException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidDeviceException.InvalidDeviceException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidDeviceException.InvalidDeviceException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidDeviceException(
string message
);
C++ public:
InvalidDeviceException(
String^ message
);
JScript public function InvalidDeviceException(
message : String
);

Parameters

message System.String


InvalidDeviceException.InvalidDeviceException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidDeviceException.InvalidDeviceException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidDeviceException();
C++ public:
InvalidDeviceException();
JScript | public function InvalidDeviceException();


InvalidFlagsException Class (Microsoft.DirectX.DirectPlay.Voice)

InvalidFlagsException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The flags passed to this method are invalid. Deprecated.

Definition

Visual Basic Public Class InvalidFlagsException
Inherits VoiceException
C# | public class InvalidFlagsException : VoiceException
C++ | public ref class InvalidFlagsException : VoiceException
JScript | public class InvalidFlagsException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidFlagsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidFlagsException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidFlagsException.InvalidFlagsException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidFlagsException();
protected InvalidFlagsException(SerializationInfo, StreamingContext);
public InvalidFlagsException(string);
public InvalidFlagsException(string, Exception);


InvalidFlagsException.InvalidFlagsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidFlagsException.InvalidFlagsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidFlagsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidFlagsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidFlagsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidFlagsException.InvalidFlagsException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidFlagsException.InvalidFlagsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidFlagsException(
string message,
Exception inner
);
C++ public:
InvalidFlagsException(
String^ message,
Exception^ inner
);
JScript public function InvalidFlagsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidFlagsException.InvalidFlagsException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidFlagsException.InvalidFlagsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidFlagsException(
string message
);
C++ public:
InvalidFlagsException(
String^ message
);
JScript public function InvalidFlagsException(
message : String
);

Parameters

message System.String


InvalidFlagsException.InvalidFlagsException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidFlagsException.InvalidFlagsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidFlagsException();
C++ public:
InvalidFlagsException();
JScript | public function InvalidFlagsException();


InvalidGroupException Class (Microsoft.DirectX.DirectPlay.Voice)

InvalidGroupException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The group ID is not recognized as a valid group ID for this game session. Deprecated.

Definition

Visual Basic Public Class InvalidGroupException
Inherits VoiceException
C# | public class InvalidGroupException : VoiceException
C++ | public ref class InvalidGroupException : VoiceException
JScript | public class InvalidGroupException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidGroupException.InvalidGroupException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidGroupException();
protected InvalidGroupException(SerializationInfo, StreamingContext);
public InvalidGroupException(string);
public InvalidGroupException(string, Exception);


InvalidGroupException.InvalidGroupException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidGroupException.InvalidGroupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidGroupException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidGroupException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidGroupException.InvalidGroupException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidGroupException.InvalidGroupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidGroupException(
string message,
Exception inner
);
C++ public:
InvalidGroupException(
String^ message,
Exception^ inner
);
JScript public function InvalidGroupException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidGroupException.InvalidGroupException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidGroupException.InvalidGroupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidGroupException(
string message
);
C++ public:
InvalidGroupException(
String^ message
);
JScript public function InvalidGroupException(
message : String
);

Parameters

message System.String


InvalidGroupException.InvalidGroupException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidGroupException.InvalidGroupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidGroupException();
C++ public:
InvalidGroupException();
JScript | public function InvalidGroupException();


InvalidHandleException Class (Microsoft.DirectX.DirectPlay.Voice)

InvalidHandleException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle specified is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidHandleException
Inherits VoiceException
C# | public class InvalidHandleException : VoiceException
C++ | public ref class InvalidHandleException : VoiceException
JScript | public class InvalidHandleException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidHandleException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidHandleException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidHandleException.InvalidHandleException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidHandleException();
protected InvalidHandleException(SerializationInfo, StreamingContext);
public InvalidHandleException(string);
public InvalidHandleException(string, Exception);


InvalidHandleException.InvalidHandleException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidHandleException.InvalidHandleException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidHandleException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidHandleException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidHandleException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidHandleException.InvalidHandleException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidHandleException.InvalidHandleException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidHandleException(
string message,
Exception inner
);
C++ public:
InvalidHandleException(
String^ message,
Exception^ inner
);
JScript public function InvalidHandleException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidHandleException.InvalidHandleException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidHandleException.InvalidHandleException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidHandleException(
string message
);
C++ public:
InvalidHandleException(
String^ message
);
JScript public function InvalidHandleException(
message : String
);

Parameters

message System.String


InvalidHandleException.InvalidHandleException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidHandleException.InvalidHandleException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidHandleException();
C++ public:
InvalidHandleException();
JScript | public function InvalidHandleException();


InvalidObjectException Class (Microsoft.DirectX.DirectPlay.Voice)

InvalidObjectException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay object is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidObjectException
Inherits VoiceException
C# | public class InvalidObjectException : VoiceException
C++ | public ref class InvalidObjectException : VoiceException
JScript | public class InvalidObjectException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidObjectException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidObjectException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidObjectException.InvalidObjectException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidObjectException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidObjectException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidObjectException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidObjectException.InvalidObjectException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidObjectException(
string message,
Exception inner
);
C++ public:
InvalidObjectException(
String^ message,
Exception^ inner
);
JScript public function InvalidObjectException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidObjectException.InvalidObjectException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidObjectException(
string message
);
C++ public:
InvalidObjectException(
String^ message
);
JScript public function InvalidObjectException(
message : String
);

Parameters

message System.String


InvalidObjectException.InvalidObjectException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidObjectException();
C++ public:
InvalidObjectException();
JScript | public function InvalidObjectException();


InvalidPlayerException Class (Microsoft.DirectX.DirectPlay.Voice)

InvalidPlayerException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not recognized as a valid player ID for this game session. Deprecated.

Definition

Visual Basic Public Class InvalidPlayerException
Inherits VoiceException
C# | public class InvalidPlayerException : VoiceException
C++ | public ref class InvalidPlayerException : VoiceException
JScript | public class InvalidPlayerException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidPlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidPlayerException.InvalidPlayerException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPlayerException();
protected InvalidPlayerException(SerializationInfo, StreamingContext);
public InvalidPlayerException(string);
public InvalidPlayerException(string, Exception);


InvalidPlayerException.InvalidPlayerException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidPlayerException.InvalidPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPlayerException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidPlayerException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidPlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidPlayerException.InvalidPlayerException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidPlayerException.InvalidPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPlayerException(
string message,
Exception inner
);
C++ public:
InvalidPlayerException(
String^ message,
Exception^ inner
);
JScript public function InvalidPlayerException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidPlayerException.InvalidPlayerException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidPlayerException.InvalidPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidPlayerException(
string message
);
C++ public:
InvalidPlayerException(
String^ message
);
JScript public function InvalidPlayerException(
message : String
);

Parameters

message System.String


InvalidPlayerException.InvalidPlayerException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidPlayerException.InvalidPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidPlayerException();
C++ public:
InvalidPlayerException();
JScript | public function InvalidPlayerException();


InvalidTargetException Class (Microsoft.DirectX.DirectPlay.Voice)

InvalidTargetException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified target is not a valid player ID or group ID for this voice session. Deprecated.

Definition

Visual Basic Public Class InvalidTargetException
Inherits VoiceException
C# | public class InvalidTargetException : VoiceException
C++ | public ref class InvalidTargetException : VoiceException
JScript | public class InvalidTargetException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidTargetException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
InvalidTargetException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidTargetException.InvalidTargetException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidTargetException();
protected InvalidTargetException(SerializationInfo, StreamingContext);
public InvalidTargetException(string);
public InvalidTargetException(string, Exception);


InvalidTargetException.InvalidTargetException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidTargetException.InvalidTargetException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidTargetException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidTargetException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidTargetException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidTargetException.InvalidTargetException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidTargetException.InvalidTargetException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidTargetException(
string message,
Exception inner
);
C++ public:
InvalidTargetException(
String^ message,
Exception^ inner
);
JScript public function InvalidTargetException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidTargetException.InvalidTargetException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidTargetException.InvalidTargetException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidTargetException(
string message
);
C++ public:
InvalidTargetException(
String^ message
);
JScript public function InvalidTargetException(
message : String
);

Parameters

message System.String


InvalidTargetException.InvalidTargetException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InvalidTargetException.InvalidTargetException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidTargetException();
C++ public:
InvalidTargetException();
JScript | public function InvalidTargetException();


LockedBufferException Class (Microsoft.DirectX.DirectPlay.Voice)

LockedBufferException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The buffer is already locked. Deprecated.

Definition

Visual Basic Public Class LockedBufferException
Inherits VoiceException
C# | public class LockedBufferException : VoiceException
C++ | public ref class LockedBufferException : VoiceException
JScript | public class LockedBufferException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
LockedBufferException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
LockedBufferException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LockedBufferException.LockedBufferException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public LockedBufferException();
protected LockedBufferException(SerializationInfo, StreamingContext);
public LockedBufferException(string);
public LockedBufferException(string, Exception);


LockedBufferException.LockedBufferException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

LockedBufferException.LockedBufferException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected LockedBufferException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
LockedBufferException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function LockedBufferException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


LockedBufferException.LockedBufferException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

LockedBufferException.LockedBufferException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public LockedBufferException(
string message,
Exception inner
);
C++ public:
LockedBufferException(
String^ message,
Exception^ inner
);
JScript public function LockedBufferException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


LockedBufferException.LockedBufferException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

LockedBufferException.LockedBufferException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public LockedBufferException(
string message
);
C++ public:
LockedBufferException(
String^ message
);
JScript public function LockedBufferException(
message : String
);

Parameters

message System.String


LockedBufferException.LockedBufferException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

LockedBufferException.LockedBufferException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public LockedBufferException();
C++ public:
LockedBufferException();
JScript | public function LockedBufferException();


No3DSoundException Class (Microsoft.DirectX.DirectPlay.Voice)

No3DSoundException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The local computer does not support 3-D sound. Deprecated.

Definition

Visual Basic Public Class No3DSoundException
Inherits VoiceException
C# | public class No3DSoundException : VoiceException
C++ | public ref class No3DSoundException : VoiceException
JScript | public class No3DSoundException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
No3DSoundException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
No3DSoundException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


No3DSoundException.No3DSoundException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public No3DSoundException();
protected No3DSoundException(SerializationInfo, StreamingContext);
public No3DSoundException(string);
public No3DSoundException(string, Exception);


No3DSoundException.No3DSoundException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

No3DSoundException.No3DSoundException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected No3DSoundException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
No3DSoundException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function No3DSoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


No3DSoundException.No3DSoundException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

No3DSoundException.No3DSoundException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public No3DSoundException(
string message,
Exception inner
);
C++ public:
No3DSoundException(
String^ message,
Exception^ inner
);
JScript public function No3DSoundException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


No3DSoundException.No3DSoundException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

No3DSoundException.No3DSoundException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public No3DSoundException(
string message
);
C++ public:
No3DSoundException(
String^ message
);
JScript public function No3DSoundException(
message : String
);

Parameters

message System.String


No3DSoundException.No3DSoundException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

No3DSoundException.No3DSoundException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public No3DSoundException();
C++ public:
No3DSoundException();
JScript | public function No3DSoundException();


NoRecordVolumeAvailableException Class (Microsoft.DirectX.DirectPlay.Voice)

NoRecordVolumeAvailableException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The local computer does not support record volume. Deprecated.

Definition

Visual Basic Public Class NoRecordVolumeAvailableException
Inherits VoiceException
C# | public class NoRecordVolumeAvailableException : VoiceException
C++ | public ref class NoRecordVolumeAvailableException : VoiceException
JScript | public class NoRecordVolumeAvailableException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoRecordVolumeAvailableException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NoRecordVolumeAvailableException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoRecordVolumeAvailableException();
protected NoRecordVolumeAvailableException(SerializationInfo, StreamingContext);
public NoRecordVolumeAvailableException(string);
public NoRecordVolumeAvailableException(string, Exception);


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoRecordVolumeAvailableException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoRecordVolumeAvailableException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoRecordVolumeAvailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoRecordVolumeAvailableException(
string message,
Exception inner
);
C++ public:
NoRecordVolumeAvailableException(
String^ message,
Exception^ inner
);
JScript public function NoRecordVolumeAvailableException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoRecordVolumeAvailableException(
string message
);
C++ public:
NoRecordVolumeAvailableException(
String^ message
);
JScript public function NoRecordVolumeAvailableException(
message : String
);

Parameters

message System.String


NoRecordVolumeAvailableException.NoRecordVolumeAvailableException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoRecordVolumeAvailableException.NoRecordVolumeAvailableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoRecordVolumeAvailableException();
C++ public:
NoRecordVolumeAvailableException();
JScript | public function NoRecordVolumeAvailableException();


NotAllowedException Class (Microsoft.DirectX.DirectPlay.Voice)

NotAllowedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object does not have the permission to perform this operation. Deprecated.

Definition

Visual Basic Public Class NotAllowedException
Inherits VoiceException
C# | public class NotAllowedException : VoiceException
C++ | public ref class NotAllowedException : VoiceException
JScript | public class NotAllowedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAllowedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotAllowedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotAllowedException.NotAllowedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotAllowedException();
protected NotAllowedException(SerializationInfo, StreamingContext);
public NotAllowedException(string);
public NotAllowedException(string, Exception);


NotAllowedException.NotAllowedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotAllowedException.NotAllowedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAllowedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotAllowedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotAllowedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotAllowedException.NotAllowedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotAllowedException.NotAllowedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAllowedException(
string message,
Exception inner
);
C++ public:
NotAllowedException(
String^ message,
Exception^ inner
);
JScript public function NotAllowedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotAllowedException.NotAllowedException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotAllowedException.NotAllowedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotAllowedException(
string message
);
C++ public:
NotAllowedException(
String^ message
);
JScript public function NotAllowedException(
message : String
);

Parameters

message System.String


NotAllowedException.NotAllowedException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotAllowedException.NotAllowedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotAllowedException();
C++ public:
NotAllowedException();
JScript | public function NotAllowedException();


NotBufferedException Class (Microsoft.DirectX.DirectPlay.Voice)

NotBufferedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is no user buffer for the specified ID. Deprecated.

Definition

Visual Basic Public Class NotBufferedException
Inherits VoiceException
C# | public class NotBufferedException : VoiceException
C++ | public ref class NotBufferedException : VoiceException
JScript | public class NotBufferedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotBufferedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotBufferedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotBufferedException.NotBufferedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotBufferedException();
protected NotBufferedException(SerializationInfo, StreamingContext);
public NotBufferedException(string);
public NotBufferedException(string, Exception);


NotBufferedException.NotBufferedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotBufferedException.NotBufferedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotBufferedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotBufferedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotBufferedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotBufferedException.NotBufferedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotBufferedException.NotBufferedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotBufferedException(
string message,
Exception inner
);
C++ public:
NotBufferedException(
String^ message,
Exception^ inner
);
JScript public function NotBufferedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotBufferedException.NotBufferedException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotBufferedException.NotBufferedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotBufferedException(
string message
);
C++ public:
NotBufferedException(
String^ message
);
JScript public function NotBufferedException(
message : String
);

Parameters

message System.String


NotBufferedException.NotBufferedException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotBufferedException.NotBufferedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotBufferedException();
C++ public:
NotBufferedException();
JScript | public function NotBufferedException();


NotConnectedException Class (Microsoft.DirectX.DirectPlay.Voice)

NotConnectedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The DirectPlay Voice object is not connected. Deprecated.

Definition

Visual Basic Public Class NotConnectedException
Inherits VoiceException
C# | public class NotConnectedException : VoiceException
C++ | public ref class NotConnectedException : VoiceException
JScript | public class NotConnectedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotConnectedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotConnectedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotConnectedException.NotConnectedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotConnectedException();
protected NotConnectedException(SerializationInfo, StreamingContext);
public NotConnectedException(string);
public NotConnectedException(string, Exception);


NotConnectedException.NotConnectedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotConnectedException.NotConnectedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotConnectedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotConnectedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotConnectedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotConnectedException.NotConnectedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotConnectedException.NotConnectedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotConnectedException(
string message,
Exception inner
);
C++ public:
NotConnectedException(
String^ message,
Exception^ inner
);
JScript public function NotConnectedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotConnectedException.NotConnectedException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotConnectedException.NotConnectedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotConnectedException(
string message
);
C++ public:
NotConnectedException(
String^ message
);
JScript public function NotConnectedException(
message : String
);

Parameters

message System.String


NotConnectedException.NotConnectedException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotConnectedException.NotConnectedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotConnectedException();
C++ public:
NotConnectedException();
JScript | public function NotConnectedException();


NotHostingException Class (Microsoft.DirectX.DirectPlay.Voice)

NotHostingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not the host of the session. Deprecated.

Definition

Visual Basic Public Class NotHostingException
Inherits VoiceException
C# | public class NotHostingException : VoiceException
C++ | public ref class NotHostingException : VoiceException
JScript | public class NotHostingException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotHostingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotHostingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotHostingException.NotHostingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotHostingException();
protected NotHostingException(SerializationInfo, StreamingContext);
public NotHostingException(string);
public NotHostingException(string, Exception);


NotHostingException.NotHostingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotHostingException.NotHostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotHostingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotHostingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotHostingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotHostingException.NotHostingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotHostingException.NotHostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotHostingException(
string message,
Exception inner
);
C++ public:
NotHostingException(
String^ message,
Exception^ inner
);
JScript public function NotHostingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotHostingException.NotHostingException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotHostingException.NotHostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotHostingException(
string message
);
C++ public:
NotHostingException(
String^ message
);
JScript public function NotHostingException(
message : String
);

Parameters

message System.String


NotHostingException.NotHostingException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotHostingException.NotHostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotHostingException();
C++ public:
NotHostingException();
JScript | public function NotHostingException();


NoTransportException Class (Microsoft.DirectX.DirectPlay.Voice)

NoTransportException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified object is not a valid transport. Deprecated.

Definition

Visual Basic Public Class NoTransportException
Inherits VoiceException
C# | public class NoTransportException : VoiceException
C++ | public ref class NoTransportException : VoiceException
JScript | public class NoTransportException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoTransportException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NoTransportException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoTransportException.NoTransportException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoTransportException();
protected NoTransportException(SerializationInfo, StreamingContext);
public NoTransportException(string);
public NoTransportException(string, Exception);


NoTransportException.NoTransportException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoTransportException.NoTransportException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoTransportException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoTransportException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoTransportException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoTransportException.NoTransportException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoTransportException.NoTransportException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoTransportException(
string message,
Exception inner
);
C++ public:
NoTransportException(
String^ message,
Exception^ inner
);
JScript public function NoTransportException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoTransportException.NoTransportException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoTransportException.NoTransportException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoTransportException(
string message
);
C++ public:
NoTransportException(
String^ message
);
JScript public function NoTransportException(
message : String
);

Parameters

message System.String


NoTransportException.NoTransportException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoTransportException.NoTransportException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoTransportException();
C++ public:
NoTransportException();
JScript | public function NoTransportException();


NotSupportedException Class (Microsoft.DirectX.DirectPlay.Voice)

NotSupportedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation is not supported. Deprecated.

Definition

Visual Basic Public Class NotSupportedException
Inherits VoiceException
C# | public class NotSupportedException : VoiceException
C++ | public ref class NotSupportedException : VoiceException
JScript | public class NotSupportedException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotSupportedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NotSupportedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotSupportedException.NotSupportedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotSupportedException();
protected NotSupportedException(SerializationInfo, StreamingContext);
public NotSupportedException(string);
public NotSupportedException(string, Exception);


NotSupportedException.NotSupportedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotSupportedException.NotSupportedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotSupportedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotSupportedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotSupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotSupportedException.NotSupportedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotSupportedException.NotSupportedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotSupportedException(
string message,
Exception inner
);
C++ public:
NotSupportedException(
String^ message,
Exception^ inner
);
JScript public function NotSupportedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotSupportedException.NotSupportedException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotSupportedException.NotSupportedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotSupportedException(
string message
);
C++ public:
NotSupportedException(
String^ message
);
JScript public function NotSupportedException(
message : String
);

Parameters

message System.String


NotSupportedException.NotSupportedException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

NotSupportedException.NotSupportedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotSupportedException();
C++ public:
NotSupportedException();
JScript | public function NotSupportedException();


NoVoiceSessionException Class (Microsoft.DirectX.DirectPlay.Voice)

NoVoiceSessionException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The session specified is not a voice session. Deprecated.

Definition

Visual Basic Public Class NoVoiceSessionException
Inherits VoiceException
C# | public class NoVoiceSessionException : VoiceException
C++ | public ref class NoVoiceSessionException : VoiceException
JScript | public class NoVoiceSessionException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoVoiceSessionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
NoVoiceSessionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoVoiceSessionException.NoVoiceSessionException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoVoiceSessionException();
protected NoVoiceSessionException(SerializationInfo, StreamingContext);
public NoVoiceSessionException(string);
public NoVoiceSessionException(string, Exception);


NoVoiceSessionException.NoVoiceSessionException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoVoiceSessionException.NoVoiceSessionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoVoiceSessionException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoVoiceSessionException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoVoiceSessionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoVoiceSessionException.NoVoiceSessionException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoVoiceSessionException.NoVoiceSessionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoVoiceSessionException(
string message,
Exception inner
);
C++ public:
NoVoiceSessionException(
String^ message,
Exception^ inner
);
JScript public function NoVoiceSessionException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoVoiceSessionException.NoVoiceSessionException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoVoiceSessionException.NoVoiceSessionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoVoiceSessionException(
string message
);
C++ public:
NoVoiceSessionException(
String^ message
);
JScript public function NoVoiceSessionException(
message : String
);

Parameters

message System.String


NoVoiceSessionException.NoVoiceSessionException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

NoVoiceSessionException.NoVoiceSessionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoVoiceSessionException();
C++ public:
NoVoiceSessionException();
JScript | public function NoVoiceSessionException();


OutputLevelEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidOutputlevelDplay message periodically to notify the user of the output level of playback.The structure contains information for the DvmsgidOutputlevelDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class OutputLevelEventArgs
Inherits EventArgs
C# | public sealed class OutputLevelEventArgs : EventArgs
C++ | public ref class OutputLevelEventArgs sealed : EventArgs
JScript | public final class OutputLevelEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
OutputLevelEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
OutputLevelEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OutputLevelEventArgs.OutputLevelEventArgs(OutputLevelMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelEventArgs.OutputLevelEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As OutputLevelMessage _
)
C# public OutputLevelEventArgs(
OutputLevelMessage dpMessage
);
C++ public:
OutputLevelEventArgs(
OutputLevelMessage dpMessage
);
JScript public function OutputLevelEventArgs(
dpMessage : OutputLevelMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.OutputLevelMessage


OutputLevelEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As OutputLevelMessage
C# | public OutputLevelMessage Message;
C++ | public: OutputLevelMessage Message;
JScript | public var Message : OutputLevelMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.OutputLevelMessage

This field is read/write.


PlaybackSystemErrorException Class (Microsoft.DirectX.DirectPlay.Voice)

PlaybackSystemErrorException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error in the playback system occurred. Deprecated.

Definition

Visual Basic Public Class PlaybackSystemErrorException
Inherits VoiceException
C# | public class PlaybackSystemErrorException : VoiceException
C++ | public ref class PlaybackSystemErrorException : VoiceException
JScript | public class PlaybackSystemErrorException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlaybackSystemErrorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
PlaybackSystemErrorException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlaybackSystemErrorException.PlaybackSystemErrorException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlaybackSystemErrorException();
protected PlaybackSystemErrorException(SerializationInfo, StreamingContext);
public PlaybackSystemErrorException(string);
public PlaybackSystemErrorException(string, Exception);


PlaybackSystemErrorException.PlaybackSystemErrorException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlaybackSystemErrorException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PlaybackSystemErrorException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PlaybackSystemErrorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


PlaybackSystemErrorException.PlaybackSystemErrorException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlaybackSystemErrorException(
string message,
Exception inner
);
C++ public:
PlaybackSystemErrorException(
String^ message,
Exception^ inner
);
JScript public function PlaybackSystemErrorException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


PlaybackSystemErrorException.PlaybackSystemErrorException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PlaybackSystemErrorException(
string message
);
C++ public:
PlaybackSystemErrorException(
String^ message
);
JScript public function PlaybackSystemErrorException(
message : String
);

Parameters

message System.String


PlaybackSystemErrorException.PlaybackSystemErrorException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlaybackSystemErrorException.PlaybackSystemErrorException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlaybackSystemErrorException();
C++ public:
PlaybackSystemErrorException();
JScript | public function PlaybackSystemErrorException();


PlayerOutputLevelEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class PlayerOutputLevelEventArgs
Inherits EventArgs
C# | public sealed class PlayerOutputLevelEventArgs : EventArgs
C++ | public ref class PlayerOutputLevelEventArgs sealed : EventArgs
JScript | public final class PlayerOutputLevelEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerOutputLevelEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerOutputLevelEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerOutputLevelEventArgs.PlayerOutputLevelEventArgs(PlayerOutputLevelMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelEventArgs.PlayerOutputLevelEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As PlayerOutputLevelMessage _
)
C# public PlayerOutputLevelEventArgs(
PlayerOutputLevelMessage dpMessage
);
C++ public:
PlayerOutputLevelEventArgs(
PlayerOutputLevelMessage dpMessage
);
JScript public function PlayerOutputLevelEventArgs(
dpMessage : PlayerOutputLevelMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelMessage


PlayerOutputLevelEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As PlayerOutputLevelMessage
C# | public PlayerOutputLevelMessage Message;
C++ | public: PlayerOutputLevelMessage Message;
JScript | public var Message : PlayerOutputLevelMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelMessage

This field is read/write.


PlayerStartedEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

PlayerStartedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerStarted event. Deprecated.

Definition

Visual Basic NotInheritable Public Class PlayerStartedEventArgs
Inherits EventArgs
C# | public sealed class PlayerStartedEventArgs : EventArgs
C++ | public ref class PlayerStartedEventArgs sealed : EventArgs
JScript | public final class PlayerStartedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerStartedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerStartedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerStartedEventArgs.PlayerStartedEventArgs(PlayerVoiceStartMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlayerStartedEventArgs.PlayerStartedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As PlayerVoiceStartMessage _
)
C# public PlayerStartedEventArgs(
PlayerVoiceStartMessage dpMessage
);
C++ public:
PlayerStartedEventArgs(
PlayerVoiceStartMessage dpMessage
);
JScript public function PlayerStartedEventArgs(
dpMessage : PlayerVoiceStartMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.PlayerVoiceStartMessage


PlayerStartedEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

PlayerStartedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As PlayerVoiceStartMessage
C# | public PlayerVoiceStartMessage Message;
C++ | public: PlayerVoiceStartMessage Message;
JScript | public var Message : PlayerVoiceStartMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.PlayerVoiceStartMessage

This field is read/write.


PlayerStoppedEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

PlayerStoppedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerStopped event. Deprecated.

Definition

Visual Basic NotInheritable Public Class PlayerStoppedEventArgs
Inherits EventArgs
C# | public sealed class PlayerStoppedEventArgs : EventArgs
C++ | public ref class PlayerStoppedEventArgs sealed : EventArgs
JScript | public final class PlayerStoppedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerStoppedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerStoppedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerStoppedEventArgs.PlayerStoppedEventArgs(PlayerVoiceStopMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlayerStoppedEventArgs.PlayerStoppedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As PlayerVoiceStopMessage _
)
C# public PlayerStoppedEventArgs(
PlayerVoiceStopMessage dpMessage
);
C++ public:
PlayerStoppedEventArgs(
PlayerVoiceStopMessage dpMessage
);
JScript public function PlayerStoppedEventArgs(
dpMessage : PlayerVoiceStopMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.PlayerVoiceStopMessage


PlayerStoppedEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

PlayerStoppedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As PlayerVoiceStopMessage
C# | public PlayerVoiceStopMessage Message;
C++ | public: PlayerVoiceStopMessage Message;
JScript | public var Message : PlayerVoiceStopMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.PlayerVoiceStopMessage

This field is read/write.


RecordStartedEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

RecordStartedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the RecordStarted event. Deprecated.

Definition

Visual Basic NotInheritable Public Class RecordStartedEventArgs
Inherits EventArgs
C# | public sealed class RecordStartedEventArgs : EventArgs
C++ | public ref class RecordStartedEventArgs sealed : EventArgs
JScript | public final class RecordStartedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
RecordStartedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
RecordStartedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RecordStartedEventArgs.RecordStartedEventArgs(RecordStartMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

RecordStartedEventArgs.RecordStartedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As RecordStartMessage _
)
C# public RecordStartedEventArgs(
RecordStartMessage dpMessage
);
C++ public:
RecordStartedEventArgs(
RecordStartMessage dpMessage
);
JScript public function RecordStartedEventArgs(
dpMessage : RecordStartMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.RecordStartMessage


RecordStartedEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

RecordStartedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As RecordStartMessage
C# | public RecordStartMessage Message;
C++ | public: RecordStartMessage Message;
JScript | public var Message : RecordStartMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.RecordStartMessage

This field is read/write.


RecordStoppedEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

RecordStoppedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the RecordStopped event. Deprecated.

Definition

Visual Basic NotInheritable Public Class RecordStoppedEventArgs
Inherits EventArgs
C# | public sealed class RecordStoppedEventArgs : EventArgs
C++ | public ref class RecordStoppedEventArgs sealed : EventArgs
JScript | public final class RecordStoppedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
RecordStoppedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
RecordStoppedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RecordStoppedEventArgs.RecordStoppedEventArgs(RecordStopMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

RecordStoppedEventArgs.RecordStoppedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As RecordStopMessage _
)
C# public RecordStoppedEventArgs(
RecordStopMessage dpMessage
);
C++ public:
RecordStoppedEventArgs(
RecordStopMessage dpMessage
);
JScript public function RecordStoppedEventArgs(
dpMessage : RecordStopMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.RecordStopMessage


RecordStoppedEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

RecordStoppedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As RecordStopMessage
C# | public RecordStopMessage Message;
C++ | public: RecordStopMessage Message;
JScript | public var Message : RecordStopMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.RecordStopMessage

This field is read/write.


RecordSystemErrorException Class (Microsoft.DirectX.DirectPlay.Voice)

RecordSystemErrorException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error in the recording system occurred. Deprecated.

Definition

Visual Basic Public Class RecordSystemErrorException
Inherits VoiceException
C# | public class RecordSystemErrorException : VoiceException
C++ | public ref class RecordSystemErrorException : VoiceException
JScript | public class RecordSystemErrorException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
RecordSystemErrorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
RecordSystemErrorException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RecordSystemErrorException.RecordSystemErrorException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public RecordSystemErrorException();
protected RecordSystemErrorException(SerializationInfo, StreamingContext);
public RecordSystemErrorException(string);
public RecordSystemErrorException(string, Exception);


RecordSystemErrorException.RecordSystemErrorException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected RecordSystemErrorException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
RecordSystemErrorException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function RecordSystemErrorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


RecordSystemErrorException.RecordSystemErrorException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public RecordSystemErrorException(
string message,
Exception inner
);
C++ public:
RecordSystemErrorException(
String^ message,
Exception^ inner
);
JScript public function RecordSystemErrorException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


RecordSystemErrorException.RecordSystemErrorException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public RecordSystemErrorException(
string message
);
C++ public:
RecordSystemErrorException(
String^ message
);
JScript public function RecordSystemErrorException(
message : String
);

Parameters

message System.String


RecordSystemErrorException.RecordSystemErrorException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

RecordSystemErrorException.RecordSystemErrorException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public RecordSystemErrorException();
C++ public:
RecordSystemErrorException();
JScript | public function RecordSystemErrorException();


RunSetupException Class (Microsoft.DirectX.DirectPlay.Voice)

RunSetupException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified audio configuration has not been tested. Call the Test.CheckAudioSetup method. Deprecated.

Definition

Visual Basic Public Class RunSetupException
Inherits VoiceException
C# | public class RunSetupException : VoiceException
C++ | public ref class RunSetupException : VoiceException
JScript | public class RunSetupException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
RunSetupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
RunSetupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RunSetupException.RunSetupException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public RunSetupException();
protected RunSetupException(SerializationInfo, StreamingContext);
public RunSetupException(string);
public RunSetupException(string, Exception);


RunSetupException.RunSetupException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

RunSetupException.RunSetupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected RunSetupException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
RunSetupException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function RunSetupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


RunSetupException.RunSetupException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

RunSetupException.RunSetupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public RunSetupException(
string message,
Exception inner
);
C++ public:
RunSetupException(
String^ message,
Exception^ inner
);
JScript public function RunSetupException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


RunSetupException.RunSetupException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

RunSetupException.RunSetupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public RunSetupException(
string message
);
C++ public:
RunSetupException(
String^ message
);
JScript public function RunSetupException(
message : String
);

Parameters

message System.String


RunSetupException.RunSetupException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

RunSetupException.RunSetupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public RunSetupException();
C++ public:
RunSetupException();
JScript | public function RunSetupException();


SendErrorException Class (Microsoft.DirectX.DirectPlay.Voice)

SendErrorException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An error occurred while sending data. Deprecated.

Definition

Visual Basic Public Class SendErrorException
Inherits VoiceException
C# | public class SendErrorException : VoiceException
C++ | public ref class SendErrorException : VoiceException
JScript | public class SendErrorException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SendErrorException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
SendErrorException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SendErrorException.SendErrorException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SendErrorException();
protected SendErrorException(SerializationInfo, StreamingContext);
public SendErrorException(string);
public SendErrorException(string, Exception);


SendErrorException.SendErrorException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SendErrorException.SendErrorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SendErrorException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SendErrorException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SendErrorException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SendErrorException.SendErrorException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SendErrorException.SendErrorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SendErrorException(
string message,
Exception inner
);
C++ public:
SendErrorException(
String^ message,
Exception^ inner
);
JScript public function SendErrorException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SendErrorException.SendErrorException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SendErrorException.SendErrorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SendErrorException(
string message
);
C++ public:
SendErrorException(
String^ message
);
JScript public function SendErrorException(
message : String
);

Parameters

message System.String


SendErrorException.SendErrorException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

SendErrorException.SendErrorException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SendErrorException();
C++ public:
SendErrorException();
JScript | public function SendErrorException();


Server Class (Microsoft.DirectX.DirectPlay.Voice)

Server Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Server object to manage the host of the voice session. Deprecated.

Definition

Visual Basic Public Class Server
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Server : MarshalByRefObject, IDisposable
C++ | public ref class Server : MarshalByRefObject, IDisposable
JScript | public class Server extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
PlayerCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.
PlayerDeleted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.
SessionLost
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a session is lost. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetTransmitTargets
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the transmit targets, if any, of the voice stream for a player in a session. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerDeleted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionLost
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Server
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetTransmitTargets
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the transmission of audio from the client to the specified members of the session. Deprecated.
StartSession
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Starts an initialized Microsoft® DirectPlay® Voice session within a running Microsoft® DirectPlay® transport session. This method must be successfully called before the clients can complete a connection to the voice session. Deprecated.
StopSession
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stops the Microsoft® DirectPlay® Voice session. Deprecated.

Properties

Property Description
CompressionTypes
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves available compression types for the system. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
SessionDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the Microsoft DirectPlay Voice session settings. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Server

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Server.Dispose() Method (Microsoft.DirectX.DirectPlay.Voice)

Server.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by the object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Server();
JScript | public override function Dispose();


Server.Equals(Object) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Server.Finalize() Method (Microsoft.DirectX.DirectPlay.Voice)

Server.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Server();
C++ | !Server();
JScript | protected override function Finalize();


Server.GetHashCode() Method (Microsoft.DirectX.DirectPlay.Voice)

Server.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Server.GetTransmitTargets(Int32) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.GetTransmitTargets Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the transmit targets, if any, of the voice stream for a player in a session. Deprecated.

Definition

Visual Basic Public Function GetTransmitTargets( _
ByVal sourceID As Integer _
) As Integer()
C# public int[] GetTransmitTargets(
int sourceID
);
C++ public:
array<int>^ GetTransmitTargets(
int sourceID
);
JScript public function GetTransmitTargets(
sourceID : int
) : int[];

Parameters

sourceID System.Int32

Return Value

System.Int32[]


Server.op_Equality(Server,Server) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Server, _
ByVal right As Server _
) As Boolean
C# public static bool op_Equality(
Server left,
Server right
);
C++ public:
static bool operator==(
Server^ left,
Server^ right
);
JScript public static function op_Equality(
left : Server,
right : Server
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Voice.Server
The Server structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Voice.Server
The Server structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Server.op_Inequality(Server,Server) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Server, _
ByVal right As Server _
) As Boolean
C# public static bool op_Inequality(
Server left,
Server right
);
C++ public:
static bool operator!=(
Server^ left,
Server^ right
);
JScript public static function op_Inequality(
left : Server,
right : Server
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Voice.Server
The Server structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Voice.Server
The Server structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Server.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Server.raise_PlayerCreated(Object,VoicePlayerCreatedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.raise_PlayerCreated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerCreated( _
ByVal i1 As Object, _
ByVal i2 As VoicePlayerCreatedEventArgs _
)
C# protected void raise_PlayerCreated(
object i1,
VoicePlayerCreatedEventArgs i2
);
C++ protected:
void raise_PlayerCreated(
Object^ i1,
VoicePlayerCreatedEventArgs^ i2
);
JScript protected function raise_PlayerCreated(
i1 : Object,
i2 : VoicePlayerCreatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.VoicePlayerCreatedEventArgs


Server.raise_PlayerDeleted(Object,VoicePlayerDeletedEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.raise_PlayerDeleted Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerDeleted( _
ByVal i1 As Object, _
ByVal i2 As VoicePlayerDeletedEventArgs _
)
C# protected void raise_PlayerDeleted(
object i1,
VoicePlayerDeletedEventArgs i2
);
C++ protected:
void raise_PlayerDeleted(
Object^ i1,
VoicePlayerDeletedEventArgs^ i2
);
JScript protected function raise_PlayerDeleted(
i1 : Object,
i2 : VoicePlayerDeletedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.VoicePlayerDeletedEventArgs


Server.raise_SessionLost(Object,SessionLostEventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.raise_SessionLost Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SessionLost( _
ByVal i1 As Object, _
ByVal i2 As SessionLostEventArgs _
)
C# protected void raise_SessionLost(
object i1,
SessionLostEventArgs i2
);
C++ protected:
void raise_SessionLost(
Object^ i1,
SessionLostEventArgs^ i2
);
JScript protected function raise_SessionLost(
i1 : Object,
i2 : SessionLostEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.Voice.SessionLostEventArgs


Server.Server Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Server(object);
public Server(object, int[]);


Server.Server(Object,Int32[]) Constructor (Microsoft.DirectX.DirectPlay.Voice)

Server.Server Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dplayObject As Object, _
ByVal msgMask() As Integer _
)
C# public Server(
object dplayObject,
int[] msgMask
);
C++ public:
Server(
Object^ dplayObject,
array<int>^ msgMask
);
JScript public function Server(
dplayObject : Object,
msgMask : int[]
);

Parameters

dplayObject System.Object
msgMask System.Int32[]


Server.Server(Object) Constructor (Microsoft.DirectX.DirectPlay.Voice)

Server.Server Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dplayObject As Object _
)
C# public Server(
object dplayObject
);
C++ public:
Server(
Object^ dplayObject
);
JScript public function Server(
dplayObject : Object
);

Parameters

dplayObject System.Object


Server.SetTransmitTargets(Int32,Int32[]) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.SetTransmitTargets Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the transmission of audio from the client to the specified members of the session. Deprecated.

Definition

Visual Basic Public Sub SetTransmitTargets( _
ByVal sourceID As Integer, _
ByVal targets() As Integer _
)
C# public void SetTransmitTargets(
int sourceID,
int[] targets
);
C++ public:
void SetTransmitTargets(
int sourceID,
array<int>^ targets
);
JScript public function SetTransmitTargets(
sourceID : int,
targets : int[]
);

Parameters

sourceID System.Int32
targets System.Int32[]


Server.StartSession(SessionDescription) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.StartSession Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Starts an initialized Microsoft® DirectPlay® Voice session within a running Microsoft® DirectPlay® transport session. This method must be successfully called before the clients can complete a connection to the voice session. Deprecated.

Definition

Visual Basic Public Sub StartSession( _
ByVal sessionDescription As SessionDescription _
)
C# public void StartSession(
SessionDescription sessionDescription
);
C++ public:
void StartSession(
SessionDescription sessionDescription
);
JScript public function StartSession(
sessionDescription : SessionDescription
);

Parameters

sessionDescription Microsoft.DirectX.DirectPlay.Voice.SessionDescription


Server.StopSession Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stops the Microsoft® DirectPlay® Voice session. Deprecated.

Overload List

public void StopSession();
public void StopSession(StopSessionFlags);


Server.StopSession() Method (Microsoft.DirectX.DirectPlay.Voice)

Server.StopSession Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stops the Microsoft® DirectPlay® Voice session. Deprecated.

Definition

Visual Basic | Public Sub StopSession()
C# | public void StopSession();
C++ public:
void StopSession();
JScript | public function StopSession();


Server.StopSession(StopSessionFlags) Method (Microsoft.DirectX.DirectPlay.Voice)

Server.StopSession Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Stops the Microsoft® DirectPlay® Voice session. Deprecated.

Definition

Visual Basic Public Sub StopSession( _
ByVal flags As StopSessionFlags _
)
C# public void StopSession(
StopSessionFlags flags
);
C++ public:
void StopSession(
StopSessionFlags flags
);
JScript public function StopSession(
flags : StopSessionFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.Voice.StopSessionFlags


Server.CompressionTypes Property (Microsoft.DirectX.DirectPlay.Voice)

Server.CompressionTypes Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves available compression types for the system. Deprecated.

Definition

Visual Basic | Public ReadOnly Property CompressionTypes As CompressionInformation()
C# | public CompressionInformation[] CompressionTypes { get; }
C++ public:
property array<CompressionInformation>^ CompressionTypes {
array<CompressionInformation>^ get();
}
JScript | public function get CompressionTypes() : CompressionInformation[]

Property Value

Microsoft.DirectX.DirectPlay.Voice.CompressionInformation[]

This property is read-only.


Server.Disposed Property (Microsoft.DirectX.DirectPlay.Voice)

Server.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Server.SessionDescription Property (Microsoft.DirectX.DirectPlay.Voice)

Server.SessionDescription Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the Microsoft DirectPlay Voice session settings. Deprecated.

Definition

Visual Basic | Public Property SessionDescription As SessionDescription
C# | public SessionDescription SessionDescription { get; set; }
C++ public:
property SessionDescription SessionDescription {
SessionDescription get();
void set(SessionDescription value);
}
JScript public function get SessionDescription() : SessionDescription
public function set SessionDescription(SessionDescription);

Property Value

Microsoft.DirectX.DirectPlay.Voice.SessionDescription

This property is read/write.


Server.Disposing Event (Microsoft.DirectX.DirectPlay.Voice)

Server.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Server.Disposing event, use the following code.

server.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Server.PlayerCreated Event (Microsoft.DirectX.DirectPlay.Voice)

Server.PlayerCreated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.

Definition

Visual Basic | Public Event PlayerCreated As VoicePlayerCreatedEventHandler
C# | public event VoicePlayerCreatedEventHandler PlayerCreated;
C++ public:
event VoicePlayerCreatedEventHandler^ PlayerCreated;
JScript | In JScript, you can use events, but you cannot define your own.


Server.PlayerDeleted Event (Microsoft.DirectX.DirectPlay.Voice)

Server.PlayerDeleted Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.

Definition

Visual Basic | Public Event PlayerDeleted As VoicePlayerDeletedEventHandler
C# | public event VoicePlayerDeletedEventHandler PlayerDeleted;
C++ public:
event VoicePlayerDeletedEventHandler^ PlayerDeleted;
JScript | In JScript, you can use events, but you cannot define your own.


Server.SessionLost Event (Microsoft.DirectX.DirectPlay.Voice)

Server.SessionLost Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a session is lost. Deprecated.

Definition

Visual Basic | Public Event SessionLost As SessionLostEventHandler
C# | public event SessionLostEventHandler SessionLost;
C++ public:
event SessionLostEventHandler^ SessionLost;
JScript | In JScript, you can use events, but you cannot define your own.


SessionLostEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

SessionLostEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidSessionlostDplay message when the voice session terminates.The structure contains information for the DvmsgidSessionlostDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class SessionLostEventArgs
Inherits EventArgs
C# | public sealed class SessionLostEventArgs : EventArgs
C++ | public ref class SessionLostEventArgs sealed : EventArgs
JScript | public final class SessionLostEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SessionLostEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SessionLostEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionLostEventArgs.SessionLostEventArgs(SessionLostMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SessionLostEventArgs.SessionLostEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As SessionLostMessage _
)
C# public SessionLostEventArgs(
SessionLostMessage dpMessage
);
C++ public:
SessionLostEventArgs(
SessionLostMessage dpMessage
);
JScript public function SessionLostEventArgs(
dpMessage : SessionLostMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.SessionLostMessage


SessionLostEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

SessionLostEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As SessionLostMessage
C# | public SessionLostMessage Message;
C++ | public: SessionLostMessage Message;
JScript | public var Message : SessionLostMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.SessionLostMessage

This field is read/write.


SessionLostException Class (Microsoft.DirectX.DirectPlay.Voice)

SessionLostException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The transport has lost the connection to the session. Deprecated.

Definition

Visual Basic Public Class SessionLostException
Inherits VoiceException
C# | public class SessionLostException : VoiceException
C++ | public ref class SessionLostException : VoiceException
JScript | public class SessionLostException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SessionLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
SessionLostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionLostException.SessionLostException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SessionLostException();
protected SessionLostException(SerializationInfo, StreamingContext);
public SessionLostException(string);
public SessionLostException(string, Exception);


SessionLostException.SessionLostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SessionLostException.SessionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SessionLostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SessionLostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SessionLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SessionLostException.SessionLostException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SessionLostException.SessionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SessionLostException(
string message,
Exception inner
);
C++ public:
SessionLostException(
String^ message,
Exception^ inner
);
JScript public function SessionLostException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SessionLostException.SessionLostException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SessionLostException.SessionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SessionLostException(
string message
);
C++ public:
SessionLostException(
String^ message
);
JScript public function SessionLostException(
message : String
);

Parameters

message System.String


SessionLostException.SessionLostException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

SessionLostException.SessionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SessionLostException();
C++ public:
SessionLostException();
JScript | public function SessionLostException();


SetTargetsEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

SetTargetsEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the SetTargets event. Deprecated.

Definition

Visual Basic NotInheritable Public Class SetTargetsEventArgs
Inherits EventArgs
C# | public sealed class SetTargetsEventArgs : EventArgs
C++ | public ref class SetTargetsEventArgs sealed : EventArgs
JScript | public final class SetTargetsEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SetTargetsEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SetTargetsEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SetTargetsEventArgs.SetTargetsEventArgs(SetTargetsMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SetTargetsEventArgs.SetTargetsEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As SetTargetsMessage _
)
C# public SetTargetsEventArgs(
SetTargetsMessage dpMessage
);
C++ public:
SetTargetsEventArgs(
SetTargetsMessage dpMessage
);
JScript public function SetTargetsEventArgs(
dpMessage : SetTargetsMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.SetTargetsMessage


SetTargetsEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

SetTargetsEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As SetTargetsMessage
C# | public SetTargetsMessage Message;
C++ | public: SetTargetsMessage Message;
JScript | public var Message : SetTargetsMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.SetTargetsMessage

This field is read/write.


SoundInitializeFailureException Class (Microsoft.DirectX.DirectPlay.Voice)

SoundInitializeFailureException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A failure was encountered initializing the sound card. Deprecated.

Definition

Visual Basic Public Class SoundInitializeFailureException
Inherits VoiceException
C# | public class SoundInitializeFailureException : VoiceException
C++ | public ref class SoundInitializeFailureException : VoiceException
JScript | public class SoundInitializeFailureException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SoundInitializeFailureException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
SoundInitializeFailureException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SoundInitializeFailureException.SoundInitializeFailureException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SoundInitializeFailureException();
protected SoundInitializeFailureException(SerializationInfo, StreamingContext);
public SoundInitializeFailureException(string);
public SoundInitializeFailureException(string, Exception);


SoundInitializeFailureException.SoundInitializeFailureException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SoundInitializeFailureException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SoundInitializeFailureException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SoundInitializeFailureException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SoundInitializeFailureException.SoundInitializeFailureException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SoundInitializeFailureException(
string message,
Exception inner
);
C++ public:
SoundInitializeFailureException(
String^ message,
Exception^ inner
);
JScript public function SoundInitializeFailureException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SoundInitializeFailureException.SoundInitializeFailureException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SoundInitializeFailureException(
string message
);
C++ public:
SoundInitializeFailureException(
String^ message
);
JScript public function SoundInitializeFailureException(
message : String
);

Parameters

message System.String


SoundInitializeFailureException.SoundInitializeFailureException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

SoundInitializeFailureException.SoundInitializeFailureException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SoundInitializeFailureException();
C++ public:
SoundInitializeFailureException();
JScript | public function SoundInitializeFailureException();


Test Class (Microsoft.DirectX.DirectPlay.Voice)

Test Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the Test.CheckAudioSetup method of the Test object to test the Microsoft® DirectPlay® Voice audio configuration. Deprecated.

Definition

Visual Basic Public Class Test
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Test : MarshalByRefObject, IDisposable
C++ | public ref class Test : MarshalByRefObject, IDisposable
JScript | public class Test extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Methods

Method Description
CheckAudioSetup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Test
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Test

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Test.CheckAudioSetup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Overload List

public void CheckAudioSetup();
public void CheckAudioSetup(Guid, Guid);
public void CheckAudioSetup(Guid, Guid, Control, TestFlags);
public void CheckAudioSetup(Guid, Guid, TestFlags);


Test.CheckAudioSetup() Method (Microsoft.DirectX.DirectPlay.Voice)

Test.CheckAudioSetup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Definition

Visual Basic | Public Sub CheckAudioSetup()
C# | public void CheckAudioSetup();
C++ public:
void CheckAudioSetup();
JScript | public function CheckAudioSetup();


Test.CheckAudioSetup(Guid,Guid,TestFlags) Method (Microsoft.DirectX.DirectPlay.Voice)

Test.CheckAudioSetup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Definition

Visual Basic Public Sub CheckAudioSetup( _
ByVal guidPlayback As Guid, _
ByVal guidCapture As Guid, _
ByVal flags As TestFlags _
)
C# public void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture,
TestFlags flags
);
C++ public:
void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture,
TestFlags flags
);
JScript public function CheckAudioSetup(
guidPlayback : Guid,
guidCapture : Guid,
flags : TestFlags
);

Parameters

guidPlayback System.Guid
guidCapture System.Guid
flags Microsoft.DirectX.DirectPlay.Voice.TestFlags


Test.CheckAudioSetup(Guid,Guid) Method (Microsoft.DirectX.DirectPlay.Voice)

Test.CheckAudioSetup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Definition

Visual Basic Public Sub CheckAudioSetup( _
ByVal guidPlayback As Guid, _
ByVal guidCapture As Guid _
)
C# public void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture
);
C++ public:
void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture
);
JScript public function CheckAudioSetup(
guidPlayback : Guid,
guidCapture : Guid
);

Parameters

guidPlayback System.Guid
guidCapture System.Guid


Test.CheckAudioSetup(Guid,Guid,Control,TestFlags) Method (Microsoft.DirectX.DirectPlay.Voice)

Test.CheckAudioSetup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Runs the Audio Setup Wizard on the specified devices. This wizard runs a series of tests on the devices to determine if they are capable of full duplex audio and to ensure that the microphone is plugged in and working correctly on the capture device. Deprecated.

Definition

Visual Basic Public Sub CheckAudioSetup( _
ByVal guidPlayback As Guid, _
ByVal guidCapture As Guid, _
ByVal window As Control, _
ByVal flags As TestFlags _
)
C# public void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture,
Control window,
TestFlags flags
);
C++ public:
void CheckAudioSetup(
Guid guidPlayback,
Guid guidCapture,
Control^ window,
TestFlags flags
);
JScript public function CheckAudioSetup(
guidPlayback : Guid,
guidCapture : Guid,
window : Control,
flags : TestFlags
);

Parameters

guidPlayback System.Guid
guidCapture System.Guid
window System.Windows.Forms.Control
flags Microsoft.DirectX.DirectPlay.Voice.TestFlags


Test.Dispose() Method (Microsoft.DirectX.DirectPlay.Voice)

Test.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Test();
JScript | public override function Dispose();

See Also

  • Test.Dispose
  • Test.Disposing


Test.Finalize() Method (Microsoft.DirectX.DirectPlay.Voice)

Test.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Test();
C++ | !Test();
JScript | protected override function Finalize();


Test.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay.Voice)

Test.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Test.Test() Constructor (Microsoft.DirectX.DirectPlay.Voice)

Test.Test Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Test();
C++ public:
Test();
JScript | public function Test();


Test.Disposed Property (Microsoft.DirectX.DirectPlay.Voice)

Test.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Test.Disposing Event (Microsoft.DirectX.DirectPlay.Voice)

Test.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Test.Disposing event, use the following code.

test.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


TimedOutException Class (Microsoft.DirectX.DirectPlay.Voice)

TimedOutException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not complete because it has timed out. Deprecated.

Definition

Visual Basic Public Class TimedOutException
Inherits VoiceException
C# | public class TimedOutException : VoiceException
C++ | public ref class TimedOutException : VoiceException
JScript | public class TimedOutException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TimedOutException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
TimedOutException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TimedOutException.TimedOutException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TimedOutException();
protected TimedOutException(SerializationInfo, StreamingContext);
public TimedOutException(string);
public TimedOutException(string, Exception);


TimedOutException.TimedOutException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TimedOutException.TimedOutException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TimedOutException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TimedOutException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TimedOutException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TimedOutException.TimedOutException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TimedOutException.TimedOutException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TimedOutException(
string message,
Exception inner
);
C++ public:
TimedOutException(
String^ message,
Exception^ inner
);
JScript public function TimedOutException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TimedOutException.TimedOutException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TimedOutException.TimedOutException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TimedOutException(
string message
);
C++ public:
TimedOutException(
String^ message
);
JScript public function TimedOutException(
message : String
);

Parameters

message System.String


TimedOutException.TimedOutException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

TimedOutException.TimedOutException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TimedOutException();
C++ public:
TimedOutException();
JScript | public function TimedOutException();


TransportNoPlayerException Class (Microsoft.DirectX.DirectPlay.Voice)

TransportNoPlayerException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified transport is connected/hosting but no local player exists. Deprecated.

Definition

Visual Basic Public Class TransportNoPlayerException
Inherits VoiceException
C# | public class TransportNoPlayerException : VoiceException
C++ | public ref class TransportNoPlayerException : VoiceException
JScript | public class TransportNoPlayerException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
TransportNoPlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
TransportNoPlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TransportNoPlayerException.TransportNoPlayerException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TransportNoPlayerException();
protected TransportNoPlayerException(SerializationInfo, StreamingContext);
public TransportNoPlayerException(string);
public TransportNoPlayerException(string, Exception);


TransportNoPlayerException.TransportNoPlayerException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TransportNoPlayerException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TransportNoPlayerException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TransportNoPlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TransportNoPlayerException.TransportNoPlayerException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TransportNoPlayerException(
string message,
Exception inner
);
C++ public:
TransportNoPlayerException(
String^ message,
Exception^ inner
);
JScript public function TransportNoPlayerException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TransportNoPlayerException.TransportNoPlayerException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TransportNoPlayerException(
string message
);
C++ public:
TransportNoPlayerException(
String^ message
);
JScript public function TransportNoPlayerException(
message : String
);

Parameters

message System.String


TransportNoPlayerException.TransportNoPlayerException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNoPlayerException.TransportNoPlayerException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TransportNoPlayerException();
C++ public:
TransportNoPlayerException();
JScript | public function TransportNoPlayerException();


TransportNoSessionException Class (Microsoft.DirectX.DirectPlay.Voice)

TransportNoSessionException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified transport is valid but is not connected/hosting. Deprecated.

Definition

Visual Basic Public Class TransportNoSessionException
Inherits VoiceException
C# | public class TransportNoSessionException : VoiceException
C++ | public ref class TransportNoSessionException : VoiceException
JScript | public class TransportNoSessionException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
TransportNoSessionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
TransportNoSessionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TransportNoSessionException.TransportNoSessionException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TransportNoSessionException();
protected TransportNoSessionException(SerializationInfo, StreamingContext);
public TransportNoSessionException(string);
public TransportNoSessionException(string, Exception);


TransportNoSessionException.TransportNoSessionException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TransportNoSessionException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TransportNoSessionException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TransportNoSessionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TransportNoSessionException.TransportNoSessionException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TransportNoSessionException(
string message,
Exception inner
);
C++ public:
TransportNoSessionException(
String^ message,
Exception^ inner
);
JScript public function TransportNoSessionException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TransportNoSessionException.TransportNoSessionException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TransportNoSessionException(
string message
);
C++ public:
TransportNoSessionException(
String^ message
);
JScript public function TransportNoSessionException(
message : String
);

Parameters

message System.String


TransportNoSessionException.TransportNoSessionException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNoSessionException.TransportNoSessionException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TransportNoSessionException();
C++ public:
TransportNoSessionException();
JScript | public function TransportNoSessionException();


TransportNotHostException Class (Microsoft.DirectX.DirectPlay.Voice)

TransportNotHostException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not the host of the voice session. Deprecated.

Definition

Visual Basic Public Class TransportNotHostException
Inherits VoiceException
C# | public class TransportNotHostException : VoiceException
C++ | public ref class TransportNotHostException : VoiceException
JScript | public class TransportNotHostException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
TransportNotHostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
TransportNotHostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TransportNotHostException.TransportNotHostException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TransportNotHostException();
protected TransportNotHostException(SerializationInfo, StreamingContext);
public TransportNotHostException(string);
public TransportNotHostException(string, Exception);


TransportNotHostException.TransportNotHostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNotHostException.TransportNotHostException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TransportNotHostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TransportNotHostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TransportNotHostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TransportNotHostException.TransportNotHostException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNotHostException.TransportNotHostException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TransportNotHostException(
string message,
Exception inner
);
C++ public:
TransportNotHostException(
String^ message,
Exception^ inner
);
JScript public function TransportNotHostException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TransportNotHostException.TransportNotHostException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNotHostException.TransportNotHostException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TransportNotHostException(
string message
);
C++ public:
TransportNotHostException(
String^ message
);
JScript public function TransportNotHostException(
message : String
);

Parameters

message System.String


TransportNotHostException.TransportNotHostException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

TransportNotHostException.TransportNotHostException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TransportNotHostException();
C++ public:
TransportNotHostException();
JScript | public function TransportNotHostException();


UserBackException Class (Microsoft.DirectX.DirectPlay.Voice)

UserBackException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user has pressed back on the first page of the CheckAudioSetup wizard. Deprecated.

Definition

Visual Basic Public Class UserBackException
Inherits VoiceException
C# | public class UserBackException : VoiceException
C++ | public ref class UserBackException : VoiceException
JScript | public class UserBackException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UserBackException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
UserBackException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UserBackException.UserBackException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UserBackException();
protected UserBackException(SerializationInfo, StreamingContext);
public UserBackException(string);
public UserBackException(string, Exception);


UserBackException.UserBackException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

UserBackException.UserBackException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UserBackException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UserBackException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UserBackException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UserBackException.UserBackException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

UserBackException.UserBackException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UserBackException(
string message,
Exception inner
);
C++ public:
UserBackException(
String^ message,
Exception^ inner
);
JScript public function UserBackException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UserBackException.UserBackException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

UserBackException.UserBackException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UserBackException(
string message
);
C++ public:
UserBackException(
String^ message
);
JScript public function UserBackException(
message : String
);

Parameters

message System.String


UserBackException.UserBackException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

UserBackException.UserBackException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public UserBackException();
C++ public:
UserBackException();
JScript | public function UserBackException();


UserCancelException Class (Microsoft.DirectX.DirectPlay.Voice)

UserCancelException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user canceled the operation. Deprecated.

Definition

Visual Basic Public Class UserCancelException
Inherits VoiceException
C# | public class UserCancelException : VoiceException
C++ | public ref class UserCancelException : VoiceException
JScript | public class UserCancelException extends VoiceException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from VoiceException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UserCancelException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
UserCancelException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UserCancelException.UserCancelException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public UserCancelException();
protected UserCancelException(SerializationInfo, StreamingContext);
public UserCancelException(string);
public UserCancelException(string, Exception);


UserCancelException.UserCancelException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

UserCancelException.UserCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UserCancelException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UserCancelException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UserCancelException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UserCancelException.UserCancelException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

UserCancelException.UserCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UserCancelException(
string message,
Exception inner
);
C++ public:
UserCancelException(
String^ message,
Exception^ inner
);
JScript public function UserCancelException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UserCancelException.UserCancelException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

UserCancelException.UserCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UserCancelException(
string message
);
C++ public:
UserCancelException(
String^ message
);
JScript public function UserCancelException(
message : String
);

Parameters

message System.String


UserCancelException.UserCancelException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

UserCancelException.UserCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public UserCancelException();
C++ public:
UserCancelException();
JScript | public function UserCancelException();


VoiceException Class (Microsoft.DirectX.DirectPlay.Voice)

VoiceException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception type for DirectPlay Voice exceptions. Derives from DirectXException. Deprecated.

Definition

Visual Basic Public Class VoiceException
Inherits DirectPlayException
C# | public class VoiceException : DirectPlayException
C++ | public ref class VoiceException : DirectPlayException
JScript | public class VoiceException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
VoiceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
VoiceException
AlreadyBufferedException
AlreadyPendingException
CompressionNotSupportedException
ConnectAbortedException
ConnectAbortingException
ConnectedException
ConnectionLostException
HostingException
IncompatibleVersionException
InvalidBufferException
InvalidDeviceException
InvalidFlagsException
InvalidGroupException
InvalidHandleException
InvalidObjectException
InvalidPlayerException
InvalidTargetException
LockedBufferException
No3DSoundException
NoRecordVolumeAvailableException
NotAllowedException
NotBufferedException
NotConnectedException
NotHostingException
NoTransportException
NotSupportedException
NoVoiceSessionException
PlaybackSystemErrorException
RecordSystemErrorException
RunSetupException
SendErrorException
SessionLostException
SoundInitializeFailureException
TimedOutException
TransportNoPlayerException
TransportNoSessionException
TransportNotHostException
UserBackException
UserCancelException

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VoiceException.GetExceptionFromResultInternal(Int32) Method (Microsoft.DirectX.DirectPlay.Voice)

VoiceException.GetExceptionFromResultInternal Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Shadows Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public new static Exception GetExceptionFromResultInternal(
int resultCode
);
C++ public:
static Exception^ GetExceptionFromResultInternal(
int resultCode
);
JScript public hide static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32

Return Value

System.Exception

Applies To

This object applies to a large number of classes.


VoiceException.VoiceException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public VoiceException();
protected VoiceException(SerializationInfo, StreamingContext);
public VoiceException(string);
public VoiceException(string, Exception);


VoiceException.VoiceException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay.Voice)

VoiceException.VoiceException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected VoiceException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
VoiceException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function VoiceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


VoiceException.VoiceException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay.Voice)

VoiceException.VoiceException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public VoiceException(
string message,
Exception inner
);
C++ public:
VoiceException(
String^ message,
Exception^ inner
);
JScript public function VoiceException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


VoiceException.VoiceException(String) Constructor (Microsoft.DirectX.DirectPlay.Voice)

VoiceException.VoiceException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public VoiceException(
string message
);
C++ public:
VoiceException(
String^ message
);
JScript public function VoiceException(
message : String
);

Parameters

message System.String


VoiceException.VoiceException() Constructor (Microsoft.DirectX.DirectPlay.Voice)

VoiceException.VoiceException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public VoiceException();
C++ public:
VoiceException();
JScript | public function VoiceException();


VoicePlayerCreatedEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

VoicePlayerCreatedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerCreated event. Deprecated.

Definition

Visual Basic NotInheritable Public Class VoicePlayerCreatedEventArgs
Inherits EventArgs
C# | public sealed class VoicePlayerCreatedEventArgs : EventArgs
C++ | public ref class VoicePlayerCreatedEventArgs sealed : EventArgs
JScript | public final class VoicePlayerCreatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
VoicePlayerCreatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
VoicePlayerCreatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VoicePlayerCreatedEventArgs.VoicePlayerCreatedEventArgs(CreateVoicePlayerMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

VoicePlayerCreatedEventArgs.VoicePlayerCreatedEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As CreateVoicePlayerMessage _
)
C# public VoicePlayerCreatedEventArgs(
CreateVoicePlayerMessage dpMessage
);
C++ public:
VoicePlayerCreatedEventArgs(
CreateVoicePlayerMessage dpMessage
);
JScript public function VoicePlayerCreatedEventArgs(
dpMessage : CreateVoicePlayerMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.CreateVoicePlayerMessage


VoicePlayerCreatedEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

VoicePlayerCreatedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As CreateVoicePlayerMessage
C# | public CreateVoicePlayerMessage Message;
C++ | public: CreateVoicePlayerMessage Message;
JScript | public var Message : CreateVoicePlayerMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.CreateVoicePlayerMessage

This field is read/write.


VoicePlayerDeletedEventArgs Class (Microsoft.DirectX.DirectPlay.Voice)

VoicePlayerDeletedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerDeleted event. Deprecated.

Definition

Visual Basic NotInheritable Public Class VoicePlayerDeletedEventArgs
Inherits EventArgs
C# | public sealed class VoicePlayerDeletedEventArgs : EventArgs
C++ | public ref class VoicePlayerDeletedEventArgs sealed : EventArgs
JScript | public final class VoicePlayerDeletedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
VoicePlayerDeletedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
VoicePlayerDeletedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VoicePlayerDeletedEventArgs.VoicePlayerDeletedEventArgs(DeleteVoicePlayerMessage) Constructor (Microsoft.DirectX.DirectPlay.Voice)

VoicePlayerDeletedEventArgs.VoicePlayerDeletedEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As DeleteVoicePlayerMessage _
)
C# public VoicePlayerDeletedEventArgs(
DeleteVoicePlayerMessage dpMessage
);
C++ public:
VoicePlayerDeletedEventArgs(
DeleteVoicePlayerMessage dpMessage
);
JScript public function VoicePlayerDeletedEventArgs(
dpMessage : DeleteVoicePlayerMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.Voice.DeleteVoicePlayerMessage


VoicePlayerDeletedEventArgs.Message Field (Microsoft.DirectX.DirectPlay.Voice)

VoicePlayerDeletedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As DeleteVoicePlayerMessage
C# | public DeleteVoicePlayerMessage Message;
C++ | public: DeleteVoicePlayerMessage Message;
JScript | public var Message : DeleteVoicePlayerMessage

Field Value

Microsoft.DirectX.DirectPlay.Voice.DeleteVoicePlayerMessage

This field is read/write.


BufferAggressiveness Enumeration (Microsoft.DirectX.DirectPlay.Voice)

BufferAggressiveness Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for BufferAggressiveness. Deprecated.

Definition

Visual Basic | Public Enum BufferAggressiveness
C# | public enum BufferAggressiveness
C++ | public enum class BufferAggressiveness
JScript | public enum BufferAggressiveness

Members

Member | Value | Description
Default | 0
Max | 100
Min | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BufferQuality Enumeration (Microsoft.DirectX.DirectPlay.Voice)

BufferQuality Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for BufferQuality. Deprecated.

Definition

Visual Basic | Public Enum BufferQuality
C# | public enum BufferQuality
C++ | public enum class BufferQuality
JScript | public enum BufferQuality

Members

Member | Value | Description
Default | 0
Max | 100
Min | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClientConfigFlags Enumeration (Microsoft.DirectX.DirectPlay.Voice)

ClientConfigFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for client configuration. Deprecated.

Definition

Visual Basic | Public Enum ClientConfigFlags
C# | public enum ClientConfigFlags
C++ | public enum class ClientConfigFlags
JScript | public enum ClientConfigFlags

Members

Member | Value | Description
EchoSuppression | 134217728
AutoVoiceActivated | 32
MuteGlobal | 16
AutoRecordVolume | 8
ManualVoiceActivated | 4
PlaybackMute | 2
RecordMute | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputLevelFlags Enumeration (Microsoft.DirectX.DirectPlay.Voice)

InputLevelFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for input level. Deprecated.

Definition

Visual Basic | Public Enum InputLevelFlags
C# | public enum InputLevelFlags
C++ | public enum class InputLevelFlags
JScript | public enum InputLevelFlags

Members

Member | Value | Description
Max | 99
Min | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotifyPeriod Enumeration (Microsoft.DirectX.DirectPlay.Voice)

NotifyPeriod Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for NotifyPeriod. Deprecated.

Definition

Visual Basic | Public Enum NotifyPeriod
C# | public enum NotifyPeriod
C++ | public enum class NotifyPeriod
JScript | public enum NotifyPeriod

Members

Member | Value | Description
Minimum | 20

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlaybackVolume Enumeration (Microsoft.DirectX.DirectPlay.Voice)

PlaybackVolume Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for PlaybackVolume. Deprecated.

Definition

Visual Basic | Public Enum PlaybackVolume
C# | public enum PlaybackVolume
C++ | public enum class PlaybackVolume
JScript | public enum PlaybackVolume

Members

Member | Value | Description
Default | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerCapsFlags Enumeration (Microsoft.DirectX.DirectPlay.Voice)

PlayerCapsFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player capability flags. Deprecated.

Definition

Visual Basic | Public Enum PlayerCapsFlags
C# | public enum PlayerCapsFlags
C++ | public enum class PlayerCapsFlags
JScript | public enum PlayerCapsFlags

Members

Member | Value | Description
Local | 2
HalfDuplex | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerId Enumeration (Microsoft.DirectX.DirectPlay.Voice)

PlayerId Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
System wide player id's. Deprecated.

Definition

Visual Basic | Public Enum PlayerId
C# | public enum PlayerId
C++ | public enum class PlayerId
JScript | public enum PlayerId

Members

Member | Value | Description
System | 0
Remaining | -1
AllPlayers | 0
ServerPlayer | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RecordVolume Enumeration (Microsoft.DirectX.DirectPlay.Voice)

RecordVolume Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for RecordVolume. Deprecated.

Definition

Visual Basic | Public Enum RecordVolume
C# | public enum RecordVolume
C++ | public enum class RecordVolume
JScript | public enum RecordVolume

Members

Member | Value | Description
Last | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ResultCode Enumeration (Microsoft.DirectX.DirectPlay.Voice)

ResultCode Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various codes that can be returned by events. Deprecated.

Definition

Visual Basic | Public Enum ResultCode
C# | public enum ResultCode
C++ | public enum class ResultCode
JScript | public enum ResultCode

Members

Member | Value | Description
Connected | -2146107030
FullDuplex | 1376261
LockedBuffer | -2146106992
InvalidBuffer | -2146106993
NoRecVolAvailable | -2146106994
UserBack | -2146106995
TransportNoPlayer | -2146106996
TransportNoSession | -2146106997
TransportNotInit | -2146106998
NoCallback | -2146106999
NoTransport | -2146107000
InvalidPointer | -2147467261
Initialized | -2146107001
IncompatibleVersion | -2146107004
RunSetup | -2146107005
UserCancel | -2146107008
SendError | -2146107009
PlaybackSystemError | -2146107010
RecordSystemError | -2146107011
InvalidDevice | -2146107012
NotHosting | -2146107013
Hosting | -2146107014
NotBuffered | -2146107015
AlreadyBuffered | -2146107016
No3DSound | -2146107017
ConnectAborted | -2146107018
TimeOut | -2146107019
SoundInitFailure | -2146107020
AlreadyPending | -2146107021
CompressionNotSupported | -2146107022
TransportNotHost | -2146107023
InvalidTarget | -2146107024
NotAllowed | -2146107025
ConnectAborting | -2146107026
NotConnected | -2146107029
ConnectionLost | -2146107032
NoVoiceSession | -2146107090
SessionLost | -2146107092
NotSupported | -2147467263
HalfDuplex | 1376266

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionFlags Enumeration (Microsoft.DirectX.DirectPlay.Voice)

SessionFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for controlling sessions. Deprecated.

Definition

Visual Basic | Public Enum SessionFlags
C# | public enum SessionFlags
C++ | public enum class SessionFlags
JScript | public enum SessionFlags

Members

Member | Value | Description
ServerControlTarget | 2
NoHostMigration | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionType Enumeration (Microsoft.DirectX.DirectPlay.Voice)

SessionType Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The type of DirectPlay Voice session to run. Deprecated.

Definition

Visual Basic | Public Enum SessionType
C# | public enum SessionType
C++ | public enum class SessionType
JScript | public enum SessionType

Members

Member | Value | Description
Peer | 1
Echo | 4
Fowarding | 3
Mixing | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SoundConfigFlags Enumeration (Microsoft.DirectX.DirectPlay.Voice)

SoundConfigFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags to control how the sound device is configured. Deprecated.

Definition

Visual Basic | Public Enum SoundConfigFlags
C# | public enum SoundConfigFlags
C++ | public enum class SoundConfigFlags
JScript | public enum SoundConfigFlags

Members

Member | Value | Description
StrictFocus | 1073741824
NoFocus | 536870912
NoRecordVolumeAvailable | 16
SetConversionQuality | 8
HalfDuplex | 4
AutoSelect | 2
NormalMode | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


StopSessionFlags Enumeration (Microsoft.DirectX.DirectPlay.Voice)

StopSessionFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flags for stopping a session. Deprecated.

Definition

Visual Basic | Public Enum StopSessionFlags
C# | public enum StopSessionFlags
C++ | public enum class StopSessionFlags
JScript | public enum StopSessionFlags

Members

Member | Value | Description
NoHostMigrate | 8

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TestFlags Enumeration (Microsoft.DirectX.DirectPlay.Voice)

TestFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Determines whether the user can press the Back button and whether the setup should be queried. Deprecated.

Definition

Visual Basic | Public Enum TestFlags
C# | public enum TestFlags
C++ | public enum class TestFlags
JScript | public enum TestFlags

Members

Member | Value | Description
AllowBack | 16
QueryOnly | 2

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Threshold Enumeration (Microsoft.DirectX.DirectPlay.Voice)

Threshold Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default values for Threshold. Deprecated.

Definition

Visual Basic | Public Enum Threshold
C# | public enum Threshold
C++ | public enum class Threshold
JScript | public enum Threshold

Members

Member | Value | Description
Unused | -2
Default | -1
Max | 99
Min | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VoiceFlags Enumeration (Microsoft.DirectX.DirectPlay.Voice)

VoiceFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Various flags for DirectPlay Voice. Deprecated.

Definition

Visual Basic | Public Enum VoiceFlags
C# | public enum VoiceFlags
C++ | public enum class VoiceFlags
JScript | public enum VoiceFlags

Members

Member | Value | Description
Sync | 1 | The method does not return until the operation is completed.

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClientConfig Structure (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Controls the run-time parameters for the client. Deprecated.

Definition

Visual Basic | Public Structure ClientConfig
C# | public struct ClientConfig
C++ | public value class ClientConfig sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ClientConfig
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
BufferAggressiveness
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer aggressiveness setting for the adaptive buffer algorithm. For most applications, this can be set to DVBUFFERAGGRESSIVENESS_DEFAULT. It can also be set to anything in the range of DVBUFFERAGGRESSIVENESS_MIN and DVBUFFERAGGRESSIVENESS_MAX. In general, the higher the value, the quicker the adaptive buffering adjusts to changing conditions. The lower the value, the slower the adaptive buffering adjusts to changing conditions. Deprecated.
BufferQuality
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer quality setting for the adaptive buffering algorithm. For most applications, this should be set to DVBUFFERQUALITY_DEFAULT. It can be set to anything in the range of DVBUFFERQUALITY_MIN to DVBUFFERQUALITY_MAX. In general, the higher the value, the higher the quality of the voice but the higher the latency. The lower the value, the lower the latency but the lower the quality. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Client configuration flags. Deprecated.
NotifyPeriod
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Value indicating how often you want to receive DVMSGID_OUTPUTLEVEL and DVMSGID_INPUTLEVEL (if session is full duplex) messages. If this value is set to 0, these messages are disabled. The value specifies the number of milliseconds between these messages. DVNOTIFYPERIOD_MINPERIOD specifies the minimum period between messages that is allowed. Deprecated.
PlaybackVolume
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Value indicating what the playback volume should be set to. Adjusting this volume adjusts both the main buffer and all 3-D sound buffers. See the IDirectSoundBuffer8.SetVolume method for valid values. You can specify DVPLAYBACKVOLUME_DEFAULT to use a default value that is appropriate for most situations (full volume). Deprecated.
RecordVolume
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
LONG value that specifies what the volume of the recording should be set to. See the IDirectSoundBuffer8.SetVolume method for valid values.If automatic gain control is enabled, this value can be set to DVRECORDVOLUME_LAST, which tells the system to use the current volume as determined by the automatic gain control algorithm. If a value other than DVRECORDVOLUME_LAST is specified in combination with automatic gain control, this value will be used to restart the algorithm at the specified value.On return from a call to PlayvoiceclientGetclientconfigDplay, this value will contain the current recording volume. When adjusting the recording volume, Microsoft® DirectPlay® Voice will adjust the volume for the microphone (if a microphone volume is present for the card) and the master recording volume (if one is present on the card). If neither a microphone volume nor a master record volume is present, Microsoft® DirectPlay® Voice will be unable to adjust the recording volume. Deprecated.
Threshold
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Input level used to trigger voice transmission if the DVCLIENTCONFIG_MANUALVOICEACTIVATED flag is specified in the dwFlags member. When the flag is specified, this value can be set to anywhere in the range of DVTHRESHOLD_MIN to DVTHRESHOLD_MAX. Additionally, DVTHRESHOLD_DEFAULT can be set to use a default value. If DVCLIENTCONFIG_MANUALVOICEACTIVATED or DVCLIENTCONFIG_AUTOVOICEACTIVATED is not specified in the dwFlags member. When the flag is specified, this value can be set to anywhere in the range member of this structure (indicating push-to-talk mode) this value must be set to DVTHRESHOLD_UNUSED. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClientConfig.ClientConfig() Constructor (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.ClientConfig Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ClientConfig();
C++ public:
ClientConfig();
JScript | public function ClientConfig();


ClientConfig.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ClientConfig.BufferAggressiveness Property (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.BufferAggressiveness Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer aggressiveness setting for the adaptive buffer algorithm. For most applications, this can be set to DVBUFFERAGGRESSIVENESS_DEFAULT. It can also be set to anything in the range of DVBUFFERAGGRESSIVENESS_MIN and DVBUFFERAGGRESSIVENESS_MAX. In general, the higher the value, the quicker the adaptive buffering adjusts to changing conditions. The lower the value, the slower the adaptive buffering adjusts to changing conditions. Deprecated.

Definition

Visual Basic | Public Property BufferAggressiveness As BufferAggressiveness
C# | public BufferAggressiveness BufferAggressiveness { get; set; }
C++ public:
property BufferAggressiveness BufferAggressiveness {
BufferAggressiveness get();
void set(BufferAggressiveness value);
}
JScript public function get BufferAggressiveness() : BufferAggressiveness
public function set BufferAggressiveness(BufferAggressiveness);

Property Value

Microsoft.DirectX.DirectPlay.Voice.BufferAggressiveness

This property is read/write.


ClientConfig.BufferQuality Property (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.BufferQuality Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer quality setting for the adaptive buffering algorithm. For most applications, this should be set to DVBUFFERQUALITY_DEFAULT. It can be set to anything in the range of DVBUFFERQUALITY_MIN to DVBUFFERQUALITY_MAX. In general, the higher the value, the higher the quality of the voice but the higher the latency. The lower the value, the lower the latency but the lower the quality. Deprecated.

Definition

Visual Basic | Public Property BufferQuality As BufferQuality
C# | public BufferQuality BufferQuality { get; set; }
C++ public:
property BufferQuality BufferQuality {
BufferQuality get();
void set(BufferQuality value);
}
JScript public function get BufferQuality() : BufferQuality
public function set BufferQuality(BufferQuality);

Property Value

Microsoft.DirectX.DirectPlay.Voice.BufferQuality

This property is read/write.


ClientConfig.Flags Property (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Client configuration flags. Deprecated.

Definition

Visual Basic | Public Property Flags As ClientConfigFlags
C# | public ClientConfigFlags Flags { get; set; }
C++ public:
property ClientConfigFlags Flags {
ClientConfigFlags get();
void set(ClientConfigFlags value);
}
JScript public function get Flags() : ClientConfigFlags
public function set Flags(ClientConfigFlags);

Property Value

Microsoft.DirectX.DirectPlay.Voice.ClientConfigFlags

This property is read/write.


ClientConfig.NotifyPeriod Property (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.NotifyPeriod Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Value indicating how often you want to receive DVMSGID_OUTPUTLEVEL and DVMSGID_INPUTLEVEL (if session is full duplex) messages. If this value is set to 0, these messages are disabled. The value specifies the number of milliseconds between these messages. DVNOTIFYPERIOD_MINPERIOD specifies the minimum period between messages that is allowed. Deprecated.

Definition

Visual Basic | Public Property NotifyPeriod As Integer
C# | public int NotifyPeriod { get; set; }
C++ public:
property int NotifyPeriod {
int get();
void set(int value);
}
JScript public function get NotifyPeriod() : int
public function set NotifyPeriod(int);

Property Value

System.Int32

This property is read/write.


ClientConfig.PlaybackVolume Property (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.PlaybackVolume Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Value indicating what the playback volume should be set to. Adjusting this volume adjusts both the main buffer and all 3-D sound buffers. See the IDirectSoundBuffer8.SetVolume method for valid values. You can specify DVPLAYBACKVOLUME_DEFAULT to use a default value that is appropriate for most situations (full volume). Deprecated.

Definition

Visual Basic | Public Property PlaybackVolume As Integer
C# | public int PlaybackVolume { get; set; }
C++ public:
property int PlaybackVolume {
int get();
void set(int value);
}
JScript public function get PlaybackVolume() : int
public function set PlaybackVolume(int);

Property Value

System.Int32

This property is read/write.


ClientConfig.RecordVolume Property (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.RecordVolume Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
LONG value that specifies what the volume of the recording should be set to. See the IDirectSoundBuffer8.SetVolume method for valid values.If automatic gain control is enabled, this value can be set to DVRECORDVOLUME_LAST, which tells the system to use the current volume as determined by the automatic gain control algorithm. If a value other than DVRECORDVOLUME_LAST is specified in combination with automatic gain control, this value will be used to restart the algorithm at the specified value.On return from a call to PlayvoiceclientGetclientconfigDplay, this value will contain the current recording volume. When adjusting the recording volume, Microsoft® DirectPlay® Voice will adjust the volume for the microphone (if a microphone volume is present for the card) and the master recording volume (if one is present on the card). If neither a microphone volume nor a master record volume is present, Microsoft® DirectPlay® Voice will be unable to adjust the recording volume. Deprecated.

Definition

Visual Basic | Public Property RecordVolume As Integer
C# | public int RecordVolume { get; set; }
C++ public:
property int RecordVolume {
int get();
void set(int value);
}
JScript public function get RecordVolume() : int
public function set RecordVolume(int);

Property Value

System.Int32

This property is read/write.


ClientConfig.Threshold Property (Microsoft.DirectX.DirectPlay.Voice)

ClientConfig.Threshold Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Input level used to trigger voice transmission if the DVCLIENTCONFIG_MANUALVOICEACTIVATED flag is specified in the dwFlags member. When the flag is specified, this value can be set to anywhere in the range of DVTHRESHOLD_MIN to DVTHRESHOLD_MAX. Additionally, DVTHRESHOLD_DEFAULT can be set to use a default value. If DVCLIENTCONFIG_MANUALVOICEACTIVATED or DVCLIENTCONFIG_AUTOVOICEACTIVATED is not specified in the dwFlags member. When the flag is specified, this value can be set to anywhere in the range member of this structure (indicating push-to-talk mode) this value must be set to DVTHRESHOLD_UNUSED. Deprecated.

Definition

Visual Basic | Public Property Threshold As Threshold
C# | public Threshold Threshold { get; set; }
C++ public:
property Threshold Threshold {
Threshold get();
void set(Threshold value);
}
JScript public function get Threshold() : Threshold
public function set Threshold(Threshold);

Property Value

Microsoft.DirectX.DirectPlay.Voice.Threshold

This property is read/write.


CompressionInformation Structure (Microsoft.DirectX.DirectPlay.Voice)

CompressionInformation Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the attributes of a specific Microsoft® DirectPlay® Voice compression type. Deprecated.

Definition

Visual Basic | Public Structure CompressionInformation
C# | public struct CompressionInformation
C++ | public value class CompressionInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CompressionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Description
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a longer name of the codec. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved; must be 0. Deprecated.
GuidType
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID used to identify this compression type by Microsoft® DirectPlay® Voice. Deprecated.
MaxBitsPerSecond
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of bits per second claimed by the codec. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a name describing the codec. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CompressionInformation.CompressionInformation() Constructor (Microsoft.DirectX.DirectPlay.Voice)

CompressionInformation.CompressionInformation Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CompressionInformation();
C++ public:
CompressionInformation();
JScript | public function CompressionInformation();


CompressionInformation.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

CompressionInformation.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CompressionInformation.Description Property (Microsoft.DirectX.DirectPlay.Voice)

CompressionInformation.Description Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a longer name of the codec. Deprecated.

Definition

Visual Basic | Public Property Description As String
C# | public string Description { get; set; }
C++ public:
property String^ Description {
String^ get();
void set(String^ value);
}
JScript public function get Description() : String
public function set Description(String);

Property Value

System.String

This property is read/write.


CompressionInformation.Flags Property (Microsoft.DirectX.DirectPlay.Voice)

CompressionInformation.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved; must be 0. Deprecated.

Definition

Visual Basic | Public Property Flags As Integer
C# | public int Flags { get; set; }
C++ public:
property int Flags {
int get();
void set(int value);
}
JScript public function get Flags() : int
public function set Flags(int);

Property Value

System.Int32

This property is read/write.


CompressionInformation.GuidType Property (Microsoft.DirectX.DirectPlay.Voice)

CompressionInformation.GuidType Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID used to identify this compression type by Microsoft® DirectPlay® Voice. Deprecated.

Definition

Visual Basic | Public Property GuidType As Guid
C# | public Guid GuidType { get; set; }
C++ public:
property Guid GuidType {
Guid get();
void set(Guid value);
}
JScript public function get GuidType() : Guid
public function set GuidType(Guid);

Property Value

System.Guid

This property is read/write.


CompressionInformation.MaxBitsPerSecond Property (Microsoft.DirectX.DirectPlay.Voice)

CompressionInformation.MaxBitsPerSecond Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of bits per second claimed by the codec. Deprecated.

Definition

Visual Basic | Public Property MaxBitsPerSecond As Integer
C# | public int MaxBitsPerSecond { get; set; }
C++ public:
property int MaxBitsPerSecond {
int get();
void set(int value);
}
JScript public function get MaxBitsPerSecond() : int
public function set MaxBitsPerSecond(int);

Property Value

System.Int32

This property is read/write.


CompressionInformation.Name Property (Microsoft.DirectX.DirectPlay.Voice)

CompressionInformation.Name Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a name describing the codec. Deprecated.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String

This property is read/write.


ConnectResultMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

ConnectResultMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidConnectresultDplay message when the connect request generated through a call to the PlayvoiceclientConnectDplay method has completed.The structure contains information for the DvmsgidConnectresultDplay message. Deprecated.

Definition

Visual Basic | Public Structure ConnectResultMessage
C# | public struct ConnectResultMessage
C++ | public value class ConnectResultMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ConnectResultMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Result
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT that specifies the outcome of the connection attempt. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectResultMessage.ConnectResultMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

ConnectResultMessage.ConnectResultMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectResultMessage();
C++ public:
ConnectResultMessage();
JScript | public function ConnectResultMessage();


ConnectResultMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

ConnectResultMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConnectResultMessage.Result Property (Microsoft.DirectX.DirectPlay.Voice)

ConnectResultMessage.Result Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT that specifies the outcome of the connection attempt. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Result As ResultCode
C# | public ResultCode Result { get; }
C++ public:
property ResultCode Result {
ResultCode get();
}
JScript | public function get Result() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.Voice.ResultCode

This property is read-only.


CreateVoicePlayerMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

CreateVoicePlayerMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidCreatevoiceplayerDplay message when a new player joins the voice session.The structure contains information for the DvmsgidCreatevoiceplayerDplay message. Deprecated.

Definition

Visual Basic | Public Structure CreateVoicePlayerMessage
C# | public struct CreateVoicePlayerMessage
C++ | public value class CreateVoicePlayerMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CreateVoicePlayerMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag specifying information about the player: Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value for the player in the voice session. This value is set through this parameter when this message is received. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player who connected. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CreateVoicePlayerMessage.CreateVoicePlayerMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

CreateVoicePlayerMessage.CreateVoicePlayerMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CreateVoicePlayerMessage();
C++ public:
CreateVoicePlayerMessage();
JScript | public function CreateVoicePlayerMessage();


CreateVoicePlayerMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

CreateVoicePlayerMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CreateVoicePlayerMessage.Flags Property (Microsoft.DirectX.DirectPlay.Voice)

CreateVoicePlayerMessage.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag specifying information about the player: Deprecated.

Definition

Visual Basic | Public ReadOnly Property Flags As PlayerCapsFlags
C# | public PlayerCapsFlags Flags { get; }
C++ public:
property PlayerCapsFlags Flags {
PlayerCapsFlags get();
}
JScript | public function get Flags() : PlayerCapsFlags

Property Value

Microsoft.DirectX.DirectPlay.Voice.PlayerCapsFlags

This property is read-only.


CreateVoicePlayerMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

CreateVoicePlayerMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value for the player in the voice session. This value is set through this parameter when this message is received. Deprecated.

Definition

Visual Basic | Public Property PlayerContext As Object
C# | public object PlayerContext { get; set; }
C++ public:
property Object^ PlayerContext {
Object^ get();
void set(Object^ value);
}
JScript public function get PlayerContext() : Object
public function set PlayerContext(Object);

Property Value

System.Object

This property is read/write.


CreateVoicePlayerMessage.PlayerID Property (Microsoft.DirectX.DirectPlay.Voice)

CreateVoicePlayerMessage.PlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player who connected. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
C++ public:
property int PlayerID {
int get();
}
JScript | public function get PlayerID() : int

Property Value

System.Int32

This property is read-only.


DeleteVoicePlayerMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

DeleteVoicePlayerMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
For clients, Microsoft® DirectPlay® Voice generates the DvmsgidDeletevoiceplayerDplay message when a player quits the voice session. This message is available only to clients in peer-to-peer voice sessions.For the host, Microsoft® DirectPlay® Voice generates the message when a player quits the voice session.The structure contains information for the DvmsgidDeletevoiceplayerDplay system message. Deprecated.

Definition

Visual Basic | Public Structure DeleteVoicePlayerMessage
C# | public struct DeleteVoicePlayerMessage
C++ | public value class DeleteVoicePlayerMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DeleteVoicePlayerMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay structure. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of player who disconnected. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DeleteVoicePlayerMessage.DeleteVoicePlayerMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

DeleteVoicePlayerMessage.DeleteVoicePlayerMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DeleteVoicePlayerMessage();
C++ public:
DeleteVoicePlayerMessage();
JScript | public function DeleteVoicePlayerMessage();


DeleteVoicePlayerMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

DeleteVoicePlayerMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeleteVoicePlayerMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

DeleteVoicePlayerMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


DeleteVoicePlayerMessage.PlayerID Property (Microsoft.DirectX.DirectPlay.Voice)

DeleteVoicePlayerMessage.PlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of player who disconnected. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
C++ public:
property int PlayerID {
int get();
}
JScript | public function get PlayerID() : int

Property Value

System.Int32

This property is read-only.


DisconnectResultMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

DisconnectResultMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.

Definition

Visual Basic | Public Structure DisconnectResultMessage
C# | public struct DisconnectResultMessage
C++ | public value class DisconnectResultMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DisconnectResultMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Result
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result of the disconnect request. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisconnectResultMessage.DisconnectResultMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

DisconnectResultMessage.DisconnectResultMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DisconnectResultMessage();
C++ public:
DisconnectResultMessage();
JScript | public function DisconnectResultMessage();


DisconnectResultMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

DisconnectResultMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DisconnectResultMessage.Result Property (Microsoft.DirectX.DirectPlay.Voice)

DisconnectResultMessage.Result Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result of the disconnect request. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Result As ResultCode
C# | public ResultCode Result { get; }
C++ public:
property ResultCode Result {
ResultCode get();
}
JScript | public function get Result() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.Voice.ResultCode

This property is read-only.


HostMigratedMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

HostMigratedMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.

Definition

Visual Basic | Public Structure HostMigratedMessage
C# | public struct HostMigratedMessage
C++ | public value class HostMigratedMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
HostMigratedMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
NewHostID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the new host. Deprecated.
ServerObject
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If the local client has become the new voice session host, this member will point to a newly created PlayvoiceserverDplay object that can be used by the local client for providing host services. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HostMigratedMessage.HostMigratedMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

HostMigratedMessage.HostMigratedMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public HostMigratedMessage();
C++ public:
HostMigratedMessage();
JScript | public function HostMigratedMessage();


HostMigratedMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

HostMigratedMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


HostMigratedMessage.NewHostID Property (Microsoft.DirectX.DirectPlay.Voice)

HostMigratedMessage.NewHostID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the new host. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NewHostID As Integer
C# | public int NewHostID { get; }
C++ public:
property int NewHostID {
int get();
}
JScript | public function get NewHostID() : int

Property Value

System.Int32

This property is read-only.


HostMigratedMessage.ServerObject Property (Microsoft.DirectX.DirectPlay.Voice)

HostMigratedMessage.ServerObject Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
If the local client has become the new voice session host, this member will point to a newly created PlayvoiceserverDplay object that can be used by the local client for providing host services. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ServerObject As Server
C# | public Server ServerObject { get; }
C++ public:
property Server^ ServerObject {
Server^ get();
}
JScript | public function get ServerObject() : Server

Property Value

Microsoft.DirectX.DirectPlay.Voice.Server

This property is read-only.


InputLevelMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

InputLevelMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidInputlevelDplay message periodically to notify the user of the input level from the microphone.The structure contains information for the DvmsgidInputlevelDplay system message. Deprecated.

Definition

Visual Basic | Public Structure InputLevelMessage
C# | public struct InputLevelMessage
C++ | public value class InputLevelMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
InputLevelMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
LocalPlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the local player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay structure. Deprecated.
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer value representing peak level across the current frame, which corresponds to approximately 1/10 second of audio stream. The current frame typically lags 50-200 ms behind real-time. This value can range from 0 through 99, with 0 being completely silent and 99 being the highest possible input level. Deprecated.
RecordVolume
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current recording volume for the client. The value can range from -10,000 to 0. This member is available even when automatic gain control is active. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputLevelMessage.InputLevelMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

InputLevelMessage.InputLevelMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InputLevelMessage();
C++ public:
InputLevelMessage();
JScript | public function InputLevelMessage();


InputLevelMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

InputLevelMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


InputLevelMessage.LocalPlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

InputLevelMessage.LocalPlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the local player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property LocalPlayerContext As Object
C# | public object LocalPlayerContext { get; }
C++ public:
property Object^ LocalPlayerContext {
Object^ get();
}
JScript | public function get LocalPlayerContext() : Object

Property Value

System.Object

This property is read-only.


InputLevelMessage.PeakLevel Property (Microsoft.DirectX.DirectPlay.Voice)

InputLevelMessage.PeakLevel Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer value representing peak level across the current frame, which corresponds to approximately 1/10 second of audio stream. The current frame typically lags 50-200 ms behind real-time. This value can range from 0 through 99, with 0 being completely silent and 99 being the highest possible input level. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
C++ public:
property int PeakLevel {
int get();
}
JScript | public function get PeakLevel() : int

Property Value

System.Int32

This property is read-only.


InputLevelMessage.RecordVolume Property (Microsoft.DirectX.DirectPlay.Voice)

InputLevelMessage.RecordVolume Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current recording volume for the client. The value can range from -10,000 to 0. This member is available even when automatic gain control is active. Deprecated.

Definition

Visual Basic | Public ReadOnly Property RecordVolume As Integer
C# | public int RecordVolume { get; }
C++ public:
property int RecordVolume {
int get();
}
JScript | public function get RecordVolume() : int

Property Value

System.Int32

This property is read-only.


OutputLevelMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidOutputlevelDplay message periodically to notify the user of the output level of playback.The structure contains information for the DvmsgidOutputlevelDplay system message. Deprecated.

Definition

Visual Basic | Public Structure OutputLevelMessage
C# | public struct OutputLevelMessage
C++ | public value class OutputLevelMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
OutputLevelMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
LocalPlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the local player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
OutputVolume
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current playback volume for the client. Deprecated.
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer representing the current output level of playback. This value must be in the range from 0 through 99. 0 indicates complete silence and 99 indicates the highest possible output level. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OutputLevelMessage.OutputLevelMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelMessage.OutputLevelMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public OutputLevelMessage();
C++ public:
OutputLevelMessage();
JScript | public function OutputLevelMessage();


OutputLevelMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


OutputLevelMessage.LocalPlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelMessage.LocalPlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the local player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property LocalPlayerContext As Object
C# | public object LocalPlayerContext { get; }
C++ public:
property Object^ LocalPlayerContext {
Object^ get();
}
JScript | public function get LocalPlayerContext() : Object

Property Value

System.Object

This property is read-only.


OutputLevelMessage.OutputVolume Property (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelMessage.OutputVolume Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current playback volume for the client. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OutputVolume As Integer
C# | public int OutputVolume { get; }
C++ public:
property int OutputVolume {
int get();
}
JScript | public function get OutputVolume() : int

Property Value

System.Int32

This property is read-only.


OutputLevelMessage.PeakLevel Property (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelMessage.PeakLevel Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer representing the current output level of playback. This value must be in the range from 0 through 99. 0 indicates complete silence and 99 indicates the highest possible output level. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
C++ public:
property int PeakLevel {
int get();
}
JScript | public function get PeakLevel() : int

Property Value

System.Int32

This property is read-only.


PlayerOutputLevelMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.

Definition

Visual Basic | Public Structure PlayerOutputLevelMessage
C# | public struct PlayerOutputLevelMessage
C++ | public value class PlayerOutputLevelMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PlayerOutputLevelMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer representing the current output level of the player's voice stream. This value must be in the range from 0 through 99, with 0 being completely silent and 99 being the highest possible output level. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
SourcePlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player whose voice is being played back. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerOutputLevelMessage.PlayerOutputLevelMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelMessage.PlayerOutputLevelMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlayerOutputLevelMessage();
C++ public:
PlayerOutputLevelMessage();
JScript | public function PlayerOutputLevelMessage();


PlayerOutputLevelMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PlayerOutputLevelMessage.PeakLevel Property (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelMessage.PeakLevel Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Integer representing the current output level of the player's voice stream. This value must be in the range from 0 through 99, with 0 being completely silent and 99 being the highest possible output level. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
C++ public:
property int PeakLevel {
int get();
}
JScript | public function get PeakLevel() : int

Property Value

System.Int32

This property is read-only.


PlayerOutputLevelMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


PlayerOutputLevelMessage.SourcePlayerID Property (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelMessage.SourcePlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player whose voice is being played back. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourcePlayerID As Integer
C# | public int SourcePlayerID { get; }
C++ public:
property int SourcePlayerID {
int get();
}
JScript | public function get SourcePlayerID() : int

Property Value

System.Int32

This property is read-only.


PlayerVoiceStartMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStartMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayervoicestartDplay message when an incoming audio stream begins playing back.The structure contains information for the DvmsgidPlayervoicestartDplay system message. Deprecated.

Definition

Visual Basic | Public Structure PlayerVoiceStartMessage
C# | public struct PlayerVoiceStartMessage
C++ | public value class PlayerVoiceStartMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PlayerVoiceStartMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
SourcePlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player where the voice transmission originated. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerVoiceStartMessage.PlayerVoiceStartMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStartMessage.PlayerVoiceStartMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlayerVoiceStartMessage();
C++ public:
PlayerVoiceStartMessage();
JScript | public function PlayerVoiceStartMessage();


PlayerVoiceStartMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStartMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PlayerVoiceStartMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStartMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


PlayerVoiceStartMessage.SourcePlayerID Property (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStartMessage.SourcePlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player where the voice transmission originated. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourcePlayerID As Integer
C# | public int SourcePlayerID { get; }
C++ public:
property int SourcePlayerID {
int get();
}
JScript | public function get SourcePlayerID() : int

Property Value

System.Int32

This property is read-only.


PlayerVoiceStopMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStopMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayervoicestopDplay message when an incoming audio stream stops.The DvmsgidPlayervoicestopDplay structure contains information for the DvmsgidPlayervoicestopDplay system message. Deprecated.

Definition

Visual Basic | Public Structure PlayerVoiceStopMessage
C# | public struct PlayerVoiceStopMessage
C++ | public value class PlayerVoiceStopMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PlayerVoiceStopMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
SourcePlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player where the voice transmission originated. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerVoiceStopMessage.PlayerVoiceStopMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStopMessage.PlayerVoiceStopMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlayerVoiceStopMessage();
C++ public:
PlayerVoiceStopMessage();
JScript | public function PlayerVoiceStopMessage();


PlayerVoiceStopMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStopMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PlayerVoiceStopMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStopMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


PlayerVoiceStopMessage.SourcePlayerID Property (Microsoft.DirectX.DirectPlay.Voice)

PlayerVoiceStopMessage.SourcePlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the player where the voice transmission originated. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SourcePlayerID As Integer
C# | public int SourcePlayerID { get; }
C++ public:
property int SourcePlayerID {
int get();
}
JScript | public function get SourcePlayerID() : int

Property Value

System.Int32

This property is read-only.


RecordStartMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

RecordStartMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidRecordstartDplay message when audio input on the local client begins.The structure contains information for the DvmsgidRecordstartDplay system message. Deprecated.

Definition

Visual Basic | Public Structure RecordStartMessage
C# | public struct RecordStartMessage
C++ | public value class RecordStartMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
RecordStartMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
LocalPlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Voice activation level that caused the transmission to begin. In push-to-talk mode, this value is 0. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RecordStartMessage.RecordStartMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

RecordStartMessage.RecordStartMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public RecordStartMessage();
C++ public:
RecordStartMessage();
JScript | public function RecordStartMessage();


RecordStartMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

RecordStartMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RecordStartMessage.LocalPlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

RecordStartMessage.LocalPlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property LocalPlayerContext As Object
C# | public object LocalPlayerContext { get; }
C++ public:
property Object^ LocalPlayerContext {
Object^ get();
}
JScript | public function get LocalPlayerContext() : Object

Property Value

System.Object

This property is read-only.


RecordStartMessage.PeakLevel Property (Microsoft.DirectX.DirectPlay.Voice)

RecordStartMessage.PeakLevel Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Voice activation level that caused the transmission to begin. In push-to-talk mode, this value is 0. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
C++ public:
property int PeakLevel {
int get();
}
JScript | public function get PeakLevel() : int

Property Value

System.Int32

This property is read-only.


RecordStopMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

RecordStopMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidRecordstopDplay message when audio input on the local client stops.The structure contains information for the DvmsgidRecordstopDplay system message. Deprecated.

Definition

Visual Basic | Public Structure RecordStopMessage
C# | public struct RecordStopMessage
C++ | public value class RecordStopMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
RecordStopMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
LocalPlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.
PeakLevel
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Voice activation level that caused the transmission to stop. In push-to-talk mode, this value is 0. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RecordStopMessage.RecordStopMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

RecordStopMessage.RecordStopMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public RecordStopMessage();
C++ public:
RecordStopMessage();
JScript | public function RecordStopMessage();


RecordStopMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

RecordStopMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RecordStopMessage.LocalPlayerContext Property (Microsoft.DirectX.DirectPlay.Voice)

RecordStopMessage.LocalPlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the context value set for the player. This value is set through the pvPlayerContext member of the DvmsgidCreatevoiceplayerDplay message structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property LocalPlayerContext As Object
C# | public object LocalPlayerContext { get; }
C++ public:
property Object^ LocalPlayerContext {
Object^ get();
}
JScript | public function get LocalPlayerContext() : Object

Property Value

System.Object

This property is read-only.


RecordStopMessage.PeakLevel Property (Microsoft.DirectX.DirectPlay.Voice)

RecordStopMessage.PeakLevel Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Voice activation level that caused the transmission to stop. In push-to-talk mode, this value is 0. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PeakLevel As Integer
C# | public int PeakLevel { get; }
C++ public:
property int PeakLevel {
int get();
}
JScript | public function get PeakLevel() : int

Property Value

System.Int32

This property is read-only.


SessionDescription Structure (Microsoft.DirectX.DirectPlay.Voice)

SessionDescription Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the desired or current session settings for the Microsoft® DirectPlay® Voice server. This structure is used by the voice session host to configure the session, and by the session host and clients to retrieve information about the current session. Deprecated.

Definition

Visual Basic | Public Structure SessionDescription
C# | public struct SessionDescription
C++ | public value class SessionDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SessionDescription
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
BufferAggressiveness
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer aggressiveness setting. This member is unused for all session types except mixing sessions. For all sessions except mixing sessions, set this member to DVBUFFERAGGRESSIVENESS_DEFAULT. Allowable values are between DVBUFFERAGGRESSIVENESS _MIN and DVBUFFERAGGRESSIVENESS _MAX. Additionally, this member can be set to the following value. Deprecated.
BufferQuality
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The buffer quality setting. This member is unused for all session types except mixing sessions. For all sessions except mixing sessions, set this member to DVBUFFERQUALITY_DEFAULT. Allowable values are between DVBUFFERQUALITY_MIN and DVBUFFERQUALITY_MAX. Additionally, this member can be set to the following value. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Combination of the following flags. Deprecated.
GuidCompressionType
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID specifying the compression type of the session. To select the default compression codec, set this member to DPVCTGUID_DEFAULT. Deprecated.
SessionType
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The type of Microsoft® DirectPlay® Voice session to run. The DVSESSIONTYPE_PEER flag is not available in client/server sessions; all other flags are valid for all session types. This member can be one of the following values. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionDescription.SessionDescription() Constructor (Microsoft.DirectX.DirectPlay.Voice)

SessionDescription.SessionDescription Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SessionDescription();
C++ public:
SessionDescription();
JScript | public function SessionDescription();


SessionDescription.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

SessionDescription.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


SessionDescription.BufferAggressiveness Property (Microsoft.DirectX.DirectPlay.Voice)

SessionDescription.BufferAggressiveness Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Buffer aggressiveness setting. This member is unused for all session types except mixing sessions. For all sessions except mixing sessions, set this member to DVBUFFERAGGRESSIVENESS_DEFAULT. Allowable values are between DVBUFFERAGGRESSIVENESS _MIN and DVBUFFERAGGRESSIVENESS _MAX. Additionally, this member can be set to the following value. Deprecated.

Definition

Visual Basic | Public Property BufferAggressiveness As BufferAggressiveness
C# | public BufferAggressiveness BufferAggressiveness { get; set; }
C++ public:
property BufferAggressiveness BufferAggressiveness {
BufferAggressiveness get();
void set(BufferAggressiveness value);
}
JScript public function get BufferAggressiveness() : BufferAggressiveness
public function set BufferAggressiveness(BufferAggressiveness);

Property Value

Microsoft.DirectX.DirectPlay.Voice.BufferAggressiveness

This property is read/write.


SessionDescription.BufferQuality Property (Microsoft.DirectX.DirectPlay.Voice)

SessionDescription.BufferQuality Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The buffer quality setting. This member is unused for all session types except mixing sessions. For all sessions except mixing sessions, set this member to DVBUFFERQUALITY_DEFAULT. Allowable values are between DVBUFFERQUALITY_MIN and DVBUFFERQUALITY_MAX. Additionally, this member can be set to the following value. Deprecated.

Definition

Visual Basic | Public Property BufferQuality As BufferQuality
C# | public BufferQuality BufferQuality { get; set; }
C++ public:
property BufferQuality BufferQuality {
BufferQuality get();
void set(BufferQuality value);
}
JScript public function get BufferQuality() : BufferQuality
public function set BufferQuality(BufferQuality);

Property Value

Microsoft.DirectX.DirectPlay.Voice.BufferQuality

This property is read/write.


SessionDescription.Flags Property (Microsoft.DirectX.DirectPlay.Voice)

SessionDescription.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Combination of the following flags. Deprecated.

Definition

Visual Basic | Public Property Flags As SessionFlags
C# | public SessionFlags Flags { get; set; }
C++ public:
property SessionFlags Flags {
SessionFlags get();
void set(SessionFlags value);
}
JScript public function get Flags() : SessionFlags
public function set Flags(SessionFlags);

Property Value

Microsoft.DirectX.DirectPlay.Voice.SessionFlags

This property is read/write.


SessionDescription.GuidCompressionType Property (Microsoft.DirectX.DirectPlay.Voice)

SessionDescription.GuidCompressionType Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID specifying the compression type of the session. To select the default compression codec, set this member to DPVCTGUID_DEFAULT. Deprecated.

Definition

Visual Basic | Public Property GuidCompressionType As Guid
C# | public Guid GuidCompressionType { get; set; }
C++ public:
property Guid GuidCompressionType {
Guid get();
void set(Guid value);
}
JScript public function get GuidCompressionType() : Guid
public function set GuidCompressionType(Guid);

Property Value

System.Guid

This property is read/write.


SessionDescription.SessionType Property (Microsoft.DirectX.DirectPlay.Voice)

SessionDescription.SessionType Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The type of Microsoft® DirectPlay® Voice session to run. The DVSESSIONTYPE_PEER flag is not available in client/server sessions; all other flags are valid for all session types. This member can be one of the following values. Deprecated.

Definition

Visual Basic | Public Property SessionType As SessionType
C# | public SessionType SessionType { get; set; }
C++ public:
property SessionType SessionType {
SessionType get();
void set(SessionType value);
}
JScript public function get SessionType() : SessionType
public function set SessionType(SessionType);

Property Value

Microsoft.DirectX.DirectPlay.Voice.SessionType

This property is read/write.


SessionLostMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

SessionLostMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidSessionlostDplay message when the voice session terminates.The structure contains information for the DvmsgidSessionlostDplay system message. Deprecated.

Definition

Visual Basic | Public Structure SessionLostMessage
C# | public struct SessionLostMessage
C++ | public value class SessionLostMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SessionLostMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Result
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT value indicating why the session was terminated. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionLostMessage.SessionLostMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

SessionLostMessage.SessionLostMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SessionLostMessage();
C++ public:
SessionLostMessage();
JScript | public function SessionLostMessage();


SessionLostMessage.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

SessionLostMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


SessionLostMessage.Result Property (Microsoft.DirectX.DirectPlay.Voice)

SessionLostMessage.Result Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT value indicating why the session was terminated. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Result As ResultCode
C# | public ResultCode Result { get; }
C++ public:
property ResultCode Result {
ResultCode get();
}
JScript | public function get Result() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.Voice.ResultCode

This property is read-only.


SetTargetsMessage Structure (Microsoft.DirectX.DirectPlay.Voice)

SetTargetsMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
PdvmessagehandlerDplay is an application-defined callback function used by the PlayvoiceclientDplay and PlayvoiceserverDplay objects to send messages to the user. Deprecated.

Definition

Visual Basic | Public Structure SetTargetsMessage
C# | public struct SetTargetsMessage
C++ | public value class SetTargetsMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Targets
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies which players and/or groups receive audio transmissions from the local client. Deprecated.

Methods

Method Description
SetTargetsMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SetTargetsMessage.SetTargetsMessage() Constructor (Microsoft.DirectX.DirectPlay.Voice)

SetTargetsMessage.SetTargetsMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SetTargetsMessage();
C++ public:
SetTargetsMessage();
JScript | public function SetTargetsMessage();


SetTargetsMessage.Targets Field (Microsoft.DirectX.DirectPlay.Voice)

SetTargetsMessage.Targets Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies which players and/or groups receive audio transmissions from the local client. Deprecated.

Definition

Visual Basic | Public Targets As Int32
C# | public Int32 Targets;
C++ | public: Int32 Targets;
JScript | public var Targets : Int32

Field Value

System.Int32[]

This field is read/write.


SoundDeviceConfig Structure (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to set and retrieve information about the sound device configuration and cannot be changed once a connection has been made. After a connection is made, you can retrieve the current sound device configuration by calling PlayvoiceclientGetsounddeviceconfigDplay. Deprecated.

Definition

Visual Basic | Public Structure SoundDeviceConfig
C# | public struct SoundDeviceConfig
C++ | public value class SoundDeviceConfig sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SoundDeviceConfig
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
CaptureDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When this structure is used in PlayvoiceclientConnectDplay method, this member specifies the GUID of the device used for capture. This must be specified even if the LpdsCaptureDevice member is used. If you used NULL when specifying the device when you created your DirectSoundCapture object, pass DSDEVID_DefaultCapture for this member. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A combination of the following flags. Deprecated.
GuidCaptureDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When this structure is used in PlayvoiceclientConnectDplay method, this member specifies the GUID of the device used for capture. This must be specified even if the LpdsCaptureDevice member is used. If you used NULL when specifying the device when you created your DirectSoundCapture object, pass DSDEVID_DefaultCapture for this member. Deprecated.
GuidPlaybackDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the globally unique identifier (GUID) of the device used for playback. Deprecated.
MainBuffer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an IDirectSoundBuffer8 object, which is used to create the Microsoft® DirectPlay® Voice main buffer. This can be either NULL or a user-created Microsoft DirectSound® buffer. If this member is set to NULL, Microsoft® DirectPlay® Voice will create a buffer for the main voice buffer. If users specify a buffer here, Microsoft® DirectPlay® Voice will use their buffer for the main voice buffer. User-created buffers have the following restrictions. Deprecated.
MainBufferFlags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Passed directly to the dwFlags parameter of the IDirectSoundBuffer8.Play method when Play is called for the main buffer. The DSBPLAY_LOOPING flag is automatically added to this field. See the documentation on IDirectSoundBuffer8.Play for details. This parameter must be 0 if the LpdsMainBuffer member of this structure is NULL. Deprecated.
MainBufferPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Passed directly to the dwPriority parameter of the IDirectSoundBuffer8.Play method when Play is called on the main buffer. See documentation for IDirectSoundBuffer8.Play for more information. This member must be set to 0 if lpdsMainBufferDesc is NULL. Deprecated.
PlaybackDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the playback device. Deprecated.
Window
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Must be set to the window that will be used to determine focus for sound playback. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SoundDeviceConfig.SoundDeviceConfig() Constructor (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.SoundDeviceConfig Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SoundDeviceConfig();
C++ public:
SoundDeviceConfig();
JScript | public function SoundDeviceConfig();


SoundDeviceConfig.ToString() Method (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


SoundDeviceConfig.CaptureDevice Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.CaptureDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When this structure is used in PlayvoiceclientConnectDplay method, this member specifies the GUID of the device used for capture. This must be specified even if the LpdsCaptureDevice member is used. If you used NULL when specifying the device when you created your DirectSoundCapture object, pass DSDEVID_DefaultCapture for this member. Deprecated.

Definition

Visual Basic | Public Property CaptureDevice As Capture
C# | public Capture CaptureDevice { get; set; }
C++ public:
property Capture^ CaptureDevice {
Capture^ get();
void set(Capture^ value);
}
JScript public function get CaptureDevice() : Capture
public function set CaptureDevice(Capture);

Property Value

Microsoft.DirectX.DirectSound.Capture

This property is read/write.


SoundDeviceConfig.Flags Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A combination of the following flags. Deprecated.

Definition

Visual Basic | Public Property Flags As SoundConfigFlags
C# | public SoundConfigFlags Flags { get; set; }
C++ public:
property SoundConfigFlags Flags {
SoundConfigFlags get();
void set(SoundConfigFlags value);
}
JScript public function get Flags() : SoundConfigFlags
public function set Flags(SoundConfigFlags);

Property Value

Microsoft.DirectX.DirectPlay.Voice.SoundConfigFlags

This property is read/write.


SoundDeviceConfig.GuidCaptureDevice Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.GuidCaptureDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
When this structure is used in PlayvoiceclientConnectDplay method, this member specifies the GUID of the device used for capture. This must be specified even if the LpdsCaptureDevice member is used. If you used NULL when specifying the device when you created your DirectSoundCapture object, pass DSDEVID_DefaultCapture for this member. Deprecated.

Definition

Visual Basic | Public Property GuidCaptureDevice As Guid
C# | public Guid GuidCaptureDevice { get; set; }
C++ public:
property Guid GuidCaptureDevice {
Guid get();
void set(Guid value);
}
JScript public function get GuidCaptureDevice() : Guid
public function set GuidCaptureDevice(Guid);

Property Value

System.Guid

This property is read/write.


SoundDeviceConfig.GuidPlaybackDevice Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.GuidPlaybackDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the globally unique identifier (GUID) of the device used for playback. Deprecated.

Definition

Visual Basic | Public Property GuidPlaybackDevice As Guid
C# | public Guid GuidPlaybackDevice { get; set; }
C++ public:
property Guid GuidPlaybackDevice {
Guid get();
void set(Guid value);
}
JScript public function get GuidPlaybackDevice() : Guid
public function set GuidPlaybackDevice(Guid);

Property Value

System.Guid

This property is read/write.


SoundDeviceConfig.MainBuffer Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.MainBuffer Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an IDirectSoundBuffer8 object, which is used to create the Microsoft® DirectPlay® Voice main buffer. This can be either NULL or a user-created Microsoft DirectSound® buffer. If this member is set to NULL, Microsoft® DirectPlay® Voice will create a buffer for the main voice buffer. If users specify a buffer here, Microsoft® DirectPlay® Voice will use their buffer for the main voice buffer. User-created buffers have the following restrictions. Deprecated.

Definition

Visual Basic | Public Property MainBuffer As Buffer
C# | public Buffer MainBuffer { get; set; }
C++ public:
property Buffer^ MainBuffer {
Buffer^ get();
void set(Buffer^ value);
}
JScript public function get MainBuffer() : Buffer
public function set MainBuffer(Buffer);

Property Value

Microsoft.DirectX.DirectSound.Buffer

This property is read/write.


SoundDeviceConfig.MainBufferFlags Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.MainBufferFlags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Passed directly to the dwFlags parameter of the IDirectSoundBuffer8.Play method when Play is called for the main buffer. The DSBPLAY_LOOPING flag is automatically added to this field. See the documentation on IDirectSoundBuffer8.Play for details. This parameter must be 0 if the LpdsMainBuffer member of this structure is NULL. Deprecated.

Definition

Visual Basic | Public Property MainBufferFlags As Integer
C# | public int MainBufferFlags { get; set; }
C++ public:
property int MainBufferFlags {
int get();
void set(int value);
}
JScript public function get MainBufferFlags() : int
public function set MainBufferFlags(int);

Property Value

System.Int32

This property is read/write.


SoundDeviceConfig.MainBufferPriority Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.MainBufferPriority Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Passed directly to the dwPriority parameter of the IDirectSoundBuffer8.Play method when Play is called on the main buffer. See documentation for IDirectSoundBuffer8.Play for more information. This member must be set to 0 if lpdsMainBufferDesc is NULL. Deprecated.

Definition

Visual Basic | Public Property MainBufferPriority As Integer
C# | public int MainBufferPriority { get; set; }
C++ public:
property int MainBufferPriority {
int get();
void set(int value);
}
JScript public function get MainBufferPriority() : int
public function set MainBufferPriority(int);

Property Value

System.Int32

This property is read/write.


SoundDeviceConfig.PlaybackDevice Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.PlaybackDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the playback device. Deprecated.

Definition

Visual Basic | Public Property PlaybackDevice As Device
C# | public Device PlaybackDevice { get; set; }
C++ public:
property Device^ PlaybackDevice {
Device^ get();
void set(Device^ value);
}
JScript public function get PlaybackDevice() : Device
public function set PlaybackDevice(Device);

Property Value

Microsoft.DirectX.DirectSound.Device

This property is read/write.


SoundDeviceConfig.Window Property (Microsoft.DirectX.DirectPlay.Voice)

SoundDeviceConfig.Window Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Must be set to the window that will be used to determine focus for sound playback. Deprecated.

Definition

Visual Basic | Public Property Window As Control
C# | public Control Window { get; set; }
C++ public:
property Control^ Window {
Control^ get();
void set(Control^ value);
}
JScript public function get Window() : Control
public function set Window(Control);

Property Value

System.Windows.Forms.Control

This property is read/write.


ConnectResultEventHandler(Object,ConnectResultEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

ConnectResultEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ConnectResult event. Deprecated.

Definition

Visual Basic Public Delegate Sub ConnectResultEventHandler( _
ByVal sender As Object, _
ByVal e As ConnectResultEventArgs _
)
C# public delegate void ConnectResultEventHandler(
object sender,
ConnectResultEventArgs e
);
C++ public delegate void ConnectResultEventHandler(
Object^ sender,
ConnectResultEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.ConnectResultEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DisconnectResultEventHandler(Object,DisconnectResultEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

DisconnectResultEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidDisconnectresultDplay message when the disconnect request generated through a call to the PlayvoiceclientDisconnectDplay method has completed.The structure contains information for the DvmsgidDisconnectresultDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub DisconnectResultEventHandler( _
ByVal sender As Object, _
ByVal e As DisconnectResultEventArgs _
)
C# public delegate void DisconnectResultEventHandler(
object sender,
DisconnectResultEventArgs e
);
C++ public delegate void DisconnectResultEventHandler(
Object^ sender,
DisconnectResultEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.DisconnectResultEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputLevelEventHandler(Object,InputLevelEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

InputLevelEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the InputLevel event. Deprecated.

Definition

Visual Basic Public Delegate Sub InputLevelEventHandler( _
ByVal sender As Object, _
ByVal e As InputLevelEventArgs _
)
C# public delegate void InputLevelEventHandler(
object sender,
InputLevelEventArgs e
);
C++ public delegate void InputLevelEventHandler(
Object^ sender,
InputLevelEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.InputLevelEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OutputLevelEventHandler(Object,OutputLevelEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

OutputLevelEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the OutputLevel event. Deprecated.

Definition

Visual Basic Public Delegate Sub OutputLevelEventHandler( _
ByVal sender As Object, _
ByVal e As OutputLevelEventArgs _
)
C# public delegate void OutputLevelEventHandler(
object sender,
OutputLevelEventArgs e
);
C++ public delegate void OutputLevelEventHandler(
Object^ sender,
OutputLevelEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.OutputLevelEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerOutputLevelEventHandler(Object,PlayerOutputLevelEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

PlayerOutputLevelEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidPlayeroutputlevelDplay message periodically to notify the user of the output level of an individual player's voice stream.The structure contains information for the DvmsgidPlayeroutputlevelDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub PlayerOutputLevelEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerOutputLevelEventArgs _
)
C# public delegate void PlayerOutputLevelEventHandler(
object sender,
PlayerOutputLevelEventArgs e
);
C++ public delegate void PlayerOutputLevelEventHandler(
Object^ sender,
PlayerOutputLevelEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.PlayerOutputLevelEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerStartedEventHandler(Object,PlayerStartedEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

PlayerStartedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerStarted event. Deprecated.

Definition

Visual Basic Public Delegate Sub PlayerStartedEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerStartedEventArgs _
)
C# public delegate void PlayerStartedEventHandler(
object sender,
PlayerStartedEventArgs e
);
C++ public delegate void PlayerStartedEventHandler(
Object^ sender,
PlayerStartedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.PlayerStartedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerStoppedEventHandler(Object,PlayerStoppedEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

PlayerStoppedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerStopped event. Deprecated.

Definition

Visual Basic Public Delegate Sub PlayerStoppedEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerStoppedEventArgs _
)
C# public delegate void PlayerStoppedEventHandler(
object sender,
PlayerStoppedEventArgs e
);
C++ public delegate void PlayerStoppedEventHandler(
Object^ sender,
PlayerStoppedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.PlayerStoppedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RecordStartedEventHandler(Object,RecordStartedEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

RecordStartedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the RecordStarted event. Deprecated.

Definition

Visual Basic Public Delegate Sub RecordStartedEventHandler( _
ByVal sender As Object, _
ByVal e As RecordStartedEventArgs _
)
C# public delegate void RecordStartedEventHandler(
object sender,
RecordStartedEventArgs e
);
C++ public delegate void RecordStartedEventHandler(
Object^ sender,
RecordStartedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.RecordStartedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RecordStoppedEventHandler(Object,RecordStoppedEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

RecordStoppedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the RecordStopped event. Deprecated.

Definition

Visual Basic Public Delegate Sub RecordStoppedEventHandler( _
ByVal sender As Object, _
ByVal e As RecordStoppedEventArgs _
)
C# public delegate void RecordStoppedEventHandler(
object sender,
RecordStoppedEventArgs e
);
C++ public delegate void RecordStoppedEventHandler(
Object^ sender,
RecordStoppedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.RecordStoppedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionLostEventHandler(Object,SessionLostEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

SessionLostEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionLost event. Deprecated.

Definition

Visual Basic Public Delegate Sub SessionLostEventHandler( _
ByVal sender As Object, _
ByVal e As SessionLostEventArgs _
)
C# public delegate void SessionLostEventHandler(
object sender,
SessionLostEventArgs e
);
C++ public delegate void SessionLostEventHandler(
Object^ sender,
SessionLostEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.SessionLostEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SetTargetsEventHandler(Object,SetTargetsEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

SetTargetsEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SetTargets event. Deprecated.

Definition

Visual Basic Public Delegate Sub SetTargetsEventHandler( _
ByVal sender As Object, _
ByVal e As SetTargetsEventArgs _
)
C# public delegate void SetTargetsEventHandler(
object sender,
SetTargetsEventArgs e
);
C++ public delegate void SetTargetsEventHandler(
Object^ sender,
SetTargetsEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.SetTargetsEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VoiceHostMigratedEventHandler(Object,HostMigratedEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

VoiceHostMigratedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the HostMigrated event. Deprecated.

Definition

Visual Basic Public Delegate Sub VoiceHostMigratedEventHandler( _
ByVal sender As Object, _
ByVal e As HostMigratedEventArgs _
)
C# public delegate void VoiceHostMigratedEventHandler(
object sender,
HostMigratedEventArgs e
);
C++ public delegate void VoiceHostMigratedEventHandler(
Object^ sender,
HostMigratedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.HostMigratedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VoicePlayerCreatedEventHandler(Object,VoicePlayerCreatedEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

VoicePlayerCreatedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerCreated event. Deprecated.

Definition

Visual Basic Public Delegate Sub VoicePlayerCreatedEventHandler( _
ByVal sender As Object, _
ByVal e As VoicePlayerCreatedEventArgs _
)
C# public delegate void VoicePlayerCreatedEventHandler(
object sender,
VoicePlayerCreatedEventArgs e
);
C++ public delegate void VoicePlayerCreatedEventHandler(
Object^ sender,
VoicePlayerCreatedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.VoicePlayerCreatedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


VoicePlayerDeletedEventHandler(Object,VoicePlayerDeletedEventArgs) Delegate (Microsoft.DirectX.DirectPlay.Voice)

VoicePlayerDeletedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerDeleted event. Deprecated.

Definition

Visual Basic Public Delegate Sub VoicePlayerDeletedEventHandler( _
ByVal sender As Object, _
ByVal e As VoicePlayerDeletedEventArgs _
)
C# public delegate void VoicePlayerDeletedEventHandler(
object sender,
VoicePlayerDeletedEventArgs e
);
C++ public delegate void VoicePlayerDeletedEventHandler(
Object^ sender,
VoicePlayerDeletedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.Voice.VoicePlayerDeletedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay.Voice
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Microsoft.DirectX.DirectPlay

Warning: Microsoft DirectPlay has been deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay enables you to write network applications such as multiplayer games. The following tables list the members exposed by the Microsoft.DirectX.DirectPlay namespace.

Classes

AbortedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation was canceled before it could be completed. Deprecated.
Address
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Address object contains generic addressing methods used to create and manipulate addresses for Microsoft® DirectPlay®. Deprecated.
AddressingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address specified is invalid. Deprecated.
AlreadyClosingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to call the Close method on a session has been made more than once. Deprecated.
AlreadyConnectedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is already connected to the session. Deprecated.
AlreadyDisconnectingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The client is already disconnecting from the session. Deprecated.
AlreadyRegisteredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object has already been registered. Deprecated.
AsyncOperationCompleteEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the AsyncOperationComplete event. Deprecated.
CannotCancelException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not be canceled. Deprecated.
CannotCreateGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A new group cannot be created. Deprecated.
CannotCreatePlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A new player cannot be created. Deprecated.
CannotLaunchApplicationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The lobby cannot launch the specified application. Deprecated.
Client
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Warning: This interface has been deprecated.
Applications use the methods of the Client object to create and manage client applications for client/server sessions. Deprecated.
ClientInformationEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DirectPlay generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.
ConnectCompleteEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.
ConnectingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The method is in the process of connecting to the network. Deprecated.
ConnectionLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider connection was reset while data was being sent. Deprecated.
ConversionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data could not be converted. Deprecated.
DataTooLargeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The application data is too large for the service provider's Maximum Transmission Unit. Deprecated.
DirectPlayException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception type for all DirectPlay exceptions. Derives from DirectXException. Deprecated.
DoesNotExistException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Requested element is not part of the address or the requested application globally unique identifier (Guid) is not registered. Deprecated.
DuplicateCommandException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A duplicate command has been issued. Deprecated.
EndPointNotReceivingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An end point is not receiving data. Deprecated.
FindHostQueryEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the FindHostQuery event. Deprecated.
FindHostQueryTooLargeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The query data specified is too large. Deprecated.
FindHostResponseEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response to an enumeration query is too large. Deprecated.
FindHostResponseTooLargeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response to an enumeration query is too large. Deprecated.
GroupCreatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the GroupCreated event. Deprecated.
GroupDestroyedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the Group Destroyed event. Deprecated.
GroupInformationEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.
GroupMembersList
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A collection of group members. Deprecated.
GroupNotEmptyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified group is not empty. Deprecated.
HostingException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The session is already hosting. Deprecated.
HostMigratedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.
IncompleteAddressException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address specified is not complete. Deprecated.
IndicateConnectEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.
IndicatedConnectAbortedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.
InvalidAddressFormatException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address format is invalid. Deprecated.
InvalidApplicationException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Guid supplied for the application is invalid. Deprecated.
InvalidCommandException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The command specified is invalid. Deprecated.
InvalidDeviceAddressException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address for the local computer or adapter is invalid. Deprecated.
InvalidEndPointException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The endpoint was invalid Deprecated.
InvalidFlagsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The flags passed to this method are invalid. Deprecated.
InvalidGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The group identifier (ID) is not recognized as a valid group ID for this game session. Deprecated.
InvalidHandleException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle specified is invalid. Deprecated.
InvalidHostAddressException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified remote address is invalid. Deprecated.
InvalidInstanceException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Guid for the application instance is invalid. Deprecated.
InvalidObjectException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object parameter is invalid. This value will be returned in a connect request if the connecting player was not a client in a client/server game or a peer in a peer-to-peer game. Deprecated.
InvalidPasswordException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An invalid password was supplied when attempting to join a session that requires a password. Deprecated.
InvalidPlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not recognized as a valid player ID for this game session. Deprecated.
InvalidPriorityException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified priority is not within the range of allowed priorities, which is inclusively from 0 through 65535. Deprecated.
InvalidStringException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
String specified as a parameter is invalid. Deprecated.
InvalidUrlException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specified string is not a valid DirectPlay URL. Deprecated.
InvalidVersionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There was an attempt to connect to an invalid version of DirectPlay. Deprecated.
NatResolver
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the NatResolver object to simplify traversal through the Internet Connection Sharing features available in Microsoft® Windows® Millennium Edition (Windows Me) and Windows XP, as well as other Network Address Translators. Deprecated.
NatResolverQueryEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the NatResolver Query event. Deprecated.
NetworkPacket
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A network packet that can be sent to other members of this session. Deprecated.
NoCapsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The communication link that DirectPlay is attempting to use is not capable of this function. Deprecated.
NoConnectionException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No communication link was established. Deprecated.
NoHostPlayerException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is currently no player acting as the host of the session. Deprecated.
NoMoreAddressComponentsException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No more address components can be added to this address. Deprecated.
NoResponseException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There was no response from the specified target. Deprecated.
NotAllowedException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This function is not allowed on this object. Deprecated.
NotHostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt by the client to connect to a nonhost computer. Additionally, this error value can be returned by a nonhost that tries to set the application description. Deprecated.
NotReadyException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not ready for use. Deprecated.
NotRegisteredException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This object is not registered. Deprecated.
Peer
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Peer object to create a peer-to-peer Microsoft® DirectPlay® session. Deprecated.
PeerInformationEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.
PlayerAddedToGroupEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerAddedToGroup event. Deprecated.
PlayerAlreadyInGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is already included in the group. Deprecated.
PlayerCreatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerCreated event. Deprecated.
PlayerDestroyedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerDestroyed event. Deprecated.
PlayerLostException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A player has lost the connection to the session. Deprecated.
PlayerNotInGroupException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not included in the group. Deprecated.
PlayerNotReachableException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A player has tried to join a peer-peer session where at least one other existing player in the session cannot connect to the joining player. Deprecated.
PlayerRemovedFromGroupEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerRemovedFromGroup event. Deprecated.
PlayersGroupsEnumerator
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides an enumerator for player and group lists. Deprecated.
ReceiveEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.
SendCompleteEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidSendCompleteDplay message when an asynchronous send message request has completed.The structure contains information for the DpnMsgidSendCompleteDplay system message. Deprecated.
SendTooLargeException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The send was too large. Deprecated.
Server
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Server object to create and manage the server for a Microsoft® DirectPlay® client/server transport session. Deprecated.
ServerInformationEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.
SessionFullException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The request to connect to the host or server failed because the maximum number of players allotted for the session has been reached. Deprecated.
SessionTerminatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the SessionTerminated event. Deprecated.
TableFullException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The table is full. Deprecated.
ThreadCreatedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ThreadCreated event. Deprecated.
ThreadDestroyedEventArgs
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ThreadDestroyed event. Deprecated.
ThreadPool
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the ThreadPool object to manage threads in a Microsoft® DirectPlay® application Deprecated.
TimedOutException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not complete because it has timed out. Deprecated.
UserCancelException
Warning: This class is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user canceled the operation. Deprecated.

Enumerations

CancelFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancel all asynchronous requests. Deprecated.
ConnectFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.
DestroyGroupFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
DestroyPlayerFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
FindHostsFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
GetSendQueueInformationFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
GroupFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
HostFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.
InitializeFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disable parameter validation for the current object. Deprecated.
LocalAddressFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
PlayerID
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default system player id's. Deprecated.
ResultCode
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result codes that can be returned via events. Deprecated.
SendFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
SessionFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.
SyncFlags
Warning: This enum is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Structures

AddPlayerToGroupMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidAddPlayerToGroupDplay message when a player has been added to a group in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidAddPlayerToGroupDplay system message. Deprecated.
ApplicationDescription
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the settings for a Microsoft® DirectPlay® application. Deprecated.
AsyncOperationCompleteMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the AsyncOperationComplete event. Deprecated.
Caps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used when setting and retrieving general parameters for Microsoft® DirectPlay®. Deprecated.
ClientInformationMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.
ConnectCompleteMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.
ConnectionInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to retrieve statistics for the connection between you and a remote computer that you are connected to. Deprecated.
CreateGroupMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreateGroupDplay message when a group is created.The structure contains information for the DpnMsgidCreateGroupDplay system message. Deprecated.
CreatePlayerMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreatePlayerDplay message when a player is added to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidCreatePlayerDplay system message. Deprecated.
CreateThreadMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreateThreadDplay message when a new thread is created.The structure contains information for the DpnMsgidCreateThreadDplay system message. Deprecated.
DestroyGroupMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyGroupDplay message when a group is destroyed from a peer-to-peer or client/server session.The structure contains information for the DpnMsgidDestroyGroupDplay system message. Deprecated.
DestroyPlayerMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyPlayerDplay message when a player leaves a peer-to-peer or client/server session.The structure contains information for the DpnMsgidDestroyPlayerDplay system message. Deprecated.
DestroyThreadMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyThreadDplay message when a thread is shut down.The structure contains information for the DpnMsgidDestroyThreadDplay system message. Deprecated.
FindHostsQueryMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the FindHostQuery event. Deprecated.
FindHostsResponseMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® sends the DpnMsgidEnumHostsResponseDplay message to a peer or client's message handler to convey the host's response to an enumeration request.The structure contains information for the DpnMsgidEnumHostsResponseDplay system message. Deprecated.
GroupInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes static group information. Deprecated.
GroupInformationMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.
HostMigratedMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.
IndicateConnectMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.
IndicatedConnectAbortedMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.
NatResolverQueryMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the NatResolverQuery event. Deprecated.
PeerInformationMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.
PlayerInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes static player information. Deprecated.
ReceiveMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.
RemovePlayerFromGroupMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidRemovePlayerFromGroupDplay message when a player has been deleted from a group in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidRemovePlayerFromGroupDplay system message. Deprecated.
SendCompleteMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidSendCompleteDplay message when an asynchronous send message request has completed.The structure contains information for the DpnMsgidSendCompleteDplay system message. Deprecated.
ServerInformationMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.
ServiceProviderCaps
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to set and retrieve parameters for service providers. Deprecated.
ServiceProviderCapsFlags
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers for the system, including those that are not available to the application or do not have devices installed. Deprecated.
ServiceProviderInformation
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used when enumerating information for a specific service provider. Deprecated.
ServiceProviderInformationFlags
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the service provider. Deprecated.
TerminateSessionMessage
Warning: This struct is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidTerminateSessionDplay message when a session is terminated by the host.The structure contains information for the DpnMsgidTerminateSessionDplay system message. Deprecated.

Delegates

ApplicationDescriptionEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This message indicates that the application description has been changed. There is no accompanying structure. Deprecated.
AsyncOperationCompleteEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the AsyncOperationComplete event. Deprecated.
ClientInformationEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.
ConnectCompleteEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.
FindHostQueryEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the FindHostQuery event. Deprecated.
FindHostResponseEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the FindHostResponse event. Deprecated.
GroupCreatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the GroupCreated event. Deprecated.
GroupDestroyedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the GroupDestroyed event. Deprecated.
GroupInformationEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.
HostMigratedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the HostMigrated event. Deprecated.
IndicateConnectEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.
IndicatedConnectAbortedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.
NatResolverQueryEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the NatResolverQuery event. Deprecated.
PeerInformationEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.
PlayerAddedToGroupEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerAddedToGroup event. Deprecated.
PlayerCreatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerCreated event. Deprecated.
PlayerDestroyedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerDestroyed event. Deprecated.
PlayerRemovedFromGroupEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerRemovedFromGroup event. Deprecated.
ReceiveEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Receive event. Deprecated.
SendCompleteEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SendComplete event. Deprecated.
ServerInformationEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.
SessionTerminatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionTerminated event. Deprecated.
ThreadCreatedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the ThreadCreated event. Deprecated.
ThreadDestroyedEventHandler
Warning: This delegate is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the ThreadDestroyed event. Deprecated.


AbortedException Class (Microsoft.DirectX.DirectPlay)

AbortedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation was canceled before it could be completed. Deprecated.

Definition

Visual Basic Public Class AbortedException
Inherits DirectPlayException
C# | public class AbortedException : DirectPlayException
C++ | public ref class AbortedException : DirectPlayException
JScript | public class AbortedException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AbortedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AbortedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AbortedException.AbortedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AbortedException();
protected AbortedException(SerializationInfo, StreamingContext);
public AbortedException(string);
public AbortedException(string, Exception);


AbortedException.AbortedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

AbortedException.AbortedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AbortedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AbortedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AbortedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AbortedException.AbortedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

AbortedException.AbortedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AbortedException(
string message,
Exception inner
);
C++ public:
AbortedException(
String^ message,
Exception^ inner
);
JScript public function AbortedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AbortedException.AbortedException(String) Constructor (Microsoft.DirectX.DirectPlay)

AbortedException.AbortedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AbortedException(
string message
);
C++ public:
AbortedException(
String^ message
);
JScript public function AbortedException(
message : String
);

Parameters

message System.String


AbortedException.AbortedException() Constructor (Microsoft.DirectX.DirectPlay)

AbortedException.AbortedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AbortedException();
C++ public:
AbortedException();
JScript | public function AbortedException();


Address Class (Microsoft.DirectX.DirectPlay)

Address Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Address object contains generic addressing methods used to create and manipulate addresses for Microsoft® DirectPlay®. Deprecated.

Definition

Visual Basic Public Class Address
Inherits MarshalByRefObject
Implements ICloneable, IDisposable
C# | public class Address : MarshalByRefObject, ICloneable, IDisposable
C++ | public ref class Address : MarshalByRefObject, ICloneable, IDisposable
JScript | public class Address extends MarshalByRefObject implements ICloneable, IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Fields

Field Description
static (Shared in Visual Basic) BaudRate115200
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) BaudRate14400
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) BaudRate19200
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) BaudRate38400
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) BaudRate56000
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) BaudRate57600
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) BaudRate9600
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) DpnServerPort
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) EscapeChar
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) FlowControlControlRts
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) FlowControlDtr
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) FlowControlNone
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) FlowControlRtsDtr
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) FlowControlXonXoff
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) Header
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) IndexInvalid
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) IpxProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyApplicationInstance
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyBaud
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyDevice
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyFlowControl
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyHostname
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyNatResolver
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyNatResolverUserString
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyParity
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyPhoneNumber
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyPort
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyProcessor
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyProgram
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyScope
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyStopBits
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) KeyTraversalMode
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ModemProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ParityEven
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ParityMark
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ParityNone
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ParityOdd
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ParitySpace
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) SeparatorComponent
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) SeparatorKeyValue
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) SeparatorUserdata
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) SerialProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ServiceProviderBlueTooth
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ServiceProviderIpx
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ServiceProviderModem
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ServiceProviderSerial
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) ServiceProviderTcpIp
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) StopBitsOne
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) StopBitsOneFive
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) StopBitsTwo
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) TcpIpProvider
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) TraversalModeNone
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) TraversalModePortRecommended
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) TraversalModePortRequired
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
AddComponent
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.
Address
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Clear
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Resets the address object to an empty address. Deprecated.
Clone
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Duplicates the object. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetComponentBinary
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.
GetComponentGuid
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.
GetComponentInteger
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.
GetComponentString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
SetEqual
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the contents of the object it is called on to match the contents of the address object passed to the method. Deprecated.

Properties

Property Description
Device
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the local device GUID in the Address object.Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
NumberComponents
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the number of components in the Address object. Deprecated.
ServiceProvider
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the service provider globally unique identifier (GUID) in the Address object.Deprecated.
Url
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Microsoft DirectPlay address URL string represented by this Address object. Deprecated.
UserData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the user data in the Address object.Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Address

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Address.AddComponent Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Overload List

public void AddComponent(string, byte[]);
public void AddComponent(string, Guid);
public void AddComponent(string, int);
public void AddComponent(string, string);


Address.AddComponent(String,Byte[]) Method (Microsoft.DirectX.DirectPlay)

Address.AddComponent Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Definition

Visual Basic Public Sub AddComponent( _
ByVal keyName As String, _
ByVal value() As Byte _
)
C# public void AddComponent(
string keyName,
byte[] value
);
C++ public:
void AddComponent(
String^ keyName,
array<unsigned char>^ value
);
JScript public function AddComponent(
keyName : String,
value : byte[]
);

Parameters

keyName System.String
value System.Byte[]


Address.AddComponent(String,Guid) Method (Microsoft.DirectX.DirectPlay)

Address.AddComponent Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Definition

Visual Basic Public Sub AddComponent( _
ByVal keyName As String, _
ByVal value As Guid _
)
C# public void AddComponent(
string keyName,
Guid value
);
C++ public:
void AddComponent(
String^ keyName,
Guid value
);
JScript public function AddComponent(
keyName : String,
value : Guid
);

Parameters

keyName System.String
value System.Guid


Address.AddComponent(String,String) Method (Microsoft.DirectX.DirectPlay)

Address.AddComponent Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Definition

Visual Basic Public Sub AddComponent( _
ByVal keyName As String, _
ByVal value As String _
)
C# public void AddComponent(
string keyName,
string value
);
C++ public:
void AddComponent(
String^ keyName,
String^ value
);
JScript public function AddComponent(
keyName : String,
value : String
);

Parameters

keyName System.String
value System.String


Address.AddComponent(String,Int32) Method (Microsoft.DirectX.DirectPlay)

Address.AddComponent Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a component to the address. If the component is part of the address, it is replaced by the new value in this call.Values are specified in native formats when making this call. Therefore, the parameter should be a recast reference to a variable that holds the data in the native format. For example, if the component is a , the parameter should be a recast reference to a . This method validates that the predefined component types are the right format. Deprecated.

Definition

Visual Basic Public Sub AddComponent( _
ByVal keyName As String, _
ByVal iValue As Integer _
)
C# public void AddComponent(
string keyName,
int iValue
);
C++ public:
void AddComponent(
String^ keyName,
int iValue
);
JScript public function AddComponent(
keyName : String,
iValue : int
);

Parameters

keyName System.String
iValue System.Int32


Address.Address Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Address();
public Address(IPAddress);
public Address(IPEndPoint);
public Address(string, int);


Address.Address(IPEndPoint) Constructor (Microsoft.DirectX.DirectPlay)

Address.Address Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal address As IPEndPoint _
)
C# public Address(
IPEndPoint address
);
C++ public:
Address(
IPEndPoint^ address
);
JScript public function Address(
address : IPEndPoint
);

Parameters

address System.Net.IPEndPoint


Address.Address(IPAddress) Constructor (Microsoft.DirectX.DirectPlay)

Address.Address Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal address As IPAddress _
)
C# public Address(
IPAddress address
);
C++ public:
Address(
IPAddress^ address
);
JScript public function Address(
address : IPAddress
);

Parameters

address System.Net.IPAddress


Address.Address(String,Int32) Constructor (Microsoft.DirectX.DirectPlay)

Address.Address Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal hostname As String, _
ByVal port As Integer _
)
C# public Address(
string hostname,
int port
);
C++ public:
Address(
String^ hostname,
int port
);
JScript public function Address(
hostname : String,
port : int
);

Parameters

hostname System.String
port System.Int32


Address.Address() Constructor (Microsoft.DirectX.DirectPlay)

Address.Address Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Address();
C++ public:
Address();
JScript | public function Address();


Address.Clear() Method (Microsoft.DirectX.DirectPlay)

Address.Clear Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Resets the address object to an empty address. Deprecated.

Definition

Visual Basic | Public Sub Clear()
C# | public void Clear();
C++ public:
void Clear();
JScript | public function Clear();


Address.Clone() Method (Microsoft.DirectX.DirectPlay)

Address.Clone Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Duplicates the object. Deprecated.

Definition

Visual Basic | Overrides Public Function Clone() As Object
C# | public override object Clone();
C++ public:
virtual Object^ Clone() override;
JScript | public override function Clone() : Object;

Return Value

System.Object


Address.Dispose() Method (Microsoft.DirectX.DirectPlay)

Address.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Address();
JScript | public override function Dispose();

See Also

  • Address.Disposed
  • Address.Disposing


Address.Equals Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Overload List

public bool Equals(Address);
public override bool Equals(object);


Address.Equals(Address) Method (Microsoft.DirectX.DirectPlay)

Address.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Public Function Equals( _
ByVal address As Address _
) As Boolean
C# public bool Equals(
Address address
);
C++ public:
bool Equals(
Address^ address
);
JScript public function Equals(
address : Address
) : boolean;

Parameters

address Microsoft.DirectX.DirectPlay.Address
An Address object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Address.Equals(Object) Method (Microsoft.DirectX.DirectPlay)

Address.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Address.Finalize() Method (Microsoft.DirectX.DirectPlay)

Address.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Address();
C++ | !Address();
JScript | protected override function Finalize();


Address.GetComponentBinary(String) Method (Microsoft.DirectX.DirectPlay)

Address.GetComponentBinary Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.

Definition

Visual Basic Public Function GetComponentBinary( _
ByVal keyName As String _
) As Byte()
C# public byte[] GetComponentBinary(
string keyName
);
C++ public:
array<unsigned char>^ GetComponentBinary(
String^ keyName
);
JScript public function GetComponentBinary(
keyName : String
) : byte[];

Parameters

keyName System.String

Return Value

System.Byte[]


Address.GetComponentGuid(String) Method (Microsoft.DirectX.DirectPlay)

Address.GetComponentGuid Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.

Definition

Visual Basic Public Function GetComponentGuid( _
ByVal keyName As String _
) As Guid
C# public Guid GetComponentGuid(
string keyName
);
C++ public:
Guid GetComponentGuid(
String^ keyName
);
JScript public function GetComponentGuid(
keyName : String
) : Guid;

Parameters

keyName System.String

Return Value

System.Guid


Address.GetComponentInteger(String) Method (Microsoft.DirectX.DirectPlay)

Address.GetComponentInteger Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.

Definition

Visual Basic Public Function GetComponentInteger( _
ByVal keyName As String _
) As Integer
C# public int GetComponentInteger(
string keyName
);
C++ public:
int GetComponentInteger(
String^ keyName
);
JScript public function GetComponentInteger(
keyName : String
) : int;

Parameters

keyName System.String

Return Value

System.Int32


Address.GetComponentString(String) Method (Microsoft.DirectX.DirectPlay)

Address.GetComponentString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves information on the component at the specified key. Values for the component are retrieved in their native format. If the component key is not found, DPNERR_DOESNOTEXIST is returned.The value of the component is retrieved in its native format. Therefore, if the component's value is a , a is retrieved by this call. So buffer size = 4 and should be a recast . Deprecated.

Definition

Visual Basic Public Function GetComponentString( _
ByVal keyName As String _
) As String
C# public string GetComponentString(
string keyName
);
C++ public:
String^ GetComponentString(
String^ keyName
);
JScript public function GetComponentString(
keyName : String
) : String;

Parameters

keyName System.String

Return Value

System.String


Address.GetHashCode() Method (Microsoft.DirectX.DirectPlay)

Address.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Address.op_Equality(Address,Address) Method (Microsoft.DirectX.DirectPlay)

Address.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Address, _
ByVal right As Address _
) As Boolean
C# public static bool op_Equality(
Address left,
Address right
);
C++ public:
static bool operator==(
Address^ left,
Address^ right
);
JScript public static function op_Equality(
left : Address,
right : Address
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Address
The Address structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Address
The Address structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Address.op_Inequality(Address,Address) Method (Microsoft.DirectX.DirectPlay)

Address.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Address, _
ByVal right As Address _
) As Boolean
C# public static bool op_Inequality(
Address left,
Address right
);
C++ public:
static bool operator!=(
Address^ left,
Address^ right
);
JScript public static function op_Inequality(
left : Address,
right : Address
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Address
The Address structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Address
The Address structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Address.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

Address.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Address.SetEqual(Address) Method (Microsoft.DirectX.DirectPlay)

Address.SetEqual Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the contents of the object it is called on to match the contents of the address object passed to the method. Deprecated.

Definition

Visual Basic Public Sub SetEqual( _
ByVal address As Address _
)
C# public void SetEqual(
Address address
);
C++ public:
void SetEqual(
Address^ address
);
JScript public function SetEqual(
address : Address
);

Parameters

address Microsoft.DirectX.DirectPlay.Address


Address.Device Property (Microsoft.DirectX.DirectPlay)

Address.Device Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the local device globally unique identifier (GUID) in the Address object.Deprecated.

Definition

Visual Basic | Public Property Device As Guid
C# | public Guid Device { get; set; }
C++ public:
property Guid Device {
Guid get();
void set(Guid value);
}
JScript public function get Device() : Guid
public function set Device(Guid);

Property Value

System.Guid

This property is read/write.


Address.Disposed Property (Microsoft.DirectX.DirectPlay)

Address.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Address.NumberComponents Property (Microsoft.DirectX.DirectPlay)

Address.NumberComponents Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the number of components in the Address object. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NumberComponents As Integer
C# | public int NumberComponents { get; }
C++ public:
property int NumberComponents {
int get();
}
JScript | public function get NumberComponents() : int

Property Value

System.Int32

This property is read-only.


Address.ServiceProvider Property (Microsoft.DirectX.DirectPlay)

Address.ServiceProvider Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the service provider globally unique identifier (GUID) in the Address object.Deprecated.

Definition

Visual Basic | Public Property ServiceProvider As Guid
C# | public Guid ServiceProvider { get; set; }
C++ public:
property Guid ServiceProvider {
Guid get();
void set(Guid value);
}
JScript public function get ServiceProvider() : Guid
public function set ServiceProvider(Guid);

Property Value

System.Guid

This property is read/write.


Address.Url Property (Microsoft.DirectX.DirectPlay)

Address.Url Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the Microsoft DirectPlay address URL string represented by this Address object. Deprecated.

Definition

Visual Basic | Public Property Url As String
C# | public string Url { get; set; }
C++ public:
property String^ Url {
String^ get();
void set(String^ value);
}
JScript public function get Url() : String
public function set Url(String);

Property Value

System.String

This property is read/write.


Address.UserData Property (Microsoft.DirectX.DirectPlay)

Address.UserData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the user data in the Address object.Deprecated.

Definition

Visual Basic | Public Property UserData As IntPtr
C# | public IntPtr UserData { get; set; }
C++ public:
property IntPtr UserData {
IntPtr get();
void set(IntPtr value);
}
JScript public function get UserData() : IntPtr
public function set UserData(IntPtr);

Property Value

System.IntPtr

This property is read/write.


Address.BaudRate115200 Field (Microsoft.DirectX.DirectPlay)

Address.BaudRate115200 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared BaudRate115200 As Int32
C# | public static Int32 BaudRate115200;
C++ | public: static Int32 BaudRate115200;
JScript | public static var BaudRate115200 : Int32

Field Value

System.Int32

This field is read-only.


Address.BaudRate14400 Field (Microsoft.DirectX.DirectPlay)

Address.BaudRate14400 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared BaudRate14400 As Int32
C# | public static Int32 BaudRate14400;
C++ | public: static Int32 BaudRate14400;
JScript | public static var BaudRate14400 : Int32

Field Value

System.Int32

This field is read-only.


Address.BaudRate19200 Field (Microsoft.DirectX.DirectPlay)

Address.BaudRate19200 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared BaudRate19200 As Int32
C# | public static Int32 BaudRate19200;
C++ | public: static Int32 BaudRate19200;
JScript | public static var BaudRate19200 : Int32

Field Value

System.Int32

This field is read-only.


Address.BaudRate38400 Field (Microsoft.DirectX.DirectPlay)

Address.BaudRate38400 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared BaudRate38400 As Int32
C# | public static Int32 BaudRate38400;
C++ | public: static Int32 BaudRate38400;
JScript | public static var BaudRate38400 : Int32

Field Value

System.Int32

This field is read-only.


Address.BaudRate56000 Field (Microsoft.DirectX.DirectPlay)

Address.BaudRate56000 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared BaudRate56000 As Int32
C# | public static Int32 BaudRate56000;
C++ | public: static Int32 BaudRate56000;
JScript | public static var BaudRate56000 : Int32

Field Value

System.Int32

This field is read-only.


Address.BaudRate57600 Field (Microsoft.DirectX.DirectPlay)

Address.BaudRate57600 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared BaudRate57600 As Int32
C# | public static Int32 BaudRate57600;
C++ | public: static Int32 BaudRate57600;
JScript | public static var BaudRate57600 : Int32

Field Value

System.Int32

This field is read-only.


Address.BaudRate9600 Field (Microsoft.DirectX.DirectPlay)

Address.BaudRate9600 Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared BaudRate9600 As Int32
C# | public static Int32 BaudRate9600;
C++ | public: static Int32 BaudRate9600;
JScript | public static var BaudRate9600 : Int32

Field Value

System.Int32

This field is read-only.


Address.DpnServerPort Field (Microsoft.DirectX.DirectPlay)

Address.DpnServerPort Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared DpnServerPort As Int32
C# | public static Int32 DpnServerPort;
C++ | public: static Int32 DpnServerPort;
JScript | public static var DpnServerPort : Int32

Field Value

System.Int32

This field is read-only.


Address.EscapeChar Field (Microsoft.DirectX.DirectPlay)

Address.EscapeChar Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared EscapeChar As String
C# | public static String EscapeChar;
C++ | public: static String EscapeChar;
JScript | public static var EscapeChar : String

Field Value

System.String

This field is read/write.


Address.FlowControlControlRts Field (Microsoft.DirectX.DirectPlay)

Address.FlowControlControlRts Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared FlowControlControlRts As String
C# | public static String FlowControlControlRts;
C++ | public: static String FlowControlControlRts;
JScript | public static var FlowControlControlRts : String

Field Value

System.String

This field is read/write.


Address.FlowControlDtr Field (Microsoft.DirectX.DirectPlay)

Address.FlowControlDtr Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared FlowControlDtr As String
C# | public static String FlowControlDtr;
C++ | public: static String FlowControlDtr;
JScript | public static var FlowControlDtr : String

Field Value

System.String

This field is read/write.


Address.FlowControlNone Field (Microsoft.DirectX.DirectPlay)

Address.FlowControlNone Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared FlowControlNone As String
C# | public static String FlowControlNone;
C++ | public: static String FlowControlNone;
JScript | public static var FlowControlNone : String

Field Value

System.String

This field is read/write.


Address.FlowControlRtsDtr Field (Microsoft.DirectX.DirectPlay)

Address.FlowControlRtsDtr Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared FlowControlRtsDtr As String
C# | public static String FlowControlRtsDtr;
C++ | public: static String FlowControlRtsDtr;
JScript | public static var FlowControlRtsDtr : String

Field Value

System.String

This field is read/write.


Address.FlowControlXonXoff Field (Microsoft.DirectX.DirectPlay)

Address.FlowControlXonXoff Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared FlowControlXonXoff As String
C# | public static String FlowControlXonXoff;
C++ | public: static String FlowControlXonXoff;
JScript | public static var FlowControlXonXoff : String

Field Value

System.String

This field is read/write.


Address.Header Field (Microsoft.DirectX.DirectPlay)

Address.Header Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared Header As String
C# | public static String Header;
C++ | public: static String Header;
JScript | public static var Header : String

Field Value

System.String

This field is read/write.


Address.IndexInvalid Field (Microsoft.DirectX.DirectPlay)

Address.IndexInvalid Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared IndexInvalid As Int32
C# | public static Int32 IndexInvalid;
C++ | public: static Int32 IndexInvalid;
JScript | public static var IndexInvalid : Int32

Field Value

System.Int32

This field is read-only.


Address.IpxProvider Field (Microsoft.DirectX.DirectPlay)

Address.IpxProvider Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared IpxProvider As String
C# | public static String IpxProvider;
C++ | public: static String IpxProvider;
JScript | public static var IpxProvider : String

Field Value

System.String

This field is read/write.


Address.KeyApplicationInstance Field (Microsoft.DirectX.DirectPlay)

Address.KeyApplicationInstance Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyApplicationInstance As String
C# | public static String KeyApplicationInstance;
C++ | public: static String KeyApplicationInstance;
JScript | public static var KeyApplicationInstance : String

Field Value

System.String

This field is read/write.


Address.KeyBaud Field (Microsoft.DirectX.DirectPlay)

Address.KeyBaud Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyBaud As String
C# | public static String KeyBaud;
C++ | public: static String KeyBaud;
JScript | public static var KeyBaud : String

Field Value

System.String

This field is read/write.


Address.KeyDevice Field (Microsoft.DirectX.DirectPlay)

Address.KeyDevice Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyDevice As String
C# | public static String KeyDevice;
C++ | public: static String KeyDevice;
JScript | public static var KeyDevice : String

Field Value

System.String

This field is read/write.


Address.KeyFlowControl Field (Microsoft.DirectX.DirectPlay)

Address.KeyFlowControl Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyFlowControl As String
C# | public static String KeyFlowControl;
C++ | public: static String KeyFlowControl;
JScript | public static var KeyFlowControl : String

Field Value

System.String

This field is read/write.


Address.KeyHostname Field (Microsoft.DirectX.DirectPlay)

Address.KeyHostname Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyHostname As String
C# | public static String KeyHostname;
C++ | public: static String KeyHostname;
JScript | public static var KeyHostname : String

Field Value

System.String

This field is read/write.


Address.KeyNatResolver Field (Microsoft.DirectX.DirectPlay)

Address.KeyNatResolver Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyNatResolver As String
C# | public static String KeyNatResolver;
C++ | public: static String KeyNatResolver;
JScript | public static var KeyNatResolver : String

Field Value

System.String

This field is read/write.


Address.KeyNatResolverUserString Field (Microsoft.DirectX.DirectPlay)

Address.KeyNatResolverUserString Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyNatResolverUserString As String
C# | public static String KeyNatResolverUserString;
C++ | public: static String KeyNatResolverUserString;
JScript | public static var KeyNatResolverUserString : String

Field Value

System.String

This field is read/write.


Address.KeyParity Field (Microsoft.DirectX.DirectPlay)

Address.KeyParity Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyParity As String
C# | public static String KeyParity;
C++ | public: static String KeyParity;
JScript | public static var KeyParity : String

Field Value

System.String

This field is read/write.


Address.KeyPhoneNumber Field (Microsoft.DirectX.DirectPlay)

Address.KeyPhoneNumber Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyPhoneNumber As String
C# | public static String KeyPhoneNumber;
C++ | public: static String KeyPhoneNumber;
JScript | public static var KeyPhoneNumber : String

Field Value

System.String

This field is read/write.


Address.KeyPort Field (Microsoft.DirectX.DirectPlay)

Address.KeyPort Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyPort As String
C# | public static String KeyPort;
C++ | public: static String KeyPort;
JScript | public static var KeyPort : String

Field Value

System.String

This field is read/write.


Address.KeyProcessor Field (Microsoft.DirectX.DirectPlay)

Address.KeyProcessor Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyProcessor As String
C# | public static String KeyProcessor;
C++ | public: static String KeyProcessor;
JScript | public static var KeyProcessor : String

Field Value

System.String

This field is read/write.


Address.KeyProgram Field (Microsoft.DirectX.DirectPlay)

Address.KeyProgram Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyProgram As String
C# | public static String KeyProgram;
C++ | public: static String KeyProgram;
JScript | public static var KeyProgram : String

Field Value

System.String

This field is read/write.


Address.KeyProvider Field (Microsoft.DirectX.DirectPlay)

Address.KeyProvider Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyProvider As String
C# | public static String KeyProvider;
C++ | public: static String KeyProvider;
JScript | public static var KeyProvider : String

Field Value

System.String

This field is read/write.


Address.KeyScope Field (Microsoft.DirectX.DirectPlay)

Address.KeyScope Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyScope As String
C# | public static String KeyScope;
C++ | public: static String KeyScope;
JScript | public static var KeyScope : String

Field Value

System.String

This field is read/write.


Address.KeyStopBits Field (Microsoft.DirectX.DirectPlay)

Address.KeyStopBits Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyStopBits As String
C# | public static String KeyStopBits;
C++ | public: static String KeyStopBits;
JScript | public static var KeyStopBits : String

Field Value

System.String

This field is read/write.


Address.KeyTraversalMode Field (Microsoft.DirectX.DirectPlay)

Address.KeyTraversalMode Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared KeyTraversalMode As String
C# | public static String KeyTraversalMode;
C++ | public: static String KeyTraversalMode;
JScript | public static var KeyTraversalMode : String

Field Value

System.String

This field is read/write.


Address.ModemProvider Field (Microsoft.DirectX.DirectPlay)

Address.ModemProvider Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ModemProvider As String
C# | public static String ModemProvider;
C++ | public: static String ModemProvider;
JScript | public static var ModemProvider : String

Field Value

System.String

This field is read/write.


Address.ParityEven Field (Microsoft.DirectX.DirectPlay)

Address.ParityEven Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ParityEven As String
C# | public static String ParityEven;
C++ | public: static String ParityEven;
JScript | public static var ParityEven : String

Field Value

System.String

This field is read/write.


Address.ParityMark Field (Microsoft.DirectX.DirectPlay)

Address.ParityMark Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ParityMark As String
C# | public static String ParityMark;
C++ | public: static String ParityMark;
JScript | public static var ParityMark : String

Field Value

System.String

This field is read/write.


Address.ParityNone Field (Microsoft.DirectX.DirectPlay)

Address.ParityNone Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ParityNone As String
C# | public static String ParityNone;
C++ | public: static String ParityNone;
JScript | public static var ParityNone : String

Field Value

System.String

This field is read/write.


Address.ParityOdd Field (Microsoft.DirectX.DirectPlay)

Address.ParityOdd Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ParityOdd As String
C# | public static String ParityOdd;
C++ | public: static String ParityOdd;
JScript | public static var ParityOdd : String

Field Value

System.String

This field is read/write.


Address.ParitySpace Field (Microsoft.DirectX.DirectPlay)

Address.ParitySpace Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ParitySpace As String
C# | public static String ParitySpace;
C++ | public: static String ParitySpace;
JScript | public static var ParitySpace : String

Field Value

System.String

This field is read/write.


Address.SeparatorComponent Field (Microsoft.DirectX.DirectPlay)

Address.SeparatorComponent Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared SeparatorComponent As String
C# | public static String SeparatorComponent;
C++ | public: static String SeparatorComponent;
JScript | public static var SeparatorComponent : String

Field Value

System.String

This field is read/write.


Address.SeparatorKeyValue Field (Microsoft.DirectX.DirectPlay)

Address.SeparatorKeyValue Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared SeparatorKeyValue As String
C# | public static String SeparatorKeyValue;
C++ | public: static String SeparatorKeyValue;
JScript | public static var SeparatorKeyValue : String

Field Value

System.String

This field is read/write.


Address.SeparatorUserdata Field (Microsoft.DirectX.DirectPlay)

Address.SeparatorUserdata Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared SeparatorUserdata As String
C# | public static String SeparatorUserdata;
C++ | public: static String SeparatorUserdata;
JScript | public static var SeparatorUserdata : String

Field Value

System.String

This field is read/write.


Address.SerialProvider Field (Microsoft.DirectX.DirectPlay)

Address.SerialProvider Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared SerialProvider As String
C# | public static String SerialProvider;
C++ | public: static String SerialProvider;
JScript | public static var SerialProvider : String

Field Value

System.String

This field is read/write.


Address.ServiceProviderBlueTooth Field (Microsoft.DirectX.DirectPlay)

Address.ServiceProviderBlueTooth Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ServiceProviderBlueTooth As Guid
C# | public static Guid ServiceProviderBlueTooth;
C++ | public: static Guid ServiceProviderBlueTooth;
JScript | public static var ServiceProviderBlueTooth : Guid

Field Value

System.Guid

This field is read-only.


Address.ServiceProviderIpx Field (Microsoft.DirectX.DirectPlay)

Address.ServiceProviderIpx Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ServiceProviderIpx As Guid
C# | public static Guid ServiceProviderIpx;
C++ | public: static Guid ServiceProviderIpx;
JScript | public static var ServiceProviderIpx : Guid

Field Value

System.Guid

This field is read-only.


Address.ServiceProviderModem Field (Microsoft.DirectX.DirectPlay)

Address.ServiceProviderModem Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ServiceProviderModem As Guid
C# | public static Guid ServiceProviderModem;
C++ | public: static Guid ServiceProviderModem;
JScript | public static var ServiceProviderModem : Guid

Field Value

System.Guid

This field is read-only.


Address.ServiceProviderSerial Field (Microsoft.DirectX.DirectPlay)

Address.ServiceProviderSerial Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ServiceProviderSerial As Guid
C# | public static Guid ServiceProviderSerial;
C++ | public: static Guid ServiceProviderSerial;
JScript | public static var ServiceProviderSerial : Guid

Field Value

System.Guid

This field is read-only.


Address.ServiceProviderTcpIp Field (Microsoft.DirectX.DirectPlay)

Address.ServiceProviderTcpIp Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared ServiceProviderTcpIp As Guid
C# | public static Guid ServiceProviderTcpIp;
C++ | public: static Guid ServiceProviderTcpIp;
JScript | public static var ServiceProviderTcpIp : Guid

Field Value

System.Guid

This field is read-only.


Address.StopBitsOne Field (Microsoft.DirectX.DirectPlay)

Address.StopBitsOne Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared StopBitsOne As String
C# | public static String StopBitsOne;
C++ | public: static String StopBitsOne;
JScript | public static var StopBitsOne : String

Field Value

System.String

This field is read/write.


Address.StopBitsOneFive Field (Microsoft.DirectX.DirectPlay)

Address.StopBitsOneFive Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared StopBitsOneFive As String
C# | public static String StopBitsOneFive;
C++ | public: static String StopBitsOneFive;
JScript | public static var StopBitsOneFive : String

Field Value

System.String

This field is read/write.


Address.StopBitsTwo Field (Microsoft.DirectX.DirectPlay)

Address.StopBitsTwo Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared StopBitsTwo As String
C# | public static String StopBitsTwo;
C++ | public: static String StopBitsTwo;
JScript | public static var StopBitsTwo : String

Field Value

System.String

This field is read/write.


Address.TcpIpProvider Field (Microsoft.DirectX.DirectPlay)

Address.TcpIpProvider Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared TcpIpProvider As String
C# | public static String TcpIpProvider;
C++ | public: static String TcpIpProvider;
JScript | public static var TcpIpProvider : String

Field Value

System.String

This field is read/write.


Address.TraversalModeNone Field (Microsoft.DirectX.DirectPlay)

Address.TraversalModeNone Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared TraversalModeNone As Int32
C# | public static Int32 TraversalModeNone;
C++ | public: static Int32 TraversalModeNone;
JScript | public static var TraversalModeNone : Int32

Field Value

System.Int32

This field is read-only.


Address.TraversalModePortRecommended Field (Microsoft.DirectX.DirectPlay)

Address.TraversalModePortRecommended Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared TraversalModePortRecommended As Int32
C# | public static Int32 TraversalModePortRecommended;
C++ | public: static Int32 TraversalModePortRecommended;
JScript | public static var TraversalModePortRecommended : Int32

Field Value

System.Int32

This field is read-only.


Address.TraversalModePortRequired Field (Microsoft.DirectX.DirectPlay)

Address.TraversalModePortRequired Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Shared TraversalModePortRequired As Int32
C# | public static Int32 TraversalModePortRequired;
C++ | public: static Int32 TraversalModePortRequired;
JScript | public static var TraversalModePortRequired : Int32

Field Value

System.Int32

This field is read-only.


Address.Disposing Event (Microsoft.DirectX.DirectPlay)

Address.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for an Address.Disposing event, use the following code.

address.Disposing += new System.EventHandler(this.OnDisposing);

The Dispose property of an object indicates whether that object has been disposed.


AddressingException Class (Microsoft.DirectX.DirectPlay)

AddressingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address specified is invalid. Deprecated.

Definition

Visual Basic Public Class AddressingException
Inherits DirectPlayException
C# | public class AddressingException : DirectPlayException
C++ | public ref class AddressingException : DirectPlayException
JScript | public class AddressingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AddressingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AddressingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AddressingException.AddressingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AddressingException();
protected AddressingException(SerializationInfo, StreamingContext);
public AddressingException(string);
public AddressingException(string, Exception);


AddressingException.AddressingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

AddressingException.AddressingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AddressingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AddressingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AddressingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AddressingException.AddressingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

AddressingException.AddressingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AddressingException(
string message,
Exception inner
);
C++ public:
AddressingException(
String^ message,
Exception^ inner
);
JScript public function AddressingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AddressingException.AddressingException(String) Constructor (Microsoft.DirectX.DirectPlay)

AddressingException.AddressingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AddressingException(
string message
);
C++ public:
AddressingException(
String^ message
);
JScript public function AddressingException(
message : String
);

Parameters

message System.String


AddressingException.AddressingException() Constructor (Microsoft.DirectX.DirectPlay)

AddressingException.AddressingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AddressingException();
C++ public:
AddressingException();
JScript | public function AddressingException();


AlreadyClosingException Class (Microsoft.DirectX.DirectPlay)

AlreadyClosingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt to call the Close method on a session has been made more than once. Deprecated.

Definition

Visual Basic Public Class AlreadyClosingException
Inherits DirectPlayException
C# | public class AlreadyClosingException : DirectPlayException
C++ | public ref class AlreadyClosingException : DirectPlayException
JScript | public class AlreadyClosingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyClosingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AlreadyClosingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AlreadyClosingException.AlreadyClosingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyClosingException();
protected AlreadyClosingException(SerializationInfo, StreamingContext);
public AlreadyClosingException(string);
public AlreadyClosingException(string, Exception);


AlreadyClosingException.AlreadyClosingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyClosingException.AlreadyClosingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyClosingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AlreadyClosingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AlreadyClosingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AlreadyClosingException.AlreadyClosingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyClosingException.AlreadyClosingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyClosingException(
string message,
Exception inner
);
C++ public:
AlreadyClosingException(
String^ message,
Exception^ inner
);
JScript public function AlreadyClosingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AlreadyClosingException.AlreadyClosingException(String) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyClosingException.AlreadyClosingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AlreadyClosingException(
string message
);
C++ public:
AlreadyClosingException(
String^ message
);
JScript public function AlreadyClosingException(
message : String
);

Parameters

message System.String


AlreadyClosingException.AlreadyClosingException() Constructor (Microsoft.DirectX.DirectPlay)

AlreadyClosingException.AlreadyClosingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AlreadyClosingException();
C++ public:
AlreadyClosingException();
JScript | public function AlreadyClosingException();


AlreadyConnectedException Class (Microsoft.DirectX.DirectPlay)

AlreadyConnectedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is already connected to the session. Deprecated.

Definition

Visual Basic Public Class AlreadyConnectedException
Inherits DirectPlayException
C# | public class AlreadyConnectedException : DirectPlayException
C++ | public ref class AlreadyConnectedException : DirectPlayException
JScript | public class AlreadyConnectedException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyConnectedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AlreadyConnectedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AlreadyConnectedException.AlreadyConnectedException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyConnectedException();
protected AlreadyConnectedException(SerializationInfo, StreamingContext);
public AlreadyConnectedException(string);
public AlreadyConnectedException(string, Exception);


AlreadyConnectedException.AlreadyConnectedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyConnectedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AlreadyConnectedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AlreadyConnectedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AlreadyConnectedException.AlreadyConnectedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyConnectedException(
string message,
Exception inner
);
C++ public:
AlreadyConnectedException(
String^ message,
Exception^ inner
);
JScript public function AlreadyConnectedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AlreadyConnectedException.AlreadyConnectedException(String) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AlreadyConnectedException(
string message
);
C++ public:
AlreadyConnectedException(
String^ message
);
JScript public function AlreadyConnectedException(
message : String
);

Parameters

message System.String


AlreadyConnectedException.AlreadyConnectedException() Constructor (Microsoft.DirectX.DirectPlay)

AlreadyConnectedException.AlreadyConnectedException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AlreadyConnectedException();
C++ public:
AlreadyConnectedException();
JScript | public function AlreadyConnectedException();


AlreadyDisconnectingException Class (Microsoft.DirectX.DirectPlay)

AlreadyDisconnectingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The client is already disconnecting from the session. Deprecated.

Definition

Visual Basic Public Class AlreadyDisconnectingException
Inherits DirectPlayException
C# | public class AlreadyDisconnectingException : DirectPlayException
C++ | public ref class AlreadyDisconnectingException : DirectPlayException
JScript | public class AlreadyDisconnectingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyDisconnectingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AlreadyDisconnectingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AlreadyDisconnectingException.AlreadyDisconnectingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyDisconnectingException();
protected AlreadyDisconnectingException(SerializationInfo, StreamingContext);
public AlreadyDisconnectingException(string);
public AlreadyDisconnectingException(string, Exception);


AlreadyDisconnectingException.AlreadyDisconnectingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyDisconnectingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AlreadyDisconnectingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AlreadyDisconnectingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AlreadyDisconnectingException.AlreadyDisconnectingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyDisconnectingException(
string message,
Exception inner
);
C++ public:
AlreadyDisconnectingException(
String^ message,
Exception^ inner
);
JScript public function AlreadyDisconnectingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AlreadyDisconnectingException.AlreadyDisconnectingException(String) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AlreadyDisconnectingException(
string message
);
C++ public:
AlreadyDisconnectingException(
String^ message
);
JScript public function AlreadyDisconnectingException(
message : String
);

Parameters

message System.String


AlreadyDisconnectingException.AlreadyDisconnectingException() Constructor (Microsoft.DirectX.DirectPlay)

AlreadyDisconnectingException.AlreadyDisconnectingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AlreadyDisconnectingException();
C++ public:
AlreadyDisconnectingException();
JScript | public function AlreadyDisconnectingException();


AlreadyRegisteredException Class (Microsoft.DirectX.DirectPlay)

AlreadyRegisteredException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object has already been registered. Deprecated.

Definition

Visual Basic Public Class AlreadyRegisteredException
Inherits DirectPlayException
C# | public class AlreadyRegisteredException : DirectPlayException
C++ | public ref class AlreadyRegisteredException : DirectPlayException
JScript | public class AlreadyRegisteredException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AlreadyRegisteredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AlreadyRegisteredException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AlreadyRegisteredException.AlreadyRegisteredException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public AlreadyRegisteredException();
protected AlreadyRegisteredException(SerializationInfo, StreamingContext);
public AlreadyRegisteredException(string);
public AlreadyRegisteredException(string, Exception);


AlreadyRegisteredException.AlreadyRegisteredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AlreadyRegisteredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AlreadyRegisteredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AlreadyRegisteredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


AlreadyRegisteredException.AlreadyRegisteredException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AlreadyRegisteredException(
string message,
Exception inner
);
C++ public:
AlreadyRegisteredException(
String^ message,
Exception^ inner
);
JScript public function AlreadyRegisteredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


AlreadyRegisteredException.AlreadyRegisteredException(String) Constructor (Microsoft.DirectX.DirectPlay)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AlreadyRegisteredException(
string message
);
C++ public:
AlreadyRegisteredException(
String^ message
);
JScript public function AlreadyRegisteredException(
message : String
);

Parameters

message System.String


AlreadyRegisteredException.AlreadyRegisteredException() Constructor (Microsoft.DirectX.DirectPlay)

AlreadyRegisteredException.AlreadyRegisteredException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AlreadyRegisteredException();
C++ public:
AlreadyRegisteredException();
JScript | public function AlreadyRegisteredException();


AsyncOperationCompleteEventArgs Class (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the AsyncOperationComplete event. Deprecated.

Definition

Visual Basic NotInheritable Public Class AsyncOperationCompleteEventArgs
Inherits EventArgs
C# | public sealed class AsyncOperationCompleteEventArgs : EventArgs
C++ | public ref class AsyncOperationCompleteEventArgs sealed : EventArgs
JScript | public final class AsyncOperationCompleteEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
AsyncOperationCompleteEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
AsyncOperationCompleteEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AsyncOperationCompleteEventArgs.AsyncOperationCompleteEventArgs(AsyncOperationCompleteMessage) Constructor (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteEventArgs.AsyncOperationCompleteEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As AsyncOperationCompleteMessage _
)
C# public AsyncOperationCompleteEventArgs(
AsyncOperationCompleteMessage dpMessage
);
C++ public:
AsyncOperationCompleteEventArgs(
AsyncOperationCompleteMessage dpMessage
);
JScript public function AsyncOperationCompleteEventArgs(
dpMessage : AsyncOperationCompleteMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.AsyncOperationCompleteMessage


AsyncOperationCompleteEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As AsyncOperationCompleteMessage
C# | public AsyncOperationCompleteMessage Message;
C++ | public: AsyncOperationCompleteMessage Message;
JScript | public var Message : AsyncOperationCompleteMessage

Field Value

Microsoft.DirectX.DirectPlay.AsyncOperationCompleteMessage

This field is read/write.


CannotCancelException Class (Microsoft.DirectX.DirectPlay)

CannotCancelException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not be canceled. Deprecated.

Definition

Visual Basic Public Class CannotCancelException
Inherits DirectPlayException
C# | public class CannotCancelException : DirectPlayException
C++ | public ref class CannotCancelException : DirectPlayException
JScript | public class CannotCancelException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCancelException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
CannotCancelException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotCancelException.CannotCancelException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCancelException();
protected CannotCancelException(SerializationInfo, StreamingContext);
public CannotCancelException(string);
public CannotCancelException(string, Exception);


CannotCancelException.CannotCancelException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

CannotCancelException.CannotCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCancelException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotCancelException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotCancelException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotCancelException.CannotCancelException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

CannotCancelException.CannotCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCancelException(
string message,
Exception inner
);
C++ public:
CannotCancelException(
String^ message,
Exception^ inner
);
JScript public function CannotCancelException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotCancelException.CannotCancelException(String) Constructor (Microsoft.DirectX.DirectPlay)

CannotCancelException.CannotCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotCancelException(
string message
);
C++ public:
CannotCancelException(
String^ message
);
JScript public function CannotCancelException(
message : String
);

Parameters

message System.String


CannotCancelException.CannotCancelException() Constructor (Microsoft.DirectX.DirectPlay)

CannotCancelException.CannotCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotCancelException();
C++ public:
CannotCancelException();
JScript | public function CannotCancelException();


CannotCreateGroupException Class (Microsoft.DirectX.DirectPlay)

CannotCreateGroupException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A new group cannot be created. Deprecated.

Definition

Visual Basic Public Class CannotCreateGroupException
Inherits DirectPlayException
C# | public class CannotCreateGroupException : DirectPlayException
C++ | public ref class CannotCreateGroupException : DirectPlayException
JScript | public class CannotCreateGroupException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCreateGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
CannotCreateGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotCreateGroupException.CannotCreateGroupException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCreateGroupException();
protected CannotCreateGroupException(SerializationInfo, StreamingContext);
public CannotCreateGroupException(string);
public CannotCreateGroupException(string, Exception);


CannotCreateGroupException.CannotCreateGroupException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCreateGroupException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotCreateGroupException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotCreateGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotCreateGroupException.CannotCreateGroupException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCreateGroupException(
string message,
Exception inner
);
C++ public:
CannotCreateGroupException(
String^ message,
Exception^ inner
);
JScript public function CannotCreateGroupException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotCreateGroupException.CannotCreateGroupException(String) Constructor (Microsoft.DirectX.DirectPlay)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotCreateGroupException(
string message
);
C++ public:
CannotCreateGroupException(
String^ message
);
JScript public function CannotCreateGroupException(
message : String
);

Parameters

message System.String


CannotCreateGroupException.CannotCreateGroupException() Constructor (Microsoft.DirectX.DirectPlay)

CannotCreateGroupException.CannotCreateGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotCreateGroupException();
C++ public:
CannotCreateGroupException();
JScript | public function CannotCreateGroupException();


CannotCreatePlayerException Class (Microsoft.DirectX.DirectPlay)

CannotCreatePlayerException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A new player cannot be created. Deprecated.

Definition

Visual Basic Public Class CannotCreatePlayerException
Inherits DirectPlayException
C# | public class CannotCreatePlayerException : DirectPlayException
C++ | public ref class CannotCreatePlayerException : DirectPlayException
JScript | public class CannotCreatePlayerException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotCreatePlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
CannotCreatePlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotCreatePlayerException.CannotCreatePlayerException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotCreatePlayerException();
protected CannotCreatePlayerException(SerializationInfo, StreamingContext);
public CannotCreatePlayerException(string);
public CannotCreatePlayerException(string, Exception);


CannotCreatePlayerException.CannotCreatePlayerException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotCreatePlayerException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotCreatePlayerException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotCreatePlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotCreatePlayerException.CannotCreatePlayerException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotCreatePlayerException(
string message,
Exception inner
);
C++ public:
CannotCreatePlayerException(
String^ message,
Exception^ inner
);
JScript public function CannotCreatePlayerException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotCreatePlayerException.CannotCreatePlayerException(String) Constructor (Microsoft.DirectX.DirectPlay)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotCreatePlayerException(
string message
);
C++ public:
CannotCreatePlayerException(
String^ message
);
JScript public function CannotCreatePlayerException(
message : String
);

Parameters

message System.String


CannotCreatePlayerException.CannotCreatePlayerException() Constructor (Microsoft.DirectX.DirectPlay)

CannotCreatePlayerException.CannotCreatePlayerException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotCreatePlayerException();
C++ public:
CannotCreatePlayerException();
JScript | public function CannotCreatePlayerException();


CannotLaunchApplicationException Class (Microsoft.DirectX.DirectPlay)

CannotLaunchApplicationException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The lobby cannot launch the specified application. Deprecated.

Definition

Visual Basic Public Class CannotLaunchApplicationException
Inherits DirectPlayException
C# | public class CannotLaunchApplicationException : DirectPlayException
C++ | public ref class CannotLaunchApplicationException : DirectPlayException
JScript | public class CannotLaunchApplicationException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
CannotLaunchApplicationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
CannotLaunchApplicationException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CannotLaunchApplicationException.CannotLaunchApplicationException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public CannotLaunchApplicationException();
protected CannotLaunchApplicationException(SerializationInfo, StreamingContext);
public CannotLaunchApplicationException(string);
public CannotLaunchApplicationException(string, Exception);


CannotLaunchApplicationException.CannotLaunchApplicationException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected CannotLaunchApplicationException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
CannotLaunchApplicationException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function CannotLaunchApplicationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


CannotLaunchApplicationException.CannotLaunchApplicationException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public CannotLaunchApplicationException(
string message,
Exception inner
);
C++ public:
CannotLaunchApplicationException(
String^ message,
Exception^ inner
);
JScript public function CannotLaunchApplicationException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


CannotLaunchApplicationException.CannotLaunchApplicationException(String) Constructor (Microsoft.DirectX.DirectPlay)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public CannotLaunchApplicationException(
string message
);
C++ public:
CannotLaunchApplicationException(
String^ message
);
JScript public function CannotLaunchApplicationException(
message : String
);

Parameters

message System.String


CannotLaunchApplicationException.CannotLaunchApplicationException() Constructor (Microsoft.DirectX.DirectPlay)

CannotLaunchApplicationException.CannotLaunchApplicationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CannotLaunchApplicationException();
C++ public:
CannotLaunchApplicationException();
JScript | public function CannotLaunchApplicationException();


Client Class (Microsoft.DirectX.DirectPlay)

Client Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Warning: This interface has been deprecated.
Applications use the methods of the Client object to create and manage client applications for client/server sessions. Deprecated.

Definition

Visual Basic Public Class Client
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Client : MarshalByRefObject, IDisposable
C++ | public ref class Client : MarshalByRefObject, IDisposable
JScript | public class Client extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
ApplicationDescriptionChanged
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.
AsyncOperationComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an async operation has completed. Deprecated.
ClientInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.
ConnectComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has completed. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
FindHostResponse
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a host responds to a FindHosts call. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the client receives data. Deprecated.
SendComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.
ServerInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the data set for the server set by the call to the method. Deprecated.
SessionTerminated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been terminated. Deprecated.

Methods

Method Description
CancelAsyncOperation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.
Client
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
FindHosts
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.
GetConnectionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local client and the server. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetSendQueueInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Microsoft® DirectPlay® does not send messages faster than the receiving computer can process them. As a result, if the sending computer is sending faster than the receiver can receive, messages accumulate in the sender's queue. If the application registers that the send queue is growing too large, it should decrease the rate that messages are sent. Deprecated.
GetServerAddress
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address of the server for the session. Deprecated.
GetServerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the data set for the server set by the call to the method. Deprecated.
GetServiceProviders
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.
GetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the DpnSpCapsDplay structure for the specified service provider. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_ApplicationDescriptionChanged
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_AsyncOperationComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ClientInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ConnectComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_FindHostResponse
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SendComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ServerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionTerminated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RegisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Send
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.
SetClientInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.
SetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the DpnSpCapsDplay structure for the specified service provider. Deprecated.
UnregisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ApplicationDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the full application description for the connected application. Deprecated.
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Client object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Client

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Client.CancelAsyncOperation Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Overload List

public void CancelAsyncOperation(CancelFlags);
public void CancelAsyncOperation(int);


Client.CancelAsyncOperation(Int32) Method (Microsoft.DirectX.DirectPlay)

Client.CancelAsyncOperation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Definition

Visual Basic Public Sub CancelAsyncOperation( _
ByVal asyncHandle As Integer _
)
C# public void CancelAsyncOperation(
int asyncHandle
);
C++ public:
void CancelAsyncOperation(
int asyncHandle
);
JScript public function CancelAsyncOperation(
asyncHandle : int
);

Parameters

asyncHandle System.Int32


Client.CancelAsyncOperation(CancelFlags) Method (Microsoft.DirectX.DirectPlay)

Client.CancelAsyncOperation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Definition

Visual Basic Public Sub CancelAsyncOperation( _
ByVal flags As CancelFlags _
)
C# public void CancelAsyncOperation(
CancelFlags flags
);
C++ public:
void CancelAsyncOperation(
CancelFlags flags
);
JScript public function CancelAsyncOperation(
flags : CancelFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.CancelFlags


Client.Client(InitializeFlags) Constructor (Microsoft.DirectX.DirectPlay)

Client.Client Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Client(
InitializeFlags flags
);
C++ public:
Client(
InitializeFlags flags
);
JScript public function Client(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags


Client.Client() Constructor (Microsoft.DirectX.DirectPlay)

Client.Client Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Client();
C++ public:
Client();
JScript | public function Client();


Client.Connect Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Overload List

public void Connect(ApplicationDescription, Address, Address, NetworkPacket, ConnectFlags);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, ConnectFlags, object);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, out int, ConnectFlags);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, out int, ConnectFlags, object);


Client.Connect(ApplicationDescription,Address,Address,NetworkPacket,ConnectFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByVal flags As ConnectFlags, _
ByVal userContext As Object _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
ConnectFlags flags,
object userContext
);
C++ public:
void Connect(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userConnectData,
ConnectFlags flags,
Object^ userContext
);
JScript public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
flags : ConnectFlags,
userContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userConnectData Microsoft.DirectX.DirectPlay.NetworkPacket
flags Microsoft.DirectX.DirectPlay.ConnectFlags
userContext System.Object


Client.Connect(ApplicationDescription,Address,Address,NetworkPacket,Int32,ConnectFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByRef asyncHandle As Integer, _
ByVal flags As ConnectFlags, _
ByVal userContext As Object _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
out int asyncHandle,
ConnectFlags flags,
object userContext
);
C++ public:
void Connect(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userConnectData,
[Out] int% asyncHandle,
ConnectFlags flags,
Object^ userContext
);
JScript public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
asyncHandle : int,
flags : ConnectFlags,
userContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userConnectData Microsoft.DirectX.DirectPlay.NetworkPacket
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.ConnectFlags
userContext System.Object


Client.Connect(ApplicationDescription,Address,Address,NetworkPacket,ConnectFlags) Method (Microsoft.DirectX.DirectPlay)

Client.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByVal flags As ConnectFlags _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
ConnectFlags flags
);
C++ public:
void Connect(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userConnectData,
ConnectFlags flags
);
JScript public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
flags : ConnectFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userConnectData Microsoft.DirectX.DirectPlay.NetworkPacket
flags Microsoft.DirectX.DirectPlay.ConnectFlags


Client.Connect(ApplicationDescription,Address,Address,NetworkPacket,Int32,ConnectFlags) Method (Microsoft.DirectX.DirectPlay)

Client.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to the server. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByRef asyncHandle As Integer, _
ByVal flags As ConnectFlags _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
out int asyncHandle,
ConnectFlags flags
);
C++ public:
void Connect(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userConnectData,
[Out] int% asyncHandle,
ConnectFlags flags
);
JScript public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
asyncHandle : int,
flags : ConnectFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userConnectData Microsoft.DirectX.DirectPlay.NetworkPacket
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.ConnectFlags


Client.Dispose Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Overload List

public override void Dispose();
public void Dispose(bool);

See Also

  • Client.Disposed
  • Client.Disposing


Client.Dispose(Boolean) Method (Microsoft.DirectX.DirectPlay)

Client.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic Public Sub Dispose( _
ByVal closeImmediate As Boolean _
)
C# public void Dispose(
bool closeImmediate
);
C++ public:
void Dispose(
bool closeImmediate
);
JScript public function Dispose(
closeImmediate : boolean
);

Parameters

closeImmediate System.Boolean

See Also

  • Client.Disposed
  • Client.Disposing


Client.Dispose() Method (Microsoft.DirectX.DirectPlay)

Client.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Client();
JScript | public override function Dispose();

See Also

  • Client.Disposed
  • Client.Disposing


Client.Equals(Object) Method (Microsoft.DirectX.DirectPlay)

Client.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Client.Finalize() Method (Microsoft.DirectX.DirectPlay)

Client.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Client();
C++ | !Client();
JScript | protected override function Finalize();


Client.FindHosts Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Overload List

public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, out int);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, out int, object);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, object);


Client.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.FindHosts Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByVal userContext As Object _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
object userContext
);
C++ public:
void FindHosts(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
Object^ userContext
);
JScript public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
userContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userEnumData Microsoft.DirectX.DirectPlay.NetworkPacket
count System.Int32
retryInterval System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.FindHostsFlags
userContext System.Object


Client.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Int32,Object) Method (Microsoft.DirectX.DirectPlay)

Client.FindHosts Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByRef asyncHandle As Integer, _
ByVal userContext As Object _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
out int asyncHandle,
object userContext
);
C++ public:
void FindHosts(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
[Out] int% asyncHandle,
Object^ userContext
);
JScript public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
asyncHandle : int,
userContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userEnumData Microsoft.DirectX.DirectPlay.NetworkPacket
count System.Int32
retryInterval System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.FindHostsFlags
asyncHandle System.Int32
userContext System.Object


Client.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags) Method (Microsoft.DirectX.DirectPlay)

Client.FindHosts Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags
);
C++ public:
void FindHosts(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags
);
JScript public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userEnumData Microsoft.DirectX.DirectPlay.NetworkPacket
count System.Int32
retryInterval System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.FindHostsFlags


Client.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Int32) Method (Microsoft.DirectX.DirectPlay)

Client.FindHosts Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Finds applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByRef asyncHandle As Integer _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
out int asyncHandle
);
C++ public:
void FindHosts(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
[Out] int% asyncHandle
);
JScript public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
asyncHandle : int
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userEnumData Microsoft.DirectX.DirectPlay.NetworkPacket
count System.Int32
retryInterval System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.FindHostsFlags
asyncHandle System.Int32


Client.GetConnectionInformation() Method (Microsoft.DirectX.DirectPlay)

Client.GetConnectionInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local client and the server. Deprecated.

Definition

Visual Basic | Public Function GetConnectionInformation() As ConnectionInformation
C# | public ConnectionInformation GetConnectionInformation();
C++ public:
ConnectionInformation GetConnectionInformation();
JScript | public function GetConnectionInformation() : ConnectionInformation;

Return Value

Microsoft.DirectX.DirectPlay.ConnectionInformation


Client.GetHashCode() Method (Microsoft.DirectX.DirectPlay)

Client.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Client.GetSendQueueInformation(Int32,Int32,GetSendQueueInformationFlags) Method (Microsoft.DirectX.DirectPlay)

Client.GetSendQueueInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Microsoft® DirectPlay® does not send messages faster than the receiving computer can process them. As a result, if the sending computer is sending faster than the receiver can receive, messages accumulate in the sender's queue. If the application registers that the send queue is growing too large, it should decrease the rate that messages are sent. Deprecated.

Definition

Visual Basic Public Sub GetSendQueueInformation( _
ByRef numberMessages As Integer, _
ByRef numberBytes As Integer, _
ByVal flags As GetSendQueueInformationFlags _
)
C# public void GetSendQueueInformation(
out int numberMessages,
out int numberBytes,
GetSendQueueInformationFlags flags
);
C++ public:
void GetSendQueueInformation(
[Out] int% numberMessages,
[Out] int% numberBytes,
GetSendQueueInformationFlags flags
);
JScript public function GetSendQueueInformation(
numberMessages : int,
numberBytes : int,
flags : GetSendQueueInformationFlags
);

Parameters

numberMessages System.Int32
numberBytes System.Int32
flags Microsoft.DirectX.DirectPlay.GetSendQueueInformationFlags


Client.GetServerAddress() Method (Microsoft.DirectX.DirectPlay)

Client.GetServerAddress Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address of the server for the session. Deprecated.

Definition

Visual Basic | Public Function GetServerAddress() As Address
C# | public Address GetServerAddress();
C++ public:
Address^ GetServerAddress();
JScript | public function GetServerAddress() : Address;

Return Value

Microsoft.DirectX.DirectPlay.Address


Client.GetServerInformation() Method (Microsoft.DirectX.DirectPlay)

Client.GetServerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the data set for the server set by the call to the method. Deprecated.

Definition

Visual Basic | Public Function GetServerInformation() As PlayerInformation
C# | public PlayerInformation GetServerInformation();
C++ public:
PlayerInformation GetServerInformation();
JScript | public function GetServerInformation() : PlayerInformation;

Return Value

Microsoft.DirectX.DirectPlay.PlayerInformation


Client.GetServiceProviders Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Overload List

public ServiceProviderInformation[] GetServiceProviders(bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, Guid, bool);


Client.GetServiceProviders(Boolean) Method (Microsoft.DirectX.DirectPlay)

Client.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
bool getAll
);
JScript public function GetServiceProviders(
getAll : boolean
) : ServiceProviderInformation[];

Parameters

getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Client.GetServiceProviders(Guid,Boolean) Method (Microsoft.DirectX.DirectPlay)

Client.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
JScript public function GetServiceProviders(
guidServiceProvider : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider System.Guid
getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Client.GetServiceProviders(Guid,Guid,Boolean) Method (Microsoft.DirectX.DirectPlay)

Client.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal guidApplication As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
JScript public function GetServiceProviders(
guidServiceProvider : Guid,
guidApplication : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider System.Guid
guidApplication System.Guid
getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Client.GetSPCaps(Guid) Method (Microsoft.DirectX.DirectPlay)

Client.GetSPCaps Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the DpnSpCapsDplay structure for the specified service provider. Deprecated.

Definition

Visual Basic Public Function GetSPCaps( _
ByVal guidServiceProvider As Guid _
) As ServiceProviderCaps
C# public ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
C++ public:
ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
JScript public function GetSPCaps(
guidServiceProvider : Guid
) : ServiceProviderCaps;

Parameters

guidServiceProvider System.Guid

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderCaps


Client.op_Equality(Client,Client) Method (Microsoft.DirectX.DirectPlay)

Client.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Equality(
Client left,
Client right
);
C++ public:
static bool operator==(
Client^ left,
Client^ right
);
JScript public static function op_Equality(
left : Client,
right : Client
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Client
The Client structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Client
The Client structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Client.op_Inequality(Client,Client) Method (Microsoft.DirectX.DirectPlay)

Client.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Client, _
ByVal right As Client _
) As Boolean
C# public static bool op_Inequality(
Client left,
Client right
);
C++ public:
static bool operator!=(
Client^ left,
Client^ right
);
JScript public static function op_Inequality(
left : Client,
right : Client
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Client
The Client structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Client
The Client structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Client.raise_ApplicationDescriptionChanged(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_ApplicationDescriptionChanged Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ApplicationDescriptionChanged( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_ApplicationDescriptionChanged(
object i1,
EventArgs i2
);
C++ protected:
void raise_ApplicationDescriptionChanged(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_ApplicationDescriptionChanged(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Client.raise_AsyncOperationComplete(Object,AsyncOperationCompleteEventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_AsyncOperationComplete Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_AsyncOperationComplete( _
ByVal i1 As Object, _
ByVal i2 As AsyncOperationCompleteEventArgs _
)
C# protected void raise_AsyncOperationComplete(
object i1,
AsyncOperationCompleteEventArgs i2
);
C++ protected:
void raise_AsyncOperationComplete(
Object^ i1,
AsyncOperationCompleteEventArgs^ i2
);
JScript protected function raise_AsyncOperationComplete(
i1 : Object,
i2 : AsyncOperationCompleteEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs


Client.raise_ClientInformation(Object,ClientInformationEventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_ClientInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ClientInformation( _
ByVal i1 As Object, _
ByVal i2 As ClientInformationEventArgs _
)
C# protected void raise_ClientInformation(
object i1,
ClientInformationEventArgs i2
);
C++ protected:
void raise_ClientInformation(
Object^ i1,
ClientInformationEventArgs^ i2
);
JScript protected function raise_ClientInformation(
i1 : Object,
i2 : ClientInformationEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ClientInformationEventArgs


Client.raise_ConnectComplete(Object,ConnectCompleteEventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_ConnectComplete Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ConnectComplete( _
ByVal i1 As Object, _
ByVal i2 As ConnectCompleteEventArgs _
)
C# protected void raise_ConnectComplete(
object i1,
ConnectCompleteEventArgs i2
);
C++ protected:
void raise_ConnectComplete(
Object^ i1,
ConnectCompleteEventArgs^ i2
);
JScript protected function raise_ConnectComplete(
i1 : Object,
i2 : ConnectCompleteEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ConnectCompleteEventArgs


Client.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Client.raise_FindHostResponse(Object,FindHostResponseEventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_FindHostResponse Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_FindHostResponse( _
ByVal i1 As Object, _
ByVal i2 As FindHostResponseEventArgs _
)
C# protected void raise_FindHostResponse(
object i1,
FindHostResponseEventArgs i2
);
C++ protected:
void raise_FindHostResponse(
Object^ i1,
FindHostResponseEventArgs^ i2
);
JScript protected function raise_FindHostResponse(
i1 : Object,
i2 : FindHostResponseEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.FindHostResponseEventArgs


Client.raise_Receive(Object,ReceiveEventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_Receive Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
C++ protected:
void raise_Receive(
Object^ i1,
ReceiveEventArgs^ i2
);
JScript protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ReceiveEventArgs


Client.raise_SendComplete(Object,SendCompleteEventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_SendComplete Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SendComplete( _
ByVal i1 As Object, _
ByVal i2 As SendCompleteEventArgs _
)
C# protected void raise_SendComplete(
object i1,
SendCompleteEventArgs i2
);
C++ protected:
void raise_SendComplete(
Object^ i1,
SendCompleteEventArgs^ i2
);
JScript protected function raise_SendComplete(
i1 : Object,
i2 : SendCompleteEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.SendCompleteEventArgs


Client.raise_ServerInformation(Object,ServerInformationEventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_ServerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ServerInformation( _
ByVal i1 As Object, _
ByVal i2 As ServerInformationEventArgs _
)
C# protected void raise_ServerInformation(
object i1,
ServerInformationEventArgs i2
);
C++ protected:
void raise_ServerInformation(
Object^ i1,
ServerInformationEventArgs^ i2
);
JScript protected function raise_ServerInformation(
i1 : Object,
i2 : ServerInformationEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ServerInformationEventArgs


Client.raise_SessionTerminated(Object,SessionTerminatedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Client.raise_SessionTerminated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SessionTerminated( _
ByVal i1 As Object, _
ByVal i2 As SessionTerminatedEventArgs _
)
C# protected void raise_SessionTerminated(
object i1,
SessionTerminatedEventArgs i2
);
C++ protected:
void raise_SessionTerminated(
Object^ i1,
SessionTerminatedEventArgs^ i2
);
JScript protected function raise_SessionTerminated(
i1 : Object,
i2 : SessionTerminatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.SessionTerminatedEventArgs


Client.RegisterLobby(Int32,Application) Method (Microsoft.DirectX.DirectPlay)

Client.RegisterLobby Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub RegisterLobby( _
ByVal handle As Integer, _
ByVal lobbiedApplication As Application _
)
C# public void RegisterLobby(
int handle,
Application lobbiedApplication
);
C++ public:
void RegisterLobby(
int handle,
Application^ lobbiedApplication
);
JScript public function RegisterLobby(
handle : int,
lobbiedApplication : Application
);

Parameters

handle System.Int32
lobbiedApplication Microsoft.DirectX.DirectPlay.Lobby.Application


Client.Send Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Overload List

public void Send(GCHandle, int, int, out int, SendFlags);
public void Send(GCHandle, int, int, out int, SendFlags, object);
public void Send(GCHandle, int, int, SendFlags);
public void Send(GCHandle, int, int, SendFlags, object);
public void Send(NetworkPacket, int, out int, SendFlags);
public void Send(NetworkPacket, int, out int, SendFlags, object);
public void Send(NetworkPacket, int, SendFlags);
public void Send(NetworkPacket, int, SendFlags, object);


Client.Send(GCHandle,Int32,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
C++ public:
void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags,
Object^ context
);
JScript public function Send(
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Client.Send(GCHandle,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
object context
);
C++ public:
void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
Object^ context
);
JScript public function Send(
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Client.Send(GCHandle,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
C++ public:
void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
JScript public function Send(
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags
);

Parameters

gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Client.Send(GCHandle,Int32,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags
);
C++ public:
void Send(
GCHandle gcbuffer,
int bufferSize,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags
);
JScript public function Send(
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Client.Send(NetworkPacket,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void Send(
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
C++ public:
void Send(
NetworkPacket^ sendData,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags,
Object^ context
);
JScript public function Send(
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Client.Send(NetworkPacket,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void Send(
NetworkPacket sendData,
int timeOut,
SendFlags flags,
object context
);
C++ public:
void Send(
NetworkPacket^ sendData,
int timeOut,
SendFlags flags,
Object^ context
);
JScript public function Send(
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Client.Send(NetworkPacket,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void Send(
NetworkPacket sendData,
int timeOut,
SendFlags flags
);
C++ public:
void Send(
NetworkPacket^ sendData,
int timeOut,
SendFlags flags
);
JScript public function Send(
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags
);

Parameters

sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Client.Send(NetworkPacket,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Client.Send Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to the server. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub Send( _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void Send(
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags
);
C++ public:
void Send(
NetworkPacket^ sendData,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags
);
JScript public function Send(
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Client.SetClientInformation Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Overload List

public void SetClientInformation(PlayerInformation, out int, SyncFlags);
public void SetClientInformation(PlayerInformation, out int, SyncFlags, object);
public void SetClientInformation(PlayerInformation, SyncFlags);
public void SetClientInformation(PlayerInformation, SyncFlags, object);


Client.SetClientInformation(PlayerInformation,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Client.SetClientInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic Public Sub SetClientInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags _
)
C# public void SetClientInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
C++ public:
void SetClientInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
JScript public function SetClientInformation(
playerInformation : PlayerInformation,
flags : SyncFlags
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags


Client.SetClientInformation(PlayerInformation,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Client.SetClientInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic Public Sub SetClientInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetClientInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void SetClientInformation(
PlayerInformation playerInformation,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function SetClientInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Client.SetClientInformation(PlayerInformation,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.SetClientInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic Public Sub SetClientInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetClientInformation(
PlayerInformation playerInformation,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetClientInformation(
PlayerInformation playerInformation,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetClientInformation(
playerInformation : PlayerInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Client.SetClientInformation(PlayerInformation,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Client.SetClientInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic Public Sub SetClientInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetClientInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetClientInformation(
PlayerInformation playerInformation,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetClientInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Client.SetSPCaps(Guid,ServiceProviderCaps) Method (Microsoft.DirectX.DirectPlay)

Client.SetSPCaps Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the DpnSpCapsDplay structure for the specified service provider. Deprecated.

Definition

Visual Basic Public Sub SetSPCaps( _
ByVal guidServiceProvider As Guid, _
ByVal value As ServiceProviderCaps _
)
C# public void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
C++ public:
void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
JScript public function SetSPCaps(
guidServiceProvider : Guid,
value : ServiceProviderCaps
);

Parameters

guidServiceProvider System.Guid
value Microsoft.DirectX.DirectPlay.ServiceProviderCaps


Client.UnregisterLobby() Method (Microsoft.DirectX.DirectPlay)

Client.UnregisterLobby Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Sub UnregisterLobby()
C# | public void UnregisterLobby();
C++ public:
void UnregisterLobby();
JScript | public function UnregisterLobby();


Client.ApplicationDescription Property (Microsoft.DirectX.DirectPlay)

Client.ApplicationDescription Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the full application description for the connected application. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ApplicationDescription As ApplicationDescription
C# | public ApplicationDescription ApplicationDescription { get; }
C++ public:
property ApplicationDescription ApplicationDescription {
ApplicationDescription get();
}
JScript | public function get ApplicationDescription() : ApplicationDescription

Property Value

Microsoft.DirectX.DirectPlay.ApplicationDescription

This property is read-only.


Client.Caps Property (Microsoft.DirectX.DirectPlay)

Client.Caps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Client object. Deprecated.

Definition

Visual Basic | Public Property Caps As Caps
C# | public Caps Caps { get; set; }
C++ public:
property Caps Caps {
Caps get();
void set(Caps value);
}
JScript public function get Caps() : Caps
public function set Caps(Caps);

Property Value

Microsoft.DirectX.DirectPlay.Caps

This property is read/write.


Client.Disposed Property (Microsoft.DirectX.DirectPlay)

Client.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Client.ApplicationDescriptionChanged Event (Microsoft.DirectX.DirectPlay)

Client.ApplicationDescriptionChanged Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.

Definition

Visual Basic | Public Event ApplicationDescriptionChanged As ApplicationDescriptionEventHandler
C# | public event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
C++ public:
event ApplicationDescriptionEventHandler^ ApplicationDescriptionChanged;
JScript | In JScript, you can use events, but you cannot define your own.


Client.AsyncOperationComplete Event (Microsoft.DirectX.DirectPlay)

Client.AsyncOperationComplete Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an async operation has completed. Deprecated.

Definition

Visual Basic | Public Event AsyncOperationComplete As AsyncOperationCompleteEventHandler
C# | public event AsyncOperationCompleteEventHandler AsyncOperationComplete;
C++ public:
event AsyncOperationCompleteEventHandler^ AsyncOperationComplete;
JScript | In JScript, you can use events, but you cannot define your own.


Client.ClientInformation Event (Microsoft.DirectX.DirectPlay)

Client.ClientInformation Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a client with an application. Call this method before connecting to relay basic player information to the application. When the client successfully connects with the application, the server can retrieve information obtained through this method by calling the method. Deprecated.

Definition

Visual Basic | Public Event ClientInformation As ClientInformationEventHandler
C# | public event ClientInformationEventHandler ClientInformation;
C++ public:
event ClientInformationEventHandler^ ClientInformation;
JScript | In JScript, you can use events, but you cannot define your own.


Client.ConnectComplete Event (Microsoft.DirectX.DirectPlay)

Client.ConnectComplete Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has completed. Deprecated.

Definition

Visual Basic | Public Event ConnectComplete As ConnectCompleteEventHandler
C# | public event ConnectCompleteEventHandler ConnectComplete;
C++ public:
event ConnectCompleteEventHandler^ ConnectComplete;
JScript | In JScript, you can use events, but you cannot define your own.


Client.Disposing Event (Microsoft.DirectX.DirectPlay)

Client.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Client.Disposing event, use the following code.

client.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Client.FindHostResponse Event (Microsoft.DirectX.DirectPlay)

Client.FindHostResponse Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a host responds to a FindHosts call. Deprecated.

Definition

Visual Basic | Public Event FindHostResponse As FindHostResponseEventHandler
C# | public event FindHostResponseEventHandler FindHostResponse;
C++ public:
event FindHostResponseEventHandler^ FindHostResponse;
JScript | In JScript, you can use events, but you cannot define your own.


Client.Receive Event (Microsoft.DirectX.DirectPlay)

Client.Receive Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the client receives data. Deprecated.

Definition

Visual Basic | Public Event Receive As ReceiveEventHandler
C# | public event ReceiveEventHandler Receive;
C++ public:
event ReceiveEventHandler^ Receive;
JScript | In JScript, you can use events, but you cannot define your own.


Client.SendComplete Event (Microsoft.DirectX.DirectPlay)

Client.SendComplete Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.

Definition

Visual Basic | Public Event SendComplete As SendCompleteEventHandler
C# | public event SendCompleteEventHandler SendComplete;
C++ public:
event SendCompleteEventHandler^ SendComplete;
JScript | In JScript, you can use events, but you cannot define your own.


Client.ServerInformation Event (Microsoft.DirectX.DirectPlay)

Client.ServerInformation Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the data set for the server set by the call to the method. Deprecated.

Definition

Visual Basic | Public Event ServerInformation As ServerInformationEventHandler
C# | public event ServerInformationEventHandler ServerInformation;
C++ public:
event ServerInformationEventHandler^ ServerInformation;
JScript | In JScript, you can use events, but you cannot define your own.


Client.SessionTerminated Event (Microsoft.DirectX.DirectPlay)

Client.SessionTerminated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been terminated. Deprecated.

Definition

Visual Basic | Public Event SessionTerminated As SessionTerminatedEventHandler
C# | public event SessionTerminatedEventHandler SessionTerminated;
C++ public:
event SessionTerminatedEventHandler^ SessionTerminated;
JScript | In JScript, you can use events, but you cannot define your own.


ClientInformationEventArgs Class (Microsoft.DirectX.DirectPlay)

ClientInformationEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft DirectPlay generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class ClientInformationEventArgs
Inherits EventArgs
C# | public sealed class ClientInformationEventArgs : EventArgs
C++ | public ref class ClientInformationEventArgs sealed : EventArgs
JScript | public final class ClientInformationEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ClientInformationEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ClientInformationEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClientInformationEventArgs.ClientInformationEventArgs(ClientInformationMessage) Constructor (Microsoft.DirectX.DirectPlay)

ClientInformationEventArgs.ClientInformationEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As ClientInformationMessage _
)
C# public ClientInformationEventArgs(
ClientInformationMessage dpMessage
);
C++ public:
ClientInformationEventArgs(
ClientInformationMessage dpMessage
);
JScript public function ClientInformationEventArgs(
dpMessage : ClientInformationMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.ClientInformationMessage


ClientInformationEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

ClientInformationEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As ClientInformationMessage
C# | public ClientInformationMessage Message;
C++ | public: ClientInformationMessage Message;
JScript | public var Message : ClientInformationMessage

Field Value

Microsoft.DirectX.DirectPlay.ClientInformationMessage

This field is read/write.


ConnectCompleteEventArgs Class (Microsoft.DirectX.DirectPlay)

ConnectCompleteEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class ConnectCompleteEventArgs
Inherits EventArgs
C# | public sealed class ConnectCompleteEventArgs : EventArgs
C++ | public ref class ConnectCompleteEventArgs sealed : EventArgs
JScript | public final class ConnectCompleteEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ConnectCompleteEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ConnectCompleteEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectCompleteEventArgs.ConnectCompleteEventArgs(ConnectCompleteMessage) Constructor (Microsoft.DirectX.DirectPlay)

ConnectCompleteEventArgs.ConnectCompleteEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As ConnectCompleteMessage _
)
C# public ConnectCompleteEventArgs(
ConnectCompleteMessage dpMessage
);
C++ public:
ConnectCompleteEventArgs(
ConnectCompleteMessage dpMessage
);
JScript public function ConnectCompleteEventArgs(
dpMessage : ConnectCompleteMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.ConnectCompleteMessage


ConnectCompleteEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

ConnectCompleteEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As ConnectCompleteMessage
C# | public ConnectCompleteMessage Message;
C++ | public: ConnectCompleteMessage Message;
JScript | public var Message : ConnectCompleteMessage

Field Value

Microsoft.DirectX.DirectPlay.ConnectCompleteMessage

This field is read/write.


ConnectingException Class (Microsoft.DirectX.DirectPlay)

ConnectingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The method is in the process of connecting to the network. Deprecated.

Definition

Visual Basic Public Class ConnectingException
Inherits DirectPlayException
C# | public class ConnectingException : DirectPlayException
C++ | public ref class ConnectingException : DirectPlayException
JScript | public class ConnectingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
ConnectingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectingException.ConnectingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConnectingException();
protected ConnectingException(SerializationInfo, StreamingContext);
public ConnectingException(string);
public ConnectingException(string, Exception);


ConnectingException.ConnectingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

ConnectingException.ConnectingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConnectingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConnectingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ConnectingException.ConnectingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

ConnectingException.ConnectingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectingException(
string message,
Exception inner
);
C++ public:
ConnectingException(
String^ message,
Exception^ inner
);
JScript public function ConnectingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ConnectingException.ConnectingException(String) Constructor (Microsoft.DirectX.DirectPlay)

ConnectingException.ConnectingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConnectingException(
string message
);
C++ public:
ConnectingException(
String^ message
);
JScript public function ConnectingException(
message : String
);

Parameters

message System.String


ConnectingException.ConnectingException() Constructor (Microsoft.DirectX.DirectPlay)

ConnectingException.ConnectingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectingException();
C++ public:
ConnectingException();
JScript | public function ConnectingException();


ConnectionLostException Class (Microsoft.DirectX.DirectPlay)

ConnectionLostException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider connection was reset while data was being sent. Deprecated.

Definition

Visual Basic Public Class ConnectionLostException
Inherits DirectPlayException
C# | public class ConnectionLostException : DirectPlayException
C++ | public ref class ConnectionLostException : DirectPlayException
JScript | public class ConnectionLostException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConnectionLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
ConnectionLostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectionLostException.ConnectionLostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

ConnectionLostException.ConnectionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConnectionLostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConnectionLostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConnectionLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ConnectionLostException.ConnectionLostException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

ConnectionLostException.ConnectionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConnectionLostException(
string message,
Exception inner
);
C++ public:
ConnectionLostException(
String^ message,
Exception^ inner
);
JScript public function ConnectionLostException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ConnectionLostException.ConnectionLostException(String) Constructor (Microsoft.DirectX.DirectPlay)

ConnectionLostException.ConnectionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConnectionLostException(
string message
);
C++ public:
ConnectionLostException(
String^ message
);
JScript public function ConnectionLostException(
message : String
);

Parameters

message System.String


ConnectionLostException.ConnectionLostException() Constructor (Microsoft.DirectX.DirectPlay)

ConnectionLostException.ConnectionLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectionLostException();
C++ public:
ConnectionLostException();
JScript | public function ConnectionLostException();


ConversionException Class (Microsoft.DirectX.DirectPlay)

ConversionException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The data could not be converted. Deprecated.

Definition

Visual Basic Public Class ConversionException
Inherits DirectPlayException
C# | public class ConversionException : DirectPlayException
C++ | public ref class ConversionException : DirectPlayException
JScript | public class ConversionException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ConversionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
ConversionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConversionException.ConversionException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ConversionException();
protected ConversionException(SerializationInfo, StreamingContext);
public ConversionException(string);
public ConversionException(string, Exception);


ConversionException.ConversionException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

ConversionException.ConversionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ConversionException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ConversionException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ConversionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


ConversionException.ConversionException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

ConversionException.ConversionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ConversionException(
string message,
Exception inner
);
C++ public:
ConversionException(
String^ message,
Exception^ inner
);
JScript public function ConversionException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


ConversionException.ConversionException(String) Constructor (Microsoft.DirectX.DirectPlay)

ConversionException.ConversionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ConversionException(
string message
);
C++ public:
ConversionException(
String^ message
);
JScript public function ConversionException(
message : String
);

Parameters

message System.String


ConversionException.ConversionException() Constructor (Microsoft.DirectX.DirectPlay)

ConversionException.ConversionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConversionException();
C++ public:
ConversionException();
JScript | public function ConversionException();


DataTooLargeException Class (Microsoft.DirectX.DirectPlay)

DataTooLargeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The application data is too large for the service provider's Maximum Transmission Unit. Deprecated.

Definition

Visual Basic Public Class DataTooLargeException
Inherits DirectPlayException
C# | public class DataTooLargeException : DirectPlayException
C++ | public ref class DataTooLargeException : DirectPlayException
JScript | public class DataTooLargeException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DataTooLargeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
DataTooLargeException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DataTooLargeException.DataTooLargeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DataTooLargeException();
protected DataTooLargeException(SerializationInfo, StreamingContext);
public DataTooLargeException(string);
public DataTooLargeException(string, Exception);


DataTooLargeException.DataTooLargeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

DataTooLargeException.DataTooLargeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DataTooLargeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DataTooLargeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DataTooLargeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


DataTooLargeException.DataTooLargeException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

DataTooLargeException.DataTooLargeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DataTooLargeException(
string message,
Exception inner
);
C++ public:
DataTooLargeException(
String^ message,
Exception^ inner
);
JScript public function DataTooLargeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


DataTooLargeException.DataTooLargeException(String) Constructor (Microsoft.DirectX.DirectPlay)

DataTooLargeException.DataTooLargeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DataTooLargeException(
string message
);
C++ public:
DataTooLargeException(
String^ message
);
JScript public function DataTooLargeException(
message : String
);

Parameters

message System.String


DataTooLargeException.DataTooLargeException() Constructor (Microsoft.DirectX.DirectPlay)

DataTooLargeException.DataTooLargeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DataTooLargeException();
C++ public:
DataTooLargeException();
JScript | public function DataTooLargeException();


DirectPlayException Class (Microsoft.DirectX.DirectPlay)

DirectPlayException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Base exception type for all DirectPlay exceptions. Derives from DirectXException. Deprecated.

Definition

Visual Basic Public Class DirectPlayException
Inherits DirectXException
C# | public class DirectPlayException : DirectXException
C++ | public ref class DirectPlayException : DirectXException
JScript | public class DirectPlayException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DirectPlayException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
AbortedException
AddressingException
AlreadyClosingException
AlreadyConnectedException
AlreadyDisconnectingException
AlreadyRegisteredException
CannotCancelException
CannotCreateGroupException
CannotCreatePlayerException
CannotLaunchApplicationException
ConnectingException
ConnectionLostException
ConversionException
DataTooLargeException
DoesNotExistException
DuplicateCommandException
EndPointNotReceivingException
FindHostQueryTooLargeException
FindHostResponseTooLargeException
GroupNotEmptyException
HostingException
IncompleteAddressException
InvalidAddressFormatException
InvalidApplicationException
InvalidCommandException
InvalidDeviceAddressException
InvalidEndPointException
InvalidFlagsException
InvalidGroupException
InvalidHandleException
InvalidHostAddressException
InvalidInstanceException
InvalidObjectException
InvalidPasswordException
InvalidPlayerException
InvalidPriorityException
InvalidStringException
InvalidUrlException
InvalidVersionException
NoCapsException
NoConnectionException
NoHostPlayerException
NoMoreAddressComponentsException
NoResponseException
NotAllowedException
NotHostException
NotReadyException
NotRegisteredException
PlayerAlreadyInGroupException
PlayerLostException
PlayerNotInGroupException
PlayerNotReachableException
SendTooLargeException
SessionFullException
TableFullException
TimedOutException
UserCancelException
VoiceException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DirectPlayException.DirectPlayException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DirectPlayException();
protected DirectPlayException(SerializationInfo, StreamingContext);
public DirectPlayException(string);
public DirectPlayException(string, Exception);


DirectPlayException.DirectPlayException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

DirectPlayException.DirectPlayException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DirectPlayException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DirectPlayException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DirectPlayException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


DirectPlayException.DirectPlayException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

DirectPlayException.DirectPlayException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DirectPlayException(
string message,
Exception inner
);
C++ public:
DirectPlayException(
String^ message,
Exception^ inner
);
JScript public function DirectPlayException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


DirectPlayException.DirectPlayException(String) Constructor (Microsoft.DirectX.DirectPlay)

DirectPlayException.DirectPlayException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DirectPlayException(
string message
);
C++ public:
DirectPlayException(
String^ message
);
JScript public function DirectPlayException(
message : String
);

Parameters

message System.String


DirectPlayException.DirectPlayException() Constructor (Microsoft.DirectX.DirectPlay)

DirectPlayException.DirectPlayException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DirectPlayException();
C++ public:
DirectPlayException();
JScript | public function DirectPlayException();


DirectPlayException.GetExceptionFromResultInternal(Int32) Method (Microsoft.DirectX.DirectPlay)

DirectPlayException.GetExceptionFromResultInternal Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Shadows Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public new static Exception GetExceptionFromResultInternal(
int resultCode
);
C++ public:
static Exception^ GetExceptionFromResultInternal(
int resultCode
);
JScript public hide static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32

Return Value

System.Exception

Applies To

This object applies to a large number of classes.


DoesNotExistException Class (Microsoft.DirectX.DirectPlay)

DoesNotExistException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Requested element is not part of the address or the requested application globally unique identifier (Guid) is not registered. Deprecated.

Definition

Visual Basic Public Class DoesNotExistException
Inherits DirectPlayException
C# | public class DoesNotExistException : DirectPlayException
C++ | public ref class DoesNotExistException : DirectPlayException
JScript | public class DoesNotExistException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DoesNotExistException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
DoesNotExistException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DoesNotExistException.DoesNotExistException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DoesNotExistException();
protected DoesNotExistException(SerializationInfo, StreamingContext);
public DoesNotExistException(string);
public DoesNotExistException(string, Exception);


DoesNotExistException.DoesNotExistException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

DoesNotExistException.DoesNotExistException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DoesNotExistException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DoesNotExistException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DoesNotExistException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


DoesNotExistException.DoesNotExistException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

DoesNotExistException.DoesNotExistException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DoesNotExistException(
string message,
Exception inner
);
C++ public:
DoesNotExistException(
String^ message,
Exception^ inner
);
JScript public function DoesNotExistException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


DoesNotExistException.DoesNotExistException(String) Constructor (Microsoft.DirectX.DirectPlay)

DoesNotExistException.DoesNotExistException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DoesNotExistException(
string message
);
C++ public:
DoesNotExistException(
String^ message
);
JScript public function DoesNotExistException(
message : String
);

Parameters

message System.String


DoesNotExistException.DoesNotExistException() Constructor (Microsoft.DirectX.DirectPlay)

DoesNotExistException.DoesNotExistException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DoesNotExistException();
C++ public:
DoesNotExistException();
JScript | public function DoesNotExistException();


DuplicateCommandException Class (Microsoft.DirectX.DirectPlay)

DuplicateCommandException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A duplicate command has been issued. Deprecated.

Definition

Visual Basic Public Class DuplicateCommandException
Inherits DirectPlayException
C# | public class DuplicateCommandException : DirectPlayException
C++ | public ref class DuplicateCommandException : DirectPlayException
JScript | public class DuplicateCommandException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
DuplicateCommandException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
DuplicateCommandException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DuplicateCommandException.DuplicateCommandException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public DuplicateCommandException();
protected DuplicateCommandException(SerializationInfo, StreamingContext);
public DuplicateCommandException(string);
public DuplicateCommandException(string, Exception);


DuplicateCommandException.DuplicateCommandException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DuplicateCommandException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DuplicateCommandException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DuplicateCommandException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


DuplicateCommandException.DuplicateCommandException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DuplicateCommandException(
string message,
Exception inner
);
C++ public:
DuplicateCommandException(
String^ message,
Exception^ inner
);
JScript public function DuplicateCommandException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


DuplicateCommandException.DuplicateCommandException(String) Constructor (Microsoft.DirectX.DirectPlay)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DuplicateCommandException(
string message
);
C++ public:
DuplicateCommandException(
String^ message
);
JScript public function DuplicateCommandException(
message : String
);

Parameters

message System.String


DuplicateCommandException.DuplicateCommandException() Constructor (Microsoft.DirectX.DirectPlay)

DuplicateCommandException.DuplicateCommandException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DuplicateCommandException();
C++ public:
DuplicateCommandException();
JScript | public function DuplicateCommandException();


EndPointNotReceivingException Class (Microsoft.DirectX.DirectPlay)

EndPointNotReceivingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An end point is not receiving data. Deprecated.

Definition

Visual Basic Public Class EndPointNotReceivingException
Inherits DirectPlayException
C# | public class EndPointNotReceivingException : DirectPlayException
C++ | public ref class EndPointNotReceivingException : DirectPlayException
JScript | public class EndPointNotReceivingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
EndPointNotReceivingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
EndPointNotReceivingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EndPointNotReceivingException.EndPointNotReceivingException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public EndPointNotReceivingException();
protected EndPointNotReceivingException(SerializationInfo, StreamingContext);
public EndPointNotReceivingException(string);
public EndPointNotReceivingException(string, Exception);


EndPointNotReceivingException.EndPointNotReceivingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected EndPointNotReceivingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
EndPointNotReceivingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function EndPointNotReceivingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


EndPointNotReceivingException.EndPointNotReceivingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public EndPointNotReceivingException(
string message,
Exception inner
);
C++ public:
EndPointNotReceivingException(
String^ message,
Exception^ inner
);
JScript public function EndPointNotReceivingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


EndPointNotReceivingException.EndPointNotReceivingException(String) Constructor (Microsoft.DirectX.DirectPlay)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public EndPointNotReceivingException(
string message
);
C++ public:
EndPointNotReceivingException(
String^ message
);
JScript public function EndPointNotReceivingException(
message : String
);

Parameters

message System.String


EndPointNotReceivingException.EndPointNotReceivingException() Constructor (Microsoft.DirectX.DirectPlay)

EndPointNotReceivingException.EndPointNotReceivingException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public EndPointNotReceivingException();
C++ public:
EndPointNotReceivingException();
JScript | public function EndPointNotReceivingException();


FindHostQueryEventArgs Class (Microsoft.DirectX.DirectPlay)

FindHostQueryEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the FindHostQuery event. Deprecated.

Definition

Visual Basic NotInheritable Public Class FindHostQueryEventArgs
Inherits EventArgs
C# | public sealed class FindHostQueryEventArgs : EventArgs
C++ | public ref class FindHostQueryEventArgs sealed : EventArgs
JScript | public final class FindHostQueryEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
FindHostQueryEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
RejectMessage
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
FindHostQueryEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostQueryEventArgs.FindHostQueryEventArgs(FindHostsQueryMessage) Constructor (Microsoft.DirectX.DirectPlay)

FindHostQueryEventArgs.FindHostQueryEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As FindHostsQueryMessage _
)
C# public FindHostQueryEventArgs(
FindHostsQueryMessage dpMessage
);
C++ public:
FindHostQueryEventArgs(
FindHostsQueryMessage dpMessage
);
JScript public function FindHostQueryEventArgs(
dpMessage : FindHostsQueryMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.FindHostsQueryMessage


FindHostQueryEventArgs.RejectMessage Property (Microsoft.DirectX.DirectPlay)

FindHostQueryEventArgs.RejectMessage Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Definition

Visual Basic | Public Property RejectMessage As Boolean
C# | public bool RejectMessage { get; set; }
C++ public:
property bool RejectMessage {
bool get();
void set(bool value);
}
JScript public function get RejectMessage() : boolean
public function set RejectMessage(boolean);

Property Value

System.Boolean

This property is read/write.


FindHostQueryEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

FindHostQueryEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As FindHostsQueryMessage
C# | public FindHostsQueryMessage Message;
C++ | public: FindHostsQueryMessage Message;
JScript | public var Message : FindHostsQueryMessage

Field Value

Microsoft.DirectX.DirectPlay.FindHostsQueryMessage

This field is read/write.


FindHostQueryTooLargeException Class (Microsoft.DirectX.DirectPlay)

FindHostQueryTooLargeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The query data specified is too large. Deprecated.

Definition

Visual Basic Public Class FindHostQueryTooLargeException
Inherits DirectPlayException
C# | public class FindHostQueryTooLargeException : DirectPlayException
C++ | public ref class FindHostQueryTooLargeException : DirectPlayException
JScript | public class FindHostQueryTooLargeException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
FindHostQueryTooLargeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
FindHostQueryTooLargeException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public FindHostQueryTooLargeException();
protected FindHostQueryTooLargeException(SerializationInfo, StreamingContext);
public FindHostQueryTooLargeException(string);
public FindHostQueryTooLargeException(string, Exception);


FindHostQueryTooLargeException.FindHostQueryTooLargeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected FindHostQueryTooLargeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
FindHostQueryTooLargeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function FindHostQueryTooLargeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


FindHostQueryTooLargeException.FindHostQueryTooLargeException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public FindHostQueryTooLargeException(
string message,
Exception inner
);
C++ public:
FindHostQueryTooLargeException(
String^ message,
Exception^ inner
);
JScript public function FindHostQueryTooLargeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


FindHostQueryTooLargeException.FindHostQueryTooLargeException(String) Constructor (Microsoft.DirectX.DirectPlay)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public FindHostQueryTooLargeException(
string message
);
C++ public:
FindHostQueryTooLargeException(
String^ message
);
JScript public function FindHostQueryTooLargeException(
message : String
);

Parameters

message System.String


FindHostQueryTooLargeException.FindHostQueryTooLargeException() Constructor (Microsoft.DirectX.DirectPlay)

FindHostQueryTooLargeException.FindHostQueryTooLargeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public FindHostQueryTooLargeException();
C++ public:
FindHostQueryTooLargeException();
JScript | public function FindHostQueryTooLargeException();


FindHostResponseEventArgs Class (Microsoft.DirectX.DirectPlay)

FindHostResponseEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response to an enumeration query is too large. Deprecated.

Definition

Visual Basic NotInheritable Public Class FindHostResponseEventArgs
Inherits EventArgs
C# | public sealed class FindHostResponseEventArgs : EventArgs
C++ | public ref class FindHostResponseEventArgs sealed : EventArgs
JScript | public final class FindHostResponseEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
FindHostResponseEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
FindHostResponseEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostResponseEventArgs.FindHostResponseEventArgs(FindHostsResponseMessage) Constructor (Microsoft.DirectX.DirectPlay)

FindHostResponseEventArgs.FindHostResponseEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As FindHostsResponseMessage _
)
C# public FindHostResponseEventArgs(
FindHostsResponseMessage dpMessage
);
C++ public:
FindHostResponseEventArgs(
FindHostsResponseMessage dpMessage
);
JScript public function FindHostResponseEventArgs(
dpMessage : FindHostsResponseMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.FindHostsResponseMessage


FindHostResponseEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

FindHostResponseEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As FindHostsResponseMessage
C# | public FindHostsResponseMessage Message;
C++ | public: FindHostsResponseMessage Message;
JScript | public var Message : FindHostsResponseMessage

Field Value

Microsoft.DirectX.DirectPlay.FindHostsResponseMessage

This field is read/write.


FindHostResponseTooLargeException Class (Microsoft.DirectX.DirectPlay)

FindHostResponseTooLargeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response to an enumeration query is too large. Deprecated.

Definition

Visual Basic Public Class FindHostResponseTooLargeException
Inherits DirectPlayException
C# | public class FindHostResponseTooLargeException : DirectPlayException
C++ | public ref class FindHostResponseTooLargeException : DirectPlayException
JScript | public class FindHostResponseTooLargeException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
FindHostResponseTooLargeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
FindHostResponseTooLargeException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public FindHostResponseTooLargeException();
protected FindHostResponseTooLargeException(SerializationInfo, StreamingContext);
public FindHostResponseTooLargeException(string);
public FindHostResponseTooLargeException(string, Exception);


FindHostResponseTooLargeException.FindHostResponseTooLargeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected FindHostResponseTooLargeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
FindHostResponseTooLargeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function FindHostResponseTooLargeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


FindHostResponseTooLargeException.FindHostResponseTooLargeException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public FindHostResponseTooLargeException(
string message,
Exception inner
);
C++ public:
FindHostResponseTooLargeException(
String^ message,
Exception^ inner
);
JScript public function FindHostResponseTooLargeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


FindHostResponseTooLargeException.FindHostResponseTooLargeException(String) Constructor (Microsoft.DirectX.DirectPlay)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public FindHostResponseTooLargeException(
string message
);
C++ public:
FindHostResponseTooLargeException(
String^ message
);
JScript public function FindHostResponseTooLargeException(
message : String
);

Parameters

message System.String


FindHostResponseTooLargeException.FindHostResponseTooLargeException() Constructor (Microsoft.DirectX.DirectPlay)

FindHostResponseTooLargeException.FindHostResponseTooLargeException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public FindHostResponseTooLargeException();
C++ public:
FindHostResponseTooLargeException();
JScript | public function FindHostResponseTooLargeException();


GroupCreatedEventArgs Class (Microsoft.DirectX.DirectPlay)

GroupCreatedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the GroupCreated event. Deprecated.

Definition

Visual Basic NotInheritable Public Class GroupCreatedEventArgs
Inherits EventArgs
C# | public sealed class GroupCreatedEventArgs : EventArgs
C++ | public ref class GroupCreatedEventArgs sealed : EventArgs
JScript | public final class GroupCreatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
GroupCreatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
GroupCreatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupCreatedEventArgs.GroupCreatedEventArgs(CreateGroupMessage) Constructor (Microsoft.DirectX.DirectPlay)

GroupCreatedEventArgs.GroupCreatedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As CreateGroupMessage _
)
C# public GroupCreatedEventArgs(
CreateGroupMessage dpMessage
);
C++ public:
GroupCreatedEventArgs(
CreateGroupMessage dpMessage
);
JScript public function GroupCreatedEventArgs(
dpMessage : CreateGroupMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.CreateGroupMessage


GroupCreatedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

GroupCreatedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As CreateGroupMessage
C# | public CreateGroupMessage Message;
C++ | public: CreateGroupMessage Message;
JScript | public var Message : CreateGroupMessage

Field Value

Microsoft.DirectX.DirectPlay.CreateGroupMessage

This field is read/write.


GroupDestroyedEventArgs Class (Microsoft.DirectX.DirectPlay)

GroupDestroyedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the Group Destroyed event. Deprecated.

Definition

Visual Basic NotInheritable Public Class GroupDestroyedEventArgs
Inherits EventArgs
C# | public sealed class GroupDestroyedEventArgs : EventArgs
C++ | public ref class GroupDestroyedEventArgs sealed : EventArgs
JScript | public final class GroupDestroyedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
GroupDestroyedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
GroupDestroyedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupDestroyedEventArgs.GroupDestroyedEventArgs(DestroyGroupMessage) Constructor (Microsoft.DirectX.DirectPlay)

GroupDestroyedEventArgs.GroupDestroyedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As DestroyGroupMessage _
)
C# public GroupDestroyedEventArgs(
DestroyGroupMessage dpMessage
);
C++ public:
GroupDestroyedEventArgs(
DestroyGroupMessage dpMessage
);
JScript public function GroupDestroyedEventArgs(
dpMessage : DestroyGroupMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.DestroyGroupMessage


GroupDestroyedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

GroupDestroyedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As DestroyGroupMessage
C# | public DestroyGroupMessage Message;
C++ | public: DestroyGroupMessage Message;
JScript | public var Message : DestroyGroupMessage

Field Value

Microsoft.DirectX.DirectPlay.DestroyGroupMessage

This field is read/write.


GroupInformationEventArgs Class (Microsoft.DirectX.DirectPlay)

GroupInformationEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class GroupInformationEventArgs
Inherits EventArgs
C# | public sealed class GroupInformationEventArgs : EventArgs
C++ | public ref class GroupInformationEventArgs sealed : EventArgs
JScript | public final class GroupInformationEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
GroupInformationEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
GroupInformationEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupInformationEventArgs.GroupInformationEventArgs(GroupInformationMessage) Constructor (Microsoft.DirectX.DirectPlay)

GroupInformationEventArgs.GroupInformationEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As GroupInformationMessage _
)
C# public GroupInformationEventArgs(
GroupInformationMessage dpMessage
);
C++ public:
GroupInformationEventArgs(
GroupInformationMessage dpMessage
);
JScript public function GroupInformationEventArgs(
dpMessage : GroupInformationMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.GroupInformationMessage


GroupInformationEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

GroupInformationEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As GroupInformationMessage
C# | public GroupInformationMessage Message;
C++ | public: GroupInformationMessage Message;
JScript | public var Message : GroupInformationMessage

Field Value

Microsoft.DirectX.DirectPlay.GroupInformationMessage

This field is read/write.


GroupMembersList Class (Microsoft.DirectX.DirectPlay)

GroupMembersList Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A collection of group members. Deprecated.

Definition

Visual Basic NotInheritable Public Class GroupMembersList
Inherits Object
C# | public sealed class GroupMembersList : Object
C++ | public ref class GroupMembersList sealed : Object
JScript | public final class GroupMembersList extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Properties

Property Description
Item
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Inheritance Hierarchy

Object Leave Site
GroupMembersList

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupMembersList.Item Property (Microsoft.DirectX.DirectPlay)

GroupMembersList.Item Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal groupId As Integer _
) As PlayersGroupsEnumerator
C# public PlayersGroupsEnumerator this[
int groupId
] { get; }
C++ public:
property PlayersGroupsEnumerator^ default [int] {
PlayersGroupsEnumerator^ get(int groupId);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

groupId System.Int32

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator

This property is read-only.


GroupNotEmptyException Class (Microsoft.DirectX.DirectPlay)

GroupNotEmptyException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified group is not empty. Deprecated.

Definition

Visual Basic Public Class GroupNotEmptyException
Inherits DirectPlayException
C# | public class GroupNotEmptyException : DirectPlayException
C++ | public ref class GroupNotEmptyException : DirectPlayException
JScript | public class GroupNotEmptyException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
GroupNotEmptyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
GroupNotEmptyException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupNotEmptyException.GroupNotEmptyException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public GroupNotEmptyException();
protected GroupNotEmptyException(SerializationInfo, StreamingContext);
public GroupNotEmptyException(string);
public GroupNotEmptyException(string, Exception);


GroupNotEmptyException.GroupNotEmptyException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

GroupNotEmptyException.GroupNotEmptyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected GroupNotEmptyException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
GroupNotEmptyException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function GroupNotEmptyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


GroupNotEmptyException.GroupNotEmptyException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

GroupNotEmptyException.GroupNotEmptyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public GroupNotEmptyException(
string message,
Exception inner
);
C++ public:
GroupNotEmptyException(
String^ message,
Exception^ inner
);
JScript public function GroupNotEmptyException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


GroupNotEmptyException.GroupNotEmptyException(String) Constructor (Microsoft.DirectX.DirectPlay)

GroupNotEmptyException.GroupNotEmptyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public GroupNotEmptyException(
string message
);
C++ public:
GroupNotEmptyException(
String^ message
);
JScript public function GroupNotEmptyException(
message : String
);

Parameters

message System.String


GroupNotEmptyException.GroupNotEmptyException() Constructor (Microsoft.DirectX.DirectPlay)

GroupNotEmptyException.GroupNotEmptyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public GroupNotEmptyException();
C++ public:
GroupNotEmptyException();
JScript | public function GroupNotEmptyException();


HostingException Class (Microsoft.DirectX.DirectPlay)

HostingException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The session is already hosting. Deprecated.

Definition

Visual Basic Public Class HostingException
Inherits DirectPlayException
C# | public class HostingException : DirectPlayException
C++ | public ref class HostingException : DirectPlayException
JScript | public class HostingException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
HostingException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
HostingException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HostingException.HostingException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

HostingException.HostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected HostingException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
HostingException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function HostingException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


HostingException.HostingException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

HostingException.HostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public HostingException(
string message,
Exception inner
);
C++ public:
HostingException(
String^ message,
Exception^ inner
);
JScript public function HostingException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


HostingException.HostingException(String) Constructor (Microsoft.DirectX.DirectPlay)

HostingException.HostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public HostingException(
string message
);
C++ public:
HostingException(
String^ message
);
JScript public function HostingException(
message : String
);

Parameters

message System.String


HostingException.HostingException() Constructor (Microsoft.DirectX.DirectPlay)

HostingException.HostingException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public HostingException();
C++ public:
HostingException();
JScript | public function HostingException();


HostMigratedEventArgs Class (Microsoft.DirectX.DirectPlay)

HostMigratedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class HostMigratedEventArgs
Inherits EventArgs
C# | public sealed class HostMigratedEventArgs : EventArgs
C++ | public ref class HostMigratedEventArgs sealed : EventArgs
JScript | public final class HostMigratedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
HostMigratedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
HostMigratedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HostMigratedEventArgs.HostMigratedEventArgs(HostMigratedMessage) Constructor (Microsoft.DirectX.DirectPlay)

HostMigratedEventArgs.HostMigratedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As HostMigratedMessage _
)
C# public HostMigratedEventArgs(
HostMigratedMessage dpMessage
);
C++ public:
HostMigratedEventArgs(
HostMigratedMessage dpMessage
);
JScript public function HostMigratedEventArgs(
dpMessage : HostMigratedMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.HostMigratedMessage


HostMigratedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

HostMigratedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As HostMigratedMessage
C# | public HostMigratedMessage Message;
C++ | public: HostMigratedMessage Message;
JScript | public var Message : HostMigratedMessage

Field Value

Microsoft.DirectX.DirectPlay.HostMigratedMessage

This field is read/write.


IncompleteAddressException Class (Microsoft.DirectX.DirectPlay)

IncompleteAddressException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address specified is not complete. Deprecated.

Definition

Visual Basic Public Class IncompleteAddressException
Inherits DirectPlayException
C# | public class IncompleteAddressException : DirectPlayException
C++ | public ref class IncompleteAddressException : DirectPlayException
JScript | public class IncompleteAddressException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
IncompleteAddressException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
IncompleteAddressException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IncompleteAddressException.IncompleteAddressException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public IncompleteAddressException();
protected IncompleteAddressException(SerializationInfo, StreamingContext);
public IncompleteAddressException(string);
public IncompleteAddressException(string, Exception);


IncompleteAddressException.IncompleteAddressException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected IncompleteAddressException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
IncompleteAddressException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function IncompleteAddressException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


IncompleteAddressException.IncompleteAddressException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public IncompleteAddressException(
string message,
Exception inner
);
C++ public:
IncompleteAddressException(
String^ message,
Exception^ inner
);
JScript public function IncompleteAddressException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


IncompleteAddressException.IncompleteAddressException(String) Constructor (Microsoft.DirectX.DirectPlay)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public IncompleteAddressException(
string message
);
C++ public:
IncompleteAddressException(
String^ message
);
JScript public function IncompleteAddressException(
message : String
);

Parameters

message System.String


IncompleteAddressException.IncompleteAddressException() Constructor (Microsoft.DirectX.DirectPlay)

IncompleteAddressException.IncompleteAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public IncompleteAddressException();
C++ public:
IncompleteAddressException();
JScript | public function IncompleteAddressException();


IndicateConnectEventArgs Class (Microsoft.DirectX.DirectPlay)

IndicateConnectEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class IndicateConnectEventArgs
Inherits EventArgs
C# | public sealed class IndicateConnectEventArgs : EventArgs
C++ | public ref class IndicateConnectEventArgs sealed : EventArgs
JScript | public final class IndicateConnectEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
IndicateConnectEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
RejectMessage
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
IndicateConnectEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IndicateConnectEventArgs.IndicateConnectEventArgs(IndicateConnectMessage) Constructor (Microsoft.DirectX.DirectPlay)

IndicateConnectEventArgs.IndicateConnectEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As IndicateConnectMessage _
)
C# public IndicateConnectEventArgs(
IndicateConnectMessage dpMessage
);
C++ public:
IndicateConnectEventArgs(
IndicateConnectMessage dpMessage
);
JScript public function IndicateConnectEventArgs(
dpMessage : IndicateConnectMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.IndicateConnectMessage


IndicateConnectEventArgs.RejectMessage Property (Microsoft.DirectX.DirectPlay)

IndicateConnectEventArgs.RejectMessage Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Definition

Visual Basic | Public Property RejectMessage As Boolean
C# | public bool RejectMessage { get; set; }
C++ public:
property bool RejectMessage {
bool get();
void set(bool value);
}
JScript public function get RejectMessage() : boolean
public function set RejectMessage(boolean);

Property Value

System.Boolean

This property is read/write.


IndicateConnectEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

IndicateConnectEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As IndicateConnectMessage
C# | public IndicateConnectMessage Message;
C++ | public: IndicateConnectMessage Message;
JScript | public var Message : IndicateConnectMessage

Field Value

Microsoft.DirectX.DirectPlay.IndicateConnectMessage

This field is read/write.


IndicatedConnectAbortedEventArgs Class (Microsoft.DirectX.DirectPlay)

IndicatedConnectAbortedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class IndicatedConnectAbortedEventArgs
Inherits EventArgs
C# | public sealed class IndicatedConnectAbortedEventArgs : EventArgs
C++ | public ref class IndicatedConnectAbortedEventArgs sealed : EventArgs
JScript | public final class IndicatedConnectAbortedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Methods

Method Description
IndicatedConnectAbortedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
IndicatedConnectAbortedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IndicatedConnectAbortedEventArgs.IndicatedConnectAbortedEventArgs(IndicatedConnectAbortedMessage) Constructor (Microsoft.DirectX.DirectPlay)

IndicatedConnectAbortedEventArgs.IndicatedConnectAbortedEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As IndicatedConnectAbortedMessage _
)
C# public IndicatedConnectAbortedEventArgs(
IndicatedConnectAbortedMessage dpMessage
);
C++ public:
IndicatedConnectAbortedEventArgs(
IndicatedConnectAbortedMessage dpMessage
);
JScript public function IndicatedConnectAbortedEventArgs(
dpMessage : IndicatedConnectAbortedMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedMessage


IndicatedConnectAbortedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

IndicatedConnectAbortedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Definition

Visual Basic | Public Message As IndicatedConnectAbortedMessage
C# | public IndicatedConnectAbortedMessage Message;
C++ | public: IndicatedConnectAbortedMessage Message;
JScript | public var Message : IndicatedConnectAbortedMessage

Field Value

Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedMessage

This field is read/write.


InvalidAddressFormatException Class (Microsoft.DirectX.DirectPlay)

InvalidAddressFormatException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address format is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidAddressFormatException
Inherits DirectPlayException
C# | public class InvalidAddressFormatException : DirectPlayException
C++ | public ref class InvalidAddressFormatException : DirectPlayException
JScript | public class InvalidAddressFormatException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidAddressFormatException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidAddressFormatException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidAddressFormatException.InvalidAddressFormatException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidAddressFormatException();
protected InvalidAddressFormatException(SerializationInfo, StreamingContext);
public InvalidAddressFormatException(string);
public InvalidAddressFormatException(string, Exception);


InvalidAddressFormatException.InvalidAddressFormatException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidAddressFormatException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidAddressFormatException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidAddressFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidAddressFormatException.InvalidAddressFormatException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidAddressFormatException(
string message,
Exception inner
);
C++ public:
InvalidAddressFormatException(
String^ message,
Exception^ inner
);
JScript public function InvalidAddressFormatException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidAddressFormatException.InvalidAddressFormatException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidAddressFormatException(
string message
);
C++ public:
InvalidAddressFormatException(
String^ message
);
JScript public function InvalidAddressFormatException(
message : String
);

Parameters

message System.String


InvalidAddressFormatException.InvalidAddressFormatException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidAddressFormatException.InvalidAddressFormatException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidAddressFormatException();
C++ public:
InvalidAddressFormatException();
JScript | public function InvalidAddressFormatException();


InvalidApplicationException Class (Microsoft.DirectX.DirectPlay)

InvalidApplicationException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Guid supplied for the application is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidApplicationException
Inherits DirectPlayException
C# | public class InvalidApplicationException : DirectPlayException
C++ | public ref class InvalidApplicationException : DirectPlayException
JScript | public class InvalidApplicationException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidApplicationException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidApplicationException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidApplicationException.InvalidApplicationException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidApplicationException();
protected InvalidApplicationException(SerializationInfo, StreamingContext);
public InvalidApplicationException(string);
public InvalidApplicationException(string, Exception);


InvalidApplicationException.InvalidApplicationException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidApplicationException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidApplicationException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidApplicationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidApplicationException.InvalidApplicationException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidApplicationException(
string message,
Exception inner
);
C++ public:
InvalidApplicationException(
String^ message,
Exception^ inner
);
JScript public function InvalidApplicationException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidApplicationException.InvalidApplicationException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidApplicationException(
string message
);
C++ public:
InvalidApplicationException(
String^ message
);
JScript public function InvalidApplicationException(
message : String
);

Parameters

message System.String


InvalidApplicationException.InvalidApplicationException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidApplicationException.InvalidApplicationException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidApplicationException();
C++ public:
InvalidApplicationException();
JScript | public function InvalidApplicationException();


InvalidCommandException Class (Microsoft.DirectX.DirectPlay)

InvalidCommandException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The command specified is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidCommandException
Inherits DirectPlayException
C# | public class InvalidCommandException : DirectPlayException
C++ | public ref class InvalidCommandException : DirectPlayException
JScript | public class InvalidCommandException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidCommandException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidCommandException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidCommandException.InvalidCommandException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidCommandException();
protected InvalidCommandException(SerializationInfo, StreamingContext);
public InvalidCommandException(string);
public InvalidCommandException(string, Exception);


InvalidCommandException.InvalidCommandException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidCommandException.InvalidCommandException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidCommandException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidCommandException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidCommandException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidCommandException.InvalidCommandException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidCommandException.InvalidCommandException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidCommandException(
string message,
Exception inner
);
C++ public:
InvalidCommandException(
String^ message,
Exception^ inner
);
JScript public function InvalidCommandException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidCommandException.InvalidCommandException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidCommandException.InvalidCommandException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidCommandException(
string message
);
C++ public:
InvalidCommandException(
String^ message
);
JScript public function InvalidCommandException(
message : String
);

Parameters

message System.String


InvalidCommandException.InvalidCommandException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidCommandException.InvalidCommandException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidCommandException();
C++ public:
InvalidCommandException();
JScript | public function InvalidCommandException();


InvalidDeviceAddressException Class (Microsoft.DirectX.DirectPlay)

InvalidDeviceAddressException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The address for the local computer or adapter is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidDeviceAddressException
Inherits DirectPlayException
C# | public class InvalidDeviceAddressException : DirectPlayException
C++ | public ref class InvalidDeviceAddressException : DirectPlayException
JScript | public class InvalidDeviceAddressException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidDeviceAddressException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidDeviceAddressException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidDeviceAddressException.InvalidDeviceAddressException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidDeviceAddressException();
protected InvalidDeviceAddressException(SerializationInfo, StreamingContext);
public InvalidDeviceAddressException(string);
public InvalidDeviceAddressException(string, Exception);


InvalidDeviceAddressException.InvalidDeviceAddressException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidDeviceAddressException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidDeviceAddressException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidDeviceAddressException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidDeviceAddressException.InvalidDeviceAddressException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidDeviceAddressException(
string message,
Exception inner
);
C++ public:
InvalidDeviceAddressException(
String^ message,
Exception^ inner
);
JScript public function InvalidDeviceAddressException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidDeviceAddressException.InvalidDeviceAddressException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidDeviceAddressException(
string message
);
C++ public:
InvalidDeviceAddressException(
String^ message
);
JScript public function InvalidDeviceAddressException(
message : String
);

Parameters

message System.String


InvalidDeviceAddressException.InvalidDeviceAddressException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidDeviceAddressException.InvalidDeviceAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidDeviceAddressException();
C++ public:
InvalidDeviceAddressException();
JScript | public function InvalidDeviceAddressException();


InvalidEndPointException Class (Microsoft.DirectX.DirectPlay)

InvalidEndPointException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The endpoint was invalid Deprecated.

Definition

Visual Basic Public Class InvalidEndPointException
Inherits DirectPlayException
C# | public class InvalidEndPointException : DirectPlayException
C++ | public ref class InvalidEndPointException : DirectPlayException
JScript | public class InvalidEndPointException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidEndPointException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidEndPointException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidEndPointException.InvalidEndPointException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidEndPointException();
protected InvalidEndPointException(SerializationInfo, StreamingContext);
public InvalidEndPointException(string);
public InvalidEndPointException(string, Exception);


InvalidEndPointException.InvalidEndPointException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidEndPointException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidEndPointException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidEndPointException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidEndPointException.InvalidEndPointException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidEndPointException(
string message,
Exception inner
);
C++ public:
InvalidEndPointException(
String^ message,
Exception^ inner
);
JScript public function InvalidEndPointException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidEndPointException.InvalidEndPointException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidEndPointException(
string message
);
C++ public:
InvalidEndPointException(
String^ message
);
JScript public function InvalidEndPointException(
message : String
);

Parameters

message System.String


InvalidEndPointException.InvalidEndPointException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidEndPointException.InvalidEndPointException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidEndPointException();
C++ public:
InvalidEndPointException();
JScript | public function InvalidEndPointException();


InvalidFlagsException Class (Microsoft.DirectX.DirectPlay)

InvalidFlagsException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The flags passed to this method are invalid. Deprecated.

Definition

Visual Basic Public Class InvalidFlagsException
Inherits DirectPlayException
C# | public class InvalidFlagsException : DirectPlayException
C++ | public ref class InvalidFlagsException : DirectPlayException
JScript | public class InvalidFlagsException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidFlagsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidFlagsException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidFlagsException.InvalidFlagsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidFlagsException.InvalidFlagsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidFlagsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidFlagsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidFlagsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidFlagsException.InvalidFlagsException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidFlagsException.InvalidFlagsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidFlagsException(
string message,
Exception inner
);
C++ public:
InvalidFlagsException(
String^ message,
Exception^ inner
);
JScript public function InvalidFlagsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidFlagsException.InvalidFlagsException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidFlagsException.InvalidFlagsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidFlagsException(
string message
);
C++ public:
InvalidFlagsException(
String^ message
);
JScript public function InvalidFlagsException(
message : String
);

Parameters

message System.String


InvalidFlagsException.InvalidFlagsException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidFlagsException.InvalidFlagsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidFlagsException();
C++ public:
InvalidFlagsException();
JScript | public function InvalidFlagsException();


InvalidGroupException Class (Microsoft.DirectX.DirectPlay)

InvalidGroupException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The group identifier (ID) is not recognized as a valid group ID for this game session. Deprecated.

Definition

Visual Basic Public Class InvalidGroupException
Inherits DirectPlayException
C# | public class InvalidGroupException : DirectPlayException
C++ | public ref class InvalidGroupException : DirectPlayException
JScript | public class InvalidGroupException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidGroupException.InvalidGroupException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidGroupException.InvalidGroupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidGroupException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidGroupException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidGroupException.InvalidGroupException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidGroupException.InvalidGroupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidGroupException(
string message,
Exception inner
);
C++ public:
InvalidGroupException(
String^ message,
Exception^ inner
);
JScript public function InvalidGroupException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidGroupException.InvalidGroupException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidGroupException.InvalidGroupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidGroupException(
string message
);
C++ public:
InvalidGroupException(
String^ message
);
JScript public function InvalidGroupException(
message : String
);

Parameters

message System.String


InvalidGroupException.InvalidGroupException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidGroupException.InvalidGroupException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidGroupException();
C++ public:
InvalidGroupException();
JScript | public function InvalidGroupException();


InvalidHandleException Class (Microsoft.DirectX.DirectPlay)

InvalidHandleException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The handle specified is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidHandleException
Inherits DirectPlayException
C# | public class InvalidHandleException : DirectPlayException
C++ | public ref class InvalidHandleException : DirectPlayException
JScript | public class InvalidHandleException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidHandleException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidHandleException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidHandleException.InvalidHandleException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidHandleException.InvalidHandleException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidHandleException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidHandleException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidHandleException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidHandleException.InvalidHandleException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidHandleException.InvalidHandleException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidHandleException(
string message,
Exception inner
);
C++ public:
InvalidHandleException(
String^ message,
Exception^ inner
);
JScript public function InvalidHandleException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidHandleException.InvalidHandleException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidHandleException.InvalidHandleException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidHandleException(
string message
);
C++ public:
InvalidHandleException(
String^ message
);
JScript public function InvalidHandleException(
message : String
);

Parameters

message System.String


InvalidHandleException.InvalidHandleException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidHandleException.InvalidHandleException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidHandleException();
C++ public:
InvalidHandleException();
JScript | public function InvalidHandleException();


InvalidHostAddressException Class (Microsoft.DirectX.DirectPlay)

InvalidHostAddressException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified remote address is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidHostAddressException
Inherits DirectPlayException
C# | public class InvalidHostAddressException : DirectPlayException
C++ | public ref class InvalidHostAddressException : DirectPlayException
JScript | public class InvalidHostAddressException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidHostAddressException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidHostAddressException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidHostAddressException.InvalidHostAddressException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidHostAddressException();
protected InvalidHostAddressException(SerializationInfo, StreamingContext);
public InvalidHostAddressException(string);
public InvalidHostAddressException(string, Exception);


InvalidHostAddressException.InvalidHostAddressException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidHostAddressException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidHostAddressException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidHostAddressException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidHostAddressException.InvalidHostAddressException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidHostAddressException(
string message,
Exception inner
);
C++ public:
InvalidHostAddressException(
String^ message,
Exception^ inner
);
JScript public function InvalidHostAddressException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidHostAddressException.InvalidHostAddressException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidHostAddressException(
string message
);
C++ public:
InvalidHostAddressException(
String^ message
);
JScript public function InvalidHostAddressException(
message : String
);

Parameters

message System.String


InvalidHostAddressException.InvalidHostAddressException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidHostAddressException.InvalidHostAddressException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidHostAddressException();
C++ public:
InvalidHostAddressException();
JScript | public function InvalidHostAddressException();


InvalidInstanceException Class (Microsoft.DirectX.DirectPlay)

InvalidInstanceException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The Guid for the application instance is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidInstanceException
Inherits DirectPlayException
C# | public class InvalidInstanceException : DirectPlayException
C++ | public ref class InvalidInstanceException : DirectPlayException
JScript | public class InvalidInstanceException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidInstanceException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidInstanceException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidInstanceException.InvalidInstanceException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidInstanceException();
protected InvalidInstanceException(SerializationInfo, StreamingContext);
public InvalidInstanceException(string);
public InvalidInstanceException(string, Exception);


InvalidInstanceException.InvalidInstanceException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidInstanceException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidInstanceException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidInstanceException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidInstanceException.InvalidInstanceException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidInstanceException(
string message,
Exception inner
);
C++ public:
InvalidInstanceException(
String^ message,
Exception^ inner
);
JScript public function InvalidInstanceException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidInstanceException.InvalidInstanceException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidInstanceException(
string message
);
C++ public:
InvalidInstanceException(
String^ message
);
JScript public function InvalidInstanceException(
message : String
);

Parameters

message System.String


InvalidInstanceException.InvalidInstanceException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidInstanceException.InvalidInstanceException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidInstanceException();
C++ public:
InvalidInstanceException();
JScript | public function InvalidInstanceException();


InvalidObjectException Class (Microsoft.DirectX.DirectPlay)

InvalidObjectException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object parameter is invalid. This value will be returned in a connect request if the connecting player was not a client in a client/server game or a peer in a peer-to-peer game. Deprecated.

Definition

Visual Basic Public Class InvalidObjectException
Inherits DirectPlayException
C# | public class InvalidObjectException : DirectPlayException
C++ | public ref class InvalidObjectException : DirectPlayException
JScript | public class InvalidObjectException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidObjectException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidObjectException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidObjectException.InvalidObjectException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidObjectException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidObjectException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidObjectException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidObjectException.InvalidObjectException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidObjectException(
string message,
Exception inner
);
C++ public:
InvalidObjectException(
String^ message,
Exception^ inner
);
JScript public function InvalidObjectException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidObjectException.InvalidObjectException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidObjectException(
string message
);
C++ public:
InvalidObjectException(
String^ message
);
JScript public function InvalidObjectException(
message : String
);

Parameters

message System.String


InvalidObjectException.InvalidObjectException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidObjectException.InvalidObjectException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidObjectException();
C++ public:
InvalidObjectException();
JScript | public function InvalidObjectException();


InvalidPasswordException Class (Microsoft.DirectX.DirectPlay)

InvalidPasswordException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An invalid password was supplied when attempting to join a session that requires a password. Deprecated.

Definition

Visual Basic Public Class InvalidPasswordException
Inherits DirectPlayException
C# | public class InvalidPasswordException : DirectPlayException
C++ | public ref class InvalidPasswordException : DirectPlayException
JScript | public class InvalidPasswordException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPasswordException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidPasswordException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidPasswordException.InvalidPasswordException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPasswordException();
protected InvalidPasswordException(SerializationInfo, StreamingContext);
public InvalidPasswordException(string);
public InvalidPasswordException(string, Exception);


InvalidPasswordException.InvalidPasswordException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPasswordException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidPasswordException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidPasswordException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidPasswordException.InvalidPasswordException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPasswordException(
string message,
Exception inner
);
C++ public:
InvalidPasswordException(
String^ message,
Exception^ inner
);
JScript public function InvalidPasswordException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidPasswordException.InvalidPasswordException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidPasswordException(
string message
);
C++ public:
InvalidPasswordException(
String^ message
);
JScript public function InvalidPasswordException(
message : String
);

Parameters

message System.String


InvalidPasswordException.InvalidPasswordException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidPasswordException.InvalidPasswordException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidPasswordException();
C++ public:
InvalidPasswordException();
JScript | public function InvalidPasswordException();


InvalidPlayerException Class (Microsoft.DirectX.DirectPlay)

InvalidPlayerException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not recognized as a valid player ID for this game session. Deprecated.

Definition

Visual Basic Public Class InvalidPlayerException
Inherits DirectPlayException
C# | public class InvalidPlayerException : DirectPlayException
C++ | public ref class InvalidPlayerException : DirectPlayException
JScript | public class InvalidPlayerException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidPlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidPlayerException.InvalidPlayerException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPlayerException.InvalidPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPlayerException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidPlayerException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidPlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidPlayerException.InvalidPlayerException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPlayerException.InvalidPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPlayerException(
string message,
Exception inner
);
C++ public:
InvalidPlayerException(
String^ message,
Exception^ inner
);
JScript public function InvalidPlayerException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidPlayerException.InvalidPlayerException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPlayerException.InvalidPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidPlayerException(
string message
);
C++ public:
InvalidPlayerException(
String^ message
);
JScript public function InvalidPlayerException(
message : String
);

Parameters

message System.String


InvalidPlayerException.InvalidPlayerException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidPlayerException.InvalidPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidPlayerException();
C++ public:
InvalidPlayerException();
JScript | public function InvalidPlayerException();


InvalidPriorityException Class (Microsoft.DirectX.DirectPlay)

InvalidPriorityException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The specified priority is not within the range of allowed priorities, which is inclusively from 0 through 65535. Deprecated.

Definition

Visual Basic Public Class InvalidPriorityException
Inherits DirectPlayException
C# | public class InvalidPriorityException : DirectPlayException
C++ | public ref class InvalidPriorityException : DirectPlayException
JScript | public class InvalidPriorityException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidPriorityException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidPriorityException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidPriorityException.InvalidPriorityException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidPriorityException();
protected InvalidPriorityException(SerializationInfo, StreamingContext);
public InvalidPriorityException(string);
public InvalidPriorityException(string, Exception);


InvalidPriorityException.InvalidPriorityException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidPriorityException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidPriorityException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidPriorityException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidPriorityException.InvalidPriorityException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidPriorityException(
string message,
Exception inner
);
C++ public:
InvalidPriorityException(
String^ message,
Exception^ inner
);
JScript public function InvalidPriorityException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidPriorityException.InvalidPriorityException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidPriorityException(
string message
);
C++ public:
InvalidPriorityException(
String^ message
);
JScript public function InvalidPriorityException(
message : String
);

Parameters

message System.String


InvalidPriorityException.InvalidPriorityException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidPriorityException.InvalidPriorityException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidPriorityException();
C++ public:
InvalidPriorityException();
JScript | public function InvalidPriorityException();


InvalidStringException Class (Microsoft.DirectX.DirectPlay)

InvalidStringException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
String specified as a parameter is invalid. Deprecated.

Definition

Visual Basic Public Class InvalidStringException
Inherits DirectPlayException
C# | public class InvalidStringException : DirectPlayException
C++ | public ref class InvalidStringException : DirectPlayException
JScript | public class InvalidStringException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidStringException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidStringException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidStringException.InvalidStringException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidStringException();
protected InvalidStringException(SerializationInfo, StreamingContext);
public InvalidStringException(string);
public InvalidStringException(string, Exception);


InvalidStringException.InvalidStringException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidStringException.InvalidStringException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidStringException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidStringException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidStringException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidStringException.InvalidStringException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidStringException.InvalidStringException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidStringException(
string message,
Exception inner
);
C++ public:
InvalidStringException(
String^ message,
Exception^ inner
);
JScript public function InvalidStringException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidStringException.InvalidStringException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidStringException.InvalidStringException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidStringException(
string message
);
C++ public:
InvalidStringException(
String^ message
);
JScript public function InvalidStringException(
message : String
);

Parameters

message System.String


InvalidStringException.InvalidStringException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidStringException.InvalidStringException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidStringException();
C++ public:
InvalidStringException();
JScript | public function InvalidStringException();


InvalidUrlException Class (Microsoft.DirectX.DirectPlay)

InvalidUrlException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specified string is not a valid DirectPlay URL. Deprecated.

Definition

Visual Basic Public Class InvalidUrlException
Inherits DirectPlayException
C# | public class InvalidUrlException : DirectPlayException
C++ | public ref class InvalidUrlException : DirectPlayException
JScript | public class InvalidUrlException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidUrlException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidUrlException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidUrlException.InvalidUrlException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidUrlException();
protected InvalidUrlException(SerializationInfo, StreamingContext);
public InvalidUrlException(string);
public InvalidUrlException(string, Exception);


InvalidUrlException.InvalidUrlException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidUrlException.InvalidUrlException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidUrlException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidUrlException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidUrlException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidUrlException.InvalidUrlException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidUrlException.InvalidUrlException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidUrlException(
string message,
Exception inner
);
C++ public:
InvalidUrlException(
String^ message,
Exception^ inner
);
JScript public function InvalidUrlException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidUrlException.InvalidUrlException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidUrlException.InvalidUrlException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidUrlException(
string message
);
C++ public:
InvalidUrlException(
String^ message
);
JScript public function InvalidUrlException(
message : String
);

Parameters

message System.String


InvalidUrlException.InvalidUrlException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidUrlException.InvalidUrlException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidUrlException();
C++ public:
InvalidUrlException();
JScript | public function InvalidUrlException();


InvalidVersionException Class (Microsoft.DirectX.DirectPlay)

InvalidVersionException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There was an attempt to connect to an invalid version of DirectPlay. Deprecated.

Definition

Visual Basic Public Class InvalidVersionException
Inherits DirectPlayException
C# | public class InvalidVersionException : DirectPlayException
C++ | public ref class InvalidVersionException : DirectPlayException
JScript | public class InvalidVersionException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidVersionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
InvalidVersionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidVersionException.InvalidVersionException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public InvalidVersionException();
protected InvalidVersionException(SerializationInfo, StreamingContext);
public InvalidVersionException(string);
public InvalidVersionException(string, Exception);


InvalidVersionException.InvalidVersionException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

InvalidVersionException.InvalidVersionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidVersionException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidVersionException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidVersionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


InvalidVersionException.InvalidVersionException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

InvalidVersionException.InvalidVersionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidVersionException(
string message,
Exception inner
);
C++ public:
InvalidVersionException(
String^ message,
Exception^ inner
);
JScript public function InvalidVersionException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


InvalidVersionException.InvalidVersionException(String) Constructor (Microsoft.DirectX.DirectPlay)

InvalidVersionException.InvalidVersionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidVersionException(
string message
);
C++ public:
InvalidVersionException(
String^ message
);
JScript public function InvalidVersionException(
message : String
);

Parameters

message System.String


InvalidVersionException.InvalidVersionException() Constructor (Microsoft.DirectX.DirectPlay)

InvalidVersionException.InvalidVersionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public InvalidVersionException();
C++ public:
InvalidVersionException();
JScript | public function InvalidVersionException();


NatResolver Class (Microsoft.DirectX.DirectPlay)

NatResolver Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the NatResolver object to simplify traversal through the Internet Connection Sharing features available in Microsoft® Windows® Millennium Edition (Windows Me) and Windows XP, as well as other Network Address Translators. Deprecated.

Definition

Visual Basic Public Class NatResolver
Inherits MarshalByRefObject
Implements IDisposable
C# | public class NatResolver : MarshalByRefObject, IDisposable
C++ | public ref class NatResolver : MarshalByRefObject, IDisposable
JScript | public class NatResolver extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
Query
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a query for a Nat Resolver has been received. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the list of objects on which the NAT Resolver has been started. Deprecated.
GetDevices
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the list of available devices on which the NAT Resolver can be started. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
NatResolver
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Query
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Start
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Launches the NAT Resolver server using the specified device addresses. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
NatResolver

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NatResolver.Dispose() Method (Microsoft.DirectX.DirectPlay)

NatResolver.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~NatResolver();
JScript | public override function Dispose();

See Also

  • NatResolver.Disposed
  • NatResolver.Disposing


NatResolver.Equals(Object) Method (Microsoft.DirectX.DirectPlay)

NatResolver.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


NatResolver.Finalize() Method (Microsoft.DirectX.DirectPlay)

NatResolver.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~NatResolver();
C++ | !NatResolver();
JScript | protected override function Finalize();


NatResolver.GetAddresses() Method (Microsoft.DirectX.DirectPlay)

NatResolver.GetAddresses Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the list of objects on which the NAT Resolver has been started. Deprecated.

Definition

Visual Basic | Public Function GetAddresses() As Address()
C# | public Address[] GetAddresses();
C++ public:
array<Address^>^ GetAddresses();
JScript | public function GetAddresses() : Address[];

Return Value

Microsoft.DirectX.DirectPlay.Address[]


NatResolver.GetDevices() Method (Microsoft.DirectX.DirectPlay)

NatResolver.GetDevices Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the list of available devices on which the NAT Resolver can be started. Deprecated.

Definition

Visual Basic | Public Function GetDevices() As ServiceProviderInformation()
C# | public ServiceProviderInformation[] GetDevices();
C++ public:
array<ServiceProviderInformation>^ GetDevices();
JScript | public function GetDevices() : ServiceProviderInformation[];

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


NatResolver.GetHashCode() Method (Microsoft.DirectX.DirectPlay)

NatResolver.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


NatResolver.NatResolver Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NatResolver();
public NatResolver(InitializeFlags);


NatResolver.NatResolver(InitializeFlags) Constructor (Microsoft.DirectX.DirectPlay)

NatResolver.NatResolver Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public NatResolver(
InitializeFlags flags
);
C++ public:
NatResolver(
InitializeFlags flags
);
JScript public function NatResolver(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags


NatResolver.NatResolver() Constructor (Microsoft.DirectX.DirectPlay)

NatResolver.NatResolver Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NatResolver();
C++ public:
NatResolver();
JScript | public function NatResolver();


NatResolver.op_Equality(NatResolver,NatResolver) Method (Microsoft.DirectX.DirectPlay)

NatResolver.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As NatResolver, _
ByVal right As NatResolver _
) As Boolean
C# public static bool op_Equality(
NatResolver left,
NatResolver right
);
C++ public:
static bool operator==(
NatResolver^ left,
NatResolver^ right
);
JScript public static function op_Equality(
left : NatResolver,
right : NatResolver
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.NatResolver
The NatResolver structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.NatResolver
The NatResolver structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


NatResolver.op_Inequality(NatResolver,NatResolver) Method (Microsoft.DirectX.DirectPlay)

NatResolver.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As NatResolver, _
ByVal right As NatResolver _
) As Boolean
C# public static bool op_Inequality(
NatResolver left,
NatResolver right
);
C++ public:
static bool operator!=(
NatResolver^ left,
NatResolver^ right
);
JScript public static function op_Inequality(
left : NatResolver,
right : NatResolver
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.NatResolver
The NatResolver structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.NatResolver
The NatResolver structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


NatResolver.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

NatResolver.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


NatResolver.raise_Query(Object,NatResolverQueryEventArgs) Method (Microsoft.DirectX.DirectPlay)

NatResolver.raise_Query Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Query( _
ByVal i1 As Object, _
ByVal i2 As NatResolverQueryEventArgs _
)
C# protected void raise_Query(
object i1,
NatResolverQueryEventArgs i2
);
C++ protected:
void raise_Query(
Object^ i1,
NatResolverQueryEventArgs^ i2
);
JScript protected function raise_Query(
i1 : Object,
i2 : NatResolverQueryEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.NatResolverQueryEventArgs


NatResolver.Start Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Launches the NAT Resolver server using the specified device addresses. Deprecated.

Overload List

public void Start();
public void Start(Address[]);


NatResolver.Start() Method (Microsoft.DirectX.DirectPlay)

NatResolver.Start Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Launches the NAT Resolver server using the specified device addresses. Deprecated.

Definition

Visual Basic | Public Sub Start()
C# | public void Start();
C++ public:
void Start();
JScript | public function Start();


NatResolver.Start(Address[]) Method (Microsoft.DirectX.DirectPlay)

NatResolver.Start Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Launches the NAT Resolver server using the specified device addresses. Deprecated.

Definition

Visual Basic Public Sub Start( _
ByVal devices() As Address _
)
C# public void Start(
Address[] devices
);
C++ public:
void Start(
array<Address^>^ devices
);
JScript public function Start(
devices : Address[]
);

Parameters

devices Microsoft.DirectX.DirectPlay.Address[]


NatResolver.Disposed Property (Microsoft.DirectX.DirectPlay)

NatResolver.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


NatResolver.Disposing Event (Microsoft.DirectX.DirectPlay)

NatResolver.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a NatResolver.Disposing event, use the following code.

natResolver.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


NatResolver.Query Event (Microsoft.DirectX.DirectPlay)

NatResolver.Query Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a query for a Nat Resolver has been received. Deprecated.

Definition

Visual Basic | Public Event Query As NatResolverQueryEventHandler
C# | public event NatResolverQueryEventHandler Query;
C++ public:
event NatResolverQueryEventHandler^ Query;
JScript | In JScript, you can use events, but you cannot define your own.


NatResolverQueryEventArgs Class (Microsoft.DirectX.DirectPlay)

NatResolverQueryEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the NatResolver Query event. Deprecated.

Definition

Visual Basic NotInheritable Public Class NatResolverQueryEventArgs
Inherits EventArgs
C# | public sealed class NatResolverQueryEventArgs : EventArgs
C++ | public ref class NatResolverQueryEventArgs sealed : EventArgs
JScript | public final class NatResolverQueryEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
NatResolverQueryEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
RejectMessage
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
NatResolverQueryEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NatResolverQueryEventArgs.NatResolverQueryEventArgs(NatResolverQueryMessage) Constructor (Microsoft.DirectX.DirectPlay)

NatResolverQueryEventArgs.NatResolverQueryEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As NatResolverQueryMessage _
)
C# public NatResolverQueryEventArgs(
NatResolverQueryMessage dpMessage
);
C++ public:
NatResolverQueryEventArgs(
NatResolverQueryMessage dpMessage
);
JScript public function NatResolverQueryEventArgs(
dpMessage : NatResolverQueryMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.NatResolverQueryMessage


NatResolverQueryEventArgs.RejectMessage Property (Microsoft.DirectX.DirectPlay)

NatResolverQueryEventArgs.RejectMessage Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
specifiy true to reject this message, and not allow your session to be found. Deprecated.

Definition

Visual Basic | Public Property RejectMessage As Boolean
C# | public bool RejectMessage { get; set; }
C++ public:
property bool RejectMessage {
bool get();
void set(bool value);
}
JScript public function get RejectMessage() : boolean
public function set RejectMessage(boolean);

Property Value

System.Boolean

This property is read/write.


NatResolverQueryEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

NatResolverQueryEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As NatResolverQueryMessage
C# | public NatResolverQueryMessage Message;
C++ | public: NatResolverQueryMessage Message;
JScript | public var Message : NatResolverQueryMessage

Field Value

Microsoft.DirectX.DirectPlay.NatResolverQueryMessage

This field is read/write.


NetworkPacket Class (Microsoft.DirectX.DirectPlay)

NetworkPacket Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A network packet that can be sent to other members of this session. Deprecated.

Definition

Visual Basic NotInheritable Public Class NetworkPacket
Inherits Object
Implements IDisposable
C# | public sealed class NetworkPacket : Object, IDisposable
C++ | public ref class NetworkPacket sealed : Object, IDisposable
JScript | public final class NetworkPacket extends Object implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the current data as a byte array. Deprecated.
NetworkPacket
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Read
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet the specified type into an array. Deprecated.
ReadString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet a string. Deprecated.
Write
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Properties

Property Description
Length
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Length of the network packet. Deprecated.
Position
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current position of the network packet. Deprecated.

Inheritance Hierarchy

Object Leave Site
NetworkPacket

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NetworkPacket.Dispose() Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~NetworkPacket();
JScript | public override function Dispose();


NetworkPacket.Finalize() Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~NetworkPacket();
C++ | !NetworkPacket();
JScript | protected override function Finalize();


NetworkPacket.GetData() Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.GetData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the current data as a byte array. Deprecated.

Definition

Visual Basic | Public Function GetData() As Byte()
C# | public byte[] GetData();
C++ public:
array<unsigned char>^ GetData();
JScript | public function GetData() : byte[];

Return Value

System.Byte[]


NetworkPacket.NetworkPacket Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Overload List

public NetworkPacket();
public NetworkPacket(int);


NetworkPacket.NetworkPacket(Int32) Constructor (Microsoft.DirectX.DirectPlay)

NetworkPacket.NetworkPacket Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal initialSize As Integer _
)
C# public NetworkPacket(
int initialSize
);
C++ public:
NetworkPacket(
int initialSize
);
JScript public function NetworkPacket(
initialSize : int
);

Parameters

initialSize System.Int32


NetworkPacket.NetworkPacket() Constructor (Microsoft.DirectX.DirectPlay)

NetworkPacket.NetworkPacket Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NetworkPacket();
C++ public:
NetworkPacket();
JScript | public function NetworkPacket();


NetworkPacket.Read Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet the specified type into an array. Deprecated.

Overload List

public ValueType Read(Type);
public Array Read(Type, int[]);


NetworkPacket.Read(Type,Int32[]) Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.Read Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet the specified type into an array. Deprecated.

Definition

Visual Basic Public Function Read( _
ByVal returnType As Type, _
ByVal ranks() As Integer _
) As Array
C# public Array Read(
Type returnType,
int[] ranks
);
C++ public:
Array^ Read(
Type^ returnType,
array<int>^ ranks
);
JScript public function Read(
returnType : Type,
ranks : int[]
) : Array;

Parameters

returnType System.Type
ranks System.Int32[]

Return Value

System.Array


NetworkPacket.Read(Type) Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.Read Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet the specified type into an array. Deprecated.

Definition

Visual Basic Public Function Read( _
ByVal returnType As Type _
) As ValueType
C# public ValueType Read(
Type returnType
);
C++ public:
ValueType^ Read(
Type^ returnType
);
JScript public function Read(
returnType : Type
) : ValueType;

Parameters

returnType System.Type

Return Value

System.ValueType


NetworkPacket.ReadString() Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.ReadString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Read from the network packet a string. Deprecated.

Definition

Visual Basic | Public Function ReadString() As String
C# | public string ReadString();
C++ public:
String^ ReadString();
JScript | public function ReadString() : String;

Return Value

System.String


NetworkPacket.Write Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Overload List

public void Write(Array);
public void Write(string);
public void Write(ValueType);


NetworkPacket.Write(String) Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.Write Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Definition

Visual Basic Public Sub Write( _
ByVal value As String _
)
C# public void Write(
string value
);
C++ public:
void Write(
String^ value
);
JScript public function Write(
value : String
);

Parameters

value System.String


NetworkPacket.Write(Array) Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.Write Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Definition

Visual Basic Public Sub Write( _
ByVal value As Array _
)
C# public void Write(
Array value
);
C++ public:
void Write(
Array^ value
);
JScript public function Write(
value : Array
);

Parameters

value System.Array


NetworkPacket.Write(ValueType) Method (Microsoft.DirectX.DirectPlay)

NetworkPacket.Write Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Write a string to the network packet. Deprecated.

Definition

Visual Basic Public Sub Write( _
ByVal value As ValueType _
)
C# public void Write(
ValueType value
);
C++ public:
void Write(
ValueType^ value
);
JScript public function Write(
value : ValueType
);

Parameters

value System.ValueType


NetworkPacket.Length Property (Microsoft.DirectX.DirectPlay)

NetworkPacket.Length Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Length of the network packet. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Length As Integer
C# | public int Length { get; }
C++ public:
property int Length {
int get();
}
JScript | public function get Length() : int

Property Value

System.Int32

This property is read-only.


NetworkPacket.Position Property (Microsoft.DirectX.DirectPlay)

NetworkPacket.Position Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Current position of the network packet. Deprecated.

Definition

Visual Basic | Public Property Position As Integer
C# | public int Position { get; set; }
C++ public:
property int Position {
int get();
void set(int value);
}
JScript public function get Position() : int
public function set Position(int);

Property Value

System.Int32

This property is read/write.


NoCapsException Class (Microsoft.DirectX.DirectPlay)

NoCapsException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The communication link that DirectPlay is attempting to use is not capable of this function. Deprecated.

Definition

Visual Basic Public Class NoCapsException
Inherits DirectPlayException
C# | public class NoCapsException : DirectPlayException
C++ | public ref class NoCapsException : DirectPlayException
JScript | public class NoCapsException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoCapsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoCapsException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoCapsException.NoCapsException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoCapsException();
protected NoCapsException(SerializationInfo, StreamingContext);
public NoCapsException(string);
public NoCapsException(string, Exception);


NoCapsException.NoCapsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NoCapsException.NoCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoCapsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoCapsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoCapsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoCapsException.NoCapsException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NoCapsException.NoCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoCapsException(
string message,
Exception inner
);
C++ public:
NoCapsException(
String^ message,
Exception^ inner
);
JScript public function NoCapsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoCapsException.NoCapsException(String) Constructor (Microsoft.DirectX.DirectPlay)

NoCapsException.NoCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoCapsException(
string message
);
C++ public:
NoCapsException(
String^ message
);
JScript public function NoCapsException(
message : String
);

Parameters

message System.String


NoCapsException.NoCapsException() Constructor (Microsoft.DirectX.DirectPlay)

NoCapsException.NoCapsException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoCapsException();
C++ public:
NoCapsException();
JScript | public function NoCapsException();


NoConnectionException Class (Microsoft.DirectX.DirectPlay)

NoConnectionException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No communication link was established. Deprecated.

Definition

Visual Basic Public Class NoConnectionException
Inherits DirectPlayException
C# | public class NoConnectionException : DirectPlayException
C++ | public ref class NoConnectionException : DirectPlayException
JScript | public class NoConnectionException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoConnectionException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoConnectionException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoConnectionException.NoConnectionException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoConnectionException();
protected NoConnectionException(SerializationInfo, StreamingContext);
public NoConnectionException(string);
public NoConnectionException(string, Exception);


NoConnectionException.NoConnectionException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NoConnectionException.NoConnectionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoConnectionException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoConnectionException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoConnectionException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoConnectionException.NoConnectionException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NoConnectionException.NoConnectionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoConnectionException(
string message,
Exception inner
);
C++ public:
NoConnectionException(
String^ message,
Exception^ inner
);
JScript public function NoConnectionException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoConnectionException.NoConnectionException(String) Constructor (Microsoft.DirectX.DirectPlay)

NoConnectionException.NoConnectionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoConnectionException(
string message
);
C++ public:
NoConnectionException(
String^ message
);
JScript public function NoConnectionException(
message : String
);

Parameters

message System.String


NoConnectionException.NoConnectionException() Constructor (Microsoft.DirectX.DirectPlay)

NoConnectionException.NoConnectionException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoConnectionException();
C++ public:
NoConnectionException();
JScript | public function NoConnectionException();


NoHostPlayerException Class (Microsoft.DirectX.DirectPlay)

NoHostPlayerException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There is currently no player acting as the host of the session. Deprecated.

Definition

Visual Basic Public Class NoHostPlayerException
Inherits DirectPlayException
C# | public class NoHostPlayerException : DirectPlayException
C++ | public ref class NoHostPlayerException : DirectPlayException
JScript | public class NoHostPlayerException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoHostPlayerException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoHostPlayerException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoHostPlayerException.NoHostPlayerException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoHostPlayerException();
protected NoHostPlayerException(SerializationInfo, StreamingContext);
public NoHostPlayerException(string);
public NoHostPlayerException(string, Exception);


NoHostPlayerException.NoHostPlayerException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NoHostPlayerException.NoHostPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoHostPlayerException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoHostPlayerException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoHostPlayerException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoHostPlayerException.NoHostPlayerException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NoHostPlayerException.NoHostPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoHostPlayerException(
string message,
Exception inner
);
C++ public:
NoHostPlayerException(
String^ message,
Exception^ inner
);
JScript public function NoHostPlayerException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoHostPlayerException.NoHostPlayerException(String) Constructor (Microsoft.DirectX.DirectPlay)

NoHostPlayerException.NoHostPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoHostPlayerException(
string message
);
C++ public:
NoHostPlayerException(
String^ message
);
JScript public function NoHostPlayerException(
message : String
);

Parameters

message System.String


NoHostPlayerException.NoHostPlayerException() Constructor (Microsoft.DirectX.DirectPlay)

NoHostPlayerException.NoHostPlayerException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoHostPlayerException();
C++ public:
NoHostPlayerException();
JScript | public function NoHostPlayerException();


NoMoreAddressComponentsException Class (Microsoft.DirectX.DirectPlay)

NoMoreAddressComponentsException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
No more address components can be added to this address. Deprecated.

Definition

Visual Basic Public Class NoMoreAddressComponentsException
Inherits DirectPlayException
C# | public class NoMoreAddressComponentsException : DirectPlayException
C++ | public ref class NoMoreAddressComponentsException : DirectPlayException
JScript | public class NoMoreAddressComponentsException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoMoreAddressComponentsException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoMoreAddressComponentsException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoMoreAddressComponentsException();
protected NoMoreAddressComponentsException(SerializationInfo, StreamingContext);
public NoMoreAddressComponentsException(string);
public NoMoreAddressComponentsException(string, Exception);


NoMoreAddressComponentsException.NoMoreAddressComponentsException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoMoreAddressComponentsException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoMoreAddressComponentsException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoMoreAddressComponentsException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoMoreAddressComponentsException.NoMoreAddressComponentsException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoMoreAddressComponentsException(
string message,
Exception inner
);
C++ public:
NoMoreAddressComponentsException(
String^ message,
Exception^ inner
);
JScript public function NoMoreAddressComponentsException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoMoreAddressComponentsException.NoMoreAddressComponentsException(String) Constructor (Microsoft.DirectX.DirectPlay)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoMoreAddressComponentsException(
string message
);
C++ public:
NoMoreAddressComponentsException(
String^ message
);
JScript public function NoMoreAddressComponentsException(
message : String
);

Parameters

message System.String


NoMoreAddressComponentsException.NoMoreAddressComponentsException() Constructor (Microsoft.DirectX.DirectPlay)

NoMoreAddressComponentsException.NoMoreAddressComponentsException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoMoreAddressComponentsException();
C++ public:
NoMoreAddressComponentsException();
JScript | public function NoMoreAddressComponentsException();


NoResponseException Class (Microsoft.DirectX.DirectPlay)

NoResponseException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
There was no response from the specified target. Deprecated.

Definition

Visual Basic Public Class NoResponseException
Inherits DirectPlayException
C# | public class NoResponseException : DirectPlayException
C++ | public ref class NoResponseException : DirectPlayException
JScript | public class NoResponseException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoResponseException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NoResponseException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoResponseException.NoResponseException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NoResponseException();
protected NoResponseException(SerializationInfo, StreamingContext);
public NoResponseException(string);
public NoResponseException(string, Exception);


NoResponseException.NoResponseException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NoResponseException.NoResponseException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoResponseException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoResponseException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoResponseException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NoResponseException.NoResponseException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NoResponseException.NoResponseException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoResponseException(
string message,
Exception inner
);
C++ public:
NoResponseException(
String^ message,
Exception^ inner
);
JScript public function NoResponseException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NoResponseException.NoResponseException(String) Constructor (Microsoft.DirectX.DirectPlay)

NoResponseException.NoResponseException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoResponseException(
string message
);
C++ public:
NoResponseException(
String^ message
);
JScript public function NoResponseException(
message : String
);

Parameters

message System.String


NoResponseException.NoResponseException() Constructor (Microsoft.DirectX.DirectPlay)

NoResponseException.NoResponseException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NoResponseException();
C++ public:
NoResponseException();
JScript | public function NoResponseException();


NotAllowedException Class (Microsoft.DirectX.DirectPlay)

NotAllowedException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This function is not allowed on this object. Deprecated.

Definition

Visual Basic Public Class NotAllowedException
Inherits DirectPlayException
C# | public class NotAllowedException : DirectPlayException
C++ | public ref class NotAllowedException : DirectPlayException
JScript | public class NotAllowedException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotAllowedException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NotAllowedException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotAllowedException.NotAllowedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NotAllowedException.NotAllowedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotAllowedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotAllowedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotAllowedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotAllowedException.NotAllowedException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NotAllowedException.NotAllowedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotAllowedException(
string message,
Exception inner
);
C++ public:
NotAllowedException(
String^ message,
Exception^ inner
);
JScript public function NotAllowedException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotAllowedException.NotAllowedException(String) Constructor (Microsoft.DirectX.DirectPlay)

NotAllowedException.NotAllowedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotAllowedException(
string message
);
C++ public:
NotAllowedException(
String^ message
);
JScript public function NotAllowedException(
message : String
);

Parameters

message System.String


NotAllowedException.NotAllowedException() Constructor (Microsoft.DirectX.DirectPlay)

NotAllowedException.NotAllowedException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotAllowedException();
C++ public:
NotAllowedException();
JScript | public function NotAllowedException();


NotHostException Class (Microsoft.DirectX.DirectPlay)

NotHostException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
An attempt by the client to connect to a nonhost computer. Additionally, this error value can be returned by a nonhost that tries to set the application description. Deprecated.

Definition

Visual Basic Public Class NotHostException
Inherits DirectPlayException
C# | public class NotHostException : DirectPlayException
C++ | public ref class NotHostException : DirectPlayException
JScript | public class NotHostException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotHostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NotHostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotHostException.NotHostException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotHostException();
protected NotHostException(SerializationInfo, StreamingContext);
public NotHostException(string);
public NotHostException(string, Exception);


NotHostException.NotHostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NotHostException.NotHostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotHostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotHostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotHostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotHostException.NotHostException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NotHostException.NotHostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotHostException(
string message,
Exception inner
);
C++ public:
NotHostException(
String^ message,
Exception^ inner
);
JScript public function NotHostException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotHostException.NotHostException(String) Constructor (Microsoft.DirectX.DirectPlay)

NotHostException.NotHostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotHostException(
string message
);
C++ public:
NotHostException(
String^ message
);
JScript public function NotHostException(
message : String
);

Parameters

message System.String


NotHostException.NotHostException() Constructor (Microsoft.DirectX.DirectPlay)

NotHostException.NotHostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotHostException();
C++ public:
NotHostException();
JScript | public function NotHostException();


NotReadyException Class (Microsoft.DirectX.DirectPlay)

NotReadyException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The object is not ready for use. Deprecated.

Definition

Visual Basic Public Class NotReadyException
Inherits DirectPlayException
C# | public class NotReadyException : DirectPlayException
C++ | public ref class NotReadyException : DirectPlayException
JScript | public class NotReadyException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotReadyException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NotReadyException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotReadyException.NotReadyException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotReadyException();
protected NotReadyException(SerializationInfo, StreamingContext);
public NotReadyException(string);
public NotReadyException(string, Exception);


NotReadyException.NotReadyException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NotReadyException.NotReadyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotReadyException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotReadyException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotReadyException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotReadyException.NotReadyException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NotReadyException.NotReadyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotReadyException(
string message,
Exception inner
);
C++ public:
NotReadyException(
String^ message,
Exception^ inner
);
JScript public function NotReadyException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotReadyException.NotReadyException(String) Constructor (Microsoft.DirectX.DirectPlay)

NotReadyException.NotReadyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotReadyException(
string message
);
C++ public:
NotReadyException(
String^ message
);
JScript public function NotReadyException(
message : String
);

Parameters

message System.String


NotReadyException.NotReadyException() Constructor (Microsoft.DirectX.DirectPlay)

NotReadyException.NotReadyException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotReadyException();
C++ public:
NotReadyException();
JScript | public function NotReadyException();


NotRegisteredException Class (Microsoft.DirectX.DirectPlay)

NotRegisteredException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This object is not registered. Deprecated.

Definition

Visual Basic Public Class NotRegisteredException
Inherits DirectPlayException
C# | public class NotRegisteredException : DirectPlayException
C++ | public ref class NotRegisteredException : DirectPlayException
JScript | public class NotRegisteredException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NotRegisteredException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
NotRegisteredException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NotRegisteredException.NotRegisteredException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public NotRegisteredException();
protected NotRegisteredException(SerializationInfo, StreamingContext);
public NotRegisteredException(string);
public NotRegisteredException(string, Exception);


NotRegisteredException.NotRegisteredException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

NotRegisteredException.NotRegisteredException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NotRegisteredException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NotRegisteredException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NotRegisteredException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


NotRegisteredException.NotRegisteredException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

NotRegisteredException.NotRegisteredException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NotRegisteredException(
string message,
Exception inner
);
C++ public:
NotRegisteredException(
String^ message,
Exception^ inner
);
JScript public function NotRegisteredException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


NotRegisteredException.NotRegisteredException(String) Constructor (Microsoft.DirectX.DirectPlay)

NotRegisteredException.NotRegisteredException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NotRegisteredException(
string message
);
C++ public:
NotRegisteredException(
String^ message
);
JScript public function NotRegisteredException(
message : String
);

Parameters

message System.String


NotRegisteredException.NotRegisteredException() Constructor (Microsoft.DirectX.DirectPlay)

NotRegisteredException.NotRegisteredException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NotRegisteredException();
C++ public:
NotRegisteredException();
JScript | public function NotRegisteredException();


Peer Class (Microsoft.DirectX.DirectPlay)

Peer Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Peer object to create a peer-to-peer Microsoft® DirectPlay® session. Deprecated.

Definition

Visual Basic Public Class Peer
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Peer : MarshalByRefObject, IDisposable
C++ | public ref class Peer : MarshalByRefObject, IDisposable
JScript | public class Peer extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
ApplicationDescriptionChanged
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.
AsyncOperationComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the async operation has completed. Deprecated.
ConnectComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
FindHostQuery
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an when a peer or client is enumerating the available hosts. Deprecated.
FindHostResponse
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a host responds to a FindHosts call. Deprecated.
GroupCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is created. Deprecated.
GroupDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is destroyed. Deprecated.
GroupInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.
HostMigrated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the host has been migrated. Deprecated.
IndicateConnect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is trying to connect to your session. Deprecated.
IndicatedConnectAborted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an indicated played has aborted his connection. Deprecated.
PeerInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.
PlayerAddedToGroup
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is added to a group. Deprecated.
PlayerCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.
PlayerDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.
PlayerRemovedFromGroup
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been removed from a group. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the peer object receives data. Deprecated.
SendComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.
SessionTerminated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been terminated. Deprecated.

Methods

Method Description
AddPlayerToGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.
CancelAsyncOperation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.
Connect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.
CreateGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.
DestroyGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.
DestroyPeer
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a peer from the session. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
FindHosts
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.
GetConnectionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local application and the specified remote player. Deprecated.
GetGroupContext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the group context value for the specified group. Deprecated.
GetGroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetLocalHostAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
GetPeerAddress
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address for the specified remote player in the session. Deprecated.
GetPeerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.
GetPlayerContext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the player context value for the specified peer. Deprecated.
GetSendQueueInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Deprecated.
GetServiceProviders
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.
GetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the structure for the specified service provider. Deprecated.
Host
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
Peer
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
raise_ApplicationDescriptionChanged
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_AsyncOperationComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ConnectComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_FindHostQuery
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_FindHostResponse
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_HostMigrated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_IndicateConnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_IndicatedConnectAborted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PeerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerAddedToGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerRemovedFromGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SendComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SessionTerminated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RegisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RemovePlayerFromGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.
SendTo
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.
SetGroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.
SetPeerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.
SetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the DpnSpCapsDplay structure for the specified service provider. Deprecated.
TerminateSession
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Terminates the current session. Deprecated.
UnregisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ApplicationDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the full application description for the connected application. Deprecated.
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Peer object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
GroupMembers
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.
Groups
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the session. Deprecated.
Players
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the session. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Peer

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Peer.AddPlayerToGroup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Overload List

public void AddPlayerToGroup(int, int, out int, SyncFlags);
public void AddPlayerToGroup(int, int, out int, SyncFlags, object);
public void AddPlayerToGroup(int, int, SyncFlags);
public void AddPlayerToGroup(int, int, SyncFlags, object);


Peer.AddPlayerToGroup(Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.AddPlayerToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags,
object asyncContext
);
C++ public:
void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags,
Object^ asyncContext
);
JScript public function AddPlayerToGroup(
groupID : int,
clientID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
clientID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.AddPlayerToGroup(Int32,Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.AddPlayerToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void AddPlayerToGroup(
int groupID,
int clientID,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function AddPlayerToGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
clientID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.AddPlayerToGroup(Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.AddPlayerToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags
);
C++ public:
void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags
);
JScript public function AddPlayerToGroup(
groupID : int,
clientID : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
clientID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.AddPlayerToGroup(Int32,Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.AddPlayerToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a peer to a group.When this method is called, all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void AddPlayerToGroup(
int groupID,
int clientID,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function AddPlayerToGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
clientID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.CancelAsyncOperation Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Overload List

public void CancelAsyncOperation(CancelFlags);
public void CancelAsyncOperation(int);

Remarks

This method is useful when several methods of an object run asynchronously by default with each returning an asyncHandle parameter. To cancel a request before it is processed, pass that request's returned handle in this method's asyncHandle parameter.

To cancel all pending asynchronous operations, call this method with NULL in the asyncHandle parameter and DPNCANCEL_ALL_OPERATIONS in the flags parameter.

If you pass a specific handle to this method, do not set any flags.


Peer.CancelAsyncOperation(Int32) Method (Microsoft.DirectX.DirectPlay)

Peer.CancelAsyncOperation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Definition

Visual Basic Public Sub CancelAsyncOperation( _
ByVal asyncHandle As Integer _
)
C# public void CancelAsyncOperation(
int asyncHandle
);
C++ public:
void CancelAsyncOperation(
int asyncHandle
);
JScript public function CancelAsyncOperation(
asyncHandle : int
);

Parameters

asyncHandle System.Int32

Remarks

This method is useful when several methods of an object run asynchronously by default with each returning an asyncHandle parameter. To cancel a request before it is processed, pass that request's returned handle in this method's asyncHandle parameter.

To cancel all pending asynchronous operations, call this method with NULL in the asyncHandle parameter and DPNCANCEL_ALL_OPERATIONS in the flags parameter.

If you pass a specific handle to this method, do not set any flags.


Peer.CancelAsyncOperation(CancelFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.CancelAsyncOperation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Deprecated.

Definition

Visual Basic Public Sub CancelAsyncOperation( _
ByVal flags As CancelFlags _
)
C# public void CancelAsyncOperation(
CancelFlags flags
);
C++ public:
void CancelAsyncOperation(
CancelFlags flags
);
JScript public function CancelAsyncOperation(
flags : CancelFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.CancelFlags

Remarks

This method is useful when several methods of an object run asynchronously by default with each returning an asyncHandle parameter. To cancel a request before it is processed, pass that request's returned handle in this method's asyncHandle parameter.

To cancel all pending asynchronous operations, call this method with NULL in the asyncHandle parameter and DPNCANCEL_ALL_OPERATIONS in the flags parameter.

If you pass a specific handle to this method, do not set any flags.


Peer.Connect Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Overload List

public void Connect(ApplicationDescription, Address, Address, NetworkPacket, ConnectFlags);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, ConnectFlags, object, object);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, out int, ConnectFlags);
public void Connect(ApplicationDescription, Address, Address, NetworkPacket, out int, ConnectFlags, object, object);


Peer.Connect(ApplicationDescription,Address,Address,NetworkPacket,ConnectFlags,Object,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByVal flags As ConnectFlags, _
ByVal playerContext As Object, _
ByVal userContext As Object _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
ConnectFlags flags,
object playerContext,
object userContext
);
C++ public:
void Connect(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userConnectData,
ConnectFlags flags,
Object^ playerContext,
Object^ userContext
);
JScript public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
flags : ConnectFlags,
playerContext : Object,
userContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userConnectData Microsoft.DirectX.DirectPlay.NetworkPacket
flags Microsoft.DirectX.DirectPlay.ConnectFlags
playerContext System.Object
userContext System.Object


Peer.Connect(ApplicationDescription,Address,Address,NetworkPacket,Int32,ConnectFlags,Object,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByRef asyncHandle As Integer, _
ByVal flags As ConnectFlags, _
ByVal playerContext As Object, _
ByVal userContext As Object _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
out int asyncHandle,
ConnectFlags flags,
object playerContext,
object userContext
);
C++ public:
void Connect(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userConnectData,
[Out] int% asyncHandle,
ConnectFlags flags,
Object^ playerContext,
Object^ userContext
);
JScript public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
asyncHandle : int,
flags : ConnectFlags,
playerContext : Object,
userContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userConnectData Microsoft.DirectX.DirectPlay.NetworkPacket
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.ConnectFlags
playerContext System.Object
userContext System.Object


Peer.Connect(ApplicationDescription,Address,Address,NetworkPacket,ConnectFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByVal flags As ConnectFlags _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
ConnectFlags flags
);
C++ public:
void Connect(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userConnectData,
ConnectFlags flags
);
JScript public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
flags : ConnectFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userConnectData Microsoft.DirectX.DirectPlay.NetworkPacket
flags Microsoft.DirectX.DirectPlay.ConnectFlags


Peer.Connect(ApplicationDescription,Address,Address,NetworkPacket,Int32,ConnectFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.Connect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Establishes the connection to all the peers in a peer-to-peer session. Once a connection is established, the communication channel on the object is open and the application should expect messages to arrive immediately. Deprecated.

Definition

Visual Basic Public Sub Connect( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userConnectData As NetworkPacket, _
ByRef asyncHandle As Integer, _
ByVal flags As ConnectFlags _
)
C# public void Connect(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userConnectData,
out int asyncHandle,
ConnectFlags flags
);
C++ public:
void Connect(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userConnectData,
[Out] int% asyncHandle,
ConnectFlags flags
);
JScript public function Connect(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userConnectData : NetworkPacket,
asyncHandle : int,
flags : ConnectFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userConnectData Microsoft.DirectX.DirectPlay.NetworkPacket
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.ConnectFlags


Peer.CreateGroup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Overload List

public void CreateGroup(GroupInformation, out int, SyncFlags);
public void CreateGroup(GroupInformation, out int, SyncFlags, object, object);
public void CreateGroup(GroupInformation, SyncFlags);
public void CreateGroup(GroupInformation, SyncFlags, object, object);


Peer.CreateGroup(GroupInformation,SyncFlags,Object,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.CreateGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Definition

Visual Basic Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags, _
ByVal groupContext As Object, _
ByVal asyncContext As Object _
)
C# public void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags,
object groupContext,
object asyncContext
);
C++ public:
void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags,
Object^ groupContext,
Object^ asyncContext
);
JScript public function CreateGroup(
groupInformation : GroupInformation,
flags : SyncFlags,
groupContext : Object,
asyncContext : Object
);

Parameters

groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags
groupContext System.Object
asyncContext System.Object


Peer.CreateGroup(GroupInformation,Int32,SyncFlags,Object,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.CreateGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Definition

Visual Basic Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal groupContext As Object, _
ByVal asyncContext As Object _
)
C# public void CreateGroup(
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags,
object groupContext,
object asyncContext
);
C++ public:
void CreateGroup(
GroupInformation groupInformation,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ groupContext,
Object^ asyncContext
);
JScript public function CreateGroup(
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags,
groupContext : Object,
asyncContext : Object
);

Parameters

groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
groupContext System.Object
asyncContext System.Object


Peer.CreateGroup(GroupInformation,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.CreateGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Definition

Visual Basic Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags _
)
C# public void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags
);
C++ public:
void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags
);
JScript public function CreateGroup(
groupInformation : GroupInformation,
flags : SyncFlags
);

Parameters

groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.CreateGroup(GroupInformation,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.CreateGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. A group is a logical collection of players. Deprecated.

Definition

Visual Basic Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void CreateGroup(
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void CreateGroup(
GroupInformation groupInformation,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function CreateGroup(
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.DestroyGroup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Overload List

public void DestroyGroup(int, out int, SyncFlags);
public void DestroyGroup(int, out int, SyncFlags, object);
public void DestroyGroup(int, SyncFlags);
public void DestroyGroup(int, SyncFlags, object);


Peer.DestroyGroup(Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.DestroyGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Definition

Visual Basic Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void DestroyGroup(
int groupID,
SyncFlags flags,
object asyncContext
);
C++ public:
void DestroyGroup(
int groupID,
SyncFlags flags,
Object^ asyncContext
);
JScript public function DestroyGroup(
groupID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.DestroyGroup(Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.DestroyGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Definition

Visual Basic Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void DestroyGroup(
int groupID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void DestroyGroup(
int groupID,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function DestroyGroup(
groupID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.DestroyGroup(Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.DestroyGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Definition

Visual Basic Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByVal flags As SyncFlags _
)
C# public void DestroyGroup(
int groupID,
SyncFlags flags
);
C++ public:
void DestroyGroup(
int groupID,
SyncFlags flags
);
JScript public function DestroyGroup(
groupID : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.DestroyGroup(Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.DestroyGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8peerCreategroupDplay method. This method can be called by any peer in the session. Deprecated.

Definition

Visual Basic Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void DestroyGroup(
int groupID,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void DestroyGroup(
int groupID,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function DestroyGroup(
groupID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.DestroyPeer(Int32,NetworkPacket) Method (Microsoft.DirectX.DirectPlay)

Peer.DestroyPeer Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a peer from the session. Deprecated.

Definition

Visual Basic Public Sub DestroyPeer( _
ByVal playerID As Integer, _
ByVal destroyData As NetworkPacket _
)
C# public void DestroyPeer(
int playerID,
NetworkPacket destroyData
);
C++ public:
void DestroyPeer(
int playerID,
NetworkPacket^ destroyData
);
JScript public function DestroyPeer(
playerID : int,
destroyData : NetworkPacket
);

Parameters

playerID System.Int32
destroyData Microsoft.DirectX.DirectPlay.NetworkPacket


Peer.Dispose Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Overload List

public override void Dispose();
public void Dispose(bool);

See Also

  • Peer.Disposed
  • Peer.Disposing


Peer.Dispose(Boolean) Method (Microsoft.DirectX.DirectPlay)

Peer.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic Public Sub Dispose( _
ByVal closeImmediate As Boolean _
)
C# public void Dispose(
bool closeImmediate
);
C++ public:
void Dispose(
bool closeImmediate
);
JScript public function Dispose(
closeImmediate : boolean
);

Parameters

closeImmediate System.Boolean

See Also

  • Peer.Disposed
  • Peer.Disposing


Peer.Dispose() Method (Microsoft.DirectX.DirectPlay)

Peer.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Peer();
JScript | public override function Dispose();

See Also

  • Peer.Disposed
  • Peer.Disposing


Peer.Equals(Object) Method (Microsoft.DirectX.DirectPlay)

Peer.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Peer.Finalize() Method (Microsoft.DirectX.DirectPlay)

Peer.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Peer();
C++ | !Peer();
JScript | protected override function Finalize();


Peer.FindHosts Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Overload List

public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, out int);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, out int, object);
public void FindHosts(ApplicationDescription, Address, Address, NetworkPacket, int, int, int, FindHostsFlags, object);


Peer.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.FindHosts Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByVal userContext As Object _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
object userContext
);
C++ public:
void FindHosts(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
Object^ userContext
);
JScript public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
userContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userEnumData Microsoft.DirectX.DirectPlay.NetworkPacket
count System.Int32
retryInterval System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.FindHostsFlags
userContext System.Object


Peer.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Int32,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.FindHosts Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByRef asyncHandle As Integer, _
ByVal userContext As Object _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
out int asyncHandle,
object userContext
);
C++ public:
void FindHosts(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
[Out] int% asyncHandle,
Object^ userContext
);
JScript public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
asyncHandle : int,
userContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userEnumData Microsoft.DirectX.DirectPlay.NetworkPacket
count System.Int32
retryInterval System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.FindHostsFlags
asyncHandle System.Int32
userContext System.Object


Peer.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.FindHosts Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags
);
C++ public:
void FindHosts(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags
);
JScript public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userEnumData Microsoft.DirectX.DirectPlay.NetworkPacket
count System.Int32
retryInterval System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.FindHostsFlags


Peer.FindHosts(ApplicationDescription,Address,Address,NetworkPacket,Int32,Int32,Int32,FindHostsFlags,Int32) Method (Microsoft.DirectX.DirectPlay)

Peer.FindHosts Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates applications that host Microsoft® DirectPlay® games. Deprecated.

Definition

Visual Basic Public Sub FindHosts( _
ByVal applicationDescription As ApplicationDescription, _
ByVal hostAddress As Address, _
ByVal deviceInformation As Address, _
ByVal userEnumData As NetworkPacket, _
ByVal count As Integer, _
ByVal retryInterval As Integer, _
ByVal timeOut As Integer, _
ByVal flags As FindHostsFlags, _
ByRef asyncHandle As Integer _
)
C# public void FindHosts(
ApplicationDescription applicationDescription,
Address hostAddress,
Address deviceInformation,
NetworkPacket userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
out int asyncHandle
);
C++ public:
void FindHosts(
ApplicationDescription applicationDescription,
Address^ hostAddress,
Address^ deviceInformation,
NetworkPacket^ userEnumData,
int count,
int retryInterval,
int timeOut,
FindHostsFlags flags,
[Out] int% asyncHandle
);
JScript public function FindHosts(
applicationDescription : ApplicationDescription,
hostAddress : Address,
deviceInformation : Address,
userEnumData : NetworkPacket,
count : int,
retryInterval : int,
timeOut : int,
flags : FindHostsFlags,
asyncHandle : int
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
hostAddress Microsoft.DirectX.DirectPlay.Address
deviceInformation Microsoft.DirectX.DirectPlay.Address
userEnumData Microsoft.DirectX.DirectPlay.NetworkPacket
count System.Int32
retryInterval System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.FindHostsFlags
asyncHandle System.Int32


Peer.GetConnectionInformation(Int32) Method (Microsoft.DirectX.DirectPlay)

Peer.GetConnectionInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local application and the specified remote player. Deprecated.

Definition

Visual Basic Public Function GetConnectionInformation( _
ByVal playerID As Integer _
) As ConnectionInformation
C# public ConnectionInformation GetConnectionInformation(
int playerID
);
C++ public:
ConnectionInformation GetConnectionInformation(
int playerID
);
JScript public function GetConnectionInformation(
playerID : int
) : ConnectionInformation;

Parameters

playerID System.Int32

Return Value

Microsoft.DirectX.DirectPlay.ConnectionInformation


Peer.GetGroupContext(Int32) Method (Microsoft.DirectX.DirectPlay)

Peer.GetGroupContext Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the group context value for the specified group. Deprecated.

Definition

Visual Basic Public Function GetGroupContext( _
ByVal groupID As Integer _
) As Object
C# public object GetGroupContext(
int groupID
);
C++ public:
Object^ GetGroupContext(
int groupID
);
JScript public function GetGroupContext(
groupID : int
) : Object;

Parameters

groupID System.Int32

Return Value

System.Object


Peer.GetGroupInformation(Int32) Method (Microsoft.DirectX.DirectPlay)

Peer.GetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Function GetGroupInformation( _
ByVal groupID As Integer _
) As GroupInformation
C# public GroupInformation GetGroupInformation(
int groupID
);
C++ public:
GroupInformation GetGroupInformation(
int groupID
);
JScript public function GetGroupInformation(
groupID : int
) : GroupInformation;

Parameters

groupID System.Int32

Return Value

Microsoft.DirectX.DirectPlay.GroupInformation


Peer.GetHashCode() Method (Microsoft.DirectX.DirectPlay)

Peer.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Peer.GetLocalHostAddresses(LocalAddressFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.GetLocalHostAddresses Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Function GetLocalHostAddresses( _
ByVal flags As LocalAddressFlags _
) As Address()
C# public Address[] GetLocalHostAddresses(
LocalAddressFlags flags
);
C++ public:
array<Address^>^ GetLocalHostAddresses(
LocalAddressFlags flags
);
JScript public function GetLocalHostAddresses(
flags : LocalAddressFlags
) : Address[];

Parameters

flags Microsoft.DirectX.DirectPlay.LocalAddressFlags

Return Value

Microsoft.DirectX.DirectPlay.Address[]


Peer.GetPeerAddress(Int32) Method (Microsoft.DirectX.DirectPlay)

Peer.GetPeerAddress Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address for the specified remote player in the session. Deprecated.

Definition

Visual Basic Public Function GetPeerAddress( _
ByVal playerID As Integer _
) As Address
C# public Address GetPeerAddress(
int playerID
);
C++ public:
Address^ GetPeerAddress(
int playerID
);
JScript public function GetPeerAddress(
playerID : int
) : Address;

Parameters

playerID System.Int32

Return Value

Microsoft.DirectX.DirectPlay.Address


Peer.GetPeerInformation(Int32) Method (Microsoft.DirectX.DirectPlay)

Peer.GetPeerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic Public Function GetPeerInformation( _
ByVal playerID As Integer _
) As PlayerInformation
C# public PlayerInformation GetPeerInformation(
int playerID
);
C++ public:
PlayerInformation GetPeerInformation(
int playerID
);
JScript public function GetPeerInformation(
playerID : int
) : PlayerInformation;

Parameters

playerID System.Int32

Return Value

Microsoft.DirectX.DirectPlay.PlayerInformation


Peer.GetPlayerContext(Int32) Method (Microsoft.DirectX.DirectPlay)

Peer.GetPlayerContext Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the player context value for the specified peer. Deprecated.

Definition

Visual Basic Public Function GetPlayerContext( _
ByVal playerID As Integer _
) As Object
C# public object GetPlayerContext(
int playerID
);
C++ public:
Object^ GetPlayerContext(
int playerID
);
JScript public function GetPlayerContext(
playerID : int
) : Object;

Parameters

playerID System.Int32

Return Value

System.Object


Peer.GetSendQueueInformation(Int32,Int32,Int32,GetSendQueueInformationFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.GetSendQueueInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Deprecated.

Definition

Visual Basic Public Sub GetSendQueueInformation( _
ByVal dpnidPlayer As Integer, _
ByRef numberMessages As Integer, _
ByRef numberBytes As Integer, _
ByVal flags As GetSendQueueInformationFlags _
)
C# public void GetSendQueueInformation(
int dpnidPlayer,
out int numberMessages,
out int numberBytes,
GetSendQueueInformationFlags flags
);
C++ public:
void GetSendQueueInformation(
int dpnidPlayer,
[Out] int% numberMessages,
[Out] int% numberBytes,
GetSendQueueInformationFlags flags
);
JScript public function GetSendQueueInformation(
dpnidPlayer : int,
numberMessages : int,
numberBytes : int,
flags : GetSendQueueInformationFlags
);

Parameters

dpnidPlayer System.Int32
numberMessages System.Int32
numberBytes System.Int32
flags Microsoft.DirectX.DirectPlay.GetSendQueueInformationFlags


Peer.GetServiceProviders Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.

Overload List

public ServiceProviderInformation[] GetServiceProviders(bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, Guid, bool);


Peer.GetServiceProviders(Boolean) Method (Microsoft.DirectX.DirectPlay)

Peer.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
bool getAll
);
JScript public function GetServiceProviders(
getAll : boolean
) : ServiceProviderInformation[];

Parameters

getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Peer.GetServiceProviders(Guid,Boolean) Method (Microsoft.DirectX.DirectPlay)

Peer.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
JScript public function GetServiceProviders(
guidServiceProvider : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider System.Guid
getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Peer.GetServiceProviders(Guid,Guid,Boolean) Method (Microsoft.DirectX.DirectPlay)

Peer.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal guidApplication As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
JScript public function GetServiceProviders(
guidServiceProvider : Guid,
guidApplication : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider System.Guid
guidApplication System.Guid
getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Peer.GetSPCaps(Guid) Method (Microsoft.DirectX.DirectPlay)

Peer.GetSPCaps Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the structure for the specified service provider. Deprecated.

Definition

Visual Basic Public Function GetSPCaps( _
ByVal guidServiceProvider As Guid _
) As ServiceProviderCaps
C# public ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
C++ public:
ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
JScript public function GetSPCaps(
guidServiceProvider : Guid
) : ServiceProviderCaps;

Parameters

guidServiceProvider System.Guid

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderCaps


Peer.Host Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Overload List

public void Host(ApplicationDescription, Address);
public void Host(ApplicationDescription, Address, HostFlags);
public void Host(ApplicationDescription, Address, object);
public void Host(ApplicationDescription, Address, object, HostFlags);
public void Host(ApplicationDescription, Address[]);
public void Host(ApplicationDescription, Address[], HostFlags);
public void Host(ApplicationDescription, Address[], object);
public void Host(ApplicationDescription, Address[], object, HostFlags);


Peer.Host(ApplicationDescription,Address[],Object,HostFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal playerContext As Object, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
object playerContext,
HostFlags flags
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
array<Address^>^ deviceAddress,
Object^ playerContext,
HostFlags flags
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
playerContext : Object,
flags : HostFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address[]
playerContext System.Object
flags Microsoft.DirectX.DirectPlay.HostFlags


Peer.Host(ApplicationDescription,Address,Object,HostFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal playerContext As Object, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
object playerContext,
HostFlags flags
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
Address^ deviceAddress,
Object^ playerContext,
HostFlags flags
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
playerContext : Object,
flags : HostFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address
playerContext System.Object
flags Microsoft.DirectX.DirectPlay.HostFlags


Peer.Host(ApplicationDescription,Address[],HostFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
HostFlags flags
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
array<Address^>^ deviceAddress,
HostFlags flags
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
flags : HostFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address[]
flags Microsoft.DirectX.DirectPlay.HostFlags


Peer.Host(ApplicationDescription,Address,HostFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
HostFlags flags
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
Address^ deviceAddress,
HostFlags flags
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
flags : HostFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address
flags Microsoft.DirectX.DirectPlay.HostFlags


Peer.Host(ApplicationDescription,Address[],Object) Method (Microsoft.DirectX.DirectPlay)

Peer.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal playerContext As Object _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
object playerContext
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
array<Address^>^ deviceAddress,
Object^ playerContext
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
playerContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address[]
playerContext System.Object


Peer.Host(ApplicationDescription,Address,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal playerContext As Object _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
object playerContext
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
Address^ deviceAddress,
Object^ playerContext
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
playerContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address
playerContext System.Object


Peer.Host(ApplicationDescription,Address[]) Method (Microsoft.DirectX.DirectPlay)

Peer.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
array<Address^>^ deviceAddress
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[]
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address[]


Peer.Host(ApplicationDescription,Address) Method (Microsoft.DirectX.DirectPlay)

Peer.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new peer-to-peer session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
Address^ deviceAddress
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address


Peer.op_Equality(Peer,Peer) Method (Microsoft.DirectX.DirectPlay)

Peer.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Peer, _
ByVal right As Peer _
) As Boolean
C# public static bool op_Equality(
Peer left,
Peer right
);
C++ public:
static bool operator==(
Peer^ left,
Peer^ right
);
JScript public static function op_Equality(
left : Peer,
right : Peer
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Peer
The Peer structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Peer
The Peer structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Peer.op_Inequality(Peer,Peer) Method (Microsoft.DirectX.DirectPlay)

Peer.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Peer, _
ByVal right As Peer _
) As Boolean
C# public static bool op_Inequality(
Peer left,
Peer right
);
C++ public:
static bool operator!=(
Peer^ left,
Peer^ right
);
JScript public static function op_Inequality(
left : Peer,
right : Peer
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Peer
The Peer structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Peer
The Peer structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Peer.Peer Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Peer();
public Peer(InitializeFlags);


Peer.Peer(InitializeFlags) Constructor (Microsoft.DirectX.DirectPlay)

Peer.Peer Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Peer(
InitializeFlags flags
);
C++ public:
Peer(
InitializeFlags flags
);
JScript public function Peer(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags


Peer.Peer() Constructor (Microsoft.DirectX.DirectPlay)

Peer.Peer Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Peer();
C++ public:
Peer();
JScript | public function Peer();


Peer.raise_ApplicationDescriptionChanged(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_ApplicationDescriptionChanged Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ApplicationDescriptionChanged( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_ApplicationDescriptionChanged(
object i1,
EventArgs i2
);
C++ protected:
void raise_ApplicationDescriptionChanged(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_ApplicationDescriptionChanged(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Peer.raise_AsyncOperationComplete(Object,AsyncOperationCompleteEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_AsyncOperationComplete Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_AsyncOperationComplete( _
ByVal i1 As Object, _
ByVal i2 As AsyncOperationCompleteEventArgs _
)
C# protected void raise_AsyncOperationComplete(
object i1,
AsyncOperationCompleteEventArgs i2
);
C++ protected:
void raise_AsyncOperationComplete(
Object^ i1,
AsyncOperationCompleteEventArgs^ i2
);
JScript protected function raise_AsyncOperationComplete(
i1 : Object,
i2 : AsyncOperationCompleteEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs


Peer.raise_ConnectComplete(Object,ConnectCompleteEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_ConnectComplete Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ConnectComplete( _
ByVal i1 As Object, _
ByVal i2 As ConnectCompleteEventArgs _
)
C# protected void raise_ConnectComplete(
object i1,
ConnectCompleteEventArgs i2
);
C++ protected:
void raise_ConnectComplete(
Object^ i1,
ConnectCompleteEventArgs^ i2
);
JScript protected function raise_ConnectComplete(
i1 : Object,
i2 : ConnectCompleteEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ConnectCompleteEventArgs


Peer.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Peer.raise_FindHostQuery(Object,FindHostQueryEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_FindHostQuery Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_FindHostQuery( _
ByVal i1 As Object, _
ByVal i2 As FindHostQueryEventArgs _
)
C# protected void raise_FindHostQuery(
object i1,
FindHostQueryEventArgs i2
);
C++ protected:
void raise_FindHostQuery(
Object^ i1,
FindHostQueryEventArgs^ i2
);
JScript protected function raise_FindHostQuery(
i1 : Object,
i2 : FindHostQueryEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.FindHostQueryEventArgs


Peer.raise_FindHostResponse(Object,FindHostResponseEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_FindHostResponse Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_FindHostResponse( _
ByVal i1 As Object, _
ByVal i2 As FindHostResponseEventArgs _
)
C# protected void raise_FindHostResponse(
object i1,
FindHostResponseEventArgs i2
);
C++ protected:
void raise_FindHostResponse(
Object^ i1,
FindHostResponseEventArgs^ i2
);
JScript protected function raise_FindHostResponse(
i1 : Object,
i2 : FindHostResponseEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.FindHostResponseEventArgs


Peer.raise_GroupCreated(Object,GroupCreatedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_GroupCreated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_GroupCreated( _
ByVal i1 As Object, _
ByVal i2 As GroupCreatedEventArgs _
)
C# protected void raise_GroupCreated(
object i1,
GroupCreatedEventArgs i2
);
C++ protected:
void raise_GroupCreated(
Object^ i1,
GroupCreatedEventArgs^ i2
);
JScript protected function raise_GroupCreated(
i1 : Object,
i2 : GroupCreatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.GroupCreatedEventArgs


Peer.raise_GroupDestroyed(Object,GroupDestroyedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_GroupDestroyed Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_GroupDestroyed( _
ByVal i1 As Object, _
ByVal i2 As GroupDestroyedEventArgs _
)
C# protected void raise_GroupDestroyed(
object i1,
GroupDestroyedEventArgs i2
);
C++ protected:
void raise_GroupDestroyed(
Object^ i1,
GroupDestroyedEventArgs^ i2
);
JScript protected function raise_GroupDestroyed(
i1 : Object,
i2 : GroupDestroyedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.GroupDestroyedEventArgs


Peer.raise_GroupInformation(Object,GroupInformationEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_GroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_GroupInformation( _
ByVal i1 As Object, _
ByVal i2 As GroupInformationEventArgs _
)
C# protected void raise_GroupInformation(
object i1,
GroupInformationEventArgs i2
);
C++ protected:
void raise_GroupInformation(
Object^ i1,
GroupInformationEventArgs^ i2
);
JScript protected function raise_GroupInformation(
i1 : Object,
i2 : GroupInformationEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.GroupInformationEventArgs


Peer.raise_HostMigrated(Object,HostMigratedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_HostMigrated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_HostMigrated( _
ByVal i1 As Object, _
ByVal i2 As HostMigratedEventArgs _
)
C# protected void raise_HostMigrated(
object i1,
HostMigratedEventArgs i2
);
C++ protected:
void raise_HostMigrated(
Object^ i1,
HostMigratedEventArgs^ i2
);
JScript protected function raise_HostMigrated(
i1 : Object,
i2 : HostMigratedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.HostMigratedEventArgs


Peer.raise_IndicateConnect(Object,IndicateConnectEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_IndicateConnect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_IndicateConnect( _
ByVal i1 As Object, _
ByVal i2 As IndicateConnectEventArgs _
)
C# protected void raise_IndicateConnect(
object i1,
IndicateConnectEventArgs i2
);
C++ protected:
void raise_IndicateConnect(
Object^ i1,
IndicateConnectEventArgs^ i2
);
JScript protected function raise_IndicateConnect(
i1 : Object,
i2 : IndicateConnectEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.IndicateConnectEventArgs


Peer.raise_IndicatedConnectAborted(Object,IndicatedConnectAbortedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_IndicatedConnectAborted Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_IndicatedConnectAborted( _
ByVal i1 As Object, _
ByVal i2 As IndicatedConnectAbortedEventArgs _
)
C# protected void raise_IndicatedConnectAborted(
object i1,
IndicatedConnectAbortedEventArgs i2
);
C++ protected:
void raise_IndicatedConnectAborted(
Object^ i1,
IndicatedConnectAbortedEventArgs^ i2
);
JScript protected function raise_IndicatedConnectAborted(
i1 : Object,
i2 : IndicatedConnectAbortedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedEventArgs


Peer.raise_PeerInformation(Object,PeerInformationEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_PeerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PeerInformation( _
ByVal i1 As Object, _
ByVal i2 As PeerInformationEventArgs _
)
C# protected void raise_PeerInformation(
object i1,
PeerInformationEventArgs i2
);
C++ protected:
void raise_PeerInformation(
Object^ i1,
PeerInformationEventArgs^ i2
);
JScript protected function raise_PeerInformation(
i1 : Object,
i2 : PeerInformationEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PeerInformationEventArgs


Peer.raise_PlayerAddedToGroup(Object,PlayerAddedToGroupEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_PlayerAddedToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerAddedToGroup( _
ByVal i1 As Object, _
ByVal i2 As PlayerAddedToGroupEventArgs _
)
C# protected void raise_PlayerAddedToGroup(
object i1,
PlayerAddedToGroupEventArgs i2
);
C++ protected:
void raise_PlayerAddedToGroup(
Object^ i1,
PlayerAddedToGroupEventArgs^ i2
);
JScript protected function raise_PlayerAddedToGroup(
i1 : Object,
i2 : PlayerAddedToGroupEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PlayerAddedToGroupEventArgs


Peer.raise_PlayerCreated(Object,PlayerCreatedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_PlayerCreated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerCreated( _
ByVal i1 As Object, _
ByVal i2 As PlayerCreatedEventArgs _
)
C# protected void raise_PlayerCreated(
object i1,
PlayerCreatedEventArgs i2
);
C++ protected:
void raise_PlayerCreated(
Object^ i1,
PlayerCreatedEventArgs^ i2
);
JScript protected function raise_PlayerCreated(
i1 : Object,
i2 : PlayerCreatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PlayerCreatedEventArgs


Peer.raise_PlayerDestroyed(Object,PlayerDestroyedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_PlayerDestroyed Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerDestroyed( _
ByVal i1 As Object, _
ByVal i2 As PlayerDestroyedEventArgs _
)
C# protected void raise_PlayerDestroyed(
object i1,
PlayerDestroyedEventArgs i2
);
C++ protected:
void raise_PlayerDestroyed(
Object^ i1,
PlayerDestroyedEventArgs^ i2
);
JScript protected function raise_PlayerDestroyed(
i1 : Object,
i2 : PlayerDestroyedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PlayerDestroyedEventArgs


Peer.raise_PlayerRemovedFromGroup(Object,PlayerRemovedFromGroupEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_PlayerRemovedFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerRemovedFromGroup( _
ByVal i1 As Object, _
ByVal i2 As PlayerRemovedFromGroupEventArgs _
)
C# protected void raise_PlayerRemovedFromGroup(
object i1,
PlayerRemovedFromGroupEventArgs i2
);
C++ protected:
void raise_PlayerRemovedFromGroup(
Object^ i1,
PlayerRemovedFromGroupEventArgs^ i2
);
JScript protected function raise_PlayerRemovedFromGroup(
i1 : Object,
i2 : PlayerRemovedFromGroupEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PlayerRemovedFromGroupEventArgs


Peer.raise_Receive(Object,ReceiveEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_Receive Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
C++ protected:
void raise_Receive(
Object^ i1,
ReceiveEventArgs^ i2
);
JScript protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ReceiveEventArgs


Peer.raise_SendComplete(Object,SendCompleteEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_SendComplete Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SendComplete( _
ByVal i1 As Object, _
ByVal i2 As SendCompleteEventArgs _
)
C# protected void raise_SendComplete(
object i1,
SendCompleteEventArgs i2
);
C++ protected:
void raise_SendComplete(
Object^ i1,
SendCompleteEventArgs^ i2
);
JScript protected function raise_SendComplete(
i1 : Object,
i2 : SendCompleteEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.SendCompleteEventArgs


Peer.raise_SessionTerminated(Object,SessionTerminatedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Peer.raise_SessionTerminated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SessionTerminated( _
ByVal i1 As Object, _
ByVal i2 As SessionTerminatedEventArgs _
)
C# protected void raise_SessionTerminated(
object i1,
SessionTerminatedEventArgs i2
);
C++ protected:
void raise_SessionTerminated(
Object^ i1,
SessionTerminatedEventArgs^ i2
);
JScript protected function raise_SessionTerminated(
i1 : Object,
i2 : SessionTerminatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.SessionTerminatedEventArgs


Peer.RegisterLobby(Int32,Application) Method (Microsoft.DirectX.DirectPlay)

Peer.RegisterLobby Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub RegisterLobby( _
ByVal handle As Integer, _
ByVal lobbiedApplication As Application _
)
C# public void RegisterLobby(
int handle,
Application lobbiedApplication
);
C++ public:
void RegisterLobby(
int handle,
Application^ lobbiedApplication
);
JScript public function RegisterLobby(
handle : int,
lobbiedApplication : Application
);

Parameters

handle System.Int32
lobbiedApplication Microsoft.DirectX.DirectPlay.Lobby.Application


Peer.RemovePlayerFromGroup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Overload List

public void RemovePlayerFromGroup(int, int, out int, SyncFlags);
public void RemovePlayerFromGroup(int, int, out int, SyncFlags, object);
public void RemovePlayerFromGroup(int, int, SyncFlags);
public void RemovePlayerFromGroup(int, int, SyncFlags, object);


Peer.RemovePlayerFromGroup(Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.RemovePlayerFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags,
object asyncContext
);
C++ public:
void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags,
Object^ asyncContext
);
JScript public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
clientID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.RemovePlayerFromGroup(Int32,Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.RemovePlayerFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void RemovePlayerFromGroup(
int groupID,
int clientID,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
clientID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.RemovePlayerFromGroup(Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.RemovePlayerFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags
);
C++ public:
void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags
);
JScript public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
clientID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.RemovePlayerFromGroup(Int32,Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.RemovePlayerFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a peer from a group.When this method is called all peers connected to the application receive a message. Deprecated.

Definition

Visual Basic Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void RemovePlayerFromGroup(
int groupID,
int clientID,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
clientID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.SendTo Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Overload List

public void SendTo(int, GCHandle, int, int, out int, SendFlags);
public void SendTo(int, GCHandle, int, int, out int, SendFlags, object);
public void SendTo(int, GCHandle, int, int, SendFlags);
public void SendTo(int, GCHandle, int, int, SendFlags, object);
public void SendTo(int, NetworkPacket, int, out int, SendFlags);
public void SendTo(int, NetworkPacket, int, out int, SendFlags, object);
public void SendTo(int, NetworkPacket, int, SendFlags);
public void SendTo(int, NetworkPacket, int, SendFlags, object);


Peer.SendTo(Int32,GCHandle,Int32,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
C++ public:
void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags,
Object^ context
);
JScript public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

playerID System.Int32
gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Peer.SendTo(Int32,GCHandle,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
object context
);
C++ public:
void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
Object^ context
);
JScript public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

playerID System.Int32
gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Peer.SendTo(Int32,GCHandle,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
C++ public:
void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
JScript public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags
);

Parameters

playerID System.Int32
gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Peer.SendTo(Int32,GCHandle,Int32,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags
);
C++ public:
void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags
);
JScript public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

playerID System.Int32
gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Peer.SendTo(Int32,NetworkPacket,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
C++ public:
void SendTo(
int playerID,
NetworkPacket^ sendData,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags,
Object^ context
);
JScript public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

playerID System.Int32
sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Peer.SendTo(Int32,NetworkPacket,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
SendFlags flags,
object context
);
C++ public:
void SendTo(
int playerID,
NetworkPacket^ sendData,
int timeOut,
SendFlags flags,
Object^ context
);
JScript public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

playerID System.Int32
sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Peer.SendTo(Int32,NetworkPacket,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
SendFlags flags
);
C++ public:
void SendTo(
int playerID,
NetworkPacket^ sendData,
int timeOut,
SendFlags flags
);
JScript public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags
);

Parameters

playerID System.Int32
sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Peer.SendTo(Int32,NetworkPacket,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to another peer or group within the session by sending a message to the appropriate message handlers. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags
);
C++ public:
void SendTo(
int playerID,
NetworkPacket^ sendData,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags
);
JScript public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

playerID System.Int32
sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Peer.SetGroupInformation Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Overload List

public void SetGroupInformation(int, GroupInformation, out int, SyncFlags);
public void SetGroupInformation(int, GroupInformation, out int, SyncFlags, object);
public void SetGroupInformation(int, GroupInformation, SyncFlags);
public void SetGroupInformation(int, GroupInformation, SyncFlags, object);


Peer.SetGroupInformation(Int32,GroupInformation,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.SetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags
);
C++ public:
void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags
);
JScript public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
flags : SyncFlags
);

Parameters

groupID System.Int32
groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.SetGroupInformation(Int32,GroupInformation,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.SetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.SetGroupInformation(Int32,GroupInformation,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.SetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.SetGroupInformation(Int32,GroupInformation,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.SetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.SetPeerInformation Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Overload List

public void SetPeerInformation(PlayerInformation, out int, SyncFlags);
public void SetPeerInformation(PlayerInformation, out int, SyncFlags, object);
public void SetPeerInformation(PlayerInformation, SyncFlags);
public void SetPeerInformation(PlayerInformation, SyncFlags, object);


Peer.SetPeerInformation(PlayerInformation,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.SetPeerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic Public Sub SetPeerInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags _
)
C# public void SetPeerInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
C++ public:
void SetPeerInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
JScript public function SetPeerInformation(
playerInformation : PlayerInformation,
flags : SyncFlags
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.SetPeerInformation(PlayerInformation,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Peer.SetPeerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic Public Sub SetPeerInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetPeerInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void SetPeerInformation(
PlayerInformation playerInformation,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function SetPeerInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Peer.SetPeerInformation(PlayerInformation,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.SetPeerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic Public Sub SetPeerInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetPeerInformation(
PlayerInformation playerInformation,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetPeerInformation(
PlayerInformation playerInformation,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetPeerInformation(
playerInformation : PlayerInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.SetPeerInformation(PlayerInformation,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Peer.SetPeerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic Public Sub SetPeerInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetPeerInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetPeerInformation(
PlayerInformation playerInformation,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetPeerInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Peer.SetSPCaps(Guid,ServiceProviderCaps) Method (Microsoft.DirectX.DirectPlay)

Peer.SetSPCaps Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the DpnSpCapsDplay structure for the specified service provider. Deprecated.

Definition

Visual Basic Public Sub SetSPCaps( _
ByVal guidServiceProvider As Guid, _
ByVal value As ServiceProviderCaps _
)
C# public void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
C++ public:
void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
JScript public function SetSPCaps(
guidServiceProvider : Guid,
value : ServiceProviderCaps
);

Parameters

guidServiceProvider System.Guid
value Microsoft.DirectX.DirectPlay.ServiceProviderCaps


Peer.TerminateSession(NetworkPacket) Method (Microsoft.DirectX.DirectPlay)

Peer.TerminateSession Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Terminates the current session. Deprecated.

Definition

Visual Basic Public Sub TerminateSession( _
ByVal terminateData As NetworkPacket _
)
C# public void TerminateSession(
NetworkPacket terminateData
);
C++ public:
void TerminateSession(
NetworkPacket^ terminateData
);
JScript public function TerminateSession(
terminateData : NetworkPacket
);

Parameters

terminateData Microsoft.DirectX.DirectPlay.NetworkPacket


Peer.UnregisterLobby() Method (Microsoft.DirectX.DirectPlay)

Peer.UnregisterLobby Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Sub UnregisterLobby()
C# | public void UnregisterLobby();
C++ public:
void UnregisterLobby();
JScript | public function UnregisterLobby();


Peer.ApplicationDescription Property (Microsoft.DirectX.DirectPlay)

Peer.ApplicationDescription Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the full application description for the connected application. Deprecated.

Definition

Visual Basic | Public Property ApplicationDescription As ApplicationDescription
C# | public ApplicationDescription ApplicationDescription { get; set; }
C++ public:
property ApplicationDescription ApplicationDescription {
ApplicationDescription get();
void set(ApplicationDescription value);
}
JScript public function get ApplicationDescription() : ApplicationDescription
public function set ApplicationDescription(ApplicationDescription);

Property Value

Microsoft.DirectX.DirectPlay.ApplicationDescription

This property is read/write.


Peer.Caps Property (Microsoft.DirectX.DirectPlay)

Peer.Caps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Peer object. Deprecated.

Definition

Visual Basic | Public Property Caps As Caps
C# | public Caps Caps { get; set; }
C++ public:
property Caps Caps {
Caps get();
void set(Caps value);
}
JScript public function get Caps() : Caps
public function set Caps(Caps);

Property Value

Microsoft.DirectX.DirectPlay.Caps

This property is read/write.


Peer.Disposed Property (Microsoft.DirectX.DirectPlay)

Peer.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Peer.GroupMembers Property (Microsoft.DirectX.DirectPlay)

Peer.GroupMembers Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupMembers As GroupMembersList
C# | public GroupMembersList GroupMembers { get; }
C++ public:
property GroupMembersList^ GroupMembers {
GroupMembersList^ get();
}
JScript | public function get GroupMembers() : GroupMembersList

Property Value

Microsoft.DirectX.DirectPlay.GroupMembersList

This property is read-only.


Peer.Groups Property (Microsoft.DirectX.DirectPlay)

Peer.Groups Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the session. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Groups As PlayersGroupsEnumerator
C# | public PlayersGroupsEnumerator Groups { get; }
C++ public:
property PlayersGroupsEnumerator^ Groups {
PlayersGroupsEnumerator^ get();
}
JScript | public function get Groups() : PlayersGroupsEnumerator

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator

This property is read-only.


Peer.Players Property (Microsoft.DirectX.DirectPlay)

Peer.Players Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the session. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Players As PlayersGroupsEnumerator
C# | public PlayersGroupsEnumerator Players { get; }
C++ public:
property PlayersGroupsEnumerator^ Players {
PlayersGroupsEnumerator^ get();
}
JScript | public function get Players() : PlayersGroupsEnumerator

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator

This property is read-only.


Peer.ApplicationDescriptionChanged Event (Microsoft.DirectX.DirectPlay)

Peer.ApplicationDescriptionChanged Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.

Definition

Visual Basic | Public Event ApplicationDescriptionChanged As ApplicationDescriptionEventHandler
C# | public event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
C++ public:
event ApplicationDescriptionEventHandler^ ApplicationDescriptionChanged;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.AsyncOperationComplete Event (Microsoft.DirectX.DirectPlay)

Peer.AsyncOperationComplete Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the async operation has completed. Deprecated.

Definition

Visual Basic | Public Event AsyncOperationComplete As AsyncOperationCompleteEventHandler
C# | public event AsyncOperationCompleteEventHandler AsyncOperationComplete;
C++ public:
event AsyncOperationCompleteEventHandler^ AsyncOperationComplete;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.ConnectComplete Event (Microsoft.DirectX.DirectPlay)

Peer.ConnectComplete Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a connection has been completed. Deprecated.

Definition

Visual Basic | Public Event ConnectComplete As ConnectCompleteEventHandler
C# | public event ConnectCompleteEventHandler ConnectComplete;
C++ public:
event ConnectCompleteEventHandler^ ConnectComplete;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.Disposing Event (Microsoft.DirectX.DirectPlay)

Peer.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Peer.Disposing event, use the following code.

peer.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Peer.FindHostQuery Event (Microsoft.DirectX.DirectPlay)

Peer.FindHostQuery Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an when a peer or client is enumerating the available hosts. Deprecated.

Definition

Visual Basic | Public Event FindHostQuery As FindHostQueryEventHandler
C# | public event FindHostQueryEventHandler FindHostQuery;
C++ public:
event FindHostQueryEventHandler^ FindHostQuery;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.FindHostResponse Event (Microsoft.DirectX.DirectPlay)

Peer.FindHostResponse Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a host responds to a FindHosts call. Deprecated.

Definition

Visual Basic | Public Event FindHostResponse As FindHostResponseEventHandler
C# | public event FindHostResponseEventHandler FindHostResponse;
C++ public:
event FindHostResponseEventHandler^ FindHostResponse;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.GroupCreated Event (Microsoft.DirectX.DirectPlay)

Peer.GroupCreated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is created. Deprecated.

Definition

Visual Basic | Public Event GroupCreated As GroupCreatedEventHandler
C# | public event GroupCreatedEventHandler GroupCreated;
C++ public:
event GroupCreatedEventHandler^ GroupCreated;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.GroupDestroyed Event (Microsoft.DirectX.DirectPlay)

Peer.GroupDestroyed Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is destroyed. Deprecated.

Definition

Visual Basic | Public Event GroupDestroyed As GroupDestroyedEventHandler
C# | public event GroupDestroyedEventHandler GroupDestroyed;
C++ public:
event GroupDestroyedEventHandler^ GroupDestroyed;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.GroupInformation Event (Microsoft.DirectX.DirectPlay)

Peer.GroupInformation Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a DpnMsgidGroupInfoDplay system message is received indicating that the group data has been modified. Deprecated.

Definition

Visual Basic | Public Event GroupInformation As GroupInformationEventHandler
C# | public event GroupInformationEventHandler GroupInformation;
C++ public:
event GroupInformationEventHandler^ GroupInformation;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.HostMigrated Event (Microsoft.DirectX.DirectPlay)

Peer.HostMigrated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the host has been migrated. Deprecated.

Definition

Visual Basic | Public Event HostMigrated As HostMigratedEventHandler
C# | public event HostMigratedEventHandler HostMigrated;
C++ public:
event HostMigratedEventHandler^ HostMigrated;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.IndicateConnect Event (Microsoft.DirectX.DirectPlay)

Peer.IndicateConnect Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is trying to connect to your session. Deprecated.

Definition

Visual Basic | Public Event IndicateConnect As IndicateConnectEventHandler
C# | public event IndicateConnectEventHandler IndicateConnect;
C++ public:
event IndicateConnectEventHandler^ IndicateConnect;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.IndicatedConnectAborted Event (Microsoft.DirectX.DirectPlay)

Peer.IndicatedConnectAborted Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an indicated played has aborted his connection. Deprecated.

Definition

Visual Basic | Public Event IndicatedConnectAborted As IndicatedConnectAbortedEventHandler
C# | public event IndicatedConnectAbortedEventHandler IndicatedConnectAborted;
C++ public:
event IndicatedConnectAbortedEventHandler^ IndicatedConnectAborted;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.PeerInformation Event (Microsoft.DirectX.DirectPlay)

Peer.PeerInformation Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves peer information set for the specified peer. Deprecated.

Definition

Visual Basic | Public Event PeerInformation As PeerInformationEventHandler
C# | public event PeerInformationEventHandler PeerInformation;
C++ public:
event PeerInformationEventHandler^ PeerInformation;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.PlayerAddedToGroup Event (Microsoft.DirectX.DirectPlay)

Peer.PlayerAddedToGroup Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is added to a group. Deprecated.

Definition

Visual Basic | Public Event PlayerAddedToGroup As PlayerAddedToGroupEventHandler
C# | public event PlayerAddedToGroupEventHandler PlayerAddedToGroup;
C++ public:
event PlayerAddedToGroupEventHandler^ PlayerAddedToGroup;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.PlayerCreated Event (Microsoft.DirectX.DirectPlay)

Peer.PlayerCreated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.

Definition

Visual Basic | Public Event PlayerCreated As PlayerCreatedEventHandler
C# | public event PlayerCreatedEventHandler PlayerCreated;
C++ public:
event PlayerCreatedEventHandler^ PlayerCreated;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.PlayerDestroyed Event (Microsoft.DirectX.DirectPlay)

Peer.PlayerDestroyed Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.

Definition

Visual Basic | Public Event PlayerDestroyed As PlayerDestroyedEventHandler
C# | public event PlayerDestroyedEventHandler PlayerDestroyed;
C++ public:
event PlayerDestroyedEventHandler^ PlayerDestroyed;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.PlayerRemovedFromGroup Event (Microsoft.DirectX.DirectPlay)

Peer.PlayerRemovedFromGroup Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been removed from a group. Deprecated.

Definition

Visual Basic | Public Event PlayerRemovedFromGroup As PlayerRemovedFromGroupEventHandler
C# | public event PlayerRemovedFromGroupEventHandler PlayerRemovedFromGroup;
C++ public:
event PlayerRemovedFromGroupEventHandler^ PlayerRemovedFromGroup;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.Receive Event (Microsoft.DirectX.DirectPlay)

Peer.Receive Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the peer object receives data. Deprecated.

Definition

Visual Basic | Public Event Receive As ReceiveEventHandler
C# | public event ReceiveEventHandler Receive;
C++ public:
event ReceiveEventHandler^ Receive;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.SendComplete Event (Microsoft.DirectX.DirectPlay)

Peer.SendComplete Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.

Definition

Visual Basic | Public Event SendComplete As SendCompleteEventHandler
C# | public event SendCompleteEventHandler SendComplete;
C++ public:
event SendCompleteEventHandler^ SendComplete;
JScript | In JScript, you can use events, but you cannot define your own.


Peer.SessionTerminated Event (Microsoft.DirectX.DirectPlay)

Peer.SessionTerminated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the session has been terminated. Deprecated.

Definition

Visual Basic | Public Event SessionTerminated As SessionTerminatedEventHandler
C# | public event SessionTerminatedEventHandler SessionTerminated;
C++ public:
event SessionTerminatedEventHandler^ SessionTerminated;
JScript | In JScript, you can use events, but you cannot define your own.


PeerInformationEventArgs Class (Microsoft.DirectX.DirectPlay)

PeerInformationEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class PeerInformationEventArgs
Inherits EventArgs
C# | public sealed class PeerInformationEventArgs : EventArgs
C++ | public ref class PeerInformationEventArgs sealed : EventArgs
JScript | public final class PeerInformationEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PeerInformationEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PeerInformationEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PeerInformationEventArgs.PeerInformationEventArgs(PeerInformationMessage) Constructor (Microsoft.DirectX.DirectPlay)

PeerInformationEventArgs.PeerInformationEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As PeerInformationMessage _
)
C# public PeerInformationEventArgs(
PeerInformationMessage dpMessage
);
C++ public:
PeerInformationEventArgs(
PeerInformationMessage dpMessage
);
JScript public function PeerInformationEventArgs(
dpMessage : PeerInformationMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.PeerInformationMessage


PeerInformationEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

PeerInformationEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As PeerInformationMessage
C# | public PeerInformationMessage Message;
C++ | public: PeerInformationMessage Message;
JScript | public var Message : PeerInformationMessage

Field Value

Microsoft.DirectX.DirectPlay.PeerInformationMessage

This field is read/write.


PlayerAddedToGroupEventArgs Class (Microsoft.DirectX.DirectPlay)

PlayerAddedToGroupEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerAddedToGroup event. Deprecated.

Definition

Visual Basic NotInheritable Public Class PlayerAddedToGroupEventArgs
Inherits EventArgs
C# | public sealed class PlayerAddedToGroupEventArgs : EventArgs
C++ | public ref class PlayerAddedToGroupEventArgs sealed : EventArgs
JScript | public final class PlayerAddedToGroupEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerAddedToGroupEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerAddedToGroupEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerAddedToGroupEventArgs.PlayerAddedToGroupEventArgs(AddPlayerToGroupMessage) Constructor (Microsoft.DirectX.DirectPlay)

PlayerAddedToGroupEventArgs.PlayerAddedToGroupEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As AddPlayerToGroupMessage _
)
C# public PlayerAddedToGroupEventArgs(
AddPlayerToGroupMessage dpMessage
);
C++ public:
PlayerAddedToGroupEventArgs(
AddPlayerToGroupMessage dpMessage
);
JScript public function PlayerAddedToGroupEventArgs(
dpMessage : AddPlayerToGroupMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.AddPlayerToGroupMessage


PlayerAddedToGroupEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

PlayerAddedToGroupEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As AddPlayerToGroupMessage
C# | public AddPlayerToGroupMessage Message;
C++ | public: AddPlayerToGroupMessage Message;
JScript | public var Message : AddPlayerToGroupMessage

Field Value

Microsoft.DirectX.DirectPlay.AddPlayerToGroupMessage

This field is read/write.


PlayerAlreadyInGroupException Class (Microsoft.DirectX.DirectPlay)

PlayerAlreadyInGroupException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is already included in the group. Deprecated.

Definition

Visual Basic Public Class PlayerAlreadyInGroupException
Inherits DirectPlayException
C# | public class PlayerAlreadyInGroupException : DirectPlayException
C++ | public ref class PlayerAlreadyInGroupException : DirectPlayException
JScript | public class PlayerAlreadyInGroupException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlayerAlreadyInGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
PlayerAlreadyInGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlayerAlreadyInGroupException();
protected PlayerAlreadyInGroupException(SerializationInfo, StreamingContext);
public PlayerAlreadyInGroupException(string);
public PlayerAlreadyInGroupException(string, Exception);


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlayerAlreadyInGroupException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PlayerAlreadyInGroupException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PlayerAlreadyInGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlayerAlreadyInGroupException(
string message,
Exception inner
);
C++ public:
PlayerAlreadyInGroupException(
String^ message,
Exception^ inner
);
JScript public function PlayerAlreadyInGroupException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException(String) Constructor (Microsoft.DirectX.DirectPlay)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PlayerAlreadyInGroupException(
string message
);
C++ public:
PlayerAlreadyInGroupException(
String^ message
);
JScript public function PlayerAlreadyInGroupException(
message : String
);

Parameters

message System.String


PlayerAlreadyInGroupException.PlayerAlreadyInGroupException() Constructor (Microsoft.DirectX.DirectPlay)

PlayerAlreadyInGroupException.PlayerAlreadyInGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlayerAlreadyInGroupException();
C++ public:
PlayerAlreadyInGroupException();
JScript | public function PlayerAlreadyInGroupException();


PlayerCreatedEventArgs Class (Microsoft.DirectX.DirectPlay)

PlayerCreatedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerCreated event. Deprecated.

Definition

Visual Basic NotInheritable Public Class PlayerCreatedEventArgs
Inherits EventArgs
C# | public sealed class PlayerCreatedEventArgs : EventArgs
C++ | public ref class PlayerCreatedEventArgs sealed : EventArgs
JScript | public final class PlayerCreatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerCreatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerCreatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerCreatedEventArgs.PlayerCreatedEventArgs(CreatePlayerMessage) Constructor (Microsoft.DirectX.DirectPlay)

PlayerCreatedEventArgs.PlayerCreatedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As CreatePlayerMessage _
)
C# public PlayerCreatedEventArgs(
CreatePlayerMessage dpMessage
);
C++ public:
PlayerCreatedEventArgs(
CreatePlayerMessage dpMessage
);
JScript public function PlayerCreatedEventArgs(
dpMessage : CreatePlayerMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.CreatePlayerMessage


PlayerCreatedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

PlayerCreatedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As CreatePlayerMessage
C# | public CreatePlayerMessage Message;
C++ | public: CreatePlayerMessage Message;
JScript | public var Message : CreatePlayerMessage

Field Value

Microsoft.DirectX.DirectPlay.CreatePlayerMessage

This field is read/write.


PlayerDestroyedEventArgs Class (Microsoft.DirectX.DirectPlay)

PlayerDestroyedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerDestroyed event. Deprecated.

Definition

Visual Basic NotInheritable Public Class PlayerDestroyedEventArgs
Inherits EventArgs
C# | public sealed class PlayerDestroyedEventArgs : EventArgs
C++ | public ref class PlayerDestroyedEventArgs sealed : EventArgs
JScript | public final class PlayerDestroyedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerDestroyedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerDestroyedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerDestroyedEventArgs.PlayerDestroyedEventArgs(DestroyPlayerMessage) Constructor (Microsoft.DirectX.DirectPlay)

PlayerDestroyedEventArgs.PlayerDestroyedEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As DestroyPlayerMessage _
)
C# public PlayerDestroyedEventArgs(
DestroyPlayerMessage dpMessage
);
C++ public:
PlayerDestroyedEventArgs(
DestroyPlayerMessage dpMessage
);
JScript public function PlayerDestroyedEventArgs(
dpMessage : DestroyPlayerMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.DestroyPlayerMessage


PlayerDestroyedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

PlayerDestroyedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As DestroyPlayerMessage
C# | public DestroyPlayerMessage Message;
C++ | public: DestroyPlayerMessage Message;
JScript | public var Message : DestroyPlayerMessage

Field Value

Microsoft.DirectX.DirectPlay.DestroyPlayerMessage

This field is read/write.


PlayerLostException Class (Microsoft.DirectX.DirectPlay)

PlayerLostException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A player has lost the connection to the session. Deprecated.

Definition

Visual Basic Public Class PlayerLostException
Inherits DirectPlayException
C# | public class PlayerLostException : DirectPlayException
C++ | public ref class PlayerLostException : DirectPlayException
JScript | public class PlayerLostException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlayerLostException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
PlayerLostException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerLostException.PlayerLostException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlayerLostException();
protected PlayerLostException(SerializationInfo, StreamingContext);
public PlayerLostException(string);
public PlayerLostException(string, Exception);


PlayerLostException.PlayerLostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

PlayerLostException.PlayerLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlayerLostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PlayerLostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PlayerLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


PlayerLostException.PlayerLostException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

PlayerLostException.PlayerLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlayerLostException(
string message,
Exception inner
);
C++ public:
PlayerLostException(
String^ message,
Exception^ inner
);
JScript public function PlayerLostException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


PlayerLostException.PlayerLostException(String) Constructor (Microsoft.DirectX.DirectPlay)

PlayerLostException.PlayerLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PlayerLostException(
string message
);
C++ public:
PlayerLostException(
String^ message
);
JScript public function PlayerLostException(
message : String
);

Parameters

message System.String


PlayerLostException.PlayerLostException() Constructor (Microsoft.DirectX.DirectPlay)

PlayerLostException.PlayerLostException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlayerLostException();
C++ public:
PlayerLostException();
JScript | public function PlayerLostException();


PlayerNotInGroupException Class (Microsoft.DirectX.DirectPlay)

PlayerNotInGroupException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The player ID is not included in the group. Deprecated.

Definition

Visual Basic Public Class PlayerNotInGroupException
Inherits DirectPlayException
C# | public class PlayerNotInGroupException : DirectPlayException
C++ | public ref class PlayerNotInGroupException : DirectPlayException
JScript | public class PlayerNotInGroupException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlayerNotInGroupException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
PlayerNotInGroupException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerNotInGroupException.PlayerNotInGroupException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlayerNotInGroupException();
protected PlayerNotInGroupException(SerializationInfo, StreamingContext);
public PlayerNotInGroupException(string);
public PlayerNotInGroupException(string, Exception);


PlayerNotInGroupException.PlayerNotInGroupException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlayerNotInGroupException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PlayerNotInGroupException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PlayerNotInGroupException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


PlayerNotInGroupException.PlayerNotInGroupException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlayerNotInGroupException(
string message,
Exception inner
);
C++ public:
PlayerNotInGroupException(
String^ message,
Exception^ inner
);
JScript public function PlayerNotInGroupException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


PlayerNotInGroupException.PlayerNotInGroupException(String) Constructor (Microsoft.DirectX.DirectPlay)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PlayerNotInGroupException(
string message
);
C++ public:
PlayerNotInGroupException(
String^ message
);
JScript public function PlayerNotInGroupException(
message : String
);

Parameters

message System.String


PlayerNotInGroupException.PlayerNotInGroupException() Constructor (Microsoft.DirectX.DirectPlay)

PlayerNotInGroupException.PlayerNotInGroupException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlayerNotInGroupException();
C++ public:
PlayerNotInGroupException();
JScript | public function PlayerNotInGroupException();


PlayerNotReachableException Class (Microsoft.DirectX.DirectPlay)

PlayerNotReachableException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
A player has tried to join a peer-peer session where at least one other existing player in the session cannot connect to the joining player. Deprecated.

Definition

Visual Basic Public Class PlayerNotReachableException
Inherits DirectPlayException
C# | public class PlayerNotReachableException : DirectPlayException
C++ | public ref class PlayerNotReachableException : DirectPlayException
JScript | public class PlayerNotReachableException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PlayerNotReachableException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
PlayerNotReachableException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerNotReachableException.PlayerNotReachableException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public PlayerNotReachableException();
protected PlayerNotReachableException(SerializationInfo, StreamingContext);
public PlayerNotReachableException(string);
public PlayerNotReachableException(string, Exception);


PlayerNotReachableException.PlayerNotReachableException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PlayerNotReachableException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PlayerNotReachableException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PlayerNotReachableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


PlayerNotReachableException.PlayerNotReachableException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PlayerNotReachableException(
string message,
Exception inner
);
C++ public:
PlayerNotReachableException(
String^ message,
Exception^ inner
);
JScript public function PlayerNotReachableException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


PlayerNotReachableException.PlayerNotReachableException(String) Constructor (Microsoft.DirectX.DirectPlay)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PlayerNotReachableException(
string message
);
C++ public:
PlayerNotReachableException(
String^ message
);
JScript public function PlayerNotReachableException(
message : String
);

Parameters

message System.String


PlayerNotReachableException.PlayerNotReachableException() Constructor (Microsoft.DirectX.DirectPlay)

PlayerNotReachableException.PlayerNotReachableException Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlayerNotReachableException();
C++ public:
PlayerNotReachableException();
JScript | public function PlayerNotReachableException();


PlayerRemovedFromGroupEventArgs Class (Microsoft.DirectX.DirectPlay)

PlayerRemovedFromGroupEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the PlayerRemovedFromGroup event. Deprecated.

Definition

Visual Basic NotInheritable Public Class PlayerRemovedFromGroupEventArgs
Inherits EventArgs
C# | public sealed class PlayerRemovedFromGroupEventArgs : EventArgs
C++ | public ref class PlayerRemovedFromGroupEventArgs sealed : EventArgs
JScript | public final class PlayerRemovedFromGroupEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
PlayerRemovedFromGroupEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
PlayerRemovedFromGroupEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerRemovedFromGroupEventArgs.PlayerRemovedFromGroupEventArgs(RemovePlayerFromGroupMessage) Constructor (Microsoft.DirectX.DirectPlay)

PlayerRemovedFromGroupEventArgs.PlayerRemovedFromGroupEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As RemovePlayerFromGroupMessage _
)
C# public PlayerRemovedFromGroupEventArgs(
RemovePlayerFromGroupMessage dpMessage
);
C++ public:
PlayerRemovedFromGroupEventArgs(
RemovePlayerFromGroupMessage dpMessage
);
JScript public function PlayerRemovedFromGroupEventArgs(
dpMessage : RemovePlayerFromGroupMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.RemovePlayerFromGroupMessage


PlayerRemovedFromGroupEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

PlayerRemovedFromGroupEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As RemovePlayerFromGroupMessage
C# | public RemovePlayerFromGroupMessage Message;
C++ | public: RemovePlayerFromGroupMessage Message;
JScript | public var Message : RemovePlayerFromGroupMessage

Field Value

Microsoft.DirectX.DirectPlay.RemovePlayerFromGroupMessage

This field is read/write.


PlayersGroupsEnumerator Class (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides an enumerator for player and group lists. Deprecated.

Definition

Visual Basic NotInheritable Public Class PlayersGroupsEnumerator
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class PlayersGroupsEnumerator : Object, IEnumerable, IEnumerator
C++ | public ref class PlayersGroupsEnumerator sealed : Object, IEnumerable, IEnumerator
JScript | public final class PlayersGroupsEnumerator extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns an array of Int32 representing the player or group id's of the members of the list. Deprecated.
GetEnumerator
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.
GetUserData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the user data Deprecated.
MoveNext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.
Reset
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Properties

Property Description
Count
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.
Current
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.
Item
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the current user or group name. Deprecated.

Inheritance Hierarchy

Object Leave Site
PlayersGroupsEnumerator

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayersGroupsEnumerator.GetData() Method (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.GetData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns an array of Int32 representing the player or group id's of the members of the list. Deprecated.

Definition

Visual Basic | Public Function GetData() As Integer()
C# | public int[] GetData();
C++ public:
array<int>^ GetData();
JScript | public function GetData() : int[];

Return Value

System.Int32[]


PlayersGroupsEnumerator.GetEnumerator() Method (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.GetEnumerator Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets an enumerator for this collection. Deprecated.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator


PlayersGroupsEnumerator.GetUserData() Method (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.GetUserData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Get the user data Deprecated.

Definition

Visual Basic | Public Function GetUserData() As Byte()
C# | public byte[] GetUserData();
C++ public:
array<unsigned char>^ GetUserData();
JScript | public function GetUserData() : byte[];

Return Value

System.Byte[]


PlayersGroupsEnumerator.MoveNext() Method (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.MoveNext Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Advances the enumerator to the next element of the collection. Deprecated.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean


PlayersGroupsEnumerator.Reset() Method (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.Reset Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the enumerator to its initial position, which is before the first element in the collection. Deprecated.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();


PlayersGroupsEnumerator.Count Property (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.Count Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the number of elements. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32

This property is read-only.


PlayersGroupsEnumerator.Current Property (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.Current Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets the current element in the collection. Deprecated.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object

This property is read-only.


PlayersGroupsEnumerator.Item Property (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.Item Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal index As Integer _
) As Integer
C# public int this[
int index
] { get; }
C++ public:
property int default [int] {
int get(int index);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32

Property Value

System.Int32

This property is read-only.


PlayersGroupsEnumerator.Name Property (Microsoft.DirectX.DirectPlay)

PlayersGroupsEnumerator.Name Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the current user or group name. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Name As String
C# | public string Name { get; }
C++ public:
property String^ Name {
String^ get();
}
JScript | public function get Name() : String

Property Value

System.String

This property is read-only.


ReceiveEventArgs Class (Microsoft.DirectX.DirectPlay)

ReceiveEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class ReceiveEventArgs
Inherits EventArgs
C# | public sealed class ReceiveEventArgs : EventArgs
C++ | public ref class ReceiveEventArgs sealed : EventArgs
JScript | public final class ReceiveEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ReceiveEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ReceiveEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ReceiveEventArgs.ReceiveEventArgs(ReceiveMessage) Constructor (Microsoft.DirectX.DirectPlay)

ReceiveEventArgs.ReceiveEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As ReceiveMessage _
)
C# public ReceiveEventArgs(
ReceiveMessage dpMessage
);
C++ public:
ReceiveEventArgs(
ReceiveMessage dpMessage
);
JScript public function ReceiveEventArgs(
dpMessage : ReceiveMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.ReceiveMessage


ReceiveEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

ReceiveEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As ReceiveMessage
C# | public ReceiveMessage Message;
C++ | public: ReceiveMessage Message;
JScript | public var Message : ReceiveMessage

Field Value

Microsoft.DirectX.DirectPlay.ReceiveMessage

This field is read/write.


SendCompleteEventArgs Class (Microsoft.DirectX.DirectPlay)

SendCompleteEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidSendCompleteDplay message when an asynchronous send message request has completed.The structure contains information for the DpnMsgidSendCompleteDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class SendCompleteEventArgs
Inherits EventArgs
C# | public sealed class SendCompleteEventArgs : EventArgs
C++ | public ref class SendCompleteEventArgs sealed : EventArgs
JScript | public final class SendCompleteEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SendCompleteEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SendCompleteEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SendCompleteEventArgs.SendCompleteEventArgs(SendCompleteMessage) Constructor (Microsoft.DirectX.DirectPlay)

SendCompleteEventArgs.SendCompleteEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As SendCompleteMessage _
)
C# public SendCompleteEventArgs(
SendCompleteMessage dpMessage
);
C++ public:
SendCompleteEventArgs(
SendCompleteMessage dpMessage
);
JScript public function SendCompleteEventArgs(
dpMessage : SendCompleteMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.SendCompleteMessage


SendCompleteEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

SendCompleteEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As SendCompleteMessage
C# | public SendCompleteMessage Message;
C++ | public: SendCompleteMessage Message;
JScript | public var Message : SendCompleteMessage

Field Value

Microsoft.DirectX.DirectPlay.SendCompleteMessage

This field is read/write.


SendTooLargeException Class (Microsoft.DirectX.DirectPlay)

SendTooLargeException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The send was too large. Deprecated.

Definition

Visual Basic Public Class SendTooLargeException
Inherits DirectPlayException
C# | public class SendTooLargeException : DirectPlayException
C++ | public ref class SendTooLargeException : DirectPlayException
JScript | public class SendTooLargeException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SendTooLargeException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
SendTooLargeException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SendTooLargeException.SendTooLargeException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SendTooLargeException();
protected SendTooLargeException(SerializationInfo, StreamingContext);
public SendTooLargeException(string);
public SendTooLargeException(string, Exception);


SendTooLargeException.SendTooLargeException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

SendTooLargeException.SendTooLargeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SendTooLargeException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SendTooLargeException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SendTooLargeException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SendTooLargeException.SendTooLargeException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

SendTooLargeException.SendTooLargeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SendTooLargeException(
string message,
Exception inner
);
C++ public:
SendTooLargeException(
String^ message,
Exception^ inner
);
JScript public function SendTooLargeException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SendTooLargeException.SendTooLargeException(String) Constructor (Microsoft.DirectX.DirectPlay)

SendTooLargeException.SendTooLargeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SendTooLargeException(
string message
);
C++ public:
SendTooLargeException(
String^ message
);
JScript public function SendTooLargeException(
message : String
);

Parameters

message System.String


SendTooLargeException.SendTooLargeException() Constructor (Microsoft.DirectX.DirectPlay)

SendTooLargeException.SendTooLargeException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SendTooLargeException();
C++ public:
SendTooLargeException();
JScript | public function SendTooLargeException();


Server Class (Microsoft.DirectX.DirectPlay)

Server Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the Server object to create and manage the server for a Microsoft® DirectPlay® client/server transport session. Deprecated.

Definition

Visual Basic Public Class Server
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Server : MarshalByRefObject, IDisposable
C++ | public ref class Server : MarshalByRefObject, IDisposable
JScript | public class Server extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
ApplicationDescriptionChanged
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.
AsyncOperationComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an async operation has completed. Deprecated.
ClientInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the client information set for the specified client. Deprecated.
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
FindHostQuery
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an when a peer or client is enumerating the available hosts. Deprecated.
GroupCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is created. Deprecated.
GroupDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is destroyed. Deprecated.
GroupInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.
IndicateConnect
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is trying to connect to your session. Deprecated.
IndicatedConnectAborted
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an indicated played has aborted his connection. Deprecated.
PlayerAddedToGroup
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is added to a group. Deprecated.
PlayerCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.
PlayerDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.
PlayerRemovedFromGroup
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been removed from a group. Deprecated.
Receive
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the server object receives data. Deprecated.
SendComplete
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.
ServerInformation
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Methods

Method Description
AddPlayerToGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.
CancelAsyncOperation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Many methods of the Play8serverDplay object run asynchronously by default. Depending on the situation, you might want to cancel requests before they are processed. All the methods of this object that can be run asynchronously return an hAsyncHandle parameter.Specific requests are canceled by passing the hAsyncHandle of the request in this method's hAsyncHandle parameter. You can cancel all pending asynchronous operations by calling this method, specifying NULL in the hAsyncHandle parameter, and specifying DPNCANCEL_ALL_OPERATIONS in the dwFlags parameter. If a specific handle is provided to this method, no flags should be set. Deprecated.
CreateGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.
DestroyClient
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a client from the session. Deprecated.
DestroyGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetClientAddress
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address for the specified player in the session. Deprecated.
GetClientInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the client information set for the specified client. Deprecated.
GetConnectionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local server and the specified remote client. Deprecated.
GetGroupContext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the group context value for a group. Deprecated.
GetGroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetLocalHostAddresses
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
GetPlayerContext
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the player context value for a client. Deprecated.
GetSendQueueInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Microsoft® DirectPlay® does not send messages faster than the receiving computer can process them. As a result, if the sending computer is sending faster than the receiver can receive, messages accumulate in the sender's queue. If the application registers that the send queue is growing too large, it should slow the rate that messages are sent. Deprecated.
GetServiceProviders
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.
GetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the structure for the specified service provider. Deprecated.
Host
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_ApplicationDescriptionChanged
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_AsyncOperationComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ClientInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_FindHostQuery
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_GroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_IndicateConnect
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_IndicatedConnectAborted
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerAddedToGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_PlayerRemovedFromGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_Receive
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_SendComplete
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ServerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RegisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
RemovePlayerFromGroup
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.
SendTo
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.
Server
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetGroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.
SetServerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.
SetSPCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the structure for the specified service provider. Deprecated.
UnregisterLobby
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Properties

Property Description
ApplicationDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the full application description for the connected application. Deprecated.
Caps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Server object. Deprecated.
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.
GroupMembers
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.
Groups
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.
Players
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the application. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Server

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Server.AddPlayerToGroup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Overload List

public void AddPlayerToGroup(int, int, out int, SyncFlags);
public void AddPlayerToGroup(int, int, out int, SyncFlags, object);
public void AddPlayerToGroup(int, int, SyncFlags);
public void AddPlayerToGroup(int, int, SyncFlags, object);


Server.AddPlayerToGroup(Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.AddPlayerToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Definition

Visual Basic Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags,
object asyncContext
);
C++ public:
void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags,
Object^ asyncContext
);
JScript public function AddPlayerToGroup(
groupID : int,
clientID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
clientID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.AddPlayerToGroup(Int32,Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.AddPlayerToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Definition

Visual Basic Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void AddPlayerToGroup(
int groupID,
int clientID,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function AddPlayerToGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
clientID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.AddPlayerToGroup(Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.AddPlayerToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Definition

Visual Basic Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags
);
C++ public:
void AddPlayerToGroup(
int groupID,
int clientID,
SyncFlags flags
);
JScript public function AddPlayerToGroup(
groupID : int,
clientID : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
clientID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.AddPlayerToGroup(Int32,Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.AddPlayerToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Adds a client to a group. After the client is successfully added to the group, all messages sent to the group are sent to the client. Deprecated.

Definition

Visual Basic Public Sub AddPlayerToGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void AddPlayerToGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void AddPlayerToGroup(
int groupID,
int clientID,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function AddPlayerToGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
clientID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.CancelAsyncOperation Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Many methods of the Play8serverDplay object run asynchronously by default. Depending on the situation, you might want to cancel requests before they are processed. All the methods of this object that can be run asynchronously return an hAsyncHandle parameter.Specific requests are canceled by passing the hAsyncHandle of the request in this method's hAsyncHandle parameter. You can cancel all pending asynchronous operations by calling this method, specifying NULL in the hAsyncHandle parameter, and specifying DPNCANCEL_ALL_OPERATIONS in the dwFlags parameter. If a specific handle is provided to this method, no flags should be set. Deprecated.

Overload List

public void CancelAsyncOperation(CancelFlags);
public void CancelAsyncOperation(int);


Server.CancelAsyncOperation(Int32) Method (Microsoft.DirectX.DirectPlay)

Server.CancelAsyncOperation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Many methods of the Play8serverDplay object run asynchronously by default. Depending on the situation, you might want to cancel requests before they are processed. All the methods of this object that can be run asynchronously return an hAsyncHandle parameter.Specific requests are canceled by passing the hAsyncHandle of the request in this method's hAsyncHandle parameter. You can cancel all pending asynchronous operations by calling this method, specifying NULL in the hAsyncHandle parameter, and specifying DPNCANCEL_ALL_OPERATIONS in the dwFlags parameter. If a specific handle is provided to this method, no flags should be set. Deprecated.

Definition

Visual Basic Public Sub CancelAsyncOperation( _
ByVal asyncHandle As Integer _
)
C# public void CancelAsyncOperation(
int asyncHandle
);
C++ public:
void CancelAsyncOperation(
int asyncHandle
);
JScript public function CancelAsyncOperation(
asyncHandle : int
);

Parameters

asyncHandle System.Int32


Server.CancelAsyncOperation(CancelFlags) Method (Microsoft.DirectX.DirectPlay)

Server.CancelAsyncOperation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancels asynchronous requests. Many methods of the Play8serverDplay object run asynchronously by default. Depending on the situation, you might want to cancel requests before they are processed. All the methods of this object that can be run asynchronously return an hAsyncHandle parameter.Specific requests are canceled by passing the hAsyncHandle of the request in this method's hAsyncHandle parameter. You can cancel all pending asynchronous operations by calling this method, specifying NULL in the hAsyncHandle parameter, and specifying DPNCANCEL_ALL_OPERATIONS in the dwFlags parameter. If a specific handle is provided to this method, no flags should be set. Deprecated.

Definition

Visual Basic Public Sub CancelAsyncOperation( _
ByVal flags As CancelFlags _
)
C# public void CancelAsyncOperation(
CancelFlags flags
);
C++ public:
void CancelAsyncOperation(
CancelFlags flags
);
JScript public function CancelAsyncOperation(
flags : CancelFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.CancelFlags


Server.CreateGroup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Overload List

public void CreateGroup(GroupInformation, out int, SyncFlags);
public void CreateGroup(GroupInformation, out int, SyncFlags, object, object);
public void CreateGroup(GroupInformation, SyncFlags);
public void CreateGroup(GroupInformation, SyncFlags, object, object);


Server.CreateGroup(GroupInformation,SyncFlags,Object,Object) Method (Microsoft.DirectX.DirectPlay)

Server.CreateGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Definition

Visual Basic Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags, _
ByVal groupContext As Object, _
ByVal asyncContext As Object _
)
C# public void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags,
object groupContext,
object asyncContext
);
C++ public:
void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags,
Object^ groupContext,
Object^ asyncContext
);
JScript public function CreateGroup(
groupInformation : GroupInformation,
flags : SyncFlags,
groupContext : Object,
asyncContext : Object
);

Parameters

groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags
groupContext System.Object
asyncContext System.Object


Server.CreateGroup(GroupInformation,Int32,SyncFlags,Object,Object) Method (Microsoft.DirectX.DirectPlay)

Server.CreateGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Definition

Visual Basic Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal groupContext As Object, _
ByVal asyncContext As Object _
)
C# public void CreateGroup(
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags,
object groupContext,
object asyncContext
);
C++ public:
void CreateGroup(
GroupInformation groupInformation,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ groupContext,
Object^ asyncContext
);
JScript public function CreateGroup(
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags,
groupContext : Object,
asyncContext : Object
);

Parameters

groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
groupContext System.Object
asyncContext System.Object


Server.CreateGroup(GroupInformation,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.CreateGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Definition

Visual Basic Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags _
)
C# public void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags
);
C++ public:
void CreateGroup(
GroupInformation groupInformation,
SyncFlags flags
);
JScript public function CreateGroup(
groupInformation : GroupInformation,
flags : SyncFlags
);

Parameters

groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.CreateGroup(GroupInformation,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.CreateGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a group in the current session. When this method is called, the server's message handler receives a DPN_MSGID_CREATE_GROUP message. Deprecated.

Definition

Visual Basic Public Sub CreateGroup( _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void CreateGroup(
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void CreateGroup(
GroupInformation groupInformation,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function CreateGroup(
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.DestroyClient(Int32,NetworkPacket) Method (Microsoft.DirectX.DirectPlay)

Server.DestroyClient Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a client from the session. Deprecated.

Definition

Visual Basic Public Sub DestroyClient( _
ByVal playerID As Integer, _
ByVal destroyData As NetworkPacket _
)
C# public void DestroyClient(
int playerID,
NetworkPacket destroyData
);
C++ public:
void DestroyClient(
int playerID,
NetworkPacket^ destroyData
);
JScript public function DestroyClient(
playerID : int,
destroyData : NetworkPacket
);

Parameters

playerID System.Int32
destroyData Microsoft.DirectX.DirectPlay.NetworkPacket


Server.DestroyGroup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Overload List

public void DestroyGroup(int, out int, SyncFlags);
public void DestroyGroup(int, out int, SyncFlags, object);
public void DestroyGroup(int, SyncFlags);
public void DestroyGroup(int, SyncFlags, object);


Server.DestroyGroup(Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.DestroyGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Definition

Visual Basic Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void DestroyGroup(
int groupID,
SyncFlags flags,
object asyncContext
);
C++ public:
void DestroyGroup(
int groupID,
SyncFlags flags,
Object^ asyncContext
);
JScript public function DestroyGroup(
groupID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.DestroyGroup(Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.DestroyGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Definition

Visual Basic Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void DestroyGroup(
int groupID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void DestroyGroup(
int groupID,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function DestroyGroup(
groupID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.DestroyGroup(Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.DestroyGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Definition

Visual Basic Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByVal flags As SyncFlags _
)
C# public void DestroyGroup(
int groupID,
SyncFlags flags
);
C++ public:
void DestroyGroup(
int groupID,
SyncFlags flags
);
JScript public function DestroyGroup(
groupID : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.DestroyGroup(Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.DestroyGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deletes a group created by the Play8serverCreategroupDplay method. Deprecated.

Definition

Visual Basic Public Sub DestroyGroup( _
ByVal groupID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void DestroyGroup(
int groupID,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void DestroyGroup(
int groupID,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function DestroyGroup(
groupID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.Dispose Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Overload List

public override void Dispose();
public void Dispose(bool);

See Also

  • Server.Disposed
  • Server.Disposing


Server.Dispose(Boolean) Method (Microsoft.DirectX.DirectPlay)

Server.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic Public Sub Dispose( _
ByVal closeImmediate As Boolean _
)
C# public void Dispose(
bool closeImmediate
);
C++ public:
void Dispose(
bool closeImmediate
);
JScript public function Dispose(
closeImmediate : boolean
);

Parameters

closeImmediate System.Boolean

See Also

  • Server.Disposed
  • Server.Disposing


Server.Dispose() Method (Microsoft.DirectX.DirectPlay)

Server.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Server();
JScript | public override function Dispose();

See Also

  • Server.Disposed
  • Server.Disposing


Server.Equals(Object) Method (Microsoft.DirectX.DirectPlay)

Server.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Server.Finalize() Method (Microsoft.DirectX.DirectPlay)

Server.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Server();
C++ | !Server();
JScript | protected override function Finalize();


Server.GetClientAddress(Int32) Method (Microsoft.DirectX.DirectPlay)

Server.GetClientAddress Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the address for the specified player in the session. Deprecated.

Definition

Visual Basic Public Function GetClientAddress( _
ByVal playerID As Integer _
) As Address
C# public Address GetClientAddress(
int playerID
);
C++ public:
Address^ GetClientAddress(
int playerID
);
JScript public function GetClientAddress(
playerID : int
) : Address;

Parameters

playerID System.Int32

Return Value

Microsoft.DirectX.DirectPlay.Address


Server.GetClientInformation(Int32) Method (Microsoft.DirectX.DirectPlay)

Server.GetClientInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the client information set for the specified client. Deprecated.

Definition

Visual Basic Public Function GetClientInformation( _
ByVal playerID As Integer _
) As PlayerInformation
C# public PlayerInformation GetClientInformation(
int playerID
);
C++ public:
PlayerInformation GetClientInformation(
int playerID
);
JScript public function GetClientInformation(
playerID : int
) : PlayerInformation;

Parameters

playerID System.Int32

Return Value

Microsoft.DirectX.DirectPlay.PlayerInformation


Server.GetConnectionInformation(Int32) Method (Microsoft.DirectX.DirectPlay)

Server.GetConnectionInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves statistical information about the connection between the local server and the specified remote client. Deprecated.

Definition

Visual Basic Public Function GetConnectionInformation( _
ByVal playerID As Integer _
) As ConnectionInformation
C# public ConnectionInformation GetConnectionInformation(
int playerID
);
C++ public:
ConnectionInformation GetConnectionInformation(
int playerID
);
JScript public function GetConnectionInformation(
playerID : int
) : ConnectionInformation;

Parameters

playerID System.Int32

Return Value

Microsoft.DirectX.DirectPlay.ConnectionInformation


Server.GetGroupContext(Int32) Method (Microsoft.DirectX.DirectPlay)

Server.GetGroupContext Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the group context value for a group. Deprecated.

Definition

Visual Basic Public Function GetGroupContext( _
ByVal groupID As Integer _
) As Object
C# public object GetGroupContext(
int groupID
);
C++ public:
Object^ GetGroupContext(
int groupID
);
JScript public function GetGroupContext(
groupID : int
) : Object;

Parameters

groupID System.Int32

Return Value

System.Object


Server.GetGroupInformation(Int32) Method (Microsoft.DirectX.DirectPlay)

Server.GetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Function GetGroupInformation( _
ByVal groupID As Integer _
) As GroupInformation
C# public GroupInformation GetGroupInformation(
int groupID
);
C++ public:
GroupInformation GetGroupInformation(
int groupID
);
JScript public function GetGroupInformation(
groupID : int
) : GroupInformation;

Parameters

groupID System.Int32

Return Value

Microsoft.DirectX.DirectPlay.GroupInformation


Server.GetHashCode() Method (Microsoft.DirectX.DirectPlay)

Server.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Server.GetLocalHostAddresses(LocalAddressFlags) Method (Microsoft.DirectX.DirectPlay)

Server.GetLocalHostAddresses Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Function GetLocalHostAddresses( _
ByVal flags As LocalAddressFlags _
) As Address()
C# public Address[] GetLocalHostAddresses(
LocalAddressFlags flags
);
C++ public:
array<Address^>^ GetLocalHostAddresses(
LocalAddressFlags flags
);
JScript public function GetLocalHostAddresses(
flags : LocalAddressFlags
) : Address[];

Parameters

flags Microsoft.DirectX.DirectPlay.LocalAddressFlags

Return Value

Microsoft.DirectX.DirectPlay.Address[]


Server.GetPlayerContext(Int32) Method (Microsoft.DirectX.DirectPlay)

Server.GetPlayerContext Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the player context value for a client. Deprecated.

Definition

Visual Basic Public Function GetPlayerContext( _
ByVal playerID As Integer _
) As Object
C# public object GetPlayerContext(
int playerID
);
C++ public:
Object^ GetPlayerContext(
int playerID
);
JScript public function GetPlayerContext(
playerID : int
) : Object;

Parameters

playerID System.Int32

Return Value

System.Object


Server.GetSendQueueInformation(Int32,Int32,Int32,GetSendQueueInformationFlags) Method (Microsoft.DirectX.DirectPlay)

Server.GetSendQueueInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used by the application to monitor the size of the send queue. Microsoft® DirectPlay® does not send messages faster than the receiving computer can process them. As a result, if the sending computer is sending faster than the receiver can receive, messages accumulate in the sender's queue. If the application registers that the send queue is growing too large, it should slow the rate that messages are sent. Deprecated.

Definition

Visual Basic Public Sub GetSendQueueInformation( _
ByVal dpnidPlayer As Integer, _
ByRef numberMessages As Integer, _
ByRef numberBytes As Integer, _
ByVal flags As GetSendQueueInformationFlags _
)
C# public void GetSendQueueInformation(
int dpnidPlayer,
out int numberMessages,
out int numberBytes,
GetSendQueueInformationFlags flags
);
C++ public:
void GetSendQueueInformation(
int dpnidPlayer,
[Out] int% numberMessages,
[Out] int% numberBytes,
GetSendQueueInformationFlags flags
);
JScript public function GetSendQueueInformation(
dpnidPlayer : int,
numberMessages : int,
numberBytes : int,
flags : GetSendQueueInformationFlags
);

Parameters

dpnidPlayer System.Int32
numberMessages System.Int32
numberBytes System.Int32
flags Microsoft.DirectX.DirectPlay.GetSendQueueInformationFlags


Server.GetServiceProviders Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Overload List

public ServiceProviderInformation[] GetServiceProviders(bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, bool);
public ServiceProviderInformation[] GetServiceProviders(Guid, Guid, bool);


Server.GetServiceProviders(Boolean) Method (Microsoft.DirectX.DirectPlay)

Server.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
bool getAll
);
JScript public function GetServiceProviders(
getAll : boolean
) : ServiceProviderInformation[];

Parameters

getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Server.GetServiceProviders(Guid,Boolean) Method (Microsoft.DirectX.DirectPlay)

Server.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
Guid guidServiceProvider,
bool getAll
);
JScript public function GetServiceProviders(
guidServiceProvider : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider System.Guid
getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Server.GetServiceProviders(Guid,Guid,Boolean) Method (Microsoft.DirectX.DirectPlay)

Server.GetServiceProviders Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates the registered service providers available to the application. Deprecated.

Definition

Visual Basic Public Function GetServiceProviders( _
ByVal guidServiceProvider As Guid, _
ByVal guidApplication As Guid, _
ByVal getAll As Boolean _
) As ServiceProviderInformation()
C# public ServiceProviderInformation[] GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
C++ public:
array<ServiceProviderInformation>^ GetServiceProviders(
Guid guidServiceProvider,
Guid guidApplication,
bool getAll
);
JScript public function GetServiceProviders(
guidServiceProvider : Guid,
guidApplication : Guid,
getAll : boolean
) : ServiceProviderInformation[];

Parameters

guidServiceProvider System.Guid
guidApplication System.Guid
getAll System.Boolean

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformation[]


Server.GetSPCaps(Guid) Method (Microsoft.DirectX.DirectPlay)

Server.GetSPCaps Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the structure for the specified service provider. Deprecated.

Definition

Visual Basic Public Function GetSPCaps( _
ByVal guidServiceProvider As Guid _
) As ServiceProviderCaps
C# public ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
C++ public:
ServiceProviderCaps GetSPCaps(
Guid guidServiceProvider
);
JScript public function GetSPCaps(
guidServiceProvider : Guid
) : ServiceProviderCaps;

Parameters

guidServiceProvider System.Guid

Return Value

Microsoft.DirectX.DirectPlay.ServiceProviderCaps


Server.Host Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Overload List

public void Host(ApplicationDescription, Address);
public void Host(ApplicationDescription, Address, HostFlags);
public void Host(ApplicationDescription, Address, object);
public void Host(ApplicationDescription, Address, object, HostFlags);
public void Host(ApplicationDescription, Address[]);
public void Host(ApplicationDescription, Address[], HostFlags);
public void Host(ApplicationDescription, Address[], object);
public void Host(ApplicationDescription, Address[], object, HostFlags);


Server.Host(ApplicationDescription,Address[],Object,HostFlags) Method (Microsoft.DirectX.DirectPlay)

Server.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal playerContext As Object, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
object playerContext,
HostFlags flags
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
array<Address^>^ deviceAddress,
Object^ playerContext,
HostFlags flags
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
playerContext : Object,
flags : HostFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address[]
playerContext System.Object
flags Microsoft.DirectX.DirectPlay.HostFlags


Server.Host(ApplicationDescription,Address,Object,HostFlags) Method (Microsoft.DirectX.DirectPlay)

Server.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal playerContext As Object, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
object playerContext,
HostFlags flags
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
Address^ deviceAddress,
Object^ playerContext,
HostFlags flags
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
playerContext : Object,
flags : HostFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address
playerContext System.Object
flags Microsoft.DirectX.DirectPlay.HostFlags


Server.Host(ApplicationDescription,Address[],HostFlags) Method (Microsoft.DirectX.DirectPlay)

Server.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
HostFlags flags
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
array<Address^>^ deviceAddress,
HostFlags flags
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
flags : HostFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address[]
flags Microsoft.DirectX.DirectPlay.HostFlags


Server.Host(ApplicationDescription,Address,HostFlags) Method (Microsoft.DirectX.DirectPlay)

Server.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal flags As HostFlags _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
HostFlags flags
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
Address^ deviceAddress,
HostFlags flags
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
flags : HostFlags
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address
flags Microsoft.DirectX.DirectPlay.HostFlags


Server.Host(ApplicationDescription,Address[],Object) Method (Microsoft.DirectX.DirectPlay)

Server.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address, _
ByVal playerContext As Object _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress,
object playerContext
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
array<Address^>^ deviceAddress,
Object^ playerContext
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[],
playerContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address[]
playerContext System.Object


Server.Host(ApplicationDescription,Address,Object) Method (Microsoft.DirectX.DirectPlay)

Server.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address, _
ByVal playerContext As Object _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress,
object playerContext
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
Address^ deviceAddress,
Object^ playerContext
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address,
playerContext : Object
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address
playerContext System.Object


Server.Host(ApplicationDescription,Address[]) Method (Microsoft.DirectX.DirectPlay)

Server.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress() As Address _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address[] deviceAddress
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
array<Address^>^ deviceAddress
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address[]
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address[]


Server.Host(ApplicationDescription,Address) Method (Microsoft.DirectX.DirectPlay)

Server.Host Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Creates a new client/server session, hosted by the local computer. Deprecated.

Definition

Visual Basic Public Sub Host( _
ByVal applicationDescription As ApplicationDescription, _
ByVal deviceAddress As Address _
)
C# public void Host(
ApplicationDescription applicationDescription,
Address deviceAddress
);
C++ public:
void Host(
ApplicationDescription applicationDescription,
Address^ deviceAddress
);
JScript public function Host(
applicationDescription : ApplicationDescription,
deviceAddress : Address
);

Parameters

applicationDescription Microsoft.DirectX.DirectPlay.ApplicationDescription
deviceAddress Microsoft.DirectX.DirectPlay.Address


Server.op_Equality(Server,Server) Method (Microsoft.DirectX.DirectPlay)

Server.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Server, _
ByVal right As Server _
) As Boolean
C# public static bool op_Equality(
Server left,
Server right
);
C++ public:
static bool operator==(
Server^ left,
Server^ right
);
JScript public static function op_Equality(
left : Server,
right : Server
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Server
The Server structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Server
The Server structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Server.op_Inequality(Server,Server) Method (Microsoft.DirectX.DirectPlay)

Server.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Server, _
ByVal right As Server _
) As Boolean
C# public static bool op_Inequality(
Server left,
Server right
);
C++ public:
static bool operator!=(
Server^ left,
Server^ right
);
JScript public static function op_Inequality(
left : Server,
right : Server
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.Server
The Server structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.Server
The Server structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Server.raise_ApplicationDescriptionChanged(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_ApplicationDescriptionChanged Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ApplicationDescriptionChanged( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_ApplicationDescriptionChanged(
object i1,
EventArgs i2
);
C++ protected:
void raise_ApplicationDescriptionChanged(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_ApplicationDescriptionChanged(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Server.raise_AsyncOperationComplete(Object,AsyncOperationCompleteEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_AsyncOperationComplete Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_AsyncOperationComplete( _
ByVal i1 As Object, _
ByVal i2 As AsyncOperationCompleteEventArgs _
)
C# protected void raise_AsyncOperationComplete(
object i1,
AsyncOperationCompleteEventArgs i2
);
C++ protected:
void raise_AsyncOperationComplete(
Object^ i1,
AsyncOperationCompleteEventArgs^ i2
);
JScript protected function raise_AsyncOperationComplete(
i1 : Object,
i2 : AsyncOperationCompleteEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs


Server.raise_ClientInformation(Object,ClientInformationEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_ClientInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ClientInformation( _
ByVal i1 As Object, _
ByVal i2 As ClientInformationEventArgs _
)
C# protected void raise_ClientInformation(
object i1,
ClientInformationEventArgs i2
);
C++ protected:
void raise_ClientInformation(
Object^ i1,
ClientInformationEventArgs^ i2
);
JScript protected function raise_ClientInformation(
i1 : Object,
i2 : ClientInformationEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ClientInformationEventArgs


Server.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


Server.raise_FindHostQuery(Object,FindHostQueryEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_FindHostQuery Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_FindHostQuery( _
ByVal i1 As Object, _
ByVal i2 As FindHostQueryEventArgs _
)
C# protected void raise_FindHostQuery(
object i1,
FindHostQueryEventArgs i2
);
C++ protected:
void raise_FindHostQuery(
Object^ i1,
FindHostQueryEventArgs^ i2
);
JScript protected function raise_FindHostQuery(
i1 : Object,
i2 : FindHostQueryEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.FindHostQueryEventArgs


Server.raise_GroupCreated(Object,GroupCreatedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_GroupCreated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_GroupCreated( _
ByVal i1 As Object, _
ByVal i2 As GroupCreatedEventArgs _
)
C# protected void raise_GroupCreated(
object i1,
GroupCreatedEventArgs i2
);
C++ protected:
void raise_GroupCreated(
Object^ i1,
GroupCreatedEventArgs^ i2
);
JScript protected function raise_GroupCreated(
i1 : Object,
i2 : GroupCreatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.GroupCreatedEventArgs


Server.raise_GroupDestroyed(Object,GroupDestroyedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_GroupDestroyed Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_GroupDestroyed( _
ByVal i1 As Object, _
ByVal i2 As GroupDestroyedEventArgs _
)
C# protected void raise_GroupDestroyed(
object i1,
GroupDestroyedEventArgs i2
);
C++ protected:
void raise_GroupDestroyed(
Object^ i1,
GroupDestroyedEventArgs^ i2
);
JScript protected function raise_GroupDestroyed(
i1 : Object,
i2 : GroupDestroyedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.GroupDestroyedEventArgs


Server.raise_GroupInformation(Object,GroupInformationEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_GroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_GroupInformation( _
ByVal i1 As Object, _
ByVal i2 As GroupInformationEventArgs _
)
C# protected void raise_GroupInformation(
object i1,
GroupInformationEventArgs i2
);
C++ protected:
void raise_GroupInformation(
Object^ i1,
GroupInformationEventArgs^ i2
);
JScript protected function raise_GroupInformation(
i1 : Object,
i2 : GroupInformationEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.GroupInformationEventArgs


Server.raise_IndicateConnect(Object,IndicateConnectEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_IndicateConnect Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_IndicateConnect( _
ByVal i1 As Object, _
ByVal i2 As IndicateConnectEventArgs _
)
C# protected void raise_IndicateConnect(
object i1,
IndicateConnectEventArgs i2
);
C++ protected:
void raise_IndicateConnect(
Object^ i1,
IndicateConnectEventArgs^ i2
);
JScript protected function raise_IndicateConnect(
i1 : Object,
i2 : IndicateConnectEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.IndicateConnectEventArgs


Server.raise_IndicatedConnectAborted(Object,IndicatedConnectAbortedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_IndicatedConnectAborted Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_IndicatedConnectAborted( _
ByVal i1 As Object, _
ByVal i2 As IndicatedConnectAbortedEventArgs _
)
C# protected void raise_IndicatedConnectAborted(
object i1,
IndicatedConnectAbortedEventArgs i2
);
C++ protected:
void raise_IndicatedConnectAborted(
Object^ i1,
IndicatedConnectAbortedEventArgs^ i2
);
JScript protected function raise_IndicatedConnectAborted(
i1 : Object,
i2 : IndicatedConnectAbortedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedEventArgs


Server.raise_PlayerAddedToGroup(Object,PlayerAddedToGroupEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_PlayerAddedToGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerAddedToGroup( _
ByVal i1 As Object, _
ByVal i2 As PlayerAddedToGroupEventArgs _
)
C# protected void raise_PlayerAddedToGroup(
object i1,
PlayerAddedToGroupEventArgs i2
);
C++ protected:
void raise_PlayerAddedToGroup(
Object^ i1,
PlayerAddedToGroupEventArgs^ i2
);
JScript protected function raise_PlayerAddedToGroup(
i1 : Object,
i2 : PlayerAddedToGroupEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PlayerAddedToGroupEventArgs


Server.raise_PlayerCreated(Object,PlayerCreatedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_PlayerCreated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerCreated( _
ByVal i1 As Object, _
ByVal i2 As PlayerCreatedEventArgs _
)
C# protected void raise_PlayerCreated(
object i1,
PlayerCreatedEventArgs i2
);
C++ protected:
void raise_PlayerCreated(
Object^ i1,
PlayerCreatedEventArgs^ i2
);
JScript protected function raise_PlayerCreated(
i1 : Object,
i2 : PlayerCreatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PlayerCreatedEventArgs


Server.raise_PlayerDestroyed(Object,PlayerDestroyedEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_PlayerDestroyed Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerDestroyed( _
ByVal i1 As Object, _
ByVal i2 As PlayerDestroyedEventArgs _
)
C# protected void raise_PlayerDestroyed(
object i1,
PlayerDestroyedEventArgs i2
);
C++ protected:
void raise_PlayerDestroyed(
Object^ i1,
PlayerDestroyedEventArgs^ i2
);
JScript protected function raise_PlayerDestroyed(
i1 : Object,
i2 : PlayerDestroyedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PlayerDestroyedEventArgs


Server.raise_PlayerRemovedFromGroup(Object,PlayerRemovedFromGroupEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_PlayerRemovedFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_PlayerRemovedFromGroup( _
ByVal i1 As Object, _
ByVal i2 As PlayerRemovedFromGroupEventArgs _
)
C# protected void raise_PlayerRemovedFromGroup(
object i1,
PlayerRemovedFromGroupEventArgs i2
);
C++ protected:
void raise_PlayerRemovedFromGroup(
Object^ i1,
PlayerRemovedFromGroupEventArgs^ i2
);
JScript protected function raise_PlayerRemovedFromGroup(
i1 : Object,
i2 : PlayerRemovedFromGroupEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.PlayerRemovedFromGroupEventArgs


Server.raise_Receive(Object,ReceiveEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_Receive Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Receive( _
ByVal i1 As Object, _
ByVal i2 As ReceiveEventArgs _
)
C# protected void raise_Receive(
object i1,
ReceiveEventArgs i2
);
C++ protected:
void raise_Receive(
Object^ i1,
ReceiveEventArgs^ i2
);
JScript protected function raise_Receive(
i1 : Object,
i2 : ReceiveEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ReceiveEventArgs


Server.raise_SendComplete(Object,SendCompleteEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_SendComplete Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_SendComplete( _
ByVal i1 As Object, _
ByVal i2 As SendCompleteEventArgs _
)
C# protected void raise_SendComplete(
object i1,
SendCompleteEventArgs i2
);
C++ protected:
void raise_SendComplete(
Object^ i1,
SendCompleteEventArgs^ i2
);
JScript protected function raise_SendComplete(
i1 : Object,
i2 : SendCompleteEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.SendCompleteEventArgs


Server.raise_ServerInformation(Object,ServerInformationEventArgs) Method (Microsoft.DirectX.DirectPlay)

Server.raise_ServerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ServerInformation( _
ByVal i1 As Object, _
ByVal i2 As ServerInformationEventArgs _
)
C# protected void raise_ServerInformation(
object i1,
ServerInformationEventArgs i2
);
C++ protected:
void raise_ServerInformation(
Object^ i1,
ServerInformationEventArgs^ i2
);
JScript protected function raise_ServerInformation(
i1 : Object,
i2 : ServerInformationEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ServerInformationEventArgs


Server.RegisterLobby(Int32,Application) Method (Microsoft.DirectX.DirectPlay)

Server.RegisterLobby Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Public Sub RegisterLobby( _
ByVal handle As Integer, _
ByVal lobbiedApplication As Application _
)
C# public void RegisterLobby(
int handle,
Application lobbiedApplication
);
C++ public:
void RegisterLobby(
int handle,
Application^ lobbiedApplication
);
JScript public function RegisterLobby(
handle : int,
lobbiedApplication : Application
);

Parameters

handle System.Int32
lobbiedApplication Microsoft.DirectX.DirectPlay.Lobby.Application


Server.RemovePlayerFromGroup Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Overload List

public void RemovePlayerFromGroup(int, int, out int, SyncFlags);
public void RemovePlayerFromGroup(int, int, out int, SyncFlags, object);
public void RemovePlayerFromGroup(int, int, SyncFlags);
public void RemovePlayerFromGroup(int, int, SyncFlags, object);


Server.RemovePlayerFromGroup(Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.RemovePlayerFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Definition

Visual Basic Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags,
object asyncContext
);
C++ public:
void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags,
Object^ asyncContext
);
JScript public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
clientID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.RemovePlayerFromGroup(Int32,Int32,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.RemovePlayerFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Definition

Visual Basic Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void RemovePlayerFromGroup(
int groupID,
int clientID,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
clientID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.RemovePlayerFromGroup(Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.RemovePlayerFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Definition

Visual Basic Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByVal flags As SyncFlags _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags
);
C++ public:
void RemovePlayerFromGroup(
int groupID,
int clientID,
SyncFlags flags
);
JScript public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
clientID System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.RemovePlayerFromGroup(Int32,Int32,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.RemovePlayerFromGroup Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Removes a client from a group. Deprecated.

Definition

Visual Basic Public Sub RemovePlayerFromGroup( _
ByVal groupID As Integer, _
ByVal clientID As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void RemovePlayerFromGroup(
int groupID,
int clientID,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void RemovePlayerFromGroup(
int groupID,
int clientID,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function RemovePlayerFromGroup(
groupID : int,
clientID : int,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
clientID System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.SendTo Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Overload List

public void SendTo(int, GCHandle, int, int, out int, SendFlags);
public void SendTo(int, GCHandle, int, int, out int, SendFlags, object);
public void SendTo(int, GCHandle, int, int, SendFlags);
public void SendTo(int, GCHandle, int, int, SendFlags, object);
public void SendTo(int, NetworkPacket, int, out int, SendFlags);
public void SendTo(int, NetworkPacket, int, out int, SendFlags, object);
public void SendTo(int, NetworkPacket, int, SendFlags);
public void SendTo(int, NetworkPacket, int, SendFlags, object);


Server.SendTo(Int32,GCHandle,Int32,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
C++ public:
void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags,
Object^ context
);
JScript public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

playerID System.Int32
gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Server.SendTo(Int32,GCHandle,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
object context
);
C++ public:
void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags,
Object^ context
);
JScript public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

playerID System.Int32
gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Server.SendTo(Int32,GCHandle,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Server.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
C++ public:
void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
SendFlags flags
);
JScript public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
flags : SendFlags
);

Parameters

playerID System.Int32
gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Server.SendTo(Int32,GCHandle,Int32,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Server.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal gcbuffer As GCHandle, _
ByVal bufferSize As Integer, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
out int asyncHandle,
SendFlags flags
);
C++ public:
void SendTo(
int playerID,
GCHandle gcbuffer,
int bufferSize,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags
);
JScript public function SendTo(
playerID : int,
gcbuffer : GCHandle,
bufferSize : int,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

playerID System.Int32
gcbuffer System.Runtime.InteropServices.GCHandle
bufferSize System.Int32
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Server.SendTo(Int32,NetworkPacket,Int32,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags,
object context
);
C++ public:
void SendTo(
int playerID,
NetworkPacket^ sendData,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags,
Object^ context
);
JScript public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags,
context : Object
);

Parameters

playerID System.Int32
sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Server.SendTo(Int32,NetworkPacket,Int32,SendFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags, _
ByVal context As Object _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
SendFlags flags,
object context
);
C++ public:
void SendTo(
int playerID,
NetworkPacket^ sendData,
int timeOut,
SendFlags flags,
Object^ context
);
JScript public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags,
context : Object
);

Parameters

playerID System.Int32
sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags
context System.Object


Server.SendTo(Int32,NetworkPacket,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Server.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
SendFlags flags
);
C++ public:
void SendTo(
int playerID,
NetworkPacket^ sendData,
int timeOut,
SendFlags flags
);
JScript public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
flags : SendFlags
);

Parameters

playerID System.Int32
sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Server.SendTo(Int32,NetworkPacket,Int32,Int32,SendFlags) Method (Microsoft.DirectX.DirectPlay)

Server.SendTo Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Transmits data to a client or group within the session. The message can be sent synchronously or asynchronously. Deprecated.

Definition

Visual Basic Public Sub SendTo( _
ByVal playerID As Integer, _
ByVal sendData As NetworkPacket, _
ByVal timeOut As Integer, _
ByRef asyncHandle As Integer, _
ByVal flags As SendFlags _
)
C# public void SendTo(
int playerID,
NetworkPacket sendData,
int timeOut,
out int asyncHandle,
SendFlags flags
);
C++ public:
void SendTo(
int playerID,
NetworkPacket^ sendData,
int timeOut,
[Out] int% asyncHandle,
SendFlags flags
);
JScript public function SendTo(
playerID : int,
sendData : NetworkPacket,
timeOut : int,
asyncHandle : int,
flags : SendFlags
);

Parameters

playerID System.Int32
sendData Microsoft.DirectX.DirectPlay.NetworkPacket
timeOut System.Int32
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SendFlags


Server.Server Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public Server();
public Server(InitializeFlags);


Server.Server(InitializeFlags) Constructor (Microsoft.DirectX.DirectPlay)

Server.Server Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public Server(
InitializeFlags flags
);
C++ public:
Server(
InitializeFlags flags
);
JScript public function Server(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags


Server.Server() Constructor (Microsoft.DirectX.DirectPlay)

Server.Server Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Server();
C++ public:
Server();
JScript | public function Server();


Server.SetGroupInformation Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Overload List

public void SetGroupInformation(int, GroupInformation, out int, SyncFlags);
public void SetGroupInformation(int, GroupInformation, out int, SyncFlags, object);
public void SetGroupInformation(int, GroupInformation, SyncFlags);
public void SetGroupInformation(int, GroupInformation, SyncFlags, object);


Server.SetGroupInformation(Int32,GroupInformation,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.SetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags
);
C++ public:
void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags
);
JScript public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
flags : SyncFlags
);

Parameters

groupID System.Int32
groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.SetGroupInformation(Int32,GroupInformation,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.SetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

groupID System.Int32
groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.SetGroupInformation(Int32,GroupInformation,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.SetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.SetGroupInformation(Int32,GroupInformation,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.SetGroupInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic Public Sub SetGroupInformation( _
ByVal groupID As Integer, _
ByVal groupInformation As GroupInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetGroupInformation(
int groupID,
GroupInformation groupInformation,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetGroupInformation(
groupID : int,
groupInformation : GroupInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

groupID System.Int32
groupInformation Microsoft.DirectX.DirectPlay.GroupInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.SetServerInformation Method ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Overload List

public void SetServerInformation(PlayerInformation, out int, SyncFlags);
public void SetServerInformation(PlayerInformation, out int, SyncFlags, object);
public void SetServerInformation(PlayerInformation, SyncFlags);
public void SetServerInformation(PlayerInformation, SyncFlags, object);


Server.SetServerInformation(PlayerInformation,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.SetServerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic Public Sub SetServerInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags _
)
C# public void SetServerInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
C++ public:
void SetServerInformation(
PlayerInformation playerInformation,
SyncFlags flags
);
JScript public function SetServerInformation(
playerInformation : PlayerInformation,
flags : SyncFlags
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.SetServerInformation(PlayerInformation,Int32,SyncFlags) Method (Microsoft.DirectX.DirectPlay)

Server.SetServerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic Public Sub SetServerInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags _
)
C# public void SetServerInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags
);
C++ public:
void SetServerInformation(
PlayerInformation playerInformation,
[Out] int% asyncHandle,
SyncFlags flags
);
JScript public function SetServerInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags


Server.SetServerInformation(PlayerInformation,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.SetServerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic Public Sub SetServerInformation( _
ByVal playerInformation As PlayerInformation, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetServerInformation(
PlayerInformation playerInformation,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetServerInformation(
PlayerInformation playerInformation,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetServerInformation(
playerInformation : PlayerInformation,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.SetServerInformation(PlayerInformation,Int32,SyncFlags,Object) Method (Microsoft.DirectX.DirectPlay)

Server.SetServerInformation Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic Public Sub SetServerInformation( _
ByVal playerInformation As PlayerInformation, _
ByRef asyncHandle As Integer, _
ByVal flags As SyncFlags, _
ByVal asyncContext As Object _
)
C# public void SetServerInformation(
PlayerInformation playerInformation,
out int asyncHandle,
SyncFlags flags,
object asyncContext
);
C++ public:
void SetServerInformation(
PlayerInformation playerInformation,
[Out] int% asyncHandle,
SyncFlags flags,
Object^ asyncContext
);
JScript public function SetServerInformation(
playerInformation : PlayerInformation,
asyncHandle : int,
flags : SyncFlags,
asyncContext : Object
);

Parameters

playerInformation Microsoft.DirectX.DirectPlay.PlayerInformation
asyncHandle System.Int32
flags Microsoft.DirectX.DirectPlay.SyncFlags
asyncContext System.Object


Server.SetSPCaps(Guid,ServiceProviderCaps) Method (Microsoft.DirectX.DirectPlay)

Server.SetSPCaps Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the structure for the specified service provider. Deprecated.

Definition

Visual Basic Public Sub SetSPCaps( _
ByVal guidServiceProvider As Guid, _
ByVal value As ServiceProviderCaps _
)
C# public void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
C++ public:
void SetSPCaps(
Guid guidServiceProvider,
ServiceProviderCaps value
);
JScript public function SetSPCaps(
guidServiceProvider : Guid,
value : ServiceProviderCaps
);

Parameters

guidServiceProvider System.Guid
value Microsoft.DirectX.DirectPlay.ServiceProviderCaps


Server.UnregisterLobby() Method (Microsoft.DirectX.DirectPlay)

Server.UnregisterLobby Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Sub UnregisterLobby()
C# | public void UnregisterLobby();
C++ public:
void UnregisterLobby();
JScript | public function UnregisterLobby();


Server.ApplicationDescription Property (Microsoft.DirectX.DirectPlay)

Server.ApplicationDescription Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the full application description for the connected application. Deprecated.

Definition

Visual Basic | Public Property ApplicationDescription As ApplicationDescription
C# | public ApplicationDescription ApplicationDescription { get; set; }
C++ public:
property ApplicationDescription ApplicationDescription {
ApplicationDescription get();
void set(ApplicationDescription value);
}
JScript public function get ApplicationDescription() : ApplicationDescription
public function set ApplicationDescription(ApplicationDescription);

Property Value

Microsoft.DirectX.DirectPlay.ApplicationDescription

This property is read/write.


Server.Caps Property (Microsoft.DirectX.DirectPlay)

Server.Caps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves or sets the capabilities of the current Server object. Deprecated.

Definition

Visual Basic | Public Property Caps As Caps
C# | public Caps Caps { get; set; }
C++ public:
property Caps Caps {
Caps get();
void set(Caps value);
}
JScript public function get Caps() : Caps
public function set Caps(Caps);

Property Value

Microsoft.DirectX.DirectPlay.Caps

This property is read/write.


Server.Disposed Property (Microsoft.DirectX.DirectPlay)

Server.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


Server.GroupMembers Property (Microsoft.DirectX.DirectPlay)

Server.GroupMembers Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupMembers As GroupMembersList
C# | public GroupMembersList GroupMembers { get; }
C++ public:
property GroupMembersList^ GroupMembers {
GroupMembersList^ get();
}
JScript | public function get GroupMembers() : GroupMembersList

Property Value

Microsoft.DirectX.DirectPlay.GroupMembersList

This property is read-only.


Server.Groups Property (Microsoft.DirectX.DirectPlay)

Server.Groups Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all players in a group. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Groups As PlayersGroupsEnumerator
C# | public PlayersGroupsEnumerator Groups { get; }
C++ public:
property PlayersGroupsEnumerator^ Groups {
PlayersGroupsEnumerator^ get();
}
JScript | public function get Groups() : PlayersGroupsEnumerator

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator

This property is read-only.


Server.Players Property (Microsoft.DirectX.DirectPlay)

Server.Players Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a list of all the player and/or group identifiers for the application. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Players As PlayersGroupsEnumerator
C# | public PlayersGroupsEnumerator Players { get; }
C++ public:
property PlayersGroupsEnumerator^ Players {
PlayersGroupsEnumerator^ get();
}
JScript | public function get Players() : PlayersGroupsEnumerator

Property Value

Microsoft.DirectX.DirectPlay.PlayersGroupsEnumerator

This property is read-only.


Server.ApplicationDescriptionChanged Event (Microsoft.DirectX.DirectPlay)

Server.ApplicationDescriptionChanged Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the application description has changed. Deprecated.

Definition

Visual Basic | Public Event ApplicationDescriptionChanged As ApplicationDescriptionEventHandler
C# | public event ApplicationDescriptionEventHandler ApplicationDescriptionChanged;
C++ public:
event ApplicationDescriptionEventHandler^ ApplicationDescriptionChanged;
JScript | In JScript, you can use events, but you cannot define your own.


Server.AsyncOperationComplete Event (Microsoft.DirectX.DirectPlay)

Server.AsyncOperationComplete Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an async operation has completed. Deprecated.

Definition

Visual Basic | Public Event AsyncOperationComplete As AsyncOperationCompleteEventHandler
C# | public event AsyncOperationCompleteEventHandler AsyncOperationComplete;
C++ public:
event AsyncOperationCompleteEventHandler^ AsyncOperationComplete;
JScript | In JScript, you can use events, but you cannot define your own.


Server.ClientInformation Event (Microsoft.DirectX.DirectPlay)

Server.ClientInformation Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the client information set for the specified client. Deprecated.

Definition

Visual Basic | Public Event ClientInformation As ClientInformationEventHandler
C# | public event ClientInformationEventHandler ClientInformation;
C++ public:
event ClientInformationEventHandler^ ClientInformation;
JScript | In JScript, you can use events, but you cannot define your own.


Server.Disposing Event (Microsoft.DirectX.DirectPlay)

Server.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a Server.Disposing event, use the following code.

server.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


Server.FindHostQuery Event (Microsoft.DirectX.DirectPlay)

Server.FindHostQuery Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an when a peer or client is enumerating the available hosts. Deprecated.

Definition

Visual Basic | Public Event FindHostQuery As FindHostQueryEventHandler
C# | public event FindHostQueryEventHandler FindHostQuery;
C++ public:
event FindHostQueryEventHandler^ FindHostQuery;
JScript | In JScript, you can use events, but you cannot define your own.


Server.GroupCreated Event (Microsoft.DirectX.DirectPlay)

Server.GroupCreated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is created. Deprecated.

Definition

Visual Basic | Public Event GroupCreated As GroupCreatedEventHandler
C# | public event GroupCreatedEventHandler GroupCreated;
C++ public:
event GroupCreatedEventHandler^ GroupCreated;
JScript | In JScript, you can use events, but you cannot define your own.


Server.GroupDestroyed Event (Microsoft.DirectX.DirectPlay)

Server.GroupDestroyed Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a group is destroyed. Deprecated.

Definition

Visual Basic | Public Event GroupDestroyed As GroupDestroyedEventHandler
C# | public event GroupDestroyedEventHandler GroupDestroyed;
C++ public:
event GroupDestroyedEventHandler^ GroupDestroyed;
JScript | In JScript, you can use events, but you cannot define your own.


Server.GroupInformation Event (Microsoft.DirectX.DirectPlay)

Server.GroupInformation Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a block of data associated with a group, including the group name.This method is typically called after a system message is received, indicating that the group data has been modified. Deprecated.

Definition

Visual Basic | Public Event GroupInformation As GroupInformationEventHandler
C# | public event GroupInformationEventHandler GroupInformation;
C++ public:
event GroupInformationEventHandler^ GroupInformation;
JScript | In JScript, you can use events, but you cannot define your own.


Server.IndicateConnect Event (Microsoft.DirectX.DirectPlay)

Server.IndicateConnect Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is trying to connect to your session. Deprecated.

Definition

Visual Basic | Public Event IndicateConnect As IndicateConnectEventHandler
C# | public event IndicateConnectEventHandler IndicateConnect;
C++ public:
event IndicateConnectEventHandler^ IndicateConnect;
JScript | In JScript, you can use events, but you cannot define your own.


Server.IndicatedConnectAborted Event (Microsoft.DirectX.DirectPlay)

Server.IndicatedConnectAborted Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when an indicated played has aborted his connection. Deprecated.

Definition

Visual Basic | Public Event IndicatedConnectAborted As IndicatedConnectAbortedEventHandler
C# | public event IndicatedConnectAbortedEventHandler IndicatedConnectAborted;
C++ public:
event IndicatedConnectAbortedEventHandler^ IndicatedConnectAborted;
JScript | In JScript, you can use events, but you cannot define your own.


Server.PlayerAddedToGroup Event (Microsoft.DirectX.DirectPlay)

Server.PlayerAddedToGroup Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player is added to a group. Deprecated.

Definition

Visual Basic | Public Event PlayerAddedToGroup As PlayerAddedToGroupEventHandler
C# | public event PlayerAddedToGroupEventHandler PlayerAddedToGroup;
C++ public:
event PlayerAddedToGroupEventHandler^ PlayerAddedToGroup;
JScript | In JScript, you can use events, but you cannot define your own.


Server.PlayerCreated Event (Microsoft.DirectX.DirectPlay)

Server.PlayerCreated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been created. Deprecated.

Definition

Visual Basic | Public Event PlayerCreated As PlayerCreatedEventHandler
C# | public event PlayerCreatedEventHandler PlayerCreated;
C++ public:
event PlayerCreatedEventHandler^ PlayerCreated;
JScript | In JScript, you can use events, but you cannot define your own.


Server.PlayerDestroyed Event (Microsoft.DirectX.DirectPlay)

Server.PlayerDestroyed Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been destroyed. Deprecated.

Definition

Visual Basic | Public Event PlayerDestroyed As PlayerDestroyedEventHandler
C# | public event PlayerDestroyedEventHandler PlayerDestroyed;
C++ public:
event PlayerDestroyedEventHandler^ PlayerDestroyed;
JScript | In JScript, you can use events, but you cannot define your own.


Server.PlayerRemovedFromGroup Event (Microsoft.DirectX.DirectPlay)

Server.PlayerRemovedFromGroup Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a player has been removed from a group. Deprecated.

Definition

Visual Basic | Public Event PlayerRemovedFromGroup As PlayerRemovedFromGroupEventHandler
C# | public event PlayerRemovedFromGroupEventHandler PlayerRemovedFromGroup;
C++ public:
event PlayerRemovedFromGroupEventHandler^ PlayerRemovedFromGroup;
JScript | In JScript, you can use events, but you cannot define your own.


Server.Receive Event (Microsoft.DirectX.DirectPlay)

Server.Receive Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the server object receives data. Deprecated.

Definition

Visual Basic | Public Event Receive As ReceiveEventHandler
C# | public event ReceiveEventHandler Receive;
C++ public:
event ReceiveEventHandler^ Receive;
JScript | In JScript, you can use events, but you cannot define your own.


Server.SendComplete Event (Microsoft.DirectX.DirectPlay)

Server.SendComplete Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the send operation has completed. Deprecated.

Definition

Visual Basic | Public Event SendComplete As SendCompleteEventHandler
C# | public event SendCompleteEventHandler SendComplete;
C++ public:
event SendCompleteEventHandler^ SendComplete;
JScript | In JScript, you can use events, but you cannot define your own.


Server.ServerInformation Event (Microsoft.DirectX.DirectPlay)

Server.ServerInformation Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the static settings of a server with an application. After clients successfully connect to the server, they can retrieve the information set by this method by calling the method. Deprecated.

Definition

Visual Basic | Public Event ServerInformation As ServerInformationEventHandler
C# | public event ServerInformationEventHandler ServerInformation;
C++ public:
event ServerInformationEventHandler^ ServerInformation;
JScript | In JScript, you can use events, but you cannot define your own.


ServerInformationEventArgs Class (Microsoft.DirectX.DirectPlay)

ServerInformationEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.

Definition

Visual Basic NotInheritable Public Class ServerInformationEventArgs
Inherits EventArgs
C# | public sealed class ServerInformationEventArgs : EventArgs
C++ | public ref class ServerInformationEventArgs sealed : EventArgs
JScript | public final class ServerInformationEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ServerInformationEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ServerInformationEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ServerInformationEventArgs.ServerInformationEventArgs(ServerInformationMessage) Constructor (Microsoft.DirectX.DirectPlay)

ServerInformationEventArgs.ServerInformationEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As ServerInformationMessage _
)
C# public ServerInformationEventArgs(
ServerInformationMessage dpMessage
);
C++ public:
ServerInformationEventArgs(
ServerInformationMessage dpMessage
);
JScript public function ServerInformationEventArgs(
dpMessage : ServerInformationMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.ServerInformationMessage


ServerInformationEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

ServerInformationEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As ServerInformationMessage
C# | public ServerInformationMessage Message;
C++ | public: ServerInformationMessage Message;
JScript | public var Message : ServerInformationMessage

Field Value

Microsoft.DirectX.DirectPlay.ServerInformationMessage

This field is read/write.


SessionFullException Class (Microsoft.DirectX.DirectPlay)

SessionFullException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The request to connect to the host or server failed because the maximum number of players allotted for the session has been reached. Deprecated.

Definition

Visual Basic Public Class SessionFullException
Inherits DirectPlayException
C# | public class SessionFullException : DirectPlayException
C++ | public ref class SessionFullException : DirectPlayException
JScript | public class SessionFullException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SessionFullException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
SessionFullException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionFullException.SessionFullException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public SessionFullException();
protected SessionFullException(SerializationInfo, StreamingContext);
public SessionFullException(string);
public SessionFullException(string, Exception);


SessionFullException.SessionFullException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

SessionFullException.SessionFullException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SessionFullException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SessionFullException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SessionFullException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


SessionFullException.SessionFullException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

SessionFullException.SessionFullException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SessionFullException(
string message,
Exception inner
);
C++ public:
SessionFullException(
String^ message,
Exception^ inner
);
JScript public function SessionFullException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


SessionFullException.SessionFullException(String) Constructor (Microsoft.DirectX.DirectPlay)

SessionFullException.SessionFullException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SessionFullException(
string message
);
C++ public:
SessionFullException(
String^ message
);
JScript public function SessionFullException(
message : String
);

Parameters

message System.String


SessionFullException.SessionFullException() Constructor (Microsoft.DirectX.DirectPlay)

SessionFullException.SessionFullException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SessionFullException();
C++ public:
SessionFullException();
JScript | public function SessionFullException();


SessionTerminatedEventArgs Class (Microsoft.DirectX.DirectPlay)

SessionTerminatedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the SessionTerminated event. Deprecated.

Definition

Visual Basic NotInheritable Public Class SessionTerminatedEventArgs
Inherits EventArgs
C# | public sealed class SessionTerminatedEventArgs : EventArgs
C++ | public ref class SessionTerminatedEventArgs sealed : EventArgs
JScript | public final class SessionTerminatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
SessionTerminatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
SessionTerminatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionTerminatedEventArgs.SessionTerminatedEventArgs(TerminateSessionMessage) Constructor (Microsoft.DirectX.DirectPlay)

SessionTerminatedEventArgs.SessionTerminatedEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As TerminateSessionMessage _
)
C# public SessionTerminatedEventArgs(
TerminateSessionMessage dpMessage
);
C++ public:
SessionTerminatedEventArgs(
TerminateSessionMessage dpMessage
);
JScript public function SessionTerminatedEventArgs(
dpMessage : TerminateSessionMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.TerminateSessionMessage


SessionTerminatedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

SessionTerminatedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As TerminateSessionMessage
C# | public TerminateSessionMessage Message;
C++ | public: TerminateSessionMessage Message;
JScript | public var Message : TerminateSessionMessage

Field Value

Microsoft.DirectX.DirectPlay.TerminateSessionMessage

This field is read/write.


TableFullException Class (Microsoft.DirectX.DirectPlay)

TableFullException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The table is full. Deprecated.

Definition

Visual Basic Public Class TableFullException
Inherits DirectPlayException
C# | public class TableFullException : DirectPlayException
C++ | public ref class TableFullException : DirectPlayException
JScript | public class TableFullException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TableFullException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
TableFullException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TableFullException.TableFullException Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public TableFullException();
protected TableFullException(SerializationInfo, StreamingContext);
public TableFullException(string);
public TableFullException(string, Exception);


TableFullException.TableFullException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

TableFullException.TableFullException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TableFullException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TableFullException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TableFullException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TableFullException.TableFullException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

TableFullException.TableFullException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TableFullException(
string message,
Exception inner
);
C++ public:
TableFullException(
String^ message,
Exception^ inner
);
JScript public function TableFullException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TableFullException.TableFullException(String) Constructor (Microsoft.DirectX.DirectPlay)

TableFullException.TableFullException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TableFullException(
string message
);
C++ public:
TableFullException(
String^ message
);
JScript public function TableFullException(
message : String
);

Parameters

message System.String


TableFullException.TableFullException() Constructor (Microsoft.DirectX.DirectPlay)

TableFullException.TableFullException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TableFullException();
C++ public:
TableFullException();
JScript | public function TableFullException();


ThreadCreatedEventArgs Class (Microsoft.DirectX.DirectPlay)

ThreadCreatedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ThreadCreated event. Deprecated.

Definition

Visual Basic NotInheritable Public Class ThreadCreatedEventArgs
Inherits EventArgs
C# | public sealed class ThreadCreatedEventArgs : EventArgs
C++ | public ref class ThreadCreatedEventArgs sealed : EventArgs
JScript | public final class ThreadCreatedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ThreadCreatedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ThreadCreatedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ThreadCreatedEventArgs.ThreadCreatedEventArgs(CreateThreadMessage) Constructor (Microsoft.DirectX.DirectPlay)

ThreadCreatedEventArgs.ThreadCreatedEventArgs Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As CreateThreadMessage _
)
C# public ThreadCreatedEventArgs(
CreateThreadMessage dpMessage
);
C++ public:
ThreadCreatedEventArgs(
CreateThreadMessage dpMessage
);
JScript public function ThreadCreatedEventArgs(
dpMessage : CreateThreadMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.CreateThreadMessage


ThreadCreatedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

ThreadCreatedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As CreateThreadMessage
C# | public CreateThreadMessage Message;
C++ | public: CreateThreadMessage Message;
JScript | public var Message : CreateThreadMessage

Field Value

Microsoft.DirectX.DirectPlay.CreateThreadMessage

This field is read/write.


ThreadDestroyedEventArgs Class (Microsoft.DirectX.DirectPlay)

ThreadDestroyedEventArgs Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Provides data for the ThreadDestroyed event. Deprecated.

Definition

Visual Basic NotInheritable Public Class ThreadDestroyedEventArgs
Inherits EventArgs
C# | public sealed class ThreadDestroyedEventArgs : EventArgs
C++ | public ref class ThreadDestroyedEventArgs sealed : EventArgs
JScript | public final class ThreadDestroyedEventArgs extends EventArgs

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field Description
Message
Warning: This field is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Methods

Method Description
ThreadDestroyedEventArgs
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Inheritance Hierarchy

Object Leave Site
EventArgs Leave Site
ThreadDestroyedEventArgs

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ThreadDestroyedEventArgs.ThreadDestroyedEventArgs(DestroyThreadMessage) Constructor (Microsoft.DirectX.DirectPlay)

ThreadDestroyedEventArgs.ThreadDestroyedEventArgs Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal dpMessage As DestroyThreadMessage _
)
C# public ThreadDestroyedEventArgs(
DestroyThreadMessage dpMessage
);
C++ public:
ThreadDestroyedEventArgs(
DestroyThreadMessage dpMessage
);
JScript public function ThreadDestroyedEventArgs(
dpMessage : DestroyThreadMessage
);

Parameters

dpMessage Microsoft.DirectX.DirectPlay.DestroyThreadMessage


ThreadDestroyedEventArgs.Message Field (Microsoft.DirectX.DirectPlay)

ThreadDestroyedEventArgs.Message Field

Warning: This field is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Message As DestroyThreadMessage
C# | public DestroyThreadMessage Message;
C++ | public: DestroyThreadMessage Message;
JScript | public var Message : DestroyThreadMessage

Field Value

Microsoft.DirectX.DirectPlay.DestroyThreadMessage

This field is read/write.


ThreadPool Class (Microsoft.DirectX.DirectPlay)

ThreadPool Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Applications use the methods of the ThreadPool object to manage threads in a Microsoft® DirectPlay® application Deprecated.

Definition

Visual Basic Public Class ThreadPool
Inherits MarshalByRefObject
Implements IDisposable
C# | public class ThreadPool : MarshalByRefObject, IDisposable
C++ | public ref class ThreadPool : MarshalByRefObject, IDisposable
JScript | public class ThreadPool extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event Description
Disposing
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.
ThreadCreated
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a thread has been created. Deprecated.
ThreadDestroyed
Warning: This event is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a thread has been destroyed. Deprecated.

Methods

Method Description
Dispose
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.
DoWork
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs work that is currently scheduled. Deprecated.
Equals
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.
Finalize
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.
GetHashCode
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.
GetThreadCount
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the number of threads for the specified processor or all processors. Deprecated.
static (Shared in Visual Basic) op_Equality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.
static (Shared in Visual Basic) op_Inequality
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.
raise_Disposing
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ThreadCreated
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
raise_ThreadDestroyed
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.
SetThreadCount
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes the number of threads for a specified processor or all processors. Deprecated.
ThreadPool
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property Description
Disposed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
ThreadPool

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ThreadPool.Dispose() Method (Microsoft.DirectX.DirectPlay)

ThreadPool.Dispose Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Immediately releases the unmanaged resources used by an object. Deprecated.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~ThreadPool();
JScript | public override function Dispose();

See Also

  • ThreadPool.Disposed
  • ThreadPool.Disposing


ThreadPool.DoWork(Int32) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.DoWork Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Performs work that is currently scheduled. Deprecated.

Definition

Visual Basic Public Sub DoWork( _
ByVal allowedTimeSlice As Integer _
)
C# public void DoWork(
int allowedTimeSlice
);
C++ public:
void DoWork(
int allowedTimeSlice
);
JScript public function DoWork(
allowedTimeSlice : int
);

Parameters

allowedTimeSlice System.Int32


ThreadPool.Equals(Object) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.Equals Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns a value that indicates whether the current instance is equal to a specified object. Deprecated.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


ThreadPool.Finalize() Method (Microsoft.DirectX.DirectPlay)

ThreadPool.Finalize Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector. Deprecated.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~ThreadPool();
C++ | !ThreadPool();
JScript | protected override function Finalize();


ThreadPool.GetHashCode() Method (Microsoft.DirectX.DirectPlay)

ThreadPool.GetHashCode Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Returns the hash code for the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


ThreadPool.GetThreadCount(Int32) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.GetThreadCount Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves the number of threads for the specified processor or all processors. Deprecated.

Definition

Visual Basic Public Function GetThreadCount( _
ByVal processorNumber As Integer _
) As Integer
C# public int GetThreadCount(
int processorNumber
);
C++ public:
int GetThreadCount(
int processorNumber
);
JScript public function GetThreadCount(
processorNumber : int
) : int;

Parameters

processorNumber System.Int32

Return Value

System.Int32


ThreadPool.op_Equality(ThreadPool,ThreadPool) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.op_Equality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are the same. Deprecated.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As ThreadPool, _
ByVal right As ThreadPool _
) As Boolean
C# public static bool op_Equality(
ThreadPool left,
ThreadPool right
);
C++ public:
static bool operator==(
ThreadPool^ left,
ThreadPool^ right
);
JScript public static function op_Equality(
left : ThreadPool,
right : ThreadPool
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.ThreadPool
The ThreadPool structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.ThreadPool
The ThreadPool structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


ThreadPool.op_Inequality(ThreadPool,ThreadPool) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.op_Inequality Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Compares the current instance of a class to another instance to determine whether they are different. Deprecated.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As ThreadPool, _
ByVal right As ThreadPool _
) As Boolean
C# public static bool op_Inequality(
ThreadPool left,
ThreadPool right
);
C++ public:
static bool operator!=(
ThreadPool^ left,
ThreadPool^ right
);
JScript public static function op_Inequality(
left : ThreadPool,
right : ThreadPool
) : boolean;

Parameters

left Microsoft.DirectX.DirectPlay.ThreadPool
The ThreadPool structure to the left of the equality operator.
right Microsoft.DirectX.DirectPlay.ThreadPool
The ThreadPool structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


ThreadPool.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.raise_Disposing Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
i2 System.EventArgs


ThreadPool.raise_ThreadCreated(Object,ThreadCreatedEventArgs) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.raise_ThreadCreated Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ThreadCreated( _
ByVal i1 As Object, _
ByVal i2 As ThreadCreatedEventArgs _
)
C# protected void raise_ThreadCreated(
object i1,
ThreadCreatedEventArgs i2
);
C++ protected:
void raise_ThreadCreated(
Object^ i1,
ThreadCreatedEventArgs^ i2
);
JScript protected function raise_ThreadCreated(
i1 : Object,
i2 : ThreadCreatedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ThreadCreatedEventArgs


ThreadPool.raise_ThreadDestroyed(Object,ThreadDestroyedEventArgs) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.raise_ThreadDestroyed Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic Protected Sub raise_ThreadDestroyed( _
ByVal i1 As Object, _
ByVal i2 As ThreadDestroyedEventArgs _
)
C# protected void raise_ThreadDestroyed(
object i1,
ThreadDestroyedEventArgs i2
);
C++ protected:
void raise_ThreadDestroyed(
Object^ i1,
ThreadDestroyedEventArgs^ i2
);
JScript protected function raise_ThreadDestroyed(
i1 : Object,
i2 : ThreadDestroyedEventArgs
);

Parameters

i1 System.Object
i2 Microsoft.DirectX.DirectPlay.ThreadDestroyedEventArgs


ThreadPool.SetThreadCount(Int32,Int32) Method (Microsoft.DirectX.DirectPlay)

ThreadPool.SetThreadCount Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Changes the number of threads for a specified processor or all processors. Deprecated.

Definition

Visual Basic Public Sub SetThreadCount( _
ByVal processorNumber As Integer, _
ByVal numThreads As Integer _
)
C# public void SetThreadCount(
int processorNumber,
int numThreads
);
C++ public:
void SetThreadCount(
int processorNumber,
int numThreads
);
JScript public function SetThreadCount(
processorNumber : int,
numThreads : int
);

Parameters

processorNumber System.Int32
numThreads System.Int32


ThreadPool.ThreadPool Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ThreadPool();
public ThreadPool(InitializeFlags);


ThreadPool.ThreadPool(InitializeFlags) Constructor (Microsoft.DirectX.DirectPlay)

ThreadPool.ThreadPool Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal flags As InitializeFlags _
)
C# public ThreadPool(
InitializeFlags flags
);
C++ public:
ThreadPool(
InitializeFlags flags
);
JScript public function ThreadPool(
flags : InitializeFlags
);

Parameters

flags Microsoft.DirectX.DirectPlay.InitializeFlags


ThreadPool.ThreadPool() Constructor (Microsoft.DirectX.DirectPlay)

ThreadPool.ThreadPool Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ThreadPool();
C++ public:
ThreadPool();
JScript | public function ThreadPool();


ThreadPool.Disposed Property (Microsoft.DirectX.DirectPlay)

ThreadPool.Disposed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Retrieves a value that is true if the object is disposed; otherwise the value is false. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


ThreadPool.Disposing Event (Microsoft.DirectX.DirectPlay)

ThreadPool.Disposing Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime. Deprecated.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a ThreadPool.Disposing event, use the following code.

threadPool.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of an object indicates whether that object has been disposed.


ThreadPool.ThreadCreated Event (Microsoft.DirectX.DirectPlay)

ThreadPool.ThreadCreated Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a thread has been created. Deprecated.

Definition

Visual Basic | Public Event ThreadCreated As ThreadCreatedEventHandler
C# | public event ThreadCreatedEventHandler ThreadCreated;
C++ public:
event ThreadCreatedEventHandler^ ThreadCreated;
JScript | In JScript, you can use events, but you cannot define your own.


ThreadPool.ThreadDestroyed Event (Microsoft.DirectX.DirectPlay)

ThreadPool.ThreadDestroyed Event

Warning: This event is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Occurs when a thread has been destroyed. Deprecated.

Definition

Visual Basic | Public Event ThreadDestroyed As ThreadDestroyedEventHandler
C# | public event ThreadDestroyedEventHandler ThreadDestroyed;
C++ public:
event ThreadDestroyedEventHandler^ ThreadDestroyed;
JScript | In JScript, you can use events, but you cannot define your own.


TimedOutException Class (Microsoft.DirectX.DirectPlay)

TimedOutException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The operation could not complete because it has timed out. Deprecated.

Definition

Visual Basic Public Class TimedOutException
Inherits DirectPlayException
C# | public class TimedOutException : DirectPlayException
C++ | public ref class TimedOutException : DirectPlayException
JScript | public class TimedOutException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
TimedOutException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
TimedOutException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TimedOutException.TimedOutException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

TimedOutException.TimedOutException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected TimedOutException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
TimedOutException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function TimedOutException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


TimedOutException.TimedOutException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

TimedOutException.TimedOutException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public TimedOutException(
string message,
Exception inner
);
C++ public:
TimedOutException(
String^ message,
Exception^ inner
);
JScript public function TimedOutException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


TimedOutException.TimedOutException(String) Constructor (Microsoft.DirectX.DirectPlay)

TimedOutException.TimedOutException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public TimedOutException(
string message
);
C++ public:
TimedOutException(
String^ message
);
JScript public function TimedOutException(
message : String
);

Parameters

message System.String


TimedOutException.TimedOutException() Constructor (Microsoft.DirectX.DirectPlay)

TimedOutException.TimedOutException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TimedOutException();
C++ public:
TimedOutException();
JScript | public function TimedOutException();


UserCancelException Class (Microsoft.DirectX.DirectPlay)

UserCancelException Class

Warning: This class is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The user canceled the operation. Deprecated.

Definition

Visual Basic Public Class UserCancelException
Inherits DirectPlayException
C# | public class UserCancelException : DirectPlayException
C++ | public ref class UserCancelException : DirectPlayException
JScript | public class UserCancelException extends DirectPlayException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated. Inherited from DirectPlayException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UserCancelException
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
DirectPlayException
UserCancelException

Class Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UserCancelException.UserCancelException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectPlay)

UserCancelException.UserCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UserCancelException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UserCancelException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UserCancelException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
context System.Runtime.Serialization.StreamingContext


UserCancelException.UserCancelException(String,Exception) Constructor (Microsoft.DirectX.DirectPlay)

UserCancelException.UserCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UserCancelException(
string message,
Exception inner
);
C++ public:
UserCancelException(
String^ message,
Exception^ inner
);
JScript public function UserCancelException(
message : String,
inner : Exception
);

Parameters

message System.String
inner System.Exception


UserCancelException.UserCancelException(String) Constructor (Microsoft.DirectX.DirectPlay)

UserCancelException.UserCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UserCancelException(
string message
);
C++ public:
UserCancelException(
String^ message
);
JScript public function UserCancelException(
message : String
);

Parameters

message System.String


UserCancelException.UserCancelException() Constructor (Microsoft.DirectX.DirectPlay)

UserCancelException.UserCancelException Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public UserCancelException();
C++ public:
UserCancelException();
JScript | public function UserCancelException();


CancelFlags Enumeration (Microsoft.DirectX.DirectPlay)

CancelFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Cancel all asynchronous requests. Deprecated.

Definition

Visual Basic | Public Enum CancelFlags
C# | public enum CancelFlags
C++ | public enum class CancelFlags
JScript | public enum CancelFlags

Members

Member | Value | Description
PlayerSendsPriorityLow | -2147221504
PlayerSendsPriorityNormal | -2147352576
PlayerSendsPriorityHigh | -2147418112
PlayerSends | -2147483648
Send | 4 | Cancel an asynchronous
FindHosts | 2
Connect | 1 | Cancel an asynchronous
AllOperations | 32768

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectFlags Enumeration (Microsoft.DirectX.DirectPlay)

ConnectFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.

Definition

Visual Basic | Public Enum ConnectFlags
C# | public enum ConnectFlags
C++ | public enum class ConnectFlags
JScript | public enum ConnectFlags

Members

Member | Value | Description
Sync | -2147483648 | Process the connection request synchronously. Setting this flag does not generate a
OkToQueryForAddressing | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DestroyGroupFlags Enumeration (Microsoft.DirectX.DirectPlay)

DestroyGroupFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic | Public Enum DestroyGroupFlags
C# | public enum DestroyGroupFlags
C++ | public enum class DestroyGroupFlags
JScript | public enum DestroyGroupFlags

Members

Member | Value | Description
SessionTerminated | 3
AutoDestinationructed | 2
Normal | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DestroyPlayerFlags Enumeration (Microsoft.DirectX.DirectPlay)

DestroyPlayerFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic | Public Enum DestroyPlayerFlags
C# | public enum DestroyPlayerFlags
C++ | public enum class DestroyPlayerFlags
JScript | public enum DestroyPlayerFlags

Members

Member | Value | Description
HostDestroyedPlayer | 4
SessionTerminated | 3
ConnectionLost | 2
Normal | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostsFlags Enumeration (Microsoft.DirectX.DirectPlay)

FindHostsFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic | Public Enum FindHostsFlags
C# | public enum FindHostsFlags
C++ | public enum class FindHostsFlags
JScript | public enum FindHostsFlags

Members

Member | Value | Description
Sync | -2147483648
NoBroadcastFallback | 2
OkToQueryForAddressing | 1
None | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GetSendQueueInformationFlags Enumeration (Microsoft.DirectX.DirectPlay)

GetSendQueueInformationFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic | Public Enum GetSendQueueInformationFlags
C# | public enum GetSendQueueInformationFlags
C++ | public enum class GetSendQueueInformationFlags
JScript | public enum GetSendQueueInformationFlags

Members

Member | Value | Description
PriorityLow | 4
PriorityHigh | 2
PriorityNormal | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupFlags Enumeration (Microsoft.DirectX.DirectPlay)

GroupFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic | Public Enum GroupFlags
C# | public enum GroupFlags
C++ | public enum class GroupFlags
JScript | public enum GroupFlags

Members

Member | Value | Description
AutoDestinationruct | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HostFlags Enumeration (Microsoft.DirectX.DirectPlay)

HostFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Setting this flag will display a standard Deprecated.

Definition

Visual Basic | Public Enum HostFlags
C# | public enum HostFlags
C++ | public enum class HostFlags
JScript | public enum HostFlags

Members

Member | Value | Description
OkToQueryForAddressing | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InitializeFlags Enumeration (Microsoft.DirectX.DirectPlay)

InitializeFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Disable parameter validation for the current object. Deprecated.

Definition

Visual Basic | Public Enum InitializeFlags
C# | public enum InitializeFlags
C++ | public enum class InitializeFlags
JScript | public enum InitializeFlags

Members

Member | Value | Description
DisableLinkTuning | 4
LanSessionHint | 2
DisableParameterValidation | 1
None | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


LocalAddressFlags Enumeration (Microsoft.DirectX.DirectPlay)

LocalAddressFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Deprecated.

Definition

Visual Basic | Public Enum LocalAddressFlags
C# | public enum LocalAddressFlags
C++ | public enum class LocalAddressFlags
JScript | public enum LocalAddressFlags

Members

Member | Value | Description
Combined | 1
None | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerID Enumeration (Microsoft.DirectX.DirectPlay)

PlayerID Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default system player id's. Deprecated.

Definition

Visual Basic | Public Enum PlayerID
C# | public enum PlayerID
C++ | public enum class PlayerID
JScript | public enum PlayerID

Members

Member | Value | Description
AllPlayers | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ResultCode Enumeration (Microsoft.DirectX.DirectPlay)

ResultCode Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result codes that can be returned via events. Deprecated.

Definition

Visual Basic | Public Enum ResultCode
C# | public enum ResultCode
C++ | public enum class ResultCode
JScript | public enum ResultCode

Members

Member | Value | Description
ConnectionLost | -2146074272
UserCancel | -2146073008
TimedOut | -2146073040
SessionFull | -2146073072
PlayerNotReachable | -2146073200
PlayerNotInGroup | -2146073216
PlayerLost | -2146073232
PlayerAlreadyInGroup | -2146073248
NotReady | -2146073280
NotHost | -2146073296
NotAllowed | -2146073312
NoResponse | -2146073328
NoHostPlayer | -2146073456
NoConnection | -2146073472
HostTerminatedSession | -2146074000
HostRejectedConnection | -2146074016
DoesNotExist | -2146074240
CannotCreatePlayer | -2146074320
CannotCreateGroup | -2146074336
CannotCancel | -2146074352
Aborted | -2146074576
Success | 0

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SendFlags Enumeration (Microsoft.DirectX.DirectPlay)

SendFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic | Public Enum SendFlags
C# | public enum SendFlags
C++ | public enum class SendFlags
JScript | public enum SendFlags

Members

Member | Value | Description
Coalesce | 256
PriorityHigh | 128
PriorityLow | 64
NoLoopback | 32
NonSequential | 16
Guaranteed | 8
CompleteOnProcess | 4
NoComplete | 2
NoCopy | 1
Sync | -2147483648

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionFlags Enumeration (Microsoft.DirectX.DirectPlay)

SessionFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic | Public Enum SessionFlags
C# | public enum SessionFlags
C++ | public enum class SessionFlags
JScript | public enum SessionFlags

Members

Member | Value | Description
FastSigned | 512
FullSigned | 1024
NoEnumerations | 256
RequirePassword | 128
NoDpnServer | 64
MigrateHost | 4
ClientServer | 1

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SyncFlags Enumeration (Microsoft.DirectX.DirectPlay)

SyncFlags Enumeration

Warning: This enum is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Flag that controls how this method is processed. Deprecated.

Definition

Visual Basic | Public Enum SyncFlags
C# | public enum SyncFlags
C++ | public enum class SyncFlags
JScript | public enum SyncFlags

Members

Member | Value | Description
PeerInformation | -2147483648
ServerInformation | -2147483648
ClientInformation | -2147483648
GroupInformation | -2147483648
OperationSynchronous | -2147483648
RemovePlayerFromGroup | -2147483648
AddPlayerToGroup | -2147483648
DestroyGroup | -2147483648
CreateGroup | -2147483648

Enumeration Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AddPlayerToGroupMessage Structure (Microsoft.DirectX.DirectPlay)

AddPlayerToGroupMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidAddPlayerToGroupDplay message when a player has been added to a group in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidAddPlayerToGroupDplay system message. Deprecated.

Definition

Visual Basic | Public Structure AddPlayerToGroupMessage
C# | public struct AddPlayerToGroupMessage
C++ | public value class AddPlayerToGroupMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
AddPlayerToGroupMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group to add the player. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player added to the group. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AddPlayerToGroupMessage.AddPlayerToGroupMessage() Constructor (Microsoft.DirectX.DirectPlay)

AddPlayerToGroupMessage.AddPlayerToGroupMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AddPlayerToGroupMessage();
C++ public:
AddPlayerToGroupMessage();
JScript | public function AddPlayerToGroupMessage();


AddPlayerToGroupMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

AddPlayerToGroupMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


AddPlayerToGroupMessage.GroupContext Property (Microsoft.DirectX.DirectPlay)

AddPlayerToGroupMessage.GroupContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupContext As Object
C# | public object GroupContext { get; }
C++ public:
property Object^ GroupContext {
Object^ get();
}
JScript | public function get GroupContext() : Object

Property Value

System.Object

This property is read-only.


AddPlayerToGroupMessage.GroupID Property (Microsoft.DirectX.DirectPlay)

AddPlayerToGroupMessage.GroupID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group to add the player. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
C++ public:
property int GroupID {
int get();
}
JScript | public function get GroupID() : int

Property Value

System.Int32

This property is read-only.


AddPlayerToGroupMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

AddPlayerToGroupMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


AddPlayerToGroupMessage.PlayerID Property (Microsoft.DirectX.DirectPlay)

AddPlayerToGroupMessage.PlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player added to the group. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
C++ public:
property int PlayerID {
int get();
}
JScript | public function get PlayerID() : int

Property Value

System.Int32

This property is read-only.


ApplicationDescription Structure (Microsoft.DirectX.DirectPlay)

ApplicationDescription Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the settings for a Microsoft® DirectPlay® application. Deprecated.

Definition

Visual Basic | Public Structure ApplicationDescription
C# | public struct ApplicationDescription
C++ | public value class ApplicationDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ApplicationDescription
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
CurrentPlayers
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD specifying the number of players currently connected to the session. This member is is set only by the Play8peerGetapplicationdescDplay, Play8clientGetapplicationdescDplay, and Play8serverGetapplicationdescDplay methods. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags describing application behavior. Deprecated.
GuidApplication
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Application GUID. Deprecated.
GuidInstance
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID that is generated by Microsoft® DirectPlay® at startup . This member is an [out] parameter when calling Play8peerGetapplicationdescDplay, Play8clientGetapplicationdescDplay, or Play8serverGetapplicationdescDplay. It is an optional [in] parameter when calling the Play8peerConnectDplay and Play8clientConnectDplay methods. It must be set to GUID_NULL when you call the Play8peerSetapplicationdescDplay or Play8serverSetapplicationdescDplay methods. You cannot obtain this GUID by calling the Play8serverHostDplay or Play8peerHostDplay methods. You must obtain the GUID by calling a GetApplicationDesc method. Deprecated.
MaxPlayers
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD, specifying the maximum number of players allowed in the session. Set this member to 0 to specify an unlimited number of players. Deprecated.
Password
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WCHAR specifying the Unicode password that is required to connect to the session. This must be NULL if the DPNSESSION_REQUIREPASSWORD is not set in thedwFlags member. Deprecated.
SessionName
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WCHAR specifying the name of the session. This member is set by the host or server only for informational purposes. A client cannot use this name to connect to a host or server. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ApplicationDescription.ApplicationDescription() Constructor (Microsoft.DirectX.DirectPlay)

ApplicationDescription.ApplicationDescription Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ApplicationDescription();
C++ public:
ApplicationDescription();
JScript | public function ApplicationDescription();


ApplicationDescription.ToString() Method (Microsoft.DirectX.DirectPlay)

ApplicationDescription.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ApplicationDescription.CurrentPlayers Property (Microsoft.DirectX.DirectPlay)

ApplicationDescription.CurrentPlayers Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD specifying the number of players currently connected to the session. This member is is set only by the Play8peerGetapplicationdescDplay, Play8clientGetapplicationdescDplay, and Play8serverGetapplicationdescDplay methods. Deprecated.

Definition

Visual Basic | Public Property CurrentPlayers As Integer
C# | public int CurrentPlayers { get; set; }
C++ public:
property int CurrentPlayers {
int get();
void set(int value);
}
JScript public function get CurrentPlayers() : int
public function set CurrentPlayers(int);

Property Value

System.Int32

This property is read/write.


ApplicationDescription.Flags Property (Microsoft.DirectX.DirectPlay)

ApplicationDescription.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags describing application behavior. Deprecated.

Definition

Visual Basic | Public Property Flags As SessionFlags
C# | public SessionFlags Flags { get; set; }
C++ public:
property SessionFlags Flags {
SessionFlags get();
void set(SessionFlags value);
}
JScript public function get Flags() : SessionFlags
public function set Flags(SessionFlags);

Property Value

Microsoft.DirectX.DirectPlay.SessionFlags

This property is read/write.


ApplicationDescription.GuidApplication Property (Microsoft.DirectX.DirectPlay)

ApplicationDescription.GuidApplication Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Application GUID. Deprecated.

Definition

Visual Basic | Public Property GuidApplication As Guid
C# | public Guid GuidApplication { get; set; }
C++ public:
property Guid GuidApplication {
Guid get();
void set(Guid value);
}
JScript public function get GuidApplication() : Guid
public function set GuidApplication(Guid);

Property Value

System.Guid

This property is read/write.


ApplicationDescription.GuidInstance Property (Microsoft.DirectX.DirectPlay)

ApplicationDescription.GuidInstance Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID that is generated by Microsoft® DirectPlay® at startup . This member is an [out] parameter when calling Play8peerGetapplicationdescDplay, Play8clientGetapplicationdescDplay, or Play8serverGetapplicationdescDplay. It is an optional [in] parameter when calling the Play8peerConnectDplay and Play8clientConnectDplay methods. It must be set to GUID_NULL when you call the Play8peerSetapplicationdescDplay or Play8serverSetapplicationdescDplay methods. You cannot obtain this GUID by calling the Play8serverHostDplay or Play8peerHostDplay methods. You must obtain the GUID by calling a GetApplicationDesc method. Deprecated.

Definition

Visual Basic | Public Property GuidInstance As Guid
C# | public Guid GuidInstance { get; set; }
C++ public:
property Guid GuidInstance {
Guid get();
void set(Guid value);
}
JScript public function get GuidInstance() : Guid
public function set GuidInstance(Guid);

Property Value

System.Guid

This property is read/write.


ApplicationDescription.MaxPlayers Property (Microsoft.DirectX.DirectPlay)

ApplicationDescription.MaxPlayers Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD, specifying the maximum number of players allowed in the session. Set this member to 0 to specify an unlimited number of players. Deprecated.

Definition

Visual Basic | Public Property MaxPlayers As Integer
C# | public int MaxPlayers { get; set; }
C++ public:
property int MaxPlayers {
int get();
void set(int value);
}
JScript public function get MaxPlayers() : int
public function set MaxPlayers(int);

Property Value

System.Int32

This property is read/write.


ApplicationDescription.Password Property (Microsoft.DirectX.DirectPlay)

ApplicationDescription.Password Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WCHAR specifying the Unicode password that is required to connect to the session. This must be NULL if the DPNSESSION_REQUIREPASSWORD is not set in thedwFlags member. Deprecated.

Definition

Visual Basic | Public Property Password As String
C# | public string Password { get; set; }
C++ public:
property String^ Password {
String^ get();
void set(String^ value);
}
JScript public function get Password() : String
public function set Password(String);

Property Value

System.String

This property is read/write.


ApplicationDescription.SessionName Property (Microsoft.DirectX.DirectPlay)

ApplicationDescription.SessionName Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type WCHAR specifying the name of the session. This member is set by the host or server only for informational purposes. A client cannot use this name to connect to a host or server. Deprecated.

Definition

Visual Basic | Public Property SessionName As String
C# | public string SessionName { get; set; }
C++ public:
property String^ SessionName {
String^ get();
void set(String^ value);
}
JScript public function get SessionName() : String
public function set SessionName(String);

Property Value

System.String

This property is read/write.


AsyncOperationCompleteMessage Structure (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the AsyncOperationComplete event. Deprecated.

Definition

Visual Basic | Public Structure AsyncOperationCompleteMessage
C# | public struct AsyncOperationCompleteMessage
C++ | public value class AsyncOperationCompleteMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
AsyncOperationCompleteMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AsyncOperationHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.
ResultCode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result of the asynchronous operation. Deprecated.
UserContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supplied user context. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AsyncOperationCompleteMessage.AsyncOperationCompleteMessage() Constructor (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteMessage.AsyncOperationCompleteMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public AsyncOperationCompleteMessage();
C++ public:
AsyncOperationCompleteMessage();
JScript | public function AsyncOperationCompleteMessage();


AsyncOperationCompleteMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


AsyncOperationCompleteMessage.AsyncOperationHandle Property (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteMessage.AsyncOperationHandle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AsyncOperationHandle As Integer
C# | public int AsyncOperationHandle { get; }
C++ public:
property int AsyncOperationHandle {
int get();
}
JScript | public function get AsyncOperationHandle() : int

Property Value

System.Int32

This property is read-only.


AsyncOperationCompleteMessage.ResultCode Property (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteMessage.ResultCode Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Result of the asynchronous operation. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ResultCode As ResultCode
C# | public ResultCode ResultCode { get; }
C++ public:
property ResultCode ResultCode {
ResultCode get();
}
JScript | public function get ResultCode() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode

This property is read-only.


AsyncOperationCompleteMessage.UserContext Property (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteMessage.UserContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Supplied user context. Deprecated.

Definition

Visual Basic | Public ReadOnly Property UserContext As Object
C# | public object UserContext { get; }
C++ public:
property Object^ UserContext {
Object^ get();
}
JScript | public function get UserContext() : Object

Property Value

System.Object

This property is read-only.


Caps Structure (Microsoft.DirectX.DirectPlay)

Caps Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used when setting and retrieving general parameters for Microsoft® DirectPlay®. Deprecated.

Definition

Visual Basic | Public Structure Caps
C# | public struct Caps
C++ | public value class Caps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
Caps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ConnectRetries
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of connection retries Microsoft® DirectPlay® should make during the connection process. Deprecated.
ConnectTimeout
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of milliseconds Microsoft® DirectPlay® should wait before it retries a connection request. Deprecated.
DropThresholdRate
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Percentage of dropped packets allowed before is applied. Deprecated.
MaxHardDisconnectPeriod
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum period of time in milliseconds between each hard disconnect frame sent. Deprecated.
MaxReceiveMessageSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum size of received messages, in bytes. Deprecated.
MaxSendRetryInterval
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of times applications can try to send a message before the connection is considered dead. Deprecated.
NumberHardDisconnectSends
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of hard disconnect frames to send when the Close.Immediate flag is specified. Deprecated.
NumberSendRetries
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of hard disconnect frames to send when the DPNCLOSE_IMMEDIATE flag is specified. Deprecated.
ThrottleRate
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Percentage to reduce the send queue when applying message throttling. Deprecated.
TimeoutUntilKeepAlive
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of milliseconds Microsoft® DirectPlay® waits since the last time it received a packet from an endpoint, before it sends a keep alive message. The actual delay can vary from the specified value to as much as twice the specified value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Caps.Caps() Constructor (Microsoft.DirectX.DirectPlay)

Caps.Caps Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public Caps();
C++ public:
Caps();
JScript | public function Caps();


Caps.ToString() Method (Microsoft.DirectX.DirectPlay)

Caps.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Caps.ConnectRetries Property (Microsoft.DirectX.DirectPlay)

Caps.ConnectRetries Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of connection retries Microsoft® DirectPlay® should make during the connection process. Deprecated.

Definition

Visual Basic | Public Property ConnectRetries As Integer
C# | public int ConnectRetries { get; set; }
C++ public:
property int ConnectRetries {
int get();
void set(int value);
}
JScript public function get ConnectRetries() : int
public function set ConnectRetries(int);

Property Value

System.Int32

This property is read/write.


Caps.ConnectTimeout Property (Microsoft.DirectX.DirectPlay)

Caps.ConnectTimeout Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of milliseconds Microsoft® DirectPlay® should wait before it retries a connection request. Deprecated.

Definition

Visual Basic | Public Property ConnectTimeout As Integer
C# | public int ConnectTimeout { get; set; }
C++ public:
property int ConnectTimeout {
int get();
void set(int value);
}
JScript public function get ConnectTimeout() : int
public function set ConnectTimeout(int);

Property Value

System.Int32

This property is read/write.


Caps.DropThresholdRate Property (Microsoft.DirectX.DirectPlay)

Caps.DropThresholdRate Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Percentage of dropped packets allowed before is applied. Deprecated.

Definition

Visual Basic | Public Property DropThresholdRate As Integer
C# | public int DropThresholdRate { get; set; }
C++ public:
property int DropThresholdRate {
int get();
void set(int value);
}
JScript public function get DropThresholdRate() : int
public function set DropThresholdRate(int);

Property Value

System.Int32

This property is read/write.


Caps.MaxHardDisconnectPeriod Property (Microsoft.DirectX.DirectPlay)

Caps.MaxHardDisconnectPeriod Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum period of time in milliseconds between each hard disconnect frame sent. Deprecated.

Definition

Visual Basic | Public Property MaxHardDisconnectPeriod As Integer
C# | public int MaxHardDisconnectPeriod { get; set; }
C++ public:
property int MaxHardDisconnectPeriod {
int get();
void set(int value);
}
JScript public function get MaxHardDisconnectPeriod() : int
public function set MaxHardDisconnectPeriod(int);

Property Value

System.Int32

This property is read/write.


Caps.MaxReceiveMessageSize Property (Microsoft.DirectX.DirectPlay)

Caps.MaxReceiveMessageSize Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum size of received messages, in bytes. Deprecated.

Definition

Visual Basic | Public Property MaxReceiveMessageSize As Integer
C# | public int MaxReceiveMessageSize { get; set; }
C++ public:
property int MaxReceiveMessageSize {
int get();
void set(int value);
}
JScript public function get MaxReceiveMessageSize() : int
public function set MaxReceiveMessageSize(int);

Property Value

System.Int32

This property is read/write.


Caps.MaxSendRetryInterval Property (Microsoft.DirectX.DirectPlay)

Caps.MaxSendRetryInterval Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum number of times applications can try to send a message before the connection is considered dead. Deprecated.

Definition

Visual Basic | Public Property MaxSendRetryInterval As Integer
C# | public int MaxSendRetryInterval { get; set; }
C++ public:
property int MaxSendRetryInterval {
int get();
void set(int value);
}
JScript public function get MaxSendRetryInterval() : int
public function set MaxSendRetryInterval(int);

Property Value

System.Int32

This property is read/write.


Caps.NumberHardDisconnectSends Property (Microsoft.DirectX.DirectPlay)

Caps.NumberHardDisconnectSends Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of hard disconnect frames to send when the Close.Immediate flag is specified. Deprecated.

Definition

Visual Basic | Public Property NumberHardDisconnectSends As Integer
C# | public int NumberHardDisconnectSends { get; set; }
C++ public:
property int NumberHardDisconnectSends {
int get();
void set(int value);
}
JScript public function get NumberHardDisconnectSends() : int
public function set NumberHardDisconnectSends(int);

Property Value

System.Int32

This property is read/write.


Caps.NumberSendRetries Property (Microsoft.DirectX.DirectPlay)

Caps.NumberSendRetries Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of hard disconnect frames to send when the DPNCLOSE_IMMEDIATE flag is specified. Deprecated.

Definition

Visual Basic | Public Property NumberSendRetries As Integer
C# | public int NumberSendRetries { get; set; }
C++ public:
property int NumberSendRetries {
int get();
void set(int value);
}
JScript public function get NumberSendRetries() : int
public function set NumberSendRetries(int);

Property Value

System.Int32

This property is read/write.


Caps.ThrottleRate Property (Microsoft.DirectX.DirectPlay)

Caps.ThrottleRate Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Percentage to reduce the send queue when applying message throttling. Deprecated.

Definition

Visual Basic | Public Property ThrottleRate As Integer
C# | public int ThrottleRate { get; set; }
C++ public:
property int ThrottleRate {
int get();
void set(int value);
}
JScript public function get ThrottleRate() : int
public function set ThrottleRate(int);

Property Value

System.Int32

This property is read/write.


Caps.TimeoutUntilKeepAlive Property (Microsoft.DirectX.DirectPlay)

Caps.TimeoutUntilKeepAlive Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of milliseconds Microsoft® DirectPlay® waits since the last time it received a packet from an endpoint, before it sends a keep alive message. The actual delay can vary from the specified value to as much as twice the specified value. Deprecated.

Definition

Visual Basic | Public Property TimeoutUntilKeepAlive As Integer
C# | public int TimeoutUntilKeepAlive { get; set; }
C++ public:
property int TimeoutUntilKeepAlive {
int get();
void set(int value);
}
JScript public function get TimeoutUntilKeepAlive() : int
public function set TimeoutUntilKeepAlive(int);

Property Value

System.Int32

This property is read/write.


ClientInformationMessage Structure (Microsoft.DirectX.DirectPlay)

ClientInformationMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.

Definition

Visual Basic | Public Structure ClientInformationMessage
C# | public struct ClientInformationMessage
C++ | public value class ClientInformationMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ClientInformationMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ClientID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the client for client information. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClientInformationMessage.ClientInformationMessage() Constructor (Microsoft.DirectX.DirectPlay)

ClientInformationMessage.ClientInformationMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ClientInformationMessage();
C++ public:
ClientInformationMessage();
JScript | public function ClientInformationMessage();


ClientInformationMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

ClientInformationMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ClientInformationMessage.ClientID Property (Microsoft.DirectX.DirectPlay)

ClientInformationMessage.ClientID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the client for client information. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ClientID As Integer
C# | public int ClientID { get; }
C++ public:
property int ClientID {
int get();
}
JScript | public function get ClientID() : int

Property Value

System.Int32

This property is read-only.


ClientInformationMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

ClientInformationMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


ConnectCompleteMessage Structure (Microsoft.DirectX.DirectPlay)

ConnectCompleteMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.

Definition

Visual Basic | Public Structure ConnectCompleteMessage
C# | public struct ConnectCompleteMessage
C++ | public value class ConnectCompleteMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ConnectCompleteMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ApplicationReplyData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Connection reply data returned from the host or server. Deprecated.
AsyncOperationHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.
LocalPlayerId
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the DPNID of the local player. Deprecated.
ResultCode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT describing the result of the connection attempt. See the Return Values section in the Play8peerConnectDplay or Play8clientConnectDplay method for more information. Additionally, DPNERR_PLAYERNOTREACHABLE will be returned if a player has tried to join a peer-to-peer session where at least one other existing player in the session cannot connect to the joining player. Deprecated.
UserContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User context supplied when the Play8peerConnectDplay or Play8clientConnectDplay methods are called. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectCompleteMessage.ConnectCompleteMessage() Constructor (Microsoft.DirectX.DirectPlay)

ConnectCompleteMessage.ConnectCompleteMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectCompleteMessage();
C++ public:
ConnectCompleteMessage();
JScript | public function ConnectCompleteMessage();


ConnectCompleteMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

ConnectCompleteMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConnectCompleteMessage.ApplicationReplyData Property (Microsoft.DirectX.DirectPlay)

ConnectCompleteMessage.ApplicationReplyData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Connection reply data returned from the host or server. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ApplicationReplyData As NetworkPacket
C# | public NetworkPacket ApplicationReplyData { get; }
C++ public:
property NetworkPacket^ ApplicationReplyData {
NetworkPacket^ get();
}
JScript | public function get ApplicationReplyData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read-only.


ConnectCompleteMessage.AsyncOperationHandle Property (Microsoft.DirectX.DirectPlay)

ConnectCompleteMessage.AsyncOperationHandle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AsyncOperationHandle As Integer
C# | public int AsyncOperationHandle { get; }
C++ public:
property int AsyncOperationHandle {
int get();
}
JScript | public function get AsyncOperationHandle() : int

Property Value

System.Int32

This property is read-only.


ConnectCompleteMessage.LocalPlayerId Property (Microsoft.DirectX.DirectPlay)

ConnectCompleteMessage.LocalPlayerId Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the DPNID of the local player. Deprecated.

Definition

Visual Basic | Public ReadOnly Property LocalPlayerId As Integer
C# | public int LocalPlayerId { get; }
C++ public:
property int LocalPlayerId {
int get();
}
JScript | public function get LocalPlayerId() : int

Property Value

System.Int32

This property is read-only.


ConnectCompleteMessage.ResultCode Property (Microsoft.DirectX.DirectPlay)

ConnectCompleteMessage.ResultCode Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT describing the result of the connection attempt. See the Return Values section in the Play8peerConnectDplay or Play8clientConnectDplay method for more information. Additionally, DPNERR_PLAYERNOTREACHABLE will be returned if a player has tried to join a peer-to-peer session where at least one other existing player in the session cannot connect to the joining player. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ResultCode As ResultCode
C# | public ResultCode ResultCode { get; }
C++ public:
property ResultCode ResultCode {
ResultCode get();
}
JScript | public function get ResultCode() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode

This property is read-only.


ConnectCompleteMessage.UserContext Property (Microsoft.DirectX.DirectPlay)

ConnectCompleteMessage.UserContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User context supplied when the Play8peerConnectDplay or Play8clientConnectDplay methods are called. Deprecated.

Definition

Visual Basic | Public ReadOnly Property UserContext As Object
C# | public object UserContext { get; }
C++ public:
property Object^ UserContext {
Object^ get();
}
JScript | public function get UserContext() : Object

Property Value

System.Object

This property is read-only.


ConnectionInformation Structure (Microsoft.DirectX.DirectPlay)

ConnectionInformation Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to retrieve statistics for the connection between you and a remote computer that you are connected to. Deprecated.

Definition

Visual Basic | Public Structure ConnectionInformation
C# | public struct ConnectionInformation
C++ | public value class ConnectionInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ConnectionInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
BytesDropped
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of messages that have been dropped. Deprecated.
BytesReceivedGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of guaranteed messages that have been received. Deprecated.
BytesReceivedNonGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of nonguaranteed messages that have been received. Deprecated.
BytesRetried
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of messages that have been retried. Deprecated.
BytesSentGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of guaranteed messages that have been sent. Deprecated.
BytesSentNonGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of nonguaranteed messages that have been sent. Deprecated.
MessagesReceived
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of messages that have been received. Deprecated.
MessagesTimedOutHighPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of high-priority messages that have timed out. Deprecated.
MessagesTimedOutLowPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of low priority messages that have timed out. Deprecated.
MessagesTimedOutNormalPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of normal-priority messages that have timed out. Deprecated.
MessagesTransmittedHighPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of high-priority messages that have been transmitted. Deprecated.
MessagesTransmittedLowPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of low-priority messages that have been transmitted. Deprecated.
MessagesTransmittedNormalPriority
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of normal-priority messages that have been transmitted. Deprecated.
PacketsDropped
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets that have been dropped. Deprecated.
PacketsReceivedGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of guaranteed messages that have been received. Deprecated.
PacketsReceivedNonGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of nonguaranteed messages that have been received. Deprecated.
PacketsRetried
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount of packets that have been retried. Deprecated.
PacketsSentGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of guaranteed messages that have been sent. Deprecated.
PacketsSentNonGuaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of nonguaranteed messages that have been sent. Deprecated.
PeakThroughputBps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Peak throughput, in bytes per second (Bps) for the link. This number will change throughout the session as link conditions change. This value is approximate, and you may want to calculate your own value for greater accuracy. Deprecated.
RoundTripLatencyMs
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Approximate time, in milliseconds (ms), it takes a packet to reach the remote computer and be returned to the local computer. This number will change throughout the session as link conditions change. Deprecated.
ThroughputBps
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Approximate throughput, in bytes per second (Bps), for the link. This number will change throughout the session as link conditions change. This value is approximate, and you may want to calculate your own value for greater accuracy. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectionInformation.ConnectionInformation() Constructor (Microsoft.DirectX.DirectPlay)

ConnectionInformation.ConnectionInformation Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ConnectionInformation();
C++ public:
ConnectionInformation();
JScript | public function ConnectionInformation();


ConnectionInformation.ToString() Method (Microsoft.DirectX.DirectPlay)

ConnectionInformation.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ConnectionInformation.BytesDropped Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.BytesDropped Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of messages that have been dropped. Deprecated.

Definition

Visual Basic | Public Property BytesDropped As Integer
C# | public int BytesDropped { get; set; }
C++ public:
property int BytesDropped {
int get();
void set(int value);
}
JScript public function get BytesDropped() : int
public function set BytesDropped(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.BytesReceivedGuaranteed Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.BytesReceivedGuaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of guaranteed messages that have been received. Deprecated.

Definition

Visual Basic | Public Property BytesReceivedGuaranteed As Integer
C# | public int BytesReceivedGuaranteed { get; set; }
C++ public:
property int BytesReceivedGuaranteed {
int get();
void set(int value);
}
JScript public function get BytesReceivedGuaranteed() : int
public function set BytesReceivedGuaranteed(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.BytesReceivedNonGuaranteed Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.BytesReceivedNonGuaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of nonguaranteed messages that have been received. Deprecated.

Definition

Visual Basic | Public Property BytesReceivedNonGuaranteed As Integer
C# | public int BytesReceivedNonGuaranteed { get; set; }
C++ public:
property int BytesReceivedNonGuaranteed {
int get();
void set(int value);
}
JScript public function get BytesReceivedNonGuaranteed() : int
public function set BytesReceivedNonGuaranteed(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.BytesRetried Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.BytesRetried Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of messages that have been retried. Deprecated.

Definition

Visual Basic | Public Property BytesRetried As Integer
C# | public int BytesRetried { get; set; }
C++ public:
property int BytesRetried {
int get();
void set(int value);
}
JScript public function get BytesRetried() : int
public function set BytesRetried(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.BytesSentGuaranteed Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.BytesSentGuaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of guaranteed messages that have been sent. Deprecated.

Definition

Visual Basic | Public Property BytesSentGuaranteed As Integer
C# | public int BytesSentGuaranteed { get; set; }
C++ public:
property int BytesSentGuaranteed {
int get();
void set(int value);
}
JScript public function get BytesSentGuaranteed() : int
public function set BytesSentGuaranteed(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.BytesSentNonGuaranteed Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.BytesSentNonGuaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount, in bytes, of nonguaranteed messages that have been sent. Deprecated.

Definition

Visual Basic | Public Property BytesSentNonGuaranteed As Integer
C# | public int BytesSentNonGuaranteed { get; set; }
C++ public:
property int BytesSentNonGuaranteed {
int get();
void set(int value);
}
JScript public function get BytesSentNonGuaranteed() : int
public function set BytesSentNonGuaranteed(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.MessagesReceived Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.MessagesReceived Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of messages that have been received. Deprecated.

Definition

Visual Basic | Public Property MessagesReceived As Integer
C# | public int MessagesReceived { get; set; }
C++ public:
property int MessagesReceived {
int get();
void set(int value);
}
JScript public function get MessagesReceived() : int
public function set MessagesReceived(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.MessagesTimedOutHighPriority Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.MessagesTimedOutHighPriority Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of high-priority messages that have timed out. Deprecated.

Definition

Visual Basic | Public Property MessagesTimedOutHighPriority As Integer
C# | public int MessagesTimedOutHighPriority { get; set; }
C++ public:
property int MessagesTimedOutHighPriority {
int get();
void set(int value);
}
JScript public function get MessagesTimedOutHighPriority() : int
public function set MessagesTimedOutHighPriority(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.MessagesTimedOutLowPriority Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.MessagesTimedOutLowPriority Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of low priority messages that have timed out. Deprecated.

Definition

Visual Basic | Public Property MessagesTimedOutLowPriority As Integer
C# | public int MessagesTimedOutLowPriority { get; set; }
C++ public:
property int MessagesTimedOutLowPriority {
int get();
void set(int value);
}
JScript public function get MessagesTimedOutLowPriority() : int
public function set MessagesTimedOutLowPriority(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.MessagesTimedOutNormalPriority Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.MessagesTimedOutNormalPriority Property

Language:

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of normal-priority messages that have timed out. Deprecated.

Definition

Visual Basic | Public Property MessagesTimedOutNormalPriority As Integer
C# | public int MessagesTimedOutNormalPriority { get; set; }
C++ public:
property int MessagesTimedOutNormalPriority {
int get();
void set(int value);
}
JScript public function get MessagesTimedOutNormalPriority() : int
public function set MessagesTimedOutNormalPriority(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.MessagesTransmittedHighPriority Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.MessagesTransmittedHighPriority Property

Language:

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of high-priority messages that have been transmitted. Deprecated.

Definition

Visual Basic | Public Property MessagesTransmittedHighPriority As Integer
C# | public int MessagesTransmittedHighPriority { get; set; }
C++ public:
property int MessagesTransmittedHighPriority {
int get();
void set(int value);
}
JScript public function get MessagesTransmittedHighPriority() : int
public function set MessagesTransmittedHighPriority(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.MessagesTransmittedLowPriority Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.MessagesTransmittedLowPriority Property

Language:

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of low-priority messages that have been transmitted. Deprecated.

Definition

Visual Basic | Public Property MessagesTransmittedLowPriority As Integer
C# | public int MessagesTransmittedLowPriority { get; set; }
C++ public:
property int MessagesTransmittedLowPriority {
int get();
void set(int value);
}
JScript public function get MessagesTransmittedLowPriority() : int
public function set MessagesTransmittedLowPriority(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.MessagesTransmittedNormalPriority Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.MessagesTransmittedNormalPriority Property

Language:

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of normal-priority messages that have been transmitted. Deprecated.

Definition

Visual Basic | Public Property MessagesTransmittedNormalPriority As Integer
C# | public int MessagesTransmittedNormalPriority { get; set; }
C++ public:
property int MessagesTransmittedNormalPriority {
int get();
void set(int value);
}
JScript public function get MessagesTransmittedNormalPriority() : int
public function set MessagesTransmittedNormalPriority(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.PacketsDropped Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.PacketsDropped Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets that have been dropped. Deprecated.

Definition

Visual Basic | Public Property PacketsDropped As Integer
C# | public int PacketsDropped { get; set; }
C++ public:
property int PacketsDropped {
int get();
void set(int value);
}
JScript public function get PacketsDropped() : int
public function set PacketsDropped(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.PacketsReceivedGuaranteed Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.PacketsReceivedGuaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of guaranteed messages that have been received. Deprecated.

Definition

Visual Basic | Public Property PacketsReceivedGuaranteed As Integer
C# | public int PacketsReceivedGuaranteed { get; set; }
C++ public:
property int PacketsReceivedGuaranteed {
int get();
void set(int value);
}
JScript public function get PacketsReceivedGuaranteed() : int
public function set PacketsReceivedGuaranteed(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.PacketsReceivedNonGuaranteed Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.PacketsReceivedNonGuaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of nonguaranteed messages that have been received. Deprecated.

Definition

Visual Basic | Public Property PacketsReceivedNonGuaranteed As Integer
C# | public int PacketsReceivedNonGuaranteed { get; set; }
C++ public:
property int PacketsReceivedNonGuaranteed {
int get();
void set(int value);
}
JScript public function get PacketsReceivedNonGuaranteed() : int
public function set PacketsReceivedNonGuaranteed(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.PacketsRetried Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.PacketsRetried Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Amount of packets that have been retried. Deprecated.

Definition

Visual Basic | Public Property PacketsRetried As Integer
C# | public int PacketsRetried { get; set; }
C++ public:
property int PacketsRetried {
int get();
void set(int value);
}
JScript public function get PacketsRetried() : int
public function set PacketsRetried(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.PacketsSentGuaranteed Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.PacketsSentGuaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of guaranteed messages that have been sent. Deprecated.

Definition

Visual Basic | Public Property PacketsSentGuaranteed As Integer
C# | public int PacketsSentGuaranteed { get; set; }
C++ public:
property int PacketsSentGuaranteed {
int get();
void set(int value);
}
JScript public function get PacketsSentGuaranteed() : int
public function set PacketsSentGuaranteed(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.PacketsSentNonGuaranteed Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.PacketsSentNonGuaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of packets of nonguaranteed messages that have been sent. Deprecated.

Definition

Visual Basic | Public Property PacketsSentNonGuaranteed As Integer
C# | public int PacketsSentNonGuaranteed { get; set; }
C++ public:
property int PacketsSentNonGuaranteed {
int get();
void set(int value);
}
JScript public function get PacketsSentNonGuaranteed() : int
public function set PacketsSentNonGuaranteed(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.PeakThroughputBps Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.PeakThroughputBps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Peak throughput, in bytes per second (Bps) for the link. This number will change throughout the session as link conditions change. This value is approximate, and you may want to calculate your own value for greater accuracy. Deprecated.

Definition

Visual Basic | Public Property PeakThroughputBps As Integer
C# | public int PeakThroughputBps { get; set; }
C++ public:
property int PeakThroughputBps {
int get();
void set(int value);
}
JScript public function get PeakThroughputBps() : int
public function set PeakThroughputBps(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.RoundTripLatencyMs Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.RoundTripLatencyMs Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Approximate time, in milliseconds (ms), it takes a packet to reach the remote computer and be returned to the local computer. This number will change throughout the session as link conditions change. Deprecated.

Definition

Visual Basic | Public Property RoundTripLatencyMs As Integer
C# | public int RoundTripLatencyMs { get; set; }
C++ public:
property int RoundTripLatencyMs {
int get();
void set(int value);
}
JScript public function get RoundTripLatencyMs() : int
public function set RoundTripLatencyMs(int);

Property Value

System.Int32

This property is read/write.


ConnectionInformation.ThroughputBps Property (Microsoft.DirectX.DirectPlay)

ConnectionInformation.ThroughputBps Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Approximate throughput, in bytes per second (Bps), for the link. This number will change throughout the session as link conditions change. This value is approximate, and you may want to calculate your own value for greater accuracy. Deprecated.

Definition

Visual Basic | Public Property ThroughputBps As Integer
C# | public int ThroughputBps { get; set; }
C++ public:
property int ThroughputBps {
int get();
void set(int value);
}
JScript public function get ThroughputBps() : int
public function set ThroughputBps(int);

Property Value

System.Int32

This property is read/write.


CreateGroupMessage Structure (Microsoft.DirectX.DirectPlay)

CreateGroupMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreateGroupDplay message when a group is created.The structure contains information for the DpnMsgidCreateGroupDplay system message. Deprecated.

Definition

Visual Basic | Public Structure CreateGroupMessage
C# | public struct CreateGroupMessage
C++ | public value class CreateGroupMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CreateGroupMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the of the created group. Deprecated.
OwnerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Owner context value. Deprecated.
OwnerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the of the group's owner. This value is only set for groups that have the DPNGROUP_AUTODESTRUCT flag set in the dwGroupFlags member of the DpnGroupInfoDplay structure. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CreateGroupMessage.CreateGroupMessage() Constructor (Microsoft.DirectX.DirectPlay)

CreateGroupMessage.CreateGroupMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CreateGroupMessage();
C++ public:
CreateGroupMessage();
JScript | public function CreateGroupMessage();


CreateGroupMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

CreateGroupMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CreateGroupMessage.GroupContext Property (Microsoft.DirectX.DirectPlay)

CreateGroupMessage.GroupContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic | Public Property GroupContext As Object
C# | public object GroupContext { get; set; }
C++ public:
property Object^ GroupContext {
Object^ get();
void set(Object^ value);
}
JScript public function get GroupContext() : Object
public function set GroupContext(Object);

Property Value

System.Object

This property is read/write.


CreateGroupMessage.GroupID Property (Microsoft.DirectX.DirectPlay)

CreateGroupMessage.GroupID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the of the created group. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
C++ public:
property int GroupID {
int get();
}
JScript | public function get GroupID() : int

Property Value

System.Int32

This property is read-only.


CreateGroupMessage.OwnerContext Property (Microsoft.DirectX.DirectPlay)

CreateGroupMessage.OwnerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Owner context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OwnerContext As Object
C# | public object OwnerContext { get; }
C++ public:
property Object^ OwnerContext {
Object^ get();
}
JScript | public function get OwnerContext() : Object

Property Value

System.Object

This property is read-only.


CreateGroupMessage.OwnerID Property (Microsoft.DirectX.DirectPlay)

CreateGroupMessage.OwnerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the of the group's owner. This value is only set for groups that have the DPNGROUP_AUTODESTRUCT flag set in the dwGroupFlags member of the DpnGroupInfoDplay structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property OwnerID As Integer
C# | public int OwnerID { get; }
C++ public:
property int OwnerID {
int get();
}
JScript | public function get OwnerID() : int

Property Value

System.Int32

This property is read-only.


CreatePlayerMessage Structure (Microsoft.DirectX.DirectPlay)

CreatePlayerMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreatePlayerDplay message when a player is added to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidCreatePlayerDplay system message. Deprecated.

Definition

Visual Basic | Public Structure CreatePlayerMessage
C# | public struct CreatePlayerMessage
C++ | public value class CreatePlayerMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CreatePlayerMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player that was added to the session. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CreatePlayerMessage.CreatePlayerMessage() Constructor (Microsoft.DirectX.DirectPlay)

CreatePlayerMessage.CreatePlayerMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CreatePlayerMessage();
C++ public:
CreatePlayerMessage();
JScript | public function CreatePlayerMessage();


CreatePlayerMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

CreatePlayerMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CreatePlayerMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

CreatePlayerMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public Property PlayerContext As Object
C# | public object PlayerContext { get; set; }
C++ public:
property Object^ PlayerContext {
Object^ get();
void set(Object^ value);
}
JScript public function get PlayerContext() : Object
public function set PlayerContext(Object);

Property Value

System.Object

This property is read/write.


CreatePlayerMessage.PlayerID Property (Microsoft.DirectX.DirectPlay)

CreatePlayerMessage.PlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player that was added to the session. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
C++ public:
property int PlayerID {
int get();
}
JScript | public function get PlayerID() : int

Property Value

System.Int32

This property is read-only.


CreateThreadMessage Structure (Microsoft.DirectX.DirectPlay)

CreateThreadMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidCreateThreadDplay message when a new thread is created.The structure contains information for the DpnMsgidCreateThreadDplay system message. Deprecated.

Definition

Visual Basic | Public Structure CreateThreadMessage
C# | public struct CreateThreadMessage
C++ | public value class CreateThreadMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
CreateThreadMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Thread context value. Deprecated.
ProcessorNum
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the processor index to which this thread is bound. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CreateThreadMessage.CreateThreadMessage() Constructor (Microsoft.DirectX.DirectPlay)

CreateThreadMessage.CreateThreadMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public CreateThreadMessage();
C++ public:
CreateThreadMessage();
JScript | public function CreateThreadMessage();


CreateThreadMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

CreateThreadMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CreateThreadMessage.Flags Property (Microsoft.DirectX.DirectPlay)

CreateThreadMessage.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Flags As Integer
C# | public int Flags { get; }
C++ public:
property int Flags {
int get();
}
JScript | public function get Flags() : int

Property Value

System.Int32

This property is read-only.


CreateThreadMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

CreateThreadMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Thread context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


CreateThreadMessage.ProcessorNum Property (Microsoft.DirectX.DirectPlay)

CreateThreadMessage.ProcessorNum Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies the processor index to which this thread is bound. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ProcessorNum As Integer
C# | public int ProcessorNum { get; }
C++ public:
property int ProcessorNum {
int get();
}
JScript | public function get ProcessorNum() : int

Property Value

System.Int32

This property is read-only.


DestroyGroupMessage Structure (Microsoft.DirectX.DirectPlay)

DestroyGroupMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyGroupDplay message when a group is destroyed from a peer-to-peer or client/server session.The structure contains information for the DpnMsgidDestroyGroupDplay system message. Deprecated.

Definition

Visual Basic | Public Structure DestroyGroupMessage
C# | public struct DestroyGroupMessage
C++ | public value class DestroyGroupMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DestroyGroupMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group deleted from the session. Deprecated.
Reason
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The following flag can be set to indicate why the player was destroyed. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DestroyGroupMessage.DestroyGroupMessage() Constructor (Microsoft.DirectX.DirectPlay)

DestroyGroupMessage.DestroyGroupMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DestroyGroupMessage();
C++ public:
DestroyGroupMessage();
JScript | public function DestroyGroupMessage();


DestroyGroupMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

DestroyGroupMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DestroyGroupMessage.GroupContext Property (Microsoft.DirectX.DirectPlay)

DestroyGroupMessage.GroupContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupContext As Object
C# | public object GroupContext { get; }
C++ public:
property Object^ GroupContext {
Object^ get();
}
JScript | public function get GroupContext() : Object

Property Value

System.Object

This property is read-only.


DestroyGroupMessage.GroupID Property (Microsoft.DirectX.DirectPlay)

DestroyGroupMessage.GroupID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group deleted from the session. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
C++ public:
property int GroupID {
int get();
}
JScript | public function get GroupID() : int

Property Value

System.Int32

This property is read-only.


DestroyGroupMessage.Reason Property (Microsoft.DirectX.DirectPlay)

DestroyGroupMessage.Reason Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The following flag can be set to indicate why the player was destroyed. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Reason As DestroyGroupFlags
C# | public DestroyGroupFlags Reason { get; }
C++ public:
property DestroyGroupFlags Reason {
DestroyGroupFlags get();
}
JScript | public function get Reason() : DestroyGroupFlags

Property Value

Microsoft.DirectX.DirectPlay.DestroyGroupFlags

This property is read-only.


DestroyPlayerMessage Structure (Microsoft.DirectX.DirectPlay)

DestroyPlayerMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyPlayerDplay message when a player leaves a peer-to-peer or client/server session.The structure contains information for the DpnMsgidDestroyPlayerDplay system message. Deprecated.

Definition

Visual Basic | Public Structure DestroyPlayerMessage
C# | public struct DestroyPlayerMessage
C++ | public value class DestroyPlayerMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DestroyPlayerMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player deleted from the session. Deprecated.
Reason
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags indicating why the player was destroyed. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DestroyPlayerMessage.DestroyPlayerMessage() Constructor (Microsoft.DirectX.DirectPlay)

DestroyPlayerMessage.DestroyPlayerMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DestroyPlayerMessage();
C++ public:
DestroyPlayerMessage();
JScript | public function DestroyPlayerMessage();


DestroyPlayerMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

DestroyPlayerMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DestroyPlayerMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

DestroyPlayerMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


DestroyPlayerMessage.PlayerID Property (Microsoft.DirectX.DirectPlay)

DestroyPlayerMessage.PlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player deleted from the session. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
C++ public:
property int PlayerID {
int get();
}
JScript | public function get PlayerID() : int

Property Value

System.Int32

This property is read-only.


DestroyPlayerMessage.Reason Property (Microsoft.DirectX.DirectPlay)

DestroyPlayerMessage.Reason Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
One of the following flags indicating why the player was destroyed. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Reason As DestroyPlayerFlags
C# | public DestroyPlayerFlags Reason { get; }
C++ public:
property DestroyPlayerFlags Reason {
DestroyPlayerFlags get();
}
JScript | public function get Reason() : DestroyPlayerFlags

Property Value

Microsoft.DirectX.DirectPlay.DestroyPlayerFlags

This property is read-only.


DestroyThreadMessage Structure (Microsoft.DirectX.DirectPlay)

DestroyThreadMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidDestroyThreadDplay message when a thread is shut down.The structure contains information for the DpnMsgidDestroyThreadDplay system message. Deprecated.

Definition

Visual Basic | Public Structure DestroyThreadMessage
C# | public struct DestroyThreadMessage
C++ | public value class DestroyThreadMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
DestroyThreadMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Thread context value. Deprecated.
ProcessorNumber
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Processor Number this thread was created on. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DestroyThreadMessage.DestroyThreadMessage() Constructor (Microsoft.DirectX.DirectPlay)

DestroyThreadMessage.DestroyThreadMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public DestroyThreadMessage();
C++ public:
DestroyThreadMessage();
JScript | public function DestroyThreadMessage();


DestroyThreadMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

DestroyThreadMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DestroyThreadMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

DestroyThreadMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Thread context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


DestroyThreadMessage.ProcessorNumber Property (Microsoft.DirectX.DirectPlay)

DestroyThreadMessage.ProcessorNumber Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Processor Number this thread was created on. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ProcessorNumber As Integer
C# | public int ProcessorNumber { get; }
C++ public:
property int ProcessorNumber {
int get();
}
JScript | public function get ProcessorNumber() : int

Property Value

System.Int32

This property is read-only.


FindHostsQueryMessage Structure (Microsoft.DirectX.DirectPlay)

FindHostsQueryMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the FindHostQuery event. Deprecated.

Definition

Visual Basic | Public Structure FindHostsQueryMessage
C# | public struct FindHostsQueryMessage
C++ | public value class FindHostsQueryMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
FindHostsQueryMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetResponseData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response data from the enumeration. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AddressDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.
AddressSender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.
MaxResponseDataSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum allowed size for the enumeration response. Deprecated.
ReceivedData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Network packet that contains the received data. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostsQueryMessage.FindHostsQueryMessage() Constructor (Microsoft.DirectX.DirectPlay)

FindHostsQueryMessage.FindHostsQueryMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public FindHostsQueryMessage();
C++ public:
FindHostsQueryMessage();
JScript | public function FindHostsQueryMessage();


FindHostsQueryMessage.SetResponseData(NetworkPacket) Method (Microsoft.DirectX.DirectPlay)

FindHostsQueryMessage.SetResponseData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The response data from the enumeration. Deprecated.

Definition

Visual Basic Public Sub SetResponseData( _
ByVal data As NetworkPacket _
)
C# public void SetResponseData(
NetworkPacket data
);
C++ public:
void SetResponseData(
NetworkPacket^ data
);
JScript public function SetResponseData(
data : NetworkPacket
);

Parameters

data Microsoft.DirectX.DirectPlay.NetworkPacket


FindHostsQueryMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

FindHostsQueryMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FindHostsQueryMessage.AddressDevice Property (Microsoft.DirectX.DirectPlay)

FindHostsQueryMessage.AddressDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AddressDevice As Address
C# | public Address AddressDevice { get; }
C++ public:
property Address^ AddressDevice {
Address^ get();
}
JScript | public function get AddressDevice() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read-only.


FindHostsQueryMessage.AddressSender Property (Microsoft.DirectX.DirectPlay)

FindHostsQueryMessage.AddressSender Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AddressSender As Address
C# | public Address AddressSender { get; }
C++ public:
property Address^ AddressSender {
Address^ get();
}
JScript | public function get AddressSender() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read-only.


FindHostsQueryMessage.MaxResponseDataSize Property (Microsoft.DirectX.DirectPlay)

FindHostsQueryMessage.MaxResponseDataSize Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum allowed size for the enumeration response. Deprecated.

Definition

Visual Basic | Public ReadOnly Property MaxResponseDataSize As Integer
C# | public int MaxResponseDataSize { get; }
C++ public:
property int MaxResponseDataSize {
int get();
}
JScript | public function get MaxResponseDataSize() : int

Property Value

System.Int32

This property is read-only.


FindHostsQueryMessage.ReceivedData Property (Microsoft.DirectX.DirectPlay)

FindHostsQueryMessage.ReceivedData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Network packet that contains the received data. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ReceivedData As NetworkPacket
C# | public NetworkPacket ReceivedData { get; }
C++ public:
property NetworkPacket^ ReceivedData {
NetworkPacket^ get();
}
JScript | public function get ReceivedData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read-only.


FindHostsResponseMessage Structure (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® sends the DpnMsgidEnumHostsResponseDplay message to a peer or client's message handler to convey the host's response to an enumeration request.The structure contains information for the DpnMsgidEnumHostsResponseDplay system message. Deprecated.

Definition

Visual Basic | Public Structure FindHostsResponseMessage
C# | public struct FindHostsResponseMessage
C++ | public value class FindHostsResponseMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
FindHostsResponseMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AddressDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.
AddressSender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.
ApplicationDescription
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The application description. Deprecated.
ResponseData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a response context value. This value will be passed to the host's message handler with the DpnMsgidReturnBufferDplay message as the pvUserContext member of the associated structure. Deprecated.
RoundTripLatencyMs
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Latency measured in milliseconds. Deprecated.
UserContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the user context value. This value is the same as the user context value passed to Play8peerEnumhostsDplay or Play8clientEnumhostsDplay. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostsResponseMessage.FindHostsResponseMessage() Constructor (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage.FindHostsResponseMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public FindHostsResponseMessage();
C++ public:
FindHostsResponseMessage();
JScript | public function FindHostsResponseMessage();


FindHostsResponseMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


FindHostsResponseMessage.AddressDevice Property (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage.AddressDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AddressDevice As Address
C# | public Address AddressDevice { get; }
C++ public:
property Address^ AddressDevice {
Address^ get();
}
JScript | public function get AddressDevice() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read-only.


FindHostsResponseMessage.AddressSender Property (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage.AddressSender Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AddressSender As Address
C# | public Address AddressSender { get; }
C++ public:
property Address^ AddressSender {
Address^ get();
}
JScript | public function get AddressSender() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read-only.


FindHostsResponseMessage.ApplicationDescription Property (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage.ApplicationDescription Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The application description. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ApplicationDescription As ApplicationDescription
C# | public ApplicationDescription ApplicationDescription { get; }
C++ public:
property ApplicationDescription ApplicationDescription {
ApplicationDescription get();
}
JScript | public function get ApplicationDescription() : ApplicationDescription

Property Value

Microsoft.DirectX.DirectPlay.ApplicationDescription

This property is read-only.


FindHostsResponseMessage.ResponseData Property (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage.ResponseData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a response context value. This value will be passed to the host's message handler with the DpnMsgidReturnBufferDplay message as the pvUserContext member of the associated structure. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ResponseData As NetworkPacket
C# | public NetworkPacket ResponseData { get; }
C++ public:
property NetworkPacket^ ResponseData {
NetworkPacket^ get();
}
JScript | public function get ResponseData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read-only.


FindHostsResponseMessage.RoundTripLatencyMs Property (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage.RoundTripLatencyMs Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Latency measured in milliseconds. Deprecated.

Definition

Visual Basic | Public ReadOnly Property RoundTripLatencyMs As Integer
C# | public int RoundTripLatencyMs { get; }
C++ public:
property int RoundTripLatencyMs {
int get();
}
JScript | public function get RoundTripLatencyMs() : int

Property Value

System.Int32

This property is read-only.


FindHostsResponseMessage.UserContext Property (Microsoft.DirectX.DirectPlay)

FindHostsResponseMessage.UserContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the user context value. This value is the same as the user context value passed to Play8peerEnumhostsDplay or Play8clientEnumhostsDplay. Deprecated.

Definition

Visual Basic | Public ReadOnly Property UserContext As Object
C# | public object UserContext { get; }
C++ public:
property Object^ UserContext {
Object^ get();
}
JScript | public function get UserContext() : Object

Property Value

System.Object

This property is read-only.


GroupInformation Structure (Microsoft.DirectX.DirectPlay)

GroupInformation Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes static group information. Deprecated.

Definition

Visual Basic | Public Structure GroupInformation
C# | public struct GroupInformation
C++ | public value class GroupInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the group. Deprecated.
GroupInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the group. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupFlags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD that can be set to the following description flag. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type PWSTR specifying the Unicode name of the group. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupInformation.GetData() Method (Microsoft.DirectX.DirectPlay)

GroupInformation.GetData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the group. Deprecated.

Definition

Visual Basic | Public Function GetData() As Byte()
C# | public byte[] GetData();
C++ public:
array<unsigned char>^ GetData();
JScript | public function GetData() : byte[];

Return Value

System.Byte[]


GroupInformation.GroupInformation() Constructor (Microsoft.DirectX.DirectPlay)

GroupInformation.GroupInformation Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public GroupInformation();
C++ public:
GroupInformation();
JScript | public function GroupInformation();


GroupInformation.SetData(Byte[]) Method (Microsoft.DirectX.DirectPlay)

GroupInformation.SetData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the group. Deprecated.

Definition

Visual Basic Public Sub SetData( _
ByVal value() As Byte _
)
C# public void SetData(
byte[] value
);
C++ public:
void SetData(
array<unsigned char>^ value
);
JScript public function SetData(
value : byte[]
);

Parameters

value System.Byte[]


GroupInformation.ToString() Method (Microsoft.DirectX.DirectPlay)

GroupInformation.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


GroupInformation.GroupFlags Property (Microsoft.DirectX.DirectPlay)

GroupInformation.GroupFlags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Variable of type DWORD that can be set to the following description flag. Deprecated.

Definition

Visual Basic | Public Property GroupFlags As GroupFlags
C# | public GroupFlags GroupFlags { get; set; }
C++ public:
property GroupFlags GroupFlags {
GroupFlags get();
void set(GroupFlags value);
}
JScript public function get GroupFlags() : GroupFlags
public function set GroupFlags(GroupFlags);

Property Value

Microsoft.DirectX.DirectPlay.GroupFlags

This property is read/write.


GroupInformation.Name Property (Microsoft.DirectX.DirectPlay)

GroupInformation.Name Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type PWSTR specifying the Unicode name of the group. Deprecated.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String

This property is read/write.


GroupInformationMessage Structure (Microsoft.DirectX.DirectPlay)

GroupInformationMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.

Definition

Visual Basic | Public Structure GroupInformationMessage
C# | public struct GroupInformationMessage
C++ | public value class GroupInformationMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GroupInformationMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group for group information. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupInformationMessage.GroupInformationMessage() Constructor (Microsoft.DirectX.DirectPlay)

GroupInformationMessage.GroupInformationMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public GroupInformationMessage();
C++ public:
GroupInformationMessage();
JScript | public function GroupInformationMessage();


GroupInformationMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

GroupInformationMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


GroupInformationMessage.GroupContext Property (Microsoft.DirectX.DirectPlay)

GroupInformationMessage.GroupContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupContext As Object
C# | public object GroupContext { get; }
C++ public:
property Object^ GroupContext {
Object^ get();
}
JScript | public function get GroupContext() : Object

Property Value

System.Object

This property is read-only.


GroupInformationMessage.GroupID Property (Microsoft.DirectX.DirectPlay)

GroupInformationMessage.GroupID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group for group information. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
C++ public:
property int GroupID {
int get();
}
JScript | public function get GroupID() : int

Property Value

System.Int32

This property is read-only.


HostMigratedMessage Structure (Microsoft.DirectX.DirectPlay)

HostMigratedMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® Voice generates the DvmsgidHostmigratedDplay message when the voice host has migrated.The structure contains information for the DvmsgidHostmigratedDplay system message. Deprecated.

Definition

Visual Basic | Public Structure HostMigratedMessage
C# | public struct HostMigratedMessage
C++ | public value class HostMigratedMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
HostMigratedMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
NewHostID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the new host. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HostMigratedMessage.HostMigratedMessage() Constructor (Microsoft.DirectX.DirectPlay)

HostMigratedMessage.HostMigratedMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public HostMigratedMessage();
C++ public:
HostMigratedMessage();
JScript | public function HostMigratedMessage();


HostMigratedMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

HostMigratedMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


HostMigratedMessage.NewHostID Property (Microsoft.DirectX.DirectPlay)

HostMigratedMessage.NewHostID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DVID of the new host. Deprecated.

Definition

Visual Basic | Public ReadOnly Property NewHostID As Integer
C# | public int NewHostID { get; }
C++ public:
property int NewHostID {
int get();
}
JScript | public function get NewHostID() : int

Property Value

System.Int32

This property is read-only.


HostMigratedMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

HostMigratedMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


IndicateConnectMessage Structure (Microsoft.DirectX.DirectPlay)

IndicateConnectMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.

Definition

Visual Basic | Public Structure IndicateConnectMessage
C# | public struct IndicateConnectMessage
C++ | public value class IndicateConnectMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
IndicateConnectMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetReplyData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the data used to reply to this event. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AddressDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an Play8addressDplay object for the device receiving the connect attempt. You must call UnknownAddrefDxintro to increment the object's reference count. Call UnknownReleaseDxintro when you no longer need the object. Deprecated.
AddressPlayer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an Play8addressDplay object for the connecting player. You must call UnknownAddrefDxintro to increment the object's reference count. Call UnknownReleaseDxintro when you no longer need the object. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context preset. Deprecated.
UserConnectData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Data of the connecting player. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IndicateConnectMessage.IndicateConnectMessage() Constructor (Microsoft.DirectX.DirectPlay)

IndicateConnectMessage.IndicateConnectMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public IndicateConnectMessage();
C++ public:
IndicateConnectMessage();
JScript | public function IndicateConnectMessage();


IndicateConnectMessage.SetReplyData(NetworkPacket) Method (Microsoft.DirectX.DirectPlay)

IndicateConnectMessage.SetReplyData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Sets the data used to reply to this event. Deprecated.

Definition

Visual Basic Public Sub SetReplyData( _
ByVal data As NetworkPacket _
)
C# public void SetReplyData(
NetworkPacket data
);
C++ public:
void SetReplyData(
NetworkPacket^ data
);
JScript public function SetReplyData(
data : NetworkPacket
);

Parameters

data Microsoft.DirectX.DirectPlay.NetworkPacket


IndicateConnectMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

IndicateConnectMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


IndicateConnectMessage.AddressDevice Property (Microsoft.DirectX.DirectPlay)

IndicateConnectMessage.AddressDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an Play8addressDplay object for the device receiving the connect attempt. You must call UnknownAddrefDxintro to increment the object's reference count. Call UnknownReleaseDxintro when you no longer need the object. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AddressDevice As Address
C# | public Address AddressDevice { get; }
C++ public:
property Address^ AddressDevice {
Address^ get();
}
JScript | public function get AddressDevice() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read-only.


IndicateConnectMessage.AddressPlayer Property (Microsoft.DirectX.DirectPlay)

IndicateConnectMessage.AddressPlayer Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to an Play8addressDplay object for the connecting player. You must call UnknownAddrefDxintro to increment the object's reference count. Call UnknownReleaseDxintro when you no longer need the object. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AddressPlayer As Address
C# | public Address AddressPlayer { get; }
C++ public:
property Address^ AddressPlayer {
Address^ get();
}
JScript | public function get AddressPlayer() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read-only.


IndicateConnectMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

IndicateConnectMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context preset. Deprecated.

Definition

Visual Basic | Public Property PlayerContext As Object
C# | public object PlayerContext { get; set; }
C++ public:
property Object^ PlayerContext {
Object^ get();
void set(Object^ value);
}
JScript public function get PlayerContext() : Object
public function set PlayerContext(Object);

Property Value

System.Object

This property is read/write.


IndicateConnectMessage.UserConnectData Property (Microsoft.DirectX.DirectPlay)

IndicateConnectMessage.UserConnectData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Data of the connecting player. Deprecated.

Definition

Visual Basic | Public ReadOnly Property UserConnectData As NetworkPacket
C# | public NetworkPacket UserConnectData { get; }
C++ public:
property NetworkPacket^ UserConnectData {
NetworkPacket^ get();
}
JScript | public function get UserConnectData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read-only.


IndicatedConnectAbortedMessage Structure (Microsoft.DirectX.DirectPlay)

IndicatedConnectAbortedMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Definition

Visual Basic | Public Structure IndicatedConnectAbortedMessage
C# | public struct IndicatedConnectAbortedMessage
C++ | public value class IndicatedConnectAbortedMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
IndicatedConnectAbortedMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IndicatedConnectAbortedMessage.IndicatedConnectAbortedMessage() Constructor (Microsoft.DirectX.DirectPlay)

IndicatedConnectAbortedMessage.IndicatedConnectAbortedMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public IndicatedConnectAbortedMessage();
C++ public:
IndicatedConnectAbortedMessage();
JScript | public function IndicatedConnectAbortedMessage();


IndicatedConnectAbortedMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

IndicatedConnectAbortedMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


IndicatedConnectAbortedMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

IndicatedConnectAbortedMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


NatResolverQueryMessage Structure (Microsoft.DirectX.DirectPlay)

NatResolverQueryMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Contains data for the NatResolverQuery event. Deprecated.

Definition

Visual Basic | Public Structure NatResolverQueryMessage
C# | public struct NatResolverQueryMessage
C++ | public value class NatResolverQueryMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
NatResolverQueryMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AddressDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.
AddressSender
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.
UserString
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User specified string included in this query. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NatResolverQueryMessage.NatResolverQueryMessage() Constructor (Microsoft.DirectX.DirectPlay)

NatResolverQueryMessage.NatResolverQueryMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public NatResolverQueryMessage();
C++ public:
NatResolverQueryMessage();
JScript | public function NatResolverQueryMessage();


NatResolverQueryMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

NatResolverQueryMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


NatResolverQueryMessage.AddressDevice Property (Microsoft.DirectX.DirectPlay)

NatResolverQueryMessage.AddressDevice Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the device. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AddressDevice As Address
C# | public Address AddressDevice { get; }
C++ public:
property Address^ AddressDevice {
Address^ get();
}
JScript | public function get AddressDevice() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read-only.


NatResolverQueryMessage.AddressSender Property (Microsoft.DirectX.DirectPlay)

NatResolverQueryMessage.AddressSender Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Address object specifying the address of the sender. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AddressSender As Address
C# | public Address AddressSender { get; }
C++ public:
property Address^ AddressSender {
Address^ get();
}
JScript | public function get AddressSender() : Address

Property Value

Microsoft.DirectX.DirectPlay.Address

This property is read-only.


NatResolverQueryMessage.UserString Property (Microsoft.DirectX.DirectPlay)

NatResolverQueryMessage.UserString Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User specified string included in this query. Deprecated.

Definition

Visual Basic | Public ReadOnly Property UserString As String
C# | public string UserString { get; }
C++ public:
property String^ UserString {
String^ get();
}
JScript | public function get UserString() : String

Property Value

System.String

This property is read-only.


PeerInformationMessage Structure (Microsoft.DirectX.DirectPlay)

PeerInformationMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.

Definition

Visual Basic | Public Structure PeerInformationMessage
C# | public struct PeerInformationMessage
C++ | public value class PeerInformationMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
PeerInformationMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PeerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the peer for peer information. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PeerInformationMessage.PeerInformationMessage() Constructor (Microsoft.DirectX.DirectPlay)

PeerInformationMessage.PeerInformationMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PeerInformationMessage();
C++ public:
PeerInformationMessage();
JScript | public function PeerInformationMessage();


PeerInformationMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

PeerInformationMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PeerInformationMessage.PeerID Property (Microsoft.DirectX.DirectPlay)

PeerInformationMessage.PeerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the peer for peer information. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PeerID As Integer
C# | public int PeerID { get; }
C++ public:
property int PeerID {
int get();
}
JScript | public function get PeerID() : int

Property Value

System.Int32

This property is read-only.


PeerInformationMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

PeerInformationMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


PlayerInformation Structure (Microsoft.DirectX.DirectPlay)

PlayerInformation Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes static player information. Deprecated.

Definition

Visual Basic | Public Structure PlayerInformation
C# | public struct PlayerInformation
C++ | public value class PlayerInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
GetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the player. Deprecated.
PlayerInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
SetData
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the player. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Host
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this player is the host. Deprecated.
Local
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this player is local. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type PWSTR specifying the Unicode name of the player. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerInformation.GetData() Method (Microsoft.DirectX.DirectPlay)

PlayerInformation.GetData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the player. Deprecated.

Definition

Visual Basic | Public Function GetData() As Byte()
C# | public byte[] GetData();
C++ public:
array<unsigned char>^ GetData();
JScript | public function GetData() : byte[];

Return Value

System.Byte[]


PlayerInformation.PlayerInformation() Constructor (Microsoft.DirectX.DirectPlay)

PlayerInformation.PlayerInformation Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public PlayerInformation();
C++ public:
PlayerInformation();
JScript | public function PlayerInformation();


PlayerInformation.SetData(Byte[]) Method (Microsoft.DirectX.DirectPlay)

PlayerInformation.SetData Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the data describing the player. Deprecated.

Definition

Visual Basic Public Sub SetData( _
ByVal value() As Byte _
)
C# public void SetData(
byte[] value
);
C++ public:
void SetData(
array<unsigned char>^ value
);
JScript public function SetData(
value : byte[]
);

Parameters

value System.Byte[]


PlayerInformation.ToString() Method (Microsoft.DirectX.DirectPlay)

PlayerInformation.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


PlayerInformation.Host Property (Microsoft.DirectX.DirectPlay)

PlayerInformation.Host Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this player is the host. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Host As Boolean
C# | public bool Host { get; }
C++ public:
property bool Host {
bool get();
}
JScript | public function get Host() : boolean

Property Value

System.Boolean

This property is read-only.


PlayerInformation.Local Property (Microsoft.DirectX.DirectPlay)

PlayerInformation.Local Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this player is local. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Local As Boolean
C# | public bool Local { get; }
C++ public:
property bool Local {
bool get();
}
JScript | public function get Local() : boolean

Property Value

System.Boolean

This property is read-only.


PlayerInformation.Name Property (Microsoft.DirectX.DirectPlay)

PlayerInformation.Name Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to a variable of type PWSTR specifying the Unicode name of the player. Deprecated.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String

This property is read/write.


ReceiveMessage Structure (Microsoft.DirectX.DirectPlay)

ReceiveMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the message when the target receives a message sent by the or method.The structure contains information for the system message. Deprecated.

Definition

Visual Basic | Public Structure ReceiveMessage
C# | public struct ReceiveMessage
C++ | public value class ReceiveMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ReceiveMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Coalesced
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this messaged was coalesced. Deprecated.
Guaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was guaranteed. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value of the player that sent the message. Deprecated.
ReceiveData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the message data buffer. This buffer is normally only valid while the DpnMsgidReceiveDplay message is being processed by the callback message handler. Deprecated.
SenderID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle of the client that sent the message. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ReceiveMessage.ReceiveMessage() Constructor (Microsoft.DirectX.DirectPlay)

ReceiveMessage.ReceiveMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ReceiveMessage();
C++ public:
ReceiveMessage();
JScript | public function ReceiveMessage();


ReceiveMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

ReceiveMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ReceiveMessage.Coalesced Property (Microsoft.DirectX.DirectPlay)

ReceiveMessage.Coalesced Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this messaged was coalesced. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Coalesced As Boolean
C# | public bool Coalesced { get; }
C++ public:
property bool Coalesced {
bool get();
}
JScript | public function get Coalesced() : boolean

Property Value

System.Boolean

This property is read-only.


ReceiveMessage.Guaranteed Property (Microsoft.DirectX.DirectPlay)

ReceiveMessage.Guaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was guaranteed. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Guaranteed As Boolean
C# | public bool Guaranteed { get; }
C++ public:
property bool Guaranteed {
bool get();
}
JScript | public function get Guaranteed() : boolean

Property Value

System.Boolean

This property is read-only.


ReceiveMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

ReceiveMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value of the player that sent the message. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


ReceiveMessage.ReceiveData Property (Microsoft.DirectX.DirectPlay)

ReceiveMessage.ReceiveData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Pointer to the message data buffer. This buffer is normally only valid while the DpnMsgidReceiveDplay message is being processed by the callback message handler. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ReceiveData As NetworkPacket
C# | public NetworkPacket ReceiveData { get; }
C++ public:
property NetworkPacket^ ReceiveData {
NetworkPacket^ get();
}
JScript | public function get ReceiveData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read-only.


ReceiveMessage.SenderID Property (Microsoft.DirectX.DirectPlay)

ReceiveMessage.SenderID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Handle of the client that sent the message. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SenderID As Integer
C# | public int SenderID { get; }
C++ public:
property int SenderID {
int get();
}
JScript | public function get SenderID() : int

Property Value

System.Int32

This property is read-only.


RemovePlayerFromGroupMessage Structure (Microsoft.DirectX.DirectPlay)

RemovePlayerFromGroupMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidRemovePlayerFromGroupDplay message when a player has been deleted from a group in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidRemovePlayerFromGroupDplay system message. Deprecated.

Definition

Visual Basic | Public Structure RemovePlayerFromGroupMessage
C# | public struct RemovePlayerFromGroupMessage
C++ | public value class RemovePlayerFromGroupMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
RemovePlayerFromGroupMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
GroupContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.
GroupID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group that the player was deleted from. Deprecated.
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
PlayerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player deleted from the group. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


RemovePlayerFromGroupMessage.RemovePlayerFromGroupMessage() Constructor (Microsoft.DirectX.DirectPlay)

RemovePlayerFromGroupMessage.RemovePlayerFromGroupMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public RemovePlayerFromGroupMessage();
C++ public:
RemovePlayerFromGroupMessage();
JScript | public function RemovePlayerFromGroupMessage();


RemovePlayerFromGroupMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

RemovePlayerFromGroupMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


RemovePlayerFromGroupMessage.GroupContext Property (Microsoft.DirectX.DirectPlay)

RemovePlayerFromGroupMessage.GroupContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Group context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupContext As Object
C# | public object GroupContext { get; }
C++ public:
property Object^ GroupContext {
Object^ get();
}
JScript | public function get GroupContext() : Object

Property Value

System.Object

This property is read-only.


RemovePlayerFromGroupMessage.GroupID Property (Microsoft.DirectX.DirectPlay)

RemovePlayerFromGroupMessage.GroupID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the group that the player was deleted from. Deprecated.

Definition

Visual Basic | Public ReadOnly Property GroupID As Integer
C# | public int GroupID { get; }
C++ public:
property int GroupID {
int get();
}
JScript | public function get GroupID() : int

Property Value

System.Int32

This property is read-only.


RemovePlayerFromGroupMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

RemovePlayerFromGroupMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


RemovePlayerFromGroupMessage.PlayerID Property (Microsoft.DirectX.DirectPlay)

RemovePlayerFromGroupMessage.PlayerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the player deleted from the group. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerID As Integer
C# | public int PlayerID { get; }
C++ public:
property int PlayerID {
int get();
}
JScript | public function get PlayerID() : int

Property Value

System.Int32

This property is read-only.


SendCompleteMessage Structure (Microsoft.DirectX.DirectPlay)

SendCompleteMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidSendCompleteDplay message when an asynchronous send message request has completed.The structure contains information for the DpnMsgidSendCompleteDplay system message. Deprecated.

Definition

Visual Basic | Public Structure SendCompleteMessage
C# | public struct SendCompleteMessage
C++ | public value class SendCompleteMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
SendCompleteMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
AsyncOperationHandle
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.
Coalesced
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was coalesced. Deprecated.
FirstFrameRetryCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Time for the first frame in the message to travel round trip. Deprecated.
FirstFrameReturnTripTime
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Time for the first frame in the message to travel round trip. Deprecated.
Guaranteed
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was guaranteed. Deprecated.
ResultCode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT indicating the result of the send message request. Deprecated.
SendTime
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Total time, in milliseconds, between send call and completion. Deprecated.
UserContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User context supplied in the Play8clientSendDplay, Play8peerSendtoDplay and Play8serverSendtoDplay methods. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SendCompleteMessage.SendCompleteMessage() Constructor (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.SendCompleteMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public SendCompleteMessage();
C++ public:
SendCompleteMessage();
JScript | public function SendCompleteMessage();


SendCompleteMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


SendCompleteMessage.AsyncOperationHandle Property (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.AsyncOperationHandle Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Asynchronous operation handle. Deprecated.

Definition

Visual Basic | Public ReadOnly Property AsyncOperationHandle As Integer
C# | public int AsyncOperationHandle { get; }
C++ public:
property int AsyncOperationHandle {
int get();
}
JScript | public function get AsyncOperationHandle() : int

Property Value

System.Int32

This property is read-only.


SendCompleteMessage.Coalesced Property (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.Coalesced Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was coalesced. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Coalesced As Boolean
C# | public bool Coalesced { get; }
C++ public:
property bool Coalesced {
bool get();
}
JScript | public function get Coalesced() : boolean

Property Value

System.Boolean

This property is read-only.


SendCompleteMessage.FirstFrameRetryCount Property (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.FirstFrameRetryCount Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Time for the first frame in the message to travel round trip. Deprecated.

Definition

Visual Basic | Public ReadOnly Property FirstFrameRetryCount As Integer
C# | public int FirstFrameRetryCount { get; }
C++ public:
property int FirstFrameRetryCount {
int get();
}
JScript | public function get FirstFrameRetryCount() : int

Property Value

System.Int32

This property is read-only.


SendCompleteMessage.FirstFrameReturnTripTime Property (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.FirstFrameReturnTripTime Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Time for the first frame in the message to travel round trip. Deprecated.

Definition

Visual Basic | Public ReadOnly Property FirstFrameReturnTripTime As Integer
C# | public int FirstFrameReturnTripTime { get; }
C++ public:
property int FirstFrameReturnTripTime {
int get();
}
JScript | public function get FirstFrameReturnTripTime() : int

Property Value

System.Int32

This property is read-only.


SendCompleteMessage.Guaranteed Property (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.Guaranteed Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Gets a value indicating if this message was guaranteed. Deprecated.

Definition

Visual Basic | Public ReadOnly Property Guaranteed As Boolean
C# | public bool Guaranteed { get; }
C++ public:
property bool Guaranteed {
bool get();
}
JScript | public function get Guaranteed() : boolean

Property Value

System.Boolean

This property is read-only.


SendCompleteMessage.ResultCode Property (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.ResultCode Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
HRESULT indicating the result of the send message request. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ResultCode As ResultCode
C# | public ResultCode ResultCode { get; }
C++ public:
property ResultCode ResultCode {
ResultCode get();
}
JScript | public function get ResultCode() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode

This property is read-only.


SendCompleteMessage.SendTime Property (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.SendTime Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Total time, in milliseconds, between send call and completion. Deprecated.

Definition

Visual Basic | Public ReadOnly Property SendTime As Integer
C# | public int SendTime { get; }
C++ public:
property int SendTime {
int get();
}
JScript | public function get SendTime() : int

Property Value

System.Int32

This property is read-only.


SendCompleteMessage.UserContext Property (Microsoft.DirectX.DirectPlay)

SendCompleteMessage.UserContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
User context supplied in the Play8clientSendDplay, Play8peerSendtoDplay and Play8serverSendtoDplay methods. Deprecated.

Definition

Visual Basic | Public ReadOnly Property UserContext As Object
C# | public object UserContext { get; }
C++ public:
property Object^ UserContext {
Object^ get();
}
JScript | public function get UserContext() : Object

Property Value

System.Object

This property is read-only.


ServerInformationMessage Structure (Microsoft.DirectX.DirectPlay)

ServerInformationMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.

Definition

Visual Basic | Public Structure ServerInformationMessage
C# | public struct ServerInformationMessage
C++ | public value class ServerInformationMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServerInformationMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
PlayerContext
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.
ServerID
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the server for server information. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ServerInformationMessage.ServerInformationMessage() Constructor (Microsoft.DirectX.DirectPlay)

ServerInformationMessage.ServerInformationMessage Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ServerInformationMessage();
C++ public:
ServerInformationMessage();
JScript | public function ServerInformationMessage();


ServerInformationMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

ServerInformationMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ServerInformationMessage.PlayerContext Property (Microsoft.DirectX.DirectPlay)

ServerInformationMessage.PlayerContext Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Player context value. Deprecated.

Definition

Visual Basic | Public ReadOnly Property PlayerContext As Object
C# | public object PlayerContext { get; }
C++ public:
property Object^ PlayerContext {
Object^ get();
}
JScript | public function get PlayerContext() : Object

Property Value

System.Object

This property is read-only.


ServerInformationMessage.ServerID Property (Microsoft.DirectX.DirectPlay)

ServerInformationMessage.ServerID Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNID of the server for server information. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ServerID As Integer
C# | public int ServerID { get; }
C++ public:
property int ServerID {
int get();
}
JScript | public function get ServerID() : int

Property Value

System.Int32

This property is read-only.


ServiceProviderCaps Structure (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to set and retrieve parameters for service providers. Deprecated.

Definition

Visual Basic | Public Structure ServiceProviderCaps
C# | public struct ServiceProviderCaps
C++ | public value class ServiceProviderCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServiceProviderCaps
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
BuffersPerThread
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The number of outstanding receive buffers allocated for each DirectPlay thread. If you increase the number of receive buffers, DirectPlay can pull more data out of the operating system buffers. However, you can also increase latency if data is arriving faster than your application can process it. Deprecated.
DefaultCount
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default enumeration count. Deprecated.
DefaultEnumRetryInterval
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default retry interval, in milliseconds. Deprecated.
DefaultEnumTimeout
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default enumeration timeout value, in milliseconds. Deprecated.
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to determine various capabilities of the service provider. Deprecated.
MaxEnumPayloadSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum size of the payload information. Deprecated.
NumberThreads
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of threads the service provider will use for servicing network requests. The default value for this is based on an algorithm that takes into account the number of processors on the system. Most applications will not need to modify this value. Deprecated.
SystemBufferSize
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The size of the operating system buffer. This buffer holds data from the communications device when your application cannot process data as fast as it arrives. The purpose of this buffer is to prevent data loss if you receive a sudden burst of data, or if the receive threads are momentarily stalled. Increasing SystemBufferSize can increase latency if your application cannot process the received data fast enough. You can eliminate the operating system buffer by setting SystemBufferSize to 0. However, if you do so, you run the risk of losing data if you cannot process the received data as fast as it arrives. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ServiceProviderCaps.ServiceProviderCaps() Constructor (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.ServiceProviderCaps Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ServiceProviderCaps();
C++ public:
ServiceProviderCaps();
JScript | public function ServiceProviderCaps();


ServiceProviderCaps.ToString() Method (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ServiceProviderCaps.BuffersPerThread Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.BuffersPerThread Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The number of outstanding receive buffers allocated for each DirectPlay thread. If you increase the number of receive buffers, DirectPlay can pull more data out of the operating system buffers. However, you can also increase latency if data is arriving faster than your application can process it. Deprecated.

Definition

Visual Basic | Public Property BuffersPerThread As Integer
C# | public int BuffersPerThread { get; set; }
C++ public:
property int BuffersPerThread {
int get();
void set(int value);
}
JScript public function get BuffersPerThread() : int
public function set BuffersPerThread(int);

Property Value

System.Int32

This property is read/write.


ServiceProviderCaps.DefaultCount Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.DefaultCount Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default enumeration count. Deprecated.

Definition

Visual Basic | Public Property DefaultCount As Integer
C# | public int DefaultCount { get; set; }
C++ public:
property int DefaultCount {
int get();
void set(int value);
}
JScript public function get DefaultCount() : int
public function set DefaultCount(int);

Property Value

System.Int32

This property is read/write.


ServiceProviderCaps.DefaultEnumRetryInterval Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.DefaultEnumRetryInterval Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default retry interval, in milliseconds. Deprecated.

Definition

Visual Basic | Public Property DefaultEnumRetryInterval As Integer
C# | public int DefaultEnumRetryInterval { get; set; }
C++ public:
property int DefaultEnumRetryInterval {
int get();
void set(int value);
}
JScript public function get DefaultEnumRetryInterval() : int
public function set DefaultEnumRetryInterval(int);

Property Value

System.Int32

This property is read/write.


ServiceProviderCaps.DefaultEnumTimeout Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.DefaultEnumTimeout Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Default enumeration timeout value, in milliseconds. Deprecated.

Definition

Visual Basic | Public Property DefaultEnumTimeout As Integer
C# | public int DefaultEnumTimeout { get; set; }
C++ public:
property int DefaultEnumTimeout {
int get();
void set(int value);
}
JScript public function get DefaultEnumTimeout() : int
public function set DefaultEnumTimeout(int);

Property Value

System.Int32

This property is read/write.


ServiceProviderCaps.Flags Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used to determine various capabilities of the service provider. Deprecated.

Definition

Visual Basic | Public Property Flags As ServiceProviderCapsFlags
C# | public ServiceProviderCapsFlags Flags { get; set; }
C++ public:
property ServiceProviderCapsFlags Flags {
ServiceProviderCapsFlags get();
void set(ServiceProviderCapsFlags value);
}
JScript public function get Flags() : ServiceProviderCapsFlags
public function set Flags(ServiceProviderCapsFlags);

Property Value

Microsoft.DirectX.DirectPlay.ServiceProviderCapsFlags

This property is read/write.


ServiceProviderCaps.MaxEnumPayloadSize Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.MaxEnumPayloadSize Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Maximum size of the payload information. Deprecated.

Definition

Visual Basic | Public Property MaxEnumPayloadSize As Integer
C# | public int MaxEnumPayloadSize { get; set; }
C++ public:
property int MaxEnumPayloadSize {
int get();
void set(int value);
}
JScript public function get MaxEnumPayloadSize() : int
public function set MaxEnumPayloadSize(int);

Property Value

System.Int32

This property is read/write.


ServiceProviderCaps.NumberThreads Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.NumberThreads Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Number of threads the service provider will use for servicing network requests. The default value for this is based on an algorithm that takes into account the number of processors on the system. Most applications will not need to modify this value. Deprecated.

Definition

Visual Basic | Public Property NumberThreads As Integer
C# | public int NumberThreads { get; set; }
C++ public:
property int NumberThreads {
int get();
void set(int value);
}
JScript public function get NumberThreads() : int
public function set NumberThreads(int);

Property Value

System.Int32

This property is read/write.


ServiceProviderCaps.SystemBufferSize Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCaps.SystemBufferSize Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The size of the operating system buffer. This buffer holds data from the communications device when your application cannot process data as fast as it arrives. The purpose of this buffer is to prevent data loss if you receive a sudden burst of data, or if the receive threads are momentarily stalled. Increasing SystemBufferSize can increase latency if your application cannot process the received data fast enough. You can eliminate the operating system buffer by setting SystemBufferSize to 0. However, if you do so, you run the risk of losing data if you cannot process the received data as fast as it arrives. Deprecated.

Definition

Visual Basic | Public Property SystemBufferSize As Integer
C# | public int SystemBufferSize { get; set; }
C++ public:
property int SystemBufferSize {
int get();
void set(int value);
}
JScript public function get SystemBufferSize() : int
public function set SystemBufferSize(int);

Property Value

System.Int32

This property is read/write.


ServiceProviderCapsFlags Structure (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Enumerates all the registered service providers for the system, including those that are not available to the application or do not have devices installed. Deprecated.

Definition

Visual Basic | Public Structure ServiceProviderCapsFlags
C# | public struct ServiceProviderCapsFlags
C++ | public value class ServiceProviderCapsFlags sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServiceProviderCapsFlags
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
NetworkSimulator
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies that the service provider is the network simulator. Deprecated.
SupportsAllAdapters
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider will use all devices on the system. There is no need to specify a device element. Deprecated.
SupportsBroadcast
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
On IP and IPX applications, the service provider has the ability to broadcast to find games if not enough addressing information is passed. Deprecated.
SupportsDpnServer
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNSVR.EXE will provide port sharing for the given SP. Currently this flag is available on Internet Protocol (IP) and Internetwork Packet Exchange (IPX) only. Deprecated.
SupportsThreadPool
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider will support the thread pool. Deprecated.
Value
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bitwise or'd combination of flags. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ServiceProviderCapsFlags.ServiceProviderCapsFlags Constructor ()

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Overload List

public ServiceProviderCapsFlags();
public ServiceProviderCapsFlags(int);
public ServiceProviderCapsFlags(int[]);


ServiceProviderCapsFlags.ServiceProviderCapsFlags(Int32[]) Constructor (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.ServiceProviderCapsFlags Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal initCaps() As Integer _
)
C# public ServiceProviderCapsFlags(
int[] initCaps
);
C++ public:
ServiceProviderCapsFlags(
array<int>^ initCaps
);
JScript public function ServiceProviderCapsFlags(
initCaps : int[]
);

Parameters

initCaps System.Int32[]


ServiceProviderCapsFlags.ServiceProviderCapsFlags(Int32) Constructor (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.ServiceProviderCapsFlags Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic Public Sub New( _
ByVal initialCap As Integer _
)
C# public ServiceProviderCapsFlags(
int initialCap
);
C++ public:
ServiceProviderCapsFlags(
int initialCap
);
JScript public function ServiceProviderCapsFlags(
initialCap : int
);

Parameters

initialCap System.Int32


ServiceProviderCapsFlags.ServiceProviderCapsFlags() Constructor (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.ServiceProviderCapsFlags Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ServiceProviderCapsFlags();
C++ public:
ServiceProviderCapsFlags();
JScript | public function ServiceProviderCapsFlags();


ServiceProviderCapsFlags.ToString() Method (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ServiceProviderCapsFlags.NetworkSimulator Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.NetworkSimulator Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies that the service provider is the network simulator. Deprecated.

Definition

Visual Basic | Public Property NetworkSimulator As Boolean
C# | public bool NetworkSimulator { get; set; }
C++ public:
property bool NetworkSimulator {
bool get();
void set(bool value);
}
JScript public function get NetworkSimulator() : boolean
public function set NetworkSimulator(boolean);

Property Value

System.Boolean

This property is read/write.


ServiceProviderCapsFlags.SupportsAllAdapters Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.SupportsAllAdapters Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider will use all devices on the system. There is no need to specify a device element. Deprecated.

Definition

Visual Basic | Public Property SupportsAllAdapters As Boolean
C# | public bool SupportsAllAdapters { get; set; }
C++ public:
property bool SupportsAllAdapters {
bool get();
void set(bool value);
}
JScript public function get SupportsAllAdapters() : boolean
public function set SupportsAllAdapters(boolean);

Property Value

System.Boolean

This property is read/write.


ServiceProviderCapsFlags.SupportsBroadcast Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.SupportsBroadcast Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
On IP and IPX applications, the service provider has the ability to broadcast to find games if not enough addressing information is passed. Deprecated.

Definition

Visual Basic | Public Property SupportsBroadcast As Boolean
C# | public bool SupportsBroadcast { get; set; }
C++ public:
property bool SupportsBroadcast {
bool get();
void set(bool value);
}
JScript public function get SupportsBroadcast() : boolean
public function set SupportsBroadcast(boolean);

Property Value

System.Boolean

This property is read/write.


ServiceProviderCapsFlags.SupportsDpnServer Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.SupportsDpnServer Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
DPNSVR.EXE will provide port sharing for the given SP. Currently this flag is available on Internet Protocol (IP) and Internetwork Packet Exchange (IPX) only. Deprecated.

Definition

Visual Basic | Public Property SupportsDpnServer As Boolean
C# | public bool SupportsDpnServer { get; set; }
C++ public:
property bool SupportsDpnServer {
bool get();
void set(bool value);
}
JScript public function get SupportsDpnServer() : boolean
public function set SupportsDpnServer(boolean);

Property Value

System.Boolean

This property is read/write.


ServiceProviderCapsFlags.SupportsThreadPool Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.SupportsThreadPool Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
The service provider will support the thread pool. Deprecated.

Definition

Visual Basic | Public Property SupportsThreadPool As Boolean
C# | public bool SupportsThreadPool { get; set; }
C++ public:
property bool SupportsThreadPool {
bool get();
void set(bool value);
}
JScript public function get SupportsThreadPool() : boolean
public function set SupportsThreadPool(boolean);

Property Value

System.Boolean

This property is read/write.


ServiceProviderCapsFlags.Value Property (Microsoft.DirectX.DirectPlay)

ServiceProviderCapsFlags.Value Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Bitwise or'd combination of flags. Deprecated.

Definition

Visual Basic | Public Property Value As Integer
C# | public int Value { get; set; }
C++ public:
property int Value {
int get();
void set(int value);
}
JScript public function get Value() : int
public function set Value(int);

Property Value

System.Int32

This property is read/write.


ServiceProviderInformation Structure (Microsoft.DirectX.DirectPlay)

ServiceProviderInformation Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Used when enumerating information for a specific service provider. Deprecated.

Definition

Visual Basic | Public Structure ServiceProviderInformation
C# | public struct ServiceProviderInformation
C++ | public value class ServiceProviderInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServiceProviderInformation
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
Flags
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.
Guid
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID for the service provider. Deprecated.
Name
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the service provider. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ServiceProviderInformation.ServiceProviderInformation() Constructor (Microsoft.DirectX.DirectPlay)

ServiceProviderInformation.ServiceProviderInformation Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ServiceProviderInformation();
C++ public:
ServiceProviderInformation();
JScript | public function ServiceProviderInformation();


ServiceProviderInformation.ToString() Method (Microsoft.DirectX.DirectPlay)

ServiceProviderInformation.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ServiceProviderInformation.Flags Property (Microsoft.DirectX.DirectPlay)

ServiceProviderInformation.Flags Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic | Public Property Flags As ServiceProviderInformationFlags
C# | public ServiceProviderInformationFlags Flags { get; set; }
C++ public:
property ServiceProviderInformationFlags Flags {
ServiceProviderInformationFlags get();
void set(ServiceProviderInformationFlags value);
}
JScript public function get Flags() : ServiceProviderInformationFlags
public function set Flags(ServiceProviderInformationFlags);

Property Value

Microsoft.DirectX.DirectPlay.ServiceProviderInformationFlags

This property is read/write.


ServiceProviderInformation.Guid Property (Microsoft.DirectX.DirectPlay)

ServiceProviderInformation.Guid Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
GUID for the service provider. Deprecated.

Definition

Visual Basic | Public Property Guid As Guid
C# | public Guid Guid { get; set; }
C++ public:
property Guid Guid {
Guid get();
void set(Guid value);
}
JScript public function get Guid() : Guid
public function set Guid(Guid);

Property Value

System.Guid

This property is read/write.


ServiceProviderInformation.Name Property (Microsoft.DirectX.DirectPlay)

ServiceProviderInformation.Name Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Name of the service provider. Deprecated.

Definition

Visual Basic | Public Property Name As String
C# | public string Name { get; set; }
C++ public:
property String^ Name {
String^ get();
void set(String^ value);
}
JScript public function get Name() : String
public function set Name(String);

Property Value

System.String

This property is read/write.


ServiceProviderInformationFlags Structure (Microsoft.DirectX.DirectPlay)

ServiceProviderInformationFlags Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Describes the service provider. Deprecated.

Definition

Visual Basic | Public Structure ServiceProviderInformationFlags
C# | public struct ServiceProviderInformationFlags
C++ | public value class ServiceProviderInformationFlags sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
ServiceProviderInformationFlags
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
NetworkSimulatorDevice
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Device is available to the network simulator service provider. Deprecated.
Value
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ServiceProviderInformationFlags.ServiceProviderInformationFlags() Constructor (Microsoft.DirectX.DirectPlay)

ServiceProviderInformationFlags.ServiceProviderInformationFlags Constructor

 Language:

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public ServiceProviderInformationFlags();
C++ public:
ServiceProviderInformationFlags();
JScript | public function ServiceProviderInformationFlags();


ServiceProviderInformationFlags.ToString() Method (Microsoft.DirectX.DirectPlay)

ServiceProviderInformationFlags.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


ServiceProviderInformationFlags.NetworkSimulatorDevice Property (Microsoft.DirectX.DirectPlay)

ServiceProviderInformationFlags.NetworkSimulatorDevice Property

Language:

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Device is available to the network simulator service provider. Deprecated.

Definition

Visual Basic | Public Property NetworkSimulatorDevice As Boolean
C# | public bool NetworkSimulatorDevice { get; set; }
C++ public:
property bool NetworkSimulatorDevice {
bool get();
void set(bool value);
}
JScript public function get NetworkSimulatorDevice() : boolean
public function set NetworkSimulatorDevice(boolean);

Property Value

System.Boolean

This property is read/write.


ServiceProviderInformationFlags.Value Property (Microsoft.DirectX.DirectPlay)

ServiceProviderInformationFlags.Value Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Reserved. Must be 0. Deprecated.

Definition

Visual Basic | Public Property Value As Integer
C# | public int Value { get; set; }
C++ public:
property int Value {
int get();
void set(int value);
}
JScript public function get Value() : int
public function set Value(int);

Property Value

System.Int32

This property is read/write.


TerminateSessionMessage Structure (Microsoft.DirectX.DirectPlay)

TerminateSessionMessage Structure

Warning: This struct is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidTerminateSessionDplay message when a session is terminated by the host.The structure contains information for the DpnMsgidTerminateSessionDplay system message. Deprecated.

Definition

Visual Basic | Public Structure TerminateSessionMessage
C# | public struct TerminateSessionMessage
C++ | public value class TerminateSessionMessage sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
TerminateSessionMessage
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.
ToString
Warning: This method is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Properties

Property Description
ResultCode
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies how the session was terminated. This member is set to DPNERR_HOSTTERMINATEDSESSION if the session was peer-to-peer, and the host called Play8peerTerminatesessionDplay. If the session was ended by the host calling Play8peerCloseDplay, or if the host stops responding, hResultCode is set to DPNERR_CONNECTIONLOST. Deprecated.
TerminateData
Warning: This property is deprecated. Deprecated components of DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Termination data. If hResultCode is set to DPNERR_HOSTTERMINATEDSESSION, pvTerminateData points to the data block that the host passed through the pvTerminateData parameter of Play8peerTerminatesessionDplay. Deprecated.

Structure Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


TerminateSessionMessage.TerminateSessionMessage() Constructor (Microsoft.DirectX.DirectPlay)

TerminateSessionMessage.TerminateSessionMessage Constructor

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Initializes a new instance of the object. Deprecated.

Definition

Visual Basic | Public Sub New()
C# | public TerminateSessionMessage();
C++ public:
TerminateSessionMessage();
JScript | public function TerminateSessionMessage();


TerminateSessionMessage.ToString() Method (Microsoft.DirectX.DirectPlay)

TerminateSessionMessage.ToString Method

Warning: This method is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Obtains a string representation of the current instance. Deprecated.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


TerminateSessionMessage.ResultCode Property (Microsoft.DirectX.DirectPlay)

TerminateSessionMessage.ResultCode Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Specifies how the session was terminated. This member is set to DPNERR_HOSTTERMINATEDSESSION if the session was peer-to-peer, and the host called Play8peerTerminatesessionDplay. If the session was ended by the host calling Play8peerCloseDplay, or if the host stops responding, hResultCode is set to DPNERR_CONNECTIONLOST. Deprecated.

Definition

Visual Basic | Public ReadOnly Property ResultCode As ResultCode
C# | public ResultCode ResultCode { get; }
C++ public:
property ResultCode ResultCode {
ResultCode get();
}
JScript | public function get ResultCode() : ResultCode

Property Value

Microsoft.DirectX.DirectPlay.ResultCode

This property is read-only.


TerminateSessionMessage.TerminateData Property (Microsoft.DirectX.DirectPlay)

TerminateSessionMessage.TerminateData Property

Warning: This property is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Termination data. If hResultCode is set to DPNERR_HOSTTERMINATEDSESSION, pvTerminateData points to the data block that the host passed through the pvTerminateData parameter of Play8peerTerminatesessionDplay. Deprecated.

Definition

Visual Basic | Public ReadOnly Property TerminateData As NetworkPacket
C# | public NetworkPacket TerminateData { get; }
C++ public:
property NetworkPacket^ TerminateData {
NetworkPacket^ get();
}
JScript | public function get TerminateData() : NetworkPacket

Property Value

Microsoft.DirectX.DirectPlay.NetworkPacket

This property is read-only.


ApplicationDescriptionEventHandler(Object,EventArgs) Delegate (Microsoft.DirectX.DirectPlay)

ApplicationDescriptionEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
This message indicates that the application description has been changed. There is no accompanying structure. Deprecated.

Definition

Visual Basic Public Delegate Sub ApplicationDescriptionEventHandler( _
ByVal sender As Object, _
ByVal e As EventArgs _
)
C# public delegate void ApplicationDescriptionEventHandler(
object sender,
EventArgs e
);
C++ public delegate void ApplicationDescriptionEventHandler(
Object^ sender,
EventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e System.EventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AsyncOperationCompleteEventHandler(Object,AsyncOperationCompleteEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

AsyncOperationCompleteEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the AsyncOperationComplete event. Deprecated.

Definition

Visual Basic Public Delegate Sub AsyncOperationCompleteEventHandler( _
ByVal sender As Object, _
ByVal e As AsyncOperationCompleteEventArgs _
)
C# public delegate void AsyncOperationCompleteEventHandler(
object sender,
AsyncOperationCompleteEventArgs e
);
C++ public delegate void AsyncOperationCompleteEventHandler(
Object^ sender,
AsyncOperationCompleteEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.AsyncOperationCompleteEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ClientInformationEventHandler(Object,ClientInformationEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

ClientInformationEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidClientInfoDplay message when client data is modified during a client/server session.The structure contains information for the DpnMsgidClientInfoDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub ClientInformationEventHandler( _
ByVal sender As Object, _
ByVal e As ClientInformationEventArgs _
)
C# public delegate void ClientInformationEventHandler(
object sender,
ClientInformationEventArgs e
);
C++ public delegate void ClientInformationEventHandler(
Object^ sender,
ClientInformationEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.ClientInformationEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ConnectCompleteEventHandler(Object,ConnectCompleteEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

ConnectCompleteEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidConnectCompleteDplay message when the connection attempt has been completed in a peer-to-peer or client/server session.The structure contains information for the DpnMsgidConnectCompleteDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub ConnectCompleteEventHandler( _
ByVal sender As Object, _
ByVal e As ConnectCompleteEventArgs _
)
C# public delegate void ConnectCompleteEventHandler(
object sender,
ConnectCompleteEventArgs e
);
C++ public delegate void ConnectCompleteEventHandler(
Object^ sender,
ConnectCompleteEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.ConnectCompleteEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostQueryEventHandler(Object,FindHostQueryEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

FindHostQueryEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the FindHostQuery event. Deprecated.

Definition

Visual Basic Public Delegate Sub FindHostQueryEventHandler( _
ByVal sender As Object, _
ByVal e As FindHostQueryEventArgs _
)
C# public delegate void FindHostQueryEventHandler(
object sender,
FindHostQueryEventArgs e
);
C++ public delegate void FindHostQueryEventHandler(
Object^ sender,
FindHostQueryEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.FindHostQueryEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FindHostResponseEventHandler(Object,FindHostResponseEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

FindHostResponseEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the FindHostResponse event. Deprecated.

Definition

Visual Basic Public Delegate Sub FindHostResponseEventHandler( _
ByVal sender As Object, _
ByVal e As FindHostResponseEventArgs _
)
C# public delegate void FindHostResponseEventHandler(
object sender,
FindHostResponseEventArgs e
);
C++ public delegate void FindHostResponseEventHandler(
Object^ sender,
FindHostResponseEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.FindHostResponseEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupCreatedEventHandler(Object,GroupCreatedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

GroupCreatedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the GroupCreated event. Deprecated.

Definition

Visual Basic Public Delegate Sub GroupCreatedEventHandler( _
ByVal sender As Object, _
ByVal e As GroupCreatedEventArgs _
)
C# public delegate void GroupCreatedEventHandler(
object sender,
GroupCreatedEventArgs e
);
C++ public delegate void GroupCreatedEventHandler(
Object^ sender,
GroupCreatedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.GroupCreatedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupDestroyedEventHandler(Object,GroupDestroyedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

GroupDestroyedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the GroupDestroyed event. Deprecated.

Definition

Visual Basic Public Delegate Sub GroupDestroyedEventHandler( _
ByVal sender As Object, _
ByVal e As GroupDestroyedEventArgs _
)
C# public delegate void GroupDestroyedEventHandler(
object sender,
GroupDestroyedEventArgs e
);
C++ public delegate void GroupDestroyedEventHandler(
Object^ sender,
GroupDestroyedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.GroupDestroyedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GroupInformationEventHandler(Object,GroupInformationEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

GroupInformationEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidGroupInfoDplay message when group data is modified during a peer-to-peer or client/server session.The structure contains information for the DpnMsgidGroupInfoDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub GroupInformationEventHandler( _
ByVal sender As Object, _
ByVal e As GroupInformationEventArgs _
)
C# public delegate void GroupInformationEventHandler(
object sender,
GroupInformationEventArgs e
);
C++ public delegate void GroupInformationEventHandler(
Object^ sender,
GroupInformationEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.GroupInformationEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HostMigratedEventHandler(Object,HostMigratedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

HostMigratedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the HostMigrated event. Deprecated.

Definition

Visual Basic Public Delegate Sub HostMigratedEventHandler( _
ByVal sender As Object, _
ByVal e As HostMigratedEventArgs _
)
C# public delegate void HostMigratedEventHandler(
object sender,
HostMigratedEventArgs e
);
C++ public delegate void HostMigratedEventHandler(
Object^ sender,
HostMigratedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.HostMigratedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IndicateConnectEventHandler(Object,IndicateConnectEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

IndicateConnectEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicateConnectDplay message when a player attempts to connect to a peer-to-peer or client/server session.The structure contains information for the DpnMsgidIndicateConnectDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub IndicateConnectEventHandler( _
ByVal sender As Object, _
ByVal e As IndicateConnectEventArgs _
)
C# public delegate void IndicateConnectEventHandler(
object sender,
IndicateConnectEventArgs e
);
C++ public delegate void IndicateConnectEventHandler(
Object^ sender,
IndicateConnectEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.IndicateConnectEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IndicatedConnectAbortedEventHandler(Object,IndicatedConnectAbortedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

IndicatedConnectAbortedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidIndicatedConnectAbortedDplay message if a player's connection drops after it was indicated on the host, but prior to being added to the session though .The structure contains information for the DpnMsgidIndicatedConnectAbortedDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub IndicatedConnectAbortedEventHandler( _
ByVal sender As Object, _
ByVal e As IndicatedConnectAbortedEventArgs _
)
C# public delegate void IndicatedConnectAbortedEventHandler(
object sender,
IndicatedConnectAbortedEventArgs e
);
C++ public delegate void IndicatedConnectAbortedEventHandler(
Object^ sender,
IndicatedConnectAbortedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.IndicatedConnectAbortedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NatResolverQueryEventHandler(Object,NatResolverQueryEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

NatResolverQueryEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the NatResolverQuery event. Deprecated.

Definition

Visual Basic Public Delegate Sub NatResolverQueryEventHandler( _
ByVal sender As Object, _
ByVal e As NatResolverQueryEventArgs _
)
C# public delegate void NatResolverQueryEventHandler(
object sender,
NatResolverQueryEventArgs e
);
C++ public delegate void NatResolverQueryEventHandler(
Object^ sender,
NatResolverQueryEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.NatResolverQueryEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PeerInformationEventHandler(Object,PeerInformationEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

PeerInformationEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidPeerInfoDplay message when peer data is modified during a peer-to-peer session.The structure contains information for the DpnMsgidPeerInfoDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub PeerInformationEventHandler( _
ByVal sender As Object, _
ByVal e As PeerInformationEventArgs _
)
C# public delegate void PeerInformationEventHandler(
object sender,
PeerInformationEventArgs e
);
C++ public delegate void PeerInformationEventHandler(
Object^ sender,
PeerInformationEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.PeerInformationEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerAddedToGroupEventHandler(Object,PlayerAddedToGroupEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

PlayerAddedToGroupEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerAddedToGroup event. Deprecated.

Definition

Visual Basic Public Delegate Sub PlayerAddedToGroupEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerAddedToGroupEventArgs _
)
C# public delegate void PlayerAddedToGroupEventHandler(
object sender,
PlayerAddedToGroupEventArgs e
);
C++ public delegate void PlayerAddedToGroupEventHandler(
Object^ sender,
PlayerAddedToGroupEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.PlayerAddedToGroupEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerCreatedEventHandler(Object,PlayerCreatedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

PlayerCreatedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerCreated event. Deprecated.

Definition

Visual Basic Public Delegate Sub PlayerCreatedEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerCreatedEventArgs _
)
C# public delegate void PlayerCreatedEventHandler(
object sender,
PlayerCreatedEventArgs e
);
C++ public delegate void PlayerCreatedEventHandler(
Object^ sender,
PlayerCreatedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.PlayerCreatedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerDestroyedEventHandler(Object,PlayerDestroyedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

PlayerDestroyedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerDestroyed event. Deprecated.

Definition

Visual Basic Public Delegate Sub PlayerDestroyedEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerDestroyedEventArgs _
)
C# public delegate void PlayerDestroyedEventHandler(
object sender,
PlayerDestroyedEventArgs e
);
C++ public delegate void PlayerDestroyedEventHandler(
Object^ sender,
PlayerDestroyedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.PlayerDestroyedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PlayerRemovedFromGroupEventHandler(Object,PlayerRemovedFromGroupEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

PlayerRemovedFromGroupEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the PlayerRemovedFromGroup event. Deprecated.

Definition

Visual Basic Public Delegate Sub PlayerRemovedFromGroupEventHandler( _
ByVal sender As Object, _
ByVal e As PlayerRemovedFromGroupEventArgs _
)
C# public delegate void PlayerRemovedFromGroupEventHandler(
object sender,
PlayerRemovedFromGroupEventArgs e
);
C++ public delegate void PlayerRemovedFromGroupEventHandler(
Object^ sender,
PlayerRemovedFromGroupEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.PlayerRemovedFromGroupEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ReceiveEventHandler(Object,ReceiveEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

ReceiveEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the Receive event. Deprecated.

Definition

Visual Basic Public Delegate Sub ReceiveEventHandler( _
ByVal sender As Object, _
ByVal e As ReceiveEventArgs _
)
C# public delegate void ReceiveEventHandler(
object sender,
ReceiveEventArgs e
);
C++ public delegate void ReceiveEventHandler(
Object^ sender,
ReceiveEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.ReceiveEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SendCompleteEventHandler(Object,SendCompleteEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

SendCompleteEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SendComplete event. Deprecated.

Definition

Visual Basic Public Delegate Sub SendCompleteEventHandler( _
ByVal sender As Object, _
ByVal e As SendCompleteEventArgs _
)
C# public delegate void SendCompleteEventHandler(
object sender,
SendCompleteEventArgs e
);
C++ public delegate void SendCompleteEventHandler(
Object^ sender,
SendCompleteEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.SendCompleteEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ServerInformationEventHandler(Object,ServerInformationEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

ServerInformationEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Microsoft® DirectPlay® generates the DpnMsgidServerInfoDplay message when server data is modified during a client/server session.The structure contains information for the DpnMsgidServerInfoDplay system message. Deprecated.

Definition

Visual Basic Public Delegate Sub ServerInformationEventHandler( _
ByVal sender As Object, _
ByVal e As ServerInformationEventArgs _
)
C# public delegate void ServerInformationEventHandler(
object sender,
ServerInformationEventArgs e
);
C++ public delegate void ServerInformationEventHandler(
Object^ sender,
ServerInformationEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.ServerInformationEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SessionTerminatedEventHandler(Object,SessionTerminatedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

SessionTerminatedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the SessionTerminated event. Deprecated.

Definition

Visual Basic Public Delegate Sub SessionTerminatedEventHandler( _
ByVal sender As Object, _
ByVal e As SessionTerminatedEventArgs _
)
C# public delegate void SessionTerminatedEventHandler(
object sender,
SessionTerminatedEventArgs e
);
C++ public delegate void SessionTerminatedEventHandler(
Object^ sender,
SessionTerminatedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.SessionTerminatedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ThreadCreatedEventHandler(Object,ThreadCreatedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

ThreadCreatedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the ThreadCreated event. Deprecated.

Definition

Visual Basic Public Delegate Sub ThreadCreatedEventHandler( _
ByVal sender As Object, _
ByVal e As ThreadCreatedEventArgs _
)
C# public delegate void ThreadCreatedEventHandler(
object sender,
ThreadCreatedEventArgs e
);
C++ public delegate void ThreadCreatedEventHandler(
Object^ sender,
ThreadCreatedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.ThreadCreatedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ThreadDestroyedEventHandler(Object,ThreadDestroyedEventArgs) Delegate (Microsoft.DirectX.DirectPlay)

ThreadDestroyedEventHandler Delegate

Warning: This delegate is deprecated. Deprecated components of Microsoft DirectX 9.0 for Managed Code are considered obsolete. While these components are still supported in this release of DirectX 9.0 for Managed Code, they may be removed in the future. When writing new applications, you should avoid using these deprecated components. When modifying existing applications, you are strongly encouraged to remove any dependency on these components.
Represents the method that will handle the ThreadDestroyed event. Deprecated.

Definition

Visual Basic Public Delegate Sub ThreadDestroyedEventHandler( _
ByVal sender As Object, _
ByVal e As ThreadDestroyedEventArgs _
)
C# public delegate void ThreadDestroyedEventHandler(
object sender,
ThreadDestroyedEventArgs e
);
C++ public delegate void ThreadDestroyedEventHandler(
Object^ sender,
ThreadDestroyedEventArgs^ e
);
JScript In JScript, you can use delegates, but you cannot define your own.

Parameters

sender System.Object
e Microsoft.DirectX.DirectPlay.ThreadDestroyedEventArgs

Delegate Information

Namespace | Microsoft.DirectX.DirectPlay
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Microsoft.DirectX.DirectSound

Microsoft DirectSound provides a system to capture sounds from input devices and play sounds through various playback devices using advanced 3-D positioning effects, and filters for echo, distortion, reverberation, and other effects. The following tables list the members exposed by the Microsoft.DirectX.DirectSound namespace.

Classes

AccessDeniedException | The request failed because access was denied.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
BadFormatException | The specified wave format is not supported.
BadSendBufferGuidException | The globally unique identifier (GUID) specified in an audiopath file does not match a valid mix-in buffer.
Buffer | Contains methods and properties used to manage sound buffers.
Buffer3D | Contains methods and properties used to retrieve and set parameters that describe the position, orientation, and environment of a sound buffer in 3-D space.
BufferDescription | Contains properties and methods that describe the characteristics of a new buffer object.
BufferLostException | The buffer memory has been lost and must be restored.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
Capture | Contains properties and methods used to create sound capture buffers.
CaptureAcousticEchoCancellationEffect | Represents a DirectSound capture effects object used to set and retrieve parameters on a capture buffer that supports acoustic echo cancellation. This object requires Microsoft Windows XP or later.
CaptureBuffer | Contains properties and methods used to manipulate sound capture buffers.
CaptureDevicesCollection | Represents a collection of DeviceInformation structures for each available capture device.
CaptureNoiseSuppressEffect | Represents a DirectSound capture effects object used to set and retrieve parameters on a capture buffer that supports noise suppression. This object requires Microsoft Windows XP or later.
ChorusEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports chorus.
CompressorEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports compression.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
Device | Contains methods and properties used to create buffer objects, manage devices, and set up the environment.
DevicesCollection | Represents a collection of DeviceInformation structures for each available sound device.
DistortionEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports distortion.
DSoundHelper | Contains helper methods and fields for DirectSound.
EchoEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports echo.
EffectsUnavailableException | The effects requested could not be found on the system, or they are in the wrong order or in the wrong location; for example, an effect expected in hardware was found in software.
FlangerEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports flange.
FullDuplex | Represents a full-duplex stream.
GargleEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports amplitude modulation.
Interactive3DLevel2ReverbEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports Interactive 3-D Audio Level 2 (I3DL2) reverberation effects.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
Listener3D | Retrieves and sets parameters that describe a listener's position, orientation, and listening environment in 3-D space.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given GUID is not a valid DirectSound device ID.
Notify | Sets up notification events for a playback or capture buffer.
ObjectNotFoundException | The requested object was not found.
OtherApplicationHasPriorityException | Another application has a higher priority level, preventing this call from succeeding.
ParamEqEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports parametric equalizer effects.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.
SecondaryBuffer | Contains methods and properties used to manage sound buffers that can support effects.
SendLoopException | A circular loop of send effects was detected.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.
UnsupportedException | The function called is not supported at this time.
WavesReverbEffect | Represents a DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports Waves reverberation.

Enumerations

BufferDescriptionFlags | Contains constants for specifying the capabilities of sound buffers.
BufferPlayFlags | Contains constants for specifying the play behavior of the buffer.
BufferSize | Contains constants for the minimum and maximum buffer size.
CaptureEffectsReturnValue | Contains constants for a CaptureBuffer object's effects status.
CooperativeLevel | Contains constants for a Device object's cooperative level.
EffectsEnvironmentPreset | Containts constants for reverberation presets for an Interactive3DLevel2ReverbEffect object.
EffectsReturnValue | Contains constants that describe the status of an effect object returned from a SecondaryBuffer object.
EffectStatus | Contains constants that describe the success of the effect in canceling the echo using a CaptureAcousticEchoCancellationEffect object.
Frequency | Contains constants that describe the range of frequency, in samples per second, at which a software buffer can play.
LockFlag | Contains constants that describe how to lock a buffer while reading or writing to it.
Mode3D | Contains constents that describe the operation mode for 3-D sound processing.
OperationMode | Contains constants that describe the mode of a CaptureAcousticEchoCancellationEffect object.
Pan | Contains constants which describe how a buffer plays a sound in the stereo (2-channel) field.
PositionNotifyFlag | Contains constants that are used to signify types of position notifications.
Volume | Contains constants that describe the minimum and maximum volume at which a buffer can play.
WaveFormatTag | Contains constants that describe waveform-audio format types.

Structures

Angles | Contains properties that describe the inside and outside angles of the sound projection cone.
Buffer3DSettings | Contains properties that describe all the information necessary to uniquely describe the location, orientation, and motion of a 3-D sound buffer.
BufferCaps | Contains properties that describe the capabilities of a Buffer object or a SecondaryBuffer object.
BufferPositionNotify | Contains properties that describe a notification position.
BufferStatus | Contains properties that describe the status of a buffer.
Caps | Contains properties that describe the capabilities of a DirectSound Device object.
CaptureBufferCaps | Contains properties that describe the capabilities of a CaptureBuffer object.
CaptureBufferDescription | Contains properties that describe a CaptureBuffer object.
CaptureCaps | Contains properties that describes the capabilities of the capture device.
CaptureEffectDescription | Contains properties for an effect associated with a CaptureBuffer object.
CaptureEffectsAcousticEchoCancellation | Contains properties for acoustic echo cancellation in a capture buffer.
CaptureEffectsNoiseSuppress | Contains parameters for noise suppression in a capture buffer.
DeviceInformation | Contains properties that describe information about a device.
EffectDescription | Contains properties that describe an effect associated with a buffer.
EffectsChorus | Contains parameters for a chorus effect.
EffectsCompressor | Contains parameters for a compressor effect.
EffectsDistortion | Contains parameters for a distortion effect.
EffectsEcho | Contains parameters for an echo effect.
EffectsFlanger | Contains parameters for a flange effect.
EffectsGargle | Contains parameters for an amplitude modulation effect.
EffectsInteractive3DLevel2Reverb | Contains parameters for an I3DL2 (Interactive 3D Audio Level 2) reverberation effect.
EffectsParamEq | Contains parameters for a parametric equalizer effect.
EffectsWavesReverb | Contains parameters for a Waves reverberation effect.
Listener3DOrientation | Contains properties that encompass the front and top 3-D vectors for listeners orientation.
Listener3DSettings | Contains properties that describes the 3-D world parameters and the position of the listener.
Speakers | Contains properties that define various speaker configurations.
WaveFormat | Contains properties that define the format of waveform-audio data.


AccessDeniedException Class (Microsoft.DirectX.DirectSound)

AccessDeniedException Class

The request failed because access was denied.

Definition

Visual Basic Public Class AccessDeniedException
Inherits SoundException
C# | public class AccessDeniedException : SoundException
C++ | public ref class AccessDeniedException : SoundException
JScript | public class AccessDeniedException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AccessDeniedException | Initializes a new instance of the AccessDeniedException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
AccessDeniedException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AccessDeniedException.AccessDeniedException Constructor ()

Initializes a new instance of the AccessDeniedException class.

Overload List

public AccessDeniedException();
protected AccessDeniedException(SerializationInfo, StreamingContext);
public AccessDeniedException(string);
public AccessDeniedException(string, Exception);


AccessDeniedException.AccessDeniedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

AccessDeniedException.AccessDeniedException Constructor

Initializes a new instance of the AccessDeniedException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AccessDeniedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AccessDeniedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AccessDeniedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


AccessDeniedException.AccessDeniedException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

AccessDeniedException.AccessDeniedException Constructor

Initializes a new instance of the AccessDeniedException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AccessDeniedException(
string message,
Exception inner
);
C++ public:
AccessDeniedException(
String^ message,
Exception^ inner
);
JScript public function AccessDeniedException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


AccessDeniedException.AccessDeniedException(String) Constructor (Microsoft.DirectX.DirectSound)

AccessDeniedException.AccessDeniedException Constructor

Initializes a new instance of the AccessDeniedException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AccessDeniedException(
string message
);
C++ public:
AccessDeniedException(
String^ message
);
JScript public function AccessDeniedException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


AccessDeniedException.AccessDeniedException() Constructor (Microsoft.DirectX.DirectSound)

AccessDeniedException.AccessDeniedException Constructor

Initializes a new instance of the AccessDeniedException class.

Definition

Visual Basic | Public Sub New()
C# | public AccessDeniedException();
C++ public:
AccessDeniedException();
JScript | public function AccessDeniedException();


AllocatedException Class (Microsoft.DirectX.DirectSound)

AllocatedException Class

The request failed because resources, such as a priority level, were already in use by another caller.

Definition

Visual Basic Public Class AllocatedException
Inherits SoundException
C# | public class AllocatedException : SoundException
C++ | public ref class AllocatedException : SoundException
JScript | public class AllocatedException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
AllocatedException | Initializes a new instance of the AllocatedException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
AllocatedException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


AllocatedException.AllocatedException Constructor ()

Initializes a new instance of the AllocatedException class.

Overload List

public AllocatedException();
protected AllocatedException(SerializationInfo, StreamingContext);
public AllocatedException(string);
public AllocatedException(string, Exception);


AllocatedException.AllocatedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

AllocatedException.AllocatedException Constructor

Initializes a new instance of the AllocatedException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected AllocatedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
AllocatedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function AllocatedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


AllocatedException.AllocatedException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

AllocatedException.AllocatedException Constructor

Initializes a new instance of the AllocatedException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public AllocatedException(
string message,
Exception inner
);
C++ public:
AllocatedException(
String^ message,
Exception^ inner
);
JScript public function AllocatedException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


AllocatedException.AllocatedException(String) Constructor (Microsoft.DirectX.DirectSound)

AllocatedException.AllocatedException Constructor

Initializes a new instance of the AllocatedException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public AllocatedException(
string message
);
C++ public:
AllocatedException(
String^ message
);
JScript public function AllocatedException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


AllocatedException.AllocatedException() Constructor (Microsoft.DirectX.DirectSound)

AllocatedException.AllocatedException Constructor

Initializes a new instance of the AllocatedException class.

Definition

Visual Basic | Public Sub New()
C# | public AllocatedException();
C++ public:
AllocatedException();
JScript | public function AllocatedException();


BadFormatException Class (Microsoft.DirectX.DirectSound)

BadFormatException Class

The specified wave format is not supported.

Definition

Visual Basic Public Class BadFormatException
Inherits SoundException
C# | public class BadFormatException : SoundException
C++ | public ref class BadFormatException : SoundException
JScript | public class BadFormatException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BadFormatException | Initializes a new instance of the BadFormatException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
BadFormatException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BadFormatException.BadFormatException Constructor ()

Initializes a new instance of the BadFormatException class.

Overload List

public BadFormatException();
protected BadFormatException(SerializationInfo, StreamingContext);
public BadFormatException(string);
public BadFormatException(string, Exception);


BadFormatException.BadFormatException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

BadFormatException.BadFormatException Constructor

Initializes a new instance of the BadFormatException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BadFormatException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
BadFormatException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function BadFormatException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


BadFormatException.BadFormatException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

BadFormatException.BadFormatException Constructor

Initializes a new instance of the BadFormatException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BadFormatException(
string message,
Exception inner
);
C++ public:
BadFormatException(
String^ message,
Exception^ inner
);
JScript public function BadFormatException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


BadFormatException.BadFormatException(String) Constructor (Microsoft.DirectX.DirectSound)

BadFormatException.BadFormatException Constructor

Initializes a new instance of the BadFormatException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public BadFormatException(
string message
);
C++ public:
BadFormatException(
String^ message
);
JScript public function BadFormatException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


BadFormatException.BadFormatException() Constructor (Microsoft.DirectX.DirectSound)

BadFormatException.BadFormatException Constructor

Initializes a new instance of the BadFormatException class.

Definition

Visual Basic | Public Sub New()
C# | public BadFormatException();
C++ public:
BadFormatException();
JScript | public function BadFormatException();


BadSendBufferGuidException Class (Microsoft.DirectX.DirectSound)

BadSendBufferGuidException Class

The globally unique identifier (GUID) specified in an audiopath file does not match a valid mix-in buffer.

Definition

Visual Basic Public Class BadSendBufferGuidException
Inherits SoundException
C# | public class BadSendBufferGuidException : SoundException
C++ | public ref class BadSendBufferGuidException : SoundException
JScript | public class BadSendBufferGuidException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BadSendBufferGuidException | Initializes a new instance of the BadSendBufferGuidException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
BadSendBufferGuidException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BadSendBufferGuidException.BadSendBufferGuidException Constructor ()

Initializes a new instance of the BadSendBufferGuidException class.

Overload List

public BadSendBufferGuidException();
protected BadSendBufferGuidException(SerializationInfo, StreamingContext);
public BadSendBufferGuidException(string);
public BadSendBufferGuidException(string, Exception);


BadSendBufferGuidException.BadSendBufferGuidException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:

Initializes a new instance of the BadSendBufferGuidException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BadSendBufferGuidException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
BadSendBufferGuidException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function BadSendBufferGuidException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


BadSendBufferGuidException.BadSendBufferGuidException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:

Initializes a new instance of the BadSendBufferGuidException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BadSendBufferGuidException(
string message,
Exception inner
);
C++ public:
BadSendBufferGuidException(
String^ message,
Exception^ inner
);
JScript public function BadSendBufferGuidException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


BadSendBufferGuidException.BadSendBufferGuidException(String) Constructor (Microsoft.DirectX.DirectSound)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:

Initializes a new instance of the BadSendBufferGuidException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public BadSendBufferGuidException(
string message
);
C++ public:
BadSendBufferGuidException(
String^ message
);
JScript public function BadSendBufferGuidException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


BadSendBufferGuidException.BadSendBufferGuidException() Constructor (Microsoft.DirectX.DirectSound)

BadSendBufferGuidException.BadSendBufferGuidException Constructor

 Language:

Initializes a new instance of the BadSendBufferGuidException class.

Definition

Visual Basic | Public Sub New()
C# | public BadSendBufferGuidException();
C++ public:
BadSendBufferGuidException();
JScript | public function BadSendBufferGuidException();


Buffer Class (Microsoft.DirectX.DirectSound)

Buffer Class

Contains methods and properties used to manage sound buffers.

Definition

Visual Basic Public Class Buffer
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Buffer : MarshalByRefObject, IDisposable
C++ | public ref class Buffer : MarshalByRefObject, IDisposable
JScript | public class Buffer extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Buffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Buffer | Initializes a new instance of the Buffer class.
Clone | Duplicates the buffer object.
Dispose | Immediately releases the unmanaged resources used by the Buffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Buffer object to free resources before it is destroyed by the garbage collector.
GetCurrentPosition | Retrieves the position of the play and write cursors in the sound buffer.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Play | Begin playing the sound buffer, starting at the play cursor.
raise_Disposing | Raises the Buffer.Disposing event when called from within a derived class.
Read | Reads the current data in the buffer.
Restore | Restores the memory allocation for a lost sound buffer.
SetCurrentPosition | Sets the position of the play cursor, which is the point at which the next byte of data is read from the buffer.
Stop | Causes the sound buffer to stop playing.
Write | Writes data to the buffer.

Properties

Property | Description
Caps | Retrieves the capabilities of the buffer object.
Disposed | Gets a value that indicates whether the object is disposed.
Format | Retrieves or sets a description of the sound data format in the buffer.
Frequency | Retrieves or sets the frequency, in samples per second, at which the buffer is playing.
NotVirtualized | Retrieves a value that indicates whether the buffer is virtualized.
Pan | Retrieves or sets the relative volume of the left and right audio channels.
PlayPosition | Retrieves the position of the play cursor in the sound buffer.
Status | Retrieves the status of the sound buffer.
Volume | Retrieves or sets the attenuation of the sound.
WritePosition | Retrieves the position of the write cursor in the sound buffer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Buffer
SecondaryBuffer

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Buffer.Buffer Constructor ()

Initializes a new instance of the Buffer class.

Overload List

public Buffer(BufferDescription, Device);
public Buffer(IntPtr, Device);
public Buffer(Stream, BufferDescription, Device);
public Buffer(Stream, Device);
public Buffer(Stream, int, BufferDescription, Device);
public Buffer(Stream, int, Device);
public Buffer(string, BufferDescription, Device);
public Buffer(string, Device);

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(Stream,Int32,Device) Constructor (Microsoft.DirectX.DirectSound)

Buffer.Buffer Constructor

Initializes a new instance of the Buffer class.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer, _
ByVal parent As Device _
)
C# public Buffer(
Stream source,
int length,
Device parent
);
C++ public:
Buffer(
Stream^ source,
int length,
Device^ parent
);
JScript public function Buffer(
source : Stream,
length : int,
parent : Device
);

Parameters

source System.IO.Stream
A Stream Leave Site object that contains the source data for the buffer.
length System.Int32
An integer that represents the size of the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(Stream,Device) Constructor (Microsoft.DirectX.DirectSound)

Buffer.Buffer Constructor

Initializes a new instance of the Buffer class.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal parent As Device _
)
C# public Buffer(
Stream source,
Device parent
);
C++ public:
Buffer(
Stream^ source,
Device^ parent
);
JScript public function Buffer(
source : Stream,
parent : Device
);

Parameters

source System.IO.Stream
A Stream Leave Site object that contains the source data for the buffer.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(String,Device) Constructor (Microsoft.DirectX.DirectSound)

Buffer.Buffer Constructor

Initializes a new instance of the Buffer class.

Definition

Visual Basic Public Sub New( _
ByVal fileName As String, _
ByVal parent As Device _
)
C# public Buffer(
string fileName,
Device parent
);
C++ public:
Buffer(
String^ fileName,
Device^ parent
);
JScript public function Buffer(
fileName : String,
parent : Device
);

Parameters

fileName System.String
A String Leave Site that represents the file name of the file that contains source data for the buffer.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(Stream,BufferDescription,Device) Constructor (Microsoft.DirectX.DirectSound)

Buffer.Buffer Constructor

Initializes a new instance of the Buffer class.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public Buffer(
Stream source,
BufferDescription desc,
Device parent
);
C++ public:
Buffer(
Stream^ source,
BufferDescription^ desc,
Device^ parent
);
JScript public function Buffer(
source : Stream,
desc : BufferDescription,
parent : Device
);

Parameters

source System.IO.Stream
A Stream Leave Site object that contains the source data for the buffer.
desc Microsoft.DirectX.DirectSound.BufferDescription
A BufferDescription object that describes the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(Stream,Int32,BufferDescription,Device) Constructor (Microsoft.DirectX.DirectSound)

Buffer.Buffer Constructor

Initializes a new instance of the Buffer class.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public Buffer(
Stream source,
int length,
BufferDescription desc,
Device parent
);
C++ public:
Buffer(
Stream^ source,
int length,
BufferDescription^ desc,
Device^ parent
);
JScript public function Buffer(
source : Stream,
length : int,
desc : BufferDescription,
parent : Device
);

Parameters

source System.IO.Stream
A Stream Leave Site object that contains the source data for the buffer.
length System.Int32
An integer that represents the size of the buffer to create.
desc Microsoft.DirectX.DirectSound.BufferDescription
A BufferDescription object that describes the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(String,BufferDescription,Device) Constructor (Microsoft.DirectX.DirectSound)

Buffer.Buffer Constructor

Initializes a new instance of the Buffer class.

Definition

Visual Basic Public Sub New( _
ByVal fileName As String, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public Buffer(
string fileName,
BufferDescription desc,
Device parent
);
C++ public:
Buffer(
String^ fileName,
BufferDescription^ desc,
Device^ parent
);
JScript public function Buffer(
fileName : String,
desc : BufferDescription,
parent : Device
);

Parameters

fileName System.String
A String Leave Site that represents the file name of the file that contains source data for the buffer.
desc Microsoft.DirectX.DirectSound.BufferDescription
A BufferDescription object that describes the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(IntPtr,Device) Constructor (Microsoft.DirectX.DirectSound)

Buffer.Buffer Constructor

Initializes a new instance of the Buffer class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal parent As Device _
)
C# public Buffer(
IntPtr lp,
Device parent
);
C++ public:
Buffer(
IntPtr lp,
Device^ parent
);
JScript public function Buffer(
lp : IntPtr,
parent : Device
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundBuffer8, which allows unmanaged COM clients to create an instance of the managed buffer class. Not supported.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Buffer(BufferDescription,Device) Constructor (Microsoft.DirectX.DirectSound)

Buffer.Buffer Constructor

Initializes a new instance of the Buffer class.

Definition

Visual Basic Public Sub New( _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public Buffer(
BufferDescription desc,
Device parent
);
C++ public:
Buffer(
BufferDescription^ desc,
Device^ parent
);
JScript public function Buffer(
desc : BufferDescription,
parent : Device
);

Parameters

desc Microsoft.DirectX.DirectSound.BufferDescription
A BufferDescription object that describes the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, check the Buffer.NotVirtualized property to determine whether a requested 3-D algorithm was available and stereo panning was substituted.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with BufferCaps.LocateInHardware set to true on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending upon the operating system.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.


Buffer.Clone(Device) Method (Microsoft.DirectX.DirectSound)

Buffer.Clone Method

Duplicates the buffer object.

Definition

Visual Basic Public Function Clone( _
ByVal parent As Device _
) As Buffer
C# public Buffer Clone(
Device parent
);
C++ public:
Buffer^ Clone(
Device^ parent
);
JScript public function Clone(
parent : Device
) : Buffer;

Parameters

parent Microsoft.DirectX.DirectSound.Device
The Device object associated with the buffer.

Return Value

Microsoft.DirectX.DirectSound.Buffer
A Buffer object that represents the cloned buffer.

Remarks

This method is not valid for buffers created with BufferCaps.ControlEffects set to true.

Initially, the duplicate buffer will have the same parameters as the original buffer. However, the application can change the parameters of each buffer independently, and each can be played or stopped without affecting the other.

Exceptions
ArgumentNullException Leave Site | The parent parameter is null.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
InvalidCallException | The method call is invalid for the current state of this object.
ArgumentException Leave Site | An invalid parameter was passed to the method.

Applies To

SecondaryBuffer


Buffer.Dispose() Method (Microsoft.DirectX.DirectSound)

Buffer.Dispose Method

Immediately releases the unmanaged resources used by the Buffer object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Buffer();
JScript | public override function Dispose();

Applies To

SecondaryBuffer

See Also

  • Buffer.Disposed
  • Buffer.Disposing


Buffer.Equals(Object) Method (Microsoft.DirectX.DirectSound)

Buffer.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

SecondaryBuffer


Buffer.Finalize() Method (Microsoft.DirectX.DirectSound)

Buffer.Finalize Method

Allows the Buffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Buffer();
C++ | !Buffer();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.

Applies To

SecondaryBuffer


Buffer.GetCurrentPosition(Int32,Int32) Method (Microsoft.DirectX.DirectSound)

Buffer.GetCurrentPosition Method

Retrieves the position of the play and write cursors in the sound buffer.

Definition

Visual Basic Public Sub GetCurrentPosition( _
ByRef currentPlayPosition As Integer, _
ByRef currentWritePosition As Integer _
)
C# public void GetCurrentPosition(
out int currentPlayPosition,
out int currentWritePosition
);
C++ public:
void GetCurrentPosition(
[Out] int% currentPlayPosition,
[Out] int% currentWritePosition
);
JScript public function GetCurrentPosition(
currentPlayPosition : int,
currentWritePosition : int
);

Parameters

currentPlayPosition System.Int32
An integer that receives the offset, in bytes, of the play cursor position in the sound buffer.
currentWritePosition System.Int32
An integer that receives the offset, in bytes, of the write cursor position in the sound buffer.

Remarks

The write cursor is the point in the buffer ahead of which it is safe to write data to the buffer. Data should not be written to the part of the buffer after the play cursor and before the write cursor.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.GetHashCode() Method (Microsoft.DirectX.DirectSound)

Buffer.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Applies To

SecondaryBuffer


Buffer.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

Buffer.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundBuffer8, which allows unmanaged COM clients to create an instance of the managed Buffer class. Not supported.

Applies To

SecondaryBuffer


Buffer.op_Equality(Buffer,Buffer) Method (Microsoft.DirectX.DirectSound)

Buffer.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Buffer, _
ByVal right As Buffer _
) As Boolean
C# public static bool op_Equality(
Buffer left,
Buffer right
);
C++ public:
static bool operator==(
Buffer^ left,
Buffer^ right
);
JScript public static function op_Equality(
left : Buffer,
right : Buffer
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Buffer
The Buffer object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Buffer
The Buffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Applies To

SecondaryBuffer


Buffer.op_Inequality(Buffer,Buffer) Method (Microsoft.DirectX.DirectSound)

Buffer.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Buffer, _
ByVal right As Buffer _
) As Boolean
C# public static bool op_Inequality(
Buffer left,
Buffer right
);
C++ public:
static bool operator!=(
Buffer^ left,
Buffer^ right
);
JScript public static function op_Inequality(
left : Buffer,
right : Buffer
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Buffer
The Buffer object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Buffer
The Buffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Applies To

SecondaryBuffer


Buffer.Play(Int32,BufferPlayFlags) Method (Microsoft.DirectX.DirectSound)

Buffer.Play Method

Begin playing the sound buffer, starting at the play cursor.

Definition

Visual Basic Public Sub Play( _
ByVal priority As Integer, _
ByVal flags As BufferPlayFlags _
)
C# public void Play(
int priority,
BufferPlayFlags flags
);
C++ public:
void Play(
int priority,
BufferPlayFlags flags
);
JScript public function Play(
priority : int,
flags : BufferPlayFlags
);

Parameters

priority System.Int32
An integer that represents the Priority for the sound, used by the voice manager when assigning hardware mixing resources. The lowest priority is 0, and the highest priority is 0xFFFFFFFF. If the buffer was created with the BufferCaps.LocationDefer property set to false, this value must be 0.
flags Microsoft.DirectX.DirectSound.BufferPlayFlags
One or more BufferPlayFlags enumerated values.

Applies To

SecondaryBuffer


Buffer.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

Buffer.raise_Disposing Method

Raises the Buffer.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Applies To

SecondaryBuffer


Buffer.Read Method ()

Reads the current data in the buffer.

Overload List

public void Read(int, Stream, int, LockFlag);
public Array Read(int, Type, LockFlag, int[]);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


Buffer.Read(Int32,Type,LockFlag,Int32[]) Method (Microsoft.DirectX.DirectSound)

Buffer.Read Method

Reads the current data in the buffer.

Definition

Visual Basic Public Function Read( _
ByVal bufferStartingLocation As Integer, _
ByVal returnedDataType As Type, _
ByVal flag As LockFlag, _
ByVal ranks() As Integer _
) As Array
C# public Array Read(
int bufferStartingLocation,
Type returnedDataType,
LockFlag flag,
int[] ranks
);
C++ public:
Array^ Read(
int bufferStartingLocation,
Type^ returnedDataType,
LockFlag flag,
array<int>^ ranks
);
JScript public function Read(
bufferStartingLocation : int,
returnedDataType : Type,
flag : LockFlag,
ranks : int[]
) : Array;

Parameters

bufferStartingLocation System.Int32
An integer that represents the offet, in bytes, of where to begin reading from the buffer. This parameter is ignored if LockFlag.FromWriteCursor is specified in the flag parameter.
returnedDataType System.Type
Value that indicates the Type Leave Site of the returned array.
flag Microsoft.DirectX.DirectSound.LockFlag
A LockFlag enumerated value that describes the type of lock to perform.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site of type returnDataType that contains the data read from the buffer.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Read(Int32,Stream,Int32,LockFlag) Method (Microsoft.DirectX.DirectSound)

Buffer.Read Method

Reads the current data in the buffer.

Definition

Visual Basic Public Sub Read( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Stream, _
ByVal numberBytesToRead As Integer, _
ByVal flag As LockFlag _
)
C# public void Read(
int bufferStartingLocation,
Stream data,
int numberBytesToRead,
LockFlag flag
);
C++ public:
void Read(
int bufferStartingLocation,
Stream^ data,
int numberBytesToRead,
LockFlag flag
);
JScript public function Read(
bufferStartingLocation : int,
data : Stream,
numberBytesToRead : int,
flag : LockFlag
);

Parameters

bufferStartingLocation System.Int32
An integer that represents the offet, in bytes, of where to begin reading from the buffer. This parameter is ignored if LockFlag.FromWriteCursor is specified in the flag parameter.
data System.IO.Stream
A Stream Leave Site object that receives the data read from the buffer.
numberBytesToRead System.Int32
An integer that represents the number of bytes read into data from the buffer. The buffer is conceptually circular, so this number can exceed the number of bytes between bufferStartingLocation and the end of the buffer.
flag Microsoft.DirectX.DirectSound.LockFlag
A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Restore() Method (Microsoft.DirectX.DirectSound)

Buffer.Restore Method

Restores the memory allocation for a lost sound buffer.

Definition

Visual Basic | Public Sub Restore()
C# | public void Restore();
C++ public:
void Restore();
JScript | public function Restore();

Remarks

If the application does not have the input focus, Buffer.Restore might not succeed. For example, if the application with the input focus has the CooperativeLevel.WritePrimary cooperative level, no other application will be able to restore its buffers. Similarly, an application with the CooperativeLevel.WritePrimary cooperative level must have the input focus to restore its primary sound buffer.

After Microsoft DirectSound restores the buffer memory, the application must rewrite the buffer with valid sound data. DirectSound can only restore the memory itself, not the contents of the memory.

The application can receive notification that a buffer is lost when the following methods are called:

  • Buffer.Play
  • Buffer.Read
  • Buffer.Write

These methods throw BufferLostException to indicate a lost buffer. The Buffer.Status property can also be used to retrieve the status of the sound buffer and test the BufferStatus.BufferLost property.

Exceptions
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid for the current state of this object.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.SetCurrentPosition(Int32) Method (Microsoft.DirectX.DirectSound)

Buffer.SetCurrentPosition Method

Sets the position of the play cursor, which is the point at which the next byte of data is read from the buffer.

Definition

Visual Basic Public Sub SetCurrentPosition( _
ByVal newPosition As Integer _
)
C# public void SetCurrentPosition(
int newPosition
);
C++ public:
void SetCurrentPosition(
int newPosition
);
JScript public function SetCurrentPosition(
newPosition : int
);

Parameters

newPosition System.Int32
An integer that represents the offset of the play cursor, in bytes, from the beginning of the buffer.

Remarks

This method cannot be called on the primary sound buffer.

If the buffer is playing, the cursor immediately moves to the new position and play continues from that point. If it is not playing, playback will begin from the new position the next time the Buffer.Play method is called.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Stop() Method (Microsoft.DirectX.DirectSound)

Buffer.Stop Method

Causes the sound buffer to stop playing.

Definition

Visual Basic | Public Sub Stop()
C# | public void Stop();
C++ public:
void Stop();
JScript | public function Stop();

Remarks

For secondary sound buffers, Buffer.Stop sets the play cursor to the sample that follows the last sample played. This means that when the Buffer.Play method is next called on the buffer, it will continue playing where it left off.

For the primary buffer, if an application has the CooperativeLevel.WritePrimary level, this method will stop the buffer and reset the play cursor to 0 (the beginning of the buffer). This is necessary because the primary buffers on most sound cards can play only from the beginning of the buffer.

However, if Buffer.Stop is called on a primary buffer and the application has a cooperative level other than CooperativeLevel.WritePrimary, this method simply reverses the effects of Buffer.Play. It configures the primary buffer to stop if no secondary buffers are playing. If other buffers are playing in this or other applications, the primary buffer will not actually stop until they are stopped. This method is useful because playing the primary buffer consumes processing overhead even if the buffer is playing sound data with the amplitude of 0 decibels.

Exceptions
PriorityLevelNeededException A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Write Method ()

Writes data to the buffer.

Overload List

public void Write(int, Array, LockFlag);
public void Write(int, Stream, int, LockFlag);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


Buffer.Write(Int32,Array,LockFlag) Method (Microsoft.DirectX.DirectSound)

Buffer.Write Method

Writes data to the buffer.

Definition

Visual Basic Public Sub Write( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Array, _
ByVal flag As LockFlag _
)
C# public void Write(
int bufferStartingLocation,
Array data,
LockFlag flag
);
C++ public:
void Write(
int bufferStartingLocation,
Array^ data,
LockFlag flag
);
JScript public function Write(
bufferStartingLocation : int,
data : Array,
flag : LockFlag
);

Parameters

bufferStartingLocation System.Int32
An integer that represents the offet, in bytes, of where to begin writing into the buffer.
data System.Array
An Array Leave Site that contains the data to write into the buffer.
flag Microsoft.DirectX.DirectSound.LockFlag
A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Write(Int32,Stream,Int32,LockFlag) Method (Microsoft.DirectX.DirectSound)

Buffer.Write Method

Writes data to the buffer.

Definition

Visual Basic Public Sub Write( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Stream, _
ByVal numberBytesToWrite As Integer, _
ByVal flag As LockFlag _
)
C# public void Write(
int bufferStartingLocation,
Stream data,
int numberBytesToWrite,
LockFlag flag
);
C++ public:
void Write(
int bufferStartingLocation,
Stream^ data,
int numberBytesToWrite,
LockFlag flag
);
JScript public function Write(
bufferStartingLocation : int,
data : Stream,
numberBytesToWrite : int,
flag : LockFlag
);

Parameters

bufferStartingLocation System.Int32
An integer that represents the offet, in bytes, of where to begin writing into the buffer.
data System.IO.Stream
A Stream Leave Site object that contains the data to write into the buffer.
numberBytesToWrite System.Int32
An integer that represents the number of bytes to write into the buffer.
flag Microsoft.DirectX.DirectSound.LockFlag
A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.Caps Property (Microsoft.DirectX.DirectSound)

Buffer.Caps Property

Retrieves the capabilities of the buffer object.

Definition

Visual Basic | Public ReadOnly Property Caps As BufferCaps
C# | public BufferCaps Caps { get; }
C++ public:
property BufferCaps Caps {
BufferCaps get();
}
JScript | public function get Caps() : BufferCaps

Property Value

Microsoft.DirectX.DirectSound.BufferCaps
A BufferCaps object that describes the capabilities of the buffer.

This property is read-only.

Remarks

The BufferCaps structure contains similar information to the BufferDescription class passed to the Buffer constructor, with some additional information. This additional information can include the buffer's location, either in hardware or software, and performance measures.

The BufferCaps properties are the same properties used by the BufferDescription class. The only difference is that in the BufferCaps structure, either BufferCaps.LocateInHardware or BufferCaps.LocateInSoftware will be set to true according to the location of the buffer memory. In the BufferDescription class, setting the properties are optional and, depending on which property is set, force the buffer to be located in either hardware or software.

Applies To

SecondaryBuffer


Buffer.Disposed Property (Microsoft.DirectX.DirectSound)

Buffer.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Applies To

SecondaryBuffer


Buffer.Format Property (Microsoft.DirectX.DirectSound)

Buffer.Format Property

Retrieves or sets a description of the sound data format in the buffer.

Definition

Visual Basic | Public Property Format As WaveFormat
C# | public WaveFormat Format { get; set; }
C++ public:
property WaveFormat Format {
WaveFormat get();
void set(WaveFormat value);
}
JScript public function get Format() : WaveFormat
public function set Format(WaveFormat);

Property Value

Microsoft.DirectX.DirectSound.WaveFormat
A WaveFormat object that represents the current sound data format in the buffer or sound data format values to set.

This property is read/write.

Remarks

The Buffer.Format property sets the format of the primary buffer. Whenever this application has the input focus, Microsoft DirectSound will set the primary buffer to the specified format.

The format of the primary buffer should be set before secondary buffers are created.

Setting the property fails if the application has the CooperativeLevel.Normal cooperative level.

If the application is using DirectSound at the CooperativeLevel.WritePrimary cooperative level, the buffer must be stopped before Buffer.Format is called to set a new WaveFormat. If the format is not supported, the method fails.

If the cooperative level is CooperativeLevel.Priority, DirectSound stops the primary buffer, changes the format, and restarts the buffer. The method succeeds even if the hardware does not support the requested format; DirectSound sets the buffer to the closest supported format. To determine whether this has happened, an application can obtain the WaveFormat object using Buffer.Format property for the primary buffer and compare the result with the format that was set using Buffer.Format property.

This property is not available for secondary sound buffers. If a new format is required, the application must create a new Buffer object.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
BadFormatException | The specified wave format is not supported.
InvalidCallException | The method call is invalid for the current state of this object.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.
UnsupportedException | The function called is not supported at this time.

Applies To

SecondaryBuffer


Buffer.Frequency Property (Microsoft.DirectX.DirectSound)

Buffer.Frequency Property

Retrieves or sets the frequency, in samples per second, at which the buffer is playing.

Definition

Visual Basic | Public Property Frequency As Integer
C# | public int Frequency { get; set; }
C++ public:
property int Frequency {
int get();
void set(int value);
}
JScript public function get Frequency() : int
public function set Frequency(int);

Property Value

System.Int32
Value that represents the frequency, in hertz (Hz), to set or retrieve. A value of Frequency.Original resets the frequency to the default value of the buffer format.

This property is read/write.

Remarks

The frequency value for software buffers is in the range of Frequency.Min to Frequency.Max. Hardware buffers can return other values.

Increasing or decreasing the frequency changes the perceived pitch of the audio data. This property does not affect the format of the buffer.

Before setting the frequency, you should ascertain whether the frequency is supported by checking Caps.MinSecondarySampleRate and Caps.MaxSecondarySampleRate for the device. Some operating systems do not support frequencies greater than 100,000 Hz.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.NotVirtualized Property (Microsoft.DirectX.DirectSound)

Buffer.NotVirtualized Property

Retrieves a value that indicates whether the buffer is virtualized.

Definition

Visual Basic | Public ReadOnly Property NotVirtualized As Boolean
C# | public bool NotVirtualized { get; }
C++ public:
property bool NotVirtualized {
bool get();
}
JScript | public function get NotVirtualized() : boolean

Property Value

System.Boolean
Set to true if a requested 3-D algorithm was not available and stereo panning was substituted; otherwise, false.

This property is read-only.

Remarks

If a buffer is created using one of the head-related transfer function (HRTF) algorithms and the HRTF algorithm is not available on the system (for example, a non-WDM system), Buffer.NotVirtualized is set to true.

Applies To

SecondaryBuffer


Buffer.Pan Property (Microsoft.DirectX.DirectSound)

Buffer.Pan Property

Retrieves or sets the relative volume of the left and right audio channels.

Definition

Visual Basic | Public Property Pan As Integer
C# | public int Pan { get; set; }
C++ public:
property int Pan {
int get();
void set(int value);
}
JScript public function get Pan() : int
public function set Pan(int);

Property Value

System.Int32
Value that represents the relative volume between the left and right channels, to set or retrieve.

This property is read/write.

Remarks

The value set or retrieved is measured in hundredths of a decibel (dB), in the range of Pan.Left to Pan.Right. These values are defined as -10,000 and 10,000 respectively. The value Pan.Left means the right channel is effectively silent. The value Pan.Right means the left channel is effectively silent. The neutral value is Pan.Center, defined as 0, which means that both channels are at full volume. When one channel is attenuated, the other remains at full volume.

The pan control acts cumulatively with the volume control.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.PlayPosition Property (Microsoft.DirectX.DirectSound)

Buffer.PlayPosition Property

Retrieves the position of the play cursor in the sound buffer.

Definition

Visual Basic | Public ReadOnly Property PlayPosition As Integer
C# | public int PlayPosition { get; }
C++ public:
property int PlayPosition {
int get();
}
JScript | public function get PlayPosition() : int

Property Value

System.Int32
Value that represents the position of the play cursor.

This property is read-only.

Applies To

SecondaryBuffer

See Also

  • Buffer.GetCurrentPosition
  • Buffer.SetCurrentPosition


Buffer.Status Property (Microsoft.DirectX.DirectSound)

Buffer.Status Property

Retrieves the status of the sound buffer.

Definition

Visual Basic | Public ReadOnly Property Status As BufferStatus
C# | public BufferStatus Status { get; }
C++ public:
property BufferStatus Status {
BufferStatus get();
}
JScript | public function get Status() : BufferStatus

Property Value

Microsoft.DirectX.DirectSound.BufferStatus
A BufferStatus object that contains the status of the sound buffer.

This property is read-only.

Remarks

BufferStatus.Playing is set if the buffer is being heard. Because of latency, a call to Buffer.Play or Buffer.Stop might not immediately change the status.

Applies To

SecondaryBuffer


Buffer.Volume Property (Microsoft.DirectX.DirectSound)

Buffer.Volume Property

Retrieves or sets the attenuation of the sound.

Definition

Visual Basic | Public Property Volume As Integer
C# | public int Volume { get; set; }
C++ public:
property int Volume {
int get();
void set(int value);
}
JScript public function get Volume() : int
public function set Volume(int);

Property Value

System.Int32
Value that represents the attenuation, in hundredths of a decibel (dB).

This property is read/write.

Remarks

The return value is between Volume.Min and Volume.Max. These values are defined as 0 and -10,000, respectively. The value Volume.Max represents the original, unadjusted volume of the sound. The value Volume.Min indicates an audio volume attenuated by 100 dB, which, for practical purposes, is silence.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.

Applies To

SecondaryBuffer


Buffer.WritePosition Property (Microsoft.DirectX.DirectSound)

Buffer.WritePosition Property

Retrieves the position of the write cursor in the sound buffer.

Definition

Visual Basic | Public ReadOnly Property WritePosition As Integer
C# | public int WritePosition { get; }
C++ public:
property int WritePosition {
int get();
}
JScript | public function get WritePosition() : int

Property Value

System.Int32
Value that represents the position of the write cursor.

This property is read-only.

Applies To

SecondaryBuffer

See Also

  • Buffer.GetCurrentPosition
  • Buffer.SetCurrentPosition


Buffer.Disposing Event (Microsoft.DirectX.DirectSound)

Buffer.Disposing Event

Occurs when the Dispose method is called or when the Buffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Buffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Buffer object indicates whether that object has been disposed.

Applies To

SecondaryBuffer


Buffer3D Class (Microsoft.DirectX.DirectSound)

Buffer3D Class

Contains methods and properties used to retrieve and set parameters that describe the position, orientation, and environment of a sound buffer in 3-D space.

Definition

Visual Basic Public Class Buffer3D
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Buffer3D : MarshalByRefObject, IDisposable
C++ | public ref class Buffer3D : MarshalByRefObject, IDisposable
JScript | public class Buffer3D extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Buffer3D object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Buffer3D | Initializes a new instance of the Buffer3D class.
Dispose | Immediately releases the unmanaged resources used by the Buffer3D object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Buffer3D object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Buffer3D.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets the 3-D properties of the sound buffer.
ConeAngles | Retrieves or sets the inside and outside angles of the sound projection cone.
ConeOrientation | Retrieves or sets the orientation of the sound projection cone.
ConeOutsideVolume | Retrieves or sets the amount of attenuation to apply to the sound outside of the sound projection cone.
Deferred | Determines whether changes to the Buffer3D object are deferred or applied immediately.
Disposed | Gets a value that indicates whether the object is disposed.
MaxDistance | Retrieves or sets the maximum distance, from the listener, beyond which sounds in this buffer are no longer attenuated.
MinDistance | Retrieves or sets the minimum distance, from the listener, at which sounds in this buffer begin to be attenuated.
Mode | Retrieves or sets the operation mode for 3-D sound processing.
Position | Retrieves or sets the position of the sound source.
Velocity | Retrieves or sets the velocity of the sound source.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Buffer3D

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Buffer3D.Buffer3D Constructor ()

Initializes a new instance of the Buffer3D class.

Overload List

public Buffer3D(Buffer);
public Buffer3D(IntPtr, Buffer);
public Buffer3D(IntPtr, SecondaryBuffer);
public Buffer3D(SecondaryBuffer);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Buffer3D(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

Buffer3D.Buffer3D Constructor

Initializes a new instance of the Buffer3D class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal buff As SecondaryBuffer _
)
C# public Buffer3D(
IntPtr lp,
SecondaryBuffer buff
);
C++ public:
Buffer3D(
IntPtr lp,
SecondaryBuffer^ buff
);
JScript public function Buffer3D(
lp : IntPtr,
buff : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound3DBuffer8, which allows unmanaged COM clients to create an instance of the managed buffer class. Not supported.
buff Microsoft.DirectX.DirectSound.SecondaryBuffer
A SecondaryBuffer object to associate with a new instance of the Buffer3D.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Buffer3D(IntPtr,Buffer) Constructor (Microsoft.DirectX.DirectSound)

Buffer3D.Buffer3D Constructor

Initializes a new instance of the Buffer3D class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal buff As Buffer _
)
C# public Buffer3D(
IntPtr lp,
Buffer buff
);
C++ public:
Buffer3D(
IntPtr lp,
Buffer^ buff
);
JScript public function Buffer3D(
lp : IntPtr,
buff : Buffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound3DBuffer8, which allows unmanaged COM clients to create an instance of the managed buffer class. Not supported.
buff Microsoft.DirectX.DirectSound.Buffer
A Buffer object to associate with a new instance of the Buffer3D.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Buffer3D(SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

Buffer3D.Buffer3D Constructor

Initializes a new instance of the Buffer3D class.

Definition

Visual Basic Public Sub New( _
ByVal lp As SecondaryBuffer _
)
C# public Buffer3D(
SecondaryBuffer lp
);
C++ public:
Buffer3D(
SecondaryBuffer^ lp
);
JScript public function Buffer3D(
lp : SecondaryBuffer
);

Parameters

lp Microsoft.DirectX.DirectSound.SecondaryBuffer
A SecondaryBuffer object to associate with a new instance of the Buffer3D.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Buffer3D(Buffer) Constructor (Microsoft.DirectX.DirectSound)

Buffer3D.Buffer3D Constructor

Initializes a new instance of the Buffer3D class.

Definition

Visual Basic Public Sub New( _
ByVal lp As Buffer _
)
C# public Buffer3D(
Buffer lp
);
C++ public:
Buffer3D(
Buffer^ lp
);
JScript public function Buffer3D(
lp : Buffer
);

Parameters

lp Microsoft.DirectX.DirectSound.Buffer
A Buffer object to associate with a new instance of the Buffer3D.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.


Buffer3D.Dispose() Method (Microsoft.DirectX.DirectSound)

Buffer3D.Dispose Method

Immediately releases the unmanaged resources used by the Buffer3D object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Buffer3D();
JScript | public override function Dispose();

See Also

  • Buffer3D.Disposed
  • Buffer3D.Disposing


Buffer3D.Equals(Object) Method (Microsoft.DirectX.DirectSound)

Buffer3D.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Buffer3D.Finalize() Method (Microsoft.DirectX.DirectSound)

Buffer3D.Finalize Method

Allows the Buffer3D object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Buffer3D();
C++ | !Buffer3D();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Buffer3D.GetHashCode() Method (Microsoft.DirectX.DirectSound)

Buffer3D.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Buffer3D.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

Buffer3D.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound3DBuffer8, which allows unmanaged COM clients to create an instance of the managed Buffer3D class. Not supported.


Buffer3D.op_Equality(Buffer3D,Buffer3D) Method (Microsoft.DirectX.DirectSound)

Buffer3D.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Buffer3D, _
ByVal right As Buffer3D _
) As Boolean
C# public static bool op_Equality(
Buffer3D left,
Buffer3D right
);
C++ public:
static bool operator==(
Buffer3D^ left,
Buffer3D^ right
);
JScript public static function op_Equality(
left : Buffer3D,
right : Buffer3D
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Buffer3D
The Buffer3D object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Buffer3D
The Buffer3D object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Buffer3D.op_Inequality(Buffer3D,Buffer3D) Method (Microsoft.DirectX.DirectSound)

Buffer3D.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Buffer3D, _
ByVal right As Buffer3D _
) As Boolean
C# public static bool op_Inequality(
Buffer3D left,
Buffer3D right
);
C++ public:
static bool operator!=(
Buffer3D^ left,
Buffer3D^ right
);
JScript public static function op_Inequality(
left : Buffer3D,
right : Buffer3D
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Buffer3D
The Buffer3D object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Buffer3D
The Buffer3D object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Buffer3D.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

Buffer3D.raise_Disposing Method

Raises the Buffer3D.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Buffer3D.AllParameters Property (Microsoft.DirectX.DirectSound)

Buffer3D.AllParameters Property

Retrieves or sets the 3-D properties of the sound buffer.

Definition

Visual Basic | Public Property AllParameters As Buffer3DSettings
C# | public Buffer3DSettings AllParameters { get; set; }
C++ public:
property Buffer3DSettings AllParameters {
Buffer3DSettings get();
void set(Buffer3DSettings value);
}
JScript public function get AllParameters() : Buffer3DSettings
public function set AllParameters(Buffer3DSettings);

Property Value

Microsoft.DirectX.DirectSound.Buffer3DSettings
A Buffer3DSettings object that contains the information necessary to describe a 3-D sound buffer.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Buffer3D.ConeAngles Property (Microsoft.DirectX.DirectSound)

Buffer3D.ConeAngles Property

Retrieves or sets the inside and outside angles of the sound projection cone.

Definition

Visual Basic | Public Property ConeAngles As Angles
C# | public Angles ConeAngles { get; set; }
C++ public:
property Angles ConeAngles {
Angles get();
void set(Angles value);
}
JScript public function get ConeAngles() : Angles
public function set ConeAngles(Angles);

Property Value

Microsoft.DirectX.DirectSound.Angles
An Angles structure that contains the inside and outside angles to set or retrieve.

This property is read/write.

Remarks

The minimum, maximum, and default cone angles are defined as DSoundHelper.MinConeAngle, DSoundHelper.MaxConeAngle, and DSoundHelper.DefaultConeAngle.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Sound Cones in 3-D Buffers


Buffer3D.ConeOrientation Property (Microsoft.DirectX.DirectSound)

Buffer3D.ConeOrientation Property

Retrieves or sets the orientation of the sound projection cone.

Definition

Visual Basic | Public Property ConeOrientation As Vector3
C# | public Vector3 ConeOrientation { get; set; }
C++ public:
property Vector3 ConeOrientation {
Vector3 get();
void set(Vector3 value);
}
JScript public function get ConeOrientation() : Vector3
public function set ConeOrientation(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that specifies the coordinates of the sound cone orientation in 3-D space.

This property is read/write.

Remarks

This method has no effect unless the cone angle and cone outside volume also have been set to values other than the default.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Sound Cones in 3-D Buffers


Buffer3D.ConeOutsideVolume Property (Microsoft.DirectX.DirectSound)

Buffer3D.ConeOutsideVolume Property

Retrieves or sets the amount of attenuation to apply to the sound outside of the sound projection cone.

Definition

Visual Basic | Public Property ConeOutsideVolume As Integer
C# | public int ConeOutsideVolume { get; set; }
C++ public:
property int ConeOutsideVolume {
int get();
void set(int value);
}
JScript public function get ConeOutsideVolume() : int
public function set ConeOutsideVolume(int);

Property Value

System.Int32
Value that represents the attenuation, in hundredths of a decibel (dB).

This property is read/write.

Remarks

Volume levels are expressed as attenuation, in hundredths of a decibel. Allowable values are between Volume.Max (no attenuation) and Volume.Min (silence). The default value is DSoundHelper.DefaultConeOutsideVolume (no attenuation). Microsoft DirectSound does not support amplification.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Sound Cones in 3-D Buffers


Buffer3D.Deferred Property (Microsoft.DirectX.DirectSound)

Buffer3D.Deferred Property

Determines whether changes to the Buffer3D object are deferred or applied immediately.

Definition

Visual Basic | Public Property Deferred As Boolean
C# | public bool Deferred { get; set; }
C++ public:
property bool Deferred {
bool get();
void set(bool value);
}
JScript public function get Deferred() : boolean
public function set Deferred(boolean);

Property Value

System.Boolean
Set to true for deferred operations, or false to apply setting changes immediately.

This property is read/write.

Remarks

The default value is false. Settings are applied immediately, causing the system to recalculate the 3-D coordinates for all 3-D sound buffers.

Every change to 3-D sound buffer and listener settings causes remixing, at the expense of CPU cycles. To minimize the performance impact of changing 3-D settings, use deferred operations (set to true) to allow the application to change several settings and generate a single recalculation. To commit deferred operations, call Listener3D.CommitDeferredSettings.

See Also

  • Listener3D


Buffer3D.Disposed Property (Microsoft.DirectX.DirectSound)

Buffer3D.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Buffer3D.MaxDistance Property (Microsoft.DirectX.DirectSound)

Buffer3D.MaxDistance Property

Retrieves or sets the maximum distance, from the listener, beyond which sounds in this buffer are no longer attenuated.

Definition

Visual Basic | Public Property MaxDistance As Single
C# | public float MaxDistance { get; set; }
C++ public:
property float MaxDistance {
float get();
void set(float value);
}
JScript public function get MaxDistance() : float
public function set MaxDistance(float);

Property Value

System.Single
Maximum distance in meters to set or retrieve.

This property is read/write.

Remarks

The default maximum distance, defined as DSoundHelper.DefaultMaxDistance, is effectively infinite.

The default unit of measurement is meters, but this can be changed by using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Buffer3D.MinDistance


Buffer3D.MinDistance Property (Microsoft.DirectX.DirectSound)

Buffer3D.MinDistance Property

Retrieves or sets the minimum distance, from the listener, at which sounds in this buffer begin to be attenuated.

Definition

Visual Basic | Public Property MinDistance As Single
C# | public float MinDistance { get; set; }
C++ public:
property float MinDistance {
float get();
void set(float value);
}
JScript public function get MinDistance() : float
public function set MinDistance(float);

Property Value

System.Single
Minimum distance in meters to set or retrieve.

This property is read/write.

Remarks

The default minimum distance, DSoundHelper.DefaultMinDistance, is defined as 1.0 (corresponding to 1.0 meter at the default distance factor of 1.0 meters per unit).

The default unit of measurement is meters, but this can be changed by using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Buffer3D.MaxDistance


Buffer3D.Mode Property (Microsoft.DirectX.DirectSound)

Buffer3D.Mode Property

Retrieves or sets the operation mode for 3-D sound processing.

Definition

Visual Basic | Public Property Mode As Mode3D
C# | public Mode3D Mode { get; set; }
C++ public:
property Mode3D Mode {
Mode3D get();
void set(Mode3D value);
}
JScript public function get Mode() : Mode3D
public function set Mode(Mode3D);

Property Value

Microsoft.DirectX.DirectSound.Mode3D
Value of the Mode3D enumeration that represents the sound processing mode to set or retrieve.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Buffer3D.Position Property (Microsoft.DirectX.DirectSound)

Buffer3D.Position Property

Retrieves or sets the position of the sound source.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that specifies the coordinates of the sound source in 3-D space.

This property is read/write.

Remarks

The default unit of measurement is meters, but this can be changed by using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Buffer3D.Velocity Property (Microsoft.DirectX.DirectSound)

Buffer3D.Velocity Property

Retrieves or sets the velocity of the sound source.

Definition

Visual Basic | Public Property Velocity As Vector3
C# | public Vector3 Velocity { get; set; }
C++ public:
property Vector3 Velocity {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Velocity() : Vector3
public function set Velocity(Vector3);

Property Value

Microsoft.DirectX.Vector3
A Vector3 object that specifies the coordinates of the sound source's velocity vector, in meters per second by default.

This property is read/write.

Remarks

Velocity is used for Doppler effects only. It does not actually move the buffer.

The default unit of measurement is meters, but this can be changed by using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Buffer3D.Disposing Event (Microsoft.DirectX.DirectSound)

Buffer3D.Disposing Event

Occurs when the Dispose method is called or when the Buffer3D object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Buffer3D.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Buffer3D object indicates whether that object has been disposed.


BufferDescription Class (Microsoft.DirectX.DirectSound)

BufferDescription Class

Contains properties and methods that describe the characteristics of a new buffer object.

Definition

Visual Basic Public Class BufferDescription
Inherits MarshalByRefObject
Implements IDisposable
C# | public class BufferDescription : MarshalByRefObject, IDisposable
C++ | public ref class BufferDescription : MarshalByRefObject, IDisposable
JScript | public class BufferDescription extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BufferDescription | Initializes a new instance of the BufferDescription class.
Dispose | Immediately releases the unmanaged resources used by the BufferDescription object.
Finalize | Allows the BufferDescription object to free resources before it is destroyed by the garbage collector.

Properties

Property | Description
BufferBytes | Retrieves or sets the size of the new buffer.
CanGetCurrentPosition | Determines whether the application can get a more accurate play cursor.
Control3D | Determines whether the buffer has 3-D control capability.
ControlEffects | Specifies whether the buffer supports effects processing.
ControlFrequency | Specifies whether the buffer has frequency control capability.
ControlPan | Specifies whether the buffer has pan control capability.
ControlPositionNotify | Specifies whether the buffer has position notification capability.
ControlVolume | Specifies whether the buffer has volume control capability.
DeferLocation | Specifies whether the buffer can be assigned to a hardware or software resource at play time.
Flags | Retrieves or sets the capabilities of the buffer.
Format | Retrieves or sets the the waveform format for the buffer.
GlobalFocus | Specifies whether the buffer is a global sound buffer.
Guid3DAlgorithm | Retrieves or sets the unique identifier of the two-speaker virtualization algorithm to be used by DirectSound3D hardware emulation.
LocateInHardware | Specifies whether the buffer must use hardware mixing.
LocateInSoftware | Specifies whether the buffer must use software memory and use software mixing, even if BufferDescription.StaticBuffer is specified and hardware resources are available.
Mute3DAtMaximumDistance | Specifies whether the sound is reduced to silence at the maximum distance.
PrimaryBuffer | Specifies whether the buffer is a primary sound buffer.
StaticBuffer | Specifies whether the buffer is placed in on-board hardware memory, if available.
StickyFocus | Specifies whether the buffer has sticky focus.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
BufferDescription

Remarks

When creating a primary buffer, applications must set the BufferBytes member to zero. Microsoft DirectSound will determine the best buffer size for the particular sound device in use. To determine the size of a created primary buffer, check the BufferBytes property of the BufferCaps structure for the primary buffer.

On virtual device drivers (VxD), a sound buffer created with ControlPositionNotify is always a software buffer, because the VxD driver model does not support notifications. With Windows Driver Model (WDM) drivers, a notification-enabled buffer can be in hardware, if hardware resources are available.

The LocateInHardware and LocateInSoftware flags are optional and mutually exclusive. LocateInHardware forces the buffer to reside in hardware, meaning that it will be mixed by the sound card. LocateInSoftware forces the buffer to reside in software, where it is mixed by the CPU.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BufferDescription.BufferDescription Constructor ()

Initializes a new instance of the BufferDescription class.

Overload List

public BufferDescription();
public BufferDescription(WaveFormat);


BufferDescription.BufferDescription(WaveFormat) Constructor (Microsoft.DirectX.DirectSound)

BufferDescription.BufferDescription Constructor

Initializes a new instance of the BufferDescription class.

Definition

Visual Basic Public Sub New( _
ByVal wfx As WaveFormat _
)
C# public BufferDescription(
WaveFormat wfx
);
C++ public:
BufferDescription(
WaveFormat wfx
);
JScript public function BufferDescription(
wfx : WaveFormat
);

Parameters

wfx Microsoft.DirectX.DirectSound.WaveFormat
A WaveFormat object that defines the format of waveform-audio data.


BufferDescription.BufferDescription() Constructor (Microsoft.DirectX.DirectSound)

BufferDescription.BufferDescription Constructor

Initializes a new instance of the BufferDescription class.

Definition

Visual Basic | Public Sub New()
C# | public BufferDescription();
C++ public:
BufferDescription();
JScript | public function BufferDescription();


BufferDescription.Dispose() Method (Microsoft.DirectX.DirectSound)

BufferDescription.Dispose Method

Immediately releases the unmanaged resources used by the BufferDescription object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~BufferDescription();
JScript | public override function Dispose();


BufferDescription.Finalize() Method (Microsoft.DirectX.DirectSound)

BufferDescription.Finalize Method

Allows the BufferDescription object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~BufferDescription();
C++ | !BufferDescription();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


BufferDescription.BufferBytes Property (Microsoft.DirectX.DirectSound)

BufferDescription.BufferBytes Property

Retrieves or sets the size of the new buffer.

Definition

Visual Basic | Public Property BufferBytes As Integer
C# | public int BufferBytes { get; set; }
C++ public:
property int BufferBytes {
int get();
void set(int value);
}
JScript public function get BufferBytes() : int
public function set BufferBytes(int);

Property Value

System.Int32
Value that represents the size of the new buffer, in bytes, to set or retrieve.

This property is read/write.

Remarks

This value must be 0 when creating a buffer with BufferDescription.PrimaryBuffer set to true.


BufferDescription.CanGetCurrentPosition Property (Microsoft.DirectX.DirectSound)

BufferDescription.CanGetCurrentPosition Property

Determines whether the application can get a more accurate play cursor.

Definition

Visual Basic | Public Property CanGetCurrentPosition As Boolean
C# | public bool CanGetCurrentPosition { get; set; }
C++ public:
property bool CanGetCurrentPosition {
bool get();
void set(bool value);
}
JScript public function get CanGetCurrentPosition() : boolean
public function set CanGetCurrentPosition(boolean);

Property Value

System.Boolean
This value is set to true if the application can get a more accurate play cursor from the buffer; otherwise, false.

This property is read/write.

Remarks

The Buffer.GetCurrentPosition method uses the new behavior of the play cursor. In Microsoft DirectSound included with Microsoft DirectX 1, the play cursor was significantly ahead of the actual playing sound on emulated sound cards; it was directly behind the write cursor. Now, if CanGetCurrentPosition is set to true, the application can get a more accurate play cursor. If this property is set to false, the old behavior is preserved for compatibility.

CanGetCurrentPosition affects only emulated sound cards. If a DirectSound driver is present, the play cursor is accurate for DirectSound in all versions of DirectX.


BufferDescription.Control3D Property (Microsoft.DirectX.DirectSound)

BufferDescription.Control3D Property

Determines whether the buffer has 3-D control capability.

Definition

Visual Basic | Public Property Control3D As Boolean
C# | public bool Control3D { get; set; }
C++ public:
property bool Control3D {
bool get();
void set(bool value);
}
JScript public function get Control3D() : boolean
public function set Control3D(boolean);

Property Value

System.Boolean
This value is set to true if the buffer has 3-D control capability; otherwise, false.

This property is read/write.

Remarks

BufferDescription.Control3D cannot be combined with BufferDescription.ControlPan, and cannot be set for a buffer with a stereo format in WaveFormat.


BufferDescription.ControlEffects Property (Microsoft.DirectX.DirectSound)

BufferDescription.ControlEffects Property

Specifies whether the buffer supports effects processing.

Definition

Visual Basic | Public Property ControlEffects As Boolean
C# | public bool ControlEffects { get; set; }
C++ public:
property bool ControlEffects {
bool get();
void set(bool value);
}
JScript public function get ControlEffects() : boolean
public function set ControlEffects(boolean);

Property Value

System.Boolean
This value is set to true if the buffer supports effects processing; otherwise, false.

This property is read/write.

Remarks

The format in WaveFormat must be an 8-bit or 16-bit PCM format with no more than two channels, and the buffer must be large enough to hold at least BufferSize.EffectsMin milliseconds of data.


BufferDescription.ControlFrequency Property (Microsoft.DirectX.DirectSound)

BufferDescription.ControlFrequency Property

Specifies whether the buffer has frequency control capability.

Definition

Visual Basic | Public Property ControlFrequency As Boolean
C# | public bool ControlFrequency { get; set; }
C++ public:
property bool ControlFrequency {
bool get();
void set(bool value);
}
JScript public function get ControlFrequency() : boolean
public function set ControlFrequency(boolean);

Property Value

System.Boolean
This value is set to true if the buffer has frequency control capability; otherwise, false.

This property is read/write.


BufferDescription.ControlPan Property (Microsoft.DirectX.DirectSound)

BufferDescription.ControlPan Property

Specifies whether the buffer has pan control capability.

Definition

Visual Basic | Public Property ControlPan As Boolean
C# | public bool ControlPan { get; set; }
C++ public:
property bool ControlPan {
bool get();
void set(bool value);
}
JScript public function get ControlPan() : boolean
public function set ControlPan(boolean);

Property Value

System.Boolean
This value is set to true if the buffer has pan control capability; otherwise, false.

This property is read/write.

Remarks

BufferDescription.ControlPan cannot be combined with BufferDescription.Control3D.


BufferDescription.ControlPositionNotify Property (Microsoft.DirectX.DirectSound)

BufferDescription.ControlPositionNotify Property

Specifies whether the buffer has position notification capability.

Definition

Visual Basic | Public Property ControlPositionNotify As Boolean
C# | public bool ControlPositionNotify { get; set; }
C++ public:
property bool ControlPositionNotify {
bool get();
void set(bool value);
}
JScript public function get ControlPositionNotify() : boolean
public function set ControlPositionNotify(boolean);

Property Value

System.Boolean
This value is set to true if the buffer has position notification capability; otherwise, false.

This property is read/write.

Remarks

Because the virtual device driver model (VXD) does not support notifications, a sound buffer created with BufferDescription.ControlPositionNotify set to true is always a software buffer when using VXD drivers. With the Windows Driver Model (WDM), a notification-enabled buffer can be in hardware, if hardware resources are available.


BufferDescription.ControlVolume Property (Microsoft.DirectX.DirectSound)

BufferDescription.ControlVolume Property

Specifies whether the buffer has volume control capability.

Definition

Visual Basic | Public Property ControlVolume As Boolean
C# | public bool ControlVolume { get; set; }
C++ public:
property bool ControlVolume {
bool get();
void set(bool value);
}
JScript public function get ControlVolume() : boolean
public function set ControlVolume(boolean);

Property Value

System.Boolean
This value is set to true if the buffer has volume control capability; otherwise, false.

This property is read/write.


BufferDescription.DeferLocation Property (Microsoft.DirectX.DirectSound)

BufferDescription.DeferLocation Property

Specifies whether the buffer can be assigned to a hardware or software resource at play time.

Definition

Visual Basic | Public Property DeferLocation As Boolean
C# | public bool DeferLocation { get; set; }
C++ public:
property bool DeferLocation {
bool get();
void set(bool value);
}
JScript public function get DeferLocation() : boolean
public function set DeferLocation(boolean);

Property Value

System.Boolean
This value is set to true if if the buffer can be assigned to a hardware or software resource at play time; otherwise, false.

This property is read/write.

Remarks

Note: This property must be set for buffers that use voice management.


BufferDescription.Flags Property (Microsoft.DirectX.DirectSound)

BufferDescription.Flags Property

Retrieves or sets the capabilities of the buffer.

Definition

Visual Basic | Public Property Flags As BufferDescriptionFlags
C# | public BufferDescriptionFlags Flags { get; set; }
C++ public:
property BufferDescriptionFlags Flags {
BufferDescriptionFlags get();
void set(BufferDescriptionFlags value);
}
JScript public function get Flags() : BufferDescriptionFlags
public function set Flags(BufferDescriptionFlags);

Property Value

Microsoft.DirectX.DirectSound.BufferDescriptionFlags
A bitwise OR combination of BufferDescriptionFlags enumeration values that describes the capabilities of the buffer.

This property is read/write.


BufferDescription.Format Property (Microsoft.DirectX.DirectSound)

BufferDescription.Format Property

Retrieves or sets the the waveform format for the buffer.

Definition

Visual Basic | Public Property Format As WaveFormat
C# | public WaveFormat Format { get; set; }
C++ public:
property WaveFormat Format {
WaveFormat get();
void set(WaveFormat value);
}
JScript public function get Format() : WaveFormat
public function set Format(WaveFormat);

Property Value

Microsoft.DirectX.DirectSound.WaveFormat
A WaveFormat structure that contains a description of the waveform format that is used by the buffer.

This property is read/write.


BufferDescription.GlobalFocus Property (Microsoft.DirectX.DirectSound)

BufferDescription.GlobalFocus Property

Specifies whether the buffer is a global sound buffer.

Definition

Visual Basic | Public Property GlobalFocus As Boolean
C# | public bool GlobalFocus { get; set; }
C++ public:
property bool GlobalFocus {
bool get();
void set(bool value);
}
JScript public function get GlobalFocus() : boolean
public function set GlobalFocus(boolean);

Property Value

System.Boolean
This value is set to true if the buffer is a global buffer; otherwise, false.

This property is read/write.

Remarks

With GlobalFocus set to true, an application using Microsoft DirectSound can continue to play its buffers if the user switches focus to another application, even if the new application uses DirectSound. The one exception is that the global sounds from other applications will not be audible if you switch focus to a DirectSound application that uses the CooperativeLevel.WritePrimary flag for its cooperative level.


BufferDescription.Guid3DAlgorithm Property (Microsoft.DirectX.DirectSound)

BufferDescription.Guid3DAlgorithm Property

Retrieves or sets the unique identifier of the two-speaker virtualization algorithm to be used by DirectSound3D hardware emulation.

Definition

Visual Basic | Public Property Guid3DAlgorithm As Guid
C# | public Guid Guid3DAlgorithm { get; set; }
C++ public:
property Guid Guid3DAlgorithm {
Guid get();
void set(Guid value);
}
JScript public function get Guid3DAlgorithm() : Guid
public function set Guid3DAlgorithm(Guid);

Property Value

System.Guid
A Guid Leave Site that represents the algorithm identifier to set or retrieve.

This property is read/write.

Remarks

Use the Guid Leave Site fields in the DSoundHelper class to obtain a virtualization algorithm's Guid Leave Site to set in this method.


BufferDescription.LocateInHardware Property (Microsoft.DirectX.DirectSound)

BufferDescription.LocateInHardware Property

Specifies whether the buffer must use hardware mixing.

Definition

Visual Basic | Public Property LocateInHardware As Boolean
C# | public bool LocateInHardware { get; set; }
C++ public:
property bool LocateInHardware {
bool get();
void set(bool value);
}
JScript public function get LocateInHardware() : boolean
public function set LocateInHardware(boolean);

Property Value

System.Boolean
This value is set to true if the buffer must use hardware mixing; otherwise, false.

This property is read/write.

Remarks

If an attempt is made to create a Buffer or SecondaryBuffer with BufferDescription.LocateInHardware set to true on a system where hardware acceleration is not available, the constructor method will fail.

The application must ensure that a mixing channel is available for the buffer.

If neither BufferDescription.LocateInHardware nor BufferDescription.LocateInSoftware is specified, the buffer is placed in hardware if resources are available, or in software if hardware resources are not available. Hardware buffers are not supported in 64-bit operating systems.


BufferDescription.LocateInSoftware Property (Microsoft.DirectX.DirectSound)

BufferDescription.LocateInSoftware Property

Specifies whether the buffer must use software memory and use software mixing, even if BufferDescription.StaticBuffer is specified and hardware resources are available.

Definition

Visual Basic | Public Property LocateInSoftware As Boolean
C# | public bool LocateInSoftware { get; set; }
C++ public:
property bool LocateInSoftware {
bool get();
void set(bool value);
}
JScript public function get LocateInSoftware() : boolean
public function set LocateInSoftware(boolean);

Property Value

System.Boolean
This value is set to true if the buffer must use software mixing; otherwise, false.

This property is read/write.


BufferDescription.Mute3DAtMaximumDistance Property (Microsoft.DirectX.DirectSound)

BufferDescription.Mute3DAtMaximumDistance Property

Specifies whether the sound is reduced to silence at the maximum distance.

Definition

Visual Basic | Public Property Mute3DAtMaximumDistance As Boolean
C# | public bool Mute3DAtMaximumDistance { get; set; }
C++ public:
property bool Mute3DAtMaximumDistance {
bool get();
void set(bool value);
}
JScript public function get Mute3DAtMaximumDistance() : boolean
public function set Mute3DAtMaximumDistance(boolean);

Property Value

System.Boolean
This value is set to true to mute sound at the maximum distance; otherwise, false.

This property is read/write.

Remarks

The buffer will stop playing when the maximum distance is exceeded, so that processor time is not wasted. Applies only to software buffers.


BufferDescription.PrimaryBuffer Property (Microsoft.DirectX.DirectSound)

BufferDescription.PrimaryBuffer Property

Specifies whether the buffer is a primary sound buffer.

Definition

Visual Basic | Public Property PrimaryBuffer As Boolean
C# | public bool PrimaryBuffer { get; set; }
C++ public:
property bool PrimaryBuffer {
bool get();
void set(bool value);
}
JScript public function get PrimaryBuffer() : boolean
public function set PrimaryBuffer(boolean);

Property Value

System.Boolean
This value is set to true if the buffer is a primary sound buffer; otherwise, false.

This property is read/write.

Remarks

This property cannot be combined with BufferDescription.ControlEffects.


BufferDescription.StaticBuffer Property (Microsoft.DirectX.DirectSound)

BufferDescription.StaticBuffer Property

Specifies whether the buffer is placed in on-board hardware memory, if available.

Definition

Visual Basic | Public Property StaticBuffer As Boolean
C# | public bool StaticBuffer { get; set; }
C++ public:
property bool StaticBuffer {
bool get();
void set(bool value);
}
JScript public function get StaticBuffer() : boolean
public function set StaticBuffer(boolean);

Property Value

System.Boolean
This value is set to true if the buffer is a static buffer; otherwise, false.

This property is read/write.

Remarks

No error occurs if on-board hardware memory is not available. This flag has no effect on cards using the peripheral component interconnect (PCI) bus.

This property cannot be combined with BufferDescription.ControlEffects.


BufferDescription.StickyFocus Property (Microsoft.DirectX.DirectSound)

BufferDescription.StickyFocus Property

Specifies whether the buffer has sticky focus.

Definition

Visual Basic | Public Property StickyFocus As Boolean
C# | public bool StickyFocus { get; set; }
C++ public:
property bool StickyFocus {
bool get();
void set(bool value);
}
JScript public function get StickyFocus() : boolean
public function set StickyFocus(boolean);

Property Value

System.Boolean
This value is set to true if the buffer has sticky focus; otherwise, false.

This property is read/write.

Remarks

If the user switches to another application not using Microsoft DirectSound, the application's normal buffers are muted, but sticky focus buffers are still audible.


BufferLostException Class (Microsoft.DirectX.DirectSound)

BufferLostException Class

The buffer memory has been lost and must be restored.

Definition

Visual Basic Public Class BufferLostException
Inherits SoundException
C# | public class BufferLostException : SoundException
C++ | public ref class BufferLostException : SoundException
JScript | public class BufferLostException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BufferLostException | Initializes a new instance of the BufferLostException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
BufferLostException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BufferLostException.BufferLostException Constructor ()

Initializes a new instance of the BufferLostException class.

Overload List

public BufferLostException();
protected BufferLostException(SerializationInfo, StreamingContext);
public BufferLostException(string);
public BufferLostException(string, Exception);


BufferLostException.BufferLostException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

BufferLostException.BufferLostException Constructor

Initializes a new instance of the BufferLostException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BufferLostException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
BufferLostException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function BufferLostException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


BufferLostException.BufferLostException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

BufferLostException.BufferLostException Constructor

Initializes a new instance of the BufferLostException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BufferLostException(
string message,
Exception inner
);
C++ public:
BufferLostException(
String^ message,
Exception^ inner
);
JScript public function BufferLostException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


BufferLostException.BufferLostException(String) Constructor (Microsoft.DirectX.DirectSound)

BufferLostException.BufferLostException Constructor

Initializes a new instance of the BufferLostException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public BufferLostException(
string message
);
C++ public:
BufferLostException(
String^ message
);
JScript public function BufferLostException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


BufferLostException.BufferLostException() Constructor (Microsoft.DirectX.DirectSound)

BufferLostException.BufferLostException Constructor

Initializes a new instance of the BufferLostException class.

Definition

Visual Basic | Public Sub New()
C# | public BufferLostException();
C++ public:
BufferLostException();
JScript | public function BufferLostException();


BufferTooSmallException Class (Microsoft.DirectX.DirectSound)

BufferTooSmallException Class

The buffer size is not large enough to enable effects processing.

Definition

Visual Basic Public Class BufferTooSmallException
Inherits SoundException
C# | public class BufferTooSmallException : SoundException
C++ | public ref class BufferTooSmallException : SoundException
JScript | public class BufferTooSmallException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
BufferTooSmallException | Initializes a new instance of the BufferTooSmallException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
BufferTooSmallException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


BufferTooSmallException.BufferTooSmallException Constructor ()

Initializes a new instance of the BufferTooSmallException class.

Overload List

public BufferTooSmallException();
protected BufferTooSmallException(SerializationInfo, StreamingContext);
public BufferTooSmallException(string);
public BufferTooSmallException(string, Exception);


BufferTooSmallException.BufferTooSmallException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

BufferTooSmallException.BufferTooSmallException Constructor

Initializes a new instance of the BufferTooSmallException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected BufferTooSmallException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
BufferTooSmallException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function BufferTooSmallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


BufferTooSmallException.BufferTooSmallException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

BufferTooSmallException.BufferTooSmallException Constructor

Initializes a new instance of the BufferTooSmallException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public BufferTooSmallException(
string message,
Exception inner
);
C++ public:
BufferTooSmallException(
String^ message,
Exception^ inner
);
JScript public function BufferTooSmallException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


BufferTooSmallException.BufferTooSmallException(String) Constructor (Microsoft.DirectX.DirectSound)

BufferTooSmallException.BufferTooSmallException Constructor

Initializes a new instance of the BufferTooSmallException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public BufferTooSmallException(
string message
);
C++ public:
BufferTooSmallException(
String^ message
);
JScript public function BufferTooSmallException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


BufferTooSmallException.BufferTooSmallException() Constructor (Microsoft.DirectX.DirectSound)

BufferTooSmallException.BufferTooSmallException Constructor

Initializes a new instance of the BufferTooSmallException class.

Definition

Visual Basic | Public Sub New()
C# | public BufferTooSmallException();
C++ public:
BufferTooSmallException();
JScript | public function BufferTooSmallException();


Capture Class (Microsoft.DirectX.DirectSound)

Capture Class

Contains properties and methods used to create sound capture buffers.

Definition

Visual Basic Public Class Capture
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Capture : MarshalByRefObject, IDisposable
C++ | public ref class Capture : MarshalByRefObject, IDisposable
JScript | public class Capture extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Capture object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Capture | Initializes a new instance of the Capture class using the default Microsoft DirectSound capture device.
Dispose | Immediately releases the unmanaged resources used by the Capture object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Capture object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Capture.Disposing event when called from within a derived class.

Properties

Property | Description
Caps | Retrieves the capabilities of the capture device.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Capture

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Capture.Capture Constructor ()

Initializes a new instance of the Capture class using the default Microsoft DirectSound capture device.

Overload List

public Capture();
public Capture(Guid);
public Capture(IntPtr);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
NoAggregationException | The object does not support aggregation.


Capture.Capture(IntPtr) Constructor (Microsoft.DirectX.DirectSound)

Capture.Capture Constructor

Initializes a new instance of the Capture class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr _
)
C# public Capture(
IntPtr lp
);
C++ public:
Capture(
IntPtr lp
);
JScript public function Capture(
lp : IntPtr
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCapture8, which allows unmanaged COM clients to create an instance of the managed Capture class. Not supported.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft DirectSound could not allocate sufficient memory to complete the call.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
NoAggregationException | The object does not support aggregation.


Capture.Capture(Guid) Constructor (Microsoft.DirectX.DirectSound)

Capture.Capture Constructor

Initializes a new instance of the Capture class using the Microsoft DirectSound capture device specified by its device globally unique identifier (GUID).

Definition

Visual Basic Public Sub New( _
ByVal guidDev As Guid _
)
C# public Capture(
Guid guidDev
);
C++ public:
Capture(
Guid guidDev
);
JScript public function Capture(
guidDev : Guid
);

Parameters

guidDev System.Guid
The DirectSound capture device's GUID.

Remarks

To get a capture device's GUID, first enumerate the devices using the CaptureDevicesCollection object. Then get the GUID from the DriverGuid property of the DeviceInformation structure of the device you want to use.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
NoAggregationException | The object does not support aggregation.


Capture.Capture() Constructor (Microsoft.DirectX.DirectSound)

Capture.Capture Constructor

Initializes a new instance of the Capture class using the default Microsoft DirectSound capture device.

Definition

Visual Basic | Public Sub New()
C# | public Capture();
C++ public:
Capture();
JScript | public function Capture();

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
NoAggregationException | The object does not support aggregation.


Capture.Dispose() Method (Microsoft.DirectX.DirectSound)

Capture.Dispose Method

Immediately releases the unmanaged resources used by the Capture object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Capture();
JScript | public override function Dispose();

See Also

  • Capture.Disposed
  • Capture.Disposing


Capture.Equals(Object) Method (Microsoft.DirectX.DirectSound)

Capture.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Capture.Finalize() Method (Microsoft.DirectX.DirectSound)

Capture.Finalize Method

Allows the Capture object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Capture();
C++ | !Capture();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Capture.GetHashCode() Method (Microsoft.DirectX.DirectSound)

Capture.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Capture.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

Capture.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCapture8 , which allows unmanaged COM clients to create an instance of the managed Capture class. Not supported.


Capture.op_Equality(Capture,Capture) Method (Microsoft.DirectX.DirectSound)

Capture.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Capture, _
ByVal right As Capture _
) As Boolean
C# public static bool op_Equality(
Capture left,
Capture right
);
C++ public:
static bool operator==(
Capture^ left,
Capture^ right
);
JScript public static function op_Equality(
left : Capture,
right : Capture
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Capture
The Capture object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Capture
The Capture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Capture.op_Inequality(Capture,Capture) Method (Microsoft.DirectX.DirectSound)

Capture.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Capture, _
ByVal right As Capture _
) As Boolean
C# public static bool op_Inequality(
Capture left,
Capture right
);
C++ public:
static bool operator!=(
Capture^ left,
Capture^ right
);
JScript public static function op_Inequality(
left : Capture,
right : Capture
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Capture
The Capture object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Capture
The Capture object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Capture.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

Capture.raise_Disposing Method

Raises the Capture.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Capture.Caps Property (Microsoft.DirectX.DirectSound)

Capture.Caps Property

Retrieves the capabilities of the capture device.

Definition

Visual Basic | Public ReadOnly Property Caps As CaptureCaps
C# | public CaptureCaps Caps { get; }
C++ public:
property CaptureCaps Caps {
CaptureCaps get();
}
JScript | public function get Caps() : CaptureCaps

Property Value

Microsoft.DirectX.DirectSound.CaptureCaps
The capabilities of the capture device.

This property is read-only.


Capture.Disposed Property (Microsoft.DirectX.DirectSound)

Capture.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Capture.Disposing Event (Microsoft.DirectX.DirectSound)

Capture.Disposing Event

Occurs when the Dispose method is called or when the Capture object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Capture.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Capture object indicates whether that object has been disposed.


CaptureAcousticEchoCancellationEffect Class (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect Class

Represents a Microsoft DirectSound capture effects object used to set and retrieve parameters on a capture buffer that supports acoustic echo cancellation. This object requires Microsoft Windows XP or later.

Definition

Visual Basic Public Class CaptureAcousticEchoCancellationEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class CaptureAcousticEchoCancellationEffect : MarshalByRefObject, IDisposable
C++ | public ref class CaptureAcousticEchoCancellationEffect : MarshalByRefObject, IDisposable
JScript | public class CaptureAcousticEchoCancellationEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CaptureAcousticEchoCancellationEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the CaptureAcousticEchoCancellationEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CaptureAcousticEchoCancellationEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the CaptureAcousticEchoCancellationEffect.Disposing event when called from within a derived class.
Reset | Resets the effect to its initial state.

Properties

Property | Description
AllParameters | Retrieves or sets capture acoustic echo cancellation parameters of a CaptureBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.
Status | Retrieves the status of the capture acoustic echo cancellation effect.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
CaptureAcousticEchoCancellationEffect

Remarks

Obtain this object by calling the GetObjectInPath method of a CaptureBuffer object that is using the effect.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CaptureAcousticEchoCancellationEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.Dispose Method

Immediately releases the unmanaged resources used by the CaptureAcousticEchoCancellationEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~CaptureAcousticEchoCancellationEffect();
JScript | public override function Dispose();

See Also

  • CaptureAcousticEchoCancellationEffect.Disposed
  • CaptureAcousticEchoCancellationEffect.Disposing


CaptureAcousticEchoCancellationEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CaptureAcousticEchoCancellationEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.Finalize Method

Allows the CaptureAcousticEchoCancellationEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~CaptureAcousticEchoCancellationEffect();
C++ | !CaptureAcousticEchoCancellationEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


CaptureAcousticEchoCancellationEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


CaptureAcousticEchoCancellationEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.GetObjectByValue Method

 Language:

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCaptureFXAec8, which allows unmanaged COM clients to create an instance of the managed CaptureAcousticEchoCancellationEffect class. Not supported.


CaptureAcousticEchoCancellationEffect.op_Equality(CaptureAcousticEchoCancellationEffect,CaptureAcousticEchoCancellationEffect) Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As CaptureAcousticEchoCancellationEffect, _
ByVal right As CaptureAcousticEchoCancellationEffect _
) As Boolean
C# public static bool op_Equality(
CaptureAcousticEchoCancellationEffect left,
CaptureAcousticEchoCancellationEffect right
);
C++ public:
static bool operator==(
CaptureAcousticEchoCancellationEffect^ left,
CaptureAcousticEchoCancellationEffect^ right
);
JScript public static function op_Equality(
left : CaptureAcousticEchoCancellationEffect,
right : CaptureAcousticEchoCancellationEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect
The CaptureAcousticEchoCancellationEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect
The CaptureAcousticEchoCancellationEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CaptureAcousticEchoCancellationEffect.op_Inequality(CaptureAcousticEchoCancellationEffect,CaptureAcousticEchoCancellationEffect) Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As CaptureAcousticEchoCancellationEffect, _
ByVal right As CaptureAcousticEchoCancellationEffect _
) As Boolean
C# public static bool op_Inequality(
CaptureAcousticEchoCancellationEffect left,
CaptureAcousticEchoCancellationEffect right
);
C++ public:
static bool operator!=(
CaptureAcousticEchoCancellationEffect^ left,
CaptureAcousticEchoCancellationEffect^ right
);
JScript public static function op_Inequality(
left : CaptureAcousticEchoCancellationEffect,
right : CaptureAcousticEchoCancellationEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect
The CaptureAcousticEchoCancellationEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.CaptureAcousticEchoCancellationEffect
The CaptureAcousticEchoCancellationEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


CaptureAcousticEchoCancellationEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.raise_Disposing Method

Raises the CaptureAcousticEchoCancellationEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


CaptureAcousticEchoCancellationEffect.Reset() Method (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.Reset Method

Resets the effect to its initial state.

Definition

Visual Basic | Public Sub Reset()
C# | public void Reset();
C++ public:
void Reset();
JScript | public function Reset();

Remarks

Applications should not reset an effect except when necessary because it has entered an incorrect state. This might be done in response to user input. An effect must not be reset arbitrarily at start-up, because another application might be using the same effect.


CaptureAcousticEchoCancellationEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.AllParameters Property

Retrieves or sets capture acoustic echo cancellation parameters of a CaptureBuffer object.

Definition

Visual Basic | Public Property AllParameters As CaptureEffectsAcousticEchoCancellation
C# | public CaptureEffectsAcousticEchoCancellation AllParameters { get; set; }
C++ public:
property CaptureEffectsAcousticEchoCancellation AllParameters {
CaptureEffectsAcousticEchoCancellation get();
void set(CaptureEffectsAcousticEchoCancellation value);
}
JScript public function get AllParameters() : CaptureEffectsAcousticEchoCancellation
public function set AllParameters(CaptureEffectsAcousticEchoCancellation);

Property Value

Microsoft.DirectX.DirectSound.CaptureEffectsAcousticEchoCancellation
Contains parameters for capture acoustic echo cancellation effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


CaptureAcousticEchoCancellationEffect.Disposed Property (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


CaptureAcousticEchoCancellationEffect.Status Property (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.Status Property

Retrieves the status of the capture acoustic echo cancellation effect.

Definition

Visual Basic | Public ReadOnly Property Status As EffectStatus
C# | public EffectStatus Status { get; }
C++ public:
property EffectStatus Status {
EffectStatus get();
}
JScript | public function get Status() : EffectStatus

Property Value

Microsoft.DirectX.DirectSound.EffectStatus
The capture acoustic echo cancellation effect.

This property is read-only.


CaptureAcousticEchoCancellationEffect.Disposing Event (Microsoft.DirectX.DirectSound)

CaptureAcousticEchoCancellationEffect.Disposing Event

Occurs when the Dispose method is called or when the CaptureAcousticEchoCancellationEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the CaptureAcousticEchoCancellationEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CaptureAcousticEchoCancellationEffect object indicates whether that object has been disposed.


CaptureBuffer Class (Microsoft.DirectX.DirectSound)

CaptureBuffer Class

Contains properties and methods used to manipulate sound capture buffers.

Definition

Visual Basic Public Class CaptureBuffer
Inherits Object
C# | public class CaptureBuffer : Object
C++ | public ref class CaptureBuffer : Object
JScript | public class CaptureBuffer extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CaptureBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
CaptureBuffer | Initializes a new instance of the CaptureBuffer class.
Dispose | Immediately releases the unmanaged resources used by the CaptureBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CaptureBuffer object to free resources before it is destroyed by the garbage collector.
GetCurrentPosition | Retrieves the position of the capture and read cursors in the CaptureBuffer object.
GetEffectsStatus | Retrieves the status of capture effects.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetObjectInPath | Retrieves a capture effect object associated with the CaptureBuffer object.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the CaptureBuffer.Disposing event when called from within a derived class.
Read | Reads current data in the capture buffer.
Start | Begins capturing data into the buffer.
Stop | Stops the buffer so that it is no longer capturing data.
Write | Writes data to the capture buffer.

Properties

Property | Description
Caps | Retrieves the capabilities of the capture buffer.
Capturing | Retrieves whether the capture buffer is currently capturing.
Disposed | Gets a value that indicates whether the object is disposed.
Format | Retrieves the waveform format of the capture buffer.
Looping | Retrieves whether the capture buffer is currently looping.

Inheritance Hierarchy

Object Leave Site
CaptureBuffer

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CaptureBuffer.CaptureBuffer Constructor ()

Initializes a new instance of the CaptureBuffer class.

Overload List

public CaptureBuffer(CaptureBufferDescription, Capture);
public CaptureBuffer(IntPtr, Capture);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.


CaptureBuffer.CaptureBuffer(IntPtr,Capture) Constructor (Microsoft.DirectX.DirectSound)

CaptureBuffer.CaptureBuffer Constructor

Initializes a new instance of the CaptureBuffer class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal device As Capture _
)
C# public CaptureBuffer(
IntPtr lp,
Capture device
);
C++ public:
CaptureBuffer(
IntPtr lp,
Capture^ device
);
JScript public function CaptureBuffer(
lp : IntPtr,
device : Capture
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCaptureBuffer8, which allows unmanaged COM clients to create an instance of the managed CaptureBuffer class. Not supported.
device Microsoft.DirectX.DirectSound.Capture
The Capture object that represents the parent capture device to use with the capture buffer.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.


CaptureBuffer.CaptureBuffer(CaptureBufferDescription,Capture) Constructor (Microsoft.DirectX.DirectSound)

CaptureBuffer.CaptureBuffer Constructor

Initializes a new instance of the CaptureBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal desc As CaptureBufferDescription, _
ByVal parent As Capture _
)
C# public CaptureBuffer(
CaptureBufferDescription desc,
Capture parent
);
C++ public:
CaptureBuffer(
CaptureBufferDescription desc,
Capture^ parent
);
JScript public function CaptureBuffer(
desc : CaptureBufferDescription,
parent : Capture
);

Parameters

desc Microsoft.DirectX.DirectSound.CaptureBufferDescription
A CaptureBufferDescription structure that describes the capture buffer to create.
parent Microsoft.DirectX.DirectSound.Capture
The Capture object that represents the parent capture device to use with the capture buffer.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.


CaptureBuffer.Dispose() Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Dispose Method

Immediately releases the unmanaged resources used by the CaptureBuffer object.

Definition

Visual Basic | Public Sub Dispose()
C# | public void Dispose();
C++ | ~CaptureBuffer();
JScript | public function Dispose();

See Also

  • CaptureBuffer.Disposed
  • CaptureBuffer.Disposing


CaptureBuffer.Equals(Object) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CaptureBuffer.Finalize() Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Finalize Method

Allows the CaptureBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~CaptureBuffer();
C++ | !CaptureBuffer();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


CaptureBuffer.GetCurrentPosition(Int32,Int32) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.GetCurrentPosition Method

Retrieves the position of the capture and read cursors in the CaptureBuffer object.

Definition

Visual Basic Public Sub GetCurrentPosition( _
ByRef currentCapturePosition As Integer, _
ByRef currentReadPosition As Integer _
)
C# public void GetCurrentPosition(
out int currentCapturePosition,
out int currentReadPosition
);
C++ public:
void GetCurrentPosition(
[Out] int% currentCapturePosition,
[Out] int% currentReadPosition
);
JScript public function GetCurrentPosition(
currentCapturePosition : int,
currentReadPosition : int
);

Parameters

currentCapturePosition System.Int32
An integer that receives the offset, in bytes, of the capture cursor position in the capture buffer.
currentReadPosition System.Int32
An integer that receives the offset, in bytes, of the read cursor position in the capture buffer.

Remarks

The capture cursor is ahead of the read cursor. The data after the read position, up to and including the capture position, is not necessarily valid data.


CaptureBuffer.GetEffectsStatus(Int32) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.GetEffectsStatus Method

Retrieves the status of capture effects.

Definition

Visual Basic Public Function GetEffectsStatus( _
ByVal numEffects As Integer _
) As CaptureEffectsReturnValue()
C# public CaptureEffectsReturnValue[] GetEffectsStatus(
int numEffects
);
C++ public:
array<CaptureEffectsReturnValue>^ GetEffectsStatus(
int numEffects
);
JScript public function GetEffectsStatus(
numEffects : int
) : CaptureEffectsReturnValue[];

Parameters

numEffects System.Int32
The number of capture effects to retrieve.

Return Value

Microsoft.DirectX.DirectSound.CaptureEffectsReturnValue[]
An array of values from the CaptureEffectsReturnValue enumeration that describe the status of capture effects in the CaptureBuffer object.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


CaptureBuffer.GetHashCode() Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


CaptureBuffer.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCaptureBuffer8, which allows unmanaged COM clients to create an instance of the managed CaptureBuffer class. Not supported.


CaptureBuffer.GetObjectInPath(Guid,Int32,Guid) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.GetObjectInPath Method

Retrieves a capture effect object associated with the CaptureBuffer object.

Definition

Visual Basic Public Function GetObjectInPath( _
ByVal guidObject As Guid, _
ByVal index As Integer, _
ByVal guidInterface As Guid _
) As Object
C# public object GetObjectInPath(
Guid guidObject,
int index,
Guid guidInterface
);
C++ public:
Object^ GetObjectInPath(
Guid guidObject,
int index,
Guid guidInterface
);
JScript public function GetObjectInPath(
guidObject : Guid,
index : int,
guidInterface : Guid
) : Object;

Parameters

guidObject System.Guid
Unique class identifier of the object being searched for, such as DSoundHelper.CaptureEffectsMsAcousticEchoCancellation.
index System.Int32
Index of the capture effect to retrieve from the CaptureBuffer object.
guidInterface System.Guid
Unique identifier of the desired interface, such as DSoundHelper.InterfaceCaptureEffectsAcousticEchoCancellation.

Return Value

System.Object
A capture effect used by the CaptureBuffer object.

Remarks

The value in index is the index of the object within the array of effects in the CaptureBufferDescription structure used in the CaptureBuffer constructor.

An object is returned solely on the basis of whether it matches guidObject and index. It is up to the application to ensure that guidInterface specifies an interface that can be expected to be found on the object.

Since this method returns the type of Object Leave Site, be sure to cast it to the correct type of the capture effect that you are retrieving.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all Microsoft DirectSound Exceptions. Derives from DirectXException.


CaptureBuffer.op_Equality(CaptureBuffer,CaptureBuffer) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As CaptureBuffer, _
ByVal right As CaptureBuffer _
) As Boolean
C# public static bool op_Equality(
CaptureBuffer left,
CaptureBuffer right
);
C++ public:
static bool operator==(
CaptureBuffer^ left,
CaptureBuffer^ right
);
JScript public static function op_Equality(
left : CaptureBuffer,
right : CaptureBuffer
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.CaptureBuffer
The CaptureBuffer object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.CaptureBuffer
The CaptureBuffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CaptureBuffer.op_Inequality(CaptureBuffer,CaptureBuffer) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As CaptureBuffer, _
ByVal right As CaptureBuffer _
) As Boolean
C# public static bool op_Inequality(
CaptureBuffer left,
CaptureBuffer right
);
C++ public:
static bool operator!=(
CaptureBuffer^ left,
CaptureBuffer^ right
);
JScript public static function op_Inequality(
left : CaptureBuffer,
right : CaptureBuffer
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.CaptureBuffer
The CaptureBuffer object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.CaptureBuffer
The CaptureBuffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


CaptureBuffer.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.raise_Disposing Method

Raises the CaptureBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


CaptureBuffer.Read Method ()

Reads current data in the capture buffer.

Overload List

public void Read(int, Stream, int, LockFlag);
public Array Read(int, Type, LockFlag, int[]);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Read(Int32,Type,LockFlag,Int32[]) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Read Method

Reads current data in the capture buffer.

Definition

Visual Basic Public Function Read( _
ByVal bufferStartingLocation As Integer, _
ByVal returnedDataType As Type, _
ByVal flag As LockFlag, _
ByVal ranks() As Integer _
) As Array
C# public Array Read(
int bufferStartingLocation,
Type returnedDataType,
LockFlag flag,
int[] ranks
);
C++ public:
Array^ Read(
int bufferStartingLocation,
Type^ returnedDataType,
LockFlag flag,
array<int>^ ranks
);
JScript public function Read(
bufferStartingLocation : int,
returnedDataType : Type,
flag : LockFlag,
ranks : int[]
) : Array;

Parameters

bufferStartingLocation System.Int32
An integer that represents the offet, in bytes, of where to begin reading from the capture buffer. This parameter is ignored if LockFlag.FromWriteCursor is specified in the flag parameter.
returnedDataType System.Type
Value that indicates the Type Leave Site of the returned array.
flag Microsoft.DirectX.DirectSound.LockFlag
A LockFlag enumerated value that describes the type of lock to perform.
ranks System.Int32[]
Array of one to three Int32 Leave Site values that indicate the dimensions of the returning Array. The maximum number of ranks allowed is three.

Return Value

System.Array
An Array Leave Site of type returnedDataType that contains the data read from the buffer.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Read(Int32,Stream,Int32,LockFlag) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Read Method

Reads current data in the capture buffer.

Definition

Visual Basic Public Sub Read( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Stream, _
ByVal numberBytesToRead As Integer, _
ByVal flag As LockFlag _
)
C# public void Read(
int bufferStartingLocation,
Stream data,
int numberBytesToRead,
LockFlag flag
);
C++ public:
void Read(
int bufferStartingLocation,
Stream^ data,
int numberBytesToRead,
LockFlag flag
);
JScript public function Read(
bufferStartingLocation : int,
data : Stream,
numberBytesToRead : int,
flag : LockFlag
);

Parameters

bufferStartingLocation System.Int32
An integer that represents the offet, in bytes, of where to begin reading from the capture buffer. This parameter is ignored if LockFlag.FromWriteCursor is specified in the flag parameter.
data System.IO.Stream
A Stream Leave Site object that receives the data read from the capture buffer.
numberBytesToRead System.Int32
An integer that represents the number of bytes read into data from the buffer. The buffer is conceptually circular, so this number can exceed the number of bytes between bufferStartingLocation and the end of the buffer.
flag Microsoft.DirectX.DirectSound.LockFlag
A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToRead is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
ArgumentOutOfRangeException Leave Site | The ranks parameter is out of range. The maximum number of dimensions for the ranks array is three.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to write to the receiving stream object, data. Check if the stream is writable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Start(Boolean) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Start Method

Begins capturing data into the buffer.

Definition

Visual Basic Public Sub Start( _
ByVal looping As Boolean _
)
C# public void Start(
bool looping
);
C++ public:
void Start(
bool looping
);
JScript public function Start(
looping : boolean
);

Parameters

looping System.Boolean
Set to true if, after the end of the buffer is reached, capture restarts at the beginning and continues until explicitly stopped; otherwise, false.

Remarks

If the buffer is already capturing, the method has no effect.

If the buffer is already capturing, a call to this method using a different value in looping might not change the value returned by Looping.

If the application is multithreaded, the thread that starts the buffer must continue to exist as long as the buffer is capturing. Buffers created on Windows Driver Model (WDM) drivers stop capturing when the thread is terminated.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft DirectSound could not allocate sufficient memory to complete the call.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid DirectSound device identifier (ID).


CaptureBuffer.Stop() Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Stop Method

Stops the buffer so that it is no longer capturing data.

Definition

Visual Basic | Public Sub Stop()
C# | public void Stop();
C++ public:
void Stop();
JScript | public function Stop();

Remarks

If the buffer is not capturing, the method has no effect.

Exceptions
OutOfMemoryException Leave Site | Microsoft DirectSound could not allocate sufficient memory to complete the call.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid DirectSound device identifier (ID).


CaptureBuffer.Write Method ()

Writes data to the capture buffer.

Overload List

public void Write(int, Array, LockFlag);
public void Write(int, Stream, int, LockFlag);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Write(Int32,Array,LockFlag) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Write Method

Writes data to the capture buffer.

Definition

Visual Basic Public Sub Write( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Array, _
ByVal flag As LockFlag _
)
C# public void Write(
int bufferStartingLocation,
Array data,
LockFlag flag
);
C++ public:
void Write(
int bufferStartingLocation,
Array^ data,
LockFlag flag
);
JScript public function Write(
bufferStartingLocation : int,
data : Array,
flag : LockFlag
);

Parameters

bufferStartingLocation System.Int32
An integer that represents the offet, in bytes, of where to begin writing into the capture buffer.
data System.Array
An Array Leave Site that contains the data to write into the capture buffer.
flag Microsoft.DirectX.DirectSound.LockFlag
A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Write(Int32,Stream,Int32,LockFlag) Method (Microsoft.DirectX.DirectSound)

CaptureBuffer.Write Method

Writes data to the capture buffer.

Definition

Visual Basic Public Sub Write( _
ByVal bufferStartingLocation As Integer, _
ByVal data As Stream, _
ByVal numberBytesToWrite As Integer, _
ByVal flag As LockFlag _
)
C# public void Write(
int bufferStartingLocation,
Stream data,
int numberBytesToWrite,
LockFlag flag
);
C++ public:
void Write(
int bufferStartingLocation,
Stream^ data,
int numberBytesToWrite,
LockFlag flag
);
JScript public function Write(
bufferStartingLocation : int,
data : Stream,
numberBytesToWrite : int,
flag : LockFlag
);

Parameters

bufferStartingLocation System.Int32
An integer that represents the offet, in bytes, of where to begin writing into the capture buffer.
data System.IO.Stream
A Stream Leave Site object that contains the data to write into the capture buffer.
numberBytesToWrite System.Int32
An integer that represents the number of bytes to write into the capture buffer.
flag Microsoft.DirectX.DirectSound.LockFlag
A LockFlag enumerated value that describes the type of lock to perform.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method, or numberBytesToWrite is set to zero.
ArgumentNullException Leave Site | One or more parameters is null.
BufferLostException | The buffer memory has been lost and must be restored.
InvalidCallException | The method call is invalid. For example, a method's parameter might not be valid.
NotSupportedException Leave Site | Unable to read from the source stream object, data. Check if the stream is readable.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.


CaptureBuffer.Caps Property (Microsoft.DirectX.DirectSound)

CaptureBuffer.Caps Property

Retrieves the capabilities of the capture buffer.

Definition

Visual Basic | Public ReadOnly Property Caps As CaptureBufferCaps
C# | public CaptureBufferCaps Caps { get; }
C++ public:
property CaptureBufferCaps Caps {
CaptureBufferCaps get();
}
JScript | public function get Caps() : CaptureBufferCaps

Property Value

Microsoft.DirectX.DirectSound.CaptureBufferCaps
A CaptureBufferCaps structure that describes the capibilites of the CaptureBuffer object.

This property is read-only.


CaptureBuffer.Capturing Property (Microsoft.DirectX.DirectSound)

CaptureBuffer.Capturing Property

Retrieves whether the capture buffer is currently capturing.

Definition

Visual Basic | Public ReadOnly Property Capturing As Boolean
C# | public bool Capturing { get; }
C++ public:
property bool Capturing {
bool get();
}
JScript | public function get Capturing() : boolean

Property Value

System.Boolean
Value that is set to true if the capture buffer is currently capturing; otherwise, false.

This property is read-only.


CaptureBuffer.Disposed Property (Microsoft.DirectX.DirectSound)

CaptureBuffer.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


CaptureBuffer.Format Property (Microsoft.DirectX.DirectSound)

CaptureBuffer.Format Property

Retrieves the waveform format of the capture buffer.

Definition

Visual Basic | Public ReadOnly Property Format As WaveFormat
C# | public WaveFormat Format { get; }
C++ public:
property WaveFormat Format {
WaveFormat get();
}
JScript | public function get Format() : WaveFormat

Property Value

Microsoft.DirectX.DirectSound.WaveFormat
A WaveFormat structure that describes the waveform format of the capture buffer.

This property is read-only.


CaptureBuffer.Looping Property (Microsoft.DirectX.DirectSound)

CaptureBuffer.Looping Property

Retrieves whether the capture buffer is currently looping.

Definition

Visual Basic | Public ReadOnly Property Looping As Boolean
C# | public bool Looping { get; }
C++ public:
property bool Looping {
bool get();
}
JScript | public function get Looping() : boolean

Property Value

System.Boolean
Value that is set to true if the capture buffer is currently looping; otherwise, false.

This property is read-only.


CaptureBuffer.Disposing Event (Microsoft.DirectX.DirectSound)

CaptureBuffer.Disposing Event

Occurs when the Dispose method is called or when the CaptureBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the CaptureBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CaptureBuffer object indicates whether that object has been disposed.


CaptureDevicesCollection Class (Microsoft.DirectX.DirectSound)

CaptureDevicesCollection Class

Represents a collection of DeviceInformation structures for each available capture device.

Definition

Visual Basic NotInheritable Public Class CaptureDevicesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class CaptureDevicesCollection : Object, IEnumerable, IEnumerator
C++ | public ref class CaptureDevicesCollection sealed : Object, IEnumerable, IEnumerator
JScript | public final class CaptureDevicesCollection extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureDevicesCollection | Initializes a new instance of the CaptureDevicesCollection class.
GetEnumerator | Retrieves an enumerator for the CaptureDevicesCollection object.
MoveNext | Advances to the next DeviceInformation structure in the CaptureDevicesCollection object.
Reset | Sets the CaptureDevicesCollection object to its initial position.

Properties

Property | Description
Count | Gets the number of DeviceInformation structures in the CaptureDevicesCollection object.
Current | Gets the current element from the enumeration of the CaptureDevicesCollection object.
Item | Retrieves a DeviceInformation structure at a particular index.

Inheritance Hierarchy

Object Leave Site
CaptureDevicesCollection

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CaptureDevicesCollection.CaptureDevicesCollection() Constructor (Microsoft.DirectX.DirectSound)

CaptureDevicesCollection.CaptureDevicesCollection Constructor

 Language:

Initializes a new instance of the CaptureDevicesCollection class.

Definition

Visual Basic | Public Sub New()
C# | public CaptureDevicesCollection();
C++ public:
CaptureDevicesCollection();
JScript | public function CaptureDevicesCollection();


CaptureDevicesCollection.GetEnumerator() Method (Microsoft.DirectX.DirectSound)

CaptureDevicesCollection.GetEnumerator Method

Retrieves an enumerator for the CaptureDevicesCollection object.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator
An enumerator for the CaptureDevicesCollection object.


CaptureDevicesCollection.MoveNext() Method (Microsoft.DirectX.DirectSound)

CaptureDevicesCollection.MoveNext Method

Advances to the next DeviceInformation structure in the CaptureDevicesCollection object.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean
Returns true if the CaptureDevicesCollection object was successfully advanced, and false if the CaptureDevicesCollection object has passed the end of the collection.


CaptureDevicesCollection.Reset() Method (Microsoft.DirectX.DirectSound)

CaptureDevicesCollection.Reset Method

Sets the CaptureDevicesCollection object to its initial position.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();

Remarks

The initial position of the CaptureDevicesCollection object is before the first DeviceInformation structure.


CaptureDevicesCollection.Count Property (Microsoft.DirectX.DirectSound)

CaptureDevicesCollection.Count Property

Gets the number of DeviceInformation structures in the CaptureDevicesCollection object.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32
The number of DeviceInformation structures.

This property is read-only.


CaptureDevicesCollection.Current Property (Microsoft.DirectX.DirectSound)

CaptureDevicesCollection.Current Property

Gets the current element from the enumeration of the CaptureDevicesCollection object.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object
The current element from the enumeration of the CaptureDevicesCollection object.

This property is read-only.

Remarks

Since this method has a return value type of Object Leave Site, you must cast it into a DeviceInformation structure to access its properties and method. See the example below:

[C#]
CaptureDevicesCollection devices = new CaptureDevicesCollection();
while (devices.MoveNext())
{
    DeviceInformation di = (DeviceInformation)devices.Current;
}


CaptureDevicesCollection.Item Property (Microsoft.DirectX.DirectSound)

CaptureDevicesCollection.Item Property

Retrieves a DeviceInformation structure at a particular index.

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal index As Integer _
) As DeviceInformation
C# public DeviceInformation this[
int index
] { get; }
C++ public:
property DeviceInformation default [int] {
DeviceInformation get(int index);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32
The index of the DeviceInformation structure to retrieve.

Property Value

Microsoft.DirectX.DirectSound.DeviceInformation
The DeviceInformation structure in the CaptureDevicesCollection at the index from the index parameter.

This property is read-only.

Remarks

Exceptions
ArgumentOutOfRangeException Leave Site The index parameter is out of range of the collection.


CaptureNoiseSuppressEffect Class (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect Class

Represents a Microsoft DirectSound capture effects object used to set and retrieve parameters on a capture buffer that supports noise suppression. This object requires Microsoft Windows XP or later.

Definition

Visual Basic Public Class CaptureNoiseSuppressEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class CaptureNoiseSuppressEffect : MarshalByRefObject, IDisposable
C++ | public ref class CaptureNoiseSuppressEffect : MarshalByRefObject, IDisposable
JScript | public class CaptureNoiseSuppressEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CaptureNoiseSuppressEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the CaptureNoiseSuppressEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CaptureNoiseSuppressEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the CaptureNoiseSuppressEffect.Disposing event when called from within a derived class.
Reset | Resets the effect to its initial state.

Properties

Property | Description
AllParameters | Retrieves or sets capture noise suppress parameters of a CaptureBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
CaptureNoiseSuppressEffect

Remarks

Obtain this object by calling the GetObjectInPath method of a CaptureBuffer object that is using the effect.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CaptureNoiseSuppressEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.Dispose Method

Immediately releases the unmanaged resources used by the CaptureNoiseSuppressEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~CaptureNoiseSuppressEffect();
JScript | public override function Dispose();

See Also

  • CaptureNoiseSuppressEffect.Disposed
  • CaptureNoiseSuppressEffect.Disposing


CaptureNoiseSuppressEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CaptureNoiseSuppressEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.Finalize Method

Allows the CaptureNoiseSuppressEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~CaptureNoiseSuppressEffect();
C++ | !CaptureNoiseSuppressEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


CaptureNoiseSuppressEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


CaptureNoiseSuppressEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundCaptureFXNoiseSuppress8 , which allows unmanaged COM clients to create an instance of the managed CaptureNoiseSuppressEffect class. Not supported.


CaptureNoiseSuppressEffect.op_Equality(CaptureNoiseSuppressEffect,CaptureNoiseSuppressEffect) Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As CaptureNoiseSuppressEffect, _
ByVal right As CaptureNoiseSuppressEffect _
) As Boolean
C# public static bool op_Equality(
CaptureNoiseSuppressEffect left,
CaptureNoiseSuppressEffect right
);
C++ public:
static bool operator==(
CaptureNoiseSuppressEffect^ left,
CaptureNoiseSuppressEffect^ right
);
JScript public static function op_Equality(
left : CaptureNoiseSuppressEffect,
right : CaptureNoiseSuppressEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect
The CaptureNoiseSuppressEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect
The CaptureNoiseSuppressEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CaptureNoiseSuppressEffect.op_Inequality(CaptureNoiseSuppressEffect,CaptureNoiseSuppressEffect) Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As CaptureNoiseSuppressEffect, _
ByVal right As CaptureNoiseSuppressEffect _
) As Boolean
C# public static bool op_Inequality(
CaptureNoiseSuppressEffect left,
CaptureNoiseSuppressEffect right
);
C++ public:
static bool operator!=(
CaptureNoiseSuppressEffect^ left,
CaptureNoiseSuppressEffect^ right
);
JScript public static function op_Inequality(
left : CaptureNoiseSuppressEffect,
right : CaptureNoiseSuppressEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect
The CaptureNoiseSuppressEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.CaptureNoiseSuppressEffect
The CaptureNoiseSuppressEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


CaptureNoiseSuppressEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.raise_Disposing Method

Raises the CaptureNoiseSuppressEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


CaptureNoiseSuppressEffect.Reset() Method (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.Reset Method

Resets the effect to its initial state.

Definition

Visual Basic | Public Sub Reset()
C# | public void Reset();
C++ public:
void Reset();
JScript | public function Reset();

Remarks

Applications should not reset an effect except when necessary because it has entered an incorrect state. This might be done in response to user input. An effect must not be reset arbitrarily at start-up, because another application might be using the same effect.


CaptureNoiseSuppressEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.AllParameters Property

Retrieves or sets capture noise suppress parameters of a CaptureBuffer object.

Definition

Visual Basic | Public Property AllParameters As CaptureEffectsNoiseSuppress
C# | public CaptureEffectsNoiseSuppress AllParameters { get; set; }
C++ public:
property CaptureEffectsNoiseSuppress AllParameters {
CaptureEffectsNoiseSuppress get();
void set(CaptureEffectsNoiseSuppress value);
}
JScript public function get AllParameters() : CaptureEffectsNoiseSuppress
public function set AllParameters(CaptureEffectsNoiseSuppress);

Property Value

Microsoft.DirectX.DirectSound.CaptureEffectsNoiseSuppress
Contains parameters for capture noise suppress effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


CaptureNoiseSuppressEffect.Disposed Property (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


CaptureNoiseSuppressEffect.Disposing Event (Microsoft.DirectX.DirectSound)

CaptureNoiseSuppressEffect.Disposing Event

Occurs when the Dispose method is called or when the CaptureNoiseSuppressEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the CaptureNoiseSuppressEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CaptureNoiseSuppressEffect object indicates whether that object has been disposed.


ChorusEffect Class (Microsoft.DirectX.DirectSound)

ChorusEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports chorus.

Definition

Visual Basic Public Class ChorusEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class ChorusEffect : MarshalByRefObject, IDisposable
C++ | public ref class ChorusEffect : MarshalByRefObject, IDisposable
JScript | public class ChorusEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the ChorusEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) DelayMax | Retrieves the maximum value for the EffectsChorus.Delay property.
static (Shared in Visual Basic) DelayMin | Retrieves the minimum value for the EffectsChorus.Delay property.
static (Shared in Visual Basic) DepthMax | Retrieves the maximum value for the EffectsChorus.Depth property.
static (Shared in Visual Basic) DepthMin | Retrieves the minimum value for the EffectsChorus.Depth property.
static (Shared in Visual Basic) FeedbackMax | Retrieves the maximum value for the EffectsChorus.Feedback property.
static (Shared in Visual Basic) FeedbackMin | Retrieves the minimum value for the EffectsChorus.Feedback property.
static (Shared in Visual Basic) FrequencyMax | Retrieves the maximum value for the EffectsChorus.Frequency property.
static (Shared in Visual Basic) FrequencyMin | Retrieves the minimum value for the EffectsChorus.Frequency property.
static (Shared in Visual Basic) Phase180 | Retrieves the value of 180 degrees of phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic) Phase90 | Retrieves the value of 90 degrees of phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic) PhaseMax | Retrieves the maximum value for the EffectsChorus.Phase property.
static (Shared in Visual Basic) PhaseMin | Retrieves the minimum value for the EffectsChorus.Phase property.
static (Shared in Visual Basic) PhaseNegative180 | Retrieves the value of negative 180 degrees of phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic) PhaseNegative90 | Retrieves the value of negative 90 degrees of phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic) PhaseZero | Retrieves the value of no phase differential for the EffectsChorus.Phase property.
static (Shared in Visual Basic) WaveSin | Retrieves the value for a sine waveform for the EffectsChorus.Waveform property.
static (Shared in Visual Basic) WaveTriangle | Retrieves the value for a triangle waveform for the EffectsChorus.Waveform property.
static (Shared in Visual Basic) WetDryMixMax | Retrieves the maximum value for the EffectsChorus.WetDryMix property.
static (Shared in Visual Basic) WetDryMixMin | Retrieves the maximum value for the EffectsChorus.WetDryMix property.

Methods

Method | Description
ChorusEffect | Initializes a new instance of the ChorusEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
Dispose | Immediately releases the unmanaged resources used by the ChorusEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the ChorusEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the ChorusEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets chorus parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
ChorusEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ChorusEffect.ChorusEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

ChorusEffect.ChorusEffect Constructor

Initializes a new instance of the ChorusEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public ChorusEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
ChorusEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function ChorusEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXChorus8, which allows unmanaged COM clients to create an instance of the managed ChorusEffect class. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the ChorusEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


ChorusEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

ChorusEffect.Dispose Method

Immediately releases the unmanaged resources used by the ChorusEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~ChorusEffect();
JScript | public override function Dispose();

See Also

  • ChorusEffect.Disposed
  • ChorusEffect.Disposing


ChorusEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

ChorusEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


ChorusEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

ChorusEffect.Finalize Method

Allows the ChorusEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~ChorusEffect();
C++ | !ChorusEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


ChorusEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

ChorusEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


ChorusEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

ChorusEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXChorus8, which allows unmanaged COM clients to create an instance of the managed ChorusEffect class. Not supported.


ChorusEffect.op_Equality(ChorusEffect,ChorusEffect) Method (Microsoft.DirectX.DirectSound)

ChorusEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As ChorusEffect, _
ByVal right As ChorusEffect _
) As Boolean
C# public static bool op_Equality(
ChorusEffect left,
ChorusEffect right
);
C++ public:
static bool operator==(
ChorusEffect^ left,
ChorusEffect^ right
);
JScript public static function op_Equality(
left : ChorusEffect,
right : ChorusEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.ChorusEffect
The ChorusEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.ChorusEffect
The ChorusEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


ChorusEffect.op_Inequality(ChorusEffect,ChorusEffect) Method (Microsoft.DirectX.DirectSound)

ChorusEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As ChorusEffect, _
ByVal right As ChorusEffect _
) As Boolean
C# public static bool op_Inequality(
ChorusEffect left,
ChorusEffect right
);
C++ public:
static bool operator!=(
ChorusEffect^ left,
ChorusEffect^ right
);
JScript public static function op_Inequality(
left : ChorusEffect,
right : ChorusEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.ChorusEffect
The ChorusEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.ChorusEffect
The ChorusEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


ChorusEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

ChorusEffect.raise_Disposing Method

Raises the ChorusEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


ChorusEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

ChorusEffect.AllParameters Property

Retrieves or sets chorus parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsChorus
C# | public EffectsChorus AllParameters { get; set; }
C++ public:
property EffectsChorus AllParameters {
EffectsChorus get();
void set(EffectsChorus value);
}
JScript public function get AllParameters() : EffectsChorus
public function set AllParameters(EffectsChorus);

Property Value

Microsoft.DirectX.DirectSound.EffectsChorus
Contains parameters for a chorus effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


ChorusEffect.Disposed Property (Microsoft.DirectX.DirectSound)

ChorusEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


ChorusEffect.DelayMax Field (Microsoft.DirectX.DirectSound)

ChorusEffect.DelayMax Field

Retrieves the maximum value for the EffectsChorus.Delay property.

Definition

Visual Basic | Public Shared DelayMax As Single
C# | public static Single DelayMax;
C++ | public: static Single DelayMax;
JScript | public static var DelayMax : Single

Field Value

System.Single
Maximum value for the EffectsChorus.Delay property.

This field is read-only.

See Also

  • EffectsChorus.Delay


ChorusEffect.DelayMin Field (Microsoft.DirectX.DirectSound)

ChorusEffect.DelayMin Field

Retrieves the minimum value for the EffectsChorus.Delay property.

Definition

Visual Basic | Public Shared DelayMin As Single
C# | public static Single DelayMin;
C++ | public: static Single DelayMin;
JScript | public static var DelayMin : Single

Field Value

System.Single
Minimum value for the EffectsChorus.Delay property.

This field is read-only.

See Also

  • EffectsChorus.Delay


ChorusEffect.DepthMax Field (Microsoft.DirectX.DirectSound)

ChorusEffect.DepthMax Field

Retrieves the maximum value for the EffectsChorus.Depth property.

Definition

Visual Basic | Public Shared DepthMax As Single
C# | public static Single DepthMax;
C++ | public: static Single DepthMax;
JScript | public static var DepthMax : Single

Field Value

System.Single
Maximum value for the EffectsChorus.Depth property.

This field is read-only.

See Also

  • EffectsChorus.Depth


ChorusEffect.DepthMin Field (Microsoft.DirectX.DirectSound)

ChorusEffect.DepthMin Field

Retrieves the minimum value for the EffectsChorus.Depth property.

Definition

Visual Basic | Public Shared DepthMin As Single
C# | public static Single DepthMin;
C++ | public: static Single DepthMin;
JScript | public static var DepthMin : Single

Field Value

System.Single
Minimum value for the EffectsChorus.Depth property.

This field is read-only.

See Also

  • EffectsChorus.Depth


ChorusEffect.FeedbackMax Field (Microsoft.DirectX.DirectSound)

ChorusEffect.FeedbackMax Field

Retrieves the maximum value for the EffectsChorus.Feedback property.

Definition

Visual Basic | Public Shared FeedbackMax As Single
C# | public static Single FeedbackMax;
C++ | public: static Single FeedbackMax;
JScript | public static var FeedbackMax : Single

Field Value

System.Single
Maximum value for the EffectsChorus.Fedeback property.

This field is read-only.

See Also

  • EffectsChorus.Feedback


ChorusEffect.FeedbackMin Field (Microsoft.DirectX.DirectSound)

ChorusEffect.FeedbackMin Field

Retrieves the minimum value for the EffectsChorus.Feedback property.

Definition

Visual Basic | Public Shared FeedbackMin As Single
C# | public static Single FeedbackMin;
C++ | public: static Single FeedbackMin;
JScript | public static var FeedbackMin : Single

Field Value

System.Single
Minimum value for the EffectsChorus.Feedback property.

This field is read-only.

See Also

  • EffectsChorus.Feedback


ChorusEffect.FrequencyMax Field (Microsoft.DirectX.DirectSound)

ChorusEffect.FrequencyMax Field

Retrieves the maximum value for the EffectsChorus.Frequency property.

Definition

Visual Basic | Public Shared FrequencyMax As Single
C# | public static Single FrequencyMax;
C++ | public: static Single FrequencyMax;
JScript | public static var FrequencyMax : Single

Field Value

System.Single
Maximum value for the EffectsChorus.Frequency property.

This field is read-only.

See Also

  • EffectsChorus.Frequency


ChorusEffect.FrequencyMin Field (Microsoft.DirectX.DirectSound)

ChorusEffect.FrequencyMin Field

Retrieves the minimum value for the EffectsChorus.Frequency property.

Definition

Visual Basic | Public Shared FrequencyMin As Single
C# | public static Single FrequencyMin;
C++ | public: static Single FrequencyMin;
JScript | public static var FrequencyMin : Single

Field Value

System.Single
Minimum value for the EffectsChorus.Frequency property.

This field is read-only.

See Also

  • EffectsChorus.Frequency


ChorusEffect.Phase180 Field (Microsoft.DirectX.DirectSound)

ChorusEffect.Phase180 Field

Retrieves the value of 180 degrees of phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic | Public Shared Phase180 As Int32
C# | public static Int32 Phase180;
C++ | public: static Int32 Phase180;
JScript | public static var Phase180 : Int32

Field Value

System.Int32
Value of 180 degrees of phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.Phase90 Field (Microsoft.DirectX.DirectSound)

ChorusEffect.Phase90 Field

Retrieves the value of 90 degrees of phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic | Public Shared Phase90 As Int32
C# | public static Int32 Phase90;
C++ | public: static Int32 Phase90;
JScript | public static var Phase90 : Int32

Field Value

System.Int32
Value of 90 degrees of phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseMax Field (Microsoft.DirectX.DirectSound)

ChorusEffect.PhaseMax Field

Retrieves the maximum value for the EffectsChorus.Phase property.

Definition

Visual Basic | Public Shared PhaseMax As Int32
C# | public static Int32 PhaseMax;
C++ | public: static Int32 PhaseMax;
JScript | public static var PhaseMax : Int32

Field Value

System.Int32
Maximum value for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseMin Field (Microsoft.DirectX.DirectSound)

ChorusEffect.PhaseMin Field

Retrieves the minimum value for the EffectsChorus.Phase property.

Definition

Visual Basic | Public Shared PhaseMin As Int32
C# | public static Int32 PhaseMin;
C++ | public: static Int32 PhaseMin;
JScript | public static var PhaseMin : Int32

Field Value

System.Int32
Minimum value for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseNegative180 Field (Microsoft.DirectX.DirectSound)

ChorusEffect.PhaseNegative180 Field

Retrieves the value of negative 180 degrees of phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic | Public Shared PhaseNegative180 As Int32
C# | public static Int32 PhaseNegative180;
C++ | public: static Int32 PhaseNegative180;
JScript | public static var PhaseNegative180 : Int32

Field Value

System.Int32
Value of negative 180 degrees of phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseNegative90 Field (Microsoft.DirectX.DirectSound)

ChorusEffect.PhaseNegative90 Field

Retrieves the value of negative 90 degrees of phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic | Public Shared PhaseNegative90 As Int32
C# | public static Int32 PhaseNegative90;
C++ | public: static Int32 PhaseNegative90;
JScript | public static var PhaseNegative90 : Int32

Field Value

System.Int32
Value of negative 90 degrees of phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.PhaseZero Field (Microsoft.DirectX.DirectSound)

ChorusEffect.PhaseZero Field

Retrieves the value of no phase differential for the EffectsChorus.Phase property.

Definition

Visual Basic | Public Shared PhaseZero As Int32
C# | public static Int32 PhaseZero;
C++ | public: static Int32 PhaseZero;
JScript | public static var PhaseZero : Int32

Field Value

System.Int32
Value of no phase differential for the EffectsChorus.Phase property.

This field is read-only.

See Also

  • EffectsChorus.Phase


ChorusEffect.WaveSin Field (Microsoft.DirectX.DirectSound)

ChorusEffect.WaveSin Field

Retrieves the value for a sine waveform for the EffectsChorus.Waveform property.

Definition

Visual Basic | Public Shared WaveSin As Int32
C# | public static Int32 WaveSin;
C++ | public: static Int32 WaveSin;
JScript | public static var WaveSin : Int32

Field Value

System.Int32
Value for a sine waveform for the EffectsChorus.Waveform property.

This field is read-only.

See Also

  • EffectsChorus.Waveform


ChorusEffect.WaveTriangle Field (Microsoft.DirectX.DirectSound)

ChorusEffect.WaveTriangle Field

Retrieves the value for a triangle waveform for the EffectsChorus.Waveform property.

Definition

Visual Basic | Public Shared WaveTriangle As Int32
C# | public static Int32 WaveTriangle;
C++ | public: static Int32 WaveTriangle;
JScript | public static var WaveTriangle : Int32

Field Value

System.Int32
Value for a triangle waveform for the EffectsChorus.Waveform property.

This field is read-only.

See Also

  • EffectsChorus.Waveform


ChorusEffect.WetDryMixMax Field (Microsoft.DirectX.DirectSound)

ChorusEffect.WetDryMixMax Field

Retrieves the maximum value for the EffectsChorus.WetDryMix property.

Definition

Visual Basic | Public Shared WetDryMixMax As Single
C# | public static Single WetDryMixMax;
C++ | public: static Single WetDryMixMax;
JScript | public static var WetDryMixMax : Single

Field Value

System.Single
Maximum value for the EffectsChorus.WetDryMix property.

This field is read-only.

See Also

  • EffectsChorus.WetDryMix


ChorusEffect.WetDryMixMin Field (Microsoft.DirectX.DirectSound)

ChorusEffect.WetDryMixMin Field

Retrieves the maximum value for the EffectsChorus.WetDryMix property.

Definition

Visual Basic | Public Shared WetDryMixMin As Single
C# | public static Single WetDryMixMin;
C++ | public: static Single WetDryMixMin;
JScript | public static var WetDryMixMin : Single

Field Value

System.Single
Maximum value for the EffectsChorus.WetDryMix property.

This field is read-only.

See Also

  • EffectsChorus.WetDryMix


ChorusEffect.Disposing Event (Microsoft.DirectX.DirectSound)

ChorusEffect.Disposing Event

Occurs when the Dispose method is called or when the ChorusEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the ChorusEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the ChorusEffect object indicates whether that object has been disposed.


CompressorEffect Class (Microsoft.DirectX.DirectSound)

CompressorEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports compression.

Definition

Visual Basic Public Class CompressorEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class CompressorEffect : MarshalByRefObject, IDisposable
C++ | public ref class CompressorEffect : MarshalByRefObject, IDisposable
JScript | public class CompressorEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the CompressorEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) AttackMax | Retrieves the maximum value for the EffectsCompression.Attack property.
static (Shared in Visual Basic) AttackMin | Retrieves the minimum value for the EffectsCompression.Attack property.
static (Shared in Visual Basic) GainMax | Retrieves the maximum value for the EffectsCompression.Gain property.
static (Shared in Visual Basic) GainMin | Retrieves the minimum value for the EffectsCompression.Gain property.
static (Shared in Visual Basic) PreDelayMax | Retrieves the maximum value for the EffectsCompression.PreDelay property.
static (Shared in Visual Basic) PreDelayMin | Retrieves the minimum value for the EffectsCompression.PreDelay property.
static (Shared in Visual Basic) RatioMax | Retrieves the maximum value for the EffectsCompression.Ratio property.
static (Shared in Visual Basic) RatioMin | Retrieves the minimum value for the EffectsCompression.Ratio property.
static (Shared in Visual Basic) ReleaseMax | Retrieves the maximum value for the EffectsCompression.Release property.
static (Shared in Visual Basic) ReleaseMin | Retrieves the minimum value for the EffectsCompression.Release property.
static (Shared in Visual Basic) ThresholdMax | Retrieves the maximum value for the EffectsCompression.Threshold property.
static (Shared in Visual Basic) ThresholdMin | Retrieves the minimum value for the EffectsCompression.Threshold property.

Methods

Method | Description
CompressorEffect | Initializes a new instance of the CompressorEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
Dispose | Immediately releases the unmanaged resources used by the CompressorEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the CompressorEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the CompressorEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets compression parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
CompressorEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CompressorEffect.CompressorEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

CompressorEffect.CompressorEffect Constructor

Initializes a new instance of the CompressorEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public CompressorEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
CompressorEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function CompressorEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXCompressor8, which allows unmanaged COM clients to create an instance of the managed CompressorEffect class. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the CompressorEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


CompressorEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

CompressorEffect.Dispose Method

Immediately releases the unmanaged resources used by the CompressorEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~CompressorEffect();
JScript | public override function Dispose();

See Also

  • CompressorEffect.Disposed
  • CompressorEffect.Disposing


CompressorEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

CompressorEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CompressorEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

CompressorEffect.Finalize Method

Allows the CompressorEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~CompressorEffect();
C++ | !CompressorEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


CompressorEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

CompressorEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


CompressorEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

CompressorEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXCompressor8, which allows unmanaged COM clients to create an instance of the managed CompressorEffect class. Not supported.


CompressorEffect.op_Equality(CompressorEffect,CompressorEffect) Method (Microsoft.DirectX.DirectSound)

CompressorEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As CompressorEffect, _
ByVal right As CompressorEffect _
) As Boolean
C# public static bool op_Equality(
CompressorEffect left,
CompressorEffect right
);
C++ public:
static bool operator==(
CompressorEffect^ left,
CompressorEffect^ right
);
JScript public static function op_Equality(
left : CompressorEffect,
right : CompressorEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.CompressorEffect
The CompressorEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.CompressorEffect
The CompressorEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


CompressorEffect.op_Inequality(CompressorEffect,CompressorEffect) Method (Microsoft.DirectX.DirectSound)

CompressorEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As CompressorEffect, _
ByVal right As CompressorEffect _
) As Boolean
C# public static bool op_Inequality(
CompressorEffect left,
CompressorEffect right
);
C++ public:
static bool operator!=(
CompressorEffect^ left,
CompressorEffect^ right
);
JScript public static function op_Inequality(
left : CompressorEffect,
right : CompressorEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.CompressorEffect
The CompressorEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.CompressorEffect
The CompressorEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


CompressorEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

CompressorEffect.raise_Disposing Method

Raises the CompressorEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


CompressorEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

CompressorEffect.AllParameters Property

Retrieves or sets compression parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsCompressor
C# | public EffectsCompressor AllParameters { get; set; }
C++ public:
property EffectsCompressor AllParameters {
EffectsCompressor get();
void set(EffectsCompressor value);
}
JScript public function get AllParameters() : EffectsCompressor
public function set AllParameters(EffectsCompressor);

Property Value

Microsoft.DirectX.DirectSound.EffectsCompressor
Contains parameters for an compressor effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


CompressorEffect.Disposed Property (Microsoft.DirectX.DirectSound)

CompressorEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


CompressorEffect.AttackMax Field (Microsoft.DirectX.DirectSound)

CompressorEffect.AttackMax Field

Retrieves the maximum value for the EffectsCompression.Attack property.

Definition

Visual Basic | Public Shared AttackMax As Single
C# | public static Single AttackMax;
C++ | public: static Single AttackMax;
JScript | public static var AttackMax : Single

Field Value

System.Single
Maximum value for the EffectsCompression.Attack property.

This field is read-only.

See Also

  • EffectsCompression.Attack


CompressorEffect.AttackMin Field (Microsoft.DirectX.DirectSound)

CompressorEffect.AttackMin Field

Retrieves the minimum value for the EffectsCompression.Attack property.

Definition

Visual Basic | Public Shared AttackMin As Single
C# | public static Single AttackMin;
C++ | public: static Single AttackMin;
JScript | public static var AttackMin : Single

Field Value

System.Single
Minimum value for the EffectsCompression.Attack property.

This field is read-only.

See Also

  • EffectsCompression.Attack


CompressorEffect.GainMax Field (Microsoft.DirectX.DirectSound)

CompressorEffect.GainMax Field

Retrieves the maximum value for the EffectsCompression.Gain property.

Definition

Visual Basic | Public Shared GainMax As Single
C# | public static Single GainMax;
C++ | public: static Single GainMax;
JScript | public static var GainMax : Single

Field Value

System.Single
Maximum value for the EffectsCompression.Gain property.

This field is read-only.

See Also

  • EffectsCompression.Gain


CompressorEffect.GainMin Field (Microsoft.DirectX.DirectSound)

CompressorEffect.GainMin Field

Retrieves the minimum value for the EffectsCompression.Gain property.

Definition

Visual Basic | Public Shared GainMin As Single
C# | public static Single GainMin;
C++ | public: static Single GainMin;
JScript | public static var GainMin : Single

Field Value

System.Single
Minimum value for the EffectsCompression.Gain property.

This field is read-only.

See Also

  • EffectsCompression.Gain


CompressorEffect.PreDelayMax Field (Microsoft.DirectX.DirectSound)

CompressorEffect.PreDelayMax Field

Retrieves the maximum value for the EffectsCompression.PreDelay property.

Definition

Visual Basic | Public Shared PreDelayMax As Single
C# | public static Single PreDelayMax;
C++ | public: static Single PreDelayMax;
JScript | public static var PreDelayMax : Single

Field Value

System.Single
Maximum value for the EffectsCompression.PreDelay property.

This field is read-only.

See Also

  • EffectsCompression.PreDelay


CompressorEffect.PreDelayMin Field (Microsoft.DirectX.DirectSound)

CompressorEffect.PreDelayMin Field

Retrieves the minimum value for the EffectsCompression.PreDelay property.

Definition

Visual Basic | Public Shared PreDelayMin As Single
C# | public static Single PreDelayMin;
C++ | public: static Single PreDelayMin;
JScript | public static var PreDelayMin : Single

Field Value

System.Single
Minimum value for the EffectsCompression.PreDelay property.

This field is read-only.

See Also

  • EffectsCompression.PreDelay


CompressorEffect.RatioMax Field (Microsoft.DirectX.DirectSound)

CompressorEffect.RatioMax Field

Retrieves the maximum value for the EffectsCompression.Ratio property.

Definition

Visual Basic | Public Shared RatioMax As Single
C# | public static Single RatioMax;
C++ | public: static Single RatioMax;
JScript | public static var RatioMax : Single

Field Value

System.Single
Maximum value for the EffectsCompression.Ratio property.

This field is read-only.

See Also

  • EffectsCompression.Ratio


CompressorEffect.RatioMin Field (Microsoft.DirectX.DirectSound)

CompressorEffect.RatioMin Field

Retrieves the minimum value for the EffectsCompression.Ratio property.

Definition

Visual Basic | Public Shared RatioMin As Single
C# | public static Single RatioMin;
C++ | public: static Single RatioMin;
JScript | public static var RatioMin : Single

Field Value

System.Single
Minimum value for the EffectsCompression.Ratio property.

This field is read-only.

See Also

  • EffectsCompression.Ratio


CompressorEffect.ReleaseMax Field (Microsoft.DirectX.DirectSound)

CompressorEffect.ReleaseMax Field

Retrieves the maximum value for the EffectsCompression.Release property.

Definition

Visual Basic | Public Shared ReleaseMax As Single
C# | public static Single ReleaseMax;
C++ | public: static Single ReleaseMax;
JScript | public static var ReleaseMax : Single

Field Value

System.Single
Maximum value for the EffectsCompression.Release property.

This field is read-only.

See Also

  • EffectsCompression.Release


CompressorEffect.ReleaseMin Field (Microsoft.DirectX.DirectSound)

CompressorEffect.ReleaseMin Field

Retrieves the minimum value for the EffectsCompression.Release property.

Definition

Visual Basic | Public Shared ReleaseMin As Single
C# | public static Single ReleaseMin;
C++ | public: static Single ReleaseMin;
JScript | public static var ReleaseMin : Single

Field Value

System.Single
Minimum value for the EffectsCompression.Release property.

This field is read-only.

See Also

  • EffectsCompression.Release


CompressorEffect.ThresholdMax Field (Microsoft.DirectX.DirectSound)

CompressorEffect.ThresholdMax Field

Retrieves the maximum value for the EffectsCompression.Threshold property.

Definition

Visual Basic | Public Shared ThresholdMax As Single
C# | public static Single ThresholdMax;
C++ | public: static Single ThresholdMax;
JScript | public static var ThresholdMax : Single

Field Value

System.Single
Maximum value for the EffectsCompression.Threshold property.

This field is read-only.

See Also

  • EffectsCompression.Threshold


CompressorEffect.ThresholdMin Field (Microsoft.DirectX.DirectSound)

CompressorEffect.ThresholdMin Field

Retrieves the minimum value for the EffectsCompression.Threshold property.

Definition

Visual Basic | Public Shared ThresholdMin As Single
C# | public static Single ThresholdMin;
C++ | public: static Single ThresholdMin;
JScript | public static var ThresholdMin : Single

Field Value

System.Single
Minimum value for the EffectsCompression.Threshold property.

This field is read-only.

See Also

  • EffectsCompression.Threshold


CompressorEffect.Disposing Event (Microsoft.DirectX.DirectSound)

CompressorEffect.Disposing Event

Occurs when the Dispose method is called or when the CompressorEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the CompressorEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the CompressorEffect object indicates whether that object has been disposed.


ControlUnavailableException Class (Microsoft.DirectX.DirectSound)

ControlUnavailableException Class

The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.

Definition

Visual Basic Public Class ControlUnavailableException
Inherits SoundException
C# | public class ControlUnavailableException : SoundException
C++ | public ref class ControlUnavailableException : SoundException
JScript | public class ControlUnavailableException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
ControlUnavailableException | Initializes a new instance of the ControlUnavailableException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
ControlUnavailableException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ControlUnavailableException.ControlUnavailableException Constructor ()

Initializes a new instance of the ControlUnavailableException class.

Overload List

public ControlUnavailableException();
protected ControlUnavailableException(SerializationInfo, StreamingContext);
public ControlUnavailableException(string);
public ControlUnavailableException(string, Exception);


ControlUnavailableException.ControlUnavailableException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:

Initializes a new instance of the ControlUnavailableException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ControlUnavailableException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ControlUnavailableException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ControlUnavailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


ControlUnavailableException.ControlUnavailableException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:

Initializes a new instance of the ControlUnavailableException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ControlUnavailableException(
string message,
Exception inner
);
C++ public:
ControlUnavailableException(
String^ message,
Exception^ inner
);
JScript public function ControlUnavailableException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


ControlUnavailableException.ControlUnavailableException(String) Constructor (Microsoft.DirectX.DirectSound)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:

Initializes a new instance of the ControlUnavailableException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ControlUnavailableException(
string message
);
C++ public:
ControlUnavailableException(
String^ message
);
JScript public function ControlUnavailableException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


ControlUnavailableException.ControlUnavailableException() Constructor (Microsoft.DirectX.DirectSound)

ControlUnavailableException.ControlUnavailableException Constructor

 Language:

Initializes a new instance of the ControlUnavailableException class.

Definition

Visual Basic | Public Sub New()
C# | public ControlUnavailableException();
C++ public:
ControlUnavailableException();
JScript | public function ControlUnavailableException();


Device Class (Microsoft.DirectX.DirectSound)

Device Class

Contains methods and properties used to create buffer objects, manage devices, and set up the environment.

Definition

Visual Basic Public Class Device
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Device : MarshalByRefObject, IDisposable
C++ | public ref class Device : MarshalByRefObject, IDisposable
JScript | public class Device extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Device object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Compact | This method has no effect.
Device | Initializes a new instance of the Device class.
Dispose | Immediately releases the unmanaged resources used by the Device object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Device object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Device.Disposing event when called from within a derived class.
SetCooperativeLevel | Sets the cooperative level of the application for this sound device.

Properties

Property | Description
Caps | Retrieves the capabilities of the hardware device.
Certified | Ascertains whether the device driver is certified for DirectX.
Disposed | Gets a value that indicates whether the object is disposed.
SpeakerConfig | Retrieves or sets the speaker configuration of the device.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Device

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Device.Compact() Method (Microsoft.DirectX.DirectSound)

Device.Compact Method

This method has no effect.

Definition

Visual Basic | Public Sub Compact()
C# | public void Compact();
C++ public:
void Compact();
JScript | public function Compact();

Remarks

This method was formerly used for compacting the on-board memory of ISA sound cards.


Device.Device Constructor ()

Initializes a new instance of the Device class.

Overload List

public Device();
public Device(Guid);
public Device(IntPtr);

Remarks

The application must call the SetCooperativeLevel method immediately after creating a Device object.

Exceptions

AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


Device.Device(IntPtr) Constructor (Microsoft.DirectX.DirectSound)

Device.Device Constructor

Initializes a new instance of the Device class.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr _
)
C# public Device(
IntPtr lp
);
C++ public:
Device(
IntPtr lp
);
JScript public function Device(
lp : IntPtr
);

Parameters

lp System.IntPtr
Pointer to the unmanaged interface, which allows unmanaged COM clients to create an instance of the managed Device class. Not supported.

Remarks

The application must call the SetCooperativeLevel method immediately after creating a Device object.

Exceptions

AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


Device.Device(Guid) Constructor (Microsoft.DirectX.DirectSound)

Device.Device Constructor

Initializes a new instance of the Device class.

Definition

Visual Basic Public Sub New( _
ByVal guidDev As Guid _
)
C# public Device(
Guid guidDev
);
C++ public:
Device(
Guid guidDev
);
JScript public function Device(
guidDev : Guid
);

Parameters

guidDev System.Guid
The Guid Leave Site of the device to create an instanse of. See Remarks.

Remarks

To create an instance a particular Device object using its Guid Leave Site, first retrieve an available device's DeviceInformation from the DevicesCollection object, then get the Guid Leave Site from the DeviceInformation.DriverGuid property.

The application must call the SetCooperativeLevel method immediately after creating a Device object.

Exceptions

AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


Device.Device() Constructor (Microsoft.DirectX.DirectSound)

Device.Device Constructor

Initializes a new instance of the Device class.

Definition

Visual Basic | Public Sub New()
C# | public Device();
C++ public:
Device();
JScript | public function Device();

Remarks

The application must call the SetCooperativeLevel method immediately after creating a Device object.

Exceptions

AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


Device.Dispose() Method (Microsoft.DirectX.DirectSound)

Device.Dispose Method

Immediately releases the unmanaged resources used by the Device object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Device();
JScript | public override function Dispose();

See Also

  • Device.Disposed
  • Device.Disposing


Device.Equals(Object) Method (Microsoft.DirectX.DirectSound)

Device.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Device.Finalize() Method (Microsoft.DirectX.DirectSound)

Device.Finalize Method

Allows the Device object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Device();
C++ | !Device();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Device.GetHashCode() Method (Microsoft.DirectX.DirectSound)

Device.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Device.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

Device.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound8, which allows unmanaged COM clients to create an instance of the managed Device class. Not supported.


Device.op_Equality(Device,Device) Method (Microsoft.DirectX.DirectSound)

Device.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Equality(
Device left,
Device right
);
C++ public:
static bool operator==(
Device^ left,
Device^ right
);
JScript public static function op_Equality(
left : Device,
right : Device
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Device
The Device object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Device
The Device object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Device.op_Inequality(Device,Device) Method (Microsoft.DirectX.DirectSound)

Device.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Device, _
ByVal right As Device _
) As Boolean
C# public static bool op_Inequality(
Device left,
Device right
);
C++ public:
static bool operator!=(
Device^ left,
Device^ right
);
JScript public static function op_Inequality(
left : Device,
right : Device
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Device
The Device object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Device
The Device object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Device.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

Device.raise_Disposing Method

Raises the Device.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Device.SetCooperativeLevel Method ()

Sets the cooperative level of the application for this sound device.

Overload List

public void SetCooperativeLevel(Control, CooperativeLevel);
public void SetCooperativeLevel(IntPtr, CooperativeLevel);

Remarks

The application must set the cooperative level by calling this method before its buffers can be played.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetCooperativeLevel(IntPtr,CooperativeLevel) Method (Microsoft.DirectX.DirectSound)

Device.SetCooperativeLevel Method

Sets the cooperative level of the application for this sound device.

Definition

Visual Basic Public Sub SetCooperativeLevel( _
ByVal owner As IntPtr, _
ByVal level As CooperativeLevel _
)
C# public void SetCooperativeLevel(
IntPtr owner,
CooperativeLevel level
);
C++ public:
void SetCooperativeLevel(
IntPtr owner,
CooperativeLevel level
);
JScript public function SetCooperativeLevel(
owner : IntPtr,
level : CooperativeLevel
);

Parameters

owner System.IntPtr
level Microsoft.DirectX.DirectSound.CooperativeLevel
The requested cooperative level. Specify one of the values shown in the following table

Remarks

The application must set the cooperative level by calling this method before its buffers can be played.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.SetCooperativeLevel(Control,CooperativeLevel) Method (Microsoft.DirectX.DirectSound)

Device.SetCooperativeLevel Method

Sets the cooperative level of the application for this sound device.

Definition

Visual Basic Public Sub SetCooperativeLevel( _
ByVal owner As Control, _
ByVal level As CooperativeLevel _
)
C# public void SetCooperativeLevel(
Control owner,
CooperativeLevel level
);
C++ public:
void SetCooperativeLevel(
Control^ owner,
CooperativeLevel level
);
JScript public function SetCooperativeLevel(
owner : Control,
level : CooperativeLevel
);

Parameters

owner System.Windows.Forms.Control
The System.Windows.Forms.Control Leave Site of the application that is using the Device object.
level Microsoft.DirectX.DirectSound.CooperativeLevel
The requested cooperative level. Specify one of the values shown in the following table

Remarks

The application must set the cooperative level by calling this method before its buffers can be played.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Device.Caps Property (Microsoft.DirectX.DirectSound)

Device.Caps Property

Retrieves the capabilities of the hardware device.

Definition

Visual Basic | Public ReadOnly Property Caps As Caps
C# | public Caps Caps { get; }
C++ public:
property Caps Caps {
Caps get();
}
JScript | public function get Caps() : Caps

Property Value

Microsoft.DirectX.DirectSound.Caps
The capabilities of this sound device.

This property is read-only.

Remarks

Information retrieved in the Caps structure describes the maximum capabilities of the sound device and those currently available, such as the number of hardware mixing channels and the amount of on-board sound memory. You can use this information to fine-tune performance and optimize resource allocation.

Because of resource-sharing requirements, the maximum capabilities in one area might be available only at the cost of another area.

Exceptions

SoundException | Root exception type for all Microsoft DirectSound exceptions. Derives from DirectXException.
ArgumentException Leave Site | An invalid parameter was passed to the called method.


Device.Certified Property (Microsoft.DirectX.DirectSound)

Device.Certified Property

Ascertains whether the device driver is certified for Microsoft DirectX.

Definition

Visual Basic | Public ReadOnly Property Certified As Boolean
C# | public bool Certified { get; }
C++ public:
property bool Certified {
bool get();
}
JScript | public function get Certified() : boolean

Property Value

System.Boolean
Returns true when driver is certified for DirectX; otherwise returns false.

This property is read-only.

Remarks

This method may attempt to retrieve certification information from the Internet.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
UnsupportedException | The function called is not supported at this time.


Device.Disposed Property (Microsoft.DirectX.DirectSound)

Device.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Device.SpeakerConfig Property (Microsoft.DirectX.DirectSound)

Device.SpeakerConfig Property

Retrieves or sets the speaker configuration of the device.

Definition

Visual Basic | Public Property SpeakerConfig As Speakers
C# | public Speakers SpeakerConfig { get; set; }
C++ public:
property Speakers SpeakerConfig {
Speakers get();
void set(Speakers value);
}
JScript public function get SpeakerConfig() : Speakers
public function set SpeakerConfig(Speakers);

Property Value

Microsoft.DirectX.DirectSound.Speakers
The speaker configuration for this device.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
SoundException | Root exception type for all Microsoft DirectSound exceptions. Derives from DirectXException.


Device.Disposing Event (Microsoft.DirectX.DirectSound)

Device.Disposing Event

Occurs when the Dispose method is called or when the Device object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Device.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Device object indicates whether that object has been disposed.


DevicesCollection Class (Microsoft.DirectX.DirectSound)

DevicesCollection Class

Represents a collection of DeviceInformation structures for each available sound device.

Definition

Visual Basic NotInheritable Public Class DevicesCollection
Inherits Object
Implements IEnumerable, IEnumerator
C# | public sealed class DevicesCollection : Object, IEnumerable, IEnumerator
C++ | public ref class DevicesCollection sealed : Object, IEnumerable, IEnumerator
JScript | public final class DevicesCollection extends Object implements IEnumerable, IEnumerator

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DevicesCollection | Initializes a new instance of the DevicesCollection class.
GetEnumerator | Retrieves an enumerator for the DevicesCollection object.
MoveNext | Advances to the next DeviceInformation structure in the DevicesCollection object.
Reset | Sets the DevicesCollection object to its initial position.

Properties

Property | Description
Count | Gets the number of DeviceInformation structures in the DevicesCollection object.
Current | Retrives the element at the current position of the DevicesCollection object's enumeration.
Item | Retrieves a DeviceInformation structure at a particular index.

Inheritance Hierarchy

Object Leave Site
DevicesCollection

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DevicesCollection.DevicesCollection() Constructor (Microsoft.DirectX.DirectSound)

DevicesCollection.DevicesCollection Constructor

Initializes a new instance of the DevicesCollection class.

Definition

Visual Basic | Public Sub New()
C# | public DevicesCollection();
C++ public:
DevicesCollection();
JScript | public function DevicesCollection();


DevicesCollection.GetEnumerator() Method (Microsoft.DirectX.DirectSound)

DevicesCollection.GetEnumerator Method

Retrieves an enumerator for the DevicesCollection object.

Definition

Visual Basic | Overrides Public Function GetEnumerator() As IEnumerator
C# | public override IEnumerator GetEnumerator();
C++ public:
virtual IEnumerator^ GetEnumerator() override;
JScript | public override function GetEnumerator() : IEnumerator;

Return Value

System.Collections.IEnumerator
An enumerator for the DevicesCollection object.


DevicesCollection.MoveNext() Method (Microsoft.DirectX.DirectSound)

DevicesCollection.MoveNext Method

Advances to the next DeviceInformation structure in the DevicesCollection object.

Definition

Visual Basic | Overrides Public Function MoveNext() As Boolean
C# | public override bool MoveNext();
C++ public:
virtual bool MoveNext() override;
JScript | public override function MoveNext() : boolean;

Return Value

System.Boolean
Indicates if DevicesCollection successfully advanced to the next DeviceInformation structure.

Remarks

Returns true if the DevicesCollection object was successfully advanced, and false if the DevicesCollection object has passed the end of the collection.


DevicesCollection.Reset() Method (Microsoft.DirectX.DirectSound)

DevicesCollection.Reset Method

Sets the DevicesCollection object to its initial position.

Definition

Visual Basic | Overrides Public Sub Reset()
C# | public override void Reset();
C++ public:
virtual void Reset() override;
JScript | public override function Reset();

Remarks

The initial position of the DevicesCollection object is before the first DeviceInformation structure.


DevicesCollection.Count Property (Microsoft.DirectX.DirectSound)

DevicesCollection.Count Property

Gets the number of DeviceInformation structures in the DevicesCollection object.

Definition

Visual Basic | Public ReadOnly Property Count As Integer
C# | public int Count { get; }
C++ public:
property int Count {
int get();
}
JScript | public function get Count() : int

Property Value

System.Int32
The number of DeviceInformation structures.

This property is read-only.


DevicesCollection.Current Property (Microsoft.DirectX.DirectSound)

DevicesCollection.Current Property

Retrives the element at the current position of the DevicesCollection object's enumeration.

Definition

Visual Basic | Overrides Public ReadOnly Property Current As Object
C# | public override object Current { get; }
C++ public:
property virtual Object^ Current override {
Object^ get();
}
JScript | public function get Current() : Object

Property Value

System.Object
The current element from the DevicesCollection object's enumeration.

This property is read-only.

Remarks

Since this method has a return value type of Object Leave Site, you must cast it into a DeviceInformation structure to access its properties and method. See the example below:

[C#]
DevicesCollection devices = new DevicesCollection();
while (devices.MoveNext())
{
    DeviceInformation di = (DeviceInformation)devices.Current;
}


DevicesCollection.Item Property (Microsoft.DirectX.DirectSound)

DevicesCollection.Item Property

Retrieves a DeviceInformation structure at a particular index.

Definition

Visual Basic Public ReadOnly Property Item( _
ByVal index As Integer _
) As DeviceInformation
C# public DeviceInformation this[
int index
] { get; }
C++ public:
property DeviceInformation default [int] {
DeviceInformation get(int index);
}
JScript In JScript, you can use indexed properties, but you cannot define your own.

Parameters

index System.Int32
The index of the DeviceInformation structure to retrieve.

Property Value

Microsoft.DirectX.DirectSound.DeviceInformation
The DeviceInformation structure in the DevicesCollection at the index from the index parameter.

This property is read-only.

Remarks

Exceptions
ArgumentOutOfRangeException Leave Site The index parameter is out of range of the collection.


DistortionEffect Class (Microsoft.DirectX.DirectSound)

DistortionEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports distortion.

Definition

Visual Basic Public Class DistortionEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class DistortionEffect : MarshalByRefObject, IDisposable
C++ | public ref class DistortionEffect : MarshalByRefObject, IDisposable
JScript | public class DistortionEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the DistortionEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) EdgeMax | Retrieves the maximum value for the EffectsDistortion.Edge property.
static (Shared in Visual Basic) EdgeMin | Retrieves the minimum value for the EffectsDistortion.Edge property.
static (Shared in Visual Basic) GainMax | Retrieves the maximum value for the EffectsDistortion.Gain property.
static (Shared in Visual Basic) GainMin | Retrieves the minimum value for the EffectsDistortion.Gain property.
static (Shared in Visual Basic) PostEqBandwidthMax | Retrieves the maximum value for the EffectsDistortion.PostEqBandwidth property.
static (Shared in Visual Basic) PostEqBandwidthMin | Retrieves the minimum value for the EffectsDistortion.PostEqBandwidth property.
static (Shared in Visual Basic) PostEqCenterFrequencyMax | Retrieves the maximum value for the EffectsDistortion.PostEqCenterFrequency property.
static (Shared in Visual Basic) PostEqCenterFrequencyMin | Retrieves the minimum value for the EffectsDistortion.PostEqCenterFrequency property.
static (Shared in Visual Basic) PreLowPassCutoffMax | Retrieves the maximum value for the EffectsDistortion.PreLowPassCuttoff property.
static (Shared in Visual Basic) PreLowPassCutoffMin | Retrieves the minimum value for the EffectsDistortion.PreLowPassCutoff property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the DistortionEffect object.
DistortionEffect | Initializes a new instance of the DistortionEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the DistortionEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the DistortionEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets distortion parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
DistortionEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DistortionEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

DistortionEffect.Dispose Method

Immediately releases the unmanaged resources used by the DistortionEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~DistortionEffect();
JScript | public override function Dispose();

See Also

  • DistortionEffect.Disposed
  • DistortionEffect.Disposing


DistortionEffect.DistortionEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

DistortionEffect.DistortionEffect Constructor

Initializes a new instance of the DistortionEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public DistortionEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
DistortionEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function DistortionEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXDistortion8, which allows unmanaged COM clients to create an instance of the managed DistortionEffect class. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the DistortionEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


DistortionEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

DistortionEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


DistortionEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

DistortionEffect.Finalize Method

Allows the DistortionEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~DistortionEffect();
C++ | !DistortionEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


DistortionEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

DistortionEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


DistortionEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

DistortionEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXDistortion8, which allows unmanaged COM clients to create an instance of the managed DistortionEffect class. Not supported.


DistortionEffect.op_Equality(DistortionEffect,DistortionEffect) Method (Microsoft.DirectX.DirectSound)

DistortionEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As DistortionEffect, _
ByVal right As DistortionEffect _
) As Boolean
C# public static bool op_Equality(
DistortionEffect left,
DistortionEffect right
);
C++ public:
static bool operator==(
DistortionEffect^ left,
DistortionEffect^ right
);
JScript public static function op_Equality(
left : DistortionEffect,
right : DistortionEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.DistortionEffect
The DistortionEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.DistortionEffect
The DistortionEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


DistortionEffect.op_Inequality(DistortionEffect,DistortionEffect) Method (Microsoft.DirectX.DirectSound)

DistortionEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As DistortionEffect, _
ByVal right As DistortionEffect _
) As Boolean
C# public static bool op_Inequality(
DistortionEffect left,
DistortionEffect right
);
C++ public:
static bool operator!=(
DistortionEffect^ left,
DistortionEffect^ right
);
JScript public static function op_Inequality(
left : DistortionEffect,
right : DistortionEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.DistortionEffect
The DistortionEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.DistortionEffect
The DistortionEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


DistortionEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

DistortionEffect.raise_Disposing Method

Raises the DistortionEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


DistortionEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

DistortionEffect.AllParameters Property

Retrieves or sets distortion parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsDistortion
C# | public EffectsDistortion AllParameters { get; set; }
C++ public:
property EffectsDistortion AllParameters {
EffectsDistortion get();
void set(EffectsDistortion value);
}
JScript public function get AllParameters() : EffectsDistortion
public function set AllParameters(EffectsDistortion);

Property Value

Microsoft.DirectX.DirectSound.EffectsDistortion
Contains parameters for a distortion effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


DistortionEffect.Disposed Property (Microsoft.DirectX.DirectSound)

DistortionEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


DistortionEffect.EdgeMax Field (Microsoft.DirectX.DirectSound)

DistortionEffect.EdgeMax Field

Retrieves the maximum value for the EffectsDistortion.Edge property.

Definition

Visual Basic | Public Shared EdgeMax As Single
C# | public static Single EdgeMax;
C++ | public: static Single EdgeMax;
JScript | public static var EdgeMax : Single

Field Value

System.Single
Maximum value for the EffectsDistortion.Edge property.

This field is read-only.

See Also

  • EffectsDistortion.Edge


DistortionEffect.EdgeMin Field (Microsoft.DirectX.DirectSound)

DistortionEffect.EdgeMin Field

Retrieves the minimum value for the EffectsDistortion.Edge property.

Definition

Visual Basic | Public Shared EdgeMin As Single
C# | public static Single EdgeMin;
C++ | public: static Single EdgeMin;
JScript | public static var EdgeMin : Single

Field Value

System.Single
Minimum value for the EffectsDistortion.Edge property.

This field is read-only.

See Also

  • EffectsDistortion.Edge


DistortionEffect.GainMax Field (Microsoft.DirectX.DirectSound)

DistortionEffect.GainMax Field

Retrieves the maximum value for the EffectsDistortion.Gain property.

Definition

Visual Basic | Public Shared GainMax As Single
C# | public static Single GainMax;
C++ | public: static Single GainMax;
JScript | public static var GainMax : Single

Field Value

System.Single
Maximum value for the EffectsDistortion.Gain property.

This field is read-only.

See Also

  • EffectsDistortion.Gain


DistortionEffect.GainMin Field (Microsoft.DirectX.DirectSound)

DistortionEffect.GainMin Field

Retrieves the minimum value for the EffectsDistortion.Gain property.

Definition

Visual Basic | Public Shared GainMin As Single
C# | public static Single GainMin;
C++ | public: static Single GainMin;
JScript | public static var GainMin : Single

Field Value

System.Single
Minimum value for the EffectsDistortion.Gain property.

This field is read-only.

See Also

  • EffectsDistortion.Gain


DistortionEffect.PostEqBandwidthMax Field (Microsoft.DirectX.DirectSound)

DistortionEffect.PostEqBandwidthMax Field

Retrieves the maximum value for the EffectsDistortion.PostEqBandwidth property.

Definition

Visual Basic | Public Shared PostEqBandwidthMax As Single
C# | public static Single PostEqBandwidthMax;
C++ | public: static Single PostEqBandwidthMax;
JScript | public static var PostEqBandwidthMax : Single

Field Value

System.Single
Maximum value for the EffectsDistortion.PostEqBandwidth property.

This field is read-only.

See Also

  • EffectsDistortion.PostEqBandwidth


DistortionEffect.PostEqBandwidthMin Field (Microsoft.DirectX.DirectSound)

DistortionEffect.PostEqBandwidthMin Field

Retrieves the minimum value for the EffectsDistortion.PostEqBandwidth property.

Definition

Visual Basic | Public Shared PostEqBandwidthMin As Single
C# | public static Single PostEqBandwidthMin;
C++ | public: static Single PostEqBandwidthMin;
JScript | public static var PostEqBandwidthMin : Single

Field Value

System.Single
Minimum value for the EffectsDistortion.PostEqBandwidth property.

This field is read-only.

See Also

  • EffectsDistortion.PostEqBandwidth


DistortionEffect.PostEqCenterFrequencyMax Field (Microsoft.DirectX.DirectSound)

DistortionEffect.PostEqCenterFrequencyMax Field

Retrieves the maximum value for the EffectsDistortion.PostEqCenterFrequency property.

Definition

Visual Basic | Public Shared PostEqCenterFrequencyMax As Single
C# | public static Single PostEqCenterFrequencyMax;
C++ | public: static Single PostEqCenterFrequencyMax;
JScript | public static var PostEqCenterFrequencyMax : Single

Field Value

System.Single
Maximum value for the EffectsDistortion.PostEqCenterFrequency property.

This field is read-only.

See Also

  • EffectsDistortion.PostEqCenterFrequency


DistortionEffect.PostEqCenterFrequencyMin Field (Microsoft.DirectX.DirectSound)

DistortionEffect.PostEqCenterFrequencyMin Field

Retrieves the minimum value for the EffectsDistortion.PostEqCenterFrequency property.

Definition

Visual Basic | Public Shared PostEqCenterFrequencyMin As Single
C# | public static Single PostEqCenterFrequencyMin;
C++ | public: static Single PostEqCenterFrequencyMin;
JScript | public static var PostEqCenterFrequencyMin : Single

Field Value

System.Single
Minimum value for the EffectsDistortion.PostEqCenterFrequency property.

This field is read-only.

See Also

  • EffectsDistortion.PostEqCenterFrequency


DistortionEffect.PreLowPassCutoffMax Field (Microsoft.DirectX.DirectSound)

DistortionEffect.PreLowPassCutoffMax Field

Retrieves the maximum value for the EffectsDistortion.PreLowPassCuttoff property.

Definition

Visual Basic | Public Shared PreLowPassCutoffMax As Single
C# | public static Single PreLowPassCutoffMax;
C++ | public: static Single PreLowPassCutoffMax;
JScript | public static var PreLowPassCutoffMax : Single

Field Value

System.Single
Maximum value for the EffectsDistortion.PreLowPassCutoff property.

This field is read-only.

See Also

  • EffectsDistortion.PreLowPassCutoff


DistortionEffect.PreLowPassCutoffMin Field (Microsoft.DirectX.DirectSound)

DistortionEffect.PreLowPassCutoffMin Field

Retrieves the minimum value for the EffectsDistortion.PreLowPassCutoff property.

Definition

Visual Basic | Public Shared PreLowPassCutoffMin As Single
C# | public static Single PreLowPassCutoffMin;
C++ | public: static Single PreLowPassCutoffMin;
JScript | public static var PreLowPassCutoffMin : Single

Field Value

System.Single
Minimum value for the EffectsDistortion.PreLowPassCutoff property.

This field is read-only.

See Also

  • EffectsDistortion.PreLowPassCutoff


DistortionEffect.Disposing Event (Microsoft.DirectX.DirectSound)

DistortionEffect.Disposing Event

Occurs when the Dispose method is called or when the DistortionEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the DistortionEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the DistortionEffect object indicates whether that object has been disposed.


DSoundHelper Class (Microsoft.DirectX.DirectSound)

DSoundHelper Class

Contains helper methods and fields for Microsoft DirectSound.

Definition

Visual Basic NotInheritable MustInherit Public Class DSoundHelper
Inherits Object
C# | public abstract sealed class DSoundHelper : Object
C++ | public ref class DSoundHelper abstract sealed : Object
JScript | public final abstract class DSoundHelper extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) CaptureEffectsClassAcousticEchoCancellation | Retrieves the GUID class identifier for the acoustic echo cancellation capture effect.
static (Shared in Visual Basic) CaptureEffectsClassNoiseSuppression | Retrieves the GUID class identifier for the noise suppression capture effect.
static (Shared in Visual Basic) CaptureEffectsMsAcousticEchoCancellation | Retrieves the GUID class identifier for the Microsoft acoustic echo cancellation capture effect.
static (Shared in Visual Basic) CaptureEffectsMsNoiseSuppression | Retrieves the GUID class identifier for the Microsoft noise suppression capture effect.
static (Shared in Visual Basic) CaptureEffectsSystemAcousticEchoCancellation | Retrieves the GUID class identifier for the system acoustic echo cancellation capture effect.
static (Shared in Visual Basic) CaptureEffectsSystemNoiseSuppression | Retrieves the GUID class identifier for the system noise suppression capture effect.
static (Shared in Visual Basic) DefaultCaptureDevice | Retrieves the GUID for the system-wide default audio capture device.
static (Shared in Visual Basic) DefaultConeAngle | Retrieves the default cone angle for an Angles structure, in degrees.
static (Shared in Visual Basic) DefaultConeOutsideVolume | Retrieves the default outside cone angle for an Angles structure, in degrees.
static (Shared in Visual Basic) DefaultDistanceFactor | Retrieves the default distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.
static (Shared in Visual Basic) DefaultDopplerFactor | Retrieves the default ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.
static (Shared in Visual Basic) DefaultMaxDistance | Retrieves the default maximum distance used by the Buffer3D.MaxDistance and Buffer3DSettings.MaxDistance properties, in meters.
static (Shared in Visual Basic) DefaultMinDistance | Retrieves the default minimum distance used by the Buffer3D.MinDistance and Buffer3DSettings.MinDistance properties, in meters.
static (Shared in Visual Basic) DefaultPlaybackDevice | Retrieves the GUID for the system-wide default audio playback device.
static (Shared in Visual Basic) DefaultRolloffFactor | Retrieves the default ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.
static (Shared in Visual Basic) DefaultVoiceCaptureDevice | Retrieves the GUID for the default voice capture device.
static (Shared in Visual Basic) DefaultVoicePlaybackDevice | Retrieves the GUID for the default voice playback device.
static (Shared in Visual Basic) Guid3DAlgorithmDefault | Retrieves the default 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.
static (Shared in Visual Basic) Guid3DAlgorithmHrtfFull | Retrieves the high quality 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.
static (Shared in Visual Basic) Guid3DAlgorithmHrtfLight | Retrieves the efficient 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.
static (Shared in Visual Basic) Guid3DAlgorithmNoVirtualization | Retrieves the 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property that is mapped onto normal left and right stereo panning.
static (Shared in Visual Basic) GuidAllObjects | Retrieves the GUID that can represent any DirectSound effect class identifier.
static (Shared in Visual Basic) Interface3DBuffer | Retrieves the GUID for the Buffer3D interface.
static (Shared in Visual Basic) Interface3DListener | Retrieves the GUID for the Listener3D interface.
static (Shared in Visual Basic) InterfaceBuffer | Retrieves the GUID for the Buffer interface.
static (Shared in Visual Basic) InterfaceCaptureBuffer | Retrieves the GUID for the CaptureBuffer interface.
static (Shared in Visual Basic) InterfaceCaptureEffectsAcousticEchoCancellation | Retrieves the GUID for the acoustic echo cancellation capture effect interface.
static (Shared in Visual Basic) InterfaceCaptureEffectsNoiseSuppress | Retrieves the GUID for the noise suppression capture effect interface.
static (Shared in Visual Basic) InterfaceDirectSound | Retrieves the GUID for the Microsoft.DirectX.DirectSound interface.
static (Shared in Visual Basic) InterfaceDirectSoundCapture | Retrieves the GUID for the Capture interface.
static (Shared in Visual Basic) InterfaceEffectsChorus | Retrieves the GUID for the chorus effect interface.
static (Shared in Visual Basic) InterfaceEffectsCompressor | Retrieves the GUID for the compressor effect interface.
static (Shared in Visual Basic) InterfaceEffectsDistortion | Retrieves the GUID for the distortion effect interface.
static (Shared in Visual Basic) InterfaceEffectsEcho | Retrieves the GUID for the echo effect interface.
static (Shared in Visual Basic) InterfaceEffectsFlanger | Retrieves the GUID for the flanger effect interface.
static (Shared in Visual Basic) InterfaceEffectsGargle | Retrieves the GUID for the gargle effect interface.
static (Shared in Visual Basic) InterfaceEffectsInteractive3DLevel2Reverb | Retrieves the GUID for the interactive 3-D level2 reverb effect interface.
static (Shared in Visual Basic) InterfaceEffectsParamEq | Retrieves the GUID for the parameteric equalizer effect interface.
static (Shared in Visual Basic) InterfaceEffectsWavesReverb | Retrieves the GUID for the Waves reverb effect interface.
static (Shared in Visual Basic) InterfaceNotify | Retrieves the GUID for the Notify interface.
static (Shared in Visual Basic) InterfaceSecondaryBuffer | Retrieves the GUID for the SecondaryBuffer interface.
static (Shared in Visual Basic) MaxConeAngle | Retrieves the maximum cone angle for an Angles structure, in degrees.
static (Shared in Visual Basic) MaxDistanceFactor | Retrieves the maximum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.
static (Shared in Visual Basic) MaxDopplerFactor | Retrieves the maximum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.
static (Shared in Visual Basic) MaxRolloffFactor | Retrieves the maximum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.
static (Shared in Visual Basic) MinConeAngle | Retrieves the minimum cone angle for an Angles structure, in degrees.
static (Shared in Visual Basic) MinDistanceFactor | Retrieves the minimum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.
static (Shared in Visual Basic) MinDopplerFactor | Retrieves the minimum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.
static (Shared in Visual Basic) MinRolloffFactor | Retrieves the minimum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.
static (Shared in Visual Basic) StandardChorusGuid | Retrieves the GUID class identifier for the chorus effect.
static (Shared in Visual Basic) StandardCompressorGuid | Retrieves the GUID class identifier for the compressor effect.
static (Shared in Visual Basic) StandardDistortionGuid | Retrieves the GUID class identifier for the distortion effect.
static (Shared in Visual Basic) StandardEchoGuid | Retrieves the GUID class identifier for the echo effect.
static (Shared in Visual Basic) StandardFlangerGuid | Retrieves the GUID class identifier for the flanger effect.
static (Shared in Visual Basic) StandardGargleGuid | Retrieves the GUID class identifier for the gargle effect.
static (Shared in Visual Basic) StandardInteractive3DLevel2ReverbGuid | Retrieves the GUID class identifier for the interactive 3-D level2 reverb effect.
static (Shared in Visual Basic) StandardParamEqGuid | Retrieves the GUID class identifier for the parameteric equalizer effect.
static (Shared in Visual Basic) StandardWavesReverbGuid | Retrieves the GUID class identifier for the Waves reverb effect.

Methods

Method | Description
static (Shared in Visual Basic) GetObjectFromInterfaceGuid | Retrieves an object based on an interface globally unique identifier (GUID).

Inheritance Hierarchy

Object Leave Site
DSoundHelper

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DSoundHelper.GetObjectFromInterfaceGuid(IntPtr,Guid,Object) Method (Microsoft.DirectX.DirectSound)

DSoundHelper.GetObjectFromInterfaceGuid Method

Retrieves an object based on an interface globally unique identifier (GUID).

Definition

Visual Basic Public Shared Function GetObjectFromInterfaceGuid( _
ByVal lpVal As IntPtr, _
ByVal iid As Guid, _
ByVal source As Object _
) As Object
C# public static object GetObjectFromInterfaceGuid(
IntPtr lpVal,
Guid iid,
object source
);
C++ public:
static Object^ GetObjectFromInterfaceGuid(
IntPtr lpVal,
Guid iid,
Object^ source
);
JScript public static function GetObjectFromInterfaceGuid(
lpVal : IntPtr,
iid : Guid,
source : Object
) : Object;

Parameters

lpVal System.IntPtr
The pointer to the unmanaged Component Object Model (COM) interface of the requested object.
iid System.Guid
The interface GUID of the requested object.
source System.Object
The parent object of the requested object (see Remarks).

Return Value

System.Object
Returns the object that is requested.

Remarks

The source parameter is the requested object's parent object. As an example, if you are requesting a SecondaryBuffer object, you would pass the Device object to this method using the source parameter.


DSoundHelper.CaptureEffectsClassAcousticEchoCancellation Field (Microsoft.DirectX.DirectSound)

DSoundHelper.CaptureEffectsClassAcousticEchoCancellation Field

 Language:

Retrieves the globally unique identifier (GUID) class identifier for the acoustic echo cancellation capture effect.

Definition

Visual Basic | Public Shared CaptureEffectsClassAcousticEchoCancellation As Guid
C# | public static Guid CaptureEffectsClassAcousticEchoCancellation;
C++ | public: static Guid CaptureEffectsClassAcousticEchoCancellation;
JScript | public static var CaptureEffectsClassAcousticEchoCancellation : Guid

Field Value

System.Guid
Returns the GUID class identifier for the acoustic echo cancellation capture effect.

This field is read-only.

Remarks

This GUID is used by the CaptureEffectDescription structure to set the acoustic echo cancellation capture effect to a CaptureBuffer object.

Once the acoustic echo cancellation capture effect is set to a CaptureBuffer object, the CaptureAcousticEchoCancellationEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsClassNoiseSuppression Field (Microsoft.DirectX.DirectSound)

DSoundHelper.CaptureEffectsClassNoiseSuppression Field

Retrieves the globally unique identifier (GUID) class identifier for the noise suppression capture effect.

Definition

Visual Basic | Public Shared CaptureEffectsClassNoiseSuppression As Guid
C# | public static Guid CaptureEffectsClassNoiseSuppression;
C++ | public: static Guid CaptureEffectsClassNoiseSuppression;
JScript | public static var CaptureEffectsClassNoiseSuppression : Guid

Field Value

System.Guid
Returns the GUID class identifier for the noise suppression capture effect.

This field is read-only.

Remarks

This GUID is used by the CaptureEffectDescription structure to set the noise suppression capture effect to a CaptureBuffer object.

Once the noise suppression capture effect is set to a CaptureBuffer object, the CaptureNoiseSuppressEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsMsAcousticEchoCancellation Field (Microsoft.DirectX.DirectSound)

DSoundHelper.CaptureEffectsMsAcousticEchoCancellation Field

Retrieves the globally unique identifier (GUID) class identifier for the Microsoft acoustic echo cancellation capture effect.

Definition

Visual Basic | Public Shared CaptureEffectsMsAcousticEchoCancellation As Guid
C# | public static Guid CaptureEffectsMsAcousticEchoCancellation;
C++ | public: static Guid CaptureEffectsMsAcousticEchoCancellation;
JScript | public static var CaptureEffectsMsAcousticEchoCancellation : Guid

Field Value

System.Guid
Returns the GUID class identifier for the Microsoft acoustic echo cancellation capture effect.

This field is read-only.

Remarks

This GUID is used by the CaptureEffectDescription structure to set the Microsoft acoustic echo cancellation capture effect to a CaptureBuffer object.

Once the Microsoft acoustic echo cancellation capture effect is set to a CaptureBuffer object, the CaptureAcousticEchoCancellationEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsMsNoiseSuppression Field (Microsoft.DirectX.DirectSound)

DSoundHelper.CaptureEffectsMsNoiseSuppression Field

Retrieves the globally unique identifier (GUID) class identifier for the Microsoft noise suppression capture effect.

Definition

Visual Basic | Public Shared CaptureEffectsMsNoiseSuppression As Guid
C# | public static Guid CaptureEffectsMsNoiseSuppression;
C++ | public: static Guid CaptureEffectsMsNoiseSuppression;
JScript | public static var CaptureEffectsMsNoiseSuppression : Guid

Field Value

System.Guid
Returns the GUID class identifier for the Microsoft noise suppression capture effect.

This field is read-only.

Remarks

This GUID is used by the CaptureEffectDescription structure to set the Microsoft noise suppression capture effect to a CaptureBuffer object.

Once the Microsoft noise suppression capture effect is set to a CaptureBuffer object, the CaptureNoiseSuppressEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsSystemAcousticEchoCancellation Field (Microsoft.DirectX.DirectSound)

DSoundHelper.CaptureEffectsSystemAcousticEchoCancellation Field

 Language:

Retrieves the globally unique identifier (GUID) class identifier for the system acoustic echo cancellation capture effect.

Definition

Visual Basic | Public Shared CaptureEffectsSystemAcousticEchoCancellation As Guid
C# | public static Guid CaptureEffectsSystemAcousticEchoCancellation;
C++ | public: static Guid CaptureEffectsSystemAcousticEchoCancellation;
JScript | public static var CaptureEffectsSystemAcousticEchoCancellation : Guid

Field Value

System.Guid
Returns the GUID class identifier for the system acoustic echo cancellation capture effect.

This field is read-only.

Remarks

This GUID is used by the CaptureEffectDescription structure to set the system acoustic echo cancellation capture effect to a CaptureBuffer object.

Once the system acoustic echo cancellation capture effect is set to a CaptureBuffer object, the CaptureAcousticEchoCancellationEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.CaptureEffectsSystemNoiseSuppression Field (Microsoft.DirectX.DirectSound)

DSoundHelper.CaptureEffectsSystemNoiseSuppression Field

Retrieves the globally unique identifier (GUID) class identifier for the system noise suppression capture effect.

Definition

Visual Basic | Public Shared CaptureEffectsSystemNoiseSuppression As Guid
C# | public static Guid CaptureEffectsSystemNoiseSuppression;
C++ | public: static Guid CaptureEffectsSystemNoiseSuppression;
JScript | public static var CaptureEffectsSystemNoiseSuppression : Guid

Field Value

System.Guid
Returns the GUID class identifier for the system noise suppression capture effect.

This field is read-only.

Remarks

This GUID is used by the CaptureEffectDescription structure to set the system noise suppression capture effect to a CaptureBuffer object.

Once the system noise suppression capture effect is set to a CaptureBuffer object, the CaptureNoiseSuppressEffect object can be retrieved using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.DefaultCaptureDevice Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultCaptureDevice Field

Retrieves the globally unique identifier (GUID) for the system-wide default audio capture device.

Definition

Visual Basic | Public Shared DefaultCaptureDevice As Guid
C# | public static Guid DefaultCaptureDevice;
C++ | public: static Guid DefaultCaptureDevice;
JScript | public static var DefaultCaptureDevice : Guid

Field Value

System.Guid
Returns the GUID for the system-wide default audio capture device.

This field is read-only.


DSoundHelper.DefaultConeAngle Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultConeAngle Field

Retrieves the default cone angle for an Angles structure, in degrees.

Definition

Visual Basic | Public Shared DefaultConeAngle As Single
C# | public static Single DefaultConeAngle;
C++ | public: static Single DefaultConeAngle;
JScript | public static var DefaultConeAngle : Single

Field Value

System.Single
Returns the default cone angle for an Angles structure, in degrees.

This field is read-only.


DSoundHelper.DefaultConeOutsideVolume Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultConeOutsideVolume Field

Retrieves the default outside cone angle for an Angles structure, in degrees.

Definition

Visual Basic | Public Shared DefaultConeOutsideVolume As Int32
C# | public static Int32 DefaultConeOutsideVolume;
C++ | public: static Int32 DefaultConeOutsideVolume;
JScript | public static var DefaultConeOutsideVolume : Int32

Field Value

System.Int32
Returns the default outside cone angle for an Angles structure, in degrees.

This field is read-only.


DSoundHelper.DefaultDistanceFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultDistanceFactor Field

Retrieves the default distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

Definition

Visual Basic | Public Shared DefaultDistanceFactor As Single
C# | public static Single DefaultDistanceFactor;
C++ | public: static Single DefaultDistanceFactor;
JScript | public static var DefaultDistanceFactor : Single

Field Value

System.Single
Returns the default distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

This field is read-only.


DSoundHelper.DefaultDopplerFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultDopplerFactor Field

Retrieves the default ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

Definition

Visual Basic | Public Shared DefaultDopplerFactor As Single
C# | public static Single DefaultDopplerFactor;
C++ | public: static Single DefaultDopplerFactor;
JScript | public static var DefaultDopplerFactor : Single

Field Value

System.Single
Returns the default ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

This field is read-only.


DSoundHelper.DefaultMaxDistance Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultMaxDistance Field

Retrieves the default maximum distance used by the Buffer3D.MaxDistance and Buffer3DSettings.MaxDistance properties, in meters.

Definition

Visual Basic | Public Shared DefaultMaxDistance As Single
C# | public static Single DefaultMaxDistance;
C++ | public: static Single DefaultMaxDistance;
JScript | public static var DefaultMaxDistance : Single

Field Value

System.Single
Returns the default maximum distance used by the Buffer3D.MaxDistance and Buffer3DSettings.MaxDistance properties, in meters.

This field is read-only.


DSoundHelper.DefaultMinDistance Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultMinDistance Field

Retrieves the default minimum distance used by the Buffer3D.MinDistance and Buffer3DSettings.MinDistance properties, in meters.

Definition

Visual Basic | Public Shared DefaultMinDistance As Single
C# | public static Single DefaultMinDistance;
C++ | public: static Single DefaultMinDistance;
JScript | public static var DefaultMinDistance : Single

Field Value

System.Single
Returns the default minimum distance used by the Buffer3D.MinDistance and Buffer3DSettings.MinDistance properties, in meters.

This field is read-only.


DSoundHelper.DefaultPlaybackDevice Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultPlaybackDevice Field

Retrieves the globally unique identifier (GUID) for the system-wide default audio playback device.

Definition

Visual Basic | Public Shared DefaultPlaybackDevice As Guid
C# | public static Guid DefaultPlaybackDevice;
C++ | public: static Guid DefaultPlaybackDevice;
JScript | public static var DefaultPlaybackDevice : Guid

Field Value

System.Guid
Returns the GUID for the system-wide default audio playback device.

This field is read-only.


DSoundHelper.DefaultRolloffFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultRolloffFactor Field

Retrieves the default ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

Definition

Visual Basic | Public Shared DefaultRolloffFactor As Single
C# | public static Single DefaultRolloffFactor;
C++ | public: static Single DefaultRolloffFactor;
JScript | public static var DefaultRolloffFactor : Single

Field Value

System.Single
Returns the default ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

This field is read-only.


DSoundHelper.DefaultVoiceCaptureDevice Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultVoiceCaptureDevice Field

Retrieves the globally unique identifier (GUID) for the default voice capture device.

Definition

Visual Basic | Public Shared DefaultVoiceCaptureDevice As Guid
C# | public static Guid DefaultVoiceCaptureDevice;
C++ | public: static Guid DefaultVoiceCaptureDevice;
JScript | public static var DefaultVoiceCaptureDevice : Guid

Field Value

System.Guid
Returns the GUID for the default voice capture device.

This field is read-only.


DSoundHelper.DefaultVoicePlaybackDevice Field (Microsoft.DirectX.DirectSound)

DSoundHelper.DefaultVoicePlaybackDevice Field

Retrieves the globally unique identifier (GUID) for the default voice playback device.

Definition

Visual Basic | Public Shared DefaultVoicePlaybackDevice As Guid
C# | public static Guid DefaultVoicePlaybackDevice;
C++ | public: static Guid DefaultVoicePlaybackDevice;
JScript | public static var DefaultVoicePlaybackDevice : Guid

Field Value

System.Guid
Returns the GUID for the default playback capture device.

This field is read-only.


DSoundHelper.Guid3DAlgorithmDefault Field (Microsoft.DirectX.DirectSound)

DSoundHelper.Guid3DAlgorithmDefault Field

Retrieves the default 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

Definition

Visual Basic | Public Shared Guid3DAlgorithmDefault As Guid
C# | public static Guid Guid3DAlgorithmDefault;
C++ | public: static Guid Guid3DAlgorithmDefault;
JScript | public static var Guid3DAlgorithmDefault : Guid

Field Value

System.Guid
Returns the default 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

This field is read-only.


DSoundHelper.Guid3DAlgorithmHrtfFull Field (Microsoft.DirectX.DirectSound)

DSoundHelper.Guid3DAlgorithmHrtfFull Field

Retrieves the high quality 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

Definition

Visual Basic | Public Shared Guid3DAlgorithmHrtfFull As Guid
C# | public static Guid Guid3DAlgorithmHrtfFull;
C++ | public: static Guid Guid3DAlgorithmHrtfFull;
JScript | public static var Guid3DAlgorithmHrtfFull : Guid

Field Value

System.Guid
Returns the high quality 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

This field is read-only.

Remarks

This algorithm gives the highest quality 3-D audio effect, but uses more CPU cycles than the other 3-D algorithms..


DSoundHelper.Guid3DAlgorithmHrtfLight Field (Microsoft.DirectX.DirectSound)

DSoundHelper.Guid3DAlgorithmHrtfLight Field

Retrieves the efficient 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

Definition

Visual Basic | Public Shared Guid3DAlgorithmHrtfLight As Guid
C# | public static Guid Guid3DAlgorithmHrtfLight;
C++ | public: static Guid Guid3DAlgorithmHrtfLight;
JScript | public static var Guid3DAlgorithmHrtfLight : Guid

Field Value

System.Guid
Returns the efficient 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property.

This field is read-only.

Remarks

This algorithm gives a good 3-D audio effect, but uses fewer CPU cycles than the other 3-D algorithms.


DSoundHelper.Guid3DAlgorithmNoVirtualization Field (Microsoft.DirectX.DirectSound)

DSoundHelper.Guid3DAlgorithmNoVirtualization Field

Retrieves the 3-D algorithm used by the BufferDescription.Guid3DAlgorithm property that is mapped onto normal left and right stereo panning.

Definition

Visual Basic | Public Shared Guid3DAlgorithmNoVirtualization As Guid
C# | public static Guid Guid3DAlgorithmNoVirtualization;
C++ | public: static Guid Guid3DAlgorithmNoVirtualization;
JScript | public static var Guid3DAlgorithmNoVirtualization : Guid

Field Value

System.Guid
Returns the efficient 3-D algorithm used by the BufferDescription.Guid3DAlgorithm that is mapped onto normal left and right stereo panning.

This field is read-only.

Remarks

At 90 degrees to the left, the sound is coming out of only the left speaker; at 90 degrees to the right, sound is coming out of only the right speaker. The vertical axis is ignored except for scaling of volume due to distance. Doppler shift and volume scaling are still applied, but the 3-D filtering is not performed on this buffer.

This is the most efficient software implementation, but provides no virtual 3-D audio effect.


DSoundHelper.GuidAllObjects Field (Microsoft.DirectX.DirectSound)

DSoundHelper.GuidAllObjects Field

Retrieves the globally unique identifier (GUID) that can represent any Microsoft DirectSound effect class identifier.

Definition

Visual Basic | Public Shared GuidAllObjects As Guid
C# | public static Guid GuidAllObjects;
C++ | public: static Guid GuidAllObjects;
JScript | public static var GuidAllObjects : Guid

Field Value

System.Guid
Returns the GUID that can represent any DirectSound effect class identifier.

This field is read-only.

Remarks

This GUID can be used for any class identifier when retrieving an effect using either the SecondaryBuffer.GetObjectInPath or CaptureBuffer.GetObjectInPath methods.


DSoundHelper.Interface3DBuffer Field (Microsoft.DirectX.DirectSound)

DSoundHelper.Interface3DBuffer Field

Retrieves the globally unique identifier (GUID) for the Buffer3D interface.

Definition

Visual Basic | Public Shared Interface3DBuffer As Guid
C# | public static Guid Interface3DBuffer;
C++ | public: static Guid Interface3DBuffer;
JScript | public static var Interface3DBuffer : Guid

Field Value

System.Guid
Returns the GUID for the Buffer3D interface.

This field is read-only.


DSoundHelper.Interface3DListener Field (Microsoft.DirectX.DirectSound)

DSoundHelper.Interface3DListener Field

Retrieves the globally unique identifier (GUID) for the Listener3D interface.

Definition

Visual Basic | Public Shared Interface3DListener As Guid
C# | public static Guid Interface3DListener;
C++ | public: static Guid Interface3DListener;
JScript | public static var Interface3DListener : Guid

Field Value

System.Guid
Returns the GUID for the Listener3D interface.

This field is read-only.


DSoundHelper.InterfaceBuffer Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceBuffer Field

Retrieves the globally unique identifier (GUID) for the Buffer interface.

Definition

Visual Basic | Public Shared InterfaceBuffer As Guid
C# | public static Guid InterfaceBuffer;
C++ | public: static Guid InterfaceBuffer;
JScript | public static var InterfaceBuffer : Guid

Field Value

System.Guid
Returns the GUID for the Buffer interface.

This field is read-only.


DSoundHelper.InterfaceCaptureBuffer Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceCaptureBuffer Field

Retrieves the globally unique identifier (GUID) for the CaptureBuffer interface.

Definition

Visual Basic | Public Shared InterfaceCaptureBuffer As Guid
C# | public static Guid InterfaceCaptureBuffer;
C++ | public: static Guid InterfaceCaptureBuffer;
JScript | public static var InterfaceCaptureBuffer : Guid

Field Value

System.Guid
Returns the GUID for the CaptureBuffer interface.

This field is read-only.


DSoundHelper.InterfaceCaptureEffectsAcousticEchoCancellation Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceCaptureEffectsAcousticEchoCancellation Field

 Language:

Retrieves the globally unique identifier (GUID) for the acoustic echo cancellation capture effect interface.

Definition

Visual Basic | Public Shared InterfaceCaptureEffectsAcousticEchoCancellation As Guid
C# | public static Guid InterfaceCaptureEffectsAcousticEchoCancellation;
C++ | public: static Guid InterfaceCaptureEffectsAcousticEchoCancellation;
JScript | public static var InterfaceCaptureEffectsAcousticEchoCancellation : Guid

Field Value

System.Guid
Returns the GUID for the acoustic echo cancellation capture effect interface.

This field is read-only.

Remarks

This field is used to retrieve the CaptureAcousticEchoCancellationEffect object, that currently in a CaptureBuffer object, using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.InterfaceCaptureEffectsNoiseSuppress Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceCaptureEffectsNoiseSuppress Field

Retrieves the globally unique identifier (GUID) for the noise suppression capture effect interface.

Definition

Visual Basic | Public Shared InterfaceCaptureEffectsNoiseSuppress As Guid
C# | public static Guid InterfaceCaptureEffectsNoiseSuppress;
C++ | public: static Guid InterfaceCaptureEffectsNoiseSuppress;
JScript | public static var InterfaceCaptureEffectsNoiseSuppress : Guid

Field Value

System.Guid
Returns the GUID for the noise suppression capture effect interface.

This field is read-only.

Remarks

This field is used to retrieve the CaptureNoiseSuppressEffect object, that currently in a CaptureBuffer object, using the CaptureBuffer.GetObjectInPath method.


DSoundHelper.InterfaceDirectSound Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceDirectSound Field

Retrieves the globally unique identifier (GUID) for the Microsoft.DirectX.DirectSound interface.

Definition

Visual Basic | Public Shared InterfaceDirectSound As Guid
C# | public static Guid InterfaceDirectSound;
C++ | public: static Guid InterfaceDirectSound;
JScript | public static var InterfaceDirectSound : Guid

Field Value

System.Guid
Returns the GUID for the Microsoft.DirectX.DirectSound interface.

This field is read-only.


DSoundHelper.InterfaceDirectSoundCapture Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceDirectSoundCapture Field

Retrieves the globally unique identifier (GUID) for the Capture interface.

Definition

Visual Basic | Public Shared InterfaceDirectSoundCapture As Guid
C# | public static Guid InterfaceDirectSoundCapture;
C++ | public: static Guid InterfaceDirectSoundCapture;
JScript | public static var InterfaceDirectSoundCapture : Guid

Field Value

System.Guid
Returns the GUID for the Capture interface.

This field is read-only.


DSoundHelper.InterfaceEffectsChorus Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsChorus Field

Retrieves the globally unique identifier (GUID) for the chorus effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsChorus As Guid
C# | public static Guid InterfaceEffectsChorus;
C++ | public: static Guid InterfaceEffectsChorus;
JScript | public static var InterfaceEffectsChorus : Guid

Field Value

System.Guid
Returns the GUID for the chorus effect interface.

This field is read-only.

Remarks

This field is used to retrieve the ChorusEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsCompressor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsCompressor Field

Retrieves the globally unique identifier (GUID) for the compressor effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsCompressor As Guid
C# | public static Guid InterfaceEffectsCompressor;
C++ | public: static Guid InterfaceEffectsCompressor;
JScript | public static var InterfaceEffectsCompressor : Guid

Field Value

System.Guid
Returns the GUID for the compressor effect interface.

This field is read-only.

Remarks

This field is used to retrieve the CompressorEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsDistortion Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsDistortion Field

Retrieves the globally unique identifier (GUID) for the distortion effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsDistortion As Guid
C# | public static Guid InterfaceEffectsDistortion;
C++ | public: static Guid InterfaceEffectsDistortion;
JScript | public static var InterfaceEffectsDistortion : Guid

Field Value

System.Guid
Returns the GUID for the distortion effect interface.

This field is read-only.

Remarks

This field is used to retrieve the DistortionEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsEcho Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsEcho Field

Retrieves the globally unique identifier (GUID) for the echo effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsEcho As Guid
C# | public static Guid InterfaceEffectsEcho;
C++ | public: static Guid InterfaceEffectsEcho;
JScript | public static var InterfaceEffectsEcho : Guid

Field Value

System.Guid
Returns the GUID for the echo effect interface.

This field is read-only.

Remarks

This field is used to retrieve the EchoEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsFlanger Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsFlanger Field

Retrieves the globally unique identifier (GUID) for the flanger effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsFlanger As Guid
C# | public static Guid InterfaceEffectsFlanger;
C++ | public: static Guid InterfaceEffectsFlanger;
JScript | public static var InterfaceEffectsFlanger : Guid

Field Value

System.Guid
Returns the GUID for the flanger effect interface.

This field is read-only.

Remarks

This field is used to retrieve the FlangerEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsGargle Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsGargle Field

Retrieves the globally unique identifier (GUID) for the gargle effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsGargle As Guid
C# | public static Guid InterfaceEffectsGargle;
C++ | public: static Guid InterfaceEffectsGargle;
JScript | public static var InterfaceEffectsGargle : Guid

Field Value

System.Guid
Returns the GUID for the gargle effect interface.

This field is read-only.

Remarks

This field is used to retrieve the GargleEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsInteractive3DLevel2Reverb Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsInteractive3DLevel2Reverb Field

Retrieves the globally unique identifier (GUID) for the interactive 3-D level2 reverb effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsInteractive3DLevel2Reverb As Guid
C# | public static Guid InterfaceEffectsInteractive3DLevel2Reverb;
C++ | public: static Guid InterfaceEffectsInteractive3DLevel2Reverb;
JScript | public static var InterfaceEffectsInteractive3DLevel2Reverb : Guid

Field Value

System.Guid
Returns the GUID for the interactive 3-D level2 reverb effect interface.

This field is read-only.

Remarks

This field is used to retrieve the Interactive3DLevel2ReverbEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsParamEq Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsParamEq Field

Retrieves the globally unique identifier (GUID) for the parameteric equalizer effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsParamEq As Guid
C# | public static Guid InterfaceEffectsParamEq;
C++ | public: static Guid InterfaceEffectsParamEq;
JScript | public static var InterfaceEffectsParamEq : Guid

Field Value

System.Guid
Returns the GUID for the parameteric equalizer effect interface.

This field is read-only.

Remarks

This field is used to retrieve the ParamEqEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceEffectsWavesReverb Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceEffectsWavesReverb Field

Retrieves the globally unique identifier (GUID) for the Waves reverb effect interface.

Definition

Visual Basic | Public Shared InterfaceEffectsWavesReverb As Guid
C# | public static Guid InterfaceEffectsWavesReverb;
C++ | public: static Guid InterfaceEffectsWavesReverb;
JScript | public static var InterfaceEffectsWavesReverb : Guid

Field Value

System.Guid
Returns the GUID for the Waves reverb effect interface.

This field is read-only.

Remarks

This field is used to retrieve the WavesReverbEffect object, that currently in a SecondaryBuffer object, using the SecondaryBuffer.GetObjectInPath method.


DSoundHelper.InterfaceNotify Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceNotify Field

Retrieves the globally unique identifier (GUID) for the Notify interface.

Definition

Visual Basic | Public Shared InterfaceNotify As Guid
C# | public static Guid InterfaceNotify;
C++ | public: static Guid InterfaceNotify;
JScript | public static var InterfaceNotify : Guid

Field Value

System.Guid
Returns the GUID for the Notify interface.

This field is read-only.


DSoundHelper.InterfaceSecondaryBuffer Field (Microsoft.DirectX.DirectSound)

DSoundHelper.InterfaceSecondaryBuffer Field

Retrieves the globally unique identifier (GUID) for the SecondaryBuffer interface.

Definition

Visual Basic | Public Shared InterfaceSecondaryBuffer As Guid
C# | public static Guid InterfaceSecondaryBuffer;
C++ | public: static Guid InterfaceSecondaryBuffer;
JScript | public static var InterfaceSecondaryBuffer : Guid

Field Value

System.Guid
Returns the GUID for the SecondaryBuffer interface.

This field is read-only.


DSoundHelper.MaxConeAngle Field (Microsoft.DirectX.DirectSound)

DSoundHelper.MaxConeAngle Field

Retrieves the maximum cone angle for an Angles structure, in degrees.

Definition

Visual Basic | Public Shared MaxConeAngle As Single
C# | public static Single MaxConeAngle;
C++ | public: static Single MaxConeAngle;
JScript | public static var MaxConeAngle : Single

Field Value

System.Single
Returns the maximum cone angle for an Angles structure, in degrees.

This field is read-only.


DSoundHelper.MaxDistanceFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.MaxDistanceFactor Field

Retrieves the maximum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

Definition

Visual Basic | Public Shared MaxDistanceFactor As Single
C# | public static Single MaxDistanceFactor;
C++ | public: static Single MaxDistanceFactor;
JScript | public static var MaxDistanceFactor : Single

Field Value

System.Single
Returns the maximum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

This field is read-only.


DSoundHelper.MaxDopplerFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.MaxDopplerFactor Field

Retrieves the maximum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

Definition

Visual Basic | Public Shared MaxDopplerFactor As Single
C# | public static Single MaxDopplerFactor;
C++ | public: static Single MaxDopplerFactor;
JScript | public static var MaxDopplerFactor : Single

Field Value

System.Single
Returns the maximum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

This field is read-only.


DSoundHelper.MaxRolloffFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.MaxRolloffFactor Field

Retrieves the maximum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

Definition

Visual Basic | Public Shared MaxRolloffFactor As Single
C# | public static Single MaxRolloffFactor;
C++ | public: static Single MaxRolloffFactor;
JScript | public static var MaxRolloffFactor : Single

Field Value

System.Single
Returns the maximum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

This field is read-only.


DSoundHelper.MinConeAngle Field (Microsoft.DirectX.DirectSound)

DSoundHelper.MinConeAngle Field

Retrieves the minimum cone angle for an Angles structure, in degrees.

Definition

Visual Basic | Public Shared MinConeAngle As Single
C# | public static Single MinConeAngle;
C++ | public: static Single MinConeAngle;
JScript | public static var MinConeAngle : Single

Field Value

System.Single
Returns the minimum cone angle for an Angles structure, in degrees.

This field is read-only.


DSoundHelper.MinDistanceFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.MinDistanceFactor Field

Retrieves the minimum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

Definition

Visual Basic | Public Shared MinDistanceFactor As Single
C# | public static Single MinDistanceFactor;
C++ | public: static Single MinDistanceFactor;
JScript | public static var MinDistanceFactor : Single

Field Value

System.Single
Returns the minimum distance factor used by the Listener3D.DistanceFactor and Listener3DSettings.DistanceFactor properties, in meters.

This field is read-only.


DSoundHelper.MinDopplerFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.MinDopplerFactor Field

Retrieves the minimum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

Definition

Visual Basic | Public Shared MinDopplerFactor As Single
C# | public static Single MinDopplerFactor;
C++ | public: static Single MinDopplerFactor;
JScript | public static var MinDopplerFactor : Single

Field Value

System.Single
Returns the minimum ratio of Doppler effect to that in the real world used by the Listener3D.DopplerFactor and Listener3DSettings.DopplerFactor properties, in meters.

This field is read-only.


DSoundHelper.MinRolloffFactor Field (Microsoft.DirectX.DirectSound)

DSoundHelper.MinRolloffFactor Field

Retrieves the minimum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

Definition

Visual Basic | Public Shared MinRolloffFactor As Single
C# | public static Single MinRolloffFactor;
C++ | public: static Single MinRolloffFactor;
JScript | public static var MinRolloffFactor : Single

Field Value

System.Single
Returns the minimum ratio of attenuation over distance to that in the real world used by the Listener3D.RolloffFactor and Listener3DSettings.RolloffFactor properties, in meters.

This field is read-only.


DSoundHelper.StandardChorusGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardChorusGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the chorus effect.

Definition

Visual Basic | Public Shared StandardChorusGuid As Guid
C# | public static Guid StandardChorusGuid;
C++ | public: static Guid StandardChorusGuid;
JScript | public static var StandardChorusGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the chorus effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the chorus effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardCompressorGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardCompressorGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the compressor effect.

Definition

Visual Basic | Public Shared StandardCompressorGuid As Guid
C# | public static Guid StandardCompressorGuid;
C++ | public: static Guid StandardCompressorGuid;
JScript | public static var StandardCompressorGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the compressor effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the compressor effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardDistortionGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardDistortionGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the distortion effect.

Definition

Visual Basic | Public Shared StandardDistortionGuid As Guid
C# | public static Guid StandardDistortionGuid;
C++ | public: static Guid StandardDistortionGuid;
JScript | public static var StandardDistortionGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the distortion effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the distortion effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardEchoGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardEchoGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the echo effect.

Definition

Visual Basic | Public Shared StandardEchoGuid As Guid
C# | public static Guid StandardEchoGuid;
C++ | public: static Guid StandardEchoGuid;
JScript | public static var StandardEchoGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the echo effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the echo effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardFlangerGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardFlangerGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the flanger effect.

Definition

Visual Basic | Public Shared StandardFlangerGuid As Guid
C# | public static Guid StandardFlangerGuid;
C++ | public: static Guid StandardFlangerGuid;
JScript | public static var StandardFlangerGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the flanger effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the flanger effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardGargleGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardGargleGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the gargle effect.

Definition

Visual Basic | Public Shared StandardGargleGuid As Guid
C# | public static Guid StandardGargleGuid;
C++ | public: static Guid StandardGargleGuid;
JScript | public static var StandardGargleGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the gargle effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the gargle effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardInteractive3DLevel2ReverbGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardInteractive3DLevel2ReverbGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the interactive 3-D level2 reverb effect.

Definition

Visual Basic | Public Shared StandardInteractive3DLevel2ReverbGuid As Guid
C# | public static Guid StandardInteractive3DLevel2ReverbGuid;
C++ | public: static Guid StandardInteractive3DLevel2ReverbGuid;
JScript | public static var StandardInteractive3DLevel2ReverbGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the interactive 3-D level2 reverb effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the interactive 3-D level2 reverb effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardParamEqGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardParamEqGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the parameteric equalizer effect.

Definition

Visual Basic | Public Shared StandardParamEqGuid As Guid
C# | public static Guid StandardParamEqGuid;
C++ | public: static Guid StandardParamEqGuid;
JScript | public static var StandardParamEqGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the parameteric equalizer effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the parameteric equalizer effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


DSoundHelper.StandardWavesReverbGuid Field (Microsoft.DirectX.DirectSound)

DSoundHelper.StandardWavesReverbGuid Field

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves the globally unique identifier (GUID) class identifier for the Waves reverb effect.

Definition

Visual Basic | Public Shared StandardWavesReverbGuid As Guid
C# | public static Guid StandardWavesReverbGuid;
C++ | public: static Guid StandardWavesReverbGuid;
JScript | public static var StandardWavesReverbGuid : Guid

Field Value

System.Guid
Returns the GUID class identifier for the Waves reverb effect.

This field is read-only.

Remarks

This GUID is used by the EffectDescription structure to set the Waves reverb effect to a SecondaryBuffer object.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


EchoEffect Class (Microsoft.DirectX.DirectSound)

EchoEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports echo.

Definition

Visual Basic Public Class EchoEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class EchoEffect : MarshalByRefObject, IDisposable
C++ | public ref class EchoEffect : MarshalByRefObject, IDisposable
JScript | public class EchoEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the EchoEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) FeedbackMax | Retrieves the maximum value for the EffectsEcho.Feedback property.
static (Shared in Visual Basic) FeedbackMin | Retrieves the minimum value for the EffectsEcho.Feedback property.
static (Shared in Visual Basic) LeftDelayMax | Retrieves the maximum value for the EffectsEcho.LeftDelay property.
static (Shared in Visual Basic) LeftDelayMin | Retrieves the minimum value for the EffectsEcho.LeftDelay property.
static (Shared in Visual Basic) PanDelayMax | Retrieves the maximum value for the EffectsEcho.PanDelay property.
static (Shared in Visual Basic) PanDelayMin | Retrieves the minimum value for the EffectsEcho.PanDelay property.
static (Shared in Visual Basic) RightDelayMax | Retrieves the maximum value for the EffectsEcho.RightDelay property.
static (Shared in Visual Basic) RightDelayMin | Retrieves the minimum value for the EffectsEcho.RightDelay property.
static (Shared in Visual Basic) WetDryMixMax | Retrieves the maximum value for the EffectsEcho.WetDryMix property.
static (Shared in Visual Basic) WetDryMixMin | Retrieves the minimum value for the EffectsEcho.WetDryMix property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the EchoEffect object.
EchoEffect | Initializes a new instance of the EchoEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the EchoEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the EchoEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets echo parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
EchoEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EchoEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

EchoEffect.Dispose Method

Immediately releases the unmanaged resources used by the EchoEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~EchoEffect();
JScript | public override function Dispose();

See Also

  • EchoEffect.Disposed
  • EchoEffect.Disposing


EchoEffect.EchoEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

EchoEffect.EchoEffect Constructor

Initializes a new instance of the EchoEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public EchoEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
EchoEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function EchoEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXEcho8, which allows unmanaged COM clients to create an instance of the managed EchoEffect class. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the EchoEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


EchoEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

EchoEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


EchoEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

EchoEffect.Finalize Method

Allows the EchoEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~EchoEffect();
C++ | !EchoEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


EchoEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

EchoEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


EchoEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

EchoEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXEcho8, which allows unmanaged COM clients to create an instance of the managed EchoEffect class. Not supported.


EchoEffect.op_Equality(EchoEffect,EchoEffect) Method (Microsoft.DirectX.DirectSound)

EchoEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As EchoEffect, _
ByVal right As EchoEffect _
) As Boolean
C# public static bool op_Equality(
EchoEffect left,
EchoEffect right
);
C++ public:
static bool operator==(
EchoEffect^ left,
EchoEffect^ right
);
JScript public static function op_Equality(
left : EchoEffect,
right : EchoEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.EchoEffect
The EchoEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.EchoEffect
The EchoEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


EchoEffect.op_Inequality(EchoEffect,EchoEffect) Method (Microsoft.DirectX.DirectSound)

EchoEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As EchoEffect, _
ByVal right As EchoEffect _
) As Boolean
C# public static bool op_Inequality(
EchoEffect left,
EchoEffect right
);
C++ public:
static bool operator!=(
EchoEffect^ left,
EchoEffect^ right
);
JScript public static function op_Inequality(
left : EchoEffect,
right : EchoEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.EchoEffect
The EchoEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.EchoEffect
The EchoEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


EchoEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

EchoEffect.raise_Disposing Method

Raises the EchoEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


EchoEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

EchoEffect.AllParameters Property

Retrieves or sets echo parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsEcho
C# | public EffectsEcho AllParameters { get; set; }
C++ public:
property EffectsEcho AllParameters {
EffectsEcho get();
void set(EffectsEcho value);
}
JScript public function get AllParameters() : EffectsEcho
public function set AllParameters(EffectsEcho);

Property Value

Microsoft.DirectX.DirectSound.EffectsEcho
Contains parameters for an echo effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


EchoEffect.Disposed Property (Microsoft.DirectX.DirectSound)

EchoEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


EchoEffect.FeedbackMax Field (Microsoft.DirectX.DirectSound)

EchoEffect.FeedbackMax Field

Retrieves the maximum value for the EffectsEcho.Feedback property.

Definition

Visual Basic | Public Shared FeedbackMax As Single
C# | public static Single FeedbackMax;
C++ | public: static Single FeedbackMax;
JScript | public static var FeedbackMax : Single

Field Value

System.Single
Maximum value for the EffectsEcho.Feedback property.

This field is read-only.

See Also

  • EffectsEcho.Feedback


EchoEffect.FeedbackMin Field (Microsoft.DirectX.DirectSound)

EchoEffect.FeedbackMin Field

Retrieves the minimum value for the EffectsEcho.Feedback property.

Definition

Visual Basic | Public Shared FeedbackMin As Single
C# | public static Single FeedbackMin;
C++ | public: static Single FeedbackMin;
JScript | public static var FeedbackMin : Single

Field Value

System.Single
Minimum value for the EffectsEcho.Feedback property.

This field is read-only.

See Also

  • EffectsEcho.Feedback


EchoEffect.LeftDelayMax Field (Microsoft.DirectX.DirectSound)

EchoEffect.LeftDelayMax Field

Retrieves the maximum value for the EffectsEcho.LeftDelay property.

Definition

Visual Basic | Public Shared LeftDelayMax As Single
C# | public static Single LeftDelayMax;
C++ | public: static Single LeftDelayMax;
JScript | public static var LeftDelayMax : Single

Field Value

System.Single
Maximum value for the EffectsEcho.LeftDelay property.

This field is read-only.

See Also

  • EffectsEcho.LeftDelay


EchoEffect.LeftDelayMin Field (Microsoft.DirectX.DirectSound)

EchoEffect.LeftDelayMin Field

Retrieves the minimum value for the EffectsEcho.LeftDelay property.

Definition

Visual Basic | Public Shared LeftDelayMin As Single
C# | public static Single LeftDelayMin;
C++ | public: static Single LeftDelayMin;
JScript | public static var LeftDelayMin : Single

Field Value

System.Single
Minimum value for the EffectsEcho.LeftDelay property.

This field is read-only.

See Also

  • EffectsEcho.LeftDelay


EchoEffect.PanDelayMax Field (Microsoft.DirectX.DirectSound)

EchoEffect.PanDelayMax Field

Retrieves the maximum value for the EffectsEcho.PanDelay property.

Definition

Visual Basic | Public Shared PanDelayMax As Int32
C# | public static Int32 PanDelayMax;
C++ | public: static Int32 PanDelayMax;
JScript | public static var PanDelayMax : Int32

Field Value

System.Int32
Maximum value for the EffectsEcho.PanDelay property.

This field is read-only.

See Also

  • EffectsEcho.PanDelay


EchoEffect.PanDelayMin Field (Microsoft.DirectX.DirectSound)

EchoEffect.PanDelayMin Field

Retrieves the minimum value for the EffectsEcho.PanDelay property.

Definition

Visual Basic | Public Shared PanDelayMin As Int32
C# | public static Int32 PanDelayMin;
C++ | public: static Int32 PanDelayMin;
JScript | public static var PanDelayMin : Int32

Field Value

System.Int32
Minimum value for the EffectsEcho.PanDelay property.

This field is read-only.

See Also

  • EffectsEcho.PanDelay


EchoEffect.RightDelayMax Field (Microsoft.DirectX.DirectSound)

EchoEffect.RightDelayMax Field

Retrieves the maximum value for the EffectsEcho.RightDelay property.

Definition

Visual Basic | Public Shared RightDelayMax As Single
C# | public static Single RightDelayMax;
C++ | public: static Single RightDelayMax;
JScript | public static var RightDelayMax : Single

Field Value

System.Single
Maximum value for the EffectsEcho.RightDelay property.

This field is read-only.

See Also

  • EffectsEcho.RightDelay


EchoEffect.RightDelayMin Field (Microsoft.DirectX.DirectSound)

EchoEffect.RightDelayMin Field

Retrieves the minimum value for the EffectsEcho.RightDelay property.

Definition

Visual Basic | Public Shared RightDelayMin As Single
C# | public static Single RightDelayMin;
C++ | public: static Single RightDelayMin;
JScript | public static var RightDelayMin : Single

Field Value

System.Single
Minimum value for the EffectsEcho.RightDelay property.

This field is read-only.

See Also

  • EffectsEcho.RightDelay


EchoEffect.WetDryMixMax Field (Microsoft.DirectX.DirectSound)

EchoEffect.WetDryMixMax Field

Retrieves the maximum value for the EffectsEcho.WetDryMix property.

Definition

Visual Basic | Public Shared WetDryMixMax As Single
C# | public static Single WetDryMixMax;
C++ | public: static Single WetDryMixMax;
JScript | public static var WetDryMixMax : Single

Field Value

System.Single
Maximum value for the EffectsEcho.WetDryMix property.

This field is read-only.

See Also

  • EffectsEcho.WetDryMix


EchoEffect.WetDryMixMin Field (Microsoft.DirectX.DirectSound)

EchoEffect.WetDryMixMin Field

Retrieves the minimum value for the EffectsEcho.WetDryMix property.

Definition

Visual Basic | Public Shared WetDryMixMin As Single
C# | public static Single WetDryMixMin;
C++ | public: static Single WetDryMixMin;
JScript | public static var WetDryMixMin : Single

Field Value

System.Single
Minimum value for the EffectsEcho.WetDryMix property.

This field is read-only.

See Also

  • EffectsEcho.WetDryMix


EchoEffect.Disposing Event (Microsoft.DirectX.DirectSound)

EchoEffect.Disposing Event

Occurs when the Dispose method is called or when the EchoEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the EchoEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the EchoEffect object indicates whether that object has been disposed.


EffectsUnavailableException Class (Microsoft.DirectX.DirectSound)

EffectsUnavailableException Class

The effects requested could not be found on the system, or they are in the wrong order or in the wrong location; for example, an effect expected in hardware was found in software.

Definition

Visual Basic Public Class EffectsUnavailableException
Inherits SoundException
C# | public class EffectsUnavailableException : SoundException
C++ | public ref class EffectsUnavailableException : SoundException
JScript | public class EffectsUnavailableException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
EffectsUnavailableException | Initializes a new instance of the EffectsUnavailableException class.
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
EffectsUnavailableException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


EffectsUnavailableException.EffectsUnavailableException Constructor ()

Initializes a new instance of the EffectsUnavailableException class.

Overload List

public EffectsUnavailableException();
protected EffectsUnavailableException(SerializationInfo, StreamingContext);
public EffectsUnavailableException(string);
public EffectsUnavailableException(string, Exception);


EffectsUnavailableException.EffectsUnavailableException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:

Initializes a new instance of the EffectsUnavailableException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected EffectsUnavailableException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
EffectsUnavailableException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function EffectsUnavailableException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


EffectsUnavailableException.EffectsUnavailableException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:

Initializes a new instance of the EffectsUnavailableException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public EffectsUnavailableException(
string message,
Exception inner
);
C++ public:
EffectsUnavailableException(
String^ message,
Exception^ inner
);
JScript public function EffectsUnavailableException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


EffectsUnavailableException.EffectsUnavailableException(String) Constructor (Microsoft.DirectX.DirectSound)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:

Initializes a new instance of the EffectsUnavailableException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public EffectsUnavailableException(
string message
);
C++ public:
EffectsUnavailableException(
String^ message
);
JScript public function EffectsUnavailableException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


EffectsUnavailableException.EffectsUnavailableException() Constructor (Microsoft.DirectX.DirectSound)

EffectsUnavailableException.EffectsUnavailableException Constructor

 Language:

Initializes a new instance of the EffectsUnavailableException class.

Definition

Visual Basic | Public Sub New()
C# | public EffectsUnavailableException();
C++ public:
EffectsUnavailableException();
JScript | public function EffectsUnavailableException();


FlangerEffect Class (Microsoft.DirectX.DirectSound)

FlangerEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports flange.

Definition

Visual Basic Public Class FlangerEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class FlangerEffect : MarshalByRefObject, IDisposable
C++ | public ref class FlangerEffect : MarshalByRefObject, IDisposable
JScript | public class FlangerEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the FlangerEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) DelayMax | Retrieves the maximum value for the EffectsFlanger.Delay property.
static (Shared in Visual Basic) DelayMin | Retrieves the minimum value for the EffectsFlanger.Delay property.
static (Shared in Visual Basic) DepthMax | Retrieves the maximum value for the EffectsFlanger.Depth property.
static (Shared in Visual Basic) DepthMin | Retrieves the minimum value for the EffectsFlanger.Depth property.
static (Shared in Visual Basic) FeedbackMax | Retrieves the maximum value for the EffectsFlanger.Feedback property.
static (Shared in Visual Basic) FeedbackMin | Retrieves the minimum value for the EffectsFlanger.Feedback property.
static (Shared in Visual Basic) FrequencyMax | Retrieves the maximum value for the EffectsFlanger.Frequency property.
static (Shared in Visual Basic) FrequencyMin | Retrieves the minimum value for the EffectsFlanger.Frequency property.
static (Shared in Visual Basic) Phase180 | Retrieves the value of 180 degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic) Phase90 | Retrieves the value of 90 degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic) PhaseMax | Retrieves the maximum value for the EffectsFlanger.Phase property.
static (Shared in Visual Basic) PhaseMin | Retrieves the minimum value for the EffectsFlanger.Phase property.
static (Shared in Visual Basic) PhaseNeg180 | Retrieves the value of negative 180 degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic) PhaseNeg90 | Retrieves the value of negative 90 degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic) PhaseZero | Retrieves the value of zero degrees of phase differential for the EffectsFlanger.Phase property.
static (Shared in Visual Basic) WaveSin | Retrieves the value for a sine waveform for the EffectsFlanger.Waveform property.
static (Shared in Visual Basic) WaveTriangle | Retrieves the value for a triangle waveform for the EffectsFlanger.Waveform property.
static (Shared in Visual Basic) WetDryMixMax | Retrieves the maximum value for the EffectsFlanger.WetDryMix property.
static (Shared in Visual Basic) WetDryMixMin | Retrieves the minimum value for the EffectsFlanger.WetDryMix property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the FlangerEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the FlangerEffect object to free resources before it is destroyed by the garbage collector.
FlangerEffect | Initializes a new instance of the FlangerEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the FlangerEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets flanger parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
FlangerEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FlangerEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

FlangerEffect.Dispose Method

Immediately releases the unmanaged resources used by the FlangerEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~FlangerEffect();
JScript | public override function Dispose();

See Also

  • FlangerEffect.Disposed
  • FlangerEffect.Disposing


FlangerEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

FlangerEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


FlangerEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

FlangerEffect.Finalize Method

Allows the FlangerEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~FlangerEffect();
C++ | !FlangerEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


FlangerEffect.FlangerEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

FlangerEffect.FlangerEffect Constructor

Initializes a new instance of the FlangerEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public FlangerEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
FlangerEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function FlangerEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXFlanger8, which allows unmanaged COM clients to create an instance of the managed FlangerEffect class. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the FlangerEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


FlangerEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

FlangerEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


FlangerEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

FlangerEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXFlanger8, which allows unmanaged COM clients to create an instance of the managed FlangerEffect class. Not supported.


FlangerEffect.op_Equality(FlangerEffect,FlangerEffect) Method (Microsoft.DirectX.DirectSound)

FlangerEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As FlangerEffect, _
ByVal right As FlangerEffect _
) As Boolean
C# public static bool op_Equality(
FlangerEffect left,
FlangerEffect right
);
C++ public:
static bool operator==(
FlangerEffect^ left,
FlangerEffect^ right
);
JScript public static function op_Equality(
left : FlangerEffect,
right : FlangerEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.FlangerEffect
The FlangerEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.FlangerEffect
The FlangerEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


FlangerEffect.op_Inequality(FlangerEffect,FlangerEffect) Method (Microsoft.DirectX.DirectSound)

FlangerEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As FlangerEffect, _
ByVal right As FlangerEffect _
) As Boolean
C# public static bool op_Inequality(
FlangerEffect left,
FlangerEffect right
);
C++ public:
static bool operator!=(
FlangerEffect^ left,
FlangerEffect^ right
);
JScript public static function op_Inequality(
left : FlangerEffect,
right : FlangerEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.FlangerEffect
The FlangerEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.FlangerEffect
The FlangerEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


FlangerEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

FlangerEffect.raise_Disposing Method

Raises the FlangerEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


FlangerEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

FlangerEffect.AllParameters Property

Retrieves or sets flanger parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsFlanger
C# | public EffectsFlanger AllParameters { get; set; }
C++ public:
property EffectsFlanger AllParameters {
EffectsFlanger get();
void set(EffectsFlanger value);
}
JScript public function get AllParameters() : EffectsFlanger
public function set AllParameters(EffectsFlanger);

Property Value

Microsoft.DirectX.DirectSound.EffectsFlanger
Contains parameters for a flanger effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


FlangerEffect.Disposed Property (Microsoft.DirectX.DirectSound)

FlangerEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


FlangerEffect.DelayMax Field (Microsoft.DirectX.DirectSound)

FlangerEffect.DelayMax Field

Retrieves the maximum value for the EffectsFlanger.Delay property.

Definition

Visual Basic | Public Shared DelayMax As Single
C# | public static Single DelayMax;
C++ | public: static Single DelayMax;
JScript | public static var DelayMax : Single

Field Value

System.Single
Maximum value for the EffectsFlanger.Delay property.

This field is read-only.

See Also

  • EffectsFlanger.Delay


FlangerEffect.DelayMin Field (Microsoft.DirectX.DirectSound)

FlangerEffect.DelayMin Field

Retrieves the minimum value for the EffectsFlanger.Delay property.

Definition

Visual Basic | Public Shared DelayMin As Single
C# | public static Single DelayMin;
C++ | public: static Single DelayMin;
JScript | public static var DelayMin : Single

Field Value

System.Single
Minimum value for the EffectsFlanger.Delay property.

This field is read-only.

See Also

  • EffectsFlanger.Delay


FlangerEffect.DepthMax Field (Microsoft.DirectX.DirectSound)

FlangerEffect.DepthMax Field

Retrieves the maximum value for the EffectsFlanger.Depth property.

Definition

Visual Basic | Public Shared DepthMax As Single
C# | public static Single DepthMax;
C++ | public: static Single DepthMax;
JScript | public static var DepthMax : Single

Field Value

System.Single
Maximum value for the EffectsFlanger.Depth property.

This field is read-only.

See Also

  • EffectsFlanger.Depth


FlangerEffect.DepthMin Field (Microsoft.DirectX.DirectSound)

FlangerEffect.DepthMin Field

Retrieves the minimum value for the EffectsFlanger.Depth property.

Definition

Visual Basic | Public Shared DepthMin As Single
C# | public static Single DepthMin;
C++ | public: static Single DepthMin;
JScript | public static var DepthMin : Single

Field Value

System.Single
Minimum value for the EffectsFlanger.Depth property.

This field is read-only.

See Also

  • EffectsFlanger.Depth


FlangerEffect.FeedbackMax Field (Microsoft.DirectX.DirectSound)

FlangerEffect.FeedbackMax Field

Retrieves the maximum value for the EffectsFlanger.Feedback property.

Definition

Visual Basic | Public Shared FeedbackMax As Single
C# | public static Single FeedbackMax;
C++ | public: static Single FeedbackMax;
JScript | public static var FeedbackMax : Single

Field Value

System.Single
Maximum value for the EffectsFlanger.Feedback property.

This field is read-only.

See Also

  • EffectsFlanger.Feedback


FlangerEffect.FeedbackMin Field (Microsoft.DirectX.DirectSound)

FlangerEffect.FeedbackMin Field

Retrieves the minimum value for the EffectsFlanger.Feedback property.

Definition

Visual Basic | Public Shared FeedbackMin As Single
C# | public static Single FeedbackMin;
C++ | public: static Single FeedbackMin;
JScript | public static var FeedbackMin : Single

Field Value

System.Single
Minimum value for the EffectsFlanger.Feedback property.

This field is read-only.

See Also

  • EffectsFlanger.Feedback


FlangerEffect.FrequencyMax Field (Microsoft.DirectX.DirectSound)

FlangerEffect.FrequencyMax Field

Retrieves the maximum value for the EffectsFlanger.Frequency property.

Definition

Visual Basic | Public Shared FrequencyMax As Single
C# | public static Single FrequencyMax;
C++ | public: static Single FrequencyMax;
JScript | public static var FrequencyMax : Single

Field Value

System.Single
Maximum value for the EffectsFlanger.Frequency property.

This field is read-only.

See Also

  • EffectsFlanger.Frequency


FlangerEffect.FrequencyMin Field (Microsoft.DirectX.DirectSound)

FlangerEffect.FrequencyMin Field

Retrieves the minimum value for the EffectsFlanger.Frequency property.

Definition

Visual Basic | Public Shared FrequencyMin As Single
C# | public static Single FrequencyMin;
C++ | public: static Single FrequencyMin;
JScript | public static var FrequencyMin : Single

Field Value

System.Single
Minimum value for the EffectsFlanger.Frequency property.

This field is read-only.

See Also

  • EffectsFlanger.Frequency


FlangerEffect.Phase180 Field (Microsoft.DirectX.DirectSound)

FlangerEffect.Phase180 Field

Retrieves the value of 180 degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic | Public Shared Phase180 As Int32
C# | public static Int32 Phase180;
C++ | public: static Int32 Phase180;
JScript | public static var Phase180 : Int32

Field Value

System.Int32
Value of 180 degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.Phase90 Field (Microsoft.DirectX.DirectSound)

FlangerEffect.Phase90 Field

Retrieves the value of 90 degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic | Public Shared Phase90 As Int32
C# | public static Int32 Phase90;
C++ | public: static Int32 Phase90;
JScript | public static var Phase90 : Int32

Field Value

System.Int32
Value of 90 degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseMax Field (Microsoft.DirectX.DirectSound)

FlangerEffect.PhaseMax Field

Retrieves the maximum value for the EffectsFlanger.Phase property.

Definition

Visual Basic | Public Shared PhaseMax As Int32
C# | public static Int32 PhaseMax;
C++ | public: static Int32 PhaseMax;
JScript | public static var PhaseMax : Int32

Field Value

System.Int32
Maximum value for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseMin Field (Microsoft.DirectX.DirectSound)

FlangerEffect.PhaseMin Field

Retrieves the minimum value for the EffectsFlanger.Phase property.

Definition

Visual Basic | Public Shared PhaseMin As Int32
C# | public static Int32 PhaseMin;
C++ | public: static Int32 PhaseMin;
JScript | public static var PhaseMin : Int32

Field Value

System.Int32
Minimum value for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseNeg180 Field (Microsoft.DirectX.DirectSound)

FlangerEffect.PhaseNeg180 Field

Retrieves the value of negative 180 degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic | Public Shared PhaseNeg180 As Int32
C# | public static Int32 PhaseNeg180;
C++ | public: static Int32 PhaseNeg180;
JScript | public static var PhaseNeg180 : Int32

Field Value

System.Int32
Value of negative 180 degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseNeg90 Field (Microsoft.DirectX.DirectSound)

FlangerEffect.PhaseNeg90 Field

Retrieves the value of negative 90 degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic | Public Shared PhaseNeg90 As Int32
C# | public static Int32 PhaseNeg90;
C++ | public: static Int32 PhaseNeg90;
JScript | public static var PhaseNeg90 : Int32

Field Value

System.Int32
Value of negative 90 degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.PhaseZero Field (Microsoft.DirectX.DirectSound)

FlangerEffect.PhaseZero Field

Retrieves the value of zero degrees of phase differential for the EffectsFlanger.Phase property.

Definition

Visual Basic | Public Shared PhaseZero As Int32
C# | public static Int32 PhaseZero;
C++ | public: static Int32 PhaseZero;
JScript | public static var PhaseZero : Int32

Field Value

System.Int32
Value of zero degrees of phase differential for the EffectsFlanger.Phase property.

This field is read-only.

See Also

  • EffectsFlanger.Phase


FlangerEffect.WaveSin Field (Microsoft.DirectX.DirectSound)

FlangerEffect.WaveSin Field

Retrieves the value for a sine waveform for the EffectsFlanger.Waveform property.

Definition

Visual Basic | Public Shared WaveSin As Int32
C# | public static Int32 WaveSin;
C++ | public: static Int32 WaveSin;
JScript | public static var WaveSin : Int32

Field Value

System.Int32
Value for a sine waveform for the EffectsFlanger.Waveform property.

This field is read-only.

See Also

  • EffectsFlanger.Waveform


FlangerEffect.WaveTriangle Field (Microsoft.DirectX.DirectSound)

FlangerEffect.WaveTriangle Field

Retrieves the value for a triangle waveform for the EffectsFlanger.Waveform property.

Definition

Visual Basic | Public Shared WaveTriangle As Int32
C# | public static Int32 WaveTriangle;
C++ | public: static Int32 WaveTriangle;
JScript | public static var WaveTriangle : Int32

Field Value

System.Int32
Value for a triangle waveform for the EffectsFlanger.Waveform property.

This field is read-only.

See Also

  • EffectsFlanger.Waveform


FlangerEffect.WetDryMixMax Field (Microsoft.DirectX.DirectSound)

FlangerEffect.WetDryMixMax Field

Retrieves the maximum value for the EffectsFlanger.WetDryMix property.

Definition

Visual Basic | Public Shared WetDryMixMax As Single
C# | public static Single WetDryMixMax;
C++ | public: static Single WetDryMixMax;
JScript | public static var WetDryMixMax : Single

Field Value

System.Single
Maximum value for the EffectsFlanger.WetDryMix property.

This field is read-only.

See Also

  • EffectsFlanger.WetDryMix


FlangerEffect.WetDryMixMin Field (Microsoft.DirectX.DirectSound)

FlangerEffect.WetDryMixMin Field

Retrieves the minimum value for the EffectsFlanger.WetDryMix property.

Definition

Visual Basic | Public Shared WetDryMixMin As Single
C# | public static Single WetDryMixMin;
C++ | public: static Single WetDryMixMin;
JScript | public static var WetDryMixMin : Single

Field Value

System.Single
Minimum value for the EffectsFlanger.WetDryMix property.

This field is read-only.

See Also

  • EffectsFlanger.WetDryMix


FlangerEffect.Disposing Event (Microsoft.DirectX.DirectSound)

FlangerEffect.Disposing Event

Occurs when the Dispose method is called or when the FlangerEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the FlangerEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the FlangerEffect object indicates whether that object has been disposed.


FullDuplex Class (Microsoft.DirectX.DirectSound)

FullDuplex Class

Represents a full-duplex stream.

Definition

Visual Basic Public Class FullDuplex
Inherits MarshalByRefObject
Implements IDisposable
C# | public class FullDuplex : MarshalByRefObject, IDisposable
C++ | public ref class FullDuplex : MarshalByRefObject, IDisposable
JScript | public class FullDuplex extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the FullDuplex object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the FullDuplex object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the FullDuplex object to free resources before it is destroyed by the garbage collector.
FullDuplex | Initializes a new instance of the FullDuplex class.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the FullDuplex.Disposing event when called from within a derived class.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
FullDuplex

Remarks

The FullDuplex object requires Microsoft Windows XP or later. Full duplex can be implemented on other operating systems, but the capture and rendering devices must be created separately.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FullDuplex.Dispose() Method (Microsoft.DirectX.DirectSound)

FullDuplex.Dispose Method

Immediately releases the unmanaged resources used by the FullDuplex object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~FullDuplex();
JScript | public override function Dispose();

See Also

  • FullDuplex.Disposed
  • FullDuplex.Disposing


FullDuplex.Equals(Object) Method (Microsoft.DirectX.DirectSound)

FullDuplex.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


FullDuplex.Finalize() Method (Microsoft.DirectX.DirectSound)

FullDuplex.Finalize Method

Allows the FullDuplex object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~FullDuplex();
C++ | !FullDuplex();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


FullDuplex.FullDuplex Constructor ()

Initializes a new instance of the FullDuplex class.

Overload List

public FullDuplex(CaptureBufferDescription, BufferDescription, Control, CooperativeLevel, ref CaptureBuffer, ref SecondaryBuffer);
public FullDuplex(CaptureBufferDescription, BufferDescription, IntPtr, CooperativeLevel, ref CaptureBuffer, ref SecondaryBuffer);
public FullDuplex(Guid, Guid, CaptureBufferDescription, BufferDescription, Control, CooperativeLevel, ref CaptureBuffer, ref SecondaryBuffer);
public FullDuplex(Guid, Guid, CaptureBufferDescription, BufferDescription, IntPtr, CooperativeLevel, ref CaptureBuffer, ref SecondaryBuffer);

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given GUID is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.FullDuplex(CaptureBufferDescription,BufferDescription,Control,CooperativeLevel,CaptureBuffer,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

FullDuplex.FullDuplex Constructor

Initializes a new instance of the FullDuplex class.

Definition

Visual Basic Public Sub New( _
ByVal captureDesc As CaptureBufferDescription, _
ByVal bufferDesc As BufferDescription, _
ByVal owner As Control, _
ByVal level As CooperativeLevel, _
ByRef captureBuffer As CaptureBuffer, _
ByRef buffer As SecondaryBuffer _
)
C# public FullDuplex(
CaptureBufferDescription captureDesc,
BufferDescription bufferDesc,
Control owner,
CooperativeLevel level,
ref CaptureBuffer captureBuffer,
ref SecondaryBuffer buffer
);
C++ public:
FullDuplex(
CaptureBufferDescription captureDesc,
BufferDescription^ bufferDesc,
Control^ owner,
CooperativeLevel level,
CaptureBuffer^% captureBuffer,
SecondaryBuffer^% buffer
);
JScript public function FullDuplex(
captureDesc : CaptureBufferDescription,
bufferDesc : BufferDescription,
owner : Control,
level : CooperativeLevel,
captureBuffer : CaptureBuffer,
buffer : SecondaryBuffer
);

Parameters

captureDesc Microsoft.DirectX.DirectSound.CaptureBufferDescription
The CaptureBufferDescription that specifies the characteristics of the capture buffer.
bufferDesc Microsoft.DirectX.DirectSound.BufferDescription
The BufferDescription that specifies the characteristics of the render buffer.
owner System.Windows.Forms.Control
The Control Leave Site that is the application window.
level Microsoft.DirectX.DirectSound.CooperativeLevel
Cooperative level for the device.
captureBuffer Microsoft.DirectX.DirectSound.CaptureBuffer
A reference to the CaptureBuffer object that is used for capturing audio data.
buffer Microsoft.DirectX.DirectSound.SecondaryBuffer
A reference to the SecondaryBuffer object that is used for rendering audio data.

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.FullDuplex(Guid,Guid,CaptureBufferDescription,BufferDescription,Control,CooperativeLevel,CaptureBuffer,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

FullDuplex.FullDuplex Constructor

Initializes a new instance of the FullDuplex class.

Definition

Visual Basic Public Sub New( _
ByVal guidCapture As Guid, _
ByVal guidRender As Guid, _
ByVal captureDesc As CaptureBufferDescription, _
ByVal bufferDesc As BufferDescription, _
ByVal owner As Control, _
ByVal level As CooperativeLevel, _
ByRef captureBuffer As CaptureBuffer, _
ByRef buffer As SecondaryBuffer _
)
C# public FullDuplex(
Guid guidCapture,
Guid guidRender,
CaptureBufferDescription captureDesc,
BufferDescription bufferDesc,
Control owner,
CooperativeLevel level,
ref CaptureBuffer captureBuffer,
ref SecondaryBuffer buffer
);
C++ public:
FullDuplex(
Guid guidCapture,
Guid guidRender,
CaptureBufferDescription captureDesc,
BufferDescription^ bufferDesc,
Control^ owner,
CooperativeLevel level,
CaptureBuffer^% captureBuffer,
SecondaryBuffer^% buffer
);
JScript public function FullDuplex(
guidCapture : Guid,
guidRender : Guid,
captureDesc : CaptureBufferDescription,
bufferDesc : BufferDescription,
owner : Control,
level : CooperativeLevel,
captureBuffer : CaptureBuffer,
buffer : SecondaryBuffer
);

Parameters

guidCapture System.Guid
The globally unique identifier (GUID) of the capture device driver.
guidRender System.Guid
The GUID of the render device driver.
captureDesc Microsoft.DirectX.DirectSound.CaptureBufferDescription
The CaptureBufferDescription that specifies the characteristics of the capture buffer.
bufferDesc Microsoft.DirectX.DirectSound.BufferDescription
The BufferDescription that specifies the characteristics of the render buffer.
owner System.Windows.Forms.Control
The Control Leave Site that is the application window.
level Microsoft.DirectX.DirectSound.CooperativeLevel
Cooperative level for the device.
captureBuffer Microsoft.DirectX.DirectSound.CaptureBuffer
A reference to the CaptureBuffer object that is used for capturing audio data.
buffer Microsoft.DirectX.DirectSound.SecondaryBuffer
A reference to the SecondaryBuffer object that is used for rendering audio data.

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given GUID is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.FullDuplex(CaptureBufferDescription,BufferDescription,IntPtr,CooperativeLevel,CaptureBuffer,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

FullDuplex.FullDuplex Constructor

Initializes a new instance of the FullDuplex class.

Definition

Visual Basic Public Sub New( _
ByVal captureDesc As CaptureBufferDescription, _
ByVal bufferDesc As BufferDescription, _
ByVal owner As IntPtr, _
ByVal level As CooperativeLevel, _
ByRef captureBuffer As CaptureBuffer, _
ByRef buffer As SecondaryBuffer _
)
C# public FullDuplex(
CaptureBufferDescription captureDesc,
BufferDescription bufferDesc,
IntPtr owner,
CooperativeLevel level,
ref CaptureBuffer captureBuffer,
ref SecondaryBuffer buffer
);
C++ public:
FullDuplex(
CaptureBufferDescription captureDesc,
BufferDescription^ bufferDesc,
IntPtr owner,
CooperativeLevel level,
CaptureBuffer^% captureBuffer,
SecondaryBuffer^% buffer
);
JScript public function FullDuplex(
captureDesc : CaptureBufferDescription,
bufferDesc : BufferDescription,
owner : IntPtr,
level : CooperativeLevel,
captureBuffer : CaptureBuffer,
buffer : SecondaryBuffer
);

Parameters

captureDesc Microsoft.DirectX.DirectSound.CaptureBufferDescription
The CaptureBufferDescription that specifies the characteristics of the capture buffer.
bufferDesc Microsoft.DirectX.DirectSound.BufferDescription
The BufferDescription that specifies the characteristics of the render buffer.
owner System.IntPtr
The handle of the application window.
level Microsoft.DirectX.DirectSound.CooperativeLevel
Cooperative level for the device.
captureBuffer Microsoft.DirectX.DirectSound.CaptureBuffer
A reference to the CaptureBuffer object that is used for capturing audio data.
buffer Microsoft.DirectX.DirectSound.SecondaryBuffer
A reference to the SecondaryBuffer object that is used for rendering audio data.

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.FullDuplex(Guid,Guid,CaptureBufferDescription,BufferDescription,IntPtr,CooperativeLevel,CaptureBuffer,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

FullDuplex.FullDuplex Constructor

Initializes a new instance of the FullDuplex class.

Definition

Visual Basic Public Sub New( _
ByVal guidCapture As Guid, _
ByVal guidRender As Guid, _
ByVal captureDesc As CaptureBufferDescription, _
ByVal bufferDesc As BufferDescription, _
ByVal owner As IntPtr, _
ByVal level As CooperativeLevel, _
ByRef captureBuffer As CaptureBuffer, _
ByRef buffer As SecondaryBuffer _
)
C# public FullDuplex(
Guid guidCapture,
Guid guidRender,
CaptureBufferDescription captureDesc,
BufferDescription bufferDesc,
IntPtr owner,
CooperativeLevel level,
ref CaptureBuffer captureBuffer,
ref SecondaryBuffer buffer
);
C++ public:
FullDuplex(
Guid guidCapture,
Guid guidRender,
CaptureBufferDescription captureDesc,
BufferDescription^ bufferDesc,
IntPtr owner,
CooperativeLevel level,
CaptureBuffer^% captureBuffer,
SecondaryBuffer^% buffer
);
JScript public function FullDuplex(
guidCapture : Guid,
guidRender : Guid,
captureDesc : CaptureBufferDescription,
bufferDesc : BufferDescription,
owner : IntPtr,
level : CooperativeLevel,
captureBuffer : CaptureBuffer,
buffer : SecondaryBuffer
);

Parameters

guidCapture System.Guid
The globally unique identifier (GUID) of the capture device driver.
guidRender System.Guid
The GUID of the render device driver.
captureDesc Microsoft.DirectX.DirectSound.CaptureBufferDescription
The CaptureBufferDescription that specifies the characteristics of the capture buffer.
bufferDesc Microsoft.DirectX.DirectSound.BufferDescription
The BufferDescription that specifies the characteristics of the render buffer.
owner System.IntPtr
The handle of the application window.
level Microsoft.DirectX.DirectSound.CooperativeLevel
Cooperative level for the device.
captureBuffer Microsoft.DirectX.DirectSound.CaptureBuffer
A reference to the CaptureBuffer object that is used for capturing audio data.
buffer Microsoft.DirectX.DirectSound.SecondaryBuffer
A reference to the SecondaryBuffer object that is used for rendering audio data.

Remarks

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
NoDriverException | No sound driver is available for use, or the given GUID is not a valid Microsoft DirectSound device identifier (ID).
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.


FullDuplex.GetHashCode() Method (Microsoft.DirectX.DirectSound)

FullDuplex.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


FullDuplex.op_Equality(FullDuplex,FullDuplex) Method (Microsoft.DirectX.DirectSound)

FullDuplex.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As FullDuplex, _
ByVal right As FullDuplex _
) As Boolean
C# public static bool op_Equality(
FullDuplex left,
FullDuplex right
);
C++ public:
static bool operator==(
FullDuplex^ left,
FullDuplex^ right
);
JScript public static function op_Equality(
left : FullDuplex,
right : FullDuplex
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.FullDuplex
The FullDuplex object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.FullDuplex
The FullDuplex object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


FullDuplex.op_Inequality(FullDuplex,FullDuplex) Method (Microsoft.DirectX.DirectSound)

FullDuplex.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As FullDuplex, _
ByVal right As FullDuplex _
) As Boolean
C# public static bool op_Inequality(
FullDuplex left,
FullDuplex right
);
C++ public:
static bool operator!=(
FullDuplex^ left,
FullDuplex^ right
);
JScript public static function op_Inequality(
left : FullDuplex,
right : FullDuplex
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.FullDuplex
The FullDuplex object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.FullDuplex
The FullDuplex object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


FullDuplex.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

FullDuplex.raise_Disposing Method

Raises the FullDuplex.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


FullDuplex.Disposed Property (Microsoft.DirectX.DirectSound)

FullDuplex.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


FullDuplex.Disposing Event (Microsoft.DirectX.DirectSound)

FullDuplex.Disposing Event

Occurs when the Dispose method is called or when the FullDuplex object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the FullDuplex.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the FullDuplex object indicates whether that object has been disposed.


GargleEffect Class (Microsoft.DirectX.DirectSound)

GargleEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports amplitude modulation.

Definition

Visual Basic Public Class GargleEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class GargleEffect : MarshalByRefObject, IDisposable
C++ | public ref class GargleEffect : MarshalByRefObject, IDisposable
JScript | public class GargleEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the GargleEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) RateHzMax | Retrieves the maximum value for the EffectsGargle.RateHz property.
static (Shared in Visual Basic) RateHzMin | Retrieves the minimum value for the EffectsGargle.RateHz property.
static (Shared in Visual Basic) WaveSquare | Retrieves the value for a square modulation waveform for the EffectsGargle.WaveShape property.
static (Shared in Visual Basic) WaveTriangle | Retrieves the value for a triangle modulation waveform for the EffectsGargle.WaveShape property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the GargleEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the GargleEffect object to free resources before it is destroyed by the garbage collector.
GargleEffect | Initializes a new instance of the GargleEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the GargleEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets gargle parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
GargleEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GargleEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

GargleEffect.Dispose Method

Immediately releases the unmanaged resources used by the GargleEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~GargleEffect();
JScript | public override function Dispose();

See Also

  • GargleEffect.Disposed
  • GargleEffect.Disposing


GargleEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

GargleEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


GargleEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

GargleEffect.Finalize Method

Allows the GargleEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~GargleEffect();
C++ | !GargleEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


GargleEffect.GargleEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

GargleEffect.GargleEffect Constructor

Initializes a new instance of the GargleEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public GargleEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
GargleEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function GargleEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXGargle8 Interface, which allows unmanaged COM clients to create an instance of the managed GargleEffect class. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the GargleEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


GargleEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

GargleEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


GargleEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

GargleEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXGargle8, which allows unmanaged COM clients to create an instance of the managed GargleEffect class. Not supported.


GargleEffect.op_Equality(GargleEffect,GargleEffect) Method (Microsoft.DirectX.DirectSound)

GargleEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As GargleEffect, _
ByVal right As GargleEffect _
) As Boolean
C# public static bool op_Equality(
GargleEffect left,
GargleEffect right
);
C++ public:
static bool operator==(
GargleEffect^ left,
GargleEffect^ right
);
JScript public static function op_Equality(
left : GargleEffect,
right : GargleEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.GargleEffect
The GargleEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.GargleEffect
The GargleEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


GargleEffect.op_Inequality(GargleEffect,GargleEffect) Method (Microsoft.DirectX.DirectSound)

GargleEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As GargleEffect, _
ByVal right As GargleEffect _
) As Boolean
C# public static bool op_Inequality(
GargleEffect left,
GargleEffect right
);
C++ public:
static bool operator!=(
GargleEffect^ left,
GargleEffect^ right
);
JScript public static function op_Inequality(
left : GargleEffect,
right : GargleEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.GargleEffect
The GargleEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.GargleEffect
The GargleEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


GargleEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

GargleEffect.raise_Disposing Method

Raises the GargleEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


GargleEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

GargleEffect.AllParameters Property

Retrieves or sets gargle parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsGargle
C# | public EffectsGargle AllParameters { get; set; }
C++ public:
property EffectsGargle AllParameters {
EffectsGargle get();
void set(EffectsGargle value);
}
JScript public function get AllParameters() : EffectsGargle
public function set AllParameters(EffectsGargle);

Property Value

Microsoft.DirectX.DirectSound.EffectsGargle
Contains parameters for a gargle effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


GargleEffect.Disposed Property (Microsoft.DirectX.DirectSound)

GargleEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


GargleEffect.RateHzMax Field (Microsoft.DirectX.DirectSound)

GargleEffect.RateHzMax Field

Retrieves the maximum value for the EffectsGargle.RateHz property.

Definition

Visual Basic | Public Shared RateHzMax As Int32
C# | public static Int32 RateHzMax;
C++ | public: static Int32 RateHzMax;
JScript | public static var RateHzMax : Int32

Field Value

System.Int32
Maximum value for the EffectsGargle.RateHz property.

This field is read-only.

See Also

  • EffectsGargle.RateHz


GargleEffect.RateHzMin Field (Microsoft.DirectX.DirectSound)

GargleEffect.RateHzMin Field

Retrieves the minimum value for the EffectsGargle.RateHz property.

Definition

Visual Basic | Public Shared RateHzMin As Int32
C# | public static Int32 RateHzMin;
C++ | public: static Int32 RateHzMin;
JScript | public static var RateHzMin : Int32

Field Value

System.Int32
Minimum value for the EffectsGargle.RateHz property.

This field is read-only.

See Also

  • EffectsGargle.RateHz


GargleEffect.WaveSquare Field (Microsoft.DirectX.DirectSound)

GargleEffect.WaveSquare Field

Retrieves the value for a square modulation waveform for the EffectsGargle.WaveShape property.

Definition

Visual Basic | Public Shared WaveSquare As Int32
C# | public static Int32 WaveSquare;
C++ | public: static Int32 WaveSquare;
JScript | public static var WaveSquare : Int32

Field Value

System.Int32
Value for a square modulation waveform for the EffectsGargle.WaveShape property.

This field is read-only.

See Also

  • EffectsGargle.WaveShape


GargleEffect.WaveTriangle Field (Microsoft.DirectX.DirectSound)

GargleEffect.WaveTriangle Field

Retrieves the value for a triangle modulation waveform for the EffectsGargle.WaveShape property.

Definition

Visual Basic | Public Shared WaveTriangle As Int32
C# | public static Int32 WaveTriangle;
C++ | public: static Int32 WaveTriangle;
JScript | public static var WaveTriangle : Int32

Field Value

System.Int32
Value for a triangle modulation waveform for the EffectsGargle.WaveShape property.

This field is read-only.

See Also

  • EffectsGargle.WaveShape


GargleEffect.Disposing Event (Microsoft.DirectX.DirectSound)

GargleEffect.Disposing Event

Occurs when the Dispose method is called or when the GargleEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the GargleEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the GargleEffect object indicates whether that object has been disposed.


Interactive3DLevel2ReverbEffect Class (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports Interactive 3-D Audio Level 2 (I3DL2) reverberation effects.

Definition

Visual Basic Public Class Interactive3DLevel2ReverbEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Interactive3DLevel2ReverbEffect : MarshalByRefObject, IDisposable
C++ | public ref class Interactive3DLevel2ReverbEffect : MarshalByRefObject, IDisposable
JScript | public class Interactive3DLevel2ReverbEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Interactive3DLevel2ReverbEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) DecayHfRatioDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.
static (Shared in Visual Basic) DecayHfRatioMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.
static (Shared in Visual Basic) DecayHfRatioMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.
static (Shared in Visual Basic) DecayTimeDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.DecayTime property.
static (Shared in Visual Basic) DecayTimeMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.
static (Shared in Visual Basic) DecayTimeMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.
static (Shared in Visual Basic) DensityDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Density property.
static (Shared in Visual Basic) DensityMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Density property.
static (Shared in Visual Basic) DensityMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Density property.
static (Shared in Visual Basic) DiffusionDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Diffusion property.
static (Shared in Visual Basic) DiffusionMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.
static (Shared in Visual Basic) DiffusionMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.
static (Shared in Visual Basic) HfReferenceDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.HfReference property.
static (Shared in Visual Basic) HfReferenceMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.HfReference property.
static (Shared in Visual Basic) HfReferenceMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.HfReference property.
static (Shared in Visual Basic) QualityDefault | Retrieves the default value for the Interactive3DLevel2ReverbEffect.Quality property.
static (Shared in Visual Basic) QualityMax | Retrieves the maximum value for the Interactive3DLevel2ReverbEffect.Quality property.
static (Shared in Visual Basic) QualityMin | Retrieves the minimum value for the Interactive3DLevel2ReverbEffect.Quality property.
static (Shared in Visual Basic) ReflectionsDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Reflections property.
static (Shared in Visual Basic) ReflectionsDelayDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.
static (Shared in Visual Basic) ReflectionsDelayMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.
static (Shared in Visual Basic) ReflectionsDelayMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.
static (Shared in Visual Basic) ReflectionsMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Reflections property.
static (Shared in Visual Basic) ReflectionsMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Reflections property.
static (Shared in Visual Basic) ReverbDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Reverb property.
static (Shared in Visual Basic) ReverbDelayDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.
static (Shared in Visual Basic) ReverbDelayMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.
static (Shared in Visual Basic) ReverbDelayMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.
static (Shared in Visual Basic) ReverbMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Reverb property.
static (Shared in Visual Basic) ReverbMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Reverb property.
static (Shared in Visual Basic) RoomDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Room property.
static (Shared in Visual Basic) RoomHfDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.RoomHf property.
static (Shared in Visual Basic) RoomHfMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.
static (Shared in Visual Basic) RoomHfMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.
static (Shared in Visual Basic) RoomMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Room property.
static (Shared in Visual Basic) RoomMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Room property.
static (Shared in Visual Basic) RoomRollOffFactorDefault | Retrieves the default value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.
static (Shared in Visual Basic) RoomRollOffFactorMax | Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.
static (Shared in Visual Basic) RoomRollOffFactorMin | Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Interactive3DLevel2ReverbEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Interactive3DLevel2ReverbEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
Interactive3DLevel2ReverbEffect | Initializes a new instance of the Interactive3DLevel2ReverbEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Interactive3DLevel2ReverbEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets interactive 3-D level 2 (I3DL2) environmental reverberation parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.
Preset | Retrieves or sets a standard reverberation parameters of a SecondaryBuffer object.
Quality | Retrieves or sets the quality of the environmental reverberation effect.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Interactive3DLevel2ReverbEffect

Remarks

Obtain this object by calling the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Interactive3DLevel2ReverbEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.Dispose Method

Immediately releases the unmanaged resources used by the Interactive3DLevel2ReverbEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Interactive3DLevel2ReverbEffect();
JScript | public override function Dispose();

See Also

  • Interactive3DLevel2ReverbEffect.Disposed
  • Interactive3DLevel2ReverbEffect.Disposing


Interactive3DLevel2ReverbEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Interactive3DLevel2ReverbEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.Finalize Method

Allows the Interactive3DLevel2ReverbEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Interactive3DLevel2ReverbEffect();
C++ | !Interactive3DLevel2ReverbEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Interactive3DLevel2ReverbEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Interactive3DLevel2ReverbEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXI3DL2Reverb8, which allows unmanaged COM clients to create an instance of the managed Interactive3DLevel2ReverbEffect class. Not supported.


Interactive3DLevel2ReverbEffect.Interactive3DLevel2ReverbEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.Interactive3DLevel2ReverbEffect Constructor

 Language:

Initializes a new instance of the Interactive3DLevel2ReverbEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public Interactive3DLevel2ReverbEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
Interactive3DLevel2ReverbEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function Interactive3DLevel2ReverbEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXI3DL2Reverb8, which allows unmanaged COM clients to create an instance of the managed Interactive3DLevel2ReverbEffect class. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the Interactive3DLevel2ReverbEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


Interactive3DLevel2ReverbEffect.op_Equality(Interactive3DLevel2ReverbEffect,Interactive3DLevel2ReverbEffect) Method (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Interactive3DLevel2ReverbEffect, _
ByVal right As Interactive3DLevel2ReverbEffect _
) As Boolean
C# public static bool op_Equality(
Interactive3DLevel2ReverbEffect left,
Interactive3DLevel2ReverbEffect right
);
C++ public:
static bool operator==(
Interactive3DLevel2ReverbEffect^ left,
Interactive3DLevel2ReverbEffect^ right
);
JScript public static function op_Equality(
left : Interactive3DLevel2ReverbEffect,
right : Interactive3DLevel2ReverbEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect
The Interactive3DLevel2ReverbEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect
The Interactive3DLevel2ReverbEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Interactive3DLevel2ReverbEffect.op_Inequality(Interactive3DLevel2ReverbEffect,Interactive3DLevel2ReverbEffect) Method (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Interactive3DLevel2ReverbEffect, _
ByVal right As Interactive3DLevel2ReverbEffect _
) As Boolean
C# public static bool op_Inequality(
Interactive3DLevel2ReverbEffect left,
Interactive3DLevel2ReverbEffect right
);
C++ public:
static bool operator!=(
Interactive3DLevel2ReverbEffect^ left,
Interactive3DLevel2ReverbEffect^ right
);
JScript public static function op_Inequality(
left : Interactive3DLevel2ReverbEffect,
right : Interactive3DLevel2ReverbEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect
The Interactive3DLevel2ReverbEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Interactive3DLevel2ReverbEffect
The Interactive3DLevel2ReverbEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Interactive3DLevel2ReverbEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.raise_Disposing Method

Raises the Interactive3DLevel2ReverbEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Interactive3DLevel2ReverbEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.AllParameters Property

Retrieves or sets interactive 3-D level 2 (I3DL2) environmental reverberation parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsInteractive3DLevel2Reverb
C# | public EffectsInteractive3DLevel2Reverb AllParameters { get; set; }
C++ public:
property EffectsInteractive3DLevel2Reverb AllParameters {
EffectsInteractive3DLevel2Reverb get();
void set(EffectsInteractive3DLevel2Reverb value);
}
JScript public function get AllParameters() : EffectsInteractive3DLevel2Reverb
public function set AllParameters(EffectsInteractive3DLevel2Reverb);

Property Value

Microsoft.DirectX.DirectSound.EffectsInteractive3DLevel2Reverb
Contains parameters for a I3DL2 environmental reverberation effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

See Also

  • Setting Effects on Buffers
  • Effect Parameters


Interactive3DLevel2ReverbEffect.Disposed Property (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Interactive3DLevel2ReverbEffect.Preset Property (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.Preset Property

Retrieves or sets a standard reverberation parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property Preset As EffectsEnvironmentPreset
C# | public EffectsEnvironmentPreset Preset { get; set; }
C++ public:
property EffectsEnvironmentPreset Preset {
EffectsEnvironmentPreset get();
void set(EffectsEnvironmentPreset value);
}
JScript public function get Preset() : EffectsEnvironmentPreset
public function set Preset(EffectsEnvironmentPreset);

Property Value

Microsoft.DirectX.DirectSound.EffectsEnvironmentPreset

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Interactive3DLevel2ReverbEffect.Quality Property (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.Quality Property

Retrieves or sets the quality of the environmental reverberation effect.

Definition

Visual Basic | Public Property Quality As Integer
C# | public int Quality { get; set; }
C++ public:
property int Quality {
int get();
void set(int value);
}
JScript public function get Quality() : int
public function set Quality(int);

Property Value

System.Int32
Quality of the effect.

This property is read/write.

Remarks

Higher values produce better quality at the expense of processing time.

Can range from Interactive3DLevel2ReverbEffect.QualityMin to Interactive3DLevel2ReverbEffect.QualityMax.

The default value is 2.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Interactive3DLevel2ReverbEffect.DecayHfRatioDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DecayHfRatioDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

Definition

Visual Basic | Public Shared DecayHfRatioDefault As Single
C# | public static Single DecayHfRatioDefault;
C++ | public: static Single DecayHfRatioDefault;
JScript | public static var DecayHfRatioDefault : Single

Field Value

System.Single
Default value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayHfRatio


Interactive3DLevel2ReverbEffect.DecayHfRatioMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DecayHfRatioMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

Definition

Visual Basic | Public Shared DecayHfRatioMax As Single
C# | public static Single DecayHfRatioMax;
C++ | public: static Single DecayHfRatioMax;
JScript | public static var DecayHfRatioMax : Single

Field Value

System.Single
Maximum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayHfRatio


Interactive3DLevel2ReverbEffect.DecayHfRatioMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DecayHfRatioMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

Definition

Visual Basic | Public Shared DecayHfRatioMin As Single
C# | public static Single DecayHfRatioMin;
C++ | public: static Single DecayHfRatioMin;
JScript | public static var DecayHfRatioMin : Single

Field Value

System.Single
Minimum value for the EffectsInteractive3DLevel2Reverb.DecayHfRatio property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayHfRatio


Interactive3DLevel2ReverbEffect.DecayTimeDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DecayTimeDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

Definition

Visual Basic | Public Shared DecayTimeDefault As Single
C# | public static Single DecayTimeDefault;
C++ | public: static Single DecayTimeDefault;
JScript | public static var DecayTimeDefault : Single

Field Value

System.Single
Default value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayTime


Interactive3DLevel2ReverbEffect.DecayTimeMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DecayTimeMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

Definition

Visual Basic | Public Shared DecayTimeMax As Single
C# | public static Single DecayTimeMax;
C++ | public: static Single DecayTimeMax;
JScript | public static var DecayTimeMax : Single

Field Value

System.Single
Maximum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayTime


Interactive3DLevel2ReverbEffect.DecayTimeMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DecayTimeMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

Definition

Visual Basic | Public Shared DecayTimeMin As Single
C# | public static Single DecayTimeMin;
C++ | public: static Single DecayTimeMin;
JScript | public static var DecayTimeMin : Single

Field Value

System.Single
Minimum value for the EffectsInteractive3DLevel2Reverb.DecayTime property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.DecayTime


Interactive3DLevel2ReverbEffect.DensityDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DensityDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Density property.

Definition

Visual Basic | Public Shared DensityDefault As Single
C# | public static Single DensityDefault;
C++ | public: static Single DensityDefault;
JScript | public static var DensityDefault : Single

Field Value

System.Single
Default value for the EffectsInteractive3DLevel2Reverb.Density property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Density


Interactive3DLevel2ReverbEffect.DensityMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DensityMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Density property.

Definition

Visual Basic | Public Shared DensityMax As Single
C# | public static Single DensityMax;
C++ | public: static Single DensityMax;
JScript | public static var DensityMax : Single

Field Value

System.Single
Maximum value for the EffectsInteractive3DLevel2Reverb.Density property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Density


Interactive3DLevel2ReverbEffect.DensityMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DensityMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Density property.

Definition

Visual Basic | Public Shared DensityMin As Single
C# | public static Single DensityMin;
C++ | public: static Single DensityMin;
JScript | public static var DensityMin : Single

Field Value

System.Single
Minimum value for the EffectsInteractive3DLevel2Reverb.Density property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Density


Interactive3DLevel2ReverbEffect.DiffusionDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DiffusionDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

Definition

Visual Basic | Public Shared DiffusionDefault As Single
C# | public static Single DiffusionDefault;
C++ | public: static Single DiffusionDefault;
JScript | public static var DiffusionDefault : Single

Field Value

System.Single
Default value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Diffusion


Interactive3DLevel2ReverbEffect.DiffusionMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DiffusionMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

Definition

Visual Basic | Public Shared DiffusionMax As Single
C# | public static Single DiffusionMax;
C++ | public: static Single DiffusionMax;
JScript | public static var DiffusionMax : Single

Field Value

System.Single
Maximum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Diffusion


Interactive3DLevel2ReverbEffect.DiffusionMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.DiffusionMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

Definition

Visual Basic | Public Shared DiffusionMin As Single
C# | public static Single DiffusionMin;
C++ | public: static Single DiffusionMin;
JScript | public static var DiffusionMin : Single

Field Value

System.Single
Minimum value for the EffectsInteractive3DLevel2Reverb.Diffusion property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Diffusion


Interactive3DLevel2ReverbEffect.HfReferenceDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.HfReferenceDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.HfReference property.

Definition

Visual Basic | Public Shared HfReferenceDefault As Single
C# | public static Single HfReferenceDefault;
C++ | public: static Single HfReferenceDefault;
JScript | public static var HfReferenceDefault : Single

Field Value

System.Single
Default value for the EffectsInteractive3DLevel2Reverb.HfReference property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.HfReference


Interactive3DLevel2ReverbEffect.HfReferenceMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.HfReferenceMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.HfReference property.

Definition

Visual Basic | Public Shared HfReferenceMax As Single
C# | public static Single HfReferenceMax;
C++ | public: static Single HfReferenceMax;
JScript | public static var HfReferenceMax : Single

Field Value

System.Single
Maximum value for the EffectsInteractive3DLevel2Reverb.HfReference property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.HfReference


Interactive3DLevel2ReverbEffect.HfReferenceMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.HfReferenceMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.HfReference property.

Definition

Visual Basic | Public Shared HfReferenceMin As Single
C# | public static Single HfReferenceMin;
C++ | public: static Single HfReferenceMin;
JScript | public static var HfReferenceMin : Single

Field Value

System.Single
Minimum value for the EffectsInteractive3DLevel2Reverb.HfReference property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.HfReference


Interactive3DLevel2ReverbEffect.QualityDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.QualityDefault Field

Retrieves the default value for the Interactive3DLevel2ReverbEffect.Quality property.

Definition

Visual Basic | Public Shared QualityDefault As Int32
C# | public static Int32 QualityDefault;
C++ | public: static Int32 QualityDefault;
JScript | public static var QualityDefault : Int32

Field Value

System.Int32
Default value for the Interactive3DLevel2ReverbEffect.Quality property.

This field is read-only.

See Also

  • Interactive3DLevel2ReverbEffect.Quality


Interactive3DLevel2ReverbEffect.QualityMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.QualityMax Field

Retrieves the maximum value for the Interactive3DLevel2ReverbEffect.Quality property.

Definition

Visual Basic | Public Shared QualityMax As Int32
C# | public static Int32 QualityMax;
C++ | public: static Int32 QualityMax;
JScript | public static var QualityMax : Int32

Field Value

System.Int32
Maximum value for the Interactive3DLevel2ReverbEffect.Quality property.

This field is read-only.

See Also

  • Interactive3DLevel2ReverbEffect.Quality


Interactive3DLevel2ReverbEffect.QualityMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.QualityMin Field

Retrieves the minimum value for the Interactive3DLevel2ReverbEffect.Quality property.

Definition

Visual Basic | Public Shared QualityMin As Int32
C# | public static Int32 QualityMin;
C++ | public: static Int32 QualityMin;
JScript | public static var QualityMin : Int32

Field Value

System.Int32
Minimum value for the Interactive3DLevel2ReverbEffect.Quality property.

This field is read-only.

See Also

  • Interactive3DLevel2ReverbEffect.Quality


Interactive3DLevel2ReverbEffect.ReflectionsDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReflectionsDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Reflections property.

Definition

Visual Basic | Public Shared ReflectionsDefault As Int32
C# | public static Int32 ReflectionsDefault;
C++ | public: static Int32 ReflectionsDefault;
JScript | public static var ReflectionsDefault : Int32

Field Value

System.Int32
Default value for the EffectsInteractive3DLevel2Reverb.Reflections property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reflections


Interactive3DLevel2ReverbEffect.ReflectionsDelayDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReflectionsDelayDefault Field

 Language:

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

Definition

Visual Basic | Public Shared ReflectionsDelayDefault As Single
C# | public static Single ReflectionsDelayDefault;
C++ | public: static Single ReflectionsDelayDefault;
JScript | public static var ReflectionsDelayDefault : Single

Field Value

System.Single
Default value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReflectionsDelay


Interactive3DLevel2ReverbEffect.ReflectionsDelayMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReflectionsDelayMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

Definition

Visual Basic | Public Shared ReflectionsDelayMax As Single
C# | public static Single ReflectionsDelayMax;
C++ | public: static Single ReflectionsDelayMax;
JScript | public static var ReflectionsDelayMax : Single

Field Value

System.Single
Maximum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReflectionsDelay


Interactive3DLevel2ReverbEffect.ReflectionsDelayMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReflectionsDelayMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

Definition

Visual Basic | Public Shared ReflectionsDelayMin As Single
C# | public static Single ReflectionsDelayMin;
C++ | public: static Single ReflectionsDelayMin;
JScript | public static var ReflectionsDelayMin : Single

Field Value

System.Single
Minimum value for the EffectsInteractive3DLevel2Reverb.ReflectionsDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReflectionsDelay


Interactive3DLevel2ReverbEffect.ReflectionsMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReflectionsMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Reflections property.

Definition

Visual Basic | Public Shared ReflectionsMax As Int32
C# | public static Int32 ReflectionsMax;
C++ | public: static Int32 ReflectionsMax;
JScript | public static var ReflectionsMax : Int32

Field Value

System.Int32
Maximum value for the EffectsInteractive3DLevel2Reverb.Reflections property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reflections


Interactive3DLevel2ReverbEffect.ReflectionsMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReflectionsMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Reflections property.

Definition

Visual Basic | Public Shared ReflectionsMin As Int32
C# | public static Int32 ReflectionsMin;
C++ | public: static Int32 ReflectionsMin;
JScript | public static var ReflectionsMin : Int32

Field Value

System.Int32
Minimum value for the EffectsInteractive3DLevel2Reverb.Reflections property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reflections


Interactive3DLevel2ReverbEffect.ReverbDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReverbDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Reverb property.

Definition

Visual Basic | Public Shared ReverbDefault As Int32
C# | public static Int32 ReverbDefault;
C++ | public: static Int32 ReverbDefault;
JScript | public static var ReverbDefault : Int32

Field Value

System.Int32
Default value for the EffectsInteractive3DLevel2Reverb.Reverb property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reverb


Interactive3DLevel2ReverbEffect.ReverbDelayDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReverbDelayDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

Definition

Visual Basic | Public Shared ReverbDelayDefault As Single
C# | public static Single ReverbDelayDefault;
C++ | public: static Single ReverbDelayDefault;
JScript | public static var ReverbDelayDefault : Single

Field Value

System.Single
Default value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReverbDelay


Interactive3DLevel2ReverbEffect.ReverbDelayMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReverbDelayMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

Definition

Visual Basic | Public Shared ReverbDelayMax As Single
C# | public static Single ReverbDelayMax;
C++ | public: static Single ReverbDelayMax;
JScript | public static var ReverbDelayMax : Single

Field Value

System.Single
Maximum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReverbDelay


Interactive3DLevel2ReverbEffect.ReverbDelayMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReverbDelayMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

Definition

Visual Basic | Public Shared ReverbDelayMin As Single
C# | public static Single ReverbDelayMin;
C++ | public: static Single ReverbDelayMin;
JScript | public static var ReverbDelayMin : Single

Field Value

System.Single
Minimum value for the EffectsInteractive3DLevel2Reverb.ReverbDelay property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.ReverbDelay


Interactive3DLevel2ReverbEffect.ReverbMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReverbMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Reverb property.

Definition

Visual Basic | Public Shared ReverbMax As Int32
C# | public static Int32 ReverbMax;
C++ | public: static Int32 ReverbMax;
JScript | public static var ReverbMax : Int32

Field Value

System.Int32
Maximum value for the EffectsInteractive3DLevel2Reverb.Reverb property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reverb


Interactive3DLevel2ReverbEffect.ReverbMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.ReverbMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Reverb property.

Definition

Visual Basic | Public Shared ReverbMin As Int32
C# | public static Int32 ReverbMin;
C++ | public: static Int32 ReverbMin;
JScript | public static var ReverbMin : Int32

Field Value

System.Int32
Minimum value for the EffectsInteractive3DLevel2Reverb.Reverb property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Reverb


Interactive3DLevel2ReverbEffect.RoomDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.Room property.

Definition

Visual Basic | Public Shared RoomDefault As Int32
C# | public static Int32 RoomDefault;
C++ | public: static Int32 RoomDefault;
JScript | public static var RoomDefault : Int32

Field Value

System.Int32
Default value for the EffectsInteractive3DLevel2Reverb.Room property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Room


Interactive3DLevel2ReverbEffect.RoomHfDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomHfDefault Field

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

Definition

Visual Basic | Public Shared RoomHfDefault As Int32
C# | public static Int32 RoomHfDefault;
C++ | public: static Int32 RoomHfDefault;
JScript | public static var RoomHfDefault : Int32

Field Value

System.Int32
Default value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomHf


Interactive3DLevel2ReverbEffect.RoomHfMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomHfMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

Definition

Visual Basic | Public Shared RoomHfMax As Int32
C# | public static Int32 RoomHfMax;
C++ | public: static Int32 RoomHfMax;
JScript | public static var RoomHfMax : Int32

Field Value

System.Int32
Maximum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomHf


Interactive3DLevel2ReverbEffect.RoomHfMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomHfMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

Definition

Visual Basic | Public Shared RoomHfMin As Int32
C# | public static Int32 RoomHfMin;
C++ | public: static Int32 RoomHfMin;
JScript | public static var RoomHfMin : Int32

Field Value

System.Int32
Minimum value for the EffectsInteractive3DLevel2Reverb.RoomHf property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomHf


Interactive3DLevel2ReverbEffect.RoomMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.Room property.

Definition

Visual Basic | Public Shared RoomMax As Int32
C# | public static Int32 RoomMax;
C++ | public: static Int32 RoomMax;
JScript | public static var RoomMax : Int32

Field Value

System.Int32
Maximum value for the EffectsInteractive3DLevel2Reverb.Room property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Room


Interactive3DLevel2ReverbEffect.RoomMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.Room property.

Definition

Visual Basic | Public Shared RoomMin As Int32
C# | public static Int32 RoomMin;
C++ | public: static Int32 RoomMin;
JScript | public static var RoomMin : Int32

Field Value

System.Int32
Minimum value for the EffectsInteractive3DLevel2Reverb.Room property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.Room


Interactive3DLevel2ReverbEffect.RoomRollOffFactorDefault Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomRollOffFactorDefault Field

 Language:

Retrieves the default value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

Definition

Visual Basic | Public Shared RoomRollOffFactorDefault As Single
C# | public static Single RoomRollOffFactorDefault;
C++ | public: static Single RoomRollOffFactorDefault;
JScript | public static var RoomRollOffFactorDefault : Single

Field Value

System.Single
Default value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomRollOffFactor


Interactive3DLevel2ReverbEffect.RoomRollOffFactorMax Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomRollOffFactorMax Field

Retrieves the maximum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

Definition

Visual Basic | Public Shared RoomRollOffFactorMax As Single
C# | public static Single RoomRollOffFactorMax;
C++ | public: static Single RoomRollOffFactorMax;
JScript | public static var RoomRollOffFactorMax : Single

Field Value

System.Single
Maximum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomRollOffFactor


Interactive3DLevel2ReverbEffect.RoomRollOffFactorMin Field (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.RoomRollOffFactorMin Field

Retrieves the minimum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

Definition

Visual Basic | Public Shared RoomRollOffFactorMin As Single
C# | public static Single RoomRollOffFactorMin;
C++ | public: static Single RoomRollOffFactorMin;
JScript | public static var RoomRollOffFactorMin : Single

Field Value

System.Single
Minimum value for the EffectsInteractive3DLevel2Reverb.RoomRollOffFactor property.

This field is read-only.

See Also

  • EffectsInteractive3DLevel2Reverb.RoomRollOffFactor


Interactive3DLevel2ReverbEffect.Disposing Event (Microsoft.DirectX.DirectSound)

Interactive3DLevel2ReverbEffect.Disposing Event

Occurs when the Dispose method is called or when the Interactive3DLevel2ReverbEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Interactive3DLevel2ReverbEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Interactive3DLevel2ReverbEffect object indicates whether that object has been disposed.


InvalidCallException Class (Microsoft.DirectX.DirectSound)

InvalidCallException Class

The method call is invalid. For example, a method's parameter might not be valid.

Definition

Visual Basic Public Class InvalidCallException
Inherits SoundException
C# | public class InvalidCallException : SoundException
C++ | public ref class InvalidCallException : SoundException
JScript | public class InvalidCallException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
InvalidCallException | Initializes a new instance of the InvalidCallException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
InvalidCallException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InvalidCallException.InvalidCallException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

InvalidCallException.InvalidCallException Constructor

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected InvalidCallException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
InvalidCallException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function InvalidCallException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


InvalidCallException.InvalidCallException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

InvalidCallException.InvalidCallException Constructor

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public InvalidCallException(
string message,
Exception inner
);
C++ public:
InvalidCallException(
String^ message,
Exception^ inner
);
JScript public function InvalidCallException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


InvalidCallException.InvalidCallException(String) Constructor (Microsoft.DirectX.DirectSound)

InvalidCallException.InvalidCallException Constructor

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public InvalidCallException(
string message
);
C++ public:
InvalidCallException(
String^ message
);
JScript public function InvalidCallException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


InvalidCallException.InvalidCallException() Constructor (Microsoft.DirectX.DirectSound)

InvalidCallException.InvalidCallException Constructor

Initializes a new instance of the InvalidCallException class.

Definition

Visual Basic | Public Sub New()
C# | public InvalidCallException();
C++ public:
InvalidCallException();
JScript | public function InvalidCallException();


Listener3D Class (Microsoft.DirectX.DirectSound)

Listener3D Class

Retrieves and sets parameters that describe a listener's position, orientation, and listening environment in 3-D space.

Definition

Visual Basic Public Class Listener3D
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Listener3D : MarshalByRefObject, IDisposable
C++ | public ref class Listener3D : MarshalByRefObject, IDisposable
JScript | public class Listener3D extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Listener3D object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) DistanceFactorDefault | Retrieves the default value for the Listener3D.DistanceFactor property.
static (Shared in Visual Basic) DistanceFactorMax | Retrieves the maximum value for the Listener3D.DistanceFactor property.
static (Shared in Visual Basic) DistanceFactorMin | Retrieves the minimum value for the Listener3D.DistanceFactor property.

Methods

Method | Description
CommitDeferredSettings | Commits any deferred settings made since the last call to this method.
Dispose | Immediately releases the unmanaged resources used by the Listener3D object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Listener3D object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
Listener3D | Initializes a new instance of the Listener3D class.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Listener3D.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves and sets all 3-D parameters of the sound environment and the listener.
Deferred | Determines if settings are set immediately or deferred.
Disposed | Gets a value that indicates whether the object is disposed.
DistanceFactor | Retrieves or sets the distance factor, which is the number of meters in a vector unit.
DopplerFactor | Retrieves or sets the multiplier for the Doppler effect.
Orientation | Retrieves or sets the orientation of the listener's head.
Position | Retrieves or sets the listener's position.
RolloffFactor | Retrieves and sets the rolloff factor, which determines the rate of attenuation over distance.
Velocity | Retrieves or sets the listener's velocity.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Listener3D

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Listener3D.CommitDeferredSettings() Method (Microsoft.DirectX.DirectSound)

Listener3D.CommitDeferredSettings Method

Commits any deferred settings made since the last call to this method.

Definition

Visual Basic | Public Sub CommitDeferredSettings()
C# | public void CommitDeferredSettings();
C++ public:
void CommitDeferredSettings();
JScript | public function CommitDeferredSettings();


Listener3D.Dispose() Method (Microsoft.DirectX.DirectSound)

Listener3D.Dispose Method

Immediately releases the unmanaged resources used by the Listener3D object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Listener3D();
JScript | public override function Dispose();

See Also

  • Listener3D.Disposed
  • Listener3D.Disposing


Listener3D.Equals(Object) Method (Microsoft.DirectX.DirectSound)

Listener3D.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Listener3D.Finalize() Method (Microsoft.DirectX.DirectSound)

Listener3D.Finalize Method

Allows the Listener3D object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Listener3D();
C++ | !Listener3D();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Listener3D.GetHashCode() Method (Microsoft.DirectX.DirectSound)

Listener3D.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Listener3D.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

Listener3D.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSound3DListener8, which allows unmanaged COM clients to create an instance of the managed Listener3D class. Not supported.


Listener3D.Listener3D Constructor ()

Initializes a new instance of the Listener3D class.

Overload List

public Listener3D(Buffer);
public Listener3D(IntPtr, Buffer);
public Listener3D(IntPtr, SecondaryBuffer);


Listener3D.Listener3D(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

Listener3D.Listener3D Constructor

Initializes a new instance of the object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal buff As SecondaryBuffer _
)
C# public Listener3D(
IntPtr lp,
SecondaryBuffer buff
);
C++ public:
Listener3D(
IntPtr lp,
SecondaryBuffer^ buff
);
JScript public function Listener3D(
lp : IntPtr,
buff : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXWavesReverb8, which allows unmanaged COM clients to create an instance of the managed Listener3D class. Not supported.
buff Microsoft.DirectX.DirectSound.SecondaryBuffer
A SecondaryBuffer object that acts as the sound source for the listener.


Listener3D.Listener3D(IntPtr,Buffer) Constructor (Microsoft.DirectX.DirectSound)

Listener3D.Listener3D Constructor

Initializes a new instance of the object. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal buff As Buffer _
)
C# public Listener3D(
IntPtr lp,
Buffer buff
);
C++ public:
Listener3D(
IntPtr lp,
Buffer^ buff
);
JScript public function Listener3D(
lp : IntPtr,
buff : Buffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXWavesReverb8, which allows unmanaged COM clients to create an instance of the managed Listener3D class. Not supported.
buff Microsoft.DirectX.DirectSound.Buffer
A Buffer object that acts as the sound source for the listener.


Listener3D.Listener3D(Buffer) Constructor (Microsoft.DirectX.DirectSound)

Listener3D.Listener3D Constructor

Initializes a new instance of the object using a primary Buffer object.

Definition

Visual Basic Public Sub New( _
ByVal lp As Buffer _
)
C# public Listener3D(
Buffer lp
);
C++ public:
Listener3D(
Buffer^ lp
);
JScript public function Listener3D(
lp : Buffer
);

Parameters

lp Microsoft.DirectX.DirectSound.Buffer
A primary Buffer object that acts as the sound source for the listener.

Remarks

The Buffer object passed to this method must have the PrimaryBuffer property set to true in its BufferDescription.


Listener3D.op_Equality(Listener3D,Listener3D) Method (Microsoft.DirectX.DirectSound)

Listener3D.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Listener3D, _
ByVal right As Listener3D _
) As Boolean
C# public static bool op_Equality(
Listener3D left,
Listener3D right
);
C++ public:
static bool operator==(
Listener3D^ left,
Listener3D^ right
);
JScript public static function op_Equality(
left : Listener3D,
right : Listener3D
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Listener3D
The Listener3D object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Listener3D
The Listener3D object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Listener3D.op_Inequality(Listener3D,Listener3D) Method (Microsoft.DirectX.DirectSound)

Listener3D.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Listener3D, _
ByVal right As Listener3D _
) As Boolean
C# public static bool op_Inequality(
Listener3D left,
Listener3D right
);
C++ public:
static bool operator!=(
Listener3D^ left,
Listener3D^ right
);
JScript public static function op_Inequality(
left : Listener3D,
right : Listener3D
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Listener3D
The Listener3D object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Listener3D
The Listener3D object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Listener3D.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

Listener3D.raise_Disposing Method

Raises the Listener3D.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Listener3D.AllParameters Property (Microsoft.DirectX.DirectSound)

Listener3D.AllParameters Property

Retrieves and sets all 3-D parameters of the sound environment and the listener.

Definition

Visual Basic | Public Property AllParameters As Listener3DSettings
C# | public Listener3DSettings AllParameters { get; set; }
C++ public:
property Listener3DSettings AllParameters {
Listener3DSettings get();
void set(Listener3DSettings value);
}
JScript public function get AllParameters() : Listener3DSettings
public function set AllParameters(Listener3DSettings);

Property Value

Microsoft.DirectX.DirectSound.Listener3DSettings
Contains the 3-D parameters for the sound environment and the listener.

This property is read/write.

Remarks

If the Deferred property of the Listener3D object is set to true, the parameters are not applied until the application calls the CommitDeferredSettings method of the Listener3D object. Otherwise, the parameters are applied immediately, causing the system to recalculate the 3-D coordinates.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.Deferred Property (Microsoft.DirectX.DirectSound)

Listener3D.Deferred Property

Determines if settings are set immediately or deferred.

Definition

Visual Basic | Public Property Deferred As Boolean
C# | public bool Deferred { get; set; }
C++ public:
property bool Deferred {
bool get();
void set(bool value);
}
JScript public function get Deferred() : boolean
public function set Deferred(boolean);

Property Value

System.Boolean
Value that is false if the settings are set immediately at play time, or true if settings are set with the CommitDeferredSettings mothod.

This property is read/write.

Remarks

Every change to 3-D sound buffer and listener settings causes remixing, at the expense of CPU cycles. To minimize the performance impact of changing 3-D settings, set the Deferred property of the Listener3D object to true. Then call the CommitDeferredSettings method to execute all of the deferred commands at once.

Deferred settings are overwritten by immediate settings.


Listener3D.Disposed Property (Microsoft.DirectX.DirectSound)

Listener3D.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Listener3D.DistanceFactor Property (Microsoft.DirectX.DirectSound)

Listener3D.DistanceFactor Property

Retrieves or sets the distance factor, which is the number of meters in a vector unit.

Definition

Visual Basic | Public Property DistanceFactor As Single
C# | public float DistanceFactor { get; set; }
C++ public:
property float DistanceFactor {
float get();
void set(float value);
}
JScript public function get DistanceFactor() : float
public function set DistanceFactor(float);

Property Value

System.Single
The distance factor, which is the number of meters in a vector unit.

This property is read/write.

Remarks

Can range from Listener3D.DistanceFactorMin to Listener3D.DistanceFactorMax.

The default value is 1 meter or Listener3D.DistanceFactorDefault.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.DopplerFactor Property (Microsoft.DirectX.DirectSound)

Listener3D.DopplerFactor Property

Retrieves or sets the multiplier for the Doppler effect.

Definition

Visual Basic | Public Property DopplerFactor As Single
C# | public float DopplerFactor { get; set; }
C++ public:
property float DopplerFactor {
float get();
void set(float value);
}
JScript public function get DopplerFactor() : float
public function set DopplerFactor(float);

Property Value

System.Single
The multiplier for the Doppler effect.

This property is read/write.

Remarks

The Doppler factor has a range of 0.0 (no Doppler effects) to 10.0 (ten times the Doppler effects found in the real world). The default value is 1.0.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.Orientation Property (Microsoft.DirectX.DirectSound)

Listener3D.Orientation Property

Retrieves or sets the orientation of the listener's head.

Definition

Visual Basic | Public Property Orientation As Listener3DOrientation
C# | public Listener3DOrientation Orientation { get; set; }
C++ public:
property Listener3DOrientation Orientation {
Listener3DOrientation get();
void set(Listener3DOrientation value);
}
JScript public function get Orientation() : Listener3DOrientation
public function set Orientation(Listener3DOrientation);

Property Value

Microsoft.DirectX.DirectSound.Listener3DOrientation
The orientation of the listener's head.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.Position Property (Microsoft.DirectX.DirectSound)

Listener3D.Position Property

Retrieves or sets the listener's position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
The listener's position.

This property is read/write.

Remarks

By default, measurement units are in meters. This can be changed using the Listener3D.DistanceFactor property.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.RolloffFactor Property (Microsoft.DirectX.DirectSound)

Listener3D.RolloffFactor Property

Retrieves and sets the rolloff factor, which determines the rate of attenuation over distance.

Definition

Visual Basic | Public Property RolloffFactor As Single
C# | public float RolloffFactor { get; set; }
C++ public:
property float RolloffFactor {
float get();
void set(float value);
}
JScript public function get RolloffFactor() : float
public function set RolloffFactor(float);

Property Value

System.Single
The rolloff factor, which determines the rate of attenuation over distance.

This property is read/write.

Remarks

The rolloff factor has a range of 0.0 (no rolloff) to 10.0 (ten times the rolloff found in the real world). The default value is 1.0.

The rolloff factor is global. To change the effect of distance for an individual sound buffer, you can set the minimum distance for the buffer.

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.


Listener3D.Velocity Property (Microsoft.DirectX.DirectSound)

Listener3D.Velocity Property

Retrieves or sets the listener's velocity.

Definition

Visual Basic | Public Property Velocity As Vector3
C# | public Vector3 Velocity { get; set; }
C++ public:
property Vector3 Velocity {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Velocity() : Vector3
public function set Velocity(Vector3);

Property Value

Microsoft.DirectX.Vector3
The listener's velocity.

This property is read/write.

Remarks

Velocity is used only for Doppler effects. It does not actually move the listener. To change the listener's position, use the Listener3D.Position property. The default velocity is (0,0,0).

By default, measurement units are meters per second. This can be changed using the Listener3D.DistanceFactor property.


Listener3D.DistanceFactorDefault Field (Microsoft.DirectX.DirectSound)

Listener3D.DistanceFactorDefault Field

Retrieves the default value for the Listener3D.DistanceFactor property.

Definition

Visual Basic | Public Shared DistanceFactorDefault As Single
C# | public static Single DistanceFactorDefault;
C++ | public: static Single DistanceFactorDefault;
JScript | public static var DistanceFactorDefault : Single

Field Value

System.Single
Default value for the Listener3D.DistanceFactor property in meters. Default value is 1.0.

This field is read-only.


Listener3D.DistanceFactorMax Field (Microsoft.DirectX.DirectSound)

Listener3D.DistanceFactorMax Field

Retrieves the maximum value for the Listener3D.DistanceFactor property.

Definition

Visual Basic | Public Shared DistanceFactorMax As Single
C# | public static Single DistanceFactorMax;
C++ | public: static Single DistanceFactorMax;
JScript | public static var DistanceFactorMax : Single

Field Value

System.Single
Maximum value for the Listener3D.DistanceFactor property in meters.

This field is read-only.


Listener3D.DistanceFactorMin Field (Microsoft.DirectX.DirectSound)

Listener3D.DistanceFactorMin Field

Retrieves the minimum value for the Listener3D.DistanceFactor property.

Definition

Visual Basic | Public Shared DistanceFactorMin As Single
C# | public static Single DistanceFactorMin;
C++ | public: static Single DistanceFactorMin;
JScript | public static var DistanceFactorMin : Single

Field Value

System.Single
Minimum value for the Listener3D.DistanceFactor property in meters.

This field is read-only.


Listener3D.Disposing Event (Microsoft.DirectX.DirectSound)

Listener3D.Disposing Event

Occurs when the Dispose method is called or when the Listener3D object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Listener3D.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Listener3D object indicates whether that object has been disposed.


NoAggregationException Class (Microsoft.DirectX.DirectSound)

NoAggregationException Class

The object does not support aggregation.

Definition

Visual Basic Public Class NoAggregationException
Inherits SoundException
C# | public class NoAggregationException : SoundException
C++ | public ref class NoAggregationException : SoundException
JScript | public class NoAggregationException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoAggregationException | Initializes a new instance of the NoAggregationException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
NoAggregationException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoAggregationException.NoAggregationException Constructor ()

Initializes a new instance of the NoAggregationException class.

Overload List

public NoAggregationException();
protected NoAggregationException(SerializationInfo, StreamingContext);
public NoAggregationException(string);
public NoAggregationException(string, Exception);


NoAggregationException.NoAggregationException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

NoAggregationException.NoAggregationException Constructor

Initializes a new instance of the NoAggregationException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoAggregationException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoAggregationException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoAggregationException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


NoAggregationException.NoAggregationException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

NoAggregationException.NoAggregationException Constructor

Initializes a new instance of the NoAggregationException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoAggregationException(
string message,
Exception inner
);
C++ public:
NoAggregationException(
String^ message,
Exception^ inner
);
JScript public function NoAggregationException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


NoAggregationException.NoAggregationException(String) Constructor (Microsoft.DirectX.DirectSound)

NoAggregationException.NoAggregationException Constructor

Initializes a new instance of the NoAggregationException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoAggregationException(
string message
);
C++ public:
NoAggregationException(
String^ message
);
JScript public function NoAggregationException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


NoAggregationException.NoAggregationException() Constructor (Microsoft.DirectX.DirectSound)

NoAggregationException.NoAggregationException Constructor

Initializes a new instance of the NoAggregationException class.

Definition

Visual Basic | Public Sub New()
C# | public NoAggregationException();
C++ public:
NoAggregationException();
JScript | public function NoAggregationException();


NoDriverException Class (Microsoft.DirectX.DirectSound)

NoDriverException Class

No sound driver is available for use, or the given globally unique identifier (GUID) is not a valid Microsoft DirectSound device ID.

Definition

Visual Basic Public Class NoDriverException
Inherits SoundException
C# | public class NoDriverException : SoundException
C++ | public ref class NoDriverException : SoundException
JScript | public class NoDriverException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
NoDriverException | Initializes a new instance of the NoDriverException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
NoDriverException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NoDriverException.NoDriverException Constructor ()

Initializes a new instance of the NoDriverException class.

Overload List

public NoDriverException();
protected NoDriverException(SerializationInfo, StreamingContext);
public NoDriverException(string);
public NoDriverException(string, Exception);


NoDriverException.NoDriverException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

NoDriverException.NoDriverException Constructor

Initializes a new instance of the NoDriverException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected NoDriverException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
NoDriverException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function NoDriverException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


NoDriverException.NoDriverException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

NoDriverException.NoDriverException Constructor

Initializes a new instance of the NoDriverException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public NoDriverException(
string message,
Exception inner
);
C++ public:
NoDriverException(
String^ message,
Exception^ inner
);
JScript public function NoDriverException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


NoDriverException.NoDriverException(String) Constructor (Microsoft.DirectX.DirectSound)

NoDriverException.NoDriverException Constructor

Initializes a new instance of the NoDriverException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public NoDriverException(
string message
);
C++ public:
NoDriverException(
String^ message
);
JScript public function NoDriverException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


NoDriverException.NoDriverException() Constructor (Microsoft.DirectX.DirectSound)

NoDriverException.NoDriverException Constructor

Initializes a new instance of the NoDriverException class.

Definition

Visual Basic | Public Sub New()
C# | public NoDriverException();
C++ public:
NoDriverException();
JScript | public function NoDriverException();


Notify Class (Microsoft.DirectX.DirectSound)

Notify Class

Sets up notification events for a playback or capture buffer.

Definition

Visual Basic Public Class Notify
Inherits MarshalByRefObject
Implements IDisposable
C# | public class Notify : MarshalByRefObject, IDisposable
C++ | public ref class Notify : MarshalByRefObject, IDisposable
JScript | public class Notify extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the Notify object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the Notify object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the Notify object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
Notify | Initializes a new instance of the Notify class.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the Notify.Disposing event when called from within a derived class.
SetNotificationPositions | Sets the notification positions for triggering events during capture or playback.

Properties

Property | Description
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Notify

Remarks

A SecondaryBuffer object will support notification events only if its BufferDescription.ControlPositionNotify is set to true.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Notify.Dispose() Method (Microsoft.DirectX.DirectSound)

Notify.Dispose Method

Immediately releases the unmanaged resources used by the Notify object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~Notify();
JScript | public override function Dispose();

See Also

  • Notify.Disposed
  • Notify.Disposing


Notify.Equals(Object) Method (Microsoft.DirectX.DirectSound)

Notify.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Notify.Finalize() Method (Microsoft.DirectX.DirectSound)

Notify.Finalize Method

Allows the Notify object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~Notify();
C++ | !Notify();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


Notify.GetHashCode() Method (Microsoft.DirectX.DirectSound)

Notify.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Notify.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

Notify.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundNotify8, which allows unmanaged COM clients to create an instance of the managed Notify class. Not supported.


Notify.Notify Constructor ()

Initializes a new instance of the Notify class.

Overload List

public Notify(Buffer);
public Notify(CaptureBuffer);
public Notify(SecondaryBuffer);


Notify.Notify(CaptureBuffer) Constructor (Microsoft.DirectX.DirectSound)

Notify.Notify Constructor

Initializes a new instance of the Notify class.

Definition

Visual Basic Public Sub New( _
ByVal lp As CaptureBuffer _
)
C# public Notify(
CaptureBuffer lp
);
C++ public:
Notify(
CaptureBuffer^ lp
);
JScript public function Notify(
lp : CaptureBuffer
);

Parameters

lp Microsoft.DirectX.DirectSound.CaptureBuffer
The CaptureBuffer that will trigger the notification events.


Notify.Notify(SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

Notify.Notify Constructor

Initializes a new instance of the Notify class.

Definition

Visual Basic Public Sub New( _
ByVal lp As SecondaryBuffer _
)
C# public Notify(
SecondaryBuffer lp
);
C++ public:
Notify(
SecondaryBuffer^ lp
);
JScript public function Notify(
lp : SecondaryBuffer
);

Parameters

lp Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that will trigger the notification events.


Notify.Notify(Buffer) Constructor (Microsoft.DirectX.DirectSound)

Notify.Notify Constructor

Initializes a new instance of the Notify class.

Definition

Visual Basic Public Sub New( _
ByVal lp As Buffer _
)
C# public Notify(
Buffer lp
);
C++ public:
Notify(
Buffer^ lp
);
JScript public function Notify(
lp : Buffer
);

Parameters

lp Microsoft.DirectX.DirectSound.Buffer
The Buffer that will trigger the notification events.


Notify.op_Equality(Notify,Notify) Method (Microsoft.DirectX.DirectSound)

Notify.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Notify, _
ByVal right As Notify _
) As Boolean
C# public static bool op_Equality(
Notify left,
Notify right
);
C++ public:
static bool operator==(
Notify^ left,
Notify^ right
);
JScript public static function op_Equality(
left : Notify,
right : Notify
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Notify
The Notify object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Notify
The Notify object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


Notify.op_Inequality(Notify,Notify) Method (Microsoft.DirectX.DirectSound)

Notify.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Notify, _
ByVal right As Notify _
) As Boolean
C# public static bool op_Inequality(
Notify left,
Notify right
);
C++ public:
static bool operator!=(
Notify^ left,
Notify^ right
);
JScript public static function op_Inequality(
left : Notify,
right : Notify
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.Notify
The Notify object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.Notify
The Notify object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


Notify.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

Notify.raise_Disposing Method

Raises the Notify.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


Notify.SetNotificationPositions Method ()

Sets the notification positions for triggering events during capture or playback.

Overload List

public void SetNotificationPositions(BufferPositionNotify[]);
public void SetNotificationPositions(BufferPositionNotify[], int);

Remarks

During capture or playback, the associated event is signaled whenever the read or play cursor reaches one of the notification positions set by this method.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft DirectSound could not allocate sufficient memory to complete the call.

See Also

  • BufferPositionNotify


Notify.SetNotificationPositions(BufferPositionNotify[],Int32) Method (Microsoft.DirectX.DirectSound)

Notify.SetNotificationPositions Method

Sets the notification positions for triggering events during capture or playback.

Definition

Visual Basic Public Sub SetNotificationPositions( _
ByVal notify() As BufferPositionNotify, _
ByVal numNotificationPositions As Integer _
)
C# public void SetNotificationPositions(
BufferPositionNotify[] notify,
int numNotificationPositions
);
C++ public:
void SetNotificationPositions(
array<BufferPositionNotify>^ notify,
int numNotificationPositions
);
JScript public function SetNotificationPositions(
notify : BufferPositionNotify[],
numNotificationPositions : int
);

Parameters

notify Microsoft.DirectX.DirectSound.BufferPositionNotify[]
An array of BufferPositionNotify structures that describe the notification positions.
numNotificationPositions System.Int32
Length of notify.

Remarks

During capture or playback, the associated event is signaled whenever the read or play cursor reaches one of the notification positions set by this method.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft DirectSound could not allocate sufficient memory to complete the call.

See Also

  • BufferPositionNotify


Notify.SetNotificationPositions(BufferPositionNotify[]) Method (Microsoft.DirectX.DirectSound)

Notify.SetNotificationPositions Method

Sets the notification positions for triggering events during capture or playback.

Definition

Visual Basic Public Sub SetNotificationPositions( _
ByVal notify() As BufferPositionNotify _
)
C# public void SetNotificationPositions(
BufferPositionNotify[] notify
);
C++ public:
void SetNotificationPositions(
array<BufferPositionNotify>^ notify
);
JScript public function SetNotificationPositions(
notify : BufferPositionNotify[]
);

Parameters

notify Microsoft.DirectX.DirectSound.BufferPositionNotify[]
An array of BufferPositionNotify structures that describe the notification positions.

Remarks

During capture or playback, the associated event is signaled whenever the read or play cursor reaches one of the notification positions set by this method.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
OutOfMemoryException Leave Site | Microsoft DirectSound could not allocate sufficient memory to complete the call.

See Also

  • BufferPositionNotify


Notify.Disposed Property (Microsoft.DirectX.DirectSound)

Notify.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


Notify.Disposing Event (Microsoft.DirectX.DirectSound)

Notify.Disposing Event

Occurs when the Dispose method is called or when the Notify object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the Notify.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the Notify object indicates whether that object has been disposed.


ObjectNotFoundException Class (Microsoft.DirectX.DirectSound)

ObjectNotFoundException Class

The requested object was not found.

Definition

Visual Basic Public Class ObjectNotFoundException
Inherits SoundException
C# | public class ObjectNotFoundException : SoundException
C++ | public ref class ObjectNotFoundException : SoundException
JScript | public class ObjectNotFoundException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ObjectNotFoundException | Initializes a new instance of the ObjectNotFoundException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
ObjectNotFoundException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ObjectNotFoundException.ObjectNotFoundException Constructor ()

Initializes a new instance of the ObjectNotFoundException class.

Overload List

public ObjectNotFoundException();
protected ObjectNotFoundException(SerializationInfo, StreamingContext);
public ObjectNotFoundException(string);
public ObjectNotFoundException(string, Exception);


ObjectNotFoundException.ObjectNotFoundException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

ObjectNotFoundException.ObjectNotFoundException Constructor

Initializes a new instance of the ObjectNotFoundException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected ObjectNotFoundException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
ObjectNotFoundException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function ObjectNotFoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


ObjectNotFoundException.ObjectNotFoundException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

ObjectNotFoundException.ObjectNotFoundException Constructor

Initializes a new instance of the ObjectNotFoundException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public ObjectNotFoundException(
string message,
Exception inner
);
C++ public:
ObjectNotFoundException(
String^ message,
Exception^ inner
);
JScript public function ObjectNotFoundException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


ObjectNotFoundException.ObjectNotFoundException(String) Constructor (Microsoft.DirectX.DirectSound)

ObjectNotFoundException.ObjectNotFoundException Constructor

Initializes a new instance of the ObjectNotFoundException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public ObjectNotFoundException(
string message
);
C++ public:
ObjectNotFoundException(
String^ message
);
JScript public function ObjectNotFoundException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


ObjectNotFoundException.ObjectNotFoundException() Constructor (Microsoft.DirectX.DirectSound)

ObjectNotFoundException.ObjectNotFoundException Constructor

Initializes a new instance of the ObjectNotFoundException class.

Definition

Visual Basic | Public Sub New()
C# | public ObjectNotFoundException();
C++ public:
ObjectNotFoundException();
JScript | public function ObjectNotFoundException();


OtherApplicationHasPriorityException Class (Microsoft.DirectX.DirectSound)

OtherApplicationHasPriorityException Class

Another application has a higher priority level, preventing this call from succeeding.

Definition

Visual Basic Public Class OtherApplicationHasPriorityException
Inherits SoundException
C# | public class OtherApplicationHasPriorityException : SoundException
C++ | public ref class OtherApplicationHasPriorityException : SoundException
JScript | public class OtherApplicationHasPriorityException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
OtherApplicationHasPriorityException | Initializes a new instance of the OtherApplicationHasPriorityException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
OtherApplicationHasPriorityException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor ()

Initializes a new instance of the OtherApplicationHasPriorityException class.

Overload List

public OtherApplicationHasPriorityException();
protected OtherApplicationHasPriorityException(SerializationInfo, StreamingContext);
public OtherApplicationHasPriorityException(string);
public OtherApplicationHasPriorityException(string, Exception);


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected OtherApplicationHasPriorityException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
OtherApplicationHasPriorityException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function OtherApplicationHasPriorityException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public OtherApplicationHasPriorityException(
string message,
Exception inner
);
C++ public:
OtherApplicationHasPriorityException(
String^ message,
Exception^ inner
);
JScript public function OtherApplicationHasPriorityException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException(String) Constructor (Microsoft.DirectX.DirectSound)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public OtherApplicationHasPriorityException(
string message
);
C++ public:
OtherApplicationHasPriorityException(
String^ message
);
JScript public function OtherApplicationHasPriorityException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


OtherApplicationHasPriorityException.OtherApplicationHasPriorityException() Constructor (Microsoft.DirectX.DirectSound)

OtherApplicationHasPriorityException.OtherApplicationHasPriorityException Constructor

 Language:

Initializes a new instance of the OtherApplicationHasPriorityException class.

Definition

Visual Basic | Public Sub New()
C# | public OtherApplicationHasPriorityException();
C++ public:
OtherApplicationHasPriorityException();
JScript | public function OtherApplicationHasPriorityException();


ParamEqEffect Class (Microsoft.DirectX.DirectSound)

ParamEqEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports parametric equalizer effects.

Definition

Visual Basic Public Class ParamEqEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class ParamEqEffect : MarshalByRefObject, IDisposable
C++ | public ref class ParamEqEffect : MarshalByRefObject, IDisposable
JScript | public class ParamEqEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the ParamEqEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) BandwidthMax | Retrives the maximum value for the EffectsParamEq.Bandwidth property.
static (Shared in Visual Basic) BandwidthMin | Retrives the minimum value for the EffectsParamEq.Bandwidth property.
static (Shared in Visual Basic) CenterMax | Retrives the maximum value for the EffectsParamEq.Center property.
static (Shared in Visual Basic) CenterMin | Retrives the minimum value for the EffectsParamEq.Center property.
static (Shared in Visual Basic) GainMax | Retrieves the maximum value for the EffectsParamEq.Gain property.
static (Shared in Visual Basic) GainMin | Retrieves the minimum value for the EffectsParamEq.Gain property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the ParamEqEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the ParamEqEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
ParamEqEffect | Initializes a new instance of the ParamEqEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.
raise_Disposing | Raises the ParamEqEffect.Disposing event when called from within a derived class.

Properties

Property | Description
AllParameters | Retrieves or sets parametric equalizer parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
ParamEqEffect

Remarks

Obtain this object by calling on the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ParamEqEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

ParamEqEffect.Dispose Method

Immediately releases the unmanaged resources used by the ParamEqEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~ParamEqEffect();
JScript | public override function Dispose();

See Also

  • ParamEqEffect.Disposed
  • ParamEqEffect.Disposing


ParamEqEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

ParamEqEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


ParamEqEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

ParamEqEffect.Finalize Method

Allows the ParamEqEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~ParamEqEffect();
C++ | !ParamEqEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


ParamEqEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

ParamEqEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


ParamEqEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

ParamEqEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXParamEq8, which allows unmanaged COM clients to create an instance of the managed ParamEqEffect class. Not supported.


ParamEqEffect.op_Equality(ParamEqEffect,ParamEqEffect) Method (Microsoft.DirectX.DirectSound)

ParamEqEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As ParamEqEffect, _
ByVal right As ParamEqEffect _
) As Boolean
C# public static bool op_Equality(
ParamEqEffect left,
ParamEqEffect right
);
C++ public:
static bool operator==(
ParamEqEffect^ left,
ParamEqEffect^ right
);
JScript public static function op_Equality(
left : ParamEqEffect,
right : ParamEqEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.ParamEqEffect
The ParamEqEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.ParamEqEffect
The ParamEqEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


ParamEqEffect.op_Inequality(ParamEqEffect,ParamEqEffect) Method (Microsoft.DirectX.DirectSound)

ParamEqEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As ParamEqEffect, _
ByVal right As ParamEqEffect _
) As Boolean
C# public static bool op_Inequality(
ParamEqEffect left,
ParamEqEffect right
);
C++ public:
static bool operator!=(
ParamEqEffect^ left,
ParamEqEffect^ right
);
JScript public static function op_Inequality(
left : ParamEqEffect,
right : ParamEqEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.ParamEqEffect
The ParamEqEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.ParamEqEffect
The ParamEqEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


ParamEqEffect.ParamEqEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

ParamEqEffect.ParamEqEffect Constructor

Initializes a new instance of the ParamEqEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public ParamEqEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
ParamEqEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function ParamEqEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXParamEq8, which allows unmanaged COM clients to create an instance of the managed ParamEqEffect class. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the ParamEqEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


ParamEqEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

ParamEqEffect.raise_Disposing Method

Raises the ParamEqEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


ParamEqEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

ParamEqEffect.AllParameters Property

How Do I...?
  • Use Effect Parameters

Retrieves or sets parametric equalizer parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsParamEq
C# | public EffectsParamEq AllParameters { get; set; }
C++ public:
property EffectsParamEq AllParameters {
EffectsParamEq get();
void set(EffectsParamEq value);
}
JScript public function get AllParameters() : EffectsParamEq
public function set AllParameters(EffectsParamEq);

Property Value

Microsoft.DirectX.DirectSound.EffectsParamEq
Contains parameters for a parametric equalizer effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • Effect Parameters


ParamEqEffect.Disposed Property (Microsoft.DirectX.DirectSound)

ParamEqEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


ParamEqEffect.BandwidthMax Field (Microsoft.DirectX.DirectSound)

ParamEqEffect.BandwidthMax Field

Retrives the maximum value for the EffectsParamEq.Bandwidth property.

Definition

Visual Basic | Public Shared BandwidthMax As Single
C# | public static Single BandwidthMax;
C++ | public: static Single BandwidthMax;
JScript | public static var BandwidthMax : Single

Field Value

System.Single
Maximum value for the EffectsParamEq.Bandwidth property.

This field is read-only.

See Also

  • EffectsParamEq.Bandwidth


ParamEqEffect.BandwidthMin Field (Microsoft.DirectX.DirectSound)

ParamEqEffect.BandwidthMin Field

Retrives the minimum value for the EffectsParamEq.Bandwidth property.

Definition

Visual Basic | Public Shared BandwidthMin As Single
C# | public static Single BandwidthMin;
C++ | public: static Single BandwidthMin;
JScript | public static var BandwidthMin : Single

Field Value

System.Single
Minimum value for the EffectsParamEq.Bandwidth property.

This field is read-only.

See Also

  • EffectsParamEq.Bandwidth


ParamEqEffect.CenterMax Field (Microsoft.DirectX.DirectSound)

ParamEqEffect.CenterMax Field

Retrives the maximum value for the EffectsParamEq.Center property.

Definition

Visual Basic | Public Shared CenterMax As Single
C# | public static Single CenterMax;
C++ | public: static Single CenterMax;
JScript | public static var CenterMax : Single

Field Value

System.Single
Maximum value for the EffectsParamEq.Center.

This field is read-only.

See Also

  • EffectsParamEq.Center


ParamEqEffect.CenterMin Field (Microsoft.DirectX.DirectSound)

ParamEqEffect.CenterMin Field

Retrives the minimum value for the EffectsParamEq.Center property.

Definition

Visual Basic | Public Shared CenterMin As Single
C# | public static Single CenterMin;
C++ | public: static Single CenterMin;
JScript | public static var CenterMin : Single

Field Value

System.Single
Minimum value for the EffectsParamEq.Center.

This field is read-only.

See Also

  • EffectsParamEq.Center


ParamEqEffect.GainMax Field (Microsoft.DirectX.DirectSound)

ParamEqEffect.GainMax Field

Retrieves the maximum value for the EffectsParamEq.Gain property.

Definition

Visual Basic | Public Shared GainMax As Single
C# | public static Single GainMax;
C++ | public: static Single GainMax;
JScript | public static var GainMax : Single

Field Value

System.Single
Maximum value for the EffectsParamEq.Gain property.

This field is read-only.

See Also

  • EffectsParamEq.Gain


ParamEqEffect.GainMin Field (Microsoft.DirectX.DirectSound)

ParamEqEffect.GainMin Field

Retrieves the minimum value for the EffectsParamEq.Gain property.

Definition

Visual Basic | Public Shared GainMin As Single
C# | public static Single GainMin;
C++ | public: static Single GainMin;
JScript | public static var GainMin : Single

Field Value

System.Single
Minimum value for the EffectsParamEq.Gain property.

This field is read-only.

See Also

  • EffectsParamEq.Gain


ParamEqEffect.Disposing Event (Microsoft.DirectX.DirectSound)

ParamEqEffect.Disposing Event

Occurs when the Dispose method is called or when the ParamEqEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the ParamEqEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the ParamEqEffect object indicates whether that object has been disposed.


PriorityLevelNeededException Class (Microsoft.DirectX.DirectSound)

PriorityLevelNeededException Class

A cooperative level of Priority or higher is required.

Definition

Visual Basic Public Class PriorityLevelNeededException
Inherits SoundException
C# | public class PriorityLevelNeededException : SoundException
C++ | public ref class PriorityLevelNeededException : SoundException
JScript | public class PriorityLevelNeededException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
PriorityLevelNeededException | Initializes a new instance of the PriorityLevelNeededException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
PriorityLevelNeededException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


PriorityLevelNeededException.PriorityLevelNeededException Constructor ()

Initializes a new instance of the PriorityLevelNeededException class.

Overload List

public PriorityLevelNeededException();
protected PriorityLevelNeededException(SerializationInfo, StreamingContext);
public PriorityLevelNeededException(string);
public PriorityLevelNeededException(string, Exception);


PriorityLevelNeededException.PriorityLevelNeededException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:

Initializes a new instance of the PriorityLevelNeededException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected PriorityLevelNeededException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
PriorityLevelNeededException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function PriorityLevelNeededException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


PriorityLevelNeededException.PriorityLevelNeededException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:

Initializes a new instance of the PriorityLevelNeededException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public PriorityLevelNeededException(
string message,
Exception inner
);
C++ public:
PriorityLevelNeededException(
String^ message,
Exception^ inner
);
JScript public function PriorityLevelNeededException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


PriorityLevelNeededException.PriorityLevelNeededException(String) Constructor (Microsoft.DirectX.DirectSound)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:

Initializes a new instance of the PriorityLevelNeededException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public PriorityLevelNeededException(
string message
);
C++ public:
PriorityLevelNeededException(
String^ message
);
JScript public function PriorityLevelNeededException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


PriorityLevelNeededException.PriorityLevelNeededException() Constructor (Microsoft.DirectX.DirectSound)

PriorityLevelNeededException.PriorityLevelNeededException Constructor

 Language:

Initializes a new instance of the PriorityLevelNeededException class.

Definition

Visual Basic | Public Sub New()
C# | public PriorityLevelNeededException();
C++ public:
PriorityLevelNeededException();
JScript | public function PriorityLevelNeededException();


SecondaryBuffer Class (Microsoft.DirectX.DirectSound)

SecondaryBuffer Class

Contains methods and properties used to manage sound buffers that can support effects.

Definition

Visual Basic Public Class SecondaryBuffer
Inherits Buffer
C# | public class SecondaryBuffer : Buffer
C++ | public ref class SecondaryBuffer : Buffer
JScript | public class SecondaryBuffer extends Buffer

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the SecondaryBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
AcquireResources | Allocates resources for a SecondaryBuffer object that was created with the DeferLocation flag set in the BufferDescription.
Clone | Duplicates the SecondaryBuffer object.
Clone | Duplicates the buffer object. Inherited from Buffer.
Dispose | Immediately releases the unmanaged resources used by the SecondaryBuffer object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the SecondaryBuffer object to free resources before it is destroyed by the garbage collector.
GetCurrentPosition | Retrieves the position of the play and write cursors in the sound buffer. Inherited from Buffer.
GetEffects | Retrieves a Microsoft DirectSound effect object or objects from a SecondaryBuffer object.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
GetObjectInPath | Retrieves a DirectSound effect object at a particular index from a SecondaryBuffer object.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same. Inherited from Buffer.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different. Inherited from Buffer.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Play | Begin playing the sound buffer, starting at the play cursor. Inherited from Buffer.
raise_Disposing | Raises the SecondaryBuffer.Disposing event when called from within a derived class.
Read | Reads the current data in the buffer. Inherited from Buffer.
Restore | Restores the memory allocation for a lost sound buffer. Inherited from Buffer.
SecondaryBuffer | Initializes a new instance of the SecondaryBuffer class.
SetCurrentPosition | Sets the position of the play cursor, which is the point at which the next byte of data is read from the buffer. Inherited from Buffer.
SetEffects | Enables effects on a SecondaryBuffer object.
Stop | Causes the sound buffer to stop playing. Inherited from Buffer.
Write | Writes data to the buffer. Inherited from Buffer.

Properties

Property | Description
Caps | Retrieves the capabilities of the buffer object. Inherited from Buffer.
Disposed | Gets a value that indicates whether the object is disposed.
Format | Retrieves or sets a description of the sound data format in the buffer. Inherited from Buffer.
Frequency | Retrieves or sets the frequency, in samples per second, at which the buffer is playing. Inherited from Buffer.
NotVirtualized | Retrieves a value that indicates whether the buffer is virtualized. Inherited from Buffer.
Pan | Retrieves or sets the relative volume of the left and right audio channels. Inherited from Buffer.
PlayPosition | Retrieves the position of the play cursor in the sound buffer. Inherited from Buffer.
Status | Retrieves the status of the sound buffer. Inherited from Buffer.
Volume | Retrieves or sets the attenuation of the sound. Inherited from Buffer.
WritePosition | Retrieves the position of the write cursor in the sound buffer. Inherited from Buffer.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Buffer
SecondaryBuffer

Remarks

SecondaryBuffer objects are derived from the Buffer class and can support effects; Buffer objects do not support effects.

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SecondaryBuffer.AcquireResources(Int32,Int32) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.AcquireResources Method

Allocates resources for a SecondaryBuffer object that was created with the DeferLocation flag set in the BufferDescription.

Definition

Visual Basic Public Function AcquireResources( _
ByVal flags As Integer, _
ByVal effectsCount As Integer _
) As EffectsReturnValue()
C# public EffectsReturnValue[] AcquireResources(
int flags,
int effectsCount
);
C++ public:
array<EffectsReturnValue>^ AcquireResources(
int flags,
int effectsCount
);
JScript public function AcquireResources(
flags : int,
effectsCount : int
) : EffectsReturnValue[];

Parameters

flags System.Int32
Specifies how resources are to be allocated for the SecondaryBuffer object. For a list of values, see the voice management and voice allocation flags in the BufferPlayFlags enumeration.
effectsCount System.Int32
Number of Microsoft DirectSound effect objects in the SecondaryBuffer set by the SetEffects method.

Return Value

Microsoft.DirectX.DirectSound.EffectsReturnValue[]
An array that contains one element for each of the DirectSound effect objects that was assigned to the SecondaryBuffer object by the SetEffects method. One of the following values is returned for each DirectSound effect object.

Remarks

In order to use the BufferPlayFlags enumeration in the flags parameter, you must cast it to an integer, as done in the following code.

[C#]
int flags = (int)(BufferPlayFlags.LocateInSoftware | BufferPlayFlags.TerminateByTime);
EffectsReturnValue[] returnval = buffer.AcquireResources(flags,1);

If the DeferLocation flag is not set in the BufferDescription of the SecondaryBuffer object, an InvalidCallException is thrown.

If one of the BufferPlayFlags is set in the flags parameter and is not supported, a ControlUnavailableException is thrown.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | A parameter is null.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Clone(Device) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.Clone Method

Duplicates the SecondaryBuffer object.

Definition

Visual Basic Public Shadows Function Clone( _
ByVal parent As Device _
) As SecondaryBuffer
C# public new SecondaryBuffer Clone(
Device parent
);
C++ public:
SecondaryBuffer^ Clone(
Device^ parent
);
JScript public hide function Clone(
parent : Device
) : SecondaryBuffer;

Parameters

parent Microsoft.DirectX.DirectSound.Device
The Device object associated with the SecondaryBuffer object.

Return Value

Microsoft.DirectX.DirectSound.SecondaryBuffer
A SecondaryBuffer object that represents the cloned SecondaryBuffer object.

Remarks

This method is not valid for buffers created with BufferCaps.ControlEffects set to true.

Initially, the duplicate buffer will have the same parameters as the original buffer. However, the application can change the parameters of each buffer independently, and each can be played or stopped without affecting the other.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the method.
ArgumentNullException Leave Site | The parent parameter is null.
InvalidCallException | The method call is invalid for the current state of this object.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Dispose() Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.Dispose Method

Immediately releases the unmanaged resources used by the SecondaryBuffer object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~SecondaryBuffer();
JScript | public override function Dispose();

See Also

  • SecondaryBuffer.Disposed
  • SecondaryBuffer.Disposing

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Equals(Object) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Finalize() Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.Finalize Method

Allows the SecondaryBuffer object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~SecondaryBuffer();
C++ | !SecondaryBuffer();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetEffects Method ()

How Do I...?
  • Use Effect Parameters

Retrieves a Microsoft DirectSound effect object or objects from a SecondaryBuffer object.

Overload List

public object GetEffects(int);
public object[] GetEffects(int, int);

Remarks

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • SecondaryBuffer.SetEffects
  • GetObjectInPath

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetEffects(Int32,Int32) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.GetEffects Method

How Do I...?
  • Use Effect Parameters

Retrieves a range of Microsoft DirectSound effect objects from a SecondaryBuffer object.

Definition

Visual Basic Public Function GetEffects( _
ByVal startIndex As Integer, _
ByVal count As Integer _
) As Object()
C# public object[] GetEffects(
int startIndex,
int count
);
C++ public:
array<Object^>^ GetEffects(
int startIndex,
int count
);
JScript public function GetEffects(
startIndex : int,
count : int
) : Object[];

Parameters

startIndex System.Int32
Starting index of the range of DirectSound effect objects to retrieve from the SecondaryBuffer object.
count System.Int32
The number of DirectSound effect objects to retrieve from the SecondaryBuffer object.

Return Value

System.Object[]
An array of DirectSound effect objects, such as EchoEffect, from the SecondaryBuffer object.

Remarks

To retrieve an effect object out of the returned array, first retrieve it as an object, than cast it into the appropriate effect object type as seen in the example below.

[C#]
object[] effects_objects = buffer.GetEffects(0,1);
WavesReverbEffect wre = (WavesReverbEffect)effects_objects[0];

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • SecondaryBuffer.SetEffects
  • GetObjectInPath

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetEffects(Int32) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.GetEffects Method

How Do I...?
  • Use Effect Parameters

Retrieves a Microsoft DirectSound effect object at a particular index from a SecondaryBuffer object.

Definition

Visual Basic Public Function GetEffects( _
ByVal index As Integer _
) As Object
C# public object GetEffects(
int index
);
C++ public:
Object^ GetEffects(
int index
);
JScript public function GetEffects(
index : int
) : Object;

Parameters

index System.Int32
Index of DirectSound effect object to retrieve from the SecondaryBuffer object.

Return Value

System.Object
A DirectSound effect object, such as EchoEffect, from the SecondaryBuffer object.

Remarks

When retrieving an effect object, you must cast it into the appropriate effect object type as seen in the example below.

[C#]
WavesReverbEffect wre = (WavesReverbEffect)buffer.GetEffects(0);

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all DirectSound exceptions. Derives from DirectXException.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • SecondaryBuffer.SetEffects
  • GetObjectInPath

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetHashCode() Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Shadows Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public new IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public hide function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundBuffer8, which allows unmanaged COM clients to create an instance of the managed SecondaryBuffer class. Not supported.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.GetObjectInPath(Guid,Int32,Guid) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.GetObjectInPath Method

Retrieves a Microsoft DirectSound effect object at a particular index from a SecondaryBuffer object.

Definition

Visual Basic Public Function GetObjectInPath( _
ByVal guidObject As Guid, _
ByVal index As Integer, _
ByVal guidInterface As Guid _
) As Object
C# public object GetObjectInPath(
Guid guidObject,
int index,
Guid guidInterface
);
C++ public:
Object^ GetObjectInPath(
Guid guidObject,
int index,
Guid guidInterface
);
JScript public function GetObjectInPath(
guidObject : Guid,
index : int,
guidInterface : Guid
) : Object;

Parameters

guidObject System.Guid
Unique class identifier of the object being searched for, such as DSoundHelper.StandardEchoGuid.
index System.Int32
Index of DirectSound effect object to retrieve from the SecondaryBuffer object.
guidInterface System.Guid
Unique identifier of the desired interface, such as DSoundHelper.InterfaceEffectsEcho

Return Value

System.Object
A DirectSound effect object, such as EchoEffect, from the SecondaryBuffer object you are searching.

Remarks

Any DMO that has been set on a buffer by using SetEffects method can be retrieved, even if it has not been allocated resources.

The following interfaces can be retrieved for the various DMOs supplied with Microsoft DirectX.

Effect guidObject guidInterface
ChorusEffect DSoundHelper.StandardChorusGuid DSoundHelper.InterfaceEffectsChorus
CompressorEffect DSoundHelper.StandardCompressorGuid DSoundHelper.InterfaceEffectsCompressor
DistortionEffect DSoundHelper.StandardDistortionGuid DSoundHelper.InterfaceEffectsDistortion
EchoEffect DSoundHelper.StandardEchoGuid DSoundHelper.InterfaceEffectsEcho
FlangerEffect DSoundHelper.StandardFlangerGuid DSoundHelper.InterfaceEffectsFlanger
GargleEffect DSoundHelper.StandardGargleGuid DSoundHelper.InterfaceEffectsGargle
Interactive3DLevel2ReverbEffect DSoundHelper.StandardInteractive3DLevel2ReverbGuid DSoundHelper.InterfaceEffectsInteractive3DLevel2Reverb
ParamEqEffect DSoundHelper.StandardParamEqGuid DSoundHelper.InterfaceEffectsParamEq
WavesReverbEffect DSoundHelper.StandardWavesReverbGuid DSoundHelper.InterfaceEffectsWavesReverb

The value of the index is the index of the object within the array of effects passed to SetEffects. This is not necessarily the actual position of the object in the effects chain, because some effects might not have been created.

An object is returned solely on the basis of whether it matches guidObject and index. It is up to the application to ensure that guidInterface specifies an interface that can be expected to be found on the object.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
ObjectNotFoundException | The requested object was not found.
SoundException | Root exception type for all DirectSound Exceptions. Derives from DirectXException.

See Also

  • DSoundHelper
  • ChorusEffect
  • CompressorEffect
  • DistortionEffect
  • EchoEffect
  • FlangerEffect
  • GargleEffect
  • Interactive3DLevel2ReverbEffect
  • ParamEqEffect
  • WavesReverbEffect

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.op_Equality(SecondaryBuffer,SecondaryBuffer) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As SecondaryBuffer, _
ByVal right As SecondaryBuffer _
) As Boolean
C# public static bool op_Equality(
SecondaryBuffer left,
SecondaryBuffer right
);
C++ public:
static bool operator==(
SecondaryBuffer^ left,
SecondaryBuffer^ right
);
JScript public static function op_Equality(
left : SecondaryBuffer,
right : SecondaryBuffer
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.op_Inequality(SecondaryBuffer,SecondaryBuffer) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As SecondaryBuffer, _
ByVal right As SecondaryBuffer _
) As Boolean
C# public static bool op_Inequality(
SecondaryBuffer left,
SecondaryBuffer right
);
C++ public:
static bool operator!=(
SecondaryBuffer^ left,
SecondaryBuffer^ right
);
JScript public static function op_Inequality(
left : SecondaryBuffer,
right : SecondaryBuffer
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.raise_Disposing Method

Raises the SecondaryBuffer.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer Constructor ()

Initializes a new instance of the SecondaryBuffer class.

Overload List

public SecondaryBuffer(BufferDescription, Device);
public SecondaryBuffer(Stream, BufferDescription, Device);
public SecondaryBuffer(Stream, Device);
public SecondaryBuffer(Stream, int, BufferDescription, Device);
public SecondaryBuffer(Stream, int, Device);
public SecondaryBuffer(string, BufferDescription, Device);
public SecondaryBuffer(string, Device);

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(Stream,Int32,Device) Constructor (Microsoft.DirectX.DirectSound)

SecondaryBuffer.SecondaryBuffer Constructor

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
Stream source,
int length,
Device parent
);
C++ public:
SecondaryBuffer(
Stream^ source,
int length,
Device^ parent
);
JScript public function SecondaryBuffer(
source : Stream,
length : int,
parent : Device
);

Parameters

source System.IO.Stream
A Stream Leave Site object that contains the source data for the buffer.
length System.Int32
An integer that represents the size of the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(Stream,Device) Constructor (Microsoft.DirectX.DirectSound)

SecondaryBuffer.SecondaryBuffer Constructor

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
Stream source,
Device parent
);
C++ public:
SecondaryBuffer(
Stream^ source,
Device^ parent
);
JScript public function SecondaryBuffer(
source : Stream,
parent : Device
);

Parameters

source System.IO.Stream
A Stream Leave Site object that contains the source data for the buffer.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(String,Device) Constructor (Microsoft.DirectX.DirectSound)

SecondaryBuffer.SecondaryBuffer Constructor

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal fileName As String, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
string fileName,
Device parent
);
C++ public:
SecondaryBuffer(
String^ fileName,
Device^ parent
);
JScript public function SecondaryBuffer(
fileName : String,
parent : Device
);

Parameters

fileName System.String
A String Leave Site that represents the file name of the file that contains source data for the buffer.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(Stream,Int32,BufferDescription,Device) Constructor (Microsoft.DirectX.DirectSound)

SecondaryBuffer.SecondaryBuffer Constructor

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal length As Integer, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
Stream source,
int length,
BufferDescription desc,
Device parent
);
C++ public:
SecondaryBuffer(
Stream^ source,
int length,
BufferDescription^ desc,
Device^ parent
);
JScript public function SecondaryBuffer(
source : Stream,
length : int,
desc : BufferDescription,
parent : Device
);

Parameters

source System.IO.Stream
A Stream Leave Site object that contains the source data for the buffer.
length System.Int32
An integer that represents the size of the buffer to create.
desc Microsoft.DirectX.DirectSound.BufferDescription
A BufferDescription object that describes the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(Stream,BufferDescription,Device) Constructor (Microsoft.DirectX.DirectSound)

SecondaryBuffer.SecondaryBuffer Constructor

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal source As Stream, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
Stream source,
BufferDescription desc,
Device parent
);
C++ public:
SecondaryBuffer(
Stream^ source,
BufferDescription^ desc,
Device^ parent
);
JScript public function SecondaryBuffer(
source : Stream,
desc : BufferDescription,
parent : Device
);

Parameters

source System.IO.Stream
A Stream Leave Site object that contains the source data for the buffer.
desc Microsoft.DirectX.DirectSound.BufferDescription
A BufferDescription object that describes the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(String,BufferDescription,Device) Constructor (Microsoft.DirectX.DirectSound)

SecondaryBuffer.SecondaryBuffer Constructor

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal fileName As String, _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
string fileName,
BufferDescription desc,
Device parent
);
C++ public:
SecondaryBuffer(
String^ fileName,
BufferDescription^ desc,
Device^ parent
);
JScript public function SecondaryBuffer(
fileName : String,
desc : BufferDescription,
parent : Device
);

Parameters

fileName System.String
A String Leave Site that represents the file name of the file that contains source data for the buffer.
desc Microsoft.DirectX.DirectSound.BufferDescription
A BufferDescription object that describes the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SecondaryBuffer(BufferDescription,Device) Constructor (Microsoft.DirectX.DirectSound)

SecondaryBuffer.SecondaryBuffer Constructor

Initializes a new instance of the SecondaryBuffer class.

Definition

Visual Basic Public Sub New( _
ByVal desc As BufferDescription, _
ByVal parent As Device _
)
C# public SecondaryBuffer(
BufferDescription desc,
Device parent
);
C++ public:
SecondaryBuffer(
BufferDescription^ desc,
Device^ parent
);
JScript public function SecondaryBuffer(
desc : BufferDescription,
parent : Device
);

Parameters

desc Microsoft.DirectX.DirectSound.BufferDescription
A BufferDescription object that describes the buffer to create.
parent Microsoft.DirectX.DirectSound.Device
A Device object that represents the parent device to use with the buffer.

Remarks

Note: If the method succeeds, to determine whether a requested 3-D algorithm was available or not, and stereo panning was substituted, check the Buffer.NotVirtualized property.

Microsoft DirectSound does not initialize the contents of the buffer, and the application cannot assume that it contains silence.

If an attempt is made to create a buffer with LocateInHardware set to true in the BufferDescription on a system where hardware acceleration is not available, the method fails throwing either ControlUnavailableException or InvalidCallException, depending on the operating system.

If an attempt is made to create a buffer with Control3D set to true in the BufferDescription and you attempt to load the buffer with a stero sound, the method fails throwing a ArgumentException Leave Site.

Exceptions
AllocatedException | The request failed because resources, such as a priority level, were already in use by another caller.
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ArgumentNullException Leave Site | One or more of the parameters is null.
BadFormatException | The specified wave format is not supported.
BufferTooSmallException | The buffer size is not large enough to enable effects processing.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
NoAggregationException | The object does not support aggregation.
OutOfMemoryException Leave Site | DirectSound could not allocate sufficient memory to complete the call.
UnsupportedException | The function called is not supported at this time.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.SetEffects(EffectDescription[]) Method (Microsoft.DirectX.DirectSound)

SecondaryBuffer.SetEffects Method

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Enables effects on a SecondaryBuffer object.

Definition

Visual Basic Public Function SetEffects( _
ByVal dsEff() As EffectDescription _
) As EffectsReturnValue()
C# public EffectsReturnValue[] SetEffects(
EffectDescription[] dsEff
);
C++ public:
array<EffectsReturnValue>^ SetEffects(
array<EffectDescription>^ dsEff
);
JScript public function SetEffects(
dsEff : EffectDescription[]
) : EffectsReturnValue[];

Parameters

dsEff Microsoft.DirectX.DirectSound.EffectDescription[]
An Array of EffectDescription structures that contains descriptions of the effects to set in the SecondaryBuffer object.

Return Value

Microsoft.DirectX.DirectSound.EffectsReturnValue[]
An array that contains one element for each of the Microsoft DirectSound effect objects that was assigned to the SecondaryBuffer object. One of the following values is returned for each DirectSound effect object.

Remarks

If the method fails, the return value for each effect in EffectsReturnValue is either Present or Unknown. Check these values to determine which effects caused the failure.

For the method to succeed, the buffer must have been created with the BufferDescription.ControlEffects set to true and must not be playing or locked.

If the method throws a SoundException, check the result code array for Present or Unknown to ascertain which effect caused the error. If the method throws an ArgumentException Leave Site, check the result codes for Failed to see which effects failed to acquire resources.

An effect must be set on a buffer before the effect interface can be obtained. To obtain the effect interface, use SecondaryBuffer.GetEffects or SecondaryBuffer.GetObjectInPath.

Exceptions
ArgumentException Leave Site | An invalid parameter was passed to the called method.
ControlUnavailableException | The buffer control (volume, pan, and so on) requested by the caller is not available. Controls must be specified when the buffer is created.
InvalidCallException | The method call is invalid for the current state of this object.
PriorityLevelNeededException | A cooperative level of Priority or higher is required.
SoundException | Root exception type for all DirectSound Exceptions. Derives from DirectXException.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • SecondaryBuffer.GetEffects

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Disposed Property (Microsoft.DirectX.DirectSound)

SecondaryBuffer.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public Shadows ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SecondaryBuffer.Disposing Event (Microsoft.DirectX.DirectSound)

SecondaryBuffer.Disposing Event

Occurs when the Dispose method is called or when the SecondaryBuffer object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the SecondaryBuffer.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the SecondaryBuffer object indicates whether that object has been disposed.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


SendLoopException Class (Microsoft.DirectX.DirectSound)

SendLoopException Class

A circular loop of send effects was detected.

Definition

Visual Basic Public Class SendLoopException
Inherits SoundException
C# | public class SendLoopException : SoundException
C++ | public ref class SendLoopException : SoundException
JScript | public class SendLoopException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SendLoopException | Initializes a new instance of the SendLoopException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
SendLoopException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SendLoopException.SendLoopException Constructor ()

Initializes a new instance of the SendLoopException class.

Overload List

public SendLoopException();
protected SendLoopException(SerializationInfo, StreamingContext);
public SendLoopException(string);
public SendLoopException(string, Exception);


SendLoopException.SendLoopException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

SendLoopException.SendLoopException Constructor

Initializes a new instance of the SendLoopException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SendLoopException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SendLoopException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SendLoopException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


SendLoopException.SendLoopException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

SendLoopException.SendLoopException Constructor

Initializes a new instance of the SendLoopException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SendLoopException(
string message,
Exception inner
);
C++ public:
SendLoopException(
String^ message,
Exception^ inner
);
JScript public function SendLoopException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


SendLoopException.SendLoopException(String) Constructor (Microsoft.DirectX.DirectSound)

SendLoopException.SendLoopException Constructor

Initializes a new instance of the SendLoopException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SendLoopException(
string message
);
C++ public:
SendLoopException(
String^ message
);
JScript public function SendLoopException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


SendLoopException.SendLoopException() Constructor (Microsoft.DirectX.DirectSound)

SendLoopException.SendLoopException Constructor

Initializes a new instance of the SendLoopException class.

Definition

Visual Basic | Public Sub New()
C# | public SendLoopException();
C++ public:
SendLoopException();
JScript | public function SendLoopException();


SoundException Class (Microsoft.DirectX.DirectSound)

SoundException Class

Root exception type for all Microsoft DirectSound exceptions. Derives from DirectXException.

Definition

Visual Basic Public Class SoundException
Inherits DirectXException
C# | public class SoundException : DirectXException
C++ | public ref class SoundException : DirectXException
JScript | public class SoundException extends DirectXException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
SoundException | Initializes a new instance of the SoundException class.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
AccessDeniedException
AllocatedException
BadFormatException
BadSendBufferGuidException
BufferLostException
BufferTooSmallException
ControlUnavailableException
EffectsUnavailableException
InvalidCallException
NoAggregationException
NoDriverException
ObjectNotFoundException
OtherApplicationHasPriorityException
PriorityLevelNeededException
SendLoopException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SoundException.GetExceptionFromResultInternal(Int32) Method (Microsoft.DirectX.DirectSound)

SoundException.GetExceptionFromResultInternal Method

Retrieves an Exception Leave Site object that represents the result code passed in.

Definition

Visual Basic Public Shadows Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public new static Exception GetExceptionFromResultInternal(
int resultCode
);
C++ public:
static Exception^ GetExceptionFromResultInternal(
int resultCode
);
JScript public hide static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32
Integer that represents the result code of the exception.

Return Value

System.Exception
An Exception Leave Site object that represents the error that occurred.

Applies To

AccessDeniedException, AllocatedException, BadFormatException, BadSendBufferGuidException, BufferLostException, BufferTooSmallException, ControlUnavailableException, EffectsUnavailableException, InvalidCallException, NoAggregationException, NoDriverException, ObjectNotFoundException, OtherApplicationHasPriorityException, PriorityLevelNeededException, SendLoopException, UnsupportedException


SoundException.SoundException Constructor ()

Initializes a new instance of the SoundException class.

Overload List

public SoundException();
protected SoundException(SerializationInfo, StreamingContext);
public SoundException(string);
public SoundException(string, Exception);


SoundException.SoundException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

SoundException.SoundException Constructor

Initializes a new instance of the SoundException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected SoundException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
SoundException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function SoundException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


SoundException.SoundException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

SoundException.SoundException Constructor

Initializes a new instance of the SoundException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public SoundException(
string message,
Exception inner
);
C++ public:
SoundException(
String^ message,
Exception^ inner
);
JScript public function SoundException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


SoundException.SoundException(String) Constructor (Microsoft.DirectX.DirectSound)

SoundException.SoundException Constructor

Initializes a new instance of the SoundException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public SoundException(
string message
);
C++ public:
SoundException(
String^ message
);
JScript public function SoundException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


SoundException.SoundException() Constructor (Microsoft.DirectX.DirectSound)

SoundException.SoundException Constructor

Initializes a new instance of the SoundException class.

Definition

Visual Basic | Public Sub New()
C# | public SoundException();
C++ public:
SoundException();
JScript | public function SoundException();


UnsupportedException Class (Microsoft.DirectX.DirectSound)

UnsupportedException Class

The function called is not supported at this time.

Definition

Visual Basic Public Class UnsupportedException
Inherits SoundException
C# | public class UnsupportedException : SoundException
C++ | public ref class UnsupportedException : SoundException
JScript | public class UnsupportedException extends SoundException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled. Inherited from DirectXException.

Methods

Method | Description
static (Shared in Visual Basic) EnableExceptions | Enables Microsoft DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code. Inherited from DirectXException.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves an Exception Leave Site object that represents the result code passed in. Inherited from SoundException.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing. Inherited from DirectXException.
ToString | Obtains the string representation of the current instance. Inherited from DirectXException.
UnsupportedException | Initializes a new instance of the UnsupportedException class.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code. Inherited from DirectXException.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code. Inherited from DirectXException.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed. Inherited from DirectXException.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
SoundException
UnsupportedException

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsupportedException.UnsupportedException Constructor ()

Initializes a new instance of the UnsupportedException class.

Overload List

public UnsupportedException();
protected UnsupportedException(SerializationInfo, StreamingContext);
public UnsupportedException(string);
public UnsupportedException(string, Exception);


UnsupportedException.UnsupportedException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX.DirectSound)

UnsupportedException.UnsupportedException Constructor

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected UnsupportedException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
UnsupportedException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function UnsupportedException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that holds all of the data needed to serialize or deserialize the object.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that describes the source and destination serialized stream.


UnsupportedException.UnsupportedException(String,Exception) Constructor (Microsoft.DirectX.DirectSound)

UnsupportedException.UnsupportedException Constructor

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public UnsupportedException(
string message,
Exception inner
);
C++ public:
UnsupportedException(
String^ message,
Exception^ inner
);
JScript public function UnsupportedException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error message to display.
inner System.Exception
An Exception Leave Site object that represents errors that occur during application execution.


UnsupportedException.UnsupportedException(String) Constructor (Microsoft.DirectX.DirectSound)

UnsupportedException.UnsupportedException Constructor

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public UnsupportedException(
string message
);
C++ public:
UnsupportedException(
String^ message
);
JScript public function UnsupportedException(
message : String
);

Parameters

message System.String
String that contains the error message to display.


UnsupportedException.UnsupportedException() Constructor (Microsoft.DirectX.DirectSound)

UnsupportedException.UnsupportedException Constructor

Initializes a new instance of the UnsupportedException class.

Definition

Visual Basic | Public Sub New()
C# | public UnsupportedException();
C++ public:
UnsupportedException();
JScript | public function UnsupportedException();


WavesReverbEffect Class (Microsoft.DirectX.DirectSound)

WavesReverbEffect Class

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Represents a Microsoft DirectSound effects object used to set and retrieve effect parameters on a SecondaryBuffer object that supports Waves reverberation.

Definition

Visual Basic Public Class WavesReverbEffect
Inherits MarshalByRefObject
Implements IDisposable
C# | public class WavesReverbEffect : MarshalByRefObject, IDisposable
C++ | public ref class WavesReverbEffect : MarshalByRefObject, IDisposable
JScript | public class WavesReverbEffect extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the WavesReverbEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Fields

Field | Description
static (Shared in Visual Basic) HighFrequencyRtRatioDefault | Retrieves the default value for the EffectsWavesReverb.HighFrequencyRtRatio property.
static (Shared in Visual Basic) HighFrequencyRtRatioMax | Retrieves the maximum value for the EffectsWavesReverb.HighFrequencyRtRatio property.
static (Shared in Visual Basic) HighFrequencyRtRatioMin | Retrieves the minimum value for the EffectsWavesReverb.HighFrequencyRtRatio property.
static (Shared in Visual Basic) InGainDefault | Retrieves the default value for the EffectsWavesReverb.InGain property.
static (Shared in Visual Basic) InGainMax | Retrieves the maximum value for the EffectsWavesReverb.InGain property.
static (Shared in Visual Basic) InGainMin | Retrieves the minimum value for the EffectsWavesReverb.InGain property.
static (Shared in Visual Basic) ReverbMixDefault | Retrieves the default value for the EffectsWavesReverb.ReverbMix property.
static (Shared in Visual Basic) ReverbMixMax | Retrieves the maximum value for the EffectsWavesReverb.ReverbMix property.
static (Shared in Visual Basic) ReverbMixMin | Retrieves the minimum value for the EffectsWavesReverb.ReverbMix property.
static (Shared in Visual Basic) ReverbTimeDefault | Retrieves the default value for the EffectsWavesReverb.ReverbTime property.
static (Shared in Visual Basic) ReverbTimeMax | Retrieves the maximum value for the EffectsWavesReverb.ReverbTime property.
static (Shared in Visual Basic) ReverbTimeMin | Retrieves the minimum value for the EffectsWavesReverb.ReverbTime property.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by the WavesReverbEffect object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Allows the WavesReverbEffect object to free resources before it is destroyed by the garbage collector.
GetHashCode | Returns the hash code for the current instance.
GetObjectByValue | This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
raise_Disposing | Raises the WavesReverbEffect.Disposing event when called from within a derived class.
WavesReverbEffect | Initializes a new instance of the WavesReverbEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Properties

Property | Description
AllParameters | Retrieves or sets Waves reverb parameters of a SecondaryBuffer object.
Disposed | Gets a value that indicates whether the object is disposed.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
WavesReverbEffect

Remarks

Obtain this object by calling on the GetEffects or GetObjectInPath method of a SecondaryBuffer object that is using the effect.

The Waves reverberation DMO is based on the Waves MaxxVerb technology, which is licensed to Microsoft.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Class Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers


WavesReverbEffect.Dispose() Method (Microsoft.DirectX.DirectSound)

WavesReverbEffect.Dispose Method

Immediately releases the unmanaged resources used by the WavesReverbEffect object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~WavesReverbEffect();
JScript | public override function Dispose();

See Also

  • WavesReverbEffect.Disposed
  • WavesReverbEffect.Disposing


WavesReverbEffect.Equals(Object) Method (Microsoft.DirectX.DirectSound)

WavesReverbEffect.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object to compare to this object.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


WavesReverbEffect.Finalize() Method (Microsoft.DirectX.DirectSound)

WavesReverbEffect.Finalize Method

Allows the WavesReverbEffect object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~WavesReverbEffect();
C++ | !WavesReverbEffect();
JScript | protected override function Finalize();

Remarks

Called during garbage collection.


WavesReverbEffect.GetHashCode() Method (Microsoft.DirectX.DirectSound)

WavesReverbEffect.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


WavesReverbEffect.GetObjectByValue(Int32) Method (Microsoft.DirectX.DirectSound)

WavesReverbEffect.GetObjectByValue Method

This member supports the infrastructure for Microsoft DirectX 9.0 for Managed Code and is not intended to be used directly from your code.

Definition

Visual Basic Public Function GetObjectByValue( _
ByVal objId As Integer _
) As IntPtr
C# public IntPtr GetObjectByValue(
int objId
);
C++ public:
IntPtr GetObjectByValue(
int objId
);
JScript public function GetObjectByValue(
objId : int
) : IntPtr;

Parameters

objId System.Int32
Object identifier.

Return Value

System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXWavesReverb8, which allows unmanaged COM clients to create an instance of the managed WavesReverbEffect class. Not supported.


WavesReverbEffect.op_Equality(WavesReverbEffect,WavesReverbEffect) Method (Microsoft.DirectX.DirectSound)

WavesReverbEffect.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As WavesReverbEffect, _
ByVal right As WavesReverbEffect _
) As Boolean
C# public static bool op_Equality(
WavesReverbEffect left,
WavesReverbEffect right
);
C++ public:
static bool operator==(
WavesReverbEffect^ left,
WavesReverbEffect^ right
);
JScript public static function op_Equality(
left : WavesReverbEffect,
right : WavesReverbEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.WavesReverbEffect
The WavesReverbEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.WavesReverbEffect
The WavesReverbEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are the same; otherwise, false.


WavesReverbEffect.op_Inequality(WavesReverbEffect,WavesReverbEffect) Method (Microsoft.DirectX.DirectSound)

WavesReverbEffect.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As WavesReverbEffect, _
ByVal right As WavesReverbEffect _
) As Boolean
C# public static bool op_Inequality(
WavesReverbEffect left,
WavesReverbEffect right
);
C++ public:
static bool operator!=(
WavesReverbEffect^ left,
WavesReverbEffect^ right
);
JScript public static function op_Inequality(
left : WavesReverbEffect,
right : WavesReverbEffect
) : boolean;

Parameters

left Microsoft.DirectX.DirectSound.WavesReverbEffect
The WavesReverbEffect object to the left of the equality operator.
right Microsoft.DirectX.DirectSound.WavesReverbEffect
The WavesReverbEffect object to the right of the equality operator.

Return Value

System.Boolean
Returns true if the objects are different; otherwise, false.


WavesReverbEffect.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX.DirectSound)

WavesReverbEffect.raise_Disposing Method

Raises the WavesReverbEffect.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference; should be this object.
i2 System.EventArgs
Arguments to pass to the event handler.


WavesReverbEffect.WavesReverbEffect(IntPtr,SecondaryBuffer) Constructor (Microsoft.DirectX.DirectSound)

WavesReverbEffect.WavesReverbEffect Constructor

Initializes a new instance of the WavesReverbEffect class. This method supports the .NET Framework Infrastructure and is not intended to be used directly in your code.

Definition

Visual Basic Public Sub New( _
ByVal lp As IntPtr, _
ByVal source As SecondaryBuffer _
)
C# public WavesReverbEffect(
IntPtr lp,
SecondaryBuffer source
);
C++ public:
WavesReverbEffect(
IntPtr lp,
SecondaryBuffer^ source
);
JScript public function WavesReverbEffect(
lp : IntPtr,
source : SecondaryBuffer
);

Parameters

lp System.IntPtr
Pointer to the unmanaged Component Object Model (COM) interface, IDirectSoundFXWavesReverb8, which allows unmanaged COM clients to create an instance of the managed WavesReverbEffect. Not supported.
source Microsoft.DirectX.DirectSound.SecondaryBuffer
The SecondaryBuffer that is using this effect.

Remarks

Obtain the WavesReverbEffect object by calling on the GetEffects or GetObjectInPath method of the SecondaryBuffer object that is using the effect.

See Also

  • Add Effects to a SecondaryBuffer Object
  • Use Effect Parameters


WavesReverbEffect.AllParameters Property (Microsoft.DirectX.DirectSound)

WavesReverbEffect.AllParameters Property

How Do I...?
  • Use Effect Parameters

Retrieves or sets Waves reverb parameters of a SecondaryBuffer object.

Definition

Visual Basic | Public Property AllParameters As EffectsWavesReverb
C# | public EffectsWavesReverb AllParameters { get; set; }
C++ public:
property EffectsWavesReverb AllParameters {
EffectsWavesReverb get();
void set(EffectsWavesReverb value);
}
JScript public function get AllParameters() : EffectsWavesReverb
public function set AllParameters(EffectsWavesReverb);

Property Value

Microsoft.DirectX.DirectSound.EffectsWavesReverb
Contains parameters for a Waves reverb effect.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site An invalid parameter was passed to the called method.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

See Also

  • Setting Effects on Buffers
  • Effect Parameters


WavesReverbEffect.Disposed Property (Microsoft.DirectX.DirectSound)

WavesReverbEffect.Disposed Property

Gets a value that indicates whether the object is disposed.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Returns true if the object is disposed; otherwise, false.

This property is read-only.


WavesReverbEffect.HighFrequencyRtRatioDefault Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.HighFrequencyRtRatioDefault Field

Retrieves the default value for the EffectsWavesReverb.HighFrequencyRtRatio property.

Definition

Visual Basic | Public Shared HighFrequencyRtRatioDefault As Single
C# | public static Single HighFrequencyRtRatioDefault;
C++ | public: static Single HighFrequencyRtRatioDefault;
JScript | public static var HighFrequencyRtRatioDefault : Single

Field Value

System.Single
Default value for the EffectsWavesReverb.HighFrequencyRtRatio property.

This field is read-only.

See Also

  • EffectsWavesReverb.HighFrequencyRtRatio


WavesReverbEffect.HighFrequencyRtRatioMax Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.HighFrequencyRtRatioMax Field

Retrieves the maximum value for the EffectsWavesReverb.HighFrequencyRtRatio property.

Definition

Visual Basic | Public Shared HighFrequencyRtRatioMax As Single
C# | public static Single HighFrequencyRtRatioMax;
C++ | public: static Single HighFrequencyRtRatioMax;
JScript | public static var HighFrequencyRtRatioMax : Single

Field Value

System.Single
Maximum value for the EffectsWavesReverb.HighFrequencyRtRatio property.

This field is read-only.

See Also

  • EffectsWavesReverb.HighFrequencyRtRatio


WavesReverbEffect.HighFrequencyRtRatioMin Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.HighFrequencyRtRatioMin Field

Retrieves the minimum value for the EffectsWavesReverb.HighFrequencyRtRatio property.

Definition

Visual Basic | Public Shared HighFrequencyRtRatioMin As Single
C# | public static Single HighFrequencyRtRatioMin;
C++ | public: static Single HighFrequencyRtRatioMin;
JScript | public static var HighFrequencyRtRatioMin : Single

Field Value

System.Single
Minimum value for the EffectsWavesReverb.HighFrequencyRtRatio property.

This field is read-only.

See Also

  • EffectsWavesReverb.HighFrequencyRtRatio


WavesReverbEffect.InGainDefault Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.InGainDefault Field

Retrieves the default value for the EffectsWavesReverb.InGain property.

Definition

Visual Basic | Public Shared InGainDefault As Single
C# | public static Single InGainDefault;
C++ | public: static Single InGainDefault;
JScript | public static var InGainDefault : Single

Field Value

System.Single
Default value for the EffectsWavesReverb.InGain property.

This field is read-only.

See Also

  • EffectsWavesReverb.InGain


WavesReverbEffect.InGainMax Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.InGainMax Field

Retrieves the maximum value for the EffectsWavesReverb.InGain property.

Definition

Visual Basic | Public Shared InGainMax As Single
C# | public static Single InGainMax;
C++ | public: static Single InGainMax;
JScript | public static var InGainMax : Single

Field Value

System.Single
Maximum value for the EffectsWavesReverb.InGain property.

This field is read-only.

See Also

  • EffectsWavesReverb.InGain


WavesReverbEffect.InGainMin Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.InGainMin Field

Retrieves the minimum value for the EffectsWavesReverb.InGain property.

Definition

Visual Basic | Public Shared InGainMin As Single
C# | public static Single InGainMin;
C++ | public: static Single InGainMin;
JScript | public static var InGainMin : Single

Field Value

System.Single
Minimum value for the EffectsWavesReverb.InGain property.

This field is read-only.

See Also

  • EffectsWavesReverb.InGain


WavesReverbEffect.ReverbMixDefault Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.ReverbMixDefault Field

Retrieves the default value for the EffectsWavesReverb.ReverbMix property.

Definition

Visual Basic | Public Shared ReverbMixDefault As Single
C# | public static Single ReverbMixDefault;
C++ | public: static Single ReverbMixDefault;
JScript | public static var ReverbMixDefault : Single

Field Value

System.Single
Default value for the EffectsWavesReverb.ReverbMix property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbMix


WavesReverbEffect.ReverbMixMax Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.ReverbMixMax Field

Retrieves the maximum value for the EffectsWavesReverb.ReverbMix property.

Definition

Visual Basic | Public Shared ReverbMixMax As Single
C# | public static Single ReverbMixMax;
C++ | public: static Single ReverbMixMax;
JScript | public static var ReverbMixMax : Single

Field Value

System.Single
Maximum value for the EffectsWavesReverb.ReverbMix property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbMix


WavesReverbEffect.ReverbMixMin Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.ReverbMixMin Field

Retrieves the minimum value for the EffectsWavesReverb.ReverbMix property.

Definition

Visual Basic | Public Shared ReverbMixMin As Single
C# | public static Single ReverbMixMin;
C++ | public: static Single ReverbMixMin;
JScript | public static var ReverbMixMin : Single

Field Value

System.Single
Minimum value for the EffectsWavesReverb.ReverbMix property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbMix


WavesReverbEffect.ReverbTimeDefault Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.ReverbTimeDefault Field

Retrieves the default value for the EffectsWavesReverb.ReverbTime property.

Definition

Visual Basic | Public Shared ReverbTimeDefault As Single
C# | public static Single ReverbTimeDefault;
C++ | public: static Single ReverbTimeDefault;
JScript | public static var ReverbTimeDefault : Single

Field Value

System.Single
Default value for the EffectsWavesReverb.ReverbTime property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbTime


WavesReverbEffect.ReverbTimeMax Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.ReverbTimeMax Field

Retrieves the maximum value for the EffectsWavesReverb.ReverbTime property.

Definition

Visual Basic | Public Shared ReverbTimeMax As Single
C# | public static Single ReverbTimeMax;
C++ | public: static Single ReverbTimeMax;
JScript | public static var ReverbTimeMax : Single

Field Value

System.Single
Maximum value for the EffectsWavesReverb.ReverbTime property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbTime


WavesReverbEffect.ReverbTimeMin Field (Microsoft.DirectX.DirectSound)

WavesReverbEffect.ReverbTimeMin Field

Retrieves the minimum value for the EffectsWavesReverb.ReverbTime property.

Definition

Visual Basic | Public Shared ReverbTimeMin As Single
C# | public static Single ReverbTimeMin;
C++ | public: static Single ReverbTimeMin;
JScript | public static var ReverbTimeMin : Single

Field Value

System.Single
Minimum value for the EffectsWavesReverb.ReverbTime property.

This field is read-only.

See Also

  • EffectsWavesReverb.ReverbTime


WavesReverbEffect.Disposing Event (Microsoft.DirectX.DirectSound)

WavesReverbEffect.Disposing Event

Occurs when the Dispose method is called or when the WavesReverbEffect object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for the WavesReverbEffect.Disposing event, use the following code.

obj.Disposing += new System.EventHandler(this.OnDisposing);

The Disposed property of the WavesReverbEffect object indicates whether that object has been disposed.


BufferDescriptionFlags Enumeration (Microsoft.DirectX.DirectSound)

BufferDescriptionFlags Enumeration

Contains constants for specifying the capabilities of sound buffers.

Definition

Visual Basic | Public Enum BufferDescriptionFlags
C# | public enum BufferDescriptionFlags
C++ | public enum class BufferDescriptionFlags
JScript | public enum BufferDescriptionFlags

Members

Member | Value | Description
LocateInHardware | 4 | The buffer must use hardware mixing.
LocateInSoftware | 8 | The buffer must be in software memory and use software mixing.
StickyFocus | 16384 | The buffer has sticky focus. If the user switches to another application not using Microsoft DirectSound, the application's normal buffers are muted, but sticky focus buffers are still audible.
StaticBuffer | 2 | No error occurs if such memory is not available. This flag has no effect on cards using the Peripheral Component Interconnect (PCI) bus. Cannot be combined with ControlEffects.
PrimaryBuffer | 1 | The buffer is a primary buffer. Cannot be combined with ControlEffects.
Mute3DAtMaximumDistance | 131072 | The sound is reduced to silence at the maximum distance. Applies only to software buffers.
GlobalFocus | 32768 | The buffer is a global sound buffer. With this flag set, an application using DirectSound can continue to play its buffers if the user switches focus to another application, even if the new application uses DirectSound.
CanGetCurrentPosition | 65536 | The buffer can get an more accurate accurate play cursor.
ControlVolume | 128 | The buffer has volume control capability.
ControlPositionNotify | 256 | The buffer has position notification capability.
ControlPan | 64 | The buffer has pan control capability. Cannot be combined with Control3D.
ControlEffects | 512 | The buffer supports effects processing.
ControlFrequency | 32 | The buffer has frequency control capability.
Control3D | 16 | The buffer has 3-D control capability. Cannot be combined with ControlPan, and cannot be set for a buffer with a stereo format in WaveFormat.
DeferLocation | 262144 | The buffer can be assigned to a hardware or software resource at play time. This flag must be set for buffers that use voice management.

Remarks

This enumeration is used by the BufferDescription.Flags property to set the capabilities using flags.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • BufferDescription.Flags


BufferPlayFlags Enumeration (Microsoft.DirectX.DirectSound)

BufferPlayFlags Enumeration

Contains constants for specifying the play behavior of the buffer.

Definition

Visual Basic | Public Enum BufferPlayFlags
C# | public enum BufferPlayFlags
C++ | public enum class BufferPlayFlags
JScript | public enum BufferPlayFlags

Members

Member | Value | Description
TerminateByPriority | 32 | If the hardware has no available voices, a currently playing buffer will be stopped to make room for the new buffer. The buffer prematurely terminated will be the one with the lowest priority as set by the priority parameter Play method for the buffer.
TerminateByDistance | 16 | If the hardware has no available voices, a currently playing buffer will be stopped to make room for the new buffer. The buffer prematurely terminated will be selected from buffers that have the buffer's BufferDescription.Mute3DAtMaximumDistance property set to true and are beyond their maximum distance. If there are no such buffers, the method fails.
TerminateByTime | 8 | If the hardware has no available voices, a currently playing nonlooping buffer will be stopped to make room for the new buffer. The buffer prematurely terminated is the one with the least time left to play.
LocateInSoftware | 4 | Play this voice in a software buffer only. This flag cannot be combined with LocateInHardware or any voice management flag.
LocateInHardware | 2 | Play this voice in a hardware buffer only. If the hardware has no available voices and no voice management flags are set, the Play method fails. This flag cannot be combined with LocateInSoftware.
Looping | 1 | After the end of the audio buffer is reached, play restarts at the beginning of the buffer. Play continues until explicitly stopped. This flag must be set when playing a primary buffer.
Default | 0 | Play this voice with the default settings.

Remarks

This enumeration is used by the Play method of a buffer to specify the play behavior of the buffer.

This enumeration is also used by the SecondaryBuffer.AquireResources method to set the capabilities of a SecondaryBuffer object that was created with the DeferLocation flag set in the BufferDescription in order to use the use voice allocation and management.

When using this enumeration in the SecondaryBuffer.AquireResources method, you must cast it to an integer, as done in the following code.

[C#]
int flags = (int)(BufferPlayFlags.LocateInSoftware | BufferPlayFlags.TerminateByTime);
EffectsReturnValue[] returnval = buffer.AcquireResources(flags,1);

Voice allocation flags (LocateInSoftware, LocateInHardware)

The voice allocation flags are valid only for buffers created with the DeferLocation flag set in the BufferDescription. One of the following flags can be used to force the processing of the sound into hardware or software. If neither LocateInHardware nor LocateInSoftware is set, the sound is played in either software or hardware, depending on the availability of resources at the time the method is called.

Voice management flags (TerminateByPriority, TerminateByDistance, TerminateByTime)

The voice management flags are valid only for buffers created with the DeferLocation flag set in the BufferDescription, and are used for sounds that are to play in hardware. These flags enable hardware resources that are already in use to be yielded to the current sound. Only buffers created with the DeferLocation flag set in the BufferDescription are candidates for premature termination.

The following table shows the behavior of the method under various combinations of the voice allocation and voice management flags when no free hardware voices are available.
LocateInHardware | Neither LocateInHardware nor LocateInSoftware | LocateInSoftware
TerminateByDistance | If any sounds currently playing in hardware are beyond their maximum distance and have the BufferDescription.Mute3DAtMaximumDistance property set to true, one of them is terminated and the new sound plays in hardware. Otherwise, the call fails. | If any sounds currently playing in hardware are beyond their maximum distance and have the BufferDescription.Mute3DAtMaximumDistance property set to true, one of them is terminated and the new sound plays in hardware. Otherwise, the new sound plays in software. | New sound plays in software.
TerminateByPriority | If the new sound's priority is higher than or equal to that of any sound currently playing in hardware, one of the lowest-priority sounds is terminated and the new sound plays in hardware. Otherwise, the call fails. | If the new sound's priority is higher than or equal to that of any sound currently playing in hardware, one of the lowest-priority sounds is terminated and the new sound plays in hardware. Otherwise, the new sound plays in software. | New sound plays in software.
TerminateByTime | The sound with the least time left to play is terminated and the new sound plays on the released voice. | The sound with the least time left to play is terminated and the new sound plays on the released voice. | New sound plays in software.

If the buffer specified in the method is already playing, the call to the method succeeds and the buffer continues to play. However, the flags defined in the most recent call supersede flags defined in previous calls.

TerminateByTime and TerminateByDistance cannot be combined, but either may be combined with TerminateByPriority, in which case the TerminateByTime or TerminateByDistance flag is used to determine which buffer should be terminated in the event of a priority tie.

If the method is called with a voice allocation or voice management flag set on a buffer that was not created with the DeferLocation flag set in the BufferDescription, the call fails with ArgumentException Leave Site.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • SecondaryBuffer.AquireResources
  • Buffer.Play


BufferSize Enumeration (Microsoft.DirectX.DirectSound)

BufferSize Enumeration

Contains constants for the minimum and maximum buffer size.

Definition

Visual Basic | Public Enum BufferSize
C# | public enum BufferSize
C++ | public enum class BufferSize
JScript | public enum BufferSize

Members

Member | Value | Description
EffectsMin | 150 | Minimum length for a buffer using effects, in milliseconds.
Max | 268435455 | Maximum length for a buffer, in bytes.
Min | 4 | Minimum length for a buffer (Other than the primary buffer), in bytes.

Remarks

A primary buffer must have a length of 0.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


CaptureEffectsReturnValue Enumeration (Microsoft.DirectX.DirectSound)

CaptureEffectsReturnValue Enumeration

Contains constants for a CaptureBuffer object's effects status.

Definition

Visual Basic | Public Enum CaptureEffectsReturnValue
C# | public enum CaptureEffectsReturnValue
C++ | public enum class CaptureEffectsReturnValue
JScript | public enum CaptureEffectsReturnValue

Members

Member | Value | Description
LocatedInSoftware | 32 | Effect is instantiated in hardware.
LocatedInHardware | 16 | Effect is instantiated in software.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CaptureBuffer.GetEffectsStatus


CooperativeLevel Enumeration (Microsoft.DirectX.DirectSound)

CooperativeLevel Enumeration

Contains constants for a Device object's cooperative level.

Definition

Visual Basic | Public Enum CooperativeLevel
C# | public enum CooperativeLevel
C++ | public enum class CooperativeLevel
JScript | public enum CooperativeLevel

Members

Member | Value | Description
Normal | 1 | Sets the normal level. This level has the smoothest multitasking and resource-sharing behavior, but because it does not allow the primary buffer format to change, output is restricted to the default 8-bit format.
Priority | 2 | Sets the priority level. Applications with this cooperative level can have buffers that use the Format property and devices that call the Compact method.
WritePrimary | 4 | Sets the write-primary level. The application has write access to the primary buffer. No secondary buffers can be played. This level cannot be set if the DirectSound driver is being emulated for the device; that is, if the Device.Caps property returns the EmulateDriver flag in the Caps structure.

Remarks

The application must set the cooperative level by calling this method before its buffers can be played. The recommended cooperative level is Priority.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Device.SetCooperativeLevel


EffectsEnvironmentPreset Enumeration (Microsoft.DirectX.DirectSound)

EffectsEnvironmentPreset Enumeration

Containts constants for reverberation presets for an Interactive3DLevel2ReverbEffect object.

Definition

Visual Basic | Public Enum EffectsEnvironmentPreset
C# | public enum EffectsEnvironmentPreset
C++ | public enum class EffectsEnvironmentPreset
JScript | public enum EffectsEnvironmentPreset

Members

Member | Value | Description
Plate | 29 | Simulates a classic plate reverb.
LargeHall | 28 | Simulates the reverberation of a long hall.
MediumHall | 27 | Simulates the reverberation of being in a medium hall.
LargeRoom | 26 | Simulates the reverberation of being in a large room.
MediumRoom | 25 | Simulates the reverberation of being in a medium room.
SmallRoom | 24 | Simulates the reverberation of being in a small room.
UnderWater | 23 | Simulates the reverberation of being underwater.
SewerPipe | 22 | Simulates the reverberation of being in a sewer pipe.
ParkingLot | 21 | Simulates the reverberation of being in a parking lot.
Plain | 20 | Simulates the reverberation of being on a plain.
Quarry | 19 | Simulates the reverberation of being in a quarry.
Mountains | 18 | Simulates the reverberation of being in the mountains.
City | 17 | Simulates the reverberation of being in a city.
Forest | 16 | Simulates the reverberation of being in a forest.
Alley | 15 | Simulates the reverberation of being in an alley
StoneCorridor | 14 | Simulates the reverberation of being in a stone corridor.
Hallway | 13 | Simulates the reverberation of being in a normal hallway.
CarpetedHallway | 12 | Simulates the reverberation of being in a hallway with carpet.
Hangar | 11 | Simulates the reverberation of being in a hangar.
Arena | 10 | Simulates the reverberation of being in an arena.
Cave | 9 | Simulates the reverberation of being in a cave.
ConcertHall | 8 | Simulates the reverberation of being in a concert hall.
Auditorium | 7 | Simulates the reverberation of being in an auditorium.
StoneRoom | 6 | Simulates the reverberation of being in a room made of stone.
Livingroom | 5 | Simulates the reverberation of being in a living room.
Bathroom | 4 | Simulates the reverberation of being in a bathroom.
Room | 3 | Simulates the reverberation of being in a normal room.
PaddedCell | 2 | Simulates the reverberation of being in a padded room.
Generic | 1 | Preset uses generic settings.
Default | 0 | Preset uses default settings.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Interactive3DLevel2ReverbEffect.Preset


EffectsReturnValue Enumeration (Microsoft.DirectX.DirectSound)

EffectsReturnValue Enumeration

Contains constants that describe the status of an effect object returned from a SecondaryBuffer object.

Definition

Visual Basic | Public Enum EffectsReturnValue
C# | public enum EffectsReturnValue
C++ | public enum class EffectsReturnValue
JScript | public enum EffectsReturnValue

Members

Member | Value | Description
Failed | 4 | No effect was created because resources weren't available.
LocatedInHardware | 1 | Effect is instantiated in hardware.
LocatedInSoftware | 2 | Effect is instantiated in software.
Present | 0 | Effect is available but was not created because one of the other effects requested could not be created. If any of the effects requested cannot be created, none of them are, and the call fails.
SendLoop | 6 | A circular loop of send effects was detected.
Unallocated | 3 | Effect has not yet been assigned to hardware or software. This value is returned if the buffer was created with the BufferDescription.DeferLocation flag set to true.
Unknown | 5 | Effect is not registered on the system, and the method failed as a result.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • SecondaryBuffer.SetEffects
  • SecondaryBuffer.AcquireResources


EffectStatus Enumeration (Microsoft.DirectX.DirectSound)

EffectStatus Enumeration

Contains constants that describe the success of the effect in canceling the echo using a CaptureAcousticEchoCancellationEffect object.

Definition

Visual Basic | Public Enum EffectStatus
C# | public enum EffectStatus
C++ | public enum class EffectStatus
JScript | public enum EffectStatus

Members

Member | Value | Description
CurrentlyConverged | 8 | The Acoustic Echo Cancellation (AEC) algorithm is currently converged.
PreviouslyDiverged | 2 | The Acoustic Echo Cancellation (AEC) algorithm lost convergence. The convergence history remains in this state until the algorithm is reset or timely data is no longer arriving on the capture or render stream.
ContinuouslyConverged | 1 | When the Acoustic Echo Cancellation (AEC) algorithm has converged.
Uninitialized | 0 | Initial state of the Acoustic Echo Cancellation (AEC) algorithm.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CaptureAcousticEchoCancellationEffect.Status


Frequency Enumeration (Microsoft.DirectX.DirectSound)

Frequency Enumeration

Contains constants that describe the range of frequency, in samples per second, at which a software buffer can play.

Definition

Visual Basic | Public Enum Frequency
C# | public enum Frequency
C++ | public enum class Frequency
JScript | public enum Frequency

Members

Member | Value | Description
Original | 0 | Orignal buffer frequency.
Max | 200000 | Maximum buffer frequency.
Min | 100 | Minimum buffer frequency.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer.Frequency


LockFlag Enumeration (Microsoft.DirectX.DirectSound)

LockFlag Enumeration

Contains constants that describe how to lock a buffer while reading or writing to it.

Definition

Visual Basic | Public Enum LockFlag
C# | public enum LockFlag
C++ | public enum class LockFlag
JScript | public enum LockFlag

Members

Member | Value | Description
None | 0 | Do not lock the buffer.
EntireBuffer | 2 | Lock the entire buffer.
FromWriteCursor | 1 | Start the lock at the write cursor.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer.Read
  • Buffer.Write
  • CaptureBuffer.Read
  • CaptureBuffer.Write


Mode3D Enumeration (Microsoft.DirectX.DirectSound)

Mode3D Enumeration

Contains constents that describe the operation mode for 3-D sound processing.

Definition

Visual Basic | Public Enum Mode3D
C# | public enum Mode3D
C++ | public enum class Mode3D
JScript | public enum Mode3D

Members

Member | Value | Description
Disable | 2 | Processing of 3-D sound is disabled. The sound seems to originate from the center of the listener's head.
HeadRelative | 1 | Sound parameters (position, velocity, and orientation) are relative to the listener's parameters. In this mode, the absolute parameters of the sound are updated automatically as the listener's parameters change so that the relative parameters remain constant.
Normal | 0 | Normal processing. This is the default mode.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer3D.Mode


OperationMode Enumeration (Microsoft.DirectX.DirectSound)

OperationMode Enumeration

Contains constants that describe the mode of a CaptureAcousticEchoCancellationEffect object.

Definition

Visual Basic | Public Enum OperationMode
C# | public enum OperationMode
C++ | public enum class OperationMode
JScript | public enum OperationMode

Members

Member | Value | Description
FullDuplex | 2 | The effect is passing through capture and render data without modifying it.
HalfDuplex | 1 | The effect is running in half duplex mode. Not presently supported.
PassThrough | 0 | The effect is passing through capture and render data without modifying it.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CaptureEffectsAcousticEchoCancellation.Mode


Pan Enumeration (Microsoft.DirectX.DirectSound)

Pan Enumeration

Contains constants which describe how a buffer plays a sound in the stereo (2-channel) field.

Definition

Visual Basic | Public Enum Pan
C# | public enum Pan
C++ | public enum class Pan
JScript | public enum Pan

Members

Member | Value | Description
Center | 0 | Equal volume in both channels.
Right | 10000 | The right channel is at normal volume, and the left channel is effectively silent.
Left | -10000 | The left channel is at normal volume, and the right channel is effectively silent.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer.Pan


PositionNotifyFlag Enumeration (Microsoft.DirectX.DirectSound)

PositionNotifyFlag Enumeration

Contains constants that are used to signify types of position notifications.

Definition

Visual Basic | Public Enum PositionNotifyFlag
C# | public enum PositionNotifyFlag
C++ | public enum class PositionNotifyFlag
JScript | public enum PositionNotifyFlag

Members

Member | Value | Description
OffsetStop | -1 | Causes the event to be signaled when playback or capture stops.
None | 0 | No event is raised.

Remarks

This enumeration can be used by the BufferPositionNotify.Offset property to signify events that are not absolute offset times. In order to use this enumeration as such, you must cast it to an integer, as in the following code:

[C#]
int offsetStop = (int)PositionNotifyFlag.OffsetStop;
BufferPositionNotify.Offset = offsetStop;

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • BufferPositionNotify.Offset


Volume Enumeration (Microsoft.DirectX.DirectSound)

Volume Enumeration

Contains constants that describe the minimum and maximum volume at which a buffer can play.

Definition

Visual Basic | Public Enum Volume
C# | public enum Volume
C++ | public enum class Volume
JScript | public enum Volume

Members

Member | Value | Description
Max | 0 | Maximum volume. The buffer volume is not attenuated.
Min | -10000 | Minimum volume. The buffer volume is effectively silent.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer.Volume
  • Buffer3D.ConeOutsideVolume


WaveFormatTag Enumeration (Microsoft.DirectX.DirectSound)

WaveFormatTag Enumeration

Contains constants that describe waveform-audio format types.

Definition

Visual Basic | Public Enum WaveFormatTag
C# | public enum WaveFormatTag
C++ | public enum class WaveFormatTag
JScript | public enum WaveFormatTag

Members

Member | Value | Description
Pcm | 1 | Waveform-audio format is one- or two-channel PCM data.

Enumeration Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • WaveFormat.FormatTag


Angles Structure (Microsoft.DirectX.DirectSound)

Angles Structure

Contains properties that describe the inside and outside angles of the sound projection cone.

Definition

Visual Basic | Public Structure Angles
C# | public struct Angles
C++ | public value class Angles sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Angles | Initializes a new instance of the Angles structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Inside | Retrieves the inside angle of the sound projection cone, in degrees.
Outside | Retrieves the outside angle of the sound projection cone, in degrees.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer3D.ConeAngles


Angles.Angles() Constructor (Microsoft.DirectX.DirectSound)

Angles.Angles Constructor

Initializes a new instance of the Angles structure.

Definition

Visual Basic | Public Sub New()
C# | public Angles();
C++ public:
Angles();
JScript | public function Angles();


Angles.ToString() Method (Microsoft.DirectX.DirectSound)

Angles.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Angles.Inside Property (Microsoft.DirectX.DirectSound)

Angles.Inside Property

Retrieves the inside angle of the sound projection cone, in degrees.

Definition

Visual Basic | Public Property Inside As Integer
C# | public int Inside { get; set; }
C++ public:
property int Inside {
int get();
void set(int value);
}
JScript public function get Inside() : int
public function set Inside(int);

Property Value

System.Int32
The inside angle of the sound projection cone, in degrees.

This property is read/write.

Remarks

This is the angle within which the sound is at its normal volume.


Angles.Outside Property (Microsoft.DirectX.DirectSound)

Angles.Outside Property

Retrieves the outside angle of the sound projection cone, in degrees.

Definition

Visual Basic | Public Property Outside As Integer
C# | public int Outside { get; set; }
C++ public:
property int Outside {
int get();
void set(int value);
}
JScript public function get Outside() : int
public function set Outside(int);

Property Value

System.Int32
The outside angle of the sound projection cone, in degrees.

This property is read/write.

Remarks

This is the angle outside of which the sound is at its outside volume.


Buffer3DSettings Structure (Microsoft.DirectX.DirectSound)

Buffer3DSettings Structure

Contains properties that describe all the information necessary to uniquely describe the location, orientation, and motion of a 3-D sound buffer.

Definition

Visual Basic | Public Structure Buffer3DSettings
C# | public struct Buffer3DSettings
C++ | public value class Buffer3DSettings sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Buffer3DSettings | Initializes a new instance of the Buffer3DSettings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
ConeOrientation | Retrieves and sets the current orientation of this 3-D buffer's sound projection cone.
ConeOutsideVolume | Retrieves and sets the volume of the sound outside the outside angle of the sound projection cone.
InsideConeAngle | Retrieves and sets the angle of the inside sound projection cone.
MaxDistance | Retrieves and sets the maximum attenuation distance.
MinDistance | Retrieves and sets the minimum attenuation distance.
Mode | Retrieves and sets the 3-D sound processing mode to be set.
OutsideConeAngle | Retrieves and sets the angle of the outside sound projection cone.
Position | Retrieves and sets the current position of the 3-D sound buffer.
Velocity | Retrieves and sets the current velocity of the 3-D sound buffer.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer3D.AllParameters


Buffer3DSettings.Buffer3DSettings() Constructor (Microsoft.DirectX.DirectSound)

Buffer3DSettings.Buffer3DSettings Constructor

Initializes a new instance of the Buffer3DSettings structure.

Definition

Visual Basic | Public Sub New()
C# | public Buffer3DSettings();
C++ public:
Buffer3DSettings();
JScript | public function Buffer3DSettings();


Buffer3DSettings.ToString() Method (Microsoft.DirectX.DirectSound)

Buffer3DSettings.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Buffer3DSettings.ConeOrientation Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.ConeOrientation Property

Retrieves and sets the current orientation of this 3-D buffer's sound projection cone.

Definition

Visual Basic | Public Property ConeOrientation As Vector3
C# | public Vector3 ConeOrientation { get; set; }
C++ public:
property Vector3 ConeOrientation {
Vector3 get();
void set(Vector3 value);
}
JScript public function get ConeOrientation() : Vector3
public function set ConeOrientation(Vector3);

Property Value

Microsoft.DirectX.Vector3
The current orientation of this 3-D buffer's sound projection cone.

This property is read/write.


Buffer3DSettings.ConeOutsideVolume Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.ConeOutsideVolume Property

Retrieves and sets the volume of the sound outside the outside angle of the sound projection cone.

Definition

Visual Basic | Public Property ConeOutsideVolume As Integer
C# | public int ConeOutsideVolume { get; set; }
C++ public:
property int ConeOutsideVolume {
int get();
void set(int value);
}
JScript public function get ConeOutsideVolume() : int
public function set ConeOutsideVolume(int);

Property Value

System.Int32
The the volume of the sound outside the outside angle of the sound projection cone.

This property is read/write.


Buffer3DSettings.InsideConeAngle Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.InsideConeAngle Property

Retrieves and sets the angle of the inside sound projection cone.

Definition

Visual Basic | Public Property InsideConeAngle As Integer
C# | public int InsideConeAngle { get; set; }
C++ public:
property int InsideConeAngle {
int get();
void set(int value);
}
JScript public function get InsideConeAngle() : int
public function set InsideConeAngle(int);

Property Value

System.Int32
The angle of the inside sound projection cone.

This property is read/write.


Buffer3DSettings.MaxDistance Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.MaxDistance Property

Retrieves and sets the maximum attenuation distance.

Definition

Visual Basic | Public Property MaxDistance As Single
C# | public float MaxDistance { get; set; }
C++ public:
property float MaxDistance {
float get();
void set(float value);
}
JScript public function get MaxDistance() : float
public function set MaxDistance(float);

Property Value

System.Single
The maximum attenuation distance.

This property is read/write.

Remarks

This property is the distance from the listener beyond which sounds in this buffer are no longer attenuated.


Buffer3DSettings.MinDistance Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.MinDistance Property

Retrieves and sets the minimum attenuation distance.

Definition

Visual Basic | Public Property MinDistance As Single
C# | public float MinDistance { get; set; }
C++ public:
property float MinDistance {
float get();
void set(float value);
}
JScript public function get MinDistance() : float
public function set MinDistance(float);

Property Value

System.Single
The minimum attenuation distance.

This property is read/write.

Remarks

This property is the distance from the listener at which sounds in this buffer begin to be attenuated.


Buffer3DSettings.Mode Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.Mode Property

Retrieves and sets the 3-D sound processing mode to be set.

Definition

Visual Basic | Public Property Mode As Mode3D
C# | public Mode3D Mode { get; set; }
C++ public:
property Mode3D Mode {
Mode3D get();
void set(Mode3D value);
}
JScript public function get Mode() : Mode3D
public function set Mode(Mode3D);

Property Value

Microsoft.DirectX.DirectSound.Mode3D
The 3-D sound processing mode to be set.

This property is read/write.


Buffer3DSettings.OutsideConeAngle Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.OutsideConeAngle Property

Retrieves and sets the angle of the outside sound projection cone.

Definition

Visual Basic | Public Property OutsideConeAngle As Integer
C# | public int OutsideConeAngle { get; set; }
C++ public:
property int OutsideConeAngle {
int get();
void set(int value);
}
JScript public function get OutsideConeAngle() : int
public function set OutsideConeAngle(int);

Property Value

System.Int32
The angle of the outside sound projection cone.

This property is read/write.


Buffer3DSettings.Position Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.Position Property

Retrieves and sets the current position of the 3-D sound buffer.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
The current position of the 3-D sound buffer.

This property is read/write.


Buffer3DSettings.Velocity Property (Microsoft.DirectX.DirectSound)

Buffer3DSettings.Velocity Property

Retrieves and sets the current velocity of the 3-D sound buffer.

Definition

Visual Basic | Public Property Velocity As Vector3
C# | public Vector3 Velocity { get; set; }
C++ public:
property Vector3 Velocity {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Velocity() : Vector3
public function set Velocity(Vector3);

Property Value

Microsoft.DirectX.Vector3
The current velocity of the 3-D sound buffer.

This property is read/write.


BufferCaps Structure (Microsoft.DirectX.DirectSound)

BufferCaps Structure

Contains properties that describe the capabilities of a Buffer object or a SecondaryBuffer object.

Definition

Visual Basic | Public Structure BufferCaps
C# | public struct BufferCaps
C++ | public value class BufferCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BufferCaps | Initializes a new instance of the BufferCaps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BufferBytes | Retrieves the size of the new buffer.
CanGetCurrentPosition | Retrieves whether the application can get a more accurate play cursor.
Control3D | Retrieves whether the buffer has 3-D control capability.
ControlEffects | Retrieves whether the buffer supports effects processing.
ControlFrequency | Retrieves whether the buffer has frequency control capability.
ControlPan | Retrieves whether the buffer has pan control capability.
ControlPositionNotify | Retrieves whether the buffer has position notification capability.
ControlVolume | Retrieves whether the buffer has volume control capability.
GlobalFocus | Retrieves whether the buffer is a global sound buffer.
LocateInHardware | Retrieves whether the buffer must use hardware mixing.
LocateInSoftware | Retrieves whether the buffer must use software memory and use software mixing, even if BufferDescription.StaticBuffer is specified and hardware resources are available.
LocationDefer | Retrieves whether the buffer can be assigned to a hardware or software resource at play time.
Mute3DAtMaximumDistance | Retrieves whether the sound is reduced to silence at the maximum distance.
PlayCpuOverhead | Retrieves the processing overhead, as a percentage, of main processor cycles needed to mix this sound buffer.
PrimaryBuffer | Retrieves whether the buffer is a primary sound buffer.
StaticBuffer | Retrieves whether the buffer is placed in on-board hardware memory, if available.
StickyFocus | Retrieves whether the buffer has sticky focus.
UnlockTransferRate | Retrieves the rate, in kilobytes per second, at which data is transferred to the buffer memory when reading and writing to a buffer.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer.Caps


BufferCaps.BufferCaps() Constructor (Microsoft.DirectX.DirectSound)

BufferCaps.BufferCaps Constructor

Initializes a new instance of the BufferCaps structure.

Definition

Visual Basic | Public Sub New()
C# | public BufferCaps();
C++ public:
BufferCaps();
JScript | public function BufferCaps();


BufferCaps.ToString() Method (Microsoft.DirectX.DirectSound)

BufferCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


BufferCaps.BufferBytes Property (Microsoft.DirectX.DirectSound)

BufferCaps.BufferBytes Property

Retrieves the size of the new buffer.

Definition

Visual Basic | Public ReadOnly Property BufferBytes As Integer
C# | public int BufferBytes { get; }
C++ public:
property int BufferBytes {
int get();
}
JScript | public function get BufferBytes() : int

Property Value

System.Int32
Value that represents the size of the new buffer, in bytes.

This property is read-only.

Remarks

This value will always be 0 for a buffer created with BufferDescription.PrimaryBuffer set to true.


BufferCaps.CanGetCurrentPosition Property (Microsoft.DirectX.DirectSound)

BufferCaps.CanGetCurrentPosition Property

Retrieves whether the application can get a more accurate play cursor.

Definition

Visual Basic | Public ReadOnly Property CanGetCurrentPosition As Boolean
C# | public bool CanGetCurrentPosition { get; }
C++ public:
property bool CanGetCurrentPosition {
bool get();
}
JScript | public function get CanGetCurrentPosition() : boolean

Property Value

System.Boolean
Value that is set to true if the application can get a more accurate play cursor from the buffer; otherwise, false.

This property is read-only.

Remarks

The Buffer.GetCurrentPosition method uses the new behavior of the play cursor. In Microsoft DirectSound in Microsoft DirectX 1, the play cursor was significantly ahead of the actual playing sound on emulated sound cards; it was directly behind the write cursor. Now, if CanGetCurrentPosition is true, the application can get a more accurate play cursor. If this property is false, the old behavior is preserved for compatibility.

CanGetCurrentPosition only matters with emulated sound cards. If a DirectSound driver is present, the play cursor is accurate for DirectSound in all versions of DirectX.


BufferCaps.Control3D Property (Microsoft.DirectX.DirectSound)

BufferCaps.Control3D Property

Retrieves whether the buffer has 3-D control capability.

Definition

Visual Basic | Public ReadOnly Property Control3D As Boolean
C# | public bool Control3D { get; }
C++ public:
property bool Control3D {
bool get();
}
JScript | public function get Control3D() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer has 3-D control capability; otherwise, false.

This property is read-only.


BufferCaps.ControlEffects Property (Microsoft.DirectX.DirectSound)

BufferCaps.ControlEffects Property

Retrieves whether the buffer supports effects processing.

Definition

Visual Basic | Public ReadOnly Property ControlEffects As Boolean
C# | public bool ControlEffects { get; }
C++ public:
property bool ControlEffects {
bool get();
}
JScript | public function get ControlEffects() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer supports effects processing; otherwise, false.

This property is read-only.


BufferCaps.ControlFrequency Property (Microsoft.DirectX.DirectSound)

BufferCaps.ControlFrequency Property

Retrieves whether the buffer has frequency control capability.

Definition

Visual Basic | Public ReadOnly Property ControlFrequency As Boolean
C# | public bool ControlFrequency { get; }
C++ public:
property bool ControlFrequency {
bool get();
}
JScript | public function get ControlFrequency() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer has frequency control capability; otherwise, false.

This property is read-only.


BufferCaps.ControlPan Property (Microsoft.DirectX.DirectSound)

BufferCaps.ControlPan Property

Retrieves whether the buffer has pan control capability.

Definition

Visual Basic | Public ReadOnly Property ControlPan As Boolean
C# | public bool ControlPan { get; }
C++ public:
property bool ControlPan {
bool get();
}
JScript | public function get ControlPan() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer has pan control capability; otherwise, false.

This property is read-only.


BufferCaps.ControlPositionNotify Property (Microsoft.DirectX.DirectSound)

BufferCaps.ControlPositionNotify Property

Retrieves whether the buffer has position notification capability.

Definition

Visual Basic | Public ReadOnly Property ControlPositionNotify As Boolean
C# | public bool ControlPositionNotify { get; }
C++ public:
property bool ControlPositionNotify {
bool get();
}
JScript | public function get ControlPositionNotify() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer has position notification capability; otherwise, false.

This property is read-only.

Remarks

Because the virtual device driver model (VXD) does not support notifications, a sound buffer created with BufferDescription.ControlPositionNotify set to true is always a software buffer when using VXD drivers. With the Windows Driver Model (WDM), a notification-enabled buffer can be in hardware, if hardware resources are available.


BufferCaps.ControlVolume Property (Microsoft.DirectX.DirectSound)

BufferCaps.ControlVolume Property

Retrieves whether the buffer has volume control capability.

Definition

Visual Basic | Public ReadOnly Property ControlVolume As Boolean
C# | public bool ControlVolume { get; }
C++ public:
property bool ControlVolume {
bool get();
}
JScript | public function get ControlVolume() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer has volume control capability; otherwise, false.

This property is read-only.


BufferCaps.GlobalFocus Property (Microsoft.DirectX.DirectSound)

BufferCaps.GlobalFocus Property

Retrieves whether the buffer is a global sound buffer.

Definition

Visual Basic | Public ReadOnly Property GlobalFocus As Boolean
C# | public bool GlobalFocus { get; }
C++ public:
property bool GlobalFocus {
bool get();
}
JScript | public function get GlobalFocus() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer is a global buffer; otherwise, false.

This property is read-only.

Remarks

When GlobalFocus is set to true, an application using Microsoft DirectSound can continue to play its buffers if the user switches focus to another application, even if the new application uses DirectSound. The one exception is that the global sounds from other applications will not be audible if you switch focus to a DirectSound application that uses the CooperativeLevel.WritePrimary flag for its cooperative level.


BufferCaps.LocateInHardware Property (Microsoft.DirectX.DirectSound)

BufferCaps.LocateInHardware Property

Retrieves whether the buffer must use hardware mixing.

Definition

Visual Basic | Public ReadOnly Property LocateInHardware As Boolean
C# | public bool LocateInHardware { get; }
C++ public:
property bool LocateInHardware {
bool get();
}
JScript | public function get LocateInHardware() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer must use hardware mixing; otherwise, false.

This property is read-only.


BufferCaps.LocateInSoftware Property (Microsoft.DirectX.DirectSound)

BufferCaps.LocateInSoftware Property

Retrieves whether the buffer must use software memory and use software mixing, even if BufferDescription.StaticBuffer is specified and hardware resources are available.

Definition

Visual Basic | Public ReadOnly Property LocateInSoftware As Boolean
C# | public bool LocateInSoftware { get; }
C++ public:
property bool LocateInSoftware {
bool get();
}
JScript | public function get LocateInSoftware() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer must use software mixing; otherwise, false.

This property is read-only.


BufferCaps.LocationDefer Property (Microsoft.DirectX.DirectSound)

BufferCaps.LocationDefer Property

Retrieves whether the buffer can be assigned to a hardware or software resource at play time.

Definition

Visual Basic | Public ReadOnly Property LocationDefer As Boolean
C# | public bool LocationDefer { get; }
C++ public:
property bool LocationDefer {
bool get();
}
JScript | public function get LocationDefer() : boolean

Property Value

System.Boolean
Value that is set to true if if the buffer can be assigned to a hardware or software resource at play time; otherwise, false.

This property is read-only.


BufferCaps.Mute3DAtMaximumDistance Property (Microsoft.DirectX.DirectSound)

BufferCaps.Mute3DAtMaximumDistance Property

Retrieves whether the sound is reduced to silence at the maximum distance.

Definition

Visual Basic | Public ReadOnly Property Mute3DAtMaximumDistance As Boolean
C# | public bool Mute3DAtMaximumDistance { get; }
C++ public:
property bool Mute3DAtMaximumDistance {
bool get();
}
JScript | public function get Mute3DAtMaximumDistance() : boolean

Property Value

System.Boolean
Value that is set to true to mute sound at the maximum distance; otherwise, false.

This property is read-only.

Remarks

The buffer will stop playing when the maximum distance is exceeded, so that processor time is not wasted. Applies only to software buffers.


BufferCaps.PlayCpuOverhead Property (Microsoft.DirectX.DirectSound)

BufferCaps.PlayCpuOverhead Property

Retrieves the processing overhead, as a percentage, of main processor cycles needed to mix this sound buffer.

Definition

Visual Basic | Public ReadOnly Property PlayCpuOverhead As Integer
C# | public int PlayCpuOverhead { get; }
C++ public:
property int PlayCpuOverhead {
int get();
}
JScript | public function get PlayCpuOverhead() : int

Property Value

System.Int32
The processing overhead, as a percentage, of main processor cycles needed to mix this sound buffer.

This property is read-only.

Remarks

For hardware buffers, this member will be zero because the mixing is performed by the sound device. For software buffers, this member depends on the buffer format and the speed of the system processor.


BufferCaps.PrimaryBuffer Property (Microsoft.DirectX.DirectSound)

BufferCaps.PrimaryBuffer Property

Retrieves whether the buffer is a primary sound buffer.

Definition

Visual Basic | Public ReadOnly Property PrimaryBuffer As Boolean
C# | public bool PrimaryBuffer { get; }
C++ public:
property bool PrimaryBuffer {
bool get();
}
JScript | public function get PrimaryBuffer() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer is a primary sound buffer; otherwise, false.

This property is read-only.


BufferCaps.StaticBuffer Property (Microsoft.DirectX.DirectSound)

BufferCaps.StaticBuffer Property

Retrieves whether the buffer is placed in on-board hardware memory, if available.

Definition

Visual Basic | Public ReadOnly Property StaticBuffer As Boolean
C# | public bool StaticBuffer { get; }
C++ public:
property bool StaticBuffer {
bool get();
}
JScript | public function get StaticBuffer() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer is a static buffer; otherwise, false.

This property is read-only.


BufferCaps.StickyFocus Property (Microsoft.DirectX.DirectSound)

BufferCaps.StickyFocus Property

Retrieves whether the buffer has sticky focus.

Definition

Visual Basic | Public ReadOnly Property StickyFocus As Boolean
C# | public bool StickyFocus { get; }
C++ public:
property bool StickyFocus {
bool get();
}
JScript | public function get StickyFocus() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer has sticky focus; otherwise, false.

This property is read-only.

Remarks

If the user switches to another application not using Microsoft DirectSound, the application's normal buffers are muted, but sticky focus buffers are still audible.


BufferCaps.UnlockTransferRate Property (Microsoft.DirectX.DirectSound)

BufferCaps.UnlockTransferRate Property

Retrieves the rate, in kilobytes per second, at which data is transferred to the buffer memory when reading and writing to a buffer.

Definition

Visual Basic | Public ReadOnly Property UnlockTransferRate As Integer
C# | public int UnlockTransferRate { get; }
C++ public:
property int UnlockTransferRate {
int get();
}
JScript | public function get UnlockTransferRate() : int

Property Value

System.Int32
The rate, in kilobytes per second, at which data is transferred to the buffer memory when reading and writing to a buffer.

This property is read-only.


BufferPositionNotify Structure (Microsoft.DirectX.DirectSound)

BufferPositionNotify Structure

Contains properties that describe a notification position.

Definition

Visual Basic | Public Structure BufferPositionNotify
C# | public struct BufferPositionNotify
C++ | public value class BufferPositionNotify sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BufferPositionNotify | Initializes a new instance of the BufferPositionNotify structure.

Properties

Property | Description
EventNotifyHandle | Retrieves and sets the handle to the event to be signaled when the offset has been reached.
Offset | Retrieves and sets the offset from the beginning of the buffer where the notify event is to be triggered, or PositionNotifyFlag.OffsetStop.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Notify.NotificationPositions


BufferPositionNotify.BufferPositionNotify() Constructor (Microsoft.DirectX.DirectSound)

BufferPositionNotify.BufferPositionNotify Constructor

Initializes a new instance of the BufferPositionNotify structure.

Definition

Visual Basic | Public Sub New()
C# | public BufferPositionNotify();
C++ public:
BufferPositionNotify();
JScript | public function BufferPositionNotify();


BufferPositionNotify.EventNotifyHandle Property (Microsoft.DirectX.DirectSound)

BufferPositionNotify.EventNotifyHandle Property

Retrieves and sets the handle to the event to be signaled when the offset has been reached.

Definition

Visual Basic | Public Property EventNotifyHandle As IntPtr
C# | public IntPtr EventNotifyHandle { get; set; }
C++ public:
property IntPtr EventNotifyHandle {
IntPtr get();
void set(IntPtr value);
}
JScript public function get EventNotifyHandle() : IntPtr
public function set EventNotifyHandle(IntPtr);

Property Value

System.IntPtr
The handle to the event to be signaled when the offset has been reached.

This property is read/write.


BufferPositionNotify.Offset Property (Microsoft.DirectX.DirectSound)

BufferPositionNotify.Offset Property

Retrieves and sets the offset from the beginning of the buffer where the notify event is to be triggered, or PositionNotifyFlag.OffsetStop.

Definition

Visual Basic | Public Property Offset As Integer
C# | public int Offset { get; set; }
C++ public:
property int Offset {
int get();
void set(int value);
}
JScript public function get Offset() : int
public function set Offset(int);

Property Value

System.Int32
The offset from the beginning of the buffer where the notify event is to be triggered, or PositionNotifyFlag.OffsetStop.

This property is read/write.

Remarks

Setting this property to PositionNotifyFlag.OffsetStop causes the event to be signaled when playback or capture stops, either because the end of the buffer has been reached (and playback or capture is not looping) or because the application called stop method of the buffer.

In order to set this property with the PositionNotifyFlag.OffsetStop flag, you must cast it to an integer, as done in the following code.

[C#]
BufferPositionNotify.Offset = (int)PositionNotifyFlag.OffsetStop;

When a playback buffer was created with BufferDescription.DeferLocation and BufferDescription.ControlPositionNotify along with any voice management flag, it is possible that a sound that has notifications set, but not yet reached, will be terminated by the voice manager. In this case, no event is signaled.


BufferStatus Structure (Microsoft.DirectX.DirectSound)

BufferStatus Structure

Contains properties that describe the status of a buffer.

Definition

Visual Basic | Public Structure BufferStatus
C# | public struct BufferStatus
C++ | public value class BufferStatus sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
BufferStatus | Initializes a new instance of the BufferStatus structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BufferLost | Retrieves whether a buffer is lost and must be restored before it is played or locked.
LocatedInHardware | Retrieves whether a buffer is located in hardware.
LocatedInSoftware | Retrieves whether a buffer is located in software.
Looping | Retrieves whether the buffer is looping.
Playing | Retrieves whether the buffer is playing.
Terminated | Retrieves whether the buffer has terminated.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer.Status


BufferStatus.BufferStatus() Constructor (Microsoft.DirectX.DirectSound)

BufferStatus.BufferStatus Constructor

Initializes a new instance of the BufferStatus structure.

Definition

Visual Basic | Public Sub New()
C# | public BufferStatus();
C++ public:
BufferStatus();
JScript | public function BufferStatus();


BufferStatus.ToString() Method (Microsoft.DirectX.DirectSound)

BufferStatus.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


BufferStatus.BufferLost Property (Microsoft.DirectX.DirectSound)

BufferStatus.BufferLost Property

Retrieves whether a buffer is lost and must be restored before it is played or locked.

Definition

Visual Basic | Public ReadOnly Property BufferLost As Boolean
C# | public bool BufferLost { get; }
C++ public:
property bool BufferLost {
bool get();
}
JScript | public function get BufferLost() : boolean

Property Value

System.Boolean
Value that is set to true if a buffer is lost and must be restored; otherwise, false.

This property is read-only.


BufferStatus.LocatedInHardware Property (Microsoft.DirectX.DirectSound)

BufferStatus.LocatedInHardware Property

Retrieves whether a buffer is located in hardware.

Definition

Visual Basic | Public ReadOnly Property LocatedInHardware As Boolean
C# | public bool LocatedInHardware { get; }
C++ public:
property bool LocatedInHardware {
bool get();
}
JScript | public function get LocatedInHardware() : boolean

Property Value

System.Boolean
Value that is set to true if a buffer is located in hardware; otherwise, false.

This property is read-only.

Remarks

This property is set only for buffers created with the BufferDescription.DeferLocation set to true.


BufferStatus.LocatedInSoftware Property (Microsoft.DirectX.DirectSound)

BufferStatus.LocatedInSoftware Property

Retrieves whether a buffer is located in software.

Definition

Visual Basic | Public ReadOnly Property LocatedInSoftware As Boolean
C# | public bool LocatedInSoftware { get; }
C++ public:
property bool LocatedInSoftware {
bool get();
}
JScript | public function get LocatedInSoftware() : boolean

Property Value

System.Boolean
Value that is set to true if a buffer is located in software; otherwise, false.

This property is read-only.

Remarks

This property is set only for buffers created with the BufferDescription.DeferLocation set to true.


BufferStatus.Looping Property (Microsoft.DirectX.DirectSound)

BufferStatus.Looping Property

Retrieves whether the buffer is looping.

Definition

Visual Basic | Public ReadOnly Property Looping As Boolean
C# | public bool Looping { get; }
C++ public:
property bool Looping {
bool get();
}
JScript | public function get Looping() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer is looping; otherwise, false.

This property is read-only.

Remarks

This property is only set in combination with Playing


BufferStatus.Playing Property (Microsoft.DirectX.DirectSound)

BufferStatus.Playing Property

Retrieves whether the buffer is playing.

Definition

Visual Basic | Public ReadOnly Property Playing As Boolean
C# | public bool Playing { get; }
C++ public:
property bool Playing {
bool get();
}
JScript | public function get Playing() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer is playing; otherwise, false.

This property is read-only.

Remarks

This property is set if the buffer is being heard. When making a call to play or stop a buffer, this property might not immediately change the status because of latency.


BufferStatus.Terminated Property (Microsoft.DirectX.DirectSound)

BufferStatus.Terminated Property

Retrieves whether the buffer has terminated.

Definition

Visual Basic | Public ReadOnly Property Terminated As Boolean
C# | public bool Terminated { get; }
C++ public:
property bool Terminated {
bool get();
}
JScript | public function get Terminated() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer has terminated; otherwise, false.

This property is read-only.


Caps Structure (Microsoft.DirectX.DirectSound)

Caps Structure

Contains properties that describe the capabilities of a Microsoft DirectSound Device object.

Definition

Visual Basic | Public Structure Caps
C# | public struct Caps
C++ | public value class Caps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Caps | Initializes a new instance of the Caps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Certified | Retrieves whether the driver is a certified Windows Driver Module (WDM) device driver.
ContinuousRate | Retrieves whether the Device object supports all sample rates between the MinSecondarySampleRate and MaxSecondarySampleRate values.
EmulateDriver | Retrieves whether the Device object does not have a DirectSound driver installed.
FreeHardware3DAllBuffers | Retrieves the number of unallocated 3-D buffers.
FreeHardware3DStaticBuffers | Retrieves the number of unallocated static 3-D buffers.
FreeHardware3DStreamingBuffers | Retrieves the number of unallocated streaming 3-D buffers.
FreeHardwareMemoryBytes | Retrieves the size, in bytes, of the free memory on the sound card.
FreeHardwareMixingAllBuffers | Retrieves the number of unallocated buffers.
FreeHardwareMixingStaticBuffers | Retrieves the number of unallocated static buffers.
FreeHardwareMixingStreamingBuffers | Retrieves the number of unallocated streaming buffers.
MaxContigousFreeHardwareMemoryBytes | Retrieves the size, in bytes, of the largest contiguous block of free memory on the sound card.
MaxHardware3DAllBuffers | Retrieves the maximum number of 3-D buffers.
MaxHardware3DStaticBuffers | Retrieves the maximum number of static 3-D buffers.
MaxHardware3DStreamingBuffers | Retrieves the maximum number of streaming 3-D buffers.
MaxHardwareMixingAllBuffers | Retrieves the number of buffers that can be mixed in hardware.
MaxHardwareMixingStaticBuffers | Retrieves the maximum number of static buffers.
MaxHardwareMixingStreamingBuffers | Retrieves the maximum number of streaming sound buffers.
MaxSecondarySampleRate | Retrieves the maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.
MinSecondarySampleRate | Retrieves the maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.
PlayCpuOverheadSoftwareBuffers | Retrieves the processing overhead, as a percentage of main processor cycles, needed to mix software buffers.
Primary16Bit | Retrieves whether the Device object supports a primary buffer with 16-bit samples.
Primary8Bit | Retrieves whether the Device object supports primary buffers with 8-bit samples.
PrimaryBuffers | Retrieves the number of primary buffers supported.
PrimaryMono | Retrieves whether the Device object supports monophonic primary buffers.
PrimaryStereo | Retrieves whether the Device object supports stereo primary buffers.
Secondary16Bit | Retrieves whether the Device object supports hardware-mixed SecondaryBuffer objects with 16-bit samples.
Secondary8Bit | Retrieves whether the Device object supports hardware-mixed SecondaryBuffer objects with 8-bit samples.
SecondaryMono | Retrieves whether the Device object supports hardware-mixed monophonic SecondaryBuffer objects.
SecondaryStereo | Retrieves whether the Device object supports hardware-mixed stereo SecondaryBuffer objects.
TotalHardwareMemoryBytes | Retrieves the size, in bytes, of the amount of memory on the sound card that stores static sound buffers.
UnlockTransferRateHardwareBuffers | Retrieves the rate, in kilobytes per second, at which data can be transferred to hardware static sound buffers.

Remarks

Some audio cards may be unable to report accurately the number of available or free hardware buffers. This can happen, for example, when the card can play more sounds at lower sampling rates than at higher rates. In general, a nonzero value in any of the members relating to number of free hardware buffers signifies that at least one hardware resource of the appropriate type is available.

The unlock transfer rate for software buffers is 0, because the data need not be transferred anywhere. Similarly, the play processing overhead for hardware buffers is 0 because the mixing is done by the sound device.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Device.Caps


Caps.Caps() Constructor (Microsoft.DirectX.DirectSound)

Caps.Caps Constructor

Initializes a new instance of the Caps structure.

Definition

Visual Basic | Public Sub New()
C# | public Caps();
C++ public:
Caps();
JScript | public function Caps();


Caps.ToString() Method (Microsoft.DirectX.DirectSound)

Caps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Caps.Certified Property (Microsoft.DirectX.DirectSound)

Caps.Certified Property

Retrieves whether the driver is a certified Windows Driver Module (WDM) device driver.

Definition

Visual Basic | Public ReadOnly Property Certified As Boolean
C# | public bool Certified { get; }
C++ public:
property bool Certified {
bool get();
}
JScript | public function get Certified() : boolean

Property Value

System.Boolean
Value that is set to true if the driver is a certified Windows Driver Module (WDM) device driver; otherwise, false.

This property is read-only.


Caps.ContinuousRate Property (Microsoft.DirectX.DirectSound)

Caps.ContinuousRate Property

Retrieves whether the Device object supports all sample rates between the MinSecondarySampleRate and MaxSecondarySampleRate values.

Definition

Visual Basic | Public ReadOnly Property ContinuousRate As Boolean
C# | public bool ContinuousRate { get; }
C++ public:
property bool ContinuousRate {
bool get();
}
JScript | public function get ContinuousRate() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports all sample rates between the MinSecondarySampleRate and MaxSecondarySampleRate values; otherwise, false.

This property is read-only.

Remarks

Typically, this means that the actual output rate will be within +/- 10 hertz (Hz) of the requested frequency.


Caps.EmulateDriver Property (Microsoft.DirectX.DirectSound)

Caps.EmulateDriver Property

Retrieves whether the Device object does not have a Microsoft DirectSound driver installed.

Definition

Visual Basic | Public ReadOnly Property EmulateDriver As Boolean
C# | public bool EmulateDriver { get; }
C++ public:
property bool EmulateDriver {
bool get();
}
JScript | public function get EmulateDriver() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object does not have a DirectSound driver installed; otherwise, false.

This property is read-only.

Remarks

If this property is true, the Device object is being emulated through the waveform-audio functions. Performance degradation should be expected.


Caps.FreeHardware3DAllBuffers Property (Microsoft.DirectX.DirectSound)

Caps.FreeHardware3DAllBuffers Property

Retrieves the number of unallocated 3-D buffers.

Definition

Visual Basic | Public ReadOnly Property FreeHardware3DAllBuffers As Integer
C# | public int FreeHardware3DAllBuffers { get; }
C++ public:
property int FreeHardware3DAllBuffers {
int get();
}
JScript | public function get FreeHardware3DAllBuffers() : int

Property Value

System.Int32
The number of unallocated 3-D buffers.

This property is read-only.


Caps.FreeHardware3DStaticBuffers Property (Microsoft.DirectX.DirectSound)

Caps.FreeHardware3DStaticBuffers Property

Retrieves the number of unallocated static 3-D buffers.

Definition

Visual Basic | Public ReadOnly Property FreeHardware3DStaticBuffers As Integer
C# | public int FreeHardware3DStaticBuffers { get; }
C++ public:
property int FreeHardware3DStaticBuffers {
int get();
}
JScript | public function get FreeHardware3DStaticBuffers() : int

Property Value

System.Int32
The number of unallocated static 3-D buffers.

This property is read-only.


Caps.FreeHardware3DStreamingBuffers Property (Microsoft.DirectX.DirectSound)

Caps.FreeHardware3DStreamingBuffers Property

Retrieves the number of unallocated streaming 3-D buffers.

Definition

Visual Basic | Public ReadOnly Property FreeHardware3DStreamingBuffers As Integer
C# | public int FreeHardware3DStreamingBuffers { get; }
C++ public:
property int FreeHardware3DStreamingBuffers {
int get();
}
JScript | public function get FreeHardware3DStreamingBuffers() : int

Property Value

System.Int32
The number of unallocated streaming 3-D buffers.

This property is read-only.


Caps.FreeHardwareMemoryBytes Property (Microsoft.DirectX.DirectSound)

Caps.FreeHardwareMemoryBytes Property

Retrieves the size, in bytes, of the free memory on the sound card.

Definition

Visual Basic | Public ReadOnly Property FreeHardwareMemoryBytes As Integer
C# | public int FreeHardwareMemoryBytes { get; }
C++ public:
property int FreeHardwareMemoryBytes {
int get();
}
JScript | public function get FreeHardwareMemoryBytes() : int

Property Value

System.Int32
The size, in bytes, of the free memory on the sound card.

This property is read-only.


Caps.FreeHardwareMixingAllBuffers Property (Microsoft.DirectX.DirectSound)

Caps.FreeHardwareMixingAllBuffers Property

Retrieves the number of unallocated buffers.

Definition

Visual Basic | Public ReadOnly Property FreeHardwareMixingAllBuffers As Integer
C# | public int FreeHardwareMixingAllBuffers { get; }
C++ public:
property int FreeHardwareMixingAllBuffers {
int get();
}
JScript | public function get FreeHardwareMixingAllBuffers() : int

Property Value

System.Int32
The number of unallocated buffers.

This property is read-only.

Remarks

On Windows Driver Model (WDM) drivers, this includes FreeHardware3DAllBuffers.


Caps.FreeHardwareMixingStaticBuffers Property (Microsoft.DirectX.DirectSound)

Caps.FreeHardwareMixingStaticBuffers Property

Retrieves the number of unallocated static buffers.

Definition

Visual Basic | Public ReadOnly Property FreeHardwareMixingStaticBuffers As Integer
C# | public int FreeHardwareMixingStaticBuffers { get; }
C++ public:
property int FreeHardwareMixingStaticBuffers {
int get();
}
JScript | public function get FreeHardwareMixingStaticBuffers() : int

Property Value

System.Int32
The number of unallocated static buffers.

This property is read-only.


Caps.FreeHardwareMixingStreamingBuffers Property (Microsoft.DirectX.DirectSound)

Caps.FreeHardwareMixingStreamingBuffers Property

Retrieves the number of unallocated streaming buffers.

Definition

Visual Basic | Public ReadOnly Property FreeHardwareMixingStreamingBuffers As Integer
C# | public int FreeHardwareMixingStreamingBuffers { get; }
C++ public:
property int FreeHardwareMixingStreamingBuffers {
int get();
}
JScript | public function get FreeHardwareMixingStreamingBuffers() : int

Property Value

System.Int32
The number of unallocated streaming buffers.

This property is read-only.


Caps.MaxContigousFreeHardwareMemoryBytes Property (Microsoft.DirectX.DirectSound)

Caps.MaxContigousFreeHardwareMemoryBytes Property

Retrieves the size, in bytes, of the largest contiguous block of free memory on the sound card.

Definition

Visual Basic | Public ReadOnly Property MaxContigousFreeHardwareMemoryBytes As Integer
C# | public int MaxContigousFreeHardwareMemoryBytes { get; }
C++ public:
property int MaxContigousFreeHardwareMemoryBytes {
int get();
}
JScript | public function get MaxContigousFreeHardwareMemoryBytes() : int

Property Value

System.Int32
The size, in bytes, of the largest contiguous block of free memory on the sound card.

This property is read-only.


Caps.MaxHardware3DAllBuffers Property (Microsoft.DirectX.DirectSound)

Caps.MaxHardware3DAllBuffers Property

Retrieves the maximum number of 3-D buffers.

Definition

Visual Basic | Public ReadOnly Property MaxHardware3DAllBuffers As Integer
C# | public int MaxHardware3DAllBuffers { get; }
C++ public:
property int MaxHardware3DAllBuffers {
int get();
}
JScript | public function get MaxHardware3DAllBuffers() : int

Property Value

System.Int32
The maximum number of 3-D buffers.

This property is read-only.


Caps.MaxHardware3DStaticBuffers Property (Microsoft.DirectX.DirectSound)

Caps.MaxHardware3DStaticBuffers Property

Retrieves the maximum number of static 3-D buffers.

Definition

Visual Basic | Public ReadOnly Property MaxHardware3DStaticBuffers As Integer
C# | public int MaxHardware3DStaticBuffers { get; }
C++ public:
property int MaxHardware3DStaticBuffers {
int get();
}
JScript | public function get MaxHardware3DStaticBuffers() : int

Property Value

System.Int32
The maximum number of static 3-D buffers.

This property is read-only.


Caps.MaxHardware3DStreamingBuffers Property (Microsoft.DirectX.DirectSound)

Caps.MaxHardware3DStreamingBuffers Property

Retrieves the maximum number of streaming 3-D buffers.

Definition

Visual Basic | Public ReadOnly Property MaxHardware3DStreamingBuffers As Integer
C# | public int MaxHardware3DStreamingBuffers { get; }
C++ public:
property int MaxHardware3DStreamingBuffers {
int get();
}
JScript | public function get MaxHardware3DStreamingBuffers() : int

Property Value

System.Int32
The maximum number of streaming 3-D buffers.

This property is read-only.


Caps.MaxHardwareMixingAllBuffers Property (Microsoft.DirectX.DirectSound)

Caps.MaxHardwareMixingAllBuffers Property

Retrieves the number of buffers that can be mixed in hardware.

Definition

Visual Basic | Public ReadOnly Property MaxHardwareMixingAllBuffers As Integer
C# | public int MaxHardwareMixingAllBuffers { get; }
C++ public:
property int MaxHardwareMixingAllBuffers {
int get();
}
JScript | public function get MaxHardwareMixingAllBuffers() : int

Property Value

System.Int32
The number of buffers that can be mixed in hardware.

This property is read-only.

Remarks

This member can be less than the sum of MaxHardwareMixingStaticBuffers and MaxHardwareMixingStreamingBuffers. Resource tradeoffs frequently occur.


Caps.MaxHardwareMixingStaticBuffers Property (Microsoft.DirectX.DirectSound)

Caps.MaxHardwareMixingStaticBuffers Property

Retrieves the maximum number of static buffers.

Definition

Visual Basic | Public ReadOnly Property MaxHardwareMixingStaticBuffers As Integer
C# | public int MaxHardwareMixingStaticBuffers { get; }
C++ public:
property int MaxHardwareMixingStaticBuffers {
int get();
}
JScript | public function get MaxHardwareMixingStaticBuffers() : int

Property Value

System.Int32
The maximum number of static buffers.

This property is read-only.


Caps.MaxHardwareMixingStreamingBuffers Property (Microsoft.DirectX.DirectSound)

Caps.MaxHardwareMixingStreamingBuffers Property

Retrieves the maximum number of streaming sound buffers.

Definition

Visual Basic | Public ReadOnly Property MaxHardwareMixingStreamingBuffers As Integer
C# | public int MaxHardwareMixingStreamingBuffers { get; }
C++ public:
property int MaxHardwareMixingStreamingBuffers {
int get();
}
JScript | public function get MaxHardwareMixingStreamingBuffers() : int

Property Value

System.Int32
The maximum number of streaming sound buffers.

This property is read-only.


Caps.MaxSecondarySampleRate Property (Microsoft.DirectX.DirectSound)

Caps.MaxSecondarySampleRate Property

Retrieves the maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.

Definition

Visual Basic | Public ReadOnly Property MaxSecondarySampleRate As Integer
C# | public int MaxSecondarySampleRate { get; }
C++ public:
property int MaxSecondarySampleRate {
int get();
}
JScript | public function get MaxSecondarySampleRate() : int

Property Value

System.Int32
The maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.

This property is read-only.


Caps.MinSecondarySampleRate Property (Microsoft.DirectX.DirectSound)

Caps.MinSecondarySampleRate Property

Retrieves the maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.

Definition

Visual Basic | Public ReadOnly Property MinSecondarySampleRate As Integer
C# | public int MinSecondarySampleRate { get; }
C++ public:
property int MinSecondarySampleRate {
int get();
}
JScript | public function get MinSecondarySampleRate() : int

Property Value

System.Int32
The maximum sample rate specifications that are supported by this Device object's hardware SecondaryBuffer objects.

This property is read-only.


Caps.PlayCpuOverheadSoftwareBuffers Property (Microsoft.DirectX.DirectSound)

Caps.PlayCpuOverheadSoftwareBuffers Property

Retrieves the processing overhead, as a percentage of main processor cycles, needed to mix software buffers.

Definition

Visual Basic | Public ReadOnly Property PlayCpuOverheadSoftwareBuffers As Integer
C# | public int PlayCpuOverheadSoftwareBuffers { get; }
C++ public:
property int PlayCpuOverheadSoftwareBuffers {
int get();
}
JScript | public function get PlayCpuOverheadSoftwareBuffers() : int

Property Value

System.Int32
The processing overhead, as a percentage of main processor cycles, needed to mix software buffers.

This property is read-only.

Remarks

This property varies according to the bus type, the processor type, and the clock speed.


Caps.Primary16Bit Property (Microsoft.DirectX.DirectSound)

Caps.Primary16Bit Property

Retrieves whether the Device object supports a primary buffer with 16-bit samples.

Definition

Visual Basic | Public ReadOnly Property Primary16Bit As Boolean
C# | public bool Primary16Bit { get; }
C++ public:
property bool Primary16Bit {
bool get();
}
JScript | public function get Primary16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports a primary buffer with 16-bit samples; otherwise, false.

This property is read-only.


Caps.Primary8Bit Property (Microsoft.DirectX.DirectSound)

Caps.Primary8Bit Property

Retrieves whether the Device object supports primary buffers with 8-bit samples.

Definition

Visual Basic | Public ReadOnly Property Primary8Bit As Boolean
C# | public bool Primary8Bit { get; }
C++ public:
property bool Primary8Bit {
bool get();
}
JScript | public function get Primary8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports primary buffers with 8-bit samples; otherwise, false.

This property is read-only.


Caps.PrimaryBuffers Property (Microsoft.DirectX.DirectSound)

Caps.PrimaryBuffers Property

Retrieves the number of primary buffers supported.

Definition

Visual Basic | Public ReadOnly Property PrimaryBuffers As Integer
C# | public int PrimaryBuffers { get; }
C++ public:
property int PrimaryBuffers {
int get();
}
JScript | public function get PrimaryBuffers() : int

Property Value

System.Int32
The number of primary buffers supported.

This property is read-only.

Remarks

This value will always be 1.


Caps.PrimaryMono Property (Microsoft.DirectX.DirectSound)

Caps.PrimaryMono Property

Retrieves whether the Device object supports monophonic primary buffers.

Definition

Visual Basic | Public ReadOnly Property PrimaryMono As Boolean
C# | public bool PrimaryMono { get; }
C++ public:
property bool PrimaryMono {
bool get();
}
JScript | public function get PrimaryMono() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports monophonic primary buffers; otherwise, false.

This property is read-only.


Caps.PrimaryStereo Property (Microsoft.DirectX.DirectSound)

Caps.PrimaryStereo Property

Retrieves whether the Device object supports stereo primary buffers.

Definition

Visual Basic | Public ReadOnly Property PrimaryStereo As Boolean
C# | public bool PrimaryStereo { get; }
C++ public:
property bool PrimaryStereo {
bool get();
}
JScript | public function get PrimaryStereo() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports stereo primary buffers; otherwise, false.

This property is read-only.


Caps.Secondary16Bit Property (Microsoft.DirectX.DirectSound)

Caps.Secondary16Bit Property

Retrieves whether the Device object supports hardware-mixed SecondaryBuffer objects with 16-bit samples.

Definition

Visual Basic | Public ReadOnly Property Secondary16Bit As Boolean
C# | public bool Secondary16Bit { get; }
C++ public:
property bool Secondary16Bit {
bool get();
}
JScript | public function get Secondary16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports hardware-mixed SecondaryBuffer objects with 16-bit samples; otherwise, false.

This property is read-only.


Caps.Secondary8Bit Property (Microsoft.DirectX.DirectSound)

Caps.Secondary8Bit Property

Retrieves whether the Device object supports hardware-mixed SecondaryBuffer objects with 8-bit samples.

Definition

Visual Basic | Public ReadOnly Property Secondary8Bit As Boolean
C# | public bool Secondary8Bit { get; }
C++ public:
property bool Secondary8Bit {
bool get();
}
JScript | public function get Secondary8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports hardware-mixed SecondaryBuffer objects with 8-bit samples; otherwise, false.

This property is read-only.


Caps.SecondaryMono Property (Microsoft.DirectX.DirectSound)

Caps.SecondaryMono Property

Retrieves whether the Device object supports hardware-mixed monophonic SecondaryBuffer objects.

Definition

Visual Basic | Public ReadOnly Property SecondaryMono As Boolean
C# | public bool SecondaryMono { get; }
C++ public:
property bool SecondaryMono {
bool get();
}
JScript | public function get SecondaryMono() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports hardware-mixed monophonic SecondaryBuffer objects; otherwise, false.

This property is read-only.


Caps.SecondaryStereo Property (Microsoft.DirectX.DirectSound)

Caps.SecondaryStereo Property

Retrieves whether the Device object supports hardware-mixed stereo SecondaryBuffer objects.

Definition

Visual Basic | Public ReadOnly Property SecondaryStereo As Boolean
C# | public bool SecondaryStereo { get; }
C++ public:
property bool SecondaryStereo {
bool get();
}
JScript | public function get SecondaryStereo() : boolean

Property Value

System.Boolean
Value that is set to true if the Device object supports hardware-mixed stero SecondaryBuffer objects; otherwise, false.

This property is read-only.


Caps.TotalHardwareMemoryBytes Property (Microsoft.DirectX.DirectSound)

Caps.TotalHardwareMemoryBytes Property

Retrieves the size, in bytes, of the amount of memory on the sound card that stores static sound buffers.

Definition

Visual Basic | Public ReadOnly Property TotalHardwareMemoryBytes As Integer
C# | public int TotalHardwareMemoryBytes { get; }
C++ public:
property int TotalHardwareMemoryBytes {
int get();
}
JScript | public function get TotalHardwareMemoryBytes() : int

Property Value

System.Int32
The size, in bytes, of the amount of memory on the sound card that stores static sound buffers.

This property is read-only.


Caps.UnlockTransferRateHardwareBuffers Property (Microsoft.DirectX.DirectSound)

Caps.UnlockTransferRateHardwareBuffers Property

Retrieves the rate, in kilobytes per second, at which data can be transferred to hardware static sound buffers.

Definition

Visual Basic | Public ReadOnly Property UnlockTransferRateHardwareBuffers As Integer
C# | public int UnlockTransferRateHardwareBuffers { get; }
C++ public:
property int UnlockTransferRateHardwareBuffers {
int get();
}
JScript | public function get UnlockTransferRateHardwareBuffers() : int

Property Value

System.Int32
The rate, in kilobytes per second, at which data can be transferred to hardware static sound buffers.

This property is read-only.

Remarks

This and the number of bytes transferred determines the duration of a call to the Buffer.Read and Buffer.Write methods.


CaptureBufferCaps Structure (Microsoft.DirectX.DirectSound)

CaptureBufferCaps Structure

Contains properties that describe the capabilities of a CaptureBuffer object.

Definition

Visual Basic | Public Structure CaptureBufferCaps
C# | public struct CaptureBufferCaps
C++ | public value class CaptureBufferCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureBufferCaps | Initializes a new instance of the CaptureBufferCaps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BufferBytes | Retrieves the size, in bytes, of the CaptureBuffer object.
WaveMapped | Retrieves whether the buffer wave mapped.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CaptureBuffer.Caps


CaptureBufferCaps.CaptureBufferCaps() Constructor (Microsoft.DirectX.DirectSound)

CaptureBufferCaps.CaptureBufferCaps Constructor

Initializes a new instance of the CaptureBufferCaps structure.

Definition

Visual Basic | Public Sub New()
C# | public CaptureBufferCaps();
C++ public:
CaptureBufferCaps();
JScript | public function CaptureBufferCaps();


CaptureBufferCaps.ToString() Method (Microsoft.DirectX.DirectSound)

CaptureBufferCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CaptureBufferCaps.BufferBytes Property (Microsoft.DirectX.DirectSound)

CaptureBufferCaps.BufferBytes Property

Retrieves the size, in bytes, of the CaptureBuffer object.

Definition

Visual Basic | Public ReadOnly Property BufferBytes As Integer
C# | public int BufferBytes { get; }
C++ public:
property int BufferBytes {
int get();
}
JScript | public function get BufferBytes() : int

Property Value

System.Int32
The size, in bytes, of the CaptureBuffer object.

This property is read-only.


CaptureBufferCaps.WaveMapped Property (Microsoft.DirectX.DirectSound)

CaptureBufferCaps.WaveMapped Property

Retrieves whether the buffer wave mapped.

Definition

Visual Basic | Public ReadOnly Property WaveMapped As Boolean
C# | public bool WaveMapped { get; }
C++ public:
property bool WaveMapped {
bool get();
}
JScript | public function get WaveMapped() : boolean

Property Value

System.Boolean
Value that is set to true if the buffer wave mapped; otherwise, false.

This property is read-only.


CaptureBufferDescription Structure (Microsoft.DirectX.DirectSound)

CaptureBufferDescription Structure

Contains properties that describe a CaptureBuffer object.

Definition

Visual Basic | Public Structure CaptureBufferDescription
C# | public struct CaptureBufferDescription
C++ | public value class CaptureBufferDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureBufferDescription | Initializes a new instance of the CaptureBufferDescription structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
BufferBytes | Retrieves and sets the size of the capture buffer to create, in bytes.
CaptureEffectDescription | Retrieves and sets an array of CaptureEffectDescription structures that describe capture effects supported by the CaptureBuffer object.
ControlEffects | Retrieves and sets whether the CaptureBuffer object supports capture effects.
Format | Retrieves and sets the format in which to capture the audio data.
WaveMapped | Retrieves and sets whether the Microsoft Win32 wave mapper will be used for formats not supported by the device.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CaptureBuffer constructor
  • FullDuplex constructor


CaptureBufferDescription.CaptureBufferDescription() Constructor (Microsoft.DirectX.DirectSound)

CaptureBufferDescription.CaptureBufferDescription Constructor

 Language:

Initializes a new instance of the CaptureBufferDescription structure.

Definition

Visual Basic | Public Sub New()
C# | public CaptureBufferDescription();
C++ public:
CaptureBufferDescription();
JScript | public function CaptureBufferDescription();


CaptureBufferDescription.ToString() Method (Microsoft.DirectX.DirectSound)

CaptureBufferDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CaptureBufferDescription.BufferBytes Property (Microsoft.DirectX.DirectSound)

CaptureBufferDescription.BufferBytes Property

Retrieves and sets the size of the capture buffer to create, in bytes.

Definition

Visual Basic | Public Property BufferBytes As Integer
C# | public int BufferBytes { get; set; }
C++ public:
property int BufferBytes {
int get();
void set(int value);
}
JScript public function get BufferBytes() : int
public function set BufferBytes(int);

Property Value

System.Int32
The size of the capture buffer to create, in bytes.

This property is read/write.


CaptureBufferDescription.CaptureEffectDescription Property (Microsoft.DirectX.DirectSound)

CaptureBufferDescription.CaptureEffectDescription Property

Retrieves and sets an array of CaptureEffectDescription structures that describe capture effects supported by the CaptureBuffer object.

Definition

Visual Basic | Public Property CaptureEffectDescription As CaptureEffectDescription()
C# | public CaptureEffectDescription[] CaptureEffectDescription { get; set; }
C++ public:
property array<CaptureEffectDescription>^ CaptureEffectDescription {
array<CaptureEffectDescription>^ get();
void set(array<CaptureEffectDescription>^ value);
}
JScript public function get CaptureEffectDescription() : CaptureEffectDescription[]
public function set CaptureEffectDescription(CaptureEffectDescription[]);

Property Value

Microsoft.DirectX.DirectSound.CaptureEffectDescription[]
An array of CaptureEffectDescription structures that describe capture effects supported by the CaptureBuffer object.

This property is read/write.


CaptureBufferDescription.ControlEffects Property (Microsoft.DirectX.DirectSound)

CaptureBufferDescription.ControlEffects Property

Retrieves and sets whether the CaptureBuffer object supports capture effects.

Definition

Visual Basic | Public Property ControlEffects As Boolean
C# | public bool ControlEffects { get; set; }
C++ public:
property bool ControlEffects {
bool get();
void set(bool value);
}
JScript public function get ControlEffects() : boolean
public function set ControlEffects(boolean);

Property Value

System.Boolean
Value set that is set to true if the CaptureBuffer object supports capture effects; otherwise, false.

This property is read/write.


CaptureBufferDescription.Format Property (Microsoft.DirectX.DirectSound)

CaptureBufferDescription.Format Property

Retrieves and sets the format in which to capture the audio data.

Definition

Visual Basic | Public Property Format As WaveFormat
C# | public WaveFormat Format { get; set; }
C++ public:
property WaveFormat Format {
WaveFormat get();
void set(WaveFormat value);
}
JScript public function get Format() : WaveFormat
public function set Format(WaveFormat);

Property Value

Microsoft.DirectX.DirectSound.WaveFormat
The format in which to capture the audio data.

This property is read/write.


CaptureBufferDescription.WaveMapped Property (Microsoft.DirectX.DirectSound)

CaptureBufferDescription.WaveMapped Property

Retrieves and sets whether the Microsoft Win32 wave mapper will be used for formats not supported by the device.

Definition

Visual Basic | Public Property WaveMapped As Boolean
C# | public bool WaveMapped { get; set; }
C++ public:
property bool WaveMapped {
bool get();
void set(bool value);
}
JScript public function get WaveMapped() : boolean
public function set WaveMapped(boolean);

Property Value

System.Boolean
Value that is set to true if the Win32 wave mapper will be used for formats not supported by the device; otherwise, false.

This property is read/write.


CaptureCaps Structure (Microsoft.DirectX.DirectSound)

CaptureCaps Structure

Contains properties that describes the capabilities of the capture device.

Definition

Visual Basic | Public Structure CaptureCaps
C# | public struct CaptureCaps
C++ | public value class CaptureCaps sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureCaps | Initializes a new instance of the CaptureCaps structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Certified | Retrieves whether the driver for the device is a certified Windows Driver Model (WDM) driver.
Channels | Retrieves the number of channels supported by the device.
EmulatedDriver | Retrieves whether there is no Microsoft DirectSound capture driver for the device.
Format11KhzMono16Bit | Retrieves whether the capture device supports capturing audio with the 11Khz, 16-bit, mono wave format.
Format11KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 11Khz, 8-bit, mono wave format.
Format11KhzStereo16Bit | Retrieves whet,er the capture device supports capturing audio with the 11Khz, 16-bit, stereo wave format.
Format11KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 11Khz, 8-bit, stereo wave format.
Format22KhzMono16Bit | Retrieves whet,er the capture device supports capturing audio with the 22Khz, 16-bit, mono wave format.
Format22KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 22Khz, 8-bit, mono wave format.
Format22KhzStereo16Bit | Retrieves whether the capture device supports capturing audio with the 22Khz, 16-bit, stereo wave format.
Format22KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 22Khz, 8-bit, stereo wave format.
Format44KhzMono16Bit | Retrieves whether the capture device supports capturing audio with the 44Khz, 16-bit, mono wave format.
Format44KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 44Khz, 8-bit, mono wave format.
Format44KhzStereo16Bit | Retrieves whether the capture device supports capturing audio with the 44Khz, 16-bit, stereo wave format.
Format44KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 44Khz, 8-bit, stereo wave format.
Format48KhzMono16Bit | Retrieves whether the capture device supports capturing audio with the 48Khz, 16-bit, mono wave format.
Format48KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 48Khz, 8-bit, mono wave format.
Format48KhzStereo16Bit | Retrieves whether the capture device supports capturing audio with the 48Khz, 16-bit, stereo wave format.
Format48KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 48Khz, 8-bit, stereo wave format.
Format96KhzMono16Bit | Retrieves whether the capture device supports capturing audio with the 96Khz, 16-bit, mono wave format.
Format96KhzMono8Bit | Retrieves whether the capture device supports capturing audio with the 96Khz, 8-bit, mono wave format.
Format96KhzStereo16Bit | Retrieves whether the capture device supports capturing audio with the 96Khz, 16-bit, stereo wave format.
Format96KhzStereo8Bit | Retrieves whether the capture device supports capturing audio with the 96Khz, 8-bit, stereo wave format.
MultipleCapture | Retrieves whether multiple capture objects can be used simultaneously on the capture device.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Capture.Caps


CaptureCaps.CaptureCaps() Constructor (Microsoft.DirectX.DirectSound)

CaptureCaps.CaptureCaps Constructor

Initializes a new instance of the CaptureCaps structure.

Definition

Visual Basic | Public Sub New()
C# | public CaptureCaps();
C++ public:
CaptureCaps();
JScript | public function CaptureCaps();


CaptureCaps.ToString() Method (Microsoft.DirectX.DirectSound)

CaptureCaps.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CaptureCaps.Certified Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Certified Property

Retrieves whether the driver for the device is a certified Windows Driver Model (WDM) driver.

Definition

Visual Basic | Public ReadOnly Property Certified As Boolean
C# | public bool Certified { get; }
C++ public:
property bool Certified {
bool get();
}
JScript | public function get Certified() : boolean

Property Value

System.Boolean
Value that is set to true if the driver for the device is a certified WDM driver; otherwise, false.

This property is read-only.


CaptureCaps.Channels Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Channels Property

Retrieves the number of channels supported by the device.

Definition

Visual Basic | Public ReadOnly Property Channels As Integer
C# | public int Channels { get; }
C++ public:
property int Channels {
int get();
}
JScript | public function get Channels() : int

Property Value

System.Int32
The number of channels supported by the device.

This property is read-only.

Remarks

Mono is one channel, stereo is two channels, and so on.


CaptureCaps.EmulatedDriver Property (Microsoft.DirectX.DirectSound)

CaptureCaps.EmulatedDriver Property

Retrieves whether there is no Microsoft DirectSound capture driver for the device.

Definition

Visual Basic | Public ReadOnly Property EmulatedDriver As Boolean
C# | public bool EmulatedDriver { get; }
C++ public:
property bool EmulatedDriver {
bool get();
}
JScript | public function get EmulatedDriver() : boolean

Property Value

System.Boolean
Value that is set to true if there is no DirectSound Capture driver for the device; otherwise, false.

This property is read-only.

Remarks

If this property is true, the standard waveform audio functions are being used.


CaptureCaps.Format11KhzMono16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format11KhzMono16Bit Property

Retrieves whether the capture device supports capturing audio with the 11Khz, 16-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format11KhzMono16Bit As Boolean
C# | public bool Format11KhzMono16Bit { get; }
C++ public:
property bool Format11KhzMono16Bit {
bool get();
}
JScript | public function get Format11KhzMono16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 11Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format11KhzMono8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format11KhzMono8Bit Property

Retrieves whether the capture device supports capturing audio with the 11Khz, 8-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format11KhzMono8Bit As Boolean
C# | public bool Format11KhzMono8Bit { get; }
C++ public:
property bool Format11KhzMono8Bit {
bool get();
}
JScript | public function get Format11KhzMono8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 11Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format11KhzStereo16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format11KhzStereo16Bit Property

Retrieves whet,er the capture device supports capturing audio with the 11Khz, 16-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format11KhzStereo16Bit As Boolean
C# | public bool Format11KhzStereo16Bit { get; }
C++ public:
property bool Format11KhzStereo16Bit {
bool get();
}
JScript | public function get Format11KhzStereo16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 11Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format11KhzStereo8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format11KhzStereo8Bit Property

Retrieves whether the capture device supports capturing audio with the 11Khz, 8-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format11KhzStereo8Bit As Boolean
C# | public bool Format11KhzStereo8Bit { get; }
C++ public:
property bool Format11KhzStereo8Bit {
bool get();
}
JScript | public function get Format11KhzStereo8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 11Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format22KhzMono16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format22KhzMono16Bit Property

Retrieves whet,er the capture device supports capturing audio with the 22Khz, 16-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format22KhzMono16Bit As Boolean
C# | public bool Format22KhzMono16Bit { get; }
C++ public:
property bool Format22KhzMono16Bit {
bool get();
}
JScript | public function get Format22KhzMono16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 22Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format22KhzMono8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format22KhzMono8Bit Property

Retrieves whether the capture device supports capturing audio with the 22Khz, 8-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format22KhzMono8Bit As Boolean
C# | public bool Format22KhzMono8Bit { get; }
C++ public:
property bool Format22KhzMono8Bit {
bool get();
}
JScript | public function get Format22KhzMono8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 22Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format22KhzStereo16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format22KhzStereo16Bit Property

Retrieves whether the capture device supports capturing audio with the 22Khz, 16-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format22KhzStereo16Bit As Boolean
C# | public bool Format22KhzStereo16Bit { get; }
C++ public:
property bool Format22KhzStereo16Bit {
bool get();
}
JScript | public function get Format22KhzStereo16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 22Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format22KhzStereo8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format22KhzStereo8Bit Property

Retrieves whether the capture device supports capturing audio with the 22Khz, 8-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format22KhzStereo8Bit As Boolean
C# | public bool Format22KhzStereo8Bit { get; }
C++ public:
property bool Format22KhzStereo8Bit {
bool get();
}
JScript | public function get Format22KhzStereo8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 22Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format44KhzMono16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format44KhzMono16Bit Property

Retrieves whether the capture device supports capturing audio with the 44Khz, 16-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format44KhzMono16Bit As Boolean
C# | public bool Format44KhzMono16Bit { get; }
C++ public:
property bool Format44KhzMono16Bit {
bool get();
}
JScript | public function get Format44KhzMono16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 44Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format44KhzMono8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format44KhzMono8Bit Property

Retrieves whether the capture device supports capturing audio with the 44Khz, 8-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format44KhzMono8Bit As Boolean
C# | public bool Format44KhzMono8Bit { get; }
C++ public:
property bool Format44KhzMono8Bit {
bool get();
}
JScript | public function get Format44KhzMono8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 44Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format44KhzStereo16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format44KhzStereo16Bit Property

Retrieves whether the capture device supports capturing audio with the 44Khz, 16-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format44KhzStereo16Bit As Boolean
C# | public bool Format44KhzStereo16Bit { get; }
C++ public:
property bool Format44KhzStereo16Bit {
bool get();
}
JScript | public function get Format44KhzStereo16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 44Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format44KhzStereo8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format44KhzStereo8Bit Property

Retrieves whether the capture device supports capturing audio with the 44Khz, 8-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format44KhzStereo8Bit As Boolean
C# | public bool Format44KhzStereo8Bit { get; }
C++ public:
property bool Format44KhzStereo8Bit {
bool get();
}
JScript | public function get Format44KhzStereo8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 44Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format48KhzMono16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format48KhzMono16Bit Property

Retrieves whether the capture device supports capturing audio with the 48Khz, 16-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format48KhzMono16Bit As Boolean
C# | public bool Format48KhzMono16Bit { get; }
C++ public:
property bool Format48KhzMono16Bit {
bool get();
}
JScript | public function get Format48KhzMono16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 48Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format48KhzMono8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format48KhzMono8Bit Property

Retrieves whether the capture device supports capturing audio with the 48Khz, 8-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format48KhzMono8Bit As Boolean
C# | public bool Format48KhzMono8Bit { get; }
C++ public:
property bool Format48KhzMono8Bit {
bool get();
}
JScript | public function get Format48KhzMono8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 48Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format48KhzStereo16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format48KhzStereo16Bit Property

Retrieves whether the capture device supports capturing audio with the 48Khz, 16-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format48KhzStereo16Bit As Boolean
C# | public bool Format48KhzStereo16Bit { get; }
C++ public:
property bool Format48KhzStereo16Bit {
bool get();
}
JScript | public function get Format48KhzStereo16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 48Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format48KhzStereo8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format48KhzStereo8Bit Property

Retrieves whether the capture device supports capturing audio with the 48Khz, 8-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format48KhzStereo8Bit As Boolean
C# | public bool Format48KhzStereo8Bit { get; }
C++ public:
property bool Format48KhzStereo8Bit {
bool get();
}
JScript | public function get Format48KhzStereo8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 48Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format96KhzMono16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format96KhzMono16Bit Property

Retrieves whether the capture device supports capturing audio with the 96Khz, 16-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format96KhzMono16Bit As Boolean
C# | public bool Format96KhzMono16Bit { get; }
C++ public:
property bool Format96KhzMono16Bit {
bool get();
}
JScript | public function get Format96KhzMono16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 96Khz, 16-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format96KhzMono8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format96KhzMono8Bit Property

Retrieves whether the capture device supports capturing audio with the 96Khz, 8-bit, mono wave format.

Definition

Visual Basic | Public ReadOnly Property Format96KhzMono8Bit As Boolean
C# | public bool Format96KhzMono8Bit { get; }
C++ public:
property bool Format96KhzMono8Bit {
bool get();
}
JScript | public function get Format96KhzMono8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 96Khz, 8-bit, mono wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format96KhzStereo16Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format96KhzStereo16Bit Property

Retrieves whether the capture device supports capturing audio with the 96Khz, 16-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format96KhzStereo16Bit As Boolean
C# | public bool Format96KhzStereo16Bit { get; }
C++ public:
property bool Format96KhzStereo16Bit {
bool get();
}
JScript | public function get Format96KhzStereo16Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 96Khz, 16-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.Format96KhzStereo8Bit Property (Microsoft.DirectX.DirectSound)

CaptureCaps.Format96KhzStereo8Bit Property

Retrieves whether the capture device supports capturing audio with the 96Khz, 8-bit, stereo wave format.

Definition

Visual Basic | Public ReadOnly Property Format96KhzStereo8Bit As Boolean
C# | public bool Format96KhzStereo8Bit { get; }
C++ public:
property bool Format96KhzStereo8Bit {
bool get();
}
JScript | public function get Format96KhzStereo8Bit() : boolean

Property Value

System.Boolean
Value that is set to true if the capture device supports capturing audio with the 96Khz, 8-bit, stereo wave format; otherwise, false.

This property is read-only.


CaptureCaps.MultipleCapture Property (Microsoft.DirectX.DirectSound)

CaptureCaps.MultipleCapture Property

Retrieves whether multiple capture objects can be used simultaneously on the capture device.

Definition

Visual Basic | Public ReadOnly Property MultipleCapture As Boolean
C# | public bool MultipleCapture { get; }
C++ public:
property bool MultipleCapture {
bool get();
}
JScript | public function get MultipleCapture() : boolean

Property Value

System.Boolean
Value that is set to true if multiple capture objects can be used simultaneously on the capture device; otherwise, false.

This property is read-only.


CaptureEffectDescription Structure (Microsoft.DirectX.DirectSound)

CaptureEffectDescription Structure

Contains properties for an effect associated with a CaptureBuffer object.

Definition

Visual Basic | Public Structure CaptureEffectDescription
C# | public struct CaptureEffectDescription
C++ | public value class CaptureEffectDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureEffectDescription | Initializes a new instance of the CaptureEffectDescription structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
GuidEffectsClass | Retrieves and sets the class identifier of the capture effect.
GuidEffectsInstance | Retrieves and sets the unique identifier of the preferred capture effect.
LocateInHardware | Retrieves or sets whether the capture effect must be in hardware.
LocateInSoftware | Retrieves or sets whether the capture effect must be in software.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CaptureBuffer.GetObjectInPath


CaptureEffectDescription.CaptureEffectDescription() Constructor (Microsoft.DirectX.DirectSound)

CaptureEffectDescription.CaptureEffectDescription Constructor

 Language:

Initializes a new instance of the CaptureEffectDescription structure.

Definition

Visual Basic | Public Sub New()
C# | public CaptureEffectDescription();
C++ public:
CaptureEffectDescription();
JScript | public function CaptureEffectDescription();


CaptureEffectDescription.ToString() Method (Microsoft.DirectX.DirectSound)

CaptureEffectDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CaptureEffectDescription.GuidEffectsClass Property (Microsoft.DirectX.DirectSound)

CaptureEffectDescription.GuidEffectsClass Property

Retrieves and sets the class identifier of the capture effect.

Definition

Visual Basic | Public Property GuidEffectsClass As Guid
C# | public Guid GuidEffectsClass { get; set; }
C++ public:
property Guid GuidEffectsClass {
Guid get();
void set(Guid value);
}
JScript public function get GuidEffectsClass() : Guid
public function set GuidEffectsClass(Guid);

Property Value

System.Guid
The class identifier of the capture effect.

This property is read/write.

Remarks

When setting capture effects to a CaptureBuffer object, use the DSoundHelper class to get the globally unique identifier (GUID) for this property.


CaptureEffectDescription.GuidEffectsInstance Property (Microsoft.DirectX.DirectSound)

CaptureEffectDescription.GuidEffectsInstance Property

Retrieves and sets the unique identifier of the preferred capture effect.

Definition

Visual Basic | Public Property GuidEffectsInstance As Guid
C# | public Guid GuidEffectsInstance { get; set; }
C++ public:
property Guid GuidEffectsInstance {
Guid get();
void set(Guid value);
}
JScript public function get GuidEffectsInstance() : Guid
public function set GuidEffectsInstance(Guid);

Property Value

System.Guid
The unique identifier of the preferred capture effect.

This property is read/write.

Remarks

When setting capture effects to a CaptureBuffer object, use the DSoundHelper class to get the globally unique identifier (GUID) for this property.


CaptureEffectDescription.LocateInHardware Property (Microsoft.DirectX.DirectSound)

CaptureEffectDescription.LocateInHardware Property

Retrieves or sets whether the capture effect must be in hardware.

Definition

Visual Basic | Public Property LocateInHardware As Boolean
C# | public bool LocateInHardware { get; set; }
C++ public:
property bool LocateInHardware {
bool get();
void set(bool value);
}
JScript public function get LocateInHardware() : boolean
public function set LocateInHardware(boolean);

Property Value

System.Boolean
Value that is set to true if the capture effect must be in hardware; otherwise, false.

This property is read/write.

Remarks

Because Microsoft DirectX 9.0 does not support hardware acceleration of capture effects, this flag should not be used.


CaptureEffectDescription.LocateInSoftware Property (Microsoft.DirectX.DirectSound)

CaptureEffectDescription.LocateInSoftware Property

Retrieves or sets whether the capture effect must be in software.

Definition

Visual Basic | Public Property LocateInSoftware As Boolean
C# | public bool LocateInSoftware { get; set; }
C++ public:
property bool LocateInSoftware {
bool get();
void set(bool value);
}
JScript public function get LocateInSoftware() : boolean
public function set LocateInSoftware(boolean);

Property Value

System.Boolean
Value that is set to true if the capture effect must be in software; otherwise, false.

This property is read/write.

Remarks

In Microsoft DirectX 9.0, all capture effects are in software regardless of whether this flag is set.


CaptureEffectsAcousticEchoCancellation Structure (Microsoft.DirectX.DirectSound)

CaptureEffectsAcousticEchoCancellation Structure

Contains properties for acoustic echo cancellation in a capture buffer.

Definition

Visual Basic | Public Structure CaptureEffectsAcousticEchoCancellation
C# | public struct CaptureEffectsAcousticEchoCancellation
C++ | public value class CaptureEffectsAcousticEchoCancellation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureEffectsAcousticEchoCancellation | Initializes a new instance of the CaptureEffectsAcousticEchoCancellation structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Enable | Retrieves and sets whether the effect is enabled.
Mode | Retrieves and sets the operation mode of the effect.
NoiseFill | Retrieves and sets whether to enable background comfort noise for the effect.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CaptureAcousticEchoCancellationEffect.AllParameters


CaptureEffectsAcousticEchoCancellation.CaptureEffectsAcousticEchoCancellation() Constructor (Microsoft.DirectX.DirectSound)

CaptureEffectsAcousticEchoCancellation.CaptureEffectsAcousticEchoCancellation Constructor

 Language:

Initializes a new instance of the CaptureEffectsAcousticEchoCancellation structure.

Definition

Visual Basic | Public Sub New()
C# | public CaptureEffectsAcousticEchoCancellation();
C++ public:
CaptureEffectsAcousticEchoCancellation();
JScript | public function CaptureEffectsAcousticEchoCancellation();


CaptureEffectsAcousticEchoCancellation.ToString() Method (Microsoft.DirectX.DirectSound)

CaptureEffectsAcousticEchoCancellation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CaptureEffectsAcousticEchoCancellation.Enable Property (Microsoft.DirectX.DirectSound)

CaptureEffectsAcousticEchoCancellation.Enable Property

Retrieves and sets whether the effect is enabled.

Definition

Visual Basic | Public Property Enable As Boolean
C# | public bool Enable { get; set; }
C++ public:
property bool Enable {
bool get();
void set(bool value);
}
JScript public function get Enable() : boolean
public function set Enable(boolean);

Property Value

System.Boolean
Value that is set to true if the effect is enabled; otherwise, false.

This property is read/write.


CaptureEffectsAcousticEchoCancellation.Mode Property (Microsoft.DirectX.DirectSound)

CaptureEffectsAcousticEchoCancellation.Mode Property

Retrieves and sets the operation mode of the effect.

Definition

Visual Basic | Public Property Mode As OperationMode
C# | public OperationMode Mode { get; set; }
C++ public:
property OperationMode Mode {
OperationMode get();
void set(OperationMode value);
}
JScript public function get Mode() : OperationMode
public function set Mode(OperationMode);

Property Value

Microsoft.DirectX.DirectSound.OperationMode
The operation mode of the effect.

This property is read/write.


CaptureEffectsAcousticEchoCancellation.NoiseFill Property (Microsoft.DirectX.DirectSound)

CaptureEffectsAcousticEchoCancellation.NoiseFill Property

Retrieves and sets whether to enable background comfort noise for the effect.

Definition

Visual Basic | Public Property NoiseFill As Boolean
C# | public bool NoiseFill { get; set; }
C++ public:
property bool NoiseFill {
bool get();
void set(bool value);
}
JScript public function get NoiseFill() : boolean
public function set NoiseFill(boolean);

Property Value

System.Boolean
Value that is set to true if the effect enables background comfort noise; otherwise, false.

This property is read/write.

Remarks

Enabling background comfort noise for the effect makes the capture signal sound more natural by preventing periods of dead silence.

By default, background comfort noise is not enabled.


CaptureEffectsNoiseSuppress Structure (Microsoft.DirectX.DirectSound)

CaptureEffectsNoiseSuppress Structure

Contains parameters for noise suppression in a capture buffer.

Definition

Visual Basic | Public Structure CaptureEffectsNoiseSuppress
C# | public struct CaptureEffectsNoiseSuppress
C++ | public value class CaptureEffectsNoiseSuppress sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CaptureEffectsNoiseSuppress | Initializes a new instance of the CaptureEffectsNoiseSuppress structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Enable | Retrieves and sets whether the effect is enabled in the CaptureEffectsNoiseSuppress structure.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CaptureNoiseSuppressEffect.AllParameters


CaptureEffectsNoiseSuppress.CaptureEffectsNoiseSuppress() Constructor (Microsoft.DirectX.DirectSound)

CaptureEffectsNoiseSuppress.CaptureEffectsNoiseSuppress Constructor

 Language:

Initializes a new instance of the CaptureEffectsNoiseSuppress structure.

Definition

Visual Basic | Public Sub New()
C# | public CaptureEffectsNoiseSuppress();
C++ public:
CaptureEffectsNoiseSuppress();
JScript | public function CaptureEffectsNoiseSuppress();


CaptureEffectsNoiseSuppress.ToString() Method (Microsoft.DirectX.DirectSound)

CaptureEffectsNoiseSuppress.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


CaptureEffectsNoiseSuppress.Enable Property (Microsoft.DirectX.DirectSound)

CaptureEffectsNoiseSuppress.Enable Property

Retrieves and sets whether the effect is enabled in the CaptureEffectsNoiseSuppress structure.

Definition

Visual Basic | Public Property Enable As Boolean
C# | public bool Enable { get; set; }
C++ public:
property bool Enable {
bool get();
void set(bool value);
}
JScript public function get Enable() : boolean
public function set Enable(boolean);

Property Value

System.Boolean
Specifies whether the effect is enabled.

This property is read/write.


DeviceInformation Structure (Microsoft.DirectX.DirectSound)

DeviceInformation Structure

Contains properties that describe information about a device.

Definition

Visual Basic | Public Structure DeviceInformation
C# | public struct DeviceInformation
C++ | public value class DeviceInformation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
DeviceInformation | Initializes a new instance of the DeviceInformation structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Description | Retrieves a textual description of the DirectSound device.
DriverGuid | Retrieves the globally unique identifier (GUID) of a DirectSound driver.
ModuleName | Retrieves the module name of the Microsoft DirectSound driver corresponding to this device.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • CapturedevicesCollection.Reset
  • CapturedevicesCollection.Count
  • CapturedevicesCollection.Current
  • CapturedevicesCollection.Item
  • CapturedevicesCollection
  • CapturedevicesCollection.MoveNext
  • Device constructor
  • DeviceCollection
  • DeviceCollection.Count
  • DeviceCollection.Current
  • DeviceCollection.Item
  • DeviceCollection.MoveNext
  • DeviceCollection.Reset


DeviceInformation.DeviceInformation() Constructor (Microsoft.DirectX.DirectSound)

DeviceInformation.DeviceInformation Constructor

Initializes a new instance of the DeviceInformation structure.

Definition

Visual Basic | Public Sub New()
C# | public DeviceInformation();
C++ public:
DeviceInformation();
JScript | public function DeviceInformation();


DeviceInformation.ToString() Method (Microsoft.DirectX.DirectSound)

DeviceInformation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


DeviceInformation.Description Property (Microsoft.DirectX.DirectSound)

DeviceInformation.Description Property

Retrieves a textual description of the Microsoft DirectSound device.

Definition

Visual Basic | Public ReadOnly Property Description As String
C# | public string Description { get; }
C++ public:
property String^ Description {
String^ get();
}
JScript | public function get Description() : String

Property Value

System.String
A textual description of the DirectSound device.

This property is read-only.


DeviceInformation.DriverGuid Property (Microsoft.DirectX.DirectSound)

DeviceInformation.DriverGuid Property

Retrieves the globally unique identifier (GUID) of a Microsoft DirectSound driver.

Definition

Visual Basic | Public ReadOnly Property DriverGuid As Guid
C# | public Guid DriverGuid { get; }
C++ public:
property Guid DriverGuid {
Guid get();
}
JScript | public function get DriverGuid() : Guid

Property Value

System.Guid
The GUID of a DirectSound driver.

This property is read-only.

Remarks

The primary device can have more than one GUID. The first is always null. This null GUID is used when the device is used as the primary device. Its actual GUID is used when it is used by its actual device identifier.


DeviceInformation.ModuleName Property (Microsoft.DirectX.DirectSound)

DeviceInformation.ModuleName Property

Retrieves the module name of the Microsoft DirectSound driver corresponding to this device.

Definition

Visual Basic | Public ReadOnly Property ModuleName As String
C# | public string ModuleName { get; }
C++ public:
property String^ ModuleName {
String^ get();
}
JScript | public function get ModuleName() : String

Property Value

System.String
The module name of the DirectSound driver corresponding to this device.

This property is read-only.


EffectDescription Structure (Microsoft.DirectX.DirectSound)

EffectDescription Structure

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Contains properties that describe an effect associated with a buffer.

Definition

Visual Basic | Public Structure EffectDescription
C# | public struct EffectDescription
C++ | public value class EffectDescription sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectDescription | Initializes a new instance of the EffectDescription structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
GuidEffectClass | Retrieves and sets the class identifier of the effect.
LocateInHardware | Retrieves or sets whether the effect must be in hardware.
LocateInSoftware | Retrieves or sets whether the effect must be in software.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Secondarybuffer.SetEffects


EffectDescription.EffectDescription() Constructor (Microsoft.DirectX.DirectSound)

EffectDescription.EffectDescription Constructor

Initializes a new instance of the EffectDescription structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectDescription();
C++ public:
EffectDescription();
JScript | public function EffectDescription();


EffectDescription.ToString() Method (Microsoft.DirectX.DirectSound)

EffectDescription.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectDescription.GuidEffectClass Property (Microsoft.DirectX.DirectSound)

EffectDescription.GuidEffectClass Property

How Do I...?
  • Add Effects to a SecondaryBuffer Object

Retrieves and sets the class identifier of the effect.

Definition

Visual Basic | Public Property GuidEffectClass As Guid
C# | public Guid GuidEffectClass { get; set; }
C++ public:
property Guid GuidEffectClass {
Guid get();
void set(Guid value);
}
JScript public function get GuidEffectClass() : Guid
public function set GuidEffectClass(Guid);

Property Value

System.Guid
The class identifier of the effect.

This property is read/write.

Remarks

When setting effects to a sound buffer, use the DSoundHelper class to get the globally unique identifier (GUID) for this property.

How Do I...?

Add Effects to a SecondaryBuffer Object

This C# example demonstrates how to add effect objects to a SecondaryBuffer object.

              [C#]

//Create and setup the sound device.
Device dev = new Device();
dev.SetCooperativeLevel(this,CooperativeLevel.Normal);

//Create and setup the buffer description.
BufferDescription buffer_desc = new BufferDescription();
buffer_desc.ControlEffects = true; //this has to be true to use effects.
buffer_desc.GlobalFocus = true; //play sound even if application loses focus.

//Create and setup the buffer for playing the sound.
SecondaryBuffer buffer = new SecondaryBuffer(
    @"C:\WINDOWS\Media\ding.wav",
    buffer_desc,
    dev);

//Create an array of effects descriptions,
//set the effect objects to echo and chorus and
//set it in the buffer.
EffectDescription[] effects = new EffectDescription[2];
effects[0].GuidEffectClass = DSoundHelper.StandardEchoGuid;
effects[1].GuidEffectClass = DSoundHelper.StandardChorusGuid;
buffer.SetEffects(effects);

//Play Buffer.
buffer.Play(0,BufferPlayFlags.Default);


EffectDescription.LocateInHardware Property (Microsoft.DirectX.DirectSound)

EffectDescription.LocateInHardware Property

Retrieves or sets whether the effect must be in hardware.

Definition

Visual Basic | Public Property LocateInHardware As Boolean
C# | public bool LocateInHardware { get; set; }
C++ public:
property bool LocateInHardware {
bool get();
void set(bool value);
}
JScript public function get LocateInHardware() : boolean
public function set LocateInHardware(boolean);

Property Value

System.Boolean
Value that is set to true if the effect must be in hardware; otherwise, false.

This property is read/write.

Remarks

Because Microsoft DirectX 9.0 does not support hardware acceleration of effects, this flag should not be used.


EffectDescription.LocateInSoftware Property (Microsoft.DirectX.DirectSound)

EffectDescription.LocateInSoftware Property

Retrieves or sets whether the effect must be in software.

Definition

Visual Basic | Public Property LocateInSoftware As Boolean
C# | public bool LocateInSoftware { get; set; }
C++ public:
property bool LocateInSoftware {
bool get();
void set(bool value);
}
JScript public function get LocateInSoftware() : boolean
public function set LocateInSoftware(boolean);

Property Value

System.Boolean
Value that is set to true if the effect must be in software; otherwise, false.

This property is read/write.

Remarks

In Microsoft DirectX 9.0, all effects are in software regardless of whether this flag is set.


EffectsChorus Structure (Microsoft.DirectX.DirectSound)

EffectsChorus Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for a chorus effect.

Definition

Visual Basic | Public Structure EffectsChorus
C# | public struct EffectsChorus
C++ | public value class EffectsChorus sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsChorus | Initializes a new instance of the EffectsChorus structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Delay | Retrieves and sets the number of milliseconds the input is delayed before it is played back, in the EffectsChorus structure.
Depth | Retrieves and sets the percentage by which the delay time is modulated by the low-frequency oscillator, in hundredths of a percentage point, in the EffectsChorus structure.
Feedback | Retrieves and sets the percentage of output signal to feed back into the effect's input, in the EffectsChorus structure.
Frequency | Retrieves and sets the frequency of the LFO, in the EffectsChorus structure.
Phase | Retrieves and sets the phase differential between left and right LFOs, in the EffectsChorus structure.
Waveform | Retrieves and sets the waveform shape of the LFO, in the EffectsChorus structure.
WetDryMix | Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal, in the EffectsChorus structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • ChorusEffect.AllParameters


EffectsChorus.EffectsChorus() Constructor (Microsoft.DirectX.DirectSound)

EffectsChorus.EffectsChorus Constructor

How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsChorus structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsChorus();
C++ public:
EffectsChorus();
JScript | public function EffectsChorus();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsChorus.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectsChorus.Delay Property (Microsoft.DirectX.DirectSound)

EffectsChorus.Delay Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the number of milliseconds the input is delayed before it is played back, in the EffectsChorus structure.

Definition

Visual Basic | Public Property Delay As Single
C# | public float Delay { get; set; }
C++ public:
property float Delay {
float get();
void set(float value);
}
JScript public function get Delay() : float
public function set Delay(float);

Property Value

System.Single
Number of milliseconds the input is delayed before it is played back.

This property is read/write.

Remarks

Can range from ChorusEffect.DelayMin to ChorusEffect.DelayMax.

The default value is 16 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Depth Property (Microsoft.DirectX.DirectSound)

EffectsChorus.Depth Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage by which the delay time is modulated by the low-frequency oscillator, in hundredths of a percentage point, in the EffectsChorus structure.

Definition

Visual Basic | Public Property Depth As Single
C# | public float Depth { get; set; }
C++ public:
property float Depth {
float get();
void set(float value);
}
JScript public function get Depth() : float
public function set Depth(float);

Property Value

System.Single
Percentage by which the delay time is modulated by the low-frequency oscillator, in hundredths of a percentage point.

This property is read/write.

Remarks

Can range from ChorusEffect.DepthMin to ChorusEffect.DepthMax.

The default value is 10.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Feedback Property (Microsoft.DirectX.DirectSound)

EffectsChorus.Feedback Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage of output signal to feed back into the effect's input, in the EffectsChorus structure.

Definition

Visual Basic | Public Property Feedback As Single
C# | public float Feedback { get; set; }
C++ public:
property float Feedback {
float get();
void set(float value);
}
JScript public function get Feedback() : float
public function set Feedback(float);

Property Value

System.Single
Percentage of output signal to feed back into the effect's input.

This property is read/write.

Remarks

Can range from ChorusEffect.FeedbackMin to ChorusEffect.FeedbackMax.

The default value is 25.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Frequency Property (Microsoft.DirectX.DirectSound)

EffectsChorus.Frequency Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the frequency of the LFO, in the EffectsChorus structure.

Definition

Visual Basic | Public Property Frequency As Single
C# | public float Frequency { get; set; }
C++ public:
property float Frequency {
float get();
void set(float value);
}
JScript public function get Frequency() : float
public function set Frequency(float);

Property Value

System.Single
Frequency of the LFO.

This property is read/write.

Remarks

Can range from ChorusEffect.FrequencyMin to ChorusEffect.FrequencyMax.

The default value is 1.1.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Phase Property (Microsoft.DirectX.DirectSound)

EffectsChorus.Phase Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the phase differential between left and right LFOs, in the EffectsChorus structure.

Definition

Visual Basic | Public Property Phase As Integer
C# | public int Phase { get; set; }
C++ public:
property int Phase {
int get();
void set(int value);
}
JScript public function get Phase() : int
public function set Phase(int);

Property Value

System.Int32
Phase differential between left and right LFOs.

This property is read/write.

Remarks

Can range from ChorusEffect.PhaseMin to ChorusEffect.PhaseMax.

Can be set by the one values below:

  • ChorusEffect.PhaseZero
  • ChorusEffect.Phase90
  • ChorusEffect.PhaseNegative90
  • ChorusEffect.Phase180
  • ChorusEffect.PhaseNegative180

The default value is ChorusEffect.Phase90.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.Waveform Property (Microsoft.DirectX.DirectSound)

EffectsChorus.Waveform Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the waveform shape of the LFO, in the EffectsChorus structure.

Definition

Visual Basic | Public Property Waveform As Integer
C# | public int Waveform { get; set; }
C++ public:
property int Waveform {
int get();
void set(int value);
}
JScript public function get Waveform() : int
public function set Waveform(int);

Property Value

System.Int32
Waveform shape of the LFO.

This property is read/write.

Remarks

Can be set by the one values below:

  • ChorusEffect.WaveSin
  • ChorusEffect.WaveTrianlge

The default value is ChorusEffect.WaveSin.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsChorus.WetDryMix Property (Microsoft.DirectX.DirectSound)

EffectsChorus.WetDryMix Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal, in the EffectsChorus structure.

Definition

Visual Basic | Public Property WetDryMix As Single
C# | public float WetDryMix { get; set; }
C++ public:
property float WetDryMix {
float get();
void set(float value);
}
JScript public function get WetDryMix() : float
public function set WetDryMix(float);

Property Value

System.Single
Ratio of wet (processed) signal to dry (unprocessed) signal.

This property is read/write.

Remarks

Can range from ChorusEffect.WetDryMixMin to ChorusEffect.WetDryMixMax.

The default value is 50.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor Structure (Microsoft.DirectX.DirectSound)

EffectsCompressor Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for a compressor effect.

Definition

Visual Basic | Public Structure EffectsCompressor
C# | public struct EffectsCompressor
C++ | public value class EffectsCompressor sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsCompressor | Initializes a new instance of the EffectsCompressor structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Attack | Retrieves and sets the time before compression reaches its full value, in the EffectsCompressor structure.
Gain | Retrieves and sets the output gain of signal after compression, in the EffectsCompressor structure.
Predelay | Retrieves and sets the time after Threshold is reached before attack phase is started, in milliseconds, in the EffectsCompressor structure.
Ratio | Retrieves and sets the compression ratio, in the EffectsCompressor structure.
Release | Retrieves and sets the speed at which compression is stopped after input drops below Threshold, in the EffectsCompressor structure.
Threshold | Retrieves and sets the point at which compression begins, in the EffectsCompressor structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • ChorusEffect.AllParameters


EffectsCompressor.EffectsCompressor() Constructor (Microsoft.DirectX.DirectSound)

EffectsCompressor.EffectsCompressor Constructor

How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsCompressor structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsCompressor();
C++ public:
EffectsCompressor();
JScript | public function EffectsCompressor();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsCompressor.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectsCompressor.Attack Property (Microsoft.DirectX.DirectSound)

EffectsCompressor.Attack Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the time before compression reaches its full value, in the EffectsCompressor structure.

Definition

Visual Basic | Public Property Attack As Single
C# | public float Attack { get; set; }
C++ public:
property float Attack {
float get();
void set(float value);
}
JScript public function get Attack() : float
public function set Attack(float);

Property Value

System.Single
Time before compression reaches its full value.

This property is read/write.

Remarks

Can range from CompressorEffect.AttackMin to CompressorEffect.AttackMax.

The default value is 10 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Gain Property (Microsoft.DirectX.DirectSound)

EffectsCompressor.Gain Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the output gain of signal after compression, in the EffectsCompressor structure.

Definition

Visual Basic | Public Property Gain As Single
C# | public float Gain { get; set; }
C++ public:
property float Gain {
float get();
void set(float value);
}
JScript public function get Gain() : float
public function set Gain(float);

Property Value

System.Single
Output gain of signal after compression.

This property is read/write.

Remarks

Can range from CompressorEffect.GainMin to CompressorEffect.GainMax.

The default value is 0 dB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Predelay Property (Microsoft.DirectX.DirectSound)

EffectsCompressor.Predelay Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the time after Threshold is reached before attack phase is started, in milliseconds, in the EffectsCompressor structure.

Definition

Visual Basic | Public Property Predelay As Single
C# | public float Predelay { get; set; }
C++ public:
property float Predelay {
float get();
void set(float value);
}
JScript public function get Predelay() : float
public function set Predelay(float);

Property Value

System.Single
Time after Threshold is reached before attack phase is started, in milliseconds.

This property is read/write.

Remarks

Can range from CompressorEffect.PredelayMin to CompressorEffect.PredelayMax.

The default value is 4 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Ratio Property (Microsoft.DirectX.DirectSound)

EffectsCompressor.Ratio Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the compression ratio, in the EffectsCompressor structure.

Definition

Visual Basic | Public Property Ratio As Single
C# | public float Ratio { get; set; }
C++ public:
property float Ratio {
float get();
void set(float value);
}
JScript public function get Ratio() : float
public function set Ratio(float);

Property Value

System.Single
Compression ratio.

This property is read/write.

Remarks

Can range from CompressorEffect.RatioMin to CompressorEffect.RatioMax.

The default value is 3, which means 3:1 compression.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Release Property (Microsoft.DirectX.DirectSound)

EffectsCompressor.Release Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the speed at which compression is stopped after input drops below Threshold, in the EffectsCompressor structure.

Definition

Visual Basic | Public Property Release As Single
C# | public float Release { get; set; }
C++ public:
property float Release {
float get();
void set(float value);
}
JScript public function get Release() : float
public function set Release(float);

Property Value

System.Single
Speed at which compression is stopped after input drops below Threshold.

This property is read/write.

Remarks

Can range from CompressorEffect.ReleaseMin to CompressorEffect.ReleaseMax.

The default value is 200 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsCompressor.Threshold Property (Microsoft.DirectX.DirectSound)

EffectsCompressor.Threshold Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the point at which compression begins, in the EffectsCompressor structure.

Definition

Visual Basic | Public Property Threshold As Single
C# | public float Threshold { get; set; }
C++ public:
property float Threshold {
float get();
void set(float value);
}
JScript public function get Threshold() : float
public function set Threshold(float);

Property Value

System.Single
Point at which compression begins.

This property is read/write.

Remarks

Can range from CompressorEffect.ThresholdMin to CompressorEffect.ThresholdMax.

The default value is -20 dB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion Structure (Microsoft.DirectX.DirectSound)

EffectsDistortion Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for a distortion effect.

Definition

Visual Basic | Public Structure EffectsDistortion
C# | public struct EffectsDistortion
C++ | public value class EffectsDistortion sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsDistortion | Initializes a new instance of the EffectsDistortion structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Edge | Retrieves and sets the percentage of distortion intensity, in the EffectsDistortion structure.
Gain | Retrieves and sets the amount of signal change after distortion, in the EffectsDistortion structure.
PostEqBandwidth | Retrieves and sets the width of frequency band that determines range of harmonic content addition, in the EffectsDistortion structure.
PostEqCenterFrequency | Retrieves and sets the center frequency of harmonic content addition, in the EffectsDistortion structure.
PreLowpassCutoff | Retrieves and sets the filter cutoff for high-frequency harmonics attenuation, in the EffectsDistortion structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • DistortionEffect.AllParameters


EffectsDistortion.EffectsDistortion() Constructor (Microsoft.DirectX.DirectSound)

EffectsDistortion.EffectsDistortion Constructor

How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsDistortion structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsDistortion();
C++ public:
EffectsDistortion();
JScript | public function EffectsDistortion();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsDistortion.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectsDistortion.Edge Property (Microsoft.DirectX.DirectSound)

EffectsDistortion.Edge Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage of distortion intensity, in the EffectsDistortion structure.

Definition

Visual Basic | Public Property Edge As Single
C# | public float Edge { get; set; }
C++ public:
property float Edge {
float get();
void set(float value);
}
JScript public function get Edge() : float
public function set Edge(float);

Property Value

System.Single
Percentage of distortion intensity.

This property is read/write.

Remarks

Can range from DistortionEffect.EdgeMin to DistortionEffect.EdgeMax.

The default value is 15.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.Gain Property (Microsoft.DirectX.DirectSound)

EffectsDistortion.Gain Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the amount of signal change after distortion, in the EffectsDistortion structure.

Definition

Visual Basic | Public Property Gain As Single
C# | public float Gain { get; set; }
C++ public:
property float Gain {
float get();
void set(float value);
}
JScript public function get Gain() : float
public function set Gain(float);

Property Value

System.Single
Amount of signal change after distortion.

This property is read/write.

Remarks

Can range from DistortionEffect.GainMin to DistortionEffect.GainMax.

The default value is -18 dB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.PostEqBandwidth Property (Microsoft.DirectX.DirectSound)

EffectsDistortion.PostEqBandwidth Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the width of frequency band that determines range of harmonic content addition, in the EffectsDistortion structure.

Definition

Visual Basic | Public Property PostEqBandwidth As Single
C# | public float PostEqBandwidth { get; set; }
C++ public:
property float PostEqBandwidth {
float get();
void set(float value);
}
JScript public function get PostEqBandwidth() : float
public function set PostEqBandwidth(float);

Property Value

System.Single
Width of frequency band that determines range of harmonic content addition.

This property is read/write.

Remarks

Can range from DistortionEffect.PostEqBandwidthMin to DistortionEffect.PostEqBandwidthMax.

The default value is 2400Hz.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.PostEqCenterFrequency Property (Microsoft.DirectX.DirectSound)

EffectsDistortion.PostEqCenterFrequency Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the center frequency of harmonic content addition, in the EffectsDistortion structure.

Definition

Visual Basic | Public Property PostEqCenterFrequency As Single
C# | public float PostEqCenterFrequency { get; set; }
C++ public:
property float PostEqCenterFrequency {
float get();
void set(float value);
}
JScript public function get PostEqCenterFrequency() : float
public function set PostEqCenterFrequency(float);

Property Value

System.Single
Center frequency of harmonic content addition.

This property is read/write.

Remarks

Can range from DistortionEffect.PostEqCenterFrequencyMin to DistortionEffect.PostEqCenterFrequency.

The default value is 2400 Hz.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsDistortion.PreLowpassCutoff Property (Microsoft.DirectX.DirectSound)

EffectsDistortion.PreLowpassCutoff Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the filter cutoff for high-frequency harmonics attenuation, in the EffectsDistortion structure.

Definition

Visual Basic | Public Property PreLowpassCutoff As Single
C# | public float PreLowpassCutoff { get; set; }
C++ public:
property float PreLowpassCutoff {
float get();
void set(float value);
}
JScript public function get PreLowpassCutoff() : float
public function set PreLowpassCutoff(float);

Property Value

System.Single
Filter cutoff for high-frequency harmonics attenuation.

This property is read/write.

Remarks

Can range from DistortionEffect.PreLowpassCutoffMin to DistortionEffect.PreLowpassCutoffMax.

The default value is 15.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho Structure (Microsoft.DirectX.DirectSound)

EffectsEcho Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for an echo effect.

Definition

Visual Basic | Public Structure EffectsEcho
C# | public struct EffectsEcho
C++ | public value class EffectsEcho sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsEcho | Initializes a new instance of the EffectsEcho structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Feedback | Retrieves and sets the percentage of output fed back into input, in the EffectsEcho structure.
LeftDelay | Retrieves and sets the delay for left channel, in milliseconds, in the EffectsEcho structure.
PanDelay | Retrieves and sets the value that specifies whether to swap left and right delays with each successive echo, in the EffectsEcho structure.
RightDelay | Retrieves and sets the delay for right channel, in milliseconds, in the EffectsEcho structure.
WetDryMix | Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal in the EffectsEcho structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • EchoEffect.AllParameters


EffectsEcho.EffectsEcho() Constructor (Microsoft.DirectX.DirectSound)

EffectsEcho.EffectsEcho Constructor

How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsEcho structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsEcho();
C++ public:
EffectsEcho();
JScript | public function EffectsEcho();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsEcho.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectsEcho.Feedback Property (Microsoft.DirectX.DirectSound)

EffectsEcho.Feedback Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage of output fed back into input, in the EffectsEcho structure.

Definition

Visual Basic | Public Property Feedback As Single
C# | public float Feedback { get; set; }
C++ public:
property float Feedback {
float get();
void set(float value);
}
JScript public function get Feedback() : float
public function set Feedback(float);

Property Value

System.Single
Percentage of output fed back into input.

This property is read/write.

Remarks

Can range from EchoEffect.FeedbackMin to EchoEffect.FeedbackMax.

The default value is 50.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.LeftDelay Property (Microsoft.DirectX.DirectSound)

EffectsEcho.LeftDelay Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the delay for left channel, in milliseconds, in the EffectsEcho structure.

Definition

Visual Basic | Public Property LeftDelay As Single
C# | public float LeftDelay { get; set; }
C++ public:
property float LeftDelay {
float get();
void set(float value);
}
JScript public function get LeftDelay() : float
public function set LeftDelay(float);

Property Value

System.Single
Delay for left channel, in milliseconds.

This property is read/write.

Remarks

Can range from EchoEffect.LefttDelayMin to EchoEffect.LeftDelayMax.

The default value is 500 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.PanDelay Property (Microsoft.DirectX.DirectSound)

EffectsEcho.PanDelay Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the value that specifies whether to swap left and right delays with each successive echo, in the EffectsEcho structure.

Definition

Visual Basic | Public Property PanDelay As Integer
C# | public int PanDelay { get; set; }
C++ public:
property int PanDelay {
int get();
void set(int value);
}
JScript public function get PanDelay() : int
public function set PanDelay(int);

Property Value

System.Int32
Value that specifies whether to swap left and right delays with each successive echo.

This property is read/write.

Remarks

Can range from EchoEffect.PanDelayMin to EchoEffect.PanDelayMax.

The default value is zero, meaning no swap.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.RightDelay Property (Microsoft.DirectX.DirectSound)

EffectsEcho.RightDelay Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the delay for right channel, in milliseconds, in the EffectsEcho structure.

Definition

Visual Basic | Public Property RightDelay As Single
C# | public float RightDelay { get; set; }
C++ public:
property float RightDelay {
float get();
void set(float value);
}
JScript public function get RightDelay() : float
public function set RightDelay(float);

Property Value

System.Single
Delay for right channel, in milliseconds.

This property is read/write.

Remarks

Can range from EchoEffect.RightDelayMin to EchoEffect.RightDelayMax.

The default value is 500 ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsEcho.WetDryMix Property (Microsoft.DirectX.DirectSound)

EffectsEcho.WetDryMix Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal in the EffectsEcho structure.

Definition

Visual Basic | Public Property WetDryMix As Single
C# | public float WetDryMix { get; set; }
C++ public:
property float WetDryMix {
float get();
void set(float value);
}
JScript public function get WetDryMix() : float
public function set WetDryMix(float);

Property Value

System.Single
Ratio of wet (processed) signal to dry (unprocessed) signal.

This property is read/write.

Remarks

Can range from EchoEffect.WetDryMixMin to EchoEffect.WetDryMixMax.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger Structure (Microsoft.DirectX.DirectSound)

EffectsFlanger Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for a flange effect.

Definition

Visual Basic | Public Structure EffectsFlanger
C# | public struct EffectsFlanger
C++ | public value class EffectsFlanger sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsFlanger | Initializes a new instance of the EffectsFlanger structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Delay | Retrieves and sets the number of milliseconds the input is delayed before it is played back in the EffectsFlanger structure.
Depth | Retrieves and sets the percentage by which the delay time is modulated by the low-frequency oscillator (LFO), in hundredths of a percentage point in the EffectsFlanger structure.
Feedback | Retrieves and sets the percentage of output signal to feed back into the effect's input in the EffectsFlanger structure.
Frequency | Retrieves and sets the frequency of the LFO in the EffectsFlanger structure.
Phase | Retrieves and sets the phase differential between left and right LFOs in the EffectsFlanger structure.
Waveform | Retrieves and sets the waveform shape of the LFO in the EffectsFlanger structure.
WetDryMix | Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal of the EffectsFlanger structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • FlangerEffect.AllParameters


EffectsFlanger.EffectsFlanger() Constructor (Microsoft.DirectX.DirectSound)

EffectsFlanger.EffectsFlanger Constructor

How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsFlanger structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsFlanger();
C++ public:
EffectsFlanger();
JScript | public function EffectsFlanger();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsFlanger.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectsFlanger.Delay Property (Microsoft.DirectX.DirectSound)

EffectsFlanger.Delay Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the number of milliseconds the input is delayed before it is played back in the EffectsFlanger structure.

Definition

Visual Basic | Public Property Delay As Single
C# | public float Delay { get; set; }
C++ public:
property float Delay {
float get();
void set(float value);
}
JScript public function get Delay() : float
public function set Delay(float);

Property Value

System.Single
Number of milliseconds the input is delayed before it is played back.

This property is read/write.

Remarks

Can range from FlangerEffect.DelayMin to FlangerEffect.DelayMax.

The default value is 2ms.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Depth Property (Microsoft.DirectX.DirectSound)

EffectsFlanger.Depth Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage by which the delay time is modulated by the low-frequency oscillator (LFO), in hundredths of a percentage point in the EffectsFlanger structure.

Definition

Visual Basic | Public Property Depth As Single
C# | public float Depth { get; set; }
C++ public:
property float Depth {
float get();
void set(float value);
}
JScript public function get Depth() : float
public function set Depth(float);

Property Value

System.Single
Percentage by which the delay time is modulated by the low-frequency oscillator (LFO), in hundredths of a percentage point.

This property is read/write.

Remarks

Can range from FlangerEffect.DepthMin to FlangerEffect.DepthMax.

The default value is 100.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Feedback Property (Microsoft.DirectX.DirectSound)

EffectsFlanger.Feedback Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the percentage of output signal to feed back into the effect's input in the EffectsFlanger structure.

Definition

Visual Basic | Public Property Feedback As Single
C# | public float Feedback { get; set; }
C++ public:
property float Feedback {
float get();
void set(float value);
}
JScript public function get Feedback() : float
public function set Feedback(float);

Property Value

System.Single
Percentage of output signal to feed back into the effect's input.

This property is read/write.

Remarks

Can range from FlangerEffect.FeedbackMin to FlangerEffect.FeedbackMax.

The default value is -50.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Frequency Property (Microsoft.DirectX.DirectSound)

EffectsFlanger.Frequency Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the frequency of the LFO in the EffectsFlanger structure.

Definition

Visual Basic | Public Property Frequency As Single
C# | public float Frequency { get; set; }
C++ public:
property float Frequency {
float get();
void set(float value);
}
JScript public function get Frequency() : float
public function set Frequency(float);

Property Value

System.Single
Frequency of the LFO.

This property is read/write.

Remarks

Can range from FlangerEffect.FrequencyMin to FlangerEffect.FrequencyMax.

The default value is 0.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Phase Property (Microsoft.DirectX.DirectSound)

EffectsFlanger.Phase Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the phase differential between left and right LFOs in the EffectsFlanger structure.

Definition

Visual Basic | Public Property Phase As Integer
C# | public int Phase { get; set; }
C++ public:
property int Phase {
int get();
void set(int value);
}
JScript public function get Phase() : int
public function set Phase(int);

Property Value

System.Int32
Phase differential between left and right LFOs.

This property is read/write.

Remarks

Can be set to on of the following:

  • FlangerEffect.PhaseNeg180
  • FlangerEffect.PhaseNeg90
  • FlangerEffect.PhaseZero
  • FlangerEffect.Phase90
  • FlangerEffect.Phase180

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.Waveform Property (Microsoft.DirectX.DirectSound)

EffectsFlanger.Waveform Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the waveform shape of the LFO in the EffectsFlanger structure.

Definition

Visual Basic | Public Property Waveform As Integer
C# | public int Waveform { get; set; }
C++ public:
property int Waveform {
int get();
void set(int value);
}
JScript public function get Waveform() : int
public function set Waveform(int);

Property Value

System.Int32
Waveform shape of the LFO.

This property is read/write.

Remarks

Can be set to on of the following:

  • FlangerEffect.WaveSine (default)
  • FlangerEffect.WaveTriangle

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsFlanger.WetDryMix Property (Microsoft.DirectX.DirectSound)

EffectsFlanger.WetDryMix Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the ratio of wet (processed) signal to dry (unprocessed) signal of the EffectsFlanger structure.

Definition

Visual Basic | Public Property WetDryMix As Single
C# | public float WetDryMix { get; set; }
C++ public:
property float WetDryMix {
float get();
void set(float value);
}
JScript public function get WetDryMix() : float
public function set WetDryMix(float);

Property Value

System.Single
Ratio of wet (processed) signal to dry (unprocessed) signal.

This property is read/write.

Remarks

Can range from FlangerEffect.WetDryMixMin to FlangerEffect.WetDryMixMax.

The default value is 50.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsGargle Structure (Microsoft.DirectX.DirectSound)

EffectsGargle Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for an amplitude modulation effect.

Definition

Visual Basic | Public Structure EffectsGargle
C# | public struct EffectsGargle
C++ | public value class EffectsGargle sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsGargle | Initializes a new instance of the EffectsGargle structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
RateHz | Retrieves and sets the rate of modulation, in Hertz, of the EffectsGargle structure.
WaveShape | Retrieves and sets the shape of the modulation waveform of the EffectsGargle structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • GargleEffect.AllParameters


EffectsGargle.EffectsGargle() Constructor (Microsoft.DirectX.DirectSound)

EffectsGargle.EffectsGargle Constructor

How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsGargle structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsGargle();
C++ public:
EffectsGargle();
JScript | public function EffectsGargle();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsGargle.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsGargle.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectsGargle.RateHz Property (Microsoft.DirectX.DirectSound)

EffectsGargle.RateHz Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the rate of modulation, in Hertz, of the EffectsGargle structure.

Definition

Visual Basic | Public Property RateHz As Integer
C# | public int RateHz { get; set; }
C++ public:
property int RateHz {
int get();
void set(int value);
}
JScript public function get RateHz() : int
public function set RateHz(int);

Property Value

System.Int32
Rate of modulation, in Hertz.

This property is read/write.

Remarks

Can range from GargleEffect.RateHzMin to GargleEffect.RateHzMax.

The default value is 20.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsGargle.WaveShape Property (Microsoft.DirectX.DirectSound)

EffectsGargle.WaveShape Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the shape of the modulation waveform of the EffectsGargle structure.

Definition

Visual Basic | Public Property WaveShape As Integer
C# | public int WaveShape { get; set; }
C++ public:
property int WaveShape {
int get();
void set(int value);
}
JScript public function get WaveShape() : int
public function set WaveShape(int);

Property Value

System.Int32
Shape of the modulation waveform.

This property is read/write.

Remarks

Can be set to one of the following:

  • GargleEffect.WaveTriangle (default)
  • GargleEffect.WaveSquare

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb Structure (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for an I3DL2 (Interactive 3D Audio Level 2) reverberation effect.

Definition

Visual Basic | Public Structure EffectsInteractive3DLevel2Reverb
C# | public struct EffectsInteractive3DLevel2Reverb
C++ | public value class EffectsInteractive3DLevel2Reverb sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsInteractive3DLevel2Reverb | Initializes a new instance of the EffectsInteractive3DLevel2Reverb structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DecayHfRatio | Retrieves and sets the ratio of the decay time at high frequencies to the decay time at low frequencies, of the EffectsInteractive3DLevel2Reverb structure.
DecayTime | Retrieves and sets the decay time, in seconds, of the EffectsInteractive3DLevel2Reverb structure.
Density | Retrieves and sets the modal density in the late reverberation decay, in percent, of the EffectsInteractive3DLevel2Reverb structure.
Diffusion | Retrieves and sets the echo density in the late reverberation decay, in percent, of the EffectsInteractive3DLevel2Reverb structure.
HfReference | Retrieves and sets the reference high frequency, in hertz, of the EffectsInteractive3DLevel2Reverb structure.
Reflections | Retrieves and sets the attenuation of early reflections relative to Room, in mB, of the EffectsInteractive3DLevel2Reverb structure.
ReflectionsDelay | Retrieves and sets the delay time of the first reflection relative to the direct path, in seconds, of the EffectsInteractive3DLevel2Reverb structure.
Reverb | Retrieves and sets the attenuation of late reverberation relative to Room, in mB, of the EffectsInteractive3DLevel2Reverb structure.
ReverbDelay | Retrieves and sets the time limit between the early reflections and the late reverberation relative to the time of the first reflection, in seconds, of the EffectsInteractive3DLevel2Reverb structure.
Room | Retrieves and sets the attenuation of the room effect, in millibels (mB), of the EffectsInteractive3DLevel2Reverb structure.
RoomHf | Retrieves and sets the attenuation of the room high-frequency effect, in mB, of the EffectsInteractive3DLevel2Reverb structure.
RoomRolloffFactor | Retrieves and sets the rolloff factor for the reflected signals of the EffectsInteractive3DLevel2Reverb structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • Interactive3DLevel2ReverbEffect.AllParameters


EffectsInteractive3DLevel2Reverb.EffectsInteractive3DLevel2Reverb() Constructor (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.EffectsInteractive3DLevel2Reverb Constructor

 Language:
How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsInteractive3DLevel2Reverb();
C++ public:
EffectsInteractive3DLevel2Reverb();
JScript | public function EffectsInteractive3DLevel2Reverb();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectsInteractive3DLevel2Reverb.DecayHfRatio Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.DecayHfRatio Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the ratio of the decay time at high frequencies to the decay time at low frequencies, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property DecayHfRatio As Single
C# | public float DecayHfRatio { get; set; }
C++ public:
property float DecayHfRatio {
float get();
void set(float value);
}
JScript public function get DecayHfRatio() : float
public function set DecayHfRatio(float);

Property Value

System.Single
Ratio of the decay time at high frequencies to the decay time at low frequencies.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.DecayHfRatioMin to Interactive3DLevel2ReverbEffect.DecayHfRatioMax.

The default value is Interactive3DLevel2ReverbEffect.DecayHfRatioDefault or 0.83.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.DecayTime Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.DecayTime Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the decay time, in seconds, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property DecayTime As Single
C# | public float DecayTime { get; set; }
C++ public:
property float DecayTime {
float get();
void set(float value);
}
JScript public function get DecayTime() : float
public function set DecayTime(float);

Property Value

System.Single
Decay time, in seconds.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.DecayTimeMin to Interactive3DLevel2ReverbEffect.DecayTimeMax.

The default value is Interactive3DLevel2ReverbEffect.DecayTimeDefault or 1.49 seconds.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Density Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.Density Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the modal density in the late reverberation decay, in percent, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property Density As Single
C# | public float Density { get; set; }
C++ public:
property float Density {
float get();
void set(float value);
}
JScript public function get Density() : float
public function set Density(float);

Property Value

System.Single
Modal density in the late reverberation decay, in percent

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.DensityMin to Interactive3DLevel2ReverbEffect.DensityMax.

The default value is Interactive3DLevel2ReverbEffect.DensityDefault or 100 percent.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Diffusion Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.Diffusion Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the echo density in the late reverberation decay, in percent, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property Diffusion As Single
C# | public float Diffusion { get; set; }
C++ public:
property float Diffusion {
float get();
void set(float value);
}
JScript public function get Diffusion() : float
public function set Diffusion(float);

Property Value

System.Single
Echo density in the late reverberation decay, in percent.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.DiffusionyMin to Interactive3DLevel2ReverbEffect.DiffusionMax.

The default value is Interactive3DLevel2ReverbEffect.DiffusionDefault or 100 percent.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.HfReference Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.HfReference Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the reference high frequency, in hertz, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property HfReference As Single
C# | public float HfReference { get; set; }
C++ public:
property float HfReference {
float get();
void set(float value);
}
JScript public function get HfReference() : float
public function set HfReference(float);

Property Value

System.Single
Reference high frequency, in hertz.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.HfReferenceyMin to Interactive3DLevel2ReverbEffect.HfReferenceMax.

The default value is Interactive3DLevel2ReverbEffect.HfReferenceDefault or 5000.0 Hz.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Reflections Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.Reflections Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the attenuation of early reflections relative to Room, in mB, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property Reflections As Integer
C# | public int Reflections { get; set; }
C++ public:
property int Reflections {
int get();
void set(int value);
}
JScript public function get Reflections() : int
public function set Reflections(int);

Property Value

System.Int32
Attenuation of early reflections relative to Room, in mB.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.ReflectionsMin to Interactive3DLevel2ReverbEffect.ReflectionsMax.

The default value is Interactive3DLevel2ReverbEffect.ReflectionsDefault or -2602 mB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.ReflectionsDelay Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.ReflectionsDelay Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the delay time of the first reflection relative to the direct path, in seconds, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property ReflectionsDelay As Single
C# | public float ReflectionsDelay { get; set; }
C++ public:
property float ReflectionsDelay {
float get();
void set(float value);
}
JScript public function get ReflectionsDelay() : float
public function set ReflectionsDelay(float);

Property Value

System.Single
Delay time of the first reflection relative to the direct path, in seconds.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.ReflectionsDelayMin to Interactive3DLevel2ReverbEffect.ReflectionsDelayMax.

The default value is Interactive3DLevel2ReverbEffect.ReflectionsDelayDefault or 0.007 seconds.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Reverb Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.Reverb Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the attenuation of late reverberation relative to Room, in mB, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property Reverb As Integer
C# | public int Reverb { get; set; }
C++ public:
property int Reverb {
int get();
void set(int value);
}
JScript public function get Reverb() : int
public function set Reverb(int);

Property Value

System.Int32
Attenuation of late reverberation relative to Room, in mB.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.ReverbMin to Interactive3DLevel2ReverbEffect.ReverbMax.

The default value is Interactive3DLevel2ReverbEffect.ReverbDefault or -200 mB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.ReverbDelay Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.ReverbDelay Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the time limit between the early reflections and the late reverberation relative to the time of the first reflection, in seconds, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property ReverbDelay As Single
C# | public float ReverbDelay { get; set; }
C++ public:
property float ReverbDelay {
float get();
void set(float value);
}
JScript public function get ReverbDelay() : float
public function set ReverbDelay(float);

Property Value

System.Single
Time limit between the early reflections and the late reverberation relative to the time of the first reflection, in seconds.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.ReverbDelayMin to Interactive3DLevel2ReverbEffect.ReverbDelayMax.

The default value is Interactive3DLevel2ReverbEffect.ReverbDelayDefault or 0.011 seconds.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.Room Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.Room Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the attenuation of the room effect, in millibels (mB), of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property Room As Integer
C# | public int Room { get; set; }
C++ public:
property int Room {
int get();
void set(int value);
}
JScript public function get Room() : int
public function set Room(int);

Property Value

System.Int32
Attenuation of the room effect, in millibels (mB).

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.RoomMin to Interactive3DLevel2ReverbEffect.RoomMax.

The default value is Interactive3DLevel2ReverbEffect.RoomDefault or -1000 mB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.RoomHf Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.RoomHf Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the attenuation of the room high-frequency effect, in mB, of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property RoomHf As Integer
C# | public int RoomHf { get; set; }
C++ public:
property int RoomHf {
int get();
void set(int value);
}
JScript public function get RoomHf() : int
public function set RoomHf(int);

Property Value

System.Int32
Attenuation of the room high-frequency effect, in mB.

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.RoomHfMin to Interactive3DLevel2ReverbEffect.RoomHfMax.

The default value is Interactive3DLevel2ReverbEffect.RoomHfDefault or -100 mB.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsInteractive3DLevel2Reverb.RoomRolloffFactor Property (Microsoft.DirectX.DirectSound)

EffectsInteractive3DLevel2Reverb.RoomRolloffFactor Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the rolloff factor for the reflected signals of the EffectsInteractive3DLevel2Reverb structure.

Definition

Visual Basic | Public Property RoomRolloffFactor As Single
C# | public float RoomRolloffFactor { get; set; }
C++ public:
property float RoomRolloffFactor {
float get();
void set(float value);
}
JScript public function get RoomRolloffFactor() : float
public function set RoomRolloffFactor(float);

Property Value

System.Single

This property is read/write.

Remarks

Can range from Interactive3DLevel2ReverbEffect.RoomRolloffFactorMin to Interactive3DLevel2ReverbEffect.RoomRolloffFactorMax.

The default value is Interactive3DLevel2ReverbEffect.RoomRolloffFactorDefault or 0.0.

The rolloff factor for the direct path is controlled by the DirectSound listener.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsParamEq Structure (Microsoft.DirectX.DirectSound)

EffectsParamEq Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for a parametric equalizer effect.

Definition

Visual Basic | Public Structure EffectsParamEq
C# | public struct EffectsParamEq
C++ | public value class EffectsParamEq sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsParamEq | Initializes a new instance of the EffectsParamEq structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Bandwidth | Retrieves and sets the bandwidth, in semitones, of the EffectsParamEq structure.
Center | Retrieves and sets the center frequency, in hertz, of the EffectsParamEq structure.
Gain | Retrieves and sets the gain, of the EffectsParamEq structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • ParamEqEffect.AllParameters


EffectsParamEq.EffectsParamEq() Constructor (Microsoft.DirectX.DirectSound)

EffectsParamEq.EffectsParamEq Constructor

How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsParamEq structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsParamEq();
C++ public:
EffectsParamEq();
JScript | public function EffectsParamEq();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsParamEq.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsParamEq.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


EffectsParamEq.Bandwidth Property (Microsoft.DirectX.DirectSound)

EffectsParamEq.Bandwidth Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the bandwidth, in semitones, of the EffectsParamEq structure.

Definition

Visual Basic | Public Property Bandwidth As Single
C# | public float Bandwidth { get; set; }
C++ public:
property float Bandwidth {
float get();
void set(float value);
}
JScript public function get Bandwidth() : float
public function set Bandwidth(float);

Property Value

System.Single
Bandwidth, in semitones.

This property is read/write.

Remarks

Can range from ParamEqEffect.BandwidthMin to ParamEqEffect.BandwidthMax.

The default value is 12.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsParamEq.Center Property (Microsoft.DirectX.DirectSound)

EffectsParamEq.Center Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the center frequency, in hertz, of the EffectsParamEq structure.

Definition

Visual Basic | Public Property Center As Single
C# | public float Center { get; set; }
C++ public:
property float Center {
float get();
void set(float value);
}
JScript public function get Center() : float
public function set Center(float);

Property Value

System.Single
Center frequency, in hertz.

This property is read/write.

Remarks

Can range from ParamEqEffect.CenterMin to ParamEqEffect.CenterMax.

The default value is 8000.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsParamEq.Gain Property (Microsoft.DirectX.DirectSound)

EffectsParamEq.Gain Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the gain, of the EffectsParamEq structure.

Definition

Visual Basic | Public Property Gain As Single
C# | public float Gain { get; set; }
C++ public:
property float Gain {
float get();
void set(float value);
}
JScript public function get Gain() : float
public function set Gain(float);

Property Value

System.Single
Gain.

This property is read/write.

Remarks

Can range from ParamEqEffect.GainMin to ParamEqEffect.GainMax.

The default value is 0.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);


EffectsWavesReverb Structure (Microsoft.DirectX.DirectSound)

EffectsWavesReverb Structure

How Do I...?
  • Use Effect Parameters

Contains parameters for a Waves reverberation effect.

Definition

Visual Basic | Public Structure EffectsWavesReverb
C# | public struct EffectsWavesReverb
C++ | public value class EffectsWavesReverb sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
EffectsWavesReverb | Initializes a new instance of the EffectsWavesReverb structure.
ToString | Retrieves a string representation of the current instance.

Properties

Property | Description
HighFrequencyRtRatio | Retrieves and sets the high-frequency reverb time ratio of the EffectsWavesReverb structure.
InGain | Retrieves and sets the input gain of signal, in decibels (dB), of the EffectsWavesReverb structure.
ReverbMix | Retrieves and sets the reverb mix, in decibels (dB), of the EffectsWavesReverb structure.
ReverbTime | Retrieves and sets the reverb time, in milliseconds, of the EffectsWavesReverb structure.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Setting Effects on Buffers
  • Effect Parameters
  • WavesReverbEffect.AllParameters


EffectsWavesReverb.EffectsWavesReverb() Constructor (Microsoft.DirectX.DirectSound)

EffectsWavesReverb.EffectsWavesReverb Constructor

How Do I...?
  • Use Effect Parameters

Initializes a new instance of the EffectsWavesReverb structure.

Definition

Visual Basic | Public Sub New()
C# | public EffectsWavesReverb();
C++ public:
EffectsWavesReverb();
JScript | public function EffectsWavesReverb();

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.ToString() Method (Microsoft.DirectX.DirectSound)

EffectsWavesReverb.ToString Method

Retrieves a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.HighFrequencyRtRatio Property (Microsoft.DirectX.DirectSound)

EffectsWavesReverb.HighFrequencyRtRatio Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the high-frequency reverb time ratio of the EffectsWavesReverb structure.

Definition

Visual Basic | Public Property HighFrequencyRtRatio As Single
C# | public float HighFrequencyRtRatio { get; set; }
C++ public:
property float HighFrequencyRtRatio {
float get();
void set(float value);
}
JScript public function get HighFrequencyRtRatio() : float
public function set HighFrequencyRtRatio(float);

Property Value

System.Single
High-frequency reverb time ratio.

This property is read/write.

Remarks

Can range from WavesReverbEffect.HighFrequencyRtRationMin to WavesReverbEffect.HighFrequencyRtRationMax.

The default value is 0.001 or WavesReverbEffect.HighFrequencyRtRationDefault.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.InGain Property (Microsoft.DirectX.DirectSound)

EffectsWavesReverb.InGain Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the input gain of signal, in decibels (dB), of the EffectsWavesReverb structure.

Definition

Visual Basic | Public Property InGain As Single
C# | public float InGain { get; set; }
C++ public:
property float InGain {
float get();
void set(float value);
}
JScript public function get InGain() : float
public function set InGain(float);

Property Value

System.Single
Input gain of signal, in decibels (dB).

This property is read/write.

Remarks

Can range from WavesReverbEffect.InGainMin to WavesReverbEffect.InGainMax.

The default value is 0 db or WavesReverbEffect.InGainDefault.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.ReverbMix Property (Microsoft.DirectX.DirectSound)

EffectsWavesReverb.ReverbMix Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the reverb mix, in decibels (dB), of the EffectsWavesReverb structure.

Definition

Visual Basic | Public Property ReverbMix As Single
C# | public float ReverbMix { get; set; }
C++ public:
property float ReverbMix {
float get();
void set(float value);
}
JScript public function get ReverbMix() : float
public function set ReverbMix(float);

Property Value

System.Single
Reverb mix, in decibels (dB).

This property is read/write.

Remarks

Can range from WavesReverbEffect.ReverbMixMin to WavesReverbEffect.ReverbMixMax.

The default value is 0 db or WavesReverbEffect.ReverbMixDefault.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


EffectsWavesReverb.ReverbTime Property (Microsoft.DirectX.DirectSound)

EffectsWavesReverb.ReverbTime Property

How Do I...?
  • Use Effect Parameters

Retrieves and sets the reverb time, in milliseconds, of the EffectsWavesReverb structure.

Definition

Visual Basic | Public Property ReverbTime As Single
C# | public float ReverbTime { get; set; }
C++ public:
property float ReverbTime {
float get();
void set(float value);
}
JScript public function get ReverbTime() : float
public function set ReverbTime(float);

Property Value

System.Single
Reverb time, in milliseconds.

This property is read/write.

Remarks

Can range from WavesReverbEffect.ReverbTimeMin to WavesReverbEffect.ReverbTimeMax.

The default value is 1000 ms or WavesReverbEffect.ReverbTimeDefault.

How Do I...?

Use Effect Parameters

This C# example demonstrates how to use the parameters of an effect object from a SecondaryBuffer object.

The buffer object in this code snippet is assumed to be the SecondaryBuffer from the code in Add Effects to a SecondaryBuffer Object.

              [C#]

//Retrieve the effects object and
//the effect param sturctures and edit parameters.
EchoEffect echo = (EchoEffect)buffer.GetEffects(0);
EffectsEcho echo_params = echo.AllParameters;

echo_params.LeftDelay = 250.0f;
echo_params.RightDelay = 100.0f;
echo_params.Feedback = 85.0f;
echo_params.PanDelay = 1;
echo_params.WetDryMix = 50.0f;

ChorusEffect chorus = (ChorusEffect)buffer.GetEffects(1);
EffectsChorus chorus_params = chorus.AllParameters;

chorus_params.Delay = 15.0f;
chorus_params.Depth = ChorusEffect.DepthMax;
chorus_params.Phase = ChorusEffect.PhaseNegative90;
chorus_params.Waveform = ChorusEffect.WaveSin;
chorus_params.WetDryMix = 50.0f;

//Set the new parameters and play the buffer.
echo.AllParameters = echo_params;
chorus.AllParameters = chorus_params;
buffer.Play(0,BufferPlayFlags.Default);

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Listener3DOrientation Structure (Microsoft.DirectX.DirectSound)

Listener3DOrientation Structure

Contains properties that encompass the front and top 3-D vectors for listeners orientation.

Definition

Visual Basic | Public Structure Listener3DOrientation
C# | public struct Listener3DOrientation
C++ | public value class Listener3DOrientation sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Listener3DOrientation | Initializes a new instance of the Listener3DOrientation structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
Front | Retrieves and sets the front of the listener's orientation.
Top | Retrieves and sets the top of the listener's orientation.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Listener3D.Orientation


Listener3DOrientation.Listener3DOrientation Constructor ()

Initializes a new instance of the Listener3DOrientation structure.

Overload List

public Listener3DOrientation();
public Listener3DOrientation(Vector3, Vector3);


Listener3DOrientation.Listener3DOrientation(Vector3,Vector3) Constructor (Microsoft.DirectX.DirectSound)

Listener3DOrientation.Listener3DOrientation Constructor

Initializes a new instance of the Listener3DOrientation structure.

Definition

Visual Basic Public Sub New( _
ByVal front As Vector3, _
ByVal top As Vector3 _
)
C# public Listener3DOrientation(
Vector3 front,
Vector3 top
);
C++ public:
Listener3DOrientation(
Vector3 front,
Vector3 top
);
JScript public function Listener3DOrientation(
front : Vector3,
top : Vector3
);

Parameters

front Microsoft.DirectX.Vector3
top Microsoft.DirectX.Vector3


Listener3DOrientation.Listener3DOrientation() Constructor (Microsoft.DirectX.DirectSound)

Listener3DOrientation.Listener3DOrientation Constructor

Initializes a new instance of the Listener3DOrientation structure.

Definition

Visual Basic | Public Sub New()
C# | public Listener3DOrientation();
C++ public:
Listener3DOrientation();
JScript | public function Listener3DOrientation();


Listener3DOrientation.ToString() Method (Microsoft.DirectX.DirectSound)

Listener3DOrientation.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Listener3DOrientation.Front Property (Microsoft.DirectX.DirectSound)

Listener3DOrientation.Front Property

Retrieves and sets the front of the listener's orientation.

Definition

Visual Basic | Public Property Front As Vector3
C# | public Vector3 Front { get; set; }
C++ public:
property Vector3 Front {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Front() : Vector3
public function set Front(Vector3);

Property Value

Microsoft.DirectX.Vector3
The front of the listener's orientation.

This property is read/write.


Listener3DOrientation.Top Property (Microsoft.DirectX.DirectSound)

Listener3DOrientation.Top Property

Retrieves and sets the top of the listener's orientation.

Definition

Visual Basic | Public Property Top As Vector3
C# | public Vector3 Top { get; set; }
C++ public:
property Vector3 Top {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Top() : Vector3
public function set Top(Vector3);

Property Value

Microsoft.DirectX.Vector3
The top of the listener's orientation.

This property is read/write.


Listener3DSettings Structure (Microsoft.DirectX.DirectSound)

Listener3DSettings Structure

Contains properties that describes the 3-D world parameters and the position of the listener.

Definition

Visual Basic | Public Structure Listener3DSettings
C# | public struct Listener3DSettings
C++ | public value class Listener3DSettings sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Listener3DSettings | Initializes a new instance of the Listener3DSettings structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
DistanceFactor | Retrieves and sets the number of meters in a vector unit.
DopplerFactor | Retrieves and sets the ratio of Doppler effect to that in the real world.
OrientFront | Retrieves and sets the listener's front orientation.
OrientTop | Retrieves and sets the listener's top orientation.
Position | Retrieves and sets the listener's position.
RolloffFactor | Retrieves and sets the ratio of attenuation over distance to that in the real world.
Velocity | Retrieves and sets the listener's velocity.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Listener3D.AllParameters


Listener3DSettings.Listener3DSettings() Constructor (Microsoft.DirectX.DirectSound)

Listener3DSettings.Listener3DSettings Constructor

Initializes a new instance of the Listener3DSettings structure.

Definition

Visual Basic | Public Sub New()
C# | public Listener3DSettings();
C++ public:
Listener3DSettings();
JScript | public function Listener3DSettings();


Listener3DSettings.ToString() Method (Microsoft.DirectX.DirectSound)

Listener3DSettings.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Listener3DSettings.DistanceFactor Property (Microsoft.DirectX.DirectSound)

Listener3DSettings.DistanceFactor Property

Retrieves and sets the number of meters in a vector unit.

Definition

Visual Basic | Public Property DistanceFactor As Single
C# | public float DistanceFactor { get; set; }
C++ public:
property float DistanceFactor {
float get();
void set(float value);
}
JScript public function get DistanceFactor() : float
public function set DistanceFactor(float);

Property Value

System.Single
The number of meters in a vector unit.

This property is read/write.

Remarks

Can range from Listener3D.DistanceFactorMin to Listener3D.DistanceFactorMax.

The default value is 1 meter or Listener3D.DistanceFactorDefault.


Listener3DSettings.DopplerFactor Property (Microsoft.DirectX.DirectSound)

Listener3DSettings.DopplerFactor Property

Retrieves and sets the ratio of Doppler effect to that in the real world.

Definition

Visual Basic | Public Property DopplerFactor As Single
C# | public float DopplerFactor { get; set; }
C++ public:
property float DopplerFactor {
float get();
void set(float value);
}
JScript public function get DopplerFactor() : float
public function set DopplerFactor(float);

Property Value

System.Single
The ratio of Doppler effect to that in the real world.

This property is read/write.

Remarks

This property has a range of 0.0 (no Doppler effects) to 10.0 (10 times the Doppler effects found in the real world). The default value is 1.0.


Listener3DSettings.OrientFront Property (Microsoft.DirectX.DirectSound)

Listener3DSettings.OrientFront Property

Retrieves and sets the listener's front orientation.

Definition

Visual Basic | Public Property OrientFront As Vector3
C# | public Vector3 OrientFront { get; set; }
C++ public:
property Vector3 OrientFront {
Vector3 get();
void set(Vector3 value);
}
JScript public function get OrientFront() : Vector3
public function set OrientFront(Vector3);

Property Value

Microsoft.DirectX.Vector3
The listener's front orientation.

This property is read/write.


Listener3DSettings.OrientTop Property (Microsoft.DirectX.DirectSound)

Listener3DSettings.OrientTop Property

Retrieves and sets the listener's top orientation.

Definition

Visual Basic | Public Property OrientTop As Vector3
C# | public Vector3 OrientTop { get; set; }
C++ public:
property Vector3 OrientTop {
Vector3 get();
void set(Vector3 value);
}
JScript public function get OrientTop() : Vector3
public function set OrientTop(Vector3);

Property Value

Microsoft.DirectX.Vector3
The listener's top orientation.

This property is read/write.


Listener3DSettings.Position Property (Microsoft.DirectX.DirectSound)

Listener3DSettings.Position Property

Retrieves and sets the listener's position.

Definition

Visual Basic | Public Property Position As Vector3
C# | public Vector3 Position { get; set; }
C++ public:
property Vector3 Position {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Position() : Vector3
public function set Position(Vector3);

Property Value

Microsoft.DirectX.Vector3
The listener's position.

This property is read/write.

Remarks

By default, measurement units are meters, but this can be changed by changing the Listener3DSettings.DistanceFactor property.


Listener3DSettings.RolloffFactor Property (Microsoft.DirectX.DirectSound)

Listener3DSettings.RolloffFactor Property

Retrieves and sets the ratio of attenuation over distance to that in the real world.

Definition

Visual Basic | Public Property RolloffFactor As Single
C# | public float RolloffFactor { get; set; }
C++ public:
property float RolloffFactor {
float get();
void set(float value);
}
JScript public function get RolloffFactor() : float
public function set RolloffFactor(float);

Property Value

System.Single
The ratio of attenuation over distance to that in the real world.

This property is read/write.

Remarks

This property has a range of 0.0 (no rolloff) to 10.0 (10 times the rolloff found in the real world). The default value is 1.0.

Rolloff factor is global. To change the effect of distance for an individual sound buffer, you can set the minimum distance for the buffer.


Listener3DSettings.Velocity Property (Microsoft.DirectX.DirectSound)

Listener3DSettings.Velocity Property

Retrieves and sets the listener's velocity.

Definition

Visual Basic | Public Property Velocity As Vector3
C# | public Vector3 Velocity { get; set; }
C++ public:
property Vector3 Velocity {
Vector3 get();
void set(Vector3 value);
}
JScript public function get Velocity() : Vector3
public function set Velocity(Vector3);

Property Value

Microsoft.DirectX.Vector3
The listener's velocity.

This property is read/write.

Remarks

Velocity is used only for Doppler effects. It does not actually move the listener. To change the listener's position, use the Listener3DSettings.Position property. The default velocity is (0,0,0).

By default, measurement units are meters per second, but this can be changed by changing the Listener3DSettings.DistanceFactor property.


Speakers Structure (Microsoft.DirectX.DirectSound)

Speakers Structure

Contains properties that define various speaker configurations.

Definition

Visual Basic | Public Structure Speakers
C# | public struct Speakers
C++ | public value class Speakers sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Speakers | Initializes a new instance of the Speakers structure.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
FivePointOne | Retrieves and sets whether the audio will be played through a speaker arrangement of five surround speakers with a subwoofer.
GeometryMax | Retrieves and sets whether the speakers are directed over an arc of 180 degrees.
GeometryMin | Retrieves and sets whether the speakers are directed over an arc of 5 degrees.
GeometryNarrow | Retrieves and sets whether the speakers are directed over an arc of 10 degrees.
GeometryWide | Retrieves and sets whether the speakers are directed over an arc of 20 degrees.
Headphone | Retrieves and sets whether the audio will be played through headphones.
Mono | Retrieves and sets whether the audio will be played through a monaural speaker type.
Quad | Retrieves and sets whether the audio will be played through a quadraphonic speaker type.
SevenPointOne | Retrieves and sets whether the audio will be played through a speaker arrangement of seven surround speakers with a subwoofer.
Stereo | Retrieves and sets whether the audio will be played through a stereo speaker type.
Surround | Retrieves and sets whether the audio will be played through a surround sound speaker type.

Remarks

A Speakers object should have one of the following speaker type properties set to true:

  • FivePointOne
  • Headphone
  • Mono
  • Quad
  • SevenPointOne
  • Stereo
  • Surround

A Speakers object, in combination with the speaker type mention above, should have one of the following geometry type properties set to true:

  • GeometryMax
  • GeometryMin
  • GeometryNarrow
  • GeometryWide

This structure is used to control a global Windows setting that affect all users and applications on the system. It is provided only for use by configuration utilities provided by audio device vendors. No other applications should call it.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Device.SpeakerConfig


Speakers.Speakers() Constructor (Microsoft.DirectX.DirectSound)

Speakers.Speakers Constructor

Initializes a new instance of the Speakers structure.

Definition

Visual Basic | Public Sub New()
C# | public Speakers();
C++ public:
Speakers();
JScript | public function Speakers();


Speakers.ToString() Method (Microsoft.DirectX.DirectSound)

Speakers.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Speakers.FivePointOne Property (Microsoft.DirectX.DirectSound)

Speakers.FivePointOne Property

Retrieves and sets whether the audio will be played through a speaker arrangement of five surround speakers with a subwoofer.

Definition

Visual Basic | Public Property FivePointOne As Boolean
C# | public bool FivePointOne { get; set; }
C++ public:
property bool FivePointOne {
bool get();
void set(bool value);
}
JScript public function get FivePointOne() : boolean
public function set FivePointOne(boolean);

Property Value

System.Boolean
A value set to true if the audio will be played through a speaker arrangement of five surround speakers with a subwoofer; otherwise, false.

This property is read/write.


Speakers.GeometryMax Property (Microsoft.DirectX.DirectSound)

Speakers.GeometryMax Property

Retrieves and sets whether the speakers are directed over an arc of 180 degrees.

Definition

Visual Basic | Public Property GeometryMax As Boolean
C# | public bool GeometryMax { get; set; }
C++ public:
property bool GeometryMax {
bool get();
void set(bool value);
}
JScript public function get GeometryMax() : boolean
public function set GeometryMax(boolean);

Property Value

System.Boolean
A value set to true if the speakers are directed over an arc of 180 degrees; otherwise, false.

This property is read/write.


Speakers.GeometryMin Property (Microsoft.DirectX.DirectSound)

Speakers.GeometryMin Property

Retrieves and sets whether the speakers are directed over an arc of 5 degrees.

Definition

Visual Basic | Public Property GeometryMin As Boolean
C# | public bool GeometryMin { get; set; }
C++ public:
property bool GeometryMin {
bool get();
void set(bool value);
}
JScript public function get GeometryMin() : boolean
public function set GeometryMin(boolean);

Property Value

System.Boolean
A value set to true if the speakers are directed over an arc of 5 degrees; otherwise, false.

This property is read/write.


Speakers.GeometryNarrow Property (Microsoft.DirectX.DirectSound)

Speakers.GeometryNarrow Property

Retrieves and sets whether the speakers are directed over an arc of 10 degrees.

Definition

Visual Basic | Public Property GeometryNarrow As Boolean
C# | public bool GeometryNarrow { get; set; }
C++ public:
property bool GeometryNarrow {
bool get();
void set(bool value);
}
JScript public function get GeometryNarrow() : boolean
public function set GeometryNarrow(boolean);

Property Value

System.Boolean
A value set to true if the speakers are directed over an arc of 10 degrees; otherwise, false.

This property is read/write.


Speakers.GeometryWide Property (Microsoft.DirectX.DirectSound)

Speakers.GeometryWide Property

Retrieves and sets whether the speakers are directed over an arc of 20 degrees.

Definition

Visual Basic | Public Property GeometryWide As Boolean
C# | public bool GeometryWide { get; set; }
C++ public:
property bool GeometryWide {
bool get();
void set(bool value);
}
JScript public function get GeometryWide() : boolean
public function set GeometryWide(boolean);

Property Value

System.Boolean
A value set to true if the speakers are directed over an arc of 20 degrees; otherwise, false.

This property is read/write.


Speakers.Headphone Property (Microsoft.DirectX.DirectSound)

Speakers.Headphone Property

Retrieves and sets whether the audio will be played through headphones.

Definition

Visual Basic | Public Property Headphone As Boolean
C# | public bool Headphone { get; set; }
C++ public:
property bool Headphone {
bool get();
void set(bool value);
}
JScript public function get Headphone() : boolean
public function set Headphone(boolean);

Property Value

System.Boolean
A value set to true if the audio will be played through headphones; otherwise, false.

This property is read/write.


Speakers.Mono Property (Microsoft.DirectX.DirectSound)

Speakers.Mono Property

Retrieves and sets whether the audio will be played through a monaural speaker type.

Definition

Visual Basic | Public Property Mono As Boolean
C# | public bool Mono { get; set; }
C++ public:
property bool Mono {
bool get();
void set(bool value);
}
JScript public function get Mono() : boolean
public function set Mono(boolean);

Property Value

System.Boolean
A value set to true if the audio will be played through a monaural speaker type; otherwise, false.

This property is read/write.


Speakers.Quad Property (Microsoft.DirectX.DirectSound)

Speakers.Quad Property

Retrieves and sets whether the audio will be played through a quadraphonic speaker type.

Definition

Visual Basic | Public Property Quad As Boolean
C# | public bool Quad { get; set; }
C++ public:
property bool Quad {
bool get();
void set(bool value);
}
JScript public function get Quad() : boolean
public function set Quad(boolean);

Property Value

System.Boolean
A value set to true if the audio will be played through a quadraphonic speaker type; otherwise, false.

This property is read/write.


Speakers.SevenPointOne Property (Microsoft.DirectX.DirectSound)

Speakers.SevenPointOne Property

Retrieves and sets whether the audio will be played through a speaker arrangement of seven surround speakers with a subwoofer.

Definition

Visual Basic | Public Property SevenPointOne As Boolean
C# | public bool SevenPointOne { get; set; }
C++ public:
property bool SevenPointOne {
bool get();
void set(bool value);
}
JScript public function get SevenPointOne() : boolean
public function set SevenPointOne(boolean);

Property Value

System.Boolean
A value set to true if the audio will be played through a speaker arrangement of seven surround speakers with a subwoofer; otherwise, false.

This property is read/write.


Speakers.Stereo Property (Microsoft.DirectX.DirectSound)

Speakers.Stereo Property

Retrieves and sets whether the audio will be played through a stereo speaker type.

Definition

Visual Basic | Public Property Stereo As Boolean
C# | public bool Stereo { get; set; }
C++ public:
property bool Stereo {
bool get();
void set(bool value);
}
JScript public function get Stereo() : boolean
public function set Stereo(boolean);

Property Value

System.Boolean
A value set to true if the audio will be played through a stereo speaker type; otherwise, false.

This property is read/write.


Speakers.Surround Property (Microsoft.DirectX.DirectSound)

Speakers.Surround Property

Retrieves and sets whether the audio will be played through a surround sound speaker type.

Definition

Visual Basic | Public Property Surround As Boolean
C# | public bool Surround { get; set; }
C++ public:
property bool Surround {
bool get();
void set(bool value);
}
JScript public function get Surround() : boolean
public function set Surround(boolean);

Property Value

System.Boolean
A value set to true if the audio will be played through a surround sound speaker type; otherwise, false.

This property is read/write.


WaveFormat Structure (Microsoft.DirectX.DirectSound)

WaveFormat Structure

Contains properties that define the format of waveform-audio data.

Definition

Visual Basic | Public Structure WaveFormat
C# | public struct WaveFormat
C++ | public value class WaveFormat sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
ToString | Obtains a string representation of the current instance.
WaveFormat | Initializes a new instance of the WaveFormat sturcture.

Properties

Property | Description
AverageBytesPerSecond | Retrieves and sets the required average data-transfer rate, in bytes per second, for the format type.
BitsPerSample | Retrieves and sets the bits per sample for the format type.
BlockAlign | Retrieves and sets the minimum atomic unit of data, in bytes, for the format type.
Channels | Retrieves and sets the number of channels in the waveform-audio data, for the format type.
FormatTag | Retrieves and sets the waveform-audio format type, for the format type.
SamplesPerSecond | Retrieves and sets the sample rate, in samples per second (hertz), for the format type.

Structure Information

Namespace | Microsoft.DirectX.DirectSound
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Buffer.Format
  • BufferDescription constructor
  • CaptureBuffer.Format
  • CaptureBufferDescription.Format


WaveFormat.ToString() Method (Microsoft.DirectX.DirectSound)

WaveFormat.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


WaveFormat.WaveFormat() Constructor (Microsoft.DirectX.DirectSound)

WaveFormat.WaveFormat Constructor

Initializes a new instance of the WaveFormat sturcture.

Definition

Visual Basic | Public Sub New()
C# | public WaveFormat();
C++ public:
WaveFormat();
JScript | public function WaveFormat();


WaveFormat.AverageBytesPerSecond Property (Microsoft.DirectX.DirectSound)

WaveFormat.AverageBytesPerSecond Property

Retrieves and sets the required average data-transfer rate, in bytes per second, for the format type.

Definition

Visual Basic | Public Property AverageBytesPerSecond As Integer
C# | public int AverageBytesPerSecond { get; set; }
C++ public:
property int AverageBytesPerSecond {
int get();
void set(int value);
}
JScript public function get AverageBytesPerSecond() : int
public function set AverageBytesPerSecond(int);

Property Value

System.Int32
The required average data-transfer rate, in bytes per second, for the format type.

This property is read/write.

Remarks

Because Microsoft DirectX 9.0 for Managed Code only supports a FormatTag of WaveFormatTag.Pcm, the AverageBytesPerSecond property should be a product of BlockAlign and SamplesPerSecond


WaveFormat.BitsPerSample Property (Microsoft.DirectX.DirectSound)

WaveFormat.BitsPerSample Property

Retrieves and sets the bits per sample for the format type.

Definition

Visual Basic | Public Property BitsPerSample As Short
C# | public short BitsPerSample { get; set; }
C++ public:
property short BitsPerSample {
short get();
void set(short value);
}
JScript public function get BitsPerSample() : short
public function set BitsPerSample(short);

Property Value

System.Int16
Bits per sample for the format type.

This property is read/write.

Remarks

Because Microsoft DirectX 9.0 for Managed Code only supports a FormatTag of WaveFormatTag.Pcm, the value of the BitsPerSample property should be equal to 8 or 16.


WaveFormat.BlockAlign Property (Microsoft.DirectX.DirectSound)

WaveFormat.BlockAlign Property

Retrieves and sets the minimum atomic unit of data, in bytes, for the format type.

Definition

Visual Basic | Public Property BlockAlign As Short
C# | public short BlockAlign { get; set; }
C++ public:
property short BlockAlign {
short get();
void set(short value);
}
JScript public function get BlockAlign() : short
public function set BlockAlign(short);

Property Value

System.Int16
The minimum atomic unit of data, in bytes, for the format type.

This property is read/write.

Remarks

The value of the BlockAlign property must be equal to the product of Channels and BitsPerSample divided by 8 (bits per byte).

Software must process a multiple of BlockAlign bytes of data at a time. Data written to and read from a device must always start at the beginning of a block. For example, it is illegal to start playback of Pulse Code Modulation (PCM) data in the middle of a sample (that is, on a non-block-aligned boundary).


WaveFormat.Channels Property (Microsoft.DirectX.DirectSound)

WaveFormat.Channels Property

Retrieves and sets the number of channels in the waveform-audio data, for the format type.

Definition

Visual Basic | Public Property Channels As Short
C# | public short Channels { get; set; }
C++ public:
property short Channels {
short get();
void set(short value);
}
JScript public function get Channels() : short
public function set Channels(short);

Property Value

System.Int16
The number of channels in the waveform-audio data, for the format type.

This property is read/write.

Remarks

Monaural data uses one channel and stereo data uses two channels.


WaveFormat.FormatTag Property (Microsoft.DirectX.DirectSound)

WaveFormat.FormatTag Property

Retrieves and sets the waveform-audio format type, for the format type.

Definition

Visual Basic | Public Property FormatTag As WaveFormatTag
C# | public WaveFormatTag FormatTag { get; set; }
C++ public:
property WaveFormatTag FormatTag {
WaveFormatTag get();
void set(WaveFormatTag value);
}
JScript public function get FormatTag() : WaveFormatTag
public function set FormatTag(WaveFormatTag);

Property Value

Microsoft.DirectX.DirectSound.WaveFormatTag
The waveform-audio format type, for the format type.

This property is read/write.

Remarks

Microsoft DirectX 9.0 for Managed Code only supports a FormatTag of WaveFormatTag.Pcm.


WaveFormat.SamplesPerSecond Property (Microsoft.DirectX.DirectSound)

WaveFormat.SamplesPerSecond Property

Retrieves and sets the sample rate, in samples per second (hertz), for the format type.

Definition

Visual Basic | Public Property SamplesPerSecond As Integer
C# | public int SamplesPerSecond { get; set; }
C++ public:
property int SamplesPerSecond {
int get();
void set(int value);
}
JScript public function get SamplesPerSecond() : int
public function set SamplesPerSecond(int);

Property Value

System.Int32
The sample rate, in samples per second (hertz), for the format type.

This property is read/write.

Remarks

Because Microsoft DirectX 9.0 for Managed Code only supports a FormatTag of WaveFormatTag.Pcm, the SamplesPerSecond property should be a common value such as 8.0 kHz, 11.025 kHz, 22.05 kHz, or 44.1 kHz.


Microsoft.DirectX.PrivateImplementationDetails

The PrivateImplementationDetails namespace contains structures and interfaces that allow the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. These structures and interfaces are not intended to be used directly from your code.

Structures

_BUFFERDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DADAPTER_IDENTIFIER9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DBOX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DCAPS9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DCLIPSTATUS9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DCOLORVALUE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DDEVICE_CREATION_PARAMETERS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DDEVINFO_RESOURCEMANAGER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DDISPLAYMODE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DGAMMARAMP | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DINDEXBUFFER_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DLIGHT9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DLOCKED_BOX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DLOCKED_RECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DMATERIAL9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DMATRIX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DPRESENT_PARAMETERS_ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DPSHADERCAPS2_0 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DRASTER_STATUS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DRECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DRECTPATCH_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DSURFACE_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DTRIPATCH_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVECTOR | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVERTEXBUFFER_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVERTEXELEMENT9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVIEWPORT9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVOLUME_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DVSHADERCAPS2_0 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXATTRIBUTERANGE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXATTRIBUTEWEIGHTS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXBONECOMBINATION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXCONSTANT_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXCONSTANTTABLE_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXEFFECT_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXEFFECTDEFAULT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXEFFECTINSTANCE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXEVENT_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXF_FILELOADMEMORY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFONT_DESCA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFONT_DESCW | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFRAGMENT_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFRAME | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXFUNCTION_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXIMAGE_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXKEY_CALLBACK | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXKEY_QUATERNION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXKEY_VECTOR3 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMACRO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMATERIAL | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMATRIXA16 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMESHCONTAINER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXMESHDATA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXPARAMETER_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXPASS_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXPATCHINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXRTE_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXRTS_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXSEMANTIC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXSHMATERIAL | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXTECHNIQUE_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXTRACK_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_D3DXWELDEPSILONS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDBLTFX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDCAPS_DX7 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDCOLORCONTROL | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDCOLORKEY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDGAMMARAMP | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDOVERLAYFX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDPIXELFORMAT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDSCAPS2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DDSURFACEDESC2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DEV_BROADCAST_DEVICEINTERFACE_A | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DEV_BROADCAST_HDR | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIACTIONA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIACTIONFORMATA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DICOLORSET | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DICONFIGUREDEVICESPARAMSA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIDATAFORMAT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIDEVICEIMAGEINFOA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIDEVICEIMAGEINFOHEADERA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIMOUSESTATE2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DIOBJECTDATAFORMAT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_APPLICATION_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_CONNECT_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_CONNECTION_SETTINGS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_MESSAGE_CONNECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_MESSAGE_CONNECTION_SETTINGS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_MESSAGE_RECEIVE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPL_PROGRAM_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_APPLICATION_DESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_CAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_CAPS_EX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_CONNECTION_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_GROUP_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_PLAYER_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_SERVICE_PROVIDER_INFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPN_SP_CAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_CONNECT_COMPLETE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_ENUM_HOSTS_QUERY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_ENUM_HOSTS_RESPONSE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_INDICATE_CONNECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_NAT_RESOLVER_QUERY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_RECEIVE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DPNMSG_TERMINATE_SESSION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DS3DBUFFER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DS3DLISTENER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSBCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSBPOSITIONNOTIFY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSBUFFERDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCBCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCBUFFERDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCEFFECTDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCFXAec | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSCFXNoiseSuppress | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSEFFECTDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXChorus | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXCompressor | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXDistortion | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXEcho | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXFlanger | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXGargle | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXI3DL2Reverb | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXParamEq | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DSFXWavesReverb | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_DXDIAG_INIT_PARAMS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_GLYPHMETRICSFLOAT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_GUID | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_ICONINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_IMAGE_DOS_HEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_MMCKINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_MMIOINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_OVERLAPPED | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_RGNDATA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_SECURITY_ATTRIBUTES | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
_SYSTEMTIME | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXCOLOR | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXFLOAT16 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXMATRIX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXPLANE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXQUATERNION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR2_16F | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR3 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR3_16F | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR4 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
D3DXVECTOR4_16F | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DICONDITION | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DICONSTANTFORCE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DICUSTOMFORCE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIDEVCAPS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIDEVICEINSTANCEA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIDEVICEOBJECTDATA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIDEVICEOBJECTINSTANCEA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIEFFECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIEFFECTINFOA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIEFFESCAPE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIENVELOPE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIFILEEFFECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIJOYSTATE2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPERIODIC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPCPOINTS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPDWORD | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPHEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPPOINTER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPRANGE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIPROPSTRING | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DIRAMPFORCE | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVCLIENTCONFIG | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVCOMPRESSIONINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVMSG_HOSTMIGRATED | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVMSG_SETTARGETS | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVSESSIONDESC | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
DVSOUNDDEVICECONFIG | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
FileHeader | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HACMDRIVER__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HACMSTREAM__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HBITMAP__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HBRUSH__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HDC__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HFONT__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HICON__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HINSTANCE__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HMMIO__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HMONITOR__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HPEN__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
HWND__ | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXAllocateHierarchy | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXAnimationCallbackHandler | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXAnimationController | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXAnimationSet | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXBaseEffect | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXBaseMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXCompressedAnimationSet | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXConstantTable | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXEffect | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXEffectCompiler | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXEffectPool | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXEffectStateManager | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFile | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFileData | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFileEnumObject | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFileSaveData | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFileSaveObject | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFont | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXFragmentLinker | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXInclude | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXKeyframedAnimationSet | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXLine | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXLoadUserData | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXMatrixStack | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPatchMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPRTBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPRTCompBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXPRTEngine | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXRenderToEnvMap | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXRenderToSurface | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXSaveUserData | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXSkinInfo | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXSPMesh | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXSprite | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXTextureGutterHelper | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ID3DXTextureShader | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3D9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DBaseTexture9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DCubeTexture9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DDevice9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DIndexBuffer9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DPixelShader9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DQuery9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DResource9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DStateBlock9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DSurface9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DSwapChain9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DTexture9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVertexBuffer9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVertexDeclaration9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVertexShader9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVolume9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirect3DVolumeTexture9 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDraw7 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawClipper | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawColorControl | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawGammaControl | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawPalette | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectDrawSurface7 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectInput8A | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectInputDevice8A | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectInputEffect | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8Address | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8Client | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8LobbiedApplication | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8LobbyClient | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8NATResolver | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8Peer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8Server | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlay8ThreadPool | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlayVoiceClient | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlayVoiceServer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectPlayVoiceTest | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSound | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSound3DBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSound3DListener | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSound8 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundBuffer8 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCapture | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCaptureBuffer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCaptureBuffer8 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCaptureFXAec | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundCaptureFXNoiseSuppress | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFullDuplex | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXChorus | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXCompressor | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXDistortion | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXEcho | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXFlanger | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXGargle | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXI3DL2Reverb | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXParamEq | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundFXWavesReverb | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDirectSoundNotify | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDxDiagContainer | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IDxDiagProvider | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
IUnknown | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
ManagedD3DXEffectStateManager | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
pcmwaveformat_tag | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tACMSTREAMHEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagBITMAP | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagBITMAPFILEHEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagBITMAPINFO | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagBITMAPINFOHEADER | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagDDDEVICEIDENTIFIER2 | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagLOGBRUSH | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagMSG | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagPALETTEENTRY | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagPOINT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagPROPVARIANT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagRECT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagTEXTMETRICA | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tagVARIANT | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
tWAVEFORMATEX | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.
wavefilter_tag | Allows the managed API to have access to the unmanaged portions of the DirectX API. This is not intended to be used directly from your code.


_BUFFERDESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_BUFFERDESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _BUFFERDESC
C# | public struct _BUFFERDESC
C++ | public value class _BUFFERDESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DADAPTER_IDENTIFIER9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DADAPTER_IDENTIFIER9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DADAPTER_IDENTIFIER9
C# | public struct _D3DADAPTER_IDENTIFIER9
C++ | public value class _D3DADAPTER_IDENTIFIER9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DBOX Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DBOX Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DBOX
C# | public struct _D3DBOX
C++ | public value class _D3DBOX sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DCAPS9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DCAPS9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DCAPS9
C# | public struct _D3DCAPS9
C++ | public value class _D3DCAPS9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DCLIPSTATUS9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DCLIPSTATUS9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DCLIPSTATUS9
C# | public struct _D3DCLIPSTATUS9
C++ | public value class _D3DCLIPSTATUS9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DCOLORVALUE Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DCOLORVALUE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DCOLORVALUE
C# | public struct _D3DCOLORVALUE
C++ | public value class _D3DCOLORVALUE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DDEVICE_CREATION_PARAMETERS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DDEVICE_CREATION_PARAMETERS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DDEVICE_CREATION_PARAMETERS
C# | public struct _D3DDEVICE_CREATION_PARAMETERS
C++ | public value class _D3DDEVICE_CREATION_PARAMETERS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DDEVINFO_RESOURCEMANAGER Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DDEVINFO_RESOURCEMANAGER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DDEVINFO_RESOURCEMANAGER
C# | public struct _D3DDEVINFO_RESOURCEMANAGER
C++ | public value class _D3DDEVINFO_RESOURCEMANAGER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DDISPLAYMODE Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DDISPLAYMODE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DDISPLAYMODE
C# | public struct _D3DDISPLAYMODE
C++ | public value class _D3DDISPLAYMODE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DGAMMARAMP Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DGAMMARAMP Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DGAMMARAMP
C# | public struct _D3DGAMMARAMP
C++ | public value class _D3DGAMMARAMP sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DINDEXBUFFER_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DINDEXBUFFER_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DINDEXBUFFER_DESC
C# | public struct _D3DINDEXBUFFER_DESC
C++ | public value class _D3DINDEXBUFFER_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DLIGHT9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DLIGHT9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DLIGHT9
C# | public struct _D3DLIGHT9
C++ | public value class _D3DLIGHT9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DLOCKED_BOX Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DLOCKED_BOX Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DLOCKED_BOX
C# | public struct _D3DLOCKED_BOX
C++ | public value class _D3DLOCKED_BOX sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DLOCKED_RECT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DLOCKED_RECT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DLOCKED_RECT
C# | public struct _D3DLOCKED_RECT
C++ | public value class _D3DLOCKED_RECT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DMATERIAL9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DMATERIAL9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DMATERIAL9
C# | public struct _D3DMATERIAL9
C++ | public value class _D3DMATERIAL9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DMATRIX Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DMATRIX Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DMATRIX
C# | public struct _D3DMATRIX
C++ | public value class _D3DMATRIX sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DPRESENT_PARAMETERS_ Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DPRESENT_PARAMETERS_ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DPRESENT_PARAMETERS_
C# | public struct _D3DPRESENT_PARAMETERS_
C++ | public value class _D3DPRESENT_PARAMETERS_ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DPSHADERCAPS2_0 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DPSHADERCAPS2_0 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DPSHADERCAPS2_0
C# | public struct _D3DPSHADERCAPS2_0
C++ | public value class _D3DPSHADERCAPS2_0 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DRASTER_STATUS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DRASTER_STATUS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DRASTER_STATUS
C# | public struct _D3DRASTER_STATUS
C++ | public value class _D3DRASTER_STATUS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DRECT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DRECT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DRECT
C# | public struct _D3DRECT
C++ | public value class _D3DRECT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DRECTPATCH_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DRECTPATCH_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DRECTPATCH_INFO
C# | public struct _D3DRECTPATCH_INFO
C++ | public value class _D3DRECTPATCH_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DSURFACE_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DSURFACE_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DSURFACE_DESC
C# | public struct _D3DSURFACE_DESC
C++ | public value class _D3DSURFACE_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DTRIPATCH_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DTRIPATCH_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DTRIPATCH_INFO
C# | public struct _D3DTRIPATCH_INFO
C++ | public value class _D3DTRIPATCH_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DVECTOR Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DVECTOR Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DVECTOR
C# | public struct _D3DVECTOR
C++ | public value class _D3DVECTOR sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DVERTEXBUFFER_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DVERTEXBUFFER_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DVERTEXBUFFER_DESC
C# | public struct _D3DVERTEXBUFFER_DESC
C++ | public value class _D3DVERTEXBUFFER_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DVERTEXELEMENT9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DVERTEXELEMENT9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DVERTEXELEMENT9
C# | public struct _D3DVERTEXELEMENT9
C++ | public value class _D3DVERTEXELEMENT9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DVIEWPORT9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DVIEWPORT9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DVIEWPORT9
C# | public struct _D3DVIEWPORT9
C++ | public value class _D3DVIEWPORT9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DVOLUME_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DVOLUME_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DVOLUME_DESC
C# | public struct _D3DVOLUME_DESC
C++ | public value class _D3DVOLUME_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DVSHADERCAPS2_0 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DVSHADERCAPS2_0 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DVSHADERCAPS2_0
C# | public struct _D3DVSHADERCAPS2_0
C++ | public value class _D3DVSHADERCAPS2_0 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXATTRIBUTERANGE Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXATTRIBUTERANGE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXATTRIBUTERANGE
C# | public struct _D3DXATTRIBUTERANGE
C++ | public value class _D3DXATTRIBUTERANGE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXATTRIBUTEWEIGHTS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXATTRIBUTEWEIGHTS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXATTRIBUTEWEIGHTS
C# | public struct _D3DXATTRIBUTEWEIGHTS
C++ | public value class _D3DXATTRIBUTEWEIGHTS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXBONECOMBINATION Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXBONECOMBINATION Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXBONECOMBINATION
C# | public struct _D3DXBONECOMBINATION
C++ | public value class _D3DXBONECOMBINATION sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXCONSTANT_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXCONSTANT_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXCONSTANT_DESC
C# | public struct _D3DXCONSTANT_DESC
C++ | public value class _D3DXCONSTANT_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXCONSTANTTABLE_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXCONSTANTTABLE_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXCONSTANTTABLE_DESC
C# | public struct _D3DXCONSTANTTABLE_DESC
C++ | public value class _D3DXCONSTANTTABLE_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXEFFECT_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXEFFECT_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXEFFECT_DESC
C# | public struct _D3DXEFFECT_DESC
C++ | public value class _D3DXEFFECT_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXEFFECTDEFAULT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXEFFECTDEFAULT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXEFFECTDEFAULT
C# | public struct _D3DXEFFECTDEFAULT
C++ | public value class _D3DXEFFECTDEFAULT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXEFFECTINSTANCE Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXEFFECTINSTANCE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXEFFECTINSTANCE
C# | public struct _D3DXEFFECTINSTANCE
C++ | public value class _D3DXEFFECTINSTANCE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXEVENT_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXEVENT_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXEVENT_DESC
C# | public struct _D3DXEVENT_DESC
C++ | public value class _D3DXEVENT_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXF_FILELOADMEMORY Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXF_FILELOADMEMORY Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXF_FILELOADMEMORY
C# | public struct _D3DXF_FILELOADMEMORY
C++ | public value class _D3DXF_FILELOADMEMORY sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXFONT_DESCA Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXFONT_DESCA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXFONT_DESCA
C# | public struct _D3DXFONT_DESCA
C++ | public value class _D3DXFONT_DESCA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXFONT_DESCW Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXFONT_DESCW Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXFONT_DESCW
C# | public struct _D3DXFONT_DESCW
C++ | public value class _D3DXFONT_DESCW sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXFRAGMENT_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXFRAGMENT_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXFRAGMENT_DESC
C# | public struct _D3DXFRAGMENT_DESC
C++ | public value class _D3DXFRAGMENT_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXFRAME Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXFRAME Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXFRAME
C# | public struct _D3DXFRAME
C++ | public value class _D3DXFRAME sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXFUNCTION_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXFUNCTION_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXFUNCTION_DESC
C# | public struct _D3DXFUNCTION_DESC
C++ | public value class _D3DXFUNCTION_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXIMAGE_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXIMAGE_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXIMAGE_INFO
C# | public struct _D3DXIMAGE_INFO
C++ | public value class _D3DXIMAGE_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXKEY_CALLBACK Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXKEY_CALLBACK Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXKEY_CALLBACK
C# | public struct _D3DXKEY_CALLBACK
C++ | public value class _D3DXKEY_CALLBACK sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXKEY_QUATERNION Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXKEY_QUATERNION Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXKEY_QUATERNION
C# | public struct _D3DXKEY_QUATERNION
C++ | public value class _D3DXKEY_QUATERNION sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXKEY_VECTOR3 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXKEY_VECTOR3 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXKEY_VECTOR3
C# | public struct _D3DXKEY_VECTOR3
C++ | public value class _D3DXKEY_VECTOR3 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXMACRO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXMACRO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXMACRO
C# | public struct _D3DXMACRO
C++ | public value class _D3DXMACRO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXMATERIAL Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXMATERIAL Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXMATERIAL
C# | public struct _D3DXMATERIAL
C++ | public value class _D3DXMATERIAL sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXMATRIXA16 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXMATRIXA16 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXMATRIXA16
C# | public struct _D3DXMATRIXA16
C++ | public value class _D3DXMATRIXA16 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXMESHCONTAINER Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXMESHCONTAINER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXMESHCONTAINER
C# | public struct _D3DXMESHCONTAINER
C++ | public value class _D3DXMESHCONTAINER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXMESHDATA Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXMESHDATA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXMESHDATA
C# | public struct _D3DXMESHDATA
C++ | public value class _D3DXMESHDATA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXPARAMETER_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXPARAMETER_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXPARAMETER_DESC
C# | public struct _D3DXPARAMETER_DESC
C++ | public value class _D3DXPARAMETER_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXPASS_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXPASS_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXPASS_DESC
C# | public struct _D3DXPASS_DESC
C++ | public value class _D3DXPASS_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXPATCHINFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXPATCHINFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXPATCHINFO
C# | public struct _D3DXPATCHINFO
C++ | public value class _D3DXPATCHINFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXRTE_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXRTE_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXRTE_DESC
C# | public struct _D3DXRTE_DESC
C++ | public value class _D3DXRTE_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXRTS_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXRTS_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXRTS_DESC
C# | public struct _D3DXRTS_DESC
C++ | public value class _D3DXRTS_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXSEMANTIC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXSEMANTIC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXSEMANTIC
C# | public struct _D3DXSEMANTIC
C++ | public value class _D3DXSEMANTIC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXSHMATERIAL Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXSHMATERIAL Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXSHMATERIAL
C# | public struct _D3DXSHMATERIAL
C++ | public value class _D3DXSHMATERIAL sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXTECHNIQUE_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXTECHNIQUE_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXTECHNIQUE_DESC
C# | public struct _D3DXTECHNIQUE_DESC
C++ | public value class _D3DXTECHNIQUE_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXTRACK_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXTRACK_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXTRACK_DESC
C# | public struct _D3DXTRACK_DESC
C++ | public value class _D3DXTRACK_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_D3DXWELDEPSILONS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_D3DXWELDEPSILONS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _D3DXWELDEPSILONS
C# | public struct _D3DXWELDEPSILONS
C++ | public value class _D3DXWELDEPSILONS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDBLTFX Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDBLTFX Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDBLTFX
C# | public struct _DDBLTFX
C++ | public value class _DDBLTFX sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDCAPS_DX7 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDCAPS_DX7 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDCAPS_DX7
C# | public struct _DDCAPS_DX7
C++ | public value class _DDCAPS_DX7 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDCOLORCONTROL Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDCOLORCONTROL Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDCOLORCONTROL
C# | public struct _DDCOLORCONTROL
C++ | public value class _DDCOLORCONTROL sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDCOLORKEY Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDCOLORKEY Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDCOLORKEY
C# | public struct _DDCOLORKEY
C++ | public value class _DDCOLORKEY sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDGAMMARAMP Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDGAMMARAMP Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDGAMMARAMP
C# | public struct _DDGAMMARAMP
C++ | public value class _DDGAMMARAMP sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDOVERLAYFX Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDOVERLAYFX Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDOVERLAYFX
C# | public struct _DDOVERLAYFX
C++ | public value class _DDOVERLAYFX sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDPIXELFORMAT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDPIXELFORMAT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDPIXELFORMAT
C# | public struct _DDPIXELFORMAT
C++ | public value class _DDPIXELFORMAT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDSCAPS2 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDSCAPS2 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDSCAPS2
C# | public struct _DDSCAPS2
C++ | public value class _DDSCAPS2 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DDSURFACEDESC2 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DDSURFACEDESC2 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DDSURFACEDESC2
C# | public struct _DDSURFACEDESC2
C++ | public value class _DDSURFACEDESC2 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DEV_BROADCAST_DEVICEINTERFACE_A Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DEV_BROADCAST_DEVICEINTERFACE_A Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DEV_BROADCAST_DEVICEINTERFACE_A
C# | public struct _DEV_BROADCAST_DEVICEINTERFACE_A
C++ | public value class _DEV_BROADCAST_DEVICEINTERFACE_A sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DEV_BROADCAST_HDR Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DEV_BROADCAST_HDR Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DEV_BROADCAST_HDR
C# | public struct _DEV_BROADCAST_HDR
C++ | public value class _DEV_BROADCAST_HDR sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DIACTIONA Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DIACTIONA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DIACTIONA
C# | public struct _DIACTIONA
C++ | public value class _DIACTIONA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DIACTIONFORMATA Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DIACTIONFORMATA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DIACTIONFORMATA
C# | public struct _DIACTIONFORMATA
C++ | public value class _DIACTIONFORMATA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DICOLORSET Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DICOLORSET Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DICOLORSET
C# | public struct _DICOLORSET
C++ | public value class _DICOLORSET sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DICONFIGUREDEVICESPARAMSA Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DICONFIGUREDEVICESPARAMSA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DICONFIGUREDEVICESPARAMSA
C# | public struct _DICONFIGUREDEVICESPARAMSA
C++ | public value class _DICONFIGUREDEVICESPARAMSA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DIDATAFORMAT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DIDATAFORMAT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DIDATAFORMAT
C# | public struct _DIDATAFORMAT
C++ | public value class _DIDATAFORMAT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DIDEVICEIMAGEINFOA Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DIDEVICEIMAGEINFOA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DIDEVICEIMAGEINFOA
C# | public struct _DIDEVICEIMAGEINFOA
C++ | public value class _DIDEVICEIMAGEINFOA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DIDEVICEIMAGEINFOHEADERA Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DIDEVICEIMAGEINFOHEADERA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DIDEVICEIMAGEINFOHEADERA
C# | public struct _DIDEVICEIMAGEINFOHEADERA
C++ | public value class _DIDEVICEIMAGEINFOHEADERA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DIMOUSESTATE2 Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DIMOUSESTATE2 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DIMOUSESTATE2
C# | public struct _DIMOUSESTATE2
C++ | public value class _DIMOUSESTATE2 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DIOBJECTDATAFORMAT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DIOBJECTDATAFORMAT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DIOBJECTDATAFORMAT
C# | public struct _DIOBJECTDATAFORMAT
C++ | public value class _DIOBJECTDATAFORMAT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPL_APPLICATION_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPL_APPLICATION_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPL_APPLICATION_INFO
C# | public struct _DPL_APPLICATION_INFO
C++ | public value class _DPL_APPLICATION_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPL_CONNECT_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPL_CONNECT_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPL_CONNECT_INFO
C# | public struct _DPL_CONNECT_INFO
C++ | public value class _DPL_CONNECT_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPL_CONNECTION_SETTINGS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPL_CONNECTION_SETTINGS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPL_CONNECTION_SETTINGS
C# | public struct _DPL_CONNECTION_SETTINGS
C++ | public value class _DPL_CONNECTION_SETTINGS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPL_MESSAGE_CONNECT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPL_MESSAGE_CONNECT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPL_MESSAGE_CONNECT
C# | public struct _DPL_MESSAGE_CONNECT
C++ | public value class _DPL_MESSAGE_CONNECT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPL_MESSAGE_CONNECTION_SETTINGS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPL_MESSAGE_CONNECTION_SETTINGS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPL_MESSAGE_CONNECTION_SETTINGS
C# | public struct _DPL_MESSAGE_CONNECTION_SETTINGS
C++ | public value class _DPL_MESSAGE_CONNECTION_SETTINGS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPL_MESSAGE_RECEIVE Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPL_MESSAGE_RECEIVE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPL_MESSAGE_RECEIVE
C# | public struct _DPL_MESSAGE_RECEIVE
C++ | public value class _DPL_MESSAGE_RECEIVE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPL_PROGRAM_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPL_PROGRAM_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPL_PROGRAM_DESC
C# | public struct _DPL_PROGRAM_DESC
C++ | public value class _DPL_PROGRAM_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPN_APPLICATION_DESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPN_APPLICATION_DESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPN_APPLICATION_DESC
C# | public struct _DPN_APPLICATION_DESC
C++ | public value class _DPN_APPLICATION_DESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPN_CAPS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPN_CAPS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPN_CAPS
C# | public struct _DPN_CAPS
C++ | public value class _DPN_CAPS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPN_CAPS_EX Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPN_CAPS_EX Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPN_CAPS_EX
C# | public struct _DPN_CAPS_EX
C++ | public value class _DPN_CAPS_EX sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPN_CONNECTION_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPN_CONNECTION_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPN_CONNECTION_INFO
C# | public struct _DPN_CONNECTION_INFO
C++ | public value class _DPN_CONNECTION_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPN_GROUP_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPN_GROUP_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPN_GROUP_INFO
C# | public struct _DPN_GROUP_INFO
C++ | public value class _DPN_GROUP_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPN_PLAYER_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPN_PLAYER_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPN_PLAYER_INFO
C# | public struct _DPN_PLAYER_INFO
C++ | public value class _DPN_PLAYER_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPN_SERVICE_PROVIDER_INFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPN_SERVICE_PROVIDER_INFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPN_SERVICE_PROVIDER_INFO
C# | public struct _DPN_SERVICE_PROVIDER_INFO
C++ | public value class _DPN_SERVICE_PROVIDER_INFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPN_SP_CAPS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPN_SP_CAPS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPN_SP_CAPS
C# | public struct _DPN_SP_CAPS
C++ | public value class _DPN_SP_CAPS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPNMSG_CONNECT_COMPLETE Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPNMSG_CONNECT_COMPLETE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPNMSG_CONNECT_COMPLETE
C# | public struct _DPNMSG_CONNECT_COMPLETE
C++ | public value class _DPNMSG_CONNECT_COMPLETE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPNMSG_ENUM_HOSTS_QUERY Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPNMSG_ENUM_HOSTS_QUERY Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPNMSG_ENUM_HOSTS_QUERY
C# | public struct _DPNMSG_ENUM_HOSTS_QUERY
C++ | public value class _DPNMSG_ENUM_HOSTS_QUERY sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPNMSG_ENUM_HOSTS_RESPONSE Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPNMSG_ENUM_HOSTS_RESPONSE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPNMSG_ENUM_HOSTS_RESPONSE
C# | public struct _DPNMSG_ENUM_HOSTS_RESPONSE
C++ | public value class _DPNMSG_ENUM_HOSTS_RESPONSE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPNMSG_INDICATE_CONNECT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPNMSG_INDICATE_CONNECT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPNMSG_INDICATE_CONNECT
C# | public struct _DPNMSG_INDICATE_CONNECT
C++ | public value class _DPNMSG_INDICATE_CONNECT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPNMSG_NAT_RESOLVER_QUERY Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPNMSG_NAT_RESOLVER_QUERY Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPNMSG_NAT_RESOLVER_QUERY
C# | public struct _DPNMSG_NAT_RESOLVER_QUERY
C++ | public value class _DPNMSG_NAT_RESOLVER_QUERY sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPNMSG_RECEIVE Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPNMSG_RECEIVE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPNMSG_RECEIVE
C# | public struct _DPNMSG_RECEIVE
C++ | public value class _DPNMSG_RECEIVE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DPNMSG_TERMINATE_SESSION Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DPNMSG_TERMINATE_SESSION Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DPNMSG_TERMINATE_SESSION
C# | public struct _DPNMSG_TERMINATE_SESSION
C++ | public value class _DPNMSG_TERMINATE_SESSION sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DS3DBUFFER Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DS3DBUFFER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DS3DBUFFER
C# | public struct _DS3DBUFFER
C++ | public value class _DS3DBUFFER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DS3DLISTENER Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DS3DLISTENER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DS3DLISTENER
C# | public struct _DS3DLISTENER
C++ | public value class _DS3DLISTENER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSBCAPS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSBCAPS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSBCAPS
C# | public struct _DSBCAPS
C++ | public value class _DSBCAPS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSBPOSITIONNOTIFY Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSBPOSITIONNOTIFY Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSBPOSITIONNOTIFY
C# | public struct _DSBPOSITIONNOTIFY
C++ | public value class _DSBPOSITIONNOTIFY sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSBUFFERDESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSBUFFERDESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSBUFFERDESC
C# | public struct _DSBUFFERDESC
C++ | public value class _DSBUFFERDESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSCAPS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSCAPS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSCAPS
C# | public struct _DSCAPS
C++ | public value class _DSCAPS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSCBCAPS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSCBCAPS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSCBCAPS
C# | public struct _DSCBCAPS
C++ | public value class _DSCBCAPS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSCBUFFERDESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSCBUFFERDESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSCBUFFERDESC
C# | public struct _DSCBUFFERDESC
C++ | public value class _DSCBUFFERDESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSCCAPS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSCCAPS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSCCAPS
C# | public struct _DSCCAPS
C++ | public value class _DSCCAPS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSCEFFECTDESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSCEFFECTDESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSCEFFECTDESC
C# | public struct _DSCEFFECTDESC
C++ | public value class _DSCEFFECTDESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSCFXAec Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSCFXAec Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSCFXAec
C# | public struct _DSCFXAec
C++ | public value class _DSCFXAec sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSCFXNoiseSuppress Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSCFXNoiseSuppress Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSCFXNoiseSuppress
C# | public struct _DSCFXNoiseSuppress
C++ | public value class _DSCFXNoiseSuppress sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSEFFECTDESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSEFFECTDESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSEFFECTDESC
C# | public struct _DSEFFECTDESC
C++ | public value class _DSEFFECTDESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXChorus Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXChorus Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXChorus
C# | public struct _DSFXChorus
C++ | public value class _DSFXChorus sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXCompressor Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXCompressor Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXCompressor
C# | public struct _DSFXCompressor
C++ | public value class _DSFXCompressor sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXDistortion Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXDistortion Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXDistortion
C# | public struct _DSFXDistortion
C++ | public value class _DSFXDistortion sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXEcho Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXEcho Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXEcho
C# | public struct _DSFXEcho
C++ | public value class _DSFXEcho sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXFlanger Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXFlanger Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXFlanger
C# | public struct _DSFXFlanger
C++ | public value class _DSFXFlanger sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXGargle Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXGargle Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXGargle
C# | public struct _DSFXGargle
C++ | public value class _DSFXGargle sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXI3DL2Reverb Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXI3DL2Reverb Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXI3DL2Reverb
C# | public struct _DSFXI3DL2Reverb
C++ | public value class _DSFXI3DL2Reverb sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXParamEq Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXParamEq Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXParamEq
C# | public struct _DSFXParamEq
C++ | public value class _DSFXParamEq sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DSFXWavesReverb Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DSFXWavesReverb Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DSFXWavesReverb
C# | public struct _DSFXWavesReverb
C++ | public value class _DSFXWavesReverb sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_DXDIAG_INIT_PARAMS Structure (Microsoft.DirectX.PrivateImplementationDetails)

_DXDIAG_INIT_PARAMS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _DXDIAG_INIT_PARAMS
C# | public struct _DXDIAG_INIT_PARAMS
C++ | public value class _DXDIAG_INIT_PARAMS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_GLYPHMETRICSFLOAT Structure (Microsoft.DirectX.PrivateImplementationDetails)

_GLYPHMETRICSFLOAT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _GLYPHMETRICSFLOAT
C# | public struct _GLYPHMETRICSFLOAT
C++ | public value class _GLYPHMETRICSFLOAT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_GUID Structure (Microsoft.DirectX.PrivateImplementationDetails)

_GUID Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _GUID
C# | public struct _GUID
C++ | public value class _GUID sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_ICONINFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_ICONINFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _ICONINFO
C# | public struct _ICONINFO
C++ | public value class _ICONINFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_IMAGE_DOS_HEADER Structure (Microsoft.DirectX.PrivateImplementationDetails)

_IMAGE_DOS_HEADER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _IMAGE_DOS_HEADER
C# | public struct _IMAGE_DOS_HEADER
C++ | public value class _IMAGE_DOS_HEADER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_MMCKINFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_MMCKINFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _MMCKINFO
C# | public struct _MMCKINFO
C++ | public value class _MMCKINFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_MMIOINFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

_MMIOINFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _MMIOINFO
C# | public struct _MMIOINFO
C++ | public value class _MMIOINFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_OVERLAPPED Structure (Microsoft.DirectX.PrivateImplementationDetails)

_OVERLAPPED Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _OVERLAPPED
C# | public struct _OVERLAPPED
C++ | public value class _OVERLAPPED sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_RGNDATA Structure (Microsoft.DirectX.PrivateImplementationDetails)

_RGNDATA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _RGNDATA
C# | public struct _RGNDATA
C++ | public value class _RGNDATA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_SECURITY_ATTRIBUTES Structure (Microsoft.DirectX.PrivateImplementationDetails)

_SECURITY_ATTRIBUTES Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure _SECURITY_ATTRIBUTES
C# | public struct _SECURITY_ATTRIBUTES
C++ | public value class _SECURITY_ATTRIBUTES sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


_SYSTEMTIME Structure (Microsoft.DirectX.PrivateImplementationDetails)

_SYSTEMTIME Structure

Definition

Visual Basic | Public Structure _SYSTEMTIME
C# | public struct _SYSTEMTIME
C++ | public value class _SYSTEMTIME sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


D3DXCOLOR Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXCOLOR Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXCOLOR
C# | public struct D3DXCOLOR
C++ | public value class D3DXCOLOR sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXFLOAT16 Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXFLOAT16 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXFLOAT16
C# | public struct D3DXFLOAT16
C++ | public value class D3DXFLOAT16 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXMATRIX Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXMATRIX Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXMATRIX
C# | public struct D3DXMATRIX
C++ | public value class D3DXMATRIX sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXPLANE Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXPLANE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXPLANE
C# | public struct D3DXPLANE
C++ | public value class D3DXPLANE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXQUATERNION Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXQUATERNION Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXQUATERNION
C# | public struct D3DXQUATERNION
C++ | public value class D3DXQUATERNION sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXVECTOR2 Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXVECTOR2 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXVECTOR2
C# | public struct D3DXVECTOR2
C++ | public value class D3DXVECTOR2 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXVECTOR2_16F Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXVECTOR2_16F Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXVECTOR2_16F
C# | public struct D3DXVECTOR2_16F
C++ | public value class D3DXVECTOR2_16F sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXVECTOR3 Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXVECTOR3 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXVECTOR3
C# | public struct D3DXVECTOR3
C++ | public value class D3DXVECTOR3 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXVECTOR3_16F Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXVECTOR3_16F Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXVECTOR3_16F
C# | public struct D3DXVECTOR3_16F
C++ | public value class D3DXVECTOR3_16F sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXVECTOR4 Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXVECTOR4 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXVECTOR4
C# | public struct D3DXVECTOR4
C++ | public value class D3DXVECTOR4 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


D3DXVECTOR4_16F Structure (Microsoft.DirectX.PrivateImplementationDetails)

D3DXVECTOR4_16F Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure D3DXVECTOR4_16F
C# | public struct D3DXVECTOR4_16F
C++ | public value class D3DXVECTOR4_16F sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DICONDITION Structure (Microsoft.DirectX.PrivateImplementationDetails)

DICONDITION Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DICONDITION
C# | public struct DICONDITION
C++ | public value class DICONDITION sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DICONSTANTFORCE Structure (Microsoft.DirectX.PrivateImplementationDetails)

DICONSTANTFORCE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DICONSTANTFORCE
C# | public struct DICONSTANTFORCE
C++ | public value class DICONSTANTFORCE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DICUSTOMFORCE Structure (Microsoft.DirectX.PrivateImplementationDetails)

DICUSTOMFORCE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DICUSTOMFORCE
C# | public struct DICUSTOMFORCE
C++ | public value class DICUSTOMFORCE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIDEVCAPS Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIDEVCAPS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIDEVCAPS
C# | public struct DIDEVCAPS
C++ | public value class DIDEVCAPS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIDEVICEINSTANCEA Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIDEVICEINSTANCEA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIDEVICEINSTANCEA
C# | public struct DIDEVICEINSTANCEA
C++ | public value class DIDEVICEINSTANCEA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIDEVICEOBJECTDATA Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIDEVICEOBJECTDATA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIDEVICEOBJECTDATA
C# | public struct DIDEVICEOBJECTDATA
C++ | public value class DIDEVICEOBJECTDATA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIDEVICEOBJECTINSTANCEA Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIDEVICEOBJECTINSTANCEA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIDEVICEOBJECTINSTANCEA
C# | public struct DIDEVICEOBJECTINSTANCEA
C++ | public value class DIDEVICEOBJECTINSTANCEA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIEFFECT Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIEFFECT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIEFFECT
C# | public struct DIEFFECT
C++ | public value class DIEFFECT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIEFFECTINFOA Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIEFFECTINFOA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIEFFECTINFOA
C# | public struct DIEFFECTINFOA
C++ | public value class DIEFFECTINFOA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIEFFESCAPE Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIEFFESCAPE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIEFFESCAPE
C# | public struct DIEFFESCAPE
C++ | public value class DIEFFESCAPE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIENVELOPE Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIENVELOPE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIENVELOPE
C# | public struct DIENVELOPE
C++ | public value class DIENVELOPE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIFILEEFFECT Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIFILEEFFECT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIFILEEFFECT
C# | public struct DIFILEEFFECT
C++ | public value class DIFILEEFFECT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIJOYSTATE2 Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIJOYSTATE2 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIJOYSTATE2
C# | public struct DIJOYSTATE2
C++ | public value class DIJOYSTATE2 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIPERIODIC Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIPERIODIC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIPERIODIC
C# | public struct DIPERIODIC
C++ | public value class DIPERIODIC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIPROPCPOINTS Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIPROPCPOINTS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIPROPCPOINTS
C# | public struct DIPROPCPOINTS
C++ | public value class DIPROPCPOINTS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIPROPDWORD Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIPROPDWORD Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIPROPDWORD
C# | public struct DIPROPDWORD
C++ | public value class DIPROPDWORD sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIPROPHEADER Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIPROPHEADER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIPROPHEADER
C# | public struct DIPROPHEADER
C++ | public value class DIPROPHEADER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIPROPPOINTER Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIPROPPOINTER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIPROPPOINTER
C# | public struct DIPROPPOINTER
C++ | public value class DIPROPPOINTER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIPROPRANGE Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIPROPRANGE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIPROPRANGE
C# | public struct DIPROPRANGE
C++ | public value class DIPROPRANGE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIPROPSTRING Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIPROPSTRING Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIPROPSTRING
C# | public struct DIPROPSTRING
C++ | public value class DIPROPSTRING sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DIRAMPFORCE Structure (Microsoft.DirectX.PrivateImplementationDetails)

DIRAMPFORCE Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DIRAMPFORCE
C# | public struct DIRAMPFORCE
C++ | public value class DIRAMPFORCE sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DVCLIENTCONFIG Structure (Microsoft.DirectX.PrivateImplementationDetails)

DVCLIENTCONFIG Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DVCLIENTCONFIG
C# | public struct DVCLIENTCONFIG
C++ | public value class DVCLIENTCONFIG sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DVCOMPRESSIONINFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

DVCOMPRESSIONINFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DVCOMPRESSIONINFO
C# | public struct DVCOMPRESSIONINFO
C++ | public value class DVCOMPRESSIONINFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DVMSG_HOSTMIGRATED Structure (Microsoft.DirectX.PrivateImplementationDetails)

DVMSG_HOSTMIGRATED Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DVMSG_HOSTMIGRATED
C# | public struct DVMSG_HOSTMIGRATED
C++ | public value class DVMSG_HOSTMIGRATED sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DVMSG_SETTARGETS Structure (Microsoft.DirectX.PrivateImplementationDetails)

DVMSG_SETTARGETS Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DVMSG_SETTARGETS
C# | public struct DVMSG_SETTARGETS
C++ | public value class DVMSG_SETTARGETS sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DVSESSIONDESC Structure (Microsoft.DirectX.PrivateImplementationDetails)

DVSESSIONDESC Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DVSESSIONDESC
C# | public struct DVSESSIONDESC
C++ | public value class DVSESSIONDESC sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DVSOUNDDEVICECONFIG Structure (Microsoft.DirectX.PrivateImplementationDetails)

DVSOUNDDEVICECONFIG Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure DVSOUNDDEVICECONFIG
C# | public struct DVSOUNDDEVICECONFIG
C++ | public value class DVSOUNDDEVICECONFIG sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


FileHeader Structure (Microsoft.DirectX.PrivateImplementationDetails)

FileHeader Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure FileHeader
C# | public struct FileHeader
C++ | public value class FileHeader sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HACMDRIVER__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HACMDRIVER__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HACMDRIVER__
C# | public struct HACMDRIVER__
C++ | public value class HACMDRIVER__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HACMSTREAM__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HACMSTREAM__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HACMSTREAM__
C# | public struct HACMSTREAM__
C++ | public value class HACMSTREAM__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HBITMAP__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HBITMAP__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HBITMAP__
C# | public struct HBITMAP__
C++ | public value class HBITMAP__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HBRUSH__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HBRUSH__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HBRUSH__
C# | public struct HBRUSH__
C++ | public value class HBRUSH__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HDC__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HDC__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HDC__
C# | public struct HDC__
C++ | public value class HDC__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HFONT__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HFONT__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HFONT__
C# | public struct HFONT__
C++ | public value class HFONT__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HICON__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HICON__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HICON__
C# | public struct HICON__
C++ | public value class HICON__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HINSTANCE__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HINSTANCE__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HINSTANCE__
C# | public struct HINSTANCE__
C++ | public value class HINSTANCE__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HMMIO__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HMMIO__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HMMIO__
C# | public struct HMMIO__
C++ | public value class HMMIO__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HMONITOR__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HMONITOR__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HMONITOR__
C# | public struct HMONITOR__
C++ | public value class HMONITOR__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HPEN__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HPEN__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HPEN__
C# | public struct HPEN__
C++ | public value class HPEN__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


HWND__ Structure (Microsoft.DirectX.PrivateImplementationDetails)

HWND__ Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure HWND__
C# | public struct HWND__
C++ | public value class HWND__ sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXAllocateHierarchy Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXAllocateHierarchy Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXAllocateHierarchy
C# | public struct ID3DXAllocateHierarchy
C++ | public value class ID3DXAllocateHierarchy sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXAnimationCallbackHandler Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXAnimationCallbackHandler Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXAnimationCallbackHandler
C# | public struct ID3DXAnimationCallbackHandler
C++ | public value class ID3DXAnimationCallbackHandler sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXAnimationController Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXAnimationController Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXAnimationController
C# | public struct ID3DXAnimationController
C++ | public value class ID3DXAnimationController sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXAnimationSet Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXAnimationSet Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXAnimationSet
C# | public struct ID3DXAnimationSet
C++ | public value class ID3DXAnimationSet sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXBaseEffect Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXBaseEffect Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXBaseEffect
C# | public struct ID3DXBaseEffect
C++ | public value class ID3DXBaseEffect sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXBaseMesh Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXBaseMesh Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXBaseMesh
C# | public struct ID3DXBaseMesh
C++ | public value class ID3DXBaseMesh sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXBuffer Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXBuffer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXBuffer
C# | public struct ID3DXBuffer
C++ | public value class ID3DXBuffer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXCompressedAnimationSet Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXCompressedAnimationSet Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXCompressedAnimationSet
C# | public struct ID3DXCompressedAnimationSet
C++ | public value class ID3DXCompressedAnimationSet sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXConstantTable Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXConstantTable Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXConstantTable
C# | public struct ID3DXConstantTable
C++ | public value class ID3DXConstantTable sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXEffect Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXEffect Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXEffect
C# | public struct ID3DXEffect
C++ | public value class ID3DXEffect sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXEffectCompiler Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXEffectCompiler Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXEffectCompiler
C# | public struct ID3DXEffectCompiler
C++ | public value class ID3DXEffectCompiler sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXEffectPool Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXEffectPool Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXEffectPool
C# | public struct ID3DXEffectPool
C++ | public value class ID3DXEffectPool sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXEffectStateManager Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXEffectStateManager Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXEffectStateManager
C# | public struct ID3DXEffectStateManager
C++ | public value class ID3DXEffectStateManager sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXFile Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXFile Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXFile
C# | public struct ID3DXFile
C++ | public value class ID3DXFile sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXFileData Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXFileData Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXFileData
C# | public struct ID3DXFileData
C++ | public value class ID3DXFileData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXFileEnumObject Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXFileEnumObject Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXFileEnumObject
C# | public struct ID3DXFileEnumObject
C++ | public value class ID3DXFileEnumObject sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXFileSaveData Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXFileSaveData Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXFileSaveData
C# | public struct ID3DXFileSaveData
C++ | public value class ID3DXFileSaveData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXFileSaveObject Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXFileSaveObject Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXFileSaveObject
C# | public struct ID3DXFileSaveObject
C++ | public value class ID3DXFileSaveObject sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXFont Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXFont Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXFont
C# | public struct ID3DXFont
C++ | public value class ID3DXFont sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXFragmentLinker Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXFragmentLinker Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXFragmentLinker
C# | public struct ID3DXFragmentLinker
C++ | public value class ID3DXFragmentLinker sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXInclude Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXInclude Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXInclude
C# | public struct ID3DXInclude
C++ | public value class ID3DXInclude sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXKeyframedAnimationSet Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXKeyframedAnimationSet Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXKeyframedAnimationSet
C# | public struct ID3DXKeyframedAnimationSet
C++ | public value class ID3DXKeyframedAnimationSet sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXLine Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXLine Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXLine
C# | public struct ID3DXLine
C++ | public value class ID3DXLine sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXLoadUserData Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXLoadUserData Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXLoadUserData
C# | public struct ID3DXLoadUserData
C++ | public value class ID3DXLoadUserData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXMatrixStack Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXMatrixStack Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXMatrixStack
C# | public struct ID3DXMatrixStack
C++ | public value class ID3DXMatrixStack sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXMesh Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXMesh Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXMesh
C# | public struct ID3DXMesh
C++ | public value class ID3DXMesh sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXPatchMesh Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXPatchMesh Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXPatchMesh
C# | public struct ID3DXPatchMesh
C++ | public value class ID3DXPatchMesh sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXPMesh Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXPMesh Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXPMesh
C# | public struct ID3DXPMesh
C++ | public value class ID3DXPMesh sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXPRTBuffer Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXPRTBuffer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXPRTBuffer
C# | public struct ID3DXPRTBuffer
C++ | public value class ID3DXPRTBuffer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXPRTCompBuffer Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXPRTCompBuffer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXPRTCompBuffer
C# | public struct ID3DXPRTCompBuffer
C++ | public value class ID3DXPRTCompBuffer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXPRTEngine Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXPRTEngine Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXPRTEngine
C# | public struct ID3DXPRTEngine
C++ | public value class ID3DXPRTEngine sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXRenderToEnvMap Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXRenderToEnvMap Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXRenderToEnvMap
C# | public struct ID3DXRenderToEnvMap
C++ | public value class ID3DXRenderToEnvMap sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXRenderToSurface Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXRenderToSurface Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXRenderToSurface
C# | public struct ID3DXRenderToSurface
C++ | public value class ID3DXRenderToSurface sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXSaveUserData Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXSaveUserData Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXSaveUserData
C# | public struct ID3DXSaveUserData
C++ | public value class ID3DXSaveUserData sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXSkinInfo Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXSkinInfo Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXSkinInfo
C# | public struct ID3DXSkinInfo
C++ | public value class ID3DXSkinInfo sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXSPMesh Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXSPMesh Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXSPMesh
C# | public struct ID3DXSPMesh
C++ | public value class ID3DXSPMesh sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXSprite Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXSprite Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXSprite
C# | public struct ID3DXSprite
C++ | public value class ID3DXSprite sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXTextureGutterHelper Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXTextureGutterHelper Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXTextureGutterHelper
C# | public struct ID3DXTextureGutterHelper
C++ | public value class ID3DXTextureGutterHelper sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ID3DXTextureShader Structure (Microsoft.DirectX.PrivateImplementationDetails)

ID3DXTextureShader Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ID3DXTextureShader
C# | public struct ID3DXTextureShader
C++ | public value class ID3DXTextureShader sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3D9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3D9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3D9
C# | public struct IDirect3D9
C++ | public value class IDirect3D9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DBaseTexture9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DBaseTexture9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DBaseTexture9
C# | public struct IDirect3DBaseTexture9
C++ | public value class IDirect3DBaseTexture9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DCubeTexture9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DCubeTexture9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DCubeTexture9
C# | public struct IDirect3DCubeTexture9
C++ | public value class IDirect3DCubeTexture9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DDevice9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DDevice9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DDevice9
C# | public struct IDirect3DDevice9
C++ | public value class IDirect3DDevice9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DIndexBuffer9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DIndexBuffer9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DIndexBuffer9
C# | public struct IDirect3DIndexBuffer9
C++ | public value class IDirect3DIndexBuffer9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DPixelShader9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DPixelShader9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DPixelShader9
C# | public struct IDirect3DPixelShader9
C++ | public value class IDirect3DPixelShader9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DQuery9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DQuery9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DQuery9
C# | public struct IDirect3DQuery9
C++ | public value class IDirect3DQuery9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DResource9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DResource9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DResource9
C# | public struct IDirect3DResource9
C++ | public value class IDirect3DResource9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DStateBlock9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DStateBlock9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DStateBlock9
C# | public struct IDirect3DStateBlock9
C++ | public value class IDirect3DStateBlock9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DSurface9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DSurface9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DSurface9
C# | public struct IDirect3DSurface9
C++ | public value class IDirect3DSurface9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DSwapChain9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DSwapChain9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DSwapChain9
C# | public struct IDirect3DSwapChain9
C++ | public value class IDirect3DSwapChain9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DTexture9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DTexture9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DTexture9
C# | public struct IDirect3DTexture9
C++ | public value class IDirect3DTexture9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.AudioVideoPlayback (microsoft.directx.audiovideoplayback.dll)
Strong Name | Microsoft.DirectX.AudioVideoPlayback, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DVertexBuffer9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DVertexBuffer9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DVertexBuffer9
C# | public struct IDirect3DVertexBuffer9
C++ | public value class IDirect3DVertexBuffer9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DVertexDeclaration9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DVertexDeclaration9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DVertexDeclaration9
C# | public struct IDirect3DVertexDeclaration9
C++ | public value class IDirect3DVertexDeclaration9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DVertexShader9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DVertexShader9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DVertexShader9
C# | public struct IDirect3DVertexShader9
C++ | public value class IDirect3DVertexShader9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DVolume9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DVolume9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DVolume9
C# | public struct IDirect3DVolume9
C++ | public value class IDirect3DVolume9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirect3DVolumeTexture9 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirect3DVolumeTexture9 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirect3DVolumeTexture9
C# | public struct IDirect3DVolumeTexture9
C++ | public value class IDirect3DVolumeTexture9 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectDraw7 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectDraw7 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectDraw7
C# | public struct IDirectDraw7
C++ | public value class IDirectDraw7 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectDrawClipper Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectDrawClipper Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectDrawClipper
C# | public struct IDirectDrawClipper
C++ | public value class IDirectDrawClipper sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectDrawColorControl Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectDrawColorControl Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectDrawColorControl
C# | public struct IDirectDrawColorControl
C++ | public value class IDirectDrawColorControl sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectDrawGammaControl Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectDrawGammaControl Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectDrawGammaControl
C# | public struct IDirectDrawGammaControl
C++ | public value class IDirectDrawGammaControl sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectDrawPalette Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectDrawPalette Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectDrawPalette
C# | public struct IDirectDrawPalette
C++ | public value class IDirectDrawPalette sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectDrawSurface7 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectDrawSurface7 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectDrawSurface7
C# | public struct IDirectDrawSurface7
C++ | public value class IDirectDrawSurface7 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectInput8A Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectInput8A Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectInput8A
C# | public struct IDirectInput8A
C++ | public value class IDirectInput8A sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectInputDevice8A Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectInputDevice8A Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectInputDevice8A
C# | public struct IDirectInputDevice8A
C++ | public value class IDirectInputDevice8A sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectInputEffect Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectInputEffect Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectInputEffect
C# | public struct IDirectInputEffect
C++ | public value class IDirectInputEffect sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectInput (microsoft.directx.directinput.dll)
Strong Name | Microsoft.DirectX.DirectInput, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlay8Address Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlay8Address Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlay8Address
C# | public struct IDirectPlay8Address
C++ | public value class IDirectPlay8Address sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlay8Client Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlay8Client Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlay8Client
C# | public struct IDirectPlay8Client
C++ | public value class IDirectPlay8Client sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlay8LobbiedApplication Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlay8LobbiedApplication Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlay8LobbiedApplication
C# | public struct IDirectPlay8LobbiedApplication
C++ | public value class IDirectPlay8LobbiedApplication sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlay8LobbyClient Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlay8LobbyClient Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlay8LobbyClient
C# | public struct IDirectPlay8LobbyClient
C++ | public value class IDirectPlay8LobbyClient sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlay8NATResolver Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlay8NATResolver Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlay8NATResolver
C# | public struct IDirectPlay8NATResolver
C++ | public value class IDirectPlay8NATResolver sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlay8Peer Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlay8Peer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlay8Peer
C# | public struct IDirectPlay8Peer
C++ | public value class IDirectPlay8Peer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlay8Server Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlay8Server Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlay8Server
C# | public struct IDirectPlay8Server
C++ | public value class IDirectPlay8Server sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlay8ThreadPool Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlay8ThreadPool Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlay8ThreadPool
C# | public struct IDirectPlay8ThreadPool
C++ | public value class IDirectPlay8ThreadPool sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlayVoiceClient Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlayVoiceClient Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlayVoiceClient
C# | public struct IDirectPlayVoiceClient
C++ | public value class IDirectPlayVoiceClient sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlayVoiceServer Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlayVoiceServer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlayVoiceServer
C# | public struct IDirectPlayVoiceServer
C++ | public value class IDirectPlayVoiceServer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectPlayVoiceTest Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectPlayVoiceTest Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectPlayVoiceTest
C# | public struct IDirectPlayVoiceTest
C++ | public value class IDirectPlayVoiceTest sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSound Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSound Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSound
C# | public struct IDirectSound
C++ | public value class IDirectSound sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSound3DBuffer Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSound3DBuffer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSound3DBuffer
C# | public struct IDirectSound3DBuffer
C++ | public value class IDirectSound3DBuffer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSound3DListener Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSound3DListener Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSound3DListener
C# | public struct IDirectSound3DListener
C++ | public value class IDirectSound3DListener sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSound8 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSound8 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSound8
C# | public struct IDirectSound8
C++ | public value class IDirectSound8 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundBuffer Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundBuffer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundBuffer
C# | public struct IDirectSoundBuffer
C++ | public value class IDirectSoundBuffer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundBuffer8 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundBuffer8 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundBuffer8
C# | public struct IDirectSoundBuffer8
C++ | public value class IDirectSoundBuffer8 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectPlay (microsoft.directx.directplay.dll)
Strong Name | Microsoft.DirectX.DirectPlay, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundCapture Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundCapture Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundCapture
C# | public struct IDirectSoundCapture
C++ | public value class IDirectSoundCapture sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundCaptureBuffer Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundCaptureBuffer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundCaptureBuffer
C# | public struct IDirectSoundCaptureBuffer
C++ | public value class IDirectSoundCaptureBuffer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundCaptureBuffer8 Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundCaptureBuffer8 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundCaptureBuffer8
C# | public struct IDirectSoundCaptureBuffer8
C++ | public value class IDirectSoundCaptureBuffer8 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundCaptureFXAec Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundCaptureFXAec Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundCaptureFXAec
C# | public struct IDirectSoundCaptureFXAec
C++ | public value class IDirectSoundCaptureFXAec sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundCaptureFXNoiseSuppress Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundCaptureFXNoiseSuppress Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundCaptureFXNoiseSuppress
C# | public struct IDirectSoundCaptureFXNoiseSuppress
C++ | public value class IDirectSoundCaptureFXNoiseSuppress sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFullDuplex Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFullDuplex Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFullDuplex
C# | public struct IDirectSoundFullDuplex
C++ | public value class IDirectSoundFullDuplex sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXChorus Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXChorus Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXChorus
C# | public struct IDirectSoundFXChorus
C++ | public value class IDirectSoundFXChorus sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXCompressor Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXCompressor Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXCompressor
C# | public struct IDirectSoundFXCompressor
C++ | public value class IDirectSoundFXCompressor sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXDistortion Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXDistortion Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXDistortion
C# | public struct IDirectSoundFXDistortion
C++ | public value class IDirectSoundFXDistortion sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXEcho Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXEcho Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXEcho
C# | public struct IDirectSoundFXEcho
C++ | public value class IDirectSoundFXEcho sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXFlanger Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXFlanger Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXFlanger
C# | public struct IDirectSoundFXFlanger
C++ | public value class IDirectSoundFXFlanger sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXGargle Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXGargle Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXGargle
C# | public struct IDirectSoundFXGargle
C++ | public value class IDirectSoundFXGargle sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXI3DL2Reverb Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXI3DL2Reverb Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXI3DL2Reverb
C# | public struct IDirectSoundFXI3DL2Reverb
C++ | public value class IDirectSoundFXI3DL2Reverb sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXParamEq Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXParamEq Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXParamEq
C# | public struct IDirectSoundFXParamEq
C++ | public value class IDirectSoundFXParamEq sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundFXWavesReverb Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundFXWavesReverb Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundFXWavesReverb
C# | public struct IDirectSoundFXWavesReverb
C++ | public value class IDirectSoundFXWavesReverb sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDirectSoundNotify Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDirectSoundNotify Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDirectSoundNotify
C# | public struct IDirectSoundNotify
C++ | public value class IDirectSoundNotify sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDxDiagContainer Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDxDiagContainer Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDxDiagContainer
C# | public struct IDxDiagContainer
C++ | public value class IDxDiagContainer sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IDxDiagProvider Structure (Microsoft.DirectX.PrivateImplementationDetails)

IDxDiagProvider Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IDxDiagProvider
C# | public struct IDxDiagProvider
C++ | public value class IDxDiagProvider sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


IUnknown Structure (Microsoft.DirectX.PrivateImplementationDetails)

IUnknown Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure IUnknown
C# | public struct IUnknown
C++ | public value class IUnknown sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


ManagedD3DXEffectStateManager Structure (Microsoft.DirectX.PrivateImplementationDetails)

ManagedD3DXEffectStateManager Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure ManagedD3DXEffectStateManager
C# | public struct ManagedD3DXEffectStateManager
C++ | public value class ManagedD3DXEffectStateManager sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


pcmwaveformat_tag Structure (Microsoft.DirectX.PrivateImplementationDetails)

pcmwaveformat_tag Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure pcmwaveformat_tag
C# | public struct pcmwaveformat_tag
C++ | public value class pcmwaveformat_tag sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tACMSTREAMHEADER Structure (Microsoft.DirectX.PrivateImplementationDetails)

tACMSTREAMHEADER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tACMSTREAMHEADER
C# | public struct tACMSTREAMHEADER
C++ | public value class tACMSTREAMHEADER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagBITMAP Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagBITMAP Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagBITMAP
C# | public struct tagBITMAP
C++ | public value class tagBITMAP sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagBITMAPFILEHEADER Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagBITMAPFILEHEADER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagBITMAPFILEHEADER
C# | public struct tagBITMAPFILEHEADER
C++ | public value class tagBITMAPFILEHEADER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagBITMAPINFO Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagBITMAPINFO Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagBITMAPINFO
C# | public struct tagBITMAPINFO
C++ | public value class tagBITMAPINFO sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagBITMAPINFOHEADER Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagBITMAPINFOHEADER Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagBITMAPINFOHEADER
C# | public struct tagBITMAPINFOHEADER
C++ | public value class tagBITMAPINFOHEADER sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagDDDEVICEIDENTIFIER2 Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagDDDEVICEIDENTIFIER2 Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagDDDEVICEIDENTIFIER2
C# | public struct tagDDDEVICEIDENTIFIER2
C++ | public value class tagDDDEVICEIDENTIFIER2 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagLOGBRUSH Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagLOGBRUSH Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagLOGBRUSH
C# | public struct tagLOGBRUSH
C++ | public value class tagLOGBRUSH sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectDraw (microsoft.directx.directdraw.dll)
Strong Name | Microsoft.DirectX.DirectDraw, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagMSG Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagMSG Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagMSG
C# | public struct tagMSG
C++ | public value class tagMSG sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


tagPALETTEENTRY Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagPALETTEENTRY Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagPALETTEENTRY
C# | public struct tagPALETTEENTRY
C++ | public value class tagPALETTEENTRY sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagPOINT Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagPOINT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagPOINT
C# | public struct tagPOINT
C++ | public value class tagPOINT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagPROPVARIANT Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagPROPVARIANT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagPROPVARIANT
C# | public struct tagPROPVARIANT
C++ | public value class tagPROPVARIANT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagRECT Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagRECT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagRECT
C# | public struct tagRECT
C++ | public value class tagRECT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3D (microsoft.directx.direct3d.dll)
Strong Name | Microsoft.DirectX.Direct3D, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tagTEXTMETRICA Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagTEXTMETRICA Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagTEXTMETRICA
C# | public struct tagTEXTMETRICA
C++ | public value class tagTEXTMETRICA sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Direct3DX (microsoft.directx.direct3dx.dll)
Strong Name | Microsoft.DirectX.Direct3DX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


tagVARIANT Structure (Microsoft.DirectX.PrivateImplementationDetails)

tagVARIANT Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tagVARIANT
C# | public struct tagVARIANT
C++ | public value class tagVARIANT sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.Diagnostics (microsoft.directx.diagnostics.dll)
Strong Name | Microsoft.DirectX.Diagnostics, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


tWAVEFORMATEX Structure (Microsoft.DirectX.PrivateImplementationDetails)

tWAVEFORMATEX Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure tWAVEFORMATEX
C# | public struct tWAVEFORMATEX
C++ | public value class tWAVEFORMATEX sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


wavefilter_tag Structure (Microsoft.DirectX.PrivateImplementationDetails)

wavefilter_tag Structure

Allows the managed application programming interface (API) to have access to the unmanaged portions of the Microsoft DirectX API. This is not intended to be used directly from your code.

Definition

Visual Basic | Public Structure wavefilter_tag
C# | public struct wavefilter_tag
C++ | public value class wavefilter_tag sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Structure Information

Namespace | Microsoft.DirectX.PrivateImplementationDetails
Assembly | Microsoft.DirectX.DirectSound (microsoft.directx.directsound.dll)
Strong Name | Microsoft.DirectX.DirectSound, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Microsoft.DirectX.Security.Permissions

Allows security actions to be applied to code using declarative security. The following tables list the members exposed by the Microsoft.DirectX.Security.Permissions namespace.

Classes

GraphicsPermissionAttribute | Allows security actions for GraphicsPermission to be applied to code using declarative security.
InputPermissionAttribute | Allows security actions for InputPermission to be applied to code using declarative security.
NetworkPermissionAttribute | Allows security actions for NetworkPermission to be applied to code using declarative security.
SoundPermissionAttribute | Allows security actions for SoundPermission to be applied to code using declarative security.


GraphicsPermissionAttribute Class (Microsoft.DirectX.Security.Permissions)

GraphicsPermissionAttribute Class

Allows security actions for GraphicsPermission to be applied to code using declarative security.

Definition

Visual Basic NotInheritable Public Class GraphicsPermissionAttribute
Inherits CodeAccessSecurityAttribute
C# | public sealed class GraphicsPermissionAttribute : CodeAccessSecurityAttribute
C++ | public ref class GraphicsPermissionAttribute sealed : CodeAccessSecurityAttribute
JScript | public final class GraphicsPermissionAttribute extends CodeAccessSecurityAttribute

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CreatePermission | Creates a new permission.
GraphicsPermissionAttribute | Initializes a new instance of the object.

Properties

Property | Description
Use | Gets or sets the type of access.

Inheritance Hierarchy

Object Leave Site
Attribute Leave Site
SecurityAttribute Leave Site
CodeAccessSecurityAttribute Leave Site
GraphicsPermissionAttribute

Class Information

Namespace | Microsoft.DirectX.Security.Permissions
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GraphicsPermissionAttribute.CreatePermission() Method (Microsoft.DirectX.Security.Permissions)

GraphicsPermissionAttribute.CreatePermission Method

Creates a new permission.

Definition

Visual Basic | Overrides Public Function CreatePermission() As IPermission
C# | public override IPermission CreatePermission();
C++ public:
virtual IPermission^ CreatePermission() override;
JScript | public override function CreatePermission() : IPermission;

Return Value

System.Security.IPermission


GraphicsPermissionAttribute.GraphicsPermissionAttribute(SecurityAction) Constructor (Microsoft.DirectX.Security.Permissions)

GraphicsPermissionAttribute.GraphicsPermissionAttribute Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal action As SecurityAction _
)
C# public GraphicsPermissionAttribute(
SecurityAction action
);
C++ public:
GraphicsPermissionAttribute(
SecurityAction action
);
JScript public function GraphicsPermissionAttribute(
action : SecurityAction
);

Parameters

action System.Security.Permissions.SecurityAction


GraphicsPermissionAttribute.Use Property (Microsoft.DirectX.Security.Permissions)

GraphicsPermissionAttribute.Use Property

Gets or sets the type of access.

Definition

Visual Basic | Public Property Use As Boolean
C# | public bool Use { get; set; }
C++ public:
property bool Use {
bool get();
void set(bool value);
}
JScript public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean

This property is read/write.


InputPermissionAttribute Class (Microsoft.DirectX.Security.Permissions)

InputPermissionAttribute Class

Allows security actions for InputPermission to be applied to code using declarative security.

Definition

Visual Basic NotInheritable Public Class InputPermissionAttribute
Inherits CodeAccessSecurityAttribute
C# | public sealed class InputPermissionAttribute : CodeAccessSecurityAttribute
C++ | public ref class InputPermissionAttribute sealed : CodeAccessSecurityAttribute
JScript | public final class InputPermissionAttribute extends CodeAccessSecurityAttribute

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CreatePermission | Creates a new permission.
InputPermissionAttribute | Initializes a new instance of the object.

Properties

Property | Description
Use | Gets or sets the type of access.

Inheritance Hierarchy

Object Leave Site
Attribute Leave Site
SecurityAttribute Leave Site
CodeAccessSecurityAttribute Leave Site
InputPermissionAttribute

Class Information

Namespace | Microsoft.DirectX.Security.Permissions
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputPermissionAttribute.CreatePermission() Method (Microsoft.DirectX.Security.Permissions)

InputPermissionAttribute.CreatePermission Method

Creates a new permission.

Definition

Visual Basic | Overrides Public Function CreatePermission() As IPermission
C# | public override IPermission CreatePermission();
C++ public:
virtual IPermission^ CreatePermission() override;
JScript | public override function CreatePermission() : IPermission;

Return Value

System.Security.IPermission


InputPermissionAttribute.InputPermissionAttribute(SecurityAction) Constructor (Microsoft.DirectX.Security.Permissions)

InputPermissionAttribute.InputPermissionAttribute Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal action As SecurityAction _
)
C# public InputPermissionAttribute(
SecurityAction action
);
C++ public:
InputPermissionAttribute(
SecurityAction action
);
JScript public function InputPermissionAttribute(
action : SecurityAction
);

Parameters

action System.Security.Permissions.SecurityAction


InputPermissionAttribute.Use Property (Microsoft.DirectX.Security.Permissions)

InputPermissionAttribute.Use Property

Gets or sets the type of access.

Definition

Visual Basic | Public Property Use As Boolean
C# | public bool Use { get; set; }
C++ public:
property bool Use {
bool get();
void set(bool value);
}
JScript public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean

This property is read/write.


NetworkPermissionAttribute Class (Microsoft.DirectX.Security.Permissions)

NetworkPermissionAttribute Class

Allows security actions for NetworkPermission to be applied to code using declarative security.

Definition

Visual Basic NotInheritable Public Class NetworkPermissionAttribute
Inherits CodeAccessSecurityAttribute
C# | public sealed class NetworkPermissionAttribute : CodeAccessSecurityAttribute
C++ | public ref class NetworkPermissionAttribute sealed : CodeAccessSecurityAttribute
JScript | public final class NetworkPermissionAttribute extends CodeAccessSecurityAttribute

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CreatePermission | Create a new permission.
NetworkPermissionAttribute | Initializes a new instance of the object.

Properties

Property | Description
Host | Gets or sets the type of access.
Join | Gets or sets the type of access.

Inheritance Hierarchy

Object Leave Site
Attribute Leave Site
SecurityAttribute Leave Site
CodeAccessSecurityAttribute Leave Site
NetworkPermissionAttribute

Class Information

Namespace | Microsoft.DirectX.Security.Permissions
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NetworkPermissionAttribute.CreatePermission() Method (Microsoft.DirectX.Security.Permissions)

NetworkPermissionAttribute.CreatePermission Method

Create a new permission.

Definition

Visual Basic | Overrides Public Function CreatePermission() As IPermission
C# | public override IPermission CreatePermission();
C++ public:
virtual IPermission^ CreatePermission() override;
JScript | public override function CreatePermission() : IPermission;

Return Value

System.Security.IPermission


NetworkPermissionAttribute.NetworkPermissionAttribute(SecurityAction) Constructor (Microsoft.DirectX.Security.Permissions)

NetworkPermissionAttribute.NetworkPermissionAttribute Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal action As SecurityAction _
)
C# public NetworkPermissionAttribute(
SecurityAction action
);
C++ public:
NetworkPermissionAttribute(
SecurityAction action
);
JScript public function NetworkPermissionAttribute(
action : SecurityAction
);

Parameters

action System.Security.Permissions.SecurityAction


NetworkPermissionAttribute.Host Property (Microsoft.DirectX.Security.Permissions)

NetworkPermissionAttribute.Host Property

Gets or sets the type of access.

Definition

Visual Basic | Public Property Host As Boolean
C# | public bool Host { get; set; }
C++ public:
property bool Host {
bool get();
void set(bool value);
}
JScript public function get Host() : boolean
public function set Host(boolean);

Property Value

System.Boolean

This property is read/write.


NetworkPermissionAttribute.Join Property (Microsoft.DirectX.Security.Permissions)

NetworkPermissionAttribute.Join Property

Gets or sets the type of access.

Definition

Visual Basic | Public Property Join As Boolean
C# | public bool Join { get; set; }
C++ public:
property bool Join {
bool get();
void set(bool value);
}
JScript public function get Join() : boolean
public function set Join(boolean);

Property Value

System.Boolean

This property is read/write.


SoundPermissionAttribute Class (Microsoft.DirectX.Security.Permissions)

SoundPermissionAttribute Class

Allows security actions for SoundPermission to be applied to code using declarative security.

Definition

Visual Basic NotInheritable Public Class SoundPermissionAttribute
Inherits CodeAccessSecurityAttribute
C# | public sealed class SoundPermissionAttribute : CodeAccessSecurityAttribute
C++ | public ref class SoundPermissionAttribute sealed : CodeAccessSecurityAttribute
JScript | public final class SoundPermissionAttribute extends CodeAccessSecurityAttribute

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
CreatePermission | Creates a new permission.
SoundPermissionAttribute | Initializes a new instance of the object.

Properties

Property | Description
Use | Gets or sets the type of access.
UseCapture | Gets or sets the type of access.

Inheritance Hierarchy

Object Leave Site
Attribute Leave Site
SecurityAttribute Leave Site
CodeAccessSecurityAttribute Leave Site
SoundPermissionAttribute

Class Information

Namespace | Microsoft.DirectX.Security.Permissions
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SoundPermissionAttribute.CreatePermission() Method (Microsoft.DirectX.Security.Permissions)

SoundPermissionAttribute.CreatePermission Method

Creates a new permission.

Definition

Visual Basic | Overrides Public Function CreatePermission() As IPermission
C# | public override IPermission CreatePermission();
C++ public:
virtual IPermission^ CreatePermission() override;
JScript | public override function CreatePermission() : IPermission;

Return Value

System.Security.IPermission


SoundPermissionAttribute.SoundPermissionAttribute(SecurityAction) Constructor (Microsoft.DirectX.Security.Permissions)

SoundPermissionAttribute.SoundPermissionAttribute Constructor

 Language:

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal action As SecurityAction _
)
C# public SoundPermissionAttribute(
SecurityAction action
);
C++ public:
SoundPermissionAttribute(
SecurityAction action
);
JScript public function SoundPermissionAttribute(
action : SecurityAction
);

Parameters

action System.Security.Permissions.SecurityAction


SoundPermissionAttribute.Use Property (Microsoft.DirectX.Security.Permissions)

SoundPermissionAttribute.Use Property

Gets or sets the type of access.

Definition

Visual Basic | Public Property Use As Boolean
C# | public bool Use { get; set; }
C++ public:
property bool Use {
bool get();
void set(bool value);
}
JScript public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean

This property is read/write.


SoundPermissionAttribute.UseCapture Property (Microsoft.DirectX.Security.Permissions)

SoundPermissionAttribute.UseCapture Property

Gets or sets the type of access.

Definition

Visual Basic | Public Property UseCapture As Boolean
C# | public bool UseCapture { get; set; }
C++ public:
property bool UseCapture {
bool get();
void set(bool value);
}
JScript public function get UseCapture() : boolean
public function set UseCapture(boolean);

Property Value

System.Boolean

This property is read/write.


Microsoft.DirectX.Security

Controls permissions related to Microsoft Direct3D, Microsoft DirectInput, Microsoft DirectPlay, and Microsoft DirectSound. The following tables list the members exposed by the Microsoft.DirectX.Security namespace.

Classes

GraphicsPermission | Controls the permissions related to DirectX Graphics.
InputPermission | Controls the permissions related to DirectInput.
NetworkPermission | Controls the permissions related DirectPlay.
SoundPermission | Controls the permissions related DirectX Audio.


GraphicsPermission Class (Microsoft.DirectX.Security)

GraphicsPermission Class

Controls the permissions related to DirectX Graphics.

Definition

Visual Basic NotInheritable Public Class GraphicsPermission
Inherits CodeAccessPermission
Implements IUnrestrictedPermission
C# | public sealed class GraphicsPermission : CodeAccessPermission, IUnrestrictedPermission
C++ | public ref class GraphicsPermission sealed : CodeAccessPermission, IUnrestrictedPermission
JScript | public final class GraphicsPermission extends CodeAccessPermission implements IUnrestrictedPermission

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Copy | Creates and returns an identical copy of the current permission.
FromXml | Reconstructs a permission with a specified state from an XML encoding.
GraphicsPermission | Initializes a new instance of the object.
Intersect | Creates and returns a permission that is the intersection of the current permission and the specified permission.
IsSubsetOf | Determines whether the current permission is a subset of the specified permission.
IsUnrestricted | Returns a value indicating whether the current permission is unrestricted.
ToXml | Creates an XML encoding of the permission and its current state.
Union | Creates a permission that is the union of the permission and the specified permission.

Properties

Property | Description
Use | Gets or sets the access represented by the permission.

Inheritance Hierarchy

Object Leave Site
CodeAccessPermission Leave Site
GraphicsPermission

Class Information

Namespace | Microsoft.DirectX.Security
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GraphicsPermission.Copy() Method (Microsoft.DirectX.Security)

GraphicsPermission.Copy Method

Creates and returns an identical copy of the current permission.

Definition

Visual Basic | Overrides Public Function Copy() As IPermission
C# | public override IPermission Copy();
C++ public:
virtual IPermission^ Copy() override;
JScript | public override function Copy() : IPermission;

Return Value

System.Security.IPermission


GraphicsPermission.FromXml(SecurityElement) Method (Microsoft.DirectX.Security)

GraphicsPermission.FromXml Method

Reconstructs a permission with a specified state from an XML encoding.

Definition

Visual Basic Overrides Public Sub FromXml( _
ByVal securityElement As SecurityElement _
)
C# public override void FromXml(
SecurityElement securityElement
);
C++ public:
virtual void FromXml(
SecurityElement^ securityElement
) override;
JScript public override function FromXml(
securityElement : SecurityElement
);

Parameters

securityElement System.Security.SecurityElement


GraphicsPermission.GraphicsPermission Constructor ()

Initializes a new instance of the object.

Overload List

public GraphicsPermission(bool);
public GraphicsPermission(PermissionState);


GraphicsPermission.GraphicsPermission(Boolean) Constructor (Microsoft.DirectX.Security)

GraphicsPermission.GraphicsPermission Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal canUse As Boolean _
)
C# public GraphicsPermission(
bool canUse
);
C++ public:
GraphicsPermission(
bool canUse
);
JScript public function GraphicsPermission(
canUse : boolean
);

Parameters

canUse System.Boolean


GraphicsPermission.GraphicsPermission(PermissionState) Constructor (Microsoft.DirectX.Security)

GraphicsPermission.GraphicsPermission Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal state As PermissionState _
)
C# public GraphicsPermission(
PermissionState state
);
C++ public:
GraphicsPermission(
PermissionState state
);
JScript public function GraphicsPermission(
state : PermissionState
);

Parameters

state System.Security.Permissions.PermissionState


GraphicsPermission.Intersect(IPermission) Method (Microsoft.DirectX.Security)

GraphicsPermission.Intersect Method

Creates and returns a permission that is the intersection of the current permission and the specified permission.

Definition

Visual Basic Overrides Public Function Intersect( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Intersect(
IPermission target
);
C++ public:
virtual IPermission^ Intersect(
IPermission^ target
) override;
JScript public override function Intersect(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission

Return Value

System.Security.IPermission


GraphicsPermission.IsSubsetOf(IPermission) Method (Microsoft.DirectX.Security)

GraphicsPermission.IsSubsetOf Method

Determines whether the current permission is a subset of the specified permission.

Definition

Visual Basic Overrides Public Function IsSubsetOf( _
ByVal target As IPermission _
) As Boolean
C# public override bool IsSubsetOf(
IPermission target
);
C++ public:
virtual bool IsSubsetOf(
IPermission^ target
) override;
JScript public override function IsSubsetOf(
target : IPermission
) : boolean;

Parameters

target System.Security.IPermission

Return Value

System.Boolean


GraphicsPermission.IsUnrestricted() Method (Microsoft.DirectX.Security)

GraphicsPermission.IsUnrestricted Method

Returns a value indicating whether the current permission is unrestricted.

Definition

Visual Basic | Overrides Public Function IsUnrestricted() As Boolean
C# | public override bool IsUnrestricted();
C++ public:
virtual bool IsUnrestricted() override;
JScript | public override function IsUnrestricted() : boolean;

Return Value

System.Boolean


GraphicsPermission.ToXml() Method (Microsoft.DirectX.Security)

GraphicsPermission.ToXml Method

Creates an XML encoding of the permission and its current state.

Definition

Visual Basic | Overrides Public Function ToXml() As SecurityElement
C# | public override SecurityElement ToXml();
C++ public:
virtual SecurityElement^ ToXml() override;
JScript | public override function ToXml() : SecurityElement;

Return Value

System.Security.SecurityElement


GraphicsPermission.Union(IPermission) Method (Microsoft.DirectX.Security)

GraphicsPermission.Union Method

Creates a permission that is the union of the permission and the specified permission.

Definition

Visual Basic Overrides Public Function Union( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Union(
IPermission target
);
C++ public:
virtual IPermission^ Union(
IPermission^ target
) override;
JScript public override function Union(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission

Return Value

System.Security.IPermission


GraphicsPermission.Use Property (Microsoft.DirectX.Security)

GraphicsPermission.Use Property

Gets or sets the access represented by the permission.

Definition

Visual Basic | Public Property Use As Boolean
C# | public bool Use { get; set; }
C++ public:
property bool Use {
bool get();
void set(bool value);
}
JScript public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean

This property is read/write.


InputPermission Class (Microsoft.DirectX.Security)

InputPermission Class

Controls the permissions related to DirectInput.

Definition

Visual Basic NotInheritable Public Class InputPermission
Inherits CodeAccessPermission
Implements IUnrestrictedPermission
C# | public sealed class InputPermission : CodeAccessPermission, IUnrestrictedPermission
C++ | public ref class InputPermission sealed : CodeAccessPermission, IUnrestrictedPermission
JScript | public final class InputPermission extends CodeAccessPermission implements IUnrestrictedPermission

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Copy | Creates and returns an identical copy of the current permission.
FromXml | Reconstructs a permission with a specified state from an XML encoding.
InputPermission | Initializes a new instance of the object.
Intersect | Creates and returns a permission that is the intersection of the current permission and the specified permission.
IsSubsetOf | Determines whether the current permission is a subset of the specified permission.
IsUnrestricted | Returns a value indicating whether the current permission is unrestricted.
ToXml | Creates an XML encoding of the permission and its current state.
Union | Creates a permission that is the union of the permission and the specified permission.

Properties

Property | Description
Use | Gets or sets the access represented by the permission.

Inheritance Hierarchy

Object Leave Site
CodeAccessPermission Leave Site
InputPermission

Class Information

Namespace | Microsoft.DirectX.Security
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


InputPermission.Copy() Method (Microsoft.DirectX.Security)

InputPermission.Copy Method

Creates and returns an identical copy of the current permission.

Definition

Visual Basic | Overrides Public Function Copy() As IPermission
C# | public override IPermission Copy();
C++ public:
virtual IPermission^ Copy() override;
JScript | public override function Copy() : IPermission;

Return Value

System.Security.IPermission


InputPermission.FromXml(SecurityElement) Method (Microsoft.DirectX.Security)

InputPermission.FromXml Method

Reconstructs a permission with a specified state from an XML encoding.

Definition

Visual Basic Overrides Public Sub FromXml( _
ByVal securityElement As SecurityElement _
)
C# public override void FromXml(
SecurityElement securityElement
);
C++ public:
virtual void FromXml(
SecurityElement^ securityElement
) override;
JScript public override function FromXml(
securityElement : SecurityElement
);

Parameters

securityElement System.Security.SecurityElement


InputPermission.InputPermission(PermissionState) Constructor (Microsoft.DirectX.Security)

InputPermission.InputPermission Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal state As PermissionState _
)
C# public InputPermission(
PermissionState state
);
C++ public:
InputPermission(
PermissionState state
);
JScript public function InputPermission(
state : PermissionState
);

Parameters

state System.Security.Permissions.PermissionState


InputPermission.Intersect(IPermission) Method (Microsoft.DirectX.Security)

InputPermission.Intersect Method

Creates and returns a permission that is the intersection of the current permission and the specified permission.

Definition

Visual Basic Overrides Public Function Intersect( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Intersect(
IPermission target
);
C++ public:
virtual IPermission^ Intersect(
IPermission^ target
) override;
JScript public override function Intersect(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission

Return Value

System.Security.IPermission


InputPermission.IsSubsetOf(IPermission) Method (Microsoft.DirectX.Security)

InputPermission.IsSubsetOf Method

Determines whether the current permission is a subset of the specified permission.

Definition

Visual Basic Overrides Public Function IsSubsetOf( _
ByVal target As IPermission _
) As Boolean
C# public override bool IsSubsetOf(
IPermission target
);
C++ public:
virtual bool IsSubsetOf(
IPermission^ target
) override;
JScript public override function IsSubsetOf(
target : IPermission
) : boolean;

Parameters

target System.Security.IPermission

Return Value

System.Boolean


InputPermission.IsUnrestricted() Method (Microsoft.DirectX.Security)

InputPermission.IsUnrestricted Method

Returns a value indicating whether the current permission is unrestricted.

Definition

Visual Basic | Overrides Public Function IsUnrestricted() As Boolean
C# | public override bool IsUnrestricted();
C++ public:
virtual bool IsUnrestricted() override;
JScript | public override function IsUnrestricted() : boolean;

Return Value

System.Boolean


InputPermission.ToXml() Method (Microsoft.DirectX.Security)

InputPermission.ToXml Method

Creates an XML encoding of the permission and its current state.

Definition

Visual Basic | Overrides Public Function ToXml() As SecurityElement
C# | public override SecurityElement ToXml();
C++ public:
virtual SecurityElement^ ToXml() override;
JScript | public override function ToXml() : SecurityElement;

Return Value

System.Security.SecurityElement


InputPermission.Union(IPermission) Method (Microsoft.DirectX.Security)

InputPermission.Union Method

Creates a permission that is the union of the permission and the specified permission.

Definition

Visual Basic Overrides Public Function Union( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Union(
IPermission target
);
C++ public:
virtual IPermission^ Union(
IPermission^ target
) override;
JScript public override function Union(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission

Return Value

System.Security.IPermission


InputPermission.Use Property (Microsoft.DirectX.Security)

InputPermission.Use Property

Gets or sets the access represented by the permission.

Definition

Visual Basic | Public Property Use As Boolean
C# | public bool Use { get; set; }
C++ public:
property bool Use {
bool get();
void set(bool value);
}
JScript public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean

This property is read/write.


NetworkPermission Class (Microsoft.DirectX.Security)

NetworkPermission Class

Controls the permissions related DirectPlay.

Definition

Visual Basic NotInheritable Public Class NetworkPermission
Inherits CodeAccessPermission
Implements IUnrestrictedPermission
C# | public sealed class NetworkPermission : CodeAccessPermission, IUnrestrictedPermission
C++ | public ref class NetworkPermission sealed : CodeAccessPermission, IUnrestrictedPermission
JScript | public final class NetworkPermission extends CodeAccessPermission implements IUnrestrictedPermission

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Copy | Creates and returns an identical copy of the current permission.
FromXml | Reconstructs a permission with a specified state from an XML encoding.
Intersect | Creates and returns a permission that is the intersection of the current permission and the specified permission.
IsSubsetOf | Determines whether the current permission is a subset of the specified permission.
IsUnrestricted | Returns a value indicating whether the current permission is unrestricted.
NetworkPermission | Initializes a new instance of the object.
ToXml | Creates an XML encoding of the permission and its current state.
Union | Creates a permission that is the union of the permission and the specified permission.

Properties

Property | Description
Host | Gets or sets the access represented by the permission.
Join | Gets or sets the access represented by the permission.

Inheritance Hierarchy

Object Leave Site
CodeAccessPermission Leave Site
NetworkPermission

Class Information

Namespace | Microsoft.DirectX.Security
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


NetworkPermission.Copy() Method (Microsoft.DirectX.Security)

NetworkPermission.Copy Method

Creates and returns an identical copy of the current permission.

Definition

Visual Basic | Overrides Public Function Copy() As IPermission
C# | public override IPermission Copy();
C++ public:
virtual IPermission^ Copy() override;
JScript | public override function Copy() : IPermission;

Return Value

System.Security.IPermission


NetworkPermission.FromXml(SecurityElement) Method (Microsoft.DirectX.Security)

NetworkPermission.FromXml Method

Reconstructs a permission with a specified state from an XML encoding.

Definition

Visual Basic Overrides Public Sub FromXml( _
ByVal securityElement As SecurityElement _
)
C# public override void FromXml(
SecurityElement securityElement
);
C++ public:
virtual void FromXml(
SecurityElement^ securityElement
) override;
JScript public override function FromXml(
securityElement : SecurityElement
);

Parameters

securityElement System.Security.SecurityElement


NetworkPermission.Intersect(IPermission) Method (Microsoft.DirectX.Security)

NetworkPermission.Intersect Method

Creates and returns a permission that is the intersection of the current permission and the specified permission.

Definition

Visual Basic Overrides Public Function Intersect( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Intersect(
IPermission target
);
C++ public:
virtual IPermission^ Intersect(
IPermission^ target
) override;
JScript public override function Intersect(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission

Return Value

System.Security.IPermission


NetworkPermission.IsSubsetOf(IPermission) Method (Microsoft.DirectX.Security)

NetworkPermission.IsSubsetOf Method

Determines whether the current permission is a subset of the specified permission.

Definition

Visual Basic Overrides Public Function IsSubsetOf( _
ByVal target As IPermission _
) As Boolean
C# public override bool IsSubsetOf(
IPermission target
);
C++ public:
virtual bool IsSubsetOf(
IPermission^ target
) override;
JScript public override function IsSubsetOf(
target : IPermission
) : boolean;

Parameters

target System.Security.IPermission

Return Value

System.Boolean


NetworkPermission.IsUnrestricted() Method (Microsoft.DirectX.Security)

NetworkPermission.IsUnrestricted Method

Returns a value indicating whether the current permission is unrestricted.

Definition

Visual Basic | Overrides Public Function IsUnrestricted() As Boolean
C# | public override bool IsUnrestricted();
C++ public:
virtual bool IsUnrestricted() override;
JScript | public override function IsUnrestricted() : boolean;

Return Value

System.Boolean


NetworkPermission.NetworkPermission(PermissionState) Constructor (Microsoft.DirectX.Security)

NetworkPermission.NetworkPermission Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal state As PermissionState _
)
C# public NetworkPermission(
PermissionState state
);
C++ public:
NetworkPermission(
PermissionState state
);
JScript public function NetworkPermission(
state : PermissionState
);

Parameters

state System.Security.Permissions.PermissionState


NetworkPermission.ToXml() Method (Microsoft.DirectX.Security)

NetworkPermission.ToXml Method

Creates an XML encoding of the permission and its current state.

Definition

Visual Basic | Overrides Public Function ToXml() As SecurityElement
C# | public override SecurityElement ToXml();
C++ public:
virtual SecurityElement^ ToXml() override;
JScript | public override function ToXml() : SecurityElement;

Return Value

System.Security.SecurityElement


NetworkPermission.Union(IPermission) Method (Microsoft.DirectX.Security)

NetworkPermission.Union Method

Creates a permission that is the union of the permission and the specified permission.

Definition

Visual Basic Overrides Public Function Union( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Union(
IPermission target
);
C++ public:
virtual IPermission^ Union(
IPermission^ target
) override;
JScript public override function Union(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission

Return Value

System.Security.IPermission


NetworkPermission.Host Property (Microsoft.DirectX.Security)

NetworkPermission.Host Property

Gets or sets the access represented by the permission.

Definition

Visual Basic | Public Property Host As Boolean
C# | public bool Host { get; set; }
C++ public:
property bool Host {
bool get();
void set(bool value);
}
JScript public function get Host() : boolean
public function set Host(boolean);

Property Value

System.Boolean

This property is read/write.


NetworkPermission.Join Property (Microsoft.DirectX.Security)

NetworkPermission.Join Property

Gets or sets the access represented by the permission.

Definition

Visual Basic | Public Property Join As Boolean
C# | public bool Join { get; set; }
C++ public:
property bool Join {
bool get();
void set(bool value);
}
JScript public function get Join() : boolean
public function set Join(boolean);

Property Value

System.Boolean

This property is read/write.


SoundPermission Class (Microsoft.DirectX.Security)

SoundPermission Class

Controls the permissions related DirectX Audio.

Definition

Visual Basic NotInheritable Public Class SoundPermission
Inherits CodeAccessPermission
Implements IUnrestrictedPermission
C# | public sealed class SoundPermission : CodeAccessPermission, IUnrestrictedPermission
C++ | public ref class SoundPermission sealed : CodeAccessPermission, IUnrestrictedPermission
JScript | public final class SoundPermission extends CodeAccessPermission implements IUnrestrictedPermission

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Copy | Creates and returns an identical copy of the current permission.
FromXml | Reconstructs a permission with a specified state from an XML encoding.
Intersect | Creates and returns a permission that is the intersection of the current permission and the specified permission.
IsSubsetOf | Determines whether the current permission is a subset of the specified permission.
IsUnrestricted | Returns a value indicating whether the current permission is unrestricted.
SoundPermission | Initializes a new instance of the object.
ToXml | Creates an XML encoding of the permission and its current state.
Union | Creates a permission that is the union of the permission and the specified permission.

Properties

Property | Description
Use | Gets or sets the access represented by the permission.
UseCapture | Gets or sets the access represented by the permission.

Inheritance Hierarchy

Object Leave Site
CodeAccessPermission Leave Site
SoundPermission

Class Information

Namespace | Microsoft.DirectX.Security
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


SoundPermission.Copy() Method (Microsoft.DirectX.Security)

SoundPermission.Copy Method

Creates and returns an identical copy of the current permission.

Definition

Visual Basic | Overrides Public Function Copy() As IPermission
C# | public override IPermission Copy();
C++ public:
virtual IPermission^ Copy() override;
JScript | public override function Copy() : IPermission;

Return Value

System.Security.IPermission


SoundPermission.FromXml(SecurityElement) Method (Microsoft.DirectX.Security)

SoundPermission.FromXml Method

Reconstructs a permission with a specified state from an XML encoding.

Definition

Visual Basic Overrides Public Sub FromXml( _
ByVal securityElement As SecurityElement _
)
C# public override void FromXml(
SecurityElement securityElement
);
C++ public:
virtual void FromXml(
SecurityElement^ securityElement
) override;
JScript public override function FromXml(
securityElement : SecurityElement
);

Parameters

securityElement System.Security.SecurityElement


SoundPermission.Intersect(IPermission) Method (Microsoft.DirectX.Security)

SoundPermission.Intersect Method

Creates and returns a permission that is the intersection of the current permission and the specified permission.

Definition

Visual Basic Overrides Public Function Intersect( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Intersect(
IPermission target
);
C++ public:
virtual IPermission^ Intersect(
IPermission^ target
) override;
JScript public override function Intersect(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission

Return Value

System.Security.IPermission


SoundPermission.IsSubsetOf(IPermission) Method (Microsoft.DirectX.Security)

SoundPermission.IsSubsetOf Method

Determines whether the current permission is a subset of the specified permission.

Definition

Visual Basic Overrides Public Function IsSubsetOf( _
ByVal target As IPermission _
) As Boolean
C# public override bool IsSubsetOf(
IPermission target
);
C++ public:
virtual bool IsSubsetOf(
IPermission^ target
) override;
JScript public override function IsSubsetOf(
target : IPermission
) : boolean;

Parameters

target System.Security.IPermission

Return Value

System.Boolean


SoundPermission.IsUnrestricted() Method (Microsoft.DirectX.Security)

SoundPermission.IsUnrestricted Method

Returns a value indicating whether the current permission is unrestricted.

Definition

Visual Basic | Overrides Public Function IsUnrestricted() As Boolean
C# | public override bool IsUnrestricted();
C++ public:
virtual bool IsUnrestricted() override;
JScript | public override function IsUnrestricted() : boolean;

Return Value

System.Boolean


SoundPermission.SoundPermission(PermissionState) Constructor (Microsoft.DirectX.Security)

SoundPermission.SoundPermission Constructor

Initializes a new instance of the object.

Definition

Visual Basic Public Sub New( _
ByVal state As PermissionState _
)
C# public SoundPermission(
PermissionState state
);
C++ public:
SoundPermission(
PermissionState state
);
JScript public function SoundPermission(
state : PermissionState
);

Parameters

state System.Security.Permissions.PermissionState


SoundPermission.ToXml() Method (Microsoft.DirectX.Security)

SoundPermission.ToXml Method

Creates an XML encoding of the permission and its current state.

Definition

Visual Basic | Overrides Public Function ToXml() As SecurityElement
C# | public override SecurityElement ToXml();
C++ public:
virtual SecurityElement^ ToXml() override;
JScript | public override function ToXml() : SecurityElement;

Return Value

System.Security.SecurityElement


SoundPermission.Union(IPermission) Method (Microsoft.DirectX.Security)

SoundPermission.Union Method

Creates a permission that is the union of the permission and the specified permission.

Definition

Visual Basic Overrides Public Function Union( _
ByVal target As IPermission _
) As IPermission
C# public override IPermission Union(
IPermission target
);
C++ public:
virtual IPermission^ Union(
IPermission^ target
) override;
JScript public override function Union(
target : IPermission
) : IPermission;

Parameters

target System.Security.IPermission

Return Value

System.Security.IPermission


SoundPermission.Use Property (Microsoft.DirectX.Security)

SoundPermission.Use Property

Gets or sets the access represented by the permission.

Definition

Visual Basic | Public Property Use As Boolean
C# | public bool Use { get; set; }
C++ public:
property bool Use {
bool get();
void set(bool value);
}
JScript public function get Use() : boolean
public function set Use(boolean);

Property Value

System.Boolean

This property is read/write.


SoundPermission.UseCapture Property (Microsoft.DirectX.Security)

SoundPermission.UseCapture Property

Gets or sets the access represented by the permission.

Definition

Visual Basic | Public Property UseCapture As Boolean
C# | public bool UseCapture { get; set; }
C++ public:
property bool UseCapture {
bool get();
void set(bool value);
}
JScript public function get UseCapture() : boolean
public function set UseCapture(boolean);

Property Value

System.Boolean

This property is read/write.


Microsoft.DirectX

This namespace provides utility operations and data storage for Microsoft DirectX application programming, including exception handling, simple helper methods, and structures used for matrix, clipping plane, quaternion, and vector manipulation. The following tables list the members exposed by the Microsoft.DirectX namespace.

Classes

DirectXException | Describes the root exception class for all DirectX 9.0 for Managed Code exceptions.
DXHelp | Contains miscellaneous helper functions for DirectX 9.0 for Managed Code.
GraphicsStream | Contains a graphics data stream.
MatrixStack | Contains methods and properties that applications use to manipulate a matrix stack.
UnsafeNativeMethods Defines high-performance utility methods for matrix, plane, quaternion, and vector manipulation. This class is a container of classes. See the individual classes for more information.
Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the methods of the Microsoft.DirectX Structures.
UnsafeNativeMethods.Matrix Describes and manipulates a matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Matrix structure.
UnsafeNativeMethods.Plane Describes and manipulates a plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Plane structure.
UnsafeNativeMethods.Quaternion Describes and manipulates a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Quaternion structure.
UnsafeNativeMethods.Vector2 Describes and manipulates a vector in two-dimensional (2-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector2 structure.
UnsafeNativeMethods.Vector3 Describes and manipulates a vector in three-dimensional (3-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector3 structure.
UnsafeNativeMethods.Vector4 Describes and manipulates a vector in four-dimensional (4-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector4 structure.

Structures

Matrix | Describes and manipulates a matrix.
Plane | Describes and manipulates a plane.
Quaternion | Describes a quaternion.
Single16 | Describes and manipulates a 16-bit floating-point value.
Vector2 | Describes and manipulates a vector in two-dimensional (2-D) space.
Vector3 | Describes and manipulates a vector in three-dimensional (3-D) space.
Vector4 | Describes a vector in four-dimensional (4-D) space.


DirectXException Class (Microsoft.DirectX)

DirectXException Class

Describes the root exception class for all Microsoft DirectX 9.0 for Managed Code exceptions.

Definition

Visual Basic Public Class DirectXException
Inherits ApplicationException
C# | public class DirectXException : ApplicationException
C++ | public ref class DirectXException : ApplicationException
JScript | public class DirectXException extends ApplicationException

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) IsExceptionIgnored | Specifies whether DirectX 9.0 for Managed Code exceptions are enabled or disabled.

Methods

Method | Description
DirectXException | Initializes a new instance of the DirectXException class.
static (Shared in Visual Basic) EnableExceptions | Enables DirectX 9.0 for Managed Code exception throwing.
static (Shared in Visual Basic) GetDirectXErrorString | Retrieves a string that contains the name of the DirectX error code.
static (Shared in Visual Basic) GetExceptionFromResultInternal | Retrieves the Exception Leave Site object associated with the resultCode passed in.
static (Shared in Visual Basic) IgnoreExceptions | Disables DirectX 9.0 for Managed Code exception throwing.
ToString | Obtains the string representation of the current instance.

Properties

Property | Description
ErrorCode | Retrieves or sets the integer value result code.
ErrorString | Retrieves the error string that is specific to DirectX 9.0 for Managed Code.
static (Shared in Visual Basic) LastError | Retrieves the error status for the last operation that failed.

Inheritance Hierarchy

Object Leave Site
Exception Leave Site
ApplicationException Leave Site
DirectXException
Direct3DXException
DirectPlayException
GraphicsException
GraphicsException
InputException
SoundException

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DirectXException.DirectXException Constructor ()

Initializes a new instance of the DirectXException class.

Overload List

public DirectXException();
protected DirectXException(SerializationInfo, StreamingContext);
public DirectXException(string);
public DirectXException(string, Exception);


DirectXException.DirectXException(SerializationInfo,StreamingContext) Constructor (Microsoft.DirectX)

DirectXException.DirectXException Constructor

Initializes a new instance of the DirectXException class.

Definition

Visual Basic Protected Sub New( _
ByVal info As SerializationInfo, _
ByVal context As StreamingContext _
)
C# protected DirectXException(
SerializationInfo info,
StreamingContext context
);
C++ protected:
DirectXException(
SerializationInfo^ info,
StreamingContext context
);
JScript protected function DirectXException(
info : SerializationInfo,
context : StreamingContext
);

Parameters

info System.Runtime.Serialization.SerializationInfo
A SerializationInfo Leave Site object that contains serialization information for the current exception.
context System.Runtime.Serialization.StreamingContext
A StreamingContext Leave Site object that contains the context for the current exception.


DirectXException.DirectXException(String,Exception) Constructor (Microsoft.DirectX)

DirectXException.DirectXException Constructor

Initializes a new instance of the DirectXException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String, _
ByVal inner As Exception _
)
C# public DirectXException(
string message,
Exception inner
);
C++ public:
DirectXException(
String^ message,
Exception^ inner
);
JScript public function DirectXException(
message : String,
inner : Exception
);

Parameters

message System.String
String that contains the error text for the exception.
inner System.Exception
An Exception Leave Site object that contains the inner exception.


DirectXException.DirectXException(String) Constructor (Microsoft.DirectX)

DirectXException.DirectXException Constructor

Initializes a new instance of the DirectXException class.

Definition

Visual Basic Public Sub New( _
ByVal message As String _
)
C# public DirectXException(
string message
);
C++ public:
DirectXException(
String^ message
);
JScript public function DirectXException(
message : String
);

Parameters

message System.String
String that contains the error text for the exception.


DirectXException.DirectXException() Constructor (Microsoft.DirectX)

DirectXException.DirectXException Constructor

Initializes a new instance of the DirectXException class.

Definition

Visual Basic | Public Sub New()
C# | public DirectXException();
C++ public:
DirectXException();
JScript | public function DirectXException();


DirectXException.EnableExceptions() Method (Microsoft.DirectX)

DirectXException.EnableExceptions Method

Enables Microsoft DirectX 9.0 for Managed Code exception throwing.

Definition

Visual Basic | Public Shared Sub EnableExceptions()
C# | public static void EnableExceptions();
C++ public:
static void EnableExceptions();
JScript | public static function EnableExceptions();

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DirectXException.GetDirectXErrorString(Int32) Method (Microsoft.DirectX)

DirectXException.GetDirectXErrorString Method

Retrieves a string that contains the name of the Microsoft DirectX error code.

Definition

Visual Basic Public Shared Function GetDirectXErrorString( _
ByVal errorCode As Integer _
) As String
C# public static string GetDirectXErrorString(
int errorCode
);
C++ public:
static String^ GetDirectXErrorString(
int errorCode
);
JScript public static function GetDirectXErrorString(
errorCode : int
) : String;

Parameters

errorCode System.Int32
Result code of the failed method that caused this exception.

Return Value

System.String
A string that contains the name of the error code.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DirectXException.GetExceptionFromResultInternal(Int32) Method (Microsoft.DirectX)

DirectXException.GetExceptionFromResultInternal Method

Retrieves the Exception Leave Site object associated with the resultCode passed in.

Definition

Visual Basic Public Shared Function GetExceptionFromResultInternal( _
ByVal resultCode As Integer _
) As Exception
C# public static Exception GetExceptionFromResultInternal(
int resultCode
);
C++ public:
static Exception^ GetExceptionFromResultInternal(
int resultCode
);
JScript public static function GetExceptionFromResultInternal(
resultCode : int
) : Exception;

Parameters

resultCode System.Int32
Result code of the failed method that caused this exception.

Return Value

System.Exception
An Exception Leave Site object that contains the new exception created from passing in resultCode.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DirectXException.IgnoreExceptions() Method (Microsoft.DirectX)

DirectXException.IgnoreExceptions Method

Disables Microsoft DirectX 9.0 for Managed Code exception throwing.

Definition

Visual Basic | Public Shared Sub IgnoreExceptions()
C# | public static void IgnoreExceptions();
C++ public:
static void IgnoreExceptions();
JScript | public static function IgnoreExceptions();

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DirectXException.ToString() Method (Microsoft.DirectX)

DirectXException.ToString Method

Obtains the string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DirectXException.ErrorCode Property (Microsoft.DirectX)

DirectXException.ErrorCode Property

Retrieves or sets the integer value result code.

Definition

Visual Basic | Public Property ErrorCode As Integer
C# | public int ErrorCode { get; set; }
C++ public:
property int ErrorCode {
int get();
void set(int value);
}
JScript public function get ErrorCode() : int
public function set ErrorCode(int);

Property Value

System.Int32
Integer that represents the result code.

This property is read/write.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DirectXException.ErrorString Property (Microsoft.DirectX)

DirectXException.ErrorString Property

Retrieves the error string that is specific to Microsoft DirectX 9.0 for Managed Code.

Definition

Visual Basic | Public ReadOnly Property ErrorString As String
C# | public string ErrorString { get; }
C++ public:
property String^ ErrorString {
String^ get();
}
JScript | public function get ErrorString() : String

Property Value

System.String
String that contains the error message.

This property is read-only.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DirectXException.LastError Property (Microsoft.DirectX)

DirectXException.LastError Property

Retrieves the error status for the last operation that failed.

Definition

Visual Basic | Public Shared ReadOnly Property LastError As Integer
C# | public static int LastError { get; }
C++ public:
static property int LastError {
int get();
}
JScript | public static function get LastError() : int

Property Value

System.Int32
Integer that represents the last error code.

This property is read-only.

Remarks

LastError should be called immediately if a method fails, otherwise a subsequent method call may overwrite the last error code.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DirectXException.IsExceptionIgnored Field (Microsoft.DirectX)

DirectXException.IsExceptionIgnored Field

Specifies whether Microsoft DirectX 9.0 for Managed Code exceptions are enabled or disabled.

Definition

Visual Basic | Public Shared IsExceptionIgnored As Boolean
C# | public static Boolean IsExceptionIgnored;
C++ | public: static Boolean IsExceptionIgnored;
JScript | public static var IsExceptionIgnored : Boolean

Field Value

System.Boolean
Value that is true if exceptions are enabled, or false if they are disabled.

This field is read/write.

Applies To

Direct3DXException, DirectPlayException, GraphicsException, GraphicsException, InputException, SoundException

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


DXHelp Class (Microsoft.DirectX)

DXHelp Class

Contains miscellaneous helper functions for Microsoft DirectX 9.0 for Managed Code.

Definition

Visual Basic NotInheritable MustInherit Public Class DXHelp
Inherits Object
C# | public abstract sealed class DXHelp : Object
C++ | public ref class DXHelp abstract sealed : Object
JScript | public final abstract class DXHelp extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) CopyObjectDataToPointer | Copies a managed object to an unmanaged pointer.
static (Shared in Visual Basic) CopyPointerDataToObject | Copies an unmanaged pointer to a managed object.
static (Shared in Visual Basic) GetObjectSize | Retrieves an object's size.
static (Shared in Visual Basic) GetTypeSize | Retrieves the size of the Type Leave Site.

Inheritance Hierarchy

Object Leave Site
DXHelp

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


DXHelp.CopyObjectDataToPointer(Object,IntPtr) Method (Microsoft.DirectX)

DXHelp.CopyObjectDataToPointer Method

Copies a managed object to an unmanaged pointer.

Definition

Visual Basic Public Shared Sub CopyObjectDataToPointer( _
ByVal objectData As Object, _
ByVal pointerData As IntPtr _
)
C# public static void CopyObjectDataToPointer(
object objectData,
IntPtr pointerData
);
C++ public:
static void CopyObjectDataToPointer(
Object^ objectData,
IntPtr pointerData
);
JScript public static function CopyObjectDataToPointer(
objectData : Object,
pointerData : IntPtr
);

Parameters

objectData System.Object
Source Object Leave Site to copy to the unmanaged pointer.
pointerData System.IntPtr
Destination pointer to which the source object is copied.

Remarks

This method copies strings and arrays of strings, but it is not a fast process.

Exceptions
ArgumentException Leave Site A value type must be passed to this method.


DXHelp.CopyPointerDataToObject(Object,IntPtr) Method (Microsoft.DirectX)

DXHelp.CopyPointerDataToObject Method

Copies an unmanaged pointer to a managed object.

Definition

Visual Basic Public Shared Sub CopyPointerDataToObject( _
ByRef objectData As Object, _
ByVal pointerData As IntPtr _
)
C# public static void CopyPointerDataToObject(
ref object objectData,
IntPtr pointerData
);
C++ public:
static void CopyPointerDataToObject(
Object^% objectData,
IntPtr pointerData
);
JScript public static function CopyPointerDataToObject(
objectData : Object,
pointerData : IntPtr
);

Parameters

objectData System.Object
[ref] Destination Object Leave Site to which the pointer data is copied.
pointerData System.IntPtr
Source pointer data that is copied to the object.

Remarks

Exceptions
ArgumentException Leave Site A value type must be passed to this method.


DXHelp.GetObjectSize(Object) Method (Microsoft.DirectX)

DXHelp.GetObjectSize Method

Retrieves an object's size.

Definition

Visual Basic Public Shared Function GetObjectSize( _
ByVal objectSize As Object _
) As Integer
C# public static int GetObjectSize(
object objectSize
);
C++ public:
static int GetObjectSize(
Object^ objectSize
);
JScript public static function GetObjectSize(
objectSize : Object
) : int;

Parameters

objectSize System.Object
Reference to the Object Leave Site whose size is being returned.

Return Value

System.Int32
Integer that represents the size of the object.

Remarks

Exceptions
ArgumentException Leave Site A value type must be passed to this method.


DXHelp.GetTypeSize(Type) Method (Microsoft.DirectX)

DXHelp.GetTypeSize Method

Retrieves the size of the Type Leave Site.

Definition

Visual Basic Public Shared Function GetTypeSize( _
ByVal typeSize As Type _
) As Integer
C# public static int GetTypeSize(
Type typeSize
);
C++ public:
static int GetTypeSize(
Type^ typeSize
);
JScript public static function GetTypeSize(
typeSize : Type
) : int;

Parameters

typeSize System.Type
Reference to the Type Leave Site whose size is being returned.

Return Value

System.Int32
Integer that represents the size of the type.

Remarks

Exceptions
ArgumentException Leave Site A value type must be passed to this method.


GraphicsStream Class (Microsoft.DirectX)

GraphicsStream Class

How Do I...?
  • Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams
  • Read and Write VertexBuffer Data With Arrays

Contains a graphics data stream.

Definition

Visual Basic NotInheritable Public Class GraphicsStream
Inherits Stream
C# | public sealed class GraphicsStream : Stream
C++ | public ref class GraphicsStream sealed : Stream
JScript | public final class GraphicsStream extends Stream

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
Close | Closes the current stream and releases any resources associated with it.
Dispose | Immediately releases the unmanaged resources used by an object.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
Flush | Flushing the graphics stream is not supported.
GetHashCode | Returns the hash code for the current instance.
GraphicsStream | Initializes a new instance of the GraphicsStream class.
Read | Reads from the current stream and advances the position within it by the number of bytes read.
Seek | Sets the position within the current stream.
SetLength | Resizing the graphics stream is not supported.
Write | Writes to the current stream and advances the current position within it by the number of bytes written.

Properties

Property | Description
CanRead | Retrieves a value that indicates whether the current stream supports reading.
CanSeek | Retrieves a value that indicates whether the current stream supports seeking.
CanWrite | Retrieves a value that indicates whether the current stream supports writing.
InternalBuffer | This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.
InternalBufferPointer | This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.
InternalData | This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.
InternalDataPointer | This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.
Length | Retrieves the length of the stream in bytes.
Position | Retrieves or sets the position within the current stream.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
Stream Leave Site
GraphicsStream

How Do I...?

Read and Write VertexBuffer and IndexBuffer Data With GraphicsStreams

This example demonstrates how to use GraphicsStream objects to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a flexible vertex format (FVF) type defined by the PositionNormalTexVertex structure. The vertex buffer data is then locked using its offset and size in bytes. A GraphicsStream object is returned which is derived from Stream Leave Site and can be used in a similar fashon. In the code example, the Write method is used to copy data into the stream from an array of vertex data.

The second part of the method shows use of GraphicsStream using unsafe data access. The InternalDataPointerGraphicsStream.InternalData property returns a void pointer to the vertex buffer data. In this code example, the data is cast to an array of PositionNormalTexVertex structures which makes data manipulation more readable.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public  float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}
public class Example
{
    public unsafe void  GraphicsStreamReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTexVertex.FVF, Pool.Managed);

        //First, fill an array of PositionNormalTexVertex elements with data.
        PositionNormalTexVertex[] vertices = new PositionNormalTexVertex[50];
        for(int i=0; i<50; i++)
        {
            //fill the vertices with some data...
            vertices[i].Position = new Vector3(3f,4f,5f);
        }

        //The size of the verticies are 32-bytes each (float3 (12) + float3 (12) + float(4) + float(4))
        //To lock 50 verticies, the size of the lock would be 1600 (32 * 50)
        GraphicsStream vbData =  vb.Lock(0,1600, LockFlags.None);

        //copy the vertex data into the vertex buffer
        vbData.Write(vertices);

        //Unlock the VB
        vb.Unlock();

        //This time, lock the entire VertexBuffer
        vbData =  vb.Lock(0, 3200, LockFlags.None);

        //Cast the InternalDataPointer (a void pointer) to an array of verticies
        PositionNormalTexVertex* vbArray = (PositionNormalTexVertex*) vbData.InternalDataPointer;

        for(int i=0; i<100; i++)
        {
            //perform some operations on the data
            vbArray[i].Tu0 = i;
            vbArray[i].Tv0 = vbArray[i].Tu0 * 2;

            Console.WriteLine(vbArray[i].Tv0.ToString());
        }

        //Unlock the buffer
        vb.Unlock();
        vb.Dispose();
    }
}

Read and Write VertexBuffer Data With Arrays

This example demonstrates how to use arrays to fill and retrieve data from a VertexBuffer and IndexBuffer objects.

[C#]

In the following C# code example, a VertexBuffer object is created using a FVF type defined by the PositionNormalTexVertex structure. The first part of the code sample shows the use of Lock to lock an arbitrary number of vertices and fill them with data. The second part shows how to lock an entire VertexBuffer for reading and retrieving data from the array. A similar procedure can be used to write to and read from nearly all Microsoft Direct3D resource types.

Using Arrays Leave Site is not the most efficient method for filling and reading from Direct3D resources; it requires extra memory and cycles to copy the unmanaged resources into managed arrays. However, it makes for very readable code with no unsafe access.

using System;
using Microsoft.DirectX;
using Microsoft.DirectX.Direct3D;

public struct PositionNormalTexVertex
{
    public Vector3 Position;
    public Vector3 Normal;
    public float Tu0, Tv0;
    public static readonly VertexFormats FVF = VertexFormats.Position | VertexFormats.Texture1;
}

public class Example
{
    public void ArrayBasedReadWrite()
    {
        //Create a vertex buffer in the managed pool
        VertexBuffer vb = new VertexBuffer(typeof(PositionNormalTexVertex), 100, device, Usage.None, PositionNormalTex1Vertex.FVF, Pool.Managed);

        //Fill an array of the appropriate type with the VB data using Lock()
        PositionNormalTexVertex[] vbData = (PositionNormalTexVertex[]) vb.Lock(0, typeof(PositionNormalTexVertex), LockFlags.None, 50);
        for(int i=0; i<50; i++)
        {
            //set your vertices to something...
            vbData[i].Position = new Vector3(2f,2f,2f);
            vbData[i].Normal = new Vector3(1f,0f,0f);
            vbData[i].Tu0 = i;
            vbData[i].Tv0 = i;
        }
        //Unlock the vb before you can use it elsewhere
        vb.Unlock();

        //This lock overload simply locks the entire VB -- setting ReadOnly can improve perf when reading a vertexbuffer
        vbData = (PositionNormalTexVertex[]) vb.Lock(0, LockFlags.ReadOnly);
        for(int i=0; i<100; i++)
        {
            //read some vertex data
            Console.WriteLine("Vertex " + i + "Tu: " +  vbData[i].Tu0 + " , Tv: " + vbData[i].Tv0);
        }

        //Unlock the buffer
        vb.Unlock();

        vb.Dispose();
    }
}

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


GraphicsStream.Close() Method (Microsoft.DirectX)

GraphicsStream.Close Method

Closes the current stream and releases any resources associated with it.

Definition

Visual Basic | Overrides Public Sub Close()
C# | public override void Close();
C++ public:
virtual void Close() override;
JScript | public override function Close();


GraphicsStream.Dispose() Method (Microsoft.DirectX)

GraphicsStream.Dispose Method

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic | Public Sub Dispose()
C# | public void Dispose();
C++ | ~GraphicsStream();
JScript | public function Dispose();


GraphicsStream.Equals(Object) Method (Microsoft.DirectX)

GraphicsStream.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


GraphicsStream.Finalize() Method (Microsoft.DirectX)

GraphicsStream.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~GraphicsStream();
C++ | !GraphicsStream();
JScript | protected override function Finalize();


GraphicsStream.Flush() Method (Microsoft.DirectX)

GraphicsStream.Flush Method

Flushing the graphics stream is not supported.

Definition

Visual Basic | Overrides Public Sub Flush()
C# | public override void Flush();
C++ public:
virtual void Flush() override;
JScript | public override function Flush();


GraphicsStream.GetHashCode() Method (Microsoft.DirectX)

GraphicsStream.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


GraphicsStream.GraphicsStream Constructor ()

Initializes a new instance of the GraphicsStream class.

Overload List

public GraphicsStream(IntPtr, long, bool, bool);
public GraphicsStream(IntPtr, long, IntPtr);
public GraphicsStream(void, long, bool, bool);
public GraphicsStream(void, long, void);


GraphicsStream.GraphicsStream(IntPtr,Int64,Boolean,Boolean) Constructor (Microsoft.DirectX)

GraphicsStream.GraphicsStream Constructor

Initializes a new instance of the GraphicsStream class.

Definition

Visual Basic Public Sub New( _
ByVal dataPointer As IntPtr, _
ByVal size As Long, _
ByVal read As Boolean, _
ByVal write As Boolean _
)
C# public GraphicsStream(
IntPtr dataPointer,
long size,
bool read,
bool write
);
C++ public:
GraphicsStream(
IntPtr dataPointer,
long size,
bool read,
bool write
);
JScript public function GraphicsStream(
dataPointer : IntPtr,
size : long,
read : boolean,
write : boolean
);

Parameters

dataPointer System.IntPtr
Reference to the graphics data in the stream buffer.
size System.Int64
Size of the data referenced by dataPointer.
read System.Boolean
Set to true if the buffer is readable; otherwise, false.
write System.Boolean
Set to true if buffer is writable; otherwise, false.


GraphicsStream.GraphicsStream(Void,Int64,Boolean,Boolean) Constructor (Microsoft.DirectX)

GraphicsStream.GraphicsStream Constructor

Initializes a new instance of the GraphicsStream class.

Definition

Visual Basic Public Sub New( _
ByVal pDataPointer As Void, _
ByVal size As Long, _
ByVal read As Boolean, _
ByVal write As Boolean _
)
C# public GraphicsStream(
void pDataPointer,
long size,
bool read,
bool write
);
C++ public:
GraphicsStream(
void pDataPointer,
long size,
bool read,
bool write
);
JScript public function GraphicsStream(
pDataPointer : void,
size : long,
read : boolean,
write : boolean
);

Parameters

pDataPointer System.Void
Reference to the graphics data in the stream buffer.
size System.Int64
Size of the data referenced by dataPointer.
read System.Boolean
Set to true if the buffer is readable; otherwise, false.
write System.Boolean
Set to true if buffer is writable; otherwise, false.


GraphicsStream.GraphicsStream(IntPtr,Int64,IntPtr) Constructor (Microsoft.DirectX)

GraphicsStream.GraphicsStream Constructor

Initializes a new instance of the GraphicsStream class.

Definition

Visual Basic Public Sub New( _
ByVal dataPointer As IntPtr, _
ByVal size As Long, _
ByVal bufferPointer As IntPtr _
)
C# public GraphicsStream(
IntPtr dataPointer,
long size,
IntPtr bufferPointer
);
C++ public:
GraphicsStream(
IntPtr dataPointer,
long size,
IntPtr bufferPointer
);
JScript public function GraphicsStream(
dataPointer : IntPtr,
size : long,
bufferPointer : IntPtr
);

Parameters

dataPointer System.IntPtr
Reference to the graphics data in the stream buffer.
size System.Int64
Size of the data referenced by dataPointer.
bufferPointer System.IntPtr
Reference to the actual stream buffer.


GraphicsStream.GraphicsStream(Void,Int64,Void) Constructor (Microsoft.DirectX)

GraphicsStream.GraphicsStream Constructor

Initializes a new instance of the GraphicsStream class.

Definition

Visual Basic Public Sub New( _
ByVal pDataPointer As Void, _
ByVal size As Long, _
ByVal bufferPointer As Void _
)
C# public GraphicsStream(
void pDataPointer,
long size,
void bufferPointer
);
C++ public:
GraphicsStream(
void pDataPointer,
long size,
void bufferPointer
);
JScript public function GraphicsStream(
pDataPointer : void,
size : long,
bufferPointer : void
);

Parameters

pDataPointer System.Void
Reference to the graphics data in the stream buffer.
size System.Int64
Size of the data referenced by dataPointer.
bufferPointer System.Void
Reference to the actual stream buffer.


GraphicsStream.Read Method ()

Reads from the current stream and advances the position within it by the number of bytes read.

Overload List

public string Read(bool);
public override int Read(byte[], int, int);
public ValueType Read(Type);
public Array Read(Type, int[]);

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Read(Boolean) Method (Microsoft.DirectX)

GraphicsStream.Read Method

Reads from the current stream and advances the position within it by the number of bytes read.

Definition

Visual Basic Public Function Read( _
ByVal unicode As Boolean _
) As String
C# public string Read(
bool unicode
);
C++ public:
String^ Read(
bool unicode
);
JScript public function Read(
unicode : boolean
) : String;

Parameters

unicode System.Boolean
Set to true if the graphics stream is Unicode. Set to false if the graphics stream is ASCII.

Return Value

System.String
A String Leave Site that contains the data to read from the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Read(Type,Int32[]) Method (Microsoft.DirectX)

GraphicsStream.Read Method

Reads from the current stream and advances the position within it by the number of bytes read.

Definition

Visual Basic Public Function Read( _
ByVal returnType As Type, _
ByVal ranks() As Integer _
) As Array
C# public Array Read(
Type returnType,
int[] ranks
);
C++ public:
Array^ Read(
Type^ returnType,
array<int>^ ranks
);
JScript public function Read(
returnType : Type,
ranks : int[]
) : Array;

Parameters

returnType System.Type
Value that indicates the Type Leave Site of the returned array.
ranks System.Int32[]
An array of Int32 Leave Site values that represent the size of each dimension of the returning array.

Return Value

System.Array
An Array Leave Site of type returnType that contains the data read from the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Read(Type) Method (Microsoft.DirectX)

GraphicsStream.Read Method

Reads from the current stream and advances the position within it by the number of bytes read.

Definition

Visual Basic Public Function Read( _
ByVal returnType As Type _
) As ValueType
C# public ValueType Read(
Type returnType
);
C++ public:
ValueType^ Read(
Type^ returnType
);
JScript public function Read(
returnType : Type
) : ValueType;

Parameters

returnType System.Type
Value that indicates the Type Leave Site of the returned array.

Return Value

System.ValueType
A ValueType Leave Site of type returnType that contains the data read from the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Read(Byte[],Int32,Int32) Method (Microsoft.DirectX)

GraphicsStream.Read Method

Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.

Definition

Visual Basic Overrides Public Function Read( _
ByVal buffer() As Byte, _
ByVal offset As Integer, _
ByVal count As Integer _
) As Integer
C# public override int Read(
byte[] buffer,
int offset,
int count
);
C++ public:
virtual int Read(
array<unsigned char>^ buffer,
int offset,
int count
) override;
JScript public override function Read(
buffer : byte[],
offset : int,
count : int
) : int;

Parameters

buffer System.Byte[]
Reference to a Byte Leave Site array that is used as the read buffer.
offset System.Int32
Value that specifies the offset, from the start of the buffer, of the data read from buffer.
count System.Int32
Value that specifies the number of bytes to read.

Return Value

System.Int32
Integer that represents the number of bytes read into buffer from the graphics stream.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to read from the stream buffer, or there is no data to read.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Seek(Int64,SeekOrigin) Method (Microsoft.DirectX)

GraphicsStream.Seek Method

Sets the position within the current stream.

Definition

Visual Basic Overrides Public Function Seek( _
ByVal newposition As Long, _
ByVal origin As SeekOrigin _
) As Long
C# public override long Seek(
long newposition,
SeekOrigin origin
);
C++ public:
virtual long Seek(
long newposition,
SeekOrigin origin
) override;
JScript public override function Seek(
newposition : long,
origin : SeekOrigin
) : long;

Parameters

newposition System.Int64
Value that represents the new position within the stream buffer.
origin System.IO.SeekOrigin
Member of the SeekOrigin Leave Site enumeration that specifies where to begin seeking.

Return Value

System.Int64
New position within the stream buffer.

Remarks

Exceptions
ArgumentException Leave Site The new location is either less than 0 or greater than the stream buffer's data size.


GraphicsStream.SetLength(Int64) Method (Microsoft.DirectX)

GraphicsStream.SetLength Method

Resizing the graphics stream is not supported.

Definition

Visual Basic Overrides Public Sub SetLength( _
ByVal newLength As Long _
)
C# public override void SetLength(
long newLength
);
C++ public:
virtual void SetLength(
long newLength
) override;
JScript public override function SetLength(
newLength : long
);

Parameters

newLength System.Int64


GraphicsStream.Write Method ()

Writes to the current stream and advances the current position within it by the number of bytes written.

Overload List

public void Write(Array);
public override void Write(byte[], int, int);
public void Write(string);
public void Write(string, bool);
public void Write(ValueType);

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(String) Method (Microsoft.DirectX)

GraphicsStream.Write Method

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic Public Sub Write( _
ByVal value As String _
)
C# public void Write(
string value
);
C++ public:
void Write(
String^ value
);
JScript public function Write(
value : String
);

Parameters

value System.String
Reference to a String Leave Site that contains the data to write into the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(String,Boolean) Method (Microsoft.DirectX)

GraphicsStream.Write Method

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic Public Sub Write( _
ByVal value As String, _
ByVal isUnicodeString As Boolean _
)
C# public void Write(
string value,
bool isUnicodeString
);
C++ public:
void Write(
String^ value,
bool isUnicodeString
);
JScript public function Write(
value : String,
isUnicodeString : boolean
);

Parameters

value System.String
Reference to a String Leave Site that contains the data to write into the stream buffer.
isUnicodeString System.Boolean
Set to true if the graphics stream is Unicode. Set to false if the graphics stream is ASCII.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(Array) Method (Microsoft.DirectX)

GraphicsStream.Write Method

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic Public Sub Write( _
ByVal value As Array _
)
C# public void Write(
Array value
);
C++ public:
void Write(
Array^ value
);
JScript public function Write(
value : Array
);

Parameters

value System.Array
Reference to an Array Leave Site that contains the data to write into the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(ValueType) Method (Microsoft.DirectX)

GraphicsStream.Write Method

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic Public Sub Write( _
ByVal value As ValueType _
)
C# public void Write(
ValueType value
);
C++ public:
void Write(
ValueType^ value
);
JScript public function Write(
value : ValueType
);

Parameters

value System.ValueType
Value that specifies the ValueType Leave Site of the data to write into the stream buffer.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.Write(Byte[],Int32,Int32) Method (Microsoft.DirectX)

GraphicsStream.Write Method

Writes to the current stream and advances the current position within it by the number of bytes written.

Definition

Visual Basic Overrides Public Sub Write( _
ByVal buffer() As Byte, _
ByVal offset As Integer, _
ByVal count As Integer _
)
C# public override void Write(
byte[] buffer,
int offset,
int count
);
C++ public:
virtual void Write(
array<unsigned char>^ buffer,
int offset,
int count
) override;
JScript public override function Write(
buffer : byte[],
offset : int,
count : int
);

Parameters

buffer System.Byte[]
Reference to a Byte Leave Site array that is used as the write buffer.
offset System.Int32
Value that specifies the offset of the data to write from buffer.
count System.Int32
Value that specifies the number of bytes to write.

Remarks

Exceptions
NotSupportedException Leave Site | Unable to write to the stream buffer, or there is no data to write.
ArgumentException Leave Site | One of the parameters is invalid, the stream buffer is not large enough to hold the requested data, or ranks is greater than three.


GraphicsStream.CanRead Property (Microsoft.DirectX)

GraphicsStream.CanRead Property

Retrieves a value that indicates whether the current stream supports reading.

Definition

Visual Basic | Overrides Public ReadOnly Property CanRead As Boolean
C# | public override bool CanRead { get; }
C++ public:
property virtual bool CanRead override {
bool get();
}
JScript | public function get CanRead() : boolean

Property Value

System.Boolean
Value that is true if the stream supports reading, or false if it does not.

This property is read-only.


GraphicsStream.CanSeek Property (Microsoft.DirectX)

GraphicsStream.CanSeek Property

Retrieves a value that indicates whether the current stream supports seeking.

Definition

Visual Basic | Overrides Public ReadOnly Property CanSeek As Boolean
C# | public override bool CanSeek { get; }
C++ public:
property virtual bool CanSeek override {
bool get();
}
JScript | public function get CanSeek() : boolean

Property Value

System.Boolean
Value that is true if the stream supports seeking, or false if it does not.

This property is read-only.


GraphicsStream.CanWrite Property (Microsoft.DirectX)

GraphicsStream.CanWrite Property

Retrieves a value that indicates whether the current stream supports writing.

Definition

Visual Basic | Overrides Public ReadOnly Property CanWrite As Boolean
C# | public override bool CanWrite { get; }
C++ public:
property virtual bool CanWrite override {
bool get();
}
JScript | public function get CanWrite() : boolean

Property Value

System.Boolean
Value that is true if the stream supports writing, or false if it does not.

This property is read-only.


GraphicsStream.InternalBuffer Property (Microsoft.DirectX)

GraphicsStream.InternalBuffer Property

This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.

Definition

Visual Basic | Public ReadOnly Property InternalBuffer As IntPtr
C# | public IntPtr InternalBuffer { get; }
C++ public:
property IntPtr InternalBuffer {
IntPtr get();
}
JScript | public function get InternalBuffer() : IntPtr

Property Value

System.IntPtr
Retrieves a pointer to the stream object's internal buffer.

This property is read-only.


GraphicsStream.InternalBufferPointer Property (Microsoft.DirectX)

GraphicsStream.InternalBufferPointer Property

This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.

Definition

Visual Basic | Public ReadOnly Property InternalBufferPointer
C# | public void InternalBufferPointer { get; }
C++ public:
property void InternalBufferPointer {
void get();
}
JScript | public function get InternalBufferPointer() : void

Property Value

System.Void
Retrieves a void pointer to the stream object's internal buffer.

This property is read-only.


GraphicsStream.InternalData Property (Microsoft.DirectX)

GraphicsStream.InternalData Property

This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.

Definition

Visual Basic | Public ReadOnly Property InternalData As IntPtr
C# | public IntPtr InternalData { get; }
C++ public:
property IntPtr InternalData {
IntPtr get();
}
JScript | public function get InternalData() : IntPtr

Property Value

System.IntPtr
Retrieves a pointer to the stream object's internal data.

This property is read-only.


GraphicsStream.InternalDataPointer Property (Microsoft.DirectX)

GraphicsStream.InternalDataPointer Property

This internal data member is the direct pointer to the unmanaged memory. It can be used, for example, to glue in unmanaged code that renders to dynamic textures.

Definition

Visual Basic | Public ReadOnly Property InternalDataPointer
C# | public void InternalDataPointer { get; }
C++ public:
property void InternalDataPointer {
void get();
}
JScript | public function get InternalDataPointer() : void

Property Value

System.Void
Retrieves a void pointer to the stream object's internal data.

This property is read-only.


GraphicsStream.Length Property (Microsoft.DirectX)

GraphicsStream.Length Property

Retrieves the length of the stream in bytes.

Definition

Visual Basic | Overrides Public ReadOnly Property Length As Long
C# | public override long Length { get; }
C++ public:
property virtual long Length override {
long get();
}
JScript | public function get Length() : long

Property Value

System.Int64
Stream length in bytes.

This property is read-only.


GraphicsStream.Position Property (Microsoft.DirectX)

GraphicsStream.Position Property

Retrieves or sets the position within the current stream.

Definition

Visual Basic | Overrides Public Property Position As Long
C# | public override long Position { get; set; }
C++ public:
property virtual long Position override {
long get();
void set(long value);
}
JScript public function get Position() : long
public function set Position(long);

Property Value

System.Int64
Value that represents the position to set or retrieve.

This property is read/write.

Remarks

Exceptions
ArgumentException Leave Site The position is greater than the stream buffer's data size.


Matrix Class (Microsoft.DirectX)

UnsafeNativeMethods.Matrix Class

Describes and manipulates a matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the methods of the Microsoft.DirectX.Matrix structure.

Definition

Visual Basic NotInheritable MustInherit Public Class Matrix
Inherits Object
C# | public abstract sealed class Matrix : Object
C++ | public ref class Matrix abstract sealed : Object
JScript | public final abstract class Matrix extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic) AffineTransformation2D Builds a 2-D affine transformation matrix in the xy plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Invert Calculates the inverse of a matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) LookAtLH Builds a left-handed look-at matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) LookAtRH Builds a right-handed look-at matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Multiply Determines the product of two matrices.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) MultiplyTranspose Calculates the transposed product of two matrices.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) RotationAxis Builds a matrix that rotates around an arbitrary axis.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) RotationQuaternion Builds a matrix from a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Scaling Builds a matrix that scales along the x-axis, y-axis, and z-axis.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Transformation Builds a transformation matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Transformation2D Builds a 2-D transformation matrix in the xy plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Translation Builds a matrix using specified offsets.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Matrix

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Microsoft.DirectX.Matrix Structure


UnsafeNativeMethods.Matrix.AffineTransformation2D(Matrix,Single,Vector2,Single,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.AffineTransformation2D Method

Builds a 2-D affine transformation matrix in the xy plane.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function AffineTransformation2D( _
ByVal pOut As Matrix, _
ByVal scaling As Single, _
ByVal rotationCenter As Vector2, _
ByVal rotation As Single, _
ByVal translation As Vector2 _
) As Matrix
C# public static Matrix AffineTransformation2D(
Matrix pOut,
float scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
C++ public:
static Matrix AffineTransformation2D(
Matrix pOut,
float scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
JScript public static function AffineTransformation2D(
pOut : Matrix,
scaling : float,
rotationCenter : Vector2,
rotation : float,
translation : Vector2
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that is an affine transformation matrix.
scaling System.Single
Scaling factor. A value of zero indicates no scaling.
rotationCenter Microsoft.DirectX.Vector2
A Vector2 structure that represents a point identifying the center of rotation. Use an empty Vector2 for no rotation.
rotation System.Single
Angle of rotation. A value of zero indicates no rotation.
translation Microsoft.DirectX.Vector2
A Vector2 structure that represents the translation. Use Vector2.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is an affine transformation matrix.

Remarks

The AffineTransformation2D method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

Mout = Ms * (Mrc)-1 * Mr * Mrc * Mt

where:

  • Mout = output matrix (pOut)
  • Ms = scaling matrix (scaling)
  • Mrc = center of rotation matrix (rotationCenter)
  • Mr = rotation matrix (rotation)
  • Mt = translation matrix (translation)

The return value for this method is the same value returned in the pOut parameter. This allows you to use the AffineTransformation2D method as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.AffineTransformation2D


UnsafeNativeMethods.Matrix.Invert Method ()

Calculates the inverse of a matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Overload List

public static Matrix Invert(Matrix, Matrix);
public static Matrix Invert(Matrix, float, Matrix);

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Invert method as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Invert


UnsafeNativeMethods.Matrix.Invert(Matrix,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.Invert Method

Calculates the inverse of a matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Invert( _
ByVal pOut As Matrix, _
ByVal source As Matrix _
) As Matrix
C# public static Matrix Invert(
Matrix pOut,
Matrix source
);
C++ public:
static Matrix Invert(
Matrix pOut,
Matrix source
);
JScript public static function Invert(
pOut : Matrix,
source : Matrix
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that is the result of the operation.
source Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Invert method as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Invert


UnsafeNativeMethods.Matrix.Invert(Matrix,Single,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.Invert Method

Calculates the inverse of a matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Invert( _
ByVal pOut As Matrix, _
ByVal determinant As Single, _
ByVal source As Matrix _
) As Matrix
C# public static Matrix Invert(
Matrix pOut,
float determinant,
Matrix source
);
C++ public:
static Matrix Invert(
Matrix pOut,
float determinant,
Matrix source
);
JScript public static function Invert(
pOut : Matrix,
determinant : float,
source : Matrix
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that is the result of the operation.
determinant System.Single
A Single Leave Site value that contains the determinant of the matrix. If the determinant is not needed, the parameter is omitted.
source Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Invert method as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Invert


UnsafeNativeMethods.Matrix.LookAtLH(Matrix,Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.LookAtLH Method

Builds a left-handed look-at matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function LookAtLH( _
ByVal pOut As Matrix, _
ByVal cameraPosition As Vector3, _
ByVal cameraTarget As Vector3, _
ByVal cameraUpVector As Vector3 _
) As Matrix
C# public static Matrix LookAtLH(
Matrix pOut,
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
C++ public:
static Matrix LookAtLH(
Matrix pOut,
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
JScript public static function LookAtLH(
pOut : Matrix,
cameraPosition : Vector3,
cameraTarget : Vector3,
cameraUpVector : Vector3
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that is a left-handed look-at matrix.
cameraPosition Microsoft.DirectX.Vector3
A Vector3 structure that defines the camera point. This value is used in translation.
cameraTarget Microsoft.DirectX.Vector3
A Vector3 structure that defines the camera look-at target.
cameraUpVector Microsoft.DirectX.Vector3
A Vector3 structure that defines the up direction of the current world, usually [0, 1, 0].

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a left-handed look-at matrix.

Remarks

This method uses the following formula to compute the returned matrix.

zaxis = normal(cameraTarget - cameraPosition)
xaxis = normal(cross(cameraUpVector, zaxis))
yaxis = cross(zaxis, xaxis)

 xaxis.x           yaxis.x           zaxis.x          0
 xaxis.y           yaxis.y           zaxis.y          0
 xaxis.z           yaxis.z           zaxis.z          0
-dot(xaxis, cameraPosition)  -dot(yaxis, cameraPosition)  -dot(zaxis, cameraPosition)  1

The return value for this method is the same value returned in the pOut parameter. This allows you to use the LookAtLH method as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Matrix.LookAtRH
  • Microsoft.DirectX.Matrix.LookAtLH


UnsafeNativeMethods.Matrix.LookAtRH(Matrix,Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.LookAtRH Method

Builds a right-handed look-at matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function LookAtRH( _
ByVal pOut As Matrix, _
ByVal cameraPosition As Vector3, _
ByVal cameraTarget As Vector3, _
ByVal cameraUpVector As Vector3 _
) As Matrix
C# public static Matrix LookAtRH(
Matrix pOut,
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
C++ public:
static Matrix LookAtRH(
Matrix pOut,
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
JScript public static function LookAtRH(
pOut : Matrix,
cameraPosition : Vector3,
cameraTarget : Vector3,
cameraUpVector : Vector3
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that is a right-handed look-at matrix.
cameraPosition Microsoft.DirectX.Vector3
A Vector3 structure that defines the camera point. This value is used in translation.
cameraTarget Microsoft.DirectX.Vector3
A Vector3 structure that defines the camera look-at target.
cameraUpVector Microsoft.DirectX.Vector3
A Vector3 structure that defines the up direction of the current world, usually [0, 1, 0].

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a right-handed look-at matrix.

Remarks

This method uses the following formula to compute the returned matrix.

zaxis = normal(cameraPosition - cameraTarget)
xaxis = normal(cross(cameraUpVector, zaxis))
yaxis = cross(zaxis, xaxis)

 xaxis.x           yaxis.x           zaxis.x          0
 xaxis.y           yaxis.y           zaxis.y          0
 xaxis.z           yaxis.z           zaxis.z          0
-dot(xaxis, cameraPosition)  -dot(yaxis, cameraPosition)  -dot(zaxis, cameraPosition)  1

The return value for this method is the same value returned in the pOut parameter. This allows you to use the LookAtRH method as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Matrix.LookAtLH
  • Microsoft.DirectX.Matrix.LookAtRH


UnsafeNativeMethods.Matrix.Multiply(Matrix,Matrix,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.Multiply Method

Determines the product of two matrices.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Multiply( _
ByVal pOut As Matrix, _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix Multiply(
Matrix pOut,
Matrix left,
Matrix right
);
C++ public:
static Matrix Multiply(
Matrix pOut,
Matrix left,
Matrix right
);
JScript public static function Multiply(
pOut : Matrix,
left : Matrix,
right : Matrix
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that is the product of two matrices.
left Microsoft.DirectX.Matrix
Source Matrix structure.
right Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is the product of two matrices.

Remarks

This method's result represents the transformation of left (or the current instance) followed by the transformation of right (or source).

The following equations demonstrate how the multiplication takes place.

Out = left * right

Out = this instance * source

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Multiply method as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Quaternion.Multiply
  • Microsoft.DirectX.Matrix.Multiply


UnsafeNativeMethods.Matrix.MultiplyTranspose(Matrix,Matrix,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.MultiplyTranspose Method

Calculates the transposed product of two matrices.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function MultiplyTranspose( _
ByVal pOut As Matrix, _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix MultiplyTranspose(
Matrix pOut,
Matrix left,
Matrix right
);
C++ public:
static Matrix MultiplyTranspose(
Matrix pOut,
Matrix left,
Matrix right
);
JScript public static function MultiplyTranspose(
pOut : Matrix,
left : Matrix,
right : Matrix
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that is the product and transposition of two matrices.
left Microsoft.DirectX.Matrix
Source Matrix structure.
right Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix

Remarks

This method's result is the transposed product of two transformation matrices:

Out = T(left * right).

Out = T(this instance * source).

This method is useful for setting matrices as constants for vertex and pixel shaders.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the MultiplyTranspose method as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Matrix.Multiply
  • Microsoft.DirectX.UnsafeNativeMethods.Quaternion.Multiply
  • Microsoft.DirectX.Matrix.Multiply


UnsafeNativeMethods.Matrix.RotationAxis(Matrix,Vector3,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.RotationAxis Method

Builds a matrix that rotates around an arbitrary axis.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function RotationAxis( _
ByVal pOut As Matrix, _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationAxis(
Matrix pOut,
Vector3 axisRotation,
float angle
);
C++ public:
static Matrix RotationAxis(
Matrix pOut,
Vector3 axisRotation,
float angle
);
JScript public static function RotationAxis(
pOut : Matrix,
axisRotation : Vector3,
angle : float
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
Rotated Matrix structure.
axisRotation Microsoft.DirectX.Vector3
A Vector3 structure that identifies the axis about which to rotate the matrix.
angle System.Single

Return Value

Microsoft.DirectX.Matrix
Rotated Matrix structure.

Remarks

The input rotation angle is in radians.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the RotationAxis method as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.RotationAxis


UnsafeNativeMethods.Matrix.RotationQuaternion(Matrix,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.RotationQuaternion Method

Builds a matrix from a quaternion.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function RotationQuaternion( _
ByVal pOut As Matrix, _
ByVal quat As Quaternion _
) As Matrix
C# public static Matrix RotationQuaternion(
Matrix pOut,
Quaternion quat
);
C++ public:
static Matrix RotationQuaternion(
Matrix pOut,
Quaternion quat
);
JScript public static function RotationQuaternion(
pOut : Matrix,
quat : Quaternion
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
Rotated Matrix structure.
quat Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Matrix
Rotated Matrix structure.

Remarks

For information about how to calculate quaternion values from a direction vector (x, y, z) and an angle of rotation, see Quaternion.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the RotationQuaternion method as a parameter for another method.

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Matrix.RotationAxis
  • Microsoft.DirectX.Matrix.RotationQuaternion


UnsafeNativeMethods.Matrix.Scaling(Matrix,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.Scaling Method

Builds a matrix that scales along the x-axis, y-axis, and z-axis.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Scaling( _
ByVal pOut As Matrix, _
ByVal v As Vector3 _
) As Matrix
C# public static Matrix Scaling(
Matrix pOut,
Vector3 v
);
C++ public:
static Matrix Scaling(
Matrix pOut,
Vector3 v
);
JScript public static function Scaling(
pOut : Matrix,
v : Vector3
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
Scaled Matrix structure.
v Microsoft.DirectX.Vector3
A Vector3 structure containing three values that represent the scaling factors applied along the x-axis, y-axis, and z-axis.

Return Value

Microsoft.DirectX.Matrix
Scaled Matrix structure.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Scaling method as a parameter for another method.


UnsafeNativeMethods.Matrix.Transformation(Matrix,Vector3,Quaternion,Vector3,Vector3,Quaternion,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.Transformation Method

Builds a transformation matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Transformation( _
ByVal pOut As Matrix, _
ByVal scalingCenter As Vector3, _
ByVal scalingRotation As Quaternion, _
ByVal scalingFactor As Vector3, _
ByVal rotationCenter As Vector3, _
ByVal rotation As Quaternion, _
ByVal translation As Vector3 _
) As Matrix
C# public static Matrix Transformation(
Matrix pOut,
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
C++ public:
static Matrix Transformation(
Matrix pOut,
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
JScript public static function Transformation(
pOut : Matrix,
scalingCenter : Vector3,
scalingRotation : Quaternion,
scalingFactor : Vector3,
rotationCenter : Vector3,
rotation : Quaternion,
translation : Vector3
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
Resulting Matrix structure.
scalingCenter Microsoft.DirectX.Vector3
A Vector3 structure that identifies the scaling center point.
scalingRotation Microsoft.DirectX.Quaternion
A Quaternion structure that specifies the scaling rotation. Use Quaternion.Identity to specify no scaling.
scalingFactor Microsoft.DirectX.Vector3
A Vector3 structure that is the scaling vector.
rotationCenter Microsoft.DirectX.Vector3
A Vector3 structure that is a point identifying the center of rotation.
rotation Microsoft.DirectX.Quaternion
A Quaternion structure that specifies the rotation. Use Quaternion.Identity to specify no rotation.
translation Microsoft.DirectX.Vector3
A Vector3 structure that represents the translation. Use Vector3.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix
Resulting Matrix structure.

Remarks

The Transformation method calculates the transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = output transformation matrix (the return value)
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scalingFactor)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Transformation method as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Transformation
  • Transformation2D


UnsafeNativeMethods.Matrix.Transformation2D(Matrix,Vector2,Single,Vector2,Vector2,Single,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.Transformation2D Method

Builds a 2-D transformation matrix in the xy plane.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Transformation2D( _
ByVal pOut As Matrix, _
ByVal scalingCenter As Vector2, _
ByVal scalingRotation As Single, _
ByVal scaling As Vector2, _
ByVal rotationCenter As Vector2, _
ByVal rotation As Single, _
ByVal translation As Vector2 _
) As Matrix
C# public static Matrix Transformation2D(
Matrix pOut,
Vector2 scalingCenter,
float scalingRotation,
Vector2 scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
C++ public:
static Matrix Transformation2D(
Matrix pOut,
Vector2 scalingCenter,
float scalingRotation,
Vector2 scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
JScript public static function Transformation2D(
pOut : Matrix,
scalingCenter : Vector2,
scalingRotation : float,
scaling : Vector2,
rotationCenter : Vector2,
rotation : float,
translation : Vector2
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that contains the transformation matrix.
scalingCenter Microsoft.DirectX.Vector2
A Vector2 structure that is a point identifying the scaling center.
scalingRotation System.Single
Scaling rotation factor. Use a zero value to specify no rotation.
scaling Microsoft.DirectX.Vector2
A Vector2 structure that is a point identifying the scale. Use Vector2.Empty to specify no scaling.
rotationCenter Microsoft.DirectX.Vector2
A Vector2 structure that is a point identifying the rotation center.
rotation System.Single
Angle of rotation, in radians.
translation Microsoft.DirectX.Vector2
A Vector2 structure that identifies the translation. Use Vector2.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that contains the transformation matrix.

Remarks

The Transformation2D method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order:

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = output transformation matrix (pOut)
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scaling)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Transformation2D method as a parameter for another method.

For 3-D transformations, use Transformation.

See Also

  • Microsoft.DirectX.Matrix.Transformation2D
  • Transformation


UnsafeNativeMethods.Matrix.Translation(Matrix,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Matrix.Translation Method

Builds a matrix using specified offsets.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Translation( _
ByVal pOut As Matrix, _
ByVal v As Vector3 _
) As Matrix
C# public static Matrix Translation(
Matrix pOut,
Vector3 v
);
C++ public:
static Matrix Translation(
Matrix pOut,
Vector3 v
);
JScript public static function Translation(
pOut : Matrix,
v : Vector3
) : Matrix;

Parameters

pOut Microsoft.DirectX.Matrix
A Matrix structure that contains a translated transformation matrix.
v Microsoft.DirectX.Vector3
A Vector3 structure that contains the x-coordinate, y-coordinate, and z-coordinate offsets.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that contains a translated transformation matrix.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Translation method as a parameter for another method.

See Also

  • Microsoft.DirectX.Matrix.Translation


MatrixStack Class (Microsoft.DirectX)

MatrixStack Class

Contains methods and properties that applications use to manipulate a matrix stack.

Definition

Visual Basic Public Class MatrixStack
Inherits MarshalByRefObject
Implements IDisposable
C# | public class MatrixStack : MarshalByRefObject, IDisposable
C++ | public ref class MatrixStack : MarshalByRefObject, IDisposable
JScript | public class MatrixStack extends MarshalByRefObject implements IDisposable

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Events

Event | Description
Disposing | Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Methods

Method | Description
Dispose | Immediately releases the unmanaged resources used by an object.
Finalize | Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.
LoadIdentity | Loads identity in the current matrix.
LoadMatrix | Loads a given matrix into the current matrix.
MatrixStack | Initializes a new instance of the MatrixStack class.
MultiplyMatrix | Determines the product of the current matrix and a given matrix.
MultiplyMatrixLocal | Determines the product of a given matrix and the current matrix.
Pop | Removes the current matrix from the top of the stack.
Push | Adds a matrix to the stack.
raise_Disposing | Raises a MatrixStack.Disposing event when called from within a derived class.
RotateAxis | Determines the product of the current matrix and the computed rotation matrix.
RotateAxisLocal | Determines the product of the current matrix and the computed rotation matrix.
RotateYawPitchRoll | Determines the product of the current matrix and the computed rotation matrix, which is composed of a given yaw, pitch, and roll.
RotateYawPitchRollLocal | Determines the product of the current matrix and the computed rotation matrix, which is composed of a given yaw, pitch, and roll.
Scale | Determines the product of the current matrix and the computed scale matrix composed from the given point (x, y, and z).
ScaleLocal | Determines the product of the computed scale matrix composed from the given point (x, y, and z) and the current matrix.
Translate | Determines the product of the current matrix and the computed translation matrix by the given factors (x, y, and z).
TranslateLocal | Determines the product of the computed translation matrix by the given factors (x, y, and z) and the current matrix.

Properties

Property | Description
Disposed | Retrieves a value that is true if the object is disposed; otherwise the value is false.
Top | Retrieves the current matrix at the top of the stack.

Inheritance Hierarchy

Object Leave Site
MarshalByRefObject Leave Site
MatrixStack

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


MatrixStack.Dispose() Method (Microsoft.DirectX)

MatrixStack.Dispose Method

Immediately releases the unmanaged resources used by an object.

Definition

Visual Basic | Overrides Public Sub Dispose()
C# | public override void Dispose();
C++ | ~MatrixStack();
JScript | public override function Dispose();

See Also

  • MatrixStack.Disposed
  • MatrixStack.Disposing


MatrixStack.Finalize() Method (Microsoft.DirectX)

MatrixStack.Finalize Method

Called during garbage collection. If implemented, allows an object to free resources before it is destroyed by the garbage collector.

Definition

Visual Basic | Overrides Protected Sub Finalize()
C# | ~MatrixStack();
C++ | !MatrixStack();
JScript | protected override function Finalize();


MatrixStack.LoadIdentity() Method (Microsoft.DirectX)

MatrixStack.LoadIdentity Method

Loads identity in the current matrix.

Definition

Visual Basic | Public Sub LoadIdentity()
C# | public void LoadIdentity();
C++ public:
void LoadIdentity();
JScript | public function LoadIdentity();

Remarks

In an identity matrix, all coefficients are 0.0 except the [1,1][2,2][3,3][4,4] coefficients, which are set to 1.0. The identity matrix is special in that when it is applied to vertices, they are unchanged. The identity matrix is used as the starting point for matrices that modify vertex values to create rotations, translations, and any other transformations that can be represented by a 4x4 matrix.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.


MatrixStack.LoadMatrix(Matrix) Method (Microsoft.DirectX)

MatrixStack.LoadMatrix Method

Loads a given matrix into the current matrix.

Definition

Visual Basic Public Sub LoadMatrix( _
ByVal value As Matrix _
)
C# public void LoadMatrix(
Matrix value
);
C++ public:
void LoadMatrix(
Matrix value
);
JScript public function LoadMatrix(
value : Matrix
);

Parameters

value Microsoft.DirectX.Matrix
New Matrix to load into the current matrix.

Remarks

This method does not add an item to the stack; rather, it replaces the current matrix with the supplied matrix.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.LoadIdentity


MatrixStack.MatrixStack() Constructor (Microsoft.DirectX)

MatrixStack.MatrixStack Constructor

Initializes a new instance of the MatrixStack class.

Definition

Visual Basic | Public Sub New()
C# | public MatrixStack();
C++ public:
MatrixStack();
JScript | public function MatrixStack();


MatrixStack.MultiplyMatrix(Matrix) Method (Microsoft.DirectX)

MatrixStack.MultiplyMatrix Method

Determines the product of the current matrix and a given matrix.

Definition

Visual Basic Public Sub MultiplyMatrix( _
ByVal value As Matrix _
)
C# public void MultiplyMatrix(
Matrix value
);
C++ public:
void MultiplyMatrix(
Matrix value
);
JScript public function MultiplyMatrix(
value : Matrix
);

Parameters

value Microsoft.DirectX.Matrix
A Matrix to multiply with the current matrix.

Remarks

This method right-multiplies the given matrix by the current matrix (transformation is about the current world origin). The method does not add an item to the stack; rather, it replaces the current matrix with the product of the current matrix and the given matrix.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.MultiplyMatrixLocal


MatrixStack.MultiplyMatrixLocal(Matrix) Method (Microsoft.DirectX)

MatrixStack.MultiplyMatrixLocal Method

Determines the product of a given matrix and the current matrix.

Definition

Visual Basic Public Sub MultiplyMatrixLocal( _
ByVal value As Matrix _
)
C# public void MultiplyMatrixLocal(
Matrix value
);
C++ public:
void MultiplyMatrixLocal(
Matrix value
);
JScript public function MultiplyMatrixLocal(
value : Matrix
);

Parameters

value Microsoft.DirectX.Matrix
A Matrix to multiply with the current matrix.

Remarks

This method left-multiplies the given matrix by the current matrix (transformation is about the local origin of the object). The method does not add an item to the stack; rather, it replaces the current matrix with the product of the given matrix and the current matrix.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.MultiplyMatrixLocal


MatrixStack.Pop() Method (Microsoft.DirectX)

MatrixStack.Pop Method

Removes the current matrix from the top of the stack.

Definition

Visual Basic | Public Sub Pop()
C# | public void Pop();
C++ public:
void Pop();
JScript | public function Pop();

Remarks

This method decrements the count of items on the stack by 1, effectively removing the current matrix from the top of the stack and promoting a different matrix to that position. If the current count of items on the stack is 0, this method returns without taking any action. If the current count of items is 1, the method empties the stack.

See Also

  • MatrixStack.Push
  • MatrixStack.Top


MatrixStack.Push() Method (Microsoft.DirectX)

MatrixStack.Push Method

Adds a matrix to the stack.

Definition

Visual Basic | Public Sub Push()
C# | public void Push();
C++ public:
void Push();
JScript | public function Push();

Remarks

This method increments the count of items on the stack by 1. The stack grows dynamically as more items are added.

See Also

  • MatrixStack.Pop
  • MatrixStack.Top


MatrixStack.raise_Disposing(Object,EventArgs) Method (Microsoft.DirectX)

MatrixStack.raise_Disposing Method

Raises a MatrixStack.Disposing event when called from within a derived class.

Definition

Visual Basic Protected Sub raise_Disposing( _
ByVal i1 As Object, _
ByVal i2 As EventArgs _
)
C# protected void raise_Disposing(
object i1,
EventArgs i2
);
C++ protected:
void raise_Disposing(
Object^ i1,
EventArgs^ i2
);
JScript protected function raise_Disposing(
i1 : Object,
i2 : EventArgs
);

Parameters

i1 System.Object
Invoking object reference. Should be the current object.
i2 System.EventArgs
Arguments to pass into the event handler.

Remarks

This method is a protected member.


MatrixStack.RotateAxis(Vector3,Single) Method (Microsoft.DirectX)

MatrixStack.RotateAxis Method

Determines the product of the current matrix and the computed rotation matrix.

Definition

Visual Basic Public Sub RotateAxis( _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
)
C# public void RotateAxis(
Vector3 axisRotation,
float angle
);
C++ public:
void RotateAxis(
Vector3 axisRotation,
float angle
);
JScript public function RotateAxis(
axisRotation : Vector3,
angle : float
);

Parameters

axisRotation Microsoft.DirectX.Vector3
A Vector3 structure that represents the rotation axis to use for the calculation.
angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Remarks

This method right-multiplies the current matrix by the computed rotation matrix, counterclockwise about the given axis with the given angle (rotation is about the current world origin).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.RotateAxisLocal
  • MatrixStack.RotateYawPitchRoll
  • MatrixStack.RotateYawPitchRollLocal


MatrixStack.RotateAxisLocal(Vector3,Single) Method (Microsoft.DirectX)

MatrixStack.RotateAxisLocal Method

Determines the product of the current matrix and the computed rotation matrix.

Definition

Visual Basic Public Sub RotateAxisLocal( _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
)
C# public void RotateAxisLocal(
Vector3 axisRotation,
float angle
);
C++ public:
void RotateAxisLocal(
Vector3 axisRotation,
float angle
);
JScript public function RotateAxisLocal(
axisRotation : Vector3,
angle : float
);

Parameters

axisRotation Microsoft.DirectX.Vector3
A Vector3 structure that represents the rotation axis to use for the calculation.
angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Remarks

This method left-multiplies the current matrix with the computed rotation matrix, counterclockwise around the given axis with the given angle (rotation is around the local origin of the object).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.RotateAxis
  • MatrixStack.RotateYawPitchRoll
  • MatrixStack.RotateYawPitchRollLocal


MatrixStack.RotateYawPitchRoll(Single,Single,Single) Method (Microsoft.DirectX)

MatrixStack.RotateYawPitchRoll Method

Determines the product of the current matrix and the computed rotation matrix, which is composed of a given yaw, pitch, and roll.

Definition

Visual Basic Public Sub RotateYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
)
C# public void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
C++ public:
void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript public function RotateYawPitchRoll(
yaw : float,
pitch : float,
roll : float
);

Parameters

yaw System.Single
Floating-point value that represents the yaw around the y-axis, in radians.
pitch System.Single
Floating-point value that represents the pitch around the x-axis, in radians.
roll System.Single
Floating-point value that represents the roll around the z-axis, in radians.

Remarks

This method right-multiplies the current matrix by the computed rotation matrix. All angles are counterclockwise and rotation is about the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.RotateAxis
  • MatrixStack.RotateAxisLocal
  • MatrixStack.RotateYawPitchRollLocal


MatrixStack.RotateYawPitchRollLocal(Single,Single,Single) Method (Microsoft.DirectX)

MatrixStack.RotateYawPitchRollLocal Method

Determines the product of the current matrix and the computed rotation matrix, which is composed of a given yaw, pitch, and roll.

Definition

Visual Basic Public Sub RotateYawPitchRollLocal( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
)
C# public void RotateYawPitchRollLocal(
float yaw,
float pitch,
float roll
);
C++ public:
void RotateYawPitchRollLocal(
float yaw,
float pitch,
float roll
);
JScript public function RotateYawPitchRollLocal(
yaw : float,
pitch : float,
roll : float
);

Parameters

yaw System.Single
Floating-point value that represents the yaw around the y-axis, in radians.
pitch System.Single
Floating-point value that represents the pitch around the x-axis, in radians.
roll System.Single
Floating-point value that represents the roll around the z-axis, in radians.

Remarks

This method left-multiplies the current matrix with the computed rotation matrix. All angles are counterclockwise and rotation is about the local origin of the object.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.RotateAxis
  • MatrixStack.RotateAxisLocal
  • MatrixStack.RotateYawPitchRoll


MatrixStack.Scale Method ()

Determines the product of the current matrix and the computed scale matrix composed from the given point (x, y, and z).

Overload List

public void Scale(float, float, float);
public void Scale(Vector3);

Remarks

This method right-multiplies the current matrix by the computed scale matrix. The transformation is about the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.ScaleLocal


MatrixStack.Scale(Vector3) Method (Microsoft.DirectX)

MatrixStack.Scale Method

Determines the product of the current matrix and the computed scale matrix composed from the given point (x, y, and z).

Definition

Visual Basic Public Sub Scale( _
ByVal scale As Vector3 _
)
C# public void Scale(
Vector3 scale
);
C++ public:
void Scale(
Vector3 scale
);
JScript public function Scale(
scale : Vector3
);

Parameters

scale Microsoft.DirectX.Vector3
A Vector3 object that represents the scale values to use in the calculation.

Remarks

This method right-multiplies the current matrix by the computed scale matrix. The transformation is about the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.ScaleLocal


MatrixStack.Scale(Single,Single,Single) Method (Microsoft.DirectX)

MatrixStack.Scale Method

Determines the product of the current matrix and the computed scale matrix composed from the given point (x, y, and z).

Definition

Visual Basic Public Sub Scale( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void Scale(
float x,
float y,
float z
);
C++ public:
void Scale(
float x,
float y,
float z
);
JScript public function Scale(
x : float,
y : float,
z : float
);

Parameters

x System.Single
Floating-point value that represents the scaling component in the x-direction.
y System.Single
Floating-point value that represents the scaling component in the y-direction.
z System.Single
Floating-point value that represents the scaling component in the z-direction.

Remarks

This method right-multiplies the current matrix by the computed scale matrix. The transformation is about the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.ScaleLocal


MatrixStack.ScaleLocal Method ()

Determines the product of the computed scale matrix composed from the given point (x, y, and z) and the current matrix.

Overload List

public void ScaleLocal(float, float, float);
public void ScaleLocal(Vector3);

Remarks

This method left-multiplies the current matrix with the computed scale matrix. The transformation is about the local origin of the object.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Scale


MatrixStack.ScaleLocal(Vector3) Method (Microsoft.DirectX)

MatrixStack.ScaleLocal Method

Determines the product of the computed scale matrix composed from the given point (x, y, and z) and the current matrix.

Definition

Visual Basic Public Sub ScaleLocal( _
ByVal scale As Vector3 _
)
C# public void ScaleLocal(
Vector3 scale
);
C++ public:
void ScaleLocal(
Vector3 scale
);
JScript public function ScaleLocal(
scale : Vector3
);

Parameters

scale Microsoft.DirectX.Vector3
A Vector3 object that represents the scale values to use in the calculation.

Remarks

This method left-multiplies the current matrix with the computed scale matrix. The transformation is about the local origin of the object.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Scale


MatrixStack.ScaleLocal(Single,Single,Single) Method (Microsoft.DirectX)

MatrixStack.ScaleLocal Method

Determines the product of the computed scale matrix composed from the given point (x, y, and z) and the current matrix.

Definition

Visual Basic Public Sub ScaleLocal( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void ScaleLocal(
float x,
float y,
float z
);
C++ public:
void ScaleLocal(
float x,
float y,
float z
);
JScript public function ScaleLocal(
x : float,
y : float,
z : float
);

Parameters

x System.Single
Floating-point value that represents the scaling component in the x-direction.
y System.Single
Floating-point value that represents the scaling component in the y-direction.
z System.Single
Floating-point value that represents the scaling component in the z-direction.

Remarks

This method left-multiplies the current matrix with the computed scale matrix. The transformation is about the local origin of the object.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Scale


MatrixStack.Translate Method ()

Determines the product of the current matrix and the computed translation matrix by the given factors (x, y, and z).

Overload List

public void Translate(float, float, float);
public void Translate(Vector3);

Remarks

This method right-multiplies the current matrix by the computed translation matrix. The transformation is around the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.TranslateLocal


MatrixStack.Translate(Vector3) Method (Microsoft.DirectX)

MatrixStack.Translate Method

Determines the product of the current matrix and the computed translation matrix by the given factors (x, y, and z).

Definition

Visual Basic Public Sub Translate( _
ByVal trans As Vector3 _
)
C# public void Translate(
Vector3 trans
);
C++ public:
void Translate(
Vector3 trans
);
JScript public function Translate(
trans : Vector3
);

Parameters

trans Microsoft.DirectX.Vector3
A Vector3 object that represents the translation factors to use in the calculation.

Remarks

This method right-multiplies the current matrix by the computed translation matrix. The transformation is around the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.TranslateLocal


MatrixStack.Translate(Single,Single,Single) Method (Microsoft.DirectX)

MatrixStack.Translate Method

Determines the product of the current matrix and the computed translation matrix by the given factors (x, y, and z).

Definition

Visual Basic Public Sub Translate( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void Translate(
float x,
float y,
float z
);
C++ public:
void Translate(
float x,
float y,
float z
);
JScript public function Translate(
x : float,
y : float,
z : float
);

Parameters

x System.Single
Floating-point value that represents the translation factor in the x-direction.
y System.Single
Floating-point value that represents the translation factor in the y-direction.
z System.Single
Floating-point value that represents the translation factor in the z-direction.

Remarks

This method right-multiplies the current matrix by the computed translation matrix. The transformation is around the current world origin.

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.TranslateLocal


MatrixStack.TranslateLocal Method ()

Determines the product of the computed translation matrix by the given factors (x, y, and z) and the current matrix.

Overload List

public void TranslateLocal(float, float, float);
public void TranslateLocal(Vector3);

Remarks

This method left-multiplies the current matrix by the computed translation matrix (transformation is around the local origin of the object).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Translate


MatrixStack.TranslateLocal(Vector3) Method (Microsoft.DirectX)

MatrixStack.TranslateLocal Method

Determines the product of the computed translation matrix by the given factors (x, y, and z) and the current matrix.

Definition

Visual Basic Public Sub TranslateLocal( _
ByVal trans As Vector3 _
)
C# public void TranslateLocal(
Vector3 trans
);
C++ public:
void TranslateLocal(
Vector3 trans
);
JScript public function TranslateLocal(
trans : Vector3
);

Parameters

trans Microsoft.DirectX.Vector3
A Vector3 object that represents the translation factors to use in the calculation.

Remarks

This method left-multiplies the current matrix by the computed translation matrix (transformation is around the local origin of the object).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Translate


MatrixStack.TranslateLocal(Single,Single,Single) Method (Microsoft.DirectX)

MatrixStack.TranslateLocal Method

Determines the product of the computed translation matrix by the given factors (x, y, and z) and the current matrix.

Definition

Visual Basic Public Sub TranslateLocal( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void TranslateLocal(
float x,
float y,
float z
);
C++ public:
void TranslateLocal(
float x,
float y,
float z
);
JScript public function TranslateLocal(
x : float,
y : float,
z : float
);

Parameters

x System.Single
Floating-point value that represents the translation factor in the x-direction.
y System.Single
Floating-point value that represents the translation factor in the y-direction.
z System.Single
Floating-point value that represents the translation factor in the z-direction.

Remarks

This method left-multiplies the current matrix by the computed translation matrix (transformation is around the local origin of the object).

Exceptions
InvalidCallException The method call is invalid. For example, a method's parameter might contain an invalid value.

See Also

  • MatrixStack.Translate


MatrixStack.Disposed Property (Microsoft.DirectX)

MatrixStack.Disposed Property

Retrieves a value that is true if the object is disposed; otherwise the value is false.

Definition

Visual Basic | Public ReadOnly Property Disposed As Boolean
C# | public bool Disposed { get; }
C++ public:
property bool Disposed {
bool get();
}
JScript | public function get Disposed() : boolean

Property Value

System.Boolean
Value that indicates whether the object is disposed.

This property is read-only.


MatrixStack.Top Property (Microsoft.DirectX)

MatrixStack.Top Property

Retrieves the current matrix at the top of the stack.

Definition

Visual Basic | Public ReadOnly Property Top As Matrix
C# | public Matrix Top { get; }
C++ public:
property Matrix Top {
Matrix get();
}
JScript | public function get Top() : Matrix

Property Value

Microsoft.DirectX.Matrix
The Matrix at the top of the matrix stack.

This property is read-only.


MatrixStack.Disposing Event (Microsoft.DirectX)

MatrixStack.Disposing Event

Occurs when the Dispose method is called or when the object is finalized and collected by the garbage collector of the Microsoft .NET common language runtime.

Definition

Visual Basic | Public Event Disposing As EventHandler
C# | public event EventHandler Disposing;
C++ public:
event EventHandler^ Disposing;
JScript | In JScript, you can use events, but you cannot define your own.

Remarks

To add an event handler that listens for a MatrixStack.Disposing event, use the following C# code.

[C#]
ms.Disposing += new System.EventHandler(this.DisposingEventHandler);

The Dispose property of an object indicates whether that object has been disposed.


Plane Class (Microsoft.DirectX)

UnsafeNativeMethods.Plane Class

Describes and manipulates a plane.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the methods of the Microsoft.DirectX.Plane structure.

Definition

Visual Basic NotInheritable MustInherit Public Class Plane
Inherits Object
C# | public abstract sealed class Plane : Object
C++ | public ref class Plane abstract sealed : Object
JScript | public final abstract class Plane extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic) Dot Computes the dot product of a plane and a vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) DotCoordinate Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) DotNormal Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 0.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) FromPointNormal Constructs a plane from a point and a normal.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) FromPoints Constructs a plane from three points.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) IntersectLine Finds the intersection between a plane and a line.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Normalize Returns the normal of a plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Scale Scales the plane with a given scaling factor.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Transform Transforms a plane by a matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformArray Transforms an array of planes by a matrix. The vectors that describe each plane must be normalized.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Plane

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Microsoft.DirectX.Plane Structure


UnsafeNativeMethods.Plane.Dot(Plane,Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.Dot Method

Computes the dot product of a plane and a vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Dot( _
ByVal pPlane As Plane, _
ByVal pV As Vector4 _
) As Single
C# public static float Dot(
Plane pPlane,
Vector4 pV
);
C++ public:
static float Dot(
Plane pPlane,
Vector4 pV
);
JScript public static function Dot(
pPlane : Plane,
pV : Vector4
) : float;

Parameters

pPlane Microsoft.DirectX.Plane
Source Plane structure.
pV Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

System.Single
A Single Leave Site value that is the dot product of the plane and the vector.

Remarks

Given a plane (a, b, c, d) and a 4-D vector (x, y, z, w), this method's return value is a*x + b*y + c*z + d*w. The Dot method is useful for determining the plane's relationship with a homogeneous coordinate. For example, it can determine whether a coordinate is on a particular plane, or on which side of a particular plane a coordinate lies.

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*1. The Dot method is useful for determining the plane's relationship with a coordinate in 3-D space.

See Also

  • DotNormal
  • Microsoft.DirectX.Plane.Dot


UnsafeNativeMethods.Plane.DotCoordinate(Plane,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.DotCoordinate Method

Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 1.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function DotCoordinate( _
ByVal pPlane As Plane, _
ByVal pV As Vector3 _
) As Single
C# public static float DotCoordinate(
Plane pPlane,
Vector3 pV
);
C++ public:
static float DotCoordinate(
Plane pPlane,
Vector3 pV
);
JScript public static function DotCoordinate(
pPlane : Plane,
pV : Vector3
) : float;

Parameters

pPlane Microsoft.DirectX.Plane
Source Plane structure.
pV Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that is the dot product of the plane and the vector.

Remarks

Given a plane (a, b, c, d) and a 3-D vector (x, y, z) the return value of this function is a*x + b*y + c*z + d*1. The DotCoordinate method is useful for determining the plane's relationship with a coordinate in 3-D space.


UnsafeNativeMethods.Plane.DotNormal(Plane,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.DotNormal Method

Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 0.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function DotNormal( _
ByVal pPlane As Plane, _
ByVal pV As Vector3 _
) As Single
C# public static float DotNormal(
Plane pPlane,
Vector3 pV
);
C++ public:
static float DotNormal(
Plane pPlane,
Vector3 pV
);
JScript public static function DotNormal(
pPlane : Plane,
pV : Vector3
) : float;

Parameters

pPlane Microsoft.DirectX.Plane
pV Microsoft.DirectX.Vector3

Return Value

System.Single
A Single Leave Site value that represents the dot product of the plane and the 3-D vector.

Remarks

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*0. The DotNormal method is useful for calculating the angle between the normal of the plane and another normal.

See Also

  • Microsoft.DirectX.Plane.DotNormal


UnsafeNativeMethods.Plane.FromPointNormal(Plane,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.FromPointNormal Method

Constructs a plane from a point and a normal.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function FromPointNormal( _
ByVal pOut As Plane, _
ByVal pPoint As Vector3, _
ByVal pNormal As Vector3 _
) As Plane
C# public static Plane FromPointNormal(
Plane pOut,
Vector3 pPoint,
Vector3 pNormal
);
C++ public:
static Plane FromPointNormal(
Plane pOut,
Vector3 pPoint,
Vector3 pNormal
);
JScript public static function FromPointNormal(
pOut : Plane,
pPoint : Vector3,
pNormal : Vector3
) : Plane;

Parameters

pOut Microsoft.DirectX.Plane
A Plane structure constructed from the point and the normal.
pPoint Microsoft.DirectX.Vector3
A Vector3 structure that defines the point used to construct the plane.
pNormal Microsoft.DirectX.Vector3
A Vector3 structure that defines the normal used to construct the plane.

Return Value

Microsoft.DirectX.Plane
A Plane structure constructed from the point and the normal.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the FromPointNormal method as a parameter for another method.

See Also

  • Microsoft.DirectX.Plane Structure
  • Microsoft.DirectX.Plane.PointNormal


UnsafeNativeMethods.Plane.FromPoints(Plane,Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.FromPoints Method

Constructs a plane from three points.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function FromPoints( _
ByVal pOut As Plane, _
ByVal pPoint1 As Vector3, _
ByVal pPoint2 As Vector3, _
ByVal pPoint3 As Vector3 _
) As Plane
C# public static Plane FromPoints(
Plane pOut,
Vector3 pPoint1,
Vector3 pPoint2,
Vector3 pPoint3
);
C++ public:
static Plane FromPoints(
Plane pOut,
Vector3 pPoint1,
Vector3 pPoint2,
Vector3 pPoint3
);
JScript public static function FromPoints(
pOut : Plane,
pPoint1 : Vector3,
pPoint2 : Vector3,
pPoint3 : Vector3
) : Plane;

Parameters

pOut Microsoft.DirectX.Plane
A Plane structure constructed from the given points.
pPoint1 Microsoft.DirectX.Vector3
A Vector3 structure that defines one of the points used to construct the plane.
pPoint2 Microsoft.DirectX.Vector3
A Vector3 structure that defines one of the points used to construct the plane.
pPoint3 Microsoft.DirectX.Vector3
A Vector3 structure that defines one of the points used to construct the plane.

Return Value

Microsoft.DirectX.Plane
A Plane structure constructed from the given points.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the FromPoints method as a parameter for another method.

See Also

  • FromPointNormal
  • Microsoft.DirectX.Plane.FromPoints


UnsafeNativeMethods.Plane.IntersectLine(Vector3,Plane,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.IntersectLine Method

Finds the intersection between a plane and a line.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function IntersectLine( _
ByVal pOut As Vector3, _
ByVal pPlane As Plane, _
ByVal pV1 As Vector3, _
ByVal pV2 As Vector3 _
) As Vector3
C# public static Vector3 IntersectLine(
Vector3 pOut,
Plane pPlane,
Vector3 pV1,
Vector3 pV2
);
C++ public:
static Vector3 IntersectLine(
Vector3 pOut,
Plane pPlane,
Vector3 pV1,
Vector3 pV2
);
JScript public static function IntersectLine(
pOut : Vector3,
pPlane : Plane,
pV1 : Vector3,
pV2 : Vector3
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the intersection between the specified plane and line.
pPlane Microsoft.DirectX.Plane
Source Plane structure.
pV1 Microsoft.DirectX.Vector3
Source Vector3 structure that defines a line starting point.
pV2 Microsoft.DirectX.Vector3
Source Vector3 structure that defines a line ending point.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the intersection between the specified plane and line.

Remarks

If the line is parallel to the plane, a null pointer is returned.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the IntersectLine method as a parameter for another method.

See Also

  • Microsoft.DirectX.Plane.IntersectLine


UnsafeNativeMethods.Plane.Normalize(Plane,Plane) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.Normalize Method

Returns the normal of a plane.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal pOut As Plane, _
ByVal pPlane As Plane _
) As Plane
C# public static Plane Normalize(
Plane pOut,
Plane pPlane
);
C++ public:
static Plane Normalize(
Plane pOut,
Plane pPlane
);
JScript public static function Normalize(
pOut : Plane,
pPlane : Plane
) : Plane;

Parameters

pOut Microsoft.DirectX.Plane
A Plane structure that represents the normal of the plane.
pPlane Microsoft.DirectX.Plane
Source Plane structure.

Return Value

Microsoft.DirectX.Plane
A Plane structure that represents the normal of the plane.

Remarks

This method normalizes a plane so that |a, b, c| == 1.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Normalize method as a parameter for another method.

See Also

  • Microsoft.DirectX.Plane.Normalize


UnsafeNativeMethods.Plane.Scale(Plane,Plane,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.Scale Method

Scales the plane with a given scaling factor.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Scale( _
ByVal pOut As Plane, _
ByVal pPlane As Plane, _
ByVal s As Single _
) As Plane
C# public static Plane Scale(
Plane pOut,
Plane pPlane,
float s
);
C++ public:
static Plane Scale(
Plane pOut,
Plane pPlane,
float s
);
JScript public static function Scale(
pOut : Plane,
pPlane : Plane,
s : float
) : Plane;

Parameters

pOut Microsoft.DirectX.Plane
The Plane structure that represents the scaled plane.
pPlane Microsoft.DirectX.Plane
Pointer to the source Plane structure.
s System.Single
Scale factor.

Return Value

Microsoft.DirectX.Plane
The Plane structure that represents the scaled plane.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Scale method as a parameter for another method.

See Also

  • Microsoft.DirectX.Plane.Scale


UnsafeNativeMethods.Plane.Transform(Plane,Plane,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.Transform Method

Transforms a plane by a matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Transform( _
ByVal pOut As Plane, _
ByVal pPlane As Plane, _
ByVal pMatrix As Matrix _
) As Plane
C# public static Plane Transform(
Plane pOut,
Plane pPlane,
Matrix pMatrix
);
C++ public:
static Plane Transform(
Plane pOut,
Plane pPlane,
Matrix pMatrix
);
JScript public static function Transform(
pOut : Plane,
pPlane : Plane,
pMatrix : Matrix
) : Plane;

Parameters

pOut Microsoft.DirectX.Plane
A Plane structure that represents the transformed plane.
pPlane Microsoft.DirectX.Plane
Input Plane structure, which contains the plane to be transformed. The vector (a,b,c) that describes the plane must be normalized before this method is called.
pMatrix Microsoft.DirectX.Matrix
Source Matrix structure, which contains the transformation values. This matrix must contain the inverse transpose of the transformation values.

Return Value

Microsoft.DirectX.Plane
A Plane structure that represents the transformed plane.

Remarks

The input matrix is the inverse transpose of the actual transformation.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Transform method as a parameter for another method.

See Also

  • Normalize
  • Microsoft.DirectX.Plane.Transform


UnsafeNativeMethods.Plane.TransformArray(Plane,Int32,Plane,Int32,Matrix,Int32) Method (Microsoft.DirectX)

UnsafeNativeMethods.Plane.TransformArray Method

Transforms an array of planes by a matrix. The vectors that describe each plane must be normalized.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformArray( _
ByVal pOut As Plane, _
ByVal outStride As Integer, _
ByVal pPlane As Plane, _
ByVal vectorStride As Integer, _
ByVal pMatrix As Matrix, _
ByVal count As Integer _
) As Plane
C# public static Plane TransformArray(
Plane pOut,
int outStride,
Plane pPlane,
int vectorStride,
Matrix pMatrix,
int count
);
C++ public:
static Plane TransformArray(
Plane pOut,
int outStride,
Plane pPlane,
int vectorStride,
Matrix pMatrix,
int count
);
JScript public static function TransformArray(
pOut : Plane,
outStride : int,
pPlane : Plane,
vectorStride : int,
pMatrix : Matrix,
count : int
) : Plane;

Parameters

pOut Microsoft.DirectX.Plane
A Plane structure that represents the transformed plane.
outStride System.Int32
The stride of each transformed plane.
pPlane Microsoft.DirectX.Plane
Input Plane structure, which contains the plane to be transformed. The vector (a,b,c) that describes the plane must be normalized before this method is called.
vectorStride System.Int32
The stride of each non-transformed plane.
pMatrix Microsoft.DirectX.Matrix
Source Matrix structure, which contains the transformation values. This matrix must contain the inverse transpose of the transformation values.
count System.Int32
The number of planes to transform.

Return Value

Microsoft.DirectX.Plane
A Plane structure that represents the transformed plane.

Remarks

The input matrix is the inverse transpose of the actual transformation.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformArray method as a parameter for another method.

See Also

  • Normalize
  • Transform


Quaternion Class (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion Class

Describes and manipulates a quaternion.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the methods of the Microsoft.DirectX.Quaternion structure.

Definition

Visual Basic NotInheritable MustInherit Public Class Quaternion
Inherits Object
C# | public abstract sealed class Quaternion : Object
C++ | public ref class Quaternion abstract sealed : Object
JScript | public final abstract class Quaternion extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic) BaryCentric Returns a quaternion in barycentric coordinates.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Conjugate Returns the conjugate of a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Dot Returns the dot product of two quaternions.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Exp Calculates the exponential.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Invert Conjugates and re-normalizes a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Length Returns the length of a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) LengthSq Returns the square of a quaternion's length.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Ln Calculates the natural logarithm.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Multiply Multiplies two quaternions.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Normalize Returns the normal of a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) RotationAxis Builds a quaternion that is rotated around an arbitrary axis.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) RotationMatrix Builds a quaternion from a rotation matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Slerp Interpolates between two quaternions, using spherical linear interpolation.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Squad Interpolates between quaternions, using spherical quadrangle interpolation.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) SquadSetup Sets up control points for spherical quadrangle interpolation.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) ToAxisAngle Computes a quaternion's axis and angle of rotation.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Quaternion

Remarks

Quaternions add a fourth element to the [ x, y, z] values that define a vector, resulting in arbitrary 4-D vectors. However, the following example illustrates how each element of a unit quaternion relates to an axis-angle rotation, where q represents a unit quaternion (x, y, z, w), axis is normalized, and theta is the desired counterclockwise (CCW) rotation around the axis.

q.x = sin(theta/2) * axis.x

q.y = sin(theta/2) * axis.y

q.z = sin(theta/2) * axis.z

q.w = cos(theta/2)

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Vectors, Vertices, and Quaternions
  • Microsoft.DirectX.Quaternion Structure


UnsafeNativeMethods.Quaternion.BaryCentric(Quaternion,Quaternion,Quaternion,Quaternion,Single,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.BaryCentric Method

Returns a quaternion in barycentric coordinates.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function BaryCentric( _
ByVal pOut As Quaternion, _
ByVal pQuat1 As Quaternion, _
ByVal pQuat2 As Quaternion, _
ByVal pQuat3 As Quaternion, _
ByVal f As Single, _
ByVal g As Single _
) As Quaternion
C# public static Quaternion BaryCentric(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2,
Quaternion pQuat3,
float f,
float g
);
C++ public:
static Quaternion BaryCentric(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2,
Quaternion pQuat3,
float f,
float g
);
JScript public static function BaryCentric(
pOut : Quaternion,
pQuat1 : Quaternion,
pQuat2 : Quaternion,
pQuat3 : Quaternion,
f : float,
g : float
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
Resulting Quaternion structure in barycentric coordinates.
pQuat1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
pQuat2 Microsoft.DirectX.Quaternion
Source Quaternion structure.
pQuat3 Microsoft.DirectX.Quaternion
Source Quaternion structure.
f System.Single
Weighting factor. See Remarks.
g System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Quaternion
Resulting Quaternion structure in barycentric coordinates.

Remarks

To compute the barycentric coordinates, the BaryCentric method implements the following series of spherical linear interpolation operations.

Slerp(Slerp(pQuat1, pQuat2, f + g))

Slerp(pQuat1, pQuat3, f + g)

g/(f + g)

The return value for this method is the same value returned in the pOut parameter. This allows you to use the BaryCentric method as a parameter for another method.

See Also

  • Slerp
  • Microsoft.DirectX.Quaternion.BaryCentric


UnsafeNativeMethods.Quaternion.Conjugate(Quaternion,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Conjugate Method

Returns the conjugate of a quaternion.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Conjugate( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Conjugate(
Quaternion pOut,
Quaternion pQuat
);
C++ public:
static Quaternion Conjugate(
Quaternion pOut,
Quaternion pQuat
);
JScript public static function Conjugate(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure that is the conjugate of the pQuat parameter.
pQuat Microsoft.DirectX.Quaternion
Source Quaternion.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the conjugate of the pQuat parameter.

Remarks

Given a quaternion (x, y, z, w), the Conjugate method returns the quaternion (-x, -y, -z, w).

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Conjugate method as a parameter for another method.

See Also

  • Invert
  • Microsoft.DirectX.Quaternion.Conjugate


UnsafeNativeMethods.Quaternion.Dot(Quaternion,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Dot Method

Returns the dot product of two quaternions.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Dot( _
ByVal pQuat1 As Quaternion, _
ByVal pQuat2 As Quaternion _
) As Single
C# public static float Dot(
Quaternion pQuat1,
Quaternion pQuat2
);
C++ public:
static float Dot(
Quaternion pQuat1,
Quaternion pQuat2
);
JScript public static function Dot(
pQuat1 : Quaternion,
pQuat2 : Quaternion
) : float;

Parameters

pQuat1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
pQuat2 Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

System.Single
Dot product of two quaternions.

See Also

  • Microsoft.DirectX.Quaternion.Dot


UnsafeNativeMethods.Quaternion.Exp(Quaternion,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Exp Method

Calculates the exponential.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Exp( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Exp(
Quaternion pOut,
Quaternion pQuat
);
C++ public:
static Quaternion Exp(
Quaternion pOut,
Quaternion pQuat
);
JScript public static function Exp(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
The Quaternion structure that is the exponential of the pQuat parameter.
pQuat Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
The Quaternion structure that is the exponential of the pQuat parameter.

Remarks

The Exp method converts a pure quaternion to a unit quaternion. The method expects a pure quaternion, where w is ignored in the calculation (w == 0). In the following example, v represents the vector portion of a quaternion.

Given a pure quaternion defined by:
q = (0, theta * v);

This method calculates the exponential result.
exp(Q) = (cos(theta), sin(theta) * v)

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Exp method as a parameter for another method.

See Also

  • Microsoft.DirectX.Quaternion.Exp


UnsafeNativeMethods.Quaternion.Invert(Quaternion,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Invert Method

Conjugates and re-normalizes a quaternion.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Invert( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Invert(
Quaternion pOut,
Quaternion pQuat
);
C++ public:
static Quaternion Invert(
Quaternion pOut,
Quaternion pQuat
);
JScript public static function Invert(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure that is the inverse of the quaternion passed into the pQuat parameter.
pQuat Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the inverse of the quaternion passed into the pQuat parameter.

Remarks

A unit quaternion is defined by the following equation.

q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of q is ln(q) = (0, theta * v)

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Invert method as a parameter for another method.

See Also

  • Conjugate
  • Normalize
  • Microsoft.DirectX.Quaternion.Invert


UnsafeNativeMethods.Quaternion.Length(Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Length Method

Returns the length of a quaternion.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Length( _
ByVal pQuat As Quaternion _
) As Single
C# public static float Length(
Quaternion pQuat
);
C++ public:
static float Length(
Quaternion pQuat
);
JScript public static function Length(
pQuat : Quaternion
) : float;

Parameters

pQuat Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

System.Single
A Single Leave Site value that represents the quaternion's length.

See Also

  • LengthSq
  • Microsoft.DirectX.Quaternion.Length


UnsafeNativeMethods.Quaternion.LengthSq(Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.LengthSq Method

Returns the square of a quaternion's length.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function LengthSq( _
ByVal pQuat As Quaternion _
) As Single
C# public static float LengthSq(
Quaternion pQuat
);
C++ public:
static float LengthSq(
Quaternion pQuat
);
JScript public static function LengthSq(
pQuat : Quaternion
) : float;

Parameters

pQuat Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

System.Single
A Single Leave Site value that represents the quaternion's squared length.

See Also

  • Length
  • Microsoft.DirectX.Quaternion.LengthSq


UnsafeNativeMethods.Quaternion.Ln(Quaternion,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Ln Method

Calculates the natural logarithm.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Ln( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Ln(
Quaternion pOut,
Quaternion pQuat
);
C++ public:
static Quaternion Ln(
Quaternion pOut,
Quaternion pQuat
);
JScript public static function Ln(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure that is the natural logarithm of the quaternion passed into the pQuat parameter.
pQuat Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the natural logarithm of the quaternion passed into the pQuat parameter.

Remarks

The Ln method works only for unit quaternions.

A unit quaternion is defined by the following example.

Q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of Q is ln(Q) = (0, theta * v)

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Ln method as a parameter for another method.

See Also

  • Exp
  • Squad
  • Microsoft.DirectX.Quaternion.Ln


UnsafeNativeMethods.Quaternion.Multiply(Quaternion,Quaternion,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Multiply Method

Multiplies two quaternions.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Multiply( _
ByVal pOut As Quaternion, _
ByVal pQuat1 As Quaternion, _
ByVal pQuat2 As Quaternion _
) As Quaternion
C# public static Quaternion Multiply(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2
);
C++ public:
static Quaternion Multiply(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2
);
JScript public static function Multiply(
pOut : Quaternion,
pQuat1 : Quaternion,
pQuat2 : Quaternion
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure that is the product of two quaternions.
pQuat1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
pQuat2 Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the product of two quaternions.

Remarks

Transformations are concatenated in the same order for the Quaternion.Multiply and Matrix.Multiply methods. In the following C# code example, assuming that mX and mY represent the same rotations as qX and qY, both m and q represent the same rotations.

[C#]

m = Matrix.Multiply(mX, mY);

q = Quaternion.Multiply(qX, qY);
The multiplication of quaternions is not commutative; that is, the order in which they are multiplied is important.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Multiply method as a parameter for another method.

See Also

  • Multiply
  • Microsoft.DirectX.Quaternion.Multiply


UnsafeNativeMethods.Quaternion.Normalize(Quaternion,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Normalize Method

Returns the normal of a quaternion.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal pOut As Quaternion, _
ByVal pQuat As Quaternion _
) As Quaternion
C# public static Quaternion Normalize(
Quaternion pOut,
Quaternion pQuat
);
C++ public:
static Quaternion Normalize(
Quaternion pOut,
Quaternion pQuat
);
JScript public static function Normalize(
pOut : Quaternion,
pQuat : Quaternion
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure that is the normal of the quaternion.
pQuat Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the normal of the quaternion.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Normalize method as a parameter for another method.

See Also

  • Invert
  • Microsoft.DirectX.Quaternion.Normalize


UnsafeNativeMethods.Quaternion.RotationAxis(Quaternion,Vector3,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.RotationAxis Method

Builds a quaternion that is rotated around an arbitrary axis.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function RotationAxis( _
ByVal pOut As Quaternion, _
ByVal pAxis As Vector3, _
ByVal angle As Single _
) As Quaternion
C# public static Quaternion RotationAxis(
Quaternion pOut,
Vector3 pAxis,
float angle
);
C++ public:
static Quaternion RotationAxis(
Quaternion pOut,
Vector3 pAxis,
float angle
);
JScript public static function RotationAxis(
pOut : Quaternion,
pAxis : Vector3,
angle : float
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure that is rotated around the specified axis.
pAxis Microsoft.DirectX.Vector3
A Vector3 structure that identifies the axis about which to rotate the quaternion.
angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is rotated around the specified axis.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the RotationAxis method as a parameter for another method.

See Also

  • RotationMatrix
  • Microsoft.DirectX.Quaternion.RotationAxis


UnsafeNativeMethods.Quaternion.RotationMatrix(Quaternion,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.RotationMatrix Method

Builds a quaternion from a rotation matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function RotationMatrix( _
ByVal pOut As Quaternion, _
ByVal pMatrix As Matrix _
) As Quaternion
C# public static Quaternion RotationMatrix(
Quaternion pOut,
Matrix pMatrix
);
C++ public:
static Quaternion RotationMatrix(
Quaternion pOut,
Matrix pMatrix
);
JScript public static function RotationMatrix(
pOut : Quaternion,
pMatrix : Matrix
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure built from a rotation matrix.
pMatrix Microsoft.DirectX.Matrix
Source Matrix structure that defines the rotation.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure built from a rotation matrix.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the RotationMatrix method as a parameter for another method.

See Also

  • RotationAxis
  • Microsoft.DirectX.Quaternion.RotationMatrix


UnsafeNativeMethods.Quaternion.Slerp(Quaternion,Quaternion,Quaternion,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Slerp Method

Interpolates between two quaternions, using spherical linear interpolation.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Slerp( _
ByVal pOut As Quaternion, _
ByVal pQuat1 As Quaternion, _
ByVal pQuat2 As Quaternion, _
ByVal t As Single _
) As Quaternion
C# public static Quaternion Slerp(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2,
float t
);
C++ public:
static Quaternion Slerp(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuat2,
float t
);
JScript public static function Slerp(
pOut : Quaternion,
pQuat1 : Quaternion,
pQuat2 : Quaternion,
t : float
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure that is the result of the interpolation.
pQuat1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
pQuat2 Microsoft.DirectX.Quaternion
Source Quaternion structure.
t System.Single
A Single Leave Site value that indicates how far to interpolate between the quaternions.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the result of the interpolation.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Slerp method as a parameter for another method.

See Also

  • Microsoft.DirectX.Quaternion.Slerp


UnsafeNativeMethods.Quaternion.Squad(Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.Squad Method

Interpolates between quaternions, using spherical quadrangle interpolation.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Squad( _
ByVal pOut As Quaternion, _
ByVal pQuat1 As Quaternion, _
ByVal pQuata As Quaternion, _
ByVal pQuatb As Quaternion, _
ByVal pQuatc As Quaternion, _
ByVal t As Single _
) As Quaternion
C# public static Quaternion Squad(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuata,
Quaternion pQuatb,
Quaternion pQuatc,
float t
);
C++ public:
static Quaternion Squad(
Quaternion pOut,
Quaternion pQuat1,
Quaternion pQuata,
Quaternion pQuatb,
Quaternion pQuatc,
float t
);
JScript public static function Squad(
pOut : Quaternion,
pQuat1 : Quaternion,
pQuata : Quaternion,
pQuatb : Quaternion,
pQuatc : Quaternion,
t : float
) : Quaternion;

Parameters

pOut Microsoft.DirectX.Quaternion
A Quaternion structure that is the result of the spherical quadrangle interpolation.
pQuat1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
pQuata Microsoft.DirectX.Quaternion
Source Quaternion structure.
pQuatb Microsoft.DirectX.Quaternion
Source Quaternion structure.
pQuatc Microsoft.DirectX.Quaternion
Source Quaternion structure.
t System.Single
A Single Leave Site value that indicates how far to interpolate between the quaternions.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the result of the spherical quadrangle interpolation.

Remarks

This method uses the following sequence of spherical linear interpolation operations.

Slerp(Slerp(pQuat1, pQuatc, t), Slerp(pQuata, pQuatb, t), 2t(1 - t))

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Squad method as a parameter for another method.

See Also

  • Microsoft.DirectX.Quaternion.Squad


UnsafeNativeMethods.Quaternion.SquadSetup(Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Quaternion) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.SquadSetup Method

Sets up control points for spherical quadrangle interpolation.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Sub SquadSetup( _
ByVal pOutA As Quaternion, _
ByVal pOutB As Quaternion, _
ByVal pOutC As Quaternion, _
ByVal pQ0 As Quaternion, _
ByVal pQ1 As Quaternion, _
ByVal pQ2 As Quaternion, _
ByVal pQ3 As Quaternion _
)
C# public static void SquadSetup(
Quaternion pOutA,
Quaternion pOutB,
Quaternion pOutC,
Quaternion pQ0,
Quaternion pQ1,
Quaternion pQ2,
Quaternion pQ3
);
C++ public:
static void SquadSetup(
Quaternion pOutA,
Quaternion pOutB,
Quaternion pOutC,
Quaternion pQ0,
Quaternion pQ1,
Quaternion pQ2,
Quaternion pQ3
);
JScript public static function SquadSetup(
pOutA : Quaternion,
pOutB : Quaternion,
pOutC : Quaternion,
pQ0 : Quaternion,
pQ1 : Quaternion,
pQ2 : Quaternion,
pQ3 : Quaternion
);

Parameters

pOutA Microsoft.DirectX.Quaternion
A Quaternion instance that represents the outA value.
pOutB Microsoft.DirectX.Quaternion
A Quaternion instance that represents the outB value.
pOutC Microsoft.DirectX.Quaternion
A Quaternion instance that represents the outC value.
pQ0 Microsoft.DirectX.Quaternion
A Quaternion instance that represents the q0 input control point.
pQ1 Microsoft.DirectX.Quaternion
A Quaternion instance that represents the q1 input control point.
pQ2 Microsoft.DirectX.Quaternion
A Quaternion instance that represents the q2 input control point.
pQ3 Microsoft.DirectX.Quaternion
A Quaternion instance that represents the q3 input control point.

Remarks

This method takes four control points, which are supplied to the inputs as q0, q1, q2, and q3, and alters their values to find a curve that flows along the shortest path. The values of q0, q2, and q3 are calculated as shown below.

q0 = |q0 + q1| < |q0 - q1| ? -q0 : q0
q2 = |q1 + q2| < |q1 - q2| ? -q2 : q2
q3 = |q2 + q3| < |q2 - q3| ? -q3 : q3
Having calculated the new q values, the values for outA, outB, and outC are calculated as shown below.
outA = q1 * exp[-0.25 *( Ln[Exp(q1)*q2] + Ln[Exp(q1)*q0] ) ]

outB = q2 * exp[-0.25 *( Ln[Exp(q2)*q3] + Ln[Exp(q2)*q1] ) ]

outC = q2
Note: In the preceding example, Ln is the application programming interface (API) method Quaternion.Ln, and Exp is the API method Quaternion.Exp.

Examples

The following example shows how to use a set of quaternion keys (Q0, Q1, Q2, Q3) to compute the inner quadrangle points (A, B, C). This ensures that the tangents are continuous across adjacent segments.
        A     B
  Q0    Q1    Q2    Q3
 The following C# code example shows how you can interpolate between Q1 and Q2.
[C#]
// Rotation about the z-axis
Quaternion Q0 =  new Quaternion(0f,  0f, 0.707f, -.707f);
Quaternion Q1 = new Quaternion(0f,  0f, 0.000f, 1.000f);
Quaternion Q2 = new Quaternion(0f,  0f, 0.707f, 0.707f);
Quaternion Q3 = new Quaternion(0f,  0f, 1.000f, 0.000f);
Quaternion A = new Quaternion();
Quaternion B = new Quaternion();
Quaternion C = new Quaternion();
Quaternion Qt = new Quaternion();

Single time = 0.5f;

Quaternion.SquadSetup(ref A, ref B, ref C, Q0, Q1, Q2, Q3);
Qt = Quaternion.Squad(Q1, A, B, C, time);
 Note:
  • C is +/- Q2 depending on the result of the function
  • Qt is the result of the function
The result is a rotation of 45 degrees around the z-axis for time = 0.5.

See Also

  • Microsoft.DirectX.Quaternion.SquadSetup


UnsafeNativeMethods.Quaternion.ToAxisAngle(Quaternion,Vector3,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Quaternion.ToAxisAngle Method

Computes a quaternion's axis and angle of rotation.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Sub ToAxisAngle( _
ByVal pQuat As Quaternion, _
ByVal pAxis As Vector3, _
ByVal pAngle As Single _
)
C# public static void ToAxisAngle(
Quaternion pQuat,
Vector3 pAxis,
float pAngle
);
C++ public:
static void ToAxisAngle(
Quaternion pQuat,
Vector3 pAxis,
float pAngle
);
JScript public static function ToAxisAngle(
pQuat : Quaternion,
pAxis : Vector3,
pAngle : float
);

Parameters

pQuat Microsoft.DirectX.Quaternion
Source Quaternion structure. See Remarks.
pAxis Microsoft.DirectX.Vector3
A Vector3 structure that identifies the quaternion's axis of rotation.
pAngle System.Single
A Single Leave Site value that identifies the quaternion's angle of rotation, in radians.

Remarks

This method requires unit quaternions.

See Also

  • Microsoft.DirectX.Quaternion.ToAxisAngle


UnsafeNativeMethods Class (Microsoft.DirectX)

UnsafeNativeMethods Class

Defines high-performance utility methods for matrix, plane, quaternion, and vector manipulation. This class is a container of classes. See the individual classes for more information.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the methods of the Microsoft.DirectX Structures.

Definition

Visual Basic NotInheritable Public Class UnsafeNativeMethods
Inherits Object
C# | public sealed class UnsafeNativeMethods : Object
C++ | public ref class UnsafeNativeMethods sealed : Object
JScript | public final class UnsafeNativeMethods extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Classes

Classes Description
UnsafeNativeMethods.Matrix Describes and manipulates a matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Matrix structure.
UnsafeNativeMethods.Plane Describes and manipulates a plane.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Plane structure.
UnsafeNativeMethods.Quaternion Describes and manipulates a quaternion.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Quaternion structure.
UnsafeNativeMethods.Vector2 Describes and manipulates a vector in two-dimensional (2-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector2 structure.
UnsafeNativeMethods.Vector3 Describes and manipulates a vector in three-dimensional (3-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector3 structure.
UnsafeNativeMethods.Vector4 Describes and manipulates a vector in four-dimensional (4-D) space.
Note: For programming in Visual Basic .NET or JScript .NET, use the methods of the Microsoft.DirectX.Vector4 structure.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Microsoft.DirectX.Matrix Structure
  • Microsoft.DirectX.Plane Structure
  • Microsoft.DirectX.Quaternion Structure
  • Microsoft.DirectX.Vector2 Structure
  • Microsoft.DirectX.Vector3 Structure
  • Microsoft.DirectX.Vector4 Structure


Vector2 Class (Microsoft.DirectX)

UnsafeNativeMethods.Vector2 Class

Describes and manipulates a vector in two-dimensional (2-D) space.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the methods of the Microsoft.DirectX.Vector2 structure.

Definition

Visual Basic NotInheritable MustInherit Public Class Vector2
Inherits Object
C# | public abstract sealed class Vector2 : Object
C++ | public ref class Vector2 abstract sealed : Object
JScript | public final abstract class Vector2 extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method | Description
static (Shared in Visual Basic) Add Adds two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) BaryCentric Returns a point in barycentric coordinates, using specified 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) CatmullRom Performs a Catmull-Rom interpolation using specified 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Ccw Returns the z component by calculating the cross product of two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Dot Determines the dot product of two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Hermite | Performs a Hermite spline interpolation using specified 2-D vectors.
static (Shared in Visual Basic) Length Returns the length of a 2-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) LengthSq Returns the square of the length of a 2-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Lerp Performs a linear interpolation between two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Maximize Returns a 2-D vector that is made up of the largest components of two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Minimize Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Normalize Returns the normalized version of a 2-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Scale Scales a 2-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Subtract Subtracts two 2-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Transform Transforms a 2-D vector or an array of 2-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformArray Transforms an array of 2-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformCoordinate Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformCoordinateArray Transforms array (x, y, 0, 1) by a given matrix, and projects the result back into w = 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformNormal Transforms the 2-D vector normal by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformNormalArray Transforms array (x, y, 0, 0) by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Vector2

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsafeNativeMethods.Vector2.Add(Vector2,Vector2,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Add Method

Adds two 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Add( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Vector2
C# public static Vector2 Add(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
C++ public:
static Vector2 Add(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
JScript public static function Add(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
Sum of the two source Vector2 structures.
pLeft Microsoft.DirectX.Vector2
Source Vector2.
pRight Microsoft.DirectX.Vector2
Source Vector2.

Return Value

Microsoft.DirectX.Vector2
Sum of the two source Vector2 structures.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Add method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Add


UnsafeNativeMethods.Vector2.BaryCentric(Vector2,Vector2,Vector2,Vector2,Single,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.BaryCentric Method

Returns a point in barycentric coordinates, using specified 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function BaryCentric( _
ByVal pOut As Vector2, _
ByVal pV1 As Vector2, _
ByVal pV2 As Vector2, _
ByVal pV3 As Vector2, _
ByVal f As Single, _
ByVal g As Single _
) As Vector2
C# public static Vector2 BaryCentric(
Vector2 pOut,
Vector2 pV1,
Vector2 pV2,
Vector2 pV3,
float f,
float g
);
C++ public:
static Vector2 BaryCentric(
Vector2 pOut,
Vector2 pV1,
Vector2 pV2,
Vector2 pV3,
float f,
float g
);
JScript public static function BaryCentric(
pOut : Vector2,
pV1 : Vector2,
pV2 : Vector2,
pV3 : Vector2,
f : float,
g : float
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure in barycentric coordinates.
pV1 Microsoft.DirectX.Vector2
Source Vector2 structure.
pV2 Microsoft.DirectX.Vector2
Source Vector2 structure.
pV3 Microsoft.DirectX.Vector2
Source Vector2 structure.
f System.Single
Weighting factor. See Remarks.
g System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure in barycentric coordinates.

Remarks

The BaryCentric method provides a way to understand points in and around a triangle, regardless of its actual location. This method returns the resulting point by using the following equation.

pV1 + f(pV2 - pV1) + g(pV3 - pV1)

Any point in the plane pV1pV2pV3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which pV2 gets weighted into the result, and the f parameter controls the extent to which pV3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which pV1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle pV1pV2pV3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line pV1pV3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line pV1pV2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line pV2pV3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the BaryCentric method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.BaryCentric


UnsafeNativeMethods.Vector2.CatmullRom(Vector2,Vector2,Vector2,Vector2,Vector2,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.CatmullRom Method

Performs a Catmull-Rom interpolation using specified 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function CatmullRom( _
ByVal pOut As Vector2, _
ByVal pPosition1 As Vector2, _
ByVal pPosition2 As Vector2, _
ByVal pPosition3 As Vector2, _
ByVal pPosition4 As Vector2, _
ByVal weightingFactor As Single _
) As Vector2
C# public static Vector2 CatmullRom(
Vector2 pOut,
Vector2 pPosition1,
Vector2 pPosition2,
Vector2 pPosition3,
Vector2 pPosition4,
float weightingFactor
);
C++ public:
static Vector2 CatmullRom(
Vector2 pOut,
Vector2 pPosition1,
Vector2 pPosition2,
Vector2 pPosition3,
Vector2 pPosition4,
float weightingFactor
);
JScript public static function CatmullRom(
pOut : Vector2,
pPosition1 : Vector2,
pPosition2 : Vector2,
pPosition3 : Vector2,
pPosition4 : Vector2,
weightingFactor : float
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the Catmull-Rom interpolation.
pPosition1 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
pPosition2 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
pPosition3 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
pPosition4 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of pPosition1, v2 is the contents of pPosition2, p3 is the contents of pPosition3, p4 is the contents of pPosition4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the Hermite spline equation:

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
and substituting for v1, v2, t1, t2 yields:
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This can be rearranged as:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

The return value for this method is the same value returned in the pOut parameter. This allows you to use the CatmullRom method as a parameter for another method.

See Also

  • Vector3.CatmullRom
  • Vector4.CatmullRom
  • Microsoft.DirectX.Vector2.CatmullRom


UnsafeNativeMethods.Vector2.Ccw(Vector2,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Ccw Method

Returns the z component by calculating the cross product of two 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Ccw( _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Single
C# public static float Ccw(
Vector2 pLeft,
Vector2 pRight
);
C++ public:
static float Ccw(
Vector2 pLeft,
Vector2 pRight
);
JScript public static function Ccw(
pLeft : Vector2,
pRight : Vector2
) : float;

Parameters

pLeft Microsoft.DirectX.Vector2
Source Vector2 structure.
pRight Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

System.Single
The z component.

Remarks

This method determines the z component by calculating the cross product based on the following formula.

((x1,y1,0) cross (x2,y2,0))

The following C# code fragment provides an example.

[C#]
left->x * right->y - left->y * right->x

If the z component's value is positive, the vector right is counterclockwise from the vector left. This information is useful for back-face culling.

See Also

  • Microsoft.DirectX.Vector2.Ccw


UnsafeNativeMethods.Vector2.Dot(Vector2,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Dot Method

Determines the dot product of two 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Dot( _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Single
C# public static float Dot(
Vector2 pLeft,
Vector2 pRight
);
C++ public:
static float Dot(
Vector2 pLeft,
Vector2 pRight
);
JScript public static function Dot(
pLeft : Vector2,
pRight : Vector2
) : float;

Parameters

pLeft Microsoft.DirectX.Vector2
Source Vector2 structure.
pRight Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

System.Single
Dot product.

See Also

  • Ccw
  • Microsoft.DirectX.Vector2.Dot


UnsafeNativeMethods.Vector2.Hermite(Vector2,Vector2,Vector2,Vector2,Vector2,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Hermite Method

Performs a Hermite spline interpolation using specified 2-D vectors.

Definition

Visual Basic Public Shared Function Hermite( _
ByVal pOut As Vector2, _
ByVal pPosition As Vector2, _
ByVal pTangent As Vector2, _
ByVal pPosition2 As Vector2, _
ByVal pTangent2 As Vector2, _
ByVal weightingFactor As Single _
) As Vector2
C# public static Vector2 Hermite(
Vector2 pOut,
Vector2 pPosition,
Vector2 pTangent,
Vector2 pPosition2,
Vector2 pTangent2,
float weightingFactor
);
C++ public:
static Vector2 Hermite(
Vector2 pOut,
Vector2 pPosition,
Vector2 pTangent,
Vector2 pPosition2,
Vector2 pTangent2,
float weightingFactor
);
JScript public static function Hermite(
pOut : Vector2,
pPosition : Vector2,
pTangent : Vector2,
pPosition2 : Vector2,
pTangent2 : Vector2,
weightingFactor : float
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the Hermite spline interpolation.
pPosition Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
pTangent Microsoft.DirectX.Vector2
Source Vector2 structure that is a tangent vector.
pPosition2 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
pTangent2 Microsoft.DirectX.Vector2
Source Vector2 structure that is a tangent vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (pPosition, pTangent) to (pPosition2, pTangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of ease-in, ease-out spline interpolation. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of pPosition, v2 is the contents of pPosition2, t1 is the contents of pTangent, t2 is the contents of pTangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, and D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

The preceding example yields the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Hermite method as a parameter for another method.

See Also

  • Hermite


UnsafeNativeMethods.Vector2.Length(Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Length Method

Returns the length of a 2-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Length( _
ByVal pSource As Vector2 _
) As Single
C# public static float Length(
Vector2 pSource
);
C++ public:
static float Length(
Vector2 pSource
);
JScript public static function Length(
pSource : Vector2
) : float;

Parameters

pSource Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

System.Single
Vector length.

See Also

  • LengthSq
  • Microsoft.DirectX.Vector2.Length


UnsafeNativeMethods.Vector2.LengthSq(Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.LengthSq Method

Returns the square of the length of a 2-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function LengthSq( _
ByVal pSource As Vector2 _
) As Single
C# public static float LengthSq(
Vector2 pSource
);
C++ public:
static float LengthSq(
Vector2 pSource
);
JScript public static function LengthSq(
pSource : Vector2
) : float;

Parameters

pSource Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

System.Single
Vector's squared length.

See Also

  • Length
  • Microsoft.DirectX.Vector2.LengthSq


UnsafeNativeMethods.Vector2.Lerp(Vector2,Vector2,Vector2,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Lerp Method

Performs a linear interpolation between two 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2, _
ByVal interpolater As Single _
) As Vector2
C# public static Vector2 Lerp(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight,
float interpolater
);
C++ public:
static Vector2 Lerp(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight,
float interpolater
);
JScript public static function Lerp(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2,
interpolater : float
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the linear interpolation.
pLeft Microsoft.DirectX.Vector2
Source Vector2 structure.
pRight Microsoft.DirectX.Vector2
Source Vector2 structure.
interpolater System.Single
Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

pLeft + interpolater(pRight - pLeft).

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Lerp method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Lerp


UnsafeNativeMethods.Vector2.Maximize(Vector2,Vector2,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Maximize Method

Returns a 2-D vector that is made up of the largest components of two 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Maximize( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Vector2
C# public static Vector2 Maximize(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
C++ public:
static Vector2 Maximize(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
JScript public static function Maximize(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is made up of the largest components of the two vectors.
pLeft Microsoft.DirectX.Vector2
Source Vector2 structure.
pRight Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is made up of the largest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Maximize method as a parameter for another method.

See Also

  • Minimize
  • Microsoft.DirectX.Vector2.Maximize


UnsafeNativeMethods.Vector2.Minimize(Vector2,Vector2,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Minimize Method

Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Minimize( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Vector2
C# public static Vector2 Minimize(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
C++ public:
static Vector2 Minimize(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
JScript public static function Minimize(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is made up of the smallest components of the two vectors.
pLeft Microsoft.DirectX.Vector2
Source Vector2 structure.
pRight Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is made up of the smallest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Minimize method as a parameter for another method.

See Also

  • Maximize
  • Microsoft.DirectX.Vector2.Minimize


UnsafeNativeMethods.Vector2.Normalize(Vector2,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Normalize Method

Returns the normalized version of a 2-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal pOut As Vector2, _
ByVal pSource As Vector2 _
) As Vector2
C# public static Vector2 Normalize(
Vector2 pOut,
Vector2 pSource
);
C++ public:
static Vector2 Normalize(
Vector2 pOut,
Vector2 pSource
);
JScript public static function Normalize(
pOut : Vector2,
pSource : Vector2
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is the normalized version of the vector.
pSource Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the normalized version of the vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Normalize method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Normalize


UnsafeNativeMethods.Vector2.Scale(Vector2,Vector2,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Scale Method

Scales a 2-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Scale( _
ByVal pOut As Vector2, _
ByVal pSource As Vector2, _
ByVal scalingFactor As Single _
) As Vector2
C# public static Vector2 Scale(
Vector2 pOut,
Vector2 pSource,
float scalingFactor
);
C++ public:
static Vector2 Scale(
Vector2 pOut,
Vector2 pSource,
float scalingFactor
);
JScript public static function Scale(
pOut : Vector2,
pSource : Vector2,
scalingFactor : float
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is the scaled vector.
pSource Microsoft.DirectX.Vector2
Source Vector2 structure.
scalingFactor System.Single
Scaling value.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the scaled vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Scale method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Scale


UnsafeNativeMethods.Vector2.Subtract(Vector2,Vector2,Vector2) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Subtract Method

Subtracts two 2-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal pOut As Vector2, _
ByVal pLeft As Vector2, _
ByVal pRight As Vector2 _
) As Vector2
C# public static Vector2 Subtract(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
C++ public:
static Vector2 Subtract(
Vector2 pOut,
Vector2 pLeft,
Vector2 pRight
);
JScript public static function Subtract(
pOut : Vector2,
pLeft : Vector2,
pRight : Vector2
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the operation.
pLeft Microsoft.DirectX.Vector2
Source Vector2 structure to the left of the subtraction operator.
pRight Microsoft.DirectX.Vector2
Source Vector2 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Subtract method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Subtract


UnsafeNativeMethods.Vector2.Transform(Vector4,Vector2,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.Transform Method

Transforms a 2-D vector or an array of 2-D vectors by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Transform( _
ByVal pOut As Vector4, _
ByVal pSource As Vector2, _
ByVal pSourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector4 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
C++ public:
static Vector4 Transform(
Vector4 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
JScript public static function Transform(
pOut : Vector4,
pSource : Vector2,
pSourceMatrix : Matrix
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.
pSource Microsoft.DirectX.Vector2
Source Vector2 structure.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.

Remarks

This method transforms the pSource vector (x, y, 0, 1) by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Transform method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.Transform


UnsafeNativeMethods.Vector2.TransformArray(Vector4,Int32,Vector2,Int32,Matrix,Int32) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.TransformArray Method

Transforms an array of 2-D vectors by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformArray( _
ByVal pOut As Vector4, _
ByVal outStride As Integer, _
ByVal pSource As Vector2, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector4
C# public static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
C++ public:
static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript public static function TransformArray(
pOut : Vector4,
outStride : int,
pSource : Vector2,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.
outStride System.Int32
Stride between vectors in the output data stream.
pSource Microsoft.DirectX.Vector2
Source Vector2 structure.
vectorStride System.Int32
Stride between vectors in the input data stream.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.
count System.Int32
Number of elements in the array.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.

Remarks

This method transforms the array of vectors, pSource (x, y, 0, 1), by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformArray method as a parameter for another method.


UnsafeNativeMethods.Vector2.TransformCoordinate(Vector2,Vector2,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.TransformCoordinate Method

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformCoordinate( _
ByVal pOut As Vector2, _
ByVal pSource As Vector2, _
ByVal pSourceMatrix As Matrix _
) As Vector2
C# public static Vector2 TransformCoordinate(
Vector2 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
C++ public:
static Vector2 TransformCoordinate(
Vector2 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
JScript public static function TransformCoordinate(
pOut : Vector2,
pSource : Vector2,
pSourceMatrix : Matrix
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that represents the results of the method.
pSource Microsoft.DirectX.Vector2
Source Vector2 structure.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that represents the results of the method.

Remarks

This method transforms the source vector, pOut (x, y, 0, 1), by the matrix pSourceMatrix, projecting the result back into w = 1.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformCoordinate method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.TransformCoordinate


UnsafeNativeMethods.Vector2.TransformCoordinateArray(Vector2,Int32,Vector2,Int32,Matrix,Int32) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.TransformCoordinateArray Method

Transforms array (x, y, 0, 1) by a given matrix, and projects the result back into w = 1.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformCoordinateArray( _
ByVal pOut As Vector2, _
ByVal outStride As Integer, _
ByVal pSource As Vector2, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector2
C# public static Vector2 TransformCoordinateArray(
Vector2 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
C++ public:
static Vector2 TransformCoordinateArray(
Vector2 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript public static function TransformCoordinateArray(
pOut : Vector2,
outStride : int,
pSource : Vector2,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that represents the results of the method.
outStride System.Int32
The stride of each transformed array.
pSource Microsoft.DirectX.Vector2
Source Vector2 structure.
vectorStride System.Int32
Stride between vectors in the input data stream.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.
count System.Int32
Number of elements in the array.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the method.

Remarks

This method transforms the source vector, pSource (x, y, 0, 1), by the matrix pSourceMatrix, projecting the result back into w = 1.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformCoordinateArray method as a parameter for another method.


UnsafeNativeMethods.Vector2.TransformNormal(Vector2,Vector2,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.TransformNormal Method

Transforms the 2-D vector normal by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformNormal( _
ByVal pOut As Vector2, _
ByVal pSource As Vector2, _
ByVal pSourceMatrix As Matrix _
) As Vector2
C# public static Vector2 TransformNormal(
Vector2 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
C++ public:
static Vector2 TransformNormal(
Vector2 pOut,
Vector2 pSource,
Matrix pSourceMatrix
);
JScript public static function TransformNormal(
pOut : Vector2,
pSource : Vector2,
pSourceMatrix : Matrix
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that contains the results of this method.
pSource Microsoft.DirectX.Vector2
Source Vector2 structure.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that contains the results of this method.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the pSource vector, by the pSourceMatrix source matrix.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformNormal method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector2.TransformNormal


UnsafeNativeMethods.Vector2.TransformNormalArray(Vector2,Int32,Vector2,Int32,Matrix,Int32) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector2.TransformNormalArray Method

Transforms array (x, y, 0, 0) by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformNormalArray( _
ByVal pOut As Vector2, _
ByVal outStride As Integer, _
ByVal pSource As Vector2, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector2
C# public static Vector2 TransformNormalArray(
Vector2 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
C++ public:
static Vector2 TransformNormalArray(
Vector2 pOut,
int outStride,
Vector2 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript public static function TransformNormalArray(
pOut : Vector2,
outStride : int,
pSource : Vector2,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector2;

Parameters

pOut Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the method.
outStride System.Int32
Stride between vectors in the output data stream.
pSource Microsoft.DirectX.Vector2
Source Vector2 structure.
vectorStride System.Int32
Stride between vectors in the input data stream.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.
count System.Int32
Number of elements in the array.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the method.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the pSource vector by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformNormalArray method as a parameter for another method.


Vector3 Class (Microsoft.DirectX)

UnsafeNativeMethods.Vector3 Class

Describes and manipulates a vector in three-dimensional (3-D) space.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the methods of the Microsoft.DirectX.Vector3 structure.

Definition

Visual Basic NotInheritable MustInherit Public Class Vector3
Inherits Object
C# | public abstract sealed class Vector3 : Object
C++ | public ref class Vector3 abstract sealed : Object
JScript | public final abstract class Vector3 extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic) Add Adds two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) BaryCentric Returns a point in barycentric coordinates, using specified 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) CatmullRom Performs a Catmull-Rom interpolation using specified 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Cross Determines the cross product of two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Dot Determines the dot product of two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Hermite Performs a Hermite spline interpolation using the specified 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Length Returns the length of a 3-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) LengthSq Returns the square of the length of a 3-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Lerp Performs a linear interpolation between two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Maximize Returns a 3-D vector that is made up of the largest components of two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Minimize Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Normalize Returns the normalized version of a 3-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Scale Scales a 3-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Subtract Subtracts two 3-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Transform Transforms a 3-D vector or an array of 3-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformArray Transforms an array of 3-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformCoordinate Transforms a 3-D vector by a given matrix, projecting the result back into w = 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformCoordinateArray Transforms array (x, y, z, 1) by a given matrix, and projects the result back into w = 1.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformNormal Transforms a 3-D vector normal by the given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformNormalArray Transforms array (x, y, z, 0) by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Vector3

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsafeNativeMethods.Vector3.Add(Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Add Method

Adds two 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Add( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Vector3
C# public static Vector3 Add(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
C++ public:
static Vector3 Add(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
JScript public static function Add(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
Sum of the two source Vector3 structures.
pLeft Microsoft.DirectX.Vector3
Source Vector3.
pRight Microsoft.DirectX.Vector3
Source Vector3.

Return Value

Microsoft.DirectX.Vector3
Sum of the two source Vector3 structures.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Add method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Add


UnsafeNativeMethods.Vector3.BaryCentric(Vector3,Vector3,Vector3,Vector3,Single,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.BaryCentric Method

Returns a point in barycentric coordinates, using specified 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function BaryCentric( _
ByVal pOut As Vector3, _
ByVal pV1 As Vector3, _
ByVal pV2 As Vector3, _
ByVal pV3 As Vector3, _
ByVal f As Single, _
ByVal g As Single _
) As Vector3
C# public static Vector3 BaryCentric(
Vector3 pOut,
Vector3 pV1,
Vector3 pV2,
Vector3 pV3,
float f,
float g
);
C++ public:
static Vector3 BaryCentric(
Vector3 pOut,
Vector3 pV1,
Vector3 pV2,
Vector3 pV3,
float f,
float g
);
JScript public static function BaryCentric(
pOut : Vector3,
pV1 : Vector3,
pV2 : Vector3,
pV3 : Vector3,
f : float,
g : float
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure in barycentric coordinates.
pV1 Microsoft.DirectX.Vector3
Source Vector3 structure.
pV2 Microsoft.DirectX.Vector3
Source Vector3 structure.
pV3 Microsoft.DirectX.Vector3
Source Vector3 structure.
f System.Single
Weighting factor. See Remarks.
g System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure in barycentric coordinates.

Remarks

The BaryCentric method provides a way to understand points in and around a triangle, regardless of where the triangle is actually located. This method returns the resulting point by using the following equation.

pV1 + f(pV2 - pV1) + g(pV3 - pV1)

Any point in the plane pV1pV2pV3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which pV2 gets weighted into the result, and the f parameter controls the extent to which pV3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which pV1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle pV1pV2pV3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line pV1pV3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line pV1pV2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line pV2pV3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the BaryCentric method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.BaryCentric


UnsafeNativeMethods.Vector3.CatmullRom(Vector3,Vector3,Vector3,Vector3,Vector3,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.CatmullRom Method

Performs a Catmull-Rom interpolation using specified 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function CatmullRom( _
ByVal pOut As Vector3, _
ByVal pPosition1 As Vector3, _
ByVal pPosition2 As Vector3, _
ByVal pPosition3 As Vector3, _
ByVal pPosition4 As Vector3, _
ByVal weightingFactor As Single _
) As Vector3
C# public static Vector3 CatmullRom(
Vector3 pOut,
Vector3 pPosition1,
Vector3 pPosition2,
Vector3 pPosition3,
Vector3 pPosition4,
float weightingFactor
);
C++ public:
static Vector3 CatmullRom(
Vector3 pOut,
Vector3 pPosition1,
Vector3 pPosition2,
Vector3 pPosition3,
Vector3 pPosition4,
float weightingFactor
);
JScript public static function CatmullRom(
pOut : Vector3,
pPosition1 : Vector3,
pPosition2 : Vector3,
pPosition3 : Vector3,
pPosition4 : Vector3,
weightingFactor : float
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the Catmull-Rom interpolation.
pPosition1 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
pPosition2 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
pPosition3 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
pPosition4 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of pPosition1, v2 is the contents of pPosition2, p3 is the contents of pPosition3, p4 is the contents of pPosition4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the Hermite spline equation.

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
Substituting for v1, v2, t1, t2 yields the following result.
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This result can be rearranged as follows:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

The return value for this method is the same value returned in the pOut parameter. This allows you to use the CatmullRom method as a parameter for another method.

See Also

  • Vector2.CatmullRom
  • Vector4.CatmullRom
  • Microsoft.DirectX.Vector3.CatmullRom


UnsafeNativeMethods.Vector3.Cross(Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Cross Method

Determines the cross product of two 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Cross( _
ByVal pOut As Vector3, _
ByVal pV1 As Vector3, _
ByVal pV2 As Vector3 _
) As Vector3
C# public static Vector3 Cross(
Vector3 pOut,
Vector3 pV1,
Vector3 pV2
);
C++ public:
static Vector3 Cross(
Vector3 pOut,
Vector3 pV1,
Vector3 pV2
);
JScript public static function Cross(
pOut : Vector3,
pV1 : Vector3,
pV2 : Vector3
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the cross product of two 3-D vectors.
pV1 Microsoft.DirectX.Vector3
Source Vector3 structure.
pV2 Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the cross product of two 3-D vectors.

Remarks

The following C# example demonstrates how the Cross method finds the cross-product.

[C#]
Vector3 returnValue;
    returnValue.x = left.y * right.z - left.z * right.y;
    returnValue.y = left.z * right.x - left.x * right.z;
    returnValue.z = left.x * right.y - left.y * right.x;

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Cross method as a parameter for another method.

See Also

  • Dot
  • Microsoft.DirectX.Vector3.Cross


UnsafeNativeMethods.Vector3.Dot(Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Dot Method

Determines the dot product of two 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Dot( _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Single
C# public static float Dot(
Vector3 pLeft,
Vector3 pRight
);
C++ public:
static float Dot(
Vector3 pLeft,
Vector3 pRight
);
JScript public static function Dot(
pLeft : Vector3,
pRight : Vector3
) : float;

Parameters

pLeft Microsoft.DirectX.Vector3
Source Vector3 structure.
pRight Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that is the dot product.

See Also

  • Cross
  • Microsoft.DirectX.Vector3.Dot


UnsafeNativeMethods.Vector3.Hermite(Vector3,Vector3,Vector3,Vector3,Vector3,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Hermite Method

Performs a Hermite spline interpolation using the specified 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Hermite( _
ByVal pOut As Vector3, _
ByVal pPosition As Vector3, _
ByVal pTangent As Vector3, _
ByVal pPosition2 As Vector3, _
ByVal pTangent2 As Vector3, _
ByVal weightingFactor As Single _
) As Vector3
C# public static Vector3 Hermite(
Vector3 pOut,
Vector3 pPosition,
Vector3 pTangent,
Vector3 pPosition2,
Vector3 pTangent2,
float weightingFactor
);
C++ public:
static Vector3 Hermite(
Vector3 pOut,
Vector3 pPosition,
Vector3 pTangent,
Vector3 pPosition2,
Vector3 pTangent2,
float weightingFactor
);
JScript public static function Hermite(
pOut : Vector3,
pPosition : Vector3,
pTangent : Vector3,
pPosition2 : Vector3,
pTangent2 : Vector3,
weightingFactor : float
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the Hermite spline interpolation.
pPosition Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
pTangent Microsoft.DirectX.Vector3
Source Vector3 structure that is a tangent vector.
pPosition2 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
pTangent2 Microsoft.DirectX.Vector3
Source Vector3 structure that is a tangent vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (pPosition, pTangent) to (pPosition2, pTangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of the ease-in, ease-out spline. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of pPosition, v2 is the contents of pPosition2, t1 is the contents of pTangent, t2 is the contents of pTangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

These properties yield the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
Which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Hermite method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Hermite


UnsafeNativeMethods.Vector3.Length(Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Length Method

Returns the length of a 3-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Length( _
ByVal pSource As Vector3 _
) As Single
C# public static float Length(
Vector3 pSource
);
C++ public:
static float Length(
Vector3 pSource
);
JScript public static function Length(
pSource : Vector3
) : float;

Parameters

pSource Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that contains the vector's length.

See Also

  • LengthSq
  • Microsoft.DirectX.Vector3.Length


UnsafeNativeMethods.Vector3.LengthSq(Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.LengthSq Method

Returns the square of the length of a 3-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function LengthSq( _
ByVal pSource As Vector3 _
) As Single
C# public static float LengthSq(
Vector3 pSource
);
C++ public:
static float LengthSq(
Vector3 pSource
);
JScript public static function LengthSq(
pSource : Vector3
) : float;

Parameters

pSource Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that contains the vector's squared length.

See Also

  • Length
  • Microsoft.DirectX.Vector3.LengthSq


UnsafeNativeMethods.Vector3.Lerp(Vector3,Vector3,Vector3,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Lerp Method

Performs a linear interpolation between two 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3, _
ByVal interpolater As Single _
) As Vector3
C# public static Vector3 Lerp(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight,
float interpolater
);
C++ public:
static Vector3 Lerp(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight,
float interpolater
);
JScript public static function Lerp(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3,
interpolater : float
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the linear interpolation.
pLeft Microsoft.DirectX.Vector3
Source Vector3 structure.
pRight Microsoft.DirectX.Vector3
Source Vector3 structure.
interpolater System.Single
Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

pLeft + interpolater(pRight - pLeft).

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Lerp method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Lerp


UnsafeNativeMethods.Vector3.Maximize(Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Maximize Method

Returns a 3-D vector that is made up of the largest components of two 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Maximize( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Vector3
C# public static Vector3 Maximize(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
C++ public:
static Vector3 Maximize(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
JScript public static function Maximize(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is made up of the largest components of the two vectors.
pLeft Microsoft.DirectX.Vector3
Source Vector3 structure.
pRight Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is made up of the largest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Maximize method as a parameter for another method.

See Also

  • Minimize
  • Microsoft.DirectX.Vector3.Maximize


UnsafeNativeMethods.Vector3.Minimize(Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Minimize Method

Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Minimize( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Vector3
C# public static Vector3 Minimize(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
C++ public:
static Vector3 Minimize(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
JScript public static function Minimize(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is made up of the smallest components of the two vectors.
pLeft Microsoft.DirectX.Vector3
Source Vector3 structure.
pRight Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is made up of the smallest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Minimize method as a parameter for another method.

See Also

  • Maximize
  • Microsoft.DirectX.Vector3.Minimize


UnsafeNativeMethods.Vector3.Normalize(Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Normalize Method

Returns the normalized version of a 3-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal pOut As Vector3, _
ByVal pSource As Vector3 _
) As Vector3
C# public static Vector3 Normalize(
Vector3 pOut,
Vector3 pSource
);
C++ public:
static Vector3 Normalize(
Vector3 pOut,
Vector3 pSource
);
JScript public static function Normalize(
pOut : Vector3,
pSource : Vector3
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the normalized version of the specified vector.
pSource Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the normalized version of the specified vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Normalize method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Normalize


UnsafeNativeMethods.Vector3.Scale(Vector3,Vector3,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Scale Method

Scales a 3-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Scale( _
ByVal pOut As Vector3, _
ByVal pSource As Vector3, _
ByVal scalingFactor As Single _
) As Vector3
C# public static Vector3 Scale(
Vector3 pOut,
Vector3 pSource,
float scalingFactor
);
C++ public:
static Vector3 Scale(
Vector3 pOut,
Vector3 pSource,
float scalingFactor
);
JScript public static function Scale(
pOut : Vector3,
pSource : Vector3,
scalingFactor : float
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the scaled vector.
pSource Microsoft.DirectX.Vector3
Source Vector3 structure.
scalingFactor System.Single
Scaling value.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the scaled vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Scale method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Scale


UnsafeNativeMethods.Vector3.Subtract(Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Subtract Method

Subtracts two 3-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal pOut As Vector3, _
ByVal pLeft As Vector3, _
ByVal pRight As Vector3 _
) As Vector3
C# public static Vector3 Subtract(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
C++ public:
static Vector3 Subtract(
Vector3 pOut,
Vector3 pLeft,
Vector3 pRight
);
JScript public static function Subtract(
pOut : Vector3,
pLeft : Vector3,
pRight : Vector3
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the operation.
pLeft Microsoft.DirectX.Vector3
Source Vector3 structure to the left of the subtraction operator.
pRight Microsoft.DirectX.Vector3
Source Vector3 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Subtract method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector3.Subtract


UnsafeNativeMethods.Vector3.Transform(Vector4,Vector3,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.Transform Method

Transforms a 3-D vector or an array of 3-D vectors by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Transform( _
ByVal pOut As Vector4, _
ByVal pSource As Vector3, _
ByVal pSourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector4 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
C++ public:
static Vector4 Transform(
Vector4 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
JScript public static function Transform(
pOut : Vector4,
pSource : Vector3,
pSourceMatrix : Matrix
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.
pSource Microsoft.DirectX.Vector3
Source Vector3 structure.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.

Remarks

This method transforms the pSource vector (x, y, z, 1) by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Transform method as a parameter for another method.

See Also

  • TransformCoordinate
  • TransformNormal
  • Microsoft.DirectX.Vector3.Transform


UnsafeNativeMethods.Vector3.TransformArray(Vector4,Int32,Vector3,Int32,Matrix,Int32) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.TransformArray Method

Transforms an array of 3-D vectors by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformArray( _
ByVal pOut As Vector4, _
ByVal outStride As Integer, _
ByVal pSource As Vector3, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector4
C# public static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
C++ public:
static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript public static function TransformArray(
pOut : Vector4,
outStride : int,
pSource : Vector3,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.
outStride System.Int32
Stride between vectors in the output data stream.
pSource Microsoft.DirectX.Vector3
Source Vector3 structure array.
vectorStride System.Int32
Stride between vectors in the input data stream.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.
count System.Int32
Number of elements in the array.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.

Remarks

This method transforms the array of vectors, pSource (x, y, 0, 1), by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformArray method as a parameter for another method.


UnsafeNativeMethods.Vector3.TransformCoordinate(Vector3,Vector3,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.TransformCoordinate Method

Transforms a 3-D vector by a given matrix, projecting the result back into w = 1.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformCoordinate( _
ByVal pOut As Vector3, _
ByVal pSource As Vector3, _
ByVal pSourceMatrix As Matrix _
) As Vector3
C# public static Vector3 TransformCoordinate(
Vector3 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
C++ public:
static Vector3 TransformCoordinate(
Vector3 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
JScript public static function TransformCoordinate(
pOut : Vector3,
pSource : Vector3,
pSourceMatrix : Matrix
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that represents the results of the method.
pSource Microsoft.DirectX.Vector3
Source Vector3 structure.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that represents the results of the method.

Remarks

This method transforms the source vector, pSource (x, y, z, 1) by the pSourceMatrix, projecting the result back into w = 1.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformCoordinate method as a parameter for another method.

See Also

  • Transform
  • TransformNormal
  • Microsoft.DirectX.Vector3.TransformCoordinate


UnsafeNativeMethods.Vector3.TransformCoordinateArray(Vector3,Int32,Vector3,Int32,Matrix,Int32) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.TransformCoordinateArray Method

Transforms array (x, y, z, 1) by a given matrix, and projects the result back into w = 1.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformCoordinateArray( _
ByVal pOut As Vector3, _
ByVal outStride As Integer, _
ByVal pSource As Vector3, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector3
C# public static Vector3 TransformCoordinateArray(
Vector3 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
C++ public:
static Vector3 TransformCoordinateArray(
Vector3 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript public static function TransformCoordinateArray(
pOut : Vector3,
outStride : int,
pSource : Vector3,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that represents the results of the method.
outStride System.Int32
Stride between vectors in the output data stream.
pSource Microsoft.DirectX.Vector3
Source Vector3 structure array.
vectorStride System.Int32
Stride between vectors in the input data stream.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.
count System.Int32
Number of elements in the array.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the method.

Remarks

This method transforms all vectors in the pSource parameter by the matrix pSourceMatrix, projecting the result back into w = 1.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformCoordinateArray method as a parameter for another method.

See Also

  • TransformCoordinate


UnsafeNativeMethods.Vector3.TransformNormal(Vector3,Vector3,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.TransformNormal Method

Transforms a 3-D vector normal by the given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformNormal( _
ByVal pOut As Vector3, _
ByVal pSource As Vector3, _
ByVal pSourceMatrix As Matrix _
) As Vector3
C# public static Vector3 TransformNormal(
Vector3 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
C++ public:
static Vector3 TransformNormal(
Vector3 pOut,
Vector3 pSource,
Matrix pSourceMatrix
);
JScript public static function TransformNormal(
pOut : Vector3,
pSource : Vector3,
pSourceMatrix : Matrix
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that contains the results of this method.
pSource Microsoft.DirectX.Vector3
Source Vector3 structure.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that contains the results of this method.

Remarks

This method transforms the vector normal (x, y, z, 0) of the pSource vector by the pSourceMatrix source matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformNormal method as a parameter for another method.

See Also

  • Transform
  • TransformCoordinate
  • Microsoft.DirectX.Vector3.TransformNormal


UnsafeNativeMethods.Vector3.TransformNormalArray(Vector3,Int32,Vector3,Int32,Matrix,Int32) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector3.TransformNormalArray Method

Transforms array (x, y, z, 0) by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformNormalArray( _
ByVal pOut As Vector3, _
ByVal outStride As Integer, _
ByVal pSource As Vector3, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector3
C# public static Vector3 TransformNormalArray(
Vector3 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
C++ public:
static Vector3 TransformNormalArray(
Vector3 pOut,
int outStride,
Vector3 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript public static function TransformNormalArray(
pOut : Vector3,
outStride : int,
pSource : Vector3,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector3;

Parameters

pOut Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the method.
outStride System.Int32
Stride between vectors in the output data stream.
pSource Microsoft.DirectX.Vector3
Source Vector3 structure array.
vectorStride System.Int32
Stride between vectors in the input data stream.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.
count System.Int32
Number of elements in the array.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the method.

Remarks

This method transforms the vector normals (x, y, z, 0) of the pSource parameter by the matrix pSourceMatrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformNormalArray method as a parameter for another method.


Vector4 Class (Microsoft.DirectX)

UnsafeNativeMethods.Vector4 Class

Describes and manipulates a vector in four-dimensional (4-D) space.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the methods of the Microsoft.DirectX.Vector4 structure.

Definition

Visual Basic NotInheritable MustInherit Public Class Vector4
Inherits Object
C# | public abstract sealed class Vector4 : Object
C++ | public ref class Vector4 abstract sealed : Object
JScript | public final abstract class Vector4 extends Object

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Methods

Method Description
static (Shared in Visual Basic) Add Adds two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) BaryCentric Returns a point in barycentric coordinates, using the specified 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) CatmullRom Performs a Catmull-Rom interpolation using specified 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Cross Determines the cross product in four dimensions.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Dot Determines the dot product of two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Hermite Performs a Hermite spline interpolation using the specified 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Length Returns the length of a 4-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) LengthSq Returns the square of the length of a 4-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Lerp Performs a linear interpolation between two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Maximize Returns a 4-D vector that is made up of the largest components of two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Minimize Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Normalize Returns the normalized version of a 4-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Scale Scales a 4-D vector.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Subtract Subtracts two 4-D vectors.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) Transform Transforms a 4-D vector or an array of 4-D vectors by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.
static (Shared in Visual Basic) TransformArray Transforms a vector array by a given matrix.
Note: For programming in Visual Basic .NET or JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Inheritance Hierarchy

Object Leave Site
UnsafeNativeMethods.Vector4

Class Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


UnsafeNativeMethods.Vector4.Add(Vector4,Vector4,Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Add Method

Adds two 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Add( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Vector4
C# public static Vector4 Add(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
C++ public:
static Vector4 Add(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
JScript public static function Add(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
Sum of the two Vector4 structures.
pLeft Microsoft.DirectX.Vector4
Source Vector4.
pRight Microsoft.DirectX.Vector4
Source Vector4.

Return Value

Microsoft.DirectX.Vector4
Sum of the two Vector4 structures.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Add method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Add


UnsafeNativeMethods.Vector4.BaryCentric(Vector4,Vector4,Vector4,Vector4,Single,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.BaryCentric Method

Returns a point in barycentric coordinates, using the specified 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function BaryCentric( _
ByVal pOut As Vector4, _
ByVal pV1 As Vector4, _
ByVal pV2 As Vector4, _
ByVal pV3 As Vector4, _
ByVal f As Single, _
ByVal g As Single _
) As Vector4
C# public static Vector4 BaryCentric(
Vector4 pOut,
Vector4 pV1,
Vector4 pV2,
Vector4 pV3,
float f,
float g
);
C++ public:
static Vector4 BaryCentric(
Vector4 pOut,
Vector4 pV1,
Vector4 pV2,
Vector4 pV3,
float f,
float g
);
JScript public static function BaryCentric(
pOut : Vector4,
pV1 : Vector4,
pV2 : Vector4,
pV3 : Vector4,
f : float,
g : float
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure in barycentric coordinates.
pV1 Microsoft.DirectX.Vector4
Source Vector4 structure.
pV2 Microsoft.DirectX.Vector4
Source Vector4 structure.
pV3 Microsoft.DirectX.Vector4
Source Vector4 structure.
f System.Single
Weighting factor. See Remarks.
g System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure in barycentric coordinates.

Remarks

The BaryCentric method provides a way to understand points in and around a triangle, regardless of where the triangle is actually located. This method returns the resulting point by using the following equation.

pV1 + f(pV2 - pV1) + g(pV3 - pV1)

Any point in the plane pV1pV2pV3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which pV2 gets weighted into the result, and the f parameter controls the extent to which pV3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which pV1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle pV1pV2pV3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line pV1pV3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line pV1pV2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line pV2pV3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the BaryCentric method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.BaryCentric


UnsafeNativeMethods.Vector4.CatmullRom(Vector4,Vector4,Vector4,Vector4,Vector4,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.CatmullRom Method

Performs a Catmull-Rom interpolation using specified 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function CatmullRom( _
ByVal pOut As Vector4, _
ByVal pPosition1 As Vector4, _
ByVal pPosition2 As Vector4, _
ByVal pPosition3 As Vector4, _
ByVal pPosition4 As Vector4, _
ByVal weightingFactor As Single _
) As Vector4
C# public static Vector4 CatmullRom(
Vector4 pOut,
Vector4 pPosition1,
Vector4 pPosition2,
Vector4 pPosition3,
Vector4 pPosition4,
float weightingFactor
);
C++ public:
static Vector4 CatmullRom(
Vector4 pOut,
Vector4 pPosition1,
Vector4 pPosition2,
Vector4 pPosition3,
Vector4 pPosition4,
float weightingFactor
);
JScript public static function CatmullRom(
pOut : Vector4,
pPosition1 : Vector4,
pPosition2 : Vector4,
pPosition3 : Vector4,
pPosition4 : Vector4,
weightingFactor : float
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the Catmull-Rom interpolation.
pPosition1 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
pPosition2 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
pPosition3 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
pPosition4 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of pPosition1, v2 is the contents of pPosition2, p3 is the contents of pPosition3, p4 is the contents of pPosition4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the following Hermite spline equation:

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
and substituting for v1, v2, t1, t2 yields the following result.
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This result can be rearranged as follows:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

The return value for this method is the same value returned in the pOut parameter. This allows you to use the CatmullRom method as a parameter for another method.

See Also

  • Vector2.CatmullRom
  • Vector4.CatmullRom
  • Microsoft.DirectX.Vector4.CatmullRom


UnsafeNativeMethods.Vector4.Cross(Vector4,Vector4,Vector4,Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Cross Method

Determines the cross product in four dimensions.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Cross( _
ByVal pOut As Vector4, _
ByVal pV1 As Vector4, _
ByVal pV2 As Vector4, _
ByVal pV3 As Vector4 _
) As Vector4
C# public static Vector4 Cross(
Vector4 pOut,
Vector4 pV1,
Vector4 pV2,
Vector4 pV3
);
C++ public:
static Vector4 Cross(
Vector4 pOut,
Vector4 pV1,
Vector4 pV2,
Vector4 pV3
);
JScript public static function Cross(
pOut : Vector4,
pV1 : Vector4,
pV2 : Vector4,
pV3 : Vector4
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the cross product.
pV1 Microsoft.DirectX.Vector4
Source Vector4 structure.
pV2 Microsoft.DirectX.Vector4
Source Vector4 structure.
pV3 Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the cross product.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Cross method as a parameter for another method.

See Also

  • Dot
  • Microsoft.DirectX.Vector4.Cross


UnsafeNativeMethods.Vector4.Dot(Vector4,Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Dot Method

Determines the dot product of two 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Dot( _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Single
C# public static float Dot(
Vector4 pLeft,
Vector4 pRight
);
C++ public:
static float Dot(
Vector4 pLeft,
Vector4 pRight
);
JScript public static function Dot(
pLeft : Vector4,
pRight : Vector4
) : float;

Parameters

pLeft Microsoft.DirectX.Vector4
Source Vector4 structure.
pRight Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

System.Single
A Single Leave Site value that represents the dot product.

See Also

  • Cross
  • Microsoft.DirectX.Vector4.Dot


UnsafeNativeMethods.Vector4.Hermite(Vector4,Vector4,Vector4,Vector4,Vector4,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Hermite Method

Performs a Hermite spline interpolation using the specified 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Hermite( _
ByVal pOut As Vector4, _
ByVal pPosition As Vector4, _
ByVal pTangent As Vector4, _
ByVal pPosition2 As Vector4, _
ByVal pTangent2 As Vector4, _
ByVal weightingFactor As Single _
) As Vector4
C# public static Vector4 Hermite(
Vector4 pOut,
Vector4 pPosition,
Vector4 pTangent,
Vector4 pPosition2,
Vector4 pTangent2,
float weightingFactor
);
C++ public:
static Vector4 Hermite(
Vector4 pOut,
Vector4 pPosition,
Vector4 pTangent,
Vector4 pPosition2,
Vector4 pTangent2,
float weightingFactor
);
JScript public static function Hermite(
pOut : Vector4,
pPosition : Vector4,
pTangent : Vector4,
pPosition2 : Vector4,
pTangent2 : Vector4,
weightingFactor : float
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the Hermite spline interpolation.
pPosition Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
pTangent Microsoft.DirectX.Vector4
Source Vector4 structure that is a tangent vector.
pPosition2 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
pTangent2 Microsoft.DirectX.Vector4
Source Vector4 structure that is a tangent vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (pPosition, pTangent) to (pPosition2, pTangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of the ease-in, ease-out spline. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of pPosition v2 is the contents of pPosition2, t1 is the contents of pTangent, t2 is the contents of pTangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

These properties yield the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
Which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Hermite method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Hermite


UnsafeNativeMethods.Vector4.Length(Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Length Method

Returns the length of a 4-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Length( _
ByVal pSource As Vector4 _
) As Single
C# public static float Length(
Vector4 pSource
);
C++ public:
static float Length(
Vector4 pSource
);
JScript public static function Length(
pSource : Vector4
) : float;

Parameters

pSource Microsoft.DirectX.Vector4
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that indicates the vector's length.

See Also

  • LengthSq
  • Microsoft.DirectX.Vector4.Length


UnsafeNativeMethods.Vector4.LengthSq(Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.LengthSq Method

Returns the square of the length of a 4-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function LengthSq( _
ByVal pSource As Vector4 _
) As Single
C# public static float LengthSq(
Vector4 pSource
);
C++ public:
static float LengthSq(
Vector4 pSource
);
JScript public static function LengthSq(
pSource : Vector4
) : float;

Parameters

pSource Microsoft.DirectX.Vector4
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that indicates the vector's squared length.

See Also

  • Length
  • Microsoft.DirectX.Vector4.LengthSq


UnsafeNativeMethods.Vector4.Lerp(Vector4,Vector4,Vector4,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Lerp Method

Performs a linear interpolation between two 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4, _
ByVal interpolater As Single _
) As Vector4
C# public static Vector4 Lerp(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight,
float interpolater
);
C++ public:
static Vector4 Lerp(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight,
float interpolater
);
JScript public static function Lerp(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4,
interpolater : float
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the linear interpolation.
pLeft Microsoft.DirectX.Vector4
Source Vector4 structure.
pRight Microsoft.DirectX.Vector4
Source Vector4 structure.
interpolater System.Single
Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

pLeft + interpolater(pRight - pLeft).

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Lerp method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Lerp


UnsafeNativeMethods.Vector4.Maximize(Vector4,Vector4,Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Maximize Method

Returns a 4-D vector that is made up of the largest components of two 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Maximize( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Vector4
C# public static Vector4 Maximize(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
C++ public:
static Vector4 Maximize(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
JScript public static function Maximize(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is made up of the largest components of the two vectors.
pLeft Microsoft.DirectX.Vector4
Source Vector4 structure.
pRight Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is made up of the largest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Maximize method as a parameter for another method.

See Also

  • Minimize
  • Microsoft.DirectX.Vector4.Maximize


UnsafeNativeMethods.Vector4.Minimize(Vector4,Vector4,Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Minimize Method

Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Minimize( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Vector4
C# public static Vector4 Minimize(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
C++ public:
static Vector4 Minimize(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
JScript public static function Minimize(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is made up of the smallest components of the two vectors.
pLeft Microsoft.DirectX.Vector4
Source Vector4 structure.
pRight Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is made up of the smallest components of the two vectors.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Minimize method as a parameter for another method.

See Also

  • Maximize
  • Microsoft.DirectX.Vector4.Minimize


UnsafeNativeMethods.Vector4.Normalize(Vector4,Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Normalize Method

Returns the normalized version of a 4-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal pOut As Vector4, _
ByVal pSource As Vector4 _
) As Vector4
C# public static Vector4 Normalize(
Vector4 pOut,
Vector4 pSource
);
C++ public:
static Vector4 Normalize(
Vector4 pOut,
Vector4 pSource
);
JScript public static function Normalize(
pOut : Vector4,
pSource : Vector4
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the normalized version of the specified vector.
pSource Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the normalized version of the specified vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Normalize method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Normalize


UnsafeNativeMethods.Vector4.Scale(Vector4,Vector4,Single) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Scale Method

Scales a 4-D vector.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Scale( _
ByVal pOut As Vector4, _
ByVal pSource As Vector4, _
ByVal scalingFactor As Single _
) As Vector4
C# public static Vector4 Scale(
Vector4 pOut,
Vector4 pSource,
float scalingFactor
);
C++ public:
static Vector4 Scale(
Vector4 pOut,
Vector4 pSource,
float scalingFactor
);
JScript public static function Scale(
pOut : Vector4,
pSource : Vector4,
scalingFactor : float
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the scaled vector.
pSource Microsoft.DirectX.Vector4
Source Vector4 structure.
scalingFactor System.Single
Scaling value.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the scaled vector.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Scale method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Scale


UnsafeNativeMethods.Vector4.Subtract(Vector4,Vector4,Vector4) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Subtract Method

Subtracts two 4-D vectors.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal pOut As Vector4, _
ByVal pLeft As Vector4, _
ByVal pRight As Vector4 _
) As Vector4
C# public static Vector4 Subtract(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
C++ public:
static Vector4 Subtract(
Vector4 pOut,
Vector4 pLeft,
Vector4 pRight
);
JScript public static function Subtract(
pOut : Vector4,
pLeft : Vector4,
pRight : Vector4
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the operation.
pLeft Microsoft.DirectX.Vector4
Source Vector4 structure to the left of the subtraction operator.
pRight Microsoft.DirectX.Vector4
Source Vector4 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the operation.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Subtract method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Subtract


UnsafeNativeMethods.Vector4.Transform(Vector4,Vector4,Matrix) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.Transform Method

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function Transform( _
ByVal pOut As Vector4, _
ByVal pSource As Vector4, _
ByVal pSourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector4 pOut,
Vector4 pSource,
Matrix pSourceMatrix
);
C++ public:
static Vector4 Transform(
Vector4 pOut,
Vector4 pSource,
Matrix pSourceMatrix
);
JScript public static function Transform(
pOut : Vector4,
pSource : Vector4,
pSourceMatrix : Matrix
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.
pSource Microsoft.DirectX.Vector4
Source Vector4 structure.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.

Remarks

The return value for this method is the same value returned in the pOut parameter. This allows you to use the Transform method as a parameter for another method.

See Also

  • Microsoft.DirectX.Vector4.Transform


UnsafeNativeMethods.Vector4.TransformArray(Vector4,Int32,Vector4,Int32,Matrix,Int32) Method (Microsoft.DirectX)

UnsafeNativeMethods.Vector4.TransformArray Method

Transforms a vector array by a given matrix.

Note: For programming in Microsoft Visual Basic .NET or Microsoft JScript .NET, use the equivalent method in the Microsoft.DirectX structures.

Definition

Visual Basic Public Shared Function TransformArray( _
ByVal pOut As Vector4, _
ByVal outStride As Integer, _
ByVal pSource As Vector4, _
ByVal vectorStride As Integer, _
ByVal pSourceMatrix As Matrix, _
ByVal count As Integer _
) As Vector4
C# public static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector4 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
C++ public:
static Vector4 TransformArray(
Vector4 pOut,
int outStride,
Vector4 pSource,
int vectorStride,
Matrix pSourceMatrix,
int count
);
JScript public static function TransformArray(
pOut : Vector4,
outStride : int,
pSource : Vector4,
vectorStride : int,
pSourceMatrix : Matrix,
count : int
) : Vector4;

Parameters

pOut Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.
outStride System.Int32
Stride between vectors in the output data stream.
pSource Microsoft.DirectX.Vector4
Source Vector4 structure array.
vectorStride System.Int32
Stride between vectors in the input data stream.
pSourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.
count System.Int32
Number of elements in the array.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.

Remarks

This method transforms the array pSource (x, y, 0, 1) by the matrix pSourceMatrix.

The return value for this method is the same value returned in the pOut parameter. This allows you to use the TransformArray method as a parameter for another method.


Matrix Structure (Microsoft.DirectX)

Matrix Structure

How Do I...?
  • Set Up a Projection Matrix

Describes and manipulates a matrix.

Definition

Visual Basic | Public Structure Matrix
C# | public struct Matrix
C++ | public value class Matrix sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
M11 | Retrieves or sets the element in the first row and the first column of the matrix.
M12 | Retrieves or sets the element in the first row and the second column of the matrix.
M13 | Retrieves or sets the element in the first row and the third column of the matrix.
M14 | Retrieves or sets the element in the first row and the fourth column of the matrix.
M21 | Retrieves or sets the element in the second row and the first column of the matrix.
M22 | Retrieves or sets the element in the second row and the second column of the matrix.
M23 | Retrieves or sets the element in the second row and the third column of the matrix.
M24 | Retrieves or sets the element in the second row and the fourth column of the matrix.
M31 | Retrieves or sets the element in the third row and the first column of the matrix.
M32 | Retrieves or sets the element in the third row and the second column of the matrix.
M33 | Retrieves or sets the element in the third row and the third column of the matrix.
M34 | Retrieves or sets the element in the third row and the fourth column of the matrix.
M41 | Retrieves or sets the element in the fourth row and the first column of the matrix.
M42 | Retrieves or sets the element in the fourth row and the second column of the matrix.
M43 | Retrieves or sets the element in the fourth row and the third column of the matrix.
M44 | Retrieves or sets the element in the fourth row and the fourth column of the matrix.

Methods

Method | Description
static (Shared in Visual Basic) Add | Adds two matrices.
AffineTransformation | Builds a 3-D affine transformation matrix.
static (Shared in Visual Basic) AffineTransformation2D | Builds a 2-D affine transformation matrix in the xy plane.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
Invert | Calculates the inverse of a matrix.
static (Shared in Visual Basic) LookAtLH | Builds a left-handed look-at matrix.
static (Shared in Visual Basic) LookAtRH | Builds a right-handed look-at matrix.
Matrix | Initializes a new instance of the Matrix class.
Multiply | Determines the product of two matrices.
MultiplyTranspose | Calculates the transposed product of two matrices.
static (Shared in Visual Basic) op_Addition | Adds two instances of the Matrix structure.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Multiply | Determines the product of two matrices.
static (Shared in Visual Basic) op_Subtraction | Subtracts two instances of the Matrix structure.
static (Shared in Visual Basic) OrthoLH | Builds a left-handed orthogonal projection matrix.
static (Shared in Visual Basic) OrthoOffCenterLH | Builds a customized, left-handed orthogonal projection matrix.
static (Shared in Visual Basic) OrthoOffCenterRH | Builds a customized, right-handed orthogonal projection matrix.
static (Shared in Visual Basic) OrthoRH | Builds a right-handed orthogonal projection matrix.
static (Shared in Visual Basic) PerspectiveFovLH | Builds a left-handed perspective projection matrix based on a field of view.
static (Shared in Visual Basic) PerspectiveFovRH | Builds a right-handed perspective projection matrix based on a field of view (FOV).
static (Shared in Visual Basic) PerspectiveLH | Builds a left-handed perspective projection matrix.
static (Shared in Visual Basic) PerspectiveOffCenterLH | Builds a customized, left-handed perspective projection matrix.
static (Shared in Visual Basic) PerspectiveOffCenterRH | Builds a customized, right-handed perspective projection matrix.
static (Shared in Visual Basic) PerspectiveRH | Builds a right-handed perspective projection matrix.
Reflect | Builds a matrix that reflects the coordinate system about a plane.
RotateAxis | Rotates the matrix around an arbitrary axis.
RotateQuaternion | Rotates a matrix from a quaternion.
RotateX | Rotates a matrix around the x-axis.
RotateY | Rotates a matrix around the y-axis.
RotateYawPitchRoll | Rotates a matrix with a specified yaw, pitch, and roll.
RotateZ | Rotates the matrix around the z-axis.
static (Shared in Visual Basic) RotationAxis | Builds a matrix that rotates around an arbitrary axis.
static (Shared in Visual Basic) RotationQuaternion | Builds a matrix from a quaternion.
static (Shared in Visual Basic) RotationX | Builds a matrix that rotates around the x-axis.
static (Shared in Visual Basic) RotationY | Builds a matrix that rotates around the y-axis.
static (Shared in Visual Basic) RotationYawPitchRoll | Builds a matrix with a specified yaw, pitch, and roll.
static (Shared in Visual Basic) RotationZ | Builds a matrix that rotates around the z-axis.
Scale | Scales the matrix along the x-axis, y-axis, and z-axis.
static (Shared in Visual Basic) Scaling | Builds a matrix that scales along the x-axis, y-axis, and z-axis.
Shadow | Builds a matrix that flattens geometry into a plane.
static (Shared in Visual Basic) Subtract | Subtracts one matrix from another.
ToString | Obtains a string representation of the current instance.
Transform | Transforms the matrix.
static (Shared in Visual Basic) Transformation | Builds a transformation matrix.
static (Shared in Visual Basic) Transformation2D | Builds a 2-D transformation matrix in the xy plane.
Translate | Translates the matrix using specified offsets.
static (Shared in Visual Basic) Translation | Builds a matrix using specified offsets.
Transpose | Transposes the matrix using a source matrix.
static (Shared in Visual Basic) TransposeMatrix | Returns the matrix transpose of a given matrix.

Properties

Property | Description
Determinant | Retrieves the determinant of the matrix.
static (Shared in Visual Basic) Identity | Retrieves the identity of the matrix.
static (Shared in Visual Basic) Zero | Retrieves an empty matrix.

Remarks

This structure represents a 4x4 matrix of Single Leave Site values. The fields of this structure are named with the row number first, then the column number.

In Microsoft Direct3D, the M34 element of a projection matrix cannot be a negative number. If an application needs to use a negative value in this location, it should scale the entire projection matrix by -1 instead.

How Do I...?

Set Up a Projection Matrix

This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.

See the following C# code example, the Projection transformation matrix is set to be equal to the left-handed (LH) PerspectiveFovLH matrix. Input arguments to PerspectiveFovLH are as follows.

  1. Field of view in radians: pi/4.
  2. Aspect ratio, or view-space height divided by width: 1, for a square window.
  3. Near clipping plane distance: 1 unit.
  4. Far clipping plane distance: 100 units.

              [C#]

using Microsoft.DirectX;

Direct3D.Device device = null;  // Create rendering device.

// For the projection matrix, you set up a perspective transform (which
//   transforms geometry from 3-D view space to 2-D viewport space, with
//   a perspective divide making objects smaller in the distance). To build
//   a perspective transform, you need the field of view (1/4 pi is common),
//   the aspect ratio, and the near and far clipping planes (which define
//   the distances at which geometry should no longer be rendered).

device.Transform.Projection = Matrix.PerspectiveFovLH(
                              (float)Math.PI / 4, 1.0f, 1.0f, 100.0f );

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Device.GetTransform
  • Device.SetTransform
  • Device.SetTransform
  • Microsoft.DirectX.UnsafeNativeMethods.Matrix Class


Matrix.Add(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.Add Method

Adds two matrices.

Definition

Visual Basic Public Shared Function Add( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix Add(
Matrix left,
Matrix right
);
C++ public:
static Matrix Add(
Matrix left,
Matrix right
);
JScript public static function Add(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left Microsoft.DirectX.Matrix
A Matrix instance on the left side of the addition operator.
right Microsoft.DirectX.Matrix
A Matrix instance on the right side of the addition operator.

Return Value

Microsoft.DirectX.Matrix
A Matrix instance that represents the result of the addition.


Matrix.AffineTransformation(Single,Vector3,Quaternion,Vector3) Method (Microsoft.DirectX)

Matrix.AffineTransformation Method

Builds a 3-D affine transformation matrix.

Definition

Visual Basic Public Sub AffineTransformation( _
ByVal scaling As Single, _
ByVal rotationCenter As Vector3, _
ByVal rotation As Quaternion, _
ByVal translation As Vector3 _
)
C# public void AffineTransformation(
float scaling,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
C++ public:
void AffineTransformation(
float scaling,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
JScript public function AffineTransformation(
scaling : float,
rotationCenter : Vector3,
rotation : Quaternion,
translation : Vector3
);

Parameters

scaling System.Single
Scaling factor. A value of zero indicates no scaling.
rotationCenter Microsoft.DirectX.Vector3
A Vector3 structure that indicates the point at the center of rotation.
rotation Microsoft.DirectX.Quaternion
A Quaternion structure that specifies the rotation. Use Quaternion.Identity to specify no rotation.
translation Microsoft.DirectX.Vector3
A Vector3 structure that represents the translation. Use Vector2.Empty to specify no translation.

Remarks

The AffineTransformation method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

Mout = Ms * (Mrc)-1 * Mr * Mrc * Mt

where:

  • Mout = output matrix (this instance)
  • Ms = scaling matrix (scaling)
  • Mrc = center of rotation matrix (rotationCenter)
  • Mr = rotation matrix (rotation)
  • Mt = translation matrix (translation)

For 2-D affine transformations, use AffineTransformation2D.


Matrix.AffineTransformation2D(Single,Vector2,Single,Vector2) Method (Microsoft.DirectX)

Matrix.AffineTransformation2D Method

Builds a 2-D affine transformation matrix in the xy plane.

Definition

Visual Basic Public Shared Function AffineTransformation2D( _
ByVal scaling As Single, _
ByVal rotationCenter As Vector2, _
ByVal rotation As Single, _
ByVal translation As Vector2 _
) As Matrix
C# public static Matrix AffineTransformation2D(
float scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
C++ public:
static Matrix AffineTransformation2D(
float scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
JScript public static function AffineTransformation2D(
scaling : float,
rotationCenter : Vector2,
rotation : float,
translation : Vector2
) : Matrix;

Parameters

scaling System.Single
Scaling factor. A value of zero indicates no scaling.
rotationCenter Microsoft.DirectX.Vector2
A Vector2 structure that represents a point identifying the center of rotation. Use an empty Vector2 for no rotation.
rotation System.Single
Angle of rotation. A value of zero indicates no rotation
translation Microsoft.DirectX.Vector2
A Vector2 structure that represents the translation. Use Vector2.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is an affine transformation matrix.

Remarks

The AffineTransformation2D method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

Mout = Ms * (Mrc)-1 * Mr * Mrc * Mt

where:

  • Mout = output matrix (this instance)
  • Ms = scaling matrix (scaling)
  • Mrc = center of rotation matrix (rotationCenter)
  • Mr = rotation matrix (rotation)
  • Mt = translation matrix (translation)

For 3-D affine transformations, use AffineTransformation.


Matrix.Equals(Object) Method (Microsoft.DirectX)

Matrix.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Matrix.GetHashCode() Method (Microsoft.DirectX)

Matrix.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Matrix.Invert Method ()

Calculates the inverse of a matrix.

Overload List

public void Invert();
public static Matrix Invert(Matrix);
public static Matrix Invert(ref float, Matrix);


Matrix.Invert() Method (Microsoft.DirectX)

Matrix.Invert Method

Calculates the inverse of a matrix.

Definition

Visual Basic | Public Sub Invert()
C# | public void Invert();
C++ public:
void Invert();
JScript | public function Invert();


Matrix.Invert(Matrix) Method (Microsoft.DirectX)

Matrix.Invert Method

Calculates the inverse of a matrix.

Definition

Visual Basic Public Shared Function Invert( _
ByVal source As Matrix _
) As Matrix
C# public static Matrix Invert(
Matrix source
);
C++ public:
static Matrix Invert(
Matrix source
);
JScript public static function Invert(
source : Matrix
) : Matrix;

Parameters

source Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is the result of the operation.


Matrix.Invert(Single,Matrix) Method (Microsoft.DirectX)

Matrix.Invert Method

Calculates the inverse of a matrix.

Definition

Visual Basic Public Shared Function Invert( _
ByRef determinant As Single, _
ByVal source As Matrix _
) As Matrix
C# public static Matrix Invert(
ref float determinant,
Matrix source
);
C++ public:
static Matrix Invert(
float% determinant,
Matrix source
);
JScript public static function Invert(
determinant : float,
source : Matrix
) : Matrix;

Parameters

determinant System.Single
A Single Leave Site value that contains the determinant of the matrix. If the determinant is not needed, the parameter is omitted.
source Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is the result of the operation.


Matrix.LookAtLH(Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

Matrix.LookAtLH Method

How Do I...?
  • Set Up a View Matrix

Builds a left-handed look-at matrix.

Definition

Visual Basic Public Shared Function LookAtLH( _
ByVal cameraPosition As Vector3, _
ByVal cameraTarget As Vector3, _
ByVal cameraUpVector As Vector3 _
) As Matrix
C# public static Matrix LookAtLH(
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
C++ public:
static Matrix LookAtLH(
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
JScript public static function LookAtLH(
cameraPosition : Vector3,
cameraTarget : Vector3,
cameraUpVector : Vector3
) : Matrix;

Parameters

cameraPosition Microsoft.DirectX.Vector3
A Vector3 structure that defines the camera point. This value is used in translation.
cameraTarget Microsoft.DirectX.Vector3
A Vector3 structure that defines the camera look-at target.
cameraUpVector Microsoft.DirectX.Vector3
A Vector3 structure that defines the up direction of the current world, usually [0, 1, 0].

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a left-handed look-at matrix.

Remarks

This method uses the following formula to compute the returned matrix.

zaxis = normal(cameraTarget - cameraPosition)
xaxis = normal(cross(cameraUpVector, zaxis))
yaxis = cross(zaxis, xaxis)

 xaxis.x           yaxis.x           zaxis.x          0
 xaxis.y           yaxis.y           zaxis.y          0
 xaxis.z           yaxis.z           zaxis.z          0
-dot(xaxis, cameraPosition)  -dot(yaxis, cameraPosition)  -dot(zaxis, cameraPosition)  1

How Do I...?

Set Up a View Matrix

This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.

In the following C# code example, the vector components of the Vector3 structure form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The View transformation matrix is set to be equal to this look-at matrix.

The three input vectors represent the following, respectively:

  1. The eye point: [0, 3, -5].
  2. The camera look-at target: the origin [0, 0, 0].
  3. The current world's up-direction: usually [0, 1, 0].

              [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;  // Create rendering device.

// Set up the view matrix. A view matrix can be defined given an eye point,
//   a point to view, and a direction for which way is up. Here, you set
//   the eye five units back along the z-axis and up three units, view the
//   origin, and define "up" to be in the y-direction.

device.Transform.View = Microsoft.DirectX.Matrix.LookAtLH(
                            new Vector3(0.0f, 3.0f, -5.0f),
                            new Vector3(0.0f, 0.0f, 0.0f),
                            new Vector3(0.0f, 1.0f, 0.0f));

See Also

  • Matrix.LookAtRH


Matrix.LookAtRH(Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

Matrix.LookAtRH Method

Builds a right-handed look-at matrix.

Definition

Visual Basic Public Shared Function LookAtRH( _
ByVal cameraPosition As Vector3, _
ByVal cameraTarget As Vector3, _
ByVal cameraUpVector As Vector3 _
) As Matrix
C# public static Matrix LookAtRH(
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
C++ public:
static Matrix LookAtRH(
Vector3 cameraPosition,
Vector3 cameraTarget,
Vector3 cameraUpVector
);
JScript public static function LookAtRH(
cameraPosition : Vector3,
cameraTarget : Vector3,
cameraUpVector : Vector3
) : Matrix;

Parameters

cameraPosition Microsoft.DirectX.Vector3
A Vector3 structure that defines the camera point. This value is used in translation.
cameraTarget Microsoft.DirectX.Vector3
A Vector3 structure that defines the camera look-at target.
cameraUpVector Microsoft.DirectX.Vector3
A Vector3 structure that defines the up direction of the current world, usually [0, 1, 0].

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a right-handed look-at matrix.

Remarks

This method uses the following formula to compute the returned matrix.

zaxis = normal(cameraPosition - cameraTarget)
xaxis = normal(cross(cameraUpVector, zaxis))
yaxis = cross(zaxis, xaxis)

 xaxis.x           yaxis.x           zaxis.x          0
 xaxis.y           yaxis.y           zaxis.y          0
 xaxis.z           yaxis.z           zaxis.z          0
-dot(xaxis, cameraPosition)  -dot(yaxis, cameraPosition)  -dot(zaxis, cameraPosition)  1

See Also

  • Matrix.LookAtLH


Matrix.Matrix() Constructor (Microsoft.DirectX)

Matrix.Matrix Constructor

Initializes a new instance of the Matrix class.

Definition

Visual Basic | Public Sub New()
C# | public Matrix();
C++ public:
Matrix();
JScript | public function Matrix();


Matrix.Multiply Method ()

Determines the product of two matrices.

Overload List

public void Multiply(Matrix);
public static Matrix Multiply(Matrix, Matrix);

Remarks

This method's result represents the transformation of left (or the current instance) followed by the transformation of right (or source).

The following equations demonstrate how the multiplication takes place.

Out = left * right

Out = this instance * source

See Also

  • Quaternion.Multiply


Matrix.Multiply(Matrix) Method (Microsoft.DirectX)

Matrix.Multiply Method

Determines the product of two matrices.

Definition

Visual Basic Public Sub Multiply( _
ByVal source As Matrix _
)
C# public void Multiply(
Matrix source
);
C++ public:
void Multiply(
Matrix source
);
JScript public function Multiply(
source : Matrix
);

Parameters

source Microsoft.DirectX.Matrix
Source Matrix structure to multiply by the current instance.

Remarks

This method's result represents the transformation of left (or the current instance) followed by the transformation of right (or source).

The following equations demonstrate how the multiplication takes place.

Out = left * right

Out = this instance * source

See Also

  • Quaternion.Multiply


Matrix.Multiply(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.Multiply Method

Determines the product of two matrices.

Definition

Visual Basic Public Shared Function Multiply( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix Multiply(
Matrix left,
Matrix right
);
C++ public:
static Matrix Multiply(
Matrix left,
Matrix right
);
JScript public static function Multiply(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left Microsoft.DirectX.Matrix
Source Matrix structure.
right Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is the product of two matrices.

Remarks

This method's result represents the transformation of left (or the current instance) followed by the transformation of right (or source).

The following equations demonstrate how the multiplication takes place.

Out = left * right

Out = this instance * source

See Also

  • Quaternion.Multiply


Matrix.MultiplyTranspose Method ()

Calculates the transposed product of two matrices.

Overload List

public void MultiplyTranspose(Matrix);
public static Matrix MultiplyTranspose(Matrix, Matrix);

Remarks

This method's result is the transposed product of two transformation matrices:

Out = T(left * right).

Out = T(this instance * source).

This method is useful for setting matrices as constants for vertex and pixel shaders.

See Also

  • Matrix.Multiply
  • Quaternion.Multiply


Matrix.MultiplyTranspose(Matrix) Method (Microsoft.DirectX)

Matrix.MultiplyTranspose Method

Calculates the transposed product of two matrices.

Definition

Visual Basic Public Sub MultiplyTranspose( _
ByVal source As Matrix _
)
C# public void MultiplyTranspose(
Matrix source
);
C++ public:
void MultiplyTranspose(
Matrix source
);
JScript public function MultiplyTranspose(
source : Matrix
);

Parameters

source Microsoft.DirectX.Matrix
Source Matrix structure to multiply and transpose with the current instance.

Remarks

This method's result is the transposed product of two transformation matrices:

Out = T(left * right).

Out = T(this instance * source).

This method is useful for setting matrices as constants for vertex and pixel shaders.

See Also

  • Matrix.Multiply
  • Quaternion.Multiply


Matrix.MultiplyTranspose(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.MultiplyTranspose Method

Calculates the transposed product of two matrices.

Definition

Visual Basic Public Shared Function MultiplyTranspose( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix MultiplyTranspose(
Matrix left,
Matrix right
);
C++ public:
static Matrix MultiplyTranspose(
Matrix left,
Matrix right
);
JScript public static function MultiplyTranspose(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left Microsoft.DirectX.Matrix
Source Matrix structure.
right Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is the product and transposition of two matrices.

Remarks

This method's result is the transposed product of two transformation matrices:

Out = T(left * right).

Out = T(this instance * source).

This method is useful for setting matrices as constants for vertex and pixel shaders.

See Also

  • Matrix.Multiply
  • Quaternion.Multiply


Matrix.op_Addition(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.op_Addition Method

Adds two instances of the Matrix structure.

Definition

Visual Basic Public Shared Function op_Addition( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix op_Addition(
Matrix left,
Matrix right
);
C++ public:
static Matrix operator+(
Matrix left,
Matrix right
);
JScript public static function op_Addition(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left Microsoft.DirectX.Matrix
The Matrix structure to the left of the addition operator.
right Microsoft.DirectX.Matrix
The Matrix structure to the right of the addition operator.

Return Value

Microsoft.DirectX.Matrix
Resulting Matrix structure.


Matrix.op_Equality(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Boolean
C# public static bool op_Equality(
Matrix left,
Matrix right
);
C++ public:
static bool operator==(
Matrix left,
Matrix right
);
JScript public static function op_Equality(
left : Matrix,
right : Matrix
) : boolean;

Parameters

left Microsoft.DirectX.Matrix
The Matrix structure to the left of the equality operator.
right Microsoft.DirectX.Matrix
The Matrix structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Matrix.op_Inequality(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Boolean
C# public static bool op_Inequality(
Matrix left,
Matrix right
);
C++ public:
static bool operator!=(
Matrix left,
Matrix right
);
JScript public static function op_Inequality(
left : Matrix,
right : Matrix
) : boolean;

Parameters

left Microsoft.DirectX.Matrix
The Matrix structure to the left of the inequality operator.
right Microsoft.DirectX.Matrix
The Matrix structure to the right of the inequality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Matrix.op_Multiply(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.op_Multiply Method

Determines the product of two matrices.

Definition

Visual Basic Public Shared Function op_Multiply( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix op_Multiply(
Matrix left,
Matrix right
);
C++ public:
static Matrix operator*(
Matrix left,
Matrix right
);
JScript public static function op_Multiply(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left Microsoft.DirectX.Matrix
Source Matrix structure.
right Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is the product of two matrices.

See Also

  • Multiply


Matrix.op_Subtraction(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.op_Subtraction Method

Subtracts two instances of the Matrix structure.

Definition

Visual Basic Public Shared Function op_Subtraction( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix op_Subtraction(
Matrix left,
Matrix right
);
C++ public:
static Matrix operator-(
Matrix left,
Matrix right
);
JScript public static function op_Subtraction(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left Microsoft.DirectX.Matrix
The Matrix structure to the left of the subtraction operator.
right Microsoft.DirectX.Matrix
The Matrix structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Matrix
Resulting Matrix structure.


Matrix.OrthoLH(Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.OrthoLH Method

Builds a left-handed orthogonal projection matrix.

Definition

Visual Basic Public Shared Function OrthoLH( _
ByVal width As Single, _
ByVal height As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix OrthoLH(
float width,
float height,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix OrthoLH(
float width,
float height,
float znearPlane,
float zfarPlane
);
JScript public static function OrthoLH(
width : float,
height : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

width System.Single
Width of the view volume.
height System.Single
Height of the view volume.
znearPlane System.Single
Minimum z-value of the view volume, which is referred to as z-near.
zfarPlane System.Single
Maximum z-value of the view volume, which is referred to as z-far.

Return Value

Microsoft.DirectX.Matrix
Pointer to a Matrix structure that is a left-handed orthogonal projection matrix.

Remarks

An orthogonal matrix is an invertible matrix for which the inverse is equal to the transpose.

All of the parameters of the OrthoLH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2/width    0         0                                  0
0          2/height  0                                  0
0          0         1/(zfarPlane-znearPlane)           0
0          0         znearPlane/(znearPlane-zfarPlane)  1

See Also

  • Matrix.OrthoRH
  • Matrix.OrthoOffCenterRH
  • Matrix.OrthoOffCenterLH


Matrix.OrthoOffCenterLH(Single,Single,Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.OrthoOffCenterLH Method

Builds a customized, left-handed orthogonal projection matrix.

Definition

Visual Basic Public Shared Function OrthoOffCenterLH( _
ByVal left As Single, _
ByVal right As Single, _
ByVal bottom As Single, _
ByVal top As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix OrthoOffCenterLH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix OrthoOffCenterLH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
JScript public static function OrthoOffCenterLH(
left : float,
right : float,
bottom : float,
top : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

left System.Single
Minimum x-value of the view volume.
right System.Single
Maximum x-value of the view volume.
bottom System.Single
Minimum y-value of the view volume.
top System.Single
Maximum y-value of the view volume.
znearPlane System.Single
Minimum z-value of the view volume.
zfarPlane System.Single
Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a customized, left-handed orthogonal projection matrix.

Remarks

An orthogonal matrix is an invertible matrix for which the inverse is equal to the transpose.

The OrthoLH method is a special case of the OrthoOffCenterLH method. To create the same projection using OrthoOffCenterLH, use the following values: left = -width/2, right = width/2, bottom = -height/2, and top = height/2.

All of the parameters of the OrthoOffCenterLH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2/(right-l)           0                         0                                  0
0                     2/(top-bottom)            0                                  0
0                     0                         1/(zfarPlane-znearPlane)           0
(l+right)/(l-right)  (top+bottom)/(bottom-top)  znearPlane/(znearPlane-zfarPlane)  1

See Also

  • Matrix.OrthoLH
  • Matrix.OrthoRH
  • Matrix.OrthoOffCenterRH


Matrix.OrthoOffCenterRH(Single,Single,Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.OrthoOffCenterRH Method

Builds a customized, right-handed orthogonal projection matrix.

Definition

Visual Basic Public Shared Function OrthoOffCenterRH( _
ByVal left As Single, _
ByVal right As Single, _
ByVal bottom As Single, _
ByVal top As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix OrthoOffCenterRH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix OrthoOffCenterRH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
JScript public static function OrthoOffCenterRH(
left : float,
right : float,
bottom : float,
top : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

left System.Single
Minimum x-value of the view volume.
right System.Single
Maximum x-value of the view volume.
bottom System.Single
Maximum y-value of the view volume.
top System.Single
Minimum y-value of the view volume.
znearPlane System.Single
Minimum z-value of the view volume.
zfarPlane System.Single
Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a customized, right-handed orthogonal projection matrix.

Remarks

An orthogonal matrix is an invertible matrix for which the inverse is equal to the transpose.

The OrthoRH method is a special case of the OrthoOffCenterRH method. To create the same projection using OrthoOffCenterRH, use the following values: left = -width/2, right = width/2, bottom = -height/2, and top = height/2.

All of the parameters of the OrthoOffCenterRH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2/(right-left)         0                         0                                  0
0                      2/(top-bottom)            0                                  0
0                      0                         1/(znearPlane-zfarPlane)           0
(l+right)/(l-rright)  (top+bottom)/(bottom-top)  znearPlane/(znearPlane-zfarPlane)  1

See Also

  • Matrix.OrthoLH
  • Matrix.OrthoRH
  • Matrix.OrthoOffCenterLH


Matrix.OrthoRH(Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.OrthoRH Method

Builds a right-handed orthogonal projection matrix.

Definition

Visual Basic Public Shared Function OrthoRH( _
ByVal width As Single, _
ByVal height As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix OrthoRH(
float width,
float height,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix OrthoRH(
float width,
float height,
float znearPlane,
float zfarPlane
);
JScript public static function OrthoRH(
width : float,
height : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

width System.Single
Width of the view volume.
height System.Single
Height of the view volume.
znearPlane System.Single
Minimum z-value of the view volume.
zfarPlane System.Single
Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix
Pointer to a Matrix structure that is a right-handed orthogonal projection matrix.

Remarks

An orthogonal matrix is an invertible matrix for which the inverse is equal to the transpose.

All of the parameters of the OrthoRH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2/width  0         0                                  0
0        2/height  0                                  0
0        0         1/(znearPlane-zfarPlane)           0
0        0         znearPlane/(znearPlane-zfarPlane)  1

See Also

  • Matrix.OrthoLH
  • Matrix.OrthoOffCenterRH
  • Matrix.OrthoOffCenterLH


Matrix.PerspectiveFovLH(Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.PerspectiveFovLH Method

How Do I...?
  • Set Up a Projection Matrix

Builds a left-handed perspective projection matrix based on a field of view.

Definition

Visual Basic Public Shared Function PerspectiveFovLH( _
ByVal fieldOfViewY As Single, _
ByVal aspectRatio As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveFovLH(
float fieldOfViewY,
float aspectRatio,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix PerspectiveFovLH(
float fieldOfViewY,
float aspectRatio,
float znearPlane,
float zfarPlane
);
JScript public static function PerspectiveFovLH(
fieldOfViewY : float,
aspectRatio : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

fieldOfViewY System.Single
Field of view in the y direction, in radians.
aspectRatio System.Single
Aspect ratio, defined as the view space width divided by height.
znearPlane System.Single
Z-value of the near view plane.
zfarPlane System.Single
Z-value of the far view plane.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a left-handed perspective projection matrix.

Remarks

This method uses the following formula to compute the returned matrix. The view space height is represented by h, which is calculated from h = cot(fieldOfViewY/2). The view space width is represented by w, which is calculated from h = w / aspectRatio.

w       0       0                                             0
0       h       0                                             0
0       0       zfarPlane/(zfarPlane-znearPlane)              1
0       0       -znearPlane*zfarPlane/(zfarPlane-znearPlane)  0

How Do I...?

Set Up a Projection Matrix

This example demonstrates how to set up the projection transformation matrix, which transforms 3-D camera or view space coordinates into 2-D screen coordinates.

See the following C# code example, the Projection transformation matrix is set to be equal to the left-handed (LH) PerspectiveFovLH matrix. Input arguments to PerspectiveFovLH are as follows.

  1. Field of view in radians: pi/4.
  2. Aspect ratio, or view-space height divided by width: 1, for a square window.
  3. Near clipping plane distance: 1 unit.
  4. Far clipping plane distance: 100 units.

              [C#]

using Microsoft.DirectX;

Direct3D.Device device = null;  // Create rendering device.

// For the projection matrix, you set up a perspective transform (which
//   transforms geometry from 3-D view space to 2-D viewport space, with
//   a perspective divide making objects smaller in the distance). To build
//   a perspective transform, you need the field of view (1/4 pi is common),
//   the aspect ratio, and the near and far clipping planes (which define
//   the distances at which geometry should no longer be rendered).

device.Transform.Projection = Matrix.PerspectiveFovLH(
                              (float)Math.PI / 4, 1.0f, 1.0f, 100.0f );

See Also

  • PerspectiveFovRH
  • PerspectiveLH
  • PerspectiveOffCenterLH
  • PerspectiveOffCenterRH
  • PerspectiveRH


Matrix.PerspectiveFovRH(Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.PerspectiveFovRH Method

Builds a right-handed perspective projection matrix based on a field of view (FOV).

Definition

Visual Basic Public Shared Function PerspectiveFovRH( _
ByVal fieldOfViewY As Single, _
ByVal aspectRatio As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveFovRH(
float fieldOfViewY,
float aspectRatio,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix PerspectiveFovRH(
float fieldOfViewY,
float aspectRatio,
float znearPlane,
float zfarPlane
);
JScript public static function PerspectiveFovRH(
fieldOfViewY : float,
aspectRatio : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

fieldOfViewY System.Single
Field of view in the y direction, in radians.
aspectRatio System.Single
Aspect ratio, defined as the view space width divided by height.
znearPlane System.Single
Z-value of the near view plane.
zfarPlane System.Single
Z-value of the far view plane.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a right-handed perspective projection matrix.

Remarks

This method uses the following formula to compute the returned matrix. The view space height is represented by h. It is calculated from h = cot(fieldOfViewY/2). The view space width is represented by w. It is calculated from h = w / aspectRatio.

w       0       0                                              0
0       h       0                                              0
0       0       zfarPlane/(znearPlane-zfarPlane)              -1
0       0       znearPlane*zfarPlane/(znearPlane-zfarPlane)    0

See Also

  • PerspectiveFovLH
  • PerspectiveLH
  • PerspectiveOffCenterLH
  • PerspectiveOffCenterRH
  • PerspectiveRH


Matrix.PerspectiveLH(Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.PerspectiveLH Method

Builds a left-handed perspective projection matrix.

Definition

Visual Basic Public Shared Function PerspectiveLH( _
ByVal width As Single, _
ByVal height As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveLH(
float width,
float height,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix PerspectiveLH(
float width,
float height,
float znearPlane,
float zfarPlane
);
JScript public static function PerspectiveLH(
width : float,
height : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

width System.Single
Width of the view volume at the near view plane.
height System.Single
Height of the view volume at the near view plane.
znearPlane System.Single
Z-value of the near view plane.
zfarPlane System.Single
Z-value of the far view plane.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a left-handed perspective projection matrix.

Remarks

All of the parameters of the PerspectiveLH method are distances in camera space. The parameters describe the dimensions of the view volume.

2*znearPlane/width  0                    0                                            0
0                   2*znearPlane/height  0                                            0
0                   0                    zfarPlane/(zfarPlane-znearPlane)             1
0                   0                    znearPlane*zfarPlane/(znearPlane-zfarPlane)  0

See Also

  • PerspectiveFovLH
  • PerspectiveRH
  • PerspectiveOffCenterLH
  • PerspectiveOffCenterRH
  • PerspectiveRH


Matrix.PerspectiveOffCenterLH(Single,Single,Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.PerspectiveOffCenterLH Method

Builds a customized, left-handed perspective projection matrix.

Definition

Visual Basic Public Shared Function PerspectiveOffCenterLH( _
ByVal left As Single, _
ByVal right As Single, _
ByVal bottom As Single, _
ByVal top As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveOffCenterLH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix PerspectiveOffCenterLH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
JScript public static function PerspectiveOffCenterLH(
left : float,
right : float,
bottom : float,
top : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

left System.Single
Minimum x-value of the view volume.
right System.Single
Maximum x-value of the view volume.
bottom System.Single
Minimum y-value of the view volume.
top System.Single
Maximum y-value of the view volume.
znearPlane System.Single
Minimum z-value of the view volume.
zfarPlane System.Single
Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a customized, left-handed perspective projection matrix.

Remarks

All of the parameters of the PerspectiveOffCenterLH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2*znearPlane/(right-left)  0                           0                                            0
0                          2*znearPlane/(top-bottom)   0                                            0
(left+right)/(left-right)  (top+bottom)/(bottom-top)   zfarPlane/(zfarPlane-znearPlane)             1
0                          0                           znearPlane*zfarPlane/(znearPlane-zfarPlane)  0

See Also

  • PerspectiveFovLH
  • PerspectiveFovRH
  • PerspectiveRH
  • PerspectiveLH
  • PerspectiveOffCenterRH


Matrix.PerspectiveOffCenterRH(Single,Single,Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.PerspectiveOffCenterRH Method

Builds a customized, right-handed perspective projection matrix.

Definition

Visual Basic Public Shared Function PerspectiveOffCenterRH( _
ByVal left As Single, _
ByVal right As Single, _
ByVal bottom As Single, _
ByVal top As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveOffCenterRH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix PerspectiveOffCenterRH(
float left,
float right,
float bottom,
float top,
float znearPlane,
float zfarPlane
);
JScript public static function PerspectiveOffCenterRH(
left : float,
right : float,
bottom : float,
top : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

left System.Single
Minimum x-value of the view volume.
right System.Single
Maximum x-value of the view volume.
bottom System.Single
Minimum y-value of the view volume.
top System.Single
Maximum y-value of the view volume.
znearPlane System.Single
Minimum z-value of the view volume.
zfarPlane System.Single
Maximum z-value of the view volume.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that is a customized, right-handed perspective projection matrix.

Remarks

All of the parameters of the PerspectiveOffCenterRH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2*znearPlane/(right-left)   0                           0                                              0
0                           2*znearPlane/(top-bottom)   0                                              0
(left+right)/(right-left)  (top+bottom)/(top-bottom)    zfarPlane/(znearPlane-zfarPlane)              -1
0                           0                           znearPlane*zfarPlane/(znearPlane-zfarPlane)    0

See Also

  • PerspectiveFovLH
  • PerspectiveFovRH
  • PerspectiveRH
  • PerspectiveLH
  • PerspectiveOffCenterLH


Matrix.PerspectiveRH(Single,Single,Single,Single) Method (Microsoft.DirectX)

Matrix.PerspectiveRH Method

Builds a right-handed perspective projection matrix.

Definition

Visual Basic Public Shared Function PerspectiveRH( _
ByVal width As Single, _
ByVal height As Single, _
ByVal znearPlane As Single, _
ByVal zfarPlane As Single _
) As Matrix
C# public static Matrix PerspectiveRH(
float width,
float height,
float znearPlane,
float zfarPlane
);
C++ public:
static Matrix PerspectiveRH(
float width,
float height,
float znearPlane,
float zfarPlane
);
JScript public static function PerspectiveRH(
width : float,
height : float,
znearPlane : float,
zfarPlane : float
) : Matrix;

Parameters

width System.Single
Width of the view volume at the near view plane.
height System.Single
Height of the view volume at the near view plane.
znearPlane System.Single
Z-value of the near view plane.
zfarPlane System.Single
Z-value of the far view plane.

Return Value

Microsoft.DirectX.Matrix
Pointer to a Matrix structure that is a right-handed perspective projection matrix.

Remarks

All of the parameters of the PerspectiveRH method are distances in camera space. The parameters describe the dimensions of the view volume.

This method uses the following formula to compute the returned matrix.

2*znearPlane/width  0                    0                                            0
0                   2*znearPlane/height  0                                            0
0                   0                    zfarPlane/(znearPlane-zfarPlane)            -1
0                   0                    znearPlane*zfarPlane/(znearPlane-zfarPlane)  0

See Also

  • PerspectiveFovLH
  • PerspectiveFovRH
  • PerspectiveLH
  • PerspectiveOffCenterLH
  • PerspectiveOffCenterRH


Matrix.Reflect(Plane) Method (Microsoft.DirectX)

Matrix.Reflect Method

Builds a matrix that reflects the coordinate system about a plane.

Definition

Visual Basic Public Sub Reflect( _
ByVal plane As Plane _
)
C# public void Reflect(
Plane plane
);
C++ public:
void Reflect(
Plane plane
);
JScript public function Reflect(
plane : Plane
);

Parameters

plane Microsoft.DirectX.Plane
Source Plane structure.

Remarks

The Reflect method normalizes the plane equation before it creates the reflected matrix.

The method uses the following formula to compute the returned matrix.

P = normalize(plane);

-2 * P.a * P.a + 1  -2 * P.b * P.a      -2 * P.c * P.a        0
-2 * P.a * P.b      -2 * P.b * P.b + 1  -2 * P.c * P.b        0
-2 * P.a * P.c      -2 * P.b * P.c      -2 * P.c * P.c + 1    0
-2 * P.a * P.d      -2 * P.b * P.d      -2 * P.c * P.d        1


Matrix.RotateAxis(Vector3,Single) Method (Microsoft.DirectX)

Matrix.RotateAxis Method

Rotates the matrix around an arbitrary axis.

Definition

Visual Basic Public Sub RotateAxis( _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
)
C# public void RotateAxis(
Vector3 axisRotation,
float angle
);
C++ public:
void RotateAxis(
Vector3 axisRotation,
float angle
);
JScript public function RotateAxis(
axisRotation : Vector3,
angle : float
);

Parameters

axisRotation Microsoft.DirectX.Vector3
A Vector3 structure that identifies the axis about which to rotate the matrix.
angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

See Also

  • Matrix.RotateQuaternion
  • Matrix.RotateX
  • Matrix.RotateY
  • Matrix.RotateZ
  • Matrix.RotateYawPitchRoll


Matrix.RotateQuaternion(Quaternion) Method (Microsoft.DirectX)

Matrix.RotateQuaternion Method

Rotates a matrix from a quaternion.

Definition

Visual Basic Public Sub RotateQuaternion( _
ByVal quat As Quaternion _
)
C# public void RotateQuaternion(
Quaternion quat
);
C++ public:
void RotateQuaternion(
Quaternion quat
);
JScript public function RotateQuaternion(
quat : Quaternion
);

Parameters

quat Microsoft.DirectX.Quaternion
Source Quaternion structure that defines the rotation.

Remarks

For information about how to calculate quaternion values from a direction vector ( x, y, z ) and an angle of rotation, see Quaternion.

See Also

  • Matrix.RotateAxis
  • Matrix.RotateX
  • Matrix.RotateY
  • Matrix.RotateZ
  • Matrix.RotateYawPitchRoll


Matrix.RotateX(Single) Method (Microsoft.DirectX)

Matrix.RotateX Method

Rotates a matrix around the x-axis.

Definition

Visual Basic Public Sub RotateX( _
ByVal angle As Single _
)
C# public void RotateX(
float angle
);
C++ public:
void RotateX(
float angle
);
JScript public function RotateX(
angle : float
);

Parameters

angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

See Also

  • Matrix.RotateAxis
  • Matrix.RotateQuaternion
  • Matrix.RotateY
  • Matrix.RotateZ
  • Matrix.RotateYawPitchRoll


Matrix.RotateY(Single) Method (Microsoft.DirectX)

Matrix.RotateY Method

Rotates a matrix around the y-axis.

Definition

Visual Basic Public Sub RotateY( _
ByVal angle As Single _
)
C# public void RotateY(
float angle
);
C++ public:
void RotateY(
float angle
);
JScript public function RotateY(
angle : float
);

Parameters

angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

See Also

  • Matrix.RotateAxis
  • Matrix.Quaternion
  • Matrix.RotateX
  • Matrix.RotateZ
  • Matrix.RotateYawPitchRoll


Matrix.RotateYawPitchRoll(Single,Single,Single) Method (Microsoft.DirectX)

Matrix.RotateYawPitchRoll Method

Rotates a matrix with a specified yaw, pitch, and roll.

Definition

Visual Basic Public Sub RotateYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
)
C# public void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
C++ public:
void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript public function RotateYawPitchRoll(
yaw : float,
pitch : float,
roll : float
);

Parameters

yaw System.Single
Yaw around the y-axis, in radians.
pitch System.Single
Pitch around the x-axis, in radians.
roll System.Single
Roll around the z-axis, in radians.

Remarks

The order of transformations is first roll, then pitch, then yaw. Relative to the object's local coordinate axis, this is equivalent to rotation around the z-axis, followed by rotation around the x-axis, followed by rotation around the y-axis.

Pitch Yaw Roll diagram

See Also

  • Matrix.RotateAxis
  • Matrix.Quaternion
  • Matrix.RotateX
  • Matrix.RotateY
  • Matrix.RotateZ


Matrix.RotateZ(Single) Method (Microsoft.DirectX)

Matrix.RotateZ Method

Rotates the matrix around the z-axis.

Definition

Visual Basic Public Sub RotateZ( _
ByVal angle As Single _
)
C# public void RotateZ(
float angle
);
C++ public:
void RotateZ(
float angle
);
JScript public function RotateZ(
angle : float
);

Parameters

angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when viewed from the rotation axis (positive side) toward the origin.

See Also

  • Matrix.RotateAxis
  • Matrix.Quaternion
  • Matrix.RotateX
  • Matrix.RotateY
  • Matrix.RotateYawPitchRoll


Matrix.RotationAxis(Vector3,Single) Method (Microsoft.DirectX)

Matrix.RotationAxis Method

Builds a matrix that rotates around an arbitrary axis.

Definition

Visual Basic Public Shared Function RotationAxis( _
ByVal axisRotation As Vector3, _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationAxis(
Vector3 axisRotation,
float angle
);
C++ public:
static Matrix RotationAxis(
Vector3 axisRotation,
float angle
);
JScript public static function RotationAxis(
axisRotation : Vector3,
angle : float
) : Matrix;

Parameters

axisRotation Microsoft.DirectX.Vector3
A Vector3 structure that identifies the axis about which to rotate the matrix.
angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Matrix
Rotated Matrix structure.

Remarks

The input rotation angle is in radians.

See Also

  • Matrix.RotationQuaternion
  • Matrix.RotationX
  • Matrix.RotationY
  • Matrix.RotationZ
  • Matrix.RotationYawPitchRoll


Matrix.RotationQuaternion(Quaternion) Method (Microsoft.DirectX)

Matrix.RotationQuaternion Method

Builds a matrix from a quaternion.

Definition

Visual Basic Public Shared Function RotationQuaternion( _
ByVal quat As Quaternion _
) As Matrix
C# public static Matrix RotationQuaternion(
Quaternion quat
);
C++ public:
static Matrix RotationQuaternion(
Quaternion quat
);
JScript public static function RotationQuaternion(
quat : Quaternion
) : Matrix;

Parameters

quat Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Matrix
Rotated Matrix structure.

Remarks

For information about how to calculate quaternion values from a direction vector (x, y, z) and an angle of rotation, see Quaternion.

See Also

  • Matrix.RotationAxis
  • Matrix.RotationX
  • Matrix.RotationY
  • Matrix.RotationZ
  • Matrix.RotationYawPitchRoll


Matrix.RotationX(Single) Method (Microsoft.DirectX)

Matrix.RotationX Method

Builds a matrix that rotates around the x-axis.

Definition

Visual Basic Public Shared Function RotationX( _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationX(
float angle
);
C++ public:
static Matrix RotationX(
float angle
);
JScript public static function RotationX(
angle : float
) : Matrix;

Parameters

angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Matrix
Rotated Matrix structure.

Remarks

The input rotation angle is in radians.

See Also

  • Matrix.RotationAxis
  • Matrix.RotationQuaternion
  • Matrix.RotationY
  • Matrix.RotationZ
  • Matrix.RotationYawPitchRoll


Matrix.RotationY(Single) Method (Microsoft.DirectX)

Matrix.RotationY Method

Builds a matrix that rotates around the y-axis.

Definition

Visual Basic Public Shared Function RotationY( _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationY(
float angle
);
C++ public:
static Matrix RotationY(
float angle
);
JScript public static function RotationY(
angle : float
) : Matrix;

Parameters

angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Matrix
Rotated Matrix structure.

See Also

  • Matrix.RotationAxis
  • Matrix.RotationQuaternion
  • Matrix.RotationX
  • Matrix.RotationZ
  • Matrix.RotationYawPitchRoll


Matrix.RotationYawPitchRoll(Single,Single,Single) Method (Microsoft.DirectX)

Matrix.RotationYawPitchRoll Method

Builds a matrix with a specified yaw, pitch, and roll.

Definition

Visual Basic Public Shared Function RotationYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
) As Matrix
C# public static Matrix RotationYawPitchRoll(
float yaw,
float pitch,
float roll
);
C++ public:
static Matrix RotationYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript public static function RotationYawPitchRoll(
yaw : float,
pitch : float,
roll : float
) : Matrix;

Parameters

yaw System.Single
Yaw around the y-axis, in radians.
pitch System.Single
Pitch around the x-axis, in radians.
roll System.Single
Roll around the z-axis, in radians.

Return Value

Microsoft.DirectX.Matrix
Rotated Matrix structure.

Remarks

The order of transformations is first roll, then pitch, then yaw. Relative to the object's local coordinate axis, this is equivalent to rotation around the z-axis, followed by rotation around the x-axis, followed by rotation around the y-axis.

Pitch Yaw Roll diagram

See Also

  • Matrix.RotationAxis
  • Matrix.RotationQuaternion
  • Matrix.RotationX
  • Matrix.RotationY
  • Matrix.RotationZ


Matrix.RotationZ(Single) Method (Microsoft.DirectX)

Matrix.RotationZ Method

Builds a matrix that rotates around the z-axis.

Definition

Visual Basic Public Shared Function RotationZ( _
ByVal angle As Single _
) As Matrix
C# public static Matrix RotationZ(
float angle
);
C++ public:
static Matrix RotationZ(
float angle
);
JScript public static function RotationZ(
angle : float
) : Matrix;

Parameters

angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when viewed from the rotation axis (positive side) toward the origin.

Return Value

Microsoft.DirectX.Matrix
Rotated Matrix structure.

See Also

  • Matrix.RotationAxis
  • Matrix.RotationQuaternion
  • Matrix.RotationX
  • Matrix.RotationY
  • Matrix.RotationYawPitchRoll


Matrix.Scale Method ()

Scales the matrix along the x-axis, y-axis, and z-axis.

Overload List

public void Scale(float, float, float);
public void Scale(Vector3);


Matrix.Scale(Vector3) Method (Microsoft.DirectX)

Matrix.Scale Method

Scales the matrix along the x-axis, y-axis, and z-axis.

Definition

Visual Basic Public Sub Scale( _
ByVal v As Vector3 _
)
C# public void Scale(
Vector3 v
);
C++ public:
void Scale(
Vector3 v
);
JScript public function Scale(
v : Vector3
);

Parameters

v Microsoft.DirectX.Vector3
A Vector3 structure containing three values that represent the scaling factors applied along the x-axis, y-axis, and z-axis.


Matrix.Scale(Single,Single,Single) Method (Microsoft.DirectX)

Matrix.Scale Method

Scales the matrix along the x-axis, y-axis, and z-axis.

Definition

Visual Basic Public Sub Scale( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void Scale(
float x,
float y,
float z
);
C++ public:
void Scale(
float x,
float y,
float z
);
JScript public function Scale(
x : float,
y : float,
z : float
);

Parameters

x System.Single
Scaling factor that is applied along the x-axis.
y System.Single
Scaling factor that is applied along the y-axis.
z System.Single
Scaling factor that is applied along the z-axis.


Matrix.Scaling Method ()

Builds a matrix that scales along the x-axis, y-axis, and z-axis.

Overload List

public static Matrix Scaling(float, float, float);
public static Matrix Scaling(Vector3);


Matrix.Scaling(Vector3) Method (Microsoft.DirectX)

Matrix.Scaling Method

Builds a matrix that scales along the x-axis, y-axis, and z-axis.

Definition

Visual Basic Public Shared Function Scaling( _
ByVal v As Vector3 _
) As Matrix
C# public static Matrix Scaling(
Vector3 v
);
C++ public:
static Matrix Scaling(
Vector3 v
);
JScript public static function Scaling(
v : Vector3
) : Matrix;

Parameters

v Microsoft.DirectX.Vector3
A Vector3 structure containing three values that represent the scaling factors applied along the x-axis, y-axis, and z-axis.

Return Value

Microsoft.DirectX.Matrix
Scaled Matrix structure.


Matrix.Scaling(Single,Single,Single) Method (Microsoft.DirectX)

Matrix.Scaling Method

Builds a matrix that scales along the x-axis, y-axis, and z-axis.

Definition

Visual Basic Public Shared Function Scaling( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
) As Matrix
C# public static Matrix Scaling(
float x,
float y,
float z
);
C++ public:
static Matrix Scaling(
float x,
float y,
float z
);
JScript public static function Scaling(
x : float,
y : float,
z : float
) : Matrix;

Parameters

x System.Single
Scaling factor that is applied along the x-axis.
y System.Single
Scaling factor that is applied along the y-axis.
z System.Single
Scaling factor that is applied along the z-axis.

Return Value

Microsoft.DirectX.Matrix
Scaled Matrix structure.


Matrix.Shadow(Vector4,Plane) Method (Microsoft.DirectX)

Matrix.Shadow Method

Builds a matrix that flattens geometry into a plane.

Definition

Visual Basic Public Sub Shadow( _
ByVal light As Vector4, _
ByVal plane As Plane _
)
C# public void Shadow(
Vector4 light,
Plane plane
);
C++ public:
void Shadow(
Vector4 light,
Plane plane
);
JScript public function Shadow(
light : Vector4,
plane : Plane
);

Parameters

light Microsoft.DirectX.Vector4
A Vector4 structure that describes the light's position.
plane Microsoft.DirectX.Plane
Source Plane structure.

Remarks

The Shadow method flattens geometry into a plane, as if it were casting a shadow from a light.

This method uses the following formula to compute the returned matrix.

P = normalize(Plane);
L = Light;
d = dot(P, L)

P.a * L.x + d  P.a * L.y      P.a * L.z      P.a * L.w
P.b * L.x      P.b * L.y + d  P.b * L.z      P.b * L.w
P.c * L.x      P.c * L.y      P.c * L.z + d  P.c * L.w
P.d * L.x      P.d * L.y      P.d * L.z      P.d * L.w + d
If the light's w-component is 0, the ray from the light's origin represents a directional light. If the w-component is 1, the light is a point light.


Matrix.Subtract(Matrix,Matrix) Method (Microsoft.DirectX)

Matrix.Subtract Method

Subtracts one matrix from another.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal left As Matrix, _
ByVal right As Matrix _
) As Matrix
C# public static Matrix Subtract(
Matrix left,
Matrix right
);
C++ public:
static Matrix Subtract(
Matrix left,
Matrix right
);
JScript public static function Subtract(
left : Matrix,
right : Matrix
) : Matrix;

Parameters

left Microsoft.DirectX.Matrix
A Matrix instance on the left side of the subtraction operation.
right Microsoft.DirectX.Matrix
A Matrix instance on the right side of the subtraction operation.

Return Value

Microsoft.DirectX.Matrix
A Matrix instance that represents the result of the subtraction.


Matrix.ToString() Method (Microsoft.DirectX)

Matrix.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Matrix.Transform(Vector3,Quaternion,Vector3,Vector3,Quaternion,Vector3) Method (Microsoft.DirectX)

Matrix.Transform Method

Transforms the matrix.

Definition

Visual Basic Public Sub Transform( _
ByVal scalingCenter As Vector3, _
ByVal scalingRotation As Quaternion, _
ByVal scalingFactor As Vector3, _
ByVal rotationCenter As Vector3, _
ByVal rotation As Quaternion, _
ByVal translation As Vector3 _
)
C# public void Transform(
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
C++ public:
void Transform(
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
JScript public function Transform(
scalingCenter : Vector3,
scalingRotation : Quaternion,
scalingFactor : Vector3,
rotationCenter : Vector3,
rotation : Quaternion,
translation : Vector3
);

Parameters

scalingCenter Microsoft.DirectX.Vector3
A Vector3 structure that identifies the scaling center point.
scalingRotation Microsoft.DirectX.Quaternion
A Quaternion structure that specifies the scaling rotation. Use Quaternion.Identity to specify no scaling.
scalingFactor Microsoft.DirectX.Vector3
A Vector3 structure that is the scaling vector.
rotationCenter Microsoft.DirectX.Vector3
A Vector3 structure that is a point that identifies the center of rotation.
rotation Microsoft.DirectX.Quaternion
A Quaternion structure that specifies the rotation. Use Quaternion.Identity to specify no rotation.
translation Microsoft.DirectX.Vector3
A Vector3 structure that represents the translation. Use Vector3.Empty to specify no translation.

Remarks

The Transform method calculates the transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = transformation matrix
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scalingFactor)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

For 3-D affine transformations, use AffineTransformation.

See Also

  • Transformation
  • AffineTransformation


Matrix.Transformation(Vector3,Quaternion,Vector3,Vector3,Quaternion,Vector3) Method (Microsoft.DirectX)

Matrix.Transformation Method

Builds a transformation matrix.

Definition

Visual Basic Public Shared Function Transformation( _
ByVal scalingCenter As Vector3, _
ByVal scalingRotation As Quaternion, _
ByVal scalingFactor As Vector3, _
ByVal rotationCenter As Vector3, _
ByVal rotation As Quaternion, _
ByVal translation As Vector3 _
) As Matrix
C# public static Matrix Transformation(
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
C++ public:
static Matrix Transformation(
Vector3 scalingCenter,
Quaternion scalingRotation,
Vector3 scalingFactor,
Vector3 rotationCenter,
Quaternion rotation,
Vector3 translation
);
JScript public static function Transformation(
scalingCenter : Vector3,
scalingRotation : Quaternion,
scalingFactor : Vector3,
rotationCenter : Vector3,
rotation : Quaternion,
translation : Vector3
) : Matrix;

Parameters

scalingCenter Microsoft.DirectX.Vector3
A Vector3 structure that identifies the scaling center point.
scalingRotation Microsoft.DirectX.Quaternion
A Quaternion structure that specifies the scaling rotation. Use Quaternion.Identity to specify no scaling.
scalingFactor Microsoft.DirectX.Vector3
A Vector3 structure that is the scaling vector.
rotationCenter Microsoft.DirectX.Vector3
A Vector3 structure that is a point identifying the center of rotation.
rotation Microsoft.DirectX.Quaternion
A Quaternion structure that specifies the rotation. Use Quaternion.Identity to specify no rotation.
translation Microsoft.DirectX.Vector3
A Vector3 structure that represents the translation. Use Vector3.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix
Resulting Matrix structure.

Remarks

The Transformation method calculates the transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order.

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = output transformation matrix (the return value)
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scalingFactor)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

For 3-D affine transformations, use AffineTransformation.

See Also

  • Transform
  • AffineTransformation
  • Transformation2D


Matrix.Transformation2D(Vector2,Single,Vector2,Vector2,Single,Vector2) Method (Microsoft.DirectX)

Matrix.Transformation2D Method

Builds a 2-D transformation matrix in the xy plane.

Definition

Visual Basic Public Shared Function Transformation2D( _
ByVal scalingCenter As Vector2, _
ByVal scalingRotation As Single, _
ByVal scaling As Vector2, _
ByVal rotationCenter As Vector2, _
ByVal rotation As Single, _
ByVal translation As Vector2 _
) As Matrix
C# public static Matrix Transformation2D(
Vector2 scalingCenter,
float scalingRotation,
Vector2 scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
C++ public:
static Matrix Transformation2D(
Vector2 scalingCenter,
float scalingRotation,
Vector2 scaling,
Vector2 rotationCenter,
float rotation,
Vector2 translation
);
JScript public static function Transformation2D(
scalingCenter : Vector2,
scalingRotation : float,
scaling : Vector2,
rotationCenter : Vector2,
rotation : float,
translation : Vector2
) : Matrix;

Parameters

scalingCenter Microsoft.DirectX.Vector2
A Vector2 structure that is a point identifying the scaling center.
scalingRotation System.Single
Scaling rotation factor. Use a zero value to specify no rotation.
scaling Microsoft.DirectX.Vector2
A Vector2 structure that is a point identifying the scale. Use Vector2.Empty to specify no scaling.
rotationCenter Microsoft.DirectX.Vector2
A Vector2 structure that is a point identifying the rotation center.
rotation System.Single
Angle of rotation, in radians.
translation Microsoft.DirectX.Vector2
A Vector2 structure that identifies the translation. Use Vector2.Empty to specify no translation.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that contains the transformation matrix.

Remarks

The Transformation2D method calculates the affine transformation matrix using the following formula, with matrix concatenation evaluated in left-to-right order:

M out = (Msc)-1 * (Msr)-1 * Ms * Msr * Msc * (Mrc)-1 * Mr * Mrc * Mt

where:

  • M out = output transformation matrix (the return value)
  • M sc = scaling center matrix (scalingCenter)
  • M sr = scaling rotation matrix (scalingRotation)
  • M s = scaling matrix (scaling)
  • M rc = center of rotation matrix (rotationCenter)
  • M r = rotation matrix (rotation)
  • M t = translation matrix (translation)

For 3-D transformations, use Transformation.


Matrix.Translate Method ()

Translates the matrix using specified offsets.

Overload List

public void Translate(float, float, float);
public void Translate(Vector3);


Matrix.Translate(Vector3) Method (Microsoft.DirectX)

Matrix.Translate Method

Translates the matrix using specified offsets.

Definition

Visual Basic Public Sub Translate( _
ByVal v As Vector3 _
)
C# public void Translate(
Vector3 v
);
C++ public:
void Translate(
Vector3 v
);
JScript public function Translate(
v : Vector3
);

Parameters

v Microsoft.DirectX.Vector3
A Vector3 structure that contains the x-coordinate, y-coordinate, and z-coordinate offsets.


Matrix.Translate(Single,Single,Single) Method (Microsoft.DirectX)

Matrix.Translate Method

Translates the matrix using specified offsets.

Definition

Visual Basic Public Sub Translate( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
)
C# public void Translate(
float x,
float y,
float z
);
C++ public:
void Translate(
float x,
float y,
float z
);
JScript public function Translate(
x : float,
y : float,
z : float
);

Parameters

x System.Single
X-coordinate offset.
y System.Single
Y-coordinate offset.
z System.Single
Z-coordinate offset.


Matrix.Translation Method ()

Builds a matrix using specified offsets.

Overload List

public static Matrix Translation(float, float, float);
public static Matrix Translation(Vector3);


Matrix.Translation(Vector3) Method (Microsoft.DirectX)

Matrix.Translation Method

Builds a matrix using specified offsets.

Definition

Visual Basic Public Shared Function Translation( _
ByVal v As Vector3 _
) As Matrix
C# public static Matrix Translation(
Vector3 v
);
C++ public:
static Matrix Translation(
Vector3 v
);
JScript public static function Translation(
v : Vector3
) : Matrix;

Parameters

v Microsoft.DirectX.Vector3
A Vector3 structure that contains the x-coordinate, y-coordinate, and z-coordinate offsets.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that contains a translated transformation matrix.


Matrix.Translation(Single,Single,Single) Method (Microsoft.DirectX)

Matrix.Translation Method

Builds a matrix using specified offsets.

Definition

Visual Basic Public Shared Function Translation( _
ByVal x As Single, _
ByVal y As Single, _
ByVal z As Single _
) As Matrix
C# public static Matrix Translation(
float x,
float y,
float z
);
C++ public:
static Matrix Translation(
float x,
float y,
float z
);
JScript public static function Translation(
x : float,
y : float,
z : float
) : Matrix;

Parameters

x System.Single
X-coordinate offset.
y System.Single
Y-coordinate offset.
z System.Single
Z-coordinate offset.

Return Value

Microsoft.DirectX.Matrix
A Matrix structure that contains a translated transformation matrix.


Matrix.Transpose(Matrix) Method (Microsoft.DirectX)

Matrix.Transpose Method

Transposes the matrix using a source matrix.

Definition

Visual Basic Public Sub Transpose( _
ByVal source As Matrix _
)
C# public void Transpose(
Matrix source
);
C++ public:
void Transpose(
Matrix source
);
JScript public function Transpose(
source : Matrix
);

Parameters

source Microsoft.DirectX.Matrix
Source Matrix structure.


Matrix.TransposeMatrix(Matrix) Method (Microsoft.DirectX)

Matrix.TransposeMatrix Method

Returns the matrix transpose of a given matrix.

Definition

Visual Basic Public Shared Function TransposeMatrix( _
ByVal source As Matrix _
) As Matrix
C# public static Matrix TransposeMatrix(
Matrix source
);
C++ public:
static Matrix TransposeMatrix(
Matrix source
);
JScript public static function TransposeMatrix(
source : Matrix
) : Matrix;

Parameters

source Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Matrix
A Matrix object that is the matrix transpose of the matrix.


Matrix.Determinant Property (Microsoft.DirectX)

Matrix.Determinant Property

Retrieves the determinant of the matrix.

Definition

Visual Basic | Public ReadOnly Property Determinant As Single
C# | public float Determinant { get; }
C++ public:
property float Determinant {
float get();
}
JScript | public function get Determinant() : float

Property Value

System.Single
A Single Leave Site value that indicates the determinant of the matrix.

This property is read-only.


Matrix.Identity Property (Microsoft.DirectX)

Matrix.Identity Property

Retrieves the identity of the matrix.

Definition

Visual Basic | Public Shared ReadOnly Property Identity As Matrix
C# | public static Matrix Identity { get; }
C++ public:
static property Matrix Identity {
Matrix get();
}
JScript | public static function get Identity() : Matrix

Property Value

Microsoft.DirectX.Matrix
A Matrix structure that represents the matrix identity.

This property is read-only.

Remarks

In an identity matrix, all coefficients are 0 except the [1,1][2,2][3,3][4,4] coefficients, which are set to 1. The identity matrix is special in that when it is applied to vertices, they are unchanged. The identity matrix is used as the starting point for matrices that modify vertex values to create rotations, translations, and any other transformations that can be represented by a 4x4 matrix.


Matrix.Zero Property (Microsoft.DirectX)

Matrix.Zero Property

Retrieves an empty matrix.

Definition

Visual Basic | Public Shared ReadOnly Property Zero As Matrix
C# | public static Matrix Zero { get; }
C++ public:
static property Matrix Zero {
Matrix get();
}
JScript | public static function get Zero() : Matrix

Property Value

Microsoft.DirectX.Matrix
Empty Matrix structure.

This property is read-only.


Matrix.M11 Field (Microsoft.DirectX)

Matrix.M11 Field

Retrieves or sets the element in the first row and the first column of the matrix.

Definition

Visual Basic | Public M11 As Single
C# | public Single M11;
C++ | public: Single M11;
JScript | public var M11 : Single

Field Value

System.Single
A Single Leave Site value that represents the first row and the first column of the matrix.

This field is read/write.


Matrix.M12 Field (Microsoft.DirectX)

Matrix.M12 Field

Retrieves or sets the element in the first row and the second column of the matrix.

Definition

Visual Basic | Public M12 As Single
C# | public Single M12;
C++ | public: Single M12;
JScript | public var M12 : Single

Field Value

System.Single
A Single Leave Site value that represents the first row and the second column of the matrix.

This field is read/write.


Matrix.M13 Field (Microsoft.DirectX)

Matrix.M13 Field

Retrieves or sets the element in the first row and the third column of the matrix.

Definition

Visual Basic | Public M13 As Single
C# | public Single M13;
C++ | public: Single M13;
JScript | public var M13 : Single

Field Value

System.Single
A Single Leave Site value that represents the first row and the third column of the matrix.

This field is read/write.


Matrix.M14 Field (Microsoft.DirectX)

Matrix.M14 Field

Retrieves or sets the element in the first row and the fourth column of the matrix.

Definition

Visual Basic | Public M14 As Single
C# | public Single M14;
C++ | public: Single M14;
JScript | public var M14 : Single

Field Value

System.Single
A Single Leave Site value that represents the first row and the fourth column of the matrix.

This field is read/write.


Matrix.M21 Field (Microsoft.DirectX)

Matrix.M21 Field

Retrieves or sets the element in the second row and the first column of the matrix.

Definition

Visual Basic | Public M21 As Single
C# | public Single M21;
C++ | public: Single M21;
JScript | public var M21 : Single

Field Value

System.Single
A Single Leave Site value that represents the second row and the first column of the matrix.

This field is read/write.


Matrix.M22 Field (Microsoft.DirectX)

Matrix.M22 Field

Retrieves or sets the element in the second row and the second column of the matrix.

Definition

Visual Basic | Public M22 As Single
C# | public Single M22;
C++ | public: Single M22;
JScript | public var M22 : Single

Field Value

System.Single
A Single Leave Site value that represents the second row and the second column of the matrix.

This field is read/write.


Matrix.M23 Field (Microsoft.DirectX)

Matrix.M23 Field

Retrieves or sets the element in the second row and the third column of the matrix.

Definition

Visual Basic | Public M23 As Single
C# | public Single M23;
C++ | public: Single M23;
JScript | public var M23 : Single

Field Value

System.Single
A Single Leave Site value that represents the second row and the third column of the matrix.

This field is read/write.


Matrix.M24 Field (Microsoft.DirectX)

Matrix.M24 Field

Retrieves or sets the element in the second row and the fourth column of the matrix.

Definition

Visual Basic | Public M24 As Single
C# | public Single M24;
C++ | public: Single M24;
JScript | public var M24 : Single

Field Value

System.Single
A Single Leave Site value that represents the second row and the fourth column of the matrix.

This field is read/write.


Matrix.M31 Field (Microsoft.DirectX)

Matrix.M31 Field

Retrieves or sets the element in the third row and the first column of the matrix.

Definition

Visual Basic | Public M31 As Single
C# | public Single M31;
C++ | public: Single M31;
JScript | public var M31 : Single

Field Value

System.Single
A Single Leave Site value that represents the third row and the first column of the matrix.

This field is read/write.


Matrix.M32 Field (Microsoft.DirectX)

Matrix.M32 Field

Retrieves or sets the element in the third row and the second column of the matrix.

Definition

Visual Basic | Public M32 As Single
C# | public Single M32;
C++ | public: Single M32;
JScript | public var M32 : Single

Field Value

System.Single
A Single Leave Site value that represents the third row and the second column of the matrix.

This field is read/write.


Matrix.M33 Field (Microsoft.DirectX)

Matrix.M33 Field

Retrieves or sets the element in the third row and the third column of the matrix.

Definition

Visual Basic | Public M33 As Single
C# | public Single M33;
C++ | public: Single M33;
JScript | public var M33 : Single

Field Value

System.Single
A Single Leave Site value that represents the third row and the third column of the matrix.

This field is read/write.


Matrix.M34 Field (Microsoft.DirectX)

Matrix.M34 Field

Retrieves or sets the element in the third row and the fourth column of the matrix.

Definition

Visual Basic | Public M34 As Single
C# | public Single M34;
C++ | public: Single M34;
JScript | public var M34 : Single

Field Value

System.Single
A Single Leave Site value that represents the third row and the fourth column of the matrix.

This field is read/write.

Remarks

In Microsoft Direct3D, the M34 element of a projection matrix cannot be a negative number. If an application needs to use a negative value in this location, it should scale the entire projection matrix by -1 instead.


Matrix.M41 Field (Microsoft.DirectX)

Matrix.M41 Field

Retrieves or sets the element in the fourth row and the first column of the matrix.

Definition

Visual Basic | Public M41 As Single
C# | public Single M41;
C++ | public: Single M41;
JScript | public var M41 : Single

Field Value

System.Single
A Single Leave Site value that represents the fourth row and the first column of the matrix.

This field is read/write.


Matrix.M42 Field (Microsoft.DirectX)

Matrix.M42 Field

Retrieves or sets the element in the fourth row and the second column of the matrix.

Definition

Visual Basic | Public M42 As Single
C# | public Single M42;
C++ | public: Single M42;
JScript | public var M42 : Single

Field Value

System.Single
A Single Leave Site value that represents the fourth row and the second column of the matrix.

This field is read/write.


Matrix.M43 Field (Microsoft.DirectX)

Matrix.M43 Field

Retrieves or sets the element in the fourth row and the third column of the matrix.

Definition

Visual Basic | Public M43 As Single
C# | public Single M43;
C++ | public: Single M43;
JScript | public var M43 : Single

Field Value

System.Single
A Single Leave Site value that represents the fourth row and the third column of the matrix.

This field is read/write.


Matrix.M44 Field (Microsoft.DirectX)

Matrix.M44 Field

Retrieves or sets the element in the fourth row and the fourth column of the matrix.

Definition

Visual Basic | Public M44 As Single
C# | public Single M44;
C++ | public: Single M44;
JScript | public var M44 : Single

Field Value

System.Single
A Single Leave Site value that represents the fourth row and the fourth column of the matrix.

This field is read/write.


Plane Structure (Microsoft.DirectX)

Plane Structure

Describes and manipulates a plane.

Definition

Visual Basic | Public Structure Plane
C# | public struct Plane
C++ | public value class Plane sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
A | Retrieves or sets the 'A' coefficient of the clipping plane in the general plane equation.
B | Retrieves or sets the 'B' coefficient of the clipping plane in the general plane equation.
C | Retrieves or sets the 'C' coefficient of the clipping plane in the general plane equation.
D | Retrieves or sets the 'D' coefficient of the clipping plane in the general plane equation.

Methods

Method | Description
Dot | Computes the dot product of a plane and a vector.
static (Shared in Visual Basic) DotNormal | Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 0.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
static (Shared in Visual Basic) FromPointNormal | Constructs a plane from a point and a normal.
static (Shared in Visual Basic) FromPoints | Constructs a plane from three points.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic) IntersectLine | Finds the intersection between a plane and a line.
Normalize | Returns the normal of a plane.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Plane | Initializes a new instance of the Plane class.
Scale | Scales the plane with a given scaling factor.
ToString | Obtains a string representation of the current instance.
Transform | Transforms a plane by a matrix.

Properties

Property | Description
static (Shared in Visual Basic) Empty | Retrieves an empty plane.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that ax + by + cz + dw = 0.

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Plane Class


Plane.Dot Method ()

Computes the dot product of a plane and a vector.

Overload List

public float Dot(Vector3);
public float Dot(Vector4);

Remarks

Given a plane (a, b, c, d) and a 4-D vector (x, y, z, w), this method's return value is a*x + b*y + c*z + d*w. The Dot method is useful for determining the plane's relationship with a homogeneous coordinate. For example, it can determine whether a coordinate is on a particular plane, or on which side of a particular plane a coordinate lies.

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*1. The Dot method is useful for determining the plane's relationship with a coordinate in 3-D space.

See Also

  • DotNormal


Plane.Dot(Vector3) Method (Microsoft.DirectX)

Plane.Dot Method

Computes the dot product of a plane and a vector.

Definition

Visual Basic Public Function Dot( _
ByVal v As Vector3 _
) As Single
C# public float Dot(
Vector3 v
);
C++ public:
float Dot(
Vector3 v
);
JScript public function Dot(
v : Vector3
) : float;

Parameters

v Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that is the dot product of the plane and the vector.

Remarks

Given a plane (a, b, c, d) and a 4-D vector (x, y, z, w), this method's return value is a*x + b*y + c*z + d*w. The Dot method is useful for determining the plane's relationship with a homogeneous coordinate. For example, it can determine whether a coordinate is on a particular plane, or on which side of a particular plane a coordinate lies.

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*1. The Dot method is useful for determining the plane's relationship with a coordinate in 3-D space.

See Also

  • DotNormal


Plane.Dot(Vector4) Method (Microsoft.DirectX)

Plane.Dot Method

Computes the dot product of a plane and a vector.

Definition

Visual Basic Public Function Dot( _
ByVal v As Vector4 _
) As Single
C# public float Dot(
Vector4 v
);
C++ public:
float Dot(
Vector4 v
);
JScript public function Dot(
v : Vector4
) : float;

Parameters

v Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

System.Single
A Single Leave Site value that is the dot product of the plane and the vector.

Remarks

Given a plane (a, b, c, d) and a 4-D vector (x, y, z, w), this method's return value is a*x + b*y + c*z + d*w. The Dot method is useful for determining the plane's relationship with a homogeneous coordinate. For example, it can determine whether a coordinate is on a particular plane, or on which side of a particular plane a coordinate lies.

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*1. The Dot method is useful for determining the plane's relationship with a coordinate in 3-D space.

See Also

  • DotNormal


Plane.DotNormal(Plane,Vector3) Method (Microsoft.DirectX)

Plane.DotNormal Method

Computes the dot product of a plane and a 3-D vector. The w parameter of the vector is assumed to be 0.

Definition

Visual Basic Public Shared Function DotNormal( _
ByVal p As Plane, _
ByVal v As Vector3 _
) As Single
C# public static float DotNormal(
Plane p,
Vector3 v
);
C++ public:
static float DotNormal(
Plane p,
Vector3 v
);
JScript public static function DotNormal(
p : Plane,
v : Vector3
) : float;

Parameters

p Microsoft.DirectX.Plane
Source Plane structure.
v Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that represents the dot product of the plane and the 3-D vector.

Remarks

Given a plane (a, b, c, d) and a 3-D vector (x, y, z), this method's return value is a*x + b*y + c*z + d*0. The DotNormal method is useful for calculating the angle between the normal of the plane and another normal.


Plane.Equals(Object) Method (Microsoft.DirectX)

Plane.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the current instance is equal to the specified object, or false if it is not.


Plane.FromPointNormal(Vector3,Vector3) Method (Microsoft.DirectX)

Plane.FromPointNormal Method

Constructs a plane from a point and a normal.

Definition

Visual Basic Public Shared Function FromPointNormal( _
ByVal point As Vector3, _
ByVal normal As Vector3 _
) As Plane
C# public static Plane FromPointNormal(
Vector3 point,
Vector3 normal
);
C++ public:
static Plane FromPointNormal(
Vector3 point,
Vector3 normal
);
JScript public static function FromPointNormal(
point : Vector3,
normal : Vector3
) : Plane;

Parameters

point Microsoft.DirectX.Vector3
A Vector3 structure that defines the point used to construct the plane.
normal Microsoft.DirectX.Vector3
A Vector3 structure that defines the normal used to construct the plane.

Return Value

Microsoft.DirectX.Plane
A Plane structure constructed from the point and the normal.

See Also

  • Plane


Plane.FromPoints(Vector3,Vector3,Vector3) Method (Microsoft.DirectX)

Plane.FromPoints Method

Constructs a plane from three points.

Definition

Visual Basic Public Shared Function FromPoints( _
ByVal p1 As Vector3, _
ByVal p2 As Vector3, _
ByVal p3 As Vector3 _
) As Plane
C# public static Plane FromPoints(
Vector3 p1,
Vector3 p2,
Vector3 p3
);
C++ public:
static Plane FromPoints(
Vector3 p1,
Vector3 p2,
Vector3 p3
);
JScript public static function FromPoints(
p1 : Vector3,
p2 : Vector3,
p3 : Vector3
) : Plane;

Parameters

p1 Microsoft.DirectX.Vector3
A Vector3 structure that defines one of the points used to construct the plane.
p2 Microsoft.DirectX.Vector3
A Vector3 structure that defines one of the points used to construct the plane.
p3 Microsoft.DirectX.Vector3
A Vector3 structure that defines one of the points used to construct the plane.

Return Value

Microsoft.DirectX.Plane
A Plane structure constructed from the given points.

See Also

  • FromPointNormal


Plane.GetHashCode() Method (Microsoft.DirectX)

Plane.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Plane.IntersectLine(Plane,Vector3,Vector3) Method (Microsoft.DirectX)

Plane.IntersectLine Method

Finds the intersection between a plane and a line.

Definition

Visual Basic Public Shared Function IntersectLine( _
ByVal p As Plane, _
ByVal v1 As Vector3, _
ByVal v2 As Vector3 _
) As Vector3
C# public static Vector3 IntersectLine(
Plane p,
Vector3 v1,
Vector3 v2
);
C++ public:
static Vector3 IntersectLine(
Plane p,
Vector3 v1,
Vector3 v2
);
JScript public static function IntersectLine(
p : Plane,
v1 : Vector3,
v2 : Vector3
) : Vector3;

Parameters

p Microsoft.DirectX.Plane
Source Plane structure.
v1 Microsoft.DirectX.Vector3
Source Vector3 structure that defines a line starting point.
v2 Microsoft.DirectX.Vector3
Source Vector3 structure that defines a line ending point.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the intersection between the specified plane and line.

Remarks

If the line is parallel to the plane, a Vector3 structure set to (0, 0, 0) is returned.


Plane.Normalize Method ()

Returns the normal of a plane.

Overload List

public void Normalize();
public static Plane Normalize(Plane);

Remarks

This method normalizes a plane so that |a, b, c| == 1.


Plane.Normalize() Method (Microsoft.DirectX)

Plane.Normalize Method

Returns the normal of a plane.

Definition

Visual Basic | Public Sub Normalize()
C# | public void Normalize();
C++ public:
void Normalize();
JScript | public function Normalize();

Remarks

This method normalizes a plane so that |a, b, c| == 1.


Plane.Normalize(Plane) Method (Microsoft.DirectX)

Plane.Normalize Method

Returns the normal of a plane.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal p As Plane _
) As Plane
C# public static Plane Normalize(
Plane p
);
C++ public:
static Plane Normalize(
Plane p
);
JScript public static function Normalize(
p : Plane
) : Plane;

Parameters

p Microsoft.DirectX.Plane
Source Plane structure.

Return Value

Microsoft.DirectX.Plane
A Plane structure that represents the normal of the plane.

Remarks

This method normalizes a plane so that |a, b, c| == 1.


Plane.op_Equality(Plane,Plane) Method (Microsoft.DirectX)

Plane.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Plane, _
ByVal right As Plane _
) As Boolean
C# public static bool op_Equality(
Plane left,
Plane right
);
C++ public:
static bool operator==(
Plane left,
Plane right
);
JScript public static function op_Equality(
left : Plane,
right : Plane
) : boolean;

Parameters

left Microsoft.DirectX.Plane
The Plane structure to the left of the equality operator.
right Microsoft.DirectX.Plane
The Plane structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Plane.op_Inequality(Plane,Plane) Method (Microsoft.DirectX)

Plane.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Plane, _
ByVal right As Plane _
) As Boolean
C# public static bool op_Inequality(
Plane left,
Plane right
);
C++ public:
static bool operator!=(
Plane left,
Plane right
);
JScript public static function op_Inequality(
left : Plane,
right : Plane
) : boolean;

Parameters

left Microsoft.DirectX.Plane
The Plane structure to the left of the inequality operator.
right Microsoft.DirectX.Plane
The Plane structure to the right of the inequality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Plane.Plane Constructor ()

Initializes a new instance of the Plane class.

Overload List

public Plane();
public Plane(float, float, float, float);


Plane.Plane() Constructor (Microsoft.DirectX)

Plane.Plane Constructor

Initializes a new instance of the Plane class.

Definition

Visual Basic | Public Sub New()
C# | public Plane();
C++ public:
Plane();
JScript | public function Plane();


Plane.Plane(Single,Single,Single,Single) Constructor (Microsoft.DirectX)

Plane.Plane Constructor

Initializes a new instance of the Plane class.

Definition

Visual Basic Public Sub New( _
ByVal valuePointA As Single, _
ByVal valuePointB As Single, _
ByVal valuePointC As Single, _
ByVal valuePointD As Single _
)
C# public Plane(
float valuePointA,
float valuePointB,
float valuePointC,
float valuePointD
);
C++ public:
Plane(
float valuePointA,
float valuePointB,
float valuePointC,
float valuePointD
);
JScript public function Plane(
valuePointA : float,
valuePointB : float,
valuePointC : float,
valuePointD : float
);

Parameters

valuePointA System.Single
A Single Leave Site value used to set the initial value of the A field.
valuePointB System.Single
A Single Leave Site value used to set the initial value of the B field.
valuePointC System.Single
A Single Leave Site value used to set the initial value of the C field.
valuePointD System.Single
A Single Leave Site value used to set the initial value of the D field.


Plane.Scale Method ()

Scales the plane with a given scaling factor.

Overload List

public static Plane Scale(Plane, float);
public void Scale(float);


Plane.Scale(Single) Method (Microsoft.DirectX)

Plane.Scale Method

Scales the plane with a given scaling factor.

Definition

Visual Basic Public Sub Scale( _
ByVal s As Single _
)
C# public void Scale(
float s
);
C++ public:
void Scale(
float s
);
JScript public function Scale(
s : float
);

Parameters

s System.Single
Scale factor.


Plane.Scale(Plane,Single) Method (Microsoft.DirectX)

Plane.Scale Method

Scales the plane with a given scaling factor.

Definition

Visual Basic Public Shared Function Scale( _
ByVal p As Plane, _
ByVal s As Single _
) As Plane
C# public static Plane Scale(
Plane p,
float s
);
C++ public:
static Plane Scale(
Plane p,
float s
);
JScript public static function Scale(
p : Plane,
s : float
) : Plane;

Parameters

p Microsoft.DirectX.Plane
Pointer to the source Plane structure.
s System.Single
Scale factor.

Return Value

Microsoft.DirectX.Plane
The Plane structure that represents the scaled plane.


Plane.ToString() Method (Microsoft.DirectX)

Plane.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Plane.Transform Method ()

Transforms a plane by a matrix.

Overload List

public void Transform(Matrix);
public static Plane Transform(Plane, Matrix);

Remarks

The input matrix is the inverse transpose of the actual transformation.

Examples

This C# code example transforms a plane by applying a non-uniform scale.
[C#]
Plane   planeNew;
Plane plane = new Plane(0, 1, 1, 0);
plane = Plane.Normalize(plane);

Matrix  matrix;
matrix = Matrix.Scaling(1.0f, 2.0f, 3.0f);
matrix = Matrix.Invert(matrix);
matrix.Transpose(matrix);
planeNew = Plane.Transform(plane, matrix);
 A plane is described by ax + by + cz + dw = 0. The first plane is created with (a, b, c, d) = (0, 1, 1, 0), which is a plane described by y + z = 0. After scaling, the new plane contains (a, b, c, d) = (0, 0.353f, 0.235f, 0), which shows the new plane to be described by 0.353y + 0.235z = 0.

The parameter m contains the inverse transpose of the transformation matrix. The inverse transpose is required by this method so that the normal vector of the transformed plane can be correctly transformed as well.

See Also

  • Normalize


Plane.Transform(Matrix) Method (Microsoft.DirectX)

Plane.Transform Method

Transforms a plane by a matrix.

Definition

Visual Basic Public Sub Transform( _
ByVal m As Matrix _
)
C# public void Transform(
Matrix m
);
C++ public:
void Transform(
Matrix m
);
JScript public function Transform(
m : Matrix
);

Parameters

m Microsoft.DirectX.Matrix
Source Matrix structure, which contains the transformation values. This matrix must contain the inverse transpose of the transformation values.

Remarks

The input matrix is the inverse transpose of the actual transformation.

Examples

This C# code example transforms a plane by applying a non-uniform scale.
[C#]
Plane   planeNew;
Plane plane = new Plane(0, 1, 1, 0);
plane = Plane.Normalize(plane);

Matrix  matrix;
matrix = Matrix.Scaling(1.0f, 2.0f, 3.0f);
matrix = Matrix.Invert(matrix);
matrix.Transpose(matrix);
planeNew = Plane.Transform(plane, matrix);
 A plane is described by ax + by + cz + dw = 0. The first plane is created with (a, b, c, d) = (0, 1, 1, 0), which is a plane described by y + z = 0. After scaling, the new plane contains (a, b, c, d) = (0, 0.353f, 0.235f, 0), which shows the new plane to be described by 0.353y + 0.235z = 0.

The parameter m contains the inverse transpose of the transformation matrix. The inverse transpose is required by this method so that the normal vector of the transformed plane can be correctly transformed as well.

See Also

  • Normalize


Plane.Transform(Plane,Matrix) Method (Microsoft.DirectX)

Plane.Transform Method

Transforms a plane by a matrix.

Definition

Visual Basic Public Shared Function Transform( _
ByVal p As Plane, _
ByVal m As Matrix _
) As Plane
C# public static Plane Transform(
Plane p,
Matrix m
);
C++ public:
static Plane Transform(
Plane p,
Matrix m
);
JScript public static function Transform(
p : Plane,
m : Matrix
) : Plane;

Parameters

p Microsoft.DirectX.Plane
Input Plane structure, which contains the plane to be transformed. The vector (a,b,c) that describes the plane must be normalized before this method is called.
m Microsoft.DirectX.Matrix
Source Matrix structure, which contains the transformation values. This matrix must contain the inverse transpose of the transformation values.

Return Value

Microsoft.DirectX.Plane
A Plane structure that represents the transformed plane.

Remarks

The input matrix is the inverse transpose of the actual transformation.

Examples

This C# code example transforms a plane by applying a non-uniform scale.
[C#]
Plane   planeNew;
Plane plane = new Plane(0, 1, 1, 0);
plane = Plane.Normalize(plane);

Matrix  matrix;
matrix = Matrix.Scaling(1.0f, 2.0f, 3.0f);
matrix = Matrix.Invert(matrix);
matrix.Transpose(matrix);
planeNew = Plane.Transform(plane, matrix);
 A plane is described by ax + by + cz + dw = 0. The first plane is created with (a, b, c, d) = (0, 1, 1, 0), which is a plane described by y + z = 0. After scaling, the new plane contains (a, b, c, d) = (0, 0.353f, 0.235f, 0), which shows the new plane to be described by 0.353y + 0.235z = 0.

The parameter m contains the inverse transpose of the transformation matrix. The inverse transpose is required by this method so that the normal vector of the transformed plane can be correctly transformed as well.

See Also

  • Normalize


Plane.Empty Property (Microsoft.DirectX)

Plane.Empty Property

Retrieves an empty plane.

Definition

Visual Basic | Public Shared ReadOnly Property Empty As Plane
C# | public static Plane Empty { get; }
C++ public:
static property Plane Empty {
Plane get();
}
JScript | public static function get Empty() : Plane

Property Value

Microsoft.DirectX.Plane
Empty Plane structure.

This property is read-only.


Plane.A Field (Microsoft.DirectX)

Plane.A Field

Retrieves or sets the 'A' coefficient of the clipping plane in the general plane equation.

Definition

Visual Basic | Public A As Single
C# | public Single A;
C++ | public: Single A;
JScript | public var A : Single

Field Value

System.Single
A Single Leave Site value that represents the 'A' coefficient of the clipping plane in the general plane equation.

This field is read/write.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that Ax + By + Cz + Dw = 0.


Plane.B Field (Microsoft.DirectX)

Plane.B Field

Retrieves or sets the 'B' coefficient of the clipping plane in the general plane equation.

Definition

Visual Basic | Public B As Single
C# | public Single B;
C++ | public: Single B;
JScript | public var B : Single

Field Value

System.Single
A Single Leave Site value that represents the 'B' coefficient of the clipping plane in the general plane equation.

This field is read/write.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that Ax + By + Cz + Dw = 0.


Plane.C Field (Microsoft.DirectX)

Plane.C Field

Retrieves or sets the 'C' coefficient of the clipping plane in the general plane equation.

Definition

Visual Basic | Public C As Single
C# | public Single C;
C++ | public: Single C;
JScript | public var C : Single

Field Value

System.Single
A Single Leave Site value that represents the 'C' coefficient of the clipping plane in the general plane equation.

This field is read/write.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that Ax + By + Cz + Dw = 0.


Plane.D Field (Microsoft.DirectX)

Plane.D Field

Retrieves or sets the 'D' coefficient of the clipping plane in the general plane equation.

Definition

Visual Basic | Public D As Single
C# | public Single D;
C++ | public: Single D;
JScript | public var D : Single

Field Value

System.Single
A Single Leave Site value that represents the 'D' coefficient of the clipping plane in the general plane equation.

This field is read/write.

Remarks

The members of the Plane structure take the form of the general plane equation. They fit into the general plane equation so that Ax + By + Cz + Dw = 0.


Quaternion Structure (Microsoft.DirectX)

Quaternion Structure

Describes a quaternion.

Definition

Visual Basic | Public Structure Quaternion
C# | public struct Quaternion
C++ | public value class Quaternion sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
W | Retrieves or sets the w component of the quaternion.
X | Retrieves or sets the x component of the quaternion.
Y | Retrieves or sets the y component of the quaternion.
Z | Retrieves or sets the z component of the quaternion.

Methods

Method | Description
static (Shared in Visual Basic) Add | Adds two quaternions.
static (Shared in Visual Basic) BaryCentric | Returns a quaternion in barycentric coordinates.
static (Shared in Visual Basic) Conjugate | Returns the conjugate of a quaternion.
static (Shared in Visual Basic) Dot | Returns the dot product of two quaternions.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
Exp | Calculates the exponential.
GetHashCode | Returns the hash code for the current instance.
Invert | Conjugates and re-normalizes a quaternion.
Length | Returns the length of a quaternion.
LengthSq | Returns the square of a quaternion's length.
Ln | Calculates the natural logarithm.
Multiply | Multiplies two quaternions.
Normalize | Returns the normal of a quaternion.
static (Shared in Visual Basic) op_Addition | Adds two quaternions.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Multiply | Determines the product of two quaternions.
static (Shared in Visual Basic) op_Subtraction | Subtracts two quaternions.
Quaternion | Initializes a new instance of the Quaternion class.
RotateAxis | Rotates a quaternion around an arbitrary axis.
RotateMatrix | Builds a quaternion from a rotation matrix.
RotateYawPitchRoll | Builds a quaternion with the given yaw, pitch, and roll.
static (Shared in Visual Basic) RotationAxis | Builds a quaternion that is rotated around an arbitrary axis.
static (Shared in Visual Basic) RotationMatrix | Builds a quaternion from a rotation matrix.
static (Shared in Visual Basic) RotationYawPitchRoll | Builds a quaternion with the given yaw, pitch, and roll.
static (Shared in Visual Basic) Slerp | Interpolates between two quaternions, using spherical linear interpolation.
static (Shared in Visual Basic) Squad | Interpolates between quaternions, using spherical quadrangle interpolation.
static (Shared in Visual Basic) SquadSetup | Sets up control points for spherical quadrangle interpolation.
static (Shared in Visual Basic) Subtract | Subtracts two quaternion instances.
static (Shared in Visual Basic) ToAxisAngle | Computes a quaternion's axis and angle of rotation.
ToString | Obtains a string representation of the current instance.

Properties

Property | Description
static (Shared in Visual Basic) Identity | Retrieves the identity quaternion.
static (Shared in Visual Basic) Zero | Retrieves an empty quaternion.

Remarks

Quaternions add a fourth element to the [ x, y, z] values that define a vector, resulting in arbitrary 4-D vectors. However, the following example illustrates how each element of a unit quaternion relates to an axis-angle rotation, where q represents a unit quaternion (x, y, z, w), axis is normalized, and theta is the desired counterclockwise (CCW) rotation around the axis.

q.x = sin(theta/2) * axis.x

q.y = sin(theta/2) * axis.y

q.z = sin(theta/2) * axis.z

q.w = cos(theta/2)

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Vectors, Vertices, and Quaternions
  • Microsoft.DirectX.UnsafeNativeMethods.Quaternion Class


Quaternion.Add(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.Add Method

Adds two quaternions.

Definition

Visual Basic Public Shared Function Add( _
ByVal m1 As Quaternion, _
ByVal m2 As Quaternion _
) As Quaternion
C# public static Quaternion Add(
Quaternion m1,
Quaternion m2
);
C++ public:
static Quaternion Add(
Quaternion m1,
Quaternion m2
);
JScript public static function Add(
m1 : Quaternion,
m2 : Quaternion
) : Quaternion;

Parameters

m1 Microsoft.DirectX.Quaternion
Source Quaternion.
m2 Microsoft.DirectX.Quaternion
Source Quaternion.

Return Value

Microsoft.DirectX.Quaternion
Sum of the two source Quaternion structures.


Quaternion.BaryCentric(Quaternion,Quaternion,Quaternion,Single,Single) Method (Microsoft.DirectX)

Quaternion.BaryCentric Method

Returns a quaternion in barycentric coordinates.

Definition

Visual Basic Public Shared Function BaryCentric( _
ByVal q1 As Quaternion, _
ByVal q2 As Quaternion, _
ByVal q3 As Quaternion, _
ByVal f As Single, _
ByVal g As Single _
) As Quaternion
C# public static Quaternion BaryCentric(
Quaternion q1,
Quaternion q2,
Quaternion q3,
float f,
float g
);
C++ public:
static Quaternion BaryCentric(
Quaternion q1,
Quaternion q2,
Quaternion q3,
float f,
float g
);
JScript public static function BaryCentric(
q1 : Quaternion,
q2 : Quaternion,
q3 : Quaternion,
f : float,
g : float
) : Quaternion;

Parameters

q1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
q2 Microsoft.DirectX.Quaternion
Source Quaternion structure.
q3 Microsoft.DirectX.Quaternion
Source Quaternion structure.
f System.Single
Weighting factor. See Remarks.
g System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Quaternion
Resulting Quaternion structure in barycentric coordinates.

Remarks

To compute the barycentric coordinates, the BaryCentric method implements the following series of spherical linear interpolation operations.

Slerp(Slerp(q1, q2, f + g))

Slerp(q1, q3, f + g)

g/(f + g)

See Also

  • Quaternion.Slerp


Quaternion.Conjugate(Quaternion) Method (Microsoft.DirectX)

Quaternion.Conjugate Method

Returns the conjugate of a quaternion.

Definition

Visual Basic Public Shared Function Conjugate( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Conjugate(
Quaternion q
);
C++ public:
static Quaternion Conjugate(
Quaternion q
);
JScript public static function Conjugate(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion
Source Quaternion.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the conjugate of the q parameter.

Remarks

Given a quaternion (x, y, z, w), the Conjugate method returns the quaternion (-x, -y, -z, w).

See Also

  • Invert


Quaternion.Dot(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.Dot Method

Returns the dot product of two quaternions.

Definition

Visual Basic Public Shared Function Dot( _
ByVal v1 As Quaternion, _
ByVal v2 As Quaternion _
) As Single
C# public static float Dot(
Quaternion v1,
Quaternion v2
);
C++ public:
static float Dot(
Quaternion v1,
Quaternion v2
);
JScript public static function Dot(
v1 : Quaternion,
v2 : Quaternion
) : float;

Parameters

v1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
v2 Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

System.Single
Dot product of two quaternions.


Quaternion.Equals(Object) Method (Microsoft.DirectX)

Quaternion.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the instance is equal to the specified object, or false if it is not.


Quaternion.Exp Method ()

Calculates the exponential.

Overload List

public void Exp();
public static Quaternion Exp(Quaternion);

Remarks

The Exp method converts a pure quaternion to a unit quaternion. The method expects a pure quaternion, where w is ignored in the calculation (w == 0). In the following example, v represents the vector portion of a quaternion.

Given a pure quaternion defined by:
q = (0, theta * v);

This method calculates the exponential result.
exp(Q) = (cos(theta), sin(theta) * v)

The SquadSetup method also can be used to set up the control points of a quaternion.


Quaternion.Exp() Method (Microsoft.DirectX)

Quaternion.Exp Method

Calculates the exponential.

Definition

Visual Basic | Public Sub Exp()
C# | public void Exp();
C++ public:
void Exp();
JScript | public function Exp();

Remarks

The Exp method converts a pure quaternion to a unit quaternion. The method expects a pure quaternion, where w is ignored in the calculation (w == 0). In the following example, v represents the vector portion of a quaternion.

Given a pure quaternion defined by:
q = (0, theta * v);

This method calculates the exponential result.
exp(Q) = (cos(theta), sin(theta) * v)

The SquadSetup method also can be used to set up the control points of a quaternion.


Quaternion.Exp(Quaternion) Method (Microsoft.DirectX)

Quaternion.Exp Method

Calculates the exponential.

Definition

Visual Basic Public Shared Function Exp( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Exp(
Quaternion q
);
C++ public:
static Quaternion Exp(
Quaternion q
);
JScript public static function Exp(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
The Quaternion structure that is the exponential of the q parameter.

Remarks

The Exp method converts a pure quaternion to a unit quaternion. The method expects a pure quaternion, where w is ignored in the calculation (w == 0). In the following example, v represents the vector portion of a quaternion.

Given a pure quaternion defined by:
q = (0, theta * v);

This method calculates the exponential result.
exp(Q) = (cos(theta), sin(theta) * v)

The SquadSetup method also can be used to set up the control points of a quaternion.


Quaternion.GetHashCode() Method (Microsoft.DirectX)

Quaternion.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Quaternion.Invert Method ()

Conjugates and re-normalizes a quaternion.

Overload List

public void Invert();
public static Quaternion Invert(Quaternion);

Remarks

A unit quaternion is defined by the following equation.

q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of q is ln(q) = (0, theta * v)

See Also

  • Quaternion.Conjugate
  • Quaternion.Normalize


Quaternion.Invert() Method (Microsoft.DirectX)

Quaternion.Invert Method

Conjugates and re-normalizes a quaternion.

Definition

Visual Basic | Public Sub Invert()
C# | public void Invert();
C++ public:
void Invert();
JScript | public function Invert();

Remarks

A unit quaternion is defined by the following equation.

q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of q is ln(q) = (0, theta * v)

See Also

  • Quaternion.Conjugate
  • Quaternion.Normalize


Quaternion.Invert(Quaternion) Method (Microsoft.DirectX)

Quaternion.Invert Method

Conjugates and re-normalizes a quaternion.

Definition

Visual Basic Public Shared Function Invert( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Invert(
Quaternion q
);
C++ public:
static Quaternion Invert(
Quaternion q
);
JScript public static function Invert(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the inverse of the quaternion passed into the q parameter.

Remarks

A unit quaternion is defined by the following equation.

q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of q is ln(q) = (0, theta * v)

See Also

  • Quaternion.Conjugate
  • Quaternion.Normalize


Quaternion.Length Method ()

Returns the length of a quaternion.

Overload List

public float Length();
public static float Length(Quaternion);

See Also

  • LengthSq


Quaternion.Length() Method (Microsoft.DirectX)

Quaternion.Length Method

Returns the length of a quaternion.

Definition

Visual Basic | Public Function Length() As Single
C# | public float Length();
C++ public:
float Length();
JScript | public function Length() : float;

Return Value

System.Single
A Single Leave Site value that represents the quaternion's length.

See Also

  • LengthSq


Quaternion.Length(Quaternion) Method (Microsoft.DirectX)

Quaternion.Length Method

Returns the length of a quaternion.

Definition

Visual Basic Public Shared Function Length( _
ByVal v As Quaternion _
) As Single
C# public static float Length(
Quaternion v
);
C++ public:
static float Length(
Quaternion v
);
JScript public static function Length(
v : Quaternion
) : float;

Parameters

v Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

System.Single
A Single Leave Site value that represents the quaternion's length.

See Also

  • LengthSq


Quaternion.LengthSq Method ()

Returns the square of a quaternion's length.

Overload List

public float LengthSq();
public static float LengthSq(Quaternion);

See Also

  • Length


Quaternion.LengthSq() Method (Microsoft.DirectX)

Quaternion.LengthSq Method

Returns the square of a quaternion's length.

Definition

Visual Basic | Public Function LengthSq() As Single
C# | public float LengthSq();
C++ public:
float LengthSq();
JScript | public function LengthSq() : float;

Return Value

System.Single
A Single Leave Site value that represents the quaternion's squared length.

See Also

  • Length


Quaternion.LengthSq(Quaternion) Method (Microsoft.DirectX)

Quaternion.LengthSq Method

Returns the square of a quaternion's length.

Definition

Visual Basic Public Shared Function LengthSq( _
ByVal v As Quaternion _
) As Single
C# public static float LengthSq(
Quaternion v
);
C++ public:
static float LengthSq(
Quaternion v
);
JScript public static function LengthSq(
v : Quaternion
) : float;

Parameters

v Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

System.Single
A Single Leave Site value that represents the quaternion's squared length.

See Also

  • Length


Quaternion.Ln Method ()

Calculates the natural logarithm.

Overload List

public void Ln();
public static Quaternion Ln(Quaternion);

Remarks

The Ln method works only for unit quaternions.

A unit quaternion is defined by the following example.

Q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of Q is ln(Q) = (0, theta * v)

See Also

  • Exp
  • Squad


Quaternion.Ln() Method (Microsoft.DirectX)

Quaternion.Ln Method

Calculates the natural logarithm.

Definition

Visual Basic | Public Sub Ln()
C# | public void Ln();
C++ public:
void Ln();
JScript | public function Ln();

Remarks

The Ln method works only for unit quaternions.

A unit quaternion is defined by the following example.

Q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of Q is ln(Q) = (0, theta * v)

See Also

  • Exp
  • Squad


Quaternion.Ln(Quaternion) Method (Microsoft.DirectX)

Quaternion.Ln Method

Calculates the natural logarithm.

Definition

Visual Basic Public Shared Function Ln( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Ln(
Quaternion q
);
C++ public:
static Quaternion Ln(
Quaternion q
);
JScript public static function Ln(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the natural logarithm of the quaternion passed into the q parameter.

Remarks

The Ln method works only for unit quaternions.

A unit quaternion is defined by the following example.

Q == (cos(theta), sin(theta) * v) where |v| = 1
The natural logarithm of Q is ln(Q) = (0, theta * v)

See Also

  • Exp
  • Squad


Quaternion.Multiply Method ()

Multiplies two quaternions.

Overload List

public void Multiply(Quaternion);
public static Quaternion Multiply(Quaternion, Quaternion);

Remarks

The result represents the rotation m1 followed by the rotation m2 (return value = m1 * m2). This is done so that Multiply maintains the same semantics as Matrix, because unit quaternions can be considered as another way of representing rotation matrices.

Transformations are concatenated in the same order for the Quaternion.Multiply and Matrix.Multiply methods. In the following C# code example, assuming that mX and mY represent the same rotations as qX and qY, both m and q represent the same rotations.

[C#]

m = Matrix.Multiply(mX, mY);

q = Quaternion.Multiply(qX, qY);
The multiplication of quaternions is not commutative; that is, the order in which they are multiplied is important.

See Also

  • Microsoft.DirectX.Matrix.Multiply


Quaternion.Multiply(Quaternion) Method (Microsoft.DirectX)

Quaternion.Multiply Method

Multiplies two quaternions.

Definition

Visual Basic Public Sub Multiply( _
ByVal q As Quaternion _
)
C# public void Multiply(
Quaternion q
);
C++ public:
void Multiply(
Quaternion q
);
JScript public function Multiply(
q : Quaternion
);

Parameters

q Microsoft.DirectX.Quaternion
Source Quaternion structure.

Remarks

If the single parameter overload of this method is used, the current Quaternion instance is used as the m1 parameter and the quaternion that is passed in is treated as the m2 parameter.

The result represents the rotation m1 followed by the rotation m2 (return value = m1 * m2). This is done so that Multiply maintains the same semantics as Matrix, because unit quaternions can be considered as another way of representing rotation matrices.

Transformations are concatenated in the same order for the Quaternion.Multiply and Matrix.Multiply methods. In the following C# code example, assuming that mX and mY represent the same rotations as qX and qY, both m and q represent the same rotations.

[C#]

m = Matrix.Multiply(mX, mY);

q = Quaternion.Multiply(qX, qY);
The multiplication of quaternions is not commutative; that is, the order in which they are multiplied is important.

See Also

  • Microsoft.DirectX.Matrix.Multiply


Quaternion.Multiply(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.Multiply Method

Multiplies two quaternions.

Definition

Visual Basic Public Shared Function Multiply( _
ByVal m1 As Quaternion, _
ByVal m2 As Quaternion _
) As Quaternion
C# public static Quaternion Multiply(
Quaternion m1,
Quaternion m2
);
C++ public:
static Quaternion Multiply(
Quaternion m1,
Quaternion m2
);
JScript public static function Multiply(
m1 : Quaternion,
m2 : Quaternion
) : Quaternion;

Parameters

m1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
m2 Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the product of two quaternions.

Remarks

The result represents the rotation m1 followed by the rotation m2 (return value = m1 * m2). This is done so that Multiply maintains the same semantics as Matrix, because unit quaternions can be considered as another way of representing rotation matrices.

Transformations are concatenated in the same order for the Quaternion.Multiply and Matrix.Multiply methods. In the following C# code example, assuming that mX and mY represent the same rotations as qX and qY, both m and q represent the same rotations.

[C#]

m = Matrix.Multiply(mX, mY);

q = Quaternion.Multiply(qX, qY);
The multiplication of quaternions is not commutative; that is, the order in which they are multiplied is important.

See Also

  • Microsoft.DirectX.Matrix.Multiply


Quaternion.Normalize Method ()

Returns the normal of a quaternion.

Overload List

public void Normalize();
public static Quaternion Normalize(Quaternion);

See Also

  • Invert


Quaternion.Normalize() Method (Microsoft.DirectX)

Quaternion.Normalize Method

Returns the normal of a quaternion.

Definition

Visual Basic | Public Sub Normalize()
C# | public void Normalize();
C++ public:
void Normalize();
JScript | public function Normalize();

See Also

  • Invert


Quaternion.Normalize(Quaternion) Method (Microsoft.DirectX)

Quaternion.Normalize Method

Returns the normal of a quaternion.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal q As Quaternion _
) As Quaternion
C# public static Quaternion Normalize(
Quaternion q
);
C++ public:
static Quaternion Normalize(
Quaternion q
);
JScript public static function Normalize(
q : Quaternion
) : Quaternion;

Parameters

q Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the normal of the quaternion.

See Also

  • Invert


Quaternion.op_Addition(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.op_Addition Method

Adds two quaternions.

Definition

Visual Basic Public Shared Function op_Addition( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Quaternion
C# public static Quaternion op_Addition(
Quaternion left,
Quaternion right
);
C++ public:
static Quaternion operator+(
Quaternion left,
Quaternion right
);
JScript public static function op_Addition(
left : Quaternion,
right : Quaternion
) : Quaternion;

Parameters

left Microsoft.DirectX.Quaternion
The Quaternion structure to the left of the addition operator.
right Microsoft.DirectX.Quaternion
The Quaternion structure to the right of the addition operator.

Return Value

Microsoft.DirectX.Quaternion
Resulting Quaternion structure.


Quaternion.op_Equality(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Boolean
C# public static bool op_Equality(
Quaternion left,
Quaternion right
);
C++ public:
static bool operator==(
Quaternion left,
Quaternion right
);
JScript public static function op_Equality(
left : Quaternion,
right : Quaternion
) : boolean;

Parameters

left Microsoft.DirectX.Quaternion
The Quaternion structure to the left of the equality operator.
right Microsoft.DirectX.Quaternion
The Quaternion structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Quaternion.op_Inequality(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Boolean
C# public static bool op_Inequality(
Quaternion left,
Quaternion right
);
C++ public:
static bool operator!=(
Quaternion left,
Quaternion right
);
JScript public static function op_Inequality(
left : Quaternion,
right : Quaternion
) : boolean;

Parameters

left Microsoft.DirectX.Quaternion
The Quaternion structure to the left of the inequality operator.
right Microsoft.DirectX.Quaternion
The Quaternion structure to the right of the inequality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Quaternion.op_Multiply(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.op_Multiply Method

Determines the product of two quaternions.

Definition

Visual Basic Public Shared Function op_Multiply( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Quaternion
C# public static Quaternion op_Multiply(
Quaternion left,
Quaternion right
);
C++ public:
static Quaternion operator*(
Quaternion left,
Quaternion right
);
JScript public static function op_Multiply(
left : Quaternion,
right : Quaternion
) : Quaternion;

Parameters

left Microsoft.DirectX.Quaternion
Source Quaternion structure.
right Microsoft.DirectX.Quaternion
Source Quaternion structure.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the product of two quaternions.

See Also

  • Multiply


Quaternion.op_Subtraction(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.op_Subtraction Method

Subtracts two quaternions.

Definition

Visual Basic Public Shared Function op_Subtraction( _
ByVal left As Quaternion, _
ByVal right As Quaternion _
) As Quaternion
C# public static Quaternion op_Subtraction(
Quaternion left,
Quaternion right
);
C++ public:
static Quaternion operator-(
Quaternion left,
Quaternion right
);
JScript public static function op_Subtraction(
left : Quaternion,
right : Quaternion
) : Quaternion;

Parameters

left Microsoft.DirectX.Quaternion
The Quaternion structure to the left of the subtraction operator.
right Microsoft.DirectX.Quaternion
The Quaternion structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Quaternion
Resulting Quaternion structure.


Quaternion.Quaternion Constructor ()

Initializes a new instance of the Quaternion class.

Overload List

public Quaternion();
public Quaternion(float, float, float, float);


Quaternion.Quaternion() Constructor (Microsoft.DirectX)

Quaternion.Quaternion Constructor

Initializes a new instance of the Quaternion class.

Definition

Visual Basic | Public Sub New()
C# | public Quaternion();
C++ public:
Quaternion();
JScript | public function Quaternion();


Quaternion.Quaternion(Single,Single,Single,Single) Constructor (Microsoft.DirectX)

Quaternion.Quaternion Constructor

Initializes a new instance of the Quaternion class.

Definition

Visual Basic Public Sub New( _
ByVal valueX As Single, _
ByVal valueY As Single, _
ByVal valueZ As Single, _
ByVal valueW As Single _
)
C# public Quaternion(
float valueX,
float valueY,
float valueZ,
float valueW
);
C++ public:
Quaternion(
float valueX,
float valueY,
float valueZ,
float valueW
);
JScript public function Quaternion(
valueX : float,
valueY : float,
valueZ : float,
valueW : float
);

Parameters

valueX System.Single
Initial Single Leave Site value for the Quaternion.X member.
valueY System.Single
Initial Single Leave Site value for the Quaternion.Y member.
valueZ System.Single
Initial Single Leave Site value for the Quaternion.Z member.
valueW System.Single
Initial Single Leave Site value for the Quaternion.W member.


Quaternion.RotateAxis(Vector3,Single) Method (Microsoft.DirectX)

Quaternion.RotateAxis Method

Rotates a quaternion around an arbitrary axis.

Definition

Visual Basic Public Sub RotateAxis( _
ByVal v As Vector3, _
ByVal angle As Single _
)
C# public void RotateAxis(
Vector3 v,
float angle
);
C++ public:
void RotateAxis(
Vector3 v,
float angle
);
JScript public function RotateAxis(
v : Vector3,
angle : float
);

Parameters

v Microsoft.DirectX.Vector3
A Vector3 structure that identifies the axis about which to rotate the quaternion.
angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

See Also

  • Quaternion.RotateMatrix
  • Quaternion.RotateYawPitchRoll


Quaternion.RotateMatrix(Matrix) Method (Microsoft.DirectX)

Quaternion.RotateMatrix Method

Builds a quaternion from a rotation matrix.

Definition

Visual Basic Public Sub RotateMatrix( _
ByVal m As Matrix _
)
C# public void RotateMatrix(
Matrix m
);
C++ public:
void RotateMatrix(
Matrix m
);
JScript public function RotateMatrix(
m : Matrix
);

Parameters

m Microsoft.DirectX.Matrix
Source Matrix structure that defines the rotation.

See Also

  • Quaternion.RotateAxis
  • Quaternion.RotateYawPitchRoll


Quaternion.RotateYawPitchRoll(Single,Single,Single) Method (Microsoft.DirectX)

Quaternion.RotateYawPitchRoll Method

Builds a quaternion with the given yaw, pitch, and roll.

Definition

Visual Basic Public Sub RotateYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
)
C# public void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
C++ public:
void RotateYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript public function RotateYawPitchRoll(
yaw : float,
pitch : float,
roll : float
);

Parameters

yaw System.Single
Yaw around the y-axis, in radians.
pitch System.Single
Pitch around the x-axis, in radians.
roll System.Single
Roll around the z-axis, in radians.

See Also

  • Quaternion.RotateAxis
  • Quaternion.RotateMatrix


Quaternion.RotationAxis(Vector3,Single) Method (Microsoft.DirectX)

Quaternion.RotationAxis Method

Builds a quaternion that is rotated around an arbitrary axis.

Definition

Visual Basic Public Shared Function RotationAxis( _
ByVal v As Vector3, _
ByVal angle As Single _
) As Quaternion
C# public static Quaternion RotationAxis(
Vector3 v,
float angle
);
C++ public:
static Quaternion RotationAxis(
Vector3 v,
float angle
);
JScript public static function RotationAxis(
v : Vector3,
angle : float
) : Quaternion;

Parameters

v Microsoft.DirectX.Vector3
A Vector3 structure that identifies the axis about which to rotate the quaternion.
angle System.Single
Angle of rotation, in radians. Angles are measured clockwise when looking along the rotation axis toward the origin.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is rotated around the specified axis.

See Also

  • Quaternion.RotationYawPitchRollTopic
  • Quaternion.RotationMatrix


Quaternion.RotationMatrix(Matrix) Method (Microsoft.DirectX)

Quaternion.RotationMatrix Method

Builds a quaternion from a rotation matrix.

Definition

Visual Basic Public Shared Function RotationMatrix( _
ByVal m As Matrix _
) As Quaternion
C# public static Quaternion RotationMatrix(
Matrix m
);
C++ public:
static Quaternion RotationMatrix(
Matrix m
);
JScript public static function RotationMatrix(
m : Matrix
) : Quaternion;

Parameters

m Microsoft.DirectX.Matrix
Source Matrix structure that defines the rotation.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure built from a rotation matrix.

See Also

  • Quaternion.RotationAxis
  • Quaternion.RotationYawPitchRollTopic


Quaternion.RotationYawPitchRoll(Single,Single,Single) Method (Microsoft.DirectX)

Quaternion.RotationYawPitchRoll Method

Builds a quaternion with the given yaw, pitch, and roll.

Definition

Visual Basic Public Shared Function RotationYawPitchRoll( _
ByVal yaw As Single, _
ByVal pitch As Single, _
ByVal roll As Single _
) As Quaternion
C# public static Quaternion RotationYawPitchRoll(
float yaw,
float pitch,
float roll
);
C++ public:
static Quaternion RotationYawPitchRoll(
float yaw,
float pitch,
float roll
);
JScript public static function RotationYawPitchRoll(
yaw : float,
pitch : float,
roll : float
) : Quaternion;

Parameters

yaw System.Single
Yaw around the y-axis, in radians.
pitch System.Single
Pitch around the x-axis, in radians.
roll System.Single
Roll around the z-axis, in radians.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure with the specified yaw, pitch, and roll.

See Also

  • Quaternion.RotationMatrix
  • Quaternion.RotationAxis


Quaternion.Slerp(Quaternion,Quaternion,Single) Method (Microsoft.DirectX)

Quaternion.Slerp Method

Interpolates between two quaternions, using spherical linear interpolation.

Definition

Visual Basic Public Shared Function Slerp( _
ByVal q1 As Quaternion, _
ByVal q2 As Quaternion, _
ByVal t As Single _
) As Quaternion
C# public static Quaternion Slerp(
Quaternion q1,
Quaternion q2,
float t
);
C++ public:
static Quaternion Slerp(
Quaternion q1,
Quaternion q2,
float t
);
JScript public static function Slerp(
q1 : Quaternion,
q2 : Quaternion,
t : float
) : Quaternion;

Parameters

q1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
q2 Microsoft.DirectX.Quaternion
Source Quaternion structure.
t System.Single
A Single Leave Site value that indicates how far to interpolate between the quaternions.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the result of the interpolation.


Quaternion.Squad(Quaternion,Quaternion,Quaternion,Quaternion,Single) Method (Microsoft.DirectX)

Quaternion.Squad Method

Interpolates between quaternions, using spherical quadrangle interpolation.

Definition

Visual Basic Public Shared Function Squad( _
ByVal q1 As Quaternion, _
ByVal a As Quaternion, _
ByVal b As Quaternion, _
ByVal c As Quaternion, _
ByVal t As Single _
) As Quaternion
C# public static Quaternion Squad(
Quaternion q1,
Quaternion a,
Quaternion b,
Quaternion c,
float t
);
C++ public:
static Quaternion Squad(
Quaternion q1,
Quaternion a,
Quaternion b,
Quaternion c,
float t
);
JScript public static function Squad(
q1 : Quaternion,
a : Quaternion,
b : Quaternion,
c : Quaternion,
t : float
) : Quaternion;

Parameters

q1 Microsoft.DirectX.Quaternion
Source Quaternion structure.
a Microsoft.DirectX.Quaternion
Source Quaternion structure.
b Microsoft.DirectX.Quaternion
Source Quaternion structure.
c Microsoft.DirectX.Quaternion
Source Quaternion structure.
t System.Single
A Single Leave Site value that indicates how far to interpolate between the quaternions.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the result of the spherical quadrangle interpolation.

Remarks

This method uses the following sequence of spherical linear interpolation operations.

Slerp(Slerp(q1, c, t), Slerp(a, b, t), 2t(1 - t))


Quaternion.SquadSetup(Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.SquadSetup Method

Sets up control points for spherical quadrangle interpolation.

Definition

Visual Basic Public Shared Sub SquadSetup( _
ByRef outA As Quaternion, _
ByRef outB As Quaternion, _
ByRef outC As Quaternion, _
ByVal q0 As Quaternion, _
ByVal q1 As Quaternion, _
ByVal q2 As Quaternion, _
ByVal q3 As Quaternion _
)
C# public static void SquadSetup(
ref Quaternion outA,
ref Quaternion outB,
ref Quaternion outC,
Quaternion q0,
Quaternion q1,
Quaternion q2,
Quaternion q3
);
C++ public:
static void SquadSetup(
Quaternion% outA,
Quaternion% outB,
Quaternion% outC,
Quaternion q0,
Quaternion q1,
Quaternion q2,
Quaternion q3
);
JScript public static function SquadSetup(
outA : Quaternion,
outB : Quaternion,
outC : Quaternion,
q0 : Quaternion,
q1 : Quaternion,
q2 : Quaternion,
q3 : Quaternion
);

Parameters

outA Microsoft.DirectX.Quaternion
A Quaternion instance that represents the outA value.
outB Microsoft.DirectX.Quaternion
A Quaternion instance that represents the outB value.
outC Microsoft.DirectX.Quaternion
A Quaternion instance that represents the outC value.
q0 Microsoft.DirectX.Quaternion
A Quaternion instance that represents the q0 input control point.
q1 Microsoft.DirectX.Quaternion
A Quaternion instance that represents the q1 input control point.
q2 Microsoft.DirectX.Quaternion
A Quaternion instance that represents the q2 input control point.
q3 Microsoft.DirectX.Quaternion
A Quaternion instance that represents the q3 input control point.

Remarks

This method takes four control points, which are supplied to the inputs q0, q1, q2, and q3, and alters their values to find a curve that flows along the shortest path. The values of q0, q2, and q3 are calculated as shown below.

q0 = |q0 + q1| < |q0 - q1| ? -q0 : q0
q2 = |q1 + q2| < |q1 - q2| ? -q2 : q2
q3 = |q2 + q3| < |q2 - q3| ? -q3 : q3
Having calculated the new q values, the values for outA, outB, and outC are calculated as shown below.
outA = q1 * exp[-0.25 *( Ln[Exp(q1)*q2] + Ln[Exp(q1)*q0] ) ]

outB = q2 * exp[-0.25 *( Ln[Exp(q2)*q3] + Ln[Exp(q2)*q1] ) ]

outC = q2
Note: In the preceding example, Ln is the application programming interface (API) method Quaternion.Ln, and Exp is the API method Quaternion.Exp.

Examples

The following example shows how to use a set of quaternion keys (Q0, Q1, Q2, Q3) to compute the inner quadrangle points (A, B, C). This ensures that the tangents are continuous across adjacent segments.
        A     B
  Q0    Q1    Q2    Q3
 The following C# code example shows how you can interpolate between Q1 and Q2.
[C#]
// Rotation about the z-axis
Quaternion Q0 =  new Quaternion(0f,  0f, 0.707f, -.707f);
Quaternion Q1 = new Quaternion(0f,  0f, 0.000f, 1.000f);
Quaternion Q2 = new Quaternion(0f,  0f, 0.707f, 0.707f);
Quaternion Q3 = new Quaternion(0f,  0f, 1.000f, 0.000f);
Quaternion A = new Quaternion();
Quaternion B = new Quaternion();
Quaternion C = new Quaternion();
Quaternion Qt = new Quaternion();

Single time = 0.5f;

Quaternion.SquadSetup(ref A, ref B, ref C, Q0, Q1, Q2, Q3);
Qt = Quaternion.Squad(Q1, A, B, C, time);
 Note:
  • C is +/- Q2 depending on the result of the function
  • Qt is the result of the function
The result is a rotation of 45 degrees around the z-axis for time = 0.5.


Quaternion.Subtract(Quaternion,Quaternion) Method (Microsoft.DirectX)

Quaternion.Subtract Method

Subtracts two quaternion instances.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal m1 As Quaternion, _
ByVal m2 As Quaternion _
) As Quaternion
C# public static Quaternion Subtract(
Quaternion m1,
Quaternion m2
);
C++ public:
static Quaternion Subtract(
Quaternion m1,
Quaternion m2
);
JScript public static function Subtract(
m1 : Quaternion,
m2 : Quaternion
) : Quaternion;

Parameters

m1 Microsoft.DirectX.Quaternion
Source Quaternion structure to the left of the subtraction operator.
m2 Microsoft.DirectX.Quaternion
Source Quaternion structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Quaternion
A Quaternion structure that is the result of the operation.


Quaternion.ToAxisAngle(Quaternion,Vector3,Single) Method (Microsoft.DirectX)

Quaternion.ToAxisAngle Method

Computes a quaternion's axis and angle of rotation.

Definition

Visual Basic Public Shared Sub ToAxisAngle( _
ByVal q As Quaternion, _
ByRef axis As Vector3, _
ByRef angle As Single _
)
C# public static void ToAxisAngle(
Quaternion q,
ref Vector3 axis,
ref float angle
);
C++ public:
static void ToAxisAngle(
Quaternion q,
Vector3% axis,
float% angle
);
JScript public static function ToAxisAngle(
q : Quaternion,
axis : Vector3,
angle : float
);

Parameters

q Microsoft.DirectX.Quaternion
Source Quaternion structure. See Remarks.
axis Microsoft.DirectX.Vector3
A Vector3 structure that identifies the quaternion's axis of rotation.
angle System.Single
A Single Leave Site value that identifies the quaternion's angle of rotation, in radians.

Remarks

This method requires unit quaternions.


Quaternion.ToString() Method (Microsoft.DirectX)

Quaternion.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Quaternion.Identity Property (Microsoft.DirectX)

Quaternion.Identity Property

Retrieves the identity quaternion.

Definition

Visual Basic | Public Shared ReadOnly Property Identity As Quaternion
C# | public static Quaternion Identity { get; }
C++ public:
static property Quaternion Identity {
Quaternion get();
}
JScript | public static function get Identity() : Quaternion

Property Value

Microsoft.DirectX.Quaternion
A Quaternion structure that represents the identity quaternion.

This property is read-only.

Remarks

Given a quaternion (x, y, z, w), the Quaternion.Identity method returns the quaternion (0, 0, 0, 1).


Quaternion.Zero Property (Microsoft.DirectX)

Quaternion.Zero Property

Retrieves an empty quaternion.

Definition

Visual Basic | Public Shared ReadOnly Property Zero As Quaternion
C# | public static Quaternion Zero { get; }
C++ public:
static property Quaternion Zero {
Quaternion get();
}
JScript | public static function get Zero() : Quaternion

Property Value

Microsoft.DirectX.Quaternion
Empty Quaternion structure.

This property is read-only.


Quaternion.W Field (Microsoft.DirectX)

Quaternion.W Field

Retrieves or sets the w component of the quaternion.

Definition

Visual Basic | Public W As Single
C# | public Single W;
C++ | public: Single W;
JScript | public var W : Single

Field Value

System.Single
A Single Leave Site value that indicates the w component of the quaternion.

This field is read/write.


Quaternion.X Field (Microsoft.DirectX)

Quaternion.X Field

Retrieves or sets the x component of the quaternion.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
A Single Leave Site value that indicates the x component of the quaternion.

This field is read/write.


Quaternion.Y Field (Microsoft.DirectX)

Quaternion.Y Field

Retrieves or sets the y component of the quaternion.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
A Single Leave Site value that indicates the y component of the quaternion.

This field is read/write.


Quaternion.Z Field (Microsoft.DirectX)

Quaternion.Z Field

Retrieves or sets the z component of the quaternion.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
A Single Leave Site value that indicates the z component of the quaternion.

This field is read/write.


Single16 Structure (Microsoft.DirectX)

Single16 Structure

Describes and manipulates a 16-bit floating-point value.

Definition

Visual Basic | Public Structure Single16
C# | public struct Single16
C++ | public value class Single16 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
static (Shared in Visual Basic) AdditionRounding | Retrieves a value that indicates the largest value that is rounded.
static (Shared in Visual Basic) DigitsOfPrecision | Retrieves a value that indicates the number of decimal digits of precision for the Single16.
static (Shared in Visual Basic) Epsilon | Retrieves the smallest value that a Single Leave Site can hold.
static (Shared in Visual Basic) ExponentRadix | Retrieves the exponent radix value.
static (Shared in Visual Basic) MantissaBits | Retrieves the number of bits in a mantissa.
static (Shared in Visual Basic) MaxBinaryExponent | Retrieves the maximum binary exponent.
static (Shared in Visual Basic) MaxDecimalExponent | Retrieves the maximum decimal exponent.
static (Shared in Visual Basic) MaxValue | Retrieves the maximum value for this type.
static (Shared in Visual Basic) MinBinaryExponent | Retrieves the minimum binary exponent.
static (Shared in Visual Basic) MinDecimalExponent | Retrieves the minimum decimal exponent.
static (Shared in Visual Basic) MinValue | Retrieves the minimum value for this type.

Methods

Method | Description
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
Single16 | Initializes a new instance of the Single16 class.
ToString | Obtains a string representation of the current instance.

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492


Single16.Equals(Object) Method (Microsoft.DirectX)

Single16.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the current instance is equal to the specified object, or false if it is not.


Single16.GetHashCode() Method (Microsoft.DirectX)

Single16.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Single16.op_Equality(Single16,Single16) Method (Microsoft.DirectX)

Single16.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Single16, _
ByVal right As Single16 _
) As Boolean
C# public static bool op_Equality(
Single16 left,
Single16 right
);
C++ public:
static bool operator==(
Single16 left,
Single16 right
);
JScript public static function op_Equality(
left : Single16,
right : Single16
) : boolean;

Parameters

left Microsoft.DirectX.Single16
The Quaternion structure to the left of the equality operator.
right Microsoft.DirectX.Single16
The Quaternion structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Single16.op_Inequality(Single16,Single16) Method (Microsoft.DirectX)

Single16.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Single16, _
ByVal right As Single16 _
) As Boolean
C# public static bool op_Inequality(
Single16 left,
Single16 right
);
C++ public:
static bool operator!=(
Single16 left,
Single16 right
);
JScript public static function op_Inequality(
left : Single16,
right : Single16
) : boolean;

Parameters

left Microsoft.DirectX.Single16
The Quaternion structure to the left of the inequality operator.
right Microsoft.DirectX.Single16
The Quaternion structure to the right of the inequality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Single16.Single16(Single) Constructor (Microsoft.DirectX)

Single16.Single16 Constructor

Initializes a new instance of the Single16 class.

Definition

Visual Basic Public Sub New( _
ByVal value As Single _
)
C# public Single16(
float value
);
C++ public:
Single16(
float value
);
JScript public function Single16(
value : float
);

Parameters

value System.Single
A Single Leave Site value that is used to set the initial value.


Single16.ToString() Method (Microsoft.DirectX)

Single16.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Single16.AdditionRounding Field (Microsoft.DirectX)

Single16.AdditionRounding Field

Retrieves a value that indicates the largest value that is rounded.

Definition

Visual Basic | Public Shared AdditionRounding As Int32
C# | public static Int32 AdditionRounding;
C++ | public: static Int32 AdditionRounding;
JScript | public static var AdditionRounding : Int32

Field Value

System.Int32

This field is read-only.

Send comments about this topic to Microsoft. © Microsoft Corporation. All rights reserved.

Feedback? Please provide us with your comments on this topic.


Single16.DigitsOfPrecision Field (Microsoft.DirectX)

Single16.DigitsOfPrecision Field

Retrieves a value that indicates the number of decimal digits of precision for the Single16.

Definition

Visual Basic | Public Shared DigitsOfPrecision As Int32
C# | public static Int32 DigitsOfPrecision;
C++ | public: static Int32 DigitsOfPrecision;
JScript | public static var DigitsOfPrecision : Int32

Field Value

System.Int32
An Int32 Leave Site value that indicates the number of decimal digits of precision for the Single16.

This field is read-only.


Single16.Epsilon Field (Microsoft.DirectX)

Single16.Epsilon Field

Retrieves the smallest value that a Single Leave Site can hold.

Definition

Visual Basic | Public Shared Epsilon As Single
C# | public static Single Epsilon;
C++ | public: static Single Epsilon;
JScript | public static var Epsilon : Single

Field Value

System.Single
A Single Leave Site value that indicates the smallest value that the Single Leave Site can hold.

This field is read-only.

Remarks

This field's value is the smallest value for which the following equation is true:

1.0 + epsilon != 1


Single16.ExponentRadix Field (Microsoft.DirectX)

Single16.ExponentRadix Field

Retrieves the exponent radix value.

Definition

Visual Basic | Public Shared ExponentRadix As Int32
C# | public static Int32 ExponentRadix;
C++ | public: static Int32 ExponentRadix;
JScript | public static var ExponentRadix : Int32

Field Value

System.Int32
An Int32 Leave Site value that indicates the exponent radix value for the Single Leave Site.

This field is read-only.


Single16.MantissaBits Field (Microsoft.DirectX)

Single16.MantissaBits Field

Retrieves the number of bits in a mantissa.

Definition

Visual Basic | Public Shared MantissaBits As Int32
C# | public static Int32 MantissaBits;
C++ | public: static Int32 MantissaBits;
JScript | public static var MantissaBits : Int32

Field Value

System.Int32
An Int32 Leave Site value that indicates the number of bits in the mantissa.

This field is read-only.


Single16.MaxBinaryExponent Field (Microsoft.DirectX)

Single16.MaxBinaryExponent Field

Retrieves the maximum binary exponent.

Definition

Visual Basic | Public Shared MaxBinaryExponent As Int32
C# | public static Int32 MaxBinaryExponent;
C++ | public: static Int32 MaxBinaryExponent;
JScript | public static var MaxBinaryExponent : Int32

Field Value

System.Int32
An Int32 Leave Site value that indicates the maximum binary exponent.

This field is read-only.


Single16.MaxDecimalExponent Field (Microsoft.DirectX)

Single16.MaxDecimalExponent Field

Retrieves the maximum decimal exponent.

Definition

Visual Basic | Public Shared MaxDecimalExponent As Int32
C# | public static Int32 MaxDecimalExponent;
C++ | public: static Int32 MaxDecimalExponent;
JScript | public static var MaxDecimalExponent : Int32

Field Value

System.Int32
An Int32 Leave Site value that indicates the maximum decimal exponent.

This field is read-only.


Single16.MaxValue Field (Microsoft.DirectX)

Single16.MaxValue Field

Retrieves the maximum value for this type.

Definition

Visual Basic | Public Shared MaxValue As Single
C# | public static Single MaxValue;
C++ | public: static Single MaxValue;
JScript | public static var MaxValue : Single

Field Value

System.Single
An Int32 Leave Site value that indicates the maximum value.

This field is read-only.


Single16.MinBinaryExponent Field (Microsoft.DirectX)

Single16.MinBinaryExponent Field

Retrieves the minimum binary exponent.

Definition

Visual Basic | Public Shared MinBinaryExponent As Int32
C# | public static Int32 MinBinaryExponent;
C++ | public: static Int32 MinBinaryExponent;
JScript | public static var MinBinaryExponent : Int32

Field Value

System.Int32
An Int32 Leave Site value that indicates the minimum binary exponent.

This field is read-only.


Single16.MinDecimalExponent Field (Microsoft.DirectX)

Single16.MinDecimalExponent Field

Retrieves the minimum decimal exponent.

Definition

Visual Basic | Public Shared MinDecimalExponent As Int32
C# | public static Int32 MinDecimalExponent;
C++ | public: static Int32 MinDecimalExponent;
JScript | public static var MinDecimalExponent : Int32

Field Value

System.Int32
An Int32 Leave Site value that indicates the minimum decimal exponent.

This field is read-only.


Single16.MinValue Field (Microsoft.DirectX)

Single16.MinValue Field

Retrieves the minimum value for this type.

Definition

Visual Basic | Public Shared MinValue As Single
C# | public static Single MinValue;
C++ | public: static Single MinValue;
JScript | public static var MinValue : Single

Field Value

System.Single
A Single Leave Site value that indicates the minimum value.

This field is read-only.


Vector2 Structure (Microsoft.DirectX)

Vector2 Structure

Describes and manipulates a vector in two-dimensional (2-D) space.

Definition

Visual Basic | Public Structure Vector2
C# | public struct Vector2
C++ | public value class Vector2 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
X | Retrieves or sets the x component of a 2-D vector.
Y | Retrieves or sets the y component of a 2-D vector.

Methods

Method | Description
Add | Adds two 2-D vectors.
static (Shared in Visual Basic) BaryCentric | Returns a point in barycentric coordinates, using specified 2-D vectors.
static (Shared in Visual Basic) CatmullRom | Performs a Catmull-Rom interpolation using specified 2-D vectors.
static (Shared in Visual Basic) Ccw | Returns the z component by calculating the cross product of two 2-D vectors.
static (Shared in Visual Basic) Dot | Determines the dot product of two 2-D vectors.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic) Hermite | Performs a Hermite spline interpolation using specified 2-D vectors.
Length | Returns the length of a 2-D vector.
LengthSq | Returns the square of the length of a 2-D vector.
static (Shared in Visual Basic) Lerp | Performs a linear interpolation between two 2-D vectors.
Maximize | Returns a 2-D vector that is made up of the largest components of two 2-D vectors.
Minimize | Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.
Multiply | Multiplies the current 2-D vector with a single value.
Normalize | Returns the normalized version of a 2-D vector.
static (Shared in Visual Basic) op_Addition | Adds two 2-D vectors.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Multiply | Determines the product of a single value and a 2-D vector.
static (Shared in Visual Basic) op_Subtraction | Subtracts two 2-D vectors.
static (Shared in Visual Basic) op_UnaryNegation | Negates the vector.
Scale | Scales a 2-D vector.
Subtract | Subtracts two 2-D vectors.
ToString | Obtains a string representation of the current instance.
static (Shared in Visual Basic) Transform | Transforms a 2-D vector or an array of 2-D vectors by a given matrix.
TransformCoordinate | Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.
TransformNormal | Transforms the 2-D vector normal by a given matrix.
Vector2 | Initializes a new instance of the Vector2 class.

Properties

Property | Description
static (Shared in Visual Basic) Empty | Retrieves an empty 2-D vector.

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Vector2 Class


Vector2.Add Method ()

Adds two 2-D vectors.

Overload List

public void Add(Vector2);
public static Vector2 Add(Vector2, Vector2);


Vector2.Add(Vector2) Method (Microsoft.DirectX)

Vector2.Add Method

Adds two 2-D vectors.

Definition

Visual Basic Public Sub Add( _
ByVal v As Vector2 _
)
C# public void Add(
Vector2 v
);
C++ public:
void Add(
Vector2 v
);
JScript public function Add(
v : Vector2
);

Parameters

v Microsoft.DirectX.Vector2
Source Vector2.


Vector2.Add(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.Add Method

Adds two 2-D vectors.

Definition

Visual Basic Public Shared Function Add( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 Add(
Vector2 left,
Vector2 right
);
C++ public:
static Vector2 Add(
Vector2 left,
Vector2 right
);
JScript public static function Add(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left Microsoft.DirectX.Vector2
Source Vector2.
right Microsoft.DirectX.Vector2
Source Vector2.

Return Value

Microsoft.DirectX.Vector2
Sum of the two source Vector2 structures.


Vector2.BaryCentric(Vector2,Vector2,Vector2,Single,Single) Method (Microsoft.DirectX)

Vector2.BaryCentric Method

Returns a point in barycentric coordinates, using specified 2-D vectors.

Definition

Visual Basic Public Shared Function BaryCentric( _
ByVal v1 As Vector2, _
ByVal v2 As Vector2, _
ByVal v3 As Vector2, _
ByVal f As Single, _
ByVal g As Single _
) As Vector2
C# public static Vector2 BaryCentric(
Vector2 v1,
Vector2 v2,
Vector2 v3,
float f,
float g
);
C++ public:
static Vector2 BaryCentric(
Vector2 v1,
Vector2 v2,
Vector2 v3,
float f,
float g
);
JScript public static function BaryCentric(
v1 : Vector2,
v2 : Vector2,
v3 : Vector2,
f : float,
g : float
) : Vector2;

Parameters

v1 Microsoft.DirectX.Vector2
Source Vector2 structure.
v2 Microsoft.DirectX.Vector2
Source Vector2 structure.
v3 Microsoft.DirectX.Vector2
Source Vector2 structure.
f System.Single
Weighting factor. See Remarks.
g System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure in barycentric coordinates.

Remarks

The BaryCentric method provides a way to understand points in and around a triangle, regardless of its actual location. This method returns the resulting point by using the following equation.

v1 + f(v2 - v1) + g(v3 - v1)

Any point in the plane v1v2v3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which v2 gets weighted into the result, and the f parameter controls the extent to which v3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which v1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle v1v2v3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line v1v3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line v1v2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line v2v3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates also holds true for barycentric coordinates.


Vector2.CatmullRom(Vector2,Vector2,Vector2,Vector2,Single) Method (Microsoft.DirectX)

Vector2.CatmullRom Method

Performs a Catmull-Rom interpolation using specified 2-D vectors.

Definition

Visual Basic Public Shared Function CatmullRom( _
ByVal position1 As Vector2, _
ByVal position2 As Vector2, _
ByVal position3 As Vector2, _
ByVal position4 As Vector2, _
ByVal weightingFactor As Single _
) As Vector2
C# public static Vector2 CatmullRom(
Vector2 position1,
Vector2 position2,
Vector2 position3,
Vector2 position4,
float weightingFactor
);
C++ public:
static Vector2 CatmullRom(
Vector2 position1,
Vector2 position2,
Vector2 position3,
Vector2 position4,
float weightingFactor
);
JScript public static function CatmullRom(
position1 : Vector2,
position2 : Vector2,
position3 : Vector2,
position4 : Vector2,
weightingFactor : float
) : Vector2;

Parameters

position1 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
position2 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
position3 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
position4 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of position1, v2 is the contents of position2, p3 is the contents of position3, p4 is the contents of position4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the Hermite spline equation:

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
and substituting for v1, v2, t1, t2 yields:
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This can be rearranged as:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

See Also

  • Vector3.CatmullRom
  • Vector4.CatmullRom


Vector2.Ccw(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.Ccw Method

Returns the z component by calculating the cross product of two 2-D vectors.

Definition

Visual Basic Public Shared Function Ccw( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Single
C# public static float Ccw(
Vector2 left,
Vector2 right
);
C++ public:
static float Ccw(
Vector2 left,
Vector2 right
);
JScript public static function Ccw(
left : Vector2,
right : Vector2
) : float;

Parameters

left Microsoft.DirectX.Vector2
Source Vector2 structure.
right Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

System.Single
The z component.

Remarks

This method determines the z component by calculating the cross product based on the following formula.

((x1,y1,0) cross (x2,y2,0))

The following C# code fragment provides an example.

[C#]
left->x * right->y - left->y * right->x

If the z component's value is positive, the vector right is counterclockwise from the vector left. This information is useful for back-face culling.


Vector2.Dot(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.Dot Method

Determines the dot product of two 2-D vectors.

Definition

Visual Basic Public Shared Function Dot( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Single
C# public static float Dot(
Vector2 left,
Vector2 right
);
C++ public:
static float Dot(
Vector2 left,
Vector2 right
);
JScript public static function Dot(
left : Vector2,
right : Vector2
) : float;

Parameters

left Microsoft.DirectX.Vector2
Source Vector2 structure.
right Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

System.Single
Dot product.

See Also

  • Ccw


Vector2.Equals(Object) Method (Microsoft.DirectX)

Vector2.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the current instance is equal to the specified object, or false if it is not.


Vector2.GetHashCode() Method (Microsoft.DirectX)

Vector2.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Vector2.Hermite(Vector2,Vector2,Vector2,Vector2,Single) Method (Microsoft.DirectX)

Vector2.Hermite Method

Performs a Hermite spline interpolation using specified 2-D vectors.

Definition

Visual Basic Public Shared Function Hermite( _
ByVal position As Vector2, _
ByVal tangent As Vector2, _
ByVal position2 As Vector2, _
ByVal tangent2 As Vector2, _
ByVal weightingFactor As Single _
) As Vector2
C# public static Vector2 Hermite(
Vector2 position,
Vector2 tangent,
Vector2 position2,
Vector2 tangent2,
float weightingFactor
);
C++ public:
static Vector2 Hermite(
Vector2 position,
Vector2 tangent,
Vector2 position2,
Vector2 tangent2,
float weightingFactor
);
JScript public static function Hermite(
position : Vector2,
tangent : Vector2,
position2 : Vector2,
tangent2 : Vector2,
weightingFactor : float
) : Vector2;

Parameters

position Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
tangent Microsoft.DirectX.Vector2
Source Vector2 structure that is a tangent vector.
position2 Microsoft.DirectX.Vector2
Source Vector2 structure that is a position vector.
tangent2 Microsoft.DirectX.Vector2
Source Vector2 structure that is a tangent vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (position, tangent) to (position2, tangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of ease-in, ease-out spline interpolation. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of position, v2 is the contents of position2, t1 is the contents of tangent, t2 is the contents of tangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, and D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

The preceding example yields the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.


Vector2.Length Method ()

Returns the length of a 2-D vector.

Overload List

public float Length();
public static float Length(Vector2);

See Also

  • LengthSq


Vector2.Length() Method (Microsoft.DirectX)

Vector2.Length Method

Returns the length of a 2-D vector.

Definition

Visual Basic | Public Function Length() As Single
C# | public float Length();
C++ public:
float Length();
JScript | public function Length() : float;

Return Value

System.Single
Vector length.

See Also

  • LengthSq


Vector2.Length(Vector2) Method (Microsoft.DirectX)

Vector2.Length Method

Returns the length of a 2-D vector.

Definition

Visual Basic Public Shared Function Length( _
ByVal source As Vector2 _
) As Single
C# public static float Length(
Vector2 source
);
C++ public:
static float Length(
Vector2 source
);
JScript public static function Length(
source : Vector2
) : float;

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

System.Single
Vector length.

See Also

  • LengthSq


Vector2.LengthSq Method ()

Returns the square of the length of a 2-D vector.

Overload List

public float LengthSq();
public static float LengthSq(Vector2);

See Also

  • Length


Vector2.LengthSq() Method (Microsoft.DirectX)

Vector2.LengthSq Method

Returns the square of the length of a 2-D vector.

Definition

Visual Basic | Public Function LengthSq() As Single
C# | public float LengthSq();
C++ public:
float LengthSq();
JScript | public function LengthSq() : float;

Return Value

System.Single
Vector's squared length.

See Also

  • Length


Vector2.LengthSq(Vector2) Method (Microsoft.DirectX)

Vector2.LengthSq Method

Returns the square of the length of a 2-D vector.

Definition

Visual Basic Public Shared Function LengthSq( _
ByVal source As Vector2 _
) As Single
C# public static float LengthSq(
Vector2 source
);
C++ public:
static float LengthSq(
Vector2 source
);
JScript public static function LengthSq(
source : Vector2
) : float;

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

System.Single
Vector's squared length.

See Also

  • Length


Vector2.Lerp(Vector2,Vector2,Single) Method (Microsoft.DirectX)

Vector2.Lerp Method

Performs a linear interpolation between two 2-D vectors.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal left As Vector2, _
ByVal right As Vector2, _
ByVal interpolater As Single _
) As Vector2
C# public static Vector2 Lerp(
Vector2 left,
Vector2 right,
float interpolater
);
C++ public:
static Vector2 Lerp(
Vector2 left,
Vector2 right,
float interpolater
);
JScript public static function Lerp(
left : Vector2,
right : Vector2,
interpolater : float
) : Vector2;

Parameters

left Microsoft.DirectX.Vector2
Source Vector2 structure.
right Microsoft.DirectX.Vector2
Source Vector2 structure.
interpolater System.Single
Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

left + interpolater(right - left).


Vector2.Maximize Method ()

Returns a 2-D vector that is made up of the largest components of two 2-D vectors.

Overload List

public void Maximize(Vector2);
public static Vector2 Maximize(Vector2, Vector2);

See Also

  • Vector2.Minimize


Vector2.Maximize(Vector2) Method (Microsoft.DirectX)

Vector2.Maximize Method

Returns a 2-D vector that is made up of the largest components of two 2-D vectors.

Definition

Visual Basic Public Sub Maximize( _
ByVal source As Vector2 _
)
C# public void Maximize(
Vector2 source
);
C++ public:
void Maximize(
Vector2 source
);
JScript public function Maximize(
source : Vector2
);

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.

See Also

  • Vector2.Minimize


Vector2.Maximize(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.Maximize Method

Returns a 2-D vector that is made up of the largest components of two 2-D vectors.

Definition

Visual Basic Public Shared Function Maximize( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 Maximize(
Vector2 left,
Vector2 right
);
C++ public:
static Vector2 Maximize(
Vector2 left,
Vector2 right
);
JScript public static function Maximize(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left Microsoft.DirectX.Vector2
Source Vector2 structure.
right Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is made up of the largest components of the two vectors.

See Also

  • Vector2.Minimize


Vector2.Minimize Method ()

Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.

Overload List

public void Minimize(Vector2);
public static Vector2 Minimize(Vector2, Vector2);

See Also

  • Vector2.Maximize


Vector2.Minimize(Vector2) Method (Microsoft.DirectX)

Vector2.Minimize Method

Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.

Definition

Visual Basic Public Sub Minimize( _
ByVal source As Vector2 _
)
C# public void Minimize(
Vector2 source
);
C++ public:
void Minimize(
Vector2 source
);
JScript public function Minimize(
source : Vector2
);

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.

See Also

  • Vector2.Maximize


Vector2.Minimize(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.Minimize Method

Returns a 2-D vector that is made up of the smallest components of two 2-D vectors.

Definition

Visual Basic Public Shared Function Minimize( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 Minimize(
Vector2 left,
Vector2 right
);
C++ public:
static Vector2 Minimize(
Vector2 left,
Vector2 right
);
JScript public static function Minimize(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left Microsoft.DirectX.Vector2
Source Vector2 structure.
right Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is made up of the smallest components of the two vectors.

See Also

  • Vector2.Maximize


Vector2.Multiply Method ()

Multiplies the current 2-D vector with a single value.

Overload List

public void Multiply(float);
public static Vector2 Multiply(Vector2, float);


Vector2.Multiply(Vector2,Single) Method (Microsoft.DirectX)

Vector2.Multiply Method

Multiplies the current 2-D vector with a single value.

Definition

Visual Basic Public Shared Function Multiply( _
ByVal source As Vector2, _
ByVal s As Single _
) As Vector2
C# public static Vector2 Multiply(
Vector2 source,
float s
);
C++ public:
static Vector2 Multiply(
Vector2 source,
float s
);
JScript public static function Multiply(
source : Vector2,
s : float
) : Vector2;

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.
s System.Single
Source Single Leave Site value.

Return Value

Microsoft.DirectX.Vector2
A Vector2 that is the result of the source parameter multiplied by the s parameter.


Vector2.Multiply(Single) Method (Microsoft.DirectX)

Vector2.Multiply Method

Multiplies the current 2-D vector with a single value.

Definition

Visual Basic Public Sub Multiply( _
ByVal s As Single _
)
C# public void Multiply(
float s
);
C++ public:
void Multiply(
float s
);
JScript public function Multiply(
s : float
);

Parameters

s System.Single
Source Single Leave Site value.


Vector2.Normalize Method ()

Returns the normalized version of a 2-D vector.

Overload List

public void Normalize();
public static Vector2 Normalize(Vector2);


Vector2.Normalize() Method (Microsoft.DirectX)

Vector2.Normalize Method

Returns the normalized version of a 2-D vector.

Definition

Visual Basic | Public Sub Normalize()
C# | public void Normalize();
C++ public:
void Normalize();
JScript | public function Normalize();


Vector2.Normalize(Vector2) Method (Microsoft.DirectX)

Vector2.Normalize Method

Returns the normalized version of a 2-D vector.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal source As Vector2 _
) As Vector2
C# public static Vector2 Normalize(
Vector2 source
);
C++ public:
static Vector2 Normalize(
Vector2 source
);
JScript public static function Normalize(
source : Vector2
) : Vector2;

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the normalized version of the vector.


Vector2.op_Addition(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.op_Addition Method

Adds two 2-D vectors.

Definition

Visual Basic Public Shared Function op_Addition( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 op_Addition(
Vector2 left,
Vector2 right
);
C++ public:
static Vector2 operator+(
Vector2 left,
Vector2 right
);
JScript public static function op_Addition(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left Microsoft.DirectX.Vector2
The Vector2 structure to the left of the addition operator.
right Microsoft.DirectX.Vector2
The Vector2 structure to the right of the addition operator.

Return Value

Microsoft.DirectX.Vector2
Resulting Vector2 structure.


Vector2.op_Equality(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Boolean
C# public static bool op_Equality(
Vector2 left,
Vector2 right
);
C++ public:
static bool operator==(
Vector2 left,
Vector2 right
);
JScript public static function op_Equality(
left : Vector2,
right : Vector2
) : boolean;

Parameters

left Microsoft.DirectX.Vector2
The Vector2 structure to the left of the equality operator.
right Microsoft.DirectX.Vector2
The Vector2 structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Vector2.op_Inequality(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Boolean
C# public static bool op_Inequality(
Vector2 left,
Vector2 right
);
C++ public:
static bool operator!=(
Vector2 left,
Vector2 right
);
JScript public static function op_Inequality(
left : Vector2,
right : Vector2
) : boolean;

Parameters

left Microsoft.DirectX.Vector2
The Vector2 structure to the left of the inequality operator.
right Microsoft.DirectX.Vector2
The Vector2 structure to the right of the inequality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Vector2.op_Multiply Method ()

Determines the product of a single value and a 2-D vector.

Overload List

public static Vector2 op_Multiply(float, Vector2);
public static Vector2 op_Multiply(Vector2, float);


Vector2.op_Multiply(Single,Vector2) Method (Microsoft.DirectX)

Vector2.op_Multiply Method

Determines the product of a single value and a 2-D vector.

Definition

Visual Basic Public Shared Function op_Multiply( _
ByVal right As Single, _
ByVal left As Vector2 _
) As Vector2
C# public static Vector2 op_Multiply(
float right,
Vector2 left
);
C++ public:
static Vector2 operator*(
float right,
Vector2 left
);
JScript public static function op_Multiply(
right : float,
left : Vector2
) : Vector2;

Parameters

right System.Single
Source Single Leave Site structure.
left Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the product of the right and left parameters.


Vector2.op_Multiply(Vector2,Single) Method (Microsoft.DirectX)

Vector2.op_Multiply Method

Determines the product of a single value and a 2-D vector.

Definition

Visual Basic Public Shared Function op_Multiply( _
ByVal left As Vector2, _
ByVal right As Single _
) As Vector2
C# public static Vector2 op_Multiply(
Vector2 left,
float right
);
C++ public:
static Vector2 operator*(
Vector2 left,
float right
);
JScript public static function op_Multiply(
left : Vector2,
right : float
) : Vector2;

Parameters

left Microsoft.DirectX.Vector2
Source Vector2 structure.
right System.Single
Source Single Leave Site structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the product of the right and left parameters.


Vector2.op_Subtraction(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.op_Subtraction Method

Subtracts two 2-D vectors.

Definition

Visual Basic Public Shared Function op_Subtraction( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 op_Subtraction(
Vector2 left,
Vector2 right
);
C++ public:
static Vector2 operator-(
Vector2 left,
Vector2 right
);
JScript public static function op_Subtraction(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left Microsoft.DirectX.Vector2
The Vector2 structure to the left of the subtraction operator.
right Microsoft.DirectX.Vector2
The Vector2 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector2
Resulting Vector2 structure.


Vector2.op_UnaryNegation(Vector2) Method (Microsoft.DirectX)

Vector2.op_UnaryNegation Method

Negates the vector.

Definition

Visual Basic Public Shared Function op_UnaryNegation( _
ByVal vec As Vector2 _
) As Vector2
C# public static Vector2 op_UnaryNegation(
Vector2 vec
);
C++ public:
static Vector2 operator-(
Vector2 vec
);
JScript public static function op_UnaryNegation(
vec : Vector2
) : Vector2;

Parameters

vec Microsoft.DirectX.Vector2
Source Vector2 structure.

Return Value

Microsoft.DirectX.Vector2
The Vector2 structure that is the result of the negation operation.

Remarks

This method switches positive and negative values of the Vector2 structure's X and Y fields.


Vector2.Scale Method ()

Scales a 2-D vector.

Overload List

public void Scale(float);
public static Vector2 Scale(Vector2, float);


Vector2.Scale(Single) Method (Microsoft.DirectX)

Vector2.Scale Method

Scales a 2-D vector.

Definition

Visual Basic Public Sub Scale( _
ByVal scalingFactor As Single _
)
C# public void Scale(
float scalingFactor
);
C++ public:
void Scale(
float scalingFactor
);
JScript public function Scale(
scalingFactor : float
);

Parameters

scalingFactor System.Single
Scaling value.


Vector2.Scale(Vector2,Single) Method (Microsoft.DirectX)

Vector2.Scale Method

Scales a 2-D vector.

Definition

Visual Basic Public Shared Function Scale( _
ByVal source As Vector2, _
ByVal scalingFactor As Single _
) As Vector2
C# public static Vector2 Scale(
Vector2 source,
float scalingFactor
);
C++ public:
static Vector2 Scale(
Vector2 source,
float scalingFactor
);
JScript public static function Scale(
source : Vector2,
scalingFactor : float
) : Vector2;

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.
scalingFactor System.Single
Scaling value.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the scaled vector.


Vector2.Subtract Method ()

Subtracts two 2-D vectors.

Overload List

public void Subtract(Vector2);
public static Vector2 Subtract(Vector2, Vector2);


Vector2.Subtract(Vector2) Method (Microsoft.DirectX)

Vector2.Subtract Method

Subtracts two 2-D vectors.

Definition

Visual Basic Public Sub Subtract( _
ByVal source As Vector2 _
)
C# public void Subtract(
Vector2 source
);
C++ public:
void Subtract(
Vector2 source
);
JScript public function Subtract(
source : Vector2
);

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 a structure to subtract from the current Vector2 instance.


Vector2.Subtract(Vector2,Vector2) Method (Microsoft.DirectX)

Vector2.Subtract Method

Subtracts two 2-D vectors.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal left As Vector2, _
ByVal right As Vector2 _
) As Vector2
C# public static Vector2 Subtract(
Vector2 left,
Vector2 right
);
C++ public:
static Vector2 Subtract(
Vector2 left,
Vector2 right
);
JScript public static function Subtract(
left : Vector2,
right : Vector2
) : Vector2;

Parameters

left Microsoft.DirectX.Vector2
Source Vector2 structure to the left of the subtraction operator.
right Microsoft.DirectX.Vector2
Source Vector2 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that is the result of the operation.


Vector2.ToString() Method (Microsoft.DirectX)

Vector2.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Vector2.Transform Method ()

Transforms a 2-D vector or an array of 2-D vectors by a given matrix.

Overload List

public static Vector4 Transform(Vector2, Matrix);
public static Vector4[] Transform(Vector2[], Matrix);


Vector2.Transform(Vector2[],Matrix) Method (Microsoft.DirectX)

Vector2.Transform Method

Transforms a 2-D vector or an array of 2-D vectors by a given matrix.

Definition

Visual Basic Public Shared Function Transform( _
ByVal vector() As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector4()
C# public static Vector4[] Transform(
Vector2[] vector,
Matrix sourceMatrix
);
C++ public:
static array<Vector4>^ Transform(
array<Vector2>^ vector,
Matrix sourceMatrix
);
JScript public static function Transform(
vector : Vector2[],
sourceMatrix : Matrix
) : Vector4[];

Parameters

vector Microsoft.DirectX.Vector2[]
Array of source Vector2 structures.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4[]
Array of Vector4 structures that are the result of the method.

Remarks

This method transforms an array of vectors passed into vector by the matrix sourceMatrix.


Vector2.Transform(Vector2,Matrix) Method (Microsoft.DirectX)

Vector2.Transform Method

Transforms a 2-D vector or an array of 2-D vectors by a given matrix.

Definition

Visual Basic Public Shared Function Transform( _
ByVal source As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector2 source,
Matrix sourceMatrix
);
C++ public:
static Vector4 Transform(
Vector2 source,
Matrix sourceMatrix
);
JScript public static function Transform(
source : Vector2,
sourceMatrix : Matrix
) : Vector4;

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.

Remarks

This method transforms the vector source (x, y, 0, 1) by the matrix sourceMatrix.


Vector2.TransformCoordinate Method ()

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Overload List

public void TransformCoordinate(Matrix);
public static Vector2 TransformCoordinate(Vector2, Matrix);
public static Vector2[] TransformCoordinate(Vector2[], Matrix);

Remarks

This method transforms the source vector, source (x, y, 0, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.


Vector2.TransformCoordinate(Matrix) Method (Microsoft.DirectX)

Vector2.TransformCoordinate Method

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic Public Sub TransformCoordinate( _
ByVal sourceMatrix As Matrix _
)
C# public void TransformCoordinate(
Matrix sourceMatrix
);
C++ public:
void TransformCoordinate(
Matrix sourceMatrix
);
JScript public function TransformCoordinate(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Remarks

This method transforms the source vector, source (x, y, 0, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.


Vector2.TransformCoordinate(Vector2[],Matrix) Method (Microsoft.DirectX)

Vector2.TransformCoordinate Method

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic Public Shared Function TransformCoordinate( _
ByVal vector() As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector2()
C# public static Vector2[] TransformCoordinate(
Vector2[] vector,
Matrix sourceMatrix
);
C++ public:
static array<Vector2>^ TransformCoordinate(
array<Vector2>^ vector,
Matrix sourceMatrix
);
JScript public static function TransformCoordinate(
vector : Vector2[],
sourceMatrix : Matrix
) : Vector2[];

Parameters

vector Microsoft.DirectX.Vector2[]
Array of source Vector2 structures.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2[]
Array of Vector2 structures that represent the results of the method.

Remarks

This method transforms the source vector, source (x, y, 0, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.


Vector2.TransformCoordinate(Vector2,Matrix) Method (Microsoft.DirectX)

Vector2.TransformCoordinate Method

Transforms a 2-D vector or an array of 2-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic Public Shared Function TransformCoordinate( _
ByVal source As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector2
C# public static Vector2 TransformCoordinate(
Vector2 source,
Matrix sourceMatrix
);
C++ public:
static Vector2 TransformCoordinate(
Vector2 source,
Matrix sourceMatrix
);
JScript public static function TransformCoordinate(
source : Vector2,
sourceMatrix : Matrix
) : Vector2;

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that represents the results of the method.

Remarks

This method transforms the source vector, source (x, y, 0, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.


Vector2.TransformNormal Method ()

Transforms the 2-D vector normal by a given matrix.

Overload List

public void TransformNormal(Matrix);
public static Vector2 TransformNormal(Vector2, Matrix);
public static Vector2[] TransformNormal(Vector2[], Matrix);

Remarks

This method transforms the vector normal (x, y, 0, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.


Vector2.TransformNormal(Matrix) Method (Microsoft.DirectX)

Vector2.TransformNormal Method

Transforms the 2-D vector normal by a given matrix.

Definition

Visual Basic Public Sub TransformNormal( _
ByVal sourceMatrix As Matrix _
)
C# public void TransformNormal(
Matrix sourceMatrix
);
C++ public:
void TransformNormal(
Matrix sourceMatrix
);
JScript public function TransformNormal(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.


Vector2.TransformNormal(Vector2[],Matrix) Method (Microsoft.DirectX)

Vector2.TransformNormal Method

Transforms the 2-D vector normal by a given matrix.

Definition

Visual Basic Public Shared Function TransformNormal( _
ByVal vector() As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector2()
C# public static Vector2[] TransformNormal(
Vector2[] vector,
Matrix sourceMatrix
);
C++ public:
static array<Vector2>^ TransformNormal(
array<Vector2>^ vector,
Matrix sourceMatrix
);
JScript public static function TransformNormal(
vector : Vector2[],
sourceMatrix : Matrix
) : Vector2[];

Parameters

vector Microsoft.DirectX.Vector2[]
Array of source Vector2 structures.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2[]
Array of Vector2 structures that contain the results of this method.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.


Vector2.TransformNormal(Vector2,Matrix) Method (Microsoft.DirectX)

Vector2.TransformNormal Method

Transforms the 2-D vector normal by a given matrix.

Definition

Visual Basic Public Shared Function TransformNormal( _
ByVal source As Vector2, _
ByVal sourceMatrix As Matrix _
) As Vector2
C# public static Vector2 TransformNormal(
Vector2 source,
Matrix sourceMatrix
);
C++ public:
static Vector2 TransformNormal(
Vector2 source,
Matrix sourceMatrix
);
JScript public static function TransformNormal(
source : Vector2,
sourceMatrix : Matrix
) : Vector2;

Parameters

source Microsoft.DirectX.Vector2
Source Vector2 structure.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector2
A Vector2 structure that contains the results of this method.

Remarks

This method transforms the vector normal (x, y, 0, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.


Vector2.Vector2 Constructor ()

Initializes a new instance of the Vector2 class.

Overload List

public Vector2();
public Vector2(float, float);


Vector2.Vector2() Constructor (Microsoft.DirectX)

Vector2.Vector2 Constructor

Initializes a new instance of the Vector2 class.

Definition

Visual Basic | Public Sub New()
C# | public Vector2();
C++ public:
Vector2();
JScript | public function Vector2();


Vector2.Vector2(Single,Single) Constructor (Microsoft.DirectX)

Vector2.Vector2 Constructor

Initializes a new instance of the Vector2 class.

Definition

Visual Basic Public Sub New( _
ByVal valueX As Single, _
ByVal valueY As Single _
)
C# public Vector2(
float valueX,
float valueY
);
C++ public:
Vector2(
float valueX,
float valueY
);
JScript public function Vector2(
valueX : float,
valueY : float
);

Parameters

valueX System.Single
Initial X value.
valueY System.Single
Initial Y value.


Vector2.Empty Property (Microsoft.DirectX)

Vector2.Empty Property

Retrieves an empty 2-D vector.

Definition

Visual Basic | Public Shared ReadOnly Property Empty As Vector2
C# | public static Vector2 Empty { get; }
C++ public:
static property Vector2 Empty {
Vector2 get();
}
JScript | public static function get Empty() : Vector2

Property Value

Microsoft.DirectX.Vector2
Empty 2-D Vector2 instance.

This property is read-only.


Vector2.X Field (Microsoft.DirectX)

Vector2.X Field

Retrieves or sets the x component of a 2-D vector.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
A Single Leave Site value that represents the x component of a 2-D vector.

This field is read/write.


Vector2.Y Field (Microsoft.DirectX)

Vector2.Y Field

Retrieves or sets the y component of a 2-D vector.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
A Single Leave Site value that represents the y component of a 2-D vector.

This field is read/write.


Vector3 Structure (Microsoft.DirectX)

Vector3 Structure

How Do I...?
  • Set Up a View Matrix

Describes and manipulates a vector in three-dimensional (3-D) space.

Definition

Visual Basic | Public Structure Vector3
C# | public struct Vector3
C++ | public value class Vector3 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
X | Retrieves or sets the x component of a 3-D vector.
Y | Retrieves or sets the y component of a 3-D vector.
Z | Retrieves or sets the z component of a 3-D vector.

Methods

Method | Description
Add | Adds two 3-D vectors.
static (Shared in Visual Basic) BaryCentric | Returns a point in barycentric coordinates, using specified 3-D vectors.
static (Shared in Visual Basic) CatmullRom | Performs a Catmull-Rom interpolation using specified 3-D vectors.
static (Shared in Visual Basic) Cross | Determines the cross product of two 3-D vectors.
static (Shared in Visual Basic) Dot | Determines the dot product of two 3-D vectors.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic) Hermite | Performs a Hermite spline interpolation using the specified 3-D vectors.
Length | Returns the length of a 3-D vector.
LengthSq | Returns the square of the length of a 3-D vector.
static (Shared in Visual Basic) Lerp | Performs a linear interpolation between two 3-D vectors.
Maximize | Returns a 3-D vector that is made up of the largest components of two 3-D vectors.
Minimize | Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.
Multiply | Multiplies a 3-D vector by a Single Leave Site value.
Normalize | Returns the normalized version of a 3-D vector.
static (Shared in Visual Basic) op_Addition | Adds two vectors.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Multiply | Determines the product of a single value and a 3-D vector.
static (Shared in Visual Basic) op_Subtraction | Subtracts two 3-D vectors.
static (Shared in Visual Basic) op_UnaryNegation | Negates the vector.
Project | Projects a vector from object space into screen space.
Scale | Scales a 3-D vector.
Subtract | Subtracts two 3-D vectors.
ToString | Obtains a string representation of the current instance.
static (Shared in Visual Basic) Transform | Transforms a 3-D vector or an array of 3-D vectors by a given matrix.
TransformCoordinate | Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.
TransformNormal | Transforms a 3-D vector normal by the given matrix.
Unproject | Projects a vector from screen space into object space.
Vector3 | Initializes a new instance of the Vector3 class.

Properties

Property | Description
static (Shared in Visual Basic) Empty | Retrieves an empty 3-D vector.

How Do I...?

Set Up a View Matrix

This example demonstrates how to initialize the view transformation matrix, which transforms world coordinates into camera or view space.

In the following C# code example, the vector components of the Vector3 structure form the arguments for the LookAtLH method, which builds a left-handed (LH) look-at matrix. The View transformation matrix is set to be equal to this look-at matrix.

The three input vectors represent the following, respectively:

  1. The eye point: [0, 3, -5].
  2. The camera look-at target: the origin [0, 0, 0].
  3. The current world's up-direction: usually [0, 1, 0].

              [C#]

using Microsoft.DirectX.Direct3D;

Device device = null;  // Create rendering device.

// Set up the view matrix. A view matrix can be defined given an eye point,
//   a point to view, and a direction for which way is up. Here, you set
//   the eye five units back along the z-axis and up three units, view the
//   origin, and define "up" to be in the y-direction.

device.Transform.View = Microsoft.DirectX.Matrix.LookAtLH(
                            new Vector3(0.0f, 3.0f, -5.0f),
                            new Vector3(0.0f, 0.0f, 0.0f),
                            new Vector3(0.0f, 1.0f, 0.0f));

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Vector3 Class


Vector3.Add Method ()

Adds two 3-D vectors.

Overload List

public void Add(Vector3);
public static Vector3 Add(Vector3, Vector3);


Vector3.Add(Vector3) Method (Microsoft.DirectX)

Vector3.Add Method

Adds two 3-D vectors.

Definition

Visual Basic Public Sub Add( _
ByVal source As Vector3 _
)
C# public void Add(
Vector3 source
);
C++ public:
void Add(
Vector3 source
);
JScript public function Add(
source : Vector3
);

Parameters

source Microsoft.DirectX.Vector3


Vector3.Add(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.Add Method

Adds two 3-D vectors.

Definition

Visual Basic Public Shared Function Add( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Add(
Vector3 left,
Vector3 right
);
C++ public:
static Vector3 Add(
Vector3 left,
Vector3 right
);
JScript public static function Add(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3.
right Microsoft.DirectX.Vector3
Source Vector3.

Return Value

Microsoft.DirectX.Vector3
Sum of the two Vector3 structures.


Vector3.BaryCentric(Vector3,Vector3,Vector3,Single,Single) Method (Microsoft.DirectX)

Vector3.BaryCentric Method

Returns a point in barycentric coordinates, using specified 3-D vectors.

Definition

Visual Basic Public Shared Function BaryCentric( _
ByVal v1 As Vector3, _
ByVal v2 As Vector3, _
ByVal v3 As Vector3, _
ByVal f As Single, _
ByVal g As Single _
) As Vector3
C# public static Vector3 BaryCentric(
Vector3 v1,
Vector3 v2,
Vector3 v3,
float f,
float g
);
C++ public:
static Vector3 BaryCentric(
Vector3 v1,
Vector3 v2,
Vector3 v3,
float f,
float g
);
JScript public static function BaryCentric(
v1 : Vector3,
v2 : Vector3,
v3 : Vector3,
f : float,
g : float
) : Vector3;

Parameters

v1 Microsoft.DirectX.Vector3
Source Vector3 structure.
v2 Microsoft.DirectX.Vector3
Source Vector3 structure.
v3 Microsoft.DirectX.Vector3
Source Vector3 structure.
f System.Single
Weighting factor. See Remarks.
g System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure in barycentric coordinates.

Remarks

The Vector3.BaryCentric method provides a way to understand points in and around a triangle, regardless of where the triangle is actually located. This method returns the resulting point by using the following equation.

v1 + f(v2 - v1) + g(v3 - v1)

Any point in the plane v1v2v3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which v2 gets weighted into the result, and the f parameter controls the extent to which v3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which v1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle v1v2v3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line v1v3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line v1v2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line v2v3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.


Vector3.CatmullRom(Vector3,Vector3,Vector3,Vector3,Single) Method (Microsoft.DirectX)

Vector3.CatmullRom Method

Performs a Catmull-Rom interpolation using specified 3-D vectors.

Definition

Visual Basic Public Shared Function CatmullRom( _
ByVal position1 As Vector3, _
ByVal position2 As Vector3, _
ByVal position3 As Vector3, _
ByVal position4 As Vector3, _
ByVal weightingFactor As Single _
) As Vector3
C# public static Vector3 CatmullRom(
Vector3 position1,
Vector3 position2,
Vector3 position3,
Vector3 position4,
float weightingFactor
);
C++ public:
static Vector3 CatmullRom(
Vector3 position1,
Vector3 position2,
Vector3 position3,
Vector3 position4,
float weightingFactor
);
JScript public static function CatmullRom(
position1 : Vector3,
position2 : Vector3,
position3 : Vector3,
position4 : Vector3,
weightingFactor : float
) : Vector3;

Parameters

position1 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
position2 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
position3 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
position4 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of position1, v2 is the contents of position2, p3 is the contents of position3, p4 is the contents of position4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the Hermite spline equation.

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
Substituting for v1, v2, t1, t2 yields the following result.
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This result can be rearranged as follows:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

See Also

  • Vector2.CatmullRom
  • Vector4.CatmullRom


Vector3.Cross(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.Cross Method

Determines the cross product of two 3-D vectors.

Definition

Visual Basic Public Shared Function Cross( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Cross(
Vector3 left,
Vector3 right
);
C++ public:
static Vector3 Cross(
Vector3 left,
Vector3 right
);
JScript public static function Cross(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3 structure.
right Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the cross product of two 3-D vectors.

Remarks

The following C# example demonstrates how the Cross method finds the cross-product.

[C#]
Vector3 returnValue;
    returnValue.x = left.y * right.z - left.z * right.y;
    returnValue.y = left.z * right.x - left.x * right.z;
    returnValue.z = left.x * right.y - left.y * right.x;

See Also

  • Dot


Vector3.Dot(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.Dot Method

Determines the dot product of two 3-D vectors.

Definition

Visual Basic Public Shared Function Dot( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Single
C# public static float Dot(
Vector3 left,
Vector3 right
);
C++ public:
static float Dot(
Vector3 left,
Vector3 right
);
JScript public static function Dot(
left : Vector3,
right : Vector3
) : float;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3 structure.
right Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that is the dot product.

See Also

  • Cross


Vector3.Equals(Object) Method (Microsoft.DirectX)

Vector3.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the current instance is equal to the specified object, or false if it is not.


Vector3.GetHashCode() Method (Microsoft.DirectX)

Vector3.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Vector3.Hermite(Vector3,Vector3,Vector3,Vector3,Single) Method (Microsoft.DirectX)

Vector3.Hermite Method

Performs a Hermite spline interpolation using the specified 3-D vectors.

Definition

Visual Basic Public Shared Function Hermite( _
ByVal position As Vector3, _
ByVal tangent As Vector3, _
ByVal position2 As Vector3, _
ByVal tangent2 As Vector3, _
ByVal weightingFactor As Single _
) As Vector3
C# public static Vector3 Hermite(
Vector3 position,
Vector3 tangent,
Vector3 position2,
Vector3 tangent2,
float weightingFactor
);
C++ public:
static Vector3 Hermite(
Vector3 position,
Vector3 tangent,
Vector3 position2,
Vector3 tangent2,
float weightingFactor
);
JScript public static function Hermite(
position : Vector3,
tangent : Vector3,
position2 : Vector3,
tangent2 : Vector3,
weightingFactor : float
) : Vector3;

Parameters

position Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
tangent Microsoft.DirectX.Vector3
Source Vector3 structure that is a tangent vector.
position2 Microsoft.DirectX.Vector3
Source Vector3 structure that is a position vector.
tangent2 Microsoft.DirectX.Vector3
Source Vector3 structure that is a tangent vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (position, tangent) to (position2, tangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of the ease-in, ease-out spline. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of position, v2 is the contents of position2, t1 is the contents of tangent, t2 is the contents of tangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

These properties yield the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
Which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.


Vector3.Length Method ()

Returns the length of a 3-D vector.

Overload List

public float Length();
public static float Length(Vector3);

See Also

  • LengthSq


Vector3.Length() Method (Microsoft.DirectX)

Vector3.Length Method

Returns the length of a 3-D vector.

Definition

Visual Basic | Public Function Length() As Single
C# | public float Length();
C++ public:
float Length();
JScript | public function Length() : float;

Return Value

System.Single
A Single Leave Site value that contains the vector's length.

See Also

  • LengthSq


Vector3.Length(Vector3) Method (Microsoft.DirectX)

Vector3.Length Method

Returns the length of a 3-D vector.

Definition

Visual Basic Public Shared Function Length( _
ByVal source As Vector3 _
) As Single
C# public static float Length(
Vector3 source
);
C++ public:
static float Length(
Vector3 source
);
JScript public static function Length(
source : Vector3
) : float;

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that contains the vector's length.

See Also

  • LengthSq


Vector3.LengthSq Method ()

Returns the square of the length of a 3-D vector.

Overload List

public float LengthSq();
public static float LengthSq(Vector3);

See Also

  • Length


Vector3.LengthSq() Method (Microsoft.DirectX)

Vector3.LengthSq Method

Returns the square of the length of a 3-D vector.

Definition

Visual Basic | Public Function LengthSq() As Single
C# | public float LengthSq();
C++ public:
float LengthSq();
JScript | public function LengthSq() : float;

Return Value

System.Single
A Single Leave Site value that contains the vector's squared length.

See Also

  • Length


Vector3.LengthSq(Vector3) Method (Microsoft.DirectX)

Vector3.LengthSq Method

Returns the square of the length of a 3-D vector.

Definition

Visual Basic Public Shared Function LengthSq( _
ByVal source As Vector3 _
) As Single
C# public static float LengthSq(
Vector3 source
);
C++ public:
static float LengthSq(
Vector3 source
);
JScript public static function LengthSq(
source : Vector3
) : float;

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

System.Single
A Single Leave Site value that contains the vector's squared length.

See Also

  • Length


Vector3.Lerp(Vector3,Vector3,Single) Method (Microsoft.DirectX)

Vector3.Lerp Method

Performs a linear interpolation between two 3-D vectors.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal left As Vector3, _
ByVal right As Vector3, _
ByVal interpolater As Single _
) As Vector3
C# public static Vector3 Lerp(
Vector3 left,
Vector3 right,
float interpolater
);
C++ public:
static Vector3 Lerp(
Vector3 left,
Vector3 right,
float interpolater
);
JScript public static function Lerp(
left : Vector3,
right : Vector3,
interpolater : float
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3 structure.
right Microsoft.DirectX.Vector3
Source Vector3 structure.
interpolater System.Single
Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

left + interpolater(right - left).


Vector3.Maximize Method ()

Returns a 3-D vector that is made up of the largest components of two 3-D vectors.

Overload List

public void Maximize(Vector3);
public static Vector3 Maximize(Vector3, Vector3);

See Also

  • Minimize


Vector3.Maximize(Vector3) Method (Microsoft.DirectX)

Vector3.Maximize Method

Returns a 3-D vector that is made up of the largest components of two 3-D vectors.

Definition

Visual Basic Public Sub Maximize( _
ByVal source As Vector3 _
)
C# public void Maximize(
Vector3 source
);
C++ public:
void Maximize(
Vector3 source
);
JScript public function Maximize(
source : Vector3
);

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.

See Also

  • Minimize


Vector3.Maximize(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.Maximize Method

Returns a 3-D vector that is made up of the largest components of two 3-D vectors.

Definition

Visual Basic Public Shared Function Maximize( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Maximize(
Vector3 left,
Vector3 right
);
C++ public:
static Vector3 Maximize(
Vector3 left,
Vector3 right
);
JScript public static function Maximize(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3 structure.
right Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is made up of the largest components of the two vectors.

See Also

  • Minimize


Vector3.Minimize Method ()

Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.

Overload List

public void Minimize(Vector3);
public static Vector3 Minimize(Vector3, Vector3);

See Also

  • Maximize


Vector3.Minimize(Vector3) Method (Microsoft.DirectX)

Vector3.Minimize Method

Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.

Definition

Visual Basic Public Sub Minimize( _
ByVal source As Vector3 _
)
C# public void Minimize(
Vector3 source
);
C++ public:
void Minimize(
Vector3 source
);
JScript public function Minimize(
source : Vector3
);

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.

See Also

  • Maximize


Vector3.Minimize(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.Minimize Method

Returns a 3-D vector that is made up of the smallest components of two 3-D vectors.

Definition

Visual Basic Public Shared Function Minimize( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Minimize(
Vector3 left,
Vector3 right
);
C++ public:
static Vector3 Minimize(
Vector3 left,
Vector3 right
);
JScript public static function Minimize(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3 structure.
right Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is made up of the smallest components of the two vectors.

See Also

  • Maximize


Vector3.Multiply Method ()

Multiplies a 3-D vector by a Single Leave Site value.

Overload List

public void Multiply(float);
public static Vector3 Multiply(Vector3, float);


Vector3.Multiply(Vector3,Single) Method (Microsoft.DirectX)

Vector3.Multiply Method

Multiplies a 3-D vector by a Single Leave Site value.

Definition

Visual Basic Public Shared Function Multiply( _
ByVal source As Vector3, _
ByVal f As Single _
) As Vector3
C# public static Vector3 Multiply(
Vector3 source,
float f
);
C++ public:
static Vector3 Multiply(
Vector3 source,
float f
);
JScript public static function Multiply(
source : Vector3,
f : float
) : Vector3;

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.
f System.Single
Source Single Leave Site value used as a multiplier.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is multiplied by the Single Leave Site value.


Vector3.Multiply(Single) Method (Microsoft.DirectX)

Vector3.Multiply Method

Multiplies a 3-D vector by a Single Leave Site value.

Definition

Visual Basic Public Sub Multiply( _
ByVal s As Single _
)
C# public void Multiply(
float s
);
C++ public:
void Multiply(
float s
);
JScript public function Multiply(
s : float
);

Parameters

s System.Single
Source Single Leave Site value used as a multiplier.


Vector3.Normalize Method ()

Returns the normalized version of a 3-D vector.

Overload List

public void Normalize();
public static Vector3 Normalize(Vector3);


Vector3.Normalize() Method (Microsoft.DirectX)

Vector3.Normalize Method

Returns the normalized version of a 3-D vector.

Definition

Visual Basic | Public Sub Normalize()
C# | public void Normalize();
C++ public:
void Normalize();
JScript | public function Normalize();


Vector3.Normalize(Vector3) Method (Microsoft.DirectX)

Vector3.Normalize Method

Returns the normalized version of a 3-D vector.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal source As Vector3 _
) As Vector3
C# public static Vector3 Normalize(
Vector3 source
);
C++ public:
static Vector3 Normalize(
Vector3 source
);
JScript public static function Normalize(
source : Vector3
) : Vector3;

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the normalized version of the specified vector.


Vector3.op_Addition(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.op_Addition Method

Adds two vectors.

Definition

Visual Basic Public Shared Function op_Addition( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 op_Addition(
Vector3 left,
Vector3 right
);
C++ public:
static Vector3 operator+(
Vector3 left,
Vector3 right
);
JScript public static function op_Addition(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3 structure.
right Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that contains the sum of the parameters.


Vector3.op_Equality(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Boolean
C# public static bool op_Equality(
Vector3 left,
Vector3 right
);
C++ public:
static bool operator==(
Vector3 left,
Vector3 right
);
JScript public static function op_Equality(
left : Vector3,
right : Vector3
) : boolean;

Parameters

left Microsoft.DirectX.Vector3
The Vector3 structure to the left of the equality operator.
right Microsoft.DirectX.Vector3
The Vector3 structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Vector3.op_Inequality(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Boolean
C# public static bool op_Inequality(
Vector3 left,
Vector3 right
);
C++ public:
static bool operator!=(
Vector3 left,
Vector3 right
);
JScript public static function op_Inequality(
left : Vector3,
right : Vector3
) : boolean;

Parameters

left Microsoft.DirectX.Vector3
The Vector3 structure to the left of the inequality operator.
right Microsoft.DirectX.Vector3
The Vector3 structure to the right of the inequality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Vector3.op_Multiply Method ()

Determines the product of a single value and a 3-D vector.

Overload List

public static Vector3 op_Multiply(float, Vector3);
public static Vector3 op_Multiply(Vector3, float);


Vector3.op_Multiply(Single,Vector3) Method (Microsoft.DirectX)

Vector3.op_Multiply Method

Determines the product of a single value and a 3-D vector.

Definition

Visual Basic Public Shared Function op_Multiply( _
ByVal right As Single, _
ByVal left As Vector3 _
) As Vector3
C# public static Vector3 op_Multiply(
float right,
Vector3 left
);
C++ public:
static Vector3 operator*(
float right,
Vector3 left
);
JScript public static function op_Multiply(
right : float,
left : Vector3
) : Vector3;

Parameters

right System.Single
Source Single Leave Site structure.
left Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the product of the right and left parameters.


Vector3.op_Multiply(Vector3,Single) Method (Microsoft.DirectX)

Vector3.op_Multiply Method

Determines the product of a single value and a 3-D vector.

Definition

Visual Basic Public Shared Function op_Multiply( _
ByVal left As Vector3, _
ByVal right As Single _
) As Vector3
C# public static Vector3 op_Multiply(
Vector3 left,
float right
);
C++ public:
static Vector3 operator*(
Vector3 left,
float right
);
JScript public static function op_Multiply(
left : Vector3,
right : float
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3 structure.
right System.Single
Source Single Leave Site structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the product of the right and left parameters.


Vector3.op_Subtraction(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.op_Subtraction Method

Subtracts two 3-D vectors.

Definition

Visual Basic Public Shared Function op_Subtraction( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 op_Subtraction(
Vector3 left,
Vector3 right
);
C++ public:
static Vector3 operator-(
Vector3 left,
Vector3 right
);
JScript public static function op_Subtraction(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
The Vector3 structure to the left of the subtraction operator.
right Microsoft.DirectX.Vector3
The Vector3 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector3
Resulting Vector3 structure.


Vector3.op_UnaryNegation(Vector3) Method (Microsoft.DirectX)

Vector3.op_UnaryNegation Method

Negates the vector.

Definition

Visual Basic Public Shared Function op_UnaryNegation( _
ByVal vec As Vector3 _
) As Vector3
C# public static Vector3 op_UnaryNegation(
Vector3 vec
);
C++ public:
static Vector3 operator-(
Vector3 vec
);
JScript public static function op_UnaryNegation(
vec : Vector3
) : Vector3;

Parameters

vec Microsoft.DirectX.Vector3
Source Vector3 structure.

Return Value

Microsoft.DirectX.Vector3
The Vector3 structure that is the result of the operation.

Remarks

This method switches positive and negative values of the Vector3 structure's X, Y, and Z fields.


Vector3.Project Method ()

Projects a vector from object space into screen space.

Overload List

public void Project(object, Matrix, Matrix, Matrix);
public static Vector3 Project(Vector3, object, Matrix, Matrix, Matrix);

See Also

  • Unproject


Vector3.Project(Object,Matrix,Matrix,Matrix) Method (Microsoft.DirectX)

Vector3.Project Method

Projects a vector from object space into screen space.

Definition

Visual Basic Public Sub Project( _
ByVal viewport As Object, _
ByVal projection As Matrix, _
ByVal view As Matrix, _
ByVal world As Matrix _
)
C# public void Project(
object viewport,
Matrix projection,
Matrix view,
Matrix world
);
C++ public:
void Project(
Object^ viewport,
Matrix projection,
Matrix view,
Matrix world
);
JScript public function Project(
viewport : Object,
projection : Matrix,
view : Matrix,
world : Matrix
);

Parameters

viewport System.Object
An Object Leave Site structure that represents the viewport. Only Viewport structures are valid for this parameter.
projection Microsoft.DirectX.Matrix
A Matrix structure that represents the projection matrix.
view Microsoft.DirectX.Matrix
A Matrix structure that represents the view matrix.
world Microsoft.DirectX.Matrix
A Matrix structure that represents the world matrix.

See Also

  • Unproject


Vector3.Project(Vector3,Object,Matrix,Matrix,Matrix) Method (Microsoft.DirectX)

Vector3.Project Method

Projects a vector from object space into screen space.

Definition

Visual Basic Public Shared Function Project( _
ByVal v As Vector3, _
ByVal viewport As Object, _
ByVal projection As Matrix, _
ByVal view As Matrix, _
ByVal world As Matrix _
) As Vector3
C# public static Vector3 Project(
Vector3 v,
object viewport,
Matrix projection,
Matrix view,
Matrix world
);
C++ public:
static Vector3 Project(
Vector3 v,
Object^ viewport,
Matrix projection,
Matrix view,
Matrix world
);
JScript public static function Project(
v : Vector3,
viewport : Object,
projection : Matrix,
view : Matrix,
world : Matrix
) : Vector3;

Parameters

v Microsoft.DirectX.Vector3
The source Vector3 structure.
viewport System.Object
An Object Leave Site structure that represents the viewport. Only Viewport structures are valid for this parameter.
projection Microsoft.DirectX.Matrix
A Matrix structure that represents the projection matrix.
view Microsoft.DirectX.Matrix
A Matrix structure that represents the view matrix.
world Microsoft.DirectX.Matrix
A Matrix structure that represents the world matrix.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the vector projected from object space into screen space.

See Also

  • Unproject


Vector3.Scale Method ()

Scales a 3-D vector.

Overload List

public void Scale(float);
public static Vector3 Scale(Vector3, float);


Vector3.Scale(Single) Method (Microsoft.DirectX)

Vector3.Scale Method

Scales a 3-D vector.

Definition

Visual Basic Public Sub Scale( _
ByVal scalingFactor As Single _
)
C# public void Scale(
float scalingFactor
);
C++ public:
void Scale(
float scalingFactor
);
JScript public function Scale(
scalingFactor : float
);

Parameters

scalingFactor System.Single
Scaling value.


Vector3.Scale(Vector3,Single) Method (Microsoft.DirectX)

Vector3.Scale Method

Scales a 3-D vector.

Definition

Visual Basic Public Shared Function Scale( _
ByVal source As Vector3, _
ByVal scalingFactor As Single _
) As Vector3
C# public static Vector3 Scale(
Vector3 source,
float scalingFactor
);
C++ public:
static Vector3 Scale(
Vector3 source,
float scalingFactor
);
JScript public static function Scale(
source : Vector3,
scalingFactor : float
) : Vector3;

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.
scalingFactor System.Single
Scaling value.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the scaled vector.


Vector3.Subtract Method ()

Subtracts two 3-D vectors.

Overload List

public void Subtract(Vector3);
public static Vector3 Subtract(Vector3, Vector3);


Vector3.Subtract(Vector3) Method (Microsoft.DirectX)

Vector3.Subtract Method

Subtracts two 3-D vectors.

Definition

Visual Basic Public Sub Subtract( _
ByVal source As Vector3 _
)
C# public void Subtract(
Vector3 source
);
C++ public:
void Subtract(
Vector3 source
);
JScript public function Subtract(
source : Vector3
);

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure to subtract from the current instance.


Vector3.Subtract(Vector3,Vector3) Method (Microsoft.DirectX)

Vector3.Subtract Method

Subtracts two 3-D vectors.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal left As Vector3, _
ByVal right As Vector3 _
) As Vector3
C# public static Vector3 Subtract(
Vector3 left,
Vector3 right
);
C++ public:
static Vector3 Subtract(
Vector3 left,
Vector3 right
);
JScript public static function Subtract(
left : Vector3,
right : Vector3
) : Vector3;

Parameters

left Microsoft.DirectX.Vector3
Source Vector3 structure to the left of the subtraction operator.
right Microsoft.DirectX.Vector3
Source Vector3 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the result of the operation.


Vector3.ToString() Method (Microsoft.DirectX)

Vector3.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Vector3.Transform Method ()

Transforms a 3-D vector or an array of 3-D vectors by a given matrix.

Overload List

public static Vector4 Transform(Vector3, Matrix);
public static Vector4[] Transform(Vector3[], Matrix);

See Also

  • TransformCoordinate
  • TransformNormal


Vector3.Transform(Vector3[],Matrix) Method (Microsoft.DirectX)

Vector3.Transform Method

Transforms a 3-D vector or an array of 3-D vectors by a given matrix.

Definition

Visual Basic Public Shared Function Transform( _
ByVal vector() As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector4()
C# public static Vector4[] Transform(
Vector3[] vector,
Matrix sourceMatrix
);
C++ public:
static array<Vector4>^ Transform(
array<Vector3>^ vector,
Matrix sourceMatrix
);
JScript public static function Transform(
vector : Vector3[],
sourceMatrix : Matrix
) : Vector4[];

Parameters

vector Microsoft.DirectX.Vector3[]
Array of source Vector3 structures.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4[]
Array of Vector4 structures that are the result of the method.

Remarks

This method transforms an array of vectors passed into vector by the matrix sourceMatrix.

See Also

  • TransformCoordinate
  • TransformNormal


Vector3.Transform(Vector3,Matrix) Method (Microsoft.DirectX)

Vector3.Transform Method

Transforms a 3-D vector or an array of 3-D vectors by a given matrix.

Definition

Visual Basic Public Shared Function Transform( _
ByVal source As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector3 source,
Matrix sourceMatrix
);
C++ public:
static Vector4 Transform(
Vector3 source,
Matrix sourceMatrix
);
JScript public static function Transform(
source : Vector3,
sourceMatrix : Matrix
) : Vector4;

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.

Remarks

This method transforms the vector source (x, y, 0, 1) by the matrix sourceMatrix.

See Also

  • TransformCoordinate
  • TransformNormal


Vector3.TransformCoordinate Method ()

Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.

Overload List

public void TransformCoordinate(Matrix);
public static Vector3 TransformCoordinate(Vector3, Matrix);
public static Vector3[] TransformCoordinate(Vector3[], Matrix);

Remarks

This method transforms the source vector, source (x, y, z, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.

Note: Overloads of this method that accept a Matrix structure as a parameter are static.

See Also

  • Transform
  • TransformNormal


Vector3.TransformCoordinate(Matrix) Method (Microsoft.DirectX)

Vector3.TransformCoordinate Method

Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic Public Sub TransformCoordinate( _
ByVal sourceMatrix As Matrix _
)
C# public void TransformCoordinate(
Matrix sourceMatrix
);
C++ public:
void TransformCoordinate(
Matrix sourceMatrix
);
JScript public function TransformCoordinate(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Remarks

This method transforms the source vector, source (x, y, z, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.

Note: Overloads of this method that accept a Matrix structure as a parameter are static.

See Also

  • Transform
  • TransformNormal


Vector3.TransformCoordinate(Vector3[],Matrix) Method (Microsoft.DirectX)

Vector3.TransformCoordinate Method

Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic Public Shared Function TransformCoordinate( _
ByVal vector() As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector3()
C# public static Vector3[] TransformCoordinate(
Vector3[] vector,
Matrix sourceMatrix
);
C++ public:
static array<Vector3>^ TransformCoordinate(
array<Vector3>^ vector,
Matrix sourceMatrix
);
JScript public static function TransformCoordinate(
vector : Vector3[],
sourceMatrix : Matrix
) : Vector3[];

Parameters

vector Microsoft.DirectX.Vector3[]
Array of source Vector3 structures.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3[]
Array of Vector3 structures that represent the results of the method.

Remarks

This method transforms the source vector, source (x, y, z, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.

Note: Overloads of this method that accept a Matrix structure as a parameter are static.

See Also

  • Transform
  • TransformNormal


Vector3.TransformCoordinate(Vector3,Matrix) Method (Microsoft.DirectX)

Vector3.TransformCoordinate Method

Transforms a 3-D vector or an array of 3-D vectors by a given matrix, projecting the result back into w = 1.

Definition

Visual Basic Public Shared Function TransformCoordinate( _
ByVal source As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector3
C# public static Vector3 TransformCoordinate(
Vector3 source,
Matrix sourceMatrix
);
C++ public:
static Vector3 TransformCoordinate(
Vector3 source,
Matrix sourceMatrix
);
JScript public static function TransformCoordinate(
source : Vector3,
sourceMatrix : Matrix
) : Vector3;

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that represents the results of the method.

Remarks

This method transforms the source vector, source (x, y, z, 1), or all vectors in the vector parameter, by the matrix sourceMatrix, projecting the result back into w = 1.

Note: Overloads of this method that accept a Matrix structure as a parameter are static.

See Also

  • Transform
  • TransformNormal


Vector3.TransformNormal Method ()

Transforms a 3-D vector normal by the given matrix.

Overload List

public void TransformNormal(Matrix);
public static Vector3 TransformNormal(Vector3, Matrix);
public static Vector3[] TransformNormal(Vector3[], Matrix);

Remarks

This method transforms the vector normal (x, y, z, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

See Also

  • Transform
  • TransformCoordinate


Vector3.TransformNormal(Matrix) Method (Microsoft.DirectX)

Vector3.TransformNormal Method

Transforms a 3-D vector normal by the given matrix.

Definition

Visual Basic Public Sub TransformNormal( _
ByVal sourceMatrix As Matrix _
)
C# public void TransformNormal(
Matrix sourceMatrix
);
C++ public:
void TransformNormal(
Matrix sourceMatrix
);
JScript public function TransformNormal(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Remarks

This method transforms the vector normal (x, y, z, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

See Also

  • Transform
  • TransformCoordinate


Vector3.TransformNormal(Vector3[],Matrix) Method (Microsoft.DirectX)

Vector3.TransformNormal Method

Transforms a 3-D vector normal by the given matrix.

Definition

Visual Basic Public Shared Function TransformNormal( _
ByVal vector() As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector3()
C# public static Vector3[] TransformNormal(
Vector3[] vector,
Matrix sourceMatrix
);
C++ public:
static array<Vector3>^ TransformNormal(
array<Vector3>^ vector,
Matrix sourceMatrix
);
JScript public static function TransformNormal(
vector : Vector3[],
sourceMatrix : Matrix
) : Vector3[];

Parameters

vector Microsoft.DirectX.Vector3[]
Array of source Vector3 structures.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3[]
Array of Vector3 structures that contain the results of this method.

Remarks

This method transforms the vector normal (x, y, z, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

See Also

  • Transform
  • TransformCoordinate


Vector3.TransformNormal(Vector3,Matrix) Method (Microsoft.DirectX)

Vector3.TransformNormal Method

Transforms a 3-D vector normal by the given matrix.

Definition

Visual Basic Public Shared Function TransformNormal( _
ByVal source As Vector3, _
ByVal sourceMatrix As Matrix _
) As Vector3
C# public static Vector3 TransformNormal(
Vector3 source,
Matrix sourceMatrix
);
C++ public:
static Vector3 TransformNormal(
Vector3 source,
Matrix sourceMatrix
);
JScript public static function TransformNormal(
source : Vector3,
sourceMatrix : Matrix
) : Vector3;

Parameters

source Microsoft.DirectX.Vector3
Source Vector3 structure.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that contains the results of this method.

Remarks

This method transforms the vector normal (x, y, z, 0) of the source vector, or the array of vector structures, by the sourceMatrix matrix.

If you transform a normal by a non-affine matrix, the matrix you pass to this function should be the transpose of the inverse of the matrix you would use to transform a coordinate.

See Also

  • Transform
  • TransformCoordinate


Vector3.Unproject Method ()

Projects a vector from screen space into object space.

Overload List

public void Unproject(object, Matrix, Matrix, Matrix);
public static Vector3 Unproject(Vector3, object, Matrix, Matrix, Matrix);

See Also

  • Project


Vector3.Unproject(Object,Matrix,Matrix,Matrix) Method (Microsoft.DirectX)

Vector3.Unproject Method

Projects a vector from screen space into object space.

Definition

Visual Basic Public Sub Unproject( _
ByVal viewport As Object, _
ByVal projection As Matrix, _
ByVal view As Matrix, _
ByVal world As Matrix _
)
C# public void Unproject(
object viewport,
Matrix projection,
Matrix view,
Matrix world
);
C++ public:
void Unproject(
Object^ viewport,
Matrix projection,
Matrix view,
Matrix world
);
JScript public function Unproject(
viewport : Object,
projection : Matrix,
view : Matrix,
world : Matrix
);

Parameters

viewport System.Object
An Object Leave Site that represents the viewport.
projection Microsoft.DirectX.Matrix
A Matrix structure that represents the projection matrix.
view Microsoft.DirectX.Matrix
A Matrix structure that represents the view matrix.
world Microsoft.DirectX.Matrix
A Matrix structure that represents the world matrix.

See Also

  • Project


Vector3.Unproject(Vector3,Object,Matrix,Matrix,Matrix) Method (Microsoft.DirectX)

Vector3.Unproject Method

Projects a vector from screen space into object space.

Definition

Visual Basic Public Shared Function Unproject( _
ByVal v As Vector3, _
ByVal viewport As Object, _
ByVal projection As Matrix, _
ByVal view As Matrix, _
ByVal world As Matrix _
) As Vector3
C# public static Vector3 Unproject(
Vector3 v,
object viewport,
Matrix projection,
Matrix view,
Matrix world
);
C++ public:
static Vector3 Unproject(
Vector3 v,
Object^ viewport,
Matrix projection,
Matrix view,
Matrix world
);
JScript public static function Unproject(
v : Vector3,
viewport : Object,
projection : Matrix,
view : Matrix,
world : Matrix
) : Vector3;

Parameters

v Microsoft.DirectX.Vector3
Source Vector3 structure.
viewport System.Object
An Object Leave Site that represents the viewport.
projection Microsoft.DirectX.Matrix
A Matrix structure that represents the projection matrix.
view Microsoft.DirectX.Matrix
A Matrix structure that represents the view matrix.
world Microsoft.DirectX.Matrix
A Matrix structure that represents the world matrix.

Return Value

Microsoft.DirectX.Vector3
A Vector3 structure that is the vector projected from screen space into object space.

See Also

  • Project


Vector3.Vector3 Constructor ()

Initializes a new instance of the Vector3 class.

Overload List

public Vector3();
public Vector3(float, float, float);


Vector3.Vector3() Constructor (Microsoft.DirectX)

Vector3.Vector3 Constructor

Initializes a new instance of the Vector3 class.

Definition

Visual Basic | Public Sub New()
C# | public Vector3();
C++ public:
Vector3();
JScript | public function Vector3();


Vector3.Vector3(Single,Single,Single) Constructor (Microsoft.DirectX)

Vector3.Vector3 Constructor

Initializes a new instance of the Vector3 class.

Definition

Visual Basic Public Sub New( _
ByVal valueX As Single, _
ByVal valueY As Single, _
ByVal valueZ As Single _
)
C# public Vector3(
float valueX,
float valueY,
float valueZ
);
C++ public:
Vector3(
float valueX,
float valueY,
float valueZ
);
JScript public function Vector3(
valueX : float,
valueY : float,
valueZ : float
);

Parameters

valueX System.Single
Initial X value.
valueY System.Single
Initial Y value.
valueZ System.Single
Initial Z value.


Vector3.Empty Property (Microsoft.DirectX)

Vector3.Empty Property

Retrieves an empty 3-D vector.

Definition

Visual Basic | Public Shared ReadOnly Property Empty As Vector3
C# | public static Vector3 Empty { get; }
C++ public:
static property Vector3 Empty {
Vector3 get();
}
JScript | public static function get Empty() : Vector3

Property Value

Microsoft.DirectX.Vector3
Empty Vector3 structure.

This property is read-only.


Vector3.X Field (Microsoft.DirectX)

Vector3.X Field

Retrieves or sets the x component of a 3-D vector.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
A Single Leave Site value that represents the x component of a 3-D vector.

This field is read/write.


Vector3.Y Field (Microsoft.DirectX)

Vector3.Y Field

Retrieves or sets the y component of a 3-D vector.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
A Single Leave Site value that represents the y component of a 3-D vector.

This field is read/write.


Vector3.Z Field (Microsoft.DirectX)

Vector3.Z Field

Retrieves or sets the z component of a 3-D vector.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
A Single Leave Site value that represents the z component of a 3-D vector.

This field is read/write.


Vector4 Structure (Microsoft.DirectX)

Vector4 Structure

Describes a vector in four-dimensional (4-D) space.

Definition

Visual Basic | Public Structure Vector4
C# | public struct Vector4
C++ | public value class Vector4 sealed
JScript | In JScript, you can use structures, but you cannot define your own.

Members Table

The following table lists the members exposed by the object. Click a tab on the left to choose the type of member you want to view.

Fields

Field | Description
W | Retrieves or sets the w component of a 4-D vector.
X | Retrieves or sets the x component of a 4-D vector.
Y | Retrieves or sets the y component of a 4-D vector.
Z | Retrieves or sets the z component of a 4-D vector.

Methods

Method | Description
Add | Adds two 4-D vectors.
static (Shared in Visual Basic) BaryCentric | Returns a point in barycentric coordinates, using the specified 4-D vectors.
static (Shared in Visual Basic) CatmullRom | Performs a Catmull-Rom interpolation using specified 4-D vectors.
static (Shared in Visual Basic) Cross | Determines the cross product in four dimensions.
static (Shared in Visual Basic) Dot | Determines the dot product of two 4-D vectors.
Equals | Returns a value that indicates whether the current instance is equal to a specified object.
GetHashCode | Returns the hash code for the current instance.
static (Shared in Visual Basic) Hermite | Performs a Hermite spline interpolation using the specified 4-D vectors.
Length | Returns the length of a 4-D vector.
LengthSq | Returns the square of the length of a 4-D vector.
static (Shared in Visual Basic) Lerp | Performs a linear interpolation between two 4-D vectors.
Maximize | Returns a 4-D vector that is made up of the largest components of two 4-D vectors.
Minimize | Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.
Multiply | Multiplies a 4-D vector by a Single Leave Site value.
Normalize | Returns the normalized version of a 4-D vector.
static (Shared in Visual Basic) op_Addition | Adds two vectors.
static (Shared in Visual Basic) op_Equality | Compares the current instance of a class to another instance to determine whether they are the same.
static (Shared in Visual Basic) op_Inequality | Compares the current instance of a class to another instance to determine whether they are different.
static (Shared in Visual Basic) op_Multiply | Determines the product of a Single Leave Site value and a 4-D vector.
static (Shared in Visual Basic) op_Subtraction | Subtracts two 4-D vectors.
static (Shared in Visual Basic) op_UnaryNegation | Negates the vector.
Scale | Scales a 4-D vector.
Subtract | Subtracts two 4-D vectors.
ToString | Obtains a string representation of the current instance.
Transform | Transforms a 4-D vector or an array of 4-D vectors by a given matrix.
Vector4 | Initializes a new instance of the Vector4 class.

Properties

Property | Description
static (Shared in Visual Basic) Empty | Returns an empty 4-D vector.

Structure Information

Namespace | Microsoft.DirectX
Assembly | Microsoft.DirectX (microsoft.directx.dll)
Strong Name | Microsoft.DirectX, Version=1.0.900.0, Culture=neutral, PublicKeyToken=d3231b57b74a1492

See Also

  • Microsoft.DirectX.UnsafeNativeMethods.Vector4 Class


Vector4.Add Method ()

Adds two 4-D vectors.

Overload List

public void Add(Vector4);
public static Vector4 Add(Vector4, Vector4);


Vector4.Add(Vector4) Method (Microsoft.DirectX)

Vector4.Add Method

Adds two 4-D vectors.

Definition

Visual Basic Public Sub Add( _
ByVal source As Vector4 _
)
C# public void Add(
Vector4 source
);
C++ public:
void Add(
Vector4 source
);
JScript public function Add(
source : Vector4
);

Parameters

source Microsoft.DirectX.Vector4


Vector4.Add(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.Add Method

Adds two 4-D vectors.

Definition

Visual Basic Public Shared Function Add( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 Add(
Vector4 left,
Vector4 right
);
C++ public:
static Vector4 Add(
Vector4 left,
Vector4 right
);
JScript public static function Add(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left Microsoft.DirectX.Vector4
Source Vector4.
right Microsoft.DirectX.Vector4
Source Vector4.

Return Value

Microsoft.DirectX.Vector4
Sum of the two Vector4 structures.


Vector4.BaryCentric(Vector4,Vector4,Vector4,Single,Single) Method (Microsoft.DirectX)

Vector4.BaryCentric Method

Returns a point in barycentric coordinates, using the specified 4-D vectors.

Definition

Visual Basic Public Shared Function BaryCentric( _
ByVal v1 As Vector4, _
ByVal v2 As Vector4, _
ByVal v3 As Vector4, _
ByVal f As Single, _
ByVal g As Single _
) As Vector4
C# public static Vector4 BaryCentric(
Vector4 v1,
Vector4 v2,
Vector4 v3,
float f,
float g
);
C++ public:
static Vector4 BaryCentric(
Vector4 v1,
Vector4 v2,
Vector4 v3,
float f,
float g
);
JScript public static function BaryCentric(
v1 : Vector4,
v2 : Vector4,
v3 : Vector4,
f : float,
g : float
) : Vector4;

Parameters

v1 Microsoft.DirectX.Vector4
Source Vector4 structure.
v2 Microsoft.DirectX.Vector4
Source Vector4 structure.
v3 Microsoft.DirectX.Vector4
Source Vector4 structure.
f System.Single
Weighting factor. See Remarks.
g System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure in barycentric coordinates.

Remarks

The Vector4.BaryCentric method provides a way to understand points in and around a triangle, regardless of where the triangle is actually located. This method returns the resulting point by using the following equation.

v1 + f(v2 - v1) + g(v3 - v1)

Any point in the plane v1v2v3 can be represented by the barycentric coordinates (f, g). The f parameter controls the extent to which v2 gets weighted into the result, and the f parameter controls the extent to which v3 gets weighted into the result. Lastly, (1 - f - g) controls the extent to which v1 gets weighted into the result.

Note the following relations.

  • If (f >= 0 && g >=0 && 1 - f - g >= 0), the point is inside the triangle v1v2v3.
  • If (f == 0 && g >= 0 && 1 - f - g >= 0), the point is on the line v1v3.
  • If (f >= 0 && g == 0 && 1 - f - g >= 0), the point is on the line v1v2.
  • If (f >= 0 && g >= 0 && 1 - f - g == 0), the point is on the line v2v3.

Barycentric coordinates are a form of general coordinates. In this context, using them represents a change in coordinate systems. What holds true for Cartesian coordinates holds true for barycentric coordinates.


Vector4.CatmullRom(Vector4,Vector4,Vector4,Vector4,Single) Method (Microsoft.DirectX)

Vector4.CatmullRom Method

Performs a Catmull-Rom interpolation using specified 4-D vectors.

Definition

Visual Basic Public Shared Function CatmullRom( _
ByVal position1 As Vector4, _
ByVal position2 As Vector4, _
ByVal position3 As Vector4, _
ByVal position4 As Vector4, _
ByVal weightingFactor As Single _
) As Vector4
C# public static Vector4 CatmullRom(
Vector4 position1,
Vector4 position2,
Vector4 position3,
Vector4 position4,
float weightingFactor
);
C++ public:
static Vector4 CatmullRom(
Vector4 position1,
Vector4 position2,
Vector4 position3,
Vector4 position4,
float weightingFactor
);
JScript public static function CatmullRom(
position1 : Vector4,
position2 : Vector4,
position3 : Vector4,
position4 : Vector4,
weightingFactor : float
) : Vector4;

Parameters

position1 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
position2 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
position3 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
position4 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the Catmull-Rom interpolation.

Remarks

To derive the Catmull-Rom spline from the Hermite spline, use the following settings. In this example, v1 is the contents of position1, v2 is the contents of position2, p3 is the contents of position3, p4 is the contents of position4, and s is the contents of weightingFactor.

v1 = p2
v2 = p3
t1 = (p3 - p1) / 2
t2 = (p4 - p2) / 2

Using the following Hermite spline equation:

Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2
and substituting for v1, v2, t1, t2 yields the following result.
Q(s) = (2s3 - 3s2 + 1)p2 + (-2s3 + 3s2)p3 + (s3 - 2s2 + s)(p3 - p1) / 2 + (s3 - s2)(p4 - p2)/2
 This result can be rearranged as follows:
Q(s) = [(-s3 + 2s2 - s)p1 + (3s3 - 5s2 + 2)p2 + (-3s3 + 4s2 + s)p3 + (s3 - s2)p4] / 2

See Also

  • Vector2.CatmullRom
  • Vector4.CatmullRom


Vector4.Cross(Vector4,Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.Cross Method

Determines the cross product in four dimensions.

Definition

Visual Basic Public Shared Function Cross( _
ByVal v1 As Vector4, _
ByVal v2 As Vector4, _
ByVal v3 As Vector4 _
) As Vector4
C# public static Vector4 Cross(
Vector4 v1,
Vector4 v2,
Vector4 v3
);
C++ public:
static Vector4 Cross(
Vector4 v1,
Vector4 v2,
Vector4 v3
);
JScript public static function Cross(
v1 : Vector4,
v2 : Vector4,
v3 : Vector4
) : Vector4;

Parameters

v1 Microsoft.DirectX.Vector4
Source Vector4 structure.
v2 Microsoft.DirectX.Vector4
Source Vector4 structure.
v3 Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the cross product.

See Also

  • Dot


Vector4.Dot(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.Dot Method

Determines the dot product of two 4-D vectors.

Definition

Visual Basic Public Shared Function Dot( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Single
C# public static float Dot(
Vector4 left,
Vector4 right
);
C++ public:
static float Dot(
Vector4 left,
Vector4 right
);
JScript public static function Dot(
left : Vector4,
right : Vector4
) : float;

Parameters

left Microsoft.DirectX.Vector4
Source Vector4 structure.
right Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

System.Single
A Single Leave Site value that represents the dot product.

See Also

  • Cross


Vector4.Equals(Object) Method (Microsoft.DirectX)

Vector4.Equals Method

Returns a value that indicates whether the current instance is equal to a specified object.

Definition

Visual Basic Overrides Public Function Equals( _
ByVal compare As Object _
) As Boolean
C# public override bool Equals(
object compare
);
C++ public:
virtual bool Equals(
Object^ compare
) override;
JScript public override function Equals(
compare : Object
) : boolean;

Parameters

compare System.Object
Object with which to make the comparison.

Return Value

System.Boolean
Value that is true if the current instance is equal to the specified object, or false if it is not.


Vector4.GetHashCode() Method (Microsoft.DirectX)

Vector4.GetHashCode Method

Returns the hash code for the current instance.

Definition

Visual Basic | Overrides Public Function GetHashCode() As Integer
C# | public override int GetHashCode();
C++ public:
virtual int GetHashCode() override;
JScript | public override function GetHashCode() : int;

Return Value

System.Int32
Hash code for the instance.


Vector4.Hermite(Vector4,Vector4,Vector4,Vector4,Single) Method (Microsoft.DirectX)

Vector4.Hermite Method

Performs a Hermite spline interpolation using the specified 4-D vectors.

Definition

Visual Basic Public Shared Function Hermite( _
ByVal position As Vector4, _
ByVal tangent As Vector4, _
ByVal position2 As Vector4, _
ByVal tangent2 As Vector4, _
ByVal weightingFactor As Single _
) As Vector4
C# public static Vector4 Hermite(
Vector4 position,
Vector4 tangent,
Vector4 position2,
Vector4 tangent2,
float weightingFactor
);
C++ public:
static Vector4 Hermite(
Vector4 position,
Vector4 tangent,
Vector4 position2,
Vector4 tangent2,
float weightingFactor
);
JScript public static function Hermite(
position : Vector4,
tangent : Vector4,
position2 : Vector4,
tangent2 : Vector4,
weightingFactor : float
) : Vector4;

Parameters

position Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
tangent Microsoft.DirectX.Vector4
Source Vector4 structure that is a tangent vector.
position2 Microsoft.DirectX.Vector4
Source Vector4 structure that is a position vector.
tangent2 Microsoft.DirectX.Vector4
Source Vector4 structure that is a tangent vector.
weightingFactor System.Single
Weighting factor. See Remarks.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the Hermite spline interpolation.

Remarks

The Hermite method interpolates from (position, tangent) to (position2, tangent2) using Hermite spline interpolation.

The spline interpolation is a generalization of the ease-in, ease-out spline. The ramp is a function of Q(s) with the following properties.

Q(s) = As3 + Bs2 + Cs + D (and therefore, Q'(s) = 3As2 + 2Bs + C)

a) Q(0) = v1, so Q'(0) = t1

b) Q(1) = v2, so Q'(1) = t2

In these properties, v1 is the contents of position, v2 is the contents of position2, t1 is the contents of tangent, t2 is the contents of tangent2, and s is the contents of weightingFactor.

These properties are used to solve for A, B, C, D in the following example.

D = v1  (from a)
C = t1  (from a)
3A + 2B = t2 - t-1 (substituting for C)
A + B = v2 - v1 - t1 (substituting for C and D)

To generate Q(s), pass in the solutions for A, B, C, and D as follows.

A = 2v1 - 2v2 + t2 + t1
B = 3v2 - 3v1 - 2t1 - t2
C = t1
D = v1

These properties yield the following:

Q(s) = (2v1 - 2v2 + t2 + t1)s3 + (3v2 - 3v1 - 2t1 - t2)s2 + t1s + v1.
Which can be rearranged as:
Q(s) = (2s3 - 3s2 + 1)v1 + (-2s3 + 3s2)v2 + (s3 - 2s2 + s)t1 + (s3 - s2)t2.

Hermite splines are useful for controlling animation because the curve runs through all of the control points. Also, because the position and tangent are explicitly specified at the ends of each segment, it is easy to create a continuous curve, provided that the starting position and tangent match the ending values of the last segment.


Vector4.Length Method ()

Returns the length of a 4-D vector.

Overload List

public float Length();
public static float Length(Vector4);

See Also

  • LengthSq


Vector4.Length() Method (Microsoft.DirectX)

Vector4.Length Method

Returns the length of a 4-D vector.

Definition

Visual Basic | Public Function Length() As Single
C# | public float Length();
C++ public:
float Length();
JScript | public function Length() : float;

Return Value

System.Single
A Single Leave Site value that indicates the vector's length.

See Also

  • LengthSq


Vector4.Length(Vector4) Method (Microsoft.DirectX)

Vector4.Length Method

Returns the length of a 4-D vector.

Definition

Visual Basic Public Shared Function Length( _
ByVal source As Vector4 _
) As Single
C# public static float Length(
Vector4 source
);
C++ public:
static float Length(
Vector4 source
);
JScript public static function Length(
source : Vector4
) : float;

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

System.Single
A Single Leave Site value that indicates the vector's length.

See Also

  • LengthSq


Vector4.LengthSq Method ()

Returns the square of the length of a 4-D vector.

Overload List

public float LengthSq();
public static float LengthSq(Vector4);

See Also

  • Length


Vector4.LengthSq() Method (Microsoft.DirectX)

Vector4.LengthSq Method

Returns the square of the length of a 4-D vector.

Definition

Visual Basic | Public Function LengthSq() As Single
C# | public float LengthSq();
C++ public:
float LengthSq();
JScript | public function LengthSq() : float;

Return Value

System.Single
A Single Leave Site value that indicates the vector's squared length.

See Also

  • Length


Vector4.LengthSq(Vector4) Method (Microsoft.DirectX)

Vector4.LengthSq Method

Returns the square of the length of a 4-D vector.

Definition

Visual Basic Public Shared Function LengthSq( _
ByVal source As Vector4 _
) As Single
C# public static float LengthSq(
Vector4 source
);
C++ public:
static float LengthSq(
Vector4 source
);
JScript public static function LengthSq(
source : Vector4
) : float;

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

System.Single
A Single Leave Site value that indicates the vector's squared length.

See Also

  • Length


Vector4.Lerp(Vector4,Vector4,Single) Method (Microsoft.DirectX)

Vector4.Lerp Method

Performs a linear interpolation between two 4-D vectors.

Definition

Visual Basic Public Shared Function Lerp( _
ByVal left As Vector4, _
ByVal right As Vector4, _
ByVal interpolater As Single _
) As Vector4
C# public static Vector4 Lerp(
Vector4 left,
Vector4 right,
float interpolater
);
C++ public:
static Vector4 Lerp(
Vector4 left,
Vector4 right,
float interpolater
);
JScript public static function Lerp(
left : Vector4,
right : Vector4,
interpolater : float
) : Vector4;

Parameters

left Microsoft.DirectX.Vector4
Source Vector4 structure.
right Microsoft.DirectX.Vector4
Source Vector4 structure.
interpolater System.Single
Parameter that linearly interpolates between the vectors.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the linear interpolation.

Remarks

This method performs the linear interpolation based on the following formula.

left + interpolater(right - left).


Vector4.Maximize Method ()

Returns a 4-D vector that is made up of the largest components of two 4-D vectors.

Overload List

public void Maximize(Vector4);
public static Vector4 Maximize(Vector4, Vector4);

See Also

  • Minimize


Vector4.Maximize(Vector4) Method (Microsoft.DirectX)

Vector4.Maximize Method

Returns a 4-D vector that is made up of the largest components of two 4-D vectors.

Definition

Visual Basic Public Sub Maximize( _
ByVal source As Vector4 _
)
C# public void Maximize(
Vector4 source
);
C++ public:
void Maximize(
Vector4 source
);
JScript public function Maximize(
source : Vector4
);

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure.

See Also

  • Minimize


Vector4.Maximize(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.Maximize Method

Returns a 4-D vector that is made up of the largest components of two 4-D vectors.

Definition

Visual Basic Public Shared Function Maximize( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 Maximize(
Vector4 left,
Vector4 right
);
C++ public:
static Vector4 Maximize(
Vector4 left,
Vector4 right
);
JScript public static function Maximize(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left Microsoft.DirectX.Vector4
Source Vector4 structure.
right Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is made up of the largest components of the two vectors.

See Also

  • Minimize


Vector4.Minimize Method ()

Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.

Overload List

public void Minimize(Vector4);
public static Vector4 Minimize(Vector4, Vector4);

See Also

  • Maximize


Vector4.Minimize(Vector4) Method (Microsoft.DirectX)

Vector4.Minimize Method

Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.

Definition

Visual Basic Public Sub Minimize( _
ByVal source As Vector4 _
)
C# public void Minimize(
Vector4 source
);
C++ public:
void Minimize(
Vector4 source
);
JScript public function Minimize(
source : Vector4
);

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure.

See Also

  • Maximize


Vector4.Minimize(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.Minimize Method

Returns a 4-D vector that is made up of the smallest components of two 4-D vectors.

Definition

Visual Basic Public Shared Function Minimize( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 Minimize(
Vector4 left,
Vector4 right
);
C++ public:
static Vector4 Minimize(
Vector4 left,
Vector4 right
);
JScript public static function Minimize(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left Microsoft.DirectX.Vector4
Source Vector4 structure.
right Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is made up of the smallest components of the two vectors.

See Also

  • Maximize


Vector4.Multiply Method ()

Multiplies a 4-D vector by a Single Leave Site value.

Overload List

public void Multiply(float);
public static Vector4 Multiply(Vector4, float);


Vector4.Multiply(Vector4,Single) Method (Microsoft.DirectX)

Vector4.Multiply Method

Multiplies a 4-D vector by a Single Leave Site value.

Definition

Visual Basic Public Shared Function Multiply( _
ByVal source As Vector4, _
ByVal f As Single _
) As Vector4
C# public static Vector4 Multiply(
Vector4 source,
float f
);
C++ public:
static Vector4 Multiply(
Vector4 source,
float f
);
JScript public static function Multiply(
source : Vector4,
f : float
) : Vector4;

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure.
f System.Single
Source Single Leave Site value used as a multiplier.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is multiplied by the Single Leave Site value.


Vector4.Multiply(Single) Method (Microsoft.DirectX)

Vector4.Multiply Method

Multiplies a 4-D vector by a Single Leave Site value.

Definition

Visual Basic Public Sub Multiply( _
ByVal s As Single _
)
C# public void Multiply(
float s
);
C++ public:
void Multiply(
float s
);
JScript public function Multiply(
s : float
);

Parameters

s System.Single
Source Single Leave Site value used as a multiplier.


Vector4.Normalize Method ()

Returns the normalized version of a 4-D vector.

Overload List

public void Normalize();
public static Vector4 Normalize(Vector4);


Vector4.Normalize() Method (Microsoft.DirectX)

Vector4.Normalize Method

Returns the normalized version of a 4-D vector.

Definition

Visual Basic | Public Sub Normalize()
C# | public void Normalize();
C++ public:
void Normalize();
JScript | public function Normalize();


Vector4.Normalize(Vector4) Method (Microsoft.DirectX)

Vector4.Normalize Method

Returns the normalized version of a 4-D vector.

Definition

Visual Basic Public Shared Function Normalize( _
ByVal source As Vector4 _
) As Vector4
C# public static Vector4 Normalize(
Vector4 source
);
C++ public:
static Vector4 Normalize(
Vector4 source
);
JScript public static function Normalize(
source : Vector4
) : Vector4;

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the normalized version of the specified vector.


Vector4.op_Addition(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.op_Addition Method

Adds two vectors.

Definition

Visual Basic Public Shared Function op_Addition( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 op_Addition(
Vector4 left,
Vector4 right
);
C++ public:
static Vector4 operator+(
Vector4 left,
Vector4 right
);
JScript public static function op_Addition(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left Microsoft.DirectX.Vector4
Source Vector4 structure.
right Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that contains the sum of the parameters.


Vector4.op_Equality(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.op_Equality Method

Compares the current instance of a class to another instance to determine whether they are the same.

Definition

Visual Basic Public Shared Function op_Equality( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Boolean
C# public static bool op_Equality(
Vector4 left,
Vector4 right
);
C++ public:
static bool operator==(
Vector4 left,
Vector4 right
);
JScript public static function op_Equality(
left : Vector4,
right : Vector4
) : boolean;

Parameters

left Microsoft.DirectX.Vector4
The Vector4 structure to the left of the equality operator.
right Microsoft.DirectX.Vector4
The Vector4 structure to the right of the equality operator.

Return Value

System.Boolean
Value that is true if the objects are the same, or false if they are different.


Vector4.op_Inequality(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.op_Inequality Method

Compares the current instance of a class to another instance to determine whether they are different.

Definition

Visual Basic Public Shared Function op_Inequality( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Boolean
C# public static bool op_Inequality(
Vector4 left,
Vector4 right
);
C++ public:
static bool operator!=(
Vector4 left,
Vector4 right
);
JScript public static function op_Inequality(
left : Vector4,
right : Vector4
) : boolean;

Parameters

left Microsoft.DirectX.Vector4
The Vector4 structure to the left of the inequality operator.
right Microsoft.DirectX.Vector4
The Vector4 structure to the right of the inequality operator.

Return Value

System.Boolean
Value that is true if the objects are different, or false if they are the same.


Vector4.op_Multiply Method ()

Determines the product of a Single Leave Site value and a 4-D vector.

Overload List

public static Vector4 op_Multiply(float, Vector4);
public static Vector4 op_Multiply(Vector4, float);


Vector4.op_Multiply(Single,Vector4) Method (Microsoft.DirectX)

Vector4.op_Multiply Method

Determines the product of a Single Leave Site value and a 4-D vector.

Definition

Visual Basic Public Shared Function op_Multiply( _
ByVal right As Single, _
ByVal left As Vector4 _
) As Vector4
C# public static Vector4 op_Multiply(
float right,
Vector4 left
);
C++ public:
static Vector4 operator*(
float right,
Vector4 left
);
JScript public static function op_Multiply(
right : float,
left : Vector4
) : Vector4;

Parameters

right System.Single
Source Single Leave Site structure.
left Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the product of the right and left parameters.


Vector4.op_Multiply(Vector4,Single) Method (Microsoft.DirectX)

Vector4.op_Multiply Method

Determines the product of a Single Leave Site value and a 4-D vector.

Definition

Visual Basic Public Shared Function op_Multiply( _
ByVal left As Vector4, _
ByVal right As Single _
) As Vector4
C# public static Vector4 op_Multiply(
Vector4 left,
float right
);
C++ public:
static Vector4 operator*(
Vector4 left,
float right
);
JScript public static function op_Multiply(
left : Vector4,
right : float
) : Vector4;

Parameters

left Microsoft.DirectX.Vector4
Source Vector4 structure.
right System.Single
Source Single Leave Site structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the product of the right and left parameters.


Vector4.op_Subtraction(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.op_Subtraction Method

Subtracts two 4-D vectors.

Definition

Visual Basic Public Shared Function op_Subtraction( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 op_Subtraction(
Vector4 left,
Vector4 right
);
C++ public:
static Vector4 operator-(
Vector4 left,
Vector4 right
);
JScript public static function op_Subtraction(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left Microsoft.DirectX.Vector4
The Vector4 structure to the left of the subtraction operator.
right Microsoft.DirectX.Vector4
The Vector4 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector4
Resulting Vector4 structure.


Vector4.op_UnaryNegation(Vector4) Method (Microsoft.DirectX)

Vector4.op_UnaryNegation Method

Negates the vector.

Definition

Visual Basic Public Shared Function op_UnaryNegation( _
ByVal vec As Vector4 _
) As Vector4
C# public static Vector4 op_UnaryNegation(
Vector4 vec
);
C++ public:
static Vector4 operator-(
Vector4 vec
);
JScript public static function op_UnaryNegation(
vec : Vector4
) : Vector4;

Parameters

vec Microsoft.DirectX.Vector4
Source Vector4 structure.

Return Value

Microsoft.DirectX.Vector4
The Vector4 structure that is the result of the operation.

Remarks

This method switches positive and negative values of the Vector4 structure's X, Y, and Z fields.


Vector4.Scale Method ()

Scales a 4-D vector.

Overload List

public void Scale(float);
public static Vector4 Scale(Vector4, float);


Vector4.Scale(Single) Method (Microsoft.DirectX)

Vector4.Scale Method

Scales a 4-D vector.

Definition

Visual Basic Public Sub Scale( _
ByVal scalingFactor As Single _
)
C# public void Scale(
float scalingFactor
);
C++ public:
void Scale(
float scalingFactor
);
JScript public function Scale(
scalingFactor : float
);

Parameters

scalingFactor System.Single
Scaling value.


Vector4.Scale(Vector4,Single) Method (Microsoft.DirectX)

Vector4.Scale Method

Scales a 4-D vector.

Definition

Visual Basic Public Shared Function Scale( _
ByVal source As Vector4, _
ByVal scalingFactor As Single _
) As Vector4
C# public static Vector4 Scale(
Vector4 source,
float scalingFactor
);
C++ public:
static Vector4 Scale(
Vector4 source,
float scalingFactor
);
JScript public static function Scale(
source : Vector4,
scalingFactor : float
) : Vector4;

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure.
scalingFactor System.Single
Scaling value.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the scaled vector.


Vector4.Subtract Method ()

Subtracts two 4-D vectors.

Overload List

public void Subtract(Vector4);
public static Vector4 Subtract(Vector4, Vector4);


Vector4.Subtract(Vector4) Method (Microsoft.DirectX)

Vector4.Subtract Method

Subtracts two 4-D vectors.

Definition

Visual Basic Public Sub Subtract( _
ByVal source As Vector4 _
)
C# public void Subtract(
Vector4 source
);
C++ public:
void Subtract(
Vector4 source
);
JScript public function Subtract(
source : Vector4
);

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure to subtract from the current instance.


Vector4.Subtract(Vector4,Vector4) Method (Microsoft.DirectX)

Vector4.Subtract Method

Subtracts two 4-D vectors.

Definition

Visual Basic Public Shared Function Subtract( _
ByVal left As Vector4, _
ByVal right As Vector4 _
) As Vector4
C# public static Vector4 Subtract(
Vector4 left,
Vector4 right
);
C++ public:
static Vector4 Subtract(
Vector4 left,
Vector4 right
);
JScript public static function Subtract(
left : Vector4,
right : Vector4
) : Vector4;

Parameters

left Microsoft.DirectX.Vector4
Source Vector4 structure to the left of the subtraction operator.
right Microsoft.DirectX.Vector4
Source Vector4 structure to the right of the subtraction operator.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the operation.


Vector4.ToString() Method (Microsoft.DirectX)

Vector4.ToString Method

Obtains a string representation of the current instance.

Definition

Visual Basic | Overrides Public Function ToString() As String
C# | public override string ToString();
C++ public:
virtual String^ ToString() override;
JScript | public override function ToString() : String;

Return Value

System.String
String that represents the object.


Vector4.Transform Method ()

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Overload List

public void Transform(Matrix);
public static Vector4 Transform(Vector4, Matrix);
public static Vector4[] Transform(Vector4[], Matrix);


Vector4.Transform(Matrix) Method (Microsoft.DirectX)

Vector4.Transform Method

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Definition

Visual Basic Public Sub Transform( _
ByVal sourceMatrix As Matrix _
)
C# public void Transform(
Matrix sourceMatrix
);
C++ public:
void Transform(
Matrix sourceMatrix
);
JScript public function Transform(
sourceMatrix : Matrix
);

Parameters

sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.


Vector4.Transform(Vector4[],Matrix) Method (Microsoft.DirectX)

Vector4.Transform Method

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Definition

Visual Basic Public Shared Function Transform( _
ByVal vector() As Vector4, _
ByVal sourceMatrix As Matrix _
) As Vector4()
C# public static Vector4[] Transform(
Vector4[] vector,
Matrix sourceMatrix
);
C++ public:
static array<Vector4>^ Transform(
array<Vector4>^ vector,
Matrix sourceMatrix
);
JScript public static function Transform(
vector : Vector4[],
sourceMatrix : Matrix
) : Vector4[];

Parameters

vector Microsoft.DirectX.Vector4[]
Array of source Vector4 structures.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4[]
Array of Vector4 structures that are the result of the method.


Vector4.Transform(Vector4,Matrix) Method (Microsoft.DirectX)

Vector4.Transform Method

Transforms a 4-D vector or an array of 4-D vectors by a given matrix.

Definition

Visual Basic Public Shared Function Transform( _
ByVal source As Vector4, _
ByVal sourceMatrix As Matrix _
) As Vector4
C# public static Vector4 Transform(
Vector4 source,
Matrix sourceMatrix
);
C++ public:
static Vector4 Transform(
Vector4 source,
Matrix sourceMatrix
);
JScript public static function Transform(
source : Vector4,
sourceMatrix : Matrix
) : Vector4;

Parameters

source Microsoft.DirectX.Vector4
Source Vector4 structure.
sourceMatrix Microsoft.DirectX.Matrix
Source Matrix structure.

Return Value

Microsoft.DirectX.Vector4
A Vector4 structure that is the result of the method.


Vector4.Vector4 Constructor ()

Initializes a new instance of the Vector4 class.

Overload List

public Vector4();
public Vector4(float, float, float, float);


Vector4.Vector4() Constructor (Microsoft.DirectX)

Vector4.Vector4 Constructor

Initializes a new instance of the Vector4 class.

Definition

Visual Basic | Public Sub New()
C# | public Vector4();
C++ public:
Vector4();
JScript | public function Vector4();


Vector4.Vector4(Single,Single,Single,Single) Constructor (Microsoft.DirectX)

Vector4.Vector4 Constructor

Initializes a new instance of the Vector4 class.

Definition

Visual Basic Public Sub New( _
ByVal valueX As Single, _
ByVal valueY As Single, _
ByVal valueZ As Single, _
ByVal valueW As Single _
)
C# public Vector4(
float valueX,
float valueY,
float valueZ,
float valueW
);
C++ public:
Vector4(
float valueX,
float valueY,
float valueZ,
float valueW
);
JScript public function Vector4(
valueX : float,
valueY : float,
valueZ : float,
valueW : float
);

Parameters

valueX System.Single
Initial X value.
valueY System.Single
Initial Y value.
valueZ System.Single
Initial Z value.
valueW System.Single
Initial W value.


Vector4.Empty Property (Microsoft.DirectX)

Vector4.Empty Property

Returns an empty 4-D vector.

Definition

Visual Basic | Public Shared ReadOnly Property Empty As Vector4
C# | public static Vector4 Empty { get; }
C++ public:
static property Vector4 Empty {
Vector4 get();
}
JScript | public static function get Empty() : Vector4

Property Value

Microsoft.DirectX.Vector4
Empty Vector4.

This property is read-only.


Vector4.W Field (Microsoft.DirectX)

Vector4.W Field

Retrieves or sets the w component of a 4-D vector.

Definition

Visual Basic | Public W As Single
C# | public Single W;
C++ | public: Single W;
JScript | public var W : Single

Field Value

System.Single
A Single Leave Site value that represents the w component of the 4-D vector.

This field is read/write.


Vector4.X Field (Microsoft.DirectX)

Vector4.X Field

Retrieves or sets the x component of a 4-D vector.

Definition

Visual Basic | Public X As Single
C# | public Single X;
C++ | public: Single X;
JScript | public var X : Single

Field Value

System.Single
A Single Leave Site value that represents the x component of the 4-D vector.

This field is read/write.


Vector4.Y Field (Microsoft.DirectX)

Vector4.Y Field

Retrieves or sets the y component of a 4-D vector.

Definition

Visual Basic | Public Y As Single
C# | public Single Y;
C++ | public: Single Y;
JScript | public var Y : Single

Field Value

System.Single
A Single Leave Site value that represents the y component of the 4-D vector.

This field is read/write.


Vector4.Z Field (Microsoft.DirectX)

Vector4.Z Field

Retrieves or sets the z component of a 4-D vector.

Definition

Visual Basic | Public Z As Single
C# | public Single Z;
C++ | public: Single Z;
JScript | public var Z : Single

Field Value

System.Single
A Single Leave Site value that represents the z component of the 4-D vector.

This field is read/write.


Projection Transformation

The projection transformation can be thought of as controlling the camera's internals; it is analogous to choosing a lens for the camera. This is the most complicated of the three transformation types. This discussion of the projection transformation is organized into the following topics.

  • What Is the Projection Transformation?
  • Setting Up a Projection Matrix
  • A W-Friendly Projection Matrix


Setting Up a Projection Matrix

The following ProjectionMatrix sample function sets the front and back clipping planes, as well as the horizontal and vertical field-of-view angles. This C# code parallels the approach discussed in What Is the Projection Transformation?. The fields of view should be less than pi radians.

          [C#]

private Matrix ProjectionMatrix(float near_plane, float far_plane,
                                float fov_horiz, float fov_vert)
{
   float h,w,Q;

   w =  1/(float)Math.Tan(fov_horiz*0.5); // 1/tan(x) == cot(x)
   h =  1/(float)Math.Tan(fov_vert*0.5); // 1/tan(x) == cot(x)
   Q = far_plane/(far_plane - near_plane);

   Matrix ret = new Matrix();

   ret.M11 = w;
   ret.M22 = h;
   ret.M33 = Q;
   ret.M43 = -Q*near_plane;
   ret.M34 = 1;

   return ret;

}

After creating the matrix, set it with SetTransform, specifying TransformType.Projection, or pass the matrix to the Device.Transform.Projection property.

Microsoft DirectX 9.0 for Managed Code provides the following functions to help you set up a projection matrix.

  • Matrix.PerspectiveLH
  • Matrix.PerspectiveRH
  • Matrix.PerspectiveFovLH
  • Matrix.PerspectiveFovRH
  • Matrix.PerspectiveOffCenterLH
  • Matrix.PerspectiveOffCenterRH


A W-Friendly Projection Matrix

Microsoft Direct3D can use the w-component of a vertex that has been transformed by the world, view, and projection matrices to perform depth-based calculations in depth-buffer or fog effects. Computations such as these require that a projection matrix normalize w to be equivalent to world-space z. In short, if a projection matrix includes a (3,4) coefficient that is not 1, you must scale all of the coefficients by the inverse of the (3,4) coefficient to make a proper matrix. If you do not provide a compliant matrix, fog effects and depth buffering are not applied correctly. The projection matrix recommended in What Is the Projection Transformation? is compliant with w-based calculations.

The following illustration shows a noncompliant projection matrix, and the same matrix scaled so that eye-relative fog is enabled.

In the preceding matrices, all variables are assumed to be nonzero. For more information about eye-relative fog, see Eye-Relative vs. Z-Based Depth. For more information about w-based depth buffering, see Depth Buffers.

Note: Direct3D uses the currently set projection matrix in its w-based depth calculations. As a result, applications must set a compliant projection matrix to receive the desired w-based features, even if they do not use the Direct3D transformation pipeline.


What Is the Projection Transformation?

The projection matrix is typically a scale and perspective projection. The projection transformation converts the viewing frustum into a cuboid shape. The near end of the viewing frustum is smaller than the far end, which has the effect of expanding objects that are near to the camera. This is how perspective is applied to the scene.

In the viewing frustum, the distance between the camera and the origin of the viewing transformation space is defined arbitrarily as D, so the projection matrix looks like the following illustration.

Projection matrix 1

The viewing matrix translates the camera to the origin by translating in the z-direction by -D. The translation matrix is as follows.

Projection matrix 2

Multiplying the translation matrix by the projection matrix (T*P) gives the composite projection matrix. It looks like the following illustration.

Projection matrix 3

The following illustration shows how the perspective transformation converts a viewing frustum to a new coordinate space. Notice that the frustum becomes cuboid and also that the origin moves from the upper-right corner of the scene to the center.

In the perspective transformation, the limits of the x- and y-directions are -1 and 1. The limits of the z-direction are 0 for the front plane and 1 for the back plane.

This matrix translates and scales objects based on a specified distance from the camera to the near clipping plane, but it does not consider the field of view (fov), and the z-values that it produces for objects in the distance can be nearly identical, making depth comparisons difficult. The following matrix addresses these issues, and it adjusts vertices to account for the aspect ratio of the viewport, making it a good choice for the perspective projection.

Projection matrix X1

In the following matrix, Zn is the z-value of the near clipping plane. The variables w, h, and Q have the following meanings. Note that fovw and fovk represent the viewport's horizontal and vertical fields of view, in radians.

Projection matrix X2

For your application, using field-of-view angles to define the x- and y-scaling coefficients might not be as convenient as using the viewport's horizontal and vertical dimensions (in camera space). As the math works out, the following two formulas for w and h use the viewport's dimensions, and are equivalent to the preceding formulas.

Projection matrix X3

In these formulas, Zn represents the position of the near clipping plane, and the Vw and Vh variables represent the width and height of the viewport, in camera space.

For a managed application, these two dimensions correspond directly to the Width and Height members of the Viewport structure.

Whatever formula you decide to use, be sure to set Z to as large a value as possible, because z-values extremely close to the camera do not vary by much. This makes depth comparisons using 16-bit z-buffers somewhat complicated.

As with the world and view transformations, you call the Device.SetTransform method to set the projection transformation.